EP6002-0002 - Zwei serielle Schnittstellen: RS232 oder RS422/RS485

BECKHOFF Feldbuskomponenten

Dokumentation zu

EP6002-0002

Zwei serielle Schnittstellen: RS232 oder RS422/RS485

Version: 1.3.0
Datum: 09.07.2015

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


EP6002 - Ausgabestände der Dokumentation

BECKHOFF EP6002-0002: Vorwort

Ausgabestände der Dokumentation

Version Änderungen
1.3.0
  • Power-Anschluss aktualisiert
1.2.0
  • Beschreibung der Auswahl des Schnittstellen-Typs mittels System-Manager korrigiert
  • Objektbeschreibung erweitert
  • Hinweise zum RS485-Betrieb erweitert
  • Kapitel EtherCAT-Anschluss aktualisiert
1.1.0
  • Beschreibung der M12-Buchsen korrigiert
  • Technische Daten aktualisiert
1.0.0
  • Erweiterter Umgebungstemperaturbereich
  • Beispielprogramme hinzugefügt
  • Besondere Bedingungen für ATEX hinzugefügt
  • Beschreibung des Power-Anschlusses aktualisiert
  • Übersicht der EtherCAT-Kabel erweitert
0.1
  • Erste vorläufige Version für EP6002-0002

Firm- und Hardware-Stände

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.

Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.

Dokumentation Version | EP6002-0002
 | Firmware | Hardware
1.2.0 | 03 | 05
1.1.0 | 03 | 05
1.0.0 | 01 | 03
0.1 | 01 | 01

Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.

Aufbau der Batch-Nummer (D-Nummer)

D: WW JJ FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 29 10 02 01:

29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


EtherCAT Box - Einführung

Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP 67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.

Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.

Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.

Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.

Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:

  • digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)

  • digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom

  • analoge Ein- und Ausgänge mit 16 Bit Auflösung

  • Thermoelement- und RTD-Eingänge

  • Schrittmotormodule

Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.

EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren | EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren

Hinweis 		Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.

Hinweis 		XML-Dateien
XML-Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP6002-0002 - Einführung

Zweikanaliges serielles Schnittstellenmodul: RS232 oder RS422/RS485

Das zweikanalige serielle Schnittstellenmodul EP6002-0002 ermöglicht den Anschluss von Geräten mit RS232- oder RS422/RS485-Schnittstelle. Das Modul überträgt die Daten volltransparent zum überlagerten Automatisierungsgerät, wobei der Datentransfer über den Feldbus mit einem einfachen Handshake-Protokoll abgewickelt wird. Dieses hat keinen Einfluss auf das Protokoll der seriellen Schnittstelle. Der aktive serielle Kommunikationskanal arbeitet unabhängig vom überlagerten Bussystem im Vollduplex-Betrieb mit bis zu 115.200 Baud, wobei 864 Byte Empfangs- und 128 Byte Sendepuffer zur Verfügung stehen.

In Verbindung mit TwinCATs Virtual-Serial-COM-Treiber (siehe TwinCAT Supplements – Communication) kann die EP6002 als normale Windows-COM-Schnittstelle genutzt werden.

Die Auswahl des Anschlusses ist abhängig vom Schnittstellen-Typ. Für jeden Kanal können Sie im TwinCAT System Manager den RS232-Anschluss oder den RS422/RS485-Anschluss auswählen.

Verwenden Sie für

  • RS422/RS485 die M12-Anschlüsse 1 und 3
  • RS232 die M12-Anschlüsse 2 und 4

Schnittstellen-Modi / Betriebsarten

über die CoE-Objekte lassen sich folgende Einstellungen für die Schnittstellen vornehmen:

  • RS232: Punkt-zu-Punkt-Verbindung zu einem RS232-Gerät
  • RS422: 4-Draht Punkt-zu-Punkt-Verbindung zu einem RS422-Gerät
  • RS485: 2-Draht-Verbindung in Bus-Struktur zu RS485-Gerät(en)
  • RS485: 2-Draht-Verbindung mit externer Brücke in Bus-Struktur zu RS485-Gerät(en), Mithören der gesendeten Daten
Quick Links

Installation

Schnittstellen-Modi

Konfiguration

Beispielprogramme

UL-Anforderungen

ATEX - Besondere Bedingungen


EP6002 - Technische Daten

Technische Daten | EP6002-0002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Übertragungskanäle | 2 (1/1), TxD und RxD, Vollduplex
Übertragungsraten | 300…115.200 Baud, 9.600 Baud (8 Bit, No Parity, 1 Stopp-Bit) voreingestellt
Signalanschluss | M12-Buchsen für RS232 oder RS422/485
Bitverzerrung | < 3 %
Leitungslänge | RS232: max. 15 m; RS422/RS485: ca. 1.000 m
Datenpuffer | 864-Byte-Empfangspuffer, 128-Byte-Sendepuffer
Prozessabbild pro Kanal | 22 x 8 Bit Input, 22 x 8 Bit Output, 16 Bit Control, 16 Bit Status
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 130 mA + Last, z.B. 130 mA + 2 x 20 mA = 170 mA
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Potenzialtrennung | 500 V
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) 0°C ... +55°C (gemäß cULus siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Gewicht | ca. 165 g
Einbaulage | beliebig
Zulassungen | CE, cULus, ATEX


EP6002-0002 - Prozessabbild

BECKHOFF EP6001-0002: Produktübersicht

EP6001-0002 - Prozessabbild

Der TwinCAT System-Manager zeigt die Daten der EP6001-0002 in einer Baumstruktur an.

Der Baum zeigt:
  • COM Inputs Channel 1: Eingangsdaten des 1. Kanals
  • COM Inputs Channel 2: Eingangsdaten des 2. Kanals
  • COM Outputs Channel 1: Ausgangsdaten des 1. Kanals
  • COM Outputs Channel 2: Ausgangsdaten des 2. Kanals
COM Inputs Channel 1
Der Baum zeigt:
  • Status: Status-Bits des 1. Kanals
  • Data In 0 bis Data In21: Eingangsdaten des 1. Kanals
COM Inputs Channel 2

Die Daten des 2. Kanals sind genauso aufgebaut, wie die des 1. Kanals.

COM Outputs Channel 1
Der Baum zeigt:
  • Status: Control-Bits des 1. Kanals
  • Data In 0 bis Data In21: Ausgangsdaten des 1. Kanals
COM Outputs Channel 2

Die Daten des 2. Kanals sind genauso aufgebaut, wie die des 1. Kanals.


EtherCAT Box - Abmessungen

BECKHOFF EtherCAT Box: Montage und Verkabelung

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | EtherCAT Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Zulassungen | CE
Gewicht | ca. 120 g - 200 g, je nach Modultyp


EPxxxx - Befestigung

BECKHOFF EtherCAT Box: Montage und Verkabelung

Befestigung

Hinweis 		Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung!

Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind!
Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.

Die Module werden mit zwei M3-Schrauben befestigt. Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher besitzen kein Gewinde. Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.

Montageschiene ZS5300-0001

Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module. Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3 Gewinden. Mittels M5 Schrauben (5,3 mm Langlöcher) kann die Schiene an der Maschine befestigt werden.

Die Schiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 Modulen. Sie kann applikationsspezifisch gekürzt werden.


EPxxxx - Anzugsmomente für Steckverbinder

BECKHOFF EtherCAT Box: Montage und Verkabelung

Anzugsmomente für Steckverbinder

M8-Steckverbinder

Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen.

M12-Steckverbinder

Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.

Drehmomentschlüssel

Hinweis 		Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (siehe Zubehör)!


EtherCAT-Anschluss

Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt

  • die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
  • die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8 | Koppler Box: M12

Belegung

Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm

1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003

2) Aderfarben nach EN 61918

3) Aderfarben

Hinweis 		Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)

Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx,
also die mit M8-Steckverbindern vorkonfektionierten Leitungen
auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau).

Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!

EtherCAT-Steckverbinder

Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.

Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12 | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8 | vierpolig, IP67, feldkonfektionierbar


Feldbus-LEDs

BECKHOFF EtherCAT Box: Montage und Verkabelung

EtherCAT- Feldbus-LEDs

LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational

Hinweis 		EtherCAT-Stati
Die verschiedenen Stati, die eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


EtherCAT-Leitung

BECKHOFF Feldbuskomponenten: Montage und Verkabelung

EtherCAT-Kabel

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.

Hinweis 		Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.Beckhoff.de zum Download zur Verfügung steht.

EtherCAT nutzt vier Adern der Kabel für die Signalübertragung. Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.

Es folgt eine Auswahl an Kabel für EtherCAT. Weitere Kabel in verschiedenen Längen finden Sie im Beckhoff Gesamtkatalog und unter www.beckhoff.de.

Meterware

Bezeichnung | Beschreibung
ZB9010 | CAT 5e, 4-adrig, für feste Verlegung, nicht für M8-Steckverbinder
ZB9020 | CAT 5e, 4-adrig, schleppkettentauglich, nicht für M8-Steckverbinder
ZB9030 | PVC, Ø4,9 mm für M8-Steckverbinder
ZB9031 | PUR, Ø4,8 mm für M8-Steckverbinder
ZB9032 | PUR, Ø5,4 mm für M8-Steckverbinder hochflexibel

Konfektionierte Kabel

ZK1090-3100-0xxx: M8-Stecker - offenes Ende, PUR, hochflexibel, vorkonfektioniert

ZK1090-3100- | 0020 | 0050
Länge | 2 m | 5 m

ZK1090-3100-3xxx: M8-Stecker - offenes Ende, PVC, vorkonfektioniert

ZK1090-3100- | 3020 | 3050
Länge | 2 m | 5 m

ZK1090-3131-0xxx: 2 x M8-Stecker, PUR, hochflexibel, fertig konfektioniert

ZK1090-3131- | 0001 | 0003 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0075 | 0100
Länge | 0,15 m | 0,3 m | 0,5 m | 1,0 m | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 7,5 m | 10 m
ZK1090-3131- | 0150 | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Länge | 15 m | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m

ZK1090-3131-3xxx: 2 x M8-Stecker, PVC, fertig konfektioniert

ZK1090-3131- | 3020 | 3030 | 3040 | 3050 | 3075 | 3100 | 3150 | 3200 | 3250 | 3300
Länge | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 7,5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3131- | 3350 | 3400 | 3450 | 3500
Länge | 35 m | 40 m | 45 m | 50 m

ZK1090-3132-0xxx: M8-Stecker - M8-Kupplung, PUR, hochflexibel, fertig konfektioniert

ZK1090-3132- | 0002 | 0004 | 0020 | 0050 | 0075 | 0100 | 0150 | 0200 | 0250 | 0300
Länge | 0,2 m | 0,4 m | 2,0 m | 5,0 m | 7,5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3132- | 0400 | 0500
Länge | 40 m | 50 m

ZK1090-3132-3xxx: M8-Stecker - M8-Kupplung, PVC, fertig konfektioniert

ZK1090-3132- | 0020 | 0050 | 0100 | 0150 | 0200 | 0250 | 0300 | 0400 | 0500
Länge | 2,0 m | 5,0 m | 10 m | 15 m | 20 m | 25 m | 30 m | 40 m | 50 m

ZK1090-3191-0xxx: M8-Stecker - RJ45-Stecker, PUR, hochflexibel, fertig konfektioniert

ZK1090-3191- | 0004 | 0005 | 0010 | 0020 | 0035 | 0050 | 0070 | 0100 | 0150 | 0200
Länge | 0,4 m | 0,5 m | 1 m | 2 m | 3,5 m | 5 m | 7 m | 10 m | 15 m | 20 m
ZK1090-3191- | 0250
Länge | 25 m

ZK1090-3191-3xxx: M8-Stecker - RJ45-Stecker, PVC, fertig konfektioniert

ZK1090-3191- | 3005 | 3020 | 3050
Länge | 0,5 m | 2 m | 5 m

ZK1090-3291-3xxx: M8-Kupplung - RJ45-Stecker, PVC, fertig konfektioniert

ZK1090-3291- | 0004 | 0005 | 0010 | 0020 | 0050 | 100 | 200 | 250
Länge | 0,4 m | 0,5 m | 1 m | 2 m | 5 m | 10 m | 20 m | 25 m

ZK1090-3161-0xxx: M8-Stecker - M12-Stecker (d-codiert), fertig konfektioniert

ZK1090-3161- | 0010 | 0020 | 0050
Länge | 1,0 m | 2,0 m | 5,0 m

ZK1090-6161-0xxx: 2 x M12-Stecker (d-codiert), fertig konfektioniert

ZK1090-6161- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Länge | 0,5 m | 1,0 m | 2,0 m | 2,5 m | 5,0 m | 10 m

ZK1090-6191-0xxx: M12-Stecker - RJ45-Stecker, fertig konfektioniert

ZK1090-6191- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Länge | 0,5 m | 1,0 m | 2,0 m | 2,5 m | 5,0 m | 10 m

ZK1090-6292-0xxx: M12-Buchse - RJ45-Stecker, fertig konfektioniert

ZK1090-6292- | 0005 | 0020 | 0050 | 0100
Länge | 0,5 m | 2 m | 5 m | 10 m

ZK1090-9191-0xxx: 2 x RJ45-Stecker, Patch-Kabel

ZK1090-9191- | 0001 | 0002 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0100 | 0150
Länge | 0,17 m | 0,26 m | 0,5 m | 1,0 m | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 10 m | 15 m
ZK1090-9191- | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Länge | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m


EP6002 - Signalanschluss - RS232

BECKHOFF EP6002-0002: Montage und Anschluss

Signalanschluss - RS232

Pin | Signal | Anschluss für
1 | 5 VDC | Hilfsspannung 5 VDC (20 mA, kurzschlussfest)
2 | TxD | Sendedaten
3 | GND | Masse
4 | RxD | Empfangsdaten
5 | SHLD | Schirm


EP6002 - Signalanschluss - RS422/RS485

BECKHOFF EP6002-0002: Montage und Anschluss

Signalanschluss - RS422/RS485

Pin | Signal | Anschluss für
1 | TxD- | Sendedaten
2 | TxD+ | Sendedaten
3 | RxD- | Empfangsdaten
4 | RxD+ | Empfangsdaten
5 | SHLD | Schirm

Hinweis 		RS485 - Halb-Duplex-Verbindung
Bei Halb-Duplex-Verbindung unter RS485 wird zur Datenübertragung nur ein Adernpaar benötigt.
Schließen Sie dieses Adernpaar an TxD-/TxD+ an.

Hinweis 		RS485-Busaufbau - Abschlusswiderstände verwenden
Im RS485-Betrieb kann ein linearer Bus mit mehr als zwei Teilnehmern aufgebaut werden.
Um Reflektionen bei der Datenübertragung zu verhindern ist es notwendig die Leitungsenden des Buskabels mit Widerständen (120 Ω) abzuschließen.


EP6002 - Status-LEDs

Status-LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1-4 | RX links | aus | Serieller Port an diesem M12-Anschluss nicht bereit um Daten zu empfangen
 |  | grün | Serieller Port an diesem M12-Anschluss bereit um Daten zu empfangen
 |  | orange | Serieller Port an diesem M12-Anschluss empfängt Daten
 | TX rechts | aus | Serieller Port an diesem M12-Anschluss nicht bereit um Daten zu senden
 |  | grün | Serieller Port an diesem M12-Anschluss bereit um Daten zu senden
 |  | orange | Serieller Port an diesem M12-Anschluss sendet Daten
Spannungsversorgung
LED | Anzeige | Bedeutung
Us | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
Up | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


EtherCAT Box - Power-Anschluss

BECKHOFF EtherCAT Box: Montage und Verkabelung

Power-Anschluss

Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:

  • IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
  • OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen

Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*

Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.

Zwei LEDs zeigen den Status der Versorgungsspannungen an.

Achtung 		Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!

Steuerspannung Us: 24VDC

Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.

Peripheriespannung Up: 24VDC

Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.

Weiterleitung der Versorgungsspannungen

Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.

Achtung 		Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!

Versorgung über PowerBox Module EP92x4-0023

Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).

Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.

Galvanische Trennung

Digitale Module

Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!

Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.

Analoge Module

Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.

Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0...10 V Eingängen eine beliebige Referenzspannung (0...30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).

Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.

Achtung 		Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann ist galvanische Trennung der Analogsignale u.U. nicht mehr gegeben!


EtherCAT Box - Status-LEDs für die Spannungsversorgung

BECKHOFF EtherCAT Box: Montage und Verkabelung

Status-LEDs für die Spannungsversorgung

LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Powerkabel

Bestelldaten

Bestellbezeichnung | Powerleitung | Schraub- Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m

Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).

Technische Daten

Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109 W
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mW
Schutzart nach IEC 60529 | IP65/66/67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste

Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkablung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.

Beispiel:
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.


EtherCAT Box - UL-Anforderungen

BECKHOFF EtherCAT Box: Montage und Verkabelung

UL-Anforderungen

Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.

Versorgungsspannung

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammt.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!

Netzwerke

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!

Umgebungstemperatur

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!

Kennzeichnung für UL

Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet:


EtherCAT Box - ATEX - Besondere Bedingungen

BECKHOFF EtherCAT Box: Montage und Verdrahtung

ATEX - Besondere Bedingungen

WARNUNG 		Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von
EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
  • Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
  • Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
  • Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
  • Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
  • Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!

Normen

Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Kennzeichnung

Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:

II 3 G Ex nA II T4

DEKRA 11ATEX0080 X Ta: 0 - 55°C

oder

II 3 G Ex nA nC IIC T4

DEKRA 11ATEX0080 X Ta: 0 - 55°C

Batch-Nummer (D-Nummer)

Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:

D: KW JJ FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 29 10 02 01:

29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!

ATEX

Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.

Installation

1.

Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.

2.

Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.

3.

Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.


EtherCAT Box - ATEX-Dokumentation

BECKHOFF EtherCAT Box: Montage und Verdrahtung

ATEX-Dokumentation

Hinweis 		Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


EP6002-0002 - Schnittstellen-Modi

Über die CoE-Objekte lassen sich folgende Einstellungen für die Schnittstellen vornehmen:

Hinweis 		Parametrierung
Die Parametrierung des Moduls wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) vorgenommen.

Es werden hier nur die zwingend erforderlichen Parameter für den jeweilige Schnittstellen-Modus angegeben. Weitere Einstellungen darüber hinaus sind möglich.

RS232: Punkt-zu-Punkt-Verbindung zu einem RS232-Gerät

Direkte Verbindung zu einem RS232-Endgerät, Vollduplex-Datenübertragung (Default-Einstellung).

Folgende CoE-Objekte müssen eingestellt werden
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
F800:0n | Interface Type Ch n | 0x00 | RS232 | BIT1 | RW | 0x00 (0dez) (default)
 |  | 0x01 | RS485/422

RS422: 4-Draht-Punkt-zu-Punkt-Verbindung zu einem RS422-Gerät

Direkte Verbindung zu einem RS422-Endgerät, Vollduplex-Datenübertragung.

Im RS422 Modus können Daten vollduplex übertragen werden. Es können nur Punkt-zu-Punkt Verbindungen hergestellt werden.

Folgende CoE-Objekte müssen eingestellt werden
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
F800:0n | Interface Type Ch n | 0x00 | RS232 | BIT1 | RW | 0x01 (1dez)
 |  | 0x01 | RS485/422
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
80n0:07 | Enable point to point connection (RS422) Channel n | 0bin | Das Modul wird nach dem RS485-Standard in einer Busstruktur genutzt. | BOOLEAN | RW | 1bin
 |  | 1bin | Das Modul wird für eine Punkt zu Punkt Verbindung genutzt (RS422).

RS485: 2-Draht Verbindung in Bus-Struktur zu RS485-Gerät(en)

Bus-Struktur, Halbduplex-Datenübertragung

Folgende CoE-Objekte müssen eingestellt werden
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
F800:0n | Interface Type Ch n | 0x00 | RS232 | BIT1 | RW | 0x01 (1dez)
 |  | 0x01 | RS485/422
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
80n0:06 | Enable half duplex channel n | 0bin | Vollduplex: gesendete Daten werden mitgehört. Das Bit hat im RS232- und im RS422-Betrieb keine Auswirkungen | BOOLEAN | RW | 1bin (default)
 |  | 1bin | Halbduplex: Der Empfang der von der Box selbst gesendeten Daten wird unterdrückt
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
80n0:07 | Enable point to point connection (RS422) Channel n | 0bin | Das Modul wird nach dem RS485-Standard in einer Busstruktur genutzt. | BOOLEAN | RW | 0bin
 |  | 1bin | Das Modul wird für eine Punkt zu Punkt Verbindung genutzt (RS422).

Hinweis 		Deaktivierter Empfangs-Treiber
Während des Sende-Vorgangs wird der Empfangs-Treiber deaktiviert. Die gesendeten Daten werden nicht mitgehört!

RS485: 2-Draht Verbindung mit externer Brücke in Bus-Struktur zu RS485-Gerät(en)

Bus-Struktur, Halbduplex-Datenübertragung mit Diagnose der gesendeten Daten

Folgende CoE-Objekte müssen eingestellt werden
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
F800:0n | Interface Type Ch n | 0x00 | RS232 | BIT1 | RW | 0x01 (1dez)
 |  | 0x01 | RS485/422
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
80n0:06 | Enable half duplex channel n | 0bin | Vollduplex: gesendete Daten werden mitgehört. Das Bit hat im RS232- und im RS422-Betrieb keine Auswirkungen | BOOLEAN | RW | 0bin
 |  | 1bin | Halbduplex: Der Empfang der von der Box selbst gesendeten Daten wird unterdrückt
Index | Name | Bedeutung |  | Datentyp | Flags | Setting
80n0:07 | Enable point to point connection (RS422) Channel n | 0bin | Das Modul wird nach dem RS485-Standard in einer Busstruktur genutzt. | BOOLEAN | RW | 0bin
 |  | 1bin | Das Modul wird für eine Punkt zu Punkt Verbindung genutzt (RS422).

Hinweis 		Aktivierter Empfangs-Treiber (ab Firmware-Stand: 03)
Während des Sende-Vorgangs bleibt der Empfangs-Treiber aktiviert. Die gesendeten Daten werden mitgehört!

Dadurch ist eine bedingte Diagnose der Leitung möglich.

Bei Abweichung zwischen gesendeten Daten und mitgehörten Daten kann davon ausgegangen werden, dass auch ein weiterer Empfänger diese Daten nicht einwandfrei empfangen konnte.

Überprüfen Sie in diesem Fall die Busleitung!


EP6002-0002 - Grundlagen zur Funktion

BECKHOFF EP6002-0002: Produktübersicht

Grundlagen zur Funktion

Das zweikanalige, serielle Schnittstellenmodul EP6002-0002 ermöglicht den Anschluss von zwei Geräten mit einer RS232 oder RS485/RS422-Schnittstelle.

Zwei konfigurierbare Schnittstellen

Das Modul hat zwei physikalische Schnittstellen die jeweils als RS232 oder RS422/485 konfiguriert werden können.

Schnittstelle 1
  • RS232 an M12-Buchse 1 oder
  • RS422/485 an M12-Buchse 2
Schnittstelle 2
  • RS232 an M12-Buchse 3 oder
  • RS422/485 an M12-Buchse 4

Der Empfangsbuffer ist 864 Byte, der Sendebuffer 128 Byte groß. Die Werkseinstellung des Moduls ist 9600 Baud, 8 Datenbits, 1 Stopp-Bit, no Parity.

Es findet keine Hardware-Flusskontrolle statt, Software-Flusskontrolle über XON, XOFF ist aber möglich.

Kommunikation zwischen SPS und EP6002-0002

Die Kommunikation erfolgt

  • wie bei einem COM-Port unter Verwendung des virtuellen, seriellen Com-Treibers oder
  • über Control-Wort und Status-Word

Daten senden

Sie können über DataOut 0 ... DataOut 21 bis zu 22 Byte Daten in einem Zyklus an das Modul senden.

  • Setzen Sie im Control-Byte den Parameter Output Length auf die Anzahl der zu sendenden Bytes.
  • Toggeln Sie im Control-Byte das Bit Transmit Request.
  • Das Modul quittiert die Datenübertragung im Status-Byte über den Parameter Transmit Accepted.

Daten empfangen

Wenn das Modul im Status-Byte das Bit Receive Request toggelt, liegen neue Empfangsdaten vor

  • Lesen Sie aus dem Status-Byte den Parameter Input Length aus. Er enthält die Anzahl der zu empfangenden Bytes.
  • Die Daten liegen in DataOut 0 ... DataOut 21 bereit. Das erste Datum steht in DataIn 0.
  • Nach auslesen der Daten quittieren Sie dies durch Toggeln des Bits Receive Request im Control-Byte.
    Erst danach stellt das Modul neue Daten zur Verfügung.

Schnittstellen-Pegel

Das Modul EP6002-0002 arbeitet auf RS232-Pegel in Bezug auf GND oder mit differentiellem RS485/422-Pegel.

Prozessdaten

Im Auslieferungszustand werden 22 Byte Nutzdaten und 1 Control/Status-Wort übertragen.

Parametrierung über CoE (Index 80n0)

Die Parametrierung des Moduls kann im CoE (CAN over EtherCAT)-Verzeichnis eingestellt werden.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen

Folgende CoE-Einstellungen aus dem Objekt 8000 sind möglich und hier in den Default-Einstellungen wiedergegeben:

Prozessdatenbeschreibung

Die Prozessdaten werden aus den CoE-Objekten 6000 (Inputs) und 7000 (Outputs) generiert und sind im Kapitel Objektbeschreibung und Parametrierung dargestellt

Transferraten

Die Klemme verfügt über ein Prozessabbild von 22 Byte Nutzdaten. Es ist maximal jeden zweiten Zyklus möglich, diese 22 Byte zu versenden oder zu empfangen.

Im ersten Zyklus werden die Daten von der Klemme an die Steuerung übertragen. Im zweiten Zyklus muss die Steuerung quittieren, dass sie die Daten übernommen hat.

Bei einer Zykluszeit von 10 ms lassen sich also pro Sekunde 50 mal 22 Byte übertragen.

Bei einem eingestellten Data frame von 8N1 setzt sich jedes gesendete Byte wie aus einem Startbit, acht Datenbits und einem Stoppbit zusammen. Dies entspricht 10 Bit pro Nutzbyte.

Mit den oben erwähnen Einstellungen lässt sich demnach eine kontinuierliche Datentransferrate von:

  • 50[1/s] x 22[Byte] x 10[Bit] = 11000 bps

erzielen.

Die nächst niedrigere Baudrate ist 9600 Baud. Bei einer Zykluszeit von 10 ms lässt sich demnach eine kontinuierliche Übertragung mit maximal 9600 Baud sicherstellen.

Sollten nur sporadisch geringe Datenmengen gesendet oder empfangen werden (z.B. Barcodescanner) kann die Baudrate auch höher eingestellt werden, bzw. die Zykluszeit vergrößert werden.

Falls die Steuerung die Daten nicht schnell genug von der Klemme abholen kann, werden dies im internen Puffer der Klemme zwischengespeichert. Der Puffer für Empfangsdaten hat eine Größe von 864 Byte. Sollte dieser erschöpft sein gehen alle weiteren Daten verloren.

Auch für die Sendedaten steht ein Puffer zur Verfügung. Bei einer Eingestellten "Baudrate" von 300 und einem "Data Frame" von 8N1 kann die Klemme nur 30 Byte pro Sekunde senden. Sollten jedoch mehr als dies 30 Byte pro Sekunde eingehen wird auch hier zuerst ein 128 Byte großer Sendepuffer beschrieben. Nachdem dieser gefüllt ist gehen alle weiteren Daten verloren.

Transferraten Optimierung

Im normalen Betrieb werden empfangene Daten sofort in das Prozessabbild übernommen. Um einen zusammenhängenden Datenstrom zu ermöglichen ist die Option "Enable transfer rate optimization" im Settings-Objekt standardmäßig aktiviert. Durch diesen Schalter werden die Daten zuerst im Empfangspuffer (864 Byte) zwischengespeichert.

Die Daten werden erst in das Prozessabbild kopiert, wenn 16 Bitzeiten lang kein weiteres Zeichen empfangen wurde oder der Puffer voll ist.

Kontinuierliches Senden von Daten

Für viele Anwendungen ist ein kontinuierlicher Datenstrom unerlässlich. Zu diesem Zweck verfügen die Beckhoff Module über die Einstellung "Enable send FIFO data continuous" im Settings-Objekt. Durch setzen dieses Schalters kann zuerst der interne Sendepuffer (128 Byte) der Klemme gefüllt werden. Anschließend kann der gesamte Pufferinhalt unterbrechungsfrei gesendet werden. Dazu werden Daten, wie bei einer Normalen Übertragung, von der Steuerung an die Klemme gesendet. Erst mit einer steigenden Flanke des Bits "Send continuous" werden die Daten aus dem Puffer gesendet. Sind die Daten übertragen, so wird dies durch das Setzen des Bits "InitAccepted" von der Klemme an die Steuerung quittiert. "Init accepted" wird mit "Send continuous" zurückgenommen.

Priorisierung

Da Empfangsdaten i.d.R. nicht vom anderen Sender wiederholt werden können, haben diese im Modul eine höhere Priorität als zu sendende Daten.
Weiterhin sinkt die Priorität mit steigender Kanalnummer. Die höchste Priorität hat somit der Empfang von Daten auf Kanal 1.

Beispiele für die Datenübertragung

Initialisierung

Vor dem ersten Senden/Empfangen wird die Initialisierung durchgeführt. Dabei wird das Modul mit den Daten des entsprechenden Settings-Objektes parametriert.

Vorgehensweise:

  1. "Init request" auf 1 setzen
  2. Die Erfogreiche Initialisierung wird von dem Modul durch das Setzen von "Init accepted" bestätigt
  3. "Init request" zurücksetzen
  4. Das Modul setzt "Init accepted" auf 0
Das modul ist nun zum Datenaustausch bereit.

Datenübertragung von der Steuerung zum Modul (2 Zeichen senden )

  1. "Output length" auf 2 setzen
  2. "Data Out 0" und "Data Out 1" mit Nutzdaten füllen
  3. Den Zustand von "Transmit request" umschalten
  4. Das Modul quittiert die Entgegennahme mit einer Zustandsänderung des "Transmit accepted" Bits

Datenübertragung vom Modul zur Steuerung (Zeichen empfangen)

  1. Das Modul zeigt durch die Zustandsänderung des "Receive request" Bits an, dass sich neue Daten im Prozessabbild befinden.
  2. Die Anzahl der empfangenen Bytes wird in "Input length" abgelegt
  3. Die Steuerung quittiert mit einer Zustandsänderung von "Receive request" die Übernahme der Bytes


EtherCAT Box - Einfügen in das EtherCAT-Netzwerk

BECKHOFF EtherCAT Box: Inbetriebnahme und Konfiguration

Einfügen in das EtherCAT-Netzwerk

Hinweis 		Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen installiert werden.

Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:

  • durch Einscannen vorhandener Hardware (genannt "online") und
  • durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.

Automatisches Einscannen des Moduls

  • Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
  • Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein (siehe Abb.1). Bestätigen Sie alle folgenden Dialoge mit "OK", so dass sich die Konfiguration im "FreeRun" -Modus befindet.

Abb. 1: Einscannen der EtherCAT Konfiguration (E/A-Geräte-> Rechte Maustaste -> Geräte suchen...

Manuelles Anfügen eines Moduls

  • Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
  • Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
  • Fügen Sie ein neues E/A-Gerät an (siehe Abb. 2). Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), s. Abb. 3, bestätigen Sie mit OK.

Abb. 2: Anfügen eines neuen E/A-Gerätes (E/A-Geräte-> Rechte Maustaste -> Gerät anfügen... )

Abb. 3: Auswahl des Gerätes (EtherCAT)

  • Fügen Sie eine neue Box an (siehe Abb. 4).

Abb. 4: Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen... )

  • Im angezeigten Dialog wählen Sie die gewünschte Box, bestätigen Sie mit OK.

Abb. 5: Auswahl einer Box

Abb. 6 Angefügte Box im TwinCAT Baum


EPxxxx - Konfiguration mit dem TwinCAT System Manager

BECKHOFF EtherCAT Box: Inbetriebnahme und Konfiguration

Konfiguration mit dem TwinCAT System Manager

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten.

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.

Karteireiter Allgemein

Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.

Karteireiter EtherCAT

Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem Anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.

Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.

Karteireiter Prozessdaten

Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.

Sync-Manager

Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.

Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.

PDO-Zuordnung

PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:

  • Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
  • Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.

Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.

Hinweis 		Aktivierung der PDO-Zuordnung
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
  • der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
  • der System-Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])

PDO-Liste

Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.

Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.

PDO-Inhalt

Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.

Download

Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.

PDO-Zuordnung

Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.

PDO-Konfiguration

Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.

Karteireiter Startup

Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.

Spalte | Beschreibung
Transition Übergang, in den der Request gesendet wird. Dies kann entweder
  • der Übergang von Pre-Operational to Safe-Operational (PS) oder
  • der Übergang von Safe-Operational to Operational (SO) sein.

Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll | Art des Mailbox-Protokolls
Index | Index des Objekts
Data | Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar | Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.

Karteireiter CoE - Online

Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.

Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.

Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.

Karteireiter Online

Status Maschine

Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.

DLL-Status

Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:

Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.

File Access over EtherCAT

Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


EP6002 - Auswahl des Schnittstellen-Typs

Im TwinCAT System-Manager können Sie auf dem Karteireiter CoE-Online unter dem Objekt F800:0 die seriellen Schnittstellen parametrieren.

Klicken Sie auf die Objekte F800:01 und F800:02 wählen Sie für beide Schnittstellen den Interface-Type aus.

Zuordnung der Anschlüsse

Je nach Schnittstellen-Typ müssen Sie den entsprechenden M12-Anschluss benutzen.

Kanal | ausgewählter Schnittstellen-Typ | verwenden Sie | Kommentar
Kanal 1 | RS485/RS422 | M12-Anschluss Nr. 1 | M12-Anschluss Nr. 2 hat keine Funktion
 | RS232 | M12-Anschluss Nr. 2 | M12-Anschluss Nr. 1 hat keine Funktion
Kanal 2 | RS485/RS422 | M12-Anschluss Nr. 3 | M12-Anschluss Nr. 4 hat keine Funktion
 | RS232 | M12-Anschluss Nr. 4 | M12-Anschluss Nr. 3 hat keine Funktion


EP6002 - Control- und Status-Wort

BECKHOFF EP6002: Konfiguration

Control- und Status-Wort

Control- und Status-Wort befinden sich in den ersten 16 Bit des Eingangs- und Ausgangsprozessabbildes. Über sie wird die Kommunikation zwischen der Klemme und der Steuerung kontrolliert.

Status-Wort

Bit-Position | Name | Bedeutung |  | Datentyp
0 | Transmit accepted | Das Modul quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. Erst daraufhin werden neue Daten von der Steuerung zur Klemme übertragen. |  | BOOLEAN
1 | Receive request | Über eine Zustandsänderung dieses Bits teilt das Modul der Steuerung mit, dass sich die in Input length angezeigte Anzahl von Bytes in den DataIn-Bytes befinden. Die Steuerung muss die Entgegennahme der Daten mit Zustandsänderung des ReceiveAccepted-Bits quittieren. Erst daraufhin werden neue Daten vom Modul zur Steuerung übertragen. |  | BOOLEAN
2 | Init accepted | 0bin | Das Modul ist wieder für den seriellen Datenaustausch bereit. | BOOLEAN
 |  | 1bin | Die Initialisierung wurde vom Modul ausgeführt.
3 | Buffer full | Das Empfangs-FIFO ist voll. Ab diesem Zeitpunkt gehen alle eingehenden Daten verloren! |  | BOOLEAN
4 | Parity error | Es ist ein Parity-Error aufgetreten. |  | BOOLEAN
5 | Framing error | Es ist ein Framing-Error aufgetreten. |  | BOOLEAN
6 | Overrun error | Es ist ein Overrun-Error aufgetreten. |  | BOOLEAN
7 | - | reserviert |  |
8...15 | Input length | Anzahl der Eingangs-Bytes, die für die Übertragung vom Modul zur Steuerung bereit stehen. |  | UINT8

Control-Wort

Bit-Position | Name | Bedeutung |  | Datentyp
0 | Transmit request | Über eine Zustandsänderung dieses Bits teilt die Steuerung dem Modul mit, dass sich die in mit den Output length angezeigte Anzahl von Bytes in den DataOut-Bytes befinden. Das Modul quittiert die Entgegennahme der Daten mit Zustandsänderung des Bits TransmitAccepted. Erst daraufhin werden neue Daten von der Steuerung zum Modul übertragen. |  | BOOLEAN
1 | Receive accepted | Die Steuerung quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. Erst daraufhin werden neue Daten vom Modul zur Steuerung übertragen. |  | BOOLEAN
2 | Init request | 0bin | Die Steuerung fordert vom Modul wieder die Bereitschaft für den seriellen Datenaustausch. | BOOLEAN
 |  | 1bin | Die Steuerung fordert die Klemme zur Initialisierung auf. Die Sende- und Empfangsfunktionen werden gesperrt, die FIFO-Zeiger werden zurückgesetzt und die Schnittstelle wird mit den Werten des zuständigen Settings-Objektes initialisiert. Die Ausführung der Initialisierung wird vom Modul mit dem Bit Init accepted quittiert.
3 | Send continuous | Kontinuierliches Senden der Daten aus dem FIFO. Über die Steuerung wird der Sendebuffer gefüllt (bis zu 128 Byte). Mit steigender Flanke des Bits wird der gefüllte Buffer-Inhalt gesendet. Sind die Daten übertragen, so wird dies durch das Setzen des Bits Init accepted vom Modul an die Steuerung quittiert. Init accepted wird mit SendContinuous zurückgenommen. |  | BOOLEAN
4...7 | - | reserviert |  |
8...15 | Output length | Anzahl der Ausgangs-Bytes, die für die Übertragung von der Steuerung zum Modul bereit stehen. |  | UINT8


EP6002 - Objektübersicht

BECKHOFF EP6002: Konfiguration

Objektübersicht

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.
Index |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x02581389 (39326601dez)
1008 |  | Device name | RO | EP6002-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 00
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x17724052 (393363538dez)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1400:0 | Subindex | COM RxPDO-Par Outputs Ch.1 | RO | 0x06 (6dez)
 | 1400:06 | Exclude RxPDOs | RO | 04 16
1401:0 | Subindex | COM RxPDO-Par Outputs Ch.2 | RO | 0x06 (6dez)
 | 1401:06 | Exclude RxPDOs | RO | 05 16
1404:0 | Subindex | COM RxPDO-Par Outputs Ch.1 | RO | 0x06 (6dez)
 | 1404:06 | Exclude RxPDOs | RO | 00 16
1405:0 | Subindex | COM RxPDO-Par Outputs Ch.2 | RO | 0x06 (6dez)
 | 1405:06 | Exclude RxPDOs | RO | 01 16
1600:0 | Subindex | COM RxPDO-Map Outputs Ch.1 | RO | 0x1C (28dez)
 | 1600:01 | SubIndex 001 | RO | 0x7000:01, 1
 | 1600:02 | SubIndex 002 | RO | 0x7000:02, 1
 | 1600:03 | SubIndex 003 | RO | 0x7000:03, 1
 | 1600:04 | SubIndex 004 | RO | 0x7000:04, 1
 | 1600:05 | SubIndex 005 | RO | 0x0000:00, 4
 | 1600:06 | SubIndex 006 | RO | 0x7000:09, 8
 | 1600:07 | SubIndex 007 | RO | 0x7000:11, 8
 | 1600:08 | SubIndex 008 | RO | 0x7000:12, 8
 | 1600:09 | SubIndex 009 | RO | 0x7000:13, 8
 | 1600:0A | SubIndex 010 | RO | 0x7000:14, 8
 | 1600:0B | SubIndex 011 | RO | 0x7000:15, 8
 | 1600:0C | SubIndex 012 | RO | 0x7000:16, 8
 | 1600:0D | SubIndex 013 | RO | 0x7000:17, 8
 | 1600:0E | SubIndex 014 | RO | 0x7000:18, 8
 | 1600:0F | SubIndex 015 | RO | 0x7000:19, 8
 | 1600:10 | SubIndex 016 | RO | 0x7000:1A, 8
 | 1600:11 | SubIndex 017 | RO | 0x7000:1B, 8
 | 1600:12 | SubIndex 018 | RO | 0x7000:1C, 8
 | 1600:13 | SubIndex 019 | RO | 0x7000:1D, 8
 | 1600:14 | SubIndex 020 | RO | 0x7000:1E, 8
 | 1600:15 | SubIndex 021 | RO | 0x7000:1F, 8
 | 1600:16 | SubIndex 022 | RO | 0x7000:20, 8
 | 1600:17 | SubIndex 023 | RO | 0x7000:21, 8
 | 1600:18 | SubIndex 024 | RO | 0x7000:22, 8
 | 1600:19 | SubIndex 025 | RO | 0x7000:23, 8
 | 1600:1A | SubIndex 026 | RO | 0x7000:24, 8
 | 1600:1B | SubIndex 027 | RO | 0x7000:25, 8
 | 1600:1C | SubIndex 028 | RO | 0x7000:26, 8
1601:0 | Subindex | COM RxPDO-Map Outputs Ch.2 | RO | 0x1C (28dez)
 | 1601:01 | SubIndex 001 | RO | 0x7010:01, 1
 | 1601:02 | SubIndex 002 | RO | 0x7010:02, 1
 | 1601:03 | SubIndex 003 | RO | 0x7010:03, 1
 | 1601:04 | SubIndex 004 | RO | 0x7010:04, 1
 | 1601:05 | SubIndex 005 | RO | 0x0000:00, 4
 | 1601:06 | SubIndex 006 | RO | 0x7010:09, 8
 | 1601:07 | SubIndex 007 | RO | 0x7010:11, 8
 | 1601:08 | SubIndex 008 | RO | 0x7010:12, 8
 | 1601:09 | SubIndex 009 | RO | 0x7010:13, 8
 | 1601:0A | SubIndex 010 | RO | 0x7010:14, 8
 | 1601:0B | SubIndex 011 | RO | 0x7010:15, 8
 | 1601:0C | SubIndex 012 | RO | 0x7010:16, 8
 | 1601:0D | SubIndex 013 | RO | 0x7010:17, 8
 | 1601:0E | SubIndex 014 | RO | 0x7010:18, 8
 | 1601:0F | SubIndex 015 | RO | 0x7010:19, 8
 | 1601:10 | SubIndex 016 | RO | 0x7010:1A, 8
 | 1601:11 | SubIndex 017 | RO | 0x7010:1B, 8
 | 1601:12 | SubIndex 018 | RO | 0x7010:1C, 8
 | 1601:13 | SubIndex 019 | RO | 0x7010:1D, 8
 | 1601:14 | SubIndex 020 | RO | 0x7010:1E, 8
 | 1601:15 | SubIndex 021 | RO | 0x7010:1F, 8
 | 1601:16 | SubIndex 022 | RO | 0x7010:20, 8
 | 1601:17 | SubIndex 023 | RO | 0x7010:21, 8
 | 1601:18 | SubIndex 024 | RO | 0x7010:22, 8
 | 1601:19 | SubIndex 025 | RO | 0x7010:23, 8
 | 1601:1A | SubIndex 026 | RO | 0x7010:24, 8
 | 1601:1B | SubIndex 027 | RO | 0x7010:25, 8
 | 1601:1C | SubIndex 028 | RO | 0x7010:26, 8
1604:0 | Subindex | COM RxPDO-Map Outputs Ch.1 | RO | 0x17 (23dez)
 | 1604:01 | SubIndex 001 | RO | 0x7001:01, 16
 | 1604:02 | SubIndex 002 | RO | 0x7000:11, 8
 | 1604:03 | SubIndex 003 | RO | 0x7000:12, 8
 | 1604:04 | SubIndex 004 | RO | 0x7000:13, 8
 | 1604:05 | SubIndex 005 | RO | 0x7000:14, 8
 | 1604:06 | SubIndex 006 | RO | 0x7000:15, 8
 | 1604:07 | SubIndex 007 | RO | 0x7000:16, 8
 | 1604:08 | SubIndex 008 | RO | 0x7000:17, 8
 | 1604:09 | SubIndex 009 | RO | 0x7000:18, 8
 | 1604:0A | SubIndex 010 | RO | 0x7000:19, 8
 | 1604:0B | SubIndex 011 | RO | 0x7000:1A, 8
 | 1604:0C | SubIndex 012 | RO | 0x7000:1B, 8
 | 1604:0D | SubIndex 013 | RO | 0x7000:1C, 8
 | 1604:0E | SubIndex 014 | RO | 0x7000:1D, 8
 | 1604:0F | SubIndex 015 | RO | 0x7000:1E, 8
 | 1604:10 | SubIndex 016 | RO | 0x7000:1F, 8
 | 1604:11 | SubIndex 017 | RO | 0x7000:20, 8
 | 1604:12 | SubIndex 018 | RO | 0x7000:21, 8
 | 1604:13 | SubIndex 019 | RO | 0x7000:22, 8
 | 1604:14 | SubIndex 020 | RO | 0x7000:23, 8
 | 1604:15 | SubIndex 021 | RO | 0x7000:24, 8
 | 1604:16 | SubIndex 022 | RO | 0x7000:25, 8
 | 1604:17 | SubIndex 023 | RO | 0x7000:26, 8
1605:0 | Subindex | COM RxPDO-Map Outputs Ch.2 | RO | 0x17 (23dez)
 | 1605:01 | SubIndex 001 | RO | 0x7011:01, 16
 | 1605:02 | SubIndex 002 | RO | 0x7010:11, 8
 | 1605:03 | SubIndex 003 | RO | 0x7010:12, 8
 | 1605:04 | SubIndex 004 | RO | 0x7010:13, 8
 | 1605:05 | SubIndex 005 | RO | 0x7010:14, 8
 | 1605:06 | SubIndex 006 | RO | 0x7010:15, 8
 | 1605:07 | SubIndex 007 | RO | 0x7010:16, 8
 | 1605:08 | SubIndex 008 | RO | 0x7010:17, 8
 | 1605:09 | SubIndex 009 | RO | 0x7010:18, 8
 | 1605:0A | SubIndex 010 | RO | 0x7010:19, 8
 | 1605:0B | SubIndex 011 | RO | 0x7010:1A, 8
 | 1605:0C | SubIndex 012 | RO | 0x7010:1B, 8
 | 1605:0D | SubIndex 013 | RO | 0x7010:1C, 8
 | 1605:0E | SubIndex 014 | RO | 0x7010:1D, 8
 | 1605:0F | SubIndex 015 | RO | 0x7010:1E, 8
 | 1605:10 | SubIndex 016 | RO | 0x7010:1F, 8
 | 1605:11 | SubIndex 017 | RO | 0x7010:20, 8
 | 1605:12 | SubIndex 018 | RO | 0x7010:21, 8
 | 1605:13 | SubIndex 019 | RO | 0x7010:22, 8
 | 1605:14 | SubIndex 020 | RO | 0x7010:23, 8
 | 1605:15 | SubIndex 021 | RO | 0x7010:24, 8
 | 1605:16 | SubIndex 022 | RO | 0x7010:25, 8
 | 1605:17 | SubIndex 023 | RO | 0x7010:26, 8
1800:0 | Subindex | COM TxPDO-Par Inputs Ch.1 | RO | 0x06 (6dez)
 | 1800:06 | Exclude TxPDOs | RO | 04 1A
1801:0 | Subindex | COM TxPDO-Par Inputs Ch.2 | RO | 0x06 (6dez)
 | 1801:06 | Exclude TxPDOs | RO | 05 1A
1804:0 | Subindex | COM TxPDO-Par Inputs Ch.1 | RO | 0x06 (6dez)
 | 1804:06 | Exclude TxPDOs | RO | 00 1A
1805:0 | Subindex | COM TxPDO-Par Inputs Ch.2 | RO | 0x06 (6dez)
 | 1805:06 | Exclude TxPDOs | RO | 01 1A
1A00:0 | Subindex | COM TxPDO-Map Inputs Ch.1 | RO | 0x1F (31dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x0000:00, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:09, 8
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 8
 | 1A00:0B | SubIndex 011 | RO | 0x6000:12, 8
 | 1A00:0C | SubIndex 012 | RO | 0x6000:13, 8
 | 1A00:0D | SubIndex 013 | RO | 0x6000:14, 8
 | 1A00:0E | SubIndex 014 | RO | 0x6000:15, 8
 | 1A00:0F | SubIndex 015 | RO | 0x6000:16, 8
 | 1A00:10 | SubIndex 016 | RO | 0x6000:17, 8
 | 1A00:11 | SubIndex 017 | RO | 0x6000:18, 8
 | 1A00:12 | SubIndex 018 | RO | 0x6000:19, 8
 | 1A00:13 | SubIndex 019 | RO | 0x6000:1A, 8
 | 1A00:14 | SubIndex 020 | RO | 0x6000:1B, 8
 | 1A00:15 | SubIndex 021 | RO | 0x6000:1C, 8
 | 1A00:16 | SubIndex 022 | RO | 0x6000:1D, 8
 | 1A00:17 | SubIndex 023 | RO | 0x6000:1E, 8
 | 1A00:18 | SubIndex 024 | RO | 0x6000:1F, 8
 | 1A00:19 | SubIndex 025 | RO | 0x6000:20, 8
 | 1A00:1A | SubIndex 026 | RO | 0x6000:21, 8
 | 1A00:1B | SubIndex 027 | RO | 0x6000:22, 8
 | 1A00:1C | SubIndex 028 | RO | 0x6000:23, 8
 | 1A00:1D | SubIndex 029 | RO | 0x6000:24, 8
 | 1A00:1E | SubIndex 030 | RO | 0x6000:25, 8
 | 1A00:1F | SubIndex 031 | RO | 0x6000:26, 8
1A01:0 | Subindex | COM TxPDO-Map Inputs Ch.2 | RO | 0x1F (31dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x0000:00, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:09, 8
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 8
 | 1A01:0B | SubIndex 011 | RO | 0x6010:12, 8
 | 1A01:0C | SubIndex 012 | RO | 0x6010:13, 8
 | 1A01:0D | SubIndex 013 | RO | 0x6010:14, 8
 | 1A01:0E | SubIndex 014 | RO | 0x6010:15, 8
 | 1A01:0F | SubIndex 015 | RO | 0x6010:16, 8
 | 1A01:10 | SubIndex 016 | RO | 0x6010:17, 8
 | 1A01:11 | SubIndex 017 | RO | 0x6010:18, 8
 | 1A01:12 | SubIndex 018 | RO | 0x6010:19, 8
 | 1A01:13 | SubIndex 019 | RO | 0x6010:1A, 8
 | 1A01:14 | SubIndex 020 | RO | 0x6010:1B, 8
 | 1A01:15 | SubIndex 021 | RO | 0x6010:1C, 8
 | 1A01:16 | SubIndex 022 | RO | 0x6010:1D, 8
 | 1A01:17 | SubIndex 023 | RO | 0x6010:1E, 8
 | 1A01:18 | SubIndex 024 | RO | 0x6010:1F, 8
 | 1A01:19 | SubIndex 025 | RO | 0x6010:20, 8
 | 1A01:1A | SubIndex 026 | RO | 0x6010:21, 8
 | 1A01:1B | SubIndex 027 | RO | 0x6010:22, 8
 | 1A01:1C | SubIndex 028 | RO | 0x6010:23, 8
 | 1A01:1D | SubIndex 029 | RO | 0x6010:24, 8
 | 1A01:1E | SubIndex 030 | RO | 0x6010:25, 8
 | 1A01:1F | SubIndex 031 | RO | 0x6010:26, 8
1A04:0 | Subindex | COM TxPDO-Map Inputs Ch.1 | RO | 0x17 (23dez)
 | 1A04:01 | SubIndex 001 | RO | 0x6001:01, 16
 | 1A04:02 | SubIndex 002 | RO | 0x6000:11, 8
 | 1A04:03 | SubIndex 003 | RO | 0x6000:12, 8
 | 1A04:04 | SubIndex 004 | RO | 0x6000:13, 8
 | 1A04:05 | SubIndex 005 | RO | 0x6000:14, 8
 | 1A04:06 | SubIndex 006 | RO | 0x6000:15, 8
 | 1A04:07 | SubIndex 007 | RO | 0x6000:16, 8
 | 1A04:08 | SubIndex 008 | RO | 0x6000:17, 8
 | 1A04:09 | SubIndex 009 | RO | 0x6000:18, 8
 | 1A04:0A | SubIndex 010 | RO | 0x6000:19, 8
 | 1A04:0B | SubIndex 011 | RO | 0x6000:1A, 8
 | 1A04:0C | SubIndex 012 | RO | 0x6000:1B, 8
 | 1A04:0D | SubIndex 013 | RO | 0x6000:1C, 8
 | 1A04:0E | SubIndex 014 | RO | 0x6000:1D, 8
 | 1A04:0F | SubIndex 015 | RO | 0x6000:1E, 8
 | 1A04:10 | SubIndex 016 | RO | 0x6000:1F, 8
 | 1A04:11 | SubIndex 017 | RO | 0x6000:20, 8
 | 1A04:12 | SubIndex 018 | RO | 0x6000:21, 8
 | 1A04:13 | SubIndex 019 | RO | 0x6000:22, 8
 | 1A04:14 | SubIndex 020 | RO | 0x6000:23, 8
 | 1A04:15 | SubIndex 021 | RO | 0x6000:24, 8
 | 1A04:16 | SubIndex 022 | RO | 0x6000:25, 8
 | 1A04:17 | SubIndex 023 | RO | 0x6000:26, 8
1A05:0 | Subindex | COM TxPDO-Map Inputs Ch.2 | RO | 0x17 (23dez)
 | 1A05:01 | SubIndex 001 | RO | 0x6011:01, 16
 | 1A05:02 | SubIndex 002 | RO | 0x6010:11, 8
 | 1A05:03 | SubIndex 003 | RO | 0x6010:12, 8
 | 1A05:04 | SubIndex 004 | RO | 0x6010:13, 8
 | 1A05:05 | SubIndex 005 | RO | 0x6010:14, 8
 | 1A05:06 | SubIndex 006 | RO | 0x6010:15, 8
 | 1A05:07 | SubIndex 007 | RO | 0x6010:16, 8
 | 1A05:08 | SubIndex 008 | RO | 0x6010:17, 8
 | 1A05:09 | SubIndex 009 | RO | 0x6010:18, 8
 | 1A05:0A | SubIndex 010 | RO | 0x6010:19, 8
 | 1A05:0B | SubIndex 011 | RO | 0x6010:1A, 8
 | 1A05:0C | SubIndex 012 | RO | 0x6010:1B, 8
 | 1A05:0D | SubIndex 013 | RO | 0x6010:1C, 8
 | 1A05:0E | SubIndex 014 | RO | 0x6010:1D, 8
 | 1A05:0F | SubIndex 015 | RO | 0x6010:1E, 8
 | 1A05:10 | SubIndex 016 | RO | 0x6010:1F, 8
 | 1A05:11 | SubIndex 017 | RO | 0x6010:20, 8
 | 1A05:12 | SubIndex 018 | RO | 0x6010:21, 8
 | 1A05:13 | SubIndex 019 | RO | 0x6010:22, 8
 | 1A05:14 | SubIndex 020 | RO | 0x6010:23, 8
 | 1A05:15 | SubIndex 021 | RO | 0x6010:24, 8
 | 1A05:16 | SubIndex 022 | RO | 0x6010:25, 8
 | 1A05:17 | SubIndex 023 | RO | 0x6010:26, 8
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1604 (5636dez)
 | 1C12:02 | SubIndex 002 | RW | 0x1605 (5637dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x02 (2dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A04 (6660dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A05 (6661dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0000 (0dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00000384 (900dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x00002710 (10000dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00000384 (900dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum Delay time | RO | 0x00000384 (900dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0000 (0dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000384 (900dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x00002710 (10000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000384 (900dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum Delay time | RO | 0x00000384 (900dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | COM Inputs Ch.1 | RO | 0x26 (38dez)
 | 6000:01 | Transmit accepted | RO | 0x00 (0dez)
 | 6000:02 | Receive request | RO | 0x00 (0dez)
 | 6000:03 | Init accepted | RO | 0x00 (0dez)
 | 6000:04 | Buffer full | RO | 0x00 (0dez)
 | 6000:05 | Parity error | RO | 0x00 (0dez)
 | 6000:06 | Framing error | RO | 0x00 (0dez)
 | 6000:07 | Overrun error | RO | 0x00 (0dez)
 | 6000:09 | Input length | RO | 0x00 (0dez)
 | 6000:11 | Data In 0 | RO | 0x00 (0dez)
 | 6000:12 | Data In 1 | RO | 0x00 (0dez)
 | 6000:13 | Data In 2 | RO | 0x00 (0dez)
 | 6000:14 | Data In 3 | RO | 0x00 (0dez)
 | 6000:15 | Data In 4 | RO | 0x00 (0dez)
 | 6000:16 | Data In 5 | RO | 0x00 (0dez)
 | 6000:17 | Data In 6 | RO | 0x00 (0dez)
 | 6000:18 | Data In 7 | RO | 0x00 (0dez)
 | 6000:19 | Data In 8 | RO | 0x00 (0dez)
 | 6000:1A | Data In 9 | RO | 0x00 (0dez)
 | 6000:1B | Data In 10 | RO | 0x00 (0dez)
 | 6000:1C | Data In 11 | RO | 0x00 (0dez)
 | 6000:1D | Data In 12 | RO | 0x00 (0dez)
 | 6000:1E | Data In 13 | RO | 0x00 (0dez)
 | 6000:1F | Data In 14 | RO | 0x00 (0dez)
 | 6000:20 | Data In 15 | RO | 0x00 (0dez)
 | 6000:21 | Data In 16 | RO | 0x00 (0dez)
 | 6000:22 | Data In 17 | RO | 0x00 (0dez)
 | 6000:23 | Data In 18 | RO | 0x00 (0dez)
 | 6000:24 | Data In 19 | RO | 0x00 (0dez)
 | 6000:25 | Data In 20 | RO | 0x00 (0dez)
 | 6000:26 | Data In 21 | RO | 0x00 (0dez)
6001:0 | Subindex | Status Ch.1 | RO | 0x01 (1dez)
 | 6001:01 | Status | RO | 0x0000 (0dez)
6010:0 | Subindex | COM Inputs Ch.2 | RO | 0x26 (38dez)
 | 6010:01 | Transmit accepted | RO | 0x00 (0dez)
 | 6010:02 | Receive request | RO | 0x00 (0dez)
 | 6010:03 | Init accepted | RO | 0x00 (0dez)
 | 6010:04 | Buffer full | RO | 0x00 (0dez)
 | 6010:05 | Parity error | RO | 0x00 (0dez)
 | 6010:06 | Framing error | RO | 0x00 (0dez)
 | 6010:07 | Overrun error | RO | 0x00 (0dez)
 | 6010:09 | Input length | RO | 0x00 (0dez)
 | 6010:11 | Data In 0 | RO | 0x00 (0dez)
 | 6010:12 | Data In 1 | RO | 0x00 (0dez)
 | 6010:13 | Data In 2 | RO | 0x00 (0dez)
 | 6010:14 | Data In 3 | RO | 0x00 (0dez)
 | 6010:15 | Data In 4 | RO | 0x00 (0dez)
 | 6010:16 | Data In 5 | RO | 0x00 (0dez)
 | 6010:17 | Data In 6 | RO | 0x00 (0dez)
 | 6010:18 | Data In 7 | RO | 0x00 (0dez)
 | 6010:19 | Data In 8 | RO | 0x00 (0dez)
 | 6010:1A | Data In 9 | RO | 0x00 (0dez)
 | 6010:1B | Data In 10 | RO | 0x00 (0dez)
 | 6010:1C | Data In 11 | RO | 0x00 (0dez)
 | 6010:1D | Data In 12 | RO | 0x00 (0dez)
 | 6010:1E | Data In 13 | RO | 0x00 (0dez)
 | 6010:1F | Data In 14 | RO | 0x00 (0dez)
 | 6010:20 | Data In 15 | RO | 0x00 (0dez)
 | 6010:21 | Data In 16 | RO | 0x00 (0dez)
 | 6010:22 | Data In 17 | RO | 0x00 (0dez)
 | 6010:23 | Data In 18 | RO | 0x00 (0dez)
 | 6010:24 | Data In 19 | RO | 0x00 (0dez)
 | 6010:25 | Data In 20 | RO | 0x00 (0dez)
 | 6010:26 | Data In 21 | RO | 0x00 (0dez)
6011:0 | Subindex | Status Ch.2 | RO | 0x01 (1dez)
 | 6011:01 | Status | RO | 0x0000 (0dez)
7000:0 | Subindex | COM Outputs Ch.1 | RO | 0x26 (38dez)
 | 7000:01 | Transmit request | RO | 0x00 (0dez)
 | 7000:02 | Receive accepted | RO | 0x00 (0dez)
 | 7000:03 | Init request | RO | 0x00 (0dez)
 | 7000:04 | Send continuous | RO | 0x00 (0dez)
 | 7000:09 | Output length | RO | 0x00 (0dez)
 | 7000:11 | Data Out 0 | RO | 0x00 (0dez)
 | 7000:12 | Data Out 1 | RO | 0x00 (0dez)
 | 7000:13 | Data Out 2 | RO | 0x00 (0dez)
 | 7000:14 | Data Out 3 | RO | 0x00 (0dez)
 | 7000:15 | Data Out 4 | RO | 0x00 (0dez)
 | 7000:16 | Data Out 5 | RO | 0x00 (0dez)
 | 7000:17 | Data Out 6 | RO | 0x00 (0dez)
 | 7000:18 | Data Out 7 | RO | 0x00 (0dez)
 | 7000:19 | Data Out 8 | RO | 0x00 (0dez)
 | 7000:1A | Data Out 9 | RO | 0x00 (0dez)
 | 7000:1B | Data Out 10 | RO | 0x00 (0dez)
 | 7000:1C | Data Out 11 | RO | 0x00 (0dez)
 | 7000:1D | Data Out 12 | RO | 0x00 (0dez)
 | 7000:1E | Data Out 13 | RO | 0x00 (0dez)
 | 7000:1F | Data Out 14 | RO | 0x00 (0dez)
 | 7000:20 | Data Out 15 | RO | 0x00 (0dez)
 | 7000:21 | Data Out 16 | RO | 0x00 (0dez)
 | 7000:22 | Data Out 17 | RO | 0x00 (0dez)
 | 7000:23 | Data Out 18 | RO | 0x00 (0dez)
 | 7000:24 | Data Out 19 | RO | 0x00 (0dez)
 | 7000:25 | Data Out 20 | RO | 0x00 (0dez)
 | 7000:26 | Data Out 21 | RO | 0x00 (0dez)
7001:0 | Subindex | Ctrl Ch.1 | RO | 0x01 (1dez)
 | 7001:01 | Ctrl | RO | 0x0000 (0dez)
7010:0 | Subindex | COM Outputs Ch.2 | RO | 0x26 (38dez)
 | 7010:01 | Transmit request | RO | 0x00 (0dez)
 | 7010:02 | Receive accepted | RO | 0x00 (0dez)
 | 7010:03 | Init request | RO | 0x00 (0dez)
 | 7010:04 | Send continuous | RO | 0x00 (0dez)
 | 7010:09 | Output length | RO | 0x00 (0dez)
 | 7010:11 | Data Out 0 | RO | 0x00 (0dez)
 | 7010:12 | Data Out 1 | RO | 0x00 (0dez)
 | 7010:13 | Data Out 2 | RO | 0x00 (0dez)
 | 7010:14 | Data Out 3 | RO | 0x00 (0dez)
 | 7010:15 | Data Out 4 | RO | 0x00 (0dez)
 | 7010:16 | Data Out 5 | RO | 0x00 (0dez)
 | 7010:17 | Data Out 6 | RO | 0x00 (0dez)
 | 7010:18 | Data Out 7 | RO | 0x00 (0dez)
 | 7010:19 | Data Out 8 | RO | 0x00 (0dez)
 | 7010:1A | Data Out 9 | RO | 0x00 (0dez)
 | 7010:1B | Data Out 10 | RO | 0x00 (0dez)
 | 7010:1C | Data Out 11 | RO | 0x00 (0dez)
 | 7010:1D | Data Out 12 | RO | 0x00 (0dez)
 | 7010:1E | Data Out 13 | RO | 0x00 (0dez)
 | 7010:1F | Data Out 14 | RO | 0x00 (0dez)
 | 7010:20 | Data Out 15 | RO | 0x00 (0dez)
 | 7010:21 | Data Out 16 | RO | 0x00 (0dez)
 | 7010:22 | Data Out 17 | RO | 0x00 (0dez)
 | 7010:23 | Data Out 18 | RO | 0x00 (0dez)
 | 7010:24 | Data Out 19 | RO | 0x00 (0dez)
 | 7010:25 | Data Out 20 | RO | 0x00 (0dez)
 | 7010:26 | Data Out 21 | RO | 0x00 (0dez)
7011:0 | Subindex | Ctrl Ch.2 | RO | 0x01 (1dez)
 | 7011:01 | Ctrl | RO | 0x0000 (0dez)
8000:0 | Subindex | COM Settings Ch.1 | RW | 0x1A (26dez)
 | 8000:02 | Enable XON/XOFF supported tx data | RW | 0x00 (0dez)
 | 8000:03 | Enable XON/XOFF supported rx data | RW | 0x00 (0dez)
 | 8000:04 | Enable send FIFO data continuous | RW | 0x00 (0dez)
 | 8000:05 | Enable transfer rate optimization | RW | 0x01 (1dez)
 | 8000:07 | Enable point to point connection (RS422) | RW | 0x00 (0dez)
 | 8000:11 | Baudrate | RW | 0x06 (6dez)
 | 8000:15 | Data frame | RW | 0x03 (3dez)
 | 8000:1A | Rx buffer full notification | RW | 0x0360 (864dez)
8010:0 | Subindex | COM Settings Ch.2 | RW | 0x1A (26dez)
 | 8010:02 | Enable XON/XOFF supported tx data | RW | 0x00 (0dez)
 | 8010:03 | Enable XON/XOFF supported rx data | RW | 0x00 (0dez)
 | 8010:04 | Enable send FIFO data continuous | RW | 0x00 (0dez)
 | 8010:05 | Enable transfer rate optimization | RW | 0x01 (1dez)
 | 8010:07 | Enable point to point connection (RS422) | RW | 0x00 (0dez)
 | 8010:11 | Baudrate | RW | 0x06 (6dez)
 | 8010:15 | Data frame | RW | 0x03 (3dez)
 | 8010:1A | Rx buffer full notification | RW | 0x0360 (864dez)
A000:0 | Subindex | COM Diag data Ch.1 | RO | 0x21 (33dez)
 | A000:01 | Buffer overflow | RO | 0x00 (0dez)
 | A000:02 | Parity error | RO | 0x00 (0dez)
 | A000:03 | Framing error | RO | 0x00 (0dez)
 | A000:04 | Overrun error | RO | 0x00 (0dez)
 | A000:05 | Buffer full | RO | 0x00 (0dez)
 | A000:11 | Data bytes in send buffer | RO | 0x0000 (0dez)
 | A000:21 | Data bytes in receive buffer | RO | 0x0000 (0dez)
A010:0 | Subindex | COM Diag data Ch.2 | RO | 0x21 (33dez)
 | A010:01 | Buffer overflow | RO | 0x00 (0dez)
 | A010:02 | Parity error | RO | 0x00 (0dez)
 | A010:03 | Framing error | RO | 0x00 (0dez)
 | A010:04 | Overrun error | RO | 0x00 (0dez)
 | A010:05 | Buffer full | RO | 0x00 (0dez)
 | A010:11 | Data bytes in send buffer | RO | 0x0000 (0dez)
 | A010:21 | Data bytes in receive buffer | RO | 0x0000 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0002 (2dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x02 (2dez)
 | F010:01 | SubIndex 001 | RW | 0x00000258 (600dez)
 | F010:02 | SubIndex 002 | RW | 0x00000258 (600dez)
F800:0 | Subindex | COM Settings | RW | 0x03 (3dez)
 | F800:01 | Interface Type Ch 1 | RW | 0x00 (0dez)
 | F800:02 | Interface Type Ch 2 | RW | 0x00 (0dez)
Legende

Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


EP6002 - Objektbeschreibung

BECKHOFF EP6002: Konfiguration

Objektbeschreibung und Parametrierung

Hinweis 		Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zur Auswahl des Schitstellen-Typs nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
  • Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte zur Parametrierung bei der Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 COM Settings Ch.1
Index | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | COM Settings Ch.1 |  |  | UINT8 | RO | 0x1A (26dez)
8000:02 | Enable XON/XOFF supported tx data | XON/XOFF wird für Sendedaten unterstützt |  | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable XON/XOFF supported rx data | XON/XOFF wird für Empfangsdaten unterstützt |  | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Enable send FIFO data continuous | Kontinuierliches Senden der Daten aus dem FIFO freigeschaltet |  | BOOLEAN | RW | 0x00 (0dez)
8000:05 | Enable transfer rate optimization | Einschalten der Transferraten-Optimierung |  | BOOLEAN | RW | 0x01 (1dez)
8000:06 | Enable half duplex | Halb-Duplex für RS485-Betrieb (dieses Bit wird im RS232- und RS422-Betrieb nicht ausgewertet) |  | BOOLEAN | RW | 0x00 (0dez)
 |  | 0 | Voll-Duplex: Das Modul hört seine gesendeten Daten mit.
 |  | 1 | Halb-Duplex: Das Modul hört die von ihm selbst gesendeten Daten nicht mit.
8000:07 | Enable point to point connection (RS422) | 0 | Das Modul wird nach der RS485 Norm in einer Busstruktur genutzt. | BOOLEAN | RW | 0x00 (0dez)
 |  | 1 | Das Modul wird als Punkt zu Punkt Verbindung genutzt (RS422)
8000:11 | Baudrate | Baud Rate |  | BIT4 | RW | 0x06 (6dez)
 |  | 0x01 | 300 Baud
 |  | 0x02 | 600 Baud
 |  | 0x03 | 1200 Baud
 |  | 0x04 | 2400 Baud
 |  | 0x05 | 4800 Baud
 |  | 0x06 | 9600 Baud
 |  | 0x07 | 19200 Baud
 |  | 0x08 | 38400 Baud
 |  | 0x09 | 57600 Baud
 |  | 0x0A | 115200 Baud
8000:15 | Data frame | Data frame / Stop-Bits |  | BIT4 | RW | 0x03 (3dez)
 |  | 0x01 | 7E1
 |  | 0x02 | 7O1
 |  | 0x03 | 8N1
 |  | 0x04 | 8E1
 |  | 0x05 | 8O1
 |  | 0x09 | 7E2
 |  | 0x0A | 7O2
 |  | 0x0B | 8N2
 |  | 0x0C | 8E2
 |  | 0x0D | 8O2
8000:1A | Rx buffer full notification | Der Wert legt die Anzahl der Daten im Empfangs-FIFO fest, ab der das "Buffer full" Bit gesetzt wird. |  | UINT16 | RW | 0x0360 (864dez)
Index 8010 COM Settings Ch.2
Index | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | COM Settings Ch.2 |  |  | UINT8 | RO | 0x1A (26dez)
8010:02 | Enable XON/XOFF supported tx data | XON/XOFF wird für Sendedaten unterstützt |  | BOOLEAN | RW | 0x00 (0dez)
8010:03 | Enable XON/XOFF supported rx data | XON/XOFF wird für Empfangsdaten unterstützt |  | BOOLEAN | RW | 0x00 (0dez)
8010:04 | Enable send FIFO data continuous | Kontinuierliches Senden der Daten aus dem FIFO freigeschaltet |  | BOOLEAN | RW | 0x00 (0dez)
8010:05 | Enable transfer rate optimization | Einschalten der Transferraten-Optimierung |  | BOOLEAN | RW | 0x01 (1dez)
8010:06 | Enable half duplex | Halb-Duplex für RS485-Betrieb (dieses Bit wird im RS232- und RS422-Betrieb nicht ausgewertet) |  | BOOLEAN | RW | 0x00 (0dez)
 |  | 0 | Voll-Duplex: Das Modul hört seine gesendeten Daten mit.
 |  | 1 | Halb-Duplex: Das Modul hört die von ihm selbst gesendeten Daten nicht mit.
8010:07 | Enable point to point connection (RS422) | 0 | Das Modul wird nach der RS485 Norm in einer Busstruktur genutzt. | BOOLEAN | RW | 0x00 (0dez)
 |  | 1 | Das Modul wird als Punkt zu Punkt Verbindung genutzt (RS422)
8010:11 | Baudrate | Baud Rate |  | BIT4 | RW | 0x06 (6dez)
 |  | 0x01 | 300 Baud
 |  | 0x02 | 600 Baud
 |  | 0x03 | 1200 Baud
 |  | 0x04 | 2400 Baud
 |  | 0x05 | 4800 Baud
 |  | 0x06 | 9600 Baud
 |  | 0x07 | 19200 Baud
 |  | 0x08 | 38400 Baud
 |  | 0x09 | 57600 Baud
 |  | 0x0A | 115200 Baud
8010:15 | Data frame | Data frame / Stop-Bits |  | BIT4 | RW | 0x03 (3dez)
 |  | 0x01 | 7E1
 |  | 0x02 | 7O1
 |  | 0x03 | 8N1
 |  | 0x04 | 8E1
 |  | 0x05 | 8O1
 |  | 0x09 | 7E2
 |  | 0x0A | 7O2
 |  | 0x0B | 8N2
 |  | 0x0C | 8E2
 |  | 0x0D | 8O2
8010:1A | Rx buffer full notification | Der Wert legt die Anzahl der Daten im Empfangs-FIFO fest, ab der das "Buffer full" Bit gesetzt wird. |  | UINT16 | RW | 0x0360 (864dez)
Index F800 COM Settings
Index | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | COM Settings |  |  | UINT8 | RO | 0x03 (3dez)
F800:01 | Interface Type Ch 1 | 0x00 | RS232 | BIT1 | RW | 0x00 (0dez)
 |  | 0x01 | RS485/422
F800:02 | Interface Type Ch 2 | 0x00 | RS232 | BIT1 | RW | 0x00 (0dez)
 |  | 0x01 | RS485/422

Objekte für den regulären Betrieb

Die EP6002 verfügt über keine solchen Objekte.

Weitere Objekte

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x02581389 (39326601dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP6002-0002
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x17724052 (393363538dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100002 (1048578dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 COM RxPDO-Par Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | COM RxPDO-Par Outputs Ch.1 | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 16
Index 1401 COM RxPDO-Par Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | COM RxPDO-Par Outputs Ch.2 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 16
Index 1404 COM RxPDO-Par Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | COM RxPDO-Par Outputs Ch.1 | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1405 COM RxPDO-Par Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | COM RxPDO-Par Outputs Ch.2 | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1600 COM RxPDO-Map Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | COM RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x1C (28dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x01 (Transmit request)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x02 (Receive accepted)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x03 (Init request)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x04 (Send continuous)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x09 (Output length)) | UINT32 | RO | 0x7000:09, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x11 (Data Out 0)) | UINT32 | RO | 0x7000:11, 8
1600:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x12 (Data Out 1)) | UINT32 | RO | 0x7000:12, 8
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x13 (Data Out 2)) | UINT32 | RO | 0x7000:13, 8
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x14 (Data Out 3)) | UINT32 | RO | 0x7000:14, 8
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x15 (Data Out 4)) | UINT32 | RO | 0x7000:15, 8
1600:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x16 (Data Out 5)) | UINT32 | RO | 0x7000:16, 8
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x17 (Data Out 6)) | UINT32 | RO | 0x7000:17, 8
1600:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x18 (Data Out 7)) | UINT32 | RO | 0x7000:18, 8
1600:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x19 (Data Out 8)) | UINT32 | RO | 0x7000:19, 8
1600:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1A (Data Out 9)) | UINT32 | RO | 0x7000:1A, 8
1600:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1B (Data Out 10)) | UINT32 | RO | 0x7000:1B, 8
1600:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1C (Data Out 11)) | UINT32 | RO | 0x7000:1C, 8
1600:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1D (Data Out 12)) | UINT32 | RO | 0x7000:1D, 8
1600:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1E (Data Out 13)) | UINT32 | RO | 0x7000:1E, 8
1600:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1F (Data Out 14)) | UINT32 | RO | 0x7000:1F, 8
1600:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x20 (Data Out 15)) | UINT32 | RO | 0x7000:20, 8
1600:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x21 (Data Out 16)) | UINT32 | RO | 0x7000:21, 8
1600:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x22 (Data Out 17)) | UINT32 | RO | 0x7000:22, 8
1600:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x23 (Data Out 18)) | UINT32 | RO | 0x7000:23, 8
1600:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x24 (Data Out 19)) | UINT32 | RO | 0x7000:24, 8
1600:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x25 (Data Out 20)) | UINT32 | RO | 0x7000:25, 8
1600:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x26 (Data Out 21)) | UINT32 | RO | 0x7000:26, 8
Index 1601 COM RxPDO-Map Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | COM RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x1C (28dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x01 (Transmit request)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x02 (Receive accepted)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x03 (Init request)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x04 (Send continuous)) | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x09 (Output length)) | UINT32 | RO | 0x7010:09, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x11 (Data Out 0)) | UINT32 | RO | 0x7010:11, 8
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x12 (Data Out 1)) | UINT32 | RO | 0x7010:12, 8
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x13 (Data Out 2)) | UINT32 | RO | 0x7010:13, 8
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x14 (Data Out 3)) | UINT32 | RO | 0x7010:14, 8
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x15 (Data Out 4)) | UINT32 | RO | 0x7010:15, 8
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x16 (Data Out 5)) | UINT32 | RO | 0x7010:16, 8
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x17 (Data Out 6)) | UINT32 | RO | 0x7010:17, 8
1601:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x18 (Data Out 7)) | UINT32 | RO | 0x7010:18, 8
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x19 (Data Out 8)) | UINT32 | RO | 0x7010:19, 8
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1A (Data Out 9)) | UINT32 | RO | 0x7010:1A, 8
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1B (Data Out 10)) | UINT32 | RO | 0x7010:1B, 8
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1C (Data Out 11)) | UINT32 | RO | 0x7010:1C, 8
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1D (Data Out 12)) | UINT32 | RO | 0x7010:1D, 8
1601:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1E (Data Out 13)) | UINT32 | RO | 0x7010:1E, 8
1601:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1F (Data Out 14)) | UINT32 | RO | 0x7010:1F, 8
1601:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x20 (Data Out 15)) | UINT32 | RO | 0x7010:20, 8
1601:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x21 (Data Out 16)) | UINT32 | RO | 0x7010:21, 8
1601:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x22 (Data Out 17)) | UINT32 | RO | 0x7010:22, 8
1601:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x23 (Data Out 18)) | UINT32 | RO | 0x7010:23, 8
1601:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x24 (Data Out 19)) | UINT32 | RO | 0x7010:24, 8
1601:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x25 (Data Out 20)) | UINT32 | RO | 0x7010:25, 8
1601:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x26 (Data Out 21)) | UINT32 | RO | 0x7010:26, 8
Index 1604 COM RxPDO-Map Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | COM RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x17 (23dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (Ctrl Ch.1), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7001:01, 16
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x11 (Data Out 0)) | UINT32 | RO | 0x7000:11, 8
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x12 (Data Out 1)) | UINT32 | RO | 0x7000:12, 8
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x13 (Data Out 2)) | UINT32 | RO | 0x7000:13, 8
1604:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x14 (Data Out 3)) | UINT32 | RO | 0x7000:14, 8
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x15 (Data Out 4)) | UINT32 | RO | 0x7000:15, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x16 (Data Out 5)) | UINT32 | RO | 0x7000:16, 8
1604:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x17 (Data Out 6)) | UINT32 | RO | 0x7000:17, 8
1604:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x18 (Data Out 7)) | UINT32 | RO | 0x7000:18, 8
1604:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x19 (Data Out 8)) | UINT32 | RO | 0x7000:19, 8
1604:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1A (Data Out 9)) | UINT32 | RO | 0x7000:1A, 8
1604:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1B (Data Out 10)) | UINT32 | RO | 0x7000:1B, 8
1604:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1C (Data Out 11)) | UINT32 | RO | 0x7000:1C, 8
1604:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1D (Data Out 12)) | UINT32 | RO | 0x7000:1D, 8
1604:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1E (Data Out 13)) | UINT32 | RO | 0x7000:1E, 8
1604:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x1F (Data Out 14)) | UINT32 | RO | 0x7000:1F, 8
1604:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x20 (Data Out 15)) | UINT32 | RO | 0x7000:20, 8
1604:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x21 (Data Out 16)) | UINT32 | RO | 0x7000:21, 8
1604:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x22 (Data Out 17)) | UINT32 | RO | 0x7000:22, 8
1604:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x23 (Data Out 18)) | UINT32 | RO | 0x7000:23, 8
1604:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x24 (Data Out 19)) | UINT32 | RO | 0x7000:24, 8
1604:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x25 (Data Out 20)) | UINT32 | RO | 0x7000:25, 8
1604:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7000 (COM Outputs Ch.1), entry 0x26 (Data Out 21)) | UINT32 | RO | 0x7000:26, 8
Index 1605 COM RxPDO-Map Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | COM RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x17 (23dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (Ctrl Ch.2), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7011:01, 16
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x11 (Data Out 0)) | UINT32 | RO | 0x7010:11, 8
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x12 (Data Out 1)) | UINT32 | RO | 0x7010:12, 8
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x13 (Data Out 2)) | UINT32 | RO | 0x7010:13, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x14 (Data Out 3)) | UINT32 | RO | 0x7010:14, 8
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x15 (Data Out 4)) | UINT32 | RO | 0x7010:15, 8
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x16 (Data Out 5)) | UINT32 | RO | 0x7010:16, 8
1605:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x17 (Data Out 6)) | UINT32 | RO | 0x7010:17, 8
1605:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x18 (Data Out 7)) | UINT32 | RO | 0x7010:18, 8
1605:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x19 (Data Out 8)) | UINT32 | RO | 0x7010:19, 8
1605:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1A (Data Out 9)) | UINT32 | RO | 0x7010:1A, 8
1605:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1B (Data Out 10)) | UINT32 | RO | 0x7010:1B, 8
1605:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1C (Data Out 11)) | UINT32 | RO | 0x7010:1C, 8
1605:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1D (Data Out 12)) | UINT32 | RO | 0x7010:1D, 8
1605:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1E (Data Out 13)) | UINT32 | RO | 0x7010:1E, 8
1605:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x1F (Data Out 14)) | UINT32 | RO | 0x7010:1F, 8
1605:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x20 (Data Out 15)) | UINT32 | RO | 0x7010:20, 8
1605:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x21 (Data Out 16)) | UINT32 | RO | 0x7010:21, 8
1605:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x22 (Data Out 17)) | UINT32 | RO | 0x7010:22, 8
1605:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x23 (Data Out 18)) | UINT32 | RO | 0x7010:23, 8
1605:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x24 (Data Out 19)) | UINT32 | RO | 0x7010:24, 8
1605:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x25 (Data Out 20)) | UINT32 | RO | 0x7010:25, 8
1605:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7010 (COM Outputs Ch.2), entry 0x26 (Data Out 21)) | UINT32 | RO | 0x7010:26, 8
Index 1800 COM TxPDO-Par Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | COM TxPDO-Par Inputs Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
Index 1801 COM TxPDO-Par Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | COM TxPDO-Par Inputs Ch.2 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1804 COM TxPDO-Par Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | COM TxPDO-Par Inputs Ch.1 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1805 COM TxPDO-Par Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | COM TxPDO-Par Inputs Ch.2 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1A00 COM TxPDO-Map Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | COM TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x1F (31dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x01 (Transmit accepted)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x02 (Receive request)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x03 (Init accepted)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x04 (Buffer full)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x05 (Parity error)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x06 (Framing error)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x07 (Overrun error)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x09 (Input length)) | UINT32 | RO | 0x6000:09, 8
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x11 (Data In 0)) | UINT32 | RO | 0x6000:11, 8
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x12 (Data In 1)) | UINT32 | RO | 0x6000:12, 8
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x13 (Data In 2)) | UINT32 | RO | 0x6000:13, 8
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x14 (Data In 3)) | UINT32 | RO | 0x6000:14, 8
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x15 (Data In 4)) | UINT32 | RO | 0x6000:15, 8
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x16 (Data In 5)) | UINT32 | RO | 0x6000:16, 8
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x17 (Data In 6)) | UINT32 | RO | 0x6000:17, 8
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x18 (Data In 7)) | UINT32 | RO | 0x6000:18, 8
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x19 (Data In 8)) | UINT32 | RO | 0x6000:19, 8
1A00:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1A (Data In 9)) | UINT32 | RO | 0x6000:1A, 8
1A00:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1B (Data In 10)) | UINT32 | RO | 0x6000:1B, 8
1A00:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1C (Data In 11)) | UINT32 | RO | 0x6000:1C, 8
1A00:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1D (Data In 12)) | UINT32 | RO | 0x6000:1D, 8
1A00:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1E (Data In 13)) | UINT32 | RO | 0x6000:1E, 8
1A00:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1F (Data In 14)) | UINT32 | RO | 0x6000:1F, 8
1A00:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x20 (Data In 15)) | UINT32 | RO | 0x6000:20, 8
1A00:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x21 (Data In 16)) | UINT32 | RO | 0x6000:21, 8
1A00:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x22 (Data In 17)) | UINT32 | RO | 0x6000:22, 8
1A00:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x23 (Data In 18)) | UINT32 | RO | 0x6000:23, 8
1A00:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x24 (Data In 19)) | UINT32 | RO | 0x6000:24, 8
1A00:1E | SubIndex 030 | 30. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x25 (Data In 20)) | UINT32 | RO | 0x6000:25, 8
1A00:1F | SubIndex 031 | 31. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x26 (Data In 21)) | UINT32 | RO | 0x6000:26, 8
Index 1A01 COM TxPDO-Map Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | COM TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x1F (31dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x01 (Transmit accepted)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x02 (Receive request)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x03 (Init accepted)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x04 (Buffer full)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x05 (Parity error)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x06 (Framing error)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x07 (Overrun error)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x09 (Input length)) | UINT32 | RO | 0x6010:09, 8
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x11 (Data In 0)) | UINT32 | RO | 0x6010:11, 8
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x12 (Data In 1)) | UINT32 | RO | 0x6010:12, 8
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x13 (Data In 2)) | UINT32 | RO | 0x6010:13, 8
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x14 (Data In 3)) | UINT32 | RO | 0x6010:14, 8
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x15 (Data In 4)) | UINT32 | RO | 0x6010:15, 8
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x16 (Data In 5)) | UINT32 | RO | 0x6010:16, 8
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x17 (Data In 6)) | UINT32 | RO | 0x6010:17, 8
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x18 (Data In 7)) | UINT32 | RO | 0x6010:18, 8
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x19 (Data In 8)) | UINT32 | RO | 0x6010:19, 8
1A01:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1A (Data In 9)) | UINT32 | RO | 0x6010:1A, 8
1A01:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1B (Data In 10)) | UINT32 | RO | 0x6010:1B, 8
1A01:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1C (Data In 11)) | UINT32 | RO | 0x6010:1C, 8
1A01:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1D (Data In 12)) | UINT32 | RO | 0x6010:1D, 8
1A01:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1E (Data In 13)) | UINT32 | RO | 0x6010:1E, 8
1A01:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1F (Data In 14)) | UINT32 | RO | 0x6010:1F, 8
1A01:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x20 (Data In 15)) | UINT32 | RO | 0x6010:20, 8
1A01:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x21 (Data In 16)) | UINT32 | RO | 0x6010:21, 8
1A01:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x22 (Data In 17)) | UINT32 | RO | 0x6010:22, 8
1A01:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x23 (Data In 18)) | UINT32 | RO | 0x6010:23, 8
1A01:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x24 (Data In 19)) | UINT32 | RO | 0x6010:24, 8
1A01:1E | SubIndex 030 | 30. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x25 (Data In 20)) | UINT32 | RO | 0x6010:25, 8
1A01:1F | SubIndex 031 | 31. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x26 (Data In 21)) | UINT32 | RO | 0x6010:26, 8
Index 1A04 COM TxPDO-Map Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | COM TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x17 (23dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Status Ch.1), entry 0x01 (Status)) | UINT32 | RO | 0x6001:01, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x11 (Data In 0)) | UINT32 | RO | 0x6000:11, 8
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x12 (Data In 1)) | UINT32 | RO | 0x6000:12, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x13 (Data In 2)) | UINT32 | RO | 0x6000:13, 8
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x14 (Data In 3)) | UINT32 | RO | 0x6000:14, 8
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x15 (Data In 4)) | UINT32 | RO | 0x6000:15, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x16 (Data In 5)) | UINT32 | RO | 0x6000:16, 8
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x17 (Data In 6)) | UINT32 | RO | 0x6000:17, 8
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x18 (Data In 7)) | UINT32 | RO | 0x6000:18, 8
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x19 (Data In 8)) | UINT32 | RO | 0x6000:19, 8
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1A (Data In 9)) | UINT32 | RO | 0x6000:1A, 8
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1B (Data In 10)) | UINT32 | RO | 0x6000:1B, 8
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1C (Data In 11)) | UINT32 | RO | 0x6000:1C, 8
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1D (Data In 12)) | UINT32 | RO | 0x6000:1D, 8
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1E (Data In 13)) | UINT32 | RO | 0x6000:1E, 8
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x1F (Data In 14)) | UINT32 | RO | 0x6000:1F, 8
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x20 (Data In 15)) | UINT32 | RO | 0x6000:20, 8
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x21 (Data In 16)) | UINT32 | RO | 0x6000:21, 8
1A04:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x22 (Data In 17)) | UINT32 | RO | 0x6000:22, 8
1A04:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x23 (Data In 18)) | UINT32 | RO | 0x6000:23, 8
1A04:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x24 (Data In 19)) | UINT32 | RO | 0x6000:24, 8
1A04:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x25 (Data In 20)) | UINT32 | RO | 0x6000:25, 8
1A04:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 (COM Inputs Ch.1), entry 0x26 (Data In 21)) | UINT32 | RO | 0x6000:26, 8
Index 1A05 COM TxPDO-Map Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | COM TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x17 (23dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Status Ch.2), entry 0x01 (Status)) | UINT32 | RO | 0x6011:01, 16
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x11 (Data In 0)) | UINT32 | RO | 0x6010:11, 8
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x12 (Data In 1)) | UINT32 | RO | 0x6010:12, 8
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x13 (Data In 2)) | UINT32 | RO | 0x6010:13, 8
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x14 (Data In 3)) | UINT32 | RO | 0x6010:14, 8
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x15 (Data In 4)) | UINT32 | RO | 0x6010:15, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x16 (Data In 5)) | UINT32 | RO | 0x6010:16, 8
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x17 (Data In 6)) | UINT32 | RO | 0x6010:17, 8
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x18 (Data In 7)) | UINT32 | RO | 0x6010:18, 8
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x19 (Data In 8)) | UINT32 | RO | 0x6010:19, 8
1A05:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1A (Data In 9)) | UINT32 | RO | 0x6010:1A, 8
1A05:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1B (Data In 10)) | UINT32 | RO | 0x6010:1B, 8
1A05:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1C (Data In 11)) | UINT32 | RO | 0x6010:1C, 8
1A05:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1D (Data In 12)) | UINT32 | RO | 0x6010:1D, 8
1A05:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1E (Data In 13)) | UINT32 | RO | 0x6010:1E, 8
1A05:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x1F (Data In 14)) | UINT32 | RO | 0x6010:1F, 8
1A05:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x20 (Data In 15)) | UINT32 | RO | 0x6010:20, 8
1A05:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x21 (Data In 16)) | UINT32 | RO | 0x6010:21, 8
1A05:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x22 (Data In 17)) | UINT32 | RO | 0x6010:22, 8
1A05:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x23 (Data In 18)) | UINT32 | RO | 0x6010:23, 8
1A05:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x24 (Data In 19)) | UINT32 | RO | 0x6010:24, 8
1A05:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x25 (Data In 20)) | UINT32 | RO | 0x6010:25, 8
1A05:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6010 (COM Inputs Ch.2), entry 0x26 (Data In 21)) | UINT32 | RO | 0x6010:26, 8
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1605 (5637dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A05 (6661dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0000 (0dez)
1C32:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron with SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
 UINT32 RW 0x000F4240 (1000000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0 = 1: Free Run wird unterstützt
  • Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
 UINT16 RO 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x00002710 (10000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:07 | Minimum delay time | UINT32 | RO | 0x00000384 (900dez)
1C32:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestoppt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt

UINT16 RW 0x0000 (0dez)
1C32:09 | Maximum Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x000F4240 (1000000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x00002710 (10000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000384 (900dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 COM Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | COM Inputs Ch.1 |  | UINT8 | RO | 0x26 (38dez)
6000:01 | Transmit accepted | Das Modul quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Receive request | Über eine Zustandsänderung dieses Bits teilt das Modul der Steuerung mit, dass sich die in "Input length" angezeigte Anzahl von Bytes in den DataIn-Bytes befinden | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Init accepted | Die Initialisierung wurde von der Klemme durchgeführt | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Buffer full | Das Empfangs-FIFO ist voll | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Parity error | Es ist ein Parity-Error aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Framing error | Es ist ein Framing-Error aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Overrun error | Es ist ein Overrun-Error aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Input length | Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen | UINT8 | RO | 0x00 (0dez)
6000:11 | Data In 0 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:12 | Data In 1 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:13 | Data In 2 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:14 | Data In 3 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:15 | Data In 4 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:16 | Data In 5 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:17 | Data In 6 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:18 | Data In 7 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:19 | Data In 8 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:1A | Data In 9 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:1B | Data In 10 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:1C | Data In 11 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:1D | Data In 12 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:1E | Data In 13 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:1F | Data In 14 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:20 | Data In 15 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:21 | Data In 16 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:22 | Data In 17 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:23 | Data In 18 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:24 | Data In 19 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:25 | Data In 20 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6000:26 | Data In 21 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
Index 6001 Status Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6001:0 | Status Ch.1 |  | UINT8 | RO | 0x01 (1dez)
6001:01 | Status | Statusl-Wort für kompatibles Prozessabbild | UINT16 | RO | 0x0000 (0dez)
Index 6010 COM Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | COM Inputs Ch.2 |  | UINT8 | RO | 0x26 (38dez)
6010:01 | Transmit accepted | Das Modul quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Receive request | Über eine Zustandsänderung dieses Bits teilt das Modul der Steuerung mit, dass sich die in "Input length" angezeigte Anzahl von Bytes in den DataIn-Bytes befinden | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Init accepted | Die Initialisierung wurde von der Klemme durchgeführt | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Buffer full | Das Empfangs-FIFO ist voll | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Parity error | Es ist ein Parity-Error aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Framing error | Es ist ein Framing-Error aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Overrun error | Es ist ein Overrun-Error aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:09 | Input length | Anzahl der Eingangs-Bytes, die für die Übertragung von der Klemme zur Steuerung bereit stehen | UINT8 | RO | 0x00 (0dez)
6010:11 | Data In 0 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:12 | Data In 1 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:13 | Data In 2 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:14 | Data In 3 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:15 | Data In 4 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:16 | Data In 5 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:17 | Data In 6 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:18 | Data In 7 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:19 | Data In 8 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:1A | Data In 9 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:1B | Data In 10 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:1C | Data In 11 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:1D | Data In 12 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:1E | Data In 13 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:1F | Data In 14 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:20 | Data In 15 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:21 | Data In 16 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:22 | Data In 17 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:23 | Data In 18 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:24 | Data In 19 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:25 | Data In 20 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
6010:26 | Data In 21 | Eingangsdaten | UINT8 | RO | 0x00 (0dez)
Index 6011 Status Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
6011:0 | Status Ch.2 |  | UINT8 | RO | 0x01 (1dez)
6011:01 | Status | Statusl-Wort für kompatibles Prozessabbild | UINT16 | RO | 0x0000 (0dez)
Index 7000 COM Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | COM Outputs Ch.1 |  | UINT8 | RO | 0x26 (38dez)
7000:01 | Transmit request | Über eine Zustandsänderung dieses Bits teilt die Steuerung der Klemme mit, dass sich die in "Output length" angezeigte Anzahl von Bytes in den DataOut-Bytes befinden. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Receive accepted | Die Steuerung quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Init request | Die Steuerung fordert das Modul zur Initialisierung auf. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Send continuous | Kontinuierliches Senden der Daten aus dem FIFO. | BOOLEAN | RO | 0x00 (0dez)
7000:09 | Output length | Anzahl der Ausgangs-Bytes, die für die Übertragung von der Steuerung zur Klemme bereit stehen. | UINT8 | RO | 0x00 (0dez)
7000:11 | Data Out 0 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:12 | Data Out 1 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:13 | Data Out 2 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:14 | Data Out 3 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:15 | Data Out 4 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:16 | Data Out 5 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:17 | Data Out 6 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:18 | Data Out 7 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:19 | Data Out 8 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:1A | Data Out 9 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:1B | Data Out 10 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:1C | Data Out 11 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:1D | Data Out 12 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:1E | Data Out 13 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:1F | Data Out 14 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:20 | Data Out 15 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:21 | Data Out 16 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:22 | Data Out 17 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:23 | Data Out 18 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:24 | Data Out 19 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:25 | Data Out 20 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7000:26 | Data Out 21 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
Index 7001 Ctrl Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
7001:0 | Ctrl Ch.1 |  | UINT8 | RO | 0x01 (1dez)
7001:01 | Ctrl | Control-Wort für kompatibles Prozessabbild | UINT16 | RO | 0x0000 (0dez)
Index 7010 COM Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | COM Outputs Ch.2 |  | UINT8 | RO | 0x26 (38dez)
7010:01 | Transmit request | Über eine Zustandsänderung dieses Bits teilt die Steuerung der Klemme mit, dass sich die in "Output length" angezeigte Anzahl von Bytes in den DataOut-Bytes befinden. | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Receive accepted | Die Steuerung quittiert die Entgegennahme von Daten mit Zustandsänderung dieses Bits. | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Init request | Die Steuerung fordert das Modul zur Initialisierung auf. | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Send continuous | Kontinuierliches Senden der Daten aus dem FIFO. | BOOLEAN | RO | 0x00 (0dez)
7010:09 | Output length | Anzahl der Ausgangs-Bytes, die für die Übertragung von der Steuerung zur Klemme bereit stehen. | UINT8 | RO | 0x00 (0dez)
7010:11 | Data Out 0 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:12 | Data Out 1 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:13 | Data Out 2 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:14 | Data Out 3 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:15 | Data Out 4 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:16 | Data Out 5 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:17 | Data Out 6 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:18 | Data Out 7 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:19 | Data Out 8 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:1A | Data Out 9 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:1B | Data Out 10 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:1C | Data Out 11 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:1D | Data Out 12 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:1E | Data Out 13 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:1F | Data Out 14 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:20 | Data Out 15 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:21 | Data Out 16 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:22 | Data Out 17 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:23 | Data Out 18 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:24 | Data Out 19 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:25 | Data Out 20 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
7010:26 | Data Out 21 | Ausgangsdaten | UINT8 | RO | 0x00 (0dez)
Index 7011 Ctrl Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
7011:0 | Ctrl Ch.2 |  | UINT8 | RO | 0x01 (1dez)
7011:01 | Ctrl | Control-Wort für kompatibles Prozessabbild | UINT16 | RO | 0x0000 (0dez)
Index A000 COM Diag data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | COM Diag data Ch.1 |  | UINT8 | RO | 0x21 (33dez)
A000:01 | Buffer overflow | Es ist ein Buffer-Overflow aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Parity error | Es ist ein Parity-Error aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Framing error | Es ist ein Framing-Error aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A000:04 | Overrun error | Es ist ein Overrun-Error aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A000:05 | Buffer full | Das Empfangs-FIFO ist voll. | BOOLEAN | RO | 0x00 (0dez)
A000:11 | Data bytes in send buffer | Anzahl der Datenbytes im Sende-FIFO | UINT16 | RO | 0x0000 (0dez)
A000:21 | Data bytes in receive buffer | Anzahl der Datenbytes im Empfangs-FIFO | UINT16 | RO | 0x0000 (0dez)
Index A010 COM Diag data Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
A010:0 | COM Diag data Ch.2 |  | UINT8 | RO | 0x21 (33dez)
A010:01 | Buffer overflow | Es ist ein Buffer-Overflow aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A010:02 | Parity error | Es ist ein Parity-Error aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A010:03 | Framing error | Es ist ein Framing-Error aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A010:04 | Overrun error | Es ist ein Overrun-Error aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
A010:05 | Buffer full | Das Empfangs-FIFO ist voll. | BOOLEAN | RO | 0x00 (0dez)
A010:11 | Data bytes in send buffer | Anzahl der Datenbytes im Sende-FIFO | UINT16 | RO | 0x0000 (0dez)
A010:21 | Data bytes in receive buffer | Anzahl der Datenbytes im Empfangs-FIFO | UINT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000258 (600dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000258 (600dez)


EP6002-0002 - Beispielprogramm 1

BECKHOFF EP6002-0002: Inbetriebnahme/Konfiguration

Beispielprogramm 1

Hinweis 		Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen den typischen Eigenschaften unsere Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle. Daher liegt es in der Verantwortung des Kunden zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.

Anschluss eines seriellen Barcodescanners

Download:

In diesem Beispiel wird ein Barcode-Lesegerät am EP6002 angeschlossen. Dabei werden von dem Lesegerät solange Zeichen gelesen, bis das ASCII-Zeichen 0x0D (13dez, CR) empfangen wurde.

Daten:

  • Schnell Task zur Abwicklung der seriellen Kommunikation: 1 ms Zykluszeit
  • Standard SPS Task: 10 ms Zykluszeit
  • Barcodescanner an Kanal 1
  • TWinCAT 2.11 erforderlich
  • Supplement "TwinCAT-PLC-Serial-Communication" erforderlich

Eine detaillierte Beschreibung zur Verwendung der Serial-Communication Library ist im Beckhoff Information System hinterlegt.

Beckhoff Information System -> TwinCAT -> TwinCAT PLC -> TwinCAT Bibliotheken für PC-basierende Systeme -> TwinCAT PLC Library : Serielle Kommunikation

Starten des Beispielprogramms

Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.

Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.

Für den Prüfaufbau wurde folgende Hardware und Software verwendet:

  • TwinCAT-Master-PC mit Betriebssystem Windows XP Professional SP 3, TwinCAT Version 2.11 (Build 1528) und INTEL PRO/100 VE Ethernet-Adapter
  • Beckhoff EtherCAT Box EP6002
  • Serieller Barcodescanner

Vorgehensweise zum Starten des Programms

  • Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.TSM (Konfigurationsdatei und *.PRO (PLC-Programmdatei) in einem temporären Arbeitsordner
  • Start der *.TSM-Datei und *.PRO Datei; der TwinCAT-System Manger und die TwinCAT PLC öffnen sich
  • Schließen Sie die Hardware entsprechend Abb. 1 an und verbinden Sie den Ethernet-Adapter ihres PCs mit dem EtherCAT-Koppler (weitere Hinweise hierzu finden sie in den entsprechenden Kopplerhandbüchern)
  • Auswahl des lokalen Ethernet-Adapters (ggf. mit Echtzeit-Treiber) unter Systemkonfiguration, E/A - Konfiguration, E/A -Geräte, Gerät (EtherCAT); dann unter Karteireiter "Adapter", "Suchen..." den entsprechenden Adapter auswählen und bestätigen (siehe Abb. 2a + 2 b)

    Abb. 2a: Suchen des Ethernet-Adapters

    Abb. 2b: Auswahl und Bestätigung des Ethernet-Adapters

  • Aktivierung der Konfiguration und bestätigen (Abb. 3a +3b)

    Abb. 3: Aktivierung der Konfiguration

    Abb. 3b: Konfigurationsaktivierung bestätigen

  • Neue Variablenzuordnung bestätigen, Neustart im RUN-Modus (Abb. 4a + 4b)

    Abb. 4a: Variablenzuordnung erzeugen

    Abb. 4b: Neustart TwinCAT im RUN-Modus

  • In der TwinCAT PLC unter Menü "Projekt" -> "Alles Übersetzen" das Projekt übersetzen (Abb. 5)

    Abb. 5: Projekt übersetzen

  • In der TwinCAT PLC: Einloggen mit der Taste "F11", Laden des Programms bestätigen (Abb. 6), Start des Programms mit Taste "F5"

    Abb. 6: Programmstart bestätigen

  • Nachdem das Zeichen 0x13 empfangen wurde, wird der Barcode in "LastBarcode" abgelegt.

    Abb. 7: Empfangener Barcode


EP6002-0002 - Beispielprogramm 2

BECKHOFF EP6002-0002: Inbetriebnahme/Konfiguration

Beispielprogramm 2

Hinweis 		Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen den typischen Eigenschaften unsere Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Kunden zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Download Beispielprogramm:

Lesen und Interpretation von Zeittelegrammen

In diesem Beispiel wird ein Weg aufgezeigt, wie verschiedenste serielle Zeitprotokolle in der SPS aufbereitet und interpretiert werden können. Dazu werden IEC61131-PLC-Bausteine vorgestellt, die den in der PLC eintreffenden Bitstrom interpretieren und ggf. die Zeit / Ortsinformationen extrahieren. Mit dieser Information können z.B. Steuerungen synchronisiert oder Bewegungen aufgezeichnet werden

In diesem Beispiel wird davon ausgegangen, dass die Daten über ein 22-Byte-Interface von einer Beckhoff EL / KL60xx seriellen Datenaustauschklemme geliefert werden.

Hintergrundinformation

Nicht nur im maritimen Bereich werden Zeit- und Ortsinformationen über serielle Busse transportiert: meist existiert eine Quelle, die über RS232 / RS485, USB oder Ethernet ihre Informationen an untergeordnete Listener/Listener zyklisch oder nach Trigger verteilt.

Weltweit existieren eine sehr große Anzahl von Telegrammformaten zur Verteilung von Zeit- und Ortsinformationen, auch "Sentences" genannt. Solch ein Telegramm besteht aus n Byte Daten und zeichnet sich aus durch:

  • Start- und Endezeichen STX, ETX zur Telegramm-Erkennung, ggf. auch mehrere Endezeichen
  • eine definierte und feste Länge
  • einen definierten Aufbau
  • ggf. Checksumme
  • ggf. Typbezeichnungen im Sentence
Verschiedenste Organisationen und Firmen haben für spezifische Einsatzzwecke offene oder proprietäre Formate entwickelt. Deshalb werden in diesem Beispiel 2 Beispielimplementationen vorgestellt, die kundenseitig leicht für spezifische andere Protokolle geändert werden können. Die Telegrammformate im Beispiel sind Meinberg Standard und NMEA0183 v2.3 Typ RMC.

Informationsquellen

Als Datensender im seriellen Bereich werden z. B. GPS- oder Funkuhrengateways verwendet. Diese Geräte empfangen das jeweilige Zeitsignal (GPS über Satellit oder Funkuhr über Langwelle) und setzen es auf die serielle drahtgebundene Übertragung um, z.B. RS232 mit 8N1. Dabei hält das Gateway oft auch eine lokale Taktquelle vor, um bei kurzzeitigem Ausfall des Referenzsignals (GPS, Funksender) über eine gewisse Zeit weiter verlässliche Zeitinformationen verteilen zu können. In Mitteleuropa kann der deutsche DCF77-Sender verwendet werden.

Dabei können aus dem Referenzsignal ggf. noch weitere Informationen verwendet werden:

  • GPS: Standortinformationen (W/N und Höhe), anstehende Zeitumstellung DCF77: Wetterinformationen, Großschadenslagen
  • DCF77: Wetterinformationen, Großschadenslagen

Synchronisierung untergeordneter Time-Slaves

Im Allgemeinen sollen untergeordnete Slaves dem Zeitgateway nachgeregelt werden, d.h. sie sollen sich in ihrer Zeit aufsynchronisieren. Dazu sind nötig:
  • der Offset: die absolute Abweichung der eigenen Uhr zur Referenzzeit des Gateways – diese Information kann z.B. azyklisch seriell übertragen werden wenn bekannt ist, wann die Zeitinformation als gültig anzusehen ist. Der serielle Transportweg aus deinem Beispiel ermöglicht die Gewinnung dieser Offset-Information.
  • das Frequenzverhältnis: ein hochgenau zyklisches Signal vom Gateway zu den Slaves erlaubt das Ausregeln von Driftvorgängen und gibt ggf. auch den Zeitpunkt an, wann der obige absolute Offset gültig ist. Beispiel für ein solches Signal ist das weitverbreitete PPS (Pulse per Second).

Wird das serielle Telegramm vom Gateway zyklisch auf den Bus gelegt, kann der Zeitpunkt des ersten Bits oft als PPS-Signal interpretiert werden. In den Bausteinen dieses Beispiels geht diese Information verloren; es wird nur die absolute Zeitinformation ausgewertet.

Zeitformate

Weit verbreitet sind Zeittelegramme nach dem NMEA0183-Standard. Dabei ist zu beachten:
  • Innerhalb der NMEA0183-Standards gibt es aktuell (2009) 8 Versionen von NMEA1083 1.5 bis 4.00 – der Aufbau von Telegrammen kann sich zwischen den Versionen geändert haben
  • Allein in NMEA1083 v2.30 sind über 70 verschiedene Formate definiert, dazu können Gerätehersteller eigene Formate erstellen
  • Das Telegramm wird Sentence genannt
  • Eine TalkerID (2 Zeichen) und eine TypID (3 Zeichen) am Beginn definieren den verwendeten Sentence-Typ
  • Es wird eine Checksumme über das Telegramm berechnet
  • Informationen sind unter www.nmea.org oder anderweitig online einsichtlich.
Des weiteren existieren viele proprietäre Formate wie Meinberg Standard, Siemens SINEC H1, SAT 1703 oder militärische wie IRIG-Codes (USA).

Anwendung des Beispielprogramms

Im PLC-Projekt sind 2 FunctionBlocks (FB) enthalten, die exklusiv mit einer EL/KL600x verlinkt werden müssen. Dann holen Sie von der Klemme die empfangenen Bytes ab und interpretieren nach Möglichkeit den Inhalt. Die FB decken ab:
  • Meinberg Standard
  • NMEA0183 v2.3 Typ RMC

Für andere Zeitformate lassen sich danach eigene Interpretations-FB anhand eines bekannten Telegrammaufbaus erstellen, wenden Sie sich dazu an Ihren Gerätehersteller.

Im Beispiel verwendete Hardware: EK1100 und EL6001 (auch EL600x, KL600x)
Der FB der getestet werden soll, muss mit seinen Prozessdaten im Systemmanager mit der Klemme verlinkt werden (22-Byte-Prozessabbild und Control/Status-Word).

Im Beispiel ist der NMEA-Baustein verlinkt. Die Baudrate der Klemme muss auf Ihren Sender eingestellt werden.

Referenzen:

  • www.beuth.de, IEC61162: angelehnt an NMEA2000
  • www.gpsinformation.org , privat, über NMEA, viele Formate: http://www.gpsinformation.org/dale/nmea.htm
    http://www.nmea.de/nmea0183datensaetze.html
  • http://www.meinberg.de/german/info/irig.htm, IRIG-Codes
  • http://www.siemens-edm.de/FAQ.siemens-edm-faq0.0.html, Zeitsynchronisation


ELxxxx - Wiederherstellen des Auslieferungszustandes

BECKHOFF ELxxxx: Konfiguration

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).

Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert

Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"

Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box - Zubehör

Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder unbedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmomentsteckschlüssel mit Ratsche für angespritzte M8-Steckverbinder
ZB8800-0001 | Ratsche für feldkonfektionierbare M8-Steckverbinder
ZB8800-0002 | Ratsche für angespritzte M12-Steckverbinder

Hinweis 		Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter www.beckhoff.de.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.