EP5xxx - Winkel-/Wegmessung
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.3.0
▪
Hinweis Schirmung eingefügt
2.2.0
▪
Update chapter EP5001-0002 - Signalanschluss
2.1.0
▪
EP5101-2011 eingefügt
▪
Update Kapitel Montage
▪
Update Kapitel Inbetriebnahme
▪
Update Struktur
2.0.0
▪
Migration
▪
EP5001-0002 hinzugefügt
▪
Umbenennung auf EP5xxx
▪
Aktualisierung diverser Kapitel
1.6.0
▪
Steckerbelegung aktualisiert
▪
Status-LEDs aktualisiert
▪
Kapitel Anzugsmomente für Steckverbinder aktualisiert
▪
Zubehör aktualisiert
1.5.0
▪
Power-Anschluss aktualisiert
1.4.0
▪
Einführung erweitert
1.3.0
▪
Titelblatt um EP5101-1002 und EP5151-0002 erweitert
▪
EP51x1 - Einführung um EP5101-1002 und EP5151-0002 erweitert
▪
EP5151 Signallevel (Schnittstellenpegel) hinzugefügt
▪
Status-LEDs um EP5101-1002 und EP5151-0002 erweitert
▪
Technische Daten um EP5101-1002 und EP5151-0002 erweitert
▪
Encoder-Anschluss, M12, 8-polig um EP5151 erweitert
▪
Grundlagen zur Funktion angepasst
▪
Parameter und Modi angepasst
▪
Prozessabbild der EP5151-0002 hinzugefügt
▪
Prozessabbild der EP5101-0002 angepasst
▪
Hinweise zur Dokumentation aktualisiert
▪
Support & Service aktualisiert
▪
Sicherheitshinweise aktualisiert
▪
EtherCAT-Kabel aktualisiert
▪
EtherCAT-Box Zubehör aktualisiert
▪
Anzugsmomente für Steckverbinder aktualisiert
▪
EtherCAT-Anschluss aktualisiert
▪
Befestigung aktualisiert
1.2.0
▪
Schnittstellenpegel ergänzt (single ended und differentielle Signale)
1.1.0
▪
Beschreibung des Power-Anschlusses aktualisiert
▪
Hinweis auf die Dokumentation Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) hinzugefügt.
1.0.0
▪
erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
Modulübersicht EP5xxx
•
EP5001-0002
•
EP51x1-x0xx


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Modulübersicht EP5xxx

Produktübersicht [image] Modulübersicht EP5xxx
Modulübersicht EP5xxx
SSI-Geber-Interface
Modul | Anschluss Encoder/Sensor | Anzahl Kanäle | Sensorversorgung | Kommentar
EP5001-0002 | M12, schraubbar | 1 | 24 VDC | Distributed-Clocks
Inkremental-Encoder-Interface mit Differenzeingängen
Modul | Anschluss Encoder/Sensor | Anzahl Kanäle | Sensorversorgung | Kommentar
EP5101-0002 | M12, schraubbar, 8-polig | 1 | +5 VDC, 150 mA (VCC) | Distributed-Clocks, 4 Mio. Inkremente/s
EP5101-1002 |  | 1 | 24 VDC, 500 mA (VCC)
EP5101-0011 | D-Sub-Buchse, 15-polig | 1 | +5 VDC, 150 mA (VCC) | Distributed-Clocks 4 Mio. Inkremente/s Latch, Gate
EP5101-2011 |  | 1 |  | Distributed-Clocks, 20 Mio. Inkremente/s Latch, Gate
Inkremental-Encoder-Interface mit Single-ended Eingängen
Modul | Anschluss Encoder/Sensor | Anzahl Kanäle | Sensorversorgung | Kommentar
EP5151-0002 | M12, schraubbar, 8-polig | 1 | 24 VDC, 0,5 A | Distributed-Clocks 4 Mio. Inkremente/s Latch, Gate


EP5001-0002

Produktübersicht [image] EP5001-0002
EP5001-0002
Weiterführende Informationen
•
EP5001-0002 - Einführung
•
EP5001-0002 - Technische Daten
•
EP5001-0002 - Prozessabbild


EP5001-0002 - Einführung

Produktübersicht [image] EP5001-0002 [image] EP5001-0002 - Einführung
EP5001-0002 - Einführung
EP5001-0002
EP5001-0002 SSI-Geber-Interface
Die EtherCAT Box EP5001-0002 ist ein Interface zum direkten Anschluss eines SSI-Gebers mit Differenzeingängen (RS422). Die Schnittstellenschaltung gibt zum Auslesen des Gebers ein Taktsignal aus und stellt der Steuerung den einlaufenden Datenstrom als Datenwort im Prozessabbild zur Verfügung. Unterschiedliche Betriebsarten, Übertragungsfrequenzen und Bitbreiten können über Kontrollregister dauerhaft eingestellt werden. Der Anschluss des Gebers erfolgt über eine 8-polige M12-Buchse.
Quick Links
Installation
Konfiguration
UL-Anforderungen für UL-zugelassene Module
ATEX - Besondere Bedingungen für ATEX-zugelassene Module


EP5001-0002 - Technische Daten

Produktübersicht [image] EP5001-0002 [image] EP5001-0002 - Technische Daten
EP5001-0002 - Technische Daten
Technische Daten | EP5001-0002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Kanäle | 1
Anschluss Kanäle | M12, schraubbar
Geberanschluss | Binäreingang: D+, D-, Binärausgang: CI+, CI-
Nennspannung | 24 VDC (-15 %/+ 20 %)
Signaltyp | differenziell (RS422)
Distributed-Clocks | ja
Übertragungsraten | Einstellbar bis 1 MHz, 250 kHz voreingestellt
Serieller Eingang | 24-Bit-Breite (einstellbar)
Datenrichtung | Lesen
Anschluss Spannungsversorgung | Einspeisung: 1 x M8-Stecker, 4-polig; Weiterleitung: 1 x M8-Buchse, 4-polig
Stromaufnahme aus US | 130 mA typ. + Sensorversorgung
Breite im Prozessabbild | 1 x 32-Bit-Input, 8-Bit-Status
Potenzialtrennung | 500 V
Besondere Eigenschaften | Baudrate, Kodierung und Datenlänge einstellbar
Gewicht | ca. 165 g
Betriebs-/Lagertemperatur | 0…+55 °C / -25…+85 °C
Schwingungs-/Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27
EMV-Festigkeit/-Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP65/66/67 (gemäß EN 60529)/beliebig
Zulassungen | CE


EP5001-0002 - Prozessabbild

Produktübersicht [image] EP5001-0002 [image] EP5001-0002 - Prozessabbild
EP5001-0002 - Prozessabbild
TwinCAT zeigt die Daten der EP5001-0002 in einer Baumstruktur an.
EP5001-0002 - ProcDataTree
SSI Inputs
Status
▪
Data error
Fehler am SSI-Eingang
▪
Frame error
Es liegt ein falscher Datenrahmen vor
▪
Power failure
Es ist ein geberspezifischer Fehler aufgetreten. Aktivierung durch Enable Power failure bit (Index 0x8000:02)
▪
Sync error
EtherCAT Fehler, siehe EtherCAT System-Dokumentation
▪
TxPDO State
Siehe Objektbeschreibung
▪
TxPDO Toggle
Siehe Objektbeschreibung
Counter value
Aktueller Zählerwert des Encoders


EP51x1-x0xx

Produktübersicht [image] EP51x1-x0xx
EP51x1-x0xx
Weiterführende Informationen
•
EP5101-x0xx - Einführung
•
EP5151-000x - Einführung
•
EP51x1-x0xx - Technische Daten
•
EP5101-0002, EP5101-1002 - Prozessabbild
•
EP5101-0011 - Prozessabbild
•
EP5101-2011 - Prozessabbild
•
EP5151-0002 - Prozessabbild


EP5101-x0xx - Einführung

Produktübersicht [image] EP51x1-x0xx [image] EP5101-x0xx - Einführung
EP5101-x0xx - Einführung
EP5101-x0xx | Inkremental-Encoder-Interface mit Differenzeingängen
Die EtherCAT Box EP5101-x0xx ist ein Interface zum direkten Anschluss von Inkremental-Encodern mit Differenzeingängen (RS422). Ein 32/16-Bit-Zähler mit Quadraturdecoder sowie ein 32/16-Bit-Latch für den Nullimpuls können gelesen, gesetzt oder aktiviert werden. An den Statuseingang des Interfaces sind Inkremental-Encoder mit Störmeldeausgang anschließbar. Eine Periodendauermessung mit einer Auflösung von bis zu 100 ns ist möglich. Der Gate-Eingang erlaubt das Sperren des Zählers; der Latch-Eingang übernimmt den Zählerstand mit steigender Flanke. Die EP5101-1002 verfügt über eine 24 VDC Sensorversorgung.
Durch die optionale interpolierende Mikroinkrementefunktionalität kann die EP5101 bei dynamischen Achsen noch genauere Achspositionen liefern. Zudem unterstützt sie über die hochpräzisen EtherCAT-Distributed-Clocks (DC) das synchrone Einlesen des Geberwertes zusammen mit anderen Eingangsdaten im EtherCAT-System.
Der Anschluss des Gebers erfolgt über eine 8-polige M12-Buchse (EP5101-0002 und EP5101-1002) oder über eine 15-polige D-Sub-Buchse (EP5101-0011 und EP5101-2011). In der M12-Variante stehen nicht alle Signale zur Verfügung.
Quick Links
Installation
Konfiguration
UL-Anforderungen für UL-zugelassene Module
ATEX - Besondere Bedingungen für ATEX-zugelassene Module


EP5151-000x - Einführung

Produktübersicht [image] EP51x1-x0xx [image] EP5151-000x - Einführung
EP5151-000x - Einführung
EP5151-0002 | Inkremental-Encoder-Interface mit Single-ended-Eingängen
Die EtherCAT Box EP5151-0002 ist ein Interface zum direkten Anschluss von Inkremental-Encodern mit 24-V-DC-Eingängen. Ein 32/16-Bit-Zähler mit Quadraturdecoder sowie ein 32/16-Bit-Latch für den Nullimpuls können gelesen, gesetzt oder aktiviert werden. Eine Periodendauermessung mit einer Auflösung von bis zu 100 ns ist möglich.
Durch die optionale interpolierende Mikroinkrementefunktionalität kann die EP5151-0002 bei dynamischen Achsen noch genauere Achspositionen liefern. Zudem unterstützt sie über die hochpräzisen EtherCAT-Distributed-Clocks (DC) das synchrone Einlesen des Geberwertes zusammen mit anderen Eingangsdaten im EtherCAT-System. Der Anschluss des Gebers erfolgt über eine 8-polige M12-Buchse.
Quick-Links
Installation
Konfiguration
UL-Anforderungen für UL-zugelassene Module
ATEX - Besondere Bedingungen für ATEX-zugelassene Module


EP51x1-x0xx - Technische Daten

Produktübersicht [image] EP51x1-x0xx [image] EP51x1-x0xx - Technische Daten
EP51x1-x0xx - Technische Daten
Technische Daten | EP5101-0002 | EP5101-1002 |  |  | EP5101-0011 | EP5101-2011 | EP5151-0002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Encoder-Eingänge | 1
Geberanschluss | A, EP5101-x0xx - Technische Daten_Aneg , B, EP5101-x0xx - Technische Daten_Bneg , C, Grafik aus EP5101-x0xx - Technische Daten_Cneg (RS485 Differenzeingänge) auch Single-ended-Anschluss (5 V ±20%) möglich |  |  | A, EP5101-x0xx - Technische Daten_Aneg , B, EP5101-x0xx - Technische Daten_Bneg , C, Grafik aus EP5101-x0xx - Technische Daten_Cneg (RS485 Differenzeingänge) auch Single-ended-Anschluss (5 V ±20%) möglich, Latch, Gate |  |  | A, B,C, (24 VDC), Latch, Gate
Anschluss Encoder | M12-Buchse, 8-polig |  |  | D-Sub-Buchse, 15-polig |  |  | M12-Buchse, 8-polig
Encoder-Versorgung | +5 VDC, 150 mA |  | +24 VDC | +5 VDC, 150 mA |  |  | +24 VDC
Zähler | 32 Bit oder 16 Bit, binär
Grenzfrequenz | 4 Mio. Inkremente/s (bei Vierfachauswertung) |  |  |  |  | 20 Mio. Inkremente/s (bei Vierfachauswertung) | 4 Mio. Inkremente/s (bei Vierfachauswertung)
Quadraturdecoder | Vierfachauswertung
Nullimpuls-Latch | 16 Bit
Befehle | Lesen, Setzen, Aktivieren
Distributed Clocks | ja
Versorgung der Modulelektronik | aus der Steuerspannung US
Stromaufnahme der Modulelektronik | typisch 130 mA + Last
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Prozessabbild | Eingänge: 32 Bit Daten, 8 Bit Status Ausgänge: 16 Bit Daten, 8 Bit Control
Potenzialtrennung | Steuerspannung / Feldbus: 500 V
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) 0°C ... +55°C (gemäß cULus siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus, ATEX |  |  |  |  | CE, cULus | CE, cULus, ATEX


EP5101-0002, EP5101-1002 - Prozessabbild

Produktübersicht [image] EP51x1-x0xx [image] EP5101-0002, EP5101-1002 - Prozessabbild
EP5101-0002, EP5101-1002 - Prozessabbild
TwinCAT zeigt die Daten der EP5101-0002 und EP5101-1002 am Beispiel der EP5101-0002 in einer Baumstruktur an.
EP5101-0002 - ProcDataTree
ENC Status Compact
Eingangsdaten des Encoder-Interfaces
Status
▪
Latch C valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch C
▪
Set Counter done
Quittierung zum setzen des Set counter
▪
Counter underflow
Zähler unterschreitet den kleinsten darstellbaren Zählerwert
▪
Counter overflow
Zähler überschreitet den höchsten darstellbaren Zählerwert
▪
Open circuit
Einer der Kanäle A, B oder C hat einen Drahtbruch (einstellbar je Kanal über CoE)
▪
Extrapolation stall
Microinkrement-Wert ungültig (Bei aktivierter Microinkrement-Auswertung -> Index 0x8000:0A)
▪
Status of Input A, B,C
Status der Eingänge A, B und C
▪
Sync error
EtherCAT Fehler, siehe EtherCAT System-Dokumentation
▪
TxPDO State
Siehe Objektbeschreibung
▪
TxPDO Toggle
Siehe Objektbeschreibung
Counter value
Aktueller Zählerwert des Encoders
Latch value
Zählerwert des Encoders bei steigender Flanke am Latch-Eingang
ENC Control Compact
Ausgangs-Daten des Encoder-Interfaces.
Control
▪
Enable latch C
Eingang C wird freigegeben. Bei einer Flanke wird Counter value in Latch value gespeichert.
▪
Set counter
Bei positiver Flanke Übernahme von Set Counter value in Counter value
Set Counter value
Vorwahlwert für Counter value


EP5101-0011 - Prozessabbild

Produktübersicht [image] EP51x1-x0xx [image] EP5101-0011 - Prozessabbild
EP5101-0011 - Prozessabbild
TwinCAT zeigt die Daten des EP5101-0011 in einer Baumstruktur an.
ENC Status Compact
Status
▪
Latch C valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch C
▪
Latch extern valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch extern on positive/negative edge
▪
Set Counter done
Quittierung zum setzen des Set counter
▪
Counter underflow
Zähler unterschreitet den kleinsten darstellbaren Zählerwert
▪
Counter overflow
Zähler überschreitet den höchsten darstellbaren Zählerwert
▪
Status of input status
Status des Error-Signal (typisch vom Encoder kommend)
▪
Open circuit
Einer der Kanäle A, B oder C hat einen Drahtbruch (einstellbar je Kanal über CoE)
▪
Extrapolation stall
Microinkrement-Wert ungültig (Bei aktivierter Microinkrement-Auswertung -> Index 0x8000:0A)
▪
Status of Input A, B,C
Status der Eingänge A, B und C
▪
Status of input gate
Status des Gate-Eingangs
▪
Status of extern latch
Status des Latch-Eingangs
▪
Sync error
EtherCAT Fehler, siehe EtherCAT System-Dokumentation
▪
TxPDO State
Siehe Objektbeschreibung
▪
TxPDO Toggle
Siehe Objektbeschreibung
Counter value
Aktueller Zählerwert des Encoders
Latch value
Zählerwert des Encoders bei steigender Flanke am Latch-Eingang
ENC Control Compact
Ausgangs-Daten des Encoder-Interfaces.
Control
▪
Enable latch C
Eingang C wird freigegeben. Bei einer Flanke wird Counter value in Latch value gespeichert.
▪
Enable latch extern on positive edge
Externer Latch Eingang wird freigegeben. Bei einer positiven Flanke wird Counter value in Latch value gespeichert.
▪
Set counter
Bei positiver Flanke Übernahme von Set Counter value in Counter value
▪
Enable latch extern on negative edge
Externer Latch Eingang wird freigegeben. Bei einer negativen Flanke wird Counter value in Latch value gespeichert.
Set Counter value
Vorwahlwert für Counter value


EP5101-2011 - Prozessabbild

Produktübersicht [image] EP51x1-x0xx [image] EP5101-2011 - Prozessabbild
EP5101-2011 - Prozessabbild
TwinCAT zeigt die Daten des EP5101-2011 in einer Baumstruktur an.
ENC Status Compact
Status
▪
Latch C valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch C
▪
Latch extern valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch extern on positive/negative edge
▪
Set Counter done
Quittierung zum setzen des Set counter
▪
Status of input status
Status des Error-Signal (typisch vom Encoder kommend)
▪
Open circuit
Einer der Kanäle A, B oder C hat einen Drahtbruch (einstellbar je Kanal über CoE)
▪
Status of Input A, B,C
Status der Eingänge A, B und C
▪
Status of input gate
Status des Gate-Eingangs
▪
Status of extern latch
Status des Latch-Eingangs
▪
Sync error
EtherCAT Fehler, siehe EtherCAT System-Dokumentation
▪
TxPDO State
Siehe Objektbeschreibung
▪
TxPDO Toggle
Siehe Objektbeschreibung
Counter value
Aktueller Zählerwert des Encoders
Latch value
Zählerwert des Encoders bei steigender Flanke am Latch-Eingang
ENC Control Compact
Ausgangs-Daten des Encoder-Interfaces.
Control
▪
Enable latch C
Eingang C wird freigegeben. Bei einer Flanke wird Counter value in Latch value gespeichert.
▪
Enable latch extern on positive edge
Externer Latch Eingang wird freigegeben. Bei einer positiven Flanke wird Counter value in Latch value gespeichert.
▪
Set counter
Bei positiver Flanke Übernahme von Set Counter value in Counter value
▪
Enable latch extern on negative edge
Externer Latch Eingang wird freigegeben. Bei einer negativen Flanke wird Counter value in Latch value gespeichert.
Set Counter value
Vorwahlwert für Counter value


EP5151-0002 - Prozessabbild

Produktübersicht [image] EP51x1-x0xx [image] EP5151-0002 - Prozessabbild
EP5151-0002 - Prozessabbild
ENC Status Compact
Status
▪
Latch C valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch C
▪
Latch extern valid
In den Prozessdaten Latch value stehen neue Daten bereit. Reset durch Enable latch extern on positive/negative edge
▪
Set Counter done
Quittierung zum setzen des Set counter
▪
Counter underflow
Zähler unterschreitet den kleinsten darstellbaren Zählerwert
▪
Counter overflow
Zähler überschreitet den höchsten darstellbaren Zählerwert
▪
Status of input status
Status des Error-Signal (typisch vom Encoder kommend)
▪
Open circuit
Einer der Kanäle A, B oder C hat einen Drahtbruch (einstellbar je Kanal über CoE)
▪
Extrapolation stall
Microinkrement-Wert ungültig (Bei aktivierter Microinkrement-Auswertung -> Index 0x8000:0A)
▪
Status of Input A, B,C
Status der Eingänge A, B und C
▪
Status of input gate
Status des Gate-Eingangs
▪
Status of extern latch
Status des Latch-Eingangs
▪
Sync error
EtherCAT Fehler, siehe EtherCAT System-Dokumentation
▪
TxPDO State
Siehe Objektbeschreibung
▪
TxPDO Toggle
Siehe Objektbeschreibung
Counter value
Aktueller Zählerwert des Encoders
Latch value
Zählerwert des Encoders bei steigender Flanke am Latch-Eingang
ENC Control Compact
Ausgangs-Daten des Encoder-Interfaces.
Control
▪
Enable latch C
Eingang C wird freigegeben. Bei einer Flanke wird Counter value in Latch value gespeichert.
▪
Enable latch extern on positive edge
Externer Latch Eingang wird freigegeben. Bei einer positiven Flanke wird Counter value in Latch value gespeichert.
▪
Set counter
Bei positiver Flanke Übernahme von Set Counter value in Counter value
▪
Enable latch extern on negative edge
Externer Latch Eingang wird freigegeben. Bei einer negativen Flanke wird Counter value in Latch value gespeichert.
Set Counter value
Vorwahlwert für Counter value


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
EtherCAT
•
Spannungsversorgung
•
Verkabelung
•
Schirmung
•
UL-Anforderungen
•
ATEX-Hinweise
•
Signalanschluss und Bedeutung der LEDs


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder
•
Zusätzliche Prüfungen


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Montage und Anschluss [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


Zusätzliche Prüfungen

Montage und Anschluss [image] Montage [image] Zusätzliche Prüfungen
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


EtherCAT

Montage und Anschluss [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs


EtherCAT-Anschluss

Montage und Anschluss [image] EtherCAT [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Montage und Anschluss [image] EtherCAT [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (https://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Spannungsversorgung

Montage und Anschluss [image] Spannungsversorgung
Spannungsversorgung
Weiterführende Informationen
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Leitungsverluste M8
•
Leitungsverluste 7/8"


Power-Anschluss

Montage und Anschluss [image] Spannungsversorgung [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z. B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z. B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u. U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Anschluss [image] Spannungsversorgung [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Leitungsverluste M8

Montage und Anschluss [image] Spannungsversorgung [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Leitungsverluste 7/8"

Montage und Anschluss [image] Spannungsversorgung [image] Leitungsverluste 7/8"
Leitungsverluste 7/8"
Bei den Powerkabeln ZK2030-xxxx-yyyy sollten 15 m Gesamtlänge bei 16 A nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
ZK2030-xxxx-yyyy - Leitungsverluste
Alternativ können auch höhere Leitungsquerschnitte von z.B. 2.5 mm2 eingesetzt werden.


Verkabelung

Montage und Anschluss [image] Verkabelung
Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: https://beckhoff.de/german/fieldbus_box/ethercat_box_accessories_overview.htm?id=25525466903389
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link:
https://beckhoff.de/german/ethercat-box/ethercat_box_cables.htm?id=690338951657421
EtherCAT-Kabel
ZK1090-3131-0xxx
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
Powerkabel
ZK2020-3132-0xxx
Sensorkabel
Sensorkabel - Beckhoff.png
Auswahl von Beckhoff-Sensorkabel


Schirmung

Montage und Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Montage und Anschluss [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000-0000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Montage und Anschluss [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

Montage und Anschluss [image] ATEX-Hinweise [image] BG2000-0000 - Schutzgehäuse für EtherCAT Box
BG2000-0000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.
BG2000-0000, Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000-0000, Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.
BG2000-0000, Schutzgehäuse montieren


ATEX-Dokumentation

Montage und Anschluss [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Signalanschluss und Bedeutung der LEDs

Montage und Anschluss [image] Signalanschluss und Bedeutung der LEDs
Signalanschluss und Bedeutung der LEDs
Weiterführende Informationen
•
EP5001-0002 - Signalanschluss
•
EP5101-x0xx - Signalanschluss
•
EP5151-0002 - Signalanschluss


EP5001-0002 - Signalanschluss

Montage und Anschluss [image] Signalanschluss und Bedeutung der LEDs [image] EP5001-0002 - Signalanschluss
EP5001-0002 - Signalanschluss
EP5001-0002, Pinbelegung M12
Bedeutung der LEDs
EP5001-0002, LEDs
LED | grün | rot
Data | Geberversorgung eingeschaltet (funktionsfähiger Zustand, nicht kurzgeschlossen) | SSI hat keine Spannungsversorgung Drahtbruch auf dem SSI-Dateneingang D+ oder D- Datenleitungen vertauscht Der SSI-Eingang des Moduls liegt auf Low-Pegel, es findet keine Datenübertragung statt. Falsche Parametrierung im CoE Drahtbruch auf Clock-Leitungen
CLOCK | Keine Funktion


EP5101-x0xx - Signalanschluss

Montage und Anschluss [image] Signalanschluss und Bedeutung der LEDs [image] EP5101-x0xx - Signalanschluss
EP5101-x0xx - Signalanschluss
Pinbelegung Encoder, M12, Buchse, 8-polig
EP5101-0002, EP5101-1002 Pinbelegung
EP5101-0002, EP5101-1002 LEDs
Bedeutung der LEDs
Anschluss | LED | Anzeige | Bedeutung
M12 | A | aus | Eingang A / Spur A low
 |  | grün | Eingang A / Spur A High
 | B | aus | Eingang B / Spur B low
 |  | grün | Eingang B / Spur B high
 | C | aus | Eingang C / Spur C low
 |  | grün | Eingang C / Spur C high
Pinbelegung Encoder, D-Sub-Buchse, 15-polig
EP5101-0011, Pinbelegung
EP5101-0011, LEDs
Bedeutung der LEDs
Anschluss | LED | Anzeige | Bedeutung
D-Sub | A | aus | Eingang A / Spur A low
 |  | grün | Eingang A / Spur A High
 | B | aus | Eingang B / Spur B low
 |  | grün | Eingang B / Spur B high
 | C | aus | Eingang C / Spur C low
 |  | grün | Eingang C / Spur C high
 | L | aus | Eingang Latch low
 |  | grün | Eingang Latch High
 | G | aus | Eingang Gate low
 |  | grün | Eingang Gate high
 | E | aus | Eingang Error low
 |  | grün | Eingang Error high


EP5151-0002 - Signalanschluss

Montage und Anschluss [image] Signalanschluss und Bedeutung der LEDs [image] EP5151-0002 - Signalanschluss
EP5151-0002 - Signalanschluss
Encoder-Anschluss, M12-Buchse, 8-polig
EP5151-0002, Pinbelegung
Bedeutung der LEDs
EP5151-0002, LEDs
Anschluss | LED | Anzeige | Bedeutung
M12 | A | aus | Eingang A / Spur A low
 |  | grün | Eingang A / Spur A High
 | B | aus | Eingang B / Spur B low
 |  | grün | Eingang B / Spur B high
 | C | aus | Eingang C / Spur C low
 |  | grün | Eingang C / Spur C high
 | L | aus | Eingang Latch low
 |  | grün | Eingang Latch High
 | G | aus | Eingang Gate low
 |  | grün | Eingang Gate high
 | E | aus | Eingang Error low
 |  | grün | Eingang Error high


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Konfigurationserstellung TwinCAT - Manuell
•
Konfigurationserstellung TwinCAT - Online scan
•
Konfiguration mit TwinCAT
•
Prozessdaten Einstellungen EtherCAT Slave (PDO)
•
EP5001-0002 - Parameter und Modi
•
EP51x1-x0xx - Parameter und Modi
•
EP5001 - Schnittstellenpegel
•
EP5101 - Schnittstellenpegel
•
EP5151 - Schnittstellenpegel
•
EP5001-0002 - Objektbeschreibung und Parametrierung
•
EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
•
EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
•
EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
•
EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
•
Wiederherstellen des Auslieferungszustandes


Konfigurationserstellung TwinCAT - Manuell

Inbetriebnahme/Konfiguration [image] Konfigurationserstellung TwinCAT - Manuell
Konfigurationserstellung TwinCAT - Manuell
In diesem Teil der Dokumentation wird die manuelle Konfiguration einer EtherCAT-Box in TwinCAT beschrieben.
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter Konfigurationserstellung TwinCAT - Manuell beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…)
Update EtherCAT Device Description 1439726603
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E_A-Gerätes
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP6224-2022), bestätigen Sie mit OK.
Auswahl einer Box
Auswahl einer Box (z.B.: EP6224-2022)


Konfigurationserstellung TwinCAT - Online scan

Inbetriebnahme/Konfiguration [image] Konfigurationserstellung TwinCAT - Online scan
Konfigurationserstellung TwinCAT - Online scan
In diesem Teil der Dokumentation wird die Konfiguration einer physisch vorhandenen EtherCAT-Box in TwinCAT beschrieben.
Online Konfigurationserstellung „Scannen“ (TwinCAT 3.x)
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie unter Konfigurationserstellung TwinCAT - Manuell beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft die EtherCAT-Box bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen.
Damit die aktuellsten Features/Einstellungen der EtherCAT-Box genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description 1439726603
Zur Konfigurationserstellung
▪
muss die reale EtherCAT- und IO-Link-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
die Geräte/Module müssen über EtherCAT-Kabel und IO-Link-Kabel so verbunden sein wie sie später eingesetzt werden sollen.
▪
die Geräte/Module müssen mit Energie versorgt werden und kommunikationsbereit sein.
▪
TwinCAT muss auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer- Dieser Schritt kann auch unabhängig vom vorherigen Schritt durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.
Erkennen/Scan des EtherCAT Geräts
Befindet sich das TwinCAT-System im Config-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.
TwinCAT Anzeige Config-Modus
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.
Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.
TwinCAT target und local System
Im Konfigurationsbaum bringt Sie ein Rechtsklick auf den Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer Gerätescan
Hinweis automatischer Gerätescan
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Gerät angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
erkannte Ethernet-Geräte
Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen (siehe nachfolgende Abbildung).
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Information des EtherCAT Devices aus dem Device-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan for Boxes
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes
Die Konfiguration wurde aufgebaut und direkt in den Online-Zustand (OPERATIONAL) versetzt. Das EtherCAT System sollte sich in einem funktionsfähigen zyklischen Betrieb, wie in der nachfolgenden Abbildung dargestellt, befinden.
beispielhafte Online-Anzeige
Zu beachten sind:
▪
Alle Boxen sollten im OP-State sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Wie in der nachfolgenden Abbildung sichtbar, wird die angeschlossene EtherCAT-Box (EP6224-3022) im TwinCAT Baum angezeigt.
Master-Anzeige_Nach Scan for Boxes
Master-Anzeige nach „Scan for boxes“
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Device für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Device hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Scan über bestehender Konfiguration
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Configuration is identical
Identische Konfiguration
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Beispiel-Korrekturdialog
Es wird empfohlen das Häkchen „Extended Information“ zu setzen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe | Erläuterung
grün | dieses EtherCAT Device findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau | dieses EtherCAT Device ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich. Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau | dieses EtherCAT Device wird ignoriert (Button "Ignore")
rot | dieses EtherCAT Device ist auf der Gegenseite nicht vorhanden.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Device/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:
Geräte-Revision in der Anlage >= Geräte Revision in der Konfiguration
Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich). Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Beispiel-Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Prozessdaten Einstellungen EtherCAT Slave (PDO)

Inbetriebnahme/Konfiguration [image] Prozessdaten Einstellungen EtherCAT Slave (PDO)
Prozessdaten Einstellungen EtherCAT Slave (PDO)
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (Process Data Objects, PDO) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL/ES/EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation. Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch den erfolgreichen Hochlauf des Slaves. Es wird abgeraten, andere als die vorgesehenen Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist laut Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden (siehe nachfolgende Abbildung).
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data" in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als verlinkbare Variablen im Systemmanager sichtbar. Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten1
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann laut ESI-Beschreibung ein PDO als „fixed“ mit einem Flag „F“ gekennzeichnet sein (siehe vorherige Abbildung, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet („Edit“). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration „G“ unterstützt. Bei falscher konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen „invalid SM cfg“ wird im Systemmanager ausgegeben:
`Box 1 (EP3356)` (0022): state change aborted (requested ‚SAFEOP`, back to ‚PREOP`), `Box1 (EP3356)` (0022): `PREOP to SAFEOP`failed! Error: `check device state for SAFEOP`, AL Status `0x0012`read and 0x0004` expected. AL Status code `0x001e – Invalid SM IN cfg` Diese Fehlermeldung „invalid SM IN cfg“ oder „invalid SM OUT cfg“ bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.


EP5001-0002 - Parameter und Modi

Inbetriebnahme/Konfiguration [image] EP5001-0002 - Parameter und Modi
EP5001-0002 - Parameter und Modi
Weiterführende Informationen
•
Prozessdaten
•
DC (Distributed Clocks)
•
Features CoE


Prozessdaten

Inbetriebnahme/Konfiguration [image] EP5001-0002 - Parameter und Modi [image] Prozessdaten
Prozessdaten
Die EP5001-0002 kann sowohl mit 16 Bit Status Daten und einen 32-Bit Zählerwert zur Verfügung.
EP5001-0002
Weiterführende Informationen
•
EP5001-0002 - PDO-Zuordnung


EP5001-0002 - PDO-Zuordnung

Inbetriebnahme/Konfiguration [image] EP5001-0002 - Parameter und Modi [image] Prozessdaten [image] EP5001-0002 - PDO-Zuordnung
EP5001-0002 - PDO-Zuordnung
EP5001-0002 - PDOAssignment
PDO-Zuordnung und Inhalte am Beispiel EP5001-0002
Die Änderung der Zusammenstellung des PDO 0x1A00 der EP5001-0002 ist nicht möglich.
PDO-Zuordnung
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1A00 (default) |  | 6.0 | SSI Inputs | 0x6000:01 - Data error 0x6000:02 - Frame error 0x6000:03 - Power failure 0x6000:0E - Sync error 0x6000:0F - TxPDO State 0x6000:10 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit)


DC (Distributed Clocks)

Inbetriebnahme/Konfiguration [image] EP5001-0002 - Parameter und Modi [image] DC (Distributed Clocks)
DC (Distributed Clocks)
Beschreibt, ob das Modul mit Unterstützung von Distributed Clocks-betrieben wird:
Distributed Clocks
▪
FreeRun: das Modul arbeitet Frame-getriggert, der zyklische Betrieb wird durch die SyncManager der EtherCAT-Frame-Bearbeitung gestartet.
▪
DC-Synchron: der Zyklische Betrieb in dem Modul wird durch die lokale Distributed Clock in exakten Zeitabständen gestartet. Dabei ist der Startzeitpunkt so gewählt, dass er mit anderen Output-Slaves im EtherCAT-System zusammenfällt.
▪
DC-Synchron (input based): Arbeitsweise wie DC-Synchron, aber der zyklische Startzeitpunkt ist so gewählt, dass er mit anderen Input-Slaves im EtherCAT-System zusammenfällt.


Features CoE

Inbetriebnahme/Konfiguration [image] EP5001-0002 - Parameter und Modi [image] Features CoE
Features CoE
Im CoE (CAN over EtherCAT)-Verzeichnis sind weitere Einstellungen anwählbar.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
CoE-Reload zum Zurücksetzen der Veränderungen
Folgende CoE-Einstellungen aus den Objekten 0x8000 und 0x800D sind möglich und hier in den Default-Einstellungen wiedergegeben:
EP5001-0002 - CoE_0x800x
EP5001-0002 - Defaulteinstellung der Objekte 0x8000 und 0x800D
Die Parameter werden im Kapitel Objektbeschreibung erläutert.
SSI-Settings
▪
Index 0x8000:01, Disable Frame Error
Wenn das Bit auf TRUE gesetzt ist, werden Datenfehler wie falsche Telegrammgröße nicht mehr im Prozessdatum Data error angezeigt.
▪
Index 0x8000:02, Enable Power failure bit
Wenn das Bit auf TRUE gesetzt ist, wird das letzte Bit (LSB) im SSI-Telegramm als PowerFail-Bit des SSI-Slave interpretiert und im Prozessdatum angezeigt.
▪
Index 0x8000:03, Enable Inhibit time
Wenn Bit auf TRUE gesetzt, wird mit dem Start der nächsten SSI-Kommunikation mindestens die Min. Inhibit time (Index 0x8000:13) abgewartet, auch wenn schon früher die nächste Startanforderung durch EtherCAT oder Distributed Clocks kam.
▪
Index 0x8000:04, Enable test mode
Nur für Produktionszwecke.
▪
Index 0x8000:06, SSI-encoding
Einzustellen auf Dual oder Gray-Codierung (üblich).
▪
Index 0x8000:09, SSI-baudrate
Einzustellen auf 125, 250, 500 kBaud (default) oder 1 MBaud.
▪
Index 0x8000:0F, SSI-frame type
25, 13 oder variable Bitbreite (25 default).
▪
Index 0x8000:11, SSI-frame size
Gesamtumfang der Daten inkl. PowerFail-Bit.
▪
Index 0x8000:12, SSI-data length
Umfang der Daten exkl. PowerFail-Bit.
▪
Index 0x8000:13, Min. Inhibit time [µs]
Siehe Index 0x8000:03.
SSI Advanced Settings
▪
Index 0x800D:01, Encoder power supply on
Schaltet die 24 V Versorgungsspannung
▪
Index 0x800D:02, Encoder direction pin on
Schaltet die 24 V am Direction pin
▪
Index 0x800D:03, Encoder reset pin on
Schaltet die 24 V am Reset pin
Der Gesamtumfang der Daten hängt vom eingesetzten Encoder ab. Ebenso ist es typenspezifisch, ob ein PowerFail-Bit oder ein anderes Zusatzbit unterstützt wird. Der Zählerstand in Counter Value Index 0x6000:11 wird anhand des im Objekt SSI-data length Index 0x8000:12 eingetragenen Wertes bestimmt.
Im Folgenden sind einige Beispielkonfigurationen dargestellt:
Spezifikation des Encoders |  |  | Einstellungen im CoE der EP5001-0002
ST | MT | Error Bit | 0x8000:0F SSI-frame type | 0x8000:11 SSI-frame size | 0x8000:12 SSI-data length | 0x8000:02 Enable power failure bit
13 | 0 | 0 | 1: Single-turn analysis is active | 13 | 13 | 0: Power failure bit is not active
12 | 12 | 1 | 0: Multi-turn analysis is active | 25 | 24 | 1: Power failure bit is active
12 | 12 | 0 | 2: Variable analysis is active | 24 | 24 | 0: Power failure bit is not active
12 | 13 | 0 | 2: Variable analysis is active | 25 | 25 | 0: Power failure bit is not active
16 | 16 | 0 | 2: Variable analysis is active | 32 | 32 | 0: Power failure bit is not active
16 | 0 | 0 | 2: Variable analysis is active | 16 | 16 | 0: Power failure bit is not active
13 | 16 | 1 | 2: Variable analysis is active | 30 | 29 | 1: Power failure bit is active
12 | 12 | 2 | 2: Variable analysis is active | 26* | 26* | 0: Power failure bit is not active
*) Analyse der Daten und Aufteilung in Position und Zusatzbits muss in der SPS erfolgen.
Bietet der Encoder mehr als 1 Zusatzbit, so kann dies durch geeignete Konfiguration der Objekte 0x8000:11 SSI-frame size und 0x8000 SSI-data length erfolgen. Hierbei ist die maximal Größe von 32 Bit zu beachten. Haben die Parameter die gleiche Größe, so werden im Counter Value Index 0x6000:11 nicht nur die Position, sondern auch Zusatzbits mit angezeigt. Die Analyse der Daten und Aufteilung in Position und Zusatzbits muss in der SPS erfolgen.
Wurden die Einstellungen im CoE nicht korrekt vorgenommen, oder besteht ein Fehler bei den Eingängen, so wird dies über die Statusbits angezeigt
Data Error (Index 0x6000:01) | Frame error (Index 0x6000:02) | Mögliche Fehlerart
TRUE | FALSE | Fehler am SSI-Eingang: - SSI hat keine Spannungsversorgung - Drahtbruch auf den SSI-Dateneingänge D+ oder D- Wenn keine Datenübertragung stattfindet, liegt der SSI-Eingang der Klemme auf Low-Pegel.
FALSE | TRUE | Es liegt ein falscher Datenrahmen vor, der Datenrahmen wurde nicht mit Null abgeschlossen evtl. - Drahtbruch auf Clock-Leitungen - Falsche Parametrierung im CoE
TRUE | TRUE | - Drahtbruch auf den SSI-Dateneingänge D+ oder D- - Datenleitungen vertauscht
FALSE | FALSE | Sind Bits im Counter Value, trotz korrekter CoE Parametrierung, verschoben, so kann es mit einem Vertauschen der Clock-Leitungen zusammen hängen


EP51x1-x0xx - Parameter und Modi

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi
EP51x1-x0xx - Parameter und Modi
Weiterführende Informationen
•
Prozessdaten
•
DC (Distributed Clocks)
•
Features CoE


Prozessdaten

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] Prozessdaten
Prozessdaten
16 oder 32 Bit Prozessdaten
Die EP51x1 kann sowohl mit 16 Bit Prozessdaten (default), als auch mit 32 Bit Prozessdaten betrieben werden. Diese Einstellung erfolgt über das Predefined PDO Assignment im Tabellenreiter Process Data.
16 oder 32 Bit Prozessdaten
Haupt-PDO
Auswahl der Basis-Prozessdaten
Haupt-PDO am Beispiel der EP5101-0011
A: Anwahl der Datenrichtung: Input oder Output | C: Erläuterungen zu den PDO
B: Auswahl (optionaler) PDO (Prozessdatenobjekte) | D: Inhalte der PDO
▪
compact: die Prozessdaten können mit 16 Bit Umfang als compact oder mit 32 Bit Umfang dargestellt werden.
Optionale PDO
Zum Haupt-PDO optional wählbare PDO:
▪
PDO 1 (0x1A02 oder 0x1A03): als optionales PDO 1 ist entweder die Frequenz oder die Periode anwählbar.
▪
PDO 2 (0x1A04 oder 0x1A05): In einem der DC-Modi ist ein 32 Bit oder 64 Bit großer Timestamp zuwählbar. Der Timestamp gibt die Uhrzeit der letzten registrierten Inkrementflanke, basierend auf dem Distributed Clocks System an.
Zuordnung und Inhalte der PDOs
Zuordnung und Inhalte der PDOs sind bei den Boxen teilweise unterschiedlich. Entnehmen Sie Inhalte und Zuordnung der PDOs dem
•
TwinCAT System Manager im Karteireiter Prozess Daten oder dem
•
Kapitel Zuordnung der PDOs der betreffenden Box.
Weiterführende Informationen
•
EP5101-x002 - PDO-Zuordnung
•
EP5101-0011 - PDO-Zuordnung
•
EP5101-2011 - PDO-Zuordnung
•
EP5151-0002 - PDO-Zuordnung


EP5101-x002 - PDO-Zuordnung

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] Prozessdaten [image] EP5101-x002 - PDO-Zuordnung
EP5101-x002 - PDO-Zuordnung
PDO-Zuordnung und Inhalte am Beispiel EP5101-0002
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld Sync Manager (siehe Abb.oben) den gewünschten Sync Manager (editierbar sind hier SM 2 + SM 3). Im Feld darunter PDO Assignment können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:03 - Set counter 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:03 - Set counter 0x7000:11 - Set counter value (32-bit)
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A03 | 0x1A02 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - Timestamp (64-Bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - Timestamp compact (32-Bit)


EP5101-0011 - PDO-Zuordnung

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] Prozessdaten [image] EP5101-0011 - PDO-Zuordnung
EP5101-0011 - PDO-Zuordnung
PDO-Zuordnung und Inhalte am Beispiel EP5101-0011
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld Sync Manager (siehe Abb.oben) den gewünschten Sync Manager (editierbar sind hier SM 2 + SM 3). Im Feld darunter PDO Assignment können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (32-bit)
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A03 | 0x1A02 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - Timestamp (64-Bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - Timestamp compact (32-Bit)


EP5101-2011 - PDO-Zuordnung

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] Prozessdaten [image] EP5101-2011 - PDO-Zuordnung
EP5101-2011 - PDO-Zuordnung
PDO-Zuordnung und Inhalte EP5101-2011
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld Sync Manager (siehe Abb.oben) den gewünschten Sync Manager (editierbar sind hier SM 2 + SM 3). Im Feld darunter PDO Assignment können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1600 | 0x1601 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (32-bit)
0x1601 (default) | 0x1600 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (16-bit)
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1A00 | 0x1A01 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x6000:0E - Sync error 0x6000:0F - TxPDO State 0x6000:10 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A01 (default) | 0x1A00 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x6000:0E - Sync error 0x6000:0F - TxPDO State 0x6000:10 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A03 | 0x1A02 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - Timestamp (64-Bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - Timestamp compact (32-Bit)


EP5151-0002 - PDO-Zuordnung

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] Prozessdaten [image] EP5151-0002 - PDO-Zuordnung
EP5151-0002 - PDO-Zuordnung
PDO-Zuordnung und Inhalte am Beispiel EP5151-0002
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld Sync Manager (siehe Abb.oben) den gewünschten Sync Manager (editierbar sind hier SM 2 + SM 3). Im Feld darunter PDO Assignment können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | 0x7000:01 - Enable Latch C 0x7000:02 - Enable Latch extern on positive edge 0x7000:03 - Set counter 0x7000:04 - Enable Latch extern on negative edge 0x7000:11 - Set counter value (32-bit)
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt (Index - Name)
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (16-Bit) 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | 0x6000:01 - Latch C valid 0x6000:02 - Latch extern valid 0x6000:03 - Set counter done 0x6000:04 - Counter underflow 0x6000:05 - Counter overflow 0x6000:06 - Status of input status 0x6000:07 - Open circuit 0x6000:08 - Extrapolation stall 0x6000:09 - Status of input A 0x6000:0A - Status of input B 0x6000:0B - Status of input C 0x6000:0C - Status of input gate 0x6000:0D - Status of extern latch 0x1C32:20 - Sync error 0x1800:07 - TxPDO State 0x1800:09 - TxPDO Toggle 0x6000:11 - Counter value (32-Bit) 0x6000:12 - Latch value (32-Bit)
0x1A02 | 0x1A03 | 4.0 | ENC Frequency | 0x6000:13 - Frequency value
0x1A03 | 0x1A02 | 4.0 | ENC Period | 0x6000:14 - Period value
0x1A04 | 0x1A05 | 8.0 | ENC Timest. | 0x6000:16 - Timestamp (64-Bit)
0x1A05 | 0x1A04 | 4.0 | ENC Timest. compact | 0x6000:16 - Timestamp compact (32-Bit)


DC (Distributed Clocks)

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] DC (Distributed Clocks)
DC (Distributed Clocks)
Beschreibt, ob das Modul mit Unterstützung von Distributed Clocks-betrieben wird:
Distributed Clocks
▪
FreeRun: das Modul arbeitet Frame-getriggert, der zyklische Betrieb wird durch die SyncManager der EtherCAT-Frame-Bearbeitung gestartet.
▪
DC-Synchron: der Zyklische Betrieb in dem Modul wird durch die lokale Distributed Clock in exakten Zeitabständen gestartet. Dabei ist der Startzeitpunkt so gewählt, dass er mit anderen Output-Slaves im EtherCAT-System zusammenfällt.
▪
DC-Synchron (input based): Arbeitsweise wie DC-Synchron, aber der zyklische Startzeitpunkt ist so gewählt, dass er mit anderen Input-Slaves im EtherCAT-System zusammenfällt.


Features CoE

Inbetriebnahme/Konfiguration [image] EP51x1-x0xx - Parameter und Modi [image] Features CoE
Features CoE
Abhängig von den Haupt-PDO/optionalen PDO sind im CoE (CAN over EtherCAT)-Verzeichnis weitere Einstellungen anwählbar.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
CoE-Reload zum Zurücksetzen der Veränderungen
Folgende CoE-Einstellungen aus dem Objekt 0x8000 sind möglich und hier in den Default-Einstellungen am Beispiel der EP5101-0011 wiedergegeben:
Objekt 0x8000 - Default am Beispiel EP5101-0011
Die Parameter werden im Kapitel Objektbeschreibung der entsprechenden EtherCAT-Box erläutert.
▪
Auf Grund der unterschiedlichen Pin-Belegung werden die folgenden Objekte von der Modulen EP51x1-x002 nicht unterstützt!
–
0x8000:02 - Enable extern reset
–
0x8000:04 - Gate polarity
–
0x8000:10 - Extern reset polarity
▪
Auf Grund einer anderen Firmware werden die folgenden Objekte von dem Modul EP5101-2011 nicht unterstützt!
–
0x8000:03 - Enable up/down counter
–
0x8000:08 - Disable filter
–
0x8000:0A - Enable micro increments
Weitere Hinweise
Frequenz
▪
Das Zeitfenster für die Frequenzberechnung sowie die Auflösung kann in den CoE-Objekten Frequency window 0x8000:11, Frequency scaling 0x8000:13, Frequency resolution 0x8000:15, Frequency wait time 0x8000:17 parametriert werden.
▪
Es werden die positiven Flanken der Spur A im angegebenen Zeitfenster gezählt und die nächste folgende Flanke inkl. der Zeit bis dahin gezählt. Die Zeit, wie lange auf die Flanke gewartet wird, ist im CoE Objekt Frequency Wait Time 0x8000:17 einstellbar (Einheit: ms) und standardmäßig auf 1,6 s gesetzt. Das ist auch der Maximalwert.
▪
Das Zeitfenster ist 10 ms (default), min. 1 µs. Mit der Standardeinstellung können Frequenzen bis ca. 800 kHz gemessen werden, bei höheren Frequenzen ist ein kleinerer Wert für das Zeitfenster zu wählen.
▪
Die Zeit wird mit einer Auflösung von 100 ns gemessen.
▪
Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
▪
Wenn der Zähler durch das Gate gesperrt ist, ist keine Frequenzmessung möglich; die Messung der Periodendauer kann in diesem Fall trotzdem durchgeführt werden.
▪
Ein C- oder externer Reset startet die Frequenzmessung neu, der zuletzt ausgegebene Frequenzwert bleibt bis zur Ermittlung eines neuen Frequenzwertes unverändert.
Frequenzmessung
▪
Basiseinheit 1 µs: alle Fenstergrößen
Ablauf der Messung
▪
Die Messung beginnt mit einer steigenden Flanke der Spur A, aktueller Zählerstand und Zeit (Auflösung: 100 ns) werden gespeichert.
▪
Nach Ablauf des Messfensters (Index 0x8000:11) wird noch bis zur folgenden steigenden Flanke an Spur A gewartet, maximal jedoch 1,6 s bzw. die Zeit aus Frequency Wait Time 0x8000:17.
▪
Die Frequenz wird berechnet aus der Flankendifferenz und der real vergangenen Zeit.
Prinzip Frequenzmessung im erweiterten Betriebsmodus
Periodenberechnung
▪
Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
▪
Es wird in jedem Zyklus der Abstand zwischen 2 positiven Flanken von Eingang A gezählt.
▪
Ereignet sich 1,6 s lang kein Flankenwechsel, wird die evtl. bestehende Periodenangabe gelöscht.
Latch
▪
Aktivierung des Latch C-Eingangs (Enable latch C Index 0x7000:01) und Speichern ("Latchen") des Zählerstandes
–
Beim ersten externen Latchimpuls (positive Flanke an Eingang "C") nach gesetztem Bit (TRUE) in Enable latch C Index 0x7000:01 wird der Counterwert gespeichert (hat Vorrang vor Enable latch extern on positive / negative edge 0x7000:02 / 0x7000:04). Die folgenden Impulse an den anderen Eingängen haben bei gesetztem Bit keinen Einfluss auf den Latch-Wert in Index 0x6000:12.
–
Hinweis Latch C valid - Bit: Erst wenn der Wert des Latch C valid - Bit (Index 0x6000:01) FALSE ist, kann ein neuer Counterwert auf den Latch-Eingang geschrieben werden.
▪
Aktivierung des externen Latch-Eingangs ("Gate/Latch") und Verriegeln ("Latchen") des Zählerstandes (Index 0x7000:02, 0x7000:04) (nicht bei EP5101-x002)
–
Bei gesetztem Bit (TRUE) in Enable latch extern on positive edge Index 0x7000:02 wird beim ersten externen Latchimpuls mit steigender Flanke der Counterwert auf den Latch-Eingang (Index 0x6000:12) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert in Index 0x6000:12.
–
Bei gesetztem Bit (TRUE) in Enable latch extern on negative edge Index 0x7000:04 wird beim ersten externen Latchimpuls mit fallender Flanke der Counterwert auf den Latch-Eingang (Index 0x6000:12) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert in Index 0x6000:12.
–
Hinweis Latch extern valid - Bit: Erst wenn der Wert des Latch extern valid - Bit Index 0x6000:02) FALSE ist, kann ein neuer Counterwert auf den Latch-Eingang geschrieben werden.
Reset
▪
Reset des Zählers über den Eingang C:
–
Für den Zähler-Reset ist das Bit in Enable latch C Index 0x8000:01 zu setzen.
▪
Reset des Zählers über den externen Latch-Eingang (nicht für EP5101-x002)
–
Für den Reset über den externen Latch-Eingang ist das Bit in Enable extern reset Index 0x8000:02 zu setzen
–
Über Extern reset polarity Index 0x8000:10 besteht die Möglichkeit zur Auswahl der Flanke, um den Zähler auf null zu setzen.
• Bit nicht gesetzt: Zähler wird mit fallender Flanke auf null gesetzt.
• Bit gesetzt: Zähler wird mit steigender Flanke auf null gesetzt.
▪
Die Aktivierung der Funktionen Enable C reset (0x8000:01) und das Enable extern reset (0x8000:02) sind gleichzeitig nicht möglich.
Vorwärts-/Rückwärts-Zähler
▪
Die Betriebsartenwahl (Encoder oder V/R-Zähler) wird über Enable up/down counter Index 0x8000:03 vorgenommen. (nicht für EP5101-2011)
–
Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizex,
–
geben Sie den Wert "1" im SetValue-Dialog ein und
–
bestätigen Sie mit OK.
▪
Ebenso ist über das Objekt 0x8000:04 die Gate-Polarität einzustellen.
▪
Eine zusätzliche Option zur Drehrichtungsumkehr ist mit Setzen des Bits in Reversion of rotation Index 0x8000:0E gegeben.
Over-/Underflow (nicht für EP5101-2011)
▪
In Kombination mit einer aktivierten Reset-Funktion (C/extern) ist die Over-/Underflowkontrolle unwirksam.
▪
Das Underflow-Bit (0x6000:04) wird gesetzt, wenn ein Unterlauf ...00 ->...FF eintritt. Es wird zurückgesetzt, wenn 2/3 des Zählerbereiches unterschritten werden.
▪
Das Overflow-Bit (0x6000:05) wird gesetzt, wenn ein Überlauf FF...-> 00... eintritt. Es wird zurückgesetzt, wenn 1/3 des Zählerbereiches überschritten werden.
Drahtbrucherkennung / Open circuit detection
▪
Für die Kanäle A, B und C kann jeweils separat eine Drahtbrucherkennung aktiviert werden (Index 0x8000:0B, 0x8000:0C, 0x8000:0D).
▪
Standardmäßig ist die Drahtbrucherkennung für die Kanäle A und B aktiviert.
▪
Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert.
▪
Ein erkannter Drahtbruch wird als Prozessdatum Open circuit =TRUE angezeigt (Bit in Objekt Open circuit 0x6000:07 wird gesetzt). Die separate Anzeige eines Drahtbruchs wird in den Indizes 0xA000:01 (Spur A), 0xA000:02 (Spur B) und 0xA000:03 (Spur C) angezeigt.
▪
TxPDO State wird bei einem erkannten Drahtbruch ebenfalls TRUE, da von ungültigen Daten ausgegangen werden muss.
Mikroinkremente
▪
Arbeitet mit und ohne Distributed Clocks, ist aber in der EP51x1 nur in Verbindung mit einem der DC-Modi sinnvoll.
▪
Über das Zählerstand-Setzen kann nur der ganzzahlige Anteil verändert werden.
▪
das Prinzip Frequenzmessung im erweiterten Betriebsmodus:
DC-gestützte Mikroinkremente
Die hochkonstante Abfragezyklen (Genauigkeit: 100 ns) des Distributed Clocks-Systems erlauben es der EP51x1, ab einer bestimmten Geschwindigkeit interpolierte Achspositionen zwischen die gezählten Encoder-Inkremente zu interpolieren. Die Interpolationsauflösung beträgt dabei 8 Bit entsprechend 256 Werte. Ein Standard-Encoder mit 1.024 Strichen wird so mit 4-fach Auswertung und Mikroinkrementen zu einem hochauflösenden Achsgeber mit 4096 x 256 = 1.048.567 Strichen.
Die Unterschreitung der Mindestgeschwindigkeit wird durch das Objekt Extrapolation stall 0x6000:08 (nicht bei EP5101-2011) in den Prozessdaten angezeigt.


EP5001 - Schnittstellenpegel

Inbetriebnahme/Konfiguration [image] EP5001 - Schnittstellenpegel
EP5001 - Schnittstellenpegel
Die EP5001-0002 erwartet Pegel nach RS485.
Die typ. output level gelten bei einer Last von minimal 60 Ohm.
Differentieller Signaleingang
Spannungspegel für differentiellen Modus
Die EP5001-0002 unterstützt den Single ended Modus nicht.


EP5101 - Schnittstellenpegel

Inbetriebnahme/Konfiguration [image] EP5101 - Schnittstellenpegel
EP5101 - Schnittstellenpegel
Die EP5101-x00x erwartet im Differentialmode die Pegel nach RS422. Die Daten werden ohne Massebezug als Spannungsdifferenz zwischen zwei Leitungen (Signal A und invertiertes Signal /A) übertragen. Das Modul wertet Pegel von -200mV < Vid < +200mV als gültige Signale aus. Das Differenzsignal muss im Common Mode Bereich (<+13,2 V und >-10 V, in Bezug zu GND) liegen (vgl. Abbildung), Pegel außerhalb dieses Bereiches können zur Zerstörung führen
EP5101 Pegel Schnittstelle
Im Differentialmode wird nur die Spannungsdifferenz ausgewertet, so dass Gleichtaktstörungen auf der Übertragungsstrecke zur keiner Verfälschung des Nutzsignals führen, da diese Störung auf beide Leitungen gleichzeitig wirken.
Wird die EP5101 nur im Single Ended Modus betrieben, wird eine Pegelspannung von nominell 3,5 V bis 5,5 V erwartet.
Für die EP5101-x00x Versionen wird die Drahtbrucherkennung / Open circuit detection im Bereich typ. -1,5 V > Vid > +1,5 aktiviert (Änderungen vorbehalten).


EP5151 - Schnittstellenpegel

Inbetriebnahme/Konfiguration [image] EP5151 - Schnittstellenpegel
EP5151 - Schnittstellenpegel
Die EP5151 erwartet Pegel nach HTL (Push-Pull).
Differentieller Signaleingang
Spannungspegel für differentiellen Modus


EP5001-0002 - Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] EP5001-0002 - Objektbeschreibung und Parametrierung
EP5001-0002 - Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind.
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01F51389 (32838537dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP5001-0002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | -
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Default-Einstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13894052 (327762002dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1800 SSI TxPDO-Par Inputs
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1801:0 | SSI TxPDO-Par Inputs | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1A00 SSI TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A00:0 | SSI TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x01 (Data error)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x02 (Frame error)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x03 (Power failure)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (SSI Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0xC00B (49163dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00030D40 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
-
UINT32
RO
0x000001B0 (7600dez)
1C33:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x000001B0 (7600dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 6000 SSI Inputs
Index (hex) | Name | Bedeutung | Data type | Flags | Default
6000:0 | SSI Inputs | Länge dieses Objekts | UINT8 | RO | 0x11 (17dez)
6000:01 | Data error | Fehler am SSI-Eingang: - SSI hat keine Spannungsversorgung - Drahtbruch auf den SSI-Dateneingänge D+ oder D- - Datenleitungen vertauscht Wenn keine Datenübertragung stattfindet, liegt der SSI-Eingang der Klemme auf Low-Pegel. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Frame error | Es liegt ein falscher Datenrahmen vor, d. h. der Datenrahmen wurde nicht mit Null abgeschlossen (evtl. Drahtbruch auf Clock-Leitungen) | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Power failure | Es ist ein geberspezifischer Fehler aufgetreten. Dieses Fehlerbit wird nur angezeigt, wenn es zuvor durch Enable power failure bit Index 0x8000:02 aktiviert wurde. | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EP5001-0002 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
Index 8000 SSI Settings
Index (hex) | Name | Bedeutung | Data type | Flags | Default
8000:0 | SSI Settings | Länge dieses Objekts | UINT8 | RO | 0x13 (19dez)
8000:01 | Disable frame error | 0: Frame-Error wird nicht unterdrückt 1: Frame-Error wird unterdrückt | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable power failure bit | 0: Power-Failure-Bit ist nicht aktiv 1: Power-Failure-Bit ist aktiv: das letztes Bit des Datenrahmens (geberspezifisches Fehlerbit) wird als Fehlerbit im Objekt Power failure (Index 0x6000:03) und Bit 2 des Status-Worts eingeblendet. | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable inhibit time | 0: Inhibit-Zeit ist nicht aktiv 1: Inhibit-Zeit ist aktiv | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Enable test mode | 0: Test mode ist nicht aktiv 1: Test mode ist aktiv | BOOLEAN | RW | 0x00 (0dez)
8000:06 | SSI-coding | 0: Binär-Code aktiv 1: Gray-Code aktiv | BIT1 | RW | 0x01 (1dez)
8000:09 | SSI-baudrate | 0: reserviert 1: 1250 kBaud 2: 1000 kBaud 3: 500 kBaud 4: 250 kBaud 5: 125 kBaud 6 - 65535: reserviert | BIT3 | RW | 0x03 (3dez)
8000:0F | SSI-frame type | 0: Multiturn-Auswertung aktiv (25 Bit Datenrahmen) 1: Singleturn-Auswertung aktiv (13 Bit Datenrahmen) 2: Variable Auswertung aktiv. Die Länge des Datenrahmens (1 bis 32 Bit) wird mit Objekt SSI-frame size (Index 0x8000:11) festgelegt. | BIT2 | RW | 0x00 (0dez)
8000:11 | SSI-frame size | Länge des SSI-Datenrahmens (in Bit) | UINT16 | RW | 0x0019 (25dez)
8000:12 | SSI-data length | Datenlänge | UINT16 | RW | 0x0018 (24dez)
8000:13 | Min. inhibit time[µs] | Minimale Inhibit-Zeit in µs (1 bis 65535) | UINT16 | RW | 0x0000 (0dez)
Index 800D SSI Advanced Settings
Index (hex) | Name | Bedeutung | Data type | Flags | Default
800D:0 | SSI Advanced Settings | SSI Advanced Settings |  | RW | 0x03 (3dez)
800D:01 | Encoder power supply on | Schaltet die 24 V Versorgungsspannung |  | RW | 0x01 (1dez)
800D:02 | Encoder direction pin on | Schaltet die 24 V am direction pin |  | RW | 0x00 (0dez)
800D:03 | Encoder reset pin on | Schaltet die 24 V am reset pin |  | RW | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word (ab FW11 bei EL5001)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F010:0 | Module list | Länge dieses Objekts | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x000001F5 (501dez)


EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Standardobjekte


Restore-Objekt

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über die C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable up/down counter | Freigabe des V/R-Zählers an Stelle des Encoders bei gesetztem Bit. Gezählt werden Inkremente am Eingang A, Zählrichtung gibt Eingang B vor. | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x01 (1dez)
8000:0A | Enable micro increments | Bei Aktivierung interpolieren die EP5101-0002 und EP5101-1002 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 bit des Counter Value benutzt. Aus einem 32-bit-Zähler wird so ein 24+8bit Zähler, aus einem 16-bit-Zähler ein 8+8bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8000:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs]. Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. Frequency Wait Time lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird im Objekt Frequency value (Index 0x6000:13) und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8000:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
8000:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Objekt Period scaling (Index 0x8000:14) (z. B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:17 | Frequency wait time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums Frequency erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dez)


Eingangsdaten

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch C (Index 0x7000:01) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über die Objekte Open circuit detection A Index 0x8000:0B, Open circuit detection B Index 0x8000:0C, Open circuit detection C Index 0x8000:0D | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig. | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EP51x1 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in den Objekten Frequency scaling Index 0x8000:13 und Frequency resolution Index 0x8000:15) | UINT32 | RO | 0x00000000 (0dez)
6000:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in den Objekten Period scaling Index 0x8000:14 und Period resolution Index 0x8000:16) | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs | Maximaler subindex | UINT8 | RO | 0x11(17dez)
7000:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über Set counter (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (dez)


Informations-/Diagnosedaten (kanalspezifisch)

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A000 ENC Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
A000:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)


Standardobjekte

Inbetriebnahme/Konfiguration [image] EP5101-0002, EP5101-1002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01FF1389 (33493897dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP5101-0002 EP5101-1002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED4052 (334315602dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact (EP5101-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
1600:07 | SubIndex 007 | 7. reserviert | UINT32 | RO | -
Index 1600 ENC RxPDO-Map Control compact (EP5101-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control (EP5101-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x06 (6dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), ventry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00,5
1601:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
1601:07 | SubIndex 007 | 7. reserviert | UINT32 | RO | -
Index 1601 ENC RxPDO-Map Control (EP5101-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen. | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten. | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem Aktualisieren der zugehörigen Eingangsdaten getoggelt. | BOOLEAN | RO | 0x00 (0dez)
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen. | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten. | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem Aktualisieren der zugehörigen Eingangsdaten getoggelt. | BOOLEAN | RO | 0x00 (0dez)
Index 1802 ENC TxPDO-Par Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen. | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen. | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timestamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Timestamp | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen. | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timestamp compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Timestamp compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen. | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact (EP5101-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status compact | UINT8 | RO | 0x011 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (2 bit align) | UINT32 | RO | 0x0000:00, 2
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
1A00:12 | SubIndex 018 | reserviert | UINT32 | RO | -
Index 1A00 ENC TxPDO-Map Status compact (EP5101-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status compact | UINT8 | RO | 0x012 (18dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status (EP5101-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (2 bit align) | UINT32 | RO | 0x0000:00, 2
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
1A01:12 | SubIndex 018 | 18. reserviert | UINT32 | RO | -
Index 1A01 ENC TxPDO-Map Status (EP5101-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | ENC TxPDO-Map Status | UINT8 | RO | 0x12 (18dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Frequency | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Period | ENC TxPDO-Map Period | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. | ENC TxPDO-Map Timest. | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | ENC TxPDO-Map Timest. compact | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FE (510dez)


EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Standardobjekte


Restore-Objekt

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über die C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24 V). | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable up/down counter | Freigabe des V/R-Zählers an Stelle des Encoders bei gesetztem Bit. Gezählt werden Inkremente am Eingang A, Zählrichtung gibt Eingang B vor. | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit HIGH-Pegel) 2: Enable neg. gate (Gate sperrt mit LOW-Pegel) | BIT2 | RW | 0x01 (1dez)
8000:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x01 (1dez)
8000:0A | Enable micro increments | Bei Aktivierung interpoliert die EP5101-0011 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 bit des Counter Value benutzt. Aus einem 32-bit-Zähler wird so ein 24+8bit Zähler, aus einem 16-bit-Zähler ein 8+8bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8000:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT2 | RW | 0x01 (1dez)
8000:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs]. Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. Frequency Wait Time lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird im Objekt Frequency value (Index 0x6000:13) und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8000:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
8000:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Objekt Period scaling (Index 0x8000:14) (z. B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
8000:17 | Frequency wait time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums Frequency erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dez)


Eingangsdaten

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch C (Index 0x7000:01) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch extern on positive edge (Index 0x7000:02) bzw. Objekt Enable latch extern on negative edge (Index 0x7000:04) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über die Objekte: Open circuit detection A Index0x8000:0B, Open circuit detection B Index0x8000:0C, Open circuit detection C Index0x8000:0D | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig. | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern ledge | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EP5101-0011 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:13 | Frequency value | Die Frequenz (Einstellung der Skalierung in Index 0x8000:13 und Auflösung in Index 0x8000:15) | UINT32 | RO | 0x00000000 (0dez)
6000:14 | Period value | Die Periodendauer (Einstellung der Skalierung in Index 0x8000:14 und Auflösung in Index 0x8000:16) | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs | Maximaler subindex | UINT8 | RO | 0x11(17dez)
7000:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:01 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über Set counter (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (dez)


Informations-/Diagnosedaten (kanalspezifisch)

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A000 ENC Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
A000:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)


Standardobjekte

Inbetriebnahme/Konfiguration [image] EP5101-0011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01FF1389 (33493897dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP5101-0011
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED4052 (334315602dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs),entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x700:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x700:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1802 ENC TxPDO-Par Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timest.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status | ENC TxPDO-Map Status compact | UINT8 | RO | 0x012 (18dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C; 2
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D; 2
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (18dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 |  | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) |  |  | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A02 ENC TxPDO-Map Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Frequency | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Period | ENC TxPDO-Map Period | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FE (510dez)
F010:02 | SubIndex 002 | reserviert | UINT32 | RW | 0x000001FF (511dez)


EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Standardobjekte


Restore-Objekt

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über die C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24 V). | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit HIGH-Pegel) 2: Enable neg. gate (Gate sperrt mit LOW-Pegel) | BIT2 | RW | 0x01 (1dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8000:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT2 | RW | 0x01 (1dez)
8000:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs]. Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. Frequency Wait Time lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird im Objekt Frequency value (Index 0x6000:13) und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8000:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
8000:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Objekt Period scaling (Index 0x8000:14) (z. B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:17 | Frequency wait time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums Frequency erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dez)


Eingangsdaten

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch C (Index 0x7000:01) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch extern on positive edge (Index 0x7000:02) bzw. Objekt Enable latch extern on negative edge (Index 0x7000:04) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über die Objekte: Open circuit detection A Index 0x8000:0B, Open circuit detection B Index 0x8000:0C, Open circuit detection C Index 0x8000:0D | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern ledge | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EP5101-2011 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in Index 8000:13 und 8000:15) | UINT32 | RO | 0x00000000 (0dez)
6000:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in Index 8000:14 und 8000:16) | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs | Maximaler subindex | UINT8 | RO | 0x11(17dez)
7000:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über Set counter (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (dez)


Informations-/Diagnosedaten (kanalspezifisch)

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A000 ENC Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
A000:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)
A000:04 | Field power failure | Fehler Feldbusspannung | BOOLEAN | RO | 0x00 (0dez)


Standardobjekte

Inbetriebnahme/Konfiguration [image] EP5101-2011 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01FF1389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP5101-2011
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED4052 (334315602dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs),entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x700:11, 32
Index 1601 ENC RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7002:00,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x700:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x700:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,16
Index 1800 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1802 ENC TxPDO-Par Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timest.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status | ENC TxPDO-Map Status compact | UINT8 | RO | 0x011 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A02 ENC TxPDO-Map Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Period | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14, 32
Index 1A03 ENC TxPDO-Map Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Frequency | ENC TxPDO-Map Frequency | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6010:13,32)
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:06
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:06
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FF (511dez)


EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus

Inbetriebnahme/Konfiguration [image] EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Standardobjekte


Restore-Objekt

Inbetriebnahme/Konfiguration [image] EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme/Konfiguration [image] EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über die C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24 V). | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable up/down counter | Freigabe des V/R-Zählers an Stelle des Encoders bei gesetztem Bit. Gezählt werden Inkremente am Eingang A, Zählrichtung gibt Eingang B vor. | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit HIGH-Pegel) 2: Enable neg. gate (Gate sperrt mit LOW-Pegel) | BIT2 | RW | 0x01 (1dez)
8000:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x01 (1dez)
8000:0A | Enable micro increments | Bei Aktivierung interpoliert die EP5151-0002 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 bit des Counter Value benutzt. Aus einem 32-bit-Zähler wird so ein 24+8bit Zähler, aus einem 16-bit-Zähler ein 8+8bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Objekt Open circuit (Index 0x6000:07) und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8000:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT2 | RW | 0x01 (1dez)
8000:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs]. Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. Frequency Wait Time lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird im Objekt Frequency value (Index 0x6000:13) und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8000:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
8000:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Objekt Period scaling (Index 0x8000:14) (z. B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
8000:17 | Frequency wait time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums Frequency erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. T >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dez)


Eingangsdaten

Inbetriebnahme/Konfiguration [image] EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch C (Index 0x7000:01) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Latch Value (Index 0x6000:12) entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Enable latch extern on positive edge (Index 0x7000:02) bzw. Objekt Enable latch extern on negative edge (Index 0x7000:04) erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Objekt: Open circuit detection A Index 0x8000:0B, Open circuit detection B Index 0x8000:0C, Open circuit detection C Index 0x8000:0D, | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig. | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern ledge | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EP5151-0002 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:13 | Frequency value | Die Frequenz (Einstellung der Skalierung in Index 0x8000:13 und Auflösung in Index 0x8000:15) | UINT32 | RO | 0x00000000 (0dez)
6000:14 | Period value | Die Periodendauer (Einstellung der Skalierung in Index 0x8000:14 und der Auflösung in Index 0x8000:16) | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme/Konfiguration [image] EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs | Maximaler subindex | UINT8 | RO | 0x11(17dez)
7000:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:01 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über Set counter (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (dez)


Standardobjekte

Inbetriebnahme/Konfiguration [image] EP5151-0002 - Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01FF1389 (33493897dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP5151-0002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED4052 (334315602dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01,1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02,1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x700:03,1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x700:04,1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00,4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00,8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11,32
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen. | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten. | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem Aktualisieren der zugehörigen Eingangsdaten getoggelt. | BOOLEAN | RO | 0x00 (0dez)
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen. | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten. | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem Aktualisieren der zugehörigen Eingangsdaten getoggelt. | BOOLEAN | RO | 0x00 (0dez)
Index 1802 ENC TxPDO-Par Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen. | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen. | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Timestamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Timestamp | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen. | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timestamp compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Timestamp compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen. | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status | ENC TxPDO-Map Status compact | UINT8 | RO | 0x012 (18dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Frequency | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Period | ENC TxPDO-Map Period | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:14,32
Index 1A04 ENC TxPDO-Map Timest.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write(Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:06
Minim delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x01 (1dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FF (511dez)


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.