EP5101-0002, EP5101-0011 - Inkremental-Encoder-Interface

BECKHOFF Feldbuskomponenten

Dokumentation zu

EP5101-0002, EP5101-0011

EtherCAT Box mit Inkremental-Encoder-Interface

Version: 1.2.0
Datum: 14.01.2014

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


EP5101 - Ausgabestände der Dokumentation

BECKHOFF EP5101: Vorwort

Ausgabestände der Dokumentation

Version Kommentar
1.2.0
  • Schnittstellenpegel ergänzt (single ended und differentielle Signale)
1.1.0
  • Beschreibung des Power-Anschlusses aktualisiert
  • Hinweis auf die Dokumentation "Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)" hinzugefügt.
1.0.0
  • erste Veröffentlichung

Firm- und Hardware-Stände

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.

Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.

Dokumentation Version | EP5101-0002 |  | EP5101-0011
 | Firmware | Hardware | Firmware | Hardware
1.1.0 | 01 | 04 | 01 | 04
1.0.0 | 01 | 04 | 01 | 04

Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.

Syntax der Batch-Nummer (D-Nummer)

WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 55 09 01 00:

55 - Produktionswoche 55
09 - Produktionsjahr 2009
01 - Firmware-Stand 01
00 - Hardware-Stand 001


EtherCAT Box - Einführung

Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP 67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.

Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.

Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.

Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.

Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:

  • digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)

  • digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom

  • analoge Ein- und Ausgänge mit 16 Bit Auflösung

  • Thermoelement- und RTD-Eingänge

  • Schrittmotormodule

Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.

EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren | EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren

Hinweis 		Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.

Hinweis 		XML-Dateien
XML-Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP5101 - Einführung

Inkremental-Encoder-Interface

Die EtherCAT Box EP5101 ist ein Interface zum direkten Anschluss von Inkremental-Encodern mit Differenzeingängen (RS485). Ein 32/16-Bit-Zähler mit Quadraturdecoder sowie ein 32/16-Bit-Latch für den Nullimpuls können gelesen, gesetzt oder aktiviert werden. An den Statuseingang des Interfaces sind Inkremental-Encoder mit Störmeldeausgang anschließbar. Eine Periodendauermessung mit einer Auflösung von bis zu 100 ns ist möglich. Der Gate-Eingang erlaubt das Sperren des Zählers; der Latch-Eingang übernimmt den Zählerstand mit steigender Flanke.

Durch die optionale interpolierende Mikroinkrement-Funktionalität kann die EP5101 bei dynamischen Achsen noch genauere Achspositionen liefern. Zudem unterstützt sie über hochpräzise Distributed Clocks (DC) das synchrone Einlesen des Geberwertes zusammen mit anderen Eingangsdaten im EtherCAT-System.

Der Anschluss des Gebers erfolgt über eine 8-polige M12-Buchse (EP5101-0002) oder über eine 15-polige D-Sub-Buchse (EP5101-0011). In der M12-Variante stehen nicht alle Signale zur Verfügung.

Quick-Links

Installation

Konfiguration

UL-Anforderungen für UL-zugelassene Module

ATEX - Besondere Bedingungen für ATEX-zugelassene Module


EP5101 - Technische Daten

Technische Daten | EP5101-0002 | EP5101-0011
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Encoder-Eingänge | 1
Anschluss Encoder | M12-Buchse, 8-polig | D-Sub-Buchse, 15-polig
Encoder-Versorgung | +5 VDC, 150 mA
Zähler | 32 oder 16 Bit, binär
Grenzfrequenz | 4 Mio. Inkremente/s (bei Vierfachauswertung)
Quadraturdecoder | Vierfachauswertung
Nullimpuls-Latch | 16 Bit
Befehle | Lesen, Setzen, Aktivieren
Distributed Clocks | ja
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 130 mA + Last
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Prozessabbild | Eingänge: 32 Bit Daten, 8 Bit Status Ausgänge: 16 Bit Daten, 8 Bit Control
Potenzialtrennung | Steuerspannung / Feldbus: 500 V
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) 0°C ... +55°C (gemäß cULus siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus, ATEX


EP5101-0002 - Prozessabbild

Der TwinCAT System-Manager zeigt die Daten des EP5101-0002 in einer Baumstruktur an.

Unter ENC Status Compact finden Sie die Eingangs-Daten des Encoder-Interfaces.

Status
  • Latch C valid - in den Prozessdaten "Latch value" stehen neue Daten bereit. Reset durch "Enable latch C"
  • Set Counter done - Quitierung zum setzen des "Set counter"
  • Counter underflow - Zähler unterschreitet den kleinsten, darstellbaren Zählwert
  • Counter overflow - Zähler überschreitet den höchsten, darstellbaren Zählwert
  • Open circuit - einer der Kanäle A, B oder C hat einen Drahtbruch (einstellbar je Kanal über CoE)
  • Extrapolation stall - Microincrement-Wert ungültig (Bei aktivierter Microinkrement-Auswertung -> Index 8010:0a)
  • Status of Input A - Status des Eingangs A
  • Status of Input B - Status des Eingangs B
  • Status of input C - Status des Eingangs C
  • Sync error - EtherCAT Fehler, siehe EtherCAT System-Dokumentation
  • TxPDO State - siehe Objektbeschreibung
  • TxPDO Toggle - siehe Objektbeschreibung

Counter value - aktueller Zählwert des Encoders

Latch value - Zählwert des Encoders bei steigender Flanke am Latch-Eingang

Unter ENC Control Compact finden Sie die Ausgangs-Daten des Encoder-Interfaces.
Control
  • Enable latch C - Eingang C wird freigegeben. Bei einer Flanke wird "Counter value" in "Latch value" gespeichert.
  • Set counter - bei positiver Flanke Übernahme von "Set Counter value " in "Counter value"

Set Counter value - Vorwahlwert für "Counter value"


EP5101-0011 - Prozessabbild

Der TwinCAT System-Manager zeigt die Daten des EP5101-0011 in einer Baumstruktur an.

Unter ENC Status Compact finden Sie die Eingangs-Daten des Encoder-Interfaces.

Status
  • Latch C valid - in den Prozessdaten "Latch value" stehen neue Daten bereit. Reset durch "Enable latch C"
  • Set Counter done - Quitierung zum Setzen des "Set counter"
  • Counter underflow - Zähler unterschreitet den kleinsten, darstellbaren Zählwert
  • Counter overflow - Zähler überschreitet den höchsten, darstellbaren Zählwert
  • Status of input status - Status des Error-Signal (typisch vom Encoder kommend)
  • Open circuit - einer der Kanäle A, B oder C hat einen Drahtbruch (einstellbar je Kanal über CoE)
  • Extrapolation stall - Microincrement-Wert ungültig (Bei aktivierter Microinkrement-Auswertung -> Index 8010:0a)
  • Status of Input A - Status des Eingangs A
  • Status of Input B - Status EIdes Eingangs B
  • Status of input C - Status des Eingangs C
  • Status of input gate - Status des Gate-Eingangs
  • Status of extern latch - Status des Latch-Eingangs
  • Sync error - EtherCAT Fehler, siehe EtherCAT System-Dokumentation
  • TxPDO State - siehe Objektbeschreibung
  • TxPDO Toggle - siehe Objektbeschreibung

Counter value - aktueller Zählwert des Encoders

Latch value - Zählwert des Encoders bei steigender Flanke am Latch-Eingang

Unter ENC Control Compact finden Sie die Ausgangs-Daten des Encoder-Interfaces.
Control
  • Enable latch C - Eingang C wird freigegeben. Bei einer Flanke wird "Counter value" in "Latch value" gespeichert.
  • Enable latch extern on positive edge - Triggermodus des Latch Eingangs festlegen -> positive Flanke
  • Set counter - bei positiver Flanke Übernahme von "Set Counter value " in "Counter value"
  • Enable latch extern on negative edge - Triggermodus des Latch Eingangs festlegen -> negative Flanke

Set Counter value - Vorwahlwert für "Counter value"


EtherCAT Box - Zubehör

Befestigung
Bestellangaben | Befestigung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial
Bestellangaben | Beschriftungsmaterial
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder unbedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage


EtherCAT Box - Abmessungen

BECKHOFF EtherCAT Box: Montage und Verkabelung

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | EtherCAT Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Zulassungen | CE
Gewicht | ca. 120 g - 200 g, je nach Modultyp


EPxxxx - Befestigung

BECKHOFF EtherCAT Box: Montage und Verkabelung

Befestigung

Hinweis 		Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung!

Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind!
Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.

Die Module werden mit zwei M3-Schrauben befestigt. Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher besitzen kein Gewinde. Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.

Montageschiene ZS5300-0001

Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module. Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3 Gewinden. Mittels M5 Schrauben (5,3 mm Langlöcher) kann die Schiene an der Maschine befestigt werden.

Die Schiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 Modulen. Sie kann applikationsspezifisch gekürzt werden.


EPxxxx - Anzugsmomente für Steckverbinder

BECKHOFF EtherCAT Box: Montage und Verkabelung

Anzugsmomente für Steckverbinder

M8-Steckverbinder für Sensoren, Aktoren, Spannungsversorgung und EtherCAT

Es wird empfohlen die M8-Steckverbinder für Sensoren, Aktoren, Spannungsversorgung und EtherCAT mit einem Drehmoment von 0,4 Nm festzuziehen.

M12-Steckverbinder für Sensoren und Aktoren

Es wird empfohlen die M12-Steckverbinder für Sensoren und Aktoren mit einem Drehmoment von 0,6 Nm festzuziehen.


EtherCAT-Anschluss

Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt

  • die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
  • die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8 | Koppler Box: M12

Belegung

Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZK1090-6292 | ZB903x, ZK1090-31xx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm

1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003

2) Aderfarben nach EN 61918

3) Aderfarben

EtherCAT-Steckverbinder

Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.

Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12 | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8 | vierpolig, IP67, feldkonfektionierbar


Feldbus-LEDs

BECKHOFF EtherCAT Box: Montage und Verkabelung

EtherCAT- Feldbus-LEDs

LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational

Hinweis 		EtherCAT-Stati
Die verschiedenen Stati, die eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


EtherCAT-Leitung

BECKHOFF Feldbuskomponenten: Montage und Verkabelung

EtherCAT-Kabel

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.

Hinweis 		Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.Beckhoff.de zum Download zur Verfügung steht.

EtherCAT nutzt vier Adern der Kabel für die Signalübertragung. Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.

Es folgt eine Auswahl an Kabel für EtherCAT. Weitere Kabel in verschiedenen Längen finden Sie im Beckhoff Gesamtkatalog und unter www.beckhoff.de.

Meterware

Bezeichnung | Beschreibung
ZB9010 | CAT 5e, 4-adrig, für feste Verlegung, nicht für M8-Steckverbinder
ZB9020 | CAT 5e, 4-adrig, schleppkettentauglich, nicht für M8-Steckverbinder
ZB9030 | PVC, Ø4,9 mm für M8-Steckverbinder
ZB9031 | PUR, Ø4,8 mm für M8-Steckverbinder
ZB9032 | PUR, Ø5,4 mm für M8-Steckverbinder hochflexibel

Konfektionierte Kabel

ZK1090-3100-0xxx: M8-Stecker - offenes Ende, PUR, hochflexibel, vorkonfektioniert

ZK1090-3100- | 0020 | 0050
Länge | 2 m | 5 m

ZK1090-3100-3xxx: M8-Stecker - offenes Ende, PVC, vorkonfektioniert

ZK1090-3100- | 3020 | 3050
Länge | 2 m | 5 m

ZK1090-3131-0xxx: 2 x M8-Stecker, PUR, hochflexibel, fertig konfektioniert

ZK1090-3131- | 0001 | 0003 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0075 | 0100
Länge | 0,15 m | 0,3 m | 0,5 m | 1,0 m | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 7,5 m | 10 m
ZK1090-3131- | 0150 | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Länge | 15 m | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m

ZK1090-3131-3xxx: 2 x M8-Stecker, PVC, fertig konfektioniert

ZK1090-3131- | 3020 | 3030 | 3040 | 3050 | 3075 | 3100 | 3150 | 3200 | 3250 | 3300
Länge | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 7,5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3131- | 3350 | 3400 | 3450 | 3500
Länge | 35 m | 40 m | 45 m | 50 m

ZK1090-3132-0xxx: M8-Stecker - M8-Kupplung, PUR, hochflexibel, fertig konfektioniert

ZK1090-3132- | 0002 | 0004 | 0020 | 0050 | 0075 | 0100 | 0150 | 0200 | 0250 | 0300
Länge | 0,2 m | 0,4 m | 2,0 m | 5,0 m | 7,5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3132- | 0400 | 0500
Länge | 40 m | 50 m

ZK1090-3132-3xxx: M8-Stecker - M8-Kupplung, PVC, fertig konfektioniert

ZK1090-3132- | 0020 | 0050 | 0100 | 0150 | 0200 | 0250 | 0300 | 0400 | 0500
Länge | 2,0 m | 5,0 m | 10 m | 15 m | 20 m | 25 m | 30 m | 40 m | 50 m

ZK1090-3191-0xxx: M8-Stecker - RJ45-Stecker, PUR, hochflexibel, fertig konfektioniert

ZK1090-3191- | 0004 | 0005 | 0010 | 0020 | 0035 | 0050 | 0070 | 0100 | 0150 | 0200
Länge | 0,4 m | 0,5 m | 1 m | 2 m | 3,5 m | 5 m | 7 m | 10 m | 15 m | 20 m
ZK1090-3191- | 0250
Länge | 25 m

ZK1090-3191-3xxx: M8-Stecker - RJ45-Stecker, PVC, fertig konfektioniert

ZK1090-3191- | 3005 | 3020 | 3050
Länge | 0,5 m | 2 m | 5 m

ZK1090-3291-3xxx: M8-Kupplung - RJ45-Stecker, PVC, fertig konfektioniert

ZK1090-3291- | 0004 | 0005 | 0010 | 0020 | 0050 | 100 | 200 | 250
Länge | 0,4 m | 0,5 m | 1 m | 2 m | 5 m | 10 m | 20 m | 25 m

ZK1090-3161-0xxx: M8-Stecker - M12-Stecker (d-codiert), fertig konfektioniert

ZK1090-3161- | 0010 | 0020 | 0050
Länge | 1,0 m | 2,0 m | 5,0 m

ZK1090-6161-0xxx: 2 x M12-Stecker (d-codiert), fertig konfektioniert

ZK1090-6161- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Länge | 0,5 m | 1,0 m | 2,0 m | 2,5 m | 5,0 m | 10 m

ZK1090-6292-0xxx: M12-Buchse - RJ45-Stecker, fertig konfektioniert

ZK1090-6292- | 0005 | 0020 | 0050 | 0100
Länge | 0,5 m | 2 m | 5 m | 10 m

ZK1090-9191-0xxx: 2 x RJ45-Stecker, Patch-Kabel

ZK1090-9191- | 0001 | 0002 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0100 | 0150
Länge | 0,17 m | 0,26 m | 0,5 m | 1,0 m | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 10 m | 15 m
ZK1090-9191- | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Länge | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m


EtherCAT Box - Power-Anschluss

BECKHOFF EtherCAT Box: Montage und Verkabelung

Power-Anschluss

Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:

  • IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
  • OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*

Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.

Zwei LEDs zeigen den Status der Versorgungsspannungen an.

Achtung 		Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!

Steuerspannung Us: 24VDC

Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.

Peripheriespannung Up: 24VDC

Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.

Weiterleitung der Versorgungsspannungen

Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.

Achtung 		Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!

Galvanische Trennung

Digitale Module

Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) miteinander verbunden!

Analoge Module

Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.

Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0...10 V Eingängen eine beliebige Referenzspannung (0...30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).

Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.

Achtung 		Galvanische Trennung kann aufgehoben werden!
Wenn Sie digitale und analoge Feldbus Boxen direkt über vierpolige Powerleitungen verbinden, so ist für die analogen Feldbus Boxen die galvanische Trennung der Analogsignale von der Steuerspannung nicht mehr gegeben!


EtherCAT Box - Status-LEDs für die Spannungsversorgung

BECKHOFF EtherCAT Box: Montage und Verkabelung

Status-LEDs für die Spannungsversorgung

LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Powerkabel

Bestelldaten

Bestellbezeichnung | Powerleitung | Schraub- Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m

Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).

Technische Daten

Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109 W
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mW
Schutzart nach IEC 60529 | IP65/66/67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste

Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkablung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.

Beispiel:
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.


EtherCAT Box - UL-Anforderungen

BECKHOFF EtherCAT Box: Montage und Verkabelung

UL-Anforderungen

Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.

Versorgungsspannung

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammt.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!

Netzwerke

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!

Umgebungstemperatur

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!

Kennzeichnung für UL

Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet:


EtherCAT Box - ATEX - Besondere Bedingungen

BECKHOFF EtherCAT Box: Montage und Verdrahtung

ATEX - Besondere Bedingungen

WARNUNG 		Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von
EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
  • Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
  • Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
  • Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
  • Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
  • Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!

Normen

Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Kennzeichnung

Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen eine der folgenden folgende Kennzeichnungen:

II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C

oder

II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C

Batch-Nummer (D-Nummer)

Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:

D: WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit D-Nr. 29 10 02 01:

29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!

ATEX

Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.

Installation

  1. Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000
  2. Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest
  3. Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box


EtherCAT Box - ATEX-Dokumentation

BECKHOFF EtherCAT Box: Montage und Verdrahtung

ATEX-Dokumentation

Hinweis 		Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Encoder-Anschluss, M12-Buchse, 8-polig

Bedeutung der LEDs

LED A - Eingang A / Spur A

LED B - Einang B / Spur B

LED C - Eingang C / Spur C


Encoder-Anschluss, D-Sub-Buchse, 15-polig

Bedeutung der LEDs

LED A - Eingang A / Spur A

LED B - Eingang B / Spur B

LED C - Eingang C / Spur C

LED L - Eingang Latch

LED G - Eingang Gate

LED E - Eingang Error


EP5101 - Status-LEDs

EP5101-0002: Status-LEDs am M12-Anschluss
Anschluss | LED | Anzeige | Bedeutung
M12 | A | aus | Eingang A / Spur A low
 |  | grün | Eingang A / Spur A High
 | B | aus | Eingang B / Spur B low
 |  | grün | Eingang B / Spur B high
 | C | aus | Eingang C / Spur C low
 |  | grün | Eingang C / Spur C high
EP5101-0011: Status-LEDs am D-Sub-Anschluss
Anschluss | LED | Anzeige | Bedeutung
D-Sub | A | aus | Eingang A / Spur A low
 |  | grün | Eingang A / Spur A High
 | B | aus | Eingang B / Spur B low
 |  | grün | Eingang B / Spur B high
 | C | aus | Eingang C / Spur C low
 |  | grün | Eingang C / Spur C high
 | L | aus | Eingang Latch low
 |  | grün | Eingang Latch High
 | G | aus | Eingang Gate low
 |  | grün | Eingang Gate high
 | E | aus | Eingang Error low
 |  | grün | Eingang Error high


EtherCAT Box - Einfügen in das EtherCAT-Netzwerk

BECKHOFF EtherCAT Box: Inbetriebnahme und Konfiguration

Einfügen in das EtherCAT-Netzwerk

Hinweis 		Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen installiert werden.

Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:

  • durch Einscannen vorhandener Hardware (genannt "online") und
  • durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.

Automatisches Einscannen der Box

  • Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
  • Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein (siehe Abb.1). Bestätigen Sie alle folgenden Dialoge mit "OK", so dass sich die Konfiguration im "FreeRun" -Modus befindet.

Abb. 1: Einscannen der EtherCAT Konfiguration (E/A-Geräte-> Rechte Maustaste -> Geräte suchen...

Manuelles Anfügen eines Moduls

  • Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
  • Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
  • Fügen Sie ein neues E/A-Gerät an (siehe Abb. 2). Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), s. Abb. 3, bestätigen Sie mit OK.

Abb. 2: Anfügen eines neuen E/A-Gerätes (E/A-Geräte-> Rechte Maustaste -> Gerät anfügen... )

Abb. 3: Auswahl des Gerätes (EtherCAT)

  • Fügen Sie eine neue Box an (siehe Abb. 4).

Abb. 4: Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen... )

  • Im angezeigten Dialog wählen Sie die gewünschte Box, bestätigen Sie mit OK.

Abb. 5: Auswahl einer Box

Abb. 6 Angefügte Box im TwinCAT Baum


EPxxxx - Konfiguration mit dem TwinCAT System Manager

BECKHOFF EtherCAT Box: Inbetriebnahme und Konfiguration

Konfiguration mit dem TwinCAT System Manager

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten.

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.

Karteireiter Allgemein

Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.

Karteireiter EtherCAT

Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem Anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.

Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.

Karteireiter Prozessdaten

Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.

Sync-Manager

Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.

Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.

PDO-Zuordnung

PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:

  • Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
  • Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.

Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.

Hinweis 		Aktivierung der PDO-Zuordnung
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
  • der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
  • der System-Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])

PDO-Liste

Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.

Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.

PDO-Inhalt

Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.

Download

Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.

PDO-Zuordnung

Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.

PDO-Konfiguration

Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.

Karteireiter Startup

Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.

Spalte | Beschreibung
Transition Übergang, in den der Request gesendet wird. Dies kann entweder
  • der Übergang von Pre-Operational to Safe-Operational (PS) oder
  • der Übergang von Safe-Operational to Operational (SO) sein.

Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll | Art des Mailbox-Protokolls
Index | Index des Objekts
Data | Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar | Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.

Karteireiter CoE - Online

Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.

Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.

Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.

Karteireiter Online

Status Maschine

Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.

DLL-Status

Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:

Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.

File Access over EtherCAT

Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


EL5101 - Grundlagen zur Funktion

BECKHOFF EP5101: Inbetriebnahme

Grundlagen zur Funktion

Das Inkremental-Encoder-Interface der EP5101 ermöglicht den Anschluss von Inkremental-Encodern mit A/B/C-Spur am EtherCAT. Ein 32-Bit-Zähler mit Quadraturdecoder sowie ein 32-Bit-Latch können gelesen, gesetzt oder aktiviert werden. Als Geberanschluss sind differentielle Signale nach RS485 vorgesehen.

Neben den Gebereingängen A, B, C steht ein zusätzlicher Latch-Eingang G1 (24 V) sowie ein Gate-Eingang G2 (24 V) zum Sperren des Zählers im Zählerbetrieb zur Verfügung.

Geliefert wird die Box als 4-fach Quadraturdecoder mit komplementärer Auswertung der Gebersignale A, B, C. Besitzt der Inkremental-Encoder einen Störmelde-Ausgang, so kann dieser an den Statuseingang ERROR der Box angeschlossen werden. Optional kann die EP5101 als Zählermodul auf Kanal A betrieben werden.

Hinweis 		Überwachung der Prozessdaten
Es wird empfohlen, folgende Prozessdaten in jedem Zyklus zu überwachen:
  • WcState: wenn ≠ 0, dann nimmt dieser EtherCAT Teilnehmer nicht am Prozessdatenverkehr teil
  • State: wenn ≠ 8, dann ist der EtherCAT Teilnehmer nicht im OP (Operational) Status
  • TxPDO State, SyncError: wenn ≠ 0, dann liegen keine gültigen Prozessdaten vor, z.B. durch Drahtbruch
  • TxPDO Toggle: wenn dieses Bit toggelt, liegt ein neuer Satz Prozessdaten vor

EtherCAT Zykluszeit

Für die EP5101 wird eine minimale EtherCAT-Zykluszeit von 100 µs empfohlen. Wird eine schnellere Zykluszeit benötigt, müssen Sie mit dem toggelnden Prozessdatum TxPDO Toggle überwachen, wann die EP5101 neue Prozessdaten liefert.

Eingangsimpedanz der EP5101

Die Signalquelle muss die Eingangsimpedanz der EP5101 (typisch 220 W, Änderungen vorbehalten) mit ausreichenden Spannungspegeln nach RS485-Spezification betreiben können.

Gate/Latcheingang

Für Gate- und Latcheingang (24 V) ist eine max. Eingangsfrequenz von 1 MHz zulässig (Änderungen vorbehalten).


EP5101 - Parameter und Modi

BECKHOFF EP5101: Inbetriebnahme und Konfiguration

Parameter und Modi

16 oder 32 Bit Prozessdaten

Die EP5101 kann sowohl mit 16 Bit Prozessdaten (default), als auch mit 32 Bit Prozessdaten betrieben werden.

Diese Einstellung erfolgt über das Predefined PDO Assignment auf den Tabellereiter Process Data.

DC (Distributed Clocks)

Beschreibt, ob das Modul mit Unterstützung von Distributed Clocks-betrieben wird:

  • FreeRun: das Modul arbeitet Frame-getriggert, der zyklische Betrieb wird durch die SyncManager der EtherCAT-Frame-Bearbeitung gestartet.
  • DC-Synchron: der Zyklische Betrieb in dem Modul wird durch die lokale Distributed Clock in exakten Zeitabständen gestartet. Dabei ist der Startzeitpunkt so gewählt, dass er mit anderen Output-Slaves im EtherCAT-System zusammenfällt.
  • DC-Synchron (input based): Arbeitsweise wie DC-Synchron, aber der zyklische Startzeitpunkt ist so gewählt, dass er mit anderen Input-Slaves im EtherCAT-System zusammenfällt.

Haupt-PDO

Auswahl der Basis-Prozessdaten

A: Anwahl der Datenrichtung: Input oder Output
B: Auswahl (optionaler) PDO (Prozessdatenobjekte)
C: Erläuterungen zu den PDO

  • compact: die Prozessdaten können mit 16 Bit Umfang als "compact" oder mit 32 Bit Umfang dargestellt werden.

Optionale PDO

Zum Haupt-PDO optional wählbare PDO:

  • PDO 1 (1A02 oder 1A03): als optionales PDO 1 ist entweder die Frequenz oder die Periode anwählbar
  • PDO 2 (1A04 oder 1A05): In einem der DC-Modi ist ein 32 oder 64 Bit großer Timestamp zuwählbar. Der Timestamp gibt die Uhrzeit der letzten registrierten Inkrementflanke, basierend auf dem DistributedClocks System an.

Features CoE

Abhängig von den Haupt-PDO/optionalen PDO sind im CoE (CAN over EtherCAT)-Verzeichnis weitere Einstellungen anwählbar.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
  • StartUp-Liste führen für den Austauschfall
  • Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
  • CoE-Reload zum Zurücksetzen der Veränderungen

Folgende CoE-Einstellungen aus dem Objekt 8000 sind möglich und hier in den Default-Einstellungen wiedergegeben:

Die Parameter werden auf der Seite Objektbeschreibung erläutert.

Auf Grund der unterschiedlichen Pinbelegung werden nicht alle Objekte von der EP5101-0002 unterstützt!

Weitere Hinweise

Frequenz

  • Das Zeitfenster für die Frequenzberechnung sowie die Auflösung kann in den CoE-Objekten 8000:11, 8000:13, 8000:15, 8000:17 parametriert werden.
  • Es werden die positiven Flanken der Spur A im angegebnen Zeitfenster gezählt und die nächste folgende Flanke inkl. der Zeit bis dahin gezählt. Die Zeit, wie lange auf die Flanke gewartet wird, ist im CoE Objekt 8000:17 "Frequency Wait Time" einstellbar (Einheit: ms) und standardmäßig auf 1,6 s gesetzt. Das ist auch der Maximalwert.
  • Das Zeitfenster ist 10 ms (default), min. 1 µs.
  • Die Zeit wird mit einer Auflösung von 100 ns gemessen.
  • Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
  • Wenn der Zähler durch das Gate gesperrt ist, ist keine Frequenzmessung möglich; die Messung der Periodendauer kann in diesem Fall trotzdem durchgeführt werden.
  • Ein C- oder externer Reset startet die Frequenzmessung neu, der zuletzt ausgegebene Frequenzwert bleibt bis zur Ermittlung eines neuen Frequenzwertes unverändert.
Frequenzmessung
  • Basiseinheit 1 µs: alle Fenstergrößen

Ablauf der Messung

  • Die Messung beginnt mit einer steigenden Flanke der Spur A, aktueller Zählerstand und Zeit (Auflösung: 100 ns) werden gespeichert.
  • Nach Ablauf des Messfensters (Index 8000:11) wird noch bis zur folgenden steigenden Flanke an Spur A gewartet, maximal jedoch 1,6 s bzw. die Zeit aus 8000:17
  • Die Frequenz wird berechnet aus der Flankendifferenz und der real vergangenen Zeit.

Abb.: Prinzip Frequenzmessung im erweiterten Betriebsmodus

Periodenberechnung

  • Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
  • Es wird in jedem Zyklus der Abstand zwischen 2 positiven Flanken von Eingang A gezählt.
  • Ereignet sich 1,6 s lang kein Flankenwechsel, wird die evtl. bestehende Periodenangabe gelöscht.

Latch

Aktivierung des Latch C-Eingangs ("C") und Speichern ("Latchen") des Zählerstandes (Index 7000:01)
  • Beim ersten externen Latchimpuls (positive Flanke an Eingang "C") nach gesetztem Bit ("TRUE") in Index 7000:01 wird der Counterwert gespeichert (hat Vorrang vor 7000:02 / 7000:04 ). Die folgenden Impulse an den anderen Eingängen haben bei gesetztem Bit keinen Einfluss auf den Latch-Wert in Index 6000:12
  • Hinweis "Latch C valid" - Bit: Erst wenn der Wert des "Latch C valid" - Bit (Index 6000:01) "FALSE" ist, kann ein neuer Counterwert auf den Latch-Eingang geschrieben werden.
Aktivierung des externen Latch-Eingangs ("Gate/Latch") und Verriegeln ("Latchen") des Zählerstandes (Index 7000:02, 7000:04)
  • Bei gesetztem Bit ("TRUE") in Index 7000:02 wird beim ersten externen Latchimpuls mit steigender Flanke der Counterwert auf den Latch-Eingang (Index 6000:12 ) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert in Index 6000:12 .
  • Bei gesetztem Bit ("TRUE") in Index 7000:04 wird beim ersten externen Latchimpuls mit fallender Flanke der Counterwert auf den Latch-Eingang (Index 6000:12 ) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert in Index 6000:12 .
  • Hinweis "Latch extern valid" - Bit: Erst wenn der Wert des "Latch extern valid" - Bit Index 6000:02) "FALSE" ist, kann ein neuer Counterwert auf den Latch-Eingang geschrieben werden.

Reset

  • Reset des Zählers (Index 8000:01, 8000:02, 8000:10): Für den Zählerreset über den Eingang C ist das Bit im Index 8000:01 zu setzen, für den Reset über den externen Latch-Eingang das Bit im Index 8000:02.
  • Die Aktivierung der Funktionen "Enable C reset" (8000:01 ) und das "Enable extern reset" (8000:02) sind gleichzeitig nicht möglich.
  • Hinweis "Extern reset polarity" , Index 8000:10: Über den Index 8000:10 besteht die Möglichkeit zur Auswahl der Flanke, um den Zähler auf Null zu setzen.
    Bit nicht gesetzt: Zähler wird mit fallender Flanke auf "Null" gesetzt.
    Bit gesetzt: Zähler wird mit steigender Flanke auf "Null" gesetzt.

Vorwärts-/Rückwärts-Zähler

  • Die Betriebsartenwahl (Encoder oder V/R-Zähler) wird über die CoE-Objekte (Profilspezifische Objekte, Karteireiter CoE -Online, Index 8000:03 "Non-Volatile Settings") vorgenommen. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben Sie den Wert "1" im "SetValue"-Dialog ein und bestätigen Sie mit "OK".
  • Ebenso ist über das Objekt 8000:04 die Gate-Polarität einzustellen.
  • Eine zusätzliche Option zur Drehrichtungsumkehr ist mit Setzen des Bits in Index 8000:0E gegeben.

Over-/Underflow

  • In Kombination mit einer aktivierten Reset-Funktion (C/extern) ist die Over-/Underflowkontrolle unwirksam.
  • Das Underflow-Bit (6000:04) wird gesetzt, wenn ein Unterlauf ...00 ®...FF eintritt. Es wird zurückgesetzt, wenn 2/3 des Zählerbereiches unterschritten werden.
  • Das Overflow-Bit (6000:05) wird gesetzt, wenn ein Überlauf FF...® 00... eintritt. Es wird zurückgesetzt, wenn 1/3 des Zählerbereiches überschritten werden.

Drahtbrucherkennung / Open circuit detection

  • Für die Kanäle A, B und C kann jeweils separat eine Drahtbrucherkennung aktiviert werden (Index 8000:0B, 8000:0C, 8000:0D).
  • Standardmäßig ist die Drahtbrucherkennung für die Kanäle A und B aktiviert.
  • Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert.
  • Ein erkannter Drahtbruch wird als Prozessdatum open circuit =TRUE angezeigt Bit in Objekt 6000:07 wird gesetzt; die separate Anzeige eines Drahtbruchs wird in den Indizes A000:01 (Spur A), A000:02 (Spur B) und A000:03 (Spur C) angezeigt.
  • TxPDO state wird bei einem erkannten Drahtbruch ebenfalls TRUE, da von ungültigen Daten ausgegangen werden muss.

Mikroinkremente

  • Arbeitet mit und ohne Distributed Clocks, ist aber in der EP5101 nur in Verbindung mit einem der DC-Modi sinnvoll
  • Über das Zählerstand-Setzen kann nur der ganzzahlige Anteil verändert werden.
  • das Prinzip Frequenzmessung im erweiterten Betriebsmodus:

Die hochkonstante Abfragezyklen (Genauigkeit: 100 ns) des Distributed Clocks-Systems erlauben es der EP5101, ab einer bestimmten Geschwindigkeit interpolierte Achspositionen zwischen die gezählten Encoder-Inkremente zu interpolieren. Die Interpolationsauflösung beträgt dabei 8 Bit entsprechend 256 Werte. Ein Standard-Encoder mit 1.024 Strichen wird so mit 4fach Auswertung und Mikroinkrementen zu einem hochauflösenden Achsgeber mit

4096 x 256 = 1.048.567 Strichen.

Die Unterschreitung der Mindestgeschwindigkeit wird durch das Objekt 6000:08 (Extrapolation stall) in den Prozessdaten angezeigt.


EP5101 - Signal Level

BECKHOFF EP5101: Produktübersicht

EP5101 - Signallevel

Schnittstellenpegel

Die EP5101 erwartet Pegel nach RS485.

Differentieller Signaleingang

Abb.: Spannungspegel für differentiellen Modus

Single ended Modus

In Ergänzung interpretiert die EP5101 auch single ended Signale korrekt, allerdings wird trotz der einwandfreien Verarbeitung das Error Bit gesetzt.

Dieser Modus ist also nur nach genauer Prüfung zu nutzen.

Abb.: Spannungspegel für single ended Modus

Für den Einsatz im single ended Modus wird eine Sapnnung von nominell HIGH = +5V erwartet.


EP5101 - Objektübersicht

BECKHOFF EP5101: Konfiguration

Objektübersicht

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.
Index |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x01FF1389 (33493897dez)
1008 |  | Device name | RO | EP5101-0011
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x13ED4052 (334315602dez)
 | 1018:03 | Revision | RO | 0x0010000B (1048587dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1400:0 | Subindex | ENC RxPDO-Par Control compact | RO | 0x06 (6dez)
 | 1400:06 | Exclude RxPDOs | RO | 01 16
1401:0 | Subindex | ENC RxPDO-Par Control | RO | 0x06 (6dez)
 | 1401:06 | Exclude RxPDOs | RO | 00 16
1600:0 | Subindex | ENC RxPDO-Map Control compact | RO | 0x07 (7dez)
 | 1600:01 | SubIndex 001 | RO | 0x7000:01, 1
 | 1600:02 | SubIndex 002 | RO | 0x7000:02, 1
 | 1600:03 | SubIndex 003 | RO | 0x7000:03, 1
 | 1600:04 | SubIndex 004 | RO | 0x7000:04, 1
 | 1600:05 | SubIndex 005 | RO | 0x0000:00, 4
 | 1600:06 | SubIndex 006 | RO | 0x0000:00, 8
 | 1600:07 | SubIndex 007 | RO | 0x7000:11, 16
1601:0 | Subindex | ENC RxPDO-Map Control | RO | 0x07 (7dez)
 | 1601:01 | SubIndex 001 | RO | 0x7000:01, 1
 | 1601:02 | SubIndex 002 | RO | 0x7000:02, 1
 | 1601:03 | SubIndex 003 | RO | 0x7000:03, 1
 | 1601:04 | SubIndex 004 | RO | 0x7000:04, 1
 | 1601:05 | SubIndex 005 | RO | 0x0000:00, 4
 | 1601:06 | SubIndex 006 | RO | 0x0000:00, 8
 | 1601:07 | SubIndex 007 | RO | 0x7000:11, 32
1800:0 | Subindex | ENC TxPDO-Par Status compact | RO | 0x09 (9dez)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
 | 1800:07 | TxPDO State | RO | 0x00 (0dez)
 | 1800:09 | TxPDO Toggle | RO | 0x00 (0dez)
1801:0 | Subindex | ENC TxPDO-Par Status | RO | 0x09 (9dez)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
 | 1801:07 | TxPDO State | RO | 0x00 (0dez)
 | 1801:09 | TxPDO Toggle | RO | 0x00 (0dez)
1802:0 | Subindex | ENC TxPDO-Par Frequency | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | ENC TxPDO-Par Period | RO | 0x06 (6dez)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | ENC TxPDO-Par Timest. | RO | 0x06 (6dez)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | ENC TxPDO-Par Timest. compact | RO | 0x06 (6dez)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1A00:0 | Subindex | ENC TxPDO-Map Status compact | RO | 0x12 (18dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:09, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:0A, 1
 | 1A00:0B | SubIndex 011 | RO | 0x6000:0B, 1
 | 1A00:0C | SubIndex 012 | RO | 0x6000:0C, 1
 | 1A00:0D | SubIndex 013 | RO | 0x6000:0D, 1
 | 1A00:0E | SubIndex 014 | RO | 0x1C32:20, 1
 | 1A00:0F | SubIndex 015 | RO | 0x1800:07, 1
 | 1A00:10 | SubIndex 016 | RO | 0x1800:09, 1
 | 1A00:11 | SubIndex 017 | RO | 0x6000:11, 16
 | 1A00:12 | SubIndex 018 | RO | 0x6000:12, 16
1A01:0 | Subindex | ENC TxPDO-Map Status | RO | 0x12 (18dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6000:09, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6000:0A, 1
 | 1A01:0B | SubIndex 011 | RO | 0x6000:0B, 1
 | 1A01:0C | SubIndex 012 | RO | 0x6000:0C, 1
 | 1A01:0D | SubIndex 013 | RO | 0x6000:0D, 1
 | 1A01:0E | SubIndex 014 | RO | 0x1C32:20, 1
 | 1A01:0F | SubIndex 015 | RO | 0x1801:07, 1
 | 1A01:10 | SubIndex 016 | RO | 0x1801:09, 1
 | 1A01:11 | SubIndex 017 | RO | 0x6000:11, 32
 | 1A01:12 | SubIndex 018 | RO | 0x6000:12, 32
1A02:0 | Subindex | ENC TxPDO-Map Frequency | RO | 0x01 (1dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6000:13, 32
1A03:0 | Subindex | ENC TxPDO-Map Period | RO | 0x01 (1dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6000:14, 32
1A04:0 | Subindex | ENC TxPDO-Map Timest. | RO | 0x01 (1dez)
 | 1A04:01 | SubIndex 001 | RO | 0x6000:16, 64
1A05:0 | Subindex | ENC TxPDO-Map Timest. compact | RO | 0x01 (1dez)
 | 1A05:01 | SubIndex 001 | RO | 0x6000:16, 32
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x01 (1dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x01 (1dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x0000 (0dez)
 | 1C13:03 | SubIndex 003 | RW | 0x0000 (0dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x000103C4 (66500dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x000103C4 (66500dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | ENC Inputs | RO | 0x16 (22dez)
 | 6000:01 | Latch C valid | RO | 0x00 (0dez)
 | 6000:02 | Latch extern valid | RO | 0x00 (0dez)
 | 6000:03 | Set counter done | RO | 0x00 (0dez)
 | 6000:04 | Counter underflow | RO | 0x00 (0dez)
 | 6000:05 | Counter overflow | RO | 0x00 (0dez)
 | 6000:06 | Status of input status | RO | 0x00 (0dez)
 | 6000:07 | Open circuit | RO | 0x00 (0dez)
 | 6000:08 | Extrapolation stall | RO | 0x00 (0dez)
 | 6000:09 | Status of input A | RO | 0x00 (0dez)
 | 6000:0A | Status of input B | RO | 0x00 (0dez)
 | 6000:0B | Status of input C | RO | 0x00 (0dez)
 | 6000:0C | Status of input gate | RO | 0x00 (0dez)
 | 6000:0D | Status of extern latch | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Counter value | RO | 0x00000000 (0dez)
 | 6000:12 | Latch value | RO | 0x00000000 (0dez)
 | 6000:13 | Frequency value | RO | 0x00000000 (0dez)
 | 6000:14 | Period value | RO | 0x00000000 (0dez)
 | 6000:16 | Timestamp | RO |
7000:0 | Subindex | ENC Outputs | RO | 0x11 (17dez)
 | 7000:01 | Enable latch C | RO | 0x00 (0dez)
 | 7000:02 | Enable latch extern on positive edge | RO | 0x00 (0dez)
 | 7000:03 | Set counter | RO | 0x00 (0dez)
 | 7000:04 | Enable latch extern on negative edge | RO | 0x00 (0dez)
 | 7000:11 | Set counter value | RO | 0x00000000 (0dez)
8000:0 | Subindex | ENC Settings | RW | 0x17 (23dez)
 | 8000:01 | Enable C reset | RW | 0x00 (0dez)
 | 8000:02 | Enable extern reset | RW | 0x00 (0dez)
 | 8000:03 | Enable up/down counter | RW | 0x00 (0dez)
 | 8000:04 | Gate polarity | RW | 0x01 (1dez)
 | 8000:08 | Disable filter | RW | 0x01 (1dez)
 | 8000:0A | Enable micro increments | RW | 0x00 (0dez)
 | 8000:0B | Open circuit detection A | RW | 0x01 (1dez)
 | 8000:0C | Open circuit detection B | RW | 0x01 (1dez)
 | 8000:0D | Open circuit detection C | RW | 0x00 (0dez)
 | 8000:0E | Reversion of rotation | RW | 0x00 (0dez)
 | 8000:10 | Extern reset polarity | RW | 0x01 (1dez)
 | 8000:11 | Frequency window | RW | 0x2710 (10000dez)
 | 8000:13 | Frequency scaling | RW | 0x0064 (100dez)
 | 8000:14 | Period scaling | RW | 0x0064 (100dez)
 | 8000:15 | Frequency resolution | RW | 0x0064 (100dez)
 | 8000:16 | Period resolution | RW | 0x0064 (100dez)
 | 8000:17 | Frequency wait time | RW | 0x0640 (1600dez)
A000:0 | Subindex | ENC Diag data | RO | 0x03 (3dez)
 | A000:01 | Open circuit A | RO | 0x00 (0dez)
 | A000:02 | Open circuit B | RO | 0x00 (0dez)
 | A000:03 | Open circuit C | RO | 0x00 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0001 (1dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x01 (1dez)
 | F010:01 | SubIndex 001 | RW | 0x000001FF (511dez)
Legende

Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


EP5101 - Objektbeschreibung

BECKHOFF EP5101: Inbetriebnahme und Konfiguration

Objektbeschreibung und Parametrierung

Hinweis 		Parametrierung
Die Parametrierung des Moduls wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
  • Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte zur Parametrierung bei der Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 ENC Settings
Index | Name | Bedeutung | Data type | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über die C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24V) | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable up/down counter | Freigabe des V/R-Zählers an Stelle des Encoders bei gesetztem Bit. Gezählt werden Inkremente am Eingang A, Zählrichtung gibt Eingang B vor. | BOOLEAN | RW | 0x00 (0dez)
8000:04 Gate polarity 0: Disable gate
1: Enable pos. gate (Gate sperrt mit "HIGH"-Pegel)
2: Enable neg. gate (Gate sperrt mit "LOW"-Pegel) 		BIT2 RW 0x01 (1dez)
8000:08 Disable filter 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C)
1: Deaktiviert Eingangsfilter
Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. 		BOOLEAN RW 0x01 (1dez)
8000:0A | Enable micro increments | Bei Aktivierung interpoliert die EL5101 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 bit des Counter-Value benutzt. Aus einem 32-bit-Zähler wird so ein 24+8bit Zähler, aus einem 16-bit-Zähler ein 8+8bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Index 6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Index 6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Index 6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8000:10 Extern reset polarity 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt)

1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt)

BIT1 RW 0x01 (1dez)
8000:11 Frequency window Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs].
Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. "Frequency Wait Time" lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird in Index 6000:13 und als Prozessdatum ausgegeben.
Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. 		UINT16 RW 0x2710 (10000dez)
8000:13 Frequency scaling Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält):

100: "0,01 Hz"

UINT16 RW 0x0064 (100dez)
8000:14 Period scaling Auflösung der Periodendauer im Prozessdatum:

100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns

500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns

UINT16 RW 0x0064 (100dez)
8000:15 Frequency resolution Auflösung der Frequenzmessung:

100: "0,01 Hz"

UINT16 RW 0x0064 (100dez)
8000:16 Period resolution Interne Auflösung der Periodendauermessung:

100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns
Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen.

500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns
Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Index 8000:14 (z.B. 100 ns [default]).

UINT16 RW 0x0064 (100dez)
8000:17 Frequency wait time Wartezeit [ms] der Frequenzmessung

Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums "Frequency" erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. t >= 2* (1 / fmin)

UINT16 RW 0x0640 (1600dez)

Weitere Objekte

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01FF1389 (33493897dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP5101-0011
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED4052 (334315602dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sondermodulnummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x0010000B (1048587dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control compact
Index | Name | Bedeutung | Data type | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 ENC RxPDO-Par Control
Index | Name | Bedeutung | Data type | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1600 ENC RxPDO-Map Control compact
Index | Name | Bedeutung | Data type | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index | Name | Bedeutung | Data type | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1800 ENC TxPDO-Par Status compact
Index | Name | Bedeutung | Data type | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1801 ENC TxPDO-Par Status
Index | Name | Bedeutung | Data type | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1802 ENC TxPDO-Par Frequency
Index | Name | Bedeutung | Data type | Flags | Default
1802:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Period
Index | Name | Bedeutung | Data type | Flags | Default
1803:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1804ENC TxPDO-Par Timest.
Index | Name | Bedeutung | Data type | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Timest. compact
Index | Name | Bedeutung | Data type | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
Index 1A00 ENC TxPDO-Map Status compact
Index | Name | Bedeutung | Data type | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x12 (18dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1800:07, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index | Name | Bedeutung | Data type | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (18dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Frequency
Index | Name | Bedeutung | Data type | Flags | Default
1A02:0 | ENC TxPDO-Map Frequency | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:13, 32
Index 1A03 ENC TxPDO-Map Period
Index | Name | Bedeutung | Data type | Flags | Default
1A03:0 | ENC TxPDO-Map Period | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:14, 32
Index 1A04 ENC TxPDO-Map Timest.
Index | Name | Bedeutung | Data type | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Timest. compact
Index | Name | Bedeutung | Data type | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:16, 32
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dez)
1C32:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron with SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
 UINT32 RW 0x000F4240 (1000000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0 = 1: Free Run wird unterstützt
  • Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
 UINT16 RO 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x000103C4 (66500dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C32:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestoppt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt

UINT16 RW 0x0000 (0dez)
1C32:09 | Maximum delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0022 (34dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x000F4240 (1000000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x000103C4 (66500dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 ENC Inputs
Index | Name | Bedeutung | Data type | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Index 6000:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 7000:01 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Index 6000:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 7000:02 bzw. Objekt-Index 7000:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Index 8000:0A, 8000:0B, 8000:0C | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig. | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EL5101 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in Index 8000:13 und 8000:15) | UINT32 | RO | 0x00000000 (0dez)
6000:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in Index 8000:14 und 8000:16) | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |
Index 7000 ENC Outputs
Index | Name | Bedeutung | Data type | Flags | Default
7000:0 | ENC Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über „Set counter“ (Index 7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index A000 ENC Diag data
Index | Name | Bedeutung | Data type | Flags | Default
A000:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
A000:01 | Open circuit A |  | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Open circuit B |  | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Open circuit C |  | BOOLEAN | RO | 0x00 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index | Name | Bedeutung | Data type | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Data type | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x01 (1dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FF (511dez)


ELxxxx - Wiederherstellen des Auslieferungszustandes

BECKHOFF ELxxxx: Konfiguration

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).

Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert

Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"

Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.