EP4174 - EtherCAT Box mit vier konfigurierbaren, analogen Ausgängen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.1.0
▪
Sicherheitshinweise neues Layout
▪
Update chapter Mounting
1.0.0
▪
Migration
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Dokumentation Version | EP4174-0002
 | Firmware | Hardware
1.1.0 | 02 | 11
1.0.0 | 02 | 10
0.5 | 01 | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Seriennummer entnehmen.
Syntax der Seriennummer
Aufbau der Seriennummer: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 55 09 01 00:
55 - Produktionswoche 55
09 - Produktionsjahr 2009
01 - Firmware-Stand 01
00 - Hardware-Stand 001


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
EP4174-0002 - Einführung
•
EP4174-0002 - Technische Daten
•
EP4174 - Status-LEDs
•
EP4174-0002 - Prozessabbild


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP4174-0002 - Einführung

Produktübersicht [image] EP4174-0002 - Einführung
EP4174-0002 - Einführung
EP4174-0002
EtherCAT Box mit vier konfigurierbaren, analogen Ausgängen
Die EtherCAT Box EP4174-0002 verfügt über vier analoge Ausgänge, die einzeln parametriert werden können, sodass sie entweder Signale im Bereich von -10 bis +10 V oder im Bereich von 0/4…20 mA erzeugen.
Die Spannung bzw. der Ausgangsstrom wird mit einer Auflösung von 15 Bit (Default) galvanisch getrennt zur Prozessebene gespeist. Die Skalierung der Ausgänge lässt sich bei Bedarf verändern.
Die vier Ausgangskanäle besitzen ein gemeinsames Massepotenzial mit der Versorgung 24 VDC. Die analogen Aktoren werden aus der Lastspannung (frei wählbar bis 30 VDC) gespeist. Die eingespeiste Lastspannung steht zur Aktorversorgung weiterer EtherCAT-Box-Module zur Verfügung.


EP4174-0002 - Technische Daten

Produktübersicht [image] EP4174-0002 - Technische Daten
EP4174-0002 - Technische Daten
Technische Daten | EP4174-0002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Ausgänge | 4
Anschluss Ausgänge | M12-Buchsen
Signaltyp | Konfigurierbar: 0…+10 V -10…+10 V 0…20 mA 4…20 mA
Bürde | > 5 kΩ | < 500 Ω
Auflösung | 16 Bit (inkl. Vorzeichen)
Wandlungszeit | < 4 ms
Messfehler | < 0,1 % (bezogen auf den Messbereichsendwert)
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 120 mA
Sensorversorgung | aus Lastspannung Up, DC, frei wählbar bis 30 V
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Prozessabbild | Ausgänge: 4 x 16 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C 0°C ... +55°C (gemäß cULus, siehe UL-Anforderungen) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen)
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Zulassungen | CE, cULus, ATEX
Einbaulage | beliebig


EP4174 - Status-LEDs

Produktübersicht [image] EP4174 - Status-LEDs
EP4174 - Status-LEDs
LEDs EP4174
Status-LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1-4 | R links | aus | keine Datenübertragung zum D/A-Wandler
 |  | grün | Datenübertragung zum D/A-Wandler
 | E rechts | aus | einwandfreie Funktion
 |  | rot | Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs
Spannungsversorgung
LED | Anzeige | Bedeutung
Us | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
Up | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


EP4174-0002 - Prozessabbild

Produktübersicht [image] EP4174-0002 - Prozessabbild
EP4174-0002 - Prozessabbild
Prozessabbild EP4174-0002
AO Outputs Channel 1
Unter AO Outputs Channel 1 finden Sie die Daten des 1. analogen Kanals.
AO Outputs Channel 2 bis 4
Die Daten des 2. bis 4. analogen Kanals sind genauso aufgebaut, wie die des 1. Kanals.


Installation

Installation
Installation
Weiterführende Informationen
•
Montage
•
Anschluss
•
UL-Anforderungen
•
ATEX-Hinweise


Montage

Installation [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder
•
Zusätzliche Prüfungen


Abmessungen

Installation [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Befestigung

Installation [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Installation [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


Zusätzliche Prüfungen

Installation [image] Montage [image] Zusätzliche Prüfungen
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


Anschluss

Installation [image] Anschluss
Anschluss
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs
•
Power-Anschluss
•
Power-Kabel
•
Leitungsverluste M8
•
EP4174-0002 - Signalanschluss


EtherCAT-Anschluss

Installation [image] Anschluss [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Installation [image] Anschluss [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (https://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Power-Anschluss

Installation [image] Anschluss [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u.U. nicht mehr gegeben sein!


Power-Kabel

Installation [image] Anschluss [image] Power-Kabel
Power-Kabel
Bestelldaten
Bestellbezeichnung | Power-Kabel | Schraub-Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m
Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).
Technische Daten
Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109Ω
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mΩ
Schutzart nach IEC 60529 | IP65/IP66/IP67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste M8

Installation [image] Anschluss [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


EP4174-0002 - Signalanschluss

Installation [image] Anschluss [image] EP4174-0002 - Signalanschluss
EP4174-0002 - Signalanschluss
Weiterführende Informationen
•
Analoge Spannungsausgänge (M12)
•
Analoge Stromausgänge (M12)


Analoge Spannungsausgänge (M12)

Installation [image] Anschluss [image] EP4174-0002 - Signalanschluss [image] Analoge Spannungsausgänge (M12)
Analoge Spannungsausgänge (M12)
Analoge Ausgänge, -10 bis +10 V
Der angeschlossene Aktor wird über Output +/- und Output GND angeschlossen. Optional kann der Aktor noch mit 24 VDC betrieben/versorgt werden.
Anschluss der analogen Spannungsausgänge (M12)
Bedeutung der LEDs
Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A-Wandler übertragen werden. Die rote LED Error zeigt einen Fehler an (Drahtbruch, Messwert außerhalb des Messbereichs).
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.
Status- und Diagnose-LED am M12-Steckverbinder


Analoge Stromausgänge (M12)

Installation [image] Anschluss [image] EP4174-0002 - Signalanschluss [image] Analoge Stromausgänge (M12)
Analoge Stromausgänge (M12)
Analoge Ausgänge, 0 bis 20 mA oder 4 bis 20 mA
Der angeschlossene Aktor wird über Output + und Output - angeschlossen. Optional kann der Aktor noch mit 24 VDC betrieben/versorgt werden.
Anschluss der analogen Stromausgänge (M12)
Bedeutung der LEDs
Für jeden Kanal gibt es eine grüne LED Run und eine rote LED Error. Die grüne LED Run leuchtet wenn Daten zum D/A Wandler übertragen werden. Die rote LED Error zeigt einen Fehler an (Drahtbruch, Messwert außerhalb des Messbereichs).
Eine einwandfreie Funktion besteht wenn die grüne LED Run leuchtet und die rote LED Error aus ist.
Status- und Diagnose-LED am M12-Steckverbinder


UL-Anforderungen

Installation [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Installation [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000-0000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Installation [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

Installation [image] ATEX-Hinweise [image] BG2000-0000 - Schutzgehäuse für EtherCAT Box
BG2000-0000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.
BG2000-0000, Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000-0000, Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.
BG2000-0000, Schutzgehäuse montieren


ATEX-Dokumentation

Installation [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
Objektübersicht
•
Objektbeschreibung und Parametrierung
•
Wiederherstellen des Auslieferungszustandes


Einfügen in das EtherCAT-Netzwerk

Inbetriebnahme/Konfiguration [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Objektübersicht

Inbetriebnahme/Konfiguration [image] Objektübersicht
Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x01901389 (26219401dez)
1008 |  | Device name | RO | EP4174-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x104E4052 (273563730dez)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1600:0 | Subindex | AO RxPDO-Map Ch.1 | RO | 0x01 (1dez)
 | 1600:01 | SubIndex 001 | RO | 0x7000:11, 16
1601:0 | Subindex | AO RxPDO-Map Ch.2 | RO | 0x01 (1dez)
 | 1601:01 | SubIndex 001 | RO | 0x7010:11, 16
1602:0 | Subindex | AO RxPDO-Map Ch.3 | RO | 0x01 (1dez)
 | 1602:01 | SubIndex 001 | RO | 0x7020:11, 16
1603:0 | Subindex | AO RxPDO-Map Ch.4 | RO | 0x01 (1dez)
 | 1603:01 | SubIndex 001 | RO | 0x7030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x04 (4dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dez)
 | 1C12:03 | SubIndex 003 | RW | 0x1602 (5634dez)
 | 1C12:04 | SubIndex 004 | RW | 0x1603 (5635dez)
1C133:0 | Subindex | TxPDO assign | RW | 0x00 (0dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00003A98 (15000dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x000493E0 (300000dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00003A98 (15000dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum Delay time | RO | 0x00003A98 (15000dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
Index (hex) |  | Name | Flags | Default Wert
7000:0 | Subindex | AO outputs Ch.1 | RO | 0x11 (17dez)
 | 7000:11 | Analog output | RO | 0x0000 (0dez)
7010:0 | Subindex | AO outputs Ch.2 | RO | 0x11 (17dez)
 | 7010:11 | Analog output | RO | 0x0000 (0dez)
7020:0 | Subindex | AO outputs Ch.3 | RO | 0x11 (17dez)
 | 7020:11 | Analog output | RO | 0x0000 (0dez)
7030:0 | Subindex | AO outputs Ch.4 | RO | 0x11 (17dez)
 | 7030:11 | Analog output | RO | 0x0000 (0dez)
8000:0 | Subindex | AO settings Ch.1 | RW | 0x16 (22dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Watchdog | RW | 0x00 (0dez)
 | 8000:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8000:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Default output | RW | 0x0000 (0dez)
 | 8000:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8000:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:16 | User calibration gain | RW | 0x4000 (16384dez)
800E:0 | Subindex | AO internal data Ch.1 | RO | 0x01 (1dez)
 | 800E:01 | DAC raw value | RO | 0x0000 (0dez)
800F:0 | Subindex | AO vendor data Ch.1 | RW | 0x06 (6dez)
 | 800F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 800F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 800F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 800F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 800F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 800F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
8010:0 | Subindex | AO settings Ch.2 | RW | 0x16 (22dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Watchdog | RW | 0x00 (0dez)
 | 8010:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8010:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Default output | RW | 0x0000 (0dez)
 | 8010:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8010:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:16 | User calibration gain | RW | 0x4000 (16384dez)
801E:0 | Subindex | AO internal data Ch.2 | RO | 0x01 (1dez)
 | 801E:01 | DAC raw value | RO | 0x0000 (0dez)
801F:0 | Subindex | AO vendor data Ch.2 | RW | 0x06 (6dez)
 | 801F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 801F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 801F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 801F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 801F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 801F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
Index (hex) |  | Name | Flags | Default Wert
8020:0 | Subindex | AO settings Ch.3 | RW | 0x16 (22dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:02 | Presentation | RW | 0x00 (0dez)
 | 8020:05 | Watchdog | RW | 0x00 (0dez)
 | 8020:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8020:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8020:13 | Default output | RW | 0x0000 (0dez)
 | 8020:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8020:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:16 | User calibration gain | RW | 0x4000 (16384dez)
802E:0 | Subindex | AO internal data Ch.3 | RO | 0x01 (1dez)
 | 802E:01 | DAC raw value | RO | 0x0000 (0dez)
802F:0 | Subindex | AO vendor data Ch.3 | RW | 0x06 (6dez)
 | 802F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 802F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 802F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 802F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 802F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 802F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
8030:0 | Subindex | AO settings Ch.4 | RW | 0x16 (22dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:02 | Presentation | RW | 0x00 (0dez)
 | 8030:05 | Watchdog | RW | 0x00 (0dez)
 | 8030:07 | Enable user calibration | RW | 0x00 (0dez)
 | 8030:08 | Enable vendor calibration | RW | 0x01 (1dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8030:13 | Default output | RW | 0x0000 (0dez)
 | 8030:14 | Default output ramp | RW | 0xFFFF (65535dez)
 | 8030:15 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:16 | User calibration gain | RW | 0x4000 (16384dez)
803E:0 | Subindex | AO internal data Ch.4 | RO | 0x01 (1dez)
 | 803E:01 | DAC raw value | RO | 0x0000 (0dez)
803F:0 | Subindex | AO vendor data Ch.4 | RW | 0x06 (6dez)
 | 803F:01 | R0 Calibration Offset | RW | 0x0000 (0dez)
 | 803F:02 | R0 Calibration Gain | RW | 0x4000 (16384dez)
 | 803F:03 | R1 Calibration Offset | RW | 0x0000 (0dez)
 | 803F:04 | R1 Calibration Gain | RW | 0x4000 (16384dez)
 | 803F:05 | R2 Calibration Offset | RW | 0x0000 (0dez)
 | 803F:06 | R2 Calibration Gain | RW | 0x4000 (16384dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x04 (4dez)
 | F010:01 | SubIndex 001 | RW | 0x00000190 (400dez)
 | F010:02 | SubIndex 002 | RW | 0x00000190 (400dez)
 | F010:03 | SubIndex 003 | RW | 0x00000190 (400dez)
 | F010:04 | SubIndex 004 | RW | 0x00000190 (400dez)
F800:0 | Subindex | AO Range Settings | RW | 0x04 (4dez)
 | F800:01 | Output type Ch1 | RW | 0x0000 (0dez)
 | F800:02 | Output type Ch2 | RW | 0x0000 (0dez)
 | F800:03 | Output type Ch3 | RW | 0x0000 (0dez)
 | F800:04 | Output type Ch4 | RW | 0x0000 (0dez)
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Objekte für den regulären Betrieb
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 AO settings Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | AO settings Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x16 (22dez)
8000:01 | Enable user scale | Mit diesem Eintrag wird die Skalierung für 0x8pp0:11 und 0x8pp0:12 aktiviert. |  | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | 0 | Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich.
 |  | 2 | Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv.
 |  | 3 | Absolute value Es wird der Absolutwert der signed Darstellung gebildet.
8000:05 | Watchdog | 0 | Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. | BIT2 | RW | 0x00 (0dez)
 |  | 1 | Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv.
 |  | 2 | Last output value Das letzte Prozessdatum wird im Fehlerfall (Ansprechen des Watchdogs) ausgegeben.
8000:07 | Enable user calibration | Freigabe des Anwenderabgleichs |  | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable vendor calibration | Freigabe des Herstellerabgleichs |  | BOOLEAN | RW | 0x01 (1dez)
8000:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Anwenderskalierung: Gain. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert eins entspricht 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Default output | Default-Ausgabewert |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. |  | UINT16 | RW | 0xFFFF (65535dez)
8000:15 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:16 | User calibration gain | Anwenderabgleich: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index 8010 AO settings Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | AO settings Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x16 (22dez)
8010:01 | Enable user scale | Mit diesem Eintrag wird die Skalierung für 0x8pp0:11 und 0x8pp0:12 aktiviert. |  | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | 0 | Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich.
 |  | 2 | Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv.
 |  | 3 | Absolute value Es wird der Absolutwert der signed Darstellung gebildet.
8010:05 | Watchdog | 0 | Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. | BIT2 | RW | 0x00 (0dez)
 |  | 1 | Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv.
 |  | 2 | Last output value Das letzte Prozessdatum wird im Fehlerfall (Ansprechen des Watchdogs) ausgegeben.
8010:07 | Enable user calibration | Freigabe des Anwenderabgleichs |  | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable vendor calibration | Freigabe des Herstellerabgleichs |  | BOOLEAN | RW | 0x01 (1dez)
8010:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Anwenderskalierung: Gain. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert eins entspricht 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Default output | Default-Ausgabewert |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. |  | UINT16 | RW | 0xFFFF (65535dez)
8010:15 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:16 | User calibration gain | Anwenderabgleich: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index 8020 AO settings Ch.3
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | AO settings Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x16 (22dez)
8020:01 | Enable user scale | Mit diesem Eintrag wird die Skalierung für 0x8pp0:11 und 0x8pp0:12 aktiviert. |  | BOOLEAN | RW | 0x00 (0dez)
8020:02 | Presentation | 0 | Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich.
 |  | 2 | Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv.
 |  | 3 | Absolute value Es wird der Absolutwert der signed Darstellung gebildet.
8020:05 | Watchdog | 0 | Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. | BIT2 | RW | 0x00 (0dez)
 |  | 1 | Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv.
 |  | 2 | Last output value Das letzte Prozessdatum wird im Fehlerfall (Ansprechen des Watchdogs) ausgegeben.
8020:07 | Enable user calibration | Freigabe des Anwenderabgleichs |  | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable vendor calibration | Freigabe des Herstellerabgleichs |  | BOOLEAN | RW | 0x01 (1dez)
8020:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:12 | User scale gain | Anwenderskalierung: Gain. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert eins entspricht 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dez)
8020:13 | Default output | Default-Ausgabewert |  | INT16 | RW | 0x0000 (0dez)
8020:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. |  | UINT16 | RW | 0xFFFF (65535dez)
8020:15 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:16 | User calibration gain | Anwenderabgleich: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index 8030 AO settings Ch.4
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0 | AO settings Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x16 (22dez)
8030:01 | Enable user scale | Mit diesem Eintrag wird die Skalierung für 0x8pp0:11 und 0x8pp0:12 aktiviert. |  | BOOLEAN | RW | 0x00 (0dez)
8030:02 | Presentation | 0 | Signed presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit signed Integer dargestellt. Bei unipolaren Klemmen (0-10 V oder 0-20 mA) wird der negative Bereich auf Null gesetzt. | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation Der Wertebereich der Ausgabe 0x7pp1:11 wird als 16 Bit unsigned Integer dargestellt. Negative Werte sind nicht möglich.
 |  | 2 | Absolute value with MSB as sign Betragsvorzeichendarstellung ist aktiv.
 |  | 3 | Absolute value Es wird der Absolutwert der signed Darstellung gebildet.
8030:05 | Watchdog | 0 | Default watchdog value Der Defaultwert (0x8pp0:13) ist aktiv. | BIT2 | RW | 0x00 (0dez)
 |  | 1 | Watchdog ramp Die Rampe (0x8pp0:14) zum Fahren auf den Defaultwert ((0x8pp0:13)) ist aktiv.
 |  | 2 | Last output value Das letzte Prozessdatum wird im Fehlerfall (Ansprechen des Watchdogs) ausgegeben.
8030:07 | Enable user calibration | Freigabe des Anwenderabgleichs |  | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable vendor calibration | Freigabe des Herstellerabgleichs |  | BOOLEAN | RW | 0x01 (1dez)
8030:11 | User scale offset | Anwenderskalierung: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:12 | User scale gain | Anwenderskalierung: Gain. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert eins entspricht 65535 (0x00010000). |  | INT32 | RW | 0x00010000 (65536dez)
8030:13 | Default output | Default-Ausgabewert |  | INT16 | RW | 0x0000 (0dez)
8030:14 | Default output ramp | Dieser Wert legt die Rampen zum Herunterfahren auf den Defaultwert fest. Der Wert wird in Digits / ms vorgegeben. Ist der Eintrag z. B. 100 und der Defaultwert 0, so dauert es 327 ms (32767/100) bis der Ausgangswert im Fehlerfall vom Maximalwert (32767) auf den Defaultwert geht. |  | UINT16 | RW | 0xFFFF (65535dez)
8030:15 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:16 | User calibration gain | Anwenderabgleich: Gain |  | UINT16 | RW | 0x4000 (16384dez)
Index F800 AO Range Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | AO Range Settings | Maximaler Subindex |  | UINT8 | RO | 0x04 (4dez)
F800:01 | Output type Ch1 | Ausgangssignalbereich für Kanal 1 |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | -10...+10 V
 |  | 1 | 0...20 mA
 |  | 2 | 4...20 mA
 |  | 6 | 0...10 V
F800:02 | Output type Ch2 | Ausgangssignalbereich für Kanal 2 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)
F800:03 | Output type Ch3 | Ausgangssignalbereich für Kanal 3 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)
F800:04 | Output type Ch4 | Ausgangssignalbereich für Kanal 4 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)


Objekte für den regulären Betrieb

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte für den regulären Betrieb
Objekte für den regulären Betrieb
Die EP4174 verfügt über keine solchen Objekte.


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01901389 (26219401dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP4174-0002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x104E4052 (273563730dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100002 (1048578dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 AO RxPDO-Map Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | AO RxPDO-Map Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (AO outputs Ch.1), entry 0x11 (Analog output)) | UINT32 | RO | 0x7000:11, 16
Index 1601 AO RxPDO-Map Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | AO RxPDO-Map Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (AO outputs Ch.2), entry 0x11 (Analog output)) | UINT32 | RO | 0x7010:11, 16
Index 1602 AO RxPDO-Map Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | AO RxPDO-Map Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (AO outputs Ch.3), entry 0x11 (Analog output)) | UINT32 | RO | 0x7020:11, 16
Index 1603 AO RxPDO-Map Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | AO RxPDO-Map Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (AO outputs Ch.4), entry 0x11 (Analog output)) | UINT32 | RO | 0x7030:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1603 (5635dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x00 (0dez)
Index 1C32 SM output parameter
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs |  |  | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Wert | Aktuelle Synchronisierungsbetriebsart |  | UINT16 | RW | 0x0001 (1dez)
 |  | 0 | Free Run
 |  | 1 | Synchron with SM 2 Event
 |  | 2 | DC-Mode - Synchron with SYNC0 Event
 |  | 3 | DC-Mode - Synchron with SYNC1 Event
1C32:02 | Cycle time | Zykluszeit (in ns) |  |  | UINT32 | RW | 0x000F4240 (1000000dez)
 |  | Free Run |  | Zykluszeit des lokalen Timers
 |  | Synchron with SM 2 Event |  | Zykluszeit des Masters
 |  | DC-Mode |  | SYNC0/SYNC1 Cycle Time
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) |  |  | UINT32 | RO | 0x00003A98 (15000dez)
1C32:04 | Sync modes supported | Bit | Wert | Unterstützte Synchronisierungsbetriebsarten: | UINT16 | RO | 0xC007 (49159dez)
 |  | 0 | 1 | Free Run wird unterstützt
 |  | 1 | 1 | Synchron mit SM 2 Event wird unterstützt
 |  | 3,2 | 01 | DC-Mode wird unterstützt
 |  | 5,4 | 10 | Output Shift mit SYNC1 Event (nur DC-Mode)
 |  | 14 | 1 | dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) |  |  | UINT32 | RO | 0x000493E0 (300000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) |  |  | UINT32 | RO | 0x00000000 (0dez)
1C32:07 | Minimum delay time |  |  |  | UINT32 | RO | 0x00003A98 (15000dez)
1C32:08 | Command | 0 | Messung der lokalen Zykluszeit wird gestoppt |  | UINT16 | RW | 0x0000 (0dez)
 |  | 1 | Messung der lokalen Zykluszeit wird gestartet
 |  | Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09
1C32:09 | Maximum Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) |  |  | UINT32 | RO | 0x00003A98 (15000dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) |  |  | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) |  |  | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) |  |  | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) |  |  | BOOLEAN | RO | 0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 7000 AO outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | AO outputs Ch.1 |  | UINT8 | RO | 0x11 (17dez)
7000:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 7010 AO outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | AO outputs Ch.2 |  | UINT8 | RO | 0x11 (17dez)
7010:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 7020 AO outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | AO outputs Ch.3 |  | UINT8 | RO | 0x11 (17dez)
7020:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 7030 AO outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | AO outputs Ch.4 |  | UINT8 | RO | 0x11 (17dez)
7030:11 | Analog output | Das analoge Ausgangsdatum | INT16 | RO | 0x0000 (0dez)
Index 800E AO internal data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | AO internal data Ch.1 |  | UINT8 | RO | 0x01 (1dez)
800E:01 | DAC raw value | Rohwert des D/A-Konverters | UINT16 | RO | 0x0000 (0dez)
Index 800F AO vendor data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | AO vendor data Ch.1 |  | UINT8 | RO | 0x06 (6dez)
800F:01 | R0 Calibration Offset | Herstellerabgleich: Offset für +/-10 V | INT16 | RW | 0x0000 (0dez)
800F:02 | R0 Calibration Gain | Herstellerabgleich: Gain für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
800F:03 | R1 Calibration Offset | Herstellerabgleich: Offset für 0-20 mA | INT16 | RW | 0x0000 (0dez)
800F:04 | R1 Calibration Gain | Herstellerabgleich: Gain für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
800F:05 | R2 Calibration Offset | Herstellerabgleich: Offset für 4-20 mA | INT16 | RW | 0x0000 (0dez)
800F:06 | R2 Calibration Gain | Herstellerabgleich: Gain für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index 801E AO internal data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | AO internal data Ch.2 |  | UINT8 | RO | 0x01 (1dez)
801E:01 | DAC raw value | Rohwert des D/A-Konverters | UINT16 | RO | 0x0000 (0dez)
Index 801F AO vendor data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | AO vendor data Ch.2 |  | UINT8 | RO | 0x06 (6dez)
801F:01 | R0 Calibration Offset | Herstellerabgleich: Offset für +/-10 V | INT16 | RW | 0x0000 (0dez)
801F:02 | R0 Calibration Gain | Herstellerabgleich: Gain für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
801F:03 | R1 Calibration Offset | Herstellerabgleich: Offset für 0-20 mA | INT16 | RW | 0x0000 (0dez)
801F:04 | R1 Calibration Gain | Herstellerabgleich: Gain für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
801F:05 | R2 Calibration Offset | Herstellerabgleich: Offset für 4-20 mA | INT16 | RW | 0x0000 (0dez)
801F:06 | R2 Calibration Gain | Herstellerabgleich: Gain für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index 802E AO internal data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802E:0 | AO internal data Ch.3 |  | UINT8 | RO | 0x01 (1dez)
802E:01 | DAC raw value | Rohwert des D/A-Konverters | UINT16 | RO | 0x0000 (0dez)
Index 802F AO vendor data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | AO vendor data Ch.3 |  | UINT8 | RO | 0x06 (6dez)
802F:01 | R0 Calibration Offset | Herstellerabgleich: Offset für +/-10 V | INT16 | RW | 0x0000 (0dez)
802F:02 | R0 Calibration Gain | Herstellerabgleich: Gain für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
802F:03 | R1 Calibration Offset | Herstellerabgleich: Offset für 0-20 mA | INT16 | RW | 0x0000 (0dez)
802F:04 | R1 Calibration Gain | Herstellerabgleich: Gain für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
802F:05 | R2 Calibration Offset | Herstellerabgleich: Offset für 4-20 mA | INT16 | RW | 0x0000 (0dez)
802F:06 | R2 Calibration Gain | Herstellerabgleich: Gain für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index 803E AO internal data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803E:0 | AO internal data Ch.4 |  | UINT8 | RO | 0x01 (1dez)
803E:01 | DAC raw value | Rohwert des D/A-Konverters | UINT16 | RO | 0x0000 (0dez)
Index 803F AO vendor data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | AO vendor data Ch.4 |  | UINT8 | RO | 0x06 (6dez)
803F:01 | R0 Calibration Offset | Herstellerabgleich: Offset für +/-10 V | INT16 | RW | 0x0000 (0dez)
803F:02 | R0 Calibration Gain | Herstellerabgleich: Gain für +/-10 V | UINT16 | RW | 0x4000 (16384dez)
803F:03 | R1 Calibration Offset | Herstellerabgleich: Offset für 0-20 mA | INT16 | RW | 0x0000 (0dez)
803F:04 | R1 Calibration Gain | Herstellerabgleich: Gain für 0-20 mA | UINT16 | RW | 0x4000 (16384dez)
803F:05 | R2 Calibration Offset | Herstellerabgleich: Offset für 4-20 mA | INT16 | RW | 0x0000 (0dez)
803F:06 | R2 Calibration Gain | Herstellerabgleich: Gain für 4-20 mA | UINT16 | RW | 0x4000 (16384dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000190 (400dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000190 (400dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000190 (400dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000190 (400dez)


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.