EP3744 - EtherCAT Box mit digitalen Ein-, Aus- und Differenzdruckeingängen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.2
▪
Technische Daten aktualisiert
2.1
▪
Sicherheitshinweise neues Layout
▪
Korrektur im Kapitel Prozessabbild
▪
Update Kapitel Montage
2.0.0
▪
Migration
1.3.0
▪
Kapitel Einstellungen hinzugefügt
1.2.0
▪
Power-Anschluss aktualisiert
1.1.0
▪
Titelseite aktualisiert
▪
EP3744-x041 Einführung um EP3744-1041 ergänzt
▪
Technische Daten um EP3744-1041 ergänzt
▪
Prozessabbild Überschrift angepasst
▪
Support und Service aktualisiert
▪
Sicherheitshinweise aktualisiert
▪
Hinweise zur Dokumentation aktualisiert
▪
EtherCAT- Anschluss aktualisiert
▪
Anzugsmomente für Steckverbinder aktualisiert
▪
EtherCAT-Kabel aktualisiert
1.0.0
▪
Erste Veröffentlichung
0.1.0
▪
Vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 50 13 03 01:
50 - Produktionswoche 50
13 - Produktionsjahr 2013
03 - Firmware-Stand 03
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
Einführung
•
Technische Daten
•
Prozessabbild


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Einführung

Produktübersicht [image] Einführung
Einführung
EP3744-0041, EP3744-1041
EtherCAT Box mit 6 digitalen Eingängen (24 VDC, 10 µs), 2 digitalen Ausgängen (24 VDC, 0,5 A) und Referenzdruckeingängen
Die EtherCAT Box EP3744-x041 mit sechs digitalen Eingängen und zwei digitalen Ausgängen erfasst binäre Steuersignale aus der Prozessebene und überträgt sie galvanisch getrennt zur Steuerung. Der Signalzustand wird über Leuchtdioden angezeigt, der Signalanschluss erfolgt über dreipolige M8-Steckverbinder (Buchsen).
Vier Pneumatik-Anschlüsse (6 mm) bieten die Möglichkeit einer Differenzdruckmessung. Dieser Wert wird gegenüber dem fünften Referenzdruckanschluss (6 mm) gemessen bzw. berechnet.
Die Sensoren und Ausgänge werden aus der Steuerspannung Us versorgt. Da auf dem M8-Stecker für Ein- und Ausgänge nur ein GND zur Verfügung steht, wurde diese abweichende Versorgung gewählt.
Die Lastspannung Up wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.
Druckmessung mit EP3744-0041
Die Druckmessung erfolgt als Absolut- oder Differenzdruckmessung zum fünften Anschluss per integriertem 6 mm Fitting. Die Druckwerte stehen als 16 Bit Wert zur Verfügung. Gemessen werden kann -1 Bar bis +1 Bar, wobei der Wert relativ zum fünften Anschluss ausgegeben wird, z. B. zur Unterdruckmessung gegenüber dem Umgebungsdruck an Sauggreifern. Im Absolutdruck-Modus können Drücke von 0 bis 1 Bar gemessen werden.
Druckmessung mit EP3744-1041
Die Druckmessung erfolgt als Absolut- oder Differenzdruckmessung zum fünften Anschluss per integriertem 6 mm Fitting. Die Druckwerte stehen als 16 Bit Wert zur Verfügung. Gemessen werden kann -7 Bar bis +7 Bar, wobei der Wert relativ zum fünften Anschluss ausgegeben wird, z. B. zur Unterdruckmessung gegenüber dem Umgebungsdruck an Sauggreifern. Im Absolutdruck-Modus können Drücke von 0 bis 7 Bar gemessen werden.
▪
Installation
▪
UL-Anforderungen für UL-zugelassene Module


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten
EP3744-0041
EP3744-1041
Feldbus
EtherCAT
Feldbusanschluss
2 x M8 Buchse (grün)
Anzahl digitaler Eingänge
6 x digitaler Eingang
Anschluss Eingänge
4 x M8 (Buchsen 0,1, 2 und 3)
Nennspannung Eingänge
24 VDC (-15%/+20%)
Eingangsfilter
10 µs (für digitale Eingänge)
Signalspannung "0"
-3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1"
+11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom
typisch 3 mA (EN 61131-2, Typ 3)
Anzahl Ausgänge
2 x digitaler Ausgang
Anschluss Ausgänge
2 x M8 (Buchsen 2 und 3)
Nennspannung Ausgänge
24 VDC (-15%/+20%)
Diagnose
Unterspannungserkennung < 18 VDC für Us und Up
Anzahl Druckeingänge
4 x Druckeingang + 1 x Referenzdruck, d=6 mm
Druckanschlüsse
Fittings, d = 6 mm
Drucksensoren
15 psi / 1034 hPa
100 psi / 6894 hPa
Technik (optional)
▪
Differenzdruckmessung gegen Referenzdruck-Messstelle (default)
▪
Absolutdruckmessung
Messbereich Differenzdruckmessung
-1...1 bar (-15...15 psi)
-7...7 bar (-100...100 psi)
Messbereich Absolutdruckmessung
0...1 bar (0...15 psi)
0...7 bar (0...100 psi)
Zulässige Medien
Nicht aggressive Gase
Auflösung
1 mbar pro Digit
Messfehler
3% bezogen auf Endwert
Max. Überlast
3 x Pmax
Auflösung (Rohwert)
16 Bit
Wandlungszeit
5 x Zykluszeit
min. Zykluszeit
700 µsec
Versorgung der Modulelektronik
aus der Steuerspannung Us
Stromaufnahme der Modulelektronik
typisch 120 mA
Sensorversorgung
aus der Steuerspannung Us
Stromaufnahme der Sensoren
max. 0,5 A, gesamt kurzschlussfest
Anschluss Spannungsversorgung
Einspeisung: 1 x M8 Stecker, 4-polig
Weiterleitung: 1 x M8 Buchse, 4-polig
Potenzialtrennung
Steuerspannung / Feldbus: ja
Zulässige Umgebungstemperatur im Betrieb
-25°C ... +60°C
0°C ... +55°C (gemäß cULus, siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung
-40°C ... +85°C
Vibrations- / Schockfestigkeit
gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung
gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart
IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage
beliebig
Zulassungen
CE, cULus


Prozessabbild

Produktübersicht [image] Prozessabbild
Prozessabbild
Kanal 1 bis Kanal 16
Unter DIG Inputs 1 bis Input6 finden Sie die 6 digitalen Eingänge des Moduls.
▪
Input 1 - Buchse 0, Pin 4
▪
Input 2 - Buchse 0, Pin 2
▪
Input 3 - Buchse 1, Pin 4
▪
Input 4 - Buchse 1, Pin 2
▪
Input 5 - Buchse 2, Pin 4
▪
Input 6 - Buchse 3, Pin 4
Unter AI Inputs Channel 1 bis 4 finden Sie die 4 Druckmess-Eingänge des Moduls.
▪
Underrange: der Underrange Wert wurde unterschritten
▪
Overrange: der Overrange Wert wurde überschritten
▪
Limit1: der in den CoE Objekten angegebene Limit1 Wert wurde erreicht
▪
Limit2: der in den CoE Objekten angegebene Limit2 Wert wurde erreicht
▪
Error: eins der o.a. Ereignisse ist aufgetreten
▪
Value: der gemessene Druckwert in der in den CoE Objekten vorskalierten Einheit (z. B. mBar)
Unter DEV Inputs Device finden Sie die Diagnosedaten des Moduls.
▪
Safe State Active: es gab eine Kommunikationsunterbrechung, woraufhin die Ausgänge in den Safe State gewechselt haben
▪
Sync error: ein Synchronisierungsfehler ist aufgetreten
▪
Undervoltage Us: die Spannung Us beträgt weniger als ca. 18 VDC
▪
Undervoltage Up: die Spannung Up beträgt weniger als ca. 18 VDC
▪
TxPDO Toggle: EtherCAT Variable zum Anzeigen eines gesendeten Eingangsdatums (siehe allgemeine EtherCAT Dokumentation)
Unter DIG Outputs 1 und 2 finden Sie die 2 digitalen Ausgänge des Moduls.
▪
Output 1 - Buchse 2, Pin 2
▪
Output 2 - Buchse 3, Pin 2
Unter DEV Output Device finden Sie die Ausgangsvariablen zum Setzen bzw. Zurücksetzen der Ausgänge des Moduls.
▪
Set safe state: Ausgänge nehmen den definierten Wert ein (siehe CoE Objekte)
▪
Reset Outputs: reserved
Dies sind Standard EtherCAT Variablen, mehr Informationen im allgemeinen EtherCAT-Handbuch.


Montage und Anschluss

Montage und Anschluss
Montage und Anschluss
Weiterführende Informationen
•
Montage
•
Anschluss
•
UL-Anforderungen


Montage

Montage und Anschluss [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder


Abmessungen

Montage und Anschluss [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyurethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Befestigung

Montage und Anschluss [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Montage und Anschluss [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


Anschluss

Montage und Anschluss [image] Anschluss
Anschluss
SmallWarningYellow VORSICHT
Druckluft
•
Prüfen Sie vor dem Anschluss oder der Demontage des Moduls, ob das System unter Druck steht.
⇨
Solange das System unter Druck steht, dürfen die Druckluftanschlüsse nicht geöffnet werden.
•
Die allgemeinen Sicherheits- und Einbauvorschriften im Umgang mit Druckluft sind zu beachten.
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Power-Kabel
•
Leitungsverluste M8
•
Signalanschluss
•
Status-LEDs an den Signalanschlüssen


EtherCAT-Anschluss

Montage und Anschluss [image] Anschluss [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Montage und Anschluss [image] Anschluss [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (https://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Power-Anschluss

Montage und Anschluss [image] Anschluss [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z. B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z. B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u. U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Anschluss [image] Anschluss [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Power-Kabel

Montage und Anschluss [image] Anschluss [image] Power-Kabel
Power-Kabel
Bestelldaten
Bestellbezeichnung | Power-Kabel | Schraub-Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m
Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).
Technische Daten
Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109Ω
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mΩ
Schutzart nach IEC 60529 | IP65/IP66/IP67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste M8

Montage und Anschluss [image] Anschluss [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Signalanschluss

Montage und Anschluss [image] Anschluss [image] Signalanschluss
Signalanschluss
Signalanschluss
Digitale Ein-/Ausgänge M8, 4-polig
Die EP3744 besitzt vier 4-polige M8-Buchsen.
Die Buchsen 0 und 1 besitzen jeweils 2 digitale Eingänge, die Buchse 2 und 3 einen Ein- und einen Ausgang.
Der Signalanschluss erfolgt über M8-Steckverbinder
Buchse 0 und 1
Buchse 2 und 3
Die Sensoren werden aus der Steuerspannung Us mit einem gemeinsamen, maximalen Strom von 0,5 A versorgt.
Leuchtdioden zeigen den Signalzustand der Eingänge an.
Druckmess-Eingänge, 6 mm Pneumatikschlauch
Der Anschluss zur Druckmessung erfolgt über Fittings für Standard-Pneumatikschläuche (6 mm). Die Werte werden als Referenz zum unteren, linken Messkanal ausgegeben.
Die Werte des Referenz-Kanals stehen nicht in den Prozessdaten, aber in den CoE-Objekten zur Verfügung.


Status-LEDs an den Signalanschlüssen

Montage und Anschluss [image] Anschluss [image] Status-LEDs an den Signalanschlüssen
Status-LEDs an den Signalanschlüssen
LED-Anzeigen
LED | Anzeige | Bedeutung
STATUS 1-4 | leuchtet grün | mindestens an einem Eingang der Kanäle 1-6 liegt ein Signal (24 V) an oder einer der Ausgänge 1 oder 2 ist eingeschaltet
Us | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Kurzschluss an den Sensorversorgungsausgängen der Us
Up | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


UL-Anforderungen

Montage und Anschluss [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
Objektübersicht
•
Objektbeschreibung und Parametrierung
•
Einstellungen
•
Wiederherstellen des Auslieferungszustandes
•
Firmware Update EL/ES/EM/EPxxxx


Einfügen in das EtherCAT-Netzwerk

Inbetriebnahme/Konfiguration [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Objektübersicht

Inbetriebnahme/Konfiguration [image] Objektübersicht
Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default-Wert
1000 |  | Device type | RO | 0x00001389 (5001dez)
1008 |  | Device name | RO | EP3744-0041
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 03
1011 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 0x1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 0x1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 0x1018:02 | Product code | RO | 0x0EA04052 (245383250dez)
 | 0x1018:03 | Revision | RO | 0x00000000 (0dez)
 | 0x1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 0x10F0:01 | Checksum | RO | 0x00000000 (0dez)
1600:0 | Subindex | DIG RxPDO-Map Outputs | RO | 0x03 (3dez)
 | 0x1600:01 | SubIndex 001 | RO | 0x7010:01, 1
 | 0x1600:02 | SubIndex 002 | RO | 0x7010:02, 1
 | 0x1600:03 | SubIndex 003 | RO | 0x0000:00, 14
1601:0 | Subindex | DEV RxPDO-Map Outputs Device | RO | 0x02 (2dez)
 | 0x1601:01 | SubIndex 001 | RO | 0xF700:01, 1
 | 0x1601:02 | SubIndex 002 | RO | 0x0000:00, 15
1A00:0 | Subindex | DIG TxPDO-Map Inputs | RO | 0x07 (7dez)
 | 0x1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 0x1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 0x1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 0x1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 0x1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 0x1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 0x1A00:07 | SubIndex 007 | RO | 0x0000:00, 10
1A01:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x09 (9dez)
 | 0x1A01:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 0x1A01:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 0x1A01:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 0x1A01:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 0x1A01:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 0x1A01:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A01:07 | SubIndex 007 | RO | 0x6020:0F, 1
 | 0x1A01:08 | SubIndex 008 | RO | 0x6020:10, 1
 | 0x1A01:09 | SubIndex 009 | RO | 0x6020:11, 32
Index (hex) |  | Name | Flags | Default-Wert
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x09 (9dez)
 | 0x1A02:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 0x1A02:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 0x1A02:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 0x1A02:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 0x1A02:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 0x1A02:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A02:07 | SubIndex 007 | RO | 0x6030:0F, 1
 | 0x1A02:08 | SubIndex 008 | RO | 0x6030:10, 1
 | 0x1A02:09 | SubIndex 009 | RO | 0x6030:11, 32
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x09 (9dez)
 | 0x1A03:01 | SubIndex 001 | RO | 0x6040:01, 1
 | 0x1A03:02 | SubIndex 002 | RO | 0x6040:02, 1
 | 0x1A03:03 | SubIndex 003 | RO | 0x6040:03, 2
 | 0x1A03:04 | SubIndex 004 | RO | 0x6040:05, 2
 | 0x1A03:05 | SubIndex 005 | RO | 0x6040:07, 1
 | 0x1A03:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A03:07 | SubIndex 007 | RO | 0x6040:0F, 1
 | 0x1A03:08 | SubIndex 008 | RO | 0x6040:10, 1
 | 0x1A03:09 | SubIndex 009 | RO | 0x6040:11, 32
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x09 (9dez)
 | 0x1A04:01 | SubIndex 001 | RO | 0x6050:01, 1
 | 0x1A04:02 | SubIndex 002 | RO | 0x6050:02, 1
 | 0x1A04:03 | SubIndex 003 | RO | 0x6050:03, 2
 | 0x1A04:04 | SubIndex 004 | RO | 0x6050:05, 2
 | 0x1A04:05 | SubIndex 005 | RO | 0x6050:07, 1
 | 0x1A04:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 0x1A04:07 | SubIndex 007 | RO | 0x6050:0F, 1
 | 0x1A04:08 | SubIndex 008 | RO | 0x6050:10, 1
 | 0x1A04:09 | SubIndex 009 | RO | 0x6050:11, 32
1A05:0 | Subindex | DEV TxPDO-Map Inputs Device | RO | 0x07 (7dez)
 | 0x1A05:01 | SubIndex 001 | RO | 0xF600:01, 1
 | 0x1A05:02 | SubIndex 002 | RO | 0x0000:00, 15
 | 0x1A05:03 | SubIndex 003 | RO | 0xF611:01, 1
 | 0x1A05:04 | SubIndex 004 | RO | 0xF611:02, 1
 | 0x1A05:05 | SubIndex 005 | RO | 0x0000:00, 13
 | 0x1A05:06 | SubIndex 006 | RO | 0xF611:10, 1
 | 0x1A05:07 | SubIndex 007 | RO | 0x0000:00, 96
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 0x1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 0x1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 0x1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 0x1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dez)
 | 0x1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
 | 0x1C12:02 | SubIndex 002 | RW | 0x1601 (5633dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x06 (6dez)
 | 0x1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 0x1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dez)
 | 0x1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dez)
 | 0x1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dez)
 | 0x1C13:05 | SubIndex 005 | RW | 0x1A04 (6660dez)
 | 0x1C13:06 | SubIndex 006 | RW | 0x1A05 (6661dez)
Index (hex) |  | Name | Flags | Default-Wert
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 0x1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 0x1C32:02 | Cycle time | RW | 0x003D0900 (4000000dez)
 | 0x1C32:03 | Shift time | RO | 0x00000384 (900dez)
 | 0x1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 0x1C32:05 | Minimum cycle time | RO | 0x000F4240 (1000000dez)
 | 0x1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 0x1C32:07 | Minimum delay time | RO | 0x00000384 (900dez)
 | 0x1C32:08 | Command | RW | 0x0000 (0dez)
 | 0x1C32:09 | Maximum delay time | RO | 0x00000384 (900dez)
 | 0x1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 0x1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 0x1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 0x1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 0x1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 0x1C33:02 | Cycle time | RW | 0x003D0900 (4000000dez)
 | 0x1C33:03 | Shift time | RO | 0x00000384 (900dez)
 | 0x1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 0x1C33:05 | Minimum cycle time | RO | 0x000F4240 (1000000dez)
 | 0x1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 0x1C33:07 | Minimum delay time | RO | 0x00000384 (900dez)
 | 0x1C33:08 | Command | RW | 0x0000 (0dez)
 | 0x1C33:09 | Maximum delay time | RO | 0x00000384 (900dez)
 | 0x1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 0x1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 0x1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 0x1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | Dig Inputs | RO | 0x06 (6dez)
 | 0x6000:01 | Input 1 | RO | 0x00 (0dez)
 | 0x6000:02 | Input 2 | RO | 0x00 (0dez)
 | 0x6000:03 | Input 3 | RO | 0x00 (0dez)
 | 0x6000:04 | Input 4 | RO | 0x00 (0dez)
 | 0x6000:05 | Input 5 | RO | 0x00 (0dez)
 | 0x6000:06 | Input 6 | RO | 0x00 (0dez)
6020:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dez)
 | 0x6020:01 | Underrange | RO | 0x00 (0dez)
 | 0x6020:02 | Overrange | RO | 0x00 (0dez)
 | 0x6020:03 | Limit 1 | RO | 0x00 (0dez)
 | 0x6020:05 | Limit 2 | RO | 0x00 (0dez)
 | 0x6020:07 | Error | RO | 0x00 (0dez)
 | 0x6020:0F | TxPDO State | RO | 0x00 (0dez)
 | 0x6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 0x6020:11 | Value | RO | 0x00000000 (0dez)
6030:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dez)
 | 0x6030:01 | Underrange | RO | 0x00 (0dez)
 | 0x6030:02 | Overrange | RO | 0x00 (0dez)
 | 0x6030:03 | Limit 1 | RO | 0x00 (0dez)
 | 0x6030:05 | Limit 2 | RO | 0x00 (0dez)
 | 0x6030:07 | Error | RO | 0x00 (0dez)
 | 0x6030:0F | TxPDO State | RO | 0x00 (0dez)
 | 0x6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 0x6030:11 | Value | RO | 0x00000000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
6040:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dez)
 | 0x6040:01 | Underrange | RO | 0x00 (0dez)
 | 0x6040:02 | Overrange | RO | 0x00 (0dez)
 | 0x6040:03 | Limit 1 | RO | 0x00 (0dez)
 | 0x6040:05 | Limit 2 | RO | 0x00 (0dez)
 | 0x6040:07 | Error | RO | 0x00 (0dez)
 | 0x6040:0F | TxPDO State | RO | 0x00 (0dez)
 | 0x6040:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 0x6040:11 | Value | RO | 0x00000000 (0dez)
6050:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dez)
 | 0x6050:01 | Underrange | RO | 0x00 (0dez)
 | 0x6050:02 | Overrange | RO | 0x00 (0dez)
 | 0x6050:03 | Limit 1 | RO | 0x00 (0dez)
 | 0x6050:05 | Limit 2 | RO | 0x00 (0dez)
 | 0x6050:07 | Error | RO | 0x00 (0dez)
 | 0x6050:0F | TxPDO State | RO | 0x00 (0dez)
 | 0x6050:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 0x6050:11 | Value | RO | 0x00000000 (0dez)
7010:0 | Subindex | Dig Outputs | RO | 0x02 (2dez)
 | 0x7010:01 | Output 1 | RO | 0x00 (0dez)
 | 0x7010:02 | Output 2 | RO | 0x00 (0dez)
8010:0 | Subindex | Safe state active | RW | 0x02 (2dez)
 | 0x8010:01 | Output 1 | RW | 0x00 (0dez)
 | 0x8010:02 | Output 2 | RW | 0x00 (0dez)
8011:0 | Subindex | Safe state value | RW | 0x02 (2dez)
 | 0x8011:01 | Output 1 | RW | 0x00 (0dez)
 | 0x8011:02 | Output 2 | RW | 0x00 (0dez)
8020:0 | Subindex | AI Settings Ch.1 | RW | 0x19 (25dez)
 | 0x8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 0x8020:06 | Enable filter | RW | 0x01 (1dez)
 | 0x8020:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 0x8020:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 0x8020:0A | Enable user calibration | RW | 0x00 (0dez)
 | 0x8020:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 0x8020:11 | User scale offset | RW | 0x00000000 (0dez)
 | 0x8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 0x8020:13 | Limit 1 | RW | 0x0000 (0dez)
 | 0x8020:14 | Limit 2 | RW | 0x0000 (0dez)
 | 0x8020:15 | Filter settings | RW | 0x0000 (0dez)
 | 0x8020:17 | User calibration offset | RW | 0x00000000 (0dez)
 | 0x8020:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 0x8020:19 | Range | RW | 0x0008 (8dez)
802E:0 | Subindex | AI Internal data Ch.1 | RO | 0x01 (1dez)
 | 0x802E:01 | ADC raw value | RO | 0x00000000 (0dez)
802F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x04 (4dez)
 | 0x802F:01 | Calibration offset pressure | RW | 0x00000000 (0dez)
 | 0x802F:02 | Calibration gain pressure | RW | 0x4000 (16384dez)
 | 0x802F:03 | Calibration offset temp | RW | 0x00000000 (0dez)
 | 0x802F:04 | Calibration gain temp | RW | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
8030:0 | Subindex | AI Settings Ch.2 | RW | 0x19 (25dez)
 | 0x8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 0x8030:06 | Enable filter | RW | 0x01 (1dez)
 | 0x8030:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 0x8030:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 0x8030:0A | Enable user calibration | RW | 0x00 (0dez)
 | 0x8030:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 0x8030:11 | User scale offset | RW | 0x00000000 (0dez)
 | 0x8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 0x8030:13 | Limit 1 | RW | 0x0000 (0dez)
 | 0x8030:14 | Limit 2 | RW | 0x0000 (0dez)
 | 0x8030:15 | Filter settings | RW | 0x0000 (0dez)
 | 0x8030:17 | User calibration offset | RW | 0x00000000 (0dez)
 | 0x8030:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 0x8030:19 | Range | RW | 0x0008 (8dez)
803E:0 | Subindex | AI Internal data Ch.2 | RO | 0x01 (1dez)
 | 0x803E:01 | ADC raw value | RO | 0x00000000 (0dez)
803F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x04 (4dez)
 | 0x803F:01 | Calibration offset pressure | RW | 0x00000000 (0dez)
 | 0x803F:02 | Calibration gain pressure | RW | 0x4000 (16384dez)
 | 0x803F:03 | Calibration offset temp | RW | 0x00000000 (0dez)
 | 0x803F:04 | Calibration gain temp | RW | 0x0000 (0dez)
8040:0 | Subindex | AI Settings Ch.3 | RW | 0x19 (25dez)
 | 0x8040:01 | Enable user scale | RW | 0x00 (0dez)
 | 0x8040:06 | Enable filter | RW | 0x01 (1dez)
 | 0x8040:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 0x8040:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 0x8040:0A | Enable user calibration | RW | 0x00 (0dez)
 | 0x8040:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 0x8040:11 | User scale offset | RW | 0x00000000 (0dez)
 | 0x8040:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 0x8040:13 | Limit 1 | RW | 0x0000 (0dez)
 | 0x8040:14 | Limit 2 | RW | 0x0000 (0dez)
 | 0x8040:15 | Filter settings | RW | 0x0000 (0dez)
 | 0x8040:17 | User calibration offset | RW | 0x00000000 (0dez)
 | 0x8040:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 0x8040:19 | Range | RW | 0x0008 (8dez)
804E:0 | Subindex | AI Internal data Ch.3 | RO | 0x01 (1dez)
 | 0x804E:01 | ADC raw value | RO | 0x00000000 (0dez)
804F:0 | Subindex | AI Vendor data Ch.3 | RW | 0x04 (4dez)
 | 0x804F:01 | Calibration offset pressure | RW | 0x00000000 (0dez)
 | 0x804F:02 | Calibration gain pressure | RW | 0x4000 (16384dez)
 | 0x804F:03 | Calibration offset temp | RW | 0x00000000 (0dez)
 | 0x804F:04 | Calibration gain temp | RW | 0x0000 (0dez)
Index (hex) |  | Name | Flags | Default-Wert
8050:0 | Subindex | AI Settings Ch.4 | RW | 0x19 (25dez)
 | 0x8050:01 | Enable user scale | RW | 0x00 (0dez)
 | 0x8050:06 | Enable filter | RW | 0x01 (1dez)
 | 0x8050:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 0x8050:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 0x8050:0A | Enable user calibration | RW | 0x00 (0dez)
 | 0x8050:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 0x8050:11 | User scale offset | RW | 0x00000000 (0dez)
 | 0x8050:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 0x8050:13 | Limit 1 | RW | 0x0000 (0dez)
 | 0x8050:14 | Limit 2 | RW | 0x0000 (0dez)
 | 0x8050:15 | Filter settings | RW | 0x0000 (0dez)
 | 0x8050:17 | User calibration offset | RW | 0x00000000 (0dez)
 | 0x8050:18 | User calibration gain | RW | 0x4000 (16384dez)
 | 0x8050:19 | Range | RW | 0x0008 (8dez)
805E:0 | Subindex | AI Internal data Ch.4 | RO | 0x01 (1dez)
 | 0x805E:01 | ADC raw value | RO | 0x00000000 (0dez)
805F:0 | Subindex | AI Vendor data Ch.4 | RW | 0x04 (4dez)
 | 0x805F:01 | Calibration offset pressure | RW | 0x00000000 (0dez)
 | 0x805F:02 | Calibration gain pressure | RW | 0x4000 (16384dez)
 | 0x805F:03 | Calibration offset temp | RW | 0x00000000 (0dez)
 | 0x805F:04 | Calibration gain temp | RW | 0x0000 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | 0xF000:01 | Module index distance | RO | 0x0010 (16dez)
 | 0xF000:02 | Maximum number of modules | RO | 0x0006 (6dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x06 (6dez)
 | 0xF010:01 | SubIndex 001 | RW | 0x00000118 (280dez)
 | 0xF010:02 | SubIndex 002 | RW | 0x00000118 (280dez)
 | 0xF010:03 | SubIndex 003 | RW | 0x0000012C (300dez)
 | 0xF010:04 | SubIndex 004 | RW | 0x0000012C (300dez)
 | 0xF010:05 | SubIndex 005 | RW | 0x0000012C (300dez)
 | 0xF010:06 | SubIndex 006 | RW | 0x0000012C (300dez)
F600:0 | Subindex | DEV Inputs Safe State Active | RO | 0x01 (1dez)
 | 0xF600:01 | Safe State Active | RO | 0x00 (0dez)
F611:0 | Subindex | DEV Inputs Undervoltage | RO | 0x10 (16dez)
 | 0xF611:01 | Undervoltage Us | RO | 0x00 (0dez)
 | 0xF611:02 | Undervoltage Up | RO | 0x00 (0dez)
 | 0xF611:10 | TxPDO Toggle | RO | 0x00 (0dez)
F700:0 | Subindex | DEV Outputs Set Safe State | RO | 0x01 (1dez)
 | 0xF700:01 | Set safe state | RO | 0x00 (0dez)
F800:0 | Subindex | AI Settings Reference | RW | 0x18 (24dez)
 | 0xF800:0A | Enable user calibration | RW | 0x00 (0dez)
 | 0xF800:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 0xF800:17 | User calibration offset | RW | 0x00000000 (0dez)
 | 0xF800:18 | User calibration gain | RW | 0x4000 (16384dez)
F80E:0 | Subindex | AI Internal data Reference | RO | 0x02 (2dez)
 | 0xF80E:01 | ADC raw value 1 | RO | 0x00000000 (0dez)
 | 0xF80E:02 | ADC raw value 2 | RO | 0x00000000 (0dez)
F80F:0 | Subindex | AI Vendor data Reference | RW | 0x04 (4dez)
 | 0xF80F:01 | Calibration offset pressure | RW | 0x00000000 (0dez)
 | 0xF80F:02 | Calibration gain pressure | RW | 0x4000 (16384dez)
 | 0xF80F:03 | Calibration offset temp | RW | 0x00000000 (0dez)
 | 0xF80F:04 | Calibration gain temp | RW | 0x0000 (0dez)
Legend
Flags:
RO = Read Only
RW = Read/Write


Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Standard-Objekte (0x1000-0x1FFF)
•
Profile specific objects (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8010 Safe state active
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | Safe state active |  |  | UINT8 | RO | 0x02 (2dez)
8010:01 | Output 1 | 0 | Der Status des Ausgangs bleibt unverändert während OP-> SafeOP | BOOLEAN | RW | 0x00 (0dez)
 |  | 1 | Der Ausgang geht während OP-> SafeOP in den in Safe State value (Index 0x8011:01) definierten Zustand.
8010:02 | Output 2 | 0 | Der Status des Ausgangs bleibt unverändert während OP-> SafeOP | BOOLEAN | RW | 0x00 (0dez)
 |  | 1 | Der Ausgang geht während OP-> SafeOP in den in Safe State value (Index 0x8011:02) definierten Zustand.
Index 8011 Safe state value
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8011:0 | Safe state value |  |  | UINT8 | RO | 0x02 (2dez)
8011:01 | Output 1 | 0 | Safe state value für Ausgang 1 = 0 | BOOLEAN | RW | 0x00 (0dez)
 |  | 1 | Safe state value für Ausgang 1 = 1
8011:02 | Output 2 | 0 | Safe state value für Ausgang 2 = 0 | BOOLEAN | RW | 0x00 (0dez)
 |  | 1 | Safe state value für Ausgang 2 = 1
Index 8020 AI Settings Ch.1 (Parametrierung von Kanal 1)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | AI Settings Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x19 (25dez)
8020:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8020:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8020:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8020:11 | User scale offset | Offset der Anwender-Skalierung |  | INT32 | RW | 0x00000000 (0dez)
8020:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8020:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8020:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8020:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen aller Kanäle des Moduls, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8020:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dez)
8020:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dez)
8020:19 | Range | Zulässige Werte: |  | UINT16 | RW | 0x0008 (8dez)
 |  | 8 | Differentiale Druckmessung zum Referenz-Sensor
 |  | 7 | Absolute Druckmessung
Index 8030 AI Settings Ch.2 (Parametrierung von Kanal 2)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0 | AI Settings Ch.2 | Maximaler Subindex |  | UINT8 | RO | 0x19 (25dez)
8030:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8030:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8030:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8030:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8030:11 | User scale offset | Offset der Anwender-Skalierung |  | INT32 | RW | 0x00000000 (0dez)
8030:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8030:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8030:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8030:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8030:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dez)
8030:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dez)
8030:19 | Range | Zulässige Werte: |  | UINT16 | RW | 0x0008 (8dez)
 |  | 8 | Differentiale Druckmessung zum Referenz-Sensor
 |  | 7 | Absolute Druckmessung
Index 8040 AI Settings Ch.3 (Parametrierung von Kanal 3)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8040:0 | AI Settings Ch.3 | Maximaler Subindex |  | UINT8 | RO | 0x19 (25dez)
8040:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8040:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8040:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8040:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8040:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8040:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8040:11 | User scale offset | Offset der Anwender-Skalierung |  | INT32 | RW | 0x00000000 (0dez)
8040:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8040:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8040:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8040:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8040:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dez)
8040:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dez)
8040:19 | Range | Zulässige Werte: |  | UINT16 | RW | 0x0008 (8dez)
 |  | 8 | Differentiale Druckmessung zum Referenz-Sensor
 |  | 7 | Absolute Druckmessung
Index 8050 AI Settings Ch.4 (Parametrierung von Kanal 4 )
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8050:0 | AI Settings Ch.4 | Maximaler Subindex |  | UINT8 | RO | 0x19 (25dez)
8050:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8050:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8050:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8050:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8050:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8050:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8050:11 | User scale offset | Offset der Anwender-Skalierung |  | INT32 | RW | 0x00000000 (0dez)
8050:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8050:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8050:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8050:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8050:17 | User calibration offset |  |  | INT32 | RW | 0x00000000 (0dez)
8050:18 | User calibration gain |  |  | INT16 | RW | 0x4000 (16384dez)
8050:19 | Range | Zulässige Werte: |  | UINT16 | RW | 0x0008 (8dez)
 |  | 8 | Differentiale Druckmessung zum Referenz-Sensor
 |  | 7 | Absolute Druckmessung


Standard-Objekte (0x1000-0x1FFF)

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Standard-Objekte (0x1000-0x1FFF)
Standard-Objekte (0x1000-0x1FFF)
Die Standard-Objekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP3744-0041
Index 1009: Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x0EA04052 (245383250dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer/Sonderboxennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DIG RxPDO-Map Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DIG RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x03 (3dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (Dig Outputs), entry 0x01 (Output 1)) | UINT32 | RO | 0x7010:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (Dig Outputs), entry 0x02 (Output 2)) | UINT32 | RO | 0x7010:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1601 DEV RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DEV RxPDO-Map Outputs Device | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DEV Outputs Set Safe State), entry 0x01 (Set safe state)) | UINT32 | RO | 0xF700:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (DEV Outputs Set Safe State), entry 0x02 (Reset Outputs)) | UINT32 | RO | 0x0000:00, 15
Index 1A00 DIG TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x07 (7dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Dig Inputs), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
Index 1A01 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 32
Index 1A02 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 32
Index 1A03 AI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RO | 0x6040:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RO | 0x6040:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6040:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6040:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6040:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6040:0F, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 32
Index 1A04 AI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x09 (9dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RO | 0x6050:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RO | 0x6050:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6050:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6050:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6050:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6050:0F, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 32
Index 1A05 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DEV Inputs Safe State Active), entry 0x01 (Safe State Active)) | UINT32 | RO | 0xF600:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs Undervoltage), entry 0x01 (Undervoltage Us )) | UINT32 | RO | 0xF611:01, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs Undervoltage), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 13
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs Undervoltage), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF611:10, 1
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (96 bits align) | UINT32 | RO | 0x0000:00, 96
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Usage of the Sync Manager channels | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. assigned RxPDO (contains the index of the corresponding RxPDO Mapping object) | UINT16 | RW | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x06 (6dez)
1C13:01 | Subindex 001 | 1. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | Subindex 005 | 5. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A04 (6660dez)
1C13:06 | Subindex 006 | 6. assigned TxPDO (contains the index of the corresponding TxPDO Mapping object) | UINT16 | RW | 0x1A05 (6661dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchronous with SM 2 Event
▪
2: DC-Mode - Synchronous with SYNC0 Event
▪
3: DC-Mode - Synchronous with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle time
UINT32
RW
0x003D0900 (4000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:04
Sync modes supported
▪
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchronous with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000F4240 (1000000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
The Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
▪
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x003D0900 (4000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
▪
Unterstützte Synchronisierungsbetriebsarten
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch locales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x000F4240 (1000000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profile specific objects (0x6000-0xFFFF)

Inbetriebnahme/Konfiguration [image] Objektbeschreibung und Parametrierung [image] Profile specific objects (0x6000-0xFFFF)
Profile specific objects (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6020 AI Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dez)
6020:01 | Underrange | Messbereich unterschritten | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Overrange | Messbereich überschritten | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dez)
6020:05 | Limit 2 | Bit 0: Wert ist größer als Limit2 Bit1: Wert ist kleiner als Limit2 | BIT2 | RO | 0x00 (0dez)
6020:07 | Error | Bit wird bei Über- oder Unterschreiten des Messbereichs gesetzt | BOOLEAN | RO | 0x00 (0dez)
6020:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value |  | INT32 | RO | 0x00000000 (0dez)
Index 6030 AI Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6030:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dez)
6030:01 | Underrange | Messbereich unterschritten | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Overrange | Messbereich überschritten | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dez)
6030:05 | Limit 2 | Bit 0: Wert ist größer als Limit2 Bit1: Wert ist kleiner als Limit2 | BIT2 | RO | 0x00 (0dez)
6030:07 | Error | Bit wird bei Über- oder Unterschreiten des Messbereichs gesetzt | BOOLEAN | RO | 0x00 (0dez)
6030:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value |  | INT32 | RO | 0x00000000 (0dez)
Index 6040 AI Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dez)
6040:01 | Underrange | Messbereich unterschritten | BOOLEAN | RO | 0x00 (0dez)
6040:02 | Overrange | Messbereich überschritten | BOOLEAN | RO | 0x00 (0dez)
6040:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dez)
6040:05 | Limit 2 | Bit 0: Wert ist größer als Limit2 Bit1: Wert ist kleiner als Limit2 | BIT2 | RO | 0x00 (0dez)
6040:07 | Error | Bit wird bei Über- oder Unterschreiten des Messbereichs gesetzt | BOOLEAN | RO | 0x00 (0dez)
6040:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dez)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6040:11 | Value |  | INT32 | RO | 0x00000000 (0dez)
Index 6050 AI Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6050:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dez)
6050:01 | Underrange | Messbereich unterschritten | BOOLEAN | RO | 0x00 (0dez)
6050:02 | Overrange | Messbereich überschritten | BOOLEAN | RO | 0x00 (0dez)
6050:03 | Limit 1 |  | BIT2 | RO | 0x00 (0dez)
6050:05 | Limit 2 | Bit 0: Wert ist größer als Limit2 Bit1: Wert ist kleiner als Limit2 | BIT2 | RO | 0x00 (0dez)
6050:07 | Error | Bit wird bei Über- oder Unterschreiten des Messbereichs gesetzt | BOOLEAN | RO | 0x00 (0dez)
6050:0F | TxPDO State |  | BOOLEAN | RO | 0x00 (0dez)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6050:11 | Value |  | INT32 | RO | 0x00000000 (0dez)
Index 6000 Dig Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Dig Inputs |  | UINT8 | RO | 0x06 (6dez)
6000:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dez)
Index 7010 Dig Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | Dig Outputs |  | UINT8 | RO | 0x02 (2dez)
7010:01 | Output 1 |  | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Output 2 |  | BOOLEAN | RO | 0x00 (0dez)
Index 802E AI Internal data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802E:0 | AI Internal data Ch.1 |  | UINT8 | RO | 0x01 (1dez)
802E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dez)
Index 802F AI Vendor data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x04 (4dez)
802F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dez)
802F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dez)
802F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dez)
802F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dez)
Index 803E AI Internal data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803E:0 | AI Internal data Ch.2 |  | UINT8 | RO | 0x01 (1dez)
803E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dez)
Index 803F AI Vendor data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x04 (4dez)
803F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dez)
803F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dez)
803F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dez)
803F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dez)
Index 804E AI Internal data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
804E:0 | AI Internal data Ch.3 |  | UINT8 | RO | 0x01 (1dez)
804E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dez)
Index 804F AI Vendor data Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
804F:0 | AI Vendor data Ch.3 |  | UINT8 | RO | 0x04 (4dez)
804F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dez)
804F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dez)
804F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dez)
804F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dez)
Index 805E AI Internal data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
805E:0 | AI Internal data Ch.4 |  | UINT8 | RO | 0x01 (1dez)
805E:01 | ADC raw value |  | INT32 | RO | 0x00000000 (0dez)
Index 805F AI Vendor data Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
805F:0 | AI Vendor data Ch.4 |  | UINT8 | RO | 0x04 (4dez)
805F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dez)
805F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dez)
805F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dez)
805F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand für die Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0006 (6dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x06 (6dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dez)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dez)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x0000012C (300dez)
Index F600 DEV Inputs Safe State Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | DEV Inputs Safe State Active |  | UINT8 | RO | 0x01 (1dez)
F600:01 | Safe State Active | 1: Ausgänge sind im Safe State 0: Ausgänge sind im normalen Status | BOOLEAN | RO | 0x00 (0dez)
Index F611 DEV Inputs Undervoltage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F611:0 | DEV Inputs Undervoltage |  | UINT8 | RO | 0x10 (16dez)
F611:01 | Undervoltage Us | Us ≤ 18 V | BOOLEAN | RO | 0x00 (0dez)
F611:02 | Undervoltage Up | Up ≤ 18 V | BOOLEAN | RO | 0x00 (0dez)
F611:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
Index F700 DEV Outputs Set Safe State
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F700:0 | DEV Outputs Set Safe State |  | UINT8 | RO | 0x01 (1dez)
F700:01 | Set safe state | Setzt das Gerät ins Safe State | BOOLEAN | RO | 0x00 (0dez)
Index F800 AI Settings Reference
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F800:0 | AI Settings Reference |  | UINT8 | RO | 0x18 (24dez)
F800:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
F800:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x01 (1dez)
F800:17 | User calibration offset |  | INT32 | RW | 0x00000000 (0dez)
F800:18 | User calibration gain |  | INT16 | RW | 0x4000 (16384dez)
Index F80E AI Internal data Reference
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80E:0 | AI Internal data Reference |  | UINT8 | RO | 0x02 (2dez)
F80E:01 | ADC raw value 1 | Druckwert | INT32 | RO | 0x00000000 (0dez)
F80E:02 | ADC raw value 2 | Druckwert | INT32 | RO | 0x00000000 (0dez)
Index F80F AI Vendor data Reference
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | AI Vendor data Reference |  | UINT8 | RO | 0x04 (4dez)
F80F:01 | Calibration offset pressure |  | INT32 | RW | 0x00000000 (0dez)
F80F:02 | Calibration gain pressure |  | INT16 | RW | 0x4000 (16384dez)
F80F:03 | Calibration offset temp |  | INT32 | RW | 0x00000000 (0dez)
F80F:04 | Calibration gain temp |  | INT16 | RW | 0x0000 (0dez)


Einstellungen

Inbetriebnahme/Konfiguration [image] Einstellungen
Einstellungen
FIR- und IIR-Filter
Die Box EP3744 ist mit einem digitalen Filter ausgestattet, das je nach Einstellung die Charakteristik eines Filter mit endlicher Impulsantwort (Finite Impulse Response filter, FIR-Filter) oder eines Filter mit unendlicher Impulsantwort (Infinite Impulse Response filter, IIR-Filter), annehmen kann. Der Filter kann auch deaktiviert werden.
Einstellung der Filtereigenschaften über Index 0x8020:15
Die Filterfrequenzen werden für alle Kanäle der Box EP3744 zentral über den Index 0x8020:15 (Kanal 1) eingestellt. Die entsprechenden Indizes 0x80n0:15der weiteren Kanäle haben keine Parametrierungsfunktion.
FIR-Filter
Das Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit der Box. Es wird über den Index 0x8020:15 parametriert. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit. Es steht ein 50 und ein 60 Hz Filter zur Verfügung.
Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also in der Amplitude dämpft.
Das FIR-Filter arbeitet als nicht-rekursives Filter, das über die Parametrierung des Objektes 0x8020:15 eingestellt werden kann.
Typ. Dämpfungskurve Notch-Filter bei 50 Hz
Filterdaten FIR - Filter (1- 4 kanalige Boxen)
Filter | Dämpfung | Grenzfrequenz (-3 dB)
50 Hz FIR | > 50 dB | 22 Hz
60 Hz FIR | > 40 dB | 26 Hz
Filterdaten FIR - Filter (8 kanalige Boxen)
Filter | Dämpfung | Grenzfrequenz (-3 dB)
50 Hz FIR | > 50 dB | 23 Hz
60 Hz FIR | > 50 dB | 27 Hz
IIR-Filter
Das Filter mit IIR-Charakteristik ist ein zeitdiskretes, lineares, zeitinvariantes Filter, welches in 8 Level eingestellt werden kann (Level 1 = schwaches rekursives Filter, bis Level 8 = starkes rekursives Filter).
Der IIR kann als gleitende Mittelwertberechnung nach einem Tiefpass verstanden werden.
Durch den Synchronisierungsmodus FreeRun arbeitet der IIR-Filter mit 500 µs (1, 2 oder 4 Kanäle) bzw. 1 ms (8 Kanäle) interner Zykluszeit.
Filterdaten IIR - Filter
IIR - Filter | Grenzfrequenz bei boxinterner Zykluszeit 1 ms (-3 dB)
IIR 1 | 168 Hz
IIR 2 | 88 Hz
IIR 3 | 43 Hz
IIR 4 | 21 Hz
IIR 5 | 10,5 Hz
IIR 6 | 5,2 Hz
IIR 7 | 2,5 Hz
IIR 8 | 1,2 Hz
Wandlungszeit & FIR- und IIR-Filter, Index 0x80n0:06
Die typ. Wandlungszeit und Triggermodus ist abhängig von
▪
der gewählten Filtereinstellung (default: 50 Hz)
▪
der Einstellung im CoE-Register 0x1C33:01
–
durch manuelles Parametrieren im Systemmanager. ACHTUNG: Vorgenommene Änderungen in die StartUp-Liste eintragen!
–
durch die StartUp-Liste als automatischer Parameterdownload während der EtherCAT-Startphase. ACHTUNG: Einträge werden erst nach Aktivieren der Konfiguration ausgeführt!
Die Wandlungszeit ist der Zeitabstand, in dem die EP3744 einen neuen Messwert zur Verfügung stellt. Ein neuer Messwert wird durch Toggeln von "TxPDO Toggle" (Index 0x60n0:10) angezeigt.
Limit 1 und Limit 2, Index 0x80n0:13, Index 0x80n0:14
Beim Über- bzw. Unterschreiten der Werte, die in den Indizes 0x80n0:13 und 0x80n0:14 eingegeben werden können, werden die Bits in den Indizes 0x60n0:03 und 0x60n0:05 entsprechend gesetzt (siehe unteres Beispiel). Zur Aktivierung der Grenzwertüberwachung dienen die Indizes 0x80n0:07 bzw. 0x80n0:08.
Ausgabe Limit n (2 Bit):
▪
0: nicht aktiv
▪
1: Wert ist kleiner als Grenzwert
▪
2: Wert ist größer als Grenzwert
▪
3: Wert ist gleich dem Grenzwert
Verlinkung in der PLC mit 2-Bit-Werten
Die Limit-Information besteht aus 2 Bit. Im System Manager kann Limitn mit der PLC oder einer Task verknüpft werden.
▪
PLC:
Es gibt in der IEC61131-PLC keinen 2-Bit-Datentyp der mit diesem Prozessdatum 1:1 verlinkt werden kann. Zur Übertragung der Limit-Information definieren Sie deshalb ein Eingangsbyte, z. B. und verlinken Sie den Limit mit dem VariableSizeMismatch-Dialog, wie in der Abbildung Verlinkung 2-Bit-Variable mit zusätzlicher Task beschrieben.
Definition Eingangsbyte
▪
Zusätzliche Task
Im System Manager können 2-Bit-Variablen angelegt werden.
Verlinkung 2-Bit-Variable mit zusätzlicher Task
Beispiel für EL3062:
Kanal 1; Limit1 und Limit 2 enabled, Limit 1 = 2,8 V, Limit 2 = 7,4 V, Darstellung: signed integer
Eingabe in Index 0x80n0:13 (Limit 1):
(2,8 V / 10 V) x 216 / 2 - 1 = 9.174dez
Eingabe in Index 0x80n0:14(Limit 2):
(7,4 V / 10 V) x 216 / 2 - 1 = 24.247dez
Ausgabe:
Eingang Kanal 1 | Index 0x6000:03 | Index 0x6000:05
1.8 V | 0x01hex, (Limit 1, Grenzbereich unterschritten) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
2.8 V | 0x03hex, (Limit 1, Grenzbereich erreicht) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
4.2 V | 0x02hex, (Limit 1, Grenzbereich überschritten) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
8.5 V | 0x02hex, (Limit 1, Grenzbereich überschritten) | 0x02hex, (Limit 2, Grenzbereich überschritten)


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx- und EPPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Firmware Update EL/ES/EM/EPxxxx

Inbetriebnahme/Konfiguration [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein
Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Scan Boxes
Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes.
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. Änderungsdialog. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einer Beckhoff EtherCAT Box ist eine Batch-Nummer (D-Nummer) aufgelasert. Der Aufbau der D-Nummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. Beckhoff EL5xxx.xml) enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z. B. durch den Beckhoff Support vorliegen.
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei
▪
Nach Beendigung des Download in INIT schalten, dann in OP
▪
Slave kurz stromlos schalten
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.
Dialog Weitere Einstellungen wählen
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,
Dialog Schreibe FPGA wählen
Datei auswählen
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!
Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.