EP3632 - EtherCAT Box mit Interface für Condition Monitoring
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.1.0
▪
Update Technische Daten
▪
Korrekturen in Kapitel CoE-Objektbeschreibung
1.0.0
▪
Ergänzungen
▪
1. Veröffentlichung
0.3
▪
Update Kapitel Montage und Verkabelung
▪
Update Kapitel Inbetriebnahme / Konfiguration
0.2
▪
Update Kapitel "Grundlagen zur Funktion"
0.1
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
EP3632-0001 - Einführung
•
Technische Daten
•
Grundlagen zur Funktion


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP3632-0001 - Einführung

Produktübersicht [image] EP3632-0001 - Einführung
EP3632-0001 - Einführung
EP3632-0001
Die EtherCAT Box EP3632 ist ein zweikanaliges Oversampling-Interface für bis zu zwei IEPE-Sensoren mit Zweileiteranschluss. Der Strom der integrierten Konstantstromquelle ist in Abhängigkeit von Sensor und Leitungslänge für jeden Kanal getrennt auf 2 mA, 4 mA oder 8 mA einstellbar.
Das Eingangssignal wird nach dem Oversampling-Prinzip mit bis zu 50 kSamples Abtastung pro Kanal und Sekunde abgetastet. Durch Distributed-Clocks können die Messwerte in Bezug zu anderen Anlagenteilen gesetzt werden. Bis auf die Filterung findet in der EP3632 keine Vorverarbeitung der Schwingungsamplitudenwerte statt, dies obliegt allein der abrufenden Steuerung. Durch einstellbare Filter und Versorgungsströme lässt sich das Interface auf die applikationsspezifischen Anforderungen anpassen.
Zur Auswertung der Signale in der Steuerung bietet die Condition-Monitoring-Bibliothek des TwinCAT 3 umfangreiche Algorithmen, so dass sich die Performance- und Flexibilitätsvorteile der PC-Plattform voll ausnutzen lassen.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EP3632-0001
Technik | Condition Monitoring / IEPE
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Eingänge | 2
Anschluss Eingänge | 2 x M8-Buchsen
Signalspannung | IEPE-Konstantstromspeisung und Erfassung der modulierten Wechselspannung
Sensorzustandsüberwachung | ja, durch Überwachung der Biasspannung
Messbereich | voreingestellt ±5 V bis 25 kHz, ±250 mV bis 10 Hz
Grenzfrequenz der Eingangsfilter | Analoger parametrierbarer Tiefpassfilter 5. Ordnung bis 25 kHz, typ. 0,05 Hz Hochpass
Messfehler | <± 0,5 % (DC; bezogen auf den Messbereichsendwert)
Auflösung | 16 Bit (inkl. Vorzeichen)
Nennspannung | 24 VDC (-15 %/+20 %)
Wandlungszeit | 20 μs (max. 50 kSamples/s)
Versorgungsstrom IEXCITE | typ. 2/4/8 mA (für beide Kanäle separat einstellbar)
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme | typ. 120 mA
Sensorversorgung | aus der Steuerspannung US
Anschluss der Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Distributed-Clocks | ja
Besondere Eigenschaften | automatische Antialiasingfunktion, Leitungsbrucherkennung
Potenzialtrennung | Steuerspannung / Feldbus: ja
Gewicht | Ca. 165 g
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Weiterführende Informationen
•
Schwingungsanalyse
•
Einsatz von Condition-Monitoring
•
Ausgangssignale von IEPE-Sensoren
•
Grundlagen der IEPE-Technologie


Schwingungsanalyse

Produktübersicht [image] Grundlagen zur Funktion [image] Schwingungsanalyse
Schwingungsanalyse
Unter Schwingungsanalyse versteht man die Gewinnung von Informationen aus vorhandenen (mechanischen) Schwingungen z. B. an Maschinen oder bei bestimmten Produktionsprozessen. Dies kann sowohl im Bereich Condition-Monitoring - also Maschinenzustandsüberwachung - geschehen, z. B. bei Antrieben, Stanz- und Presswerkzeugen, bei Fertigungsprozessen wie z. B. Wuchten von rotierenden Teilen, oder aber bei sonstigen Bewegungen wie Torsion von Türmen/Windkraftanlagen.
Zur Verdeutlichung sind in der unteren Tabelle typische Beschleunigungswerte aus Natur und Technik aufgelistet.
Typische Werte für Beschleunigungen
Maschine oder Ereignis | Typischer g-Wert
Verkehrsflugzeug (Anfahrt) | ≈ 0,5
Formel-1-Wagen (Anfahrt) | ≈ 1 – 1,5
Verkehrsflugzeug (Kurvenflug max.) | ≈ 2,5
Fadenpendel bei 90° Amplitude | ≈ 2
Space Shuttle beim Flug in den Erdorbit | max. 3 (exakt)
Space Shuttle beim Wiedereintritt in die Erdatmosphäre | max. 1,6
Achterbahn typisch (max.) | 4 (6)
Formel-1-Wagen (Kurvenfahrt max.) | ≈ 4 – 5
Kreisförmiger Looping (Basis) | ≥ 6
Kampfflugzeug/Kunstflieger (max.) | ≈ 10 (13,8)
Schleudersitz | 15 – 20
PKW-Rückenlehne bricht bei | ≈ 20
Frontalzusammenstoß PKW | bis ≈ 50
PKW-Crash Fahrgastzelle | Spitze 120
von einem Menschen überlebt | ≈ 180
harter Körperschlag mit der Faust | bis ≈ 100
Regentropfen in das Auge | bis ≈ 150
Kugelschreiber fällt aus 1 m Höhe auf harten Boden | Größenordnung 1000
Festplatte fällt aus 1 m Höhe auf harten Boden (ohne Deformation des Bodens) | 10.000 und größer
Laborzentrifuge | ≈ 10.000
Ultrazentrifuge | ≈ 100.000
Gewehrkugel beim Abschuss | ≈ 100.000
Stachel beim Ausstoß aus einer Nesselzelle | 5.410.000
Atombombenexplosion (Bombenhülle) | bis ≈ 1011
Oberfläche eines Neutronensterns | ≈ 2·1011


Einsatz von Condition-Monitoring

Produktübersicht [image] Grundlagen zur Funktion [image] Einsatz von Condition-Monitoring
Einsatz von Condition-Monitoring
In Bezug auf Condition-Monitoring kann durch Messung von Schwingungen an Maschinen/Antrieben/Getrieben und anschließender Analyse mit geeigneten mathematischen Hilfsmitteln (z. B. TwinCAT-Bibliothek, FFT, kundeneigene Benutzerprogramme) auf den Zustand von rotierenden/beweglichen Teilen geschlossen werden.
Es wird kontinuierlich oder auch in zeitlich größeren, regelmäßigen Abständen die vorhandene Schwingung aufgenommen und letztendlich mit einem Sollwert/Anfangswert verglichen (Abb. Beispiel eines Kugellagerschadens und anschließender Analyse).
So können beginnende Schäden frühzeitig entdeckt werden. Anstatt turnusmäßig verschiedene Bauteile vorbeugend zu tauschen, oder aber auf plötzliche Schäden und darauf folgende teure Maschinenstillstandszeiten und evtl. Folgeschäden zu warten, werden nun bevorstehende Reparaturen und Stillstandszeiten planbar. Unnötige Ausfälle, Folgeschäden, oder vorzeitiges und kostspieliges Tauschen noch intakter Teile werden vermieden.
Beispiel eines Kugellagerschadens und anschließender Analyse
Im oberen Beispiel erlaubt die so genannte Einhüllende die Analyse von Stoßimpulsen, die auf Unebenheiten in dem Wälzlager zurückgehen. Durch die Periodizität kann das schadhafte Element identifiziert werden (Einhüllenden Spektrum).


Ausgangssignale von IEPE-Sensoren

Produktübersicht [image] Grundlagen zur Funktion [image] Ausgangssignale von IEPE-Sensoren
Ausgangssignale von IEPE-Sensoren
Schwingungen können z. B. mit IEPE (Integrated Electronics Piezo Electric)-Sensoren aufgenommen werden. Der Vorteil dieser Technologie ist ein integrierter Verstärker als Impedanzwandler, so dass für das niederimpedante Ausgangssignal nur ein einfacher Zweidrahtanschluss (Koax) benötig wird. IEPE-Sensoren werden typischer Weise mit 2…20 mA Konstantstrom versorgt. Sie erzeugen im Ruhezustand eine konstante DC-Bias-Spannung (Nullspannung/Ubias) von typ. 7…14 V. Je nach Beschleunigung des Sensors wird auf dessen Ubias eine proportional zur Bewegung erzeugte analoge AC-Spannung aufaddiert, z. B. liefert eine Auslenkung mit der Amplitude 1 g (= 9,81 m/s2) mit 50 Hz Sinus bei einem Sensor mit der Empfindlichkeit 50 mV/g eine Ausgangsspannung von AC +/-50 mV mit 50 Hz Sinus + Ubias (Abb. Ausgangssignal eines IEPE-Sensors (Beispiel)). Das maximale Ausgangssignal eines Sensors beträgt üblicher Weise AC +/-5 V (+ Ubias).
Mit steigender Kabellänge steigt die Kabelkapazität (typ. 100 pF/m), wodurch mit steigender Signalfrequenz die Aussteuerfähigkeit des integrierten Verstärkers sinkt. Durch erhöhen des Versorgungsstromes kann dies teilweise kompensiert werden (Abb. Aussteuerbarkeit des IEPE-Impedanzwandlers in Abhängigkeit von Kabelkapazität und Speisestrom).
Aussteuerbarkeit des IEPE-Impedanzwandlers in Abhängigkeit von Kabelkapazität und Speisestrom
Die grundlegenden Eigenschaften von IEPE-Beschleunigungssensoren werden durch verschiedene Angaben gekennzeichnet wie Empfindlichkeit (z. B. 50 mV/g), Messbereich (z. B. +/-100 g), +/-3 dB Frequenzbereich (unter 1 Hz bis mehreren kHz), Stromaufnahme (2…20 mA), Biasspannung etc. Im Abb. Frequenzgang eines Beschleunigungssensors ist der beispielhafte Frequenzgang dargestellt (Amplitude des Ausgangssignals bezogen auf die Frequenz).
Ausgangssignal eines IEPE-Sensors (Beispiel)
Frequenzgang eines Beschleunigungssensors
Weitere herstellergeschützte Bezeichnungen für dieses elektrische Verfahren sind z. B. DeltaTron®, Isotron™, ICP™, Piezotron™ oder CCLD.
Hinweis: Im Kern bestehen IEPE-Sensoren meist aus Quarzkristallen, die durch die Bewegung kleinste Ladungsverschiebungen erfahren. Um diese zu messen bzw. über mehrere Meter Entfernung zu transportieren sind aufwendige Kabelinstallationen und Messgeräte zur Ladungsverstärkung nötig. Für den preiswerten und robusten Einsatz im industriellen Umfeld wird deshalb ein einfacher Ladungsverstärker als Impedanzwandler bereits in den Sensor integriert. Dadurch ist er in der Lage das o.g. Spannungssignal zu erzeugen und die Schwingungsinformation auch über größere Entfernung (einige 10 m) zu transportieren.


Grundlagen der IEPE-Technologie

Produktübersicht [image] Grundlagen zur Funktion [image] Grundlagen der IEPE-Technologie
Grundlagen der IEPE-Technologie
IEPE („Integrated Electronics Piezo Electric”) ist der genormte Name für eine elektrische analoge Schnittstelle zwischen piezoelektrischen Sensoren und der Auswertelektronik. Von verschiedenen Herstellern wurden dafür eigene Markennamen geprägt: ICP®, CCLD®, IsoTron®, DeltaTron®, Piezotron®…
Anwendung
Piezoelektrische Sensoren basieren meist auf einem Quarz, in dem unter mechanischer Belastung eine elektrische Ladung verschoben wird, die bei entsprechend hochimpedanter Messung von außen als Spannung erkennbar wird. Es handelt sich hierbei um einen bevorzugt statischen Vorgang << 10 Sekunden, da sonst die Ladungsdifferenz über äußere oder innere Ableitung abgebaut wird. Ein solcher Sensor ist daher eher weniger für statische Langzeitbelastungen wie z.B. Wiegen eines Silos geeignet. Als Anwendungsfall solcher Sensoren findet sich deshalb Schwingungsmessung aller Art (Unwuchterkennung, Schallsignale über Mikrophone bis Ultraschall, mechanische Vibrationen, Fundamentbeobachtung etc.).
Es haben sich über die Jahrzehnte 2 elektrische Ausprägungen entwickelt:
▪
Direkter Ladungsausgang
▪
IEPE-Ausgang
Ladungsausgang
Wird die Spannungsinformation direkt über ein (kurzes) 2-poliges Kabel abgegriffen, muss die Messelektronik ein sog. Ladungsverstärker sein.
Vorteil: der Sensor kann hohen Temperaturen >150°C ausgesetzt werden, keine Stromversorgung nötig
Nachteil: sehr empfindlich gegen äußere Einflüsse auf das Kabel, aufwendige Empfangselektronik und Leitung da hohe Quell-Impedanz
IEPE-Ausgang
Da die Ladungsschnittstelle im industriellen Einsatz wenig Akzeptanz findet, wurde schon früh nach einer robusteren Übertragung gesucht. Dazu wird bei IEPE ein FET-Bauteil direkt mit in den Sensor integriert.
Wird dieser mit Konstantstrom 2...8 mA (DC) auf dem 2-poligen Kabel als „Versorgung“ gespeist, stellt sich eine Bias-Spannung von ca. 8....15 V ein. Wird der Sensor nun durch eine Beschleunigungskraft belastet, ändert der FET seinen Innenwiderstand durch der an seinem Gate entsprechenden anstehenden Spannung. Da die äußere Konstantstromquelle versucht ihren Strom aufrecht zu halten, ändert sich demzufolge die Bias-Spannung entsprechend der mechanischen Belastung im Bereich einiger Volt. Das Auswertegerät hat nun zwar den DC-Strom zu speisen, kann dafür jedoch über größere Entfernungen aus der rückgemessenen Spannung auf die Schwingbeschleunigung schließen.
Vorteil: robustes System das auch unter Industriebedingungen installiert werden kann
Nachteil: Temperaturobergrenze für den Sensor 150..200 °C, kleinerer Dynamikumfang
Hinweise zum Konstantstrom
▪
Je größer der Speisestrom, desto mehr erwärmt sich der Schwingungssensor. Dies kann nachteilig sein. Angaben des Sensorherstellers beachten.
▪
Je größer der Speisestrom, desto höher liegt die maximal übertragbare Signalfrequenz da Ladungs-zu/ ab -flüsse auf dem Kabel schneller nachgeführt werden können.
▪
Je größer der Speisestrom, umso höher die sich einstellende Bias-Spannung. Dies kann dazu führen dass die Übertragung robuster wird gegen elektromagnetische Einwirkung, aber auch das große positive Amplituden in die obere Sättigung gehen.
Hinweise zum IEPE- Messgerät
▪
Manche IEPE-Messgeräte können den Speisestrom auch abschalten (0 mA) und somit auch zur Spannungsmessung verwendet werden. Vgl. z.B. Beckhoff ELM3604.
▪
Da im Schwingungsbereich i.d.R. nur AC-Signale interessieren, verfügen IEPE-Auswertungen eingangsseitig über einen elektrischen Hochpass > 10 Hz. Je nach Anwendung z.B. langsame Turmschwingungen kann die Grenze dieses Hochpass relevant sein. Vgl. z.B. dazu den einstellbaren und abschaltbaren Hochpass der ELM3604.
▪
Die Bias-Spannung kann gut zur Detektion von Drahtbruchfall/Kurzschluss verwendet werden. Siehe dazu z.B. die Diagnosemöglichkeiten der ELM3604.


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
Anschluss


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Anzugsmomente für Steckverbinder


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Anzugsmomente für Steckverbinder

Montage und Verkabelung [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


Anschluss

Montage und Verkabelung [image] Anschluss
Anschluss
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Leitungsverluste M8
•
Signalanschluss, LEDs


EtherCAT-Anschluss

Montage und Verkabelung [image] Anschluss [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Montage und Verkabelung [image] Anschluss [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (https://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Power-Anschluss

Montage und Verkabelung [image] Anschluss [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z. B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z. B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u. U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Verkabelung [image] Anschluss [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Leitungsverluste M8

Montage und Verkabelung [image] Anschluss [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Signalanschluss, LEDs

Montage und Verkabelung [image] Anschluss [image] Signalanschluss, LEDs
Signalanschluss, LEDs
Signalanschluss IEPE-Sensoren
Die Eingänge X01 und X02 ermöglichen den Anschluss von bis zu zwei IEPE-Sensoren im 2-Leiteranschluss.
EP3632 - Signalanschluss für die Eingänge X01 und X02, M8, 4-polig
Bedeutung der LEDs
EP3632 - LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme/Box wieder:
 |  | aus | Zustand der EtherCAT State Machine: INT = Initialisierung der Klemme/Box
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion der Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme/Box
ERR | rot | EIN | Drahtbruchfehler


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
Oversampling Klemmen/Boxen und TwinCAT Scope
•
Inbetriebnahme
•
Hinweise zu analogen Spezifikationen
•
Anwendungsbeispiel
•
Fehlerbeschreibung und Abhilfe
•
Wiederherstellen des Auslieferungszustandes
•
Firmware Update EL/ES/EM/EPxxxx


Einfügen in das EtherCAT-Netzwerk

Inbetriebnahme/Konfiguration [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Oversampling Klemmen/Boxen und TwinCAT Scope

Inbetriebnahme/Konfiguration [image] Oversampling Klemmen/Boxen und TwinCAT Scope
Oversampling Klemmen/Boxen und TwinCAT Scope
Grundsätzlich können Eingangsdaten einer Klemme/Box entweder direkt (über den aktivierten ADS-Server) oder über die Bildung einer PLC Variablen, auf die das PDO der Klemme/Box verweist mit dem Scope für deren Aufzeichnung erreicht werden. Beide Vorgehensweisen werden im Folgenden jeweils zunächst für TwinCAT 3 (kurz: TC3) und dann für TwinCAT 2 (TC2) erklärt.
Oversampling bedeutet, dass ein analoges oder digitales Eingangsgerät je
Prozessdatenzyklus/EtherCAT-Zyklkus (Dauer T) nicht nur einen Messwert liefert, sondern mehrere, die in konstantem Abstand t < T ermittelt werden. Das Verhältnis T/t ist der Oversamplingfaktor n. In den Prozessdaten bietet so ein Kanal also nicht nur einen PDO zum Verlinken an wie hier im Beispiel die EL3102, sondern n davon wie die EL3702 und andere Oversampling-Klemmen/Boxen.
Der Begriff „Oversampling“ aus der Sicht von Beckhoff ist hierbei nicht zu verwechseln mit dem oversampling – Verfahren eines deltaSigma-ADC-Wandlers:
▪
deltaSigma-ADC: die Frequenz mit der der ADC das analoge Signal abtastet ist um ein Vielfaches schneller (üblicherweise MHz-Bereich) als die Frequenz der bereitgestellten digitalen Samples (üblicherweise kHz-Bereich) – dies wird Oversampling genannt, resultiert aus dem Funktionsprinzip diese Wandlertyps und dient u.a. dem AntiAliasing.
▪
Beckhoff: das Gerät/die Klemme/Box liest aus dem verwendeten ADC (der auch ein deltaSigma-ADC sein kann) digitale Samples n-mal öfter aus als die Zykluszeit beträgt und überträgt jedes Sample in die Steuerung – gebündelt als Oversampling-PDO-Block.
Beispielsweise sind diese beiden Methoden in der EL3751 in ihrer technischen Umsetzung nacheinander angeordnet und können somit gleichsam vorhanden sein.
Oversampling-PDO der Serie EL37xx und im Vergleich mit EL31xx
Das Scope2 (TC2) bzw. ScopeView (TC3) kann entsprechend mehrere PDO je Zyklus einlesen und zeitrichtig darstellen.
Weiterführende Informationen
•
Vorgehen bei TwinCAT 3
•
Vorgehen bei TwinCAT 2


Vorgehen bei TwinCAT 3

Inbetriebnahme/Konfiguration [image] Oversampling Klemmen/Boxen und TwinCAT Scope [image] Vorgehen bei TwinCAT 3
Vorgehen bei TwinCAT 3
Ab TwinCAT 3.1 build 4012 und unter Verwendung der unten angegebenen Revision erkennt das integrierte ScopeView in seinem VariablenBrowser, dass die Oversampling-Daten ein Array-Paket sind und aktiviert ForceOversampling selbsttätig. Die Feldvariable ist per „Add Symbol“ als Array als Gesamtes auszuwählen (siehe Erläuterung im nächsten Abschnitt). Der erweiterte PDO-Name liefert dafür die Grundlage. Ab einer bestimmten Revision der jeweiligen Klemme/Box kann also ScopeView den Array-Typ einer Gruppe von Variablen von sich aus erkennen.
Klemme | Revision
EL4732 | alle
EL4712 | alle
EL3783 | EL3783-0000-0017
EL3773 | EL3773-0000-0019
EL3751 | alle
EL3742 | alle
EL3702 | alle
EL3632 | alle
EL2262 | alle
EL1262-0050 | alle
EL1262 | alle
EP3632-0001 | alle
EPP3632-0001 | alle
Aufzeichnung einer PLC Variablen mit dem TwinCAT 3 – ScopeView
Unter Voraussetzung eines bereits erstellten TwinCAT 3 – Projekts und einer angeschlossenen PLC mit einer oversampling-fähigen Klemme/Box in der Konfiguration wird im Folgenden gezeigt, wie eine oversampling Variable im Scope (als Standard Bestandteil der TwinCAT 3 Umgebung) dargestellt werden kann. Dies wird Ausgehend von einem Beispielprojekt „SCOPE_with_Oversampling“, einem Standard PLC Projekt in einigen Schritten erklärt.
Schritt 1: Hinzufügen eines Projektes „Scope YT“
Dem Beispielprojekt „SCOPE_with_Oversampling“ wird durch Rechtsklick (A) und der Auswahl (B) „Add“ → „New Project..“ ein TwinCAT Measurement – Projekt „Scope YT Projekt“ (C) hinzugefügt. Als Name wird „Scope for OS“ eingetragen. Das neue Projekt erscheint sogleich im Solution Explorer (D).
Hinzufügen eines Scope Projekts zu einem bereits vorhandenen Projekt
Schritt 2a: Erzeugen einer PLC Variablen in einer POU
In der TwinCAT 3 Entwicklungsumgebung wird zunächst einer POU des Projekts eine Eingangsvariable als Feld mit entsprechender Größe des vorgegebenen Oversamplingfaktors in einer POU definiert wie im Folgenden im Beispiel mit strukturierten Text (ST) für die POU „MAIN“ für den Oversamplingfaktor 10 gezeigt ist:
PROGRAM MAIN
VAR
aU1_Samples AT%I* : ARRAY[0..9] OF INT;
END_VAR
Die Kennzeichnung “AT%I*” steht für die spätere Auslagerung dieser Feldvariable um sie mit den Prozessdatenobjekten (PDOs) einer Klemme/Box zu Verknüpfen. Anzumerken ist, dass die Feldvariable lediglich die gleiche Anzahl von Elementen wie der Oversampling Faktor haben muss; daher können die Indizes auch von 0 bis 9 gesetzt werden. Sobald der Kompiliervorgang gestartet und erfolgreich abgeschlossen wurde (wobei zunächst nicht unbedingt Programmcode vorhanden sein muss), erscheint diese Feldvariable im Solution Explorer der TwinCAT 3 Entwicklungsumgebung in der Gruppe PLC unter „..Instance“.
In der folgenden Darstellung sind rechts Ausschnitte des Solution Explorers gezeigt. Beispielsweise wird hierbei das Verknüpfen einer Feldvariablen mit einem Satz an oversampling Prozessdaten einer EL3773 gezeigt:
Darstellung der erstellten PLC Feldvariablen („aUI_Samples“) zur Verknüpfung mit oversampling PDOs einer EL3773
Schritt 2b: Erzeugen einer PLC Variablen über eine freie Task
Wird eine POU auf dem jeweiligen System nicht benötigt, so kann eine Variablenreferenz auch über eine freie Task angelegt werden. Falls eine freie Task noch nicht vorhanden ist, ist sie über rechts-Klick auf „Tasks“ über das Projekt im SYSTEM per „Add New Item…“ zu erstellen:
Einfügen einer "freien" Task
Die Task ist als „TwinCAT Task With Image“ einzufügen und erzeugt dadurch auch einen „Inputs“ und „Outputs“ Ordner. Die Eigenschaften der neuen (oder ggf. Vorhandenen Task) muss die Einstellung „Create symbols“ aktiviert haben, damit der „Target Browser“ des Scope diese später auswählbar macht. Die Taskzykluszeit ist ggf. ebenfalls einzustellen. In diesem Fall wird beispielsweise bei 10 x Oversampling mit der EL3751 1 ms bei 100 µs Basiszeit, also 10 Ticks gewählt:
Task Eigenschaft "Create symbols" ist zu aktivieren
Für die Portangabe liegt eine Voreinstellung vor (hier: 301) und kann falls nötig geändert werden. Diese Zahl muss später ggf. dem Scope bekannt gemacht werden. Durch einen rechts-Klick auf „Inputs“ kann nun die dem Oversampling zugrunde liegende Variable mit dem passenden Datentyp als Array hinzugefügt werden; in diesem Fall „ARRAY [0..9] OF DINT“ mit der Bezeichnung „Var 1“:
Einfügen der zum Oversampling passenden Variablen „Var 1“
Schritt 3: Verknüpfen der Feldvariablen mit einem oversampling PDO
Durch Rechtsklick auf „MAIN.aUI_Samples“ (für den vorhergehenden Schritt 2a) bzw. „Var 1“ der freien Task 1(für den vorhergehenden Schritt 2b) im Solution Explorer wird ein Fenster zur Auswahl der Prozessdaten geöffnet:
Setzen der Verknüpfung der PLC Feldvariablen (links: vorhergehender Schritt 2a; rechts: : vorhergehender Schritt 2b)
Auswahl des EL3773 PDO "L1 Voltage Samples" zum Erstellen eines Links mit der PLC Feldvariablen „aUI_Samples“
Die Auswahl des PDO "U1 Samples" der EL3773 für “MAIN.aUI_Samples”, wie oben gezeigt, basiert auf für den vorhergehenden Schritt 2a und ist ggf. für "Var 1" in gleicher Weise vorzunehmen.
Schritt 4: Auswahl der PLC Feldvariablen für die Y-Achse des Scope
Nun wird die Konfiguration aktiviert ( [image])und auf die PLC eingeloggt ( [image]), damit für den „target browser“ des Scope die Feldvariable zur Auswahl erscheinen kann.
Dazu wird mit einem Rechtsklick auf „Axis“ (A) das drop-down Menü für die Auswahl der Scope Funktionen geöffnet (B):
Auswahl der oversampling - Variablen mit dem "target browser"
Mit dem Anwählen des jeweiligen Systems, der die PLC mit der Feldvariablen aus der POU „MAIN“ entspricht (in diesem Fall „Any PC (CX2040)“) wird bis zu der „aUI_Samples“ Variablen navigiert (C):
Hinzufügen der "aUI_Samples" Feldvariablen zu "Axis" des Scope
Variable erscheint nicht im Target Browser
Falls „ROUTES“ keine Auswahlmöglichkeit der bereitgestellten Variablen bietet, sollte der entsprechende Port dem Target Browser bekannt gemacht werden:
Mit „Add Symbol“ wird sogleich die „aUI_Samples“ Feldvariable unterhalb von „Axis“ des Scope-Projekts im Solution Explorer angezeigt.
Nun ist – obwohl bislang kein Programm vorliegt – mit [image] der Programmstart formal vorzunehmen. Mit „Start Recording“ [image] kann nun der Prozessdatenwert des Oversampling-PDO „L1 Voltage Samples“ über die verlinkte PLC Feldvariable zeitlich aufgezeichnet werden.
Als Beispiel wird eine Sinusförmige Eingangsmessgröße (204,5 Hz) im Folgenden dargestellt:
Beispiel einer Messung eines Sinussignals mit 10 Fach Oversampling bei 1 ms Messzykluszeit
Mittels „Panning X“ [image] ist nach Beendigung der Aufzeichnung [image] die X-Achse passend sakaliert. Nachfolgend die „Chart“-Eigenschaft „Use X-Axis SubGrid“ auf „True“ mit 10 Teilungen sowie innerhalb der „.ChannelNodeProperties“ die Eigenschaft „Marks“ auf „On“ mit den Farben „Line Color“ Blau und „Mark Color“ Rot eingestellt worden. Letzteres zeigt somit die 10 oversampling-Messpunkte durch die roten Markierungen.
Vorgehen bei TwinCAT 3 / alternativ per ADS
Bei früheren TwinCAT 3 Versionen (oder einer kleineren Revision der Klemme als wie in obiger Tabelle angegeben) kann per Aktivierung des ADS Servers das Oversampling-PDO der betreffenden oversampling fähigen Klemme/Box für das ScopeView sichtbar gemacht werden.
Aktivierung des ADS Servers des EtherCAT Device (TwinCAT 3)
Die Aktivierung des Servers erfolgt durch Auswahl von „Image“ im linksseitigen Solution Explorer:
„I/O → Devices → Device .. (EtherCAT) → Image“.
Hier wird dann der Karteireiter „ADS“ ausgewählt und jeweils die Checkbox „Enable ADS Server“ und dann „Create symbols“ aktiviert (der Port – Eintrag erfolgt automatisch).
Dadurch kann ohne eine eingebundene POU bzw. ohne einen Variablenverweis mit dem ScopeView per Target Browser auf Prozessdaten zugegriffen werden:
Direkter Zugriff des ScopeView auf PDOs der Klemme
Datentyp nicht korrekt
Es kann vorkommen, dass es dem „Target Browser“ nach dem Einfügen des oversampling PDO (entspricht i.d.R. einer Feldvariable) nicht gelingt den Datentyp zu ermitteln. In diesem Fall kann dieser nachträglich in den Kanaleigenschaften geändert werden:
TwinCAT 3: ADS Server des EtherCAT Gerätes aktivieren
Siehe hierzu im Beckhoff Information System:
infosys.beckhoff.com → TwinCAT 3 → TExxxx | TC3 Engineering → TE13xx | TC3 ScopeView → Anhang → How To’s → Oversampling-Aufnahmen mit dem TwinCAT 3 Scope


Vorgehen bei TwinCAT 2

Inbetriebnahme/Konfiguration [image] Oversampling Klemmen/Boxen und TwinCAT Scope [image] Vorgehen bei TwinCAT 2
Vorgehen bei TwinCAT 2
TwinCAT Scope2 unterstützt das Einlesen und die Anzeige von Oversampling-Prozessdaten wie sie von oversampling-fähigen Klemmen/Box zur Verfügung stehen.
Vorraussetzungen
Es muss ein TwinCAT Scope2 auf dem System installiert sein.
Es muss eine oversampling-fähige Klemme/Box in der Konfiguration vorhanden sein.
Das TwinCAT Scope2 bekommt über die ADS-Daten auch den Datentyp der Variablen übermittelt. Deshalb ist die ARRAY-Variable anzulegen
▪
in der PLC, siehe Schritt 1a
▪
oder direkt im System Manager wenn nur eine freie Task vorliegt, siehe Schritt 1b
Im Scope2 sind für beide Fälle dieselben Einstellungen vorzunehmen, siehe Schritt 2
Aufzeichnung einer PLC Variablen mit dem TwinCAT 2 – Scope2
Schritt 1a: Erzeugen einer PLC Variable über eine POU
Da die Kanaldaten in der PLC verwendet werden sollen, ist dort eine verlinkbare ARRAY-Variable anzulegen, wie in folgendem Beispiel gezeigt:
PLC Deklaration
Im System Manager erscheint diese dann in der Liste, in der Regel ist sie dann auch ohne weitere Maßnahmen über ADS erreichbar da PLC-Variablen immer als ADS-Symbol im Hintergrund angelegt werden.
PLC im System Manager
Hinweis: das Scope2 kann solche Variablen im Variablen Browser nur "sehen", wenn sich TwinCAT und die PLC im RUN befinden.
Schritt 1b: Erzeugen einer PLC Variable über eine freie Task
Die für das Scope2 notwendige Array-Variable kann alternativ auch manuell im System Manager definiert und angelegt werden.
Add Variable Type
Wie bisher im Programm (POU „Main“) ist auch hier eine ARRAY-Variable vom gleichen Typ wie die oversampling PDO der jeweiligen Klemme/Box anzulegen. In diesem Beispiel nun ein Array 0..9 vom Typ INT, also mit 10 Feldern.
Definieren des Variablen Typs
Wenn diese Variable dem System Manager bekannt ist, kann eine Instanz davon einer zusätzlichen Task mit Rechtsklick zugeordnet werden. Sie erscheint in der nach Bitgröße sortierten Übersicht.
Übersicht deklarierte Typen
In diesem Beispiel wird die Variable Var152 angelegt. Sie kann nun mit dem PDO-Array vom jeweiligen Kanal der Klemme/Box verlinkt werden.
Verlinken
Wenn im Dialog MatchingSize aktiviert ist, bieten sich direkt die einzelnen Kanäle an.
Array-Variablen einer Oversampling-Klemme
Damit die Variablen auch über ADS im Scope2 zu finden sind, sind die ADS-Symbole zu aktivieren, so wie das Enable Auto-Start, sonst läuft die Task nicht selbsttätig. Dann werden ADS-Symboltabellen von allen Variablen angelegt, die diese Task in ihren Prozessdatenimages hat.
Einstellungen in der zusätzlichen Task
Schritt 2: Konfiguration im Scope2
Damit die Verlinkung funktioniert, muss im System Manager je eine Array-Variable mit den Kanaldaten der jeweiligen Klemme/Box vorliegen, d. h. jedes Oversampling-Datenpaket muss in einem Array vorliegen. Diese Array-Variable ist manuell zu definieren und anzulegen, siehe oben.
Im Scope2 kann nun bis zur betreffenden Variable gebrowst werden.
Variablenbrowser bis zum Array VAR152
Es ist dann nicht das Array zu öffnen, sondern direkt das Array-Symbol per Rechtsklick AddSymbol auszuwählen.
AddSymbol auf dem Array
Im Einstellungsdialog des nun erzeugten Kanals ist ForceOversampling und DataType INT16 einzustellen. Ggf. ist dazu vorübergehend SymbolBased zu deaktivieren.
Channel-Einstellungen
Zur Überprüfung, dass wirklich die einzelnen Oversampling-Werte geloggt werden, können im Scope2 die Marks aktiviert werden. Bitte beachten Sie die Zusammenhänge aus Task-Zykluszeit, Sampling-Zeit des Scope2-Kanals und Oversamplingfaktor.
Aktivieren der Marks
Ein weiteres Beispiel zeigt die folgende Abbildung der Darstellung einer Oversampling – Variablen der EL3751 mit 10 x Oversampling:
Darstellung einer 10 x Oversampling-Variablen der EL3751 mit dem Scope2
In der Abbildung ist nachträglich eingezeichnet, das die von der PLC stammende Oversampling Variable mit „Add Symbol“ einfach als Y-Kanal der Achse eingefügt wurde (Auswahl des PLC-POU Namen „MAIN“ im „ROUTES“ - Baum beachten). Hierbei ist „Force Oversampling“ aktiviert, da es sich nicht um eine von der Klemme/Box bereit gestellte Oversampling-Variablen handelt.
Vorgehen bei TwinCAT 2 / alternativ per ADS
Bei früheren TwinCAT 2 Versionen (oder einer kleineren Revision der Klemme als wie in obiger Tabelle angegeben) kann per Aktivierung des ADS Servers das Oversampling-PDO der betreffenden oversampling fähigen Klemme/Box für das Scope2 sichtbar gemacht werden.
Es kann so ebenfalls auf die Erstellung einer Feldvariablen in einer PLC verzichtet werden. Dazu ist der ADS Server des EtherCAT Device zu aktivieren, an dem die oversampling fähige Klemme/Box angeschlossen ist.
Aktivierung des ADS Servers des EtherCAT Device (TwinCAT 2)
Die Aktivierung des Servers erfolgt durch Auswahl des „Device – Image“ im linksseitigen Konfigurationsbaum: „I/O – Configuration → I/O Devices → Device .. (EtherCAT) → Device .. – Image“.
Hier wird dann der Karteireiter „ADS“ ausgewählt und jeweils die Checkbox „Enable ADS Server“ und dann „Create symbols“ aktiviert (der Port Eintrag erfolgt automatisch).
Dadurch kann ohne eine eingebundene POU bzw. ohne einen Variablenverweis mit dem Scope2 per Target Browser auf Prozessdaten zugegriffen werden:
Direkter Zugriff des Scope2 auf PDOs der Klemme
Siehe hierzu im Beckhoff Information System
infosys.beckhoff.com → TwinCAT 2 → TwinCAT Supplement → Kategorie Measurement TS3xxx → TS3300 | TwinCAT Scope 2 → Anhang → Oversampling Aufnahme
Beckhoff TwinCAT unterstützt das Scope2 bei einigen Oversampling-Geräten in spezieller Weise, indem es automatisch im Hintergrund ein besonderes ADS-Array-Symbol berechnet, das im Scope2 im Variablenbrowser erscheint. Dieses kann dann als Variable verlinkt werden und bringt automatisch die Array-Information mit.
Automatisch berechnete Array-Variable (rot) im Scope2
Zusammenfassung: es muss eine ARRAY-Variable vorliegen die über ADS erreichbar ist. Dies kann eine PLC-Variable, eine im System Manager definierte ARRAY-Variable sein oder alternativ ist der ADS Server des Device der Klemme/Box aktiviert. Diese wird dann vom Scope2 erkannt.


Inbetriebnahme

Inbetriebnahme/Konfiguration [image] Inbetriebnahme
Inbetriebnahme
Ermitteln der gewünschten Abtastrate
Die erforderliche/gewünschte Abtastrate ergibt sich aus der gewählten Zykluszeit und dem eingestellten Oversampling-Faktor.
Das automatische Einstellen der Klemme/Box durch alleiniges Wählen der Abtastrate ist nicht möglich.
Maximalwerte: 50-fach Oversampling, 50 kSP/s, 10 ms Zykluszeit
Abtastraten in Abhängigkeit von Zykluszeit und Oversampling
Abtastzeiten in Abhängigkeit von Zykluszeiten und Oversampling
Konfigurationen, die Samplingzeiten verlangen die nicht durch 500 ns teilbar sind werden nicht unterstützt.
Einstellen der Abtastrate
1. Klemme/Box im TwinCAT-Baum auswählen
2. Reiter „DC /Oversampling“ wählen
3. Betriebsart (1 / 2 kanalig) wählen
4. „Sync Unit Cycle Time“ wird angezeigt, anhand der obigen Tabelle den...
5. Oversampling-Faktor wählen. Die "Sample Cycle Time (µs)" gibt den Kehrwert der Abtastrate an. Der SM aktiviert danach alle Prozessdateneinträge automatisch.
Abtastrate in TwinCAT einstellen
Laden der Konfigurationsdaten (ESI) aus der Klemme/Box
Das Verwenden der Online-Description führt dazu, dass der Dialog "DC/Oversampling" nicht im TwinCAT System Manager angezeigt wird.
Um den Dialog zu verwenden, muss vor dem Starten des TwinCAT System Manager die XML-Beschreibung in den vorgesehenen Ordner "TwinCAT/Io/EtherCAT kopiert werden.
Verwendung mit fremden Mastern
Die Oversampling-Funktion kann auch manuell aktiviert werden: In Abhängigkeit der gewünschten Abtastrate und Zykluszeit muss der Oversampling-Faktor festgelegt werden.
Für jeden gewünschten Kanal muss über das Status-Word sowie die entsprechende Anzahl Samples in das Objekt 0x1C13 eingetragen werden. Ggf. PDOs "Next Sync1 Time" und/oder "Sample Counter" aktivieren. Dazu ist vorher der Subindex 0 auf 0 und am Ende auf die Anzahl der eingetragenen Werte zu setzen.
Die Sync-Interrupts müssen folgendermaßen parametriert werden: Sync0: CycleTime/Oversampling Factor, Enable setzen; Sync1: Cycle Unit Cycle, Enable setzen.
Der Master muss Distributed Clocks unterstützen.
Auswahl der Prozessdaten
Bei TwinCAT nicht mehr erforderlich.
Filter
Jeder Kanal verfügt über einen parametrierbaren Filter 5. Ordnung mit Butterworth Charakteristik mit vor- und nachgeschaltetem automatisch parametrierten Anti-Aliasing Filtern. Die gesamte Filterstufe ist in Hardware aufgebaut, Softwarefilter (außer der aktiven Offset-Einstellung) sind nicht vorhanden. Bei eingestellter Grenzfrequenz 10 Hz (0) wird automatisch eine zusätzliche Verstärkung Faktor 20 aktiviert.
Aufbau Filter
Die analogen Eingangsfilter können über die CoE-Objekte 0x80n0:15 (Kanal1/2) eingestellt werden. Das Abschalten der Filter ist nicht möglich.
Die Berechnung des Mittelwertes ist einstellbar:
0: 10 Hz, Gain 20
1: 100 Hz
2: 500 Hz
3: 1000 Hz
4: 5000 Hz
5: 10000 Hz
6: 25000 Hz
7: 2000 Hz (ab Firmware 11)
Einstellen der Filter
Die Filter müssen für beide Kanäle separat konfiguriert werden!
Durch das Einstellen der Filter wird kurzzeitig die Wandlung neuer Daten unterbrochen.
Aktive Offset Einstellung
Die Funktion "Active offset adjustment" berechnet den Langzeit-Mittelwert der Werte. Anstelle der eingestellten "User-" und "Vendor calibration offset"-Einträge wird der berechnete Offset-Wert verwendet. Es ist notwendig, dass mindestens eine Funktion, "User-" oder Vendor calibration", aktiviert ist.
Die Berechnung des Mittelwertes ist einstellbar:
Level 1: b = 1/4096
Level 2: b = 1/8192
Level 3: b = 1/16384
Level 4: b = 1/32768
Level 5: b = 1/65536
Level 6: b = 1/131072 (128 k)
Level 7: b = 1/262144 (256 k)
Level 8: b = 1/524288 (512 k).
Kalibrierung
Die Eingangswerte können durch Hersteller- oder Anwenderwerte kalibriert werden:
Abb. 5: Datenfluss
Hersteller-Abgleich, Index 0x80n0:0B
Die Freigabe des Hersteller-Abgleichs erfolgt über den Index 0x80n0:0B. Die Parametrierung erfolgt über die Indizes
▪
0x80nF:01 Offset (Herstellerabgleich)
▪
0x80nF:02 Gain (Herstellerabgleich)
YH = (XADC - BK) * AK
Messwert nach Hersteller-Kalibrierung (entspricht XADC , wenn Index 0x80n0:0B inaktiv)
Anwender-Abgleich, Index 0x80n0:0A
Die Freigabe des Anwender-Abgleichs erfolgt über den Index 0x80n0:0A. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:17 Anwender Offset Abgleich
▪
0x80n0:18 Anwender Gain Abgleich
YA = (YH - BW) * AW
Messwert nach Anwender-Kalibrierung (entspricht YH , wenn Index 0x80n0:0A inaktiv)
Active offset adjustment
Ist die Funktion "Active offset adjustment" aktiv werden die Offset-Werte nicht verwendet, stattdessen wird ein dynamisch berechneter Offset subtrahiert.
Beispiel Interpretation
Beispiel: ein Sensor mit einer Empfindlichkeit S von 100 mV / g (10,2 mV/(m/s^2) ist an einer abgeglichenen EL3632/EP3632 (15 Bit Auflösung + Vorzeichen, +/- 5 V) angeschlossen. In den Prozessdaten ist eine Amplitude mit dem Wert 1507 gemessen.
a = YA * 5 V / ( 2^15 * S )
a = 1507 * 5 V / ( 2^15 * 0,1 V/g )
a = 2,3 g
a = 2,3 g * 9,81 (m/s^2) / g
a = 22,5 m/s^2
Umrechnung von Prozessdatenwert YA in Beschleunigung a.
YA = 2^15 / 5 V * S * a
YA = 2^15 / 5 V * 0,1 V/g * 2,3 g
YA = 1507
Umrechnung von Beschleunigung g in Prozessdatenwert YA.
Sensoranschluss
Der Versorgungsstrom für die Sensoren kann umgestellt werden. Bei 8 mA muss die senkrechte (Standard) Einbaulage der Klemme sichergestellt werden. Abhängig von Sensor und Leitungslänge sollte der kleinste mögliche Versorgungsstrom eingestellt werden.
Nach dem Einschalten der 24 V Versorgungsspannung bzw. dem Anklemmen des Sensors bildet sich durch die Eingangskapazität am Hochpass ein Leckstrom aus. Dieser Strom basiert auf den physikalischen Eigenschaften von Elektrolytkondensatoren und ist technisch nicht zu verhindern. Dieser Strom schwingt sich innerhalb weniger Minuten auf einen konstanten Wert ein und erzeugt bei der Messung einen konstanten Offset von typ. einigen mV innerhalb des spezifizierten Toleranzbereiches. Sollte dieser Offset bei der Analyse der Messung dennoch stören, so kann dieser permanent durch Aktivierung des „Active offset adjustment" (Objekt 0x80n0:21) automatisch herausgerechnet werden.
Eine geschirmte (einfach oder mehrfach) Sensorleitung ist vorgeschrieben. Der Schirm sollte direkt an den Schirmanschlüssen der Klemme angeschlossen werden.
Bei Leitungsbruch oder nicht angeschlossenem Sensor leuchtet die rote Error-LED und das Error-Bit wird gesetzt. Ist nur der 1. Kanal aktiviert, wird im SAFEOP und OP die rote LED des 2. Kanals deaktiviert.
Nicht verwendete Eingänge
Nicht verwendete Eingänge dürfen nicht kurzgeschlossen werden!
Messfehler
Messfehler < ±0,5% (DC; bezogen auf den Messbereichsendwert) unter Berücksichtigung der Butterworth-Charakteristik.
Weiterführende Informationen
•
CoE-Objektbeschreibung


CoE-Objektbeschreibung

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung
CoE-Objektbeschreibung
Weiterführende Informationen
•
Profilspezifische- und Parametrierungsobjekte
•
Standardobjekte und PDO-Mapping


Profilspezifische- und Parametrierungsobjekte

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Profilspezifische- und Parametrierungsobjekte
Profilspezifische- und Parametrierungsobjekte
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando-Objekt
•
Eingangsdaten
•
Informations-/Diagnostikdaten (gerätespezifisch)


Restore Objekt

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Profilspezifische- und Parametrierungsobjekte [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Profilspezifische- und Parametrierungsobjekte [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 AI Settings (für n= 0 Kanal 1; n = 1 Kanal 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | AI Settings | Maximaler Subindex | UINT8 | RO | 0x20 (32dez)
80n0:07 | Enable limit | Aktiviere Limit Auswertung (weicht von anderen EL Klemmen ab!) | BOOLEAN | RW | 0x0 (FALSE)
80n0:0A | Enable user calibration | Freigabe des Anwender-Abgleichs | BOOLEAN | RW | 0x0 (FALSE
80n0:0B | Enable vendor calibration | Freigabe des Hersteller-Abgleichs | BOOLEAN | RW | 0x1 (TRUE)
80n0:13 | Limit 1 | Oberer Grenzwert | INT16 | RW | 0x0000 (0dez)
80n0:14 | Limit 2 | Unterer Grenzwert | INT16 | RW | 0x0000 (0dez)
80n0:15 | Filter settings | Einstellungen der Filter 0: 10 Hz, Gain 20 1: 100 Hz 2: 500 Hz 3: 1000 Hz 4: 5000 Hz 5: 10000 Hz 6: 25000 Hz 7: 2000 Hz (ab Firmware 11) | ENUM | RW | 10000 Hz (5)
80n0:17 | User calibration offset | Offset der Anwender -Kalibrierung | INT16 | RW | 0
80n0:18 | User calibration gain | Gain Faktor der Anwender-Kalibrierung | INT16 | RW | 16384
80n0:20 | Supply current | Einstellung des Sensorstromes 0: 2 mA 1: 4 mA 2: 8 mA | ENUM | RW | 2 mA (0)
80n0:21 | Active offset adjustment | Automatische Offset Berechnung 0: Disabled 1: Level 1 2: Level 2 3: Level 3 4: Level 4 5: Level 5 6: Level 6 7: Level 7 8: Level 8 | ENUM | RW | Disabled (0)
Index 80n8 AI Advanced Settings (für n= 0 Kanal 1; n = 1 Kanal 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n8:0 | AI Advanced Settings | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
80n8:06 | Input Amplifier | erlaubte Werte: | BIT2 | RW | 0x00 (0dez)
 |  | 0: Preset (Einstellung über Objekt 0x80n0:15)
 |  | 1: ON (Einschalten des Analogverstärkers x20 unabhängig von Filtereinstellungen, Verstärkungsfaktor 20 nicht veränderbar)
 |  | 2: OFF (Ausschalten des Analogverstärkers unabhängig von Filtereinstellungen)
Index 8012 AI Device Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8012:0 | AI Device Settings | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
8012:11 | DC Timestamp Shift |  | UINT32 | RW | 0x00000000 (0dez)
Index 80nF AI Vendor data (für n= 0 Kanal 1; n = 1 Kanal 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
80nF:01 | Calibration offset (gain 1) | Offset (Herstellerabgleich), gain 1 | INT16 | RW | 0x0000 (0dez)
80nF:02 | Calibration gain (gain 1) | Gain(Herstellerabgleich), gain 1 | INT16 | RW | 0x0000 (0dez)
80nF:03 | Calibration offset (gain 20) | Offset (Herstellerabgleich), gain 20 | INT16 | RW | 0x0000 (0dez)
80nF:04 | Calibration gain (gain 20) | Gain(Herstellerabgleich), gain 20 | INT16 | RW | 0x0000 (0dez)


Kommando-Objekt

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Profilspezifische- und Parametrierungsobjekte [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | DCM Command | Kommandoschnittstelle | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x8000: Software reset, Hardware wird mit der aktuellen CoE-Konfiguration neu Initialisiert (geschieht sonst nur beim Übergang nach INIT) | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | 0x8000: bei erfolgtem Reset 0x01 | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | 0x8000: nicht benutzt | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Profilspezifische- und Parametrierungsobjekte [image] Eingangsdaten
Eingangsdaten
Index 60n0 Status (für n= 0 Kanal 1; n = 1 Kanal 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | SAI Inputs | Maximaler Subindex | UINT8 | RO | 0x10 (16dez)
60n0:01 | Underrange | Zeigt ein Unterschreiten des elektrischen Messbereiches an | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overrange | Zeigt ein Überschreiten des elektrischen Messbereiches an | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Limit 1 | 1: ein oder mehrere Werte kleiner oder gleich Limit 2 2: ein oder mehrere Werte größer oder gleich Limit 1 3: 1 und 2 trifft zu | BIT2 | RO | 0x00 (0dez)
60n0:07 | Error | Messfehler | BOOLEAN | RO | 0x00 (0dez)
60n0:0E | Sync error | Synchronisierungsfehler | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
60n0:10 | TxPDO Toggle | Ein neuer Messwert liegt an (wenn Toggle-Bit geändert). Status-Bits werden z.T. unabhängig vom Toggle Bit geändert. | BOOLEAN | RO | 0x00 (0dez)
Index 60n1 Samples (für n= 0 Kanal 1; n = 1 Kanal 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n1:0 | Samples | Maximaler Subindex | UINT8 | RO | 0x32 (50dez)
60n1:01 | Subindex 001 | 1. Sample | UINT16 | RO P | 0x0000 (0dez)
... | ... | ... | ... | ... | ...
60n1:32 | Subindex 050 | 50. Sample | UINT16 | RO P | 0x0000 (0dez)
Index 6020 Next Sync 1 Time
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | Next Sync 1 Time | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
6020:01 | Start time next latch | DC Timestamp des nächsten Datensatzes | UINT64 | RO P | 0x00 00 00 00 00 00 00 00 (0dez)
Index 6021 Sample Count
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6021:0 | Sample Count | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
6021:01 | Sample Count | Sample-Counter (wird mit jedem ADC-Wert inkrementiert) | UINT16 | RO P | 0x0000 (0dez)


Informations-/Diagnostikdaten (gerätespezifisch)

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Profilspezifische- und Parametrierungsobjekte [image] Informations-/Diagnostikdaten (gerätespezifisch)
Informations-/Diagnostikdaten (gerätespezifisch)
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 16 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[20] | RO | {0}
... | ... | .. | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |


Standardobjekte und PDO-Mapping

Inbetriebnahme/Konfiguration [image] Inbetriebnahme [image] CoE-Objektbeschreibung [image] Standardobjekte und PDO-Mapping
Standardobjekte und PDO-Mapping
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x012C1389 (19665801dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP3632
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 05
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0E303052 (238039122dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00110000 (1114112dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1A00 Analog Input TxPDO-MapStatus Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | Analog Input TxPDO-MapStatus Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Status), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Status), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Status), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Status), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (Status), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (Status), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (Status), entry 0x0F (TxPDO-State)) | UINT32 | RO | 0x6000:0F, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (Status), entry 0x10 (TxPDO-Toggle)) | UINT32 | RO | 0x6000:10, 1
Index 1A01 Analog Input TxPDO-MapSamples 1 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | Analog Input TxPDO-MapSamples 1 Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x01 ()) | UINT32 | RO | 0x6001:01, 16
Index 1A02 Analog Input TxPDO-MapSamples 2 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | Analog Input TxPDO-MapSamples 2 Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x02 ()) | UINT32 | RO | 0x6001:02, 16
Index 1A03 Analog Input TxPDO-MapSamples 3 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | Analog Input TxPDO-MapSamples 3 Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x03 ()) | UINT32 | RO | 0x6001:03, 16
Index 1A04 Analog Input TxPDO-MapSamples 4 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | Analog Input TxPDO-MapSamples 4 Ch.1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x04 ()) | UINT32 | RO | 0x6001:04, 16
Index 1A05 Analog Input TxPDO-MapSamples 5 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | Analog Input TxPDO-MapSamples 5 Ch.1 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x05 ()) | UINT32 | RO | 0x6001:05, 16
Index 1A06 Analog Input TxPDO-MapSamples 6 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | Analog Input TxPDO-MapSamples 6 Ch.1 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x06 ()) | UINT32 | RO | 0x6001:06, 16
Index 1A07 Analog Input TxPDO-MapSamples 7 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | Analog Input TxPDO-MapSamples 7 Ch.1 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x07 ()) | UINT32 | RO | 0x6001:07, 16
Index 1A08 Analog Input TxPDO-MapSamples 8 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | Analog Input TxPDO-MapSamples 8 Ch.1 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x08 ()) | UINT32 | RO | 0x6001:08, 16
Index 1A09 Analog Input TxPDO-MapSamples 9 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | Analog Input TxPDO-MapSamples 9 Ch.1 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x09 ()) | UINT32 | RO | 0x6001:09, 16
Index 1A0A Analog Input TxPDO-MapSamples 10 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | Analog Input TxPDO-MapSamples 10 Ch.1 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x0A ()) | UINT32 | RO | 0x6001:0A, 16
Index 1A0B Analog Input TxPDO-MapSamples 11 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | Analog Input TxPDO-MapSamples 11 Ch.1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x0B ()) | UINT32 | RO | 0x6001:0B, 16
Index 1A0C Analog Input TxPDO-MapSamples 12 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | Analog Input TxPDO-MapSamples 12 Ch.1 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x01 (1dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x0C ()) | UINT32 | RO | 0x6001:0C, 16
Index 1A0D Analog Input TxPDO-MapSamples 13 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | Analog Input TxPDO-MapSamples 13 Ch.1 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x01 (1dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x0D ()) | UINT32 | RO | 0x6001:0D, 16
Index 1A0E Analog Input TxPDO-MapSamples 14 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0E:0 | Analog Input TxPDO-MapSamples 14 Ch.1 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x01 (1dez)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x0E ()) | UINT32 | RO | 0x6001:0E, 16
Index 1A0F Analog Input TxPDO-MapSamples 15 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0F:0 | Analog Input TxPDO-MapSamples 15 Ch.1 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x01 (1dez)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x0F ()) | UINT32 | RO | 0x6001:0F, 16
Index 1A10 Analog Input TxPDO-MapSamples 16 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | Analog Input TxPDO-MapSamples 16 Ch.1 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x01 (1dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x10 ()) | UINT32 | RO | 0x6001:10, 16
Index 1A11 Analog Input TxPDO-MapSamples 17 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A11:0 | Analog Input TxPDO-MapSamples 17 Ch.1 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x01 (1dez)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x11 ()) | UINT32 | RO | 0x6001:11, 16
Index 1A12 Analog Input TxPDO-MapSamples 18 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A12:0 | Analog Input TxPDO-MapSamples 18 Ch.1 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x01 (1dez)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x12 ()) | UINT32 | RO | 0x6001:12, 16
Index 1A13 Analog Input TxPDO-MapSamples 19 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A13:0 | Analog Input TxPDO-MapSamples 19 Ch.1 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x01 (1dez)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x13 ()) | UINT32 | RO | 0x6001:13, 16
Index 1A14 Analog Input TxPDO-MapSamples 20 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A14:0 | Analog Input TxPDO-MapSamples 20 Ch.1 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x01 (1dez)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x14 ()) | UINT32 | RO | 0x6001:14, 16
Index 1A15 Analog Input TxPDO-MapSamples 21 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | Analog Input TxPDO-MapSamples 21 Ch.1 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x01 (1dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x15 ()) | UINT32 | RO | 0x6001:15, 16
Index 1A16 Analog Input TxPDO-MapSamples 22 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A16:0 | Analog Input TxPDO-MapSamples 22 Ch.1 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x01 (1dez)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x16 ()) | UINT32 | RO | 0x6001:16, 16
Index 1A17 Analog Input TxPDO-MapSamples 23 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A17:0 | Analog Input TxPDO-MapSamples 23 Ch.1 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x01 (1dez)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x17 ()) | UINT32 | RO | 0x6001:17, 16
Index 1A18 Analog Input TxPDO-MapSamples 24 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A18:0 | Analog Input TxPDO-MapSamples 24 Ch.1 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x01 (1dez)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x18 ()) | UINT32 | RO | 0x6001:18, 16
Index 1A19 Analog Input TxPDO-MapSamples 25 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A19:0 | Analog Input TxPDO-MapSamples 25 Ch.1 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x01 (1dez)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x19 ()) | UINT32 | RO | 0x6001:19, 16
Index 1A1A Analog Input TxPDO-MapSamples 26 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1A:0 | Analog Input TxPDO-MapSamples 26 Ch.1 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x01 (1dez)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x1A ()) | UINT32 | RO | 0x6001:1A, 16
Index 1A1B Analog Input TxPDO-MapSamples 27 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1B:0 | Analog Input TxPDO-MapSamples 27 Ch.1 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x01 (1dez)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x1B ()) | UINT32 | RO | 0x6001:1B, 16
Index 1A1C Analog Input TxPDO-MapSamples 28 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1C:0 | Analog Input TxPDO-MapSamples 28 Ch.1 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x01 (1dez)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x1C ()) | UINT32 | RO | 0x6001:1C, 16
Index 1A1D Analog Input TxPDO-MapSamples 29 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1D:0 | Analog Input TxPDO-MapSamples 29 Ch.1 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x01 (1dez)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x1D ()) | UINT32 | RO | 0x6001:1D, 16
Index 1A1E Analog Input TxPDO-MapSamples 30 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | Analog Input TxPDO-MapSamples 30 Ch.1 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x01 (1dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x1E ()) | UINT32 | RO | 0x6001:1E, 16
Index 1A1F Analog Input TxPDO-MapSamples 31 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1F:0 | Analog Input TxPDO-MapSamples 31 Ch.1 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x01 (1dez)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x1F ()) | UINT32 | RO | 0x6001:1F, 16
Index 1A20 Analog Input TxPDO-MapSamples 32 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A20:0 | Analog Input TxPDO-MapSamples 32 Ch.1 | PDO Mapping TxPDO 33 | UINT8 | RO | 0x01 (1dez)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x20 ()) | UINT32 | RO | 0x6001:20, 16
Index 1A21 Analog Input TxPDO-MapSamples 33 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A21:0 | Analog Input TxPDO-MapSamples 33 Ch.1 | PDO Mapping TxPDO 34 | UINT8 | RO | 0x01 (1dez)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x21 ()) | UINT32 | RO | 0x6001:21, 16
Index 1A22 Analog Input TxPDO-MapSamples 34 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A22:0 | Analog Input TxPDO-MapSamples 34 Ch.1 | PDO Mapping TxPDO 35 | UINT8 | RO | 0x01 (1dez)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x22 ()) | UINT32 | RO | 0x6001:22, 16
Index 1A23 Analog Input TxPDO-MapSamples 35 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A23:0 | Analog Input TxPDO-MapSamples 35 Ch.1 | PDO Mapping TxPDO 36 | UINT8 | RO | 0x01 (1dez)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x23 ()) | UINT32 | RO | 0x6001:23, 16
Index 1A24 Analog Input TxPDO-MapSamples 36 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A24:0 | Analog Input TxPDO-MapSamples 36 Ch.1 | PDO Mapping TxPDO 37 | UINT8 | RO | 0x01 (1dez)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x24 ()) | UINT32 | RO | 0x6001:24, 16
Index 1A25 Analog Input TxPDO-MapSamples 37 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A25:0 | Analog Input TxPDO-MapSamples 37 Ch.1 | PDO Mapping TxPDO 38 | UINT8 | RO | 0x01 (1dez)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x25 ()) | UINT32 | RO | 0x6001:25, 16
Index 1A26 Analog Input TxPDO-MapSamples 38 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A26:0 | Analog Input TxPDO-MapSamples 38 Ch.1 | PDO Mapping TxPDO 39 | UINT8 | RO | 0x01 (1dez)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x26 ()) | UINT32 | RO | 0x6001:26, 16
Index 1A27 Analog Input TxPDO-MapSamples 39 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A27:0 | Analog Input TxPDO-MapSamples 39 Ch.1 | PDO Mapping TxPDO 40 | UINT8 | RO | 0x01 (1dez)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x27 ()) | UINT32 | RO | 0x6001:27, 16
Index 1A28 Analog Input TxPDO-MapSamples 40 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A28:0 | Analog Input TxPDO-MapSamples 40 Ch.1 | PDO Mapping TxPDO 41 | UINT8 | RO | 0x01 (1dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x28 ()) | UINT32 | RO | 0x6001:28, 16
Index 1A29 Analog Input TxPDO-MapSamples 41 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A29:0 | Analog Input TxPDO-MapSamples 41 Ch.1 | PDO Mapping TxPDO 42 | UINT8 | RO | 0x01 (1dez)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x29 ()) | UINT32 | RO | 0x6001:29, 16
Index 1A2A Analog Input TxPDO-MapSamples 42 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2A:0 | Analog Input TxPDO-MapSamples 42 Ch.1 | PDO Mapping TxPDO 43 | UINT8 | RO | 0x01 (1dez)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x2A ()) | UINT32 | RO | 0x6001:2A, 16
Index 1A2B Analog Input TxPDO-MapSamples 43 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2B:0 | Analog Input TxPDO-MapSamples 43 Ch.1 | PDO Mapping TxPDO 44 | UINT8 | RO | 0x01 (1dez)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x2B ()) | UINT32 | RO | 0x6001:2B, 16
Index 1A2C Analog Input TxPDO-MapSamples 44 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2C:0 | Analog Input TxPDO-MapSamples 44 Ch.1 | PDO Mapping TxPDO 45 | UINT8 | RO | 0x01 (1dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x2C ()) | UINT32 | RO | 0x6001:2C, 16
Index 1A2D Analog Input TxPDO-MapSamples 45 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2D:0 | Analog Input TxPDO-MapSamples 45 Ch.1 | PDO Mapping TxPDO 46 | UINT8 | RO | 0x01 (1dez)
1A2D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x2D ()) | UINT32 | RO | 0x6001:2D, 16
Index 1A2E Analog Input TxPDO-MapSamples 46 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2E:0 | Analog Input TxPDO-MapSamples 46 Ch.1 | PDO Mapping TxPDO 47 | UINT8 | RO | 0x01 (1dez)
1A2E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x2E ()) | UINT32 | RO | 0x6001:2E, 16
Index 1A2F Analog Input TxPDO-MapSamples 47 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2F:0 | Analog Input TxPDO-MapSamples 47 Ch.1 | PDO Mapping TxPDO 48 | UINT8 | RO | 0x01 (1dez)
1A2F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x2F ()) | UINT32 | RO | 0x6001:2F, 16
Index 1A30 Analog Input TxPDO-MapSamples 48 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A30:0 | Analog Input TxPDO-MapSamples 48 Ch.1 | PDO Mapping TxPDO 49 | UINT8 | RO | 0x01 (1dez)
1A30:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x30 ()) | UINT32 | RO | 0x6001:30, 16
Index 1A31 Analog Input TxPDO-MapSamples 49 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A31:0 | Analog Input TxPDO-MapSamples 49 Ch.1 | PDO Mapping TxPDO 50 | UINT8 | RO | 0x01 (1dez)
1A31:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x31 ()) | UINT32 | RO | 0x6001:31, 16
Index 1A32 Analog Input TxPDO-MapSamples 50 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A32:0 | Analog Input TxPDO-MapSamples 50 Ch.1 | PDO Mapping TxPDO 51 | UINT8 | RO | 0x01 (1dez)
1A32:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (Samples), entry 0x32 ()) | UINT32 | RO | 0x6001:32, 16
Index 1A40 Analog Input TxPDO-MapStatus Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:0 | Analog Input TxPDO-MapStatus Ch.2 | PDO Mapping TxPDO 65 | UINT8 | RO | 0x09 (9dez)
1A40:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (Status), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A40:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (Status), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A40:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (Status), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A40:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (Status), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A40:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (Status), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A40:06 | SubIndex 006 | 6. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A40:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (Status), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A40:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A40:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
Index 1A41 Analog Input TxPDO-MapSamples 1 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A41:0 | Analog Input TxPDO-MapSamples 1 Ch.2 | PDO Mapping TxPDO 66 | UINT8 | RO | 0x01 (1dez)
1A41:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x01 ()) | UINT32 | RO | 0x6011:01, 16
Index 1A42 Analog Input TxPDO-MapSamples 2 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A42:0 | Analog Input TxPDO-MapSamples 2 Ch.2 | PDO Mapping TxPDO 67 | UINT8 | RO | 0x01 (1dez)
1A42:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x02 ()) | UINT32 | RO | 0x6011:02, 16
Index 1A43 Analog Input TxPDO-MapSamples 3 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A43:0 | Analog Input TxPDO-MapSamples 3 Ch.2 | PDO Mapping TxPDO 68 | UINT8 | RO | 0x01 (1dez)
1A43:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x03 ()) | UINT32 | RO | 0x6011:03, 16
Index 1A44 Analog Input TxPDO-MapSamples 4 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A44:0 | Analog Input TxPDO-MapSamples 4 Ch.2 | PDO Mapping TxPDO 69 | UINT8 | RO | 0x01 (1dez)
1A44:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x04 ()) | UINT32 | RO | 0x6011:04, 16
Index 1A45 Analog Input TxPDO-MapSamples 5 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A45:0 | Analog Input TxPDO-MapSamples 5 Ch.2 | PDO Mapping TxPDO 70 | UINT8 | RO | 0x01 (1dez)
1A45:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x05 ()) | UINT32 | RO | 0x6011:05, 16
Index 1A46 Analog Input TxPDO-MapSamples 6 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A46:0 | Analog Input TxPDO-MapSamples 6 Ch.2 | PDO Mapping TxPDO 71 | UINT8 | RO | 0x01 (1dez)
1A46:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x06 ()) | UINT32 | RO | 0x6011:06, 16
Index 1A47 Analog Input TxPDO-MapSamples 7 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A47:0 | Analog Input TxPDO-MapSamples 7 Ch.2 | PDO Mapping TxPDO 72 | UINT8 | RO | 0x01 (1dez)
1A47:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x07 ()) | UINT32 | RO | 0x6011:07, 16
Index 1A48 Analog Input TxPDO-MapSamples 8 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A48:0 | Analog Input TxPDO-MapSamples 8 Ch.2 | PDO Mapping TxPDO 73 | UINT8 | RO | 0x01 (1dez)
1A48:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples),), entry 0x08 ()) | UINT32 | RO | 0x6011:08, 16
Index 1A49 Analog Input TxPDO-MapSamples 9 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A49:0 | Analog Input TxPDO-MapSamples 9 Ch.2 | PDO Mapping TxPDO 74 | UINT8 | RO | 0x01 (1dez)
1A49:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x09 ()) | UINT32 | RO | 0x6011:09, 16
Index 1A4A Analog Input TxPDO-MapSamples 10 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A4A:0 | Analog Input TxPDO-MapSamples 10 Ch.2 | PDO Mapping TxPDO 75 | UINT8 | RO | 0x01 (1dez)
1A4A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x0A ()) | UINT32 | RO | 0x6011:0A, 16
Index 1A4B Analog Input TxPDO-MapSamples 11 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A4B:0 | Analog Input TxPDO-MapSamples 11 Ch.2 | PDO Mapping TxPDO 76 | UINT8 | RO | 0x01 (1dez)
1A4B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x0B ()) | UINT32 | RO | 0x6011:0B, 16
Index 1A4C Analog Input TxPDO-MapSamples 12 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A4C:0 | Analog Input TxPDO-MapSamples 12 Ch.2 | PDO Mapping TxPDO 77 | UINT8 | RO | 0x01 (1dez)
1A4C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x0C ()) | UINT32 | RO | 0x6011:0C, 16
Index 1A4D Analog Input TxPDO-MapSamples 13 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A4D:0 | Analog Input TxPDO-MapSamples 13 Ch.2 | PDO Mapping TxPDO 78 | UINT8 | RO | 0x01 (1dez)
1A4D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x0D ()) | UINT32 | RO | 0x6011:0D, 16
Index 1A4E Analog Input TxPDO-MapSamples 14 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A4E:0 | Analog Input TxPDO-MapSamples 14 Ch.2 | PDO Mapping TxPDO 79 | UINT8 | RO | 0x01 (1dez)
1A4E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x0E ()) | UINT32 | RO | 0x6011:0E, 16
Index 1A4F Analog Input TxPDO-MapSamples 15 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A4F:0 | Analog Input TxPDO-MapSamples 15 Ch.2 | PDO Mapping TxPDO 80 | UINT8 | RO | 0x01 (1dez)
1A4F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x0F ()) | UINT32 | RO | 0x6011:0F, 16
Index 1A50 Analog Input TxPDO-MapSamples 16 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A50:0 | Analog Input TxPDO-MapSamples 16 Ch.2 | PDO Mapping TxPDO 81 | UINT8 | RO | 0x01 (1dez)
1A50:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x10 ()) | UINT32 | RO | 0x6011:10, 16
Index 1A51 Analog Input TxPDO-MapSamples 17 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A51:0 | Analog Input TxPDO-MapSamples 17 Ch.2 | PDO Mapping TxPDO 82 | UINT8 | RO | 0x01 (1dez)
1A51:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples),), entry 0x11 ()) | UINT32 | RO | 0x6011:11, 16
Index 1A52 Analog Input TxPDO-MapSamples 18 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A52:0 | Analog Input TxPDO-MapSamples 18 Ch.2 | PDO Mapping TxPDO 83 | UINT8 | RO | 0x01 (1dez)
1A52:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x12 ()) | UINT32 | RO | 0x6011:12, 16
Index 1A53 Analog Input TxPDO-MapSamples 19 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A53:0 | Analog Input TxPDO-MapSamples 19 Ch.2 | PDO Mapping TxPDO 84 | UINT8 | RO | 0x01 (1dez)
1A53:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples),), entry 0x13 ()) | UINT32 | RO | 0x6011:13, 16
Index 1A54 Analog Input TxPDO-MapSamples 20 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A54:0 | Analog Input TxPDO-MapSamples 20 Ch.2 | PDO Mapping TxPDO 85 | UINT8 | RO | 0x01 (1dez)
1A54:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x14 ()) | UINT32 | RO | 0x6011:14, 16
Index 1A55 Analog Input TxPDO-MapSamples 21 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A55:0 | Analog Input TxPDO-MapSamples 21 Ch.2 | PDO Mapping TxPDO 86 | UINT8 | RO | 0x01 (1dez)
1A55:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x15 ()) | UINT32 | RO | 0x6011:15, 16
Index 1A56 Analog Input TxPDO-MapSamples 22 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A56:0 | Analog Input TxPDO-MapSamples 22 Ch.2 | PDO Mapping TxPDO 87 | UINT8 | RO | 0x01 (1dez)
1A56:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x16 ()) | UINT32 | RO | 0x6011:16, 16
Index 1A57 Analog Input TxPDO-MapSamples 23 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A57:0 | Analog Input TxPDO-MapSamples 23 Ch.2 | PDO Mapping TxPDO 88 | UINT8 | RO | 0x01 (1dez)
1A57:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x17 ()) | UINT32 | RO | 0x6011:17, 16
Index 1A58 Analog Input TxPDO-MapSamples 24 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A58:0 | Analog Input TxPDO-MapSamples 24 Ch.2 | PDO Mapping TxPDO 89 | UINT8 | RO | 0x01 (1dez)
1A58:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x18 ()) | UINT32 | RO | 0x6011:18, 16
Index 1A59 Analog Input TxPDO-MapSamples 25 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A59:0 | Analog Input TxPDO-MapSamples 25 Ch.2 | PDO Mapping TxPDO 90 | UINT8 | RO | 0x01 (1dez)
1A59:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x19 ()) | UINT32 | RO | 0x6011:19, 16
Index 1A5A Analog Input TxPDO-MapSamples 26 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A5A:0 | Analog Input TxPDO-MapSamples 26 Ch.2 | PDO Mapping TxPDO 91 | UINT8 | RO | 0x01 (1dez)
1A5A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x1A ()) | UINT32 | RO | 0x6011:1A, 16
Index 1A5B Analog Input TxPDO-MapSamples 27 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A5B:0 | Analog Input TxPDO-MapSamples 27 Ch.2 | PDO Mapping TxPDO 92 | UINT8 | RO | 0x01 (1dez)
1A5B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x1B ()) | UINT32 | RO | 0x6011:1B, 16
Index 1A5C Analog Input TxPDO-MapSamples 28 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A5C:0 | Analog Input TxPDO-MapSamples 28 Ch.2 | PDO Mapping TxPDO 93 | UINT8 | RO | 0x01 (1dez)
1A5C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x1C ()) | UINT32 | RO | 0x6011:1C, 16
Index 1A5D Analog Input TxPDO-MapSamples 29 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A5D:0 | Analog Input TxPDO-MapSamples 29 Ch.2 | PDO Mapping TxPDO 94 | UINT8 | RO | 0x01 (1dez)
1A5D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x1D ()) | UINT32 | RO | 0x6011:1D, 16
Index 1A5E Analog Input TxPDO-MapSamples 30 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A5E:0 | Analog Input TxPDO-MapSamples 30 Ch.2 | PDO Mapping TxPDO 95 | UINT8 | RO | 0x01 (1dez)
1A5E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x1E ()) | UINT32 | RO | 0x6011:1E, 16
Index 1A5F Analog Input TxPDO-MapSamples 31 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A5F:0 | Analog Input TxPDO-MapSamples 31 Ch.2 | PDO Mapping TxPDO 96 | UINT8 | RO | 0x01 (1dez)
1A5F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x1F ()) | UINT32 | RO | 0x6011:1F, 16
Index 1A60 Analog Input TxPDO-MapSamples 32 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A60:0 | Analog Input TxPDO-MapSamples 32 Ch.2 | PDO Mapping TxPDO 97 | UINT8 | RO | 0x01 (1dez)
1A60:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x20 ()) | UINT32 | RO | 0x6011:20, 16
Index 1A61 Analog Input TxPDO-MapSamples 33 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A61:0 | Analog Input TxPDO-MapSamples 33 Ch.2 | PDO Mapping TxPDO 98 | UINT8 | RO | 0x01 (1dez)
1A61:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x21 ()) | UINT32 | RO | 0x6011:21, 16
Index 1A62 Analog Input TxPDO-MapSamples 34 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A62:0 | Analog Input TxPDO-MapSamples 34 Ch.2 | PDO Mapping TxPDO 99 | UINT8 | RO | 0x01 (1dez)
1A62:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x22 ()) | UINT32 | RO | 0x6011:22, 16
Index 1A63 Analog Input TxPDO-MapSamples 35 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A63:0 | Analog Input TxPDO-MapSamples 35 Ch.2 | PDO Mapping TxPDO 100 | UINT8 | RO | 0x01 (1dez)
1A63:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x23 ()) | UINT32 | RO | 0x6011:23, 16
Index 1A64 Analog Input TxPDO-MapSamples 36 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A64:0 | Analog Input TxPDO-MapSamples 36 Ch.2 | PDO Mapping TxPDO 101 | UINT8 | RO | 0x01 (1dez)
1A64:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x24 ()) | UINT32 | RO | 0x6011:24, 16
Index 1A65 Analog Input TxPDO-MapSamples 37 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A65:0 | Analog Input TxPDO-MapSamples 37 Ch.2 | PDO Mapping TxPDO 102 | UINT8 | RO | 0x01 (1dez)
1A65:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x25 ()) | UINT32 | RO | 0x6011:25, 16
Index 1A66 Analog Input TxPDO-MapSamples 38 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A66:0 | Analog Input TxPDO-MapSamples 38 Ch.2 | PDO Mapping TxPDO 103 | UINT8 | RO | 0x01 (1dez)
1A66:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x26 ()) | UINT32 | RO | 0x6011:26, 16
Index 1A67 Analog Input TxPDO-MapSamples 39 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A67:0 | Analog Input TxPDO-MapSamples 39 Ch.2 | PDO Mapping TxPDO 104 | UINT8 | RO | 0x01 (1dez)
1A67:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x27 ()) | UINT32 | RO | 0x6011:27, 16
Index 1A68 Analog Input TxPDO-MapSamples 40 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A68:0 | Analog Input TxPDO-MapSamples 40 Ch.2 | PDO Mapping TxPDO 105 | UINT8 | RO | 0x01 (1dez)
1A68:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x28 ()) | UINT32 | RO | 0x6011:28, 16
Index 1A69 Analog Input TxPDO-MapSamples 41 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A69:0 | Analog Input TxPDO-MapSamples 41 Ch.2 | PDO Mapping TxPDO 106 | UINT8 | RO | 0x01 (1dez)
1A69:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x29 ()) | UINT32 | RO | 0x6011:29, 16
Index 1A6A Analog Input TxPDO-MapSamples 42 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A6A:0 | Analog Input TxPDO-MapSamples 42 Ch.2 | PDO Mapping TxPDO 107 | UINT8 | RO | 0x01 (1dez)
1A6A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x2A ()) | UINT32 | RO | 0x6011:2A, 16
Index 1A6B Analog Input TxPDO-MapSamples 43 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A6B:0 | Analog Input TxPDO-MapSamples 43 Ch.2 | PDO Mapping TxPDO 108 | UINT8 | RO | 0x01 (1dez)
1A6B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x2B ()) | UINT32 | RO | 0x6011:2B, 16
Index 1A6C Analog Input TxPDO-MapSamples 44 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A6C:0 | Analog Input TxPDO-MapSamples 44 Ch.2 | PDO Mapping TxPDO 109 | UINT8 | RO | 0x01 (1dez)
1A6C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x2C ()) | UINT32 | RO | 0x6011:2C, 16
Index 1A6D Analog Input TxPDO-MapSamples 45 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A6D:0 | Analog Input TxPDO-MapSamples 45 Ch.2 | PDO Mapping TxPDO 110 | UINT8 | RO | 0x01 (1dez)
1A6D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x2D ()) | UINT32 | RO | 0x6011:2D, 16
Index 1A6E Analog Input TxPDO-MapSamples 46 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A6E:0 | Analog Input TxPDO-MapSamples 46 Ch.2 | PDO Mapping TxPDO 111 | UINT8 | RO | 0x01 (1dez)
1A6E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x2E ()) | UINT32 | RO | 0x6011:2E, 16
Index 1A6F Analog Input TxPDO-MapSamples 47 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A6F:0 | Analog Input TxPDO-MapSamples 47 Ch.2 | PDO Mapping TxPDO 112 | UINT8 | RO | 0x01 (1dez)
1A6F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x2F ()) | UINT32 | RO | 0x6011:2F, 16
Index 1A70 Analog Input TxPDO-MapSamples 48 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A70:0 | Analog Input TxPDO-MapSamples 48 Ch.2 | PDO Mapping TxPDO 113 | UINT8 | RO | 0x01 (1dez)
1A70:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x30 ()) | UINT32 | RO | 0x6011:30, 16
Index 1A71 Analog Input TxPDO-MapSamples 49 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A71:0 | Analog Input TxPDO-MapSamples 49 Ch.2 | PDO Mapping TxPDO 114 | UINT8 | RO | 0x01 (1dez)
1A71:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x31 ()) | UINT32 | RO | 0x6011:31, 16
Index 1A72 Analog Input TxPDO-MapSamples 50 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A72:0 | Analog Input TxPDO-MapSamples 50 Ch.2 | PDO Mapping TxPDO 115 | UINT8 | RO | 0x01 (1dez)
1A72:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (Samples), entry 0x32 ()) | UINT32 | RO | 0x6011:32, 16
Index 1A80 Analog Input Timestamp TxPDO-Map NextSync1Time
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A80:0 | Analog Input Timestamp TxPDO-Map NextSync1Time | PDO Mapping TxPDO 129 | UINT8 | RO | 0x01 (1dez)
1A80:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (NextSync1Time), entry 0x01 (StartTimeNextLatch)) | UINT32 | RO | 0x6020:01, 64
Index 1A81 Analog Input Timestamp TxPDO-Map Sample Count
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A81:0 | Analog Input Timestamp TxPDO-Map Sample Count | PDO Mapping TxPDO 130 | UINT8 | RO | 0x01 (1dez)
1A81:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (SampleCount), entry 0x01 (SampleCount)) | UINT32 | RO | 0x6021:01, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x06 (6dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A40 (6720dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A41 (6721dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A80 (6784dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A81 (6785dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
... | ... | ... | ... | ... | ..
1C13:69 | Subindex 105 | 105. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0C06 (3078dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00002710 (10000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | Profil AI | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 | Profil AI | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 | Profil AI | UINT32 | RW | 0x0000012C (300dez)


Hinweise zu analogen Spezifikationen

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen
Hinweise zu analogen Spezifikationen
Beckhoff IO-Geräte (Klemmen, Boxen, Module) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Weiterführende Informationen
•
Messbereichsendwert (MBE)
•
Messfehler/ Messabweichung
•
Temperaturkoeffizient tK [ppm/K]
•
Typisierung SingleEnded / Differentiell
•
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
•
Spannungsfestigkeit
•
Zeitliche Aspekte der analog/digital Wandlung


Messbereichsendwert (MBE)

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Messbereichsendwert (MBE)
Messbereichsendwert (MBE)
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereichsendwert, Messspanne
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200...1370°C: asymmetrisch bipolar, MBE = 1370°C, Messspanne = 1570°C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/ -boxen (bzw. verwandten Beckhoff‑Produktgruppen).


Messfehler/ Messabweichung

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Messfehler/ Messabweichung
Messfehler/ Messabweichung
Der relative Messfehler (% vom MBE) bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung usw.).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3% MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Geringerer Messfehler
Da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsgeräte.


Temperaturkoeffizient tK [ppm/K]

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Temperaturkoeffizient tK [ppm/K]
Temperaturkoeffizient tK [ppm/K]
Eine elektronische Schaltung ist in der Regel mehr oder weniger temperaturabhängig. Im Bereich der analogen Messtechnik bedeutet dies, daß der mittels einer elektronischen Schaltung ermittelte Messwert reproduzierbar in seiner Abweichung vom „wahren“ Wert von der Umgebungs/Betriebstemperatur abhängig ist.
Lindern kann ein Hersteller dies durch Verwendung höherwertiger Bauteile oder Software-Maßnahmen.
Der von Beckhoff ggf. angegebene Temperaturkoeffizient erlaubt es dem Anwender den zu erwartenden Messfehler außerhalb der Grundgenauigkeit bei 23°C zu berechnen.
Aufgrund der umfangreichen Unsicherheitsbetrachtungen, die in die Bestimmungen der Grundgenauigkeit (bei 23°C) eingehen, empfiehlt Beckhoff eine quadratische Summierung.
Beispiel: Grundgenauigkeit bei 23°C sei ±0,01% typ. (MBE), tK = 20 ppm/K typ., gesucht ist die Genauigkeit G35 bei 35°C, somit ΔT = 12K
Anmerkungen:
ppm ≙ 10-6
% ≙ 10-2


Typisierung SingleEnded / Differentiell

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Typisierung SingleEnded / Differentiell
Typisierung SingleEnded / Differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
SE und DIFF-Modul als 2-kanalige Variante
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss. Galvanisch getrennte Kanäle arbeiten grundsätzlich in differentieller Art, nur dass überhaupt kein direkter (galvanischer) Massebezug im Modul hergestellt ist. Spezifikationsangaben zu empfohlenen und maximalen Spannungen sind jeweils allerdings zu beachten.
Grundsätzlich gilt:
▪
Die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten.
Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
Dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
Für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
–
Bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt.
Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
Es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen.
Beckhoff IO-Module verfügen über 1..8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden
–
wie sich die Kanäle INNERHALB eines Module zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
–
Beckhoff Klemmen/ Boxen (bzw. verwandte Produktgruppen) sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen/ Boxen also nicht über die Powerkontakte/ Powerleitung miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
–
Falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder ein 1-Kanal-Modul keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
Analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Dokumentationen zu den Klemmen/ Boxen sind zu beachten.
Erläuterung
▪
differentiell (DIFF)
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (vgl. Abb. SE und DIFF-Modul als 2-kanalige Variante) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)", wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/ Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/ Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird.
Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung in Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
–
Weitere hilfreiche Ergänzungen dazu sind der Dokumentationsseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) zu entnehmen.
▪
Single Ended (SE)
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/ Box von außen zum Anschluss des Bezugspotenzials zugänglich sein, z. B. über die Powerkontakte/ Powerleitung.
–
SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/ Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z. B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/Bezugspotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst.
Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4-20mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss siehe Abb. 2-Leiter-Anschluss, vgl. IEC60381-1
▪
Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
2-Leiter-Anschluss
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/ Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Extern versorgte Sensoren
▪
3- und 4-Leiter-Anschluss siehe Abb. Anschluss extern versorgte Sensoren, vgl. IEC60381-1
▪
Die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:
–
1 Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm.
–
2 Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +Supply/-Supply/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
Ja:
Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
Nein:
es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Bei unipolaren Klemmen/ Boxen (und verwandten Produktgruppen) ist üblicherweise eine interne Diode vorhanden, dann ist die Polarität/Stromrichtung zu beachten:
Anschluss extern versorgte Sensoren
Einordnung der Beckhoff-Klemmen/ Boxen - Beckhoff 0/4-20mA Klemmen/ Boxen (und verwandten Produktgruppen) sind als differentiell und single-ended verfügbar:
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA, genauso KL und verwandten Produktgruppen | differentiell EL3x1x: 0-20 mA, EL3x2x: 4-20 mA, genauso KL und verwandten Produktgruppen
Stromvorzugsrichtung da interne Diode | Stromvorzugsrichtung da interne Diode
Sind für den Anschluss von extern versorgenden Sensoren im 3/4-Leiter-Anschluss konzipiert. | Die Klemme/ Box ist eine passive differentielle Strommessvorrichtung, „passiv“ bedeutet, dass keine Sensorspeisung erfolgt.
Sind für den Anschluss von selbstversorgenden Sensoren im 2-Leiter-Anschluss konzipiert |
Single-ended
Differential
2-, 3- und 4-Leiter-Anschluss an Single Ended - und Differenz Eingänge


Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung (CommonMode, Ucm) wird als der Mittelwert der Spannungen an den einzelnen Anschlüssen/Eingängen definiert und wird gegen eine Bezugsmasse gemessen/angegeben.
Gleichtaktspannung (Ucm)
Bei der Definition des zulässigen Gleichtaktspannungsbereiches und bei der Messung der Gleichtaktunterdrückung (CMRR, common mode rejection ratio) bei differenziellen Eingängen ist die Definition der Bezugsmasse wichtig.
Die Bezugsmasse ist auch das Potential, gegen welches der Eingangswiderstand und die Eingangsimpedanz bei single-ended-Eingängen bzw. der Gleichtaktwiderstand und die Gleichtaktimpedanz bei differenziellen Eingängen gemessen werden.
Die Bezugsmasse ist an/bei der Klemme/ Box i.d.R. zugänglich. Orte dafür können Klemmkontakte, Powerkontakte/ Powerleitung oder auch nur eine Tragschiene sein. Zur Verortung siehe Dokumentation, die Bezugsmasse sollte beim betrachteten Gerät angegeben sein.
Bei mehrkanaligen Klemmen/ Boxen mit resistiver (=direkter, ohmscher, galvanischer) oder kapazitiver Verbindung zwischen den Kanälen ist die Bezugsmasse vorzugsweise der Symmetriepunkt aller Kanäle, unter Betrachtung der Verbindungswiderstände.
Beispiele für Bezugsmassen bei Beckhoff IO Geräten:
1.
internes AGND (analog GND) herausgeführt:
EL3102/EL3112, resistive Verbindung der Kanäle untereinander
2.
0V-Powerkontakt:
EL3104/EL3114, resistive Verbindung der Kanäle untereinander an AGND, AGND niederohmig verbunden mit 0V-Powerkontakt
3.
Erde bzw. SGND (shield GND):
–
EL3174-0002: Kanäle haben keine resistive Verbindung untereinander, aber sind kapazitiv durch Ableitkondensatoren an SGND gekoppelt
–
EL3314: keine interne Masse auf die Klemmpunkte herausgeführt, aber kapazitive Kopplung an SGND


Spannungsfestigkeit

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Spannungsfestigkeit
Spannungsfestigkeit
Es ist zu unterscheiden zwischen:
▪
Spannungsfestigkeit (Zerstörgrenze): eine Überschreitung kann irreversible Veränderungen an der Elektronik zur Folge haben, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
▪
Empfohlener Einsatzspannungsbereich: Bei einer Überschreitung kann nicht mehr von einem spezifikationsgemäßem Betrieb ausgegangen werden, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
Empfohlener Einsatzspannungsbereich
Es können in den Gerätedokumentationen besondere Spezifikationsangaben dazu und zur Zeitangabe gemacht werden, unter Berücksichtigung von:
▪
Eigenerwärmung
▪
Nennspannung
▪
Isolationsfestigkeit
▪
Flankensteilheit der Anlege-Spannung bzw. Haltedauern
▪
Normatives Umfeld (z.B. PELV)


Zeitliche Aspekte der analog/digital Wandlung

Inbetriebnahme/Konfiguration [image] Hinweise zu analogen Spezifikationen [image] Zeitliche Aspekte der analog/digital Wandlung
Zeitliche Aspekte der analog/digital Wandlung
Die Umwandlung des stetigen analogen elektrischen Eingangssignals in eine wertdiskrete digitale und maschinenlesbare Form wird in den Beckhoff analogen Eingangsbaugruppen EL/KL/EP mit sog. ADC (analog digital converter) umgesetzt. Obgleich verschiedene ADC-Technologien gängig sind, haben sie alle aus Anwendersicht ein gemeinsames Merkmal: nach dem Ende der Umwandlung steht ein bestimmter digitaler Wert zur Weiterverarbeitung in der Steuerung bereit. Dieser Digitalwert, das sog. Analoge Prozessdatum, steht in einem festen zeitlichen Zusammenhang mit der „Ur-Größe“, dem elektrischen Eingangswert. Deshalb können für Beckhoff analoge Eingangsgeräte auch entsprechende zeitliche Kenndaten ermittelt und spezifiziert werden.
In diesen Prozess sind mehrere funktionale Komponenten involviert, die mehr oder weniger stark ausgeprägt in jeder AI (analog input) Baugruppe wirken:
▪
die elektrische Eingangsschaltung
▪
die Analog/Digital-Wandlung
▪
die digitale Weiterverarbeitung
▪
die finale Bereitstellung der Prozess- und Diagnosedaten zur Abholung an den Feldbus (EtherCAT, K-Bus etc.)
Signalverarbeitung Analogeingang
Aus Anwendersicht sind dabei zwei Aspekte entscheidend:
▪
„wie oft bekomme ich neue Werte?“, also eine Samplingrate im Sinne einer Schnelligkeit in Bezug auf das Gerät/den Kanal
▪
Wieviel Verzögerung verursacht die (gesamte) AD-Wandlung des Gerätes/des Kanals?
- also Hard- und Firmware-Teile in toto. Aus technologischen Gründen muss zur Bestimmung dieser Angabe die Signalcharakteristik betrachtet werden: je nach Signalfrequenz kann es zu unterschiedlichen Laufzeiten durch das System kommen.
Dies ist die „äußere“ Betrachtung des Systems „Beckhoff AI Kanal“ – intern setzt sich insbesondere die Signalverzögerung aus den verschiedenen Anteilen Hardware, Verstärker, Wandlung selbst, Datentransport und Verarbeitung zusammen. Auch kann ggf. intern eine höhere Abtastrate verwendet werden (z.B. bei deltaSigma-Wandlern) als „außen“ aus Anwendersicht angeboten wird. Dies ist aber für ein nutzseitige Betrachtung der Komponente „Beckhoff AI Kanal“ normalerweise ohne Belang bzw. wird entsprechend spezifiziert, falls es doch für die Funktion relevant ist.
Damit können für Beckhoff AI Geräte folgende Spezifikationsangaben zum AI Kanal aus zeitlicher Sicht für den Anwender angegeben werden:
1. Minimale Wandlungszeit [ms, µs]
= der Kehrwert der maximalen Samplingrate [Sps, Samples per second]:
Gibt an, wie oft der analoge Kanal einen neu festgestellten Prozessdatenwert zur Abholung durch den Feldbus bereitstellt. Ob der Feldbus (EtherCAT, K-Bus) diesen dann auch genauso schnell (also im Gleichtakt), schneller (weil der AI Kanal im langsame FreeRun läuft) oder langsamer (z.B. bei Oversampling) abholt, ist dann eine Frage der Einstellung des Feldbusses und welche Betriebsmodi das AI Gerät unterstützt.
Bei EtherCAT Geräten zeigt das sog. ToggleBit bei den Diagnose-PDO an (indem es toggelt), dass ein neu ermittelter AnalogWert vorliegt.
Entsprechend kann eine maximale Wandlungszeit, also eine minimal vom AI Gerät unterstützte Samplingrate spezifiziert werden.
Entspricht IEC 61131-2 Kap 7.10.2 2) „Abtast Wiederholzeit“
2. Typ. Signalverzögerung
Entspricht IEC 61131-2 Kap 7.10.2 1) „Abtastdauer“. Sie inkludiert nach dieser Betrachtung alle geräteinternen Hard- und Firmwareanteile, aber nicht „äußere“ Verzögerungsanteile aus dem Feldbus oder der Steuerung (TwinCAT).
Diese Verzögerung ist insbesondere relevant für absolute Zeitbetrachtungen, wenn AI Kanäle zum Amplitudenwert auch einen zugehörigen Zeitstempel (timestamp) mitliefern – von dem ja angenommen werden darf, dass er in seinem Zeitwert zu dem außen ehemals physikalisch anliegenden Amplitudenwert passt.
Aufgrund der frequenzabhängigen Laufzeit eines Signals, kann ein dezidierter Wert nur für ein gegebenes Signal spezifiziert werden. Der Wert ist auch abhängig von ggf. veränderlichen Filtereinstellungen des Kanals.
Eine typische Charakterisierung in der Gerätedokumentation kann sein:
2.1 Signalverzögerung (Sprungantwort)
Stichworte: Einschwingzeit
Das Rechtecksignal kann extern mit einem Frequenzgenerator (Impedanz beachten!) erzeugt werden.
Als Erkennungsschwelle wird die 90% Grenze verwendet.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem (idealen) elektrischen Rechtecksignal und der Zeitpunkt wo der analoge Prozesswert die 90% Amplitude erreicht hat.
Diagramm Signalverzögerung (Sprungantwort)
2.2 Signalverzögerung (linear)
Stichwort: Gruppenlaufzeit
Beschreibt die Verzögerung eines frequenzkonstanten Signals
Testsignal kann extern mit einem Frequenzgenerator erzeugt werden, z.B. als Sägezahn oder Sinus. Referenz wäre dann ein zeitgleiches Rechtecksignal.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem eingespeisten elektrischen Signal einer bestimmten Amplitude und dem Moment wo der analoge Prozesswert denselben Wert erreicht.
Dazu muss die Testfrequenz in einem sinnvollen Bereich gewählt werden; diese kann z.B. bei 1/20 der maximalen Samplingrate liegen.
Diagramm Signalverzögerung (linear)
3. Weitere Angaben:
können in der Spezifikation optional angeführt sein, wie z.B.
3.1 Tatsächliche Samplingrate des ADC (wenn unterschiedlich von der Kanal-Samplingrate)
3.2 Zeit-Korrekturwerte für Laufzeiten bei unterschiedlichen Filtereinstellungen
…


Anwendungsbeispiel

Inbetriebnahme/Konfiguration [image] Anwendungsbeispiel
Anwendungsbeispiel
Das im Folgenden für EtherCAT-Klemmen beschriebene Anwendungsbeispiel kann auch für die EtherCAT-Box EP3632 und die EtherCAT-P-Box EPP3632 angewendet werden.
ScopeView2 mit Oversampling verwenden
Vorbereitung
▪
TwinCAT 2.11 ab Build 1549 verwenden
▪
Aktuelles ScopeView2 verwenden
Oversampling aktivieren
Folgende Schritte sind durchzuführen (Abb. ScopeView2 aktivieren):
1.
Prozessabbild des EtherCAT Masters (hier: ”Gerät 1-Prozessabbild”) wählen
2.
Im Reiter ”ADS” -> ”ADS Server aktivieren”
3.
”Symbole erzeugen” wählen
4.
”Port” notieren (i.d.R. 27905)
5.
Konfiguration übernehmen (Achtung: PLC Neustart erforderlich!)
ScopeView2 aktivieren
Oversampling-Variable verwenden
Folgende Schritte sind durchzuführen (Abb. Target Browser):
▪
ScopeView2 ”View” -> ”Target Browser” wählen
▪
”Enable Server Ports” wählen (Button oben links)
▪
Im Feld unten links den notierten Port eintragen (s. Abb. ScopeView2 aktivieren)
▪
”Add” und ”OK” bestätigen
▪
Im Target Browser erscheint ein neuer Eintrag ”AdsPort of Image 1”; wählen und mit [+] den Baum anzeigen lassen
▪
Für die verwendete Klemme die Variable ”CH1 SAMPLE 0” bzw ”CH2 SAMPLE 0” wählen und mit [+] den Baum anzeigen lassen
Der letzte Eintrag im Baum beinhaltet die Oversampling Variable (zu erkennen am Index T+Oversampling-Faktor)
Ein Doppelklick auf diese Variable zeigt deren Eigenschaften an. Ein Doppelklick auf die Variable mit dem blauen Kästchen fügt diese in den Objekt Browser ein.
Target Browser
Task erzeugen
Wenn keine PLC aktiv ist, muss eine zusätzliche Task verwendet werden: TwinCAT System Manager: ”SYSTEM – Konfiguration” -> Zusätzliche Task -> Rechte Maustaste ”Task anfügen” -> Rechte Maustaste ”Variable Einfügen”. Variable(n) erzeugen und mit einer Klemme verknüpfen. Bedeutung und Größe der Variablen sind nicht relevant.


Fehlerbeschreibung und Abhilfe

Inbetriebnahme/Konfiguration [image] Fehlerbeschreibung und Abhilfe
Fehlerbeschreibung und Abhilfe
Error Codes
Error Index 0x6000:07 | Underange Index 0x6000:01 | Overrange Index 0x6000:02 | TxPDO State Index 0x6000:0F | Sync Error Index 0x6000:0E | Fehlerbeschreibung | Abhilfe
1 | 1 |  |  |  | Messbereich unterschritten | Eingangspegel reduzieren, Verstärkung ändern (Filter Einstellungen)
1 |  | 1 |  |  | Messbereich überschritten | Eingangspegel reduzieren, Verstärkung ändern (Filter Einstellungen)
1 |  |  |  |  | Messfehler allgemein | z. B. Leitungsbruch
 |  |  |  | 1 | Synchronisierungsfehler | Jitter vom Master zu hoch, Distributed Clocks abgeschaltet
Die Error-LED leuchtet nur bei Drahtbruch.
Fehleranalyse und Beseitigung
Der Dialog zur Einstellung der Abtastrate fehlt
Der Dialog zur Einstellung der Abtastrate fehlt Der TwinCAT System Manager verwendet die „Online description“ der Klemme. Der Hinweis, dass der Dialog zur Parametrierung verwendet werden soll, ist jedoch nur in der XML-Beschreibung vorhanden.
Lösung: Sicherstellen, dass die aktuellste XML-Beschreibung verwendet wird.
Die Amplitude ist zu klein
Filtereinstellung falsch.
Lösung: Im CoE in den Einträgen 0x80n0:15 die Einstellungen korrigieren.
Die Klemme wechselt nach SAFEOP
Die Klemme wechselt nach SAFEOP Die Echtzeit-Einstellungen sind nicht ausreichend genau.
Lösung: PC ohne Mobil-Chipsatz/CPU verwenden.


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Firmware Update EL/ES/EM/EPxxxx

Inbetriebnahme/Konfiguration [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein
Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Scan Boxes
Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes.
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. Änderungsdialog. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einer Beckhoff EtherCAT Box ist eine Batch-Nummer (D-Nummer) aufgelasert. Der Aufbau der D-Nummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. Beckhoff EL5xxx.xml) enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z. B. durch den Beckhoff Support vorliegen.
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei
▪
Nach Beendigung des Download in INIT schalten, dann in OP
▪
Slave kurz stromlos schalten
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.
Dialog Weitere Einstellungen wählen
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,
Dialog Schreibe FPGA wählen
Datei auswählen
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!
Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.