EP3356 - Einkanalige präzise Wägezellenauswertung (Widerstandsmessbrücke), 24 Bit
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
1.1.0
▪
Sicherheitshinweise neues Layout
▪
Update Kapitel Montage und Verkabelung
1.0.4
▪
Technische Daten aktualisiert
▪
EP3356-0022 – Signalanschluss aktualisiert
1.0.3
▪
Grundlagen der Funktion aktualisiert
1.0.2
▪
Anzugsmomente für Steckverbinder aktualisiert
1.0.1
▪
Analoge Spannungseingänge M12 und Bedeutung der LEDs aktualisiert
1.0.0
▪
Erste Veröffentlichung
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EP3356-0022 - Einführung
•
EP3356-0022 - Technische Daten
•
Grundlagen der DMS-Technologie


EP3356-0022 - Einführung

Produktübersicht [image] EP3356-0022 - Einführung
EP3356-0022 - Einführung
EP3356-0022
1-Kanal präzise Wägezellenauswertung (Widerstandsbrücke), 24 Bit
Die EtherCAT Box EP3356 ermöglicht den direkten Anschluss einer Widerstandsbrücke (Dehnungsmessstreifen – DMS) oder Wägezelle in 4-Leiteranschlusstechnik. Das Verhältnis der Brückenspannung UD zur Versorgungsspannung Uref wird in der Eingangsschaltung mit hoher Präzision ermittelt und – anhand der Einstellungen in der EP3356 – der endgültige Lastwert als Prozesswert berechnet. Mit automatischer Selbstkalibrierung (deaktivierbar), dynamischen Filtern, Distributed-Clocks-Unterstützung und einer Abtastrate von bis zu 100 µs eignet sich die EP3356 besonders für die schnelle und präzise Erfassung von Drehmoment- oder Schwingungssensoren.
Installation
Konfiguration


EP3356-0022 - Technische Daten

Produktübersicht [image] EP3356-0022 - Technische Daten
EP3356-0022 - Technische Daten
Technische Daten | EP3356-0022
Anzahl analoge Eingänge | 2, für 1 Brückenschaltung in Vollbrückentechnik
Signalanschluss | M12
Auflösung | 24 Bit, Darstellung 32 Bit
Wandlungszeit | 0,1 ms…250 ms, konfigurierbar, max. 10.000 Samples/s
Nennspannung | 24 VDC (-15 %/+20 %)
Distributed Clocks | ja
Umschaltbare Modi | ja (2)
Messfehler | < ±0,01 % für den berechneten Lastwert bezogen auf den Lastendwert bei 12 V Speisung und 24 mV Brückenspannung (somit Nennkennwert DMS: 2 mV/V), Selbstkalibrierung aktiv, 50 Hz Filter aktiv. Achtung: Durch externe Einflüsse wie Temperaturdrifts und HF-Störungen kann ggf. ein nicht unerheblicher Fehler entstehen!
Messbereich UD | max. -27 mV…+27 mV typ. (siehe Hinweis zu Spannungsmessung) empfohlen: -25 mV…+25 mV Nennspannung
Messbereich Uref | max. -13,8 V…+13,8 V typ. (siehe Hinweis zu Spannungsmessung) empfohlen: -12 V…+12 V Nennspannung
unterstützte Nennkennwerte | Beliebig, Auflösung des Parameters: 0,01 µV/V Empfohlen: 0,5 mV/V …4 mV/V
min. DMS Widerstand | Parallelbetrieb von DMS nur mit entsprechend geeigneten DMS empfohlen
Grenzfrequenz Eingangsfilter (Hardware) | 10 kHz Tiefpass (-3 dB, siehe Filterhinweise)
Filter (Software) | Voreinstellung 50 Hz, konfigurierbar: 50/60 Hz FIR Notchfilter, IIR Tiefpass 4-fach Averager
Innenwiderstand | >200 kΩ (Uref), >1 MΩ (Ud)
Besondere Eigenschaften | Autokalibrierung, 4-fach Averager, dynamische Filter, schnelle Messwerterfassung, Parallelschaltung
Sensorversorgung | Uref= 10 V (wird in der EP3356 erzeugt)
Stromaufnahme aus US (ohne Sensorstrom) | 120 mA
Anschluss Spannungsversorgung | Einspeisung: 1 x M8-Stecker, 4-polig Weiterleitung: 1 x M8-Buchse, 4-polig
Zulässige Umgebungstemperatur im Betrieb | -25°C…+60°C 0°C ... +55°C (gemäß cULus, siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C…+85°C
Vibrations- / Schockfestigkeit | gemäß EN 600068-2-6 / EN600068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Abmessungen | 126 mm x 60 mm x 40 mm
Gewicht | ca. 450 g
Einbaulage | beliebig
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Zulassungen | CE, UL


Grundlagen der DMS-Technologie

Produktübersicht [image] Grundlagen der DMS-Technologie
Grundlagen der DMS-Technologie
Es sollen im Folgenden einige grundsätzliche Informationen zum Technologiebereich „DMS/Wägezellen“ als metrologisches Instrument gegeben werden. Diese sind von allgemeiner Natur, es ist vom Anwender zu prüfen, inwieweit diese Hinweise auf seine Applikation zutreffen.
▪
Dehnungsmessstreifen (DMS) dienen dazu, entweder unmittelbar durch Fixierung auf einem Körper dessen statischen (0 bis wenige Hz) oder dynamischen (bis mehrere kHz) Dehnungen, Stauchungen oder Torsionen aufzunehmen. Oder aber mittelbar als Teil eines Sensors verschiedene Kräfte oder Bewegungen zu erfassen (z.B. Wägezellen/Kraftaufnehmer, Wegaufnehmer, Schwingungssensoren).
▪
Bei optischen DMS (z. B. Bragg-Gitter) bewirkt eine Krafteinwirkung auf eine als Sensor genutzte Faser eine proportionale Veränderung von deren optischen Eigenschaften. Es wird Licht mit einer bestimmten Wellenlänge in den Sensor geleitet. Je nach Verformung des in den Sensor eingelaserten Gitters durch die mechanische Beanspruchung wird ein Teil des Lichts reflektiert und mit einem geeigneten Messwertaufnehmer (Interrogator) ausgewertet.
Das am weitesten verbreitete Prinzip im industriellen Umfeld ist der elektrische DMS. Es sind viele Begriffe für diese Art von Sensoren üblich: Wägezelle, Lastmessdose, Wiegebrücke etc.
Aufbau elektrischer DMS
Ein DMS besteht aus einem Trägermaterial (z.B. dehnbare Kunststofffolie) mit aufgebrachter Metallfolie, aus welchem –je nach Anforderung in sehr verschiedenen geometrischen Formen- ein Gitter aus elektrisch leitfähigem Widerstandsmaterial herausgearbeitet wird.
DMS
Dabei wird das Verhalten ausgenutzt, dass z.B. bei Dehnung eines metallischen Widerstandsleiters seine Länge zu-, und der Durchmesser abnimmt, wodurch schließlich sein elektrischer Widerstand proportional steigt.
ΔR/R = k*ε
Dabei entspricht ε = Δl/l der Längendehnung, die Dehnungsempfindlichkeit wird als k-Faktor bezeichnet. Daraus resultiert auch die charakteristische Bahnführung innerhalb des DMS: die Widerstandsbahn wird mäanderförmig "in Schlangenlinien" verlegt, um eine möglichst lange Strecke der Dehnung auszusetzen.
Beispiel
Die Dehnung von ε = 0,1% eines DMS mit k-Faktor 2 bewirkt eine Widerstandserhöhung um 0,2%. Typische Widerstandsmaterialien sind Konstantan (k~2) oder Platin Wolfram (92PT, 8W mit k ~4). Bei Halbleiter-DMS wird eine Siliziumstruktur auf ein Trägermaterial geklebt. Die Leitfähigkeit wird primär durch Deformation des Kristallgitters verändert (piezoresistiver Effekt), es können k-Faktoren bis 200 erreicht werden.
Messung von Signalen
Die Widerstandsänderung eines einzelnen DMS kann grundsätzlich durch Widerstandsmessung (Strom-/Spannungsmessung) in 2/3/4-Leitermessung ermittelt werden
Üblicherweise werden 1/2/4 DMS in einer wheatstoneschen Brücke angeordnet (-> Viertel-/Halb-/Vollbrücke), dabei ist der Nennwiderstand/Impedanz R0 aller DMS (und der ggf. verwendeten Ergänzungswiderstände) üblicherweise gleich R1=R2=R3=R4=R0. Im unbelasteten Zustand sind typische Werte R0 = 120 Ω, 350 Ω, 700 Ω und 1 kΩ.
Die Vollbrücke besitzt die besten Eigenschaften wie Linearität bei Strom-/Spannungsspeisung, 4-fache Empfindlichkeit gegenüber der Viertelbrücke, sowie systematische Kompensation von Störeinflüssen wie Temperaturdrift und Kriechen. Um die hohe Empfindlichkeit zu erreichen werden dabei die 4 einzelnen DMS auf dem Träger so angeordnet, dass je 2 gedehnt und 2 gestaucht werden.
Viertel-, Halb-, und Vollbrücke
Die Messbrücken können mit Konstantstrom, Konstantspannung, oder aber mit Wechselspannung im Trägerfrequenzverfahren betrieben werden.
Messverfahren
Die Beckhoff Klemmen EL/KL335x und das Box-Modul EP3356 unterstützen nur die Konstanterregung
Vollbrücken-DMS an Konstantspannung (ratiometrische Messung)
Da die relative Widerstandsänderung ΔR im Verhältnis zum Nennwiderstand R0 gering ist, wird für DMS in der wheatstoneschen Anordnung eine vereinfachte Gleichung angegeben:
UD/UV = ¼ * (ΔR1-ΔR2+ΔR3-ΔR4)/R0
Bei Dehnung hat ΔR in der Regel ein positives, bei Stauchung ein negatives Vorzeichen.
Eine geeignete Messeinrichtung misst die Brückenversorgungsspannung UV (bzw. USupply) und die resultierende Brückenspannung UD (bzw. UBridge), und bildet den Quotienten aus beiden Spannungen, also das Verhältnis (lateinisch: "ratio"). Nach weiterer Berechnung und Skalierung erfolgt die Ausgabe des Messwertes z.B. in kg. Aufgrund der Division von UD und UV ist die Messung grundsätzlich unabhängig von Änderungen der Versorgungsspannung.
Werden die Spannungen UV und UD dabei simultan, d.h. im gleichen Moment gemessen und ins Verhältnis gesetzt, so spricht man deshalb von einer ratiometrischen Messung.
Der Vorteil liegt darin, dass (bei simultaner Messung!) auch kurzzeitige Veränderungen der Versorgungsspannung (z.B. EMV-Einflüsse) oder eine allgemein nicht ganz exakte oder stabile Versorgungsspannung ebenfalls keinen Einfluss auf die Messung haben.
Eine Änderung von UV um z.B. 1 % erzeugt nach der obigen Gleichung die gleiche prozentuale Änderung an UD. Durch die simultane Messung von UD und UV kürzt sich der Fehler bei der Division vollständig heraus.
4-Leiter- vs. 6-Leiter-Anschluss
Bei Versorgung mit einer konstanten Spannung von 5 … 12 V fließt ein nicht unerheblicher Strom von z.B.12 V/350 Ω = 34,3 mA. Dadurch entsteht nicht nur Verlustwärme, wobei die Spezifikation des verwendeten DMS nicht überschritten werden darf, sondern es können Messfehler bei unzureichender Verdrahtung durch nicht berücksichtigte oder nicht kompensierbare Leitungsverluste entstehen.
Grundsätzlich kann eine Vollbrücke in Vierleiterschaltung betrieben werden (2 Leitungen für die Versorgung UV, und 2 Leitungen für die Messung der Brückenspannung UD).
Bei Verwendung von z.B. 25 m Kupferleitung (hin + zurück = 50 m) mit einem Querschnitt von q = 0,25 mm² ergibt dies einen Leitungswiderstand von:
RL = l/ (κ * q) = 50 m / (58 S*m/mm² * 0,25 mm²) = 3,5 Ω
Bleibt dieser Wert konstant, so kann der dadurch entstehende Fehler herauskalibriert werden. Aber unter Annahme einer realitätsnahen Temperaturänderung von z. B. 30° ändert sich der Leitungswiderstand RL um:
ΔRL =30° * 3,9 * 10-4 * 3,5 Ω = 0,41 Ω
Bezogen auf eine 350 Ω Messbrücke bedeutet dies einen Messfehler von > 0,1%
4-Leiter-Anschluss
Abhilfe schafft besonders bei Präzisionsanwendungen ein 6-Leiter-Anschluss (Nur mit den EL3356 möglich).
6-Leiter-Anschluss
Dabei wird die Versorgungsspannung UV an die DMS herangeführt (= stromführende Leitung). Erst direkt an der Messbrücke wird die ankommende Versorgungsspannung als Referenzspannung Uref genauso wie die Brückenspannung UD mit je zwei stromlosen Rückleitern hochohmig gemessen. Somit entfallen die leitungsbedingten Fehler.
Da es sich um sehr kleine Spannungspegel handelt im mV und µV-Bereich, sollten alle Leitungen geschirmt sein und der Schirm an Pin 5 des M12-Steckverbinders angeschlossen sein.
EP3356-0022: Kein 6-Leiter-Anschluss notwendig
Mit der EP3356-0022 genügt der Anschluss einer DMS über 4-Leiter, da aufgrund der kurzen Leitungslängen keine Messfehler auftreten.
Aufbau einer Wägezelle mit DMS
Eine Anwendung der DMS ist der Aufbau von Wägezellen (WZ).
Dabei werden DMS (in der Regel Vollbrücken) auf einen elastischen mechanischen Träger, z. B. Doppelbiegebalken-Federkörper, geklebt und gegen Umwelteinflüsse zusätzlich abgedeckt.
Die einzelnen DMS werden für maximale Ausgangssignale entsprechend der Beanspruchungsrichtung ausgerichtet (dabei 2 DMS in Dehnungsrichtung und 2 in Stauchungsrichtung).
Beispiel-Wägezelle
Kenndaten
Bitte informieren Sie sich beim Sensorhersteller über die genauen Kenndaten!
Nennlast Emax
Maximal zulässige Belastung für normalen Betrieb, z. B. 10 kg
Nennkennwert mV/V
Der Nennkennwert 2 mV/V bedeutet, dass bei einer Versorgung mit US=10 V und bei voller Belastung Emax der Wägezelle die maximale Ausgangsspannung UD = 10 V * 2 mV/V *E = 20 mV beträgt. Der Nennkennwert ist immer ein nomineller Wert - bei guten Wägezellen ist ein Herstellerprüfprotokoll beigegeben, das den für die einzelne Wägezelle ermittelten Kennwert mitteilt, z. B. 2.0782 mV/V.
Mindesteichwert Vmin
Gibt die kleinste Masse an die gemessen werden kann, ohne dass der maximal zulässige Fehler der WZ überschritten wird [RevT].
Dieser Wert wird entweder durch die Formel Vmin = Emax / n dargestellt (mit n als ganzzahligem Wert z.B. 10000), oder in %von Emax (z. B. 0,01).
Dies bedeutet, dass eine Wägezelle mit Emax = 10 kg eine maximale Auflösung von
Vmin = 10 kg / 10000 = 1 g bzw. Vmin = 10 kg * 0,01 % = 1 g hat.
Genauigkeitsklasse nach OIML R60
Die Genauigkeitsklasse wird durch einen Buchstaben (A, B, C, D) und eine zusätzliche Ziffer angegeben, welche den Teilungswert d mit einer maximalen Anzahl nmax verschlüsselt (*1000), z.B. C4 bedeutet Klasse C mit maximal 4000d Teilungswerten.
Die Klassen geben eine Höchst- und Mindestgrenze für Teilungswerte d vor:
▪
A: 50.000 – unbegrenzt
▪
B: 5000 – 100.000
▪
C 500 – 10.000
▪
D: 500 - 1000
Der Teilungswert nmax = 4000d sagt aus, dass mit einer WZ mit einer Auflösung von Vmin = 1 g eine eichfähige Waage gebaut werden kann, welche einen maximalen Messbereich von 4000d * Vmin = 4 kg hat. Da Vmin dabei eine Mindestangabe ist, könnte – wenn es die Anwendung zulässt – mit der gleichen WZ eine 8 kg Waage gebaut werden, wobei dann die (eichfähige) Auflösung auf 8 kg / 4000d = 2 g sinkt. Anders betrachtet ist der Teilungswert nmax eine Maximalangabe, so könnte mit o. g. Wägezelle eine Waage mit Messbereich 4 kg, aber nur einer Auflösung von 2000 Teilen = 2 g gebaut werden, wenn dies für die jeweilige Anwendung ausreichend ist. Es unterscheiden sich auch die Klassen in bestimmten Fehlergrenzen bezogen auf Nichtwiederholbarkeit/Kriechen/TK.
Genauigkeitsklasse nach PTB
In fast gleichlautender Weise sind die europäischen Genauigkeitsklassen definiert (Quelle: PTB).
Klasse | Eichwerte | Mindestlast | Max/e
 |  |  | Mindestwert | Höchstwert
| Feinwaage | 0,001 g <= e | 100 e | 50000 | -
|| Präzisionswaage | 0,001 g <= e <= 0,05 g 0,1 g <= e | 20 e 50 e | 100 5000 | 100000 100000
||| Handelswaage | 0,1 g <= e <= 2 g 5 g <= e | 20 e 20 e | 100 500 | 10000 10000
|||| Grobwaage | 5 g<= e | 10 e | 100 | 1000
Mindestanwendungsbereich bzw. Mindestmessbereich % v. Nennlast
Dies ist der minimale Messbereich/Messbereichsintervall, welchen eine eichfähige Wägezelle/Waage abdecken muss.
Beispiel: obige Wägezelle Emax = 10 kg; Mindestanwendungsbereich z. B. 40 % Emax
Der genutzte Messbereich der WZ muss mindestens 4 kg sein. Der Mindestanwendungsbereich kann in einem beliebigen Bereich zwischen Emin und Emax liegen, z. B. zwischen 2 kg und 6 kg, wenn schon aufbaubedingt eine Taramasse von 2 kg vorliegt. Es ist dabei ebenfalls ein Zusammenhang mit nmax und Vmin ersichtlich: 4000 * 1 g = 4 kg.
Es gibt weitere wichtige Kennwerte, die weitestgehend selbsterklärend sind, und daher hier nicht weiter besprochen werden, wie Nennkennwerttoleranz, Eingangs-/Ausgangswiderstand, Empfohlene Versorgungsspannung, Nenntemperaturbereich etc.
Parallelschaltung von DMS
Es ist üblich, eine Last mechanisch auf mehreren DMS-Wägezellen gleichzeitig zu verteilen. Damit kann. z.B. eine 3-Punkt-Lagerung eines Silobehälters auf 3 Wägezellen realisiert werden. Unter Berücksichtigung von Windlasten und Beladungsdynamik kann somit die Gesamtbeladung des Silos inkl. Behältereigenlast gemessen werden. Die mechanisch parallel geschalteten Wägezellen werden üblicherweise auch elektrisch parallel geschaltet und an z. B. zwei beliebige M12-Buchsen der EP3356-0022 angeschlossen (siehe nachfolgende Abbildung). Dazu ist zu beachten:
▪
die Wägezellen müssen für diesen Betrieb aufeinander abgeglichen und vom Hersteller freigegeben sein
▪
die Impedanz der Wägezellen muss so beschaffen sein, dass die Stromspeisefähigkeit der Aufnehmerelektronik (max. 350 mA) nicht überlastet wird.
Parallelschaltung von DMS
Fehlerquellen/Störgrößen
Elektrisches Eigenrauschen der Wägezelle
Elektrische Leiter besitzen ein sogenanntes Wärmerauschen (thermisches/Johnson Rauschen), welches durch unregelmäßige temperaturabhängige Bewegungen der Elektronen im Leiterwerkstoff hervorgerufen wird. Bereits durch diesen physikalischen Effekt wird die Auflösung des Brückensignals beschränkt. Der Effektivwert en des Rauschens kann berechnet werden mit en = √4kTRB.
Bei einer Wägezelle mit R0 = 350 Ω bei Umgebungstemperatur T = 20 °C (= 293 K) und einer Bandbreite des Messwertaufnehmers von 50 Hz (und Boltzmannkonstante k = 1,38 * 10-23 J/K) beträgt der Effektivwert en= 16,8 nV. Das peak-peak-Rauschen epp beträgt somit etwa epp ~ 4* en = 67,3 nV.
Beispiel:
Bezogen auf die maximale Ausgangsspannung Uoutmax einer Brücke mit 2 mV/V und US = 5 V entspricht dies Uout-max = 5 V * 2 mV/V = 10 mV (für die Nennlast) ergibt dies eine maximale Auflösung von 10 mV / 67,3 nV = 148588 digits. In Bit-Auflösung umgerechnet: ln(148588)/ln(2) = 17 bit. Interpretation: eine höhere digitale Messauflösung als 17 Bit ist für ein solches analoges Signal also im ersten Schritt nicht angebracht. Wird eine höhere Messauflösung eingesetzt, sind ggf. zusätzliche Maßnahmen in der Auswertekette zu treffen, um den höheren Informationsgehalt aus dem Signal zu gewinnen, z. B. Hardwaretiefpassfilter oder Softwarealgorithmen.
Diese Auflösung gilt allein für die Messbrücke ohne jegliche weiteren Störeinflüsse. Durch Reduzierung der Bandbreite der Messeinrichtung kann die Auflösung des Messsignals gesteigert werden.
Wird der DMS auf einen Träger aufgeklebt (Wägezelle) und verdrahtet, können sowohl elektrische Störungen von außen (z. B. Thermospannungen an Anschlussstellen), als auch in der näheren Umgebung vorhandene mechanische Schwingungen (Maschinen, Antriebe, Transformatoren (mechanische und hörbare 50 Hz-Schwingung durch Magnetostriktion etc.)) das Messergebnis zusätzlich beeinträchtigen.
Kriechen
Bei konstanter Belastung können sich Federwerkstoffe weiter in Belastungsrichtung verformen. Dieser Vorgang ist reversibel, erzeugt aber während der statischen Messung einen sich langsam ändernden Messwert. Durch konstruktive Maßnahmen (Geometrie, Klebewerkstoffe) kann der Fehler im Idealfall kompensiert werden.
Hysterese
Erfolgt eine gleichmäßige Dehnung und Stauchung der Wägezelle, so durchläuft die Ausgangsspannung nicht exakt die gleiche Kennlinie, da u. a. bedingt durch den Klebwerkstoff und dessen Schichtdicke die Verformung von DMS und Träger unterschiedlich sind.
Temperaturdrift (Eigenerwärmung, Umgebungstemperatur)
Bei DMS-Anwendungen können relativ große Ströme fließen, z. B. I = US/R0 = 10 V / 350 Ω = 26 mA. Die Verlustleistung beträgt somit am Sensor Pv = U*I = 10 V * 26 mA = 260 mW. Je nach Anwendung/Trägermaterial (= Kühlung) und Umgebungstemperatur kann ggf. ein nicht unerheblicher Fehler entstehen, welcher als scheinbare Dehnung bezeichnet wird. Die Sensorhersteller integrieren entsprechende Kompensationselemente in Ihre DMS ein.
Unzureichende Schaltungstechnik
Wie bereits aufgezeigt; kann eine Vollbrücke Nichtlinearität, Kriechen und Temperaturdrift systembedingt u. U. vollständig kompensieren. Verdrahtungsbedingte Messfehler werden durch die 6-Leiterschaltung umgangen.
Referenzen
Im Folgenden sind einige Organisationen genannt die Vorgaben oder Dokumente für den Technologiebereich Wägetechnik bereitstellen:
▪
OIML (ORGANISATION INTERNATIONALE DE MÉTROLOGIE LÉGALE) www.oiml.org
▪
PTB - Physikalisch-Technischen Bundesanstalt www.ptb.de/cms/
▪
www.eichamt.de
▪
WELMEC - European cooperation in legal metrology www.welmec.org/
▪
DAkkS – Deutsche Akkreditierungsstelle www.dakks.de
▪
Fachgemeinschaft Waagen (AWA) im Verband Deutscher Maschinen- und Anlagenbau VDMA http://www.vdma.org/


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT Grundlagen
•
Watchdogeinstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT Grundlagen

Grundlagen der Kommunikation [image] EtherCAT Grundlagen
EtherCAT Grundlagen
Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


Watchdogeinstellung

Grundlagen der Kommunikation [image] Watchdogeinstellung
Watchdogeinstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen und die EPxxxx Box-Module sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme/Box zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme/Box statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme/Box bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT--> Erweiterte Einstellungen-->Verhalten--> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist. Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmen-/Boxentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40 ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0...~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Vorsicht! Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Vorsicht! Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand – je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand. Die Inputdaten werden aber zyklisch aktualisiert.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind:
▪
Index 0…65535
▪
Subindex: 0…255
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexadezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind:
▪
0x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier liegen in manchen EtherCAT-Geräten alternativ zum 0x8000-Bereich die Kanalparameter.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i. d. R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis.
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter CoE-Online
In der vorherigen Abbildung sind die im Beispiel-gerät „EL2502“ verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zu sehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (vorherige Abbildung) durch Anklicken. Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im Dialog SetValue ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek. Dies wird für Änderungen während der Anlagenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart sind die veränderten CoE-Parameter immer noch erhalten. Andere Hersteller können dies anders handhaben.
StartUP-Liste
StartUP-Liste
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Werte nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im System Manager vornehmen. Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen. Die Reihenfolge der StartUp-Einträge ist dabei i. d. R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom System Manager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abbildung „Karteireiter CoE-Online“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
Wenn der Slave offline ist
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
Wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt.
–
Ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z. B. hat eine 4 kanalige Analogeingangsklemme 0 ... 10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
…
Allgemein wird dies geschrieben als 0x80n0. Ausführliche Hinweise zum Coe-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
EtherCAT
•
Spannungsversorgung
•
Verkabelung
•
UL-Anforderungen
•
ATEX-Hinweise


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder
•
Zusätzliche Prüfungen


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Montage und Verkabelung [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


Zusätzliche Prüfungen

Montage und Verkabelung [image] Montage [image] Zusätzliche Prüfungen
Zusätzliche Prüfungen
Die Boxen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3 Achsen
 | 5 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3 Achsen
 | 35 g, 11 ms


EtherCAT

Montage und Verkabelung [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs


EtherCAT-Anschluss

Montage und Verkabelung [image] EtherCAT [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Montage und Verkabelung [image] EtherCAT [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (http://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Spannungsversorgung

Montage und Verkabelung [image] Spannungsversorgung
Spannungsversorgung
Weiterführende Informationen
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Leitungsverluste M8
•
Leitungsverluste 7/8"


Power-Anschluss

Montage und Verkabelung [image] Spannungsversorgung [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u.U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Verkabelung [image] Spannungsversorgung [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Leitungsverluste M8

Montage und Verkabelung [image] Spannungsversorgung [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Leitungsverluste 7/8"

Montage und Verkabelung [image] Spannungsversorgung [image] Leitungsverluste 7/8"
Leitungsverluste 7/8"
Bei den Powerkabeln ZK2030-xxxx-yyyy sollten 15 m Gesamtlänge bei 16 A nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
ZK2030-xxxx-yyyy - Leitungsverluste
Alternativ können auch höhere Leitungsquerschnitte von z.B. 2.5 mm2 eingesetzt werden.


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: https://beckhoff.de/german/fieldbus_box/ethercat_box_accessories_overview.htm?id=25525466903389
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link:
https://beckhoff.de/german/ethercat-box/ethercat_box_cables.htm?id=690338951657421
EtherCAT-Kabel
ZK1090-3131-0xxx
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
Powerkabel
ZK2020-3132-0xxx
Sensorkabel
Sensorkabel - Beckhoff.png
Auswahl von Beckhoff-Sensorkabel


UL-Anforderungen

Montage und Verkabelung [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Montage und Verkabelung [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000-0000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Montage und Verkabelung [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

Montage und Verkabelung [image] ATEX-Hinweise [image] BG2000-0000 - Schutzgehäuse für EtherCAT Box
BG2000-0000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.
BG2000-0000, Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000-0000, Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.
BG2000-0000, Schutzgehäuse montieren


ATEX-Dokumentation

Montage und Verkabelung [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


EP3356-0022 - Signalanschluss

EP3356-0022 - Signalanschluss
EP3356-0022 - Signalanschluss
Weiterführende Informationen
•
Analoge Spannungseingänge M12 und Bedeutung der LEDs


Analoge Spannungseingänge M12 und Bedeutung der LEDs

EP3356-0022 - Signalanschluss [image] Analoge Spannungseingänge M12 und Bedeutung der LEDs
Analoge Spannungseingänge M12 und Bedeutung der LEDs
1-Kanal präzise Wägezellenauswertung
Der analoge Eingang ermöglicht den direkten Anschluss einer Widerstandsbrücke (Dehnungsmessstreifen – DMS) oder Wägezelle in 4-Leiteranschlusstechnik.
Analoger Spannungseingang M12, Widerstandsbrücke
Der Schirm muss an Pin 5 des M12-Steckverbinders angeschlossen werden.
Ein Beispiel zu der Parallelschaltung von DMS finden Sie hier.
Die Spannung Uref beträgt 10 V und wird in der EP3356-0022 erzeugt.
Sensor-Kabelschirm sensorseitig nicht erden
Sofern ein geschirmtes Sensorkabel verwendet wird, sollte es auf der Sensorseite nicht geerdet werden. In bestimmten Anlagenkonfigurationen kann es sonst unter Umständen zu Messabweichungen kommen.
Bedeutung der LEDs
LEDs EP3356-0022
LED
Farbe
Bedeutung
RUN
grün
Diese LED gibt den Betriebszustand der Klemme/Box wieder:
aus
Zustand der EtherCAT State Machine: INT = Initialisierung der Klemme/Box
blinkend
Zustand der EtherCAT State Machine: PREOP = Funktion der Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
Einzelblitz
Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
an
Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation möglich
flimmernd
Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme/Box
Measure
grün
EIN
Messung aktiv (Prozessdaten sind gültig)
AUS
▪
Kalibrierung aktiv (wenn die LED Calibr. Leuchtet) oder
▪
Prüfung aktiv (wenn die LED Test leuchtet)
▪
Filter warden initialisiert
Steady state
grün
EIN
Der Messwert ist stabil
AUS
Der Messwert ist nicht stabil
Self Calibr.
grün
EIN
▪
Kalibrierung aktiv
▪
Prozessdaten sind nicht gültig
Self Test
grün
EIN
▪
Selbsttest aktiv
▪
Prozessdaten sind nicht gültig
Error Dif
rot
EIN
▪
Kanal 1 (DMS-Differenzsigna) ober- oder unterhalb des gültigen Wertebereiches
▪
interne Referenzspannung von Kanal 1 fehlt
Error Ref
rot
EIN
▪
Kanal 2 (DMS-Referenzsignal) ober- oder unterhalb des gültigen Wertebereiches
▪
Interne Referenzspannung von Kanal 2 fehlt
▪
Referenzspannung zu klein (zwischen -1 V und +1 V)


Inbetriebnahme/Konfiguration

Inbetriebnahme/Konfiguration
Inbetriebnahme/Konfiguration
Weiterführende Informationen
•
Konfigurationserstellung TwinCAT - Manuell
•
Konfigurationserstellung TwinCAT - Online scan
•
Prozessdaten Einstellungen EtherCAT Slave (PDO)
•
Konfiguration mit TwinCAT
•
Grundlagen zur Funktion
•
Anwendungshinweise
•
Kalibrierung und Abgleich
•
Hinweise zur analogen Spezifikation
•
Spannungsmessung
•
Distributed Clocks Betrieb (nur EL3356-0010 und EP3356-0022)
•
Prozessdaten
•
CoE - Objektbeschreibung und Parametrierung
•
Beispielprogramm
•
Wiederherstellen des Auslieferungszustandes


Konfigurationserstellung TwinCAT - Manuell

Inbetriebnahme/Konfiguration [image] Konfigurationserstellung TwinCAT - Manuell
Konfigurationserstellung TwinCAT - Manuell
In diesem Teil der Dokumentation wird die manuelle Konfiguration einer EtherCAT-Box in TwinCAT beschrieben.
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie nachfolgend unter Konfigurationserstellung TwinCAT - Manuell beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen. Dieser Test kann in den erweiterten Device-Einstellungen parametriert werden.
Damit die aktuellsten Features/Einstellungen des Masters genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…)
Update EtherCAT Device Description 1439726603
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E_A-Gerätes
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP6224-2022), bestätigen Sie mit OK.
Auswahl einer Box
Auswahl einer Box (z.B.: EP6224-2022)


Konfigurationserstellung TwinCAT - Online scan

Inbetriebnahme/Konfiguration [image] Konfigurationserstellung TwinCAT - Online scan
Konfigurationserstellung TwinCAT - Online scan
In diesem Teil der Dokumentation wird die Konfiguration einer physisch vorhandenen EtherCAT-Box in TwinCAT beschrieben.
Online Konfigurationserstellung „Scannen“ (TwinCAT 3.x)
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, Box-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden (wie unter Konfigurationserstellung TwinCAT - Manuell beschrieben ist). Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang. In jedem Fall prüft die EtherCAT-Box bei jedem realen Hochlauf, ob die vorgefundenen Geräte der Konfiguration entsprechen.
Damit die aktuellsten Features/Einstellungen der EtherCAT-Box genutzt werden können, sollte immer die aktuellste ESI-Datei heruntergeladen werden. Beachten Sie bitte deshalb den nachfolgenden Hinweis.
Installation der neusten ESI-XML-Device-Description
Der TwinCAT Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Die Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140). Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen. TwinCAT bringt bei der Installation die Beckhoff-ESI-Dateien mit, die zum Erstellungszeitpunkt des TwinCAT builds aktuell waren. Ab TwinCAT 2.11 und in TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (TwinCAT → EtherCAT-Devices → Update Device Description…) Update EtherCAT Device Description 1439726603
Zur Konfigurationserstellung
▪
muss die reale EtherCAT- und IO-Link-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
die Geräte/Module müssen über EtherCAT-Kabel und IO-Link-Kabel so verbunden sein wie sie später eingesetzt werden sollen.
▪
die Geräte/Module müssen mit Energie versorgt werden und kommunikationsbereit sein.
▪
TwinCAT muss auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer- Dieser Schritt kann auch unabhängig vom vorherigen Schritt durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.
Erkennen/Scan des EtherCAT Geräts
Befindet sich das TwinCAT-System im Config-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.
TwinCAT Anzeige Config-Modus
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.
Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.
TwinCAT target und local System
Im Konfigurationsbaum bringt Sie ein Rechtsklick auf den Punkt „I/O Devices“ zum Such-Dialog.
Scan Devices
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer Gerätescan
Hinweis automatischer Gerätescan
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Gerät angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
erkannte Ethernet-Geräte
Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen (siehe nachfolgende Abbildung).
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Information des EtherCAT Devices aus dem Device-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan for Boxes
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes
Die Konfiguration wurde aufgebaut und direkt in den Online-Zustand (OPERATIONAL) versetzt. Das EtherCAT System sollte sich in einem funktionsfähigen zyklischen Betrieb, wie in der nachfolgenden Abbildung dargestellt, befinden.
beispielhafte Online-Anzeige
Zu beachten sind:
▪
Alle Boxen sollten im OP-State sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Wie in der nachfolgenden Abbildung sichtbar, wird die angeschlossene EtherCAT-Box (EP6224-3022) im TwinCAT Baum angezeigt.
Master-Anzeige_Nach Scan for Boxes
Master-Anzeige nach „Scan for boxes“
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Device für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen.
▪
Teilnehmer werden nicht richtig erkannt
Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Device hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Scan über bestehender Konfiguration
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Configuration is identical
Identische Konfiguration
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Beispiel-Korrekturdialog
Es wird empfohlen das Häkchen „Extended Information“ zu setzen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe | Erläuterung
grün | dieses EtherCAT Device findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau | dieses EtherCAT Device ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich. Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau | dieses EtherCAT Device wird ignoriert (Button "Ignore")
rot | dieses EtherCAT Device ist auf der Gegenseite nicht vorhanden.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Device/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:
Geräte-Revision in der Anlage >= Geräte Revision in der Konfiguration
Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich). Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Beispiel-Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch „OK“ in die reale *.tsm-Konfiguration übernommen werden.


Prozessdaten Einstellungen EtherCAT Slave (PDO)

Inbetriebnahme/Konfiguration [image] Prozessdaten Einstellungen EtherCAT Slave (PDO)
Prozessdaten Einstellungen EtherCAT Slave (PDO)
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (Process Data Objects, PDO) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL/ES/EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation. Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch den erfolgreichen Hochlauf des Slaves. Es wird abgeraten, andere als die vorgesehenen Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist laut Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden (siehe nachfolgende Abbildung).
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data" in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als verlinkbare Variablen im Systemmanager sichtbar. Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten1
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann laut ESI-Beschreibung ein PDO als „fixed“ mit einem Flag „F“ gekennzeichnet sein (siehe vorherige Abbildung, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet („Edit“). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration „G“ unterstützt. Bei falscher konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen „invalid SM cfg“ wird im Systemmanager ausgegeben:
`Box 1 (EP3356)` (0022): state change aborted (requested ‚SAFEOP`, back to ‚PREOP`), `Box1 (EP3356)` (0022): `PREOP to SAFEOP`failed! Error: `check device state for SAFEOP`, AL Status `0x0012`read and 0x0004` expected. AL Status code `0x001e – Invalid SM IN cfg` Diese Fehlermeldung „invalid SM IN cfg“ oder „invalid SM OUT cfg“ bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.


Konfiguration mit TwinCAT

Inbetriebnahme/Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Grundlagen zur Funktion

Inbetriebnahme/Konfiguration [image] Grundlagen zur Funktion
Grundlagen zur Funktion
EL/EP3356 und Sonderversionen
Wenn nicht anders genannt, bezieht sich die Angabe „EL/EP3356“ immer auch auf die Sonderversionen wie z. B. EL3356-0010 und EP3356-0022.
Die Messfunktionen der EL/EP3356 lassen sich wie folgt beschreiben:
▪
Mit der Analogeingangsklemme EL3356 oder der Analogeingangsbox EP3356 wird die Versorgungsspannung einer Wägezelle als Referenzspannung und auch die der Krafteinwirkung proportionalen Differenzspannung erfasst.
▪
Es muss eine Vollbrücke angeschlossen werden. Steht nur eine Viertel- oder Halbbrücke zur Verfügung, müssen externe Ergänzungsbrücken hinzugefügt werden. Der Nennkennwert ist dann entsprechend zu modifizieren.
▪
Die Messung der Referenz- und Differenzspannung erfolgt zeitgleich
▪
Da die beiden Spannungen gleichzeitig gemessen werden, ist grundsätzlich keine hochgenaue Referenzspannung in Bezug auf den Pegel notwendig. Mit Änderung der Referenzspannung ändert sich im gleichen Maße die Differenzspannung über die Vollbrücke. Daher sollte hier eine stabilisierte Referenzspannung verwendet werden, die nur geringen Schwankungen unterliegt (z. B. mit der Versorgungsklemme EL95xx)
▪
Die Veränderung des Quotienten aus Differenz- und Referenzspannung entspricht der relativen Krafteinwirkung auf die Wägezelle.
▪
Der Quotient wird in Gewicht umgerechnet und als Prozessdatum ausgegeben.
▪
Die Datenverarbeitung unterliegt folgenden Filtervorgängen:
–
der Analogwandler (ADC) integriert über 76 Samples
–
Mittelwertbildung im Averager (wenn aktiviert)
–
Softwarefilter IIR/FIR (wenn aktiviert)
▪
Die EL/EP3356 verfügt über einen automatischen Abgleich/Selbstkalibrierung
–
Default-Zustand: aktivierte Selbstkalibrierung, Durchführung alle 3 Minuten
–
Abweichungen der verwendeten Analogeingangsstufen (Temperatur-, Langzeitdrift usw.) werden durch automatische regelmäßige Kalibrierungen überprüft und innerhalb des zulässigen Toleranzbereiches ausgeglichen.
–
die Automatik ist abschaltbar bzw. kontrolliert ansteuerbar
▪
Die EL/EP3356 kann auch als 2-kanalige analoge Eingangsklemme/Eingangsbox zur Spannungsmessung verwendet werden.
▪
Die EL3356-0010 und die EP3356-0022 verfügen über eine aktivierbare Zeitstempelfunktion durch Distributed Clocks. Im DC-Modus sind die Filterfunktionen außer Betrieb.
Allgemeine Hinweise
▪
Die Messbereiche beider Kanäle (Versorgungsspannung und Brückenspannung) sollten immer so weit wie möglich ausgenutzt werden, um eine hohe Messgenauigkeit zu erreichen. Empfohlen wird eine Versorgungsspannung von 12 V in Verbindung mit einer Wägezelle mit einer derart beschaffenen Empfindlichkeit (z.B. 2 mV/V), dass eine möglichst große Brückenspannung - idealerweise ±25 mV - erzeugt wird. Dabei sind die Eingangsspannungen (siehe technische Daten) zu beachten.
Eingangsspannungen
▪
Ein Parallelbetrieb von Wägezellen ist mit der EL/EP3356 möglich. Dabei ist zu beachten:
–
die EL3356 stellt keine Versorgung bereit! Somit muss die verwendete Spannungsversorgung ausreichend dimensioniert werden, da sich der Gesamtbrückenwiderstand aller zusammen geschalteten DMS durch die Parallelschaltung deutlich verringert.
–
es sollten vom Wägezellen-Hersteller entsprechend für den Parallelbetrieb freigegebene und abgeglichene Wägezellen verwendet werden. Die Nennkennwerte [mV/V], Nulloffset [mV/V] und Impedanz [Ω, Ohm] werden dann üblicherweise entsprechend angeglichen.
–
ein 6-Leiter-Anschluss wird mit der EL3356 ausdrücklich empfohlen
Parallelschaltung mit EL3356
Parallelschaltung mit EP3356
▪
Wägezellen-Signale sind von geringer Amplitude und mitunter sehr empfindlich für EMV-Störungen. In Anbetracht der anlagentypischen Besonderheiten und unter Berücksichtigung der technischen Möglichkeiten sind zielführende EMV-Schutzmaßnahmen nach dem Stand der Technik anzuwenden. Der Schirm des Sensorkabels kann an der EL3356 an den Klemmstellen 4/8 aufgelegt werden. Unter hoher EMV-Störbelastung kann es hilfreich sein, den Kabelschirm vor der Klemme noch zusätzlich mit geeignetem Schirmmaterial aufzulegen.
▪
die minimal zulässige zugeordnete EtherCAT Zykluszeit für die EL/EP3356 beträgt 100 µs.
▪
Soll die EL3356-0010 oder die EP3356-0022 im Distributed Clocks-Betrieb genutzt werden:
–
Ist DC zu aktivieren
–
Ist das Prozessdatum Timestamp zu aktivieren. Die Filterfunktionen sind dann außer Betrieb.
Signalflussplan
Signalflussplan der EP3356-0022
Die EL/EP3356 bearbeitet die Daten in folgender Reihenfolge:
▪
Hardware-Tiefpass 10 kHz
▪
2-kanaliges simultanes Sampling in 10,5/105,5 kSps mit 64-facher Überabtastung durch Delta-Sigma-(ΔΣ)-Wandler und interner Vorfilterung
▪
Averager 4-fach (deaktivierbar)
▪
Software-Filter (deaktivierbar)
▪
Gewichtsberechnung
Messprinzip Delta-Sigma-(ΔΣ)-Wandler
Das in der EL/EP3356 verwendete Messprinzip mit realer Abtastung im MHz-Bereich verschiebt Aliasing-Effekte in einen sehr hochfrequenten Bereich, so dass für den Betrieb im kHz-Bereich in der Regel keine derartigen Effekte zu erwarten sind.
Averager
Um die hohe Datenrate des Analog-Digital-Wandlers (ADC) auch bei langsamen Zykluszeiten nutzen zu können, ist dem ADC ein Mittelwertfilter nachgeschaltet. Dieser bildet einen gleitenden Mittelwert über die letzten 4 Messwerte. Diese Funktion lässt sich über das CoE-Objekt "Mode X enable averager" für jeden Modus deaktivieren.
Software-FIlter
Die EL/EP3356 ist mit einem digitalen Software-Filter ausgestattet, das je nach Einstellung die Charakteristik eines Filter mit endlicher Impulsantwort (Finite Impulse Response filter, FIR-Filter) oder eines Filter mit unendlicher Impulsantwort (Infinite Impulse Response filter, IIR-Filter), annehmen kann. Der Filter ist per default als 50 Hz-FIR aktiviert.
Im jeweiligen Messmodus kann der Filter aktiviert (0x8000:01, 0x8000:02) und parametriert (0x8000:11, 0x8000:12) werden (die EL3356-0000 unterstützt nur Modus 0).
FIR 50/60 Hz
▪
Der Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit der Klemme/Box. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit. Es steht ein 50 Hz und ein 60 Hz Filter zur Verfügung. Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also in der Amplitude dämpft. Das FIR-Filter arbeitet als nicht-rekursives Filter.
PDO Filter
▪
Der Filter verhält sich wie die oben beschriebenen 50/60Hz FIR Filter. Jedoch lässt sich hier die Filterfrequenz in 0,1 Hz Schritten durch ein Ausgangsdatenobjekt einstellen. Der Filterfrequenzbereich reicht von 0,1 Hz bis 200 Hz und kann im laufenden Betrieb umparametriert werden. Dazu muss das PDO 0x1601 ("RMB Filter frequency") in die Prozessdaten eingeblendet und im Objekt 0x8000:11 der Eintrag "PDO Filter frequency" ausgewählt werden.
▪
Diese Funktion erlaubt der EL/EP3356 Störungen einer bekannten Frequenz aus dem Messsignal zu unterdrücken. Ein typischer Anwendungsfall ist z.B. ein Silo, welches durch eine angetriebene Schnecke befüllt und gewogen wird. Die Drehzahl der Schnecke ist bekannt und kann als Frequenz in das Objekt übernommen werden. Somit können mechanische Schwingungen aus dem Messsignal entfernt werden.
Notch-Kennlinie/Amplitudengang und Sprungantwort der FIR-Filter
IIR-Filter 1..8
▪
Der Filter mit IIR-Charakteristik ist ein zeitdiskretes, lineares, zeitinvariantes Filter, welches in 8 Leveln eingestellt werden kann (Level 1 = schwaches rekursives Filter, bis Level 8 = starkes rekursives Filter). Der IIR kann als gleitende Mittelwertberechnung nach einem Tiefpass verstanden werden.
Sprungantwort und Bodediagramm der IIR-Filter
Übersicht Wandlungszeiten
Filter Settings | Wert | PDO Updatezeit EL3356 | PDO Updatezeit EP3356-0022/ EL3356-0010 | Filtereigenschaft | Grenzfrequenz (-3 dB) [Hz] (typ.) | Kommentar | Anstiegszeit 10-90 % [s] (typ.)
Filter deaktiviert | - | min. 10 ms | Zyklussynchron, min. 100 µs | - | - | - | -
0 | FIR 50 Hz | min. 10 ms | 312.5 µs | 50 Hz Notchfilter | 22 Hz | Wandlungszeit typ. 312.5 µs | 0.013
1 | FIR 60 Hz | min. 10 ms | 260.4 µs | 60 Hz Notchfilter | 25 Hz | Wandlungszeit typ. 260.4 µs | 0.016
2 | IIR1 | Zyklussynchron (bis min. 10 ms Update) | Zyklussynchron (bis min. 100 µs) | Tiefpass | 2000 Hz | a0=1/21 = 0.5 | 0.0003
3 | IIR2 |  |  | Tiefpass | 500 Hz | a0=1/22 = 0.25 | 0.0008
4 | IIR3 |  |  | Tiefpass | 125 Hz | a0=1/24 = 62.5e-3 | 0.0035
5 | IIR4 |  |  | Tiefpass | 30 Hz | a0=1/26 = 15.6e-3 | 0.014
6 | IIR5 |  |  | Tiefpass | 8 Hz | a0=1/28 = 3.91e-3 | 0.056
7 | IIR6 |  |  | Tiefpass | 2 Hz | a0=1/210 = 977e-6 | 0.225
8 | IIR7 |  |  | Tiefpass | 0.5 Hz | a0=1/212 = 244e-6 | 0.9
9 | IIR8 |  |  | Tiefpass | 0.1 Hz | a0=1/214 = 61.0e-6 | 3.6
10 | Dynamic IIR |  |  | Der Filter wechselt dynamisch zwischen den Filtern IIR1 bis IIR8
11 | PDO Filter frequency | min. 10 ms | 1/PDO Value[Hz]*64 | Notchfilter mit einstellbarer Frequenz | ca. 0,443 * PDO Value [Hz] | - | -
Filter und Zykluszeit
Bei eingeschalteten FIR Filtern (50 Hz oder 60 Hz) werden die Prozessdaten maximal mit der angegebenen Wandlungszeit aktualisiert (siehe Tabelle). Die IIR Filter arbeiten zyklussynchron. Somit steht jedem SPS-Zyklus ein neuer Messwert zur Verfügung.
An welcher Stelle die Filter eingestellt werden können ist in dem Kapitel „CoE-Objektbeschreibung und Parametrierung“ z.B. unter dem Index 0x8000:12 beschrieben.
IIR Filter
Differenzengleichung: Yn= Xn * a0 + Yn-1 * b1 mit a0 + b1 = 1
a0= (siehe Tabelle), b1 = 1 – a0
Dynamisches IIR Filter
Das dynamische IIR-Filter schaltet in Abhängigkeit der Gewichtsänderung eigenständig die 8 verschiedenen IIR-Filter durch. Das Konzept:
▪
Zielzustand ist immer der IIR8-Filter, also die größtmögliche Dämpfung und somit ein sehr beruhigter Messwert.
▪
Bei schnellen Änderungen der Eingangsgröße wird der Filter geöffnet also zum nächstniedrigeren Filter geschaltet (wenn noch möglich). Dadurch wird der Signalflanke mehr Gewicht gegeben und der Messwertverlauf kann schnell der Last folgen.
▪
Bei geringer Messwertänderung wird der Filter zugezogen, also zum nächsthöheren Filter geschaltet (wenn noch möglich). Dadurch wird der statische Zustand mit einer hohen Genauigkeit abgebildet.
▪
Die Bewertung ob eine Filteränderung nach unten erforderlich bzw. nach oben möglich ist, erfolgt fortlaufend in festem Zeitabstand.
Die Parametrierung wird über die CoE Enträge 0x8000:13 und 0x8000:14 vorgenommen. Die Bewertung erfolgt nach 2 Parametern:
▪
Im Objekt "Dynamic filter change time" (0x8000:13) wird eingestellt, in welchem Zeitabstand das vorliegende Signal neu bewertet wird
▪
Im Objekt 0x8000:14 wird festgelegt, welche maximale Abweichung in dieser Zeit zulässig ist, ohne dass es zu einer Filterumschaltung kommt.
Beispiel:
Der dynamische Filter soll derart eingestellt werden, dass eine maximale Steigung von 0.5 digit pro 100 ms (5 Digit pro Sekunde) möglich ist, ohne dass der Filter geöffnet wird. Dadurch wird eine "ruhige" Messwertausgabe erreicht. Bei schnellerer Änderung soll aber umgehend der Last gefolgt werden können.
▪
Dynamic filter change time (0x8000:13) = 10 (entspricht 100 ms)
▪
Dynamic filter delta (0x8000:14) = 0.5 (bezogen auf den berechneten Lastwert)
Im Folgenden ist der Messwertverlauf bei langsamer (links) und schneller (rechts) Änderung abgebildet.
Auswirkung dynamischer IIR-Filter
▪
Links: Die Waage wird langsam belastet. Die Änderung des Gewichtes (delta/time) bleibt unterhalb der Marke von 0.5 Digit pro 100 ms. Der Filter bleibt somit unverändert auf der stärksten Stufe (IIR8) und bewirkt einen schwankungsarmen Messwert.
▪
Rechts: Die Waage wird schlagartig belastet. Die Änderung des Gewichtes überschreitet sofort den Grenzwert von 0.5 Digit pro 100 ms. Der Filter wird alle 100 ms um eine Stufe geöffnet (IIR8 → IIR7 → IIR6 ...) und der Anzeigewert folgt sofort dem Sprung. Nach der Entfernung des Gewichtes fällt das Signal zügig wieder ab. Ist die Änderung des Gewichtes kleiner als 0.5 Digit pro 100 ms, wird der Filter alle 100 ms eine Stufe stärker gestellt bis IIR8 erreicht wird. Die grüne Linie soll den abnehmenden "Rauschpegel" verdeutlichen.
Gewichtsberechnung
Nach jeder Erfassung der Analogeingänge erfolgt die Berechnung des resultierenden Gewichts bzw. der resultierenden Kraft, welche sich aus dem Verhältnis des Messsignals zum Referenzsignal und aus mehreren Kalibrierungen zusammensetzt:
YR = (UDiff / Uref) x Ai | (1.0) | Berechnung des Rohwertes in mV/V
YL = ( (YR – CZB) / (Cn – CZB) ) * Emax | (1.1) | Berechnung des Gewichts
YS = YL * AS | (1.2) | Skalierfaktor (z.B. Faktor 1000 für Umskalierung von kg in g)
YG = YS * (G / 9.80665) | (1.3) | Einfluss der Erdbeschleunigung
YAUS = YG x Gain - Tara | (1.4) | Gain und Tara
Legende
Name | Bezeichnung | CoE Index
UDiff | Brückenspannung/Differenzspannung des Sensorelementes, nach Averager und Filter |
Uref | Brückenspeisespannung/Referenzsignal des Sensorelementes, nach Averager und Filter |
Ai | Interne Verstärkung, nicht veränderbar. Dieser Faktor berücksichtigt die Einheitennormierung von mV zu V und die unterschiedlichen Vollausschläge der Eingangskanäle |
Cn | Nennkennwert des Sensorelementes (Einheit mV/V, z.B. nominell 2 mV/V oder 2.0234 mV/V laut Abgleichprotokoll) | 8000:23
CZB | Nullpunktabgleich (Zero balance) des Sensorelementes (Einheit mV/V, z.B. -0.0142 laut Abgleichprotokoll) | 8000:25
Emax | Nennlast des Sensorelementes | 8000:24
AS | Skalierfaktor (z.B. Faktor 1000 für Umskalierung in kg in g) | 8000:27
G | Erdbeschleunigung in m/s^2 (default: 9.80665 ms/s^2) | 8000:26
Gain |  | 8000:21
Tara |  | 8000:22
Wandlungsmodus
Der so genannte Wandlungsmodus bestimmt die Geschwindigkeit und Latenz der analogen Messung in der EL/EP3356. Die Charakteristika:
Modus | Bedeutung | typ. Latenz | EL3356 | EL3356-0010 und EP3356-0022 | Stromaufnahme typ.
0 | High precision Analoge Wandlung mit 10,5 kSps (Samples per second) Langsame Wandlung und damit hohe Genauigkeit | 7,2 ms | x | x | 70 % (bez. Nennwert, siehe Technische Daten)
1 | High speed / low latency Analoge Wandlung mit 105,5 kSps (Samples per second) schnelle Wandlung bei geringer Latenz | 0,72 ms | - | x | 100 % (bez. Nennwert, siehe Technische Daten)
Das Wandlungsprinzip der EL/EP3356 bedingt, dass erst nach einer definierten Zeit die analoge Spannung als Digitalwert zur Verfügung steht. Dies veranschaulicht die nachfolgende Abbildung.
Es wird ein Sprungsignal 0 →1 auf den Eingang gegeben. Je nach Wandlungsmodus 0/1 ist nach 7,2 ms bzw. 0,72 ms der Messwert innerhalb der definierten Genauigkeit erreicht und auslesbar. Zu diesem Zeitpunkt wird auch im Distributed Clocks-Betrieb der Zeitstempel gewonnen. Im realen Betrieb wird üblicherweise kein sprungbehaftetes sondern ein höherfrequentes, wenn auch stetiges Signal angeschlossen. Dann bildet die EL/EP3356 das Eingangssignal mit der entsprechenden Latenz zur Weiterverarbeitung ab, weshalb auch eine schnellere Abfrage der Abtasteinheit in kürzeren Abständen als die Latenzzeit (EL3356-0010/EP3356-0022 ermöglicht bis 100 µs) zur detailgetreuen Abbildung des analogen Eingangssignals sinnvoll ist.
Latenz des Analog-Digital-Wandlers
Eine Veränderung der angegebenen Latenzzeit ist nicht möglich.
Darüber hinaus sind in jedem Modus über CoE einzeln einstellbar
▪
Aktivierung Averager
▪
Aktivierung Filter
▪
Filterart
zu den einzelnen Modi gehörige Einstellparameter im CoE
Die EL3356 verfügt nur über Modus 0, die EL3356-0010 und die EP3356-0022 über Modus 0 + 1.
Moduswechsel (nur EL3356-0010, EP3356-0022)
Insbesondere für dynamische Wägevorgänge kann es sinnvoll sein, während des Wägevorgangs die Messcharakteristik erheblich zu verändern. Wenn z. B. ein Schüttgut sackweise innerhalb 5 Sekunden abgefüllt wird, sollte zu anfangs ein sehr offener Filter eingesetzt werden, damit der Messwert schnell dem Füllungsgrad folgt. Dass der Messwert dabei sehr ungenau ist und hohen Schwankungen unterliegt, spielt während dieser Phase keine Rolle. Wenn der Sack dann zu >90 % befüllt ist, muss die Befüllung verlangsamt und mit hoher Genauigkeit die Beladung verfolgt werden, der Filter ist nun "zuzuziehen". Deshalb können in der EL3356-0010 und EP3356-0022 die beiden Wandlungsmodi über das Prozessdatenbit "Sample mode" in Bezug auf die Analogwertverarbeitung umgeschaltet werden.
Der Moduswechsel dauert ca. 30 ms, in dieser Zeit sind die Messwerte ungültig und zeigen dies durch das Statusbyte an.
Umschaltung SampleMode


Anwendungshinweise

Inbetriebnahme/Konfiguration [image] Anwendungshinweise
Anwendungshinweise
Symmetrisches Bezugspotential
Die EL/EP3356 misst die beiden Spannungen Usupply und Ubridge unabhängig voneinander und ohne galvanischen Bezug zu einer Versorgungsspannung. Die Messgenauigkeit kann zusätzlich gesteigert werden, wenn ein Auseinanderdriften der internen Messkreise durch eine interne Kopplung verhindert wird. Dazu besitzt die EL/EP3356 einen internen Schalter, der standardmäßig geschlossen ist und einen Potentialbezug zwischen interner Elektronik und dem Brückenpunkt herstellt.
Interner Schalter zur Erhöhung der Messgenauigkeit
Wenn mehrere DMS aus derselben Versorgung gespeist werden und es zu Ausgleichsströmen kommt die die Messung verfälschen, kann der Schalter über CoE 0x8000:05 geöffnet werden. Alternativ sind galvanisch getrennte DMS-Versorgungen zu installieren.
Drahtbrucherkennung
Die EL/EP3356 verfügt über keine ausdrückliche Drahtbrucherkennung. Wird jedoch eine der Bridge-Leitungen getrennt, geht i. d. R. die dort gemessene Spannung gegen den Endwert und zeigt somit einen Error im Status-Wort an. Ein Over/Underrange der Speisespannung wird ebenfalls angezeigt.
Input freeze
Wenn die Klemme/Box durch InputFreeze im Control-Wort in den Freeze-Zustand versetzt wird, werden keine analogen Messwerte mehr an den internen Filter weitergereicht. Diese Funktion ist dann anwendbar, wenn z. B. aus der Applikation ein Einfüllstoß erwartet wird, der durch die Kraftbelastung die Filter unnötig übersteuern würde. Das hätte zur Folge, dass einige Zeit verstreichen würde, bis sich die Filter wieder eingeschwungen hätten. Der Anwender hat selbst auszumessen, wie lange für seinen Einfüllvorgang das InputFreeze sinnvoll ist.
Zur Verdeutlichung: die zeitliche Steuerung und Entscheidung über den InputFreeze muss vom Anwender in der PLC realisiert werden, sie ist nicht Bestandteil der EL/EP3356.
Im folgenden Beispiel (aufgezeichnet mit Scope2) werden Stöße auf eine 15 kg-Wägezelle aufgezeichnet, der Filter ist mit IIR1 weit offen damit steile Flanken im Signal auftreten.
Stöße auf Wägezelle mit und ohne InputFreeze
Erläuterung: Blau dargestellt ist die Gewichtskraft (A), in rot (B) der Zustand der Variable InputFreeze die vom PLC-Program bedient wird und TRUE/FALSE sein kann. Die ersten beiden Stöße (C) führen zu großen Spitzenausschlägen im Signal. Danach wird im PLC-Programm (siehe Beispielprogramm) folgendes aktiviert:
▪
wenn sich der Messwert zum letzten Zyklus (Zykluszeit 100 µs) um mehr als 10 g geändert hat (als Indiz für schlagartige Belastung), wird bInputFreeze durch einen TOF-Baustein an die EL/EP3356 für 50 ms auf TRUE gesetzt
In (D) ist die Wirkung zu sehen: Die Spitzenbelastungen werden von der EL/EP3356 nicht mehr zur Kenntnis genommen. Bei optimaler Anpassung an den erwarteten Kraftstoß kann die EL/EP3356 ohne Überschwingen den aktuellen Belastungswert einmessen
Schwerkraftanpassung
Die Berechnung der Gewichtskraft ist abhängig von der Gravitation/Erdschwerkraft/Fallbeschleunigung am Aufstellort der Waage. Im Allgemeinen entspricht die Gravitationsbeschleunigung der Erde am Aufstellort der Anlage nicht dem festgelegten Standardwert g = 9,80665 m/s². Beispielsweise sind in Deutschland 4 Fallbeschleunigungszonen festgelegt, in denen eine lokale Gravitationsbeschleunigung von 9,807 m/s² bis 9,813 m/s² anzunehmen ist. Es handelt sich hier also schon innerhalb Deutschlands um eine deutliche Streuung im Promille-Bereich für die Gravitationsbeschleunigung, die sich über die Formel FG = m*g direkt auf die gemessene Gewichtskraft auswirkt!
Wenn:
▪
Wägezellen im theoretischen Abgleich mit Kennwerten nach Sensorzertifikat eingesetzt werden
▪
Eichgewichte verwendet werden, deren Gewichtskraft am Waagenaufstellort naturgemäß eine andere ist als am Herkunftsort
▪
Waagen der Genauigkeitsklasse I bis III realisiert werden
▪
generell eine fallbeschleunigungsabhängige Waage realisiert wird
sollte geprüft werden, ob die Schwerkraftkorrektur über das Objekt 0x8000:26 angepasst werden muss.
Ruheerkennung
Wiegen ist ein dynamischer Vorgang, der zu großen Sprüngen in der Brückenspannung und damit Wertberechnung führen kann. Nach einer Belastungsänderung muss sich der Messwert erst "beruhigen" damit der Prozesswert in der Steuerung verwertbar ist. Die Auswertung des Messwertes und der Entscheid über den Grad der Ruhe kann in der Steuerung vorgenommen werden, die EL/EP3356 bietet aber ebenfalls diese Funktion, die standardmäßig aktiviert ist. Das Ergebnis wird im Status-Wort ausgegeben.
▪
Befindet sich der Lastwert länger als Zeit x innerhalb eines Wertebereichs y, wird das SteadyState im StatusWord aktiviert
▪
Sobald diese Bedingung nicht mehr zutrifft, wird SteadyState auf FALSE gesetzt.
▪
Die Parameter x und y können im CoE vorgegeben werden
▪
Die Auswertung wird natürlich erheblich vom eingestellten Filter beeinflusst
Im folgenden Beispiel (aufgenommen mit den TwinCAT Scope2) wird eine 15 kg-Wägezelle sprunghaft mit 547 g ent- und belastet. SteadyState unterliegt einer Fensterzeit von 100 ms und 8 g Toleranz (15 kg Nennwert, Skalierung 1000; siehe CoE).
Sprunghafte ent- und belastung einer Wägezelle
Eichfähigkeit
"Eichen" ist eine besondere Art der Kalibrierung, die nach besonderen Vorschriften und unter Einbeziehung ausgebildeten Personals und vorgeschriebener Hilfsmittel durchgeführt wird. Insbesondere beim Abfüllen von Lebensmitteln sind im zentraleuropäischen Raum "geeichte" Waagen vorgeschrieben. Dadurch wird in besonderer Weise die Richtigkeit der abgewogenen Menge sichergestellt.
Die Beckhoff Klemmen EL/KL335x als auch die Box EP3356 sind als Einzelgeräte nicht eichfähig. Sie können aber als Teilelemente in Applikationen integriert werden, welche dann durch entsprechende Maßnahmen seitens des Integrators mit den nötigen Eigenschaften für Eichfähigkeit ausgerüstet werden.


Kalibrierung und Abgleich

Inbetriebnahme/Konfiguration [image] Kalibrierung und Abgleich
Kalibrierung und Abgleich
Der Begriff "Kalibrierung" lässt sich in 3 verschiedenen Weisen auf die EL/EP3356 anwenden:
▪
Sensorkalibrierung: einmalige Kalibrierung des eingesetzten Sensors (DMS) bei Anlageninbetriebnahme
▪
Selbstkalibrierung: fortlaufende wiederholte Selbstkalibrierung der Klemme/Box zur Verbesserung der Messgenauigkeit
▪
Tara: wiederholte Brutto/Netto-Kompensation durch Tara
EL/EP3356 und Sonderversionen
Wenn nicht anders genannt bezieht sich die Angabe „EL/EP3356“ immer auch auf die Sonderversionen wie z.B. EL3356-0010 und EP3356-0022.
Sensorkalibrierung
Durch die Kalibrierung wird die EL/EP3356 an die Kennlinie des Sensorelementes angepasst. Für diesen Vorgang werden zwei Werte benötigt: der Ausgangswert ohne Belastung ("Zero balance") und der unter voller Belastung ("Rated output"). Diese Werte können durch ein Abgleichprotokoll oder durch eine Kalibrierung mit Abgleichgewichten ermittelt werden.
Anpassen an die Sensorkennlinie
Kalibrierung mittels Abgleich in der Anlage
Bei der "praktischen" Kalibrierung wird zuerst mit unbelasteter Waage, dann mit definiert belasteter Waage gemessen. Aus den Messwerten berechnet die EL/EP3356 automatisch die vorliegenden Sensorkennwerte.
Der Ablauf:
1.
CoE-Reset mit Objekt 0x1011:01 durchführen, siehe Wiederherstellen des Auslieferungszustandes
2.
Scale factor (0x8000:27) = 1000 setzen (für Gewichtsangabe in g)
3.
Gravity of earth (0x8000:26) setzen falls erforderlich (default: 9.806650)
4.
Gain (0x8000:21) = 1 setzen
5.
Tara (0x8000:22) = 0 setzen
6.
Filter (0x8000:11) auf stärkste Sufe einstellen: IIR8
7.
Nennlast des Sensors in 0x8000:24 ("Nominal load") angeben
8.
Nullabgleich: Waage nicht belasten. Sobald der Messwert über mind. 10 Sekunden einen unveränderlichen Wert zeigt, das Kommando "0x0101" (257dec) auf CoE-Objekt 0xFB00:01 ausführen. Durch dieses Kommando wird der aktuelle mV/V Wert (0x9000:11) in das "Zero balance" Objekt eingetragen. Kontrolle: CoEObjekt 0xFB00:02 und 0xFB00:03 muss nach Ausführung "0" enthalten
9.
Waage mit einer Referenzlast belasten. Diese sollte mindestens 20 % der Nennlast betragen. Je größer die Referenzlast, desto besser können die Sensor-Werte berechnet werden. In Objekt 0x8000:28 ("Reference load") die Last in der gleichen Einheit wie die Nennlast (0x8000:24) angeben. Sobald der Messwert über mind. 10 Sekunden einen unveränderlichen Wert zeigt, das Kommando "0x0102" (258dec) auf CoE 0xFB00:01 ausführen. Durch diesen Befehl ermittelt die EL/EP3356 den Ausgabewert bei Nenngewicht ("Rated output"). Kontrolle: CoE-Objekt 0xFB00:02 und 0xFB00:03 muss nach Ausführung "0" enthalten
10.
Rückstellung: Kommando "0x0000" (0dec) auf CoE-Objekt 0xFB00:01 ausführen.
11.
Filter auf niedrigere Stufe stellen.
Kalibrierung nach Sensor-Abgleichprotokoll (theoretische Kalibrierung)
Die Sensorkennwerte laut Hersteller-Zertifikat werden hier direkt der EL/EP3356 mitgeteilt, damit diese die Last berechnen kann.
1.
CoE-Reset mit Objekt 0x1011:01 durchführen, siehe Wiederherstellen des Auslieferungszustandes
2.
Scale factor (0x8000:27) = 1000 setzen (für Gewichtsangabe in g)
3.
Gravity of earth (0x8000:26) setzen falls erforderlich (default: 9.806650)
4.
Gain (0x8000:21) = 1 setzen
5.
Tara (0x8000:22) = 0 setzen
6.
Nennlast des Sensors in 0x8000:24 ("Nominal load") angeben
7.
"Rated Output" (mV/V Wert 0x8000:23) aus dem Abgleichprotokoll übernehmen
8.
"Zero Balance" (0x8000:25) aus dem Abgleichprotokoll übernehmen
Kalibrierung
Die Kalibrierung ist für die Genauigkeit des Systems von großer Bedeutung. Um diese zu steigern, sollten die Filter während der gesamten Kalibrierphase möglichst stark eingestellt sein. Dabei kann es mehrere Sekunden dauern, bis sich ein statischer Wert eingestellt hat.
Lokale Speicherung
Die beim theoretischen und praktischen Abgleich geänderten Werte werden in einem lokalen EEPROM gespeichert. Dieses kann bis zu 1 Mio. mal beschrieben werden. Um die Lebensdauer des EEPROMS zu verlängern, sollten die Kommandos deshalb nicht zyklisch ausgeführt werden.
Selbstkalibrierung der Messverstärker
Die Messverstärker werden automatisch periodisch einer Überprüfung und Selbstkalibrierung unterzogen. Dafür sind mehrere Analogschalter vorgesehen, um die verschiedenen Kalibriersignale aufschalten zu können. Wichtig dabei ist, dass in jeder Phase der Kalibrierung immer der gesamte Signalpfad (inklusive aller passiven Bauteile) überprüft wird. Lediglich die Entstörglieder (L/C-Kombination) und die Analogschalter selbst können nicht erfasst werden. Zusätzlich wird in größeren Abständen noch ein Selbsttest durchgeführt. Die Selbstkalibrierung wird in der Default-Einstellung alle 3 Minuten durchgeführt.
Selbstkalibrierung
▪
Zeitintervall wird in 100 ms Schritten mit Objekt 0x8000:31 eingestellt, default: 3 min. Dauer ca 150 ms
Selbsttest
▪
Wird zusätzlich zusammen mit jeder n-ten Selbstkalibrierung durchgeführt. Das Vielfache (n) wird mit Objekt 0x8000:32 eingestellt, default: 10 zusätzliche Dauer ca. 70 ms.
Durch die Selbstkalibrierung der Eingangsstufen in den beiden Arbeitspunkten (Nullpunkt und Endwert) werden die beiden Messkanäle aufeinander abgeglichen.
Schnittstelle zur Steuerung
Die Selbstkalibrierung findet automatisch in den festgelegten Abständen statt. Um zu verhindern, dass während eines zeitkritischen Messvorganges kalibriert wird, kann über das Bit "Disable calibration" im ControlWord die automatische Kalibrierung auch dauerhaft gesperrt werden. Sollte es notwendig sein zusätzlich eine manuelle Prüfung durchzuführen, wird diese durch eine steigende Flanke des Bits "Start manual calibration" im Prozessabbild gestartet. Während die Klemme/Box eine Selbstkalibrierung oder ein Selbsttest durchführt, ist im Prozessabbild das Bit "Calibration in progress" gesetzt. Eine einmal gestartete Selbstkalibrierung/Selbsttest kann nicht abgebrochen werden. Wenn die Selbstkalibrierung durch „Disable calibration“ abgeschaltet wurde, kann sie trotzdem durch das Prozessdatenbit „Start calibration“ gestartet werden.
Selbstkalibrierung
Die Selbstkalibrierung wird erstmalig direkt nach dem Aufstarten der Klemme/Box durchgeführt. Zu diesem Zeitpunkt muss die externe Referenzspannung bereits anliegen. Sollte die Referenzspannung erst später angelegt werden, muss die Selbstkalibrierung manuell angestoßen werden (Prozessdaten Bit: „Start calibration“). Die Selbstkalibrierung muss nach jedem Aufstarten mindestens einmalig durchgeführt werden. Die Versorgungsspannung muss während der Selbstkalibrierung anliegen, da sonst nicht die nötigen Referenzspannungen erzeugt werden können. Wird die Selbstkalibrierung länger oder dauerhaft unterbunden, ist eine geringere Messgenauigkeit zu erwarten.
Nach einer Änderung der Einstellungen im CoE (Bereich x80nn) wird in jedem Fall (auch bei DisabledCalibration = TRUE) eine Selbstkalibrierung durchgeführt, da die Einstellungen den Messvorgang beeinflussen. CoE-Einstellungen sind soweit möglich außerhalb des fortlaufenden Messvorgangs zu ändern.
Tarierung
Beim Tarieren wird die Waage unter beliebiger anliegender Belastung "genullt", es wird also eine Offsetkorrektur durchgeführt. Dies ist zum Brutto/Netto-Ausgleich bei Gütern nötig, die ohne massebehaftetem Behälter nicht gewogen werden können. Die EL/EP3356 unterstützt 2 Tarierungen, es empfiehlt sich, einen starken Filter bei der Tarierung einzustellen.
Temporäres Tara
▪
Der Korrekturwert wird NICHT in der Klemme/Box gespeichert und geht bei Spannungsausfall verloren. Dazu wird das Kommando "0x0001" auf CoE-Objekt 0xFB00:01 ausgeführt (binärer Dialog im Systemmanager: "01 00"). Dabei wird das Tara Objekt (0x8000:22) so eingestellt, dass der Anzeigewert 0 ergibt. Hinweis: bei einem Geräteneustart (INIT->OP) wird das Tara nicht gelöscht. Außerdem kann dieses Tara über das Control-Word ausgeführt werden:
Dauerhaftes Tara
▪
Der Korrekturwert wird lokal in der Klemme/Box im EEPROM gespeichert und geht bei Spannungsausfall nicht verloren. Dazu wird das Kommando "0x0002" auf CoE-Objekt 0xFB00:01 ausgeführt (binärer Dialog im Systemmanager: "02 00"). Dabei wird das Tara Objekt (0x8000:22) so eingestellt, dass der Anzeigewert 0 ergibt.
Lokale Speicherung
Die beim theoretischen und praktischen Abgleich geänderten Werte werden in einem lokalen EEPROM gespeichert. Dieses kann bis zu 1 Mio. mal beschrieben werden. Um die Lebensdauer des EEPROMs zu verlängern, sollten die Kommandos deshalb nicht zyklisch ausgeführt werden.
Kommandos
Die vorher besprochenen Funktionen werden über Kommandos im standardisierten Objekt 0xFB00 vorgenommen.
Index | Name | Kommentar
FB00:01 | Request | Eingabe des auszuführenden Kommandos
FB00:02 | Status | Status des aktuell ausgeführten Kommandos 0: Kommando fehlerfrei ausgeführt 255: Kommando wird ausgeführt
FB00:03 | Response | Optionaler Rückgabewert des Kommandos
Um die Ausführung der Kommandos aus der PLC durchzuführen, können die Funktionsbausteine FB_EcCoESdoWrite und FB_EcCoESdoRead aus der TcEtherCAT.lib (enthalten in der Standard TwinCAT Installation) genutzt werden.
Kommandos der EL/EP3356
Über den CoE-Eintrag 0xFB00:01 können der Klemme/Box folgende Kommandos übergeben werden:
Kommando | Kommentar
0x0101 | Nullabgleich durchführen
0x0102 | Kalibrierung durchführen
0x0001 | Tarierung durchführen (Wert wird NICHT im EEprom der Klemme/Box gespeichert)
0x0002 | Tarierung durchführen (Wert wird im EEprom der Klemme/Box gespeichert)


Hinweise zur analogen Spezifikation

Inbetriebnahme/Konfiguration [image] Hinweise zur analogen Spezifikation
Hinweise zur analogen Spezifikation
Beckhoff IO-Geräte (Klemmen, Boxen) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Messbereichsendwert
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereiche
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200…1370 °C: asymmetrisch bipolar, MBE = 1370 °C, Messspanne = 1570 °C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/Ausgangsboxen
± Messfehler [% vom MBE] (auch: Messabweichung)
Der relative Messfehler bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung, ...).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3 % MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Hinweis: da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsklemmen/Ausgangsboxen.
Typisierung Single Ended / differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
Typisierung Single Ended / differentiell
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss.
Grundsätzlich gilt:
▪
die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten. Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
–
bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt. Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen. Beckhoff IO-Module verfügen über 1...8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden:
–
wie sich die Kanäle INNERHALB eines Moduls zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
▪
Beckhoff Klemmen/Boxen sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen/Boxen also nicht über die Powerkontakte miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
▪
falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder eine 1-Kanal-Klemme keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Klemmendokumentationen/Boxendokumentationen sind zu beachten.
Erläuterung:
▪
Differentiell
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (siehe vorherige Abbildung) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)", wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird. Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung im Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
▪
Single Ended
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/Box von außen zum Anschluss des Bezugspotenzial zugänglich sein, z.B. über die Powerkontakte.
–
SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z.B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/BezugsPotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20 mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst. Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4…20 mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss, vgl. IEC 60381-1
▪
Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
▪
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
▪
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal.
Extern versorgte Sensoren
▪
3/4-Leiter-Anschluss, vgl. IEC 60381-1
▪
die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:
1.
Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm
2.
Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +/-/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
–
Ja: Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
–
Nein: es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Generell ist wegen der internen Diode die Polarität/Stromrichtung zu beachten!
2/3/4-Leiter-Anschluss als Single-Ended- oder Differential-Anschlusstechnik


Spannungsmessung

Inbetriebnahme/Konfiguration [image] Spannungsmessung
Spannungsmessung
EL/EP3356 und Sonderversionen
Wenn nicht anders genannt, bezieht sich die Angabe „EL/EP3356“ immer auch auf die Sonderversionen wie z. B. EL3356-0010 und EP3356-0022.
Die EL/EP3356 bietet prinzipiell eine 2-kanalige Spannungsmessung auf einer Klemme/Box mit 2 sehr unterschiedlichen Messbereichen von ±25 mV und ±12 V Nennspannung. Durch die beiden gleichzeitig gemessenen Spannungen kann die Belastung des einen angeschlossenen DMS berechnet werden, die EL/EP3356 führt diese Berechnung bereits in der Klemme/Box aus und stellt somit eine 1-kanalige Klemme/Box im Sinne der Lastberechnung dar.
Für die einzelnen Kanäle gilt:
▪
Kanal 1
–
Messbereich typ. ca. -13,5 V... 0 ... +13,5 V (entsprechend Prozesswert 0x80.00.00.00 ... 0 ... 0x7F.FF.FF.FF)
–
Messbereich nominell: -12 V ... 0 ... +12 V
–
max. zulässige Spannung -UD vs. +UD: ±13,5 V
–
Messfehler < ±0,1 % vom Messbereichsendwert, 50 Hz Filter aktiv
▪
Kanal 2:
–
Messbereich typ. ca. -27 mV ...0 ... +27 mV (entsprechend Prozesswert 0x80.00.00.00 ... 0 ... 0x7F.FF.FF.FF)
–
Messbereich nominell: -25 mV... 0 ... +25 mV
–
max. zulässige Spannung -Uref vs. +Uref: ±27 mV
–
Messfehler < ±0,1 % vom Messbereichsendwert, 50 Hz Filter aktiv
▪
im DMS-Betrieb wird durch den angeschlossenen DMS sichergestellt, dass keine unzulässig hohen Potentialdifferenzen in- und außerhalb der Schaltung entstehen.
In der Standardeinstellung arbeitet die EL/EP3356 als 1-kanalige DMS-Erfassung mit dem Prozessabbild, durch Ändern der Prozessdaten kann die Klemme/Box auf 2-kanalige Spannungsmessung umgestellt werden. Siehe dazu die Hinweise zum Prozessabbild.
Wird die EL/EP3356 nicht als Lastermittlungsklemme/Lastermittlungsbox sondern als 2-kanalige analoge Eingangsmessklemme/Eingangsmessbox verwendet, ist folgendes zu beachten:
▪
Die CoE Einstellungen sind zu finden für:
–
Kanal 1: Objekte unter 0x8010:xx
–
Kanal 2: Objekte unter 0x8020:xx
–
die DMS-Objekte unter x8000:xx sind ohne Funktion. Ausnahme: der Averager (0x8000:03) ist auch im Spannungsmessbetrieb einsetzbar und für beide Kanäle gleichzeitig gültig.
▪
Die Selbstkalibrierung ist nicht möglich und sinnvoll.
▪
Beide analogen Kanäle sind herstellerseitig nicht abgeglichen, da dies für die relative Messung im DMS-Betrieb nicht erforderlich ist. Dies bedeutet z. B. für Kanal 1 mit nominellem Messbereich ±12 V bzw. typ. Messbereich ±13,5 V, dass der maximale Messwert 0x7F.FF.FF.FF bei der einen Klemme/Box bei z. B. 13,4 V, bei einer anderen bei 13,6 V ausgegeben werden kann. Sollen Klemmen/Boxen für gleich anliegende Spannungen gleiche Prozesswerte ausgeben und somit austauschbar sein, muss anwenderseitig durch kanalweise Einstellung im CoE jeder Kanal abgeglichen werden. Dazu können die Anwenderkalibrierung (CoE 0x80n0:17 [offset], 0x80n0:18 [gain]) oder die Anwenderskalierung (CoE 0x80n0:11 [offset], 0x80n0:12 [gain]) benutzt werden.
Spannungsmessung
Im Spannungsmessbetrieb ist die EL3356 in SingleEnded-Beschaltung gegen externes GND zu beschalten. Außerdem ist der interne GND-Bezug durch den CoE-Schalter SymmetricReferencePotential zu schließen. Bei der EP3356 ist „supply“ nicht nutzbar, da die Box intern 10 V erzeugt.


Distributed Clocks Betrieb (nur EL3356-0010 und EP3356-0022)

Inbetriebnahme/Konfiguration [image] Distributed Clocks Betrieb (nur EL3356-0010 und EP3356-0022)
Distributed Clocks Betrieb (nur EL3356-0010 und EP3356-0022)
Im Distributed Clocks-Betrieb (DC-Betrieb) wird zu jedem Messwert der genaue Zeitstempel aufgenommen und als zyklisches Prozessdatum an die Steuerung übertragen. Dazu ist
▪
DC zu aktivieren. Dazu ist im Reiter "DC" die Auswahl „DC-Synchron (input based)“ zu treffen
▪
das PDO 0x1A03 in der Prozessdatenverwaltung ist im SyncManager 3 "Inputs" zu aktivieren
Aktivierung DC und PDO Timestamp im TwinCAT System Manager
Die EL3356-0010/EP3356-0022 arbeitet freilaufend mit zyklischer aber nicht äquidistanter Erfassung, die Zeitabstände zwischen 2 Messwerten sind also nicht konstant. Deshalb ist der zum Prozesswert mitgelieferte 64-Bit-Zeitstempel anwenderseitig auszuwerten.
Um eine Verfälschung der Messergebnisse durch vorgeschaltete Filter zu unterbinden, wird in dieser Betriebsart sowohl der Software-Filter als auch der Averager deaktiviert. Die Messung/Berechnung und Bereitstellung des Messwertes im Prozessdatum erfolgt deshalb mit der dem Modus entsprechenden Wandlungsrate:
▪
EL3356: 10,5 kSps
▪
EL3356-0010/EP3356-0022: 10,5 oder 105,5 kSps
Die minimale zulässige EtherCAT Zykluszeit beträgt für die EL3356-0010/EP3356-0022 mit und ohne DC-Betrieb 100 µs.
Zeitstempel
Zum Zeitpunkt wann der eigentliche Zeitstempel gewonnen wird, siehe die Hinweise zur Latenz.


Prozessdaten

Inbetriebnahme/Konfiguration [image] Prozessdaten
Prozessdaten
In diesem Kapitel werden die einzelnen PDOs mit ihrem Inhalt vorgestellt. Ein PDO (Prozess-Daten-Objekt) ist eine Einheit an zyklisch übertragenen Prozesswerten. So eine Einheit kann eine einzelne Variable (z. B. das Gewicht als 32-Bit-Wert) oder eine Gruppe/Struktur von Variablen sein. Die einzelnen PDOs lassen sich im TwinCAT System Manager einzeln aktivieren bzw. deaktivieren. Dazu dient der Reiter "Prozessdaten" (nur sichtbar wenn links die Klemme/Box ausgewählt ist). Eine Änderung der Prozessdatenzusammenstellung im TwinCAT System Manager wird erst nach Neustart des EtherCAT-Systems wirksam.
Die EL/EP3356 kann in 2 Grundbetriebsarten benutzt werden
▪
1-kanalige DMS-Auswertung (Dehnmessstreifen, Wägebalken, Load Cell). Hierbei werden intern beide analogen Eingangsspannungen gemessen, nach den klemmeninternen/boxeninternen Einstellungen lokal verrechnet und der resultierende Lastwert als zyklischer Prozesswert an die Steuerung ausgegeben. Die Klemme/Box ist als 1-kanalige Klemme/Box zu betrachten. Der Lastwert kann in Ganzzahl/Integer oder als Float/Real-Darstellung ausgegeben werden.
▪
2-kanalige Spannungsmessung. Beide analogen Eingangsspannungen werden direkt als Prozesswerte ausgegeben, es findet keine Lastberechnung statt. Für jeden Kanal kann der Wert und die Statusinformationen ausgegeben werden.
Über die Auswahl der Prozessdaten (PDO) wird die Grundbetriebsart der Klemme EL3356/ Box EP3356 bestimmt.
EL/EP3356 und Sonderversionen
EL3356, EL3356-0010 und EP3356-0022 verfügen über dieselben Prozessdatenobjekte außer: - EL3356: keine Modus-Umschaltung im ControlWord
Prozessdatenauswahl
Die Prozessdaten der EL/EP3356 werden im TwinCAT System Manager eingerichtet. Die einzelnen PDOs lassen sich einzeln aktivieren bzw. deaktivieren. Dazu dient der Reiter "Prozessdaten" (nur sichtbar wenn links die Klemme/Box ausgewählt ist).
EP3356 Prozessdatenauswahl im TwinCAT Systemmanager1
EP3356 Prozessdatenauswahl im TwinCAT Systemmanager
Wenn im System Manager die Klemme/Box ausgewählt ist (A) zeigt der Reiter Prozessdaten (B) die PDO-Auswahl. Es können die beiden SyncManager der Eingänge/Inputs (SM3) und Ausgänge/Outputs (SM2) (C) verändert werden. Wird einer der beiden angeklickt, erscheint darunter die für diesen SyncManager möglichen PDO (D). Bereits aktivierte PDO haben vorne ein Häkchen, die Aktivierung geschieht durch Anklicken.
Die dann zum Gerät gehörigen Prozessdaten sind darunter aufgelistet (G). Damit die einzelnen Bitbedeutungen z.B. im Status-Wort Status sichtbar und einzeln verlinkbar sind (G), muss im Systemmanager ShowSubVariablen aktiviert werden (F). An welcher Bitposition die SubVariablen im Status- oder Control-Word Ctrl) sind, ist auch aus der Adressübersicht (H) oder den nachfolgenden Angaben zu entnehmen.
Predefined PDO Assignment
Um die Konfiguration zu vereinfachen sind in der Gerätebeschreibung typische Konfigurationskombinationen aus Prozessdaten hinterlegt. In der Prozessdatenübersicht können die vordefinierten Zusammenstellungen ausgewählt werden. Daher steht die Funktion nur zur Verfügung, wenn die ESI/XML-Dateien auf dem System hinterlegt sind (zum Download auf der Beckhoff Webseite).
Folgende Kombinationen sind möglich (siehe auch vorherige Abbildung, E):
▪
Standard (INT32): [Default-Einstellung] Lastberechnung; 32-Bit Integer-Lastwert als Endwert entsprechend der Rechenvorgaben im CoE, keine weitere Umrechnung in der PLC mehr nötig
▪
Standard (REAL): Lastberechnung; 32-Bit Fließkomma-Lastwert als Endwert entsprechend der Rechenvorgaben im CoE, keine weitere Umrechnung in der PLC mehr nötig
▪
2x AnalogIn (Standard): 2-kanalige Spannungsmessung, 32-Bit Integer-Spannungswert mit Zusatzinformationen (Underrange, Overrange, Error, TxPdoToggle)
▪
2x AnalogIn (Compact): 2-kanalige Spannungsmessung, nur 32-Bit Integer-Spannungswert
Default Prozessabbild
Das Default-Prozessabbild ist Standard (INT32).
Default-Prozessabbild EP3356-0022
Hinweis EL3356: ohne Umschaltung SampleMode im Ctrl-Word
Funktion der Variablen
Variable: Status
Bedeutung: Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme/Box zur Steuerung übertragen.
Bit | SW. 15 | SW. 14 | SW. 13 | SW.12 | SW. 11 | SW. 10 | SW. 9 | SW. 8 | SW. 7 | SW. 6 | SW. 5 | SW. 4 | SW. 3 | SW. 2 | SW. 1 | SW. 0
Name | TxPdo Toggle | - | Sync Error | - | - | - | - | Steady State | Calibration in progress | Error | - | - | Data invalid | - | Overrange | -
Bedeutung | Toggelt 0→1->0 bei jedem aktualisierten Datensatz | - | Synchronisierungsfehler |  |  |  |  | Ruheerkennung | Kalibriervorgang läuft | Sammelanzeige der Fehler | - | - | Eingangsdaten sind ungültig | - | Messbereich überschritten | -
Variable: Value
Bedeutung: Berechneter 32-Bit DINT Lastwert in Einheit [1], mit Vorzeichen
Variable: Value (Real)
Bedeutung: Berechneter 32-Bit Festkomma-REAL Lastwert mit Mantisse und Exponent in Einheit [1]. Das Format entspricht dem REAL aus der IEC 61131-3, die wiederum beim REAL Format auf die IEC 559 verweist. Dort ist eine REAL Zahl (einfache Genauigkeit) wie folgt definiert (siehe dazu auch Beckhoff InfoSys: TwinCAT PLC Control: Standard Data Types). Diese 32-Bit-Variable kann nach IEC 61131 direkt mit einer FLOAT-Variable der PLC verlinkt werden.
Bitposition (von links) | 1 | 8 | 23 (+1 „hidden bit“, siehe IE559)
Funktion | Vorzeichen | Exponent | Mantisse
Variable: WcState
Bedeutung: Zyklische Diagnosevariable; "0" zeigt ordnungsgemäße Datenübertragung an
Variable: Status
Bedeutung: State des EtherCAT Gerätes; State.3 = TRUE zeigt ordnungsgemäßen Betrieb in OP an
Variable: AdsAddr
Bedeutung: AmsNet-Adresse des EtherCAT Gerätes aus AmsNetId (hier: 192.168.0.20.5.1) und Port (hier: 1003)
Variable: Ctrl
Bedeutung: Das Control-Wort (CW) befindet sich im Ausgangsprozessabbild und wird von der Steuerung zur Klemme/Box übertragen.
Bit | CW. 15 | CW. 14 | CW. 13 | CW. 12 | CW. 11 | CW. 10 | CW. 9 | CW. 8 | CW. 7 | CW. 6 | CW. 5 | CW. 4 | CW. 3 | CW. 2 | CW. 1 | CW. 0
Name | - |  |  |  |  |  |  |  |  |  |  | Tara | Sample Mode | Input Freeze | Disable Calibration | Start Calibration
Bedeutung | - |  |  |  |  |  |  |  |  |  |  | Startet Tara | Umschaltung Modus (nur EL3356-0010 und EP3356-0022) | Stoppt die Messung | Schaltet die automatische Selbstkalibrierung ab | Startet umgehend die Selbstkalibrierung
Zur Zerlegung der Status- und Ctrl-Variable siehe auch das Beispielprogramm.
Varianten (Predefined PDO)
Festkomma-Darstellung der Last
Die Anzeige des Lastwertes kann auch schon in der Klemme/Box in eine Kommadarstellung umgerechnet werden. Dazu sind die Eingangs-PDO wie folgt zu ändern:
Lastwert in Festkomma-Darstellung
Variable: Value (Real)
Bedeutung: berechneter 32-Bit Festkomma-REAL Lastwert mit Mantisse und Exponent in Einheit [1]. Das Format entspricht dem REAL aus der IEC 61131-3, die wiederum beim REAL Format auf die IEC 559 verweist. Dort ist eine REAL Zahl (einfache Genauigkeit) wie folgt definiert (siehe dazu auch Beckhoff InfoSys: TwinCAT PLC Control: Standard Data Types). Diese 32-Bit-Variable kann nach IEC 61131 direkt mit einer FLOAT-Variable der PLC verlinkt werden.
Bitposition (von links) | 1 | 8 | 23 (+1 „hidden bit“, siehe IEC 559)
Funktionen | Vorzeichen | Exponent | Mantisse
Spannungsmessung
Die EL/EP3356 kann auch als 2-kanalige analoge Eingangsklemme/Eingangsbox zur Spannungsmessung verwendet werden, siehe Hinweise.
EP3356-0022 Spannungsmessung Predefined1 PDO
Spannungsmessung
Variable | Bedeutung
Underrange | Messbereich unterschritten
Overrange | Messbereich überschritten
Error | Sammelanzeige der Fehler
TyPdo Toggle | Toggelt 0 → 1 → 0 bei jedem aktualisierten Datensatz
Value | Rechtsbündiger Spannungswert über den jeweiligen Messbereich (Wertebereich 0x80.00.00.00…0…0x7F.FF.FF.FF) Kanal 1: Versorgungsspannung Kanal 2: Brückenspannung
Distributed Clocks
Im DC-Betrieb (Distributed Clocks) muss das Prozessdatum 0x1A03 Timestamp aktiviert werden.
Im DC-Betrieb werden bei den Prozessdaten außerdem die Variablen DcOutputShift und DcInputShift eingeblendet. Diese werden einmalig beim Aktivieren der Konfiguration auf Basis der eingestellten EtherCAT Zykluszeit (zugeordnete Task beachten!) und DC-ShiftZeiten aus den EtherCAT-Master-Einstellungen in der Einheit [ns] berechnet. In der Betriebsart InputBased gibt DcInputShift an, um wie viele Nanosekunden [ns] vor oder nach dem globalen Sync die Klemme/Box Ihre Prozessdaten ermittelt. Weitere Informationen dazu siehe die EtherCAT Systembeschreibung.
Da die EL3356-0010/EP3356-0022 nicht DC-getriggert arbeitet sondern selbst den Timestamp ermittelt, sind diese Werte bei der EL3356-0010/EP3356-0022 ohne Bedeutung.
Sync Manager (SM)
PDO-Zuordnung
Inputs: SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt Index - Bezeichnung
0x1A00 (default) | - | 2.0 | RMB Status (Resistor Measurement Bridge) | 0x6000:02 - Overrange 0x6000:04 - Data invalid 0x6000:07 - Error 0x6000:08 - Calibration in progress 0x6000:09 - Steady State 0x1C32:20 - Sync Error 0x1800:09 - TxPDO Toggle
0x1A01 (default) | 0x1A02 0x1A04 0x1A05 0x1A06 0x1A07 | 4.0 | RMB Value (INT 32) | 0x6000:11 - Value
0x1A02 | 0x1A01 0x1A04 0x1A05 0x1A06 0x1A07 | 4.0 | RMB Value (Real) | 0x6000:12 - Value
0x1A03 | 0x1A04 0x1A05 0x1A06 0x1A07 | 8.0 | RMB Timestamp | 0x6000:13 - Value
0x1A04 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A05 | 6.0 | AI Standard Channel 1 (Analog Input) | 0x6010:01 - Underrange 0x6010:02 - Overrange 0x6010:07 - Error 0x6010:10 - TxPDO Toggle 0x6010:11 - Value
0x1A05 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A04 | 4.0 | AI Standard Channel 1 (Analog Input) | 0x6010:11 - Value
0x1A06 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A07 | 6.0 | AI Standard Channel 2 (Analog Input) | 0x6020:01 - Underrange 0x6020:02 - Overrange 0x6020:07 - Error 0x6020:10 - TxPDO Toggle 0x6020:11 - Value
0x1A07 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A06 | 4.0 | AI Standard Channel 2 (Analog Input) | 0x6020:11 - Value
Outputs: SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt Index - Bezeichnung
0x1600 (default) | - | 2.0 | RMB Control (Resistor Measurement bridge) | 0x7000:01 - Start calibration 0x7000:02 - Disable calibration 0x7000:03 - Input freeze 0x7000:04 - Sample Mode (nur EL3356-0010/EP3356-0022) 0x7000:05 - Tara


CoE - Objektbeschreibung und Parametrierung

Inbetriebnahme/Konfiguration [image] CoE - Objektbeschreibung und Parametrierung
CoE - Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Index 1011: Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 RMB Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | RMB Settings | Max. Subindex | UINT8 | RO | 0x32 (50dez)
8000:01 | Mode0 enable filter | 0: Keine Filter aktiv. Die Klemme/Box arbeitet Zyklussynchron 1: Die in Subindex 0x8000:11 bzw. 0x8000:12 gewählten Filtereinstellungen sind aktiv. | BOOLEAN | RW | 0x01 (1dez)
8000:02 | Mode1 enable filter (Nur EL3356-0010/EP3356-0022) |  | BOOLEAN | RW | 0x01 (1dez)
8000:03 | Mode0 enable averager | Hardware Mittelwertfilter aktivieren | BOOLEAN | RW | 0x01 (1dez)
8000:04 | Mode1 enable averager (Nur EL3356-0010/EP3356-0022) |  | BOOLEAN | RW | 0x01 (1dez)
8000:05 | Symmetric reference potential | Symmetrische Messung einschalten | BOOLEAN | RW | 0x01 (1dez)
8000:11 | Mode0 filter settings | 0: FIR 50 Hz 1: FIR 60 Hz 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 10: Dynamic IIR 11: PDO Filter frequency siehe Filter | UINT16 | RW | 0x0000 (0dez)
8000:12 | Mode1 filter settings (Nur EL3356-0010/EP3356-0022) |  | UINT16 | RW | 0x0000 (0dez)
8000:13 | Dynamic filter change time | Abtastrate für die dynamische Filterumschaltung. Skalierung in 0.01 ms (100 = 1 s) (nur wenn die Filter eingeschaltet sind und als Filter "dynamic IIR" gewählt ist) | UINT16 | RW | 0x000A (10dez)
8000:14 | Dynamic filter delta | Grenzwert für die dynamische Filterumschaltung. (nur wenn die Filter eingeschaltet sind und als Filter "dynamic IIR" gewählt ist) | REAL32 | RW | 0x41A00000 (1101004800dez) = 20.0
8000:21 | Gain | Skalierungsfaktor | REAL32 | RW | 0x3F800000 (1065353216dez) = 1.0
8000:22 | Tara | Offset des Prozessdatenwertes | REAL32 | RW | 0x00000000 (0dez) = 0.0
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:23 | Rated output | Nennkennwert des Sensorelementes in mV/V | REAL32 | RW | 0x40000000 (1073741824dez) = 2.0
8000:24 | Nominal load | Nennlast des Kraftaufnehmers/Wägezelle/ect. (z.B. in kg oder N oder ..) | REAL32 | RW | 0x40A00000 (1084227584dez) = 5.0
8000:25 | Zero balance | Nullpunkt-Offset in mV/V | REAL32 | RW | 0x00000000 (0dez) = 0.0
8000:26 | Gravity of earth | Aktuelle Erdbeschleunigung (default 9.806650) | REAL32 | RW | 0x411CE80A (1092413450dez) = 9.806650
8000:27 | Scale factor | Über diesen Faktor kann das Prozessdatum umskaliert werden. Um z.B. die Anzeige von kg in g zu ändern, kann hier der Faktor 1000 eingetragen werden. | REAL32 | RW | 0x447A0000 (1148846080dez) = 1000.0
8000:28 | Reference load | Referenzgewicht für manuelles Kalibrieren | REAL32 | RW | 0x40A00000 (1084227584dez) = 5.0
8000:29 | Steady state window | Zeitkonstante für das "Steady state" Bit (dient zur Ruheerkennung) | UINT16 | RW | 0x03E8 (1000dez)
8000:2A | Steady state tolerance | Toleranzfenster für das "Steady state" Bit | UINT32 | RW | 0x00000005 (5dez)
8000:31 | Calibration interval | Kalibrierintervall für die automatische Kalibrierung der Klemme/Box. Die Einheit ist 100 ms. Der kleinstmögliche Wert ist 5. (500 ms) Ein Wert von 0 schaltet die automatische Selbstkalibrierung aus. Dies ist auch über das Prozessdaten-Bit "Disable calibration" möglich. | UINT16 | RW | 0x0708 (1800dez)
8000:32 | Test interval | Dieses Register beinhaltet das Prüfintervall für den zyklischen Selbsttest der Klemme/Box. Dieses Intervall ist immer ein vielfaches (Default: 10dez) des Kalibrierintervalls (0x8000:31). Somit ergibt sich im Auslieferungszustand ein Prüfintervall von 10 x 180 s = 1800 s. Über das Prozessdaten-Bit "Disable calibration" kann der Selbsttest unterbunden werden. | UINT16 | RW | 0x000A (10dez)
Index 8010, 8020 AI Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | AI Settings | Max. Subindex | UINT8 | RO | 0x18 (24dez)
80n0:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
80n0:06 | Enable filter | Filter aktivieren | BOOLEAN | RW | 0x01 (1dez)
80n0:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
80n0:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
80n0:11 | User scale offset | Offset der Anwenderskalierung | INT32 | RW | 0x00000000 (0dez)
80n0:12 | User scale gain | Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt | INT32 | RW | 0x00010000 (65536dez)
80n0:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. 0: 50 Hz FIR 1: 60 Hz FIR 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 | UINT16 | RW | 0x0000 (0dez)
80n0:17 | User calibration offset | Anwender Offset Abgleich | INT32 | RW | 0x00000000 (0dez)
80n0:18 | User calibration gain | Anwender Gain Abgleich | INT16 | RW | 0x4000 (16384dez)
Kommando-Objekt, Index FB00 RMB Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | RMB Command | Max. Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Über das Request-Objekt können Kommandos an die Klemme/Box abgesetzt werden. Befehl: - 0x0101: Nullabgleich - 0x0102: Kalibrierung - 0x0001 Tarierung - 0x0002 Tarierung (Daten werden im EEProm gespeichert) s. Kommandos | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status des aktuell ausgeführten Kommandos 0: Kommando fehlerfrei ausgeführt 255: Kommando wird ausgeführt | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | Optionaler Rückgabewert des Kommandos | OCTET-STRING[4] | RO | {0}
Eingangsdaten, Index 6000 RMB Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | RMB Inputs | Max. Subindex | UINT8 | RO | 0x13 (19dez)
6000:02 | Overrange | Der Messwert hat seinen Endwert erreicht | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Data invalid | Die angezeigten Prozessdaten sind ungültig. z.B. während der Kalibrierung. | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Error | Es ist ein Fehler aufgetreten. | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Calibration in progress | Die Kalibrierung läuft. Die Prozessdaten zeigen den letzten gültigen Messwert an. | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Steady state |  | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync Error Bit wird nur für den Distributed Clocks Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Messwert als 32 Bit signed Integer | INT32 | RO | 0x61746144 (1635017028dez)
6000:12 | Value (Real) | Messwert als Real | REAL32 | RO | 0x00000000 (0dez)
6000:13 | Timestamp | Timestamp des aktuellen Messwertes. (Nur EL3356-0010/EP3356-0022 im DC-Betrieb) | UINT64 | RO |
Eingangsdaten Index 6010, 6020 AI Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | AI Inputs | Max. Subindex | UINT8 | RO | 0x11 (17dez)
60n0:01 | Underrange | Messbereich unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overrange | Messbereich überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Error | Es ist ein Fehler aufgetreten. - Over- / Underrange Udif - Over- / Underrange Uref - die externe Uref ist zu klein (zwischen -1 V und +1 V) - Data invalid | BOOLEAN | RO | 0x00 (0dez)
60n0:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n0:11 | Value | 32 Bit Messwert | INT32 | RO | 0x00000000 (0dez)
Ausgangsdaten, Index 7000 RMB Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | RMB Outputs | Max. Subindex | UINT8 | RO | 0x05 (5dez)
7000:01 | Start calibration | Mit einer steigenden Flanke kann die Kalibrierung manuell gestartet werden. Somit kann verhindert werden, dass die Kalibrierung zu einem ungünstigen Zeitpunkt automatisch gestartet wird. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Disable calibration | 0: Die automatische Kalibrierung ist aktiv. 1: Die automatische Kalibrierung ist abgeschaltet. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Input freeze | Die Prozessdaten und die digitalen Filter werden eingefroren. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Sample mode | Auswahl des Aufnahmemodus: 0: 10,5 kHz High precision 1: 105 kHz Low latency | BOOLEAN | RO | 0x00 (0dez)
7000:05 | Tara | Mit einer steigenden Flanke kann das Prozessdatum auf 0 gesetzt werden. Der Tara-Wert wird nicht im EEProm gespeichert und steht somit nach einem Reset der Klemme/Box nicht mehr zur Verfügung. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Filter frequency | Filterfrequenz des variablen PDO-Filters in 0,1 Hz. siehe Filter Wertebereich: 1 ... 2000 (entspricht 0,1 ... 200 Hz) Bei einem Wert von 0 bzw. größer 2000, verhält sich das Filter wie ein 50 Hz FIR Filter | UINT16 | RO | 0x00 (0dez)
Informations-/Diagnostikdaten, Index 801E, 802E AI Internal data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | AI Internal data | Max. Subindex | UINT8 | RO | 0x01 (1dez)
801E:01 | ADC raw value 1 | ADC Rohwert | INT32 | RO | 0x00000000 (0dez)
Index 9000 RMB Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9000:0 | RMB Info data | Max. Subindex | UINT8 | RO | 0x11 (17dez)
9000:11 | mV/V | Aktueller mV/V Wert | REAL32 | RO | 0x00000000 (0dez)
Index A000 RMB Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | RMB Diag data | Max. Subindex | UINT8 | RO | 0x18 (24dez)
A000:11 | No internal referecnce supply | Keine interne Referenzspannung am ADC-Eingangs (URef Kanal) | BOOLEAN | RO | 0x00 (0dez)
A000:12 | No internal referecnce bridge | Keine interne Referenzspannung am ADC-Eingangs (UDif Kanal) | BOOLEAN | RO | 0x00 (0dez)
A000:13 | No external reference supply | Die externe Referenzspannung ist kleiner ±1V | BOOLEAN | RO | 0x00 (0dez)
A000:15 | Overrange bridge | Messbereichsüberschreitung im Brückenzweig | BOOLEAN | RO | 0x00 (0dez)
A000:16 | Underrange bridge | Messbereichsunterschreitung im Brückenzweig | BOOLEAN | RO | 0x00 (0dez)
A000:17 | Overrange supply | Messbereichsüberschreitung der Referenzspannung | BOOLEAN | RO | 0x00 (0dez)
A000:18 | Underrange supply | Messbereichsunterschreitung der Referenzspannung | BOOLEAN | RO | 0x00 (0dez)
Hersteller-Konfigurationsdaten, Index 801F, 802F AI Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | AI Vendor data | Max. Subindex | UINT8 | RO | 0x02 (2dez)
801F:01 | Calibration offset | Offset (Herstellerabgleich) | INT32 | RW | 0x01E10000 (31522816dez)
801F:02 | Calibration gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Standardobjekte, Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01681389 (23597961dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL3356 / EP3356
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0D1C3052 (219951186dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer/Sonderboxennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 RMB RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RMB RxPDO-Map Control | PDO Mapping RxPDO-Map control | UINT8 | RO | 0x07 (7dez)
1600:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x01 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:01, 1
1600:02 | Subindex 002 | 2. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x02 (Disable calibration)) | OCTET-STRING[10] | RO | 0x7000:02, 1
1600:03 | Subindex 003 | 3. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x03 (Input freeze)) | OCTET-STRING[10] | RO | 0x7000:03, 1
1600:04 | Subindex 004 | 4. PDO Mapping entry (1 bit align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1600:05 | Subindex 005 | 5. PDO Mapping entry (object 0x7000 (RMB outputs), entry 0x05 (Tara)) | OCTET-STRING[10] | RO | 0x7000:05, 1
1600:06 | Subindex 006 | 6. PDO Mapping entry (3 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 3
1600:07 | Subindex 007 | 7. PDO Mapping entry (8 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 8
Index 1601 RMB RxPDO-Map-Filter frequency
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | RMB RxPDO-Map Filter frequency | PDO Mapping RxPDO-Map Filter frequency | UINT8 | RO | 0x01 (1dez)
1601:01 | Subindex 001 | 1. PDO Mapping entry (object 0x7000 (RMB ouputs), entry 0x11 (Start calibration)) | OCTET-STRING[10] | RO | 0x7000:11, 16
Index 1800 RMB TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | RMB TxPDO-Par Status | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[10] | RO | 04 1A 05 1A 06 1A 07 1A 00 00
Index 1801 RMB TxPDO-Par Value (INT 32)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | RMB TxPDO-Par Value (INT32) | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[10] | RO | 02 1A 04 1A 05 1A 06 1A 07 1A
Index 1802 RMB TxPDO-Par Value (Real)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | RMB TxPDO-Par Value (Real) | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[10] | RO | 01 1A 04 1A 05 1A 06 1A 07 1A
Index 1803 RMB TxPDO-Par Timestamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | RMB TxPDO-Par Timestamp | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[10] | RO | 04 1A 05 1A 06 1A 07 1A 00 00
Index 1804 AI TxPDO-Par Standard Ch. 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.1 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[10] | RO | 05 1A 00 1A 01 1A 02 1A 03 1A
Index 1805 AI TxPDO-Par Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.1 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[10] | RO | 04 1A 00 1A 01 1A 02 1A 03 1A
Index 1806 AI TxPDO-Par Standard Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.2 | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[10] | RO | 07 1A 00 1A 01 1A 02 1A 03 1A
Index 1807 AI TxPDO-Par Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.2 | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[10] | RO | 06 1A 00 1A 01 1A 02 1A 03 1A
Index 1A00 RMB TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | RMB TxPDO-Map Status | PDO Mapping RxPDO-Map Status | UINT8 | RO | 0x0C (12dez)
1A00:01 | Subindex 001 | 1. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:02 | Subindex 002 | 2. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x02 (Overrange)) | OCTET-STRING[10] | RO | 0x6000:02, 1
1A00:03 | Subindex 003 | 3. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:04 | Subindex 004 | 4. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x04 (Data invalid)) | OCTET-STRING[10] | RO | 0x6000:04, 1
1A00:05 | Subindex 005 | 5. PDO Mapping entry (2 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 2
1A00:06 | Subindex 006 | 6. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x07 (Error)) | OCTET-STRING[10] | RO | 0x6000:07, 1
1A00:07 | Subindex 007 | 7. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x08 (Calibration in progress)) | OCTET-STRING[10] | RO | 0x6000:08, 1
1A00:08 | Subindex 008 | 8. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x09 (Steady state)) | OCTET-STRING[10] | RO | 0x6000:09, 1
1A00:09 | Subindex 009 | 9. PDO Mapping entry (4 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 4
1A00:0A | Subindex 010 | 10. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x0E (Sync error)) | OCTET-STRING[10] | RO | 0x6000:0E, 1
1A00:0B | Subindex 011 | 11. PDO Mapping entry (1 bits align) | OCTET-STRING[10] | RO | 0x0000:00, 1
1A00:0C | Subindex 012 | 12. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x10 (TxPDO Toggle)) | OCTET-STRING[10] | RO | 0x6000:10, 1
Index 1A01 RMB TxPDO-Map Value (INT32)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | RMB TxPDO-Map Value (INT32) | PDO Mapping Value (INT32) | UINT8 | RW | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 32
Index 1A02 RMB TxPDO-Map Value (Real)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | RMB TxPDO-Map Value (real) | PDO Mapping Value (real) | UINT8 | RW | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RMB inputs), entry 0x12 (Value (real))) | UINT32 | RW | 0x6000:12, 32
Index 1A03 RMB TxPDO-Map Timestamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | RMB TxPDO-Map Timestamp | PDO Mapping Value Timestamp | UINT8 | RW | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x0000, entry 0x00) | UINT64 | RW | 0x0000:00, 64
Index 1A04 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | AI supply TxPDO-Map Standard Ch. 1 | PDO Mapping TxPDO Standard Ch. 1 | UINT8 | RW | 0x07 (7dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6010:07, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6010:10, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A05 AI TxPDO-Map Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | AI supply TxPDO-Map Compact Ch. 1 | PDO Mapping TxPDO Compact Ch. 1 | UINT8 | RW | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010, entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 32
Index 1A06 AI TxPDO-Map Standard Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | AI supply TxPDO-Map Standard Ch. 2 | PDO Mapping TxPDO Standard Ch. 2 | UINT8 | RW | 0x07 (7dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI supply Inputs), entry 0x04 (Error)) | UINT32 | RW | 0x6020:07, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RW | 0x0000:00, 8
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020, entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6020:10, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1A07 AI TxPDO-Map Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | AI supply TxPDO-Map Compact Ch. 2 | PDO Mapping TxPDO Compact Ch. 2 | UINT8 | RW | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020, entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | -
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | -
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C65D4 (812500dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0000C350 (50000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum Delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000C65D4 (812500dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0000C350 (50000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | RMB | UINT32 | RW | 0x00000172 (370dez)
F010:02 | SubIndex 002 | AI | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 | AI | UINT32 | RW | 0x0000012C (300dez)


Beispielprogramm

Inbetriebnahme/Konfiguration [image] Beispielprogramm
Beispielprogramm
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Kunden zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlende Angaben.
In dem vorliegenden Beispielprogramm wird eine EP3356-0022 von einem PLC-Programm angesprochen (für TwinCAT 2). In der Zip-Datei ( ) befinden sich das PLC*.pro und der Systemmanager *.tsm. Über einfache Visualisierung kann die Box bedient werden, die Funktion InputFreeze ist beispielhaft ausprogrammiert.
Bedienung des Beispielprogramms
Die Klemme EL3356 ist dabei wie folgt anzuschließen:
EL3356: Anschluss des Lastsensors/Vollbrücke
Es wird hier eine Netzteilklemme EL9510 zur Speisung der DMS mit 10 V benutzt.
Das Box-Modul EP3356 ist dabei wie folgt anzuschließen:
Anschluss der Wägezelle
EP3356: Anschluss des Lastsensors/Vollbrücke
Die Sensorversorgung von 10 V wird in der EP3356 erzeugt.
Vorgehensweise zum Starten des Programms
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.TSM (Konfigurationsdatei und *.PRO (PLC-Programmdatei) in einem temporären Arbeitsordner
▪
Start der *.TSM-Datei und *.PRO Datei; der TwinCAT-System Manger und die TwinCAT PLC öffnen sich
▪
Schließen Sie die Hardware entsprechend einer der beiden vorherigen Abbildungen an und verbinden Sie den Ethernet-Adapter ihres PCs mit dem EtherCAT-Koppler / EtherCAT-Box (weitere Hinweise zu den EtherCAT-Kopplern finden sie in den entsprechenden Kopplerhandbüchern)
▪
Auswahl des lokalen Ethernet-Adapters (ggf. mit Echtzeit-Treiber) unter Systemkonfiguration, E/A - Konfiguration, E/A -Geräte, Gerät (EtherCAT); dann unter Karteireiter "Adapter", "Suchen..." den entsprechenden Adapter auswählen und bestätigen (siehe die beiden nachfolgende Abbildungen)
Suchen des Ethernet-Adapters
Auswahl und Bestätigung des Ethernet-Adapters
▪
Aktivieren und bestätigen der Konfiguration (siehe die beiden nachfolgenden Abbildungen)
Aktivierung der Konfiguration
Konfigurationsaktivierung bestätigen
▪
Neue Variablenzuordnung bestätigen, Neustart im RUN-Modus (siehe die beiden nachfolgenden Abbildungen)
Variablenzuordnung erzeugen
Neustart TwinCAT im RUN-Modus
▪
In der TwinCAT PLC unter Menü „Projekt“ → „Alles Übersetzen“ das Projekt übersetzen
Projekt übersetzen
▪
In der TwinCAT PLC: Einloggen mit der Taste „F11“, Laden des Programms bestätigen, Start des Programms mit Taste „F5“
Programmstart bestätigen


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme/Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.