EP31xx - EtherCAT-Box-Module mit konfigurierbaren analogen Eingängen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.3.0
▪
Anzugsmomente für Steckverbinder aktualisiert
▪
EP3174-0092 hinzugefügt
▪
Update Kapitel Montage
▪
Update Kapitel Betriebsmodi
▪
Update Struktur
2.2.0
▪
EP3162-0002 - Analoge Spannungseingänge M12 aktualisiert
▪
EP3162-0002 - Analoge Stromeingänge M12 aktualisiert
▪
EP3162-0002 - Galvanische Trennung der Kanäle aktualisiert
▪
Hinweise zur analogen Spezifikation hinzugefügt
▪
Verkabelung aktualisiert
2.1.0
▪
EP3162-0002 hinzugefügt
▪
Objektbeschreibung und Parametrierung EP31x4 aktualisiert
▪
Objektbeschreibung und Parametrierung EP31x2 hinzugefügt
▪
Objektübersicht EP31x4 aktualisiert
▪
Objektübersicht EP31x2 hinzugefügt
▪
Anzugsmomente für Steckverbinder aktualisiert
▪
Spannungsversorgung aktualisiert
2.0.0
▪
Migration
1.5.0
▪
Anschlussbeschreibung für analoge Stromeingänge (M12) überarbeitet
▪
Kapitel „Einstellungen und Betriebsmodi“ aktualisiert
1.4.0
▪
Signaleinstellungen ergänzt
▪
Anschluss der Sensoren aktualisiert
1.3.0
▪
Objektbeschreibung aktualisiert
1.2.0
▪
Technische Daten aktualisiert
▪
Übersicht der EtherCAT-Kabel erweitert
▪
Montage und Verkabelung aktualisiert
1.1.0
▪
Beschreibung der Power-LEDs erweitert
▪
Objektbeschreibung erweitert
▪
Technische Daten aktualisiert
1.0.1
▪
Objektbeschreibung korrigiert
1.0.0
▪
Beschreibung der Status-LEDs überarbeitet
0.6
▪
EP3182-1002 hinzugefügt
▪
Zubehör hinzugefügt
▪
Anzugsmomente für Steckverbinder hinzugefügt
▪
Objektbeschreibung korrigiert
0.5
▪
Erste vorläufige Version
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer):
D: WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D-Nr. 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
Modulübersicht
•
EP3162-0002 - Einführung
•
EP3162-0002 - Technische Daten
•
EP3162-0002 - Prozessabbild
•
EP3182-1002 - Einführung
•
EP3182-1002 - Technische Daten
•
EP3182-1002 - Prozessabbild
•
EP3174-0002 - Einführung
•
EP3174-0092 - Einführung
•
EP3184-0002 - Einführung
•
EP3184-1002 - Einführung
•
EP3174, EP3184 - Technische Daten
•
EP31x4-x0x2 - Prozessabbild
•
EP3174-0092 - Prozessabbild (mit TwinSAFE SC Module)


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


Modulübersicht

Produktübersicht [image] Modulübersicht
Modulübersicht
Analoge Eingangsmodule, 24 VDC
Modul | Anzahl analoger Eingänge | Anzahl digitaler Ausgänge | Signalanschluss | Kommentar
EP3162-0002 | 2 | 0 | 2 x M12 | zwei konfigurierbare, analoge Single-Ended-Eingänge
EP3174-0002 | 4 | 0 | 4 x M12 | vier konfigurierbare, analoge Differenzeingänge
EP3174-0092 | 4 | 0 | 4 x M12 | zwei konfigurierbare, analoge Single-Ended-Eingänge, TwinSAFE Single Channel
EP3182-1002 | 2 | 2 | 2 x M12 | zwei konfigurierbare, analoge Single-Ended-Eingänge zwei digitale Ausgänge
EP3184-0002 | 4 |  | 4 x M12 | vier konfigurierbare, analoge Single-Ended-Eingänge
EP3184-1002 | 4 | 0 | 2 x M12 | vier konfigurierbare, analoge Single-Ended-Eingänge


EP3162-0002 - Einführung

Produktübersicht [image] EP3162-0002 - Einführung
EP3162-0002 - Einführung
EP3162-0002
2-Kanal-Analog-Eingang ± 10 V oder 0/4…20 mA, galvanisch getrennt, single-ended, 16 Bit
Die EtherCAT Box EP3162 verfügt über zwei analoge Eingänge, die einzeln parametriert werden können, sodass sie entweder Signale im Bereich von -10 V bis +10 V oder im Bereich von 0/4 mA bis 20 mA verarbeiten. Die Spannung bzw. der Eingangsstrom wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert.
Die zwei Eingangskanäle sind galvanisch untereinander getrennt. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar. Die Skalierung der Eingänge kann bei Bedarf verändert werden; eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT. Die Parameter werden auf der Baugruppe gespeichert.
Quick Links


EP3162-0002 - Technische Daten

Produktübersicht [image] EP3162-0002 - Technische Daten
EP3162-0002 - Technische Daten
Technische Daten | EP3162-0002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8-Buchse (grün), geschirmt, schraubbar
Anzahl Eingänge | 2
Anschluss Eingänge | M12, schraubbar
Anschlusstechnik | single ended
Signaltyp | Konfigurierbar: 0 V…+10 V -10 V…+10 V 0 mA…20 mA 4 mA…20 mA -20 mA…+20 mA
Innenwiderstand | > 200 kΩ (85 Ω typ. + Diodenspannung)
Gleichtaktspannung UCM | max. 35 V
Auflösung | 16 Bit (inkl. Vorzeichen)
Eingangsfilter | konfigurierbar
Eingangsfilter Grenzfrequenz | 5 kHz
Wandlungszeit | ~ 100 µs
Nennspannung | 24 VDC (-15 %/+20 %)
Distributed-Clocks | ja
Messfehler | < ± 0,3 % (bezogen auf den Messbereichsendwert)
Versorgung der Modulelektronik | aus der Steuerspannung US
Stromaufnahme der Modulelektronik | typisch 120 mA
Sensorversorgung | UA (abgeleitet aus US), DC
Versorgungsstrom der analogen Eingänge | 50 mA (100 mA Peak)
Anschluss Spannungsversorgung | Einspeisung: 1 x M8-Stecker, 4-polig; Weiterleitung: 1 x M8-Buchse, 4-polig
Breite im Prozessabbild | Eingänge: 2 x 16-bit Status: 4x 8-Bit
Potenzialtrennung | 500 V Feldbus, 300 V Signale/Signal
Besondere Eigenschaften | Galvanische Trennung der Kanäle
Gewicht | ca. 165 g
Zulässige Umgebungstemperatur im Betrieb | -25…+60 °C
Zulässige Umgebungstemperatur bei Lagerung | -40…+85 °C
Vibrations- / Schockfestigkeit | gemäß EN60068-2-6 / EN60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 65/66/67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus


EP3162-0002 - Prozessabbild

Produktübersicht [image] EP3162-0002 - Prozessabbild
EP3162-0002 - Prozessabbild
AI Standard Channel 1 und 2
Unter AI Standard Channel 1 finden Sie die Daten des 1. Analogen Kanals.
Die Daten des 2. Analogen Kanals (AI Standard Channel 2) sind genauso aufgebaut, wie die des 1. Kanals.


EP3182-1002 - Einführung

Produktübersicht [image] EP3182-1002 - Einführung
EP3182-1002 - Einführung
EP3182-1002
2-Kanal-Analog-Eingang ±10 V oder 0/4…20 mA, parametrierbar, single-ended, 16 Bit, 2 digitale Steuerausgänge, 24 VDC, kurzschlussfest
Analoge Eingänge (Single-Ended)
Die EtherCAT Box EP3182-1002 verfügt über zwei analoge Eingänge, die einzeln parametriert werden können, so dass sie entweder Signale im Bereich von -10 V bis +10 V oder im Bereich von 0/4 mA…20 mA verarbeiten.
Die Spannung bzw. der Eingangsstrom wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert.
Die zwei Eingangskanäle sind single-ended und besitzen ein gemeinsames, internes Massepotenzial. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar.
Die Skalierung der Eingänge kann bei Bedarf verändert werden; eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT. Die Parameter werden auf der Baugruppe gespeichert.
Digitale Ausgänge
Außerdem verfügt die EtherCAT Box EP3182-1002 über zwei digitale Ausgänge über die sie binäre Steuersignale der Steuerung zur Prozessebene an die Aktoren weiterschaltet.
Diese beiden Ausgänge (Sink/Source-Typ) sind gedacht zum Schalten von Logikeingängen oder -ausgängen mit einer minimalen Impedanz von 10 kOhm (z. B. Reset-Eingänge digitaler Sensoren) und verarbeiten Ströme bis 2 mA. Sie zeigen ihren Signalzustand über Leuchtdioden und sind kurzschlussfest.
Der Signalanschluss erfolgt ebenfalls über die beiden M12-Steckverbinder.
Quick-Links


EP3182-1002 - Technische Daten

Produktübersicht [image] EP3182-1002 - Technische Daten
EP3182-1002 - Technische Daten
Technische Daten | EP3182-1002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Eingänge | 2
Anschluss Eingänge / Ausgänge | 2 x M12-Buchse
Anschlusstechnik | single ended
Signaltyp | Konfigurierbar: 0 V…+10 V -10 V…+10 V 0 mA…20 mA 4 mA…20 mA
Innenwiderstand | >200 kΩ (typ. 85 Ω + Diodenspannung)
Gleichtaktspannung UCM | max. 35 V
Auflösung | 16 Bit (inkl. Vorzeichen)
Eingangsfilter | Konfigurierbar
Eingangsfilter Grenzfrequenz | 5 kHz
Wandlungszeit | ~ 100 µs
Messfehler | <±0,3 % (bezogen auf den Messbereichsendwert)
Anzahl Ausgänge | 2
Nennspannung Ausgänge | 24 VDC
Innenwiderstand | ca. 2350 Ω
Ausgangsstrom | 2 mA (kurzschlussfest)
Versorgung der Modulelektronik | aus der Steuerspannung US
Stromaufnahme der Modulelektronik | typisch 120 mA
Sensorversorgung | Aus Lastspannung UP
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Prozessabbild | Eingänge: 4 x 16 Bit Status: 4 x 8 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja
Zulässige Umgebungstemperatur im Betrieb | 0°C…55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C…+85°C
Vibrations- / Schockfestigkeit | Gemäß EN 600068-2-6 / EN 600068-2-27
EMV-Festigkeit / Aussendung | Gemäß EN 61000-6-2 / EN61000-6-4
Schutzart | IP65, IP66. IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus


EP3182-1002 - Prozessabbild

Produktübersicht [image] EP3182-1002 - Prozessabbild
EP3182-1002 - Prozessabbild
Analoge Eingänge
AI Standard Channel 1
Unter AI Standard Channel 1 finden Sie die Daten des 1. analogen Kanals.
AI Standard Channel 2
Die Daten des 2. analogen Kanals sind genauso aufgebaut, wie die des 1. Kanals.
Digitale Ausgänge
DO Outputs
Unter DO Outputs finden Sie die Daten der digitalen Ausgänge des Moduls.


EP3174-0002 - Einführung

Produktübersicht [image] EP3174-0002 - Einführung
EP3174-0002 - Einführung
EP3174-0002
4-Kanal-Analog-Eingang ±10 V oder 0/4…20 mA, parametrierbar, Differenzeingang, 16 Bit
Die EtherCAT Box EP3174-0002 verfügt über vier analoge Eingänge, die einzeln parametriert werden können, sodass sie entweder Signale im Bereich von -10 V bis +10 V oder im Bereich von 0/4 mA…20 mA verarbeiten.
Die Spannung bzw. der Eingangsstrom wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert.
Die vier Eingangskanäle sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotenzial. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar.
Die Skalierung der Eingänge kann bei Bedarf verändert werden; eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT. Die Parameter werden auf der Baugruppe gespeichert.
Quick-Links


EP3174-0092 - Einführung

Produktübersicht [image] EP3174-0092 - Einführung
EP3174-0092 - Einführung
EP3174-0092
4-Kanal-Analog-Eingang ±10 V oder 0/4…20 mA, Differenzeingang, 16 Bit, TwinSAFE Single Channel
Die EP3174-0092 unterstützt neben dem vollen Funktionsumfang der EP3174-0002 zusätzlich die TwinSAFE SC Technologie (TwinSAFE Single Channel). Dadurch ist es möglich, in beliebigen Netzwerken bzw. Feldbussen Standardsignale für sicherheitstechnische Aufgaben nutzbar zu machen.
Quick-Links


EP3184-0002 - Einführung

Produktübersicht [image] EP3184-0002 - Einführung
EP3184-0002 - Einführung
EP3184-0002
4-Kanal-Analog-Eingang ±10 V oder 0/4…20 mA, parametrierbar, single-ended, 16 Bit
Die EtherCAT Box EP3184-0002 verfügt über vier analoge Eingänge, die einzeln parametriert werden können, sodass sie entweder Signale im Bereich von -10 V bis +10 V oder im Bereich von 0/4 mA…20 mA verarbeiten.
Die Spannung bzw. der Eingangsstrom wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert.
Die vier Eingangskanäle sind single-ended und besitzen ein gemeinsames, internes Massepotenzial. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar.
Die Skalierung der Eingänge kann bei Bedarf verändert werden; eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT. Die Parameter werden auf der Baugruppe gespeichert.
Quick-Links


EP3184-1002 - Einführung

Produktübersicht [image] EP3184-1002 - Einführung
EP3184-1002 - Einführung
EP3184-1002
4-Kanal-Analog-Eingang ±10 V oder 0/4…20 mA, parametrierbar, single-ended, 16 Bit
Die EtherCAT Box EP3184-1002 verfügt über vier analoge Eingänge, die einzeln parametriert werden können, sodass sie entweder Signale im Bereich von -10 V bis +10 V oder im Bereich von 0/4 mA…20 mA verarbeiten.
Jeweils zwei Eingänge werden auf den Buchsen 1 und 3 zusammengefasst. Die Buchsen 2 und 4 sind ohne Funktion.
Die Spannung bzw. der Eingangsstrom wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zum übergeordneten Automatisierungsgerät transportiert.
Die vier Eingangskanäle sind single-ended und besitzen ein gemeinsames, internes Massepotenzial. Die Eingangsfilter und damit verbunden die Wandlungszeiten sind in weiten Bereichen einstellbar.
Die Skalierung der Eingänge kann bei Bedarf verändert werden; eine automatische Grenzwertüberwachung steht ebenfalls zur Verfügung. Parametriert wird über EtherCAT. Die Parameter werden auf der Baugruppe gespeichert.
Quick-Links


EP3174, EP3184 - Technische Daten

Produktübersicht [image] EP3174, EP3184 - Technische Daten
EP3174, EP3184 - Technische Daten
Technische Daten | EP3174-0002 |  | EP3174-0092 |  | EP3184-0002 | EP3184-1002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Eingänge | 4
Anschluss Eingänge / Ausgänge | 4 x M12-Buchse |  |  |  | 4 x M12-Buchse 1 pro Buchse | 2 x M12-Buchse 2 pro Buchse, Buchsen 2 und 4 nicht belegt
Anschlusstechnik | zweileiter, vierleiter |  |  |  | single ended
Signaltyp | Konfigurierbar: 0 V…+10 V -10 V…+10 V 0 mA…20 mA 4 mA…20 mA
Innenwiderstand | >200 kΩ (typ. 85 Ω + Diodenspannung)
Gleichtaktspannung UCM | max. 35 V
Auflösung | 16 Bit (inkl. Vorzeichen)
Eingangsfilter | Konfigurierbar
Eingangsfilter Grenzfrequenz | 5 kHz
Wandlungszeit | ~ 100 µs
Messfehler | <±0,3 % (bezogen auf den Messbereichsendwert)
MTBF (55°C) | - | > 600.000 h |  | -
Nennspannung | 24 VDC (-15 %/+20 %)
Distributed Clocks | ja
Versorgung der Modulelektronik | aus der Steuerspannung US
Stromaufnahme der Modulelektronik | typisch 120 mA
Sensorversorgung | Aus Lastspannung UP, DC
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Prozessabbild | Eingänge: 4 x 16 Bit Status: 4 x 8 Bit
Potenzialtrennung | Steuerspannung / Feldbus: ja
Zulässige Umgebungstemperatur im Betrieb | -25°C…+60°C
 | 0°C…+55°C (gemäß ATEX, siehe besondere Bedingungen)
 | 0°C…+55°C (gemäß cULus siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C…+85°C
Vibrations- / Schockfestigkeit | Gemäß EN 600068-2-6 / EN 600068-2-27
EMV-Festigkeit / Aussendung | Gemäß EN 61000-6-2 / EN61000-6-4
Schutzart | IP65, IP66. IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus, ATEX


EP31x4-x0x2 - Prozessabbild

Produktübersicht [image] EP31x4-x0x2 - Prozessabbild
EP31x4-x0x2 - Prozessabbild
Die Prozessdaten der Module EP3174-0002, EP3174-0092, EP3184-0002 und EP3184-1002 sind in der Default-Einstellung identisch und hier am Beispiel der EP3174-0002 dargestellt.
AI Standard Channel 1
Unter AI Standard Channel 1 finden Sie die Daten des 1. analogen Kanals.
AI Standard Channel 2 bis 4
Die Daten des 2. bis 4. analogen Kanals sind genauso aufgebaut, wie die des 1. Kanals.


EP3174-0092 - Prozessabbild (mit TwinSAFE SC Module)

Produktübersicht [image] EP3174-0092 - Prozessabbild (mit TwinSAFE SC Module)
EP3174-0092 - Prozessabbild (mit TwinSAFE SC Module)
In der folgenden Abbildung sind die Prozessdaten nach einfügen des TwinSAFE SC Moduls, wie im Kapitel Konfiguration TwinSAFE SC beschrieben, dargestellt.
Unter Module 1 (EP3174-0092) finden Sie
▪
die TSC Eingangsdaten und

▪
die TSC Ausgangsdaten.

Unter AI Standard Channel 1 finden Sie die Daten des 1. analogen Kanals.
AI Standard Channel 2 bis 4
Die Daten des 2. bis 4. analogen Kanals sind genauso aufgebaut, wie die des 1. Kanals.


Montage und Verkabelung

Montage und Verkabelung
Montage und Verkabelung
Weiterführende Informationen
•
Montage
•
EtherCAT
•
Spannungsversorgung
•
Verkabelung
•
UL-Anforderungen
•
ATEX-Hinweise
•
EP3162-0002 - Galvanische Trennung der Kanäle
•
EP3162-0002 - Signalanschluss und Status-LEDs
•
EP3174-00x2 - Signalanschluss und Status-LEDs
•
EP3182-1002 - Signalanschluss und Status-LEDs
•
EP3184-0002 - Signalanschluss und Status-LEDs
•
EP3184-1002 - Signalanschluss und Status-LEDs


Montage

Montage und Verkabelung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder


Abmessungen

Montage und Verkabelung [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Befestigung

Montage und Verkabelung [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Montage und Verkabelung [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


EtherCAT

Montage und Verkabelung [image] EtherCAT
EtherCAT
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs


EtherCAT-Anschluss

Montage und Verkabelung [image] EtherCAT [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Montage und Verkabelung [image] EtherCAT [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (https://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Spannungsversorgung

Montage und Verkabelung [image] Spannungsversorgung
Spannungsversorgung
Weiterführende Informationen
•
Power-Anschluss
•
Status-LEDs für die Spannungsversorgung
•
Leitungsverluste M8
•
Leitungsverluste 7/8"


Power-Anschluss

Montage und Verkabelung [image] Spannungsversorgung [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z. B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z. B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u. U. nicht mehr gegeben sein!


Status-LEDs für die Spannungsversorgung

Montage und Verkabelung [image] Spannungsversorgung [image] Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
LED-Anzeigen
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Leitungsverluste M8

Montage und Verkabelung [image] Spannungsversorgung [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Leitungsverluste 7/8"

Montage und Verkabelung [image] Spannungsversorgung [image] Leitungsverluste 7/8"
Leitungsverluste 7/8"
Bei den Powerkabeln ZK2030-xxxx-yyyy sollten 15 m Gesamtlänge bei 16 A nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
ZK2030-xxxx-yyyy - Leitungsverluste
Alternativ können auch höhere Leitungsquerschnitte von z.B. 2.5 mm2 eingesetzt werden.


Verkabelung

Montage und Verkabelung [image] Verkabelung
Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: https://beckhoff.de/german/fieldbus_box/ethercat_box_accessories_overview.htm?id=25525466903389
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link:
https://beckhoff.de/german/ethercat-box/ethercat_box_cables.htm?id=690338951657421
EtherCAT-Kabel
ZK1090-3131-0xxx
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
Powerkabel
ZK2020-3132-0xxx
Sensorkabel
Sensorkabel - Beckhoff.png
Auswahl von Beckhoff-Sensorkabel


UL-Anforderungen

Montage und Verkabelung [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Montage und Verkabelung [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Montage und Verkabelung [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit einem Schutzgehäuse BG2000-0000 oder BG2000-0010 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Batch-Nummer 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000 - Schutzgehäuse für EtherCAT Box

Montage und Verkabelung [image] ATEX-Hinweise [image] BG2000 - Schutzgehäuse für EtherCAT Box
BG2000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
SmallWarningYellow WARNUNG
Schutzgehäuse montieren!
Um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen, muss ein Schutzgehäuse BG2000-0000 oder BG2000-0010 über der EtherCAT Box montiert werden!
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses.
BG2000 - Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000 - Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuse über der EtherCAT Box.
BG2000 - Schutzgehäuse montieren


ATEX-Dokumentation

Montage und Verkabelung [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


EP3162-0002 - Galvanische Trennung der Kanäle

Montage und Verkabelung [image] EP3162-0002 - Galvanische Trennung der Kanäle
EP3162-0002 - Galvanische Trennung der Kanäle
Das nachfolgend abgebildete Blockschaltbild verdeutlicht das Prinzip der galvanischen Trennung der beiden Kanäle. Die 24 V, mit denen die Kanäle versorgt werden, kommen aus einem galvanisch getrennten DC/DC und sind somit UA anstatt US.
Blockschaltbild galvanische Trennung
Blockschaltbild: galvanische Trennung
Galvanische Trennung von GND
Die GNDs von Kanal 1 (GNDA) und Kanal 2 (GNDB) sind galvanisch voneinander getrennt.


EP3162-0002 - Signalanschluss und Status-LEDs

Montage und Verkabelung [image] EP3162-0002 - Signalanschluss und Status-LEDs
EP3162-0002 - Signalanschluss und Status-LEDs
Weiterführende Informationen
•
Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
•
Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
•
Status-LEDs an den M12-Anschlüssen


Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse

Montage und Verkabelung [image] EP3162-0002 - Signalanschluss und Status-LEDs [image] Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
Analoger Eingang, -10 V bis +10 V oder 0 V bis +10 V
Analoge Spannungseingänge M12_ein Single Ended Eingang_1
Analoger Spannungseingang M12, Kanal 1
Analoge Spannungseingänge M12_ein Single Ended Eingang_Kanal2
Analoger Spannungseingang M12, Kanal 2
Schauen Sie sich für zusätzliche Informationen das Kapitel EP3162-0002 - Galvanische Trennung der Kanäle an.


Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse

Montage und Verkabelung [image] EP3162-0002 - Signalanschluss und Status-LEDs [image] Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
Analoger Eingang, 0 mA bis 20 mA, 4 bis 20 mA oder -20 mA bis 20 mA
Analoge Stromeingänge M12_ein Single Ended Eingang_1
Analoge Stromeingänge M12, Kanal 1
Analoge Stromeingänge M12_ein Single Ended Eingang_Kanal2
Analoge Stromeingänge M12, Kanal 2
Schauen Sie sich für zusätzliche Informationen das Kapitel EP3162-0002 – Galvanische Trennung der Kanäle an.


Status-LEDs an den M12-Anschlüssen

Montage und Verkabelung [image] EP3162-0002 - Signalanschluss und Status-LEDs [image] Status-LEDs an den M12-Anschlüssen
Status-LEDs an den M12-Anschlüssen
Status LEDs an den M12-Anschlüssen_grün
Status LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 0-1 | R links | aus | keine Datenübertragung zum A/D-Wandler
 |  | grün | Datenübertragung zum A/D-Wandler
 | E rechts | aus | einwandfreie Funktion
 |  | rot | Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs
Eine einwandfreie Funktion besteht wenn die grüne LED RUN leuchtet und die rote LED Error aus ist.


EP3174-00x2 - Signalanschluss und Status-LEDs

Montage und Verkabelung [image] EP3174-00x2 - Signalanschluss und Status-LEDs
EP3174-00x2 - Signalanschluss und Status-LEDs
Weiterführende Informationen
•
Analoge Spannungseingänge M12, ein Differenzeingang pro Buchse
•
Analoge Stromeingänge M12, ein Differenzeingang pro Buchse
•
Status-LEDs an den M12-Anschlüssen


Analoge Spannungseingänge M12, ein Differenzeingang pro Buchse

Montage und Verkabelung [image] EP3174-00x2 - Signalanschluss und Status-LEDs [image] Analoge Spannungseingänge M12, ein Differenzeingang pro Buchse
Analoge Spannungseingänge M12, ein Differenzeingang pro Buchse
Analoge Eingänge, -10 V bis +10 V
Die Eingangsspannung wird als Differenzsignal gemessen.
Analoge Spannungseingänge M12, ein Differenzeingang pro Buchse
GND Verbindungen
Werden mehrere Sensoren an einer Box angeschlossen, deren GND nicht galvanisch getrennt sind, so müssen die GND mit GNDp verbunden werden.


Analoge Stromeingänge M12, ein Differenzeingang pro Buchse

Montage und Verkabelung [image] EP3174-00x2 - Signalanschluss und Status-LEDs [image] Analoge Stromeingänge M12, ein Differenzeingang pro Buchse
Analoge Stromeingänge M12, ein Differenzeingang pro Buchse
Analoge Eingänge, 0 mA bis 20 mA oder 4 mA bis 20 mA
Der Eingangsstrom wird als Differenzsignal gemessen.
Analoge Stromeingänge M12, ein Differenzeingang pro Buchse
GND Verbindungen
Werden mehrere Sensoren an einer Box angeschlossen, deren GND nicht galvanisch getrennt sind, so müssen die GND mit GNDp verbunden werden.


Status-LEDs an den M12-Anschlüssen

Montage und Verkabelung [image] EP3174-00x2 - Signalanschluss und Status-LEDs [image] Status-LEDs an den M12-Anschlüssen
Status-LEDs an den M12-Anschlüssen
Status LEDs an den M12-Anschlüssen_grün
Status LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1-4 | R links | aus | keine Datenübertragung zum A/D-Wandler
 |  | grün | Datenübertragung zum A/D-Wandler
 | E rechts | aus | einwandfreie Funktion
 |  | rot | Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs
Eine einwandfreie Funktion besteht wenn die grüne LED RUN leuchtet und die rote LED Error aus ist.


EP3182-1002 - Signalanschluss und Status-LEDs

Montage und Verkabelung [image] EP3182-1002 - Signalanschluss und Status-LEDs
EP3182-1002 - Signalanschluss und Status-LEDs
Weiterführende Informationen
•
Analoge Spannungseingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse
•
Analoge Stromeingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse
•
Status-LEDs an den M12-Anschlüssen


Analoge Spannungseingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse

Montage und Verkabelung [image] EP3182-1002 - Signalanschluss und Status-LEDs [image] Analoge Spannungseingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse
Analoge Spannungseingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse
Analoger Eingang, -10 bis +10 V, digitaler Ausgang
Analoge Spannungseingänge M12


Analoge Stromeingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse

Montage und Verkabelung [image] EP3182-1002 - Signalanschluss und Status-LEDs [image] Analoge Stromeingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse
Analoge Stromeingänge, digitaler Ausgang M12, ein Single-Ended-Eingang und ein digitaler Ausgang pro Buchse
Analoger Eingang, 0 bis 20 mA oder 4 bis 20 mA, digitaler Ausgang
Analoge Stromeingänge M12


Status-LEDs an den M12-Anschlüssen

Montage und Verkabelung [image] EP3182-1002 - Signalanschluss und Status-LEDs [image] Status-LEDs an den M12-Anschlüssen
Status-LEDs an den M12-Anschlüssen
Status LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1-2 | R links | aus | Analoger Eingang: keine Datenübertragung zum A/D-Wandler
 |  | grün | Analoger Eingang: Datenübertragung zum A/D-Wandler
 |  | rot | Fehler am analogen Eingang: Drahtbruch oder Messwert außerhalb des Messbereichs
 | 1 rechts | aus | Digitaler Ausgang ausgeschaltet
 |  | grün | Digitaler Ausgang eingeschaltet
Eine einwandfreie Funktion besteht wenn die linke LED grün leuchtet.


EP3184-0002 - Signalanschluss und Status-LEDs

Montage und Verkabelung [image] EP3184-0002 - Signalanschluss und Status-LEDs
EP3184-0002 - Signalanschluss und Status-LEDs
Weiterführende Informationen
•
Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
•
Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
•
Status-LEDs an den M12-Anschlüssen


Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse

Montage und Verkabelung [image] EP3184-0002 - Signalanschluss und Status-LEDs [image] Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
Analoger Eingang, -10 V bis +10 V
Analoge Spannungseingänge M12, ein Single-Ended-Eingang pro Buchse
GND Verbindungen
Werden mehrere Sensoren an einer Box angeschlossen, deren GND nicht galvanisch getrennt sind, so müssen die GND mit GNDp verbunden werden.


Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse

Montage und Verkabelung [image] EP3184-0002 - Signalanschluss und Status-LEDs [image] Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
Analoger Eingang, 0 mA bis 20 mA oder 4 mA bis 20 mA
Analoge Stromeingänge M12, ein Single-Ended-Eingang pro Buchse
GND Verbindungen
Werden mehrere Sensoren an einer Box angeschlossen, deren GND nicht galvanisch getrennt sind, so müssen die GND mit GNDp verbunden werden.


Status-LEDs an den M12-Anschlüssen

Montage und Verkabelung [image] EP3184-0002 - Signalanschluss und Status-LEDs [image] Status-LEDs an den M12-Anschlüssen
Status-LEDs an den M12-Anschlüssen
Status LEDs an den M12-Anschlüssen_grün
Status LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1-4 | R links | aus | keine Datenübertragung zum A/D-Wandler
 |  | grün | Datenübertragung zum A/D-Wandler
 | E rechts | aus | einwandfreie Funktion
 |  | rot | Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs
Eine einwandfreie Funktion besteht wenn die grüne LED RUN leuchtet und die rote LED Error aus ist.


EP3184-1002 - Signalanschluss und Status-LEDs

Montage und Verkabelung [image] EP3184-1002 - Signalanschluss und Status-LEDs
EP3184-1002 - Signalanschluss und Status-LEDs
Weiterführende Informationen
•
Analoge Spannungseingänge M12, zwei Single-Ended-Eingänge pro Buchse
•
Analoge Stromeingänge M12, zwei Single-Ended-Eingänge pro Buchse
•
Status-LEDs an den M12-Anschlüssen


Analoge Spannungseingänge M12, zwei Single-Ended-Eingänge pro Buchse

Montage und Verkabelung [image] EP3184-1002 - Signalanschluss und Status-LEDs [image] Analoge Spannungseingänge M12, zwei Single-Ended-Eingänge pro Buchse
Analoge Spannungseingänge M12, zwei Single-Ended-Eingänge pro Buchse
Analoge Eingänge, -10 V bis +10 V
Analoge Spannungseingänge M12, zwei Single-Ended-Eingänge pro Buchse
GND Verbindungen
Werden mehrere Sensoren an einer Box angeschlossen, deren GND nicht galvanisch getrennt sind, so müssen die GND mit GNDp verbunden werden.


Analoge Stromeingänge M12, zwei Single-Ended-Eingänge pro Buchse

Montage und Verkabelung [image] EP3184-1002 - Signalanschluss und Status-LEDs [image] Analoge Stromeingänge M12, zwei Single-Ended-Eingänge pro Buchse
Analoge Stromeingänge M12, zwei Single-Ended-Eingänge pro Buchse
Analoge Eingänge, 0 mA bis 20 mA oder 4 mA bis 20 mA
Analoge Stromeingänge M12, zwei Single-Ended-Eingänge pro Buchse
GND Verbindungen
Werden mehrere Sensoren an einer Box angeschlossen, deren GND nicht galvanisch getrennt sind, so müssen die GND mit GNDp verbunden werden.


Status-LEDs an den M12-Anschlüssen

Montage und Verkabelung [image] EP3184-1002 - Signalanschluss und Status-LEDs [image] Status-LEDs an den M12-Anschlüssen
Status-LEDs an den M12-Anschlüssen
Status LEDs an den M12-Anschlüssen_grün
Status LEDs an den M12-Anschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1, 3 Die Buchsen 2 und 4 sind nicht belegt. | R links | aus | keine Datenübertragung zum A/D-Wandler
 |  | grün | Datenübertragung zum A/D-Wandler
 | E rechts | aus | einwandfreie Funktion
 |  | rot | Fehler: Drahtbruch oder Messwert außerhalb des Messbereichs
Eine einwandfreie Funktion besteht wenn die grüne LED RUN leuchtet und die rote LED Error aus ist.


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
EtherCAT State Machine
•
CoE-Interface
•
Hinweise zur analogen Spezifikation
•
EP31xx - Einstellungen und Betriebsmodi
•
Datenstrom
•
Messbereiche
•
Kalibrierung
•
Berechnung der Prozessdaten
•
TwinSAFE SC
•
TwinSAFE SC Prozessdaten EP3174-0092
•
EP3162-0002 - Objektübersicht
•
EP3182-1002 - Objektübersicht
•
EP31x4-x002 - Objektübersicht
•
EP3174-0092 - Objektübersicht
•
EP31x2 - Objektbeschreibung und Parametrierung
•
EP31x4 - Objektbeschreibung und Parametrierung
•
Objekte TwinSAFE Single Channel (EP3174-0092)
•
Wiederherstellen des Auslieferungszustandes


Einfügen in das EtherCAT-Netzwerk

Konfiguration [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Konfiguration [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


EtherCAT State Machine

Konfiguration [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand. Die Inputdaten werden aber zyklisch aktualisiert.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Konfiguration [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind:
▪
Index 0…65535
▪
Subindex: 0…255
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexadezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind:
▪
0x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier liegen in manchen EtherCAT-Geräten alternativ zum 0x8000-Bereich die Kanalparameter.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i. d. R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis.
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter CoE-Online
In der vorherigen Abbildung sind die im Beispiel-gerät „EL2502“ verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zu sehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (vorherige Abbildung) durch Anklicken. Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im Dialog SetValue ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek. Dies wird für Änderungen während der Anlagenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart sind die veränderten CoE-Parameter immer noch erhalten. Andere Hersteller können dies anders handhaben.
StartUP-Liste
StartUP-Liste
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Werte nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im System Manager vornehmen. Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen. Die Reihenfolge der StartUp-Einträge ist dabei i. d. R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom System Manager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abbildung „Karteireiter CoE-Online“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
Wenn der Slave offline ist
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
Wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt.
–
Ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z. B. hat eine 4 kanalige Analogeingangsklemme 0 ... 10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
…
Allgemein wird dies geschrieben als 0x80n0. Ausführliche Hinweise zum Coe-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Hinweise zur analogen Spezifikation

Konfiguration [image] Hinweise zur analogen Spezifikation
Hinweise zur analogen Spezifikation
Beckhoff IO-Geräte (Klemmen, Boxen) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Messbereichsendwert
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereiche
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200…1370 °C: asymmetrisch bipolar, MBE = 1370 °C, Messspanne = 1570 °C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/Ausgangsboxen
± Messfehler [% vom MBE] (auch: Messabweichung)
Der relative Messfehler bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung, ...).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3 % MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Hinweis: da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsklemmen/Ausgangsboxen.
Typisierung Single Ended / differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
Typisierung Single Ended / differentiell
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss.
Grundsätzlich gilt:
▪
die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten. Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
–
bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt. Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen. Beckhoff IO-Module verfügen über 1...8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden:
–
wie sich die Kanäle INNERHALB eines Moduls zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
▪
Beckhoff Klemmen/Boxen sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen/Boxen also nicht über die Powerkontakte miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
▪
falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder eine 1-Kanal-Klemme keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Klemmendokumentationen/Boxendokumentationen sind zu beachten.
Erläuterung:
▪
Differentiell
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (siehe vorherige Abbildung) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)", wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird. Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung im Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
▪
Single Ended
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/Box von außen zum Anschluss des Bezugspotenzial zugänglich sein, z.B. über die Powerkontakte.
–
SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z.B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/BezugsPotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20 mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst. Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4…20 mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss, vgl. IEC 60381-1
▪
Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
▪
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
▪
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal.
Extern versorgte Sensoren
▪
3/4-Leiter-Anschluss, vgl. IEC 60381-1
▪
die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:
1.
Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm
2.
Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +/-/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
–
Ja: Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
–
Nein: es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Generell ist wegen der internen Diode die Polarität/Stromrichtung zu beachten!
2/3/4-Leiter-Anschluss als Single-Ended- oder Differential-Anschlusstechnik


EP31xx - Einstellungen und Betriebsmodi

Konfiguration [image] EP31xx - Einstellungen und Betriebsmodi
EP31xx - Einstellungen und Betriebsmodi
Weiterführende Informationen
•
Einstellungen
•
Betriebsmodi


Einstellungen

Konfiguration [image] EP31xx - Einstellungen und Betriebsmodi [image] Einstellungen
Einstellungen
Inhaltsverzeichnis
▪
Auswahl der analogen Signalart
▪
Darstellung
▪
Siemens Bits
▪
Underrange, Overrange
▪
Limit 1 und Limit 2
Auswahl der analogen Signalart, Index 0xF800:0n
Im Auslieferungszustand sind alle Kanäle der EP31xx für eine analoge Spannungsmessung (-10 V ... +10 V) eingestellt.
Hinweis
Korrekte Signalart vor Anschluss der Sensoren einstellen
Stellen Sie die korrekte Signalart ein, bevor Sie die Sensoren anschließen!
Im CoE Objekt 0xF800:0n kann diese Einstellung für jeden Kanal individuell eingestellt werden. Änderungen werden sofort wirksam.
EP3174-0002 Auswahl des Eingangssignals
EP31x4-0002: Auswahl des Signaltyps
Bei der EP31x2 kann zusätzlich der Signaltyp -20 mA…+20 mA ausgewählt werden (siehe nachfolgende Abbildung).
EP31x2: Auswahl des Signaltyps
Darstellung (Presentation), Index 0x80n0:02
Die Ausgabe des Messwertes erfolgt ab Werk in Zweierkomplement-Darstellung (Signed Integer).
Index 0x80n0:02 bietet die Möglichkeit zur Veränderung der Darstellungsweise des Messwertes.
▪
Signed Integer-Darstellung
Der negative Ausgabewert wird im Zweierkomplement (negiert + 1) dargestellt.
Maximaler Darstellungsbereich bei 16 Bit = -32768 .. +32767dez
Eingangssignal |  |  |  | Wert
+/- 10 V | 0...20 mA | 4...20 mA | 0...10 V | dezimal | hexadezimal
10 V | 20 mA | 20 mA | 10 V | 32767 | 0x7FFF
5 V | 10 mA | 12 mA | 5 V | 16383 | 0x3FFF
0 V | 0 mA | 4 mA | 0 V | 0 | 0x0000
-5 V | - | - | - | -16383 | 0xC001
-10 V | - | - | - | -32767 | 0x8000
Übersicht weiterer Darstellungen
▪
Unsigned Integer-Darstellung
Der Ausgabewert wird mit 15 Bit Auflösung ohne Vorzeichen dargestellt, eine Polaritätserkennung ist also nicht mehr möglich.
Maximaler Darstellungsbereich bei 16 Bit = 0 .. +32767dez
▪
Absolute value with MSB as sign - Darstellung
Der Ausgabewert wird in der Betrag-Vorzeichendarstellung ausgegeben: MSB=1 (höchstes Bit) bei negativen Werten.
Maximaler Darstellungsbereich bei 16 Bit = -32768 .. +32767dez
Eingangswerte (+/- 10 V) | Darstellung (Werte dez. / Werte hex.)
 | unsigned integer | Absolutwert mit MSB als Vorzeichen
10 | 32767 / 0x7FFF | 32767 / 0x7FFF
5 V | 16383 / 0x3FFF | 16383 / 0x3FFF
0 V | 0 / 0x0000 | 0 / 0x0000
-5 | 16384 / 0x4000 | [-16384] / 0xC000
-10 | 32767 / 0x7FFF | [-32767] / 0xFFFF
Darstellungsarten
Die Darstellungsarten Unsigned Integer und Absolutwert mit MSB als Vorzeichen haben bei unipolaren Modulen keine Funktion; die Darstellung bleibt im positiven Bereich unverändert.
Siemens Bits, Index 0x80n0:05
Mit Setzen dieses Bits werden auf den niedrigsten 3 Bits Statusanzeigen eingeblendet. Im Fehlerfall "Overrange" bzw. "Underrange" wird Bit 0 gesetzt.
Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:01, 0x60n0:02
Im Kapitel Datenstrom und Korrekturberechnung finden Sie eine anschauliche Darstellung der Korrekturberechnung von den Rohwerten zu den Ausgabewerten beim Überschreiten der Grenzbereiche.
Das Underrange Bit wird gesetzt, wenn basierend auf dem Rohwert ein Wert von 0x1300 um 1 Bit unterschritten wird.
Das Overrange Bit wird gesetzt, wenn der Wert von 0x7FFF um 1 Bit überschritten wird.
Error Bit (Index 0x60n0:07), Error LED
Das Error-Bit und die Error LED werden gesetzt, wenn basierend auf dem Rohwert
ein Wert von ca. 0,5 mA unter 4 mA unterschritten oder
ein Wert von ca. 0,5 mA über 20 mA überschritten wird.
•
Damit wird ein Auslösen der Error LED verhindert, wenn vom Sensor etwas mehr als 20 mA gesendet werden.
Limit 1 und Limit 2, Index 0x80n0:13, Index 0x80n0:14
Beim Über- bzw. Unterschreiten der Werte, die in den Indizes 0x80n0:13 und 0x80n0:14 eingegeben werden können, werden die Bits in den Indizes 0x60n0:03 und 0x60n0:05 entsprechend gesetzt (siehe unteres Beispiel). Zur Aktivierung der Grenzwertüberwachung dienen die Indizes 0x80n0:07 bzw. 0x80n0:08.
Ausgabe Limit n (2 Bit):
▪
0: nicht aktiv
▪
1: Wert < als Grenzwert
▪
2: Wert > als Grenzwert
▪
3: Wert = dem Grenzwert
Limit-Auswertung
Die Limit-Auswertung geht von einer Signed-Darstellung aus. Die Umrechnung in die gewünschte Darstellung (Index 0x80n0:02) erfolgt erst nach der Limit-Auswertung.
Verlinkung in der PLC mit 2-Bit-Werten
•
PLC:
Es gibt in der IEC61131-PLC keinen 2-Bit-Datentyp der mit diesem Prozessdatum 1:1 verlinkt werden kann. Zur Übertragung der Limit-Information definieren Sie deshalb ein Eingangsbyte, z. B.

und verlinken Sie das Limit mit dem VariableSizeMismatch-Dialog, wie in Kapitel Prozessdaten, beschrieben.
•
Zusätzliche Task
Im System Manager können 2-Bit-Variablen angelegt werden.

Verlinkung 2-Bit-Variable mit zusätzlicher Task
Beispiel
Kanal 1; Limit 1 und Limit 2 enabled, Limit 1 = 2,8 V, Limit 2 = 7,4 V, Darstellung: signed integer
Eingabe in Index (Limit 1): 0x8000:13
(2,8 V / 10 V) x 216 / 2 - 1 = 9.174dez
Eingabe in Index (Limit 2): 0x8000:14
(7,4 V / 10 V) x 216 / 2 - 1 = 24.247dez
Ausgabe:
Eingang Kanal 1 | Index 0x6000:03 | Index 60x6000:05
1.8 V | 0x01hex, (Limit 1, Grenzbereich unterschritten) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
2.8 V | 0x03hex, (Limit 1, Grenzbereich erreicht) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
4.2 V | 0x02hex, (Limit 1, Grenzbereich überschritten) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
8.5 V | 0x02hex, (Limit 1, Grenzbereich überschritten) | 0x02hex, (Limit 2, Grenzbereich überschritten)
Swap Limit Index 0x80n0:0E
Durch SwapLimitBits in Index 0x80n0:0E kann die Limit-Funktion invertiert werden.
Ausgabe n (2 Bit):
Einstellung SwapLimitBits
Wert
FALSE (Default-Einstellung)
▪
0: nicht aktiv
▪
1: Wert < Grenzwert
▪
2: Wert > Grenzwert
▪
3: Wert = Grenzwert
TRUE
▪
0: nicht aktiv
▪
1: Wert > Grenzwert
▪
2: Wert < Grenzwert
▪
3: Wert = Grenzwert
Die Swap Limit Funktion ist verfügbar nach unten stehender Tabelle
Klemme | Swap Limit Funktion ab Rev.
EP3162-0002 | -0016
EP3174-0002 | -0018
EP3174-0092 | -0016
EP3182-1002 | -0017
EP3184-0002 | -0017
EP3184-1002 | -0018


Betriebsmodi

Konfiguration [image] EP31xx - Einstellungen und Betriebsmodi [image] Betriebsmodi
Betriebsmodi
Die EP31xx unterstützt drei verschiedene Betriebsmodi:
▪
Freerun (Filter ein, Timer-Interrupt)
▪
Synchron (Filter aus, SyncManager-Interrupt) und
▪
DC (DC-Sync-Interrupt)
Abb. 3: Abhängigkeit der Betriebsmodi
Durch Aktivieren/Deaktivieren der Filter über den Index wechselt das Modul zwischen den Betriebsarten Freerun (Filter an) und Synchron. Dies geschieht während das Modul im OP-Betrieb bleibt. Durch die Umstellung können verlängerte Abtastzeiten auftreten sowie Sprünge in den Prozessdaten bis die Filter eingeschwungen sind.
Der DC Betrieb kann nur bei abgeschalteten Filtern verwendet werden. Ebenso ist es nicht möglich, die Filter im DC-Betrieb einzuschalten. Der DC-Betrieb wird über den Reiter "DC" im TwinCAT System Manager parametriert.
Synchron Betrieb
Im Synchronen Betrieb werden Prozessdaten Frame-getriggert erzeugt, so dass mit jedem PLC-Zyklus ein neuer Wert vorhanden ist. Der synchrone Betrieb wird bei den EP31xx Modulen automatisch verwendet (Filter aus, kein DC). Minimale Zykluszeiten sind 80 µs (EL31x1/EL31x2), und 120 µs (EL31x4) bei Standard-IPCs.
DC-Betrieb
Im DC-Betrieb wird das Analog-Sampling per DC-interrupt ausgelöst. Dadurch spielt der zeitliche Jitter zwischen zwei Frames keine Rolle mehr und der Sampling-Zeitpunkt ist systemweit gleich.
Der "Input Based" Betrieb verschiebt den Sync-Interrupt automatisch so, dass die Prozessdaten kurz vor dem aktuellen Prozessdatenzyklus abholbereit sind.
Sollte der Frame-Jitter zu groß sein, kann es dennoch sein, dass doppelte Daten abgeholt werden bzw. es zu Aussetzern kommt in der Übertragung. Dann ist durch TwinCAT-System-Maßnahmen der Jitter zu verringern oder eine langsamere Zykluszeit zu wählen.
Filter Betrieb (FIR- und IIR), Index 0x80n0:06, 0x80n0:15
Die Module EP31xx sind mit einem digitalen Filter ausgestattet, das je nach Einstellung die Charakteristik eines Filter mit endlicher Impulsantwort (Finite Impulse Response filter, FIR-Filter) oder eines Filter mit unendlicher Impulsantwort (Infinite Impulse Response filter, IIR-Filter), annehmen kann. Der Filter ist per default deaktiviert. Zur Aktivierung mit Index 0x8000:06 bitte den folgenden Hinweis beachten.
Aktivierung des Filters (Index 0x8000: 06), Einstellung der Filtereigenschaften (Index 0x8000:15)
Die Filterfrequenzen werden für alle Kanäle der EP3xxx Module zentral über den Index 0x8000:15 (Kanal 1) eingestellt. Die entsprechenden Indizes 0x80n0:15 der weiteren Kanäle haben keine Parametrierungsfunktion.
FIR-Filter
Das Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit des Moduls. Es wird über den Index 0x8000:15 parametriert. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit. Es steht ein 50 Hz und ein 60 Hz Filter zur Verfügung.
Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also in der Amplitude dämpft.
Das FIR-Filter arbeitet als nicht-rekursives Filter.
typ. Dämpfungskurve Notch-Filter bei 50 Hz
Filterdaten FIR - Filter (1- bis 4-kanalige Module)
Filter | Dämpfung | Grenzfrequenz (-3 dB) | Wandlungszeit
50 Hz FIR | > 50 dB | 22 Hz | 625 µs
60 Hz FIR | > 45 dB | 26 Hz | 521 µs
IIR-Filter
Das Filter mit IIR-Charakteristik ist ein zeitdiskretes, lineares, zeitinvariantes Filter, welches in 8 Level eingestellt werden kann (Level 1 = schwaches rekursives Filter, bis Level 8 = starkes rekursives Filter)
Der IIR kann als gleitende Mittelwertberechnung nach einem Tiefpass verstanden werden.
Durch den Synchronisierungsmodus FreeRun arbeitet der IIR-Filter mit 180 µs (1 oder 2 Kanäle) bzw. 500 µs (4 Kanäle) interner Zykluszeit.
Filter-Charakteristik für IIR-Filter
IIR - Filter | -3 dB Grenzfrequenz bei 500 µs Sampling-Zeit
IIR 1 | 400 Hz
IIR 2 | 220 Hz
IIR 3 | 100 Hz
IIR 4 | 50 Hz
IIR 5 | 24 Hz
IIR 6 | 12 Hz
IIR 7 | 6,2 Hz
IIR 8 | 3,0 Hz


Datenstrom

Konfiguration [image] Datenstrom
Datenstrom
Im nachfolgenden Flussdiagramm ist der Datenstrom der EP31xx (Verarbeitung der Rohdaten) anschaulich dargestellt.
Darstellung des Datenstroms EP31xx


Messbereiche

Konfiguration [image] Messbereiche
Messbereiche
Die folgenden Diagramme zeigen die Ausgabewerte der Messbereiche, sowie das Verhalten beim Überschreiten der Grenzbereiche.
EP3162-0002 (+/- 20 mA)
Datenfluss mit Korrekturberechnung für +/- 20 mA
EP3162-0002, EP3174-xxxx, EP318x-xxxx (0…20 mA)
Datenfluss mit Korrekturberechnung für 0…20 mA
EP3162-0002, EP3174-xxxx, EP318x-xxxx (4…20 mA)
Datenfluss mit Korrekturberechnung für 4…20 mA
EP3162-0002, EP3174-xxxx, EP318x-xxxx (+/- 10 V)
Datenfluss mit Korrekturberechnung für +/- 10 V
EP3162-0002, EP3174-xxxx, EP318x-xxxx (0…10 V)
Datenfluss mit Korrekturberechnung für 0…10 V


Kalibrierung

Konfiguration [image] Kalibrierung
Kalibrierung
Der bei Beckhoff historisch begründete Begriff „Kalibrierung“ wird hier verwendet, auch wenn er nichts mit Abweichungsaussagen eines Kalibrierungszertifikates zu tun hat.
▪
Hersteller-Abgleich, Index 0x80n0:0B
Die Freigabe des Hersteller-Abgleichs erfolgt über den Index 0x80n0:0B. Die Parametrierung erfolgt über die Indizes:
–
0x80nF:01 Hersteller-Abgleich: Offset
–
0x80nF:02 Hersteller-Abgleich: Gain
▪
Anwender-Abgleich, Index 0x80n0:0A
Die Freigabe des Anwender-Abgleichs erfolgt über den Index 0x80n0:0A. Die Parametrierung erfolgt über die Indizes:
–
0x80n0:17 Anwender-Abgleich: Offset
–
0x80n0:18 Anwender-Abgleich: Gain
▪
Anwender-Skalierung, Index 0x80n0:01
Die Freigabe der Anwender-Skalierung erfolgt über den Index 0x80n0:01. Die Parametrierung erfolgt über die Indizes:
–
0x80n0:11 Anwender-Skalierung: Offset
–
0x80n0:12 Anwender-Skalierung: Gain
Hersteller-Kalibrierung
Der Hersteller behält sich die Grundkalibrierung der Klemmen/Box-Module vor. Die Hersteller-Kalibrierung ist daher nicht veränderbar.


Berechnung der Prozessdaten

Konfiguration [image] Berechnung der Prozessdaten
Berechnung der Prozessdaten
Die Klemme/Box nimmt permanent Messwerte auf und legt die Rohwerte ihres A/D-Wandlers ins ADC raw value-Objekt 0x80nE:01. Nach jeder Erfassung des Analogsignals erfolgt die Korrekturberechnung mit den Hersteller-Kalibrierwerten. Anschließend folgt (optional) noch die Anwender-Skalierung:
YH= (XADC-BH) * AH Messwert nach Hersteller-Kalibrierung (entspricht XADC, wenn Index 0x80n0:0B inaktiv)
YA= (YH-BA) * AA Messwert nach Anwender-Kalibrierung (entspricht YH, wenn Index 0x80n0:0A inaktiv)
YS= YA * AS * 22-16 + BS Messwert nach Anwender-Skalierung (entspricht YA, wenn Index 0x80n0:01 inaktiv)
Legende
Name | Bezeichnung | Index
XADC | Ausgabewert des A/D Wandlers | 0x80nE:01
BH | Offset der Hersteller-Kalibrierung (nur veränderbar, wenn das Objekt Producer codeword 0xF008 gesetzt wird) | 0x80nF:01
AH | Gain der Hersteller-Kalibrierung (nur veränderbar, wenn das Objekt Producer codeword 0xF008 gesetzt wird) | 0x80nF:02
YH | Messwert nach Hersteller-Kalibrierung | -
BA | Offset der Anwender-Kalibrierung | 0x80n0:11
AA | Gain der Anwender-Kalibrierung | 0x80n0:12
YS | Messwert nach Anwender-Kalibrierung | -
BS | Offset der Anwender-Skalierung (aktivierbar über Index 0x80n0:0A) | 0x80n0:17
AS | Gain der Anwender-Skalierung (aktivierbar über Index 0x80n0:0A) | 0x80n0:18
YS | Prozessdaten zur Steuerung, Messwert nach Anwender-Skalierung | -


TwinSAFE SC

Konfiguration [image] TwinSAFE SC
TwinSAFE SC
Weiterführende Informationen
•
TwinSAFE SC - Funktionsprinzip
•
Konfiguration TwinSAFE SC


TwinSAFE SC - Funktionsprinzip

Konfiguration [image] TwinSAFE SC [image] TwinSAFE SC - Funktionsprinzip
TwinSAFE SC - Funktionsprinzip
Mithilfe der TwinSAFE-SC-Technologie (TwinSAFE Single Channel) ist es möglich, in beliebigen Netzwerken bzw. Feldbussen Standardsignale für sicherheitstechnische Aufgaben nutzbar zu machen. Dazu werden EtherCAT-I/Os aus dem Bereich Analog-Eingang, Winkel-/Wegmessung oder Kommunikation (4…20 mA, Inkremental-Encoder, IO-Link usw.) um die TwinSAFE-SC-Funktion erweitert. Die signaltypischen Eigenschaften und Standard-Funktionalitäten der I/O-Komponenten bleiben dabei erhalten.
TwinSAFE-SC-I/Os unterscheiden sich optisch von Standard-I/Os durch einen gelben Streifen auf der Gehäusefront.
Die TwinSAFE-SC-Technologie ermöglicht eine Kommunikation über ein TwinSAFE-Protokoll. Diese Verbindungen können von der üblichen sicheren Kommunikation über Safety-over-EtherCAT unterschieden werden.
Die Daten der TwinSAFE-SC-Komponenten werden über ein TwinSAFE-Protokoll zu der TwinSAFE-Logic geleitet und können dort im Kontext sicherheitsrelevanter Applikationen verwendet werden. Detaillierte und durch den TÜV SÜD bestätigte/berechnete Beispiele zur korrekten Anwendung der TwinSAFE-SC-Komponenten und der jeweiligen normativen Klassifizierung können dem TwinSAFE-Applikationshandbuch entnommen werden.


Konfiguration TwinSAFE SC

Konfiguration [image] TwinSAFE SC [image] Konfiguration TwinSAFE SC
Konfiguration TwinSAFE SC
Die TwinSAFE-SC-Technologie ermöglicht eine Kommunikation mit Standard-EtherCAT-Klemmen über das Safety-over-EtherCAT-Protokoll. Diese Verbindungen verwenden eine andere Prüfsumme, um TwinSAFE SC von TwinSAFE unterscheiden zu können. Es sind acht feste CRCs auswählbar, oder es kann auch eine freie CRC durch den Anwender eingegeben werden.
Per default ist der TwinSAFE-SC-Kommunikationskanal der jeweiligen TwinSAFE-SC-Komponente nicht aktiviert. Um die Datenübertragung nutzen zu können, muss zunächst unter dem Reiter Slots das entsprechende TwinSAFE-SC-Modul hinzugefügt werden. Erst danach ist eine Verlinkung auf ein entsprechendes Alias-Device möglich.
Hinzufügen der TwinSAFE SC Prozessdaten unterhalb der Komponente z.B. EL5021-0090
Es werden zusätzliche Prozessdaten mit der Kennzeichnung TSC Inputs, TSC Outputs generiert (TSC - TwinSAFE Single Channel).
Prozessdaten TwinSAFE SC Komponente (iankfd11.png)
Prozessdaten TwinSAFE SC Komponente, Beispiel EL5021-0090
Durch Hinzufügen eines Alias Devices in dem Safety-Projekt und Auswahl von TSC (TwinSAFE Single Channel) wird eine TwinSAFE-SC-Verbindung hinzugefügt
Hinzufügen einer TwinSAFE-SC-Verbindung
Nach Öffnen des Alias Devices durch Doppelklick kann durch Auswahl des Link Buttons Grafik aus Konfiguration TwinSAFE SC (iak9opa.png) neben Physical Device: die Verknüpfung zu einer TwinSAFE-SC-Klemme erstellt werden. In dem Auswahldialog werden nur passende TwinSAFE-SC-Klemmen angeboten.
Grafik aus Konfiguration TwinSAFE SC (i8d09251.png)
Erstellen einer Verknüpfung zu einer TwinSAFE-SC-Klemme
Unter dem Reiter Connection des Alias Devices wird die zu verwendende CRC ausgewählt bzw. eine freie CRC eingetragen.
Eintrag Mode | Verwendete CRCs
TwinSAFE SC CRC 1 master | 0x17B0F
TwinSAFE SC CRC 2 master | 0x1571F
TwinSAFE SC CRC 3 master | 0x11F95
TwinSAFE SC CRC 4 master | 0x153F1
TwinSAFE SC CRC 5 master | 0x1F1D5
TwinSAFE SC CRC 6 master | 0x1663B
TwinSAFE SC CRC 7 master | 0x1B8CD
TwinSAFE SC CRC 8 master | 0x1E1BD
Auswahl einer freien CRC
Diese Einstellungen müssen zu den Einstellungen passen, die in den CoE-Objekten der TwinSAFE-SC-Komponente eingestellt sind.
Die TwinSAFE-SC-Komponente stellt zunächst alle zur Verfügung stehenden Prozessdaten bereit. Der Reiter Safety Parameters enthält typischerweise keine Parameter. Unter dem Reiter Process Image kann die Prozessdatengröße bzw. die Prozessdaten selbst ausgewählt werden.
Auswahl der Prozessdatengröße bzw. der Prozessdaten
Die Prozessdaten (definiert in der ESI-Datei) können durch Auswahl des Buttons Edit entsprechend den Anwenderanforderungen im Dialog Configure I/O element(s) eingestellt werden.
Auswahl der Prozessdaten
Auf der TwinSAFE-SC-Slave-Seite muss die Safety-Adresse zusammen mit der CRC eingetragen werden. Dies geschieht über die CoE Objekte unterhalb von TSC Settings der entsprechenden TwinSAFE-SC-Komponente (hier bei der EL5021-0090 z.B. 0x8010:01 und 0x8010:02). Die hier eingestellte Adresse muss auch im Alias Device unter dem Reiter Linking als FSoE Adresse eingestellt werden.
Unter dem Objekt 0x80n0:02 Connection Mode wird die zu verwendende CRC ausgewählt bzw. eine freie CRC eingetragen. Es stehen insgesamt 8 CRCs zur Verfügung. Eine freie CRC muss im High Word mit 0x00ff beginnen.
Grafik aus Konfiguration TwinSAFE SC (iv9tkmo3.png)
CoE Objekte 0x8010:01 und 0x8010:02 bei der EL5021-0090
Objekt „TSC Settings”
Die Index-Bezeichnung des Konfigurationsobjekts „TSC Settings“ kann je nach Klemme unterschiedlich sein.
Beispiel:
- EL3214-0090 und EL3314-0090, „TSC Settings“, Index 8040
- EL5021-0090, „TSC Settings“, Index 8010
- EL6224-0090, „TSC Settings“, Index 800F
Grafik aus Konfiguration TwinSAFE SC (isvth0a2.png)
Eintragen der Safety-Adresse und der CRC
TwinSAFE-SC-Verbindungen
Werden mehrere TwinSAFE-SC-Verbindungen innerhalb einer Konfiguration verwendet, muss für jede TwinSAFE-SC-Verbindung eine unterschiedliche CRC ausgewählt werden.


TwinSAFE SC Prozessdaten EP3174-0092

Konfiguration [image] TwinSAFE SC Prozessdaten EP3174-0092
TwinSAFE SC Prozessdaten EP3174-0092
Die EP3174-0092 überträgt folgende Prozessdaten an die TwinSAFE Logik:
Index (hex) | Name | Type | Größe
6000:11 | AI Module 1.Value | INT | 2.0
6010:11 | AI Module 2.Value | INT | 2.0
6020:11 | AI Module 3.Value | INT | 2.0
6030:11 | AI Module 4.Value | INT | 2.0
Dabei werden zunächst die Prozessdaten aller vier Kanäle übertragen. Über den Reiter „Process Image“ können im Safety Editor einzelne Kanäle ganz abgewählt werden.
Abhängig von der TwinCAT 3.1 Version können Prozessdaten bei der Verlinkung zum Safety Editor automatisch umbenannt werden.


EP3162-0002 - Objektübersicht

Konfiguration [image] EP3162-0002 - Objektübersicht
EP3162-0002 - Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x012C1389 (19665801dez)
1008 |  | Device name | RO | EP3162-0002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x0C5A4052 (207241298dez)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x11 (11dez)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x11 (11dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A01:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A01:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:0F, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A01:0B | Subindex011 | RO | 0x6010:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dez)
 | 1C12:01 | SubIndex 001 | RW | -
 | 1C12:02 | SubIndex 002 | RW | -
1C13:0 | Subindex | TxPDO assign | RW | 0x02 (2dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dez)
 | 1C13:03 | SubIndex 003 | RW | -
 | 1C13:04 | SubIndex 004 | RW | -
Index (hex) |  |  | Name | Flags | Default Wert
1C32:0 |  | Subindex | SM output parameter | RO | 0x20 (32dez)
 |  | 1C32:01 | Sync mode | RW | 0x0000 (0dez)
 |  | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 |  | 1C32:03 | Shift time | RO | 0x00000000 (0dez)
 |  | 1C32:04 | Sync modes supported | RO | 0xC009 (49161dez)
 |  | 1C32:05 | Minimum cycle time | RO | 0x00055730 (350000dez)
 |  | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 |  | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 |  | 1C32:08 | Command | RW | 0x0000 (0dez)
 |  | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dez)
 |  | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 |  | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 |  | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 |  | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 |  | Subindex | SM input parameter | RO | 0x20 (32dez)
 |  | 1C33:01 | Sync mode | RW | 0x0000 (0dez)
 |  | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 |  | 1C33:03 | Shift time | RO | 0x00001388 (5000dez)
 |  | 1C33:04 | Sync modes supported | RO | 0xC009 (49161dez)
 |  | 1C33:05 | Minimum cycle time | RO | 0x00055730 (350000dez)
 |  | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 |  | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dez)
 |  | 1C33:08 | Command | RW | 0x0000 (0dez)
 |  | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dez)
 |  | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 |  | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 |  | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 |  | 1C33:20 | Sync error | RO | 0x0000 (0dez)
6000:0 |  | Subindex | AI Inputs Ch. 1 | RO | 0x11 (17dez)
 |  | 6000:01 | Underrange | RO | 0x00 (0dez)
 |  | 6000:02 | Overrange | RO | 0x00 (0dez)
 |  | 6000:03 | Limit 1 | RO | 0x00 (0dez)
 |  | 6000:05 | Limit 2 | RO | 0x00 (0dez)
 |  | 6000:07 | Error | RO | 0x00 (0dez)
 |  | 6000:0E | Sync Error | RO | 0x00 (0dez)
 |  | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 |  | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 |  | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 |  | Subindex | AI Inputs Ch. 2 | RO | 0x11 (17dez)
 |  | 6010:01 | Underrange | RO | 0x00 (0dez)
 |  | 6010:02 | Overrange | RO | 0x00 (0dez)
 |  | 6010:03 | Limit 1 | RO | 0x00 (0dez)
 |  | 6010:05 | Limit 2 | RO | 0x00 (0dez)
 |  | 6010:07 | Error | RO | 0x00 (0dez)
 |  | 6010:0E | Sync error | RO | 0x00 (0dez)
 |  | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 |  | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 |  | 6010:11 | Value | RO | 0x0000 (0dez)
8000:0 |  | Subindex | AI Settings Ch. 1 | RW | 0x18 (24dez)
 |  | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 |  | 8000:02 | Presentation | RW | 0x00 (0dez)
 |  | 8000:06 | Enable filter | RW | 0x01 (1dez)
 |  | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 |  | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 |  | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 |  | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 |  | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 |  | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 |  | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 |  | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 |  | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 |  | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 |  | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 |  | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
800E:0 |  | Subindex | AI Internal data Ch. 1 | RW | 0x01 (1dez)
 |  | 800E:01 | ADC raw value | RW | 0x0000 (0dez)
800F:0 |  | Subindex | AI Vendor data Ch. 1 | RW | 0x06 (6dez)
 |  | 800F:01 | offset U | RW | 0x0000 (0dez)
 |  | 800F:02 | gain U | RW | 0x4000 (16384dez)
 |  | 800F:03 | offset I | RW | 0x0000 (0dez)
 |  | 800F:04 | gain I | RW | 0x4000 (16384dez)
 |  | 800F:05 | offset I4 | RW | 0x0000 (0dez)
 |  | 800F:06 | gain I4 | RW | 0x4000 (16384dez)
8010:0 |  | Subindex | AI Settings Ch. 2 | RW | 0x18 (24dez)
 |  | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 |  | 8010:02 | Presentation | RW | 0x00 (0dez)
 |  | 8010:06 | Enable filter | RW | 0x00 (0dez)
 |  | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 |  | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 |  | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 |  | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 |  | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 |  | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 |  | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 |  | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 |  | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 |  | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 |  | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 |  | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
801E:0 |  | Subindex | AI Internal data Ch. 2 | RW | 0x01 (1dez)
 |  | 801E:01 | ADC raw value | RW | 0x0000 (0dez)
801F:0 |  | Subindex | AI Vendor data Ch. 2 | RW | 0x06 (6dez)
 |  | 801F:01 | offset U | RW | 0x0000 (0dez)
 |  | 801F:02 | gain U | RW | 0x4000 (16384dez)
 |  | 801F:03 | offset I | RW | 0x0000 (0dez)
 |  | 801F:04 | gain I | RW | 0x4000 (16384dez)
 |  | 801F:05 | offset I4 | RW | 0x0000 (0dez)
 |  | 801F:06 | gain I4 | RW | 0x4000 (16384dez)
F000:0 |  | Subindex | Modular device profile | RO | 0x02 (2dez)
 |  | F000:01 | Module index distance | RO | 0x0010 (16dez)
 |  | F000:02 | Maximum number of modules | RO | 0x0002 (2dez)
F008 |  |  | Code word | RW | 0x0000 (0dez)
F010:0 | Subindex |  | Module list | RW | 0x02 (2dez)
 | F010:01 |  | SubIndex 001 | RW | 0x0000012C (300dez)
 | F010:02 |  | SubIndex 002 | RW | 0x0000012C (300dez)
F800:0 | Subindex |  | AI Range Settings | RW | 0x02 (2dez)
 | F800:01 |  | Input type Ch1 | RW | 0x0000 (0dez)
 | F800:02 |  | Input type Ch2 | RW | 0x0000 (0dez)
Legende
Flags: |
RO (Read Only): | dieses Objekt kann nur gelesen werden
RW (Read/Write): | dieses Objekt kann gelesen und beschrieben werden


EP3182-1002 - Objektübersicht

Konfiguration [image] EP3182-1002 - Objektübersicht
EP3182-1002 - Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x00001389 (5001dez)
1008 |  | Device name | RO | EP3182-1002
1009 |  | Hardware version | RO | 01
100A |  | Software version | RO | 01
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x0C6E4052 (208552018dez)
 | 1018:03 | Revision | RO | 0x001403EA (1311722dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1600:0 | Subindex | DO RxPDO-Map Outputs | RO | 0x03 (3dez)
 | 1600:01 | Subindex 001 | RO | 0x7020:01, 1
 | 1600:02 | Subindex 002 | RO | 0x7020:02, 1
 | 1600:03 | Subindex 003 | RO | 0x0000:0,14
1800:0 | Subindex | AI TxPDO-Par Standard Ch.1 | RO | 0x06 (6dez)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par Compact Ch.1 | RO | 0x06 (6dez)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dez)
 | 1801:06 | Exclude TxPDOs | RO | 02 1A
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x11 (11dez)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x11 (11dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A02:08 | SubIndex 008 | RO | 0x6010:0E, 1
 | 1A02:09 | SubIndex 009 | RO | 0x6010:0F, 1
Index (hex) |  |  | Name | Flags | Default Wert
1A02:0 |  | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 |  | 1A02:0B | Subindex011 | RO | 0x6010:11, 16
1A03:0 |  | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dez)
 |  | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1C00:0 |  | Subindex | Sync manager type | RO | 0x04 (4dez)
 |  | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 |  | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 |  | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 |  | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 |  | Subindex | RxPDO assign | RW | 0x01 (1dez)
 |  | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632)
1C13:0 |  | Subindex | TxPDO assign | RW | 0x02 (2dez)
 |  | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 |  | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dez)
1C32:0 |  | Subindex | SM output parameter | RO | 0x20 (32dez)
 |  | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 |  | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 |  | 1C32:03 | Shift time | RO | 0x00001388 (5000dez)
 |  | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 |  | 1C32:05 | Minimum cycle time | RO | 0x00030D40 (200000dez)
 |  | 1C32:06 | Calc and copy time | RO | 0x00001388 (5000dez)
 |  | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 |  | 1C32:08 | Command | RW | 0x0000 (0dez)
 |  | 1C32:09 | Maximum Delay time | RO | 0x00000000 (0dez)
 |  | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 |  | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 |  | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 |  | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 |  | Subindex | SM input parameter | RO | 0x20 (32dez)
 |  | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 |  | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 |  | 1C33:03 | Shift time | RO | 0x00001388 (5000dez)
 |  | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 |  | 1C33:05 | Minimum cycle time | RO | 0x00001388 (5000dez)
 |  | 1C33:06 | Calc and copy time | RO | 0x00002710 (10000dez)
 |  | 1C33:07 | Minimum delay time | RO | 0x00001388 (5000dez)
 |  | 1C33:08 | Command | RW | 0x0000 (0dez)
 |  | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dez)
 |  | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 |  | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 |  | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 |  | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 |  | Subindex | AI Inputs Ch. 1 | RO | 0x11 (17dez)
 |  | 6000:01 | Underrange | RO | 0x00 (0dez)
 |  | 6000:02 | Overrange | RO | 0x00 (0dez)
 |  | 6000:03 | Limit 1 | RO | 0x00 (0dez)
 |  | 6000:05 | Limit 2 | RO | 0x00 (0dez)
 |  | 6000:07 | Error | RO | 0x00 (0dez)
 |  | 6000:0E | Sync Error | RO | 0x00 (0dez)
 |  | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 |  | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 |  | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 |  | Subindex | AI Inputs Ch. 2 | RO | 0x11 (17dez)
 |  | 6010:01 | Underrange | RO | 0x00 (0dez)
 |  | 6010:02 | Overrange | RO | 0x00 (0dez)
 |  | 6010:03 | Limit 1 | RO | 0x00 (0dez)
 |  | 6010:05 | Limit 2 | RO | 0x00 (0dez)
 |  | 6010:07 | Error | RO | 0x00 (0dez)
 |  | 6010:0E | Sync error | RO | 0x00 (0dez)
 |  | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 |  | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 |  | 6010:11 | Value | RO | 0x0000 (0dez)
7020:0 |  | Subindex | DO Outputs | RO | 0x02 (2dez)
 |  | 7020:01 | Digital Output 1 | RO | 0x00 (0dez)
 |  | 7020:02 | Digital Output 2 | RO | 0x00 (0dez)
8000:0 |  | Subindex | AI Settings Ch. 1 | RW | 0x18 (24dez)
 |  | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 |  | 8000:02 | Presentation | RW | 0x00 (0dez)
 |  | 8000:06 | Enable filter | RW | 0x01 (1dez)
 |  | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 |  | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 |  | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 |  | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 |  | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 |  | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 |  | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 |  | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 |  | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 |  | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 |  | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 |  | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
800E:0 |  | Subindex | AI Internal data Ch. 1 | RW | 0x01 (1dez)
 |  | 800E:01 | ADC raw value | RW | 0x0000 (0dez)
800F:0 |  | Subindex | AI Vendor data Ch. 1 | RW | 0x06 (6dez)
 |  | 800F:01 | offset U | RW | 0x0000 (0dez)
 |  | 800F:02 | gain U | RW | 0x4000 (16384dez)
 |  | 800F:03 | offset I | RW | 0x0000 (0dez)
 |  | 800F:04 | gain I | RW | 0x4000 (16384dez)
 |  | 800F:05 | offset I4 | RW | 0x0000 (0dez)
 |  | 800F:06 | gain I4 | RW | 0x4000 (16384dez)
8010:0 |  | Subindex | AI Settings Ch. 2 | RW | 0x18 (24dez)
 |  | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 |  | 8010:02 | Presentation | RW | 0x00 (0dez)
 |  | 8010:06 | Enable filter | RW | 0x00 (0dez)
 |  | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 |  | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 |  | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 |  | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 |  | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 |  | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 |  | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 |  | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 |  | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 |  | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 |  | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 |  | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
801E:0 |  | Subindex | AI Internal data Ch. 2 | RW | 0x01 (1dez)
 |  | 801E:01 | ADC raw value | RW | 0x0000 (0dez)
801F:0 |  | Subindex | AI Vendor data Ch. 2 | RW | 0x06 (6dez)
 |  | 801F:01 | offset U | RW | 0x0000 (0dez)
 |  | 801F:02 | gain U | RW | 0x4000 (16384dez)
 |  | 801F:03 | offset I | RW | 0x0000 (0dez)
 |  | 801F:04 | gain I | RW | 0x4000 (16384dez)
 |  | 801F:05 | offset I4 | RW | 0x0000 (0dez)
 |  | 801F:06 | gain I4 | RW | 0x4000 (16384dez)
F000:0 |  | Subindex | Modular device profile | RO | 0x02 (2dez)
 |  | F000:01 | Module index distance | RO | 0x0010 (16dez)
 |  | F000:02 | Maximum number of modules | RO | 0x0003 (3dez)
F008 |  |  | Code word | RW | 0x0000 (0dez)
F010:0 | Subindex |  | Module list | RW | 0x02 (2dez)
 | F010:01 |  | SubIndex 001 | RW | 0x0000012C (300dez)
 | F010:02 |  | SubIndex 002 | RW | 0x0000012C (300dez)
 | F010:03 |  | SubIndex 003 | RW | 0x000000C8 (200dez)
F800:0 | Subindex |  | AI Range Settings | RW | 0x02 (2dez)
 | F800:01 |  | Input type Ch1 | RW | 0x0000 (0dez)
 | F800:02 |  | Input type Ch2 | RW | 0x0000 (0dez)
Legende
Flags: |
RO (Read Only): | dieses Objekt kann nur gelesen werden
RW (Read/Write): | dieses Objekt kann gelesen und beschrieben werden


EP31x4-x002 - Objektübersicht

Konfiguration [image] EP31x4-x002 - Objektübersicht
EP31x4-x002 - Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x012C1389 (19665801dez)
1008 |  | Device name | RO | EP3174-0002
1009 |  | Hardware version | RO | -
100A |  | Software version | RO | -
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x0C664052 (208027730dez)
 | 1018:03 | Revision | RO | 0x00000000 (0dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1800:0 | Subindex | AI TxPDO-Par Standard Ch. 1 | RO | 0x06 (6dez)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par-Compact Ch.1 | RO | 0x06 (6dez)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dez)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | AI TxPDO-Par Standard Ch.3 | RO | 0x06 (6dez)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | AI TxPDO-Par Compact Ch.3 | RO | 0x06 (6dez)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1806:0 | Subindex | AI TxPDO-Par Standard Ch.4 | RO | 0x06 (6dez)
 | 1806:06 | Exclude TxPDOs | RO | 07 1A
1807:0 | Subindex | AI TxPDO-Par Compact Ch.4 | RO | 0x06 (6dez)
 | 1807:06 | Exclude TxPDOs | RO | 06 1A
Index (hex) |  | Name | Flags | Default Wert
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x0B (11dez)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x0B (11dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1A04:0 | Subindex | AI TxPDO-Map Standard Ch.3 | RO | 0x0B (11dez)
 | 1A04:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A04:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A04:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A04:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A04:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A04:08 | SubIndex 008 | RO | 0x6020:0E, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6020:0F, 1
 | 1A04:0A | SubIndex 010 | RO | 0x6020:10, 1
 | 1A04:0B | SubIndex 011 | RO | 0x6020:11, 16
1A05:0 | Subindex | AI TxPDO-Map Compact Ch.3 | RO | 0x01 (1dez)
 | 1A05:01 | SubIndex 001 | RO | 0x6020:11, 16
1A06:0 | Subindex | AI TxPDO-Map Standard Ch.4 | RO | 0x0B (11dez)
 | 1A06:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A06:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A06:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A06:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A06:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A06:08 | SubIndex 008 | RO | 0x6030:0E, 1
 | 1A06:09 | SubIndex 009 | RO | 0x6030:0F, 1
 | 1A06:0A | SubIndex 010 | RO | 0x6030:10, 1
 | 1A06:0B | SubIndex 011 | RO | 0x6030:11, 16
1A07:0 | Subindex | AI TxPDO-Map Compact Ch.4 | RO | 0x01 (1dez)
 | 1A07:01 | SubIndex 001 | RO | 0x6030:11, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dez)
 | 1C13:03 | SubIndex 003 | RW | 0x1A04 (6660dez)
 | 1C13:04 | SubIndex 004 | RW | 0x1A06 (6662dez)
1C33:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00001388 (5000dez)
 | 1C33:04 | Sync modes supported | RO | 0xC00B (49163dez)
 | 1C33:05 | Minimum cycle time | RO | 0x0003D090 (250000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00001388 (5000dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum Delay time | RO | 0x00001388 (5000dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6000:01 | Underrange | RO | 0x00 (0dez)
 | 6000:02 | Overrange | RO | 0x00 (0dez)
 | 6000:03 | Limit 1 | RO | -
 | 6000:05 | Limit 2 | RO | -
 | 6000:07 | Error | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6010:01 | Underrange | RO | 0x00 (0dez)
 | 6010:02 | Overrange | RO | 0x00 (0dez)
 | 6010:03 | Limit 1 | RO | -
 | 6010:05 | Limit 2 | RO | -
 | 6010:07 | Error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Value | RO | 0x0000 (0dez)
6020:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6020:01 | Underrange | RO | 0x00 (0dez)
 | 6020:02 | Overrange | RO | 0x00 (0dez)
 | 6020:03 | Limit 1 | RO | -
 | 6020:05 | Limit 2 | RO | -
 | 6020:07 | Error | RO | 0x00 (0dez)
 | 6020:0E | Sync error | RO | 0x00 (0dez)
 | 6020:0F | TxPDO State | RO | 0x00 (0dez)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6020:11 | Value | RO | 0x0000 (0dez)
6030:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6030:01 | Underrange | RO | 0x00 (0dez)
 | 6030:02 | Overrange | RO | 0x00 (0dez)
 | 6030:03 | Limit 1 | RO | -
 | 6030:05 | Limit 2 | RO | -
 | 6030:07 | Error | RO | 0x00 (0dez)
 | 6030:0E | Sync error | RO | 0x00 (0dez)
 | 6030:0F | TxPDO State | RO | 0x00 (0dez)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6030:11 | Value | RO | 0x0000 (0dez)
8000:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Siemens Bits | RW | 0x00 (0dez)
 | 8000:06 | Enable filter | RW | 0x01 (1dez)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:18 | User calibration gain | RW | 0x4000 (16384dez)
800E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dez)
800F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 800F:01 | R0 offset | RW | 0x0000 (0dez)
 | 800F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 800F:03 | R1 offset | RW | 0x0000 (0dez)
 | 800F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 800F:05 | R2 offset | RW | 0x0000 (0dez)
 | 800F:06 | R2 gain | RW | 0x4000 (16384dez)
8010:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Siemens bits | RW | 0x00 (0dez)
 | 8010:06 | Enable filter | RW | 0x00 (0dez)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
801E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dez)
801F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 801F:01 | R0 offset | RW | 0x0000 (0dez)
 | 801F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 801F:03 | R1 offset | RW | 0x0000 (0dez)
 | 801F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 801F:05 | R2 offset | RW | 0x0000 (0dez)
 | 801F:06 | R2 gain | RW | 0x4000 (16384dez)
8020:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:02 | Presentation | RW | 0x00 (0dez)
 | 8020:05 | Siemens bits | RW | 0x00 (0dez)
 | 8020:06 | Enable filter | RW | 0x01 (1dez)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8020:15 | Filter settings | RW | 0x0000 (0dez)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:18 | User calibration gain | RW | 0x4000 (16384dez)
802E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 802E:01 | ADC raw value | RO | 0x0000 (0dez)
802F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 802F:01 | R0 offset | RW | 0x0000 (0dez)
 | 802F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 802F:03 | R1 offset | RW | 0x0000 (0dez)
 | 802F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 802F:05 | R2 offset | RW | 0x0000 (0dez)
 | 802F:06 | R2 gain | RW | 0x4000 (16384dez)
8030:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:02 | Presentation | RW | 0x00 (0dez)
 | 8030:05 | Siemens bits | RW | 0x00 (0dez)
 | 8030:06 | Enable filter | RW | 0x01 (1dez)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8030:15 | Filter settings | RW | 0x0000 (0dez)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:18 | User calibration gain | RW | 0x4000 (16384dez)
803E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 803E:01 | ADC raw value | RO | 0x0000 (0dez)
803F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 803F:01 | R0 offset | RW | 0x0000 (0dez)
 | 803F:02 | R0 gain | RW | 0x4000 (16384dez)
 | 803F:03 | R1 offset | RW | 0x0000 (0dez)
 | 803F:04 | R1 gain | RW | 0x4000 (16384dez)
 | 803F:05 | R2 offset | RW | 0x0000 (0dez)
 | 803F:06 | R2 gain | RW | 0x4000 (16384dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x04 (4dez)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dez)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dez)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dez)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dez)
F800:0 | Subindex | AI Range Settings (neue Module) | RW | 0x04 (4dez)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dez)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dez)
 | F800:03 | Input type Ch3 | RW | 0x0000 (0dez)
 | F800:04 | Input type Ch4 | RW | 0x0000 (0dez)
 | F800:05 | Enable Filter Settings Per Channel | RW | -
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


EP3174-0092 - Objektübersicht

Konfiguration [image] EP3174-0092 - Objektübersicht
EP3174-0092 - Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x012C1389 (19665801dez)
1008 |  | Device name | RO | EP3174-0092
1009 |  | Hardware version | RO | -
100A |  | Software version | RO | -
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x0C664052 (208027730dez)
 | 1018:03 | Revision | RO | 0x00000000 (0dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1610:0 | Subindex | TSC RxPDO-Map Master Message | RW | 0x04 (4dez)
 | 1610:01 | Subindex 001 | RW | 0x7040:01, 8
 | 1610:02 | Subindex 002 | RW | 0x0000:00, 8
 | 1610:03 | Subindex 003 | RW | 0x7040:03, 16
 | 1610:04 | Subindex 004 | RW | 0x7040:02, 16
1800:0 | Subindex | AI TxPDO-Par Standard Ch. 1 | RO | 0x06 (6dez)
 | 1800:06 | Exclude TxPDOs | RO | 01 1A
1801:0 | Subindex | AI TxPDO-Par-Compact Ch.1 | RO | 0x06 (6dez)
 | 1801:06 | Exclude TxPDOs | RO | 00 1A
1802:0 | Subindex | AI TxPDO-Par Standard Ch.2 | RO | 0x06 (6dez)
 | 1802:06 | Exclude TxPDOs | RO | 03 1A
1803:0 | Subindex | AI TxPDO-Par Compact Ch.2 | RO | 0x06 (6dez)
 | 1803:06 | Exclude TxPDOs | RO | 02 1A
1804:0 | Subindex | AI TxPDO-Par Standard Ch.3 | RO | 0x06 (6dez)
 | 1804:06 | Exclude TxPDOs | RO | 05 1A
1805:0 | Subindex | AI TxPDO-Par Compact Ch.3 | RO | 0x06 (6dez)
 | 1805:06 | Exclude TxPDOs | RO | 04 1A
1806:0 | Subindex | AI TxPDO-Par Standard Ch.4 | RO | 0x06 (6dez)
 | 1806:06 | Exclude TxPDOs | RO | 07 1A
1807:0 | Subindex | AI TxPDO-Par Compact Ch.4 | RO | 0x06 (6dez)
 | 1807:06 | Exclude TxPDOs | RO | 06 1A
1A00:0 | Subindex | AI TxPDO-Map Standard Ch.1 | RO | 0x0B (11dez)
 | 1A00:01 | Subindex 001 | RO | 0x6000:01, 1
 | 1A00:02 | Subindex 002 | RO | 0x6000:02, 1
 | 1A00:03 | Subindex 003 | RO | 0x6000:03, 2
 | 1A00:04 | Subindex 004 | RO | 0x6000:05, 2
 | 1A00:05 | Subindex 005 | RO | 0x6000:07, 1
 | 1A00:06 | Subindex 006 | RO | 0x0000:00, 1
 | 1A00:07 | Subindex 007 | RO | 0x0000:00, 5
 | 1A00:08 | Subindex 008 | RO | 0x6000:0E, 1
 | 1A00:09 | Subindex 009 | RO | 0x6000:0F, 1
 | 1A00:0A | Subindex 010 | RO | 0x6000:10, 1
 | 1A00:0B | Subindex 011 | RO | 0x6000:11, 16
1A01:0 | Subindex | AI TxPDO-Map Compact Ch.1 | RO | 0x01 (1dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6000:11, 16
Index (hex) |  | Name | Flags | Default Wert
1A02:0 | Subindex | AI TxPDO-Map Standard Ch.2 | RO | 0x0B (11dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6010:03, 2
 | 1A02:04 | SubIndex 004 | RO | 0x6010:05, 2
 | 1A02:05 | SubIndex 005 | RO | 0x6010:07, 1
 | 1A02:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A02:07 | SubIndex 007 | RO | 0x0000:00, 6
 | 1A02:08 | SubIndex 008 | RO | 0x1802:07, 1
 | 1A02:09 | SubIndex 009 | RO | 0x1802:09, 1
 | 1A02:0A | SubIndex 010 | RO | 0x6010:10, 1
 | 1A02:0B | SubIndex 011 | RO | 0x6010:11, 16
1A03:0 | Subindex | AI TxPDO-Map Compact Ch.2 | RO | 0x01 (1dez)
 | 1A03:01 | SubIndex 001 | RO | 0x6010:11, 16
1A04:0 | Subindex | AI TxPDO-Map Standard Ch.3 | RO | 0x0B (11dez)
 | 1A04:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A04:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A04:03 | SubIndex 003 | RO | 0x6020:03, 2
 | 1A04:04 | SubIndex 004 | RO | 0x6020:05, 2
 | 1A04:05 | SubIndex 005 | RO | 0x6020:07, 1
 | 1A04:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A04:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A04:08 | SubIndex 008 | RO | 0x6020:0E, 1
 | 1A04:09 | SubIndex 009 | RO | 0x6020:0F, 1
 | 1A04:0A | SubIndex 010 | RO | 0x6020:10, 1
 | 1A04:0B | SubIndex 011 | RO | 0x6020:11, 16
1A05:0 | Subindex | AI TxPDO-Map Compact Ch.3 | RO | 0x01 (1dez)
 | 1A05:01 | SubIndex 001 | RO | 0x6020:11, 16
1A06:0 | Subindex | AI TxPDO-Map Standard Ch.4 | RO | 0x0B (11dez)
 | 1A06:01 | SubIndex 001 | RO | 0x6030:01, 1
 | 1A06:02 | SubIndex 002 | RO | 0x6030:02, 1
 | 1A06:03 | SubIndex 003 | RO | 0x6030:03, 2
 | 1A06:04 | SubIndex 004 | RO | 0x6030:05, 2
 | 1A06:05 | SubIndex 005 | RO | 0x6030:07, 1
 | 1A06:06 | SubIndex 006 | RO | 0x0000:00, 1
 | 1A06:07 | SubIndex 007 | RO | 0x0000:00, 5
 | 1A06:08 | SubIndex 008 | RO | 0x6030:0E, 1
 | 1A06:09 | SubIndex 009 | RO | 0x6030:0F, 1
 | 1A06:0A | SubIndex 010 | RO | 0x6030:10, 1
 | 1A06:0B | SubIndex 011 | RO | 0x6030:11, 16
1A07:0 | Subindex | AI TxPDO-Map Compact Ch.4 | RO | 0x01 (1dez)
 | 1A07:01 | SubIndex 001 | RO | 0x6030:11, 16
1A10:0 | Subindex | TSC TxPDO-Map Slave Message | RO | 0x0A (10dez)
 | 1A10:01 | SubIndex 001 | RO | 0x6040:01, 8
 | 1A10:02 | SubIndex 002 | RO | 0x6000:11, 16
 | 1A10:03 | SubIndex 003 | RO | 0x6040:03, 16
 | 1A10:04 | SubIndex 004 | RO | 0x6010:11, 16
 | 1A10:05 | SubIndex 005 | RO | 0x6040:04, 16
 | 1A10:06 | SubIndex 006 | RO | 0x6020:11, 16
 | 1A10:07 | SubIndex 007 | RO | 0x6040:05, 16
 | 1A10:08 | SubIndex 008 | RO | 0x6030:11, 16
 | 1A10:09 | SubIndex 009 | RO | 0x6040:06, 16
 | 1A10:0A | SubIndex 010 | RO | 0x6040:02, 16
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x00 (0dez)
 | 1C12:00 | SubIndex 001 | RW | 0x1610 (5648dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x05 (5dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A02 (6658dez)
 | 1C13:03 | SubIndex 003 | RW | 0x1A04 (6660dez)
 | 1C13:04 | SubIndex 004 | RW | 0x1A06 (6662dez)
 | 1C13:05 | SubIndex 005 | RW | 0x1A10 (6672dez)
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x000448E0 (280800dez)
 | 1C32:04 | Sync modes supported | RO | 0xC00B (49163dez)
 | 1C32:05 | Minimum cycle time | RO | 0x00041EB0 (270000dez)
 | 1C32:06 | Calc and copy time | RO | 0x000087F0 (34800dez)
 | 1C32:07 | Minimum delay time | RO | 0x0003C0F0 (246000dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum Delay time | RO | 0x0003C0F0 (246000dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x0002FC10 (195600dez)
 | 1C33:04 | Sync modes supported | RO | 0xC00B (49163dez)
 | 1C33:05 | Minimum cycle time | RO | 0x00041EB0 (270000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000708 (1800dez)
 | 1C33:07 | Minimum delay time | RO | 0x0002FC10 (195600dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum Delay time | RO | 0x0002FC10 (195600dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6000:01 | Underrange | RO | 0x00 (0dez)
 | 6000:02 | Overrange | RO | 0x00 (0dez)
 | 6000:03 | Limit 1 | RO | -
 | 6000:05 | Limit 2 | RO | -
 | 6000:07 | Error | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Value | RO | 0x0000 (0dez)
6010:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6010:01 | Underrange | RO | 0x00 (0dez)
 | 6010:02 | Overrange | RO | 0x00 (0dez)
 | 6010:03 | Limit 1 | RO | -
 | 6010:05 | Limit 2 | RO | -
 | 6010:07 | Error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Value | RO | 0x0000 (0dez)
6020:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6020:01 | Underrange | RO | 0x00 (0dez)
 | 6020:02 | Overrange | RO | 0x00 (0dez)
 | 6020:03 | Limit 1 | RO | -
 | 6020:05 | Limit 2 | RO | -
 | 6020:07 | Error | RO | 0x00 (0dez)
 | 6020:0E | Sync error | RO | 0x00 (0dez)
 | 6020:0F | TxPDO State | RO | 0x00 (0dez)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6020:11 | Value | RO | 0x0000 (0dez)
6030:0 | Subindex | AI Inputs | RO | 0x11 (17dez)
 | 6030:01 | Underrange | RO | 0x00 (0dez)
 | 6030:02 | Overrange | RO | 0x00 (0dez)
 | 6030:03 | Limit 1 | RO | -
 | 6030:05 | Limit 2 | RO | -
 | 6030:07 | Error | RO | 0x00 (0dez)
 | 6030:0E | Sync error | RO | 0x00 (0dez)
 | 6030:0F | TxPDO State | RO | 0x00 (0dez)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6030:11 | Value | RO | 0x0000 (0dez)
6040:0 | Subindex | TSC Slave Frame Elements | RO | 0x06 (6dez)
 | 6040:01 | TSC__Slave Cmd | RO | 0x00 (0dez)
 | 6040:02 | TSC__Slave ConnID | RO | 0x0000 (0dez)
 | 6040:03 | TSC__Slave CRC_0 | RO | 0x0000 (0dez)
 | 6040:04 | TSC__Slave CRC_1 | RO | 0x0000 (0dez)
 | 6040:05 | TSC__Slave CRC_2 | RO | 0x0000 (0dez)
 | 6040:06 | TSC__Slave CRC_3 | RO | 0x0000 (0dez)
7040:0 | Subindex | TSC Master Frame Elements | RO | 0x03 (3dez)
 | 7040:01 | TSC__Master Cmd | RO | 0x00 (0dez)
 | 7040:02 | TSC__Master ConnID | RO | 0x0000 (0dez)
 | 7040:03 | TSC__Master CRC_0 | RO | 0x0000 (0dez)
8000:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8000:01 | Enable user scale | RW | 0x00 (0dez)
 | 8000:02 | Presentation | RW | 0x00 (0dez)
 | 8000:05 | Siemens Bits | RW | 0x00 (0dez)
 | 8000:06 | Enable filter | RW | 0x01 (1dez)
 | 8000:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8000:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8000:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8000:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8000:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8000:11 | User scale offset | RW | 0x0000 (0dez)
 | 8000:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8000:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8000:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8000:15 | Filter settings | RW | 0x0000 (0dez)
 | 8000:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8000:18 | User calibration gain | RW | 0x0000 (0dez)
800E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 800E:01 | ADC raw value | RO | 0x0000 (0dez)
800F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 800F:01 | R0 offset | RW | 0x0000 (0dez)
 | 800F:02 | R0 gain | RW | 0x0000 (0dez)
 | 800F:03 | R1 offset | RW | 0x0000 (0dez)
 | 800F:04 | R1 gain | RW | 0x0000 (0dez)
 | 800F:05 | R2 offset | RW | 0x0000 (0dez)
 | 800F:06 | R2 gain | RW | 0x0000 (0dez)
8010:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8010:01 | Enable user scale | RW | 0x00 (0dez)
 | 8010:02 | Presentation | RW | 0x00 (0dez)
 | 8010:05 | Siemens bits | RW | 0x00 (0dez)
 | 8010:06 | Enable filter | RW | 0x00 (0dez)
 | 8010:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8010:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8010:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8010:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8010:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8010:11 | User scale offset | RW | 0x0000 (0dez)
 | 8010:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8010:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8010:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8010:15 | Filter settings | RW | 0x0000 (0dez)
 | 8010:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8010:18 | User calibration gain | RW | 0x4000 (16384dez)
801E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 801E:01 | ADC raw value | RO | 0x0000 (0dez)
801F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 801F:01 | R0 offset | RW | 0x0000 (0dez)
 | 801F:02 | R0 gain | RW | 0x0000 (0dez)
 | 801F:03 | R1 offset | RW | 0x0000 (0dez)
 | 801F:04 | R1 gain | RW | 0x0000 (0dez)
 | 801F:05 | R2 offset | RW | 0x0000 (0dez)
 | 801F:06 | R2 gain | RW | 0x4000 (16384dez)
8020:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:02 | Presentation | RW | 0x00 (0dez)
 | 8020:05 | Siemens bits | RW | 0x00 (0dez)
 | 8020:06 | Enable filter | RW | 0x01 (1dez)
 | 8020:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8020:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8020:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8020:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8020:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8020:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8020:15 | Filter settings | RW | 0x0000 (0dez)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:18 | User calibration gain | RW | 0x0000 (0dez)
802E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 802E:01 | ADC raw value | RO | 0x0000 (0dez)
802F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 802F:01 | R0 offset | RW | 0x0000 (0dez)
 | 802F:02 | R0 gain | RW | 0x0000 (0dez)
 | 802F:03 | R1 offset | RW | 0x0000 (0dez)
 | 802F:04 | R1 gain | RW | 0x0000 (0dez)
 | 802F:05 | R2 offset | RW | 0x0000 (0dez)
 | 802F:06 | R2 gain | RW | 0x0000 (0dez)
8030:0 | Subindex | AI Settings | RW | 0x18 (24dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:02 | Presentation | RW | 0x00 (0dez)
 | 8030:05 | Siemens bits | RW | 0x00 (0dez)
 | 8030:06 | Enable filter | RW | 0x01 (1dez)
 | 8030:07 | Enable limit 1 | RW | 0x00 (0dez)
 | 8030:08 | Enable limit 2 | RW | 0x00 (0dez)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8030:0B | Enable vendor calibration | RW | 0x01 (1dez)
 | 8030:0E | Swap limit bits | RW | 0x00 (0dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x00010000 (65536dez)
 | 8030:13 | Limit 1 | RW | 0x0000 (0dez)
 | 8030:14 | Limit 2 | RW | 0x0000 (0dez)
 | 8030:15 | Filter settings | RW | 0x0000 (0dez)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:18 | User calibration gain | RW | 0x0000 (0dez)
803E:0 | Subindex | AI Internal data | RO | 0x01 (1dez)
 | 803E:01 | ADC raw value | RO | 0x0000 (0dez)
803F:0 | Subindex | AI Vendor data | RW | 0x06 (6dez)
 | 803F:01 | R0 offset | RW | 0x0000 (0dez)
 | 803F:02 | R0 gain | RW | 0x0000 (0dez)
 | 803F:03 | R1 offset | RW | 0x0000 (0dez)
 | 803F:04 | R1 gain | RW | 0x0000 (0dez)
 | 803F:05 | R2 offset | RW | 0x0000 (0dez)
 | 803F:06 | R2 gain | RW | 0x0000 (0dez)
8040:0 | 8040:0 | TSC Settings | RW | 0x02 (2dez)
 | 8040:01 | Address | RW | 0x0000 (0dez)
 | 8040:02 | Connection Mode | RW | 0x00000000 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0004 (4dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x04 (4dez)
 | F010:01 | SubIndex 001 | RW | 0x0000012C (300dez)
 | F010:02 | SubIndex 002 | RW | 0x0000012C (300dez)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dez)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dez)
F800:0 | Subindex | AI Range Settings (neue Module) | RW | 0x04 (4dez)
 | F800:01 | Input type Ch1 | RW | 0x0000 (0dez)
 | F800:02 | Input type Ch2 | RW | 0x0000 (0dez)
 | F800:03 | Input type Ch3 | RW | 0x0000 (0dez)
 | F800:04 | Input type Ch4 | RW | 0x0000 (0dez)
 | F800:05 | Enable Filter Settings Per Channel | RW | 0x000003B6 (950dez)
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


EP31x2 - Objektbeschreibung und Parametrierung

Konfiguration [image] EP31x2 - Objektbeschreibung und Parametrierung
EP31x2 - Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 AI Settings Ch.1 (Parametrierung von Kanal 1)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | AI Settings Ch.1 | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8000:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8000:05 nur EP3182-1002 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8000:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8000:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8000:0E | Swap limit bits | 1 | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-versionen herzustellen. | BOOLEAN | RW | 0x00 (0dez)
8000:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen aller Kanäle des Moduls, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x4000 (16384dez)
Index 8010 AI Settings (Parametrierung von Kanal 2)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8010:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8000:05 nur EP3182-1002 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits eingeblendet |  | BOOLEAN | RW | 0x00 (0dez)
8010:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8010:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | 1 | Freigabe des Anwenderabgleichs | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | 1 | Freigabe des Herstellerabgleichs | BOOLEAN | RW | 0x01 (1dez)
8010:0E | Swap limit bits | 1 | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. | BOOLEAN | RW | 0x00 (0dez)
8010:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x4000 (16384dez)
Index F800 AI Range Settings (EP3174/EP3184 ab Firmware-Version 04 sowie alle EP3182)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x02 (2dez)
F800:01 | Input type Ch1 | Eingangssignalbereich für Kanal 1 |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | -10 V...+10 V
 |  | 1 | 0 mA...20 mA
 |  | 2 | 4 mA...20 mA
 |  | 4 | -20 mA…20 mA
 |  | 6 | 0 V...10 V
F800:02 | Input type Ch2 | Eingangssignalbereich für Kanal 2 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)
Weitere Objekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | EP3162-0001: 0x012C1389 (19665801dez) EP3182-1002: 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP3162-0002 EP3182-1002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | EP3162.0002: 0x0C5A4052 (207241298dez) EP3182-1002: 0x0C6E4052 (208552018dez))
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DO RxPDO-Map Outputs (nur EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DO RxPDO-Map Outputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DO Outputs), entry 0x01 (Digital output 1)) | UINT32 | RO | 0x7020:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DO Outputs), entry 0x02 (Digital output 2)) | UINT32 | RO | 0x7020:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1800 AI TxPDO-Par Standard Ch.1 (nur EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI TxPDO-Par Compact Ch.1 (nur EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch.2 (nur EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI TxPDO-Par Compact Ch.2 (nur EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1A00 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs, entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x16 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Standard Ch.2 (EP3162-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1802:07, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A01 AI TxPDO-Map Compact Ch.1 (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI TxPDO-Map Standard Ch.2 (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (AI inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (AI inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60102 (AI inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch.2 (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign (EP3162-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
1C12:01 | SubIndex 001 |  | UINT8 | RW | -
1C12:02 | SubIndex 002 |  | UINT8 | RW | -
Index 1C12 RxPDO assign (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT8 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign (EP3162-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | -
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | -
Index 1C13 TxPDO assign (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6657dez)
Index 1C32 SM output parameter (EP3162-0002)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0xC009 (49161dez)
1C32:05
Minimum cycle time
UINT32
RO
0x00055730 (350000dez)
1C32:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
BOOLEAN
RO
0x00 (0dez)
Index 1C32 SM output parameter (EP3182-1002)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0001 (0dez)
1C32:02
Cycle time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
UINT32
RO
0x00030D40 (200000dez)
1C32:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM output parameter (EP3162-0002)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM output parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0xC009 (49161dez)
1C33:05
Minimum cycle time
UINT32
RO
0x00055730 (350000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dez)
1C33:08
Command
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter (EP3182-1002)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
UINT32
RO
0x00030D40 (200000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00002710 (10000dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001388 (5000dez)
1C33:08
Command
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001388 (5000dez)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dez)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 AI Inputs Ch. 1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6000:0 | AI Inputs Ch. 1 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | -
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | -
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6010 AI Inputs Ch. 2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6010:0 | AI Inputs Ch. 2 | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | -
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | -
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 7020 DO Outputs (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | DO Outputs | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
7020:01 | Digital output 1 |  | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Digital output 2 |  | BOOLEAN | RO | 0x00 (0dez)
Index 800E AI Internal data Ch. 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | AI Internal data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
800E:01 | ADC raw value | Rohwert des Analog/Digital-Konverters | INT16 | RO | 0x0000 (0dez)
Index 800F AI Vendor data Ch. 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
800F:01 | offsetU | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:02 | gainU | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
800F:03 | offsetI | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:04 | gainI | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
800F:05 | offsetI4 | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:06 | gainI4 | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Index 801E AI Internal data Ch. 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | AI Internal data Ch. 2 | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
801E:01 | ADC raw value | Rohwert des Analog/Digital-Konverters | INT16 | RO | 0x0000 (0dez)
Index 801F AI Vendor data Ch. 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
801F:01 | offsetU | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
801F:02 | gainU | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
801F:03 | offsetI | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
801F:04 | gainI | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
801F:05 | offsetI4 | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
801F:06 | gainI4 | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | EP3162-0002: 0x0002 (2dez) EP3182-1002: 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list (EP3162-0002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dez)
Index F010 Module list (EP3182-1002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000000C8 (200dez)


EP31x4 - Objektbeschreibung und Parametrierung

Konfiguration [image] EP31x4 - Objektbeschreibung und Parametrierung
EP31x4 - Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 AI Settings (Parametrierung von Kanal 1)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8000:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8000:05 | Siemens bits | 1 | Auf den niedrigsten 3 Bits werden im Status-Wort Statusanzeigen eingeblendet. | BOOLEAN | RW | 0x00 (0dez)
8000:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8000:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | 1 | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | 1 | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8000:0E | Swap limit bits | 1 | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-versionen herzustellen. | BOOLEAN | RW | 0x00 (0dez)
8000:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8000:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8000:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8000:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen aller Kanäle des Moduls, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8000:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8010 AI Settings (Parametrierung von Kanal 2)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8010:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8010:05 | Siemens bits | 1 | Auf den niedrigsten 3 Bits werden im Status-Wort Statusanzeigen eingeblendet. | BOOLEAN | RW | 0x00 (0dez)
8010:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8010:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | 1 | Freigabe des Anwenderabgleichs | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | 1 | Freigabe des Herstellerabgleichs | BOOLEAN | RW | 0x01 (1dez)
8010:0E | Swap limit bits | 1 | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. | BOOLEAN | RW | 0x00 (0dez)
8010:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8010:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8010:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8010:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8010:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8020 AI Settings (Parametrierung von Kanal 3)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8020:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8020:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8020:05 | Siemens bits | 1 | Auf den niedrigsten 3 Bits werden im Status-Wort Statusanzeigen eingeblendet. | BOOLEAN | RW | 0x00 (0dez)
8020:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8020:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration | 1 | Freigabe des Anwenderabgleichs | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration | 1 | Freigabe des Herstellerabgleichs | BOOLEAN | RW | 0x01 (1dez)
8020:0E | Swap limit bits | 1 | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. | BOOLEAN | RW | 0x00 (0dez)
8020:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8020:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8020:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8020:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8020:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8020:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8020:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8030 AI Settings (Parametrierung von Kanal 4)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8030:0 | AI Settings | Maximaler Subindex |  | UINT8 | RO | 0x18 (24dez)
8030:01 | Enable user scale | 1 | Die Anwender-Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8030:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
 |  | 1 | Unsigned presentation
 |  | 2 | Absolute value with MSB as sign (Betragsvorzeichendarstellung)
8030:05 | Siemens bits | 1 | Auf den niedrigsten 3 Bits werden im Status-Wort Statusanzeigen eingeblendet. | BOOLEAN | RW | 0x00 (0dez)
8030:06 | Enable filter | 1 | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x01 (1dez)
8030:07 | Enable limit 1 | 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable limit 2 | 1 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
8030:0A | Enable user calibration | 1 | Freigabe des Anwenderabgleichs | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration | 1 | Freigabe des Herstellerabgleichs | BOOLEAN | RW | 0x01 (1dez)
8030:0E | Swap limit bits | 1 | Tauscht die beiden Limit-Bits um Kompatibilität zu älteren Hardware-Versionen herzustellen. | BOOLEAN | RW | 0x00 (0dez)
8030:11 | User scale offset | Offset der Anwender-Skalierung |  | INT16 | RW | 0x0000 (0dez)
8030:12 | User scale gain | Gain der Anwender-Skalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535dez (0x00010000hex) und wird auf +/- 0x7FFFF begrenzt |  | INT32 | RW | 0x00010000 (65536dez)
8030:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8030:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits |  | INT16 | RW | 0x0000 (0dez)
8030:15 | Filter settings | Dieses Objekt zeigt die digitalen Filtereinstellungen. Die Filtereinstellungen können hier nur gelesen werden. Sie werden über Kanal 1 für alle Kanäle des Moduls vorgegeben. |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | 50 Hz FIR
 |  | 1 | 60 Hz FIR
 |  | 2 | IIR 1
 |  | 3 | IIR 2
 |  | 4 | IIR 3
 |  | 5 | IIR 4
 |  | 6 | IIR 5
 |  | 7 | IIR 6
 |  | 8 | IIR 7
 |  | 9 | IIR 8
8030:17 | User calibration offset | Anwenderabgleich: Offset |  | INT16 | RW | 0x0000 (0dez)
8030:18 | User calibration gain | Anwenderabgleich: Gain |  | INT16 | RW | 0x0000 (0dez)
Index F800 AI Range Settings (EP3174/EP3184 ab Firmware-Version 04)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | AI Range Settings | Maximum subindex |  | UINT8 | RO | 0x04 (4dez)
F800:01 | Input type Ch1 | Eingangssignalbereich für Kanal 1 |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | -10 V...+10 V
 |  | 1 | 0 mA...20 mA
 |  | 2 | 4 mA...20 mA
 |  | 6 | 0 V...10 V
F800:02 | Input type Ch2 | Eingangssignalbereich für Kanal 2 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)
F800:03* | Input type Ch3 | Eingangssignalbereich für Kanal 3 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)
F800:04* | Input type Ch4 | Eingangssignalbereich für Kanal 4 (Werte siehe Kanal 1) |  | UINT16 | RW | 0x0000 (0dez)
F800:05 | Enable Filter Settings Per Channel |  |  | BOOLEAN | RW | -
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP3174-0002, EP3174-0092, EP3184-0002, EP3184-1002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0C664052 (208027730dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1800 AI TxPDO-Par Standard Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | AI TxPDO-Par Standard Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 AI TxPDO-Par Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | AI TxPDO-Par Compact Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1802 AI TxPDO-Par Standard Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | AI TxPDO-Par Standard Ch.2 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 AI TxPDO-Par Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | AI TxPDO-Par Compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1804 AI TxPDO-Par Standard Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | AI TxPDO-Par Standard Ch.3 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1805 AI TxPDO-Par Compact Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | AI TxPDO-Par Compact Ch.3 | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
Index 1806 AI TxPDO-Par Standard Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | AI TxPDO-Par Standard Ch.4 | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[2] | RO | 07 1A
Index 1807 AI TxPDO-Par Compact Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | AI TxPDO-Par Compact Ch.4 | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[2] | RO | 06 1A
Index 1A00 AI TxPDO-Map Standard Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | AI TxPDO-Map Standard Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6000:0E, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1800 (AI TxPDO-Par Standard Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 AI TxPDO-Map Compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | AI TxPDO-Map Compact Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A02 AI TxPDO-Map Standard Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | AI TxPDO-Map Standard Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6010:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6010:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1802:07, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1802 (AI TxPDO-Par Standard Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 AI TxPDO-Map Compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | AI TxPDO-Map Compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A04 AI TxPDO-Map Standard Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | AI TxPDO-Map Standard Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0B (11dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6020:03, 2
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6020:05, 2
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6020:0E, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6020:0F, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1804 (AI TxPDO-Par Standard Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6020:11, 16
Index 1A05 AI TxPDO-Map Compact Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | AI TxPDO-Map Compact Ch.3 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A06 AI TxPDO-Map Standard Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | AI TxPDO-Map Standard Ch.4 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0B (11dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6030:03, 2
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6030:05, 2
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x6030:0E, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x6030:0F, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1806 (AI TxPDO-Par Standard Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6030:11, 16
Index 1A07 AI TxPDO-Map Compact Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | AI TxPDO-Map Compact Ch.4 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign (EP31x4-x002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C12 RxPDO assign (EP3174-0092)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1610 (5648dez)
Index 1C13 TxPDO assign (EP31x4-x002)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
Index 1C13 TxPDO assign (EP3174-0092)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
Index 1C32 SM output parameter (EP3174-0092)
Index (hex)
Name
Bedeutung
Data type
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x000448E0 (280800dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 3:2 = 10: DC-Mode wird unterstützt
▪
Bit 5:4 = 01: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC00B (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00041EB0 (270000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x000087F0 (34800dez)
1C32:07
Minimum delay time
UINT32
RO
0x0003C0F0 (246000dez)
1C32:08
Command
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum Delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x0003C0F0 (246000dez)
1C32:0B
SM event missed counter
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
EP31x4-x002:
0x00001388 (5000dez)
EP3174-0092:
0x0002FC10 (195600dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0xC00B (49163dez)
1C33:05
Minimum cycle time
UINT32
RO
EP31x4-x002:
0x0003D090 (250000dez)
EP3174-0092:
0x00041EB0 (270000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
EP31x4-x002:
0x00002710 (10000dez)
EP3174-0092:
0x00000708 (1800dez)
1C33:07
Minimum delay time
UINT32
RO
EP31x4-x002:
0x00001388 (5000dez)
EP3174-0092:
0x0002FC10 (195600dez)
1C33:08
Command
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
EP31x4-x002:
0x00001388 (5000dez)
EP3174-0092:
0x0002FC10 (195600dez)
1C33:0B
SM event missed counter
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
BOOLEAN
RO
0x00 (0dez)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 AI Inputs
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6000:0 | AI Inputs | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6000:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6000:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6010 AI Inputs
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6010:0 | AI Inputs | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6010:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6010:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6020 AI Inputs
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6020:0 | AI Inputs | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6020:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6020:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6020:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6020:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6020:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 6030 AI Inputs
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6030:0 | AI Inputs | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
6030:01 | Underrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors unterschritten wird oder das Prozessdatum den niedrigstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Overrange | Wird gesetzt, wenn der Arbeitsbereich des Sensors überschritten wird oder das Prozessdatum den höchstmöglichen Wert enthält. |  | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Limit 1 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6030:05 | Limit 2 | Nur bei aktivierter Limit-Prüfung |  | BIT2 | RO | 0x00 (0dez)
 |  | 1 | Eingestelltes Limit unterschritten
 |  | 2 | Eingestelltes Limit überschritten
 |  | 3 | Eingestelltes Limit erreicht
6030:07 | Error | Das Error-Bit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange). |  | BOOLEAN | RO | 0x00 (0dez)
6030:0E | Sync error |  |  | BOOLEAN | RO | 0x00 (0dez)
6030:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO |  | BOOLEAN | RO | 0x00 (0dez)
 |  | 0 | valid
 |  | 1 | invalid
6030:10 | TxPDO Toggle | TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. |  | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value | Analoges Eingangsdatum |  | INT16 | RO | 0x0000 (0dez)
Index 800E AI Internal data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | AI Internal data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
800E:01 | ADC raw value | Rohwert des Analog/Digital-Konverters | INT16 | RO | 0x0000 (0dez)
Index 800F AI Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
800F:01 | R0 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:02 | R0 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
800F:03 | R1 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:04 | R1 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
800F:05 | R2 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:06 | R2 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Index 801E AI Internal data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801E:0 | AI Internal data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
801E:01 | ADC raw value | Rohwert des Analog/Digital-Konverters | INT16 | RO | 0x0000 (0dez)
Index 801F AI Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
801F:01 | R0 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
801F:02 | R0 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
801F:03 | R1 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
801F:04 | R1 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
801F:05 | R2 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
801F:06 | R2 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Index 802E AI Internal data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802E:0 | AI Internal data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
802E:01 | ADC raw value | Rohwert des Analog/Digital-Konverters | INT16 | RO | 0x0000 (0dez)
Index 802F AI Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
802F:01 | R0 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
802F:02 | R0 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
802F:03 | R1 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
802F:04 | R1 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
802F:05 | R2 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
802F:06 | R2 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Index 803E AI Internal data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803E:0 | AI Internal data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
803E:01 | ADC raw value | Rohwert des Analog/Digital-Konverters | INT16 | RO | 0x0000 (0dez)
Index 803F AI Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
803F:01 | R0 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
803F:02 | R0 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
803F:03 | R1 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
803F:04 | R1 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
803F:05 | R2 offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
803F:06 | R2 gain | Gain (Herstellerabgleich) | INT16 | RW | 0x4000 (16384dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | EP31x4-x002: 0x0004 (4dez) EP3174-092: 0x0005 (5dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x05 (5dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dez)
F010:05* | SubIndex 005 |  | UINT32 | RW | 0x000003B6 (950dez)
*) nur EP3174-0092


Objekte TwinSAFE Single Channel (EP3174-0092)

Konfiguration [image] Objekte TwinSAFE Single Channel (EP3174-0092)
Objekte TwinSAFE Single Channel (EP3174-0092)
Index 1610 TSC RxPDO-Map Master Message
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1610:0 | TSC RxPDO-Map Master Message | PDO Mapping RxPDO | UINT8 | RO | 0x04 (4dez)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x01 (TSC___Master Cmd)) | UINT32 | RO | 0x7040:01, 8
1610:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x03 (TSC__Master CRC_0)) | UINT32 | RO | 0x7040:03, 16
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x02 (TSC__Master ConnID)) | UINT32 | RO | 0x7040:02, 16
Index 1A10 TSC TxPDO-Map Slave Message
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | TSC TxPDO-Map Slave Message | PDO Mapping TxPDO | UINT8 | RW | 0x0A (10dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x01 (TSC___Slave Cmd)) | UINT32 | RW | 0x6040:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 16
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x03 (TSC__Slave CRC_0)) | UINT32 | RW | 0x6040:03, 16
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 16
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x04 (TSC__Slave CRC_1)) | UINT32 | RW | 0x6040:04, 16
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 16
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x05 (TSC__Slave CRC_2)) | UINT32 | RW | 0x6040:05, 16
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (AI Inputs), entry 0x11 (Value)) | UINT32 | RW | 0x6030:11, 16
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x06 (TSC__Slave CRC_3)) | UINT32 | RW | 0x6040:06, 16
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x02 (TSC__Slave ConnID)) | UINT32 | RW | 0x6040:02, 16
Index 6040 TSC Slave Frame Elements
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | TSC Slave Frame Elements | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
6040:01 | TSC__Slave Cmd | reserviert | UINT8 | RO | 0x00 (0dez)
6040:02 | TSC__Slave ConnID | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:03 | TSC__Slave CRC_0 | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:04 | TSC__Slave CRC_1 | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:05 | TSC__Slave CRC_2 | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:06 | TSC__Slave CRC_3 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index 7040 TSC Master Frame Elements
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7040:0 | TSC Master Frame Elements | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
7040:01 | TSC__Master Cmd | reserviert | UINT8 | RO | 0x00 (0dez)
7040:02 | TSC__Master ConnID | reserviert | UINT16 | RO | 0x0000 (0dez)
7040:03 | TSC__Master CRC_0 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index 8040 TSC Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | TSC Settings | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
8040:01 | Address | TwinSAFE SC Adresse | UINT16 | RO | 0x0000 (0dez)
8040:02 | Connection Mode | Auswahl der TwinSAFE SC CRC | UINT32 | RO | 0x00000000 (0dez)


Wiederherstellen des Auslieferungszustandes

Konfiguration [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.