EP1xxx - EtherCAT Box modules with digital inputs
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
2.5.0
▪
EP1816-3008 added
2.4.1
▪
EP1111-0000 – technical data updated
2.4.0
▪
Nut torques for connectors updated
2.3.0
▪
Torque wrench diagram updated
▪
Power connection updated
2.2.0
▪
EP1008-0022 added
▪
EP1819-0021 added
▪
Cabling adjusted
2.1.0
▪
Nut torques for connectors extended
2.0.0
▪
Migration
▪
Technical data updated
1.4.0
▪
Accessories chapter added
▪
Chapter on Nut torques for connectors updated
▪
Chapter on EtherCAT connection updated
▪
Chapter on BG2000-0000 - protective housing for EtherCAT Box updated
1.3.0
▪
EP1111-0000 added
▪
EP1098-0001 and EP1098-0002 added
▪
EP1809-0021, EP1809-0022 and EP1819-0022 updated
1.2.0
▪
ATEX notes added
▪
Extended temperature range for activated modules documented
▪
EP1809-0021, EP1809-0022 and EP1819-0022 added
▪
Description of the power connection updated
▪
Overview of EtherCAT cables extended
1.1.0
▪
Technical data: Current consumption values amended
▪
Nut torques for connectors added
1.0.0
▪
Process data description extended
0.7
▪
Description of status LEDs added
▪
Signal connection extended
▪
Explanation of the serial number adapted to the new standard
0.6
▪
Signal connection extended
0.5
▪
First preliminary version
Firmware and hardware versions
This documentation refers to the firmware and hardware version that was applicable at the time the documentation was written.
The module features are continuously improved and developed further. Modules having earlier production statuses cannot have the same properties as modules with the latest status. However, existing properties are retained and are not changed, so that older modules can always be replaced with new ones.
The firmware and hardware version (delivery state) can be found in the batch number (D-number) printed on the side of the EtherCAT Box.
Syntax of the batch number (D-number):
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D no. 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


Product overview

Product overview
Product overview
Additional information
•
EtherCAT Box - Introduction
•
EP1xxx Module overview
•
EP1008, EP1018
•
EP1098-0001
•
EP1111-0000
•
EP1258-000x
•
EP1809, EP1819
•
EP1816-0008
•
EP1816-3008


EtherCAT Box - Introduction

Product overview [image] EtherCAT Box - Introduction
EtherCAT Box - Introduction
The EtherCAT system has been extended with EtherCAT Box modules with protection class IP 67. Through the integrated EtherCAT interface the modules can be connected directly to an EtherCAT network without an additional Coupler Box. The high-performance of EtherCAT is thus maintained into each module.
The extremely low dimensions of only 126 x 30 x 26.5 mm (h x w x d) are identical to those of the Fieldbus Box extension modules. They are thus particularly suitable for use where space is at a premium. The small mass of the EtherCAT modules facilitates applications with mobile I/O interface (e.g. on a robot arm). The EtherCAT connection is established via screened M8 connectors.
EtherCAT Box Modules within an EtherCAT network
The robust design of the EtherCAT Box modules enables them to be used directly at the machine. Control cabinets and terminal boxes are now no longer required. The modules are fully sealed and therefore ideally prepared for wet, dirty or dusty conditions.
Pre-assembled cables significantly simplify EtherCAT and signal wiring. Very few wiring errors are made, so that commissioning is optimized. In addition to pre-assembled EtherCAT, power and sensor cables, field-configurable connectors and cables are available for maximum flexibility. Depending on the application, the sensors and actuators are connected through M8 or M12 connectors.
The EtherCAT modules cover the typical range of requirements for I/O signals with protection class IP67:
▪
digital inputs with different filters (3.0 ms or 10 μs)
▪
digital outputs with 0.5 or 2 A output current
▪
analog inputs and outputs with 16 bit resolution
▪
Thermocouple and RTD inputs
▪
Stepper motor modules
XFC (eXtreme Fast Control Technology) modules, including inputs with time stamp, are also available.
EtherCAT Box with M8 connections for sensors/actuators
EtherCAT Box with M12 connections for sensors/actuators
Note
Basic EtherCAT documentation
You will find a detailed description of the EtherCAT system in the Basic System Documentation for EtherCAT, which is available for download from our website (www.beckhoff.com) under Downloads.
Note
XML files
You will find XML files (XML Device Description Files) for Beckhoff EtherCAT modules on our website (www.beckhoff.com) under Downloads, in the Configuration Files area.


EP1xxx Module overview

Product overview [image] EP1xxx Module overview
EP1xxx Module overview
Digital input modules
Module | Signal connection | Number of inputs | Filter | Comment
EP1008-0001 | 8 x M8 | 8 | 3.0 ms |
EP1008-0002 | 4 x M12 | 8 | 3.0 ms |
EP1008-0022 | 8 x M12 | 8 | 3.0 ms |
EP1018-0001 | 8 x M8 | 8 | 10 µs |
EP1018-0002 | 4 x M12 | 8 | 10 µs |
EP1098-0001 | 8 x M8 | 8 | 10 µs | negative switching
EP1111-0000 | - | 3 ID switches | - | for identification of EtherCAT groups
EP1258-0001 | 8 x M8 | 8 | 10 µs | 2 channels with time stamp
EP1258-0002 | 4 x M12 | 8 | 10 µs | 2 channels with time stamp
EP1809-0021 | 8 x M8 | 8 | 3.0 ms | wide body
EP1809-0022 | 8 x M12 | 8 | 3.0 ms | wide body
EP1816-0008 | 1 x D-Sub 25 | 16 | 10 µs |
EP1816-3008 | 2 x M8 | 16 | 10 µs | D-Sub
EP1819-0022 | 8 x M12 | 8 | 10 µs | wide body


EP1008, EP1018

Product overview [image] EP1008, EP1018
EP1008, EP1018
Additional information
•
EP1008, EP1018 - Introduction
•
EP1008, EP1018 - Technical Data
•
EP1008-0001 - Process image


EP1008, EP1018 - Introduction

Product overview [image] EP1008, EP1018 [image] EP1008, EP1018 - Introduction
EP1008, EP1018 - Introduction
EP1008-0001, EP1018-0001
EP1008-0002, EP1018-0002
EP1008-0022
8 digital inputs, 24 VDC
The EP1008 and EP1018 EtherCAT Box modules with digital inputs acquire binary control signals from the process level, and transfer them, electrically isolated, to the controller.
The status of the signal is displayed by light emitting diodes; the signal connection is made optionally through M8 connectors (EP1008-0001, EP1018-0001) or M12 connectors (EP1008-0002, EP1018-0002, EP1008-0022). These versions have input filters of different speeds.
The sensors are supplied from the control voltage US. The load voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links
Installation
UL Requirements for UL approved modules
ATEX - Special conditions for ATEX approved modules


EP1008, EP1018 - Technical Data

Product overview [image] EP1008, EP1018 [image] EP1008, EP1018 - Technical Data
EP1008, EP1018 - Technical Data
Technical data | EP1008-0001 | EP1008-0002 | EP1008-0022 | EP1018-0001 | EP1018-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8
Input connections | M8 | M12 | M12 | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3,0 ms | 3,0 ms | 3,0 ms | 10 µs | 10 µs
"0" signal voltage | -3...+5 V (EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (EN 61131-2, Type 3)
Input current | typically 3 mA (EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage, Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 8 input bits
Electrical isolation | Control voltage/fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (according to cULus, see UL Requirements) 0°C ... +55°C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus, ATEX


EP1008-0001 - Process image

Product overview [image] EP1008, EP1018 [image] EP1008-0001 - Process image
EP1008-0001 - Process image
Channel 1 to Channel 8
You will find the 8 digital inputs to the module (here using the EP1008-0001 as an example) under Channel 1 to Channel 8.
EP1008-0001, Process image


EP1098-0001

Product overview [image] EP1098-0001
EP1098-0001
Additional information
•
EP1098 - Introduction
•
EP1098 - Technical Data
•
EP1098-0001 - Process image


EP1098 - Introduction

Product overview [image] EP1098-0001 [image] EP1098 - Introduction
EP1098 - Introduction
EP1098-0001
8 digital inputs, 24 VDC, negative switching
The EP1098 EtherCAT Box modules with digital inputs acquire binary control signals from the process level, and transfer them, electrically isolated, to the controller.
The status of the signal is displayed by light emitting diodes. The signal connection is made through M8 connectors (EP1098 -0001) or M12 connectors (EP1098 -0002).
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Quick links
Installation
UL Requirements for UL approved modules


EP1098 - Technical Data

Product overview [image] EP1098-0001 [image] EP1098 - Technical Data
EP1098 - Technical Data
Technical data | EP1098-0001
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8 (negative switching)
Input connections | M8
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" signal voltage | 11…30 V
"1" signal voltage | 0…7 V
Input current | typically 2.5 mA (EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage, Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 8 input bits
Electrical isolation | Control voltage/fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (according to cULus, see UL Requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus


EP1098-0001 - Process image

Product overview [image] EP1098-0001 [image] EP1098-0001 - Process image
EP1098-0001 - Process image
Channel 1 to Channel 8
You will find the 8 digital inputs to the module (here using the EP1098-0001 as an example) under Channel 1 to Channel 8.
EP1098-0001, Process image


EP1111-0000

Product overview [image] EP1111-0000
EP1111-0000
Additional information
•
EP1111-0000 - Introduction
•
EP1111-0000 - Technical Data
•
EP1111-0000 - Process image


EP1111-0000 - Introduction

Product overview [image] EP1111-0000 [image] EP1111-0000 - Introduction
EP1111-0000 - Introduction
EP1111-0000
EtherCAT Box with ID switch
The EP1111-0000 EtherCAT Box has three decimal ID switches, with which a group of EtherCAT components can be assigned an ID. This group can be present in any position in the EtherCAT network, as a result of which variable topologies can be realized in a simple manner.
The EtherCAT connection is established via shielded M8 connectors with direct display of link and activity status. The Run LED indicates the status of the EP1111.
Quick links
Installation
Also see about this
•
UL Requirements


EP1111-0000 - Technical Data

Product overview [image] EP1111-0000 [image] EP1111-0000 - Technical Data
EP1111-0000 - Technical Data
Technical data | EP1111-0000
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Task within EtherCAT system | identification of any EtherCAT group in the EtherCAT network
Number of ID switches | 3
Positions per ID switch | 10
Number of different IDs | 999
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 2 byte input data
Weight | app. 165 g
Permissible ambient temperature during operation | -25°C ... +60°C 0°C…+55°C (according to cULus, see UL Requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus


EP1111-0000 - Process image

Product overview [image] EP1111-0000 [image] EP1111-0000 - Process image
EP1111-0000 - Process image
ID inputs
You will find input data of the ID switches under under ID Inputs.
EP1111-0000, ID inputs


EP1258-000x

Product overview [image] EP1258-000x
EP1258-000x
Additional information
•
EP1258 - Introduction
•
EP1258 - Technical Data
•
EP1258-0001 - Process image


EP1258 - Introduction

Product overview [image] EP1258-000x [image] EP1258 - Introduction
EP1258 - Introduction
EP1258-0001, EP1258-0002
8 digital inputs 24 VDC (two channels with time stamp)
The EP1258 EtherCAT Box with digital inputs acquires fast binary control signals from the process level and transmits them, electrically isolated, to the controller.
The status of the signal is displayed by light emitting diodes; the signal connection is made optionally through M8 connectors (EP1258-0001) or M12 connectors (EP1258-0002). Both modules have 10 µs input filters.
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Distributed Clocks
Channels 0 and 1 are assigned a time stamp that shows the time of the last edge change with a resolution of 1 ns. This technology enables signals to be traced exactly over time and synchronized with the clocks distributed across the system. With this technology, machine-wide parallel hardware wiring of digital inputs or encoder signals for synchronization purposes is often no longer required. As a result, equally timed reactions, independent of the bus cycle time, are to a large extent possible.
You will find more information about the distributed clocks system in the Distributed Clocks System Description, which is available under Download at our Internet site (http://www.beckhoff.com).
Quick links
Installation
UL Requirements for UL approved modules
ATEX - Special conditions for ATEX approved modules


EP1258 - Technical Data

Product overview [image] EP1258-000x [image] EP1258 - Technical Data
EP1258 - Technical Data
Technical data | EP1258-0001 | EP1258-0002
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 8
Input connections | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" signal voltage | -3...+5 V (similar to EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (similar to EN 61131-2, Type 3)
Input current | typically 3 mA (similar to EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Resolution time stamp | 1 ns (Channel 0/1)
Precision of the time stamp | 10 ns (+ input delay) (Channel 0/1)
Precision of the distributed clocks | < 100 ns (Channel 0/1)
Process image | 8 input bits , 36 byte time stamp
Electrical isolation | Control voltage/fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (according to cULus, see UL Requirements) 0°C ... +55°C (according to ATEX, see special conditions)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus, ATEX


EP1258-0001 - Process image

Product overview [image] EP1258-000x [image] EP1258-0001 - Process image
EP1258-0001 - Process image
Channel 1 to Channel 8
EP1258-0001, Process image
You will find the 8 digital inputs to the module (here using the EP1258-0001 as an example) under Channel 1 to Channel 8.


EP1809, EP1819

Product overview [image] EP1809, EP1819
EP1809, EP1819
Additional information
•
EP1809-0021, EP1819-0021 - Introduction
•
EP1809-0022, EP1819-0022 - Introduction
•
EP1809, EP1819 - Technical data
•
EP1809-0021 - Process image


EP1809-0021, EP1819-0021 - Introduction

Product overview [image] EP1809, EP1819 [image] EP1809-0021, EP1819-0021 - Introduction
EP1809-0021, EP1819-0021 - Introduction
EP1809-0021, EP1819-0021
16 digital inputs, 24 VDC
The EtherCAT modules EP1809-0021 and EP1819-0021 with digital inputs acquires the binary control signals from the process level and transmits them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via M8 connectors.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick links
Installation


EP1809-0022, EP1819-0022 - Introduction

Product overview [image] EP1809, EP1819 [image] EP1809-0022, EP1819-0022 - Introduction
EP1809-0022, EP1819-0022 - Introduction
EP1809-0022, EP1819-0022
16 digital inputs 24 VDC
The EP1809-0022 and EP1819-0022 modules with digital inputs acquire the binary control signals from the process level and transmit them, in an electrically isolated form, to the controller. The state of the signals is indicated by light emitting diodes. The signals are connected via M12 connectors. These versions are distinguished by input filters of different speeds.
The sensors are supplied from the box supply voltage US. The auxiliary voltage UP is not used in the input module, but may be connected in order to be relayed downstream.
Quick-Links
Installation


EP1809, EP1819 - Technical data

Product overview [image] EP1809, EP1819 [image] EP1809, EP1819 - Technical data
EP1809, EP1819 - Technical data
Technical data | EP1809-0021 | EP1809-0022 | EP1819-0021 | EP1819-0022
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 16
Input connections | M8 | M12 | M8 | M12
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 3 ms | 3 ms | 10 µs | 10 µs
"0" signal voltage | -3...+5 V (similar to EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (similar to EN 61131-2, Type 3)
Input current | typically 3 mA (similar to EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 130 mA (without sensor current)
Sensor supply | derived from control voltage Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 16 input bits
Electrical isolation | Control voltage / fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C | -25°C ... +60°C 0°C ... +55°C (according to cULus, see UL Requirements) | -25°C ... +60°C | -25°C ... +60°C
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE | CE, cULus | CE | CE


EP1809-0021 - Process image

Product overview [image] EP1809, EP1819 [image] EP1809-0021 - Process image
EP1809-0021 - Process image
Channel 1 to Channel 16
You will find the 16 digital inputs to the module (here using the EP1809-0021 as an example) under Channel 1 to Channel 16.
EP1809-0021, Process image


EP1816-0008

Product overview [image] EP1816-0008
EP1816-0008
Additional information
•
EP1816-0008 - Introduction
•
EP1816-0008 - Technical Data
•
EP1816-0008 - Status-LEDs
•
EP1816-0008 - Process image


EP1816-0008 - Introduction

Product overview [image] EP1816-0008 [image] EP1816-0008 - Introduction
EP1816-0008 - Introduction
EP1816-0008
16 digital inputs, 24 VDC
The EP1816-0008 EtherCAT Box with digital inputs acquires binary control signals from the process level and transfers them, with electrical isolation, to the controller. The signal status is indicated by light emitting diodes; the signal connection is made through a 25-pin Sub-D socket.
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Quick links
Installation
UL Requirements for UL approved modules


EP1816-0008 - Technical Data

Product overview [image] EP1816-0008 [image] EP1816-0008 - Technical Data
EP1816-0008 - Technical Data
Technical data | EP1816-0008
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 16
Input connections | 25 pin SUB-D socket
Nominal input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
"0" signal voltage | -3...+5 V (EN 61131-2, Type 3)
"1" signal voltage | +11...+30 V (EN 61131-2, Type 3)
Input current | typically 3 mA (EN 61131-2, Type 3)
Module electronic supply | derived from control voltage Us
Module electronic current consumption | typically 120 mA
Sensor supply | derived from control voltage Us
Sensor current consumption | max. 0.5 A total, short-circuit proof
Power supply connection | Feed: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Process image | 16 input bits
Electrical isolation | Control voltage/fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C 0°C ... +55°C (according to cULus, see UL Requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC resistance/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (conforms to EN 60529)
Installation position | variable
Approvals | CE, cULus


EP1816-0008 - Status-LEDs

Product overview [image] EP1816-0008 [image] EP1816-0008 - Status-LEDs
EP1816-0008 - Status-LEDs
EP1816-0008 - Status-LEDs
LED display
LED | Display | Meaning
STATUS 1-8 | Green illuminated | A signal (24 V) is present at a least one of the inputs for channels 1 to 8
STATUS 9-16 | Green illuminated | A signal (24 V) is present at a least one of the inputs for channels 9 to 16
Us | off | The power supply voltage, Us, is not present
 | Green illuminated | The power supply voltage, Us, is present
Up | off | The power supply voltage, Up, is not present
 | Green illuminated | The power supply voltage, Up, is present


EP1816-0008 - Process image

Product overview [image] EP1816-0008 [image] EP1816-0008 - Process image
EP1816-0008 - Process image
DIG Inputs Channel 1
You will find the first 8 digital inputs of the module under DIG Inputs Channel 1.
EP1816-0008, Process image, DIG Inputs Channel 1
DIG Inputs Channel 2
You will find the second 8 digital inputs of the module under DIG Inputs Channel 2.
EP1816-0008, Process image, DIG Inputs Channel 2


EP1816-3008

Product overview [image] EP1816-3008
EP1816-3008
Additional information
•
EP1816-3008 - Introduction
•
EP1816-3008 - Technical data
•
EP1816-3008 - Process image
•
Accelerometers
•
Acceleration measurement
•
Update frequency
•
Angle measurement


EP1816-3008 - Introduction

Product overview [image] EP1816-3008 [image] EP1816-3008 - Introduction
EP1816-3008 - Introduction
EP1816-3008
16 digital inputs 24 VDC, 2 x 3G accelerometers
The EP1816-3008 EtherCAT Box with digital inputs acquires binary control signals from the process level and transfers them, with electrical isolation, to the controller. The signal status is indicated by light emitting diodes; the signal connection is made through a 25-pin Sub-D socket.
In addition the EP1816-3008 has two 3-axis accelerometers.
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Quick links
Installation
UL requirements for UL-approved modules


EP1816-3008 - Technical data

Product overview [image] EP1816-3008 [image] EP1816-3008 - Technical data
EP1816-3008 - Technical data
Technical data | EP1816-3008
Fieldbus | EtherCAT
Fieldbus connection | 2 x M8 socket (green)
Number of inputs | 16
Input connections | 25 pin SUB-D socket
Rated input voltage | 24 VDC (-15%/+20%)
Input filter | 10 µs
Signal voltage "0" | -3...+5 V (EN 61131-2, type 3)
Signal voltage "1" | +11...+30 V (EN 61131-2, type 3)
Input current | typically 3 mA (EN 61131-2, type 3)
Minimum cycle time | > 500 µs
Diagnostics | Undervoltage detection <18 VDC for Us and Up
Supply of the module circuitry | From the control voltage Us
Current consumption of the module circuitry | typically 120 mA
Sensor supply | From the control voltage Us
Current consumption of the sensors | max. 0.5 A, short-circuit-proof overall
Power supply connection | Power supply: 1 x M8 plug, 4-pin Onward connection: 1 x M8 socket, 4-pin
Electrical isolation | Control voltage/fieldbus: yes
Permissible ambient temperature during operation | -25°C ... +60°C 0 °C ... +55 °C (according to cULus, see UL requirements)
Permissible ambient temperature during storage | -40°C ... +85°C
Vibration / shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity / emission | conforms to EN 61000-6-2 / EN 61000-6-4
Protection class | IP65, IP66, IP67 (according to EN 60529)
Installation position | variable
Technical approvals | CE, cULus
Technical data | Accelerometers
Sensor type | Two 3-axis sensors / offset by 90°
Resolution | 16 bit raw data; 1 mg / LSB
Measuring range | ±2g/±4g/±8g/±16g configurable
Special features | Self-test
Sampling rate | 1 Hz to 5 kHz
Note
Maximum transfer rate
The EP1816-3008 reads sensors with sampling rates between 1 Hz and 5 kHz. Since the smallest cycle time is limited to 500 µs due to the internal processing, the resulting maximum transfer rate is 2.5 kHz.


EP1816-3008 - Process image

Product overview [image] EP1816-3008 [image] EP1816-3008 - Process image
EP1816-3008 - Process image
DIG Inputs Channel 1 and 2
EP1816-3008, process image, DIG inputs channels 1 and 2
The 16 digital inputs of the module can be found under DIG Inputs Channel n.
AI Inputs Channel 1 to 6
EP1816-3008 - AI inputs channels 1 to 6
The data for the two accelerometers can be found under AI inputs Channel
▪
Status Error: error relating to the communication with the accelerometer
▪
Value: 16 bit acceleration value
AI Inputs Channel 1 value: sensor 1, axis +X
AI Inputs Channel 2 value: sensor 1, axis +Y
AI Inputs Channel 3 value: sensor 1, axis -Z
AI Inputs Channel 1 value: sensor 2, axis +Y
AI Inputs Channel 2 value: sensor 2, axis -X
AI Inputs Channel 3 value: sensor 2, axis -Z
DIG Inputs Device
EP1816-3008 DIG Inputs Device
16 bit status bit of the module


Accelerometers

Product overview [image] EP1816-3008 [image] Accelerometers
Accelerometers
2 x 3G accelerometers
The EP1816-3008 EtherCAT Box features 2 3-axis accelerometers.
They are fitted on the underside the PCB at 90° angles.
Location of the accelerometers
The image shows a top view and a side view of the EtherCAT Box. It shows the location of the accelerometers within the Box. The green line indicates the location of the PCB. The accelerometers are numbered 1 and 2. They are mounted on the underside of the PCB.
In this position, gravity (which is a form of acceleration), is displayed as a negative value when the Box is in its normal operating position on a flat, level surface, e.g. on a test bench.
Process values | Allocated acceleration value
AI Inputs Channel1 value | Sensor 1, +X axis
AI Inputs Channel2 value | Sensor 1, +Y axis
AI Inputs Channel3 value | Sensor 1, -Z axis
AI Inputs Channel4 value | Sensor 2, +Y axis
AI Inputs Channel5 value | Sensor 2, -X axis
AI Inputs Channel6 value | Sensor 2, -Z axis


Acceleration measurement

Product overview [image] EP1816-3008 [image] Acceleration measurement
Acceleration measurement
Resolution and display
By default the data from the accelerometers, in each case X, Y and Z axis values, are displayed as RAW data, i.e. directly in the form in which they are transferred from the sensors.
CoE object 0x8080:1D
Alternatively, the data can be converted to 1mG / LSB. CoE object 0x8080:1D must be set accordingly.
Setting for output in mG
Example for acceleration value display in TwinCAT ScopeView 2
EP1816-3008, movement of the box in the axes, resulting acceleration values
Color | Meaning
Blue | sensor 1, Z axis
Red | sensor 1, X axis
Green | Sensor 1, Y axis


Update frequency

Product overview [image] EP1816-3008 [image] Update frequency
Update frequency
Update frequency
The update frequency of the sensor data is set via CoE object 0x8080:0D. On delivery this is set to 5 kHz.


Angle measurement

Product overview [image] EP1816-3008 [image] Angle measurement
Angle measurement
The angle relative to gravity can be calculated directly in the EP1816-3008 (CoE 0x8080:1D).
However, the complex trigonometric calculations would have undue impact on the cycle time of the Box, so that in this mode the angle resolution is limited to 1°.
In cases where higher resolution and accuracy is required, the calculations should be executed on a PC. The sensors used are capable of an accuracy of less than 0.1°.
Since the angle values are derived from the acceleration values, which are subject to certain noise, they have to be filtered via suitable algorithms.
In simple cases this could be moving average, for example.
Angle measurement, process data as acceleration values, calculation on a PC
Signal noise in detail
Color | Meaning
Red | Angle measured with 1024-step encoder / 4-way analysis for reference
Green | Angle trigonometrically calculated on a PC, without noise suppression
blue | Fast algorithm
yellow | Arithmetic mean (1000 sliding values)
Direct measurement in the EP1816-3008
For direct measurements CoE object 0x8080:1D Presentation must be set to Horizontal Off-Axis Angle.
Activating direct measurements in the EP1816-3008
The angle is displayed with a resolution of 1 degree. Since the value is still noisy, filtering on the PC is recommended.
red = angle values from EP1816-3008, green = after arithmetic mean calculation on the PC
Reference directions
▪
"Power supply high / EtherCAT connection low" -> negative angle X
▪
"Power supply low / EtherCAT connection high" -> positive angle X
▪
"Box tilted to the left (top to the left)" -> positive angle Y
▪
"Box tilted to the right (top to the right)" -> negative angle Y
Color | Meaning
AI Inputs Channel 1: Input 1 | -180° to +180° relative to X
AI Inputs Channel 2: Input 2 | -180° to +180° relative to Y
AI Inputs Channel 3: Input 3 | 0
AI Inputs Channel 4: Input 4 | -180° to +180° relative to Y
AI Inputs Channel 5: Input 5 | -180° to +180° relative to X
AI Inputs Channel 6: Input 6 | 0
Calculation based on the acceleration values
If the calculation takes place on the PC, the "Presentation" in CoE object 0x8080:1D must be set to Milli-G.
Variable | Meaning
AI Inputs Channel 1 | +X1
AI Inputs Channel 2 | +Y1
AI Inputs Channel 3 | -Z1
AI Inputs Channel 4 | +Y2
AI Inputs Channel 5 | -X2
AI Inputs Channel 6 | -Z2
Winkel X = atan2[sqrt(Z1 * Z1 + Y1 * Y1), |X1)].

IF Z1 < 0
THEN
Winkel X = 90° - Winkel X,
ELSE
Winkel X = Winkel X + 90°.

IF Z1 >0
THEN
Winkel = - Winkel
Sample Program
Attention
Using the sample program
This document contains sample applications of our products for certain areas of application. The application notices provided here are based on typical features of our products and only serve as samples. The notices contained in this document explicitly do not refer to specific applications. The customer is therefore responsible for assessing and deciding whether the product is suitable for a particular application. We accept no responsibility for the completeness and correctness of the source code contained in this document. We reserve the right to modify the content of this document at any time and accept no responsibility for errors and missing information.
To download the sample program from this documentation please click on the following link: ( )


Mounting and cabling

Mounting and cabling
Mounting and cabling
Additional information
•
Mounting
•
EtherCAT
•
Power supply
•
UL Requirements
•
ATEX notes
•
Signal connection
•
Cabling


Mounting

Mounting and cabling [image] Mounting
Mounting
Additional information
•
Dimensions
•
Fixing
•
Nut torque for connectors
•
Additional checks


Dimensions

Mounting and cabling [image] Mounting [image] Dimensions
Dimensions
Dimensions of the EtherCAT Box Modules
All dimensions are given in millimeters.
Housing properties
EtherCAT Box | lean body | wide body
Housing material | PA6 (polyamide)
Casting compound | Polyurethane
Mounting | two fastening holes Ø 3 mm for M3 | two fastening holes Ø 3 mm for M3 two fastening holes Ø 4,5 mm for M4
Metal parts | Brass, nickel-plated
Contacts | CuZn, gold-plated
Power feed through | max. 4 A
Installation position | variable
Protection class | IP65, IP66, IP67 (conforms to EN 60529) when screwed together
Dimensions (H x W x D) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm
Weight | approx. 125 g, depending on module type | approx. 250 g, depending on module type


Fixing

Mounting and cabling [image] Mounting [image] Fixing
Fixing
Note
Note or pointer
While mounting the modules, protect all connectors, especially the IP-Link, against contamination! Only with connected cables or plugs the protection class IP67 is guaranteed! Unused connectors have to be protected with the right plugs! See for plug sets in the catalogue.
Modules with narrow housing are mounted with two M3 bolts.
Modules with wide housing are mounted with two M3 bolts to the fixing holes located at the corners or mounted with two M4 bolts to the fixing holes located centrally.
The bolts must be longer than 15 mm. The fixing holes of the modules are not threaded.
When assembling, remember that the fieldbus connectors increases the overall height. See chapter accessories.
Mounting Rail ZS5300-0001
The mounting rail ZS5300-0001 (500 mm x 129 mm) allows the time saving assembly of modules.
The rail is made of stainless steel, 1.5 mm thick, with already pre-made M3 threads for the modules. The rail has got 5.3 mm slots to mount it via M5 screws to the machine.
Mounting Rail ZS5300-000
The mounting rail is 500 mm long, that way 15 narrow modules can be mounted with a distance of 2 mm between two modules. The rail can be cut to length for the application.
Mounting Rail ZS5300-0011
The mounting rail ZS5300-0011 (500 mm x 129 mm) has in addition to the M3 treads also pre-made M4 treads to fix 60 mm wide modules via their middle holes.
Up to 14 narrow or 7 wide modules may be mixed mounted.


Nut torque for connectors

Mounting and cabling [image] Mounting [image] Nut torque for connectors
Nut torque for connectors
M8 connectors
It is recommended to pull the M8 connectors tight with a nut torque of 0.4 Nm. When using the torque control screwdriver ZB8800 is also a max. torque of 0.5 Nm permissible.
EtherCAT Box with M8 connectors
M12 connectors
It is recommended to pull the M12 connectors tight with a nut torque of 0.6 Nm.
EtherCAT Box with M8 and M12 connectors
7/8" plug connectors
We recommend fastening the 7/8" plug connectors with a torque of 1.5 Nm.
7/8" plug connectors
Torque socket wrenches
ZB8801 torque socket wrench
Note
Ensure the right torque
Use the torque socket wrenches available by Beckhoff to pull the connectors tight (ZB8800, ZB8801-0000)!


Additional checks

Mounting and cabling [image] Mounting [image] Additional checks
Additional checks
The boxes have undergone the following additional tests:
Verification | Explanation
Vibration | 10 frequency runs in 3 axes
 | 5 Hz < f < 60 Hz displacement 0.35 mm, constant amplitude
 | 60.1 Hz < f < 500 Hz acceleration 5 g, constant amplitude
Shocks | 1000 shocks in each direction, in 3 axes
 | 35 g, 11 ms


EtherCAT

Mounting and cabling [image] EtherCAT
EtherCAT
Additional information
•
EtherCAT connection
•
EtherCAT - Fieldbus LEDs


EtherCAT connection

Mounting and cabling [image] EtherCAT [image] EtherCAT connection
EtherCAT connection
For the incoming and ongoing EtherCAT connection,
▪
the EtherCAT Box (EPxxxx) has two M8 sockets, marked in green
▪
the Coupler Box (FBB-x110) has two M12 sockets
EtherCAT Box: M8 (30 mm housing)
EtherCAT Box: M8 60 mm housing (EP9214 for example )
Coupler Box: M12
Assignment
There are various different standards for the assignment and colors of connectors and cables for Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Plug connector |  |  | Cable |  | Standard
Signal | Description | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 and old versions of ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | yellow2 | orange/white3 | white/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | white2 | blue/white3 | white/green
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blue2 | blue3 | green
Shield | Shield | Housing |  | Shroud | Screen | Screen | Screen
1) colored markings according to EN 61918 in the four-pin RJ45 connector ZS1090-0003
2) wire colors according to EN 61918
3) wire colors
Note
Assimilation of color coding for cable ZB9030, ZB9032 and ZK1090-3xxxx-xxxx (with M8 connectors)
For unification the prevalent cables ZB9030, ZB9032 and ZK1090-3xxx-xxxx this means the pre assembled cables with M8 connectors were changed to the colors of EN61918 (yellow, orange, white, blue).So different color coding exists. But the electrical properties are absolutely identical.
EtherCAT connectors
The following connectors can be supplied for use in Beckhoff EtherCAT systems.
Designation | Plug connector | Comment
ZS1090-0003 | RJ45 | four-pin, IP20, for field assembly
ZS1090-0004 | M12 | four-pin, IP67, for field assembly
ZS1090-0005 | RJ45 | eight-pin, IP20, for field assembly, suitable for GigaBit Ethernet
ZS1090-0006 | M8 male | four-pin, IP67, for field assembly, for ZB903x cable
ZS1090-0007 | M8 female | four-pin, IP67, for field assembly, for ZB903x cable
ZS1090-1006 | M8 male | four-pin, IP67, for field assembly up to OD = 6.5 mm
ZS1090-1007 | M8 female | four-pin, IP67, for field assembly up to OD = 6.5 mm


EtherCAT - Fieldbus LEDs

Mounting and cabling [image] EtherCAT [image] EtherCAT - Fieldbus LEDs
EtherCAT - Fieldbus LEDs
EtherCAT-LEDs
LED display
LED | Display | Meaning
IN L/A | off | no connection to the preceding EtherCAT module
 | Lit | LINK: connection to the preceding EtherCAT module
 | flashing | ACT: Communication with the preceding EtherCAT module
OUT L/A | off | no connection to the following EtherCAT module
 | Lit | LINK: connection to the following EtherCAT module
 | flashing | ACT: Communication with the following EtherCAT module
Run | off | Status of the EtherCAT module is Init
 | flashes quickly | Status of the EtherCAT module is pre-operational
 | flashes slowly | Status of the EtherCAT module is safe-operational
 | Lit | Status of the EtherCAT module is operational
Note
EtherCAT statuses
The various statuses in which an EtherCAT module may be found are described in the Basic System Documentation for EtherCAT, which is available for download from our website ( ) under Downloads.


Power supply

Mounting and cabling [image] Power supply
Power supply
Additional information
•
Power Connection
•
Status LEDs for power supply
•
Power cable conductor losses M8


Power Connection

Mounting and cabling [image] Power supply [image] Power Connection
Power Connection
The feeding and forwarding of supply voltages is done via two M8 connectors at the bottom end of the modules:
▪
IN: left M8 connector for feeding the supply voltages
▪
OUT: right M8 connector for forwarding the supply voltages
EtherCAT Box, Connectors for power supply
Pin assignment M8, Power In and Power Out
PIN assignment
Pin | Voltage
1 | Control voltage Us, +24 VDC
2 | Auxiliary voltage Up, +24 VDC
3 | GNDs* | *) may be connected internally to each other depending on the module: see specific module descriptions
4 | GNDp*
The pins M8 connectors carry a maximum current of 4 A.
Two LEDs display the status of the supply voltages.
Attention
Don't confuse the power connectors with the EtherCAT connectors!
Never connect the power cables (M8, 24 VDC) with the green marked EtherCAT sockets of the EtherCAT Box Modules! This can damage the modules!
Control voltage Us: 24 VDC
Power is supplied to the fieldbus, the processor logic, the inputs and the sensors from the 24 VDC control voltage Us. The control voltage is electrically isolated from the fieldbus circuitry.
Auxiliary voltage Up 24 VDC
The Auxiliary voltage Up supplies the digital outputs; it can be brought in separately. If the load voltage is switched off, the fieldbus functions and the power supply and functionality of the inputs are retained.
Redirection of the supply voltages
The IN and OUT power connections are bridged in the module (not IP204x-Bxxx and IE204x). The supply voltages Us and Up can thus easily be transferred from EtherCAT Box to EtherCAT Box.
Attention
Pay attention to the maximum permissible current!
Pay attention also for the redirection of the supply voltages Us and Up, the maximum permissible current for M8 connectors of 4 A must not be exceeded!
Supply via EP92x4-0023 PowerBox modules
If the machine requires higher current or if the EtherCAT Box Modules are installed far away from the control cabinet with included power supply, the usage of four cannel power distribution modules EP9214 or EP9224 (with integrated data logging, see www.beckhoff.com/EP9224) is recommended.
With these modules intelligent power distribution concepts with up to 2 x 16 A and a maximum of 2.5 mm² cable cross-section can be realized.
EP92x4-0023, Connectors for Power In and Power Out
Pin assignment 7/8”, Power In and Power Out
Electrical isolation
Digital modules
In the digital input/output modules, the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are connected to each other!
Check this at the documentation of each used EtherCAT Box.
Analog modules
In the analog input/output modules the grounds of the control voltage (GNDs) and the auxiliary voltage (GNDp) are separated from each other in order to ensure electrical isolation of the analog signals from the control voltage.
In some of the analog modules the sensors or actuators are supplied by Up - this means, for instance, that in the case of 0...10 V inputs, any reference voltage (0...30 V) may be connected to Up; this is then available to the sensors (e.g. smoothed 10 V for measuring potentiometers).
Details of the power supply may be taken from the specific module descriptions.
Attention
Electrical isolation may be cancelled!
If digital and analog fieldbus boxes are connected directly via four-core power leads, the analog signals in the fieldbus boxes may be no longer electrically isolated from the control voltage!


Status LEDs for power supply

Mounting and cabling [image] Power supply [image] Status LEDs for power supply
Status LEDs for power supply
Status LEDs for power supply
LED display
LED | Display | Meaning
Us (Control voltage) | off | The power supply voltage Us is not present
 | green illuminated | The power supply voltage Us is present
 | red illuminated | Because of overload (current > 0.5 A) the sensor supply generated from power supply voltage Us was switched off for all sensors fed from this.
Up (Auxiliary voltage) | off | The power supply voltage Up is not present
 | green illuminated | The power supply voltage Up is present


Power cable conductor losses M8

Mounting and cabling [image] Power supply [image] Power cable conductor losses M8
Power cable conductor losses M8
The ZK2020-xxxx-yyyy power cables should not exceed the total length of 15 m at 4 A (with continuation). When planning the cabling, note that at 24 V nominal voltage, the functionality of the module can no longer be assured if the voltage drop reaches 6 V. Variations in the output voltage from the power supply unit must also be taken into account.
Power cable conductor losses
Example
8 m power cable with 0.34 mm² cross-section has a voltage drop of 3.2 V at 4 A.
Note
EP92x4 Power Distribution Modules
With EP9214 and EP9224 Power Distribution Modules intelligent concepts for voltage supply are available. Further information may be found under www.beckhoff.com/EP9224.


UL Requirements

Mounting and cabling [image] UL Requirements
UL Requirements
The installation of the EtherCAT Box Modules certified by UL has to meet the following requirements.
Supply voltage
CAUTION
CAUTION!
This UL requirements are valid for all supply voltages of all marked EtherCAT Box Modules!
For the compliance of the UL requirements the EtherCAT Box Modules should only be supplied
•
by a 24 VDC supply voltage, supplied by an isolating source and protected by means of a fuse (in accordance with UL248), rated maximum 4 Amp, or
•
by a 24 VDC power source, that has to satisfy NEC class 2.
A NEC class 2 power supply shall not be connected in series or parallel with another (class 2) power source!
CAUTION
CAUTION!
To meet the UL requirements, the EtherCAT Box Modules must not be connected to unlimited power sources!
Networks
CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules must not be connected to telecommunication networks!
Ambient temperature range
CAUTION
CAUTION!
To meet the UL requirements, EtherCAT Box Modules has to be operated only at an ambient temperature range of 0 to 55°C!
Marking for UL
All EtherCAT Box Modules certified by UL (Underwriters Laboratories) are marked with the following label.
UL label


ATEX notes

Mounting and cabling [image] ATEX notes
ATEX notes
Additional information
•
ATEX - Special conditions
•
BG2000-0000 - EtherCAT Box protection enclosure
•
ATEX Documentation


ATEX - Special conditions

Mounting and cabling [image] ATEX notes [image] ATEX - Special conditions
ATEX - Special conditions
WARNING
Observe the special conditions for the intended use of EtherCAT Box modules in potentially explosive areas – directive 94/9/EU.
•
The certified components are to be installed in the BG2000-0000 protection enclosure that guarantees a protection against mechanical hazards!
•
If the temperatures during rated operation are higher than 70°C at the feed-in points of cables, lines or pipes, or higher than 80°C at the wire branching points, then cables must be selected whose temperature data correspond to the actual measured temperature values!
•
Observethe permissible ambient temperature range of 0 - 55°C for the use of EtherCAT Box modules in potentially explosive areas!
•
Measures must be taken to protect against the rated operating voltage being exceeded by more than 40% due to short-term interference voltages!
•
The connections of the certified components may only be connected or disconnected if the supply voltage has been switched off or if a non-explosive atmosphere is ensured!
Standards
The fundamental health and safety requirements are fulfilled by compliance with the following standards:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Marking
The EtherCAT Box modules certified for potentially explosive areas bear the following marking:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
or
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch number (D number)
The EtherCAT Box modules bear a batch number (D number) that is structured as follows:
D: WW YY FF HH
WW - week of production (calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - week of production 29
10 - year of production 2010
02 - firmware version 02
01 - hardware version 01


BG2000-0000 - EtherCAT Box protection enclosure

Mounting and cabling [image] ATEX notes [image] BG2000-0000 - EtherCAT Box protection enclosure
BG2000-0000 - EtherCAT Box protection enclosure
WARNING
Risk of electric shock and damage of device!
Bring the EtherCAT system into a safe, powered down state before starting installation, disassembly or wiring of the modules!
ATEX
The BG2000-0000 protection enclosure has to be mounted over a single EtherCAT Box to fulfill the special conditions according to ATEX.
Installation
Put the cables for EtherCAT, power supply and sensors/actuators through the hole of the BG2000-0000 protection enclosure.
BG2000-0000, putting the cables
Fix the wires for EtherCAT, power supply and sensors/actuators to the EtherCAT Box.
BG2000-0000, fixing the cables
Mount the BG2000-0000 protection enclosure over the EtherCAT Box.
BG2000-0000, mounting the protection enclosure


ATEX Documentation

Mounting and cabling [image] ATEX notes [image] ATEX Documentation
ATEX Documentation
Note
Notes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX)
Pay also attention to the continuative documentationNotes about operation of EtherCAT Box Modules (EPxxxx-xxxx) in potentially explosive areas (ATEX) that is available in the download area of the Beckhoff homepage http:\\www.beckhoff.com!


Signal connection

Mounting and cabling [image] Signal connection
Signal connection
Additional information
•
Digital inputs M8 and M12
•
Digital inputs Sub-D25
•
EP1816-3008 - Signal connection


Digital inputs M8 and M12

Mounting and cabling [image] Signal connection [image] Digital inputs M8 and M12
Digital inputs M8 and M12
The digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit.
The signals are optionally connected via screw-in M8 connectors (EP1xxx-0001) or screw-in M12 connectors (EP1xxx-0002).
Digital inputs M8 and M12
The sensors are supplied from the control voltage Us with a maximum current of 0.5 A.
The state of the signals is indicated by light emitting diodes.


Digital inputs Sub-D25

Mounting and cabling [image] Signal connection [image] Digital inputs Sub-D25
Digital inputs Sub-D25
Digital inputs Sub-D25
The EP1xxx digital input modules acquire the binary control signals from the process level and transmit them to the higher-level automation unit.
The signal connection is made through a 25-pin sub-D socket.
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
Digital inputs Sub-D25, 16 channels


EP1816-3008 - Signal connection

Mounting and cabling [image] Signal connection [image] EP1816-3008 - Signal connection
EP1816-3008 - Signal connection
Digital inputs/outputs, 24 VDC: 25 pin SUB-D socket
The digital input modules EP100x acquire the binary control signals from the process level and transmit them to the higher-level automation device.
The signal connection is made through a 25-pin sub-D socket.
The sensors are supplied from the control voltage Us. The load voltage Up is not used in the input module, but may be connected in order to be relayed downstream.
EP1816-3008
Digital inputs Sub-D 25
Attention
Please note the special pin assignment of the EP1816-3008.
The pin assignment of the EP1816-3008 differs from the EP1816-0008!
The supply voltage and GND connections differ, which means that incorrect connection could damage the end devices, if these are not short-circuit-proof.


Cabling

Mounting and cabling [image] Cabling
Cabling
A list of EtherCAT cables, power cables, sensor cables, Ethernet/EtherCAT connectors and field-configurable connectors can be found under the following link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
The corresponding data sheets can be found under the following link:
https://beckhoff.de/default.asp?ethercat-box/ethercat_box_cables.htm?id=690338951657421
EtherCAT cables
ZK1090-3131-0xxx
For connecting EtherCAT devices, only use shielded Ethernet cables with a minimum specification of category 5 (CAT5) according to EN 50173 or ISO/IEC 11801.
Note
Wiring recommendations
Detailed recommendations for EtherCAT cabling can be found in the documentation "Design recommendations for EtherCAT/Ethernet infrastructure", which is available for download from www.beckhoff.de.
EtherCAT uses four cable wires for signal transmission.
Due to automatic cable detection (auto-crossing) symmetric (1:1) or cross-over cables can be used between EtherCAT devices from Beckhoff.
Power cable
ZK2020-3132-0xxx
Sensor cables
Sensorkabel - Beckhoff.png
Selection of Beckhoff sensor cables


Commissioning/Configuration

Commissioning/Configuration
Commissioning/Configuration
Additional information
•
Inserting into the EtherCAT network
•
Configuration via TwinCAT
•
EP1816-0008 - Object Overview
•
EP1816-0008 - Object description and parameterization
•
EP1816-3008 - Object overview
•
EP1816-3008 - Object description and parameterization
•
Restoring the delivery state
•
Firmware Update EL/ES/EM/EPxxxx


Inserting into the EtherCAT network

Commissioning/Configuration [image] Inserting into the EtherCAT network
Inserting into the EtherCAT network
Note
Installation of the latest XML device description
Please ensure that you have installed the latest XML device description in TwinCAT. This can be downloaded from the Beckhoff website (http://www.beckhoff.de/english/download/elconfg.htm?id=1983920606140) and installed according to the installation instructions.
At the Beckhoff TwinCAT System Manager the configuration tree can be build in two different ways:
▪
by scanning for existing hardware (called "online") and
▪
by manual inserting/appending of fieldbus devices, couplers and slaves.
Automatic scanning in of the box
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode), and scan in the devices (see Fig. 1). Acknowledge all dialogs with "OK", so that the configuration is in "FreeRun" mode.
Scanning in the configuration (I/O Devices -> right-click -> Scan Devices...)
Appending a module manually
▪
The EtherCAT system must be in a safe, de-energized state before the EtherCAT modules are connected to the EtherCAT network!
▪
Switch on the operating voltage, open the TwinCAT System Manager (Config mode)
▪
Append a new I/O device. In the dialog that appears select the device EtherCAT (Direct Mode), and confirm with OK.
Appending a new I/O device (I/O Devices -> right-click -> Append Device...)
Selecting the device EtherCAT
▪
Append a new box.
Appending a new box (Device -> right-click -> Append Box...)
▪
In the dialog that appears select the desired box (e.g. EP2816-0008), and confirm with OK.
Selecting a Box (e.g. EP2816-0008)
Appended Box in the TwinCAT tree


Configuration via TwinCAT

Commissioning/Configuration [image] Configuration via TwinCAT
Configuration via TwinCAT
In the left-hand window of the TwinCAT System Manager, click on the branch of the EtherCAT Box you wish to configure (EP2816-0008 in this example).
Branch of the EtherCAT box to be configured
In the right-hand window of the TwinCAT System manager, various tabs are now available for configuring the EtherCAT Box.
General tab
General tab
Name | Name of the EtherCAT device
Id | Number of the EtherCAT device
Type | EtherCAT device type
Comment | Here you can add a comment (e.g. regarding the system).
Disabled | Here you can deactivate the EtherCAT device.
Create symbols | Access to this EtherCAT slave via ADS is only available if this control box is activated.
EtherCAT tab
EtherCAT tab
Type | EtherCAT device type
Product/Revision | Product and revision number of the EtherCAT device
Auto Inc Addr. | Auto increment address of the EtherCAT device. The auto increment address can be used for addressing each EtherCAT device in the communication ring through its physical position. Auto increment addressing is used during the start-up phase when the EtherCAT master allocates addresses to the EtherCAT devices. With auto increment addressing the first EtherCAT slave in the ring has the address 0000hex. For each further slave the address is decremented by 1 (FFFFhex, FFFEhex etc.).
EtherCAT Addr. | Fixed address of an EtherCAT slave. This address is allocated by the EtherCAT master during the start-up phase. Tick the control box to the left of the input field in order to modify the default value.
Previous Port | Name and port of the EtherCAT device to which this device is connected. If it is possible to connect this device with another one without changing the order of the EtherCAT devices in the communication ring, then this combination field is activated and the EtherCAT device to which this device is to be connected can be selected.
Advanced Settings | This button opens the dialogs for advanced settings.
The link at the bottom of the tab points to the product page for this EtherCAT device on the web.
Process Data tab
Indicates the configuration of the process data. The input and output data of the EtherCAT slave are represented as CANopen process data objects (PDO). The user can select a PDO via PDO assignment and modify the content of the individual PDO via this dialog, if the EtherCAT slave supports this function.
Process Data tab
Sync Manager
Lists the configuration of the Sync Manager (SM).
If the EtherCAT device has a mailbox, SM0 is used for the mailbox output (MbxOut) and SM1 for the mailbox input (MbxIn).
SM2 is used for the output process data (outputs) and SM3 (inputs) for the input process data.
If an input is selected, the corresponding PDO assignment is displayed in the PDO Assignment list below.
PDO Assignment
PDO assignment of the selected Sync Manager. All PDOs defined for this Sync Manager type are listed here:
▪
If the output Sync Manager (outputs) is selected in the Sync Manager list, all RxPDOs are displayed.
▪
If the input Sync Manager (inputs) is selected in the Sync Manager list, all TxPDOs are displayed.
The selected entries are the PDOs involved in the process data transfer. In the tree diagram of the System Manager these PDOs are displayed as variables of the EtherCAT device. The name of the variable is identical to the Name parameter of the PDO, as displayed in the PDO list. If an entry in the PDO assignment list is deactivated (not selected and greyed out), this indicates that the input is excluded from the PDO assignment. In order to be able do select a greyed out PDO, the currently selected PDO has to be deselected first.
Note
Activation of PDO assignment
•
the EtherCAT slave has to run through the PS status transition cycle (from pre-operational to safe-operational) once (see Online tab),
•
and the System Manager has to reload the EtherCAT slaves ( [image] button)
PDO list
List of all PDOs supported by this EtherCAT device. The content of the selected PDOs is displayed in the PDO Content list. The PDO configuration can be modified by double-clicking on an entry.
Column | Description
Index | PDO index.
Size | Size of the PDO in bytes.
Name | Name of the PDO. If this PDO is assigned to a Sync Manager, it appears as a variable of the slave with this parameter as the name.
Flags | F | Fixed content: The content of this PDO is fixed and cannot be changed by the System Manager.
 | M | Mandatory PDO. This PDO is mandatory and must therefore be assigned to a Sync Manager! Consequently, this PDO cannot be deleted from the PDO Assignment list
SM | Sync Manager to which this PDO is assigned. If this entry is empty, this PDO does not take part in the process data traffic.
SU | Sync unit to which this PDO is assigned.
PDO Content
Indicates the content of the PDO. If flag F (fixed content) of the PDO is not set the content can be modified.
Download
If the device is intelligent and has a mailbox, the configuration of the PDO and the PDO assignments can be downloaded to the device. This is an optional feature that is not supported by all EtherCAT slaves.
PDO Assignment
If this check box is selected, the PDO assignment that is configured in the PDO Assignment list is downloaded to the device on startup. The required commands to be sent to the device can be viewed in the Startup tab.
PDO Configuration
If this check box is selected, the configuration of the respective PDOs (as shown in the PDO list and the PDO Content display) is downloaded to the EtherCAT slave.
Startup tab
The Startup tab is displayed if the EtherCAT slave has a mailbox and supports the CANopen over EtherCAT (CoE) or Servo drive over EtherCAT protocol. This tab indicates which download requests are sent to the mailbox during startup. It is also possible to add new mailbox requests to the list display. The download requests are sent to the slave in the same order as they are shown in the list.
Startup tab
Column
Description
Transition
Transition to which the request is sent. This can either be
▪
the transition from pre-operational to safe-operational (PS), or
▪
the transition from safe-operational to operational (SO).
If the transition is enclosed in "<>" (e.g. <PS>), the mailbox request is fixed and cannot be modified or deleted by the user.
Protocol
Type of mailbox protocol
Index
Index of the object
Data
Date on which this object is to be downloaded.
Comment
Description of the request to be sent to the mailbox
Move Up | This button moves the selected request up by one position in the list.
Move Down | This button moves the selected request down by one position in the list.
New | This button adds a new mailbox download request to be sent during startup.
Delete | This button deletes the selected entry.
Edit | This button edits an existing request.
CoE - Online tab
The additional CoE - Online tab is displayed if the EtherCAT slave supports the CANopen over EtherCAT (CoE) protocol. This dialog lists the content of the object list of the slave (SDO upload) and enables the user to modify the content of an object from this list. Details for the objects of the individual EtherCAT devices can be found in the device-specific object descriptions.
CoE - Online tab
Object list display
Column | Description
Index | Index and sub-index of the object
Name | Name of the object
Flags | RW | The object can be read, and data can be written to the object (read/write)
 | RO | The object can be read, but no data can be written to the object (read only)
 | P | An additional P identifies the object as a process data object.
Value | Value of the object
Update List | The Update list button updates all objects in the displayed list
Auto Update | If this check box is selected, the content of the objects is updated automatically.
Advanced | The Advanced button opens the Advanced Settings dialog. Here you can specify which objects are displayed in the list.
Advanced Settings
Online - via SDO Information | If this option button is selected, the list of the objects included in the object list of the slave is uploaded from the slave via SDO information. The list below can be used to specify which object types are to be uploaded.
Offline - via EDS File | If this option button is selected, the list of the objects included in the object list is read from an EDS file provided by the user.
Online tab
Online tab
State Machine
Init | This button attempts to set the EtherCAT device to the Init state.
Pre-Op | This button attempts to set the EtherCAT device to the pre-operational state.
Op | This button attempts to set the EtherCAT device to the operational state.
Bootstrap | This button attempts to set the EtherCAT device to the Bootstrap state.
Safe-Op | This button attempts to set the EtherCAT device to the safe-operational state.
Clear Error | This button attempts to delete the fault display. If an EtherCAT slave fails during change of state it sets an error flag. Example: An EtherCAT slave is in PREOP state (pre-operational). The master now requests the SAFEOP state (safe-operational). If the slave fails during change of state it sets the error flag. The current state is now displayed as ERR PREOP. When the Clear Error button is pressed the error flag is cleared, and the current state is displayed as PREOP again.
Current State | Indicates the current state of the EtherCAT device.
Requested State | Indicates the state requested for the EtherCAT device.
DLL Status
Indicates the DLL status (data link layer status) of the individual ports of the EtherCAT slave. The DLL status can have four different states:
Status | Description
No Carrier / Open | No carrier signal is available at the port, but the port is open.
No Carrier / Closed | No carrier signal is available at the port, and the port is closed.
Carrier / Open | A carrier signal is available at the port, and the port is open.
Carrier / Closed | A carrier signal is available at the port, but the port is closed.
File Access over EtherCAT
Download | With this button a file can be written to the EtherCAT device.
Upload | With this button a file can be read from the EtherCAT device.


EP1816-0008 - Object Overview

Commissioning/Configuration [image] EP1816-0008 - Object Overview
EP1816-0008 - Object Overview
Note
EtherCAT XML Device Description
The description corresponds to the display of the CoE objects from the EtherCAT XML Device Description. It is strongly recommended to download the latest revision of the corresponding XML file from the Beckhoff website (http://www.beckhoff.com/english/default.htm?download/elconfg.htm) and follow the installation instructions.
Index |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x01181389 (18355081dec)
1008 |  | Device name | RO | EP1816-0008
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01
1011:0 | SubIndex | Restore default parameters | RO | 0x01 (1dec)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | SubIndex | Identity | RO | 0x04 (4dec)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 1018:02 | Product code | RO | 0x07184052 (119029842dec)
 | 1018:03 | Revision | RO | 0x00100008 (1048584dec)
 | 1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | SubIndex | Backup parameter handling | RO | 0x01 (1dec)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | SubIndex | DO TxPDO-Map Inputs Ch.1 | RO | 0x0B (11dec)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A00:09 | SubIndex 009 | RO | 0x0000:00, 5
 | 1A00:0A | SubIndex 010 | RO | 0x1C32:20, 1
 | 1A00:0B | SubIndex 011 | RO | 0x0000:00, 2
1A01:0 | SubIndex | DO TxPDO-Map Inputs Ch.2 | RO | 0x0B (11dec)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:08, 1
 | 1A01:09 | SubIndex 009 | RO | 0x0000:00, 5
 | 1A01:0A | SubIndex 010 | RO | 0x1C32:20, 1
 | 1A01:0B | SubIndex 011 | RO | 0x0000:00, 2
1C00:0 | SubIndex | Sync manager type | RO | 0x04 (4dec)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | SubIndex | RxPDO assign | RO | 0x00 (0dec)
1C13:0 | SubIndex | TxPDO assign | RO | 0x02 (2dec)
 | 1C13:01 | SubIndex 001 | RO | 0x1A00 (6656dec)
 | 1C13:02 | SubIndex 002 | RO | 0x1A01 (6657dec)
Index |  | Name | Flags | Default value
1C33:0 | SubIndex | SM input parameter | RO | 0x20 (32dec)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 1C33:02 | Cycle time | RW | 0x000186A0 (100000dec)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 1C33:05 | Minimum cycle time | RO | 0x000124F8 (75000dec)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 1C33:08 | Command | RW | 0x0000 (0dec)
 | 1C33:09 | Delay time | RO | 0x00000000 (0dec)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | SubIndex | DO Inputs Ch.1 | RO | 0x0E (14dec)
 | 6000:01 | Input 1 | RO | 0x00 (0dec)
 | 6000:02 | Input 2 | RO | 0x00 (0dec)
 | 6000:03 | Input 3 | RO | 0x00 (0dec)
 | 6000:04 | Input 4 | RO | 0x00 (0dec)
 | 6000:05 | Input 5 | RO | 0x00 (0dec)
 | 6000:06 | Input 6 | RO | 0x00 (0dec)
 | 6000:07 | Input 7 | RO | 0x00 (0dec)
 | 6000:08 | Input 8 | RO | 0x00 (0dec)
 | 6000:0E | Sync Error | RO | 0x00 (0dec)
6010:0 | SubIndex | DO Inputs Ch.2 | RO | 0x0E (14dec)
 | 6010:01 | Input 1 | RO | 0x00 (0dec)
 | 6010:02 | Input 2 | RO | 0x00 (0dec)
 | 6010:03 | Input 3 | RO | 0x00 (0dec)
 | 6010:04 | Input 4 | RO | 0x00 (0dec)
 | 6010:05 | Input 5 | RO | 0x00 (0dec)
 | 6010:06 | Input 6 | RO | 0x00 (0dec)
 | 6010:07 | Input 7 | RO | 0x00 (0dec)
 | 6010:08 | Input 8 | RO | 0x00 (0dec)
 | 6010:0E | Sync Error | RO | 0x00 (0dec)
F000:0 | SubIndex | Modular device profile | RO | 0x02 (2dec)
 | F000:01 | Module index distance | RO | 0x0010 (16dec)
 | F000:02 | Maximum number of modules | RO | 0x0002 (2dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | SubIndex | Module list | RW | 0x02 (2dec)
 | F010:01 | SubIndex 001 | RW | 0x00000118 (280dec)
 | F010:02 | SubIndex 002 | RW | 0x00000118 (280dec)
Key
Flags:
RO = Read Only
RW = Read/Write


EP1816-0008 - Object description and parameterization

Commissioning/Configuration [image] EP1816-0008 - Object description and parameterization
EP1816-0008 - Object description and parameterization
Note
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Note
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website (http://beckhoff.de/german/download/elconfg.htm?id=1983920606140) and installing it according to the installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects intended for regular operation, e.g. through ADS access
▪
Objects for indicating internal settings (may be fixed)
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 1011 Restore default parameters
Index | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters | Restore default parameters | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 | If this object is set to 0x64616F6C in the set value dialog, all backup objects are reset to their delivery state. | UINT32 | RW | 0x00000000 (0dec)
Objects for regular operation
The EP1816 has no such objects.
Additional objects
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000 Device type
Index | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x01181389 (18355081dec)
Index 1008 Device name
Index | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | string | RO | EP1816-0008
Index 1009 Hardware version
Index | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | string | RO | 00
Index 100A Software version
Index | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | string | RO | 01
Index 1018 Identity
Index | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x07184052 (119029842dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00100008 (1048584dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling | Information for standardized loading and saving of backup entries | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum | Checksum across all backup entries of the EtherCAT slave | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 DO TxPDO-Map Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
1A00:0 | DO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0B (11dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DO Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1C32:20, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A01 DO TxPDO-Map Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
1A01:0 | DO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0B (11dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DO Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1C32, entry 0x20) | UINT32 | RO | 0x1C32:20, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1C00 Sync manager type
Index | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A01 (6657dec)
Index 1C33 SM input parameter
Index
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
Cycle time (in ns):
▪
Synchron with SM 2 Event: Master cycle time
▪
DC mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000186A0 (100000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 1C32:08 )
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
Minimum cycle time (in ns)
UINT32
RO
0x000124F8 (75000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
▪
0: Measurement of the local cycle time is stopped
▪
1: Measurement of the local cycle time is started
The entries 1C33:03, 1C33:06, 1C33:07, 1C33:09 are updated with the maximum measured values.
For a subsequent measurement the measured values are reset
UINT16
RW
0x0000 (0dec)
1C33:09
Delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
Number of missed SM events in OPERATIONAL (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
Number of occasions the cycle time was exceeded in OPERATIONAL (cycle was not completed in time or the next cycle began too early)
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
Number of occasions that the interval between SYNC0 and SYNC1 event was too short (DC mode only)
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
The synchronization was not correct in the last cycle (outputs were output too late; DC mode only)
boolean
RO
0x00 (0dec)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 DO Inputs Ch.1
Index | Name | Meaning | Data type | Flags | Default
6000:0 | DO Inputs Ch.1 |  | UINT8 | RO | 0x0E (14dec)
6000:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6000:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6000:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6000:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6000:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6000:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6000:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6000:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6000:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index 6010 DO Inputs Ch.2
Index | Name | Meaning | Data type | Flags | Default
6010:0 | DO Inputs Ch.2 |  | UINT8 | RO | 0x0E (14dec)
6010:01 | Input 1 |  | boolean | RO | 0x00 (0dec)
6010:02 | Input 2 |  | boolean | RO | 0x00 (0dec)
6010:03 | Input 3 |  | boolean | RO | 0x00 (0dec)
6010:04 | Input 4 |  | boolean | RO | 0x00 (0dec)
6010:05 | Input 5 |  | boolean | RO | 0x00 (0dec)
6010:06 | Input 6 |  | boolean | RO | 0x00 (0dec)
6010:07 | Input 7 |  | boolean | RO | 0x00 (0dec)
6010:08 | Input 8 |  | boolean | RO | 0x00 (0dec)
6010:0E | Sync Error |  | boolean | RO | 0x00 (0dec)
Index F000 Modular device profile
Index | Name | Meaning | Data type | Flags | Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Index distance of the objects of the individual channels | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules | Number of channels | UINT16 | RO | 0x0002 (2dec)
Index F008 Code word
Index | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x02 (2dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)


EP1816-3008 - Object overview

Commissioning/Configuration [image] EP1816-3008 - Object overview
EP1816-3008 - Object overview
Note
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area on the Beckhoff website (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) and installing it according to the installation instructions.
Index (hex) |  | Name | Flags | Default value
1000 |  | Device type | RO | 0x00001389 (5001dec)
1008 |  | Device name | RO | EP1816-3008
1009 |  | Hardware version | RO |
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dec)
 | 0x1011:01 | SubIndex 001 | RW | 0x00000000 (0dec)
1018:0 | Subindex | Identity | RO | 0x04 (4dec)
 | 0x1018:01 | Vendor ID | RO | 0x00000002 (2dec)
 | 0x1018:02 | Product code | RO | 0x05E44052 (98844754dec)
 | 01018:03 | Revision | RO | 0x00000000 (0dec)
 | 0x1018:04 | Serial number | RO | 0x00000000 (0dec)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dec)
 | 0x10F0:01 | Checksum | RO | 0x00000000 (0dec)
1A00:0 | Subindex | DIG TxPDO-Map Inputs Ch.1 | RO | 0x09 (9dec)
 | 0x1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 0x1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 0x1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 0x1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 0x1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 0x1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 0x1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 0x1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 0x1A00:09 | SubIndex 009 | RO | 0x0000:00, 8
1A01:0 | Subindex | DIG TxPDO-Map Inputs Ch.2 | RO | 0x09 (9dec)
 | 0x1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 0x1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 0x1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 0x1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 0x1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 0x1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 0x1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 0x1A01:08 | SubIndex 008 | RO | 0x6010:08, 1
 | 0x1A01:09 | SubIndex 009 | RO | 0x0000:00, 8
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x05 (5dec)
 | 0x1A02:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A02:02 | SubIndex 002 | RO | 0x6020:07, 1
 | 0x1A02:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A02:04 | SubIndex 004 | RO | 0x6020:10, 1
 | 0x1A02:05 | SubIndex 005 | RO | 0x6020:11, 16
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x05 (5dec)
 | 0x1A03:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A03:02 | SubIndex 002 | RO | 0x6030:07, 1
 | 0x1A03:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A03:04 | SubIndex 004 | RO | 0x6030:10, 1
 | 0x1A03:05 | SubIndex 005 | RO | 0x6030:11, 16
Index (hex) |  | Name | Flags | Default value
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x05 (5dec)
 | 0x1A04:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A04:02 | SubIndex 002 | RO | 0x6040:07, 1
 | 0x1A04:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A04:04 | SubIndex 004 | RO | 0x6040:10, 1
 | 0x1A04:05 | SubIndex 005 | RO | 0x6040:11, 16
1A05:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x05 (5dec)
 | 0x1A05:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A05:02 | SubIndex 002 | RO | 0x6050:07, 1
 | 0x1A05:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A05:04 | SubIndex 004 | RO | 0x6050:10, 1
 | 0x1A05:05 | SubIndex 005 | RO | 0x6050:11, 16
1A06:0 | Subindex | AI TxPDO-Map Inputs Ch.5 | RO | 0x05 (5dec)
 | 0x1A06:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A06:02 | SubIndex 002 | RO | 0x6060:07, 1
 | 0x1A06:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A06:04 | SubIndex 004 | RO | 0x6060:10, 1
 | 0x1A06:05 | SubIndex 005 | RO | 0x6060:11, 16
1A07:0 | Subindex | AI TxPDO-Map Inputs Ch.6 | RO | 0x05 (5dec)
 | 0x1A07:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 0x1A07:02 | SubIndex 002 | RO | 0x6070:07, 1
 | 0x1A07:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 0x1A07:04 | SubIndex 004 | RO | 0x6070:10, 1
 | 0x1A07:05 | SubIndex 005 | RO | 0x6070:11, 16
1A08:0 | Subindex | DIG TxPDO-Map Inputs Device | RO | 0x04 (4dec)
 | 0x1A08:01 | SubIndex 001 | RO | 0xF600:01, 1
 | 0x1A08:02 | SubIndex 002 | RO | 0xF600:02, 1
 | 0x1A08:03 | SubIndex 003 | RO | 0x0000:00, 13
 | 0x1A08:04 | SubIndex 004 | RO | 0xF600:10, 1
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dec)
 | 0x1C00:01 | SubIndex 001 | RO | 0x01 (1dec)
 | 0x1C00:02 | SubIndex 002 | RO | 0x02 (2dec)
 | 0x1C00:03 | SubIndex 003 | RO | 0x03 (3dec)
 | 0x1C00:04 | SubIndex 004 | RO | 0x04 (4dec)
1C12:0 | Subindex | RxPDO assign | RO | 0x00 (0dec)
1C13:0 | Subindex | TxPDO assign | RO | 0x09 (9dec)
 | 0x1C13:01 | SubIndex 001 | RO | 0x1A00 (6656dec)
 | 0x1C13:02 | SubIndex 002 | RO | 0x1A01 (6657dec)
 | 0x1C13:03 | SubIndex 003 | RO | 0x1A02 (6658dec)
 | 0x1C13:04 | SubIndex 004 | RO | 0x1A03 (6659dec)
 | 0x1C13:05 | SubIndex 005 | RO | 0x1A04 (6660dec)
 | 0x1C13:06 | SubIndex 006 | RO | 0x1A05 (6661dec)
 | 0x1C13:07 | SubIndex 007 | RO | 0x1A06 (6662dec)
 | 0x1C13:08 | SubIndex 008 | RO | 0x1A07 (6663dec)
 | 0x1C13:09 | SubIndex 009 | RO | 0x1A08 (6664dec)
Index (hex) |  | Name | Flags | Default value
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dec)
 | 0x1C33:01 | Sync mode | RW | 0x0022 (34dec)
 | 0x1C33:02 | Cycle time | RW | 0x003D0900 (4000000dec)
 | 0x1C33:03 | Shift time | RO | 0x00000000 (0dec)
 | 0x1C33:04 | Sync modes supported | RO | 0xC007 (49159dec)
 | 0x1C33:05 | Minimum cycle time | RO | 0x00030D40 (200000dec)
 | 0x1C33:06 | Calc and copy time | RO | 0x00000000 (0dec)
 | 0x1C33:07 | Minimum delay time | RO | 0x00000000 (0dec)
 | 0x1C33:08 | Command | RW | 0x0000 (0dec)
 | 0x1C33:09 | Maximum delay time | RO | 0x00000000 (0dec)
 | 0x1C33:0B | SM event missed counter | RO | 0x0000 (0dec)
 | 0x1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dec)
 | 0x1C33:0D | Shift too short counter | RO | 0x0000 (0dec)
 | 0x1C33:20 | Sync error | RO | 0x00 (0dec)
6000:0 | Subindex | DIG Inputs Ch.1 | RO | 0x08 (8dec)
 | 0x6000:01 | Input 1 | RO | 0x00 (0dec)
 | 0x6000:02 | Input 2 | RO | 0x00 (0dec)
 | 0x6000:03 | Input 3 | RO | 0x00 (0dec)
 | 0x6000:04 | Input 4 | RO | 0x00 (0dec)
 | 0x6000:05 | Input 5 | RO | 0x00 (0dec)
 | 0x6000:06 | Input 6 | RO | 0x00 (0dec)
 | 0x6000:07 | Input 7 | RO | 0x00 (0dec)
 | 0x6000:08 | Input 8 | RO | 0x00 (0dec)
6010:0 | Subindex | DIG Inputs Ch.2 | RO | 0x08 (8dec)
 | 0x6010:01 | Input 1 | RO | 0x00 (0dec)
 | 0x6010:02 | Input 2 | RO | 0x00 (0dec)
 | 0x6010:03 | Input 3 | RO | 0x00 (0dec)
 | 0x6010:04 | Input 4 | RO | 0x00 (0dec)
 | 0x6010:05 | Input 5 | RO | 0x00 (0dec)
 | 0x6010:06 | Input 6 | RO | 0x00 (0dec)
 | 0x6010:07 | Input 7 | RO | 0x00 (0dec)
 | 0x6010:08 | Input 8 | RO | 0x00 (0dec)
6020:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dec)
 | 0x6020:07 | Error | RO | 0x00 (0dec)
 | 0x6020:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6020:11 | Value | RO | 0x0000 (0dec)
6030:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dec)
 | 0x6030:07 | Error | RO | 0x00 (0dec)
 | 0x6030:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6030:11 | Value | RO | 0x0000 (0dec)
6040:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dec)
 | 0x6040:07 | Error | RO | 0x00 (0dec)
 | 0x6040:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6040:11 | Value | RO | 0x0000 (0dec)
6050:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dec)
 | 0x6050:07 | Error | RO | 0x00 (0dec)
 | 0x6050:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6050:11 | Value | RO | 0x0000 (0dec)
6060:0 | Subindex | AI Inputs Ch.5 | RO | 0x11 (17dec)
 | 0x6060:07 | Error | RO | 0x00 (0dec)
 | 0x6060:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6060:11 | Value | RO | 0x0000 (0dec)
6070:0 | Subindex | AI Inputs Ch.6 | RO | 0x11 (17dec)
 | 0x6070:07 | Error | RO | 0x00 (0dec)
 | 0x6070:10 | TxPDO Toggle | RO | 0x00 (0dec)
 | 0x6070:11 | Value | RO | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8020:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dec)
 | 0x8020:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8020:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8020:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8020:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8020:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8020:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8020:18 | User calibration gain | RW | 0x0000 (0dec)
802F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x02 (2dec)
 | 0x802F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x802F:02 | Calibration Gain | RW | 0x0000 (0dec)
8030:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dec)
 | 0x8030:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8030:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8030:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8030:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8030:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8030:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8030:18 | User calibration gain | RW | 0x0000 (0dec)
803F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x02 (2dec)
 | 0x803F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x803F:02 | Calibration Gain | RW | 0x0000 (0dec)
8040:0 | Subindex | AI Settings Ch.3 | RW | 0x18 (24dec)
 | 0x8040:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8040:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8040:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8040:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8040:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8040:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8040:18 | User calibration gain | RW | 0x0000 (0dec)
804F:0 | Subindex | AI Vendor data Ch.3 | RW | 0x02 (2dec)
 | 0x804F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x804F:02 | Calibration Gain | RW | 0x0000 (0dec)
8050:0 | Subindex | AI Settings Ch.4 | RW | 0x18 (24dec)
 | 0x8050:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8050:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8050:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8050:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8050:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8050:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8050:18 | User calibration gain | RW | 0x0000 (0dec)
805F:0 | Subindex | AI Vendor data Ch.4 | RW | 0x02 (2dec)
 | 0x805F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x805F:02 | Calibration Gain | RW | 0x0000 (0dec)
8060:0 | Subindex | AI Settings Ch.5 | RW | 0x18 (24dec)
 | 0x8060:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8060:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8060:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8060:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8060:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8060:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8060:18 | User calibration gain | RW | 0x0000 (0dec)
806F:0 | Subindex | AI Vendor data Ch.5 | RW | 0x02 (2dec)
 | 0x806F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x806F:02 | Calibration Gain | RW | 0x0000 (0dec)
Index (hex) |  | Name | Flags | Default value
8070:0 | Subindex | AI Settings Ch.6 | RW | 0x18 (24dec)
 | 0x8070:01 | Enable user scale | RW | 0x00 (0dec)
 | 0x8070:0A | Enable user calibration | RW | 0x00 (0dec)
 | 0x8070:0B | Enable vendor calibration | RW | 0x00 (0dec)
 | 0x8070:11 | User scale offset | RW | 0x0000 (0dec)
 | 0x8070:12 | User scale gain | RW | 0x02A00000 (44040192dec)
 | 0x8070:17 | User calibration offset | RW | 0x0000 (0dec)
 | 0x8070:18 | User calibration gain | RW | 0x0000 (0dec)
807F:0 | Subindex | AI Vendor data Ch.6 | RW | 0x02 (2dec)
 | 0x807F:01 | Calibration Offset | RW | 0x0000 (0dec)
 | 0x807F:02 | Calibration Gain | RW | 0x0000 (0dec)
8080:0 | Subindex | SAI Settings | RW | 0x11 (17dec)
 | 0x8080:0D | Mode | RW | 0x0000 (0dec)
 | 0x8080:11 | Range | RW | 0x0000 (0dec)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dec)
 | 0xF000:01 | Module index distance | RO | 0x0010 (16dec)
 | 0xF000:02 | Maximum number of modules | RO | 0x0009 (9dec)
F008 |  | Code word | RW | 0x00000000 (0dec)
F010:0 | Subindex | Module list | RW | 0x09 (9dec)
 | 0xF010:01 | SubIndex 001 | RW | 0x00000118 (280dec)
 | 0xF010:02 | SubIndex 002 | RW | 0x00000118 (280dec)
 | 0xF010:03 | SubIndex 003 | RW | 0x0000012C (300dec)
 | 0xF010:04 | SubIndex 004 | RW | 0x0000012C (300dec)
 | 0xF010:05 | SubIndex 005 | RW | 0x0000012C (300dec)
 | 0xF010:06 | SubIndex 006 | RW | 0x0000012C (300dec)
 | 0xF010:07 | SubIndex 007 | RW | 0x0000012C (300dec)
 | 0xF010:08 | SubIndex 008 | RW | 0x0000012C (300dec)
 | 0xF010:09 | SubIndex 009 | RW | 0x00000168 (360dec)
F600:0 | Subindex | DIG Inputs | RO | 0x10 (16dec)
 | 0xF600:01 | Us Undervoltage | RO | 0x00 (0dec)
 | 0xF600:02 | Up Undervoltage | RO | 0x00 (0dec)
 | 0xF600:10 | TxPDO Toggle | RO | 0x00 (0dec)
Key
Flags:
RO (Read Only): this object can be read only
RW (Read/Write): this object can be read and written to


EP1816-3008 - Object description and parameterization

Commissioning/Configuration [image] EP1816-3008 - Object description and parameterization
EP1816-3008 - Object description and parameterization
Note
Parameterization
The terminal is parameterized via the CoE - Online tab (double-click on the respective object) or via the Process Data tab (allocation of PDOs).
Note
EtherCAT XML Device Description
The display matches that of the CoE objects from the EtherCAT XML Device Description. We recommend downloading the latest XML file from the download area of the Beckhoff website and installing it according to installation instructions.
Introduction
The CoE overview contains objects for different intended applications:
▪
Objects required for parameterization during commissioning
▪
Objects for indicating internal settings (may be fixed)
▪
Further profile-specific objects indicating inputs, outputs and status information
The following section first describes the objects required for normal operation, followed by a complete overview of missing objects.
Additional information
•
Objects to be parameterized during commissioning
•
Standard objects (0x1000-0x1FFF)
•
Profile-specific objects (0x6000-0xFFFF)


Objects to be parameterized during commissioning

Commissioning/Configuration [image] EP1816-3008 - Object description and parameterization [image] Objects to be parameterized during commissioning
Objects to be parameterized during commissioning
Index 8020 AI Settings Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
8020:0 | AI Settings Ch.1 |  | UINT8 | RO | 0x18 (24dec)
8020:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8020:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8020:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8020:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8020:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8020:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 802F AI Vendor data Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
802F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x02 (2dec)
802F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
802F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8030 AI Settings Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
8030:0 | AI Settings Ch.2 |  | UINT8 | RO | 0x18 (24dec)
8030:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8030:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8030:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8030:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8030:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8030:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 803F AI Vendor data Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
803F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x02 (2dec)
803F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
803F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8040 AI Settings Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
8040:0 | AI Settings Ch.3 |  | UINT8 | RO | 0x18 (24dec)
8040:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8040:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8040:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8040:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8040:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8040:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8040:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 804F AI Vendor data Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
804F:0 | AI Vendor data Ch.3 |  | UINT8 | RO | 0x02 (2dec)
804F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
804F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8050 AI Settings Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
8050:0 | AI Settings Ch.4 |  | UINT8 | RO | 0x18 (24dec)
8050:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8050:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8050:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8050:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8050:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8050:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8050:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 805F AI Vendor data Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
805F:0 | AI Vendor data Ch.4 |  | UINT8 | RO | 0x02 (2dec)
805F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
805F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8060 AI Settings Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
8060:0 | AI Settings Ch.5 |  | UINT8 | RO | 0x18 (24dec)
8060:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8060:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8060:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8060:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8060:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8060:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8060:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 806F AI Vendor data Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
806F:0 | AI Vendor data Ch.5 |  | UINT8 | RO | 0x02 (2dec)
806F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
806F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8070 AI Settings Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
8070:0 | AI Settings Ch.6 |  | UINT8 | RO | 0x18 (24dec)
8070:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dec)
8070:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dec)
8070:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dec)
8070:11 | User scale offset |  | INT16 | RW | 0x0000 (0dec)
8070:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dec)
8070:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dec)
8070:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dec)
Index 807F AI Vendor data Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
807F:0 | AI Vendor data Ch.6 |  | UINT8 | RO | 0x02 (2dec)
807F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dec)
807F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dec)
Index 8080 SAI Settings
Index (hex) | Name | Meaning |  | Data type | Flags | Default
8080:0 | SAI Settings |  |  | UINT8 | RO | 0x11 (17dec)
8080:0D | Mode | permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 4 | 1 Hz
 |  | 5 | 10 Hz
 |  | 6 | 25 Hz
 |  | 7 | 50 Hz
 |  | 8 | 100 Hz
 |  | 9 | 200 Hz
 |  | 10 | 400 Hz
 |  | 11 | 1600 Hz
 |  | 12 | 5000 Hz
8080:11 | Range | permitted values: |  | UINT16 | RW | 0x0000 (0dec)
 |  | 3 | +/- 2G
 |  | 4 | +/- 4G
 |  | 5 | +/- 8G
 |  | 6 | +/-16G


Standard objects (0x1000-0x1FFF)

Commissioning/Configuration [image] EP1816-3008 - Object description and parameterization [image] Standard objects (0x1000-0x1FFF)
Standard objects (0x1000-0x1FFF)
The standard objects have the same meaning for all EtherCAT slaves.
Index 1000Device type
Index (hex) | Name | Meaning | Data type | Flags | Default
1000:0 | Device type | Device type of the EtherCAT slave: The Lo-Word contains the CoE profile used (5001). The Hi-Word contains the module profile according to the modular device profile. | UINT32 | RO | 0x00001389 (5001dec)
Index 1008Device name
Index (hex) | Name | Meaning | Data type | Flags | Default
1008:0 | Device name | Device name of the EtherCAT slave | STRING | RO | EP1816-3008
Index 1009Hardware version
Index (hex) | Name | Meaning | Data type | Flags | Default
1009:0 | Hardware version | Hardware version of the EtherCAT slave | STRING | RO |
Index 100ASoftware version
Index (hex) | Name | Meaning | Data type | Flags | Default
100A:0 | Software version | Firmware version of the EtherCAT slave | STRING | RO | 03
Index 1011 Restore default parameters
Index (hex) | Name | Meaning | Data type | Flags | Default
1011:0 | Restore default parameters |  | UINT8 | RO | 0x01 (1dec)
1011:01 | SubIndex 001 |  | UINT32 | RW | 0x00000000 (0dec)
Index 1018Identity
Index (hex) | Name | Meaning | Data type | Flags | Default
1018:0 | Identity | Information for identifying the slave | UINT8 | RO | 0x04 (4dec)
1018:01 | Vendor ID | Vendor ID of the EtherCAT slave | UINT32 | RO | 0x00000002 (2dec)
1018:02 | Product code | Product code of the EtherCAT slave | UINT32 | RO | 0x05E44052 (98844754dec)
1018:03 | Revision | Revision number of the EtherCAT slave; the low word (bit 0-15) indicates the special terminal number, the high word (bit 16-31) refers to the device description | UINT32 | RO | 0x00000000 (0dec)
1018:04 | Serial number | Serial number of the EtherCAT slave; the low byte (bit 0-7) of the low word contains the year of production, the high byte (bit 8-15) of the low word contains the week of production, the high word (bit 16-31) is 0 | UINT32 | RO | 0x00000000 (0dec)
Index 10F0 Backup parameter handling
Index (hex) | Name | Meaning | Data type | Flags | Default
10F0:0 | Backup parameter handling |  | UINT8 | RO | 0x01 (1dec)
10F0:01 | Checksum |  | UINT32 | RO | 0x00000000 (0dec)
Index 1A00 DIG TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dec)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A01 DIG TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A01:0 | DIG TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dec)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 AI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x05 (5dec)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6020:07, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 AI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x05 (5dec)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6030:07, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1A04 AI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x05 (5dec)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6040:07, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 16
Index 1A05 AI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
1A05:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x05 (5dec)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6050:07, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 16
Index 1A06 AI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
1A06:0 | AI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x05 (5dec)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6060:07, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6060:10, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RO | 0x6060:11, 16
Index 1A07 AI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
1A07:0 | AI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x05 (5dec)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6070:07, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6070:10, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x11 (Value)) | UINT32 | RO | 0x6070:11, 16
Index 1A08 DIG TxPDO-Map Inputs Device
Index (hex) | Name | Meaning | Data type | Flags | Default
1A08:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 9 | UINT8 | RO | 0x04 (4dec)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x01 (Us Undervoltage)) | UINT32 | RO | 0xF600:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Up Undervoltage)) | UINT32 | RO | 0xF600:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 13
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:10, 1
Index 1C00Sync manager type
Index (hex) | Name | Meaning | Data type | Flags | Default
1C00:0 | Sync manager type | Using the sync managers | UINT8 | RO | 0x04 (4dec)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dec)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dec)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dec)
Index 1C13 TxPDO assign
Index (hex) | Name | Meaning | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x09 (9dec)
1C13:01 | Subindex 001 | 1. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A00 (6656dec)
1C13:02 | Subindex 002 | 2. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A01 (6657dec)
1C13:03 | Subindex 003 | 3. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A02 (6658dec)
1C13:04 | Subindex 004 | 4. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A03 (6659dec)
1C13:05 | Subindex 005 | 5. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A04 (6660dec)
1C13:06 | Subindex 006 | 6. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A05 (6661dec)
1C13:07 | Subindex 007 | 7. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A06 (6662dec)
1C13:08 | Subindex 008 | 8. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A07 (6663dec)
1C13:09 | Subindex 009 | 9. allocated TxPDO (contains the index of the associated TxPDO mapping object) | UINT16 | RO | 0x1A08 (6664dec)
Index 1C33SM input parameter
Index (hex)
Name
Meaning
Data type
Flags
Default
1C33:0
SM input parameter
Synchronization parameters for the inputs
UINT8
RO
0x20 (32dec)
1C33:01
Sync mode
Current synchronization mode:
▪
0: Free Run
▪
1: Synchronous with SM 3 Event (no outputs available)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchronous with SM 2 Event (outputs available)
UINT16
RW
0x0022 (34dec)
1C33:02
Cycle time
as 0x1C32:02
UINT32
RW
0x003D0900 (4000000dec)
1C33:03
Shift time
Time between SYNC0 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:04
Sync modes supported
Supported synchronization modes:
▪
Bit 0: free run is supported
▪
Bit 1: Synchronous with SM 2 Event is supported (outputs available)
▪
Bit 1: Synchronous with SM 3 Event is supported (no outputs available)
▪
Bit 2-3 = 01: DC mode is supported
▪
Bit 4-5 = 01: Input shift through local event (outputs available)
▪
Bit 4-5 = 10: Input shift with SYNC1 event (no outputs available)
▪
Bit 14 = 1: dynamic times (measurement through writing of 0x1C32:08 or 0x1C33:08)
UINT16
RO
0xC007 (49159dec)
1C33:05
Minimum cycle time
as 0x1C32:05
UINT32
RO
0x00030D40 (200000dec)
1C33:06
Calc and copy time
Time between reading of the inputs and availability of the inputs for the master (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dec)
1C33:08
Command
as 0x1C32:08
UINT16
RW
0x0000 (0dec)
1C33:09
Maximum delay time
Time between SYNC1 event and reading of the inputs (in ns, only DC mode)
UINT32
RO
0x00000000 (0dec)
1C33:0B
SM event missed counter
as 0x1C32:11
UINT16
RO
0x0000 (0dec)
1C33:0C
Cycle exceeded counter
as 0x1C32:12
UINT16
RO
0x0000 (0dec)
1C33:0D
Shift too short counter
as 0x1C32:13
UINT16
RO
0x0000 (0dec)
1C33:20
Sync error
as 0x1C32:32
BOOLEAN
RO
0x00 (0dec)


Profile-specific objects (0x6000-0xFFFF)

Commissioning/Configuration [image] EP1816-3008 - Object description and parameterization [image] Profile-specific objects (0x6000-0xFFFF)
Profile-specific objects (0x6000-0xFFFF)
The profile-specific objects have the same meaning for all EtherCAT slaves that support the profile 5001.
Index 6000 DIG Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6000:0 | DIG Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dec)
6000:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6000:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6000:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6000:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6000:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6000:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
6000:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dec)
6000:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6010 DIG Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6010:0 | DIG Inputs Ch.2 |  | UINT8 | RO | 0x08 (8dec)
6010:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dec)
6010:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dec)
6010:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dec)
6010:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dec)
6010:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dec)
6010:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dec)
6010:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dec)
6010:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dec)
Index 6020 AI Inputs Ch.1
Index (hex) | Name | Meaning | Data type | Flags | Default
6020:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dec)
6020:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6020:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6030 AI Inputs Ch.2
Index (hex) | Name | Meaning | Data type | Flags | Default
6030:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dec)
6030:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6030:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6040 AI Inputs Ch.3
Index (hex) | Name | Meaning | Data type | Flags | Default
6040:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dec)
6040:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6040:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6050 AI Inputs Ch.4
Index (hex) | Name | Meaning | Data type | Flags | Default
6050:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dec)
6050:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6050:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6060 AI Inputs Ch.5
Index (hex) | Name | Meaning | Data type | Flags | Default
6060:0 | AI Inputs Ch.5 |  | UINT8 | RO | 0x11 (17dec)
6060:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6060:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6060:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index 6070 AI Inputs Ch.6
Index (hex) | Name | Meaning | Data type | Flags | Default
6070:0 | AI Inputs Ch.6 |  | UINT8 | RO | 0x11 (17dec)
6070:07 | Error |  | BOOLEAN | RO | 0x00 (0dec)
6070:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)
6070:11 | Value |  | INT16 | RO | 0x0000 (0dec)
Index F000 Modular device profile
Index (hex) | Maximum number of modules>Name | Meaning | UINT16>Data type | RO>Flags | 0x0009 (9dec)>Default
F000:0 | Modular device profile | General information for the modular device profile | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance |  | UINT16 | RO | 0x0010 (16dec)
F000:02 | Maximum number of modules |  | UINT16 | RO | 0x0009 (9dec)
Index F008 Code word
Index (hex) | Name | Meaning | Data type | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)
Index F010 Module list
Index (hex) | Name | Meaning | Data type | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x09 (9dec)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dec)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dec)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dec)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dec)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dec)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x0000012C (300dec)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x0000012C (300dec)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x0000012C (300dec)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000168 (360dec)
Index F600 DIG Inputs
Index (hex) | Name | Meaning | Data type | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dec)
F600:01 | Us Undervoltage |  | BOOLEAN | RO | 0x00 (0dec)
F600:02 | Up Undervoltage |  | BOOLEAN | RO | 0x00 (0dec)
F600:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dec)


Restoring the delivery state

Commissioning/Configuration [image] Restoring the delivery state
Restoring the delivery state
To restore the delivery state for backup objects in ELxxxx terminals / EPxxxx boxes, the CoE object Restore default parameters, SubIndex 001 can be selected in the TwinCAT System Manager (Config mode).
Selecting the Restore default parameters PDO
Double-click on SubIndex 001 to enter the Set Value dialog. Enter the value 1684107116 in field Dec or the value 0x64616F6C in field Hex and confirm with OK.
All backup objects are reset to the delivery state.
Entering a restore value in the Set Value dialog
Note
Alternative restore value
In some older terminals / boxes the backup objects can be switched with an alternative restore value:
Decimal value: 1819238756
Hexadecimal value: 0x6C6F6164
An incorrect entry for the restore value has no effect.


Firmware Update EL/ES/EM/EPxxxx

Commissioning/Configuration [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
This section describes the device update for Beckhoff EtherCAT slaves from the EL/ES, EM, EK and EP series. A firmware update should only be carried out after consultation with Beckhoff support.
Storage locations
An EtherCAT slave stores operating data in up to 3 locations:
▪
Depending on functionality and performance EtherCAT slaves have one or several local controllers for processing I/O data. The corresponding program is the so-called firmware in *.efw format.
▪
In some EtherCAT slaves the EtherCAT communication may also be integrated in these controllers. In this case the controller is usually a so-called FPGA chip with *.rbf firmware.
▪
In addition, each EtherCAT slave has a memory chip, a so-called ESI-EEPROM, for storing its own device description (ESI: EtherCAT Slave Information). On power-up this description is loaded and the EtherCAT communication is set up accordingly. The device description is available from the download area of the Beckhoff website at (http://www.beckhoff.de). All ESI files are accessible there as zip files.
Customers can access the data via the EtherCAT fieldbus and its communication mechanisms. Acyclic mailbox communication or register access to the ESC is used for updating or reading of these data.
The TwinCAT System Manager offers mechanisms for programming all 3 parts with new data, if the slave is set up for this purpose. Generally the slave does not check whether the new data are suitable, i.e. it may no longer be able to operate if the data are unsuitable.
Attention
Risk of damage to the device!
Note the following when downloading new device files

• Firmware downloads to an EtherCAT device must not be interrupted
• Flawless EtherCAT communication must be ensured. CRC errors or LostFrames must be avoided.
• The power supply must adequately dimensioned. The signal level must meet the specification.

In the event of malfunctions during the update process the EtherCAT device may become unusable and require re-commissioning by the manufacturer.
Device description ESI file/XML
Attention
Notice regarding update of the ESI description/EEPROM
Some slaves have stored calibration and configuration data from the production in the EEPROM. These are irretrievably overwritten during an update.
The ESI device description is stored locally on the slave and loaded on start-up. Each device description has a unique identifier consisting of slave name (9 characters/digits) and a revision number (4 digits). Each slave configured in the System Manager shows its identifier in the EtherCAT tab:
Device identifier consisting of name EL3204-0000 and revision -0016
The configured identifier must be compatible with the actual device description used as hardware, i.e. the description which the slave has loaded on start-up (in this case EL3204). Normally the configured revision must be the same or lower than that actually present in the terminal network.
For further information on this, please refer to the EtherCAT system documentation.
Note
Update of XML/ESI description
The device revision is closely linked to the firmware and hardware used. Incompatible combinations lead to malfunctions or even final shutdown of the device. Corresponding updates should only be carried out in consultation with Beckhoff support.
Display of ESI slave identifier
The simplest way to ascertain compliance of configured and actual device description is to scan the EtherCAT boxes in TwinCAT mode Config/FreeRun:
Scan the subordinate field by right-clicking on the EtherCAT device in Config/FreeRun mode
If the found field matches the configured field, the display shows
Configuration is identical
otherwise a change dialog appears for entering the actual data in the configuration.
Change dialog
In this example in Fig. "Change dialog", an EL3201-0000-0017 was found, while an EL3201-0000-0016 was configured. In this case the configuration can be adapted with the Copy Before button. The Extended Information checkbox must be set in order to display the revision.
Changing the ESI slave identifier
The ESI/EEPROM identifier can be updated as follows under TwinCAT:
▪
Trouble-free EtherCAT communication must be established with the slave.
▪
The state of the slave is irrelevant.
▪
Right-clicking on the slave in the online display opens the EEPROM Update dialog, Fig. "EEPROM Update"
EEPROM Update
The new ESI description is selected in the following dialog, see Fig. "Selecting the new ESI". The checkbox Show Hidden Devices also displays older, normally hidden versions of a slave.
Selecting the new ESI
A progress bar in the System Manager shows the progress. Data are first written, then verified.
Note
The change only takes effect after a restart.
Most EtherCAT devices read a modified ESI description immediately or after startup from the INIT. Some communication settings such as distributed clocks are only read during power-on. The EtherCAT slave therefore has to be switched off briefly in order for the change to take effect.
Determining the firmware version
Determining the version on laser inscription
Beckhoff EtherCAT Box feature batch numbers (D number) applied by laser. The D-number has the following structure: KK YY FF HH
KK - week of production (CW, calendar week)
YY - year of production
FF - firmware version
HH - hardware version
Example with D-no.: 12 10 03 02:
12 - week of production 12
10 - year of production 2010
03 - firmware version 03
02 - hardware version 02
Determining the version via the System Manager
The TwinCAT System Manager shows the version of the controller firmware if the master can access the slave online. Click on the E-Bus Terminal whose controller firmware you want to check (in the example terminal 2 (EL3204)) and select the tab CoE Online (CAN over EtherCAT).
Note
CoE Online and Offline CoE
Two CoE directories are available:
• online: This is offered in the EtherCAT slave by the controller, if the EtherCAT slave does supported it. This CoE directory can only be displayed if a slave is connected and operational.
• offline: The EtherCAT Slave Information ESI/XML may contain the default content of the CoE. This CoE directory can only be displayed if it is included in the ESI (e.g. "Beckhoff EL5xxx.xml").

The Advanced button must be used for switching between the two views.
In Fig. “Display of EL3204 firmware version” the firmware version of the selected EL3204 is shown as 03 in CoE entry 0x100A.
Display of EL3204 firmware version
In (A) TwinCAT 2.11 shows that the Online CoE directory is currently displayed. If this is not the case, the Online directory can be loaded via the Online option in Advanced Settings (B) and double-clicking on AllObjects.
Updating controller firmware *.efw
Note
CoE directory
The Online CoE directory is managed by the controller and stored in a dedicated EEPROM, which is generally not changed during a firmware update.
Switch to the Online tab to update the controller firmware of a slave, see Fig. "Firmware Update".
Firmware Update
Proceed as follows, unless instructed otherwise by Beckhoff support.
▪
Switch slave to INIT (A)
▪
Switch slave to BOOTSTRAP
▪
Check the current status (B, C)
▪
Download the new *efw file
▪
After the download switch to INIT, then OP
▪
Switch off the slave briefly
FPGA firmware *.rbf
If an FPGA chip deals with the EtherCAT communication an update may be accomplished via an *.rbf file.
▪
Controller firmware for processing I/O signals
▪
FPGA firmware for EtherCAT communication (only for terminals with FPGA)
The firmware version number included in the terminal serial number contains both firmware components. If one of these firmware components is modified this version number is updated.
Determining the version via the System Manager
The TwinCAT System Manager indicates the FPGA firmware version. Click on the Ethernet card of your EtherCAT strand (Device 2 in the example) and select the Online tab.
The Reg:0002 column indicates the firmware version of the individual EtherCAT devices in hexadecimal and decimal representation.
FPGA firmware version definition
If the column Reg:0002 is not displayed, right-click the table header and select Properties in the context menu.
Context menu Properties
The Advanced Settings dialog appears where the columns to be displayed can be selected. Under Diagnosis/Online View select the '0002 ETxxxx Build' check box in order to activate the FPGA firmware version display.
Dialog Advanced Settings
Update
For updating the FPGA firmware
▪
of an EtherCAT coupler the coupler must have FPGA firmware version 11 or higher;
▪
of an E-Bus Terminal the terminal must have FPGA firmware version 10 or higher.
Older firmware versions can only be updated by the manufacturer!
Updating an EtherCAT device
In the TwinCAT System Manager select the terminal for which the FPGA firmware is to be updated (in the example: Terminal 5: EL5001) and
click the Advanced Settings button in the EtherCAT tab.
Select dialog Advanced Settings
The Advanced Settings dialog appears. Under ESC Access/E²PROM/FPGA click on Write FPGA button,
Select dialog Write FPGA
Select file
Select the file (*.rbf) with the new FPGA firmware, and transfer it to the EtherCAT device.
Attention
Risk of damage to the device!
A firmware download to an EtherCAT device must never be interrupted! If this process is cancelled, the supply voltage switched off or the Ethernet connection interrupted, the EtherCAT device can only be recommissioned by the manufacturer!
In order to activate the new FPGA firmware a restart (switching the power supply off and on again) of the EtherCAT device is required.
Simultaneous updating of several EtherCAT devices
The firmware and ESI descriptions of several devices can be updated simultaneously, provided the devices have the same firmware file/ESI.
Multiple selection and firmware update
Select the required slaves and carry out the firmware update in BOOTSTRAP mode as described above.


Appendix

Appendix
Appendix
Additional information
•
General operating conditions
•
EtherCAT Box- / EtherCAT P Box - Accessories
•
Support and Service


General operating conditions

Appendix [image] General operating conditions
General operating conditions
Protection degrees (IP-Code)
The standard IEC 60529 (DIN EN 60529) defines the degrees of protection in different classes.
1. Number: dust protection and touch guard | Definition
0 | Non-protected
1 | Protected against access to hazardous parts with the back of a hand. Protected against solid foreign objects of Ø 50 mm
2 | Protected against access to hazardous parts with a finger. Protected against solid foreign objects of Ø 12,5 mm.
3 | Protected against access to hazardous parts with a tool. Protected against solid foreign objects Ø 2,5 mm.
4 | Protected against access to hazardous parts with a wire. Protected against solid foreign objects Ø 1 mm.
5 | Protected against access to hazardous parts with a wire. Dust-protected. Intrusion of dust is not totally prevented, but dust shall not penetrate in a quantity to interfere with satisfactory operation of the device or to impair safety.
6 | Protected against access to hazardous parts with a wire. Dust-tight. No intrusion of dust.
2. Number: water* protection | Definition
0 | Non-protected
1 | Protected against water drops
2 | Protected against water drops when enclosure tilted up to 15°.
3 | Protected against spraying water. Water sprayed at an angle up to 60° on either side of the vertical shall have no harmful effects.
4 | Protected against splashing water. Water splashed against the disclosure from any direction shall have no harmful effects
5 | Protected against water jets
6 | Protected against powerful water jets
7 | Protected against the effects of temporary immersion in water. Intrusion of water in quantities causing harmful effects shall not be possible when the enclosure is temporarily immersed in water for 30 min. in 1 m depth.
*) These protection classes define only protection against water!
Chemical Resistance
The Resistance relates to the Housing of the Fieldbus/EtherCAT Box and the used metal parts. In the table below you will find some typical resistance.
Character | Resistance
Steam | at temperatures >100°C: not resistant
Sodium base liquor (ph-Value > 12) | at room temperature: resistant > 40°C: not resistant
Acetic acid | not resistant
Argon (technical clean) | resistant
Key
resistant: Lifetime several months
non inherently resistant: Lifetime several weeks
not resistant: Lifetime several hours resp. early decomposition


EtherCAT Box- / EtherCAT P Box - Accessories

Appendix [image] EtherCAT Box- / EtherCAT P Box - Accessories
EtherCAT Box- / EtherCAT P Box - Accessories
Fixing
Ordering information | Description
ZS5300-0001 | Mounting rail (500 mm x 129 mm)
Marking material, plugs
Ordering information | Description
ZS5000-0000 | Fieldbus Box set M8 (contact labels, plugs)
ZS5000-0002 | Fieldbus Box set M12 (contact labels, plugs)
ZS5000-0010 | plugs M8, IP67 (50 pieces)
ZS5000-0020 | plugs M12, IP67 (50 pieces)
ZS5100-0000 | marking labels, not printed, 4 stripes at 10 pieces
ZS5100-xxxx | printed marking labels, on request
Tools
Ordering information | Description
ZB8800 | torque wrench for M8 cables with knurl, incl. ratchet
ZB8800-0001 | M12 ratchet for torque wrench ZB8800
ZB8800-0002 | M8 ratchet (field assembly) for torque wrench ZB8800
ZB8801-0000 | torque wrench for hexagonal plugs, adjustable
ZB8801-0001 | torque cable key, M8/wrench size 9, for torque wrench ZB8801-0000
ZB8801-0002 | torque cable key, M12/wrench size 13, for torque wrench ZB8801-0000
ZB8801-0003 | torque cable key, M12 field assembly/wrench size 13, for torque wrench ZB8801-0000
Note
Further accessories
Further accessories may be found at the price list for Beckhoff fieldbus components and at the internet under .


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com