EP1816-3008 - EtherCAT-Box mit digitalen Eingängen und Beschleunigungssensoren

BECKHOFF Feldbuskomponenten

Dokumentation zu

EP1816-3008

EtherCAT-Box mit digitalen Eingängen und Beschleunigungssensoren

Version: 1.1.0
Datum: 08.07.2015

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


EP1816-3008 - Ausgabestände der Dokumentation

BECKHOFF EP1816-3008: Vorwort

Ausgabestände der Dokumentation

Version Kommentar
1.1.0
  • Technische Daten aktualisiert
  • Power-Anschluss aktualisiert
1.0.0
  • Beispielprogramm für die Winkelberechnung hinzugefügt
  • Hinweise zum Firmware-Update hinzugefügt
0.5.0
  • Vorläufige Version
0.1.0
  • Interne Version

Firm- und Hardware-Stände

Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.

Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so das ältere Module immer durch neue ersetzt werden können.

Dokumentation Version | EP1816-3008
 | Firmware | Hardware
1.1.0 | 01 | 02
1.0.0 | 01 | 02
0.5.0 | 01 | 01
0.1.0 | 01 | 00

Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.

Syntax der Batch-Nummer (D-Nummer):

D: WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit D-Nr. 29 10 02 01:

29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


EtherCAT Box - Einführung

Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP 67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.

Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.

Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.

Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.

Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:

  • digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)

  • digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom

  • analoge Ein- und Ausgänge mit 16 Bit Auflösung

  • Thermoelement- und RTD-Eingänge

  • Schrittmotormodule

Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.

EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren | EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren

Hinweis 		Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.

Hinweis 		XML-Dateien
XML-Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP1816-0008 - Einführung

BECKHOFF EP1816-3008: Produktübersicht

EP1816-3008 - Einführung

16 digitale Eingänge 24 VDC, 2 x 3G Beschleunigungssensoren

Die EtherCAT Box EP1816-3008 mit digitalen Eingängen erfasst binäre Steuersignale aus der Prozessebene und überträgt sie galvanisch getrennt zur Steuerung. Der Signalzustand wird über Leuchtdioden angezeigt, der Signalanschluss erfolgt über eine 25-polige D-Sub-Buchse.

Darüberhinaus verfügt die EP1816-3008 über zwei 3-Achs-Beschleunigungssensoren.

Die Sensoren werden aus der Steuerspannung Us versorgt. Die Lastspannung Up wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.

Installation

UL-Anforderungen für UL-zugelassene Module


EP1816-3008 - Technische Daten

BECKHOFF EP1816-3008: Produktübersicht

Technische Daten

Technische Daten | EP1816-3008
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Eingänge | 16
Anschluss Eingänge | 25-polige D-Sub-Buchse
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter | 10 µs
Signalspannung "0" | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 3 mA (EN 61131-2, Typ 3)
Minimale Zykluszeit | > 500 µs
Diagnose | Unterspannungserkennung < 18 VDC für Us und Up
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 120 mA
Sensorversorgung | aus der Steuerspannung Us
Stromaufnahme der Sensoren | max. 0,5 A, gesamt kurzschlussfest
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Potenzialtrennung | Steuerspannung / Feldbus: ja
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C 0°C ... +55°C (gemäß cULus, siehe UL-Anforderungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus
Technische Daten | Beschleunigungssensoren
Sensor-Typ | Zwei 3-Achs-Sensoren / versetzt um 90°
Auflösung | 16 Bit Raw-Data; 1mg / LSB
Messbereich | ±2g/±4g/±8g/±16g einstellbar
Besondere Eigenschaften | Selbsttest
Abtastrate | 1 Hz bis 5 kHz

Hinweis 		Maximale Übertragungsrate
Die EP1816-3008 liest Sensoren mit einer Abtastrate von 1 Hz bis zu 5 kHz ein. Da die kleinste Zykluszeit auf Grund der internen Verarbeitung auf 500 µs begrenzt ist, ergibt sich eine maximale Übertragungsrate von 2,5 kHz.


EP1816-3008 - Prozessabbild

DIG Inputs Channel 1 und 2
Unter DIG Inputs Channel n finden Sie die 16 digitalen Eingänge des Moduls.
AI Inputs Channel 1 bis 6
Unter AI Inputs Channel finden Sie die Daten der beiden Beschleunigungssensoren
  • Status Error: ein Fehler mit der Kommunikation des Beschleunigungssensor ist aufgetreten
  • Value: 16 Bit Beschleunigungswert

AI Inputs Channel 1 value: Sensor 1, Achse +X

AI Inputs Channel 2 value: Sensor 1, Achse +Y

AI Inputs Channel 3 value: Sensor 1, Achse -Z

AI Inputs Channel 1 value: Sensor 2, Achse +Y

AI Inputs Channel 2 value: Sensor 2, Achse -X

AI Inputs Channel 3 value: Sensor 2, Achse -Z
DIG Inputs Device
16 Bit Statusbit des Moduls


EtherCAT Box - Abmessungen

BECKHOFF EtherCAT Box: Montage und Verkabelung

Abmessungen

Alle Maßangaben sind in Millimeter angegeben.

Allgemein

Technische Daten | EtherCAT Box
Gehäusematerial | PA6 (Polyamid), Vergussmasse: Polyuhrethan
Montage | 2 x Befestigungslöcher für M3
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit / Aussendung | IEC EN 50082-2 / EN 50081-2
Zulässige Umgebungstemperatur im Betrieb | 0 ... 55°C
Zulässige Umgebungstemperatur bei Lagerung | -25 ... + 85°C
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65/66/67
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm
Zulassungen | CE
Gewicht | ca. 120 g - 200 g, je nach Modultyp


EPxxxx - Befestigung

BECKHOFF EtherCAT Box: Montage und Verkabelung

Befestigung

Hinweis 		Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung!

Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind!
Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.

Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.

Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.

Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.

Montageschiene ZS5300-0001

Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.

Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.

Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.


EPxxxx - Anzugsmomente für Steckverbinder

BECKHOFF EtherCAT Box: Montage und Verkabelung

Anzugsmomente für Steckverbinder

M8-Steckverbinder

Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen.

M12-Steckverbinder

Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.

Drehmomentschlüssel

Hinweis 		Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (siehe Zubehör)!


EtherCAT-Anschluss

Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt

  • die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
  • die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8 | Koppler Box: M12

Belegung

Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.

Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm

1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003

2) Aderfarben nach EN 61918

3) Aderfarben

Hinweis 		Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)

Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx,
also die mit M8-Steckverbindern vorkonfektionierten Leitungen
auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau).

Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!

EtherCAT-Steckverbinder

Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.

Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12 | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8 | vierpolig, IP67, feldkonfektionierbar


Feldbus-LEDs

BECKHOFF EtherCAT Box: Montage und Verkabelung

EtherCAT- Feldbus-LEDs

LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational

Hinweis 		EtherCAT-Stati
Die verschiedenen Stati, die eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.


EtherCAT-Leitung

BECKHOFF Feldbuskomponenten: Montage und Verkabelung

EtherCAT-Kabel

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.

Hinweis 		Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.Beckhoff.de zum Download zur Verfügung steht.

EtherCAT nutzt vier Adern der Kabel für die Signalübertragung. Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.

Es folgt eine Auswahl an Kabel für EtherCAT. Weitere Kabel in verschiedenen Längen finden Sie im Beckhoff Gesamtkatalog und unter www.beckhoff.de.

Meterware

Bezeichnung | Beschreibung
ZB9010 | CAT 5e, 4-adrig, für feste Verlegung, nicht für M8-Steckverbinder
ZB9020 | CAT 5e, 4-adrig, schleppkettentauglich, nicht für M8-Steckverbinder
ZB9030 | PVC, Ø4,9 mm für M8-Steckverbinder
ZB9031 | PUR, Ø4,8 mm für M8-Steckverbinder
ZB9032 | PUR, Ø5,4 mm für M8-Steckverbinder hochflexibel

Konfektionierte Kabel

ZK1090-3100-0xxx: M8-Stecker - offenes Ende, PUR, hochflexibel, vorkonfektioniert

ZK1090-3100- | 0020 | 0050
Länge | 2 m | 5 m

ZK1090-3100-3xxx: M8-Stecker - offenes Ende, PVC, vorkonfektioniert

ZK1090-3100- | 3020 | 3050
Länge | 2 m | 5 m

ZK1090-3131-0xxx: 2 x M8-Stecker, PUR, hochflexibel, fertig konfektioniert

ZK1090-3131- | 0001 | 0003 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0075 | 0100
Länge | 0,15 m | 0,3 m | 0,5 m | 1,0 m | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 7,5 m | 10 m
ZK1090-3131- | 0150 | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Länge | 15 m | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m

ZK1090-3131-3xxx: 2 x M8-Stecker, PVC, fertig konfektioniert

ZK1090-3131- | 3020 | 3030 | 3040 | 3050 | 3075 | 3100 | 3150 | 3200 | 3250 | 3300
Länge | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 7,5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3131- | 3350 | 3400 | 3450 | 3500
Länge | 35 m | 40 m | 45 m | 50 m

ZK1090-3132-0xxx: M8-Stecker - M8-Kupplung, PUR, hochflexibel, fertig konfektioniert

ZK1090-3132- | 0002 | 0004 | 0020 | 0050 | 0075 | 0100 | 0150 | 0200 | 0250 | 0300
Länge | 0,2 m | 0,4 m | 2,0 m | 5,0 m | 7,5 m | 10 m | 15 m | 20 m | 25 m | 30 m
ZK1090-3132- | 0400 | 0500
Länge | 40 m | 50 m

ZK1090-3132-3xxx: M8-Stecker - M8-Kupplung, PVC, fertig konfektioniert

ZK1090-3132- | 0020 | 0050 | 0100 | 0150 | 0200 | 0250 | 0300 | 0400 | 0500
Länge | 2,0 m | 5,0 m | 10 m | 15 m | 20 m | 25 m | 30 m | 40 m | 50 m

ZK1090-3191-0xxx: M8-Stecker - RJ45-Stecker, PUR, hochflexibel, fertig konfektioniert

ZK1090-3191- | 0004 | 0005 | 0010 | 0020 | 0035 | 0050 | 0070 | 0100 | 0150 | 0200
Länge | 0,4 m | 0,5 m | 1 m | 2 m | 3,5 m | 5 m | 7 m | 10 m | 15 m | 20 m
ZK1090-3191- | 0250
Länge | 25 m

ZK1090-3191-3xxx: M8-Stecker - RJ45-Stecker, PVC, fertig konfektioniert

ZK1090-3191- | 3005 | 3020 | 3050
Länge | 0,5 m | 2 m | 5 m

ZK1090-3291-3xxx: M8-Kupplung - RJ45-Stecker, PVC, fertig konfektioniert

ZK1090-3291- | 0004 | 0005 | 0010 | 0020 | 0050 | 100 | 200 | 250
Länge | 0,4 m | 0,5 m | 1 m | 2 m | 5 m | 10 m | 20 m | 25 m

ZK1090-3161-0xxx: M8-Stecker - M12-Stecker (d-codiert), fertig konfektioniert

ZK1090-3161- | 0010 | 0020 | 0050
Länge | 1,0 m | 2,0 m | 5,0 m

ZK1090-6161-0xxx: 2 x M12-Stecker (d-codiert), fertig konfektioniert

ZK1090-6161- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Länge | 0,5 m | 1,0 m | 2,0 m | 2,5 m | 5,0 m | 10 m

ZK1090-6191-0xxx: M12-Stecker - RJ45-Stecker, fertig konfektioniert

ZK1090-6191- | 0005 | 0010 | 0020 | 0025 | 0050 | 0100
Länge | 0,5 m | 1,0 m | 2,0 m | 2,5 m | 5,0 m | 10 m

ZK1090-6292-0xxx: M12-Buchse - RJ45-Stecker, fertig konfektioniert

ZK1090-6292- | 0005 | 0020 | 0050 | 0100
Länge | 0,5 m | 2 m | 5 m | 10 m

ZK1090-9191-0xxx: 2 x RJ45-Stecker, Patch-Kabel

ZK1090-9191- | 0001 | 0002 | 0005 | 0010 | 0020 | 0030 | 0040 | 0050 | 0100 | 0150
Länge | 0,17 m | 0,26 m | 0,5 m | 1,0 m | 2,0 m | 3,0 m | 4,0 m | 5,0 m | 10 m | 15 m
ZK1090-9191- | 0200 | 0250 | 0300 | 0350 | 0400 | 0450 | 0500
Länge | 20 m | 25 m | 30 m | 35 m | 40 m | 45 m | 50 m


EtherCAT Box - Power-Anschluss

BECKHOFF EtherCAT Box: Montage und Verkabelung

Power-Anschluss

Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:

  • IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
  • OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen

Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*

Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.

Zwei LEDs zeigen den Status der Versorgungsspannungen an.

Achtung 		Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!

Steuerspannung Us: 24VDC

Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.

Peripheriespannung Up: 24VDC

Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.

Weiterleitung der Versorgungsspannungen

Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.

Achtung 		Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!

Versorgung über PowerBox Module EP92x4-0023

Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).

Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.

Galvanische Trennung

Digitale Module

Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!

Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.

Analoge Module

Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.

Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0...10 V Eingängen eine beliebige Referenzspannung (0...30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).

Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.

Achtung 		Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann ist galvanische Trennung der Analogsignale u.U. nicht mehr gegeben!


EtherCAT Box - Status-LEDs für die Spannungsversorgung

BECKHOFF EtherCAT Box: Montage und Verkabelung

Status-LEDs für die Spannungsversorgung

LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Powerkabel

Bestelldaten

Bestellbezeichnung | Powerleitung | Schraub- Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m

Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).

Technische Daten

Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109 W
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mW
Schutzart nach IEC 60529 | IP65/66/67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste

Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkablung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.

Beispiel:
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.


EtherCAT Box - UL-Anforderungen

BECKHOFF EtherCAT Box: Montage und Verkabelung

UL-Anforderungen

Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.

Versorgungsspannung

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammt.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!

Netzwerke

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!

Umgebungstemperatur

VORSICHT 		VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!

Kennzeichnung für UL

Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet:


EP1816-3008 - Signalanschluss

BECKHOFF EP1816-3008: Montage und Verkabelung

Signalanschluss

Digitale Ein- /Ausgänge, 24 VDC: 25-polige D-Sub-Buchse

Die digitalen Eingangsmodule EP100x erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät.

Der Der Signalanschluss erfolgt über eine 25-polige D-Sub-Buchse.

Die Sensoren werden aus der Steuerspannung Us versorgt. Die Lastspannung Up wird im Eingangsmodul nicht verwendet, sie kann jedoch zur Weiterleitung optional angeschlossen werden.

EP1816-3008

Achtung 		Beachten Sie die besondere Anschlussbelegung der EP1816-3008!
Die Anschlussbelegung der EP1816-3008 weicht von der EP1816-0008 ab!
Insbesondere die Versorgungsspannungen sowie der GND liegen auf anderen Anschlüssen
und könnten bei falschem Anschluss die Endgeräte beschädigen, wenn diese nicht kurzschlussfest sind.


EP1816-3008 - Status-LEDs an den Signalanschlüssen

BECKHOFF EP1816-3008: Montage und Verkabelung

Beschleunigungssensoren

2 x 3G Beschleunigungssensoren

Die EtherCAT Box EP1816-3008 verfügt über 2 Stück 3-Achs-Beschleunigungssensoren.

Diese sind um je 90° auf der Unterseite der Platine angebracht.

Abb: Lage der Beschleunigungssensoren

Die Abbildung zeigt die Draufsicht und die Seitenansicht der EtherCAT-Box. Die Lage der Beschleunigungssensoren ist innerhalb der Box angezeigt, Grün gibt die Lage der Leiterplatte an. Die Beschleunigungssensoren sind mit 1 bis 2 nummeriert, wobei sich die Sensoren auf der Unterseite der Platine befinden.

Durch die Lage der Sensoren auf der Unterseite, wird z.B. die Erdanziehungskraft, auch ein Beschleunigung, in normaler Montage der Box, z.B. beim Test auf dem Labortisch, auf einer flachen, ebenen Unterlage als negativer Wert angezeigt.

Prozesswerte | zugeordneter Beschleunigungswert
AI Inputs Channel1 value | Sensor 1, +X - Achse
AI Inputs Channel2 value | Sensor 1, +Y - Achse
AI Inputs Channel3 value | Sensor 1, -Z - Achse
AI Inputs Channel4 value | Sensor 2, +Y - Achse
AI Inputs Channel5 value | Sensor 2, -X - Achse
AI Inputs Channel6 value | Sensor 2, -Z - Achse


EtherCAT Box - Einfügen in das EtherCAT-Netzwerk

BECKHOFF EtherCAT Box: Inbetriebnahme und Konfiguration

Einfügen in das EtherCAT-Netzwerk

Hinweis 		Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen installiert werden.

Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:

  • durch Einscannen vorhandener Hardware (genannt "online") und
  • durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.

Automatisches Einscannen des Moduls

  • Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
  • Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein (siehe Abb.1). Bestätigen Sie alle folgenden Dialoge mit "OK", so dass sich die Konfiguration im "FreeRun" -Modus befindet.

Abb. 1: Einscannen der EtherCAT Konfiguration (E/A-Geräte-> Rechte Maustaste -> Geräte suchen...

Manuelles Anfügen eines Moduls

  • Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
  • Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
  • Fügen Sie ein neues E/A-Gerät an (siehe Abb. 2). Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), s. Abb. 3, bestätigen Sie mit OK.

Abb. 2: Anfügen eines neuen E/A-Gerätes (E/A-Geräte-> Rechte Maustaste -> Gerät anfügen... )

Abb. 3: Auswahl des Gerätes (EtherCAT)

  • Fügen Sie eine neue Box an (siehe Abb. 4).

Abb. 4: Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen... )

  • Im angezeigten Dialog wählen Sie die gewünschte Box, bestätigen Sie mit OK.

Abb. 5: Auswahl einer Box

Abb. 6 Angefügte Box im TwinCAT Baum


EPxxxx - Konfiguration mit dem TwinCAT System Manager

BECKHOFF EtherCAT Box: Inbetriebnahme und Konfiguration

Konfiguration mit dem TwinCAT System Manager

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten.

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.

Karteireiter Allgemein

Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.

Karteireiter EtherCAT

Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem Anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.

Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.

Karteireiter Prozessdaten

Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.

Sync-Manager

Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.

Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.

PDO-Zuordnung

PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:

  • Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
  • Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.

Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.

Hinweis 		Aktivierung der PDO-Zuordnung
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
  • der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
  • der System-Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])

PDO-Liste

Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.

Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.

PDO-Inhalt

Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.

Download

Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.

PDO-Zuordnung

Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.

PDO-Konfiguration

Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.

Karteireiter Startup

Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.

Spalte | Beschreibung
Transition Übergang, in den der Request gesendet wird. Dies kann entweder
  • der Übergang von Pre-Operational to Safe-Operational (PS) oder
  • der Übergang von Safe-Operational to Operational (SO) sein.

Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll | Art des Mailbox-Protokolls
Index | Index des Objekts
Data | Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar | Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.

Karteireiter CoE - Online

Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.

Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.

Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.

Karteireiter Online

Status Maschine

Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.

DLL-Status

Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:

Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.

File Access over EtherCAT

Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


EP1816-3008 - Beschleunigungmessung

BECKHOFF EP1816-3008: Inbetriebnahme und Konfiguration

Beschleunigungsmessung

Auflösung und Darstellung

Die Daten der Beschleunigungssensoren, jeweils, X-, Y- und Z-Achse, werden per Default als RAW Daten, also direkt wie sie aus dem Sensoren übertragen werden, angezeigt.

Abb.: CoE Objekt 8080:1D

Die Daten können auch auf 1mG / LSB konvertiert ausgegeben werden. Hierzu muß die entsprechende Einstellung des CoE Objektes 8080:1D vorgenommen werden.

Abb.: Einstellung für Wertausgabe in mG

Beispiel der Darstellung der Beschleunigungswerte mit TwinCAT ScopeView 2

Abb.: EP1816-3008, Bewegung der Box in den 3 Achsen, resultierende Beschleunigungswerte

Farbe | Bedeutung
Blau | Sensor 1, Z-Achse
Rot | Sensor 1, X.Achse
Grün | Snsor 1, Y-Achse


EP1816-0008 - Udate-Frequenz

BECKHOFF EP1816-3008: Inbetriebnahme und Konfiguration

Udate-Frequenz

Über das CoE Objekt 8080:0D wird die Udate-Frequenz der Sensordaten eingestellt. Im Auslieferungszustand beträgt diese 5 kHz.


EP1816-3008 - Winkelmessung

BECKHOFF EP1816-3008: Inbetriebnahme und Konfiguration

Winkelmessung

Die Berechnung des Winkels im Bezug auf die Erdanziehungskraft kann in der EP1816-3008 direkt erfolgen (CoE Objekt 8080:1D).

Durch die aufwendigen trigonometrischen Berechnungen würde die Zykluszeit der Box sehr herabgesetzt werden, so dass in diesem Modus die Auflösung der Winkel auf 1° beschränkt wurde.

Eine genauere Berechnung mit einer höheren Auflösung und Genauigkeit sollte auf einem PC stattfinden. Die Genauigkeit der verwendeten Sensoren erlauben eine Genauigkeit von < 0,1°.

Da die Winkelwerte aus den Beschleunigungswerten abgeleitet werden und diese mit einem bestimmten Rauschen beaufschlagt sind, muss der Winkelwert mittels geeigneter Algorithmen gefiltert werden.

Dies kann im einfachsten Fall z.B. ein gleitender Mittelwert sein.

Abb.: Winkelmessung, Prozessdaten al Beschleunigungswerte, Berechnung im PC

Abb.: Detaildarstellung Signalrauschen

Farbe | Bedeutung
Rot | Winkel gemessen mit 1024-Schritt-Encoder / 4-fach Auswertung als Referenz
Grün | trigonmetrisch im PC errechneter Winkel, ohne Rauschunterdrückung
blau | schneller Algorithmus
gelb | arithmetisches Mittel (1000 Werte gleitend)

Direkte Messung in der EP1816-3008

Zur direkten Messung muss das CoE-Objekt 8080:1D Presentation auf "Horizontal Off-Axis Angle" eingestellt werden.

Der Winkel wird in einer 1° Auflösung angezeigt. Da dieser noch stark rauschbehaftet ist, empfiehlt sich ebenfalls eine Filterung auf dem PC.

Abb.: rot = Winkelwert aus EP1816-3008, grün = nach arithmetischem Mittel im PC.

Bezugsrichtungen

  • "Spannungversorgung hoch / Ethercat Anschluss runter" -> negativer Winkel X
  • "Spannungversorgung runter / Ethercat Anschluss hoch" -> positiver Winkel X
  • "Box nach links gekippt (Oberseite nach links)" -> positiver Winkel Y
  • "Box nach rechts gekippt (Oberseite nach rechts)" -> negativer Winkel Y
Farbe | Bedeutung
AI Inputs Channel 1: Input 1 | -180° bis +180° bez. X
AI Inputs Channel 2: Input 2 | -180° bis +180° bez. Y
AI Inputs Channel 3: Input 3 | 0
AI Inputs Channel 4: Input 4 | -180° bis +180° bez. Y
AI Inputs Channel 5: Input 5 | -180° bis +180° bez. X
AI Inputs Channel 6: Input 6 | 0

Berechnungsgrundlage auf Basis der Beschleunigungswerte

Wenn die Berechnung im PC erfolgt, muss die "Presentation" CoE Objekt 8080:1D auf Milli-G eingestellt sein.

Variable | Bedeutung
AI Inputs Channel 1 | +X1
AI Inputs Channel 2 | +Y1
AI Inputs Channel 3 | -Z1
AI Inputs Channel 4 | +Y2
AI Inputs Channel 5 | -X2
AI Inputs Channel 6 | -Z2
Winkel X = atan2[sqrt(Z1 * Z1 + Y1 * Y1), |X1)].

IF Z1 < 0
     THEN
          Winkel X = 90° - Winkel X,
     ELSE
          Winkel X = Winkel X + 90°.

IF Z1 >0
     THEN
          Winkel = - Winkel

Beispielprogramm

Achtung 		Verwendung des Beispielprogramms
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Kunden zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.

Zum Download des Beispielprogramms aus dieser Dokumentation heraus klicken Sie bitte auf das Symbol:


EP1816-3008 - Objektübersicht

BECKHOFF EP1816-3008: Konfiguration

Objektübersicht

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.
Index |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x00001389 (5001dez)
1008 |  | Device name | RO | EP1816-3008
1009 |  | Hardware version | RO |
100A |  | Software version | RO | 03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x05E44052 (98844754dez)
 | 1018:03 | Revision | RO | 0x00000000 (0dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1A00:0 | Subindex | DIG TxPDO-Map Inputs Ch.1 | RO | 0x09 (9dez)
 | 1A00:01 | SubIndex 001 | RO | 0x6000:01, 1
 | 1A00:02 | SubIndex 002 | RO | 0x6000:02, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:03, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:04, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:05, 1
 | 1A00:06 | SubIndex 006 | RO | 0x6000:06, 1
 | 1A00:07 | SubIndex 007 | RO | 0x6000:07, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:08, 1
 | 1A00:09 | SubIndex 009 | RO | 0x0000:00, 8
1A01:0 | Subindex | DIG TxPDO-Map Inputs Ch.2 | RO | 0x09 (9dez)
 | 1A01:01 | SubIndex 001 | RO | 0x6010:01, 1
 | 1A01:02 | SubIndex 002 | RO | 0x6010:02, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:03, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:04, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:05, 1
 | 1A01:06 | SubIndex 006 | RO | 0x6010:06, 1
 | 1A01:07 | SubIndex 007 | RO | 0x6010:07, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:08, 1
 | 1A01:09 | SubIndex 009 | RO | 0x0000:00, 8
1A02:0 | Subindex | AI TxPDO-Map Inputs Ch.1 | RO | 0x05 (5dez)
 | 1A02:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A02:02 | SubIndex 002 | RO | 0x6020:07, 1
 | 1A02:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A02:04 | SubIndex 004 | RO | 0x6020:10, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6020:11, 16
1A03:0 | Subindex | AI TxPDO-Map Inputs Ch.2 | RO | 0x05 (5dez)
 | 1A03:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A03:02 | SubIndex 002 | RO | 0x6030:07, 1
 | 1A03:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A03:04 | SubIndex 004 | RO | 0x6030:10, 1
 | 1A03:05 | SubIndex 005 | RO | 0x6030:11, 16
1A04:0 | Subindex | AI TxPDO-Map Inputs Ch.3 | RO | 0x05 (5dez)
 | 1A04:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A04:02 | SubIndex 002 | RO | 0x6040:07, 1
 | 1A04:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A04:04 | SubIndex 004 | RO | 0x6040:10, 1
 | 1A04:05 | SubIndex 005 | RO | 0x6040:11, 16
1A05:0 | Subindex | AI TxPDO-Map Inputs Ch.4 | RO | 0x05 (5dez)
 | 1A05:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A05:02 | SubIndex 002 | RO | 0x6050:07, 1
 | 1A05:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A05:04 | SubIndex 004 | RO | 0x6050:10, 1
 | 1A05:05 | SubIndex 005 | RO | 0x6050:11, 16
1A06:0 | Subindex | AI TxPDO-Map Inputs Ch.5 | RO | 0x05 (5dez)
 | 1A06:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A06:02 | SubIndex 002 | RO | 0x6060:07, 1
 | 1A06:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A06:04 | SubIndex 004 | RO | 0x6060:10, 1
 | 1A06:05 | SubIndex 005 | RO | 0x6060:11, 16
1A07:0 | Subindex | AI TxPDO-Map Inputs Ch.6 | RO | 0x05 (5dez)
 | 1A07:01 | SubIndex 001 | RO | 0x0000:00, 6
 | 1A07:02 | SubIndex 002 | RO | 0x6070:07, 1
 | 1A07:03 | SubIndex 003 | RO | 0x0000:00, 8
 | 1A07:04 | SubIndex 004 | RO | 0x6070:10, 1
 | 1A07:05 | SubIndex 005 | RO | 0x6070:11, 16
1A08:0 | Subindex | DIG TxPDO-Map Inputs Device | RO | 0x04 (4dez)
 | 1A08:01 | SubIndex 001 | RO | 0xF600:01, 1
 | 1A08:02 | SubIndex 002 | RO | 0xF600:02, 1
 | 1A08:03 | SubIndex 003 | RO | 0x0000:00, 13
 | 1A08:04 | SubIndex 004 | RO | 0xF600:10, 1
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RO | 0x00 (0dez)
1C13:0 | Subindex | TxPDO assign | RO | 0x09 (9dez)
 | 1C13:01 | SubIndex 001 | RO | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RO | 0x1A01 (6657dez)
 | 1C13:03 | SubIndex 003 | RO | 0x1A02 (6658dez)
 | 1C13:04 | SubIndex 004 | RO | 0x1A03 (6659dez)
 | 1C13:05 | SubIndex 005 | RO | 0x1A04 (6660dez)
 | 1C13:06 | SubIndex 006 | RO | 0x1A05 (6661dez)
 | 1C13:07 | SubIndex 007 | RO | 0x1A06 (6662dez)
 | 1C13:08 | SubIndex 008 | RO | 0x1A07 (6663dez)
 | 1C13:09 | SubIndex 009 | RO | 0x1A08 (6664dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x003D0900 (4000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x00030D40 (200000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | DIG Inputs Ch.1 | RO | 0x08 (8dez)
 | 6000:01 | Input 1 | RO | 0x00 (0dez)
 | 6000:02 | Input 2 | RO | 0x00 (0dez)
 | 6000:03 | Input 3 | RO | 0x00 (0dez)
 | 6000:04 | Input 4 | RO | 0x00 (0dez)
 | 6000:05 | Input 5 | RO | 0x00 (0dez)
 | 6000:06 | Input 6 | RO | 0x00 (0dez)
 | 6000:07 | Input 7 | RO | 0x00 (0dez)
 | 6000:08 | Input 8 | RO | 0x00 (0dez)
6010:0 | Subindex | DIG Inputs Ch.2 | RO | 0x08 (8dez)
 | 6010:01 | Input 1 | RO | 0x00 (0dez)
 | 6010:02 | Input 2 | RO | 0x00 (0dez)
 | 6010:03 | Input 3 | RO | 0x00 (0dez)
 | 6010:04 | Input 4 | RO | 0x00 (0dez)
 | 6010:05 | Input 5 | RO | 0x00 (0dez)
 | 6010:06 | Input 6 | RO | 0x00 (0dez)
 | 6010:07 | Input 7 | RO | 0x00 (0dez)
 | 6010:08 | Input 8 | RO | 0x00 (0dez)
6020:0 | Subindex | AI Inputs Ch.1 | RO | 0x11 (17dez)
 | 6020:07 | Error | RO | 0x00 (0dez)
 | 6020:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6020:11 | Value | RO | 0x0000 (0dez)
6030:0 | Subindex | AI Inputs Ch.2 | RO | 0x11 (17dez)
 | 6030:07 | Error | RO | 0x00 (0dez)
 | 6030:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6030:11 | Value | RO | 0x0000 (0dez)
6040:0 | Subindex | AI Inputs Ch.3 | RO | 0x11 (17dez)
 | 6040:07 | Error | RO | 0x00 (0dez)
 | 6040:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6040:11 | Value | RO | 0x0000 (0dez)
6050:0 | Subindex | AI Inputs Ch.4 | RO | 0x11 (17dez)
 | 6050:07 | Error | RO | 0x00 (0dez)
 | 6050:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6050:11 | Value | RO | 0x0000 (0dez)
6060:0 | Subindex | AI Inputs Ch.5 | RO | 0x11 (17dez)
 | 6060:07 | Error | RO | 0x00 (0dez)
 | 6060:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6060:11 | Value | RO | 0x0000 (0dez)
6070:0 | Subindex | AI Inputs Ch.6 | RO | 0x11 (17dez)
 | 6070:07 | Error | RO | 0x00 (0dez)
 | 6070:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6070:11 | Value | RO | 0x0000 (0dez)
8020:0 | Subindex | AI Settings Ch.1 | RW | 0x18 (24dez)
 | 8020:01 | Enable user scale | RW | 0x00 (0dez)
 | 8020:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8020:0B | Enable vendor calibration | RW | 0x00 (0dez)
 | 8020:11 | User scale offset | RW | 0x0000 (0dez)
 | 8020:12 | User scale gain | RW | 0x02A00000 (44040192dez)
 | 8020:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8020:18 | User calibration gain | RW | 0x0000 (0dez)
802F:0 | Subindex | AI Vendor data Ch.1 | RW | 0x02 (2dez)
 | 802F:01 | Calibration Offset | RW | 0x0000 (0dez)
 | 802F:02 | Calibration Gain | RW | 0x0000 (0dez)
8030:0 | Subindex | AI Settings Ch.2 | RW | 0x18 (24dez)
 | 8030:01 | Enable user scale | RW | 0x00 (0dez)
 | 8030:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8030:0B | Enable vendor calibration | RW | 0x00 (0dez)
 | 8030:11 | User scale offset | RW | 0x0000 (0dez)
 | 8030:12 | User scale gain | RW | 0x02A00000 (44040192dez)
 | 8030:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8030:18 | User calibration gain | RW | 0x0000 (0dez)
803F:0 | Subindex | AI Vendor data Ch.2 | RW | 0x02 (2dez)
 | 803F:01 | Calibration Offset | RW | 0x0000 (0dez)
 | 803F:02 | Calibration Gain | RW | 0x0000 (0dez)
8040:0 | Subindex | AI Settings Ch.3 | RW | 0x18 (24dez)
 | 8040:01 | Enable user scale | RW | 0x00 (0dez)
 | 8040:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8040:0B | Enable vendor calibration | RW | 0x00 (0dez)
 | 8040:11 | User scale offset | RW | 0x0000 (0dez)
 | 8040:12 | User scale gain | RW | 0x02A00000 (44040192dez)
 | 8040:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8040:18 | User calibration gain | RW | 0x0000 (0dez)
804F:0 | Subindex | AI Vendor data Ch.3 | RW | 0x02 (2dez)
 | 804F:01 | Calibration Offset | RW | 0x0000 (0dez)
 | 804F:02 | Calibration Gain | RW | 0x0000 (0dez)
8050:0 | Subindex | AI Settings Ch.4 | RW | 0x18 (24dez)
 | 8050:01 | Enable user scale | RW | 0x00 (0dez)
 | 8050:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8050:0B | Enable vendor calibration | RW | 0x00 (0dez)
 | 8050:11 | User scale offset | RW | 0x0000 (0dez)
 | 8050:12 | User scale gain | RW | 0x02A00000 (44040192dez)
 | 8050:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8050:18 | User calibration gain | RW | 0x0000 (0dez)
805F:0 | Subindex | AI Vendor data Ch.4 | RW | 0x02 (2dez)
 | 805F:01 | Calibration Offset | RW | 0x0000 (0dez)
 | 805F:02 | Calibration Gain | RW | 0x0000 (0dez)
8060:0 | Subindex | AI Settings Ch.5 | RW | 0x18 (24dez)
 | 8060:01 | Enable user scale | RW | 0x00 (0dez)
 | 8060:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8060:0B | Enable vendor calibration | RW | 0x00 (0dez)
 | 8060:11 | User scale offset | RW | 0x0000 (0dez)
 | 8060:12 | User scale gain | RW | 0x02A00000 (44040192dez)
 | 8060:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8060:18 | User calibration gain | RW | 0x0000 (0dez)
806F:0 | Subindex | AI Vendor data Ch.5 | RW | 0x02 (2dez)
 | 806F:01 | Calibration Offset | RW | 0x0000 (0dez)
 | 806F:02 | Calibration Gain | RW | 0x0000 (0dez)
8070:0 | Subindex | AI Settings Ch.6 | RW | 0x18 (24dez)
 | 8070:01 | Enable user scale | RW | 0x00 (0dez)
 | 8070:0A | Enable user calibration | RW | 0x00 (0dez)
 | 8070:0B | Enable vendor calibration | RW | 0x00 (0dez)
 | 8070:11 | User scale offset | RW | 0x0000 (0dez)
 | 8070:12 | User scale gain | RW | 0x02A00000 (44040192dez)
 | 8070:17 | User calibration offset | RW | 0x0000 (0dez)
 | 8070:18 | User calibration gain | RW | 0x0000 (0dez)
807F:0 | Subindex | AI Vendor data Ch.6 | RW | 0x02 (2dez)
 | 807F:01 | Calibration Offset | RW | 0x0000 (0dez)
 | 807F:02 | Calibration Gain | RW | 0x0000 (0dez)
8080:0 | Subindex | SAI Settings | RW | 0x11 (17dez)
 | 8080:0D | Mode | RW | 0x0000 (0dez)
 | 8080:11 | Range | RW | 0x0000 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0009 (9dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x09 (9dez)
 | F010:01 | SubIndex 001 | RW | 0x00000118 (280dez)
 | F010:02 | SubIndex 002 | RW | 0x00000118 (280dez)
 | F010:03 | SubIndex 003 | RW | 0x0000012C (300dez)
 | F010:04 | SubIndex 004 | RW | 0x0000012C (300dez)
 | F010:05 | SubIndex 005 | RW | 0x0000012C (300dez)
 | F010:06 | SubIndex 006 | RW | 0x0000012C (300dez)
 | F010:07 | SubIndex 007 | RW | 0x0000012C (300dez)
 | F010:08 | SubIndex 008 | RW | 0x0000012C (300dez)
 | F010:09 | SubIndex 009 | RW | 0x00000168 (360dez)
F600:0 | Subindex | DIG Inputs | RO | 0x10 (16dez)
 | F600:01 | Us Undervoltage | RO | 0x00 (0dez)
 | F600:02 | Up Undervoltage | RO | 0x00 (0dez)
 | F600:10 | TxPDO Toggle | RO | 0x00 (0dez)
Legende

Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


EP1816-3008 - Objektbeschreibung

BECKHOFF EP1816-3008: Konfiguration

Objektbeschreibung und Parametrierung

Hinweis 		Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
  • Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte zur Parametrierung bei der Inbetriebnahme

Index 8020 AI Settings Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | AI Settings Ch.1 |  | UINT8 | RO | 0x18 (24dez)
8020:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dez)
8020:11 | User scale offset |  | INT16 | RW | 0x0000 (0dez)
8020:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dez)
8020:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dez)
8020:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dez)
Index 802F AI Vendor data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | AI Vendor data Ch.1 |  | UINT8 | RO | 0x02 (2dez)
802F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dez)
802F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8030 AI Settings Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
8030:0 | AI Settings Ch.2 |  | UINT8 | RO | 0x18 (24dez)
8030:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dez)
8030:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dez)
8030:11 | User scale offset |  | INT16 | RW | 0x0000 (0dez)
8030:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dez)
8030:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dez)
8030:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dez)
Index 803F AI Vendor data Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
803F:0 | AI Vendor data Ch.2 |  | UINT8 | RO | 0x02 (2dez)
803F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dez)
803F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8040 AI Settings Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | AI Settings Ch.3 |  | UINT8 | RO | 0x18 (24dez)
8040:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dez)
8040:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
8040:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dez)
8040:11 | User scale offset |  | INT16 | RW | 0x0000 (0dez)
8040:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dez)
8040:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dez)
8040:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dez)
Index 804F AI Vendor data Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
804F:0 | AI Vendor data Ch.3 |  | UINT8 | RO | 0x02 (2dez)
804F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dez)
804F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8050 AI Settings Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
8050:0 | AI Settings Ch.4 |  | UINT8 | RO | 0x18 (24dez)
8050:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dez)
8050:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
8050:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dez)
8050:11 | User scale offset |  | INT16 | RW | 0x0000 (0dez)
8050:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dez)
8050:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dez)
8050:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dez)
Index 805F AI Vendor data Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
805F:0 | AI Vendor data Ch.4 |  | UINT8 | RO | 0x02 (2dez)
805F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dez)
805F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8060 AI Settings Ch.5
Index | Name | Bedeutung | Datentyp | Flags | Default
8060:0 | AI Settings Ch.5 |  | UINT8 | RO | 0x18 (24dez)
8060:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dez)
8060:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
8060:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dez)
8060:11 | User scale offset |  | INT16 | RW | 0x0000 (0dez)
8060:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dez)
8060:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dez)
8060:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dez)
Index 806F AI Vendor data Ch.5
Index | Name | Bedeutung | Datentyp | Flags | Default
806F:0 | AI Vendor data Ch.5 |  | UINT8 | RO | 0x02 (2dez)
806F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dez)
806F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8070 AI Settings Ch.6
Index | Name | Bedeutung | Datentyp | Flags | Default
8070:0 | AI Settings Ch.6 |  | UINT8 | RO | 0x18 (24dez)
8070:01 | Enable user scale |  | BOOLEAN | RW | 0x00 (0dez)
8070:0A | Enable user calibration |  | BOOLEAN | RW | 0x00 (0dez)
8070:0B | Enable vendor calibration |  | BOOLEAN | RW | 0x00 (0dez)
8070:11 | User scale offset |  | INT16 | RW | 0x0000 (0dez)
8070:12 | User scale gain |  | INT32 | RW | 0x02A00000 (44040192dez)
8070:17 | User calibration offset |  | INT16 | RW | 0x0000 (0dez)
8070:18 | User calibration gain |  | INT16 | RW | 0x0000 (0dez)
Index 807F AI Vendor data Ch.6
Index | Name | Bedeutung | Datentyp | Flags | Default
807F:0 | AI Vendor data Ch.6 |  | UINT8 | RO | 0x02 (2dez)
807F:01 | Calibration Offset |  | INT16 | RW | 0x0000 (0dez)
807F:02 | Calibration Gain |  | INT16 | RW | 0x0000 (0dez)
Index 8080 SAI Settings
Index | Name | Bedeutung |  | Datentyp | Flags | Default
8080:0 | SAI Settings |  |  | UINT8 | RO | 0x11 (17dez)
8080:0D | Mode | erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 4 | 1 Hz
 |  | 5 | 10 Hz
 |  | 6 | 25 Hz
 |  | 7 | 50 Hz
 |  | 8 | 100 Hz
 |  | 9 | 200 Hz
 |  | 10 | 400 Hz
 |  | 11 | 1600 Hz
 |  | 12 | 5000 Hz
8080:11 | Range | erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 3 | +/- 2G
 |  | 4 | +/- 4G
 |  | 5 | +/- 8G
 |  | 6 | +/-16G

Weitere Objekte

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP1816-3008
Index 1009Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100ASoftware version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 03
Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters |  | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 |  | UINT32 | RW | 0x00000000 (0dez)
Index 1018Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x05E44052 (98844754dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling |  | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum |  | UINT32 | RO | 0x00000000 (0dez)
Index 1A00 DIG TxPDO-Map Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DIG TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x01 (Input 1)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x02 (Input 2)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x03 (Input 3)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x04 (Input 4)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x05 (Input 5)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x06 (Input 6)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x07 (Input 7)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DIG Inputs Ch.1), entry 0x08 (Input 8)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A01 DIG TxPDO-Map Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DIG TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x01 (Input 1)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x02 (Input 2)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x03 (Input 3)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x04 (Input 4)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x05 (Input 5)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x06 (Input 6)) | UINT32 | RO | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x07 (Input 7)) | UINT32 | RO | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (DIG Inputs Ch.2), entry 0x08 (Input 8)) | UINT32 | RO | 0x6010:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A02 AI TxPDO-Map Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | AI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x05 (5dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6020:07, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (AI Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 AI TxPDO-Map Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | AI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x05 (5dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6030:07, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (AI Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1A04 AI TxPDO-Map Inputs Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | AI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x05 (5dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6040:07, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6040:10, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (AI Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6040:11, 16
Index 1A05 AI TxPDO-Map Inputs Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | AI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x05 (5dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6050:07, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6050:10, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (AI Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6050:11, 16
Index 1A06 AI TxPDO-Map Inputs Ch.5
Index | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | AI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x05 (5dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6060:07, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6060:10, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (AI Inputs Ch.5), entry 0x11 (Value)) | UINT32 | RO | 0x6060:11, 16
Index 1A07 AI TxPDO-Map Inputs Ch.6
Index | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | AI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x05 (5dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 6
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x1C33 (SM input parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6070:07, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6070:10, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (AI Inputs Ch.6), entry 0x11 (Value)) | UINT32 | RO | 0x6070:11, 16
Index 1A08 DIG TxPDO-Map Inputs Device
Index | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 9 | UINT8 | RO | 0x04 (4dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x01 (Us Undervoltage)) | UINT32 | RO | 0xF600:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Up Undervoltage)) | UINT32 | RO | 0xF600:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 13
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:10, 1
Index 1C00Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x09 (9dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A03 (6659dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A04 (6660dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A05 (6661dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A06 (6662dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A07 (6663dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A08 (6664dez)
Index 1C33SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0022 (34dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x003D0900 (4000000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x00030D40 (200000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 DIG Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | DIG Inputs Ch.1 |  | UINT8 | RO | 0x08 (8dez)
6000:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dez)
Index 6010 DIG Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | DIG Inputs Ch.2 |  | UINT8 | RO | 0x08 (8dez)
6010:01 | Input 1 |  | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Input 2 |  | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Input 3 |  | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Input 4 |  | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Input 5 |  | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Input 6 |  | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Input 7 |  | BOOLEAN | RO | 0x00 (0dez)
6010:08 | Input 8 |  | BOOLEAN | RO | 0x00 (0dez)
Index 6020 AI Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | AI Inputs Ch.1 |  | UINT8 | RO | 0x11 (17dez)
6020:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6030 AI Inputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
6030:0 | AI Inputs Ch.2 |  | UINT8 | RO | 0x11 (17dez)
6030:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6040 AI Inputs Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | AI Inputs Ch.3 |  | UINT8 | RO | 0x11 (17dez)
6040:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6040:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6040:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6050 AI Inputs Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
6050:0 | AI Inputs Ch.4 |  | UINT8 | RO | 0x11 (17dez)
6050:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6050:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6050:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6060 AI Inputs Ch.5
Index | Name | Bedeutung | Datentyp | Flags | Default
6060:0 | AI Inputs Ch.5 |  | UINT8 | RO | 0x11 (17dez)
6060:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6060:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6060:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index 6070 AI Inputs Ch.6
Index | Name | Bedeutung | Datentyp | Flags | Default
6070:0 | AI Inputs Ch.6 |  | UINT8 | RO | 0x11 (17dez)
6070:07 | Error |  | BOOLEAN | RO | 0x00 (0dez)
6070:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)
6070:11 | Value |  | INT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index | Maximum number of modules>Name | Bedeutung | UINT16>Datentyp | RO>Flags | 0x0009 (9dez)>Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance |  | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules |  | UINT16 | RO | 0x0009 (9dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x09 (9dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000118 (280dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000118 (280dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x0000012C (300dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x0000012C (300dez)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x0000012C (300dez)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x0000012C (300dez)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x0000012C (300dez)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x0000012C (300dez)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000168 (360dez)
Index F600 DIG Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | DIG Inputs |  | UINT8 | RO | 0x10 (16dez)
F600:01 | Us Undervoltage |  | BOOLEAN | RO | 0x00 (0dez)
F600:02 | Up Undervoltage |  | BOOLEAN | RO | 0x00 (0dez)
F600:10 | TxPDO Toggle |  | BOOLEAN | RO | 0x00 (0dez)


ELxxxx - Wiederherstellen des Auslieferungszustandes

BECKHOFF ELxxxx: Konfiguration

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).

Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert

Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"

Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.

Inhaltsverzeichnis
• Speicherorte
• Gerätebeschreibung ESI-File/XML
• Versionsbestimmung Firmware
• Update Controller-Firmware *.efw
• Update FPGA-Firmware *.rbf
• Mehrfaches Update

Speicherorte

In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:

  • Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
  • In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
  • Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung zu speichern, in einem sog. EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien (EtherCAT Slave Information) als Zip-Datei zugänglich.

Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.

Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
  • Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
  • Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
  • Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!

Gerätebeschreibung ESI-File/XML

Achtung 		ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.

Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:

Abb. 1: Gerätekennung aus Name EL3204-0000 und Revision -0016

Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.

Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.

Hinweis 		Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes.
Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.

Anzeige der Slave-Kennung ESI

Der einfachste Weg, die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/Freerun das Scannen der EtherCAT-Boxen auszuführen:

Abb. 2: Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes

Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint

Abb. 3: Konfiguration identisch

ansonsten ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.

Abb. 4: Änderungsdialog

In diesem Beispiel in Abb. 4. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.

Änderung der Slave-Kennung ESI

Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:

  • Einwandfreie EtherCAT-Kommunikation muss zum Slave hergestellt werden
  • Der State des Slave ist unerheblich
  • Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. 5

Abb. 5: EEPROM Update

Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. 6. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave'.

Abb. 6: Auswahl des neuen ESI

Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Verifying.

Hinweis 		Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen.
Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.

Versionsbestimmung der Firmware

Versionsbestimmung nach Laseraufdruck

Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 10 03 02:

12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).

Hinweis 		CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
  • online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt.
    Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
  • offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein.
    Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.

In Abb. 7 wird der FW-Stand der markierten EL3204 in CoE-Eintrag x100A mit 03 angezeigt.

Abb. 7: Anzeige FW-Stand EL3204

TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.

Update Controller-Firmware *.efw

Hinweis 		CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.

Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. 8.

Abb. 8: Firmware Update

Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.

  • Slave in INIT schalten (A)
  • Slave in BOOTSTRAP schalten
  • Kontrolle des aktuellen Status (B, C)
  • Download der neuen *efw-Datei
  • Nach Beendigung des Download in INIT schalten, dann in OP
  • Slave kurz stromlos schalten

FPGA-Firmware *.rbf

Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.

  • Controller-Firmware für die Aufbereitung der E/A-Signale
  • FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)

Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.

Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.

Abb. 9: Versionsbestimmung FPGA-Firmware

Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.

Abb. 10: Kontextmenu "Eigenschaften" (Properties)

In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.

Abb. 11: Dialog "Advanced settings"

Update

Für das Update der FPGA-Firmware

  • eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
  • einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.

Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!

Update eines EtherCAT-Geräts

Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.

Abb. 12: Dialog "Weitere Eimstellungen" wählen

Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,

Abb. 13: Dialog "Schreibe FPGA" wählen

Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen!

Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!

Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.

Gleichzeitiges Update mehrerer EtherCAT-Geräte

Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Vorraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.

Abb. 14: mehrfache Selektion und FW-Update

Wählen Sie dazu die betreffenden Slaves aus und führen Sie den FW-Update im BOOTSTRAP Modus wie o.a. aus.


Allgemeine Betriebsbedingungen

Schutzarten nach IP-Code

In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.

1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub

2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist

*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.

Chemische Beständigkeit

Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus Box und den verwendeten Metallteilen.

Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende

beständig: Lebensdauer mehrere Monate
bedingt beständig: Lebensdauer mehrere Wochen
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


EP1816-0008 - Betriebsarten

BECKHOFF EP1816-3008: Montage und Verkabelung

Betriebsarten

2 x 3G Beschleunigungssensoren

Die EtherCAT Box EP1816-3008 verfügt über 2 Stück 3-Achs-Beschleunigungssensoren.

Diese sind um je 90° auf der Unterseite der Platine angebracht.

Die Abbildung zeigt die Draufsicht und die Seitenansicht der EtherCAT-Box. Die Lage der Beschleunigungssensoren ist innerhalb der Box angezeigt, Grün gibt die Lage der Leiterplatte an. Die Beschleunigungssensoren sind mit 1 bis 2 nummeriert, wobei sich die Sensoren auf der Unterseite der Platine befinden.

Durch die Lage der Sensoren auf der Unterseite, wird z.B. die Erdanziehungskraft, auch ein Beschleunigung, in normaler Montage der Box, z.B. beim Test auf dem Labortisch, auf einer flachen, ebenen Unterlage als negativer Wert angezeigt.

Betriebsart - Prozessdaten

Die Daten der Beschleunigungssensoren, jeweils, X-, Y- und Z-Achse, werden per Default als RAW Daten, also direkt wie sie aus dem Sensoren übertragen werden, angezeigt.

Abb.: CoE Objekt 8080:1D

ZUr Darstellung als Winkel muß der CoE Parameter 8080:1D auf den Wert 4, "Horizontal Off-Axis-Angle" eingestellt werden.


EtherCAT Box - Zubehör

Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder unbedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmomentsteckschlüssel mit Ratsche für angespritzte M8-Steckverbinder
ZB8800-0001 | Ratsche für feldkonfektionierbare M8-Steckverbinder
ZB8800-0002 | Ratsche für angespritzte M12-Steckverbinder

Hinweis 		Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter www.beckhoff.de.