EP1518 - 8 Eingänge, 2 Zähler
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.1.0
▪
Sicherheitshinweise neues Layout
▪
Update Kapitel Montage
2.0.0
▪
Migration
▪
Kapitel Grundlagen zur Funktion korrigiert
1.1.0
▪
Power-Anschluss aktualisiert
1.0.0
▪
Erste Veröffentlichung
Firm- und Hardware-Stände
Diese Dokumentation bezieht sich auf den zum Zeitpunkt ihrer Erstellung gültigen Firm- und Hardware-Stand.
Die Eigenschaften der Module werden stetig weiterentwickelt und verbessert. Module älteren Fertigungsstandes können nicht die gleichen Eigenschaften haben, wie Module neuen Standes. Bestehende Eigenschaften bleiben jedoch erhalten und werden nicht geändert, so dass ältere Module immer durch neue ersetzt werden können.
Dokumentation Version | EP1518-0002
 | Firmware | Hardware
2.1 | 04 | 06
2.0.0 | 04 | 05
1.0.0 | 02 | 00
Den Firm- und Hardware-Stand (Auslieferungszustand) können Sie der auf der Seite der EtherCAT Box aufgedruckten Batch-Nummer (D-Nummer) entnehmen.
Syntax der Batch-Nummer (D-Nummer)
WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit D. Nr.: 55 09 01 00:
55 - Produktionswoche 55
09 - Produktionsjahr 2009
01 - Firmware-Stand 01
00 - Hardware-Stand 001


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EtherCAT Box - Einführung
•
EP1518 - Einführung
•
EP1518 - Technische Daten
•
EP1518 - Prozessabbild


EtherCAT Box - Einführung

Produktübersicht [image] EtherCAT Box - Einführung
EtherCAT Box - Einführung
Das EtherCAT-System wird durch die EtherCAT-Box-Module in Schutzart IP67 erweitert. Durch das integrierte EtherCAT-Interface sind die Module ohne eine zusätzliche Kopplerbox direkt an ein EtherCAT-Netzwerk anschließbar. Die hohe EtherCAT-Performance bleibt also bis in jedes Modul erhalten.
Die außerordentlich geringen Abmessungen von nur 126 x 30 x 26,5 mm (H x B x T) sind identisch zu denen der Feldbus Box Erweiterungsmodule. Sie eignen sich somit besonders für Anwendungsfälle mit beengten Platzverhältnissen. Die geringe Masse der EtherCAT-Module begünstigt u. a. auch Applikationen, bei denen die I/O-Schnittstelle bewegt wird (z. B. an einem Roboterarm). Der EtherCAT-Anschluss erfolgt über geschirmte M8-Stecker.
EtherCAT-Box-Module in einem EtherCAT-Netzwerk
Die robuste Bauweise der EtherCAT-Box-Module erlaubt den Einsatz direkt an der Maschine. Schaltschrank und Klemmenkasten werden hier nicht mehr benötigt. Die Module sind voll vergossen und daher ideal vorbereitet für nasse, schmutzige oder staubige Umgebungsbedingungen.
Durch vorkonfektionierte Kabel vereinfacht sich die EtherCAT- und Signalverdrahtung erheblich. Verdrahtungsfehler werden weitestgehend vermieden und somit die Inbetriebnahmezeiten optimiert. Neben den vorkonfektionierten EtherCAT-, Power- und Sensorleitungen stehen auch feldkonfektionierbare Stecker und Kabel für maximale Flexibilität zur Verfügung. Der Anschluss der Sensorik und Aktorik erfolgt je nach Einsatzfall über M8- oder M12-Steckverbinder.
Die EtherCAT-Module decken das typische Anforderungsspektrum der I/O-Signale in Schutzart IP67 ab:
▪
digitale Eingänge mit unterschiedlichen Filtern (3,0 ms oder 10 μs)
▪
digitale Ausgänge mit 0,5 oder 2 A Ausgangsstrom
▪
analoge Ein- und Ausgänge mit 16 Bit Auflösung
▪
Thermoelement- und RTD-Eingänge
▪
Schrittmotormodule
Auch XFC (eXtreme Fast Control Technology)-Module wie z. B. Eingänge mit Time-Stamp sind verfügbar.
EtherCAT Box mit M8-Anschlüssen für Sensor/Aktoren
EtherCAT Box mit M12-Anschlüssen für Sensor/Aktoren
Basis-Dokumentation zu EtherCAT
Eine detaillierte Beschreibung des EtherCAT-Systems finden Sie in der System Basis-Dokumentation zu EtherCAT, die auf unserer Homepage (www.beckhoff.de) unter Downloads zur Verfügung steht.
XML-Dateien
XML -Dateien (XML Device Description Files) zu EtherCAT-Modulen von Beckhoff finden Sie unter auf unserer Homepage (www.beckhoff.de) unter Downloads im Bereich Konfigurations-Dateien.


EP1518 - Einführung

Produktübersicht [image] EP1518 - Einführung
EP1518 - Einführung
EP1518-0001 und EP1518-0002
8 digitale Eingänge (24 VDC), zwei Zähler
Die EtherCAT-Box EP1518-0002 mit digitalen Eingängen erfasst binäre Steuersignale aus der Prozessebene und übertragen sie galvanisch getrennt zur Steuerung.
Der Signalzustand wird über Leuchtdioden angezeigt. Der Anschluss erfolgt über M12-Steckverbinder. Die Eingangsfilter können über EtherCAT zwischen 0 und 100 ms eingestellt werden.
Die Eingänge 0 und 4 lassen sich als Vorwärts/Rückwärts-Zähler (32 Bit-) nutzen. Dabei arbeiten die Eingänge 1 und 5 als GATE und die Eingänge 2 und 6 steuern Up/Down.
Die EP1518 verfügt über drei Betriebsarten, die sich über die PDOs per Sync-Manager auswählen lassen:
▪
2 digitale Eingänge und 2 Zähler (Auslieferungszustand)
▪
5 digitale Eingänge und 1 Zähler
▪
8 digitale Eingänge
Auch in den Zähler-Betriebsarten werden alle Eingänge weiterhin im Prozessabbild dargestellt. Dabei erfolgt die Signalerfassung mit den über CoE eingestellten Filterzeiten.
Die Zähler-Pulse werden aber unabhängig davon immer mit einem Filter von 150 µs gezählt. Weitere Parameter lassen sich über die CoE-Objekte einstellen.
Die Sensoren werden in zwei Gruppen à vier Sensoren aus der Steuerspannung US versorgt. Ein Kurzschluss auf der Sensorseite wird detektiert und an die Steuerung gemeldet.
Die Lastspannung UP wird im Eingangsmodul nicht verwendet, sie kann jedoch optional zur Weiterleitung angeschlossen werden.
Quick-Links
▪
Installation
▪
Konfiguration


EP1518 - Technische Daten

Produktübersicht [image] EP1518 - Technische Daten
EP1518 - Technische Daten
Technische Daten | EP1518-0001 | EP1518-0002
Feldbus | EtherCAT
Feldbusanschluss | 2 x M8 Buchse (grün)
Anzahl Eingänge | 8, davon 2 als 32-Bit-V/R-Zähler nutzbar
Anschluss Eingänge | M8 | M12
Nennspannung Eingänge | 24 VDC (-15%/+20%)
Eingangsfilter (binäre Eingänge) | einstellbar 10 µs…100 ms
Eingangsfilter (Zählereingang ) | 150 µs
Signalspannung "0" | -3...+5 V (EN 61131-2, Typ 3)
Signalspannung "1" | +11...+30 V (EN 61131-2, Typ 3)
Eingangsstrom | typisch 3 mA (EN 61131-2, Typ 3)
Versorgung der Modulelektronik | aus der Steuerspannung Us
Stromaufnahme der Modulelektronik | typisch 120 mA
Versorgung der Sensoren | aus der Steuerspannung Us
Stromaufnahme der Sensoren | max. 0,5 A je 4 Sensoren, kurzschlussfest
Anschluss Spannungsversorgung | Einspeisung: 1 x M8 Stecker, 4-polig Weiterleitung: 1 x M8 Buchse, 4-polig
Eingangsprozessabbild | 8 Bit Daten, 8 Bit Diagnose, 48 Bit Zähler
Ausgangsprozessabbild | 48 Bit Zähler
Distributed-Clocks | ja
Potenzialtrennung Steuerspannung / Feldbus | 500 V
Gewicht | ca. 165 g
Zulässige Umgebungstemperatur im Betrieb | -25°C ... +60°C 0°C ... +55°C (gemäß cULus, siehe UL-Anforderungen) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen)
Zulässige Umgebungstemperatur bei Lagerung | -40°C ... +85°C
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP65, IP66, IP67 (gemäß EN 60529)
Einbaulage | beliebig
Zulassungen | CE, cULus, ATEX


EP1518 - Prozessabbild

Produktübersicht [image] EP1518 - Prozessabbild
EP1518 - Prozessabbild
Das Prozessabbild hängt von der gewählten Betriebsart ab.
Betriebsart: 2 Zähler und 2 digitale Eingänge (Auslieferungszustand)
Unter CNT Input Channel 1 finden Sie die Input-Daten des 1. Zählers.
Mit Set counter done wird die Übernahme des Bit Set counter aus dem CNT Output Channel 1 angezeigt.
Mit Counter inhibited wird die Übernahme des Bit Inhibit counter aus dem CNT Output Channel 1 angezeigt.
Status of input UD zeigt den Status des Up-/Down Counter-Eingangs des 1. Zählers.
Status of input clock zeigt den Status des Input-Cock-Eingangs des 1. Zählers.
Sync Error, TxPDO State und TxPDO Toggle sind Standard EtherCAT Processdaten.
Unter CNT Input Channel 2 finden Sie die Input-Daten des 2. Zählers. Ihre Struktur entsprechen der des 1. Zählers.
DIG Inputs zeigt die Stati der einzelnen Eingänge, unabhängig von der gewählten Betriebsart.
Error channel 1 zeigt einen Kurzschluss der Versorgungsspannung Us an den digitalen Eingängen 0 bis 3 an.
Error channel 2 zeigt einen Kurzschluss der Versorgungsspannung Us an den digitalen Eingängen 4 bis 7 an.
Unter CNT Output Channel 1 finden Sie die Output Daten des 1. Zählers.
Das Setzen von Set counter aktiviert die Übernahme des Set counter Value in den Counter Value des 1. Zählers.
Das Setzen von Inhibit Counter sperrt den 1. Zähler.
Alternativ kann der Zähler durch den physikalischen Eingang GATE gesperrt bzw. freigeschaltet werden.
Beide Werte werden per XOR verknüpft.
Unter CNT Output Channel 1 finden Sie die Output Daten des 2. Zählers. Ihre Struktur entsprechen der des 1. Zählers.
Betriebsart: 1 Zähler und 5 digitale Eingänge
Unter CNT Input Channel 1 finden Sie die Input-Daten des 1. Zählers.
Mit Set counter done wird die Übernahme des Bit Set counter aus dem CNT Output Channel 1 angezeigt.
Mit Counter inhibited wird die Übernahme des Bit Inhibit counter aus dem CNT Output Channel 1 angezeigt.
Status of input UD zeigt den Status des Up-/Down Counter Eingangs des 1. Zählers.
Status of input clock zeigt den Status des Input-Cock-Eingangs des 1. Zählers.
Sync Error, TxPDO State und TxPDO Toggle sind Standard EtherCAT Processdaten.
DIG Inputs zeigt die Stati der einzelnen Eingänge, unabhängig von der gewählten Betriebsart.
Error channel 1 zeigt einen Kurzschluss der Versorgungsspannung Us an den digitalen Eingängen 0 bis 3 an.
Error channel 2 zeigt einen Kurzschluss der Versorgungsspannung Us an den digitalen Eingängen 4 bis 7 an.
Unter CNT Output Channel 1 finden Sie die Output Daten des 1. Zählers.
Das Setzen von Set counter aktiviert die Übernahme des Set counter Value in den Counter Value des 1. Zählers.
Das Setzen von Inhibit Counter sperrt den 1. Zähler.
Alternativ kann der Zähler durch den physikalischen Eingang GATE gesperrt bzw. freigeschaltet werden.
Beide Werte werden per XOR verknüpft.
Betriebsart: 8 digitale Eingänge
DIG Inputs zeigt die Stati der einzelnen Eingänge, unabhängig von dem gewählten Modus.
Error channel 1 zeigt einen Kurzschluss der Versorgungsspannung Us an digitalen Eingängen 0 bis 3 an.
Error channel 2 zeigt einen Kurzschluss der Versorgungsspannung Us an digitalen Eingängen 4 bis 7 an.


Installation

Installation
Installation
Weiterführende Informationen
•
Montage
•
Anschluss
•
UL-Anforderungen
•
ATEX-Hinweise


Montage

Installation [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Befestigung
•
Anzugsmomente für Steckverbinder


Abmessungen

Installation [image] Montage [image] Abmessungen
Abmessungen
Dimensions
Alle Maßangaben sind in Millimeter angegeben.
Gehäuseeigenschaften
EtherCAT Box | Schmales Gehäuse | Breite Gehäuse
Gehäusematerial | PA6 (Polyamid)
Vergussmasse | Polyuhrethan
Montage | zwei Befestigungslöcher Ø 3 mm für M3 | zwei Befestigungslöcher Ø 3 mm für M3 zwei Befestigungslöcher Ø 4,5 mm für M4
Metallteile | Messing, vernickelt
Kontakte | CuZn, vergoldet
Stromweiterleitung | max. 4 A (M8) max. 16 A (7/8“) max. 15,5 A (B17 5G 1,5 mm2)
Einbaulage | beliebig
Schutzart | im verschraubten Zustand IP65, IP66, IP67 (gemäß EN 60529)
Abmessungen (H x B x T) | ca. 126 x 30 x 26,5 mm | ca. 126 x 60 x 26,5 mm ca. 150 x 60 x 26,5 mm (ohne 7/8“, B17)


Befestigung

Installation [image] Montage [image] Befestigung
Befestigung
Anschlüsse vor Verschmutzung schützen!
Schützen Sie während der Montage der Module alle Anschlüsse vor Verschmutzung! Die Schutzart IP65 ist nur gewährleistet, wenn alle Kabel und Stecker angeschlossen sind! Nicht benutzte Anschlüsse müssen mit den entsprechenden Steckern geschützt werden! Steckersets siehe Katalog.
Module mit schmalem Gehäuse werden mit zwei M3-Schrauben montiert.
Module mit breitem Gehäuse werden mit zwei M3-Schrauben an den in den Ecken angeordneten oder mit zwei M4-Schrauben an den zentriert angeordneten Befestigungslöchern montiert.
Die Schrauben müssen länger als 15 mm sein. Die Befestigungslöcher der Module besitzen kein Gewinde.
Beachten Sie bei der Montage, dass die Feldbusanschlüsse die Gesamthöhe noch vergrößert. Siehe Kapitel Zubehör.
Montageschiene ZS5300-0001
Die Montageschiene ZS5300-0001 (500 mm x 129 mm) ermöglicht einen zeitsparenden Aufbau der Module.
Die Schiene besteht aus rostfreiem Stahl (V2A), ist 1,5 mm stark mit passend vorgefertigten M3-Gewinden. Die Schiene hat 5,3 mm Langlöcher um sie mit M5-Schrauben an der Maschine zu befestigen.
Montageschiene ZS5300-0001
Die Montageschiene ist 500 mm lang und erlaubt bei einem Modulabstand von 2 mm die Montage von 15 schmalen Modulen. Sie kann applikationsspezifisch gekürzt werden.
Montageschiene ZS5300-0011
Die Montageschiene ZS5300-0011 (500 mm x 129 mm) bietet neben den M3- auch vorgefertigte M4-Gewinde zur Befestigung der 60 mm breiten Module über deren mittlere Bohrungen.
Bis zu 14 schmale oder 7 breite Module können gemischt montiert werden.


Anzugsmomente für Steckverbinder

Installation [image] Montage [image] Anzugsmomente für Steckverbinder
Anzugsmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern
M12-Steckverbinder
Es wird empfohlen die M12-Steckverbinder mit einem Drehmoment von 0,6 Nm festzuziehen.
EtherCAT Box mit M8- und M12-Steckverbindern
7/8"-Steckverbinder
Es wird empfohlen die 7/8"-Steckverbinder mit einem Drehmoment von 1,5 Nm festzuziehen.
7/8"-Steckverbinder
Drehmomentschlüssel
Drehmomentschlüssel ZB8801
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen (ZB8800, ZB8801-0000)!


Anschluss

Installation [image] Anschluss
Anschluss
Weiterführende Informationen
•
EtherCAT-Anschluss
•
EtherCAT-LEDs
•
Power-Anschluss
•
EP1518 - Status-LEDs für die Spannungsversorgung
•
Power-Kabel
•
Leitungsverluste M8
•
Signalanschluss
•
Status-LEDs an den Signalanschlüssen


EtherCAT-Anschluss

Installation [image] Anschluss [image] EtherCAT-Anschluss
EtherCAT-Anschluss
Für den ankommenden und weiterführenden EtherCAT-Anschluss verfügt
▪
die EtherCAT Box (EPxxxx) über zwei grün gekennzeichnete M8-Buchsen
▪
die Koppler Box (FBB-x110) über zwei M12-Buchsen
EtherCAT Box: M8, 30 mm Gehäuse
EtherCAT Box: M8 60 mm Gehäuse (am Beispiel EP9214)
Koppler Box: M12
Belegung
Es gibt verschiedene Standards für die Belegung und Farben bei Steckverbindern und Leitung für Ethernet/EtherCAT.
Ethernet/EtherCAT |  | Steckverbinder |  |  | Leitung |  | Norm
Signal | Beschreibung | M8 | M12 | RJ451 | ZB9010, ZB9020, ZB9030, ZB9032, ZK1090-6292, ZK1090-3xxx-xxxx | ZB9031 und alte Versionen von ZB9030, ZB9032, ZK1090-3xxx-xxxx | TIA-568B
Tx + | Transmit Data+ | Pin 1 | Pin 1 | Pin 1 | gelb2 | orange/weiß3 | weiß/orange
Tx - | Transmit Data- | Pin 4 | Pin 3 | Pin 2 | orange2 | orange3 | orange
Rx + | Receive Data+ | Pin 2 | Pin 2 | Pin 3 | weiß2 | blau/weiß3 | weiß/grün
Rx - | Receive Data- | Pin 3 | Pin 4 | Pin 6 | blau2 | blau3 | grün
Shield | Abschirmung | Gehäuse |  | Schirmblech | Schirm | Schirm | Schirm
1) farbliche Markierungen nach EN 61918 im vierpoligen RJ45-Steckverbinder ZS1090-0003
2) Aderfarben nach EN 61918
3) Aderfarben
Anpassung der Farbkodierung für die Leitungen ZB9030, ZB9032 und ZK1090-3xxxx-xxxx (mit M8-Steckverbindern)
Zur Vereinheitlichung wurden die gängigen Leitungen ZB9030, ZB9032 und ZK1090-3xxx-xxxx, also die mit M8-Steckverbindern vorkonfektionierten Leitungen auf die Farben der EN61918 umgestellt (gelb, orange, weiß, blau). Es sind also verschiedene Farbkodierungen im Umlauf. Die elektrischen Eigenschaften sind aber absolut identisch!
EtherCAT-Steckverbinder
Die folgenden Steckverbinder sind für den Einsatz in EtherCAT-Systemen von Beckhoff lieferbar.
Bezeichnung | Steckverbinder | Kommentar
ZS1090-0003 | RJ45 | vierpolig, IP20, feldkonfektionierbar
ZS1090-0004 | M12-Stecker | vierpolig, IP67, feldkonfektionierbar
ZS1090-0005 | RJ45 | achtpolig, IP20, feldkonfektionierbar, geeignet GigaBit-Ethernet
ZS1090-0006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-0007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar, für Kabel ZB903x
ZS1090-1006 | M8-Stecker | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm
ZS1090-1007 | M8-Buchse | vierpolig, IP67, feldkonfektionierbar bis OD = 6,5 mm


EtherCAT-LEDs

Installation [image] Anschluss [image] EtherCAT-LEDs
EtherCAT-LEDs
EtherCAT-LEDs
LED-Anzeigen
LED | Anzeige | Bedeutung
IN L/A | aus | keine Verbindung zum vorhergehenden EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum vorhergehenden EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit vorhergehenden EtherCAT-Modul
OUT L/A | aus | keine Verbindung zum nachfolgendem EtherCAT-Modul
 | leuchtet | LINK: Verbindung zum nachfolgendem EtherCAT-Modul
 | blinkt | ACT: Kommunikation mit nachfolgendem EtherCAT-Modul
Run | aus | EtherCAT-Modul ist im Status Init
 | blinkt schnell | EtherCAT-Modul ist im Status Pre-Operational
 | blinkt langsam | EtherCAT-Modul ist im Status Safe-Operational
 | leuchtet | EtherCAT-Modul ist im Status Operational
EtherCAT-Stati
Die verschiedenen Stati, eines EtherCAT-Moduls sind in der System Basis-Dokumentation zu EtherCAT beschrieben, die auf unserer Homepage (https://www.beckhoff.de/) unter Downloads zur Verfügung steht.


Power-Anschluss

Installation [image] Anschluss [image] Power-Anschluss
Power-Anschluss
Die Einspeisung und Weiterleitung der Versorgungsspannungen erfolgt über zwei M8-Steckverbinder am unteren Ende der Module:
▪
IN: linker M8-Steckverbinder zur Einspeisung der Versorgungsspannungen
▪
OUT: rechter M8-Steckverbinder zur Weiterleitung der Versorgungsspannungen
EtherCAT Box, Anschlüsse für die Versorgungsspannungen
Pinbelegung M8, Power In und Power Out
Kontaktbelegung
Kontakt | Spannung
1 | Steuerspannung Us, +24 VDC
2 | Peripheriespannung Up, +24 VDC
3 | GNDs* | *) können je nach Modul intern miteinander verbunden sein: siehe einzelne Modulbeschreibungen
4 | GNDp*
Die Kontakte der M8-Steckverbinder tragen einen maximalen Strom von 4 A.
Zwei LEDs zeigen den Status der Versorgungsspannungen an.
Hinweis
Power-Anschluss nicht mit EtherCAT-Anschluss verwechseln!
Verbinden Sie die Powerkabel (M8, 24 VDC) nie mit den grün gekennzeichneten EtherCAT-Buchsen der EtherCAT Box Module. Dies kann die Zerstörung der Module verursachen!
Steuerspannung Us: 24 VDC
Aus der 24 VDC Steuerspannung Us werden der Feldbus, die Prozessor-Logik, die Eingänge und auch die Sensorik versorgt. Die Steuerspannung ist galvanisch von Feldbusteil getrennt.
Peripheriespannung Up: 24 VDC
Die Peripheriespannung Up versorgt die digitalen Ausgänge, sie kann separat zugeführt werden. Wird die Lastspannung abgeschaltet, so bleiben die Feldbus-Funktion sowie Versorgung und Funktion der Eingänge erhalten.
Weiterleitung der Versorgungsspannungen
Die Power-Anschlüsse IN und OUT sind im Modul gebrückt. Somit können auf einfache Weise die Versorgungsspannungen Us und Up von EtherCAT Box zu EtherCAT Box weitergereicht werden.
Hinweis
Maximalen Strom beachten!
Beachten Sie auch bei der Weiterleitung der Versorgungsspannungen Us und Up, dass jeweils der für die M8-Steckverbinder maximal zulässige Strom von 4 A nicht überschritten wird!
Versorgung über PowerBox Module EP92x4-0023
Benötigt die Maschine größere Ströme oder sind die EtherCAT Box Module weit vom Schaltschrank und der darin befindlichen Spannungsversorgung entfernt installiert, so empfiehlt sich der Einsatz der vierkanaligen Powerverteilungsmodule EP9214 oder EP9224 (mit integriertem Data Logging, siehe www.beckhoff.de/EP9224).
Mit diesen Modulen lassen sich intelligente Powerverteilungskonzepte mit bis zu 2 x 16 A und maximal 2,5 mm² Leitungsquerschnitt im Feld realisieren.
EP92x4-0023, Anschlüsse Power In und Power Out
Pinbelegung 7/8“, Power IN und Power Out
Galvanische Trennung
Digitale Module
Bei den digitalen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) ggfs. miteinander verbunden!
Überprüfen Sie dies in der Dokumentation jeder verwendeten EtherCAT Box.
Analoge Module
Bei den analogen Ein-/Ausgabemodulen sind die Massen von Steuerspannung (GNDs) und Peripheriespannung (GNDp) galvanisch voneinander getrennt, um die galvanische Trennung der Analogsignale von der Steuerspannung zu gewährleisten.
Bei einigen Analogmodulen wird die Sensorik bzw. Aktorik aus Up versorgt - damit kann z.B. bei 0 bis 10 V Eingängen eine beliebige Referenzspannung (0 bis 30 V) an Up angeschlossen werden. Diese steht dann den Sensoren zur Verfügung (z.B. geglättete 10 V für Messpotentiometer).
Details der Spannungsversorgung entnehmen sie bitte den einzelnen Modulbeschreibungen.
Hinweis
Galvanische Trennung kann aufgehoben werden!
Wenn Sie unterschiedliche EtherCAT Boxen direkt über vierpolige Powerleitungen verbinden, so kann die galvanische Trennung der Analogsignale u.U. nicht mehr gegeben sein!


EP1518 - Status-LEDs für die Spannungsversorgung

Installation [image] Anschluss [image] EP1518 - Status-LEDs für die Spannungsversorgung
EP1518 - Status-LEDs für die Spannungsversorgung
Status-LEDs für die Spannungsversorgung
In der Initialisierungsphase der Box werden alle LEDs, grün und rot, einmal kurz angesteuert.
LED | Anzeige | Bedeutung
Us (Steuerspannung) | aus | Versorgungsspannung Us nicht vorhanden
 | leuchtet grün | Versorgungsspannung Us vorhanden
 | leuchtet rot | Wegen Überlastung (Strom > 0,5 A) wurde die aus Versorgungsspannung Us erzeugte Sensorversorgung für alle daraus gespeisten Sensoren der Grupppe1 (Eingang 0 bis 3) oder Gruppe 2 (Eingang 4 bis 7) abgeschaltet.
Up (Peripheriespannung) | aus | Versorgungsspannung Up nicht vorhanden
 | leuchtet grün | Versorgungsspannung Up vorhanden


Power-Kabel

Installation [image] Anschluss [image] Power-Kabel
Power-Kabel
Bestelldaten
Bestellbezeichnung | Power-Kabel | Schraub-Steckverbinder | Kontakte | Querschnitt | Länge
ZK2020-3200-0020 | Buchse gerade, offenes Ende | M8 | 4-polig | 0,34 mm2 | 2,00 m
ZK2020-3200-0050 |  |  |  |  | 5,00 m
ZK2020-3200-0100 |  |  |  |  | 10,00 m
ZK2020-3400-0020 | Buchse gewinkelt, offenes Ende |  |  |  | 2,00 m
ZK2020-3400-0050 |  |  |  |  | 5,00 m
ZK2020-3400-0100 |  |  |  |  | 10,00 m
ZK2020-3132-0001 | Buchse gerade, Stecker gerade |  |  |  | 0,15 m
ZK2020-3132-0005 |  |  |  |  | 0,50 m
ZK2020-3132-0010 |  |  |  |  | 1,00 m
ZK2020-3132-0020 |  |  |  |  | 2,00 m
ZK2020-3132-0050 |  |  |  |  | 5,00 m
ZK2020-3334-0001 | Buchse gewinkelt, Stecker gewinkelt |  |  |  | 0,15 m
ZK2020-3334-0005 |  |  |  |  | 0,50 m
ZK2020-3334-0010 |  |  |  |  | 1,00 m
ZK2020-3334-0020 |  |  |  |  | 2,00 m
ZK2020-3334-0050 |  |  |  |  | 5,00 m
Weitere verfügbare Powerkabel und die dazugehörigen Datenblätter finden Sie im Beckhoff Katalog oder auf unseren Internet-Seiten (http://www.beckhoff.de).
Technische Daten
Daten
Bemessungsspannung nach IEC61076-2-101 | 30 VDC
Verschmutzungsgrad nach IEC 60 664-1 | 3/2
Isolationswiderstand IEC 60 512-2 | >109Ω
Strombelastbarkeit IEC 60512-3 | 4 A
Durchgangswiderstand IEC 60512-2 | < 5 mΩ
Schutzart nach IEC 60529 | IP65/IP66/IP67, im verschraubten Zustand
Umgebungstemperatur | -30°C bis +80°C


Leitungsverluste M8

Installation [image] Anschluss [image] Leitungsverluste M8
Leitungsverluste M8
Bei den Powerkabeln ZK2020-xxxx-yyyy sollten 15 m Gesamtlänge bei 4 A (mit Weiterleitung) nicht überschritten werden. Achten Sie bei der Verkabelung darauf, dass bei 24 V Nennspannung ab einem Spannungsabfall von 6 V die Funktionalität der Module nicht mehr gewährleistet werden kann. Außerdem sind Spannungsschwankungen des Netzteils zu berücksichtigen.
Leitungsverluste auf den Powerkabeln
Beispiel
8 m Powerkabel mit 0,34 mm² hat bei 4 A Belastung einen Spannungsabfall von 3,2 V.
Powerverteilungs-Module EP92x4-0023
Mit den Powerverteilungs-Modulen EP9214 und EP9224 sind intelligente Spannungsverteilungskonzepte verfügbar. Weitere Information finden sie unter www.beckhoff.de/EP9224


Signalanschluss

Installation [image] Anschluss [image] Signalanschluss
Signalanschluss
Digitale Eingänge M8 und M12
Die digitalen Eingangsmodule erfassen die binären Steuersignale aus der Prozessebene und transportieren sie zum übergeordneten Automatisierungsgerät.
Der Signalanschluss erfolgt über M8-Steckverbinder (EPxxxx-0001) oder M12-Steckverbinder (EPxxxx-0002).
Signalanschluss - Digitale Eingänge M8 und M12
Die Sensoren werden aus der Steuerspannung Us mit einem gemeinsamen, maximalen Strom von 0,5 A versorgt.
Leuchtdioden zeigen den Signalzustand der Eingänge an.


Status-LEDs an den Signalanschlüssen

Installation [image] Anschluss [image] Status-LEDs an den Signalanschlüssen
Status-LEDs an den Signalanschlüssen
Jeder Kanal zeigt unabhängig von der eingestellten Betriebsart, den Status seines angeschlossenen Sensors durch eine grüne LED neben der Signalbuchse an.
Status-LEDs an den Signalanschlüssen
Anschluss | LED | Anzeige | Bedeutung
M12-Buchse Nr. 1 | Kanal 0, Kanal 1 | aus | Eingang nicht gesetzt
 |  | grün | Eingang gesetzt
M12-Buchse Nr. 2 | Kanal 2, Kanal 3 | aus | Eingang nicht gesetzt
 |  | grün | Eingang gesetzt
M12-Buchse Nr. 3 | Kanal 4, Kanal 5 | aus | Eingang nicht gesetzt
 |  | grün | Eingang gesetzt
M12-Buchse Nr. 4 | Kanal 6, Kanal 7 | aus | Eingang nicht gesetzt
 |  | grün | Eingang gesetzt


UL-Anforderungen

Installation [image] UL-Anforderungen
UL-Anforderungen
Die Installation der nach UL zertifizierten EtherCAT Box Module muss den folgenden Anforderungen entsprechen.
Versorgungsspannung
SmallWarningYellow VORSICHT
VORSICHT!
Die folgenden genannten Anforderungen gelten für die Versorgung aller so gekennzeichneten EtherCAT Box Module.
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur mit einer Spannung von 24 VDC versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit unbegrenzten Spannungsquellen verbunden werden!
Netzwerke
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nicht mit Telekommunikations-Netzen verbunden werden!
Umgebungstemperatur
SmallWarningYellow VORSICHT
VORSICHT!
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT Box Module nur in einem Umgebungstemperaturbereich von 0 bis 55°C betrieben werden!
Kennzeichnung für UL
Alle nach UL (Underwriters Laboratories) zertifizierten EtherCAT Box Module sind mit der folgenden Markierung gekennzeichnet.
UL-Markierung


ATEX-Hinweise

Installation [image] ATEX-Hinweise
ATEX-Hinweise
Weiterführende Informationen
•
ATEX - Besondere Bedingungen
•
BG2000-0000 - Schutzgehäuse für EtherCAT Box
•
ATEX-Dokumentation


ATEX - Besondere Bedingungen

Installation [image] ATEX-Hinweise [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen – Richtlinie 94/9/EG!
•
Die zertifizierten Komponenten sind mit dem Schutzgehäuse BG2000-0000 zu errichten, das einen Schutz gegen mechanische Gefahr gewährleistet!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von EtherCAT-Box-Modulen in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten EtherCAT-Box-Module tragen folgende Kennzeichnung:
II 3 G Ex nA II T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 DEKRA 11ATEX0080 X Ta: 0 - 55°C
Batch-Nummer (D-Nummer)
Die EtherCAT-Box-Module tragen eine Batch-Nummer (D-Nummer), die wie folgt aufgebaut ist:
D: KW JJ FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 29 10 02 01:
29 - Produktionswoche 29
10 - Produktionsjahr 2010
02 - Firmware-Stand 02
01 - Hardware-Stand 01


BG2000-0000 - Schutzgehäuse für EtherCAT Box

Installation [image] ATEX-Hinweise [image] BG2000-0000 - Schutzgehäuse für EtherCAT Box
BG2000-0000 - Schutzgehäuse für EtherCAT Box
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das EtherCAT-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Module beginnen!
ATEX
Das Schutzgehäuse BG2000-0000 wird über eine einzelne EtherCAT Box montiert, um die Einhaltung der besonderen Bedingungen gemäß ATEX zu erfüllen.
Installation
Schieben Sie die Anschlussleitungen für EtherCAT, Spannungsversorgung und die Sensoren/Aktoren durch die Öffnung des Schutzgehäuses BG2000-0000.
BG2000-0000, Anschlussleitungen durchschieben
Schrauben Sie die Anschlussleitungen für die EtherCAT, Spannungsversorgung und die Sensoren/Aktoren an der EtherCAT Box fest.
BG2000-0000, Anschlussleitungen festschrauben
Montieren Sie das Schutzgehäuses BG2000-0000 über der EtherCAT Box.
BG2000-0000, Schutzgehäuse montieren


ATEX-Dokumentation

Installation [image] ATEX-Hinweise [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation
Hinweise zum Einsatz von EtherCAT-Box-Modulen (EPxxxx-xxxx) in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme und Konfiguration

Inbetriebnahme und Konfiguration
Inbetriebnahme und Konfiguration
Weiterführende Informationen
•
Einbinden im TwinCAT
•
Konfiguration der EP1518
•
CoE Objekte


Einbinden im TwinCAT

Inbetriebnahme und Konfiguration [image] Einbinden im TwinCAT
Einbinden im TwinCAT
Weiterführende Informationen
•
Einfügen in das EtherCAT-Netzwerk
•
Konfiguration mit TwinCAT
•
Distributed Clocks (DC)
•
Distributed Clocks und EP1518


Einfügen in das EtherCAT-Netzwerk

Inbetriebnahme und Konfiguration [image] Einbinden im TwinCAT [image] Einfügen in das EtherCAT-Netzwerk
Einfügen in das EtherCAT-Netzwerk
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen (http://www.beckhoff.de/german/download/elconfg.htm?id=1983920606140) und entsprechend der Installationsanweisungen installiert werden.
Der Konfigurationsbaum im Beckhoff TwinCAT SystemManager kann auf 2 Wegen erstellt werden:
▪
durch Einscannen vorhandener Hardware (genannt "online") und
▪
durch manuelles Einfügen/Anhängen von Feldbus-Geräten, Kopplern und Slaves.
Automatisches Einscannen der Box
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode) und scannen Sie die Geräte ein. Bestätigen Sie alle folgenden Dialoge mit OK, so dass sich die Konfiguration im Modus FreeRun befindet.
Einscannen der Konfiguration (E/A-Geräte -> Rechte Maustaste -> Geräte suchen...)
Manuelles Anfügen eines Moduls
▪
Das EtherCAT-System muss sich in einem sicheren, spannungslosen Zustand befinden bevor Sie die EtherCAT-Module an das EtherCAT-Netzwerk anschließen.
▪
Nach Einschalten der Betriebsspannung öffnen Sie den TwinCAT System Manager (Config-Mode)
▪
Fügen Sie ein neues E/A-Gerät an. Im nachfolgenden Dialog wählen Sie das Gerät EtherCAT (Direct Mode), bestätigen Sie mit OK.
Anfügen eines neuen E/A-Gerätes (E/A-Geräte -> Rechte Maustaste -> Gerät anfügen...)
Auswahl des Gerätes (EtherCAT)
▪
Fügen Sie eine neue Box an.
Anfügen einer neuen Box (Gerät -> Rechte Maustaste -> Box anfügen...)
▪
Im angezeigten Dialog wählen Sie die gewünschte Box (z.B.: EP2816-0008), bestätigen Sie mit OK.
Auswahl einer Box (z.B.: EP2816-0008)
Angefügte Box im TwinCAT-Baum


Konfiguration mit TwinCAT

Inbetriebnahme und Konfiguration [image] Einbinden im TwinCAT [image] Konfiguration mit TwinCAT
Konfiguration mit TwinCAT
Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der EtherCAT Box die Sie konfigurieren möchten (in diesem Beispiel EP2816-0008).
Baumzweig der zu konfigurierende EtherCAT Box
Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der EtherCAT Box zur Verfügung.
Karteireiter Allgemein
Karteireiter Allgemein
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter EtherCAT
Karteireiter EtherCAT
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter Prozessdaten
Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter Prozessdaten
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
•
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
•
der System Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.
Karteireiter Startup
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter Startup
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter CoE - Online
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter CoE - Online
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Erweiterte Einstellungen
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter Online
Karteireiter Online
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Distributed Clocks (DC)

Inbetriebnahme und Konfiguration [image] Einbinden im TwinCAT [image] Distributed Clocks (DC)
Distributed Clocks (DC)
EtherCAT-Systemdokumentation
Auf der Beckhoff Homepage steht Ihnen im Bereich Download die eine grundlegende Einführung in das Thema EtherCAT und Distributed Clocks zur Verfügung: EtherCAT-Systemdokumentation.
Die EtherCAT Box unterstützt die Distributed-Clocks-Funktionalität. Damit die Box den aktuellen Zählerstand rechtzeitig vor Ankunft des abfragenden EtherCAT-Datagrams in den vorgesehenen Prozessdaten bereitstellen kann, muss ein entsprechendes Signal klemmenintern zyklisch generiert werden. Dieses Signal kann in der Box durch 2 Ereignisse ausgelöst werden: Den SyncManager (SM) und die Distributed Clock (DC). In der Betriebsartenwahl (s. Abb. Karteireiter DC (Distributed Clocks)) stehen zur Auswahl
▪
SM-synchron
Das SyncManager-Ereignis tritt ein, wenn ein EtherCAT-Frame Prozessdaten mit der EP1518 erfolgreich austauscht. Frame-getriggert wird so zyklisch der aktuelle Zählerstand ermittelt, allerdings mit dem geringen zeitlichen Jitter des Ethernet-Frames.
▪
DC-synchron
In der Betriebsart DC wird die Zählerstandermittlung zyklisch konstant durch die integrierte DC-Einheit ausgelöst, standardmäßig im Gleichtakt mit dem Buszyklus. Durch die gleichmäßigere Abfrage kann z. B. ein übergeordneter Regelalgorithmus mit qualitativ höherwertigen Positionsdaten versorgt werden. In der EP1518 ist dieser Auslöser das SYNC0-Signal.
Karteireiter DC (Distributed Clocks)
Beim Einschalten der Betriebsart DC-Synchron werden Einstellungen von TwinCAT gewählt, die einen zuverlässigen Betrieb der Box mit aktuellen Positionsdaten gewährleisten. Das bedeutet, die Ermittlung des aktuellen Zählerstandes wird in hochkonstanten Abständen und rechtzeitig - also mit genügend Sicherheitspuffer - vor dem abholenden EtherCAT-Datagram durch das SYNC0-Signal gestartet.
Das SYNC0-Signal kann bei Bedarf in entsprechenden Dialogen auf der Zeitachse nach rechts/spät bzw. links/früh durch Angabe einer User defined Shift Time verschoben (geshiftet) werden, s. Abb. Erweiterte Einstellungen Distributed Clock (DC).
▪
Durch ein Shiften nach rechts (positiver Shift-Wert) erfolgt die Abfrage des Zählerstandes später - damit wird der Positionswert aktueller, relativ gesehen von der PLC aus. Allerdings steigt damit das Risiko, dass die Positionsermittlung bis zur Ankunft des EtherCAT-Frames nicht rechtzeitig beendet wurde und in diesem Zyklus ein aktueller Positionswert fehlt.
▪
Durch ein Shiften nach links (negativer Shift-Wert) erfolgt die Abfrage des Zählerstandes früher - damit werden die Positionswerte älter, jedoch wird der Sicherheitspuffer vor Ankunft des EtherCAT-Datagrams erhöht. Diese Einstellung kann auf Systemen mit hohem Echtzeit-Jitter nützlich sein, wenn zur Steuerung z. B. keine Industrie-PC von Beckhoff verwendet werden.
Hinweis
Beschädigung der Geräte möglich
Die hier aufgeführten Hinweise und Erläuterungen sollten mit Bedacht angewendet werden!
Die SYNC0- und SYNC1-Einstellungen werden vom EtherCAT-Master automatisch mit Werten belegt, die eine zuverlässige und aktuelle Prozessdatenerfassung unterstützen.
Anwenderseitige Eingriffe an dieser Stelle können zu unerwünschtem Verhalten führen!
Bei der Manipulation dieser Einstellungen im System Manager wird softwareseitig keine Plausibilitätskontrolle durchgeführt! Eine korrekte Funktion der Klemme in allen denkbaren Einstellungsvarianten kann nicht gewährleistet werden!
Default-Einstellung
Das zyklische Lesen der Eingänge wird durch den SYNC0-Puls (Interrupt) der DC in der EtherCAT Box ausgelöst. Standardmäßig wird die Einlese-Zykluszeit Sync Unit Zyklus vom EtherCAT-Master auf die verwendete SPS-Zykluszeit und damit auf die EtherCAT-Zykluszeit gesetzt. Siehe Abb. Erweiterte Einstellungen Distributed Clock (DC): 4000 µs = 4 ms da sich TwinCAT im Config-Modus befindet.
DC-Einstellungen
Erweiterte Einstellungen Distributed Clock (DC)
SYNC0
Sync Unit Zyklus: Vielfaches der Buszykluszeit. In diesem Abstand (in µs) wird der Zählerstand periodisch ermittelt.
Anwenderdefiniert
Beliebige Zahl bis 232 ns ≈ 4,3 sek. Kommawerte sind möglich.
Shift Time
MIt der Shift Time kann der SYNC0-Puls dieser EtherCAT Box gegenüber anderen Boxen/Klemmen bzw. dem globalen SYNC-Puls in ns-Schritten verschoben werden. Sollen die Eingänge mehrerer Boxen gleichzeitig gelesen werden, muss hier derselbe Wert eingetragen werden.
Based on Input Reference
Bei Aktivierung dieser Option wird zum klemmenlokalen konfigurierbaren SYNC0-Shift (User defined) ein weiterer Input Shift dazu addiert. Dieser Wert wird vom EtherCAT Master berechnet und zur Verfügung gestellt (SysMan/Gerät EtherCAT/Reiter EtherCAT/Erweiterte Einstellungen/Distributed Clocks/Input Shift Time). Dadurch lesen alle Eingangsklemmen im System (EL1xxx, EL3xxx, EP1xxx, EP3xxx) möglichst kurz vor dem abholenden EtherCAT-Frame ihre Eingänge ein und liefern so möglichst „aktuelle“ Eingangsdaten an die Steuerung ab.
Enable SYNC0
Automatisch aktiviert in der Betriebsart DC-synchron.
SYNC1
Weiterer SYNC-Puls, abgeleitet aus SYNC0 oder der DC selbst.
DC-Einstellungen EtherCAT Master
In den erweiterten Einstellungen des EtherCAT Master können übergeordnete Parameter der Distributed Clocks verändert werden. Siehe dazu auch die grundlegende Einführung in das Thema EtherCAT und Distributed Clocks herunterladen: die Systembeschreibung Distributed Clocks.
EtherCAT Master, Karteireiter EtherCAT, Erweiterte Einstellungen


Distributed Clocks und EP1518

Inbetriebnahme und Konfiguration [image] Einbinden im TwinCAT [image] Distributed Clocks und EP1518
Distributed Clocks und EP1518
Digitale Eingänge und Distributed Clocks
Ist die Distributed Clock des EP1518 aktiviert, werden die digitalen Eingänge ohne den eingestellten Filter rechtzeitig vor Ankunft des abfragenden EtherCAT-Datagrams eingelesen.


Konfiguration der EP1518

Inbetriebnahme und Konfiguration [image] Konfiguration der EP1518
Konfiguration der EP1518
Weiterführende Informationen
•
Grundlagen zur Funktion
•
Betriebsarten
•
Einstellungen der Zähler
•
Wiederherstellen des Auslieferungszustandes


Grundlagen zur Funktion

Inbetriebnahme und Konfiguration [image] Konfiguration der EP1518 [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die EtherCAT Box EP1518 besitzt 8 digitale Eingänge. Davon können die Eingänge 0, 1 und 2 sowie 4, 5 und 6 jeweils für einen Zähler genutzt werden. Die Stati der einzelnen Eingänge werden unabhängig von deren Verwendung immer im Prozessabbild dargestellt.
Eingang | M8 | M12 | Eigenschaften
0 | Buchse 1, Pin 4 | Buchse 1, Pin 4 | digitaler Eingang oder Zähleingang 1
1 | Buchse 2, Pin 4 | Buchse 1, Pin 2 | digitaler Eingang oder Gate 1
2 | Buchse 3, Pin 4 | Buchse 2, Pin 4 | digitaler Eingang oder Up/Down 1
3 | Buchse 4, Pin 4 | Buchse 2, Pin 2 | digitaler Eingang
4 | Buchse 5, Pin 4 | Buchse 3, Pin 4 | digitaler Eingang oder Zähleingang 2
5 | Buchse 6, Pin 4 | Buchse 3, Pin 2 | digitaler Eingang oder Gate 2
6 | Buchse 7, Pin 4 | Buchse 4, Pin 4 | digitaler Eingang oder Up/Down 2
7 | Buchse 8, Pin 4 | Buchse 4, Pin 2 | digitaler Eingang
Betriebsarten
Die EP1518 lässt sich in drei Betriebsarten betreiben, die Einstellung erfolgt über Auswahl der PDOs im Sync-Manager:
Betriebsart | Anzahl Zählerkanäle | Anzahl "freier" digitaler Eingänge | Eigenschaften
2 Vorwärts/Rückwärtszähler (32 Bit) | 2 | 2 | Auf den Zählereingängen werden einzelne Pulse gezählt. Der Gate-Eingang oder das Software-Gate geben die Zähler frei. Die Zählrichtung wird über CoE festgelegt.
2 Vorwärts/Rückwärtszähler (32 Bit) | 1 | 5
8 digitale Eingänge, kein Zähler | - | 8 | digitale Eingänge: Filter für Eingang 0 und 4 fest auf 150 µs eingestellt. Filtervorgabe für die anderen Eingänge per Software konfigurierbar.
Die GATE- und Up/Down-Eingänge lassen sich als Standard-Eingänge umschalten.
Zählbetrieb
Die folgenden Einstellungen für GATE und Up/Down lassen sich kombinieren und gelten unabhängig für jeden Zähler.
Zählbetrieb mit Standardeinstellung (Vorwärtszähler)
Im Auslieferungszustand wird der Counter Value mit jeder steigenden Flanke inkrementiert. Die Zählrichtung ist vorwärts.
Durch einen High-Pegel am GATE-Eingang oder durch Setzen des Bits Inhibit Counters wird der Zähler gesperrt.
Zählbetrieb mit Standardeinstellung
Zählbetrieb mit Umstellung der Zählrichtung (Rückwärtszähler)
Durch einen High-Pegel am Up/Down Eingang oder durch Setzen des CoE-Objektes 0x80x0:04 Count down wird die Zählrichtung geändert. Die Zählrichtung ist rückwärts.
Zählbetrieb mit Umstellung der Zählrichtung
Zählbetrieb mit invertiertem (negierten) GATE-Eingang
In der Default-Einstellung wird der Zähler durch einen High-Pegel am GATE-Eingang oder durch Setzen des Bits Inhibit Counters gesperrt
Das Setzen des CoE-Objektes 0x80x0:05 Enable input gate aktiviert den Zähler bei gesetztem GATE und deaktiviert ihn bei nicht gesetztem GATE.
Zählbetrieb mit invertiertem GATE-Eingang
CoE zum invertieren des GATE-Eingangs


Betriebsarten

Inbetriebnahme und Konfiguration [image] Konfiguration der EP1518 [image] Betriebsarten
Betriebsarten
Betriebsartenwahl
Die EP1518 lässt sich in 3 Betriebsarten betreiben:
▪
Zwei Vorwärts/Rückwärtszähler (Auslieferungszustand)
▪
Ein Vorwärts/Rückwärtszähler
▪
8 digitale Eingänge
Die Einstellung erfolgt über Auswahl der PDOs im Sync-Manager:
Betriebsart | Anzahl 32 Bit Zähler | Anzahl "freie" digitale Eingänge | Eigenschaften
2 Vorwärts/Rückwärtszähler | 2 | 2 | einzelne Pulse auf den Zählereingängen werden gezählt, Gate-Eingang oder SoftwareGate geben die Zähler frei, Zählrichtung über CoE
1 Vorwärts/Rückwärtszähler | 1 | 5
8 digitale Eingänge, kein Zähler | - | 8 | digitale Eingänge: Filter für Eingang 0 und 4 fest auf 150 µs eingestellt. Filtervorgabe für die anderen Eingänge per Software konfigurierbar.
Betriebsarteinstellungen der PDOs | 0x1600 | 0x1601 | 0x1A00 | 0x1A01 | 0x1A02 | 0x1A03 | Bemerkungen
2 Vorwärts/Rückwärtszähler (32 Bit) | 1 | 1 | 1 | 1 | 0/1 | 0/1 | 2 Zähler, digitale Eingänge, Diagnose der Us
1 Vorwärts/Rückwärtszähler (32 Bit) | 1 | 0 | 1 | 0 | 0/1 | 0/1
8 digitale Eingänge, kein Zähler | 0 | 0 | 0 | 0 | 0/1 | 0/1 | digitale Eingänge: Filter für Eingang 0 und 4 fest auf 150 µs eingestellt. Filtervorgabe für die anderen Eingänge per Software konfigurierbar.
Die Einstellung der Modulparameter erfolgt in den CoE-Objekten 0x8000:0 für den Zähler 1, in 0x8010:0 für den Zähler 2 und in 0x8022:0 für die digitalen Eingänge. (Links einbinden)
Der zweite Zähler ist intern immer aktiv
Intern ist der zweite Zähler immer aktiv, so dass bei einer Umstellung von 1 x 32 Bit Zähler auf 2 x 32 Bit Zähler die vorher eingegangenen Pulse im zweiten Zähler gezählt wurden und im Counter Value gespeichert sind.
Zwei Vorwärts/Rückwärtszähler
Dies ist der Auslieferungsmodus der EP1518.
Einstellung der PDOs 0x1600 und 0x1601, Defaulteinstellungen der Objekte 0x8000 bis 0x8022:0
Einstellung der PDOs 0x1A00 bis 0x1A03, Defaulteinstellungen der Objekte 0x8000 bis 0x8002:0
Die PDOs 0x1600, 0x1601 sowie 0x1A00, 0x1A01, 0x1A02 und 0x1A03 sind aktiviert. Die Bedeutung der einzelnen Objekte ist in der Objektbeschreibung erläutert.
Ein Vorwärts/Rückwärtszähler (0x1601 deaktiviert, 0x1A01 deaktiviert)
Dieser Modus kann folgendermaßen eingestellt werden:
Einstellung der PDOs 0x1600
Einstellung der PDOs 0x1A00, 0x1A02 und 0x1A03
Die PDOs 0x1600 sowie 0x1A00, 0x1A02 und 0x1A03 sind aktiviert. Die CoE-Objekte sind identisch zur Betriebsart 2 x 32 Bit-Zähler.
8 digitale Eingänge, kein Zähler
Dieser Modus kann folgendermaßen eingestellt werden:
Einstellung der PDOs 0x1A02 und 0x1A03
Die PDOs 0x1A02 und 0x1A03 sind aktiviert. Die Bedeutung der einzelnen Objekte ist in der Objektbeschreibung erläutert.


Einstellungen der Zähler

Inbetriebnahme und Konfiguration [image] Konfiguration der EP1518 [image] Einstellungen der Zähler
Einstellungen der Zähler
"Freischalten" der GATE- und Up/Down Eingänge als Standard-Eingänge
Durch Setzen der CoE-Objekte Enable Input gate und Enable input UD werden die Eingänge nicht mehr den Zählern zugeordnet sondern als Standard-Eingänge verwendet.
Freischalten der Eingänge
Setzen des Zählers auf einen über die Prozessdaten vorgegebenen Wert
Der Zähler (Counter value) kann durch die Steuerung auf einen beliebigen Wert gesetzt werden.
Schreiben Sie dazu den gewünschten Wert in Set counter value. Mit steigender Flanke des Control-Bits Set counter der Wert dann vom Counter value übernommen.
Setzen des Zählers
Automatisches Setzen/Rücksetzen des Zählers auf einen definierten Wert
Durch Vorgabe eines beliebigen Wertes in Counter reload value und Aktivieren des Bits Enable reload wird der Zähler bei Über- oder Unterschreiten (je nach Zählrichtung) des vorgegebenen Werts auf 0 bzw. den eingestellten Wert gesetzt.
Automatisches Setzen des Zählers


Wiederherstellen des Auslieferungszustandes

Inbetriebnahme und Konfiguration [image] Konfiguration der EP1518 [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen / EPxxxx-Boxen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001 angewählt werden).
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK.
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Modulen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:
Dezimalwert: 1819238756
Hexadezimalwert: 0x6C6F6164
Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


CoE Objekte

Inbetriebnahme und Konfiguration [image] CoE Objekte
CoE Objekte
Weiterführende Informationen
•
Objektübersicht
•
Objektbeschreibung und Parametrierung


Objektübersicht

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektübersicht
Objektübersicht
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Index (hex) |  | Name | Flags | Default Wert
1000 |  | Device type | RO | 0x00001389 (5001dez)
1008 |  | Device name | RO | EP1518-0002
1009 |  | Hardware version | RO | 00
100A |  | Software version | RO | 01.03
1011:0 | Subindex | Restore default parameters | RO | 0x01 (1dez)
 | 1011:01 | SubIndex 001 | RW | 0x00000000 (0dez)
1018:0 | Subindex | Identity | RO | 0x04 (4dez)
 | 1018:01 | Vendor ID | RO | 0x00000002 (2dez)
 | 1018:02 | Product code | RO | 0x05EE4052 (99500114dez)
 | 1018:03 | Revision | RO | 0x00100002 (1048578dez)
 | 1018:04 | Serial number | RO | 0x00000000 (0dez)
10F0:0 | Subindex | Backup parameter handling | RO | 0x01 (1dez)
 | 10F0:01 | Checksum | RO | 0x00000000 (0dez)
1600:0 | Subindex | CNT RxPDO-Map OutputsCh.1 | RO | 0x05 (5dez)
 | 1600:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1600:02 | SubIndex 002 | RO | 0x7000:03, 1
 | 1600:03 | SubIndex 003 | RO | 0x7000:04, 1
 | 1600:04 | SubIndex 004 | RO | 0x0000:00, 12
 | 1600:05 | SubIndex 005 | RO | 0x7000:11, 32
1601:0 | Subindex | CNT RxPDO-Map OutputsCh.2 | RO | 0x05 (5dez)
 | 1601:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1601:02 | SubIndex 002 | RO | 0x7010:03, 1
 | 1601:03 | SubIndex 003 | RO | 0x7010:04, 1
 | 1601:04 | SubIndex 004 | RO | 0x0000:00, 12
 | 1601:05 | SubIndex 005 | RO | 0x7010:11, 32
1A00:0 | Subindex | CNT TxPDO-Map InputsCh.1 | RO | 0x0A (10dez)
 | 1A00:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1A00:02 | SubIndex 002 | RO | 0x6000:03, 1
 | 1A00:03 | SubIndex 003 | RO | 0x6000:04, 1
 | 1A00:04 | SubIndex 004 | RO | 0x6000:05, 1
 | 1A00:05 | SubIndex 005 | RO | 0x6000:06, 1
 | 1A00:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A00:07 | SubIndex 007 | RO | 0x6000:0E, 1
 | 1A00:08 | SubIndex 008 | RO | 0x6000:0F, 1
 | 1A00:09 | SubIndex 009 | RO | 0x6000:10, 1
 | 1A00:0A | SubIndex 010 | RO | 0x6000:11, 32
Index (hex) |  | Name | Flags | Default Wert
1A01:0 | Subindex | CNT TxPDO-Map InputsCh.2 | RO | 0x0A (10dez)
 | 1A01:01 | SubIndex 001 | RO | 0x0000:00, 2
 | 1A01:02 | SubIndex 002 | RO | 0x6010:03, 1
 | 1A01:03 | SubIndex 003 | RO | 0x6010:04, 1
 | 1A01:04 | SubIndex 004 | RO | 0x6010:05, 1
 | 1A01:05 | SubIndex 005 | RO | 0x6010:06, 1
 | 1A01:06 | SubIndex 006 | RO | 0x0000:00, 7
 | 1A01:07 | SubIndex 007 | RO | 0x6010:0E, 1
 | 1A01:08 | SubIndex 008 | RO | 0x6010:0F, 1
 | 1A01:09 | SubIndex 009 | RO | 0x6010:10, 1
 | 1A01:0A | SubIndex 010 | RO | 0x6010:11, 32
1A02:0 | Subindex | DIG TxPDO-Map Inputs | RO | 0x09 (9dez)
 | 1A02:01 | SubIndex 001 | RO | 0x6020:01, 1
 | 1A02:02 | SubIndex 002 | RO | 0x6020:02, 1
 | 1A02:03 | SubIndex 003 | RO | 0x6020:03, 1
 | 1A02:04 | SubIndex 004 | RO | 0x6020:04, 1
 | 1A02:05 | SubIndex 005 | RO | 0x6020:05, 1
 | 1A02:06 | SubIndex 006 | RO | 0x6020:06, 1
 | 1A02:07 | SubIndex 007 | RO | 0x6020:07, 1
 | 1A02:08 | SubIndex 008 | RO | 0x6020:08, 1
 | 1A02:09 | SubIndex 009 | RO | 0x0000:00, 8
1A03:0 | Subindex | DIG TxPDO-Map Inputs Device | RO | 0x07 (7dez)
 | 1A03:01 | SubIndex 001 | RO | 0x0000:00, 1
 | 1A03:02 | SubIndex 002 | RO | 0xF600:02, 1
 | 1A03:03 | SubIndex 003 | RO | 0xF600:03, 1
 | 1A03:04 | SubIndex 004 | RO | 0x0000:00, 10
 | 1A03:05 | SubIndex 005 | RO | 0xF600:0E, 1
 | 1A03:06 | SubIndex 006 | RO | 0xF600:0F, 1
 | 1A03:07 | SubIndex 007 | RO | 0xF600:10, 1
1C00:0 | Subindex | Sync manager type | RO | 0x04 (4dez)
 | 1C00:01 | SubIndex 001 | RO | 0x01 (1dez)
 | 1C00:02 | SubIndex 002 | RO | 0x02 (2dez)
 | 1C00:03 | SubIndex 003 | RO | 0x03 (3dez)
 | 1C00:04 | SubIndex 004 | RO | 0x04 (4dez)
1C12:0 | Subindex | RxPDO assign | RW | 0x02 (2dez)
 | 1C12:01 | SubIndex 001 | RW | 0x1600 (5632dez)
 | 1C12:02 | SubIndex 002 | RW | 0x1601 (5633dez)
1C13:0 | Subindex | TxPDO assign | RW | 0x04 (4dez)
 | 1C13:01 | SubIndex 001 | RW | 0x1A00 (6656dez)
 | 1C13:02 | SubIndex 002 | RW | 0x1A01 (6657dez)
 | 1C13:03 | SubIndex 003 | RW | 0x1A02 (6658dez)
 | 1C13:04 | SubIndex 004 | RW | 0x1A03 (6659dez)
Index (hex) |  | Name | Flags | Default Wert
1C32:0 | Subindex | SM output parameter | RO | 0x20 (32dez)
 | 1C32:01 | Sync mode | RW | 0x0001 (1dez)
 | 1C32:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C32:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C32:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C32:05 | Minimum cycle time | RO | 0x0003D090 (250000dez)
 | 1C32:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C32:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C32:08 | Command | RW | 0x0000 (0dez)
 | 1C32:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C32:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C32:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C32:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C32:20 | Sync error | RO | 0x00 (0dez)
1C33:0 | Subindex | SM input parameter | RO | 0x20 (32dez)
 | 1C33:01 | Sync mode | RW | 0x0022 (34dez)
 | 1C33:02 | Cycle time | RW | 0x000F4240 (1000000dez)
 | 1C33:03 | Shift time | RO | 0x00000000 (0dez)
 | 1C33:04 | Sync modes supported | RO | 0xC007 (49159dez)
 | 1C33:05 | Minimum cycle time | RO | 0x0003D090 (250000dez)
 | 1C33:06 | Calc and copy time | RO | 0x00000000 (0dez)
 | 1C33:07 | Minimum delay time | RO | 0x00000000 (0dez)
 | 1C33:08 | Command | RW | 0x0000 (0dez)
 | 1C33:09 | Maximum delay time | RO | 0x00000000 (0dez)
 | 1C33:0B | SM event missed counter | RO | 0x0000 (0dez)
 | 1C33:0C | Cycle exceeded counter | RO | 0x0000 (0dez)
 | 1C33:0D | Shift too short counter | RO | 0x0000 (0dez)
 | 1C33:20 | Sync error | RO | 0x00 (0dez)
6000:0 | Subindex | CNT Inputs | RO | 0x11 (17dez)
 | 6000:03 | Set counter done | RO | 0x00 (0dez)
 | 6000:04 | Counter inhibited | RO | 0x00 (0dez)
 | 6000:05 | Status of input UD | RO | 0x00 (0dez)
 | 6000:06 | Status of input clock | RO | 0x00 (0dez)
 | 6000:0E | Sync error | RO | 0x00 (0dez)
 | 6000:0F | TxPDO State | RO | 0x00 (0dez)
 | 6000:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6000:11 | Counter value | RO | 0x00000000 (0dez)
6010:0 | Subindex | CNT Inputs | RO | 0x11 (17dez)
 | 6010:03 | Set counter done | RO | 0x00 (0dez)
 | 6010:04 | Counter inhibited | RO | 0x00 (0dez)
 | 6010:05 | Status of input UD | RO | 0x00 (0dez)
 | 6010:06 | Status of input clock | RO | 0x00 (0dez)
 | 6010:0E | Sync error | RO | 0x00 (0dez)
 | 6010:0F | TxPDO State | RO | 0x00 (0dez)
 | 6010:10 | TxPDO Toggle | RO | 0x00 (0dez)
 | 6010:11 | Counter value | RO | 0x00000000 (0dez)
Index (hex) |  | Name | Flags | Default Wert
6020:0 | Subindex | DIG Inputs | RO | 0x08 (8dez)
 | 6020:01 | Input 0 | RO | 0x00 (0dez)
 | 6020:02 | Input 1 | RO | 0x00 (0dez)
 | 6020:03 | Input 2 | RO | 0x00 (0dez)
 | 6020:04 | Input 3 | RO | 0x00 (0dez)
 | 6020:05 | Input 4 | RO | 0x00 (0dez)
 | 6020:06 | Input 5 | RO | 0x00 (0dez)
 | 6020:07 | Input 6 | RO | 0x00 (0dez)
 | 6020:08 | Input 7 | RO | 0x00 (0dez)
7000:0 | Subindex | CNT Outputs | RO | 0x11 (17dez)
 | 7000:03 | Set counter | RO | 0x00 (0dez)
 | 7000:04 | Inhibit counter | RO | 0x00 (0dez)
 | 7000:11 | Set counter value | RO | 0x00000000 (0dez)
7010:0 | Subindex | CNT Outputs | RO | 0x11 (17dez)
 | 7010:03 | Set counter | RO | 0x00 (0dez)
 | 7010:04 | Inhibit counter | RO | 0x00 (0dez)
 | 7010:11 | Set counter value | RO | 0x00000000 (0dez)
8000:0 | Subindex | CNT Settings | RW | 0x13 (19dez)
 | 8000:03 | Enable reload | RW | 0x00 (0dez)
 | 8000:04 | Count down | RW | 0x00 (0dez)
 | 8000:05 | Operating mode | RW | 0x01 (1dez)
 | 8000:13 | Counter reload value | RW | 0x00000000 (0dez)
8010:0 | Subindex | CNT Settings | RW | 0x13 (19dez)
 | 8010:03 | Enable reload | RW | 0x00 (0dez)
 | 8010:04 | Count down | RW | 0x00 (0dez)
 | 8010:05 | Operating mode | RW | 0x01 (1dez)
 | 8010:13 | Counter reload value | RW | 0x00000000 (0dez)
8022:0 | Subindex | DIG Filter Settings | RW | 0x08 (8dez)
 | 8022:01 | Input 0 | RW | 0x00 (0dez)
 | 8022:02 | Input 1 | RW | 0x00 (0dez)
 | 8022:03 | Input 2 | RW | 0x00 (0dez)
 | 8022:04 | Input 3 | RW | 0x00 (0dez)
 | 8022:05 | Input 4 | RW | 0x00 (0dez)
 | 8022:06 | Input 5 | RW | 0x00 (0dez)
 | 8022:07 | Input 6 | RW | 0x00 (0dez)
 | 8022:08 | Input 7 | RW | 0x00 (0dez)
F000:0 | Subindex | Modular device profile | RO | 0x02 (2dez)
 | F000:01 | Module index distance | RO | 0x0010 (16dez)
 | F000:02 | Maximum number of modules | RO | 0x0003 (3dez)
F008 |  | Code word | RW | 0x00000000 (0dez)
F010:0 | Subindex | Module list | RW | 0x03 (3dez)
 | F010:01 | SubIndex 001 | RW | 0x00000096 (150dez)
 | F010:02 | SubIndex 002 | RW | 0x00000096 (150dez)
 | F010:03 | SubIndex 003 | RW | 0x00000118 (280dez)
Index (hex) |  | Name | Flags | Default Wert
F600:0 | Subindex | DIG Inputs | RO | 0x10 (16dez)
 | F600:02 | Error channel 1 | RO | 0x00 (0dez)
 | F600:03 | Error channel 2 | RO | 0x00 (0dez)
 | F600:0E | Sync error | RO | 0x00 (0dez)
 | F600:0F | TxPDO State | RO | 0x00 (0dez)
 | F600:10 | TxPDO Toggle | RO | 0x00 (0dez)
Legende
Flags:
RO (Read Only): dieses Objekt kann nur gelesen werden
RW (Read/Write): dieses Objekt kann gelesen und beschrieben werden


Objektbeschreibung und Parametrierung

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen zu installieren.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
▪
Weitere Profilspezifische Objekte, die Ein- und Ausgänge, sowie Statusinformationen anzeigen
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weitere Objekte
Weiterführende Informationen
•
Objekte zur Parametrierung bei der Inbetriebnahme
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte zur Parametrierung bei der Inbetriebnahme

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Objekte zur Parametrierung bei der Inbetriebnahme
Objekte zur Parametrierung bei der Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 CNT Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8000:0 | CNT Settings | Maximaler Subindex |  | UINT8 | RO | 0x13 (19dez)
8000:03 | Enable reload | Der Zähler zählt bis zum Wert in Index 0x8000:13 |  | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Count down | Zählrichtung: |  | BOOLEAN | RW | 0x00 (0dez)
 |  | 0bin | Vorwärts
 |  | 1bin | Rückwärt
8000:05 | Operating mode | Betriebsart |  | BIT2 | RW | 0x01 (1dez)
 |  | 01bin | Enable pos. gate (Gate sperrt mit positiven Pegel)
 |  | 10bin | Enable neg. gate (Gate sperrt mit negativen Pegel)
8000:13 | Counter reload value | Die Grenze die über „Enable reload“ (Index 0x8000:03) aktiviert werden kann. Wird aufwärts gezählt, so läuft der Zähler bis zur dieser Grenze und beginnt bei Überschreiten wieder bei Null. Wird herabgezählt, so läuft der Zähler bis 0 und wird bei Unterschreiten mit dem Wert aus diesem Register neu geladen. |  | UINT32 | RW | 0x00000000 (0dez)
Index 8010 CNT Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8010:0 | CNT Settings | Maximaler Subindex |  | UINT8 | RO | 0x13 (19dez)
8010:03 | Enable reload | Der Zähler zählt bis zum Wert in Index 0x8010:13 |  | BOOLEAN | RW | 0x00 (0dez)
8010:04 | Count down | Zählrichtung: |  | BOOLEAN | RW | 0x00 (0dez)
 |  | 0bin | Vorwärts
 |  | 1bin | Rückwärt
8010:05 | Operating mode | Betriebsart |  | BIT2 | RW | 0x01 (1dez)
 |  | 01bin | Enable pos. gate (Gate sperrt mit positiven Pegel)
 |  | 10bin | Enable neg. gate (Gate sperrt mit negativen Pegel)
8010:13 | Counter reload value | Die Grenze die über „Enable reload“ (Index 0x8010:03) aktiviert werden kann. Wird aufwärts gezählt, so läuft der Zähler bis zur dieser Grenze und beginnt bei Überschreiten wieder bei Null. Wird herabgezählt, so läuft der Zähler bis 0 und wird bei Unterschreiten mit dem Wert aus diesem Register neu geladen. |  | UINT32 | RW | 0x00000000 (0dez)
Index 8022 DIG Filter Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8022:0 | DIG Filter Settings | Maximaler Subindex |  | UINT8 | RO | 0x08 (8dez)
8022:01 | Input 0 | Filterzeit für den Eingang |  | UINT8 | RW | 0x00 (0dez)
 |  | 0dez | 10 µs
 |  | 1dez | 200 µs
 |  | 2dez | 1 ms
 |  | 3dez | 3 ms
 |  | 4dez | 10 ms
 |  | 5dez | 100 ms
8022:02 | Input 1 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)
8022:03 | Input 2 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)
8022:04 | Input 3 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)
8022:05 | Input 4 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)
8022:06 | Input 5 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)
8022:07 | Input 6 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)
8022:08 | Input 7 | siehe 0x8022:01 |  | UINT8 | RW | 0x00 (0dez)


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EP1518-0002
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01.03
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x05EE4052 (99500114dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100002 (1048578dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 CNT RxPDO-Map OutputsCh.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | CNT RxPDO-Map OutputsCh.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x05 (5dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DO Outputs), entry 0x01 (Output 0)) | UINT32 | RO | 0x0000:00, 2
1600:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x7000:03, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (CNT Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:04, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (CNT Outputs), entry 0x04 (Inhibit counter)) | UINT32 | RO | 0x0000:00, 12
1600:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x7000:11, 32
Index 1601 CNT RxPDO-Map OutputsCh.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | CNT RxPDO-Map OutputsCh.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x05 (5dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x01 (Enable output functions)) | UINT32 | RO | 0x0000:00, 2
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x02 (Set output)) | UINT32 | RO | 0x7010:03, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:04, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (CNT Outputs), entry 0x04 (Inhibit counter)) | UINT32 | RO | 0x0000:00, 12
1601:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x7010:11, 32
Index 1A00 CNT TxPDO-Map InputsCh.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | CNT TxPDO-Map InputsCh.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x01 (Input 0)) | UINT32 | RO | 0x0000:00, 2
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x02 (Input 1)) | UINT32 | RO | 0x6000:03, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x03 (Input 2)) | UINT32 | RO | 0x6000:04, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x04 (Input 3)) | UINT32 | RO | 0x6000:05, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x05 (Input 4)) | UINT32 | RO | 0x6000:06, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x06 (Input 5)) | UINT32 | RO | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x07 (Input 6)) | UINT32 | RO | 0x6000:0E, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (DI Inputs Ch.1), entry 0x08 (Input 7)) | UINT32 | RO | 0x6000:0F, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6000:10, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (CNT Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A01 CNT TxPDO-Map InputsCh.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | CNT TxPDO-Map InputsCh.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:03, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:04, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x04 (Counter inhibited)) | UINT32 | RO | 0x6010:05, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x05 (Status of input UD)) | UINT32 | RO | 0x6010:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x06 (Status of input clock)) | UINT32 | RO | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x6010:0E, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6010:0F, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (CNT Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (CNT Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
Index 1A02 DIG TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | DIG TxPDO-Map Inputs | PDO Mapping TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x6020:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6020:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6020:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6020:08, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A03 DIG TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | DIG TxPDO-Map Inputs Device | PDO Mapping TxPDO 4 | UINT8 | RO | 0x07 (7dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x02 (Error channel 1)) | UINT32 | RO | 0xF600:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x03 (Error channel 2)) | UINT32 | RO | 0xF600:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (10 bits align) | UINT32 | RO | 0x0000:00, 10
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x0E (Sync error)) | UINT32 | RO | 0xF600:0E, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0xF600:0F, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (DIG Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Minimale Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:07, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Maximale Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0003D090 (250000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
wie 0x1C32:07
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
wie 0x1C32:09
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme und Konfiguration [image] CoE Objekte [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000 CNT Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | CNT Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter inhibited | Solange dieses Bit gesetzt ist, ist der Zähler gestoppt | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Status of input UD | Der Zustand des Up/Down-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input clock | Der Zustand des Clock-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Synchronisationsfehler | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Zählerstand | UINT32 | RO | 0x00000000 (0dez)
Index 6010 CNT Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | CNT Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6010:03 | Set counter done | Der Zähler wurde gesetzt | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Counter inhibited | Solange dieses Bit gesetzt ist, ist der Zähler gestoppt | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Status of input UD | Der Zustand des Up/Down-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Status of input clock | Der Zustand des Clock-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Synchronisationsfehler | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Counter value | Zählerstand | UINT32 | RO | 0x00000000 (0dez)
Index 6020 DIG Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | DIG Inputs | Maximaler Subindex | UINT8 | RO | 0x08 (8dez)
6020:01 | Input 0 | Digitaler Eingang 0 | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Input 3 | Digitaler Eingang 3 | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Input 4 | Digitaler Eingang 4 | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Input 5 | Digitaler Eingang 5 | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Input 6 | Digitaler Eingang 6 | BOOLEAN | RO | 0x00 (0dez)
6020:08 | Input 7 | Digitaler Eingang 7 | BOOLEAN | RO | 0x00 (0dez)
Index 7000 CNT Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | CNT Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Inhibit counter | Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der alte Zählerstand bleibt erhalten | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über „Set counter“ (Index 0x7000:03) zu setzende Zählerstand | UINT32 | RO | 0x00000000 (0dez)
Index 7010 CNT Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | CNT Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7010:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Inhibit counter | Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der alte Zählerstand bleibt erhalten | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Set counter value | Dies ist der über „Set counter“ (Index 0x7010:03) zu setzende Zählerstand | UINT32 | RO | 0x00000000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x00000096 (150dez)
F010:02 | SubIndex 002 | reserviert | UINT32 | RW | 0x00000096 (150dez)
F010:03 | SubIndex 003 | reserviert | UINT32 | RW | 0x00000118 (280dez)
Index F600 DIG Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | DIG Inputs | Maximaler Subindex | UINT8 | RO | 0x10 (16dez)
F600:02 | Error channel 1 | Ist dieses Bit gesetzt, so wurde ein Kurzschluss der Versorgungsspannung an Sensorgruppe 1 (Eingänge 0 - 3) detektiert | BOOLEAN | RO | 0x00 (0dez)
F600:03 | Error channel 2 | Ist dieses Bit gesetzt, so wurde ein Kurzschluss der Versorgungsspannung an Sensorgruppe 2 (Eingänge 4 - 7) detektiert | BOOLEAN | RO | 0x00 (0dez)
F600:0E | Sync error | Synchronisationsfehler | BOOLEAN | RO | 0x00 (0dez)
F600:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
F600:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden | BOOLEAN | RO | 0x00 (0dez)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
EtherCAT Box- / EtherCAT-P-Box - Zubehör
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Schutzarten nach IP-Code
In der Norm IEC 60529 (DIN EN 60529) sind die Schutzgrade festgelegt und nach verschiedenen Klassen eingeteilt. Die Bezeichnung erfolgt in nachstehender Weise.
1. Ziffer: Staub- und Berührungsschutz | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen den Zugang zu gefährlichen Teilen mit dem Handrücken. Geschützt gegen feste Fremdkörper Ø 50 mm
2 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Finger. Geschützt gegen feste Fremdkörper Ø 12,5 mm
3 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Werkzeug. Geschützt gegen feste Fremdkörper Ø 2,5 mm
4 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Geschützt gegen feste Fremdkörper Ø 1 mm
5 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubgeschützt. Eindringen von Staub ist nicht vollständig verhindert, aber der Staub darf nicht in einer solchen Menge eindringen, dass das zufriedenstellende Arbeiten des Gerätes oder die Sicherheit beeinträchtigt wird
6 | Geschützt gegen den Zugang zu gefährlichen Teilen mit einem Draht. Staubdicht. Kein Eindringen von Staub
2. Ziffer: Wasserschutz* | Bedeutung
0 | Nicht geschützt
1 | Geschützt gegen Tropfwasser
2 | Geschützt gegen Tropfwasser, wenn das Gehäuse bis zu 15° geneigt ist
3 | Geschützt gegen Sprühwasser. Wasser, das in einem Winkel bis zu 60° beiderseits der Senkrechten gesprüht wird, darf keine schädliche Wirkung haben
4 | Geschützt gegen Spritzwasser. Wasser, das aus jeder Richtung gegen das Gehäuse spritzt, darf keine schädlichen Wirkungen haben
5 | Geschützt gegen Strahlwasser.
6 | Geschützt gegen starkes Strahlwasser.
7 | Geschützt gegen die Wirkungen beim zeitweiligen Untertauchen in Wasser. Wasser darf nicht in einer Menge eintreten, die schädliche Wirkungen verursacht, wenn das Gehäuse für 30 Minuten in 1 m Tiefe in Wasser untergetaucht ist
*) In diesen Schutzklassen wird nur der Schutz gegen Wasser definiert.
Chemische Beständigkeit
Die Beständigkeit bezieht sich auf das Gehäuse der Feldbus/EtherCAT Box und den verwendeten Metallteilen. In der nachfolgenden Tabelle finden Sie einige typische Beständigkeiten.
Art | Beständigkeit
Wasserdampf | bei Temperaturen >100°C nicht beständig
Natriumlauge (ph-Wert > 12) | bei Raumtemperatur beständig > 40°C unbeständig
Essigsäure | unbeständig
Argon (technisch rein) | beständig
Legende
▪
beständig: Lebensdauer mehrere Monate
▪
bedingt beständig: Lebensdauer mehrere Wochen
▪
unbeständig: Lebensdauer mehrere Stunden bzw. baldige Zersetzung


EtherCAT Box- / EtherCAT-P-Box - Zubehör

Anhang [image] EtherCAT Box- / EtherCAT-P-Box - Zubehör
EtherCAT Box- / EtherCAT-P-Box - Zubehör
Befestigung
Bestellangaben | Beschreibung
ZS5300-0001 | Montageschiene (500 mm x 129 mm)
Beschriftungsmaterial, Stopfen
Bestellangaben | Beschreibung
ZS5000-0000 | Feldbus-Box-Set M8 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0002 | Feldbus-Box-Set M12 (Beschriftungsschilder, Abdeckstopfen)
ZS5000-0010 | Stopfen M8, IP67 (50 Stück)
ZS5000-0020 | Stopfen M12, IP67 (50 Stück)
ZS5100-0000 | Beschriftungsschilder nicht bedruckt, 4 Streifen à 10 Stück
ZS5100-xxxx | Beschriftungsschilder bedruckt, auf Anfrage
Werkzeug
Bestellangaben | Beschreibung
ZB8800 | Drehmoment-Schraubwerkzeug für M8-Leitungen für Stecker mit Rändel, inklusive Ratsche
ZB8800-0001 | Aufsatz M12 für Drehmoment-Schraubwerkzeug ZB8800
ZB8800-0002 | Aufsatz M8 (feldkonfektionierbar) für Drehmoment-Schraubwerkzeug ZB8800
ZB8801-0000 | Drehmoment-Schraubwerkzeug für Stecker mit Sechskant, einstellbar
ZB8801-0001 | Wechselklinge für M8/SW9 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0002 | Wechselklinge für M12/SW13 für Drehmoment-Schraubwerkzeug ZB8801-0000
ZB8801-0003 | Wechselklinge für M12 feldkonfektionierbar/SW18 für Drehmoment-Schraubwerkzeug ZB8801-0000
Weiteres Zubehör
Weiteres Zubehör finden Sie in der Preisliste für Feldbuskomponenten von Beckhoff und im Internet unter https://www.beckhoff.de


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.