EL922x - Elektronische Überstromschutzklemmen
Home


Produktübersicht Elektronische Überstromschutzklemme

Produktübersicht Elektronische Überstromschutzklemme
Produktübersicht Elektronische Überstromschutzklemme
EL9221-4030 Überstromschutzklemme, 1 kanalig, IN 3 A,
EL9221-5000 Überstromschutzklemme, 1 kanalig, IN einstellbar bis 10 A,
EL9221-5090 Überstromschutzklemme, 1 kanalig, IN 10 A,
EL9221-6000 Überstromschutzklemme, 1 kanalig, IN einstellbar bis 4 A,
EL9221-6040 Überstromschutzklemme, 1 kanalig, IN 4 A,
EL9221-9060 Überstromschutzklemme, 1 kanalig, IN 6 A,
EL9221-9080 Überstromschutzklemme, 1 kanalig, IN 8 A,

EL9222-4433 Überstromschutzklemme, 2 kanalig, IN 3 A/ 3 A,
EL9222-5500 Überstromschutzklemme, 2 kanalig, IN einstellbar bis ∑10 A,
EL9222-6600 Überstromschutzklemme, 2 kanalig, IN einstellbar bis 4 A,
EL9222-6644 Überstromschutzklemme, 2 kanalig, IN 4 A/ 4 A,
EL9222-9482 Überstromschutzklemme, 2 kanalig, IN 8 A/ 2 A,
EL9222-9664 Überstromschutzklemme, 2 kanalig, IN 6 A/ 4 A,

EL9227-4433 Überstromschutzklemme, 2 kanalig, IN 3 A/ 3 A, erweiterte Funktionen
EL9227-5500 Überstromschutzklemme, 2 kanalig, IN einstellbar bis ∑10 A, erweiterte Funktionen
EL9227-6600 Überstromschutzklemme, 2 kanalig, IN einstellbar bis 4 A, erweiterte Funktionen
EL9227-6644 Überstromschutzklemme, 2 kanalig, IN 4 A/ 4 A, erweiterte Funktionen
EL9227-9482 Überstromschutzklemme, 2 kanalig, IN 8 A/ 2 A, erweiterte Funktionen
EL9227-9664 Überstromschutzklemme, 2 kanalig, IN 6 A/ 4 A, erweiterte Funktionen
Aufschlüsselung der Typenbezeichnung Überstromschutzklemmen
Schlüssel Typenbezeichnung


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
1.0 | -1. Veröffentlichung - Ergänzungen, Korrekturen
0.2 – 0.9.3 | - Ergänzungen, Korrekturen
0.1 | - Vorläufige Dokumentation für die EL922x


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten


Einführung

Produktübersicht [image] Einführung
Einführung
Elektronische Überstromschutzklemmen
EL9221-xxxx | Einkanalige Überstromschutzklemme mit Standard-Funktionalitäten
EL9221-5000
Die elektronische Überstromschutzklemme EL9221-xxxx ist eine 24-V-DC-EtherCAT-Klemme mit elektronischer Absicherungsfunktion. Die EL9221-xxxx ist einkanalig und schaltet 24-V-DC-Überströme zuverlässig ab. Der Nennstrom kann sowohl über TwinCAT als auch über einen mechanischen Taster an der Überstromschutzklemme in 1-A-Schritten bis max. 10 A eingestellt werden. Darüber hinaus gibt es weitere Varianten mit einem fest eingestellten Nennstrom. Der abgesicherte Ausgang kann sowohl über einen Klemmkontakt nach außen geführt als auch über den Powerkontakt an benachbarte Klemmen ohne Verdrahtung direkt weitergeführt werden
Die EL9221-xxxx besitzt Standardfunktionalitäten, d.h. es existieren folgende Einstellungsmöglichkeiten und Prozessdaten:
- Einstellungen: Nennstrom, Programmierfunktion LED-Taster
- Prozessdaten: Enabled, Tripped, Vorwarnung, cool down lock, Hardware Protection
EL9222-xxxx | Zweikanalige Überstromschutzklemme mit Standard-Funktionalitäten
EL9222-5500
Die elektronische Überstromschutzklemme EL9222-xxxx ist eine 24-V-DC-EtherCAT-Klemme mit elektronischer Absicherungsfunktion. Die EL9222-xxxx ist zweikanalig und schaltet 24-V-DC-Überströme zuverlässig ab. Der Nennstrom kann sowohl über TwinCAT als auch über einen mechanischen Taster an der Überstromschutzklemme in 1-A-Schritten bis max. ∑ 10 A eingestellt werden. Darüber hinaus gibt es weitere Varianten mit einem fest eingestellten Nennstrom je Kanal. Der abgesicherte Ausgang 1 kann sowohl über einen Klemmkontakt nach außen geführt als auch über den Powerkontakt an benachbarte Klemmen ohne Verdrahtung direkt weitergeführt werden.
Die EL9222-xxxx besitzt Standardfunktionalitäten, d.h. es existieren folgende Einstellungsmöglichkeiten und Prozessdaten:
- Einstellungen: Nennstrom, Programmierfunktion LED-Taster
- Prozessdaten: Enabled, Tripped, Vorwarnung, cool down lock, Hardware Protection.
EL9227-xxxx | Zweikanalige Überstromschutzklemme mit erweiterten Funktionalitäten
EL9227-5500
Die elektronische Überstromschutzklemme EL9227-xxxx ist eine 24-V-DC-EtherCAT-Klemme mit elektronischer Absicherungsfunktion. Die EL9227-xxxx ist zweikanalig und schaltet 24-V-DC-Überströme zuverlässig ab. Der Nennstrom kann sowohl über TwinCAT als auch über einen mechanischen Taster an der Überstromschutzklemme in 1-A-Schritten bis max. ∑ 10 A eingestellt werden. Darüber hinaus gibt es weitere Varianten mit einem fest eingestellten Nennstrom je Kanal. Der abgesicherte Ausgang 1 kann sowohl über einen Klemmkontakt nach außen geführt als auch über den Powerkontakt an benachbarte Klemmen ohne Verdrahtung direkt weitergeführt werden.
Die EL9227-xxxx besitzt erweiterte Funktionaltäten, d.h., sie ist zusätzlich in der Lage Monitoring Anwendungen zu übernehmen, da zahlreiche Prozessdaten zur Verfügung stehen, z.B.:
Enabled, Tripped, Kurzschluss, Überlast, Überspannung, Unterspannung, Current level warning, cool down lock, Hardware Protection, ausgeschaltet durch Taster, DI, EtherCAT, Auslastung, aktueller Strom, Eingangspannung sowie Ausgangsspannung.
Darüber hinaus ist sie flexibel einsetzbar, da zahlreiche Einstellungen individuell möglich sind, z.B.:
Nennstrom, Charakteristik, manuelle Charakteristik, Vorwarnung, Startverhalten, Eingangsverhalten, Überspannungsverhalten, Unterspannungslevel, Rückwärtseinspeiseverhalten, Programmierfunktion LED-Taster.
Alle EL9227 Klemmen sind mit einem Schutz vor Verpolung und Rückeinspeisung ausgestattet.
Quick-Links
Sehen Sie dazu auch
•
Technische Daten
•
Montage und Verdrahtung
•
Objektbeschreibung und Parametrierung


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EL9221-5000 | EL9221-6000 | EL9221-4030 | EL9221-6040 | EL9221-9060 | EL9221-9080 | EL9221-5090
Nennspannung | 24 VDC (-15 %/+20 %)
Nennstrom | Max. 10 A, einstellbar | Max. 4 A, einstellbar | 3 A, fix | 4 A, fix | 6 A, fix | 8 A, fix | 10 A, fix
Nennstromstufen | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 A | 1, 2, 3, 4 A |
Eingangsstrom | Max. 10 A (Eingangsstrom = Weiterleitungsstrom + Strom der eigenen Klemme)
Anzahl der Ausgänge | 1
Ausgang 1 | Klemmkontakt und Powerkontakt
Power-Kontakte (rechtsseitig) | +24 V DC abgesichert; 0 V DC
Anzahl digitaler Eingänge | 1 (24V DC abfallende Flanke -15% + 20%); gleicher 0 V Bezug wie Eingangsspannung
Vorwarnung Ausgangsauslastung | Fix 90%, 5% Hysterese
Auslöseverhalten | siehe Tabellen Typ. Auslösezeiten
Wiedereinschaltzeit | ≥ 10 Sekunden*
Interne Sicherung (Faile-safe Element) | 15 A (F) | 6 A(T) | 4 A (T) | 6 A (T) | 10 A (F) | 10 A (F) | 15 A (F)
Interne max. Verlustleistungs-begrenzung | typ. 400 W für 20 ms | typ. 160 W für 50 ms | typ. 160 W für 50 ms | typ. 160 W für 50 ms | typ. 266 W für 30 ms | typ. 266 W für 30 ms | typ. 400 W für 20 ms
Max. Strombegrenzung | typ. 25A für 20 ms | typ. 10A für 50 ms | typ. 10A für 50 ms | typ. 10A für 50 ms | typ. 16 A für 30 ms | typ. 16 A für 30 ms | typ. 25A für 20 ms
Einschaltverzögerung | typ. 15 ms
Überstromschutzbetrieb ohne E-Bus | Ja
Einschaltkapazität | Typ. 20.000 µF**
Überspannungsabschaltung | > 32 V DC
Parallelschalten mehrerer Ausgänge | Nicht zulässig
Stromaufnahme vom E-Bus | 80 mA typ.
Elektrische Verbindung zur Montageschiene | Ja
Messfehler | typ. ± 100 mA @23°C+- 20°C @24 V
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | siehe Hinweis!
Schutzart | IP20
Zulassungen | CE
*) weitere Erklärungen siehe Hinweis im Kapitel Inbetriebnahme
**) abhängig von: verwendeter Stromversorgung, Leitungswiderstand, Laststrom, Bauteiltoleranzen, gewähltem Strombereich
Technische Daten | EL9222-5500 | EL9222-6600 | EL9222-4433 | EL9222-6644 | EL9222-9664 | EL9222-9482
Nennspannung | 24 VDC (-15 %/+20 %)
Nennstrom | Max. Ʃ10 A einstellbar | Max. 4 A, einstellbar | 3 A / 3 A, fix | 4 A / 4 A, fix | 6 A / 4 A, fix | 8 A / 2 A, fix
Nennstromstufen | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 A | 1, 2, 3, 4 A |
Eingangsstrom | Max. 10 A (Eingangsstrom = Weiterleitungsstrom + Strom der eigenen Klemme)
Anzahl der Ausgänge | 2
Ausgang 1 | Klemmkontakt und Powerkontakt
Power-Kontakte (rechtsseitig) | +24 V DC abgesichert; 0 V DC
Anzahl digitaler Eingänge | 2 (24V DC abfallende Flanke -15% + 20%); gleicher 0 V Bezug wie Eingangsspannung
Vorwarnung Ausgangsauslastung | Fix 90%, 5% Hysterese
Auslöseverhalten | siehe Tabellen Typ. Auslösezeiten
Wiedereinschaltzeit | ≥ 10 Sekunden*
Interne Sicherung (Faile-safe Element) (Kanal1/Kanal2) | 15 A (F) / 15 A (F) | 6 A (T) / 6 A (T) | 4 A (T) / 4 A (T) | 6 A (T) / 6 A (T) | 10 A (F) / 6 A (T) | 10 A (F) / 4 A (T)
Interne max. Verlustleistungs-begrenzung (Kanal1/Kanal2) | typ. 400 W für 20 ms / typ. 400 W für 20 ms | typ. 160 W für 50 ms / typ. 160 W für 50 ms | typ. 160 W für 50 ms / typ. 160 W für 50 ms | typ. 160 W für 50 ms / typ. 160 W für 50 ms | typ. 266 W für 30 ms / typ. 160 W für 50 ms | typ. 266 W für 30 ms / typ. 160 W für 50 ms
Max. Strombegrenzung (Kanal1/Kanal2) | typ. 25 A für 20 ms / typ. 25 A für 20 ms | typ. 10 A für 50 ms / typ. 10 A für 50 ms | typ. 10 A für 50 ms / typ. 10 A für 50 ms | typ. 10 A für 50 ms / typ. 10 A für 50 ms | typ. 16 A für 30 ms / typ. 10 A für 50 ms | typ. 16 A für 30 ms / typ. 10 A für 50 ms
Einschaltverzögerung | typ. 15 ms
Überstromschutzbetrieb ohne E-Bus | Ja
Einschaltkapazität | Typ. 20.000 µF**
Überspannungsabschaltung | > 32 V DC
Parallelschalten mehrerer Ausgänge | Nicht zulässig
Stromaufnahme vom E-Bus | 80 mA typ.
Elektrische Verbindung zur Montageschiene | Ja
Messfehler | typ. ± 100 mA @23°C+- 20°C @24 V
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | siehe Hinweis!
Schutzart | IP20
Zulassungen | CE
*) weitere Erklärungen siehe Hinweis im Kapitel Inbetriebnahme
**) abhängig von: verwendeter Stromversorgung, Leitungswiderstand, Laststrom, Bauteiltoleranzen, gewähltem Strombereich
Technische Daten | EL9227-5500 | EL9227-6600 | EL9227-4433 | EL9227-6644 | EL9227-9664 | EL9227-9482
Nennspannung | 24 VDC (-15 %/+20 %)
Nennstrom | Max. Ʃ10 A, einstellbar | Max. 4 A, einstellbar | 3 A / 3 A, fix | 4 A / 4 A, fix | 6 A / 4 A, fix | 8 A / 2 A, fix
Nennstromstufen | 1, 2, 3, 4, 5, 6, 7, 8, 9, 10 A | 1, 2, 3, 4 A |
Eingangsstrom | Max. 10 A (Eingangsstrom = Weiterleitungsstrom + Strom der eigenen Klemme)
Anzahl der Ausgänge | 2
Ausgang 1 | Klemmkontakt und Powerkontakt
Power-Kontakte (rechtsseitig) | +24 V DC abgesichert; 0 V DC
Anzahl digitaler Eingänge | 2 (24V DC abfallende Flanke -15% + 20%); gleicher 0 V Bezug wie Eingangsspannung
Vorwarnung Ausgangsauslastung | Einstellbar von 50 – 100%, 5% Hysterese
Auslöseverhalten | siehe Tabellen Typ. Auslösezeiten
Wiedereinschaltzeit | ≥ 10 Sekunden (temperaturabhängig)*
Interne Sicherung (Faile-safe Element) (Kanal1/Kanal2) | 15 A (F) / 15 A (F) | 6 A (T) / 6 A (T) | 4 A (T) / 4 A (T) | 6 A (T) / 6 A (T) | 10 A (F) / 6 A (T) | 10 A (F) / 4 A (T)
Interne max. Verlustleistungs-begrenzung (Kanal1/Kanal2) | typ. 400 W für 20 ms / typ. 400 W für 20 ms | typ. 160 W für 50 ms / typ. 160 W für 50 ms | typ. 160 W für 50 ms / typ. 160 W für 50 ms | typ. 160 W für 50 ms / typ. 160 W für 50 ms | typ. 266 W für 30 ms / typ. 160 W für 50 ms | typ. 266 W für 30 ms / typ. 160 W für 50 ms
Max. Strombegrenzung (Kanal1/Kanal2) | typ. 25 A für 20 ms / typ. 25 A für 20 ms | typ. 10 A für 50 ms / typ. 10 A für 50 ms | typ. 10 A für 50 ms / typ. 10 A für 50 ms | typ. 10 A für 50 ms / typ. 10 A für 50 ms | typ. 16 A für 30 ms / typ. 10 A für 50 ms | typ. 16 A für 30 ms / typ. 10 A für 50 ms
Einschaltverzögerung | typ. 15 ms
Überstromschutzbetrieb ohne E-Bus | Ja
Einschaltkapazität | Typ. 20.000µF**
Unterspannungsvorwarnung | Einstellbar von 17 – 24 V DC
Überspannungsabschaltung | > 32 V DC
Verpolungsabschaltung | Ja
Rückeinspeiseabschaltung | UOut + 1 V > UIn Abschaltzeitenn einstellbar in 3 Stufen (Fast: nach 10 ms, Standard: nach 100 ms, Slow: nach 1000 ms)
Parallelschalten mehrerer Ausgänge | Nicht zulässig
Stromaufnahme vom E-Bus | 80 mA typ.
Elektrische Verbindung zur Montageschiene | Ja
Messfehler | typ. ± 75 mA @23°C+- 20°C @24 V
 | typ. ± 150 mV @23°C+- 20°C @24 V
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | siehe Hinweis!
Schutzart | IP20
Zulassungen | CE
*) weitere Erklärungen siehe Hinweis im Kapitel Inbetriebnahme
**) abhängig von: verwendeter Stromversorgung, Leitungswiderstand, Laststrom, Bauteiltoleranzen, gewähltem Strombereich
Typ. Auslösezeiten für: EL9221-5000*; EL9221-5090*; EL9222-5500*;
EL9227-5500
X * IN | Current | fast | standard | slow
 |  | t / in ms
1,1 |  | 7.000 | 10.000 | 15.000
1,2 |  | 7.000 | 10.000 | 15.000
1,3 |  | 3.500 | 5.000 | 7.500
1,4 |  | 3.500 | 5.000 | 7.500
1,5 |  | 700 | 1.000 | 1.500
1,6 |  | 700 | 1.000 | 1.500
1,7 |  | 700 | 1.000 | 1.500
1,8 |  | 70 | 100 | 150
1,9 |  | 70 | 100 | 150
≥ 2 | Max. typ. 25 A | 1 | 8 | 12
*) Bei diesen Varianten nur „Standard“ vorhanden
Typ. Auslösezeiten für: EL9221-9060*; EL9221-9080*; EL9222-9664 (Kanal 1)*; EL9222-9482 (Kanal 1)*; EL9227-9664 (Kanal 1), EL9227-9482 (Kanal 1)
X * IN | Current | fast | standard | slow
 |  | t / in ms
1,1 |  | 7.000 | 10.000 | 15.000
1,2 |  | 7.000 | 10.000 | 15.000
1,3 |  | 3.500 | 5.000 | 7.500
1,4 |  | 3.500 | 5.000 | 7.500
1,5 |  | 700 | 1.000 | 1.500
1,6 |  | 700 | 1.000 | 1.500
1,7 |  | 700 | 1.000 | 1.500
1,8 |  | 70 | 100 | 150
1,9 |  | 70 | 100 | 150
≥ 2 | Max. typ. 16 A | 6 | 8 | 12
*) Bei diesen Varianten nur „Standard“ vorhanden
Typ. Auslösezeiten für: EL9221-4030*; EL9221-6000*; EL9221-6040*; EL9222-4433*; EL9222-6600*; EL9222-6644*; EL9227-4433; EL9227-6600; EL9227-6644; EL9222-9664 (Kanal 2)*; EL9227-9664 (Kanal 2); EL9227-9482 (Kanal 2); EL9222-9482 (Kanal 2)*
X * IN | Current | fast | standard | slow
 |  | t / in ms
1,1 |  | 7.000 | 10.000 | 15.000
1,2 |  | 7.000 | 10.000 | 15.000
1,3 |  | 3.500 | 5.000 | 7.500
1,4 |  | 3.500 | 5.000 | 7.500
1,5 |  | 700 | 1.000 | 1.500
1,6 |  | 700 | 1.000 | 1.500
1,7 |  | 700 | 1.000 | 1.500
1,8 |  | 70 | 100 | 150
1,9 |  | 70 | 100 | 150
≥ 2 | Max. typ. 10 A | 1 | 8 | 12
*) Bei diesen Varianten nur „Standard“ vorhanden


Grundlagen der Funktion

Grundlagen der Funktion
Grundlagen der Funktion
Das Funktionsprinzip der elektronischen Überstromschutzklemmen ist das Messen und Auswerten des fließenden Stroms. Je nach dem was die Auswertung als Ergebnis liefert, wird anschließend die entsprechende Aktion ausgeführt. Eine mögliche Aktion ist beispielsweise die Abschaltung.
Bezüglich der Abschaltung gibt es zwei Möglichkeiten, einmal gemäß der typischen Auslösezeiten (Kennlinie) und einmal gemäß von Hardwareparametern.
Abschaltung nach Kennlinie
Die Abschaltung auf Basis der Kennlinie kann dann erfolgen, wenn die Ausgänge vorher erfolgreich eingeschaltet wurden. Wie lange der jeweilige Überstrom fließen darf bis es zur Abschaltung kommt werden durch die Auslösezeiten in der Kennlinie festgelegt. Die typischen Auslösezeiten finden sie bei den Technischen Daten.
Abschaltung nach Hardwareparametern
Die elektronischen Überstromschutzklemmen EL9221, EL9222 und EL9227 haben eine interne Strom- und Leistungsbegrenzung auf Basis von Hardwareparametern. Die Abschaltung nach Hardwareparametern (Leistungsbegrenzung / Strombegrenzung) erfolgt dann, wenn die Ausgänge beim Einschalten bereits überlastet werden und nicht eingeschaltet werden konnten. Wenn z.B. auf einen bestehenden Kurzschluss eingeschaltet wird. Die Hardwareabschaltung greift aber auch im Kennlinienbetrieb, wenn die Leistungsgrenze- / oder Stromgrenze überschritten werden. Wird eines von beiden überschritten erfolgt die Abschaltung nach einer festen Zeit.
Die Angabe der Verlustleistungsbegrenzung bezieht sich auf die interne Verlustleistung in der Klemme. Der Wert der Verlustleistungsbegrenzung ist fix, wohingegen der fließende Strom von dem Spannungsabfall in der Klemme abhängt. Würde beispielsweise ein 0 Ohm Kurzschluss anliegen, würden die 24 V DC komplett in der Klemme abfallen. Bei einer Leistungsbegrenzung von 400 W würde sich ein Strom von ca. 16,67 A bis zur Abschaltung einstellen. Je nach Spannungsaufteilung steigt der Strom an, jedoch nur bis auf einen maximal begrenzenden Wert. Die jeweiligen Begrenzungswerte finden sie in den Technischen Daten.
Die Verlustleistungsbegrenzung inklusiver Strombegrenzung ist zu jederzeit aktiv. Das heißt unabhängig davon ob die Ausgänge bereits eingeschaltet werden konnten oder nicht steht diese Funktion ständig zur Verfügung.
Abschaltung nach Überschreiten des Grenzlastintegrals
Die Abschaltzeiten können variieren, wenn zum Beispiel das Grenzlastintegral überschritten wird.
Beispiel: Bei einem Pulsbetrieb steht mehrmals hintereinander ein Überstrom an. Kurz vor der Abschaltung bleibt der Überstrom aus, um dann nach kurzer Zeit wieder anzustehen. Infolgedessen hat sich das Grenzlastintegral aufgebaut und es kommt schließlich zur Abschaltung.
Abschaltung im Einschaltvorgang
Elektrische Verbraucher können auf zweierlei Weise eingeschaltet werden. Einmal direkt über den Ausgang an der Überstromschutzklemme oder über weitere schaltende Produkte. Beim Einschalten des Verbrauchers über den Kanal an der Klemme sind die Verlustleistungs- und Strombegrenzungswerte für eine mögliche Abschaltung im Einschaltmoment entscheidend. Beim Einschalten eines Verbrauchers über weitere Schaltklemmen (Ausgang der Überstromschutzklemme ist bereits eingeschaltet) sind die Daten der Kennlinie entscheidend.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Anschluss
•
Vorgeschriebene Einbaulage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Positionierung von passiven Klemmen
•
LEDs und Anschlussbelegung, Programmierung mit LED-Tastern


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten
Hinweis
Zusätzliche Abdeckung des Gehäuses erfordelich!
Die Gehäuse sind für den Einsatz im IO-System spezifiziert.
Werden diese außerhalb des Busklemmenblocks betrieben (Absicherungsfunktion ist auch ohne EtherCAT gegeben) ist sicher zu stellen, dass zusätzlich bei der linken Klemme die Buskontakte und die Gehäuseöffnungen mit einer Abdeckung versehen sind.


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm
Weiterführende Informationen
•
Leitungsquerschnitt des Lastkreises


Leitungsquerschnitt des Lastkreises

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung [image] Leitungsquerschnitt des Lastkreises
Leitungsquerschnitt des Lastkreises
Hinweis
Leitungsquerschnitt an Lastkreis anpassen
Es ist vom Anwender sicher zu stellen, dass der Leitungsquerschnitt des jeweiligen Lastkreises entsprechend angepasst ist!


Vorgeschriebene Einbaulage

Montage und Verdrahtung [image] Vorgeschriebene Einbaulage
Vorgeschriebene Einbaulage
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Mindestabstände bei Standard Einbaulage
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


LEDs und Anschlussbelegung, Programmierung mit LED-Tastern

Montage und Verdrahtung [image] LEDs und Anschlussbelegung, Programmierung mit LED-Tastern
LEDs und Anschlussbelegung, Programmierung mit LED-Tastern
Weiterführende Informationen
•
EL9221-xxxx
•
EL9222-xxxx
•
EL9227-xxxx
•
Beispielprogrammierung


EL9221-xxxx

Montage und Verdrahtung [image] LEDs und Anschlussbelegung, Programmierung mit LED-Tastern [image] EL9221-xxxx
EL9221-xxxx
LEDs und Anschlussbelegung
EL9221-5000, Zuordnung und Benennung der Anschlüsse und LEDs
Bedeutung der Anschlüsse
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Digital Eingang 1 | 1 | Digitaler Eingang zum Schalten des Ausgangs 1 (neg. Flanke; 0 V Bezug wie Einspeisung)
Einspeisung 24 V | 2 | +24 V DC Eingangsspannung (intern verbunden mit Klemmstelle 6)
Einspeisung 0 V | 3 | 0 V DC Eingangsspannung (intern verbunden mit Klemmstelle 7 und Powerkontakt 0 V)
 | 4 | Nicht belegt
Abgesicherter Ausgang 1 | 5 | Abgesicherte + 24 V DC, (intern verbunden mit positivem Powerkontakt)
Abgesicherter Ausgang 1 über Powerkontakt |  | Abgesicherte + 24 V DC, (intern verbunden mit Ausgang 1)
Einspeisung 24 V | 6 | +24 V DC Eingangsspannung (intern verbunden mit Klemmstelle 2)
Einspeisung 0 V | 7 | 0 V DC Eingangsspannung (intern verbunden mit Klemmstelle 3 und Powerkontakt 0 V)
 | 8 | Nicht belegt
Bedeutung der LEDs und Taster-LED EL9221-xxxx
LED | Farbe | Bedeutung
Taster-LED 1 | Dieser Taster-LED 1 gibt den Status zu Ausgang 1 an
 | Grün | aus | Ausgang 1 ausgeschaltet
 |  | an | Ausgang 1 eingeschaltet
 |  | blinkend | Programmiermodus aktiv: Zulässiger Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.).
 |  | flimmernd | Ausschaltvorgang noch nicht abgeschlossen, Verdrahtungsfehler: Spannung am ausgeschalteten Ausgang erkannt (zusammen mit Ready LED grün)
 | Orange | an | Ausgang 1 eingeschaltet + Vorwarnungsschwelle erreicht
 |  | aufblitzen (nach drücken) | Ausgang 1 gesperrt (Nennstromwert ist auf „AUS“ gestellt)
 |  | blinkend | Rückwärtsstrom aktiv Oder Abfragemodus oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Nennstromwert nicht veränderbar da gesperrt oder fixe Variante; eingestellter Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A; etc.)
 | Rot | an | Ausgang 1 ausgelöst
 |  | blinkend | Ausgang 1 ausgelöst und Abkühlphase aktiv
Run-LED | Run-LED gibt den EtherCAT Betriebszustand der Klemme wieder
 | Grün | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Die Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Ready-LED | Ready-LED gibt den Status zum Überstromschutz / Programmiermodus / Abfragemodus an
 | Grün | an | 24 V DC Versorgungsspannung vorhanden und Initialisierung abgeschlossen, Überstromschutz aktiv, Betriebsmodus aktiv
 | Orange | an | Programmiermodus / Abfragemodus aktiv
 | Rot | an | Fehlende 24 V DC Versorgungsspannung oder Initialisierungsfehler
 |  | blinkend | Laden der Werkseinstellungen
 |  | flimmernd | Verdrahtungsfehler oder Kabelbruch (z.B. falscher Massebezug)
Die EL9221-xxxx verfügt über einen Leuchtdrucktaster!
Der Leuchtdrucktaster ermöglicht das Bedienen der Überstromschutzklemme wie z.B. Ein- und Ausschalten sowie Reset des Ausgangs. Zusätzlich ist er für die Programmierung und Abfrage des Nennstroms zuständig. Es existieren 3 Modi: Betriebsmodus, Programmiermodus und Abfragemodus.
Bei der EL9221-xxxx hat nur der Taster-LED 1 eine Funktion, da es eine 1-kanalige Variante ist.
Übersicht der 3 Betriebsmodi:
Betriebsmodus
Der Betriebsmodus ist aktiv, sobald die Überstromschutzklemme mit Versorgungsspannung versorgt wird, die Initialisierung erfolgreich durchlaufen wurde und kein anderer Modus aktiv ist. Dies ist quasi der Normalbetrieb.
Programmiermodus
Der Programmiermodus ist bei den einstellbaren Überstromschutzklemmen vorhanden. Um in diesen Modus zu gelangen, halten sie den Taster im Betriebsmodus für > 3 Sekunden gedrückt.
Abfragemodus
Der Abfragemodus existiert bei den fixen Überstromschutzklemmen, welche nicht einstellbar sind. Ist die Programmierung bei den einstellbaren Überstromschutzklemmen gesperrt, so existiert dann ebenfalls nur der Abfragemodus. Im Abfragemodus können keine Veränderungen vorgenommen werden, er ist nur zur Abfrage des Nennstromwertes. Um in diesen Modus zu gelangen halten sie den Taster im Betriebsmodus für > 3 Sekunden gedrückt.
Die Bedienung in den jeweiligen Modi entnehmen sie der Tabelle LED Taster Bedienung / Programmierung.
Taster-LED Bedienung / Programmierung
LED | Zustand | Bedeutung
Bedienung im Betriebsmodus
Taster-LED 1 | Kurz drücken | Ein- und Ausschalten bzw. Reset von Ausgang 1
 | Lang drücken (>3s) | Aktivieren des Programmiermodus oder Abfragemodus
Bedienung im Programmiermodus
Taster-LED 1 | Kurz drücken | Nennstromwert von Ausgang 1 einstellen, 1x drücken = 1A, 2x drücken = 2A, …, 10x drücken = 10 A, ≥ 11x drücken = AUS Bei den Varianten bis 4 A gilt ≥ 5 x drücken = AUS
 | Lang drücken (>3s) | Speichern des Nennstromwertes und Verlassen des Programmiermodus
Für 45 Sekunden keine Bedienung |  | Nach 45 Sekunden wird der Programmiermodus ohne Speichern der Einstellungen automatisch wieder verlassen
Bedienung im Abfragemodus
Taster-LED 1 | Kurz drücken | Keine Funktion
 | Lang drücken (>3s) | Verlassen des Abfragemodus
Für 45 Sekunden keine Bedienung |  | Nach 45 Sekunden wird der Abfragemodus der Einstellungen automatisch wieder verlassen
Beispielprogrammierungen
Weitere Beispielprogrammierungen finden Sie im Kapitel „Beispielprogrammierungen“
Verhalten der Ausgänge bei Änderungen der Einstellungen
Werden im laufenden Betrieb (Ausgänge sind eingeschaltet) Einstellungen geändert, bleiben die Ausgänge eingeschaltet. Dies hat den Vorteil, dass die Anlage in Betrieb bleiben kann und eine Änderung “online“ erfolgen kann.


EL9222-xxxx

Montage und Verdrahtung [image] LEDs und Anschlussbelegung, Programmierung mit LED-Tastern [image] EL9222-xxxx
EL9222-xxxx
LEDs und Anschlussbelegung
EL9222-5500, Zuordnung und Benennung der Anschlüsse und LEDs
Bedeutung der Anschlüsse
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Digital Eingang 1 | 1 | Digitaler Eingang zum Schalten des Ausgangs 1 (neg. Flanke; 0 V Bezug wie Einspeisung)
Einspeisung 24 V | 2 | +24 V DC Eingangsspannung (intern verbunden mit Klemmstelle 6)
Einspeisung 0 V | 3 | 0 V DC Eingangsspannung (intern verbunden mit Klemmstelle 7 und Powerkontakt 0 V)
Digital Eingang 2 | 4 | Digitaler Eingang zum Schalten des Ausgangs 2 (neg. Flanke; 0 V Bezug wie Einspeisung)
Abgesicherter Ausgang 1 | 5 | Abgesicherte + 24 V DC, (intern verbunden mit positivem Powerkontakt)
Abgesicherter Ausgang 1 über Powerkontakt |  | Abgesicherte + 24 V DC, (intern verbunden mit Ausgang 1)
Einspeisung 24 V | 6 | +24 V DC Eingangsspannung (intern verbunden mit Klemmstelle 2)
Einspeisung 0 V | 7 | 0 V DC Eingangsspannung (intern verbunden mit Klemmstelle 3 und Powerkontakt 0 V)
Abgesicherter Ausgang 2 | 8 | Abgesicherte + 24 V DC,
Bedeutung der LEDs und Taster-LEDs EL9222-xxxx
LED | Farbe | Bedeutung
Taster-LED 1 | Taster-LED 1 gibt den Status zu Ausgang 1 an.
 | Grün | aus | Ausgang 1 ausgeschaltet
 |  | an | Ausgang 1 eingeschaltet
 |  | blinkend | Programmiermodus aktiv: Zulässiger Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.).
 |  | flimmernd | Ausschaltvorgang noch nicht abgeschlossen, Verdrahtungsfehler: Spannung am ausgeschalteten Ausgang erkannt (zusammen mit Ready LED grün)
 | Orange | an | Ausgang 1 eingeschaltet + Vorwarnungsschwelle erreicht
 |  | aufblitzen (nach drücken) | Ausgang 1 gesperrt (Nennstromwert ist auf „AUS“ gestellt)
 |  | blinkend | Rückwärtsstrom aktiv Oder Abfragemodus oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Nennstromwert nicht veränderbar da gesperrt oder fixe Variante; eingestellter Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A; etc.)
 | Rot | an | Ausgang 1 ausgelöst
 |  | blinkend | Ausgang 1 ausgelöst und Abkühlphase aktiv; Oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Summenstrom beider Ausgänge überschritten, unzulässiger Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.)
Run-LED | Run-LED gibt den EtherCAT Betriebszustand der Klemme wieder
 | Grün | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Die Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Ready-LED | Ready-LED gibt den Status zum Überstromschutz / Programmiermodus / Abfragemodus an
 | Grün | an | 24 V DC Versorgungsspannung vorhanden und Initialisierung abgeschlossen, Überstromschutz aktiv, Betriebsmodus aktiv
 | Orange | an | Programmiermodus / Abfragemodus aktiv
 | Rot | an | Fehlende 24 V DC Versorgungsspannung oder Initialisierungsfehler
 |  | blinkend | Laden der Werkseinstellungen
 |  | flimmernd | Verdrahtungsfehler oder Kabelbruch (z.B. falscher Massebezug)
Taster-LED 2 | Taster-LED 2 gibt den Status zu Ausgang 2 an.
 |  | aus | Ausgang 2 ausgeschaltet
 | Grün | an | Ausgang 2 eingeschaltet
 |  | blinkend | Programmiermodus aktiv: Zulässiger Nennstromwert für Ausgang 2 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.).
 |  | flimmernd | Ausschaltvorgang noch nicht abgeschlossen, Verdrahtungsfehler: Spannung am ausgeschalteten Ausgang erkannt (zusammen mit Ready LED grün)
 | Orange | an | Ausgang 2 eingeschaltet + Vorwarnungsschwelle erreicht
 |  | aufblitzen (nach drücken) | Ausgang 2 gesperrt (Nennstromwert ist auf „AUS“ gestellt)
 |  | blinkend | Rückwärtsstrom aktiv Oder Abfragemodus oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Nennstromwert nicht veränderbar da gesperrt oder fixe Variante; eingestellter Nennstromwert für Ausgang 2 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A; etc.).
 | Rot | an | Ausgang 2 ausgelöst
 |  | blinkend | Ausgang 2 ausgelöst und Abkühlphase aktiv; oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Summenstrom beider Ausgänge überschritten, unzulässiger Nennstromwert für Ausgang 2 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.)
Die EL9222-xxxx verfügt über Leuchtdrucktaster!
Die Leuchtdrucktaster ermöglichen das Bedienen der Überstromschutzklemme wie z.B. Ein- und Ausschalten sowie Reset des jeweiligen Ausgangs. Zusätzlich sind sie für die Programmierung und Abfrage des Nennstroms zuständig. Es existieren 3 Modi: Betriebsmodus, Programmiermodus und Abfragemodus. Es existiert ein gemeinsamer Programmiermodus in dem die beiden Ausgänge gleichzeitig eingestellt werden können, da sie bei der Klemme mit Summenstrombegrenzung voneinander abhängig sind.
Übersicht der 3 Betriebsmodi:
Betriebsmodus
Der Betriebsmodus ist aktiv, sobald die Überstromschutzklemme mit Versorgungsspannung versorgt wird, die Initialisierung erfolgreich durchlaufen wurde und kein anderer Modus aktiv ist. Dies ist quasi der Normalbetrieb.
Programmiermodus
Der Programmiermodus ist bei den einstellbaren Überstromschutzklemmen vorhanden. Um in diesen Modus zu gelangen, halten sie einen der beiden Taster im Betriebsmodus für > 3 Sekunden gedrückt. Im Programmiermodus können beide Ausgänge gleichzeitig eingestellt werden.
Abfragemodus
Der Abfragemodus existiert bei den fixen Überstromschutzklemmen, welche nicht einstellbar sind. Ist die Programmierung bei den einstellbaren Überstromschutzklemmen gesperrt, so existiert dann ebenfalls nur der Abfragemodus. Im Abfragemodus können keine Veränderungen vorgenommen werden, er ist nur zur Abfrage des Nennstromwertes. Um in diesen Modus zu gelangen, halten sie einen der beiden Taster im Betriebsmodus für > 3 Sekunden gedrückt.
Die Bedienung in den jeweiligen Modi entnehmen sie der Tabelle LED Taster Bedienung / Programmierung.
Taster-LED Bedienung / Programmierung
LED | Zustand | Bedeutung
Bedienung im Betriebsmodus
Taster-LED 1 | Kurz drücken | Ein- und Ausschalten bzw. Reset von Ausgang 1
 | Lang drücken (>3s) | Aktivieren des Programmiermodus oder Abfragemodus
Taster-LED 2 | Kurz drücken | Ein- und Ausschalten bzw. Reset von Ausgang 2
 | Lang drücken (>3s) | Aktivieren des Programmiermodus oder Abfragemodus
Bedienung im Programmiermodus
Taster-LED 1 | Kurz drücken | Nennstromwert von Ausgang 1 einstellen, 1x drücken = 1A, 2x drücken = 2A, …, 10x drücken = 10 A, ≥ 11x drücken = AUS Bei den Varianten bis 4 A gilt ≥ 5x drücken = AUS
 | Lang drücken (>3s) | Speichern des Nennstromwertes und Verlassen des Programmiermodus
Taster-LED 2 | Kurz drücken | Nennstromwert von Ausgang 2 einstellen, 1x drücken = 1A, 2x drücken = 2A, …, 10x drücken = 10 A, ≥ 11x drücken = AUS Bei den Varianten bis 4 A gilt ≥ 5x drücken = AUS
 | Lang drücken (>3s) | Speichern des Nennstromwertes und Verlassen des Programmiermodus
Taster-LED 1 und 2 gleichzeitig drücken für > 5 s |  | Zurücksetzen auf Werkseinstellungen
Für 45 Sekunden keine Bedienung |  | Nach 45 Sekunden wird der Programmiermodus ohne Speichern der Einstellungen automatisch wieder verlassen
Bedienung im Abfragemodus
Taster-LED 1 | Kurz drücken | Keine Funktion
 | Lang drücken (>3s) | Verlassen des Abfragemodus
Taster-LED 2 | Kurz drücken | Keine Funktion
 | Lang drücken (>3s) | Verlassen des Abfragemodus
Für 45 Sekunden keine Bedienung |  | Nach 45 Sekunden wird der Abfragemodus der Einstellungen automatisch wieder verlassen
Beispielprogrammierungen
Weitere Beispielprogrammierungen finden Sie im Kapitel „Beispielprogrammierungen“
Verhalten der Ausgänge bei Änderungen der Einstellungen
Werden im laufenden Betrieb (Ausgänge sind eingeschaltet) Einstellungen geändert, bleiben die Ausgänge eingeschaltet. Dies hat den Vorteil, dass die Anlage in Betrieb bleiben kann und eine Änderung “online“ erfolgen kann.
Die EL9222-5500 hat eine Summenstrombegrenzung von 10 A.
Die 10 A können individuell auf beide Kanäle aufgeteilt werden. Wird ein Kanal auf 10 A eingestellt, so muss der andere Kanal auf AUS gesetzt werden! Ist der Summenstrom überschritten blinken der Taster-LED 1 und der Taster-LED 2 rot.
An Hand des Blinkcodes kann abgelesen werden wie die Kanäle eingestellt wurden, und es muss mindestens ein Kanal verändert werden.
Nach Erreichen oder Unterschreiten des Summenstroms blinken der Taster-LED 1 und der Taster-LED 2 wieder grün oder sind aus. Erst jetzt kann der Programmiermodus gespeichert und verlassen werden.


EL9227-xxxx

Montage und Verdrahtung [image] LEDs und Anschlussbelegung, Programmierung mit LED-Tastern [image] EL9227-xxxx
EL9227-xxxx
LEDs und Anschlussbelegung
EL9227-5500, Zuordnung und Benennung der Anschlüsse und LEDs
Bedeutung der Anschlüsse
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Digital Eingang 1 | 1 | Digitaler Eingang zum Schalten des Ausgangs 1 (neg. Flanke; 0 V Bezug wie Einspeisung)
Einspeisung 24 V | 2 | +24 V DC Eingangsspannung (intern verbunden mit Klemmstelle 6)
Einspeisung 0 V | 3 | 0V DC Eingangsspannung (intern verbunden mit Klemmstelle 7 und Powerkontakt 0 V)
Digital Eingang 2 | 4 | Digitaler Eingang zum Schalten des Ausgangs 2 (neg. Flanke; 0 V Bezug wie Einspeisung)
Abgesicherter Ausgang 1 | 5 | Abgesicherte + 24 V DC, (intern verbunden mit positivem Powerkontakt)
Abgesicherter Ausgang 1 über Powerkontakt |  | Abgesicherte + 24 V DC, (intern verbunden mit Ausgang 1)
Einspeisung 24 V | 6 | +24 V DC Eingangsspannung (intern verbunden mit Klemmstelle 2)
Einspeisung 0 V | 7 | 0V DC Eingangsspannung (intern verbunden mit Klemmstelle 3 und Powerkontakt 0 V)
Abgesicherter Ausgang 2 | 8 | Abgesicherte + 24 V DC,
Bedeutung der LEDs und Taster-LEDs EL9227-xxxx
LED | Farbe | Bedeutung
Taster-LED 1 | Taster-LED 1 gibt den Status zu Ausgang 1 an.
 | Grün | aus | Ausgang 1 ausgeschaltet
 |  | an | Ausgang 1 eingeschaltet
 |  | blinkend | Programmiermodus aktiv; zulässiger Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.).
 |  | flimmernd | Ausschaltvorgang noch nicht abgeschlossen (zusammen mit Ready LED grün), Verdrahtungsfehler: Spannung am ausgeschalteten Ausgang erkannt (zusammen mit Ready LED rot)
 | Orange | an | Ausgang 1 eingeschaltet + Vorwarnungsschwelle erreicht
 |  | aufblitzen (nach drücken) | Ausgang 1 gesperrt (Nennstromwert ist auf „AUS“ gestellt)
 |  | blinkend | Abfragemodus oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Nennstromwert nicht veränderbar da gesperrt oder fixe Variante; eingestellter Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A; etc.)
 | Rot | an | Ausgang 1 ausgelöst
 |  | blinkend | Programmiermodus aktiv (zusätzlich Ready-LED orange an): Summenstrom beider Ausgänge überschritten, unzulässiger Nennstromwert für Ausgang 1 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.)
Run-LED | Run-LED gibt den EtherCAT Betriebszustand der Klemme wieder
 | Grün | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Die Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Status-LED 1 | Status-LED 1 gibt Zusatzinfos zu Ausgang 1 an
 | Orange | an | Ausgang 1 hat Unter- oder Überspannung erkannt
 | Rot | blinkend | Abkühlphase Ausgang 1 aktiv
Ready-LED | Ready-LED gibt den Status zum Überstromschutz / Programmiermodus / Abfragemodus an
 | Grün | an | 24 V DC Versorgungsspannung vorhanden und Initialisierung abgeschlossen, Überstromschutz aktiv, Betriebsmodus aktiv
 | Orange | an | Programmiermodus / Abfragemodus aktiv
 | Rot | an | Fehlende 24 V DC Versorgungsspannung oder Initialisierungsfehler oder Verdrahtungsfehler (zusammen mit Taster-LED grün flimmernd; z.B. Einspeisung am Ausgang)
 |  | blinkend | Laden der Werkseinstellungen
 |  | flimmernd | Verdrahtungsfehler oder Kabelbruch (z.B. falscher Massebezug)
Status-LED 2 | Status-LED 2 gibt Zusatzinfos zu Ausgang 2 an
 | Orange | an | Ausgang 2 hat Unter- oder Überspannung erkannt
 | Rot | blinkend | Abkühlphase Ausgang 2 aktiv
Taster-LED 2 | Taster-LED 2 gibt den Status zu Ausgang 2 an.
 | Grün | aus | Ausgang 2 ausgeschaltet
 |  | an | Ausgang 2 eingeschaltet
 |  | blinkend | Programmiermodus aktiv; zulässiger Nennstromwert für Ausgang 2 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.)
 |  | flimmernd | Ausschaltvorgang noch nicht abgeschlossen (zusammen mit Ready LED grün), Verdrahtungsfehler: Spannung am ausgeschalteten Ausgang erkannt (zusammen mit Ready LED rot)
 | Orange | an | Ausgang 2 eingeschaltet + Vorwarnungsschwelle erreicht
 |  | aufblitzen (nach drücken) | Ausgang 2 gesperrt (Nennstromwert ist auf „AUS“ gestellt)
 |  | blinkend | Abfragemodus oder Programmiermodus aktiv (zusätzlich Ready-LED orange an): Nennstromwert nicht veränderbar da gesperrt oder fixe Variante; eingestellter Nennstromwert für Ausgang 2 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A; etc.)
 | Rot | an | Ausgang 2 ausgelöst
 |  | blinkend | Programmiermodus aktiv (zusätzlich Ready-LED orange an): Summenstrom beider Ausgänge überschritten, unzulässiger Nennstromwert für Ausgang 2 mit Blinkcode ablesbar (1x blinken = 1 A; 2x blinken = 2 A, etc.)
Die EL9227-xxxx verfügt über Leuchtdrucktaster!
Die Leuchtdrucktaster ermöglichen das Bedienen der Überstromschutzklemme wie z.B. Ein- und Ausschalten sowie Reset des jeweiligen Ausgangs. Zusätzlich sind sie für die Programmierung und Abfrage des Nennstroms zuständig. Es existieren 3 Modi: Betriebsmodus, Programmiermodus und Abfragemodus. Es existiert ein gemeinsamer Programmiermodus in dem die beiden Ausgänge gleichzeitig eingestellt werden können, da sie bei der Klemme mit Summenstrombegrenzung voneinander abhängig sind.
Übersicht der 3 Betriebsmodi:
Betriebsmodus
Der Betriebsmodus ist aktiv, sobald die Überstromschutzklemme mit Versorgungsspannung versorgt wird, die Initialisierung erfolgreich durchlaufen wurde und kein anderer Modus aktiv ist. Dies ist quasi der Normalbetrieb.
Programmiermodus
Der Programmiermodus ist bei den einstellbaren Überstromschutzklemmen vorhanden. Um in diesen Modus zu gelangen, halten sie einen der beiden Taster im Betriebsmodus für > 3 Sekunden gedrückt. Im Programmiermodus können beide Ausgänge gleichzeitig eingestellt werden.
Abfragemodus
Der Abfragemodus existiert bei den fixen Überstromschutzklemmen, welche nicht einstellbar sind. Ist die Programmierung bei den einstellbaren Überstromschutzklemmen gesperrt, so existiert dann ebenfalls nur der Abfragemodus. Im Abfragemodus können keine Veränderungen vorgenommen werden, er ist nur zur Abfrage des Nennstromwertes. Um in diesen Modus zu gelangen halten sie einen der beiden Taster im Betriebsmodus für > 3 Sekunden gedrückt.
Die Bedienung in den jeweiligen Modi entnehmen sie der Tabelle LED Taster Bedienung / Programmierung.
Taster-LED Bedienung / Programmierung
LED | Zustand | Bedeutung
Bedienung im Betriebsmodus
Taster-LED 1 | Kurz drücken | Ein- und Ausschalten bzw. Reset von Ausgang 1
 | Lang drücken (>3s) | Aktivieren des Programmiermodus oder Abfragemodus
Taster-LED 2 | Kurz drücken | Ein- und Ausschalten bzw. Reset von Ausgang 2
 | Lang drücken (>3s) | Aktivieren des Programmiermodus oder Abfragemodus
Bedienung im Programmiermodus
Taster-LED 1 | Kurz drücken | Nennstromwert von Ausgang 1 einstellen, 1x drücken = 1 A, 2x drücken = 2 A, ….10x drücken = 10 A, ≥ 11x drücken = AUS Bei den Varianten bis 4 A gilt ≥ 5x drücken = AUS
 | Lang drücken (>3s) | Speichern des Nennstromwertes und Verlassen des Programmiermodus
Taster-LED 2 | Kurz drücken | Nennstromwert von Ausgang 2 einstellen, 1x drücken = 1 A, 2x drücken = 2 A, ….10x drücken = 10 A, ≥ 11x drücken = AUS Bei den Varianten bis 4 A gilt ≥ 5x drücken = AUS
 | Lang drücken (>3s) | Speichern des Nennstromwertes und Verlassen des Programmiermodus
Taster-LED 1 und 2 gleichzeitig drücken für > 5s |  | Zurücksetzen auf Werkseinstellungen
Für 45 Sekunden keine Bedienung |  | Nach 45 Sekunden wird der Programmiermodus ohne Speichern der Einstellungen automatisch wieder verlassen
Bedienung im Abfragemodus
Taster-LED 1 | Kurz drücken | Keine Funktion
 | Lang drücken (>3s) | Verlassen des Abfragemodus
Taster-LED 2 | Kurz drücken | Keine Funktion
 | Lang drücken (>3s) | Verlassen des Abfragemodus
Für 45 Sekunden keine Bedienung |  | Nach 45 Sekunden wird der Abfragemodus der Einstellungen automatisch wieder verlassen
Beispielprogrammierungen
Weitere Beispielprogrammierungen finden Sie im Kapitel „Beispielprogrammierungen“
Verhalten der Ausgänge bei Änderungen der Einstellungen
Werden im laufenden Betrieb (Ausgänge sind eingeschaltet) Einstellungen geändert, bleiben die Ausgänge eingeschaltet. Dies hat den Vorteil, dass die Anlage in Betrieb bleiben kann und eine Änderung “online“ erfolgen kann.
Die EL9227-5500 hat eine Summenstrombegrenzung von 10A.
Die 10A können individuell auf beide Kanäle aufgeteilt werden. Wird ein Kanal auf 10 A eingestellt, so muss der andere Kanal auf AUS gesetzt werden! Ist der Summenstrom überschritten blinken der Taster-LED 1 und der Taster-LED 2 rot.
An Hand des Blinkcodes kann abgelesen werden wie die Kanäle eingestellt wurden, und es muss mindestens ein Kanal verändert werden.
Nach Erreichen oder Unterschreiten des Summenstroms blinken der Taster-LED 1 und der Taster-LED 2 wieder grün oder sind aus. Erst jetzt kann der Programmiermodus gespeichert und verlassen werden.


Beispielprogrammierung

Montage und Verdrahtung [image] LEDs und Anschlussbelegung, Programmierung mit LED-Tastern [image] Beispielprogrammierung
Beispielprogrammierung
Die EL922x verfügen über Leuchtdrucktaster!
Die Leuchtdrucktaster ermöglichen das Bedienen der Überstromschutzklemme wie z.B. Ein- und Ausschalten sowie Reset des jeweiligen Ausgangs. Zusätzlich sind sie für die Programmierung und Abfrage des Nennstroms zuständig. Es existieren 3 Modi: Betriebsmodus, Programmiermodus und Abfragemodus. Es existiert ein gemeinsamer Programmiermodus in dem beide Ausgänge gleichzeitig eingestellt werden können, da sie bei der Klemme mit Summenstrombegrenzung voneinander abhängig sind
1. Durch Drücken der Taster-LED 1 oder Taster-LED 2 für >3 Sekunden gelangen Sie in den Programmiermodus.
2. Ready-LED leuchtet orange und zeigt an, dass sie sich im Programmiermodus befinden.
3. Per grünem Blinkcode zeigt der Taster-LED 1 den noch aktuell eingestellten Nennstrom von Kanal 1 an und der Taster-LED 2 den von Kanal 2. Einmal blinken heißt 1 A, zweimal blinken 2 A, dreimal blinken 3 A, etc… Ein nicht blinken steht für AUS.
4. Der Programmiermodus wird automatisch verlassen, wenn nach 45 Sekunden keine Eingaben getätigt wurden und die Einstellungen, welche vorher getätigt wurden, werden nicht gespeichert. Es bleiben somit die alten gespeicherten Einstellungen erhalten.
5. Eine Veränderung der Nennströme erfolgt durch Eingabe der absoluten Stromwerte.
D.h. 1 x drücken durch Taster-LED 1 oder 2 = 1 A, 2 x drücken = 2 A, 3 x drücken = 3 A, …, 10 x drücken = 10 A, ≥11 mal drücken = AUS!
Bei den Varianten bis 4 A ist ≥5 mal drücken = AUS!
6. Durch Drücken der Taster-LED 1 oder Taster-LED 2 für >3 Sekunden werden die neuen Einstellungen gespeichert, der Programmiermodus verlassen und die neuen Werte sind aktiv.
Verhalten der Ausgänge bei Änderungen der Einstellungen
Werden im laufenden Betrieb (Ausgänge sind eingeschaltet) Einstellungen geändert, bleiben die Ausgänge eingeschaltet. Dies hat den Vorteil, dass die Anlage in Betrieb bleiben kann und eine Änderung “online“ erfolgen kann.
Beispielprogrammierung 1
Bedienung | Anzeige | Bedeutung
Taster-LED 1 für >3 Sekunden drücken |  | Programmiermodus aktivieren
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 6 x grün Taster-LED 2 blinkt 2 x grün | Programmiermodus ist aktiv Ausgang 1 steht auf 6 A Ausgang 2 steht auf 2 A
8 x drücken von Taster-LED1 |  | Ausgang 1 wird auf 8 A gestellt
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 8 x grün Taster-LED 2 blinkt 2 x grün | Programmiermodus ist aktiv Ausgang 1 steht auf 8 A Ausgang 2 steht auf 2 A
Taster-LED 1 für >3 Sekunden drücken |  | Speichern der neuen Einstellungen und beenden des Programmiermodus
Beispielprogrammierung 2
Bedienung | Anzeige | Bedeutung
Taster-LED 1 für >3 Sekunden drücken |  | Programmiermodus aktivieren
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 6 x grün Taster-LED 2 blinkt 4 x grün | Programmiermodus ist aktiv Ausgang 1 steht auf 6 A Ausgang 2 steht auf 4 A
7 x drücken von Taster-LED 1 |  | Ausgang 1 wird auf 7 A gestellt
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 7 x rot Taster-LED 2 blinkt 4 x rot | Programmiermodus ist aktiv Ausgang 1 steht auf 7 A Ausgang 2 steht auf 4 A Summenstrom von 10 A überschritten!!
3 x drücken von Taster-LED2 |  | Ausgang 2 wird auf 3 A gestellt
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 7 x grün Taster-LED 2 blinkt 3 x grün | Programmiermodus ist aktiv Ausgang 1 steht auf 7 A Ausgang 2 steht auf 3 A Summenstrom von 10 A eingehalten!!
Taster-LED 1 für >3 Sekunden drücken |  | Speichern der neuen Einstellungen und beenden des Programmiermodus
Beispielprogrammierung 3
Bedienung | Anzeige | Bedeutung
Taster-LED 2 für >3 Sekunden drücken |  | Programmiermodus aktivieren
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 6 x grün Taster-LED 2 blinkt 4 x grün | Programmiermodus ist aktiv Ausgang 1 steht auf 6 A Ausgang 2 steht auf 4 A
7 x drücken von Taster-LED 1 |  | Ausgang 1 wird auf 7 A gestellt
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 7 x rot Taster-LED 2 blinkt 4 x rot | Programmiermodus ist aktiv Ausgang 1 steht auf 7 A Ausgang 2 steht auf 4 A Summenstrom von 10 A überschritten!!
11 x drücken von Taster-LED 2 |  | Ausgang 2 wird auf Aus gestellt
 | Ready-LED leuchtet orange Taster-LED 1 blinkt 7 x grün Taster-LED 2 leuchtet NICHT | Programmiermodus ist aktiv Ausgang 1 steht auf 7 A Ausgang 2 ist Aus Summenstrom von 10 A eingehalten!!
Taster-LED 1 für >3 Sekunden drücken |  | Speichern der neuen Einstellungen und beenden des Programmiermodus
Die EL9227-5500 / EL9222-5500 haben eine Summenstrombegrenzung von 10A
Die 10A können individuell auf beide Kanäle aufgeteilt werden. Wird ein Kanal auf 10 A eingestellt, so muss der andere Kanal auf AUS gesetzt werden! Ist der Summenstrom überschritten blinken der Taster-LED 1 und der Taster-LED 2 rot.
An Hand des Blinkcodes kann abgelesen werden wie die Kanäle eingestellt wurden, und es muss mindestens ein Kanal verändert werden.
Nach Erreichen oder Unterschreiten des Summenstroms blinken der Taster-LED 1 und der Taster-LED 2 wieder grün oder sind aus. Erst jetzt kann der Programmiermodus gespeichert und verlassen werden.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Die EL922x ist eine EtherCAT Klemme mit elektronischer Überstromschutzfunktion. Die Überstromschutzfunktion steht zu jeder Zeit zur Verfügung. D.h. sobald die Eingangsspannung angelegt wurde ist die Überstromschutzfunktion (nach erfolgreichem Initialisierungsdurchlauf) gegeben, unabhängig ob EtherCAT vorhanden ist oder nicht. Dies hat zur Folge, dass die EL922x auch “Stand-Alone“ ohne EtherCAT betrieben werden kann. Durch diese Funktion sind Anwendungen möglich wo Industrie-PC, Embedded-PC oder Koppler mit 24 V DC versorgt und abgesichert werden können, welche dann später den EtherCAT aufstarten!
Erstmalige Inbetriebnahme
Vor der ersten Inbetriebnahme kontrollieren Sie bitte die Verdrahtung und vergewissern Sie sich, dass diese ordnungsgemäß durchgeführt wurde.
Nach dem ersten Einschalten der Ausgänge kann es dazu kommen, dass diese sofort auslösen und die Taster-LED rot leuchten. Überprüfen Sie den eingestellten Nennstrom. Dimensionieren Sie die Stromversorgung entsprechend hoch um eine sichere Spannungsversorgung auch im Fehlerfall zu gewährleisten. Zu gering dimensionierte Stromversorgungen können nicht nur im Fehlerfall einen Spannungseinbruch zur Folge haben, es kann dann ebenfalls zu häufigen bzw. ungewollten An- und Abschaltungen führen. Dies könnte ebenfalls zur Zerstörung der Elektronik führen.
Kontrollieren Sie die Prozessdaten (Hardware Protection) und die Diag Messages auf Warnungen, die auf einen Verdrahtungsfehler hinweisen könnten. Kontrollieren Sie zusätzlich die Ready LED und die Taster-LEDs auf ein Flimmern. Die Klemme darf in einem solchen Zustand nicht betrieben werden, da dies die Elektronik zerstören könnte.
Bei einer ersten Inbetriebnahme ohne Veränderung der Parameter beinhalten die Klemmen die Werkseinstellungen.
Werkseinstellungen
 | EL9221- |  | EL9222 |  | EL9227
 | -5000 | -6000 | -5500 | -6600 | -5500 | -6600
Nominal Current | 4 A / 4 A | 2 A / 2 A | 4 A / 4 A | 2 A / 2 A | 4 A / 4 A | 2 A / 2 A
Channel Status | Off |  | Off |  | Off
Characteristic | Standard |  | Standard |  | Standard
Current-Level Warning | 90% |  | 90% |  | 90%
Fuse Init State | Last State |  | Last State |  | Last State
Input Functions (DI&Switch) | Reset, On/Off |  | Reset, On/Off |  | Reset, On/Off
Overvoltage Behaviour | Tripping, Auto-Reset |  | Tripping, Auto-Reset |  | Tripping, Auto-Reset
Undervoltage Level | Not available |  | Not available |  | 17 V
Reverse Current Filter | Standard |  | Standard |  | Standard
Switch Programming Control | Enable |  | Enable |  | Enable
Switch On Channel Delay | Not available |  | Not available |  | Disable
Dig Safe State Active | FALSE |  | FALSE |  | FALSE
Dig Safe State Value | FALSE |  | FALSE |  | FALSE
Einstellungen mit Passwortschutz sperren
Es besteht die Möglichkeit über das Objekt 0xF009 (Password Protection, Datentyp UINT32), anwenderseitige Parameterdaten vor versehentlichem Zugriff zu schützen. Der „Passwort-Schutz“ verhindert u.a., dass die Parameter versehentlich überschrieben werden. Der Schutz wird mit dem Passwort 0x12345678 aktiviert und bleibt so lange aktiv, bis der Schutz durch das Passwort 0x11223344 wieder deaktiviert wird. Das Objekt 0xF009 zeigt ebenfalls an, ob der Passwortschutz aktiv oder deaktiviert ist. Hat das Objekt den Wert „1“ ist der Schutz aktiv und ist der Wert des Objekts „0“ ist der Schutz deaktiviert. Bei aktiviertem Schutz ist kein Schreibzugriff auf die Objekte 0x80n0 und 0x80n1 möglich und die Parameter bleiben erhalten. Dies gilt darüber hinaus, wenn ein Wiederherstellen des Auslieferungszustandes der Klemme über das Objekt 0x1011 oder durch die LED-Taster am Gerät durchgeführt werden soll. Nach einem „Reset“ der Klemme z.B. durch Stromlosschalten wird der Schutz nicht wieder deaktiviert. Ein Vermerk der Eingabe des Passwortschutzes wird in der Klemme bleibend gespeichert, bis eine Deaktivierung erfolgt.
Hinweis
Dauer-Reset, Dauer Ein-/Ausschalten
Ein dauerhaft anliegender Reset Vorgang und ein ständiges Ein- und Ausschalten der Versorgungsspannung ist nicht erlaubt. Dies könnte zur Zerstörung der Elektronik führen.
Hinweis
Wiedereinschaltverzögerung
EL9221 / EL9222
Findet innerhalb von 15 Sekunden nach Ablauf einer 10s Wiedereinschaltsperre ein weiteres Auslöse-Ereignis statt, so wird die Abkühlzeit um zusätzliche 10s verlängert. Findet nach Ablauf der dann 20s-Wiedereinschaltsperre wiederum ein weiteres Auslöse-Ereignis innerhalb von 15s statt, so wird die Wiedereinschaltsperre wiederum um 10s verlängert. Dieser Vorgang wird entsprechend fortgesetzt jedoch nur bis zur maximalen Wiedereinschaltzeit von 60s. Findet nach einem beliebigen Auslöse-Ereignis nicht innerhalb von 15s ein weiteres Auslöse-Ereignis statt, so bleibt die Abkühlzeit bei 10s.
EL9227
Die Wiedereinschaltzeit ist von der Innentemperatur der Klemme abhängig. Steigt die Temperatur an, kann die Wiedereinschaltzeit entsprechend erhöht werden.
SmallWarningYellow VORSICHT
Gefahr für Personen, Umwelt oder Geräte!
Beachten Sie, dass die Veränderung von Ausgangswerten direkten Einfluss auf Ihre Automatisierungsanwendung haben kann. Es müssen daher in der Anlage oder Maschine besondere Vorkehrungen getroffen werden, die ein automatisches Wiederanlaufen von Anlagenteilen ausschließen (vgl. Maschinenrichtlinie 2006/42/EG und EN60204-1)!
Nehmen Sie nur Veränderungen an den Ausgangswerten vor, wenn Sie sich sicher sind, das Ihr Anlagenzustand dies erlaubt und keine Gefährdung von Mensch oder Maschine besteht!
In erkannten Fehlerfällen (Kurzschluss/Überlast) wird der Lastkreis durch die Überstromschutzklemme elektronisch abgeschaltet.
Weiterführende Informationen
•
Quick Start: Inbetriebnahme der EL922x ohne EtherCAT
•
Inbetriebnahme und Parametrierung der EL922x mit EtherCAT
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Prozessdaten
•
Objektbeschreibung und Parametrierung


Quick Start: Inbetriebnahme der EL922x ohne EtherCAT

Inbetriebnahme [image] Quick Start: Inbetriebnahme der EL922x ohne EtherCAT
Quick Start: Inbetriebnahme der EL922x ohne EtherCAT
Für eine schnelle Inbetriebnahme der EL922x ohne EtherCAT gehen Sie wie folgt vor
1.
Montage
Montieren Sie die EL922x wie im Kapitel Montage und Verdrahtung beschrieben.
2.
Verdrahtung der Klemme
Spannungsversorgung
Legen Sie die 24 V DC Spannungsversorgung an die jeweiligen Klemmkontakte an. Einspeisung 24 V DC an die Klemmkontakte 2 oder 6 und die Einspeisung 0 V an die Klemmkontakte 3 oder 7. Den maximal erlaubten Eingangsstrom, im Falle einer Weiterleitung der Eingangsspannung, entnehmen sie den techn. Daten.
(Eingangsstrom = Weiterleitungsstrom + Strom der eigenen Klemme)
Abgesicherte Ausgänge
Klemmen Sie den Ausgang 1 an den Klemmpunkt 5 und/oder nutzen Sie den Powerkontakt. Der Ausgang 2 wird über den Klemmpunkt 8 abgegriffen (hier steht kein weiterer Powerkontakt zu Verfügung)
Digitale Eingänge
Klemmen Sie die digitalen Eingänge (zum Schalten und Reseten der Ausgänge) an den Klemmpunkt 1 für das Schalten von Ausgang 1 und an den Klemmpunkt 4 für das Schalten von Ausgang 2.
Es wird eine negative Flanke von 24 V DC benötigt.(gleicher 0 V Bezug wie Eingangsspannung).
Beispielhafte Verdrahtung einer EL9221-5000 und EL9227-5500

Beispielhafte Weiterverdrahtung einer EL9221-5000 zu einer weiteren Klemme

1.
Nennstromeinstellung
Über die Taster-LED 1 oder Taster-LED 2 stellen Sie den gewünschten Nennstrom ein
Programmierabfolge:
Drücken Sie einen der LED Taster für ≥3 Sekunden. Drücken Sie den Taster LED 1 so oft wie Sie den Nennstrom für Ausgang 1 wünschen. 1 mal drücken = 1A, 2 mal drücken = 2 A, …, 10 mal drücken = 10 A, ≥11 mal drücken = AUS; (Bei der 4 A Variante ist ≥5 mal drücken = Aus). Für den Ausgang 2 nehmen Sie den Taster-LED 2. Drücken Sie einen der LED Taster für ≥3 Sekunden um die Eingaben zu speichern. Siehe hierzu auch Kapitel LEDs und Anschlussbelegung, Programmierung mit LED-Taster.
2.
Inbetriebnahme
Die EL922x ist nach erfolgreicher Nennstromeinstellung, Initialisierung und grün leuchtender Ready-LED betriebsbereit.
Kontrolle der Prozessdaten und Diag Messages
Kontrollieren Sie die Prozessdaten (Hardware Protection) und die Diag Messages auf Warnungen, die auf einen Verdrahtungsfehler hinweisen könnten. Kontrollieren Sie zusätzlich die Ready LED und die Taster-LEDs auf ein Flimmern. Die Klemme darf in einem solchen Zustand nicht betrieben werden, da dies die Elektronik zerstören könnte.


Inbetriebnahme und Parametrierung der EL922x mit EtherCAT

Inbetriebnahme [image] Inbetriebnahme und Parametrierung der EL922x mit EtherCAT
Inbetriebnahme und Parametrierung der EL922x mit EtherCAT
Für eine Inbetriebnahme der EL922x mit EtherCAT gehen Sie wie folgt vor:
1.
Montage
Montieren Sie die EL922x wie im Kapitel Montage und Verdrahtung beschrieben.
2.
Verdrahtung der Klemme
Spannungsversorgung
Legen Sie die 24 V DC Spannungsversorgung an die jeweiligen Klemmkontakte an. Einspeisung 24 V DC an die Klemmkontakte 2 oder 6 und die Einspeisung 0 V an die Klemmkontakte 3 oder 7. Den maximal erlaubten Eingangsstrom, im Falle einer Weiterleitung der Eingangsspannung, entnehmen sie den techn. Daten.
(Eingangsstrom = Weiterleitungsstrom + Strom der eigenen Klemme)
Abgesicherter Ausgang
Klemmen Sie den Ausgang 1 an den Klemmpunkt 5 und/oder nutzen Sie den Powerkontakt. Der Ausgang 2 wird über den Klemmpunkt 8 abgegriffen (hier steht kein weiterer Powerkontakt zu Verfügung)
Digitale Eingänge
Klemmen Sie die digitalen Eingänge (zum Schalten und Reseten der Ausgänge) an den Klemmpunkt 1 für das Schalten von Ausgang 1 und an den Klemmpunkt 4 für das Schalten von Ausgang 2. Es wird eine negative Flanke von 24 V DC benötigt.
Beispielhafte Verdrahtung einer EL9221-5000 und EL9227-5500

Beispielhafte Weiterverdrahtung einer EL9221-5000 zu einer weiteren Klemme
3.
Konfiguration
Erstellen Sie eine Konfiguration im TwinCAT Systemmanager, indem Sie die Klemme manuell einfügen oder online scannen. Beachten Sie dazu die Installationskapitel TwinCAT.
EtherCAT XML Device Description
Sollte in Ihrem System die XML-Beschreibung ihrer EL922x nicht vorliegen, können Sie die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterladen und entsprechend der Installationsanweisungen installieren.
4.
Inbetriebnahme
Beachten Sie hier die Hinweise zur Bedienung und Konfiguration mittels der LED-Taster, wie im Kapitel Montage und Verdrahtung beschrieben.
Kontrolle der Prozessdaten und Diag Messages
Kontrollieren Sie die Prozessdaten (Hardware Protection) und die Diag Messages auf Warnungen, die auf einen Verdrahtungsfehler hinweisen könnten. Kontrollieren Sie zusätzlich die Ready LED und die Taster-LEDs auf ein Flimmern. Die Klemme darf in einem solchen Zustand nicht betrieben werden, da dies die Elektronik zerstören könnte.
Für die Einstellung der jeweiligen Parameter gibt es zwei Möglichkeiten, einmal über CoE oder über den Tab “Settings“.
Einstellungen über CoE
Die Einstellungen der jeweiligen Parameter sind wie gewohnt im Index 8000 zu tätigen. Einstellungen für Kanal 1 Index 8000:0, manuelle Kennlinie für Kanal 1 Index 8001:0 (EL9227), Einstellungen für Kanal 2 Index 8010:0, manuelle Kennlinie für Kanal 2 Index 8011:0 (EL9227).
CoE-8000-Settings-EL9227
CoE-8000-Settings-EL9222
DIG Safe State Active (Index 0x80n0:01) / DIG Safe State Value (Index 0x80n1:01)
Die Einstellung in “DIG Safe State Active“ (Index 0x80n0:01) legt fest, ob die Ausgänge bei Busfehler einen sicheren Zustand einnehmen sollen. Mit “DIG Safe State Value“ (Index 0x80n1:01) wird der sichere Zustand des Ausgangs bei Busfehler definiert.
1.
“DIG Safe State Active“ = TRUE und
–
“DIG Safe State Value“ = TRUE: Der Ausgang wird eingeschaltet.
2.
“DIG Safe State Active“ = TRUE und
–
“DIG Safe State Value“ = FALSE: Der Ausgang wird ausgeschaltet
3.
“DIG Safe State Active“ = FALSE
–
Der Zustand des Ausgangs bleibt erhalten. Einträge in “DIG Safe State Value“ (Index 0x80n1:01) haben keine Wirkung.
Beispiel Tabellarisch:
DIG Safe State Active Index 0x80n0:01 | DIG Safe State Value Index 0x80n1:01 | Output before bus error | Output bus error occurs
TRUE | TRUE | FALSE | TRUE
 |  | TRUE | TRUE
TRUE | FALSE | FALSE | FALSE
 |  | TRUE | FALSE
FALSE | FALSE / TRUE | FALSE | FALSE
 |  | TRUE | TRUE
DIG Safe State
Die EL922x haben im Defaultzustand den DIG Safe State Active auf „FALSE“.
Das bedeutet, dass keine Aktion beim Wechseln in den sicheren Zustand (z.B. Watchdog) ausgeführt wird und die Ausgänge im letzten Zustand bleiben.
Bitte beachten Sie, dass die Klemmen auch ohne EtherCAT die Absicherungsfunktion ausführen und bedienbar bleiben. Daher können die Ausgänge, wenn sie im sicheren Zustand sind, dennoch über die LED Taster und die digitale Eingänge geschaltet werden!
Einstellungen über Tab “Settings“
In einer kompakteren Darstellung können die Einstellungen auch über den Tab “Settings“ eingegeben werden. Gehen Sie hierzu wie folgt vor:
▪
Aktivieren sie die Settings-Eingabemaske links oben bei „Enable Settings“ und bestätigen Sie anschließend das Hinweisfenster mit OK. Die Eingabemasken der gebräuchlichsten Parameter werden aktiviert.
▪
Wählen Sie den gewünschten Kanal aus.
▪
Stellen sie die gewünschten Parameter über die Vorwahlfelder (pre-select xxx) ein. Unter jedem Vorwahlfeld ist das dazugehörige Anzeigefeld (active xxx) zu finden. Dort wird der Wert angezeigt, welcher in der Klemme bereits aktiv ist. Um geänderte Parameter in die Klemme zu schreiben, müssen diese mit der Schaltfläche “Apply Online“ übernommen werden.
▪
Bei den Klemmen mit erweiterten Funktionalitäten (EL9227) kann der Mode of operation auch hier umgestellt werden. Siehe hierzu auch Kapitel Prozessdaten.
Enable_Settings - Kopie
Settings with standard parameters – EL9227
Um erweiterte Parameter einstellen zu können, aktivieren Sie rechts oben die advanced settings und es öffnen sich weitere Eingabemasken (fuse Init-State, Input-functions, overvoltage behaviour, undervoltage, reverse current filter, channel delay und manual characteristic). Der Bereich active characteristic ist keine Eingabemaske (Wertefeld grau hinterlegt). Es werden dort nur die Werte der aktiven Kennlinie angezeigt.
Manuelle Kennlinie
Die maximalen Werte für eine manuelle Kennlinie sind die Werte der Slow Kennlinie.
Settings with advanced-parameters
▪
Import/Export
Die Einstellungen können über diese Schaltfläfche inportiert oder exportiert werden.
▪
Product Details
Hier sind Informationen wie z.B. Produktbild mit Anschlusshinweisen zu finden.
▪
Default Values
Durch betätigen dieser Schaltfläche werden die Default-Werte in die Vorwahlfenster geladen. Zur Übernahme sind diese noch mit Apply Online zu bestätigen.


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Klemmenspezifischer Datei-Upload
Dateibenennung bei Überstromschutzklemmen
Die Überstromschutzklemmen EL9227-xxxx haben die Möglichkeit eine Log-Datei zur Verfügung zu stellen. In der Logdatei sind mehrere zurückliegende Auslöseereignisse sowie Einstellungsänderungen zur Nachverfolgung gespeichert. Um die Logdatei vom EtherCAT-Gerät lesen zu können, muss diese als Textdatei mit dem Namen „log.txt“ abgespeichert werden.

Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Download-Revision
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Download-Revision

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Download-Revision
Download-Revision
Download-Revision in der Start-up Liste
Einzelne Klemmen / Module generieren automatisch den Eintrag aus Objekt 0xF081:01 in die Startup-Liste (vgl. Abb. „Download-Revision in der Startup Liste“).
Das Objekt 0xF081:01 (Download revision) beschreibt die Revision der Klemme / des Moduls, z. B. 0x0018000A für EL7201-0010-0024, und ist für die Erfüllung der Kompatibilität notwendig.
Es ist unbedingt darauf zu achten, dass dieser Eintrag nicht aus der Startup Liste gelöscht wird!
Download-Revision in der Startup Liste


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Prozessdaten

Inbetriebnahme [image] Prozessdaten
Prozessdaten
Einführung
In diesem Kapitel werden die wichtigsten PDOs mit ihrem Inhalt vorgestellt. Ein PDO (Prozess-Daten-Objekt) ist eine Einheit an zyklisch übertragenen Prozesswerten. So eine Einheit kann eine einzelne Variable (z. B. die Versorgungsspannung als 32-Bit Wert) oder eine Gruppe/Struktur von Variablen sein. Die einzelnen PDOs lassen sich im TwinCAT System Manager einzeln aktivieren bzw. deaktivieren. Dazu dient der Reiter "Prozessdaten" (nur sichtbar wenn links die Klemme ausgewählt ist). Eine Änderung der Prozessdatenzusammenstellung im TwinCAT-System Manager wird erst nach Neustart des EtherCAT-Systems wirksam.
Weiterführende Informationen
•
EL9221-xxxx
•
EL9222-xxxx
•
EL9227-xxxx


EL9221-xxxx

Inbetriebnahme [image] Prozessdaten [image] EL9221-xxxx
EL9221-xxxx
Weiterführende Informationen
•
PDO-Zuordnung
•
Predefined PDO Assignment


PDO-Zuordnung

Inbetriebnahme [image] Prozessdaten [image] EL9221-xxxx [image] PDO-Zuordnung
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abgeschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
Die folgenden PDO Zuordnungen sind möglich:
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt | Größe (Byte.Bit)
0x1600 (default) OCP Outputs Channel 1 | 2.0 | Control__Reset | Index 0x7000:01 | 0.1
 |  | Control__Switch | Index 0x7000:02 | 0.1
 |  | [Offset] | - | 1.6
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt | Größe (Byte.Bit)
0x1A00 (default) OCP Inputs Channel 1 | 4.0 | Status_Enabled | Index 0x6000:01 | 0.1
 |  | Status_Tripped | Index 0x6000:02 | 0.1
 |  | [Offset] | - | 0.2
 |  | Status_Hardware Protection | Index 0x6000:05 | 0.1
 |  | [Offset] | - | 0.2
 |  | Status_Current Level Warning | Index 0x6000:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6000:09 | 0.1
 |  | [Offset] | - | 0.3
 |  | Status_Diag | Index 0x6000:0D | 0.1
 |  | Status_TxPDO State | Index 0x6000:0E | 0.1
 |  | Status_input cycle counter | Index 0x6000:0F | 0.2
 |  | [Offset] | - | 0.2
 |  | Status_Error | Index 0x6000:13 | 0.1
 |  | Status_State Reset | Index 0x6000:14 | 0.1
 |  | Status_State Switch | Index 0x6000:15 | 0.1
 |  | [Offset] | - | 1.3
Zuverlässige Flankenerkennung
Aufgrund des asynchronen Betriebs der Überstromschutzklemme in Bezug auf den EtherCAT-Master ist es notwendig, eine eindeutige und zuverlässige Flankenerkennung zum Einschalten bzw. Zurücksetzen der Überstromschutzkanäle zu realisieren. Um die Flanken der Prozessdaten-Ausgänge "Switch" bzw. "Reset" innerhalb der Überstromschutzklemme entsprechend sicher zu erkennen, muss der klemmeninterne Zustand dieser Signale als gespiegelte Rückmeldung an den EtherCAT-Master als Prozessdaten-Eingänge zurückgesendet werden. Erst durch Abfrage und Berücksichtigung dieser Signale kann sichergestellt werden, dass keine Flanke unberücksichtigt bleibt. Dadurch kann der Anwender eine „1“ für einen Signal-Flankenwechsel ("Reset" bzw. "Switch") derart lange anstehen lassen, bis das zugehörige Eingangssignal ("State Reset" bzw. "State Switch") die „1“ zurückspiegelt bzw. quittiert. Das Gleiche erfolgt dann im Anschluss auf identisch Weise mit dem entsprechenden „0“-Signal.


Predefined PDO Assignment

Inbetriebnahme [image] Prozessdaten [image] EL9221-xxxx [image] Predefined PDO Assignment
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Die folgenden Predefined PDOs stehen zur Auswahl:
Name | PDO-Zuordnung
Standard Ch.1 | SM2, Outputs | 0x1600 (OCP Outputs Channel 1)
 | SM3, Inputs | 0x1A00 (OCP Inputs Channel 1)


EL9222-xxxx

Inbetriebnahme [image] Prozessdaten [image] EL9222-xxxx
EL9222-xxxx
Weiterführende Informationen
•
PDO-Zuordnung
•
Predefined PDO Assignment


PDO-Zuordnung

Inbetriebnahme [image] Prozessdaten [image] EL9222-xxxx [image] PDO-Zuordnung
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abgeschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
Die folgenden PDO Zuordnungen sind möglich:
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt | Größe (Byte.Bit)
0x1600 (default) OCP Outputs Channel 1 | 2.0 | Control__Reset | Index 0x7000:01 | 0.1
 |  | Control__Switch | Index 0x7000:02 | 0.1
 |  | [Offset] | - | 1.6
0x1601 (default) OCP Outputs Channel 2 | 2.0 | Control__Reset | Index 0x7010:01 | 0.1
 |  | Control__Switch | Index 0x7010:02 | 0.1
 |  | [Offset] | - | 1.6
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt | Größe (Byte.Bit)
0x1A00 (default) OCP Inputs Channel 1 | 4.0 | Status_Enabled | Index 0x6000:01 | 0.1
 |  | Status_Tripped | Index 0x6000:02 | 0.1
 |  | [Offset] | - | 0.2
 |  | Status_Hardware Protection | Index 0x6000:05 | 0.1
 |  | [Offset] | - | 0.2
 |  | Status_Current Level Warning | Index 0x6000:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6000:09 | 0.1
 |  | [Offset] | - | 0.3
 |  | Status_Diag | Index 0x6000:0D | 0.1
 |  | Status_TxPDO State | Index 0x6000:0E | 0.1
 |  | Status_input cycle counter | Index 0x6000:0F | 0.2
 |  | [Offset] | - | 0.2
 |  | Status_Error | Index 0x6000:13 | 0.1
 |  | Status_State Reset | Index 0x6000:14 | 0.1
 |  | Status_State Switch | Index 0x6000:15 | 0.1
 |  | [Offset] | - | 1.3
0x1A01 (default) OCP Inputs Channel 2 | 4.0 | Status_Enabled | Index 0x6010:01 | 0.1
 |  | Status_Tripped | Index 0x6010:02 | 0.1
 |  | [Offset] | - | 0.2
 |  | Status_Hardware Protection | Index 0x6010:05 | 0.1
 |  | [Offset] | - | 0.2
 |  | Status_Current Level Warning | Index 0x6010:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6010:09 | 0.1
 |  | [Offset] | - | 0.3
 |  | Status_Diag | Index 0x6010:0D | 0.1
 |  | Status_TxPDO State | Index 0x6010:0E | 0.1
 |  | Status_input cycle counter | Index 0x6010:0F | 0.2
 |  | [Offset] | - | 0.2
 |  | Status_Error | Index 0x6010:13 | 0.1
 |  | Status_State Reset | Index 0x6010:14 | 0.1
 |  | Status_State Switch | Index 0x6010:15 | 0.1
 |  | [Offset] | - | 1.3
Zuverlässige Flankenerkennung
Aufgrund des asynchronen Betriebs der Überstromschutzklemme in Bezug auf den EtherCAT-Master ist es notwendig, eine eindeutige und zuverlässige Flankenerkennung zum Einschalten bzw. Zurücksetzen der Überstromschutzkanäle zu realisieren. Um die Flanken der Prozessdaten-Ausgänge "Switch" bzw. "Reset" innerhalb der Überstromschutzklemme entsprechend sicher zu erkennen, muss der klemmeninterne Zustand dieser Signale als gespiegelte Rückmeldung an den EtherCAT-Master als Prozessdaten-Eingänge zurückgesendet werden. Erst durch Abfrage und Berücksichtigung dieser Signale kann sichergestellt werden, dass keine Flanke unberücksichtigt bleibt. Dadurch kann der Anwender eine „1“ für einen Signal-Flankenwechsel ("Reset" bzw. "Switch") derart lange anstehen lassen, bis das zugehörige Eingangssignal ("State Reset" bzw. "State Switch") die „1“ zurückspiegelt bzw. quittiert. Das Gleiche erfolgt dann im Anschluss auf identisch Weise mit dem entsprechenden „0“-Signal.


Predefined PDO Assignment

Inbetriebnahme [image] Prozessdaten [image] EL9222-xxxx [image] Predefined PDO Assignment
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Die folgenden Predefined PDOs stehen zur Auswahl:
Name | PDO-Zuordnung
Standard 2 Ch. | SM2, Outputs | 0x1600 (OCP Outputs Channel 1)
 |  | 0x1601 (OCP Outputs Channel 2)
 | SM3, Inputs | 0x1A00 (OCP Inputs Channel 1)
 |  | 0x1A01 (OCP Inputs Channel 2)


EL9227-xxxx

Inbetriebnahme [image] Prozessdaten [image] EL9227-xxxx
EL9227-xxxx
Weiterführende Informationen
•
PDO-Zuordnung
•
Predefined PDO Assignment


PDO-Zuordnung

Inbetriebnahme [image] Prozessdaten [image] EL9227-xxxx [image] PDO-Zuordnung
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abgeschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
Die folgenden PDO Zuordnungen sind möglich:
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt | Größe (Byte.Bit)
0x1600 (default) OCP Outputs Channel 1 | 2.0 | Control__Reset | Index 0x7000:01 | 0.1
 |  | Control__Switch | Index 0x7000:02 | 0.1
 |  | [Offset] | - | 1.6
0x1601 (default) OCP Outputs Channel 2 | 2.0 | Control__Reset | Index 0x7010:01 | 0.1
 |  | Control__Switch | Index 0x7010:02 | 0.1
 |  | [Offset] | - | 1.6
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt | Größe (Byte.Bit)
0x1A00 (default) OCP Inputs Channel 1 | 12.0 | Status_Enabled | Index 0x6000:01 | 0.1
 |  | Status_Tripped | Index 0x6000:02 | 0.1
 |  | Status_Short Circuit | Index 0x6000:03 | 0.1
 |  | Status_Overload | Index 0x6000:04 | 0.1
 |  | Status_Hardware Protection | Index 0x6000:05 | 0.1
 |  | Status_Overvoltage | Index 0x6000:06 | 0.1
 |  | Status_Undervoltage | Index 0x6000:07 | 0.1
 |  | Status_Current Level Warning | Index 0x6000:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6000:09 | 0.1
 |  | Status_Disabled By Switch | Index 0x6000:0A | 0.1
 |  | Status_Disabled By DI | Index 0x6000:0B | 0.1
 |  | Status_Disabled By Output | Index 0x6000:0C | 0.1
 |  | Status_Diag | Index 0x6000:0D | 0.1
 |  | Status_TxPDO State | Index 0x6000:0E | 0.1
 |  | Status_input cycle counter | Index 0x6000:0F | 0.2
 |  | Status_State Device Switch | Index 0x6000:11 | 0.1
 |  | Status_State Digital Input | Index 0x6000:12 | 0.1
 |  | Status_Error | Index 0x6000:13 | 0.1
 |  | Status_State Reset | Index 0x6000:14 | 0.1
 |  | Status_State Switch | Index 0x6000:15 | 0.1
 |  | [Offset] | - | 1.3
 |  | Load [%] | Index 0x6000:21 | 2.0
 |  | Current [0,01 A] | Index 0x6000:22 | 2.0
 |  | Voltage In [0,1 V] | Index 0x6000:23 | 2.0
 |  | Voltage Out [0,1 V] | Index 0x6000:24 | 2.0
0x1A01 (default) OCP Inputs Channel 2 | 12.0 | Status_Enabled | Index 0x6010:01 | 0.1
 |  | Status_Tripped | Index 0x6010:02 | 0.1
 |  | Status_Short Circuit | Index 0x6010:03 | 0.1
 |  | Status_Overload | Index 0x6010:04 | 0.1
 |  | Status_Hardware Protection | Index 0x6010:05 | 0.1
 |  | Status_Overvoltage | Index 0x6010:06 | 0.1
 |  | Status_Undervoltage | Index 0x6010:07 | 0.1
 |  | Status_Current Level Warning | Index 0x6010:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6010:09 | 0.1
 |  | Status_Disabled By Switch | Index 0x6010:0A | 0.1
 |  | Status_Disabled By DI | Index 0x6010:0B | 0.1
 |  | Status_Disabled By Output | Index 0x6010:0C | 0.1
 |  | Status_Diag | Index 0x6010:0D | 0.1
 |  | Status_TxPDO State | Index 0x6010:0E | 0.1
 |  | Status_input cycle counter | Index 0x6010:0F | 0.2
 |  | Status_State Device Switch | Index 0x6010:11 | 0.1
 |  | Status_State Digital Input | Index 0x6010:12 | 0.1
 |  | Status_Error | Index 0x6010:13 | 0.1
 |  | Status_State Reset | Index 0x6010:14 | 0.1
 |  | Status_State Switch | Index 0x6010:15 | 0.1
 |  | [Offset] | - | 1.3
 |  | Load [%] | Index 0x6010:21 | 2.0
 |  | Current [0,01 A] | Index 0x6010:22 | 2.0
 |  | Voltage In [0,1 V] | Index 0x6010:23 | 2.0
 |  | Voltage Out [0,1 V] | Index 0x6010:24 | 2.0
0x1A02 OCP Inputs Channel 1 Compact | 4.0 | Status_Enabled | Index 0x6000:01 | 0.1
 |  | Status_Tripped | Index 0x6000:02 | 0.1
 |  | Status_Short Circuit | Index 0x6000:03 | 0.1
 |  | Status_Overload | Index 0x6000:04 | 0.1
 |  | Status_Hardware Protection | Index 0x6000:05 | 0.1
 |  | Status_Overvoltage | Index 0x6000:06 | 0.1
 |  | Status_Undervoltage | Index 0x6000:07 | 0.1
 |  | Status_Current Level Warning | Index 0x6000:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6000:09 | 0.1
 |  | Status_Disabled By Switch | Index 0x6000:0A | 0.1
 |  | Status_Disabled By DI | Index 0x6000:0B | 0.1
 |  | Status_Disabled By Output | Index 0x6000:0C | 0.1
 |  | Status_Diag | Index 0x6000:0D | 0.1
 |  | Status_TxPDO State | Index 0x6000:0E | 0.1
 |  | Status_input cycle counter | Index 0x6000:0F | 0.2
 |  | Status_State Device Switch | Index 0x6000:11 | 0.1
 |  | Status_State Digital Input | Index 0x6000:12 | 0.1
 |  | Status_Error | Index 0x6000:13 | 0.1
 |  | Status_State Reset | Index 0x6000:14 | 0.1
 |  | Status_State Switch | Index 0x6000:15 | 0.1
 |  | [Offset] | - | 1.3
0x1A03 OCP Inputs Channel 2 Compact | 4.0 | Status_Enabled | Index 0x6010:01 | 0.1
 |  | Status_Tripped | Index 0x6010:02 | 0.1
 |  | Status_Short Circuit | Index 0x6010:03 | 0.1
 |  | Status_Overload | Index 0x6010:04 | 0.1
 |  | Status_Hardware Protection | Index 0x6010:05 | 0.1
 |  | Status_Overvoltage | Index 0x6010:06 | 0.1
 |  | Status_Undervoltage | Index 0x6010:07 | 0.1
 |  | Status_Current Level Warning | Index 0x6010:08 | 0.1
 |  | Status_Cool Down Lock | Index 0x6010:09 | 0.1
 |  | Status_Disabled By Switch | Index 0x6010:0A | 0.1
 |  | Status_Disabled By DI | Index 0x6010:0B | 0.1
 |  | Status_Disabled By Output | Index 0x6010:0C | 0.1
 |  | Status_Diag | Index 0x6010:0D | 0.1
 |  | Status_TxPDO State | Index 0x6010:0E | 0.1
 |  | Status_input cycle counter | Index 0x6010:0F | 0.2
 |  | Status_State Device Switch | Index 0x6010:11 | 0.1
 |  | Status_State Digital Input | Index 0x6010:12 | 0.1
 |  | Status_Error | Index 0x6010:13 | 0.1
 |  | Status_State Reset | Index 0x6010:14 | 0.1
 |  | Status_State Switch | Index 0x6010:15 | 0.1
 |  | [Offset] | - | 1.3
Zuverlässige Flankenerkennung
Aufgrund des asynchronen Betriebs der Überstromschutzklemme in Bezug auf den EtherCAT-Master ist es notwendig, eine eindeutige und zuverlässige Flankenerkennung zum Einschalten bzw. Zurücksetzen der Überstromschutzkanäle zu realisieren. Um die Flanken der Prozessdaten-Ausgänge "Switch" bzw. "Reset" innerhalb der Überstromschutzklemme entsprechend sicher zu erkennen, muss der klemmeninterne Zustand dieser Signale als gespiegelte Rückmeldung an den EtherCAT-Master als Prozessdaten-Eingänge zurückgesendet werden. Erst durch Abfrage und Berücksichtigung dieser Signale kann sichergestellt werden, dass keine Flanke unberücksichtigt bleibt. Dadurch kann der Anwender eine „1“ für einen Signal-Flankenwechsel ("Reset" bzw. "Switch") derart lange anstehen lassen, bis das zugehörige Eingangssignal ("State Reset" bzw. "State Switch") die „1“ zurückspiegelt bzw. quittiert. Das Gleiche erfolgt dann im Anschluss auf identisch Weise mit dem entsprechenden „0“-Signal.


Predefined PDO Assignment

Inbetriebnahme [image] Prozessdaten [image] EL9227-xxxx [image] Predefined PDO Assignment
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Die folgenden Predefined PDOs stehen zur Auswahl:
Name | PDO-Zuordnung
Standard 2 Ch. | SM2, Outputs | 0x1600 (OCP Outputs Channel 1)
 |  | 0x1601 (OCP Outputs Channel 2)
 | SM3, Inputs | 0x1A00 (OCP Inputs Channel 1)
 |  | 0x1A02 (OCP Inputs Channel 2)
Compact 2 Ch. | SM2, Outputs | 0x1600 (OCP Outputs Channel 1)
 |  | 0x1601 (OCP Outputs Channel 2)
 | SM3, Inputs | 0x1A01 (OCP Inputs Channel 1 Compact)
 |  | 0x1A03 (OCP Inputs Channel 2 Compact)


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind:
–
Restore Objekt Index 0x1011
–
Konfigurationsdaten Index 0x80n0
▪
Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
▪
Profilspezifische Objekte (Index 0x6000-0xFFFF)
–
Konfigurationsdaten (herstellerspezifisch) Index 0x80nF
–
Eingangsdaten Index 0x60n0
–
Informations- und Diagnostikdaten Index 0x80nE, 0xF000, 0xF008, 0xF010
▪
Standardobjekte (Index 0x1000-0x1FFF)
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
EL9221-xxxx
•
EL9222-xxxx
•
EL9227-xxxx


EL9221-xxxx

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx
EL9221-xxxx
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando Objekt
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | Settings | Max. Subindex | UINT8 | RO | 0x19 (25dez)
8000:11 | Nominal current | Nennstrom (eingestellter Sicherungswert), IN | UINT8 | RW | (0x80nF:17)
8000:19 | Switch Programming Control | Programmiermöglichkeit LED-Taster: Beschreibt ob der Nennstrom bei programmierbaren Klemmen über den LED Taster programmiert werden darf. Disable: Gesperrt und nicht erlaubt. Es ist nur eine Abfrage des Nennstroms möglich! Enable: Programmierung möglich | UINT8 | RW | ---
Index 8010 DIG Safe State Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | DIG Safe State Active | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
8010:01 | Active | Freigabe des in Index 0x8011:01 festgelegten Zustand des Ausgangs bei Busstörung 0: Ausgang behält den aktuellen Zustand. 1: Ausgang wird in den in Index 0x8011 definierten Zustand geschaltet. | BOOLEAN | RW | 0x01 (1dez)
Index 8011 DIG Safe State Value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:0 | DIG Safe State Value | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
8011:01 | Value | Legt den Zustand des Ausgangs bei Busstörung fest: 0: Ausgang aus 1: Ausgang an | BOOLEAN | RW | 0x00 (0dez)


Kommando Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Kommando Objekt
Kommando Objekt
Index B000 Command
Index (hex)
Name
Bedeutung
Data type
Flags
Default
B000:0
Command
Max. Subindex
UINT8
RO
0x03 (3dez)
B000:01
Request
Über das Request-Objekt können Kommandos an die Klemme abgesetzt werden
OCTET-STRING[2]
RW
{0}
B000:02
Status
Status des aktuell ausgeführten Kommandos
▪
0: Kommando fehlerfrei ausgeführt
▪
255: Kommando wird ausgeführt
UINT8
RO
0x00 (0dez)
B000:03
Response
Optionaler Rückgabewert des Kommandos
OCTET-STRING[6]
RO
{0}


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 800F Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | Vendor data | Max. Subindex | UINT8 | RO | 0x19 (25dez)
800F:11 | Voltage In Calibration Offset | Eingangsspannung Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:12 | Voltage In Calibration Gain | Eingangsspannung Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
800F:15 | Current Calibration Offset | Strom Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
800F:16 | Current Calibration Gain | Strom Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
800F:17 | Default Nominal Current | Nennstrom bei Auslieferung oder nach zurücksetzen auf Werkseinstellungen | UINT16 | RW | ---
800F:18 | Max Nominal Current | Maximaler Nennstrom | UINT16 | RW | ---
800F:19 | Nominal Current Type | Nennstrom Einstellmöglichkeit: einstellbar oder fix | UINT16 | RW | ---


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Eingangsdaten
Eingangsdaten
Index 6000 Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Inputs | Max. Subindex | UINT8 | RO | 0x13 (19dez)
6000:01 | Status__Enabled | Kanal eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Status__Tripped | Kanal ausgelöst | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Status__Hardware Protection | Hardwareschutz bzgl. Rückwärtseinspeisung und Verdrahtungsfehler, wird angezeigt so lange der Zustand ansteht | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Status__Current Level Warning | Stromwarnung: Vorwarnungsinfo wenn der aktuelle Strom die Vorwarnschwelle erreicht oder überschritten hat | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status__Cool Down Lock | Wiedereinschaltsperre (Abkühlzeit) | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status__Diag | Zeigt an, dass eine neue Meldung in der „Diag History" bereit steht | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Status__TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
6000:0F | Status__Input Cycle Counter | 2-Bit Zähler zur Synchronisierung (inkrementiert nur, wenn ein neuer Wert vorliegt) | BIT2 | RO | 0x00 (0dez)
6000:13 | Status__Error | Allgemeiner Hardware Fehler | BOOLEAN | RO | 0x00 (0dez)
6000:14 | Status__State Reset | Status Reset-Signal | BOOLEAN | RO | 0x00 (0dez)
6000:15 | Status__State Switch | Status Switch-Signal | BOOLEAN | RO | 0x00 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Ausgangsdaten
Ausgangsdaten
Index 7000 Inputs
Index (hex) | Name | Bedeutung | Datenyp | Flags | Default
7000:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
7000:01 | Control__Reset | Kanal zurücksetzen | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Control__Switch | Kanal schalten | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[20] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9221-xxxx [image] Standardobjekte
Standardobjekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x039A1389 (60429193 dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL9221
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x24053052 (604319826dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1A00 OCP TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | OCP TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0E (14eez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x01 (Enabled)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x02 (Tripped)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x05 (Hardware Protection)) | UINT32 | RO | 0x6000:05, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x08 (Current Level Warning)) | UINT32 | RO | 0x6000:08, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x09 (Cool Down Lock)) | UINT32 | RO | 0x6000:09, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x6000:0D, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6000:0E, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x13 (Error)) | UINT32 | RO | 0x6000:13, 1
1A00:0E | SubIndex 014 | 13. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x14 (State Reset)) | UINT32 | RO | 0x6000:14, 1
1A00:0F | SubIndex 015 | 13. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x15 (State Switch)) | UINT32 | RO | 0x6000:15, 1
1A00:10 | SubIndex 016 | 14. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 11
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x01 (1dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RO | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x01 (1dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0x8001 (32769dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00002710 (10000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1600 OCP RxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | OCP RxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (16dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs Ch.1), entry 0x01 (Control__Reset)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs Ch.1), entry 0x02 (Control__Switch)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1C32 SM output parameter (Teil 1)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0x0C07 (3079dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Min. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C32 SM output parameter (Teil 2)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:14
Frame repeat time
UINT32
RW
0x00000000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index F009 Password protection
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F009:0 | Password protection | Passwortschutz | UINT32 | RW | 0x00000000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x01 (1dez)
F010:01 | SubIndex 001 | OCP Profile 922 | UINT32 | RW | 0x0000039A (922dez)
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader-Version des EtherCAT-Slaves | STRING | RO | N/A


EL9222-xxxx

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx
EL9222-xxxx
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando Objekt
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 Settings (für n = 0, Ch.1; n=1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | Settings | Max. Subindex | UINT8 | RO | 0x19 (25dez)
80n0:11 | Nominal current | Nennstrom (eingestellter Sicherungswert), IN | UINT8 | RW | (0x80nF:17)
80n0:19 | Switch Programming Control | Programmiermöglichkeit LED-Taster: Beschreibt ob der Nennstrom bei programmierbaren Klemmen über den LED Taster programmiert werden darf. Disable: Gesperrt und nicht erlaubt. Es ist nur eine Abfrage des Nennstroms möglich! Enable: Programmierung möglich | UINT8 | RW | ---
Index 80n0 DIG Safe State Active Ch.n
(n=2 für Ch.1; n=3 für Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | DIG Safe State Active Ch.n | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
80n0:01 | Active | Freigabe des in Index 0x80n1:01 festgelegten Zustand des Ausgangs bei Busstörung 0: Ausgang behält den aktuellen Zustand. 1: Ausgang wird in den in Index 0x80n1 definierten Zustand geschaltet. | BOOLEAN | RW | 0x01 (1dez)
Index 80n1 DIG Safe State Value Ch.n
(n=2 für Ch.1; n=3 für Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | DIG Safe State Value Ch.n | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
80n1:01 | Value | Legt den Zustand des Ausgangs bei Busstörung fest: 0: Ausgang aus 1: Ausgang an | BOOLEAN | RW | 0x00 (0dez)


Kommando Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Kommando Objekt
Kommando Objekt
Index B000 Command
Index (hex)
Name
Bedeutung
Data type
Flags
Default
B000:0
Command
Max. Subindex
UINT8
RO
0x03 (3dez)
B000:01
Request
Über das Request-Objekt können Kommandos an die Klemme abgesetzt werden
OCTET-STRING[2]
RW
{0}
B000:02
Status
Status des aktuell ausgeführten Kommandos
▪
0: Kommando fehlerfrei ausgeführt
▪
255: Kommando wird ausgeführt
UINT8
RO
0x00 (0dez)
B000:03
Response
Optionaler Rückgabewert des Kommandos
OCTET-STRING[6]
RO
{0}


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 80nF Vendor data (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | Vendor data | Max. Subindex | UINT8 | RO | 0x19 (25dez)
80nF:11 | Voltage In Calibration Offset | Eingangsspannung Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
80nF:12 | Voltage In Calibration Gain | Eingangsspannung Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
80nF:15 | Current Calibration Offset | Strom Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
80nF:16 | Current Calibration Gain | Strom Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
80nF:17 | Default Nominal Current | Nennstrom bei Auslieferung oder nach zurücksetzen auf Werkseinstellungen | UINT16 | RW | ---
80nF:18 | Max Nominal Current | Maximaler Nennstrom | UINT16 | RW | ---
80nF:19 | Nominal Current Type | Nennstrom Einstellmöglichkeit: einstellbar oder fix | UINT16 | RW | ---


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Eingangsdaten
Eingangsdaten
Index 60n0 Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | Inputs | Max. Subindex | UINT8 | RO | 0x15 (21dez)
60n0:01 | Status__Enabled | Kanal eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Status__Tripped | Kanal ausgelöst | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Status__Hardware Protection | Hardwareschutz bzgl. Rückwärtseinspeisung und Verdrahtungsfehler, wird angezeigt so lange der Zustand ansteht | BOOLEAN | RO | 0x00 (0dez)
60n0:08 | Status__Current Level Warning | Stromwarnung: Vorwarnungsinfo wenn der aktuelle Strom die Vorwarnschwelle erreicht oder überschritten hat. | BOOLEAN | RO | 0x00 (0dez)
60n0:09 | Status__Cool Down Lock | Wiedereinschaltsperre (Abkühlzeit) | BOOLEAN | RO | 0x00 (0dez)
60n0:0D | Status__Diag | Zeigt an, dass eine neue Meldung in der „Diag History“ bereit steht | BOOLEAN | RO | 0x00 (0dez)
60n0:0E | Status__TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | Status__Input Cycle Counter | 2-Bit Zähler zur Synchronisierung (inkrementiert nur, wenn ein neuer Wert vorliegt) | BIT2 | RO | 0x00 (0dez)
60n0:13 | Status__Error | Allgemeiner Hardware Fehler | BOOLEAN | RO | 0x00 (0dez)
60n0:14 | Status__State Reset | Status Reset-Signal | BOOLEAN | RO | 0x00 (0dez)
60n0:15 | Status__State Switch | Status Switch-Signal | BOOLEAN | RO | 0x00 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Ausgangsdaten
Ausgangsdaten
Index 70n0 Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datenyp | Flags | Default
70n0:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
70n0:01 | Control__Reset | Kanal zurücksetzen | BOOLEAN | RO | 0x00 (0dez)
70n0:02 | Control__Switch | Kanal schalten | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[20] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9222-xxxx [image] Standardobjekte
Standardobjekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x039A1389 (60429193 dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL9222
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x24063052 (604385362dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1A0n OCP TxPDO-Map Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0n:0 | OCP TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x10 (16ez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x01 (Enabled)) | UINT32 | RO | 0x60n0:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x02 (Tripped)) | UINT32 | RO | 0x60n0:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x00n0:00, 2
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x05 (Hardware Protection)) | UINT32 | RO | 0x60n0:05, 1
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x00n0:00, 2
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x08 (Current Level Warning)) | UINT32 | RO | 0x60n0:08, 1
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x09 (Cool Down Lock)) | UINT32 | RO | 0x60n0:09, 1
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x00n0:00, 3
1A0n:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x60n0:0D, 1
1A0n:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x60n0:0E, 1
1A0n:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60n0:0F, 2
1A0n:0C | SubIndex 012 | 12. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A0n:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x13 (Error)) | UINT32 | RO | 0x60n0:13, 1
1A0n:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x14 (State Reset)) | UINT32 | RO | 0x60n0:14, 1
1A0n:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x15 (State Switch)) | UINT32 | RO | 0x60n0:15, 1
1A0n:10 | SubIndex 016 | 16. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RO | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RO | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A01 (6657dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0x8001 (32769dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00002710 (10000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 160n OCP RxPDO-Map Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160n:0 | OCP RxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (16dez)
160n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs Ch.1), entry 0x01 (Control__Reset)) | UINT32 | RO | 0x70n0:01, 1
160n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs Ch.1), entry 0x02 (Control__Switch)) | UINT32 | RO | 0x70n0:02, 1
160n:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x00n0:00, 14
Index 1C32 SM output parameter (Teil 1)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0x0C07 (3079dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Min. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C32 SM output parameter (Teil 2)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:14
Frame repeat time
UINT32
RW
0x00000000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F009:0 | Password protection | Passwortschutz | UINT32 | RW | 0x00000000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | OCP Profile 922 | UINT32 | RW | 0x0000039A (922ez)
F010:01 | SubIndex 001 | OCP Profile 922 | UINT32 | RW | 0x0000039A (922dez)
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader-Version des EtherCAT-Slaves | STRING | RO | N/A
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)


EL9227-xxxx

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx
EL9227-xxxx
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando Objekt
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 Settings (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | Settings | Max. Subindex | UINT8 | RO | 0x1A (26dez)
80n0:11 | Nominal current | Nennstrom (eingestellter Sicherungswert), IN | UINT8 | RW | (0x80nF:17)
80n0:12 | Characteristic | Kennlinie: Gibt an nach welcher Zeit bei welcher Stromhöhe abgeschaltet wird. | UINT8 | RW | 0x01 (1dez)
80n0:13 | Current-Level Warning | Vorwarnung: Gibt an ab welchem Stromwert eine Vorwarnung ausgegeben wird. | UINT16 | RW | 0x005A (90dez)
80n0:14 | Fuse Init State | Initialisierungszustand: Beschreibt den Zustand der Ausgänge, welchen diese einnehmen sollen, wenn die Spannung nach einer Spannungsunterbrechung wieder angelegt wurde. Aus, An oder den letzten Zustand wieder einnehmen als die Spannung noch anlag. | UINT8 | RW | 0x02 (2dez)
80n0:15 | Input Functions (DI & Switch) | Eingangsfunktionen (Digitaler Eingang & LED-Taster): Beschreibt die Funktion des dig. Eingangs und des LED Tasters welche bei Bedarf ausgeführt werden soll. Es beschreibt quasi das Verhalten. Nur Reset, nur Ein- und Ausschalten, Reset und Ein- und Ausschalten oder deaktiviert. | UINT8 | RW | 0x02 (2dez)
80n0:16 | Overvoltage Behaviour | Überspannungsverhalten: Beschreibt das Verhalten der Ausgänge wie diese reagieren sollen, wenn eine Überspannung (>32 V DC, Hysterese 2 V) am Eingang ansteht. Tripping und nicht wieder automatisch einschalten, wenn die Überspannung vorbei ist oder Tripping mit Auto-Reset und dem automatischen Wiedereinschalten, wenn die Überspannung vorbei ist. | UINT8 | RW | 0x01 (1dez)
80n0:17 | Undervoltage Level | Unterspannungsschwelle: Ist der Wert ab wann eine Unterspannung (von 17 bis 24 V DC einstellbar, Hysterese 1 V) angezeigt wird. | UINT8 | RW | 0xAA (170dez)
80n0:18 | Reverse Current Filter | Rückwärtseinspeise-Filter: Beschreibt wann abgeschaltet wird, wenn am Ausgang eine um 1 V höhere Spannung als am Eingang anliegt. Fast: Abschaltung bei Rückwärtsspeisung >10ms Standard: Abschaltung bei Rückwärtsspeisung >100ms Slow: Abschaltung bei Rückwärtsspeisung >1.000ms | UINT8 | RW | 0x01 (1dez)
80n0:19 | Switch Programming Control | Programmiermöglichkeit LED-Taster: Beschreibt ob der Nennstrom bei programmierbaren Klemmen über den LED Taster programmiert werden darf. Disable: Gesperrt und nicht erlaubt. Es ist nur eine Abfrage des Nennstroms möglich! Enable: Programmierung möglich | UINT8 | RW | ---
80n0:1A | Switch On Channel Delay | Kanal-Einschaltverzögerung: Beschreibt das Verhalten der Einschaltverzögerung von Kanal 2 zu 1. Aus: Keine Verzögerung von Kanal 2 zu 1. Ein: Kanal 1 und 2 schalten voneinander verzögert ein (Kanal 2 typ. 50 ms später als Kanal 1). | UINT16 | RW | 0x0000 (1dez)
Index 80n1 Manual Characteristic Settings (für n = 0, Ch.1; n=1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | Manual Characteristic Settings | Max. Subindex | UINT8 | RO | 0x1A (26dez)
80n1:01 | Time Value (1,1 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,1-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:02 | Time Value (1,2 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,2-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:03 | Time Value (1,3 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,3-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:04 | Time Value (1,4 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,4-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:05 | Time Value (1,5 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,5-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:06 | Time Value (1,6 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,6-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:07 | Time Value (1,7 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,7-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:08 | Time Value (1,8 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,8-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:09 | Time Value (1,9 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,9-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:0A | Time Value (2,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 2-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:0B | Time Value (2,2 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,2-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:0C | Time Value (2,4 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,4-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:0D | Time Value (2,6 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,6-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:0E | Time Value (2,8 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,8-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:0F | Time Value (3,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 3-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:10 | Time Value (3,25 * In) | Beschreibt die Auslösezeit in ms, wann beim 3,25-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:11 | Time Value (3,5 * In) | Beschreibt die Auslösezeit in ms, wann beim 3,5-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:12 | Time Value (3,75 * In) | Beschreibt die Auslösezeit in ms, wann beim 3,75-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:13 | Time Value (4,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 4-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:14 | Time Value (4,33 * In) | Beschreibt die Auslösezeit in ms, wann beim 4,33-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:15 | Time Value (4,66 * In) | Beschreibt die Auslösezeit in ms, wann beim 4,66-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:16 | Time Value (5,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 5-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:17 | Time Value (5,5 * In) | Beschreibt die Auslösezeit in ms, wann beim 5,5-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:18 | Time Value (6,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 6-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:19 | Time Value (7,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 7-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
80n1:1A | Time Value (9,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 9-fachen IN ausgelöst wird. | UINT16 | RW | 0x0000 (0dez)
Index 80n0 DIG Safe State Active Ch.n
(n=2 für Ch.1; n=3 für Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | DIG Safe State Active Ch.n | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
80n0:01 | Active | Freigabe des in Index 0x80n1:01 festgelegten Zustand des Ausgangs bei Busstörung 0: Ausgang behält den aktuellen Zustand. 1: Ausgang wird in den in Index 0x80n1 definierten Zustand geschaltet. | BOOLEAN | RW | 0x01 (1dez)
Index 80n1 DIG Safe State Value Ch.n
(n=2 für Ch.1; n=3 für Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | DIG Safe State Value Ch.n | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
80n1:01 | Value | Legt den Zustand des Ausgangs bei Busstörung fest: 0: Ausgang aus 1: Ausgang an | BOOLEAN | RW | 0x00 (0dez)


Kommando Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Kommando Objekt
Kommando Objekt
Index B000 Command
Index (hex)
Name
Bedeutung
Data type
Flags
Default
B000:0
Command
Max. Subindex
UINT8
RO
0x03 (3dez)
B000:01
Request
Über das Request-Objekt können Kommandos an die Klemme abgesetzt werden
OCTET-STRING[2]
RW
{0}
B000:02
Status
Status des aktuell ausgeführten Kommandos
▪
0: Kommando fehlerfrei ausgeführt
▪
255: Kommando wird ausgeführt
UINT8
RO
0x00 (0dez)
B000:03
Response
Optionaler Rückgabewert des Kommandos
OCTET-STRING[6]
RO
{0}


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 80nF Vendor data (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | Vendor data | Max. Subindex | UINT8 | RO | 0x19 (25dez)
80nF:11 | Voltage In Calibration Offset | Eingangsspannung Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
80nF:12 | Voltage In Calibration Gain | Eingangsspannung Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
80nF:13 | Voltage Out Calibration Offset | Ausgangsspannung Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
80nF:14 | Voltage Out Calibration Gain | Ausgangsspannung Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
80nF:15 | Current Calibration Offset | Strom Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
80nF:16 | Current Calibration Gain | Strom Gain (Herstellerabgleich) | UINT16 | RW | 0x4000 (16384dez)
80nF:17 | Default Nominal Current | Nennstrom bei Auslieferung oder nach zurücksetzen auf Werkseinstellungen | UINT16 | RW | ---
80nF:18 | Max Nominal Current | Maximaler Nennstrom | UINT16 | RW | ---
80nF:19 | Nominal Current Type | Nennstrom Einstellmöglichkeit: einstellbar oder fix | UINT16 | RW | ---


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Eingangsdaten
Eingangsdaten
Index 60n0 Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | Inputs | Max. Subindex | UINT8 | RO | 0x24 (36dez)
60n0:01 | Status__Enabled | Kanal eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Status__Tripped | Kanal ausgelöst | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Status__Short Circuit | Kurzschluss (Fehlerstrom ≥ 1,5 x IN) | BOOLEAN | RO | 0x00 (0dez)
60n0:04 | Status__Overload | Überlast (Fehlerstrom ≥ 1,1 x IN) | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Status__Hardware Protection | Hardwareschutz bzgl. Übertemperatur, Rückwärtseinspeisung, Verdrahtungsfehler und redundanter Strommessung, wird angezeigt so lange der Zustand ansteht | BOOLEAN | RO | 0x00 (0dez)
60n0:06 | Status__Overvoltage | Überspannung (Eingangsspannung ≥ 32 V DC) | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Status__Undervoltage | Unterspannungswert erreicht oder unterschritten | BOOLEAN | RO | 0x00 (0dez)
60n0:08 | Status__Current Level Warning | Stromwarnung: Vorwarnungsinfo, wenn der aktuelle Strom die Vorwarnschwelle erreicht oder überschritten hat. | BOOLEAN | RO | 0x00 (0dez)
60n0:09 | Status__Cool Down Lock | Wiedereinschaltsperre (Abkühlzeit) | BOOLEAN | RO | 0x00 (0dez)
60n0:0A | Status__Disabled By Switch | Kanal ausgeschaltet durch Taster | BOOLEAN | RO | 0x00 (0dez)
60n0:0B | Status__Disabled By DI | Kanal ausgeschaltet durch digitalen Eingang | BOOLEAN | RO | 0x00 (0dez)
60n0:0C | Status__Disabled By Output | Kanal ausgeschaltet durch Prozessdaten-Ausgang | BOOLEAN | RO | 0x00 (0dez)
60n0:0D | Status__Diag | Zeigt an, dass eine neue Meldung in der „Diag History“ bereit steht | BOOLEAN | RO | 0x00 (0dez)
60n0:0E | Status__TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | Status__Input Cycle Counter | 2-Bit Zähler zur Synchronisierung (inkrementiert nur, wenn ein neuer Wert vorliegt) | BIT2 | RO | 0x00 (0dez)
60n0:13 | Status__Error | Allgemeiner Hardware Fehler | BOOLEAN | RO | 0x00 (0dez)
60n0:14 | Status__State Reset | Status Reset-Signal; Rückmeldung zu 70n0:01 | BOOLEAN | RO | 0x00 (0dez)
60n0:15 | Status__State Switch | Status Switch-Signal: Rückmeldung zu 70n0:02 | BOOLEAN | RO | 0x00 (0dez)
60n0:21 | Load | Auslastung in % bezogen auf IN | UINT16 | RO | 0x0000 (0dez)
60n0:22 | Current | Ausgangsstrom in 0,01 A | UINT16 | RO | 0x0000 (0dez)
60n0:23 | Voltage In | Eingangsspannung in 0,1 V | UINT16 | RO | 0x0000 (0dez)
60n0:24 | Voltage Out | Ausgangsspannung in 0,1 V | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Ausgangsdaten
Ausgangsdaten
0x00 (0dez)Index 70n0 Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datenyp | Flags | Default
70n0:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
70n0:01 | Control__Reset | Kanal zurücksetzen | BOOLEAN | RO | 0x00 (0dez)
70n0:02 | Control__Switch | Kanal schalten | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[20] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 90n0 Info Data (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n0:0 | Info Data | Max. Subindex | UINT8 | RO | 0x17 (23dez)
90n0:11 | Tripped Counter Short Circuit | Auslösezähler Kurzschluss (≥1,5 x IN) | UINT32 | RO | 0x00000000 (0dez)
90n0:12 | Tripped Counter Overload | Auslösezähler Überlast (≥1,1 x IN) | UINT32 | RO | 0x00000000 (0dez)
90n0:13 | Tripped Counter Hardware Protection | Auslösezähler Hardwareschutz | UINT32 | RO | 0x00000000 (0dez)
90n0:14 | Tripped Counter Overvoltage | Auslösezähler Überspannung (≥ 32 V DC) | UINT32 | RO | 0x00000000 (0dez)
90n0:15 | Tripped Counter Undervoltage | Auslösezähler Unterspannung | UINT32 | RO | 0x00000000 (0dez)
90n0:16 | Remaining Cool Down Time | Verbleibende Wiedereinschaltzeit (Abkühlzeit) | UINT16 | RO | 0x0000 (0dez)
90n0:17 | Max Current Drag Indicator | Strom-Schleppzeiger: maximal geflossener Strom in 0,01 A | UINT16 | RO | 0x0000 (0dez)
Index 90n1 Active Characteristic (für n = 0, Ch.1; n=1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n1:0 | Active Characteristic | Max. Subindex | UINT8 | RO | 0x1A (26dez)
90n1:01 | Time Value (1,1 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,1-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:02 | Time Value (1,2 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,2-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:03 | Time Value (1,3 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,3-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:04 | Time Value (1,4 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,4-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:05 | Time Value (1,5 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,5-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:06 | Time Value (1,6 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,6-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:07 | Time Value (1,7 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,7-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:08 | Time Value (1,8 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,8-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:09 | Time Value (1,9 * In) | Beschreibt die Auslösezeit in ms, wann beim 1,9-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:0A | Time Value (2,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 2-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:0B | Time Value (2,2 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,2-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:0C | Time Value (2,4 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,4-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:0D | Time Value (2,6 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,6-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:0E | Time Value (2,8 * In) | Beschreibt die Auslösezeit in ms, wann beim 2,8-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:0F | Time Value (3,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 3-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:10 | Time Value (3,25 * In) | Beschreibt die Auslösezeit in ms, wann beim 3,25-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:11 | Time Value (3,5 * In) | Beschreibt die Auslösezeit in ms, wann beim 3,5-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:12 | Time Value (3,75 * In) | Beschreibt die Auslösezeit in ms, wann beim 3,75-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:13 | Time Value (4,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 4-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:14 | Time Value (4,33 * In) | Beschreibt die Auslösezeit in ms, wann beim 4,33-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:15 | Time Value (4,66 * In) | Beschreibt die Auslösezeit in ms, wann beim 4,66-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:16 | Time Value (5,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 5-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:17 | Time Value (5,5 * In) | Beschreibt die Auslösezeit in ms, wann beim 5,5-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:18 | Time Value (6,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 6-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:19 | Time Value (7,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 7-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
90n1:1A | Time Value (9,0 * In) | Beschreibt die Auslösezeit in ms, wann beim 9-fachen IN ausgelöst wird. | UINT16 | RO | 0x0000 (0dez)
Index 90n2 Last Tripped Event (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n2:0 | Last Tripped Event | Max. Subindex | UINT8 | RO | 0x1D (29dez)
90n2:11 | Operating Mode | Betriebsmodus (EtherCAT / Stand-Alone) | UINT8 | RO | 0x00 (0dez)
90n2:12 | Password Protection | Passwortschutz | UINT8 | RO | 0x00 (0dez)
90n2:13 | Timestamp Type | Art des Zeitstempels (relativ oder absolut) | UINT8 | RO | 0x00 (0dez)
90n2:14 | Nominal Current | Nennstrom in A | UINT8 | RO | 0x00 (0dez)
90n2:15 | Characteristic | Charakteristik, Abschaltverhalten | UINT8 | RO | 0x00 (0dez)
90n2:16 | Tripped Reason | Auslösegrund | UINT8 | RO | 0x00 (0dez)
90n2:17 | Tripped Time | Auslösezeit nach Kennlinie Info Hardwareabschaltung | UINT16 | RO | 0x0000 (0dez)
90n2:18 | Current | Auslösestrom zum Auslösezeitpunkt | UINT16 | RO | 0x0000 (0dez)
90n2:19 | Load | Auslastung in % bei Auslösung | UINT16 | RO | 0x0000 (0dez)
90n2:1A | Max Current Drag Indicator | Strom-Schleppzeiger: Höchster kurzzeitig geflossener Strom vor der Auslösung | UINT16 | RO | 0x0000 (0dez)
90n2:1B | Voltage In | Eingangsspannung zum Auslösezeitpunkt | UINT16 | RO | 0x0000 (0dez)
90n2:1C | Voltage Out | Ausgangsspannung zum Auslösezeitpunkt | UINT16 | RO | 0x0000 (0dez)
90n2:1D | Timestamp | Zeitstempel zum Auslösezeitpunkt | UINT64 | RO | ---
Index 90n3 Last Modification Event (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n3:0 | Last Modification Event | Max. Subindex | UINT8 | RO | 0x1E (30dez)
90n3:11 | Operating Mode | Betriebsmodus EtherCAT / Stand-Alone | UINT8 | RO | 0x00 (0dez)
90n3:12 | Password Protection | Passwortschutz | UINT8 | RO | 0x00 (0dez)
90n3:13 | Timestamp Type | Art des Zeitstempels (relativ oder absolut) | UINT8 | RO | 0x00 (0dez)
90n3:14 | Modification Type | Art der Modifikation, Änderungen per Taster, EtherCAT oder laden von Werkseinstellungen | UINT8 | RO | 0x00 (0dez)
90n3:15 | Nominal Current New | Nennstrom Neu | UINT8 | RO | 0x00 (0dez)
90n3:16 | Nominal Current Old | Nennstrom Alt | UINT8 | RO | 0x00 (0dez)
90n3:17 | Characteristic New | Kennlinie Neu | UINT8 | RO | 0x00 (0dez)
90n3:18 | Characteristic Old | Kennlinie Alt | UINT8 | RO | 0x00 (0dez)
90n3:19 | Current-Level Warning New | Strom-Warnung Neu | UINT16 | RO | 0x0000 (0dez)
90n3:1A | Current-Level Warning Old | Strom-Warnung Alt | UINT16 | RO | 0x0000 (0dez)
90n3:1B | Manual Char. Changed Index | Beschreibt den manuellen Kennlinien-Index welcher als letztes geändert wurde | UINT16 | RO | 0x0000 (0dez)
90n3:1C | Manual Char. Time Value New | Beschreibt den neuen manuellen Kennlinienwert welcher als letztes geändert wurde | UINT16 | RO | 0x0000 (0dez)
90n3:1D | Manual Char. Time Value Old | Beschreibt den alten manuellen Kennlinienwert welcher als letztes aktiv war | UINT16 | RO | 0x0000 (0dez)
90n3:1E | Timestamp | Zeitstempel zum Änderungszeitpunkt | UINT64 | RO | ---


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL9227-xxxx [image] Standardobjekte
Standardobjekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x039A1389 (60429193 dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL9227
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x240B3052 (604713042dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1A00 OCP TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | OCP TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x10 (16ez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x01 (Enabled)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x02 (Tripped)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x03 (Short Circuit)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x04 (Overload)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x05 (Hardware Protection)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x06 (Overvoltage)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x07 (Undervoltage)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x08 (Current Level Warning)) | UINT32 | RO | 0x6000:08, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x09 (Cool Down Lock)) | UINT32 | RO | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0A (Disabled By Switch)) | UINT32 | RO | 0x6000:0A, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0B (Disabled By DI)) | UINT32 | RO | 0x6000:0B, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0C (Disabled By Output)) | UINT32 | RO | 0x6000:0C, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x6000:0D, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6000:0E 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x11 (State Device Switch)) | UINT32 | RO | 0x6000:11, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x12 (State Digital Input)) | UINT32 | RO | 0x6000:12, 1
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x13 (Error)) | UINT32 | RO | 0x6000:13, 1
1A00:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x14 (State Reset)) | UINT32 | RO | 0x6000:14, 1
1A00:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x15 (State Switch)) | UINT32 | RO | 0x6000:15, 1
1A00:15 | SubIndex 021 | 21. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A00:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x21 (Load)) | UINT32 | RO | 0x6000:21, 16
1A00:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x22 (Current)) | UINT32 | RO | 0x6000:22, 16
1A00:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x23 (Voltage In)) | UINT32 | RO | 0x6000:23, 16
1A00:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x24 (Voltage Out)) | UINT32 | RO | 0x6000:24, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RO | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RO | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A02 (6658dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0x8001 (32769dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00002710 (10000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 160n OCP RxPDO-Map Inputs (für n = 0, Ch.1; n = 1, Ch. 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160n:0 | OCP RxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (16dez)
160n:01 | SubIndex 001 | 1. PDO Mapping entry object | UINT32 | RO | 0x70n0:01, 1
160n:02 | SubIndex 002 | 2. PDO Mapping entry object | UINT32 | RO | 0x70n0:02, 1
160n:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x00n0:00, 14
Index 1C32 SM output parameter (Teil 1)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0x0C07 (3079dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Min. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C32 SM output parameter (Teil 2)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:14
Frame repeat time
UINT32
RW
0x00000000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F009:0 | Password protection | Passwortschutz | UINT32 | RW | 0x00000000 (0dez)
Index 1800 OCP TxPDO-Par Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | OCP TxPDO-Par Inputs Ch. 1 | PDO Parameter TxPDO | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit angegebenen TxPDO übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 OCP TxPDO-Par Inputs Ch.1 Compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | OCP TxPDO-Par Inputs Ch. 1 | PDO Parameter TxPDO | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit angegebenen TxPDO übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1802 OCP TxPDO-Par Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | OCP TxPDO-Par Inputs Ch. 2 | PDO Parameter TxPDO | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit angegebenen TxPDO übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 OCP TxPDO-Par Inputs Ch.2 Compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | OCP TxPDO-Par Inputs Ch. 2 | PDO Parameter TxPDO | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit angegebenen TxPDO übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | OCP Profile 922 | UINT32 | RW | 0x0000039A (922ez)
F010:01 | SubIndex 001 | OCP Profile 922 | UINT32 | RW | 0x0000039A (922dez)
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader-Version des EtherCAT-Slaves | STRING | RO | N/A
Index 1A01 OCP TxPDO-Map Inputs Ch.1 Compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | OCP TxPDO-Map Inputs Ch.1 Compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x10 (16ez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x01 (Enabled)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x02 (Tripped)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x03 (Short Circuit)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x04 (Overload)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x05 (Hardware Protection)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x06 (Overvoltage)) | UINT32 | RO | 0x6000:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x07 (Undervoltage)) | UINT32 | RO | 0x6000:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x08 (Current Level Warning)) | UINT32 | RO | 0x6000:08, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x09 (Cool Down Lock)) | UINT32 | RO | 0x6000:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0A (Disabled By Switch)) | UINT32 | RO | 0x6000:0A, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0B (Disabled By DI)) | UINT32 | RO | 0x6000:0B, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0C (Disabled By Output)) | UINT32 | RO | 0x6000:0C, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0D (Diag)) | UINT32 | RO | 0x6000:0D, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6000:0E 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x11 (State Device Switch)) | UINT32 | RO | 0x6000:11, 1
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x12 (State Digital Input)) | UINT32 | RO | 0x6000:12, 1
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x13 (Error)) | UINT32 | RO | 0x6000:13, 1
1A01:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x14 (State Reset)) | UINT32 | RO | 0x6000:14, 1
1A01:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 (Inputs Ch.1), entry 0x15 (State Switch)) | UINT32 | RO | 0x6000:15, 1
1A01:15 | SubIndex 021 | 21. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
Index 1A02 OCP TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | OCP TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x10 (16ez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x01 (Enabled)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x02 (Tripped)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x03 (Short Circuit)) | UINT32 | RO | 0x6010:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x04 (Overload)) | UINT32 | RO | 0x6010:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x05 (Hardware Protection)) | UINT32 | RO | 0x6010:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x06 (Overvoltage)) | UINT32 | RO | 0x6010:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x07 (Undervoltage)) | UINT32 | RO | 0x6010:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x08 (Current Level Warning)) | UINT32 | RO | 0x6010:08, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x09 (Cool Down Lock)) | UINT32 | RO | 0x6010:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0A (Disabled By Switch)) | UINT32 | RO | 0x6010:0A, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0B (Disabled By DI)) | UINT32 | RO | 0x6010:0B, 1
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0C (Disabled By Output)) | UINT32 | RO | 0x6010:0C, 1
1A02:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0D (Diag)) | UINT32 | RO | 0x6010:0D, 1
1A02:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6010:0E 1
1A02:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6010:0F, 2
1A02:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x11 (State Device Switch)) | UINT32 | RO | 0x6010:11, 1
1A02:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x12 (State Digital Input)) | UINT32 | RO | 0x6010:12, 1
1A02:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x13 (Error)) | UINT32 | RO | 0x6010:13, 1
1A02:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x14 (State Reset)) | UINT32 | RO | 0x6010:14, 1
1A02:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x15 (State Switch)) | UINT32 | RO | 0x6010:15, 1
1A02:15 | SubIndex 021 | 21. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A02:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x21 (Load)) | UINT32 | RO | 0x6010:21, 16
1A02:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x22 (Current)) | UINT32 | RO | 0x6010:22, 16
1A02:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x23 (Voltage In)) | UINT32 | RO | 0x6010:23, 16
1A02:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x24 (Voltage Out)) | UINT32 | RO | 0x6010:24, 16
Index 1A03 OCP TxPDO-Map Inputs Ch.2 Compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | OCP TxPDO-Map Inputs Ch.2 Compact | PDO Mapping TxPDO 4 | UINT8 | RO | 0x10 (16ez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x01 (Enabled)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x02 (Tripped)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x03 (Short Circuit)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x04 (Overload)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x05 (Hardware Protection)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x06 (Overvoltage)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x07 (Undervoltage)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x08 (Current Level Warning)) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x09 (Cool Down Lock)) | UINT32 | RO | 0x6010:09, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0A (Disabled By Switch)) | UINT32 | RO | 0x6010:0A, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0B (Disabled By DI)) | UINT32 | RO | 0x6010:0B, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0C (Disabled By Output)) | UINT32 | RO | 0x6010:0C, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0D (Diag)) | UINT32 | RO | 0x6010:0D, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0E (TxPDO State)) | UINT32 | RO | 0x6010:0E 1
1A03:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6010:0F, 2
1A03:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x11 (State Device Switch)) | UINT32 | RO | 0x6010:11, 1
1A03:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x12 (State Digital Input)) | UINT32 | RO | 0x6010:12, 1
1A03:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x13 (Error)) | UINT32 | RO | 0x6010:13, 1
1A03:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x14 (State Reset)) | UINT32 | RO | 0x6010:14, 1
1A03:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6010 (Inputs Ch.2), entry 0x15 (State Switch)) | UINT32 | RO | 0x6010:15, 1
1A03:15 | SubIndex 021 | 21. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)


Diagnose

Diagnose
Diagnose
Weiterführende Informationen
•
Diagnose - Grundlagen zu Diag Messages
•
Text-IDs EL922x


Diagnose - Grundlagen zu Diag Messages

Diagnose [image] Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons ist selbsterklärend.
DiagMessages im ADS Logger/Eventlogger
Ab TwinCAT 3.1 build 4022 werden von einer Klemme abgesetzte DiagMessages auch im TwinCAT ADS Logger gezeigt. Da nun IO-übergreifend DiagMessages an einem Ort dargestellt werden, vereinfacht dies die Inbetriebnahme. Außerdem kann die Logger-Ausgabe in eine Datei gespeichert werden – somit stehen die DiagMessages auch langfristig für Analysen zur Verfügung.
Nachrichten in die PLC einlesen
- In Vorbereitung -
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13


Text-IDs EL922x

Diagnose [image] Text-IDs EL922x
Text-IDs EL922x
TextId Hex | Type (en) | Place (En) | MessageText (De) | Zusätzlicher Kommentar
0x1600 | Information | I/O General | Abkühlphase noch aktiv, Kanal %d |
0x4611 | Warning | I/O General | Überschreitung des maximalen Summenstroms (max. %d A) |
0x4612 | Warning | I/O General | Unterspannung erkannt, Kanal %d |
0x4613 | Warning | I/O General | Parameter-Wert wird nicht von dieser Klemmenvariante unterstützt, Kanal %d |
0x4614 | Warning | I/O General | Parameter-Wert nicht erlaubt und wurde verkleinert, Kanal %d |
0x470E | Warning |  | Übertemperatur im Gerät |
0x817F | Error | General | interner Hardwarefehler (Fehlercode) | Fehlercode:
 |  |  |  | 11 = fehlende Eingangsspannung Kanal 1
 |  |  |  | 12 = fehlende Eingangsspannung Kanal 2
 |  |  |  | 21 = fehlerhafte redundante Strommessung Kanal 1
 |  |  |  | 22 = fehlerhafte redundante Strommessung Kanal 2
 |  |  |  | 31 = Übertemperatur Kanal 1
 |  |  |  | 32 = Übertemperatur Kanal 2
 |  |  |  | 41 = Messfehler Kanal 1
 |  |  |  | 42 = Messfehler Kanal 2
 |  |  |  | 51 = Verdrahtungsfehler, Kabelbruch Kanal 1 oder Eingang
 |  |  |  | 52 = Verdrahtungsfehler, Kabelbruch Kanal 2 oder Eingang
0x8620 | Error | I/O General | Unterspannung erkannt, Kanal %d ausgelöst |
0x8621 | Error | I/O General | Überspannung erkannt, Kanal %d ausgelöst |
0x8622 | Error | I/O General | Rückwärtseinspeisung erkannt, Kanal %d ausgelöst |
0x8623 | Error | I/O General | Kurzschluss erkannt, Kanal %d ausgelöst |
0x8624 | Error | I/O General | Überlast erkannt, Kanal %d ausgelöst |


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL9221-4030
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-4030-0016 | 20xx/xx
EL9221-5000
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-5000-0016 | 20xx/xx
EL9221-5090
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-5090-0016 | 20xx/xx
EL9221-6000
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-6000-0016 | 20xx/xx
EL9221-6040
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-6040-0016 | 20xx/xx
EL9221-9060
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-9060-0016 | 20xx/xx
EL9221-9080
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9221-9080-0016 | 20xx/xx
EL9222-4433
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9222-4433-0016 | 20xx/xx
EL9222-5500
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9222-5500-0016 | 20xx/xx
EL9222-6600
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9222-6600-0016 | 20xx/xx
EL9222-6644
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9222-6644-0016 | 20xx/xx
EL9222-9482
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9222-9482-0016 | 20xx/xx
EL9222-9664
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9222-9664-0016 | 20xx/xx
EL9227-4433
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9227-4433-0016 | 20xx/xx
EL9227-5500
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9227-5500-0016 | 20xx/xx
EL9227-6600
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9227-6600-0016 | 20xx/xx
EL9227-6644
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9227-6644-0016 | 20xx/xx
EL9227-9482
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9227-9482-0016 | 20xx/xx
EL9227-9664
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 – 01* | 01 | EL9227-9664-0016 | 20xx/xx
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
Update der Firmware
Vor dem Update der Firmware ist die Eingangsspannung abzuschalten.
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!
Alternative Vorgehensweise
Alternativ können die Werkseinstellungen über gleichzeitiges Betätigen der beiden Taster im Programmiermodus für > 5 Sek. wiederhergestellt werden. Diese alternative Vorgehensweise steht nur bei 2-kanaligen Geräten zur Verfügung.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.