EL73x2 - 2 kanalige DC-Motor Endstufen
Home


Produktübersicht 2 kanalige DC-Motor-Endstufen

Produktübersicht 2 kanalige DC-Motor-Endstufen
Produktübersicht 2 kanalige DC-Motor-Endstufen
EL7332
2 kanalige DC-Motor-Endstufe; 24 VDC; 1,0 A
EL7342
2 kanalige DC-Motor-Endstufe; 50 VDC; 3,5 A


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation EtherCAT Geräte


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.3
▪
Update Kapitel "Technische Daten "
▪
Strukturupdate
▪
Update Revisionsstand
3.2
▪
Update Kapitel "Technische Daten "
▪
Strukturupdate
▪
Update Revisionsstand
3.1
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Korrektur Technische Daten
▪
Update Kapitel "TwinCAT 2.1x" -> Kapitel "TwinCAT Entwicklungsumgebung" und Kapitel "TwinCAT Quick Start"
▪
Kapitel "Download-Revision" eingefügt
▪
Strukturupdate
▪
Update Revisionsstand
3.0
▪
Erste Veröffentlichung im PDF – Format
▪
Strukturupdate
2.9
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
▪
Strukturupdate
▪
Update Revisionsstand
2.8
▪
Kapitel "Objektbeschreibung" aktualisiert
2.7
▪
Kapitel "Objektbeschreibung" aktualisiert
▪
Kapitel "Technische Daten" aktualisiert
▪
Kapitel "Firmware Status" aktualisiert
2.6
▪
Kapitel "Objektbeschreibung" aktualisiert
▪
Kapitel "Technische Daten" aktualisiert
▪
Kapitel "Positioning Interface" aktualisiert
▪
Kapitel "Chopper-Betrieb" aktualisiert
▪
Kapitel "Prozessdaten" aktualisiert
▪
Strukturupdate
2.5
▪
Kapitel "Objektbeschreibung" aktualisiert
▪
Strukturupdate
2.4
▪
Kapitel "Chopper-Betrieb" aktualisiert
2.3
▪
Technische Daten aktualisiert
2.2
▪
Technische Daten aktualisiert
2.1
▪
Update Kapitel "Positioning Interface"
2.0
▪
Ergänzung Kapitel "TwinCAT 2.1x"
▪
Update Struktur
1.1
▪
Ergänzungen Technische Daten
1.0
▪
1. Veröffentlichung, Ergänzungen Technische Daten
0.3
▪
Ergänzungen Technische Daten
0.2
▪
Ergänzungen
0.1
▪
Vorläufige Dokumentation für EL7342


Versionsidentifikation EtherCAT Geräte

Vorwort [image] Versionsidentifikation EtherCAT Geräte
Versionsidentifikation EtherCAT Geräte
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, .....)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge..
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u

D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen:
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Chargennummer
CU2016 Switch mit Chargennummer
EL3202-0020 mit Chargennummern 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP76 EtherCAT Safety Box mit Chargennummer 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit ID-Nummer (QR Code) 100001051 und eindeutiger Seriennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL7332 - Einführung
•
EL7342 - Einführung
•
EL73x2 - Technische Daten
•
Technologie
•
Start


EL7332 - Einführung

Produktübersicht [image] EL7332 - Einführung
EL7332 - Einführung
EL7332
2 kanalige DC-Motor-Endstufe 24 V, 1,0 A
Die EtherCAT-Klemme EL7332 ermöglicht den direkten Betrieb von zwei DC-Motoren und ist zum E-Bus galvanisch getrennt. Die Drehzahl wird durch einen 16-Bit-Wert vom Automatisierungsgerät vorgegeben. Die Ausgangsstufe ist überlast- und kurzschlusssicher. Die EtherCAT-Klemme enthält zwei Kanäle, deren Signalzustand durch Leuchtdioden angezeigt wird. Die LEDs ermöglichen eine schnelle Vor-Ort-Diagnose.
Quick-Links


EL7342 - Einführung

Produktübersicht [image] EL7342 - Einführung
EL7342 - Einführung
EL7342
2 kanalige DC-Motor-Endstufe 50 VDC, 3,5 A
Die EtherCAT-Klemme EL7342 ermöglicht den direkten Betrieb von zwei DC-Motoren und ist zum E-Bus galvanisch getrennt. Drehzahl und Position werden durch einen 16 Bit Wert vom Automatisierungsgerät vorgegeben. Durch den Anschluss eines Inkremental-Encoders ist die Realisierung einer einfachen Servoachse möglich. Die Ausgangsstufe ist überlast- und kurzschlusssicher. Die EtherCAT-Klemme enthält zwei Kanäle, deren Signalzustand durch Leuchtdioden angezeigt wird. Die LEDs ermöglichen eine schnelle Vor-Ort-Diagnose.
Quick-Links


EL73x2 - Technische Daten

Produktübersicht [image] EL73x2 - Technische Daten
EL73x2 - Technische Daten
Technische Daten | EL7332 | EL7342
Anzahl Kanäle | 2 DC-Motoren, 2 digitale Eingänge | 2 DC-Motoren, 2 digitale Eingänge Encodereingang
Nennlastspannung | 24 VDC (-15%/+20%) | 8…50 VDC
Lastart | Bürsten-DC-Motoren, induktiv
Ausgangsstrom ohne Lüftermodul ZB8610 | 2 x 1,0 A (überlast- und kurzschlussfest) | 2 x 3,5 A (überlast- und kurzschlussfest)
Ausgangsstrom mit Lüftermodul ZB8610 | 2 x 3,0 A (überlast- und kurzschlussfest) | 2 x 6,5 A (überlast- und kurzschlussfest)
PWM-Taktfrequenz | 30 kHz, je 180° phasenverschoben
Tastverhältnis | 0…100 % (spannungsgeregelt)
Distributed Clocks | ja
Auflösung Ansteuerung | max. 10-Bit-Strom, 16-Bit-Geschwindigkeit
Spannungsversorgung für Elektronik | über den E-Bus und Powerkontakte
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Stromaufnahme aus dem E-Bus | typ. 140 mA
Stromaufnahme Powerkontakte | typ. 40 mA + Motorstrom | typ. 70 mA
Stromaufnahme Sensorspannung | - | typ. 20 mA
Encoder-/Eingangssignal | Signalspannung "0": -3 V... 1,5 V
 | Signalspannung "1": 2,5 V... 24 V
Nennspannung der Encodersignale | 5...24 V, 5 mA, single ended
Pulsfrequenz | - | 400.000 Inkremente/s, 4-fach-Auswertung
Gewicht | ca. 50 g | ca. 90 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C (angereiht in waagerechter Einbaulage, siehe Hinweis)
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 gemäß IEC/EN 61800-3
EMV Kategorie | Kategorie C3 - Standard Kategorie C2, C1 - Zusatzfilter erforderlich
Schutzart | IP20
Einbaulage | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2) siehe Hinweis
Zulassung | CE cULus


Technologie

Produktübersicht [image] Technologie
Technologie
Die 2-Kanal DC-Motor Klemmen EL7332 und EL7342 integrieren eine kompakte Motion-Control-Lösung bis 200 W in kleinster Bauform.
DC-Motor
DC-Motoren können in vielen Anwendungen den deutlich teureren Servomotor ersetzen, wenn sie mit einer intelligenten Ansteuerung betrieben werden. Im Vergleich zu anderen Motoren ist der DC-Motor gut regelbar, da die Drehzahl proportional zur Spannung ist.
Zwei DC-Motor Endstufen für optimalen Einsatz
Mit den EtherCAT-Klemmen EL7332 und EL7342 kann ein DC-Motor sehr einfach in das Steuerungssystem integriert werden. Alle Parameter sind über den Feldbus einstellbar. Die DC-Motor Endstufen für EtherCAT vereinen kleine, kompakte Bauform und ein weitreichendes Anwendungsgebiet. Mit den Endstufen können jeweils zwei DC-Motoren direkt betrieben werden. Die EL7342 besitzt zusätzlich ein integriertes Feedback-System für Inkrementalencoder.
Mit den EtherCAT-Klemmen EL7332 und EL7342 kann die Drehzahl einfach über die Prozessdaten eingestellt werden. Die integrierte Kompensation des Innenwiderstands hält den Motor bei Laständerung auf der gewünschten Drehzahl. Die Drehzahl wird durch ein 16-Bit Wert vom Automatisierungsgerät vorgegeben. Damit ist eine einfache Antriebsaufgabe, über eine simple Steuerung, lösbar.
Die EtherCAT-Klemme enthält zwei Kanäle, deren Signalzustand durch Leuchtdioden angezeigt wird. Dadurch wird eine schnelle Vor-Ort-Diagnose ermöglicht.
Anwendungsbereiche
Zwei Anwendungsbereiche werden von den Endstufen besonders gut unterstützt:
1. Eine einfache Steuerung, mit kostengünstiger Prozessorleistung und eine geringe Anforderung an die Zykluszeit.
Durch die Nutzung der integrierten Fahrwegsteuerung kann die Klemme, ohne NC-Einsatz, selbstständige Positionierfahrten ausführen. Es wird nichts weiter benötigt, als ein DC-Motor und die EtherCAT-Klemme.
2. Eine High-End-Positionierung mit der Integrierung in TwinCAT NC.
In Verbindung mit der EtherCAT-DC-Motor-Klemme wird ein DC-Motor unter TwinCAT analog einer Servoklemme gesteuert. Es sind keine weiteren Änderungen nötig.
Für anspruchsvolle Positionieraufgaben ist ein geschlossener Drehzahlregelkreis mit einem Feedbacksystem notwendig. Die EtherCAT-Klemme EL7342 ermöglicht den Anschluss eines Inkrementalencoders.
Der Regelkreis kann entweder durch die EtherCAT-Klemme selbst oder durch die übergeordnete Steuerung geschlossen werden.
Realisierungsmöglichkeiten für Regelkreise mit der EL7342
Der Spitzenstrom darf kurzzeitig deutlich über den Nennstrom steigen und erzeugt dadurch eine hohe Dynamik der gesamten Antriebslösung. In solch dynamischen Anwendungen entstehen, durch negative Beschleunigungen, Energierückspeisungen, die am Netzteil zu Spannungsspitzen führen. Die EtherCAT-Puffer-Kondensator Klemme EL9570 schützt vor den Folgen der Überspannung, indem sie einen Teil der Energie aufnimmt. Übersteigt die Spannung das Fassungsvermögen der Klemme, vernichtet sie die überschüssige Energie, über einen Widerstand, der extern angeschlossen werden kann.


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL73x2 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EL73x2 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT Grundlagen

Grundlagen der Kommunikation [image] EtherCAT Grundlagen
EtherCAT Grundlagen
Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Hinweis
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Achtung
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Hinweis
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Hinweis
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den Systemmanager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten. Andere Hersteller können dies anders handhaben.
Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.
Hinweis
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Hinweis
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschlusstechnik
•
Montage von passiven Klemmen
•
Einbaulagen bei Betrieb mit und ohne Lüfter
•
EL7332 - LEDs und Anschlussbelegung
•
EL7342 - LEDs und Anschlussbelegung


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Hinweis
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Montage von passiven Klemmen

Montage und Verdrahtung [image] Montage von passiven Klemmen
Montage von passiven Klemmen
Hinweis
Hinweis zur Montage von Passiven Klemmen
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für Montage von passiven Klemmen (hell eingefärbt)
Korrekte Konfiguration
Inkorrekte Konfiguration


Einbaulagen bei Betrieb mit und ohne Lüfter

Montage und Verdrahtung [image] Einbaulagen bei Betrieb mit und ohne Lüfter
Einbaulagen bei Betrieb mit und ohne Lüfter
Achtung
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage bei Betrieb ohne Lüfter
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht.
Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!
Weitere Hinweise zum Betrieb ohne Lüfter sind ggf. den Technischen Daten der Klemme zu entnehmen.
Standard-Einbaulage bei Betrieb mit Lüfter
Für die Standard-Einbaulage beim Betrieb mit Lüfter wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Betrieb mit Lüfter“). Die Klemmen werden dabei unterstützend vom z. B. ZB8610 Lüftermodul von unten nach oben durchlüftet.
Empfohlene Abstände bei Betrieb mit Lüfter
Weitere Einbaulagen
Durch die verstärkende Wirkung auf die Kühlung der Klemmen durch den Lüfter sind ggf. weitere Einbaulagen zulässig (siehe Abb. „Weitere Einbaulagen, Beispiel 1 und 2“); entnehmen Sie entsprechende Hinweise bitte denn Technischen Daten der Klemme.

Weitere Einbaulagen, Beispiel 1
Weitere Einbaulagen, Beispiel 2


EL7332 - LEDs und Anschlussbelegung

Montage und Verdrahtung [image] EL7332 - LEDs und Anschlussbelegung
EL7332 - LEDs und Anschlussbelegung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
EL7332 LEDs und Anschlussbelegung
EL7332 - Anschlussbelegung
Klemmstelle | Bezeichnung | Beschreibung
1 | A1 | Motor A, Motorwicklung A1
2 | B1 | Motor B, Motorwicklung B1
3 | 24 V | Einspeisung für Motorversorgung (maximal +24VDC)
4 | Input 1 | Digitaler Eingang 1 (+24 VDC)
5 | A2 | Motor A, Motorwicklung A2
6 | B2 | Motor B, Motorwicklung B2
7 | Power Motor 0 V | Einspeisung für Motorversorgung (0 VDC)
8 | Input 2 | Digitaler Eingang 2 (+24 VDC)
EL7332 - LEDs
LED | Farbe | Bedeutung
Run | grün | Diese LED gibt den Betriebszustand der Klemme wieder.
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme.
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion der Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt.
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed-Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Enable A | grün | aus | Motoransteuerung von Motor A ist gesperrt oder EL7332 ist nicht betriebsbereit.
 |  | an | Motoransteuerung von Motor A ist freigeschaltet oder EL7332 ist betriebsbereit.
Enable B | grün | aus | Motoransteuerung von Motor B ist gesperrt oder EL7332 ist nicht betriebsbereit.
 |  | an | Motoransteuerung von Motor B ist freigeschaltet oder EL7332 ist betriebsbereit.
Warning A/B | gelb | aus | keine Mängel
 |  | an | Konfigurationsfehler, z. B.: Motorspannung nicht angelegt 80°C Temperatur überschritten …
Error A | rot | aus | keine Mängel
 |  | an | Konfigurationsfehler der Endstufe A, z. B.: 100°C Temperatur überschritten Kurzschluss Offene Last / Drahtbruch ...
Error B | rot | aus | keine Mängel
 |  | an | Konfigurationsfehler der Endstufe B, z. B.: 100°C Temperatur überschritten Kurzschluss Offene Last / Drahtbruch ...


EL7342 - LEDs und Anschlussbelegung

Montage und Verdrahtung [image] EL7342 - LEDs und Anschlussbelegung
EL7342 - LEDs und Anschlussbelegung
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
EL7342 LEDs und Anschlussbelegung
EL7342 - Anschlussbelegung (linker Gehäuseteil)
Klemmstelle | Bezeichnung | Beschreibung
1 | Enc. A, A | Encoder A-Eingang A
2 | Enc. B, A | Encoder B-Eingang B
3 | Power Encoder +24 V | + 24 V, Encoder-Versorgung (von positivem Powerkontakt)
4 | Input 1 | Digitaler Eingang 1 (+24 VDC) oder Digitaler Latch-Eingang für Motor A.
5 | Enc. A, B | Encoder A-Eingang B
6 | Enc. B, B | Encoder B-Eingang B
7 | Power Encoder 0 V | 0 V, Encoder-Versorgung (von negativem Powerkontakt)
8 | Input 2 | Digitaler Eingang 2 (+24 VDC) oder Digitaler Latch-Eingang für Motor B.
EL7342 - Anschlussbelegung (rechter Gehäuseteil)
Klemmstelle | Bezeichnung | Beschreibung
1' | A1 | Motor A, Motorwicklung A1
2' | B1 | Motor B, Motorwicklung B1
3' | Power Motor +50 V | Einspeisung für Motorversorgung (maximal +50 VDC)
4' | Power Motor +50 V | Einspeisung für Motorversorgung (maximal +50 VDC)
5' | A2 | Motor A, Motorwicklung A2
6' | B2 | Motor B, Motorwicklung B2
7' | Power Motor 0 V. | Einspeisung für Motorversorgung (0 V)
8' | Power Motor 0 V | Einspeisung für Motorversorgung (0 V)
EL7342 - LEDs (linkes Prisma)
LED | Farbe | Bedeutung
Run | grün | Diese LED gibt den Betriebszustand der Klemme wieder.
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme.
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion der Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt.
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed-Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Enc. A A | grün | an | Am Encoder A-Eingang A liegt ein Signal an.
Enc. A B | grün | an | Am Encoder A-Eingang B liegt ein Signal an.
Enc. B A | grün | an | Am Encoder B-Eingang A liegt ein Signal an.
Enc. B B | grün | an | Am Encoder B-Eingang B liegt ein Signal an.
Input 1 | grün | an | Am digitalen Eingang 1 liegt ein Signal an.
Input 2 | grün | an | Am digitalen Eingang 2 liegt ein Signal an.
EL7342 - LEDs (rechtes Prisma)
LED | Farbe | Bedeutung
Motor Power | grün | aus | Versorgungsspannung (50 VDC) nicht vorhanden oder Motoransteuerung ist gesperrt (Index ist nicht gesetzt).
 |  | an | Versorgungsspannung (50 VDC) vorhanden.
Enable A | grün | aus | Motoransteuerung von Motor A ist gesperrt oder EL7342 ist nicht betriebsbereit.
 |  | an | Motoransteuerung von Motor A ist freigeschaltet oder EL7342 ist betriebsbereit.
Enable B | grün | aus | Motoransteuerung von Motor B ist gesperrt oder EL7342 ist nicht betriebsbereit.
 |  | an | Motoransteuerung von Motor B ist freigeschaltet oder EL7342 ist betriebsbereit.
Warning A/B | gelb | aus | keine Mängel
 |  | an | Konfigurationsfehler, z. B.: Motorspannung nicht angelegt 80°C Temperatur überschritten ...
Error A | rot | aus | keine Mängel
 |  | an | Konfigurationsfehler der Endstufe A, z. B.: 100°C Temperatur überschritten Kurzschluss Offene Last / Drahtbruch ...
Error B | rot | aus | keine Mängel
 |  | an | Konfigurationsfehler der Endstufe B, z. B.: 100°C Temperatur überschritten Kurzschluss Offene Last / Drahtbruch ...


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Einbindung in die NC-Konfiguration (manuell)
•
Prozessdaten
•
Einstellungen im CoE-Register
•
Einstellungen in der NC
•
Inbetriebnahme des Motors mit der NC
•
Betriebsarten
•
Beispiele Inbetriebnahme
•
EL7332- Objektbeschreibung und Parametrierung
•
EL7342 - Objektbeschreibung und Parametrierung


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Analog-Eingangsklemme -10…+10 V)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
Hinweis
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
Hinweis
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Achtung
Veränderung der "üblichen" Konfiguration durch Scan
➢
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
Hinweis
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Hinweis
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Hinweis
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Hinweis
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Hinweis
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Hinweis
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Achtung
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Achtung
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Hinweis
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to compatible device
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf AX5000-Geräten anzuwenden. Wenn aufgerufen, schlägt TwinCAT die Geräte vor die er im zugehörigen Unterordner findet, beim AX5000 z.B. in \TwinCAT\IO\EtherCAT\Beckhoff AX5xxx.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Hinweis
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Download-Revision
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Download-Revision

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Download-Revision
Download-Revision
Hinweis
Download-Revision in der Start-up Liste
Einzelne Klemmen / Module generieren automatisch den Eintrag aus Objekt 0xF081:01 in die Startup-Liste (vgl. Abb. „Download-Revision in der Startup Liste“).
Das Objekt 0xF081:01 (Download revision) beschreibt die Revision der Klemme / des Moduls, z. B. 0x0018000A für EL7201-0010-0024, und ist für die Erfüllung der Kompatibilität notwendig.
Es ist unbedingt darauf zu achten, dass dieser Eintrag nicht aus der Startup Liste gelöscht wird!
Download-Revision in der Startup Liste


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Hinweis
Aktivierung der PDO-Zuordnung
➢
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Achtung
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
Hinweis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Achtung
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Einbindung in die NC-Konfiguration (manuell)

Inbetriebnahme [image] Einbindung in die NC-Konfiguration (manuell)
Einbindung in die NC-Konfiguration (manuell)
(Master: TwinCAT 2.11)
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Die Einbindung an die NC kann wie folgt durchgeführt werden:
▪
Die Klemme muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel Konfigurationserstellung in TwinCAT).
▪
Fügen Sie zuerst einen neuen Task an. Dazu klicken Sie mit der rechten Maustaste auf NC-Konfiguration und wählen Sie "Task Anfügen..." aus (siehe Abb. Neuen Task einfügen).
▪
Benennen Sie gegebenenfalls den Task um und bestätigen Sie mit OK.
Neuen Task einfügen
▪
Wählen Sie mit der rechten Maustaste Achsen aus und fügen anschließend eine neue Achse an (siehe Abb. Auswahl einer neuen Achse).
Auswahl einer neuen Achse
▪
Wählen Sie unter Typ eine Kontinuierliche Achse aus und bestätigen Sie mit OK (siehe Abb. Achsentyp auswählen und bestätigen).
Achsentyp auswählen und bestätigen
▪
Markieren Sie Ihre Achse mit der linken Maustaste. Unter der Registerkarte Einstellungen wählen Sie "Verknüpft mit..." aus (siehe Abb. Verknüpfung der Achse mit der Klemme).
Verknüpfung der Achse mit der Klemme
▪
Wählen Sie die passende Klemme aus (DC Drive (MDP 733)) und bestätigen Sie mit "OK ". Achten Sie darauf, dass jede Klemme zwei Motoren ansteuern kann. Wählen Sie den Kanal, den Sie angeschlossen haben.
Auswahl der richtigen Klemme
▪
Alle wichtigen Verknüpfungen zwischen der NC-Konfiguration und der Klemme werden dadurch automatisch durchgeführt (siehe Abb. Automatische Verknüpfung aller wichtigen Variablen)
Automatische Verknüpfung aller wichtigen Variablen
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapitel Konfiguration der wichtigsten Parameter.
Stellen Sie bitte diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.


Prozessdaten

Inbetriebnahme [image] Prozessdaten
Prozessdaten
Weiterführende Informationen
•
Sync Manager (SM)
•
PDO-Zuordnung
•
Predefined PDO Assignment


Sync Manager (SM)

Inbetriebnahme [image] Prozessdaten [image] Sync Manager (SM)
Sync Manager (SM)
Sync Manager (SM) Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (beispielhaft an EL7342, siehe folgende Abb.).
Karteireiter Prozessdaten SM2, EL7342 (default)
Karteireiter Prozessdaten SM3, EL7342 (default)


PDO-Zuordnung

Inbetriebnahme [image] Prozessdaten [image] PDO-Zuordnung
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (siehe Abb.) den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12, default
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 | 0x1601 | 4.0 | ENC Control compact Ch. 1 | Index 0x7000:02 - Enable Latch extern on positive edge Index 0x7000:03 - Set counter Index 0x7000:04 - Enable Latch extern on negative edge Index 0x7000:11 - Set counter value (16-bit)
0x1602 | 0x1603 | 4.0 | ENC Control compact Ch. 2 | Index 0x7010:02 - Enable Latch extern on positive edge Index 0x7010:03 - Set counter Index 0x7010:04 - Enable Latch extern on negative edge Index 0x7010:11 - Set counter value (16-bit)
0x1604 | - | 2.0 | DCM control Ch. 1 | Index 0x7020:01 - Enable Index 0x7020:02 - Reset Index 0x7020:03 - Reduce torque
0x1606 | 0x1605 0x160A 0x160B | 2.0 | DCM velocity Ch. 1 | Index 0x7020:21 - Velocity
0x1607 | - | 2.0 | DCM control Ch. 2 | Index 0x7030:01 - Enable Index 0x7030:02 - Reset Index 0x7030:03 - Reduce torque
0x1609 | 0x1608 0x160C 0x160D | 2.0 | DCM velocity Ch. 2 | Index 0x7030:21 - Velocity
SM3, PDO-Zuordnung 0x1C13, default
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 | 0x1A01 | 6.0 | ENC Status compact Ch. 1 | Index 0x6000:02 - Latch extern valid Index 0x6000:03 - Set counter done Index 0x6000:04 - Counter underflow Index 0x6000:05 - Counter overflow Index 0x6000:08 - Extrapolation stall Index 0x6000:09 - Status of input A Index 0x6000:0A - Status of input B Index 0x6000:0D - Status of extern latch Index 0x6000:0E- Sync error Index 0x6000:10 - TxPDO Toggle Index 0x6000:11 - Counter value (16-Bit) Index 0x6000:12 - Latch value (16-Bit)
0x1A03 | 0x1A04 | 6.0 | ENC Status compact Ch. 2 | Index 0x6010:02 - Latch extern valid Index 0x6010:03 - Set counter done Index 0x6010:04 - Counter underflow Index 0x6010:05 - Counter overflow Index 0x6010:08 - Extrapolation stall Index 0x6010:09 - Status of input A Index 0x6010:0A - Status of input B Index 0x6010:0D - Status of extern latch Index 0x6010:0E - Sync error Index 0x6010:10 - TxPDO Toggle Index 0x6010:11 - Counter value (16-Bit) Index 0x6010:12 - Latch value (16-Bit)
0x1A06 | - | 2.0 | DCM Status Ch. 1 | Index 0x6020:01 - Ready to enable Index 0x6020:02 - Ready Index 0x6020:03 - Warning Index 0x6020:04 - Error Index 0x6020:05 - Moving positive Index 0x6020:06 - Moving negative Index 0x6020:07 - Torque reduced Index 0x6020:0C - Digital input 1 Index 0x6020:0D - Digital input 2 Index 0x6020:0E - Sync error Index 0x6020:10 - TxPDO Toggle
0x1A08 | - | 2.0 | POS Status | Index 0x6030:01 - Ready to enable Index 0x6030:02 - Ready Index 0x6030:03 - Warning Index 0x6030:04 - Error Index 0x6030:05 - Moving positive Index 0x6030:06 - Moving negative Index 0x6030:07 - Torque reduced Index 0x6030:0C - Digital input 1 Index 0x6030:0D - Digital input 2 Index 0x6030:0E - Sync error Index 0x6030:10 - TxPDO Toggle
Tab. 1: Default PDO-Zuordnung der Sync Manager, EL7342


Predefined PDO Assignment

Inbetriebnahme [image] Prozessdaten [image] Predefined PDO Assignment
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Fünf PDO-Zuordnungen stehen zur Auswahl:
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Velocity control compact | 0x1600 0x1602 0x1604 0x1606 0x1607 0x1609 | 0x1A00 0x1A03 0x1A06 0x1A08
Velocity control | 0x1601 0x1603 0x1604 0x1606 0x1607 0x1609 | 0x1A01 0x1A04 0x1A06 0x1A08
Position control | 0x1601 0x1603 0x1604 0x1605 0x1607 0x1608 | 0x1A01 0x1A04 0x1A06 0x1A08
Positioning interface compact | 0x1601 0x1603 0x1604 0x1607 0x160A 0x160C | 0x1A01 0x1A04 0x1A06 0x1A08 0x1A0A 0x1A0C
Positioning interface | 0x1601 0x1603 0x1604 0x1607 0x160B 0x160D | 0x1A01 0x1A04 0x1A06 0x1A08 0x1A0B 0x1A0D
Karteireiter Prozessdaten Predefined PDO Assignment, EL7342


Einstellungen im CoE-Register

Inbetriebnahme [image] Einstellungen im CoE-Register
Einstellungen im CoE-Register
Die hier angegebenen Daten sind beispielhaft für einen DC Motor GR42X25, der Firma Dunkermotoren aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Weiterführende Informationen
•
Anpassung von Strom und Spannung
•
Anpassung der Encoderdaten
•
Anpassung der maximalen Geschwindigkeit
•
Auswahl der Betriebsart
•
Select info data
•
KA-Faktor


Anpassung von Strom und Spannung

Inbetriebnahme [image] Einstellungen im CoE-Register [image] Anpassung von Strom und Spannung
Anpassung von Strom und Spannung
Achtung
Überhitzung des Motors möglich!
Um den angeschlossenen Motor nicht zu überhitzen, ist es wichtig, den Strom und die Spannung, die vom Stepperinterface ausgegeben wird, dem Motor anzupassen.
Dazu müssen im CoE-Register der Index 0x8020:02 "Nominal current" und der Index 0x8020:03 "Nominal voltage" passend eingestellt werden (siehe Abb. Anpassung von Strom und Spannung). Darüber hinaus sollten Sie noch den "Maximal current" im Index 0x8020:01 und den Spulenwiderstand des Motors im Index 0x8020:04 "Motor coil resistance" dem angeschlossenen Motor anpassen.
Im Index 0x8020:05 und 0x8020:06 kann derReducedcurrent eingestellt werden. Dadurch wird der Spulenstrom im Stillstand (und damit auch die Verlustleistung) reduziert. Es ist zu beachten, dass sich damit auch das Drehmoment reduziert.
Anpassung von Strom und Spannung


Anpassung der Encoderdaten

Inbetriebnahme [image] Einstellungen im CoE-Register [image] Anpassung der Encoderdaten
Anpassung der Encoderdaten
Es sind unterschiedliche Encoder, mit unterschiedlicher Anzahl an Inkrementen erhältlich. Im Index 0x8020:07 "Encoder increments" müssen Sie die Anzahl der Inkremente Ihres Encoders angeben (siehe Abb. Anpassung der Encoderdaten). In unserem Beispiel wird ein Encoder mit 1024 Inkrementen benutzt, bei einer 4-Fach-Auswertung entspricht das 4096 Inkrementen. Die Anzahl der Inkremente Ihres Encoders entnehmen Sie bitte dem Datenblatt des Encoders.
Anpassung der Encoderdaten


Anpassung der maximalen Geschwindigkeit

Inbetriebnahme [image] Einstellungen im CoE-Register [image] Anpassung der maximalen Geschwindigkeit
Anpassung der maximalen Geschwindigkeit
Die maximale Geschwindigkeit, die Ihr DC-Motor fahren kann, muss im Index 0x8020:08 "Maximal motor velocity" eingetragen werden (siehe Abb. Anpassung der Maximalgeschwindigkeit). Sie können diesen Parameter dem Typenschild des Motors entnehmen und 1:1 in den Index schreiben. Im Beispiel hat der Motor eine maximale Geschwindigkeit von 3600 Umdrehungen pro Minute.
Anpassung der Maximalgeschwindigkeit


Auswahl der Betriebsart

Inbetriebnahme [image] Einstellungen im CoE-Register [image] Auswahl der Betriebsart
Auswahl der Betriebsart
Im Index 0x8022:01 "Operation mode" können Sie die Betriebsart wählen. Es wird empfohlen, dass Sie die Betriebsart "Automatic" (Abb. Betriebsmodus einstellen) wählen und anschließend, unter der Registerkarte Prozessdaten, die für Ihre Anwendung passende Betriebsart einstellen. Nähere Informationen dazu finden Sie unter dem Kapitel "Prozessdaten".
Betriebsmodus einstellen


Select info data

Inbetriebnahme [image] Einstellungen im CoE-Register [image] Select info data
Select info data
Sie haben die Möglichkeit, im Index 0x8022:11 "Select info data 1" und 0x8022:19 "Select info data 2", zwei Parameter auszuwählen, die Sie sich in den Prozessdaten anzeigen lassen können (siehe Abb. Auswahl zusätzlicher Informationsdaten). Folgende Parameter sind wählbar
▪
Status word
▪
Motor coil voltage
▪
Motor coil current
▪
Current limit
▪
Control error
▪
Duty cycle
▪
Motor velocity
▪
Overload time
▪
Internal temperature
▪
Control voltage
▪
Motor supply voltage
▪
Status word (drive controller)
▪
State (drive controller)
Diese zwei Parameter müssen in den Prozessdaten anschließend aktiviert werden. Wie Sie die Parameter aktivieren entnehmen Sie bitte dem Kapitel "Prozessdaten".
Auswahl zusätzlicher Informationsdaten


KA-Faktor

Inbetriebnahme [image] Einstellungen im CoE-Register [image] KA-Faktor
KA-Faktor
Mit dem KA-Faktor kann der Strom in den Beschleunigungsphasen angepasst werden. Die Stromerhöhung wird wie folgt berechnet.
Stromerhöhung in mA = Geschwindigkeitsdifferenz x KA / 1000
Je steiler also die Geschwindigkeitsrampen sind, desto höher ist die Erhöhung des Stroms.
Geschwindigkeitsrampen
Dieser Wert lässt sich im Index 0x8023:07 "Ka factor (velo./pos.)" einstellen (Abb. KA-Faktor einstellen).
KA-Faktor einstellen


Einstellungen in der NC

Inbetriebnahme [image] Einstellungen in der NC
Einstellungen in der NC
Die hier angegebenen Daten sind beispielhaft für einen DC Motor GR42X25, der Firma Dunkermotoren aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Weiterführende Informationen
•
Auswahl der Bezugsgeschwindigkeit
•
Totzeitkompensation
•
Skalierungsfaktor
•
Schleppüberwachung Position
•
KV-Faktoren


Auswahl der Bezugsgeschwindigkeit

Inbetriebnahme [image] Einstellungen in der NC [image] Auswahl der Bezugsgeschwindigkeit
Auswahl der Bezugsgeschwindigkeit
Die Maximalgeschwindigkeit errechnet sich anhand der maximalen Motorgeschwindigkeit (Typenschild) und der zu verfahrenden Distanz. Hier bezogen auf eine Umdrehung pro Sekunde.
vmax = (maximale Motorgeschwindigkeit x 360°) / 60s
= ((3600 Umdrehung / min.) x 360°) / 60s
= 21600 Umdrehungen / s
Anpassung der Bezugsgeschwindigkeit
Dies ist ein theoretischer Wert und kommt dem praktischen Wert sehr nah. Abhängig von der Belastung kann dieser Wert jedoch variieren. Um den tatsächlichen Wert zu ermitteln, sollte Sie den Kv-Faktor auf 0 setzen und die endgültige Bezugsgeschwindigkeit empirisch ermitteln. Verfahren Sie dazu den Motor mit Hilfe der Tasten F1 - F4 und vergleichen Sie die Ist-Geschwindigkeit und die Soll-Geschwindigkeit. Diese Werte müssen nahezu identisch sein. Ist die Ist-Geschwindigkeit größer, dann vergrößern Sie die Bezugsgeschwindigkeit ein wenig, ist die Ist-Geschwindigkeit kleiner als die Soll-Geschwindigkeit, dann verringern Sie ein wenig die Bezugsgeschwindigkeit. Sie sollten diese empirische Ermittlung allerdings erst durchführen, wenn Sie die restlichen Parameter eingestellt haben.
In unserem Fall liegt die Bezugsgeschwindigkeit bei 25570 Umdrehung / s. Passen Sie anschließend auch noch die Maximale erlaubte Geschwindigkeit an.


Totzeitkompensation

Inbetriebnahme [image] Einstellungen in der NC [image] Totzeitkompensation
Totzeitkompensation
Totzeitkompensation
Die Totzeitkompensation der Achse kann in der Registerkarte Time Compensation der Encodereinstellungen Achse1_ENC eingestellt werden. Sie sollte theoretisch 3 Zyklen der NC-Zykluszeit betragen, besser haben sich jedoch 4 Zyklen der NC-Zykluszeit erwiesen. Dazu sollten die Parameter Time Compensation Mode Encoder auf ‚ON (with velocity)‘ und Encoder Delay in Cycles auf 4 eingestellt sein.
Parameter Totzeitkompensation


Skalierungsfaktor

Inbetriebnahme [image] Einstellungen in der NC [image] Skalierungsfaktor
Skalierungsfaktor
Den Skalierungsfaktor können Sie ändern, wenn Sie in der NC "Achse 1_Enc" und die Registerkarte "Parameter" auswählen (siehe Abb. Skalierungsfaktor einstellen). Der Wert lässt sich mit den unten angegebenen Formeln berechnen.
Skalierungsfaktor einstellen
Berechnung des Skalierungsfaktors
SF = Weg pro Umdrehung / (Inkremente x 4) = 360° / (1024 x 4) = 0,087890625 ° / INC


Schleppüberwachung Position

Inbetriebnahme [image] Einstellungen in der NC [image] Schleppüberwachung Position
Schleppüberwachung Position
Die Schleppabstandsüberwachung überwacht, ob der aktuelle Schleppabstand einer Achse einen Grenzwert überschreitet. Als Schleppabstand wird die Differenz zwischen ausgegebenem Sollwert (Stellgröße) und dem rückgemeldeten Istwert bezeichnet. Sind die Parameter der Klemme noch unzureichend eingestellt, kann es dazu führen, dass beim Verfahren der Achse die Schleppabstandsüberwachung einen Fehler ausgibt. Bei der Inbetriebnahme kann es deswegen eventuell von Vorteil sein, wenn man die Grenzen der Schleppüberwachung Position etwas erhöht.
Achtung
ACHTUNG: Beschädigung von Geräten, Maschinen und Peripherieteilen möglich!
Bei der Parametrierung der Schleppüberwachung können durch Einstellen zu hoher Grenzwerte Geräte, Maschinen und Peripherieteile beschädigt werden!
Schleppüberwachung


KV-Faktoren

Inbetriebnahme [image] Einstellungen in der NC [image] KV-Faktoren
KV-Faktoren
In der NC lassen sich unter "Achse 1_Ctrl "in der Registerkarte "Parameter" zwei Proportionalfaktoren Kv einstellen. Wählen Sie jedoch vorher unter der Registerkarte "NC-Controller" den Typ Positionsregler mit zwei P-Konstanten (mit KA) aus. Die beiden P-Konstanten sind einmal für den Bereich Stillstand und ein weiteres Mal für den Bereich Fahren (siehe Abb. Proportionalfaktor KV einstellen). Damit hat man die Möglichkeit, im Anfahrmoment und im Bremsmoment ein anderes Drehmoment einzustellen als beim Fahren. Der Schwellwert lässt sich direkt darunter (Pos-Regelung: Geschw.schwelle V dyn) zwischen 0.0 (0%) und 1.0 (100%) einstellen. In der Abb. Geschwindigkeitsrampe mit Grenzwerten des KV-Faktors ist eine Geschwindigkeitsrampe mit Schwellwerten von 50% dargestellt. Im Bereich Stillstand (t1 und t3) kann dann ein unterschiedlicher Kv-Faktor eingestellt werden als im Bereich Fahren (t2). Der Faktor im Stillstand sollte immer höher sein, als der Faktor für den Fahrbereich.
Geschwindigkeitsrampe mit Grenzwerten des KV-Faktors
Proportionalfaktor KV einstellen


Inbetriebnahme des Motors mit der NC

Inbetriebnahme [image] Inbetriebnahme des Motors mit der NC
Inbetriebnahme des Motors mit der NC
▪
Sind die Parameter eingestellt, dann ist der Motor prinzipiell betriebsbereit. Einzelne weitere Parameter müssen der jeweiligen Applikation angepasst werden.
▪
Um die Achse in Betrieb zu nehmen, aktivieren Sie die Konfiguration (Ctrl+Shift+F4), markieren die Achse, wählen die Registerkarte Online aus und geben unter Set die Achse frei.
▪
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Achse freigeben). Anschließend kann die Achse bewegt werden.
Achse freigeben
Sie können nun die Achse mit Hilfe der Funktionstasten F1, F2 (Rückwärts) und F3, F4 (Vorwärts) bewegen.
Sie können hier den Kv Faktor verstellen und sich somit an einen passenden Faktor herantasten. Stellen Sie zunächst 0 ein, um die richtige Bezugsgeschwindigkeit einzustellen. Wie die Bezugsgeschwindigkeit berechnet wird, entnehmen Sie bitte dem Kapitel "Auswahl der Bezugsgeschwindigkeit". Die Berechnung gibt einen relativ genauen Wert an, Sie müssen diesen Wert gegebenenfalls noch etwas korrigieren. Verfahren Sie dazu den Motor mit einem Kv Faktor von 0 und achten Sie darauf, dass die Ist-Geschwindigkeit mit der Soll-Geschwindigkeit übereinstimmt.
Eine andere Möglichkeit besteht darin, unter der Registerkarte "Funktionen", die Achse anzusteuern. Nachfolgend ein Beispiel dazu.
▪
Wählen Sie als Starttyp Reversing Sequence.
▪
Geben Sie eine gewünschte Zielposition1 an, z. B. 5000°.
▪
Geben Sie ein gewünschte Zielgeschwindigkeit an, z. B. 2000°/s.
▪
Geben Sie eine gewünschte Zielposition2 an, z. B. 0°.
▪
Geben Sie den gewünschte Idle Time an, z. B. 1 s.
▪
Wählen Sie Start.
Achse freigeben
Nun dreht sich Ihr Motor auf die Position 1, verbleibt dort 1 s und fährt wieder auf die Position 2. Das wird wiederholt, bis Sie das mit "Stop" beenden.


Betriebsarten

Inbetriebnahme [image] Betriebsarten
Betriebsarten
Weiterführende Informationen
•
Übersicht
•
Chopper-Betrieb
•
Grundlagen zum "Positioning Interface"


Übersicht

Inbetriebnahme [image] Betriebsarten [image] Übersicht
Übersicht
Es werden die Betriebsarten Automatik, Geschwindigkeit direkt, Positionskontroller, Fahrwegsteuerung und Bremswiderstand unterstützt.
Automatik
In Vorbereitung!
Geschwindigkeit, direkt
Diese Betriebsart ist zur Verwendung am zyklischen Geschwindigkeitsinterface einer Numerischen Steuerung (NC) gedacht. Die NC gibt in dieser Betriebsart eine Sollgeschwindigkeit vor. Rampen für den Anlauf und das Abbremsen des Motors werden ebenfalls von der NC gesteuert.
Positionskontroller
Hinweise zu dieser Betriebsart siehe Kapitel Positioning Interface
Fahrwegsteuerung
In Vorbereitung!
Bremswiderstand
Hinweise zu dieser Betriebsart siehe Kapitel Chopper-Betrieb.


Chopper-Betrieb

Inbetriebnahme [image] Betriebsarten [image] Chopper-Betrieb
Chopper-Betrieb
Sie können an einem Kanal der EL7332/EL7342 anstelle eines DC-Motors einen Bremswiderstand (Chopper) anschließen und für diesen Kanal die Betriebsart Bremswiderstand (EL7332, Index 0x8022:01 bzw. 0x8032:01; EL7342, Index 0x8022:01 bzw. 0x8032:01) aktivieren.
Für Positionierungsaufgaben muss der Motor aktiv bremsen. Dabei wird die mechanische Energie in elektrische Energie zurückgewandelt. Geringe Energiemengen werden einem Kondensator in der EL7332/EL7342 aufgenommen. Weitere Speicherkapazitäten zum Beispiel im Netzteil können auch Energie aufnehmen. In jedem Fall führt die Rückspeisung zu einer Spannungserhöhung.
Zur Vermeidung von Überspannungen kann an die EL7332/EL7342 ein Bremswiderstand geschaltet werden um die überschüssige Energie in Form von Wärme abgeben zu können. Sobald die Spannung 110% der Nennspannung (EL7332, Index 0x8020:03 bzw. 0x8030:03; EL7342, 0x8020:03 bzw. 0x8030:03), z. B. 55 V für EL7342 erreicht, treibt die richtig eingestellte Endstufe einen schnell getakteten Strom durch den Bremswiderstand (siehe Diagramm).
ICH/IN. - UCH/UN Kennlinie
Achtung
Auslegung des Bremswiderstands
Der Bremswiderstand sollte so dimensioniert werden dass er die zu erwartende Wärmeentwicklung schadlos übersteht!
Für die EL7342 wird ein Bremswiderstand von 10 Ω empfohlen, wodurch sich ein Pulsstrom von ca. 5,5 A bis 6,5 A ergibt. Die maximal zu erwartende Dauerleistung ist 125 W. Typisch liegt der Wert jedoch deutlich darunter.
Leistungsabschätzung
PN = IN² x R
PN = (5A)² x 10 Ω
PN = 250 W
Es ist eine Einschaltdauer von maximal 50% möglich. Somit ergibt sich eine maximale Dauerleistung von 125 W.
In der Praxis ist ein Motorwirkungsgrad von 80% üblich.
Der Motor setzt also beim Beschleunigen 80% der elektrischen Nennleistung in Bewegungsenergie um.
Beim Bremsen setzt der Motor (als Generator) wiederum 80% der Bewegungsenergie in elektrische Leistung um.
So ergibt sich eine praktische Bremsleistung von:
PCH = PN/2 x 80/100 x 80/100
PCH = 125W x 80/100 x 80/100
PCH = 80 W


Grundlagen zum "Positioning Interface"

Inbetriebnahme [image] Betriebsarten [image] Grundlagen zum "Positioning Interface"
Grundlagen zum "Positioning Interface"
Das "Positioning interface" bietet dem Anwender eine Möglichkeit direkt auf der Klemme Fahraufträge auszuführen.
Inhaltsverzeichnis
▪
Predefined PDO Assignment
▪
Parametersatz
▪
Informations- und Diagnosedaten
▪
Zustände der internen Statemachine
▪
Standard Ablauf eines Fahrauftrags
▪
Starttypen
▪
Modulo - allgemeine Beschreibung
▪
Beispiele
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die Funktion "Positioning interface" oder "Positioning interface compact" aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Predefined PDO Assignment
Parametersatz
Für die Konfiguration stehen dem Anwender im CoE zwei Objekte zur Verfügung, die "POS Settings" (Index 0x8040) und die "POS Features" (Index 0x8041).
Settings-Objekte im CoE
▪
POS Settings:
–
Velocity min.:
Die Klemme benötigt aus Gründen der Performance, beim Herunterrampen auf die Zielposition einen, Sicherheitsbereich von 0,5 %. Das bedeutet, dass abhängig von der erreichten Maximalgeschwindigkeit und der konfigurierten Verzögerung der Zeitpunkt errechnet wird, an dem die Bremsrampe beginnt. Um immer sicher ins Ziel zu gelangen, werden von der ermittelten Position 0,5 % abgezogen. Ist die Bremsrampe beendet und das Ziel noch nicht erreicht, fährt die Klemme mit der Geschwindigkeit "Velocity min." bis ins Ziel hinein. Sie muss so konfiguriert werden, dass der Motor in der Lage ist abrupt und ohne einen Schrittverlust mit dieser Geschwindigkeit abzustoppen.
–
Velocity max.:
Die maximale Geschwindigkeit, mit der der Motor während eines Fahrauftrages fährt.
–
Acceleration pos.:
Beschleunigungszeit in positiver Drehrichtung.
Die 5 Parameter der Beschleunigung werden in ms angegeben. Mit der Einstellung von 1000 beschleunigt die Klemme den Motor in 1000 ms von 0 auf 100 %. Bei einer Geschwindigkeit von 50 % verringert sich die Beschleunigungszeit dementsprechend linear auf die Hälfte.
–
Acceleration neg.:
Beschleunigungszeit in negativer Drehrichtung.
–
Deceleration pos.:
Verzögerungszeit in positiver Drehrichtung.
–
Deceleration neg.:
Verzögerungszeit in negativer Drehrichtung.
–
Emergency deceleration:
Notfall-Verzögerungszeit (beide Drehrichtungen). Ist im entsprechenden PDO "Emergency stop" gesetzt, wird der Motor innerhalb dieser Zeit gestoppt.
–
Calibration position:
Der aktuelle Zählerstand wird nach erfolgter Kalibrierung mit diesem Wert geladen.
–
Calibration velocity (towards plc cam):
Geschwindigkeit, mit der der Motor, während der Kalibrierung auf die Nocke fährt.
–
Calibration velocity (off plc cam):
Geschwindigkeit, mit der der Motor, während der Kalibrierung von der Nocke herunter fährt.
–
Target window:
Zielfenster der Fahrwegsteuerung. Kommt der Motor innerhalb dieses Zielfensters zum Stillstand, wird "In-Target" gesetzt
–
In-Target timeout:
Steht der Motor nach Ablauf der Fahrwegsteuerung nach dieser eingestellten Zeit nicht im Zielfenster, wird "In-Target" nicht gesetzt. Dieser Zustand kann nur durch Kontrolle der negativen Flanke von "Busy" erkannt werden.
–
Dead time compensation:
Kompensation der internen Laufzeiten. Dieser Parameter muss bei Standardanwendungen nicht geändert werden.
–
Modulo factor:
Der "Modulo factor" wird zur Berechnung der Zielposition und der Drehrichtung in den Modulo-Betriebsarten herangezogen. Er bezieht sich auf das angesteuerte System.
–
Modulo tolerance window:
Toleranzfenster zur Ermittlung der Startbedingung der Modulo-Betriebsarten.
–
Position lag max.:
Max. erlaubter Schleppabstand, Erläuterungen siehe in "Einstellungen in der NC"
▪
POS Features:
–
Start type:
Der "Start type" bestimmt die Art der Berechnung für die Ermittlung der Zielposition (siehe unten).
–
Time information:
Durch diesen Parameter wird die Bedeutung der angezeigten "Actual drive time" konfiguriert. Zurzeit kann dieser Wert nicht verändert werden, da es keine weitere Auswahlmöglichkeit gibt. Es wird die abgelaufene Zeit des Fahrauftrages angezeigt.
–
Invert calibration cam search direction:
Bezogen auf eine positive Drehrichtung wird hier die Richtung der Suche nach der Kalibrier-Nocke konfiguriert (auf die Nocke fahren).
–
Invert sync impulse search direction:
Bezogen auf eine positive Drehrichtung wird hier die Richtung der Suche nach dem HW-Sync-Impuls konfiguriert (von der Nocke herunter fahren).
–
Emergency stop on position lag error:
Löst einen Nothalt bei Überschreitung des max. Schleppfehlers aus.
–
Enhanced diag history:
Es werden detailliertere Meldungen zum Status des Positioning Interface in der Diag History ausgegeben.
Informations- und Diagnosedaten
Über die Informations- und Diagnosedaten kann der Anwender eine genauere Aussage darüber erhalten, welcher Fehler während eines Fahrauftrages aufgetreten ist.
Diagnose-Objekte im CoE
▪
POS Info data:
–
Status word:
Das "Status word" spiegelt die im Index 0xA040 verwendeten Status-Bits in einem Datenwort, um diese in der PLC einfacher verarbeiten zu können. Die Positionen der Bits entsprechen der Nummer des Subindizes-1.
Bit 0: Command rejected
Bit 1: Command aborded
Bit 2: Target overrun
–
State (drive controller):
Hier wird der aktuelle Status der internen Statemachine eingeblendet (siehe unten).
–
Actual position lag:
Aktueller Schleppabstand, siehe Einstellungen in der NC
▪
POS Diag data:
–
Command rejected:
Eine dynamische Änderung der Zielposition wird nicht zu jedem Zeitpunkt von der Klemme übernommen, da dies dann nicht möglich ist. Der neue Auftrag wird in diesem Fall abgewiesen und durch setzen dieses Bits signalisiert.
Diese 3 Diagnose-Bits werden durch Setzten von "Warning" im PDO zur Steuerung synchron übertragen.
–
Command aborted:
Der aktuelle Fahrauftrag wird durch einen internen Fehler oder durch ein "Emergency stop" vorzeitig abgebrochen.
–
Target overrun:
Bei einer dynamischen Änderung der Zielposition kann es vorkommen, dass die Änderung zu einem relativ späten Zeitpunkt erfolgt. Dies kann zur Folge haben, dass ein Drehrichtungswechsel erforderlich ist und ggf. die neue Zielposition überfahren wird. Tritt dies ein, wird "Target overrun" gesetzt.
–
Target timeout:
Der Motor hat nach Beendigung des Fahrauftrags innerhalb der konfigurierten Zeit (0x8040:0C, 0x8050:0C), das Zielfenster (8040:0B, 8050:0B) nicht erreicht
–
Position lag:
Der Schleppabstand wurde überschritten. Bei „Position lag max.” = 0 ist die Schleppabstandsüberwachung deaktiviert. Wird in „Position lag max.” ein Wert eingetragen, so wird dieser Wert mit “Actual position lag” verglichen. Sobald “Actual position lag” größer ist als “Position lag max.” wird “Position lag” = 1 gesetzt und ein PDO-Warning ausgegeben.
–
Emergency stop:
Ein Nothalt wurde ausgelöst (automatisch oder manuell).
Zustände der internen Statemachine
Der State (drive controller) (Index 0x9040:03, 0x9050:03) gibt Auskunft über den aktuellen Zustand der internen Statemachine. Zu Diagnosezwecken kann dieser zur Laufzeit von der PLC ausgelesen werden. Der interne Zyklus arbeitet konstant mit 250 µs. Ein angeschlossener PLC-Zyklus ist großer Wahrscheinlichkeit nach langsamer (z. B. 1 ms). Daher kann es vorkommen, dass manche Zustände in der PLC überhaupt nicht sichtbar sind, da diese teilweise nur einen internen Zyklus durchlaufen werden.
Name | ID | Beschreibung
INIT | 0x0000 | Initialisierung/Vorbereitung für den nächsten Fahrauftrag
IDLE | 0x0001 | Warten auf den nächsten Fahrauftrag
START | 0x0010 | das neue Kommando wird ausgewertet und die entsprechenden Berechnungen durchgeführt
ACCEL | 0x0011 | Beschleunigungs-Phase
CONST | 0x0012 | Konstant-Phase
DECEL | 0x0013 | Verzögerungs-Phase
EMCY | 0x0040 | es wurde ein "Emergency stop" ausgelöst
STOP | 0x0041 | der Motor ist gestoppt
CALI_START | 0x0100 | Start eines Kalibrierkommandos
CALI_GO_CAM | 0x0110 | der Motor wird auf die Nocke gefahren
CALI_ON_CAM | 0x0111 | die Nocke wurde erreicht
CALI_GO_SYNC | 0x0120 | der Motor wird in Richtung des HW-Sync-Impulses gefahren
CALI_LEAVE_CAM | 0x0121 | der Motor wird von der Nocke herunter gefahren
CALI_STOP | 0x0130 | Ende der Kalibrier-Phase
CALIBRATED | 0x0140 | der Motor ist kalibriert
NOT_CALIBRATED | 0x0141 | der Motor ist nicht kalibriert
PRE_TARGET | 0x1000 | Sollposition ist erreicht, der Positionsregler "zieht" den Motor weiter ins Ziel, "In-Target timeout" wird hier gestartet
TARGET | 0x1001 | der Motor hat das Zielfenster innerhalb des Timeouts erreicht
TARGET_RESTART | 0x1002 | eine dynamische Änderung der Zielposition wird hier verarbeitet
END | 0x2000 | Ende der Positionier-Phase
WARNING | 0x4000 | während des Fahrauftrages ist eine Warn-Zustand aufgetreten, dieser wird hier verarbeitet
ERROR | 0x8000 | während des Fahrauftrages ist eine Fehler-Zustand aufgetreten, dieser wird hier verarbeitet
UNDEFINED | 0xFFFF | undefinierter Zustand (kann z. B. auftreten, wenn die Treiberstufe keine Steuerspannung hat)
Tab. 1: Zustände der internen Statemachine
Standard Ablauf eines Fahrauftrags
Im folgenden Ablaufdiagramm ist ein "normaler" Ablauf eines Fahrauftrags dargestellt.
Es wird grob zwischen diesen vier Stufen unterschieden:
Startup
Überprüfung des Systems und der Betriebsbereitschaft des Motors.
Start positioning
Schreiben aller Variablen und Berechnung der gewünschten Zielposition mit dem entsprechenden "Start type". Anschließend den Fahrauftrag starten.
Evaluate status
Überwachung des Klemmen-Status und ggf. dynamische Änderung der Zielposition.
Error handling
Im Falle eines Fehlers die nötigen Informationen aus dem CoE beziehen und auswerten.
Ablauf-Diagramm eines Fahrauftrages
Starttypen
Das "Positioning interface" bietet verschiedene Arten der Positionierung. Die folgende Tabelle enthält alle unterstützten Kommandos, diese sind in 4 Gruppen aufgeteilt.
Name | Kommando | Gruppe | Beschreibung
ABSOLUTE | 0x0001 | Standard | absolute Positionierung auf eine vorgegebene Zielposition
RELATIVE | 0x0002 |  | relative Positionierung auf eine berechnete Zielposition, ein vorgegebener Positionsunterschied wird zur aktuelle Position addiert
ENDLESS_PLUS | 0x0003 |  | endlos fahren in positiver Drehrichtung (direkte Vorgabe einer Geschwindigkeit)
ENDLESS_MINUS | 0x0004 |  | endlos fahren in negativer Drehrichtung (direkte Vorgabe einer Geschwindigkeit)
ADDITIVE | 0x0006 |  | additive Positionierung auf eine berechnete Zielposition, ein vorgegebener Positionsunterschied wird zur letzten Zielposition addiert
ABSOLUTE_CHANGE | 0x1001 | Standard Ext. | dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, absolute Position
RELATIVE_CHANGE | 0x1002 |  | dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, relative Position (es wird hier ebenfalls der aktuelle, sich verändernde Positionswert verwendet)
ADDITIVE_CHANGE | 0x1006 |  | dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, additive Position (es wird hier die letzte Zielposition verwendet)
MODULO_SHORT | 0x0105 | Modulo | modulo Positionierung auf kürzestem Weg zur Moduloposition (positiv oder negativ), berechnet durch den konfigurierten "Modulo factor" (Index 0x8040:0E)
MODULO_SHORT_EXT | 0x0115 |  | modulo Positionierung auf kürzestem Weg zur Moduloposition, das "Modulo tolerance window" (Index 0x8040:0F)
MODULO_PLUS | 0x0405 |  | modulo Positionierung in positiver Drehrichtung auf die berechnete Moduloposition
MODULO_PLUS_EXT | 0x0415 |  | modulo Positionierung in positiver Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
MODULO_MINUS | 0x0305 |  | modulo Positionierung in negativer Drehrichtung auf die berechnete Moduloposition
MODULO_MINUS_EXT | 0x0315 |  | modulo Positionierung in negativer Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
MODULO_CURRENT | 0x0405 |  | modulo Positionierung mit der letzten Drehrichtung auf die berechnete Moduloposition
MODULO_CURRENT_EXT | 0x0415 |  | modulo Positionierung mit der letzten Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
CALI_PLC_CAM | 0x6000 | Calibration | starten einer Kalibrierung mit Nocke (digitale Eingänge)
CALI_HW_SYNC | 0x6100 |  | starten einer Kalibrierung mit Nocke und HW-Sync-Impuls (C-Spur)
SET_CALIBRATION | 0x6E00 |  | manuelles Setzen der Klemme auf "Kalibriert"
SET_CALIBRATION_AUTO | 0x6E01 |  | automatisches Setzen der Klemme auf "Kalibriert" bei der ersten steigenden Flanke von "Enable"
CLEAR_CALIBRATION | 0x6F00 |  | manuelles Löschen der Kalibrierung
Tab. 2: Unterstützte "Start types" des "Positioning interface"
ABSOLUTE:
Die absolute Positionierung stellt den einfachsten Fall einer Positionierung dar. Es wird eine Position B vorgegeben, welche vom Startpunkt A aus angefahren wird.
Absolute Positionierung
RELATIVE:
Bei der relativen Positionierung gibt der Anwender ein Positionsdelta S vor, welches zur aktuellen Position A addiert wird und die Zielposition B ergibt.
Relative Positionierung
ENDLESS_PLUS / ENDLESS_MINUS:
Die beiden Starttypen "ENDLESS_PLUS" und "ENDLESS_MINUS" bieten im "Positioning interface" die Möglichkeit dem Motor eine direkte Geschwindigkeit vorzugeben, um endlos in positiver oder negativer Richtung, mit den vorgegebenen Beschleunigungen, zu fahren.
Endlos fahren
ADDITIVE:
Für die additive Positionierung wird, zur Berechnung der Zielposition B, das vom Anwender vorgegebene Positionsdelta S mit der beim letzten Fahrauftrag verwendeten Zielposition E addiert.
Diese Art der Positionierung ähnelt der relativen Positionierung, hat aber doch einen Unterschied. Wurde der letzte Fahrauftrag mit Erfolg abgeschlossen, ist die neue Zielposition gleich. Gab es aber einen Fehler, sei es dass der Motor in eine Stallsituation geraten ist oder ein "Emergency stop" ausgelöst wurde, ist die aktuelle Position beliebig und nicht vorausschaubar. Der Anwender hat jetzt den Vorteil, dass er die letzte Zielposition für die Berechnung der folgenden Zielposition nutzen kann.
Additive Positionierung
ABSOLUTE_CHANGE / RELATIVE_CHANGE / ADDITIVE_CHANGE:
Diese drei Positionierarten sind komplett identisch zu den oben beschrieben. Der wichtige Unterschied dabei ist, dass der Anwender während eines aktiven Fahrauftrags diese Kommandos nutzt, um dynamisch eine neue Zielposition vorzugeben.
Es gelten dabei die gleichen Regeln und Voraussetzungen, wie bei den "normalen" Starttypen. "ABSOLUTE_CHANGE" und "ADDITIVE_CHANGE" sind in der Berechnung der Zielposition eindeutig d.h. bei der absoluten Positionierung wird eine absolute Position vorgegeben und bei der additiven Positionierung wird ein Positionsdelta zu der gerade aktiven Zielposition addiert.
Achtung
Vorsicht bei der Verwendung der Positionierung "RELATIVE_CHANGE"
Die Änderung per "RELATIVE_CHANGE" muss mit Vorsicht angewendet werden, da auch hier die aktuelle Position des Motors als Startposition verwendet wird. Durch Laufzeiten des Systems stimmt die im PDO angezeigte Position nie mit der realen Position des Motors überein! Daher wird sich bei der Berechnung des übergebenen Positionsdeltas immer eine Differenz zur gewünschten Zielposition einstellen.
Hinweis
Zeitpunkt der Änderung der Zielposition
Eine Änderung der Zielposition kann nicht zu jedem beliebigen Zeitpunkt erfolgen. Falls die Berechnung der Ausgabeparameter ergibt, dass die neue Zielposition nicht ohne weiteres erreicht werden kann, wird das Kommando von der Klemme abgewiesen und das Bit "Command rejected" gesetzt. Dies ist z. B. im Stillstand (da die Klemme hier eine Standard Positionierung erwartet) und in der Beschleunigungsphase (da zu diesem Zeitpunkt der Bremszeitpunkt noch nicht berechnet werden kann) der Fall.
CALI_PLC_CAM / CALI_HW_SYNC / SET_CALIBRATION / SET_CALIBRATION_AUTO / CLEAR_CALIBRATION:
Der einfachste Fall einer Kalibrierung ist der, nur per Nocke (an einem dig. Eingang angeschlossen) zu kalibrieren.
Hierbei fährt der Motor im
Schritt mit der Geschwindigkeit 1 (Index 0x8040:09) in Richtung 1 (Index 0x8041:13) auf die Nocke.
Anschließend im 2. Schritt mit der Geschwindigkeit 2 (Index 0x8040:0A) in Richtung 2 (Index 0x8041:14) von der Nocke herunter.
Nachdem das "In-Target timeout" (Index 0x8040:0C) abgelaufen ist, wird die Kalibrierposition (Index 0x8040:08) als aktuelle Position von der Klemme übernommen.
Achtung
Schalthysterese des Nockenschalters beachten
Bei dieser einfachen Kalibrierung muss beachtet werden, dass die Positionserfassung der Nocke nur bedingt genau ist. Die digitalen Eingänge sind nicht interrupt gesteuert und werden "nur" gepollt. Durch die internen Laufzeiten kann sich deshalb eine systembedingte Positionsdifferenz ergeben.
Kalibrierung mit Nocke
Für eine genauere Kalibrierung wird zusätzlich zu der Nocke ein HW-Sync-Impuls (C-Spur) verwendet. Der Ablauf dieser Kalibrierung erfolgt genau wie oben beschrieben, bis zu dem Zeitpunkt, an dem der Motor von der Nocke herunterfährt. Jetzt wird nicht sofort gestoppt, sondern erst auf den Sync-Impuls gewartet. Anschließend läuft wieder das "In-Target timeout" ab und die Kalibrierposition wird als aktuelle Position von der Klemme übernommen.
Kalibrierung mit Nocke und C-Spur
Falls eine Kalibrierung per Hardware, aufgrund der applikatorischen Umstände, nicht möglich ist, kann der Anwender das Bit "Calibrated" auch manuell bzw. automatisch setzen. Das manuelle Setzen bzw. Löschen erfolgt mit den Kommandos "SET_CALIBRATION" und "CLEAR_CALIBRATION".
Einfacher ist es aber, wenn man den Standard-Starttypen (Index 0x8041:01) auf "SET_CALIBRATION_AUTO" konfiguriert. Jetzt wird bei der ersten steigenden Flanke von "Enable" das Bit "Calibrated" automatisch gesetzt. Das Kommando ist nur für diesen Zweck konzipiert, daher ist es nicht sinnvoll es über den synchronen Datenaustausch zu benutzen.
MODULO:
Die Modulo-Position der Achse ist eine zusätzliche Information zur absoluten Achsposition und die Modulo-Positionierung stellt die gewünschte Zielposition auf eine andere Art dar. Im Gegensatz zu den Standard-Positionierarten, ist bei der Modulo-Positionierung beachten, dass die gewünschte Zielposition unterschiedlich interpretiert werden kann.
Die Modulo-Positionierung bezieht sich grundsätzlich auf den im CoE einstellbaren "Modulo factor" (Index 0x8040:0E). In den folgenden Beispielen wird von einer rotatorischen Achse mit einem "Modulo factor" von umgerechnet 360 Grad ausgegangen.
Das "Modulo tolerance window" (Index 0x8040:0F) definiert ein Positionsfenster um die aktuelle Modulo-Sollposition der Achse herum. Die Fensterbreite entspricht dem doppelten angegebenen Wert (Sollposition ± Toleranzwert). Auf das Toleranzfenster wird im Folgenden näher eingegangen.
Die Positionierung einer Achse bezieht sich immer auf deren aktuellen Istposition. Die Istposition der Achse ist im Normalfall die Position, die mit dem letzten Fahrauftrag angefahren wurde. Unter Umständen (fehlerhafte Positionierung durch einen Stall der Achse, oder eine sehr grobe Auflösung des angeschlossenen Enkoders) kann sich aber eine vom Anwender nicht erwartete Position einstellen. Wenn dieser Umstand nicht berücksichtigt wird, kann sich eine nachfolgende Positionierung unerwartet verhalten.
Wirkung des Modulo-Toleranzfensters - Modulo-Zielposition 0° in positiver Richtung
Beispiel:
Eine Achse wird auf 0° positioniert, wodurch die Istposition der Achse anschließend exakt 0° beträgt. Ein weiterer Modulo-Fahrauftrag auf 360° in positiver Richtung führt zu einer vollen Umdrehung und die Modulo-Position der Achse ist anschließend wieder exakt 0°.
Kommt die Achse bedingt durch die Mechanik etwas vor oder hinter der Zielposition zum Stehen, so verhält sich das nächste Fahrkommando ggf. nicht so, wie man es erwartet.
▪
Liegt die Istposition leicht unter 0° (siehe Abb. Wirkung des Modulo-Toleranzfensters - Modulo-Zielposition 0° in positiver Richtung A), so führt ein neues Fahrkommando auf 0° in positiver Richtung nur zu einer minimalen Bewegung. Die vorher entstandene Abweichung wird ausgeglichen und die Position ist anschließend wieder exakt 0°.
▪
Liegt aber die Position leicht über 0°(siehe Abb. Wirkung des Modulo-Toleranzfensters - Modulo-Zielposition 0° in positiver Richtung B), so führt dasselbe Fahrkommando zu einer vollen Umdrehung um wieder die exakte Position von 0° zu erreichen. Diese Problematik tritt auf, wenn volle Umdrehungen um 360° oder ein Vielfaches von 360° beauftragt werden. Bei Positionierungen auf einen von der aktuellen Modulo-Position entfernten Winkel ist der Fahrauftrag eindeutig.
Um das Problem zu lösen, kann ein "Modulo tolerance window" (Index 0x8040:0F) parametriert werden. Kleine Abweichungen der Position, die innerhalb des Fensters liegen, führen damit nicht mehr zu einem unterschiedlichen Verhalten der Achse. Wird beispielsweise ein Fenster von 1° parametriert, so verhält sich die Achse im oben beschriebenen Fall gleich, solange die Istposition zwischen 359° und 1° liegt.
▪
Wenn jetzt die Position weniger als 1° über 0° liegt (siehe Abb. Wirkung des Modulo-Toleranzfensters - Modulo-Zielposition 0° in positiver Richtung D), wird die Achse bei einem Modulo-Start in positiver Richtung zurückpositioniert. Bei einer Zielposition von 0° wird also in beiden Fällen eine Minimalbewegung auf exakt 0° ausgeführt und bei einer Zielposition von 360° wird in beiden Fällen eine ganze Umdrehung gefahren.
Das Modulo-Toleranzfenster kann also innerhalb des Fensters zu Bewegungen gegen die beauftragte Richtung führen. Bei einem kleinen Fenster ist das normalerweise unproblematisch, weil auch Regelabweichungen zwischen Soll- und Istposition in beide Richtungen ausgeglichen werden. Das Toleranzfenster lässt sich also auch bei Achsen verwenden, die konstruktionsbedingt nur in einer Richtung verfahren werden dürfen.
Modulo-Positionierung um weniger als eine Umdrehung
Die Modulo-Positionierung von einer Ausgangsposition auf eine nicht identische Zielposition ist eindeutig und birgt keine Besonderheiten.
▪
Eine Modulo-Zielposition im Bereich [0 ≤ Position < 360] führt in weniger als einer ganzen Umdrehung zum gewünschten Ziel.
▪
Ist die Zielposition mit der Ausgangsposition identisch, so wird keine Bewegung ausgeführt.
▪
Bei Zielpositionen ab 360 ° aufwärts werden ein oder mehr vollständige Umdrehungen ausgeführt, bevor die Achse auf die gewünschte Zielposition fährt.
Für eine Bewegung von 270° auf 0° darf demnach nicht 360°, sondern es muss 0° als Modulo-Zielposition beauftragt werden, da 360° außerhalb des Grundbereiches liegt und zu einer zusätzlichen Umdrehung führen würde.
Die Modulo-Positionierung unterscheidet drei Richtungsvorgaben, positive Richtung, negative Richtung und auf kürzestem Weg (MODULO_PLUS, MODULO_MINUS, MODULO_SHORT).
Bei der Positionierung auf kürzestem Weg sind Zielpositionen ab 360° nicht sinnvoll, da das Ziel immer direkt angefahren wird. Im Gegensatz zur positiven oder negativen Richtung können also nicht mehrere Umdrehungen ausgeführt werden, bevor das Ziel angefahren wird.
Achtung
Nur Grundperioden kleiner 360° sind erlaubt
Bei Modulo-Positionierungen mit dem Start-Typ "MODULO_SHORT" sind nur Modulo-Zielpositionen in der Grundperiode (z. B. kleiner als 360°) erlaubt, anderenfalls wird ein Fehler zurückgegeben.
Hinweis
Positionierung ohne Modulo-Toleranzfenster
Bei den "normalen" Modulo-Positionierarten wird immer das "Modulo tolerance window" (Index 0 ) berücksichtigt. In manchen Situationen ist dies aber eher unerwünscht. Um diesen "Nachteil" zu eliminieren, können die vergleichbaren Starttypen "MODULO_SHORT_EXT", "MODULO_PLUS_EXT", "MODULO_MINUS_EXT" und "MODULO_CURRENT_EXT" verwendet werden, welche das Modulo-Toleranzfenster ignorieren.
Die folgende Tabelle zeigt einige Positionierungsbeispiele:
Modulo-Starttyp | Absolute Anfangsposition | Modulo-Zielposition | Relativer Verfahrweg | absolute Endposdpition | Modulo Enosition
MODULO_PLUS | 90° | 0° | 270° | 360° | 0°
MODULO_PLUS | 90° | 360° | 630° | 720° | 0°
MODULO_PLUS | 90° | 720° | 990° | 1080° | 0°
MODULO_MINUS | 90° | 0° | -90° | 0° | 0°
MODULO_MINUS | 90° | 360° | -450° | -360° | 0°
MODULO_MINUS | 90° | 720° | -810° | -720° | 0°
MODULO_SHORT | 90° | 0° | -90° | 0° | 0°
Tab. 3: Beispiele zur Modulo-Positionierung bei weniger als einer Umdrehung
Modulo-Positionierung um ganze Umdrehungen
Modulo-Positionierungen um ein oder mehrere ganze Umdrehungen verhalten sich grundsätzlich nicht anders als Positionierungen auf von der Ausgangsposition entfernt liegende Winkel.Wenn die beauftragte Zielposition gleich der Ausgangsposition ist, so wird keine Bewegung ausgeführt.Für eine ganze Umdrehung muss zur Ausgangsposition 360° addiert werden. Das beschriebene Verhalten im Beispiel zeigt, dass Positionierungen mit ganzzahligen Umdrehungen besonders beachtet werden müssen. Die nachfolgende Tabelle zeigt Positionierbeispiele für eine Ausgangsposition von ungefähr 90°. Das Modulo-Toleranzfenster ist hier auf 1° eingestellt. Besondere Fälle, in denen die Ausgangsposition außerhalb dieses Fensters liegt, sind gekennzeichnet.
Modulo-Starttyp | Absolute Anfangsposition | Modulo-Zielposition | Relativer Verfahrweg | absolute Endposition | Modulo Endposition | Anmerkung
MODULO_PLUS | 90,00° | 90,00° | 0,00° | 90,00° | 90,00° |
MODULO_PLUS | 90,90° | 90,00° | -0,90° | 90,00° | 90,00° |
MODULO_PLUS | 91,10° | 90,00° | 358,90° | 450,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 90,00° | 0,90° | 90,00° | 90,00° |
MODULO_PLUS | 88,90° | 90,00° | 1,10° | 90,00° | 90,00° | außerhalb TF
MODULO_PLUS | 90,00° | 450,00 | 360,00° | 450,00° | 90,00° |
MODULO_PLUS | 90,90° | 450,00° | 359,10° | 450,00° | 90,00° |
MODULO_PLUS | 91,10° | 450,00° | 718,90° | 810,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 450,00° | 360,90° | 450,00° | 90,00° |
MODULO_PLUS | 88,90° | 450,00° | 361,10° | 450,00° | 90,00° | außerhalb TF
MODULO_PLUS | 90,00° | 810,00 | 720,00° | 810,00° | 90,00° |
MODULO_PLUS | 90,90° | 810,00 | 719,10° | 810,00° | 90,00° |
MODULO_PLUS | 91,10° | 810,00 | 1078,90° | 1170,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 810,00 | 720,90° | 810,00° | 90,00° |
MODULO_PLUS | 88,90° | 810,00 | 721,10° | 810,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 90,00° | 0,00° | 90,00° | 90,00° |
MODULO_MINUS | 90,90° | 90,00° | -0,90° | 90,00° | 90,00° |
MODULO_MINUS | 91,10° | 90,00° | -1,10° | 90,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 90,00° | 0,90° | 90,00° | 90,00° |
MODULO_MINUS | 88,90° | 90,00° | -358,90° | -270,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 450,00° | -360,00° | -270,00° | 90,00° |
MODULO_MINUS | 90,90° | 450,00° | -360,90° | -270,00° | 90,00° |
MODULO_MINUS | 91,10° | 450,00° | -361,10° | -270,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 450,00° | -359,10° | -270,00° | 90,00° |
MODULO_MINUS | 88,90° | 450,00° | -718,90° | -630,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 810,00° | -720,00° | -630,00° | 90,00° |
MODULO_MINUS | 90,90° | 810,00° | -720,90° | -630,00° | 90,00° |
MODULO_MINUS | 91,10° | 810,00° | -721,10° | -630,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 810,00° | -719,10° | -630,00° | 90,00° |
MODULO_MINUS | 88,90° | 810,00° | -1078,90° | -990,00° | 90,00° | außerhalb TF
Tab. 4: Beispiele zur Modulo-Positionierung bei ganzen Umdrehungen
Beispiele von zwei Fahraufträgen mit dynamischer Änderung der Zielposition
Ohne Überfahren der Zielposition
Zeitpunkt | POS Outputs | POS Inputs | Beschreibung
t1: | Execute = 1 Target position = 200000 Velocity = 2000 Start type = 0x0001 Acceleration = 1000 Deceleration = 1000 | Busy = 1 Accelerate = 1 | - Vorgabe der ersten Parameter - Beginn der Beschleunigungsphase
t2: |  | Accelerate = 0 | - Ende der Beschleunigungsphase
t3: | Target position = 100000 Velocity = 1500 Start type = 0x1001 Acceleration = 2000 Deceleration = 2000 |  | - Änderung der Parameter - Aktivierung durch neuen Starttypen
t4: |  | Decelerate = 1 | - Beginn der Verzögerungsphase
t5: | Execute = 0 | Busy = 0 In-Target = 1 Decelerate = 0 | - Ende der Verzögerungsphase - Motor ist auf neuer Zielposition
t6 - t9: |  |  | - Absolute Fahrt zurück auf die Startposition 0
Scope-Aufnahme eines Fahrauftrages mit dynamischer Änderung der Zielposition, ohne Überfahren der Zielposition
(Die Achsen-Skalierung bezieht sich nur auf die Positionen, nicht auf die Geschwindigkeit und die Status-Bits)
Mit Überfahren der Zielposition
Zeitpunkt | POS Outputs | POS Inputs | Beschreibung
t1: | Execute = 1 Target position = 200000 Velocity = 5000 Start type = 0x0001 Acceleration = 3000 Deceleration = 5000 | Busy = 1 Accelerate = 1 | - Vorgabe der 1. Parameter - Beginn der 1. Beschleunigungsphase
t2: |  | Accelerate = 0 | - Ende der 1. Beschleunigungsphase
t3: | Target position = 100000 Velocity = 1500 Start type = 0x1001 Acceleration = 1000 Deceleration = 2000 | Warning = 1 Decelerate = 1 | - Änderung der Parameter - Aktivierung durch neuen Starttypen - Warnung vor dem Überfahren der Zielposition - Beginn der 1. Verzögerungsphase
t4: |  | Accelerate = 1 Decelerate = 0 | - Ende der 1. Verzögerungsphase - Beginn der 2. Beschleunigungsphase in Gegenrichtung
t5: |  | Accelerate = 0 Decelerate = 1 | - Ende der 2. Beschleunigungsphase - Beginn der 2. Verzögerungsphase
t6: | Execute = 0 | Busy = 0 In-Target = 1 Decelerate = 0 | - Ende der 2.Verzögerungsphase - Motor ist auf neuer Zielposition
t7 - t10: |  |  | - Absolute Fahrt zurück auf die Startposition 0
Scope-Aufnahme eines Fahrauftrages mit dynamischer Änderung der Zielposition, mit Überfahren der endgültigen Zielposition
(Die Achsen-Skalierung bezieht sich nur auf die Positionen, nicht auf die Geschwindigkeit und die Status-Bits)


Beispiele Inbetriebnahme

Inbetriebnahme [image] Beispiele Inbetriebnahme
Beispiele Inbetriebnahme
Weiterführende Informationen
•
EL73x2 - Anwendungsbeispiel Chopperbetrieb
•
Programmbeispiel Motoransteuerung mit Visualisierung


EL73x2 - Anwendungsbeispiel Chopperbetrieb

Inbetriebnahme [image] Beispiele Inbetriebnahme [image] EL73x2 - Anwendungsbeispiel Chopperbetrieb
EL73x2 - Anwendungsbeispiel Chopperbetrieb
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Bremswiderstand
Der an Kanal 2 der zweiten EL7342 angeschlossene Bremswiderstand verheizt die Bremsenergie der an den anderen drei Kanälen angeschlossenen Motoren.
Anschlussbeispiel Bremswiderstand
Achtung
Auslegung des Bremswiderstands
Der Bremswiderstand sollte so dimensioniert werden, dass er die zu erwartende Wärmeentwicklung schadlos übersteht (siehe auch Kapitel Chopper-Betrieb)!


Programmbeispiel Motoransteuerung mit Visualisierung

Inbetriebnahme [image] Beispiele Inbetriebnahme [image] Programmbeispiel Motoransteuerung mit Visualisierung
Programmbeispiel Motoransteuerung mit Visualisierung
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Download ( )
Verwendeter Master: TwinCAT 2.11 (bei älteren Versionen muss der Regelkreis manuell programmiert werden, der in diesem Fall bereits in der NC implementiert ist).
Mit diesem Anwendungsbeispiel lässt sich ein Motor mit Hilfe der Visualisierung in eine beliebige Position fahren oder im Endlosmodus betreiben. Dabei kann die Geschwindigkeit, die Anfahrbeschleunigung und die Bremsbeschleunigung festgelegt werden.
Das Beispielprogramm besteht aus 2 Dateien. Zum einen die PLC-Datei und zum anderen die System Manager-Datei.
Öffnen Sie zunächst die PLC-Datei und kompilieren Sie die Datei, damit Sie für den System Manager die .tpy-Datei zur Verfügung haben.
Beachten Sie, dass Sie im PLC-Programm gegebenenfalls die Zielplattform anpassen müssen (default: PC oder CX 8x86). Sollten Sie das ändern müssen, können Sie unter der Registerkarte Ressourcen -> Steuerungskonfiguration die richtige Zielplattform auswählen.
Auswahl der Zielplatform
Bei der System Manager-Datei muss folgendes beachtet werden:
▪
Starten Sie den System Manager im Konfig Modus.
▪
Stellen Sie sicher, dass die E/A-Konfiguration mit Ihrer tatsächlichen Konfiguration übereinstimmt. Im Beispielprogramm ist nur eine EL7342 integriert. Wenn Sie weitere Klemmen angeschlossen haben, müssen Sie diese zusätzlich einfügen oder Ihre Konfiguration neu einscannen.
▪
Sie müssen die MAC-Adresse anpassen. Klicken Sie dazu auf Ihr EtherCAT-Gerät, anschließend wählen Sie die Registerkarte Adapter und klicken hinter der MAC-Adresse auf Suchen (siehe Abb. Auswahl Adapter ). Dort wählen Sie den richtigen Adapter aus.
Auswahl Adapter
▪
Bei der SPS-Konfiguration muss der Pfad des SPS-Programms angepasst werden. Klicken Sie dazu auf das angefügte SPS-Programm und wählen Sie die Registerkarte IEC1131 aus (siehe Abb. Änderung Pfad SPS-Programm ). Dort müssen Sie Ändern anwählen und den richtigen Pfad bestimmen.
Änderung Pfad SPS-Programm
▪
Unter NC-Konfiguration ist bereits eine EL7041 mit der NC verknüpft. Sollten Sie diese neu verknüpfen müssen oder zusätzliche hinzufügen wollen, dann gehen Sie bitte wie im Kapitel "Einbindung in die NC-Konfiguration" vor.
Das PLC-Programm setzt sich wie folgt zusammen. Die Bibliotheken TcMC.lib und TcNC.lib müssen eingebunden werden (siehe Abb. Erforderliche Bibliotheken).
Erforderliche Bibliotheken
Anschließend werden einige globale Variablen deklariert (siehe Abb. Globale Variablen). Die Datentypen PLCTONC_AXLESTRUCT und NCTOPLC_AXLESTRUCT sorgen für die Kommunikation zwischen der PLC und der NC.
Globale Variablen
Nachdem die globalen Variablen deklariert worden sind, können Sie mit der Programmierung starten. Dazu deklarieren Sie vorerst die lokalen Variablen (siehe Abb. Lokale Variablen).
MC_Direction ist ein Aufzählungstyp, der dem Baustein MC_MoveVelocity die Bewegungsrichtung vorgibt, der wiederum eine Endlosfahrt des Motors durchführt.
Mit dem Funktionsbaustein MC_Reset wird ein Reset der Achse durchgeführt. MC_MoveAbsolute ist ein Funktionsbaustein mit dem eine absolute Positionierung durchgeführt wird. Mit dem Funktionsbaustein MC_ReadActualPosition kann die aktuelle Position der Achse gelesen werden.
MC_Power gibt die Achse frei und MC_Stop wird für das Stoppen der Achse benötigt.
Lokale Variablen
Das Programm kann dann wie folgt programmiert werden (siehe Abb. Programmcode):
Programmcode
Mit Hilfe der folgenden Visualisierung (siehe Abb. Visualisierung) kann der Motor anschließend betrieben werden.
Bitte betätigen Sie den Taster Enable, um die Freigaben für die Achse zu setzen. Nun haben Sie die Wahl. Sie können im free run mode den Taster Left oder Right betätigen und der Motor dreht sich mit einer im fbMoveVelocity_Axis_1 definierten Geschwindigkeit, in die ausgewählte Richtung. Oder Sie können im Absolute mode Geschwindigkeit, Beschleunigung, Bremsbeschleunigung und die anzufahrende Position angeben und mit Start Job die Fahrt starten. Wenn Sie bei der Beschleunigung und der Bremsbeschleunigung nichts angeben, wird der Default-Wert der NC benutzt.
Visualisierung
Hinweis
Informationen zu Funktionsbausteinen und Datentypen
Weitere Informationen zu den verwendeten Funktionsbausteinen und Datentypen erhalten Sie im aktuellen Beckhoff Information System.


EL7332- Objektbeschreibung und Parametrierung

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung
EL7332- Objektbeschreibung und Parametrierung
Weiterführende Informationen
•
Hinweis zur CoE-Objekte Kompatibilität
•
bis Firmware 05 / Revisionstand -0019
•
ab Firmware 06 /Revisionstand -0020


Hinweis zur CoE-Objekte Kompatibilität

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] Hinweis zur CoE-Objekte Kompatibilität
Hinweis zur CoE-Objekte Kompatibilität
Hinweis
CoE Objekte bei unterschiedlichen Hardware/Software-Ständen
Auf Grund der kontinuierlichen Weiterentwicklung der EL7332 abhängig von Firm- und Hardware, sowie dem Revisionstand ist folgendes zu beachten:
► Objektverzeichnis gültig bis Firmware 05 / Revisionstand -0019
► Objektverzeichnis gültig ab Firmware 06 / Revisionstand -0020
Die Klemmen mit dem neueren Firmware/Revisionstand sind abwärtskompatibel, d.h. es kann eine "neue" Klemme mit einer "alten" TwinCAT-Konfiguration betrieben werden; es wird intern auf das neue Objektverzeichnis gemappt.


bis Firmware 05 / Revisionstand -0019

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019
bis Firmware 05 / Revisionstand -0019
Hinweis
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind:
–
Restore Objekt
–
Konfigurationsdaten
–
Kommando-Objekt
▪
Profilspezifische Objekte:
–
Eingangsdaten
–
Ausgangsdaten
–
Informations- und Diagnostikdaten (kanalspezifisch)
–
Konfigurationsdaten (herstellerspezifisch)
–
Informations- und Diagnostikdaten (gerätespezifisch)
▪
Standardobjekte
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando - Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten (kanalspezifisch)
•
Konfigurationsdaten (herstellerspezifisch)
•
Informations- und Diagnostikdaten (gerätespezifisch)
•
Standardobjekte


Restore Objekt

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Konfigurationsdaten
Konfigurationsdaten
Index 8020 DCM Motor Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | DCM Motor Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8020:01 | Maximal current | Maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x0960 (2400dez)
8020:02 | Nominal current | Nennstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x05DC (1500dez)
8020:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0x5DC0 (24000dez)
8020:04 | Motor coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8020:05 | Reduced current (positive) | Reduziertes Drehmoment in positiver Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8020:06 | Reduced current (negative) | Reduziertes Drehmoment in negativer Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8020:0C | Time for switch-off at overload | Zeit für Überlastabschaltung (Einheit: 1 ms) | UINT16 | RW | 0x00C8 (200dez)
8020:0D | Time for current lowering at overload | Zeit für Stromreduzierung bei Überlast (von maximalem Strom bis Nennstrom, Einheit: 1 ms) | UINT16 | RW | 0x07D0 (2000dez)
8020:0E | Torque auto-reduction threshold (positive) | Prozessdatenschwelle für automatische Drehmomentreduzierung in positiver Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8020:0F | Torque auto-reduction threshold (negative) | Prozessdatenschwelle für automatische Drehmomentreduzierung in negativer Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
Index 8021 DCM Controller Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8021:0 | DCM Controller Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
8021:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x00C8 (200dez)
8021:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0002 (2dez)
8021:03 | Inner window (curr.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8021:05 | Outer window (curr.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8021:06 | Filter cut off frequency (curr.) | Grenzfrequenz des Stromreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8021:11 | Voltage adjustment enable | Aktiviert die Kompensation von Spannungsschwankungen (nur in der Betriebsart "Direct velocity") | BOOLEAN | RW | 0x00 (0dez)
8021:12 | Current adjustment enable | Aktiviert die R x I Kompensation | BOOLEAN | RW | 0x00 (0dez)
Index 8022 DCM Features Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8022:0 | DCM Features Ch.1 | Max. Subindex | UINT8 | RO | 0x3E (62dez)
8022:01 | Operation mode | Betriebsart: 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller 4 – 14: reserviert 15: Chopper resistor Vorhandene Überspannung (10 % > Nennspannung 0x8020:03) wird über angeschlossenen Chopper-Widerstand abgebaut. | BIT4 | RW | 0x00 (0dez)
8022:09 | Invert motor polarity | Invertierung der Motordrehrichtung | BOOLEAN | RW | 0x00 (0dez)
8022:0A | Torque error enable | Aktiviert die automatische Überlastabschaltung (siehe auch Subindex 0x8020:0C) | BOOLEAN | RW | 0x00 (0dez)
8022:0B | Torque auto reduce | Aktiviert die automatische Drehmomentreduzierung (siehe auch Subindex 0x8020:0D – 0x8020:0F) | BOOLEAN | RW | 0x00 (0dez)
8022:11 | Select info data 1 | Auswahl "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle 6: reserviert 7: Motor velocity 8: Overload time 9 – 100: reserviert 101: Internal temperature 102: reserviert 103: Control voltage 104: Motor supply voltage 105 – 149: reserviert 150: Status word (drive controller) 151: State (drive controller) …: reserviert | UINT8 | RW | 0x01 (1dez)
8022:19 | Select info data 2 | Auswahl "Info data 2" siehe Subindex 0x8022:11 | UINT8 | RW | 0x02 (2dez)
8022:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 | BOOLEAN | RW | 0x00 (0dez)
8022:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 | BOOLEAN | RW | 0x00 (0dez)
8022:32 | Function for input 1 | Funktion des digitalen Eingangs 1 0: Normal input 1: Hardware enable …:reserviert | BIT4 | RW | 0x00 (0dez)
8022:36 | Function for input 2 | Funktion des digitalen Eingangs 2 siehe Subindex 0x8022:32 | BIT4 | RW | 0x00 (0dez)
Index 8030 DCM Motor Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8030:0 | DCM Motor Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8030:01 | Maximal current | Maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x0960 (2400dez)
8030:02 | Nominal current | Nennstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x05DC (1500dez)
8030:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0x5DC0 (24000dez)
8030:04 | Motor coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8030:05 | Reduced current (positive) | Reduziertes Drehmoment in positiver Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8030:06 | Reduced current (negative) | Reduziertes Drehmoment in negativer Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8030:0C | Time for switch-off at overload | Zeit für Überlastabschaltung (Einheit: 1 ms) | UINT16 | RW | 0x00C8 (200dez)
8030:0D | Time for current lowering at overload | Zeit für Stromreduzierung bei Überlast (von maximalem Strom bis Nennstrom, Einheit: 1 ms) | UINT16 | RW | 0x07D0 (2000dez)
8030:0E | Torque auto-reduction threshold (positive) | Prozessdatenschwelle für automatische Drehmomentreduzierung in positiver Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8030:0F | Torque auto-reduction threshold (negative) | Prozessdatenschwelle für automatische Drehmomentreduzierung in negativer Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
Index 8031 DCM Controller Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8031:0 | DCM Controller Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
8031:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x00C8 (200dez)
8031:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0002 (2dez)
8031:03 | Inner window (curr.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8031:05 | Outer window (curr.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8031:06 | Filter cut off frequency (curr.) | Grenzfrequenz des Stromreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8031:11 | Voltage adjustment enable | Aktiviert die Kompensation von Spannungsschwankungen (nur in der Betriebsart "Direct velocity") | BOOLEAN | RW | 0x00 (0dez)
8031:12 | Current adjustment enable | Aktiviert die R x I Kompensation | BOOLEAN | RW | 0x00 (0dez)
Index 8032 DCM Features Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8032:0 | DCM Features Ch.1 | Max. Subindex | UINT8 | RO | 0x3E (62dez)
8032:01 | Operation mode | Betriebsart 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller 4 – 14: reserviert 15: Chopper resistor Vorhandene Überspannung (10 % > Nennspannung 0x8030:03) wird über angeschlossenen Chopper-Widerstand abgebaut. | BIT4 | RW | 0x00 (0dez)
8032:09 | Invert motor polarity | Invertierung der Motordrehrichtung | BOOLEAN | RW | 0x00 (0dez)
8032:0A | Torque error enable | Aktiviert die automatische Überlastabschaltung (siehe auch Subindex 0x8030:0C) | BOOLEAN | RW | 0x00 (0dez)
8032:0B | Torque auto reduce | Aktiviert die automatische Drehmomentreduzierung (siehe auch Subindex 0x8030:0D – 0x8030:0F) | BOOLEAN | RW | 0x00 (0dez)
8032:11 | Select info data 1 | Auswahl "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle 6: reserviert 7: Motor velocity 8: Overload time 9 – 100: reserviert 101: Internal temperature 102: reserviert 103: Control voltage 104: Motor supply voltage 105 – 149: reserviert 150: Status word (drive controller) 151: State (drive controller) …: reserviert | UINT8 | RW | 0x01 (1dez)
8032:19 | Select info data 2 | Auswahl "Info data 2" siehe Subindex 0x8032:11 | UINT8 | RW | 0x02 (2dez)
8032:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 | BOOLEAN | RW | 0x00 (0dez)
8032:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 | BOOLEAN | RW | 0x00 (0dez)
8032:32 | Function for input 1 | Funktion des digitalen Eingangs 1 Funktion des digitalen Eingangs 1 0: Normal input 1: Hardware enable …:reserviert | BIT4 | RW | 0x00 (0dez)
8032:36 | Function for input 2 | Funktion des digitalen Eingangs 2 siehe Subindex 0x8032:32 | BIT4 | RW | 0x00 (0dez)


Kommando - Objekt

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Kommando - Objekt
Kommando - Objekt
Index FB00 DCM Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | DCM Command | Max. Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x1000 Clear diag history: löscht die Diag History | OCTET-STRING[2] | RW | {0}
 |  | 0x1100 Get build number: Auslesen der Build-Nummer
 |  | 0x1101 Get build date: Auslesen des Build-Datums
 |  | 0x1102 Get build time: Auslesen der Build-Zeit
 |  | 0x8000 oftware reset: Software-Reset durchführen (Hardware wird mit der Aktuellen CoE-Konfiguration neu Initialisiert, geschieht sonst nur beim Übergang nach INIT)
FB00:02 | Status | 0: Finished, no error, no response Kommando ohne Fehler und ohne Antwort (Response ) beendet | UINT8 | RO | 0x00 (0dez)
 |  | 1: Finished, no error, response Kommando ohne Fehler und mit Antwort beendet
 |  | 2: Finished, error, no response Kommando mit Fehler und ohne Antwort beendet
 |  | 3: Finished, error, response Kommando mit Fehler und mit Antwort beendet
 |  | 255: Executing Kommando wird ausgeführt
FB00:03 | Response | abhängig vom Request | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Eingangsdaten
Eingangsdaten
Index 6000 DCM Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | DCM Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6000:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Warning | Eine Warnung ist aufgetreten (siehe Index 0xA000) | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Error | Ein Fehler ist aufgetreten (siehe Index 0xA000) | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Torque reduced | Reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6000:0C | Digital input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Digital input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob im abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8022:11) | UINT16 | RO | 0x0000 (0dez)
6000:12 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8022:19) | UINT16 | RO | 0x0000 (0dez)
Index 6010 DCM Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | DCM Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6010:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Warning | Eine Warnung ist aufgetreten (siehe Index 0xA010) | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Error | Ein Fehler ist aufgetreten (siehe Index 0xA010) | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Torque reduced | Reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Digital input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Digital input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob im abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8032:11) | UINT16 | RO | 0x0000 (0dez)
6010:12 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8032:19) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Ausgangsdaten
Ausgangsdaten
Index 7000 DCM Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | DCM Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x21 (33dez)
7000:01 | Enable | Aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Reset | Alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke). | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Reduce torque | Reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8020:05 / 0x8020:06) | BOOLEAN | RO | 0x00 (0dez)
7000:21 | Velocity | Vorgabe der Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7010 DCM Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | DCM Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x21 (33dez)
7010:01 | Enable | Aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Reset | Alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke). | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Reduce torque | Reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8030:05 / 0x8030:06) | BOOLEAN | RO | 0x00 (0dez)
7010:21 | Velocity | Vorgabe der Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)


Informations- und Diagnostikdaten (kanalspezifisch)

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Informations- und Diagnostikdaten (kanalspezifisch)
Informations- und Diagnostikdaten (kanalspezifisch)
Index 9000 DCM Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9000:0 | DCM Info data Ch.1 | Max. Subindex | UINT8 | RO | 0x09 (9dez)
9000:01 | Status word | Statuswort (siehe Index App0) | UINT16 | RO | 0x0000 (0dez)
9000:02 | Motor coil voltage | Aktuelle Spulenspannung | UINT16 | RO | 0x0000 (0dez)
9000:03 | Motor coil current | Aktueller Spulenstrom | INT16 | RO | 0x0000 (0dez)
9000:04 | Current limit | Aktuelle Strombegrenzung | UINT16 | RO | 0x0000 (0dez)
9000:05 | Control error | Aktueller Regelfehler | INT16 | RO | 0x0000 (0dez)
9000:06 | Duty cycle | Aktueller Duty-Cycle | INT8 | RO | 0x00 (0dez)
9000:09 | Overload time | Zeit seit Überlastung | UINT16 | RO | 0x0000 (0dez)
Index 9010 DCM Info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | DCM Info data Ch.2 | Max. Subindex | UINT8 | RO | 0x09 (9dez)
9010:01 | Status word | Statuswort (siehe Index App0) | UINT16 | RO | 0x0000 (0dez)
9010:02 | Motor coil voltage | Aktuelle Spulenspannung | UINT16 | RO | 0x0000 (0dez)
9010:03 | Motor coil current | Aktueller Spulenstrom | INT16 | RO | 0x0000 (0dez)
9010:04 | Current limit | Aktuelle Strombegrenzung | UINT16 | RO | 0x0000 (0dez)
9010:05 | Control error | Aktueller Regelfehler | INT16 | RO | 0x0000 (0dez)
9010:06 | Duty cycle | Aktueller Duty-Cycle | INT8 | RO | 0x00 (0dez)
9010:09 | Overload time | Zeit seit Überlastung | UINT16 | RO | 0x0000 (0dez)
Index A000 DCM Diag data Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
A000:0 | DCM Diag data Ch.1 | Max. Subindex |  | UINT8 | RO | 0x11 (17dez)
A000:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | Warnung | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | Warnung | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Torque overload | Aktueller Motorstrom ist größer als der Nennstrom (siehe 0x8020:02) | Warnung (0x8pp2:0A = 0) / Fehler (0x8pp2:0A = 1) | BOOLEAN | RO | 0x00 (0dez)
A000:04 | Under voltage | Versorgungsspannung kleiner als 7 V | Fehler | BOOLEAN | RO | 0x00 (0dez)
A000:05 | Over voltage | Versorgungsspannung 10 % größer, als die Nennspannung (siehe 0x8020:03) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A000:06 | Short circuit | Kurzschluss der Treiberstufe | Fehler | BOOLEAN | RO | 0x00 (0dez)
A000:08 | No control power | Treiberstufe ohne Spannungsversorgung | Fehler | BOOLEAN | RO | 0x00 (0dez)
A000:09 | Misc error | - Initialisierung fehlgeschlagen oder - Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05) oder - Motorstrom ist größer als der Nennstrom (siehe 0x8022:0A) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A000:11 | Actual operation mode | Aktuelle Betriebsart (bei automatischer Betriebsarterkennung, siehe 0x8022:01) |  | BIT4 | RO | 0x00 (0dez)
Index A010 DCM Diag data Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
A010:0 | DCM Diag data Ch.2 | Max. Subindex |  | UINT8 | RO | 0x11 (17dez)
A010:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | Warnung | BOOLEAN | RO | 0x00 (0dez)
A010:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | Warnung | BOOLEAN | RO | 0x00 (0dez)
A010:03 | Torque overload | Aktueller Motorstrom ist größer als der Nennstrom (siehe 8030:02) | Warnung (0x8032:0A = 0) / Fehler (0x8032:0A = 1) | BOOLEAN | RO | 0x00 (0dez)
A010:04 | Under voltage | Versorgungsspannung kleiner als 7 V | Fehler | BOOLEAN | RO | 0x00 (0dez)
A010:05 | Over voltage | Versorgungsspannung 10 % größer, als die Nennspannung (siehe 0x8030:03) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A010:06 | Short circuit | Kurzschluss der Treiberstufe | Fehler | BOOLEAN | RO | 0x00 (0dez)
A010:08 | No control power | Treiberstufe ohne Spannungsversorgung | Fehler | BOOLEAN | RO | 0x00 (0dez)
A010:09 | Misc error | - Initialisierung fehlgeschlagen oder - Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05) oder - Motorstrom ist größer als der Nennstrom (siehe 0x8032:0A) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A010:11 | Actual operation mode | Aktuelle Betriebsart (bei automatischer Betriebsarterkennung, siehe 0x8032:01) |  | BIT4 | RO | 0x00 (0dez)


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index F80F DCM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | DCM Vendor data | Max. Subindex | UINT8 | RO | 0x06 (6dez)
F80F:01 | PWM Frequency | Zwischenkreisfrequenz (Einheit: 1 Hz) | UINT16 | RW | 0x7530 (30000dez)
F80F:02 | Deadtime | Totzeit der Pulsweitenmodulation | UINT16 | RW | 0x0505 (1285dez)
F80F:03 | Deadtime space | Duty Cycle Begrenzung | UINT16 | RW | 0x0009 (9dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung (Einheit: 1 °C) | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur (Einheit: 1 °C) | INT8 | RW | 0x64 (100dez)
F80F:06 | Analog trigger point | Triggerpunkt der AD-Wandlung | UINT16 | RW | 0x000A (10dez)


Informations- und Diagnostikdaten (gerätespezifisch)

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Informations- und Diagnostikdaten (gerätespezifisch)
Informations- und Diagnostikdaten (gerätespezifisch)
Index F900 DCM Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DCM Info data | Max. Subindex | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Softwareversion der Treiberkarte | STRING | RO |
F900:02 | Internal temperature | Interne Klemmentemperatur (Einheit: 1 °C) | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage | Steuerspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage | Lastspannung (Einheit: mV) | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time | gemessene Zykluszeit (Einheit: 1 µs) | UINT16 | RO | 0x0000 (0dez)


Standardobjekte

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] bis Firmware 05 / Revisionstand -0019 [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x02DD1389 (48042889dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL7332
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1CA43052 (480522322dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1401 DCM RxPDO-Par Velocity Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | DCM RxPDO-Par Velocity Ch.1 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 05 16 0A 16 0B 16
Index 1403 DCM RxPDO-Par Velocity Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | DCM RxPDO-Par Velocity Ch.2 | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 07 16 0C 16 0D 16
Index 1600 DCM RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DCM RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x05 (5dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 DCM RxPDO-Map Velocity Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DCM RxPDO-Map Velocity Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7000:21, 16
Index 1602 DCM RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | DCM RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x05 (5dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1603 DCM RxPDO-Map Velocity Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | DCM RxPDO-Map Velocity Ch.2 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1A00 DCM TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DCM TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0E (14dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6000:0C, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6000:0D, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 1A01 DCM TxPDO-Map Synchron info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DCM TxPDO-Map Synchron info data Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x02 (2dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6000:11, 16
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6000:12, 16
Index 1A02 DCM TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | DCM TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0E (14dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6010:0C, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6010:0D, 1
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1802, entry 0x09) | UINT32 | RO | 0x1802:09, 1
Index 1A03 DCM TxPDO-Map Synchron info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | DCM TxPDO-Map Synchron info data Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x02 (2dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x04 (4dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1603 (5635dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0001E848 (125000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 1C32:05
UINT32
RO
0x0001E848 (125000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | Profil Nummer des DC Motor Interface | UINT32 | RW | 0x000002DD (733dez)
F010:02 | SubIndex 002 | Profil Nummer des DC Motor Interface | UINT32 | RW | 0x000002DD (733dez)


ab Firmware 06 /Revisionstand -0020

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020
ab Firmware 06 /Revisionstand -0020
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Hinweis
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind:
–
Restore Objekt
–
Konfigurationsdaten
▪
Profilspezifische Objekte:
–
Eingangsdaten
–
Ausgangsdaten
–
Informations- und Diagnostikdaten (kanalspezifisch)
–
Konfigurationsdaten (herstellerspezifisch)
–
Informations- und Diagnostikdaten (gerätespezifisch)
▪
Standardobjekte
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando - Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten (kanalspezifisch)
•
Konfigurationsdaten (herstellerspezifisch)
•
Informations- und Diagnostikdaten (gerätespezifisch)
•
Standardobjekte


Restore Objekt

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Konfigurationsdaten
Konfigurationsdaten
Index 8020 DCM Motor Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | DCM Motor Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8020:01 | Maximal current | Maximaler, dauerhafter Spulenstrom des Motors (Einheit:1 mA) | UINT16 | RW | 0x0960 (2400dez)
8020:02 | Nominal current | Nennstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x05DC (1500dez)
8020:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0x5DC0 (24000dez)
8020:04 | Motor coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8020:05 | Reduced current (positive) | Reduziertes Drehmoment in positiver Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8020:06 | Reduced current (negative) | Reduziertes Drehmoment in negativer Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8020:0C | Time for switch-off at overload | Zeit für Überlastabschaltung (Einheit: 1 ms) | UINT16 | RW | 0x00C8 (200dez)
8020:0D | Time for current lowering at overload | Zeit für Stromreduzierung bei Überlast (von maximalem Strom bis Nennstrom, Einheit: 1 ms) | UINT16 | RW | 0x07D0 (2000dez)
8020:0E | Torque auto-reduction threshold (positive) | Prozessdatenschwelle für automatische Drehmomentreduzierung in positiver Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8020:0F | Torque auto-reduction threshold (negative) | Prozessdatenschwelle für automatische Drehmomentreduzierung in negativer Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
Index 8021 DCM Controller Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8021:0 | DCM Controller Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
8021:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x00C8 (200dez)
8021:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0002 (2dez)
8021:03 | Inner window (curr.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8021:05 | Outer window (curr.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8021:06 | Filter cut off frequency (curr.) | Grenzfrequenz des Stromreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8021:11 | Voltage adjustment enable | Aktiviert die Kompensation von Spannungsschwankungen (nur in der Betriebsart "Direct velocity") | BOOLEAN | RW | 0x00 (0dez)
8021:12 | Current adjustment enable | Aktiviert die R x I Kompensation | BOOLEAN | RW | 0x00 (0dez)
Index 8022 DCM Features Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8022:0 | DCM Features Ch.1 | Max. Subindex | UINT8 | RO | 0x36 (54dez)
8022:01 | Operation mode | Betriebsart 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller …: reserviert 15: Chopper resistor Vorhandene Überspannung (10 % > Nennspannung 0x8020:03) wird über angeschlossenen Chopper-Widerstand abgebaut. | BIT4 | RW | 0x00 (0dez)
8022:09 | Invert motor polarity | Invertierung der Motordrehrichtung | BOOLEAN | RW | 0x00 (0dez)
8022:0A | Torque error enable | Aktiviert die automatische Überlastabschaltung (siehe auch Subindex 0x8020:0C) | BOOLEAN | RW | 0x00 (0dez)
8022:0B | Torque auto reduce | Aktiviert die automatische Drehmomentreduzierung (siehe auch Subindex 0x8020:0D – 0x8020:0F) | BOOLEAN | RW | 0x00 (0dez)
8022:11 | Select info data 1 | Auswahl "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle ....: reserviert 7: Motor velocity 8: Overload time ...: reserviert 101: Internal temperature ...: reserviert 103: Control voltage 104: Motor supply voltage ...: reserviert 150: Status word (drive controller) 151: State (drive controller) ...: reserviert | UINT8 | RW | 0x01 (1dez)
8022:19 | Select info data 2 | Auswahl "Info data 2" siehe Subindex 0x8022:11 | UINT8 | RW | 0x02 (2dez)
8022:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 | BOOLEAN | RW | 0x00 (0dez)
8022:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 | BOOLEAN | RW | 0x00 (0dez)
8022:32 | Function for input 1 | Funktion des digitalen Eingangs 1 0: Normal input 1: Hardware enable …: reserviert | BIT4 | RW | 0x00 (0dez)
8022:36 | Function for input 2 | Funktion des digitalen Eingangs 2 siehe Subindex 0x8022:32 | BIT4 | RW | 0x00 (0dez)
Index 8030 DCM Motor Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8030:0 | DCM Motor Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8030:01 | Maximal current | Maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x0960 (2400dez)
8030:02 | Nominal current | Nennstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x05DC (1500dez)
8030:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0x5DC0 (24000dez)
8030:04 | Motor coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8030:05 | Reduced current (positive) | Reduziertes Drehmoment in positiver Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8030:06 | Reduced current (negative) | Reduziertes Drehmoment in negativer Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x01F4 (500dez)
8030:0C | Time for switch-off at overload | Zeit für Überlastabschaltung (Einheit: 1 ms) | UINT16 | RW | 0x00C8 (200dez)
8030:0D | Time for current lowering at overload | Zeit für Stromreduzierung bei Überlast (von maximalem Strom bis Nennstrom, Einheit: 1 ms) | UINT16 | RW | 0x07D0 (2000dez)
8030:0E | Torque auto-reduction threshold (positive) | Prozessdatenschwelle für automatische Drehmomentreduzierung in positiver Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8030:0F | Torque auto-reduction threshold (negative) | Prozessdatenschwelle für automatische Drehmomentreduzierung in negativer Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
Index 8031 DCM Controller Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8031:0 | DCM Controller Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
8031:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x00C8 (200dez)
8031:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0002 (2dez)
8031:03 | Inner window (curr.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8031:05 | Outer window (curr.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8031:06 | Filter cut off frequency (curr.) | Grenzfrequenz des Stromreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8031:11 | Voltage adjustment enable | Aktiviert die Kompensation von Spannungsschwankungen (nur in der Betriebsart "Direct velocity") | BOOLEAN | RW | 0x00 (0dez)
8031:12 | Current adjustment enable | Aktiviert die R x I Kompensation | BOOLEAN | RW | 0x00 (0dez)
Index 8032 DCM Features Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8032:0 | DCM Features Ch.1 | Max. Subindex | UINT8 | RO | 0x36 (54dez)
8032:01 | Operation mode | Betriebsart 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller …: reserviert 15: Chopper resistor Vorhandene Überspannung (10 % > Nennspannung 8030:03) wird über angeschlossenen Chopper-Widerstand abgebaut. | BIT4 | RW | 0x00 (0dez)
8032:09 | Invert motor polarity | Invertierung der Motordrehrichtung | BOOLEAN | RW | 0x00 (0dez)
8032:0A | Torque error enable | Aktiviert die automatische Überlastabschaltung (siehe auch Subindex 0x8030:0C) | BOOLEAN | RW | 0x00 (0dez)
8032:0B | Torque auto reduce | Aktiviert die automatische Drehmomentreduzierung (siehe auch Subindex 0x8030:0D – 0x8030:0F) | BOOLEAN | RW | 0x00 (0dez)
8032:11 | Select info data 1 | Auswahl "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle ....: reserviert 7: Motor velocity 8: Overload time ...: reserviert 101: Internal temperature ...: reserviert 103: Control voltage 104: Motor supply voltage ...: reserviert 150: Status word (drive controller) 151: State (drive controller) ...: reserviert | UINT8 | RW | 0x01 (1dez)
8032:19 | Select info data 2 | Auswahl "Info data 2" siehe Subindex 0x8032:11 | UINT8 | RW | 0x02 (2dez)
8032:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 | BOOLEAN | RW | 0x00 (0dez)
8032:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 | BOOLEAN | RW | 0x00 (0dez)
8032:32 | Function for input 1 | Funktion des digitalen Eingangs 1 0: Normal input 1: Hardware enable …: reserviert | BIT4 | RW | 0x00 (0dez)
8032:36 | Function for input 2 | Funktion des digitalen Eingangs 2 siehe Subindex 0x8032:32 | BIT4 | RW | 0x00 (0dez)


Kommando - Objekt

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Kommando - Objekt
Kommando - Objekt
Index FB00 DCM Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | DCM Command | Kommandoschnittstelle | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x8000: Software reset, Hardware wird mit der aktuellen CoE-Konfiguration neu Initialisiert (geschieht sonst nur beim Übergang nach INIT) | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | 0x8000: bei erfolgtem Reset 0x01 | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | 0x8000: nicht benutzt | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Eingangsdaten
Eingangsdaten
Index 6000 CNT Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | CNT Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter inhibited | Zählerunterlauf | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input clock | Zustand des Clock-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
Index 6010 CNT Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | CNT Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
6010:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Counter inhibited | Zählerunterlauf | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Status of input clock | Zustand des Clock-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob im abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
Index 6020 DCM Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | DCM Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6020:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Warning | Eine Warnung ist aufgetreten (siehe Index 0xA020) | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Error | Ein Fehler ist aufgetreten (siehe Index 0xA020) | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Torque reduced | Reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6020:0C | Digital input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6020:0D | Digital input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob im abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO Aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8022:11) | UINT16 | RO | 0x0000 (0dez)
6020:12 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8022:19) | UINT16 | RO | 0x0000 (0dez)
Index 6030 DCM Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6030:0 | DCM Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6030:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Warning | Eine Warnung ist aufgetreten (siehe Index 0xA030) | BOOLEAN | RO | 0x00 (0dez)
6030:04 | Error | Ein Fehler ist aufgetreten (siehe Index 0xA030) | BOOLEAN | RO | 0x00 (0dez)
6030:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6030:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6030:07 | Torque reduced | Reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6030:0C | Digital input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6030:0D | Digital input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6030:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob im abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO Aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8032:11) | UINT16 | RO | 0x0000 (0dez)
6030:12 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8032:19) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Ausgangsdaten
Ausgangsdaten
Index 7000 CNT Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | CNT Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
7000:03 | Set counter | Zählerstand mit "Set counter value" setzen. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Inhibit counter | Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der alte Zählerstand bleibt erhalten. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über „Set counter“ zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 CNT Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | CNT Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
7010:03 | Set counter | Zählerstand mit "Set counter value" setzen. | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Inhibit counter | Der Zähler wird gestoppt, solange dieses Bit aktiv ist. Der alte Zählerstand bleibt erhalten. | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Set counter value | Dies ist der über „Set counter“ zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7020 DCM Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | DCM Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x21 (33dez)
7020:01 | Enable | Aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Reset | Alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:03 | Reduce torque | Reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8020:05 / 0x8020:06) | BOOLEAN | RO | 0x00 (0dez)
7020:21 | Velocity | Vorgabe der Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7030 DCM Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | DCM Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x21 (33dez)
7030:01 | Enable | Aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7030:02 | Reset | Alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7030:03 | Reduce torque | Reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8030:05 / 0x8030:06) | BOOLEAN | RO | 0x00 (0dez)
7030:21 | Velocity | Vorgabe der Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)


Informations- und Diagnostikdaten (kanalspezifisch)

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Informations- und Diagnostikdaten (kanalspezifisch)
Informations- und Diagnostikdaten (kanalspezifisch)
Index 9020 DCM Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9020:0 | DCM Info data Ch.1 | Max. Subindex | UINT8 | RO | 0x09 (9dez)
9020:01 | Status word | Statuswort (siehe Index App0) | UINT16 | RO | 0x0000 (0dez)
9020:02 | Motor coil voltage | Aktuelle Spulenspannung | UINT16 | RO | 0x0000 (0dez)
9020:03 | Motor coil current | Aktueller Spulenstrom | INT16 | RO | 0x0000 (0dez)
9020:04 | Current limit | Aktuelle Strombegrenzung | UINT16 | RO | 0x0000 (0dez)
9020:05 | Control error | Aktueller Regelfehler | INT16 | RO | 0x0000 (0dez)
9020:06 | Duty cycle | Aktueller Duty-Cycle | INT8 | RO | 0x00 (0dez)
9020:09 | Overload time | Zeit seit Überlastung | UINT16 | RO | 0x0000 (0dez)
Index 9030 DCM Info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9030:0 | DCM Info data Ch.2 | Max. Subindex | UINT8 | RO | 0x09 (9dez)
9030:01 | Status word | Statuswort (siehe Index App0) | UINT16 | RO | 0x0000 (0dez)
9030:02 | Motor coil voltage | Aktuelle Spulenspannung | UINT16 | RO | 0x0000 (0dez)
9030:03 | Motor coil current | Aktueller Spulenstrom | INT16 | RO | 0x0000 (0dez)
9030:04 | Current limit | Aktuelle Strombegrenzung | UINT16 | RO | 0x0000 (0dez)
9030:05 | Control error | Aktueller Regelfehler | INT16 | RO | 0x0000 (0dez)
9030:06 | Duty cycle | Aktueller Duty-Cycle | INT8 | RO | 0x00 (0dez)
9030:09 | Overload time | Zeit seit Überlastung | UINT16 | RO | 0x0000 (0dez)
Index A020 DCM Diag data Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
A020:0 | DCM Diag data Ch.1 | Max. Subindex |  | UINT8 | RO | 0x11 (17dez)
A020:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | Warnung | BOOLEAN | RO | 0x00 (0dez)
A020:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | Warnung | BOOLEAN | RO | 0x00 (0dez)
A020:03 | Torque overload | Aktueller Motorstrom ist größer als der Nennstrom (siehe 0x8020:02) | Warnung (8pp2:0A = 0) / Fehler (8pp2:0A = 1) | BOOLEAN | RO | 0x00 (0dez)
A020:04 | Under voltage | Versorgungsspannung kleiner als 7 V | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:05 | Over voltage | Versorgungsspannung 10 % größer, als die Nennspannung (siehe 0x8020:03) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:06 | Short circuit | Kurzschluss der Treiberstufe | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:08 | No control power | Treiberstufe ohne Spannungsversorgung | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:09 | Misc error | - Initialisierung fehlgeschlagen oder - Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05) oder - Motorstrom ist größer als der Nennstrom (siehe 0x8022:0A) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:11 | Actual operation mode | Aktuelle Betriebsart (bei automatischer Betriebsarterkennung, siehe 0x8022:01) |  | BIT4 | RO | 0x00 (0dez)
Index A030 DCM Diag data Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
A030:0 | DCM Diag data Ch.2 | Max. Subindex |  | UINT8 | RO | 0x11 (17dez)
A030:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | Warnung | BOOLEAN | RO | 0x00 (0dez)
A030:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | Warnung | BOOLEAN | RO | 0x00 (0dez)
A030:03 | Torque overload | Aktueller Motorstrom ist größer als der Nennstrom (siehe 0x8030:02) | Warnung (8032:0A = 0) / Fehler (8032:0A = 1) | BOOLEAN | RO | 0x00 (0dez)
A030:04 | Under voltage | Versorgungsspannung kleiner als 7 V | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:05 | Over voltage | Versorgungsspannung 10 % größer, als die Nennspannung (siehe 0x8030:03) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:06 | Short circuit | Kurzschluss der Treiberstufe | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:08 | No control power | Treiberstufe ohne Spannungsversorgung | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:09 | Misc error | - Initialisierung fehlgeschlagen oder - Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05) oder - Motorstrom ist größer als der Nennstrom (siehe 0x8032:0A) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:11 | Actual operation mode | Aktuelle Betriebsart (bei automatischer Betriebsarterkennung, siehe 0x8032:01) |  | BIT4 | RO | 0x00 (0dez)


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index F80F DCM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | DCM Vendor data | Max. Subindex | UINT8 | RO | 0x06 (6dez)
F80F:01 | PWM Frequency | Zwischenkreisfrequenz (Einheit: 1 Hz) | UINT16 | RW | 0x7530 (30000dez)
F80F:02 | Deadtime | Totzeit der Pulsweitenmodulation | UINT16 | RW | 0x0505 (1285dez)
F80F:03 | Deadtime space | Duty Cycle Begrenzung | UINT16 | RW | 0x0009 (9dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung (Einheit: 1 °C) | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur (Einheit: 1 °C) | INT8 | RW | 0x64 (100dez)
F80F:06 | Analog trigger point | Triggerpunkt der AD-Wandlung | UINT16 | RW | 0x000A (10dez)


Informations- und Diagnostikdaten (gerätespezifisch)

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Informations- und Diagnostikdaten (gerätespezifisch)
Informations- und Diagnostikdaten (gerätespezifisch)
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist. | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... |  | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index F900 DCM Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DCM Info data | Max. Subindex | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Softwareversion der Treiberkarte | STRING | RO |
F900:02 | Internal temperature | Interne Klemmentemperatur (Einheit: 1 °C) | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage | Steuerspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage | Lastspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time | gemessene Zykluszeit (Einheit: 1 µs) | UINT16 | RO | 0x0000 (0dez)
Index FB40 Memory interface
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB40:0 | Memory interface | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB40:01 | Address | reserviert | UINT32 | RW | 0x00000000 (0dez)
FB40:02 | Length | reserviert | UINT16 | RW | 0x0000 (0dez)
FB40:03 | Data | reserviert | OCTET-STRING[8] | RW | {0}


Standardobjekte

Inbetriebnahme [image] EL7332- Objektbeschreibung und Parametrierung [image] ab Firmware 06 /Revisionstand -0020 [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL7332
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 08
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1CA43052 (480522322dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 CNT RxPDO-Par Control compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | CNT RxPDO-Par Control compact Ch.1 | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 CNT RxPDO-Par Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | CNT RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1402 CNT RxPDO-Par Control compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | CNT RxPDO-Par Control compact Ch.2 | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 16
Index 1403 CNT RxPDO-Par Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | CNT RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 16
Index 1600 CNT RxPDO-Map Control compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | CNT RxPDO-Map Control compact Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 2
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:03, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:04, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x0000:00, 4
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 8
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (CNT Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1600 DCM RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DCM RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x05 (5dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 CNT RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | CNT RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 2
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (CNT Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (CNT Outputs Ch.1), entry 0x04 (Inhibit counter)) | UINT32 | RO | 0x7000:04, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (CNT Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1601 DCM RxPDO-Map Velocity Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DCM RxPDO-Map Velocity Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7000:21, 16
Index 1602 CNT RxPDO-Map Control compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | CNT RxPDO-Map Control compact Ch.2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (DCM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x0000:00, 2
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:03, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:04, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 4
1602:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (CNT Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1603 CNT RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | CNT RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DCM Outputs Ch.2), entry 0x01 (Enable)) | UINT32 | RO | 0x0000:00, 2
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (CNT Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (CNT Outputs Ch.2), entry 0x04 (Inhibit counter)) | UINT32 | RO | 0x7010:04, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (CNT Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1604 DCM RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | DCM RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x05 (5dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7020:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7020:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7020:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1604:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1605 DCM RxPDO-Map Velocity Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | DCM RxPDO-Map Velocity Ch.1 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
Index 1606 DCM RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | DCM RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x05 (5dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x01 (Enable)) | UINT32 | RO | 0x7030:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x02 (Reset)) | UINT32 | RO | 0x7030:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7030:03, 1
1606:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1606:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1607 DCM RxPDO-Map Velocity Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | DCM RxPDO-Map Velocity Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x21 (Velocity)) | UINT32 | RO | 0x7030:21, 16
Index 1800 CNT TxPDO-Par Status compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | CNT TxPDO-Par Status compact Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 CNT TxPDO-Par Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | CNT TxPDO-Par Status Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1802 CNT TxPDO-Par Status compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | CNT TxPDO-Par Status compact Ch.2 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 CNT TxPDO-Par Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | CNT TxPDO-Par Status Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1A00 DCM TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DCM TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0E (14dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6000:0C, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (DCM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6000:0D, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 1A01 CNT TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | CNT TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0B (11dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:03, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (CNT Inputs Ch.1), entry 0x04 (Counter inhibited)) | UINT32 | RO | 0x6000:04, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (CNT Inputs Ch.1), entry 0x06 (Status of input clock)) | UINT32 | RO | 0x6000:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (CNT Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (CNT Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (CNT Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A02 CNT TxPDO-Map Status compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | CNT TxPDO-Map Status compact Ch.2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0B (11dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x0000:00, 2
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:03, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x0000:00, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:06, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (DCM Inputs Ch.2), entry 0x06 (Moving negative)) | UINT32 | RO | 0x0000:00, 2
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
Index 1A03 CNT TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | CNT TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0B (11dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x0000:00, 2
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:03, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x04 (Counter inhibited)) | UINT32 | RO | 0x6010:04, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x06 (Status of input clock)) | UINT32 | RO | 0x6010:06, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (CNT Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
Index 1A04 DCM TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | DCM TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0E (14dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6020:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6020:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6020:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6020:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6020:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6020:0C, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6020:0D, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6020:0E, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6020:10, 1
Index 1A05 DCM TxPDO-Map Synchron info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DCM TxPDO-Map Synchron info data Ch.1 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x02 (2dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6020:11, 16
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6020:12, 16
Index 1A06 DCM TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | DCM TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0E (14dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6030:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x02 (Ready)) | UINT32 | RO | 0x6030:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6030:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6030:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6030:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6030:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6030:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6030:0C, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6030:0D, 1
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0E (Sync error)) | UINT32 | RO | 0x6030:0E, 1
1A06:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6030:10, 1
Index 1A07 DCM TxPDO-Map Synchron info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | DCM TxPDO-Map Synchron info data Ch.2 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x02 (2dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6030:11, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6030:12, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x06 (6dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1605 (5637dez)
1C12:05 | Subindex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1606 (5638dez)
1C12:06 | Subindex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1607 (5639dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x0C07 (3079dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0001E848 (125000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0C07 (3079dez)
1C33:05
Minimum cycle time
wie 1C32:05
UINT32
RO
0x0001E848 (125000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | Profilnummer CNT | UINT32 | RW | 0x00000096 (150dez)
F010:02 | SubIndex 002 | Profilnummer CNT | UINT32 | RW | 0x00000096 (150dez)
F010:03 | SubIndex 003 | Profilnummer DCM | UINT32 | RW | 0x000002DD (733dez)
F010:04 | SubIndex 004 | Profilnummer DCM | UINT32 | RW | 0x000002DD (733dez)


EL7342 - Objektbeschreibung und Parametrierung

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung
EL7342 - Objektbeschreibung und Parametrierung
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Hinweis
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind:
–
Restore Objekt
–
Konfigurationsdaten
–
Kommando - Objekt
▪
Profilspezifische Objekte:
–
Eingangsdaten
–
Ausgangsdaten
–
Informations- und Diagnostikdaten (kanalspezifisch)
–
Konfigurationsdaten (herstellerspezifisch)
–
Informations- und Diagnostikdaten (gerätespezifisch)
▪
Standardobjekte
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando - Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten (kanalspezifisch)
•
Konfigurationsdaten (herstellerspezifisch)
•
Informations- und Diagnostikdaten (gerätespezifisch)
•
Standardobjekte


Restore Objekt

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x0E (14dez)
8000:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable micro increments | Bei Aktivierung interpoliert die Klemme im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 Bit des Counter-Value benutzt. Aus einem 32-bit-Zähler wird so ein 24+8bit Zähler, aus einem 16-bit-Zähler ein 8+8bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
Index 8010 ENC Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | ENC Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x0E (14dez)
8010:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable micro increments | Bei Aktivierung interpoliert die Klemme im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 Bit des Counter-Value benutzt. Aus einem 32-bit-Zähler wird so ein 24+8bit Zähler, aus einem 16-bit-Zähler ein 8+8bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8010:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
Index 8020 DCM Motor Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | DCM Motor Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8020:01 | Maximal current | Maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x1388 (5000dez)
8020:02 | Nominal current | Nennstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x0DAC (3500dez)
8020:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0xC350 (50000dez)
8020:04 | Motor coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8020:05 | Reduced current (positive) | Reduziertes Drehmoment in positiver Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x07D0 (2000dez)
8020:06 | Reduced current (negative) | Reduziertes Drehmoment in negativer Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x07D0 (2000dez)
8020:07 | Encoder increments (4-fold) | Anzahl der Enkoder-Inkremente pro Umdrehung bei 4-fach Auswertung | UINT16 | RW | 0x0000 (0dez)
8020:08 | Maximal motor velocity | Nenndrehzahl des Motors bei Nennspannung (Einheit: 1 rpm) | UINT16 | RW | 0x0000 (0dez)
8020:0C | Time for switch-off at overload | Zeit für Überlastabschaltung (Einheit: 1 ms) | UINT16 | RW | 0x00C8 (200dez)
8020:0D | Time for current lowering at overload | Zeit für Stromreduzierung bei Überlast (von maximalem Strom bis Nennstrom, Einheit: 1 ms) | UINT16 | RW | 0x07D0 (2000dez)
8020:0E | Torque auto-reduction threshold (positive) | Prozessdatenschwelle für automatische Drehmomentreduzierung in positiver Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8020:0F | Torque auto-reduction threshold (negative) | Prozessdatenschwelle für automatische Drehmomentreduzierung in negativer Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
Index 8021 DCM Controller Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8021:0 | DCM Controller Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
8021:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x00C8 (200dez)
8021:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0002 (2dez)
8021:03 | Inner window (curr.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8021:05 | Outer window (curr.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8021:06 | Filter cut off frequency (curr.) | Grenzfrequenz des Stromreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8021:11 | Voltage adjustment enable | Aktiviert die Kompensation von Spannungsschwankungen (nur in der Betriebsart "Direct velocity") | BOOLEAN | RW | 0x00 (0dez)
8021:12 | Current adjustment enable | Aktiviert die R x I Kompensation | BOOLEAN | RW | 0x00 (0dez)
Index 8022 DCM Features Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8022:0 | DCM Features Ch.1 | Max. Subindex | UINT8 | RO | 0x36 (54dez)
8022:01 | Operation mode | Betriebsart 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller ...: reserviert 15: Chopper resistor Vorhandenen Überspannung (10 % > Nennspannung 0x8020:03) wird über angeschlossenen Chopper-Widerstand abgebaut. | BIT4 | RW | 0x00 (0dez)
8022:09 | Invert motor polarity | Invertierung der Motordrehrichtung | BOOLEAN | RW | 0x00 (0dez)
8022:0A | Torque error enable | Aktiviert die automatische Überlastabschaltung (siehe auch Subindex 0x8020:0C) | BOOLEAN | RW | 0x00 (0dez)
8022:0B | Torque auto reduce | Aktiviert die automatische Drehmomentreduzierung (siehe auch Subindex 0x8020:0D – 0x8020:0F) | BOOLEAN | RW | 0x00 (0dez)
8022:11 | Select info data 1 | Auswahl "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle ....: reserviert 7: Motor velocity 8: Overload time ...: reserviert 101: Internal temperature ...: reserviert 103: Control voltage 104: Motor supply voltage ...: reserviert 150: Status word (drive controller) 151: State (drive controller) ...: reserviert | UINT8 | RW | 0x01 (1dez)
8022:19 | Select info data 2 | Auswahl "Info data 2" siehe Subindex 0x8022:11 | UINT8 | RW | 0x02 (2dez)
8022:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 | BOOLEAN | RW | 0x00 (0dez)
8022:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 | BOOLEAN | RW | 0x00 (0dez)
8022:32 | Function for input 1 | Funktion des digitalen Eingangs 1 0: Normal input 1: Hardware enable …: reserviert | BIT4 | RW | 0x00 (0dez)
8022:36 | Function for input 2 | Funktion des digitalen Eingangs 2 siehe Subindex 0x8022:32 | BIT4 | RW | 0x00 (0dez)
Index 8023 DCM Controller Settings 2 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8023:0 | DCM Controller Settings 2 Ch.1 | Max. Subindex | UINT8 | RO | 0x08 (8dez)
8023:01 | Kp factor (velo./pos.) | Kp-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x00C8 (200dez)
8023:02 | Ki factor (velo./pos.) | Ki-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0002 (2dez)
8023:03 | Inner window (velo./pos.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8023:05 | Outer window (velo./pos.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8023:06 | Filter cut off frequency (velo./pos.) | Grenzfrequenz des Geschwindigkeits-/Positionsreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8023:07 | Ka factor (velo./pos.) | Ka-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0000 (0dez)
8023:08 | Kd factor (velo./pos.) | Kd-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0014 (20dez)
Index 8030 DCM Motor Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8030:0 | DCM Motor Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8030:01 | Maximal current | Maximaler, dauerhafter Spulenstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x1388 (5000dez)
8030:02 | Nominal current | Nennstrom des Motors (Einheit: 1 mA) | UINT16 | RW | 0x0DAC (3500dez)
8030:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors (Einheit: 1 mV) | UINT16 | RW | 0xC350 (50000dez)
8030:04 | Motor coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8030:05 | Reduced current (positive) | Reduziertes Drehmoment in positiver Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x07D0 (2000dez)
8030:06 | Reduced current (negative) | Reduziertes Drehmoment in negativer Drehrichtung (Einheit: 1 mA) | UINT16 | RW | 0x07D0 (2000dez)
8030:07 | Encoder increments (4-fold) | Anzahl der Enkoder-Inkremente pro Umdrehung bei 4-fach Auswertung | UINT16 | RW | 0x0000 (0dez)
8030:08 | Maximal motor velocity | Nenndrehzahl des Motors bei Nennspannung (Einheit: 1 rpm) | UINT16 | RW | 0x0000 (0dez)
8030:0C | Time for switch-off at overload | Zeit für Überlastabschaltung (Einheit: 1 ms) | UINT16 | RW | 0x00C8 (200dez)
8030:0D | Time for current lowering at overload | Zeit für Stromreduzierung bei Überlast (von maximalem Strom bis Nennstrom, Einheit: 1 ms) | UINT16 | RW | 0x07D0 (2000dez)
8030:0E | Torque auto-reduction threshold (positive) | Prozessdatenschwelle für automatische Drehmomentreduzierung in positiver Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8030:0F | Torque auto-reduction threshold (negative) | Prozessdatenschwelle für automatische Drehmomentreduzierung in negativer Drehrichtung (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
Index 8031 DCM Controller Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8031:0 | DCM Controller Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
8031:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x00C8 (200dez)
8031:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0002 (2dez)
8031:03 | Inner window (curr.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8031:05 | Outer window (curr.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8031:06 | Filter cut off frequency (curr.) | Grenzfrequenz des Stromreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8031:11 | Voltage adjustment enable | Aktiviert die Kompensation von Spannungsschwankungen (nur in der Betriebsart "Direct velocity") | BOOLEAN | RW | 0x00 (0dez)
8031:12 | Current adjustment enable | Aktiviert die R x I Kompensation | BOOLEAN | RW | 0x00 (0dez)
Index 8032 DCM Features Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8032:0 | DCM Features Ch.2 | Max. Subindex | UINT8 | RO | 0x36 (54dez)
8032:01 | Operation mode | Betriebsart 0: Automatic 1: Velocity direct 2: Velocity controller 3: Position controller ...: reserviert 15: Chopper resistor Vorhandenen Überspannung (10 % > Nennspannung 0x8030:03) wird über angeschlossenen Chopper-Widerstand abgebaut. | BIT4 | RW | 0x00 (0dez)
8032:09 | Invert motor polarity | Invertierung der Motordrehrichtung | BOOLEAN | RW | 0x00 (0dez)
8032:0A | Torque error enable | Aktiviert die automatische Überlastabschaltung (siehe auch Subindex 0x8030:0C) | BOOLEAN | RW | 0x00 (0dez)
8032:0B | Torque auto reduce | Aktiviert die automatische Drehmomentreduzierung (siehe auch Subindex 0x8030:0D – 0x8030:0F) | BOOLEAN | RW | 0x00 (0dez)
8032:11 | Select info data 1 | Auswahl "Info data 1" 0: Status word 1: Motor coil voltage 2: Motor coil current 3: Current limit 4: Control error 5: Duty cycle ....: reserviert 7: Motor velocity 8: Overload time ...: reserviert 101: Internal temperature ...: reserviert 103: Control voltage 104: Motor supply voltage ...: reserviert 150: Status word (drive controller) 151: State (drive controller) ...: reserviert | UINT8 | RW | 0x01 (1dez)
8032:19 | Select info data 2 | Auswahl "Info data 2" siehe Subindex 0x8032:11 | UINT8 | RW | 0x02 (2dez)
8032:30 | Invert digital input 1 | Invertierung des digitalen Eingangs 1 | BOOLEAN | RW | 0x00 (0dez)
8032:31 | Invert digital input 2 | Invertierung des digitalen Eingangs 2 | BOOLEAN | RW | 0x00 (0dez)
8032:32 | Function for input 1 | Funktion des digitalen Eingangs 1 0: Normal input 1: Hardware enable ...: reserviert | BIT4 | RW | 0x00 (0dez)
8032:36 | Function for input 2 | Funktion des digitalen Eingangs 2 siehe Subindex 0x8032:32 | BIT4 | RW | 0x00 (0dez)
Index 8033 DCM Controller Settings 2 Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8033:0 | DCM Controller Settings 2 Ch.2 | Max. Subindex | UINT8 | RO | 0x08 (8dez)
8033:01 | Kp factor (velo./pos.) | Kp-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x00C8 (200dez)
8033:02 | Ki factor (velo./pos.) | Ki-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0002 (2dez)
8033:03 | Inner window (velo./pos.) | Inneres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8033:05 | Outer window (velo./pos.) | Äußeres Fenster des I-Anteils (Einheit: 1 %) | UINT8 | RW | 0x00 (0dez)
8033:06 | Filter cut off frequency (velo./pos.) | Grenzfrequenz des Geschwindigkeits-/Positionsreglers (Einheit: 1 Hz) | UINT16 | RW | 0x0000 (0dez)
8033:07 | Ka factor (velo./pos.) | Ka-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0000 (0dez)
8033:08 | Kd factor (velo./pos.) | Kd-Regelfaktor des Geschwindigkeits-/Positionsreglers | UINT16 | RW | 0x0014(20dez)
Index 8040 POS Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | POS Settings Ch.1 | Max. Subindex | UINT8 | RO | 0x10 (16dez)
8040:01 | Velocity min. | minimale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8040:02 | Velocity max. | maximale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x2710 (10000dez)
8040:03 | Acceleration pos. | Beschleunigung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8040:04 | Acceleration neg. | Beschleunigung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8040:05 | Deceleration pos. | Verzögerung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8040:06 | Deceleration neg. | Verzögerung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8040:07 | Emergency deceleration | Notfallverzögerung (beide Drehrichtungen, Einheit: 1 ms) | UINT16 | RW | 0x0064 (100dez)
8040:08 | Calibration position | Kalibrierposition | UINT32 | RW | 0x00000000 (0dez)
8040:09 | Calibration velocity (towards plc cam) | Kalibriergeschwindigkeit auf die Nocke (Bereich: 0-10000) | INT16 | RW | 0x03E8 (1000dez)
8040:0A | Calibration Velocity (off plc cam) | Kalibriergeschwindigkeit von der Nocke herunter (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8040:0B | Target window | Zielfenster | UINT16 | RW | 0x000A (10dez)
8040:0C | In-Target timeout | Zielpositions-Timeout (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8040:0D | Dead time compensation | Totzeitkompensation (Einheit: 1 us) | INT16 | RW | 0x0064 (100dez)
8040:0E | Modulo factor | Modulofaktor/-position | UINT32 | RW | 0x00000000 (0dez)
8040:0F | Modulo tolerance window | Toleranzfenster für Modulopositionierung | UINT32 | RW | 0x00000000 (0dez)
8040:10 | Position lag max. | Maximal erlaubter Schleppabstand | UINT16 | RW | 0x0000 (0dez)
Index 8041 POS Features Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8041:0 | POS Features Ch.1 |  | UINT8 | RO | 0x16 (22dez)
8041:01 | Start type | Standard Starttyp | UINT16 | RW | 0x0001 (1dez)
8041:11 | Time information | Zeitinformation in Subindex 6pp0:22 ("Actual drive time") 0: Elapsed time aktuell gefahrene Zeit seit Beginn des Fahrauftrages ...: reserviert | BIT2 | RW | 0x00 (0dez)
8041:13 | Invert calibration cam search direction | Invertierung der Drehrichtung auf die Nocke | BOOLEAN | RW | 0x01 (1dez)
8041:14 | Invert sync impulse search direction | Invertierung der Drehrichtung von der Nocke herunter | BOOLEAN | RW | 0x00 (0dez)
8041:15 | Emergency stop on postion lag error | - Schleppfehlerüberwachung hat ausgelöst - Sobald “Position lag” = 1 ist, wird ein „Emergeny Stop“ ausgelöst. Der „Misc Error“ wird auf 1 gesetzt und es entsteht ein PDO-Error. | BOOLEAN | RW | 0x00 (0dez)
8041:16 | Enhanced diag history | TRUE: es werden zusätzliche Meldungen während eines Fahrauftrages ausgegeben (jede Änderung der Statemachine (Index 0x9040:03)) | BOOLEAN | RW | 0x00 (0dez)
Index 8050 POS Settings Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8050:0 | POS Settings Ch.2 | Max. Subindex | UINT8 | RO | 0x10 (16dez)
8050:01 | Velocity min. | minimale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8050:02 | Velocity max. | maximale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x2710 (10000dez)
8050:03 | Acceleration pos. | Beschleunigung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8050:04 | Acceleration neg. | Beschleunigung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8050:05 | Deceleration pos. | Verzögerung in positiver Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8050:06 | Deceleration neg. | Verzögerung in negativer Drehrichtung (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8050:07 | Emergency deceleration | Notfallverzögerung (beide Drehrichtungen, Einheit: 1 ms) | UINT16 | RW | 0x0064 (100dez)
8050:08 | Calibration position | Kalibrierposition | UINT32 | RW | 0x00000000 (0dez)
8050:09 | Calibration velocity (towards plc cam) | Kalibriergeschwindigkeit auf die Nocke (Bereich: 0-10000) | INT16 | RW | 0x03E8 (1000dez)
8050:0A | Calibration Velocity (off plc cam) | Kalibriergeschwindigkeit von der Nocke herunter (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8050:0B | Target window | Zielfenster | UINT16 | RW | 0x000A (10dez)
8050:0C | In-Target timeout | Zielpositions-Timeout (Einheit: 1 ms) | UINT16 | RW | 0x03E8 (1000dez)
8050:0D | Dead time compensation | Totzeitkompensation (Einheit: 1 us) | INT16 | RW | 0x0064 (100dez)
8050:0E | Modulo factor | Modulofaktor/-position | UINT32 | RW | 0x00000000 (0dez)
8050:0F | Modulo tolerance window | Toleranzfenster für Modulopositionierung | UINT32 | RW | 0x00000000 (0dez)
8050:10 | Position lag max. | Maximal erlaubter Schleppabstand | UINT16 | RW | 0x0000 (0dez)
Index 8051 POS Features Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8051:0 | POS Features Ch.2 | Max. Subindex | UINT8 | RO | 0x16 (22dez)
8051:01 | Start type | Standard Starttyp | UINT16 | RW | 0x0001 (1dez)
8051:11 | Time information | Zeitinformation in Subindex 6pp0:22 ("Actual drive time") 0: Elapsed time aktuell gefahrene Zeit seit Beginn des Fahrauftrages ...: reserviert | BIT2 | RW | 0x00 (0dez)
8051:13 | Invert calibration cam search direction | Invertierung der Drehrichtung auf die Nocke | BOOLEAN | RW | 0x01 (1dez)
8051:14 | Invert sync impulse search direction | Invertierung der Drehrichtung von der Nocke herunter | BOOLEAN | RW | 0x00 (0dez)
8051:15 | Emergency stop on postion lag error | - Schleppfehlerüberwachung hat ausgelöst - Sobald “Position lag” = 1 ist, wird ein „Emergeny Stop“ ausgelöst. Der „Misc Error“ wird auf 1 gesetzt und es entsteht ein PDO-Error. | BOOLEAN | RW | 0x00 (0dez)
8051:16 | Enhanced diag history | TRUE: es werden zusätzliche Meldungen während eines Fahrauftrages ausgegeben (jede Änderung der Statemachine (Index 0x9050:03)) | BOOLEAN | RW | 0x00 (0dez)


Kommando - Objekt

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Kommando - Objekt
Kommando - Objekt
Index FB00 DCM Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | DCM Command | Max. Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x1000 Clear diag history löscht die Diag History 0x1100 Get build number: Auslesen der Build-Nummer 0x1101 Get build date Auslesen des Build-Datums 0x1102 Get build time Auslesen der Build-Zeit 0x8000 Software reset Software-Reset durchführen (Hardware wird mit der Aktuellen CoE-Konfiguration neu Initialisiert, geschieht sonst nur beim Übergang nach INIT) | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | 0: Finished, no error, no response Kommando ohne Fehler und ohne Antwort (Response ) beendet | UINT8 | RO | 0x00 (0dez)
 |  | 1: Finished, no error, response Kommando ohne Fehler und mit Antwort beendet
 |  | 2: Finished, error, no response Kommando mit Fehler und ohne Antwort beendet
 |  | 3: Finished, error, response Kommando mit Fehler und mit Antwort beendet
 |  | 255: Executing Kommando wird ausgeführt
FB00:03 | Response | abhängig vom Request | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x16 (22dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Index 0x6000:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7000:02 bzw. Objekt-Index 0x7000:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig. | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der Klemme ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT32 | RO | 0x00000000 (0dez)
Index 6010 ENC Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | ENC Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x16 (22dez)
6010:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Index 0x6010:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7010:02 bzw. Objekt-Index 0x7010:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6010:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6010:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6010:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Status of extern latch | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der Klemme ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6010:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6010:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT32 | RO | 0x00000000 (0dez)
Index 6020 DCM Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | DCM Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6020:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Warning | Eine Warnung ist aufgetreten (siehe Index 0xA020) | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Error | Ein Fehler ist aufgetreten (siehe Index 0xA020) | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Torque reduced | Reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6020:0C | Digital input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6020:0D | Digital input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO Aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8022:11) | UINT16 | RO | 0x0000 (0dez)
6020:12 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8022:19) | UINT16 | RO | 0x0000 (0dez)
Index 6030 DCM Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6030:0 | DCM Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6030:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Ready | Treiberstufe ist betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Warning | Eine Warnung ist aufgetreten (siehe Index 0xA030) | BOOLEAN | RO | 0x00 (0dez)
6030:04 | Error | Ein Fehler ist aufgetreten (siehe Index 0xA030) | BOOLEAN | RO | 0x00 (0dez)
6030:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6030:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6030:07 | Torque reduced | Reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6030:0C | Digital input 1 | Digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6030:0D | Digital input 2 | Digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6030:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob im abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Info data 1 | Synchrone Informationen (Auswahl über Subindex 0x8032:11) | UINT16 | RO | 0x0000 (0dez)
6030:12 | Info data 2 | Synchrone Informationen (Auswahl über Subindex 0x8032:19) | UINT16 | RO | 0x0000 (0dez)
Index 6040 POS Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | POS Inputs Ch.1 | Max. Subindex | UINT8 | RO | 0x22 (34dez)
6040:01 | Busy | ein aktueller Fahrauftrag ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6040:02 | In-Target | Motor ist im Ziel angekommen | BOOLEAN | RO | 0x00 (0dez)
6040:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6040:04 | Error | eine Fehler ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6040:05 | Calibrated | Motor ist kalibriert | BOOLEAN | RO | 0x00 (0dez)
6040:06 | Accelerate | Motor ist in der Beschleunigungsphase | BOOLEAN | RO | 0x00 (0dez)
6040:07 | Decelerate | Motor ist in der Verzögerungsphase | BOOLEAN | RO | 0x00 (0dez)
6040:11 | Actual position | aktuelle Sollposition des Fahrauftraggenerators | UINT32 | RO | 0x00007FFF (32767dez)
6040:21 | Actual velocity | aktuelle Sollgeschwindigkeit des Fahrauftraggenerators | INT16 | RO | 0x0000 (0dez)
6040:22 | Actual drive time | Zeitinformation des Fahrauftrages (siehe Subindex 8pp1:11) | UINT32 | RO | 0x00000000 (0dez)
Index 6050 POS Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6050:0 | POS Inputs Ch.2 | Max. Subindex | UINT8 | RO | 0x22 (34dez)
6050:01 | Busy | ein aktueller Fahrauftrag ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6050:02 | In-Target | Motor ist im Ziel angekommen | BOOLEAN | RO | 0x00 (0dez)
6050:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6050:04 | Error | eine Fehler ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6050:05 | Calibrated | Motor ist kalibriert | BOOLEAN | RO | 0x00 (0dez)
6050:06 | Accelerate | Motor ist in der Beschleunigungsphase | BOOLEAN | RO | 0x00 (0dez)
6050:07 | Decelerate | Motor ist in der Verzögerungsphase | BOOLEAN | RO | 0x00 (0dez)
6050:11 | Actual position | aktuelle Sollposition des Fahrauftraggenerators | UINT32 | RO | 0x00007FFF (32767dez)
6050:21 | Actual velocity | aktuelle Sollgeschwindigkeit des Fahrauftraggenerators | INT16 | RO | 0x0000 (0dez)
6050:22 | Actual drive time | Zeitinformation des Fahrauftrages (siehe Subindex 8pp1:11) | UINT32 | RO | 0x00000000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über „Set counter“ (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 ENC Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | ENC Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
7010:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Set counter value | Der über „Set counter“ (Index 0x7010:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7020 DCM Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | DCM Outputs Ch.1 | Max. Subindex | UINT8 | RO | 0x21 (33dez)
7020:01 | Enable | Aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Reset | Alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:03 | Reduce torque | Reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8020:05 / 0x8020:06) | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Position | Vorgabe der Sollposition | UINT32 | RO | 0x00000000 (0dez)
7020:21 | Velocity | Vorgabe der Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7030 DCM Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | DCM Outputs Ch.2 | Max. Subindex | UINT8 | RO | 0x21 (33dez)
7030:01 | Enable | Aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7030:02 | Reset | Alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7030:03 | Reduce torque | Reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8030:05 / 0x8030:06) | BOOLEAN | RO | 0x00 (0dez)
7030:11 | Position | Vorgabe der Sollposition | UINT32 | RO | 0x00000000 (0dez)
7030:21 | Velocity | Vorgabe der Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7040 POS Outputs Ch.1
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
7040:0
POS Outputs Ch.1
Max. Subindex
UINT8
RO
0x24 (36dez)
7040:01
Execute
Fahrauftrag starten (steigende Flanke), bzw. Fahrauftrag vorzeitig abbrechen (fallende Flanke)
BOOLEAN
RO
0x00 (0dez)
7040:02
Emergency stop
Fahrauftrag vorzeitig mit einer Notfallrampe abbrechen (steigende Flanke)
BOOLEAN
RO
0x00 (0dez)
7040:11
Target position
Vorgabe der Zielposition
UINT32
RO
0x00007FFF (32767dez)
7040:21
Velocity
Vorgabe der maximalen Sollgeschwindigkeit
INT16
RO
0x0000 (0dez)
7040:22
Start type
Vorgabe des Starttypen
0x0000 Idle
es wird kein Fahrauftrag ausgeführt
0x0001 Absolute
Zielposition absolut
0x0002 Relative
Zielposition relativ von Startposition aus
0x0003 Endless plus
Endlosfahrt in positiver Drehrichtung
0x0004 Endless minus
Endlosfahrt in negativer Drehrichtung
0x0105 Modulo short
kürzeste Entfernung zur nächsten Moduloposition
0x0115 Modulo short extended
kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster)
0x0205 Modulo plus
Fahrt in positiver Drehrichtung zur nächsten Moduloposition
0x0215 Modulo plus extended
Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
0x0305 Modulo minus
Fahrt in negativer Drehrichtung zur nächsten Moduloposition
0x0315 Modulo minus extended
Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
0x0405 Modulo current
Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition
0x0415 Modulo current extended
Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
0x0006 Additive
neue Zielposition relativ / additiv zur letzten Zielposition
0x6000 Calibration, Plc cam
Kalibrierung mit Nocke
0x6100 Calibration, Hw sync
Kalibrierung mit Nocke und C-Spur
0x6E00 Calibration, set manual
Kalibrierung manuell setzen
0x6E01 Calibration, set manual auto
Kalibrierung automatisch setzen
0x6F00 Calibration, clear manual
Kalibrierung manuell löschen
UINT16
RO
0x0000 (0dez)
7040:23
Acceleration
Vorgabe der Beschleunigung
UINT16
RO
0x0000 (0dez)
7040:24
Deceleration
Vorgabe der Verzögerung
UINT16
RO
0x0000 (0dez)
Index 7050 POS Outputs Ch.2
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
7050:0
POS Outputs Ch.2
Max. Subindex
UINT8
RO
0x24 (36dez)
7050:01
Execute
Fahrauftrag starten (steigende Flanke), bzw. Fahrauftrag vorzeitig abbrechen (fallende Flanke)
BOOLEAN
RO
0x00 (0dez)
7050:02
Emergency stop
Fahrauftrag vorzeitig mit einer Notfallrampe abbrechen (steigende Flanke)
BOOLEAN
RO
0x00 (0dez)
7050:11
Target position
Vorgabe der Zielposition
UINT32
RO
0x00007FFF (32767dez)
7050:21
Velocity
Vorgabe der maximalen Sollgeschwindigkeit
INT16
RO
0x0000 (0dez)
7050:22
Start type
Vorgabe des Starttypen 0x0000 Idle
es wird kein Fahrauftrag ausgeführt
0x0001 Absolute
Zielposition absolut
0x0002 Relative
Zielposition relativ von Startposition aus
0x0003 Endless plus
Endlosfahrt in positiver Drehrichtung
0x0004 Endless minus
Endlosfahrt in negativer Drehrichtung
0x0105 Modulo short
kürzeste Entfernung zur nächsten Moduloposition
0x0115 Modulo short extended
kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster)
0x0205 Modulo plus
Fahrt in positiver Drehrichtung zur nächsten Moduloposition
0x0215 Modulo plus extended
Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
0x0305 Modulo minus
Fahrt in negativer Drehrichtung zur nächsten Moduloposition
0x0315 Modulo minus extended
Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
0x0405 Modulo current
Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition
0x0415 Modulo current extended
Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster)
0x0006 Additive
neue Zielposition relativ / additiv zur letzten Zielposition
0x6000 Calibration, Plc cam
Kalibrierung mit Nocke
0x6100 Calibration, Hw sync
Kalibrierung mit Nocke und C-Spur
0x6E00 Calibration, set manual
Kalibrierung manuell setzen
0x6E01 Calibration, set manual auto
Kalibrierung automatisch setzen
0x6F00 Calibration, clear manual
Kalibrierung manuell löschen
UINT16
RO
0x0000 (0dez)
7050:23
Acceleration
Vorgabe der Beschleunigung
UINT16
RO
0x0000 (0dez)
7050:24
Deceleration
Vorgabe der Verzögerung
UINT16
RO
0x0000 (0dez)


Informations- und Diagnostikdaten (kanalspezifisch)

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Informations- und Diagnostikdaten (kanalspezifisch)
Informations- und Diagnostikdaten (kanalspezifisch)
Index 9020 DCM Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9020:0 | DCM Info data Ch.1 | Max. Subindex | UINT8 | RO | 0x09 (9dez)
9020:01 | Status word | Statuswort (siehe Index App0) | UINT16 | RO | 0x0000 (0dez)
9020:02 | Motor coil voltage | Aktuelle Spulenspannung | UINT16 | RO | 0x0000 (0dez)
9020:03 | Motor coil current | Aktueller Spulenstrom | INT16 | RO | 0x0000 (0dez)
9020:04 | Current limit | Aktuelle Strombegrenzung | UINT16 | RO | 0x0000 (0dez)
9020:05 | Control error | Aktueller Regelfehler | INT16 | RO | 0x0000 (0dez)
9020:06 | Duty cycle | Aktueller Duty-Cycle | INT8 | RO | 0x00 (0dez)
9020:08 | Motor velocity | Aktuelle Motorgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
9020:09 | Overload time | Zeit seit Überlastung | UINT16 | RO | 0x0000 (0dez)
Index 9030 DCM Info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9030:0 | DCM Info data Ch.2 | Max. Subindex | UINT8 | RO | 0x09 (9dez)
9030:01 | Status word | Statuswort (siehe Index App0) | UINT16 | RO | 0x0000 (0dez)
9030:02 | Motor coil voltage | Aktuelle Spulenspannung | UINT16 | RO | 0x0000 (0dez)
9030:03 | Motor coil current | Aktueller Spulenstrom | INT16 | RO | 0x0000 (0dez)
9030:04 | Current limit | Aktuelle Strombegrenzung | UINT16 | RO | 0x0000 (0dez)
9030:05 | Control error | Aktueller Regelfehler | INT16 | RO | 0x0000 (0dez)
9030:06 | Duty cycle | Aktueller Duty-Cycle | INT8 | RO | 0x00 (0dez)
9030:08 | Motor velocity | Aktuelle Motorgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
9030:09 | Overload time | Zeit seit Überlastung | UINT16 | RO | 0x0000 (0dez)
Index 9040 POS Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9040:0 | POS Info data Ch.1 | Max. Subindex | UINT8 | RO | 0x04 (4dez)
9040:01 | Status word | Status word | UINT16 |  | 0x0000 (0dez)
9040:03 | State (drive controller) | aktueller Schritt der internen Statemachine | UINT16 | RO | 0xFFFF (65535dez)
9040:04 | Actual position lag | Aktueller Schleppabstand | UINT16 |  | 0x0000 (0dez)
Index 9050 POS Info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9050:0 | POS Info data Ch.2 | Max. Subindex | UINT8 | RO | 0x04 (4dez)
9050:01 | Status word | Status word | UINT16 | RO | 0x0000 (0dez)
9050:03 | State (drive controller) | aktueller Schritt der internen Statemachine | UINT16 | RO | 0xFFFF (65535dez)
9050:04 | Actual position lag | Aktueller Schleppabstand | UINT16 | RO | 0x0000 (0dez)
Index A020 DCM Diag data Ch.1
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
A020:0 | DCM Diag data Ch.1 | Max. Subindex |  | UINT8 | RO | 0x11 (17dez)
A020:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | Warnung | BOOLEAN | RO | 0x00 (0dez)
A020:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | Warnung | BOOLEAN | RO | 0x00 (0dez)
A020:03 | Torque overload | Aktueller Motorstrom ist größer als der Nennstrom (siehe 0x8020:02) | Warnung (8022:0A = 0) / Fehler (8022:0A = 1) | BOOLEAN | RO | 0x00 (0dez)
A020:04 | Under voltage | Versorgungsspannung kleiner als 7 V | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:05 | Over voltage | Versorgungsspannung 10 % größer, als die Nennspannung (siehe 0x8020:03) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:06 | Short circuit | Kurzschluss der Treiberstufe | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:08 | No control power | Treiberstufe ohne Spannungsversorgung | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:09 | Misc error | - Initialisierung fehlgeschlagen oder - Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05) oder - Motorstrom ist größer als der Nennstrom (siehe 0x8022:0A) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A020:0A | Configuration | CoE-Änderung wurde noch nicht in aktueller Konfiguration übernommen | Warnung | BOOLEAN | RO | 0x00 (0dez)
A020:11 | Actual operation mode | Aktuelle Betriebsart (bei automatischer Betriebsarterkennung, siehe 0x8022:01 |  | BIT4 | RO | 0x00 (0dez)
Index A030 DCM Diag data Ch.2
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
A030:0 | DCM Diag data Ch.1 | Max. Subindex |  | UINT8 | RO | 0x11 (17dez)
A030:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | Warnung | BOOLEAN | RO | 0x00 (0dez)
A030:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | Warnung | BOOLEAN | RO | 0x00 (0dez)
A030:03 | Torque overload | Aktueller Motorstrom ist größer als der Nennstrom (siehe 0x8030:02) | Warnung (0x8032:0A = 0) / Fehler (0x8032:0A = 1) | BOOLEAN | RO | 0x00 (0dez)
A030:04 | Under voltage | Versorgungsspannung kleiner als 7 V | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:05 | Over voltage | Versorgungsspannung 10 % größer, als die Nennspannung (siehe 0x8030:03) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:06 | Short circuit | Kurzschluss der Treiberstufe | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:08 | No control power | Treiberstufe ohne Spannungsversorgung | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:09 | Misc error | - Initialisierung fehlgeschlagen oder - Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05) oder - Motorstrom ist größer als der Nennstrom (siehe 0x8032:0A) | Fehler | BOOLEAN | RO | 0x00 (0dez)
A030:0A | Configuration | CoE-Änderung wurde noch nicht in aktueller Konfiguration übernommen | Warnung | BOOLEAN | RO | 0x00 (0dez)
A030:11 | Actual operation mode | Aktuelle Betriebsart (bei automatischer Betriebsarterkennung, siehe 0x8032:01 |  | BIT4 | RO | 0x00 (0dez)
Index A040 POS Diag data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A040:0 | POS Diag data Ch.1 | Max. Subindex | UINT8 | RO | 0x6 (6dez)
A040:01 | Command rejected | Fahrauftrag wurde abgewiesen | BOOLEAN | RO | 0x00 (0dez)
A040:02 | Command aborted | Fahrauftrag wurde abgebrochen | BOOLEAN | RO | 0x00 (0dez)
A040:03 | Target overrun | Zielposition wurde in entgegengesetzter Richtung überfahren | BOOLEAN | RO | 0x00 (0dez)
A040:04 | Target timeout | Der Motor hat nach Beendigung des Fahrauftrags innerhalb der konfigurierten Zeit (0x8040:0C), das Zielfenster (0x8040:0B) nicht erreicht | BOOLEAN | RO | 0x00 (0dez)
A040:05 | Position lag | Schleppabstand überschritten - Bei „Position lag max.” = 0 ist die Schleppabstandsüberwachung deaktiviert. Wird in „Position lag max.” ein Wert eingetragen, so wird dieser Wert mit “Actual position lag” verglichen. Sobald “Actual position lag” größer ist als “Position lag max.” wird “Position lag” = 1 gesetzt und ein PDO-Warning ausgegeben. | BOOLEAN | RO | 0x00 (0dez)
A040:06 | Emergency stop | Ein Nothalt wurde ausgelöst (automatisch oder manuell) | BOOLEAN | RO | 0x00 (0dez)
Index A050 POS Diag data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A050:0 | POS Diag data Ch.2 | Max. Subindex | UINT8 | RO | 0x6 (6dez)
A050:01 | Command rejected | Fahrauftrag wurde abgewiesen | BOOLEAN | RO | 0x00 (0dez)
A050:02 | Command aborted | Fahrauftrag wurde abgebrochen | BOOLEAN | RO | 0x00 (0dez)
A050:03 | Target overrun | Zielposition wurde in entgegengesetzter Richtung überfahren | BOOLEAN | RO | 0x00 (0dez)
A050:04 | Target timeout | der Motor hat nach Beendigung des Fahrauftrags innerhalb der konfigurierten Zeit (0x8050:0C), das Zielfenster (0x8050:0B) nicht erreicht. | BOOLEAN | RO | 0x00 (0dez)
A050:05 | Position lag | Schleppabstand überschritten - Bei „Position lag max.” = 0 ist die Schleppabstandsüberwachung deaktiviert. Wird in „Position lag max.” ein Wert eingetragen, so wird dieser Wert mit “Actual position lag” verglichen. Sobald “Actual position lag” größer ist als “Position lag max.”, wird “Position lag” = 1 gesetzt und ein PDO-Warning ausgegeben. | BOOLEAN | RO | 0x00 (0dez)
A050:06 | Emergency stop | ein Nothalt wurde ausgelöst (automatisch oder manuell) | BOOLEAN | RO | 0x00 (0dez)


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index F80F DCM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | DCM Vendor data | Max. Subindex | UINT8 | RO | 0x06 (6dez)
F80F:01 | PWM Frequency | Zwischenkreisfrequenz (Einheit: 1 Hz) | UINT16 | RW | 0x7530 (30000dez)
F80F:02 | Deadtime | Totzeit der Pulsweitenmodulation | UINT16 | RW | 0x0102 (258dez)
F80F:03 | Deadtime space | Duty Cycle Begrenzung | UINT16 | RW | 0x0009 (9dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung (Einheit: 1 °C) | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur (Einheit: 1 °C) | INT8 | RW | 0x64 (100dez)
F80F:06 | Analog trigger point | Triggerpunkt der AD-Wandlung | UINT16 | RW | 0x000A (10dez)


Informations- und Diagnostikdaten (gerätespezifisch)

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Informations- und Diagnostikdaten (gerätespezifisch)
Informations- und Diagnostikdaten (gerätespezifisch)
Index F900 DCM Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DCM Info data | Max. Subindex | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Softwareversion der Treiberkarte | STRING | RO |
F900:02 | Internal temperature | Interne Klemmentemperatur (Einheit: 1 °C) | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage | Steuerspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage | Lastspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time | gemessene Zykluszeit (Einheit: 1 µs) | UINT16 | RO | 0x0000 (0dez)


Standardobjekte

Inbetriebnahme [image] EL7342 - Objektbeschreibung und Parametrierung [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL7342
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 02
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 03
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1CAE3052 (481177682dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 ENC RxPDO-Par Control compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact Ch.1 | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1402 ENC RxPDO-Par Control compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | ENC RxPDO-Par Control compact Ch.2 | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 00 00 00 00
Index 1403 ENC RxPDO-Par Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | ENC RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 02 16 00 00 00 00
Index 1405 DCM RxPDO-Par Position Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | DCM RxPDO-Par Position Ch.1 | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 06 16 0A 16 0B 16
Index 1406 DCM RxPDO-Par Velocity Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | DCM RxPDO-Par Velocity Ch.1 | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 05 16 0A 16 0B 16
Index 1408 DCM RxPDO-Par Position Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1408:0 | DCM RxPDO-Par Position Ch.2 | PDO Parameter RxPDO 9 | UINT8 | RO | 0x06 (6dez)
1408:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 9 übertragen werden dürfen | OCTET-STRING[6] | RO | 09 16 0C 16 0D 16
Index 1409 DCM RxPDO-Par Velocity Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1409:0 | DCM RxPDO-Par Velocity Ch.2 | PDO Parameter RxPDO 10 | UINT8 | RO | 0x06 (6dez)
1409:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 10 übertragen werden dürfen | OCTET-STRING[6] | RO | 08 16 0C 16 0D 16
Index 140A POS RxPDO-Par Control compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
140A:0 | POS RxPDO-Par Control compact Ch.1 | PDO Parameter RxPDO 11 | UINT8 | RO | 0x06 (6dez)
140A:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 11 übertragen werden dürfen | OCTET-STRING[6] | RO | 05 16 06 16 0B 16
Index 140B POS RxPDO-Par Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
140B:0 | POS RxPDO-Par Control Ch.1 | PDO Parameter RxPDO 12 | UINT8 | RO | 0x06 (6dez)
140B:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 12 übertragen werden dürfen | OCTET-STRING[6] | RO | 05 16 06 16 0A 16
Index 140C POS RxPDO-Par Control compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
140C:0 | POS RxPDO-Par Control compact Ch.2 | PDO Parameter RxPDO 13 | UINT8 | RO | 0x06 (6dez)
140C:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 13 übertragen werden dürfen | OCTET-STRING[6] | RO | 08 16 09 16 0D 16
Index 140D POS RxPDO-Par Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
140D:0 | POS RxPDO-Par Control Ch.2 | PDO Parameter RxPDO 14 | UINT8 | RO | 0x06 (6dez)
140D:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 14 übertragen werden dürfen | OCTET-STRING[6] | RO | 08 16 09 16 0C 16
Index 1600 ENC RxPDO-Map Control compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 ENC RxPDO-Map Control compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | ENC RxPDO-Map Control compact Ch.2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1603 ENC RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | ENC RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x07 (7dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs Ch.2), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1604 DCM RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | DCM RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x05 (5dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7020:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7020:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7020:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1604:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1605 DCM RxPDO-Map Position Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | DCM RxPDO-Map Position Ch.1 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 DCM RxPDO-Map Velocity Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | DCM RxPDO-Map Velocity Ch.1 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (DCM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
Index 1607 DCM RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | DCM RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x05 (5dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x01 (Enable)) | UINT32 | RO | 0x7030:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x02 (Reset)) | UINT32 | RO | 0x7030:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7030:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1607:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1608 DCM RxPDO-Map Position Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1608:0 | DCM RxPDO-Map Position Ch.2 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x01 (1dez)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x11 (Position)) | UINT32 | RO | 0x7030:11, 32
Index 1609 DCM RxPDO-Map Velocity Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1609:0 | DCM RxPDO-Map Velocity Ch.2 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x01 (1dez)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (DCM Outputs Ch.2), entry 0x21 (Velocity)) | UINT32 | RO | 0x7030:21, 16
Index 160A POS RxPDO-Map Control compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160A:0 | POS RxPDO-Map Control compact Ch.1 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x05 (5dez)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7040:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7040:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160A:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7040:11, 32
Index 160B POS RxPDO-Map Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160B:0 | POS RxPDO-Map Control Ch.1 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x09 (9dez)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7040:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7040:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160B:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7040:11, 32
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7040:21, 16
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7040:22, 16
160B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7040:23, 16
160B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7040 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7040:24, 16
Index 160C POS RxPDO-Map Control compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160C:0 | POS RxPDO-Map Control compact Ch.2 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x05 (5dez)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x01 (Execute)) | UINT32 | RO | 0x7050:01, 1
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7050:02, 1
160C:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160C:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x11 (Target position)) | UINT32 | RO | 0x7050:11, 32
Index 160D POS RxPDO-Map Control Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160D:0 | POS RxPDO-Map Control Ch.2 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x09 (9dez)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x01 (Execute)) | UINT32 | RO | 0x7050:01, 1
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7050:02, 1
160D:03 | SubIndex 003 | 3. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
160D:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x11 (Target position)) | UINT32 | RO | 0x7050:11, 32
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x21 (Velocity)) | UINT32 | RO | 0x7050:21, 16
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x22 (Start type)) | UINT32 | RO | 0x7050:22, 16
160D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7050:23, 16
160D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7050 (POS Outputs Ch.2), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7050:24, 16
Index 1800 ENC TxPDO-Par Status compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1801 ENC TxPDO-Par Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status Ch.1 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1803 ENC TxPDO-Par Status compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Status compact Ch.2 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
1803:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1804 ENC TxPDO-Par Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Status Ch.2 | PDO Parameter TxPDO 5 | UINT8 | RO | 0x09 (9dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
1804:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 180A POS TxPDO-Par Status compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180A:0 | POS TxPDO-Par Status compact Ch.1 | PDO Parameter TxPDO 11 | UINT8 | RO | 0x06 (6dez)
180A:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 11 übertragen werden dürfen | OCTET-STRING[2] | RO | 0B 1A
Index 180B POS TxPDO-Par Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180B:0 | POS TxPDO-Par Status Ch.1 | PDO Parameter TxPDO 12 | UINT8 | RO | 0x06 (6dez)
180B:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 12 übertragen werden dürfen | OCTET-STRING[2] | RO | 0A 1A
Index 180C POS TxPDO-Par Status compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180C:0 | POS TxPDO-Par Status compact Ch.2 | PDO Parameter TxPDO 13 | UINT8 | RO | 0x06 (6dez)
180C:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 13 übertragen werden dürfen | OCTET-STRING[2] | RO | 0D 1A
Index 180D POS TxPDO-Par Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180D:0 | POS TxPDO-Par Status Ch.2 | PDO Parameter TxPDO 14 | UINT8 | RO | 0x06 (6dez)
180D:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 14 übertragen werden dürfen | OCTET-STRING[2] | RO | 0C 1A
Index 1A00 ENC TxPDO-Map Status compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 ENC TxPDO-Map Status compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Status compact Ch.2 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x11 (17dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1803 (ENC TxPDO-Par Status compact Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1803:09, 1
1A03:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A03:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A04 ENC TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x11 (17dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1804:09, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1A05 ENC TxPDO-Map Timest. compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact Ch.2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs Ch.2), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 32
Index 1A06 DCM TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | DCM TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0E (14dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6020:0C, 1
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6020:0D, 1
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A06:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A06:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1806, entry 0x09) | UINT32 | RO | 0x1806:09, 1
Index 1A07 DCM TxPDO-Map Synchron info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | DCM TxPDO-Map Synchron info data Ch.1 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x02 (2dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6020:11, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (DCM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6020:12, 16
Index 1A08 DCM TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | DCM TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x0E (14dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6030:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x02 (Ready)) | UINT32 | RO | 0x6030:02, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6030:03, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6030:04, 1
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6030:05, 1
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6030:06, 1
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6030:07, 1
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6030:0C, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x0D (Digital input 2)) | UINT32 | RO | 0x6030:0D, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1808, entry 0x09) | UINT32 | RO | 0x1808:09, 1
Index 1A09 DCM TxPDO-Map Synchron info data Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | DCM TxPDO-Map Synchron info data Ch.2 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x02 (2dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6030:11, 16
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (DCM Inputs Ch.2), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6030:12, 16
Index 1A0A POS TxPDO-Map Status compact Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | POS TxPDO-Map Status compact Ch.1 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x09 (9dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6040:01, 1
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6040:02, 1
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6040:03, 1
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6040:04, 1
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6040:05, 1
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6040:06, 1
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6040:07, 1
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0A:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A0B POS TxPDO-Map Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | POS TxPDO-Map Status Ch.1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x0C (12dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6040:01, 1
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6040:02, 1
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6040:03, 1
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6040:04, 1
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6040:05, 1
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6040:06, 1
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6040:07, 1
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0B:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6040:11, 32
1A0B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6040:21, 16
1A0B:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6040 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6040:22, 32
Index 1A0C POS TxPDO-Map Status compact Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | POS TxPDO-Map Status compact Ch.2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x09 (9dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x01 (Busy)) | UINT32 | RO | 0x6050:01, 1
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x02 (In-Target)) | UINT32 | RO | 0x6050:02, 1
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6050:03, 1
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6050:04, 1
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6050:05, 1
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6050:06, 1
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6050:07, 1
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0C:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A0D POS TxPDO-Map Status Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | POS TxPDO-Map Status Ch.2 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x0C (12dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x01 (Busy)) | UINT32 | RO | 0x6050:01, 1
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x02 (In-Target)) | UINT32 | RO | 0x6050:02, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x03 (Warning)) | UINT32 | RO | 0x6050:03, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x04 (Error)) | UINT32 | RO | 0x6050:04, 1
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6050:05, 1
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6050:06, 1
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6050:07, 1
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x11 (Actual position)) | UINT32 | RO | 0x6050:11, 32
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6050:21, 16
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6050 (POS Inputs Ch.2), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6050:22, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x06 (6dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1606 (5638dez)
1C12:05 | SubIndex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1607 (5639dez)
1C12:06 | SubIndex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1609 (5641dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A08 (6664dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | SubIndex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | SubIndex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | SubIndex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | SubIndex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | SubIndex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0003D090 (250000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0006 (6dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x06 (6dez)
F010:01 | SubIndex 001 | Profil Nummer des Encoder interface | UINT32 | RW | 0x000001FF (511dez)
F010:02 | SubIndex 002 | Profil Nummer des Encoder interface | UINT32 | RW | 0x000001FF (511dez)
F010:03 | SubIndex 003 | Profil Nummer des DC Motor Interface | UINT32 | RW | 0x000002DD (733dez)
F010:04 | SubIndex 004 | Profil Nummer des DC Motor Interface | UINT32 | RW | 0x000002DD (733dez)
F010:05 | SubIndex 005 | Profil Nummer des Positioning Interface | UINT32 | RW | 0x000002C0 (704dez)
F010:06 | SubIndex 006 | Profil Nummer des Positioning Interface | UINT32 | RW | 0x000002C0 (704dez)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
UL Hinweise
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


UL Hinweise

Anhang [image] UL Hinweise
UL Hinweise
Symbol cULus
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Symbol cULus
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
Symbol cULus
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1. UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2. UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Achtung
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL7332
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release Datum
01 | 01 | EL7332-0000-0016 | 2010/07
 | 02 | EL7332-0000-0017 | 2011/04
 | 03 |  | 2011/08
02 - 10* | 04 | EL7332-0000-0018 | 2011/09
 | 05 | EL7332-0000-0019 | 2011/12
 | 06 | EL7332-0000-0020 | 2012/02
 |  | EL7332-0000-0021 | 2012/09
 |  | EL7332-0000-0022 | 2012/11
 | 07* | EL7332-0000-0023 | 2013/01
EL7342
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release Datum
00 - 01 | 01 |  | 2009/12
 | 02 |  | 2009/12
02 - 12* | 03 | EL7342-0000-0016 | 2010/07
 | 04 | EL7342-0000-0017 | 2011/04
 | 05 |  | 2011/08
 | 06 | EL7342-0000-0018 | 2012/02
 |  | EL7342-0000-0019 | 2012/07
 | 07* | EL7342-0000-0020 | 2015/05
 |  | EL7342-0000-0021 | 2016/02
Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Achtung
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Gerätebeschreibung ESI-File/XML
Achtung
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Hinweis
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. „EEPROM Update“
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. „Auswahl des neuen ESI“. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Hinweis
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
Hinweis
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. „Anzeige FW-Stand EL3204“ wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.
Update Controller-Firmware *.efw
Hinweis
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. „Firmware Update“.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei
▪
Nach Beendigung des Download in INIT schalten, dann in OP
▪
Slave kurz stromlos schalten
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu "Eigenschaften" (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog "Advanced settings"
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.
Dialog "Weitere Eimstellungen" wählen
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,
Dialog "Schreibe FPGA" wählen
Datei auswählen
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.
Achtung
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!
Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. „Auswahl des PDO ‚Restore default parameters‘“)
Auswahl des PDO "Restore default parameters"
Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. „Eingabe des Restore-Wertes im Set Value Dialog“).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Hinweis
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:Dezimalwert: "1819238756", Hexadezimalwert: "0x6C6F6164"Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.