EL72x1-9014 - Servo-Motorklemmen, mit OCT und STO, 50 V DC
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation EtherCAT Geräte


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen und internationalen Normen und Regeln vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Dokumentenursprung
Diese Dokumentation ist in deutscher Sprache verfasst. Alle weiteren Sprachen werden von dem deutschen Original abgeleitet.
Aktualität
Bitte prüfen Sie, ob Sie die aktuelle und gültige Version des vorliegenden Dokumentes verwenden. Auf der Beckhoff Homepage finden Sie unter http://www.beckhoff.de/german/download/twinsafe.htm die jeweils aktuelle Version zum Download. Im Zweifelsfall wenden Sie sich bitte an den technischen Support.
Produkteigenschaften
Gültig sind immer nur die Produkteigenschaften, die in der jeweils aktuellen Anwenderdokumentation angegeben sind. Weitere Informationen, die auf den Produktseiten der Beckhoff Homepage, in E-Mails oder sonstigen Publikationen angegeben werden, sind nicht maßgeblich.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte unterliegen zyklisch einer Revision. Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft. Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen. Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.
Lieferbedingungen
Es gelten darüber hinaus die allgemeinen Lieferbedingungen der Fa. Beckhoff Automation GmbH & Co. KG.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Weiterführende Informationen
•
Auslieferungszustand
•
Sorgfaltspflicht des Betreibers
•
Erklärung der Sicherheitssymbole


Auslieferungszustand

Vorwort [image] Sicherheitshinweise [image] Auslieferungszustand
Auslieferungszustand
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.


Sorgfaltspflicht des Betreibers

Vorwort [image] Sicherheitshinweise [image] Sorgfaltspflicht des Betreibers
Sorgfaltspflicht des Betreibers
Der Betreiber muss sicherstellen, dass
▪
die TwinSAFE-Produkte nur bestimmungsgemäß verwendet werden (siehe Kapitel Produktbeschreibung).
▪
die TwinSAFE-Produkte nur in einwandfreiem, funktionstüchtigem Zustand betrieben werden.
▪
nur ausreichend qualifiziertes und autorisiertes Personal die TwinSAFE-Produkte betreibt.
▪
dieses Personal regelmäßig in allen zutreffenden Fragen von Arbeitssicherheit und Umweltschutz unterwiesen wird, sowie die Betriebsanleitung und insbesondere die darin enthaltenen Sicherheitshinweise kennt.
▪
die Betriebsanleitung stets in einem leserlichen Zustand und vollständig am Einsatzort der TwinSAFE-Produkte zur Verfügung steht.
▪
alle an den TwinSAFE-Produkten angebrachten Sicherheits- und Warnhinweise nicht entfernt werden und leserlich bleiben.


Erklärung der Sicherheitssymbole

Vorwort [image] Sicherheitshinweise [image] Erklärung der Sicherheitssymbole
Erklärung der Sicherheitssymbole
In der vorliegenden Betriebsanleitung werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.1
▪
Inbetriebnahme: Kapitel Quickstart hinzugefügt
▪
TwinCAT Entwicklungsumgebung: TwinCAT 3 hinzugefügt
1.0
▪
Erste Veröffentlichung
0.5
▪
vorläufige Version (nur zum internen Gebrauch)
0.4
▪
vorläufige Version (nur zum internen Gebrauch)
0.3
▪
vorläufige Version (nur zum internen Gebrauch)
0.2
▪
vorläufige Version (nur zum internen Gebrauch)
0.1
▪
vorläufige Version (nur zum internen Gebrauch)


Versionsidentifikation EtherCAT Geräte

Vorwort [image] Versionsidentifikation EtherCAT Geräte
Versionsidentifikation EtherCAT Geräte
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, .....)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge..
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u

D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen:
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Chargennummer
CU2016 Switch mit Chargennummer
EL3202-0020 mit Chargennummern 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP76 EtherCAT Safety Box mit Chargennummer 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/DateCode 50110302 und eindeutiger Seriennummer 00331701


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Produktübersicht Servo-Motorklemme
•
Einführung
•
Technische Daten
•
Technologie
•
Start


Produktübersicht Servo-Motorklemme

Produktübersicht [image] Produktübersicht Servo-Motorklemme
Produktübersicht Servo-Motorklemme
EL7201-9014 Servo-Motorklemme mit OCT und STO, 50 VDC, 2,8 Aeff
EL7211-9014 Servo-Motorklemme mit OCT und STO, 50 VDC, 4,5 Aeff


Einführung

Produktübersicht [image] Einführung
Einführung
EL7201-9014
EL7211-9014
Schnellverweise
Hinweise zum Anschluss
▪
Kapitel "Montage und Verdrahtung",
- LEDs und Anschlussbelegung
- Schirmkonzept
- Hinweise zur Strommessung über Hallsensor
Hinweise zur Konfiguration
▪
Kapitel "Inbetriebnahme",
- Konfiguration der wichtigsten Parameter
▪
Kapitel "Konfiguration mit dem TwinCAT System Manager",
- Objektbeschreibung und Parametrierung
Anwendungsbeispiel
▪
Kapitel "Inbetriebnahme",
- Anwendungsbeispiel
Servo-Motorklemmen mit OCT und STO-Eingang
Die Servomotor-EtherCAT-Klemmen EL7201-9014 (50 VDC, 2,8 Aeff) und EL7211-9014 (50 VDC, 4,5 Aeff), mit integriertem Absolutwert-Interface, bieten hohe Servo-Performance in sehr kompakter Bauform. Die EL72x1-9014 wurde für die Motortypen der Reihe AM81xx von Beckhoff Automation konzipiert.
Die schnelle Regelungstechnik, auf Basis einer feldorientierten Strom- und PI-Drehzahlregelung, unterstützt schnelle und hochdynamische Positionieraufgaben. Zahlreiche Überwachungen, wie der Über- und Unterspannung, des Überstroms, der Klemmentemperatur oder der Motorauslastung, über die Berechnung eines I²T-Modells, bieten ein Höchstmaß an Betriebssicherheit.
EtherCAT, als leistungsfähige Systemkommunikation, und CAN-over-EtherCAT (CoE), als Applikationsschicht, ermöglichen die ideale Anbindung an die PC-basierte Steuerungstechnik.
Neueste Leistungshalbleiter garantieren minimale Verlustleistung und ermöglichen beim Bremsbetrieb eine Rückspeisung in den Zwischenkreis.
Die LEDs zeigen Status-, Warn und Fehlermeldungen sowie eventuell aktive Limitierungen an.
Mit der One Cable Technology (OCT) wird die Geberleitung eingespart, indem die Signale des Gebers digital über das vorhandene Motorkabel übertragen werden. Das Einlesen der elektronischen Typenschilder der passenden Motoren der Serie AM81xx ermöglicht eine Plug-and-Play-Lösung und bietet höchsten Komfort bei der Inbetriebnahme.
Die EL72x1-9014 stellt einen STO-Eingang zur Verfügung, mit dem der an der Klemme angeschlossene Motor momentenfrei geschaltet werden kann. Dieser STO-Eingang wird mit einem sicheren Ausgang einer EL2904 beschaltet.
Für die Sicherheitsfunktion STO der EL72x1-9014 zusammen mit einer EL2904 wird ein Performance Level d, Kategorie 3 nach DIN EN ISO 13849-1:2015 erreicht.
Hinweis
Empfohlende TwinCAT-Version
Um die volle Performance der EL72x1-9014 in Anspruch nehmen zu können wird empfohlen, die EL72x1-9014 mit mindestens TwinCAT 2.11 R3 zu betreiben!
Hinweis
Obligatorische Hardware
Die EL72x1-9014 muss mit einem echtzeitfähigen Rechner und Distributed Clocks betrieben werden!
Hinweis
Freigegebene Motoren
Die EL72x1-9014 darf nur in Verbindung mit folgenden Beckhoff Motoren betrieben werden.
- AM8111-xF1x, AM8112-xF1x, AM8113-xF1x, AM8121-xF1x, AM8122-xF1x, AM8131-xF1x
- AM8111-xF2x, AM8112-xF2x, AM8113-xF2x, AM8121-xF2x, AM8122-xF2x, AM8131-xF2x


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Voraussetzungen
Technische Daten | EL7201-9014 | EL7211-9014
Anzahl Ausgänge | 3 Motorphasen, 2 Motorhaltebremse
Anzahl Eingänge | 2 (4) Zwischenkreisspannung, 2 absolutes Feedback, 2 digitale Eingänge. 1 STO-Eingang
Zwischenkreisversorgungsspannung | 8...50 VDC
Versorgungsspannung | 24 VDC über die Powerkontakte / über den E-Bus
Ausgangsstrom | 2,8 Aeff | 4,5 Aeff
Spitzenstrom | 5,7 Aeff für 1 Sekunde | 9 Aeff für 1 Sekunde
Nennleistung | 170 W | 276 W
Ausgangsspannung Motorhaltebremse | 24 V (+ 6 %, - 10 %)
Max. Ausgangsstrom Motorhaltebremse | max. 0,5 A
Lastart | Permanenterregte Synchronmotoren, induktiv (Baureihe AM81xx)
PWM Schaltfrequenz | 16kHz
Stromreglerfrequenz | doppelte PWM Schaltfrequenz
Geschwindigkeitsreglerfrequenz | 16 kHz
Diagnose-LED | Status, Warnung, Fehler und Limits
Verlustleistung | typ. 1,6 W
Stromaufnahme aus dem E-Bus | typ. 120 mA
Stromaufnahme aus den 24 V | typ. 55 mA + Haltebremse
Unterstützt Funktion NoCoeStorage | Ja
Verpolungsschutz | 24 V Spannungsversorgung: ja, durch Body-Diode der Überspannungsschutzeinrichtung 50 V Spannungsversorgung: ja, durch Body-Diode der Überspannungsschutzeinrichtung
Absicherung (vom Anwender durchzuführen) | 24 V Spannungsversorgung: 10 A 50 V Spannungsversorgung: 10 A
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
Mögliche EtherCAT-Zykluszeiten | Vielfaches von 125 µs
Konfiguration | keine Adresseinstellung erforderlich Konfiguration über TwinCAT System Manager
Gewicht | ca. 60 g | ca. 95 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 gemäß IEC/EN 61800-3
EMV Kategorie | Kategorie C3 - Standard Kategorie C2, C1 - Zusatzfilter erforderlich
Schutzart | IP20
Einbaulage | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2) siehe Hinweis
Zulassung | CE


Technologie

Produktübersicht [image] Technologie
Technologie
Die Servomotorklemme EL72x1-xxxx integriert einen vollwertigen Servoverstärker für Servomotoren bis 276 W in kleinster Bauform.
Servomotor
Der Servomotor ist ein elektrischer Motor. Zusammen mit einem Servoverstärker bildet der Servomotor einen Servoantrieb. Der Servomotor wird in einem geschlossenen Regelkreis positions-, moment- oder geschwindigkeitsgeregelt betrieben.
Die Servoklemme EL72x1-xxxx unterstützt die Ansteuerung von permanenterregten Synchronmotoren. Diese bestehen aus drei um 120° verschobenen Spulen und einen permanenterregten Rotor.
Drei um 120° verschobenen Spulen eines Synchronmotors
Besonders in hochdynamischen und präzise-positionierenden Anwendungen zeigen Servomotoren ihre Vorzüge:
▪
sehr hohe Positioniergenauigkeit bei Applikationen mit höchstem Präzisionsanspruch durch integrierte Positionsrückführung
▪
hoher Wirkungsgrad und hohes Beschleunigungsvermögen
▪
Servomotoren sind überlastbar und verfügen daher über eine weitaus höhere Dynamik als beispielsweise ein Schrittmotor
▪
belastungsunabhängiges hohes Drehmoment bis in die oberen Drehzahlbereiche
▪
reduzierter Einsatz von Wartung auf ein Minimum
Die EtherCAT-Servomotorklemme bietet dem Anwender die Möglichkeit kompakte und kostengünstige Anlagen zu konstruieren, ohne auf die Vorteile eines Servomotors verzichten zu müssen.
Die Beckhoff Servoklemme
Die EL72x1-xxxx ist ein vollwertiger Servoverstärker für den direkten Anschluss von Servomotoren im unteren Leistungsbereich. Weitere Module oder Verkabelung, um eine Verbindung zum Steuerungssystem herzustellen entfallen dadurch komplett. Das führt zu einer sehr kompakten Steuerungslösung. Durch die E-Bus-Anbindung der EL72x1-xxxx stehen dem Anwender die Eigenschaften von EtherCAT in vollen Zügen zur Verfügung. Dazu zählen insbesondere die kurze Zykluszeit, der niedrige Jitter, die Gleichzeitigkeit und die einfache Diagnose, die EtherCAT zu bieten hat. Mit Hilfe dieser Performance von EtherCAT kommt die Dynamik, die ein Servomotor erreichen kann, optimal zur Geltung.
Eine Nennspannung von max. 50 VDC und ein Nennstrom von max. 4,5 A ermöglichen es dem Anwender einen Servomotor mit einer Leistung von bis zu 276 W anzutreiben. Als Last können permanenterregte Synchronmotoren mit einem Nennstrom bis 4,5 A betrieben werden. Zahlreiche Überwachungen, z. B. der Über- und Unterspannung, des Überstroms, der Klemmentemperatur oder der Motorauslastung, bieten ein Höchstmaß an Betriebssicherheit. Moderne Leistungshalbleiter garantieren minimale Verlustleistung und ermöglichen, im Bremsbetrieb, eine Rückspeisung in den Zwischenkreis.
Mit der Integration eines vollwertigen Servoverstärkers in eine nur 12 mm breite EtherCAT-Klemme EL7201 setzt Beckhoff in Sachen Baugröße neue Maßstäbe. Diese geringe Baugröße ist dank neuster Halbleitertechnik und dem daraus resultierendem sehr hohem Leistungsfaktor möglich. Doch trotz der geringen Baugröße muss auf nichts verzichtet werden.
Die integrierte, schnelle Regelungstechnik, mit einer feldorientierten Strom- und PI-Drehzahlregelung unterstützt hochdynamische Positionieraufgaben. Neben dem direkten Anschluss von Motor und Resolver ist auch der Anschluss einer Motorhaltebremse möglich.
Die EL72x1-xx1x verfügt über 2 digitale Eingänge, die für die Funktion Touch Probe genutzt werden können. Der Status der Eingänge kann über die Select Info Data (Profil MDP 742 und DS 402) zurückgelesen werden.
Anbindung an die Steuerung
Ein weiterer großer Vorteil der EL72x1-xxxx ist die einfache Anbindung an die Steuerungslösung. Die vollständige Integration in das Steuerungssystem erleichtert die Inbetriebnahme und Parametrierung. Wie jede andere Beckhoff-Klemme wird die EL72x1-xxxx einfach in den Klemmenverbund eingeschoben. Anschließend kann der Klemmenverbund komplett vom TwinCAT System Manager eingescannt oder vom Applikateur manuell angefügt werden. Im System Manager kann die EL72x1-xxxx mit der TwinCAT NC verknüpft und parametriert werden.
Skalierbare Motion-Lösung
Die Servoklemme ergänzt die Produktpalette der Kompakt-Antriebstechnik für die Beckhoff I/O-Systeme, die für Schrittmotoren, AC- und DC-Motoren verfügbar sind. Mit der EL72x1-xxxx wird das Angebot an Servoverstärkern noch feiner skalierbar: Vom Kleinst-Servoverstärker bis 170 W, in der EtherCAT-Klemme, bis zum AX5000-Servoverstärker mit 118 kW, bietet Beckhoff ein breites Programm, inklusive der Servomotoren.
Die Baureihe AM81xx wurde speziell für die Servomotorklemme EL72x1-xxxx entwickelt.
Die One Cable Technology (OCT)
Bei den Servomotoren der Serie AM8100-xF2 x erfolgt die Übertragung der Feedback-Signale direkt über die Leitung zur Spannungsversorgung, sodass Power und Feedbacksystem in einem Motoranschlusskabel zusammengefasst sind. Durch die One Cable Technology werden die Informationen störsicher und zuverlässig über eine digitale Schnittstelle übertragen. Da sowohl motor- als auch reglerseitig Kabel und Steckverbinder entfallen, werden die Komponenten- und Inbetriebnahmekosten reduziert.
Thermisches Motormodell I²T
Das thermische I²T Motormodell bildet das thermische Verhalten der Motorwicklung unter Berücksichtigung des absoluten Wärmewiderstands Rth und der Wärmekapazität Cth des Motors und der Statorwicklung ab.
Im Modell wird angenommen, dass der Motor bei Dauerbetrieb mit Nennstrom Inenn seine maximale Dauerbetriebstemperatur Tnenn erreicht. Diese Temperatur entspricht einer Auslastung des Motors von 100%. Bei Betrieb mit Nennstrom erreicht das Motormodell nach einer Zeit von τth=Rth∙Cth eine Auslastung von 63% und erreicht langsam seine Dauerbetriebstemperatur.
Wird der Motor mit einem Strom größer dem Nennstrom betrieben, erreicht das Modell eine Auslastung von 100% schneller.
Überschreitet die Auslastung des I²T Modells den Wert von 100%, wird der angeforderte Sollstrom auf den Nennstrom limitiert, um die Motorwicklung thermisch zu schützen. Die Auslastung fällt auf maximal 100% zurück. Bei Unterschreiten des Nennstroms fällt die Auslastung auf unter 100% und die Limitierung des Sollstroms wird aufgehoben.
Bei einem vorher auf Umgebungstemperatur abgekühlten Motor kann die Zeit zum Erreichen von 100% Auslastung bei Bestromung mit einem Sollstrom größer als Nennstrom grob mit τth∙Inenn²/Iist² abgeschätzt werden.
Die exakte Berechnung des Durchtritts von 100% Auslastung erfordert die Kenntnis der aktuellen Auslastung.
Limitierung auf den Nennstroms des Motors


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL72x1-001x wie im Kapitel Montage und Verdrahtung beschrieben.
▪
konfigurieren Sie den EL72x1-001x in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT Grundlagen

Grundlagen der Kommunikation [image] EtherCAT Grundlagen
EtherCAT Grundlagen
Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Hinweis
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Achtung
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Hinweis
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Hinweis
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den Systemmanager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten. Andere Hersteller können dies anders handhaben.
Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.
Hinweis
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Hinweis
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Installation

Installation
Installation
Weiterführende Informationen
•
Sicherheitshinweise
•
Umgebungsbedingungen
•
Transportvorgaben / Lagerung
•
Schaltschrank / Klemmenkasten
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschlusstechnik
•
Montage von passiven Klemmen
•
Einbaulagen bei Betrieb mit und ohne Lüfter
•
Beispielkonfiguration zur Temperaturmessung
•
Schirmkonzept
•
Hinweise zur Strommessung über Hall-Sensor
•
EL72x1-9014 - LEDs und Anschlussbelegung


Sicherheitshinweise

Installation [image] Sicherheitshinweise
Sicherheitshinweise
Lesen Sie vor Installation und Inbetriebnahme der TwinSAFE-Komponenten auch die Sicherheitshinweise im Vorwort dieser Dokumentation.


Umgebungsbedingungen

Installation [image] Umgebungsbedingungen
Umgebungsbedingungen
Stellen Sie sicher, dass die TwinSAFE-Komponenten nur bei den spezifizierten Umgebungsbedingungen (siehe technische Daten) transportiert, gelagert und betrieben werden!
WARNUNG
Verletzungsgefahr!
Die TwinSAFE-Komponenten dürfen unter folgenden Betriebsbedingungen nicht eingesetzt werden.
•
unter dem Einfluss ionisierender Strahlung (die das Maß der natürlichen Umgebungsstrahlung überschreitet)
•
in korrosivem Umfeld
•
in einem Umfeld, das zu unzulässiger Verschmutzung der TwinSAFE-Komponente führt
Achtung
Elektromagnetische Verträglichkeit
Die TwinSAFE-Komponenten entsprechen den Anforderungen der geltenden Normen zur elektromagnetischen Verträglichkeit in Bezug auf Störausstrahlung und insbesondere auf Störfestigkeit.
Sollten jedoch in der Nähe der TwinSAFE-Komponenten Geräte (z.B. Funktelefone, Funkgeräte, Sendeanlagen oder Hochfrequenz-Systeme) betrieben werden, welche die in den Normen festgelegten Grenzen zur Störaussendung überschreiten, können diese ggf. die Funktion der TwinSAFE-Komponenten stören.


Transportvorgaben / Lagerung

Installation [image] Transportvorgaben / Lagerung
Transportvorgaben / Lagerung
Verwenden Sie zum Transport und bei der Lagerung der TwinSAFE-Komponenten die Originalverpackung in der die Komponenten geliefert wurden.
VORSICHT
Spezifizierten Umgebungsbedingungen beachten
Stellen Sie sicher, dass die digitalen TwinSAFE- Komponenten nur bei den spezifizierten Umgebungsbedingungen (siehe technische Daten) transportiert und gelagert werden.


Schaltschrank / Klemmenkasten

Installation [image] Schaltschrank / Klemmenkasten
Schaltschrank / Klemmenkasten
Die TwinSAFE-Klemmen müssen zum Betrieb in einen Schaltschrank oder Klemmenkasten montiert werden, der mindestens der Schutzart IP54 nach IEC 60529 entspricht.


Tragschienenmontage

Installation [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Installation [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschlusstechnik

Installation [image] Anschlusstechnik
Anschlusstechnik
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Hinweis
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Hinweis
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Hinweis
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Montage von passiven Klemmen

Installation [image] Montage von passiven Klemmen
Montage von passiven Klemmen
Hinweis
Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für Montage von passiven Klemmen (hell eingefärbt)
Korrekte Konfiguration
Inkorrekte Konfiguration


Einbaulagen bei Betrieb mit und ohne Lüfter

Installation [image] Einbaulagen bei Betrieb mit und ohne Lüfter
Einbaulagen bei Betrieb mit und ohne Lüfter
Achtung
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage bei Betrieb ohne Lüfter
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht.
Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!
Weitere Hinweise zum Betrieb ohne Lüfter sind ggf. den Technischen Daten der Klemme zu entnehmen.
Standard-Einbaulage bei Betrieb mit Lüfter
Für die Standard-Einbaulage beim Betrieb mit Lüfter wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Betrieb mit Lüfter“). Die Klemmen werden dabei unterstützend vom z. B. ZB8610 Lüftermodul von unten nach oben durchlüftet.
Empfohlene Abstände bei Betrieb mit Lüfter
Weitere Einbaulagen
Durch die verstärkende Wirkung auf die Kühlung der Klemmen durch den Lüfter sind ggf. weitere Einbaulagen zulässig (siehe Abb. „Weitere Einbaulagen, Beispiel 1 und 2“); entnehmen Sie entsprechende Hinweise bitte denn Technischen Daten der Klemme.

Weitere Einbaulagen, Beispiel 1
Weitere Einbaulagen, Beispiel 2


Beispielkonfiguration zur Temperaturmessung

Installation [image] Beispielkonfiguration zur Temperaturmessung
Beispielkonfiguration zur Temperaturmessung
Beispielkonfiguration zur Temperaturmessung
Die Beispielkonfiguration zur Durchführung der Temperaturmessung besteht aus einem EK1100 EtherCAT-Koppler an den Klemmen angereiht sind, die der typischen Verteilung der digitalen und analogen Signalformen an einer Maschine entsprechen. Auf der EL6900 ist ein Safety-Projekt aktiv, welches sichere Eingänge einliest und alle vier sicheren Ausgänge während der Messung einschaltet.
Hinweis
Fremderwärmung / Strahlungswärme / gestörte Konvektion
Die maximal zulässige Umgebungstemperatur von 55°C wurde mit obiger Beispielkonfiguration geprüft. Eine gestörte Konvektion, eine ungünstige Position in der Nähe von Wärmequellen oder ein ungünstiges Zusammenstellen der EtherCAT-Klemmen wirken sich ggf. negativ auf die interne Erwärmung der Klemmen aus.
Maßgeblich ist immer die maximal zulässige intern gemessene Temperatur von 95°C, ab der die TwinSAFE-Klemmen in den sicheren Zustand wechseln und einen Fehler melden. Die interne Temperatur kann über CoE aus der TwinSAFE-Komponente ausgelesen werden (siehe Kapitel Diagnose).


Schirmkonzept

Installation [image] Schirmkonzept
Schirmkonzept
Die vorkonfektionierten Leitungen von Beckhoff Automation bieten zusammen mit der Schirmschiene einen optimalen Schutz gegen elektro-magnetische Störungen.
Es wird empfohlen, den Schirm möglichst nah an der Klemme aufzulegen, um Störungen auf ein Minimum zu reduzieren.
Anschluss der Motorleitung an die Schirmschiene
Befestigen Sie die Schirmschienenträger 1 auf der Hutschiene 2. Die Tragschiene 2 muss großflächig mit der metallischen Rückwand des Schaltschranks verbunden sein. Montieren Sie die Schirmschiene 3 wie in Abb. „Schirmschiene“ abgebildet.
Alternativ kann ein Schirmschienen-Bügel 3a direkt mit der metallischen Rückwand des Schaltschranks verschraubt werden (Abb. „Schirmschienen-Bügel“)
Schirmschiene
Schirmschienen-Bügel
Verdrahten Sie die Adern 4 der Motorleitung 5 und befestigen Sie dann das kupferummantelte Ende 6 der Motorleitung 5 mit der Schirmschelle 7 an die Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Ziehen Sie die Schraube 8 bis zum Anschlag an.
Befestigen Sie die PE-Schelle 9 an die Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Klemmen Sie die PE-Ader 10 der Motorleitung 5 unter die PE-Schelle 9.
Schirmanbindung
Anschluss der Feedbackleitung an den Motor
Hinweis
Verdrillen der Feedbackleitungen
Die Feedbackleitungen sollten verdrillt werden, um Störeinflüsse zu minimieren.
Beim Anschrauben des Feedbacksteckers an den Motor wird der Schirmanschluss der Feedbackleitung über die metallische Steckerbefestigung hergestellt.
Auf der Klemmenseite kann der Schirm ebenfalls aufgelegt werden. Verdrahten Sie die Adern der Feedbackleitung und befestigen Sie das kupferummantelte Ende der Feedbackleitung mit der Schirmschelle 7 an der Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Motor- und Feedbackleitung können zusammen mit der Schraube 8 der Schirmschelle 7 aufgelegt werden.


Hinweise zur Strommessung über Hall-Sensor

Installation [image] Hinweise zur Strommessung über Hall-Sensor
Hinweise zur Strommessung über Hall-Sensor
Das in dieser Dokumentation angesprochene Gerät verfügt über einen oder mehrere integrierte Hall-Sensoren zur Strommessung.
Dabei wird das magnetische Feld, das durch einen Stromfluss durch einen Leiter erzeugt wird, von dem Hall-Sensor quantitativ erfasst.
Um die Messung nicht zu beeinträchtigen wird empfohlen, äußere Magnetfelder vom Gerät abzuschirmen oder hinreichend weit entfernt zu halten.
Hinweis
Hintergrund
Ein stromdurchflossener Leiter erzeugt in seinem Umfeld ein magnetisches Feld nach
B = µ0 * I / (2π * d)
mit
B [Tesla] magnetisches Feld
µ0 = 4*π*10-7 [H/m] (Annahme: keine magnetische Abschirmung)
I [A] Strom
d [m] Abstand zum Leiter
Hinweis
Beeinträchtigung durch äußere Magnetfelder
Die magnetische Feldstärke sollte allseitig um das Gerät herum eine zulässige Größe nicht übersteigen.
Praktisch bedeutet dies für den empfohlenen Mindestabstand eines benachbarten Stromleiters zur Geräteoberfläche:
- Strom 10 A: 12 mm
- Strom 20 A: 25 mm
- Strom 40 A: 50 mm
Wenn es in der Gerätedokumentation nicht anders spezifiziert ist, ist das Aneinanderreihen von Modulen (z.B. Reihenklemmen im 12 mm Rastermaß) gleichen Typs (z.B. EL2212-0000) darüber hinaus zulässig.


EL72x1-9014 - LEDs und Anschlussbelegung

Installation [image] EL72x1-9014 - LEDs und Anschlussbelegung
EL72x1-9014 - LEDs und Anschlussbelegung
EL7201-001x
EL7201-001x - LEDs
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
Drive OK | grün | an | Treiberstufe betriebsbereit
Limit | orange | an | Die LED ist mit dem Bit 11 des Statuswortes (MDP742 / DS402) verknüpft (Internal limit active) Limit erreicht (z. B. Torque- oder Drehzahllimit)
Read OCT | grün | blinkt | Das elektronische Typenschild wird gelesen
 |  | aus | Das Lesen des elektronischen Typenschilds wurde beendet
Warning | orange | blinkt | Fehler beim Lesen des Typenschildes
 |  | an | Die LED ist mit dem Bit 7 des Statuswortes (MDP742 / DS402) verknüpft (Warning) Der Schwellwert "Warning" ist überschritten. I²T-Modell Spannung am STO Eingang fehlt Temperatur (80°C) überschritten Spannung
Enable | grün | an | Die LED ist mit dem Bit 1 und 2 des Statuswortes (MDP742 / DS402) verknüpft (wenn "Switched on" oder "Operation enabled") Treiberstufe freigegeben
Error | rot | an | Die LED ist mit dem Bit 3 des Statuswortes (MDP742 / DS402) verknüpft (Fault) Der Schwellwert für "Error" ist überschritten. Überstrom STO bei aktiver Achse ausgelöst Spannung nicht vorhanden Resolver nicht angeschlossen max. Temperatur (100°C) überschritten
+24 V über Powerkontakte | grün | an | 24 V Spannungsversorgung für die Klemme liegen an.
DC Versorgung Zwischenkreis | grün | an | Spannung für den DC Versorgungs-Zwischenkreis liegt an.
Anschlussbelegung
EL7201-9014 Anschlussbelegung
Klemmstelle | Name | Kommentar
1 | OCT + | Positiver Eingang des absoluten Feedbacks
2 | Input 1 | Digitaler Eingang 1
3 | +24 V | Power Kontakt +24 V
4 | U | Motorphase U
5 | W | Motorphase W
6 | Brake + | Motorbremse +
7 | 50 V | Versorgung des DC Zwischenkreises + (8...50 V)
8
9 | OCT - | Negativer Eingang des absoluten Feedbacks
10 | Input 2 | Digitaler Eingang 2
11 | 0 V | Power Kontakt 0 V
12 | V | Motorphase V
13 | STO-Input | Eingang für STO Signal (24 V)
14 | Brake GND | Motorbremse 0 V
15 | 0 V | Versorgung des DC Zwischenkreises 0 V
16
EL7211-001x
EL7211-001x - LEDs
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
Drive OK | grün | an | Treiberstufe betriebsbereit
Limit | orange | an | Die LED ist mit dem Bit 11 des Statuswortes (MDP742 / DS402) verknüpft (Internal limit active) Limit erreicht (z. B. Torque- oder Drehzahllimit)
Read OCT | grün | blinkt | Das elektronische Typenschild wird gelesen
 |  | aus | Das Lesen des elektronischen Typenschilds wurde beendet
Warning | orange | blinkt | Fehler beim Lesen des Typenschildes
 |  | an | Die LED ist mit dem Bit 7 des Statuswortes (MDP742 / DS402) verknüpft (Warning) Der Schwellwert "Warning" ist überschritten. I²T-Modell Spannung am STO Eingang fehlt Temperatur (80°C) überschritten Spannung
Enable | grün | an | Die LED ist mit dem Bit 1 und 2 des Statuswortes (MDP742 / DS402) verknüpft (wenn "Switched on" oder "Operation enabled") Treiberstufe freigegeben
Error | rot | an | Die LED ist mit dem Bit 3 des Statuswortes (MDP742 / DS402) verknüpft (Fault) Der Schwellwert für "Error" ist überschritten. Überstrom STO bei aktiver Achse ausgelöst Spannung nicht vorhanden Resolver nicht angeschlossen max. Temperatur (100°C) überschritten
+24 V über Powerkontakte | grün | an | 24 V Spannungsversorgung für die Klemme liegen an.
DC Versorgung Zwischenkreis | grün | an | Spannung für den DC Versorgungs-Zwischenkreis liegt an.
Anschlussbelegung
EL7211-9014 Anschlussbelegung
Klemmstelle | Name | Kommentar
1 | OCT + | Positiver Eingang des absoluten Feedbacks
2 | Input 1 | Digitaler Eingang 1
3 | +24 V | Power Kontakt +24 V
4 | U | Motorphase U
5 | W | Motorphase W
6 | Brake + | Motorbremse +
7 | 50 V | Versorgung des DC Zwischenkreises + (8...50 V)
8
9 | OCT - | Negativer Eingang des absoluten Feedbacks
10 | Input 2 | Digitaler Eingang 2
11 | 0 V | Power Kontakt 0 V
12 | V | Motorphase V
13 | STO-Input | Eingang für STO Signal (24 V)
14 | Brake GND | Motorbremse 0 V
15 | 0 V | Versorgung des DC Zwischenkreises 0 V
16
1' - 16' |  | n.c.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Start up und Parameter-Konfiguration
•
Betriebsarten
•
Profile MDP 742 oder DS 402
•
Prozessdaten MDP742
•
Prozessdaten DS402


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Analog-Eingangsklemme -10…+10 V)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
Hinweis
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
Hinweis
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Achtung
Veränderung der "üblichen" Konfiguration durch Scan
➢
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
Hinweis
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Hinweis
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Hinweis
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Hinweis
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Hinweis
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Hinweis
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Achtung
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Achtung
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Hinweis
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to compatible device
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf AX5000-Geräten anzuwenden. Wenn aufgerufen, schlägt TwinCAT die Geräte vor die er im zugehörigen Unterordner findet, beim AX5000 z.B. in \TwinCAT\IO\EtherCAT\Beckhoff AX5xxx.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Hinweis
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Download-Revision
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Download-Revision

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Download-Revision
Download-Revision
Hinweis
Download-Revision in der Start-up Liste
Einzelne Klemmen / Module generieren automatisch den Eintrag aus Objekt 0xF081:01 in die Startup-Liste (vgl. Abb. „Download-Revision in der Startup Liste“).
Das Objekt 0xF081:01 (Download revision) beschreibt die Revision der Klemme / des Moduls, z. B. 0x0018000A für EL7201-0010-0024, und ist für die Erfüllung der Kompatibilität notwendig.
Es ist unbedingt darauf zu achten, dass dieser Eintrag nicht aus der Startup Liste gelöscht wird!
Download-Revision in der Startup Liste


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Hinweis
Aktivierung der PDO-Zuordnung
➢
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Start up und Parameter-Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration
Start up und Parameter-Konfiguration
Weiterführende Informationen
•
Einbindung in die NC-Konfiguration
•
Einstellungen mit dem Drive Manager
•
Einstellungen im CoE-Register
•
Einstellungen in der NC
•
Anwendungsbeispiel
•
Inbetriebnahme ohne die NC, Status-Wort/Control-Wort
•
Einstellungen der automatischen Konfiguration
•
Endschalter konfigurieren
•
Homing
•
Touch Probe


Einbindung in die NC-Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einbindung in die NC-Konfiguration
Einbindung in die NC-Konfiguration
(Master: TwinCAT 2.11 R3)
Hinweis
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen und entsprechend der Installationsanweisungen installiert werden.
Die Einbindung an die NC kann wie folgt durchgeführt werden:
▪
Die Klemme muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel "Konfigurationserstellung in TwinCAT").
Achse automatisch hinzufügen
▪
Nach dem erfolgreichen Einscannen der Klemmen erkennt TwinCAT automatisch die neuen Achsen. Es wird die Frage gestellt, ob die erkannten Achsen automatisch
hinzugefügt werden sollen (siehe Abb. Achse erkannt). Wenn dieses bestätigt wird, werden alle Achsen automatisch mit der NC verknüpft.
Achse erkannt
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapitel "Konfiguration der wichtigsten Parameter".
Stellen Sie bitte diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.
Achse manuell hinzufügen
▪
Fügen Sie zuerst einen neuen Task an. Dazu klicken Sie mit der rechten Maustaste auf NC-Konfiguration und wählen Sie "Task Anfügen..." aus (siehe Abb. Neuen Task einfügen).
▪
Benennen Sie gegebenenfalls den Task um und bestätigen Sie mit OK.
Neuen Task einfügen
▪
Wählen Sie mit der rechten Maustaste Achsen aus und fügen anschließend eine neue Achse an (siehe Abb. Auswahl einer neuen Achse).
Auswahl einer neuen Achse
▪
Wählen Sie unter Typ eine Kontinuierliche Achse aus und bestätigen Sie mit OK (siehe Abb. Achsentyp auswählen und bestätigen).
Achsentyp auswählen und bestätigen
▪
Markieren Sie Ihre Achse mit der linken Maustaste. Unter der Registerkarte Einstellungen wählen Sie "Verknüpft mit..." aus (siehe Abb. Verknüpfung der Achse mit der Klemme).
Verknüpfung der Achse mit der Klemme
▪
Wählen Sie die passende Klemme aus (CANopen DS402, EtherCAT CoE) und bestätigen Sie mit "OK ".
Auswahl der richtigen Klemme
▪
Alle wichtigen Verknüpfungen zwischen der NC-Konfiguration und der Klemme werden dadurch automatisch durchgeführt (siehe Abb. Automatische Verknüpfung aller wichtiger Variablen)
Automatische Verknüpfung aller wichtigen Variablen
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapiteln "Einstellungen im CoE" und "Einstellungen in der NC".
Stellen Sie bitte diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.


Einstellungen mit dem Drive Manager

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen mit dem Drive Manager
Einstellungen mit dem Drive Manager
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0000 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Hinweis
Einsatz des Drive Managers ab Revisionsstand -0019
Der Drive Manager wird erst ab der Revision -0019 der EL72x1-xxxx unterstützt. Sollten Sie eine ältere Version verwenden, müssen Sie die Einstellungen manuell durchführen. Sehen Sie dazu die Kapitel "Einstellungen im CoE" und "Einstellungen in der NC"
Inhaltsverzeichnis
• Start-up mit dem Drive Manager
• Anpassung weiterer Parameter mit dem Drive Manager
 - Integralanteil Geschwindigkeitsregler Tn
 - Proportionalanteil Geschwindigkeitsregler Kp
Sie finden den TwinCAT Drive Manager zum Download im AX5000-Download-Package.
Der TwinCAT Drive Manager für die Parametrierung einer EL72x1-xxxx Servoklemme ist in den System Manager integriert, so dass kein separates Konfigurationstool erforderlich ist. Nachdem eine Servoklemme erkannt oder eingetragen wurde, steht der TwinCAT Drive Manager im Karteireiter „Configuration“ (Konfiguration) zur Verfügung.
Die nachfolgenden Punkte sollen als Start-up dienen, um die Servoklemme in relativ kurzer Zeit in Betrieb nehmen zu können. Detaillierte Informationen zum Drive Manager entnehmen Sie bitte der zugehörigen Dokumentation "AX5000 Einführung in den TCDrivemanager"
Start-up mit dem Drive Manager
▪
Die Klemme muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel "Konfigurationserstellung in TwinCAT")
▪
Die Klemme muss bereits in der NC eingebunden sein (siehe Kapitel "Einbindung in die NC-Konfiguration")
▪
Wählen Sie den Karteireiter Configuration der EL72x1-xxxx.
▪
Unter Power Management können Sie die angeschlossene Spannung auswählen.
Auswahl der angeschlossenen Spannung
▪
Sie können anschließend unter Motor and Feedback den angeschlossenen Motor scannen oder auswählen. Sollten Sie sich für das automatische Scannen entscheiden, klicken Sie auf Scan motor and feedback. Anschließend wird automatisch das elektronische Typenschild der AM81xx-x2xx Motoren ausgelesen. Dazu ist es erforderlich, dass das automatische Scannen des Motors in der Klemme aktiviert ist (Index 0x8001, MDP oder Index 0x2018, DS402)
Automatisch Scannen des angeschlossenen Motors
▪
Sollten Sie sich für die manuelle Eingabe des angeschlossenen Motors entscheiden, klicken Sie bitte auf Select Motor.
Auswahl des angeschlossenen Motors
▪
Im Auswahlfenster können Sie den passenden Motor auswählen und mit Ok bestätigen.
Liste der verfügbaren Motoren
▪
Das nächste Dialogfenster sollte mit Ok bestätigt werden. Damit werden automatisch nötige Parameter in der NC eingetragen und der Skalierungsfaktor berechnet. Wird dies nicht bestätigt, müssen Sie diese Einstellungen manuell eintragen. Sehen Sie dazu Kapitel "Einstellungen in der NC".
Bestätigung der automatischen Einstellung der NC-Parameter
▪
Unter Scalings and NC Parameters können Sie die Skalierung bestimmen. Hier ist beispielhaft definiert, dass eine Motorumdrehung 360° entspricht. Alle nötigen Parameter werden automatisch angepasst. Die Einstellung wird erst übernommen, wenn Sie die Konfiguration aktivieren.
Anpassung der Skalierung
Damit sind alle wichtigen Parameter für die Inbetriebnahme des Motors eingestellt. Sie können den Motor nun beispielsweise mit der NC in Betrieb nehmen. Eine kurze Beschreibung hierzu finden Sie im Kapitel "Inbetriebnahme des Motors mit der NC". Oder Sie sprechen die NC aus der PLC heraus an. Auch dazu ist in der Dokumentation ein kleines hinzugefügt worden.
Sie haben weiterhin die Möglichkeit einige Parameter manuell in Ihrer Applikation anzupassen.
Anpassung weiterer Parameter mit dem Drive Manager
Die hier angegebenen Werte sind beispielhaft und haben in den meisten Fällen zu sehr guten Ergebnissen geführt. Je nach Applikation können andere Werte zu besseren Ergebnissen führen.
Sie können diese Werte im laufenden Betrieb ändern. Sobald Sie auf Download klicken, werden die Werte übernommen.
Integralanteil Geschwindigkeitsregler Tn
▪
Verringern Sie den Wert, bis der Motor anfängt leicht zu schwingen. Erhöhen Sie diesen Wert anschließend um 10%.
Anpassung Tn
Proportionalanteil Geschwindigkeitsregler Kp
▪
Erhöhen Sie den Wert, bis der Motor anfängt leicht zu schwingen. Verringern Sie diesen Wert anschließend auf 80%.
Anpassung Kp


Einstellungen im CoE-Register

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen im CoE-Register
Einstellungen im CoE-Register
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0001 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
• Einfügen der Motor XML-Datei
 - Anpassung von Strom und Spannung
• Einstellung weiterer Parameter
- Single turn bits / Multi turn bits
 - Torque limitation
- Integralanteil Geschwindigkeitsregler Tn
- Proportionalanteil Geschwindigkeitsregler Kp
Einfügen der Motor XML-Datei
Hinweis
Download der EL72x1-xxxx Motor XML-Dateien
Die Motor XML-Dateien können im Download-Bereich auf der Beckhoff Website herunter geladen werden.
Zur Erleichterung der Inbetriebnahme der Servoklemme EL72x1-xxxx wurden für die Servomotoren die von der EL72x1-xxxx unterstützt werden, Motor XML-Dateien erstellt. Diese XML-Dateien können im System Manager eingelesen werden.
Anschließend sind alle nötigen CoE-Parameter bzw. DS402-Parameter passend eingestellt.
▪
Zum Einlesen der Motor XML-Datei wählen Sie die EL72x1-xxxx aus und betätigen die Registerkarte Startup. Klicken Sie mit der rechten Maustaste in das leere Feld und wählen Sie Import from XML...(siehe Abb. Importieren der Motor XML-Datei).
Importieren der Motor XML-Datei
▪
Wählen Sie die passende Motor XML-Datei zum angeschlossenen Motor (siehe Abb. Auswahl der richtigen Motor XML-Datei)
Auswahl der richtigen Motor XML-Datei
▪
Anschließend sind alle nötigen Parameter eingestellt, um den Motor in Betrieb zu nehmen (siehe Abb. CoE Parameter der Motor XML-Datei).
CoE Parameter der Motor XML-Datei
Hinweis
Startup-Liste
Sollten applikationsabhängige Feineinstellungen nötig sein, sollten diese ebenfalls im Startup geändert werden. Andernfalls werden die geänderten Einstellungen beim nächsten Hochlauf der Klemme überschrieben.
Anpassung von Strom und Spannung
Achtung
Überhitzung des Motors möglich!
Um den angeschlossenen Motor nicht zu überhitzenist es wichtig, die Spannung die von der Servoklemme ausgegeben wird der tatsächlich angeschlossenen Spannung anzupassen.
Dazu muss der Index 0x8010:19 (0x2002:19, DS402-Profil) "Nominal DC Link Voltage" der angeschlossenen Spannung passend eingestellt werden
Einstellung weiterer Parameter
Singleturn Bits (MDP742: Index 0x8000:12 / DS402: Index 0x2010:12) / Multiturn Bits (MDP742: Index 0x8000:13 / DS402: Index 0x2010:13)
Hier kann der Anwender selber festlegen, wie viele Singleturn Bits und Multiturn Bits von der Klemme angezeigt werden sollen. Insgesamt stehen der Klemme 32 Bits zur Verfügung. Diese 32 Bits können beliebig aufgeteilt werden.
Standardmäßig sind 20 Singleturn Bits und 12 Multiturn Bits eingestellt.
Singleturn Bits: Anzahl der Bits, mit denen eine Rotordrehung aufgelöst wird.
Multiturn Bits: Nach einer Rotordrehung werden die Multiturn Bits um eins hochgezählt.
Hinweis
Überhitzung des Motors möglich!
Wird die Anzahl der Singleturn Bits geändert, muss der Skalierungsfaktor in der NC angepasst werden!
Multiturn / Singleturn bits
Torque limitation (MDP742: Index 0x7010:0B / DS402: Index 0x6072:0)
Limitiert den Strom / das Drehmoment auf diesen Wert. Der Wert wird in 1000stel vom "rated current" angegeben.
Integralanteil Geschwindigkeitsregler Tn (MDP742: Index 0x8010:14 / DS402: Index 0x2002:14)
Die hier angegebenen Werte sind beispielhaft und haben in den meisten Fällen zu sehr guten Ergebnissen geführt. Es kann aber je nach Applikation vorkommen, dass andere Werte zu besseren Ergebnissen führen.
▪
Verringern Sie den Wert, bis der Motor anfängt leicht zu schwingen. Erhöhen Sie diesen Wert anschließend um 10%.
Proportionalanteil Geschwindigkeitsregler Kp (MDP742: Index 0x8010:15 / DS402: Index 0x2002:15)
Die hier angegebenen Werte sind beispielhaft und haben in den meisten Fällen zu sehr guten Ergebnissen geführt. Es kann aber je nach Applikation vorkommen, dass andere Werte zu besseren Ergebnissen führen.
▪
Erhöhen Sie den Wert, bis der Motor anfängt leicht zu schwingen. Verringern Sie diesen Wert anschließend auf 80%.


Einstellungen in der NC

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen in der NC
Einstellungen in der NC
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8122-0F20-0000, der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
• Definition der Einheit
• Auswahl der max. Geschwindigkeit
• Totzeitkompensation
• Einstellungen der Geber-Maske
• Skalierungsfaktor
- Berechnung des Skalierungsfaktors
- Ausgabe Skalierung
• Schleppüberwachung Position
• Inbetriebnahme des Motors mit der NC
Für die Inbetriebnahme mit der NC sind einige wichtige Parameter notwendig. Diese sollten vor der Inbetriebnahme wie folgt eingestellt werden. Grundlegend für die Einstellung der folgenden Parameter ist die eingestellte Einheit, in der die NC arbeiten soll. Bei den folgenden Parametern wurde zu Grunde gelegt, dass eine Umdrehung 360° entspricht.
Definition der Einheit
Die Einheit kann in der Registerkarte Einstellungen der Achse definiert werden.
Definition der Einheit
Auswahl der max. Geschwindigkeit
Die maximale erlaubte Geschwindigkeit errechnet sich anhand der maximalen Motorgeschwindigkeit (Typenschild) und der zu verfahrenden Distanz. Hier bezogen auf 360° pro Sekunde.
Anpassung der Bezugsgeschwindigkeit
Die Bezugsgeschwindigkeit ist der maximalen erlaubten Geschwindigkeit gleichgestellt.
Darunter können bei Belieben noch die max. und min. Geschwindigkeit für den Handbetrieb der NC eingestellt werden.
Totzeitkompensation
Die Totzeitkompensation der Achse kann in der Registerkarte Time Compensation der Encodereinstellungen Achse1_ENC eingestellt werden. Sie sollte theoretisch 3 Zyklen der NC-Zykluszeit betragen, besser haben sich jedoch 4 Zyklen der NC-Zykluszeit erwiesen. Dazu sollten die Parameter Time Compensation Mode Encoder auf ‚ON (with velocity)‘ und Encoder Delay in Cycles auf 4 eingestellt sein.
Parameter Totzeitkompensation
Einstellung der Geber-Maske
In der Registerkarte Parameter der Encodereinstellungen Achse1_ENC können die maximalen Werte für die Geber-Maske eingestellt werden. Die EL72x1-xxxx stellt für den Geber maximal 32 Bit zur Verfügung.
Mit dem Parameter Geber-Maske (Maximalwert des Gebers) kann die Anzahl der Bits eingestellt werden, die maximal zur Verfügung stehen sollen. Im Default steht hier 0xFFFF FFFF, das entspricht 32 Bit (20 Singleturn Bits und 12 Multiturn Bits). Berechnen lässt sich das mit der folgenden Formel.
Der Parameter Geber-Sub-Maske (Maximalwert des Absolutbereichs) gibt an, wie viele Bits vom Maximalwert des Gebers Singleturn Bits sein sollen. Im Default sind es 20 (und damit 12 Multiturn Bits). Das kann mit folgender Formel berechnet werden.
Ein weiteres Rechenbeispiel mit 13 Singleturn Bits und 8 Multiturn Bits.
Einstellung der Geber-Maske
Skalierungsfaktor
Den Skalierungsfaktor können Sie ändern, wenn Sie in der NC Achse 1_Enc und die Registerkarte Parameter auswählen (siehe Abb. Skalierungsfaktor einstellen). Der Wert lässt sich mit den unten angegebenen Formeln berechnen. Bei der Berechnung wird zur Grunde gelegt, dass eine Umdrehung 360° entspricht.
In die Berechnung des Skalierungsfaktors fließt die Anzahl der Singleturn Bits mit ein. Wie bereits beschrieben, rechnet die EL72x1-xxxx im Default mit 20 Singleturn Bits. Mit diesem Wert wird im Folgenden auch der Skalierungsfaktor berechnet. Sollte sich der Wert der Singleturn Bits ändern, muss der Skalierungsfaktor angepasst werden.
Berechnung des Skalierungsfaktors
Skalierungsfaktor einstellen
Ausgabe Skalierung
Bitte tragen Sie in der Registerkarte Parameter der Drive-Einstellungen, beim Parameter Ausgabeskalierung (Geschw.) den Wert 32 ein.
Ausgabeskalierung
Schleppüberwachung Position
Die Schleppabstandsüberwachung kontrolliert, ob der aktuelle Schleppabstand einer Achse einen Grenzwert überschreitet. Als Schleppabstand wird die Differenz zwischen ausgegebenem Sollwert (Stellgröße) und dem rückgemeldeten Istwert bezeichnet. Sind die Parameter der Klemme noch unzureichend eingestellt, kann es dazu führen, dass beim Verfahren der Achse die Schleppabstandsüberwachung einen Fehler ausgibt. Bei der Inbetriebnahme kann es deswegen eventuell von Vorteil sein, wenn man die Grenzen der Schleppüberwachung Position etwas erhöht.
Achtung
Beschädigung von Geräten, Maschinen und Peripherieteilen möglich!
Bei der Parametrierung der Schleppüberwachung können durch Einstellen zu hoher Grenzwerte Geräte, Maschinen und Peripherieteile beschädigt werden!
Schleppüberwachung
Inbetriebnahme des Motors mit der NC
▪
Sind die Parameter eingestellt, dann ist der Motor prinzipiell betriebsbereit. Einzelne weitere Parameter müssen der jeweiligen Applikation angepasst werden.
▪
Um die Achse in Betrieb zu nehmen, aktivieren Sie die Konfiguration (Ctrl+Shift+F4), markieren die Achse, wählen die Registerkarte Online aus und geben unter Set die Achse frei.
▪
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Achse freigeben). Anschließend kann die Achse bewegt werden.
Achse freigeben
Sie können nun die Achse mit Hilfe der Funktionstasten F1, F2 (Rückwärts) und F3, F4 (Vorwärts) bewegen.
Sie können hier den Kv Faktor verstellen und sich somit an einen passenden Faktor herantasten. Stellen Sie zunächst 0 ein, um die richtige Bezugsgeschwindigkeit einzustellen. Wie die Bezugsgeschwindigkeit berechnet wird, entnehmen Sie bitte dem Kapitel "Auswahl der max. Geschwindigkeit". Die Berechnung gibt einen relativ genauen Wert an, Sie müssen diesen Wert gegebenenfalls noch etwas korrigieren. Verfahren Sie dazu den Motor mit einem Kv Faktor von 0 und achten Sie darauf, dass die Ist-Geschwindigkeit mit der Soll-Geschwindigkeit übereinstimmt.
Eine andere Möglichkeit besteht darin, unter der Registerkarte Funktionen, die Achse anzusteuern. Nachfolgend ein Beispiel dazu.
▪
Wählen Sie als Starttyp Reversing Sequence.
▪
Geben Sie eine gewünschte Zielposition2 an, z. B. 12000°.
▪
Geben Sie eine gewünschte Zielgeschwindigkeit an, z. B. 12000°/s.
▪
Geben Sie eine gewünschte Zielposition1 an, z. B. 0°.
▪
Geben Sie den gewünschte Idle Time an, z.B. 2 s.
▪
Wählen Sie Start.
Reversing Sequence
Nun dreht sich Ihr Motor auf die Position 2, verbleibt dort 2 s und fährt wieder auf die Position 1. Das wird wiederholt, bis Sie das mit "Stop" beenden.


Anwendungsbeispiel

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Anwendungsbeispiel
Anwendungsbeispiel
Hinweis
Installation der neuesten XML-Device-Description
Stellen Sie sicher, dass Sie die entsprechende aktuellste XML-Device-Description in TwinCAT installiert haben. Diese kann im Download-Bereich auf der Beckhoff Website heruntergeladen und entsprechend der Installationsanweisungen installiert werden.
Motoransteuerung mit Visualisierung
Download ( ):
Verwendeter Master: TwinCAT 2.11 (bei älteren Versionen muss der Regelkreis manuell programmiert werden, der in diesem Fall bereits in der NC implementiert ist).
Mit diesem Anwendungsbeispiel lässt sich ein Motor mit Hilfe der Visualisierung in eine beliebige Position fahren oder im Endlosmodus betreiben. Dabei kann die Geschwindigkeit, die Anfahrbeschleunigung und die Bremsbeschleunigung festgelegt werden.
Das Beispielprogramm besteht aus 2 Dateien (PLC-Datei und System Manager Datei).
Öffnen Sie zunächst die PLC-Datei und kompilieren Sie die Datei, damit Sie für den Systemmanager die *.tpy Datei zur Verfügung haben.
Beachten Sie, dass Sie im PLC-Programm gegebenenfalls die Zielplattform anpassen müssen (default: PC oder CX 8x86). Sollten Sie das ändern müssen, können Sie unter der Registerkarte Ressourcen -> Steuerungskonfiguration die richtige Zielplattform auswählen.
Auswahl der Zielplattform
Bei der System Manager Datei muss folgendes beachtet werden:
▪
Starten Sie den System Manager im Konfig-Modus.
▪
Stellen Sie sicher, dass die E/A-Konfiguration mit Ihrer tatsächlichen Konfiguration übereinstimmt. Im Beispielprogramm ist nur eine EL7041 integriert. Wenn Sie weitere Klemmen angeschlossen haben, müssen Sie diese zusätzlich einfügen oder Ihre Konfiguration neu einscannen.
▪
Sie müssen die MAC-Adresse anpassen. Klicken Sie dazu auf Ihr EtherCAT-Gerät, anschließend wählen Sie die Registerkarte Adapter und klicken hinter der MAC-Adresse auf Suchen (siehe Abb. Auswahl der MAC-Adresse). Dort wählen Sie den richtigen Adapter aus.
Auswahl der MAC-Adresse
▪
Bei der SPS-Konfiguration muss der Pfad des SPS-Programms angepasst werden. Klicken Sie dazu auf das angefügte SPS-Programm und wählen Sie die Registerkarte IEC1131 aus (siehe Abb. Ändern des SPS-Pfades). Dort müssen Sie Ändern anwählen und den richtigen Pfad bestimmen.
Ändern des SPS-Pfades
▪
Unter NC-Konfiguration ist bereits eine EL7041 mit der NC verknüpft. Sollten Sie diese neu verknüpfen müssen oder zusätzliche hinzufügen wollen, dann gehen Sie bitte wie im Kapitel "Einbindung in die NC-Konfiguration" vor.
Das PLC-Programm setzt sich wie folgt zusammen. Die Bibliotheken TcMC.lib und TcNC.lib müssen eingebunden werden (siehe Abb. Erforderliche Bibliotheken).
Erforderliche Bibliotheken
Anschließend werden einige globale Variablen deklariert (siehe Abb. Globale Variablen). Die Datentypen PLCTONC_AXLESTRUCT und NCTOPLC_AXLESTRUCT sorgen für die Kommunikation zwischen der PLC und der NC.
Globale Variablen
Nachdem die globalen Variablen deklariert worden sind, können Sie mit der Programmierung starten. Dazu deklarieren Sie vorerst die lokalen Variablen (siehe Abb. Lokale Variablen).
MC_Direction ist ein Aufzählungstyp, der dem Baustein MC_MoveVelocity die Bewegungsrichtung vorgibt, der wiederum eine Endlosfahrt des Motors durchführt.
Mit dem Funktionsbaustein MC_Reset wird ein Reset der Achse durchgeführt. MC_MoveAbsolute ist ein Funktionsbaustein mit dem eine absolute Positionierung durchgeführt wird. Mit dem Funktionsbaustein MC_ReadActualPosition kann die aktuelle Position der Achse gelesen werden.
MC_Power gibt die Achse frei und MC_Stop wird für das Stoppen der Achse benötigt.
Lokale Variablen
Der Programmcode lautet wie folgt (siehe Abb. Programmcode):
Programmcode
Mit Hilfe der folgenden Visualisierung (siehe Abb. Visualisierung) kann der Motor anschließend betrieben werden.
Bitte betätigen Sie den Taster Enable, um die Freigaben für die Achse zu setzen. Sie können jetzt im "Free run mode" den Taster Left oder Right betätigen und der Motor dreht sich mit einer im fbMoveVelocity_Axis_1 definierten Geschwindigkeit, in die ausgewählte Richtung, oder Sie können im "Absolute mode" Geschwindigkeit, Beschleunigung, Bremsbeschleunigung und die anzufahrende Position angeben und mit Start Job die Fahrt starten. Wenn Sie bei der Beschleunigung und der Bremsbeschleunigung nichts angeben, wird der Default-Wert der NC benutzt.
Visualisierung
Hinweis
Informationen zu Funktionsbausteinen und Datentypen
Weitere Informationen zu den verwendeten Funktionsbausteinen und Datentypen erhalten Sie im aktuellen Beckhoff Information System.


Inbetriebnahme ohne die NC, Status-Wort/Control-Wort

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Inbetriebnahme ohne die NC, Status-Wort/Control-Wort
Inbetriebnahme ohne die NC, Status-Wort/Control-Wort
(Master: TwinCAT 2.11 R3)
Die Betriebsarten CST, CSTCA, CSV und CSP lassen sich grundsätzlich auch ohne die TwinCAT NC betreiben.
Endstufe freigeben über Control-Wort
Für jede Betriebsart ist es notwendig, die Endstufe freizugeben. Dazu müssen über die PLC im Control-Wort (MDP742 / DS402) die folgenden Werte in der angegeben Reihenfolge eingeben werden (siehe Abb. DS402 State Machine ).
Im Statusl-Wort (MDP742 / DS402) werden die entsprechenden Statusmeldungen ausgegeben.
0hex
80hex (Fault reset)
6hex (Shutdown)
7hex (Switch on)
Fhex (Enable operation)
DS402 State Machine
CST - cyclic synchronous torque
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of operation (DS402) muss Cyclic synchronous torque mode gewählt werden. In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous torque mode (CST)' gewählt werden (siehe CoE-Prozessdaten oder DS402-Prozessdaten). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehmen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Servoklemme tatsächlich befindet.
Über die PLC kann in der Variable Target torque ein definiertes Moment eingestellt werden, auf dem die Servoklemme regeln soll. Das Moment wird in 1000stel des Nennstroms angegeben. Sollte dort beispielsweise 1000dec angegeben werden, entspricht das dem eingestellten Index 0x8011:12 Rated current (MDP) bzw. Index 0x6075:0 Motor rated current (DS402). Der Wert 1dec entspricht einem 1000stel des Nennstroms.
CSTCA - cyclic synchronous torque with commutation angle
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0Modes of operation (DS402) muss Cyclic synchronous torque mode with commutation angle gewählt werden. In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous torque mode with commutation angle mode (CSTCA)' gewählt werden (siehe CoE-Prozessdaten oder DS402-Prozessdaten). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehmen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Servoklemme tatsächlich befindet.
Über die PLC kann in der Variable Target torque ein definiertes Moment eingestellt werden, auf dem die Servoklemme regelt und in der Variable Commutation angle kann der Winkel angegeben werden, der mit dem eingestellten Moment gehalten werden soll. Das Moment wird in 1000stel des Nennstroms angegeben. Sollte dort beispielsweise 1000dec angegeben werden, entspricht das dem eingestellten Index 0x8011:12 Rated current (MDP) bzw. Index 0x6075:0 Motor rated current (DS402). Der Wert 1dec entspricht einem 1000stel des Nennstroms.
Der Wert für den Winkel muss umgerechnet werden, 65536dec entsprechen 360°.
CSV - cyclic synchronous velocity
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of operation (DS402) muss Cyclic synchronous velocity gewählt werden. In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous velocity mode (CSV)' gewählt werden (siehe CoE-Prozessdaten oder DS402-Prozessdaten). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehmen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Servoklemme tatsächlich befindet.
Über die PLC kann in der Variable Target velocity 0x7010:06 (MDP) oder 0x60FF:0 (DS402) eine definierte Drehzahl eingestellt werden, auf dem die Servoklemme regeln soll. Der konstante Wert Velocity encoder resolution im CoE Objekt 0x9010:14 (MDP) oder 0x6090:0 (DS402) entspricht 1 Umdrehung pro Sekunde. Wird dieser Wert in Target velocity eingetragen, dreht der Motor 1 Umdrehung / s, ein entsprechendes Vielfaches vom Wert Velocity encoder resolution bei Target velocity eingtragen, erhöht die Geschwindigkeit.
CSP - cyclic synchronous position
Im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of operation (DS402) muss Cyclic synchronous position gewählt werden.
In den jeweiligen Prozessdaten sollte ebenfalls das Predefined PDO Assignment: 'Cyclic synchronous position mode (CSP)' gewählt werden (siehe CoE-Prozessdaten oder DS402-Prozessdaten). Anschließend muss die Konfiguration neu geladen werden, um die Auswahl zu übernehemen.
Unter dem Index 0x6010:03 Modes of operation display (MDP) oder dem Index 0x6061:0 Modes of operation display (DS402) kann überprüft werden, in welchem Modus sich die Servoklemme tatsächlich befindet.
Über die PLC kann in der Variable Target position 0x7010:05 (MDP) oder 0x607A:0 (DS402) eine definierte Position eingestellt werden, auf die der Motor fahren soll. Bei der Berechnung der Position wird der berechnete Skalierungsfaktor zugrunde gelegt. Der in der Variable Target position eingetragene Wert muss mit dem berechneten Skalierungsfaktor multipliziert werden.


Einstellungen der automatischen Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einstellungen der automatischen Konfiguration
Einstellungen der automatischen Konfiguration
(Master TwinCAT 2.11 R3)
Die EL72x1-xxxx bietet dem Anwender die Möglichkeit, den angeschlossenen Motor der Baureihe AM81xx automatisch zu konfigurieren. Dabei wird das im Motor integrierte elektronische Typenschild ausgelesen und die notwendigen Parameter der Klemme entsprechend angepasst.
Die automatische Konfiguration ist im Auslieferungszustand ausgeschaltet. Der Anwender hat die Möglichkeit, die automatische Konfiguration entsprechend des unten ersichtlichen Flussdiagramms (siehe Abb. Flussdiagramm der automatischen Konfiguration) anzupassen.
Hinweis
Überschreibung der Parameter bei Automatischer Konfiguration
Die vom Anwender manuell geänderten Parameter der Parameterliste der automatischen Konfiguration werden beim nächsten Starten automatisch überschrieben, wenn die automatische Konfiguration eingeschaltet ist.
▪
Die automatische Konfiguration kann im Index 0x8001:01 (0x2018:01, DS402 Profil) Enable autoconfig eingeschaltet werden.
▪
Im Index 0x8001:02 (0x2018:02, DS402 Profil) Reconfig identical motor kann der Anwender entscheiden, ob im Austauschfall eines identischen Motors, die Klemme den Motor automatisch neu konfigurieren soll (Einstellung = true) oder der Motor mit den gespeicherten Einstellungen betrieben werden soll (Einstellung = false). Die Deaktivierung dieser Funktion kann beispielsweise von Vorteil sein, wenn der Anwender den Motor speziell auf seine Anwendung eingestellt hat und diese Einstellungen nach einem Austausch des Motors nicht verlieren möchte.
▪
Im Index 0x8001:03 (0x2018:03, DS402 Profil) Reconfig non-identical motor kann der Anwender entscheiden, ob im Austauschfall eines nicht-identischen Motors, die Klemme den Motor automatisch neu konfigurieren soll (Einstellung = true) oder der Motor mit den gespeicherten Einstellungen betrieben werden soll (Einstellung = false).
Flussdiagramm der automatischen Konfiguration
Parameterliste der automatischen Konfiguration
Folgende Parameter sind von der automatischen Konfiguration betroffen.
Index (hex) |  | Bezeichnung | Bedeutung
MDP 407 Profil | DS402 Profil
8010:12 | 2002:12 | Current loop integral time | wird nach dem symmetrischen Optimum berechnet
8010:13 | 2002:13 | Current loop proportional gain | wird nach dem symmetrischen Optimum berechnet
8011:11 | 2003:11 | Max. current | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:12 | 2003:12 | Rated current | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:13 | 2003:13 | Motor pole pairs | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:15 | 2003:15 | Commutation offset | wird immer auf -90° gesetzt
8011:16 | 2003:16 | Torque constant | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:18 | 2003:18 | Rotor moment of inertia | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:19 | 2003:19 | Winding inductance | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:1B | 2003:1B | Motor speed limitation | Berechnung der max. Geschwindigkeit des angeschlossenen Motors
8011:2B | 2003:2B | Motor temperature warn level | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:2C | 2003:2C | Motor temperature error level | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8011:2D | 2003:2D | Motor thermal time constant | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8012:11 | 2004:11 | Release delay | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8012:12 | 2004:12 | Application delay | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen
8012:14 | 2004:14 | Brake moment of inertia | wird aus dem elektronischen Typenschild des angeschlossenen Motors direkt übernommen


Endschalter konfigurieren

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Endschalter konfigurieren
Endschalter konfigurieren
Software-Endlagenüberwachung
Mittels der TwinCAT NC kann für die EL72x1-xxxx eine Software-Endlagenüberwachung eingestellt werden. Diese Überwachung dient der Sicherheit der Anlage. Die eingestellte Position wird von der Achse nicht überschritten (max. Endlage) bzw. unterschritten (min. Endlage). In der Registerkarte Parameter der entsprechenden Achse kann die jeweilige Endlagenüberwachung eingeschaltet werden.
Pulldown-Menü zum Einschalten der Endlagenüberwachung
Endschalter
Die Möglichkeit einen Endschalter direkt an die Klemme zu verdrahten der direkt ausgewertet wird, besteht nicht. Alternativ kann der Endschalter über eine digitale Eingangsklemme eingelesen oder die Software-Endlagenüberwachung genutzt werden.


Homing

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Homing
Homing
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0000 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Inhaltsverzeichnis
• Referenzierung
 - Funktionsbaustein "MC_Home"
 - Referenz Modi
Referenzierung
Die Referenzierung funktioniert nicht über den Online-Inbetriebnahme-Reiter der Achse (siehe Abb. Online-Homing in der NC).
Online-Homing in der NC
Funktionsbaustein "MC_Home"
▪
Die Referenzierung muss aus der SPS heraus durchgeführt werden. Dazu wird hier der Funktionsbaustein MC_Home aus der TC MC2 Lib genutzt.
▪
Folgende minimale Beschaltung ist in dem MC_Home notwendig.
–
der HomingMode, mit dem Sie auswählen können, welchen Modus Sie für die Referenzierung nutzen möchten.
–
der Execute, mit dem Sie die Referenzfahrt starten können.
–
der bCalibrationCam, der mit Ihrer Referenznocke verknüpft werden muss, um die Referenzfahrt zu stoppen.
Beschaltung des MC_Home Bausteins
▪
In der folgenden Abb. Auszug der Funktionsbeschreibung des MC_Home sehen Sie einen Auszug aus der Funktionsbeschreibung des MC_Home. Die gesamten Informationen entnehmen Sie bitte direkt aus der zugehörigen Funktionsbeschreibung.
Auszug der Funktionsbeschreibung des MC_Home
Referenz Modi
▪
Die EL72x1-xxxx kann mit den folgenden Referenz Modi der NC betrieben werden (siehe Abb. Auswahl der Referenz Modi in der NC).
▪
Default: Ist eine allgemeine Einstellung und für die meisten Anwendungen geeignet.
Fährt der Motor an den Referenznocken, wird eine Richtungsumkehr ausgelöst. Mit dem abfallenden Signal des Nocken bleibt der Motor stehen und die Referenzposition ist gesetzt.
▪
Software Sync: Die C-Spur wird virtuell nachgebildet.
Auswahl der Referenz Modi in der NC
Weiterhin lässt sich in der NC die Geschwindigkeit einstellen die bei der Referenzfahrt genutzt werden soll (Abb. Einstellung der Referenzgeschwindigkeit).
Einstellung der Referenzgeschwindigkeit


Touch Probe

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Touch Probe
Touch Probe
(Master TwinCAT 2.11 R3)
Die hier angegebenen Daten sind beispielhaft für einen Servomotor AM8131-0F20-0000 der Firma Beckhoff Automation aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Funktionsbeschreibung
Die in der EL72x1-xxxx implementierte Funktion Touch Probe bietet dem Anwender die Möglichkeit, zu einem definierten Zeitpunkt, die aktuelle Position des angeschlossenen Motors zu speichern.
Im Reiter Prozessdaten können die dazu nötigen Ein- und Ausgänge hinzugeführt werden (siehe Abb. Touch Probe inputs und Abb. Touch Probe outputs).
Die EL72x1-xxxx verfügt über 2 digitale Eingänge, die für die Funktion Touch Probe genutzt werden können. Die Abkürzung TP1 steht für Touch Probe 1 und ist mit dem Eingang 1 (Anschlusspin 3), die Abkürzung TP2 steht für Touch Probe 2 und ist mir dem Eingang 2 (Anschlusspin 11) der Klemme verknüpft. Zur Funktionsbeschreibung wird hier beispielhaft TP1 verwendet.
Touch Probe inputs
Touch Probe outputs
Step-by-step
▪
Um die Touch Probe Funktion generell zu aktivieren, muss TP1 Enable auf true gesetzt werden.
▪
Anschließend muss entschieden werden, ob bei einer positiven Flanke auf dem Eingang 1 die Position gespeichert werden soll (TP1 Enable pos edge = true), bei einer negativen Flanke (TP1 Enable neg edge = true) oder in beiden Fällen (beide auf "true" setzen).
▪
Mit TP1 Continous wird entschieden, ob nur beim ersten Event die Position gespeichert werden soll (TP1 Continous = false) oder ob das bei jedem Event geschehen soll (TP1 Continous = true).
Sind beispielsweise TP1 Continous und TP1 Enablepos edge gesetzt, wird bei jeder steigenden Flanke am Eingang 1 der Klemme die Position gespeichert.
Ist TP1 Enable neg edge gesetzt und TP1 Continous nicht, wird nur bei der ersten negativen Flanke am Eingang 1 der Klemme die Position gespeichert. Möchte man diesen Vorgang wiederholen, muss zunächst der TP1 Enable wieder deaktiviert und anschließend wieder aktiviert werden. Dann wird erneut bei der ersten negativen Flanke die Position gespeichert.
▪
Der TP1 Trigger mode hat bei der EL72x1-xxxx keine Funktion.
▪
Die gespeicherte Position der positiven Flanke kann in den Inputs der Prozessdaten unter TP1 Pos position, die der negativen Flanke kann unter TP1 Neg position ausgelesen werden.
▪
Die Variablen unter Touch probe status dienen der Diagnose.
▪
Die Touch Probe Eingänge müssen mit einem 1-Leiter +24 V Signal angesprochen werden.


Betriebsarten

Inbetriebnahme [image] Betriebsarten
Betriebsarten
Weiterführende Informationen
•
Übersicht
•
CSV
•
CST
•
CSTCA
•
CSP


Übersicht

Inbetriebnahme [image] Betriebsarten [image] Übersicht
Übersicht
Es werden die Betriebsarten CST, CSTCA, CSV und CSP unterstützt. Die Betriebsart wird im CoE-Verzeichnis im Index 0x7010:03 Modes of operation (MDP) oder Index 0x6060:0 Modes of opreration (DS402) eingestellt. In den jeweiligen Prozessdaten hat der Anwender zusätzlich die Möglichkeit das passende Predefined PDO Assigment auszuwählen. Damit sind alle nötigen Variablen in den Prozessdaten.
CSV - cyclic synchronous velocity (Geschwindigkeitsregelung)
In der Betriebsart CSV arbeitet die EL72x1-xxxx im zyklischen Geschwindigkeitsinterface. Über die Variable Target velocity kann eine definierte Geschwindigkeit eingestellt werden.
CST - cyclic synchronous torque (Drehmomentregelung)
In der Betriebsart CST arbeitet die EL72x1-xxxx im zyklischen Drehmomentsinterface. Über die Variable Target torque kann ein definiertes Drehmoments eingestellt werden.
CSTCA - cyclic synchronous torque with commutation angle (Drehmomentregelung mit Kommutierungswinkel)
Diese Betriebsart ist ebenfalls zur Verwendung am zyklischen Drehmomentsinterface. Zusätzlich hat der Anwender die Möglichkeit den Kommutierungswinkel anzugeben. Über die Variable Commutation angle kann ein Winkel eingestellt werden, der mit einem definierten Drehmoment der Variablen Target torque gehalten werden soll.
CSP - cyclic synchronous position (Positionsregelung)
In der Betriebsart CSP arbeitet die EL72x1-xxxx im zyklischen Positionsinterface. Über die Variable Target position kann eine definierte Position eingestellt werden.
Mehr Informationen zu den drei oben angegebenen Betriebsarten finden Sie im Kapitel „Inbetriebnahme ohne die NC“.


CSV

Inbetriebnahme [image] Betriebsarten [image] CSV
CSV
CSV - cyclic synchronous velocity (Geschwindigkeitsregelung)
In der Betriebsart CSV arbeitet die EL72x1-xxxx im zyklischen Geschwindigkeitsinterface. Über die Variable Target velocity kann eine definierte Geschwindigkeit eingestellt werden.
Step-by-Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous velocity mode (CSV), Abb. Auswahl Betriebsart.
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous velocity mode (CSV), Abb. Predefined PDO Assignment wählen.
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte Online der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target velocity (Abb. Vorgabe Drehmoment) können Sie eine definierte Geschwindigkeit vorgeben. Der Wert im Index 0x9010:14 Velocity encoder resolution entspricht 1 U/s.
Vorgabe Drehmoment


CST

Inbetriebnahme [image] Betriebsarten [image] CST
CST
CST - cyclic synchronous torque (Drehmomentregelung)
In der Betriebsart CST arbeitet die EL72x1-xxxx im zyklischen Drehmomentinterface. Über die Variable Target torque kann ein definiertes Drehmoments eingestellt werden.
Step-by-Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous torque mode (CST), Abb. Auswahl Betriebsart
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous torque mode (CST), Abb. Predefined PDO Assignment wählen
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte Online der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target torque (Abb. Vorgabe Drehmoment) können Sie ein definiertes Moment vorgeben. Der Wert wird in 1000stel vom rated current angegeben und das Moment wird nach folgender Formel berechnet, wobei der rated current sich auf den Wert im Index 0x8011:12 (rated current) bezieht.
Vorgabe Drehmoment
Sehen Sie dazu auch
•
Einbindung in die NC-Konfiguration
•
Einstellungen im CoE-Register


CSTCA

Inbetriebnahme [image] Betriebsarten [image] CSTCA
CSTCA
CSTCA - cyclic synchronous torque with commutation angle (Drehmomentregelung mit Kommutierungswinkel)
Diese Betriebsart ist ebenfalls zur Verwendung am zyklischen Drehmomentinterface. Zusätzlich hat der Anwender die Möglichkeit den Kommutierungswinkel anzugeben. Über die Variable Commutation angle kann ein Winkel eingestellt werden, der mit einem definierten Drehmoment der Variablen Target torque gehalten werden soll.
Step-by-Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous torque mode with commutation angle (CSTCA), Abb. Auswahl Betriebsart
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous torque mode with commutation angle (CSTCA), Abb. Predefined PDO Assignment wählen.
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte Online der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target torque können Sie ein definiertes Moment vorgeben. Der Wert wird in 1000stel vom rated current angegeben und das Moment wird nach folgeneder Formel berechnet, wobei der rated current sich auf den Wert im Index 0x8011:12 rated current bezieht.
Über die zyklische Variable Commutation angle können Sie einen definierten Winkel vorgeben. Der Wert wird in 360°/216 angegeben.
Vorgabe Drehmoment und Kommutierungswinkel
Sehen Sie dazu auch
•
Einbindung in die NC-Konfiguration
•
Einstellungen im CoE-Register


CSP

Inbetriebnahme [image] Betriebsarten [image] CSP
CSP
CSP - cyclic synchronous position (Positionsregelung)
In der Betriebsart CSP arbeitet die EL72x1-xxxx im zyklischen Positionsinterface. Über die Variable Target position kann eine definierte Position eingestellt werden.
Hinweis
Minimale Zykluszeit
Die Zykluszeit im CSP Modus muss 2^n * 125 µs betragen (mit n = 1 bis 8)
also 250 µs, 500 µs, 1 ms, 2 ms, 4 ms, 8 ms, 16 ms oder 32 ms.
Step-by-Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC.
▪
Konfigurieren Sie den Motor mit Hilfe der Automatischen Konfiguration, anhand des Drive Managers oder importieren Sie die Motor XML-Datei, wie im Kapitel Einstellungen im CoE beschrieben, in das Start-up Verzeichnis.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Cyclic synchronous position mode (CSP), Abb. Auswahl Betriebsart.
Auswahl Betriebsart
▪
Wählen Sie bei den Predefined PDO Assignments ebenfalls Cyclic synchronous position mode (CSP), Abb. Predefined PDO Assignment wählen.
Predefined PDO Assignment wählen
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu gibt es zwei Möglichkeiten:
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können in der Registerkarte "Online" der Achse die Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. Freigaben setzen). Anschließend kann die Achse bewegt werden.
Freigaben setzen
–
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Befolgen Sie dazu die Anweisungen im Kapitel Inbetriebnahme ohne die NC.
▪
Über die zyklische Variable Target position (Abb. Vorgabe Position) können Sie eine definierte Position vorgeben. Der Wert muss mit dem berechneten Skalierungsfaktor multipliziert werden, um die korrekte Position zu erhalten.
Vorgabe Position
Schleppfehlerüberwachung
Weiterhin besteht im CSP Mode die Möglichkeit, eine Schleppfehlerüberwachung einzuschalten. Im Auslieferungszustand ist die Schleppfehlerüberwachung ausgeschaltet. Bei allen anderen Modes kommt dies nicht zum Einsatz und wird ignoriert.
▪
Mit dem Following error window (Index 0x8010:50 MDP742 / Index 0x6065 DS402) lässt sich das Fenster der Schleppfehlerüberwachung einstellen. Der hier eingestellte Wert - mit dem Skalierungsfaktor multipliziert - gibt an, um welche Position die Ist-Position von der Sollposition, positiv und negativ, abweichen darf. Die gesamte akzeptierte Toleranz ist somit doppelt so groß, wie die im Following error window eingetragene Position (siehe Abb. Schleppfehlerfenster).
Schleppfehlerfenster
▪
Mit dem Following error time out (Index 0x8010:51 MDP742 / Index 0x6066 DS402) lässt sich die Zeit (in ms) einstellen, die für eine Schleppfehlerüberschreitung erlaubt ist. Sobald die Sollposition für die im Following error time out eingetragene Zeit um mehr als die im Following error window eingetragene Position überschritten wird, gibt die Klemme einen Fehler aus und bleibt unverzüglich stehen.
▪
Der aktuelle Schleppfehler kann im Following error actual value (Index 0x6010:09 MDP742 / Index 0x60F4 DS402) ausgelesen werden.
Schleppfehler über die Zeit
Der Wert 0xFFFFFF (-1) im Following error window bedeutet, dass die Schleppfehlerüberwachung ausgeschaltet ist und entspricht dem Auslieferungszustand.
Der Following error time out ist im Auslieferungszustand 0x0000 (0).


Profile MDP 742 oder DS 402

Inbetriebnahme [image] Profile MDP 742 oder DS 402
Profile MDP 742 oder DS 402
Die EL72x1-001x unterstützt die Antriebsprofile MDP 742 und DS 402. Die Profile definieren die Darstellung der Parameter der EtherCAT-Klemme und den Index unter dem die jeweiligen Parameter im Objektverzeichnis angeordnet sind.
Beide Profile beinhalten die gleichen Parameter, sie unterscheiden sich nur in den festgeschriebenen Bezeichnungen und dem Index der Parameter. Das MDP 742 Profil (Modular Device Profile) hat die für Beckhoff EtherCAT-Klemmen übliche Aufteilung der CoE-Objekte. Das DS402 Antriebsprofil ist in der IEC61800-7-200 spezifiziert (CiA402) und nutzt eine andere Aufteilung der Objektverzeichnisstruktur
Die Drive State Machine der EL72x1-001x basiert in beiden Profilen auf der CiA402 State Machine, somit ist das funktionale Verhalten identisch.
Ab Werk wird die Klemme mit dem Profil MDP 742 ausgeliefert.
Profil wechseln
In Falle des Profilwechsels muss ein EEPROM Update durchgeführt werden und die zugehörige ESI Beschreibung kann auf die Klemme geladen werden.
Es ist zu beachten, dass die CoE-Objektbeschreibung und die Prozessdaten für beide Profile unterschiedlich sind. Es müssen jeweils die zu dem eingestellten Profil passenden Motor XML Files hinzugezogen werden.
Hinweis
Klemmenbezeichnung MDP742 und DS402 Profil
Es ist zu beachten, dass durch den oben beschriebenen Profilwechselprozess die Servo Motor Klemme in TwinCAT eine andere Typenbezeichnung erhält.
Im TwinCAT System Manager stellt sich die Klemme dann als eines der folgenden Geräte dar:
- Servo Motor Klemme mit MDP742-Profil: EL72x1-0010
- Servo Motor Klemme mit DS402-Profil: EL72x1-0011


Prozessdaten MDP742

Inbetriebnahme [image] Prozessdaten MDP742
Prozessdaten MDP742
Inhaltsverzeichnis
• Sync Manger
• PDO-Zuordnung
• Predefined PDO Assignment
Sync Manager (SM)
Sync Manager (SM) Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (siehe folgende Abb.).
Karteireiter Prozessdaten SM2, EL72x1-0010 (default)
Karteireiter Prozessdaten SM3, EL72x1-0010 (default)
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (siehe Abb. Karteireiter Prozessdaten SM3, EL72x1-0010) den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | 2.0 | DRV Controlword | Index 0x7010:01
0x1601 (default) | 4.0 | DRV Target velocity | Index 0x7010:06
0x1602 | 2.0 | DRV Target torque | Index 0x7010:09
0x1603 | 2.0 | DRV Commutation angle | Index 0x7010:0E
0x1604 | 2.0 | DRV Torque limitation | Index 0x7010:0B
0x1605 | 2.0 | DRV Torque offset | Index 0x7010:0A
0x1606 | 4.0 | DRV Target position | Index 0x7010:05
0x1607 | 2.0 | FB Touch probe control | Index 0x7001:0
 |  |  | Index 0x7001:01 Index 0x7001:02 Index 0x7001:03 Index 0x7001:05 Index 0x7001:06 Index 0x7001:09 Index 0x7001:0A Index 0x7001:0B Index 0x7001:0D Index 0x7001:0E | TP1 Enable TP1 Continous TP1 Trigger mode TP1 Enable pos. edge TP1 Enable neg. edge TP2 Enable TP2 Continous TP2 Trigger mode TP2 Enable pos. edge TP2 Enable neg. edge
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 4.0 | FB Position | Index 0x6000:11
0x1A01 (default) | 2.0 | DRV Statusword | Index 0x6010:01
0x1A02 | 4.0 | DRV Velocity actual value | Index 0x6010:07
0x1A03 | 2.0 | DRV Torque actual value | Index 0x6010:08
0x1A04 | 2.0 | DRV Info data 1 | Index 0x6010:12
0x1A05 | 2.0 | DRV Info data 2 | Index 0x6010:13
0x1A06 | 4.0 | DRV Following error actual value | Index 0x6010:09
0x1A07 | 2.0 | FB Touch probe status | Index 0x6001:0
 |  |  | Index 0x6001:01 Index 0x6001:02 Index 0x6001:03 Index 0x6001:08 Index 0x6001:09 Index 0x6001:0A Index 0x6001:0B Index 0x6001:10 | TP1 Enable TP1 Pos. value stored TP1 Neg. value stored TP1 Input TP2 Enable TP2 Pos. value stored TP2 Neg. value stored TP2 Input
0x1A08 | 4.0 | FB Touch probe 1 pos. position | Index 0x6001:11
0x1A09 | 4.0 | FB Touch probe 1 neg. position | Index 0x6001:12
0x1A0A | 4.0 | FB Touch probe 2 pos. position | Index 0x6001:13
0x1A0B | 4.0 | FB Touch probe 2 neg. position | Index 0x6001:14
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Drei PDO-Zuordnungen stehen zur Auswahl:
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Cyclic synchronous velocity mode (CSV) | 0x1600 (DRV Controlword) 0x1601 (DRV Target velocity) | 0x1A00 (FB Position) 0x1A01 (DRV Statusword)
Cyclic synchronous torque mode (CST) | 0x1600 (DRV Controlword) 0x1602 (DRV Target torque) | 0x1A00 (FB Position) 0x1A01 (DRV Statusword) 0x1A03 (DRV Torque actual value)
Cyclic synchronous torque mode with commutation angel (CSTCA) | 0x1600 (DRV Controlword) 0x1602 (DRV Target torque) 0x1603 (DRV Commutation angle) | 0x1A01 (DRV Statusword)
Cyclic synchronous position mode (CSP) | 0x1600 (DRV Controlword) 0x1606 (DRV Target position) | 0x1A00(FB Position) 0x1A01(DRV Statusword)
Karteireiter Prozessdaten Predefined PDO Assignment, EL72x1-0010


Prozessdaten DS402

Inbetriebnahme [image] Prozessdaten DS402
Prozessdaten DS402
Inhaltsverzeichnis
• Sync Manger
• PDO-Zuordnung
• Predefined PDO Assignment
Sync Manager (SM)
Sync Manager (SM) Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (siehe Abb. Karteireiter Prozessdaten SM2, EL72x1-0010 (default)).
Karteireiter Prozessdaten SM2, EL72x1-0010 (default)
Karteireiter Prozessdaten SM3, EL72x1-0010 (default)
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (siehe Abb.) den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | 2.0 | DS402 Controlword | Index 0x6040
0x1601 (default) | 4.0 | DS402 Target velocity | Index 0x60FF
0x1602 | 2.0 | DS402 Target torque | Index 0x6071
0x1603 | 2.0 | DS402 Commutation angle | Index 0x60EA
0x1604 | 2.0 | DS402 Torque limitation | Index 0x6072
0x1605 | 2.0 | DS402 Torque offset | Index 0x2001:11
0x1606 | 4.0 | DS402 Target position | Index 0x607A
0x1607 | 2.0 | DS402 FB Touch probe cfunction | Index 0x60B8
 |  |  | Bit 0 Bit 1 Bit 2 Bit 4 Bit 5 Bit 8 Bit 9 Bit 10 Bit 12 Bit 13 | TP1 Enable TP1 Continous TP1 Trigger mode TP1 Enable pos. edge TP1 Enable neg. edge TP2 Enable TP2 Continous TP2 Trigger mode TP2 Enable pos. edge TP2 Enable neg. edge
SM3, PDO-Zuordnung 0x1C13
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 2.0 | DS402 Statusword | Index 0x6041
0x1A01 (default) | 4.0 | DS402 Position actual value | Index 0x6064
0x1A02 | 4.0 | DS402 Velocity actual value | Index 0x606C
0x1A03 | 2.0 | DS402 Torque actual value | Index 0x6077
0x1A04 | 4.0 | DS402 Following error actual value | Index 0x60F4
0x1A05 | 2.0 | DS402 Touch probe status | Index 0x60B9
 |  |  | Bit 0 Bit 1 Bit 2 Bit 7 Bit 8 Bit 9 Bit 10 Index 6001:10 | TP1 Enable TP1 Pos. value stored TP1 Neg. value stored TP1 Input TP2 Enable TP2 Pos. value stored TP2 Neg. value stored TP2 Input
0x1A06 | 4.0 | DS402 Touch probe 1 pos. position | Index 0x60BA
0x1A07 | 4.0 | DS402 Touch probe 1 neg. position | Index 0x60BB
0x1A08 | 4.0 | DS402 Touch probe 2 pos. position | Index 0x60BC
0x1A09 | 4.0 | DS402 Touch probe 2 neg. position | Index 0x60BD
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Drei PDO-Zuordnungen stehen zur Auswahl:
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Cyclic synchronous velocity mode (CSV) | 0x1600 (DS402 Controlword) 0x1601 (DS402 Target velocity) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value)
Cyclic synchronous torque mode (CST) | 0x1600 (DS402 Controlword) 0x1602 (DS402 Target torque) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value) 0x1A03 (DS402 Torque actual value)
Cyclic synchronous torque mode with commutation angel (CSTCA) | 0x1600 (DS402 Controlword) 0x1602 (DS402 Target torque) 0x1603 (DS402 Commutation angle) | 0x1A00 (DS402 Statusword)
Cyclic synchronous position mode (CSP) | 0x1600 (DS402 Controlword) 0x1606 (DS402 Target position) | 0x1A00 (DS402 Statusword) 0x1A01 (DS402 Position actual value)
Karteireiter Prozessdaten Predefined PDO Assignment, EL72x1-0010


Integrierte Sicherheit

Integrierte Sicherheit
Integrierte Sicherheit
Weiterführende Informationen
•
Sicherheitsbestimmungen
•
Produkt- und Funktionsbeschreibung
•
Instandhaltung
•
Lebensdauer


Sicherheitsbestimmungen

Integrierte Sicherheit [image] Sicherheitsbestimmungen
Sicherheitsbestimmungen
WARNUNG
Vorsicht Verletzungsgefahr!
Elektronische Geräte sind grundsätzlich nicht ausfallsicher. Bei Ausfall des Antriebssystems ist der Maschinenbauer dafür verantwortlich, dass die angeschlossenen Motoren und die Maschine in einen sicheren Zustand gebracht werden.
Achtung
Vorsicht, Zerstörung der Safety-Card durch elektrostatische Aufladung!
Die Safety-Card ist ein ESD-empfindliches Bauteil. Beachten Sie beim Umgang mit der Karte unbedingt die ESD-Schutzmaßnahmen (Antistatikbänder, Erdung der relevanten Komponenten usw.).


Produkt- und Funktionsbeschreibung

Integrierte Sicherheit [image] Produkt- und Funktionsbeschreibung
Produkt- und Funktionsbeschreibung
Weiterführende Informationen
•
Bestimmungsgemäße Verwendung
•
Abmessungen
•
Reaktionszeiten TwinSAFE
•
Applikationsbeispiel STO-Funktion (Kat. 3, PL d)


Bestimmungsgemäße Verwendung

Integrierte Sicherheit [image] Produkt- und Funktionsbeschreibung [image] Bestimmungsgemäße Verwendung
Bestimmungsgemäße Verwendung
WARNUNG
Vorsicht Verletzungsgefahr!
Eine Verwendung der TwinSAFE-Klemmen die über den im Folgenden beschriebene bestimmungsgemäße Verwendung hinausgeht ist nicht zulässig!
Die TwinSAFE-Klemmen erweitern das Einsatzfeld des Beckhoff Busklemmen-Systems um Funktionen, die es erlauben, diese auch im Bereich der Maschinensicherheit einzusetzen. Das angestrebte Einsatzgebiet der TwinSAFE-Klemmen sind Sicherheitsfunktionen an Maschinen und die damit unmittelbar zusammenhängenden Aufgaben in der industriellen Automatisierung. Sie sind daher nur für Anwendungen mit einem definierten Fail-Safe-Zustand zugelassen. Dieser sichere Zustand ist der energielose Zustand. Dafür ist eine Fehlersicherheit entsprechend der zugrunde gelegten Normen erforderlich.
Die TwinSAFE-Klemmen erlauben den Anschluss von:
▪
24 VDC-Sensoren (EL1904) wie
Not-Aus-Drucktaster, Reißleinenschalter, Positionsschalter, Zweihandschalter, Trittmatten, Lichtvorhänge, Lichtschranken, Laserscanner, usw.
▪
24 VDC-Aktoren (EL2904) wie
Schütze, Schutztürschalter mit Zuhaltung, Signalleuchten, Servo-Verstärker, usw.
Hinweis
Testpulse
Achten Sie bei der Auswahl der Aktoren darauf, dass die Testpulse der EL2904 nicht zu einem Schalten des Aktors oder einer Diagnosemeldung der EL2904 führen.
Für diese Aufgaben wurden folgende Module entwickelt:
▪
Die Klemme EL1904 ist ein Eingangsmodul mit digitalen Eingängen.
▪
Die Klemme EL2904 ist ein Ausgangsmodul mit digitalen Ausgängen.
▪
Die Klemme EL6900 ist ein Logikmodul.
Diese Module sind zum Betrieb geeignet an den
▪
Beckhoff Buskopplern der Serie EKxxxx
▪
Beckhoff Embedded PCs der Serie CXxxxx mit E-Bus-Anschluss
VORSICHT
Maschinenrichtlinie beachten
Die TwinSAFE-Klemmen dürfen nur in Maschinen im Sinne der Maschinenrichtlinie eingesetzt werden.
VORSICHT
Rückverfolgbarkeit sicherstellen
Der Besteller hat die Rückverfolgbarkeit der Geräte über die Seriennummer sicherzustellen.


Abmessungen

Integrierte Sicherheit [image] Produkt- und Funktionsbeschreibung [image] Abmessungen
Abmessungen
Abmessung der EL7201 (EL7201_Abmessung.png)
Abmessung der EL7201-xxxx
Breite: 12 mm (beim Aneinanderreihen)
Höhe: 100 mm
Tiefe: 68 mm
Abmessung der EL7211-xxxx (EL7211_Abmessung.png)
Abmessung der EL7211-xxxx
Breite: 24 mm (beim Aneinanderreihen)
Höhe: 100 mm
Tiefe: 68 mm


Reaktionszeiten TwinSAFE

Integrierte Sicherheit [image] Produkt- und Funktionsbeschreibung [image] Reaktionszeiten TwinSAFE
Reaktionszeiten TwinSAFE
Die TwinSAFE-Klemmen bilden ein modular aufgebautes Sicherheitssystem, welches über das Safety-over-EtherCAT-Protokoll sicherheitsgerichtete Daten austauscht. Dieses Kapitel soll dabei helfen die Reaktionszeit des Systems vom Signalwechsel am Sensor bis zur Reaktion am Aktor zu bestimmen.
Typische Reaktionszeit
Die typische Reaktionszeit ist die Zeit, die benötigt wird um eine Information vom Sensor zum Aktor zu übermitteln, wenn das Gesamtsystem fehlerfrei im Normalbetrieb arbeitet.
Typische Reaktionszeit
Definition | Beschreibung
RTSensor | Reaktionszeit des Sensors, bis das Signal an der Schnittstelle zur Verfügung gestellt wird. Wird typischerweise vom Sensorhersteller geliefert.
RTInput | Reaktionszeit des sicheren Eingangs, wie z.B. EL1904 oder EP1908. Diese Zeit kann aus den technischen Daten entnommen werden. Bei der EL1904 sind dies 4 ms.
RTComm | Reaktionszeit der Kommunikation. Diese ist typischerweise 3x die EtherCAT Zykluszeit, da neue Daten immer erst in einem neuen Safety-over-EtherCAT Telegramm versendet werden können. Diese Zeiten hängen von der übergeordneten Standard-Steuerung direkt ab (Zykluszeit der PLC/NC).
RTLogic | Reaktionszeit der Logikklemme. Dieses ist die Zykluszeit der Logikklemme und beträgt typischerweise 500 µs bis 10 ms für die EL6900, je nach Safety-Projektgröße. Die tatsächliche Zykluszeit kann aus der Klemme ausgelesen werden.
RTOutput | Reaktionszeit der Ausgangsklemme. Diese liegt typischerweise im Bereich von 2 bis 3 ms.
RTActor | Reaktionszeit der Servoklemme vom Abschalten der 24 V an Klemmstelle 13 bis zum sicheren Abschalten der Gatetreiber (Under Voltage Lockout). Diese Zeit beträgt typischerweise 20 ms.
WDComm | Watchdog-Zeit der Kommunikation
Es ergibt sich für die typische-Case Reaktionszeit folgende Formel:
mit z.B.
Worst-Case-Reaktionszeit
Die Worst-Case-Reaktionszeit gibt die Zeit an, die maximal benötigt wird um im Fehlerfall ein Abschalten des Aktors durchzuführen.
Worst-Case-Reaktionszeit
Dabei wird davon ausgegangen, dass am Sensor ein Signalwechsel erfolgt und dieser an den Eingang übermittelt wird. Gerade in dem Moment, wo das Signal an die Kommunikationsschnittstelle übergeben werden soll, tritt eine Kommunikationsstörung auf. Dies wird nach Ablauf der Watchdog-Zeit der Kommunikationsverbindung von der Logik detektiert. Diese Information soll dann an den Ausgang übergeben werden, wobei hier dann eine weitere Kommunkationsstörung auftritt. Diese Störung wird am Ausgang nach Ablauf der Watchdog-Zeit erkannt und führt dann zur Abschaltung.
Damit ergibt sich für die Worst-Case-Reaktionszeit folgende Formel:
mit z.B.


Applikationsbeispiel STO-Funktion (Kat. 3, PL d)

Integrierte Sicherheit [image] Produkt- und Funktionsbeschreibung [image] Applikationsbeispiel STO-Funktion (Kat. 3, PL d)
Applikationsbeispiel STO-Funktion (Kat. 3, PL d)
Applikationsbeispiel (STO – Safe Torque Off)
Das folgende Applikationsbeispiel zeigt wie die EL72x1-9014 zusammen mit einer EL2904 beschaltet werden kann, um eine STO Funktion nach EN 61800-5-2 zu realisieren.
Für die Verdrahtung zwischen der Safety-Ausgangsklemme (EL2904) und der Servoklemme (EL72x1-9014) muss der Anwender eine entsprechende Bewertung realisieren, damit ein Fehlerausschluss für Fremdeinspeisung und Querschluss in dieser Verdrahtung zulässig ist.
Beteiligte Komponenten
▪
Not-Halt-Gerät (Taster S1) nach ISO 13850 und Taster S2
▪
1 Safety-Eingangsklemme (EL1904) und 1 Eingangsklemme (EL 1004)
▪
1 Safety-Ausgangsklemme (EL2904)
▪
1 Safety-Logikklemme (EL6900) mit Funktionsbaustein „ESTOP“
▪
1 Servoklemme (EL72x1-9014) mit STO Eingang
▪
Speicherprogrammierbare Steuerung (PLC) und Feldbus EtherCAT
Eine Schutztür (S1 und S2) und ein Restart Signal (S3) werden logisch auf einen ESTOP Baustein verknüpft. Das EStopOut Signal wird an die NC Steuerung übergeben, mit der z.B. das Enable Signal der EL72x1-9014 geschaltet werden kann. Über den verzögerten Ausgang EStopDelOut wird der STO-Eingang der EL72x1-9014 bedient. Die EL72x1-9014 liefert über die Standard-Steuerung eine Information, dass die STO Funktion aktiv ist. Diese Information wird an den EDM Eingang des ESTOP Bausteins und zusätzlich an den EDM Baustein übergeben, um eine Erwartungshaltung für dieses Signal zu generieren.
Anschlussbeispiel EL72x1_9014 mit STO
VORSICHT
Wiederanlaufsperre in der Maschine implementieren!
Die Wiederanlaufsperre ist NICHT Teil der Sicherheitskette und muss in der Maschine implementiert werden!
Liefert die Risikoanalyse das Ergebnis, dass ein Wiederanlauf in der Sicherheitssteuerung zu realisieren ist, muss der Restart auch auf einen sicheren Eingang gelegt werden.
WARNUNG
Verdrahtung nur Schaltschrank-intern
Die Verdrahtung zwischen der EL2904 und dem STO-Eingang der EL72x1-9014 muss sich im selben Schaltschrank befinden, um einen Fehlerausschluss für den Querschluss bzw. Fremdeinspeisung der Verdrahtung zwischen EL2904 und EL72x1-9014 annehmen zu dürfen.
Die Bewertung dieser Verdrahtung und die Bewertung, ob der Fehlerausschluss zulässig ist, muss durch den Maschinenbauer bzw. Anwender erfolgen.
Hinweis
Berechnung EL72x1-9014
In der Berechnung des Performance Levels DIN EN ISO 13849-1 wird die EL72x1-9014 nicht berücksichtigt, da sie sich rückwirkungsfrei gegenüber der Sicherheitsfunktion verhält. In der Berechnung nach den EN 62061 geht der PFH Wert mit einem Wert von 0 ein.
Hinweis
Mehrere EL72x1-9014 gleichzeitig bedienen
Mit einem Abschaltkanal der EL2904 können max. 10 STO-Eingänge der entsprechenden EL72x1-9014 gleichzeitig bedient werden.
Parameter der sicheren Ein- und Ausgangsklemmen
EL1904
Parameter | Wert
Sensortest Kanal 1 aktiv | Ja
Sensortest Kanal 2 aktiv | Ja
Sensortest Kanal 3 aktiv | Ja
Sensortest Kanal 4 aktiv | Ja
Logik Kanal 1 und 2 | Single Logic
Logik Kanal 3 und 4 | Single Logic
EL2904
Parameter | Wert
Strommessung aktiv | Nein
Testpulse des Ausgangs aktiv | Ja
Blockbildung und Safety-Loops
Sicherheitsfunktion 1
EL72x1_9014_block_diagram
Berechnung
PFH / MTTFd /B10d – Werte
Komponente | Wert
EL1904 – PFH | 1,11E-09
EL2904 – PFH | 1,25E-09
EL6900 – PFH | 1,03E-09
EL72x1-9014 - PFH | 0,00
S1 – B10d | 1.000.000
S2 – B10d | 2.000.000
Arbeitstage (dop) | 230
Arbeitsstunden / Tag (hop) | 16
Zykluszeit (Minuten) (Tzyklus) | 15 (4x pro Stunde)
Lebenszeit (T1) | 20 Jahre = 175200 Stunden
Diagnostic Coverage DC
Komponente | Wert
S1/S2 mit Testung/Plausibilität | DCavg=99%
EL2904 mit Testung | DCavg=99%
Berechnung Block 1
Berechnung der PFH-/ und MTTFd-Werte aus den B10d-Werten:
Aus:
und:
Eingesetzt ergibt das:
S1:
S2:
und der Annahme, dass S1 und S2 jeweils einkanalig sind:
ergibt sich für
S1:
S2:
Nun sind folgende Annahmen zu treffen:
Die Türschalter S1/S2 werden immer gegenläufig betätigt. Da die Schalter verschiedene Werte haben, der vollständige Schutztürschalter aber aus einer Kombination von Öffner und Schließer besteht und beide Schalter funktionieren müssen, kann man den schlechteren der beiden Werte (S1) für die Kombination heranziehen!
Es gibt einen Kopplungsfaktor zwischen den Komponenten, die zweikanalig verschaltet sind. Beispiele sind Temperatur, EMV, Spannungsspitzen oder Signale zwischen diesen Komponenten. Dieser wird als Worst-Case-Abschätzung mit β =10% angenommen. Die EN 62061 enthält eine Tabelle, mit der dieser β–Faktor genau bestimmt werden kann. Weiterhin wird angenommen, dass alle üblichen Maßnahmen getroffen werden, um zu verhindern, dass beide Kanäle gleichzeitig durch einen Fehler (wie z.B. Überstrom durch Relais-Kontakte, Übertemperatur im Schaltschrank) unsicher ausfallen.
Daraus folgt für die Berechnung des PFH-Wertes für Block 1:
PFHges = β* (PFH(S1)+ PFH(S2))/2 + PFH(EL1904) + PFH(EL6900) + PFH(EL2904) + PFH(EL7201-9014)
zu:
PFHges = 10%* (1,68E-09+1,68E-09)/2 +1,11E-09 + 1,03E-09 + 1,25E-09 + 0,00 = 3,558E-09
Die Berechnung des MTTFd-Wertes für Block 1 (unter der gleichen Annahme) berechnet sich mit:
als:
mit:
Sind für EL1904, EL6900 und EL2904 nur PFH Werte vorhanden, gilt folgende Abschätzung:
Somit:
VORSICHT
Kategorie
Diese Struktur ist bis maximal Kategorie 3 möglich.
Herstellerangaben Interface Typ C – Senke
Parameter | min. | typ. | max.
Klasse | 2,3
Testimpulsdauer ti | - | - | 500 µs
Testimpulsintervall T | 10 ms | - | -
Eingangswiderstand R | 4,7 kΩ | - | -
Eingangskapazität CL | - | - | 1,21 µF
In Verbindung mit der EL2904 kann der Parameter Testing eingeschaltet werden.


Instandhaltung

Integrierte Sicherheit [image] Instandhaltung
Instandhaltung
Wartung
Die TwinSAFE-Komponenten sind wartungsfrei!
Umgebungsbedingungen
WARNUNG
Spezifizierte Umgebungsbedingungen einhalten!
Stellen Sie sicher, dass die TwinSAFE-Komponenten nur bei den spezifizierten Umgebungsbedingungen (siehe technische Daten) gelagert und betrieben werden.
Falls die TwinSAFE-Komponente außerhalb des zulässigen Umgebungstemperaturbereichs betrieben wird, geht sie in den Zustand Global Shutdown.
Reinigung
Schützen Sie die TwinSAFE-Komponenten während des Betriebs und der Lagerung vor unzulässiger Verschmutzung!
Falls die TwinSAFE-Komponente unzulässiger Verschmutzung ausgesetzt wurde, darf sie nicht weiter betrieben werden!
WARNUNG
Verschmutzte Komponenten überprüfen lassen!
Eine Reinigung der TwinSAFE-Komponente durch den Anwender ist unzulässig!
Schicken Sie verschmutzte Komponenten zur Überprüfung und Reinigung zum Hersteller!


Lebensdauer

Integrierte Sicherheit [image] Lebensdauer
Lebensdauer
Die TwinSAFE-Klemmen haben eine Lebensdauer von 20 Jahren.
Spezielle Proof-Tests sind aufgrund der hohen Diagnoseabdeckung innerhalb des Lebenszyklusses nicht notwendig.
Die TwinSAFE-Klemmen tragen einen Date Code, der wie folgt aufgebaut ist:
Date Code: KW JJ SW HW
Legende:
KW: Kalenderwoche der Herstellung
JJ: Jahr der Herstellung
SW: Software-Stand
HW: Hardware-Stand
Beispiel: Date Code 17 11 05 00
Kalenderwoche: 17
Jahr: 2011
Software-Stand: 05
Hardware-Stand: 00
Zusätzlich tragen die TwinSAFE-Klemmen eine eindeutige Seriennummer.
Eindeutige Seriennummer einer TwinSAFE-Klemme


Objektbeschreibung und Parametrierung

Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
Weiterführende Informationen
•
EL72x1-9014 (DS402)
•
EL72x1-9014 (MDP742)


EL72x1-9014 (DS402)

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402)
EL72x1-9014 (DS402)
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Hinweis
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Achtung
Beschädigung des Gerätes möglich!
Es wird dringend davon abgeraten, die Einstellungen in den CoE-Objekten zu ändern während die Achse aktiv ist, da die Reglung beeinträchtigt werden könnte.
Weiterführende Informationen
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Kommando-Objekt
•
Eingangsdaten/Ausgangsdaten
•
Informations-/Diagnostikdaten
•
Standardobjekte


Konfigurationsdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402) [image] Konfigurationsdaten
Konfigurationsdaten
Index 2002 Amplifier Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2002:0 | Amplifier Settings | Maximaler Subindex | UINT8 | RO | 0x49 (73dez)
2002:11 | Device type | 1: Servo drive (nicht änderbar) | UINT32 | RW | 0x00000001 (1dez)
2002:12* | Current loop integral time | Integralanteil Stromregler Einheit: 0,1 ms Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000A (10dez)
2002:13* | Current loop proportional gain | Proportionalanteil Stromregler Einheit: 0,1 V/A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0064 (100dez)
2002:14 | Velocity loop integral time | Integralanteil Geschwindigkeitsregler Einheit: 0,1 ms | UINT32 | RW | 0x00000032 (50dez)
2002:15 | Velocity loop proportional gain | Proportionalanteil Geschwindigkeitsregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000096 (150dez)
2002:17 | Position loop proportional gain | Proportionalanteil Positionsregler Einheit: (rad/s) / rad | UINT32 | RW | 0x0000000A (10dez)
2002:19 | Nominal DC link voltage | Nenn-Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000BB80 (48000dez)
2002:1A | Min DC link voltage | Minimale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x00001A90 (6800dez)
2002:1B | Max DC link voltage | Maximale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000EA60 (60000dez)
2002:29 | Amplifier I2T warn level | I²T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
2002:2A | Amplifier I2T error level | I²T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
2002:2B | Amplifier temperature warn level | Übertemperatur Warnschwelle Einheit : 0,1 °C | UINT16 | RW | 0x0320 (800dez)
2002:2C | Amplifier temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C | UINT16 | RW | 0x03E8 (1000dez)
2002:31 | Velocity limitation | Drehzahlbegrenzung Einheit: 1/min | UINT32 | RW | 0x00040000 (262144dez)
2002:32 | Short circuit brake duration max | Max. Dauer der Anker-Kurzschluss-Bremse Einheit: ms | UINT16 | RW | 0x03E8 (1000dez)
2002:33 | Stand still window | Stillstandsfenster Einheit: 1/min | UINT16 | RW | 0x0000 (0dez)
2002:41 | Low-pass filter frequency | Lastfilterfrequenz Einheit: Hz Es können folgende Werte eingestellt werden: 0 Hz = Aus 160 Hz 320 Hz | UINT16 | RW | 0x0140 (320dez)
2002:49 | Halt ramp deceleration | Verzögerung der Drehzahl-Halterampe Einheit: 0,1 rad / s² | UINT32 | RW | 0x0000F570 (62832dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2002:53 | Position loop proportional gain | Proportionalanteil Positionssregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000000 (0 dez)
2002:54 | Feature bits | Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Der Feature Bit ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default bei EL7201-001x) Effektivwert → Bit 0 = 1 (default bei EL7211-001x) Bei der EL7201-001x kann mit Hilfe des Lüftermoduls ZB8610 der Ausgangsstrom erhöht werden. normaler Ausgangsstrom → Bit 1 = 0 (default) erhöhter Ausgangsstrom → Bit 1 = 1 Daraus lassen sich folgende Kombinationen in einstellen: 0dez → normaler Ausgangsstrom in Scheitelwert interpretiert 1dez → normaler Ausgangsstrom in Effektivwert interpretiert 2dez → erhöhter Ausgangsstrom in Scheitelwert interpretiert 3 dez → erhöhter Ausgangsstrom in Effektivwert interpretiert | UINT32 | RW | 0x00000000 (0 dez)
2002:55 | Select info data 1 | Auswahl "Info data 1" Hier kann eine zusätzliche Information in die zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x00 (0 dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level Bit8: STO Input Level (-9014 Variant, only)
2002:56 | Select info data 2 | Auswahl "Info data 2" Hier kann eine zusätzliche Information in die zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x00 (0 dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level Bit8: STO Input Level (-9014 Variant, only)
*) siehe Index 2059 OCT Nameplate
Index 2003 Motor Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2003:0 | Motor Settings | Maximaler Subindex | UINT8 | RO | 0x2D (45dez)
2003:11* | Max current | Spitzenstrom Einheit: mA Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Der Feature Bit (2002:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default bei EL7201-001x) Effektivwert → Bit 0 = 1 (default bei EL7211-001x) Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00001770 (6000dez)
2003:13* | Motor pole pairs | Anzahl der Polpaare Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT8 | RW | 0x03 (3dez)
2003:15* | Commutation offset | Kommutierungs-Offset (zwischen elektrischer Nullposition und mechanischer Single-Turn Nullposition) Einheit: ° Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | INT16 | RW | 0x0000 (0dez)
2003:16* | Torque constant | Drehmoment-Konstante Einheit: mNm / A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
2003:18* | Rotor moment of inertia | Massenträgheitsmoment des Motors Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
2003:19* | Winding inductance | Induktivität Einheit: 0,1 mH Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000E (14dez)
2003:29 | Motor I2T warn level | I2T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
2003:2A | Motor I2T error level | I2T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
2003:2B* | Motor Temperature warn level | Übertemperatur Warnschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2003:2C* | Motor Temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2003:2D* | Motor thermal time constant | Thermische Zeitkonstante Einheit: 0,1 s Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0028 (40dez)
*) siehe Index 2059 OCT Nameplate
Index 2004 Brake Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2004:0 | Brake Settings | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
2004:01 | Manual override (release) | Manuelles Lösen der Motorhaltebremse | BOOLEAN | RW | 0x00 (0dez)
2004:11* | Release delay | Zeit, die die Haltebremse zum Öffnen (Lösen) benötigt, nachdem die Spannung angelegt wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2004:12* | Application delay | Zeit, die die Haltebremse zum Schließen (Halten) benötigt, nachdem die Spannung abgeschaltet wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
2004:13 | Emergency application timeout | Zeit, die der Verstärker abwartet, bis die Drehzahl nach Halt-Anforderung (Solldrehzahl 0 nach Halterampe oder Torque off) das Stillstandfenster erreicht. Bei Überschreiten der eingestellten Wartezeit wird die Haltebremse unabhängig von der Drehzahl ausgelöst. Hinweis: Bei rotatorischen Achsen und der Einstellung Torque off für den Fehlerfall muss dieser Parameter mindestens auf die längste Zeit des „Austrudelns“ der Achse angepasst werden. Bei hängenden Achsen und der Einstellung Torque off für den Fehlerfall sollte dieser Parameter auf eine sehr kurze Zeit eingestellt werden, um ein weites Absacken der Achse/Last zu verhindern. | UINT16 | RW | 0x0000 (0dez)
2004:14* | Brake moment of inertia | Massenträgheitsmoment der Bremse Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
*) siehe Index 2059 OCT Nameplate
Index 2010 Feedback Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2010:0 | Feedback Settings | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
2010:01 | Invert feedback direction | Zählrichtung invertieren | BOOLEAN | RW | 0x00 (0dez)
2010:11 | Device type | 3: OCT (nicht änderbar) | UINT32 | RW | 0x00000003 (3dez)
2010:12 | Singleturn bits | Anzahl der Singleturn-Bits | UINT8 | RW | 0x14 (20dez)
2010:13 | Multiturn bits | Anzahl der Multiturn-Bits | UINT8 | RW | 0x0C (12dez)
2010:14 | Observer bandwidth | Bandbreite des Drehzahlbeobachters [Hz] | UINT16 | RW | 0x01F4 (500dez)
2010:15 | Observer feed-forward | Lastverhältnis [%] 100 % = Lastfrei 50 % = Massenträgheitsmomente von An- und Abtrieb sind gleich | UINT8 | RW | 0x01 (0dez)
Index 2018 OCT Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2018:0 | OCT Settings | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
2018:01 | Enable auto config | Nach dem Einlesen des elektronischen Typenschilds wird automatisch konfiguriert (siehe Automatischen Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
2018:02 | Reconfig identical motor | Bei Austausch identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatischen Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
2018:03 | Reconfig non-identical motor | Bei Austausch nicht-identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatischen Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)


Konfigurationsdaten (herstellerspezifisch)

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402) [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 2020 Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2020:0 | Vendor data | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
2020:11 | Amplifier peak current | Spitzenstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00001F40 (8000dez)
2020:12 | Amplifier rated current | Nennstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00000FA0 (4000dez)
2020:13 | Amplifier thermal time constant | Thermische Zeitkonstante des Verstärkers Einheit: 0,1 ms | UINT16 | RW | 0x0023 (35dez)
2020:14 | Amplifier overcurrent threshold | Schwellwert für Kurzschlusserkennung Einheit: mA | UINT32 | RW | 0x00002EE0 (12000dez)
2020:15 | Max rotary field frequency | Max. Drehfeldfrequenz Einheit: Hz | UINT16 | RW | 0x0257 (599dez)


Kommando-Objekt

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402) [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | Command | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | reserviert | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | reserviert | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | reserviert | OCTET-STRING[4] | RO | {0}


Eingangsdaten/Ausgangsdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402) [image] Eingangsdaten/Ausgangsdaten
Eingangsdaten/Ausgangsdaten
Index 2001 Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2001:0 | Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
2001:11 | Torque offset | Offset des Drehmoment-Wertes Der Wert wird in 1000stel vom rated current angegeben Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dez)
Index 2008 Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2008:0 | Inputs | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
2008:01 | Info data1 | Synchrone Informationen (Auswahl über Subindex 2002:55) | UINT16 | RO | 0x0000 (0dez)
2008:01 | Info data2 | Synchrone Informationen (Auswahl über Subindex 2002:56) | UINT16 | RO | 0x0000 (0dez)
Index 603E TxPDO Data invalid
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
603E:0 | TxPDO Data invalid | Max. Subindex | UINT8 | RO | 0x02 (2dez)
603E:02 | Position actual value | 0: Die aktuelle Position ist gültig 1: Die aktuelle Position ist ungültig | BOOLEAN | RO P | 0
Index 6040 Controlword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | Controlword | DS402 Controlword Bit 0: Switch on Bit 1: Enable voltage Bit 2: reserved Bit 3: Enable operation Bit 4 - 6: reserved Bit 7: Fault reset Bit 8 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
Index 6041 Statusword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6041:0 | Statusword | DS402 Statusword Bit 0: Ready to switch on Bit 1: Switched on Bit 2: Operation enabled Bit 3: Fault Bit 4: reserved Bit 5: reserved Bit 6: Switch on disabled Bit 7: Warning Bit 8 + 9: reserved Bit 10: TxPDOToggle (An-/Abwahl über 0x60DA) Bit 11: Internal limit active Bit 12: (Target value ignored) Bit 13 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
Index 605E Fault reaction option code
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
605E:0 | Fault reaction option code | 0: Disable drive function, motor is free to rotate 1: Slow down by slow down ramp | ENUM16BIT | RW | 0
Index 6060 Modes of operation
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6060:0 | Modes of operation | erlaubte Werte: 0x08: Cyclic synchronous position mode (CSP) 0x09: Cyclic synchronous velocity mode (CSV) 0x0A: Cyclic synchronous torque mode (CST) 0x0B: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RW | 0x00 (0dez)
Index 6061 Modes of operation display
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6061:0 | Modes of operation display | erlaubte Werte: 8: Cyclic synchronous position mode (CSP) 9: Cyclic synchronous velocity mode (CSV) 10: Cyclic synchronous torque mode (CST) 11: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RO | 0x00 (0dez)
Index 6064 Position actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6064:0 | Position actual value | Position Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
Index 6065 Following error window
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6065:0 | Following error window | Schleppabstandsüberwachung: Schleppfehlerfenster Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden 0xFFFFFFFF (-1dez) = Schleppabstandsüberwachung aus Jeder andere Wert = Schleppabstandsüberwachung ein | UINT32 | RO | 0xFFFFFFFF (-1dez)
Index 6066 Following error time out
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6066:0 | Following error time out | Schleppabstandsüberwachung: Timeout Einheit: ms Ist der Schleppfehler größer als das Schleppfehlerfenster, für eine Zeit, die größer ist als der Timeout, führt das zu einer Fehlerreaktion | UINT1616 | RO | 0x0000 (0dez)
Index 606C Velocity actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
606C:0 | Velocity actual value | Anzeige des aktuellen Geschwindigkeitswerts | INT3232 | RO | 0x00000000 (0dez)
Index 6071 Target torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6071:0 | Target torque | This object shall indicate the configured input value for the torque controller. Der Wert wird in 1000stel vom rated current angegeben. Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dez)
Index 6072 Max torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6072:0 | Max torque | This object limits the target torque for the torque controller (bipolar limit). Der Wert wird in 1000stel vom rated current angegeben. Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | UINT16 | RW | 0x7FFF (32767dez)
Index 6075 Motor rated current
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6075:0 | Motor rated current | Motor-Nennstrom Einheit : mA | UINT32 | RW | 0x000003E8 (1000dez)
Index 6077 Torque actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6077:0 | Torque actual value | This object shall provide the actual value of the torque. Der Wert wird in 1000stel vom rated current angegeben. Formel für Index 2002:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (2003:16) Formel für Index 2002:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (2003:16) | INT16 | RO | 0x0000 (0dez)
Index 6079 DC link circuit voltage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6079:0 | DC link circuit voltage | Zwischenkreisspannung g Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index 607A Target position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
607A:0 | Target position | This object shall provide the actual position. Einheitit : der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 6080 Max motor speed
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6080:0 | Max motor speed | Drehzahlbegrenzung Einheit: 1 / min | UINT32 | RW | 0x00040000 (262144dez)
Index 608F Position encoder resolution
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
608F:0 | Position encoder resolution | Dieses Objekt stellt die konfigurierten Encoderinkremente und Anzahl der Motorumdrehungen dar. Die “Position encoder resolution” wird mit folgender Formel berechnet: Position encoder resolution = (Encoderinkremente / Motorumdrehungen) | UINT8 | RO | 0x02 (2dez)
608F:01 | SubIndex 001 | Encoderinkremente | UINT32 | RO | 0x00000000 (0dez)
608F:02 | SubIndex 002 | Motorumdrehungen | UINT32 | RO | 0x00000000 (0dez)
Index 6090 Velocity Encoder Resolution
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6090:0 | Velocity Encoder Resolution | Anzeige der konfigurierten Encoder-Inkremente/s und Motorumdrehungen/s. Die "Velocity Encoder Resolution" wird nach folgender Formel berechnet: Velocity Encoder Resolution = (encoder_increments / s ) / (motor_revolutions / s) | UINT32 | RO | 0x00000000 (0dez)
Index 60B8 Touch probe function
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60B8:0 | Touch probe function | Touch probe function byte | UINT16 | RO | 0x0000 (0dez)
Index 60B9 Touch probe status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60B9:0 | Touch probe status | Touch probe status byte | UINT1616 | RO | 0x0000 (0dez)
Index 60BA Touch probe 1 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BA:0 | Touch probe 1 positive edge | Positiver Positionswert von TP 1 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60BB Touch probe 1 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BB:0 | Touch probe 1 negative edge | Negativer Positionswert von TP 1 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60BC Touch probe 2 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BC:0 | Touch probe 2 positive edge | Positiver Positionswert von TP 2 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60BD Touch probe 2 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60BD:0 | Touch probe 2 negative edge | Negativer Positionswert von TP 2 Einheit :der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60C2 Interpolation time period
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60C2:0 | Interpolation time period | Maximaler Subindex x | UINT8 | RO | 0x02 (2dez)
60C2:01 | Interpolation time period value | Anzeige des Interpolations Zeitraums (sub-index 0x01) der Wert wird in 10(interpolation time index) (Sekunden) angegeben. Der Interpolation time index (sub-index 0x02) ist dimesionslos | UINT8T8 | RO | 0x00 (0dez)
60C2:02 | Interpolation time index |  | INT8 | RO | 0x00 (0dez)
Index 60D9 Supported functions
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60D9:0 | Supported functions | Angabe der vom Gerät unterstützten Funktionen | UINT3232 | RO | 0x00000000 (0dez)
Index 60DA Function settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60DA:0 | Function settings | Aktiviert / Deaktiviert unterstützte Funktionen. Bit 0: Enable TxPDOToggle-Bit in Statusword: Bit 10 Bit 1: Enable input cycle counter in Statusword: Bit 13 Bit 2-31: reserved | UINT32 | RW | 0x00000000 (0dez)
Index 60EA Commutation angle
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60EA:0 | Commutation angle | Kommutierungs-Winkel (für CSTCA Modus) Einheit: 5,49 * 10-3 ° | UINT16 | RO | 0x0000 (0dez)
Index 60F4 Following error actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60F4:0 | Following error actual value | Schleppfehler Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RO | 0x00000000 (0dez)
Index 60FF Target velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60FF:0 | Target velocity | Konfigurierte Ziel-Geschwindigkeit Die Geschwindigkeitsskalierung kann dem Objekt 0x6090 ("Velocity encoder resolution") entnommen werden | INT32 | RO | 0x00000000 (0dez)
Index 6403 Motor catalogue number
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6403:0 | Motor catalogue number | Ist der Order Code aus dem elektronischen Typenschild des Motors, z. B. AM8121-0F20-0000 | STRING | RO |
Index 6502 Supported drive modes
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6502:0 | Supported drive modes | Angabe der unterstützten Betriebsmodi. (DS402 Object 0x6502) Es werden nur die Modi CSV, CST, CSTCA und CSP unterstützt Bit 0: PP Bit 1: VL Bit 2: PV Bit 3: TQ Bit 4: R Bit 5: HM Bit 6: IP Bit 7: CSP Bit 8: CSV Bit 9: CST Bit 10: CSTCA Bit 11-15: reserved Bit 16-31: Manufacturer-specific | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnostikdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402) [image] Informations-/Diagnostikdaten
Informations-/Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 2030 Amplifier Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2030:0 | Amplifier Diag data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
2030:11 | Amplifier I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
Index 2031 Motor Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2031:0 | Motor Diag data | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
2031:11 | Motor I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
2031:13 | Motor temperature | Temperatur-Auslastung Einheit: ° | UINT16 | RO | 0x0000 (0dez)
Index 2040 Amplifier Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2040:0 | Amplifier Info data | Maximaler Subindex | UINT8 | RO | 0x12 (18dez)
2040:11 | Amplifier temperature | Klemmeninnentemperatur Einheit: 0,1 °C | UINT16 | RO | 0x0000 (0dez)
2040:12 | DC link voltage | Zwischenkreisspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index 2041 Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2041:0 | Info data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
2041:11 | Auxiliary voltage (10 V) | Hilfsspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index 2058 OCT Info data
(diese Daten werden immer automatisch aus dem elektronischen Typenschild des Motors eingelesen und dienen rein informativen Zwecken)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2058:0 | OCT Info data | Maximaler Subindex | UINT8 | RO | 0x1F (31dez)
2058:11 | Encoder Type | Feedbacktyp 2: Dreh-Encoder, unipolare Zählung | UINT16 | RO | 0x0000 (0dez)
2058:12 | Resolution | Auflösung des Feedbacks Einheit: Schritte pro Umdrehung | UINT32 | RO | 0x00000000 (0dez)
2058:13 | Range | Arbeitsbereich des Feedbacks. Beim Verlassen dieses Bereichs gibt es einen Überlauf der Position. Einheit: Umdrehungen | UINT32 | RO | 0x00000000 (0dez)
2058:14 | Type Code Name | Name des Feedbacks | STRING | RO |
2058:15 | Serial No | Seriennummer des Feedbacks | STRING | RO |
2058:16 | Firmware Revision No | Revision der Firmware | STRING | RO |
2058:17 | Firmware Date | Datum der Firmware | STRING | RO |
2058:18 | EEPROM Size | EEPROM Größe | UINT16 | RO | 0x0000 (0dez)
2058:19 | Temperature | Temperatur Einheit: 0,1° | INT16 | RO | 0x0000 (0dez)
2058:1A | LED Current | Strom der Feedback-LED Einheit: 0,1 mA | UINT16 | RO | 0x0000 (0dez)
2058:1B | Supply voltage | Versorgungsspannung des Feedbacks Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
2058:1C | Life- time | Betriebsstundenzähler Einheit: Minuten | UINT32 | RO | 0x00000000 (0dez)
2058:1D | Received Signal Strength Indicator | Empfangssignalstärke an der Klemme Einheit: % | UINT16 | RO | 0x0000 (0dez)
2058:1E | Slave Received Signal Strength Indicator | Empfangssignalstärke am Geber Einheit: % | UINT16 | RO | 0x0000 (0dez)
2058:1F | Line delay | Laufzeit des Signals im Kabel Einheit: ns | UINT16 | RO | 0x0000 (0dez)
Index 2059 OCT Nameplate
Die in diesem Index beschriebenen Parameter werden immer aus dem elektronischen Typenschild des angeschlossenen Motors gelesen. Aus diesen Parametern ergeben sich die in diesem Kapitel mit Sternchen (*) markierten Parameter automatisch, wenn das Automatische Scannen des elektronischen Typenschild eingeschaltet ist (Index 2018).
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2059:0 | OCT Nameplate | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
2059:01 | Motor vendor | Motorhersteller | STRING | RO |
2059:02 | Electric motor type | Motortyp | STRING | RO |
2059:03 | Serial No | Seriennummer | STRING | RO |
2059:04 | Order code | Bestellnummer (Auf diesen Index wird beim Autoconfig geprüft, ob der Motor identisch zum Vorgänger ist) | STRING | RO |
2059:05 | Motor construction | Art des Motors | STRING | RO |
2059:06 | Pole pairs | Polpaarzahl | UINT32 | RO | 0x00000000 (0dez)
2059:07 | Standstill current (rms) | Effektiver Haltestrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
2059:08 | Rated current (rms) | Effektiver Nennstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
2059:09 | Peak current (rms) | Effektiver Spitzenstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
2059:0A | Nominal voltage (rms) | Effektive Nennspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
2059:0B | Max voltage (rms) | Maximale Spannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
2059:0C | Max winding du/dt | Maximal zulässige Spannungsanstieg an der Spule Einheit: kV/s | UINT32 | RO | 0x00000000 (0dez)
2059:0D | Max torque | Maximales Drehmoment Einheit: mNm | UINT16 | RO | 0x0000 (0dez)
2059:0E | Torque constant | Drehmoment-Konstante Einheit: mNm / A | UINT16 | RO | 0x0000 (0dez)
2059:0F | EMK (rms) | Gegenspannung Einheit: mV / (1/min) | UINT32 | RO | 0x00000000 (0dez)
2059:10 | Winding resistance Ph-Ph 20°C | Spulenwiderstand Einheit: mOhm | UINT16 | RO | 0x0000 (0dez)
2059:11 | Ld Ph-Ph | Induktivität in Flussrichtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
2059:12 | Lq Ph-Ph | Induktivität in momentbildene Richtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
2059:13
Max speed
Maximale Geschwindigkeit
Einheit: 1/min
UINT32
RO
0x00000000 (0dez)
2059:14
Moment of inertia
Massenträgheitsmoment
Einheit: g cm^2
UINT16
RO
0x0000 (0dez)
2059:15
T motor warn limit
Warnungsschwelle Motortemperatur
Einheit: 0,1 °C
UINT16
RO
0x0000 (0dez)
2059:16
T motor shut down
Fehlerschwelle Motortemperatur
Einheit: 0,1°C
UINT16
RO
0x0000 (0dez)
2059:17
Time constant i2t
Zeitkonstante I2T-Modell
Einheit: s
UINT16
RO
0x0000 (0dez)
2059:18
Motor thermal constant
Thermische Zeitkonstante des Motors
Einheit: s
UINT16
RO
0x0000 (0dez)
2059:1B
Brake type
Typ der Bremse
▪
no Brake
▪
holding Brake
STRING
RO
2059:1C
Min brake voltage
Minimale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
2059:1D
Max brake voltage
Maximale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
2059:1E
Min brake monitor current
Minimaler Strom für die Überwachung der Bremse
Einheit: mA
UINT32
RO
0x00000000 (0dez)
2059:1F
Brake holding torque
Haltemoment der Bremse
Einheit: mNm
UINT32
RO
0x00000000 (0dez)
2059:20
Brake T on
Zeit bis die Bremse anzieht
Einheit: ms
UINT16
RO
0x0000 (0dez)
2059:21
Brake T off
Zeit bis die Bremse löst
Einheit: ms
UINT16
RO
0x0000 (0dez)
2059:22
Brake reduced holding voltage
Reduzierte Spannung der Bremse
Einheit: mV
UINT32
RO
0x00000000 (0dez)
2059:23
Brake time to red. holding volt.
Zeit ab der die Bremse mit reduzierter Spannung hält
Einheit: ms
UINT16
RO
0x0000 (0dez)
2059:24
Motor temp sensor connection
Anschluss des Temperatursensors Feedback port
(nicht änderbar)
STRING
RO


Standardobjekte

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (DS402) [image] Standardobjekte
Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00000192 (402dez)
Index 1001 Error register
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1001:0 | Error register |  | UINT8 | RO | 0x00 (0dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL72x1-x01x
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1C213052 (471937106dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DS402 RxPDO-Map Controlword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DS402 RxPDO-Map Controlword | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6040:00, 16
Index 1601 DS402 RxPDO-Map Target velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DS402 RxPDO-Map Target velocity | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60FF:00, 32
Index 1602 DS402 RxPDO-Map Target torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | DS402 RxPDO-Map Target torque | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6071:00, 16
Index 1603 DS402 RxPDO-Map Commutation angle
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | DS402 RxPDO-Map Commutation angle | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60EA:00, 16
Index 1604 DS402 RxPDO-Map Torque limitation
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | DS402 RxPDO-Map Torque limitation | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6072:00, 16
Index 1605 DS402 RxPDO-Map Torque offset
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | DS402 RxPDO-Map Torque offset | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x2001:11, 16
Index 1606 DS402 RxPDO-Map Target position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | DS402 RxPDO-Map Target position | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x607A:00, 32
Index 1607 DS402 RxPDO-Map Touch probe function
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | DS402 RxPDO-Map Touch probe function | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60B8:00, 16
Index 1A00 DS402 TxPDO-Map Statusword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | DS402 TxPDO-Map Statusword | PDO Mapping TxPDO 1 | UINT8 | RO | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6041:00, 16
Index 1A01 DS402 TxPDO-Map Position actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DS402 TxPDO-Map Position actual value | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6064:00, 32
Index 1A02 DS402 TxPDO-Map Velocity actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | DS402 TxPDO-Map Velocity actual value | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x606C:00, 32
Index 1A03 DS402 TxPDO-Map Torque actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | DS402 TxPDO-Map Torque actual value | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x6077:00, 16
Index 1A04 DS402 TxPDO-Map Following error actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | DS402 TxPDO-Map Following error actual value | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60F4:00, 32
Index 1A05 DS402 TxPDO-Map Touch probe status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DS402 TxPDO-Map Touch probe status | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60B9:00, 16
Index 1A06 DS402 TxPDO-Map Touch probe 1 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | DS402 TxPDO-Map Touch probe 1 positive edge | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BA:00, 32
Index 1A07 DS402 TxPDO-Map Touch probe 1 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | DS402 TxPDO-Map Touch probe 1 negative edge | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BB:00, 32
Index 1A08 DS402 TxPDO-Map Touch probe 2 positive edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | DS402 TxPDO-Map Touch probe 2 positive edge | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BC:00, 32
Index 1A09 DS402 TxPDO-Map Touch probe 2 negative edge
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | DS402 TxPDO-Map Touch probe 2 negative edge | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry | UINT32 | RO | 0x60BD:00, 32
Index 1A0B DS402 TxPDO-Map Info data 1
Index | Name | Bedeutung | Data type | Flags | Default
1A0B:0 | DS402 TxPDO-Map Info data 1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x2008 (Inputs), entry 0x01 (Info data 1)) | UINT32 | RO | 0x2008:01, 16
Index 1A0C DS402 TxPDO-Map Info data 2
Index | Name | Bedeutung | Data type | Flags | Default
1A0C:0 | DS402 TxPDO-Map Info data 2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x01 (1dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x2008 (Inputs), entry 0x02 (Info data 2)) | UINT32 | RO | 0x2008:02, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:05 | Subindex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:06 | Subindex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:07 | Subindex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:08 | Subindex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | Subindex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (Hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x0003D090 (250000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x4808 (18440dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0001E848 (125000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x0003D090 (250000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x4808 (18440dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0001E848 (125000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001C52 (7250dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | siehe Hinweis! | UINT32 | RW | 0x00000000 (0dez)


EL72x1-9014 (MDP742)

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742)
EL72x1-9014 (MDP742)
Hinweis
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Hinweis
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Achtung
Beschädigung des Gerätes möglich!
Es wird dringend davon abgeraten, die Einstellungen in den CoE-Objekten zu ändern während die Achse aktiv ist, da die Reglung beeinträchtigt werden könnte.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Kommando-Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnostikdaten
•
Standardobjekte


Restore-Objekt

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 FB Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | FB Settings | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
8000:01 | Invert feedback direction | Zählrichtung invertieren | BOOLEAN | RW | 0x00 (0dez)
8000:11 | Device type | 3: OCT (nicht änderbar) | UINT32 | RW | 0x00000003 (3dez)
8000:12 | Singleturn bits | Anzahl der Single-Bits | UINT8 | RW | 0x14 (20dez)
8000:13 | Multiturn bits | Anzahl der Multiturn-Bits | UINT8 | RW | 0x0C (12dez)
8000:14 | Observer bandwidth | Bandbreite des Drehzahlbeobachters [Hz] | UINT16 | RW | 0x01F4 (500dez)
8000:15 | Observer feed-forward | Lastverhältnis [%] 100 % = Lastfrei 50 % = Massenträgheitsmomente von An- und Abtrieb sind gleich | UINT8 | RW | 0x01 (0dez)
Index 8008 FB OCT Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8008:0 | FB OCT Settings | Maximaler Subindex | UINT8 | RO | 0x00 (0dez)
8008:01 | Enable autoconfig | Nach dem Einslesen des elektronischen Typenschilds wird automatisch konfiguriert (siehe Automatischen Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
8008:02 | Reconfig identical motor | Bei Austausch identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatischen Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
8008:03 | Reconfig non-identical motor | Bei Austausch nicht-identischer Motoren wird nach dem Einlesen des elekronischen Typenschilds automatisch neu konfiguriert. Enable autoconfig muss eingeschaltet sein. (siehe Automatischen Scannen der elektr. Typenschilder) | BOOLEAN | RW | 0x00 (0dez)
Index 8010 DRV Amplifier Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | DRV Amplifier Settings | Maximaler Subindex | UINT8 | RO | 0x42 (66dez)
8010:01 | Enable TxPDOToggle | TxPDO Toggle im Statuswort (Bit 10) einblenden | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Enable input cyle counter | 1: aktiviert Zwei-Bit-Zähler, der mit jedem Prozessdatenzyklus bis zum Maximalwert von 3 inkrementiert wird und danach wieder bei 0 beginnt Das Low-Bit wird in Bit 10 und das Hi-Bit in Bit 14 vom Status-Wort dargestellt. | BOOLEAN | RW | 0x00 (0dez)
8010:11 | Device type | 1: Servo drive (nicht änderbar) | UINT32 | RW | 0x00000001 (1dez)
8010:12* | Current loop integral time | Integralanteil Stromregler Einheit: 0,1 ms Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000A (10dez)
8010:13* | Current loop proportional gain | Proportionalanteil Stromregler Einheit: 0,1 V/A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0064 (100dez)
8010:14 | Velocity loop integral time | Integralanteil Geschwindigkeitsregler Einheit: 0,1 ms | UINT32 | RW | 0x00000032 (50dez)
8010:15 | Velocity loop proportional gain | Proportionalanteil Geschwindigkeitsregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000096 (150dez)
8010:17 | Position loop proportional gain | Proportionalanteil Positionsregler Einheit: (rad/s) / rad | UINT32 | RW | 0x0000000A (10dez)
8010:19 | Nominal DC link voltage | Nenn-Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000BB80 (48000dez)
8010:1A | Min DC link voltage | Minimale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x00001A90 (6800dez)
8010:1B | Max DC link voltage | Maximale Zwischenkreisspannung Einheit: mV | UINT32 | RW | 0x0000EA60 (60000dez)
8010:29 | Amplifier I2T warn level | I²T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
8010:2A | Amplifier I2T error level | I²T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
8010:2B | Amplifier Temperature warn level | Übertemperatur Warnschwelle Einheit: 0,1 °C | UINT16 | RW | 0x0320 (800dez)
8010:2C | Amplifier Temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C | UINT16 | RW | 0x03E8 (1000dez)
8010:31 | Velocity limitation | Drehzahlbegrenzung Einheit: 1/min | UINT32 | RW | 0x00040000 (262144dez)
8010:32 | Short-Circuit Brake duration max | Max. Dauer der Anker-Kurzschluss-Bremse Einheit: ms | UINT16 | RW | 0x03E8 (1000dez)
8010:33 | Stand still window | Stillstandsfenster Einheit: 1/min | UINT16 | RW | 0x0000 (0dez)
*) siehe Index 9009 FB OCT Nameplate
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:39 | Select info data 1 | Auswahl "Info data 1" Hier kann eine zusätzliche Information in die zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x01 (1dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level Bit8: STO Input Level (-9014 Variant, only)
8010:3A | Select info data 2 | Auswahl "Info data 2" Hier kann eine zusätzliche Information in die zyklischen Prozessdaten angezeigt werden. Folgende Informationen stehen zur Auswahl. | UINT8 | RW | 0x01 (1dez)
 |  | Torque current (filtered 1ms) [1000stel vom rated current]
 |  | DC link voltage [mV]
 |  | PCB temperature [0,1 °C]
 |  | Errors: Bit0: ADC Error Bit1: Overcurrent Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder Bit8: Watchdog
 |  | Warnings: Bit2: Undervoltage Bit3: Overvoltage Bit4: Overtemperature Bit5: I2T Amplifier Bit6: I2T Motor Bit7: Encoder
 |  | I2T Motor [%]
 |  | I2T Amplifier [%]
 |  | Input Level: Bit0: Digital Input 1 Level Bit1: Digital Input 2 Level Bit8: STO Input Level (-9014 Variant, only)
8010:41 | Low-pass filter frequency | Lastfilterfrequenz Einheit: Hz Es können folgende Werte eingestellt werden: 0 Hz = Aus 160 Hz 320 Hz | UINT16 | RW | 0x0140 (320dez)
8010:49 | Halt ramp deceleration | Verzögerung der Drehzahl-Halterampe Einheit: 0,1 rad / s² | UINT32 | RW | 0x0000F570 (62832dez)
8010:50 | Following error window | Schleppabstandsüberwachung: Schleppfehlerfenster Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden 0xFFFFFFFF (-1dez) = Schleppabstandsüberwachung aus Jeder andere Wert = Schleppabstandsüberwachung ein | UINT32 | RW | 0xFFFFFFFF (-1 dez)
8010:51 | Following error time out | Schleppabstandsüberwachung: Timeout Einheit: ms Ist der Schleppfehler größer als das Schleppfehlerfenster, für eine Zeit, die größer ist als der Timeout, führt das zu einer Fehlerreaktion | UINT16 | RW | 0x0000 (0 dez)
8010:52 | Fault reaction option code | Erlaubte Werte 0: Disable drive function, motor is free to rotate 1: Slow down on slow down ramp | UINT16 | RW | 0x0000 (0 dez)
8010:53 | Position loop proportional gain | Proportionalanteil Positionssregler Einheit: mA / (rad/s) | UINT32 | RW | 0x00000000 (0 dez)
8010:54 | Feature bits | Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Der Feature Bit ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default bei EL7201-001x) Effektivwert → Bit 0 = 1 (default bei EL7211-001x) Bei der EL7201-001x kann mit Hilfe des Lüftermoduls ZB8610 der Ausgangsstrom erhöht werden. normaler Ausgangsstrom → Bit 1 = 0 (default) erhöhter Ausgangsstrom → Bit 1 = 1 Daraus lassen sich folgende Kombinationen in einstellen: 0dez → normaler Ausgangsstrom in Scheitelwert interpretiert 1dez → normaler Ausgangsstrom in Effektivwert interpretiert 2dez → erhöhter Ausgangsstrom in Scheitelwert interpretiert 3 dez → erhöhter Ausgangsstrom in Effektivwert interpretiert | UINT32 | RW | 0x00000000 (0 dez)
*) siehe Index 9009 FB OCT Nameplate
Index 8011 DRV Motor Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:0 | DRV Motor Settings | Maximaler Subindex | UINT8 | RO | 0x2D (45dez)
8011:11* | Max current | Spitzenstrom Einheit: mA Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Der Feature Bit (8010:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default bei EL7201-001x) Effektivwert → Bit 0 = 1 (default bei EL7211-001x) Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00001770 (6000dez)
8011:12* | Rated current | Nennstrom Einheit: mA Die einstellbaren Motorstromwerte können als Scheitelwert oder Effektivwert interpretiert werden. Der Feature Bit (8010:54) ermöglicht die Umstellung. Scheitelwert → Bit 0 = 0 (default bei EL7201-001x) Effektivwert → Bit 0 = 1 (default bei EL7211-001x) Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x000003E8 (1000dez)
8011:13* | Motor pole pairs | Anzahl der Polpaare Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT8 | RW | 0x03 (3dez)
8011:15* | Commutation offset | Kommutierungs-Offset (zwischen elektrischer Nullposition und mechanischer Single-Turn Nullposition) Einheit: Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | INT16 | RW | 0x0000 (0dez)
8011:16* | Torque constant | Drehmoment-Konstante Einheit: mNm / A Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
8011:18* | Rotor moment of inertia | Massenträgheitsmoment des Motors Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00000000 (0dez)
8011:19* | Winding inductance | Induktivität Einheit: 0,1 mH Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x000E (14dez)
8011:1B* | Motor speed limitation | Drehzahlbegrenzung Einheit: 1/min Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT32 | RW | 0x00040000 (262144dez)
*) siehe Index 9009 FB OCT Nameplate
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:29 | I2T warn level | I2T-Modell Warnschwelle Einheit: % | UINT8 | RW | 0x50 (80dez)
8011:2A | I2T error level | I2T-Modell Fehlerschwelle Einheit: % | UINT8 | RW | 0x69 (105dez)
8011:2B* | Motor Temperature warn level | Übertemperatur Warnschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x03E8 (1000dez)
8011:2C* | Motor Temperature error level | Übertemperatur Fehlerschwelle Einheit: 0,1 °C Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x05DC (1500dez)
8011:2D* | Motor thermal time constant | Thermische Zeitkonstante Einheit: 0,1 s Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0028 (40dez)
*) siehe Index 9009 FB OCT Nameplate
Index 8012 DRV Brake Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8012:0 | DRV Brake Settings | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
8012:01 | Manual override (release) | Manuelles Lösen der Motorhaltebremse | BOOLEAN | RW | 0x00 (0dez)
8012:11* | Release delay | Zeit, die die Haltebremse zum Öffnen (Lösen) benötigt, nachdem der Strom angelegt wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
8012:12* | Application delay | Zeit, die die Haltebremse zum Schließen (Halten) benötigt, nachdem der Strom abgeschaltet wurde Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
8012:13 | Emergency application timeout | Zeit, die der Verstärker abwartet, bis die Drehzahl nach Halt-Anforderung (Solldrehzahl 0 nach Halterampe oder Torque off) das Stillstandfenster erreicht. Bei Überschreiten der eingestellten Wartezeit wird die Haltebremse unabhängig von der Drehzahl ausgelöst. Hinweis: Bei rotatorischen Achsen und der Einstellung Torque off für den Fehlerfall muss dieser Parameter mindestens auf die längste Zeit des „Austrudelns“ der Achse angepasst werden. Bei hängenden Achsen und der Einstellung Torque off für den Fehlerfall sollte dieser Parameter auf eine sehr kurze Zeit eingestellt werden, um ein weites Absacken der Achse/Last zu verhindern. | UINT16 | RW | 0x0000 (0dez)
8012:14* | Brake moment of inertia | Massenträgheitsmoment der Bremse Einheit: g cm^2 Dieser Wert ist vom Automatischen Scannen betroffen. (siehe Automatischen Scannen der elektr. Typenschilder) | UINT16 | RW | 0x0000 (0dez)
*) siehe Index 9009 FB OCT Nameplate


Konfigurationsdaten (herstellerspezifisch)

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 801F DRV Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | DRV Vendor data | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
801F:11 | Amplifier peak current | Spitzenstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00001F40 (8000dez)
801F:12 | Amplifier rated current | Nennstrom des Verstärkers (Scheitelwert) Einheit: mA | UINT32 | RW | 0x00000FA0 (4000dez)
801F:13 | Amplifier thermal time constant | Thermische Zeitkonstante des Verstärkers Einheit: 0,1 ms | UINT16 | RW | 0x0023 (35dez)
801F:14 | Amplifier overcurrent threshold | Schwellwert für Kurzschlusserkennung Einheit: mA | UINT32 | RW | 0x00002EE0 (12000dez)


Kommando-Objekt

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
FB00:0 | DCM Command | Max. Subindex |  |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x1100 | Get build number | Auslesen der Build-Nummer | OCTET-STRING[2] | RW | {0}
 |  | 0x1101 | Get build date | Auslesen des Build-Datums
 |  | 0x1102 | Get build time | Auslesen der Build-Zeit
FB00:02 | Status | 0 | Finished, no error, no response | Kommando ohne Fehler und ohne Antwort (Response ) beendet | UINT8 | RO | 0x00 (0dez)
 |  | 1 | Finished, no error, response | Kommando ohne Fehler und mit Antwort beendet
 |  | 2 | Finished, error, no response | Kommando mit Fehler und ohne Antwort beendet
 |  | 3 | Finished, error, response | Kommando mit Fehler und mit Antwort beendet
 |  | 255 | Executing | Kommando wird ausgeführt
FB00:03 | Response | abhängig vom Request |  |  | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Eingangsdaten
Eingangsdaten
Index 6000 FB Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | FB Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6000:11 | Position | Position | UINT32 | RO | 0x00000000 (0dez)
Index 6001 FB Touch probe inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6001:0 | FB Touch probe inputs | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
6001:01 | TP1 Enable | Touchprobe 1 eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
6001:02 | TP1 pos value stored | Positiver Wert von Touchprobe 1 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:03 | TP1 Neg value stored | Negativer Wert von Touchprobe 1 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:09 | TP2 Enable | Touchprobe 2 eingeschaltet | BOOLEAN | RO | 0x00 (0dez)
6001:0A | TP2 pos value stored | Positiver Wert von Touchprobe 2 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:0B | TP2 neg value stored | Negativer Wert von Touchprobe 2 gespeichert | BOOLEAN | RO | 0x00 (0dez)
6001:11 | TP1 pos position | Positiver Wert von Touchprobe 1 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
6001:12 | TP1 neg position | Negativer Wert von Touchprobe 1 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
6001:13 | TP2 pos position | Positiver Wert von Touchprobe 2 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
6001:14 | TP2 neg position | Negativer Wert von Touchprobe 2 Einheit: der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | UINT32 | RO | 0x00000000 (0dez)
Index 6010 DRV Inputs
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
6010:0
DRV Inputs
Maximaler Subindex
UINT8
RO
0x13 (19dez)
6010:01
Statusword
Statusword
Bit 0: Ready to switch on
Bit 1: Switched on
Bit 2: Operation enabled
Bit 3: Fault
Bit 4: reserved
Bit 5: Quick stop (inverse)
Bit 6: Switch on disabled
Bit 7: Warning
Bit 8 + 9: reserved
Bit 10: TxPDOToggle (An-/Abwahl über )
Bit 11: Internal limit active
Bit 12: (Target value ignored)
Bit 13 - 15: reserved
UINT16
RO
0x0000 (0dez)
6010:03
Modes of operation display
Anzeige des Betriebsmodus.

Erlaubte Werte:
9: Cyclic synchronous velocity mode (CSV)
10: Cyclic synchronous torque mode (CST)
11: Cyclic synchronous torque mode with commutation angle (CSTCA)
UINT8
RO
0x00 (0dez)
6010:07
Velocity actual value
Anzeige des aktuellen Geschwindigkeitswertes
Einheit: siehe Index 0x9010:14
INT32
RO
0x00000000 (0dez)
6010:08
Torque actual value
Anzeige des aktuellen Drehmomentwertes
Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben
Formel für Index 8010:54 = 0 :
M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16)

Formel für Index 8010:54 = 1 :
M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16)
INT16
RO
0x0000 (0dez)
6010:09
Following error actual value
Schleppfehler
Einheit : der angegebene Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden
INT32
RO
0x00000000 (0dez)
6010:12
Info data 1
Synchrone Informationen (Auswahl über Subindex 0x8010:39)
UINT16
RO
0x0000 (0dez)
6010:13
Info data 2
Synchrone Informationen (Auswahl über Subindex 0x8010:3A)
UINT16
RO
0x0000 (0dez)


Ausgangsdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Ausgangsdaten
Ausgangsdaten
Index 7001 FB Touch probe outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7001:0 | FB Touch probe outputs | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
7001:01 | TP1 Enable | Touchprobe 1 einschalten | BOOLEAN | RO | 0x00 (0dez)
7001:02 | TP1 Continous | 0: Es wird nur beim ersten Event getriggert 1. Es wird bei jedem Event getriggert | BOOLEAN | RO | 0x00 (0dez)
7001:03 | TP1 Trigger mode | Es wird Input 1 getriggert (nicht änderbar) | BIT2 | RO | 0x00 (0dez)
7001:05 | TP1 Enable pos edge | Bei positiver Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
7001:06 | TP1 Enable neg edge | Bei negativer Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
7001:09 | TP2 Enable | Touchprobe 2 einschalten | BOOLEAN | RO | 0x00 (0dez)
7001:0A | TP2 Continous | 0: Es wird nur beim ersten Event getriggert 1. Es wird bei jedem Event getriggert | BOOLEAN | RO | 0x00 (0dez)
7001:0B | TP2 Trigger mode | Es wird Input 2 getriggert (nicht änderbar) | BIT2 | RO | 0x00 (0dez)
7001:0D | TP2 Enable pos edge | Bei positiver Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
7001:0E | TP2 Enable neg edge | Bei negativer Flanke triggern | BOOLEAN | RO | 0x00 (0dez)
Index 7010 DRV Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | DRV Outputs | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
7010:01 | Controlword | Controlword Bit 0: Switch on Bit 1: Enable voltage Bit 2: Quick stop (inverse) Bit 3: Enable operation Bit 4 - 6: reserved Bit 7: Fault reset Bit 8 - 15: reserved | UINT16 | RO | 0x0000 (0dez)
7010:03 | Modes of operation | Erlaubte Werte: 0x08: Cyclic synchronous position mode (CSP) 0x09: Cyclic synchronous velocity mode (CSV) 0x0A: Cyclic synchronous torque mode (CST) 0x0B: Cyclic synchronous torque mode with commutation angle (CSTCA) | UINT8 | RW | 0x00 (0dez)
7010:05 | Target position | Konfigurierte Ziel-Position Einheit: der Wert muss mit dem entsprechenden Skalierungsfaktor multipliziert werden | INT32 | RW | 0x00000000 (0dez)
7010:06 | Target velocity | Konfigurierte Ziel-Geschwindigkeit Die Geschwindigkeitsskalierung kann dem Objekt 0x9010:14 ("Velocity encoder resolution") entnommen werden | INT32 | RO | 0x00000000 (0dez)
7010:09 | Target torque | Konfigurierter Eingangswert der Drehmoment-Überwachung Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dez)
7010:0A | Torque offset | Offset des Drehmoment-Wertes Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | INT16 | RO | 0x0000 (0dez)
7010:0B | Torque limitation | Grenzwert des Drehmomentes für die Drehmoment-Überwachung (Bipolar Limit) Der Wert wird in 1000stel vom rated current (0x8011:12) angegeben Formel für Index 8010:54 = 0 : M = ((Torque actual value / 1000) x (rated current / √2)) x torque constant (8011:16) Formel für Index 8010:54 = 1 : M = ((Torque actual value / 1000) x rated current)) x torque constant (8011:16) | UINT16 | RW | 0x7FFF (32767dez)
7010:0E | Commutation angle | Kommutierungs-Winkel (für CSTCA Modus) Einheit: 360° / 216 | UINT16 | RO | 0x0000 (0dez)


Informations-/Diagnostikdaten

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Informations-/Diagnostikdaten
Informations-/Diagnostikdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 9008 FB OCT Info data
(diese Daten werden immer automatisch aus dem elektronischen Typenschild des Motors eingelesen und dienen rein informativen Zwecken)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9008:0 | FB OCT Info data | Maximaler Subindex | UINT8 | RO | 0x1F (31dez)
9008:11 | Encoder Type | Feedbacktyp 2: Dreh-Encoder, unipolare Zählung | UINT16 | RO | 0x0000 (0dez)
9008:12 | Resolution | Auflösung des Feedbacks Einheit: Schritte pro Umdrehung | UINT32 | RO | 0x00000000 (0dez)
9008:13 | Range | Arbeitsbereich des Feedbacks. Beim Verlassen dieses Bereichs gibt es einen Überlauf der Position. Einheit: Umdrehungen | UINT32 | RO | 0x00000000 (0dez)
9008:14 | Type Code Name | Name des Feedbacks | STRING | RO |
9008:15 | Serial No | Seriennummer des Feedbacks | STRING | RO |
9008:16 | Firmware Revision No | Revision der Firmware | STRING | RO |
9008:17 | Firmware Date | Datum der Firmware | STRING | RO |
9008:18 | EEPROM Size | EEPROM Größe | UINT16 | RO | 0x0000 (0dez)
9008:19 | Temperature | Temperatur Einheit: 0,1° | INT16 | RO | 0x0000 (0dez)
9008:1A | LED Current | Strom der Feedback-LED Einheit: 0,1 mA | UINT16 | RO | 0x0000 (0dez)
9008:1B | Supply voltage | Versorgungsspannung des Feedbacks Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9008:1C | Life- time | Betriebsstundenzähler Einheit: Minuten | UINT32 | RO | 0x00000000 (0dez)
9008:1D | Received Signal Strength Indicator | Empfangssignalstärke an der Klemme Einheit: % | UINT16 | RO | 0x0000 (0dez)
9008:1E | Slave Received Signal Strength Indicator | Empfangssignalstärke am Geber Einheit: % | UINT16 | RO | 0x0000 (0dez)
9008:1F | Line delay | Laufzeit des Signals im Kabel Einheit: ns | UINT16 | RO | 0x0000 (0dez)
Index 9009 FB OCT Nameplate
Die in diesem Index beschriebenen Parameter werden immer aus dem elektronischen Typenschild des angeschlossenen Motors gelesen. Aus diesen Parametern ergeben sich die in diesem Kapitel mit Sternchen (*) markierten Parameter automatisch, wenn das Automatische Scannen des elektronischen Typenschild eingeschaltet ist (Index 8001).
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9009:0 | FB OCT Nameplate | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
9009:01 | Motor vendor | Motorhersteller | STRING | RO |
9009:02 | Electric motor type | Motortyp | STRING | RO |
9009:03 | Serial No | Seriennummer | STRING | RO |
9009:04 | Order code | Bestellnummer (Auf diesen Index wird beim Autoconfig geprüft, ob der Motor identisch zum Vorgänger ist) | STRING | RO |
9009:05 | Motor construction | Art des Motors | STRING | RO |
9009:06 | Pole pairs | Polpaarzahl | UINT32 | RO | 0x00000000 (0dez)
9009:07 | Standstill current (rms) | Effektiver Haltestrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
9009:08 | Rated current (rms) | Effektiver Nennstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
9009:09 | Peak current (rms) | Effektiver Spitzenstrom Einheit: mA | UINT32 | RO | 0x00000000 (0dez)
9009:0A | Nominal voltage (rms) | Effektive Nennspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9009:0B | Max voltage (rms) | Maximale Spannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9009:0C | Max winding du/dt | Maximal zulässige Spannungsanstieg an der Spule Einheit: kV/s | UINT32 | RO | 0x00000000 (0dez)
9009:0D | Max torque | Maximales Drehmoment Einheit: mNm | UINT16 | RO | 0x0000 (0dez)
9009:0E | Torque constant | Drehmoment-Konstante Einheit: mNm / A | UINT16 | RO | 0x0000 (0dez)
9009:0F | EMK (rms) | Gegenspannung Einheit: mV / (1/min) | UINT32 | RO | 0x00000000 (0dez)
9009:10 | Winding resistance Ph-Ph 20°C | Spulenwiderstand Einheit: mOhm | UINT16 | RO | 0x0000 (0dez)
9009:11 | Ld Ph-Ph | Induktivität in Flussrichtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
9009:12 | Lq Ph-Ph | Induktivität in momentbildene Richtung Einheit: 0,1 mH | UINT16 | RO | 0x0000 (0dez)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
9009:13
Max speed
Maximale Geschwindigkeit
Einheit: 1/min
UINT32
RO
0x00000000 (0dez)
9009:14
Moment of inertia
Massenträgheitsmoment
Einheit: g cm^2
UINT16
RO
0x0000 (0dez)
9009:15
T motor warn limit
Warnungsschwelle Motortemperatur
Einheit: 0,1°C
UINT16
RO
0x0000 (0dez)
9009:16
T motor shut down
Fehlerschwelle Motortemperatur
Einheit: 0,1°C
UINT16
RO
0x0000 (0dez)
9009:17
Time constant i2t
Zeitkonstante I2T-Modell
Einheit: s
UINT16
RO
0x0000 (0dez)
9009:18
Motor thermal constant
Thermische Zeitkonstante des Motors
Einheit: s
UINT16
RO
0x0000 (0dez)
9009:1B
Brake type
Typ der Bremse
▪
no Brake
▪
holding Brake
STRING
RO
9009:1C
Min brake voltage
Minimale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
9009:1D
Max brake voltage
Maximale Bremsspannung
Einheit: mV
UINT32
RO
0x00000000 (0dez)
9009:1E
Min brake monitor current
Minimaler Strom für die Überwachung der Bremse
Einheit: mA
UINT32
RO
0x00000000 (0dez)
9009:1F
Brake holding torque
Haltemoment der Bremse
Einheit: mNm
UINT32
RO
0x00000000 (0dez)
9009:20
Brake T on
Zeit bis die Bremse anzieht
Einheit: ms
UINT16
RO
0x0000 (0dez)
9009:21
Brake T off
Zeit bis die Bremse löst
Einheit: ms
UINT16
RO
0x0000 (0dez)
9009:22
Brake reduced holding voltage
Reduzierte Spannung der Bremse
Einheit: mV
UINT32
RO
0x00000000 (0dez)
9009:23
Brake time to red. holding volt.
Zeit ab der die Bremse mit reduzierter Spannung hält
Einheit: ms
UINT16
RO
0x0000 (0dez)
9009:24
Motor temp sensor connection
Anschluss des Temperatursensors
Feedback port (nicht änderbar)
STRING
RO
Index 9010 DRV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | DRV Info data | Maximaler Subindex | UINT8 | RO | 0x14 (20dez)
9010:11 | Amplifier temperature | Klemmeninnentemperatur Einheit: 0,1 °C | UINT16 | RO | 0x0000 (0dez)
9010:12 | DC link voltage | Zwischenkreisspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
9010:13 | Supported drive modes | Informationen der unterstützten Drive Modi. (DS402: Object 0x6502) Es werden nur die Modi CSV, CST, CSTCA und CSP unterstützt Bit 0: PP Bit 1: VL Bit 2: PV Bit 3: TQ Bit 4: R Bit 5: HM Bit 6: IP Bit 7: CSP Bit 8: CSV Bit 9: CST Bit 10: CSTCA Bit 11 - 15: reserved Bit 16-31: Manufacturer-specific | UINT32 | RO | 0x00000000 (0dez)
9010:14 | Velocity encoder resolution | Anzeige der konfigurierten Encoder-Inkremente/s und Motorumdrehungen/s. Die "Velocity Encoder Resolution" wird nach folgender Formel berechnet: Velocity Encoder Resolution = (encoder_increments / s ) / (motor_revolutions / s) | UINT32 | RO | 0x00041893 (268435dez)
Index 9018 DRV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9018:0 | DRV Info data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
9018:11 | Auxiliary voltage (10 V) | Hilfsspannung Einheit: mV | UINT32 | RO | 0x00000000 (0dez)
Index A010 DRV Amplifier Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A010:0 | DRV Amplifier Diag data | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
A010:11 | Amplifier I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
Index A011 DRV Motor Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A011:0 | DRV Motor Diag data | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
A011:11 | Motor I2T temperature | I2T-Modell-Auslastung Einheit: % | UINT8 | RO | 0x00 (0dez)
A011:13 | Motor temperature | Temperatur-Auslastung Einheit: ° | INT16 | RO | 0x0000 (0dez)


Standardobjekte

Objektbeschreibung und Parametrierung [image] EL72x1-9014 (MDP742) [image] Standardobjekte
Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL72x1-x01x
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1C213052 (471937106dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 DRV RxPDO-Map Controlword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | DRV RxPDO-Map Controlword | PDO Mapping RxPDO 1 | UINT8 | RO | 0x01 (1dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x01 (Controlword)) | UINT32 | RO | 0x7010:01, 16
Index 1601 DRV RxPDO-Map Target velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | DRV RxPDO-Map Target velocity | PDO Mapping RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x06 (Target velocity)) | UINT32 | RO | 0x7010:06, 32
Index 1602 DRV RxPDO-Map Target torque
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | DRV RxPDO-Map Target torque | PDO Mapping RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x09 (Target torque)) | UINT32 | RO | 0x7010:09, 16
Index 1603 DRV RxPDO-Map Commutation angle
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | DRV RxPDO-Map Commutation angle | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0E (Commutation angle)) | UINT32 | RO | 0x7010:0E, 16
Index 1604 DRV RxPDO-Map Torque limitation
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | DRV RxPDO-Map Torque limitation | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0B (Torque limitation)) | UINT32 | RO | 0x7010:0B, 16
Index 1605 DRV RxPDO-Map Torque offset
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | DRV RxPDO-Map Torque offset | PDO Mapping RxPDO 6 | UINT8 | RO | 0x01 (1dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0A (Torque offset)) | UINT32 | RO | 0x7010:0A, 16
Index 1606 DRV RxPDO-Map Target position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | DRV RxPDO-Map Target position | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (DRV Outputs), entry 0x0A (Torque offset)) | UINT32 | RO | 0x7010:05, 32
Index 1607 FB RxPDO-Map Touch probe control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | FB RxPDO-Map Touch probe control | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0C (12dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x01 (TP1 Enable)) | UINT32 | RO | 0x7001:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x02 (TP1 Continous)) | UINT32 | RO | 0x7001:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x03 (TP1 Trigger mode)) | UINT32 | RO | 0x7001:03, 2
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x05 (TP1 Enable pos edge)) | UINT32 | RO | 0x7001:05, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x06 (TP1 Enable neg edge)) | UINT32 | RO | 0x7001:06, 1
1607:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x09 (TP2 Enable)) | UINT32 | RO | 0x7001:09, 1
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0A (TP2 Continous)) | UINT32 | RO | 0x7001:0A, 1
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0B (TP2 Trigger mode)) | UINT32 | RO | 0x7001:0B, 2
1607:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0D (TP2 Enable pos edge)) | UINT32 | RO | 0x7001:0D, 1
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (FB Touch probe outputs), entry 0x0E (TP2 Enable neg edge)) | UINT32 | RO | 0x7001:0E, 1
1607:0C | SubIndex 012 | 12. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
Index 1A00 FB TxPDO-Map Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | FB TxPDO-Map Position | PDO Mapping TxPDO 1 | UINT8 | RO | 0x01 (1dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (FB Inputs), entry 0x11 (Position)) | UINT32 | RO | 0x6000:11, 32
Index 1A01 DRV TxPDO-Map Statusword
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | DRV TxPDO-Map Statusword | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x01 (Statusword)) | UINT32 | RO | 0x6010:01, 16
Index 1A02 DRV TxPDO-Map Velocity actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | DRV TxPDO-Map Velocity actual value | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x07 (Velocity actual value)) | UINT32 | RO | 0x6010:07, 32
Index 1A03 DRV TxPDO-Map Torque actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | DRV TxPDO-Map Torque actual value | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x08 (Torque actual value)) | UINT32 | RO | 0x6010:08, 16
Index 1A04 DRV TxPDO-Map Info data 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | DRV TxPDO-Map Info data 1 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x12 (Info data 1)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 DRV TxPDO-Map Info data 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | DRV TxPDO-Map Info data 2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x13 (Info data 2)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 DRV TxPDO-Map Following error actual value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | DRV TxPDO-Map Following error actual value | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x01 (Statusword)) | UINT32 | RO | 0x6010:09, 32
Index 1A07 FB TxPDO-Map Touch probe status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | FB TxPDO-Map Touch probe status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x08 (8dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x07 (Velocity actual value)) | UINT32 | RO | 0x6001:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x02 (TP1 pos value stored)) | UINT32 | RO | 0x6001:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x03 (TP1 Neg value stored)) | UINT32 | RO | 0x6001:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x09 (TP2 Enable)) | UINT32 | RO | 0x6001:09, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x0A (TP2 pos value stored)) | UINT32 | RO | 0x6001:0A, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x0B (TP2 neg value stored)) | UINT32 | RO | 0x6001:0B, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
Index 1A08 FB TxPDO-Map Touch probe 1 pos position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | FB TxPDO-Map Touch probe 1 pos position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x08 (Torque actual value)) | UINT32 | RO | 0x6001:11, 32
Index 1A09 FB TxPDO-Map Touch probe 1 neg position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | FB TxPDO-Map Touch probe 1 neg position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x12 (Info data 1)) | UINT32 | RO | 0x6001:12, 32
Index 1A0A FB TxPDO-Map Touch probe 2 pos position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | FB TxPDO-Map Touch probe 2 pos position | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (DRV Inputs), entry 0x13 (Info data 2)) | UINT32 | RO | 0x6001:13, 32
Index 1A0B FB TxPDO-Map Touch probe 2 neg position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | FB TxPDO-Map Touch probe 2 neg position | PDO Mapping TxPDO 12 | UINT8 | RO | 0x01 (1dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (FB Touch probe inputs), entry 0x14 (TP2 neg position)) | UINT32 | RO | 0x6001:14, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:04 | Subindex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:05 | Subindex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:06 | Subindex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:07 | Subindex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:08 | Subindex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | Subindex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0B | Subindex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | Subindex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x0003D090 (250000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x4808 (18440dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0001E848 (125000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
3: DC - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x0003D090 (250000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x4808 (18440dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0001E848 (125000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00001C52 (7250dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00001C52 (7250dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | Profilnummer Encoder Profile | UINT32 | RW | 0x00000201 (513dez)
F010:02 | SubIndex 002 | Profilnummer Servo Drive | UINT32 | RW | 0x000002E6 (742dez)
Index FB40 Memory interface
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB40:0 | Memory interface | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB40:01 | Address | reserviert | UINT32 | RW | 0x00000000 (0dez)
FB40:02 | Length | reserviert | UINT16 | RW | 0x0000 (0dez)
FB40:03 | Data | reserviert | OCTET-STRING[8] | RW | {0}


Fehlerbehebung

Fehlerbehebung
Fehlerbehebung
Weiterführende Informationen
•
Diagnose - Grundlagen zu Diag Messages


Diagnose - Grundlagen zu Diag Messages

Fehlerbehebung [image] Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Hinweis
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons sind selbsterklärend.
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13
Übersicht Text-IDs
Spezifische Text-ID sollten in der Gerätedokumentation angegeben werden.
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x0001 | Information | System | No error | Kein Fehler
0x0002 | Information | System | Communication established | Verbindung aufgebaut
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | Allgemein | Detection of operation mode completed: 0x%X, %d | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein | Cycle time o.k.: %d | Zykluszeit o.k.
0x1157 | Information | Allgemein | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Daten manuell gespeichert
0x1158 | Information | Allgemein | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Daten automatisch gespeichert
0x1159 | Information | Allgemein | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Daten gelöscht
0x117F | Information | Allgemein | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde
0x1300 | Information | Encoder | Position set: %d, %d | Position gesetzt - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder Netzteil OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder Initialisierung erfolgreich abgeschlossen
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Sende Kommando Encoder Reset
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Antrieb ist kalibriert
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Aktueller Status des Antriebs
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Prozessorauslastung ist wieder im normalen Bereich
0x1706 | Information |  | Channel is not in saturation anymore | Kanal ist nicht mehr in Sättigung
0x1707 | Information |  | Channel is not in overload anymore | Kanal ist nicht mehr überlastet
0x170A | Information |  | No channel range error anymore | Es liegt kein Messbereichsfehler mehr vor
0x170C | Information |  | Calibration data saved | Abgleichdaten wurden gespeichert
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Abgleichdaten werden erst nach dem Senden des Kommandos „0x5AFE“ übernommen und gespeichert
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Netzwerk Verbindung verloren
0x2002 | Information | System | %s: Network link detected | Netzwerk Verbindung gefunden
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Ungültige IP Konfiguration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Gültige, vom DHCP-Server zugewiesene IP-Konfiguration
0x2005 | Information | System | %s: Dhcp client timed out | Zeitüberschreitung DHCP-Client
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Doppelte IP-Adresse gefunden
0x2007 | Information | System | %s: UDP handler initialized | UDP-Handler initialisiert
0x2008 | Information | System | %s: TCP handler initialized | TCP-Handler initialisiert
0x2009 | Information | System | %s: No more free TCP sockets available | Keine freien TCP Sockets verfügbar
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x4000 | Warnung |  | Warning: 0x%X, 0x%X, 0x%X | allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4001 | Warnung | System | Warning: 0x%X, 0x%X, 0x%X |
0x4002 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful |
0x4003 | Warnung | System | %s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful |
0x4004 | Warnung | System | %s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out |
0x4005 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u) |
0x4006 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4007 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4008 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms) |
0x4101 | Warnung | Allgemein | Terminal-Overtemperature | Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle
0x4102 | Warnung | Allgemein | Discrepancy in the PDO-Configuration | Die ausgewählten PDOs passen nicht zur eingestellten Betriebsart. Beispiel: Antrieb arbeitet im Velocity-Mode. Das Velocity-PDO ist jedoch nicht in die PDOs gemapped.
0x417F | Warnung | Allgemein | Warnung: 0x%X, 0x%X, 0x%X |
0x428D | Warnung | Allgemein | Challenge is not Random |
0x4300 | Warnung | Encoder | Subincrements deactivated: %d, %d | Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301 | Warnung | Encoder | Encoder-Warning | Allgemeiner Encoderfehler
0x4400 | Warnung | Drive | Drive is not calibrated: %d, %d | Antrieb ist nicht kalibriert
0x4401 | Warnung | Drive | Starttype not supported: 0x%X, %d | Starttyp wird nicht unterstützt
0x4402 | Warnung | Drive | Command rejected: %d, %d | Kommando abgewiesen
0x4405 | Warnung | Drive | Invalid modulo subtype: %d, %d | Modulo-Subtyp ungültig
0x4410 | Warnung | Drive | Target overrun: %d, %d | Zielposition wird überfahren
0x4411 | Warnung | Drive | DC-Link undervoltage (Warning) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x4412 | Warnung | Drive | DC-Link overvoltage (Warning) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x4413 | Warnung | Drive | I2T-Model Amplifier overload (Warning) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414 | Warnung | Drive | I2T-Model Motor overload (Warning) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x4415 | Warnung | Drive | Speed limitation active | Die maximale Drehzahl wird durch die parametrierten Objekte (z.B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen
0x4416 | Warnung | Drive | Step lost detected at position: 0x%X%X | Schrittverlust erkannt
0x4417 | Warnung | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Warnschwelle.
0x4418 | Warnung | Drive | Limit: Current | Limit: Strom wird limitiert
0x4419 | Warnung | Drive | Limit: Amplifier I2T-model exceeds 100%% | Die Schwellwerte für den maximalen Strom wurden überschritten.
0x441A | Warnung | Drive | Limit: Motor I2T-model exceeds 100%% | Limit: Motor I2T-Modell übersteigt 100%
0x441B | Warnung | Drive | Limit: Velocity limitation | Die Schwellwerte für die maximale Drehzahl wurden überschritten.
0x441C | Warnung | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x4600 | Warnung | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x4610 | Warnung | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x4705 | Warnung |  | Processor usage at %d %% | Prozessorauslastung bei %d %%
0x470A | Warnung |  | EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time) | EtherCAT Frame verpasst (Einstellungen, DC Operation Mode oder Sync0 Shift Time ändern)
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x8000 | Fehler | System | %s: %s |
0x8001 | Fehler | System | Error: 0x%X, 0x%X, 0x%X | allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002 | Fehler | System | Communication aborded | Kommunikation abgebrochen
0x8003 | Fehler | System | Configuration error: 0x%X, 0x%X, 0x%X | allgemeine, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8004 | Fehler | System | %s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8005 | Fehler | System | %s: FwdClose-Request sent to %d.%d.%d.%d (%s) |
0x8006 | Fehler | System | %s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8007 | Fehler | System | %s: Connection with %d.%d.%d.%d (%s) closed |
0x8100 | Fehler | Allgemein | Status word set: 0x%X, %d | Fehlerbit im Statuswort gesetzt
0x8101 | Fehler | Allgemein | Operation mode incompatible to PDO interface: 0x%X, %d | Betriebsart inkompatibel zum PDO-Interface
0x8102 | Fehler | Allgemein | Invalid combination of Inputs and Outputs PDOs | Ungültige Kombination von In- und Output PDOs
0x8103 | Fehler | Allgemein | No variable linkage | Keine Variablen verknüpft
0x8104 | Fehler | Allgemein | Terminal-Overtemperature | Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden
0x8105 | Fehler | Allgemein | PD-Watchdog | Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt. - Die EtherCAT-Verbindung wurde im Betrieb unterbrochen - Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135 | Fehler | Allgemein | Cycletime has to be a multiple of 125 µs | Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar
0x8136 | Fehler | Allgemein | Configuration error: invalid sampling rate | Konfigurationsfehler: Ungültige Samplingrate
0x8137 | Fehler | Allgemein | Elektronisches Typenschild: CRC-Fehler | Inhalt des Speicher des externen Typenschildes nicht gültig.
0x8140 | Fehler | Allgemein | Sync Error | Echtzeitverletztung
0x8141 | Fehler | Allgemein | Sync%X Interrupt lost | Sync%X Interrupt fehlt
0x8142 | Fehler | Allgemein | Sync Interrupt asynchronous | Sync Interrupt asynchron
0x8143 | Fehler | Allgemein | Jitter too big | Jitter Grenzwertüberschreitung
0x817F | Fehler | Allgemein | Error: 0x%X, 0x%X, 0x%X |
0x8200 | Fehler | Kommunikation | Write access error: %d, %d | Fehler beim Schreiben
0x8201 | Fehler | Kommunikation | No communication to field-side (Auxiliary voltage missing) | - Es ist keine Spannung an den Powerkontakten angelegt - Ein Firmware Update ist fehlgeschlagen
0x8281 | Fehler | Kommunikation | Ownership failed: %X |
0x8282 | Fehler | Kommunikation | To many Keys founded |
0x8283 | Fehler | Kommunikation | Key Creation failed: %X |
0x8284 | Fehler | Kommunikation | Key loading failed |
0x8285 | Fehler | Kommunikation | Reading Public Key failed: %X |
0x8286 | Fehler | Kommunikation | Reading Public EK failed: %X |
0x8287 | Fehler | Kommunikation | Reading PCR Value failed: %X |
0x8288 | Fehler | Kommunikation | Reading Certificate EK failed: %X |
0x8289 | Fehler | Kommunikation | Challenge could not be hashed: %X |
0x828A | Fehler | Kommunikation | Tickstamp Process failed |
0x828B | Fehler | Kommunikation | PCR Process failed: %X |
0x828C | Fehler | Kommunikation | Quote Process failed: %X |
0x82FF | Fehler | Kommunikation | Bootmode not activated | Bootmode nicht aktiviert
0x8300 | Fehler | Encoder | Set position error: 0x%X, %d | Fehler beim Setzen der Position
0x8301 | Fehler | Encoder | Encoder increments not configured: 0x%X, %d | Enkoderinkremente nicht konfiguriert
0x8302 | Fehler | Encoder | Encoder-Error | Die Amplitude des Resolvers ist zu klein
0x8303 | Fehler | Encoder | Encoder supply error | Encoder Netzteil Fehler
0x8304 | Fehler | Encoder | Encoder communication error, channel: %X | Encoder Kommunikationsfehler
0x8305 | Fehler | Encoder | EnDat2.2 is not supported, channel: %X | EnDat2.2 wird nicht unterstützt
0x8306 | Fehler | Encoder | Delay time, tolerance limit exceeded, 0x%X, channel: %X | Laufzeitmessung, Toleranz überschritten
0x8307 | Fehler | Encoder | Delay time, maximum value exceeded, 0x%X, channel: %X | Laufzeitmessung, Maximalwert überschritten
0x8308 | Fehler | Encoder | Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported) | Falsche EnDat Bestellbezeichnung
0x8309 | Fehler | Encoder | Encoder CRC error, channel: %X | Encoder CRC Fehler
0x830A | Fehler | Encoder | Temperature %X could not be read, channel: %X | Temperatu kann nicht gelesen werden
0x8400 | Fehler | Drive | Incorrect drive configuration: 0x%X, %d | Antrieb fehlerhaft konfiguriert
0x8401 | Fehler | Drive | Limiting of calibration velocity: %d, %d | Begrenzung der Kalibrier-Geschwindigkeit
0x8402 | Fehler | Drive | Emergency stop activated: 0x%X, %d | Emergency-Stop aktiviert
0x8403 | Fehler | Drive | ADC Error | Fehler bei Strommessung im ADC
0x8404 | Fehler | Drive | Overcurrent | Überstrom Phase U, V, oder W
0x8405 | Fehler | Drive | Invalid modulo position: %d | Modulo-Position ungültig
0x8406 | Fehler | Drive | DC-Link undervoltage (Error) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x8407 | Fehler | Drive | DC-Link overvoltage (Error) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x8408 | Fehler | Drive | I2T-Model Amplifier overload (Error) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409 | Fehler | Drive | I2T-Model motor overload (Error) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x840A | Fehler | Drive | Overall current threshold exceeded | Summenstrom überschritten
0x8415 | Fehler | Drive | Invalid modulo factor: %d | Modulo-Faktor ungültig
0x8416 | Fehler | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Fehlerschwelle. Der Motor bleibt sofort stehen. Das Aktivieren der Endstufe wird unterbunden.
0x8417 | Fehler | Drive | Maximum rotating field velocity exceeded | Drehfeldgeschwindigkeit übersteigt den von Dual Use (EU 1382/2014) vorgeschriebenen Wert.
0x841C | Fehler | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x8550 | Fehler | Inputs | Zero crossing phase %X missing | Nulldurchgang Phase %X fehlt
0x8551 | Fehler | Inputs | Phase sequence Error | Drehrichtung Falsch
0x8552 | Fehler | Inputs | Overcurrent phase %X | Überstrom Phase %X
0x8553 | Fehler | Inputs | Overcurrent neutral wire | Überstrom Neutralleiter
0x8581 | Fehler | Inputs | Wire broken Ch %D | Leitungsbruch Ch %d
0x8600 | Fehler | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x8601 | Fehler | Allgemein IO | Supply voltage to low | Versorgungsspannung zu klein
0x8602 | Fehler | Allgemein IO | Supply voltage to high | Versorgungsspannung zu groß
0x8603 | Fehler | Allgemein IO | Over current of supply voltage | Überstrom der Versorgungsspannung
0x8610 | Fehler | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x8611 | Fehler | Allgemein IO | Output voltage to low | Ausgangsspannung zu klein
0x8612 | Fehler | Allgemein IO | Output voltage to high | Ausgangsspannung zu groß
0x8613 | Fehler | Allgemein IO | Over current of output voltage | Überstrom der Ausgangsspannung
0x8700 | Fehler |  | Channel/Interface not calibrated | Kanal/Interface nicht abgeglichen
0x8701 | Fehler |  | Operating time was manipulated | Betriebslaufzeit wurde manipuliert
0x8702 | Fehler |  | Oversampling setting is not possible | Oversampling Einstellung nicht möglich
0x8703 | Fehler |  | No slave controller found | Kein Slave Controller gefunden
0x8704 | Fehler |  | Slave controller is not in Bootstrap | Slave Controller ist nicht im Bootstrap
0x8705 | Fehler |  | Processor usage to high (>= 100%%) | Prozessorauslastung zu hoch (>= 100%%)
0x8706 | Fehler |  | Channel in saturation | Kanal in Sättigung
0x8707 | Fehler |  | Channel overload | Kanalüberlastung
0x8708 | Fehler |  | Overloadtime was manipulated | Überlastzeit wurde manipuliert
0x8709 | Fehler |  | Saturationtime was manipulated | Sättigungszeit wurde manipuliert
0x870A | Fehler |  | Channel range error | Messbereichsfehler des Kanals
0x870B | Fehler |  | no ADC clock | Kein ADC Takt vorhanden
0xFFFF | Information |  | Debug: 0x%X, 0x%X, 0x%X | Debug: 0x%X, 0x%X, 0x%X
Sehen Sie dazu auch
•
Diagnose - Grundlagen zu Diag Messages
•
Diagnose - Grundlagen zu Diag Messages
•
Diagnose - Grundlagen zu Diag Messages
•
Diagnose - Grundlagen zu Diag Messages
•
Diagnose - Grundlagen zu Diag Messages


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Firmware-Kompatibilität
•
EtherCAT AL Status Codes
•
Firmware Update EL/ES/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Zertifikate
•
Support und Service


Firmware-Kompatibilität

Anhang [image] Firmware-Kompatibilität
Firmware-Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Achtung
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL7211-0010
Hardware (HW) | Firmware (FW) | Revision-Nr. | Releasedatum
00 - 02 | 01 | EL7211-0010-0019 | 2013/10
 | 02 |  | 2013/10
02 - 05 | 03 | EL7211-0010-0020 | 2014/02
 | 04 | EL7211-0010-0021 | 2014/02
 | 05 | EL7211-0010-0022 | 2014/04
 | 06 | EL7211-0010-0023 | 2014/05
 | 07 |  | 2014/07
 | 08 | EL7211-0010-0024 | 2015/03
 | 09 |  | 2015/06
06 – 10* | 10 |  | 2015/06
 | 11 | EL7211-0010-0025 | 2016/05
 |  | EL7211-0010-0026 | 2016/02
 | 12* | EL7211-0010-0027 | 2016/11
EL7211-0010
Hardware (HW) | Firmware (FW) | Revision-Nr. | Releasedatum
00 - 02 | 01 | EL7211-0010-0019 | 2013/10
 | 02 |  | 2013/10
02 - 05 | 03 | EL7211-0010-0020 | 2014/02
 | 04 | EL7211-0010-0021 | 2014/02
 | 05 | EL7211-0010-0022 | 2014/04
 | 06 | EL7211-0010-0023 | 2014/05
 | 07 |  | 2014/07
 | 08 | EL7211-0010-0024 | 2015/03
 | 09 |  | 2015/06
06 – 10* | 10 |  | 2015/06
 | 11 | EL7211-0010-0025 | 2016/05
 |  | EL7211-0010-0026 | 2016/02
 | 12* | EL7211-0010-0027 | 2016/11
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Achtung
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Gerätebeschreibung ESI-File/XML
Achtung
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Hinweis
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. „EEPROM Update“
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. „Auswahl des neuen ESI“. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Hinweis
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
Hinweis
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. „Anzeige FW-Stand EL3204“ wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.
Update Controller-Firmware *.efw
Hinweis
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. „Firmware Update“.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei
▪
Nach Beendigung des Download in INIT schalten, dann in OP
▪
Slave kurz stromlos schalten
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu "Eigenschaften" (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog "Advanced settings"
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.
Dialog "Weitere Eimstellungen" wählen
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,
Dialog "Schreibe FPGA" wählen
Datei auswählen
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.
Achtung
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!
Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. „Auswahl des PDO ‚Restore default parameters‘“)
Auswahl des PDO "Restore default parameters"
Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. „Eingabe des Restore-Wertes im Set Value Dialog“).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Hinweis
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:Dezimalwert: "1819238756", Hexadezimalwert: "0x6C6F6164"Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Zertifikate

Anhang [image] Zertifikate
Zertifikate
EL72x1-9014_Certificate


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.