EL70x7 - Schrittmotorklemmen mit Feldorientierter Regelung
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
1.7 | - Update Revisionsstatus - Strukturupdate
1.6 | - Update Kapitel „Vorwort“ - Update Revisionsstatus - Strukturupdate
1.5 | - Update Kapitel „Technische Daten“ - Update Kapitel „Installation“ - Update Revisionsstatus - Strukturupdate
1.4 | - Update Kapitel „Technische Daten“ - Update Kapitel „PDO-Zuordnung“ - Update Kapitel „Predefined PDO Assignment“ - Update Revisionsstatus - Strukturupdate
1.3 | - Update Kapitel „Technische Daten“ - Update Revisionsstatus - Strukturupdate
1.2 | - Update Kapitel „Technische Daten“ - Update Kapitel „Inbetriebnahme“ - Update Kapitel „Diagnose“ - Update Revisionsstatus - Strukturupdate
1.1 | - Update Technische Daten
1.0 | - Korrekturen - Layout-Anpassungen - 1. Veröffentlichung
0.4 | - Korrekturen - EL7037 ergänzt
0.3 | - Ergänzungen, Korrekturen
0.2 | - Ergänzungen, Korrekturen
0.1 | - Vorab-Dokumentation


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
Aufbau des BICs
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL7037
•
EL7047
•
Technologie
•
Start up


EL7037

Produktübersicht [image] EL7037
EL7037
Weiterführende Informationen
•
EL7037 - Einführung
•
EL7037 - Technische Daten


EL7037 - Einführung

Produktübersicht [image] EL7037 [image] EL7037 - Einführung
EL7037 - Einführung
EL7037
Schrittmotorklemme, 24 V DC, 1,5 A, mit Feldorientierter Regelung
Die Die EtherCAT-Klemme EL7037 ist für den kleinen Leistungsbereich von Schrittmotoren vorgesehen. Die PWM-Endstufen decken einen großen Spannungs- und Strombereich ab. Sie sind, zusammen mit zwei Eingängen für Endlagenschalter, in der EtherCAT-Klemme untergebracht. Mit nur wenigen Parametern kann die EL7037 an den Motor und die Anwendung angepasst werden.
Für Schrittmotoren der Serie AS10xx lässt sich eine feldorientierte Regelung auswählen. Damit sind diverse Vorteile, wie eine bessere Dynamik und eine geringere Stromaufnahme, verbunden.
Zusammen mit einem Schrittmotor AS10xx stellt die EL7037 einen preiswerten Kompaktantrieb dar.
Schnellverweise
Hinweise zum Anschluss
• Kapitel "Montage und Verdrahtung",
- LEDs und Anschlussbelegung
- Anschlussbeispiele
Hinweise zur Inbetriebnahme
• Kapitel "Inbetriebnahme",
- Installation unter TwinCAT
- Einbinden in die NC-Konfiguration
- Grundlagen zum "Positioning interface"
Hinweise zur Konfiguration
• Kapitel "Inbetriebnahme",
- Konfiguration der wichtigsten Parameter - Einstellungen im CoE-Register
- Konfiguration der wichtigsten Parameter - Einstellungen in der NC

• Kapitel "Konfiguration mit dem TwinCAT System Manager",
- Objektbeschreibung und Parametrierung
Anwendungsbeispiel
• Kapitel "Inbetriebnahme",
- Anwendungsbeispiel


EL7037 - Technische Daten

Produktübersicht [image] EL7037 [image] EL7037 - Technische Daten
EL7037 - Technische Daten
Technische Daten | EL7037
Anzahl Ausgänge | 1 Schrittmotor, 2 Phasen
Anzahl digitale Eingänge | 2 Endlage, 4 für ein Gebersystem
Anzahl digitale Ausgänge | 1 konfigurierbar für Bremse (0,5 A)
Versorgungsspannung | 24 V DC (-15 %/+20 %)
Ausgangsstrom ohne Lüftermodul ZB8610 | 1,5 A (überlast- und kurzschlussfest)
Ausgangsstrom mit Lüftermodul ZB8610 | 3,0 A (überlast- und kurzschlussfest)
Betriebsmodi | Standardbetrieb (Velocity direct / Position controller) Feldorientierte Regelung (Extended Velocity mode / Extended Position mode) Sensorloser Betrieb Fahrwegsteuerung (Positioning interface)
Maximale Schrittfrequenz | 1.000, 2.000, 4.000, 8000 oder 16.000 Vollschritte/s (konfigurierbar)
Schrittmuster | bis zu 64-fach-Microstepping (automatische Umschaltung, Geschwindigkeitsabhängig)
Stromreglerfrequenz | ca. 30 kHz
Encoder-Pulsfrequenz | max. 400.000 Inkremente/s (4-fach Auswertung)
Eingangs-Signalspannung „0“ | -3 V … 2 V
Eingangs-Signalspannung „1“ | 3,7 V … 28 V
Eingangsstrom | typ. 5 mA
Diagnose-LED | Warnung Strang A und B, Fehler Strang A und B, Power, Enable
Auflösung | ca. 5.000 Positionen in typischen Anwendungen (pro Umdrehung)
Spannungsversorgung | über den E-Bus, Enkoder/Treiberstufe: über die Powerkontakte, Motor: über Klemmenkontakte
Stromaufnahme aus dem E-Bus | typ. 100 mA
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
Unterstützung NoCoEStorage | ja
Konfiguration | keine Adresseinstellung erforderlich Konfiguration über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 gemäß IEC/EN 61800-3
EMV Kategorie | Kategorie C3 - Standard Kategorie C2, C1 - Zusatzfilter erforderlich
Schutzart | IP 20
Einbaulage | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2) siehe Hinweis
Zulassung | CE cULus


EL7047

Produktübersicht [image] EL7047
EL7047
Weiterführende Informationen
•
EL7047 - Einführung
•
EL7047 - Technische Daten


EL7047 - Einführung

Produktübersicht [image] EL7047 [image] EL7047 - Einführung
EL7047 - Einführung
EL7047
Schrittmotorklemme, 50 V DC, 5 A, mit Feldorientierter Regelung
Die EtherCAT-Klemme EL7047 ist für den mittleren Leistungsbereich von Schrittmotoren vorgesehen. Die PWM-Endstufen decken einen großen Spannungs- und Strombereich ab. Sie sind zusammen mit zwei Eingängen für Endlagenschalter in der EtherCAT-Klemme untergebracht.
Mit einigen Parametern kann die EL7047 an den Motor und die Anwendung angepasst werden. Ein besonders ruhiger und präziser Motorlauf ist durch ein 64-fach-Microstepping sichergestellt.
Für Schrittmotoren der Reihe AS1xxx von Beckhoff Automation lässt sich eine feldorientierte Regelung auswählen. Damit sind viele Vorteile, wie z. B. eine bessere Dynamik und eine geringere Stromaufnahme, verbunden.
Zusammen mit einem Schrittmotor und einen Encoder stellt die EL7047 eine preiswerte Klein-Servoachse dar.
Die LEDs zeigen Status-, Warn- und Fehlermeldungen sowie eventuell aktive Limitierungen an.
Schnellverweise
Hinweise zum Anschluss
• Kapitel "Montage und Verdrahtung",
- LEDs und Anschlussbelegung
- Anschlussbeispiele
Hinweise zur Inbetriebnahme
• Kapitel "Inbetriebnahme",
- Installation unter TwinCAT
- Einbinden in die NC-Konfiguration
- Grundlagen zum "Positioning interface"
Hinweise zur Konfiguration
• Kapitel "Inbetriebnahme",
- Konfiguration der wichtigsten Parameter - Einstellungen im CoE-Register
- Konfiguration der wichtigsten Parameter - Einstellungen in der NC

• Kapitel "Konfiguration mit dem TwinCAT System Manager",
- Objektbeschreibung und Parametrierung
Anwendungsbeispiel
• Kapitel "Inbetriebnahme",
- Anwendungsbeispiel


EL7047 - Technische Daten

Produktübersicht [image] EL7047 [image] EL7047 - Technische Daten
EL7047 - Technische Daten
Technische Daten | EL7047
Anzahl Ausgänge | 1 Schrittmotor, 2 Phasen
Anzahl digitale Eingänge | 2 Endlage, 4 für ein Gebersystem
Anzahl digitale Ausgänge | 1 konfigurierbar für Bremse (0,5 A)
Versorgungsspannung | 8…50 V DC
Ausgangsstrom ohne Lüftermodul ZB8610 | 5 A (überlast- und kurzschlussfest)
Ausgangsstrom mit Lüftermodul ZB8610 | 6,5 A (überlast- und kurzschlussfest)
Betriebsmodi | Standardbetrieb (Velocity direct / Position controller) Feldorientierte Regelung (Extended Velocity mode / Extended Position mode) Sensorloser Betrieb Fahrwegsteuerung (Positioning interface)
Maximale Schrittfrequenz | 1.000, 2.000, 4.000, 8000 oder 16.000 Vollschritte/s (konfigurierbar)
Schrittmuster | bis zu 64-fach-Microstepping (automatische Umschaltung, Geschwindigkeitsabhängig)
Stromreglerfrequenz | ca. 30 kHz
Encoder-Pulsfrequenz | max. 400.000 Inkremente/s (4-fach Auswertung)
Eingangs-Signalspannung „0“ | -3 V … 2 V
Eingangs-Signalspannung „1“ | 3,7 V … 28 V
Eingangsstrom | typ. 5 mA
Diagnose-LED | Warnung Strang A und B, Fehler Strang A und B, Power, Enable
Auflösung | ca. 5.000 Positionen in typischen Anwendungen (pro Umdrehung)
Spannungsversorgung | über den E-Bus, Enkoder/Treiberstufe: über die Powerkontakte, Motor: über Klemmenkontakte
Stromaufnahme aus dem E-Bus | typ. 140 mA
Potenzialtrennung | 500 V (E-Bus/Signalspannung)
Unterstützung NoCoEStorage | ja
Konfiguration | keine Adresseinstellung erforderlich Konfiguration über TwinCAT System Manager
Gewicht | ca. 105 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4 gemäß IEC/EN 61800-3
EMV Kategorie | Kategorie C3 - Standard Kategorie C2, C1 - Zusatzfilter erforderlich
Schutzart | IP 20
Einbaulage | ohne Lüftermodul ZB8610: Standard-Einbaulage mit Lüftermodul ZB8610: Standard-Einbaulage, weitere Einbaulagen (Beispiel 1 & 2) siehe Hinweis
Zulassung | CE cULus


Technologie

Produktübersicht [image] Technologie
Technologie
Die Schrittmotorklemme EL70x7 integriert eine kompakte Motion-Control-Lösung für Schrittmotoren in kleinster Bauform.
Der Anwender hat die Möglichkeit Schrittmotoren vom kleinen bis zum mittleren Leistungsbereich anzusteuern. Mit dem Ausgangsstrom von bis zu 5 A kann die EL7047 ein beachtliches Drehmoment von z. B. 5 Nm an einem Standardschrittmotor erreichen. Die Versorgungsspannung von bis zu 50 VDC erlaubt hohe Drehzahlen mit gutem Drehmoment und damit eine hohe mechanische Leistung. Der Schrittmotor, sowie ein Inkrementalencoder, können direkt an die EL70x7 angeschlossen werden.
Die Schrittmotorklemme stellt 3 grundsätzliche Betriebsarten zur Verfügung.
Im Standard Betrieb lassen sich alle uni- und bipolaren Schrittmotoren ansteuern, die den Spezifikationen der entsprechenden EL70x7 genügen. Es werden zwei Ströme mit Sinus-/Cosinus-Verlauf gestellt. Der Strom wird mit 64 kHz getaktet und mit bis zu 64-fachem Microstepping aufgelöst, um einen glatten Stromverlauf zu ermöglichen.

Hinter dem Extended Mode verbirgt sich eine Feldorientierte Regelung. Mit dieser Betriebsart lassen sich nur Schrittmotoren der Firma Beckhoff betreiben. Der Strom wird nicht einfach gestellt, sondern es erfolgt eine umfangreiche Regelung. Typische Schrittmotorprobleme, wie eine ausgeprägte Resonanz, gehören damit endgültig der Vergangenheit an. Des Weiteren wird der Strom lastabhängig eingestellt und ermöglicht dadurch eine erheblichen Energieeinsparung und geringere thermische Belastungen am Schrittmotor.

Mit dem Sensorlosen Betrieb können Schrittmotoren der Firma Beckhoff auch ohne Feedbacksystem lastabhängig geregelt werden.
Realisierung von anspruchsvolleren Positionieraufgaben
Anspruchsvollere Positionieraufgaben lassen sich mit Hilfe der Beckhoff-Automatisierungssoftware TwinCAT realisieren. Die Schrittmotorklemmen werden, wie andere Achsen, via TwinCAT System Manager eingebunden und sind wie übliche Servoachsen zu nutzen. Besondere Eigenarten des Schrittmotors, wie Rücknahme der Drehzahlvorgabe bei zu großem Schleppfehler, werden automatisch durch die Option Schrittmotorachse berücksichtigt. Der Aufwand, von einem Servomotor auf einen Schrittmotor - und zurück - zu wechseln, ist nicht größer, als unter TwinCAT der Wechsel von einem Feldbus zum anderen.
Die Endstufen der Schrittmotorklemmen besitzen eine Überlastsicherung in Form einer Übertemperaturwarnung und -abschaltung. Zusammen mit der Kurzschlusserkennung werden die Diagnosedaten im Prozessabbild der Steuerung zugänglich gemacht. Zusätzlich wird dieser Status, neben weiteren Informationen durch die LEDs der Busklemme angezeigt. Mit einem Enable-Bit wird die Endstufe eingeschaltet. Über einen Parameterwert kann der Motorstrom eingestellt und abgesenkt werden.
Die optimale Anpassung an den Motor und der energiesparende Einsatz in der Anwendung erfordern keinen großen Programmieraufwand. Da alle Daten in Form von Parametern im CoE-Register eingestellt werden, ist es leicht möglich, eine EtherCAT-Klemme auszutauschen oder einmal erarbeitete Parameter zu speichern und in ein nächstes Projekt zu übertragen. Das Übertragen bestimmter Potentiometer-Einstellungen und Dokumentieren von DIP-Schalter-Einstellungen ist somit nicht mehr erforderlich.
Weiterführende Informationen
•
Schrittmotor
•
Standard Betrieb
•
Feldorientierte Regelung
•
Sensorloser Betrieb


Schrittmotor

Produktübersicht [image] Technologie [image] Schrittmotor
Schrittmotor
Der Schrittmotor ist ein Elektromotor, vergleichbar dem Synchronmotor. Der Rotor ist als Permanentmagnet ausgeführt, während der Stator aus einem Spulenpaket besteht. Die Frequenz des Statordrehfeldes steht immer in einem festen Verhältnis zur Drehzahl des Rotors. Im Unterschied zum Synchronmotor verfügt der Schrittmotor über eine große Zahl von Polpaaren. Bei einfachster Ansteuerung schaltet man den Schrittmotor von Pol zu Pol, bzw. von Schritt zu Schritt.
Schrittmotoren sind schon seit vielen Jahren im Einsatz. Sie zeichnen sich durch Robustheit aus, lassen sich leicht ansteuern und liefern ein hohes Drehmoment. Die Möglichkeit die Schritte mit zu zählen erspart in vielen Anwendungsfällen ein kostenintensives Rückführungssystem. Auch nach der zunehmenden Verbreitung der Synchron-Servomotoren ist der Schrittmotor keineswegs „in die Jahre gekommen“, sondern gilt als ausgereift und wird nach wie vor weiter entwickelt, um Kosten und Baugröße zu reduzieren und um Drehmoment und Zuverlässigkeit zu steigern. Bei einem Standard-Schrittmotor mit 200 Vollschritten beträgt die bestmögliche Positioniergenauigkeit ca. 1,8°.
Heute werden in der Industrie überwiegend Hybridschrittmotoren verwendet. Der Rotor besteht bei diesem Motortyp aus einem gezahnten Eisenkern mit einem oder wenigen Permanentmagneten im Kern des Rotors. Der Rotor ist dabei so konstruiert, dass die Polung der aufeinander folgenden Zähne jeweils invers ist. So lassen sich Motoren mit einer hohen Schrittzahl, welche ausschlaggebend für die Positioniergenauigkeit ist, kombiniert mit einem vergleichsweise hohen Drehmoment herstellen. Das elektrische Verhalten eines solchen Hybridschrittmotors ist näherungsweise vergleichbar mit dem eines hochpoligen Synchronservomotors. Durch die synchrone Zahnung von Stator und Rotor ergibt sich jedoch beim Hybridschrittmotor ein wesentlich höheres Rastmoment.
Auf dem Markt werden Hybridschrittmotoren mit zwei oder mehr Phasen angeboten. Da die beschriebenen Klemmen für zweiphasige Motoren ausgelegt sind, wird jedoch hier nur auf den zweiphasigen Typ eingegangen, dessen Phasen in dieser Dokumentation mit A und B bezeichnet werden.
Mit der Entwicklung der EtherCAT-Klemmen EL70x7 für das Beckhoff EtherCAT-Klemmen-System erschließen sich neue Anwendungsfelder. Der Einsatz von Microstepping, neuester Halbleitertechnologie und einer Feldorientierten Regelung (nur mit eigenen Motoren) bietet viele Vorteile:
▪
größere Laufruhe
▪
Vermeidung von Resonanzen
▪
sinkender Energieverbrauch
▪
geringere thermische Belastung des Motors
▪
kaum elektromagnetische Abstrahlung
▪
große Leitungslängen
▪
einfachere Handhabung
▪
reduzierte Bauform der Leistungselektronik
▪
einfache Integration in übergeordnete Systeme
▪
integriertes Rückführungssystem
Parameter eines Schrittmotors
• Mechanisches System
Unabhängig vom Antrieb und dem Schrittmotor selbst hat der Aufbau der an der Motorwelle befestigten Mechanik einen wesentlichen Einfluss auf die erreichbare Regelgüte.
Eigenresonanz, Lastresonanzen, Getriebespiel (Lose) und Haftreibung beeinträchtigen die Regelbarkeit des Antriebssystems negativ. Dies erfordert oft eine etwas weichere Reglerparametrierung, die wiederum zu einer Erhöhung des Schleppabstands im System führt. Gleitreibung bewirkt wegen des erhöhten Energiebedarfs einerseits eine Verschlechterung des Wirkungsgrades, kann jedoch die Stabilität der Regelung wegen ihrer dämpfenden Wirkung auch positiv beeinflussen.
Prinzipiell gilt, je steifer die Mechanik eines Antriebssystems konstruiert ist, umso einfacher lässt es sich regeln, was das Erreichen eines kleinen Schleppabstands im Antriebsystem begünstigt.
• Drehzahl
Die maximale Drehzahl eines Schrittmotors ist gering und wird meist als maximale Schrittfrequenz angegeben.
• Phasenzahl
Üblich sind 2- bis 5-Phasen-Motoren. Die EtherCAT-Klemmen EL70x7 unterstützen 2-Phasen-Motoren. 4-Phasen-Motoren sind im Grunde 2-Phasen-Motoren mit getrennt herausgeführten Wicklungsenden und können direkt an die EtherCAT-Klemme angeschlossen werden.
• Drehmoment
Bezeichnet das maximale Drehmoment des Motors bei unterschiedlichen Drehzahlen. Meist wird eine Kennlinie zur Darstellung verwendet. Das Drehmoment eines Schrittmotors ist im unteren Drehzahlbereich vergleichsweise hoch und ermöglicht in vielen Anwendungsfällen einen direkten Einsatz ohne weiteres Getriebe. Ein Schrittmotor liefert, im Vergleich zu anderen Motoren, ohne großen Aufwand ein Haltemoment, das in der Größenordnung des Drehmoments liegt.
• Rastmoment
Das bei Schrittmotoren konstruktionsbedingt oft stark ausgeprägte Rastmoment kann in einem motor- und lastabhängen Drehzahlbereich zu einer verhältnismäßig starken Eigenresonanz führen. Eine erhöhte Massenträgheit führt in Bezug auf das Rastmoment oft zu einer weniger stark ausgeprägten Resonanz und einer höheren Laufruhe.
• Massenträgheitsmoment
Im Standard Betrieb ist der wesentliche Parameter des mechanischen Systems das Massenträgheitsmoment JΣ. Es setzt sich im Wesentlichen aus dem Massenträgheitsmoment des Schrittmotorrotors JM und dem Massenträgheitsmoment der angeschlossenen Last JL zusammen. Reibmomente JReib und das Trägheitsmoment eines Encoders JEnc werden in erster Näherung vernachlässigt.
JƩ ≈ JM + JL
Das Verhältnis zwischen Lastmoment und Motormoment wird über die Konstante kJ angegeben.
kJ ≈ JL / JM
Vereinfachte Darstellung der Massenträgheitsmomente
Die Kopplung der einzelnen Massen über die Rotorwelle kann in erster Näherung als Zweimassenschwinger modelliert werden. Die Resonanzfrequenz zwischen Motor und Encoder liegt dabei in einem relativ hohen Frequenzbereich, der bei Schrittmotorantrieben in der Regel nicht relevant ist und wird antriebsintern durch Tiefpassfilterung unterdrückt. Die Resonanzfrequenz zwischen Motor und Last liegt häufig im Bereich zwischen 20 und 500 Hz. Sie liegt damit oft im Betriebsbereich der Antriebsregelung. Eine Reduzierung des Einflusses der Lastresonanz kann konstruktionstechnisch über ein kleines Lastverhältnis kJ und eine möglichst steife Kopplung der Motorwelle zur angeschlossenen Last erreicht werden.
• Resonanzen
In bestimmten Drehzahlbereichen zeigen Schrittmotoren einen mehr oder weniger rauen, unrunden Lauf. Dieses Phänomen ist besonders ausgeprägt, wenn der Motor ohne angekoppelte Last läuft; unter Umständen kann er dabei sogar stehen bleiben (im Standard Betrieb). Die Ursache ist in Resonanzen zu sehen. Grob kann man unterscheiden zwischen
▪
Resonanzen im unteren Frequenzbereich bis ca. 250 Hz und
▪
Resonanzen im mittleren bis oberen Frequenzbereich.
Die Resonanzen im mittleren bis oberen Frequenzbereich resultieren im Wesentlichen aus den elektrischen Kenngrößen wie Induktivität der Motorwicklung und Zuleitungskapazitäten. Sie sind über eine hohe Taktung der Regelung relativ einfach in den Griff zu bekommen.
Die Resonanzen im unteren Bereich resultieren im Wesentlichen aus den mechanischen Kenngrößen des Motors. Sie bewirken im Allgemeinen außer dem rauen Lauf, teilweise einen recht erheblichen Drehmomentverlust, bis hin zum Schrittverlust des Motors und sind also in der Anwendung besonders störend.
Der Schrittmotor stellt im Grunde ein schwingungsfähiges System dar, vergleichbar mit einem Masse-Federsystem, bestehend aus dem sich bewegenden Rotor mit Trägheitsmoment und einem magnetischen Feld, das eine Rückstellkraft auf den Rotor erzeugt. Beim Auslenken und Loslassen des Rotors wird eine gedämpfte Schwingung erzeugt. Entspricht die Ansteuerfrequenz der Resonanzfrequenz, wird die Schwingung verstärkt, so dass der Rotor im ungünstigsten Fall den Schritten nicht mehr folgt und zwischen zwei Rastungen hin und her schwingt.
Die EtherCAT-Klemmen EL70x7 verhindern diesen Effekt durch ihre Feldorientierte Regelung (Extended Operation Modes) bei allen Beckhoff Schrittmotoren.
• Drehmomentkonstante
In den Extended Operation Modes kommt als Parameter der mechanischen Regelstrecke die Drehmomentkonstante kT hinzu, die das Verhältnis zwischen dem drehmomentbildenden Motorstrom und des an der Welle wirksamen Drehmoments angibt. Da der Betrieb im feldorientierten Modus bei Schrittmotoren nicht üblich ist, ist die Drehmomentkonstante jedoch meist nicht im Motordatenblatt zu finden.
Elektrisches System
• Nennspannung, Versorgungsspannung und Wicklungswiderstand
Im stationären Zustand fließt der Nennstrom bei Nennspannung, in Abhängigkeit zum Wicklungswiderstand. Diese Spannung sollte nicht mit der Versorgungsspannung der Leistungsendstufe in der EtherCAT-Klemme verwechselt werden. Die EL70x7 gibt einen geregelten Strom auf die Motorwicklung. Unterschreitet die Versorgungsspannung die Nennspannung, kann die Leistungsendstufe den Strom nicht mehr in voller Höhe einprägen und ein Drehmomentverlust ist die Folge. Erstrebenswert sind ein kleiner Wicklungswiderstand und eine hohe Versorgungsspannung, um die Erwärmung gering zu halten und ein möglichst hohes Drehmoment bei hohen Drehzahlen zu erreichen.
• Induzierte Gegenspannung
Hybridschrittmotoren induzieren, wie Servomotoren auch, eine drehzahlproportionale Spannung ui [Vs/rad] in die Statorwicklung des Motors. Diese wird häufig auch als Back Electromotive Force (BEMF) bezeichnet. Die induzierte Gegenspannung bestimmt in Verbindung mit der Zwischenkreisspannung (Motorspannung) die physikalisch erreichbare Maximaldrehzahl des Motors.
Das Verhältnis des Betrages der induzierten Gegenspannung zur Motordrehzahl ist konstruktionsbedingt variabel und wird über die Spannungskonstante ke beschrieben.
ui = ke·ωm
Der Motorparameter ke [mV/(rad/s)] wird für die Schrittverlusterkennung ohne Encoder und die sensorlose Regelung benötigt.
Bei Schrittmotoren bei denen die Spannungskonstante nicht im Datenblatt angegeben ist, kann sie relativ einfach mit Hilfe eines Digitalmultimeters ermittelt werden. Dazu muss der zu vermessende Motor (innerhalb des Nenndrehzahlbereichs) durch einen Hilfsmotor über eine Kupplung mit konstanter Drehzahl betrieben werden. Die Motorphasen des zu vermessenden Motors müssen dazu offen sein (Nicht an der Klemme angeschlossen oder kurzgeschlossen). Mit dem Multimeter kann der Effektivwert der induzierten Gegenspannung dann an einer der beiden offenen Motorphasen (A oder B) ermittelt werden und damit die Spannungskonstante bestimmt werden.
• Schrittwinkel
Der Schrittwinkel gibt den bei einem Schritt zurückgelegten Winkel an. Typische Werte sind 3,6°, 1,8° und 0,9°. Das entspricht 100, 200 und 400 Schritten pro Motorumdrehung. Dieser Wert ist, zusammen mit der nachgeschalteten Übersetzung, ein Maß für die Positioniergenauigkeit. Aus technischen Gründen lässt sich der Schrittwinkel nicht beliebig reduzieren. Die Positioniergenauigkeit kann nur mechanisch durch die Übersetzung gesteigert werden. Eine elegante Lösung zur Erhöhung der Positioniergenauigkeit ist das Microstepping der EL70x7. Es erlaubt bis zu 64 Zwischenschritte. Der geringere, „künstliche“ Schrittwinkel hat einen weiteren positiven Effekt: Bei gleicher Genauigkeit kann der Antrieb mit einer höheren Geschwindigkeit gefahren werden. Die maximale Drehzahl bleibt erhalten, obwohl der Antrieb an der Grenze der mechanischen Auflösung positioniert.
• Wicklungswiderstand, Wicklungsinduktivität
Wicklungsinduktivität und Wicklungswiderstand des Stators des Schrittmotors bestimmen die elektrische Motorzeitkonstante Te = L / R, die für die Auslegung des Stromreglers maßgeblich ist.
Bestimmung des Schrittmotors
1.
Bestimmung der erforderlichen Positioniergenauigkeit und - dadurch bedingt - der Schrittauflösung. Zunächst muss geklärt werden, wie die Auflösung erreicht werden kann. Mechanische Untersetzungen, wie Spindel, Getriebe oder Zahnstangen führen zu einer Erhöhung. Zu berücksichtigen ist auch das 64-fache Microstepping der Schrittmotorklemmen.
2.
Bestimmung der Massen m und der Trägheitsmomente (J) aller zu bewegenden Teile.
3.
Berechnung der Beschleunigung, die sich durch die zeitlichen Anforderungen der bewegten Massen ergibt.
4.
Berechnung der auftretenden Kräfte aus Massen, Trägheitsmomenten und den jeweiligen Beschleunigungen.
5.
Umrechnung der Kräfte und Geschwindigkeiten auf die Motorachse, unter besonderer Berücksichtigung der Wirkungsgrade, Reibungsmomente und der mechanischen Größen, wie der Übersetzung. Praktischerweise berechnet man den Antrieb vom letzten Glied (das ist in der Regel die Last) aus rückwärts. Jedes weitere Element überträgt Kraft und Geschwindigkeit und führt durch Reibung zu weiteren Kräften oder Drehmomenten. An der Motorwelle ergibt sich während der Positionierung die Summe aller Kräfte und Drehmomente. Das Ergebnis ist ein Geschwindigkeits-/Drehmomentverlauf, den der Motor zu erbringen hat.
6.
Aus der Drehmomentkennlinie ist der Motor zu ermitteln, der die Mindestanforderungen erfüllt. Das Trägheitsmoment des ermittelten Motors ist zum gesamten Antrieb zu addieren. Eine erneute Überprüfung wird notwendig. Das Drehmoment sollte, um eine ausreichende Praxissicherheit zu gewährleisten, 20% bis 30% überdimensioniert sein. Gegenteilig kann die Optimierung verlaufen, wenn der größte Teil der Beschleunigung für das Rotorträgheitsmoment aufgebracht werden muss. In diesem Fall sollte der Motor möglichst klein ausgelegt werden.
7.
Test des Motors unter realen Anwendungsbedingungen: Die Gehäusetemperaturen sind im Dauerbetrieb zu überwachen. Werden die Berechnungen nicht von den Testergebnissen bestätigt, müssen die angenommenen Ausgangsgrößen und die Randbedingungen auf ihre Richtigkeit überprüft werden. Wichtig ist auch die Überprüfung von Randeffekten, wie Resonanzerscheinungen, Spiel in der Mechanik, Einstellungen der maximalen Lauffrequenz und der Rampensteilheit.
8.
Der Antrieb kann zur Erhöhung der Leistung durch unterschiedliche Maßnahmen optimiert werden: Auswahl leichterer Materialien, Hohlkörper, statt volles Material, und Reduzierung der mechanischen Massen. Großen Einfluss auf das Verhalten des Antriebs übt auch die Ansteuerung aus. Die Busklemme ermöglicht den Betrieb mit unterschiedlichen Versorgungsspannungen. Die Drehmomentkennlinie kann durch höhere Spannung verlängert werden. Dabei liefert ein Stromanhebungsfaktor im entscheidenden Augenblick das erhöhte Drehmoment, während eine allgemeine Absenkung des Stroms die Temperatur des Motors deutlich reduziert. In Sonderfällen kann auch eine speziell angepasste Motorwicklung sinnvoll sein.


Standard Betrieb

Produktübersicht [image] Technologie [image] Standard Betrieb
Standard Betrieb
Ursprünglich wurden Schrittmotoren mit sehr einfachen Endstufen betrieben, die lediglich dazu in der Lage waren die Spannungen der Motorphasen separat zu schalten (heutzutage ist die Stromregelung über eine PWM mit Pulsbreitenmodulation Standard). Zunächst wurden die Motorphasen dabei der Reihe nach einzeln angesteuert. Eine Schaltsequenz in positiver Drehrichtung entspricht der Schaltreihenfolge (+A, +B, -A, -B). Durch das sequentielle Schalten ergibt sich mit diesem Betrieb ein sehr unrunder Lauf. Um die Laufruhe zu verbessern, wurde später das so genannte Microstepping eingeführt, wobei die vier Spannungssollwerte durch Zwischenwerte (z.B. aus einer hinterlegten Sinustabelle) erweitert werden. Heute wird häufig ein Microstepping von 64 Schritten verwendet.
Regelstruktur eines Standard Schrittmotorantriebs
Unter Vernachlässigung der durch das Microstepping bedingten weiterhin vorhandenen Abtastung kann der Motorstrom I in Abhängigkeit des elektrischen Winkels φe und des Betrages des Motorstromes IABS (bei Verwendung einer Stromregelung) wie folgt beschrieben werden:
I(φe) = IA+ jIB= IABScos(φe) + jIABSsin(φe)
Dargestellt durch Betrag und Winkel ergibt sich:
I(φe ) = IABS · e jφe
Daraus geht hervor, dass eine Umdrehung des elektrischen Winkels φe vier Vollschritten entspricht. (Ein Schrittmotor mit 200 Vollschritten besitzt demzufolge 50 Polpaare).
Wird ein konstanter Strom bei unbelasteter Motorwelle eingestellt, so richtet sich die Welle aus. Die Welle zeigt dabei (innerhalb eines Polpaares) in Richtung des wirksamen Statorfeldes.
Wird die Motorwelle von außen belastet, wird die Welle aus der Feldrichtung herausgedreht und es stellt sich ein Lastwinkel (auch Polradwinkel) ein (bezogen auf eine elektrische Umdrehung des Winkels φe). Die Höhe des Lastwinkels ist abhängig vom Aufbau des Schrittmotors selbst, von der Höhe des Motorstroms und von der Höhe des an der Welle wirksamen Drehmoments. Der Zusammenhang ist nichtlinear!
Überschreitet der Lastwinkel eine motorabhängigen Maximalwert (das unter diesen Randbedingungen maximale Drehmoment der Maschine wird überschritten), so kann das Lastmoment vom Motor nicht mehr gehalten werden. Dreht man die Welle weiter aus dem Drehfeld heraus, „kippt“ sie und ein oder mehrere Schrittverluste sind die Folge. Die Höhe des „Kippwinkels“ kann von Motortyp zu Motortyp unterschiedlich sein. Oft liegt er zwischen ca. 45° und 65°.
Verhalten des Rotors bei Belastung
Da der Lastwinkel Rückschlüsse auf die Belastung der Welle zulässt ist er für den Nutzer interessant. Er wird durch die Auswertung der induzierten Gegenspannung* gemessen und kann zur Optimierung des Antriebssystems verwendet werden.


Feldorientierte Regelung

Produktübersicht [image] Technologie [image] Feldorientierte Regelung
Feldorientierte Regelung
In den Extended Operation Modes wird der Schrittmotor wie ein Servomotor nach dem Prinzip der Feldorientierten Regelung betrieben.
Funktion
Das Betriebsverhalten des Motors entspricht dabei dem Verhalten eines traditionellen Gleichstrommotors, bei dem die Kommutierung über einen mechanischen Kommutator erfolgt. Das Drehmoment der Gleichstrommaschine ist bei konstantem Erregerfeld direkt proportional zum Statorstrom und kann über diesen direkt beeinflusst werden. Das Erregerfeld wird je nach Maschinentyp durch Permanentmagnete oder z.B. bei einer fremderregten Gleichstrommaschine über eine separate Erregerwicklung erzeugt.
Koordinatentransformation der Feldorientierten Regelung
Bei Servomotoren und auch beim Hybridschrittmotor besteht zunächst kein direkter Zusammenhang zwischen den Phasenströmen und dem Drehmoment. Die Entkopplung von Feld und Drehmoment wird über die so genannte Park-Transformation mathematisch vorgenommen. Dabei werden aus den Phasenströmen zwei Stromkomponenten, „d“, für „direkt“ in Feldrichtung und „q“ für „quadratur“ in drehmomentbildender Richtung, berechnet. Über die drehmomentbildende Stromkomponente iq kann das Drehmoment der Maschine nun wie bei der Gleichstrommaschine direkt geregelt werden.

Voraussetzung ist, dass die Position des Rotors in ausreichend hoher Genauigkeit zur Verfügung steht. Beim Schrittmotor sollte die Encoderauflösung, um eine ausreichende Positioniergenauigkeit zu erreichen, mindestens 4000 Incremente pro einer mechanischen Umdrehung betragen. Weiterhin ist die Mindestauflösung des Encoders von der Anzahl der Vollschritte abhängig und kann näherungsweise wie folgt berechnet werden.
Berechnung der Auflösung
Kommutierungsfindung für Extended Operation Modes
Da die Istposition bei Inkrementalencodern nicht absolut vorliegt, besteht beim Systemstart kein direkter Bezug zur Position des Rotors, der für den feldorientierten Betrieb erforderlich ist. Der Bezug der Istposition zur Rotorposition muss daher beim Systemstart über eine Kommutierungsfindung hergestellt werden. Während dieses Vorgangs wird der Rotor mehrfach um bis zu zwei Vollschritte vor und zurück bewegt.
Kommutierungsfindung
•
Der Maximalstrom „Maximal Current“ sollte nicht wesentlich unterhalb des Motornennstromes eingestellt sein.
•
Während der Kommutierungsfindung darf die Rotorwelle nicht von außen durch ein Drehmoment belastet werden. Ist diese Bedingung nicht erfüllt, so können die Extended Operation Modes nicht verwendet werden.
Regelstruktur
Die Antriebsregelstruktur ist eine Kaskadenregelstruktur mit einem Positionsregelkreis mit unterlagertem Drehzahl- und Stromregelkreis. Bei Vorgabe eines Drehzahlsollwertes kann der äußere Positionsregelkreis entfallen.
Kaskadenregelstruktur mit Feldorientierter Regelung (Extended Operating modes)
Motorabhängigkeit
Wegen der starken Abhängigkeit der Regelung von den Motorparametern, den Reglerparametern und dem Motorverhalten selbst, ist die Verwendung der Feldorientierten Regelung auf Beckhoff Motoren beschränkt. Die Betriebsart wird für Motoren anderer Hersteller nicht unterstützt.
Hauptvorteile gegenüber dem Standard Betrieb
▪
geringe Stromaufnahme (nahezu vollständige Lastabhängigkeit)
▪
hoher Wirkungsgrad
▪
gleich bleibende Dynamik im Verhältnis zum Standard Betrieb
▪
Schrittverluste sind prinzipbedingt ausgeschlossen
Voraussetzung
▪
Encoder mit ausreichend hoher Auflösung erforderlich (min. 4000 [INC/360°])
▪
Leicht erhöhter Parametrierungsaufwand erforderlich (Drehzahlregler)
▪
Kommutierungsfindung bei Systemstart (durch Inkrementalencoder bedingt)
▪
Nur mit Schrittmotoren der Firma Beckhoff Automation möglich (AS10xx)


Sensorloser Betrieb

Produktübersicht [image] Technologie [image] Sensorloser Betrieb
Sensorloser Betrieb
Da der Standard Betrieb eines Schrittmotors mit einem konstanten, lastunabhängigen Strom nicht energieeffizient ist und zu einer dauerhaft hohen, thermischen Belastung führt, wird nach Wegen gesucht diese Belastung zu reduzieren.
Funktion
Durch die Auswertung der drehzahlproportionalen, induzierten Gegenspannung ist es möglich den Statorstrom mit Hilfe eines Maschinenmodells lastabhängig (ohne Sensor / Encoder) zu regeln und damit den Wirkungsgrad signifikant zu erhöhen.
Da für die Betriebsart eine Minimalamplitude des Betrages der induzierten Gegenspannung erforderlich ist, funktioniert die sensorlose Regelung nur im mittleren und oberen Drehzahlbereich. Im unteren Drehzahlbereich wird der Motor im Standard Betrieb betrieben. Die Umschaltung zum sensorlosen Betrieb erfolgt über parametrierbare, motorabhängige Umschaltdrehzahl. Die Umschaltdrehzahl liegt meist im Bereich von einer halben bis drei Umdrehungen pro Sekunde (Crossover velocity 1).
Beim Einschalten der Sensorlosen Regelung entsteht durch den Einschwingvorgang der Regelung ein leichter mechanischer Ruck der Welle, der sich proportional zu der an der Welle wirksamen Last verhält.
Einfluss der Geschwindigkeitsschwellwerte Crossover Velocity (1,2,3) auf die Sensorlose Regelung
Nach dem Einschalten bleibt der Steuerstrom bis zu einer zweiten parametrierbaren Drehzahl konstant und wird bis zu einer dritten parametrierbaren Drehzahl über eine lineare Rampe reduziert.
Eine lange Steuerstromrampe führt zu einer stärkeren Stabilisierung des Einschwingvorgangs der Regelung. Sie führt aber auch zu einem länger fließenden konstanten Motorstrom und dadurch bedingt zu etwas höheren Verlusten.
Motorabhängigkeit
Wegen der starken Abhängigkeit der Regelung von den Motorparametern, den Reglerparametern und dem Motorverhalten selbst, ist die Verwendung des Sensorlosen Betriebs auf Beckhoff Motoren beschränkt. Die Betriebsart wird für Motoren anderer Hersteller nicht unterstützt.
Parametrierung
Im Vergleich zu den anderen Betriebsarten ist ein relativ hoher Parametrierungsaufwand erforderlich. Alle notwendigen Parameter sind jedoch für die endsprechenden Motortypen über eine Startup-Liste vorparametriert. Bei der Inbetriebnahme ist lediglich eine Anpassung der Drehzahlreglerparameter erforderlich, die durch die gegebenen Massenträgheitsverhältnisse der angeschlossenen Lasten im mechanischen System bedingt ist.
Für den Drehzahlregler gilt prinzipiell die gleiche Abhängigkeit von Massenträgheitsmoment und Drehmomentkonstante wie in den Extended Operation Modes. Durch die unterlagerte Sensorlose Regelung ist es jedoch möglich, dass durch eine abweichende Parametrierung ein besseres Gesamtergebnis erreicht werden kann.
Alle Parameter, die für den Sensorlosen Betrieb erforderlich sind, können zusammengefasst der Tabelle „Übersicht der Parametereinstellungen einzelner Betriebsarten“ entnommen werden.
Zusammenfassung
In dieser Betriebsart wird der Motorstrom ohne Encoder oberhalb einer Mindestdrehzahl lastabhängig geregelt. Damit lässt sich ein besonders kostengünstiger Antrieb in Verbindung mit einem hohen Wirkungsgrad realisieren. Die erreichbare Dynamik der Antriebsregelung ist im Vergleich zu den anderen Betriebsarten leicht reduziert.
Vorteile gegenüber dem Standard Betrieb
▪
geringe Stromaufnahme (nahezu vollständige Lastabhängigkeit)
▪
hoher Wirkungsgrad
▪
kein Encoder erforderlich
Voraussetzungen
▪
relativ hoher Parametrierungsaufwand erforderlich (Drehzahlregler + Zusatzparameter)
▪
Minimaldrehzahl erforderlich (Bei zu geringer Drehzal wird automatisch in Standard betrieb gewechselt)
▪
Dynamik etwas niedriger als im Standard Betrieb
▪
Nur mit Schrittmotoren der Firma Beckhoff Automation möglich (AS10xx)


Start up

Produktübersicht [image] Start up
Start up
Zur Inbetriebsetzung:
▪
montieren Sie den EL70x7 wie im Kapitel Installation beschrieben.
▪
konfigurieren Sie den EL70x7 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Installation

Installation
Installation
Weiterführende Informationen
•
Tragschienenmontage
•
Anschlusstechnik
•
Einbaulagen bei Betrieb mit und ohne Lüfter
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Positionierung von passiven Klemmen
•
Schirmkonzept
•
UL Hinweise - Compact Motion
•
EL7037
•
EL7047


Tragschienenmontage

Installation [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschlusstechnik

Installation [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen bei Betrieb mit und ohne Lüfter

Installation [image] Einbaulagen bei Betrieb mit und ohne Lüfter
Einbaulagen bei Betrieb mit und ohne Lüfter
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage bei Betrieb ohne Lüfter
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht.
Empfohlene Abstände Einbaulage bei Betrieb ohne Lüfter
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!
Weitere Hinweise zum Betrieb ohne Lüfter sind ggf. den Technischen Daten der Klemme zu entnehmen.
Standard-Einbaulage bei Betrieb mit Lüfter
Für die Standard-Einbaulage beim Betrieb mit Lüfter wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Betrieb mit Lüfter“). Die Klemmen werden dabei unterstützend vom z. B. ZB8610 Lüftermodul von unten nach oben durchlüftet.
Empfohlene Abstände bei Betrieb mit Lüfter
Weitere Einbaulagen
Durch die verstärkende Wirkung auf die Kühlung der Klemmen durch den Lüfter sind ggf. weitere Einbaulagen zulässig (siehe Abb. „Weitere Einbaulagen, Beispiel 1 und 2“); entnehmen Sie entsprechende Hinweise bitte den Technischen Daten der Klemme.

Weitere Einbaulagen, Beispiel 1
Weitere Einbaulagen, Beispiel 2


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Installation [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Positionierung von passiven Klemmen

Installation [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


Schirmkonzept

Installation [image] Schirmkonzept
Schirmkonzept
Die vorkonfektionierten Leitungen von Beckhoff Automation bieten zusammen mit der Schirmschiene einen optimalen Schutz gegen elektro-magnetische Störungen.
Es wird empfohlen, den Schirm möglichst nah an der Klemme aufzulegen, um Störungen auf ein Minimum zu reduzieren.
Anschluss der Motorleitung an die Schirmschiene
Befestigen Sie die Schirmschienenträger 1 auf der Hutschiene 2. Die Tragschiene 2 muss großflächig mit der metallischen Rückwand des Schaltschranks verbunden sein. Montieren Sie die Schirmschiene 3 wie in Abb. „Schirmschiene“ abgebildet.
Alternativ kann ein Schirmschienen-Bügel 3a direkt mit der metallischen Rückwand des Schaltschranks verschraubt werden (Abb. „Schirmschienen-Bügel“)
Schirmschiene
Schirmschienen-Bügel
Verdrahten Sie die Adern 4 der Motorleitung 5 und befestigen Sie dann das kupferummantelte Ende 6 der Motorleitung 5 mit der Schirmschelle 7 an die Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Ziehen Sie die Schraube 8 bis zum Anschlag an.
Befestigen Sie die PE-Schelle 9 an die Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Klemmen Sie die PE-Ader 10 der Motorleitung 5 unter die PE-Schelle 9.
Schirmanbindung
Anschluss der Feedbackleitung an den Motor
Verdrillen der Feedbackleitungen
Die Feedbackleitungen sollten verdrillt werden, um Störeinflüsse zu minimieren.
Beim Anschrauben des Feedbacksteckers an den Motor wird der Schirmanschluss der Feedbackleitung über die metallische Steckerbefestigung hergestellt.
Auf der Klemmenseite kann der Schirm ebenfalls aufgelegt werden. Verdrahten Sie die Adern der Feedbackleitung und befestigen Sie das kupferummantelte Ende der Feedbackleitung mit der Schirmschelle 7 an der Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Motor- und Feedbackleitung können zusammen mit der Schraube 8 der Schirmschelle 7 aufgelegt werden.


UL Hinweise - Compact Motion

Installation [image] UL Hinweise - Compact Motion
UL Hinweise - Compact Motion
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
culus-logo
Notes on motion devices
•
Motor overtemperature
Motor overtemperature sensing is not provided by the drive.
•
Application for compact motion devices
The modules are intended for use only within Beckhoff’s Programmable Controller system Listed in File E172151.
•
Galvanic isolation from the supply
The modules are intended for operation within circuits not connected directly to the supply mains (galvanically isolated from the supply, i.e. on transformer secondary).
•
Requirement for environmental conditions
For use in Pollution Degree 2 Environment only.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


EL7037

Installation [image] EL7037
EL7037
Weiterführende Informationen
•
LEDs und Anschlussbelegung
•
Allgemeine Anschlussbeispiele


LEDs und Anschlussbelegung

Installation [image] EL7037 [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
EL7037-0000
LEDs und Anschluss EL7037
LEDs
Nr.
LED
Farbe
Bedeutung
1
RUN
grün
Diese LED gibt den Betriebszustand der Klemme wieder:
aus
Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
blinkend
Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
Einzelblitz
Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks.
Ausgänge bleiben im sicheren Zustand
an
Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
2
Encoder
grün
an
Encoder betriebsbereit
3
A
grün
an
Am Encoder-Eingang A liegt ein Signal an.
4
B
grün
an
Am Encoder-Eingang B liegt ein Signal an.
5
C
grün
an
Am Encoder-Eingang C liegt ein Signal an.
6
Latch
grün
an
Am Latch-Eingang des Encoders liegt ein Signal an.
7
Turn CW
grün
an
Motor wird im Uhrzeigersinn (clock wise) angesteuert
8
Input 1
grün
an
Am digitalen Eingang 1 liegt ein Signal an.
9
Driver
grün
an
Treiberstufe betriebsbereit
10
Power
grün
aus
Versorgungsspannung (24 VDC) nicht vorhanden oder
Motoransteuerung ist gesperrt (Index 6010:02 ist nicht gesetzt)
an
Versorgungsspannung (24 VDC) vorhanden
11
Warning
gelb
an
Konfigurationsfehler, z.B.:
▪
Motorspannung nicht angelegt
▪
80°C Temperatur überschritten
▪
100% Duty cycle erreicht
▪
…
12
Error A
rot
an
Konfigurationsfehler der Endstufe A, z.B.:
▪
100°C Temperatur überschritten
▪
Kurzschluss
▪
...
13
Error B
rot
an
Konfigurationsfehler der Endstufe B, z.B.:
▪
100°C Temperatur überschritten
▪
Kurzschluss
▪
...
14
Enable
grün
aus
Motoransteuerung ist gesperrt (Index 6010:02 ist nicht gesetzt) oder EL7037 ist nicht betriebsbereit)
an
Motoransteuerung ist freigeschaltet (Index 6010:02 ist gesetzt) und EL7037 ist betriebsbereit
15
Turn CCW
grün
an
Motor wird gegen den Uhrzeigersinn (counter clock wise) angesteuert
16
Input 2
grün
an
Am digitalen Eingang 2 liegt ein Signal an.
Anschlussbelegung
Klemmstelle
Name
Signal
1
A
Encoder-Eingang A
2
C
Encoder-Eingang C (Nulleingang)
Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn das Bit im Objekt 7000:01 gesetzt ist und eine steigende Flanke am Encoder-Eingang C auftritt.
3
Encoder-Versorgung +24V
Encoder-Versorgung, intern verbunden mit positivem Powerkontakt und Pin 6, 7
4
A1
Motorwicklung A1
5
B1
Motorwicklung B1
6
+24V
+24 VDC, intern verbunden mit positivem Powerkontakt und Pin 3, 7
7
+24V
+24 VDC, intern verbunden mit positivem Powerkontakt und Pin 3, 6
8
Input 1
Digitaler Eingang 1 (24 VDC)
9
B
Encoder-Eingang B
10
Latch
Latch Eingang. Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn
▪
im Objekt 7000:02 das Bit gesetzt ist und eine steigende Flanke am Latch-Eingang auftritt oder
▪
im Objekt 7000:04 das Bit gesetzt ist und eine fallende Flanke am Latch-Eingang auftritt.
11
Encoder-Versorgung
0V
Encoder-Versorgung 0 V. intern verbunden mit negativem Powerkontakt und Pin 14, 15
12
A2
Motorwicklung A2
13
B2
Motorwicklung B2
14
0V
0 VDC, intern verbunden mit negativem Powerkontakt und Pin 11, 15
15
0V
0 VDC, intern verbunden mit negativem Powerkontakt und Pin 11, 14
16
Input 2
Digitaler Eingang 2 (24 VDC), auch als digitaler Ausgang (0,5 A) konfigurierbar


Allgemeine Anschlussbeispiele

Installation [image] EL7037 [image] Allgemeine Anschlussbeispiele
Allgemeine Anschlussbeispiele
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Hinweis
Motorstränge korrekt anschließen!
Schließen Sie die Wicklungen eines Motorsstranges nur an die Klemmpunkte des gleichen Ausgangstreibers der Schrittmotorklemme an, z.B.:
• den einen Motorstrang an die Klemmpunkte A1 und A2,
• den anderen Motorstrang an die Klemmpunkte B1 und B2.
Wenn Sie einen Motorsstrang an die Klemmpunkte verschiedener Ausgangstreiber (z.B. an A1 und B1) anschließen, kann dies die Ausgangstreiber der Schrittmotorklemme zerstören!
Anschlussarten
Die Schrittmotorklemme hat bipolare Endstufen und kann damit bipolare und unipolare Motoren ansteuern.
Bipolare Motoren
Bipolare Ansteuerung (seriell) eines bipolaren Motors
Bipolare Ansteuerung (parallel) eines bipolaren Motors
Dokumentation zu Schrittmotoren von Beckhoff
Diese beiden Beispiele zeigen den Anschluss der bipolaren Beckhoff-Motoren AS1010, AS1020, AS1030, AS1050 oder AS1060. Weitere Informationen zu Schrittmotoren von Beckhoff finden Sie in der zugehörigen Dokumentation, die auf unserer Internetseite http://www.beckhoff.de unter Download zur Verfügung steht.
Bipolare Ansteuerung eines unipolaren Motors
Eine Hälfte jeder Wicklung wird angesteuert


EL7047

Installation [image] EL7047
EL7047
Weiterführende Informationen
•
LEDs und Anschlussbelegung
•
Allgemeine Anschlussbeispiele


LEDs und Anschlussbelegung

Installation [image] EL7047 [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
EL7047-0000
Anschluss EL7047
LEDs (linkes Prisma)
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
Encoder | grün | an | Encoder betriebsbereit
A | grün | an | Am Encoder-Eingang A liegt ein Signal an.
B | grün | an | Am Encoder-Eingang B liegt ein Signal an.
C | grün | an | Am Encoder-Eingang C liegt ein Signal an.
Latch | grün | an | Am Latch-Eingang des Encoders liegt ein Signal an.
Input 1 | grün | an | Am digitalen Eingang 1 liegt ein Signal an.
Input 2 | grün | an | Am digitalen Eingang 2 liegt ein Signal an.
LEDs (rechtes Prisma)
LED
Farbe
Bedeutung
Driver
grün
an
Treiberstufe betriebsbereit
Power
grün
aus
Versorgungsspannung (50VDC) nicht vorhanden oder
Motoransteuerung ist gesperrt (Index 6010:02 ist nicht gesetzt)
an
Versorgungsspannung (50VDC) vorhanden
Turn CW
grün
an
Motor wird im Uhrzeigersinn (clock wise) angesteuert
Turn CCW
grün
an
Motor wird gegen den Uhrzeigersinn (counter clock wise) angesteuert
Enable
grün
aus
Motoransteuerung ist gesperrt (Index 6010:02 ist nicht gesetzt) oder EL7047ist nicht betriebsbereit)
an
Motoransteuerung ist freigeschaltet (Index 6010:02 ist gesetzt) und EL7047 ist betriebsbereit
Warning
gelb
aus
keine Mängel
an
Konfigurationsfehler, z.B.:
▪
Motorspannung nicht angelegt
▪
80°C Temperatur überschritten
▪
100% Duty cycle erreicht
▪
...
Error A
rot
an
Konfigurationsfehler der Endstufe A, z.B.:
▪
100°C Temperatur überschritten
▪
Kurzschluss
▪
...
Error B
rot
an
Konfigurationsfehler der Endstufe B, z.B.:
▪
100°C Temperatur überschritten
▪
Kurzschluss
▪
...
Anschlussbelegung (linker Gehäuseteil)
Klemmstelle
Name
Signal
1
A
Encoder-Eingang A
2
C
Encoder-Eingang C (Nulleingang)
Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn das Bit im Objekt 7000:01 gesetzt ist und eine steigende Flanke am Encoder-Eingang C auftritt.
3
Encoder-Versorgung +24V
Encoder-Versorgung (vom positivem Powerkontakt)
4
Input 1
Digitaler Eingang 1 (24 VDC)
5
B
Encoder-Eingang B
6
Latch / Gate
Latch Eingang. Der aktuelle Counter-Wert wird als Referenzmarke im Latch-Register gespeichert, wenn
▪
im Objekt 7000:02 das Bit gesetzt ist und eine steigende Flanke am Latch-Eingang auftritt oder
▪
im Objekt 7000:04 das Bit gesetzt ist und eine fallende Flanke am Latch-Eingang auftritt.
7
Encoder-Versorgung
0V
Encoder-Versorgung (vom negativem Powerkontakt)
8
Input 2
Digitaler Eingang 2 (24 VDC), auch als digitaler Ausgang (0,5 A) konfigurierbar
Anschlussbelegung (rechter Gehäuseteil)
Klemmstelle | Name | Signal
1' | A1 | Motorwicklung A
2' | B1 | Motorwicklung B
3' | Motorversorgung +50V | Einspeisung für Endstufen (maximal +50 VDC)
4' | Motorversorgung +50V | Einspeisung für Endstufen (maximal +50 VDC)
5' | A2 | Motorwicklung A
6' | B2 | Motorwicklung B
7' | Motorversorgung 0V | Einspeisung für Endstufen (0 VDC)
8' | Motorversorgung 0V | Einspeisung für Endstufen (0 VDC)


Allgemeine Anschlussbeispiele

Installation [image] EL7047 [image] Allgemeine Anschlussbeispiele
Allgemeine Anschlussbeispiele
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Hinweis
Motorstränge korrekt anschließen!
Schließen Sie die Wicklungen eines Motorsstranges nur an die Klemmpunkte des gleichen Ausgangstreibers der Schrittmotorklemme an, z.B.:
• den einen Motorstrang an die Klemmpunkte A1 und A2,
• den anderen Motorstrang an die Klemmpunkte B1 und B2.
Wenn Sie einen Motorsstrang an die Klemmpunkte verschiedener Ausgangstreiber (z.B. an A1 und B1) anschließen, kann dies die Ausgangstreiber der Schrittmotorklemme zerstören!
Hinweis
Brems-Chopper-Klemme (EL9576) bei kurzen Bremsrampen verwenden!
Bei sehr kurzen Bremsrampen kann es zu einer kurzzeitigen erhöhten Rückspeisung kommen. In diesem Fall meldet die Klemme einen Fehler. Um dies zu verhindern sollte eine Brems-Chopper-Klemme (EL9576) mit entsprechend ausgelegtem Ballastwiderstand (z.B. 10 Ohm) parallel zur Spannungsversorgung des Motors geschaltet werden. Diese kann dann die zurück gespeiste Energie aufnehmen.
Anschlussarten
Die Schrittmotorklemme EL7047 hat bipolare Endstufen und kann damit bipolare und unipolare Motoren ansteuern.
Bipolare Motoren
Bipolare Ansteuerung (seriell) eines bipolaren Motors
Bipolare Ansteuerung (parallel) eines bipolaren Motors
Dokumentation zu Schrittmotoren von Beckhoff
Diese beiden Beispiele zeigen den Anschluss der bipolaren Beckhoff-Motoren AS1010, AS1020, AS1030, AS1050 oder AS1060. Weitere Informationen zu Schrittmotoren von Beckhoff finden Sie in der zugehörigen Dokumentation, die auf unserer Internetseite www.beckhoff.de unter Download zur Verfügung steht.
Unipolare Motoren
Bipolare Ansteuerung eines unipolaren Motors
Eine Hälfte jeder Wicklung wird angesteuert
Encoder
Anschluss eines Encoders (24 V)
Der Encoder wird über die Klemmstellen 3 (+24 V) und 7 (0 V) aus den Powerkontakten versorgt


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Start up und Parameter-Konfiguration
•
Betriebsarten


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Download-Revision
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Download-Revision

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Download-Revision
Download-Revision
Download-Revision in der Start-up Liste
Einzelne Klemmen / Module generieren automatisch den Eintrag aus Objekt 0xF081:01 in die Startup-Liste (vgl. Abb. „Download-Revision in der Startup Liste“).
Das Objekt 0xF081:01 (Download revision) beschreibt die Revision der Klemme / des Moduls, z. B. 0x0018000A für EL7201-0010-0024, und ist für die Erfüllung der Kompatibilität notwendig.
Es ist unbedingt darauf zu achten, dass dieser Eintrag nicht aus der Startup Liste gelöscht wird!
Download-Revision in der Startup Liste


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Start up und Parameter-Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration
Start up und Parameter-Konfiguration
Weiterführende Informationen
•
Prozessdaten
•
Einbindung in die NC-Konfiguration
•
Konfiguration der wichtigsten Parameter - Einstellungen im CoE-Register
•
Konfiguration der wichtigsten Parameter - Auswahl der Bezugsgeschwindigkeit
•
Anwendungsbeispiel


Prozessdaten

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Prozessdaten
Prozessdaten
Sync Manager (SM)
Sync Manager (SM) Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (siehe Abb. "Karteireiter Prozessdaten SM2, EL70xx (default), Karteireiter Prozessdaten SM3, EL70xx (default)").
Karteireiter Prozessdaten SM2, EL70xx (default)
Karteireiter Prozessdaten SM3, EL70xx (default)
PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (siehe Abb.) den gewünschten Sync Manager (editierbar sind hier SM 2 + 3). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden. Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | 0x1601 | 4.0 | ENC Control compact | Index 0x7000:01 - Enable Latch C Index 0x7000:02 - Enable Latch extern on positive edge Index 0x7000:03 - Set counter Index 0x7000:04 - Enable Latch extern on negative edge Index 0x7000:11 - Set counter value (16-bit)
0x1601 | 0x1600 | 6.0 | ENC Control | Index 0x7000:01 - Enable Latch C Index 0x7000:02 - Enable Latch extern on positive edge Index 0x7000:03 - Set counter Index 0x7000:04 - Enable Latch extern on negative edge Index 0x7000:11 - Set counter value (32-bit)
0x1602 (default) | - | 2.0 | STM Control | Index 0x7010:01 - Enable Index 0x7010:02 - Reset Index 0x7010:03 - Reduce torque Index 0x7010:0C - Digital Output 1
0x1603 | 0x1604 0x1605 0x1606 | 4.0 | STM Position | Index 0x7010:11 - Position
0x1604 (default) | 0x1603 0x1605 0x1606 | 2.0 | STM Velocity | Index 0x7010:21 - Velocity
0x1605 | 0x1603 0x1604 0x1606 | 6.0 | POS Control compact | Index 0x7020:01 - Execute Index 0x7020:02 - Emergency stop Index 0x7020:11 - Target position
0x1606 | 0x1603 0x1604 0x1605 | 14.0 | POS Control | Index 0x7020:01 - Execute Index 0x7020:02 - Emergency stop Index 0x7020:11 - Target position Index 0x7020:21 - Velocity Index 0x7020:22 - Start type Index 0x7020:23 - Acceleration Index 0x7020:24 - Deceleration
0x1607 | 0x1603 0x1604 0x1605 | 14.0 | POS Control 2 | Index 0x7021:03 – Enable auto start Index 0x7021:03 – Target position Index 0x7021:21 – Velocity Index 0x7021:22 – Start type Index 0x7021:23 – Acceleration Index 0x7021:24 – Deceleration
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 0x1A01 | 6.0 | ENC Status compact | Index 0x6000:01 - Latch C valid Index 0x6000:02 - Latch extern valid Index 0x6000:03 - Set counter done Index 0x6000:04 - Counter underflow Index 0x6000:05 - Counter overflow Index 0x6000:08 - Extrapolation stall Index 0x6000:09 - Status of input A Index 0x6000:0A - Status of input B Index 0x6000:0B - Status of input C Index 0x6000:0D - Status of extern latch Index 0x6000:0E - Sync error Index 0x6000:10 - TxPDO Toggle Index 0x6000:11 - Counter value (16-Bit) Index 0x6000:12 - Latch value (16-Bit)
0x1A01 | 0x1A00 | 10.0 | ENC Status | Index 0x6000:01 - Latch C valid Index 0x6000:02 - Latch extern valid Index 0x6000:03 - Set counter done Index 0x6000:04 - Counter underflow Index 0x6000:05 - Counter overflow Index 0x6000:08 - Extrapolation stall Index 0x6000:09 - Status of input A Index 0x6000:0A - Status of input B Index 0x6000:0B - Status of input C Index 0x6000:0D - Status of extern latch Index 0x6000:0E - Sync error Index 0x6000:10 - TxPDO Toggle Index 0x6000:11 - Counter value (32-Bit) Index 0x6000:12 - Latch value (32-Bit)
0x1A02 | - | 4.0 | ENC Timest. compact | Index 0x6000:16 - Timestamp
0x1A03 (default) | - | 2.0 | STM Status | Index 0x6010:01 - Ready to enable Index 0x6010:02 - Ready Index 0x6010:03 - Warning Index 0x6010:04 - Error Index 0x6010:05 - Moving positive Index 0x6010:06 - Moving negative Index 0x6010:07 - Torque reduced Index 0x6010:08 - Motor stall Index 0x6010:0C - Digital input 1 Index 0x6010:0D - Digital input 2 Index 0x6000:0E - Sync error Index 0x6000:10 - TxPDO Toggle
0x1A04 | - | 4.0 | STM Synchron info data | Index 0x6010:11 - Info data 1 Index 0x6010:12 - Info data 2
0x1A05 | - | 2.0 | STM Motor load | Index 0x6010:13 - Motor load
0x1A06 | 0x1A07 | 2.0 | POS Status compact | Index 0x6020:01 - Busy Index 0x6020:02 - in-Target Index 0x6020:03 - Warning Index 0x6020:04 - Error Index 0x6020:05 - Calibrated Index 0x6020:06 - Accelerate Index 0x6020:07 - Decelerate
0x1A07 | 0x1A06 | 12.0 | POS Status | Index 0x6020:01 - Busy Index 0x6020:02 - in-Target Index 0x6020:03 - Warning Index 0x6020:04 - Error Index 0x6020:05 - Calibrated Index 0x6020:06 - Accelerate Index 0x6020:07 - Decelerate Index 0x6020:11 - Actual position Index 0x6020:21 - Actual velocity Index 0x6020:22 - Actual drive time
0x1A08 | - | 4.0 | STM Internal position | Index 0x6010:14 - Internal position
0x1A09 | - | 4.0 | STM External position | Index 0x6010:15 – External position
0x1A0A | - | 4.0 | POS Actual position lag | Index 0x6020:23 – Actual position lag
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Folgende PDO-Zuordnungen stehen zur Auswahl:
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Velocity control compact | 0x1600 0x1602 0x1604 | 0x1A00 0x1A03
Velocity control compact with info data | 0x1600 0x1602 0x1604 | 0x1A00 0x1A03 0x1A04
Velocity control | 0x1601 0x1602 0x1604 | 0x1A01 0x1A03
Position control | 0x1601 0x1602 0x1603 | 0x1A01 0x1A03
Positioning interface compact | 0x1601 0x1602 0x1605 | 0x1A01 0x1A03 0x1A06
Positioning interface | 0x1601 0x1602 0x1606 | 0x1A01 0x1A03 0x1A07
Positioning interface with info data | 0x1601 0x1602 0x1606 | 0x1A01 0x1A03 0x1A04 0x1A07
Positioning interface (Auto start) | 0x1601 0x1602 0x1606 0x1607 | 0x1A01 0x1A03 0x1A06
Positioning interface (Auto start) with info data | 0x1601 0x1602 0x1606 0x1607 | 0x1A01 0x1A03 0x1A04 0x1A06
Karteireiter Prozessdaten Predefined PDO Assignment, EL70x7


Einbindung in die NC-Konfiguration

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Einbindung in die NC-Konfiguration
Einbindung in die NC-Konfiguration
(Master: TwinCAT 2.11 R3)
Installation der neuesten XML-Device-Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Die Einbindung an die NC kann wie folgt durchgeführt werden:
▪
Die Klemme muss bereits unter E/A-Geräte manuell eingefügt oder vom System eingescannt worden sein (siehe Kapitel "Konfigurationserstellung in TwinCAT").
Achse automatisch hinzufügen
▪
Nach dem erfolgreichen Einscannen der Klemmen erkennt TwinCAT automatisch die neuen Achsen. Es wird die Frage gestellt, ob die erkannten Achsen automatisch
hinzugefügt werden sollen (siehe Abb. "Achse erkannt"). Wenn dieses bestätigt wird, werden alle Achsen automatisch mit der NC verknüpft.
Achse erkannt
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie dem Kapitel "Konfiguration der wichtigsten Parameter".
Stellen Sie bitte diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.
Achse manuell hinzufügen
▪
Fügen Sie zuerst einen neuen Task an. Dazu klicken Sie mit der rechten Maustaste auf NC-Konfiguration und wählen Sie "Task Anfügen..." aus (siehe Abb. "Neuen Task einfügen").
▪
Benennen Sie gegebenenfalls den Task um und bestätigen Sie mit OK.
Neuen Task einfügen
▪
Wählen Sie mit der rechten Maustaste Achsen aus und fügen anschließend eine neue Achse an (siehe Abb. "Auswahl einer neuen Achse").
Auswahl einer neuen Achse
▪
Wählen Sie unter Typ eine Kontinuierliche Achse aus und bestätigen Sie mit OK (siehe Abb. "Achsentyp auswählen und bestätigen").
Achsentyp auswählen und bestätigen
▪
Markieren Sie Ihre Achse mit der linken Maustaste. Unter der Registerkarte Einstellungen wählen Sie "Verknüpft mit..." aus (siehe Abb. "Verknüpfung der Achse mit der Klemme").
Verknüpfung der Achse mit der Klemme
▪
Wählen Sie die passende Klemme aus (CANopen DS402, EtherCAT CoE) und bestätigen Sie mit "OK ".
Auswahl der richtigen Klemme
▪
Alle wichtigen Verknüpfungen zwischen der NC-Konfiguration und der Klemme werden dadurch automatisch durchgeführt (siehe Abb. "Automatische Verknüpfung aller wichtigen Variablen")
Automatische Verknüpfung aller wichtigen Variablen
▪
Damit der Motor in Betrieb genommen werden kann, müssen noch einige Parameter eingestellt werden. Die Werte entnehmen Sie den Kapiteln "Einstellungen im CoE" und "Einstellungen in der NC".
Stellen Sie bitte diese Parameter ein, bevor Sie mit der Inbetriebnahme des Motors fortfahren.


Konfiguration der wichtigsten Parameter - Einstellungen im CoE-Register

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Konfiguration der wichtigsten Parameter - Einstellungen im CoE-Register
Konfiguration der wichtigsten Parameter - Einstellungen im CoE-Register
Die hier angegebenen Daten sind beispielhaft für einen Stepper Motor AS 1050-0120 aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Anpassung von Strom und Spannung
Hinweis
Überhitzung des Motors möglich!
Um den angeschlossenen Motor nicht zu überhitzen, ist es wichtig den Strom und die Spannung, die vom Stepperinterface ausgegeben wird, dem Motor anzupassen.
Dazu müssen im CoE-Register der Index 8010:01 "Maximal current" und der Index 8010:03 "Nominal voltage" passend eingestellt werden (siehe Abb. "Anpassung von Strom und Spannung").
Im Index 8010:02 kann der Reduced current eingestellt werden. Dadurch wird der Spulenstrom im Stillstand (und damit auch die Verlustleistung) reduziert. Es ist zu beachten, dass sich damit auch das Drehmoment reduziert.
Anpassung von Strom und Spannung
Auswahl der Grundfrequenz
Das Microstepping ist fest auf 1/64 eingestellt und kann nicht verändert werden. Es kann jedoch die Grundfrequenz verändert werden (default: 2000). Dazu markieren Sie die Klemme und wählen die Registerkarte CoE-Online aus. Mit einem Doppelklick auf den Index 8012:05 "Speed range" können Sie die Grundfrequenz verändern (Abb. "Grundfrequenz einstellen").
Anpassung der Bezugsgeschwindigkeit
Die Grundfrequenz hängt unmittelbar mit der Bezugsgeschwindigkeit der TwinCAT NC zusammen, so dass die Bezugsgeschwindigkeit immer an eine Veränderung der Grundfrequenz angepasst werden muss.
Grundfrequenz einstellen
Auswahl des Feedbacksystems (Nur beim Modul mit Encoderanschlüssen)
Beim Feedbacksystem stehen 2 Möglichkeiten zur Auswahl:
▪
Encoder: Externen Encoder zur Positionsrückführung nutzen
▪
Internal Counter (default): Internen Zähler zur Positionsrückführung nutzen
CoE "Feedback type"
In der Grundeinstellung ist das Steppermodul auf den internen Zähler gesetzt. Wenn ein externer Encoder eingesetzt wird, muss die Einstellung mit einem Doppelklick auf den Index 8012:08 "Feedback type" im Enum-Menü geändert werden (Abb."Feedbacksystem auswählen").
Anpassung des Skalierungsfaktors
Das Feedbacksystem hängt unmittelbar mit dem Skalierungsfaktor der TwinCAT NC zusammen, so dass der Skalierungsfaktor immer an eine Veränderung des Feedbacksystems angepasst werden muss.
Feedbacksystem auswählen


Konfiguration der wichtigsten Parameter - Auswahl der Bezugsgeschwindigkeit

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Konfiguration der wichtigsten Parameter - Auswahl der Bezugsgeschwindigkeit
Konfiguration der wichtigsten Parameter - Auswahl der Bezugsgeschwindigkeit
Die hier angegebenen Daten sind beispielhaft für einen Stepper Motor AS 1050-0120 aufgeführt. Bei anderen Motoren und je nach Applikation können die Werte variieren.
Die Maximalgeschwindigkeit errechnet sich anhand der Grundfrequenz und der Motorfrequenz.
v max = Grundfrequenz / Motorfrequenz = (2000 Fullsteps / s) / (200 Fullsteps / Umdrehung) = 10 Umdrehungen / s
Multipliziert man die Maximalgeschwindigkeit mit dem Weg pro Umdrehung, erhält man die Bezugsgeschwindigkeit.
v ref = 10 Umdrehungen / s x 360° = 3600 °/ s
Anpassung der Bezugsgeschwindigkeit
Die Grundfrequenz hängt unmittelbar mit der Bezugsgeschwindigkeit der TwinCAT NC zusammen, so dass die Bezugsgeschwindigkeit immer an eine Veränderung der Grundfrequenz angepasst werden muss.
Ex70x1_KONFIG_ref_velo
Parameter Bezugsgeschwindigkeit
Totzeitkompensation
Die Totzeitkompensation der Achse kann in der Registerkarte Time Compensation der Encodereinstellungen Achse1_ENC eingestellt werden. Sie sollte theoretisch 3 Zyklen der NC-Zykluszeit betragen, besser haben sich jedoch 4 Zyklen der NC-Zykluszeit erwiesen. Dazu sollten die Parameter Time Compensation Mode Encoder auf ‚ON (with velocity)‘ und Encoder Delay in Cycles auf 4 eingestellt sein.
Parameter Totzeitkompensation
Skalierungsfaktor
Den Skalierungsfaktor können Sie ändern, wenn Sie in der NC "Achse 1_Enc" und die Registerkarte "Parameter" auswählen (siehe Abb. "Skalierungsfaktor einstellen"). Der Wert lässt sich mit den unten angegebenen Formeln berechnen.
Skalierungsfaktor einstellen
Anpassung des Skalierungsfaktors
Das Feedbacksystem hängt unmittelbar mit dem Skalierungsfaktor der TwinCAT NC zusammen, so dass der Skalierungsfaktor immer an eine Veränderung des Feedbacksystems angepasst werden muss.
Berechnung des Skalierungsfaktors
mit Encoder, 4-fach Auswertung:
SF = Weg pro Umdrehung / (Inkremente x 4) = 360° / (1024 x 4) = 0,087890625 ° / INC
ohne Encoder:
SF = Weg pro Umdrehung / (Fullsteps x Microsteps) = 360° / (200 x 64) = 0,028125 ° / INC
Schleppüberwachung Position
Die Schleppabstandsüberwachung überwacht, ob der aktuelle Schleppabstand einer Achse einen Grenzwert überschreitet. Als Schleppabstand wird die Differenz zwischen ausgegebenem Sollwert (Stellgröße) und zurückgemeldetem Istwert bezeichnet. Sind die Parameter der Klemme noch unzureichend eingestellt, kann es dazu führen, dass beim Verfahren der Achse die Schleppabstandsüberwachung einen Fehler ausgibt. Bei der Inbetriebnahme kann es deswegen eventuell von Vorteil sein, wenn man die Grenzen der Schleppüberwachung Position etwas erhöht.
Hinweis
ACHTUNG: Beschädigung von Geräten, Maschinen und Peripherieteilen möglich!
Bei der Parametrierung der Schleppüberwachung können durch Einstellen zu hoher Grenzwerte Geräte, Maschinen und Peripherieteile beschädigt werden!
Schleppüberwachung einstellen
Kv - Faktoren
In der NC lassen sich unter "Achse 1_Ctrl "in der Registerkarte "Parameter" zwei Proportionalfaktoren Kv einstellen. Wählen Sie jedoch vorher unter der Registerkarte "NC-Controller" den Typ Positionsregler mit zwei P-Konstanten (mit Ka) aus. Die beiden P-Konstanten sind einmal für den Bereich Stillstand und ein weiteres Mal für den Bereich Fahren (siehe Abb. "Proportionalfaktor Kv einstellen"). Damit hat man die Möglichkeit, im Anfahrmoment und im Bremsmoment ein anderes Drehmoment einzustellen als beim Fahren. Der Schwellwert lässt sich direkt darunter (Pos-Regelung: Geschw.schwelle V dyn) zwischen 0.0 (0%) und 1.0 (100%) einstellen. In der Abb."Geschwindigkeitsrampe mit Grenzwerten des K-Faktors" ist eine Geschwindigkeitsrampe mit Schwellwerten von 30% dargestellt. Im Bereich Stillstand (t1 und t3) kann dann ein unterschiedlicher Kv-Faktor eingestellt werden als im Bereich Fahren (t2). In diesem Fall ist jeweils der gleiche Faktor verwendet worden, da bei Steppermotoren diese Funktion nicht so ausschlaggebend ist, wie bei DC-Motoren.
Geschwindigkeitsrampe mit Grenzwerten des K-Faktors
Proportionalfaktor Kv einstellen
Totzone für Positionsfehler
Mit Hilfe des Microstepping können 200 * 64 = 12800 Positionen angefahren werden. Da der Encoder nur 1024 * 4 = 4096 Positionen abfragen kann ,wird unter Umständen eine Position, die sich zwischen 2 Abtastpunkten das Encoders befindet nicht richtig erfasst und die Klemme regelt um diese Position herum. Mit Hilfe der Totzone für Positionsfehler kann eine Toleranz angegeben werden, innerhalb der die Position als "erreicht" gesehen wird (Abb. "Totzone für Positionsfehler").
Totzone für Positionsfehler
Einstellung der Hochlaufzeit
Um eventuell auftretende Resonanzen schnell zu durchfahren, sollten Hochlaufzeit und Bremszeit möglichst mit steilen Rampen gefahren werden.
Einstellen der Hochlaufzeit
Hinweis
ACHTUNG: Pufferkondensatorklemme (EL9570) bei kurzen Bremsrampen verwenden!
Bei sehr kurzen Bremsrampen kann es zu einer kurzzeitigen erhöhten Rückspeisung kommen. In diesem Fall meldet die Klemme einen Fehler. Um dies zu verhindern sollte eine Pufferkondensatorklemme (EL9570) mit entsprechend ausgelegtem Ballastwiderstand (z.B. 10 Ohm) parallel zur Spannungsversorgung (50 V) des Motors geschaltet werden. Diese kann dann die zurück gespeiste Energie aufnehmen.


Anwendungsbeispiel

Inbetriebnahme [image] Start up und Parameter-Konfiguration [image] Anwendungsbeispiel
Anwendungsbeispiel
Installation der neuesten XML-Device-Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Motoransteuerung mit Visualisierung
Programmbeispiel:
Verwendeter Master: TwinCAT 2.11 (bei älteren Versionen muss der Regelkreis manuell programmiert werden, der in diesem Fall bereits in der NC implementiert ist).
Mit diesem Anwendungsbeispiel lässt sich ein Motor mit Hilfe der Visualisierung in eine beliebige Position fahren oder im Endlosmodus betreiben. Dabei kann die Geschwindigkeit, die Anfahrbeschleunigung und die Bremsbeschleunigung festgelegt werden.
Das Beispielprogramm besteht aus 2 Dateien (PLC-Datei und System Manager Datei).
Öffnen Sie zunächst die PLC-Datei und kompilieren Sie die Datei, damit Sie für den Systemmanager die *.tpy Datei zur Verfügung haben.
Beachten Sie, dass Sie im PLC-Programm gegebenenfalls die Zielplattform anpassen müssen (default: PC oder CX 8x86). Sollten Sie das ändern müssen, können Sie unter der Registerkarte Ressourcen -> Steuerungskonfiguration die richtige Zielplattform auswählen.
Auswahl der Zielplattform
Bei der System Manager Datei muss folgendes beachtet werden:
▪
Starten Sie den System Manager im Konfig-Modus.
▪
Stellen Sie sicher, dass die E/A-Konfiguration mit Ihrer tatsächlichen Konfiguration übereinstimmt. Im Beispielprogramm ist nur eine Schrittmotorklemme integriert. Wenn Sie weitere Klemmen angeschlossen haben, müssen Sie diese zusätzlich einfügen oder Ihre Konfiguration neu einscannen.
▪
Sie müssen die MAC-Adresse anpassen. Klicken Sie dazu auf Ihr EtherCAT-Gerät, anschließend wählen Sie die Registerkarte Adapter und klicken hinter der MAC-Adresse auf Suchen (siehe Abb. "Auswahl der MAC-Adresse"). Dort wählen Sie den richtigen Adapter aus.
Auswahl der MAC-Adresse
▪
Bei der SPS-Konfiguration muss der Pfad des SPS-Programms angepasst werden. Klicken Sie dazu auf das angefügte SPS-Programm und wählen Sie die Registerkarte IEC1131 aus (siehe Abb. "Ändern des SPS-Pfades"). Dort müssen Sie Ändern anwählen und den richtigen Pfad bestimmen.
Ändern des SPS-Pfades
▪
Unter NC-Konfiguration ist bereits eine Schrittmotorklemme mit der NC verknüpft. Sollten Sie diese neu verknüpfen müssen oder zusätzliche hinzufügen wollen, dann gehen Sie bitte wie im Kapitel "Einbindung in die NC-Konfiguration" vor.
Das PLC-Programm setzt sich wie folgt zusammen. Die Bibliotheken TcMC.lib und TcNC.lib müssen eingebunden werden (siehe Abb. "Erforderliche Bibliotheken").
Erforderliche Bibliotheken
Anschließend werden einige globale Variablen deklariert (siehe Abb. "Globale Variablen"). Die Datentypen PLCTONC_AXLESTRUCT und NCTOPLC_AXLESTRUCT sorgen für die Kommunikation zwischen der PLC und der NC.
Globale Variablen
Nachdem die globalen Variablen deklariert worden sind, können Sie mit der Programmierung starten. Dazu deklarieren Sie vorerst die lokalen Variablen (siehe Abb. "Lokale Variablen").
MC_Direction ist ein Aufzählungstyp, der dem Baustein MC_MoveVelocity die Bewegungsrichtung vorgibt, der wiederum eine Endlosfahrt des Motors durchführt.
Mit dem Funktionsbaustein MC_Reset wird ein Reset der Achse durchgeführt. MC_MoveAbsolute ist ein Funktionsbaustein mit dem eine absolute Positionierung durchgeführt wird.
Mit dem Funktionsbaustein MC_ReadActualPosition kann die aktuelle Position der Achse gelesen werden. MC_Power gibt die Achse frei und MC_Stop wird für das Stoppen der Achse benötigt.
Lokale Variablen
Der Programmcode lautet wie folgt (siehe Abb. "Programmcode"):
Programmcode
Mit Hilfe der folgenden Visualisierung (siehe Abb. "Visualisierung") kann der Motor anschließend betrieben werden.
Bitte betätigen Sie den Taster Enable, um die Freigaben für die Achse zu setzen. Sie können jetzt im "Free run mode" den Taster Left oder Right betätigen und der Motor dreht sich mit einer im fbMoveVelocity_Axis_1 definierten Geschwindigkeit, in die ausgewählte Richtung, oder Sie können im "Absolute mode" Geschwindigkeit, Beschleunigung, Bremsbeschleunigung und die anzufahrende Position angeben und mit Start Job die Fahrt starten.
Wenn Sie bei der Beschleunigung und der Bremsbeschleunigung nichts angeben, wird der Default-Wert der NC benutzt.
Visualisierung
Informationen zu Funktionsbausteinen und Datentypen
Weitere Informationen zu den verwendeten Funktionsbausteinen und Datentypen erhalten Sie im aktuellen Beckhoff Information System.


Betriebsarten

Inbetriebnahme [image] Betriebsarten
Betriebsarten
Weiterführende Informationen
•
Übersicht
•
Velocity direct
•
Position controller
•
Extended Velocity mode
•
Extended Position mode
•
Velocity sensorless
•
Grundlagen zum "Positioning interface"


Übersicht

Inbetriebnahme [image] Betriebsarten [image] Übersicht
Übersicht
Es werden die Betriebsarten Velocity direct, Position controller, Ext. Velocity mode, Ext. Position mode und Velocity sensorless unterstützt. Die Betriebsart wird im CoE-Verzeichnis im Index 8012:01 (Operation Mode) eingestellt. In den jeweiligen Prozessdaten hat der Anwender zusätzlich die Möglichkeit das passende Predefined PDO Assigment auszuwählen. Damit sind alle nötigen Variablen in den Prozessdaten.
Mit dem Predefined PDO Assignments Positioning interface und Positioning interface compact lässt sich zusätzlich, auf Basis des Positioning controller, eine Fahrwegsteuerung realisieren.
Automatik
Die Betriebsart Automatik ist die Default-Einstellung der EL70x7. Ist diese Betriebsart ausgewählt, so erkennt die EL70x7 den eingestellten Predefined PDO Assignment und wählt automatisch zwischen Velocity direct und Position controller aus, so dass das Zusammenspiel zwischen Predefined PDO Assignment und der dazu passenden Betriebsart automatisch gewährleistet ist. Wechselt der Anwender beispielsweise vom Predefined PDO Assignment Velocity control auf Position control, so erkennt das die EL70x7 und wechselt automatisch von der Betriebsart Velocity direct auf Position controller.
Die Extended modes sind in der Betriebsart Automatik nicht implementiert.
Sollten die Extended modes nicht gebraucht werden, so wird empfohlen, die Betriebsart Automatik auszuwählen.
Velocity direct
In der Betriebsart Velocity direct arbeitet die EL70x7 im zyklischen Geschwindigkeitsinterface. Über die Variable STM Velocity kann eine definierte Geschwindigkeit eingestellt werden.
Position controller
In der Betriebsart Position controller arbeitet die EL70x7 im zyklischen Positionsinterface. Über die Variable STM Position kann eine definierte Position eingestellt werden.
Extended Velocity mode
In der Betriebsart Extended Velocity mode arbeitet die EL70x7 im zyklischen Geschwindigkeitsinterface mit einer Feldorientierten Regelung. Über die Variable STM Velocity kann eine definierte Geschwindigkeit eingestellt werden.
Extended Position mode
In der Betriebsart Extended Position mode arbeitet die EL70x7 im zyklischen Positionsinterface mit einer Feldorientierten Regelung. Über die Variable STM Position kann eine definierte Position eingestellt werden.
Velocity sensorless
In der Betriebsart Velocity sensorless arbeitet die EL70x7 im zyklischen Geschwindigkeitsinterface, in dem der Motorstrom ohne Encoder oberhalb einer Mindestdrehzahl lastabhängig geregelt wird. Über die Variable STM Velocity kann eine definierte Geschwindigkeit eingestellt werden.
Positioning interface
Üblicherweise wird der Positionsregelkreis mit Hilfe der TwinCAT NC geschlossen. Mit dem Positioning interface können Fahraufträge über die PLC direkt an die Klemme übertragen werden und der Positionsregelkreis wird von der Klemme geschlossen. Dies kann bei einfachen, preissensitiven Applikation vorteilhaft sein, da die Lizenz für die TwinCAT NC entfällt. Es ist nur eine sehr niedrige TC_Zykluszeit notwendig, so dass die Steuerung entlastet wird. Allerdings ist die Genauigkeit und die Synchronisationsmöglichkeit zu anderen Antriebsklemmen und -modulen im System stark eingeschränkt.
Hinweise zu den einzelnen Betriebsarten
Die folgende Matrix zeigt eine Übersicht der Einschränkungen einzelner Betriebsarten.
Es wird aufgezeigt, ob die Betriebsart mit Fremdmotoren oder nur mit Beckhoff Motoren unterstützt und ob ein Encoder notwendig ist oder nicht. Darüber hinaus wird aufgezeigt, welche Betriebsart, nach Freigabe der Achse, eine Kommutierungsfindung durchführt.
Dabei bewegt sich die Welle minimal in beide Richtungen. Bei der Applikation muss das berücksichtigt werden.
 | Automatik | Velocity direct | Position controller | Extended Velocity mode | Extended Position mode | Velocity sensorless
Beckhoff Motor (AS10xx) | x | x | x | x | x | x
Fremdmotor | x | x | x | - | - | -
Mit Encoder | x | x | x | x | x | -
Ohne Encoder | x | x | x | - | - | x
Kommutierungs- findung erforderlich | - | - | - | x | x | -
Übersicht der Einschränkungen einzelner Betriebsarten
Vorteile der einzelnen Betriebsarten
Die folgende Matrix zeigt die Vorteile der einzelnen Betriebsarten auf.
Der Drehzahlregler kann bei Velocity sensorless nicht übermäßig hart eingestellt werden. Das führt zu einer minimal eingeschränkten Fahrdynamik. Die Fahrdynamik der Betriebarten Velocity direkt und Position controller ist für einen Schrittmotor sehr gut. Die Extended modes erreichen auf Grund der Feldorienterten Regelung jedoch eine viel bessere Fahrdynamik, die schon fast einem Servomotor gleicht.
 | Automatik | Velocity direct | Position controller | Extended Velocity mode | Extended Position mode | Velocity sensorless
Regeldynamik | + | + | + | ++ | ++ | o
Schrittverlust- erkennung | x | x | x | Schrittverluste ausgeschlossen | Schrittverluste ausgeschlossen | -
Lastwinkel- erkennung | x | x | x | immer 90° | immer 90° | -
Positioning interface | abhängig von Betriebsartenauswahl | - | x | - | x | -
Lastab- hängiger Strom | - | - | - | x | x | ja, wenn velo > velomin
Energie Effizienz | o | o | o | ++ | ++ | o, +
Übersicht der Vorteile einzelner Betriebsarten
Notwendige Parametereinstellungen der einzelnen Betriebsarten
Die folgende Matrix gibt einer Übersicht über die Parameter, die für die einzelnen Betriebsarten zwingend erforderlich sind.
Für alle unterstützten Beckhoff Motoren werden online Motor XML files zur Verfügung gestellt. Die entsprechende Datei kann in die Start up Liste eingefügt werden. Mit dieser Datei sind die Parameter sehr gut voreingestellt. Ein geringes Finetuning kann applikationsbedingt jedoch vorteilhaft sein.
 | Velocity direct | Position controller | Extended velocity mode | Extended position mode | Velocity sensorless | Lastwinkelerkennung | Schrittverlusterkennung
 |  |  |  |  |  |  | mit Encoder | ohne Encoder
Index 8010:03 Nominal voltage | X | x | x | x | x | x | x | x
Index 8010:04 Motor coil resistance |  | x |  | x |  |  |  |
Index 8010:05 Motor EMF |  |  |  |  | x | x |  | x
Index 8010:0A Motor coil inductance |  |  |  |  | x | x |  | x
Index 8011:01 Kp factor (curr.) | x | x | x | x | x | x | x | x
Index 8011:02 KI factor (curr.) | x | x | x | x | x | x | x | x
Index 8014:01 Feed forward (pos.) |  | x |  | x |  |  |  |
Index 8014:02 Kp factor (pos.) |  | x |  | x |  |  |  |
Index 8014:03 Kp factor (velo.) |  |  | x | x | x |  |  |
Index 8014:04 Tn (velo.) |  |  | x | x | x |  |  |
Übersicht der Parametereinstellungen einzelner Betriebsarten


Velocity direct

Inbetriebnahme [image] Betriebsarten [image] Velocity direct
Velocity direct
In der Betriebsart Velocity direct arbeitet die EL70x7 im zyklischen Geschwindigkeitsinterface. Über die Variable STM Velocity kann eine definierte Geschwindigkeit eingestellt werden.
Voraussetzungen
▪
Dieser Betriebsmodus kann sowohl mit angeschlossenem Encoder, als auch mit dem internen Zähler (ohne Encoder) genutzt werden.
▪
Die Prozessdaten können entweder mit Hilfe der TwinCAT NC oder direkt aus der PLC übertragen werden.
Step by Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online Scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC (wenn TwinCAT NC genutzt wird).
▪
Konfigurieren Sie die EL70x7
–
automatisch - importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE - automatisch beschrieben, in das Start-up Verzeichnis.
–
manuell - konfigurieren Sie die Parameter, wie im Kapitel Einstellungen im CoE - manuell beschrieben.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Velocity direct, Abb. "Auswahl Velocity direct".
Auswahl Velocity direct
▪
Wählen Sie bei den Predefined PDO Assignments Velocity control, Velocity control compact oder Velocity control compact with info data, Abb. "Auswahl Predefined PDO Assignment: Velocity control compact".
Auswahl Predefined PDO Assignment: Velocity control compact
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu haben Sie zwei Möglichkeiten.
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können die Achse in der Registerkarte "Online" der Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. "Freigabe der Achse in der NC"). Anschließend ist die Achse bereit.
Freigabe der Achse in der NC
▪
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Setzen Sie dazu die Variable 0x7010:01 Enable auf 1 (true), Abb. "Freigabe der Achse manuell".
Freigabe der Achse manuell
▪
Über die zyklische Variable STM velocity (Abb. "Eingabe der Geschwindigkeit") können Sie eine definierte Geschwindigkeit vorgeben.
Die Geschwindigkeit wird in % der Speed range (Index 8012:05) angegeben. Der Wert +32767 entspricht 100% und der Wert -32767 entspricht -100%.
Eingabe der Geschwindigkeit


Position controller

Inbetriebnahme [image] Betriebsarten [image] Position controller
Position controller
In der Betriebsart Position controller arbeitet die EL70x7 im zyklischen Positionsinterface. Über die Variable STM Position kann eine definierte Position eingestellt werden.
Hinweise
▪
Dieser Betriebsmodus kann sowohl mit angeschlossenem Encoder, als auch mit dem internen Zähler (ohne Encoder) genutzt werden.
▪
Die Prozessdaten können entweder mit Hilfe der TwinCAT NC oder direkt aus der PLC übertragen werden (Positioning interface).
▪
Fremdmotoren werden unterstützt
Step by Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online Scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC (wenn TwinCAT NC genutzt wird).
▪
Konfigurieren Sie die EL70x7
–
automatisch - importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE - automatisch beschrieben, in das Start-up Verzeichnis.
–
manuell - konfigurieren Sie die Parameter, wie im Kapitel Einstellungen im CoE - manuell beschrieben.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Position controller, Abb. "Auswahl Position controller".
Auswahl Position controller
▪
Wählen Sie bei den Predefined PDO Assignments Position control, Positioning interface compact, Positioning interface oder Positioning interface with info data , Abb. "Auswahl Predefined PDO Assignment: Position control".
Auswahl Predefined PDO Assignment: Position control
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu haben Sie zwei Möglichkeiten.
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können die Achse in der Registerkarte "Online" der Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. "Freigabe der Achse in der NC"). Anschließend ist die Achse bereit.
Freigabe der Achse in der NC
▪
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Setzen Sie dazu die Variable 0x7010:01 Enable auf 1 (true), Abb. "Freigabe der Achse manuell".
Freigabe der Achse manuell
▪
Über die zyklische Variable STM Position (Abb. "Eingabe der Position") können Sie eine definierte Position vorgeben.
Die Position wird in Inkrementen angegeben und ist vom ausgewählten Feedback (Index 8012:0A) abhängig. Beim internen Zähler mit einem AS10xx Motor entspricht 12.800 (64fach Microstepping * 200 Vollschritte des AS10xx Motors) eine volle Umdrehung. Beim externen Encoder ist der Wert vom Encoder abhängig. Bei einem Encoder der AS10xx Motoren mit 1024 INC/Umdrehung entspricht 4096 (1024 INC/U * 4fach Auswertung) einer volle Umdrehung.
Eingabe der Position


Extended Velocity mode

Inbetriebnahme [image] Betriebsarten [image] Extended Velocity mode
Extended Velocity mode
In der Betriebsart Extended Velocity mode arbeitet die EL70x7 im zyklischen Geschwindigkeitsinterface mit einer Feldorientierten Regelung. Über die Variable STM Velocity kann eine definierte Geschwindigkeit eingestellt werden.
Hinweise
▪
Dieser Betriebsmodus kann nur mit einem angeschlossenen Encoder mit ausreichend hoher Auflösung (min. 4000 [INC/360°]) genutzt werden.
▪
Es werden nur Schrittmotoren der Firma Beckhoff Automation GmbH unterstützt (AS10xx).
▪
Die Verwendung der TwinCAT NC ist erforderlich.
▪
Bei der Freigabe ist eine Kommutierungsfindung erforderlich, bei der die Welle ein wenig Spiel braucht. Dazu bewegt sich die Welle wenige Grad recht- und linksrum.
Step by Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online Scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC (wenn TwinCAT NC genutzt wird).
▪
Konfigurieren Sie die EL70x7
–
automatisch - importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE - automatisch beschrieben, in das Start-up Verzeichnis.
–
manuell - konfigurieren Sie die Parameter, wie im Kapitel Einstellungen im CoE - manuell beschrieben.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Extended Velocity mode, siehe Abb. "Auswahl Extended Velocity mode".
Auswahl Extended Velocity mode
▪
Wählen Sie bei den Predefined PDO Assignments Velocity control oder Velocity control compact oder Velocity control with info data, Abb. "Auswahl Predefined PDO Assignment: Velocity control compact".
Auswahl Predefined PDO Assignment: Velocity control compact
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu haben Sie zwei Möglichkeiten.
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können die Achse in der Registerkarte "Online" der Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. "Freigabe der Achse in der NC"). Anschließend ist die Achse bereit.
Freigabe der Achse in der NC
▪
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Setzen Sie dazu die Variable 0x7010:01 Enable auf 1 (true), Abb. "Freigabe der Achse manuell".
Freigabe der Achse manuell
▪
Über die zyklische Variable STM velocity (Abb. "Eingabe der Geschwindigkeit") können Sie eine definierte Geschwindigkeit vorgeben.
Die Geschwindigkeit wird in % der Speed range (Index 8012:05) angegeben. Der Wert +32767 entspricht 100% und der Wert -32767 entspricht -100%.
Eingabe der Geschwindigkeit


Extended Position mode

Inbetriebnahme [image] Betriebsarten [image] Extended Position mode
Extended Position mode
In der Betriebsart Extended Position mode arbeitet die EL70x7 im zyklischen Positionsinterface mit einer Feldorientierten Regelung. Über die Variable STM Position kann eine definierte Position eingestellt werden.
Hinweise
▪
Dieser Betriebsmodus kann nur mit einem angeschlossenen Encoder mit ausreichend hoher Auflösung (min. 4000 [INC/360°]) genutzt werden.
▪
Es werden nur Schrittmotoren der Firma Beckhoff unterstützt (AS10xx).
▪
Die Verwendung der TwinCAT NC ist nicht erforderlich.
▪
Bei der Freigabe ist eine Kommutierungsfindung erforderlich, bei der die Welle ein wenig Spiel braucht. Dazu bewegt sich die Welle wenige Grad recht- und linksrum.
Step by Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online Scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC (wenn TwinCAT NC genutzt wird).
▪
Konfigurieren Sie die EL70x7
–
automatisch - importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE - automatisch beschrieben, in das Start-up Verzeichnis.
–
manuell - konfigurieren Sie die Parameter, wie im Kapitel Einstellungen im CoE - manuell beschrieben.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Ext. Position mode, Abb. "Auswahl Ext. Position mode".
Auswahl Ext. Position mode
▪
Wählen Sie bei den Predefined PDO Assignments Position control, Positioning interface compact, Positioning interface oder Positioning interface with info data , Abb. "Auswahl Predefined PDO Assignment: Position control".
Auswahl Predefined PDO Assignment: Position control
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu haben Sie zwei Möglichkeiten.
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können die Achse in der Registerkarte "Online" der Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. "Freigabe der Achse in der NC"). Anschließend ist die Achse bereit.
Freigabe der Achse in der NC
▪
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Setzen Sie dazu die Variable 0x7010:01 Enable auf 1 (true), Abb. "Freigabe der Achse manuell".
Freigabe der Achse manuell
▪
Über die zyklische Variable STM Position (Abb. "Eingabe der Position") können Sie eine definierte Position vorgeben.
Diese Betriebsart wird nur mit AS10xx Motoren mit entsprechenden 1024 INC/U Encodern unterstützt. Die Position wird in Inkrementen angegeben und 4096 (1024 INC/U * 4fach Auswertung) entspricht einer volle Umdrehung.
Eingabe der Position


Velocity sensorless

Inbetriebnahme [image] Betriebsarten [image] Velocity sensorless
Velocity sensorless
In der Betriebsart Velocity sensorless arbeitet die EL70x7 im zyklischen Geschwindigkeitsinterface. Über die Variable STM Velocity kann eine definierte Geschwindigkeit eingestellt werden.
Voraussetzungen
▪
Dieser Betriebsmodus kann sowohl mit angeschlossenem Encoder, als auch mit dem internen Zähler (ohne Encoder) genutzt werden.
▪
Die Prozessdaten können entweder mit Hilfe der TwinCAT NC oder direkt aus der PLC übertragen werden.
Step by Step
▪
Fügen Sie die Klemme, wie im Kapitel Konfigurationserstellung TwinCAT - manuell oder - Online Scan beschrieben, zur Konfiguration hinzu.
▪
Verknüpfen Sie die Klemme, wie im Kapitel Einbindung in die NC-Konfiguration beschrieben, mit der NC (wenn TwinCAT NC genutzt wird).
▪
Konfigurieren Sie die EL70x7
–
automatisch - importieren Sie die Motor XML Datei, wie im Kapitel Einstellungen im CoE - automatisch beschrieben, in das Start-up Verzeichnis.
–
manuell - konfigurieren Sie die Parameter, wie im Kapitel Einstellungen im CoE - manuell beschrieben.
▪
Stellen Sie die Betriebsart im CoE-Verzeichnis auf Velocity sensorless, Abb. "Auswahl Velocity sensorless".
Auswahl Velocity sensorless Modus
▪
Wählen Sie bei den Predefined PDO Assignments Velocity control, Velocity control compact oder Velocity control compact with info data, Abb. "Auswahl Predefined PDO Assignment: Velocity control compact".
Auswahl Predefined PDO Assignment: Velocity control compact
▪
Aktivieren Sie die Konfiguration (Ctrl+Shift+F4)
▪
Durchlaufen Sie die State Machine der Klemme. Dazu haben Sie zwei Möglichkeiten.
–
Sie nutzen die TwinCAT NC.
Die State Machine wird von der NC automatisch durchlaufen. Sie können die Achse in der Registerkarte "Online" der Achse freigeben.
Setzen Sie alle Häkchen und stellen Sie Override auf 100% (siehe Abb. "Freigabe der Achse in der NC"). Anschließend ist die Achse bereit.
Freigabe der Achse in der NC
▪
Sie nutzen nicht die TwinCAT NC.
In diesem Fall müssen Sie die State Machine manuell durchfahren. Setzen Sie dazu die Variable 0x7010:01 Enable auf 1 (true), Abb. "Freigabe der Achse manuell".
Freigabe der Achse manuell
▪
Über die zyklische Variable STM velocity (Abb. "Eingabe der Geschwindigkeit") können Sie eine definierte Geschwindigkeit vorgeben.
Die Geschwindigkeit wird in % der Speed range (Index 8012:05) angegeben. Der Wert +32767 entspricht 100% und der Wert -32767 entspricht -100%.
Eingabe der Geschwindigkeit
▪
Die Umschaltung zum sensorlosen Betrieb erfolgt über parametrierbare, motorabhängige Umschaltdrehzahl. Die Umschaltdrehzahl liegt meist im Bereich von einer halben bis drei Umdrehungen pro Sekunde (Crossover velocity 1, Index 8014:07). Und anschließend ein Hinweis mit:
Parametrierung Sensorloser Betrieb
Alle Parameter, die für den Sensorlosen Betrieb erforderlich sind, können zusammengefasst der Tabelle „Übersicht der Parametereinstellungen einzelner Betriebsarten“ entnommen werden.
Alle notwendigen Parameter sind jedoch für die endsprechenden Motortypen über eine StartupListe vorparametriert.


Grundlagen zum "Positioning interface"

Inbetriebnahme [image] Betriebsarten [image] Grundlagen zum "Positioning interface"
Grundlagen zum "Positioning interface"
Das "Positioning interface" bietet dem Anwender eine Möglichkeit direkt auf der Klemme Fahraufträge auszuführen.
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die Funktion "Positioning interface" oder "Positioning interface compact" aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Predefined PDO Assignment
Parametersatz
Für die Konfiguration stehen dem Anwender im CoE zwei Objekte zur Verfügung, die "POS Settings" (Index 8020) und die "POS Features" (Index 8021).
Settings-Objekte im CoE
POS Settings
Velocity min.:
Die Klemme benötigt aus Gründen der Performance, beim Herunterrampen auf die Zielposition einen, Sicherheitsbereich von 0,5 %. Das bedeutet, dass abhängig von der erreichten Maximalgeschwindigkeit und der konfigurierten Verzögerung der Zeitpunkt errechnet wird, an dem die Bremsrampe beginnt. Um immer sicher ins Ziel zu gelangen, werden von der ermittelten Position 0,5% abgezogen. Ist die Bremsrampe beendet und das Ziel noch nicht erreicht, fährt die Klemme mit der Geschwindigkeit "Velocity min." bis ins Ziel hinein. Sie muss so konfiguriert werden, dass der Motor in der Lage ist abrupt und ohne einen Schrittverlust mit dieser Geschwindigkeit abzustoppen.
Velocity max.:
Die maximale Geschwindigkeit, mit der der Motor während eines Fahrauftrages fährt.
"Speed range" (Index 8012:05) [gilt für EL70x7]
Velocity min./max. sind auf die konfigurierte "Speed range" (Index 8012:05) normiert. Das bedeutet, dass bei einer „Speed range“ von beispielsweise 4000 Vollschritten/Sekunde für eine Geschwindigkeitsausgabe von 100% (d.h. 4000 Vollschritte/Sekunde) in „Velocity max.“ eine 10000 und bei 50% (d.h. 2000 Vollschritte/Sekunde) eine 5000 eingetragen werden muss
Acceleration pos.:
Beschleunigungszeit in positiver Drehrichtung.
Die 5 Parameter der Beschleunigung beziehen sich ebenfalls auf die eingestellte "Speed range" und werden in ms angegeben. Mit der Einstellung von 1000 beschleunigt die Klemme den Motor in 1000 ms von 0 auf 100%. Bei einer Geschwindigkeit von 50% verringert sich die Beschleunigungszeit dementsprechend linear auf die Hälfte.
Acceleration neg.:
Beschleunigungszeit in negativer Drehrichtung.
Deceleration pos.:
Verzögerungszeit in positiver Drehrichtung.
Deceleration neg.:
Verzögerungszeit in negativer Drehrichtung.
Emergency deceleration:
Notfall-Verzögerungszeit (beide Drehrichtungen). Ist im entsprechenden PDO "Emergency stop" gesetzt, wird der Motor innerhalb dieser Zeit gestoppt.
Calibration position:
Der aktuelle Zählerstand wird nach erfolgter Kalibrierung mit diesem Wert geladen.
Calibration velocity (towards plc cam):
Geschwindigkeit, mit der der Motor, während der Kalibrierung auf die Nocke fährt.
Calibration velocity (off plc cam):
Geschwindigkeit, mit der der Motor, während der Kalibrierung von der Nocke herunter fährt.
Target window:
Zielfenster der Fahrwegsteuerung. Kommt der Motor innerhalb diese Zielfensters zum Stillstand, wird "In-Target" gesetzt
In-Target timeout:
Steht der Motor nach Ablauf der Fahrwegsteuerung nach dieser eingestellten Zeit nicht im Zielfenster, wird "In-Target" nicht gesetzt. Dieser Zustand kann nur durch Kontrolle der negativen Flanke von "Busy" erkannt werden.
Dead time compensation:
Kompensation der internen Laufzeiten. Dieser Parameter muss bei Standardanwendungen nicht geändert werden.
Modulo factor:
Der "Modulo factor" wird zur Berechnung der Zielposition und der Drehrichtung in den Modulo-Betriebsarten herangezogen. Er bezieht sich auf das angesteuerte System.
Modulo tolerance window:
Toleranzfenster zur Ermittlung der Startbedingung der Modulo-Betriebsarten.
POS Features
Start type:
Der "Start type" bestimmt die Art der Berechnung für die Ermittlung der Zielposition (siehe unten).
Time information:
Durch dieser Parameter wird die Bedeutung der angezeigten "Actual drive time" konfiguriert. Zur Zeit kann dieser Wert nicht verändert werden, da es keine weitere Auswahlmöglichkeit gibt. Es wird die abgelaufene Zeit des Fahrauftrages angezeigt.
Invert calibration cam search direction:
Bezogen auf eine positive Drehrichtung wird hier die Richtung der Suche nach der Kalibrier-Nocke konfiguriert (auf die Nocke fahren).
Invert sync impulse search direction:
Bezogen auf eine positive Drehrichtung wird hier die Richtung der Suche nach dem HW-Sync-Impuls konfiguriert (von der Nocke herunter fahren).
Informations- und Diagnosedaten
Informations- und Diagnosedaten
Über die Informations- und Diagnosedaten kann der Anwender eine genauere Aussage darüber erhalten, welcher Fehler während eines Fahrauftrages aufgetreten ist.
Diagnose-Objekte im CoE
POS Info data
Status word:
Das "Status word" spiegelt die im Index A020 verwendeten Status-Bits in einem Datenwort, um diese in der PLC einfacher verarbeiten zu können. Die Positionen der Bits entsprechen der Nummer des Subindizes-1.
Bit 0: Command rejected
Bit 1: Command aborded
Bit 2: Target overrun
State (drive controller):
Hier wird der aktuelle Status der internen Statemachine eingeblendet (siehe unten).
POS Diag data:
Command rejected:
Eine dynamische Änderung der Zielposition wird nicht zu jedem Zeitpunkt von der Klemme übernommen, da dies dann nicht möglich ist. Der neue Auftrag wird in diesem Fall abgewiesen und durch setzen dieses Bits signalisiert.
Diese 3 Diagnose-Bits werden durch Setzten von "Warning" im PDO zur Steuerung synchron übertragen.
Command aborted:
Wird der aktuelle Fahrauftrag durch einen internen Fehler oder durch ein "Emergency stop" vorzeitig abgebrochen wird.
Target overrun:
Bei einer dynamischen Änderung der Zielposition kann es vorkommen, dass die Änderung zu einem relativ späten Zeitpunkt erfolgt. Dies kann zur Folge haben, dass ein Drehrichtungswechsel erforderlich ist und ggf. die neue Zielposition überfahren wird. Tritt dies ein, so wird "Target overrun" gesetzt.
Zustände der internen Statemachine
Zustände der internen Statemachine
Der State (drive controller) (Index 9020:03) gibt Auskunft über den aktuellen Zustand der internen Statemachine. Zu Diagnosezwecken kann dieser zur Laufzeit von der PLC ausgelesen werden. Der interne Zyklus arbeitet konstant mit 250 µs. Ein angeschlossener PLC-Zyklus ist großer Wahrscheinlichkeit nach langsamer (z.B. 1 ms). Daher kann es vorkommen, dass manche Zustände in der PLC überhaupt nicht sichtbar sind, da diese teilweise nur einen internen Zyklus durchlaufen werden.
Name | ID | Beschreibung
INIT | 0x0000 | Initialisierung/Vorbereitung für den nächsten Fahrauftrag
IDLE | 0x0001 | Warten auf den nächsten Fahrauftrag
START | 0x0010 | das neue Kommando wird ausgewertet und die entsprechenden Berechnungen durchgeführt
ACCEL | 0x0011 | Beschleunigungs-Phase
CONST | 0x0012 | Konstant-Phase
DECEL | 0x0013 | Verzögerungs-Phase
EMCY | 0x0020 | es wurde ein "Emergency stop" ausgelöst
STOP | 0x0021 | der Motor ist gestoppt
CALI_START | 0x0100 | Start eines Kalibrierkommandos
CALI_GO_CAM | 0x0110 | der Motor wird auf die Nocke gefahren
CALI_ON_CAM | 0x0111 | die Nocke wurde erreicht
CALI_GO_SYNC | 0x0120 | der Motor wird in Richtung des HW-Sync-Impulses gefahren
CALI_LEAVE_CAM | 0x0121 | der Motor wird von der Nocke herunter gefahren
CALI_STOP | 0x0130 | Ende der Kalibrier-Phase
CALIBRATED | 0x0140 | der Motor ist kalibriert
NOT_CALIBRATED | 0x0141 | der Motor ist nicht kalibriert
PRE_TARGET | 0x1000 | Sollposition ist erreicht, der Positionsregler "zieht" den Motor weiter ins Ziel, "In-Target timeout" wird hier gestartet
TARGET | 0x1001 | der Motor hat das Zielfenster innerhalb des Timeouts erreicht
TARGET_RESTART | 0x1002 | eine dynamische Änderung der Zielposition wird hier verarbeitet
END | 0x2000 | Ende der Positionier-Phase
WARNING | 0x4000 | während des Fahrauftrages ist eine Warn-Zustand aufgetreten, dieser wird hier verarbeitet
ERROR | 0x8000 | während des Fahrauftrages ist eine Fehler-Zustand aufgetreten, dieser wird hier verarbeitet
UNDEFINED | 0xFFFF | undefinierter Zustand (kann z.B. auftreteten, wenn die Treiberstufe keine Steuerspannung hat)
Zustände der internen Statemachine
Standard Ablauf eines Fahrauftrags
Standard Ablauf eines Fahrauftrags
Im folgenden Ablaufdiagramm ist ein "normaler" Ablauf eines Fahrauftrags dargestellt.
Es wird grob zwischen diesen vier Stufen unterschieden:
Startup:
Überprüfung des Systems und der Betriebsbereitschaft des Motors.
Start positioning:
Schreiben aller Variablen und Berechnung der gewünschten Zielposition mit dem entsprechenden "Start type". Anschließend den Fahrauftrag starten.
Evaluate status:
Überwachung des Klemmen-Status und ggf. dynamische Änderung der Zielposition.
Error handling:
Im Falle eines Fehlers die nötigen Informationen aus dem CoE beziehen und auswerten.
Ablauf-Diagramm eines Fahrauftrages
Starttypen
Das "Positioning interface" bietet verschiedene Arten der Positionierung. Die folgende Tabelle enthält alle unterstützten Kommandos, diese sind in 4 Gruppen aufgeteilt.
Name | Kommando | Gruppe | Beschreibung
ABSOLUTE | 0x0001 | Standard | absolute Positionierung auf eine vorgegebene Zielposition
RELATIVE | 0x0002 |  | relative Positionierung auf eine berechnete Zielposition, ein vorgegebener Positionsunterschied wird zur aktuelle Position addiert
ENDLESS_PLUS | 0x0003 |  | endlos fahren in positiver Drehrichtung (direkte Vorgabe einer Geschwindigkeit)
ENDLESS_MINUS | 0x0004 |  | endlos fahren in negativer Drehrichtung (direkte Vorgabe einer Geschwindigkeit)
ADDITIVE | 0x0006 |  | additive Positionierung auf eine berechnete Zielposition, ein vorgegebener Positionsunterschied wird zur letzten Zielposition addiert
ABSOLUTE_CHANGE | 0x1001 | Standard Ext. | dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, absolute Position
RELATIVE_CHANGE | 0x1002 |  | dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, relative Position (es wird hier ebenfalls der aktuelle, sich verändernde Positionswert verwendet)
ADDITIVE_CHANGE | 0x1006 |  | dynamische Änderung der Zielposition währen eines Fahrauftrages auf eine neue, additive Position (es wird hier die letzte Zielposition verwendet)
MODULO_SHORT | 0x0105 | Modulo | modulo Positionierung auf kürzestem Weg zur Moduloposition (positiv oder negativ), berechnet durch den konfigurierten "Modulo factor" (Index 8020:0E)
MODULO_SHORT_EXT | 0x0115 |  | modulo Positionierung auf kürzestem Weg zur Moduloposition, das "Modulo tolerance window" (Index 8020:0F) wird ignoriert
MODULO_PLUS | 0x0205 |  | modulo Positionierung in positiver Drehrichtung auf die berechnete Moduloposition
MODULO_PLUS_EXT | 0x0215 |  | modulo Positionierung in positiver Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
MODULO_MINUS | 0x0305 |  | modulo Positionierung in negativer Drehrichtung auf die berechnete Moduloposition
MODULO_MINUS_EXT | 0x0315 |  | modulo Positionierung in negativer Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
MODULO_CURRENT | 0x0405 |  | modulo Positionierung mit der letzten Drehrichtung auf die berechnete Moduloposition
MODULO_CURRENT_EXT | 0x0415 |  | modulo Positionierung mit der letzten Drehrichtung auf die berechnete Moduloposition, das "Modulo tolerance window" wird ignoriert
CALI_PLC_CAM | 0x6000 | Calibration | starten einer Kalibrierung mit Nocke (digitale Eingänge)
CALI_HW_SYNC | 0x6100 |  | starten einer Kalibrierung mit Nocke und HW-Sync-Impuls (C-Spur)
SET_CALIBRATION | 0x6E00 |  | manuelles Setzen der Klemme auf "Kalibriert"
SET_CALIBRATION_AUTO | 0x6E01 |  | automatisches Setzen der Klemme auf "Kalibriert" bei der ersten steigenden Flanke von "Enable"
CLEAR_CALIBRATION | 0x6F00 |  | manuelles Löschen der Kalibrierung
Unterstützte " Start types " des "Positioning interface "
ABSOLUTE:
Die absolute Positionierung stellt den einfachsten Fall einer Positionierung dar. Es wird eine Position B vorgegeben, welche vom Startpunkt A aus angefahren wird.
Absolute Positionierung
RELATIVE:
Bei der relativen Positionierung gibt der Anwender ein Positionsdelta S vor, welches zur aktuellen Position A addiert wird und die Zielposition B ergibt.
Relative Positionierung
ENDLESS_PLUS / ENDLESS_MINUS:
Die beiden Starttypen "ENDLESS_PLUS" und "ENDLESS_MINUS" bieten im "Positioning interface" die Möglichkeit dem Motor eine direkte Geschwindigkeit vorzugeben, um endlos in positiver oder negativer Richtung, mit den vorgegebenen Beschleunigungen, zu fahren.
Endlos fahren
ADDITIVE:
Für die additive Positionierung wird, zur Berechnung der Zielposition B, das vom Anwender vorgegebene Positionsdelta S mit der beim letzten Fahrauftrag verwendeten Zielposition E addiert.
Diese Art der Positionierung ähnelt der relativen Positionierung, hat aber doch einen Unterschied. Wurde der letzte Fahrauftrag mit Erfolg abgeschlossen, ist die neue Zielposition gleich. Gab es aber einen Fehler, sei es dass der Motor in eine Stall-Situation geraten ist oder ein "Emergency stop" ausgelöst wurde, ist die aktuelle Position beliebig und nicht vorausschaubar. Der Anwender hat jetzt den Vorteil, dass er die letzte Zielposition für die Berechnung der folgenden Zielposition nutzen kann.
Additive Positionierung
ABSOLUTE_CHANGE / RELATIVE_CHANGE / ADDITIVE_CHANGE:
Diese drei Positionierarten sind komplett identisch zu den oben beschrieben. Der wichtige Unterschied dabei ist, dass der Anwender während eines aktiven Fahrauftrags diese Kommandos nutzt, um dynamisch eine neue Zielposition vorzugeben.
Es gelten dabei die gleichen Regeln und Voraussetzungen, wie bei den "normalen" Starttypen. "ABSOLUTE_CHANGE" und "ADDITIVE_CHANGE" sind in der Berechnung der Zielposition eindeutig d.h. bei der absoluten Positionierung wird eine absolute Position vergegeben und bei der additiven Positionierung wird ein Positionsdelta zu der gerade aktiven Zielposition addiert.
Hinweis
Vorsicht bei der Verwendung der Positionierung "RELATIVE_CHANGE"
Die Änderung per "RELATIVE_CHANGE" muss mit Vorsicht angewendet werden, da auch hier die aktuelle Position des Motors als Startposition verwendet wird. Durch Laufzeiten des Systems stimmt die im PDO angezeigte Position nie mit der realen Position des Motors überein! Daher wird sich bei der Berechnung des übergebenen Positionsdeltas immer eine Differenz zur gewünschten Zielposition einstellen.
Zeitpunkt der Änderung der Zielposition
Eine Änderung der Zielposition kann nicht zu jedem beliebigen Zeitpunkt erfolgen. Falls die Berechnung der Ausgabeparameter ergibt, dass die neue Zielposition nicht ohne weiteres erreicht werden kann, wird das Kommando von der Klemme abgewiesen und das Bit "Command rejected" gesetzt. Dies ist z.B. im Stillstand (da die Klemme hier eine Standard Positionierung erwartet) und in der Beschleunigungsphase (da zu diesem Zeitpunkt der Bremszeitpunkt noch nicht berechnet werden kann) der Fall.
CALI_PLC_CAM / CALI_HW_SYNC / SET_CALIBRATION / SET_CALIBRATION_AUTO / CLEAR_CALIBRATION:
Der einfachste Fall einer Kalibrierung ist der, nur per Nocke (an einem dig. Eingang angeschlossen) zu kalibrieren.
Hierbei fährt der Motor im 1. Schritt mit der Geschwindigkeit 1 (Index 0x8020:09) in Richtung 1 (Index 0x8021:13) auf die Nocke. Anschließend im 2. Schritt mit der Geschwindigkeit 2 (Index 0x8020:0A) in Richtung 2 (Index 0x8021:14) von der Nocke herunter. Nachdem das "In-Target timeout" (Index 0x8020:0C) abgelaufen ist wird die Kalibrierposition (Index 0x8020:08) als aktuelle Position von der Klemme übernommen.
Hinweis
Schalthysterese des Nockenschalters beachten
Bei dieser einfachen Kalibrierung muss beachtet werden, dass die Positionserfassung der Nocke nur bedingt genau ist. Die digitalen Eingänge sind nicht interruptgesteuert und werden "nur" gepollt. Durch die internen Laufzeiten kann sich deshalb eine systembedingte Positionsdifferenz ergeben.
Kalibrierung mit Nocke
Für eine genauere Kalibrierung wird zusätzlich zu der Nocke ein HW-Sync-Impuls (C-Spur) verwendet. Der Ablauf dieser Kalibrierung erfolgt genau wie oben beschrieben, bis zu dem Zeitpunkt, an dem der Motor von der Nocke herunterfährt. Jetzt wird nicht sofort gestoppt, sondern erst auf den Sync-Impuls gewartet. Anschließend läuft wieder das "In-Target timeout" ab und die Kalibrierposition wird als aktuelle Position von der Klemme übernommen.
Kalibrierung mit Nocke und C-Spur
Falls eine Kalibrierung per Hardware, aufgrund der applikatorischen Umstände, nicht möglich ist, kann der Anwender das Bit "Calibrated" auch manuell bzw. automatisch setzen. Das manuelle Setzen bzw. Löschen erfolgt mit den Kommandos "SET_CALIBRATION" und "CLEAR_CALIBRATION".
Einfacher ist es aber, wenn man den Standard-Starttypen (Index 0x8021:01) auf "SET_CALIBRATION_AUTO" konfiguriert. Jetzt wird bei der ersten steigenden Flanke von "Enable" das Bit "Calibrated" automatisch gesetzt. Das Kommando ist nur für diesen Zweck konzipiert, daher ist es nicht sinnvoll es über den synchronen Datenaustausch zu benutzen.
MODULO:
Die Modulo-Position der Achse ist eine zusätzliche Information zur absoluten Achsposition und die Modulo-Positionierung stellt die gewünschte Zielposition auf eine andere Art dar. Im Gegensatz zu den Standard-Positionierarten, birgt die Modulo-Positionierung einige Tücken, da die gewünschte Zielposition unterschiedlich interpretiert werden kann.
Die Modulo-Positionierung bezieht sich grundsätzlich auf den im CoE einstellbaren "Modulo factor" (Index 0x8020:0E). In den folgenden Beispielen wird von einer rotatorischen Achse mit einem "Modulo factor" von umgerechnet 360 Grad ausgegangen.
Das "Modulo tolerance window" (Index 0x8020:0F) definiert ein Positionsfenster um die aktuelle Modulo-Sollposition der Achse herum. Die Fensterbreite entspricht dem doppelten angegebenen Wert (Sollposition ± Toleranzwert). Auf das Toleranzfenster wird im Folgenden näher eingegangen.
Die Positionierung einer Achse bezieht sich immer auf deren aktuellen Istposition. Die Istposition der Achse ist im Normalfall die Position, die mit dem letzten Fahrauftrag angefahren wurde. Unter Umständen (fehlerhafte Positionierung durch einen Stall der Achse, oder eine sehr grobe Auflösung des angeschlossenen Enkoders) kann sich aber eine vom Anwender nicht erwartete Position einstellen. Wenn dieser Umstand nicht berücksichtigt wird, kann sich eine nachfolgende Positionierung unerwartet verhalten.
Wirkung des Modulo-Toleranzfensters - Modulo-Zielposition 0° in positiver Richtung
Beispiel:
Eine Achse wird auf 0° positioniert, wodurch die Istposition der Achse anschließend exakt 0° beträgt. Ein weiterer Modulo-Fahrauftrag auf 360° in positiver Richtung führt zu einer vollen Umdrehung und die Modulo-Position der Achse ist anschließend wieder exakt 0°. Kommt die Achse bedingt durch die Mechanik etwas vor oder hinter der Zielposition zum Stehen, so verhält sich das nächste Fahrkommando ggf. nicht so, wie man es erwartet. Liegt die Istposition leicht unter 0° (siehe Abb. 9, links unten), so führt ein neues Fahrkommando auf 0° in positiver Richtung nur zu einer minimalen Bewegung. Die vorher entstandene Abweichung wird ausgeglichen und die Position ist anschließend wieder exakt 0°. Liegt aber die Position leicht über 0°, so führt dasselbe Fahrkommando zu einer vollen Umdrehung um wieder die exakte Position von 0° zu erreichen. Diese Problematik tritt auf, wenn volle Umdrehungen um 360° oder ein Vielfaches von 360° beauftragt werden. Bei Positionierungen auf einen von der aktuellen Modulo-Position entfernten Winkel ist der Fahrauftrag eindeutig.
Um das Problem zu lösen, kann ein "Modulo tolerance window" (Index 0x8020:0F) parametriert werden. Kleine Abweichungen der Position, die innerhalb des Fensters liegen, führen damit nicht mehr zu einem unterschiedlichen Verhalten der Achse. Wird beispielsweise ein Fenster von 1° parametriert, so verhält sich die Achse im oben beschriebenen Fall gleich, solange die Istposition zwischen 359° und 1° liegt. Wenn jetzt die Position weniger als 1° über 0° liegt, wird die Achse bei einem Modulo-Start in positiver Richtung zurückpositioniert. Bei einer Zielposition von 0° wird also in beiden Fällen eine Minimalbewegung auf exakt 0° ausgeführt und bei einer Zielposition von 360° wird in beiden Fällen eine ganze Umdrehung gefahren.
Das Modulo-Toleranzfenster kann also innerhalb des Fensters zu Bewegungen gegen die beauftragte Richtung führen. Bei einem kleinen Fenster ist das normalerweise unproblematisch, weil auch Regelabweichungen zwischen Soll- und Istposition in beide Richtungen ausgeglichen werden. Das Toleranzfenster lässt sich also auch bei Achsen verwenden, die konstruktionsbedingt nur in einer Richtung verfahren werden dürfen.
Modulo-Positionierung um weniger als eine Umdrehung
Die Modulo-Positionierung von einer Ausgangsposition auf eine nicht identische Zielposition ist eindeutig und birgt keine Besonderheiten. Eine Modulo-Zielposition im Bereich [0 ≤ Position < 360] führt in weniger als einer ganzen Umdrehung zum gewünschten Ziel. Ist die Zielposition mit der Ausgangsposition identisch, so wird keine Bewegung ausgeführt. Bei Zielpositionen ab 360 ° aufwärts werden ein oder mehr vollständige Umdrehungen ausgeführt, bevor die Achse auf die gewünschte Zielposition fährt.
Für eine Bewegung von 270° auf 0° darf demnach nicht 360°, sondern es muss 0° als Modulo-Zielposition beauftragt werden, da 360° außerhalb des Grundbereiches liegt und zu einer zusätzlichen Umdrehung führen würde.
Die Modulo-Positionierung unterscheidet drei Richtungsvorgaben, positive Richtung, negative Richtung und auf kürzestem Weg (MODULO_PLUS, MODULO_MINUS, MODULO_SHORT). Bei der Positionierung auf kürzestem Weg sind Zielpositionen ab 360° nicht sinnvoll, da das Ziel immer direkt angefahren wird. Im Gegensatz zur positiven oder negativen Richtung können also nicht mehrere Umdrehungen ausgeführt werden, bevor das Ziel angefahren wird.
Hinweis
Nur Grundperioden kleiner 360° sind erlaubt
Bei Modulo-Positionierungen mit dem Start-Typ "MODULO_SHORT" sind nur Modulo-Zielpositionen in der Grundperiode (z. B. kleiner als 360°) erlaubt, anderenfalls wird ein Fehler zurückgegeben.
Positionierung ohne Modulo-Toleranzfenster
Bei den "normalen" Modulo-Positionierarten wird immer das "Modulo tolerance window" (Index 0x8020:0F) berücksichtigt. In manchen Situationen ist dies aber eher unerwünscht. Um diesen "Nachteil" zu eliminieren, können die vergleichbaren Starttypen "MODULO_SHORT_EXT", "MODULO_PLUS_EXT", "MODULO_MINUS_EXT" und "MODULO_CURRENT_EXT" verwendet werden, welche das Modulo-Toleranzfensster ignorieren.
Die folgende Tabelle zeigt einige Positionierungsbeispiele:
Modulo-Starttyp | Absolute Anfangsposition | Modulo-Zielposition | Relativer Verfahrweg | absolute Endposition | Modulo Endposition
MODULO_PLUS | 90° | 0° | 270° | 360° | 0°
MODULO_PLUS | 90° | 360° | 630° | 720° | 0°
MODULO_PLUS | 90° | 720° | 990° | 1080° | 0°
MODULO_MINUS | 90° | 0° | -90° | 0° | 0°
MODULO_MINUS | 90° | 360° | -450° | -360° | 0°
MODULO_MINUS | 90° | 720° | -810° | -720° | 0°
MODULO_SHORT | 90° | 0° | -90° | 0° | 0°
Beispiele zur Modulo-Positionierung bei weniger als einer Umdrehung
Modulo-Positionierung um ganze Umdrehungen
Modulo-Positionierungen um ein oder mehrere ganze Umdrehungen verhalten sich grundsätzlich nicht anders als Positionierungen auf von der Ausgangsposition entfernt liegende Winkel. Wenn die beauftragte Zielposition gleich der Ausgangsposition ist, so wird keine Bewegung ausgeführt. Für eine ganze Umdrehung muss zur Ausgangsposition 360° addiert werden. Das beschriebene Verhalten im Beispiel zeigt, dass Positionierungen mit ganzzahligen Umdrehungen besonders beachtet werden müssen. Die nachfolgende Tabelle zeigt Positionierbeispiele für eine Ausgangsposition von ungefähr 90°. Das Modulo-Toleranzfenster ist hier auf 1° eingestellt. Besondere Fälle, in denen die Ausgangsposition außerhalb dieses Fensters liegt, sind gekennzeichnet.
Modulo- Starttyp | Absolute Anfangs- position | Modulo- Ziel position | Rela- tiver Ver- fahrweg | absolute End- position | Modulo End- position | Anmerkung
MODULO_PLUS | 90,00° | 90,00° | 0,00° | 90,00° | 90,00° |
MODULO_PLUS | 90,90° | 90,00° | -0,90° | 90,00° | 90,00° |
MODULO_PLUS | 91,10° | 90,00° | 358,90° | 450,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 90,00° | 0,90° | 90,00° | 90,00° |
MODULO_PLUS | 88,90° | 90,00° | 1,10° | 90,00° | 90,00° | außerhalb TF
MODULO_PLUS | 90,00° | 450,00 | 360,00° | 450,00° | 90,00° |
MODULO_PLUS | 90,90° | 450,00° | 359,10° | 450,00° | 90,00° |
MODULO_PLUS | 91,10° | 450,00° | 718,90° | 810,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 450,00° | 360,90° | 450,00° | 90,00° |
MODULO_PLUS | 88,90° | 450,00° | 361,10° | 450,00° | 90,00° | außerhalb TF
MODULO_PLUS | 90,00° | 810,00 | 720,00° | 810,00° | 90,00° |
MODULO_PLUS | 90,90° | 810,00 | 719,10° | 810,00° | 90,00° |
MODULO_PLUS | 91,10° | 810,00 | 1078,90° | 1170,00° | 90,00° | außerhalb TF
MODULO_PLUS | 89,10° | 810,00 | 720,90° | 810,00° | 90,00° |
MODULO_PLUS | 88,90° | 810,00 | 721,10° | 810,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 90,00° | 0,00° | 90,00° | 90,00° |
MODULO_MINUS | 90,90° | 90,00° | -0,90° | 90,00° | 90,00° |
MODULO_MINUS | 91,10° | 90,00° | -1,10° | 90,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 90,00° | 0,90° | 90,00° | 90,00° |
MODULO_MINUS | 88,90° | 90,00° | -358,90° | -270,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 450,00° | -360,00° | -270,00° | 90,00° |
MODULO_MINUS | 90,90° | 450,00° | -360,90° | -270,00° | 90,00° |
MODULO_MINUS | 91,10° | 450,00° | -361,10° | -270,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 450,00° | -359,10° | -270,00° | 90,00° |
MODULO_MINUS | 88,90° | 450,00° | -718,90° | -630,00° | 90,00° | außerhalb TF
MODULO_MINUS | 90,00° | 810,00° | -720,00° | -630,00° | 90,00° |
MODULO_MINUS | 90,90° | 810,00° | -720,90° | -630,00° | 90,00° |
MODULO_MINUS | 91,10° | 810,00° | -721,10° | -630,00° | 90,00° | außerhalb TF
MODULO_MINUS | 89,10° | 810,00° | -719,10° | -630,00° | 90,00° |
MODULO_MINUS | 88,90° | 810,00° | -1078,90° | -990,00° | 90,00° | außerhalb TF
Beispiele zur Modulo-Positionierung bei ganzen Umdrehungen
Beispiele von zwei Fahraufträgen mit dynamischer Änderung der Zielposition
Ohne Überfahren der Zielposition
Zeitpunkt | POS Outputs | POS Inputs | Beschreibung
t1: | Execute = 1 Target position = 200000 Velocity = 2000 Start type = 0x0001 Acceleration = 1000 Deceleration = 1000 | Busy = 1 Accelerate = 1 | - Vorgabe der ersten Parameter - Beginn der Beschleunigungsphase
t2: |  | Accelerate = 0 | - Ende der Beschleunigungsphase
t3: | Target position = 100000 Velocity = 1500 Start type = 0x1001 Acceleration = 2000 Deceleration = 2000 |  | - Änderung der Parameter - Aktivierung durch neuen Starttypen
t4: |  | Decelerate = 1 | - Beginn der Verzögerungsphase
t5: | Execute = 0 | Busy = 0 In-Target = 1 Decelerate = 0 | - Ende der Verzögerungsphase - Motor ist auf neuer Zielposition
t6 - t9: |  |  | - Absolute Fahrt zurück auf die Startposition 0
Scope-Aufnahme eines Fahrauftrages mit dynamischer Änderung der Zielposition, ohne Überfahren der Zielposition
(Die Achsen-Skalierung bezieht sich nur auf die Positionen, nicht auf die Geschwindigkeit und die Status-Bits)
Mit Überfahren der Zielposition
Zeitpunkt | POS Outputs | POS Inputs | Beschreibung
t1: | Execute = 1 Target position = 200000 Velocity = 5000 Start type = 0x0001 Acceleration = 3000 Deceleration = 5000 | Busy = 1 Accelerate = 1 | - Vorgabe der 1. Parameter - Beginn der 1. Beschleunigungsphase
t2: |  | Accelerate = 0 | - Ende der 1. Beschleunigungsphase
t3: | Target position = 100000 Velocity = 1500 Start type = 0x1001 Acceleration = 1000 Deceleration = 2000 | Warning = 1 Decelerate = 1 | - Änderung der Parameter - Aktivierung durch neuen Starttypen - Warnung vor dem Überfahren der Zielposition - Beginn der 1. Verzögerungsphase
t4: |  | Accelerate = 1 Decelerate = 0 | - Ende der 1. Verzögerungsphase - Beginn der 2. Beschleunigungsphase in Gegenrichtung
t5: |  | Accelerate = 0 Decelerate = 1 | - Ende der 2. Beschleunigungsphase - Beginn der 2. Verzögerungsphase
t6: | Execute = 0 | Busy = 0 In-Target = 1 Decelerate = 0 | - Ende der 2.Verzögerungsphase - Motor ist auf neuer Zielposition
t7 - t10: |  |  | - Absolute Fahrt zurück auf die Startposition 0
Scope-Aufnahme eines Fahrauftrages mit dynamischer Änderung der Zielposition, mit Überfahren der endgültigen Zielposition
(Die Achsen-Skalierung bezieht sich nur auf die Positionen, nicht auf die Geschwindigkeit und die Status-Bits)


Konfiguration mit dem TwinCAT System Manager

Konfiguration mit dem TwinCAT System Manager
Konfiguration mit dem TwinCAT System Manager
Weiterführende Informationen
•
EL7037
•
EL7047


EL7037

Konfiguration mit dem TwinCAT System Manager [image] EL7037
EL7037
Weiterführende Informationen
•
Objektbeschreibung und Parametrierung - Profilspezifische Objekte
•
Objektbeschreibung und Parametrierung - Standardobjekte


Objektbeschreibung und Parametrierung - Profilspezifische Objekte

Konfiguration mit dem TwinCAT System Manager [image] EL7037 [image] Objektbeschreibung und Parametrierung - Profilspezifische Objekte
Objektbeschreibung und Parametrierung - Profilspezifische Objekte
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Hinweis
Beschädigung des Gerätes möglich!
Es wird dringend davon abgeraten, die Einstellungen in den CoE-Objekten zu ändern während die Achse aktiv ist, da die Reglung beeinträchtigt werden könnte.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
Objektübersicht
• Restore-Objekt
• Konfigurationsdaten
• Kommando-Objekt
• Eingangsdaten
• Ausgangsdaten
• Informations-/Diagnosedaten (kanalspezifisch)
• Hersteller-Konfigurationsdaten (gerätespezifisch)
• Informations-/Diagnosedaten (gerätespezifisch)
• Standardobjekte
Restore-Objekt
Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Konfigurationsdaten
Index 8000 ENC Settings Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
8000:08 | Disable filter | Deaktiviert die Eingangsfilter. | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable micro increments | Die unteren 8 Bit des Zählerstandes werden extrapoliert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr des Enkoders. | BOOLEAN | RW | 0x00 (0dez)
Index 8010 STM Motor Settings Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | STM Motor Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
8010:01 | Maximal current | maximaler, dauerhafter Spulenstrom des Motors Einheit : 1 mA | UINT16 | RW | 0x05DC (1500dez)
8010:02 | Reduced current | reduzierter Spulenstrom Einheit : 1 mA | UINT16 | RW | 0x01F4 (500dez)
8010:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors Einheit : 10 mV | UINT16 | RW | 0x0960 (2400dez)
8010:04 | Motor coil resistance | Innenwiderstand des Motors Einheit : 10 mOhm | UINT16 | RW | 0x0064 (100dez)
8010:05 | Motor EMF | Gegenspannung des Motors Einheit : 1 mV / (rad/s) | UINT16 | RW | 0x0000 (0dez)
8010:06 | Motor fullsteps | Anzahl der Vollschritte des Motors | UINT16 | RW | 0x00C8 (200dez)
8010:07 | Encoder increments (4-fold) | Anzahl der Enkoder-Inkremente pro Umdrehung bei 4-fach Auswertung | UINT16 | RW | 0x1000 (4096dez)
8010:09 | Start velocity | minimale Startgeschwindigkeit des Motors Einheit: 10000 entspricht 100% | UINT16 | RW | 0x0000 (0dez)
8010:0A | Motor coil inductance | Induktivität des Motors Einheit: 0,01 mH | UINT16 | RW | 0x0000 (0dez)
8010:10 | Drive on delay time | Verzögerung zwischen Aktivierung der Treiberstufe und Ready = 1 Einheit: 1 ms | UINT16 | RW | 0x0064 (100dez)
8010:11 | Drive off delay time | Verzögerung zwischen Ready = 0 und Deaktivierung der Treiberstufe Einheit: 1 ms | UINT16 | RW | 0x0096 (150dez)
Index 8011 STM Controller Settings Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8011:0 | STM Controller Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
8011:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x0096 (150dez)
8011:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x000A (10dez)
Index 8012 STM Features Ch.1 (Teil 1)
Index | Name | Bedeutung | Datentyp | Flags | Default
8012:0 | STM Features Ch.1 | Maximaler Subindex | UINT8 | RO | 0x3A (58dez)
8012:01 | Operation mode | erlaubte Werte: | BIT4 | RW | 0x00 (0dez)
 |  | 0: Automatic
 |  | 1: Velocity direct
 |  | 3: Position controller
 |  | 4: Ext. Velocity mode
 |  | 5: Ext. Position mode
 |  | 6: Velocity sensorless
8012:05 | Speed range | erlaubte Werte: | BIT3 | RW | 0x01 (1dez)
 |  | 0: 1000 Fullsteps/sec
 |  | 1: 2000 Fullsteps/sec
 |  | 2: 4000 Fullsteps/sec
 |  | 3: 8000 Fullsteps/sec
 |  | 4: 16000 Fullsteps/sec
 |  | 5: 32000 Fullsteps/sec
8012:08 | Feedback type | erlaubte Werte: | BIT1 | RW | 0x01 (1dez)
 |  | 0: Encoder
 |  | 1: internal counter
8012:09 | Invert motor polarity | Drehrichtung des Motors invertieren | BOOLEAN | RW | 0x00 (0dez)
8012:0A | Error on step lost | Fehler bei Schrittverlust | BOOLEAN | RW | 0x00 (0dez)
8012:11 | Select info data 1 | erlaubte Werte: | UINT8 | RW | 0x0B (11dez)
 |  | 0: Status word
 |  | 7: Motor velocity
 |  | 11: Motor load
 |  | 13: Motor dc current
 |  | 101: Internal temperature
 |  | 103: Control voltage
 |  | 104: Motor supply voltage
 |  | 150: Drive - Status word
 |  | 151: Drive - State
 |  | 152: Drive - Position lag (low word)
 |  | 153: Drive - Position lag (high word)
Index 8012 STM Features Ch.1 (Teil 2)
Index | Name | Bedeutung | Datentyp | Flags | Default
8012:19 | Select info data 2 | erlaubte Werte: | UINT8 | RW | 0x0D (13dez)
 |  | 0: Status word
 |  | 7: Motor velocity
 |  | 11: Motor load
 |  | 13: Motor dc current
 |  | 101: Internal temperature
 |  | 103: Control voltage
 |  | 104: Motor supply voltage
 |  | 150: Drive - Status word
 |  | 151: Drive - State
 |  | 152: Drive - Position lag (low word)
 |  | 153: Drive - Position lag (high word)
8012:30 | Invert digital input 1 | Digitalen Eingang invertieren | BOOLEAN | RW | 0x00 (0dez)
8012:31 | Invert digital input 2 | Digitalen Eingang invertieren | BOOLEAN | RW | 0x00 (0dez)
8012:32 | Function for input 1 | erlaubte Werte: | BIT4 | RW | 0x00 (0dez)
 |  | 0: Normal input
 |  | 1: Hardware enable
 |  | 2: PLC cam
8012:36 | Function for input 2 | erlaubte Werte: | BIT4 | RW | 0x00 (0dez)
 |  | 0: Normal input
 |  | 1: Hardware enable
 |  | 2: PLC cam
8012:3A | Function for output 1 | erlaubte Werte: | BIT4 | RW | 0x0F (15dez)
 |  | 0: Normal output
 |  | 1: Break (linked with driver enable)
 |  | 15: Disabled
Index 8014 STM Controller Settings 3 Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8014:0 | STM Controller Settings 3 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x09 (9dez)
8014:01 | Feed forward (pos.) | Vorsteuerung des Positionsreglers | UINT32 | RW | 0x000186A0 (100000dez)
8014:02 | Kp factor (pos.) | Kp-Regelfaktor des Positionsreglers | UINT16 | RW | 0x01F4 (500dez)
8014:03 | Kp factor (velo.) | Kp-Regelfaktor des Geschwindigkeitsreglers Einheit : 0,1 mA/(rad/s) | UINT32 | RW | 0x00000032 (50dez)
8014:04 | Tn (velo.) | Zeitkonstante Tn des Geschwindigkeitsreglers Einheit : 0,01 ms | UINT16 | RW | 0xC350 (50000dez)
8014:05 | Sensorless param 1 | 1. Parameter (sensorlosen Regelung) | UINT16 | RW | 0x0000 (0dez)
8014:06 | Sensorless param 2 | 2. Parameter (sensorlosen Regelung) | UINT16 | RW | 0x0000 (0dez)
8014:07 | Cross over velocity 1 | 1. Geschwindigkeitsübergang (sensorlosen Regelung) Einheit : 0,1 rad/s | UINT16 | RW | 0x0000 (0dez)
8014:08 | Cross over velocity 2 | 2. Geschwindigkeitsübergang (sensorlosen Regelung) Einheit : 0,1 rad/s | UINT16 | RW | 0x0000 (0dez)
8014:09 | Cross over velocity 3 | 3. Geschwindigkeitsübergang (sensorlosen Regelung) Einheit : 0,1 rad/s | UINT16 | RW | 0x0000 (0dez)
Index 8020 POS Settings Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | POS Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x10 (16dez)
8020:01 | Velocity min. | minimale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8020:02 | Velocity max. | maximale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x2710 (10000dez)
8020:03 | Acceleration pos. | Beschleunigung in positiver Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:04 | Acceleration neg. | Beschleunigung in negativer Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:05 | Deceleration pos. | Verzögerung in positiver Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:06 | Deceleration neg. | Verzögerung in negativer Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:07 | Emergency deceleration | Notfallverzögerung (beide Drehrichtungen) Einheit : 1 ms | UINT16 | RW | 0x0064 (100dez)
8020:08 | Calibration position | Kalibrierposition | UINT32 | RW | 0x00000000 (0dez)
8020:09 | Calibration velocity (towards plc cam) | Kalibriergeschwindigkeit auf die Nocke (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8020:0A | Calibration Velocity (off plc cam) | Kalibriergeschwindigkeit von der Nocke herunter (Bereich: 0-10000) | INT16 | RW | 0x000A (10dez)
8020:0B | Target window | Zielfenster | UINT16 | RW | 0x000A (10dez)
8020:0C | In-Target timeout | Zielpositions-Timeout Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:0D | Dead time compensation | Totzeitkompensation Einheit : 1 µs | INT16 | RW | 0x0032 (50dez)
8020:0E | Modulo factor | Modulofaktor/-position | UINT32 | RW | 0x00000000 (0dez)
8020:0F | Modulo tolerance window | Toleranzfenster für Modulopositionierung | UINT32 | RW | 0x00000000 (0dez)
8020:10 | Position lag max. | maximal erlaubter Schrittfehler | UINT16 | RW | 0x0000 (0dez)
Index 8021 POS Features Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
8021:0 | POS Features Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
8021:01 | Start type | erlaubte Werte: | UINT16 | RW | 0x0001 (1dez)
 |  | 0: Idle
 |  | 1: Absolute
 |  | 2: Relative
 |  | 3: Endless plus
 |  | 4: Endless minus
 |  | 6: Additive
 |  | 24832: Calibration (Hardware sync)
 |  | 24576: Calibration (Plc cam)
 |  | 28416: Calibration (Clear manual)
 |  | 28160: Calibration (Set manual)
 |  | 28161: Calibration (Set manual auto)
 |  | 1029: Modulo current
 |  | 773: Modulo minus
 |  | 517: Modulo plus
 |  | 261: Modulo short
8021:11 | Time information | erlaubte Werte: 0: Elapsed time aktuell gefahrene Zeit seit Beginn des Fahrauftrages | BIT2 | RW | 0x00 (0dez)
8021:13 | Invert calibration cam search direction | Invertierung der Drehrichtung auf die Nocke | BOOLEAN | RW | 0x01 (1dez)
8021:14 | Invert sync impulse search direction | Invertierung der Drehrichtung von der Nocke herunter | BOOLEAN | RW | 0x00 (0dez)
8021:15 | Emergency stop on position lag error | löst einen Nothalt bei Überschreitung des max. Schleppfehlers aus | BOOLEAN | RW | 0x00 (0dez)
8021:16 | Enhanced diag history | gibt detailliertere Meldungen zum Status des Positioning Interface in der Diag history aus | BOOLEAN | RW | 0x00 (0dez)
Kommando-Objekt
Index FB00 STM Command
Index | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | STM Command | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Anforderung eines Kommando 0x8000: Software-Reset | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status des Kommandos | UINT8 | RO | 0x00 (0dez)
 |  | 0: kein Fehler, ohne Rückgebewert
 |  | 1: kein Fehler, mit Rückgebewert
 |  | 2: mit Fehler, ohne Rückgebewert
 |  | 3: mit Fehler, mit Rückgebewert
 |  | ... reserviert
 |  | 255: Kommandoausführung aktiv
FB00:03 | Response | Rückgabewert des ausgeführten Kommandos | OCTET-STRING[4] | RO | {0}
Eingangsdaten
Index 6000 ENC Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit der C-Spur gelatched. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch gespeichert. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Der Zustand des A-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Der Zustand des B-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Der Zustand des C-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des Ext. Latch-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Der Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Der Latchwert. | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung. | UINT32 | RO | 0x00000000 (0dez)
Index 6010 STM Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | STM Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
6010:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Ready | Treiberstufe ist Betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Warning | eine Warnung ist aufgetreten (siehe Index A010 | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Error | ein Fehler ist aufgetreten (siehe Index A010) | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Torque reduced | reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6010:08 | Motor stall | ein Schrittverlust ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Digital input 1 | digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Digital input 2 | digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Info data 1 | synchrone Informationen (Auswahl über Subindex 8012:11) | UINT16 | RO | 0x0000 (0dez)
6010:12 | Info data 2 | synchrone Informationen (Auswahl über Subindex 8012:19) | UINT16 | RO | 0x0000 (0dez)
6010:13 | Motor load | aktuelle Belastung des Motors Einheit: 0,01° | INT16 | RO | 0x0000 (0dez)
6010:14 | Internal position | interne Microstep Position | UINT32 | RO | 0x00000000 (0dez)
6010:15 | External position | Encoder Position | UINT32 | RO | 0x00000000 (0dez)
Index 6020 POS Inputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | POS Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x23 (35dez)
6020:01 | Busy | ein aktueller Fahrauftrag ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6020:02 | In-Target | Motor ist im Ziel angekommen | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Error | eine Fehler ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Calibrated | Motor ist kalibriert | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Accelerate | Motor ist in der Beschleunigungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Decelerate | Motor ist in der Verzögerungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:08 | Ready to execute | Bereit für Fahrauftrag | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Actual position | aktuelle Sollposition des Fahrauftraggenerators | UINT32 | RO | 0x00000000 (0dez)
6020:21 | Actual velocity | aktuelle Sollgeschwindigkeit des Fahrauftraggenerators | INT16 | RO | 0x0000 (0dez)
6020:22 | Actual drive time | Zeitinformation des Fahrauftrages (siehe Subindex 8021:11) | UINT32 | RO | 0x00000000 (0dez)
6020:23 | Actual position lag | Schleppabstand | INT32 | RO | 0x00000000 (0dez)
Ausgangsdaten
Index 7000 ENC Outputs (compact) Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Latchen über die C-Spur aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Den Zählerstand setzen. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über "Set counter" zu setzende Zählerstand. | UINT16 | RO | 0x0000 (0dez)
Index 7000 ENC Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Latchen über die C-Spur aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Den Zählerstand setzen. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über "Set counter" zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 STM Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | STM Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x21 (33dez)
7010:01 | Enable | aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Reset | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Reduce torque | reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 8010:02) | BOOLEAN | RO | 0x00 (0dez)
7010:0C | Digital output 1 | digitaler Ausgang 1 | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Position | Vorgabe der Sollposition Einheit: Inkremente | UINT32 | RO | 0x00000000 (0dez)
7010:21 | Velocity | Vorgabe der Sollgeschwindigkeit Einheit: +/- 32767 entspricht +/- 100% | INT16 | RO | 0x0000 (0dez)
Index 7020 POS Outputs Ch.1 (Teil1)
Index | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | POS Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
7020:01 | Execute | Fahrauftrag starten (steigende Flanke), bzw. Fahrauftrag vorzeitig abbrechen (fallende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Emergency stop | Fahrauftrag vorzeitig mit einer Notfallrampe abbrechen (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00000000 (0dez)
7020:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7020 POS Outputs Ch.1 (Teil 2)
Index | Name |  | Bedeutung | Datentyp | Flags | Default
7020:22 | Start type
 | 0x0000 Idle: es wird kein Fahrauftrag ausgeführt |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0001 Absolute: Zielposition absolut |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1001 Absolute (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0002 Relative: Zielposition relativ von der aktuellen Position aus |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1002 Relative (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0003 Endless plus: Endlosfahrt in positiver Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0004 Endless minus: Endlosfahrt in negativer Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0105 Modulo short: kürzeste Entfernung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0115 Modulo short extended: kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0205 Modulo plus: Fahrt in positiver Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0215 Modulo plus extended: Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0305 Modulo minus: Fahrt in negativer Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0315 Modulo minus extended: Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0405 Modulo current: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0415 Modulo current extended: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0006 Additive: neue Zielposition relativ / additiv zur letzten Zielposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1006 Additive (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6000 Calibration, PLC cam: Kalibrierung mit Nocke |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6100 Calibration, HW sync: Kalibrierung mit Nocke und C-Spur |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E00 Calibration, set manual: Kalibrierung manuell setzen |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E01 Calibration, set manual auto: Kalibrierung autom. setzen, bei "Enable = 1" |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6F00 Calibration, clear manual: Kalibrierung manuell löschen |  |  | UINT16 | RO | 0x0000 (0dez)
7020:23 | Acceleration | Vorgabe der Beschleunigung |  | UINT16 | RO | 0x0000 (0dez)
7020:24 | Deceleration | Vorgabe der Verzögerung |  | UINT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 1)
Index | Name | Bedeutung | Datentyp | Flags | Default
7021:0 | POS Outputs 2 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dec)
7021:03 | Enable auto start | Auto-Start Funktion aktivieren | BOOL | RO | 0x00000000 (0dez)
7021:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00000000 (0dez)
7021:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 2)
Index | Name |  | Bedeutung | Datentyp | Flags | Default
7021:22 | Start type
 | 0x0000 Idle: es wird kein Fahrauftrag ausgeführt |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0001 Absolute: Zielposition absolut |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1001 Absolute (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0002 Relative: Zielposition relativ von der aktuellen Position aus |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1002 Relative (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0003 Endless plus: Endlosfahrt in positiver Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0004 Endless minus: Endlosfahrt in negativer Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0105 Modulo short: kürzeste Entfernung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0115 Modulo short extended: kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0205 Modulo plus: Fahrt in positiver Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0215 Modulo plus extended: Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0305 Modulo minus: Fahrt in negativer Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0315 Modulo minus extended: Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0405 Modulo current: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0415 Modulo current extended: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0006 Additive: neue Zielposition relativ / additiv zur letzten Zielposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1006 Additive (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6000 Calibration, PLC cam: Kalibrierung mit Nocke |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6100 Calibration, HW sync: Kalibrierung mit Nocke und C-Spur |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E00 Calibration, set manual: Kalibrierung manuell setzen |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E01 Calibration, set manual auto: Kalibrierung autom. setzen, bei "Enable = 1" |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6F00 Calibration, clear manual: Kalibrierung manuell löschen |  |  | UINT16 | RO | 0x0000 (0dez)
7021:23 | Acceleration | Vorgabe der Beschleunigung |  | UINT16 | RO | 0x0000 (0dez)
7021:24 | Deceleration | Vorgabe der Verzögerung |  | UINT16 | RO | 0x0000 (0dez)
Informations-/Diagnosedaten (kanalspezifisch)
Index 9010 STM Info data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | STM Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
9010:01 | Status word | Statuswort (siehe Index A010) | UINT16 | RO | 0x0000 (0dez)
9010:08 | Motor velocity | aktuelle Motorgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
9010:09 | Internal position | interne Position (Mikro-Inkremente) | UINT32 | RO | 0x00000000 (0dez)
9010:0B | Motor load | aktuelle Belastung des Motors Einheit : 0,01° | INT16 | RO | 0x0000 (0dez)
9010:0D | Motor dc current | aktueller Motorstrom (DC-Vektor) Einheit : 1 mA | INT16 | RO | 0x0000 (0dez)
9010:0E | Tn (curr.) | intern berechnete Zeitkonstante des Stromreglers Einheit : 0,01 ms | UINT16 | RO | 0x0000 (0dez)
9010:13 | External position | externe Position (angeschlossener Enkoder) | UINT32 | RO | 0x00000000 (0dez)
Index 9020 POS Info data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
9020:0 | POS Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
9020:01 | Status word | Statuswort | UINT16 | RO | 0x0000 (0dez)
9020:03 | State (drive controller) | erlaubte Werte: | UINT16 | RO | 0x0000 (0dez)
 |  | 0: Init
 |  | 1: Idle
 |  | 272: Go cam
 |  | 273: On cam
 |  | 16: Start
 |  | 17: Acceleration
 |  | 18: Constant
 |  | 19: Decelleration
 |  | 288: Go sync impulse
 |  | 289: Leave cam
 |  | 4096: Pre target
 |  | 4097: In target
 |  | 32: Emergency stop
 |  | 33: Normal stop
 |  | 304: Calibration stop
 |  | 8192: Drive end
 |  | 8193: Wait for init
 |  | 320: Is calibrated
 |  | 321: Not calibrated
 |  | 16384: Drive warning
 |  | 32768: Error
 |  | 65535: Undefined
 |  | 256: Calibration start
9020:04 | Actual position lag | aktueller Schrittfehler | INT32 | RO | 0x00000000 (0dez)
Index A010 STM Diag data Ch.1
Index
Name
Bedeutung
Datentyp
Flags
Default
A010:0
STM Diag data Ch.1
Maximaler Subindex
UINT8
RO
0x11 (17dez)
A010:01
Saturated
Treiberstufe arbeitet mit maximalem Duty-Cycle
BOOLEAN
RO
0x00 (0dez)
A010:02
Over temperature
Innentemperatur der Klemme ist größer als 80 °C
BOOLEAN
RO
0x00 (0dez)
A010:03
Torque overload
DutyCycle-Ausgabe bei 100%
BOOLEAN
RO
0x00 (0dez)
A010:04
Under voltage
Versorgungsspannung kleiner als 7 V
BOOLEAN
RO
0x00 (0dez)
A010:05
Over voltage
Versorgungsspannung 10% größer, als die Nennspannung (siehe 8010:03)
BOOLEAN
RO
0x00 (0dez)
A010:06
Short circuit
Kurzschluss einer Motorspule
BOOLEAN
RO
0x00 (0dez)
A010:08
No control power
Treiberstufe ohne Spannungsversorgung
BOOLEAN
RO
0x00 (0dez)
A010:09
Misc error
▪
Initialisierung fehlgeschlagen oder
▪
Innentemperatur der Klemme ist größer als 100 °C (siehe F80F:05)
BOOLEAN
RO
0x00 (0dez)
A010:0A
Configuration
CoE-Änderung wurde noch nicht in aktueller Konfiguration übernommen
BOOLEAN
RO
0x00 (0dez)
A010:0B
Motor stall
ein Schrittverlust ist aufgetreten
BOOLEAN
RO
0x00 (0dez)
A010:0C
Open load A
BOOLEAN
RO
0x00 (0dez)
A010:0D
Open load B
BOOLEAN
RO
0x00 (0dez)
A010:11
Actual operation mode
erlaubte Werte:
BIT4
RO
0x00 (0dez)
0: Automatic
1: Velocity direct
2: Velocity controller
3: Position controller
4: Ext. Velocity mode
5: Ext. Position mode
6: Velocity sensorless
Index A020 POS Diag data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
A020:0 | POS Diag data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
A020:01 | Command rejected | Fahrauftrag wurde abgewiesen | BOOLEAN | RO | 0x00 (0dez)
A020:02 | Command aborted | Fahrauftrag wurde abgebrochen | BOOLEAN | RO | 0x00 (0dez)
A020:03 | Target overrun | Zielposition wurde in entgegengesetzter Richtung überfahren | BOOLEAN | RO | 0x00 (0dez)
A020:04 | Target timeout | das Zielfenster wurde innerhalb des In-Target timeouts nicht erreicht | BOOLEAN | RO | 0x00 (0dez)
A020:05 | Position lag | der max. Schleppfehler wurde überschritten | BOOLEAN | RO | 0x00 (0dez)
A020:06 | Emergency stop | ein Nothalt wurde ausgelöst (automatisch oder manuell) | BOOLEAN | RO | 0x00 (0dez)
Hersteller-Konfigurationsdaten (gerätespezifisch)
Index F80F STM Vendor data
Index | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | STM Vendor data | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung Einheit : 1 °C | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur Einheit : 1 °C | INT8 | RW | 0x64 (100dez)
Informations-/Diagnosedaten (gerätespezifisch)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | Profilnummer Encoder Profile | UINT32 | RW | 0x000001FF (511dez)
F010:02 | SubIndex 002 | Profilnummer Stepper Motor Profile | UINT32 | RW | 0x000002BF (703dez)
F010:03 | SubIndex 003 | Profilnummer Positioning Interface Profile | UINT32 | RW | 0x000002C0 (704dez)
Index F081 Download revision
Index | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Revisionsnummer | UINT32 | RW | 0x00000000 (0dez)
Index F900 STM Info data
Index | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | STM Info data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Software Version des Ausgangstreibers | STRING | RO |
F900:02 | Internal temperature | interne Klemmentemperatur Einheit : 1 °C | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage | Steuerspannung Einheit : 1 mV, bei feldorientierten Regelungen 10 mV | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage | Versorgungsspannung des Motors Einheit : 1 mV, bei feldorientierten Regelungen 10 mV | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time | aktuelle EtherCAT-Zykluszeit Einheit : 1 µs | UINT16 | RO | 0x0000 (0dez)
Index FB40 Memory interface
Index | Name | Bedeutung | Datentyp | Flags | Default
FB40:0 | Memory interface | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB40:01 | Address | reserviert | UINT32 | RW | 0x00000000 (0dez)
FB40:02 | Length | reserviert | UINT16 | RW | 0x0000 (0dez)
FB40:03 | Data | reserviert | OCTET-STRING[8] | RW | {0}


Objektbeschreibung und Parametrierung - Standardobjekte

Konfiguration mit dem TwinCAT System Manager [image] EL7037 [image] Objektbeschreibung und Parametrierung - Standardobjekte
Objektbeschreibung und Parametrierung - Standardobjekte
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Standardobjekte (0x1000-0x1FFF)
Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL7037
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1B873052 (461844562dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 1400 ENC RxPDO-Par Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1403 STM RxPDO-Par Position
Index | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | STM RxPDO-Par Position | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 STM RxPDO-Par Velocity
Index | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | STM RxPDO-Par Velocity | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 05 16 06 16
Index 1405 POS RxPDO-Par Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | POS RxPDO-Par Control compact | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 06 16
Index 1406 POS RxPDO-Par Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1407 POS RxPDO-Par Control 2
Index | Name | Bedeutung | Datentyp | Flags | Default
1407:0 | POS RxPDO-Par Control 2 | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 8 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1600 ENC RxPDO-Map Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 STM RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | STM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x0C (Digital output 1)) | UINT32 | RO | 0x7010:0C, 1
1602:06 | SubIndex 006 | 6. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
Index 1603 STM RxPDO-Map Position
Index | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | STM RxPDO-Map Position | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7010:11, 32
Index 1604 STM RxPDO-Map Velocity
Index | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | STM RxPDO-Map Velocity | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1605 POS RxPDO-Map Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | POS RxPDO-Map Control compact | PDO Mapping RxPDO 6 | UINT8 | RO | 0x04 (4dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 POS RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 7 | UINT8 | RO | 0x08 (8dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7020:22, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7020:23, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7020:24, 16
Index 1607 POS RxPDO-Map Control 2
Index | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 8 | UINT8 | RO | 0x08 (8dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00,2
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x03 (Enable auto start)) | UINT32 | RO | 0x7021:03, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 13
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7021:11, 32
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7021:21, 16
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7021:22, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7021:23, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7021:24, 16
Index 1800 ENC TxPDO-Par Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 1806 POS TxPDO-Par Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | POS TxPDO-Par Status compact | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[2] | RO | 07 1A
Index 1807 POS TxPDO-Par Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | POS TxPDO-Par Status | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[2] | RO | 06 1A
Index 1A00 ENC TxPDO-Map Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 STM TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | STM TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0E (14dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x08 (Motor stall)) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0C (Digital input 1)) | UINT32 | RO | 0x6010:0C, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0C (Digital input 2)) | UINT32 | RO | 0x6010:0D, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
Index 1A04 STM TxPDO-Map Synchron info data
Index | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | STM TxPDO-Map Synchron info data | PDO Mapping TxPDO 5 | UINT8 | RO | 0x02 (2dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 STM TxPDO-Map Motor load
Index | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | STM TxPDO-Map Motor load | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x13 (Motor load)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 POS TxPDO-Map Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A07 POS TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x0C (12dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A07:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6020:11, 32
1A07:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6020:21, 16
1A07:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6020:22, 32
Index 1A08 STM TxPDO-Map Internal position
Index | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | STM TxPDO-Map Internal position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x14 (Internal position)) | UINT32 | RO | 0x6010:14, 32
Index 1A09 STM TxPDO-Map External position
Index | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | STM TxPDO-Map External position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x15 (External position)) | UINT32 | RO | 0x6010:15, 32
Index 1A0A POS TxPDO-Map Actual position lag
Index | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | POS TxPDO-Map Actual position lag | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x23 (Actual position lag)) | UINT32 | RO | 0x6020:23, 32
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
.. | .. | .. | .. | .. | ..
1C13:09 | Subindex 009 | -- | -- | -- | --
Index 1C32 SM output parameter (Teil 1)
Index
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0x0C07 (3079dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Min. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C32 SM output parameter (Teil 2)
Index
Name
Bedeutung
Datentyp
Flags
Default
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:14
Frame repeat time
UINT32
RW
0x00000000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter (Teil 1)
Index
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
UINT16
RO
0x0C07 (3079dez)
1C33:05
Minimum cycle time
wie 1C32:05
UINT32
RO
0x0003D090 (250000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
Min. Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C33 SM input parameter (Teil 2)
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:14 | Frame repeat time | wie 1C32:14 | UINT32 | RW | 0x00000000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | siehe Hinweis! | UINT32 | RW | 0x00000000 (0dez)
Sehen Sie dazu auch
•
Objektbeschreibung und Parametrierung - Standardobjekte


EL7047

Konfiguration mit dem TwinCAT System Manager [image] EL7047
EL7047
Weiterführende Informationen
•
Objektbeschreibung und Parametrierung - Profilspezifische Objekte
•
Objektbeschreibung und Parametrierung - Standardobjekte


Objektbeschreibung und Parametrierung - Profilspezifische Objekte

Konfiguration mit dem TwinCAT System Manager [image] EL7047 [image] Objektbeschreibung und Parametrierung - Profilspezifische Objekte
Objektbeschreibung und Parametrierung - Profilspezifische Objekte
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Hinweis
Beschädigung des Gerätes möglich!
Es wird dringend davon abgeraten, die Einstellungen in den CoE-Objekten zu ändern während die Achse aktiv ist, da die Reglung beeinträchtigt werden könnte.
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
Objektübersicht
• Restore-Objekt
• Konfigurationsdaten
• Kommando-Objekt
• Eingangsdaten
• Ausgangsdaten
• Informations-/Diagnosedaten (kanalspezifisch)
• Hersteller-Konfigurationsdaten (gerätespezifisch)
• Informations-/Diagnosedaten (gerätespezifisch)
• Standardobjekte
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Konfigurationsdaten
Index 8000 ENC Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
8000:08 | Disable filter | Deaktiviert die Eingangsfilter. | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable micro increments | Die unteren 8 Bit des Zählerstandes werden extrapoliert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr des Enkoders. | BOOLEAN | RW | 0x00 (0dez)
Index 8010 STM Motor Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | STM Motor Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
8010:01 | Maximal current | maximaler, dauerhafter Spulenstrom des Motors Einheit : 1 mA | UINT16 | RW | 0x1388 (5000dez)
8010:02 | Reduced current | reduzierter Spulenstrom Einheit : 1 mA | UINT16 | RW | 0x09C4 (2500dez)
8010:03 | Nominal voltage | Nennspannung (Versorgungsspannung) des Motors Einheit : 10 mV | UINT16 | RW | 0x1388 (5000dez)
8010:04 | Motor coil resistance | Innenwiderstand des Motors Einheit : 10 mOhm | UINT16 | RW | 0x0064 (100dez)
8010:05 | Motor EMF | Gegenspannung des Motors Einheit : 1 mV / (rad/s) | UINT16 | RW | 0x0000 (0dez)
8010:06 | Motor fullsteps | Anzahl der Vollschritte des Motors | UINT16 | RW | 0x00C8 (200dez)
8010:07 | Encoder increments (4-fold) | Anzahl der Enkoder-Inkremente pro Umdrehung bei 4-fach Auswertung | UINT16 | RW | 0x1000 (4096dez)
8010:09 | Start velocity | minimale Startgeschwindigkeit des Motors Einheit: 10000 entspricht 100% | UINT16 | RW | 0x0000 (0dez)
8010:0A | Motor coil inductance | Induktivität des Motors Einheit: 0,01 mH | UINT16 | RW | 0x0000 (0dez)
8010:10 | Drive on delay time | Verzögerung zwischen Aktivierung der Treiberstufe und Ready = 1 Einheit: 1 ms | UINT16 | RW | 0x0064 (100dez)
8010:11 | Drive off delay time | Verzögerung zwischen Ready = 0 und Deaktivierung der Treiberstufe Einheit: 1 ms | UINT16 | RW | 0x0096 (150dez)
Index 8011 STM Controller Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8011:0 | STM Controller Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
8011:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x0096 (150dez)
8011:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x000A (10dez)
Index 8012 STM Features Ch.1 (Teil 1)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8012:0 | STM Features Ch.1 | Maximaler Subindex | UINT8 | RO | 0x3A (58dez)
8012:01 | Operation mode | erlaubte Werte: | BIT4 | RW | 0x00 (0dez)
 |  | 0: Automatic
 |  | 1: Velocity direct
 |  | 3: Position controller
 |  | 4: Ext. Velocity mode
 |  | 5: Ext. Position mode
 |  | 6: Velocity sensorless
8012:05 | Speed range | erlaubte Werte: | BIT3 | RW | 0x01 (1dez)
 |  | 0: 1000 Fullsteps/sec
 |  | 1: 2000 Fullsteps/sec
 |  | 2: 4000 Fullsteps/sec
 |  | 3: 8000 Fullsteps/sec
 |  | 4: 16000 Fullsteps/sec
 |  | 5: 32000 Fullsteps/sec
8012:08 | Feedback type | erlaubte Werte: | BIT1 | RW | 0x01 (1dez)
 |  | 0: Encoder
 |  | 1: internal counter
8012:09 | Invert motor polarity | Drehrichtung des Motors invertieren | BOOLEAN | RW | 0x00 (0dez)
8012:0A | Error on step lost | Fehler bei Schrittverlust | BOOLEAN | RW | 0x00 (0dez)
8012:11 | Select info data 1 | erlaubte Werte: | UINT8 | RW | 0x0B (11dez)
 |  | 0: Status word
 |  | 7: Motor velocity
 |  | 11: Motor load
 |  | 13: Motor dc current
 |  | 101: Internal temperature
 |  | 103: Control voltage
 |  | 104: Motor supply voltage
 |  | 150: Drive - Status word
 |  | 151: Drive - State
 |  | 152: Drive - Position lag (low word)
 |  | 153: Drive - Position lag (high word)
Index 8012 STM Features Ch.1 (Teil 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8012:19 | Select info data 2 | erlaubte Werte: | UINT8 | RW | 0x0D (13dez)
 |  | 0: Status word
 |  | 7: Motor velocity
 |  | 11: Motor load
 |  | 13: Motor dc current
 |  | 101: Internal temperature
 |  | 103: Control voltage
 |  | 104: Motor supply voltage
 |  | 150: Drive - Status word
 |  | 151: Drive - State
 |  | 152: Drive - Position lag (low word)
 |  | 153: Drive - Position lag (high word)
8012:30 | Invert digital input 1 | Digitalen Eingang invertieren | BOOLEAN | RW | 0x00 (0dez)
8012:31 | Invert digital input 2 | Digitalen Eingang invertieren | BOOLEAN | RW | 0x00 (0dez)
8012:32 | Function for input 1 | erlaubte Werte: | BIT4 | RW | 0x00 (0dez)
 |  | 0: Normal input
 |  | 1: Hardware enable
 |  | 2: PLC cam
8012:36 | Function for input 2 | erlaubte Werte: | BIT4 | RW | 0x00 (0dez)
 |  | 0: Normal input
 |  | 1: Hardware enable
 |  | 2: PLC cam
8012:3A | Function for output 1 | erlaubte Werte: | BIT4 | RW | 0x0F (15dez)
 |  | 0: Normal output
 |  | 1: Break (linked with driver enable)
 |  | 15: Disabled
Index 8014 STM Controller Settings 3 Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8014:0 | STM Controller Settings 3 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x09 (9dez)
8014:01 | Feed forward (pos.) | Vorsteuerung des Positionsreglers | UINT32 | RW | 0x000186A0 (100000dez)
8014:02 | Kp factor (pos.) | Kp-Regelfaktor des Positionsreglers | UINT16 | RW | 0x01F4 (500dez)
8014:03 | Kp factor (velo.) | Kp-Regelfaktor des Geschwindigkeitsreglers Einheit : 0,1 mA/(rad/s) | UINT32 | RW | 0x00000032 (50dez)
8014:04 | Tn (velo.) | Zeitkonstante Tn des Geschwindigkeitsreglers Einheit : 0,01 ms | UINT16 | RW | 0xC350 (50000dez)
8014:05 | Sensorless param 1 | 1. Parameter (sensorlosen Regelung) | UINT16 | RW | 0x0000 (0dez)
8014:06 | Sensorless param 2 | 2. Parameter (sensorlosen Regelung) | UINT16 | RW | 0x0000 (0dez)
8014:07 | Cross over velocity 1 | 1. Geschwindigkeitsübergang (sensorlosen Regelung) Einheit : 0,1 rad/s | UINT16 | RW | 0x0000 (0dez)
8014:08 | Cross over velocity 2 | 2. Geschwindigkeitsübergang (sensorlosen Regelung) Einheit : 0,1 rad/s | UINT16 | RW | 0x0000 (0dez)
8014:09 | Cross over velocity 3 | 3. Geschwindigkeitsübergang (sensorlosen Regelung) Einheit : 0,1 rad/s | UINT16 | RW | 0x0000 (0dez)
Index 8020 POS Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8020:0 | POS Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x10 (16dez)
8020:01 | Velocity min. | minimale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8020:02 | Velocity max. | maximale Sollgeschwindigkeit (Bereich: 0-10000) | INT16 | RW | 0x2710 (10000dez)
8020:03 | Acceleration pos. | Beschleunigung in positiver Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:04 | Acceleration neg. | Beschleunigung in negativer Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:05 | Deceleration pos. | Verzögerung in positiver Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:06 | Deceleration neg. | Verzögerung in negativer Drehrichtung Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:07 | Emergency deceleration | Notfallverzögerung (beide Drehrichtungen) Einheit : 1 ms | UINT16 | RW | 0x0064 (100dez)
8020:08 | Calibration position | Kalibrierposition | UINT32 | RW | 0x00000000 (0dez)
8020:09 | Calibration velocity (towards plc cam) | Kalibriergeschwindigkeit auf die Nocke (Bereich: 0-10000) | INT16 | RW | 0x0064 (100dez)
8020:0A | Calibration Velocity (off plc cam) | Kalibriergeschwindigkeit von der Nocke herunter (Bereich: 0-10000) | INT16 | RW | 0x000A (10dez)
8020:0B | Target window | Zielfenster | UINT16 | RW | 0x000A (10dez)
8020:0C | In-Target timeout | Zielpositions-Timeout Einheit : 1 ms | UINT16 | RW | 0x03E8 (1000dez)
8020:0D | Dead time compensation | Totzeitkompensation Einheit : 1 µs | INT16 | RW | 0x0032 (50dez)
8020:0E | Modulo factor | Modulofaktor/-position | UINT32 | RW | 0x00000000 (0dez)
8020:0F | Modulo tolerance window | Toleranzfenster für Modulopositionierung | UINT32 | RW | 0x00000000 (0dez)
8020:10 | Position lag max. | maximal erlaubter Schrittfehler | UINT16 | RW | 0x0000 (0dez)
Index 8021 POS Features Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8021:0 | POS Features Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
8021:01 | Start type | erlaubte Werte: | UINT16 | RW | 0x0001 (1dez)
 |  | 0: Idle
 |  | 1: Absolute
 |  | 2: Relative
 |  | 3: Endless plus
 |  | 4: Endless minus
 |  | 6: Additive
 |  | 24832: Calibration (Hardware sync)
 |  | 24576: Calibration (Plc cam)
 |  | 28416: Calibration (Clear manual)
 |  | 28160: Calibration (Set manual)
 |  | 28161: Calibration (Set manual auto)
 |  | 1029: Modulo current
 |  | 773: Modulo minus
 |  | 517: Modulo plus
 |  | 261: Modulo short
8021:11 | Time information | erlaubte Werte: 0: Elapsed time aktuell gefahrene Zeit seit Beginn des Fahrauftrages | BIT2 | RW | 0x00 (0dez)
8021:13 | Invert calibration cam search direction | Invertierung der Drehrichtung auf die Nocke | BOOLEAN | RW | 0x01 (1dez)
8021:14 | Invert sync impulse search direction | Invertierung der Drehrichtung von der Nocke herunter | BOOLEAN | RW | 0x00 (0dez)
8021:15 | Emergency stop on position lag error | löst einen Nothalt bei Überschreitung des max. Schleppfehlers aus | BOOLEAN | RW | 0x00 (0dez)
8021:16 | Enhanced diag history | gibt detailliertere Meldungen zum Status des Positioning Interface in der Diag history aus | BOOLEAN | RW | 0x00 (0dez)
Kommando-Objekt
Index FB00 STM Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | STM Command | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Anforderung eines Kommandos 0x8000: Software-Reset | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status des Kommandos | UINT8 | RO | 0x00 (0dez)
 |  | 0: kein Fehler, ohne Rückgebewert
 |  | 1: kein Fehler, mit Rückgebewert
 |  | 2: mit Fehler, ohne Rückgebewert
 |  | 3: mit Fehler, mit Rückgebewert
 |  | ... reserviert
 |  | 255: Kommandoausführung aktiv
FB00:03 | Response | Rückgabewert des ausgeführten Kommandos | OCTET-STRING[4] | RO | {0}
Eingangsdaten
Index 6000 ENC Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit der C-Spur gelatched. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch gespeichert. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:05 | Counter overflow | Der Zähler ist übergelaufen. | BOOLEAN | RO | 0x00 (0dez)
6000:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Der Zustand des A-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Der Zustand des B-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Der Zustand des C-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des Ext. Latch-Eingangs. | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Der Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Der Latchwert. | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung. | UINT32 | RO | 0x00000000 (0dez)
Index 6010 STM Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | STM Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
6010:01 | Ready to enable | Treiberstufe ist bereit zum Freischalten | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Ready | Treiberstufe ist Betriebsbereit | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Warning | eine Warnung ist aufgetreten (siehe Index 0xA010 | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Error | ein Fehler ist aufgetreten (siehe Index 0xA010) | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Moving positive | Treiberstufe wird in positiver Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Moving negative | Treiberstufe wird in negativer Richtung angesteuert | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Torque reduced | reduziertes Drehmoment ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6010:08 | Motor stall | ein Schrittverlust ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Digital input 1 | digitaler Eingang 1 | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Digital input 2 | digitaler Eingang 2 | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO upgedatet wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Info data 1 | synchrone Informationen (Auswahl über Subindex 0x8012:11) | UINT16 | RO | 0x0000 (0dez)
6010:12 | Info data 2 | synchrone Informationen (Auswahl über Subindex 0x8012:19) | UINT16 | RO | 0x0000 (0dez)
6010:13 | Motor load | aktuelle Belastung des Motors Einheit: 0,01° | INT16 | RO | 0x0000 (0dez)
6010:14 | Internal position | interne Microstep Position | UINT32 | RO | 0x00000000 (0dez)
6010:15 | External position | Encoder Position | UINT32 | RO | 0x00000000 (0dez)
Index 6020 POS Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | POS Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x22 (34dez)
6020:01 | Busy | ein aktueller Fahrauftrag ist aktiv | BOOLEAN | RO | 0x00 (0dez)
6020:02 | In-Target | Motor ist im Ziel angekommen | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Warning | eine Warnung ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Error | eine Fehler ist aufgetreten | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Calibrated | Motor ist kalibriert | BOOLEAN | RO | 0x00 (0dez)
6020:06 | Accelerate | Motor ist in der Beschleunigungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:07 | Decelerate | Motor ist in der Verzögerungsphase | BOOLEAN | RO | 0x00 (0dez)
6020:08 | Ready to execute | Bereit für Fahrauftrag | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Actual position | aktuelle Sollposition des Fahrauftraggenerators | UINT32 | RO | 0x00000000 (0dez)
6020:21 | Actual velocity | aktuelle Sollgeschwindigkeit des Fahrauftraggenerators | INT16 | RO | 0x0000 (0dez)
6020:22 | Actual drive time | Zeitinformation des Fahrauftrages (siehe Subindex 0x8021:11) | UINT32 | RO | 0x00000000 (0dez)
6020:23 | Actual position lag | Schleppabstand | INT32 | RO | 0x00000000 (0dez)
Ausgangsdaten
Index 7000 ENC Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Latchen über die C-Spur aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Den Zählerstand setzen. | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Dies ist der über "Set counter" zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 STM Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | STM Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x21 (33dez)
7010:01 | Enable | aktiviert die Ausgangsstufe | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Reset | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Reduce torque | reduziertes Drehmoment (Spulenstrom) ist aktiv (siehe Subindex 0x8010:02) | BOOLEAN | RO | 0x00 (0dez)
7010:0C | Digital output 1 | digitaler Ausgang 1 | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Position | Vorgabe der Sollposition Einheit: Inkremente | UINT32 | RO | 0x00000000 (0dez)
7010:21 | Velocity | Vorgabe der Sollgeschwindigkeit Einheit: +/- 32767 entspricht +/- 100% | INT16 | RO | 0x0000 (0dez)
Index 7020 POS Outputs Ch.1 (Teil1)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | POS Outputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dez)
7020:01 | Execute | Fahrauftrag starten (steigende Flanke), bzw. Fahrauftrag vorzeitig abbrechen (fallende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:02 | Emergency stop | Fahrauftrag vorzeitig mit einer Notfallrampe abbrechen (steigende Flanke) | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00000000 (0dez)
7020:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7020 POS Outputs Ch.1 (Teil 2)
Index (hex) | Name |  | Bedeutung | Datentyp | Flags | Default
7020:22 | Start type
 | 0x0000 Idle: es wird kein Fahrauftrag ausgeführt |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0001 Absolute: Zielposition absolut |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1001 Absolute (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0002 Relative: Zielposition relativ von der aktuellen Position aus |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1002 Relative (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0003 Endless plus: Endlosfahrt in positiver Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0004 Endless minus: Endlosfahrt in negativer Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0105 Modulo short: kürzeste Entfernung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0115 Modulo short extended: kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0205 Modulo plus: Fahrt in positiver Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0215 Modulo plus extended: Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0305 Modulo minus: Fahrt in negativer Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0315 Modulo minus extended: Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0405 Modulo current: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0415 Modulo current extended: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0006 Additive: neue Zielposition relativ / additiv zur letzten Zielposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1006 Additive (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6000 Calibration, PLC cam: Kalibrierung mit Nocke |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6100 Calibration, HW sync: Kalibrierung mit Nocke und C-Spur |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E00 Calibration, set manual: Kalibrierung manuell setzen |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E01 Calibration, set manual auto: Kalibrierung autom. setzen, bei "Enable = 1" |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6F00 Calibration, clear manual: Kalibrierung manuell löschen |  |  | UINT16 | RO | 0x0000 (0dez)
7020:23 | Acceleration | Vorgabe der Beschleunigung |  | UINT16 | RO | 0x0000 (0dez)
7020:24 | Deceleration | Vorgabe der Verzögerung |  | UINT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 1)
Index | Name | Bedeutung | Datentyp | Flags | Default
7021:0 | POS Outputs 2 Ch.1 | Maximaler Subindex | UINT8 | RO | 0x24 (36dec)
7021:03 | Enable auto start | Auto-Start Funktion aktivieren | BOOL | RO | 0x00000000 (0dez)
7021:11 | Target position | Vorgabe der Zielposition | UINT32 | RO | 0x00000000 (0dez)
7021:21 | Velocity | Vorgabe der maximalen Sollgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
Index 7021 POS Outputs 2 Ch.1 (Teil 2)
Index | Name |  | Bedeutung | Datentyp | Flags | Default
7021:22 | Start type
 | 0x0000 Idle: es wird kein Fahrauftrag ausgeführt |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0001 Absolute: Zielposition absolut |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1001 Absolute (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0002 Relative: Zielposition relativ von der aktuellen Position aus |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1002 Relative (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0003 Endless plus: Endlosfahrt in positiver Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0004 Endless minus: Endlosfahrt in negativer Drehrichtung |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0105 Modulo short: kürzeste Entfernung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0115 Modulo short extended: kürzeste Entfernung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0205 Modulo plus: Fahrt in positiver Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0215 Modulo plus extended: Fahrt in positiver Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0305 Modulo minus: Fahrt in negativer Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0315 Modulo minus extended: Fahrt in negativer Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0405 Modulo current: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0415 Modulo current extended: Fahrt in die letzte ausgeführte Drehrichtung zur nächsten Moduloposition (ohne Modulofenster) |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x0006 Additive: neue Zielposition relativ / additiv zur letzten Zielposition |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x1006 Additive (Change): Änderung während eines aktiven Fahrauftrages |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6000 Calibration, PLC cam: Kalibrierung mit Nocke |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6100 Calibration, HW sync: Kalibrierung mit Nocke und C-Spur |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E00 Calibration, set manual: Kalibrierung manuell setzen |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6E01 Calibration, set manual auto: Kalibrierung autom. setzen, bei "Enable = 1" |  |  | UINT16 | RO | 0x0000 (0dez)
 | 0x6F00 Calibration, clear manual: Kalibrierung manuell löschen |  |  | UINT16 | RO | 0x0000 (0dez)
7021:23 | Acceleration | Vorgabe der Beschleunigung |  | UINT16 | RO | 0x0000 (0dez)
7021:24 | Deceleration | Vorgabe der Verzögerung |  | UINT16 | RO | 0x0000 (0dez)
Informations-/Diagnosedaten (kanalspezifisch)
Index 9010 STM Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | STM Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x13 (19dez)
9010:01 | Status word | Statuswort (siehe Index 0xA010) | UINT16 | RO | 0x0000 (0dez)
9010:08 | Motor velocity | aktuelle Motorgeschwindigkeit | INT16 | RO | 0x0000 (0dez)
9010:09 | Internal position | interne Position (Mikro-Inkremente) | UINT32 | RO | 0x00000000 (0dez)
9010:0B | Motor load | aktuelle Belastung des Motors Einheit : 0,01° | INT16 | RO | 0x0000 (0dez)
9010:0D | Motor dc current | aktueller Motorstrom (DC-Vektor) Einheit : 1 mA | INT16 | RO | 0x0000 (0dez)
9010:0E | Tn (curr.) | intern berechnete Zeitkonstante des Stromreglers Einheit : 0,01 ms | UINT16 | RO | 0x0000 (0dez)
9010:13 | External position | externe Position (angeschlossener Enkoder) | UINT32 | RO | 0x00000000 (0dez)
Index 9020 POS Info data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9020:0 | POS Info data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
9020:01 | Status word | Statuswort | UINT16 | RO | 0x0000 (0dez)
9020:03 | State (drive controller) | erlaubte Werte: | UINT16 | RO | 0x0000 (0dez)
 |  | 0: Init
 |  | 1: Idle
 |  | 272: Go cam
 |  | 273: On cam
 |  | 16: Start
 |  | 17: Acceleration
 |  | 18: Constant
 |  | 19: Decelleration
 |  | 288: Go sync impulse
 |  | 289: Leave cam
 |  | 4096: Pre target
 |  | 4097: In target
 |  | 32: Emergency stop
 |  | 33: Normal stop
 |  | 304: Calibration stop
 |  | 8192: Drive end
 |  | 8193: Wait for init
 |  | 320: Is calibrated
 |  | 321: Not calibrated
 |  | 16384: Drive warning
 |  | 32768: Error
 |  | 65535: Undefined
 |  | 256: Calibration start
9020:04 | Actual position lag | aktueller Schrittfehler | INT32 | RO | 0x00000000 (0dez)
Index A010 STM Diag data Ch.1
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
A010:0
STM Diag data Ch.1
Maximaler Subindex
UINT8
RO
0x11 (17dez)
A010:01
Saturated
Treiberstufe arbeitet mit maximalem Duty-Cycle
BOOLEAN
RO
0x00 (0dez)
A010:02
Over temperature
Innentemperatur der Klemme ist größer als 80 °C
BOOLEAN
RO
0x00 (0dez)
A010:03
Torque overload
DutyCycle-Ausgabe bei 100%
BOOLEAN
RO
0x00 (0dez)
A010:04
Under voltage
Versorgungsspannung kleiner als 7 V
BOOLEAN
RO
0x00 (0dez)
A010:05
Over voltage
Versorgungsspannung 10% größer, als die Nennspannung (siehe 0x8010:03)
BOOLEAN
RO
0x00 (0dez)
A010:06
Short circuit
Kurzschluss einer Motorspule
BOOLEAN
RO
0x00 (0dez)
A010:08
No control power
Treiberstufe ohne Spannungsversorgung
BOOLEAN
RO
0x00 (0dez)
A010:09
Misc error
▪
Initialisierung fehlgeschlagen oder
▪
Innentemperatur der Klemme ist größer als 100 °C (siehe 0xF80F:05)
BOOLEAN
RO
0x00 (0dez)
A010:0A
Configuration
CoE-Änderung wurde noch nicht in aktueller Konfiguration übernommen
BOOLEAN
RO
0x00 (0dez)
A010:0B
Motor stall
ein Schrittverlust ist aufgetreten
BOOLEAN
RO
0x00 (0dez)
A010:0C
Open load A
BOOLEAN
RO
0x00 (0dez)
A010:0D
Open load B
BOOLEAN
RO
0x00 (0dez)
A010:11
Actual operation mode
erlaubte Werte:
BIT4
RO
0x00 (0dez)
0: Automatic
1: Velocity direct
2: Velocity controller
3: Position controller
4: Ext. Velocity mode
5: Ext. Position mode
6: Velocity sensorless
Index A020 POS Diag data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A020:0 | POS Diag data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
A020:01 | Command rejected | Fahrauftrag wurde abgewiesen. | BOOLEAN | RO | 0x00 (0dez)
A020:02 | Command aborted | Fahrauftrag wurde abgebrochen. | BOOLEAN | RO | 0x00 (0dez)
A020:03 | Target overrun | Zielposition wurde in entgegengesetzter Richtung überfahren. | BOOLEAN | RO | 0x00 (0dez)
A020:04 | Target timeout | Das Zielfenster wurde innerhalb des In-Target timeouts nicht erreicht. | BOOLEAN | RO | 0x00 (0dez)
A020:05 | Position lag | Der max. Schleppfehler wurde überschritten. | BOOLEAN | RO | 0x00 (0dez)
A020:06 | Emergency stop | Ein Nothalt wurde ausgelöst (automatisch oder manuell). | BOOLEAN | RO | 0x00 (0dez)
Hersteller-Konfigurationsdaten (gerätespezifisch)
Index F80F STM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | STM Vendor data | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung Einheit : 1 °C | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur Einheit : 1 °C | INT8 | RW | 0x64 (100dez)
Informations-/Diagnosedaten (gerätespezifisch)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | Profilnummer Encoder Profile | UINT32 | RW | 0x000001FF (511dez)
F010:02 | SubIndex 002 | Profilnummer Stepper Motor Profile | UINT32 | RW | 0x000002BF (703dez)
F010:03 | SubIndex 003 | Profilnummer Positioning Interface Profile | UINT32 | RW | 0x000002C0 (704dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Revisionsnummer | UINT32 | RW | 0x00000000 (0dez)
Index F900 STM Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | STM Info data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Software Version des Ausgangstreibers | STRING | RO |
F900:02 | Internal temperature | interne Klemmentemperatur Einheit : 1 °C | INT8 | RO | 0x00 (0dez)
F900:04 | Control voltage | Steuerspannung Einheit : 1 mV, bei feldorientierten Regelungen 10 mV | UINT16 | RO | 0x0000 (0dez)
F900:05 | Motor supply voltage | Versorgungsspannung des Motors Einheit : 1 mV, bei feldorientierten Regelungen 10 mV | UINT16 | RO | 0x0000 (0dez)
F900:06 | Cycle time | aktuelle EtherCAT-Zykluszeit Einheit : 1 µs | UINT16 | RO | 0x0000 (0dez)
Index FB40 Memory interface
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB40:0 | Memory interface | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
FB40:01 | Address | reserviert | UINT32 | RW | 0x00000000 (0dez)
FB40:02 | Length | reserviert | UINT16 | RW | 0x0000 (0dez)
FB40:03 | Data | reserviert | OCTET-STRING[8] | RW | {0}


Objektbeschreibung und Parametrierung - Standardobjekte

Konfiguration mit dem TwinCAT System Manager [image] EL7047 [image] Objektbeschreibung und Parametrierung - Standardobjekte
Objektbeschreibung und Parametrierung - Standardobjekte
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Standardobjekte (0x1000-0x1FFF)
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL7047
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x1B873052 (461844562dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung. | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden. | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:37 | Diagnosis Message 050 | Nachricht 50 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 1400 ENC RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen. | OCTET-STRING[6] | RO | 01 16 00 00 00 00
Index 1401 ENC RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen. | OCTET-STRING[6] | RO | 00 16 00 00 00 00
Index 1403 STM RxPDO-Par Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | STM RxPDO-Par Position | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen. | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 STM RxPDO-Par Velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | STM RxPDO-Par Velocity | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen. | OCTET-STRING[6] | RO | 03 16 05 16 06 16
Index 1405 POS RxPDO-Par Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | POS RxPDO-Par Control compact | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen. | OCTET-STRING[6] | RO | 03 16 04 16 06 16
Index 1406 POS RxPDO-Par Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | POS RxPDO-Par Control | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen. | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1407 POS RxPDO-Par Control 2
Index | Name | Bedeutung | Datentyp | Flags | Default
1407:0 | POS RxPDO-Par Control 2 | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 8 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 04 16 05 16
Index 1600 ENC RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (12 bits align) | UINT32 | RO | 0x0000:00, 12
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (ENC Outputs Ch.1), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1602 STM RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | STM RxPDO-Map Control | PDO Mapping RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x01 (Enable)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x02 (Reset)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x03 (Reduce torque)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x0C (Digital output 1)) | UINT32 | RO | 0x7010:0C, 1
1602:06 | SubIndex 006 | 6. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
Index 1603 STM RxPDO-Map Position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | STM RxPDO-Map Position | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x11 (Position)) | UINT32 | RO | 0x7010:11, 32
Index 1604 STM RxPDO-Map Velocity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | STM RxPDO-Map Velocity | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (STM Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7010:21, 16
Index 1605 POS RxPDO-Map Control compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | POS RxPDO-Map Control compact | PDO Mapping RxPDO 6 | UINT8 | RO | 0x04 (4dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
Index 1606 POS RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 7 | UINT8 | RO | 0x08 (8dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x01 (Execute)) | UINT32 | RO | 0x7020:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x02 (Emergency stop)) | UINT32 | RO | 0x7020:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7020:11, 32
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7020:21, 16
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7020:22, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7020:23, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7020:24, 16
Index 1607 POS RxPDO-Map Control 2
Index | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | POS RxPDO-Map Control | PDO Mapping RxPDO 8 | UINT8 | RO | 0x08 (8dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00,2
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (POS Outputs 2 Ch.1), entry 0x03 (Enable auto start)) | UINT32 | RO | 0x7021:03, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (13 bits align) | UINT32 | RO | 0x0000:00, 13
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x11 (Target position)) | UINT32 | RO | 0x7021:11, 32
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x21 (Velocity)) | UINT32 | RO | 0x7021:21, 16
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x22 (Start type)) | UINT32 | RO | 0x7021:22, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x23 (Acceleration)) | UINT32 | RO | 0x7021:23, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (POS Outputs 2 Ch.1), entry 0x24 (Deceleration)) | UINT32 | RO | 0x7021:24, 16
Index 1800 ENC TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 1801 ENC TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen. | OCTET-STRING[2] | RO | 00 1A
Index 1806 POS TxPDO-Par Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | POS TxPDO-Par Status compact | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen. | OCTET-STRING[2] | RO | 07 1A
Index 1807 POS TxPDO-Par Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | POS TxPDO-Par Status | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen. | OCTET-STRING[2] | RO | 06 1A
Index 1A00 ENC TxPDO-Map Status compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 16
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A01 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6000:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:08, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6000:0E, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (1 bit align) | UINT32 | RO | 0x0000:00, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A02 ENC TxPDO-Map Timest. compact
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs Ch.1), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A03 STM TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | STM TxPDO-Map Status | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0E (14dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x01 (Ready to enable)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x02 (Ready)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x05 (Moving positive)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x06 (Moving negative)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x07 (Torque reduced)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x08 (Motor stall)) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x0E (Sync error)) | UINT32 | RO | 0x6010:0C, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6010:0D, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:0E, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6010:10, 1
Index 1A04 STM TxPDO-Map Synchron info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | STM TxPDO-Map Synchron info data | PDO Mapping TxPDO 5 | UINT8 | RO | 0x02 (2dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6010:11, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6010:12, 16
Index 1A05 STM TxPDO-Map Motor load
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | STM TxPDO-Map Motor load | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x13 (Motor load)) | UINT32 | RO | 0x6010:13, 16
Index 1A06 POS TxPDO-Map Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | POS TxPDO-Map Status compact | PDO Mapping TxPDO 7 | UINT8 | RO | 0x09 (9dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A07 POS TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | POS TxPDO-Map Status | PDO Mapping TxPDO 8 | UINT8 | RO | 0x0C (12dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x01 (Busy)) | UINT32 | RO | 0x6020:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x02 (In-Target)) | UINT32 | RO | 0x6020:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x03 (Warning)) | UINT32 | RO | 0x6020:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x04 (Error)) | UINT32 | RO | 0x6020:04, 1
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x05 (Calibrated)) | UINT32 | RO | 0x6020:05, 1
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x06 (Accelerate)) | UINT32 | RO | 0x6020:06, 1
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x07 (Decelerate)) | UINT32 | RO | 0x6020:07, 1
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x08 (Ready to execute)) | UINT32 | RO | 0x6020:08, 1
1A07:09 | SubIndex 009 | 9. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A07:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x11 (Actual position)) | UINT32 | RO | 0x6020:11, 32
1A07:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x21 (Actual velocity)) | UINT32 | RO | 0x6020:21, 16
1A07:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x22 (Actual drive time)) | UINT32 | RO | 0x6020:22, 32
Index 1A08 STM TxPDO-Map Internal position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | STM TxPDO-Map Internal position | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x14 (Internal position)) | UINT32 | RO | 0x6010:14, 32
Index 1A09 STM TxPDO-Map External position
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | STM TxPDO-Map External position | PDO Mapping TxPDO 10 | UINT8 | RO | 0x01 (1dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (STM Inputs Ch.1), entry 0x15 (External position)) | UINT32 | RO | 0x6010:15, 32
Index 1A0A POS TxPDO-Map Actual position lag
Index | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | POS TxPDO-Map Actual position lag | PDO Mapping TxPDO 11 | UINT8 | RO | 0x01 (1dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (POS Inputs Ch.1), entry 0x23 (Actual position lag)) | UINT32 | RO | 0x6020:23, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter (Teil 1)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x0C07 (3079dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0003D090 (250000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
Min. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C32 SM output parameter (Teil 2)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:07, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt.
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Max. Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:14
Frame repeat time
UINT32
RW
0x00000000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter (Teil 1)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0C07 (3079dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x0003D090 (250000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
Min. Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
Index 1C33 SM input parameter (Teil 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:08 | Command | wie 0x1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Max. Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 0x1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 0x1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 0x1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:14 | Frame repeat time | wie 0x1C32:14 | UINT32 | RW | 0x00000000 (0dez)
1C33:20 | Sync error | wie 0x1C32:32 | BOOLEAN | RO | 0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | siehe Hinweis! | UINT32 | RW | 0x00000000 (0dez)
Sehen Sie dazu auch
•
Objektbeschreibung und Parametrierung - Standardobjekte


Fehlerbehebung

Fehlerbehebung
Fehlerbehebung
Weiterführende Informationen
•
Diagnose - Grundlagen zu Diag Messages
•
Hinweise zu Diag Messages in Verbindung mit Motorklemmen


Diagnose - Grundlagen zu Diag Messages

Fehlerbehebung [image] Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons ist selbsterklärend.
DiagMessages im ADS Logger/Eventlogger
Ab TwinCAT 3.1 build 4022 werden von einer Klemme abgesetzte DiagMessages auch im TwinCAT ADS Logger gezeigt. Da nun IO-übergreifend DiagMessages an einem Ort dargestellt werden, vereinfacht dies die Inbetriebnahme. Außerdem kann die Logger-Ausgabe in eine Datei gespeichert werden – somit stehen die DiagMessages auch langfristig für Analysen zur Verfügung.
Nachrichten in die PLC einlesen
- In Vorbereitung -
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13
Übersicht Text-IDs
Spezifische Text-IDs sind in der Gerätedokumentation aufgeführt.
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x0001 | Information | System | No error | Kein Fehler
0x0002 | Information | System | Communication established | Verbindung aufgebaut
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | Allgemein | Detection of operation mode completed: 0x%X, %d | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein | Cycle time o.k.: %d | Zykluszeit o.k.
0x1157 | Information | Allgemein | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Daten manuell gespeichert
0x1158 | Information | Allgemein | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Daten automatisch gespeichert
0x1159 | Information | Allgemein | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Daten gelöscht
0x117F | Information | Allgemein | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde
0x1300 | Information | Encoder | Position set: %d, %d | Position gesetzt - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder Netzteil OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder Initialisierung erfolgreich abgeschlossen
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Sende Kommando Encoder Reset
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Antrieb ist kalibriert
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Aktueller Status des Antriebs
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Prozessorauslastung ist wieder im normalen Bereich
0x1706 | Information |  | Channel is not in saturation anymore | Kanal ist nicht mehr in Sättigung
0x1707 | Information |  | Channel is not in overload anymore | Kanal ist nicht mehr überlastet
0x170A | Information |  | No channel range error anymore | Es liegt kein Messbereichsfehler mehr vor
0x170C | Information |  | Calibration data saved | Abgleichdaten wurden gespeichert
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Abgleichdaten werden erst nach dem Senden des Kommandos „0x5AFE“ übernommen und gespeichert
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Netzwerk Verbindung verloren
0x2002 | Information | System | %s: Network link detected | Netzwerk Verbindung gefunden
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Ungültige IP Konfiguration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Gültige, vom DHCP-Server zugewiesene IP-Konfiguration
0x2005 | Information | System | %s: Dhcp client timed out | Zeitüberschreitung DHCP-Client
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Doppelte IP-Adresse gefunden
0x2007 | Information | System | %s: UDP handler initialized | UDP-Handler initialisiert
0x2008 | Information | System | %s: TCP handler initialized | TCP-Handler initialisiert
0x2009 | Information | System | %s: No more free TCP sockets available | Keine freien TCP Sockets verfügbar
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x4000 | Warnung |  | Warning: 0x%X, 0x%X, 0x%X | allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4001 | Warnung | System | Warning: 0x%X, 0x%X, 0x%X |
0x4002 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful |
0x4003 | Warnung | System | %s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful |
0x4004 | Warnung | System | %s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out |
0x4005 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u) |
0x4006 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4007 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4008 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms) |
0x4101 | Warnung | Allgemein | Terminal-Overtemperature | Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle
0x4102 | Warnung | Allgemein | Discrepancy in the PDO-Configuration | Die ausgewählten PDOs passen nicht zur eingestellten Betriebsart. Beispiel: Antrieb arbeitet im Velocity-Mode. Das Velocity-PDO ist jedoch nicht in die PDOs gemapped.
0x417F | Warnung | Allgemein | Warnung: 0x%X, 0x%X, 0x%X |
0x428D | Warnung | Allgemein | Challenge is not Random |
0x4300 | Warnung | Encoder | Subincrements deactivated: %d, %d | Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301 | Warnung | Encoder | Encoder-Warning | Allgemeiner Encoderfehler
0x4400 | Warnung | Drive | Drive is not calibrated: %d, %d | Antrieb ist nicht kalibriert
0x4401 | Warnung | Drive | Starttype not supported: 0x%X, %d | Starttyp wird nicht unterstützt
0x4402 | Warnung | Drive | Command rejected: %d, %d | Kommando abgewiesen
0x4405 | Warnung | Drive | Invalid modulo subtype: %d, %d | Modulo-Subtyp ungültig
0x4410 | Warnung | Drive | Target overrun: %d, %d | Zielposition wird überfahren
0x4411 | Warnung | Drive | DC-Link undervoltage (Warning) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x4412 | Warnung | Drive | DC-Link overvoltage (Warning) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x4413 | Warnung | Drive | I2T-Model Amplifier overload (Warning) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414 | Warnung | Drive | I2T-Model Motor overload (Warning) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x4415 | Warnung | Drive | Speed limitation active | Die maximale Drehzahl wird durch die parametrierten Objekte (z.B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen
0x4416 | Warnung | Drive | Step lost detected at position: 0x%X%X | Schrittverlust erkannt
0x4417 | Warnung | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Warnschwelle.
0x4418 | Warnung | Drive | Limit: Current | Limit: Strom wird limitiert
0x4419 | Warnung | Drive | Limit: Amplifier I2T-model exceeds 100%% | Die Schwellwerte für den maximalen Strom wurden überschritten.
0x441A | Warnung | Drive | Limit: Motor I2T-model exceeds 100%% | Limit: Motor I2T-Modell übersteigt 100%
0x441B | Warnung | Drive | Limit: Velocity limitation | Die Schwellwerte für die maximale Drehzahl wurden überschritten.
0x441C | Warnung | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x4600 | Warnung | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x4610 | Warnung | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x4705 | Warnung |  | Processor usage at %d %% | Prozessorauslastung bei %d %%
0x470A | Warnung |  | EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time) | EtherCAT Frame verpasst (Einstellungen, DC Operation Mode oder Sync0 Shift Time ändern)
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x8000 | Fehler | System | %s: %s |
0x8001 | Fehler | System | Error: 0x%X, 0x%X, 0x%X | allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002 | Fehler | System | Communication aborded | Kommunikation abgebrochen
0x8003 | Fehler | System | Configuration error: 0x%X, 0x%X, 0x%X | allgemeine, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8004 | Fehler | System | %s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8005 | Fehler | System | %s: FwdClose-Request sent to %d.%d.%d.%d (%s) |
0x8006 | Fehler | System | %s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8007 | Fehler | System | %s: Connection with %d.%d.%d.%d (%s) closed |
0x8100 | Fehler | Allgemein | Status word set: 0x%X, %d | Fehlerbit im Statuswort gesetzt
0x8101 | Fehler | Allgemein | Operation mode incompatible to PDO interface: 0x%X, %d | Betriebsart inkompatibel zum PDO-Interface
0x8102 | Fehler | Allgemein | Invalid combination of Inputs and Outputs PDOs | Ungültige Kombination von In- und Output PDOs
0x8103 | Fehler | Allgemein | No variable linkage | Keine Variablen verknüpft
0x8104 | Fehler | Allgemein | Terminal-Overtemperature | Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden
0x8105 | Fehler | Allgemein | PD-Watchdog | Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt. - Die EtherCAT-Verbindung wurde im Betrieb unterbrochen - Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135 | Fehler | Allgemein | Cycletime has to be a multiple of 125 µs | Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar
0x8136 | Fehler | Allgemein | Configuration error: invalid sampling rate | Konfigurationsfehler: Ungültige Samplingrate
0x8137 | Fehler | Allgemein | Elektronisches Typenschild: CRC-Fehler | Inhalt des Speicher des externen Typenschildes nicht gültig.
0x8140 | Fehler | Allgemein | Sync Error | Echtzeitverletztung
0x8141 | Fehler | Allgemein | Sync%X Interrupt lost | Sync%X Interrupt fehlt
0x8142 | Fehler | Allgemein | Sync Interrupt asynchronous | Sync Interrupt asynchron
0x8143 | Fehler | Allgemein | Jitter too big | Jitter Grenzwertüberschreitung
0x817F | Fehler | Allgemein | Error: 0x%X, 0x%X, 0x%X |
0x8200 | Fehler | Kommunikation | Write access error: %d, %d | Fehler beim Schreiben
0x8201 | Fehler | Kommunikation | No communication to field-side (Auxiliary voltage missing) | - Es ist keine Spannung an den Powerkontakten angelegt - Ein Firmware Update ist fehlgeschlagen
0x8281 | Fehler | Kommunikation | Ownership failed: %X |
0x8282 | Fehler | Kommunikation | To many Keys founded |
0x8283 | Fehler | Kommunikation | Key Creation failed: %X |
0x8284 | Fehler | Kommunikation | Key loading failed |
0x8285 | Fehler | Kommunikation | Reading Public Key failed: %X |
0x8286 | Fehler | Kommunikation | Reading Public EK failed: %X |
0x8287 | Fehler | Kommunikation | Reading PCR Value failed: %X |
0x8288 | Fehler | Kommunikation | Reading Certificate EK failed: %X |
0x8289 | Fehler | Kommunikation | Challenge could not be hashed: %X |
0x828A | Fehler | Kommunikation | Tickstamp Process failed |
0x828B | Fehler | Kommunikation | PCR Process failed: %X |
0x828C | Fehler | Kommunikation | Quote Process failed: %X |
0x82FF | Fehler | Kommunikation | Bootmode not activated | Bootmode nicht aktiviert
0x8300 | Fehler | Encoder | Set position error: 0x%X, %d | Fehler beim Setzen der Position
0x8301 | Fehler | Encoder | Encoder increments not configured: 0x%X, %d | Enkoderinkremente nicht konfiguriert
0x8302 | Fehler | Encoder | Encoder-Error | Die Amplitude des Resolvers ist zu klein
0x8303 | Fehler | Encoder | Encoder supply error | Encoder Netzteil Fehler
0x8304 | Fehler | Encoder | Encoder communication error, channel: %X | Encoder Kommunikationsfehler
0x8305 | Fehler | Encoder | EnDat2.2 is not supported, channel: %X | EnDat2.2 wird nicht unterstützt
0x8306 | Fehler | Encoder | Delay time, tolerance limit exceeded, 0x%X, channel: %X | Laufzeitmessung, Toleranz überschritten
0x8307 | Fehler | Encoder | Delay time, maximum value exceeded, 0x%X, channel: %X | Laufzeitmessung, Maximalwert überschritten
0x8308 | Fehler | Encoder | Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported) | Falsche EnDat Bestellbezeichnung
0x8309 | Fehler | Encoder | Encoder CRC error, channel: %X | Encoder CRC Fehler
0x830A | Fehler | Encoder | Temperature %X could not be read, channel: %X | Temperatu kann nicht gelesen werden
0x8400 | Fehler | Drive | Incorrect drive configuration: 0x%X, %d | Antrieb fehlerhaft konfiguriert
0x8401 | Fehler | Drive | Limiting of calibration velocity: %d, %d | Begrenzung der Kalibrier-Geschwindigkeit
0x8402 | Fehler | Drive | Emergency stop activated: 0x%X, %d | Emergency-Stop aktiviert
0x8403 | Fehler | Drive | ADC Error | Fehler bei Strommessung im ADC
0x8404 | Fehler | Drive | Overcurrent | Überstrom Phase U, V, oder W
0x8405 | Fehler | Drive | Invalid modulo position: %d | Modulo-Position ungültig
0x8406 | Fehler | Drive | DC-Link undervoltage (Error) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x8407 | Fehler | Drive | DC-Link overvoltage (Error) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x8408 | Fehler | Drive | I2T-Model Amplifier overload (Error) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409 | Fehler | Drive | I2T-Model motor overload (Error) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x840A | Fehler | Drive | Overall current threshold exceeded | Summenstrom überschritten
0x8415 | Fehler | Drive | Invalid modulo factor: %d | Modulo-Faktor ungültig
0x8416 | Fehler | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Fehlerschwelle. Der Motor bleibt sofort stehen. Das Aktivieren der Endstufe wird unterbunden.
0x8417 | Fehler | Drive | Maximum rotating field velocity exceeded | Drehfeldgeschwindigkeit übersteigt den von Dual Use (EU 1382/2014) vorgeschriebenen Wert.
0x841C | Fehler | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x8550 | Fehler | Inputs | Zero crossing phase %X missing | Nulldurchgang Phase %X fehlt
0x8551 | Fehler | Inputs | Phase sequence Error | Drehrichtung Falsch
0x8552 | Fehler | Inputs | Overcurrent phase %X | Überstrom Phase %X
0x8553 | Fehler | Inputs | Overcurrent neutral wire | Überstrom Neutralleiter
0x8581 | Fehler | Inputs | Wire broken Ch %D | Leitungsbruch Ch %d
0x8600 | Fehler | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x8601 | Fehler | Allgemein IO | Supply voltage to low | Versorgungsspannung zu klein
0x8602 | Fehler | Allgemein IO | Supply voltage to high | Versorgungsspannung zu groß
0x8603 | Fehler | Allgemein IO | Over current of supply voltage | Überstrom der Versorgungsspannung
0x8610 | Fehler | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x8611 | Fehler | Allgemein IO | Output voltage to low | Ausgangsspannung zu klein
0x8612 | Fehler | Allgemein IO | Output voltage to high | Ausgangsspannung zu groß
0x8613 | Fehler | Allgemein IO | Over current of output voltage | Überstrom der Ausgangsspannung
0x8700 | Fehler |  | Channel/Interface not calibrated | Kanal/Interface nicht abgeglichen
0x8701 | Fehler |  | Operating time was manipulated | Betriebslaufzeit wurde manipuliert
0x8702 | Fehler |  | Oversampling setting is not possible | Oversampling Einstellung nicht möglich
0x8703 | Fehler |  | No slave controller found | Kein Slave Controller gefunden
0x8704 | Fehler |  | Slave controller is not in Bootstrap | Slave Controller ist nicht im Bootstrap
0x8705 | Fehler |  | Processor usage to high (>= 100%%) | Prozessorauslastung zu hoch (>= 100%%)
0x8706 | Fehler |  | Channel in saturation | Kanal in Sättigung
0x8707 | Fehler |  | Channel overload | Kanalüberlastung
0x8708 | Fehler |  | Overloadtime was manipulated | Überlastzeit wurde manipuliert
0x8709 | Fehler |  | Saturationtime was manipulated | Sättigungszeit wurde manipuliert
0x870A | Fehler |  | Channel range error | Messbereichsfehler des Kanals
0x870B | Fehler |  | no ADC clock | Kein ADC Takt vorhanden
0xFFFF | Information |  | Debug: 0x%X, 0x%X, 0x%X | Debug: 0x%X, 0x%X, 0x%X


Hinweise zu Diag Messages in Verbindung mit Motorklemmen

Fehlerbehebung [image] Hinweise zu Diag Messages in Verbindung mit Motorklemmen
Hinweise zu Diag Messages in Verbindung mit Motorklemmen
„Ack. Message“ Button
Der „Ack. Message“ Button wirkt sich nicht auf die Drive State-Machine der Motorklemmen aus, eine Betätigung führt zu keinem Achs-Reset.
Die Drive State-Machine der Motorklemmen hat keinen Einfluss auf die Fehlerliste, auch mit einem Achsreset können keine Fehler aus der Liste entfernt werden, Fehler können jedoch durch die Betätigung des „Ack. Message“ Buttons gelöscht werden.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Firmware Kompatibilität
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL7037
Hardware (HW) | Firmware (FW) | Revision-Nr. | Releasedatum
00 - 03* | 01 | EL7037-0000-0016 | 2015/02
 | 02 | EL7037-0000-0017 | 2015/07
 | 03 | EL7037-0000-0018 | 2016/06
 | 04* | EL7037-0000-0019 | 2017/03
EL7047
Hardware (HW) | Firmware (FW) | Revision-Nr. | Releasedatum
01 – 09* | 01 | EL7047-0000-0016 | 2014/07
 | 02 | EL7047-0000-0017 | 2015/01
 | 03 | EL7047-0000-0018 | 2015/08
 | 04 | EL7047-0000-0019 | 2016/06
 | 05 | EL7047-0000-0020 | 2017/03
07 – 09* | 06* | EL7047-0000-0021 | 2019/04
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand.
Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.