EL6631-0010 - Profinet Device
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.1.0
▪
Strukturupdate
▪
Update Revisionsstand
3.0.1
▪
Update Kapitel „Technische Daten“
▪
Strukturupdate
▪
Update Revisionsstand
3.0.0
▪
Migration
▪
Strukturupdate
▪
Update Revisionsstand
2.0.0
▪
Strukturanpassung, Technische Daten ergänzt
1.1.0
▪
Kapitel „Shared Device“ hinzugefügt, EC LED Beschreibung geändert, Baumstruktur geändert
1.0.0
▪
Erste Version
Firm- und Hardware-Stände
Den Softwarestand des Profinet Device Supplements können sie der entsprechenden TwinCAT Build Nummer entnehmen.
Für die EL6631-0010 können Sie den Firm- und Hardware-Stand (Auslieferungszustand) der auf der Seite der Klemme aufgedruckten Seriennummer entnehmen.


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


TwinCAT Supplement

TwinCAT Supplement
TwinCAT Supplement
Weiterführende Informationen
•
TwinCAT 2.10
•
TwinCAT 2.11


TwinCAT 2.10

TwinCAT Supplement [image] TwinCAT 2.10
TwinCAT 2.10
Weiterführende Informationen
•
PROFINET-Device-Einbindung unter TwinCAT 2.10


PROFINET-Device-Einbindung unter TwinCAT 2.10

TwinCAT Supplement [image] TwinCAT 2.10 [image] PROFINET-Device-Einbindung unter TwinCAT 2.10
PROFINET-Device-Einbindung unter TwinCAT 2.10
Installation
Für TwinCAT 2.10 steht keine Installationsversion mehr zu Verfügung. Verwenden Sie TwinCAT 2.11 oder wenden Sie sich an den Beckhoff Support.
1. Einbindung des PROFINET-Protokoll
Zunächst muss ein RealTime-Ethernet-Gerät angefügt werden. Diese Schnittstelle muss einer Adapterklasse zugewiesen werden. Diese stellt sich aus der MAC- und IP-Adresse der Netzwerkkarte zusammen.
Soll also z. B. ein CX9000 parametriert werden, so muss zuerst via Remote-Zugriff auf das Zielsystem gegangen werden, anschließend kann der entsprechende Ethernet Port gewählt werden.
Danach wird über die rechte Maustaste ein PROFINET-Protokoll angefügt. Es kann genau ein TwinCAT-Device-Protokoll angehängt werden!
Einfügen Profinet Device Protokoll
Unter dem Reiter "Protocol" ist die verwendete NetID zu finden. Sie wird z. B. für einen ADS-Zugriff benötigt. Außerdem besteht in dem Reiter "Sync Task" die Möglichkeit, eine freilaufende Task für die PROFINET-Kommunikation anzuhängen (wird empfohlen). Somit kann die RealTime- Kommunikation unabhängig einer PLC Task laufen. Aus Performance-Gründen (z. B. bei einem CX9000) kann aber auch auf die SyncTask verzichtet werden und es erfolgt das Standard Mapping, d.h. es muss z. B. eine PLC Task laufen, damit eine PROFINET-Kommunikation möglich ist.
Karteireiter „Sync Task“
Als nächstes wird eine Box in Form einer GSDML eingebunden (rechte Maustaste auf "PROFINET I/O Device Protocol"). In TwinCAT ist es auch möglich, mehrere virtuelle PROFINET Devices zu konfigurieren. Jedes Device ist wieder als eigener Adapter zu sehen, d.h. jedes virtuelle Gerät bekommt aus einem reservierten Bereich eine Default MAC-Adresse zugewiesen. Damit es nicht zu eventuellen Adresskonflikten kommt, kann bei den virtuellen Geräten auch die MAC-Adresse geändert werden. Der Name den das Gerät am Strang bekommen hat (oder unter Reiter "Allgemein"), wird nach einem Restart auch als PROFINET-Stationsname genommen. Anhand unterschiedlicher MAC-Adressen und Namen erkennt nun ein PROFINET Controller auch mehrere Geräte am Strang. Die einzelnen virtuellen Geräte können dann wiederum z. B. über eine PLC Task mit Klemmen aus dem E-Bus verknüpft werden. Dadurch können z. B. mehrere EL6601 Klemmen im E-Bus als einzelne PROFINET Devices konfiguriert werden.
Bei PROFINET können innerhalb eines Gerätes verschiedene Anwenderprofile definiert werden (API - Application Process Instance). In TwinCAT wird pro Gerät genau eine API zugelassen / unterstützt!
Der DAP (Device Access Point) ist nach PROFINET immer auf Slot 0 definiert. In ihm sind gerätespezifische Daten definiert. Nach PROFINET können mehrere DAPs definiert werden, aktuell gibt es in TwinCAT jedoch genau einen!
2. Prozessdaten
Ab Slot 1 können die Prozessdaten eingefügt werden. Dies erfolgt über das Einbinden der gewünschten Module in die API. Jedes Modul (Slot) verfügt im Moment über genau ein Submodul (Subslot). Die Konfiguration der Module und somit das Erstellen des Prozessdatenabbilds auf PROFINET-Seite erfolgt durch die Angabe von Datentypen / Datenbreiten (z. B. Byte, Word, DWord, Float32).
Die Bezeichnung der Ein- und Ausgänge erfolgt in TwinCAT immer aus TwinCAT-Sicht, d.h. die Eingänge sind aus PROFINET-Sicht (vom Controller) die Ausgänge! Deshalb sind die Daten des PROFINET I/O Devices wie folgt dargestellt:
Darstellung Ein-/ Ausgänge PROFINET I/O Device
Diese Darstellung gilt nur für das TwinCAT-PROFINET-Device, bei einem TwinCAT-PROFINET-Controller wird die Sichtweise wieder übereinstimmen!
3. Allgemeine Einstellungen
Im Karteireiter "PROFINET Devices" können die Instanz ID, die PROFINET Frame ID sowie der Client und der Server UDP-Port geändert werden. Für den Normalbetrieb sind die Default-Einstellungen jedoch ausreichend!
Karteireiter „Device“
Es gibt eine weitere Möglichkeit den PROFINET-Stationsnamen zu vergeben. Diese ist vergleichbar mit den Dip-Schaltern beim BK9103 und kann über eine PLC Task erfolgen. Zur Aktivierung muss "Generate Station Name from Control" aktiviert werden. Zur Verdeutlichung wird an den bisherigen Tree-Namen (Default: "tcpniodevice") eine 000 angehängt.
Tree-Name
Dieser Tree-Name entspricht nicht mehr dem PROFINET Stationsnamen! Zur Namensvergabe wird das Ctrl WORD des PROFINET-Protokolls zu Hilfe genommen, d.h. die eingegebene Zahl (Wertebereich 0 - 255) wird an den bisherigen Stationsnamen angehängt. Außerdem muss das Ctrl WORD mit einer Task verknüpft werden. Anschließend ist ein Neustart von TwinCAT erforderlich. Wird nun z. B. dem verknüpftem Ctrl WORD von der Task aus ein Wert von 11 vorgegeben, so ändert sich sein bisheriger Stationsname von z. B. auf "tcpniodevice" auf "tcpniodevice011". Der aktuelle Tree-Name ist weiterhin "tcpniodevice000"
Eine Überprüfung des aktuellen Stationsnamen sowie der benutzten IP-Konfiguration kann über den Karteireiter "PROFINET Diagnosis" erfolgen.
4. Zykluszeiten
Das Device kann in der durch PROFINET definierten minimalen Zykluszeit von 1 ms betrieben werden!
Wird TwinCAT im FREERUN Mode betrieben, so ist darauf zu achten, dass der eingestellte Freerun-Zyklus nicht größer als die PROFINET-Zykluszeit ist!
Karteireiter „Adapter“
Soll TwinCAT im RUN Mode betrieben werden, muss eine Task angelegt werden. Im einfachsten Fall ist das die bereits erwähnte SyncTask. Die Aufrufzeit der Task darf nicht größer sein als die PROFINET-Zykluszeit! Wird eine zweite Task z. B. für die PLC angelegt, kann diese auch langsamer laufen.
Anlegen einer Task
Bei weniger leistungsstarken Geräten (z. B. CX1000, CX9000 mit E-Bus) kann es passieren, dass die CPU-Last an ihre Grenzen gerät. Die Performance kann jedoch durch folgende Überlegungen/Maßnahmen wieder verbessert werden:
▪
Kann man mit nur einer PLC Task arbeiten?
▪
Muss die Zykluszeit 1 ms betragen?
▪
Bei Verwendung von zwei Tasks, kann die Zeit der PLC Task verringert werden?
▪
Werden mehrere virtuelle PROFINET Devices benötigt?


TwinCAT 2.11

TwinCAT Supplement [image] TwinCAT 2.11
TwinCAT 2.11
Weiterführende Informationen
•
Technische Daten - PROFINET RT
•
PROFINET-Device-Einbindung unter TwinCAT 2.11


Technische Daten - PROFINET RT

TwinCAT Supplement [image] TwinCAT 2.11 [image] Technische Daten - PROFINET RT
Technische Daten - PROFINET RT
Bei der Benutzung von TwinCAT 2.11 müssen auch die Zielsysteme zum Beispiele die CX Controller über eine TwinCAT 2.11 Version verfügen.
Technische Daten | Supplement
PROFINET Version | RT Class 1 ConformanceClassB
Anzahl der Device Schnittstellen )1 | 8
Topologie | beliebig
Anzahl der Nutzdaten | pro Device maximal eine Ethernet Frame-Länge )2 1500 Byte Nutzdaten incl. IOPS und IOCS
Zykluszeit | ≥ 1 ms
)1 siehe Kapitel Virtuelle PROFINET Devices
)2 abhängig von der Zykluszeit, der PROFINET Zykluszeit und der eingesetzten CPU
Vorrausetzungen für den Betrieb
Beim Einsatz des PROFINET Supplement sind folgende Punkte zu beachten:
•
nur Intel Chipsatz Ethernet Karten erlaubt.
•
RealTime-Ethernet-Treiber muss installiert sein.
•
Es dürfen über diese Schnittstelle keine weiteren RealTime-Protokolle angeschlossen sein.
•
Die Echtzeit-Fähigkeit kann nur in Senderichtung garantiert werden, die Empfangsrichtung kann durch unsachgemäße Verwendung nicht garantiert werden. Dies wäre zum Beispiel das Kopieren von großen Datenmengen über diese Schnittstelle.
Es empfiehlt sich, das PROFINET-Netzwerk von anderen Netzwerken zu trennen.


PROFINET-Device-Einbindung unter TwinCAT 2.11

TwinCAT Supplement [image] TwinCAT 2.11 [image] PROFINET-Device-Einbindung unter TwinCAT 2.11
PROFINET-Device-Einbindung unter TwinCAT 2.11
Diese Beschreibung gilt für das PROFINET DEVICE Supplement.
Installation
Für eine korrekte Installation sollte mindestens TwinCAT 2.11 Build 1546 installiert sein. Bei älteren TwinCAT Version empfehlen wir ein Update, in anderen Fällen wenden Sie sich an den Beckhoff Support.
1. Einbindung des PROFINET-Protokoll
Zunächst muss ein PROFINET-Gerät angefügt werden.
Dialog „Insert Device“
Netzwerkkarte
Wird keine Karte gefunden, ist das TwinCAT nicht im Config Mode oder der Echtzeit Ethernet Treiber wurde nicht richtig installiert.
Diese Schnittstelle muss einer Adapterklasse zugewiesen werden. Diese stellt sich aus der MAC- und IP-Adresse der Netzwerkkarte zusammen. Suchen Sie über "Search" die entsprechende Netzwerkkarte aus.
Search Button, Auswahl Netzwerkkarte
MAC Adress:
MAC-Adresse der Ethernet-Karte (nur lesend)

IP Address:
IP-Adresse der Karte (nur lesend). Die IP-Adresse wird aus dem Betriebssystem gelesen und hat nichts mit der PROFINET IP-Adresse zu tun, die später verwendet wird.
IP-Adresse Netzwerkkarte
Es ist zu beachten, dass die IP-Adresse des PROFINET Device und IP-Adresse der Ethernet-Karte nicht identisch sind! Der PROFINET-Treiber arbeitet mit einer virtuellen IP-Adresse, die nicht mit der IP Adresse des Betriebssystems übereinstimmen darf!
Promiscuous Mode:
Wird benötigt, um Ethernet Frames aufzuzeichnen, sollte im Normalfall ausgeschaltet sein.

Virtual Device Names:
Es wird ein virtueller Name für die Netzwerkkarte verwendet.

Shared Adapter Interface:
Aus Kompatibilitätsgründen enthalten, kann bei PROFINET nicht verwendet werden.

Free Cycle:
Zykluszeit im Config Mode (keine Echtzeit). Wird TwinCAT im FREERUN Mode betrieben, so ist darauf zu achten, dass der eingestellte Freerun-Zyklus nicht größer als die PROFINET-Zykluszeit ist!
Soll z. B. ein CX9000 parametriert werden, so muss zuerst via Remote-Zugriff auf das Zielsystem gegangen werden, anschließend kann der entsprechende Ethernet Port gewählt werden.
Unter dem Reiter "Protocol" ist die verwendete NetID zu finden. Sie wird z. B. für einen ADS-Zugriff benötigt. Außerdem besteht in dem Reiter "Sync Task" die Möglichkeit, eine freilaufende Task für die PROFINET-Kommunikation anzuhängen (wird empfohlen). Somit kann die RealTime- Kommunikation unabhängig einer PLC Task laufen. Aus Performance-Gründen (z. B. bei einem CX9000) kann aber auch auf die SyncTasks verzichtet werden und es erfolgt das Standard Mapping, d.h. es muss z. B. eine PLC Task laufen, damit eine PROFINET-Kommunikation möglich ist.
Anschließend wird über die rechte Maustaste ein PROFINET-Protokoll angefügt. Es kann genau ein TwinCAT Device Protokoll angehängt werden!
Einfügen eines PROFINET-Protokoll (TwinCAT Device Protokoll)
Als nächstes wird eine Box in Form einer GSDML eingebunden (rechte Maustaste auf "PROFINET Device").
Dialog „Insert Box“
Einbinden bei einer beliebigen Ethernet-Schnittstelle ohne Port-Diagnose nach Version 2.0 ohne LLDP.
Einbinden einer beliebigen Ethernet-Schnittstelle ohne Port-Diagnose
Einbinden bei einer einfachen Ethernet-Schnittstelle (ohne Switch, zum Beispiel CX1010 oder FC90xx) mit Port-Diagnose nach Version 2.1.
Einbinden einer einfachen Ethernet-Schnittstelle mit Port-Diagnose
Einbinden bei einer geswitchten Ethernet-Schnittstelle (zum Beispiel CX1020) mit Port-Diagnose nach Version 2.1.
Einbinden bei einer geswitchten Ethernet-Schnittstelle mit Port-Diagnose
Virtuelles PROFINET-Device
In TwinCAT ist es auch möglich, mehrere virtuelle PROFINET Devices zu konfigurieren (maximal 7 im Supplement und 1 in der EL6631-0010). Jedes Device ist wieder als eigener Adapter zu sehen, d.h. jedes virtuelle Gerät bekommt aus einem reservierten Bereich eine Default MAC- Adresse zugewiesen. Damit es nicht zu eventuellen Adresskonflikten kommt, kann bei den virtuellen Geräten auch das letzte Byte der MAC-Adresse geändert werden. Der Name den das Gerät am Strang bekommen hat (oder unter Reiter "Allgemein") wird nach einem Restart auch als PROFINET-Stationsname genommen. Anhand unterschiedlicher MAC-Adressen und Namen erkennt nun ein PROFINET Controller auch mehrere Geräte am Strang.
Somit ist es möglich beim PROFINET Device Supplement pro Ethernet Interface 8 Devices zu benutzen und mit 8 verschiedenen PROFINET Controllern zu kommunizieren.
Bei PROFINET können innerhalb eines Gerätes verschiedene Anwenderprofile definiert werden (API - Application Process Instance). In TwinCAT wird pro Gerät genau eine API zugelassen / unterstützt.
Der DAP (Device Access Point) ist nach PROFINET immer auf Slot 0 definiert. In ihm sind gerätespezifische Daten definiert. Nach PROFINET können mehrere DAPs definiert werden, aktuell gibt es in TwinCAT jedoch genau einen!
2. Prozessdaten
Ab Slot 1 können die Prozessdaten eingefügt werden. Dies erfolgt über das Einbinden der gewünschten Module in die API. Jedes Modul (Slot) verfügt im Moment über genau ein Submodul (Subslot). Die Konfiguration der Module und somit das Erstellen des Prozessdatenabbilds auf PROFINET-Seite erfolgt durch die Angabe von Datentypen / Datenbreiten (z. B. Byte, Word, DWord, Float32).
Die Bezeichnung der Ein- und Ausgänge erfolgt in TwinCAT immer aus TwinCAT-Sicht, d.h. die Eingänge sind aus PROFINET-Sicht (vom Controller) die Ausgänge! Deshalb sind die Daten des PROFINET I/O Devices wie folgt dargestellt:
Darstellung der Ein-/Ausgangsdaten des PROFINET I/O Device
Diese Darstellung gilt nur für das TwinCAT-PROFINET-Device, bei einem TwinCAT-PROFINET-Controller wird die Sichtweise wieder übereinstimmen!
3. Allgemeine Einstellungen
Im Karteireiter "PROFINET Devices" kann die Instanz ID geändert werden. Für den Normalbetrieb sind die Default Einstellungen jedoch ausreichend!
Karteireiter „Device“
Es gibt eine weitere Möglichkeit, den PROFINET-Stationsnamen zu vergeben. Diese ist vergleichbar mit den Dip-Schaltern beim BK9103 und kann über eine PLC Task erfolgen. Zur Aktivierung muss "Generate Station Name from Control" aktiviert werden. Zur Verdeutlichung wird an den bisherigen Tree-Namen (Default: "tcpniodevice") eine 000 angehängt.
Tree-Name
Dieser Tree-Name entspricht nicht mehr dem PROFINET-Stationsnamen! Zur Namensvergabe wird das Ctrl WORD des PROFINET-Protokolls zu Hilfe genommen, d.h. die eingegebene Zahl (Wertebereich 0 - 255) wird an den bisherigen Stationsnamen angehängt. Außerdem muss das Ctrl WORD mit einer Task verknüpft werden. Anschließend ist ein Neustart von TwinCAT erforderlich. Wird nun z. B. dem verknüpftem Ctrl WORD von der Task aus ein Wert von 11 vorgegeben, so ändert sich sein bisheriger Stationsname von z. B. auf "tcpniodevice" auf "tcpniodevice011". Der aktuelle Tree-Name ist weiterhin "tcpniodevice000"
Eine Überprüfung des aktuellen Stationsnamen sowie der benutzten IP-Konfiguration kann über den Karteireiter "PROFINET Diagnosis" erfolgen.
4. Zykluszeiten
Das Device kann in der durch PROFINET definierten minimalen Zykluszeit von 1 ms betrieben werden!
Karteireiter „Adapter“, Einstellen der Zykluszeit
Soll TwinCAT im RUN Mode betrieben werden, muss eine Task angelegt werden. Im einfachsten Fall ist das die bereits erwähnte SyncTask. Die Aufrufzeit der Task darf nicht größer sein als die PROFINET-Zykluszeit! Wird eine zweite Task z. B. für die PLC angelegt, kann diese auch langsamer laufen.
Task anlegen im TwinCAT Baum
Bei weniger leistungsstarken Geräten (z. B. CX1000, CX9000 mit E-Bus) kann es passieren, dass die CPU-Last an ihre Grenzen gerät. Die Performance kann jedoch durch folgende Überlegungen/Maßnahmen wieder verbessert werden:
▪
Kann man mit nur einer PLC Task arbeiten?
▪
Muss die Zykluszeit 1 ms betragen?
▪
Bei Verwendung von zwei Tasks, kann die Zeit der PLC-Task verringert werden?
▪
Werden mehrere virtuelle PROFINET Devices benötigt?


EL6631-0010

EL6631-0010
EL6631-0010
Weiterführende Informationen
•
Produktübersicht
•
Montage und Verdrahtung
•
Inbetriebnahme


Produktübersicht

EL6631-0010 [image] Produktübersicht
Produktübersicht
Weiterführende Informationen
•
PROFINET EL6631-0010 - Einführung
•
EL6631-0010 - Technische Daten
•
EL6631-0010 - LEDs


PROFINET EL6631-0010 - Einführung

EL6631-0010 [image] Produktübersicht [image] PROFINET EL6631-0010 - Einführung
PROFINET EL6631-0010 - Einführung
EL6631
Die PROFINET-IO-Device-(Slave)-Klemme EL6631-0010 ermöglicht den einfachen Datenaustausch zwischen EtherCAT und PROFINET IO. Sie ist ein Teilnehmer im EtherCAT-Strang, der aus bis zu 65.535 Teilnehmern bestehen kann. Die EL6631-0010 enthält einen 3-Port-Switch. Zwei Ports sind extern auf RJ-45-Buchsen geführt. Damit können die I/O-Stationen als Linientopologie aufgebaut werden, wodurch der Verdrahtungsaufwand vereinfacht wird. Die maximale Entfernung zwischen zwei Teilnehmern beträgt 100 m.
Zur Netzwerkdiagnose können Protokolle wie LLDP oder SNMP genutzt werden.


EL6631-0010 - Technische Daten

EL6631-0010 [image] Produktübersicht [image] EL6631-0010 - Technische Daten
EL6631-0010 - Technische Daten
Technische Daten | EL6631-0010
Bus-System | PROFINET RT Device
Anzahl Ethernet-Ports | 2
Ethernet-Interface | 10BASE-T/100BASE-TX Ethernet mit 2 x RJ45
Leitungslänge | bis 100 m Twisted-Pair
Übertragungsrate | 10/100 Mbit/s, IEEE 802.3u Auto-Negotiation, halb- oder vollduplex bei 10 und 100 Mbit/s möglich, Einstellungen automatisch
Diagnose | Status-LEDs
Spannungsversorgung | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 400 mA
Potenzialtrennung | 500 V (E-Bus/Ethernet)
Bitbreite im Prozessabbild | vaiable (max. 2 kByte für Ein- und Ausgänge)
Konfiguration | über den TwinCAT System Manager
Gewicht | ca. 75 g
Zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C (angereiht in waagerechter Einbaulage) 0°C ... + 45°C (alle anderen Einbaulagen, siehe Hinweis)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (Breite angereiht: 23 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | siehe Hinweis
Zulassung | CE ATEX cULus


EL6631-0010 - LEDs

EL6631-0010 [image] Produktübersicht [image] EL6631-0010 - LEDs
EL6631-0010 - LEDs
Tc_EL6631_LEDs
LEDs zur EtherCAT-Diagnose
LED |  | Anzeige | Beschreibung
RUN | grün | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme; BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkt 200 ms | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | aus (1 s) an (200 ms) | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
LED Diagnose PROFINET RUN/Err
Farbe grün | Farbe rot | Bedeutung
an | aus | EL-Klemme ist parametriert
aus (1 s) an (200 ms) | aus | EL6631-0010 hat keine IP-Adresse
blinkt 200 ms | aus | EL6631-0010 hat noch keinen PROFINET-Namen erhalten
aus | blinkt 200 ms | Klemme startet
LED Diagnose PROFINET Err
Farbe grün | Farbe rot | Bedeutung
an | aus | EL-Klemme ist im Datenaustausch
blinkt 200 ms | aus | EL-Klemme ist im Datenaustausch, aber der Provider ist im Stopp
aus (1 s) an (200 ms) | aus | EL-Klemme ist im Datenaustausch, aber die Module sind Unterschiedlich
aus | blinkt 500 ms | No AR erstablished, Verbindungsaufbau nicht initialisiert
blinkt 500 ms | blinkt 500 ms | EL-Klemme identifizieren über PROFINET "Blinking"
LEDs im Hochlauf
Run | PN Run/Err | PN Err | Bedeutung
aus | aus | aus | Keine Spannung am E-Bus angeschlossen. Sollten EtherCAT Klemmen dahinter funktionieren, muss die EL6631-0010 getauscht werden.
aus | aus | rot an | EL-Klemme läuft hoch, nach ca. 10 s sollte die LED aus gehen, ist das nicht der Fall, muss das EL6631-0010 Modul getauscht werden.


Montage und Verdrahtung

EL6631-0010 [image] Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Empfohlene Tragschienen
•
Montage und Demontage - Zughebelentriegelung
•
Montage und Demontage - Frontentriegelung oben
•
Einbaulagen
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation
•
UL-Hinweise


Hinweise zum ESD-Schutz

EL6631-0010 [image] Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Empfohlene Tragschienen

EL6631-0010 [image] Montage und Verdrahtung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
▪
Tragschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Tragschiene TH 35-15 mit 1,5 mm Materialstärke
Materialstärke der Tragschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Tragschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Montage und Demontage - Zughebelentriegelung

EL6631-0010 [image] Montage und Verdrahtung [image] Montage und Demontage - Zughebelentriegelung
Montage und Demontage - Zughebelentriegelung
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene Einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen. Dank der KM/EM-Steckverbinder müssen Sie hierzu nicht alle Leitungen einzeln entfernen, sondern pro KM/EM-Steckverbinder nur 2 Schrauben lösen um diese abziehen zu können (stehende Verdrahtung)!
▪
Hebeln Sie auf der linken Seite des Klemmenmoduls mit einem Schraubendreher (3) den Entriegelungshaken nach oben. Dabei
–
ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück,
–
bewegt sich der Entriegelungshaken nach vorne (3b) und rastet ein
▪
Bei 32- und 64-kanaligen Klemmenmodulen (KMxxx4 und KMxxx8 bzw. EMxxx4 und EMxxx8) hebeln Sie nun den zweiten Entriegelungshaken auf der rechten Seite des Klemmenmoduls auf die gleiche Weise nach oben.
▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg.


Montage und Demontage - Frontentriegelung oben

EL6631-0010 [image] Montage und Verdrahtung [image] Montage und Demontage - Frontentriegelung oben
Montage und Demontage - Frontentriegelung oben
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen.
▪
Ziehen Sie mit Daumen und Zeigefinger die orange Entriegelungslasche (3) zurück. Dabei ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück.

▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg. Vermeiden Sie ein Verkanten; stabilisieren Sie das Modul ggf. mit der freien Hand


Einbaulagen

EL6631-0010 [image] Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

EL6631-0010 [image] Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

EL6631-0010 [image] Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


UL-Hinweise

EL6631-0010 [image] Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


Inbetriebnahme

EL6631-0010 [image] Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
Technische Daten - PROFINET RT
•
PROFINET-Device (EL6631-0010) Einbindung unter TwinCAT 2.11


Technische Daten - PROFINET RT

EL6631-0010 [image] Inbetriebnahme [image] Technische Daten - PROFINET RT
Technische Daten - PROFINET RT
Technische Daten | EL6631-0010
PROFINET Version | RT Class 1 ConformanceClassB
Anzahl der Device Schnittstellen )1 | 2
Topologie | beliebig
Anzahl der Nutzdaten | 1 kByte In/Out
Zykluszeit | ≥ 1 ms
)1 siehe Kapitel Virtuelle PROFINET Devices
Switch Funktionalität
Der Interne Switch wird beim Schalten in den Bootstrap Modus deaktiviert und steht während eines Firmware Updates nicht zur Verfügung.


PROFINET-Device (EL6631-0010) Einbindung unter TwinCAT 2.11

EL6631-0010 [image] Inbetriebnahme [image] PROFINET-Device (EL6631-0010) Einbindung unter TwinCAT 2.11
PROFINET-Device (EL6631-0010) Einbindung unter TwinCAT 2.11
Diese Beschreibung gilt für das PROFINET DEVICE EL6631-0010.
1. Einbindung der EL6631-0010 im EtherCAT-Netzwerk
Fügen Sie die EL6631-0010 in Ihr TwinCAT-Projekt ein.
Einbinden der EL6631-0010 im TwinCAT-Projekt
2. Einbindung des PROFINET-Protokoll
Zunächst muss ein PROFINET-Gerät angefügt werden - EL6631-0010.
Dialog „Insert Device“
Diese Schnittstelle muss einer Adapterklasse zugewiesen werden. Diese stellt sich aus der MAC- und IP-Adresse der Netzwerkkarte zusammen. Suchen Sie über "Search" die entsprechende EtherCAT-Klemme aus, sollte nur eine Klemme im System enthalten sein wird diese automatisch konfiguriert.
Karteireiter „Adapter“
MAC Adress:
MAC-Adresse der Ethernet-Karte (nur lesend)

IP Address:
IP-Adresse der Karte (nur lesend). Die IP-Adresse wird aus dem Betriebssystem gelesen und hat nichts mit der PROFINET IP-Adresse zu tun, die später verwendet wird.

Promiscuous Mode:
Wird bei der EL6631-0010 nicht unterstützt

Virtual Device Names:
Wird bei der EL6631-0010 nicht unterstützt

Shared Adapter Interface:
Wird bei der EL6631-0010 nicht unterstützt

Free Cycle:
Zykluszeit im Config Mode (keine Echtzeit). Wird TwinCAT im FREERUN Mode betrieben, so ist darauf zu achten, dass der eingestellte Freerun-Zyklus nicht größer als die PROFINET-Zykluszeit ist!
Soll z. B. ein CX9000 parametriert werden, so muss zuerst via Remote-Zugriff auf das Zielsystem gegangen werden, anschließend kann der entsprechende Ethernet Port gewählt werden.
Unter dem Reiter "Protocol" ist die verwendete NetID zu finden. Sie wird z. B. für einen ADS-Zugriff benötigt. Außerdem besteht in dem Reiter "Sync Task" die Möglichkeit, eine freilaufende Task für die PROFINET-Kommunikation anzuhängen (wird empfohlen). Somit kann die RealTime- Kommunikation unabhängig einer PLC Task laufen. Aus Performance-Gründen (z. B. bei einem CX9000) kann aber auch auf die SyncTasks verzichtet werden und es erfolgt das Standard Mapping, d.h. es muss z. B. eine PLC Task laufen, damit eine PROFINET-Kommunikation möglich ist.
Anschließend wird über die rechte Maustaste ein PROFINET-Protokoll angefügt. Es kann genau ein TwinCAT-Device-Protokoll angehängt werden!
Einfügen Profinet Device Protokoll
Als nächstes wird eine Box in Form einer GSDML eingebunden (rechte Maustaste auf "PROFINET Device").
Dialog „Insert Box“
Wählen Sie nun aus nach welcher Version Ihre EL6631-0010 eingebunden werden soll. Der Hauptunterschied zwischen V2.0 und V2.2 ist die Unterstützung von Sub-Modulen.
Auswahl EL6631-0010 mit oder ohne Portdiagnose
In der ersten EL6631-0010 (nach V2.2) erkennt man im DAP die Ports und damit die Portdiagnose. Die nachfolgende EL6631-0010 ist nach der V2.0 eingebunden worden. Hier ist keine Port-Diagnose möglich. Im Master muss die gleiche Version verwendet werden. Ältere PROFINET-Controller können die Version 2.2 noch nicht unterstützen, verwenden Sie dann die Version 2.0.
Mehrere PROFINET Devices im TwinCAT-Baum
Virtuelles PROFINET Device
In TwinCAT ist es auch möglich, mehrere virtuelle PROFINET Devices zu konfigurieren (maximal 7 im PROFINET Device Supplement und ein zusätzliches Device in der EL6631-0010). Jedes Device ist wieder als eigener Adapter zu sehen, d.h. jedes virtuelle Gerät bekommt aus einem reservierten Bereich eine Default MAC-Adresse zu gewiesen. Damit es nicht zu eventuellen Adresskonflikten kommt, kann bei den virtuellen Geräten auch die MAC-Adresse geändert werden. Der Name den das Gerät am Strang bekommen hat (oder unter Reiter "Allgemein") wird nach einem Restart auch als PROFINET-Stationsname genommen. Anhand unterschiedlicher MAC-Adressen und Namen erkennt nun ein PROFINET Controller auch mehrere Geräte am Strang.
Somit ist es möglich beim PROFINET Device Supplement pro Ethernet Interface 8 Devices zu benutzen und damit mit 8 verschiedenen PROFINET Controllern zu kommunizieren. Bei der EL6631-0010 sind es 2 Devices.
Bei PROFINET können innerhalb eines Gerätes verschiedene Anwenderprofile definiert werden (API - Application Process Instance). In TwinCAT wird pro Gerät genau eine API zugelassen / unterstützt.
Der DAP (Device Access Point) ist nach PROFINET immer auf Slot 0 definiert. In ihm sind gerätespezifische Daten definiert. Nach PROFINET können mehrere DAPs definiert werden, aktuell gibt es in TwinCAT jedoch genau einen!
3. Prozessdaten
Ab Slot 1 können die Prozessdaten eingefügt werden. Dies erfolgt über das Einbinden der gewünschten Module in die API. Jedes Modul (Slot) verfügt im Moment über genau ein Submodul (Subslot). Die Konfiguration der Module und somit das Erstellen des Prozessdatenabbilds auf PROFINET-Seite erfolgt durch die Angabe von Datentypen / Datenbreiten (z. B. Byte, Word, DWord, Float32).
Die Bezeichnung der Ein- und Ausgänge erfolgt in TwinCAT immer aus TwinCAT-Sicht, d.h. die Eingänge sind aus PROFINET-Sicht (vom Controller) die Ausgänge! Deshalb sind die Daten des PROFINET I/O Devices wie folgt dargestellt:
Darstellung Ein-/ Ausgänge PROFINET I/O Device
Diese Darstellung gilt nur für das TwinCAT-PROFINET-Device, bei einem TwinCAT-PROFINET-Controller wird die Sichtweise wieder übereinstimmen!
4. Allgemeine Einstellungen
Im Karteireiter "PROFINET Devices" kann die FrameID geändert werden. Für den Normalbetrieb sind die Default Einstellungen jedoch ausreichend!
Karteireiter „Device“
4.1 PROFINET Namen Vergabe
Bei Auslieferung der EL6631-0010 hat diese keinen PROFINET-Namen. Es wird beim Suchen der Geräte ein Leerstring übergeben.
Es gibt mehrere Möglichkeiten den Namen einer EL6631-0010 zu vergeben:
1.
Vergabe über den PROFINET Controller
2.
Vergabe über den EtherCAT Master (dann ist eine Vergabe über den Controller nicht mehr möglich)
3.
Vergabe über eine Verknüpfung zum SPS-Programm (dann ist eine Vergabe über den Controller nicht mehr möglich)
4.
Automatischer Geräteanlauf über Topologievorgabe wird unterstützt
Weitere Informationen entnehmen Sie Ihrem PROFINET Controller
4.1.1 Vergabe über den PROFINET Controller
Hierbei vergibt der PROFINET Controller den Namen des Gerätes. Informieren Sie sich hierfür bei dem PROFINET Controller Hersteller.
4.1.2 Vergabe über den EtherCAT Master
Aktivieren Sie hierfür den Haken "get PN-Stationname from ECAT".
Karteireiter „EL663x“
Es wird dann der Name verwendet, der im System-Manager-Baum verwendet wird. Hier zum Beispiel "el6631-test-name".
TwinCAT-Baum: PROFINET-Stationsname vergeben
4.1.3 Vergabe über eine Verknüpfung zum SPS Programm
Diese ist vergleichbar mit den Dip-Schaltern beim BK9103 und kann über eine PLC Task erfolgen. Zur Aktivierung muss "Generate Station Name from Control" aktiviert werden. Zur Verdeutlichung wird an den bisherigen Tree-Namen (Default: "tcpniodevice") eine 000 angehängt.
Treename im TwinCAT-Baum
Tree-Name
Dieser Tree-Name entspricht nicht mehr dem PROFINET-Stationsnamen! Zur Namensvergabe wird das Ctrl WORD des PROFINET-Protokolls zu Hilfe genommen, d.h. die eingegebene Zahl (Wertebereich 0 - 255) wird an den bisherigen Stationsnamen angehängt. Außerdem muss das Ctrl WORD mit einer Task verknüpft werden. Anschließend ist ein Neustart von TwinCAT erforderlich. Wird nun z. B. dem verknüpftem Ctrl WORD von der Task aus ein Wert von 11 vorgegeben, so ändert sich sein bisheriger Stationsname von z. B. auf "tcpniodevice" auf "tcpniodevice011". Der aktuelle Tree-Name ist weiterhin "tcpniodevice000"
Eine Überprüfung des aktuellen Stationsnamen sowie der benutzten IP-Konfigration kann über den Karteireiter "PROFINET Diagnosis" erfolgen.
4.2 Diagnose
Im Karteireiter Diagnose wird der tatsächliche PROFINET-Name angezeigt. Die IP-Konfiguration wird mit dem Hochlauf des Masters festgelegt und besitzt die Werte, die vom Master vergeben worden sind. Im Feld "Module Difference" wird angezeigt, wenn die Soll-Konfiguration ungleich der Ist-Konfiguration ist. Im fehlerfreien Zustand sollte das Feld leer sein.
Karteireiter „Diagnose“
5. Zykluszeiten
Das Device kann in der durch PROFINET definierten minimalen Zykluszeit von 1 ms betrieben werden!
Karteireiter „Adapter“, Einstellen Zykluszeit
Soll TwinCAT im RUN Mode betrieben werden, muss eine Task angelegt werden. Im einfachsten Fall ist dies die bereits erwähnte SyncTask. Die Aufrufzeit der Task darf nicht größer sein als die PROFINET-Zykluszeit! Wird eine zweite Task z. B. für die PLC angelegt, kann diese auch langsamer laufen.
Einfügen einer Task
Bei weniger leistungsstarken Geräten (z. B. CX1000, CX9000 mit E-Bus) kann es passieren, dass die CPU Last an ihre Grenzen gerät. Die Performance kann jedoch durch folgende Überlegungen/Maßnahmen wieder verbessert werden:
▪
Kann man mit nur einer PLC Task arbeiten?
▪
Muss die Zykluszeit 1 ms betragen?
▪
Bei Verwendung von zwei Tasks, kann die Zeit der PLC Task verringert werden?
▪
Werden mehrere virtuelle PROFINET Devices benötigt?
6. PDO Mapping
Das PDO Mapping beschreibt wie die PROFINET-Daten im EtherCAT abgebildet werden sollen. Beim Einsatz von TwinCAT ist die Einstellung "Submodule data" zu verwenden.
Karteireiter „EL663x“


Profinet Features

Profinet Features
Profinet Features
Weiterführende Informationen
•
Alarme
•
Record Daten
•
Shared Device
•
Diagnose


Alarme

Profinet Features [image] Alarme
Alarme
PROFINET Alarm
Es können über die ADS Schnittstelle auch PROFINET-Alarme gesendet werden.
Hierfür ist ein ADS WRITE Baustein zu verwenden.
ADS WRITE | Kommentar
AMSNETID | AMS Net ID des PROFINET Devices
PORT | 0xFFFF (Bei der Verwendung eines virtuellen PROFINET Devices bildet sich die Port Nummer aus 0x1000 + der Geräte ID)
Index Group | High Word - Alarm Type (siehe PROFINET Spezifikation), Low Word - 0xF807
Index Offset | High Word - Slot Nummer, Low Word - Sub Slot Nummer
Es werden keine weiteren Daten versendet.
PROFINET Alarm (Beispiele)
ALARME | Kommentar
0x0000 | reserved
0x0001 | Diagnosis appears
0x0002 | Process
0x0003 | Pull
0x0004 | Plug
0x0005 | Status
... | weitere Diagnose-Meldungen (siehe PROFINET Spezifikation)


Record Daten

Profinet Features [image] Record Daten
Record Daten
PROFINET Record Daten
PROFINET Record Daten können auch über die SPS direkt empfangen werden. Dafür wird in der SPS ein "Indication" gesetzt (READINDICATION für das Lesen und WRITEINDICATION für das Schreiben). Die RECORD Daten-Struktur ist wie folgt beschrieben:
WORD RW;
#define PN_READ 0
#define PN_WRITE 1
WORD NrOfAR;
DWORD API;
WORD Slot;
WORD SubSlot;
PNIO_RECORD RecordData;
Record Data
WORD Index;
WORD Length; //zum Lesen auf 0
WORD TransferSequence;
WORD LengthOfAligned;
Tabelle PROFINET RECORD DATEN abgebildet auf ADS
PROFINET | Länge in Byte | Kommentar | ADS
- | String | AMS NET ID des PROFINET Device | AMSNETID
- | 2 | 0xFFFF Bei der Nutzung der virtuellen Schnittstelle ist die Port-Nummer aus dem System Manager zu entnehmen | Port
Read/Write | 2 | 0 - Read 1 - Write | Read - ReadIndication Write - WriteIndication
Number of AR | 2 | 0x0000 | -
API Application Process Identifier | 4 | 0x00000000 | -
Slot | 2 | Slot Nummer 0x0000-0x7FFF | IndexOffset High Word
SubSlot | 2 | SubSlot Nummer 0x0000-0x8FFF | IndexOffset Low Word
Record Data Index | 2 | 0x0000-0x1FFF | IndexGroup Low Word
- | 2 | 0x8000 | IndexGroup High Word
Record Data Length | 2 | zum Lesen auf "0" | LENGTH
Record Data Transfer Sequence | 2 | fortlaufende Nummer | -
Record Data Length of Aligned | 2 | kann Null sein | -
Beispiel für das Lesen von Daten, der PROFINET Controller will Daten über die Record Daten von einem Beckhoff Device lesen. Bei diesem Beispiel werden alle RecIndex Werte angenommen und immer das gleiche zurückgegeben - 10 Byte die im Datenarray "Data" stehen.
CASE i OF
0: ADSREADIND(
CLEAR:=FALSE ,
VALID=> ,
NETID=> ,
PORT=> ,
INVOKEID=> ,
IDXGRP=> ,
IDXOFFS=> ,
LENGTH=> );
IF ADSREADIND.VALID THEN
IdxGroup:=ADSREADIND.IDXGRP;
IdxOffset:=ADSREADIND.IDXOFFS ;
i:=10;
END_IF
10: ADSREADRES(
NETID:=ADSREADIND.NETID,
PORT:=ADSREADIND.PORT,
INVOKEID:=ADSREADIND.INVOKEID ,
RESULT:=0 ,
LEN:=10 ,
DATAADDR:=ADR(Data),
RESPOND:=TRUE );
i:=20;
ADSREADIND(CLEAR:=TRUE);
20: i:=0;
ADSREADRES(RESPOND:=FALSE);
END_CASE


Shared Device

Profinet Features [image] Shared Device
Shared Device
Das ProfiNET Feature "Shared Device" wird von der EL6631-0010 unterstützt, vom TwinCAT Supplement ab Version TC211 22.xx (= TC2 R3).
Shared Device beinhaltet die Funktionalität, wie zwei Controller gleichzeitig auf ein Device und ggf. auch auf dasselbe Prozessdatenabbild zugreifen können.
Der Unterschied zur Verwendung des virtuellen Devices besteht darin, dass beim Anlegen eines virtuellen Devices ein komplett neues Gerät (mit eigenem Namen, MAC, IP...) generiert wird. D.h. hierdurch sieht der Controller zwei getrennte Geräte und kann zwei komplett getrennte Verbindungen aufbauen.
Beim Shared Device hingegen gibt es immer nur ein Gerät. Auf Device-Seite muss hierfür nichts projektiert werden, die komplette Funktionalität wird im ProfiNET Stack gehandelt. Ein gängiges Beispiel hierfür wäre die Verwendung der Safety-Funktionalität. Ein "normaler Controller" bekommt die "normalen" Ein- und Ausgänge zugewiesen, die F-CPU die sicheren I/Os. Sollte sich das angeforderte Prozessabbild bei beiden Controllern überlappen, so bekommt die erste AR (primary) die aufgebaut wird, den vollen Lese- und Schreibzugriff auf die Submodule. Die zweite AR (secondary) erhält an den bereits belegten Submodulen einen entsprechenden ModuleDiff Block. Wird die Primary AR frei gegeben, so erhält die Secondary AR einen Alarm, welcher die angeforderten Submodule nun als frei kennzeichnet. Der zweite Controller hat nun die Möglichkeit - insofern er dies unterstützt - die Submodule neu zu parametrieren und in seiner AR zu übernehmen.


Diagnose

Profinet Features [image] Diagnose
Diagnose
Weiterführende Informationen
•
Status- und Ctrl. Flags
•
Port Diagnose
•
Weitere Diagnose über ADS-Schnittstelle


Status- und Ctrl. Flags

Profinet Features [image] Diagnose [image] Status- und Ctrl. Flags
Status- und Ctrl. Flags
PROFINET Status
Über den PnIoBoxState kann man den aktuellen Status der PROFINET-Kommunikation überwachen.
TwinCAT-Baum: PRONINET Status über „PnIoBoxState“
PnIoBoxState | Kommentar | Bedeutung
0x0001 (Bit 0) | Device is in I/O exchange | PROFINET Device ist im Datenaustausch
0x0002 (Bit 1) | Device is blinking | PROFINET Device wird über die Identifizierung gesucht
0x0004 (Bit 2) | Provider State 0=STOP, 1=RUN | Der PROFINET Controller ist in Stopp Zustand
0x0008 (Bit 3) | Problem Indicator 0=OK, 1=Error | Das PROFINET Device hat Probleme festgestellt
Im fehlerfreien Zustand ist der Wert des PnIoBoxState "5" - das bedeutet, Bit 0 und Bit 2 ist gesetzt.
PROFINET Control
PnIoBoxCtrl kann für die Namensvergabe genutzt werden, dabei ist nur das Low Byte zu verwenden. Das High Byte muss 0x00 sein.


Port Diagnose

Profinet Features [image] Diagnose [image] Port Diagnose
Port Diagnose
Die Port Diagnose kann dazu genutzt werden, die benachbarten PROFINET-Geräte zu identifizieren. Der eigene Port kann ebenfalls diagnostiziert werden.
Portdiagnose


Weitere Diagnose über ADS-Schnittstelle

Profinet Features [image] Diagnose [image] Weitere Diagnose über ADS-Schnittstelle
Weitere Diagnose über ADS-Schnittstelle
Es sind über die ADS-Schnittstelle weitere Diagnosemöglichkeiten gegeben.
PROFINET-Name und IP-Einstellungen auslesen
Hierfür ist ein ADS READ Baustein zu verwenden.
ADS WRITE | Kommentar
AMSNETID | AMS Net ID des PROFINET Devices
PORT | 0xFFFF (Bei der Verwendung eines virtuellen PROFINET Devices bildet sich die Port Nummer aus 0x1000 + der Geräte ID)
Index Group | High Word - 0x0000, Low Word - 0xF804
Index Offset | 0x0000
Length | 257
Daten Byte Offset | Wert | Kommentar
0..3 | reserved | reserved
4..7 | ARRAY4 of Byte | IP Address
8..11 | ARRAY4 of Byte | Sub Net Mask
12..15 | ARRAY4 of Byte | Default Gateway
16...x | STRING (max. length 240) | PROFINET Name
Auslesen der Modul-Differenz
Hierfür ist ein ADS READ Baustein zu verwenden.
ADS WRITE | Kommentar
AMSNETID | AMS Net ID des PROFINET Devices
PORT | 0xFFFF (Bei der Verwendung eines virtuellen PROFINET Devices bildet sich die Port Nummer aus 0x1000 + der Geräte ID)
Index Group | High Word - 0x0000, Low Word - 0xF826
Index Offset | 0x0000
Length | 20882
Kommt die Länge Null zurück, sind die Module identisch. Die Länge kann nach der Art verschieden sein (siehe ModuleDiffBlock PROFINET Spezifikation)
Beispiel wie die Daten aufgebaut sein können:
Daten Byte Offset | Wert | Kommentar
0..3 | UINT32 | API
4..5 | UINT16 | Number of Modules
6..7 | UINT16 | Slot
8..11 | UINT32 | Module Ident (see GSDML File)
12..13 | UINT16 | Module State (0-noModul, 1- WrongModule, 2- ProperModule, 3- Substitute)
14..15 | UINT16 | NumberOfSubModules
16..17 | UINT16 | SubSlot


TwinCAT Bibliothek & Programmierung

TwinCAT Bibliothek & Programmierung
TwinCAT Bibliothek & Programmierung
Weiterführende Informationen
•
Funktionen


Funktionen

TwinCAT Bibliothek & Programmierung [image] Funktionen
Funktionen
Weiterführende Informationen
•
FUNCTION_BLOCK FB_Write_IuM_EL6631_0010
•
FUNCTION_BLOCK FB_Read_IuM_EL6631_0010


FUNCTION_BLOCK FB_Write_IuM_EL6631_0010

TwinCAT Bibliothek & Programmierung [image] Funktionen [image] FUNCTION_BLOCK FB_Write_IuM_EL6631_0010
FUNCTION_BLOCK FB_Write_IuM_EL6631_0010
FUNCTION_BLOCK FB_Write_IuM_EL6631_0010
Dieser Baustein schreibt I&M1, I&M2, I&M3 und I&M4 (Identification & Maintenance) Daten nach ProfiNET-Spezifikation über EtherCAT als String auf das ProfiNET-Gerät.
VAR_INPUT
VAR_INPUT
bWrite : BOOL;
NETID : STRING; (* AMS NET ID EtherCAT Master *)
PORT : WORD; (* EtherCAT Slave address *)
byState : BYTE; (* Bit 0 -> I&M1 || Bit 1 -> I&M2 || Bit 2 -> I&M3 || Bit 3 -> I&M4*)
iNumber : INT:=0; (* "0"=EL6631-0010 or "1"=vitual EL6631-0010*)
st_IM_TagFunction : STRING; (* I&M1 byState.0=TRUE*)
st_IM_TagLocation : STRING; (* I&M1 byState.0=TRUE*)
st_IM_Date : STRING; (* I&M2 byState.1=TRUE*)
st_IM_Descriptor : STRING; (* I&M3 byState.2=TRUE*)
st_IM_Signature : STRING; (* I&M4 byState.3=TRUE*)END_VAR
bWrite: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert und die I&M Daten in das ausgewählte ProfiNET-Gerät geschrieben.
NETID: AMS Net ID des Controllers
PORT: Port über den der Controller mit dem Gerät kommuniziert ( Port = Device ID + 1000hex )
byState: Über dieses Byte kann ausgewählt werden, welche I&M Daten geschrieben werden sollen.
iNumber: Mit einer Klemme können 2 ProfiNET-Geräte abgebildet werden. Über iNumber ("0" oder "1") wird das Gerät ausgewählt, für das die I&M Daten geschrieben werden sollen.
st_IM_TagFunction: Label für die Funktion des Gerätes wird auf das Gerät geschrieben.
st_IM_Taglocation: Label für den Einbauort des Gerätes wird auf das Gerät geschrieben.
st_IM_Date: Datum des Geräteeinbaus wird auf das Gerät geschrieben.
st_IM_Descriptor: Beschreibung des Herstellers wird auf das Gerät geschrieben.
st_IM_Signature: Signatur des Herstellers wird auf das Gerät geschrieben.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bError : BOOL;
iErrorID : DINT;
END_VAR
bBusy: Bei der Aktivierung des Funktionsbausteins wird dieser Ausgang gesetzt und bleibt gesetzt, bis eine Rückmeldung erfolgt. Während Busy = TRUE wird an den Eingängen kein neuer Befehl angenommen.
bError: Sollte ein Fehler bei der Übertragung des Kommandos erfolgen, dann wird dieser Ausgang gesetzt, nachdem der bBusy-Ausgang zurückgesetzt wurde.
iErrorID: Liefert bei einem gesetzten bError-Ausgang eine ADS Fehlernummer.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 R3 | PC or CX (x86, ARM) | TcProfinetDiag.Lib


FUNCTION_BLOCK FB_Read_IuM_EL6631_0010

TwinCAT Bibliothek & Programmierung [image] Funktionen [image] FUNCTION_BLOCK FB_Read_IuM_EL6631_0010
FUNCTION_BLOCK FB_Read_IuM_EL6631_0010
FUNCTION_BLOCK FB_Read_IuM_EL6631_0010
Dieser Baustein liest I&M1, I&M2, I&M3 und I&M4 (Identification & Maintenance) Daten über EtherCAT als String aus einem ProfiNET-Gerät. Das Auslesen der I&M0 Daten erfolgt bei einem ProfiNET-Gerät mit EtherCAT über CoE (CAN over EtherCAT).
VAR_INPUT
VAR_INPUT
bRead : BOOL;
NETID : STRING; (* AMS NET ID EtherCAT Master *)
PORT : WORD; (* EtherCAT Slave address *)
iNumber : INT; (* "0"=EL6631-0010 or "1"=vitual EL6631-0010*)END_VAR
bRead: Über eine positive Flanke an diesem Eingang wird der Baustein aktiviert und die I&M Daten aus dem ProfiNET-Gerät ausgelesen.
NETID: AMS Net ID des Controllers
PORT: Port, über den der Controller mit dem Gerät kommuniziert (Port = Device ID + 1000hex)
iNumber: Mit einer Klemme können 2 ProfiNET-Geräte abgebildet werden. Über iNumber ("0" oder "1") wird das Gerät ausgewählt, für das die I&M Daten ausgelesen werden sollen.
VAR_OUTPUT
VAR_OUTPUT
bBusy : BOOL;
bError : BOOL;
iErrorID : DINT;
st_IM_TagFunction : STRING; (* I&M1 *)
st_IM_TagLocation : STRING; (* I&M1 *)
st_IM_Date : STRING; (* I&M2 *)
st_IM_Descriptor : STRING; (* I&M3 *)
st_IM_Signature : STRING; (* I&M4 *)
END_VAR
bBusy: Bei der Aktivierung des Funktionsbausteins wird dieser Ausgang gesetzt und bleibt gesetzt, bis eine Rückmeldung erfolgt. Während Busy = TRUE wird an den Eingängen kein neuer Befehl angenommen.
bError: Sollte ein Fehler bei der Übertragung des Kommandos erfolgen, wird dieser Ausgang gesetzt, nachdem der bBusy-Ausgang zurückgesetzt wurde.
iErrorID: Liefert bei einem gesetzten bError-Ausgang eine ADS Fehlernummer.
st_IM_TagFunction: ausgelesenes Label für Funktion des Gerätes.
st_IM_Taglocation: ausgelesenes Label für Einbauort des Gerätes.
st_IM_Date: Liefert das Datum des Geräteeinbaus in dem Format.
st_IM_Descriptor: Liefert die für das Gerät hinterlegte Hersteller-Beschreibung zurück.
st_IM_Signature: Liefert die für das Gerät hinterlegte Hersteller-Signatur zurück.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 R3 | PC or CX (x86, ARM) | TcProfinetDiag.Lib


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Geräte Stammdatei GSDML
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL6631-0010
Hardware (HW) | Firmware | Revision Nr. | Releasedatum
03 - 07 | 01 | EL6631-0010-0016 | 2011/05
 | 02 | EL6631-0010-0017 | 2012/12
08-14* | 02 | EL6631-0010-0018 | 2013/05
 | 03 |  | 2014/05
 | 04 |  | 2014/10
 | 05 |  | 2014/12
 | 06 |  | 2015/05
 | 07 |  | 2015/10
02 – 14* | 08 |  | 2016/11
 | 09 |  | 2017/01
 | 10 |  | 2017/06
 | 11 |  | 2017/11
 | 12 |  | 2018/04
 | 13 |  | 2018/07
 | 14* |  | 2018/12
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Geräte Stammdatei GSDML

Anhang [image] Geräte Stammdatei GSDML
Geräte Stammdatei GSDML
Die GSDML Datei beschreibt ein PROFINET Gerät. Diese Datei ist für den PROFINET Controller notwendig und muss in die entsprechende Konfigurationssoftware eingebunden werden. Die notwendigen GSDML Dateien finden Sie im Ordner TwinCAT\IO\PROFINET oder auf der Homepage www.beckhoff.de unter Downloads -> Konfigurationsdateien -> TwinCAT.
Kommentar | GSDML File Name* | PROFINET Device
Supplement Profinet Device | GSDML-V2.1-beckhoff-TCPNDevice-20091009 | PROFINET Device für FC9xxx Karten mit Intel-Chipsatz oder Ethernet-Schnittstellen mit Intel-Chipsatz, für OS mit XP, XPemb
Supplement Profinet Device CE | GSDML-V2.1-beckhoff-TCPNDevice-20091009 | PROFINET Device für FC9xxx Karten mit Intel-Chipsatz oder Ethernet Schnittstellen mit Intel-Chipsatz, für OS CE
EL6631-0010 | GSDML-V2.2-beckhoff-EL6631-20100309.xml | EL6631-0010
* Der File-Name kann sich mit Einfügen neuer Features oder Versionen ändern.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.