EL6601, EL6614 - Switch-Klemmen für Ethernet
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
4.2 | - Update Kapitel „Objektbeschreibung“ - Strukturupdate - Revisionsstatus aktualisiert
4.1 | - Hinweis im Kapitel „Adressvergabe“ ergänzt - Strukturupdate - Revisionsstatus aktualisiert
4.0 | - Migration - Strukturupdate - Revisionsstatus aktualisiert
3.4 | - Strukturupdate - Kapitel "Technische Daten" aktualisiert - Revisionsstatus aktualisiert
3.3 | - Strukturupdate - Kapitel "Technische Daten" aktualisiert - Kapitel "Einführung" aktualisiert - Kapitel "Konfiguration am CX20x0 & CX50x0 System" eingefügt - Revisionsstatus aktualisiert
3.2 | - Strukturupdate - Kapitel "Technische Daten" aktualisiert - Kapitel "EtherCAT-PC als Netzwerk-Bridge" aktualisiert - Revisionsstatus aktualisiert
3.1 | - Strukturupdate - Kapitel "Technische Daten" aktualisiert - Kapitel "Montage und Verdrahtung" aktualisiert
3.0 | - Hinweise zur Kabelredundanz ergänzt
2.9 | - Hinweise Subscriber Filter, Diagnosedaten ergänzt
2.8 | - Technische Hinweise ergänzt
2.7 | - Technische Hinweise ergänzt
2.6 | - Technische Hinweise ergänzt
2.5 | - Kapitel Firmware aktualisiert
2.4 | - Technische Hinweise Netzwerkvariablen ergänzt
2.3 | - Applikationsbeispiel ergänzt
2.2 | - Technische Hinweise ergänzt
2.1 | - Technische Hinweise (Subcriber, Publisher) ergänzt
2.0 | - Technische Hinweise und CoE Objekte ergänzt
1.9 | - Hinweis zur Einbaulage ergänzt
1.8 | - Technische Hinweise ergänzt
1.7 | -Technische Hinweise Netzwerkvariablen ergänzt
1.6 | - LED- und Portbeschreibung ergänzt
1.5 | - EL6614 ergänzt
1.4 | - Applikationsbeispiel ergänzt
1.3 | - Technische Daten ergänzt (Objekt Beschreibung)
1.2 | - Technische Daten ergänzt, Erläuterungen zu Mailboxkommunikation und Netzwerkvariablen ergänzt
1.1 | - Technische Daten ergänzt, UL Kennzeichnung ergänzt
1.0 | - Technische Daten ergänzt, erste Veröffentlichung
0.1 | - Vorläufige Dokumentation für EL6601


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Grundlagen zur Funktion
•
EL66xx - Non Realtime
•
EL66xx und Beckhoff Netzwerk Variablen
•
Konfiguration am CX20x0 & CX50x0 System


Einführung

Produktübersicht [image] Einführung
Einführung
EL6601, EL6614
Switch-Klemmen für Ethernet
Die Switch-Klemmen für Ethernet dienen dem dezentralen Anschluss beliebiger Ethernet-Geräte an den EtherCAT-Klemmenverbund. Die Ethernet-Kommunikation der angeschlossenen Geräte wird volltransparent und kollisionsfrei durch das EtherCAT-System weitergeleitet.
Die 4 Port Ethernet-Switchklemme EL6614 leitet die aus den Ports eingehenden Frames gezielt an die Zielports weiter. Im Vollduplex-Modus ermöglicht sie damit die kollisionsfreie Kommunikation der angeschlossenen Geräte untereinander.
Es können beliebig viele EL6601/EL6614 gleichzeitig und an beliebiger Position im EtherCAT-Klemmenverbund eingesetzt werden. Eine Konfiguration ist nicht erforderlich. Zusammen mit dem Netzwerkport am EtherCAT-Master arbeiten die EL6601/EL6614 wie ein virtueller Switch, dessen Ports im Feld verteilt sind. Der Backbone dieses Switches ist der EtherCAT-Feldbus.
EL6601 als im Feld verteilter, virtueller Switch
Weitere Vorteile unterstreichen die besondere Eignung für den Einsatz im Industrieumfeld:
▪
kompakte Bauform im EtherCAT-Klemmengehäuse
▪
10/100 Mbaud, halb- und voll-duplex, mit automatischer Baudratenerkennung
▪
Autocrossing (automatisches Erkennen gekreuzter Leitungen)
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LEDs geben den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
Link / Act | grün | Verbindung / Datenaustausch Feldbus
*Link/Act X1 - X4 | grün | Verbindung / Datenaustausch Ethernet-Port X1- X4
Eth Err | rot | Fehleranzeige EtherCAT (siehe Diagnose)
* nur EL6614
Anschlüsse
1 x RJ45 mit 10BASE-T/100BASE-TX Ethernet (EL6601)
4 x RJ45 mit 10BASE-T/100BASE-TX Ethernet (EL6614)


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EL6601 | EL6614
Bus-System | sämtliche Ethernet (IEEE 802.3)-basierenden Protokolle
Anzahl Ethernet-Ports | 1 | 4
Ethernet-Interface | 10BASE-T/100BASE-TX Ethernet mit 1 x RJ45 | 10BASE-T/100BASE-TX Ethernet mit 4 x RJ45
Leitungslänge | bis 100 m Twisted-Pair
Übertragungsrate | 10/100 Mbit/s, IEEE 802.3u Auto-Negotiation, halb- oder vollduplex bei 10 und 100 Mbit/s möglich, Einstellungen automatisch
Netzwerkvariablen | EL6601 ab Firmware 07, EL6614 ab Firmware 03: max. 32 Publisher mit insgesamt max. 1024 Byte Gesamtdaten max. 32 Subscriber mit insgesamt max. 1024 Byte Gesamtdaten
Distributed Clocks | nein
Diagnose | Status-LEDs, CoE Daten über ADS
Spannungsversorgung | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 310 mA | typ. 450 mA
Potenzialtrennung | 500 V (E-Bus/Ethernet)
Bitbreite im Prozessabbild | -
Konfiguration | TwinCAT System Manager/EtherCAT Master
Gewicht | ca. 75 g | ca. 85 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) | Waagerechter Einbaulage: -25°C ... +60°C (erweiterter Temperaturbereich) Alle anderen Einbaulagen: -25°C ... + 45°C, siehe Hinweis
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C | -40°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (Breite angereiht: 23 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig | siehe Hinweis
Zulassung | CE cULus ATEX


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die EL66xx Ethernet Switchport Klemmen können mit 2 unterschiedlichen Betriebsarten die Aufgaben der Ethernet-Konnektivität optimal erfüllen. Die beiden Betriebsarten, die auch gleichzeitig aktiv sein können, bilden sowohl den echtzeitkritischen Versand und Empfang von konfigurierten Netzwerkvariablen als auch den Nicht-echtzeitkritischen aber durchsatzstarken Transport von Standard-Ethernet-Verkehr z. B. mit IP-Protokoll ab:
▪
Echtzeitverkehr: Publisher/Subscriber, Beckhoff Netzwerkvariablen, EAP
Durch die TwinCAT-Konfiguration *.tsm wird eine EL66xx beim EtherCAT-Start so mit CoE-Parametern konfiguriert, dass sie
–
im Echtzeitzyklus über den zyklischen Datenverkehr gelieferte Daten als Publisher versendet.
–
ebenso empfangene Subscriber an den EtherCAT Master durch den zyklischen EtherCAT-Verkehr übermittelt.
Der zyklische Datenverkehr zur EL66xx wird beim EtherCAT-Start in den PDO-Einstellungen der EL66xx konfiguriert und ist online nicht veränderbar.
▪
Nicht-Echtzeitverkehr
Parallel dazu kann die EL66xx Ethernet-Frames über den azyklischen Mailbox-Verkehr (EoE = Ethernet over EtherCAT) zwischen Klemme und EtherCAT Master/TwinCAT übertragen. Diese Übertragung erfolgt durchsatzoptimiert und ggf. mit automatischer Fragmentierung - standardmäßig werden alle Telegramme, die nicht im PDO-Kontext übertragen werden, im azyklischen Kanal über EoE transportiert.
Der Datenlauf in der EL66xx kann wie folgt schematisiert werden:
Datenschema EL66xx
Die EL6601/EL6614 kann kein EtherNet Industrial Protocol (EtherNet/IP) transportieren.
Diagnose
Online Diagnose
Im CoE-Verzeichnis stehen folgende Objekte zur ersten Diagnose zur Verfügung:
▪
0xFA01, Subindex 01: Frame Counter Rx (an RJ45-Buchse ankommend).
▪
0xFA01, Subindex 02: Frame Counter Tx (ab RJ45-Buchse abgehend).
Die Werte können aus der Steuerung über PLC-Bausteine (FB_EcCoeSdoRead in TcEtherCAT.lib) ausgelesen werden.
Diese und weitere Diagnoseinformationen aus dem CoE der EL66xx sind über [image] zugänglich.
Error LED
Die rote Error-LED leuchtet 250 ms bei
▪
Ethernet Receive Overrun --> es werden allgemein mehr Ethernet Frames am RJ45-Anschluß empfangen als über EtherCAT (PDO oder Mailbox) abtransportiert werden können. Die Telegramme werden verworfen.
▪
Ethernet EoE Overrun --> es werden mehr Nicht-Realtime-Frames am RJ45-Anschluß empfangen als über EtherCAT/EoE abtransportiert werden können. Die Daten werden verworfen.
▪
Ethernet Frame Error
Falls es durch den Overrun-Fall zu Datenverlusten kommt, sind übergeordnete Protokollschichten in einem Ethernet-Netzwerk für eine erneute Übertragung zuständig.
Overrun-Fall
Im Overrun-Fall kann mit folgenden Maßnahmen entgegengewirkt werden:
•
Aktivierung Subscriber-Filter in der betroffenen EL66xx
•
Erhöhen/Verlangsamen der Zykluszeit des Publishers
•
zeitweises Unterdrücken des Publisher-Senden oder Modulo im System Manager
•
Verringern/Beschleunigen der EtherCAT-Zykluszeit des Subscribers, damit mehr Daten von der EL66xx abgeholt werden
Kabelredundanz
Wird die EL66xx in einem System mit Kabelredundanz betrieben, ist zu beachten:
▪
der Realtime-Betrieb mit Netzwerkvariablen ist möglich
▪
beim Nicht-Realtime-Betrieb mit IP-Übertragung wird der IP-Verkehr über den primären EtherCAT-Port geleitet. Es werden deshalb auch die Windows-IP-Einstellungen dieses Ports angewendet.
IP-Einstellungen EtherCAT Port
Entfällt der Link zu diesem Port, ist aus Windows heraus unter TwinCAT 2 bzw. 3 z.Z. auch keine IP-Kommunikation zu diesem Port mehr möglich.
Deshalb ist zu vermeiden, dass die Ethernet-Verbindung zwischen primärem EtherCAT-Port und dem ersten EtherCAT-Slave ausfällt, da ansonsten keine IP-Kommunikation über die EL66xx mehr möglich ist.
Verbindungsausfall zwischen primären EtherCAT-Port und 1. Slave (X)


EL66xx - Non Realtime

Produktübersicht [image] EL66xx - Non Realtime
EL66xx - Non Realtime
EL66xx und Ethernet-Transport über Mailbox-Kommunikation
Neben dem regulären zyklischen Prozessdatenaustausch verfügt ein EtherCAT-Master noch über einen weiteren Mechanismus, um Daten zu einem EtherCAT-Slave zu transportieren bzw. von diesem zu lesen. Dieser Mechanismus wird für einmaligen oder dynamisch wechselnden Datenaustausch benutzt, wie z. B. die Parametrierung eines EtherCAT-Slaves. Die Mailbox-Kommunikation kann aber auch dazu verwendet werden, um azyklisch große Datenblöcke auf Wunsch von Master oder Slave zu transportieren. Diese Zusatzkommunikation findet in den Zeiten zwischen den zyklischen Prozessdaten-Frames (den klassischen EtherCAT-Frames) auf dem EtherCAT-Bus statt.
Datendurchsatz bei Mailbox-Kommunikation
Weil die Mailbox-Kommunikation nur zwischen den regulären Prozessdaten-Frames stattfinden kann, ist der Datendurchsatz mit dieser Kommunikationsmethode abhängig von der Auslastung des EtherCAT-Busses. Damit ist auch der Ethernet-Durchsatz der EL6601 von der Auslastung des zugrundeliegenden EtherCAT-Feldbusses abhängig.
Für die EL66xx wird das EoE-Verfahren (Ethernet over EtherCAT) benutzt. Dafür sind im System Manager eigene Einstellungen vorhanden.
Datendurchsatz
Der Datendurchsatz der EL66xx an Ethernet-Frames bzw. Bytes/Sekunde ist abhängig
▪
von der EtherCAT-Zykluszeit auf dem Feldbus: je kürzer der für die Prozessdaten verwendete EtherCAT-Zyklus, desto mehr azyklische Mailbox-Abfragen können durchgeführt werden. Werden mehrere unterschiedliche EtherCAT-Zykluszeiten auf einem EtherCAT-Strang eingesetzt, ist die schnellste Zykluszeit maßgebend.
▪
von der Zeit zwischen den Prozessdatenrahmen, die für die Mailbox-Kommunikation zur Verfügung steht: je länger die Ethernet-Leitung für die azyklische Mailbox-Kommunikation frei ist, desto höher ist der Ethernet-Datendurchsatz der EL6601.
▪
von der Größe der Mailbox in Byte: je größer die Mailbox, desto mehr Ethernet-Frames kann die EL6601 in gleicher Zeit zum EtherCAT-Master verschicken bzw. von diesem annehmen.
▪
von der Anzahl der im EtherCAT-System verwendeten Klemmen, die gleichzeitig Mailbox-Kommunikation verwenden.
▪
von den EoE-Einstellungen im TwinCAT System Manager, Kapitel EoE.
Folgende Werte wurden exemplarisch ermittelt (TwinCAT 2.10, 2.11)
▪
> 5 MBit/s abgehend von der EL6601 an das Ethernet-Gerät.
▪
> 2 MBit/s ankommend an der EL6601 vom Ethernet-Gerät.
bei einer EtherCAT-Zykluszeit von 100 µs und einer Mailboxgröße von 1024 Byte.
Tipps zur Verkürzung der Antwortzeiten
Für die Verkürzung der Antwortzeiten in Ihrer Applikation (z. B. auf ping-Anfragen) empfiehlt sich folgende Vorgehensweise: Verringern sie die aktuell verwendete EtherCAT-Zykluszeit deutlich bzw. fügen Sie eine neue Task mit einer kleineren Zykluszeit ein, z. B.: 500 µs wenn Sie bisher 2.5 ms EtherCAT-Zyklus verwendet haben. Wichtig: diese Task muss auf echte IO-Prozessdaten aus den EtherCAT-Slaves zugreifen und unter Gerät EtherCAT -> Reiter EtherCAT erkennbar sein, s. Abb. Realer Frameaufbau aus dem TwinCAT System Manager
Realer Frameaufbau aus dem TwinCAT System Manager
Hinweis zu den angegeben Werten
Diese Angaben sind typisch und ohne Garantie; die Durchsatzraten können in verschiedenen Applikationen nach den o.a. Randbedingungen abweichen!
Adressvergabe
Ab FW03 kann die EL6601/6614 auch IP-Adressen an angeschlossene Geräte vergeben und arbeitet als DHCP- oder BOOTP-Server für ein Gerät. Die Einstellungen hierzu sind im System Manager (EL66xx --> Advanced Settings --> Mailbox --> EoE) wie folgt vorzunehmen:
▪
Einstellung "Switch Port", Abb. Standardeinstellung der EL66xx als Switch-Port ohne IP-Adressenvergabe.
Die EL66xx arbeitet wie ein normaler Switch und leitet Ethernet-Frames transparent an TwinCAT/Windows durch.
▪
Einstellung ""IP Port", Abb. Ab FW03: Einstellungen für dynamisch vergebene IP-Adresse
Die EL66xx arbeitet mit Adressvergabe an ein angeschlossenes Ethernet-Gerät. Im Gerät ist ein DHCP- oder BootP-Client zu aktivieren (siehe Netzwerkadaptereinstellungen im Betriebssystem). Die EL66xx antwortet auf die entsprechende DHCP/BootP-Anfrage des Geräts indem es die angegebene IP-Adresse/Subnetzmaske an das Gerät vergibt. Im DHCP-Verfahren wird diese Adresse regelmäßig vom Client erneut angefragt und vom Server/EL66xx vergeben.
Standardeinstellung der EL66xx als Switch-Port ohne IP-Adressenvergabe
Ab FW03: Einstellungen für dynamisch vergebene IP-Adresse
Dabei ist zu beachten:
▪
die Checkbox "DHCP" ist nicht zu benutzen - die Checkbox "IP-Address" aktiviert die DHCP/BootP-Funktion in der EL66xx.
▪
die Einstellungen Gateway, Maske und Server werden ebenfalls dem Client/Gerät mitgeteilt.
▪
es kann nur eine Adresse vergeben werden, d.h. es darf kein Switch mit angeschlossenen Teilnehmern nachfolgen.
▪
der Adressbereich muss mit dem des EtherCAT-Adapters übereinstimmen.
▪
DHCP Server Identifier: manche DHCP Server benötigen im Antworttelegramm eine ServerID.
Lösung für EL6601 ab FW15: Im CoE 0xF800:01 ist der Wert 0x1000 einzutragen. Wenn in der EL6601 ein Default Gateway eingetragen ist wird diese dann als DHCP Server Identifier genutzt.
Einstellungen der Mailbox
Die Mailbox-Größe kann im Beckhoff TwinCAT System Manager geändert werden:
Default Einstellungen der Mailbox
Standardmäßig ist die Mailbox auf 522 Byte Input und 522 Byte Output (20 Ahex) eingestellt, s. Abb. Default Einstellungen der Mailbox, Einträge für SyncManager 0 und 1. Zur Erhöhung des Datendurchsatzes kann die Mailbox auf bis zu 1024 Byte vergrößert werden, s. Abb. Vergrößerung der Mailbox.
Default Mailboxgröße
Ab Revision EL66xx-0000-0018 ist die Mailbox standardmäßig bereits auf 1024 Byte in beiden Richtungen eingestellt, kann also nicht weiter vergrößert werden.
Voranstehende Aussagen gelten für Klemmen mit Revision -0000, -0016 oder -0017.
Vergrößerung der Mailbox
Unter EL6601 -> Karteireiter EtherCAT -> "Erweiterte Einstellungen..." -> "Mailbox" kann die "Out Size" hexadezimal auf Werte zwischen 42dez/2 Ahex und 1024dez/400hex Byte eingestellt werden. Ethernet-Frames, die größer sind als die Mailbox der EL6601, werden von der EL6601 bzw. dem EtherCAT-Master fragmentiert und nach Durchlaufen des EtherCAT-Systems wieder zusammengesetzt.
Einstellung virtueller Switch
Die im TwinCAT-System vorhandenen EL66xx treten insgesamt als virtueller Switch auf, mit dem EtherCAT-System als "Backbone".
TwinCAT 2.11, virtueller TwinCAT Switch
Die Einstellungen dazu finden sich unter TwinCAT | Gerät EtherCAT | Erweiterte Einstellungen
TwinCAT 2.11, virtueller TwinCAT Switch
Hinweise
▪
wird eine große Anzahl an EL66xx im EtherCAT-Strang verwendet, kann es sinnvoll sein die Angabe MaxFrames zu erhöhen
▪
wird die EL66xx ausschließlich für Netzwerkvariablen-Verkehr benutzt, sollte ConnectToTcpStack deaktiviert werden
▪
IP-Routing ist standardmäßig aktiviert, dies kann auch durch Eingabe von "ipconfig /all" in der Kommandozeile (Windows) überprüft werden


EL66xx und Beckhoff Netzwerk Variablen

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen
EL66xx und Beckhoff Netzwerk Variablen
Weiterführende Informationen
•
Erklärung Netzwerkvariablen
•
Einstellungen im System Manager
•
Hinweise
•
Publisher unterdrücken
•
Subscriber filtern
•
Einrichtung TwinCAT 2.10
•
Einrichtung TwinCAT 2.11


Erklärung Netzwerkvariablen

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Erklärung Netzwerkvariablen
Erklärung Netzwerkvariablen
Netzwerkvariablen
Die EL66xx unterstützen das Versenden/Empfangen von Netzwerkvariablen. Dies gilt für die EL6601 ab Firmware 07, für die EL6614 ab Firmware 03.
Es sind in Summe maximal je 32 Publisher und Subscriber je EL66xx zulässig.
Austausch von Hardware
Wurde in der Anlage eine frühere Version der EL6601 projektiert (EL6601-0000-0000), ist ein Austausch gegen Versionen ab EL6601-0000-0017 problemlos möglich. Wurde dagegen eine Version ab EL6601-0000-0017 projektiert, ist ein Austausch gegen eine frühere Version aufgrund der dort nicht unterstützten Netzwerkvariablen nicht möglich.
Netzwerkvariablen ist der Begriff für besonders aufgebaute Ethernet-Frames, mit denen Beckhoff-Geräte untereinander in Echtzeit über Ethernet kommunizieren können. Ein solches Gerät kann Versender von Nachrichten (Publisher) oder Empfänger (Subscriber) sein.
Pro Publisher wird je ein Ethernet-Frame gesendet (Ethernet basiert). Somit können je Publisher maximal 1500 Byte Daten versendet werden. Innerhalb eines Publisher/Subscriber können wiederum mehrere Variablen - die Publisher- bzw. Subscriber-Variablen - angelegt werden.
Zu jedem sendenden/empfangenden Gerät (z. B. IPC oder EL6601) können üblicherweise mehrere Publisher/Subscriber konfiguriert werden.
Die Hierarchie am Beispiel eines Datensenders besteht also aus
▪
dem sendenden Gerät mit mindestens einer Ethernet Schnittstelle: IPC, CX, FC9011, EL6601, ...
–
FastEthernet/100 MBit und 1 GBit werden unterstützt
–
diese Ethernet-Schnittstelle ist im lokalen TwinCAT System Manager als Realtime-Ethernet-Gerät konfiguriert
▪
1..n konfigurierten Publisher - jeder Publisher wird als eigener Ethernet-Frame versendet und kann daher max. 1500 Byte umfassen
▪
1..n darin befindlichen Publisher-Variablen zur Verlinkung mit der Task/PLC
–
je Publisher-Variable werden die Anwendernutzdaten und Diagnosedaten übertragen
Spiegelbildlich ist der Aufbau auf der Empfängerseite angelegt.
Die EL66xx kann ebenfalls Publisher und Subscriber eigenständig verarbeiten, die Rahmendaten sind
▪
max. 32 Publisher und/oder Subscriber
▪
je Senderichtung (Publisher oder Subscriber) sind in Summe maximal zulässig
–
alle Publisher: 1024 Byte Gesamtdaten
–
alle Subscriber: 1024 Byte Gesamtdaten
Update der Klemme
Voranstehende Werte gelten für eine EL6601/6614-0000-0018. Die Version -0017 unterstützt nur maximal 300 Byte je Publisher/Subscriber. Wenn Sie eine -0017 einsetzen, können Sie durch ein Update der Klemme auf die Revision -0018 die o.a. Werte erreichen. Wenden Sie sich dazu an den Support.
Bei entsprechender EtherCAT-Zykluszeit sind je nach Umfang und Anzahl der in der EL66xx konfigurierten Publisher/Subscriber Realtime-Zykluszeiten bis zu <500 µs möglich.
Typische Durchsatzwerte der EL6601, FW08, Rev. EL6601-0000-0018 sind
▪
1 Publisher mit 1000 Byte, 1 Subscriber mit 1000 Byte, gleichzeitiger bidirektionaler Betrieb: 2 ms
▪
1 Publisher mit 100 Byte, 1 Subscriber mit 100 Byte, gleichzeitiger bidirektionaler Betrieb: 300 µs
Beide Kennwerte wurden mit diesem [image] ermittelt. Für das System Manager File *.tsm ist TwinCAT ab Version 2.11 erforderlich.
Am Beispiel der EL6601 wird erklärt, wie diese als Publisher oder Subscriber für Netzwerkvariablen konfiguriert werden kann. Die Dialoge unter TwinCAT 2.10 und TwinCAT 2.11 unterscheiden sich dabei geringfügig.
Die nachfolgenden Beschreibungen der Dialoge der EL6601 im TwinCAT System Manager sind ebenfalls auf die EL6614 anzuwenden.
Hinweis zum Begriff Gesamtdaten
Je Datenrichtung kann die EL6601/EL6614 ab Rev. -0018 max. 1024 Byte Gesamtdaten übertragen. Die Gesamtdaten setzen sich zusammen aus den Anwendernutzdaten (z. B. ein zu übertragendes UDINT) und Diagnosedaten der EL66xx.
Formel für Anzahl der Bytes der Diagnosedaten
▪
Richtung Publisher: 2 + ((Anzahl Publisher) * 2)
▪
Richtung Subscriber: 2 + ((Anzahl Subscriber Variablen) * 4)
Überschreitet die konfigurierte Datenmenge 1024 Byte, wird dies beim Aktivierungsversuch durch ein Meldungsfenster angezeigt:
Hinweis Überschreitung konfigurierte Datenmenge
Hinweis zum Datenumfang
Die EL66xx (EL6601 ab FW07, EL6614 ab FW03) verfügt über 8 kByte Nutzspeicher, der standardmäßig wie folgt belegt ist
Typ | Nutzumfang | Betriebsart | Belegter Speicher
Mailbox Out | 1024 Byte |  | 1024 Byte (fix)
Mailbox In | 1024 Byte |  | 1024 Byte (fix)
Publisher | 1024 Byte | 3-Puffer-Betrieb | 3072 Byte
Subscriber | 1024 Byte | 3-Puffer-Betrieb | 3072 Byte
Werden in einer Anwendung mehr Publisher oder Subscriber Daten benötigt, können die SyncManager zu Lasten der jeweils anderen Funktion verändert werden. Die Mailbox kann nicht verändert werden.


Einstellungen im System Manager

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Einstellungen im System Manager
Einstellungen im System Manager
Erscheinungsbild der Variablen
Je nach verwendeter Plattform (PC oder EL66xx) stellen sich Publisher/Subscriber unterschiedlich dar. Ein Publisher/Subscriber kann angelegt werden:
•
auf einer PC-Netzwerkschnittstelle, s. Beckhoff Netzwerk Variablen - Einstellungen
•
auf einer EL66xx
Im Folgenden ist beispielhaft eine Publisher- und eine Subscriber-Variable (Größe je 16 Bit Wort) auf einer EL6601 unter TwinCAT 2.10 eingerichtet.
Beispielkonfiguration Netzwerkvariablen auf EL6601
Prozessdaten:
▪
"CycleIdx": muss von der Applikation bedient werden, wenn sie auf der Subscriberseite ausgewertet werden soll.
▪
"CycleIndex": Subscriberseitiges Gegenstück zum CycleIdx.
▪
"VarData": die zu versendenden Daten.


Hinweise

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Hinweise
Hinweise
▪
Die RT-Statistik-Anzeigen werden unter TwinCAT bei einem EL66xx-RT-Geräts nicht unterstützt.
Lösung: Alternativ können zur Diagnose entsprechende CoE-Parameter ausgelesen werden.
▪
Die Publisher-Features "OnChangeOnly" und "DataExchange (Divider/Modulo)" werden in Verbindung mit der EL66xx nicht unterstützt.
Lösung: [ab FW08] Das Versenden der konfigurierten Publisher-Variablen kann durch DevCtrl zyklisch unterbunden werden.
▪
Wird ein Publisher auf einer EL66xx eingerichtet, muss der CycleIndex des Publishers vom Anwender bedient werden. Auf einem PC wird sie dagegen von TwinCAT inkrementiert.
▪
Zur Diagnose einer Netzwerkvariablenverbindung wird empfohlen:
1. LinkStatus im "DevState" des RT-Geräts überwachen (Gerät --> Inputs --> DevState). DevState = 0 ist der Sollzustand.
2. Quality und CycleIndex im Subscriber überwachen.
▪
Die Link-LED in der EL66xx zeigt nur den Zustand der Kabelverbindung an, nicht den einer ggf. bestehenden Netzwerkvariablenverbindung.
▪
Wird die EL66xx ausschließlich für Netzwerkvariablen-Verkehr benutzt, sollte ConnectToTcpStack deaktiviert werden.
▪
Es sind in Summe maximal je 32 Publisher und Subscriber je EL66xx zulässig.


Publisher unterdrücken

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Publisher unterdrücken
Publisher unterdrücken
Anwendbar: TwinCAT ab Version 2.11, EL6601 ab FW08, EL6614 ab FW04
Wird die EL66xx mit einer kurzen Zykluszeit und konfigurierten Publishern betrieben, kann dies eine hohe Netzwerklast im angeschlossenen Netzwerk verursachen. Deshalb kann die EL66xx so konfiguriert werden, dass durch die Variable DevCtrl das Versenden einzelner Publisher geblockt wird. Dazu muss im CoE (CanOpenOverEtherCAT) das Objekt 0xF800:02 belegt werden.
Gruppen von Publisher-Boxen können bitweise (Publisher-Frames) geblockt werden. In den obersten 4 Bit (High Nibble des High Byte) von 0xF800:02 ist die Granularität der Gruppen 1..15 anzugeben, d.h. wie viele Publisher-Frames jeweils in einer Gruppe zusammengefasst werden:
Die oberen 8 Bit von DevCtrl (Format: 16 Bit) sperren dann jeweils im aktuellen Zyklus das Versenden der in der jeweiligen Gruppe liegenden Publisher-Frames.
High-Byte von DevCtrl :
▪
0 = kein Blocken
▪
n = jedes Bit in DevCtrl bedeutet eine n-Gruppe von Publishern, n aus [1..31]
Damit können maximal 8 Gruppen von Publishern geblockt werden.
Beispiel:
DevCtrl.10=true und 0xF800:02= 0x2000 bedeutet, dass die 3.Gruppe in diesem PLC-Zyklus geblockt wird. Eine Gruppe besteht aus 2 Publisher-Frames, es werden hier also alle Publisher-Variablen, die in den Publisher-Frames 5+6 liegen, nicht versendet.
Hinweis
Unterdrückung einzelner Publisher
Die Struktur eines "Publisher" als Publisher-Box im System Manager ist
- ein Ethernet Frame, dieser enthält
- n Publisher
Die einzelnen Bits in DevCtrl blocken jeweils eine Gruppe an Publisher-Frames.
Der Erfolg der Maßnahmen kann z. B. mit einem Netzwerkmonitor wie Wireshark kontrolliert werden.
Veränderungen im CoE
Mit dem TwinCAT System Manager können online die CoE-Inhalte (wenn beschreibbar) geändert werden. Nach einem Neustart der Klemme/des EtherCAT-Systems ist diese Änderung jedoch nicht mehr vorhanden sondern wieder der Default-Wert gesetzt. Deshalb muss jede dauerhafte Änderung in der CoE-StartUp-Liste der Klemme hinterlegt werden.
Anmerkung: die Bitzählung beginnt in dieser Dokumentation bei 0: Wert.0, Wert.1, ...


Subscriber filtern

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Subscriber filtern
Subscriber filtern
Anwendbar: TwinCAT ab Version 2.11, EL6601 ab FW08, EL6614 ab FW06
In Abhängigkeit von der Konfiguration des Ethernet-Netzwerks kommen dort verwendete Publisher-Telegramme in niedriger oder hoher Anzahl bei den im Netzwerk eingesetzten EL66xx an. Beim Start wird die EL66xx durch den EtherCAT Master auf die von ihr zu empfangenden Subscriber-Variablen konfiguriert: Source AMS Net ID und ID der Variablen werden für jeden Subscriber in das CoE geladen. In den CoE-Objekten 0x60n0:01 und 0x60n0:02 sind dann jeweils die zu prüfenden AmsNetId und VariablenID enthalten. Deshalb kann die EL66xx auf die ankommenden Publisher-ID filtern und mit den eigenen Subscriber-ID vergleichen. Zu diesem Zweck werden die in den empfangenen Ethernet-Frames enthaltenen Publisher-Variablen zerlegt und einzeln geprüft.
Entspricht ein ankommender Subscriber:
▪
einer konfigurierten AMS Net ID und Variablen ID, wird der Inhalt über PDO an EtherCAT übergeben.
▪
NICHT dem oben genannten, wird der Inhalt standardmäßig an das azyklische Mailbox-Interface zur Übertragung an den Master übergeben.
Das ist die Standard-Einstellung der EL66xx.
Der zweite Weg erzeugt eine hohe azyklische EtherCAT-Transportlast, denn es werden von der EL66xx empfangene Subscriber transportiert, die von dieser EL66xx gar nicht transportiert werden sollten. Deshalb kann durch den CoE-Eintrag 0xF800:02 = 0x0100 (Bit 8 = TRUE) der Subscriber-Filter aktiviert werden. Dann werden Subscriber-Daten, die nicht dem AmsNetID/VariablenID-Filter entsprechen, in der Klemme verworfen und nicht an die Mailbox übergeben.
Subscriber filtern
Es wird empfohlen, den Subscriberfilter zu aktivieren.
Da die EL66xx bei jedem INIT-OP-Übergang neu initialisiert wird, muss der genannte CoE-Eintrag unbedingt in der StartUp-Liste gesetzt werden.
Anmerkung: die Bitzählung beginnt in dieser Dokumentation bei 0: Wert.0, Wert.1, ...


Einrichtung TwinCAT 2.10

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Einrichtung TwinCAT 2.10
Einrichtung TwinCAT 2.10
Nachdem der EtherCAT-Bus mit seinen Teilnehmern konfiguriert wurde, wird die EL6601 als eigenes Gerät im Konfigurationsbaum angefügt.
Gerät anfügen
Im Auswahldialog wird eine EL6601 als Real-Time Ethernet Gerät angeboten. Auch bei Einsatz einer EL6614 muss hier die EL6601 ausgewählt werden.
EL6601 auswählen
An die EL6601 wird nun eine imaginäre Box als Publisher oder Subscriber angefügt.
Box anfügen
Netzwerkvariable anfügen
Nun wird die das "Gerät EL6601" noch mit der realen EL6601 oder EL6614 im Auswahldialog verbunden (Karteireiter "Adapter" -> "Suchen...").
Gerät mit der EL6601 verbinden
Alle weiteren Schritte erfolgen wie in den vorhergehenden Artikeln beschrieben.


Einrichtung TwinCAT 2.11

Produktübersicht [image] EL66xx und Beckhoff Netzwerk Variablen [image] Einrichtung TwinCAT 2.11
Einrichtung TwinCAT 2.11
Wenn die EtherCAT Konfiguration manuell angelegt oder im Feld gescannt wurde, können Sie nun eine EL66xx als Sender/Empfänger von Netzwerkvariablen konfigurieren.
Neues Gerät anlegen
Im Gerätedialog wählen Sie das EAP aus:
EAP auswählen
Das neue Gerät wird automatisch einer verfügbaren EL66xx zugeordnet, dies kann auch manuell durchgeführt werden:
Gerätezuordnung zur EL66xx
Nun müssen die Sender/Empfängervariablen angelegt werden:
Box anfügen
Je EAP-Gerät können mehrere Publisher und Subscriber angelegt werden.
Publisher/Subscriber
In der Topologie-Ansicht taucht ein EAP-Gerät wie folgt auf:
Topologieansicht
Alle weiteren Schritte erfolgen wie in den vorhergehenden Artikeln beschrieben.


Konfiguration am CX20x0 & CX50x0 System

Produktübersicht [image] Konfiguration am CX20x0 & CX50x0 System
Konfiguration am CX20x0 & CX50x0 System
Die Embedded PC der Serie CX20x0 und CX50x0 bieten die Besonderheit des integrierten I/O-Interfaces für E-Bus und K-Bus mit automatischer Umschaltung. Die im TwinCAT-System vorhandenen EL66xx Teilnehmer treten insgesamt als virtueller Switch auf, mit dem EtherCAT-System als "Backbone". Die interne Anbindung der Schnittstelle wird beim CX20x0 und CX50x0 System nicht über eine Netzwerkschnittstelle, sondern über ein FPGA realisiert.
Virtueller TwinCAT Switch im CX20x0 & CX50x0 System
Auf Grund der internen Anbindung per FPGA und der automatischen E-Bus / K-Bus Erkennung wird bei der Offline-Konfiguration der Ethernet Port erst bei Aktivierung der Konfiguration sichtbar. Soll der Ethernet Port bereits offline konfiguriert werden, so ist wie folgt vorzugehen:
▪
Auf Grund der automatischen E-Bus und K-Bus Umschaltung ist eine beliebige Klemme mit dem entsprechendem Bus zu stecken
▪
Der interne PCI Port wird bei der Offline-Konfiguration erkannt und muss ausgewählt werden
Dialog zur Auswahl des PCI Ports
▪
Die kundenspezifische Konfiguration kann erstellt und die EL66xx kann in die Konfiguration eingefügt werden
Einfügen der EL66xx in die Konfiguration
▪
Nach "Neuladen der E/A Geräte" (F4) wird der Ethernet Port erkannt und taucht unter den Netzwerkverbindungen neu auf
▪
als "Local Area Connection 4"
Neues Netzwerk „Local Area Connection“ in den Windows Netzwerkverbindungen
▪
Der Port kann nun den Anforderungen entsprechend parametriert werden. Die Einstellungen werden übernommen und gespeichert. Auch wenn der Port wieder verschwindet, so bleiben die getätigten Einstellungen für die spätere Inbetriebnahme erhalten.
Besteht weiterhin das Problem, dass der Ethernet Port der EL66xx nicht in der Netzwerkverbindung auftaucht, so kann dies nachfolgende Ursachen haben. Diese sind zu prüfen und die aufgeführten Gegenmaßnahmen sind zu ergreifen.
Voraussetzungen
Es gilt zu prüfen:
Virtueller Ethernet Switch ist nicht aktiviert | Einstellungen virtueller Switch und entsprechende Hinweise sind zu prüfen
TwinCAT2 und TwinCAT3 sind gleichzeitig installiert | möglicher Treiber-Konflikt, bitte an den Beckhoff Support wenden


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Empfohlene Tragschienen
•
Montage und Demontage - Frontentriegelung oben
•
Positionierung von passiven Klemmen
•
Einbaulagen
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Empfohlene Tragschienen

Montage und Verdrahtung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
▪
Tragschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
▪
Tragschiene TH 35-15 mit 1,5 mm Materialstärke
Materialstärke der Tragschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Tragschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Montage und Demontage - Frontentriegelung oben

Montage und Verdrahtung [image] Montage und Demontage - Frontentriegelung oben
Montage und Demontage - Frontentriegelung oben
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen.
▪
Ziehen Sie mit Daumen und Zeigefinger die orange Entriegelungslasche (3) zurück. Dabei ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück.

▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg. Vermeiden Sie ein Verkanten; stabilisieren Sie das Modul ggf. mit der freien Hand


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Objektbeschreibung und Parametrierung
•
Beckhoff Netzwerkvariablen


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind.
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Objekte für die Inbetriebnahme
•
Objekte für den regulären Betrieb
•
Standardobjekte (0x1000-0x1FFF)
•
Profilspezifische Objekte (0x6000-0xFFFF)


Objekte für die Inbetriebnahme

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Objekte für die Inbetriebnahme
Objekte für die Inbetriebnahme
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x19C93052 (432615506dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index F800 EL6601 Para
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F800:0 | EL6601 Para | Max. Subindex | UINT8 | RW | 0x02 (2dez)
F800:01 | General | 0x0000: Standardbetrieb 0x0001: VLAN TAGS werden vor der Filterung entfernt. 0x4000: EoE Frames werden blockiert | UINT16 | RW | 0x0000 (0dez)
F800:02 | NetVars | Dieser Schalter bestimmt, ob empfangene Subscriberdaten aus Frames mit 0x88A4 im Header, die den Subscriber-Filter nicht passiert haben, über EoE/Mailbox zum EtherCAT Master weitertransportiert werden. 0x0000: default, Subscriberdaten werden über EoE weitergeleitet 0x0100: Subscriberdaten werden verworfen | UINT16 | RW | 0x0000 (0dez)


Objekte für den regulären Betrieb

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Objekte für den regulären Betrieb
Objekte für den regulären Betrieb
Index F100 Master Info
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F100:0 | Master Info | Max. Subindex | UINT8 | RO | 0x02 (2dez)
F100:01 | Status | Link Status des Ethernet-Ports 0: Link 1: kein Link | UINT16 | RO | 0x0000 (0dez)
F100:02 | Control | reserviert | UINT16 | RO | 0x0000 (0dez)
Index FA01 MAC Info
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FA01:0 | MAC Info | Max. Subindex | UINT8 | RW | 0x03 (3dez)
FA01:01 | RxPackets | Empfangene Ethernet-Telegramme | UINT16 | RW | 0x0000 (0dez)
FA01:02 | TxPackets | Gesendete Ethernet-Telegramme | UINT16 | RW | 0x0000 (0dez)
FA01:03 | Reserved | Reserviert | UINT16 | RW | 0x0000 (0dez)


Standardobjekte (0x1000-0x1FFF)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Standardobjekte (0x1000-0x1FFF)
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5002). | UINT32 | RO | 0x0000138A (5002dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | z.B. EL6601-0000-0017
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 1600-16FE RxPDO-Map
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600+n:0 | RxPDO-Map | PDO Mapping RxPDO (jedes Modul erhält einen eigenen Eintrag (Index 0x1600+n), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW | 0x02 (2dez)
(1600+n):01 | Output Mapping Area 001 | 1. PDO Mapping Eintrag (Objekt 7000+n*8:07) | UINT32 | RW | 0x7000+n*8:07, 16
(1600+n):02 | Output Mapping Area 002 | 2. PDO Mapping Eintrag (Objekt 7000+n*8:0B) | UINT32 | RW | 0x7000+n*8:0B, 16
Index 1680 PDO control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1680:0 | PDO control | Max. Subindex | UINT8 | RW | 0x01 (1dez)
1680:01 | PDO control | Eintrag Master Control | UINT32 | RW | 0xF100:02, 16
Index 1A00-1AFE TxPDO-Map
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00+n:0 | TxPDO-Map Ch.2 | PDO Mapping TxPDO (jedes Modul erhält einen eigenen Eintrag (Index 0x1A00+n), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW | 0x03 (3dez)
(1A00+n):01 | Input Mapping Area 001 | 1. PDO Mapping Eintrag (Objekt 0x6000+n*8:03) | UINT32 | RW | 0x6000+n*8:03, 16
(1A00+n):02 | Input Mapping Area 002 | 2. PDO Mapping Eintrag (Objekt 0x6000+n*8:04) | UINT32 | RW | 0x6000+n*8:04, 16
(1A00+n):03 | Input Mapping Area 003 | 3. PDO Mapping Eintrag (Objekt 0x6000+n*8:05) | UINT32 | RW | 0x6000+n*8:05, 16
Index 1A80 PDO status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1680:0 | PDO status | Max. Subindex | UINT8 | RW | 0x01 (1dez)
1680:01 | PDO status | Eintrag Master Status | UINT32 | RW | 0xF100:01, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x02 (2dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Outputs | UINT8 | RO | 0x02 (2dec)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Inputs | UINT8 | RO | 0x02 (2dec)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | -
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT32 | RW | 0x1600 (5632dez)
... |  |  |  |  |
1C12:80 | SubIndex 128 | 128. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT32 | RW | 0x167F (5759dez)
1C12:81 | SubIndex 129 | PDO Control | UINT32 | RW | 0x1680 (5760dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | -
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT32 | RW | 0x1A00 (6656dez)
... |  |  |  |  |
1C13:80 | SubIndex 128 | 128. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT32 | RW | 0x1A7F (6783dez)
1C13:81 | SubIndex 129 | PDO Status | UINT32 | RW | 0x1A80 (6784dez)
Index 1C32 SM output parameter (nur bei Netzwerkvariablen)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RW
0x0E (14dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
1: Synchron with SM 2 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RW
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
UINT16
RW
0x0002 (2dez)
Index 1C33 SM input parameter (nur bei Netzwerkvariablen)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RW
0x0E (14dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RW
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
UINT16
RW
0x0002 (2dez)


Profilspezifische Objekte (0x6000-0xFFFF)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Profilspezifische Objekte (0x6000-0xFFFF)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 6000-67F8 Receiving Frame Data (Net Var Subscriber)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000+n*8:0 | Receiving Frame Data (Net Var Subscriber) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x6000+n*8), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW P | 0x05 (5dez)
(6000+n*8):01 | Net Id | Source AMS Net Id | UINT48 | RW P | -
(6000+n*8):02 | Var Id | Identifikation der Netzwerkvariable | UINT16 | RW P | 0x0001 (1dez)
(6000+n*8):03 | Quality | Dauer, in der die Variable nicht aktualisiert wurde (Auflösung 100 µs) | UINT16 | RO P | 0x0000 (0dez)
(6000+n*8):04 | Cycle Index | Eintrag wird mit jedem Publisher-Zyklus inkrementiert | UINT16 | RO P | 0x0000 (0dez)
(6000+n*8):05 | Data area 001 | Daten-Bereich | OCTED_STRING | RO P | 00 00
Index 6001-67F9 Sending frame State (Frame status)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6001+n*8:0 | Sending frame State (Frame status) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x6001+n*8), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW P | 0x01 (1dez)
(6001+n*8):01 | Frame status | Status • Bit 0: Frame übersprungen • Bit 1: Frame zu groß | UINT16 | RW P | 0x0000 (0dez)
Index 6002-67FA Receiving Frame Identification (Ignore Item Net Var Subscriber)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
6002+n*8:0 | Receiving Frame Identification (Ignore Item Net Var Subscriber) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x6002+n*8), 0 ≤ n < maximale Anzahl der Module |  | UINT8 | RW P | 0x05 (5dez)
(6002+n*8):01 | Net Id | "Net Id" | 0: Eintrag wird überprüft, wenn Gleichheit festgestellt wird, werden die entsprechenden Datenbereiche in die Prozessdaten übernommen. 1: Eintrag wird übersprungen, entsprechende Datenbereiche werden nicht in die Prozessdaten übernommen. | UINT8 | RW P | 0x01 (1dez)
(6002+n*8):02 | Var Id | "Var Id" |  | UINT8 | RW P | 0x00 (0dez)
(6002+n*8):03 | Quality | "Quality" |  | UINT8 | RW P | 0x01 (1dez)
(6002+n*8):04 | Cycle Index | "Cycle Index" |  | UINT8 | RW P | 0x01 (1dez)
(6002+n*8):05 | Data area 001 | "Data area 001" |  | UINT8 | RW P | 0x01 (1dez)
Index 6003-67FB Receiving Frame Length (Area Length Nat Var Subscriber)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6003+n*8:0 | Receiving Frame Length (Area Length Nat Var Subscriber) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x6003+n*8), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW P | 0x05 (5dez)
(6003+n*8):01 | Net Id | Länge des "Net Id"-Feldes | UINT16 | RW P | 0x0006 (6dez)
(6003+n*8):02 | Var Id | Länge des "Var Id"-Feldes | UINT16 | RW P | 0x0002 (2dez)
(6003+n*8):03 | Quality | Länge des "Quality"-Feldes | UINT16 | RW P | 0x0002 (2dez)
(6003+n*8):04 | Cycle Index | Länge des "Cycle Index"-Feldes | UINT16 | RW P | 0x0002 (2dez)
(6003+n*8):05 | Data area 001 | Länge des "Data area"-Feldes | UINT16 | RW P | 0x0002 (2dez)
Index 7000-77F8 Sending Frame Data (Net Var Publisher)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000+n*8:0 | Sending Frame Data (Net Var Publisher) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x7000+n*8), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW P | -
(7000+n*8):01 | Destination MAC address | MAC-Ziel-Adresse Ethernet-Telegramm | UINT48 | RW P | -
(7000+n*8):02 | Source MAC address | MAC-Quellen-Adresse Ethernet-Telegramm | UINT48 | RW P | -
(7000+n*8):03 | Ethernet Type | Beckhoff Ethertype | UINT16 | RW P | 0x88A4 (42120dez)
(7000+n*8):04 | Header | Bit 0-10: Länge der folgenden Einträge Bit 11: 0, Bit 12-15: 4, Netzwerkvariable -Type | UINT16 | RW P | -
(7000+n*8):05 | Net Id | Source AMS Net Id | UINT48 | RW P | -
(7000+n*8):06 | # of Vars | Anzahl der Variablen | UINT16 | RW P | -
(7000+n*8):07 | Cycle Index | Eintrag wird mit jedem Publisher-Zyklus inkrementiert | UINT16 | RO P | -
(7000+n*8):08 | reserved | reserviert | UINT16 | RW P | -
(7000+n*8):09 | Net Var 001 Id | Identifikation der Netzwerkvariable | UINT16 | RW P | -
(7000+n*8):0A | Net Var 001 Header | Byte 0,1: Hash-Wert Byte 2,3: Länge der Daten Byte 4,5: Quality | UINT48 | RW P | -
(7000+n*8):0B | Net Var 001 Data | Daten-Bereich | STRING | RO P | -
- |  |  |  |  |
(7000+n*8) :(3*y+6) | Net Var y Id | Identifikation der Netzwerkvariable | UINT16 | RW P | -
(7000+n*8) :(3*y+7) | Net Var y Header | Byte 0,1: Hash-Wert Byte 2,3: Länge der Daten Byte 4,5: Quality | UINT48 | RW P | -
(7000+n*8) :(3*y+8) | Net Var y Data | Daten-Bereich | OCTED_STRING | RO P | -
Index 7001-77F9 Sending Frame Control (Frame control)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7001+n*8:0 | Sending Frame Control (Frame control) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x7001+n*8), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW P | 0x01 (1dez)
(7001+n*8):01 | Frame Control | Frame Control • Bit 0 = 0: Sende Frame • Bit 0 = 1: Überspringe Frame | UINT8 | RW P | 0x00 (0dez)
Index 7003-77FB Sending Frame Length (Area length Net Var Publisher)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7003+n*8:0 | Sending Frame Length (Area length Net Var Publisher) | Max. Subindex (jedes Modul erhält einen eigenen Eintrag (Index 0x7003+n*8), 0 ≤ n < maximale Anzahl der Module | UINT8 | RW P | -
(7003+n*8):01 | Destination MAC address | MAC-Ziel-Adresse Ethernet-Telegramm | UINT48 | RW P | -
(7003+n*8):02 | Source MAC address | MAC-Quellen-Adresse Ethernet-Telegramm | UINT48 | RW P | -
(7003+n*8):03 | Ethernet Type | Beckhoff Ethertype | UINT16 | RW P | 0x88A4 (42120dez)
(7003+n*8):04 | Header | Bit 0-10: Länge der folgenden Einträge Bit 11: 0, Bit 12-15: 4, Netzwerkvariable -Type | UINT16 | RW P | -
(7003+n*8):05 | Net Id | Source AMS Net Id | UINT48 | RW P | -
(7003+n*8):06 | # of Vars | Anzahl der Variablen | UINT16 | RW P | -
(7003+n*8):07 | Cycle Index | Eintrag wird mit jedem Publisher-Zyklus inkrementiert | UINT16 | RW P | -
(7003+n*8):08 | reserved | reserviert | UINT16 | RW P | -
(7003+n*8):09 | Net Var 001 Id | Identifikation der Netzwerkvariable | UINT16 | RW P | -
(7003+n*8):0A | Net Var 001 Header | Byte 0,1: Hash-Wert Byte 2,3: Länge der Daten Byte 4,5: Quality | UINT48 | RW P | -
(7003+n*8):0B | Net Var 001 Data | Daten-Bereich | STRING | RW P | -
- |  |  |  |  |
(7003+n*8) :(3*y+6) | Net Var y Id | Identifikation der Netzwerkvariable | UINT16 | RW P | -
(7003+n*8) :(3*y+7) | Net Var y Header | Byte 0,1: Hash-Wert Byte 2,3: Länge der Daten Byte 4,5: Quality | UINT48 | RW P | -
(7003+n*8) :(3*y+8) | Net Var y Data | Daten-Bereich | OCTED_STRING | RW P | -
Index 8000-87F8 Frame Config
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000+n*8:0 | Frame Config | Max. SubIndex | UINT8 | RW | 0x04 (4dez)
(8000+n*8):04 | Device Type | 3: Subscriber-Netzwerkvariable, entsprechende Indizes 600x werden angelegt. 4: Publisher-Netzwerkvariable, entsprechende Indizes 0x700x werden angelegt. | UINT16 | RW | -
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x04 (4dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0008 (8dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x00FF (255dez)
F000:03 | Standard Entries in Object 0x8yy0 | Standard Einträge in den Objekten 0x8yy0 | UINT32 | RO | 0x00000000 (0ez)
F000:04 | Standard Entries in Object 0x9yy0 | Standard Einträge in den Objekten 0x8yy0 | UINT32 | RO | 0x00000000 (0dez)


Beckhoff Netzwerkvariablen

Inbetriebnahme [image] Beckhoff Netzwerkvariablen
Beckhoff Netzwerkvariablen
Weiterführende Informationen
•
Einführung
•
Konfiguration vom Publisher
•
Konfiguration vom Subscriber
•
Beckhoff Netzwerk Variablen - Einstellungen


Einführung

Inbetriebnahme [image] Beckhoff Netzwerkvariablen [image] Einführung
Einführung
Netzwerkvariablen sind beliebige Variablen, die zwischen PC/CX1000 mit TwinCAT zyklisch ausgetauscht werden können. Es können Variablen mit beliebigen, auch komplexen, Datentypen ausgetauscht werden. Es wird das Publisher/Subscriber Modell verwendet. Zur hochdeterministischen Kommunikation muss der Echtzeit-Ethernet Treiber für TwinCAT installiert sein.
Publisher/Subscriber Modell
Beim Publisher/Subscriber Modell stellt der Publisher Variablen zur Verfügung. Subscriber können sich für eine Variable einschreiben. Der Publisher kann die Variable einem Subscriber, mehreren Subscribern oder allen Subscribern zur Verfügung stellen. Bei Broadcast wird die Variable allen PCs zur Verfügung gestellt, bei Multicast einigen Ausgewählten und bei Unicast einem einzigen ausgesuchten PC. Ein Subscriber kann gleichzeitig auch Publisher sein. Damit kann auch eine bidirektionale Datenverbindung hergestellt werden.
Publisher/Subscriber Modell
Unicast
Der Publisher stellt die Netzwerkvariable nur einem einzigen ausgesuchten PC zur Verfügung.
Multicast
Der Publisher stellt die Netzwerkvariable einigen ausgesuchten PCs zur Verfügung.
Broadcast
Der Publisher stellt die Netzwerkvariable allen PCs zur Verfügung.


Konfiguration vom Publisher

Inbetriebnahme [image] Beckhoff Netzwerkvariablen [image] Konfiguration vom Publisher
Konfiguration vom Publisher
Im TwinCAT System Manager wird unterhalb des Gerätes RT-Ethernet eine neue Box für den Publisher eingefügt.
Einfügen einer Publisher Box
Unterhalb des Gerätes RT-Ethernet muß für einen Publisher eine einsprechende Box angefügt werden.
Einfügen einer Publisher Box in die TwinCAT Konfiguration
Einfügen einer Netzwerkvariablen
Unterhalb der Box werden die Netzwerkvariablen eingefügt. Dazu ist es nötig, einen Namen (im Beispiel nCounterPub) und einen Datentyp (im Beispiel UINT32 entsprechend UDINT) anzugeben.
Einfügen einer Netzwerk Variablen
Unterhalb der eingefügten Variablen sind Eingänge und Ausgänge angelegt worden.
Inputs/Outputs der eingefügten Variablen
Der FrameState Eingang unterhalb der Box gibt Auskunft über den momentanen Status der versendeten Ethernet Frames.
Folgende Werte sind für den FrameState möglich:
Kurzbeschreibung | Wert | Beschreibung
Not sent (frame skipped) | 0x0001 |
Error (frame oversized) | 0x0001 | Die maximale Größe eines Ethernet Frames ist überschritten worden. Die verknüpfte Variable muss kleiner gewählt werden.
Im FrameCtrl Ausgang unterhalb der Box kann ein Control Wort geschrieben werden.
Folgende Werte sind für das FrameCtrl möglich:
Kurzbeschreibung | Wert | Beschreibung
Disable sending | 0x0001 | Das Senden des Frames wird unterbrochen. Erst wenn der Wert wieder auf 0 ist, beginnt das Senden des Frames erneut.
Der VarState Eingang unterhalb der Netzwerkvariablen gibt Auskunft über den momentanen Status der Netzwerkvariablen.
Folgende Werte sind für den VarState möglich:
Kurzbeschreibung | Wert | Beschreibung
Not sent (variable skipped) | 0x0001 |
Im VarCtrl Ausgang unterhalb der Netzwerkvariablen kann ein Control Wort geschrieben werden
Folgende Werte sind für das FrameCtrl möglich:
Kurzbeschreibung | Wert | Beschreibung
Disable publishing | 0x0001 | Das Senden der Netzwerkvariablen wird unterbrochen. Erst wenn der Wert wieder auf 0 ist, beginnt das Senden der Netzwerkvariablen erneut.
Verknüpfungen
Die Netzwerkvariable des Publishers kann mit jeder beliebigen Ausgangsvariablen des passenden Datentyps verknüpft werden. Im Beispiel wird die Netzwerkvariable mit einer Ausgangsvariablen einer SPS verknüpft.
Verknüpfung der Netzwerkvariablen mit der Ausgangsvariablen einer SPS


Konfiguration vom Subscriber

Inbetriebnahme [image] Beckhoff Netzwerkvariablen [image] Konfiguration vom Subscriber
Konfiguration vom Subscriber
Im TwinCAT System Manager wird unterhalb des Gerätes RT-Ethernet eine neue Box für den Subscriber eingefügt.
Einfügen einer Subscriber Box und Verbindung der Netzwerkvariablen
Unterhalb des Gerätes RT-Ethernet muss für einen Subscriber eine einsprechende Box angefügt werden.
Anlegen eines RT-Ethernet Devices
Anlegen einer Subscriber Box (“Box 1“)
Unterhalb der Subscriber Box wird dann eine Netzwerkvariable angelegt.
TwinCAT-Baum mit „Box 1“ Subscriber Box
Mit Rechtsklick Netzwerkvariable anlegen
Die Verbindung zu einer Variablen eines Publishers kann automatisch hergestellt werden. Hierzu ist der Publisher Computer zu suchen. In einer Liste werden alle Variablen dieses Publishers aufgelistet.
Suchen des Publisher Computers
Unterhalb der jetzt eingefügten Variablen sind Eingänge und Ausgänge angelegt worden.
Angelegte Ein-/Ausgänge der eingefügten Variablen
Der FrameState Eingang und der FrameCtrl Ausgang unterhalb der Box geben Auskunft über den momentanen Status bzw. Control der empfangenen Ethernet Frames. FrameState und FrameCtrl sind reserviert und werden momentan nicht unterstützt.
Der VarState Eingang und der VarCtrl Ausgang unterhalb der Netzwerkvariablen geben Auskunft über den momentanen Status bzw. Control der empfangenen Netzwerkvariablen. VarState und VarCtrl sind reserviert und werden momentan nicht unterstützt.
Qualität der Netzwerkvariablen
Die Qualität einer Netzwerkvariablen wird auf der Subscriber Seite beurteilt. Hierzu stehen zwei Eingangsvariablen unterhalb der Netzwerkvariablen zur Verfügung. Die Variable Quality liefert einen Zähler in 100 µs Auflösung. Der Zählerwert zeigt an, wie lange die Variable zu spät eintrifft. Das untere Beispiel zeigt den Online-Wert von Quality, nach Ziehen des Netzwerksteckers (Anstieg des Zählers) und erneutem Neuverbinden (Zählerstand 0).
Zeitdiagramm (Online-Wert) der Quality Variablen
Neben der Quality Variablen wird die CycleIndex Variable bei jedem Publisher Zyklus inkrementiert.
Zeitdiagramm (Online-Wert) der CycleIndex Variablen


Beckhoff Netzwerk Variablen - Einstellungen

Inbetriebnahme [image] Beckhoff Netzwerkvariablen [image] Beckhoff Netzwerk Variablen - Einstellungen
Beckhoff Netzwerk Variablen - Einstellungen
Mit den Beckhoff Netzwerkvariablen (NWV) können zyklisch oder azyklisch Daten zwischen Windows-basierten PC verschickt werden. In einem Teilnehmer als Publisher (Sender) deklariert, wird eine solche Netzwerkvariable auf der Gegenseite von einem mit dem gleichen Typ deklarierten Subscriber (Abonnent) empfangen. Dieser Datenverkehr ist dem Namen nach netzwerkbasiert und setzt in seiner Konfiguration direkt auf den verwendeten Protokollen auf.
Zur Auswahl stehen dabei:
▪
MAC: Es wird ein ISO-Layer-2-Frame mit einer Absender- und Empfänger-MAC-Adresse verschickt, Ethertype 0x0806. Ein IP-Teil mit Ziel-IP-Adresse (z. B. 192.168.0.1) ist nicht enthalten. Deshalb kann das Telegramm über einen Switch, normalerweise aber nicht über einen Router weiterverarbeitet werden.
MAC bedeutet Media Access Control und steht hier für die (eindeutige) Hardware-Adresse, die jedes Ethernet-Gerät ab Herstellung hat. Der Ethernet-Port eines Beckhoff-PC könnte z. B. die MAC-Kennung 00:01:05:34:05.84 haben - "00:01:05" ist die Beckhoff-Kennung, der Rest bei der Herstellung gewählt. Über die Quell/Source-MAC und die Ziel/Destination-MAC-Adresse ist der Weg eines jeden Ethernet-Telegramms zwischen 2 Ethernet-Kabelenden bestimmt.
Das Ethernet-Telegramm wird durch den Ethertype 0x88A4 als Beckhoff Echtzeit-Ethernet identifiziert - als "Echtzeit Ethernet-Telegramm" (RT-Ethernet) wird es am regulären Windows-TCP-Stack vorbeigeschleust und bevorzugt d.h. "sofort" über den angegebenen Ethernetport des PC versendet.
Es ist einstellbar, ob das gesendete Telegramm von allen (Broadcast), vielen (Multicast) oder einem einzigen Subscriber (Unicast) empfangen werden soll.
▪
UDP/IP: Der Empfänger wird über einen zusätzlichen IP-Header im Ethernet-Telegramm identifiziert, der UDP-Ethernet-Frame kann damit über einen Router weiterverarbeitet werden.
Auch hier stehen Broad-, Multi- und Unicast zur Verfügung und das Ethernet-Telegramm wird durch den Ethertype 0x88A4 als Beckhoff Echtzeit-Ethernet identifiziert und als RT-Protokoll im TwinCAT-PC behandelt.
Als verbindungsloses Protokoll verlangt UDP im Gegensatz zu TCP keine Empfangsbestätigung der Nachricht, der Publisher weiß also nicht ob der Subscriber die Nachricht empfangen hat. Deshalb wird zur Gegenstellenüberwachung von TwinCAT das ARP-Protokoll eingesetzt.
Über diese Adressierungsarten kommt das Telegramm mit den Prozessdaten beim Empfängergerät (Netzwerkport) an. Im Ethernet-Gerät/TwinCAT wird die Zuordnung mehrerer transportierter Prozessdaten dann über eine "Variable ID" hergestellt
Alle zu verwendenden Netzwerkvariablen müssen vor der Benutzung im System Manager deklariert werden.
Folgende Eingriffsmöglichkeiten stehen dann während des Betriebs zur Verfügung:
▪
das Versenden einer konfigurierten Netzwerkvariable kann dynamisch gesperrt werden
▪
die Ziel-IP oder Ziel-MAC kann dynamisch verändert werden
▪
Die Variablen-ID "Variable ID" kann dynamisch verändert werden
▪
der NWV-Inhalt kann verändert werden, nicht aber der Umfang (Bitgröße)
Diagnosevariablen auf Publisher- und Subscriber-Seite geben über die Verbindungsqualität Auskunft.
Bei der Verwendung von Netzwerkvariablen sind die zeitlichen Randbedingungen der verwendeten Netzwerkarchitektur zu berücksichtigen: bei IP-Adressierung (geroutet) können fallweise einige 100 ms Kommunikationszyklus erreicht werden, bei MAC-Adressierung (geswitcht) ca. 10 ms und weniger.
Diagnosevariable "Quality"
Wenn die verarbeitenden Tasks mit unterschiedlichen Zykluszeiten arbeiten oder vom Anwender der DataExchangeDivider verändert wird, ist das bei der Auswertung der Diagnosevariablen entsprechend zu berücksichtigen - ein langsamer Publisher (z. B. 100 ms) führt bei einem schnellen Subscriber (z. B. 10 ms) zu einer schlechten Verbindungsqualität im Sinne der Diagnosevariable "Quality".
Ebenso ist zu berücksichtigen, wenn das Versenden eines Publishers dynamisch zeitweise gesperrt wird. Der Subscriber registriert dann eine schlechte Quality.
Diagnosevariable "CycleIndex"
Beachten Sie die unteren Hinweise um zu entscheiden, ob die Variable CycleIndex von Ihnen bedient werden muss.
Grundlagen zu Beckhoff Netzwerkvariablen
▪
Quality:
Zeit in [100 µs], um die diese NWV zu spät beim Publisher ankam.
Bezogener Ankunftsort:
Eingangsprozessabbild des TwinCAT-Systems
Bezogene Ankunftszeit:
Zeitpunkt, wenn im nächsten Zyklus das Eingangsabbild geladen wird

Hinweis:
Die angezeigte "Verspätung" wird deshalb so fein skaliert ermittelt, weil die NWV-Verwaltung zyklusunabhängig direkt vom IO-Treiber verwaltet wird. Ungeachtet dessen werden die Daten einer um einige Prozent der Zykluszeit zu spät angekommene NWV erst im nächsten Task-Zyklus mit dem Lesen des Eingangsprozessabbildes berücksichtigt.

Hinweis EL6601/EL6614:
Auch bei Verwendung der EL66xx ist der Ankunftszeitpunkt der NWV dann, wenn die Daten im Eingangsprozessabbild des RT-Gerätes vorliegen, nicht wenn sie bei der EL66xx oder im Eingangsabbild des EtherCAT-Gerätes ankommen.
Zusammenhang Quality und verspätet angekommenen Netzwerkvariable
▪
Variable ID
Die Variablen-ID (16 Bit) dient zur globalen Identifizierung der einzelnen Prozessdaten - deshalb darf innerhalb eines TwinCAT-Devices eine ID in der Gruppe der Publisher oder Subscriber nicht mehrmals verwendet werden, s. Abb. Beispielhafte Kommunikation über Netzwerkvariablen: Publisher 1 und 2 auf PC1 müssen unterschiedliche ID (10 und 8) haben, in Publisher 2 und Subscriber 1 darf aber jeweils eine ID = 8 verwendet werden.
Auswahl der Variablen-ID
Um eine eindeutige Zuordnung zu erreichen wird empfohlen, für jede Datenübertragung zwischen zusammenhängenden PCs unterschiedliche IDs zu verwenden. Begründung: in Abb. Beispielhafte Kommunikation über Netzwerkvariablen erhält PC2/Subscriber2 nicht nur die vorgesehene ID=8-Variable von PC1/Publisher2, sondern, da als Broadcast (!) gesendet, auch die NWV von PC3/Publisher1. Eine Unterscheidung ist in PC2 dann nicht mehr möglich!
▪
Cycle Index
Der 16 Bit Cycle Index ist ein Zähler, der vom Publisher mit den Daten mitgesendet wird. Üblicherweise wird er mit jeder Sendung inkrementiert und lässt so einen Rückschluss auf eine ununterbrochene Übertragung zu. Er ist auf der Subscriber-Seite als CycleIndex auslesbar. Dabei unterscheidet sich sein Auftreten je nach Publisher-Plattform:
- Publisher auf einem PC: die Variable CycleIndex ist nicht sichtbar und wird automatisch zyklisch vom System Manager inkrementiert
- Publisher auf einer EL66xx: die Variable CycleIndex ist sichtbar und muss vom Anwender inkrementiert/bedient werden, damit sie auf der Subscriber-Seite ungleich 0 ist.
Beispielhafte Kommunikation über Netzwerkvariablen
Datendarstellung auf unterschiedlichen Plattformen
Bitte beachten Sie, dass einfache wie komplexe Daten (WORD, ARRAYs, REAL, STRING, benutzerdefinierte Strukturen) auf unterschiedlichen Plattformen intern unterschiedlich dargestellt werden!
x86-Plattformen arbeiten im Byte-Alignment, andere (ARM) im 2- oder 4-Byte-Alignment.
Das bedeutet, wenn eine komplexe Struktur in je einem x86/PC-PLC-Projekt und einem ARM-PLC-Projekt angelegt wird, sie jeweils eine andere effektive Größe und einen anderen inneren Aufbau haben kann. (siehe Abb. „Datendarstellung z.B. x86 Systeme vs. ARM Systeme“)
Im Beispiel ist die Struktur im CX (und damit die dort anzulegende Netzwerkvariable) größer als im PC, auch passen die Word- und Real-Variablen nicht zueinander da im PC auf jeder Byte-Position eine Variable beginnen kann, im CX nur an jeder geradezahligen.
Folgen
Empfehlung zum Aufbau von Strukturen, gleichlautend auf beiden Endgeräten
- Zuerst alle 4-Byte-Variablen (müssen auf einer durch 4 teilbaren Adresse liegen)
- dann alle 2-Byte-Variablen (müssen auf einer durch 2 teilbaren Adresse liegen)
- dann alle 1-Byte-Variablen
Weitere Empfehlungen
- wenn STRING(x) verwendet wird, gilt das „EndOfString“-Null ebenfalls als Zeichen, somit muss x+1 durch 4 teilbar sein
- obige Regeln gelten auch für Unter-Strukturen.
Bitte beachten Sie dazu die Hinweise im Infosys, Abschnitt Struktur.
Folgen
Verwendung von Busklemmen-Controllern (BICxxxx, BXxxxx)
Da auf Busklemmen-Controllern (BCxxxx, BXxxxx) die Darstellung von Fließkommazahlen (REAL) von der im x86 abweicht, können diese nicht übertragen werden. Für vorzeichenbehaftete Werte können z. B. „SINT“ verwendet werden.
Datendarstellung z.B. x86 Systeme vs. ARM Systeme
Einstellungen im System Manager
Erscheinungsbild der Variablen
Je nach verwendeter Plattform (PC oder EL66xx) stellen sich Publisher/Subscriber unterschiedlich dar. Ein Publisher/Subscriber kann angelegt werden
•
auf einer PC-Netzwerkschnittstelle, s. Abb. Einstellungen Publisher - RT Ethernet
•
auf einer EL66xx, s. Beckhoff Netzwerk Variablen - Einstellungen
Folgende Einstellungen können im Beckhoff System Manager TwinCAT 2.10 build 1328 vorgenommen werden:
Publisher, Box
Einstellungen Publisher - RT Ethernet
Einstellungen zum RT-Ethernet:
▪
MAC-Broadcast: Sendung geht an alle Netzwerkteilnehmer, Destination-MAC FF:FF:FF:FF:FF:FF.
▪
Multicast: Eine Destination-MAC-Adresse wird dann zu einer Multicast-Adresse, wenn das erste Bit im ersten Byte der MAC gesetzt ist, das sog. Gruppenbit. Mit der Beckhoff-Kennung "00 01 05" wird so in Abb. Einstellungen Publisher - RT Ethernet die Default-Ziel-Adresse "01 01 05 04 00 00" gebildet.
Für den allgemeinen Multicast-Einsatz ist der MAC-Bereich 01:00:5E:00:00:00 bis 01:00:5E:FF:FF:FF vorgesehen - dabei sind die ersten 3 Byte von der IEEE fest definiert, die hinteren 3 Byte leiten sich aus dem unteren Teil der IP-Adresse des Ziel-PC ab. Die dabei entstehende Ziel-MAC ist also im Netzwerk nie physikalisch vorhanden, sondern die Ziel-Netzwerkkarte erkennt solchermaßen gebildete Ethernet-Frames als zu ihr gesendete Multicast-Frames, obwohl der Ethernet-Port selbst eine andere, eindeutige MAC-Adresse haben kann. Da auch noch andere Regeln auf die Bildung von Multicast-MAC/IP-Adressen einwirken, sei im Weiteren auf die entsprechende Literatur verwiesen.
▪
Unicast: entweder direkte Eingabe der Ziel-MAC oder über die AMS-Net-ID des Ziel-Gerätes, z. B. 123.456.123.456.1.1 - dann muss diese Route aber im lokalen AMS-Router eingetragen sein (Rechtsklick TwinCAT Icon in der Taskleiste --> Eigenschaften --> AMS Router)
Verwendung von Broadcast und Multicast
Netzwerkvariablen, die als Broad- oder Multicast auf MAC- oder IP-Ebene verschickt werden, erzeugen je nach Zykluszeit eine hohe Netzwerklast, da sie ins gesamte anhängende Netz multipliziert werden! Einfache Netzwerkgeräte wie z. B. Drucker können dann abstürzen, bei kurzen Zykluszeiten kann auch der gesamte Netzwerkverkehr blockiert werden! Die Verwendung der Unicast-Adressierung wird dringend empfohlen, auch unter Berücksichtigung der o.a. Variablenidentifizierung.
Weitere Einstellungen:
▪
Data Exchange: verwendete Taskzykluszeit * Divider ist der Rhythmus, in dem diese Netzwerkvariable versendet wird. (nicht bei EL66xx).
▪
VLAN Support: in Verbindung mit managebaren Switchen kann dem hier parametrierten Ethernet-Frame durch das VLAN-Tagging (Virtual Local Area Network) eine feste Route vorgegeben werden.
Einstellungen Publisher - UDP/IP
Einstellungen zum UDP/IP - es wird das Adressierungsverfahren der IP-Vermittlungsschicht mit IP-Adressen benutzt, UDP ist ein verbindungsloses Protokoll ohne Rückmeldung.
▪
Broadcast: Versand an alle Teilnehmer mit Destination-IP(v4) 255.255.255.255
▪
Multicast: die Ziel-IP ist anzugeben, s. Anmerkungen zum MAC-Multicast
▪
Unicast: das Zielgerät (z.B: 192.168.0.1) angeben, dabei auf Erreichbarkeit durch die SubNetz-Maske achten
Verwendung von Broadcast und Multicast
Netzwerkvariablen, die als Broad- oder Multicast auf MAC- oder IP-Ebene verschickt werden, erzeugen je nach Zykluszeit eine hohe Netzwerklast, da sie ins gesamte anhängende Netz multipliziert werden! Einfache Netzwerkgeräte wie z. B. Drucker können dann abstürzen, bei kurzen Zykluszeiten kann auch der gesamte Netzwerkverkehr blockiert werden! Die Verwendung der Unicast-Adressierung wird dringend empfohlen, auch unter Berücksichtigung der o.a. Variablenidentifizierung.
Weitere Einstellungen:
▪
"ARP Retry Interval": Um sich über die Anwesenheit des Empfängers zu informieren, sendet der Publisher in diesem Abstand eine ARP-Anfrage (ARP Request) an das Zielgerät. Arbeitet die Netzwerkverwaltung des Empfänger-PC, antwortet dieser mit einem "ARP Reply". Deshalb nur bei Unicast sinnvoll.
In der Diagnosevariable "FrameState" wird im Fehlerfall Bit 3 gesetzt (0x0004).
Anmerkung: das ARP-Handling (ARP = Address Resolution Protocol: Zuordnung von Hardware/MAC-Adressen zu Netzwerkadressen [IP]) wird vom Betriebssystem (Windows) verwaltet.
▪
"Disable Subscriber Monitoring": schaltet das vorgenannte Verfahren ab.
▪
"Target Address changeable": dann kann die Ziel-IP dynamisch geändert werden.
Publisher, Variable
Einstellungen Publisher - Variable
Einstellungen:
▪
"Variable ID": Identifizierungsnummer, mit der diese Variable versendet wird, ggf. über PLC online veränderbar.
▪
"Data Exchange": s.o. (nicht bei EL66xx).
▪
"On change only": NWV wird nur bei Änderung des Wertes versendet (nicht bei EL66xx).
Subscriber, Box
Einstellungen Subscriber
Einstellungen:
▪
"Receiving Options": lässt für diesen Subscriber nur NWV eines bestimmten Publishers zu
▪
"Multicast Configuration": dto.
Prozessdaten:
▪
"VarId": wenn aktiviert, dann ist die Variablen-Id online änderbar
Subscriber, Variable
Einstellungen Subscriber - Variable
Einstellungen:
▪
"Variable ID": lässt für diesen Subscriber nur NWV mit einer bestimmten ID zu, ggf. über PLC dynamisch veränderbar.
▪
"Ignore Data Type Hash": die Hash-Berechnung wird z.Z. noch nicht unterstützt
Prozessdaten:
▪
"Quality": siehe o.a. Erläuterungen.
▪
"CycleIndex": wird mit jeder erfolgreichen Übertragung inkrementiert, WENN die Gegenseite = der Publisher dies vornimmt. Wenn der Publisher ein EL66x ist, muss dort der Anwender CycleIdx inkrementieren.
▪
"VarData": übertragene Daten.


Applikationsbeispiele

Applikationsbeispiele
Applikationsbeispiele
Weiterführende Informationen
•
Beispielprogramme
•
Applikationsbeispiel - Netzwerkdrucker
•
Applikationsbeispiel - Service-Schnittstelle mit Remotedesktop
•
Applikationsbeispiel - Unterlagerte Steuerung
•
Applikationsbeispiel - EtherCAT Master PC als Netzwerk-Bridge einrichten
•
Applikationsbeispiel - Flexibler Ethernet Port


Beispielprogramme

Applikationsbeispiele [image] Beispielprogramme
Beispielprogramme
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Kunden zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Beispiel 1: Pubisher/Subscriber Datendurchsatz ermitteln
Beispielprogramm ( )
Bei entsprechender EtherCAT-Zykluszeit sind je nach Umfang und Anzahl der in der EL66xx konfigurierten Publisher/Subscriber Realtime-Zykluszeiten bis zu <500 µs möglich.
Typische Durchsatzwerte der EL6601, FW08, Rev. EL6601-0000-0018 sind
▪
1 Publisher mit 1000 Byte, 1 Subscriber mit 1000 Byte, gleichzeitiger bidirektionaler Betrieb: 2 ms
▪
1 Publisher mit 100 Byte, 1 Subscriber mit 100 Byte, gleichzeitiger bidirektionaler Betrieb: 300 µs
Beide Kennwerte wurden mit diesem ermittelt. Für das Systemmanagerfile *.tsm ist TwinCAT ab Version 2.11 erforderlich.
Am Beispiel der EL6601 wird erklärt, wie diese als Publisher oder Subscriber für Netzwerkvariablen konfiguriert werden kann. Die Dialoge unter TwinCAT 2.10 und TwinCAT 2.11 unterscheiden sich dabei geringfügig.
Beispiel 2: Online Diagnose
Beispielprogramm ( )
Im CoE-Verzeichnis stehen folgende Objekte zur ersten Diagnose zur Verfügung:
▪
0xFA01, Subindex 01: Frame Counter Rx (an RJ45-Buchse ankommend)
▪
0xFA01, Subindex 02: Frame Counter Tx (ab RJ45-Buchse abgehend)
Die Werte können aus der Steuerung über PLC-Bausteine (FB_EcCoeSdoRead in TcEtherCAT.lib) ausgelesen werden.
Diese und weitere Diagnoseinformationen aus dem CoE der EL66xx sind über zugänglich.


Applikationsbeispiel - Netzwerkdrucker

Applikationsbeispiele [image] Applikationsbeispiel - Netzwerkdrucker
Applikationsbeispiel - Netzwerkdrucker
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.
Für den Prüfaufbau wurde folgende Hardware verwendet:
▪
TwinCAT-Master-PC mit Betriebssystem Windows XP Professional SP 2, TwinCAT Version 2.10 (Build 1305) und INTEL PRO/100 VE Ethernet-Adapter
▪
Beckhoff Ethernet Kopplerklemme EK1100, Klemmen EL1012, EL6601 und EL9010
▪
Drucker HP LaserJet 4200tn
Die Anbindung eines Netzwerkdruckers an die EL6601 im Klemmenverbund erfolgt über die Systemsteuerung des Steuerungs-IPC:
Anbindung eines Netzwerkdruckers
Legende:
EtherCAT-Verbindung
Ethernet-Verbindung
Überprüfen der Netzwerkadresse des TwinCAT-Master-PC
▪
Starten Sie den TwinCAT System Manager im Config-Modus, lesen Sie die Klemmen Konfiguration ein und aktivieren Sie den Free-Run Modus
▪
Die EL6601 sollte in der System-Konfiguration erscheinen und sich im OP-Status befinden (siehe Online Reiter EtherCAT Status Maschine )
EL6601 in der Konfiguration
▪
Verbinden Sie den Netzwerkdrucker über ein CAT-5 (1:1) Kabel mit der EL6601
▪
Überprüfen Sie in der Systemsteuerung des Steuerungs-IPC den Netzwerkadapter, über den das EtherCAT-System betrieben wird:
Netzwerkumgebung [Eigenschaften] -> LAN-Verbindung (TwinCAT-LAN-Adapter), [Eigenschaften] -> Internetprotokoll (TCP/IP) [Eigenschaften]
Kontext Menü Netzwerkumgebung -> „Eigenschaften“
Kontext Menü „LAN Verbindung (TwinCAT-LAN-Adapter),“ -> „Eigenschaften“
Eigenschaften Internetprotokoll (TCP/IP)
▪
Tragen Sie eine IP-Adresse für das Subnetz des Netzwerkdruckers ein (z. B. 192.168.0.1/255.255.255.0) und bestätigen Sie mit OK
Eintragen der IP-Adresse des Subnetzes des Netzwerkdruckers
Netzwekadresse
Die Netzwerkadresse im Beispiel dient nur zu Veranschaulichung der Konfiguration. Beachten Sie in Ihrer Applikation, dass die IP-Adresse des Netzwerkdruckers immer entsprechend des IP-Nummernkreises/Subnetzmaske des Master-PC gewählt werden muss.
▪
Konfigurieren Sie den Netzwerkdrucker (im Konfigurationsmenü des Druckers) und weisen Sie dem Drucker eine IP-Adresse aus dem IP-Nummernkreis des oben definierten Subnetzes zu
(Bedienungsanleitung Ihres Druckers beachten), hier z. B. 192.168.0.37
▪
Richten Sie den Netzwerkdrucker über die Systemsteuerung ein:
Drucker & Faxgeräte -> Drucker hinzufügen, wählen Sie im Drucker-Installationsassistent einen Lokalen Drucker und wählen Sie im anschließenden Pulldownmenü Einen neuen Anschlusstyp erstellen... einen Standard TCP/IP-Port
Systemsteuerung „Drucker hinzufügen“ unter „Drucker und Faxgeräte“
Radio Button „Lokaler Drucker“ wählen
Anschlusstyp wählen
▪
Tragen Sie im folgenden Menü unter Druckername oder IP-Adresse die im Konfigurationsmenü des Druckers definierte IP-Adresse ein (im Beispiel 192.168.0.37)
Eintragen der IP-Adresse und des Duckernamens
▪
Bestätigen Sie die Porteigenschaften und stellen Sie den Assistenten fertig
▪
Installieren Sie im folgenden Druckerinstallations-Assistenten den entsprechenden Treiber Ihres Druckerherstellers


Applikationsbeispiel - Service-Schnittstelle mit Remotedesktop

Applikationsbeispiele [image] Applikationsbeispiel - Service-Schnittstelle mit Remotedesktop
Applikationsbeispiel - Service-Schnittstelle mit Remotedesktop
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.
Für den Prüfaufbau wurde folgende Hardware verwendet:
▪
TwinCAT-Master-PC mit Betriebssystem Windows XP Professional SP 2, TwinCAT Version 2.10 (Build 1305) und INTEL PRO/100 VE Ethernet-Adapter
▪
Beckhoff Ethernet Kopplerklemme EK1100, Klemmen EL1012, EL6601 und EL9010
▪
Notebook (Service-PC) für Remotedekstop-Verbindung mit Betriebssystem Windows XP Professional SP 2 und Standard Ethernet Schnittstelle
Einbindung einer Service Schnittstelle mit Remotedesktop-PC
Konfiguration am TwinCAT Master-PC
▪
Starten Sie den TwinCAT System Manager im Config-Modus, lesen Sie die Klemmenkonfiguration ein und aktivieren Sie den Free-Run Modus
▪
Die EL6601 sollte in der System-Konfiguration erscheinen und sich im OP-Status befinden (siehe Online Reiter EtherCAT Status Maschine )
EL6601 in der Konfiguration
▪
In Analogie zur Konfiguration eines Netzwerkdruckers lautet die IP-Nummer des EtherCAT-Netzwerkports des TwinCAT Master-PC im Subnetz z. B. 192.168.0.1
▪
Offnen Sie beim TwinCAT Master-PC die Systemsteuerung und klicken Sie auf Sicherheitscenter -> Windows Firewall
Wählen von „Sicherheitscenter“ in der Ansicht Systemsteuerung Kategorie
Sicherheitseinstellungen für Windows Firewall anwählen
▪
Bei aktivierter Windows Firewall klicken Sie auf den Karteireiter Ausnahmen
▪
Markieren Sie den Dienst Remotedesktop und bestätigen Sie die Eingabe mit OK
Bei Karteireiter „Ausnahmen“ den Dienst „Remotedesktop“ aktivieren
▪
Wechseln Sie nochmals in die Systemsteuerung des TwinCAT Master-PC und wählen Sie Leistung und Wartung -> System
Wählen von „System“ in der Ansicht Systemsteuerung „Leistung und Wartung“
▪
Klicken Sie auf den Karteireiter Remote und markieren Sie in der Kategorie Remotedesktop Benutzern erlauben, eine Remotedesktopverbindung herzustellen
Haken setzen bei „Benutzern erlauben, eine Remotedesktopverbindung herzustellen“
▪
Öffnen Sie mit dem Button Remotebenutzer auswählen... die Liste der Remotedesktopbenutzer und fügen Sie hier ggf. weitere Benutzer ein
▪
Bestätigen Sie mit OK
Hinzufügen von Remotedesktopbenutzern
Konfiguration am Service-PC
Für eine Remotedesktopverbindung mit dem TwinCAT Master-PC über die EL6601 muss die Netzwerkadresse des Service-PC entsprechend des IP-Nummernkreises vom Subnetz des TwinCAT Master-PC eingestellt werden.
▪
Verbinden Sie den Ethernet-Port des Service-PC über ein CAT-5 (1:1) Kabel mit der EL6601
▪
Überprüfen Sie in der Systemsteuerung des Service-PC den Ethernet-Netzwerkadapter, über den das EtherCAT-System betrieben wird:
Netzwerkumgebung [Eigenschaften] -> LAN-Verbindung (Ethernet-LAN-Adapter), [Eigenschaften] -> Internetprotokoll (TCP/IP) [Eigenschaften]
Kontext Menü Netzwerkumgebung -> „Eigenschaften“
Kontext Menü „LAN Verbindung (Ethernet-LAN-Adapter),“ -> „Eigenschaften“
Eigenschaften Internetprotokoll (TCP/IP)
▪
Tragen Sie eine IP-Adresse für das Subnetz des Service-PC ein (z. B. 192.168.0.38/255.255.255.0) und bestätigen Sie mit OK
Eintragen der IP-Adresse des Subnetzes des Service-PC
▪
Die Ethernet-Verbindung zum TwinCAT Master-PC wird nun über die EL6601 durch den EtherCAT-Klemmenverbund getunnelt und kann über das Remotedesktop hergestellt werden.
Herstellen der Remotedesktopverbindung
▪
Starten Sie am Service-PC die Remotedesktopverbindung mit Start -> Programme -> Zubehör -> Kommunikation -> Remotedesktopverbindung
Start der Remotedesktopverbindung
▪
Tragen Sie die IP-Adresse des TwinCAT Master-PC ein (z. B. 192.168.0.1) und drücken Sie Verbinden
Eintragen der IP-Adresse des Remote-PC
▪
Sie sehen das Anmeldefenster des TwinCAT Master-PC auf dem Desktop des Service-PC
▪
Geben Sie Ihren Benutzernahmen und Passwort für den TwinCAT Master-PC ein und bestätigen Sie mit OK
Die IP-Adresse des TwinCAT Master-PC wird oberhalb des Remotedesktop eingeblendet
Anmeldefenster des Remote-PC über die Remotedesktopverbindung
Anmeldung über Remotedesktop
Für die Anmeldung über Remotedesktop ist die Vergabe eines Benutzernamen und Passwortes beim TwinCAT Master-PC obligatorisch!
▪
Sie können das TwinCAT-System nun über den Service-PC fernsteuern.
Zum Abmelden kann das Remotedesktop-Fenster geschlossen werden.
Schließen der Remotedesktopverbindung
Zugriff auf das Remote-System
Bei der Steuerung des TwinCAT Master-PC über Remotedesktop ist zu beachten, dass TwinCAT im Run-Modus oder im Config-Modus (Free Run) ausgeführt wird. Wird die Task unterbrochen, kann der Service-PC nicht mehr auf das Remote-System zugreifen!


Applikationsbeispiel - Unterlagerte Steuerung

Applikationsbeispiele [image] Applikationsbeispiel - Unterlagerte Steuerung
Applikationsbeispiel - Unterlagerte Steuerung
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.
Für den Prüfaufbau wurde folgende Hardware verwendet:
▪
TwinCAT-Master-PC mit Betriebssystem Windows XP Professional SP 2, TwinCAT Version 2.10 (Build 1305) und INTEL PRO/100 VE Ethernet-Adapter
▪
Beckhoff Ethernet Kopplerklemme EK1100, Klemmen EL1012, EL6601 und EL9010
▪
Beckhoff Embedded PC CX9000 (unterlagerte Steuerung) mit Betriebssystem Windows CE v5.00, HW 1.4, Klemmen EL2032, EL9010
Einbindung einer unterlagerten Steuerung
Konfiguration der unterlagerten Steuerung
Für eine Verbindung mit dem TwinCAT Master-PC über die EL6601 muss die Netzwerkadresse der unterlagerten Steuerung entsprechend des IP-Nummernkreises vom Subnetz des TwinCAT Master-PC eingestellt werden.
▪
Starten Sie vom Desktop der unterlagerten Steuerung (Windows CE) mit Start -> Settings -> Network and Dial-up Connections die Konfiguration der Netzwerkeinstellungen
(Hinweise zur Einstellung der Netzwerkadresse einer unterlagerten Steuerung entnehmen Sie bitte auch der Dokumentation zum )
Konfiguration der Netzwerkverbindungen wählen
▪
Öffnen Sie mit Doppelklick auf die TCIXPNPE1-Connection (Ethernet-Port) die Netzwerkeinstellungen für diese Verbindung
Netzwerkeinstellungen für Ethernet-Port anwählen
▪
Geben Sie eine dem IP-Nummernkreis des Subnetzes entsprechende IP-Nummer (z.B. 192.168.0.39/255.255.255.0) des TwinCAT Master-PC ein und bestätigen Sie mit OK.
IP-Adresse eingeben
Konfiguration am TwinCAT Master-PC und Herstellen der Verbindung
▪
Starten Sie den TwinCAT System Manager im Config-Modus, lesen Sie die Klemmenkonfiguration ein und aktivieren Sie den Free-Run Modus
▪
Die EL6601 sollte in der System-Konfiguration erscheinen und sich im OP-Status befinden (siehe Online Reiter EtherCAT Status Maschine )
EL6601 in der Konfiguration
▪
In Analogie zur Konfiguration eines Netzwerkdruckers lautet die IP-Nummer des TwinCAT Master-PC im Subnetz z. B. 192.168.0.1
▪
Verbinden Sie die unterlagerte Steuerung (Zielsystem) über ein CAT-5 (1:1) Kabel mit der EL6601
▪
Starten Sie eine weitere Session des System Managers im Config-Mode und klicken Sie Zielsystem wählen... -> Suchen (Ethernet)
Zielsystem wählen
▪
Geben Sie die IP-Adresse der unterlagerten Steuerung im Feld neben Enter Host Name / IP: ein
▪
Nach Betätigung des Buttons Enter Host Name / IP: erscheint im Auswahlfeld der Name des Zielsystems
Im „Route Dialog“ die Route des Zielsystems hinzufügen
▪
Klicken Sie Route hinzufügen und geben Sie ggf. die Zugangsdaten für das Zielsystem ein
▪
Nach dem Schließen des Dialogfensters erscheint im Auswahlmenü der Name des Zielsystems
▪
Markieren Sie Ihre Auswahl und bestätigen Sie mit OK
Auswahl bestätigen
▪
Zum Einlesen der Klemmenkonfiguration der unterlagerten Steuerung aktivieren Sie den Free-Run Modus
FreeRun aktivieren


Applikationsbeispiel - EtherCAT Master PC als Netzwerk-Bridge einrichten

Applikationsbeispiele [image] Applikationsbeispiel - EtherCAT Master PC als Netzwerk-Bridge einrichten
Applikationsbeispiel - EtherCAT Master PC als Netzwerk-Bridge einrichten
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.
In diesem Beispiel soll von einem unterlagerten PC über die EL6601 und EtherCAT and einem Master PC ins übergeordnete Netzwerk gesendet werden.
Folgende Hardware wurde verwendet:
▪
Rechner A und B: Windows XP SP2
▪
Rechner C: Windows XP embedded
Einrichten eines EtherCAT-Master-PC als Netzwerk Bridge
Dazu muss der Master PC "TwinCAT Master" (B) als TCP/IP-Bridge eingerichtet werden, um TCP/IP-Telegramme an den unterlagerten CX1020 (C) durchzuleiten bzw. in der Gegenrichtung weiterzugeben. Gegenstelle ist ein PC (A).
Dabei sind 2 Fälle zu unterscheiden: Statischen Adressen und DHCP-Adressvergabe (Netzwerk).
Die folgenden Erläuterungen setzen die vorangegangenen Beispiele als Grundwissen voraus.
Rechner (A), (B) und (C) haben eine statische IP-Adresse
Konfiguration der Netzwerk PC
▪
Konfigurieren Sie die drei PCs wie im Schema gezeigt. Die Dialoge zu den Eigenschaften des Internetprotokolls wurden in den vorangehenden Beispielen erläutert.
▪
Setzen Sie im "Bridge"-PC B mit dem Registryeditor (Start --> Ausführen --> regedit) den Eintrag "IPEnableRouter" auf den Wert 1. Dieser Eintrag liegt üblicherweise im Pfad HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\TCPIP\Parameters oder auch in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TCPIP\Parameters.
▪
Nach einem Neustart ist für diesen PC das Routing für IP-Telegramme aktiv. Dann kann mit einem Ping (Start --> Ausführen --> cmd --> ping 192.168.1.1) an den EtherCAT-Port 192.168.1.1 die Verbindung überprüft werden.
▪
Befindet sich der EtherCAT-Master in einem regulären und fehlerfreien Zustand (TwinCAT im "Config"/"FreeRun" oder "Run"-Modus), kann über die EL6601 der angeschlossene Ethernet-Teilnehmer mit der IP-Adresse 192.168.1.10 erreicht werden.
▪
Erläuterung des Eintrags Gateway am Beispiel des PC A: Der PC A hat die IP-Adresse 10.16.2.8 mit einer Subnetzmaske 255.255.255.0. Das bedeutet, alle IP-Telegramme im Bereich von 10.16.2.0 bis 10.16.2.255 kann er erreichen. Soll er ein IP-Telegramm in einen anderen Adressbereich versenden (z. B. an 192.168.1.1), muss das über das definierte Gateway laufen, hier also 10.16.2.21, der wiederum über das konfigurierte IP-Routing das Telegram an 192.168.1.10 weiterleiten kann.
▪
Windows bietet zur Kontrolle der Konfiguration den nützlichen Kommandozeilenbefehl ipconfig an. Bei richtiger Konfiguration des PC A zeigt der Befehl Start --> Ausführen --> cmd --> ipconfig /all folgendes Bild:
Kontrolle der Konfiguration mit Kommandozeilenbefehl „ipconfig /all“
▪
IP-Routing ist (default) deaktiviert, die IP-Adresse des gewählten Adapters (hier genannt LAN) ist fix vergeben. Da zuvor DHCP eingestellt war, sind noch WINS-Einträge vorhanden.
▪
Auf PC C zeigt der Befehl:
Kontrolle der Konfiguration PC C
▪
Eingetragen wurde dies unter XP im Dialog
Eintragung der Netzwerkparameter
▪
Entsprechend zeigt der Befehl im Bridge-PC B:
Kontrolle der Konfiguration Bridge PC B
Schalter "ipconfig"
Mit den Schaltern /release und /renew kann der Befehl ipconfig zum Neuaufbau von IP-Verbindungen bewegt werden.
Checkliste zur Verbindungseinstellung:
▪
Bridge-PC durch Registryeintrag zum "IPRouting" konfiguriert
▪
Feste IP-Adressen in übereinstimmenden Bereichen für alle 4 beteiligten Ethernet-Ports
▪
ggf. Firewalls deaktiviert (bei default Einstellung unnötig)
▪
EtherCAT/TwinCAT im "Freerun" oder "Run"-Modus
▪
Link-Anzeige an allen beteiligten Ports
▪
"Ping" funktioniert
Beobachtung des Netzwerkverkehrs
Versierte Benutzer können mit einem Netzwerksniffer wie Wireshark den Netzwerkverkehr beobachten und auswerten.
Hinweis zum Betriebssystem Windows CE/embedded
Unter Windows CE muss das IP Routing im CX Configuration Dialog gesetzt werden (siehe Abb. „Setzen des IP Routing in Windows CE“)
Der Eintrag „TCP/IP Settings“ -> „IP Routing“ setzt den Registry-Key „IPEnableRouter“= 1 unter [HKEY_LOCAL_MACHINE\Comm\Tcpip\Parms]
Ein Neustart ist nötig.
Siehe auch Microsoft Developer Network: Routing for IPv4 - Erklärung zum Routing.
Normalerweise wird die Routing-Tabelle automatisch gepflegt, ggf. müssen Routen noch mit dem Kommando “Route Add“ hinzugefügt werden, vergleiche dazu auch Windows XP/7 etc.
Windows CE unterstützt einige Routing-Protokolle wie RIP oder OSPF nicht.
Setzen des „IP Routing“ in Windows CE
Netzwerk mit DHCP-Adressvergabe
Ein Verbindungsaufbau zwischen den PCs C und A (bzw. dem Netzwerk) ist nicht möglich.
Erklärung: Die Rechner (A) und (B) erhalten bei entsprechender Konfiguration der Ethernetports vom DHCP-Server ihre IP-Adressen. Ein möglicher Ablauf ist wie folgt (s. RFC1541 und RFC2131):
▪
Ein neu angeschlossener PC sendet eine DHCPDISCOVER-Nachricht mit seiner MAC-Adresse per MAC-Broadcast an alle anderen Netzwerkteilnehmer.
▪
Der DHCP-Server bietet dem Anfragenden in der DHCPOFFER-Nachricht eine oder mehrere IP-Adressen an.
▪
Der anfragende PC wählt eine IP-Adresse aus und antwortet per MAC-Broadcast mit einer DHCPREQUEST-Nachricht an den DHCP-Server.
▪
Der DHCP-Server bestätigt die Wahl mit einer DHCPACK-Nachricht.
Dies funktioniert bei den Rechnern (A) und (B). Die DHCPDISCOVER-Nachrichten von Rechner (C) werden von der EL6601 zwar angenommen und in Rechner (B) über den EtherCAT-Port an Windows weitergeleitet, Windows (B) stellt diese (und alle anderen DHCP-Telegramme) jedoch nicht an den weiterführenden Ethernet-Port durch - diese DHCP-Relay-Agent genannte Funktion ist nur in den Server-Versionen von Windows enthalten.
Dies ist der normale Betriebsfall, wenn als DHCP-Teilnehmer konfigurierte Windows-PCs miteinander gekoppelt werden.
Abhilfe:
▪
Installieren Sie einen lokalen DHCP-Server auf Rechner (B), achten Sie darauf, dass sich keine Konflikte mit dem übergeordneten DHCP-Servers des Netzwerks ergeben
▪
Es besteht die Möglichkeit, dass zwei als DHCP-Teilnehmer konfigurierte und miteinander verbundene Windows-PCs erst nach kurzer Zeit (mehrere Minuten) ihre Adressen festlegen


Applikationsbeispiel - Flexibler Ethernet Port

Applikationsbeispiele [image] Applikationsbeispiel - Flexibler Ethernet Port
Applikationsbeispiel - Flexibler Ethernet Port
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.
In diesem Beispiel soll von einem unterlagerten PC über eine flexibel angebundene EL6601 und EtherCAT zum Zwecke des Fernzugriffs auf die zentrale EtherCAT-Steuerung zugegriffen werden.
Folgende Elemente wurden verwendet:
▪
IPC mit Windows XP SP2
▪
TwinCAT 2.11 b1534
▪
EL6601, SN xxxx0605
Der Ansatz
Eine ausgedehnte Anlage mit EtherCAT-Topologie soll in Betrieb genommen werden. Dazu ist häufiger Zugriff auf den TwinCAT System Manager auf dem Zentralrechner nötig. In der Praxis befindet sich hierbei der Techniker während der Inbetriebnahme vorrangig bei den dezentralen Klemmen/EtherCAT-Slaves. Es soll also vom jeweiligen Koppler-Standort aus über einen Fern-PC via Ethernet auf den zentralen Systemmanager als TwinCAT Zielsystem zugegriffen werden.
Dazu werden 2 Mechanismen benutzt:
▪
EtherCAT tunnelt Standard IP-Telegramme durch dezidierte Slaves, z. B. EL6601 über das azyklische Mailbox-Verfahren
▪
Über die HotConnect Funktionalität kann eine Kopplerstation (Koppler + Klemmen) in der Konfiguration (.tsm) als frei steckbar klassifiziert werden. Dazu müssen spezielle Koppler verwendet werden.
Eine frei steckbare Kombination aus EK1101 und EL6601 (HotConnect-Gruppe) kann nun als flexibel einsetzbare Ethernet-Schnittstelle verwendet werden.
Möglicher Aufbau
Im Folgenden ein möglicher Aufbau:
Aufbau HotConnect-Gruppe
In der Anlage sind EK1110 (Endkoppler), EK1122 (Junction-Klemmen) und freie EK1100-Ports verfügbar, um dort die HotConnect-Gruppe anzuschließen. Die IP-Adressen sind als Beispiel zu verstehen, die Hinweise vorangegangener Beispiele sind zu beachten.
Es sind keine weiteren Einstellungen am TwinCAT/EtherCAT-Master zu treffen, EoE wird in TwinCAT 2.11 automatisch durchgeleitet.
Operabilität des Fernzugriffs und EtherCAT-Status
Der hier beschriebene Vorgang der Ethernet-Durchleitung funktioniert nur so lange, wie sich der EtherCAT-Master und die EL66xx mindestens im Status PREOP befinden- ansonsten findet kein Mailbox-Verkehr und damit kein Ethernet-Transport statt. Bei bereits funktionaler Netzwerkstruktur stellt dies aber für die allgemeine Inbetriebnahme kein unüberwindbares Hindernis dar.
Standortänderung und EtherCAT-Status
Nach dem erneuten Verbinden der HotConnect-Gruppe mit dem EtherCAT-Netz dauert es ggf. mehrere Sekunden bis die Gruppe wieder am Datenverkehr teilnimmt, die EL66xx wieder im OP-State befindlich und der Link (s. Link-LED) wiederhergestellt ist.
Beispiel-Aufbau
Ein kleines EtherCAT-System wird in Betrieb genommen, die Offline-Topologie-Ansicht aus dem System Manager zeigt 2 Kopplerstationen und eine nicht lokalisierte Station mit einem EK1101.
▪
Im Offline-Zustand ist dem System Manager nicht bekannt, wo die EK1101-Station mit ihrer ID angeschlossen wurde.
Nicht lokalisierter EK1101
▪
Online ist dann die aktuelle Zuordnung sichtbar, der EK1101 mit der EL6601 hängt am 2. Port des EK1100.
EK1101 mit EL6601 lokalisiert
▪
Alle Slaves befinden sich im OP-State, damit kann nun vom Fern-PC auf dieses System als Zielsystem zugegriffen werden.
▪
Im Fern-System wird ein leerer System Manager geöffnet und als Zielsystem via IP der EtherCAT-Rechner mit der IP 172.1.1.1 (hier im Beispiel) gesucht
(Karteiereiter Aktionen -> Auswahl des Zielsystems -> "Suchen (Ethernet)" -> [Eingabe IP 172.1.1.1] -> "Enter Hostname / IP")
Auswahl des Zielsystems
Eingabe Zielsystem 172.1.1.1
▪
Nach Doppelklick auf die Zeile des gefundenen Zielsystems kann sich auf das Zielsystem eingeloggt werden:
Eingabe der Logon Informationen auf Zielsystem
▪
Nach dem erfolgreichen Verbinden kann die Konfiguration durch "Öffnen vom Zielsystem" vom Zielsystem geladen werden.
Öffnen vom Zielsystem und Laden der Konfiguration
Checkliste
Für den erfolgreichen Ablauf der Einrichtung bis zum Fernzugriff bietet sich folgende Checkliste an:
1.
EtherCAT-Konfiguration erfolgreich einrichten
- keine LostFrames
- EtherCAT Master und alle Slaves im OP-State
- alle WorkingCounter = 0; ggf. für absichtlich inaktive Slaves eigene SyncUnits einrichten
2.
IP-Addressen des EtherCAT-Ports und des verwendeten Ports am Laptop unterschiedlich, aber im gleichen Subnetz-Bereich befindlich einstellen.
(hier: 172.1.1.1 und 172.1.1.2)
3.
Durch "Ping" - Kommando von beiden Seiten die Verbindung prüfen
4.
Verbindung als Zielsystem herstellen
Ethernet-Verbindung
Es hat sich bewährt, im Eigenschaften-Dialog der Netzwerkschnittstelle, IP-Protokoll (Windows XP SP2) Default Gateway und DNS Server mit glaubwürdigen Adressen anzugeben, obwohl diese nicht benötigt werden. Hier die Einstellungen des Fern-PC aus dem Beispiel:
Eingabe von Netzwerkadressen im Fern-System


Anhang

Anhang
Anhang
Weiterführende Informationen
•
UL-Hinweise
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


UL-Hinweise

Anhang [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1.
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2.
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL6601
Hardware (HW) | Firmware (FW) | Revision Nr. | Release-Datum
05 - 14 | 06 |  | 2009/07
 | 07 | EL6601-0000-0017 | 2009/09
 | 08 |  | 2009/11
 | 09 |  | 2010/07
 |  | EL6601-0000-0018 | 2010/09
 | 10 |  | 2011/09
 |  | EL6601-0000-0019 | 2012/10
 | 11 |  | 2013/04
 | 12 | EL6601-0000-0020 | 2014/07
15 – 16* | 13 | EL6601-0000-0021 | 2014/12
 | 14 |  | 2015/07
 | 15* |  | 2017/02
EL6614
Hardware (HW) | Firmware (FW) | Revision Nr. | Release-Datum
00 - 09* | 01 | EL6614-0000-0017 | 2008/05
 | 02 |  | 2008/12
 | 03 |  | 2009/08
 | 04 |  | 2009/11
 | 05 |  | 2010/07
 |  | EL6614-0000-0018 | 2010/09
 | 06 |  | 2011/09
 |  | EL6614-0000-0019 | 2012/10
 | 07 |  | 2013/04
 | 08 | EL6614-0000-0020 | 2014/07
10 – 13* | 09 | EL6614-0000-0021 | 2014/12
 | 10 |  | 2015/07
 | 11* |  | 2017/02
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.