EL6201, EL9520 - EtherCAT-Klemmen für AS-Interface
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.4
▪
Update Kapitel „Objektbeschreibung“
▪
Update Struktur
▪
Revisionsstand aktualisiert
2.3
▪
EL9520 Ergänzung
▪
Korrektur Kapitel „Technische Daten“
▪
Update Kapitel "Anschlusstechnik" -> "Anschluss"
▪
Update Struktur
▪
Revisionsstand aktualisiert
2.2
▪
Update Kapitel "Objektbeschreibung und Parametrierung"
▪
Update Struktur
2.1
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Korrektur Technische Daten
▪
Kapitel "TwinCAT Quick Start" eingefügt
2.0
▪
Migration
▪
Ergänzungen im Kapitel „Inbetriebnahme“
▪
Ergänzungen im Kapitel „Technische Daten“
▪
Ergänzungen im Kapitel „Objektbeschreibung und Parametrierung“
▪
Update Struktur
1.5
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
▪
Revisionsstand aktualisiert
1.4
▪
Update Kapitel "Technische Daten"
▪
Update Kapitel "Anschlussbelegung"
▪
Revisionsstand aktualisiert
1.3
▪
Update Kapitel "Technische Daten"
▪
Update Kapitel "Objektbeschreibung und Parametrierung"
▪
Update Struktur
▪
Revisionsstand aktualisiert
1.2
▪
Update Kapitel "Technische Daten"
1.1
▪
Ergänzungen zur Inbetriebnahme
1.0
▪
1. Veröffentlichung
0.8
▪
Ergänzungen & Korrekturen im Kapitel "Quickstart"
0.7
▪
Ergänzungen & Korrekturen im Kapitel "Funktionalität des AS-i Masters"
0.6
▪
Ergänzungen & Korrekturen
0.5
▪
Ergänzungen & Korrekturen
0.4
▪
Ergänzungen
0.3
▪
Ergänzungen
0.2
▪
Ergänzungen
0.1
▪
Vorläufige Dokumentation für EL6201


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Technologie
•
EL9520: AS-i Potenzialeinspeiseklemme mit Filter
•
Start


Einführung

Produktübersicht [image] Einführung
Einführung
EL6201
ASi Logo
AS-Interface Masterklemme
Die AS-Interface-Masterklemme EL6201 ermöglicht den direkten Anschluss von AS-Interface-Slaves. Die AS-Interface-konforme Schnittstelle unterstützt digitale und analoge Slaves gemäß Version 3.0 (Masterprofil M3, M4). Über die AS-Interface-Potenzialeinspeiseklemme EL9520 mit integriertem Filter werden die angeschlossenen Teilnehmer versorgt.
Quick-Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EL6201-0000
AS-Interface-Kanäle | 1
Anzahl Slaves | bis zu 31 bei V 2.0; bis zu 62 bei V 2.11, V 3.0
AS-Interface-Versionen | V 2.0, V 2.11, V 3.0 (Rev. 4)
Slavetypen | Standard: digital und analog, erweitert: Typ 1 (CTT1): S-7.3, S-7.4, Typ 2 (CTT2): S-7.5.5, S-7.A.5, S-B.A.5, Typ 3 (CTT3): S-7.A.7, S-7.A.A, Typ 4 (CTT4): S-7.A.8, S-7.A.9, Typ 5 (CTT5): S-6.0, Safety at work: S-0.B, S-7.B
Diagnose | Spannungsausfall, Slaveausfall, Parametrierfehler
AS-Interface-Adressvergabe | über Konfiguration oder automatisch
Zykluszeit | max. 5 ms (bei 31 bzw. 62 Slaves)
Anschluss | 2 Stränge über Federkrafttechnik
Übertragungsraten | 167 kBit/s
Distributed-Clocks | -
Powerkontakte | nein
Potenzialtrennung | 500 V (AS-Interface/E-Bus)
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme | 120 mA (E-Bus), typ. 40 mA/max. 60 mA (AS-Interface)
Konfiguration | über TwinCAT System Manager
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Gewicht | ca. 55 g
Montage | auf 35 mm Tragschiene nach EN 60715
Betriebstemperatur | 0°C ... +55°C
Lagertemperatur | -25°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP20 / siehe Hinweis!
AS-Interface-Zertifikat | ja, ZU-No. 97701
Zulassungen | CE


Technologie

Produktübersicht [image] Technologie
Technologie
In diesem Kapitel wird eine kurze, allgemeine technische Einführung in die Technologie des AS-Interface gegeben. Weiterführende Details entnehmen Sie bitte den nachfolgenden Kapiteln.
(Quelle: (AS-INTERNATIONAL ASSOCIATION e.V.)
ASi Logo
Weiterführende Informationen
•
AS-i Anforderungen
•
Montage mit Durchdringungstechnik
•
AS-Interface für jede Topologie


AS-i Anforderungen

Produktübersicht [image] Technologie [image] AS-i Anforderungen
AS-i Anforderungen
Die Industrie hat viele vielfältige Anforderungen an moderne Automatisierungssysteme. Es wird verlangt, dass die notwendigen Funktionen zu einem optimalen Preisleistungsverhältnis erfüllt werden. AS-Interface, oder kurz AS-i, leistet genau das. Dabei fokussiert sich das System auf die untere Feldebene. Ziel der Entwicklung war nicht ein universeller Feldbus für alle Bereiche der Automatisierung, sondern ein wirtschaftlich sinnvolles System für die untere Feldebene, mit dem sich binäre Sensoren und Aktuatoren einfach, zuverlässig und wirtschaftlich vernetzen und an die höhere Steuerungsebene anbinden lassen.
Die Sensoren und Aktuatoren können über das AS-i spezifische Zweileiterkabel vernetzt und mit Spannung versorgt werden. Die Kabelbäume einer traditionellen Verkabelung entfallen. Eine massive Kostenreduktion durch die einfache Verdrahtung, die durch die bewährte mechanische Klick- and-Go-Technik auch ohne großen Schulungsaufwand möglich ist. Durch seine Wirtschaftlichkeit erweist sich das System AS-Interface als eine technisch und wirtschaftlich sinnvolle Ergänzung zum normalen Feldbus.
Die frei wählbare Netzwerk-Topologie erleichtert die Installation eines AS-i Netzwerks genauso wie seine einfache Konfiguration. Die Fehleranfälligkeit anderer Systeme führt häufig zu Verzögerungen bei der Montage, darum wurde beim System AS-Interface konsequent auf eine Reduzierung von Fehlerquellen geachtet. Der Verpolungsschutz durch das profilierte Kabel ist nur eine entsprechende Maßnahme.


Montage mit Durchdringungstechnik

Produktübersicht [image] Technologie [image] Montage mit Durchdringungstechnik
Montage mit Durchdringungstechnik
Möglich wird die einfache Montage bei AS-Interface durch die spezielle Montagetechnik, die auch als Durchdringungstechnik oder seltener als Klick-and-Go-Technik bezeichnet wird. Die Technik basiert auf der Verwendung des meist gelben AS-i Kabels, einer verpolsicheren Flachleitung mit zwei Leitern. Bei der Montage bohren sich die Durchdringungsdorne des anzuschließenden Geräts in die Leiter des Kabels und stellen sicher den Kontakt her. Einige Vorteile:
▪
Direkter einfacher Anschluss von Sensoren/Aktuatoren oder Modulen
▪
Verpolsichere Flachleitung
▪
Daten und Energie auf einer Leitung
▪
Durchdringungstechnik / Piercing
▪
einfachste Anschlusstechnik
▪
sichere Kontaktierung
▪
Schutzart IP67
▪
Ablängen und Abisolieren unnötig
▪
An jeder beliebigen Stelle montierbar
▪
Problemloses Versetzen durch Selbstheilungsfähigkeit des Kabels je Kabeltyp möglich
Profiliertes Zweileiterkabel zum Einsatz für die AS-i Technologie
Beispielhafte Montage
Ober- und Unterhälfte des AS-i Bauteils werden demontiert.
Das AS-i Kabel wird - durch seine Profilierung immer fehlerfrei - in die Unterhälfte des AS-i Bauteils eingelegt.
Ober- und Unterhälfte werden mit einem einfachen Werkzeug montiert.
Fertig montierter Abzweig
Die Durchdringungstechnik sorgt für den zuverlässigen Anschluss des AS-i Bauteils an die Leitung des AS-i Netzes.


AS-Interface für jede Topologie

Produktübersicht [image] Technologie [image] AS-Interface für jede Topologie
AS-Interface für jede Topologie
Das AS-i Protokoll gewährleistet eine einfache Erweiterbarkeit. Das AS-Interface Netzwerk kann wie jede konventionelle elektrische Installation konfiguriert werden. Jeder AS-i Slave ist frei adressierbar und kann an beliebiger Stelle mit dem Buskabel verbunden werden. Das ermöglicht einen modularen Aufbau, und aufgrund des robusten Betriebsprinzips gibt es keine Grenzen für die Struktur. Jede beliebige Netztopologie darf verwendet werden, also auch Stern- oder Baumtopologien.
Störsicher
Die Daten auf dem AS-i Netz werden zuverlässig übertragen. Jedes AS-Interface Telegramm wird im Empfänger bezüglich eines Paritätsbits und mehrerer unabhängiger, weiterer Größen überwacht. Dadurch ist eine extrem hohe Sicherheit bei der Erkennung von Ein- und Mehrfach-Fehlern gewährleistet. Der Einsatz von AS-Interface ist dadurch auch in stark belasteter Umgebung wie z. B. in Schweißanlagen oder beim Einsatz von Frequenzumrichtern problemlos möglich.
Genormte Wirtschaftlichkeit
Alle AS-Interface Produkte entsprechen der Euro Norm EN 50295 und dem Weltstandard IEC 62026-2.
Zertifiziert: Wirtschaftlich und Zuverlässig
Die Zertifizierung der AS-i Produkte gewährleistet dem Anwender ein Höchstmaß an Systemsicherheit. Die Produkte sind voll kompatibel und untereinander austauschbar. Als Anwender erkennen Sie die geprüften und zertifizierten Produkte an dem AS-Interface-"Schattenlogo" und einer damit verbundenen Prüfnummer.


EL9520: AS-i Potenzialeinspeiseklemme mit Filter

Produktübersicht [image] EL9520: AS-i Potenzialeinspeiseklemme mit Filter
EL9520: AS-i Potenzialeinspeiseklemme mit Filter
EL9520
Die Potenzialeinspeiseklemme EL9520 entkoppelt das Ein- und Ausgangssignal durch einen integrierten Filter und ermöglicht die Versorgung von AS-Interface-Netzwerken aus Standardnetzteilen oder einem anderen AS-Interface-Netzwerk.
Die EL9520 kann unmittelbar neben der AS-Interface-Masterklemme EL6201 eingesetzt werden. Der parallele Betrieb dieser Kombination in einem EtherCAT-Klemmen-Block ist mehrfach möglich und spart mehrere AS-Interface-Netzteile ein.
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LEDs geben den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Power | grün | aus |  | AS-i Spannung ist abgeschaltet.
 |  | an |  | AS-i Spannung ist eingeschaltet.
Technische Daten
Technische Daten | EL9520
Eingangsspannung | bis 35 VDC
Ausgangsspannung | bis 35 VDC
Eingangsstrom | 2 A
Ausgangsstrom | max. 2 A (nicht kurzschlussfest)
Stromaufnahme vom E-Bus | 100 mA typ.
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Galvanische Trennung | nein
Konfiguration | keine Adress- oder Konfigurationseinstellung erforderlich
Bitbreite im Prozessabbild | 0 Eingangsbits, 0 Ausgangsbits
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Gewicht | ca. 90 g
Montage | auf 35 mm Tragschiene nach EN 60715
zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
zulässige relative Feuchte | 95%, keine Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE
AS-Interface-Zertifikat | ja, ZU-No. 101601


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL6201 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EL6201 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Installation

Installation
Installation
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Vorgeschriebene Einbaulage
•
Positionierung von passiven Klemmen
•
LEDs und Anschlussbelegung


Hinweise zum ESD-Schutz

Installation [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Installation [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Installation [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Installation [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Installation [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Installation [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Installation [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Vorgeschriebene Einbaulage

Installation [image] Vorgeschriebene Einbaulage
Vorgeschriebene Einbaulage
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Sorgen Sie bei der Montage der Klemmen dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Vorgeschriebene Einbaulage
Für die vorgeschriebene Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“).
Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Mindestabstände bei Standard Einbaulage
Die Einhaltung der Abstände nach der obigen Abbildung wird dringend empfohlen!


Positionierung von passiven Klemmen

Installation [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


LEDs und Anschlussbelegung

Installation [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
EL6201 LEDs
LEDs
LED
Farbe
Bedeutung
RUN
grün
Diese LEDs geben den Betriebszustand der Klemme wieder:
aus
Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
blinkend
Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
Einzelblitz
Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks.
Ausgänge bleiben im sicheren Zustand
an
Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
flimmernd
Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
AS-i Diag
grün
Diese LED leuchtet während der AS-i Datenaustauschphase (flackern im regulären Betrieb).
Set switch
grün
Diese LED leuchtet solange die beiden Set-Eingänge kurzgeschlossen sind.
AS-i Power
grün
Diese LED leuchtet solange die AS-i Spannungsversorgung anliegt und mindestens ein AS-i Slave gefunden wurde.
AS-i fault diagnostics
rot
Diese LED blinkt, wenn die Soll- und die Ist-Konfiguration nicht übereinstimmen.
Mögliche Ursachen:
▪
AS-i ID-Code eines oder mehrerer Slaves stimmt nicht mit den projektierten Werten überein.
▪
AS-i E/A Kennung eines oder mehrerer Slaves stimmt nicht mit den projektierten Werten überein.
▪
Projektierter AS-i Slave wurde nicht gefunden.
Protected mode
grün
Diese LED leuchtet, solange die beiden Protected mode Eingänge kurzgeschlossen sind.
AS-i Installation
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Anschluss des AS-interface
Kontaktbelegung AS-i Master EL6201
Klemmenkontakt | Bezeichnung | Verwendung
1 und 5 | SCM | Setzen des Konfigurationsmodus durch kurzzeitiges Brücken der Kontakte 1 und 5
2 und 6 | ASi+ | Anschluss ASi+ (braun). Beide mit ASi+ bezeichneten Klemmstellen sind intern verbunden.
3 und 7 | ASi- | Anschluss ASi- (blau). Beide mit ASi- bezeichneten Klemmstellen sind intern verbunden.
4 und 8 | SPM | Durch kurzzeitiges Brücken der beiden SPM-Kontakte 4 und 8 können die erkannten Slaves aus der Liste der erkannten Slaves für den Protected Mode projektiert werden.
Anschlussbelegung AS-i-Potenzialeinspeiseklemme EL9520
Kontaktbelegung AS-i-Potenzialspeiseklemme EL9520
Klemmenkontakt | Bezeichnung | Verwendung
1 | Uin+ | Positiver Spannungseingang 24 V..35 V
2 | ASi+ | Anschluss ASi+ Beide mit ASi+ bezeichneten Klemmstellen sind intern verbunden.
3 | ASi- | Anschluss ASi- Beide mit ASi- bezeichneten Klemmstellen sind intern verbunden.
4 |  | nicht belegt
5 | Uin- | Negativer Spannungseingang 24 V..35 V
6 | ASi+ | Anschluss ASi+ Beide mit ASi+ bezeichneten Klemmstellen sind intern verbunden.
7 | ASi- | Anschluss ASi- Beide mit ASi- bezeichneten Klemmstellen sind intern verbunden.
8 |  | nicht belegt
Verdrahtung des AS-interface
Verdrahtungsplan (Beispiel) AS-i-Master EL6201: Anschluss mit EL9520 (links), Anschluss mit AS-i-Netzteil (rechts)
Da die Nutzdaten bei AS-interface auf die Stromversorgungsleitung aufmoduliert werden, wird ein spezielles AS-i Netzteil (30,5 VDC) benötigt.
Eine weitere Möglichkeit bietet die AS-i Potenzialeinspeiseklemme EL9520 die die Versorgung direkt aus dem EtherCAT-Klemmenverbund vornimmt.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Funktionalität des AS-i Masters
•
Quickstart
•
Weitere Hinweise zur Inbetriebnahme
•
Objektbeschreibung und Parametrierung
•
Objektbeschreibung - Standardobjekte


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Analog-Eingangsklemme -10…+10 V)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Funktionalität des AS-i Masters

Inbetriebnahme [image] Funktionalität des AS-i Masters
Funktionalität des AS-i Masters
In diesem Kapitel sei nur kurz auf die AS-i Funktionalität eingegangen. Genaueres findet sich in dem Buch AS-Interface von Kriesel/Madelung aus dem Hanser-Verlag (im wesentlichen Kapitel 4.1). Weitere Information kann auch über den AS-Interface Verband (http://www.as-interface.net) bezogen werden.
Weiterführende Informationen
•
AS-Interface Statusmaschine
•
Listen
•
Betriebsmodi
•
Details der Betriebsphasen
•
Adressvergabe der AS-i-Slaves
•
Automatische Projektierung


AS-Interface Statusmaschine

Inbetriebnahme [image] Funktionalität des AS-i Masters [image] AS-Interface Statusmaschine
AS-Interface Statusmaschine
Zunächst wird die Statusmaschine im Überblick beschrieben. Details zu den einzelnen Betriebsphasen finden sich weiter unten.
Überblick Statusmaschine
Initialisierung
Offline Phase: Während der Initialisierung findet kein AS-i Datenverkehr statt.
Aufstarten
Erkennungsphase
In der Erkennungsphase sucht der AS-i Master zunächst nach vorhandenen Slaves - unabhängig, ob diese projektiert sind oder nicht. Diese Phase wird erst verlassen, wenn mindestens ein Slave gefunden wurde.
Aktivierungsphase
In dieser Phase werden die gefundenen Slaves in Abhängigkeit des Betriebsmodi aktiviert:
▪
protected mode: alle erkannten und projektierten Slaves werden aktiviert, falls E/A-Kennung und ID-Code der erkannten Slaves mit den projektierten Daten übereinstimmt.
▪
configuration mode: alle erkannten Slaves werden vom Master aktiviert.
Normalbetrieb
Datenaustauschphase
Der AS-i Master befindet sich im zyklischen Datenaustausch mit den aktivierten Slaves.
Managementphase
Am Ende eines Zyklus geht der AS-i Master in die Managementphase, in der der Master ein Kommando zu einem spezifischen Slave schicken kann (falls gewünscht).
Aufnahmephase
Danach geht der AS-i Master in die Aufnahmephase, in der er ein Kommando an eine freie Slave-Adresse schickt um neue Slaves zu erkennen. Falls keine Antwort kommt, startet der Master unverzüglich mit der nächsten Datenaustauschphase.


Listen

Inbetriebnahme [image] Funktionalität des AS-i Masters [image] Listen
Listen
Listen der AS-i Slaves im configuration und protected mode
LES (LDS) - Liste der erkannten Slaves
Hier sind alle Slaves aufgeführt, die physikalisch am Netz vorhanden sind, eine gültige Adresse aufweisen und vom Master erkannt wurden.
LPS - Liste der projektierten Slaves
Diese Liste umfasst alle Slaves, die der Master am Netz erwartet. Im Protected Mode kommuniziert der Master nur mit diesen Slaves und gibt eine Meldung aus, wenn zusätzliche Slaves erkannt werden oder wenn Slaves aus dieser Liste fehlen.
LAS - Liste der aktivierten Slaves
Alle Slaves, mit denen der Master kommuniziert. Im Protected Mode entspricht diese Liste der LPS, im Configuration Mode entspricht diese Liste der LES (LDS).


Betriebsmodi

Inbetriebnahme [image] Funktionalität des AS-i Masters [image] Betriebsmodi
Betriebsmodi
Geschützter Modus (Protected Mode)
Im geschützten Modus werden nur die AS-i Slaves aktiviert, die in der LPS eingetragen sind. Außerdem muss deren Konfiguration (E/A-Kennung und ID-Codes) mit der projektierten Konfiguration aus den Objekten
- 0x8pp0:20, 0x8pp0:25 (projektierte E/A-Kennungen) bzw.
- 0x8pp0:21, 0x8pp0:26 (projektierte ID-Codes)
- 0x8pp0:22, 0x8pp0:27 (projektierte Extended ID-Codes 1) und
- 0x8pp0:23, 0x8pp0:28 (projektierte Extended ID-Codes 2) übereinstimmen,
falls die Überprüfung der EA-Kennung bzw. ID-Codes in den Indizes 0x8pp0:20 (Bit 7), 0x8pp0:25 (Bit 7) bzw. 0x8pp0:21 (Bit 7), 0x8pp0:26 (Bit 7) und 0x8pp0:22 (Bit 7), 0x8pp0:27 (Bit 7), sowie 0x8pp0:23 (Bit 7), 0x8pp0:28 (Bit 7) freigeschaltet ist.
Die automatische Adressierung ist möglich, wenn bei allen in der LPS eingetragenen AS-i Slaves auch die Überprüfung von E/A-Kennung sowie ID-Code freigeschaltet ist und genau ein projektierter AS-i Slave fehlt.
Konfigurationsmodus (Configuration Mode)
Im Konfigurationsmodus werden alle AS-i Slaves aktiviert, die gefunden werden. Die automatische Adressierung ist möglich, dabei wird einem gefundenen Slave mit der Adresse 0 die nächste freie Adresse zugeordnet. Eine AS-i Adresse kann aber über den Index 0x2000 (AS-i Kommando-Schnittstelle) manuell eingestellt werden. Durch Setzen des Set-Eingangs können alle gefundenen AS-i Slaves projektiert werden. In diesem Fall werden auch
▪
die entsprechenden E/A-Kennungen und ID-Codes in die Indizes 0x8pp0:20, 0x8pp0:25 (Projektierte E/A-Kennungen) bzw. 0x8pp0:21, 0x8pp0:26 und 0x8pp0:22, 0x8pp0:27, sowie 0x8pp0:23 0x8pp0:28 (projektierte ID-Codes) eingetragen und
▪
die Überprüfung in den Indizes 0x8pp0:20 (Bit 7), 0x8pp0:25 (Bit 7) bzw. 0x8pp0:21 (Bit 7), 0x8pp0:26 (Bit 7) und 0x8pp0:22 (Bit 7), 0x8pp0:27 (Bit 7), sowie 0x8pp0:23 (Bit 7), 0x8pp0:28 (Bit 7) (ID-Codes) freigeschaltet.


Details der Betriebsphasen

Inbetriebnahme [image] Funktionalität des AS-i Masters [image] Details der Betriebsphasen
Details der Betriebsphasen
Offline
Nach Power-On geht der AS-i Master in den Offline-Zustand, d.h. mit den AS-i Slaves wird noch keine Kommunikation durchgeführt.
Über die Prozessdaten kann der AS-i Master im Normalbetrieb dazu veranlasst werden, in den Offline-Zustand zu gehen (OFFLINE-Flag ist gesetzt). Dabei werden die Output-Daten aller aktivierten AS-i Slaves auf den Defaultwert 1bin und die Input-Daten aller aktivierten AS-i Slaves auf den Defaultwert 0bin gesetzt. Danach ist der AS-i Master im Zustand Offline und sendet keine weiteren AS-i Kommandos.
Start-Up
Erkennungsphase
In der Erkennungsphase werden E/A-Kennung und ID-Codes von allen AS-i Slaves abgefragt und in die Parameter
- 0x9pp0:20, 0x9pp0:25 (Gelesene E/A-Kennungen) bzw.
- 0x9pp0:21, 0x9pp0:26 (Gelesener ID-Codes),
- 0x9pp0:22, 0x9pp0:27 (Gelesene Extended ID-Codes 1) und
- 0x9pp0:23, 0x9pp0:28 (Gelesene Extended ID-Codes 2) eingetragen.
Alle gefunden AS-i Slaves werden in die Liste der erkannten AS-i Slaves (LES [LDS]), Index 0xF101 eingetragen. Der AS-i Master geht erst in die Aktivierungsphase über wenn er mindestens einen Slave erkannt bzw. gefunden hat.
Aktivierungsphase
Im Protected Mode aktiviert der AS-i Master nur die projektierten AS-i Slaves aus der Liste der projektierten Slaves (LPS, Index 0xF103).
Im Configuration Mode werden alle in der Erkennungsphase gefundenen AS-i Slaves aktiviert. Dazu sendet der AS-i Master ein Parametrieraufruf (Aktivierungs-Parameter, 0x8pp0:24, 0x8pp0:29) und ein Datenaufruf (mit den Defaultwerten 1bin als Outputs). Alle aktivierten Slaves werden in die Liste der aktivierten Slaves (LAS, Index F102) eingetragen. Wenn alle AS-i Slaves durchlaufen sind, geht der AS-i Master automatisch in die Datenaustauschphase über.
Normalbetrieb
Datenaustauschphase
In der Datenaustauschphase führt der AS-i Master mit jedem aktivierten AS-i Slave Datenaustausch durch. Wenn ein AS-i Slave in drei aufeinander folgenden Datenaustauschphasen nicht antwortet, wird er aus der LAS und der LES (LDS) ausgetragen und seine Inputs auf den Defaultwert 0bin gesetzt. Wenn mit allen aktivierten AS-i Slaves ein Datenzyklus durchgeführt wurde, geht der AS-i Master in die Managementphase über.
Managementphase
In der Managementphase wird ein AS-i Kommando gesendet, falls mit der automatischen Adressprogrammierung eine Betriebsadresse zu setzen ist oder über die AS-i Kommando-Schnittstelle (Index 0x2000 ) ein AS-i Kommando angefordert wurde. Ansonsten geht der AS-i Master in die Aufnahmephase über, ohne ein AS-i Kommando zu senden.
Aufnahmephase
In der Aufnahmephase wird immer nur genau ein Kommando gesendet. Dabei wird versucht, neue AS-i Slaves zu finden und zu aktivieren, der jeweilige Status wird entsprechend aktualisiert. Die Schritte sind dabei die gleichen wie in der Erkennungs- bzw. Aktivierungsphase, nur dass die Schritte jetzt auf bis zu sieben Zyklen verteilt werden.


Adressvergabe der AS-i-Slaves

Inbetriebnahme [image] Funktionalität des AS-i Masters [image] Adressvergabe der AS-i-Slaves
Adressvergabe der AS-i-Slaves
Die Adressvergabe kann durch den AS-i Master oder durch ein Adressiergerät erfolgen. AS-i Slaves werden in der Regel mit Adresse 0 ausgeliefert. Neu hinzugefügte Slaves werden unter dieser Adresse gesucht, anschließend wird eine Adresse zugeteilt. Die Adresse 0 ist in der Datenaustauschphase nicht zulässig.
Ab AS-i Spezifikation 2.1 wird die erweiterte Adressierung unterstützt, so daß entsprechende Slaves auch die Adressen 1B...31B bekommen können. 0B ist nicht erlaubt.
Normale Adressvergabe
Neue AS-i Slaves haben in der Regel die Adresse 0. Über den Parameter 0x2000 (AS-i Kommandoschnittstelle) kann ein Adressieraufruf-Kommando angestoßen werden. Das Adressieraufruf-Kommando funktioniert aber nur, wenn genau ein AS-i Slave mit der Adresse 0 am Bus angeschlossen ist. Eine weitere Möglichkeit zur Adressierung wird im Kapitel Quickstart aufgezeigt


Automatische Projektierung

Inbetriebnahme [image] Funktionalität des AS-i Masters [image] Automatische Projektierung
Automatische Projektierung
Automatische Adressvergabe
Die automatische Adressvergabe muss im Index 0xF100:03 freigeschaltet werden.
Configuration Mode
Im Configuration Mode bekommt ein gefundener Slave mit Adresse 0 automatisch die nächste freie Adresse.
Protected Mode
Im Protected Mode wird ein AS-i Slave mit der Adresse 0 automatisch mit seiner neuen Adresse programmiert, falls genau ein projektierter AS-i Slave fehlt, und kein anderer nicht projektierter AS-i Slave am Bus ist. Damit kann während des Betriebs ein AS-i Slave (der nicht mehr funktioniert), ausgetauscht werden.


Quickstart

Inbetriebnahme [image] Quickstart
Quickstart
Zur Erstinbetriebnahme der EL6201 sind keine besonderen Maßnahmen erforderlich.
Die Kenntnis des einführenden Kapitels Technologie wird vorausgesetzt.
In den folgenden Beispielen wird zunächst die manuelle Adressierung und die Einbindung eines digitalen AS-I-Slave in das TwinCAT-System anschaulich dargestellt.
Bei der automatischen Adressierung wird die EL6201 beispielhaft mit 2 digitalen und einem analogen AS-I Slave in Betrieb genommen.
Die EL6201 wird mit der nachstehenden Konfiguration in Betrieb genommen:
▪
Betriebssystem Windows 7 Professional SP1
▪
TwinCAT 2.11 R3 Build 2256, installierte AS-I System Manager Extension
▪
Klemmenverbund EK1100, EL1202, EL6201 und EL9010
▪
AS-I Standard-Netzteil 30,5 V
▪
AS-I Slave 2 Button / 2 LED
▪
AS-I Slave 4 digitale Inputs
▪
AS-I Slave 4 digitale Outputs
AS-I System Manager Extension an Windows 32 Bit und 64 Bit Systemen
Die AS-I System Manager Extension ist unter Windows 7 Professional SP1 32 Bit und 64 Bit getestet und lauffähig.
1. Montage und Anschluss
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System sowie das AS-I Netzteil in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
▪
Montieren Sie die EL6201 in den Klemmenverbund, wie im Kapitel Montage und Verdrahtung beschrieben.
Leitungslängen
Beim Einsatz der EL9520 (Potenzialverteilerklemme mit Filter, AS-I Power 24) darf die maximale Ausdehnung der Netzwerktopologie 50 m nicht überschreiten!
Bei der Bestimmung der Gesamtlänge müssen alle Abzweige mit einbezogen werden (Abb. Verdratungsplan AS-I-Netzteil und AS-I-Slave mit der EL6201).
Wird ein AS-I-Standard-Netzteil verwendet, beträgt die maximale Topologie-Ausdehnung 100 m.
Maximale Topologieausdehnung mit standard AS-I power supply und AS-I Power24 supply
▪
Schließen Sie den AS-I Slave und das Standard-Netzteil 24 V gemäß des unten stehenden Verdrahtungsplans (Abb. Verdratungsplan AS-I-Netzteil und AS-I-Slave mit der EL6201) an die EL6201 an. Die korrekte Verbindung des Slaves wie im Kapitel Technologie beschrieben, wird vorausgesetzt.
▪
Alternativ kann die Stromversorgung der AS-I Slaves auch über die AS-I-Potenzialeinspeiseklemme EL9520 wie im Kapitel Anschlussbelegung beschrieben, erfolgen.
Verdrahtungsplan AS-I-Slave mit der EL6201
▪
Schalten Sie die Spannungsversorgung des Busklemmensystems und das AS-I-Netzteil ein.
2. Konfiguration
TwinCAT-Konfigurationserstellung
Neuerungen ab Firmware 02 und TwinCAT-PlugIn, Version 2.1
Firmware 02:
• Unterstützung des M4-Master-Profils für Slaves des Typs 2, 3, 5 (S-7.5.5, S-7.A.5, S-B.A.5; S7.A.7, S-7.A.A; S-6.0) (aktivierbar via Flag in ASIControl)
• Unterstützung von Power24 (aktivierbar via Flag in ASIControl)
• Änderung ExtendedID-Code möglich

TwinCAT-PlugIn, Version 2.1:
• Erweiterte Ansicht für neue Slavetypen
• Neues Design zur intuitiveren Benutzung
• Vereinfachte Projektierung, Standard- und Advanced-Mode
• Optimierung für niedrige Auflösungen und hohe DPI-Einstellungen zur optimalen Bedienung in nicht optimalen Arbeitsumgebungen
Download der aktuellsten EtherCAT XML Device Description und der AS-I System Manager Extension
Stellen Sie sicher, dass sie die aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterladen und entsprechend der Installationsanweisungen installieren.
Die unten beschriebene Adressierung der AS-I Slaves setzt die Installation der AS-I System Manager Extension voraus, die Sie bitte ebenfalls herunterladen und installieren.
▪
Erstellen Sie eine Konfiguration im TwinCAT Systemmanager, indem Sie die Klemme manuell einfügen oder online scannen. Beachten Sie dazu die Installationskapitel TwinCAT 2.x.
▪
Der TwinCAT-Baum stellt sich nun wie folgt dar:
Konfigurationsbaum im TwinCAT System-Manager
Manuelles Adressieren des AS-I-Slaves
AS-I Adresse
Die Adresse eines fabrikneuen AS-I-Slaves ist immer "0".
Die Adressierung eines fabrikneuen AS-I-Slaves kann mittels des TwinCAT System Managers vorgenommen werden. Die Installation der AS-I System Manager Extension wird hierbei vorausgesetzt.
▪
Klicken Sie auf die EL6201 im TwinCAT-Baum (A) und den Reiter "Settings" (B). Klicken Sie anschließend den Button "ASI System Overview" (C), um zur unten stehenden AS-I-Übersicht zu gelangen, in der die zu adressierenden AS-I-Slaves angezeigt werden.
▪
Das "ASI Config Mode" (D) Feld in der Statusleiste wird blau dargestellt. Wird hier ein grünes Feld "ASI Protected Mode" angezeigt, klicken Sie auf das Feld, um in den "ASI Config Mode" zu gelangen
Statusleiste
Über die Statusleiste in der Systemübersicht ist ersichtlich, in welchem Zustand sich das System befindet. Einstellungen, die unterstrichen sind, können geändert werden (Wechsel zwischen Config Mode/Protected Mode, Aktivierung/Deaktivierung des Datenaustauschs).
▪
Der mit dem gelben Punkt markierte Slave "0" (E) ist der angeschlossene, bereits detektierte Slave, der mit einer gültigen Adresse belegt werden soll
AS-I-Systemübersicht mit den zu adressierenden Slaves
▪
Um die Slave-Adresse "0" in eine gültige Adresse umzuwandeln, rechtsklicken Sie auf den gelben Punkt im Adressfeld "0", um anschließend über das Auswahlfeld "Change Address" eine AS-I-Adresse auszuwählen, im Beispiel die Adresse "1A".
Adressvergabe für den AS-I-Slave
▪
Die Adresse wird nun als „Detected and activated“ (blau) angezeigt.
Adressvergabe für den AS-I-Slave akzeptiert
▪
Um die Projektierung für den Slave abzuschließen, klicken Sie auf das blaue Feld "ASI Config Mode" (B), das System schaltet in den "ASI Protected Mode" (grünes Feld).
▪
Um den AS-I Datenaustausch zu ermöglichen, klicken Sie in das graue Feld "ASI Data Exc INACTIVE", das Feld wechselt auf grün "ASI Data Exc ACTIVE" (C).
▪
Die vollständige Konfiguration wird mit dem grünen Feld "ASI Config OK" angezeigt.
Umschalten in den „Protected Mode“ und Abschluss der Projektierung“
Automatisches Adressieren der AS-I-Slaves
AS-I-Adresse bei Automatischer Adressierung
Für die automatische Vergabe von AS-I-Adressen an der EL6201 müssen die angeschlossenen AS-I-Slaves zwingend die Adresse "0" haben (unadressiert).
Die sukzessive automatische Vergabe von Adressen ist nicht möglich, wenn ein Slave bereits adressiert/projektiert ist.
Die automatische Adressierung wird ebenfalls mithilfe der AS-I System Manager Extension durchgeführt.
▪
Die o.g. AS-I-Slaves sind noch nicht mit der AS-I-Feldbusleitung verbunden, haben die Adresse "0" bzw. sind fabrikneu.
▪
Klicken Sie auf die EL6201 im TwinCAT-Baum und den Reiter "Settings" (A). Klicken Sie anschließend auf den Button "ASI Master EL6201“ (B), um zur unten stehenden Ansicht zu gelangen.
▪
Stellen Sie sicher, dass die Klemme sich im "ASI Config Mode" (blau) befindet, ggf. durch Klicken in diesen Modus versetzen (C)
▪
Im Feld "Control PDO" den "Auto Programming Mode" setzen (D)
Aktivieren des „Auto Programming Mode“
▪
Klicken Sie nun wie in Abb. Umschalten in den „Protected Mode“ und Abschluss der Projektierung den Button "ASI System Overview" (A) und Sie sehen wie in der nachfolgenden Ansicht, dass noch kein Slave detektiert/projektiert ist (B).
Kein detektierter Slave in der AS-I System Übersicht
▪
Kontaktieren Sie nun den ersten Slave mit der AS-I Feldbusleitung. Wie in der folgenden Ansicht dargestellt, wird der Slave mit "1A" automatisch adressiert (Abb. Der erste kontaktierte Slave erhält die Adresse „1A“). Diese Adresse ist nun im Slave fest implementiert.
▪
Verbinden Sie nun die weiteren Slaves mit der AS-I Feldbusleitung. Die Slaves werden wie in den unteren Abb. mit der Adresse "2A" und "3A" angelegt.
Der erste kontaktierte Slave erhält die Adresse „1A“
Der zweite kontaktierte Slave erhält die Adresse „2A“
Probleme bei der Projektierung durch AS-I „Periphery Fault“
Beim Projektieren eines neuen AS-I Slaves kann ggf. ein AS-I „Periphery Fault“ die Automatische Projektierung in einen undefinierten Zustand setzen, dies zeigt sich durch wechselndes Blinken in der Projektierungsübersicht, wie in Abb. Undefinierter Zustand eines zu projektierenden Slaves dargestellt.

Abhilfe:
Klicken Sie auf den grauen Button „ASI Data Exc INACTIVE“, der auf grün „ASI Data Exc ACTIVE“ wechselt (siehe Abb.), die Anzeige der Slaves sollte sich dann stabil im Zustand „Detected and activated“ (blau) darstellen.
Undefinierter Zustand des zu projektierenden Slaves
Abhilfe: Aktivierung des AS-I Datenaustauschs
Der dritte kontaktierte Slave erhält die Adresse „3A“, Umschaltung in den „AS-I Protected Mode“, Bestätigung der Konfiguration
▪
Klicken Sie nun den blauen "AS-I Config Mode" Button um die Projektierung abzuschließen (Abb. Der dritte kontaktierte Slave erhält die Adresse „3A“, Umschaltung in den „AS-I Protected Mode“, Bestätigung der Konfiguration). Es erscheint der grüne "ASI Protected Mode" Button (A). Eine korrekte Projektierung wird mit "ASI Config OK" bestätigt (B).
Ausfall eines Slaves in der AS-I-Konfiguration
Automatische Adressierung im Austauschfall
Im Austauschfall (Slave defekt) kann ein fabrikneuer oder mit "0" adressierter Slave anstelle des defekten Slaves eingesetzt werden.
Der neu eingesetzte Slave erhält bei automatischer Adressierung die korrekte Adresse des ausgetauschten Slaves.
Im Fehlerfall (Unterbrechung der Verbindung des Slaves zum AS-I Feldbus) wird wie in Abb. Ausfall des Slaves „2A“, der betroffene Slave als "Projected, but not Detected" dargestellt (A). Das grüne "ASI Config OK" erlischt und wechselt auf ein rotes „ASI Config NOT OK“ (B)
Abhilfe: Überprüfen Sie die Verbindung vom Slave zur AS-I-Feldbusleitung; ein in diesem Beispiel verwendete Slave könnte z. B. nicht korrekt verschraubt sein, so dass die notwendige Durchdringungstiefe zum Feldbuskabel nicht erreicht wird.
Ausfall des Slaves „2A“, rot markiert
Änderungen der ASi-Slave Overview Ansicht
Die Darstellungsweise der "ASI System Overview" Ansicht kann wie in den unteren Ansichten gewählt werden:
Darstellung sämtlicher Slaves ohne Details die konfiguriert werden können, detektierte, projektierte und aktive Slaves sind grün markiert
Darstellung der Slaves ohne Details, die detektiert und projektiert sind
Um nur die Slaves darzustellen, die projektiert und aktiv sind, rechtsklicken Sie unterhalb der dargestellten Slaves in die graue Fläche (oder wählen das Menü über den Button „View“ an) und wählen Sie im Kontextmenü "Hide not Extisting Slaves In Overview" (Abb. Darstellung der Slaves ohne Details, die detektiert und projektiert sind)
Darstellung der Slaves mit Details, die detektiert und projektiert sind
Um die Details der Slaves darzustellen, die projektiert und aktiv sind, rechtsklicken Sie unterhalb der dargestellten Slaves in die graue Fläche (oder wählen das Menü über den Button „View“ an) und wählen Sie im Kontextmenü "Show Slave Details" (Abb. Darstellung der Slaves mit Details, die detektiert und projektiert sind)
Darstellung der Profile der Slaves, die detektiert und projektiert sind
Darstellung der Prozessdaten der Slaves, die detektiert und projektiert sind
Nun können sie zwischen "Show Slave Info Data" und „Show Process Data auswählen“ (siehe Abb. oben)
3. Einstellen der Parameter und Prozessdaten
CoE-Parameter
Falls die Default-CoE-Parameter geändert werden sollen, müssen sie kanalweise im CoE hinterlegt werden.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Die CoE-Einstellungen können auch über die SPS/PLC/Task zur Laufzeit geladen werden.
4. Betrieb
Bei anliegender Spannung/Strom werden nun nach TwinCAT-Neustart z. B. im TwinCAT FreeRun-Modus die Prozessdaten ausgetauscht.


Weitere Hinweise zur Inbetriebnahme

Inbetriebnahme [image] Weitere Hinweise zur Inbetriebnahme
Weitere Hinweise zur Inbetriebnahme
Systemübersicht
Eigenschaftenfenster mit weiteren Informationen
Durch einen Doppelklick auf einen Slave in der Systemübersicht kann ein Eigenschaftenfenster (siehe Abb.) geöffnet werden, um Einstellungen am Slave vorzunehmen, oder Diagnosedaten einzusehen.
In den Slave-Eigenschaften sind das Slave-Profil, sowie die Diagnosedaten ersichtlich. Je nach Slave-Profil stehen weitere Optionen zur Verfügung, etwa ASi-String-Parameter oder String-Parameter für serielle Slaves. Außerdem können hier Parameter eingestellt und die Projektierung vorgenommen werden (manuelle Projektierung nur im Advanced Mode).
Linker Bereich des Reiters Settings
Im linken Bereich des PlugIns (siehe Abb.) kann zwischen der Systemübersicht und den Einstellungen zum ASI-Master umgeschaltet, sowie das Optionsmenü aufgerufen werden. Die ASi-Listen stellen schnell ablesbare Informationen zu erkannten, aktivierten und projektierten Slaves, sowie zu Peripheriefehlern bereit.
AS-i Master Ansicht
In der ASI-Master-Ansicht sind die Status-Werte des Systems aufgelistet und einstellbar. Wichtig sind weiterhin die Angaben zur Firmware-Version und zur Extension (PlugIn)-Version, die bei Supportanfragen stets mit anzugeben sind.
Projektierung
Die Möglichkeiten der Projektierung über das PlugIn unterscheiden sich je nach gewählter Ansicht, wobei die Erweiterte Ansicht sich wie folgt von der Standard-Ansicht unterscheidet:
▪
Standard-Ansicht
Automatische Projektierung wählbar (sieh Abb. Optionsmenü „Project all detected Slaves“). Das PlugIn projektiert alle angeschlossenen (erkannten) Slaves gemäß ihrem Profil. Das System ist nach der Projektierung bereit und arbeitet im Protected Mode (Automatischer Start in Protected Mode).
Optionsmenü „Project all detected Slaves“
▪
Erweiterte Ansicht
Zusätzlich stehen hier manuelle Projektierungsmöglichkeiten zur Verfügung. Für jeden Slave kann über das Eigenschaftenfenster das gewünschte Profil manuell vorgegeben werden
Manuelle Progarmmierung
Die Speicherung kann in die Startup-Daten oder direkt in die Klemme erfolgen (CoE) (siehe Abb.).
Speicherung der StartUp-Daten
Es wird die Automatische Projektierung empfohlen
Hinweise zur Funktion „Auto Programming“
Wird die Funktion „Auto Programming“ im Config-Mode genutzt, wird jedem neuen Slave mit Adresse 0 automatisch die nächste freie Adresse zugewiesen. Bitte beachten Sie hierfür, dass Slaves mit dem Profil S-6.0 mehrere Adressen beanspruchen können.
Besonderheiten M4-Slaves (CTT2, CTT3, CTT5)
▪
Slave Type3
Slaves vom Typ CTT2 (S-7.5.5, S-7.A.5, S-B.A.5) besitzen im Eigenschaftsfenster einen weiteren Karteireiter „Objects“ (siehe Abb.), über den azyklische Kommunikation mit dem Slave über AS-i String Command durchgeführt werden kann.
M4 Slave, Karteireiter „Objects“
▪
Slave Type 3
Slaves vom Typ CTT3 (S-7.A.7, S-7.A.A, S-7.A.8) können im A- und B-Bereich verwendet werden (Extended Address Mode). Die Digitalen I/O-Daten werden im analogen Prozessabbild (Inputs: 0x6XXX-Bereich, Outputs: 0x7XXX-Bereich) abgelegt und in der Systemübersicht entsprechend angezeigt.
▪
Slave Type 5
Slaves vom Typ CTT5 (S-6.0) erreichen eine höhere Geschwindigkeit durch die Inanspruchnahme mehrerer Slave-Adressen. Je nach Slave kann die Anzahl der verwendeten Slave-Adressen über den Extended-ID-Code eingestellt werden. Zur Änderung des Extended-ID-Code muss der Slave Adresse 0 einnehmen, siehe hierzu untere Abb.
Slave Type 5, Änderung des Extended-ID-Codes
Die Prozessdaten werden in den analogen Prozessdaten des Slave abgelegt.
Automatische Adressierung mit Slaves Type 5
Ist die Auto-Adressierung im Config-Mode aktiviert, werden Slaves mit Adresse 0 automatisch die nächste freie Adresse zugewiesen. Da Slaves vom Typ CTT5 weitere Slaveadressen in Abhängigkeit von der Startadresse belegen, kann es hier zu Überschneidungen kommen, wenn nicht genügend nachfolgende Adressen frei sind.
CoE-Erweiterungen
- Zugriff auf M4-Profile
▪
Slaves aus CTT2 Profil (S-7.5.5, S-7.A.5, S-7.B.A)
- Zyklische Kommunikation via Analog-Datenobjekt je Slave (AODI/AIDI) – Adressbereich im CoE 0x6000/0x7000
- Azyklische Kommunikation via „ASI String Command“ (0x2010-Objekt).
Kommando-Aufbau:
Byte | Content
0 | Increment for new command
1 | 0x02 (Write Paramater string)
2 | Slaveaddress*
3 | Command-Length**
4 - 7 | Reserved
8.. | Command
Example: 01 02 03* 03** 00 00 00 00 10 00 DB
▪
Slaves aus aus CTT3 Profil (S-7.A.7, S-7.A.A), Slaves aus CTT4-Profil (S-7.A.8, S-7.A.9), sowie Slaves aus CTT5-Profil (S-6.0)
- Daten von 4I/ 4O Slaves (S-7.A.7) werden direkt in die Digitalen Ein- und Ausgangsdaten übertragen
- Daten von 8/8O-Slaves werden die Analog-Datenobjekte übertragen (Value Channel)
- Änderung ExtendedID-Code
▪
Der ExtendedID-Code eines Slaves lässt sich ändern, wenn der Slave an Adresse 0 anliegt (und dies unterstützt).
▪
Die Änderung erfolgt über das Objekt „ASI Command“ (0x2000)
Befehl:
Byte | Content
0 | Increment for new command
1 | 0xC (change ID Code)
2 | New ID Code
Sehen Sie dazu auch
•
Technologie


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Kommando-Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informationsdaten
•
Diagnostikdaten
•
ASI-Daten


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:0 | ASI Settings Slave | Max. Subindex | UINT8 | RO | > 41 <
8pp0:01 | ASI Address | Slave Adresse (siehe folgende Tabelle) | UINT16 | RW | 0x0000 (0dez)
Bit | Wert | Beschreibung
0 - 4 | 0 - 31 (default 0) | Slave Adresse (0=>Eintrag inaktiv, XX=>Eintrag aktiv) (Slaveadresse ergibt sich aus Bit 4 bis Bit 8 des Index (0x8pp0)
5 - 11 | - | reserviert
12 | 0bin | A- bzw. Standard-Slave nicht projektiert
 | 1bin | A- bzw. Standard-Slave projektiert
13 | 0bin | B-Slave nicht projektiert
 | 1bin | B-Slave projektiert
14 - 15 | - | reserviert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:20 | IO Configuration (A-Slave) | Projektierte E/A-Kennung (Soll-Konfiguration) Im geschützten Betriebsmodus wird die E/A-Kennung der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit-E/A-Kennungen der AS-i Slaves befinden sich im Objekt 0x8pp0:20 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | IO Config (A- oder Standard-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:21 | ID Code (A-Slave) | Projektierter ID-Code (Soll-Konfiguration) Im geschützten Betriebsmodus wird der ID-Code der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit-ID-Codes der AS-i Slaves befinden sich im Objekt 0x8pp0:21 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | ID Code (A- oder Standard-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:22 | Extended ID Code 1 (A-Slave) | Projektierter Extended ID-Code 1 (Soll-Konfiguration) Im geschützten Betriebsmodus wird der Extended ID-Code 1 der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit Extended ID-Codes 1 der AS-i Slaves befinden sich im Objekt 0x8pp0:22 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | Extended ID Code 1 (A- oder Standard-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:23 | Extended ID Code 2 (A-Slave | Projektierter Extended ID-Code 2 (Soll-Konfiguration) Im geschützten Betriebsmodus wird der Extended ID-Code 2 der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit Extended ID-Codes 1 der AS-i Slaves befinden sich im Objekt 0x8pp0:23 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | Extended ID Code 2 (A- oder Standard-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:24 | Parameter (A-Slave) | Aktivierungs-Parameter der AS-i Slaves In der Aktivierungsphase (oder in der Aufnahmephase - bei später hinzugefügten AS-i Slaves) werden, bevor das erste Mal ein Datenaustausch durchgeführt wird, einmal 4 Bit Parameterdaten zu jedem AS-i Slave gesendet. Über die Objekte 0x8pp0:24 können diese Aktivierungs-Parameter für jeden AS-i Slave vorgegeben werden. Die Objekte 0x8pp0:24 können gelesen oder beschrieben werden und sind im Flash des AS-i Masters gespeichert, d.h. sind nach Power Off/On der AS-i Masters noch vorhanden. (siehe folgende Tabelle) | UINT8 | RW | 0x0F (15dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 15) | Parameter (A- oder Standard-Slave)
4 - 7 | - | reserviert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:25 | IO Configuration (B-Slave) | Projektierte E/A-Kennung (Soll-Konfiguration) Im geschützten Betriebsmodus wird die E/A-Kennung der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit-E/A-Kennungen der AS-i Slaves befinden sich im Objekt 0x8pp0:20 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | IO Config (B-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:26 | ID Code (B-Slave) | Projektierter ID-Code (Soll-Konfiguration) Im geschützten Betriebsmodus wird der ID-Code der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit-ID-Codes der AS-i Slaves befinden sich im Objekt 0x8pp0:21 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | ID Code (B-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:27 | Extended ID Code 1 (B-Slave) | Projektierter Extended ID-Code 1 (Soll-Konfiguration) Im geschützten Betriebsmodus wird der Extended ID-Code 1 der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit Extended ID-Codes 1 der AS-i Slaves befinden sich im Objekt 0x8pp0:22 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | Extended ID Code 1 (B-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:28 | Extended ID Code 2 (B-Slave | Projektierter Extended ID-Code 2 (Soll-Konfiguration) Im geschützten Betriebsmodus wird der Extended ID-Code 2 der projektierten AS-i Slaves überprüft. Die projektierten 4-Bit Extended ID-Codes 1 der AS-i Slaves befinden sich im Objekt 0x8pp0:23 (diese Objekte sind Read-Write und werden im Flash des AS-i Masters gespeichert (d.h. sind nach Power Off/On noch vorhanden)): (siehe folgende Tabelle) | UINT8 | RW | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 3 | 0 - 15 (default 0) | Extended ID Code 2 (B-Slave)
4 - 6 | - | reserviert
7 | 0 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode mit einbezogen
 | 1 | Wert wird beim Vergleich Soll/Ist Konfiguration im Protected Mode ignoriert
Index 8pp0 ASI Settings Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:29 | Parameter (B-Slave) | Aktivierungs-Parameter der AS-i Slaves In der Aktivierungsphase (oder in der Aufnahmephase - bei später hinzugefügten AS-i Slaves) werden, bevor das erste Mal ein Datenaustausch durchgeführt wird, einmal 4 Bit Parameterdaten zu jedem AS-i Slave gesendet. Über die Objekte 0x8pp0:24 können diese Aktivierungs-Parameter für jeden AS-i Slave vorgegeben werden. Die Objekte 0x8pp0:24 können gelesen oder beschrieben werden und sind im Flash des AS-i Masters gespeichert, d.h. sind nach Power Off/On der AS-i Masters noch vorhanden. (siehe folgende Tabelle) | UINT8 | RW | 0x07 (7dez)
Bit | Wert | Beschreibung
0 - 2 | 0 - 7 (default 7) | Parameter (B-Slave)
3 - 7 | - | reserviert


Kommando-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Kommando-Objekt
Kommando-Objekt
Index 2000 ASI Command
Mit dem Index 2000 können Sie Kommandos zu den AS-i Slaves senden. Dies ist sowohl in der Offline-Phase (keine anderen Kommandos auf dem AS-i Bus) als auch in der Management-Phase möglich. In der Managementphase können Sie aber nur nicht aktivierte AS-i Slaves ansprechen.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2000:0 | ASI Command | Max. Subindex | UINT8 | RO | 0x03 (3dez)
2000:01 | Request | Slave Adresse (siehe folgende Tabelle) | OCTET-STRING[4] | RW | {0}
Bit | Wert | Beschreibung
0 - 4 | 0 - 255 | Kommando Sequenz Nummer (sollte inkrementiert werden, damit das Kommando gesendet wird)
8 - 15 | 1 | reserviert
 | 2 | reserviert
 | 3 | reserviert
 | 4 | AS-i Kommando Parameter schreiben
 | 5 | reserviert
 | 6 | reserviert
 | 7 | AS-i Kommando Adressieraufruf Wenn in Bit 16 bis 23 eine Adresse ungleich 0 angegeben wird, wird zuerst das AS-i Kommando "Betriebsadresse löschen" aufgerufen, da die Adresse nur eingestellt werden kann, wenn sie vorher auf 0 war.
 | 8 | reserviert
 | 12 | AS-i Kommando ExtendedID-Code ändern (Slave muss sich an Adresse 0 befinden)
16 - 23 | 0 - 63 | Adresse des AS-i Slaves, an den das Kommando gesendet werden soll (32 ist nicht erlaubt)
24 - 31 | 0 - 31 | Daten des AS-i Kommandos: • bei AS-i Kommando Parameter schreiben: Parameterdaten • bei AS-i Kommando Adressieraufruf: neue Adresse • bei AS-i Kommando ExtendedID-Code ändern neuer ID Code
Index 2000 ASI Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2000:02 | Status | (siehe folgende Tabelle) | UINT8 | RO | 0x00 (0dez)
Bit | Wert | Beschreibung
0 - 7 | 0 | ASI_COMMAND_READY (Kommandoobjekt betriebsbereit, Index 0x2000:01)
 | 1 | ASI_COMMAND_BUSY (Kommandoobjekt nicht betriebsbereit, Index 0x2000:01)
 | 2 - 255 | reserviert
Index 2000 ASI Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
2000:03 | Response | (siehe folgende Tabelle) Für Quittung zum AS-i Kommando (AS-i Kommandowert Bit 4 gesetzt): Parameter schreiben Bit 31 bis 24 geben die im Aufruf des AS-i Kommandos übergebenen Daten (Bit 31 bis 24 des AS-i Kommandos) zurück. Für Quittung zum AS-i Kommando (AS-i Kommandowert Bit 7 gesetzt): Adressieraufruf Falls das Error-Bit (Bit 15) nicht gesetzt ist, enthalten Bit 31 bis 24 den Wert 00hex. Falls das Error-Bit (Bit 15) gesetzt ist, enthalten Bit 31 bis 24 einen Fehler-Code. (siehe folgende Tabelle) | OCTET-STRING[4] | RW | {0}
Bit | Beschreibung
0 - 7 | Kommando Sequenz Nummer aus dem Request
8 - 14 | Entsprechen den Bits 8 bis 15 des Kommando-Aufrufs.
15 | Error-Bit: Falls Bit 15 gesetzt ist, ist bei der Ausführung des Kommandos ein Fehler aufgetaucht und in Bit 31 bis 24 wird ein Fehler-Code ausgegeben!
16 - 23 | Adresse des AS-i Slaves, an den das Kommando gesendet wurde.
Bit | Wert | Beschreibung
24 - 31 | 0x00 | Die Adressänderung wurde erfolgreich durchgeführt.
 | 0x11 | Es ist kein Slave mit der als alte Adresse angegebenen Adresse vorhanden.
 | 0x22 | Die Adresse 0 wird zurzeit von einem anderen Slave belegt. Zum Ändern der Adresse eines AS-i Slaves, muss die EL6201 diesem zuerst die Adresse 0 zuweisen, um ihn danach von dort aus neu zu adressieren.
 | 0x36 | Es ist bereits ein Slave mit der als neue Adresse angegebenen Adresse vorhanden
 | 0x47 | Nach dem Löschen der alten Adresse ist kein Slave mit der Adresse 0 vorhanden.
 | 0x58 | Nach dem Löschen der alten Adresse kommt beim Lesen des Extended ID-Code 1 von Slave 0 ein Fehler. Bei A/B-Slaves wird zur Adressänderung auch der Extended ID-Code 1 benötigt.
 | 0x69 | Nach dem Schreiben des Extended ID-Code 1 ist kein Slave mit Adresse 0 vorhanden.
 | 0x6B | Nach dem Schreiben der neuen Adresse ist der Slave mit der neuen Adresse beim Lesen des ID-Codes nicht vorhanden.
 | 0x6C | Nach dem Schreiben der neuen Adresse ist der Slave mit der neuen Adresse beim Lesen des Status nicht vorhanden.
 | 0x7D | Die Adresse konnte nicht dauerhaft (non-volatile) gespeichert werden.
 | 0x7E | Der Extended ID-Code eines A/B-Slaves konnte nicht dauerhaft (non-volatile) gespeichert werden.
 | 0x7F | ID-Code 1 ist falsch bei A/B-Slaves
 | 0x83 | Die neue Adresse ist eine B-Adresse. Wenn auf zwei parallelen Adressen im Adressbereich A und Adressbereich B, z. B. 10A (10) und 10B (42), Slaves betrieben werden sollen, müssen beide Slaves die B-Adressierung unterstützen. In diesem Fall ist auf der parallelen A-Adresse ein Slave vorhanden, der die B-Adressierung nicht unterstützt!
 | 0x84 | Die neue Adresse ist eine B-Adresse. Der mit der alten Adresse ausgewählte Slave ist aber kein A/B-Slave, d.h. er unterstützt die B-Adressen (1B bis 31B) nicht.
 | 0x85 | Die neue Adresse ist eine A-Adresse. Slave ist kein A/B-Slave: zugehöriger B-Slave für neue Adresse ist vorhanden.
Index 2010 ASI String Command
Mit dem Objekt 0x2010 können Sie String Kommandos zu den AS-i Slaves senden (Analog Slaves Profil 7.4 und CTT2 Slaves des M4-Profils). Dies ist nur möglich, wenn der ASI-Master sich bereits in der Datenausstauschphase befindet und das „Data Exchange Active“ Bit im ASI Control gesetzt ist.
Index (hex) | Name | Bit | Wert | Bedeutung | Data type | Flags | Default
2010:0 | ASI Command | - | - | Max. Subindex | UINT8 | RO | 0x03 (3dez)
2010:01 | Request | 0 - 7 | 0 - 255 | Kommando Sequenz Nummer (sollte inkrementiert werden, damit das Kommando gesendet wird) | OCTET-STRING[256] | RW | {0}
 |  | 8 - 15 | 0, 1, 3 - 9 | reserviert
 |  |  | 2 (0x2) | Write CTT2 Parameter String
 |  |  | 10 (0xA) | Write Parameter String
 |  |  | 11 (0xB) | Read Parameter String
 |  |  | 12 (0xC) | Read Diagnosis String
 |  |  | 13 (0xD) | Read ID String
 |  |  | 14 - 255 | reserviert
 |  | 16 - 23 | 0 - 31 | Adresse des AS-i Slaves, an den das Kommando gesendet werden soll
 |  | 24 - 31 | 0 - 31 | Kommando-Länge (Anzahl der nachfolgenden Command-Bytes/String Daten) – nur CTT2
 |  | 32 - 63 | - | reserviert
 |  | 64 - 2047 | xxxx | String-Daten
2010:02 | Status | 0 - 7 | Bit 0 = 0 | ASI_STRING_COMMAND_READY (Kommandoobjekt betriebsbereit, Index 0x2010:01) | UINT8 | RO | 0x00 (0dez)
 |  |  | Bit 0 = 1 | ASI_STRING_COMMAND_BUSY (Kommandoobjekt nicht betriebsbereit, Index 0x2010:01)
 |  |  | Bit 1 - 5 | Reserviert
 |  |  | Bit 6 | Datenaustausch nicht aktiv
 |  |  | Bit 7 | PWR fail
2010:03 | Response | 0 - 7 | Kommando Sequenz Nummer aus dem Request |  | OCTET-STRING[256] | RO | {0}
 |  | 8 - 14 | Entsprechen den Bits 8 bis 15 des Kommando-Aufrufs.
 |  | 15 | Error-Bit: Falls Bit 15 gesetzt ist, ist bei der Ausführung des Kommandos ein Fehler aufgetaucht und in Bit 31 bis 24 wird ein Fehler-Code ausgegeben!
 |  | 16 - 23 | Adresse des AS-i Slaves, an den das Kommando gesendet wurde.
 |  | 24 - 31 | Falls das Error-Bit (Bit 15) gesetzt ist, enthalten Bit 31 bis 24 einen Fehler-Code.
 |  |  | 0x00 | Kommando wurde erfolgreich durchgeführt.
 |  |  | 0x10 | Slave ist kein Analog-Slave
 |  |  | 0x20 | Slave unterstützt Analog Slave Profil 7.4 nicht
 |  |  | 0x40 | String Transfer ist bereits aktiv
 |  |  | 0x80 | Datenaustausch ist nicht aktiv
 |  |  | 0x08 | Kommando wird nicht unterstützt
 |  | 32 - 63 | - | reserviert
 |  | 64 - 2047 | xxxx | String Daten


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 6pp0 ASI Analog Inputs Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
6pp0:0 | ASI Analog Inputs Slave | Max. Subindex | UINT8 | RO | 0x08 (8dez)
6pp0:01 | State Ch.1 (A-Slave) | Status Kanal 1 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:02 | Value Ch.1 (A-Slave) | Eingangsdaten Kanal 1 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:03 | State Ch.2 (A-Slave) | Status Kanal 2 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:04 | Value Ch.2 (A-Slave) | Eingangsdaten Kanal 2 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:05 | State Ch.3 (A-Slave) | Status Kanal 3 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:06 | Value Ch.3 (A-Slave) | Eingangsdaten Kanal 3 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:07 | State Ch.4 (A-Slave) | Status Kanal 4 (A-Slave) | UINT16 | RO | 0x0000 (0dez)
6pp0:08 | Value Ch.4 (A-Slave) | Eingangsdaten Kanal 4 (A-Slave) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 7pp0 ASI Analog Outputs Slave (für 01 ≤ pp ≤ 1F; Slave 1 bis Slave 31)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
7pp0:0 | ASI Analog Outputs Slave | Max. Subindex | UINT8 | RO | 0x08 (8dez)
7pp0:01 | State Ch.1 (A-Slave) | Status Kanal 1 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:02 | Value Ch.1 (A-Slave) | Ausgangsdaten Kanal 1 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:03 | State Ch.2 (A-Slave) | Status Kanal 2 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:04 | Value Ch.2 (A-Slave) | Ausgangsdaten Kanal 2 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:05 | State Ch.3 (A-Slave) | Status Kanal 3 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:06 | Value Ch.3 (A-Slave) | Ausgangsdaten Kanal 3 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:07 | State Ch.4 (A-Slave) | Status Kanal 4 (A-Slave) | UINT16 | RW | 0x0000 (0dez)
7pp0:08 | Value Ch.4 (A-Slave) | Ausgangsdaten Kanal 4 (A-Slave) | UINT16 | RW | 0x0000 (0dez)


Informationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Informationsdaten
Informationsdaten
Index 10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Data type | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | reserviert | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | reserviert | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | reserviert | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | reserviert | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | reserviert | UINT16 | RW | 0x0000 (0dez)
10F3:06 - 15 | Diagnosis Message 001 - 016 | reserviert | OCTET-STRING[20] | RO | {0}
Index 10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Data type | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO |
Index 9pp0 ASI Info Data Slave (für 00 ≤ pp ≤ 1F; Slave 0 bis Slave 31)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
9pp0:0 | ASI Info Data Slave | Maximaler Subindex | UINT8 | RO | 0x29 (41dez)
9pp0:01 | ASI Address | Adresse des AS-i Slaves (Ist-Konfiguration) | UINT16 | RO | 0x0000 (0dez)
9pp0:20 | IO Configuration (A-Slave) | Gelesene E/A-Kennung (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:21 | ID Code (A-Slave) | Gelesener Standard-ID-Code (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:22 | Extended ID Code 1 (A-Slave) | Gelesener Extended ID-Code 1 (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:23 | Extended ID Code 2 (A-Slave) | Gelesener Extended ID-Code 2 (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:24 | Parameter (A-Slave) | Antwort des Slaves auf das Aktivierungsparameterkommando ( siehe Objekt 0x8pp0:24) | UINT8 | RO | 0x00 (0dez)
9pp0:25 | IO Configuration (B-Slave) | Gelesene E/A-Kennung (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:26 | ID Code (B-Slave) | Gelesener Standard-ID-Code (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:27 | Extended ID Code 1 (B-Slave) | Gelesener Extended ID-Code 1 (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:28 | Extended ID Code 2 (B-Slave) | Gelesener Extended ID-Code 2 (Ist-Konfiguration) | UINT8 | RO | 0x00 (0dez)
9pp0:29 | Parameter (B-Slave) | Antwort des Slaves auf das Aktivierungsparameterkommando (siehe Objekt 0x8pp0:29) | UINT8 | RO | 0x00 (0dez)


Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Diagnostikdaten
Diagnostikdaten
Index App0 ASI Diag Data Slave (für 00 ≤ pp ≤ 1F; Slave 0 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0 | ASI Diag Data Slave 0 | Maximaler Subindex | UINT8 | RO | 0x12 (18dez)
App0:01 | Communication State (A-Slave) | Slave Status (siehe folgende Tabelle) | UINT16 | RO | 0x00 (0dez)
Beschreibung | Wert
Slave ist in LDS | Bit 0 (LSB)
Slave ist in LAS | Bit 1
Slave ist in LPS | Bit 2
Slave ist in der Betriebsart erweiterte Adressierung (A/B-Slaves) | Bit 3
im Protected Mode wird Slave nur aktiviert, wenn EA-Code dieses Slaves mit dem projektierten Slave übereinstimmt. | Bit 4
im Protected Mode wird Slave nur aktiviert, wenn ID-Code dieses Slaves mit dem projektierten Slave übereinstimmt | Bit 5
im Protected Mode wird Slave nur aktiviert, wenn Extended ID-Code1 dieses Slaves mit dem projektierten Slave übereinstimmt. | Bit 6
im Protected Mode wird Slave nur aktiviert, wenn Extended ID-Code2 dieses Slaves mit dem projektierten Slave übereinstimmt. | Bit 7
Slave unterstützt Extended ID-Code 1 und 2 | Bit 8
Slave ist ein Analog-Slave | Bit 9
Slave ist ein Safety-Slave | Bit 10
reserviert | Bit 11
reserviert | Bit 12
Slave benötigt M4-Master (eines der M4-Profile) | Bit 13 (MSB)
Slave hat keine digitalen Eingänge | Bit 14 (MSB)
Slave hat keine digitalen Ausgänge | Bit 15 (MSB)
Index App0 ASI Diag Data Slave (für 00 ≤ pp ≤ 1F; Slave 0 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:02 | Status Register (A-Slave) | Allgemeine Status-Informationen Letzte erhaltene Antwort eines Slaves auf das Kommando "ReadStatus" (siehe folgende Tabelle) | UINT8 | RO | 0x00 (0dez)
Bit | Beschreibung
0 - 3 | Statusregister von Slave (Default = 0)
4 - 7 | reserviert
Index App0 ASI Diag Data Slave (für 00 ≤ pp ≤ 1F; Slave 0 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:03 | Physical Fault Counter (A-Slave) | Zähler, der inkrementiert, wenn eine Antwort dem entsprechenden AS-i Slave einen Start-Bit-, Stop-Bit- oder Parity-Bit-Fehler hatte | UINT16 | RO | 0x0000 (0dez)
App0:04 | Timeout Counter (A-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave nicht geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:05 | Response Counter (A-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave korrekt geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:06 | Leave Data-Exchange Counter (A-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave aus der LAS ausgetragen wurde, d.h. dreimal hintereinander nicht (oder nicht korrekt) geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:07 | Data-Exchange Failed Counter (A-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave auf ein DataExchange-Telegramm nicht (oder nicht korrekt) geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:08 | Timeout Statistics (A-Slave) | Timeouts pro Telegramm in Prozent | UINT16 | RO | 0x0000 (0dez)
App0:09 | Data-Exchange Repeat Counter (A-Slave) | Wenn der Datenaustausch wiederholt werden muss (Slave hat nicht korrekt oder gar nicht geantwortet), wird dieser Zähler inkrementiert | UINT16 | RO | 0x0000 (0dez)
App0:0A | Communication State (B-Slave) | Slave Status see "Extracted nested table 13" | UINT8 | RO | 0x00 (0dez)
Beschreibung | Wert
Slave ist in LDS | Bit 0 (LSB)
Slave ist in LAS | Bit 1
Slave ist in LPS | Bit 2
Slave ist in der Betriebsart erweiterte Adressierung (A/B-Slaves) | Bit 3
im Protected Mode wird Slave nur aktiviert, wenn EA-Code dieses Slaves mit dem projektierten Slave übereinstimmt. | Bit 4
im Protected Mode wird Slave nur aktiviert, wenn ID-Code dieses Slaves mit dem projektierten Slave übereinstimmt | Bit 5
im Protected Mode wird Slave nur aktiviert, wenn Extended ID-Code1 dieses Slaves mit dem projektierten Slave übereinstimmt. | Bit 6
im Protected Mode wird Slave nur aktiviert, wenn Extended ID-Code2 dieses Slaves mit dem projektierten Slave übereinstimmt. | Bit 7
Slave unterstützt Extended ID-Code 1 und 2 | Bit 8
Slave ist ein Analog-Slave | Bit 9
Slave ist ein Safety-Slave | Bit 10
reserviert | Bit 11
reserviert | Bit 12
Slave benötigt M4-Master (eines der M4-Profile) | Bit 13 (MSB)
Slave hat keine digitalen Eingänge | Bit 14 (MSB)
Slave hat keine digitalen Ausgänge | Bit 15 (MSB)
Index App0 ASI Diag Data Slave (für 00 ≤ pp ≤ 1F; Slave 0 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0B | Status Register (B-Slave) | Allgemeine Status-Informationen Letzte erhaltene Antwort eines Slaves auf das Kommando "ReadStatus" (siehe folgende Tabelle) | UINT8 | RO | 0x00 (0dez)
Bit | Beschreibung
0 - 3 | Statusregister von Slave (Default = 0)
4 - 7 | reserviert
Index App0 ASI Diag Data Slave (für 00 ≤ pp ≤ 1F; Slave 0 bis Slave 31)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0C | Physical Fault Counter (B-Slave) | Zähler, der inkrementiert, wenn eine Antwort dem entsprechenden AS-i Slave einen Start-Bit-, Stop-Bit- oder Parity-Bit-Fehler hatte | UINT16 | RO | 0x0000 (0dez)
App0:0D | Timeout Counter (B-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave nicht geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:0E | Response Counter (B-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave korrekt geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:0F | Leave Data-Exchange Counter (B-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave aus der LAS ausgetragen wurde, d.h. dreimal hintereinander nicht (oder nicht korrekt) geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:10 | Data-Exchange Failed Counter (B-Slave) | Zähler, der inkrementiert, wenn der entsprechende AS-i Slave auf ein DataExchange-Telegramm nicht (oder nicht korrekt) geantwortet hat | UINT16 | RO | 0x0000 (0dez)
App0:11 | Timeout Statistics (B-Slave) | Timeouts pro Telegramm in Prozent | UINT16 | RO | 0x0000 (0dez)
App0:12 | Data-Exchange Repeat Counter (B-Slave) | Wenn der Datenaustausch wiederholt werden muss (Slave hat nicht korrekt oder gar nicht geantwortet), wird dieser Zähler inkrementiert | UINT16 | RO | 0x0000 (0dez)


ASI-Daten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] ASI-Daten
ASI-Daten
Index F100 ASI Status
Index (hex)
Name
Bedeutung
Data type
Flags
Default
F100:0
ASI Status
Maximaler Subindex
UINT8
RO
0x10 (16dez)
F100:01
Configuration okay
Valide AS-i Konfiguration
1bin: die Soll-Konfiguration und die Ist-Konfiguration stimmen überein (nur für Protected Mode relevant)
BOOLEAN
RO
0x00 (0dez)
F100:02
Power Fail
1bin: ein Spannungseinbruch hat stattgefunden
BOOLEAN
RO
0x00 (0dez)
F100:03
Auto addressing mode enabled
1bin: die automatische Adressierung ist freigegeben (der geschützte Betriebsmodus muss aktiv sein)

0bin: die automatische Adressierung ist gesperrt:
▪
ein AS-i Slave mit der Adresse 0 wurde gefunden, es fehlt aber kein projektierter AS-i Slave oder
▪
ein nicht projektierter AS-i Slave wurde gefunden
BOOLEAN
RO
0x00 (0dez)
F100:04
Auto addressing mode available
1bin: die automatische Adressierung ist verfügbar (der geschützte Betriebsmodus muss aktiv sein und es muss genau ein projektierter AS-i Slave fehlen)
BOOLEAN
RO
0x00 (0dez)
F100:05
Protected mode active
1bin: Protected Mode ist aktiviert
BOOLEAN
RO
0x00 (0dez)
F100:06
Slave with address 0 found
1bin: ein AS-i Slave mit der Adresse "0" wurde gefunden
BOOLEAN
RO
0x00 (0dez)
F100:07
Offline Ready
1bin: AS-i Master ist in Offline-Phase (die Outputs der aktivierten AS-i Slaves wurden auf den Defaultwert (1bin) gesetzt, die Inputs der aktivierten AS-i Slaves in der Steuerung wurden ebenfalls auf den Defaultwert (0bin) gesetzt
BOOLEAN
RO
0x00 (0dez)
F100:08
Normal Operation
1bin: der AS-i Master arbeitet im Normalbetrieb (die Datenaustauschphase wurde erreicht, AS-i Outputs und AS-i Inputs haben die aktuellen Werte)
BOOLEAN
RO
0x00 (0dez)
F100:09
ASI phase
ASI-State Machine:
0: Offline phase
1: Reset phase
2: Detection phase
3: Activation phase
4: Data exchange phase
5: Management phase
6: Inclusion phase
BIT3
RO
0x00 (0dez)
F100:0C***
Power24 Mode
Enabled
Power24 Support aktiv
BOOLEAN
RO
0x00 (0dez)
F100:0D***
Power24 Mode
Fail
Power24 Mode Fehler
BOOLEAN
RO
0x00 (0dez)
F100:0E***
M4 Profile Support
Enabled
M4-Profilunterstützung
BOOLEAN
RO
0x00 (0dez)
F100:10
TxPDO Toggle
Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden
BOOLEAN
RO
0x00 (0dez)
***) ab Firmware 02
Index F101 ASI LDS
Hier sind alle Slaves aufgeführt, die physikalisch am Netz vorhanden sind, eine gültige Adresse aufweisen und vom Master erkannt wurden.
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F101:0 | ASI LDS | Maximaler Subindex | UINT8 | RO | 0x3F (63dez)
F101:01 | Slave 0 | Slave 0 erkannt | BOOLEAN | RO | 0x00 (0dez)
F101:02 ... 20 | Slave 1A ... 31A | Slave 1A ... 31A erkannt | BOOLEAN | RO | 0x00 (0dez)
F101:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B erkannt | BOOLEAN | RO | 0x00 (0dez)
Index F102 ASI LAS
Alle Slaves, mit denen der Master kommuniziert. Im Protected Mode entspricht diese Liste der LPS, im Configuration Mode entspricht diese Liste der LDS
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F102:0 | ASI LAS | Maximaler Subindex | UINT8 | RO | 0x3F (63dez)
F102:01 | Slave 0 | ** | BOOLEAN | RO | 0x00 (0dez)
F102:02 ...20 | Slave 1A ... 31A | Slave 1A ... 31A aktiviert | BOOLEAN | RO | 0x00 (0dez)
F102:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B aktiviert | BOOLEAN | RO | 0x00 (0dez)
Index F103 ASI LPS
Diese Liste umfasst alle Slaves, die der Master am Netz erwartet. Im Protected Mode kommuniziert der Master nur mit diesen Slaves und gibt eine Meldung aus, wenn zusätzliche Slaves erkannt werden oder wenn Slaves aus dieser Liste fehlen.
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F103:0 | ASI LPS | Maximaler Subindex | UINT8 | RO | 0x3F (63dez)
F103:01 | Slave 0 | ** | BOOLEAN | RO | 0x00 (0dez)
F103:02 ...20 | Slave 1A ... 31A | Slave 1A ... 31A projektiert | BOOLEAN | RO | 0x00 (0dez)
F103:21 ...3F | Slave 1B... 31B | Slave 1B ... 31B projektiert | BOOLEAN | RO | 0x00 (0dez)
Index F200 ASI Control
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F200:0 | ASI Control | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
F200:01 | Auto Programming Enable | 0bin: automatische Adressierung gesperrt. 1bin: automatische Adressierung freigegeben | BOOLEAN | RW | 0x00 (0dez)
F200:02 | Go Offline Mode | 1bin: der AS-i Master geht in die Offline-Phase 0bin: der AS-i Master verlässt die Offline-Phase. | BOOLEAN | RW | 0x00 (0dez)
F200:03 | Data Exchange Active | Freigabe AS-i Datenaustausch: 1bin: die aktuellen AS-i Outputs werden an die AS-i Slaves gesendet und die empfangenen AS-i Inputs werden an die Steuerung übergeben. 0bin: die Defaultwerte (1bin) werden an die AS-i Slaves gesendet, die empfangenen AS-i Inputs werden verworfen und die Defaultwerte (0bin) an die Steuerung übergeben. | BOOLEAN | RW | 0x00 (0dez)
F200:04 | Go Protected Mode | 1bin: Protected Mode aktivieren | BOOLEAN | RW | 0x00 (0dez)
F200:05 | Go Configuration Mode | 1bin: Configuration Mode aktivieren | BOOLEAN | RW | 0x00 (0dez)
F200:06*** | Toggle Power24 mode | Power24 Mode aktivieren | BOOLEAN | RW | 0x00 (0dez)
F200:07*** | Toggle M4 Profile Support | M4 Profile Support aktivieren | BOOLEAN | RW | 0x00 (0dez)
***) ab Firmware 02
Index F600 ASI Digital Inputs
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F600:0 | ASI Digital Inputs | Maximaler Subindex | UINT8 | RO | 0xF8 (248dez)
F600:01 | Slave 1 Inputs__Slave 1A, DI0 | Slave 1 Inputs__Slave 1A, DI0, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:02 | Slave 1 Inputs__Slave 1A, DI1 | Slave 1 Inputs__Slave 1A, DI1, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:03 | Slave 1 Inputs__Slave 1A, DI2 | Slave 1 Inputs__Slave 1A, DI2, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:04 | Slave 1 Inputs__Slave 1A, DI3 | Slave 1 Inputs__Slave 1A, DI3, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:05 | Slave 1 Inputs__Slave 1B, DI0 | Slave 1 Inputs__Slave 1B, DI0, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
F600:06 | Slave 1 Inputs__Slave 1B, DI1 | Slave 1 Inputs__Slave 1B, DI1, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
F600:07 | Slave 1 Inputs__Slave 1B, DI2 | Slave 1 Inputs__Slave 1B, DI2, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
F600:08 | Slave 1 Inputs__Slave 1B, DI3 | Slave 1 Inputs__Slave 1B, DI3, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
*** | *** | *** | *** | *** | ***
F600:F1 | Slave 31 Inputs__Slave 31A, DI0 | Slave 31 Inputs__Slave 31A, DI0, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:F2 | Slave 31 Inputs__Slave 31A, DI1 | Slave 31 Inputs__Slave 31A, DI1, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:F3 | Slave 31 Inputs__Slave 31A, DI2 | Slave 31 Inputs__Slave 31A, DI2, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:F4 | Slave 31 Inputs__Slave 31A, DI3 | Slave 31 Inputs__Slave 31A, DI3, digitale Eingänge oder Safety-Flags** | BOOLEAN | RO | 0x00 (0dez)
F600:F5 | Slave 31 Inputs__Slave 31B, DI0 | Slave 31 Inputs__Slave 31B, DI0, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
F600:F6 | Slave 31 Inputs__Slave 31B, DI1 | Slave 31 Inputs__Slave 31B, DI1, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
F600:F7 | Slave 31 Inputs__Slave 31B, DI2 | Slave 31 Inputs__Slave 31B, DI2, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
F600:F8 | Slave 31 Inputs__Slave 31B, DI3 | Slave 31 Inputs__Slave 31B, DI3, digitale Eingänge | BOOLEAN | RO | 0x00 (0dez)
**) Safety-Flags: Informationen über den Zustand eines AS-i Safety-Slaves:
hex | Bit3 | Bit2 | Bit1 | Bit0 | Zustand
0x7 | 0 | 1 | 1 | 1 | Sensor im ordnungsgemäßen Ein-Zustand
0xC | 1 | 1 | 0 | 0 | Sensor im Aus-Zustand, aber nur Kontakt 2 offen
0xA | 1 | 0 | 1 | 0 | Sensor im Aus-Zustand, aber nur Kontakt 1 offen
0x8 | 1 | 0 | 0 | 0 | Sensor im ordnungsgemäßen Aus-Zustand
SmallWarningYellow WARNUNG
Auswertung der Safety-Flags nicht zulässig!
Die Auswertung der im Prozessabbild der EL6201 angezeigten Safety-Flags ist zur Steuerung sicherheitsrelevanter Funktionen nicht zulässig!
Sie dürfen nicht für Schutzfunktionen wie z.B. Not-Aus, Zugangsschutz, Schutzraumüberwachung, Roboter-Bereichsüberwachung, Pressen-Sicherheitsventil usw. verwendet werden!
Index F700 ASI Digital Outputs
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F700:0 | ASI Digital Outputs | Maximaler Subindex | UINT8 | RO | 0xF8 (248dez)
F700:01 | Slave 1 Outputs__Slave 1A, DO0 | Slave 1 Outputs__Slave 1A, DO0, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:02 | Slave 1 Outputs__Slave 1A, DO1 | Slave 1 Outputs__Slave 1A, DO1, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:03 | Slave 1 Outputs__Slave 1A, DO2 | Slave 1 Outputs__Slave 1A, DO2, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:04 | Slave 1 Outputs__Slave 1A, DO3 | Slave 1 Outputs__Slave 1A, DO3, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:05 | Slave 1 Outputs__Slave 1B, DO0 | Slave 1 Outputs__Slave 1B, DO0, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:06 | Slave 1 Outputs__Slave 1B, DO1 | Slave 1 Outputs__Slave 1B, DO1, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:07 | Slave 1 Outputs__Slave 1B, DO2 | Slave 1 Outputs__Slave 1B, DO2, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:08 | Slave 1 Outputs__Slave 1B, DO3 | Slave 1 Outputs__Slave 1B, DO3, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
*** | *** | *** | *** | *** | ***
F700:F1 | Slave 31 Outputs__Slave 31A, DO0 | Slave 31 Outputs__Slave 31A, DO0, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F2 | Slave 31 Outputs__Slave 31A, DO1 | Slave 31 Outputs__Slave 31A, DO1, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F3 | Slave 31 Outputs__Slave 31A, DO2 | Slave 31 Outputs__Slave 31A, DO2, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F4 | Slave 31 Outputs__Slave 31A, DO3 | Slave 31 Outputs__Slave 31A, DO3, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F5 | Slave 31 Outputs__Slave 31B, DO0 | Slave 31 Outputs__Slave 31B, DO0, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F6 | Slave 31 Outputs__Slave 31B, DO1 | Slave 31 Outputs__Slave 31B, DO1, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F7 | Slave 31 Outputs__Slave 31B, DO2 | Slave 31 Outputs__Slave 31B, DO2, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
F700:F8 | Slave 31 Outputs__Slave 31B, DO3 | Slave 31 Outputs__Slave 31B, DO3, digitale Ausgänge | BOOLEAN | RO | 0x00 (0dez)
Index F901 ASI Analog Slaves
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F901:0 | ASI Analog Slaves | Maximaler Subindex | UINT8 | RO | 0x3F (63dez)
F901:01 | Slave 0 | Slave 0 ist ein Analog-Slave | BOOLEAN | RO | 0x00 (0dez)
F901:02 ... 20 | Slave 1A ... 31A | Slave 1A ... 31A ist ein Analog-Slave | BOOLEAN | RO | 0x00 (0dez)
F901:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B ist ein Analog-Slave | BOOLEAN | RO | 0x00 (0dez)
Index F902 ASI Safety Slaves
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F902:0 | ASI Safety Slaves | Maximaler Subindex | UINT8 | RO | 0x3F (63dez)
F902:01 | Slave 0 | Slave 0 ist ein Safety-Slave | BOOLEAN | RO | 0x00 (0dez)
F902:02 ... 20 | Slave 1A ... 31A | Slave 1A ... 31A ist ein Safety-Slave | BOOLEAN | RO | 0x00 (0dez)
F902:21 ... 3F | Slave 1B ... 31B | Slave 1B ... 31B ist ein Safety-Slave | BOOLEAN | RO | 0x00 (0dez)


Objektbeschreibung - Standardobjekte

Inbetriebnahme [image] Objektbeschreibung - Standardobjekte
Objektbeschreibung - Standardobjekte
Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x18381389 (406328201dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL6201
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1010 Store parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1010:0 | Store parameters | reserviert | UINT8 | RO | 0x01 (1dez)
1010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x18393052 (406401106dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 10F2 Backup parameter storage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F2:0 | Backup parameter storage |  | OCTET-STRING[4] | RW | {0}
Index 1601 ASI RxPDO-Map Analog Outputs Slave 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ASI RxPDO-Map Analog Outputs Slave 1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x08 (8dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7010:01, 16
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7010:02, 16
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7010:03, 16
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7010:04, 16
1601:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7010:05, 16
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7010:06, 16
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7010:07, 16
1601:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7010 (ASI Analog Outputs Slave 1 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7010:08, 16
Index 1602 ASI RxPDO-Map Analog Outputs Slave 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | ASI RxPDO-Map Analog Outputs Slave 2 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x08 (8dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7020:01, 16
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7020:02, 16
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7020:03, 16
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7020:04, 16
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7020:05, 16
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7020:06, 16
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7020:07, 16
1602:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7020 (ASI Analog Outputs Slave 2 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7020:08, 16
Index 1603 ASI RxPDO-Map Analog Outputs Slave 3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | ASI RxPDO-Map Analog Outputs Slave 3 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x08 (8dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7030:01, 16
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7030:02, 16
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7030:03, 16
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7030:04, 16
1603:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7030:05, 16
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7030:06, 16
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7030:07, 16
1603:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7030 (ASI Analog Outputs Slave 3 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7030:08, 16
Index 1604 ASI RxPDO-Map Analog Outputs Slave 4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | ASI RxPDO-Map Analog Outputs Slave 4 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x08 (8dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7040:01, 16
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7040:02, 16
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7040:03, 16
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7040:04, 16
1604:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7040:05, 16
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7040:06, 16
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7040:07, 16
1604:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7040 (ASI Analog Outputs Slave 4 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7040:08, 16
Index 1605 ASI RxPDO-Map Analog Outputs Slave 5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | ASI RxPDO-Map Analog Outputs Slave 5 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x08 (8dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7050:01, 16
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7050:02, 16
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7050:03, 16
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7050:04, 16
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7050:05, 16
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7050:06, 16
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7050:07, 16
1605:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7050 (ASI Analog Outputs Slave 5 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7050:08, 16
Index 1606 ASI RxPDO-Map Analog Outputs Slave 6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | ASI RxPDO-Map Analog Outputs Slave 6 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x08 (8dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7060:01, 16
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7060:02, 16
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7060:03, 16
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7060:04, 16
1606:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7060:05, 16
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7060:06, 16
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7060:07, 16
1606:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7060 (ASI Analog Outputs Slave 6 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7060:08, 16
Index 1607 ASI RxPDO-Map Analog Outputs Slave 7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | ASI RxPDO-Map Analog Outputs Slave 7 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x08 (8dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7070:01, 16
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7070:02, 16
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7070:03, 16
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7070:04, 16
1607:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7070:05, 16
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7070:06, 16
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7070:07, 16
1607:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7070 (ASI Analog Outputs Slave 7 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7070:08, 16
Index 1608 ASI RxPDO-Map Analog Outputs Slave 8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1608:0 | ASI RxPDO-Map Analog Outputs Slave 8 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x08 (8dez)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7080:01, 16
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7080:02, 16
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7080:03, 16
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7080:04, 16
1608:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7080:05, 16
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7080:06, 16
1608:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7080:07, 16
1608:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7080 (ASI Analog Outputs Slave 8 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7080:08, 16
Index 1609 ASI RxPDO-Map Analog Outputs Slave 9
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1609:0 | ASI RxPDO-Map Analog Outputs Slave 9 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x08 (8dez)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7090:01, 16
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7090:02, 16
1609:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7090:03, 16
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7090:04, 16
1609:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7090:05, 16
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7090:06, 16
1609:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7090:07, 16
1609:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7090 (ASI Analog Outputs Slave 9 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7090:08, 16
Index 160A ASI RxPDO-Map Analog Outputs Slave 10
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160A:0 | ASI RxPDO-Map Analog Outputs Slave 10 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x08 (8dez)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70A0:01, 16
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70A0:02, 16
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70A0:03, 16
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70A0:04, 16
160A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70A0:05, 16
160A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70A0:06, 16
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70A0:07, 16
160A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70A0 (ASI Analog Outputs Slave 10 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70A0:08, 16
Index 160B ASI RxPDO-Map Analog Outputs Slave 11
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160B:0 | ASI RxPDO-Map Analog Outputs Slave 11 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x08 (8dez)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70B0:01, 16
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70B0:02, 16
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70B0:03, 16
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70B0:04, 16
160B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70B0:05, 16
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70B0:06, 16
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70B0:07, 16
160B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70B0 (ASI Analog Outputs Slave 11 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70B0:08, 16
Index 160C ASI RxPDO-Map Analog Outputs Slave 12
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160C:0 | ASI RxPDO-Map Analog Outputs Slave 12 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x08 (8dez)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70C0:01, 16
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70C0:02, 16
160C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70C0:03, 16
160C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70C0:04, 16
160C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70C0:05, 16
160C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70C0:06, 16
160C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70C0:07, 16
160C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70C0 (ASI Analog Outputs Slave 12 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70C0:08, 16
Index 160D ASI RxPDO-Map Analog Outputs Slave 13
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160D:0 | ASI RxPDO-Map Analog Outputs Slave 13 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x08 (8dez)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70D0:01, 16
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70D0:02, 16
160D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70D0:03, 16
160D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70D0:04, 16
160D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70D0:05, 16
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70D0:06, 16
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70D0:07, 16
160D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70D0 (ASI Analog Outputs Slave 13 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70D0:08, 16
Index 160E ASI RxPDO-Map Analog Outputs Slave 14
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160E:0 | ASI RxPDO-Map Analog Outputs Slave 14 | PDO Mapping RxPDO 15 | UINT8 | RO | 0x08 (8dez)
160E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70E0:01, 16
160E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70E0:02, 16
160E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70E0:03, 16
160E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70E0:04, 16
160E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70E0:05, 16
160E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70E0:06, 16
160E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70E0:07, 16
160E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70E0 (ASI Analog Outputs Slave 14 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70E0:08, 16
Index 160F ASI RxPDO-Map Analog Outputs Slave 15
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160F:0 | ASI RxPDO-Map Analog Outputs Slave 15 | PDO Mapping RxPDO 16 | UINT8 | RO | 0x08 (8dez)
160F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x70F0:01, 16
160F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x70F0:02, 16
160F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x70F0:03, 16
160F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x70F0:04, 16
160F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x70F0:05, 16
160F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x70F0:06, 16
160F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x70F0:07, 16
160F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x70F0 (ASI Analog Outputs Slave 15 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x70F0:08, 16
Index 1610 ASI RxPDO-Map Analog Outputs Slave 16
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1610:0 | ASI RxPDO-Map Analog Outputs Slave 16 | PDO Mapping RxPDO 17 | UINT8 | RO | 0x08 (8dez)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7100:01, 16
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7100:02, 16
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7100:03, 16
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7100:04, 16
1610:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7100:05, 16
1610:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7100:06, 16
1610:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7100:07, 16
1610:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7100 (ASI Analog Outputs Slave 16 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7100:08, 16
Index 1611 ASI RxPDO-Map Analog Outputs Slave 17
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1611:0 | ASI RxPDO-Map Analog Outputs Slave 17 | PDO Mapping RxPDO 18 | UINT8 | RO | 0x08 (8dez)
1611:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7110:01, 16
1611:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7110:02, 16
1611:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7110:03, 16
1611:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7110:04, 16
1611:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7110:05, 16
1611:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7110:06, 16
1611:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7110:07, 16
1611:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7110 (ASI Analog Outputs Slave 17 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7110:08, 16
Index 1612 ASI RxPDO-Map Analog Outputs Slave 18
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1612:0 | ASI RxPDO-Map Analog Outputs Slave 18 | PDO Mapping RxPDO 19 | UINT8 | RO | 0x08 (8dez)
1612:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7120:01, 16
1612:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7120:02, 16
1612:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7120:03, 16
1612:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7120:04, 16
1612:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7120:05, 16
1612:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7120:06, 16
1612:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7120:07, 16
1612:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7120 (ASI Analog Outputs Slave 18 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7120:08, 16
Index 1613 ASI RxPDO-Map Analog Outputs Slave 19
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1613:0 | ASI RxPDO-Map Analog Outputs Slave 19 | PDO Mapping RxPDO 20 | UINT8 | RO | 0x08 (8dez)
1613:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7130:01, 16
1613:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7130:02, 16
1613:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7130:03, 16
1613:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7130:04, 16
1613:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7130:05, 16
1613:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7130:06, 16
1613:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7130:07, 16
1613:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7130 (ASI Analog Outputs Slave 19 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7130:08, 16
Index 1614 ASI RxPDO-Map Analog Outputs Slave 20
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1614:0 | ASI RxPDO-Map Analog Outputs Slave 20 | PDO Mapping RxPDO 21 | UINT8 | RO | 0x08 (8dez)
1614:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7140:01, 16
1614:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7140:02, 16
1614:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7140:03, 16
1614:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7140:04, 16
1614:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7140:05, 16
1614:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7140:06, 16
1614:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7140:07, 16
1614:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7140 (ASI Analog Outputs Slave 20 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7140:08, 16
Index 1615 ASI RxPDO-Map Analog Outputs Slave 21
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1615:0 | ASI RxPDO-Map Analog Outputs Slave 21 | PDO Mapping RxPDO 22 | UINT8 | RO | 0x08 (8dez)
1615:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7150:01, 16
1615:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7150:02, 16
1615:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7150:03, 16
1615:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7150:04, 16
1615:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7150:05, 16
1615:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7150:06, 16
1615:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7150:07, 16
1615:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7150 (ASI Analog Outputs Slave 21 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7150:08, 16
Index 1616 ASI RxPDO-Map Analog Outputs Slave 22
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1616:0 | ASI RxPDO-Map Analog Outputs Slave 22 | PDO Mapping RxPDO 23 | UINT8 | RO | 0x08 (8dez)
1616:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7160:01, 16
1616:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7160:02, 16
1616:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7160:03, 16
1616:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7160:04, 16
1616:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7160:05, 16
1616:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7160:06, 16
1616:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7160:07, 16
1616:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7160 (ASI Analog Outputs Slave 22 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7160:08, 16
Index 1617 ASI RxPDO-Map Analog Outputs Slave 23
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1617:0 | ASI RxPDO-Map Analog Outputs Slave 23 | PDO Mapping RxPDO 24 | UINT8 | RO | 0x08 (8dez)
1617:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7170:01, 16
1617:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7170:02, 16
1617:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7170:03, 16
1617:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7170:04, 16
1617:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7170:05, 16
1617:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7170:06, 16
1617:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7170:07, 16
1617:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7170 (ASI Analog Outputs Slave 23 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7170:08, 16
Index 1618 ASI RxPDO-Map Analog Outputs Slave 24
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1618:0 | ASI RxPDO-Map Analog Outputs Slave 24 | PDO Mapping RxPDO 25 | UINT8 | RO | 0x08 (8dez)
1618:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7180:01, 16
1618:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7180:02, 16
1618:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7180:03, 16
1618:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7180:04, 16
1618:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7180:05, 16
1618:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7180:06, 16
1618:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7180:07, 16
1618:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7180 (ASI Analog Outputs Slave 24 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7180:08, 16
Index 1619 ASI RxPDO-Map Analog Outputs Slave 25
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1619:0 | ASI RxPDO-Map Analog Outputs Slave 25 | PDO Mapping RxPDO 26 | UINT8 | RO | 0x08 (8dez)
1619:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x7190:01, 16
1619:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x7190:02, 16
1619:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x7190:03, 16
1619:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x7190:04, 16
1619:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x7190:05, 16
1619:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x7190:06, 16
1619:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x7190:07, 16
1619:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x7190 (ASI Analog Outputs Slave 25 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x7190:08, 16
Index 161A ASI RxPDO-Map Analog Outputs Slave 26
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161A:0 | ASI RxPDO-Map Analog Outputs Slave 26 | PDO Mapping RxPDO 27 | UINT8 | RO | 0x08 (8dez)
161A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71A0:01, 16
161A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71A0:02, 16
161A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71A0:03, 16
161A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71A0:04, 16
161A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71A0:05, 16
161A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71A0:06, 16
161A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71A0:07, 16
161A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71A0 (ASI Analog Outputs Slave 26 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71A0:08, 16
Index 161B ASI RxPDO-Map Analog Outputs Slave 27
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161B:0 | ASI RxPDO-Map Analog Outputs Slave 27 | PDO Mapping RxPDO 28 | UINT8 | RO | 0x08 (8dez)
161B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71B0:01, 16
161B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71B0:02, 16
161B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71B0:03, 16
161B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71B0:04, 16
161B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71B0:05, 16
161B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71B0:06, 16
161B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71B0:07, 16
161B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71B0 (ASI Analog Outputs Slave 27 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71B0:08, 16
Index 161C ASI RxPDO-Map Analog Outputs Slave 28
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161C:0 | ASI RxPDO-Map Analog Outputs Slave 28 | PDO Mapping RxPDO 29 | UINT8 | RO | 0x08 (8dez)
161C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71C0:01, 16
161C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71C0:02, 16
161C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71C0:03, 16
161C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71C0:04, 16
161C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71C0:05, 16
161C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71C0:06, 16
161C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71C0:07, 16
161C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71C0 (ASI Analog Outputs Slave 28 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71C0:08, 16
Index 161D ASI RxPDO-Map Analog Outputs Slave 29
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161D:0 | ASI RxPDO-Map Analog Outputs Slave 29 | PDO Mapping RxPDO 30 | UINT8 | RO | 0x08 (8dez)
161D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71D0:01, 16
161D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71D0:02, 16
161D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71D0:03, 16
161D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71D0:04, 16
161D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71D0:05, 16
161D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71D0:06, 16
161D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71D0:07, 16
161D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71D0 (ASI Analog Outputs Slave 29 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71D0:08, 16
Index 161E ASI RxPDO-Map Analog Outputs Slave 30
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161E:0 | ASI RxPDO-Map Analog Outputs Slave 30 | PDO Mapping RxPDO 31 | UINT8 | RO | 0x08 (8dez)
161E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71E0:01, 16
161E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71E0:02, 16
161E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71E0:03, 16
161E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71E0:04, 16
161E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71E0:05, 16
161E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71E0:06, 16
161E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71E0:07, 16
161E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71E0 (ASI Analog Outputs Slave 30 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71E0:08, 16
Index 161F ASI RxPDO-Map Analog Outputs Slave 31
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161F:0 | ASI RxPDO-Map Analog Outputs Slave 31 | PDO Mapping RxPDO 32 | UINT8 | RO | 0x08 (8dez)
161F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x71F0:01, 16
161F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x71F0:02, 16
161F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x71F0:03, 16
161F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x71F0:04, 16
161F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x71F0:05, 16
161F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x71F0:06, 16
161F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x71F0:07, 16
161F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x71F0 (ASI Analog Outputs Slave 31 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x71F0:08, 16
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:0 | ASI RxPDO-Map Outputs Device | PDO Mapping RxPDO 65 | UINT8 | RO | 0xF8 (248dez)
1640:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x01 (Slave 1 Outputs__Slave 1A, DO0)) | UINT32 | RO | 0xF700:01, 1
1640:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x02 (Slave 1 Outputs__Slave 1A, DO1)) | UINT32 | RO | 0xF700:02, 1
1640:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x03 (Slave 1 Outputs__Slave 1A, DO2)) | UINT32 | RO | 0xF700:03, 1
1640:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x04 (Slave 1 Outputs__Slave 1A, DO3)) | UINT32 | RO | 0xF700:04, 1
1640:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x05 (Slave 1 Outputs__Slave 1B, DO0)) | UINT32 | RO | 0xF700:05, 1
1640:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x06 (Slave 1 Outputs__Slave 1B, DO1)) | UINT32 | RO | 0xF700:06, 1
1640:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x07 (Slave 1 Outputs__Slave 1B, DO2)) | UINT32 | RO | 0xF700:07, 1
1640:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x08 (Slave 1 Outputs__Slave 1B, DO3)) | UINT32 | RO | 0xF700:08, 1
1640:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x09 (Slave 2 Outputs__Slave 2A, DO0)) | UINT32 | RO | 0xF700:09, 1
1640:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0A (Slave 2 Outputs__Slave 2A, DO1)) | UINT32 | RO | 0xF700:0A, 1
1640:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0B (Slave 2 Outputs__Slave 2A, DO2)) | UINT32 | RO | 0xF700:0B, 1
1640:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0C (Slave 2 Outputs__Slave 2A, DO3)) | UINT32 | RO | 0xF700:0C, 1
1640:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0D (Slave 2 Outputs__Slave 2B, DO0)) | UINT32 | RO | 0xF700:0D, 1
1640:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0E (Slave 2 Outputs__Slave 2B, DO1)) | UINT32 | RO | 0xF700:0E, 1
1640:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x0F (Slave 2 Outputs__Slave 2B, DO2)) | UINT32 | RO | 0xF700:0F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x10 (Slave 2 Outputs__Slave 2B, DO3)) | UINT32 | RO | 0xF700:10, 1
1640:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x11 (Slave 3 Outputs__Slave 3A, DO0)) | UINT32 | RO | 0xF700:11, 1
1640:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x12 (Slave 3 Outputs__Slave 3A, DO1)) | UINT32 | RO | 0xF700:12, 1
1640:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x13 (Slave 3 Outputs__Slave 3A, DO2)) | UINT32 | RO | 0xF700:13, 1
1640:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x14 (Slave 3 Outputs__Slave 3A, DO3)) | UINT32 | RO | 0xF700:14, 1
1640:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x15 (Slave 3 Outputs__Slave 3B, DO0)) | UINT32 | RO | 0xF700:15, 1
1640:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x16 (Slave 3 Outputs__Slave 3B, DO1)) | UINT32 | RO | 0xF700:16, 1
1640:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x17 (Slave 3 Outputs__Slave 3B, DO2)) | UINT32 | RO | 0xF700:17, 1
1640:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x18 (Slave 3 Outputs__Slave 3B, DO3)) | UINT32 | RO | 0xF700:18, 1
1640:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x19 (Slave 4 Outputs__Slave 4A, DO0)) | UINT32 | RO | 0xF700:19, 1
1640:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1A (Slave 4 Outputs__Slave 4A, DO1)) | UINT32 | RO | 0xF700:1A, 1
1640:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1B (Slave 4 Outputs__Slave 4A, DO2)) | UINT32 | RO | 0xF700:1B, 1
1640:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1C (Slave 4 Outputs__Slave 4A, DO3)) | UINT32 | RO | 0xF700:1C, 1
1640:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1D (Slave 4 Outputs__Slave 4B, DO0)) | UINT32 | RO | 0xF700:1D, 1
1640:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1E (Slave 4 Outputs__Slave 4B, DO1)) | UINT32 | RO | 0xF700:1E, 1
1640:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x1F (Slave 4 Outputs__Slave 4B, DO2)) | UINT32 | RO | 0xF700:1F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x20 (Slave 4 Outputs__Slave 4B, DO3)) | UINT32 | RO | 0xF700:20, 1
1640:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x21 (Slave 5 Outputs__Slave 5A, DO0)) | UINT32 | RO | 0xF700:21, 1
1640:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x22 (Slave 5 Outputs__Slave 5A, DO1)) | UINT32 | RO | 0xF700:22, 1
1640:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x23 (Slave 5 Outputs__Slave 5A, DO2)) | UINT32 | RO | 0xF700:23, 1
1640:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x24 (Slave 5 Outputs__Slave 5A, DO3)) | UINT32 | RO | 0xF700:24, 1
1640:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x25 (Slave 5 Outputs__Slave 5B, DO0)) | UINT32 | RO | 0xF700:25, 1
1640:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x26 (Slave 5 Outputs__Slave 5B, DO1)) | UINT32 | RO | 0xF700:26, 1
1640:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x27 (Slave 5 Outputs__Slave 5B, DO2)) | UINT32 | RO | 0xF700:27, 1
1640:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x28 (Slave 5 Outputs__Slave 5B, DO3)) | UINT32 | RO | 0xF700:28, 1
1640:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x29 (Slave 6 Outputs__Slave 6A, DO0)) | UINT32 | RO | 0xF700:29, 1
1640:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2A (Slave 6 Outputs__Slave 6A, DO1)) | UINT32 | RO | 0xF700:2A, 1
1640:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2B (Slave 6 Outputs__Slave 6A, DO2)) | UINT32 | RO | 0xF700:2B, 1
1640:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2C (Slave 6 Outputs__Slave 6A, DO3)) | UINT32 | RO | 0xF700:2C, 1
1640:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2D (Slave 6 Outputs__Slave 6B, DO0)) | UINT32 | RO | 0xF700:2D, 1
1640:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2E (Slave 6 Outputs__Slave 6B, DO1)) | UINT32 | RO | 0xF700:2E, 1
1640:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x2F (Slave 6 Outputs__Slave 6B, DO2)) | UINT32 | RO | 0xF700:2F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x30 (Slave 6 Outputs__Slave 6B, DO3)) | UINT32 | RO | 0xF700:30, 1
1640:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x31 (Slave 7 Outputs__Slave 7A, DO0)) | UINT32 | RO | 0xF700:31, 1
1640:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x32 (Slave 7 Outputs__Slave 7A, DO1)) | UINT32 | RO | 0xF700:32, 1
1640:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x33 (Slave 7 Outputs__Slave 7A, DO2)) | UINT32 | RO | 0xF700:33, 1
1640:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x34 (Slave 7 Outputs__Slave 7A, DO3)) | UINT32 | RO | 0xF700:34, 1
1640:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x35 (Slave 7 Outputs__Slave 7B, DO0)) | UINT32 | RO | 0xF700:35, 1
1640:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x36 (Slave 7 Outputs__Slave 7B, DO1)) | UINT32 | RO | 0xF700:36, 1
1640:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x37 (Slave 7 Outputs__Slave 7B, DO2)) | UINT32 | RO | 0xF700:37, 1
1640:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x38 (Slave 7 Outputs__Slave 7B, DO3)) | UINT32 | RO | 0xF700:38, 1
1640:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x39 (Slave 8 Outputs__Slave 8A, DO0)) | UINT32 | RO | 0xF700:39, 1
1640:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3A (Slave 8 Outputs__Slave 8A, DO1)) | UINT32 | RO | 0xF700:3A, 1
1640:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3B (Slave 8 Outputs__Slave 8A, DO2)) | UINT32 | RO | 0xF700:3B, 1
1640:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3C (Slave 8 Outputs__Slave 8A, DO3)) | UINT32 | RO | 0xF700:3C, 1
1640:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3D (Slave 8 Outputs__Slave 8B, DO0)) | UINT32 | RO | 0xF700:3D, 1
1640:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3E (Slave 8 Outputs__Slave 8B, DO1)) | UINT32 | RO | 0xF700:3E, 1
1640:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x3F (Slave 8 Outputs__Slave 8B, DO2)) | UINT32 | RO | 0xF700:3F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:40 | SubIndex 064 | 64. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x40 (Slave 8 Outputs__Slave 8B, DO3)) | UINT32 | RO | 0xF700:40, 1
1640:41 | SubIndex 065 | 65. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x41 (Slave 9 Outputs__Slave 9A, DO0)) | UINT32 | RO | 0xF700:41, 1
1640:42 | SubIndex 066 | 66. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x42 (Slave 9 Outputs__Slave 9A, DO1)) | UINT32 | RO | 0xF700:42, 1
1640:43 | SubIndex 067 | 67. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x43 (Slave 9 Outputs__Slave 9A, DO2)) | UINT32 | RO | 0xF700:43, 1
1640:44 | SubIndex 068 | 68. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x44 (Slave 9 Outputs__Slave 9A, DO3)) | UINT32 | RO | 0xF700:44, 1
1640:45 | SubIndex 069 | 69. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x45 (Slave 9 Outputs__Slave 9B, DO0)) | UINT32 | RO | 0xF700:45, 1
1640:46 | SubIndex 070 | 70. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x46 (Slave 9 Outputs__Slave 9B, DO1)) | UINT32 | RO | 0xF700:46, 1
1640:47 | SubIndex 071 | 71. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x47 (Slave 9 Outputs__Slave 9B, DO2)) | UINT32 | RO | 0xF700:47, 1
1640:48 | SubIndex 072 | 72. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x48 (Slave 9 Outputs__Slave 9B, DO3)) | UINT32 | RO | 0xF700:48, 1
1640:49 | SubIndex 073 | 73. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x49 (Slave 10 Outputs__Slave 10A, DO0)) | UINT32 | RO | 0xF700:49, 1
1640:4A | SubIndex 074 | 74. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4A (Slave 10 Outputs__Slave 10A, DO1)) | UINT32 | RO | 0xF700:4A, 1
1640:4B | SubIndex 075 | 75. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4B (Slave 10 Outputs__Slave 10A, DO2)) | UINT32 | RO | 0xF700:4B, 1
1640:4C | SubIndex 076 | 76. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4C (Slave 10 Outputs__Slave 10A, DO3)) | UINT32 | RO | 0xF700:4C, 1
1640:4D | SubIndex 077 | 77. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4D (Slave 10 Outputs__Slave 10B, DO0)) | UINT32 | RO | 0xF700:4D, 1
1640:4E | SubIndex 078 | 78. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4E (Slave 10 Outputs__Slave 10B, DO1)) | UINT32 | RO | 0xF700:4E, 1
1640:4F | SubIndex 079 | 79. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x4F (Slave 10 Outputs__Slave 10B, DO2)) | UINT32 | RO | 0xF700:4F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:50 | SubIndex 080 | 80. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x50 (Slave 10 Outputs__Slave 10B, DO3)) | UINT32 | RO | 0xF700:50, 1
1640:51 | SubIndex 081 | 81. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x51 (Slave 11 Outputs__Slave 11A, DO0)) | UINT32 | RO | 0xF700:51, 1
1640:52 | SubIndex 082 | 82. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x52 (Slave 11 Outputs__Slave 11A, DO1)) | UINT32 | RO | 0xF700:52, 1
1640:53 | SubIndex 083 | 83. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x53 (Slave 11 Outputs__Slave 11A, DO2)) | UINT32 | RO | 0xF700:53, 1
1640:54 | SubIndex 084 | 84. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x54 (Slave 11 Outputs__Slave 11A, DO3)) | UINT32 | RO | 0xF700:54, 1
1640:55 | SubIndex 085 | 85. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x55 (Slave 11 Outputs__Slave 11B, DO0)) | UINT32 | RO | 0xF700:55, 1
1640:56 | SubIndex 086 | 86. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x56 (Slave 11 Outputs__Slave 11B, DO1)) | UINT32 | RO | 0xF700:56, 1
1640:57 | SubIndex 087 | 87. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x57 (Slave 11 Outputs__Slave 11B, DO2)) | UINT32 | RO | 0xF700:57, 1
1640:58 | SubIndex 088 | 88. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x58 (Slave 11 Outputs__Slave 11B, DO3)) | UINT32 | RO | 0xF700:58, 1
1640:59 | SubIndex 089 | 89. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x59 (Slave 12 Outputs__Slave 12A, DO0)) | UINT32 | RO | 0xF700:59, 1
1640:5A | SubIndex 090 | 90. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5A (Slave 12 Outputs__Slave 12A, DO1)) | UINT32 | RO | 0xF700:5A, 1
1640:5B | SubIndex 091 | 91. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5B (Slave 12 Outputs__Slave 12A, DO2)) | UINT32 | RO | 0xF700:5B, 1
1640:5C | SubIndex 092 | 92. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5C (Slave 12 Outputs__Slave 12A, DO3)) | UINT32 | RO | 0xF700:5C, 1
1640:5D | SubIndex 093 | 93. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5D (Slave 12 Outputs__Slave 12B, DO0)) | UINT32 | RO | 0xF700:5D, 1
1640:5E | SubIndex 094 | 94. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5E (Slave 12 Outputs__Slave 12B, DO1)) | UINT32 | RO | 0xF700:5E, 1
1640:5F | SubIndex 095 | 95. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x5F (Slave 12 Outputs__Slave 12B, DO2)) | UINT32 | RO | 0xF700:5F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:60 | SubIndex 096 | 96. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x60 (Slave 12 Outputs__Slave 12B, DO3)) | UINT32 | RO | 0xF700:60, 1
1640:61 | SubIndex 097 | 97. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x61 (Slave 13 Outputs__Slave 13A, DO0)) | UINT32 | RO | 0xF700:61, 1
1640:62 | SubIndex 098 | 98. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x62 (Slave 13 Outputs__Slave 13A, DO1)) | UINT32 | RO | 0xF700:62, 1
1640:63 | SubIndex 099 | 99. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x63 (Slave 13 Outputs__Slave 13A, DO2)) | UINT32 | RO | 0xF700:63, 1
1640:64 | SubIndex 100 | 100. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x64 (Slave 13 Outputs__Slave 13A, DO3)) | UINT32 | RO | 0xF700:64, 1
1640:65 | SubIndex 101 | 101. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x65 (Slave 13 Outputs__Slave 13B, DO0)) | UINT32 | RO | 0xF700:65, 1
1640:66 | SubIndex 102 | 102. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x66 (Slave 13 Outputs__Slave 13B, DO1)) | UINT32 | RO | 0xF700:66, 1
1640:67 | SubIndex 103 | 103. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x67 (Slave 13 Outputs__Slave 13B, DO2)) | UINT32 | RO | 0xF700:67, 1
1640:68 | SubIndex 104 | 104. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x68 (Slave 13 Outputs__Slave 13B, DO3)) | UINT32 | RO | 0xF700:68, 1
1640:69 | SubIndex 105 | 105. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x69 (Slave 14 Outputs__Slave 14A, DO0)) | UINT32 | RO | 0xF700:69, 1
1640:6A | SubIndex 106 | 106. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6A (Slave 14 Outputs__Slave 14A, DO1)) | UINT32 | RO | 0xF700:6A, 1
1640:6B | SubIndex 107 | 107. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6B (Slave 14 Outputs__Slave 14A, DO2)) | UINT32 | RO | 0xF700:6B, 1
1640:6C | SubIndex 108 | 108. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6C (Slave 14 Outputs__Slave 14A, DO3)) | UINT32 | RO | 0xF700:6C, 1
1640:6D | SubIndex 109 | 109. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6D (Slave 14 Outputs__Slave 14B, DO0)) | UINT32 | RO | 0xF700:6D, 1
1640:6E | SubIndex 110 | 110. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6E (Slave 14 Outputs__Slave 14B, DO1)) | UINT32 | RO | 0xF700:6E, 1
1640:6F | SubIndex 111 | 111. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x6F (Slave 14 Outputs__Slave 14B, DO2)) | UINT32 | RO | 0xF700:6F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:70 | SubIndex 112 | 112. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x70 (Slave 14 Outputs__Slave 14B, DO3)) | UINT32 | RO | 0xF700:70, 1
1640:71 | SubIndex 113 | 113. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x71 (Slave 15 Outputs__Slave 15A, DO0)) | UINT32 | RO | 0xF700:71, 1
1640:72 | SubIndex 114 | 114. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x72 (Slave 15 Outputs__Slave 15A, DO1)) | UINT32 | RO | 0xF700:72, 1
1640:73 | SubIndex 115 | 115. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x73 (Slave 15 Outputs__Slave 15A, DO2)) | UINT32 | RO | 0xF700:73, 1
1640:74 | SubIndex 116 | 116. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x74 (Slave 15 Outputs__Slave 15A, DO3)) | UINT32 | RO | 0xF700:74, 1
1640:75 | SubIndex 117 | 117. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x75 (Slave 15 Outputs__Slave 15B, DO0)) | UINT32 | RO | 0xF700:75, 1
1640:76 | SubIndex 118 | 118. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x76 (Slave 15 Outputs__Slave 15B, DO1)) | UINT32 | RO | 0xF700:76, 1
1640:77 | SubIndex 119 | 119. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x77 (Slave 15 Outputs__Slave 15B, DO2)) | UINT32 | RO | 0xF700:77, 1
1640:78 | SubIndex 120 | 120. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x78 (Slave 15 Outputs__Slave 15B, DO3)) | UINT32 | RO | 0xF700:78, 1
1640:79 | SubIndex 121 | 121. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x79 (Slave 16 Outputs__Slave 16A, DO0)) | UINT32 | RO | 0xF700:79, 1
1640:7A | SubIndex 122 | 122. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7A (Slave 16 Outputs__Slave 16A, DO1)) | UINT32 | RO | 0xF700:7A, 1
1640:7B | SubIndex 123 | 123. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7B (Slave 16 Outputs__Slave 16A, DO2)) | UINT32 | RO | 0xF700:7B, 1
1640:7C | SubIndex 124 | 124. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7C (Slave 16 Outputs__Slave 16A, DO3)) | UINT32 | RO | 0xF700:7C, 1
1640:7D | SubIndex 125 | 125. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7D (Slave 16 Outputs__Slave 16B, DO0)) | UINT32 | RO | 0xF700:7D, 1
1640:7E | SubIndex 126 | 126. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7E (Slave 16 Outputs__Slave 16B, DO1)) | UINT32 | RO | 0xF700:7E, 1
1640:7F | SubIndex 127 | 127. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x7F (Slave 16 Outputs__Slave 16B, DO2)) | UINT32 | RO | 0xF700:7F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:80 | SubIndex 128 | 128. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x80 (Slave 16 Outputs__Slave 16B, DO3)) | UINT32 | RO | 0xF700:80, 1
1640:81 | SubIndex 129 | 129. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x81 (Slave 17 Outputs__Slave 17A, DO0)) | UINT32 | RO | 0xF700:81, 1
1640:82 | SubIndex 130 | 130. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x82 (Slave 17 Outputs__Slave 17A, DO1)) | UINT32 | RO | 0xF700:82, 1
1640:83 | SubIndex 131 | 131. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x83 (Slave 17 Outputs__Slave 17A, DO2)) | UINT32 | RO | 0xF700:83, 1
1640:84 | SubIndex 132 | 132. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x84 (Slave 17 Outputs__Slave 17A, DO3)) | UINT32 | RO | 0xF700:84, 1
1640:85 | SubIndex 133 | 133. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x85 (Slave 17 Outputs__Slave 17B, DO0)) | UINT32 | RO | 0xF700:85, 1
1640:86 | SubIndex 134 | 134. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x86 (Slave 17 Outputs__Slave 17B, DO1)) | UINT32 | RO | 0xF700:86, 1
1640:87 | SubIndex 135 | 135. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x87 (Slave 17 Outputs__Slave 17B, DO2)) | UINT32 | RO | 0xF700:87, 1
1640:88 | SubIndex 136 | 136. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x88 (Slave 17 Outputs__Slave 17B, DO3)) | UINT32 | RO | 0xF700:88, 1
1640:89 | SubIndex 137 | 137. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x89 (Slave 18 Outputs__Slave 18A, DO0)) | UINT32 | RO | 0xF700:89, 1
1640:8A | SubIndex 138 | 138. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8A (Slave 18 Outputs__Slave 18A, DO1)) | UINT32 | RO | 0xF700:8A, 1
1640:8B | SubIndex 139 | 139. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8B (Slave 18 Outputs__Slave 18A, DO2)) | UINT32 | RO | 0xF700:8B, 1
1640:8C | SubIndex 140 | 140. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8C (Slave 18 Outputs__Slave 18A, DO3)) | UINT32 | RO | 0xF700:8C, 1
1640:8D | SubIndex 141 | 141. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8D (Slave 18 Outputs__Slave 18B, DO0)) | UINT32 | RO | 0xF700:8D, 1
1640:8E | SubIndex 142 | 142. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8E (Slave 18 Outputs__Slave 18B, DO1)) | UINT32 | RO | 0xF700:8E, 1
1640:8F | SubIndex 143 | 143. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x8F (Slave 18 Outputs__Slave 18B, DO2)) | UINT32 | RO | 0xF700:8F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:90 | SubIndex 144 | 144. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x90 (Slave 18 Outputs__Slave 18B, DO3)) | UINT32 | RO | 0xF700:90, 1
1640:91 | SubIndex 145 | 145. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x91 (Slave 19 Outputs__Slave 19A, DO0)) | UINT32 | RO | 0xF700:91, 1
1640:92 | SubIndex 146 | 146. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x92 (Slave 19 Outputs__Slave 19A, DO1)) | UINT32 | RO | 0xF700:92, 1
1640:93 | SubIndex 147 | 147. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x93 (Slave 19 Outputs__Slave 19A, DO2)) | UINT32 | RO | 0xF700:93, 1
1640:94 | SubIndex 148 | 148. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x94 (Slave 19 Outputs__Slave 19A, DO3)) | UINT32 | RO | 0xF700:94, 1
1640:95 | SubIndex 149 | 149. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x95 (Slave 19 Outputs__Slave 19B, DO0)) | UINT32 | RO | 0xF700:95, 1
1640:96 | SubIndex 150 | 150. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x96 (Slave 19 Outputs__Slave 19B, DO1)) | UINT32 | RO | 0xF700:96, 1
1640:97 | SubIndex 151 | 151. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x97 (Slave 19 Outputs__Slave 19B, DO2)) | UINT32 | RO | 0xF700:97, 1
1640:98 | SubIndex 152 | 152. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x98 (Slave 19 Outputs__Slave 19B, DO3)) | UINT32 | RO | 0xF700:98, 1
1640:99 | SubIndex 153 | 153. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x99 (Slave 20 Outputs__Slave 20A, DO0)) | UINT32 | RO | 0xF700:99, 1
1640:9A | SubIndex 154 | 154. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9A (Slave 20 Outputs__Slave 20A, DO1)) | UINT32 | RO | 0xF700:9A, 1
1640:9B | SubIndex 155 | 155. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9B (Slave 20 Outputs__Slave 20A, DO2)) | UINT32 | RO | 0xF700:9B, 1
1640:9C | SubIndex 156 | 156. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9C (Slave 20 Outputs__Slave 20A, DO3)) | UINT32 | RO | 0xF700:9C, 1
1640:9D | SubIndex 157 | 157. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9D (Slave 20 Outputs__Slave 20B, DO0)) | UINT32 | RO | 0xF700:9D, 1
1640:9E | SubIndex 158 | 158. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9E (Slave 20 Outputs__Slave 20B, DO1)) | UINT32 | RO | 0xF700:9E, 1
1640:9F | SubIndex 159 | 159. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0x9F (Slave 20 Outputs__Slave 20B, DO2)) | UINT32 | RO | 0xF700:9F, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:A0 | SubIndex 160 | 160. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA0 (Slave 20 Outputs__Slave 20B, DO3)) | UINT32 | RO | 0xF700:A0, 1
1640:A1 | SubIndex 161 | 161. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA1 (Slave 21 Outputs__Slave 21A, DO0)) | UINT32 | RO | 0xF700:A1, 1
1640:A2 | SubIndex 162 | 162. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA2 (Slave 21 Outputs__Slave 21A, DO1)) | UINT32 | RO | 0xF700:A2, 1
1640:A3 | SubIndex 163 | 163. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA3 (Slave 21 Outputs__Slave 21A, DO2)) | UINT32 | RO | 0xF700:A3, 1
1640:A4 | SubIndex 164 | 164. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA4 (Slave 21 Outputs__Slave 21A, DO3)) | UINT32 | RO | 0xF700:A4, 1
1640:A5 | SubIndex 165 | 165. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA5 (Slave 21 Outputs__Slave 21B, DO0)) | UINT32 | RO | 0xF700:A5, 1
1640:A6 | SubIndex 166 | 166. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA6 (Slave 21 Outputs__Slave 21B, DO1)) | UINT32 | RO | 0xF700:A6, 1
1640:A7 | SubIndex 167 | 167. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA7 (Slave 21 Outputs__Slave 21B, DO2)) | UINT32 | RO | 0xF700:A7, 1
1640:A8 | SubIndex 168 | 168. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA8 (Slave 21 Outputs__Slave 21B, DO3)) | UINT32 | RO | 0xF700:A8, 1
1640:A9 | SubIndex 169 | 169. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xA9 (Slave 22 Outputs__Slave 22A, DO0)) | UINT32 | RO | 0xF700:A9, 1
1640:AA | SubIndex 170 | 170. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAA (Slave 22 Outputs__Slave 22A, DO1)) | UINT32 | RO | 0xF700:AA, 1
1640:AB | SubIndex 171 | 171. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAB (Slave 22 Outputs__Slave 22A, DO2)) | UINT32 | RO | 0xF700:AB, 1
1640:AC | SubIndex 172 | 172. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAC (Slave 22 Outputs__Slave 22A, DO3)) | UINT32 | RO | 0xF700:AC, 1
1640:AD | SubIndex 173 | 173. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAD (Slave 22 Outputs__Slave 22B, DO0)) | UINT32 | RO | 0xF700:AD, 1
1640:AE | SubIndex 174 | 174. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAE (Slave 22 Outputs__Slave 22B, DO1)) | UINT32 | RO | 0xF700:AE, 1
1640:AF | SubIndex 175 | 175. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xAF (Slave 22 Outputs__Slave 22B, DO2)) | UINT32 | RO | 0xF700:AF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:B0 | SubIndex 176 | 176. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB0 (Slave 22 Outputs__Slave 22B, DO3)) | UINT32 | RO | 0xF700:B0, 1
1640:B1 | SubIndex 177 | 177. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB1 (Slave 23 Outputs__Slave 23A, DO0)) | UINT32 | RO | 0xF700:B1, 1
1640:B2 | SubIndex 178 | 178. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB2 (Slave 23 Outputs__Slave 23A, DO1)) | UINT32 | RO | 0xF700:B2, 1
1640:B3 | SubIndex 179 | 179. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB3 (Slave 23 Outputs__Slave 23A, DO2)) | UINT32 | RO | 0xF700:B3, 1
1640:B4 | SubIndex 180 | 180. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB4 (Slave 23 Outputs__Slave 23A, DO3)) | UINT32 | RO | 0xF700:B4, 1
1640:B5 | SubIndex 181 | 181. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB5 (Slave 23 Outputs__Slave 23B, DO0)) | UINT32 | RO | 0xF700:B5, 1
1640:B6 | SubIndex 182 | 182. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB6 (Slave 23 Outputs__Slave 23B, DO1)) | UINT32 | RO | 0xF700:B6, 1
1640:B7 | SubIndex 183 | 183. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB7 (Slave 23 Outputs__Slave 23B, DO2)) | UINT32 | RO | 0xF700:B7, 1
1640:B8 | SubIndex 184 | 184. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB8 (Slave 23 Outputs__Slave 23B, DO3)) | UINT32 | RO | 0xF700:B8, 1
1640:B9 | SubIndex 185 | 185. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xB9 (Slave 24 Outputs__Slave 24A, DO0)) | UINT32 | RO | 0xF700:B9, 1
1640:BA | SubIndex 186 | 186. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBA (Slave 24 Outputs__Slave 24A, DO1)) | UINT32 | RO | 0xF700:BA, 1
1640:BB | SubIndex 187 | 187. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBB (Slave 24 Outputs__Slave 24A, DO2)) | UINT32 | RO | 0xF700:BB, 1
1640:BC | SubIndex 188 | 188. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBC (Slave 24 Outputs__Slave 24A, DO3)) | UINT32 | RO | 0xF700:BC, 1
1640:BD | SubIndex 189 | 189. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBD (Slave 24 Outputs__Slave 24B, DO0)) | UINT32 | RO | 0xF700:BD, 1
1640:BE | SubIndex 190 | 190. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBE (Slave 24 Outputs__Slave 24B, DO1)) | UINT32 | RO | 0xF700:BE, 1
1640:BF | SubIndex 191 | 191. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xBF (Slave 24 Outputs__Slave 24B, DO2)) | UINT32 | RO | 0xF700:BF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:C0 | SubIndex 192 | 192. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC0 (Slave 24 Outputs__Slave 24B, DO3)) | UINT32 | RO | 0xF700:C0, 1
1640:C1 | SubIndex 193 | 193. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC1 (Slave 25 Outputs__Slave 25A, DO0)) | UINT32 | RO | 0xF700:C1, 1
1640:C2 | SubIndex 194 | 194. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC2 (Slave 25 Outputs__Slave 25A, DO1)) | UINT32 | RO | 0xF700:C2, 1
1640:C3 | SubIndex 195 | 195. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC3 (Slave 25 Outputs__Slave 25A, DO2)) | UINT32 | RO | 0xF700:C3, 1
1640:C4 | SubIndex 196 | 196. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC4 (Slave 25 Outputs__Slave 25A, DO3)) | UINT32 | RO | 0xF700:C4, 1
1640:C5 | SubIndex 197 | 197. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC5 (Slave 25 Outputs__Slave 25B, DO0)) | UINT32 | RO | 0xF700:C5, 1
1640:C6 | SubIndex 198 | 198. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC6 (Slave 25 Outputs__Slave 25B, DO1)) | UINT32 | RO | 0xF700:C6, 1
1640:C7 | SubIndex 199 | 199. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC7 (Slave 25 Outputs__Slave 25B, DO2)) | UINT32 | RO | 0xF700:C7, 1
1640:C8 | SubIndex 200 | 200. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC8 (Slave 25 Outputs__Slave 25B, DO3)) | UINT32 | RO | 0xF700:C8, 1
1640:C9 | SubIndex 201 | 201. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xC9 (Slave 26 Outputs__Slave 26A, DO0)) | UINT32 | RO | 0xF700:C9, 1
1640:CA | SubIndex 202 | 202. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCA (Slave 26 Outputs__Slave 26A, DO1)) | UINT32 | RO | 0xF700:CA, 1
1640:CB | SubIndex 203 | 203. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCB (Slave 26 Outputs__Slave 26A, DO2)) | UINT32 | RO | 0xF700:CB, 1
1640:CC | SubIndex 204 | 204. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCC (Slave 26 Outputs__Slave 26A, DO3)) | UINT32 | RO | 0xF700:CC, 1
1640:CD | SubIndex 205 | 205. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCD (Slave 26 Outputs__Slave 26B, DO0)) | UINT32 | RO | 0xF700:CD, 1
1640:CE | SubIndex 206 | 206. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCE (Slave 26 Outputs__Slave 26B, DO1)) | UINT32 | RO | 0xF700:CE, 1
1640:CF | SubIndex 207 | 207. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xCF (Slave 26 Outputs__Slave 26B, DO2)) | UINT32 | RO | 0xF700:CF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:D0 | SubIndex 208 | 208. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD0 (Slave 26 Outputs__Slave 26B, DO3)) | UINT32 | RO | 0xF700:D0, 1
1640:D1 | SubIndex 209 | 209. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD1 (Slave 27 Outputs__Slave 27A, DO0)) | UINT32 | RO | 0xF700:D1, 1
1640:D2 | SubIndex 210 | 210. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD2 (Slave 27 Outputs__Slave 27A, DO1)) | UINT32 | RO | 0xF700:D2, 1
1640:D3 | SubIndex 211 | 211. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD3 (Slave 27 Outputs__Slave 27A, DO2)) | UINT32 | RO | 0xF700:D3, 1
1640:D4 | SubIndex 212 | 212. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD4 (Slave 27 Outputs__Slave 27A, DO3)) | UINT32 | RO | 0xF700:D4, 1
1640:D5 | SubIndex 213 | 213. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD5 (Slave 27 Outputs__Slave 27B, DO0)) | UINT32 | RO | 0xF700:D5, 1
1640:D6 | SubIndex 214 | 214. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD6 (Slave 27 Outputs__Slave 27B, DO1)) | UINT32 | RO | 0xF700:D6, 1
1640:D7 | SubIndex 215 | 215. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD7 (Slave 27 Outputs__Slave 27B, DO2)) | UINT32 | RO | 0xF700:D7, 1
1640:D8 | SubIndex 216 | 216. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD8 (Slave 27 Outputs__Slave 27B, DO3)) | UINT32 | RO | 0xF700:D8, 1
1640:D9 | SubIndex 217 | 217. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xD9 (Slave 28 Outputs__Slave 28A, DO0)) | UINT32 | RO | 0xF700:D9, 1
1640:DA | SubIndex 218 | 218. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDA (Slave 28 Outputs__Slave 28A, DO1)) | UINT32 | RO | 0xF700:DA, 1
1640:DB | SubIndex 219 | 219. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDB (Slave 28 Outputs__Slave 28A, DO2)) | UINT32 | RO | 0xF700:DB, 1
1640:DC | SubIndex 220 | 220. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDC (Slave 28 Outputs__Slave 28A, DO3)) | UINT32 | RO | 0xF700:DC, 1
1640:DD | SubIndex 221 | 221. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDD (Slave 28 Outputs__Slave 28B, DO0)) | UINT32 | RO | 0xF700:DD, 1
1640:DE | SubIndex 222 | 222. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDE (Slave 28 Outputs__Slave 28B, DO1)) | UINT32 | RO | 0xF700:DE, 1
1640:DF | SubIndex 223 | 223. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xDF (Slave 28 Outputs__Slave 28B, DO2)) | UINT32 | RO | 0xF700:DF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:E0 | SubIndex 224 | 224. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE0 (Slave 28 Outputs__Slave 28B, DO3)) | UINT32 | RO | 0xF700:E0, 1
1640:E1 | SubIndex 225 | 225. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE1 (Slave 29 Outputs__Slave 29A, DO0)) | UINT32 | RO | 0xF700:E1, 1
1640:E2 | SubIndex 226 | 226. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE2 (Slave 29 Outputs__Slave 29A, DO1)) | UINT32 | RO | 0xF700:E2, 1
1640:E3 | SubIndex 227 | 227. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE3 (Slave 29 Outputs__Slave 29A, DO2)) | UINT32 | RO | 0xF700:E3, 1
1640:E4 | SubIndex 228 | 228. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE4 (Slave 29 Outputs__Slave 29A, DO3)) | UINT32 | RO | 0xF700:E4, 1
1640:E5 | SubIndex 229 | 229. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE5 (Slave 29 Outputs__Slave 29B, DO0)) | UINT32 | RO | 0xF700:E5, 1
1640:E6 | SubIndex 230 | 230. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE6 (Slave 29 Outputs__Slave 29B, DO1)) | UINT32 | RO | 0xF700:E6, 1
1640:E7 | SubIndex 231 | 231. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE7 (Slave 29 Outputs__Slave 29B, DO2)) | UINT32 | RO | 0xF700:E7, 1
1640:E8 | SubIndex 232 | 232. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE8 (Slave 29 Outputs__Slave 29B, DO3)) | UINT32 | RO | 0xF700:E8, 1
1640:E9 | SubIndex 233 | 233. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xE9 (Slave 30 Outputs__Slave 30A, DO0)) | UINT32 | RO | 0xF700:E9, 1
1640:EA | SubIndex 234 | 234. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEA (Slave 30 Outputs__Slave 30A, DO1)) | UINT32 | RO | 0xF700:EA, 1
1640:EB | SubIndex 235 | 235. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEB (Slave 30 Outputs__Slave 30A, DO2)) | UINT32 | RO | 0xF700:EB, 1
1640:EC | SubIndex 236 | 236. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEC (Slave 30 Outputs__Slave 30A, DO3)) | UINT32 | RO | 0xF700:EC, 1
1640:ED | SubIndex 237 | 237. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xED (Slave 30 Outputs__Slave 30B, DO0)) | UINT32 | RO | 0xF700:ED, 1
1640:EE | SubIndex 238 | 238. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEE (Slave 30 Outputs__Slave 30B, DO1)) | UINT32 | RO | 0xF700:EE, 1
1640:EF | SubIndex 239 | 239. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xEF (Slave 30 Outputs__Slave 30B, DO2)) | UINT32 | RO | 0xF700:EF, 1
Index 1640 ASI RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1640:F0 | SubIndex 240 | 240. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF0 (Slave 30 Outputs__Slave 30B, DO3)) | UINT32 | RO | 0xF700:F0, 1
1640:F1 | SubIndex 241 | 241. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF1 (Slave 31 Outputs__Slave 31A, DO0)) | UINT32 | RO | 0xF700:F1, 1
1640:F2 | SubIndex 242 | 242. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF2 (Slave 31 Outputs__Slave 31A, DO1)) | UINT32 | RO | 0xF700:F2, 1
1640:F3 | SubIndex 243 | 243. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF3 (Slave 31 Outputs__Slave 31A, DO2)) | UINT32 | RO | 0xF700:F3, 1
1640:F4 | SubIndex 244 | 244. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF4 (Slave 31 Outputs__Slave 31A, DO3)) | UINT32 | RO | 0xF700:F4, 1
1640:F5 | SubIndex 245 | 245. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF5 (Slave 31 Outputs__Slave 31B, DO0)) | UINT32 | RO | 0xF700:F5, 1
1640:F6 | SubIndex 246 | 246. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF6 (Slave 31 Outputs__Slave 31B, DO1)) | UINT32 | RO | 0xF700:F6, 1
1640:F7 | SubIndex 247 | 247. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF7 (Slave 31 Outputs__Slave 31B, DO2)) | UINT32 | RO | 0xF700:F7, 1
1640:F8 | SubIndex 248 | 248. PDO Mapping entry (object 0xF700 (ASI Digital Outputs), entry 0xF8 (Slave 31 Outputs__Slave 31B, DO3)) | UINT32 | RO | 0xF700:F8, 1
Index 1680 ASI RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1680:0 | ASI RxPDO-Map Control | PDO Mapping RxPDO 129 | UINT8 | RO | 0x06 (6dez)
1680:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x01 (Auto Programming Enable)) | UINT32 | RO | 0xF200:01, 1
1680:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x02 (Go Offline Mode)) | UINT32 | RO | 0xF200:02, 1
1680:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x03 (Data Exchange Active)) | UINT32 | RO | 0xF200:03, 1
1680:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x04 (Go Protected Mode)) | UINT32 | RO | 0xF200:04, 1
1680:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF200 (ASI Control), entry 0x05 (Go Configuration Mode)) | UINT32 | RO | 0xF200:05, 1
1680:06 | SubIndex 006 | 6. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
Index 1A01 ASI TxPDO-Map Analog Inputs Slave 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ASI TxPDO-Map Analog Inputs Slave 1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x08 (8dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6010:01, 16
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6010:02, 16
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6010:03, 16
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6010:04, 16
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6010:05, 16
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6010:06, 16
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6010:07, 16
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ASI Analog Inputs Slave 1 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6010:08, 16
Index 1A02 ASI TxPDO-Map Analog Inputs Slave 2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ASI TxPDO-Map Analog Inputs Slave 2 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x08 (8dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6020:01, 16
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6020:02, 16
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6020:03, 16
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6020:04, 16
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6020:05, 16
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6020:06, 16
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6020:07, 16
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (ASI Analog Inputs Slave 2 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6020:08, 16
Index 1A03 ASI TxPDO-Map Analog Inputs Slave 3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ASI TxPDO-Map Analog Inputs Slave 3 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x08 (8dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6030:01, 16
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6030:02, 16
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6030:03, 16
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6030:04, 16
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6030:05, 16
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6030:06, 16
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6030:07, 16
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (ASI Analog Inputs Slave 3 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6030:08, 16
Index 1A04 ASI TxPDO-Map Analog Inputs Slave 4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ASI TxPDO-Map Analog Inputs Slave 4 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x08 (8dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6040:01, 16
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6040:02, 16
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6040:03, 16
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6040:04, 16
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6040:05, 16
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6040:06, 16
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6040:07, 16
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6040 (ASI Analog Inputs Slave 4 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6040:08, 16
Index 1A05 ASI TxPDO-Map Analog Inputs Slave 5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ASI TxPDO-Map Analog Inputs Slave 5 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x08 (8dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6050:01, 16
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6050:02, 16
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6050:03, 16
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6050:04, 16
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6050:05, 16
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6050:06, 16
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6050:07, 16
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6050 (ASI Analog Inputs Slave 5 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6050:08, 16
Index 1A06 ASI TxPDO-Map Analog Inputs Slave 6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | ASI TxPDO-Map Analog Inputs Slave 6 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x08 (8dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6060:01, 16
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6060:02, 16
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6060:03, 16
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6060:04, 16
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6060:05, 16
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6060:06, 16
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6060:07, 16
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6060 (ASI Analog Inputs Slave 6 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6060:08, 16
Index 1A07 ASI TxPDO-Map Analog Inputs Slave 7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | ASI TxPDO-Map Analog Inputs Slave 7 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x08 (8dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6070:01, 16
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6070:02, 16
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6070:03, 16
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6070:04, 16
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6070:05, 16
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6070:06, 16
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6070:07, 16
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6070 (ASI Analog Inputs Slave 7 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6070:08, 16
Index 1A08 ASI TxPDO-Map Analog Inputs Slave 8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | ASI TxPDO-Map Analog Inputs Slave 8 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x08 (8dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6080:01, 16
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6080:02, 16
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6080:03, 16
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6080:04, 16
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6080:05, 16
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6080:06, 16
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6080:07, 16
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6080 (ASI Analog Inputs Slave 8 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6080:08, 16
Index 1A09 ASI TxPDO-Map Analog Inputs Slave 9
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | ASI TxPDO-Map Analog Inputs Slave 9 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x08 (8dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6090:01, 16
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6090:02, 16
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6090:03, 16
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6090:04, 16
1A09:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6090:05, 16
1A09:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6090:06, 16
1A09:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6090:07, 16
1A09:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6090 (ASI Analog Inputs Slave 9 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6090:08, 16
Index 1A0A ASI TxPDO-Map Analog Inputs Slave 10
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | ASI TxPDO-Map Analog Inputs Slave 10 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x08 (8dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60A0:01, 16
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60A0:02, 16
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60A0:03, 16
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60A0:04, 16
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60A0:05, 16
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60A0:06, 16
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60A0:07, 16
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A0 (ASI Analog Inputs Slave 10 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60A0:08, 16
Index 1A0B ASI TxPDO-Map Analog Inputs Slave 11
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | ASI TxPDO-Map Analog Inputs Slave 11 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x08 (8dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60B0:01, 16
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60B0:02, 16
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60B0:03, 16
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60B0:04, 16
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60B0:05, 16
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60B0:06, 16
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60B0:07, 16
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B0 (ASI Analog Inputs Slave 11 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60B0:08, 16
Index 1A0C ASI TxPDO-Map Analog Inputs Slave 12
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | ASI TxPDO-Map Analog Inputs Slave 12 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x08 (8dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60C0:01, 16
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60C0:02, 16
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60C0:03, 16
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60C0:04, 16
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60C0:05, 16
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60C0:06, 16
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60C0:07, 16
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C0 (ASI Analog Inputs Slave 12 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60C0:08, 16
Index 1A0D ASI TxPDO-Map Analog Inputs Slave 13
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | ASI TxPDO-Map Analog Inputs Slave 13 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x08 (8dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60D0:01, 16
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60D0:02, 16
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60D0:03, 16
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60D0:04, 16
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60D0:05, 16
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60D0:06, 16
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60D0:07, 16
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D0 (ASI Analog Inputs Slave 13 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60D0:08, 16
Index 1A0E ASI TxPDO-Map Analog Inputs Slave 14
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0E:0 | ASI TxPDO-Map Analog Inputs Slave 14 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x08 (8dez)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60E0:01, 16
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60E0:02, 16
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60E0:03, 16
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60E0:04, 16
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60E0:05, 16
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60E0:06, 16
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60E0:07, 16
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E0 (ASI Analog Inputs Slave 14 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60E0:08, 16
Index 1A0F ASI TxPDO-Map Analog Inputs Slave 15
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0F:0 | ASI TxPDO-Map Analog Inputs Slave 15 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x08 (8dez)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x60F0:01, 16
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x60F0:02, 16
1A0F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x60F0:03, 16
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x60F0:04, 16
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x60F0:05, 16
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x60F0:06, 16
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x60F0:07, 16
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F0 (ASI Analog Inputs Slave 15 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x60F0:08, 16
Index 1A10 ASI TxPDO-Map Analog Inputs Slave 16
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | ASI TxPDO-Map Analog Inputs Slave 16 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x08 (8dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6100:01, 16
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6100:02, 16
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6100:03, 16
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6100:04, 16
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6100:05, 16
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6100:06, 16
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6100:07, 16
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6100 (ASI Analog Inputs Slave 16 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6100:08, 16
Index 1A11 ASI TxPDO-Map Analog Inputs Slave 17
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A11:0 | ASI TxPDO-Map Analog Inputs Slave 17 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x08 (8dez)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6110:01, 16
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6110:02, 16
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6110:03, 16
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6110:04, 16
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6110:05, 16
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6110:06, 16
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6110:07, 16
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6110 (ASI Analog Inputs Slave 17 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6110:08, 16
Index 1A12 ASI TxPDO-Map Analog Inputs Slave 18
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A12:0 | ASI TxPDO-Map Analog Inputs Slave 18 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x08 (8dez)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6120:01, 16
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6120:02, 16
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6120:03, 16
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6120:04, 16
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6120:05, 16
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6120:06, 16
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6120:07, 16
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6120 (ASI Analog Inputs Slave 18 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6120:08, 16
Index 1A13 ASI TxPDO-Map Analog Inputs Slave 19
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A13:0 | ASI TxPDO-Map Analog Inputs Slave 19 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x08 (8dez)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6130:01, 16
1A13:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6130:02, 16
1A13:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6130:03, 16
1A13:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6130:04, 16
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6130:05, 16
1A13:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6130:06, 16
1A13:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6130:07, 16
1A13:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6130 (ASI Analog Inputs Slave 19 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6130:08, 16
Index 1A14 ASI TxPDO-Map Analog Inputs Slave 20
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A14:0 | ASI TxPDO-Map Analog Inputs Slave 20 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x08 (8dez)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6140:01, 16
1A14:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6140:02, 16
1A14:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6140:03, 16
1A14:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6140:04, 16
1A14:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6140:05, 16
1A14:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6140:06, 16
1A14:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6140:07, 16
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6140 (ASI Analog Inputs Slave 20 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6140:08, 16
Index 1A15 ASI TxPDO-Map Analog Inputs Slave 21
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | ASI TxPDO-Map Analog Inputs Slave 21 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x08 (8dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6150:01, 16
1A15:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6150:02, 16
1A15:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6150:03, 16
1A15:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6150:04, 16
1A15:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6150:05, 16
1A15:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6150:06, 16
1A15:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6150:07, 16
1A15:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6150 (ASI Analog Inputs Slave 21 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6150:08, 16
Index 1A16 ASI TxPDO-Map Analog Inputs Slave 22
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A16:0 | ASI TxPDO-Map Analog Inputs Slave 22 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x08 (8dez)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6160:01, 16
1A16:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6160:02, 16
1A16:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6160:03, 16
1A16:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6160:04, 16
1A16:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6160:05, 16
1A16:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6160:06, 16
1A16:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6160:07, 16
1A16:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6160 (ASI Analog Inputs Slave 22 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6160:08, 16
Index 1A17 ASI TxPDO-Map Analog Inputs Slave 23
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A17:0 | ASI TxPDO-Map Analog Inputs Slave 23 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x08 (8dez)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6170:01, 16
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6170:02, 16
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6170:03, 16
1A17:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6170:04, 16
1A17:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6170:05, 16
1A17:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6170:06, 16
1A17:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6170:07, 16
1A17:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6170 (ASI Analog Inputs Slave 23 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6170:08, 16
Index 1A18 ASI TxPDO-Map Analog Inputs Slave 24
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A18:0 | ASI TxPDO-Map Analog Inputs Slave 24 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x08 (8dez)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6180:01, 16
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6180:02, 16
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6180:03, 16
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6180:04, 16
1A18:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6180:05, 16
1A18:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6180:06, 16
1A18:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6180:07, 16
1A18:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6180 (ASI Analog Inputs Slave 24 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6180:08, 16
Index 1A19 ASI TxPDO-Map Analog Inputs Slave 25
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A19:0 | ASI TxPDO-Map Analog Inputs Slave 25 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x08 (8dez)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x6190:01, 16
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x6190:02, 16
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x6190:03, 16
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x6190:04, 16
1A19:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x6190:05, 16
1A19:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x6190:06, 16
1A19:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x6190:07, 16
1A19:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6190 (ASI Analog Inputs Slave 25 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x6190:08, 16
Index 1A1A ASI TxPDO-Map Analog Inputs Slave 26
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1A:0 | ASI TxPDO-Map Analog Inputs Slave 26 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x08 (8dez)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61A0:01, 16
1A1A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61A0:02, 16
1A1A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61A0:03, 16
1A1A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61A0:04, 16
1A1A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61A0:05, 16
1A1A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61A0:06, 16
1A1A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61A0:07, 16
1A1A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61A0 (ASI Analog Inputs Slave 26 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61A0:08, 16
Index 1A1B ASI TxPDO-Map Analog Inputs Slave 27
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1B:0 | ASI TxPDO-Map Analog Inputs Slave 27 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x08 (8dez)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61B0:01, 16
1A1B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61B0:02, 16
1A1B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61B0:03, 16
1A1B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61B0:04, 16
1A1B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61B0:05, 16
1A1B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61B0:06, 16
1A1B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61B0:07, 16
1A1B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61B0 (ASI Analog Inputs Slave 27 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61B0:08, 16
Index 1A1C ASI TxPDO-Map Analog Inputs Slave 28
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1C:0 | ASI TxPDO-Map Analog Inputs Slave 28 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x08 (8dez)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61C0:01, 16
1A1C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61C0:02, 16
1A1C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61C0:03, 16
1A1C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61C0:04, 16
1A1C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61C0:05, 16
1A1C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61C0:06, 16
1A1C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61C0:07, 16
1A1C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61C0 (ASI Analog Inputs Slave 28 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61C0:08, 16
Index 1A1D ASI TxPDO-Map Analog Inputs Slave 29
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1D:0 | ASI TxPDO-Map Analog Inputs Slave 29 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x08 (8dez)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61D0:01, 16
1A1D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61D0:02, 16
1A1D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61D0:03, 16
1A1D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61D0:04, 16
1A1D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61D0:05, 16
1A1D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61D0:06, 16
1A1D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61D0:07, 16
1A1D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61D0 (ASI Analog Inputs Slave 29 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61D0:08, 16
Index 1A1E ASI TxPDO-Map Analog Inputs Slave 30
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | ASI TxPDO-Map Analog Inputs Slave 30 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x08 (8dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61E0:01, 16
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61E0:02, 16
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61E0:03, 16
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61E0:04, 16
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61E0:05, 16
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61E0:06, 16
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61E0:07, 16
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61E0 (ASI Analog Inputs Slave 30 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61E0:08, 16
Index 1A1F ASI TxPDO-Map Analog Inputs Slave 31
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1F:0 | ASI TxPDO-Map Analog Inputs Slave 31 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x08 (8dez)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x01 (State Ch.1 (A-Slave))) | UINT32 | RO | 0x61F0:01, 16
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x02 (Value Ch.1 (A-Slave))) | UINT32 | RO | 0x61F0:02, 16
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x03 (State Ch.2 (A-Slave))) | UINT32 | RO | 0x61F0:03, 16
1A1F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x04 (Value Ch.2 (A-Slave))) | UINT32 | RO | 0x61F0:04, 16
1A1F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x05 (State Ch.3 (A-Slave))) | UINT32 | RO | 0x61F0:05, 16
1A1F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x06 (Value Ch.3 (A-Slave))) | UINT32 | RO | 0x61F0:06, 16
1A1F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x07 (State Ch.4 (A-Slave))) | UINT32 | RO | 0x61F0:07, 16
1A1F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x61F0 (ASI Analog Inputs Slave 31 ), entry 0x08 (Value Ch.4 (A-Slave))) | UINT32 | RO | 0x61F0:08, 16
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:0 | ASI TxPDO-Map Inputs Device | PDO Mapping TxPDO 65 | UINT8 | RO | 0xF8 (248dez)
1A40:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x01 (Slave 1 Inputs__Slave 1A, DI0)) | UINT32 | RO | 0xF600:01, 1
1A40:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x02 (Slave 1 Inputs__Slave 1A, DI1)) | UINT32 | RO | 0xF600:02, 1
1A40:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x03 (Slave 1 Inputs__Slave 1A, DI2)) | UINT32 | RO | 0xF600:03, 1
1A40:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x04 (Slave 1 Inputs__Slave 1A, DI3)) | UINT32 | RO | 0xF600:04, 1
1A40:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x05 (Slave 1 Inputs__Slave 1B, DI0)) | UINT32 | RO | 0xF600:05, 1
1A40:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x06 (Slave 1 Inputs__Slave 1B, DI1)) | UINT32 | RO | 0xF600:06, 1
1A40:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x07 (Slave 1 Inputs__Slave 1B, DI2)) | UINT32 | RO | 0xF600:07, 1
1A40:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x08 (Slave 1 Inputs__Slave 1B, DI3)) | UINT32 | RO | 0xF600:08, 1
1A40:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x09 (Slave 2 Inputs__Slave 2A, DI0)) | UINT32 | RO | 0xF600:09, 1
1A40:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0A (Slave 2 Inputs__Slave 2A, DI1)) | UINT32 | RO | 0xF600:0A, 1
1A40:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0B (Slave 2 Inputs__Slave 2A, DI2)) | UINT32 | RO | 0xF600:0B, 1
1A40:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0C (Slave 2 Inputs__Slave 2A, DI3)) | UINT32 | RO | 0xF600:0C, 1
1A40:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0D (Slave 2 Inputs__Slave 2B, DI0)) | UINT32 | RO | 0xF600:0D, 1
1A40:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0E (Slave 2 Inputs__Slave 2B, DI1)) | UINT32 | RO | 0xF600:0E, 1
1A40:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x0F (Slave 2 Inputs__Slave 2B, DI2)) | UINT32 | RO | 0xF600:0F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x10 (Slave 2 Inputs__Slave 2B, DI3)) | UINT32 | RO | 0xF600:10, 1
1A40:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x11 (Slave 3 Inputs__Slave 3A, DI0)) | UINT32 | RO | 0xF600:11, 1
1A40:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x12 (Slave 3 Inputs__Slave 3A, DI1)) | UINT32 | RO | 0xF600:12, 1
1A40:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x13 (Slave 3 Inputs__Slave 3A, DI2)) | UINT32 | RO | 0xF600:13, 1
1A40:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x14 (Slave 3 Inputs__Slave 3A, DI3)) | UINT32 | RO | 0xF600:14, 1
1A40:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x15 (Slave 3 Inputs__Slave 3B, DI0)) | UINT32 | RO | 0xF600:15, 1
1A40:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x16 (Slave 3 Inputs__Slave 3B, DI1)) | UINT32 | RO | 0xF600:16, 1
1A40:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x17 (Slave 3 Inputs__Slave 3B, DI2)) | UINT32 | RO | 0xF600:17, 1
1A40:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x18 (Slave 3 Inputs__Slave 3B, DI3)) | UINT32 | RO | 0xF600:18, 1
1A40:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x19 (Slave 4 Inputs__Slave 4A, DI0)) | UINT32 | RO | 0xF600:19, 1
1A40:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1A (Slave 4 Inputs__Slave 4A, DI1)) | UINT32 | RO | 0xF600:1A, 1
1A40:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1B (Slave 4 Inputs__Slave 4A, DI2)) | UINT32 | RO | 0xF600:1B, 1
1A40:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1C (Slave 4 Inputs__Slave 4A, DI3)) | UINT32 | RO | 0xF600:1C, 1
1A40:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1D (Slave 4 Inputs__Slave 4B, DI0)) | UINT32 | RO | 0xF600:1D, 1
1A40:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1E (Slave 4 Inputs__Slave 4B, DI1)) | UINT32 | RO | 0xF600:1E, 1
1A40:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x1F (Slave 4 Inputs__Slave 4B, DI2)) | UINT32 | RO | 0xF600:1F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x20 (Slave 4 Inputs__Slave 4B, DI3)) | UINT32 | RO | 0xF600:20, 1
1A40:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x21 (Slave 5 Inputs__Slave 5A, DI0)) | UINT32 | RO | 0xF600:21, 1
1A40:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x22 (Slave 5 Inputs__Slave 5A, DI1)) | UINT32 | RO | 0xF600:22, 1
1A40:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x23 (Slave 5 Inputs__Slave 5A, DI2)) | UINT32 | RO | 0xF600:23, 1
1A40:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x24 (Slave 5 Inputs__Slave 5A, DI3)) | UINT32 | RO | 0xF600:24, 1
1A40:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x25 (Slave 5 Inputs__Slave 5B, DI0)) | UINT32 | RO | 0xF600:25, 1
1A40:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x26 (Slave 5 Inputs__Slave 5B, DI1)) | UINT32 | RO | 0xF600:26, 1
1A40:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x27 (Slave 5 Inputs__Slave 5B, DI2)) | UINT32 | RO | 0xF600:27, 1
1A40:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x28 (Slave 5 Inputs__Slave 5B, DI3)) | UINT32 | RO | 0xF600:28, 1
1A40:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x29 (Slave 6 Inputs__Slave 6A, DI0)) | UINT32 | RO | 0xF600:29, 1
1A40:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2A (Slave 6 Inputs__Slave 6A, DI1)) | UINT32 | RO | 0xF600:2A, 1
1A40:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2B (Slave 6 Inputs__Slave 6A, DI2)) | UINT32 | RO | 0xF600:2B, 1
1A40:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2C (Slave 6 Inputs__Slave 6A, DI3)) | UINT32 | RO | 0xF600:2C, 1
1A40:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2D (Slave 6 Inputs__Slave 6B, DI0)) | UINT32 | RO | 0xF600:2D, 1
1A40:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2E (Slave 6 Inputs__Slave 6B, DI1)) | UINT32 | RO | 0xF600:2E, 1
1A40:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x2F (Slave 6 Inputs__Slave 6B, DI2)) | UINT32 | RO | 0xF600:2F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x30 (Slave 6 Inputs__Slave 6B, DI3)) | UINT32 | RO | 0xF600:30, 1
1A40:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x31 (Slave 7 Inputs__Slave 7A, DI0)) | UINT32 | RO | 0xF600:31, 1
1A40:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x32 (Slave 7 Inputs__Slave 7A, DI1)) | UINT32 | RO | 0xF600:32, 1
1A40:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x33 (Slave 7 Inputs__Slave 7A, DI2)) | UINT32 | RO | 0xF600:33, 1
1A40:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x34 (Slave 7 Inputs__Slave 7A, DI3)) | UINT32 | RO | 0xF600:34, 1
1A40:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x35 (Slave 7 Inputs__Slave 7B, DI0)) | UINT32 | RO | 0xF600:35, 1
1A40:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x36 (Slave 7 Inputs__Slave 7B, DI1)) | UINT32 | RO | 0xF600:36, 1
1A40:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x37 (Slave 7 Inputs__Slave 7B, DI2)) | UINT32 | RO | 0xF600:37, 1
1A40:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x38 (Slave 7 Inputs__Slave 7B, DI3)) | UINT32 | RO | 0xF600:38, 1
1A40:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x39 (Slave 8 Inputs__Slave 8A, DI0)) | UINT32 | RO | 0xF600:39, 1
1A40:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3A (Slave 8 Inputs__Slave 8A, DI1)) | UINT32 | RO | 0xF600:3A, 1
1A40:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3B (Slave 8 Inputs__Slave 8A, DI2)) | UINT32 | RO | 0xF600:3B, 1
1A40:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3C (Slave 8 Inputs__Slave 8A, DI3)) | UINT32 | RO | 0xF600:3C, 1
1A40:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3D (Slave 8 Inputs__Slave 8B, DI0)) | UINT32 | RO | 0xF600:3D, 1
1A40:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3E (Slave 8 Inputs__Slave 8B, DI1)) | UINT32 | RO | 0xF600:3E, 1
1A40:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x3F (Slave 8 Inputs__Slave 8B, DI2)) | UINT32 | RO | 0xF600:3F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:40 | SubIndex 064 | 64. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x40 (Slave 8 Inputs__Slave 8B, DI3)) | UINT32 | RO | 0xF600:40, 1
1A40:41 | SubIndex 065 | 65. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x41 (Slave 9 Inputs__Slave 9A, DI0)) | UINT32 | RO | 0xF600:41, 1
1A40:42 | SubIndex 066 | 66. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x42 (Slave 9 Inputs__Slave 9A, DI1)) | UINT32 | RO | 0xF600:42, 1
1A40:43 | SubIndex 067 | 67. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x43 (Slave 9 Inputs__Slave 9A, DI2)) | UINT32 | RO | 0xF600:43, 1
1A40:44 | SubIndex 068 | 68. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x44 (Slave 9 Inputs__Slave 9A, DI3)) | UINT32 | RO | 0xF600:44, 1
1A40:45 | SubIndex 069 | 69. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x45 (Slave 9 Inputs__Slave 9B, DI0)) | UINT32 | RO | 0xF600:45, 1
1A40:46 | SubIndex 070 | 70. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x46 (Slave 9 Inputs__Slave 9B, DI1)) | UINT32 | RO | 0xF600:46, 1
1A40:47 | SubIndex 071 | 71. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x47 (Slave 9 Inputs__Slave 9B, DI2)) | UINT32 | RO | 0xF600:47, 1
1A40:48 | SubIndex 072 | 72. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x48 (Slave 9 Inputs__Slave 9B, DI3)) | UINT32 | RO | 0xF600:48, 1
1A40:49 | SubIndex 073 | 73. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x49 (Slave 10 Inputs__Slave 10A, DI0)) | UINT32 | RO | 0xF600:49, 1
1A40:4A | SubIndex 074 | 74. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4A (Slave 10 Inputs__Slave 10A, DI1)) | UINT32 | RO | 0xF600:4A, 1
1A40:4B | SubIndex 075 | 75. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4B (Slave 10 Inputs__Slave 10A, DI2)) | UINT32 | RO | 0xF600:4B, 1
1A40:4C | SubIndex 076 | 76. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4C (Slave 10 Inputs__Slave 10A, DI3)) | UINT32 | RO | 0xF600:4C, 1
1A40:4D | SubIndex 077 | 77. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4D (Slave 10 Inputs__Slave 10B, DI0)) | UINT32 | RO | 0xF600:4D, 1
1A40:4E | SubIndex 078 | 78. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4E (Slave 10 Inputs__Slave 10B, DI1)) | UINT32 | RO | 0xF600:4E, 1
1A40:4F | SubIndex 079 | 79. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x4F (Slave 10 Inputs__Slave 10B, DI2)) | UINT32 | RO | 0xF600:4F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:50 | SubIndex 080 | 80. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x50 (Slave 10 Inputs__Slave 10B, DI3)) | UINT32 | RO | 0xF600:50, 1
1A40:51 | SubIndex 081 | 81. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x51 (Slave 11 Inputs__Slave 11A, DI0)) | UINT32 | RO | 0xF600:51, 1
1A40:52 | SubIndex 082 | 82. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x52 (Slave 11 Inputs__Slave 11A, DI1)) | UINT32 | RO | 0xF600:52, 1
1A40:53 | SubIndex 083 | 83. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x53 (Slave 11 Inputs__Slave 11A, DI2)) | UINT32 | RO | 0xF600:53, 1
1A40:54 | SubIndex 084 | 84. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x54 (Slave 11 Inputs__Slave 11A, DI3)) | UINT32 | RO | 0xF600:54, 1
1A40:55 | SubIndex 085 | 85. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x55 (Slave 11 Inputs__Slave 11B, DI0)) | UINT32 | RO | 0xF600:55, 1
1A40:56 | SubIndex 086 | 86. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x56 (Slave 11 Inputs__Slave 11B, DI1)) | UINT32 | RO | 0xF600:56, 1
1A40:57 | SubIndex 087 | 87. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x57 (Slave 11 Inputs__Slave 11B, DI2)) | UINT32 | RO | 0xF600:57, 1
1A40:58 | SubIndex 088 | 88. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x58 (Slave 11 Inputs__Slave 11B, DI3)) | UINT32 | RO | 0xF600:58, 1
1A40:59 | SubIndex 089 | 89. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x59 (Slave 12 Inputs__Slave 12A, DI0)) | UINT32 | RO | 0xF600:59, 1
1A40:5A | SubIndex 090 | 90. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5A (Slave 12 Inputs__Slave 12A, DI1)) | UINT32 | RO | 0xF600:5A, 1
1A40:5B | SubIndex 091 | 91. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5B (Slave 12 Inputs__Slave 12A, DI2)) | UINT32 | RO | 0xF600:5B, 1
1A40:5C | SubIndex 092 | 92. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5C (Slave 12 Inputs__Slave 12A, DI3)) | UINT32 | RO | 0xF600:5C, 1
1A40:5D | SubIndex 093 | 93. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5D (Slave 12 Inputs__Slave 12B, DI0)) | UINT32 | RO | 0xF600:5D, 1
1A40:5E | SubIndex 094 | 94. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5E (Slave 12 Inputs__Slave 12B, DI1)) | UINT32 | RO | 0xF600:5E, 1
1A40:5F | SubIndex 095 | 95. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x5F (Slave 12 Inputs__Slave 12B, DI2)) | UINT32 | RO | 0xF600:5F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:60 | SubIndex 096 | 96. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x60 (Slave 12 Inputs__Slave 12B, DI3)) | UINT32 | RO | 0xF600:60, 1
1A40:61 | SubIndex 097 | 97. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x61 (Slave 13 Inputs__Slave 13A, DI0)) | UINT32 | RO | 0xF600:61, 1
1A40:62 | SubIndex 098 | 98. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x62 (Slave 13 Inputs__Slave 13A, DI1)) | UINT32 | RO | 0xF600:62, 1
1A40:63 | SubIndex 099 | 99. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x63 (Slave 13 Inputs__Slave 13A, DI2)) | UINT32 | RO | 0xF600:63, 1
1A40:64 | SubIndex 100 | 100. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x64 (Slave 13 Inputs__Slave 13A, DI3)) | UINT32 | RO | 0xF600:64, 1
1A40:65 | SubIndex 101 | 101. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x65 (Slave 13 Inputs__Slave 13B, DI0)) | UINT32 | RO | 0xF600:65, 1
1A40:66 | SubIndex 102 | 102. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x66 (Slave 13 Inputs__Slave 13B, DI1)) | UINT32 | RO | 0xF600:66, 1
1A40:67 | SubIndex 103 | 103. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x67 (Slave 13 Inputs__Slave 13B, DI2)) | UINT32 | RO | 0xF600:67, 1
1A40:68 | SubIndex 104 | 104. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x68 (Slave 13 Inputs__Slave 13B, DI3)) | UINT32 | RO | 0xF600:68, 1
1A40:69 | SubIndex 105 | 105. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x69 (Slave 14 Inputs__Slave 14A, DI0)) | UINT32 | RO | 0xF600:69, 1
1A40:6A | SubIndex 106 | 106. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6A (Slave 14 Inputs__Slave 14A, DI1)) | UINT32 | RO | 0xF600:6A, 1
1A40:6B | SubIndex 107 | 107. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6B (Slave 14 Inputs__Slave 14A, DI2)) | UINT32 | RO | 0xF600:6B, 1
1A40:6C | SubIndex 108 | 108. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6C (Slave 14 Inputs__Slave 14A, DI3)) | UINT32 | RO | 0xF600:6C, 1
1A40:6D | SubIndex 109 | 109. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6D (Slave 14 Inputs__Slave 14B, DI0)) | UINT32 | RO | 0xF600:6D, 1
1A40:6E | SubIndex 110 | 110. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6E (Slave 14 Inputs__Slave 14B, DI1)) | UINT32 | RO | 0xF600:6E, 1
1A40:6F | SubIndex 111 | 111. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x6F (Slave 14 Inputs__Slave 14B, DI2)) | UINT32 | RO | 0xF600:6F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:70 | SubIndex 112 | 112. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x70 (Slave 14 Inputs__Slave 14B, DI3)) | UINT32 | RO | 0xF600:70, 1
1A40:71 | SubIndex 113 | 113. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x71 (Slave 15 Inputs__Slave 15A, DI0)) | UINT32 | RO | 0xF600:71, 1
1A40:72 | SubIndex 114 | 114. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x72 (Slave 15 Inputs__Slave 15A, DI1)) | UINT32 | RO | 0xF600:72, 1
1A40:73 | SubIndex 115 | 115. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x73 (Slave 15 Inputs__Slave 15A, DI2)) | UINT32 | RO | 0xF600:73, 1
1A40:74 | SubIndex 116 | 116. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x74 (Slave 15 Inputs__Slave 15A, DI3)) | UINT32 | RO | 0xF600:74, 1
1A40:75 | SubIndex 117 | 117. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x75 (Slave 15 Inputs__Slave 15B, DI0)) | UINT32 | RO | 0xF600:75, 1
1A40:76 | SubIndex 118 | 118. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x76 (Slave 15 Inputs__Slave 15B, DI1)) | UINT32 | RO | 0xF600:76, 1
1A40:77 | SubIndex 119 | 119. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x77 (Slave 15 Inputs__Slave 15B, DI2)) | UINT32 | RO | 0xF600:77, 1
1A40:78 | SubIndex 120 | 120. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x78 (Slave 15 Inputs__Slave 15B, DI3)) | UINT32 | RO | 0xF600:78, 1
1A40:79 | SubIndex 121 | 121. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x79 (Slave 16 Inputs__Slave 16A, DI0)) | UINT32 | RO | 0xF600:79, 1
1A40:7A | SubIndex 122 | 122. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7A (Slave 16 Inputs__Slave 16A, DI1)) | UINT32 | RO | 0xF600:7A, 1
1A40:7B | SubIndex 123 | 123. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7B (Slave 16 Inputs__Slave 16A, DI2)) | UINT32 | RO | 0xF600:7B, 1
1A40:7C | SubIndex 124 | 124. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7C (Slave 16 Inputs__Slave 16A, DI3)) | UINT32 | RO | 0xF600:7C, 1
1A40:7D | SubIndex 125 | 125. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7D (Slave 16 Inputs__Slave 16B, DI0)) | UINT32 | RO | 0xF600:7D, 1
1A40:7E | SubIndex 126 | 126. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7E (Slave 16 Inputs__Slave 16B, DI1)) | UINT32 | RO | 0xF600:7E, 1
1A40:7F | SubIndex 127 | 127. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x7F (Slave 16 Inputs__Slave 16B, DI2)) | UINT32 | RO | 0xF600:7F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:80 | SubIndex 128 | 128. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x80 (Slave 16 Inputs__Slave 16B, DI3)) | UINT32 | RO | 0xF600:80, 1
1A40:81 | SubIndex 129 | 129. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x81 (Slave 17 Inputs__Slave 17A, DI0)) | UINT32 | RO | 0xF600:81, 1
1A40:82 | SubIndex 130 | 130. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x82 (Slave 17 Inputs__Slave 17A, DI1)) | UINT32 | RO | 0xF600:82, 1
1A40:83 | SubIndex 131 | 131. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x83 (Slave 17 Inputs__Slave 17A, DI2)) | UINT32 | RO | 0xF600:83, 1
1A40:84 | SubIndex 132 | 132. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x84 (Slave 17 Inputs__Slave 17A, DI3)) | UINT32 | RO | 0xF600:84, 1
1A40:85 | SubIndex 133 | 133. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x85 (Slave 17 Inputs__Slave 17B, DI0)) | UINT32 | RO | 0xF600:85, 1
1A40:86 | SubIndex 134 | 134. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x86 (Slave 17 Inputs__Slave 17B, DI1)) | UINT32 | RO | 0xF600:86, 1
1A40:87 | SubIndex 135 | 135. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x87 (Slave 17 Inputs__Slave 17B, DI2)) | UINT32 | RO | 0xF600:87, 1
1A40:88 | SubIndex 136 | 136. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x88 (Slave 17 Inputs__Slave 17B, DI3)) | UINT32 | RO | 0xF600:88, 1
1A40:89 | SubIndex 137 | 137. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x89 (Slave 18 Inputs__Slave 18A, DI0)) | UINT32 | RO | 0xF600:89, 1
1A40:8A | SubIndex 138 | 138. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8A (Slave 18 Inputs__Slave 18A, DI1)) | UINT32 | RO | 0xF600:8A, 1
1A40:8B | SubIndex 139 | 139. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8B (Slave 18 Inputs__Slave 18A, DI2)) | UINT32 | RO | 0xF600:8B, 1
1A40:8C | SubIndex 140 | 140. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8C (Slave 18 Inputs__Slave 18A, DI3)) | UINT32 | RO | 0xF600:8C, 1
1A40:8D | SubIndex 141 | 141. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8D (Slave 18 Inputs__Slave 18B, DI0)) | UINT32 | RO | 0xF600:8D, 1
1A40:8E | SubIndex 142 | 142. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8E (Slave 18 Inputs__Slave 18B, DI1)) | UINT32 | RO | 0xF600:8E, 1
1A40:8F | SubIndex 143 | 143. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x8F (Slave 18 Inputs__Slave 18B, DI2)) | UINT32 | RO | 0xF600:8F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:90 | SubIndex 144 | 144. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x90 (Slave 18 Inputs__Slave 18B, DI3)) | UINT32 | RO | 0xF600:90, 1
1A40:91 | SubIndex 145 | 145. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x91 (Slave 19 Inputs__Slave 19A, DI0)) | UINT32 | RO | 0xF600:91, 1
1A40:92 | SubIndex 146 | 146. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x92 (Slave 19 Inputs__Slave 19A, DI1)) | UINT32 | RO | 0xF600:92, 1
1A40:93 | SubIndex 147 | 147. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x93 (Slave 19 Inputs__Slave 19A, DI2)) | UINT32 | RO | 0xF600:93, 1
1A40:94 | SubIndex 148 | 148. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x94 (Slave 19 Inputs__Slave 19A, DI3)) | UINT32 | RO | 0xF600:94, 1
1A40:95 | SubIndex 149 | 149. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x95 (Slave 19 Inputs__Slave 19B, DI0)) | UINT32 | RO | 0xF600:95, 1
1A40:96 | SubIndex 150 | 150. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x96 (Slave 19 Inputs__Slave 19B, DI1)) | UINT32 | RO | 0xF600:96, 1
1A40:97 | SubIndex 151 | 151. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x97 (Slave 19 Inputs__Slave 19B, DI2)) | UINT32 | RO | 0xF600:97, 1
1A40:98 | SubIndex 152 | 152. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x98 (Slave 19 Inputs__Slave 19B, DI3)) | UINT32 | RO | 0xF600:98, 1
1A40:99 | SubIndex 153 | 153. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x99 (Slave 20 Inputs__Slave 20A, DI0)) | UINT32 | RO | 0xF600:99, 1
1A40:9A | SubIndex 154 | 154. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9A (Slave 20 Inputs__Slave 20A, DI1)) | UINT32 | RO | 0xF600:9A, 1
1A40:9B | SubIndex 155 | 155. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9B (Slave 20 Inputs__Slave 20A, DI2)) | UINT32 | RO | 0xF600:9B, 1
1A40:9C | SubIndex 156 | 156. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9C (Slave 20 Inputs__Slave 20A, DI3)) | UINT32 | RO | 0xF600:9C, 1
1A40:9D | SubIndex 157 | 157. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9D (Slave 20 Inputs__Slave 20B, DI0)) | UINT32 | RO | 0xF600:9D, 1
1A40:9E | SubIndex 158 | 158. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9E (Slave 20 Inputs__Slave 20B, DI1)) | UINT32 | RO | 0xF600:9E, 1
1A40:9F | SubIndex 159 | 159. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0x9F (Slave 20 Inputs__Slave 20B, DI2)) | UINT32 | RO | 0xF600:9F, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:A0 | SubIndex 160 | 160. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA0 (Slave 20 Inputs__Slave 20B, DI3)) | UINT32 | RO | 0xF600:A0, 1
1A40:A1 | SubIndex 161 | 161. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA1 (Slave 21 Inputs__Slave 21A, DI0)) | UINT32 | RO | 0xF600:A1, 1
1A40:A2 | SubIndex 162 | 162. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA2 (Slave 21 Inputs__Slave 21A, DI1)) | UINT32 | RO | 0xF600:A2, 1
1A40:A3 | SubIndex 163 | 163. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA3 (Slave 21 Inputs__Slave 21A, DI2)) | UINT32 | RO | 0xF600:A3, 1
1A40:A4 | SubIndex 164 | 164. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA4 (Slave 21 Inputs__Slave 21A, DI3)) | UINT32 | RO | 0xF600:A4, 1
1A40:A5 | SubIndex 165 | 165. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA5 (Slave 21 Inputs__Slave 21B, DI0)) | UINT32 | RO | 0xF600:A5, 1
1A40:A6 | SubIndex 166 | 166. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA6 (Slave 21 Inputs__Slave 21B, DI1)) | UINT32 | RO | 0xF600:A6, 1
1A40:A7 | SubIndex 167 | 167. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA7 (Slave 21 Inputs__Slave 21B, DI2)) | UINT32 | RO | 0xF600:A7, 1
1A40:A8 | SubIndex 168 | 168. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA8 (Slave 21 Inputs__Slave 21B, DI3)) | UINT32 | RO | 0xF600:A8, 1
1A40:A9 | SubIndex 169 | 169. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xA9 (Slave 22 Inputs__Slave 22A, DI0)) | UINT32 | RO | 0xF600:A9, 1
1A40:AA | SubIndex 170 | 170. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAA (Slave 22 Inputs__Slave 22A, DI1)) | UINT32 | RO | 0xF600:AA, 1
1A40:AB | SubIndex 171 | 171. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAB (Slave 22 Inputs__Slave 22A, DI2)) | UINT32 | RO | 0xF600:AB, 1
1A40:AC | SubIndex 172 | 172. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAC (Slave 22 Inputs__Slave 22A, DI3)) | UINT32 | RO | 0xF600:AC, 1
1A40:AD | SubIndex 173 | 173. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAD (Slave 22 Inputs__Slave 22B, DI0)) | UINT32 | RO | 0xF600:AD, 1
1A40:AE | SubIndex 174 | 174. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAE (Slave 22 Inputs__Slave 22B, DI1)) | UINT32 | RO | 0xF600:AE, 1
1A40:AF | SubIndex 175 | 175. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xAF (Slave 22 Inputs__Slave 22B, DI2)) | UINT32 | RO | 0xF600:AF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:B0 | SubIndex 176 | 176. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB0 (Slave 22 Inputs__Slave 22B, DI3)) | UINT32 | RO | 0xF600:B0, 1
1A40:B1 | SubIndex 177 | 177. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB1 (Slave 23 Inputs__Slave 23A, DI0)) | UINT32 | RO | 0xF600:B1, 1
1A40:B2 | SubIndex 178 | 178. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB2 (Slave 23 Inputs__Slave 23A, DI1)) | UINT32 | RO | 0xF600:B2, 1
1A40:B3 | SubIndex 179 | 179. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB3 (Slave 23 Inputs__Slave 23A, DI2)) | UINT32 | RO | 0xF600:B3, 1
1A40:B4 | SubIndex 180 | 180. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB4 (Slave 23 Inputs__Slave 23A, DI3)) | UINT32 | RO | 0xF600:B4, 1
1A40:B5 | SubIndex 181 | 181. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB5 (Slave 23 Inputs__Slave 23B, DI0)) | UINT32 | RO | 0xF600:B5, 1
1A40:B6 | SubIndex 182 | 182. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB6 (Slave 23 Inputs__Slave 23B, DI1)) | UINT32 | RO | 0xF600:B6, 1
1A40:B7 | SubIndex 183 | 183. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB7 (Slave 23 Inputs__Slave 23B, DI2)) | UINT32 | RO | 0xF600:B7, 1
1A40:B8 | SubIndex 184 | 184. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB8 (Slave 23 Inputs__Slave 23B, DI3)) | UINT32 | RO | 0xF600:B8, 1
1A40:B9 | SubIndex 185 | 185. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xB9 (Slave 24 Inputs__Slave 24A, DI0)) | UINT32 | RO | 0xF600:B9, 1
1A40:BA | SubIndex 186 | 186. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBA (Slave 24 Inputs__Slave 24A, DI1)) | UINT32 | RO | 0xF600:BA, 1
1A40:BB | SubIndex 187 | 187. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBB (Slave 24 Inputs__Slave 24A, DI2)) | UINT32 | RO | 0xF600:BB, 1
1A40:BC | SubIndex 188 | 188. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBC (Slave 24 Inputs__Slave 24A, DI3)) | UINT32 | RO | 0xF600:BC, 1
1A40:BD | SubIndex 189 | 189. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBD (Slave 24 Inputs__Slave 24B, DI0)) | UINT32 | RO | 0xF600:BD, 1
1A40:BE | SubIndex 190 | 190. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBE (Slave 24 Inputs__Slave 24B, DI1)) | UINT32 | RO | 0xF600:BE, 1
1A40:BF | SubIndex 191 | 191. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xBF (Slave 24 Inputs__Slave 24B, DI2)) | UINT32 | RO | 0xF600:BF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:C0 | SubIndex 192 | 192. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC0 (Slave 24 Inputs__Slave 24B, DI3)) | UINT32 | RO | 0xF600:C0, 1
1A40:C1 | SubIndex 193 | 193. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC1 (Slave 25 Inputs__Slave 25A, DI0)) | UINT32 | RO | 0xF600:C1, 1
1A40:C2 | SubIndex 194 | 194. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC2 (Slave 25 Inputs__Slave 25A, DI1)) | UINT32 | RO | 0xF600:C2, 1
1A40:C3 | SubIndex 195 | 195. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC3 (Slave 25 Inputs__Slave 25A, DI2)) | UINT32 | RO | 0xF600:C3, 1
1A40:C4 | SubIndex 196 | 196. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC4 (Slave 25 Inputs__Slave 25A, DI3)) | UINT32 | RO | 0xF600:C4, 1
1A40:C5 | SubIndex 197 | 197. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC5 (Slave 25 Inputs__Slave 25B, DI0)) | UINT32 | RO | 0xF600:C5, 1
1A40:C6 | SubIndex 198 | 198. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC6 (Slave 25 Inputs__Slave 25B, DI1)) | UINT32 | RO | 0xF600:C6, 1
1A40:C7 | SubIndex 199 | 199. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC7 (Slave 25 Inputs__Slave 25B, DI2)) | UINT32 | RO | 0xF600:C7, 1
1A40:C8 | SubIndex 200 | 200. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC8 (Slave 25 Inputs__Slave 25B, DI3)) | UINT32 | RO | 0xF600:C8, 1
1A40:C9 | SubIndex 201 | 201. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xC9 (Slave 26 Inputs__Slave 26A, DI0)) | UINT32 | RO | 0xF600:C9, 1
1A40:CA | SubIndex 202 | 202. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCA (Slave 26 Inputs__Slave 26A, DI1)) | UINT32 | RO | 0xF600:CA, 1
1A40:CB | SubIndex 203 | 203. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCB (Slave 26 Inputs__Slave 26A, DI2)) | UINT32 | RO | 0xF600:CB, 1
1A40:CC | SubIndex 204 | 204. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCC (Slave 26 Inputs__Slave 26A, DI3)) | UINT32 | RO | 0xF600:CC, 1
1A40:CD | SubIndex 205 | 205. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCD (Slave 26 Inputs__Slave 26B, DI0)) | UINT32 | RO | 0xF600:CD, 1
1A40:CE | SubIndex 206 | 206. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCE (Slave 26 Inputs__Slave 26B, DI1)) | UINT32 | RO | 0xF600:CE, 1
1A40:CF | SubIndex 207 | 207. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xCF (Slave 26 Inputs__Slave 26B, DI2)) | UINT32 | RO | 0xF600:CF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:D0 | SubIndex 208 | 208. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD0 (Slave 26 Inputs__Slave 26B, DI3)) | UINT32 | RO | 0xF600:D0, 1
1A40:D1 | SubIndex 209 | 209. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD1 (Slave 27 Inputs__Slave 27A, DI0)) | UINT32 | RO | 0xF600:D1, 1
1A40:D2 | SubIndex 210 | 210. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD2 (Slave 27 Inputs__Slave 27A, DI1)) | UINT32 | RO | 0xF600:D2, 1
1A40:D3 | SubIndex 211 | 211. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD3 (Slave 27 Inputs__Slave 27A, DI2)) | UINT32 | RO | 0xF600:D3, 1
1A40:D4 | SubIndex 212 | 212. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD4 (Slave 27 Inputs__Slave 27A, DI3)) | UINT32 | RO | 0xF600:D4, 1
1A40:D5 | SubIndex 213 | 213. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD5 (Slave 27 Inputs__Slave 27B, DI0)) | UINT32 | RO | 0xF600:D5, 1
1A40:D6 | SubIndex 214 | 214. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD6 (Slave 27 Inputs__Slave 27B, DI1)) | UINT32 | RO | 0xF600:D6, 1
1A40:D7 | SubIndex 215 | 215. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD7 (Slave 27 Inputs__Slave 27B, DI2)) | UINT32 | RO | 0xF600:D7, 1
1A40:D8 | SubIndex 216 | 216. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD8 (Slave 27 Inputs__Slave 27B, DI3)) | UINT32 | RO | 0xF600:D8, 1
1A40:D9 | SubIndex 217 | 217. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xD9 (Slave 28 Inputs__Slave 28A, DI0)) | UINT32 | RO | 0xF600:D9, 1
1A40:DA | SubIndex 218 | 218. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDA (Slave 28 Inputs__Slave 28A, DI1)) | UINT32 | RO | 0xF600:DA, 1
1A40:DB | SubIndex 219 | 219. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDB (Slave 28 Inputs__Slave 28A, DI2)) | UINT32 | RO | 0xF600:DB, 1
1A40:DC | SubIndex 220 | 220. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDC (Slave 28 Inputs__Slave 28A, DI3)) | UINT32 | RO | 0xF600:DC, 1
1A40:DD | SubIndex 221 | 221. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDD (Slave 28 Inputs__Slave 28B, DI0)) | UINT32 | RO | 0xF600:DD, 1
1A40:DE | SubIndex 222 | 222. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDE (Slave 28 Inputs__Slave 28B, DI1)) | UINT32 | RO | 0xF600:DE, 1
1A40:DF | SubIndex 223 | 223. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xDF (Slave 28 Inputs__Slave 28B, DI2)) | UINT32 | RO | 0xF600:DF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:E0 | SubIndex 224 | 224. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE0 (Slave 28 Inputs__Slave 28B, DI3)) | UINT32 | RO | 0xF600:E0, 1
1A40:E1 | SubIndex 225 | 225. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE1 (Slave 29 Inputs__Slave 29A, DI0)) | UINT32 | RO | 0xF600:E1, 1
1A40:E2 | SubIndex 226 | 226. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE2 (Slave 29 Inputs__Slave 29A, DI1)) | UINT32 | RO | 0xF600:E2, 1
1A40:E3 | SubIndex 227 | 227. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE3 (Slave 29 Inputs__Slave 29A, DI2)) | UINT32 | RO | 0xF600:E3, 1
1A40:E4 | SubIndex 228 | 228. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE4 (Slave 29 Inputs__Slave 29A, DI3)) | UINT32 | RO | 0xF600:E4, 1
1A40:E5 | SubIndex 229 | 229. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE5 (Slave 29 Inputs__Slave 29B, DI0)) | UINT32 | RO | 0xF600:E5, 1
1A40:E6 | SubIndex 230 | 230. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE6 (Slave 29 Inputs__Slave 29B, DI1)) | UINT32 | RO | 0xF600:E6, 1
1A40:E7 | SubIndex 231 | 231. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE7 (Slave 29 Inputs__Slave 29B, DI2)) | UINT32 | RO | 0xF600:E7, 1
1A40:E8 | SubIndex 232 | 232. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE8 (Slave 29 Inputs__Slave 29B, DI3)) | UINT32 | RO | 0xF600:E8, 1
1A40:E9 | SubIndex 233 | 233. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xE9 (Slave 30 Inputs__Slave 30A, DI0)) | UINT32 | RO | 0xF600:E9, 1
1A40:EA | SubIndex 234 | 234. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEA (Slave 30 Inputs__Slave 30A, DI1)) | UINT32 | RO | 0xF600:EA, 1
1A40:EB | SubIndex 235 | 235. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEB (Slave 30 Inputs__Slave 30A, DI2)) | UINT32 | RO | 0xF600:EB, 1
1A40:EC | SubIndex 236 | 236. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEC (Slave 30 Inputs__Slave 30A, DI3)) | UINT32 | RO | 0xF600:EC, 1
1A40:ED | SubIndex 237 | 237. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xED (Slave 30 Inputs__Slave 30B, DI0)) | UINT32 | RO | 0xF600:ED, 1
1A40:EE | SubIndex 238 | 238. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEE (Slave 30 Inputs__Slave 30B, DI1)) | UINT32 | RO | 0xF600:EE, 1
1A40:EF | SubIndex 239 | 239. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xEF (Slave 30 Inputs__Slave 30B, DI2)) | UINT32 | RO | 0xF600:EF, 1
Index 1A40 ASI TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A40:F0 | SubIndex 240 | 240. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF0 (Slave 30 Inputs__Slave 30B, DI3)) | UINT32 | RO | 0xF600:F0, 1
1A40:F1 | SubIndex 241 | 241. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF1 (Slave 31 Inputs__Slave 31A, DI0)) | UINT32 | RO | 0xF600:F1, 1
1A40:F2 | SubIndex 242 | 242. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF2 (Slave 31 Inputs__Slave 31A, DI1)) | UINT32 | RO | 0xF600:F2, 1
1A40:F3 | SubIndex 243 | 243. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF3 (Slave 31 Inputs__Slave 31A, DI2)) | UINT32 | RO | 0xF600:F3, 1
1A40:F4 | SubIndex 244 | 244. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF4 (Slave 31 Inputs__Slave 31A, DI3)) | UINT32 | RO | 0xF600:F4, 1
1A40:F5 | SubIndex 245 | 245. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF5 (Slave 31 Inputs__Slave 31B, DI0)) | UINT32 | RO | 0xF600:F5, 1
1A40:F6 | SubIndex 246 | 246. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF6 (Slave 31 Inputs__Slave 31B, DI1)) | UINT32 | RO | 0xF600:F6, 1
1A40:F7 | SubIndex 247 | 247. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF7 (Slave 31 Inputs__Slave 31B, DI2)) | UINT32 | RO | 0xF600:F7, 1
1A40:F8 | SubIndex 248 | 248. PDO Mapping entry (object 0xF600 (ASI Digital Inputs), entry 0xF8 (Slave 31 Inputs__Slave 31B, DI3)) | UINT32 | RO | 0xF600:F8, 1
Index 1A80 ASI TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A80:0 | ASI TxPDO-Map Status | PDO Mapping TxPDO 129 | UINT8 | RO | 0x0D (13dez)
1A80:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x01 (Configuration okay)) | UINT32 | RO | 0xF100:01, 1
1A80:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x02 (Power Fail)) | UINT32 | RO | 0xF100:02, 1
1A80:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x03 (Auto addresing mode enabled)) | UINT32 | RO | 0xF100:03, 1
1A80:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x04 (Auto addressing mode available)) | UINT32 | RO | 0xF100:04, 1
1A80:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x05 (Protected mode active)) | UINT32 | RO | 0xF100:05, 1
1A80:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x06 (Slave with address 0 found)) | UINT32 | RO | 0xF100:06, 1
1A80:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x07 (Offline Ready)) | UINT32 | RO | 0xF100:07, 1
1A80:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x08 (Normal Operation)) | UINT32 | RO | 0xF100:08, 1
1A80:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x09 (ASI phase)) | UINT32 | RO | 0xF100:09, 3
1A80:0A | SubIndex 010 | 10. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A80:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x0E (Sync error)) | UINT32 | RO | 0xF100:0E, 1
1A80:0C | SubIndex 012 | 12. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A80:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF100 (ASI Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF100:10, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A81:0 | ASI TxPDO-Map LDS | PDO Mapping TxPDO 130 | UINT8 | RO | 0x40 (64dez)
1A81:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x01 (Slave 0)) | UINT32 | RO | 0xF101:01, 1
1A81:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x02 (Slave 1A)) | UINT32 | RO | 0xF101:02, 1
1A81:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x03 (Slave 2A)) | UINT32 | RO | 0xF101:03, 1
1A81:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x04 (Slave 3A)) | UINT32 | RO | 0xF101:04, 1
1A81:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x05 (Slave 4A)) | UINT32 | RO | 0xF101:05, 1
1A81:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x06 (Slave 5A)) | UINT32 | RO | 0xF101:06, 1
1A81:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x07 (Slave 6A)) | UINT32 | RO | 0xF101:07, 1
1A81:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x08 (Slave 7A)) | UINT32 | RO | 0xF101:08, 1
1A81:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x09 (Slave 8A)) | UINT32 | RO | 0xF101:09, 1
1A81:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0A (Slave 9A)) | UINT32 | RO | 0xF101:0A, 1
1A81:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0B (Slave 10A)) | UINT32 | RO | 0xF101:0B, 1
1A81:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0C (Slave 11A)) | UINT32 | RO | 0xF101:0C, 1
1A81:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0D (Slave 12A)) | UINT32 | RO | 0xF101:0D, 1
1A81:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0E (Slave 13A)) | UINT32 | RO | 0xF101:0E, 1
1A81:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x0F (Slave 14A)) | UINT32 | RO | 0xF101:0F, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A81:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x10 (Slave 15A)) | UINT32 | RO | 0xF101:10, 1
1A81:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x11 (Slave 16A)) | UINT32 | RO | 0xF101:11, 1
1A81:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x12 (Slave 17A)) | UINT32 | RO | 0xF101:12, 1
1A81:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x13 (Slave 18A)) | UINT32 | RO | 0xF101:13, 1
1A81:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x14 (Slave 19A)) | UINT32 | RO | 0xF101:14, 1
1A81:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x15 (Slave 20A)) | UINT32 | RO | 0xF101:15, 1
1A81:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x16 (Slave 21A)) | UINT32 | RO | 0xF101:16, 1
1A81:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x17 (Slave 22A)) | UINT32 | RO | 0xF101:17, 1
1A81:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x18 (Slave 23A)) | UINT32 | RO | 0xF101:18, 1
1A81:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x19 (Slave 24A)) | UINT32 | RO | 0xF101:19, 1
1A81:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1A (Slave 25A)) | UINT32 | RO | 0xF101:1A, 1
1A81:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1B (Slave 26A)) | UINT32 | RO | 0xF101:1B, 1
1A81:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1C (Slave 27A)) | UINT32 | RO | 0xF101:1C, 1
1A81:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1D (Slave 28A)) | UINT32 | RO | 0xF101:1D, 1
1A81:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1E (Slave 29A)) | UINT32 | RO | 0xF101:1E, 1
1A81:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x1F (Slave 30A)) | UINT32 | RO | 0xF101:1F, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A81:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x20 (Slave 31A)) | UINT32 | RO | 0xF101:20, 1
1A81:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x21 (Slave 1B)) | UINT32 | RO | 0xF101:21, 1
1A81:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x22 (Slave 2B)) | UINT32 | RO | 0xF101:22, 1
1A81:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x23 (Slave 3B)) | UINT32 | RO | 0xF101:23, 1
1A81:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x24 (Slave 4B)) | UINT32 | RO | 0xF101:24, 1
1A81:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x25 (Slave 5B)) | UINT32 | RO | 0xF101:25, 1
1A81:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x26 (Slave 6B)) | UINT32 | RO | 0xF101:26, 1
1A81:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x27 (Slave 7B)) | UINT32 | RO | 0xF101:27, 1
1A81:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x28 (Slave 8B)) | UINT32 | RO | 0xF101:28, 1
1A81:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x29 (Slave 9B)) | UINT32 | RO | 0xF101:29, 1
1A81:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2A (Slave 10B)) | UINT32 | RO | 0xF101:2A, 1
1A81:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2B (Slave 11B)) | UINT32 | RO | 0xF101:2B, 1
1A81:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2C (Slave 12B)) | UINT32 | RO | 0xF101:2C, 1
1A81:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2D (Slave 13B)) | UINT32 | RO | 0xF101:2D, 1
1A81:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2E (Slave 14B)) | UINT32 | RO | 0xF101:2E, 1
1A81:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x2F (Slave 15B)) | UINT32 | RO | 0xF101:2F, 1
Index 1A81 ASI TxPDO-Map LDS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A81:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x30 (Slave 16B)) | UINT32 | RO | 0xF101:30, 1
1A81:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x31 (Slave 17B)) | UINT32 | RO | 0xF101:31, 1
1A81:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x32 (Slave 18B)) | UINT32 | RO | 0xF101:32, 1
1A81:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x33 (Slave 19B)) | UINT32 | RO | 0xF101:33, 1
1A81:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x34 (Slave 20B)) | UINT32 | RO | 0xF101:34, 1
1A81:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x35 (Slave 21B)) | UINT32 | RO | 0xF101:35, 1
1A81:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x36 (Slave 22B)) | UINT32 | RO | 0xF101:36, 1
1A81:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x37 (Slave 23B)) | UINT32 | RO | 0xF101:37, 1
1A81:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x38 (Slave 24B)) | UINT32 | RO | 0xF101:38, 1
1A81:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x39 (Slave 25B)) | UINT32 | RO | 0xF101:39, 1
1A81:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3A (Slave 26B)) | UINT32 | RO | 0xF101:3A, 1
1A81:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3B (Slave 27B)) | UINT32 | RO | 0xF101:3B, 1
1A81:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3C (Slave 28B)) | UINT32 | RO | 0xF101:3C, 1
1A81:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3D (Slave 29B)) | UINT32 | RO | 0xF101:3D, 1
1A81:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3E (Slave 30B)) | UINT32 | RO | 0xF101:3E, 1
1A81:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF101 (ASI LDS), entry 0x3F (Slave 31B)) | UINT32 | RO | 0xF101:3F, 1
1A81:40 | SubIndex 064 | 64. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A82:0 | ASI TxPDO-Map LAS | PDO Mapping TxPDO 131 | UINT8 | RO | 0x40 (64dez)
1A82:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x01 (Slave 0)) | UINT32 | RO | 0xF102:01, 1
1A82:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x02 (Slave 1A)) | UINT32 | RO | 0xF102:02, 1
1A82:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x03 (Slave 2A)) | UINT32 | RO | 0xF102:03, 1
1A82:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x04 (Slave 3A)) | UINT32 | RO | 0xF102:04, 1
1A82:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x05 (Slave 4A)) | UINT32 | RO | 0xF102:05, 1
1A82:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x06 (Slave 5A)) | UINT32 | RO | 0xF102:06, 1
1A82:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x07 (Slave 6A)) | UINT32 | RO | 0xF102:07, 1
1A82:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x08 (Slave 7A)) | UINT32 | RO | 0xF102:08, 1
1A82:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x09 (Slave 8A)) | UINT32 | RO | 0xF102:09, 1
1A82:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0A (Slave 9A)) | UINT32 | RO | 0xF102:0A, 1
1A82:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0B (Slave 10A)) | UINT32 | RO | 0xF102:0B, 1
1A82:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0C (Slave 11A)) | UINT32 | RO | 0xF102:0C, 1
1A82:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0D (Slave 12A)) | UINT32 | RO | 0xF102:0D, 1
1A82:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0E (Slave 13A)) | UINT32 | RO | 0xF102:0E, 1
1A82:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x0F (Slave 14A)) | UINT32 | RO | 0xF102:0F, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A82:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x10 (Slave 15A)) | UINT32 | RO | 0xF102:10, 1
1A82:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x11 (Slave 16A)) | UINT32 | RO | 0xF102:11, 1
1A82:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x12 (Slave 17A)) | UINT32 | RO | 0xF102:12, 1
1A82:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x13 (Slave 18A)) | UINT32 | RO | 0xF102:13, 1
1A82:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x14 (Slave 19A)) | UINT32 | RO | 0xF102:14, 1
1A82:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x15 (Slave 20A)) | UINT32 | RO | 0xF102:15, 1
1A82:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x16 (Slave 21A)) | UINT32 | RO | 0xF102:16, 1
1A82:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x17 (Slave 22A)) | UINT32 | RO | 0xF102:17, 1
1A82:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x18 (Slave 23A)) | UINT32 | RO | 0xF102:18, 1
1A82:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x19 (Slave 24A)) | UINT32 | RO | 0xF102:19, 1
1A82:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1A (Slave 25A)) | UINT32 | RO | 0xF102:1A, 1
1A82:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1B (Slave 26A)) | UINT32 | RO | 0xF102:1B, 1
1A82:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1C (Slave 27A)) | UINT32 | RO | 0xF102:1C, 1
1A82:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1D (Slave 28A)) | UINT32 | RO | 0xF102:1D, 1
1A82:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1E (Slave 29A)) | UINT32 | RO | 0xF102:1E, 1
1A82:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x1F (Slave 30A)) | UINT32 | RO | 0xF102:1F, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A82:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x20 (Slave 31A)) | UINT32 | RO | 0xF102:20, 1
1A82:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x21 (Slave 1B)) | UINT32 | RO | 0xF102:21, 1
1A82:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x22 (Slave 2B)) | UINT32 | RO | 0xF102:22, 1
1A82:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x23 (Slave 3B)) | UINT32 | RO | 0xF102:23, 1
1A82:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x24 (Slave 4B)) | UINT32 | RO | 0xF102:24, 1
1A82:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x25 (Slave 5B)) | UINT32 | RO | 0xF102:25, 1
1A82:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x26 (Slave 6B)) | UINT32 | RO | 0xF102:26, 1
1A82:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x27 (Slave 7B)) | UINT32 | RO | 0xF102:27, 1
1A82:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x28 (Slave 8B)) | UINT32 | RO | 0xF102:28, 1
1A82:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x29 (Slave 9B)) | UINT32 | RO | 0xF102:29, 1
1A82:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2A (Slave 10B)) | UINT32 | RO | 0xF102:2A, 1
1A82:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2B (Slave 11B)) | UINT32 | RO | 0xF102:2B, 1
1A82:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2C (Slave 12B)) | UINT32 | RO | 0xF102:2C, 1
1A82:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2D (Slave 13B)) | UINT32 | RO | 0xF102:2D, 1
1A82:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2E (Slave 14B)) | UINT32 | RO | 0xF102:2E, 1
1A82:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x2F (Slave 15B)) | UINT32 | RO | 0xF102:2F, 1
Index 1A82 ASI TxPDO-Map LAS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A82:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x30 (Slave 16B)) | UINT32 | RO | 0xF102:30, 1
1A82:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x31 (Slave 17B)) | UINT32 | RO | 0xF102:31, 1
1A82:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x32 (Slave 18B)) | UINT32 | RO | 0xF102:32, 1
1A82:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x33 (Slave 19B)) | UINT32 | RO | 0xF102:33, 1
1A82:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x34 (Slave 20B)) | UINT32 | RO | 0xF102:34, 1
1A82:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x35 (Slave 21B)) | UINT32 | RO | 0xF102:35, 1
1A82:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x36 (Slave 22B)) | UINT32 | RO | 0xF102:36, 1
1A82:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x37 (Slave 23B)) | UINT32 | RO | 0xF102:37, 1
1A82:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x38 (Slave 24B)) | UINT32 | RO | 0xF102:38, 1
1A82:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x39 (Slave 25B)) | UINT32 | RO | 0xF102:39, 1
1A82:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3A (Slave 26B)) | UINT32 | RO | 0xF102:3A, 1
1A82:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3B (Slave 27B)) | UINT32 | RO | 0xF102:3B, 1
1A82:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3C (Slave 28B)) | UINT32 | RO | 0xF102:3C, 1
1A82:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3D (Slave 29B)) | UINT32 | RO | 0xF102:3D, 1
1A82:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3E (Slave 30B)) | UINT32 | RO | 0xF102:3E, 1
1A82:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF102 (ASI LAS), entry 0x3F (Slave 31B)) | UINT32 | RO | 0xF102:3F, 1
1A82:40 | SubIndex 064 | 64. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A83:0 | ASI TxPDO-Map LPS | PDO Mapping TxPDO 132 | UINT8 | RO | 0x40 (64dez)
1A83:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x01 (Slave 0)) | UINT32 | RO | 0xF103:01, 1
1A83:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x02 (Slave 1A)) | UINT32 | RO | 0xF103:02, 1
1A83:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x03 (Slave 2A)) | UINT32 | RO | 0xF103:03, 1
1A83:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x04 (Slave 3A)) | UINT32 | RO | 0xF103:04, 1
1A83:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x05 (Slave 4A)) | UINT32 | RO | 0xF103:05, 1
1A83:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x06 (Slave 5A)) | UINT32 | RO | 0xF103:06, 1
1A83:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x07 (Slave 6A)) | UINT32 | RO | 0xF103:07, 1
1A83:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x08 (Slave 7A)) | UINT32 | RO | 0xF103:08, 1
1A83:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x09 (Slave 8A)) | UINT32 | RO | 0xF103:09, 1
1A83:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0A (Slave 9A)) | UINT32 | RO | 0xF103:0A, 1
1A83:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0B (Slave 10A)) | UINT32 | RO | 0xF103:0B, 1
1A83:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0C (Slave 11A)) | UINT32 | RO | 0xF103:0C, 1
1A83:0D | SubIndex 013 | 13. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0D (Slave 12A)) | UINT32 | RO | 0xF103:0D, 1
1A83:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0E (Slave 13A)) | UINT32 | RO | 0xF103:0E, 1
1A83:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x0F (Slave 14A)) | UINT32 | RO | 0xF103:0F, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A83:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x10 (Slave 15A)) | UINT32 | RO | 0xF103:10, 1
1A83:11 | SubIndex 017 | 17. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x11 (Slave 16A)) | UINT32 | RO | 0xF103:11, 1
1A83:12 | SubIndex 018 | 18. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x12 (Slave 17A)) | UINT32 | RO | 0xF103:12, 1
1A83:13 | SubIndex 019 | 19. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x13 (Slave 18A)) | UINT32 | RO | 0xF103:13, 1
1A83:14 | SubIndex 020 | 20. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x14 (Slave 19A)) | UINT32 | RO | 0xF103:14, 1
1A83:15 | SubIndex 021 | 21. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x15 (Slave 20A)) | UINT32 | RO | 0xF103:15, 1
1A83:16 | SubIndex 022 | 22. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x16 (Slave 21A)) | UINT32 | RO | 0xF103:16, 1
1A83:17 | SubIndex 023 | 23. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x17 (Slave 22A)) | UINT32 | RO | 0xF103:17, 1
1A83:18 | SubIndex 024 | 24. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x18 (Slave 23A)) | UINT32 | RO | 0xF103:18, 1
1A83:19 | SubIndex 025 | 25. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x19 (Slave 24A)) | UINT32 | RO | 0xF103:19, 1
1A83:1A | SubIndex 026 | 26. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1A (Slave 25A)) | UINT32 | RO | 0xF103:1A, 1
1A83:1B | SubIndex 027 | 27. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1B (Slave 26A)) | UINT32 | RO | 0xF103:1B, 1
1A83:1C | SubIndex 028 | 28. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1C (Slave 27A)) | UINT32 | RO | 0xF103:1C, 1
1A83:1D | SubIndex 029 | 29. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1D (Slave 28A)) | UINT32 | RO | 0xF103:1D, 1
1A83:1E | SubIndex 030 | 30. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1E (Slave 29A)) | UINT32 | RO | 0xF103:1E, 1
1A83:1F | SubIndex 031 | 31. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x1F (Slave 30A)) | UINT32 | RO | 0xF103:1F, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A83:20 | SubIndex 032 | 32. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x20 (Slave 31A)) | UINT32 | RO | 0xF103:20, 1
1A83:21 | SubIndex 033 | 33. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x21 (Slave 1B)) | UINT32 | RO | 0xF103:21, 1
1A83:22 | SubIndex 034 | 34. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x22 (Slave 2B)) | UINT32 | RO | 0xF103:22, 1
1A83:23 | SubIndex 035 | 35. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x23 (Slave 3B)) | UINT32 | RO | 0xF103:23, 1
1A83:24 | SubIndex 036 | 36. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x24 (Slave 4B)) | UINT32 | RO | 0xF103:24, 1
1A83:25 | SubIndex 037 | 37. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x25 (Slave 5B)) | UINT32 | RO | 0xF103:25, 1
1A83:26 | SubIndex 038 | 38. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x26 (Slave 6B)) | UINT32 | RO | 0xF103:26, 1
1A83:27 | SubIndex 039 | 39. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x27 (Slave 7B)) | UINT32 | RO | 0xF103:27, 1
1A83:28 | SubIndex 040 | 40. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x28 (Slave 8B)) | UINT32 | RO | 0xF103:28, 1
1A83:29 | SubIndex 041 | 41. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x29 (Slave 9B)) | UINT32 | RO | 0xF103:29, 1
1A83:2A | SubIndex 042 | 42. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2A (Slave 10B)) | UINT32 | RO | 0xF103:2A, 1
1A83:2B | SubIndex 043 | 43. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2B (Slave 11B)) | UINT32 | RO | 0xF103:2B, 1
1A83:2C | SubIndex 044 | 44. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2C (Slave 12B)) | UINT32 | RO | 0xF103:2C, 1
1A83:2D | SubIndex 045 | 45. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2D (Slave 13B)) | UINT32 | RO | 0xF103:2D, 1
1A83:2E | SubIndex 046 | 46. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2E (Slave 14B)) | UINT32 | RO | 0xF103:2E, 1
1A83:2F | SubIndex 047 | 47. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x2F (Slave 15B)) | UINT32 | RO | 0xF103:2F, 1
Index 1A83 ASI TxPDO-Map LPS
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A83:30 | SubIndex 048 | 48. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x30 (Slave 16B)) | UINT32 | RO | 0xF103:30, 1
1A83:31 | SubIndex 049 | 49. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x31 (Slave 17B)) | UINT32 | RO | 0xF103:31, 1
1A83:32 | SubIndex 050 | 50. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x32 (Slave 18B)) | UINT32 | RO | 0xF103:32, 1
1A83:33 | SubIndex 051 | 51. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x33 (Slave 19B)) | UINT32 | RO | 0xF103:33, 1
1A83:34 | SubIndex 052 | 52. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x34 (Slave 20B)) | UINT32 | RO | 0xF103:34, 1
1A83:35 | SubIndex 053 | 53. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x35 (Slave 21B)) | UINT32 | RO | 0xF103:35, 1
1A83:36 | SubIndex 054 | 54. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x36 (Slave 22B)) | UINT32 | RO | 0xF103:36, 1
1A83:37 | SubIndex 055 | 55. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x37 (Slave 23B)) | UINT32 | RO | 0xF103:37, 1
1A83:38 | SubIndex 056 | 56. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x38 (Slave 24B)) | UINT32 | RO | 0xF103:38, 1
1A83:39 | SubIndex 057 | 57. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x39 (Slave 25B)) | UINT32 | RO | 0xF103:39, 1
1A83:3A | SubIndex 058 | 58. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3A (Slave 26B)) | UINT32 | RO | 0xF103:3A, 1
1A83:3B | SubIndex 059 | 59. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3B (Slave 27B)) | UINT32 | RO | 0xF103:3B, 1
1A83:3C | SubIndex 060 | 60. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3C (Slave 28B)) | UINT32 | RO | 0xF103:3C, 1
1A83:3D | SubIndex 061 | 61. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3D (Slave 29B)) | UINT32 | RO | 0xF103:3D, 1
1A83:3E | SubIndex 062 | 62. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3E (Slave 30B)) | UINT32 | RO | 0xF103:3E, 1
1A83:3F | SubIndex 063 | 63. PDO Mapping entry (object 0xF103 (ASI LPS), entry 0x3F (Slave 31B)) | UINT32 | RO | 0xF103:3F, 1
1A83:40 | SubIndex 064 | 64. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
Index 1C00Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1640 (5696dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1680 (5760dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:05 | SubIndex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:06 | SubIndex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:07 | SubIndex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:08 | SubIndex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:09 | SubIndex 009 | 9. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0A | SubIndex 010 | 10. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0B | SubIndex 011 | 11. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0C | SubIndex 012 | 12. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0D | SubIndex 013 | 13. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0E | SubIndex 014 | 14. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0F | SubIndex 015 | 15. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:10 | SubIndex 016 | 16. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:11 | SubIndex 017 | 17. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:12 | SubIndex 018 | 18. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:13 | SubIndex 019 | 19. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:14 | SubIndex 020 | 20. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:15 | SubIndex 021 | 21. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:16 | SubIndex 022 | 22. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:17 | SubIndex 023 | 23. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:18 | SubIndex 024 | 24. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:19 | SubIndex 025 | 25. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1A | SubIndex 026 | 26. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1B | SubIndex 027 | 27. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1C | SubIndex 028 | 28. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1D | SubIndex 029 | 29. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1E | SubIndex 030 | 30. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1F | SubIndex 031 | 31. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:20 | SubIndex 032 | 32. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:21 | SubIndex 033 | 33. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:22 | SubIndex 034 | 34. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A40 (6720dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A80 (6784dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | SubIndex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | SubIndex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | SubIndex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | SubIndex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | SubIndex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0B | SubIndex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | SubIndex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0D | SubIndex 013 | 13. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0E | SubIndex 014 | 14. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0F | SubIndex 015 | 15. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:10 | SubIndex 016 | 16. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:11 | SubIndex 017 | 17. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:12 | SubIndex 018 | 18. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:13 | SubIndex 019 | 19. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:14 | SubIndex 020 | 20. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:15 | SubIndex 021 | 21. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:16 | SubIndex 022 | 22. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:17 | SubIndex 023 | 23. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:18 | SubIndex 024 | 24. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:19 | SubIndex 025 | 25. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1A | SubIndex 026 | 26. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1B | SubIndex 027 | 27. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1C | SubIndex 028 | 28. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1D | SubIndex 029 | 29. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1E | SubIndex 030 | 30. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1F | SubIndex 031 | 31. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:20 | SubIndex 032 | 32. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:21 | SubIndex 033 | 33. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:22 | SubIndex 034 | 34. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:23 | SubIndex 035 | 35. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:24 | SubIndex 036 | 36. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:25 | SubIndex 037 | 37. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00002710 (10000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00002710 (10000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0020 (32dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | reserviert | UINT8 | RW | 0x20 (32dez)
F010:01 - 20 | SubIndex 001 - 032 | reserviert | UINT32 | RW | 0x00001838 (6200dez)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL6201-0000
Hardware (HW) | Firmware (FW) | Revision Nr. | Release - Datum
01 - 05* | 01 | EL6201-0000-0017 | 2013/01
 | 02 | EL6201-0000-0018 | 2016/01
 | 03* |  | 2019/04
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.