EL5101 - Inkremental-Encoder-Interface
Home


Übersichtseite Inkremental-Enkoder-Interface

Übersichtseite Inkremental-Enkoder-Interface
Übersichtseite Inkremental-Enkoder-Interface
EL5101-0000 (Inkremental-Enkoder-Interface)
EL5101-0010 (Inkremental-Enkoder-Interface, 20 Mio. Inkremente/s)
EL5101-0011 (Inkremental-Enkoder-Interface, mit Oversampling)
EL5101-0090 (Inkremental-Enkoder-Interface, TwinSAFE Single Channel)


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
4.5
▪
Update Kapitel "TwinSAFE SC"
▪
Update Struktur
▪
Korrekturen
▪
Update Revisionstand
4.4
▪
Update Kapitel "Technische Daten"
▪
Update Struktur
▪
Update Revisionstand
4.3
▪
EL5101-0090 ergänzt
▪
Update Struktur
▪
Update Revisionstand
4.2
▪
Update Kapitel „Technologie“
▪
Update Struktur
▪
Update Revisionstand
4.1
▪
EL5101-0011 ergänzt
▪
Update Struktur
▪
Update Revisionstand
4.0
▪
Migration in ST4
▪
Update Struktur
▪
Update Revisionstand
3.7
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
▪
Update Struktur
▪
Update Revisionsstand
3.6
▪
Aktualisierung im Kapitel "Technische Daten"
▪
Update Struktur
▪
Revisionsstand aktualisiert
3.5
▪
Ergänzungen im Kapitel "Prozessdaten"
3.4
▪
Ergänzungen im Kapitel "Prozessdaten"
3.3
▪
Ergänzungen zur EL5101-0010
3.2
▪
Hinweis zum Single-ended-Anschluss eingefügt
3.1
▪
Hinweis zur Frequenz-/Periodenmessung ergänzt
3.0
▪
Objektbeschreibung und weitere Hinweise ergänzt
2.9
▪
EL5101-0010 ergänzt
2.8
▪
Neue Sicherheitshinweise ergänzt
2.7
▪
Technische Daten ergänzt
2.6
▪
Objektbeschreibung und Technische Hinweise ergänzt
2.5
▪
Kompatibilitätshinweis ergänzt
2.4
▪
Objektbeschreibung ergänzt
2.3
▪
Aufteilung Betriebsmodi
2.2
▪
Technische Daten ergänzt, Objektbeschreibung ergänzt
2.1
▪
Technische Daten ergänzt
2.0
▪
Technische Daten ergänzt, Objektbeschreibung ergänzt
1.1.1
▪
Technische Daten korrigiert
1.1
▪
Korrektur des Hinweises für die "Non-Volatile Settings"
1.0
▪
Erweiterte Beschreibung für Status-LEDs hinzugefügt
0.1
▪
Erste vorläufige Vorabdokumentation für EL5101


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
Aufbau des BICs
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technologie
•
Technische Daten
•
Start


Einführung

Produktübersicht [image] Einführung
Einführung
Interface-Klemme für Inkremental-Encoder
EL5101-00x0
EL5101
Die EtherCAT-Klemme EL5101-00x0 ist ein Interface zum direkten Anschluss von Inkremental-Encodern mit Differenzeingängen (RS422). Ein 16-Bit-Zähler (im normalen Betriebsmodus verfügbar) oder ein umschaltbarer 16/32-Bit-Zähler (im erweiterten Betriebsmodus verfügbar mit Quadraturdecoder sowie ein 16-Bit-Latch (normaler Betriebsmodus) oder 32-Bit-Latch (erweiterter Betriebsmodus) für einen Nullimpuls können gelesen, gesetzt oder aktiviert werden. An den negativ schaltenden Statuseingang des Interfaces sind Inkremental-Encoder mit Störmeldeausgang anschließbar. Eine Periodendauer- und Frequenzmessung ist möglich. Der Gate-Eingang erlaubt das Sperren des Zählers wahlweise mit hohem oder niedrigem Pegel. Der Latch-Eingang ist ebenfalls konfigurierbar und wertet hohen oder niedrigen Pegel aus. Die EL5101-0000 ist auch als bidirektionaler Zähler auf Kanal A verwendbar, Kanal B gibt die Zählrichtung vor.
Durch die Weiterentwicklung der EL5101-0000 ist ein erweiterter Betriebsmodus (ab Firmware 14 / Hardware 09) verfügbar, der in Abhängigkeit der vorliegenden Hardware im TwinCAT System Manager parametriert werden kann.
Eine EL5101-0000 in älterer Ausführung unterstützt diesen erweiterten Betriebsmodus nicht (siehe folgende Tabelle)!
Betriebsmodi der EL5101-0000
Version | ab FW/HW | ESI | Funktionsbeschreibung
normaler Betriebsmodus EL5101-0000 | 03/05 | ab EL5101-0000-0000 | alle Basisfunktionen wie oben beschrieben
erweiterter Betriebsmodus EL5101-0000 | 14/09 | ab EL5101-0000-1018 | Änderungen zum normalen Betriebsmodus - Unterstützung Distributed Clocks - Mikroinkremente - Drahtbrucherkennung - Anschluss SingleEnded Signale möglich
Die EL5101-0010 mit einer Auflösung von 20 Mio. Inkrementen/s bei 5 MHz und 4-fach Auswertung ist nur im erweiterten Betriebsmodus einsetzbar und kann am Geberanschluss differentielle Signale nach RS422 verarbeiten. Der Mikroinkremente-Modus ist bei der EL5101-0010 nicht verfügbar.
Die EL5101-00x0 unterstützt im erweiterten Betriebsmodus die Distributed Clocks, d. h. die Eingangsdaten können synchron mit anderen Daten erfasst werden, die ebenfalls verteilt an Distributed Clock Slaves angeschlossen sind. Die systemweite Genauigkeit liegt bei < 100 ns.
Die Dokumentation trennt sich im Kapitel „Inbetriebnahme“ in die Behandlung der beiden Betriebsmodi auf, weshalb bei Inbetriebnahme zu entscheiden ist, welcher Betriebsmodus verwendet werden soll.
EL5101-0011
EL5101-0011
Die EtherCAT Klemme EL5101-0011 ist ebenfalls ein Interface zum direkten Anschluss von Inkremental-Encodern mit Differenzeingängen (RS422). Ein 32 Bit Zähler mit Quadraturdecoder kann gelesen und gesetzt werden. Die EL5101-0011 unterstützt das Oversampling-Prinzip. Die Auflösung des Positionswertes lässt sich mit diesem Verfahren auf das n-fache der Buszykluszeit steigern. Dabei wird zwischen zwei Feldbuskommunikationszyklen, konfigurierbar und zeitäquidistant, mehrmals der aktuelle Zählerstand, mit einem einstellbaren ganzzahligen Vielfachen (Oversampling-Faktor: n) der Buszykluszeit erfasst. Die Übergabe eines Pakets von n Positionswerten von je 32 Bit an die übergeordnete Steuerung findet im nächsten Feldbuskommunikationszyklus statt. Hierbei beträgt die minimale Samplingzeit 10 µs (100 kSps). Anwendungsgebiete der EL5101-0011 liegen insbesondere im Bereich der feinaufgelösten Positionserfassung.
Die EL5101-0011 unterstützt die Distributed Clocks, d. h. die Eingangsdaten können synchron mit anderen Daten erfasst werden, die ebenfalls verteilt an Distributed Slave Clocks angeschlossen sind. Die Systemgenauigkeit liegt bei < 100 ns.
EL5101-0090
EL5101-0090
Die EL5101-0090 unterstützt neben dem vollen Funktionsumfang der EL5101 zusätzlich die TwinSAFE SC Technologie (TwinSAFE Single Channel). Dadurch ist es möglich, in beliebigen Netzwerken bzw. Feldbussen Standardsignale für sicherheitstechnische Aufgaben nutzbar zu machen.
Quick-Links
▪
Grundlagen der Kommunikation
▪
Konfigurationserstellung TwinCAT
▪
EL5101-00x0 - Prozessdaten, Modi, Objektbeschreibung
▪
EL5101-0011 - Prozessdaten, Modi, Objektbeschreibung
▪
EL5101-0090 - TwinSAFE SC Prozessdaten
▪
LEDs und Anschlussbelegung


Technologie

Produktübersicht [image] Technologie
Technologie
Die Inkremental-Encoder-Interface Klemme EL5101-00x0 ermöglicht den Anschluss von Inkremental-Encodern mit A/B/C-Spur an den Buskoppler bzw. die SPS. Ein 16-Bit-Zähler (im normalen Betriebsmodus verfügbar) oder ein umschaltbarer 16/32-Bit-Zähler (im erweiterten Betriebsmodus verfügbar) mit Quadraturdecoder sowie ein 16-Bit-Latch (normaler Betriebsmodus) oder 32-Bit-Latch (erweiterter Betriebsmodus) können gelesen, gesetzt oder aktiviert werden. Als Geberanschluss sind differentielle Signale nach RS422 vorgesehen, ab Hardware 09 sind bei der EL5101-0000 durch interne PullUp-Widerstände auch Single-Ended-Signale 5 V möglich.
Neben den Gebereingängen A, B, C steht ein zusätzlicher Latch-Eingang G1 (24 V) sowie ein Gate-Eingang G2 (24 V) zum Sperren des Zählers im Zählerbetrieb zur Verfügung.
Geliefert wird die Klemme als 4-fach Quadraturdecoder mit komplementärer Auswertung der Gebersignale A, B, C. Besitzt der Inkremental-Encoder ein Störmelde-Ausgang, so kann dieser an den Status Eingang INPUT 1 der EL5101-00x0 angeschlossen werden. Optional kann die EL5101-0000 als bidirektionale Zählerklemme auf Kanal A betrieben werden.
Durch die Weiterentwicklung der EL5101-0000 ist ein erweiterter Betriebsmodus (ab Firmware 14 / Hardware 09) verfügbar, der in Abhängigkeit der vorliegenden Hardware im TwinCAT System Manager parametriert werden kann.
Eine EL5101-0000 in älterer Ausführung unterstützt diesen erweiterten Betriebsmodus nicht (siehe folgende Tabelle)!
Betriebsmodi der EL5101-0000
Version | ab FW/HW | ESI | Funktionsbeschreibung
normaler Betriebsmodus EL5101-0000 | 03/05 | ab EL5101-0000-0000 | alle Basisfunktionen wie oben beschrieben
erweiterter Betriebsmodus EL5101-0000 | 14/09 | ab EL5101-0000-1018 | Änderungen zum normalen Betriebsmodus - Unterstützung Distributed Clocks - Mikroinkremente - Drahtbrucherkennung - Anschluss SingleEnded Signale möglich
Die EL5101-0010 mit einer Auflösung von 20 Mio. Inkrementen/s bei 5 MHz und 4-fach Auswertung ist nur im erweiterten Betriebsmodus einsetzbar und kann am Geberanschluss differentielle Signale nach RS422 verarbeiten. Der Mikroinkremente-Modus ist bei der EL5101-0010 nicht verfügbar.
Kompatibilität im Servicefall
Eine im erweiterten Betriebsmodus eingesetzte und projektierte EL5101-0000 kann nicht durch eine EL5101-0000 mit älterem Hardwarestand (< 09) ausgetauscht werden! Eine EL5101-0010 unterstützt nur den erweiterten Betriebsmodus und ist ebenfalls nicht austauschkompatibel mit einer EL5101-0000 (Hardwarestand < 09)!
Unabhängig vom Hardware /Firmware -Stand meldet sich eine neu im System integrierte EL5101-0000 im normalen Betriebsmodus.
Bei der Inbetriebnahme ist zu entscheiden, in welchem Funktionsumfang d. h. in welchem Betriebsmodus die EL5101-0000 eingesetzt werden soll. Dies ist von den gewünschten Funktionen und natürlich der vorliegenden Hardware-Ausführung abhängig - eine Hardware vor Firmware 14 / Hardware 09 wird beispielsweise keine Funktionen des erweiterten Betriebsmodus unterstützen.
Eine Kombination von Funktionen aus verschiedenen Betriebsmodi ist nicht möglich.
Spezifische Einstellungen werden in den folgenden beiden Kapiteln beschrieben.
Überwachung der Prozessdaten
•
WcState: wenn ≠ 0, dann nimmt dieser EtherCAT Teilnehmer nicht am Prozessdatenverkehr teil
•
State: wenn ≠ 8, dann ist der EtherCAT Teilnehmer nicht im OP (Operational) Status
•
TxPDO State, SyncError: wenn ≠ 0, dann liegen keine gültigen Prozessdaten vor, z. B. durch Drahtbruch
•
TxPDO Toggle: wenn dieses Bit toggelt, liegt ein neuer Satz Prozessdaten vor
EtherCAT Zykluszeit
Für die EL5101 wird eine minimale EtherCAT-Zykluszeit von >100 µs empfohlen. Wird eine schnellere Zykluszeit verwendet, ist durch das toggelnde Prozessdatum TxPDO Toggle zu überwachen, wann neue Prozessdaten von der EL5101 geliefert werden.
Eingangsimpedanz EL5101
Die Signalquelle muss die Eingangsimpedanz der EL5101 (typ. 220 Ω, Änderungen vorbehalten) mit ausreichenden Spannungspegeln nach RS422 betreiben können.
Gate/Latcheingang
Für Gate- und Latcheingang (24 V) ist eine max. Eingangsfrequenz von 1 MHz zulässig. Änderungen vorbehalten.
Schnittstellenpegel
Die EL5101-00xx erwartet im Differentialmode die Pegel nach RS422. Die Daten werden ohne Massebezug als Spannungsdifferenz zwischen zwei Leitungen (Signal A und invertiertes Signal /A) übertragen. Die Klemme wertet Pegel von -200 mV < Vid < +200 mV als gültige Signale aus. Das Differenzsignal muss im Common Mode Bereich (<+13,2 V und >-10 V, in Bezug zu GND) liegen (vgl. Abbildung), Pegel außerhalb dieses Bereiches können zur Zerstörung führen.
Pegel Schnittstelle
Im Differentialmode wird nur die Spannungsdifferenz ausgewertet, so dass Gleichtaktstörungen auf der Übertragungsstrecke zur keiner Verfälschung des Nutzsignals führen, da diese Störung auf beide Leitungen gleichzeitig wirken.
Wird die EL5101 nur im Single Ended Modus betrieben, wird eine Pegelspannung von nominell 3,5 V bis 5,5 V erwartet.
Die EL5101-0010 und EL5101-0011 unterstützen den Single Ended Modus nicht.
Die Drahtbrucherkennung / Open circuit detection (Index 0x80n0:0B, 0x80n0:0C, 0x80n0:0D) wird in der Version EL5101-0010 und EL5101-0011 im Bereich typ. -0,475 V > Vid > +0,475 V aktiviert. Für die EL5101 wird diese für typ. -1,5 V > Vid > +1,5 V aktiviert (Änderungen vorbehalten).


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EL5101-0000 |  | EL5101-0090 |  | EL5101-0010 | EL5101-0011
Geberanschluss | A, ¬A, B, ¬B, C, ¬C (RS422 Differenzeingänge): auch Single-ended-Anschluss (5 V ±20%) möglich (für EL5101-0000 ab Hardware 09) |  |  |  | A, ¬A, B, ¬B, C, ¬C (RS422 Differenzeingänge)
zusätzliche Eingänge | Gate, Latch (24 VDC, beide max. 1 MHz zulässig), Status-Eingang (max. 5 VDC, potentialfrei, negativ schaltend) |  |  |  |  | -
Geberversorgung | 5 VDC
Geberausgangsstrom | 0,5 A
Zähler | 16 Bit, 16/32 Bit umschaltbar (ab Firmware 14 / Hardware 09) |  | 16 Bit, 16/32 Bit umschaltbar |  |  | 32 Bit
Nullimpuls Latch | 16 Bit, 16/32 Bit umschaltbar (ab Firmware 14 / Hardware 09) |  | 16 Bit, 16/32 Bit umschaltbar |  |  | -
Grenzfrequenz | 4 Mio. Inkremente bei 4-fach-Auswertung entspricht 1 MHz |  |  |  | 20 Mio. Inkremente bei 4-fach-Auswertung entspricht 5 MHz
Quadraturdecoder | 4-fach-Auswertung
Distributed Clocks | im erweiterten Betriebsmodus (ab Firmware 14 / Hardware 09) |  | ja
Drahtbrucherkennung zum Geber | im erweiterten Betriebsmodus (ab Firmware 14 / Hardware 09) |  | ja
Befehle | Lesen, Setzen, Aktivieren |  |  |  |  | Lesen, Setzen
Oversampling-Faktor | - |  |  |  |  | n=1..100 wählbar
Zykluszeit | min. 100 µs |  |  |  |  | min. 500 µs
Wandlungszeit | - |  |  |  |  | 10 µs / 100 kSps
Stromaufnahme aus dem E-Bus | typ. 130 mA
Stromaufnahme aus den Powerkontakten | 0,1 A (ohne Geberlaststrom)
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Bitbreite im Prozessabbild | bis zu 6 Byte Outputs, 22 Byte Inputs, abhängig von Parametrierung
MTBF (+55°C) | - | > 790.000 h |  | -
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 100 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL5101 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EL5101 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen Kommunikation

Grundlagen Kommunikation
Grundlagen Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
DC Einstellungen


EtherCAT-Grundlagen

Grundlagen Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


DC Einstellungen

Grundlagen Kommunikation [image] DC Einstellungen
DC Einstellungen
Distributed Clocks (DC)
EtherCAT und Distributed Clocks
Auf der Beckhoff Website können Sie eine grundlegende Einführung in das Thema EtherCAT und Distributed Clocks herunterladen: die "Systembeschreibung Distributed Clocks".
Die Inkremental-Encoder-Klemmen unterstützen die Distributed-Clocks-Funktionalität (EL5101: ab Hardware 09 / Firmware 14; EL5151 ab Hardware 01 / Firmware 05). Damit die EL51xx den aktuellen Zählerstand rechtzeitig vor Ankunft des abfragenden EtherCAT-Datagrams in den vorgesehenen Prozessdaten bereitstellen kann, muss ein entsprechendes Signal in der Klemme zyklisch generiert werden. Dieses Signal kann in der EL51xx durch 2 Ereignisse ausgelöst werden: Den SyncManager (SM) und die Distributed Clock (DC). In der Betriebsartenwahl (s. Abb. 1) stehen zur Auswahl:
Karteireiter „DC“ (Distributed Clocks)
▪
FreeRun/SM-Synchron
Das SyncManager-Ereignis tritt ein, wenn ein EtherCAT-Frame Prozessdaten mit der EL51xx erfolgreich austauscht. Frame-getriggert wird so zyklisch der aktuelle Zählerstand ermittelt, allerdings mit dem geringen zeitlichen Jitter des Ethernet-Frames. Ein Ethernet-Frame löst in dieser Betriebsart die Prozessdatenbereitstellung für den nächsten abholenden Frame aus. Das ist üblicherweise erst nach 1x Zykluszeit der Fall.
▪
DC-Synchron
In der Betriebsart DC wird die Zählerstandermittlung zyklisch konstant durch die integrierte DC-Einheit ausgelöst, standardmäßig im Gleichtakt mit dem Buszyklus aber mit einer konstanten Verschiebung (Phase, Shifttime, Offset). Durch die deutlich gleichmäßigere Abfrage (Synchronisationsgenauigkeit: 100 ns) kann z.B. ein übergeordneter Regelalgorithmus mit qualitativ höherwertigen Positionsdaten versorgt werden. In der EL51xx ist dieser Auslöser das SYNC0-Signal, das in der Betriebsart "DC-synchron" wie eine Ausgangsbaugruppe eingestellt wird, s. Systembeschreibung Distributed Clocks.
Die DC-Betriebsarten ermöglichen es, den Startzeitpunkt der Prozessdatenbereitstellung durch einen Offset-Wert (Shift-Wert) zu verschieben. Dieser Offset-Wert kann nur beim EtherCAT-Start gesetzt werden und ist dann während der Betriebszeit unveränderlich. Nach dem allgemeinen Distributed-Clocks-SYNC-Funktionsmodell kann das klemmenlokale SYNC-Signal sinnvoll entweder kurz vor oder nach dem erwarten Frame-Durchlaufzeitpunkt stattfinden: bei Eingangsklemmen wird das SYNC-Signal vor dem Frame generiert, um aktuelle Eingangsdaten zum Weitertransport zur Verfügung zu stellen - bei Ausgangsklemmen wird das SYNC-Signal auf einen Zeitpunkt nach dem Framedurchlauf angesetzt, damit die eben angelieferten Ausgangsdaten sofort ausgegeben werden. Da nur jeweils eine der beiden Betriebsarten möglich ist, kann der Benutzer hier die für seinen Anwendungsfall besser geeignete Betriebsart auswählen.
"DC Synchron" entspricht hier der Konfiguration als Ausgangsbaugruppe, das lokale SYNC-Event wird kurz nach der Passage des EtherCAT-Frames ausgelöst.
▪
DC-Synchron (input based)
Im Modus "DC-Synchron (input based)" wird diese EL51xx der Gruppe der Eingangsbaugruppen zugeordnet und die Shift-Time (s. Abb. Erweiterte Einstellungen Distributed Clock (DC), Klemme EL51xx) entsprechend berechnet.
Beim Einschalten der Betriebsart "DC-Synchron" werden Einstellungen von TwinCAT gewählt, die einen zuverlässigen Betrieb der EL51xx und die Gewinnung aktueller Positionsdaten gewährleisten. Das bedeutet, die Ermittlung des aktuellen Zählerstandes wird in hochkonstanten Abständen und in der Betriebsart Betriebsart "DC-synchron (input based)" rechtzeitig - also mit genügend Sicherheitspuffer - vor dem abholenden EtherCAT-Datagram durch das SYNC0-Signal gestartet.
Dauer der Prozessdatenbereitstellung in der EL51x1
Die EL5101 (ab Hardware 09 / Firmware 14) bzw. EL5151(ab Hardware 01/ Firmware 05) benötigt ca. 80 µs um nach dem SYNC-Event die Positionsdaten zu ermitteln und zur Abholung bereitzustellen. Dieser Wert ist abhängig von der Konfiguration und Parametrierung. Unter Verwendung der internen DC-Funktionen kann die aktuell real benötigte Dauer ausgelesen werden, siehe die CoE-Einstellung in 1C32:08 und das Ergebnis in 1C32:05.
Das SYNC0-Signal kann bei Bedarf in entsprechenden Dialogen auf der Zeitachse nach rechts/spät bzw. links/früh durch Angabe einer "User defined Shift Time" verschoben (geshiftet) werden, s. Abb. Erweiterte Einstellungen Distributed Clock (DC), Klemme EL51xx.
▪
Durch ein Shiften nach rechts (positiver Shift-Wert) erfolgt die Abfrage des Zählerstandes später - damit wird der Positionswert aktueller, relativ gesehen von der SPS aus. Allerdings steigt damit das Risiko, dass die Positionsermittlung bis zur Ankunft des EtherCAT-Frames nicht rechtzeitig beendet wurde und in diesem Zyklus ein aktueller Positionswert fehlt.
▪
Durch ein Shiften nach links (negativer Shift-Wert) erfolgt die Abfrage des Zählerstandes früher - damit werden die Positionswerte älter, jedoch wird der Sicherheitspuffer vor Ankunft des EtherCAT-Datagrams erhöht. Diese Einstellung kann auf Systemen mit hohem Echtzeit-Jitter nützlich sein, wenn zur Steuerung z.B. kein Industrie-PC von Beckhoff verwendet wird.
Hinweis
Achtung! Beschädigung der Geräte möglich!
Die hier aufgeführten Hinweise und Erläuterungen sollten mit Bedacht angewendet werden! Die SYNC0- und SYNC1-Einstellungen werden vom EtherCAT-Master automatisch mit Werten belegt, die eine zuverlässige und aktuelle Prozessdatenerfassung unterstützen. Anwenderseitige Eingriffe an dieser Stelle können zu unerwünschtem Verhalten führen! Bei der Manipulation dieser Einstellungen im Systemmanager wird softwareseitig keine Plausibilitätskontrolle durchgeführt! Eine korrekte Funktion der Klemme in allen denkbaren Einstellungsvarianten kann nicht gewährleistet werden!
Default-Einstellung
Das zyklische Lesen der Eingänge wird durch den SYNC0-Puls (Interrupt) der DC in der EL51xx ausgelöst. Standardmäßig wird die Einlese-Zykluszeit "Sync Unit Zyklus" vom EtherCAT-Master auf die verwendete SPS-Zykluszeit und damit auf die EtherCAT-Zykluszeit gesetzt. Siehe Abb. Erweiterte Einstellungen Distributed Clock (DC), Klemme EL51xx: 4000 µs = 4 ms da sich TwinCAT hier im Config-Modus befindet.
DC-Einstellungen EL51xx
Erweiterte Einstellungen Distributed Clock (DC), Klemme EL51xx
▪
SYNC0
Sync Unit Zyklus: Vielfaches der Buszykluszeit. In diesem Abstand (in µs) wird der Zählerstand periodisch ermittelt.
▪
Anwenderdefiniert
Beliebige Zahl bis 232 ns ≈ 4,3 sek. Kommawerte sind möglich.
▪
Shift Time
Mit der Shift Time kann der SYNC0-Puls dieser EL51xx gegenüber anderen Klemmen bzw. dem globalen SYNC-Puls in ns-Schritten verschoben werden. Sollen die Daten mehrerer EL51xx-Klemmen gleichzeitig gelesen werden, muss hier derselbe Wert eingetragen werden.
▪
Based on Input Reference
Bei Aktivierung dieser Option wird zum klemmenlokalen konfigurierbaren SYNC0-Shift ("User defined") ein weiterer „Input Shift“ dazu addiert. Dieser Wert wird vom EtherCAT Master berechnet und zur Verfügung gestellt (SysMan/Gerät EtherCAT/Reiter EtherCAT/Erweiterte Einstellungen/Distributed Clocks/Input Shift Time/, siehe Abb. EtherCAT Master, Karteireiter EtherCAT, Erweiterte Einstellungen + EtherCAT Master, Erweiterte Einstellungen, Distributed Clock). Dadurch lesen alle Eingangsklemmen im System (EL1xxx, EL3xxx und entsprechend eingestellte ELxxxx wie die EL51xx) möglichst kurz vor dem abholenden EtherCAT-Frame ihre Eingänge ein und liefern so möglichst „aktuelle“ Eingangsdaten an die Steuerung ab. In der Betriebsart "input based" wird dieser Wert automatisch berücksichtigt.
▪
Enable SYNC0
Automatisch aktiviert in der Betriebsart "DC-synchron".
▪
SYNC1
Weiterer SYNC-Puls, abgeleitet aus SYNC0 oder der DC selbst. Wird bei der EL51xx nicht benötigt.
DC-Einstellungen EtherCAT Master
In den erweiterten Einstellungen des EtherCAT Master können übergeordnete Parameter der Distributed Clocks verändert werden. Siehe dazu auch die grundlegende Einführung in das Thema EtherCAT und Distributed Clocks herunterladen: die "Systembeschreibung Distributed Clocks".
EtherCAT Master, Karteireiter EtherCAT, Erweiterte Einstellungen
EtherCAT Master, Karteireiter EtherCAT, Erweiterte Einstellungen
EtherCAT Master, Erweiterte Einstellungen, Distributed Clock


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
UL-Hinweise
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation
•
LEDs und Anschlussbelegung


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


LEDs und Anschlussbelegung

Montage und Verdrahtung [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
Weiterführende Informationen
•
EL5101-00x0
•
EL5101-0011


EL5101-00x0

Montage und Verdrahtung [image] LEDs und Anschlussbelegung [image] EL5101-00x0
EL5101-00x0
EL5101
Anschlussbelegung
Klemmstelle | Nr. | Kommentar
A | 1 | Encoder-Eingang A
B | 2 | Encoder-Eingang B
C | 3 | Encoder-Eingang C
Latch 24 V | 4 | Latch-Eingang
¬A | 5 | Encoder-Eingang A
¬B | 6 | Encoder-Eingang B
¬C | 7 | Encoder-Eingang C
Gate 24 V | 8 | Gate-Eingang
Ue = +5 V | 1' | +5 V Encoder-Versorgung
+24 V | 2' | +24 V (intern verbunden mit Klemmstelle 6' und positivem Power-Kontakt)
0 V | 3' | 0 V (intern verbunden mit Klemmstelle 7' und negativem Power-Kontakt)
Input 1 | 4' | Status-Eingang 1 Störmeldeeingang vom Drehgeber. Intern über PullUp auf 5 V gelegt. Negativ schaltend, d .h. Kontaktierung gegen GND führt zu Fehlerbit und LED-Anzeige. Wenn extern gespeist (nicht empfohlen) sind max. 5 V gegen GND zulässig.
Uo = 0 V | 5' | 0 V Encoder-Versorgung
+24 V | 6' | +24 V (intern verbunden mit Klemmstelle 2' und positivem Power-Kontakt)
0 V | 7' | 0 V (intern verbunden mit Klemmstelle 3' und negativem Power-Kontakt)
Shield | 8' | Schirm
LEDs
LED | Farbe | Bedeutung
INPUT A, B, C | grün | jeweils TRUE Pegel anzeigend
INPUT 1 | rot | leuchtet, wenn der INPUT1-Eingang gegen GND gezogen wird [INPUT 1 ist durch internen Pull-Up auf internes 5 V-HIGH-Pegel gelegt (default)]
LATCH | grün | leuchtet, wenn ein Signal (+24 V) am Latch-Eingang anliegt
GATE | grün | leuchtet, wenn ein Signal (+24 V) am Gate-Eingang anliegt
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
POWER 5 V | grün | Betriebsspannungsanzeige für Spannungsversorgung Inkremental-Encoder


EL5101-0011

Montage und Verdrahtung [image] LEDs und Anschlussbelegung [image] EL5101-0011
EL5101-0011
EL5101-0011
Anschlussbelegung
Klemmstelle | Nr. | Kommentar
A | 1 | Encoder-Eingang A
B | 2 | Encoder-Eingang B
C | 3 | Encoder-Eingang C
- | 4 | -
¬A | 5 | Encoder-Eingang A
¬B | 6 | Encoder-Eingang B
¬C | 7 | Encoder-Eingang C
- | 8 | -
Ue = +5 V | 1' | +5 V Encoder-Versorgung
+24 V | 2' | +24 V (intern verbunden mit Klemmstelle 6' und positivem Power-Kontakt)
0 V | 3' | 0 V (intern verbunden mit Klemmstelle 7' und negativem Power-Kontakt)
- | 4' | -
Uo = 0 V | 5' | 0 V Encoder-Versorgung
+24 V | 6' | +24 V (intern verbunden mit Klemmstelle 2' und positivem Power-Kontakt)
0 V | 7' | 0 V (intern verbunden mit Klemmstelle 3' und negativem Power-Kontakt)
Shield | 8' | Schirm
LEDs
LED | Farbe | Bedeutung
INPUT A, B, C | grün | jeweils TRUE Pegel anzeigend
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
POWER 5 V | grün | Betriebsspannungsanzeige für Spannungsversorgung Inkremental-Encoder


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
EL5101-00x0
•
EL5101-0011
•
EL5101-0090


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration
•
NC - Konfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


NC - Konfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] NC - Konfiguration
NC - Konfiguration
NC - Konfiguration Zur Achsen-Konfiguration und Verknüpfung der EL51x1 im TwinCAT System Manager (Config Mode) gehen Sie bitte wie folgt vor:
Klicken Sie mit der rechten Maustaste auf NC-Konfiguratuion - > Task anfügen (Abb. NC-Konfiguration, Task anfügen), wählen Sie einen Namen für die Task und bestätigen Sie mit OK (Abb. Task benennen und bestätigen)
NC-Konfiguration, Task anfügen
Task benennen und bestätigen
Klicken Sie mit der rechten Maustaste auf Achsen - >Achse anfügen (Abb. Achse einfügen), wählen Sie einen Namen und Typ der Achse und bestätigen Sie mit OK (Abb. Achse benennen und Typ auswählen)
Achse einfügen
Achse benennen und Typ auswählen
Nach der Anwahl des Karteireiters NC wählen Sie im Pulldownmenü Typ den Encoder an KL5101/Kl5111/IP5109/EL5101 (Abb. Auswahl des Encoders)
Klicken Sie den Button Verknüpft mit... und wählen Sie die Klemme EL51x1 und bestätigen Sie mit OK (Abb. Encoder-Klemme auswählen und bestätigen)
Auswahl des Encoders
Encoder-Klemme auswählen und bestätigen
Die entsprechenden Eingänge der EL51x1 sind nun mit der NC-Task verknüpft (Abb. Verknüpfte Eingänge der EL51x1 mit der NC-Task)
Verknüpfte Eingänge der EL51x1 mit der NC-Task


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EL5101-00x0

Inbetriebnahme [image] EL5101-00x0
EL5101-00x0
Weiterführende Informationen
•
Normaler Betriebsmodus
•
Erweiterter Betriebsmodus


Normaler Betriebsmodus

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus
Normaler Betriebsmodus
Weiterführende Informationen
•
Prozessdaten und Modi - Normaler Betriebsmodus
•
Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
•
Control- und Status-Byte


Prozessdaten und Modi - Normaler Betriebsmodus

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Prozessdaten und Modi - Normaler Betriebsmodus
Prozessdaten und Modi - Normaler Betriebsmodus
In der EL5101 "Normaler Betriebsmodus" sind folgende Betriebsmodi verfügbar:
Modus | DC | Haupt PDO | Kommentar | optionale PDO 1 | Kommentar | Features CoE | Kommentar
1 | FreeRun | 0x1A00 + 0x1600 | 16 Bit Value/Latch Byte-Alignment | 0x1A02 | Frequenz: 32 Bit Periode: 16 Bit Window: 16 Bit CoE-Objekt 0x8001:02: window | 0x8000:01 + 0x8001:02 | Register reload + Reload Value
2 | " | " | " | " | " | 0x8000:02 | Index Reset
3 | " | " | " | " | " | 0x8000:03, :04, :05 | FWD Cnt + pos/neg Gate
4 | FreeRun | 0x1A01 + 0x1601 | 16 Bit Value/Latch Word-Alignment | 0x1A02 | Frequenz: 32 Bit Periode: 16 Bit Window: 16 Bit CoE-Objekt 0x8001:02: window | 0x8000:01 + 0x8001:02 | Register reload + Reload Value
5 | " | " | " | " | " | 0x8000:02 | Index Reset
6 | " | " | " | " | " | 0x8000:03, :04, :05 | FWD Cnt + pos/neg Gate
Andere als die o.a. Einstellungen können zu irregulären Prozessdaten und Fehlermeldungen im TwinCAT Systemmanager Logger-Fenster führen.
Parametrierung der EL5101
• Um ggf. frühere Einstellungen unwirksam zu machen, ist ein CoE-Reset durchzuführen
• Zur Aktivierung des neuen Betriebsmodus die EtherCAT-Slaves neu laden (Schaltfläche [image] im System Manager)
Erläuterungen zu den Parametern und Modi
DC (Distributed Clocks)
Beschreibt, ob die Klemme mit DistributedClocks-Unterstützung betrieben wird:
Reiter „DC“
Distributed Clocks im normalen Betriebsmodus
Im normalen Betriebmodus stehen keine DC-Funktionen zur Verfügung.
Haupt PDO
Auswahl der Basis-Prozessdaten:
Reiter „Prozessdaten“
A: Anwahl der Datenrichtung: Input oder Output
B: Auswahl (optionaler) PDO (Prozessdatenobjekte)
C: Erläuterung zu den PDO
▪
Byte/Word-Alignment: Standardmäßig wird die EL5101 im normalen Betriebsmodus mit Byte-Alignment und damit effizient wenigen Prozessdaten betrieben. Ggf. benötigt ein EtherCAT-Master allerdings die Prozessdaten im Word-Alignment (auf volle 16 Bit aufgefüllt), dann sind die PDO 0x1A01 und 0x1601 zu verwenden.
Optionale PDO
Zum Haupt-PDO optional wählbare PDO:
▪
PDO 1 (0x1A02):
- Die Frequenz wird über 10 ms (unveränderlich) als Anzahl der Inkremente ermittelt.
- Die Periode (Zeitabstand zwischen 2 positiven Flanken vom Eingang A) wird so oft wie möglich in der Einheit 500 ns/digit ermittelt Tritt ca.1.6 Sekunden lang kein Inkrement-Ereignis mehr auf, wird Frequenz/Period auf 0 gesetzt.
- Window: ein benutzerdefiniertes Zeitfenster kann durch das CoE-Objekt 0x8001:02 mit der Einheit 16 µs/digit parametriert werden. In dieser Fensterzeit werden die Encoderinkremente gezählt und im Prozessdatum window ausgegeben.
Features CoE
Abhängig von den Haupt-PDO/optionalen PDO sind im CoE (CAN over EtherCAT-Verzeichnis) weitere Einstellungen anwählbar.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise: - StartUp-Liste führen für den Austauschfall - Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung - "CoE-Reload" zum Zurücksetzen der Veränderungen
Folgende CoE-Einstellungen aus den Objekten 0x8000 und 0x8001 sind möglich und hier in den Default-Einstellungen wiedergegeben:
Reiter „CoE – Online“
Die Parameter werden auf der Seite Objektbeschreibung und Parametrierung beschrieben.
Hinweise
Frequenz
▪
Das Zeitfenster für die Frequenzberechnung ist auf 10 ms fest eingestellt (s. Abb. Reiter „Prozessdaten“); zusätzlich steht ein variabel einstellbares Messfenster zur Verfügung (Parametrierung über Objekt 0x8001:01 , Ausgabe Frequenzwert in Objekt 0x6000:06)
▪
Es werden nur die Inkrement-Flanken im angegebenen Zeitfenster gezählt.
▪
Ereignet sich ca. 1,6 s lang kein Flankenwechsel, wird die evtl. bestehende Frequenzangabe gelöscht.
▪
Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
▪
Wenn der Zähler durch das Gate gesperrt ist, ist keine Frequenzmessung möglich; die Messung der Periodendauer kann in diesem Fall trotzdem durchgeführt werden.
▪
Wenn nur an Eingang A/A ein Encodersignal anliegt und die Frequenz/Periode gemessen werden soll, muss die Klemme im CoE 0x8000:03 auf „Enable FWD count“ eingestellt werden.
▪
Ein C- oder externer Reset startet die Frequenzmessung neu, der zuletzt ausgegebene Frequenzwert bleibt bis zur Ermittlung eines neuen Frequenzwertes unverändert.
Prinzip Frequenzmessung im normalen Betriebmodus
Periodenberechnung
▪
Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
▪
Es wird in jedem Zyklus der Abstand zwischen 2 positiven Flanken von Eingang A mit einer Auflösung von 100 ns gezählt.
▪
Ereignet sich 1,6 s lang kein Flankenwechsel, wird die evtl. bestehende Periodenangabe gelöscht.
Frequenz- und Periodenmessung
Aus den o.a. Erläuterungen wird ersichtlich, dass die Frequenzmessung den aktuellen Achsenzustand (Geschwindigkeit) deutlich genauer erfassen kann als die Periodenmessung. Es ist deshalb - wenn möglich - bevorzugt die Frequenzmessung zu verwenden.
Latch
▪
die Latch-Steuerung wird über das Control- und Status-Word vorgenommen.
Register Reload
▪
Ist Register Reload im CoE-Objekt 0x8000:01 enabled, wird der Zählerstand beim Überlauf über den Wert im CoE-Objekt 0x8001:02 auf Null bzw. beim Unterlauf unter 0 auf den Wert in CoE-Objekt 0x8001:02 gesetzt.
Index Reset
▪
Ist Index Reset im CoE-Objekt 0x8000:02 enabled, setzt der Eingang C den Zähler auf 0 zurück.
"Register Reload" und "Index Reset"
Es ist kein gleichzeitiger Betrieb von "Register Reload" und "Index Reset" möglich!
FWD Cnt
▪
Ist FwdCnt im CoE-Objekt 0x8000:03 aktiviert, arbeitet die EL5101 als Zähler auf Kanal A. Kanal B gibt die Zählrichtung an: B=TRUE vorwärts, B=FALSE rückwärts. Über den Gate-Eingang (24 V) kann der Zähler gesperrt werden.
- CoE-Objekt 0x8000:04 (TRUE): Sperrung des Zählers am Gate-Eingang mit positiver Flanke (0 V -> + 24 V).
- CoE-Objekt 0x8000:05 (TRUE): Sperrung des Zählers am Gate-Eingang mit negativer Flanke (+ 24 V -> 0 V).
Prozessdatenbeschreibung
Prozessdatenbeschreibung
Die Prozessdaten werden aus den CoE-Objekten 0x6000 (Inputs) und 0x7000 (Outputs) generiert.
▪
Status: Status-Bits (siehe Kapitel Control- und Status-Wort)
▪
Value: Encoder Position
▪
Latch: Latch Position
▪
Frequency: Aktuell berechnete Frequenz
▪
Period: Periode der letztmöglichen Messung
Refreshrate ist abhängig von der Zykluszeit und der anliegenden Frequenz
▪
Window: Anzahl der letzten im Zeitfenster "window" gezählten Flanken
▪
Ctrl: Control-Bits (siehe Kapitel Control- und Status-Wort)
▪
Value: Zu übernehmender Zählerwert


Objektbeschreibung und Parametrierung - Normaler Betriebsmodus

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt, s.u.) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 Non-Volatile Settings 0
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | Non-Volatile Settings 0 | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
8000:01 | Enable register reload | Der Zähler zählt bis zum "Counter reload value" bzw. wird bei einem Unterlauf mit dem "Counter reload value" (0x8001:02) geladen Beispiel 360° Encoder bei gesetztem Bit: Fahrt in positiver Richtung über Counter reload value: Reset Zählerstand auf 0. Fahrt in negativer Richtung unter 0: Reset Zählerstand auf Counter reload value. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable index reset | Aktiviert den Eingang "C" zum Zurücksetzen des Zählers. Beispiel 360° Encoder bei gesetztem Bit: Fahrt in positiver Richtung (Signal an Eingang "C"): Reset Zählerstand auf 0 Fahrt in negativer Richtung (Signal an Eingang "C"): Underflow mit FFFF, FFFE, usw.) | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable FWD count | FALSE Die Klemme arbeitet im Quadratur-Decoder Modus TRUE Die Klemme arbeitet als Zähler, Zählrichtung nach Eingang B | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Enable pos. gate | Gate-Eingang reagiert auf Positiv-Flanke und sperrt den Zähler | BOOLEAN | RW | 0x01 (1dez)
8000:05 | Enable neg. gate | Gate Eingang reagiert auf Negativ-Flanke und sperrt den Zähler | BOOLEAN | RW | 0x00 (0dez)
Index 8001 Non-Volatile Settings 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8001:0 | Non-Volatile Settings 1 | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
8001:01 | Frequency window | Wert gibt die Größe des Zeitfensters für die Variable "Window" an. Auflösung: 16 µs; z. B. Defaultwert: 16 µs x 100dez = 1,6 ms | UINT16 | RW | 0x0064 (100dez)
8001:02 | Counter reload value | Wenn "Enable register reload" = TRUE, zählt der Zähler bis zu diesem Wert bzw. wird bei einem Unterlauf mit diesem Wert geladen | UINT16 | RW | 0xFFFF (65535dez)


Eingangsdaten

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Inputs | Länge dieses Objekts | UINT8 | RO | 0x06 (6dez)
6000:01 | Status | Status-Byte | UINT8 | RO | 0x00 (0dez)
6000:02 | Value | Zählerstand | UINT16 | RO | 0x0000 (0dez)
6000:03 | Latch | Latch-Wert | UINT16 | RO | 0x0000 (0dez)
6000:04 | Frequency | Frequenzwert (Auflösung: 0,01 Hz / digit) [festes 10 ms Messfenster] | UINT32 | RO | 0x00000000 (0dez)
6000:05 | Period | Periodendauer (Auflösung 500 ns / digit) | UINT16 | RO | 0x0000 (0dez)
6000:06 | Window | Messwert des variablen Zeitfensters ( "Frequency Window" (0x8001:01)) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | Outputs | Länge dieses Objekts | UINT8 | RO | 0x02 (2dez)
7000:01 | Ctrl | Control-Byte | UINT8 | RO | 0x00 (0dez)
7000:02 | Value | Der über „CNT_SET“ (CB.02) zu setzende Zählerstand. | UINT16 | RO | 0x0000 (0dez)


Standardobjekte

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL5101
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 09
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 10
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED3052 (334311506dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x03F90000 (66650112dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1600 RxPDO-Map Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1601 RxPDO-Map Outputs Word-Aligned
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | RxPDO-Map Outputs Word-Aligned | PDO Mapping RxPDO 2 | UINT8 | RO | 0x03 (3dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1601:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1A00 TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (3dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A01 TxPDO-Map Inputs Word-Aligned
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | TxPDO-Map Inputs Word-Aligned | PDO Mapping TxPDO 2 | UINT8 | RO | 0x04 (4dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A02 TxPDO-Map Inputs Optional
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Inputs Optional | PDO Mapping TxPDO 3 | UINT8 | RO | 0x03 (3dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x04 (Frequency)) | UINT32 | RO | 0x6000:04, 32
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x05 (Period)) | UINT32 | RO | 0x6000:05, 16
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x06 (Window)) | UINT32 | RO | 0x6000:06, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)


Control- und Status-Byte

Inbetriebnahme [image] EL5101-00x0 [image] Normaler Betriebsmodus [image] Control- und Status-Byte
Control- und Status-Byte
Control-Byte
Das Control-Byte (CB) befindet sich im Ausgangsprozessabbild und wird von der Steuerung zur Klemme übertragen.
Bit | CB.7 | CB.6 | CB.5 | CB.4 | CB.3 | CB.2 | CB.1 | CB.0
Name | - | - | - | - | EN_LATCH_EXTN | CNT_SET | EN_LATCH_EXTP | EN_LATC
Legende
Bit | Name | Beschreibung
CB.3 | EN_LATCH_EXTN | 1bin | Nach Gültigkeit des EN_LATCH_EXTN Bits wird beim ersten externen Latchimpuls mit fallender Flanke der Counterwert auf den Latch-Eingang (Index 0x6000:03) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch Wert. Bitte beachten: Erst wenn das Latch Valid Bit (LAT_EXT_VAL) im Status-Byte einen Low-Pegel aufweist, kann ein neuer Counterwert auf den Latcheingang geschrieben werden.
CB.2 | CNT_SET | rise | Der Zähler wird mit steigender Flanke von CNT_SET auf den Wert, der über die Prozessdaten (Index 0x7000:02) vorgegeben wird, gesetzt.
CB.1 | EN_LATCH_EXTP | 1bin | Nach Gültigkeit des EN_LATCH_EXTP Bits wird beim ersten externen Latchimpuls mit steigender Flanke der Counterwert auf den Latch-Eingang (Index 0x6000:03) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch Wert. Bitte beachten: Erst wenn das Latch Valid Bit (LAT_EXT_VAL) im Status-Byte einen Low-Pegel aufweist, kann ein neuer Counterwert auf den Latcheingang geschrieben werden.
CB.0 | EN_LATC | 1bin | Der Nullpunktlatch (C-Eingang) wird aktiviert. Beim ersten externen Latchimpuls nach Gültigkeit des EN_LATC Bits wird der Counterwert gespeichert (hat Vorrang vor EN_LAT_EXTN / EN_LAT_EXTP). Die folgenden Impulse haben bei gesetztem Bit keinen Einfluss auf den Latch Wert. Bitte beachten: Erst wenn das Latch Valid Bit (LATC_VAL) im Status-Byte einen Low-Pegel aufweist, kann ein neuer Counterwert auf den Latcheingang geschrieben werden (das LATC_VAL-Bit (SB.0) wird erst von der Klemme zurückgenommen, wenn der C-Impuls = LOW).
Status-Byte
Das Status-Byte (SB) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SB.7 | SB.6 | SB.5 | SB.4 | SB.3 | SB.2 | SB.1 | SB.0
Name | - | - | STATUS_EINGANG | OVERFLOW | UNDERFLOW | CNTSET_ACC | LAT_EXT_VAL | LATC_VAL
Legende
Bit | Name | Beschreibung
SB.5 | STATUS_EINGANG | 0bin/ 1bin | Gibt den Status von INPUT 1 wieder
SB.4 | OVERFLOW | 1bin | Tritt ein Überlauf (65535 auf 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 auf 21846) oder sobald ein Unterlauf auftritt.
SB.3 | UNDERFLOW | 1bin | Tritt ein Unterlauf (0 auf 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 auf 43689) oder sobald ein Überlauf auftritt.
SB.2 | CNTSET_ACC | 1bin | Die Daten zum Setzen des Zählers (Index 0x7000:02) wurden von der Klemme übernommen.
SB.1 | LAT_EXT_VAL | 1bin | Ein externer Latchimpuls ist aufgetreten. Die Daten mit dem Index 0x6000:03 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss EN_LAT_EXTN bzw. EN_LATCH_EXTP (CB.3 bzw. CB.1) erst zurückgenommen und dann neu gesetzt werden.
SB.0 | LATC_VAL | 1bin | Ein Nullpunktlatch ist aufgetreten. Die Daten mit dem Index 0x6000:03 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latcheingang neu zu aktivieren, muss EN_LATC (CB.0) erst zurückgenommen und dann neu gesetzt werden.


Erweiterter Betriebsmodus

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus
Erweiterter Betriebsmodus
Weiterführende Informationen
•
Prozessdaten und Modi - Erweiterter Betriebsmodus
•
Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus


Prozessdaten und Modi - Erweiterter Betriebsmodus

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Prozessdaten und Modi - Erweiterter Betriebsmodus
Prozessdaten und Modi - Erweiterter Betriebsmodus
In der EL5101-0000 "Erweiterter Betriebsmodus" sind folgende Betriebsmodi verfügbar:
Modus | DC | Haupt PDO | Kommentar | optionale PDO 1 | Kommentar | optionale PDO 2 | Kommentar | Features CoE | Kommentar
7 | FreeRun | 0x1A04 + 0x1603 | Count/Latch in 32 Bit | 0x1A05 oder 0x1A06 | Frequency (32 Bit) oder Period (32 Bit) | -- |  | 0x80n0:nn | Kombinationen aus dem CoE 0x80n0:nn
8 | " | 0x1A03 + 0x1602 | compact: Count/Latch in 16 Bit | " | " | -- |  | " | " Nicht bei EL5101-0010
9 | DC/DCi | 0x1A04 + 0x1603 | Count/Latch in 32 Bit | " | " | 0x1A07 oder 0x1A08 | Timestamp 64 Bit Timestamp 32 Bit (compact) | " | "
10 | " | 0x1A03 + 0x1602 | compact: Count/Latch in 16 Bit | " | " | " | " | " | " Nicht bei EL5101-0010
Andere als die o.a. Einstellungen können zu irregulären Prozessdaten und Fehlermeldungen im TwinCAT Systemmanager Logger-Fenster führen.
Parametrierung
• Um ggf. frühere Einstellungen unwirksam zu machen, ist ein CoE-Reset durchzuführen
• Zur Aktivierung des neuen Betriebsmodus die EtherCAT-Slaves neu laden (Schaltfläche [image])
Parametrierung EL5101-0010
Bei der EL5101-0010 sind nicht alle PDO-Einträge verfügbar, dazu ist die Objektbeschreibung zu beachten.
Erläuterungen zu den Parametern und Modi
DC (Distributed Clocks)
Beschreibt, ob die Klemme mit Distributed Clocks-Unterstützung betrieben wird:
Reiter „DC“
▪
FreeRun: die Klemme arbeitet Frame-getriggert, der zyklische Betrieb wird durch die SyncManager der EtherCAT-Frame-Bearbeitung gestartet.
▪
DC-Synchron: der Zyklische Betrieb in der Klemme wird durch die lokale Distributed Clock in exakten Zeitabständen gestartet. Dabei ist der Startzeitpunkt so gewählt, dass er mit anderen Output-Slaves im EtherCAT-System zusammenfällt.
▪
DC-Synchron (input based): Arbeitsweise wie DC-Synchron, aber der zyklische Startzeitpunkt ist so gewählt, dass er mit anderen Input-Slaves im EtherCAT-System zusammenfällt.
Haupt PDO
Auswahl der Basis-Prozessdaten
Reiter „Prozessdaten“
A: Anwahl der Datenrichtung: Input oder Output
B: Auswahl (optionaler) PDO (Prozessdatenobjekte)
C: Erläuterung zu den PDO
▪
compact: die Prozessdaten können mit 16 Bit Umfang als "compact" oder mit 32 Bit Umfang dargestellt werden.
Kein "Compact"-Prozessabbild bei der EL5101-0010
Die EL5101-0010 unterstützt kein "Compact"-Prozessabbild.
Optionale PDO
Zum Haupt-PDO optional wählbare PDO:
▪
PDO 1 (0x1A05 oder 0x1A06): als optionales PDO 1 ist entweder die Frequenz oder die Periode anwählbar
▪
PDO 2 (0x1A07 oder 0x1A08): In einem der DC-Modi ist ein 32 Bit oder 64 Bit großer Timestamp zuwählbar. Der Timestamp gibt die Uhrzeit der letzten registrierten Inkrementflanke, basierend auf dem DistributedClocks System an.
Bei der EL5101-0010 sind hier andere PDO-Einträge zu wählen, dazu ist die Objektbeschreibung zu beachten.
Features CoE
abhängig von den Haupt-PDO/optionalen PDO sind im CoE (CAN over EtherCAT)-Verzeichnis weitere Einstellungen anwählbar.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise: - StartUp-Liste führen für den Austauschfall - Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung - "CoE-Reload" zum Zurücksetzen der Veränderungen
Folgende CoE-Einstellungen aus dem Objekt 0x80n0 sind möglich und hier in den Default-Einstellungen wiedergegeben:
Reiter „CoE – Online“
Die Parameter werden auf der Seite Objektbeschreibung und Parametrierung beschrieben.
Hinweise
Frequenz
▪
Das Zeitfenster für die Frequenzberechnung sowie die Auflösung kann in den CoE-Objekten 0x80n0:11, 0x80n0:13, 0x80n0:15, 0x80n0:17 parametriert werden.
▪
Es werden die positiven Flanken der Spur A im angegebenen Zeitfenster gezählt und die nächste folgende Flanke inkl. der Zeit bis dahin gezählt. Die Zeit, wie lange auf die Flanke gewartet wird, ist im CoE Objekt 0x80n0:17 "Frequency Wait Time" einstellbar (Einheit: ms) und standardmäßig auf 1,6 s gesetzt. Das ist auch der Maximalwert.
▪
Das Zeitfenster ist 10 ms (default), min. 1 µs. Mit der Standardeinstellung können Frequenzen bis ca. 800 kHz gemessen werden, bei höheren Frequenzen ist ein kleinerer Wert für das Zeitfenster zu wählen.
▪
Die Zeit wird mit einer Auflösung von 100 ns gemessen.
▪
Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
▪
Wenn der Zähler durch das Gate gesperrt ist, ist keine Frequenzmessung möglich; die Messung der Periodendauer kann in diesem Fall trotzdem durchgeführt werden.
▪
Wenn nur an Eingang A/A ein Encodersignal anliegt und die Frequenz/Periode gemessen werden soll, muss die Klemme im CoE 0x8010:03 auf „Up/Down Counter“ eingestellt werden.
▪
Ein C- oder externer Reset startet die Frequenzmessung neu, der zuletzt ausgegebene Frequenzwert bleibt bis zur Ermittlung eines neuen Frequenzwertes unverändert.
Frequenzmessung
▪
Basiseinheit 1 µs: alle Fenstergrößen
Ablauf der Messung
▪
Die Messung beginnt mit einer steigenden Flanke der Spur A, aktueller Zählerstand und Zeit (Auflösung: 100 ns) werden gespeichert.
▪
nach Ablauf des Messfensters (Index 0x80n0:11) wird noch bis zur folgenden steigenden Flanke an Spur A gewartet, maximal jedoch 1,6 s bzw. die Zeit aus 0x80n0:17
▪
die Frequenz wird berechnet aus der Flankendifferenz und der real vergangenen Zeit.
Prinzip Frequenzmessung im erweiterten Betriebsmodus
Periodenberechnung
▪
Diese Berechnung wird im Slave ohne Bezug zum Distributed Clocks-System ausgeführt, ist also von der DC-Betriebsart unabhängig.
▪
Es wird in jedem Zyklus der Abstand zwischen 2 positiven Flanken von Eingang A mit einer Auflösung von 100 ns gezählt.
▪
Ereignet sich 1,6 s lang kein Flankenwechsel, wird die evtl. bestehende Periodenangabe gelöscht.
Frequenz- und Periodenmessung
Aus den o.a. Erläuterungen wird ersichtlich, dass die Frequenzmessung den aktuellen Achsenzustand (Geschwindigkeit) deutlich genauer erfassen kann als die Periodenmessung. Es ist deshalb - wenn möglich - bevorzugt die Frequenzmessung zu verwenden.
Latch
Aktivierung des Latch C-Eingangs ("C") und Speichern ("Latchen") des Zählerstandes (Index 0x70n0:01)
▪
Beim ersten externen Latchimpuls (positive Flanke an Eingang "C") nach gesetztem Bit ("TRUE") in Index 0x70n0:01 wird der Counterwert gespeichert (hat Vorrang vor 0x70n0:02 / 0x70n0:04 ). Die folgenden Impulse an den anderen Eingängen haben bei gesetztem Bit keinen Einfluss auf den Latch-Wert in Index 0x60n0:12
▪
Hinweis "Latch C valid" - Bit: Erst wenn der Wert des "Latch C valid" - Bit (Index 0x60n0:01) "FALSE" ist, kann ein neuer Counterwert auf den Latch-Eingang geschrieben werden.
Aktivierung des externen Latch-Eingangs ("Gate/Latch") und Verriegeln ("Latchen") des Zählerstandes (Index 0x70n0:02, 0x70n0:04)
▪
Bei gesetztem Bit ("TRUE") in Index 0x70n0:02 wird beim ersten externen Latchimpuls mit steigender Flanke der Counterwert auf den Latch-Eingang (Index 0x60n0:12 ) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert in Index 0x60n0:12 .
▪
Bei gesetztem Bit ("TRUE") in Index 0x70n0:04 wird beim ersten externen Latchimpuls mit fallender Flanke der Counterwert auf den Latch-Eingang (Index 0x60n0:12 ) gespeichert. Die folgenden Impulse haben keinen Einfluss auf den Latch-Wert in Index 0x60n0:12 .
▪
Hinweis "Latch extern valid" - Bit: Erst wenn der Wert des "Latch extern valid" - Bit Index 0x60n0:02) "FALSE" ist, kann ein neuer Counterwert auf den Latch-Eingang geschrieben werden.
Reset
▪
Reset des Zählers (Index 0x80n0:01, 0x80n0:02, 0x80n0:10): Für den Zählerreset über den Eingang C ist das Bit im Index 0x80n0:01 zu setzen, für den Reset über den externen Latch-Eingang das Bit im Index 0x80n0:02.
▪
Die Aktivierung der Funktionen "Enable C reset" (0x80n0:01 )und das "Enable extern reset" (0x80n0:02) sind gleichzeitig nicht möglich.
▪
Hinweis "Extern reset polarity", Index 0x80n0:10: Über den Index 0x80n0:10 besteht die Möglichkeit zur Auswahl der Flanke, um den Zähler auf Null zu setzen.
Bit nicht gesetzt: Zähler wird mit fallender Flanke auf "Null" gesetzt.
Bit gesetzt: Zähler wird mit steigender Flanke auf "Null" gesetzt.
Vorwärts-/Rückwärts-Zähler (nur EL5101-0000)
▪
Die Betriebsartenwahl (Encoder oder V/R-Zähler) wird über die CoE-Objekte (Profilspezifische Objekte, Karteireiter CoE -Online, Index 0x80n0:03 "Non-Volatile Settings") vorgenommen. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben Sie den Wert "1" im "SetValue"-Dialog ein und bestätigen Sie mit "OK".
▪
Ebenso ist über das Objekt 0x80n0:04 die Gate-Polarität einzustellen.
▪
Eine zusätzliche Option zur Drehrichtungsumkehr ist mit Setzen des Bits in Index 0x80n0:0E gegeben.
Over-/Underflow (nur EL5101-0000)
▪
In Kombination mit einer aktivierten Reset-Funktion (C/extern) ist die Over-/Underflowkontrolle unwirksam.
▪
Das Underflow-Bit (0x60n0:04) wird gesetzt, wenn ein Unterlauf ...00 →...FF eintritt. Es wird zurückgesetzt, wenn 2/3 des Zählerbereiches unterschritten werden.
▪
Das Overflow-Bit (0x60n0:05) wird gesetzt, wenn ein Überlauf FF...→ 00... eintritt. Es wird zurückgesetzt, wenn 1/3 des Zählerbereiches überschritten werden.
Drahtbrucherkennung / Open circuit detection
▪
Für die Kanäle A, B und C kann jeweils separat eine Drahtbrucherkennung aktiviert werden (Index 0x80n0:0B, 0x80n0:0C, 0x80n0:0D).
▪
Standardmäßig ist die Drahtbrucherkennung für die Kanäle A und B aktiviert.
▪
Eine differentielle Spannung typ. -1,5V >Vid > +1,5V (EL5101) und im Bereich typ. -0,475 V > Vid >+0,475V (EL5101-001x) wird als Drahtbruch detektiert.
▪
Ein erkannter Drahtbruch wird als Prozessdatum open circuit =TRUE angezeigt Bit in Objekt 0x60n0:07 wird gesetzt; die separate Anzeige eines Drahtbruchs wird in den Indizes 0xA0n0:01 (Spur A), 0xA0n0:02 (Spur B) und 0xA0n0:03 (Spur C) angezeigt.
▪
TxPDO state wird bei einem erkannten Drahtbruch ebenfalls TRUE, da von ungültigen Daten ausgegangen werden muss.
Mikroinkremente (nur EL5101-0000)
▪
Arbeitet mit und ohne Distributed Clocks, ist aber in der EL5101 nur in Verbindung mit einem der DC-Modi sinnvoll
▪
Über das Zählerstand-Setzen kann nur der ganzzahlige Anteil verändert werden.
▪
das Prinzip:
Prinzip Frequenzmessung im erweiterten Betriebsmodus
Die hochkonstante Abfragezyklen (Genauigkeit: 100 ns) des Distributed Clocks Systems erlauben es der EL5101-0000, ab einer bestimmten Geschwindigkeit interpolierte Achspositionen zwischen die gezählten Encoderinkremente zu interpolieren. Die Interpolationsauflösung beträgt dabei 8 Bit entsprechend 256 Werte. Ein Standardencoder mit 1.024 Strichen wird so mit 4fach Auswertung und Mikroinkrementen zu einem hochauflösenden Achsgeber mit 4096 * 256 = 1.048.567 Strichen.
Die Unterschreitung der Mindestgeschwindigkeit wird durch das Objekt 0x60n0:08 (Extrapolation stall) in den Prozessdaten angezeigt.
Prozessdatenbeschreibung
Prozessdatenbeschreibung
Die Prozessdaten werden aus den CoE-Objekten 0x60n0 (Inputs) und 0x70n0 (Outputs) generiert und sind im Kapitel Objektbeschreibung und Parametrierung dargestellt


Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus
Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über den C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24V) | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit "HIGH"-Pegel) 2: Enable neg. gate (Gate sperrt mit "LOW"-Pegel) | BIT2 | RW | 0x01 (1dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8000:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT1 | RW | 0x01 (1dez)
8000:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs] Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. "Frequency Wait Time" lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird in Index 0x6000:13 und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8000:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
Index 8000 ENC Settings (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8000:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Index 0x8000:14 (z.B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
8000:17 | Frequency Wait Time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums "Frequency" erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. t >= 2* (1 / fmin) | UINT16 | RW | 0x0190 (400dez)
Index 8010 ENC Settings (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8010:01 | Enable C reset | Ein Reset des Zählers erfolgt über den C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24 V) | BOOLEAN | RW | 0x00 (0dez)
8010:03 | Enable up/down counter | Freigabe des V/R-Zählers an Stelle des Encoders bei gesetztem Bit. Gezählt werden Inkremente am Eingang A, Zählrichtung gibt Eingang B vor. | BOOLEAN | RW | 0x00 (0dez)
8010:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit "HIGH"-Pegel) 2: Enable neg. gate (Gate sperrt mit "LOW"-Pegel) | BIT2 | RW | 0x01 (1dez)
8010:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x01 (1dez)
8010:0A | Enable micro increments | Bei Aktivierung interpoliert die EL5101 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 Bit des Counter-Value benutzt. Aus einem 32-Bit-Zähler wird so ein 24+8 Bit Zähler, aus einem 16-Bit-Zähler ein 8+8 Bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Index 0x6010:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8010:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Index 0x6010:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8010:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Index 0x6010:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8010:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8010:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT1 | RW | 0x01 (1dez)
Index 8010 ENC Settings (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs] Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. "Frequency Wait Time" lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird in Index 0x6010:13 und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8010:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8010:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
8010:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8010:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Index 0x8010:14 (z.B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
8010:17 | Frequency Wait Time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums "Frequency" erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. t >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dez)


Eingangsdaten

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6000:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Index 0x6000:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7000:01 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Index 0x6000:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7000:02 bzw. Objekt-Index 0x7000:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Index 0x8000:0A, 0x8000:0B, 0x8000:0C | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Status of extern latch | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync Error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EL5101 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6000:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in Index 0x8000:13 und 0x8000:15) | UINT32 | RO | 0x00000000 (0dez)
6000:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in Index 0x8000:14 und 0x8000:16) | UINT32 | RO | 0x00000000 (0dez)
6000:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |
Index 6010 ENC Inputs (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x16 (22dez)
6010:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Index 0x6010:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7010:01 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Index 0x6010:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7010:02 bzw. Objekt-Index 0x7010:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Index 0x8010:0A, 0x8010:0B, 0x8010:0C | BOOLEAN | RO | 0x00 (0dez)
6010:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6010:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6010:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6010:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Status of extern latch | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync Error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EL5101 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6010:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6010:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in Index 0x8010:13 und 0x8010:15) | UINT32 | RO | 0x00000000 (0dez)
6010:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in Index 0x8010:14 und 0x8010:16) | UINT32 | RO | 0x00000000 (0dez)
6010:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über „Set counter“ (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7010 ENC Outputs (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | ENC Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7010:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Set counter value | Der über „Set counter“ (Index 0x7010:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnosedaten (kanalspezifisch)

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A000 ENC Diag data (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
A000:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)
A000:04 | Field power failure | Fehler Feldbusspannung | BOOLEAN | RO | 0x00 (0dez)
Index A010 ENC Diag data (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A010:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
A010:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A010:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A010:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)


Standardobjekte

Inbetriebnahme [image] EL5101-00x0 [image] Erweiterter Betriebsmodus [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL5101 (EL5101-0010)
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 09
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 10
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED3052 (334311506dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | EL5101-0000: 0x03F90000 (66650112dez) EL5101-0010: 0x0010000A (1048586dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 RxPDO-Par Outputs (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | RxPDO-Par Outputs | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1400 ENC RxPDO-Par Control (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 16
Index 1401 RxPDO-Par Outputs Word-Aligned (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | RxPDO-Par Outputs Word-Aligned | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 16 02 16 03 16
Index 1401 ENC RxPDO-Par Control compact (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 16
Index 1402 ENC RxPDO-Par Control compact (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[6] | RO | 03 16 00 16 01 16
Index 1403 ENC RxPDO-Par Control (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 02 16 00 16 01 16
Index 1600 RxPDO-Map Outputs (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1600 ENC RxPDO-Map Control (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 1 | UINT8 | RO | 0x07 (7dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 32
Index 1601 RxPDO-Map Outputs Word-Aligned (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | RxPDO-Map Outputs Word-Aligned | PDO Mapping RxPDO 2 | UINT8 | RO | 0x03 (3dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1601:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1601 ENC RxPDO-Map Control compact (EL5101-0010)
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7000:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7000:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7000:11, 16
Index 1602 ENC RxPDO-Map Control compact (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1603 ENC RxPDO-Map Control (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 4 | UINT8 | RO | 0x07 (7dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7010:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1800 TxPDO-Par Inputs (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | TxPDO-Par Inputs | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[14] | RO | 01 1A 03 1A 04 1A 05 1A 06 1A 07 1A 08 1A
Index 1800 ENC TxPDO-Par Status (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
1800:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1801 TxPDO-Par Inputs Word-Aligned (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | TxPDO-Par Inputs Word-Aligned | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 03 1A 04 1A 05 1A 06 1A 07 1A 08 1A
Index 1801 ENC TxPDO-Par Status compact (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
1801:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1802 TxPDO-Par Inputs Optional (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | TxPDO-Par Inputs Optional | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[14] | RO | 03 1A 04 1A 05 1A 06 1A 07 1A 08 1A 00 00
Index 1802 ENC TxPDO-Par Period (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[2] | RO | 03 1A
Index 1803 ENC TxPDO-Par Status compact (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[14] | RO | 04 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00
1803:07 | TxPDO-State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1803:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1803 ENC TxPDO-Par Frequency (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[2] | RO | 02 1A
Index 1804 ENC TxPDO-Par Status (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 5 | UINT8 | RO | 0x09 (9dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[14] | RO | 03 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00
1804:07 | TxPDO-State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1804:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1804 ENC TxPDO-Par Timest. (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 05 1A
Index 1805 ENC TxPDO-Par Frequency (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 01 1A 02 1A 06 1A 00 00 00 00 00 00
Index 1805 ENC TxPDO-Par Timest. compact (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
Index 1806 ENC TxPDO-Par Period (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[14] | RO | 00 1A 01 1A 02 1A 05 1A 00 00 00 00 00 00
Index 1807 ENC TxPDO-Par Timest. (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[14] | RO | 08 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00
Index 1808 ENC TxPDO-Par Timest. compact (EL5101-0000)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1808:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 9 | UINT8 | RO | 0x06 (6dez)
1808:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 9 übertragen werden dürfen | OCTET-STRING[14] | RO | 07 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00
Index 1A00 TxPDO-Map Inputs (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (3dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A00 ENC TxPDO-Map Status (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 1 | UINT8 | RO | 0x11 (17dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x0000:00, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:06, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:07, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:0A, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0B, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0C, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0D, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x1C32:20, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1800:07, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1800:09, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1800 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 32
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 32
Index 1A01 TxPDO-Map Inputs Word-Aligned (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | TxPDO-Map Inputs Word-Aligned | PDO Mapping TxPDO 2 | UINT8 | RO | 0x04 (4dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A01 ENC TxPDO-Map Status compact (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x11 (17dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6000:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x0000:00, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6000:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6000:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x0000:00, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6000:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:0A, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6000:0B, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0C, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0D, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x1C32:20, 1
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1801:07, 1
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:09, 1
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x6000:11, 16
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6000:12, 16
Index 1A02 TxPDO-Map Inputs Optional (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Inputs Optional | PDO Mapping TxPDO 3 | UINT8 | RO | 0x03 (3dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x04 (Frequency)) | UINT32 | RO | 0x6000:04, 32
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x05 (Period)) | UINT32 | RO | 0x6000:05, 16
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x06 (Window)) | UINT32 | RO | 0x6000:06, 16
Index 1A02 ENC TxPDO-Map Period (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Period | PDO Mapping TxPDO 3 | UINT8 | RO | 0x01 (1dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6000:14, 32
Index 1A03 ENC TxPDO-Map Status compact (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 4 | UINT8 | RO | 0x12 (18dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1803 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO-State)) | UINT32 | RO | 0x6010:0F, 1
1A03:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1803 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x6010:10, 1
1A03:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A03:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A03 ENC TxPDO-Map Frequency (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Frequency | PDO Mapping TxPDO 4 | UINT8 | RO | 0x01 (1dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6000:13, 32
Index 1A04 ENC TxPDO-Map Status (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 5 | UINT8 | RO | 0x12 (18dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x07 (TxPDO-State)) | UINT32 | RO | 0x6010:0F, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x6010:10, 1
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1A04 ENC TxPDO-Map Timest. (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Timest. | PDO Mapping TxPDO 5 | UINT8 | RO | 0x01 (1dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 64
Index 1A05 ENC TxPDO-Map Frequency (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Frequency | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6010:13, 32
Index 1A05 ENC TxPDO-Map Timest. compact (EL5101-0010)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6000:16, 32
Index 1A06 ENC TxPDO-Map Period (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | ENC TxPDO-Map Period | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6010:14, 32
Index 1A07 ENC TxPDO-Map Timest. (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | ENC TxPDO-Map Timest. | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 64
Index 1A08 ENC TxPDO-Map Timest. compact (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0002 (2dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x02 (2dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FE (510dez)
F010:02 | SubIndex 002 | reserviert | UINT32 | RW | 0x000001FF (511dez)


EL5101-0011

Inbetriebnahme [image] EL5101-0011
EL5101-0011
Weiterführende Informationen
•
Grundlagen zur Oversampling-Funktion
•
Prozessdaten und Konfiguration
•
Objektbeschreibung und Parametrierung


Grundlagen zur Oversampling-Funktion

Inbetriebnahme [image] EL5101-0011 [image] Grundlagen zur Oversampling-Funktion
Grundlagen zur Oversampling-Funktion
Die EtherCAT Klemme EL5101-0011 ist ein Interface zum direkten Anschluss von Inkremental-Encodern mit Differenzeingängen (RS422). Durch die Oversampling-Eigenschaft kann die Klemme mehrmals je Buszyklus den aktuellen Zählerstand erfassen.
Oversampling
Eine herkömmliche Inkremental-Encoder-Interface Klemme erfasst mit jedem Buszyklus einen Zählerstand ("Counter Value") und gibt ihn im nächsten Feldbuszyklus an die übergeordnete Steuerung weiter. Die EL5101-0011 erfasst zwischen zwei Feldbuskommunikationszyklen konfigurierbar und zeitäquidistant mehrmals den aktuellen Zählerstand. Die Übergabe eines Pakets von x Positionswerten von je 32 Bit an die übergeordnete Steuerung findet im nächsten Feldbuskommunikationszyklus statt. Dieses Verfahren wird "Oversampling" genannt.
Distributed Clocks
Für das Oversampling ist ein Taktgeber in der Klemme nötig, der die einzelnen Messwerterfassungen auslöst. Dazu wird die lokale Uhr in der Klemme genutzt, genannt Distributed Clock.
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
In der EL5101-0011 ist ein Umfang von 64 Bit realisiert.
Beispiel:
Der Feldbus/EtherCAT Master wird mit 1 ms Zykluszeit betrieben weil z.B. die übergeordnete SPS mit 1 ms Zykluszeit betrieben wird. Damit wird alle 1 ms ein EtherCAT-Frame zur Abholung der Prozessdaten der EL5101-0011 geschickt. Im ESC (EtherCAT Slave Controller) wird deshalb durch die lokale Uhr in der Klemme alle 1 ms (1 kHz) ein Interrupt ausgelöst, der die Prozessdaten rechtzeitig für den abholenden EtherCAT-Frame bereitstellt. Dieser erste Interrupt wird SYNC1 genannt.
Die EL5101-0011 sei im TwinCAT Systemmanager auf ein Oversampling n = 100 eingestellt. Dadurch generiert der ESC in der Klemme einen zweiten Interrupt mit einer n-fach höheren Frequenz, hier also 100 kHz oder 10 µs Periode. Dieser Interrupt wird SYNC0 genannt. Bei jedem SYNC0-Signal wird der Zählerstand erfasst, diese werden nacheinander in einem Puffer abgelegt. Durch die Generierung des SYNC0-Pulses aus der lokalen synchronisierten Uhr im Distributed-Clocks-Verbund ist gewährleistet, dass die Erfassung des Positionswertes in zeitlich hochkonstant gleichen Abständen mit der Periode des SYNC1-Pulses erfolgt.
Maximale Samplingfrequenz / Minimale Zykluszeit
Eine kleinere Periode als 10 μs ist für die EL5101-0011 nicht zulässig!
Die maximale Samplingfrequenz beträgt für die EL5101-0011 also 100 kSps (Samples per second).
Die minimale Zykluszeit von 500 µs bei einem Oversamplingfaktor von n=50 darf nicht unterschritten werden.
Bei der Berechnung des SYNC0 aus dem SYNC1-Puls durch die manuelle Vorgabe eines Oversamplingfaktors ist darauf zu achten, dass für SYNC0 nur ganzzahlige Werte im Nanosekundenabstand berechnet werden.
Beispiel: 187.500 μs sind zulässig, 333.3 sind nicht zulässig.
Beispiel:
Bei SYNC1 = 1 ms sind Oversamplingfaktoren wie 1,2,5 oder 100 zulässig, nicht aber 3! Wird mit unplausiblen Werten gearbeitet, erreicht die Klemme zwar den OP-State, liefert aber keine Prozessdaten.
Dies drückt sich ggf. auch durch einen Working Counter Error aus.
Die im Puffer gesammelten Messwerte von je 32 bit Umfang werden als Paket an die übergeordnete Steuerung übergeben.
Zeitbezogene Zusammenarbeit mit anderen Klemmen
Die Messwerterfassung in der EL5101-0011 wird durch einen Interrupt ausgelöst, der von der lokalen Uhr in der Klemme generiert wird. Alle lokalen Uhren in den unterstützenden EtherCAT-Slaves sind synchronisiert. Dadurch ist es möglich, EtherCAT-Slaves (hier: Klemmen) unabhängig von ihrer jeweiligen Entfernung untereinander gleichzeitig ihre Messwerte erfassen zu lassen (gleichzeitige Interrupterzeugung). Diese Gleichzeitigkeit liegt im Rahmen der Distributed-Clocks-Genauigkeit von < 100 ns.
Beispiel:
Abstimmung zweier EL5101-0011 untereinander:
Der EtherCAT Master wie z. B. Beckhoff TwinCAT konfiguriert beide EL5101-0011 so, dass ihre SYNC1 zum gleichen Zeitpunkt auftreten. Annahme: die EtherCAT-Buszykluszeit ist 500 μs. Somit wird der SYNC1 in allen EL5101-0011 alle 500 μs ausgelöst. Wenn beide Klemmen mit einem übereinstimmenden Oversamplingfaktor (z. B. 20) arbeiten, wird auch der mit dem SYNC1 korrelierende SYNC0-Puls in allen EL5101-0011 zur gleichen Zeit auftreten, hier also alle 25 μs. Werden in den eingesetzten EL5101-0011 verschiedene Oversamplingfaktoren verwendet, treten deren SYNC0-Pulse nicht mehr gleichzeitig auf. Der übergeordnete SYNC1-Puls bleibt bestehen.
Zeitstempel der Prozessdaten
Die EL5101-0011 bietet einen "Zeitstempel" für jeden Prozessdatenblock. Dieses Prozessdatum ist als StartTimeNextLatch durch die Aktivierung von 0x1A01 im Reiter Prozessdaten als 64-Bit-Wert im Default bereits aktiviert, siehe auch die Seite Prozessdaten.
Dabei ist der in jedem Zyklus übertragene Datenblock Samplewerte+Zeitstempel nicht zusammenhörig, wie der Name schon nahe legt. Der Zusammenhang ist in Abb. Zeitlicher Zusammenhang SYNC-Signale und SyncManager-Interrupt dargestellt.
Zur Erläuterung:
▪
dargestellt ist ein Beispiel für Oversamplingfaktor n = 100
▪
das SYNC0-Signal in der Klemme füllt den internen Puffer mit 100 Positionswerten
▪
Synchron mit der Zykluszeit läuft SYNC1, der die Bereitstellung des gefüllten Puffer als Prozessdatum auslöst und gleichzeitig den StartTimeNextLatch aus der lokalen DistributedClock holt
▪
dabei wird das data array zusammen mit der nächsten SYNC1 Time zusammengestellt
▪
der nächste EtherCAT-Zyklus holt diese Daten ab.
Zeitlicher Zusammenhang SYNC-Signale und SyncManager-Interrupt


Prozessdaten und Konfiguration

Inbetriebnahme [image] EL5101-0011 [image] Prozessdaten und Konfiguration
Prozessdaten und Konfiguration
Die Grundlagen zur Oversampling-Funktion und die Funktionsweise der EL5101-0011 mit dem Einsatz des SYNC0- und SYNC1-Pulses wird im Abschnitt "Grundlagen zur Oversampling Funktion" erläutert.
Im Folgenden Kapitel werden die Einstellung der verschiedenen Parameter mit dem Beckhoff TwinCAT System Manager beschrieben. Die EL5101-0011 bietet folgende Prozessdaten:
Abbildung mit PDOs
Oversampling-Einstellungen, Distributed Clocks (DC)
Im Reiter "DC" (s. Abb. Karteireiter Prozessdaten) kann der Oversamplingfaktor eingestellt werden. Im Auslieferungszustand ist der Oversamplingfaktor n=1 eingestellt. Durch die Anwahl eines Eintrages im Auswahldialog wird automatisch sowohl das richtige Erfassungsverhältnis auf Distributed-Clocks-Ebene, als auch die korrekte Anzahl der zu übertragenden Prozessdaten eingestellt.
Samplingfrequenz
Wird ein Oversamplingfaktor benötigt, der nicht in der Liste aufgeführt ist, obliegt es dem Anwender, mit den Information aus "Grundlagen zur Funktion" den SYNC0-Puls in die gewünschte Relation zum SYNC1-Puls innerhalb der zulässigen Grenzen zu setzen. Siehe dazu das Beispiel XXX.
Es gelten folgende Samplingzeiten:
Sampling-Zeiten
"StartTimeNextLatch"
Das Prozessdatum „StartTimeNextLatch“ (Index 1A01) ist per default aktiviert. Im 32Bit breiten Prozessdatum StartTimeNextLatch wird in jedem Prozessdatenzyklus der Zeitpunkt angegeben, wann der nächste SYNC1-Puls und damit der nächste Block an Sample-Werten beginnt. StartTimeNextLatch verändert sich also in jedem Zyklus um den Betrag derjenigen Taskzykluszeit, mit der diese Klemme betrieben wird. Diese Zeitangabe basiert auf der klemmenlokalen Distributed Clocks Zeit. Die EL5101-0011 bildet nur die 64 Bit großen Distributed Clocks Zeit ab.
Durch diese Zeitangabe können mit dem bekannten Oversamplingfaktor alle Samples zeitlich mit anderen Zeitangaben im EtherCAT-Bus in Zusammenhang gebracht werden.
Beispiel:
Die EL5101-0011 liefert im betrachteten Zyklus bei 1 ms Zykluszeit (= 1.000.000 ns) und Oversamplingfaktor = 20 als Prozessdaten ein StartTimeNextLatch = 503.330.625.067.077.000dez und 20 Messwerte (Counter Value) zu je 32 Bit. Es soll nun der Messzeitpunkt des 5. gelieferten Positionswertes ermittelt werden, d.h. um welche Distributed Clocks Zeit der 5. Positionswert ermittelt wurde.
Der aktuell gelieferte Satz von 20 Counter Values wurde zum Zeitpunkt:
503.330.625.067.077.000 - 1.000.000 (Zykluszeit) = 503.330.625.066.077.000 ns gestartet.
Der Zeitabstand zwischen den Samples beträgt 1.000.000 / 20 = 50.000 ns.
Der 5. Positionswert wurde also zum Zeitpunkt 503.330.625.066.077.000 + ((5 - 1) * 50.000) = 503.330.625.066.027.000 ns ermittelt.
Spezieller Oversamplingfaktor und "Shift-Time" für den SYNC0-Puls
Hinweis
VORSICHT! Beschädigung der Geräte möglich!
Bei der Manipulation dieser Einstellungen im System Manager wird softwareseitig keine Plausibilitätskontrolle durchgeführt!
Eine korrekte Funktion der Klemme in allen denkbaren Einstellungsvarianten kann nicht gewährleistet werden!
Zählerstand setzten - Referenzieren:
Da Inkrementalgeber nach dem Einschalten keine eindeutige Positionsangabe liefern, sollte eine Referenzfahrt durchgeführt werden.
Die EL5101-0011 bietet die Möglichkeit, den Referenzpunkt manuell über "Set counter " (Index 0x7000:03) zu setzen.
"Set counter " (Index 0x7000:03)
▪
In "Set counter value " (Index 0x7000:11) wird der Wert geschrieben, der als Referenzwert gesetzt werden soll (Default: 0).
▪
Die Funktion wird aktiviert, indem das Bit in "Set counter" (Index 0x7000:03) auf TRUE gesetzt wird.
▪
Der Wert aus "Set counter value " (Index 0x7000:11) wird in "counter value " (Index 0x6000:11) geschrieben.
▪
Der Wert des Bits in "Set counter done" (Index 0x6000:03) wird auf TRUE gesetzt.
▪
Erst wenn der Wert des "Set counter done" - Bit (Index 0x6000:03) FALSE ist, kann nach erneuter Aktivierung von "Set counter" (Index 0x7000:03) der nächste Referenzwert in "counter value " (Index 0x6000:11) geschrieben werden.
Drahtbrucherkennung / Open circuit detection
▪
Für die Kanäle A, B und C kann jeweils separat eine Drahtbrucherkennung aktiviert werden (Index 0x8000:0B, 0x8000:0C, 0x8000:0D).
▪
per Default ist die Drahtbrucherkennung für die Kanäle A und B aktiviert.
▪
Eine differentielle Spannung -0,475 V > Vid >+0,475V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert.
▪
Ein erkannter Drahtbruch wird als Prozessdatum „Open circuit =TRUE“ angezeigt Bit in Objekt 0x60n0:07 gesetzt; die separate Anzeige eines Drahtbruchs wird in den Indizes 0xA000:01 (Spur A), 0xA000:02 (Spur B) und 0xA000:03 (Spur C) angezeigt.
▪
„TxPDO State“ wird bei einem erkannten Drahtbruch ebenfalls TRUE, da von ungültigen Daten ausgegangen werden muss.
Weiterhin bietet die EL5101-0011 folgende zyklischen Informationen:
Variable | Bedeutung
Sync error | Im DC Mode: zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der Klemme ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok).
TxPDO State | Zeigt an ob ein Fehler aufgetreten ist (=TRUE). Wird interner Fehler detektiert oder ein Open Circuit gemeldet, so wird TxPDO State auf TRUE gesetzt, da von ungültigen Daten ausgegangen werden muss.
DcOutputShift, DcInputShift | In diesen statischen Variablen gibt der System Manager bekannt, auf welche ShiftZeit diese Klemme eingestellt worden ist. Der Wert wird einmalig beim Aktivieren/Berechnen der Konfiguration festgelegt und ist auch von den kundenspezifischen Einstellungen in den erweiterten Slave-Einstellungen abhängig. Er kann zu Offsetberechnungen in der PLC verlinkt werden.
StartTimeNextLatch | Siehe unter „StartTimeNextLatch“ Kapitel


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 ENC Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x0E (14dez)
8000:01 | Enable C reset | Ein Reset des Zählers erfolgt über den C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8000:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Index 0x6000:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)


Eingangsdaten

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 6000 ENC Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x19 (25dez)
6000:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Index 8000:0A, 8000:0B, 8000:0C | BOOLEAN | RO | 0x00 (0dez)
6000:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync Error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EL5101 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6000:19 | StartTimeNextLatch |  | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 7000 ENC Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | ENC Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7000:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Set counter value | Der über „Set counter“ (Index 0x7000:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnosedaten (kanalspezifisch)

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A000 ENC Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
A000:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A000:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A000:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)
A000:04 | Field power failure | Fehler Feldbusspannung | BOOLEAN | RO | 0x00 (0dez)


Standardobjekte

Inbetriebnahme [image] EL5101-0011 [image] Objektbeschreibung und Parametrierung [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL5101-0011
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | -
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | -
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED3052 (334311506dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 ENC RxPDO-Map Control
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x0000:00, 2
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7000:03, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x0000:00, 13
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7000 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7000:11, 32
Index 1810 ENC TxPDO-Par TxPdo 1 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1810:0 | ENC TxPDO-Par TxPdo 1 Samples Counter value | PDO Parameter TxPDO 17 | UINT8 | RO | 0x06 (6dez)
1810:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 17 übertragen werden dürfen | OCTET-STRING[28] | RO | 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1811 ENC TxPDO-Par TxPdo 2 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1811:0 | ENC TxPDO-Par TxPdo 2 Samples Counter value | PDO Parameter TxPDO 18 | UINT8 | RO | 0x06 (6dez)
1811:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 18 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1812 ENC TxPDO-Par TxPdo 4 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1812:0 | ENC TxPDO-Par TxPdo 4 Samples Counter value | PDO Parameter TxPDO 19 | UINT8 | RO | 0x06 (6dez)
1812:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 19 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1813 ENC TxPDO-Par TxPdo 5 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1813:0 | ENC TxPDO-Par TxPdo 5 Samples Counter value | PDO Parameter TxPDO 20 | UINT8 | RO | 0x06 (6dez)
1813:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 20 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1814 ENC TxPDO-Par TxPdo 8 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1814:0 | ENC TxPDO-Par TxPdo 8 Samples Counter value | PDO Parameter TxPDO 21 | UINT8 | RO | 0x06 (6dez)
1814:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 21 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1815 ENC TxPDO-Par TxPdo 10 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1815:0 | ENC TxPDO-Par TxPdo 10 Samples Counter value | PDO Parameter TxPDO 22 | UINT8 | RO | 0x06 (6dez)
1815:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 22 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1816 ENC TxPDO-Par TxPdo 16 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1816:0 | ENC TxPDO-Par TxPdo 16 Samples Counter value | PDO Parameter TxPDO 23 | UINT8 | RO | 0x06 (6dez)
1816:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 23 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1817 ENC TxPDO-Par TxPdo 20 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1817:0 | ENC TxPDO-Par TxPdo 20 Samples Counter value | PDO Parameter TxPDO 24 | UINT8 | RO | 0x06 (6dez)
1817:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 24 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1818 ENC TxPDO-Par TxPdo 25 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1818:0 | ENC TxPDO-Par TxPdo 25 Samples Counter value | PDO Parameter TxPDO 25 | UINT8 | RO | 0x06 (6dez)
1818:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 25 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 1819 ENC TxPDO-Par TxPdo 32 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1819:0 | ENC TxPDO-Par TxPdo 32 Samples Counter value | PDO Parameter TxPDO 26 | UINT8 | RO | 0x06 (6dez)
1819:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 26 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 1A 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 181A ENC TxPDO-Par TxPdo 40 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
181A:0 | ENC TxPDO-Par TxPdo 40 Samples Counter value | PDO Parameter TxPDO 27 | UINT8 | RO | 0x06 (6dez)
181A:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 27 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1B 1A 1C 1A 1D 1A 1E 1A
Index 181B ENC TxPDO-Par TxPdo 50 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
181B:0 | ENC TxPDO-Par TxPdo 50 Samples Counter value | PDO Parameter TxPDO 28 | UINT8 | RO | 0x06 (6dez)
181B:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 28 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1C 1A 1D 1A 1E 1A
Index 181C ENC TxPDO-Par TxPdo 64 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
181C:0 | ENC TxPDO-Par TxPdo 64 Samples Counter value | PDO Parameter TxPDO 29 | UINT8 | RO | 0x06 (6dez)
181C:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 29 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1D 1A 1E 1A
Index 181D ENC TxPDO-Par TxPdo 80 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
181D:0 | ENC TxPDO-Par TxPdo 80 Samples Counter value | PDO Parameter TxPDO 30 | UINT8 | RO | 0x06 (6dez)
181D:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 30 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1E 1A
Index 181E ENC TxPDO-Par TxPdo 100 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
181E:0 | ENC TxPDO-Par TxPdo 100 Samples Counter value | PDO Parameter TxPDO 31 | UINT8 | RO | 0x06 (6dez)
181E:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 31 übertragen werden dürfen | OCTET-STRING[28] | RO | 10 1A 11 1A 12 1A 13 1A 14 1A 15 1A 16 1A 17 1A 18 1A 19 1A 1A 1A 1B 1A 1C 1A 1D 1A
Index 1A00 ENC TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0C (12dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x0000:00, 2
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6000:03, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x0000:00, 3
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x0000:00, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6000:09, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x6000:0A, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6000:0B, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x0000:00, 2
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6000:0E, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6000:0F, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6000:10, 1
Index 1A01 ENC TxPDO-Map NextSync1Time
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map NextSync1Time | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6000:19, 64
Index 1A10 ENC TxPDO-Map TxPdo 1 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | ENC TxPDO-Map TxPdo 1 Samples Counter value | PDO Mapping TxPDO 17 | UINT8 | RO | 0x01 (1dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A11 ENC TxPDO-Map TxPdo 2 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A11:0 | ENC TxPDO-Map TxPdo 2 Samples Counter value | PDO Mapping TxPDO 18 | UINT8 | RO | 0x02 (2dez)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A12 ENC TxPDO-Map TxPdo 4 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A12:0 | ENC TxPDO-Map TxPdo 4 Samples Counter value | PDO Mapping TxPDO 19 | UINT8 | RO | 0x04 (4dez)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A13 ENC TxPDO-Map TxPdo 5 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A13:0 | ENC TxPDO-Map TxPdo 5 Samples Counter value | PDO Mapping TxPDO 20 | UINT8 | RO | 0x05 (5dez)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A14 ENC TxPDO-Map TxPdo 8 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A14:0 | ENC TxPDO-Map TxPdo 8 Samples Counter value | PDO Mapping TxPDO 21 | UINT8 | RO | 0x08 (8dez)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A15 ENC TxPDO-Map TxPdo 10 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | ENC TxPDO-Map TxPdo 10 Samples Counter value | PDO Mapping TxPDO 22 | UINT8 | RO | 0x0A (10dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A15:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A16 ENC TxPDO-Map TxPdo 16 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A16:0 | ENC TxPDO-Map TxPdo 16 Samples Counter value | PDO Mapping TxPDO 23 | UINT8 | RO | 0x10 (16dez)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A16:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A17 ENC TxPDO-Map TxPdo 20 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A17:0 | ENC TxPDO-Map TxPdo 20 Samples Counter value | PDO Mapping TxPDO 24 | UINT8 | RO | 0x14 (20dez)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A17:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A18 ENC TxPDO-Map TxPdo 25 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A18:0 | ENC TxPDO-Map TxPdo 25 Samples Counter value | PDO Mapping TxPDO 25 | UINT8 | RO | 0x19 (25dez)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A18:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A19 ENC TxPDO-Map TxPdo 32 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A19:0 | ENC TxPDO-Map TxPdo 32 Samples Counter value | PDO Mapping TxPDO 26 | UINT8 | RO | 0x20 (32dez)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A19:20 | SubIndex 032 | 32. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A1A ENC TxPDO-Map TxPdo 40 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1A:0 | ENC TxPDO-Map TxPdo 40 Samples Counter value | PDO Mapping TxPDO 27 | UINT8 | RO | 0x28 (40dez)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A1A:28 | SubIndex 040 | 40. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A1B ENC TxPDO-Map TxPdo 50 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1B:0 | ENC TxPDO-Map TxPdo 50 Samples Counter value | PDO Mapping TxPDO 28 | UINT8 | RO | 0x32 (50dez)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A1B:32 | SubIndex 050 | 50. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A1C ENC TxPDO-Map TxPdo 64 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1C:0 | ENC TxPDO-Map TxPdo 64 Samples Counter value | PDO Mapping TxPDO 29 | UINT8 | RO | 0x40 (64dez)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A1C:40 | SubIndex 064 | 64. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A1D ENC TxPDO-Map TxPdo 80 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1D:0 | ENC TxPDO-Map TxPdo 80 Samples Counter value | PDO Mapping TxPDO 30 | UINT8 | RO | 0x50 (80dez)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A1D:50 | SubIndex 080 | 80. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1A1E ENC TxPDO-Map TxPdo 100 Samples Counter value
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | ENC TxPDO-Map TxPdo 100 Samples Counter value | PDO Mapping TxPDO 31 | UINT8 | RO | 0x64 (100dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
… | … | … | … | … | ..
1A1E:64 | SubIndex 100 | 100. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6000:11, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Min. delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
Mit diesem Eintrag kann eine Messung der real benötigten Prozessdatenbereitstellungszeit durchgeführt werden.
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0000 (0dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Min. delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Max. delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x01 (1dez)
F010:01 | SubIndex 001 | Profil 511 | UINT32 | RW | 0x000001FF (511dez)
Index F082 MDP Profile Compatibility
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F082:0 | MDP Profile Compatibility | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
F082:01 | Compatible input cycle counter | - | BOOLEAN | RW | 0x00 (0dez)


EL5101-0090

Inbetriebnahme [image] EL5101-0090
EL5101-0090
Die EL5101-0090 unterstützt den vollen Funktionsumfang der EL5101-00x0 (lesen Sie bitte hierzu das Kapitel EL5101-00x0).
Zusätzlich unterstützt die EL5101-0090 die TwinSAFE SC Technologie.
Weiterführende Informationen
•
TwinSAFE SC
•
Prozessdaten und Betriebsmodi
•
Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
•
Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus
•
Objekte TwinSAFE Single Channel (EL5101-0090)


TwinSAFE SC

Inbetriebnahme [image] EL5101-0090 [image] TwinSAFE SC
TwinSAFE SC
Weiterführende Informationen
•
TwinSAFE SC - Funktionsprinzip
•
TwinSAFE SC - Konfiguration
•
TwinSAFE SC Prozessdaten EL5101-0090


TwinSAFE SC - Funktionsprinzip

Inbetriebnahme [image] EL5101-0090 [image] TwinSAFE SC [image] TwinSAFE SC - Funktionsprinzip
TwinSAFE SC - Funktionsprinzip
Mithilfe der TwinSAFE-SC-Technologie (TwinSAFE Single Channel) ist es möglich, in beliebigen Netzwerken bzw. Feldbussen Standardsignale für sicherheitstechnische Aufgaben nutzbar zu machen. Dazu werden EtherCAT-I/Os aus dem Bereich Analog-Eingang, Winkel-/Wegmessung oder Kommunikation (4…20 mA, Inkremental-Encoder, IO-Link usw.) um die TwinSAFE-SC-Funktion erweitert. Die signaltypischen Eigenschaften und Standard-Funktionalitäten der I/O-Komponenten bleiben dabei erhalten.
TwinSAFE-SC-I/Os unterscheiden sich optisch von Standard-I/Os durch einen gelben Streifen auf der Gehäusefront.
Die TwinSAFE-SC-Technologie ermöglicht eine Kommunikation über ein TwinSAFE-Protokoll. Diese Verbindungen können von der üblichen sicheren Kommunikation über Safety-over-EtherCAT unterschieden werden.
Die Daten der TwinSAFE-SC-Komponenten werden über ein TwinSAFE-Protokoll zu der TwinSAFE-Logic geleitet und können dort im Kontext sicherheitsrelevanter Applikationen verwendet werden. Detaillierte und durch den TÜV SÜD bestätigte/berechnete Beispiele zur korrekten Anwendung der TwinSAFE-SC-Komponenten und der jeweiligen normativen Klassifizierung können dem TwinSAFE-Applikationshandbuch entnommen werden.


TwinSAFE SC - Konfiguration

Inbetriebnahme [image] EL5101-0090 [image] TwinSAFE SC [image] TwinSAFE SC - Konfiguration
TwinSAFE SC - Konfiguration
Die TwinSAFE-SC-Technologie ermöglicht eine Kommunikation mit Standard-EtherCAT-Klemmen über das Safety-over-EtherCAT-Protokoll. Diese Verbindungen verwenden eine andere Prüfsumme, um TwinSAFE SC von TwinSAFE unterscheiden zu können. Es sind acht feste CRCs auswählbar, oder es kann auch eine freie CRC durch den Anwender eingegeben werden.
Per default ist der TwinSAFE-SC-Kommunikationskanal der jeweiligen TwinSAFE-SC-Komponente nicht aktiviert. Um die Datenübertragung nutzen zu können, muss zunächst unter dem Reiter Slots das entsprechende TwinSAFE-SC-Modul hinzugefügt werden. Erst danach ist eine Verlinkung auf ein entsprechendes Alias-Device möglich.
Hinzufügen der TwinSAFE-SC-Prozessdaten unterhalb der Komponente z.B. EL5021-0090
Es werden zusätzliche Prozessdaten mit der Kennzeichnung TSC Inputs, TSC Outputs generiert (TSC - TwinSAFE Single Channel).
Prozessdaten TwinSAFE SC Komponente (iankfd11.png)
Prozessdaten TwinSAFE SC Komponente, Beispiel EL5021-0090
Durch Hinzufügen eines Alias Devices in dem Safety-Projekt und Auswahl von TSC (TwinSAFE Single Channel) wird eine TwinSAFE-SC-Verbindung hinzugefügt.
Hinzufügen einer TwinSAFE-SC-Verbindung
Nach Öffnen des Alias Devices durch Doppelklick kann durch Auswahl des Link Buttons Grafik aus Konfiguration TwinSAFE SC (iak9opa.png) neben Physical Device: die Verknüpfung zu einer TwinSAFE-SC-Klemme erstellt werden. In dem Auswahldialog werden nur passende TwinSAFE-SC-Klemmen angeboten.
Grafik aus Konfiguration TwinSAFE SC (i8d09251.png)
Erstellen einer Verknüpfung zu einer TwinSAFE-SC-Klemme
Unter dem Reiter Connection des Alias Devices wird die zu verwendende CRC ausgewählt bzw. eine freie CRC eingetragen.
Eintrag Mode | Verwendete CRCs
TwinSAFE SC CRC 1 master | 0x17B0F
TwinSAFE SC CRC 2 master | 0x1571F
TwinSAFE SC CRC 3 master | 0x11F95
TwinSAFE SC CRC 4 master | 0x153F1
TwinSAFE SC CRC 5 master | 0x1F1D5
TwinSAFE SC CRC 6 master | 0x1663B
TwinSAFE SC CRC 7 master | 0x1B8CD
TwinSAFE SC CRC 8 master | 0x1E1BD
Auswahl einer freien CRC
Diese Einstellungen müssen zu den Einstellungen passen, die in den CoE-Objekten der TwinSAFE-SC-Komponente eingestellt sind.
Die TwinSAFE-SC-Komponente stellt zunächst alle zur Verfügung stehenden Prozessdaten bereit. Der Reiter Safety Parameters enthält typischerweise keine Parameter. Unter dem Reiter Process Image kann die Prozessdatengröße bzw. die Prozessdaten selbst ausgewählt werden.
Auswahl der Prozessdatengröße bzw. der Prozessdaten
Die Prozessdaten (definiert in der ESI-Datei) können durch Auswahl des Buttons Edit entsprechend den Anwenderanforderungen im Dialog Configure I/O element(s) eingestellt werden.
Auswahl der Prozessdaten
Auf der TwinSAFE-SC-Slave-Seite muss die Safety-Adresse zusammen mit der CRC eingetragen werden. Dies geschieht über die CoE Objekte unterhalb von TSC Settings der entsprechenden TwinSAFE-SC-Komponente (hier bei der EL5021-0090 z.B. 0x8010:01 und 0x8010:02). Die hier eingestellte Adresse muss auch im Alias Device unter dem Reiter Linking als FSoE Adresse eingestellt werden.
Unter dem Objekt 0x80n0:02 Connection Mode wird die zu verwendende CRC ausgewählt bzw. eine freie CRC eingetragen. Es stehen insgesamt 8 CRCs zur Verfügung. Eine freie CRC muss im High Word mit 0x00ff beginnen.
Grafik aus Konfiguration TwinSAFE SC (iv9tkmo3.png)
CoE Objekte 0x8010:01 und 0x8010:02 bei der EL5021-0090
Objekt TSC Settings
Die Index-Bezeichnung des Konfigurationsobjekts TSC Settings kann je nach Klemme unterschiedlich sein.
Beispiel:
- EL3214-0090 und EL3314-0090, TSC Settings, Index 8040
- EL5021-0090, TSC Settings, Index 8010
- EL6224-0090, TSC Settings, Index 800F
Grafik aus Konfiguration TwinSAFE SC (isvth0a2.png)
Eintragen der Safety-Adresse und der CRC
TwinSAFE-SC-Verbindungen
Werden mehrere TwinSAFE-SC-Verbindungen innerhalb einer Konfiguration verwendet, muss für jede TwinSAFE-SC-Verbindung eine unterschiedliche CRC ausgewählt werden.


TwinSAFE SC Prozessdaten EL5101-0090

Inbetriebnahme [image] EL5101-0090 [image] TwinSAFE SC [image] TwinSAFE SC Prozessdaten EL5101-0090
TwinSAFE SC Prozessdaten EL5101-0090
Die EL5101-0090 überträgt folgende Prozessdaten an die TwinSAFE Logik:
Index (hex) | Name | Type | Größe
6010:1D | Counter value (uint16) | UINT | 2.0
6010:11 | Counter value | UDINT | 4.0
6010:13 | Frequency value | UDINT | 4.0
6010:14 | Period value | UDINT | 4.0
6010:1C | Frequency value (uint16) | UINT | 2.0
6010:1E | Period value (uint16) | UINT | 2.0
Dabei wird der Counter value (uint16) (0x6010:1D) als Defaultwert übertragen. Über den Reiter „Process Image“ können im Safety Editor weitere Prozessdaten aus- oder ganz abgewählt werden.
Abhängig von der TwinCAT 3.1 Version können Prozessdaten bei der Verlinkung zum Safety Editor automatisch umbenannt werden.
TwinSAFE SC Objekte
Die Übersicht zu TwinSAFE SC Objekten der EL5101-0090 finden Sie im Kapitel Objekte TwinSAFE Single Channel (EL5101-0090).


Prozessdaten und Betriebsmodi

Inbetriebnahme [image] EL5101-0090 [image] Prozessdaten und Betriebsmodi
Prozessdaten und Betriebsmodi
Angaben zu Prozessdaten und Betriebsmodi finden Sie im Kapitel EL5101-00x0.


Objektbeschreibung und Parametrierung - Normaler Betriebsmodus

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
Objektbeschreibung und Parametrierung - Normaler Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt, s.u.) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8000 Non-Volatile Settings 0
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | Non-Volatile Settings 0 | Maximaler Subindex | UINT8 | RO | 0x05 (5dez)
8000:01 | Enable register reload | Der Zähler zählt bis zum "Counter reload value" bzw. wird bei einem Unterlauf mit dem "Counter reload value" (0x8001:02) geladen Beispiel 360° Encoder bei gesetztem Bit: Fahrt in positiver Richtung über Counter reload value: Reset Zählerstand auf 0. Fahrt in negativer Richtung unter 0: Reset Zählerstand auf Counter reload value. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Enable index reset | Aktiviert den Eingang "C" zum Zurücksetzen des Zählers. Beispiel 360° Encoder bei gesetztem Bit: Fahrt in positiver Richtung (Signal an Eingang "C"): Reset Zählerstand auf 0 Fahrt in negativer Richtung (Signal an Eingang "C"): Underflow mit FFFF, FFFE, usw.) | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Enable FWD count | FALSE Die Klemme arbeitet im Quadratur-Decoder Modus TRUE Die Klemme arbeitet als Zähler, Zählrichtung nach Eingang B | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Enable pos. gate | Gate-Eingang reagiert auf Positiv-Flanke und sperrt den Zähler | BOOLEAN | RW | 0x01 (1dez)
8000:05 | Enable neg. gate | Gate Eingang reagiert auf Negativ-Flanke und sperrt den Zähler | BOOLEAN | RW | 0x00 (0dez)
Index 8001 Non-Volatile Settings 1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8001:0 | Non-Volatile Settings 1 | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
8001:01 | Frequency window | Wert gibt die Größe des Zeitfensters für die Variable "Window" an. Auflösung: 16 µs; z. B. Defaultwert: 16 µs x 100dez = 1,6 ms | UINT16 | RW | 0x0064 (100dez)
8001:02 | Counter reload value | Wenn "Enable register reload" = TRUE, zählt der Zähler bis zu diesem Wert bzw. wird bei einem Unterlauf mit diesem Wert geladen | UINT16 | RW | 0xFFFF (65535dez)


Eingangsdaten

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6000 Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Inputs | Länge dieses Objekts | UINT8 | RO | 0x06 (6dez)
6000:01 | Status | Status-Byte | UINT8 | RO | 0x00 (0dez)
6000:02 | Value | Zählerstand | UINT16 | RO | 0x0000 (0dez)
6000:03 | Latch | Latch-Wert | UINT16 | RO | 0x0000 (0dez)
6000:04 | Frequency | Frequenzwert (Auflösung: 0,01 Hz / digit) [festes 10 ms Messfenster] | UINT32 | RO | 0x00000000 (0dez)
6000:05 | Period | Periodendauer (Auflösung 500 ns / digit) | UINT16 | RO | 0x0000 (0dez)
6000:06 | Window | Messwert des variablen Zeitfensters ( "Frequency Window" (0x8001:01)) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7000 Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | Outputs | Länge dieses Objekts | UINT8 | RO | 0x02 (2dez)
7000:01 | Ctrl | Control-Byte | UINT8 | RO | 0x00 (0dez)
7000:02 | Value | Der über „CNT_SET“ (CB.02) zu setzende Zählerstand. | UINT16 | RO | 0x0000 (0dez)


Standardobjekte

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Normaler Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL5101-0090
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 09
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 10
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED3052 (334311506dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1600 RxPDO-Map Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1601 RxPDO-Map Outputs Word-Aligned
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | RxPDO-Map Outputs Word-Aligned | PDO Mapping RxPDO 2 | UINT8 | RO | 0x03 (3dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1601:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1A00 TxPDO-Map Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (3dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A01 TxPDO-Map Inputs Word-Aligned
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | TxPDO-Map Inputs Word-Aligned | PDO Mapping TxPDO 2 | UINT8 | RO | 0x04 (4dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A02 TxPDO-Map Inputs Optional
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Inputs Optional | PDO Mapping TxPDO 3 | UINT8 | RO | 0x03 (3dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x04 (Frequency)) | UINT32 | RO | 0x6000:04, 32
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x05 (Period)) | UINT32 | RO | 0x6000:05, 16
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x06 (Window)) | UINT32 | RO | 0x6000:06, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1610 (5648dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC807 (51207dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000103C4 (66500dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)


Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus
Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnosedaten (kanalspezifisch)
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Wiederherstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. Hinweis: manche FW-Ausgaben akzeptieren auch auf die Eingabe "0x6C6F6164". | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Konfigurationsdaten
Konfigurationsdaten
Index 8010 ENC Settings (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | ENC Settings | Maximaler Subindex | UINT8 | RO | 0x17 (23dez)
8010:01 | Enable C reset | Ein Reset des Zählers erfolgt über den C-Eingang. | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Enable extern reset | Ein Reset des Zählers erfolgt über den externen Latch Eingang (24 V) | BOOLEAN | RW | 0x00 (0dez)
8010:03 | Enable up/down counter | Freigabe des V/R-Zählers an Stelle des Encoders bei gesetztem Bit. Gezählt werden Inkremente am Eingang A, Zählrichtung gibt Eingang B vor. | BOOLEAN | RW | 0x00 (0dez)
8010:04 | Gate polarity | 0: Disable gate 1: Enable pos. gate (Gate sperrt mit "HIGH"-Pegel) 2: Enable neg. gate (Gate sperrt mit "LOW"-Pegel) | BIT2 | RW | 0x01 (1dez)
8010:08 | Disable filter | 0: Aktiviert Eingangsfilter (nur Eingänge A, /A, B, /B, C, /C) 1: Deaktiviert Eingangsfilter Bei aktiviertem Filter muss eine Signalflanke mind. 2,4 µs anliegen um als Inkrement gezählt zu werden. | BOOLEAN | RW | 0x01 (1dez)
8010:0A | Enable micro increments | Bei Aktivierung interpoliert die EL5101 im DC-Modus zwischen die ganzzahligen Encoderinkremente Microincremente hinein. Zur Anzeige werden die jeweils unteren 8 Bit des Counter-Value benutzt. Aus einem 32-Bit-Zähler wird so ein 24+8 Bit Zähler, aus einem 16-Bit-Zähler ein 8+8 Bit Zähler. | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Open circuit detection A | Ein Drahtbruch auf der A-Spur wird im Index 0x6010:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8010:0C | Open circuit detection B | Ein Drahtbruch auf der B-Spur wird im Index 0x6010:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x01 (1dez)
8010:0D | Open circuit detection C | Ein Drahtbruch auf der C-Spur wird im Index 0x6010:07 und als Prozessdatum angezeigt. Diagnose ist nur möglich, wenn der entsprechende Eingang differentiell verdrahtet ist - Eine differentielle Spannung < 3.5 V (typ., Änderungen vorbehalten) wird als Drahtbruch detektiert. | BOOLEAN | RW | 0x00 (0dez)
8010:0E | Reversion of rotation | Aktiviert die Drehrichtungsumkehr | BOOLEAN | RW | 0x00 (0dez)
8010:10 | Extern reset polarity | 0: Fall (mit der fallenden Flanke wird der Zähler auf null gesetzt) 1: Rise (mit der steigenden Flanke wird der Zähler auf null gesetzt) | BIT1 | RW | 0x01 (1dez)
Index 8010 ENC Settings (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8010:11 | Frequency window | Dies ist die minimale Zeit, über die die Frequenz ermittelt wird Standardwert 10 ms [Auflösung: 1 µs] Es wird die Anzahl der Pulse im Zeitfenster + dem nächsten folgenden gemessen. Dabei wird max. "Frequency Wait Time" lang gewartet. Die Anzahl der Impulse wird dann durch die tatsächliche Zeitfenstergröße geteilt. Die ermittelte Frequenz wird in Index 0x6010:13 und als Prozessdatum ausgegeben. Die Frequenzberechnung wird lokal ausgeführt und nutzt keine Distributed-Clocks-Funktion. | UINT16 | RW | 0x2710 (10000dez)
8010:13 | Frequency scaling | Skalierung der Frequenzmessung (durch diesen Wert muss dividiert werden, damit man die Einheit in Hz erhält): 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8010:14 | Period scaling | Auflösung der Periodendauer im Prozessdatum: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns | UINT16 | RW | 0x0064 (100dez)
8010:15 | Frequency resolution | Auflösung der Frequenzmessung: 100: "0,01 Hz" | UINT16 | RW | 0x0064 (100dez)
8010:16 | Period resolution | Interne Auflösung der Periodendauermessung: 100: "100 ns" Periodendauerwert ist Vielfaches von 100 ns Intern wird die Periode mit 100 ns Auflösung gerechnet. Die max. messbare Periode kann ca. 1,6 Sekunden betragen. 500: "500 ns" Periodendauerwert ist Vielfaches von 500 ns Intern wird die Periode mit 500 ns Auflösung gerechnet, die max. messbare Periode kann ca.32,7 ms betragen. Die Auflösung des Prozessdatums beträgt aber weiterhin den Wert nach Index 0x8010:14 (z.B. 100 ns [default]). | UINT16 | RW | 0x0064 (100dez)
8010:17 | Frequency Wait Time | Wartezeit [ms] der Frequenzmessung Ist die Zeit aus Frequency window abgelaufen, wird noch solange auf die nächste positive Flanke aus Spur A gewartet. In Abhängigkeit von den erwarteten Frequenzen kann so eine schnellstmögliche Aktualisierung des Prozessdatums "Frequency" erreicht werden. Hier sollte mindestens die doppelte Periodendauer der minimal zu messenden Frequenz eingetragen werden. t >= 2* (1 / fmin) | UINT16 | RW | 0x0640 (1600dez)


Eingangsdaten

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Eingangsdaten
Eingangsdaten
Index 6010 ENC Inputs (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | ENC Inputs | Maximaler Subindex | UINT8 | RO | 0x1E (30dez)
6010:01 | Latch C valid | Der Zählerstand wurde mit dem "C"-Eingang verriegelt. Die Daten mit dem Index 0x6010:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7010:01 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Latch extern valid | Der Zählerstand wurde über das externe Latch verriegelt. Die Daten mit dem Index 0x6010:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 0x7010:02 bzw. Objekt-Index 0x7010:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Set counter done | Der Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Counter underflow | Der Zähler hat rückwärts den Nulldurchgang durchschritten. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Counter overflow | Der Zähler ist übergelaufen. In Kombination mit einer Reset-Funktion (C/extern) ist die Under-/Overflowkontrolle unwirksam. | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Status of input status | Der Zustand des Status-Eingangs, (Störmeldeeingang "Input 1") | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Open circuit | Zeigt einen Drahtbruch an. Konfiguration über Index 0x8010:0A, 0x8010:0B, 0x8010:0C | BOOLEAN | RO | 0x00 (0dez)
6010:08 | Extrapolation stall | Der extrapolierte Teil des Zählers ist ungültig | BOOLEAN | RO | 0x00 (0dez)
6010:09 | Status of input A | Status von Eingang A | BOOLEAN | RO | 0x00 (0dez)
6010:0A | Status of input B | Status von Eingang B | BOOLEAN | RO | 0x00 (0dez)
6010:0B | Status of input C | Status von Eingang C | BOOLEAN | RO | 0x00 (0dez)
6010:0C | Status of input gate | Der Zustand des Gate-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Status of extern latch | Der Zustand des ext. Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync Error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der EL5101 ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Counter value | Wert des Zählerstandes | UINT32 | RO | 0x00000000 (0dez)
6010:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
6010:13 | Frequency value | Die Frequenz (Einstellung der Skalierung und Auflösung in Index 0x8010:13 und 0x8010:15) | UINT32 | RO | 0x00000000 (0dez)
6010:14 | Period value | Die Periodendauer (Einstellung der Skalierung und Auflösung in Index 0x8010:14 und 0x8010:16) | UINT32 | RO | 0x00000000 (0dez)
6010:16 | Timestamp | Zeitstempel der letzten Zähleränderung | UINT64 | RO |
6010:1C | Frequency value (uint16) | Frequenz (16 Bit Wert) | UINT16 | RO | 0x0000 (0dez)
6010:1D | Counter value (uint16) | Zähler (16 Bit Wert) | UINT16 | RO | 0x0000 (0dez)
6010:1E | Period value (uint16) | Periode (16 Bit Wert) | UINT16 | RO | 0x0000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Ausgangsdaten
Ausgangsdaten
Index 7010 ENC Outputs (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | ENC Outputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
7010:01 | Enable latch C | Das Verriegeln über den Eingang "C" aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Set counter value | Der über „Set counter“ (Index 0x7010:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnosedaten (kanalspezifisch)

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Informations-/Diagnosedaten (kanalspezifisch)
Informations-/Diagnosedaten (kanalspezifisch)
Index A010 ENC Diag data (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A010:0 | ENC Diag data | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
A010:01 | Open circuit A | Drahtbruch auf Spur A | BOOLEAN | RO | 0x00 (0dez)
A010:02 | Open circuit B | Drahtbruch auf Spur B | BOOLEAN | RO | 0x00 (0dez)
A010:03 | Open circuit C | Drahtbruch auf Spur C | BOOLEAN | RO | 0x00 (0dez)


Standardobjekte

Inbetriebnahme [image] EL5101-0090 [image] Objektbeschreibung und Parametrierung - Erweiterter Betriebsmodus [image] Standardobjekte
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL5101-0090
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 09
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 10
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x13ED3052 (334311506dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 RxPDO-Par Outputs (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | RxPDO-Par Outputs | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[8] | RO | 01 16 02 16 03 16 10 16
Index 1401 RxPDO-Par Outputs Word-Aligned (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | RxPDO-Par Outputs Word-Aligned | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[8] | RO | 00 16 02 16 03 16 10 16
Index 1402 ENC RxPDO-Par Control compact (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[8] | RO | 03 16 00 16 01 16 00 00
Index 1403 ENC RxPDO-Par Control (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[8] | RO | 02 16 00 16 01 16 00 00
Index 1600 RxPDO-Map Outputs (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map Outputs | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1601 RxPDO-Map Outputs Word-Aligned (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | RxPDO-Map Outputs Word-Aligned | PDO Mapping RxPDO 2 | UINT8 | RO | 0x03 (3dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 8
1601:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Value)) | UINT32 | RO | 0x7000:02, 16
Index 1602 ENC RxPDO-Map Control compact (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7010:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1603 ENC RxPDO-Map Control (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 4 | UINT8 | RO | 0x07 (7dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x01 (Enable latch C)) | UINT32 | RO | 0x7010:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1800 TxPDO-Par Inputs (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | TxPDO-Par Inputs | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[16] | RO | 01 1A 03 1A 04 1A 05 1A 06 1A 07 1A 08 1A 10 1A
Index 1801 TxPDO-Par Inputs Word-Aligned (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | TxPDO-Par Inputs Word-Aligned | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[16] | RO | 00 1A 03 1A 04 1A 05 1A 06 1A 07 1A 08 1A 10 1A
Index 1802 TxPDO-Par Inputs Optional (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | TxPDO-Par Inputs Optional | PDO Parameter TxPDO 3 | UINT8 | RO | 0x06 (6dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[16] | RO | 03 1A 04 1A 05 1A 06 1A 07 1A 08 1A 10 1A 00 00
Index 1803 ENC TxPDO-Par Status compact (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 4 | UINT8 | RO | 0x06 (6dez)
1803:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[16] | RO | 04 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00
Index 1804 ENC TxPDO-Par Status (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 5 | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[16] | RO | 03 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00 00 00
Index 1805 ENC TxPDO-Par Frequency (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Frequency | PDO Parameter TxPDO 6 | UINT8 | RO | 0x06 (6dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[16] | RO | 00 1A 01 1A 02 1A 06 1A 00 00 00 00 00 00 00 00
Index 1806 ENC TxPDO-Par Period (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1806:0 | ENC TxPDO-Par Period | PDO Parameter TxPDO 7 | UINT8 | RO | 0x06 (6dez)
1806:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 7 übertragen werden dürfen | OCTET-STRING[16] | RO | 00 1A 01 1A 02 1A 05 1A 00 00 00 00 00 00 00 00
Index 1807 ENC TxPDO-Par Timest. (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1807:0 | ENC TxPDO-Par Timest. | PDO Parameter TxPDO 8 | UINT8 | RO | 0x06 (6dez)
1807:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 8 übertragen werden dürfen | OCTET-STRING[16] | RO | 08 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00 00 00
Index 1808 ENC TxPDO-Par Timest. compact (EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1808:0 | ENC TxPDO-Par Timest. compact | PDO Parameter TxPDO 9 | UINT8 | RO | 0x06 (6dez)
1808:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 9 übertragen werden dürfen | OCTET-STRING[16] | RO | 07 1A 00 1A 01 1A 02 1A 00 00 00 00 00 00 00 00
Index 1A00 TxPDO-Map Inputs (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map Inputs | PDO Mapping TxPDO 1 | UINT8 | RO | 0x03 (3dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A01 TxPDO-Map Inputs Word-Aligned (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | TxPDO-Map Inputs Word-Aligned | PDO Mapping TxPDO 2 | UINT8 | RO | 0x04 (4dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Value)) | UINT32 | RO | 0x6000:02, 16
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (Inputs), entry 0x03 (Latch)) | UINT32 | RO | 0x6000:03, 16
Index 1A02 TxPDO-Map Inputs Optional (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Inputs Optional | PDO Mapping TxPDO 3 | UINT8 | RO | 0x03 (3dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x04 (Frequency)) | UINT32 | RO | 0x6000:04, 32
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x05 (Period)) | UINT32 | RO | 0x6000:05, 16
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (Inputs), entry 0x06 (Window)) | UINT32 | RO | 0x6000:06, 16
Index 1A03 ENC TxPDO-Map Status compact (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 4 | UINT8 | RO | 0x12 (18dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A03:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A03:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A03:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A03:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A03:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1803 (ENC TxPDO-Par Status compact), entry 0x07 (TxPDO-State)) | UINT32 | RO | 0x6010:0F, 1
1A03:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1803 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x6010:10, 1
1A03:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A03:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A04 ENC TxPDO-Map Status (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 5 | UINT8 | RO | 0x12 (18dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x01 (Latch C valid)) | UINT32 | RO | 0x6010:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x06 (Status of input status)) | UINT32 | RO | 0x6010:06, 1
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x07 (Open circuit)) | UINT32 | RO | 0x6010:07, 1
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x08 (Extrapolation stall)) | UINT32 | RO | 0x6010:08, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x09 (Status of input A)) | UINT32 | RO | 0x6010:09, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0A (Status of input B)) | UINT32 | RO | 0x6010:0A, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0B (Status of input C)) | UINT32 | RO | 0x6010:0B, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0C (Status of input gate)) | UINT32 | RO | 0x6010:0C, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x6010:0E, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x07 (TxPDO-State)) | UINT32 | RO | 0x6010:0F, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x6010:10, 1
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1A05 ENC TxPDO-Map Frequency (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Frequency | PDO Mapping TxPDO 6 | UINT8 | RO | 0x01 (1dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RO | 0x6010:13, 32
Index 1A06 ENC TxPDO-Map Period (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | ENC TxPDO-Map Period | PDO Mapping TxPDO 7 | UINT8 | RO | 0x01 (1dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RO | 0x6010:14, 32
Index 1A07 ENC TxPDO-Map Timest. (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | ENC TxPDO-Map Timest. | PDO Mapping TxPDO 8 | UINT8 | RO | 0x01 (1dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 64
Index 1A08 ENC TxPDO-Map Timest. compact (EL5101-0000, EL5101-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | ENC TxPDO-Map Timest. compact | PDO Mapping TxPDO 9 | UINT8 | RO | 0x01 (1dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x16 (Timestamp)) | UINT32 | RO | 0x6010:16, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x02 (2dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1610 (5648dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x02 (2dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0xC807 (51207dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000103C4 (66500dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000F4240 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0xC807 (51207dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x000103C4 (66500dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x000103C4 (66500dez)
1C33:07
Minimum delay time
UINT32
RW
0x0000 (0dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000001FE (510dez)
F010:02 | SubIndex 002 | reserviert | UINT32 | RW | 0x000001FF (511dez)
F010:03 | SubIndex 003 | reserviert | UINT32 | RW | 0x000003B6 (950dez)
Index F082 MDP Profile Compatibility
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F082:0 | MDP Profile Compatibility | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
F082:01 | SubIndex 001 | reserviert | BOOLEAM | RW | 0x00 (0dez)


Objekte TwinSAFE Single Channel (EL5101-0090)

Inbetriebnahme [image] EL5101-0090 [image] Objekte TwinSAFE Single Channel (EL5101-0090)
Objekte TwinSAFE Single Channel (EL5101-0090)
Index 1410 TSC RxPDO-Par Master Message
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1410:0 | TSC RxPDO-Map Master Message | PDO Parameter RxPDO 17 | UINT8 | RO | 0x06 (6dez)
1410:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 17 übertragen werden dürfen | OCTET-STRING[8] | RO | 00 16 01 16 00 00 00 00
Index 1610 TSC RxPDO-Map Master Message
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1610:0 | TSC RxPDO-Map Master Message | PDO Mapping RxPDO 17 | UINT8 | RO | 0x04 (4dez)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (TSC Master Frame Elements), entry 0x01 (TSC___Master Cmd)) | UINT32 | RO | 0x7020:01, 8
1610:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (TSC Master Frame Elements), entry 0x03 (TSC__Master CRC_0)) | UINT32 | RO | 0x7020:03, 16
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7020 (TSC Master Frame Elements), entry 0x02 (TSC__Master ConnID)) | UINT32 | RO | 0x7020:02, 16
Index 1810 TSC TxPDO-Par Slave Message
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1810:0 | TSC TxPDO-Par Slave Message | PDO Mapping TxPDO 17 | UINT8 | RO | 0x06 (6dez)
1810:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 17 übertragen werden dürfen | OCTET-STRING[16] | RO | 00 1A 01 1A 02 1A 00 00 00 00 00 00 00 00 00 00
Index 1A10 TSC TxPDO-Map Slave Message
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | TSC TxPDO-Map Slave Message | PDO Mapping TxPDO | UINT8 | RW | 0x14 (20dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x01 (TSC___Slave Cmd)) | UINT32 | RW | 0x6020:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RW | 0x6010:11, 16
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x03 (TSC__Slave CRC_0)) | UINT32 | RW | 0x6020:03, 16
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (16 bits align) | UINT32 | RW | 0x0000:00, 16
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x04 (TSC__Slave CRC_1)) | UINT32 | RW | 0x6020:04, 16
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x13 (Frequency value)) | UINT32 | RW | 0x6010:13, 16
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x05 (TSC__Slave CRC_2)) | UINT32 | RW | 0x6020:05, 16
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (16 bits align) | UINT32 | RW | 0x0000:00, 16
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x06 (TSC__Slave CRC_3)) | UINT32 | RW | 0x6020:06, 16
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x14 (Period value)) | UINT32 | RW | 0x6010:14, 16
1A10:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x07 (TSC__Slave CRC_4)) | UINT32 | RW | 0x6020:07, 16
1A10:0C | SubIndex 012 | 12. PDO Mapping entry (16 bits align) | UINT32 | RW | 0x0000:00, 16
1A10:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x08 (TSC__Slave CRC_5)) | UINT32 | RW | 0x6020:08, 16
1A10:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x1C (Frequency value (uint16))) | UINT32 | RW | 0x6010:1C, 16
1A10:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x09 (TSC__Slave CRC_6)) | UINT32 | RW | 0x6020:09, 16
1A10:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x1D (Counter value (uint16))) | UINT32 | RW | 0x6010:1D, 16
1A10:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x0A (TSC__Slave CRC_7)) | UINT32 | RW | 0x6020:0A, 16
1A10:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x1E (Period value (uint16))) | UINT32 | RW | 0x6010:1E, 16
1A10:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x0B (TSC__Slave CRC_8)) | UINT32 | RW | 0x6020:0B, 16
1A10:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6020 (TSC Slave Frame Elements), entry 0x02 (TSC__Slave ConnID)) | UINT32 | RW | 0x6020:02, 16
Index 6020 TSC Slave Frame Elements
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | TSC Slave Frame Elements | Maximaler Subindex | UINT8 | RO | 0x0B (11dez)
6020:01 | TSC__Slave Cmd | reserviert | UINT8 | RO | 0x00 (0dez)
6020:02 | TSC__Slave ConnID | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:03 | TSC__Slave CRC_0 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:04 | TSC__Slave CRC_1 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:05 | TSC__Slave CRC_2 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:06 | TSC__Slave CRC_3 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:07 | TSC__Slave CRC_4 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:08 | TSC__Slave CRC_5 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:09 | TSC__Slave CRC_6 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:0A | TSC__Slave CRC_7 | reserviert | UINT16 | RO | 0x0000 (0dez)
6020:0B | TSC__Slave CRC_8 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index 7020 TSC Master Frame Elements
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | TSC Master Frame Elements | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
7020:01 | TSC__Master Cmd | reserviert | UINT8 | RO | 0x00 (0dez)
7020:02 | TSC__Master ConnID | reserviert | UINT16 | RO | 0x0000 (0dez)
7020:03 | TSC__Master CRC_0 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index 8020 TSC Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8020:0 | TSC Settings | Maximaler Subindex |  | UINT8 | RO | 0x02 (2dez)
8020:01 | Address | TwinSAFE SC Adresse |  | UINT16 | RO | 0x0000 (0dez)
8020:02 | Connection Mode | Auswahl der TwinSAFE SC CRC |  | UINT32 | RO | 0x00000000 (0dez)
 |  | 97039dez | TwinSAFE SC CRC1 master
 |  | 153375dez | TwinSAFE SC CRC2 master
 |  | 20469 dez | TwinSAFE SC CRC3 master
 |  | 283633dez | TwinSAFE SC CRC4 master
 |  | 389589dez | TwinSAFE SC CRC5 master
 |  | 419387dez | TwinSAFE SC CRC6 master
 |  | 506061dez | TwinSAFE SC CRC7 master
 |  | 582077dez | TwinSAFE SC CRC8 master


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL5101
Hardware (HW) | Firmware | Revision Nr. | Release-Datum
07 | 04 |  | 2007/12
08 | 05 |  | 2008/02
07 - 10 | 06 |  | 2008/03
 | 07 |  | 2008/04
 | 08 |  | 2008/05
 | 09 |  | 2008/05
 | 10 |  | 2008/08
08 - 17 | 11 | EL5101-0000-1018 | 2009/01
 | 12 |  | 2009/02
 | 13 |  | 2009/02
 | 14 |  | 2009/02
 | 15 | EL5101-0000-1019 | 2009/04
 | 16 |  | 2009/09
 | 17 |  | 2009/09
 |  | EL5101-0000-1020 | 2010/05
 |  | EL5101-0000-1021 | 2012/06
 |  | EL5101-0000-1022 | 2012/10
18 - 26* | 18 | EL5101-0000-1023 | 2013/04
 |  | EL5101-0000-1024 | 2014/11
 | 19* |  | 2018/11
EL5101-0010
Hardware (HW) | Firmware | Revision Nr. | Release-Datum
00 - 10 | 01 | EL5101-0010-0016 | 2010/10
 |  | EL5101-0010-0017 | 2012/06
 |  | EL5101-0010-0018 | 2012/10
 |  | EL5101-0010-0019 | 2014/11
11* | 02* |  | 2018/12
EL5101-0011
Hardware (HW) | Firmware | Revision Nr. | Release-Datum
07 - 10* | 01* | EL5101-0011-0016 | 2016/10
EL5101-0090
Hardware (HW) | Firmware | Revision Nr. | Release-Datum
24 - 25 | 01 | EL5101-0090-0016 | 2017/10
26* | 02* | EL5101-0090-0017 | 2018/11
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.