EL37x2 - Analog-Eingangsklemmen mit Oversampling
Home


Produktübersicht Analoge-Eingangsklemmen mit Oversampling

Produktübersicht Analoge-Eingangsklemmen mit Oversampling
Produktübersicht Analoge-Eingangsklemmen mit Oversampling
EL3702
2 Kanal Analog-Eingangsklemme, -10 V … +10 V mit Oversampling
EL3702-0015
2 Kanal Analog-Eingangsklemme, -150 mV … +150 mV mit Oversampling
EL3742
2 Kanal Analog-Eingangsklemme, 0 … 20 mA mit Oversampling


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.7
▪
Update Technische Daten
▪
Strukturupdate
▪
Update Revisionsstand
3.6
▪
EL3702-0015 ergänzt
▪
Strukturupdate
▪
Update Revisionsstand
3.5
▪
Update Kapitel "Beispielprogramme"
▪
Strukturupdate
3.4
▪
Update Technische Daten
▪
Hinweis zum ESD-Schutz eingefügt
▪
Kapitel "ATEX - Besondere Bedingungen" ausgetauscht gegen Kapitel "ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)"
▪
Update Kapitel "Hinweise zu analogen Spezifikationen"
▪
Update Revisionsstand
3.3
▪
Update Kapitel "Produktübersicht"
▪
Kapitel „Hinweise zu analogen Spezifikationen“ hinzugefügt
3.2
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Update Technische Daten
▪
Kapitel "TwinCAT Quick Start" eingefügt
▪
Update Revisionsstand
3.1
▪
Kapitel „Oversampling Klemmen und TwinCAT Scope“ ergänzt
3.0
▪
Migration
2.0
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
▪
Strukturupdate
▪
Update Revisionsstand
1.9
▪
Strukturupdate
▪
Kapitel "Technische Daten" aktualisiert
1.8
▪
Update Struktur
▪
Technische Daten aktualisiert
▪
Kapitel "Beschaltung von 0/4..20 mA Differenzeingängen" ergänzt
1.7
▪
Technische Hinweise ergänzt
1.6
▪
Technische Hinweise Beispielprogramm ergänzt
1.5
▪
Beispielprogramm ergänzt
1.4
▪
EL3742 ergänzt
1.3
▪
Beispiele ergänzt
1.2
▪
Technische Daten und Sicherheitshinweise ergänzt
1.1
▪
Technische Daten ergänzt
1.0
▪
Technische Daten ergänzt
0.1
▪
Vorläufige Dokumentation für EL37x2


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
Aufbau des BICs
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL3702 - Einführung
•
EL3702 - Technische Daten
•
EL3742 - Einführung
•
EL3742 - Technische Daten
•
Grundlagen zur Funktion
•
Beispielprogramme


EL3702 - Einführung

Produktübersicht [image] EL3702 - Einführung
EL3702 - Einführung
EL3702
2 kanalige analoge Eingangsklemme, Differenzeingänge, -10 V … +10 V mit Oversampling
Die analoge Eingangsklemme EL3702 verarbeitet Signale im Bereich -10 V bis + 10 V. Die Spannung wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zur Steuerung übertragen. Die Eingangskanäle der EtherCAT-Klemmen sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotenzial.

Die Signale werden mit einem einstellbaren ganzzahligen Vielfachen (Oversampling-Faktor: n) der Buszykluszeit abgetastet (n Mikrozyklen je EtherCAT-Buszyklus). Die EtherCAT-Klemme erzeugt für jeden EtherCAT-Buszyklus einen Satz aus n Prozessdaten je Kanal, der gesammelt und im nächsten Buszyklus übertragen wird. Die Zeitbasis der Klemme kann per Distributed-Clock mit anderen EtherCAT-Teilnehmern hochgenau synchronisiert werden. Die zeitliche Auflösung der analogen Eingangssignale lässt sich mit diesem Verfahren auf das n-fache der Buszykluszeit steigern.

In Verbindung mit der EL4702/EL4732 (analoge Ausgangsklemme mit Oversampling) oder jedem anderen Distributed-Clocks-fähigen EtherCAT-Teilnehmer werden zeitäquidistante Reaktionen möglich.
Die maximale Abtastrate der EL3702 beträgt 100 kSps (10 µs Abtastung) bei einer empfohlenen Eingangssignalbandbreite von 0..30 kHz.
Informationen zu den Distributed Clocks entnehmen Sie bitte der separaten Systembeschreibung.
Als weitere Ergänzung ist die analoge Eingangsklemme EL3702-0015 für Signale im Bereich -150 mV bis + 150 mV erhältlich.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Grundlagen zur Funktion
▪
Prozessdaten und Konfiguration


EL3702 - Technische Daten

Produktübersicht [image] EL3702 - Technische Daten
EL3702 - Technische Daten
Technische Daten | EL3702 | EL3702-0015
Anzahl der Eingänge | 2
Signalspannung | -10 V ... +10 V | -150 mV ... +150 mV
Max. Samplingrate | max. 10 µs/100 kSps (je Kanal, simultan)
Oversampling-Faktor | n = ganzzahliges Vielfaches der EtherCAT-Zykluszeit, 1..100
Eingangssignal Bandbreite | 0 ... 30 kHz (empfohlen)
Genauigkeit Distributed Clocks | < 100 ns
Innenwiderstand | > 200 kΩ
Gleichtaktspannung UCM | max. 35 V
Auflösung | 16 Bit
Wandlungszeit | ~ 10 µs
Messfehler | < ± 0,3% (bei 25 °C ... +55 °C, bezogen auf den Messbereichsendwert, bei < 10 Hz Eingangssignal) < ± 0,5% (bei Ausnutzung des erweiterten Temperaturbereichs) | < ± 0,3% (bezogen auf den Messbereichsendwert, bei < 10 Hz Eingangssignal)
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 200 mA
Bitbreite im Prozessabbild | Input: n x 2 x 16 Bit Daten, ggf. 2 x 16 Bit CycleCounter, ggf. 4 Byte StartNextLatchTime
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) | 0°C ... +55°C
Zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C | -25°C ... +85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX IECEx cULus | CE


EL3742 - Einführung

Produktübersicht [image] EL3742 - Einführung
EL3742 - Einführung
EL3742
2 kanalige analoge Eingangsklemme, Differenzeingänge, 0 ... 20 mA mit Oversampling
Die analoge Eingangsklemme EL3742 verarbeitet Signale im Bereich von 0 bis 20 mA. Die Spannung wird mit einer Auflösung von 16 Bit digitalisiert und galvanisch getrennt zur Steuerung übertragen. Die Eingangskanäle der EtherCAT-Klemmen sind Differenzeingänge und besitzen ein gemeinsames, internes Massepotenzial.

Die Signale werden mit einem einstellbaren ganzzahligen Vielfachen (Oversampling-Faktor: n) der Buszykluszeit abgetastet (n Mikrozyklen je EtherCAT-Buszyklus). Die EtherCAT-Klemme erzeugt für jeden EtherCAT-Buszyklus einen Satz aus n Prozessdaten je Kanal, der gesammelt und im nächsten Buszyklus übertragen wird. Die Zeitbasis der Klemme kann per Distributed-Clock mit anderen EtherCAT-Teilnehmern hochgenau synchronisiert werden. Die zeitliche Auflösung der analogen Eingangssignale lässt sich mit diesem Verfahren auf das n-fache der Buszykluszeit steigern.

In Verbindung mit der EL4702/EL4732 (analoge Ausgangsklemme mit Oversampling) oder jedem anderen Distributed-Clocks-fähigen EtherCAT-Teilnehmer werden zeitäquidistante Reaktionen möglich.
Die maximale Abtastrate der EL3742 beträgt 100 kSps (10 µs Abtastung) bei einer empfohlenen Eingangssignalbandbreite von 0..30 kHz.
Informationen zu den Distributed Clocks entnehmen Sie bitte der separaten Systembeschreibung.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Grundlagen zur Funktion
▪
Prozessdaten und Konfiguration


EL3742 - Technische Daten

Produktübersicht [image] EL3742 - Technische Daten
EL3742 - Technische Daten
Technische Daten | EL3742
Anzahl der Eingänge | 2
Signalspannung | 0…20 mA
Max. Samplingrate | max. 10 µs/100 kSps (je Kanal, simultan)
Oversampling-Faktor | n = ganzzahliges Vielfaches der EtherCAT-Zykluszeit, 1..100
Eingangssignal Bandbreite | 0 ... 30 kHz (empfohlen)
Genauigkeit Distributed Clocks | < 100 ns
Innenwiderstand | 85 Ω typ. + Diodenspannung
Auflösung | 16 Bit
Wandlungszeit | ~ 10 µs
Messfehler | < ± 0,3% (bei 25°C ... +55°C, bezogen auf den Messbereichsendwert, bei < 10 Hz Eingangssignal) < ± 0,5% (bei Ausnutzung des erweiterten Temperaturbereichs)
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 200 mA
Bitbreite im Prozessabbild | Input: n x 2 x 16 Bit Daten, ggf. 2 x 16 Bit CycleCounter, ggf. 4 Byte StartNextLatchTime
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Mit den Analogeingangsklemmen EL3702/ EL3742 können zwei Spannungen/Ströme gemessen und mit einer Auflösung von 16 Bit (65535 Schritte) dargestellt werden.
Durch die Oversampling-Eigenschaft kann die Klemme auf jedem Kanal mehrmals je Buszyklus analoge Eingangswerte erfassen.
Oversampling
Eine herkömmliche analoge Eingangsklemme erfasst mit jedem Buszyklus einen analogen Eingangswert ("Sample") und gibt ihn im nächsten Feldbuszyklus an die übergeordnete Steuerung weiter. Die EL37x2 erfasst zwischen zwei Feldbuskommunikationszyklen konfigurierbar und zeitäquidistant mehrmals die anliegende Spannung. Die Übergabe eines Pakets von x analogen Messwerten von je 16 Bit an die übergeordnete Steuerung findet im nächsten Feldbuskommunikationszyklus statt. Dieses Verfahren wird "Oversampling" genannt.
Distributed Clock
Für das Oversampling ist ein Taktgeber in der Klemme nötig, der die einzelnen Messwerterfassungen auslöst. Dazu wird die lokale Uhr in der Klemme genutzt, genannt Distributed Clock.
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns.
▪
Nullpunkt 1.1.2000 00:00.
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über.
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
In der EL37x2 ist nur ein Umfang von 32 Bit realisiert.
Beispiel:
Der Feldbus/EtherCAT Master wird mit 1 ms Zykluszeit betrieben weil z. B. die übergeordnete SPS mit 1 ms Zykluszeit betrieben wird. Damit wird alle 1 ms ein EtherCAT-Frame zur Abholung der Prozessdaten der EL37x2 geschickt. Im ESC wird deshalb durch die lokale Uhr in der Klemme alle 1 ms (1 kHz) ein Interrupt ausgelöst, der die Prozessdaten rechtzeitig für den abholenden EtherCAT-Frame bereitstellt. Dieses erste Interrupt wird SYNC1 genannt.

Die EL37x2 sei im TwinCAT System Manager auf ein Oversampling n = 10 eingestellt. Dadurch generiert der ESC in der Klemme einen zweiten Interrupt mit einer n-fach höheren Frequenz, hier also 10 kHz oder 100 µs Periode. Dieses Interrupt wird SYNC0 genannt. Bei jedem SYNC0-Signal wird eine Messwerterfassung durch den Analog-to-Digital-Converter (ADC) gestartet, die ermittelten analogen Messwerte nacheinander in einem Puffer abgelegt.
Ermittlung der Eingangsspannungen/Eingangsströme
Beide Eingangsspannungen/Eingangsströme (von Kanal 1 und 2) werden immer gleichzeitig ermittelt. Dies gewährleistet die Bauart des ADC, der durch den SYNC0-Puls angestoßen wird. Eine andere Betriebsart ist nicht möglich.
Durch die Generierung des SYNC0-Pulses aus der lokalen synchronisierten Uhr im Distributed-Clocks-Verbund ist gewährleistet, dass die Erfassung der analogen Messwerte in zeitlich hochkonstant gleichen Abständen mit der Periode des SYNC1-Pulses erfolgt.
Der maximale Oversamplingfaktor ist abhängig vom Speicherumfang des eingesetzten ESC und beträgt bei der EL37x2 in der Version KKYY0000 n = 100.
Maximale Samplingfrequenz
Eine kleinere Periode als 10 µs ist für die EL37x2 nicht zulässig! Die maximale Samplingfrequenz beträgt für die EL37x2 also 100 kSps (Samples per second).
Bei der Berechnung des SYNC0 aus dem SYNC1-Puls durch die manuelle Vorgabe eines Oversamplingfaktors ist darauf zu achten, daß für SYNC0 nur ganzzahlige Werte im Nanosekundenabstand berechnet werden.
Beispiel: 187.500 µs ist zulässig, 333.3 nicht!
Beispiel:
Bei SYNC1 = 1 ms sind Oversamplingfaktoren wie 1,2,5 oder 100 zulässig, nicht aber 3! Wird mit unplausiblen Werten gearbeitet, erreicht die Klemme zwar den OP-State, liefert aber keine Prozessdaten. Dies drückt sich ggf. auch durch einen Working Counter Error aus.
Die im Puffer gesammelten Messwerte von je 16 bit Umfang werden als Paket an die übergeordnete Steuerung übergeben. Bei 2 Kanälen und n = 100 werden so je EtherCAT-Zyklus 2 x 2 x 100 = 400 Byte Prozessdaten übermittelt.
Zeitbezogene Zusammenarbeit mit anderen Klemmen
Die Messwerterfassung des ADC in der EL37x2 wird durch einen Interrupt ausgelöst, der von der lokalen Uhr in der Klemme generiert wird. Alle lokalen Uhren in den unterstützenden EtherCAT-Slaves sind synchronisiert. Dadurch ist es möglich, EtherCAT-Slaves (hier: Klemmen) unabhängig von ihrer jeweiligen Entfernung untereinander gleichzeitig ihre Messwerte erfassen zu lassen (gleichzeitige Interrupterzeugung). Diese Gleichzeitigkeit liegt im Rahmen der Distributed-Clocks-Genauigkeit von < 100 ns.
Beispiel:
Abstimmung zweier EL37x2 untereinander:
Der EtherCAT Master wie z. B. Beckhoff TwinCAT konfiguriert beide EL37x2 so, dass ihre SYNC1 zum gleichen Zeitpunkt auftreten. Annahme: die EtherCAT-Buszykluszeit ist 500 µs. Somit wird der SYNC1 in allen EL37x2 alle 500 µs ausgelöst. Wenn beide Klemmen mit einem übereinstimmenden Oversamplingfaktor (z. B. 20) arbeiten, wird auch der mit dem SYNC1 korrelierende SYNC0-Puls in allen EL37x2 zur gleichen Zeit auftreten, hier also alle 25 µs. Eine Einsatzmöglichkeit wäre z. B. ein über eine weitläufige Anlage "verteiltes" Oszilloskop, hier mit einer Erfassungsfrequenz von 40 kSps.

Werden in den eingesetzten EL37x2 verschiedene Oversamplingfaktoren verwendet, treten deren SYNC0-Pulse nicht mehr gleichzeitig auf. Der übergeordnete SYNC1-Puls bleibt bestehen.

Wird im TwinCAT System Manager (Karteireiter "DC", "Advanced Settings") bei einer EL37x2 für den SYNC0-Puls ein Wert bei "Shift Time (µs)" eingetragen, wird die so manipulierte EL37x2 ihre Messwerte um den eingestellten Wert früher oder später erfassen. Dies kann sinnvoll sein, wenn z. B. ein Nutzsignal mit einer höheren Frequenz als die für die EL37x2 zulässigen 100 kSps erfasst werden soll und dazu mehrere EL37x2 in einem zeitversetzten Verbund betrieben werden.
Beispiel:
Zur Erfassung eines Nutzsignales mit 200 kSps werden zwei EL37x2 nebeneinander eingesetzt und mit demselben Nutzsignal beaufschlagt (z. B. jeweils Kanal 1 in beiden Klemmen). Der Buszyklus sei 1 ms, der Oversamplingfaktor in beiden EL37x2 n = 100 und damit maximal schnell mit 10 µs Abstand bzw. 100 kSps. In der zweiten EL37x2 wird nun im System Manager (Karteireiter "DC", "Advanced Settings", "SYNC0", "User Defined") eine Shift Time für den SYNC0-Puls dieser Klemme von 5 µs zusätzlich manuell eingetragen. Dadurch wird der jeder SYNC0-Puls dieser EL37x2 um 5 µs später erfolgen als der der ersten EL37x2.
Synchronisation und Bereitstellung der Prozessdaten
Da der SYNC1-Puls aus dem SYNC0-Puls abgeleitet wird, wird auch jeder SYNC1-Puls der zweiten EL37x2 um 5 µs nach dem SYNC1-Puls der ersten EL37x2 erfolgen. Bitte beachten Sie, dass dies ggf. Einfluss auf die rechtzeitige Bereitstellung der Prozessdaten für den EtherCAT-Frame haben kann, da dies vom SYNC1-Puls gesteuert wird!
Beide Klemmen übermitteln nun jeweils ein Paket von 400 Byte Prozessdaten an die übergeordnete Steuerung. Werden diese beiden zeitlich um 5 µs versetzten Messwertsammlungen von je 1 ms Länge in der Steuerung chronologisch richtig sortiert, wurde das Nutzsignal transparent mit 200 kSps erfasst.

Die konkrete Anwendung dieser Funktionen mit dem Beckhoff TwinCAT System Manager wird im Kapitel Prozessdaten und Konfiguration beschrieben.
SYNC0 und SYNC1 Impuls mit mehreren EtherCAT Slaves
Dieses Vorgehen der Abstimmung der SYNC0 bzw. SYNC1-Pulse mehrerer EtherCAT-Slaves ist nicht auf die EL37x2 beschränkt.
Alle EtherCAT-Slaves, die die Distributed-Clocks-Funktion unterstützen, können so relativ frei untereinander in zeitlichen Bezug gesetzt werden.
Hinweis
Achtung! Beschädigung der Geräte möglich!
Die voranstehenden Hinweise und Erläuterungen sollten mit Bedacht angewendet werden!
Die SYNC0- und SYNC1-Einstellungen werden vom EtherCAT-Master automatisch mit Werten belegt, die eine zuverlässige und aktuelle Prozessdatenerfassung unterstützen.
Anwenderseitige Eingriffe an dieser Stelle können zu unerwünschtem Verhalten führen!
Bei der Manipulation dieser Einstellungen im System Manager wird softwareseitig keine Plausibilitätskontrolle durchgeführt!
Eine korrekte Funktion der Klemme in allen denkbaren Einstellungsvarianten kann nicht gewährleistet werden!
Zeitstempel der Prozessdaten
Die EL37xx kann bei Bedarf einen "Zeitstempel" für jeden Prozessdatenblock mitliefern. Dieses Prozessdatum ist als StartTimeNextLatch durch die Aktivierung von 0x1B10 im Reiter Prozessdaten als 32-Bit-Wert aktivierbar, siehe auch die Seite Prozessdaten.
Optionales Prozessdatum StartTimeNextLatch
Dabei ist der in jedem Zyklus übertragene Datenblock Samplewerte+Zeitstempel nicht zusammenhörig, wie der Name schon nahe legt. Der Zusammenhang ist in Abb. Zeitlicher Zusammenhang SYNC-Signale und SyncManager-Interrupt dargestellt. Zur Erläuterung:
▪
dargestellt ist ein Beispiel für Oversamplingfaktor = 5
▪
das SYNC0-Signal in der Klemme triggert die AD-Wandlung und füllt den internen Puffer mit 5 Messwerten (A)
▪
Synchron mit der Zykluszeit läuft SYNC1, der die Bereitstellung des gefüllten Puffer als Prozessdatum auslöst und gleichzeitig den StartTimeNextLatch aus der lokalen DistributedClock holt (B)
▪
dabei wird der data-Block zusammen mit der übernächsten LatchTime zusammengestellt
▪
der nächste EtherCAT-Zyklus holt diese Daten ab (C)
Zeitlicher Zusammenhang SYNC-Signale und SyncManager-Interrupt
Prozessdaten
Analogwerte werden wie folgt dargestellt:
Eingangssignal | Wert
EL3702 | Dezimal | Hexadezimal
-10 V | -32767 | 0x8001
+10 V | +32767 | 0x7FFF
Eingangssignal | Wert
EL3742 | Dezimal | Hexadezimal
0 mA | 0 | 0x0000
20 mA | +32767 | 0x7FFF
Die Klemme wird bei der Herstellung abgeglichen. Weitere Eingriffe des Anwenders sind nicht erforderlich.
Eingangscharakteristik
Die Eingangsschaltung dieser Klemme ist auf höherfrequente Signale bis etwa 30 kHz optimiert, d.h. die empfohlene Bandbreite des Nutzsignals beträgt 0 Hz bis 30 kHz im Bereich von -10 V bis +10 V bzw. 0 mA bis 20 mA. In diesem Frequenzbereich beträgt die typische Messgenauigkeit wie folgt:
< 10 Hz < 0,3% vom Messbereichsendwert
< 10 kHz < 1% vom Messbereichsendwert
< 30 kHz < 4% vom Messbereichsendwert
Insbesondere bei Nutzsignalen höherer Frequenzen ist auf eine ausreichend niedrige Impedanz des Signalgebers zu achten, damit Amplitudeneinbrüche (Dämpfungen wie z. B. beim Einsatz einfacher Signalgeneratoren) nicht zu fehlerhaften Messungen führen.
Beeinflussung durch störende Geräte
Beim Betrieb dieser schnellen analogen EtherCAT-Klemme können hochfrequente, überlagernde Signale von störenden Geräten (z. B. Proportionalventile, Schrittmotor- oder DC-Motor-Endstufen) von der Klemme erfasst werden. Um einen störungsfreien Betrieb zu gewährleisten, empfehlen wir den Einsatz getrennter Netzteile für die Klemmen und die Störungen verursachenden Geräte und eine Schirmung der verwendeten Leitungen.


Beispielprogramme

Produktübersicht [image] Beispielprogramme
Beispielprogramme
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Kunden zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Diagnose & Zeitstempelung analoge Eingangsdaten
Download ( )
In diesem Beispiel werden die Eingangsdaten einer EL3702 auf Gültigkeit geprüft und bearbeitet:
▪
1 ms Zykluszeit, 10-fach Oversampling, 2 Kanäle
▪
WC, State, EtherCAT Master DevState und CycleCounter werden zyklisch überprüft, die Eingangsdaten nur dann weitergereicht wenn sie gültig sind
▪
ausgehend vom gelieferten Zeitstempel des Sample 0 werden alle anderen Samples mit 64 Bit DC-Zeitstempeln versehen
▪
bei ungültigen Eingangsdaten werden Defaultwerte weitergereicht, die Zeitstempelung wird weiter fortgeführt
▪
die Daten eines jeden Zyklus werden in einen FIFO-Puffer geschoben damit übergeordnet z. B. eine Auswertung stattfinden kann.
Anschlussschema:
Anschluss Beispielprogramm
Starten des Beispielprogramms
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.

Für den Prüfaufbau wurde folgende Hardware und Software verwendet:
▪
TwinCAT-Master-PC mit Betriebssystem Windows XP Professional SP 3, TwinCAT Version 2.10 (Build 1330) und INTEL PRO/100 VE Ethernet-Adapter
▪
Beckhoff EtherCAT Koppler EK1100, Klemmen EL3702 und EL9011
▪
2 x optischer Näherungsschalter 0 - 10 V in 2-Leitertechnik
Vorgehensweise zum Starten des Programms
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.TSM (Konfigurationsdatei) und *.PRO (PLC-Programmdatei) in einem temporären Arbeitsordner.
▪
Die *.pro-Datei kann per Doppelklick geöffnet werden oder über die TwinCAT PLC Control Anwendung mit die Menüauswahl „Datei/ Öffnen“. Die *.tsm-Datei ist für den der TwinCAT‑System Manager vorgesehen (um hier Konfigurationen einzusehen oder zu übernehmen).
▪
Schließen Sie die Hardware entsprechend Abb. Anschluss Beispielprogramm an und verbinden Sie den Ethernet-Adapter ihres PCs mit dem EtherCAT-Koppler (weitere Hinweise hierzu finden sie in den entsprechenden Kopplerhandbüchern).
▪
Auswahl des lokalen Ethernet-Adapters (ggf. mit Echtzeit-Treiber) unter Systemkonfiguration, E/A - Konfiguration, E/A -Geräte, Gerät (EtherCAT); dann unter Karteireiter "Adapter", "Suchen..." den entsprechenden Adapter auswählen und bestätigen (siehe Abb. Suchen des Ethernet-Adapters + Auswahl und Bestätigung des Ethernet-Adapters).
Suchen des Ethernet-Adapters
Auswahl und Bestätigung des Ethernet-Adapters
▪
Aktivierung der Konfiguration und bestätigen (Abb. Aktivierung der Konfiguration + Konfigurationsaktivierung bestätigen)
Aktivierung der Konfiguration
Konfigurationsaktivierung bestätigen
▪
Neue Variablenzuordnung bestätigen, Neustart im RUN-Modus (Abb. Variablenzuordnung erzeugen + Neustart TwinCAT im RUN-Modus)
Variablenzuordnung erzeugen
Neustart TwinCAT im RUN-Modus
▪
In der TwinCAT PLC unter Menü "Projekt" -> "Alles Übersetzen" das Projekt übersetzen (Abb. Projekt übersetzen)
Projekt übersetzen
▪
In der TwinCAT PLC: Einloggen mit der Taste "F11", Laden des Programms bestätigen (Abb. Programmstart bestätigen), Start des Programms mit Taste "F5"
Programmstart bestätigen
Arbeiten mit DC-Zeiten in der Steuerung
Die Distributed-Clock-Zeit hat aus der Sicht der Steuerung folgenden Eigenschaften:
▪
Einheit 1 ns
▪
universaler Nullpunkt 1.1.2000 00:00 , d.h. bei Auswertungen der Variable ist ein Offset von 2000 Jahren zu addieren
▪
Umfang bis zu 64 Bit (ausreichend für 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft das Register lokal über und beginnt wieder bei 0.
Zur Bearbeitung von DC-Zeiten werden folgende 3 Datentypen empfohlen
▪
T_DCTIME aus TcEtherCAT.lib
Basiert auf T_ULARGE_INTEGER und ist damit vorzeichenlos. Kann zur Verlinkung mit entsprechenden Hardware-Variablen verwendet werden
▪
T_ULARGE_INTEGER aus der TcUtilities.lib
Vorzeichenloser 64-Bit-Datentyp
▪
T_LARGE_INTEGER aus der TcUtilities.lib
Vorzeichenbehafteter 64-Bit-Datentyp, negative Zahlen werden im 2er-Komplement dargestellt (Unterlauf unter 0 --> 0xFFFF FFFF FFFF FFFF usw.)
Dazu stehen in der TcUtilities.lib im Kapitel INT64 viele Funktionen zur Verfügung, wichtig insbesondere die cast-Funktionen LARGE_TO_ULARGE und umgekehrt.
Sobald mit Zeitdifferenzen gearbeitet wird, bei denen negative Zeiten auftreten können, ist dieser Typ zu verwenden.
Wird TwinCAT externe Synchronisierung eingesetzt, treten zwangsläufig negative Zeiten in den Offset-Werten auf.
64- vs. 32-Bit-Darstellung
Manche EtherCAT-Slaves können die DC-Zeit nur als 32-Bit-Wert darstellen bzw. als Prozessdatum verarbeiten. Um durch Überlauf verursachten Problemen (alle 4.2 Sekunden) entgegenzuwirken wird jedoch dringend empfohlen, in der Steuerung generell nur mit 64-Bit-Zeiten zu rechnen.
•
An die PLC gelieferte 32-Bit-Zeiten sind um den aktuellen High-Teil zu erweitern
•
An die HW ist in diesem Fall nur der Low-Part (untere 32 Bit) zu liefern
In diesem Beispielprojekt
Grafik aus Arbeiten mit DC-Zeiten in der Steuerung (igd60u02.png) ( ) ist ein Funktionsblock enthalten, der zyklisch eine 32-Bit-DC-Zeit um den High-Part zu 64 Bit ergänzt.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface: Hinweis
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface: Hinweis

Grundlagen der Kommunikation [image] CoE-Interface: Hinweis
CoE-Interface: Hinweis
Dieses Gerät hat kein CoE.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschlusstechnik
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation
•
UL-Hinweise
•
Beschaltung von 0/4..20 mA Differenzeingängen
•
EL37x2 - LEDs und Anschlussbelegung


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


Beschaltung von 0/4..20 mA Differenzeingängen

Montage und Verdrahtung [image] Beschaltung von 0/4..20 mA Differenzeingängen
Beschaltung von 0/4..20 mA Differenzeingängen
Im Folgenden werden Hinweise zu den 0/4..20 mA Differenzeingängen der Klemmenserien EL301x, EL302x, EL311x, EL312x und Klemmen EL3174, EL3612, EL3742 und EL3751 gegeben.
Diese treffen auf die Single-Ended-20 mA-Eingänge der Klemmenserien EL304x, EL305x, EL314x, EL315x, EL317x, EL318x und EL375x nur im Rahmen der technischen Übertragbarkeit zu und gelten nur für Geräte, deren Analoge Eingangskanäle eine gemeinsame Bezugsmasse haben, d.h. dass die Kanäle nicht untereinander bzw. nicht zur Versorgung galvanisch getrennt sind. Ein Beispiel für ein "galvanisch getrenntes" Gerät ist hierbei die EL3174-0002.
Technischer Hintergrund
Die interne Eingangselektronik der o.g. Klemmen verfügt über folgende charakteristische Eigenschaften (s. Abb. Interne Anschlussschaltung 0/4..20 mA Eingänge):
▪
differenzielle Messung des Stromes, d.h. ein konkreter Potenzialbezug ist primär nicht erforderlich.
Als Systemgrenze gilt hierbei die einzelne Klemme EL30xx/EL31xx.
▪
Strommessung über eine 33 Ω-Shunt je Kanal, daraus folgend ein maximaler Spannungsabfall von 660 mV über den Shunt
▪
interne Widerstandsanordnung mit GND-Punkt (A) mittig zum Shunt
Dabei ist die Auslegung der Widerstände derart symmetrisch, dass das Potenzial von (A) mittig zum Spannungsabfall über den Shunt zu liegen kommt.
▪
dieses GND-Potenzial GNDint ist für alle in der Klemme realisierten Kanäle gemeinsam
▪
das gemeinsame GNDint-Potenzial (A) ist
–
bei 1- und 2-kanaligen Klemmen auf einen Klemmpunkt geführt und nicht mit GNDPC (Powerkontakt) verbunden
–
bei 4-kanaligen Klemmen mit GNDPC verbunden
▪
der Mittelpunkt der über den 33 Ω-Shunt abfallenden Spannung ist der sog. Common-Mode-Messmittelpunkt (CMP).
Die max. zulässige UCM-Spannung (common mode) laut den technischen Daten des Produkts bezieht sich auf das Potenzial zwischen dem CMP eines Kanals zum internen GND bzw. auf das Potenzial zwischen den CMP von 2 Kanälen innerhalb einer Klemme.
Sie darf die angegebene Grenze (typischerweise ±10 oder ±35 V) nicht überschreiten.
Demzufolge sind bei mehrkanaligen Messungen UCM-Vorgaben zu beachten.
Interne Anschlussschaltung 0/4...20 mA Eingänge
Am Prinzipschaltbild einer 2-kanaligen Klemme sind die verbundenen GND-Punkte innerhalb der Klemme zu sehen (Abb. Interne Anschlussschaltung 0/4..20 mA Eingänge einer EL3xx2):
Interne Anschlussschaltung 0/4...20 mA Eingänge einer EL3xx2
Bei allen Kanälen innerhalb der Klemme darf UCM-max nicht überschritten werden.
UCM bei 0/4..20 mA Eingängen
Wenn UCM eines analogen Eingangskanals überschritten wird, kommt es zu erheblichen Fehlmessungen durch interne Ausgleichsströme.
Bei den 1- und 2-kanaligen Klemmen ist genau deshalb der interne GND an einen Klemmpunkt herausgeführt, damit durch applikationsgerechte Beschaltung dieses GND-Punktes die UCM-Vorgabe auch bei atypischer Sensorbeschaltung eingehalten werden kann.
Beispiel 1
Die 2-kanalige EL3012 wird mit 2 Sensoren beschaltet, die von 5 und 24 V gespeist werden. Beide Strommessungen sind als Low-Side-Messung ausgeführt. Diese Anschlussform ist zulässig, denn CMPch1 und CMPch2 liegen jeweils bei Imax ca. 330 mV über 0 V, UCM ist somit immer < 0,5 V. Somit ist UCM < 10 V (gültig für EL30xx) eingehalten.
Beispiel 1: LowSide-Messung
Wird GNDint bei den EL30x1/EL30x2 bzw. EL31x1/EL31x2 nicht extern beschaltet, kann sich das Potenzial auf GNDint nach Erfordernis einstellen, es "floatet". Allerdings ist dann mit reduzierter Messgenauigkeit zu rechnen.
Beispiel 1a
Entsprechendes gilt auch, wenn der frei schwebende Punkt GNDint auf ein anderes Potential gezogen wird.
Beispiel 1a, HighSide-Messung
Beispiel 2
Die gleiche EL3012 wird nun wieder mit den beiden 20 mA-Sensoren beschaltet, diesmal aber einmal in Low-Side-Messung an 5 V, einmal in High-Side-Messung an 12 V. Damit ergeben sich erhebliche Potenzialunterschiede UCM > 10 V (gültig für EL30xx) beider Kanäle. Dies ist nicht zulässig.
Beispiel 2, High-Side-/Low-Side-Messung
Zur Abhilfe kann GNDint in diesem Fall extern mit einem Hilfs-Potenzial von 6 V gegenüber "0 V" verbunden werden. Damit stellt sich A/GNDint ca. mittig zwischen 0,3 V bzw. 11,6 V ein.
Beispiel 3
Bei den EL3xx4 ist GNDint intern mit dem negativen Powerkontakt verbunden. Deshalb gilt hier die Freiheit der Potenzialwahl nicht.
Unzulässige EL3xx4-Beschaltung
Es stellt sich ein CMP = 23,6 V und damit >> 10 V (gültig für EL30xx) ein. Bei den Klemmen EL30x4/EL31x4 ist deshalb die Beschaltung so zu wählen, dass CMP < UCM,max eingehalten wird.
Zusammenfassung
Daraus ergeben sich einige konkrete Vorgaben für die externe Beschaltung mit 0/4..20 mA Sensoren:
▪
Es wird empfohlen, GNDint mit einem niederimpedanten Potenzial zu verbinden, da die Messgenauigkeit der EL30xx/31xx damit erheblich verbessert wird.
Die Hinweise zum Potenzialbezug UCM sind zu beachten!
▪
Der Potenzialbezug UCM muss eingehalten werden, und zwar sowohl zwischen CMP ↔ GNDint als auch CMPch(x) ↔ CMPch(y).
Kann dies nicht gewährleistet werden, ist die 1-kanalige Variante einzusetzen.
▪
Ausprägung bei den Klemmen:
–
EL3xx1/EL3xx2: GNDint ist auf Klemmpunkt zur externen Beschaltung geführt.
GNDint soll extern derart angeschlossen werden, dass Pkt. 2 erfüllt ist.
–
EL3xx4: GND ist mit dem negativen Powerkontakt verbunden.
Die externe Beschaltung ist so zu wählen, dass Pkt. 2 erfüllt ist.
Falls die Sensorleitung mit einer Schirmung versehen ist, ist diese nicht mit der GNDint-Klemmstelle zu verbinden sondern auf einer dafür vorgesehenen niederimpedanten Schirmstelle aufzulegen.
▪
Werden Klemmstellen mehrerer EL30xx/EL31xx-Klemmen miteinander verbunden, ist insbesondere auf die Einhaltung von Pkt. 2 zu achten.
Anschluss von GNDint
Bei den EL30x1/EL30x2 und EL31x1/EL31x2 wird das interne GND, GNDint auf Klemmkontakte herausgeführt.
Zur Erzielung eines genauen Messergebnisses ist GNDint unter Beachtung der Vorgaben für UCM mit einem geeigneten externen niederohmigen Potenzial zu verbinden.
Bei den EL30x4/EL31x4 ist GNDint bereits mit dem negativen Powerkontakt verbunden. Hier sind ebenfalls die Vorgaben in Bezug auf UCM einzuhalten.


EL37x2 - LEDs und Anschlussbelegung

Montage und Verdrahtung [image] EL37x2 - LEDs und Anschlussbelegung
EL37x2 - LEDs und Anschlussbelegung
Weiterführende Informationen
•
EL37x2 - LEDs
•
EL37x2 - Anschlussbelegung


EL37x2 - LEDs

Montage und Verdrahtung [image] EL37x2 - LEDs und Anschlussbelegung [image] EL37x2 - LEDs
EL37x2 - LEDs
LEDs (ab Hardwarestand 03)
EL37x2 LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LEDs geben den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | gleichmäßig blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | langsam blinkend | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | schnell blinkend* | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
* nur LED RUN 1


EL37x2 - Anschlussbelegung

Montage und Verdrahtung [image] EL37x2 - LEDs und Anschlussbelegung [image] EL37x2 - Anschlussbelegung
EL37x2 - Anschlussbelegung
Anschlussbelegung EL3702, EL3742
Anschlussbelegung und Beschaltung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
+ Input 1 | 1 | + Eingang 1
- Input 1 | 2 | - Eingang 1
GND | 3 | Signalmasse für Eingang 1 (intern verbunden mit Klemmstelle 7)
Shield | 4 | Schirm
+ Input 2 | 5 | + Eingang 2
- Input 2 | 6 | - Eingang 2
GND | 7 | Signalmasse für Eingang 2 (intern verbunden mit Klemmstelle 3)
Shield | 8 | Schirm
Galvanische Isolierung der Eingänge
Galvanische Isolierung der Eingänge
Beispiel: Beschaltung EL3702
In Abb. 2 ist das Ersatzschaltbild mit einer variablen Spannungsquelle (Kanal 2) als Äquivalent der Beschaltung von Kanal 1 mit einem Sensor und Messverstärker anzusehen.
EL3702 - Ersatzschaltbild mit variabler Spannungsquelle
Beispiel: Beschaltung EL3742
In Abb. 2 ist das Ersatzschaltbild mit einer variablen Stromquelle (Kanal 2) als Äquivalent der Beschaltung von Kanal 1 mit einem Sensor anzusehen.
EL3742 - Ersatzschaltbild mit variabler Stromquelle


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Oversampling Klemmen/Boxen und TwinCAT Scope
•
Prozessdaten und Konfiguration
•
Hinweise zu analogen Spezifikationen


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Oversampling Klemmen/Boxen und TwinCAT Scope

Inbetriebnahme [image] Oversampling Klemmen/Boxen und TwinCAT Scope
Oversampling Klemmen/Boxen und TwinCAT Scope
Grundsätzlich können Eingangsdaten einer Klemme/Box entweder direkt (über den aktivierten ADS-Server) oder über die Bildung einer PLC Variablen, auf die das PDO der Klemme/Box verweist mit dem Scope für deren Aufzeichnung erreicht werden. Beide Vorgehensweisen werden im Folgenden jeweils zunächst für TwinCAT 3 (kurz: TC3) und dann für TwinCAT 2 (TC2) erklärt.
Oversampling bedeutet, dass ein analoges oder digitales Eingangsgerät je
Prozessdatenzyklus/EtherCAT-Zyklkus (Dauer T) nicht nur einen Messwert liefert, sondern mehrere, die in konstantem Abstand t < T ermittelt werden. Das Verhältnis T/t ist der Oversamplingfaktor n. In den Prozessdaten bietet so ein Kanal also nicht nur einen PDO zum Verlinken an wie hier im Beispiel die EL3102, sondern n davon wie die EL3702 und andere Oversampling-Klemmen/Boxen.
Der Begriff „Oversampling“ aus der Sicht von Beckhoff ist hierbei nicht zu verwechseln mit dem oversampling – Verfahren eines deltaSigma-ADC-Wandlers:
▪
deltaSigma-ADC: die Frequenz mit der der ADC das analoge Signal abtastet ist um ein Vielfaches schneller (üblicherweise MHz-Bereich) als die Frequenz der bereitgestellten digitalen Samples (üblicherweise kHz-Bereich) – dies wird Oversampling genannt, resultiert aus dem Funktionsprinzip diese Wandlertyps und dient u.a. dem AntiAliasing.
▪
Beckhoff: das Gerät/die Klemme/Box liest aus dem verwendeten ADC (der auch ein deltaSigma-ADC sein kann) digitale Samples n-mal öfter aus als die Zykluszeit beträgt und überträgt jedes Sample in die Steuerung – gebündelt als Oversampling-PDO-Block.
Beispielsweise sind diese beiden Methoden in der EL3751 in ihrer technischen Umsetzung nacheinander angeordnet und können somit gleichsam vorhanden sein.
Oversampling-PDO der Serie EL37xx und im Vergleich mit EL31xx
Das Scope2 (TC2) bzw. ScopeView (TC3) kann entsprechend mehrere PDO je Zyklus einlesen und zeitrichtig darstellen.
Weiterführende Informationen
•
Vorgehen bei TwinCAT 3
•
Vorgehen bei TwinCAT 2


Vorgehen bei TwinCAT 3

Inbetriebnahme [image] Oversampling Klemmen/Boxen und TwinCAT Scope [image] Vorgehen bei TwinCAT 3
Vorgehen bei TwinCAT 3
Ab TwinCAT 3.1 build 4012 und unter Verwendung der unten angegebenen Revision erkennt das integrierte ScopeView in seinem VariablenBrowser, dass die Oversampling-Daten ein Array-Paket sind und aktiviert ForceOversampling selbsttätig. Die Feldvariable ist per „Add Symbol“ als Array als Gesamtes auszuwählen (siehe Erläuterung im nächsten Abschnitt). Der erweiterte PDO-Name liefert dafür die Grundlage. Ab einer bestimmten Revision der jeweiligen Klemme/Box kann also ScopeView den Array-Typ einer Gruppe von Variablen von sich aus erkennen.
Klemme | Revision
EL4732 | alle
EL4712 | alle
EL3783 | EL3783-0000-0017
EL3773 | EL3773-0000-0019
EL3751 | alle
EL3742 | alle
EL3702 | alle
EL3632 | alle
EL2262 | alle
EL1262-0050 | alle
EL1262 | alle
EP3632-0001 | alle
EPP3632-0001 | alle
Aufzeichnung einer PLC Variablen mit dem TwinCAT 3 – ScopeView
Unter Voraussetzung eines bereits erstellten TwinCAT 3 – Projekts und einer angeschlossenen PLC mit einer oversampling-fähigen Klemme/Box in der Konfiguration wird im Folgenden gezeigt, wie eine oversampling Variable im Scope (als Standard Bestandteil der TwinCAT 3 Umgebung) dargestellt werden kann. Dies wird Ausgehend von einem Beispielprojekt „SCOPE_with_Oversampling“, einem Standard PLC Projekt in einigen Schritten erklärt.
Schritt 1: Hinzufügen eines Projektes „Scope YT“
Dem Beispielprojekt „SCOPE_with_Oversampling“ wird durch Rechtsklick (A) und der Auswahl (B) „Add“ → „New Project..“ ein TwinCAT Measurement – Projekt „Scope YT Projekt“ (C) hinzugefügt. Als Name wird „Scope for OS“ eingetragen. Das neue Projekt erscheint sogleich im Solution Explorer (D).
Hinzufügen eines Scope Projekts zu einem bereits vorhandenen Projekt
Schritt 2a: Erzeugen einer PLC Variablen in einer POU
In der TwinCAT 3 Entwicklungsumgebung wird zunächst einer POU des Projekts eine Eingangsvariable als Feld mit entsprechender Größe des vorgegebenen Oversamplingfaktors in einer POU definiert wie im Folgenden im Beispiel mit strukturierten Text (ST) für die POU „MAIN“ für den Oversamplingfaktor 10 gezeigt ist:
PROGRAM MAIN
VAR
aU1_Samples AT%I* : ARRAY[0..9] OF INT;
END_VAR
Die Kennzeichnung “AT%I*” steht für die spätere Auslagerung dieser Feldvariable um sie mit den Prozessdatenobjekten (PDOs) einer Klemme/Box zu Verknüpfen. Anzumerken ist, dass die Feldvariable lediglich die gleiche Anzahl von Elementen wie der Oversampling Faktor haben muss; daher können die Indizes auch von 0 bis 9 gesetzt werden. Sobald der Kompiliervorgang gestartet und erfolgreich abgeschlossen wurde (wobei zunächst nicht unbedingt Programmcode vorhanden sein muss), erscheint diese Feldvariable im Solution Explorer der TwinCAT 3 Entwicklungsumgebung in der Gruppe PLC unter „..Instance“.
In der folgenden Darstellung sind rechts Ausschnitte des Solution Explorers gezeigt. Beispielsweise wird hierbei das Verknüpfen einer Feldvariablen mit einem Satz an oversampling Prozessdaten einer EL3773 gezeigt:
Darstellung der erstellten PLC Feldvariablen („aUI_Samples“) zur Verknüpfung mit oversampling PDOs einer EL3773
Schritt 2b: Erzeugen einer PLC Variablen über eine freie Task
Wird eine POU auf dem jeweiligen System nicht benötigt, so kann eine Variablenreferenz auch über eine freie Task angelegt werden. Falls eine freie Task noch nicht vorhanden ist, ist sie über rechts-Klick auf „Tasks“ über das Projekt im SYSTEM per „Add New Item…“ zu erstellen:
Einfügen einer "freien" Task
Die Task ist als „TwinCAT Task With Image“ einzufügen und erzeugt dadurch auch einen „Inputs“ und „Outputs“ Ordner. Die Eigenschaften der neuen (oder ggf. Vorhandenen Task) muss die Einstellung „Create symbols“ aktiviert haben, damit der „Target Browser“ des Scope diese später auswählbar macht. Die Taskzykluszeit ist ggf. ebenfalls einzustellen. In diesem Fall wird beispielsweise bei 10 x Oversampling mit der EL3751 1 ms bei 100 µs Basiszeit, also 10 Ticks gewählt:
Task Eigenschaft "Create symbols" ist zu aktivieren
Für die Portangabe liegt eine Voreinstellung vor (hier: 301) und kann falls nötig geändert werden. Diese Zahl muss später ggf. dem Scope bekannt gemacht werden. Durch einen rechts-Klick auf „Inputs“ kann nun die dem Oversampling zugrunde liegende Variable mit dem passenden Datentyp als Array hinzugefügt werden; in diesem Fall „ARRAY [0..9] OF DINT“ mit der Bezeichnung „Var 1“:
Einfügen der zum Oversampling passenden Variablen „Var 1“
Schritt 3: Verknüpfen der Feldvariablen mit einem oversampling PDO
Durch Rechtsklick auf „MAIN.aUI_Samples“ (für den vorhergehenden Schritt 2a) bzw. „Var 1“ der freien Task 1(für den vorhergehenden Schritt 2b) im Solution Explorer wird ein Fenster zur Auswahl der Prozessdaten geöffnet:
Setzen der Verknüpfung der PLC Feldvariablen (links: vorhergehender Schritt 2a; rechts: : vorhergehender Schritt 2b)
Auswahl des EL3773 PDO "L1 Voltage Samples" zum Erstellen eines Links mit der PLC Feldvariablen „aUI_Samples“
Die Auswahl des PDO "U1 Samples" der EL3773 für “MAIN.aUI_Samples”, wie oben gezeigt, basiert auf für den vorhergehenden Schritt 2a und ist ggf. für "Var 1" in gleicher Weise vorzunehmen.
Schritt 4: Auswahl der PLC Feldvariablen für die Y-Achse des Scope
Nun wird die Konfiguration aktiviert ( [image])und auf die PLC eingeloggt ( [image]), damit für den „target browser“ des Scope die Feldvariable zur Auswahl erscheinen kann.
Dazu wird mit einem Rechtsklick auf „Axis“ (A) das drop-down Menü für die Auswahl der Scope Funktionen geöffnet (B):
Auswahl der oversampling - Variablen mit dem "target browser"
Mit dem Anwählen des jeweiligen Systems, der die PLC mit der Feldvariablen aus der POU „MAIN“ entspricht (in diesem Fall „Any PC (CX2040)“) wird bis zu der „aUI_Samples“ Variablen navigiert (C):
Hinzufügen der "aUI_Samples" Feldvariablen zu "Axis" des Scope
Variable erscheint nicht im Target Browser
Falls „ROUTES“ keine Auswahlmöglichkeit der bereitgestellten Variablen bietet, sollte der entsprechende Port dem Target Browser bekannt gemacht werden:
Mit „Add Symbol“ wird sogleich die „aUI_Samples“ Feldvariable unterhalb von „Axis“ des Scope-Projekts im Solution Explorer angezeigt.
Nun ist – obwohl bislang kein Programm vorliegt – mit [image] der Programmstart formal vorzunehmen. Mit „Start Recording“ [image] kann nun der Prozessdatenwert des Oversampling-PDO „L1 Voltage Samples“ über die verlinkte PLC Feldvariable zeitlich aufgezeichnet werden.
Als Beispiel wird eine Sinusförmige Eingangsmessgröße (204,5 Hz) im Folgenden dargestellt:
Beispiel einer Messung eines Sinussignals mit 10 Fach Oversampling bei 1 ms Messzykluszeit
Mittels „Panning X“ [image] ist nach Beendigung der Aufzeichnung [image] die X-Achse passend sakaliert. Nachfolgend die „Chart“-Eigenschaft „Use X-Axis SubGrid“ auf „True“ mit 10 Teilungen sowie innerhalb der „.ChannelNodeProperties“ die Eigenschaft „Marks“ auf „On“ mit den Farben „Line Color“ Blau und „Mark Color“ Rot eingestellt worden. Letzteres zeigt somit die 10 oversampling-Messpunkte durch die roten Markierungen.
Vorgehen bei TwinCAT 3 / alternativ per ADS
Bei früheren TwinCAT 3 Versionen (oder einer kleineren Revision der Klemme als wie in obiger Tabelle angegeben) kann per Aktivierung des ADS Servers das Oversampling-PDO der betreffenden oversampling fähigen Klemme/Box für das ScopeView sichtbar gemacht werden.
Aktivierung des ADS Servers des EtherCAT Device (TwinCAT 3)
Die Aktivierung des Servers erfolgt durch Auswahl von „Image“ im linksseitigen Solution Explorer:
„I/O → Devices → Device .. (EtherCAT) → Image“.
Hier wird dann der Karteireiter „ADS“ ausgewählt und jeweils die Checkbox „Enable ADS Server“ und dann „Create symbols“ aktiviert (der Port – Eintrag erfolgt automatisch).
Dadurch kann ohne eine eingebundene POU bzw. ohne einen Variablenverweis mit dem ScopeView per Target Browser auf Prozessdaten zugegriffen werden:
Direkter Zugriff des ScopeView auf PDOs der Klemme
Datentyp nicht korrekt
Es kann vorkommen, dass es dem „Target Browser“ nach dem Einfügen des oversampling PDO (entspricht i.d.R. einer Feldvariable) nicht gelingt den Datentyp zu ermitteln. In diesem Fall kann dieser nachträglich in den Kanaleigenschaften geändert werden:
TwinCAT 3: ADS Server des EtherCAT Gerätes aktivieren
Siehe hierzu im Beckhoff Information System:
infosys.beckhoff.com → TwinCAT 3 → TExxxx | TC3 Engineering → TE13xx | TC3 ScopeView → Anhang → How To’s → Oversampling-Aufnahmen mit dem TwinCAT 3 Scope


Vorgehen bei TwinCAT 2

Inbetriebnahme [image] Oversampling Klemmen/Boxen und TwinCAT Scope [image] Vorgehen bei TwinCAT 2
Vorgehen bei TwinCAT 2
TwinCAT Scope2 unterstützt das Einlesen und die Anzeige von Oversampling-Prozessdaten wie sie von oversampling-fähigen Klemmen/Box zur Verfügung stehen.
Vorraussetzungen
Es muss ein TwinCAT Scope2 auf dem System installiert sein.
Es muss eine oversampling-fähige Klemme/Box in der Konfiguration vorhanden sein.
Das TwinCAT Scope2 bekommt über die ADS-Daten auch den Datentyp der Variablen übermittelt. Deshalb ist die ARRAY-Variable anzulegen
▪
in der PLC, siehe Schritt 1a
▪
oder direkt im System Manager wenn nur eine freie Task vorliegt, siehe Schritt 1b
Im Scope2 sind für beide Fälle dieselben Einstellungen vorzunehmen, siehe Schritt 2
Aufzeichnung einer PLC Variablen mit dem TwinCAT 2 – Scope2
Schritt 1a: Erzeugen einer PLC Variable über eine POU
Da die Kanaldaten in der PLC verwendet werden sollen, ist dort eine verlinkbare ARRAY-Variable anzulegen, wie in folgendem Beispiel gezeigt:
PLC Deklaration
Im System Manager erscheint diese dann in der Liste, in der Regel ist sie dann auch ohne weitere Maßnahmen über ADS erreichbar da PLC-Variablen immer als ADS-Symbol im Hintergrund angelegt werden.
PLC im System Manager
Hinweis: das Scope2 kann solche Variablen im Variablen Browser nur "sehen", wenn sich TwinCAT und die PLC im RUN befinden.
Schritt 1b: Erzeugen einer PLC Variable über eine freie Task
Die für das Scope2 notwendige Array-Variable kann alternativ auch manuell im System Manager definiert und angelegt werden.
Add Variable Type
Wie bisher im Programm (POU „Main“) ist auch hier eine ARRAY-Variable vom gleichen Typ wie die oversampling PDO der jeweiligen Klemme/Box anzulegen. In diesem Beispiel nun ein Array 0..9 vom Typ INT, also mit 10 Feldern.
Definieren des Variablen Typs
Wenn diese Variable dem System Manager bekannt ist, kann eine Instanz davon einer zusätzlichen Task mit Rechtsklick zugeordnet werden. Sie erscheint in der nach Bitgröße sortierten Übersicht.
Übersicht deklarierte Typen
In diesem Beispiel wird die Variable Var152 angelegt. Sie kann nun mit dem PDO-Array vom jeweiligen Kanal der Klemme/Box verlinkt werden.
Verlinken
Wenn im Dialog MatchingSize aktiviert ist, bieten sich direkt die einzelnen Kanäle an.
Array-Variablen einer Oversampling-Klemme
Damit die Variablen auch über ADS im Scope2 zu finden sind, sind die ADS-Symbole zu aktivieren, so wie das Enable Auto-Start, sonst läuft die Task nicht selbsttätig. Dann werden ADS-Symboltabellen von allen Variablen angelegt, die diese Task in ihren Prozessdatenimages hat.
Einstellungen in der zusätzlichen Task
Schritt 2: Konfiguration im Scope2
Damit die Verlinkung funktioniert, muss im System Manager je eine Array-Variable mit den Kanaldaten der jeweiligen Klemme/Box vorliegen, d. h. jedes Oversampling-Datenpaket muss in einem Array vorliegen. Diese Array-Variable ist manuell zu definieren und anzulegen, siehe oben.
Im Scope2 kann nun bis zur betreffenden Variable gebrowst werden.
Variablenbrowser bis zum Array VAR152
Es ist dann nicht das Array zu öffnen, sondern direkt das Array-Symbol per Rechtsklick AddSymbol auszuwählen.
AddSymbol auf dem Array
Im Einstellungsdialog des nun erzeugten Kanals ist ForceOversampling und DataType INT16 einzustellen. Ggf. ist dazu vorübergehend SymbolBased zu deaktivieren.
Channel-Einstellungen
Zur Überprüfung, dass wirklich die einzelnen Oversampling-Werte geloggt werden, können im Scope2 die Marks aktiviert werden. Bitte beachten Sie die Zusammenhänge aus Task-Zykluszeit, Sampling-Zeit des Scope2-Kanals und Oversamplingfaktor.
Aktivieren der Marks
Ein weiteres Beispiel zeigt die folgende Abbildung der Darstellung einer Oversampling – Variablen der EL3751 mit 10 x Oversampling:
Darstellung einer 10 x Oversampling-Variablen der EL3751 mit dem Scope2
In der Abbildung ist nachträglich eingezeichnet, das die von der PLC stammende Oversampling Variable mit „Add Symbol“ einfach als Y-Kanal der Achse eingefügt wurde (Auswahl des PLC-POU Namen „MAIN“ im „ROUTES“ - Baum beachten). Hierbei ist „Force Oversampling“ aktiviert, da es sich nicht um eine von der Klemme/Box bereit gestellte Oversampling-Variablen handelt.
Vorgehen bei TwinCAT 2 / alternativ per ADS
Bei früheren TwinCAT 2 Versionen (oder einer kleineren Revision der Klemme als wie in obiger Tabelle angegeben) kann per Aktivierung des ADS Servers das Oversampling-PDO der betreffenden oversampling fähigen Klemme/Box für das Scope2 sichtbar gemacht werden.
Es kann so ebenfalls auf die Erstellung einer Feldvariablen in einer PLC verzichtet werden. Dazu ist der ADS Server des EtherCAT Device zu aktivieren, an dem die oversampling fähige Klemme/Box angeschlossen ist.
Aktivierung des ADS Servers des EtherCAT Device (TwinCAT 2)
Die Aktivierung des Servers erfolgt durch Auswahl des „Device – Image“ im linksseitigen Konfigurationsbaum: „I/O – Configuration → I/O Devices → Device .. (EtherCAT) → Device .. – Image“.
Hier wird dann der Karteireiter „ADS“ ausgewählt und jeweils die Checkbox „Enable ADS Server“ und dann „Create symbols“ aktiviert (der Port Eintrag erfolgt automatisch).
Dadurch kann ohne eine eingebundene POU bzw. ohne einen Variablenverweis mit dem Scope2 per Target Browser auf Prozessdaten zugegriffen werden:
Direkter Zugriff des Scope2 auf PDOs der Klemme
Siehe hierzu im Beckhoff Information System
infosys.beckhoff.com → TwinCAT 2 → TwinCAT Supplement → Kategorie Measurement TS3xxx → TS3300 | TwinCAT Scope 2 → Anhang → Oversampling Aufnahme
Beckhoff TwinCAT unterstützt das Scope2 bei einigen Oversampling-Geräten in spezieller Weise, indem es automatisch im Hintergrund ein besonderes ADS-Array-Symbol berechnet, das im Scope2 im Variablenbrowser erscheint. Dieses kann dann als Variable verlinkt werden und bringt automatisch die Array-Information mit.
Automatisch berechnete Array-Variable (rot) im Scope2
Zusammenfassung: es muss eine ARRAY-Variable vorliegen die über ADS erreichbar ist. Dies kann eine PLC-Variable, eine im System Manager definierte ARRAY-Variable sein oder alternativ ist der ADS Server des Device der Klemme/Box aktiviert. Diese wird dann vom Scope2 erkannt.


Prozessdaten und Konfiguration

Inbetriebnahme [image] Prozessdaten und Konfiguration
Prozessdaten und Konfiguration
Weiterführende Informationen
•
TwinCAT Baum
•
Prozessdatenumfang im Auslieferungszustand
•
Oversampling-Einstellungen, Distributed Clocks (DC)


TwinCAT Baum

Inbetriebnahme [image] Prozessdaten und Konfiguration [image] TwinCAT Baum
TwinCAT Baum
Auf die Funktionsweise der EL37x2 mit dem Einsatz des SYNC0- und SYNC1-Pulses wurde bereits im Abschnitt "Grundlagen zur Funktion" eingegangen. Hier wird nun die Einstellung der aufgeführten Parameter mit dem Beckhoff TwinCAT System Manager beschrieben.
Nach dem Einscannen der Klemme ist folgende Baumstruktur ersichtlich (siehe Abb. TwinCAT Baum EL37x2).
TwinCAT Baum EL37x2
Ch1/Ch2 CycleCount und Ch1/Ch2 Value
Jeder Datensatz der EL37x2 beinhaltet je Kanal einen CycleCounter, der mit jedem Datensatz um eine Einheit hochgezählt wird und die n analogen Messwerte von je 2 byte Breite. Bei einem Oversamplingfaktor von n = 25 besteht so ein Datensatz also aus einem 16 Bit CycleCounter (überlaufend) und 25 16-Bit Samples je Kanal. Durch den CycleCounter in der übergeordneten Steuerung eine Kontrolle möglich, ob evtl. ein Datensatz ausfiel oder doppelt übertragen wurde.
Defaultmäßig ist die EL37x2 auf n = 1 eingestellt, das Prozessabbild nach Abb. TwinCAT Baum EL37x2 ergibt sich daraus.
WcState 0/1 (Karteireiter Online)
Boolesche Variable, die den Working Counter Status der Klemme anzeigt. Ein ungültiger Working Counter (Wert: 1) wird angezeigt, wenn ungültige Daten vom EtherCAT Slave Controller übertragen wurden.
WCState, Karteireiter Online
InfoData, State
Zeigt den Online-Status (EtherCAT State Machine) der Klemme an.
InfoData, Karteireiter Online
Wert | Beschreibung
0x___1 | Slave in 'INIT' state
0x___2 | Slave in 'PREOP' state
0x___3 | Slave in 'BOOT' state
0x___4 | Slave in 'SAFEOP' state
0x___8 | Slave in 'OP' state
0x001_ | Slave signals error
0x002_ | Invalid vendorId, productCode... read
0x004_ | Initialization error occurred
0x010_ | Slave not present
0x020_ | Slave signals link error
0x040_ | Slave signals missing link
0x080_ | Slave signals unexpected link
0x100_ | Communication port A
0x200_ | Communication port B
0x400_ | Communication port C
0x800_ | Communication port D
Tab. 1: Stati der EtherCAT State Machine


Prozessdatenumfang im Auslieferungszustand

Inbetriebnahme [image] Prozessdaten und Konfiguration [image] Prozessdatenumfang im Auslieferungszustand
Prozessdatenumfang im Auslieferungszustand
Prozessdaten
Der Umfang der angebotenen Prozessdaten und die Zuordnung der SyncManager im Auslieferungszustand kann über den Reiter „Prozessdaten“ eingesehen werden (siehe Abb. Karteireiter Prozessdaten SM0+SM1+SM2, EL37x2).
Karteireiter Prozessdaten SM0, EL37x2
Karteireiter Prozessdaten SM1, EL37x2
Karteireiter Prozessdaten SM2, EL37x2
Sync Manager (SM)
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ (Abb. Karteireiter Prozessdaten SM0+SM1+SM2, EL37x2) den gewünschten Sync Manager (editierbar ist hier nur SM2). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abschaltet werden (Index 0x1B10). Ein Neustart des EtherCAT-Systems oder Neuladen der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM0, PDO-Zuordnung 0x1C10
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1B00 | - | 2.0 | Ch 1 CycleCount | Index 0x6800:01 - Ch 1 CycleCount
0x1A00 .. 0x1A63 | - | 2.0 | Ch 1 Sample 0 .. Ch 1 Sample 99 | Index 0x6000:01 - Ch 1 Value .. Index 0x6630:01 - Ch 1 Value
SM1, PDO-Zuordnung 0x1C11
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1B01 | - | 2.0 | Ch 2 CycleCount | Index 0x6800:01 - Ch 2 CycleCount
0x1A80 .. 0x1AE3 | - | 2.0 | Ch 2 Sample 0 .. Ch 2 Sample 99 | Index 0x6000:01 - Ch 2 Value .. Index 0x6630:01 - Ch 2 Value
SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1B10 | - | 4.0 | Ch 2 CycleCount | Index 0x1D09:98:01 - StartNextTimeLatch
Tab. 2: PDO-Zuordnung der Sync Manager


Oversampling-Einstellungen, Distributed Clocks (DC)

Inbetriebnahme [image] Prozessdaten und Konfiguration [image] Oversampling-Einstellungen, Distributed Clocks (DC)
Oversampling-Einstellungen, Distributed Clocks (DC)
Beispiel: Einstellung 2 kanaliges, 2 faches Oversampling
Im Reiter "DC" (s. Abb. Karteireiter Prozessdaten, Beispiel Einstellung 2 kanaliges, 2 faches Oversampling) kann der Oversamplingfaktor eingestellt werden. Wird nur ein Kanal der EL37x2 benötigt, kann zur Prozessdatenreduktion die entsprechende Betriebsart nach Abb. Karteireiter Prozessdaten, Beispiel Einstellung 2 kanaliges, 2 faches Oversampling gewählt werden. Durch die Anwahl eines Eintrages im Auswahldialog wird automatisch sowohl das richtige Erfassungsverhältnis auf Distributed-Clocks-Ebene, als auch die korrekte Anzahl der zu übertragenden Prozessdaten eingestellt.
Samplingfrequenz
Wird ein Oversamplingfaktor benötigt, der nicht in der Liste aufgeführt ist, obliegt es dem Anwender, mit den Information aus "Grundlagen zur Funktion" den SYNC0-Puls in die gewünschte Relation zum SYNC1-Puls innerhalb der zulässigen Grenzen zu setzen. Siehe dazu das Beispiel.
Karteireiter Prozessdaten, Beispiel Einstellung 2 kanaliges, 2 faches Oversampling
Bei einer Oversamplingeinstellung n = 2 und 2 genutzten Kanälen ergibt sich das Prozessabbild nach Abb. TwinCAT Baum, Beispiel Einstellung 2 kanaliges, 2 faches Oversampling.
TwinCAT Baum, Beispiel Einstellung 2 kanaliges, 2 faches Oversampling
"StartTimeNextLatch"-Aktivierung
Durch die Anwahl des Sync Manager 2 (Abb. Karteireiter Prozessdaten, Aktivierung des Indizes 0x1B10, Eintrag „StartTimeNextLatch“, oben links), kann im Feld darunter das zugeordnete Prozessdatum "StartTimeNextLatch" durch 0x1B10 zur Übertragung auf den EtherCAT-Bus aktiviert werden.
Karteireiter Prozessdaten, Aktivierung des Indizes 0x1b10, Eintrag „StartTimeNextLatch“
Im 32 Bit breiten Prozessdatum StartTimeNextLatch wird in jedem Prozessdatenzyklus der Zeitpunkt angegeben, wann der nächste SYNC1-Puls und damit der nächste Block an Sample-Werten beginnt. StartTimeNextLatch verändert sich also in jedem Zyklus um den Betrag derjenigen Taskzykluszeit, mit der diese Klemme betrieben wird. Diese Zeitangabe basiert auf der klemmenlokalen Distributed Clocks Zeit. Die EL37x2 bildet allerdings nur die unteren 32 Bit der im Allgemeinen 64 Bit großen Distributed Clocks Zeit ab.
Durch diese Zeitangabe können mit dem bekannten Oversamplingfaktor alle Samples zeitlich mit anderen Zeitangaben im EtherCAT-Bus in Zusammenhang gebracht werden.
Beispiel:
Die EL37x2 liefert im betrachteten Zyklus bei 1 ms Zykluszeit (= 1.000.000 ns) und Oversamplingfaktor = 20 als Prozessdaten ein StartTimeNextLatch = 7.777.216dez und 2 x 20 Messwerte zu je 16 Bit. Es soll nun der Messzeitpunkt des 5. gelieferten Samples ermittelt werden, d.h. um welche Distributed Clocks Zeit das 5. Sample ermittelt wurde.
Der aktuell gelieferte Satz von 20 Samples wurde zum Zeitpunkt
7.777.216 - 1.000.000 (Zykluszeit) = 6.777.216 ns gestartet.
Der Zeitabstand zwischen den Samples beträgt 1.000.000 / 20 = 50.000 ns.
Das 5. Sample wurde also zum Zeitpunkt 6.777.216 + ((5 - 1) * 50.000) = 6.977.216 ns ermittelt.
TwinCAT Baum, Eintrag "StartTimeNextLatch"
Spezieller Oversamplingfaktor und "Shift-Time" für den SYNC0-Puls
SmallWarningYellow VORSICHT
VORSICHT! Beschädigung der Geräte möglich!
Bei der Manipulation dieser Einstellungen im System Manager wird softwareseitig keine Plausibilitätskontrolle durchgeführt!
Eine korrekte Funktion der Klemme in allen denkbaren Einstellungsvarianten kann nicht gewährleistet werden!
Soll ein Oversamplingfaktor eingestellt werden, der nicht im Dialog angeboten wird, kann das Verhältnis von SYNC0 zu SYNC1-Puls manuell eingestellt werden. Dazu öffnen Sie den Dialog "Advanced Settings" im Reiter DC (Abb. Karteireiter DC, Aktivierung „Advanced Settings…“).
Ebenso kann hier ein zeitliches Versetzen mehrerer EL37x2 durch eine lokale Shift-Time eingestellt werden (Abb. Karteireiter DC, Aktivierung „Advanced Settings…“, „Distributed Clocks“).
Karteireiter DC, Aktivierung „Advanced Settings…“
Karteireiter DC, Aktivierung “Advanced Settings…”, “Distributed Clocks”
Beispiel:
Einstellung eines neuen Oversamplingfaktors:
In Abb. Karteireiter DC, Aktivierung „Advanced Settings…“, „Distributed Clocks“ befindet sich TwinCAT im Config-Modus mit 4 ms Zykluszeit (4000 µs). Deshalb wird der SYNC1-Puls alle 4000 µs ausgelöst. Der Oversamplingfaktor soll nun auf 80 eingestellt werden. Deshalb ist ein SYNC0-Abstand von 50 µs erforderlich. Dazu wird für SYNC0-Cycle Time entweder der entsprechende Teiler ausgewählt oder per "Anwenderdefiniert" manuell 50 µs eingetragen. Damit wird der ADC nun im gewünschten Zeitabstand angestoßen.

Zusätzlich muss die Anzahl der übertragenen Prozessdaten an den neuen Faktor angepasst werden. Im Beispiel sind also je Kanal 80 Werte erforderlich.
Karteireiter Prozessdaten, Anpassung der Prozessdaten in SM0
Karteireiter Prozessdaten, Anpassung der Prozessdaten in SM1
Wählen Sie nacheinander SM0 und SM1(Abb. Karteireiter Prozessdaten, Anpassung der Prozessdaten in SM0 + SM1) an und markieren Sie im Feld darunter (PDO Zuordnung) die dem Oversamplingfaktor gleichlautende Anzahl an Prozessdaten, hier also jeweils 80dez.
Vergleichen Sie in der rechtsstehenden PDO-Liste den PDO-Index mit dem letzten zu aktivierenden PDO in der PDO Zuordnung. In diesem Fall sind alle PDOs größer 0x1A4F (SM0) bzw. 0x1ACF (SM1) zu deaktivieren!
Übereinstimmung Oversamplingfaktor/Prozessdaten
Stimmt die Anzahl der Prozessdaten nicht mit dem Oversamplingfaktor n überein, wird die Klemme zwar den OP-State erreichen, aber keine Prozessdaten erzeugen!
Beispiel:
Beispiel für Einstellung einer Shift-Time:

Tragen Sie manuell bei SYNC0-Shift-Time-User defined (Abb. Karteireiter DC, Aktivierung „Advanced Settings…“, „Distributed Clocks“) eine Ihren Vorstellungen entsprechende Zeit ein. Ein automatisch vom EtherCAT-Master generierter Wert kann dabei überschrieben werden. Dieser sollte aber bei der Berechnung berücksichtigt werden.
Beispiel: Ein Wert von "-5" ist voreingetragen. Eine zusätzliche Verschiebung von +10 µs wird gewünscht. Dann wird als neuer Wert -5 + 10 = +5 eingetragen.
Die gesamten zeitbasierten/Distributed Clocks basierten Interrupts (SYNC0/SYNC1) werden nun um diesen Betrag gegenüber anderen EtherCAT-Slaves versetzt laufen.


Hinweise zu analogen Spezifikationen

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen
Hinweise zu analogen Spezifikationen
Beckhoff IO-Geräte (Klemmen, Boxen, Module) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Weiterführende Informationen
•
Messbereichsendwert (MBE)
•
Messfehler/ Messabweichung
•
Temperaturkoeffizient tK [ppm/K]
•
Typisierung SingleEnded / Differentiell
•
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
•
Spannungsfestigkeit
•
Zeitliche Aspekte der analog/digital Wandlung


Messbereichsendwert (MBE)

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Messbereichsendwert (MBE)
Messbereichsendwert (MBE)
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereichsendwert, Messspanne
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200...1370°C: asymmetrisch bipolar, MBE = 1370°C, Messspanne = 1570°C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/ -boxen (bzw. verwandten Beckhoff‑Produktgruppen).


Messfehler/ Messabweichung

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Messfehler/ Messabweichung
Messfehler/ Messabweichung
Der relative Messfehler (% vom MBE) bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung usw.).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3% MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Geringerer Messfehler
Da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsgeräte.


Temperaturkoeffizient tK [ppm/K]

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Temperaturkoeffizient tK [ppm/K]
Temperaturkoeffizient tK [ppm/K]
Eine elektronische Schaltung ist in der Regel mehr oder weniger temperaturabhängig. Im Bereich der analogen Messtechnik bedeutet dies, daß der mittels einer elektronischen Schaltung ermittelte Messwert reproduzierbar in seiner Abweichung vom „wahren“ Wert von der Umgebungs/Betriebstemperatur abhängig ist.
Lindern kann ein Hersteller dies durch Verwendung höherwertiger Bauteile oder Software-Maßnahmen.
Der von Beckhoff ggf. angegebene Temperaturkoeffizient erlaubt es dem Anwender den zu erwartenden Messfehler außerhalb der Grundgenauigkeit bei 23°C zu berechnen.
Aufgrund der umfangreichen Unsicherheitsbetrachtungen, die in die Bestimmungen der Grundgenauigkeit (bei 23°C) eingehen, empfiehlt Beckhoff eine quadratische Summierung.
Beispiel: Grundgenauigkeit bei 23°C sei ±0,01% typ. (MBE), tK = 20 ppm/K typ., gesucht ist die Genauigkeit G35 bei 35°C, somit ΔT = 12K
Anmerkungen:
ppm ≙ 10-6
% ≙ 10-2


Typisierung SingleEnded / Differentiell

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Typisierung SingleEnded / Differentiell
Typisierung SingleEnded / Differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
SE und DIFF-Modul als 2-kanalige Variante
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss. Galvanisch getrennte Kanäle arbeiten grundsätzlich in differentieller Art, nur dass überhaupt kein direkter (galvanischer) Massebezug im Modul hergestellt ist. Spezifikationsangaben zu empfohlenen und maximalen Spannungen sind jeweils allerdings zu beachten.
Grundsätzlich gilt:
▪
Die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten.
Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
Dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
Für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
–
Bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt.
Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
Es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen.
Beckhoff IO-Module verfügen über 1..8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden
–
wie sich die Kanäle INNERHALB eines Module zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
–
Beckhoff Klemmen/ Boxen (bzw. verwandte Produktgruppen) sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen/ Boxen also nicht über die Powerkontakte/ Powerleitung miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
–
Falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder ein 1-Kanal-Modul keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
Analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Dokumentationen zu den Klemmen/ Boxen sind zu beachten.
Erläuterung
▪
differentiell (DIFF)
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (vgl. Abb. SE und DIFF-Modul als 2-kanalige Variante) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)", wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/ Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/ Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird.
Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung in Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
–
Weitere hilfreiche Ergänzungen dazu sind der Dokumentationsseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) zu entnehmen.
▪
Single Ended (SE)
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/ Box von außen zum Anschluss des Bezugspotenzials zugänglich sein, z. B. über die Powerkontakte/ Powerleitung.
–
SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/ Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z. B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/Bezugspotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst.
Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4-20mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss siehe Abb. 2-Leiter-Anschluss, vgl. IEC60381-1
▪
Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
2-Leiter-Anschluss
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/ Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Extern versorgte Sensoren
▪
3- und 4-Leiter-Anschluss siehe Abb. Anschluss extern versorgte Sensoren, vgl. IEC60381-1
▪
Die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:
–
1 Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm.
–
2 Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +Supply/-Supply/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
Ja:
Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
Nein:
es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Bei unipolaren Klemmen/ Boxen (und verwandten Produktgruppen) ist üblicherweise eine interne Diode vorhanden, dann ist die Polarität/Stromrichtung zu beachten:
Anschluss extern versorgte Sensoren
Einordnung der Beckhoff-Klemmen/ Boxen - Beckhoff 0/4-20mA Klemmen/ Boxen (und verwandten Produktgruppen) sind als differentiell und single-ended verfügbar:
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA, genauso KL und verwandten Produktgruppen | differentiell EL3x1x: 0-20 mA, EL3x2x: 4-20 mA, genauso KL und verwandten Produktgruppen
Stromvorzugsrichtung da interne Diode | Stromvorzugsrichtung da interne Diode
Sind für den Anschluss von extern versorgenden Sensoren im 3/4-Leiter-Anschluss konzipiert. | Die Klemme/ Box ist eine passive differentielle Strommessvorrichtung, „passiv“ bedeutet, dass keine Sensorspeisung erfolgt.
Sind für den Anschluss von selbstversorgenden Sensoren im 2-Leiter-Anschluss konzipiert |
Single-ended
Differential
2-, 3- und 4-Leiter-Anschluss an Single Ended - und Differenz Eingänge


Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung (CommonMode, Ucm) wird als der Mittelwert der Spannungen an den einzelnen Anschlüssen/Eingängen definiert und wird gegen eine Bezugsmasse gemessen/angegeben.
Gleichtaktspannung (Ucm)
Bei der Definition des zulässigen Gleichtaktspannungsbereiches und bei der Messung der Gleichtaktunterdrückung (CMRR, common mode rejection ratio) bei differenziellen Eingängen ist die Definition der Bezugsmasse wichtig.
Die Bezugsmasse ist auch das Potential, gegen welches der Eingangswiderstand und die Eingangsimpedanz bei single-ended-Eingängen bzw. der Gleichtaktwiderstand und die Gleichtaktimpedanz bei differenziellen Eingängen gemessen werden.
Die Bezugsmasse ist an/bei der Klemme/ Box i.d.R. zugänglich. Orte dafür können Klemmkontakte, Powerkontakte/ Powerleitung oder auch nur eine Tragschiene sein. Zur Verortung siehe Dokumentation, die Bezugsmasse sollte beim betrachteten Gerät angegeben sein.
Bei mehrkanaligen Klemmen/ Boxen mit resistiver (=direkter, ohmscher, galvanischer) oder kapazitiver Verbindung zwischen den Kanälen ist die Bezugsmasse vorzugsweise der Symmetriepunkt aller Kanäle, unter Betrachtung der Verbindungswiderstände.
Beispiele für Bezugsmassen bei Beckhoff IO Geräten:
1.
internes AGND (analog GND) herausgeführt:
EL3102/EL3112, resistive Verbindung der Kanäle untereinander
2.
0V-Powerkontakt:
EL3104/EL3114, resistive Verbindung der Kanäle untereinander an AGND, AGND niederohmig verbunden mit 0V-Powerkontakt
3.
Erde bzw. SGND (shield GND):
–
EL3174-0002: Kanäle haben keine resistive Verbindung untereinander, aber sind kapazitiv durch Ableitkondensatoren an SGND gekoppelt
–
EL3314: keine interne Masse auf die Klemmpunkte herausgeführt, aber kapazitive Kopplung an SGND


Spannungsfestigkeit

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Spannungsfestigkeit
Spannungsfestigkeit
Es ist zu unterscheiden zwischen:
▪
Spannungsfestigkeit (Zerstörgrenze): eine Überschreitung kann irreversible Veränderungen an der Elektronik zur Folge haben, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
▪
Empfohlener Einsatzspannungsbereich: Bei einer Überschreitung kann nicht mehr von einem spezifikationsgemäßem Betrieb ausgegangen werden, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
Empfohlener Einsatzspannungsbereich
Es können in den Gerätedokumentationen besondere Spezifikationsangaben dazu und zur Zeitangabe gemacht werden, unter Berücksichtigung von:
▪
Eigenerwärmung
▪
Nennspannung
▪
Isolationsfestigkeit
▪
Flankensteilheit der Anlege-Spannung bzw. Haltedauern
▪
Normatives Umfeld (z.B. PELV)


Zeitliche Aspekte der analog/digital Wandlung

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Zeitliche Aspekte der analog/digital Wandlung
Zeitliche Aspekte der analog/digital Wandlung
Die Umwandlung des stetigen analogen elektrischen Eingangssignals in eine wertdiskrete digitale und maschinenlesbare Form wird in den Beckhoff analogen Eingangsbaugruppen EL/KL/EP mit sog. ADC (analog digital converter) umgesetzt. Obgleich verschiedene ADC-Technologien gängig sind, haben sie alle aus Anwendersicht ein gemeinsames Merkmal: nach dem Ende der Umwandlung steht ein bestimmter digitaler Wert zur Weiterverarbeitung in der Steuerung bereit. Dieser Digitalwert, das sog. Analoge Prozessdatum, steht in einem festen zeitlichen Zusammenhang mit der „Ur-Größe“, dem elektrischen Eingangswert. Deshalb können für Beckhoff analoge Eingangsgeräte auch entsprechende zeitliche Kenndaten ermittelt und spezifiziert werden.
In diesen Prozess sind mehrere funktionale Komponenten involviert, die mehr oder weniger stark ausgeprägt in jeder AI (analog input) Baugruppe wirken:
▪
die elektrische Eingangsschaltung
▪
die Analog/Digital-Wandlung
▪
die digitale Weiterverarbeitung
▪
die finale Bereitstellung der Prozess- und Diagnosedaten zur Abholung an den Feldbus (EtherCAT, K-Bus etc.)
Signalverarbeitung Analogeingang
Aus Anwendersicht sind dabei zwei Aspekte entscheidend:
▪
„Wie oft bekomme ich neue Werte?“, also eine Sampling-Rate im Sinne einer Schnelligkeit in Bezug auf das Gerät/den Kanal
▪
Wieviel Verzögerung verursacht die (gesamte) AD-Wandlung des Gerätes/des Kanals?
Also Hard- und Firmware-Teile in toto. Aus technologischen Gründen muss zur Bestimmung dieser Angabe die Signalcharakteristik betrachtet werden: je nach Signalfrequenz kann es zu unterschiedlichen Laufzeiten durch das System kommen.
Dies ist die „äußere“ Betrachtung des Systems „Beckhoff AI Kanal“ – intern setzt sich insbesondere die Signalverzögerung aus den verschiedenen Anteilen Hardware, Verstärker, Wandlung selbst, Datentransport und Verarbeitung zusammen. Auch kann ggf. intern eine höhere Abtastrate verwendet werden (z.B. bei deltaSigma-Wandlern) als „außen“ aus Anwendersicht angeboten wird. Dies ist aber für ein nutzseitige Betrachtung der Komponente „Beckhoff AI Kanal“ normalerweise ohne Belang bzw. wird entsprechend spezifiziert, falls es doch für die Funktion relevant ist.
Damit können für Beckhoff AI Geräte folgende Spezifikationsangaben zum AI Kanal aus zeitlicher Sicht für den Anwender angegeben werden:
1. Minimale Wandlungszeit [ms, µs]
Dies ist der Kehrwert der maximalen Sampling-Rate [Sps, Samples per second]:
Gibt an, wie oft der analoge Kanal einen neu festgestellten Prozessdatenwert zur Abholung durch den Feldbus bereitstellt. Ob der Feldbus (EtherCAT, K-Bus) diesen dann auch genauso schnell (also im Gleichtakt), schneller (weil der AI Kanal im langsame FreeRun läuft) oder langsamer (z.B. bei Oversampling) abholt, ist dann eine Frage der Einstellung des Feldbusses und welche Betriebsmodi das AI Gerät unterstützt.
Bei EtherCAT Geräten zeigt das sog. ToggleBit bei den Diagnose-PDO an (indem es toggelt), dass ein neu ermittelter Analogwert vorliegt.
Entsprechend kann eine maximale Wandlungszeit, also eine minimal vom AI Gerät unterstützte Samplingrate spezifiziert werden.
Entspricht IEC 61131-2 Kap 7.10.2 2) „Abtast-Wiederholzeit“
2. Typ. Signalverzögerung
Entspricht IEC 61131-2 Kap 7.10.2 1) „Abtastdauer“. Sie inkludiert nach dieser Betrachtung alle geräteinternen Hard- und Firmware-Anteile, aber nicht „äußere“ Verzögerungsanteile aus dem Feldbus oder der Steuerung (TwinCAT).
Diese Verzögerung ist insbesondere relevant für absolute Zeitbetrachtungen, wenn AI Kanäle zum Amplitudenwert auch einen zugehörigen Zeitstempel (timestamp) mitliefern – von dem ja angenommen werden darf, dass er in seinem Zeitwert zu dem außen ehemals physikalisch anliegenden Amplitudenwert passt.
Aufgrund der frequenzabhängigen Laufzeit eines Signals, kann ein dezidierter Wert nur für ein gegebenes Signal spezifiziert werden. Der Wert ist auch abhängig von ggf. veränderlichen Filtereinstellungen des Kanals.
Eine typische Charakterisierung in der Gerätedokumentation kann sein:
2.1 Signalverzögerung (Sprungantwort)
Stichworte: Einschwingzeit
Das Rechtecksignal kann extern mit einem Frequenzgenerator (Impedanz beachten!) erzeugt werden.
Als Erkennungsschwelle wird die 90% Grenze verwendet.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem (idealen) elektrischen Rechtecksignal und der Zeitpunkt wo der analoge Prozesswert die 90% Amplitude erreicht hat.
Diagramm Signalverzögerung (Sprungantwort)
2.2 Signalverzögerung (linear)
Stichwort: Gruppenlaufzeit
Beschreibt die Verzögerung eines frequenzkonstanten Signals
Testsignal kann extern mit einem Frequenzgenerator erzeugt werden, z.B. als Sägezahn oder Sinus. Referenz wäre dann ein zeitgleiches Rechtecksignal.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem eingespeisten elektrischen Signal einer bestimmten Amplitude und dem Moment wo der analoge Prozesswert denselben Wert erreicht.
Dazu muss die Testfrequenz in einem sinnvollen Bereich gewählt werden; diese kann z.B. bei 1/20 der maximalen Sampling-Rate liegen.
Diagramm Signalverzögerung (linear)
3. Weitere Angaben
Weitere Angaben können in der Spezifikation optional angeführt sein, wie z.B.
▪
Tatsächliche Sampling-Rate des ADC (wenn unterschiedlich von der Kanal-Sampling-Rate)
▪
Zeit-Korrekturwerte für Laufzeiten bei unterschiedlichen Filtereinstellungen
▪
usw.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Angaben Firmware EL37xx/EL47xx
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Angaben Firmware EL37xx/EL47xx

Anhang [image] Angaben Firmware EL37xx/EL47xx
Angaben Firmware EL37xx/EL47xx
Der Firmwarestand der EL-Serien EL37xx und EL47xx ist angegeben
▪
als aufgelaserte Seriennummer auf dem Gehäuse
▪
im ESC-Register 0E00hex
Zur Einsicht in das Register ist wie folgt vorzugehen (s. Abb. Firmware-Stand in EL37xx/EL47xx-Oversampling-Klemmen):
▪
EL-Klemme im EtherCAT-System, installieren, in OP-State setzen
▪
WorkingCounter = 0 kontrollieren
▪
über "Erweiterte Einstellungen" -> "Memory" den "StartOffset" auf "0e00" setzen
▪
durch "Reload"/AutoReload sicherstellen, dass ein aktueller Online-Wert angezeigt wird
▪
Firmware-Stand ist in 0E00hex ablesbar
Firmware-Stand in EL37xx/EL47xx-Oversampling-Klemmen


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL3702
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 04 | 02 | EL3702-0000-0002 | 2007/11
 | 03 |  | 2008/06
 | 04 |  | 2009/12
05 - 15* | 05 |  | 2010/11
 | 06 |  | 2011/01
 | 07 |  | 2011/02
 | 08 |  | 2011/06
 | 09 | EL3702-0000-0003 | 2012/12
 | 10 |  | 2014/02
 | 11* |  | 2015/03
EL3702-0015
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 – 02* |  | EL3702-0000-0003 | 2016/04
 | 11* |  | 2016/06
EL3742
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
02 - 05 | 05 | EL3742-0000-0002 | 2010/11
 | 06 |  | 2011/01
 | 07 |  | 2011/02
 | 08 |  | 2011/06
05 - 12* | 09 | EL3742-0000-0003 | 2012/12
 | 10 |  | 2014/02
 | 11* |  | 2015/03
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.