EL3751 - Kurzdokumentation 1-Kanal-Multifunktionseingang für analoge Messtechnik, 24 Bit, 10 kSps
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.0
▪
Erste Veröffentlichung


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
EL3751 LEDs, Anschlüsse und Belegung
1-Kanal-Multifunktionseingang für analoge Messtechnik, 24 Bit, 10 kSps, Differentialeingänge, Oversampling
Weiterführende Informationen
•
Beschreibung
•
Technische Daten


Beschreibung

Produktübersicht [image] Beschreibung
Beschreibung
Die analoge Eingangsklemme EL3751 als Multifunktionseingang für analoge Messtechnik kann zur Messung von elektrischen Größen in mehreren Messbereichen verwendet werden. Der Messbereich beträgt dabei jeweils nominell:
▪
Spannung von ±5 mV bis ±30 V, 0..10 V, 0..5 V
▪
Strom im Bereich von ±20 mA , 4..20 mA, 0..20 mA, NAMUR NE43
▪
Widerstandsbrücke, Dehnungsmessstreifen (DMS): 1/4-Brücke (350 Ω + 120 Ω),
1/2- Brücke (±16 mV/V) sowie 1/1- Brücke (±32 mV/V) im 2-6 Leiteranschluss
▪
elektr. Widerstand R / Temperatur mit RTD (PT100 etc.): 0…5 kΩ im 2-4 Leiteranschluss
▪
Potentiometer ab 1 kΩ
Der genannte nominelle Messbereich ist jeweils Teil des insgesamt zur Verfügung stehenden und nutzbaren technischen Messbereichs, der bei der EL3751 je nach Messbereich bei ca. ±107% liegt. Diese Eigenschaft „extended Range“ des erweiterten Messbereichs ist abschaltbar, somit ist auch das kompatible Verhalten zur EL30/31/36xx Serie als „legacy Range“ herstellbar.
Die Messung geschieht über einen differentiellen Eingangskanal und wird mit einer Auflösung von 24 Bit und 10 kSps digitalisiert, galvanisch getrennt zum Feldbus und wahlweise mit Oversampling zum übergeordneten Automatisierungsgerät transportiert. Durch die integrierte Versorgung und die schaltbaren Ergänzungswiderstände ist der direkte Anschluss einer Widerstandsbrücke (Dehnmessstreifen DMS) oder Wägezelle in 2/3/4/6-Leiter Anschlusstechnik, eines ohmschen Festwiderstandes, PTC oder Potentiometers möglich. Der Signalzustand der EtherCAT-Klemme wird durch Leuchtdioden angezeigt.
Falls eine niedrigere Abtastrate gewünscht ist, kann ausgehend von der festen analogen Abtastrate von 10 kSPS intern eine Datenratenreduzierung (sog. Dezimieren) eingestellt werden. Die so erzielte effektive Abtastrate ≤ 10 kSps kann dann unter Einbeziehung der Taskzykluszeit über den entsprechenden Oversampling-Faktor über EtherCAT an die Steuerung übertragen werden.
Die Klemme verfügt über 2 einstellbare numerische Softwarefilter bis FIR 39.Ordnung (40 Taps) bzw. IIR 6.Ordnung. Der erste Filter arbeitet auf den 10kSps Rohdaten, der zweite arbeitet nach dem frei einstellbaren Dezimierer und ist so zur Unterdrückung von Aliasing-Effekten anwenderseitig einzustellen. Beide Filter können entweder nach integrierter Liste (einige Tiefpass-, Hochpass-, Mittelwertfilter) oder nach freier Koeffiziententabelle gesetzt werden.
Nichtlineare Sensorkennlinien können durch eine integrierte Stützstellentabelle flexibel korrigiert werden; es sind auch einfache mathematische Operationen möglich.
Jede Klemme verfügt über eine eindeutige, aufgedruckte und elektronisch auslesbare ID-Nummer. Das optional verfügbare Werkskalibrierzertifikat (EL3751-0020) kann über diese ID-Nummer zugeordnet werden, eine Re-Kalibrierung ist möglich.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Weiterführende Informationen
•
Allgemeine technische Daten
•
Prozessdaten Interpretation
•
Allgemeines zur Messgenauigkeit/Messunsicherheit
•
Messung ±30 V
•
Messung ±10 V
•
Messung ±5 V
•
Messung ±2,5 V
•
Messung ±1,25 V
•
Messung ±640 mV
•
Messung ±320 mV
•
Messung ±160 mV
•
Messung ±80 mV
•
Messung ±40 mV
•
Messung ±20 mV
•
Messung ±10 mV
•
Messung ±5 mV
•
Messung 0…5 V
•
Messung 0…10 V
•
Messung ±20 mA
•
Messung 0…20 mA
•
Messung 4…20 mA
•
Messung 3,6…21 mA (NAMUR NE43)
•
Messung Widerstand 0…5 kΩ
•
Messung RTD
•
Messung Potentiometer
•
Messung SG 1/1-Bridge (Vollbrücke) 4/6-Leiter-Anschluss
•
Messung SG 1/2-Bridge (Halbbrücke) 3/5-Leiter-Anschluss
•
Messung SG 1/4-Bridge (Viertelbrücke) 120 Ω 2/3-Leiter-Anschluss
•
Messung SG 1/4-Bridge (Viertelbrücke) 350 Ω 2/3-Leiter-Anschluss


Allgemeine technische Daten

Produktübersicht [image] Technische Daten [image] Allgemeine technische Daten
Allgemeine technische Daten
Technische Daten
EL3751
Analoge Eingänge
1 Kanal (differentiell)
Anschlusstechnik
2 - 6 Leiter
Auflösung
24 Bit inkl. Vorz., Darstellung 32 Bit
Auswahl Oversampling-Faktoren
1, 2, 4, 5, 8, 10, 16, 20, 25, 32, 40, 50, 64
ADC Wandlungsmethode
deltaSigma ΔΣ, 1,28 MSps (interne Abtastrate);
Grenzfrequenz Eingangsfilter Hardware
Vor AD-Wandler: 30 kHz Hardware Filter
Im AD-Wandler vor Wandlung: -3dB @ 3,2 kHz, Mittelwertfilter 5.Ordnung
Messfehler
typ. ±0,01%@23°C, Ausnahmen bei einzelnen Messbereichen, Details siehe Funktionstabellen und s.u. 2)
Max. Samplingrate/min. Wandlungszeit
10 kSps / 100 µs (fest, zusätzlich freies downsampling in Firmware durch Dezimierungsfaktor.
Unterstützte EtherCAT Zykluszeit
(in Abhängigkeit von der Betriebsart)
DistributedClocks: min. 100 µs, max. 25 ms (max. 10 ms empfohlen)
FrameTriggered/Synchron: min. 200 µs, max. 100 ms
FreeRun: wird nicht unterstützt
Signalverzögerung (Sprungantwort)
tbd.
Signalverzögerung (linear)
tbd.
Linearer Phasengang, Gruppenlaufzeit konstant
Erfassungsart
Simultan (1 Kanal, simultan bei DC-Synchronisierung mehrerer Klemmen)
Spannungsfestigkeit - Zerstörgrenze
max. zul. Kurzzeitig/dauerhaft anliegende Spannung
▪
Spannung zwischen den Kontaktstellen ±I1, ±I2, +Uv und –Uv: Unversorgt ±40 V, Versorgt ±36 V
▪
Spannung zwischen jeder Kontaktstelle und SGND (Schirm, Montageschiene): siehe Angabe zur Potentialtrennung
Hinweis: -Uv entspricht dem internen GND
Distributed Clocks
Ja, mit Oversampling
Empfohlener Einsatzspannungsbereich zur Einhaltung der Spezifikation (UCM, common mode)
max. zul. Spannung während bestimmungsgemäßem Betrieb
▪
±I1 und ±I2: typ. ±10 V gegen –Uv
Hinweis: -Uv entspricht dem internen GND
Potentialtrennung Bus/Kanal
500 V DC (1 min. Typ-Prüfspannung)
Potentialtrennung Kanal/Kanal
(nicht zutreffend da 1 Kanal)
Bitbreite im Prozessabbild (Standardeinstellung)
32 Bit / pro Wert
Unterstützt Funktion NoCoeStorage
Ja
Besondere Eigenschaften
integrierte schaltbare ¼ Brückenergänzung für 120 und 350 Ω
Abgleich höherer Ordnung, PeakHold Schleppzeiger, vordefinierte und frei einstellbare Software-Filter, TrueRMS, beliebiges Downsampling, 2stufiger Integrator/Differenzierer, freie Scaling-Funktion (auch nichtlinear), Endwertbegrenzer (Limiter), extended/legacy Range, Leitungskompensation
Auf Anfrage auch mit Werkskalibrierzertifikat erhältlich
Technische Daten | EL3751
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 260 mA
Thermische Verlustleistung | typ. 1,2 W
Stromaufnahme aus den Powerkontakten | keine
Zulässiger Einsatzhöhenbereich | 0 bis 2000m (Derating bei größerer Höhe auf Anfrage)
Gewicht | ca. 65g
Zulässiger Umgebungstemperaturbereich im Betrieb | 0…+55 °C (in waagerechter Einbaulage) 0…+45°C (alle anderen Einbaulagen)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25…+85 °C
Einbaulage | Betrieb in allen Lagen möglich, Einhaltung der vollen Genauigkeit nur bei waagerechter/Standardlage möglich.
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Max. Sensor-Leitungslänge | Die Leitungslänge von der EtherCAT Klemme bis zum Sensor/Geber darf ohne weitere Schutzmaßnahmen max. 30 m betragen. Bei größeren Kabellängen ist ein geeigneter Überspannungsschutz (Surge-Protection) vorzusehen.
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Zulassung | CE
2) Dominierender Anteil der Grundgenauigkeit ist die Offset-Spezifikation (siehe folgende Tabellen). Durch Offset-Korrektur gemäß Kapitel Offset Korrektur kann dieser Anteil eliminiert und die Messgenauigkeit erheblich gesteigert werden.


Prozessdaten Interpretation

Produktübersicht [image] Technische Daten [image] Prozessdaten Interpretation
Prozessdaten Interpretation
Der gesamte Messbereich stellt sich in Bezug auf die Ausgabe über die zyklischen Prozessdaten folgendermaßen dar:
Basis Bereich eines Prozessdatenwertes
Der Kanal dieser Klemme verfügt über die Möglichkeit, den Messbereich entweder auf die bei Beckhoff bisher übliche Art „nomineller Messbereichsendwert = PDO Endwert: LegacyRange“ oder die neue Methode „technischer Messbereichsendwert = PDO Endwert: ExtendedRange“ einzustellen.
▪
Extended Range Modus
–
technischer Messbereichsendwert = PDO Endwert 0x007FFFFF.
–
der Kanal kann zu informativen Zwecken ca. 107 % über den nominellen Bereich hinaus messen, Genauigkeitsspezifikationen etc. sind dann allerdings nicht mehr gültig.
–
Außerhalb des nominellen Messbereichs wird das Overrange bzw. Underrange Bit gesetzt.
–
Zur weiteren Diagnose wird das Error Bit und die Error LED gesetzt, wenn einstellbare Grenzen über- bzw. unterschritten werden. Diese sind auf den technischen Messbereich voreingestellt (default), können aber anwenderseitig auf einen schmaleren Bereich verändert werden.
Beispiel: im Messbereich 4…20 mA ist die untere Grenze auf 0 mA gesetzt, sie kann aber kundenseitig im CoE z.B. auf 3,6 mA hochgesetzt werden um ggf. einen Sensorfehler früher zu erkennen.
–
Der Extended Range Modus ist bei Werkseinstellung der Klemme voreingestellt (default).
–
Der Modus ist definiert durch die nicht-periodische rationale LSB Schrittweite und einen ganzzahligen Endwert. Dadurch ist die Schrittweite ohne Rundungsfehler in einem PLC-Programm verwendbar.
▪
Legacy Range Modus
–
Nomineller Messbereichsendwert = PDO Endwert.
–
Kompatibel zur bisherigen Schnittstelle aus EL30xx/EL31xx/EL36xx.
–
Overrange/Underrange, Error Bit und Error LED werden zugleich bei Überschreiten des nominellen/technischen Messbereichs gesetzt.
–
Für die Klemme optional aktivierbar.
–
Der Modus ist definiert durch einen ganzzahligen Endwert; unter Inkaufnahme, dass die LSB Schrittweite keine ganze Zahl mehr ist.


Allgemeines zur Messgenauigkeit/Messunsicherheit

Produktübersicht [image] Technische Daten [image] Allgemeines zur Messgenauigkeit/Messunsicherheit
Allgemeines zur Messgenauigkeit/Messunsicherheit
Zur grundsätzlichen Einordnung nachfolgender Erläuterungen sind die Kapitel „Hinweise zu analogen Messwerten“ insbesondere zum Messbereichsendwert zu beachten!
Es lohnt sich diese Anleitung aufmerksam zu lesen und die Ratschläge zu befolgen – Sie ersparen sich Mühe, Zeit und vielleicht auch Geld.
Grundsätzliches zur Messtechnik:
Mit Messgeräten wird mit mehr oder weniger Aufwand versucht, den „wahren Wert“ einer Messgröße z.B. Umgebungstemperatur zu bestimmen. Dies ist aus verschiedenen praktischen Gründen nicht endgültig möglich. Die Messung/der Messwert unterliegt je nach Aufwand einem zufälligen nicht eliminierbaren Messfehler. Beckhoff gibt mit seinen praktisch ermittelten Spezifikationsangaben eine Handhabe um theoretisch die verbleibende Messunsicherheit im Einsatzfall berechnen zu können. Dazu dienen die folgenden Absätze.
Allgemeine Hinweise
Es ist keine besondere Wartung erforderlich, für die Klemme wird allerdings eine ein jährliche Überprüfung empfohlen.
Falls ein Werkskalibrierzertifikat für das Gerät vorliegt, gilt für das Rekalibrierintervall eine Empfehlung von 1 Jahr, falls nicht anders angegeben.
Hinweise zu den Spezifikationsdaten:
▪
Spezifikationsangaben lauten üblicherweise „% vom nominellen Messbereichsendwert“ = % MBE wenn nicht anders angegeben
▪
In Zusammenhang mit einem einzelnen Wert bedeutet „typisch“, dass diese Kenngröße durchschnittlich den angegebenen Wert hat. Bei individuellen Klemmen kann die Kenngröße vom typischen Wert jedoch abweichen. Ein Beispiel ist der Stromverbrauch.
▪
In Zusammenhang mit einer Grenze (Kenngröße ist typisch max./min. X) oder mit zwei Grenzen (Kenngröße ist typisch zwischen X und Y) bedeutet „typisch“, dass diese Kenngröße bei individuellen Klemmen überwiegend zwischen den Grenzen liegt. Abweichungen sind jedoch möglich, siehe Konfidenzniveau. Ein Beispiel ist das Rauschen Es werden üblicherweise keine Messungen unternommen, um Angaben über Standardabweichung oder Ergebnis-Häufigkeiten machen zu können. Ein typischer Wert wird üblicherweise mit der Abkürzung „typ.“ hinter der Einheit gekennzeichnet.
▪
Das Konfidenzniveau/ Vertrauenslevel liegt, wenn nicht anders angegeben bei 95%.
▪
Beim Betrieb in EMV-gestörter Umgebung ist zur Einhaltung der Spezifikation nötig
–
eine Schirmklemme EL9070 positioniert links von der Klemme
–
verdrillte und geschirmte Signalleitung, mind. einseitig geerdet
▪
Wenn nicht anders spezifiziert, werden Messfehler etc. im DC-Betrieb angegeben (keine Wechselgrößen). Bei Messung eines AC-Signals beeinflusst der Frequenzgang des Analogeingangs die Messung selbst.
Hinweis zur Temperatur
Die Temperatur innerhalb/außerhalb des Gerätes hat Einfluss auf die Messung durch die Elektronik. So weist eine messtechnische Schaltung in der Regel eine Temperaturabhängigkeit auf, die u.a. in der Angabe der Temperaturdrift spezifiziert wird. Die Spezifikationsangaben gelten für eine konstante Umgebungstemperatur – veränderliche Verhältnisse (Aufheizen des Schaltschranks, Temperatursturz durch Öffnen des Schaltschranks bei kalter Witterung), also ein Temperaturübergang, kann unter Umständen zu einer Veränderung von Messwerten durch dynamische und heterogene Temperaturverteilung führen. Zur Bereinigung solcher Effekte kann die Geräteinnentemperatur online aus dem CoE ausgelesen und ggf. zur Verrechnung herangezogen werden. Manche Geräte zeigen auch elektronisch an, dass sie sich thermisch stabilisiert haben, siehe dazu die Diagnose Eigenschaften.
Die Spezifikationsdaten gelten
▪
nach einer Aufwärmzeit des Gerätes unter Betriebsspannung und Feldbusbetrieb von mind. 60 Minuten bei konstanter Umgebungstemperatur
▪
bei waagerechter Einbaulage unter Beachtung der Mindestabstände
▪
bei freier Konvektion (keine Zwangslüftung)
▪
bei Beachtung der Spezifikationsangaben
Liegen andere Bedingungen vor, ist ein anwenderspezifischer Abgleich nötig.
Hinweis zur Rechnung mit den Spezifikationsangaben:
Die unabhängigen Einzel-Genauigkeitsangaben (Offset/Gain-Abweichung, Nichtlinearität, Wiederholgenauigkeit, Rauschen) sind quadratisch zu addieren um eine Gesamt-Messgenauigkeit zu ermitteln - wenn keine besonderen Bedingungen vorliegen die gegen eine Gleichverteilung und damit den quadratischen Ansatz sprechen (englisch: RSS – root of the sum of the squares).
Die gesondert ausgewiesene Grundgenauigkeit ist eine Teilmenge der vollständigen Messgenauigkeits-Addition, siehe u.a. Hinweis.
Beckhoff gibt die Spezifikationsdaten üblicherweise symmetrisch in [±%] an, also z.B. ±0,01% oder ±100 ppm. Entsprechend wäre das vorzeichenlose Gesamtfenster also der doppelte Wert. Auch eine Peak-to-peak-Angabe ist eine Gesamtfensterangabe, der symmetrische Wert also die Hälfte davon. In der u.a. quadratischen Verrechnung ist der symmetrische „einseitige“ Wert ohne Vorzeichen einzusetzen. Rauschangaben erfolgen üblicherweise in peak-to-peak-Form, deshalb enthält die Formel für den Rauschwert schon den Teiler /2.
Beispiel:
▪
symmetrische Angabe: ±0,01% (entspricht ±100 ppm) z.B. bei Offset-Spezifikation
▪
Gesamtfenster: 0,02% (200 ppm)
▪
Zur Verwendung in der Formel: 0,01% (100 ppm)
Der so berechnete Gesamtfehler ist wieder als symmetrischer Maximalwert zu sehen und somit zur weiteren Verwendung mit ± und ≤ zu versehen.
Beispiel:
▪
FGesamt = 100 ppm
▪
Zur weiteren Verwendung: „≤ ± 100 ppm“
Das heißt gesprochen: „Die Verrechnung der Einzelfehler unter den geg. Bedingungen erbrachte ein Fenster von 200 ppm, das symmetrisch über dem einzelnen Messwert liegt. Die Messwertangabe x hat damit eine Unsicherheit von x ±100 ppm, der wahre Wert liegt damit zu 95% in diesem Bereich.“
FOffset | : | Offset-Spezifikation (bei 23°C)
FGain | : | Gain/Scale-Spezifikation (bei 23°C)
FNoise, PtP | : | Rausch-Spezifikation als Peak-to-Peak-Wert (gültig für alle Temperaturen)
MW | : | Gemessener Wert
MBE | : | Messbereichsendwert
FLin | : | Nichtlinearitätsfehler über den gesamten Messbereich (gültig für alle Temperaturen)
FRep | : | Wiederholgenauigkeit (gültig für alle Temperaturen)
TkOffset | : | Temperaturkoeffizient Offset
TkGain | : | Temperaturkoeffizient Gain
TkTerminal | : | Temperaturkoeffizient der Klemme
ΔT | : | Differenz der Umgebungstemperatur zur spezifizierten Grundtemperatur (23°C wenn nicht anders angegeben)
FAge | : | Fehlerkoeffizient der Alterung
NYears | : | Anzahl Jahre
FGesamt | : | Theor. berechneter Gesamtfehler
Beispielsweise seien bei einem ermittelten Messwert MW = 8,13 V im 10 V Messbereich (MBE = 10 V) die folgenden Werte vorliegend (NYears = 0):
▪
Gain-Spezifikation: FGain = 60 ppm
▪
Offset-Spezifikation: FOffset = 70 ppmMBE
▪
Nichtlinearität: FLin = 25 ppmMBE
▪
Wiederholgenauigkeit: FRep = 20 ppmMBE
▪
Rauschen (ohne Filterung): FNoise, PtP = 100 ppmpeak-to-peak,
▪
Temperaturkoeffizienten:
–
TkGain = 8 ppm/K
–
TkOffset = 5 ppmMBE/K
Dann berechnet sich der theoretisch mögliche Gesamt-Messgenauigkeit bei ΔT = 12K zur Grundtemperatur wie folgt:
bzw. = ±0,0143.. %MBE
Anmerkungen:
ppm ≙ 10-6
% ≙ 10-2
Der Rauschanteil kann entfallen
Der Anteil des Rauschens FNoise in der o.a. Formel kann entfallen (= 0), wenn nicht ein einzelnes Sample sondern ein gemittelter Wert über einen Satz von Samples in Betracht gezogen wird. Die Mittelung kann in der PLC, aber auch durch einen der Filter im Analogkanal erfolgen. Der Ausgabewert einer gleitenden Mittelwertbildung über viele Samples hat einen annähernd eliminierten Rauschanteil. Die erzielbare Genauigkeit steigt somit, wenn der Rauschanteil verringert wird.
Grundgenauigkeit und Mittelwertbildung
✓
Die Grundgenauigkeit wird zur vereinfachten Verwendung extra ausgewiesen.
1.
Die Grundgenauigkeit beinhaltet Offset/Gain-Abweichung, Nichtlinearität und Wiederholgenauigkeit, nicht aber den Temperaturkoeffizient und das Rauschen und ist damit eine Teilmenge der o.a. vollständigen Rechnung. Es besteht die Möglichkeit mittels der Offset‑Korrektur die Messgenauigkeit über die Grundgenauigkeit hinaus zu steigern.
2.
„Mittelwertbildung“ bedeutet, dass der Wert aus der arithmetischen Mittelung über i.d.R. 100.000 Werte zur Eliminierung des Rauschens gewonnen wurde. Dabei muss nicht unbedingt die in der Klemme integrierte Mittelwert-Funktion genutzt werden - es kann im Falle noch vorhandener Ressourcen die Mittelwertbildung ebenso in der PLC durchgeführt werden.
Messgenauigkeit vom Messwert (vom Messwert)
Manchmal ist statt der Genauigkeitsangabe „Genauigkeit bezogen auf den Messbereichsendwert (MBE)“ die „Genauigkeit bezogen auf den aktuellen Messwert“ d.h. „Genauigkeit vom Wert (v.W.)“ gesucht.
Aus den in der Spezifikation gegebenen Daten kann dieser Wert einfach ermittelt werden, denn die Gesamtgenauigkeit setzt nach der o.a. Formel aus einem Messwert und Messbereichsendwert abhängigen Teil und einem ausschließlich Messbereichsendwert abhängigen Teil zusammen:


Messung ±30 V

Produktübersicht [image] Technische Daten [image] Messung ±30 V
Messung ±30 V
Messung Modus |  | ±30 V
Messbereich, nominell |  | -30…+30 V
Messbereich, Endwert (MBE) |  | 30 V
Messbereich, technisch nutzbar |  | -32,212…+32,212 V
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 3,84 µV
PDO LSB (Legacy Range) |  | 3,576.. µV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 65 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 65 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 45 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 7,64
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,5 ppmMBE |  | < 20 [digits]
 | Max. SNR | > 112,0 dB
Temperaturkoeffizient | TkGain | < 11 ppm/K typ.
 | TkOffset | < 10 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >68 dB typ. | 50 Hz: >68 dB typ. |  | 1 kHz: >52 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >68 dB typ. | 50 Hz: >100 dB typ. |  | 1 kHz: >100 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 570 kΩ || 11 nF
 |  | CommonMode typ. 140 kΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±30 V Messbereich
Grafik aus Neues Fragment (i76lrcd2.png)
Frequenzgang ±30 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±10 V

Produktübersicht [image] Technische Daten [image] Messung ±10 V
Messung ±10 V
Messung Modus |  | ±10 V
Messbereich, nominell |  | -10…+10 V
Messbereich, Endwert (MBE) |  | 10 V
Messbereich, technisch nutzbar |  | -10,737…+10,737 V
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 1,28 µV
PDO LSB (Legacy Range) |  | 1,192.. µV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 60 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 2,55
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
In Anlehnung an den Beckhoff „Messfehler“ (siehe Kapitel „Messfehler/ Messabweichung“) kann wie in Kapitel „Allgemeines zur Messgenauigkeit/Messunsicherheit“ angeben auch als Vergleichswert der „Gesamtmessfehler über alles“ berechnet werden.
Für den Messbereich ±10V ergibt sich dieser damit aus den o.a. Daten und TUmgebung,max = 55°C zu ±321 ppmMBE (bzw. 0,032%MBE).
Darstellung ±10 V Messbereich
Grafik aus Neues Fragment (itg8mv72.png)
Frequenzgang ±10 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±5 V

Produktübersicht [image] Technische Daten [image] Messung ±5 V
Messung ±5 V
Messung Modus |  | ±5 V
Messbereich, nominell |  | -5…+5 V
Messbereich, Endwert (MBE) |  | 5 V
Messbereich, technisch nutzbar |  | -5,368…+5,368 V
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 640 nV
PDO LSB (Legacy Range) |  | 596.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 1,27
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±5 V Messbereich
Grafik aus Neues Fragment (ia6g9tt2.png)
Frequenzgang ±5 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±2,5 V

Produktübersicht [image] Technische Daten [image] Messung ±2,5 V
Messung ±2,5 V
Messung Modus |  | ±2,5 V
Messbereich, nominell |  | -2,5…+2,5 V
Messbereich, Endwert (MBE) |  | 2,5 V
Messbereich, technisch nutzbar |  | -2,684…+2,684 V
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 320 nV
PDO LSB (Legacy Range) |  | 298.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 90 ppmMBE |  | < 703 [digits]
 | FNoise, RMS | < 17 ppmMBE |  | < 133 [digits]
 | Max. SNR | > 95,4 dB
 | Rauschdichte@1kHz | < 0,60
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 9 ppmMBE |  | < 70 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±2,5 V Messbereich
Grafik aus Neues Fragment (i7hf7kj2.png)
Frequenzgang ±2,5 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±1,25 V

Produktübersicht [image] Technische Daten [image] Messung ±1,25 V
Messung ±1,25 V
Messung Modus |  | ±1,25 V
Messbereich, nominell |  | -1,25…+1,25 V
Messbereich, Endwert (MBE) |  | 1,25 V
Messbereich, technisch nutzbar |  | -1,490…+1,490 V
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 160 nV
PDO LSB (Legacy Range) |  | 149.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 90 ppmMBE |  | < 703 [digits]
 | FNoise, RMS | < 17 ppmMBE |  | < 133 [digits]
 | Max. SNR | > 95,4 dB
 | Rauschdichte@1kHz | < 0,30
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 9 ppmMBE |  | < 70 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±1,25 V Messbereich
Grafik aus Neues Fragment (io6gt2t.png)
Frequenzgang ±1,25 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±640 mV

Produktübersicht [image] Technische Daten [image] Messung ±640 mV
Messung ±640 mV
Messung Modus |  | ±640 mV
Messbereich, nominell |  | -640…+640 mV
Messbereich, Endwert (MBE) |  | 640 mV
Messbereich, technisch nutzbar |  | -687,2…+687,2 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 81,92 nV
PDO LSB (Legacy Range) |  | 76,29.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 90 ppmMBE |  | < 703 [digits]
 | FNoise, RMS | < 17 ppmMBE |  | < 133 [digits]
 | Max. SNR | > 95,4 dB
 | Rauschdichte@1kHz | < 0,15
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 9 ppmMBE |  | < 70 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±640 mV Messbereich
Grafik aus Neues Fragment (ierckcr3.png)
Frequenzgang ±640 mV Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±320 mV

Produktübersicht [image] Technische Daten [image] Messung ±320 mV
Messung ±320 mV
Messung Modus |  | ±320 mV
Messbereich, nominell |  | -320…+320 mV
Messbereich, Endwert (MBE) |  | 320 mV
Messbereich, technisch nutzbar |  | -343,6…+343,6 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 40,96 nV
PDO LSB (Legacy Range) |  | 38,14.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 90 ppmMBE |  | < 703 [digits]
 | FNoise, RMS | < 17 ppmMBE |  | < 133 [digits]
 | Max. SNR | > 95,4 dB
 | Rauschdichte@1kHz | 76,93
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 9 ppmMBE |  | < 70 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±320 mV Messbereich
Grafik aus Neues Fragment (ih4g4jp3.png)
Frequenzgang ±320 mV Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±160 mV

Produktübersicht [image] Technische Daten [image] Messung ±160 mV
Messung ±160 mV
Messung Modus |  | ±160 mV
Messbereich, nominell |  | -160…+160 mV
Messbereich, Endwert (MBE) |  | 160 mV
Messbereich, technisch nutzbar |  | -171,8…+171,8 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 20,48 nV
PDO LSB (Legacy Range) |  | 19,07.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 120 ppmMBE |  | < 938 [digits]
 | FNoise, RMS | < 22 ppmMBE |  | < 172 [digits]
 | Max. SNR | > 93,2 dB
 | Rauschdichte@1kHz | < 49,78
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 13 ppmMBE |  | < 102 [digits]
 | FNoise, RMS | < 2,5 ppmMBE |  | < 20 [digits]
 | Max. SNR | > 112,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±160 mV Messbereich
Grafik aus Neues Fragment (ikpiuau.png)
Frequenzgang ±160 mV Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±80 mV

Produktübersicht [image] Technische Daten [image] Messung ±80 mV
Messung ±80 mV
Messung Modus |  | ±80 mV
Messbereich, nominell |  | -80…+80 mV
Messbereich, Endwert (MBE) |  | 80 mV
Messbereich, technisch nutzbar |  | -85,9…+85,9 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 10,24 nV
PDO LSB (Legacy Range) |  | 9,536.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 160 ppmMBE |  | < 1250 [digits]
 | FNoise, RMS | < 37 ppmMBE |  | < 289 [digits]
 | Max. SNR | > 88,6 dB
 | Rauschdichte@1kHz | < 41,86
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 18 ppmMBE |  | < 141 [digits]
 | FNoise, RMS | < 3,5 ppmMBE |  | < 27 [digits]
 | Max. SNR | > 109,1 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±80 mV Messbereich
Grafik aus Neues Fragment (iabkdhe2.png)
Frequenzgang ±80 mV Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±40 mV

Produktübersicht [image] Technische Daten [image] Messung ±40 mV
Messung ±40 mV
Messung Modus |  | ±40 mV
Messbereich, nominell |  | -40…+40 mV
Messbereich, Endwert (MBE) |  | 40 mV
Messbereich, technisch nutzbar |  | -42,95…+42,95 V
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 5,12 nV
PDO LSB (Legacy Range) |  | 4,768.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,02%MBE = ±200 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 175 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 65 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 45 ppmMBE
Wiederholgenauigkeit | FRep | < 30 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 375 ppmMBE |  | < 2930 [digits]
 | FNoise, RMS | < 75 ppmMBE |  | < 586 [digits]
 | Max. SNR | > 82,5 dB
 | Rauschdichte@1kHz | < 42,43
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 40 ppmMBE |  | < 313 [digits]
 | FNoise, RMS | < 5,5 ppmMBE |  | < 43 [digits]
 | Max. SNR | > 105,2 dB
Temperaturkoeffizient | TkGain | 8 ppm/K typ.
 | TkOffset | 6 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±40 mV Messbereich
Grafik aus Neues Fragment (i9e60t12.png)
Frequenzgang ±40 mV Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±20 mV

Produktübersicht [image] Technische Daten [image] Messung ±20 mV
Messung ±20 mV
Messung Modus |  | ±20 mV
Messbereich, nominell |  | -20…+20 mV
Messbereich, Endwert (MBE) |  | 20 mV
Messbereich, technisch nutzbar |  | -21,474…+21,474 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 2,56 nV
PDO LSB (Legacy Range) |  | 2,384.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,03%MBE = ±300 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 260 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 100 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 90 ppmMBE
Wiederholgenauigkeit | FRep | < 35 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 750 ppmMBE |  | < 5859 [digits]
 | FNoise, RMS | < 150 ppmMBE |  | < 1172 [digits]
 | Max. SNR | > 76,5 dB
 | Rauschdichte@1kHz | < 42,43
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 75 ppmMBE |  | < 586 [digits]
 | FNoise, RMS | < 11,5 ppmMBE |  | < 90 [digits]
 | Max. SNR | > 98,8 dB
Temperaturkoeffizient | TkGain | < 12 ppm/K typ.
 | TkOffset | < 12 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±20 mV Messbereich


Messung ±10 mV

Produktübersicht [image] Technische Daten [image] Messung ±10 mV
Messung ±10 mV
Messung Modus |  | ±10 mV
Messbereich, nominell |  | -10…+10 mV
Messbereich, Endwert (MBE) |  | 10 mV
Messbereich, technisch nutzbar |  | -10,737…+10,737 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 1,28 nV
PDO LSB (Legacy Range) |  | 1,192.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,06%MBE = ±600 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 550 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 150 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 160 ppmMBE
Wiederholgenauigkeit | FRep | < 50 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 1200 ppmMBE |  | < 9375 [digits]
 | FNoise, RMS | < 200 ppmMBE |  | < 1563 [digits]
 | Max. SNR | > 74,0 dB
 | Rauschdichte@1kHz | < 28,28
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 120 ppmMBE |  | < 938 [digits]
 | FNoise, RMS | < 21,0 ppmMBE |  | < 164 [digits]
 | Max. SNR | > 93,6 dB
Temperaturkoeffizient | TkGain | < 22 ppm/K typ.
 | TkOffset | < 20 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,2%MBE = ±2000 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±10 mV Messbereich


Messung ±5 mV

Produktübersicht [image] Technische Daten [image] Messung ±5 mV
Messung ±5 mV
Messung Modus |  | ±5 mV
Messbereich, nominell |  | -5…+5 mV
Messbereich, Endwert (MBE) |  | 5 mV
Messbereich, technisch nutzbar |  | -5,368…+5,368 mV
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 0,64 nV
PDO LSB (Legacy Range) |  | 0,596.. nV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,12%MBE = ±1200 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 1120 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 290 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 290 ppmMBE
Wiederholgenauigkeit | FRep | < 90 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 2400 ppmMBE |  | < 18750 [digits]
 | FNoise, RMS | < 380 ppmMBE |  | < 2969 [digits]
 | Max. SNR | > 68,4 dB
 | Rauschdichte@1kHz | < 26,87
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 240 ppmMBE |  | < 1875 [digits]
 | FNoise, RMS | < 42,0 ppmMBE |  | < 328 [digits]
 | Max. SNR | > 87,5 dB
Temperaturkoeffizient | TkGain | < 35 ppm/K typ.
 | TkOffset | < 35 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,2%MBE = ±2000 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung ±5 mV Messbereich


Messung 0…5 V

Produktübersicht [image] Technische Daten [image] Messung 0…5 V
Messung 0…5 V
Messung Modus |  | 0…5 V
Messbereich, nominell |  | 0…5 V
Messbereich, Endwert (MBE) |  | 5 V
Messbereich, technisch nutzbar |  | 0…5,368 V
PDO Auflösung |  | 23 Bit (vorzeichenlos)
PDO LSB (Extended Range) |  | 0,64 µV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 55 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 1,27
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung 0…5 V Messbereich
Grafik aus Neues Fragment (ia6g9tt2.png)
Frequenzgang 0…5 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung 0…10 V

Produktübersicht [image] Technische Daten [image] Messung 0…10 V
Messung 0…10 V
Messung Modus |  | 0…10 V
Messbereich, nominell |  | 0…10 V
Messbereich, Endwert (MBE) |  | 10 V
Messbereich, technisch nutzbar |  | 0…+10,737 V
PDO Auflösung |  | 23 Bit (vorzeichenlos)
PDO LSB (Extended Range) |  | 1,28 µV
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0, 01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 60 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 25 ppmMBE
Wiederholgenauigkeit | FRep | < 20 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 2,55
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 8 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: >115 dB typ. | 50 Hz: >105 dB typ. |  | 1 kHz: >80 dB typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: >115 dB typ. | 50 Hz: >115 dB typ. |  | 1 kHz: >115 dB typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Darstellung 0…10 V Messbereich
Grafik aus Neues Fragment (itg8mv72.png)
Frequenzgang 0…10 V Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung ±20 mA

Produktübersicht [image] Technische Daten [image] Messung ±20 mA
Messung ±20 mA
Messung Modus |  | ±20 mA
Messbereich, nominell |  | -20…+20 mA
Messbereich, Endwert (MBE) |  | 20 mA
Messbereich, technisch nutzbar |  | -21,474…+21,474 mA, überstromgeschützt
Absicherung |  | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 2,56 nA
PDO LSB (Legacy Range) |  | 2,384.. nA
Gleichtaktspannung Ucm |  | max. +/- 10V bezogen auf –Uv (interne Masse)
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 65 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 50 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 40 ppmMBE
Wiederholgenauigkeit | FRep | < 40 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 5,09
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 15 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. | 1 kHz: < 80 nA/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. | 1 kHz: < 3 nA/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) | Differentiell typ. 200 Ω || 11 nF
 | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 | Eingang wird in diesem Modus nicht benutzt
Strommessbereich ±20 mA
Darstellung Strommessbereich ±20 mA
Grafik aus Neues Fragment (i8011sc2.png)
Frequenzgang ±20 mA Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung 0…20 mA

Produktübersicht [image] Technische Daten [image] Messung 0…20 mA
Messung 0…20 mA
Messung Modus |  | 0-20 mA
Messbereich, nominell |  | 0…20 mA
Messbereich, Endwert (MBE) |  | 20 mA
Messbereich, technisch nutzbar |  | 0 …21,474 mA
Absicherung |  | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung |  | 23 Bit (vorzeichenlos)
PDO LSB (Extended Range) |  | 2,56 nA
PDO LSB (Legacy Range) |  | 2,384.. nA
Gleichtaktspannung Ucm |  | max. +/- 10V bezogen auf –Uv (interne Masse)
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 65 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 50 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 40 ppmMBE
Wiederholgenauigkeit | FRep | < 40 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 5,09
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 15 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 200 Ω || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Strommessbereich 0…20 mA
Darstellung Strommessbereich 0…20 mA
Grafik aus Neues Fragment (i8011sc2.png)
Frequenzgang 0…20 mA Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung 4…20 mA

Produktübersicht [image] Technische Daten [image] Messung 4…20 mA
Messung 4…20 mA
Messung Modus |  | 4…20 mA
Messbereich, nominell |  | 4…20 mA
Messbereich, Endwert (MBE) |  | 20 mA
Messbereich, technisch nutzbar |  | 0…21,179 mA
Absicherung |  | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung |  | 24 Bit
PDO LSB (Extended Range) |  | 2,048 nA
PDO LSB (Legacy Range) |  | 1,907.. nA
Gleichtaktspannung Ucm |  | max. +/- 10V bezogen auf –Uv (interne Masse)
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 65 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 50 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 40 ppmMBE
Wiederholgenauigkeit | FRep | < 40 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 5,09
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 15 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 200 Ω || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Strommessbereich 4…20 mA
Darstellung Strommessbereich 4…20 mA
Grafik aus Neues Fragment (i8011sc2.png)
Frequenzgang 4…20 mA Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung 3,6…21 mA (NAMUR NE43)

Produktübersicht [image] Technische Daten [image] Messung 3,6…21 mA (NAMUR NE43)
Messung 3,6…21 mA (NAMUR NE43)
Messung Modus |  | 3,6…21 mA (NAMUR NE43)
Messbereich, nominell |  | 4…20 mA
Messbereich, Endwert (MBE) |  | 20 mA
Messbereich, technisch nutzbar |  | 3,6…21 mA
Absicherung |  | Interne Überlastbegrenzung, dauerstromfest
PDO Auflösung |  | 24 Bit
PDO LSB (Extended Range) |  | 2,048 nA
PDO LSB (Legacy Range) |  | n.a.
Gleichtaktspannung Ucm |  | max. +/- 10V bezogen auf –Uv (interne Masse)
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | < ±0,01%MBE = ±100 ppmMBE
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 65 ppmMBE
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 50 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 40 ppmMBE
Wiederholgenauigkeit | FRep | < 40 ppmMBE
Rauschen (ohne Filterung) | FNoise, PtP | < 100 ppmMBE |  | < 781 [digits]
 | FNoise, RMS | < 18 ppmMBE |  | < 141 [digits]
 | Max. SNR | > 94,9 dB
 | Rauschdichte@1kHz | < 5,09
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 10 ppmMBE |  | < 78 [digits]
 | FNoise, RMS | < 2,0 ppmMBE |  | < 16 [digits]
 | Max. SNR | > 114,0 dB
Temperaturkoeffizient | TkGain | < 15 ppm/K typ.
 | TkOffset | < 5 ppmMBE/K typ.
Gleichtaktunterdrückung (ohne Filter) |  | DC: < 3 nA/V typ. | 50 Hz: < 5 nA/V typ. |  | 1 kHz: < 80 nA/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter) |  | DC: < 3 nA/V typ. | 50 Hz: < 3 nA/V typ. |  | 1 kHz: < 3 nA/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,05%MBE = ±500 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 200 Ω || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
Strommessbereich 3,6…21 mA (NAMUR)
Darstellung Strommessbereich 3,6…21 mA (NAMUR)
Nur Extended Range Mode bei Messbereich 4 mA NAMUR
In diesem Messbereich ist kein Legacy Range Mode verfügbar. Eine Umstellung auf den Extended Range Mode erfolgt automatisch und ein Schreibzugriff auf das entsprechende CoE Objekt 0x8000:2E (Scaler) wird zwar nicht abgelehnt, führt aber zu keiner Änderung des Parameters.
Grafik aus Neues Fragment (i8011sc2.png)
Frequenzgang 20 mA Messbereich, fsampling = 10 kHz, integrierte Filter 1/2 deaktiviert


Messung Widerstand 0…5 kΩ

Produktübersicht [image] Technische Daten [image] Messung Widerstand 0…5 kΩ
Messung Widerstand 0…5 kΩ
Bei der 2-Leiter-Messung beeinflusst der Leitungswiderstand der zu dem Sensor geführten Zuleitungen den gemessenen Wert. Ist eine Reduzierung dieses systematischen Fehleranteils bei der 2-Leiter-Messung angestrebt, ist der Zuleitungswiderstand zum Messwiderstand einzurechnen, dieser Zuleitungswiderstand muss dann allerdings erst ermittelt werden. Unter Berücksichtigung der Unsicherheit dieses Zuleitungswiderstands kann dieser dann statisch in die laufende Rechnung einbezogen werden, in der EL3751 über 0x8000:13. Eine z.B. durch Alterung bedingte Widerstandsänderung der Zuleitung wird jedoch nicht automatisch erfasst.
Durch die 3-Leiter-Messung ist es möglich den systematischen Anteil zu eliminieren, unter der Annahme dass die zwei Zuleitungen identisch sind. Bei dieser Messart wird der Leitungswiderstand der an –Input2 angeschlossenen Zuleitung dauernd gemessen. Der ermittelte Wert wird dann zwei Mal von dem Messergebnis abgezogen und der Leitungswiderstand so eliminiert. Dies führt technisch zu einer deutlich zuverlässigeren Messung. Unter Berücksichtigung der Messunsicherheit ist der Gewinn durch den 3-Leiter-Anschluss allerdings nicht so erheblich, da diese Annahme einer hohen Ungewissheit unterliegt - die einzelne, nicht nachgemessene Leitung könnte doch beschädigt oder unbemerkt widerstandsvariant sein.
Der 3-Leiter-Anschluss ist also ein technisch bewährter Ansatz, bei einer methodisch nach Messunsicherheit bewerteten Messung wird dringend der voll-kompensierte 4-Leiter-Anschluss empfohlen.
Messung Modus |  | Elektr. Widerstand
Betriebsart |  | 2,5 V Speisespannung fest eingestellt n +Uv 5 kΩ Referenzwiderstand an –I2 Speisestrom ergibt sich aus: 2,5 V / (5 kΩ + RMessung)
Messbereich, nominell |  | 0…5 kΩ
Messbereich, Endwert (MBE) |  | 5 kΩ
Messbereich, technisch nutzbar |  | 10 Ω…5.368 kΩ *)
PDO Auflösung |  | 23 Bit (vorzeichenlos)
PDO LSB (Extended Range) |  | 640 µΩ
PDO LSB (Legacy Range) |  | 596.. µΩ
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  | 2-Leiter-Anschluss: ±0,05% typ. (MBE) 3-Leiter-Anschluss: ±0,03% typ. (MBE) 4-Leiter-Anschluss: ±0,01% typ. (MBE)
Temperaturkoeffizient | TkTerminal | < 10 ppm/K typ.
Die Übergangswiderstände der Klemmkontakte beeinflussen den Messvorgang. Durch einen anwenderseitigen Abgleich bei gesteckter Signalverbindung kann der Messfehler weiter reduziert werden.
*) Der Einsatz der Klemme im Bereich 0 bis 10 Ω wird aufgrund der dann geringen (relativen) Messgenauigkeit nicht empfohlen. Für solche Messungen sind spezialisierte Widerstandsmessklemmen wie z.B. die EL3692 in 4-Leiter-Messung zu verwenden.
Messung Modus |  | Widerstand (2-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 475 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 150 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 25 [ppmMBE]
Wiederholgenauigkeit | FRep | < 20 [ppmMBE]
Rauschen (ohne Filterung) | FNoise, PtP | < 220 [ppmMBE] |  | < 1719 [digits]
 | FNoise, RMS | < 45 [ppmMBE] |  | < 352 [digits]
 | Max. SNR | > 86,9 [dB]
 | Rauschdichte@1kHz | < 3,18
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 12 [ppmMBE] |  | < 94 [digits]
 | FNoise, RMS | < 3,0 [ppmMBE] |  | < 23 [digits]
 | Max. SNR | > 110,5 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 0,6 kΩ/V typ. |  | 1 kHz: < 3,5 kΩ/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 20 Ω/V typ. |  | 1 kHz: < 0,1 Ω/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Messung Modus |  | Widerstand (3-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 280 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 100 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 25 [ppmMBE]
Wiederholgenauigkeit | FRep | < 20 [ppmMBE]
Rauschen (ohne Filterung) | FNoise, PtP | < 185 [ppmMBE] |  | < 1445 [digits]
 | FNoise, RMS | < 35 [ppmMBE] |  | < 273 [digits]
 | Max. SNR | > 89,1 [dB]
 | Rauschdichte@1kHz | < 2,47
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 11 [ppmMBE] |  | < 86 [digits]
 | FNoise, RMS | < 3,0 [ppmMBE] |  | < 23 [digits]
 | Max. SNR | > 110,5 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 0,6 kΩ/V typ. |  | 1 kHz: < 3,5 kΩ/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 20 Ω/V typ. |  | 1 kHz: < 0,1 Ω/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Messung Modus |  | Widerstand (4-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 70 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 70 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 15 [ppmMBE]
Wiederholgenauigkeit | FRep | < 10 [ppmMBE]
Rauschen (ohne Filterung) | FNoise, PtP | < 155 [ppmMBE] |  | < 1211 [digits]
 | FNoise, RMS | < 30 [ppmMBE] |  | < 234 [digits]
 | Max. SNR | > 90,5 [dB]
 | Rauschdichte@1kHz | < 2,12
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 9 [ppmMBE] |  | < 70 [digits]
 | FNoise, RMS | < 3,0 [ppmMBE] |  | < 23 [digits]
 | Max. SNR | > 110,5 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 0,6 kΩ/V typ. |  | 1 kHz: < 3,5 kΩ/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 150 Ω/V typ. | 50 Hz: < 20 Ω/V typ. |  | 1 kHz: < 0,1 Ω/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Widerstandsmessbereich 5 kΩ
Darstellung Widerstandsmessbereich 5 kΩ


Messung RTD

Produktübersicht [image] Technische Daten [image] Messung RTD
Messung RTD
Im Messbereich RTD wird der gemessene Widerstand intern nach eingestellter Transformation in eine Temperatur umgerechnet. Da der Kanal intern auf 5 kΩ misst, ist der entsprechende Messfehler in diesem Messbereich zugrunde zu legen.
In Teilbereichen wird allerdings eine (relativ) höhere Messgenauigkeit erzielt, deshalb können in u.a. Tabelle bei einzelnen Sensortypen entsprechend bessere Temperaturgenauigkeiten angegeben werden als aus der 5kΩ-Genauigkeit zu berechnen sind1).
Der Hinweis zur 2/3/4-Leiter-Messung im voranstehenden Kapitel „Widerstand“ ist zu beachten!
Messung Modus | RTD
Betriebsart | 2,5 V Speisespannung fest eingestellt n +Uv 5 kΩ Referenzwiderstand an –I2 Speisestrom ergibt sich aus: 2,5 V / (5 kΩ + RMessung) → max. 0,5 mA
PDO Auflösung | 0,01°C/digit
Die Übergangswiderstände der Klemmkontakte beeinflussen den Messvorgang. Durch einen anwenderseitigen Abgleich bei gesteckter Signalverbindung kann der Messfehler weiter reduziert werden.
Der Temperaturendwert entspricht dem nominellen Messbereichsendwert.
RTD-Messbereich
Darstellung RTD-Messbereich
Angaben zu den Sensortypen in nachfolgender Tabelle
Die in der folgenden Tabelle aufgeführten Werte zu den Sensortypen werden hier lediglich zu informativen Zwecken als Orientierungshilfe dargestellt. Alle Angaben sind ohne Gewähr und müssen mit dem Datenblatt des jeweiligen verwendeten Sensors überprüft werden.
CoE Enum RTD Element | RTD Type | Temperatur Startwert [°C] | Temperatur Endwert [°C] | Erzielbare Genauigkeit @ Sensortemperatur (MBE), 3-Leiter-Anschluss2) | Erzielbare Genauigkeit @ Sensortemperatur (MBE), 4-Leiter-Anschluss2) | Temperaturkoeffizient (Klemmenspezifischer Drift) | Messwert Startwert [Ω] | Messwert Endwert [Ω]
0 | None | - | - | - | - | - | - | -
1 | PT100 | -200 | 850 | ±1K (-200…+850°C) Siehe 1) | ±0,5K (-200…+850°C) Siehe 1) | c.a. 0,13 K/K | 18,52 | 390,48
2 | NI100 | -60 | 250 | c.a. ±2,68K @ 0°C | c.a. ±0,83K @ 0°C | c.a. 0,083 K/K | 69,52 | 289,2
3 | PT1000 | -200 | 850 | c.a. ±0,38K @ 0°C | c.a. ±0,13K @ 0°C | c.a. 0,013 K/K | 185,2 | 3904,8
4 | PT500 | -200 | 850 | c.a. ±1,03K @ 0°C | c.a. ±0,34K @ 0°C | c.a. 0,034 K/K | 92,6 | 1952,4
5 | PT200 | -200 | 850 | c.a. ±1,96K @ 0°C | c.a. ±0,65K @ 0°C | c.a. 0,065 K/K | 37,04 | 780,96
6 | NI1000 | -60 | 250 | c.a. ±0,34K @ 0°C | c.a. ±0,11K @ 0°C | c.a. 0,011 K/K | 695,2 | 2892,6
7 | NI1000 (TK5000, 100°C: 1500 Ω) | -30 | 160 | c.a. ±0,27K @ 100°C | c.a. ±0,089K @ 100°C | c.a. 0,009 K/K | 871,7 | 1863,6
8 | NI120 | -60 | 320 | - | - | - | 80,94 | 461,04
9 | KT100/110/130/210/230 KTY10/11/13/16/19 | -50 | 150 | c.a. ±0,109K @ 0°C | c.a. ±0,036K @ 0°C | c.a. 0,0036 K/K | 1036 | 4470
10 | KTY81/82-110,120,150 | -50 | 150 | c.a. ±0,216K @ 0°C | c.a. ±0,072K @ 0°C | c.a. 0,0072 K/K | 515 | 2211
11 | KTY81-121 | -50 | 150 | c.a. ±0,219K @ 0°C | c.a. ±0,073K @ 0°C | c.a. 0,0073 K/K | 510 | 2189
12 | KTY81-122 | -50 | 150 | c.a. ±0,214K @ 0°C | c.a. ±0,071K @ 0°C | c.a. 0,0071 K/K | 520 | 2233
13 | KTY81-151 | -50 | 150 | c.a. ±0,222K @ 0°C | c.a. ±0,074K @ 0°C | c.a. 0,0074 K/K | 502 | 2156
14 | KTY81-152 | -50 | 150 | c.a. ±0,211K @ 0°C | c.a. ±0,070K @ 0°C | c.a. 0,0070 K/K | 528 | 2266
15 | KTY81/82-210,220,250 | -50 | 150 | c.a. ±0,108K @ 0°C | c.a. ±0,036K @ 0°C | c.a. 0,0036 K/K | 1030 | 4280
16 | KTY81-221 | -50 | 150 | c.a. ±0,109K @ 0°C |  |  | 1019 | 4237
17 | KTY81-222 | -50 | 150 | c.a. ±0,107K @ 0°C | c.a. ±0,036K @ 0°C | c.a. 0,0036 K/K | 1040 | 4323
18 | KTY81-251 | -50 | 150 | c.a. ±0,111K @ 0°C | c.a. ±0,037K @ 0°C | c.a. 0,0037 K/K | 1004 | 4173
19 | KTY81-252 | -50 | 150 | c.a. ±0,105K @ 0°C | c.a. ±0,035K @ 0°C | c.a. 0,0035 K/K | 1055 | 4387
20 | KTY83-110,120,150 | -50 | 175 | c.a. ±0,222K @ 0°C | c.a. ±0,074K @ 0°C | c.a. 0,0074 K/K | 525 | 2535
21 | KTY83-121 | -50 | 175 | c.a. ±0,224K @ 0°C | c.a. ±0,075K @ 0°C | c.a. 0,0075 K/K | 519 | 2509
22 | KTY83-122 | -50 | 175 | c.a. ±0,221K @ 0°C | c.a. ±0,074K @ 0°C | c.a. 0,0074 K/K | 530 | 2560
23 | KTY83-151 | -50 | 175 | c.a. ±0,225K @ 0°C | c.a. ±0,075K @ 0°C | c.a. 0,0075 K/K | 512 | 2471
24 | KTY83-152 | -50 | 175 | c.a. ±0,216K @ 0°C | c.a. ±0,072K @ 0°C | c.a. 0,0072 K/K | 538 | 2598
25 | KTY84-130,150 | -40 | 300 | c.a. ±0,384K @ 0°C | c.a. ±0,128K @ 0°C | c.a. 0,013 K/K | 359 | 2624
26 | KTY84-151 | -40 | 300 | c.a. ±0,396K @ 0°C | c.a. ±0,132K @ 0°C | c.a. 0,013 K/K | 350 | 2558
27 | KTY21/23-6 | -50 | 150 | c.a. ±0,22K @ 0°C | c.a. ±0,072K @ 0°C | c.a. 0,0072 K/K | 518 | 2235
28 | KTY1x-5 | -50 | 150 | c.a. ±0,110K @ 0°C | c.a. ±0,037K @ 0°C | c.a. 0,0037 K/K | 1020 | 4403
29 | KTY1x-7 | -50 | 150 | c.a. ±0,107K @ 0°C | c.a. ±0,036K @ 0°C | c.a. 0,0036 K/K | 1052 | 4537
30 | KTY21/23-5 | -50 | 150 | c.a. ±0,220K @ 0°C | c.a. ±0,073K @ 0°C | c.a. 0,0073 K/K | 510 | 2202
31 | KTY21/23-7 | -50 | 150 | c.a. ±0,214K @ 0°C | c.a. ±0,071K @ 0°C | c.a. 0,0071 K/K | 526 | 2268
1) Erzielbar bei vernachlässigbarem Offset-Anteil, z.B. durch Offset Korrektur (ELM3xxx: Zero-Offset-Funktion).
Höhere Messgenauigkeit bei einzelnen Sensortypen deren Widerstandswert nur im kleineren Teilbereich von 0..5 kΩ liegt.
2) Relativer Fehler bezogen auf die Steigung der entsprechenden RTD Kennlinie bei 23°C Umgebung der Klemme (Angaben ohne Temperaturfehler des Sensors)!
Hinweis
Extended Range Modus nicht verfügbar
Der „Extended Range Modus“ ist für RTD-Messung nicht verfügbar.
•
bis FW07: Das Objekt 0x8000:2E (Scaler) wird in dieser Einstellung ignoriert. Im Hintergrund wird der „Legacy Range Modus“ angewandt.
•
ab FW08: Das Objekt 0x8000:2E (Scaler) wird dann automatisch in den „Legacy Range Modus“ versetzt. Eine Umstellung ist nicht möglich solange dieser Messbereich ausgewählt ist.


Messung Potentiometer

Produktübersicht [image] Technische Daten [image] Messung Potentiometer
Messung Potentiometer
Das Potentiometer ist mit dem integrierten Netzteil (max. 5V, einstellbar) zu versorgen. Die Schleiferspannung wird dann im Verhältnis zur Speisespannung gemessen und in % ausgegeben. Technisch verläuft die Messung also wie eine DMS Halbbrücke.
Es sind Potentiometer ab 1 kΩ einsetzbar.
Diagnosen
▪
Schleiferbruch: Vollausschlag bzw. 0-Anzeige
▪
Versorgungsunterbrechung: Vollausschlag bzw. 0-Anzeige
Messung Modus |  |  | Potentiometer (3/ 5-Leiter)
Betriebsart |  |  | Die Speisespannung ist per CoE einstellbar, 0,5...5 V
Messbereich, nominell |  |  | -1 … 1 V/V
Messbereich, Endwert (MBE) |  |  | 1 V/V
Messbereich, technisch nutzbar |  |  | -1 …1 V/V
PDO Auflösung |  |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  |  | 0,128 ppm
PDO LSB (Legacy Range) |  |  | 0,119… ppm
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung |  |  | < ±0,05%MBE = ±500 ppmMBE
Temperaturkoeffizient |  | TkTerminal | < 15 ppm/K typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 (Innenwiderstand) |  |  | Differentiell typ. 5 MΩ || 10 nF
 |  |  | CommonMode typ. 1,25 MΩ || 40 nF Methodik: Widerstand gegen –UV (+2,5V), Kapazität gegen SGND
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset |  | < 480 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain |  | < 100 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin |  | < 75 [ppmMBE]
Wiederholgenauigkeit | FRep |  | < 50 [ppmMBE]
Rauschen (ohne Filterung) | FNoise, PtP |  | < 150 [ppmMBE] |  | < 1172 [digits]
 | FNoise, RMS |  | < 22 [ppmMBE] |  | < 172 [digits]
 | Max. SNR |  | > 93,2 [dB]
 | Rauschdichte@1kHz |  | < 0,31
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP |  | < 14 [ppmMBE] |  | < 109 [digits]
 | FNoise, RMS |  | < 2,5 [ppmMBE] |  | < 20 [digits]
 | Max. SNR |  | > 112 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  |  | DC: < 3 [image] typ. | 50 Hz: < 9 [image] typ. |  | 1 kHz: < 140 [image] typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  |  | DC: < 3 [image] typ. | 50 Hz: < 0,2 [image] typ. |  | 1 kHz: < 5 [image] typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  |  | ±0,2%MBE = ±2000 ppmMBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Potentiometer-Messbereich
Darstellung Potentiometer-Messbereich


Messung SG 1/1-Bridge (Vollbrücke) 4/6-Leiter-Anschluss

Produktübersicht [image] Technische Daten [image] Messung SG 1/1-Bridge (Vollbrücke) 4/6-Leiter-Anschluss
Messung SG 1/1-Bridge (Vollbrücke) 4/6-Leiter-Anschluss
Zur Ermittlung des Messfehlers:
Der Messbereich nominell/technisch wird hier in „mV/V“ angegeben, wobei eine maximale Versorgungsspannung von 5V zulässig ist. Maximal ist also für die Brückenspannung ein nomineller Messbereich von ±32 mV/V * 5V = ±160 mV nutzbar, entsprechend sind die internen Schaltungen ausgelegt.
Die interne Messung erfolgt ratiometrisch, d.h. die Speise- und die Brückenspannung werden nicht absolut gemessen sondern als Verhältnis erfasst.
Zur Speisung kann die integrierte Versorgung genutzt werden. Eine externe Versorgung ist zulässig wenn 5V nicht überstiegen werden.
Hinweis: Angaben gelten für 2,5 V DMS Erregung.
Messung Modus
SG 1/1-Bridge
Messbereich, nominell
-32…+32 mV/V
Messbereich, Endwert (MBE)
32 mV/V
Messbereich, technisch nutzbar
-34,359…+34,359 mV/V
PDO Auflösung
24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range)
4,096 nV/V
PDO LSB (Legacy Range)
3,814.. nV/V
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung (2
4-Leiter-Anschluss: ±0,09%MBE = ±900 ppmMBE typ.
6-Leiter-Anschluss: ±0,05%MBE = ±500 ppmMBE typ.
Integrierte Speisung
0,5…5V Einstellbar, Max. Versorgung/Excitation 21 mA (interne elektronische Überlastsicherung) somit
▪
120R DMS: bis 2,5 V
▪
350R DMS: bis 5,0 V
Temperaturkoeffizient
TkTerminal
< 20 ppm/K typ.
2) Dominierender Anteil der Grundgenauigkeit ist die Offset-Spezifikation (siehe folgende Tabellen). Durch Offset-Korrektur gemäß Kapitel Offset Korrektur kann dieser Anteil eliminiert und die Messgenauigkeit erheblich gesteigert werden.
Messung Modus |  | SG 1/1-Bridge (4-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 850 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 200 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 120 [ppmMBE]
Wiederholgenauigkeit | FRep | < 15 [ppmMBE]
Rauschen (ohne Filterung) | FNoise, PtP | < 320 [ppmMBE] |  | < 2500 [digits]
 | FNoise, RMS | < 56 [ppmMBE] |  | < 438 [digits]
 | Max. SNR | > 85 [dB]
 | Rauschdichte@1kHz | < 25,34
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 18 [ppmMBE] |  | < 141 [digits]
 | FNoise, RMS | < 3,5 [ppmMBE] |  | < 27 [digits]
 | Max. SNR | > 109,1 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 0,15 [image] typ. | 50 Hz: < 0,5 [image] typ. |  | 1 kHz: < 10 [image] typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 100 [image] typ. | 50 Hz: < 10 [image] typ. |  | 1 kHz: < 1 [image] typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 |  | Eingang wird in diesem Modus nicht benutzt
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Messung Modus |  | SG 1/1-Bridge (6-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 470 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 120 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 120 [ppmMBE]
Wiederholgenauigkeit | FRep | < 15 [ppmMBE]
Rauschen (ohne Filterung)4 | FNoise, PtP | < 230 [ppmMBE] |  | < 1797 [digits]
 | FNoise, RMS | < 38 [ppmMBE] |  | < 297 [digits]
 | Max. SNR | > 88,4 [dB]
 | Rauschdichte@1kHz | < 17,2
Rauschen (mit 50 Hz FIR Filter)4 | FNoise, PtP | < 18 [ppmMBE] |  | < 141 [digits]
 | FNoise, RMS | < 3,5 [ppmMBE] |  | < 27 [digits]
 | Max. SNR | > 109,1 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 0,15 [image] typ. | 50 Hz: < 0,5 [image] typ. |  | 1 kHz: < 10 [image] typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 100 [image] typ. | 50 Hz: < 10 [image] typ. |  | 1 kHz: < 1 [image] typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,1%MBE = ±1000 ppmMBE typ.
Eingangsimpedanz ±Input 1 (Innenwiderstand) |  | Differentiell typ. 4,1 MΩ || 11 nF
 |  | CommonMode typ. 1 MΩ || 40 nF Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2 (Innenwiderstand) |  | Differentiell typ. 5 MΩ || 10 nF
 |  | CommonMode typ. 1,25 MΩ || 40 nF Methodik: Widerstand gegen –UV (+2,5V), Kapazität gegen SGND
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
4) Angaben gelten nur für HW-Stand ≥ 10! Folgende Angaben gelten bis HW-Stand 10:
Messung Modus |  | SG 1/1-Bridge (6-Leiter), < HW10
Rauschen (ohne Filterung) | FNoise, PtP | < 960 [ppmMBE] | < 7500 [digits]
 | FNoise, RMS | < 170 [ppmMBE] | < 1328 [digits]
 | Max. SNR | > 75,4 [dB]
 | Rauschdichte@1kHz | < 76,93
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 77 [ppmMBE] | < 602 [digits]
 | FNoise, RMS | < 15 [ppmMBE] | < 117 [digits]
 | Max. SNR | > 96,5 [dB]
Die Übergangswiderstände der Klemmkontakte beeinflussen den Messvorgang. Durch einen anwenderseitigen Abgleich bei gesteckter Signalverbindung kann der Messfehler weiter reduziert werden.
Zur Berechnung der Vollbrücke:
Der Zusammenhang zur Dehnung (µStrain, µε) ist wie folgt:
Die Interpretation des Kanalwerts (PDO) ist direkt [mV/V]:
Darstellung Messbereich SG 1/1-Bridge


Messung SG 1/2-Bridge (Halbbrücke) 3/5-Leiter-Anschluss

Produktübersicht [image] Technische Daten [image] Messung SG 1/2-Bridge (Halbbrücke) 3/5-Leiter-Anschluss
Messung SG 1/2-Bridge (Halbbrücke) 3/5-Leiter-Anschluss
Zur Ermittlung des Messfehlers:
Der Messbereich nominell/technisch wird hier in „mV/V“ angegeben, wobei eine maximale Versorgungsspannung von 5 V zulässig ist. Maximal ist also für die Brückenspannung ein nomineller Messbereich von ±16 mV/V * 5V = ±80 mV nutzbar, die internen Schaltungen sind auf die 160 mV der Vollbrückenmessung ausgelegt.
Die interne Messung erfolgt ratiometrisch, d.h. die Speise- und die Brückenspannung werden nicht absolut gemessen sondern als Verhältnis erfasst.
Zur Speisung kann die integrierte Versorgung genutzt werden. Eine externe Versorgung ist zulässig wenn 5 V nicht überstiegen werden
Hinweis: Angaben gelten für 2,5 V DMS Erregung.
Messung Modus
SG 1/2-Bridge
Messbereich, nominell
-16…+16 mV/V
[entspricht ±16.000 µε bei K=2, N=2]
Messbereich, Endwert (MBE)
16 mV/V
Messbereich, technisch nutzbar
-17,179…+17,179 mV/V
PDO Auflösung
24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range)
2,048 nV/V
PDO LSB (Legacy Range)
1,907.. nV/V
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung (2
3-Leiter-Anschluss: ±0,27% typ. (bez. auf MBE, siehe auch Hinweis)
5-Leiter-Anschluss: ±0,09% typ. (bez. auf MBE, siehe auch Hinweis)
Integrierte Speisung
0,5…5V Einstellbar, Max. Versorgung/Excitation 21 mA (interne elektronische Überlastsicherung) somit
▪
120R DMS: bis 2,5V
▪
350R DMS: bis 5,0V
Temperaturkoeffizient
TkTerminal
<75 ppm/K typ.
(bez. auf MBE, ab Produktion 2016 KW10; vgl. Seriennummer)
<250 ppm/K typ.
(bez. auf MBE, bis Produktion 2016 KW09; vgl. Seriennummer)
Eingangsimpedanz ±Input 1
(Innenwiderstand)
Differentiell typ. 4,1 MΩ || 11 nF
CommonMode typ. 1 MΩ || 40 nF
Methodik: Widerstand gegen –UV, Kapazität gegen SGND
Eingangsimpedanz ±Input 2
(Innenwiderstand)
Differentiell typ. 5 MΩ || 10 nF
CommonMode typ. 1,25 MΩ || 40 nF
Methodik: Widerstand gegen –UV (+2,5V), Kapazität gegen SGND
2) Dominierender Anteil der Grundgenauigkeit ist die Offset-Spezifikation (siehe folgende Tabellen). Durch Offset-Korrektur gemäß Kapitel Offset Korrektur kann dieser Anteil eliminiert und die Messgenauigkeit erheblich gesteigert werden.
Messung Modus |  | SG 1/2-Bridge (3-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 2650 ppmMBE (gilt ab KW01/2018, Wert vor KW01/2018: < 3600 ppmMBE)
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 290 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 390 ppmMBE
Wiederholgenauigkeit | FRep | < 50 ppmMBE
Rauschen (ohne Filterung)4 | FNoise, PtP | < 950 ppmMBE |  | < 7422 [digits]
 | FNoise, RMS | < 145 ppmMBE |  | < 1133 [digits]
 | Max. SNR | > 76,8 dB
 | Rauschdichte@1kHz | < 32,81
Rauschen (mit 50 Hz FIR Filter)4 | FNoise, PtP | < 70 ppmMBE |  | < 547 [digits]
 | FNoise, RMS | < 15 ppmMBE |  | < 117 [digits]
 | Max. SNR | > 96,5 dB
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 150 [image] typ. | 50 Hz: < 600 [image] typ. |  | 1 kHz: < 10 [image] typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 100 [image] typ. | 50 Hz: < 20 [image] typ. |  | 1 kHz: < 0,1 [image] typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,2%MBE = ±2000 ppmMBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
4) Angaben gelten nur für HW-Stand ≥ 10! Folgende Angaben gelten bis HW-Stand 10:
Messung Modus |  | SG 1/2-Bridge (3-Leiter ), < HW10
Rauschen (ohne Filterung) | FNoise, PtP | < 1100 ppmMBE | < 8594 [digits]
 | FNoise, RMS | < 160 ppmMBE | < 1250 [digits]
 | Max. SNR | > 75,9 dB
 | Rauschdichte@1kHz | < 36,2
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 120 ppmMBE | < 938 [digits]
 | FNoise, RMS | < 19 ppmMBE | < 148 [digits]
 | Max. SNR | > 94,4 dB
Messung Modus |  | SG 1/2-Bridge (5-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 750 ppmMBE (gilt ab KW01/2018, Wert vor KW01/2018: < 1100 ppmMBE)
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 290 ppm
Nichtlinearität über den gesamten Messbereich | FLin | < 390 ppmMBE
Wiederholgenauigkeit | FRep | < 50 ppmMBE
Rauschen (ohne Filterung)4 | FNoise, PtP | < 1200 ppmMBE |  | < 9375 [digits]
 | FNoise, RMS | < 175 ppmMBE |  | < 1367 [digits]
 | Max. SNR | > 75,1 dB
 | Rauschdichte@1kHz | < 39,6
Rauschen (mit 50 Hz FIR Filter)4 | FNoise, PtP | < 70 ppmMBE |  | < 547 [digits]
 | FNoise, RMS | < 14 ppmMBE |  | < 109 [digits]
 | Max. SNR | > 97,1 dB
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 150 [image] typ. | 50 Hz: < 600 [image] typ. |  | 1 kHz: < 10 [image] typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 100 [image] typ. | 50 Hz: < 20 [image] typ. |  | 1 kHz: < 0,1 [image] typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±0,2%MBE = ±2000 ppmMBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
4) Angaben gelten nur für HW-Stand ≥ 10! Folgende Angaben gelten bis HW-Stand 10:
Messung Modus |  | SG 1/2-Bridge (5-Leiter ), < HW10
Rauschen (ohne Filterung) | FNoise, PtP | < 1600 ppmMBE | < 12500 [digits]
 | FNoise, RMS | < 240 ppmMBE | < 1875 [digits]
 | Max. SNR | > 72,4 dB
 | Rauschdichte@1kHz | < 54,31
Rauschen (mit 50 Hz FIR Filter) | FNoise, PtP | < 96 ppmMBE | < 750 [digits]
 | FNoise, RMS | < 16 ppmMBE | < 125 [digits]
 | Max. SNR | > 95,9 dB
Die Übergangswiderstände der Klemmkontakte beeinflussen den Messvorgang. Durch einen anwenderseitigen Abgleich bei gesteckter Signalverbindung kann der Messfehler weiter reduziert werden.
Gültigkeit der Eigenschaftswerte
Der Brückenwiderstand liegt parallel zum o.a. Innenwiderstand der Klemme und führt zu entsprechender Offset-Verschiebung. Der Beckhoff-Werksabgleich erfolgt mit Halbbrücke 350 Ω, die o.a. Werte sind deshalb direkt nur für eine 350 Ω-Halbbrücke gültig. Bei Anschluss einer anders dimensionierten Halbbrücke ist:
•
anwenderseitig ein Abgleich (Offsetkorrektur) in der Klemme oder Steuerung/PLC durchzuführen
•
oder der theoretische Offsetfehler im Abgleichparameter S0 einzutragen. Beispiel: Bei einer 350 Ω-Brücke entspricht der beim Werksabgleich kompensierte Einfluss des Eingangswiderstandes (2 MΩ) 0,26545 %MBE (16 mV/V), das entspricht 20738 Digits.
Zur Berechnung der R1/2-Halbbrücke:
R3/4 sind die klemmeninternen schaltbaren Ergänzungswiderstände. Andere Halbbrückenkonfigurationen (z.B. R1/4 oder R1/3 veränderlich) sind nicht anschließbar.
Der Zusammenhang zur Dehnung (µStrain, µε) ist wie folgt:
Die Wahl von N ist nach der mechanischen Anordnung der variablen Widerstände zu wählen (Poisson, 2 aktive uniaxial, …). Die Interpretation des Kanalwerts (PDO) ist direkt [mV/V].
Darstellung Messbereich SG 1/2-Bridge


Messung SG 1/4-Bridge (Viertelbrücke) 120 Ω 2/3-Leiter-Anschluss

Produktübersicht [image] Technische Daten [image] Messung SG 1/4-Bridge (Viertelbrücke) 120 Ω 2/3-Leiter-Anschluss
Messung SG 1/4-Bridge (Viertelbrücke) 120 Ω 2/3-Leiter-Anschluss
¹) Die Ausführungen zur 2/3/4-Leiter-Messung im Kapitel zur Widerstandsmessung des Kapitels „technischen Daten“ ist zu beachten!
Hinweis: Angaben gelten für 2,5 V DMS Erregung.
Messung Modus |  | SG 1/4-Bridge 120 Ω
Messbereich, nominell |  | 120 ± 12 Ω bzw. ±25 mV/V [entspricht 108 Ω…132 Ω] [entspricht ±50.000 µε bei K=2]
Messbereich, Endwert (MBE) |  | 132 Ω
Messbereich, technisch nutzbar |  | 120 ± 12,88.. Ω
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 1,536 µΩ/Schritt
PDO LSB (Legacy Range) |  | 1,430.. µΩ/Schritt
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung (2 |  | 2-Leiter-Anschluss: 0,05% typ. (bez. auf MBE) 3-Leiter-Anschluss: 0,04% typ. (bez. auf MBE) 4-Leiter-Anschluss: nicht möglich
Integrierte Speisung |  | 0,5…2,5V Einstellbar, Max. Versorgung/Excitation 21 mA (interne elektronische Überlastsicherung)
Temperaturkoeffizient (¹ | TkTerminal | <8 ppm/K typ. (bez. auf MBE, ab HW-Stand 06; vgl. Seriennummer) <12 ppm/K typ. (bez. auf MBE, HW-Stand 04 ab Produktion 2016 KW10; vgl. Seriennummer) <60 ppm/K typ. (bez. auf MBE, HW-Stand 01-04, Produktion bis 2016 KW09; vgl. Seriennummer)
2) Dominierender Anteil der Grundgenauigkeit ist die Offset-Spezifikation (siehe folgende Tabellen). Durch Offset-Korrektur gemäß Kapitel Offset Korrektur kann dieser Anteil eliminiert und die Messgenauigkeit erheblich gesteigert werden.
Messung Modus |  | SG 1/4-Bridge 120 Ω (2-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 420 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 250 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 50 [ppmMBE]
Wiederholgenauigkeit (bei 23°C) | FRep | < 15 [ppmMBE]
Rauschen (ohne Filterung, bei 23°C) | FNoise, PtP | < 160 [ppmMBE] |  | < 13750 [digits]
 | FNoise, RMS | < 20 [ppmMBE] |  | < 1720 [digits]
 | Max. SNR | > 73,1 [dB]
 | Rauschdichte@1kHz | < 37,36
Rauschen (mit 50 Hz FIR Filter, bei 23°C) | FNoise, PtP | < 6 [ppmMBE] |  | < 520 [digits]
 | FNoise, RMS | < 1 [ppmMBE] |  | < 86 [digits]
 | Max. SNR | > 99,2 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 0,3 Ω/V typ. | 50 Hz: < 1 Ω/V typ. |  | 1 kHz: < 20 Ω/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 300 mΩ/V typ. | 50 Hz: < 40 mΩ/V typ. |  | 1 kHz: < 0,5 mΩ/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±1%MBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Messung Modus |  | SG 1/4-Bridge 120 Ω (3-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 360 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 150 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 50 [ppmMBE]
Wiederholgenauigkeit (bei 23°C) | FRep | < 15 [ppmMBE]
Rauschen (ohne Filterung, bei 23°C) | FNoise, PtP | < 160 [ppmMBE] |  | < 13750 [digits]
 | FNoise, RMS | < 20 [ppmMBE] |  | < 1720 [digits]
 | Max. SNR | > 73,1 [dB]
 | Rauschdichte@1kHz | < 37,36
Rauschen (mit 50 Hz FIR Filter, bei 23°C) | FNoise, PtP | < 6 [ppmMBE] |  | < 520 [digits]
 | FNoise, RMS | < 1 [ppmMBE] |  | < 86 [digits]
 | Max. SNR | > 99,2 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 0,3 Ω/V typ. | 50 Hz: < 1 Ω/V typ. |  | 1 kHz: < 20 Ω/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 300 mΩ/V typ. | 50 Hz: < 40 mΩ/V typ. |  | 1 kHz: < 0,5 mΩ/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±1%MBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Die Übergangswiderstände der Klemmkontakte beeinflussen den Messvorgang. Durch einen anwenderseitigen Abgleich bei gesteckter Signalverbindung kann der Messfehler weiter reduziert werden.
Der Temperaturkoeffizient (Klemme) kann durch einen externen, temperaturstabileren Ergänzungswiderstand und Klemmenbetrieb in Halb/Vollbrücke verbessert werden.
Zur Berechnung der Viertelbrücke:
R2/3/4 sind die klemmeninternen schaltbaren Ergänzungswiderstände.
Der Zusammenhang zur Dehnung (µStrain, µε) ist wie folgt:
Bei der Viertelbrücke ist immer N=1.
Die Interpretation des Kanalwerts (PDO) kann in ± 12 Ω bzw. ±25 mV/V erfolgen:
Darstellung Messbereich SG 1/4-Bridge 120 Ω


Messung SG 1/4-Bridge (Viertelbrücke) 350 Ω 2/3-Leiter-Anschluss

Produktübersicht [image] Technische Daten [image] Messung SG 1/4-Bridge (Viertelbrücke) 350 Ω 2/3-Leiter-Anschluss
Messung SG 1/4-Bridge (Viertelbrücke) 350 Ω 2/3-Leiter-Anschluss
¹) Die Ausführungen zur 2/3/4-Leiter-Messung im Kapitel zur Widerstandsmessung des Kapitels „technischen Daten“ ist zu beachten!
Hinweis: Angaben gelten für 2,5 V DMS Erregung.
Messung Modus |  | SG 1/4-Bridge 350 Ω
Messbereich, nominell |  | 350 ± 12 Ω bzw. ±8,571 mV/V [entspricht 338 Ω…362 Ω] [entspricht ±17.142 µε bei K=2]
Messbereich, Endwert (MBE) |  | 362 Ω
Messbereich, technisch nutzbar |  | 350 ± 12,88.. Ω
PDO Auflösung |  | 24 Bit (inkl. Vorzeichen)
PDO LSB (Extended Range) |  | 1,536 µΩ/Schritt
PDO LSB (Legacy Range) |  | 1,430.. µΩ/Schritt
Grundgenauigkeit: Messfehler bei 23°C, mit Mittelwertbildung (2 |  | 2-Leiter-Anschluss: 0,03% typ. (bez. auf MBE) 3-Leiter-Anschluss: 0,02% typ. (bez. auf MBE) 4-Leiter-Anschluss: nicht möglich
Integrierte Speisung |  | 0,5…5V Einstellbar, Max. Versorgung/Excitation 21 mA (interne elektronische Überlastsicherung)
Temperaturkoeffizient (¹ | TkTerminal | <8 ppm/K typ. (bez. auf MBE, ab Produktion 2016 KW10; vgl. Seriennummer) <40 ppm/K typ. (bez. auf MBE, bis Produktion 2016 KW09; vgl. Seriennummer)
2) Dominierender Anteil der Grundgenauigkeit ist die Offset-Spezifikation (siehe folgende Tabellen). Durch Offset-Korrektur gemäß Kapitel Offset Korrektur kann dieser Anteil eliminiert und die Messgenauigkeit erheblich gesteigert werden.
Messung Modus |  | SG 1/4-Bridge 350 Ω (2-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | < 250 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 150 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 40 [ppmMBE]
Wiederholgenauigkeit (bei 23°C) | FRep | < 10 [ppmMBE]
Rauschen (ohne Filterung, bei 23°C) | FNoise, PtP | < 105 [ppmMBE] |  | < 24750 [digits]
 | FNoise, RMS | < 18 [ppmMBE] |  | < 4240 [digits]
 | Max. SNR | > 65,3 [dB]
 | Rauschdichte@1kHz | < 92,1
Rauschen (mit 50 Hz FIR Filter, bei 23°C) | FNoise, PtP | < 6 [ppmMBE] |  | < 1400 [digits]
 | FNoise, RMS | < 1 [ppmMBE] |  | < 236 [digits]
 | Max. SNR | > 90,4 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 2 Ω/V typ. | 50 Hz: < 8 Ω/V typ. |  | 1 kHz: < 150 Ω/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 700 mΩ/V typ. | 50 Hz: < 90 mΩ/V typ. |  | 1 kHz: < 0,5 mΩ/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±1%MBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Messung Modus |  | SG 1/4-Bridge 350 Ω (3-Leiter)
Offset/Nullpunkt-Fehler (bei 23°C) | FOffset | <140 [ppmMBE]
Gain/Scale/Verstärkungs-Fehler (bei 23°C) | FGain | < 130 [ppm]
Nichtlinearität über den gesamten Messbereich | FLin | < 40 [ppmMBE]
Wiederholgenauigkeit (bei 23°C) | FRep | < 10 [ppmMBE]
Rauschen (ohne Filterung, bei 23°C) | FNoise, PtP | < 105 [ppmMBE] |  | < 24750 [digits]
 | FNoise, RMS | < 18 [ppmMBE] |  | < 4240 [digits]
 | Max. SNR | > 65,3 [dB]
 | Rauschdichte@1kHz | < 92,1
Rauschen (mit 50 Hz FIR Filter, bei 23°C) | FNoise, PtP | < 6 [ppmMBE] |  | < 1400 [digits]
 | FNoise, RMS | < 1 [ppmMBE] |  | < 236 [digits]
 | Max. SNR | > 90,4 [dB]
Gleichtaktunterdrückung (ohne Filter)3 |  | DC: < 2 Ω/V typ. | 50 Hz: < 8 Ω/V typ. |  | 1 kHz: < 150 Ω/V typ.
Gleichtaktunterdrückung (mit 50 Hz FIR Filter)3 |  | DC: < 700 mΩ/V typ. | 50 Hz: < 90 mΩ/V typ. |  | 1 kHz: < 0,5 mΩ/V typ.
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung |  | ±1%MBE typ.
3) Werte beziehen sich auf eine Gleichtaktstörung zwischen SGND und internem GND.
Die Übergangswiderstände der Klemmkontakte beeinflussen den Messvorgang. Durch einen anwenderseitigen Abgleich bei gesteckter Signalverbindung kann der Messfehler weiter reduziert werden.
Der Temperaturkoeffizient (Klemme) kann durch einen externen, temperaturstabileren Ergänzungswiderstand und Klemmenbetrieb in Halb/Vollbrücke verbessert werden.
Zur Berechnung der Viertelbrücke:
R2/3/4 sind die klemmeninternen schaltbaren Ergänzungswiderstände.
Der Zusammenhang zur Dehnung (µStrain, µε) ist wie folgt:
Bei der Viertelbrücke ist immer N=1.
Die Interpretation des Kanalwerts (PDO) kann in ± 12 Ω bzw. ±8,571 mV/V erfolgen:
Darstellung Messbereich SG 1/4-Bridge 350 Ω


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Hinweis
In dieser Kurzdokumentation sind dazu keine Informationen enthalten. Bitte wenden Sie sich an den für Sie zuständigen Beckhoff Vertrieb um die vollständige Dokumentation zu erhalten.


EL3751 Features

EL3751 Features
EL3751 Features
Hinweis
In dieser Kurzdokumentation sind dazu keine Informationen enthalten. Bitte wenden Sie sich an den für Sie zuständigen Beckhoff Vertrieb um die vollständige Dokumentation zu erhalten.


Inbetriebnahme am EtherCAT Master

Inbetriebnahme am EtherCAT Master
Inbetriebnahme am EtherCAT Master
Weiterführende Informationen
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
TwinCAT Quickstart
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme am EtherCAT Master [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


TwinCAT Quickstart

Inbetriebnahme am EtherCAT Master [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme am EtherCAT Master [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme am EtherCAT Master [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


EtherCAT-Grundlagen

Inbetriebnahme am EtherCAT Master [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Inbetriebnahme am EtherCAT Master [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Inbetriebnahme am EtherCAT Master [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Inbetriebnahme am EtherCAT Master [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Inbetriebnahme am EtherCAT Master [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Inbetriebnahme am EtherCAT Master [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
Hinweise zu Stecker und Verdrahtung
•
Schirmkonzept
•
Tragschienenmontage
•
Anschlusstechnik
•
Bedeutung der LEDs
•
Anschlussbelegung


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


Hinweise zu Stecker und Verdrahtung

Montage und Verdrahtung [image] Hinweise zu Stecker und Verdrahtung
Hinweise zu Stecker und Verdrahtung
Es liegt in der Natur von EtherCAT IO-Modulen/Klemmen/Boxen daß sie 2 Anschlussseiten haben: die eine obligatorisch zum Feldbus um mit dem Modul zu kommunizieren, die andere zum Signal/Sensor/Aktor um das Modul bestimmungsgemäß verwenden zu können. Die „äußere“ Anschlussseite ist in der Regel mit Kontaktiertechnik ausgerüstet um die weiterführenden Leitungen anschließen zu können.
Nur wenige IO Geräte verfügen über keine 2.Seite, wie z.B. die EL6070 Dongle-Klemme oder eine EL6090 Displayklemme.
Im Folgenden einige Hinweise und Anregungen zum Umgang mit der Anschlusstechnik
▪
Herstellerseitige Vorgaben/Hinweise zur Anschlusstechnik sind zu beachten. Ggf. ist vorgesehenes Spezialwerkzeug sachgerecht zu verwenden, Stichwort Gasdichtigkeit beim Crimpen durch den Pressdruck.
▪
Jede lösbare Anschlusstechnik unterliegt Vorgaben zur Anzahl der Verbindungszyklen. Bei jedem Lösen/Stecken der Verbindung kommt es zu Reibvorgängen/Abrieb, mechanischer Dehnung/Relaxation, evtl. Eintrag von Schmutz, Zutritt von Gasen/Flüssigkeiten/Betauung, Kontaktentladung, Veränderung der elektrischen Eigenschaften und des Kontaktpunkts (ohmscher Übergangswiderstand). Es treten also mechanische, chemische und damit am Ende elektrische Veränderungen ein, wenn ein Kontakt gelöst/verbunden wird.
Im Hinblick auf das Einsatzszenario ist deshalb die passende Verbindungstechnik bzw. Geräte mit der passenden Verbindungstechnik zu wählen:
–
Für selten zu lösende Verbindungen können Stecker/Kontakte sinnvoll sein die mit einer max. Steckzyklenzahl (lt. Hersteller) von 10..100 spezifiziert sind. Dies kann der Fall sein wenn Geräte einmalig installiert/verdrahtet werden, und über die Lebenszeit nur mit Umverdrahtung im Wartungsfall zu rechnen ist.
–
Für häufig zu lösende Verbindungen müssen Stecker/Kontakte mit einer max. Steckzyklenzahl von 1.000 und aufwärts gewählt werden. Solche Verbindungen sind typischerweise im Laborumfeld zu finden, wo mehrmals täglich die Verkabelung verändert wird und trotzdem über Jahre qualitativ hochwertiger Kontakt sichergestellt sein muß.
▪
Bei der Handhabung und insbesondere Konfektionierung von Steckern/Kontakten ist streng darauf zu achten daß auch bei Low-Tech Verbindungen (offene Litze, Käfigzugfeder/PushIn) der Kontakt mit Handschweiß/Flüssigkeiten vermieden wird. Saure/Alkalische Flüssigkeiten können sehr aggressiv auf die Kontaktoberflächen einwirken und führen dort schnell zu Gefügeveränderungen und Oxidationsschichten. Diese wirken äußerst störend im analogen Messbetrieb, insbesondere da sie die Reproduzierbarkeit von Messungen untergraben und damit (wenn bekannt) eine sehr große systematische Messunsicherheit bewirken. Ggf. kann eine nachfolgende gründliche Reinigung vorgesehen werden.
▪
Die auftretende/erwartete Belastung im Betrieb muß dringend bei der Steckerauswahl bedacht werden.
▪
Außerdordentliche Schwingungen können zu Mikroreibung/korrosion führen und die elektrischen Eigenschaften verändern, bis zum vollständigen Kontaktabbruch.
▪
Temperatur hat Einfluss u.a. auf die mechanische Festigkeit der Verbindung und die Federkräfte in metallischen Komponenten.
▪
Gas/Flüssigkeitseinwirkung kann die Verbindung schädigen, insbesondere wenn sie in den eigentlichen Kontaktbereich dringt und dort nicht mehr entweichen kann.
▪
Im analogen Messtechnischen Bereich ist die elektrische Qualität der Verbindung, sowohl kurzzeitig im Inbetriebnahmefall als auch über die Lebensdauer unter äußeren Einflüssen und ggf. wiederholten Steckzyklen von hoher Relevanz. Dies drückt sich in der Wiederholpräzision des Übergangs aus, der Einfluß ist gegen die gesetzten Genauigkeitserwartungen zu prüfen. Hauptsächlich ist dort der (frequenzabhängige) Kontaktwiderstand relevant; Effekte können sein:
–
Durch Erhöhung des Kontaktwiderstands kommt es bei Stromübertragung zu Spannungsabfall und damit ggf. kritischer Eigenerwärmung
–
Der interne Spannungsabfall kann entsprechende Messungen verfälschen. Um Auswirkungen zu vermeiden sind 4/5/6-Leiter-Verbindungen in der DMS/Widerstandmessung vorzusehen, da nicht-stromführende Kontakte keinen verfälschenden Spannungsabfall mehr aufweisen. Die beliebte 3-Leiter-Verbindung bei Widerstandsmessung (PT100, PT1000 etc) ist kein absoluter Schutz da die singuläre Leitung nicht diagnostiziert werden kann. Strom/Spannungsmessungen im industriellen Umfeld sind weniger sensibel auf Kontaktveränderungen.
–
Bei schadhafter Kontaktoberfläche kann es je nach Kontaktlage zu zufälligen Widerstandsverhältnissen kommen, je nach Lage/Temperatur. Damit wird eine reproduzierbare Messung schwierig.
▪
Der Aufwand für die Herstellung der Verbindung, das Konfektionieren der Leitungen/Stecker, steigt in der Regel mit dem Anspruch an die Übertragungsqualität. Dies betrifft die benötigten Werkzeuge, Sorgfalt der Ausführung und Zeitbedarf. Beispiele:
–
Die in der Automatisierungstechnik übliche Käfigzugfeder/PushIn-Verbindung (Beispiel Beckhoff EL-Klemmen) ist in wenigen Sekunden mit oder ohne Aderendhülse hergestellt oder gelöst, ein Schraubendreher oder Drückstift ist ausreichend. Dafür ist die (ohmsche) Wiederholgenauigkeit oft nicht ausreichend für hochpräzise Messungen im DMS/R-Bereich.
–
Zur Konfektionierung eines Labor-üblichen LEMO/ODU-Steckers (Beispiel Beckhoff ELM3704-0001) sind einige 10 Minuten und Kosten von einigen 10€ anzusetzen - je nach Polzahl. Dafür erhält man höchstwertige Vebindungstechnik mit hoher zugelassener Steckzyklenzahl.
–
Eine Zwischenform können feldkonfektionierbare M8/M12-Verbindungen sein. Aus Dichtigkeitsgründen sind sie aufwendiger zu konfektionieren (ggf. löten oder Schneidklemmtechnik), von der Steckzyklenzahl sind sie oft eher im Bereich der Wartungsstecker anzusiedeln.
▪
Eine konfektionierte Verbindung sollte vor Inbetriebnahme elektrisch/mechanisch geprüft werden: Sichtkontrolle, Auszugstest, Crimphöhenmessung, Widerstandsmessung etc.


Schirmkonzept

Montage und Verdrahtung [image] Schirmkonzept
Schirmkonzept
Die vorkonfektionierten Leitungen von Beckhoff Automation bieten zusammen mit der Schirmschiene einen optimalen Schutz gegen elektro-magnetische Störungen.
Es wird empfohlen, den Schirm möglichst nah an der Klemme aufzulegen, um Störungen auf ein Minimum zu reduzieren.
Anschluss der Motorleitung an die Schirmschiene
Befestigen Sie die Schirmschienenträger 1 auf der Hutschiene 2. Die Tragschiene 2 muss großflächig mit der metallischen Rückwand des Schaltschranks verbunden sein. Montieren Sie die Schirmschiene 3 wie in Abb. „Schirmschiene“ abgebildet.
Alternativ kann ein Schirmschienen-Bügel 3a direkt mit der metallischen Rückwand des Schaltschranks verschraubt werden (Abb. „Schirmschienen-Bügel“)
Schirmschiene
Schirmschienen-Bügel
Verdrahten Sie die Adern 4 der Motorleitung 5 und befestigen Sie dann das kupferummantelte Ende 6 der Motorleitung 5 mit der Schirmschelle 7 an die Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Ziehen Sie die Schraube 8 bis zum Anschlag an.
Befestigen Sie die PE-Schelle 9 an die Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Klemmen Sie die PE-Ader 10 der Motorleitung 5 unter die PE-Schelle 9.
Schirmanbindung
Anschluss der Feedbackleitung an den Motor
Verdrillen der Feedbackleitungen
Die Feedbackleitungen sollten verdrillt werden, um Störeinflüsse zu minimieren.
Beim Anschrauben des Feedbacksteckers an den Motor wird der Schirmanschluss der Feedbackleitung über die metallische Steckerbefestigung hergestellt.
Auf der Klemmenseite kann der Schirm ebenfalls aufgelegt werden. Verdrahten Sie die Adern der Feedbackleitung und befestigen Sie das kupferummantelte Ende der Feedbackleitung mit der Schirmschelle 7 an der Schirmschiene 3 bzw. Schirmschienen-Bügel 3a. Motor- und Feedbackleitung können zusammen mit der Schraube 8 der Schirmschelle 7 aufgelegt werden.


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Bedeutung der LEDs

Montage und Verdrahtung [image] Bedeutung der LEDs
Bedeutung der LEDs
LED | Farbe | Bedeutung
EcRun | grün | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
LED
Farbe
Bedeutung
Ok/Error
grün
Kein Fehler
rot
Fehleranzeige, zugleich mit Error Bit im Status, bei
▪
Range Error des Messbereiches (nicht bei Underrange/Overrange!)
▪
Messtyp eingestellt der nicht kalibriert ist (siehe CoE Objekt 0x800F)
▪
Prozessorüberlast (siehe CoE Objekt 0xF900„InfoData“)
▪
ADC in Sättigung „saturation“
▪
Analoge Schaltung überlastet „in overload“, Überspannung an Eingängen erkannt; siehe Hinweise im Kapitel „Technische Daten” und im folgenden Kapitel „Anschlussbelegung“
▪
Oversampling Error im Synchron Mode
aus
Kein Betrieb


Anschlussbelegung

Montage und Verdrahtung [image] Anschlussbelegung
Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
+Input 1 | 1 | +Eingang 1
+Input 2 | 2 | +Eingang 2
+Uv | 3 | +Versorgungsspannung
Shield | 4 | Schirm (FE)/ SGND
-Input 1 | 5 | -Eingang 1
-Input 2 | 6 | -Eingang 2
-Uv (GNDint) | 7 | -Versorgungsspannung (interne Masse)
Shield | 8 | Schirm (FE)/ SGND
Der interne Überspannungsschutz der Eingänge bezogen auf –Uv (interne Masse) wird wie folgt aktiv:
+IN1, -IN1: bei ca. 12 +/- 0,5V (im 30V-Modus bei ca. 37 +/- 1V)
+IN2, -IN2: bei ca. <-0,3V oder >+5,3V


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Beispielprogramme
•
Diagnose - Grundlagen zu Diag Messages
•
TcEventLogger und IO
•
CoE Übersicht
•
UL-Hinweise
•
ATEX-Dokumentation
•
EtherCAT AL Status Codes
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Firmware Kompatibilität - Passive Klemmen
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


Beispielprogramme

Anhang [image] Beispielprogramme
Beispielprogramme
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1
Weiterführende Informationen
•
Beispielprogramm 1 und 2 (Offset/Gain)
•
Beispielprogramm 3 (LookUp-Tabelle schreiben)
•
Beispielprogramm 4 (LookUp-Tabelle erzeugen)
•
Beispielprogramm 5 (Filterkoeffizienten schreiben)
•
Beispielprogramm 6 (Verschränken von Messwerten)
•
Beispielprogramm 7 (Allgemeine Dezimierung in der PLC)
•
Beispielprogramm 8 (FB zur Echtzeit Diagnose)


Beispielprogramm 1 und 2 (Offset/Gain)

Anhang [image] Beispielprogramme [image] Beispielprogramm 1 und 2 (Offset/Gain)
Beispielprogramm 1 und 2 (Offset/Gain)
Download TwinCAT 3 Projekt:
Programmbeschreibung/ Funktion:
1.
Berechnung eines Offset-Korrekturwertes anhand der Amplituden einer Eingangswechselspannung (mit entsprechenden Gleichspannungsanteil) sowie schrittweiser Eintrag dieses Wertes per CoE‑Zugriff in die Klemme bis eine Minimalabweichung zu Null („wOFFSET_MIN_VAL_REF“) des Messwertes erreicht ist.
2.
(Falls 1. ausgeführt:) Berechnung eines Gain-Wertes sowie schrittweiser Eintrag dieses Wertes per CoE‑Zugriff in die Klemme bis „nPRESET_MAX_VAL“ als Amplitude des Messwertes erreicht ist.
Variablendeklaration Beispielprogramme 1 und 2
PROGRAM MAIN
VAR_INPUT
// Use an external Switch to start justify Offset/Gain
bEnable AT%I* :BOOL;
PAI_Sample AT%I* :DINT; // Variable link to terminal input Ch.1
END_VAR
VAR
// "Main" State controlling Offset/Gain adjusting:
nMainCal_State :BYTE:=0;
// ===============================================
// For CoE Object 0x8005 access:
fb_coe_write :FB_EcCoESdoWrite;
// Enter your Net-Id here:
userNetId :T_AmsNetId := '191.168.1.1.4.1';
// Enter terminals adress here:
userSlaveAddr :UINT := 1003;
wCoEIndexScaler :WORD := 16#8005;
bySubIndScalGain :BYTE := 16#02;
bySubIndScalOffs :BYTE := 16#01;
nADSErrId :UDINT; // Copy of ADS-Error ID
// ===============================================
// Variables for calculation
fb_get_min_max :FB_GET_MIN_MAX;
// Variables used for offset scaling:
nSTATE_SCALE_OFFSET :INT := 0;
bStartScaleOffset :BOOL := FALSE;
bScaleOffsetDone :BOOL := FALSE;
fOffsetDeviationVal :REAL;
fScalerOffset_COE :LREAL := 0;
wOFFSET_MIN_VAL_REF :WORD := 2000; // Deviation tolerance
// Variables used for gain scaling:
nSTATE_SCALE_GAIN :INT := 0;
bStartScaleGain :BOOL := FALSE;
bScaleGainDone :BOOL := FALSE;
fScalerGain_COE :REAL := 1;
nPRESET_MAX_VAL :DINT := 3000000; // Target amplitude value
nMaxAmplVal :DINT;
// ===============================================
// Variables for intermediate results
nValue :DINT; // Used for Offset (adding)
fValue :REAL; // Used for Gain (multiply)
END_VAR
Ausführungsteil:
// Example program 1 and 2 program code:
// =====================================
IF bEnable AND (nMainCal_State = 0) THEN // Poll Switch
nMainCal_State := 10;
END_IF
CASE nMainCal_State OF // Main-State Procedure
10:
bStartScaleOffset:=TRUE; // Start with Offset scaling
nMainCal_State := nMainCal_State + 1; // next state
11:
IF bScaleOffsetDone THEN
bStartScaleGain := TRUE; // Continue with gain scaling
nMainCal_State := nMainCal_State + 1;
END_IF
12:
IF bScaleGainDone THEN
nMainCal_State := nMainCal_State + 1; // all done
END_IF
13:
IF NOT bEnable THEN
nMainCal_State :=0; // Initalization for next start by user
END_IF
END_CASE
// ----- Offset scaling -----
IF bStartScaleOffset THEN
CASE nSTATE_SCALE_OFFSET OF
0:
bScaleOffsetDone := FALSE; // Initialization of confirmation flag
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1;
1:
fb_get_min_max(nInputValue:=PAI_Sample); // Get min/max Values by current Sample value
IF fb_get_min_max.bRESULT THEN // Wait if Limit-Values are valid
fb_coe_write(bExecute := FALSE); // Prepare CoE access
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1; // Min/Max Values valid - go to next state
END_IF
2:
// Calculate current offset deviation
fOffsetDeviationVal :=
LREAL_TO_REAL(ABS(fb_get_min_max.nMinVal)
- ((ABS(fb_get_min_max.nMaxVal)
+ ABS(fb_get_min_max.nMinVal))/2));
// Offset deviation check:
IF ABS(fOffsetDeviationVal) < wOFFSET_MIN_VAL_REF THEN
// Deviation in acceptable range - offset scaling done
bScaleOffsetDone := TRUE;
bStartScaleOffset := FALSE;
nSTATE_SCALE_OFFSET := 0;
ELSE
// Calculate new offset value (consider pre-assigned value)
nValue := LREAL_TO_DINT(fScalerOffset_COE + fOffsetDeviationVal);
// ..proceed zero-point shift: write value into CoE Object
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= bySubIndScalOffs,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(nValue), // Offset-Value (CoE 0x8005:01)
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S,
bBusy=> ,
bError=> ,
nErrId=> );
nSTATE_SCALE_OFFSET := nSTATE_SCALE_OFFSET + 1;
END_IF
3:
fb_coe_write();
IF fb_coe_write.bError THEN
nSTATE_SCALE_OFFSET := 100;
ELSE
IF NOT fb_coe_write.bBusy THEN
fScalerOffset_COE := DINT_TO_LREAL(nValue);
nSTATE_SCALE_OFFSET := 0;
END_IF
END_IF
100:
// Copy Error ID for interpretation:
nADSErrId := fb_coe_write.nErrId;
END_CASE
END_IF
// ----- Justify gain: write calculated value in CoE - Object 0x8005 -----
IF bStartScaleGain THEN
CASE nSTATE_SCALE_GAIN OF
0:
bScaleGainDone := FALSE; // Initialization of confirmation flag
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1;
1:
// Get min/max Values by current Sample value:
fb_get_min_max(nInputValue:=PAI_Sample);
IF fb_get_min_max.bRESULT THEN // Wait if Limit-Values are valid
fb_coe_write(bExecute := FALSE); // Prepare CoE access
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1; // Min/Max Values valid - go to next state
END_IF
2:
// Get current amplitude for calculating the gain value:
nMaxAmplVal := MAX(ABS(fb_get_min_max.nMaxVal), ABS(fb_get_min_max.nMinVal));
// Avoid division by zero:
IF nMaxAmplVal = 0 THEN
nSTATE_SCALE_GAIN := 100;
ELSE
// Calculate Gain:
fValue := DINT_TO_REAL(nPRESET_MAX_VAL)/DINT_TO_REAL(nMaxAmplVal) * fScalerGain_COE;
// Shift gain value by 16 Bit left and convert to DINT:
nValue := REAL_TO_DINT(fValue * 65536);
// Write to CoE Index:
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= bySubIndScalGain,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(nValue), // Gain-Value (CoE 0x8005:02)
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S,
bBusy=> ,
bError=> ,
nErrId=> );
nSTATE_SCALE_GAIN := nSTATE_SCALE_GAIN + 1;
END_IF
3:
fb_coe_write();
IF fb_coe_write.bError THEN
nSTATE_SCALE_GAIN := 100;
ELSE
IF NOT fb_coe_write.bBusy THEN
fScalerGain_COE := fValue;
bStartScaleGain := FALSE; // gain scaling done
bScaleGainDone := TRUE;
nSTATE_SCALE_GAIN := 0; // Set initial state
END_IF
END_IF
100:
// Copy Error ID for interpretation:
nADSErrId := fb_coe_write.nErrId;
END_CASE
END_IF
Weiterführende Informationen
•
Funktionsblock FB_GET_MIN_MAX


Funktionsblock FB_GET_MIN_MAX

Anhang [image] Beispielprogramme [image] Beispielprogramm 1 und 2 (Offset/Gain) [image] Funktionsblock FB_GET_MIN_MAX
Funktionsblock FB_GET_MIN_MAX
Deklarationsteil:
FUNCTION_BLOCK FB_GET_MIN_MAX
VAR CONSTANT
// Counter initialization dependent by
// lowest input frequency 1/(2*f*cyclTime)
// used during offset adjust
CMMcnt :UINT := 200;
END_VAR
VAR_INPUT
bInit :BOOL := TRUE;
nInputValue :DINT;END_VAR
VAR_OUTPUT
bRESULT :BOOL;
nMaxVal :DINT :=0;
nMinVal :DINT :=0;
END_VAR
VAR
nMaxValCnt :UINT;
nMinValCnt :UINT;
bValidMinVal :BOOL;
bValidMaxVal :BOOL;
END_VAR
Ausführungsteil:
IF bInit THEN
nMaxValCnt :=CMMcnt;
nMinValCnt :=CMMcnt;
nMaxVal := 0;
nMinVal := 0;
bInit := FALSE;
END_IF
// Assertions: new min/max values exists:
bValidMaxVal := TRUE;
bValidMinVal := TRUE;
// Filter min/max values
IF nMaxVal < nInputValue THEN
bValidMaxVal := FALSE;
nMaxVal := nInputValue; // Max value was found
END_IF
IF nMinVal > nInputValue THEN
bValidMinVal := FALSE;
nMinVal := nInputValue; // Min value was found
END_IF
// Count down, if no new value come in:
IF bValidMaxVal AND nMaxValCnt > 0 THEN
nMaxValCnt := nMaxValCnt - 1;
END_IF
// Count down, if no new value come in:
IF bValidMinVal AND nMinValCnt > 0 THEN
nMinValCnt := nMinValCnt - 1;
END_IF
IF ((nMaxValCnt = 0) AND (nMinValCnt = 0)) THEN
// Consequence: min/max determined
bInit := TRUE; // Prepare next call
bRESULT := TRUE; // Sign valid results
ELSE
bRESULT := FALSE; // Sign still invalid results
END_IF


Beispielprogramm 3 (LookUp-Tabelle schreiben)

Anhang [image] Beispielprogramme [image] Beispielprogramm 3 (LookUp-Tabelle schreiben)
Beispielprogramm 3 (LookUp-Tabelle schreiben)
Download TwinCAT 3 Projekt:
Programmbeschreibung/ Funktion:
Übertragung von LookUp-Tabellenstützwerten per CoE‑Zugiff in die Klemme für die Abbildung einer Funktion f(x) = x3.
Variablendeklaration Beispielprogramm 3
PROGRAM MAIN
VAR
//LookUp-Table (LUT) generated by: MBE * x³
aLUT:ARRAY[0..99] OF DINT :=
[
-7812500,-7812500,-7493593,-6894382,
-7174765,-6051169,-6855859,-5279674,-6536953,-4576709,
-6218125,-3939087,-5899218,-3363620,-5580390,-2847120,
-5261484,-2386402,-4942578,-1978275,-4623750,-1619555,
-4304843,-1307052,-3985937,-1037580,-3667109,-807951,
-3348203,-614978,-3029375,-455472,-2710468,-326248,
-2391562,-224117,-2072734,-145892,-1753828,-88385,
-1434921,-48409,-1116093,-22776,-797187,-8300,
-478281,-1792,-159453,-66,159453,66,
478281,1792,797187,8300,1116093,22776,
1434921,48409,1753828,88385,2072734,145892,
2391562,224117,2710468,326248,3029375,455472,
3348203,614978,3667109,807951,3985937,1037580,
4304843,1307052,4623750,1619555,4942578,1978275,
5261484,2386402,5580390,2847120,5899218,3363620,
6218125,3939087,6536953,4576709,6855859,5279674,
7174765,6051169,7493593,6894382,7812500,7812500
];
// For CoE 0x8000 and 0x8005 - write values:
// ===============================================
wCoEIndexScaler :WORD := 16#8005; // CoE Index
wState :BYTE := 0; // Write status
fb_coe_write :FB_EcCoESdoWrite; // Function Block for writing in CoE
userNetId :T_AmsNetId := '172.128.1.1.5.1'; // Have to be entered
userSlaveAddr :UINT := 1001 // Have to be entered
index :BYTE:=0; // LUT-Table index
startWrite :BOOL:=FALSE; // Sign for start writing
END_VAR
Anmerkungen:
▪
Die Variable „startWrite“ (BOOL) wird bereits in Beispielprogramm 4 ebenfalls deklariert.
▪
Die Variable ‚userNetId‘ muss die Geräte-EtherCAT-Netz ID enthalten. Diese ist über den Karteireiter „EtherCAT“ bei Auswahl von „Device (EtherCAT)“ einsehbar.
▪
Die Variable „userSlaveAddr” muss die Klemmen-EtherCAT-Adresse enthalten.
Beispielprogramm zur Übertragung der LookUp-Tabelle:
Ausführungsteil:
// Example program 3:
// ###### Write LookUüp-Table in CoE Objekt 0x8005: #######
IF startWrite THEN
CASE wState OF
0:
fb_coe_write(bExecute := FALSE);// Prepare CoE-Access
wState := wState + 1;// Next state
1:
// Write 100 X/Y LookUp-Table entries
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= index+1,
nIndex:= wCoEIndexScaler,
pSrcBuf:= ADR(aLUT[index]),
cbBufLen:= SIZEOF(aLUT[index]),
bExecute:= TRUE,
tTimeout:= T#1S
);
wState := wState + 1; // Next state
2:
// Proceed with writing to CoE
fb_coe_write();
IF fb_coe_write.bError THEN
wState := 100; // Error case
ELSE
IF NOT fb_coe_write.bBusy THEN
index := index + 1;
IF index < 100 THEN
// Prepare next CoE access
fb_coe_write(bExecute := FALSE);
wState := 1;// Write next value
ELSE
wState := 200;// Done
startWrite := FALSE;
END_IF
END_IF
END_IF
100:
; // Error handling..
200:
; // Continue...
END_CASE
END_IF
Durch eine einfache Variablen-Abfrage z.B. von einem Taster, der mit bEnable verknüpft ist kann die Übertragung in Gang gesetzt werden. Dafür ist die Variablendeklaration:
VAR_INPUT
bEnable AT%I* :BOOL;
END_VAR
sowie die folgenden Programmzeilen erforderlich:
IF bEnable AND NOT startWrite THEN
startWrite := TRUE;
END_IF


Beispielprogramm 4 (LookUp-Tabelle erzeugen)

Anhang [image] Beispielprogramme [image] Beispielprogramm 4 (LookUp-Tabelle erzeugen)
Beispielprogramm 4 (LookUp-Tabelle erzeugen)
Download TwinCAT 3 Projekt:
Programmbeschreibung/ Funktion:
Aufnahme von LookUp-Tabellenstützwerten aus einem Eingangssignal der Klemme in eine Feldvariable (und wahlweise anschließender Übertragung der LookUp-Tabellenstützwerte per CoE‑Zugiff in die Klemme mittels Beispielprogramm 3).
Variablendeklaration Beispielprogramm 4
// Variablendeklaration for example program 4
VAR_INPUT
bEnable AT%I* :BOOL;
PAI_Sample AT%I* :DINT; // The linked Variable to the EL3751 Result
END_VAR
VAR
//--------------Already existing? ---------------
// startWrite :BOOL:=FALSE;
//-------------------------------------------------
LUTindex :BYTE:=0; //LUT recording index
timer :tp; // A timer instance
startRecord :BOOL:=FALSE;
aValues :ARRAY[0..49] OF DINT;
nXstartValue :DINT;
nXstepValue :DINT;
CopyLUT :BOOL:=FALSE;
// Value of -2.21 mA by direct measurement:
nTriggerValue :DINT:=-2210000;
END_VAR
Ausführungsteil:
// Example program 4:
// ################# Recording of 50 sample points: #################
IF timer.Q THEN
timer();
ELSE
timer(IN:=FALSE);
timer(IN:=TRUE, PT:=T#200MS); // Timer-value 200ms for 0,1Hz ramp
IF startRecord THEN
IF LUTindex < 50 THEN
aValues[LUTindex] := PAI_Samples_1;
LUTindex := LUTindex + 1;
ELSE
nXstartValue := aValues[0];// Start value
nXstepValue := LREAL_TO_DINT(ABS(aValues[49]-nXstartValue) / 49); // Calculating step
startRecord := FALSE;// Stop recording
CopyLUT := TRUE;// Prepare incurring into LUT
END_IF
END_IF
END_IF
IF CopyLUT THEN
// Create LUT with X-Values by recording and equidistant Y-Values:
FOR index := 0 TO 49 DO
// Create LUT X => target values, Y => current values:
// (Initialwerte werden überschrieben)
LUTindex := REAL_TO_BYTE(index*2);
aLUT[LUTindex] := aValues[index];// X-Values
aLUT[LUTindex+1] := nXstartValue;// Y-Values
// Generate next equidistant sample point
nXstartValue := nXstartValue + nXstepValue;
END_FOR
index := 0; // Initialize LUT transmission
startWrite := TRUE;// Start transfer to LUT (see example program 3)
CopyLUT := FALSE;
END_IF
// Condition to start recording (a trigger minimum value):
IF ((PAI_Sample < nTriggerValue) AND (startWrite = FALSE)) THEN
startRecord := TRUE;
END_IF


Beispielprogramm 5 (Filterkoeffizienten schreiben)

Anhang [image] Beispielprogramme [image] Beispielprogramm 5 (Filterkoeffizienten schreiben)
Beispielprogramm 5 (Filterkoeffizienten schreiben)
Download TwinCAT 3 Projekt:
Programmbeschreibung/ Funktion
Übertragung von exemplarischen Filterkoeffizienten per CoE‑Zugriff in die Klemme.
Allgemeine Einstellungen
•
Der Funktionsblock „FB_EcCoESdoWrite“ benötigt die „Tc2_EtherCAT“ Bibliothek
•
<AmsNetId> muss die Lokale Device – EtherCAT NetId in Hochkomma eingetragen haben (z.B. '168.57.1.1.5.1')
•
<DeviceEtherCATAddress> muss die Lokale Device – EtherCAT Adresse der Klemme eingetragen haben (z.B. 1007dez)
Variablendeklaration Beispielprogramm 5
PROGRAM MAIN
// Variable declaration example program 5
VAR CONSTANT
NumOfFilterCoeff :BYTE:=40;
END_VAR
VAR
// Function block of library "Tc2_EtherCAT" for CoE Object access:
fb_coe_write :FB_EcCoESdoWrite;
userNetId :T_AmsNetId := '???';
userSlaveAddr :UINT := ???;
// Writing PLC state for coefficients transfer (Set to 0 for start)
wState :BYTE:=255;
index :BYTE:=1; // Index for coefficients transfer
wCoEIndexUserFilterCoeffizents :WORD:=16#8001;
aFilterCoeffs:ARRAY[0..NumOfFilterCoeff] OF LREAL :=
[
// Example filter coefficients FIR band pass: 3600..3900 Hz
// Usage: "User defined FIR Filter" (32)
0.03663651655662163,
0.04299467480848277,
-0.007880289104928245,
0.0664029021294729,
-0.0729038234874446,
-0.00005849791174519834,
0.05628409460964408,
-0.0525134329294473,
0.026329003448584205,
0.00027114381194760643,
-0.03677629552114248,
0.06743018479714939,
-0.0560894442193289,
0.0009722394088121363,
0.05676876756757213,
-0.07775650809213645,
0.05330627422911416,
0.0009941073749156226,
-0.055674804078696793,
0.07874009379691002,
-0.055674804078696793,
0.0009941073749156226,
0.05330627422911416,
-0.07775650809213645,
0.05676876756757213,
0.0009722394088121363,
-0.0560894442193289,
0.06743018479714939,
-0.03677629552114248,
0.00027114381194760643,
0.026329003448584205,
-0.0525134329294473,
0.05628409460964408,
-0.00005849791174519834,
-0.0729038234874446,
0.0664029021294729,
-0.007880289104928245,
0.04299467480848277,
0.03663651655662163,
0
];
nValue :DINT; // Temporary variable
END_VAR
Ausführungsteil:
// Example program 5:
// writes filter coefficients of
// "User defined FIR Filter" (32)
// incl. example coefficients for band pass
// Note: writing possible, if CoE Object
// PAI Settings Ch.1 (0x8000:16) has value 32 or 33 set, only!
// (32 = User defined FIR Filter / 33 = User defined IIR Filter)
// ===============================================================
CASE wState OF
0:
fb_coe_write(bExecute := FALSE);// Prepare CoE access
wState := wState + 1;// Go to next state
1:
//nValue := REAL_TO_DINT(DINT_TO_REAL(aFilterCoeffs[index]) *16384);
nValue := LREAL_TO_DINT(aFilterCoeffs[index] * 1073741824); // Bit-shift factor: 2^30
// Write filter coefficients (max. 40 entries)
fb_coe_write(
sNetId:= userNetId,
nSlaveAddr:= userSlaveAddr,
nSubIndex:= index,
nIndex:= wCoEIndexUserFilterCoeffizents,
pSrcBuf:= ADR(nValue),
cbBufLen:= SIZEOF(nValue),
bExecute:= TRUE,
tTimeout:= T#1S
);
wState := wState + 1; // Go to next state
2:
// Execute writing to CoE
fb_coe_write();
IF fb_coe_write.bError THEN
wState := 100; // Error case
ELSE
IF NOT fb_coe_write.bBusy THEN
index := index + 1;
IF index <= (NumOfFilterCoeff) THEN
fb_coe_write(bExecute := FALSE);// Prepare the next CoE access
wState := 1;// Write next value
ELSE
wState := 255;// Done
END_IF
END_IF
END_IF
100:
; // Error handling
255:
; // Go on..
END_CASE


Beispielprogramm 6 (Verschränken von Messwerten)

Anhang [image] Beispielprogramme [image] Beispielprogramm 6 (Verschränken von Messwerten)
Beispielprogramm 6 (Verschränken von Messwerten)
Programmbeschreibung/ Funktion
Dieses Beispiel zeigt die Verwendung zweier Multifunktionseingangsklemmen mit zusammengeschalteten Eingängen, deren Eingangsmesswerte von der PLC abwechselnd eingelesen werden, um eine Verdopplung der maximalen Samplingrate einer Klemme zu erzielen. Hierfür wird folgender Aufbau verwendet:
Konfiguration und Aufbau zum Beispielprogramm 6: Verdopplung der Samplingrate mit 2 x EL3751
Das Beispiel ist mit entsprechenden Anpassungen für die ELM3xxx Klemmen ebenfalls anwendbar (z.B. 2 x ELM3002). Lediglich die optional vorhandene Task mit 50 µs im Beispiel 6a kann u.U. nicht zum Einsatz kommen.
Damit die Eingangswerte nacheinander zu einem Gesamtwert zusammengesetzt werden können, ist für jeden separaten Abtastwert eine entsprechende Verschiebungszeit notwendig; in diesem Beispiel für die zweite Klemme 50 µs. Diese wird in den „Erweiterten Einstellungen“ zu DistributedClocks (Karteireiter „DC“) der Klemme vorgenommen:
Einstellung der DC-Verschiebungszeit für Klemme 2
Diese genannte Einstellung, wie auch die Basiszeit und die Taskzykluszeit ist bereits in dem Beispielprogramm konfiguriert:
Download TwinCAT 3 Projekt/ Beispielprogramm 6a:
Weiter Erläuterungen
Die eingelesenen Messwerte liegen der PLC (i.d.R.) als eine Feldvariable bzw. als ein für Oversampling taugliches Datenformat vor (Gesamtmesswert):
Vorgang der Verschränkung der Eingangsdaten
Im Folgenden ist zunächst mit Oversampling = 1 für jeden Eingangswert die einfachste Variante der Verschränkung der Eingangswerte in „strukturierten Text“ gezeigt: eine Feldvariable mit zwei Elementen erhält je einen Wert von einer Klemme. Diese kann zur Weiterverarbeitung verwendet werden und wird hier im TwinCAT ScopeView dargestellt. Die Programmanweisungen sind bei der EL3751 einer 100 µs Task zugeordnet:
Variablendeklaration Beispielprogramm 6a
PROGRAM MAIN
VAR
nSamples_1 AT%I* :DINT; // EL3751 input with no added shift time
nSamples_2 AT%I* :DINT; // EL3751 input with -50 µs added shift time
aCollectedResult :ARRAY[0..1] OF DINT;
END_VAR
Ausführungsteil:
// Example program 6a:
// 100 µs task
// ============================================================
aCollectedResult[0] := nSamples_1; // Put 1st Value of sequence into array
// Pattern: 1.1.1.1...
aCollectedResult[1] := nSamples_2; // Put n-th Value of sequence into array (2nd here)
// Pattern: .2.2.2.2...
// ============================================================
// Result pattern: 12121212... (--> see scope view dots)
Bei einem Eingangssignal z.B. Sinus 5 kHz und 2,5 V Amplitude liefert das TwinCAT‑ScopeView folgende Ergebnisse:
Oversampling 20 KSps mit 2 x EL3751 mit Eingangssignalen (unten) und Ergebnissignal (oben)
Die obere Abbildung zeigt das Gesamtsignal und die beiden Eingangssignale (nSample_1, nSample_2), um 50 µs zueinander Zeitversetzt innerhalb von 18 s in gestauchter Form. Das Gesamteingangssignal (nCollectedResult) zeigt hier im groben die Verschränkung der beiden Eingangssignale.
Nachfolgend ist dargestellt (mit Markierungen grafisch nachbearbeitet), wie die Eingangssignale (nSample_1, nSample_2) an der Konstruktion des Gesamteingangssignals beteiligt sind:
Oversampling 20 KSps mit 2 x EL3751 zeigt abwechselnd den Eingangswert 1 und Eingangswert 2 für je einen Ergebniswert
Unter bestimmten Voraussetzungen können zudem in einer entsprechend schnellen Task beide Eingänge auf eine einzelne Variable zusammengefasst werden. Das Beispielprogramm enthält hierfür noch eine zusätzliche Task mit 50 µs Zykluszeit, die zum einen für die Darstellung der Eingangssignale im SopeView benötigt wird und zum anderen auch eine Variable (nCollected) enthält, die beide Eingänge abwechselnd zugewiesen bekommt:
// 50 µs task
// ============================================================
// Junction of the two inputs
nCollected := SEL(nToggle, MAIN.nSamples_1_, MAIN.nSamples_2_);
nToggle := NOT nToggle;
Die für das ScopeView erforderlichen Variablen der Eingänge werden in dieser Task aus der 100 µs Task ausgelesen, um die einzelnen Werte im 50 µs Abstand darstellen zu lassen.
Variante mit 2 x Oversampling 10 = Oversampling 20
Wird beispielsweise ein Oversampling‑Faktor von 10 für beide Eingangsklemmen verwendet, wird für den Gesamtmesswert eine Feldvariable das so kann die Verschränkung der Eingangswerte durch eine einfache Programmschleife erfolgen, die die Werte nacheinander in eine Feldvariable für die resultierende Ergebnisvariable einliest:
Variablendeklaration Beispielprogramm 6b
PROGRAM MAIN
VAR
aSamples_1 AT%I* :ARRAY[0..9] OF DINT; // EL3751 input with no added shift time
aSamples_2 AT%I* :ARRAY[0..9] OF DINT; // EL3751 input with -50 µs added shift time
aCollectedResult :ARRAY[0..19] OF DINT;
// ===================================================
nPos :BYTE;
END_VAR
Ausführungsteil:
// Example program 6b:
// 1 ms task
// ============================================================
FOR nPos := 0 TO 9 DO
// Put 1st Value of sequence into array:
aCollectedResult[2*nPos] := aSamples_1[nPos];
// Put n-th value of sequence into array (2nd here):
aCollectedResult[2*nPos+1] := aSamples_2[nPos];
END_FOR
Download TwinCAT 3 Projekt/ Beispielprogramm 6b:
Das Beispielprogramm 6b liefert das gleiche Ergebnis, nur liegt hier das Gesamteingangssignal lediglich in Form einer Feldvariablen mit 20 Elementen vor.
Eingangsdämpfung einer Klemme
Aufgrund der weiterhin bestehenden Eingangsfilterung einer Klemme (Anti‑Aliasing‑Filter) ist bei einem Eingangssignal, das Frequenzanteile um 10 kHz enthält, nicht das gewünschte Ergebnis zu erwarten, da die Eingangswerte einer Klemme in diesem Frequenzbereich nur stark gedämpft vorliegen werden.
Verschränken der Eingangswerte: Offsetunterschiede der Klemmen beachten
Vor einer möglichen Anwendung sollten die eingesetzten Klemmen u.a. insgesamt einem Offsetabgleich unterzogen werden, damit das Resultat möglichst wenig Verzerrung des Eingangssignals beinhaltet.


Beispielprogramm 7 (Allgemeine Dezimierung in der PLC)

Anhang [image] Beispielprogramme [image] Beispielprogramm 7 (Allgemeine Dezimierung in der PLC)
Beispielprogramm 7 (Allgemeine Dezimierung in der PLC)
Die EL3751 bzw. ELM3xxx können eine Dezimierung ihrer Basisabtastrate fmax nur durch ganzzahlige Vielfache durchführen, siehe dazu das Kapitel „Dezimierung“. Um auch beliebige andere Abtastraten fZiel < fmax für einen Kanal zu realisieren, kann beispielsweise wie folgt vorgegangen werden:
▪
Klemme/Kanal mit maximaler Abtastrate betreiben und die Daten über EtherCAT/Oversampling in die Steuerung (PLC) übertragen
▪
Dort in der PLC/C++ auf der Zeitachse in die gewünschte Abtastrate umrechnen, z.B. mittels linearer Interpolation auf Basis der Zeitstempel je Eingangswert (Sample). Da die EL3751/ELM3xxx auf DistributedClocks-basierend zeit-äquidistante Samples liefern, ist das einfach möglich.
Folgende Abbildung zeigt einen Ausschnitt eines mit 50/44,1 = 1/0,882 dezimiertes sinusförmigen Signals:
–
Grün: entspricht Original- Eingangssignal analog, ca. 432 Hz
–
Blau (O): entspricht Abtastung der EL3751/ELM3xxx mit fmax = 10.000 Sps bzw. einem Abtastintervall von 100 µs
–
Rot (X): entspricht in PLC umgerechnetes Signal auf 8820 Sps (Faktor 0,882) und damit ein Zeitintervall von ca. 113,37.. µs
▪
Hinweis: Der Begriff „Dezimierung“ wird hier sowohl angewendet auf die Rechnung in der Klemme (siehe dazu das Kapitel „Dezimierung“) als auch auf die Umrechnung im PLC-Programm. Im Folgenden ist dabei die Umrechnung in der PLC gemeint.
▪
Da hierbei das Zeitintervall der angestrebten Abtastung nach der Dezimierung in PLC i.d.R. keine ganze (endliche) Zahl mehr ist, wird für die Darstellung im PLC/Scope Wert/Zeit-Paare verwendet, d.h. jedem Y-Wert ist ein X-Zeitwert zugeordnet. Solche Wert/Zeit-Paare lassen sich mit dem TwinCAT ScopeView im XY-Modus einfach darstellen. Siehe hierzu auch unter infosys.beckhoff.com:
TwinCAT3 → TExxxx | TC3 Engineering → TE13xx | TC3 ScopeView → Konfiguration → XY‑Graph
▪
Außerdem hat die Umrechnung Folgen für die Weiterverarbeitung in PLC/C/ADS:
–
Üblicherweise ist ein PLC/EtherCAT/TwinCAT-System so eingestellt dass je Zyklus eine konstante Anzahl Samples verarbeitet wird – das ist nun i.d.R. nicht mehr der Fall: es kommt von Zyklus zu Zyklus zu einer unterschiedlicher Anzahl Samples die zu verarbeiten sind (Angabe durch die Programmvariable nResultNoOfSamples).
–
Blieb ein Zeitstempel pro Signalwert bisher relativ bedeutungslos, so führt jedoch die hier angewandte Art der Umsetzung des Dezimierungsvorgangs dazu, dass der jeweilige Zeitstempel pro Signalwert elementar zu beachten ist.
▪
Die nicht konstante Anzahl von Samples wird vom TwinCAT XY‑Scope nicht sichtbar, weil hier einige Werte sporadisch doppelt gezeichnet werden, ist jedoch zu bedenken; ggf. wäre für die programmatische Weiterverarbeitung die Verwendung eines Zwischenpuffers zu empfehlen.
▪
Zur Orientierung der aktuell gültigen Sample-Zahl pro Taskzyklus stellt das Programm die Variable nResultNoOfSamples zur Verfügung, die angibt, welche Werte in der Arrayvariable gültige Werte in einem Taskzyklus enthalten (gibt die Feldnummer - 1 an).
Im Folgenden dient das Beispielprogramm als Orientierungshilfe, das auch die XY-Darstellung im TwinCAT Scope enthält. Wegen der o.a. Problematik der nicht konstant vorhandenen Anzahl gültiger Abtastwerte liefert das Programm für das Scope das Array-Paar aVarDecResult_TS und aVarDecResult mit der gleichen Anzahl von Elementen wie für den Eingangswert aSamples_1(Wert = nOVS ). Kommt es in einem Taskdurchlauf zu weniger Werten, wird der letzte Wert einfach wiederholt eingetragen (entspricht etwa „sample & hold“). Für die Aufzeichnung wurde das ScopeView wie folgt konfiguriert:
Eigenschaft |  | Wert
ScopeNodeProperties | ViewDetauilLevel | ExtendedXYOnly
 | Record time | 00:00:00:05
ChartXYNodeProperties | Default Display Width | 0,00:00:00,050:000
 | Max Data Points | 200000
XYChannelNodeProperties | Marks | On
 | Mark Size | 5
 | Mark Color | (andere Farbe als „Line Color“)
Für eine veranschaulichende Darstellung wurde zunächst die Aufzeichnung des ScopeView gestartet und dann das Programm, das auf eine Sekunde begrenzt die Dezimierten Werte lieferte:
IF nOVS_CycleCount = 1000000000 THEN
;
bEnable := FALSE;// Stop after 1s just for recording
ELSE
...
Diese Zeile kann selbstverständlich für weitere Anpassungen auskommentiert werden:
//bEnable := FALSE;// Stop after 1s just for recording
Hinweise:
▪
die Zielabtastrate fZiel sollte in der Nähe der Samplerate fmax liegen, so dass es über die Implementierung möglich ist, ein Zeitintervall zwischen zwei dezimierten Werten auch auszuwerten. Die gewünschte Dezimierung erfordert u.U. eine Anpassung weiterer Parameter wie Taskzykluszeit, Oversamplingfaktor, etc. sowohl in der Konfiguration als auch als Variableninitialisierung im Beispielprogramm (siehe Abbildung „Vorgang der variablen Dezimierung des Beispielprogramms“ zur Funktionsweise des Programcodes).
▪
Grundsätzlich werden durch den Konvertierungsvorgang in diesem Beispielprogramm bei einer Dezimierung mit gebrochenen rationalen Faktoren Verzerrungen im Ergebnis in Bezug zur ursprünglichen Signalform verursacht (siehe Signalverlauf). Konkret entstehen Abweichungen vom originalen Signalverlauf nur in den Abschnitten, wo der zeitliche Ableitungswert (die Steigung) nicht konstant ist. Z.B. werden Eingangswerte eines Sinussignals in den nicht-linearen Bereichen durch die im Programm vorgenommene Interpolation verzerrt:
Im Frequenzspektrum wird dies z.B. durch eine Berechnung mit 20 Hz Sinussignal, abgetastet mit 500 Sps und dezimiert auf 441 Sps wie folgt anschaulich:
▪
Wenn auf dem Datenstrom keine der fZiel entsprechenden Tiefpassfilterung vorgenommen wird, wird es zu Aliasing-Effekten kommen! Es ist deshalb ratsam z.B. mit der TC3 Controller Toolbox oder der TC3 Filter Lib in der PLC eine Tiefpassfilterung vorzunehmen, bevor die Umrechung/Dezimierung vorgenommen wird. Entsprechende Filter können einfach mit dem TE1310 FilterDesigner erstellt werden. Siehe hierzu unter www.beckhoff.de:
Automation → TwinCAT 3 → TE1xxx | TC3 Engineering → TE1310 | TC3 Filter Designer
Alternativ können natürlich auch die in den EL3751/ELM3xxx verfügbaren Filter schon auf die passende Tiefpass-Frequenz gesetzt werden, auch dazu ist der TwinCAT Filter Designer hilfreich.
▪
Einträge des Dezimierungsfaktors im Programm (nDecimationValue) sollten einen Wert > 1 haben. Der Programmcode unterstützt lediglich das „downsampling“.
Beispiel: Stellt eine Klemme wie ELM3602‑0002 (2-Kanal-IEPE-Auswertung) einen Datenstrom mit Oversampling von 50 kSps bei 100µs Zykluszeit zur Verfügung, so kann dieser Beispielcode eine Dezimierung auf 44,1 kSps vornehmen. Im Beispielprogramm wären dazu die Zyklusticks in der Taskkonfiguration von 5 auf 1 sowie die entsprechende Programmvariable nTaskCycle_ns von 500000 auf 100000 zu ändern. Siehe folgenden Bildausschnitt des ScopeView XY:
Dezimierung von 20 µs (links) auf 22,675.. µs (rechts) mit ELM3602
Der Dezimierungsfaktor ist durch Eintrag des Wertes „50/44.1“ für nDecimationValue im Beispiel vorgegeben. Wird dieses Beispiel für die EL3751 mit 500 µs Zykluszeit und 5x Oversampling verwendet, wird das Abtastintervall von 100 µs, das von der EL3751 kommt, zu ca. 113,378.. µs umgerechnet. Dementsprechend ist dieses Beispiel ausgelegt.
Die Dezimierung im Programm ist frei wählbar und muss mit Oversamplingfaktor und Taskzykluszeit abgestimmt konfiguriert sein. Die Variable nOVS muss den gleichen Oversamplingfaktor enthalten, wie dieser über die Prozessdatenkonfiguration eingestellt ist.
Download Beispielprogramm 7:
▪
Konfiguration: IPC + EK1100 + EL3751 + EL9011:
▪
Konfiguration: IPC + EK1100 + ELM3602‑0002 + EL9011:
Allgemeiner Hinweis
Der Zeitpunkt der Passage der EtherCAT Frames an der Klemme unterliegt Schwankungen, dem EtherCAT‑Frame-Jitter. Falls diese Schwankungen groß im Verhältnis zur Zykluszeit sind, werden u.U. Daten verspätet von der Klemme abgeholt, es kommt in der Scope-Darstellung zu Aussetzern/Dopplungen. Mit der TwinCAT EtherCAT Diagnose können solche Effekte diagnostiziert werden. In dem Beispielprogramm zur ELM3602 steht zu dieser Kontrolle die Variable nEqualTimeStampsCnt zur Verfügung, die inkrementiert wird, falls ein solcher Ausfall auftritt. Abhilfe schafft die Veränderung der DC ShiftTime der Klemme, siehe dazu die EtherCAT Systemdokumentation.
Deklarationsteil
// THIS CODE IS ONLY AN EXAMPLE - YOU HAVE TO CHECK APTITUDE FOR YOUR APPLICATION
PROGRAM MAIN
VAR CONSTANT
// User decimation factor e.g. 50 to 44.1 kSps:
nDecimationValue :LREAL := 50/44.1; // 50/20;
nOVS :BYTE := 5; // Oversampling factor
nTaskCycle_ns :UDINT := 500000; // PlcTask configured cycle time in ns
nOVSTimeInterval_ns :UDINT := LREAL_TO_UDINT(nTaskCycle_ns/nOVS); // OVS interval
nDecTimeInterval_ns :LREAL := nDecimationValue * nOVSTimeInterval_ns; // Decimation interval
END_VAR
VAR
aSamples_1 AT%I* :ARRAY[0..nOVS-1] OF DINT; // Link to the terminal PDO
aOVS_SampleSets :ARRAY[0..(2*nOVS)-1] OF DINT; // 2 OVS sample sets
nVarDecResult :DINT; // The calculated interpolated value
tVarDecResult :LREAL; // Decimation timestamp
aVarDecResult :ARRAY[0..nOVS-1] OF DINT; // Decimation result values
aVarDecResult_TS :ARRAY[0..nOVS-1] OF LREAL; // Decimation result timestamps
nResultNoOfSamples :BYTE; // This is for the user for further processing
nDivVar :INT; // Value for selection of the target input element
tDecVar_InTaskCycle :LREAL:=0; // Time span for all decimation timestamps within a task cycle
i :BYTE:=0; // Common loop counter
nDX :LREAL; // X-Difference: target input element to decimation element
nDY :DINT; // Y-Difference: two values for interpolation
sVal :LREAL; // Slope for calculation of new value
bEnable :BOOL:=FALSE; // Start/Stop conversion to decimation values
nOVS_CycleCount :ULINT := 0; // Time value for every OVS sample
// Values for testing
bTEST_VALUES_ENABLED :BOOL := FALSE; // No input value needed, if TRUE
nPhi :LREAL := 1.4; // Start angle for sinus simulation
// For visualization only:
aOVS_Samples :ARRAY[0..nOVS-1] OF DINT; // 2 OVS sample sets (value)
aOVS_Samples_TS :ARRAY[0..nOVS-1] OF ULINT; // 2 OVS sample sets (timestamp)
END_VAR
Ausführungsteil
// 500 µs Task
FOR i:= 0 TO nOVS-1 DO
// Shift OVS set to left and update on right:
aOVS_SampleSets[i] := aOVS_SampleSets[i+nOVS]; // Transfer "samples set" to the left side
IF bTEST_VALUES_ENABLED THEN
// Simulate values:
aOVS_SampleSets[i+nOVS] := LREAL_TO_DINT(1000000 * SIN(nPhi));
nPhi := nPhi + 0.01;//0.003141592653;
ELSE
// Fill current new samples set on right:
aOVS_SampleSets[i+nOVS] := aSamples_1[i];
END_IF
END_FOR
IF bEnable THEN
nResultNoOfSamples := 0; // Use for further processing
FOR i := 0 TO nOVS-1 DO
nDivVar := TRUNC_INT(tDecVar_InTaskCycle/nOVSTimeInterval_ns);
// Check, if new value is in grid
IF (nDivVar = i) THEN
nResultNoOfSamples := nResultNoOfSamples + 1;
// Calc slope by the left and right element values (dy/dx):
nDY := aOVS_SampleSets[i+1] - aOVS_SampleSets[i];
sVal := DINT_TO_LREAL(nDY)/nOVSTimeInterval_ns;
// Get the time (difference) from the left side element start to the desired time point:
nDX := tDecVar_InTaskCycle
- TRUNC_INT(tDecVar_InTaskCycle/nOVSTimeInterval_ns)
* UDINT_TO_LREAL(nOVSTimeInterval_ns);
// Calc timestamp
tVarDecResult := nDX + ULINT_TO_LREAL(nOVS_CycleCount);
// Calc new value:
nVarDecResult :=
LREAL_TO_DINT(DINT_TO_LREAL(aOVS_SampleSets[i]) + sVal * nDX);
// next decimation time step
tDecVar_InTaskCycle := tDecVar_InTaskCycle + nDecTimeInterval_ns;
tDecVar_InTaskCycle := tDecVar_InTaskCycle
- INT_TO_UDINT(TRUNC_INT(tDecVar_InTaskCycle/nTaskCycle_ns))
* nTaskCycle_ns;
END_IF
// Fill timestamp and new value allocated to the field element of its timestamp
aVarDecResult_TS[i] := tVarDecResult;
aVarDecResult[i] := nVarDecResult;
// For visualization of the original input:
aOVS_Samples[i] := aOVS_SampleSets[i];
aOVS_Samples_TS[i] := nOVS_CycleCount;
// Count the task cycle timestamp
nOVS_CycleCount := nOVS_CycleCount + nOVSTimeInterval_ns;
END_FOR
END_IF
IF nOVS_CycleCount = 1000000000 THEN
bEnable := FALSE;// Stop after 1s just for recording
IF NOT bEnable THEN
bEnable := TRUE; // OVS‑Samples transferred complete into both array sets
END_IF
END_IF


Beispielprogramm 8 (FB zur Echtzeit Diagnose)

Anhang [image] Beispielprogramme [image] Beispielprogramm 8 (FB zur Echtzeit Diagnose)
Beispielprogramm 8 (FB zur Echtzeit Diagnose)
Folgender Funktionsblock kann als Vorlage zur Anwendung der Echtzeit Diagnose einer EtherCAT Analog-Eingangsklemme in TwinCAT SPS verwendet werden. Er wird in der SPS zwischen die Klemme und der Applikation gesetzt und wertet in Echtzeit die von der Klemme kommenden Diagnosevariablen aus, die Messwerte werden unverändert durchgeleitet.
Der Funktionsblock ist für eine ELM3602-0002 mit Oversampling=5 geschrieben und ist als funktionales Beispiel zu verstehen und muss ggf. angepasst werden an
▪
andere Klemmen, ggf. andere Value-Datentypen und andere Diagnosedaten
▪
andere Oversamplingwerte
Ebenso kann er um datenbearbeitenden Code oder weitere eigenen Diagnosen erweitert werden oder auf einen ganz anderen Klemmentyp (Analogausgang EL4xxx, Encoder EL5xxx, …) umgeschrieben werden.
Der Funktionsblock zwischen der Klemme und der SPS stellt sich schematisch wie folgt dar:
Funktionsblock als Beispiel zur Auswertung von Diagnoseinformationen der Klemme
Dieser Funktionsblock müsste mit allen Variablen der Klemme verknüpft werden: Eingänge, Ausgänge und Info-Daten. Dieser zeitintensive Vorgang kann durch Struktur-Verknüpfung in TwinCAT 3 vereinfacht und beschleunigt werden. Daher werden in diesem Kapitel zwei alternative Varianten in TwinCAT 3.1 dargelegt, wie mit wenigen Klicks eine Struktur in der SPS definiert werden kann, die dem Prozessabbild der Klemme entspricht.
Die entsprechende Variante des Funktionsblocks FB_REALTIME_DIAGNOSIS ist in den beiden Beispielprogrammen enthalten. Er enthält PDO‑Variablen mit einem anwendungsspezifischen Datentyp. Dabei handelt es sich um eine von TwinCAT 3 erzeugte Struktur. Dadurch, dass durch die von TwinCAT generierte Struktur direkt die PDO Struktur der Klemme abbildet, ist es nicht nötig, dass eine passende Struktur aufwendig erstellt werden muss oder einzelne Variablen mit einzelnen Datentypen verknüpft werden müssen. Lediglich eine Verknüpfung auf höherer Ebene (Status, Samples, Control,...) ist erforderlich.
Dies sowie sämtliche Konfigurationen sind bereits in dem jeweiligen Beispielprogramm enthalten.
▪
Beispielprogramm (Variante A – Verwendung der Plc‑Einstellungen der Klemme):
▪
Beispielprogramm (Variante B – Verwendung der erweiterten Einstellungen der Klemme):
Hinweise zum Beispielprogramm (Variante A):
die Variablendeklaration des Funktionsblocks FB_REALTIME_DIAGNOSIS enthält:
stELM3602Special : MDP5001_350_EB559ACD;
Vorgesehen ist der Lesezugriff auf die Eingänge der Klemme über die Substruktur MDP5001_350_Input und der Schreibzugriff auf die Ausgänge über die Substruktur MDP5001_350_Output der Struktur stELM3602Special.
Allgemein wird die Erzeugung dieses besonderen PDO‑Datentyps über die SPS‑Einstellungen der Klemme aktiviert (Karteireiter „Plc“): dort wird das Kontrollkästchen „Create SPS Data Type“ und dann „Per Channel“ gesetzt („Copy“ überträgt diese Zeichenkette dann in die Ablage):
Erstellung der PDO Variablen (TwinCAT‑Version >= V3.1.4024.0)
Die Adresszuweisungen für die Eingänge (%ATI*) und Ausgänge (%ATQ*) befinden sich bereits innerhalb dieser generierten Struktur. Eingänge und Ausgänge sind demnach in dieser Struktur zusammengefasst.
Hinweise zum Beispielprogramm (Variante B):
die Variablendeklaration des Funktionsblocks FB_REALTIME_DIAGNOSIS enthält:
st_SM2 AT%Q* : ECAT_ELM3602_0002_SM_3412CB6A;
st_SM3 AT%I* : ECAT_ELM3602_0002_SM_87A01A51;
Vorgesehen ist der Lesezugriff auf die Eingänge der Klemme über die Struktur st_SM3 und der Schreibzugriff auf die Ausgänge über die Struktur st_SM2. Diese Datenstruktur entspricht dem automatisch ergänzten neuen PDO‑Element „SmPdoVariables“.
Allgemein wird die Erzeugung dieser besonderen PDO‑Datentypen inkl. des PDO‑Elementes über die EtherCAT Einstellungen der Klemme aktiviert: in den Erweiterten Einstellungen ist unter „Allgemein“/ „Verhalten“ bei „Prozessdaten“ das Kontrollkästchen „Create SM/PDO Variables“ zu setzen:
Create SM_PDO vars.png
Erstellung der SmPdoVariables (TwinCAT‑Version >= V3.1.4022.30)
Der Datentyp wird durch Auswahl des PDO sichtbar und kann dort in die Ablage kopiert werden:
Ermitteln des generierten Datentyps von SmPdoVariables


Diagnose - Grundlagen zu Diag Messages

Anhang [image] Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons ist selbsterklärend.
DiagMessages im ADS Logger/Eventlogger
Ab TwinCAT 3.1 build 4022 werden von einer Klemme abgesetzte DiagMessages auch im TwinCAT ADS Logger gezeigt. Da nun IO-übergreifend DiagMessages an einem Ort dargestellt werden, vereinfacht dies die Inbetriebnahme. Außerdem kann die Logger-Ausgabe in eine Datei gespeichert werden – somit stehen die DiagMessages auch langfristig für Analysen zur Verfügung.
Nachrichten in die PLC einlesen
- In Vorbereitung -
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13
Übersicht Text-IDs
Spezifische Text-IDs sind in der Gerätedokumentation aufgeführt.
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x0001 | Information | System | No error | Kein Fehler
0x0002 | Information | System | Communication established | Verbindung aufgebaut
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | Allgemein | Detection of operation mode completed: 0x%X, %d | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein | Cycle time o.k.: %d | Zykluszeit o.k.
0x1157 | Information | Allgemein | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Daten manuell gespeichert
0x1158 | Information | Allgemein | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Daten automatisch gespeichert
0x1159 | Information | Allgemein | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Daten gelöscht
0x117F | Information | Allgemein | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde
0x1300 | Information | Encoder | Position set: %d, %d | Position gesetzt - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder Netzteil OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder Initialisierung erfolgreich abgeschlossen
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Sende Kommando Encoder Reset
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Antrieb ist kalibriert
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Aktueller Status des Antriebs
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Prozessorauslastung ist wieder im normalen Bereich
0x1706 | Information |  | Channel is not in saturation anymore | Kanal ist nicht mehr in Sättigung
0x1707 | Information |  | Channel is not in overload anymore | Kanal ist nicht mehr überlastet
0x170A | Information |  | No channel range error anymore | Es liegt kein Messbereichsfehler mehr vor
0x170C | Information |  | Calibration data saved | Abgleichdaten wurden gespeichert
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Abgleichdaten werden erst nach dem Senden des Kommandos „0x5AFE“ übernommen und gespeichert
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Netzwerk Verbindung verloren
0x2002 | Information | System | %s: Network link detected | Netzwerk Verbindung gefunden
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Ungültige IP Konfiguration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Gültige, vom DHCP-Server zugewiesene IP-Konfiguration
0x2005 | Information | System | %s: Dhcp client timed out | Zeitüberschreitung DHCP-Client
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Doppelte IP-Adresse gefunden
0x2007 | Information | System | %s: UDP handler initialized | UDP-Handler initialisiert
0x2008 | Information | System | %s: TCP handler initialized | TCP-Handler initialisiert
0x2009 | Information | System | %s: No more free TCP sockets available | Keine freien TCP Sockets verfügbar
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x4000 | Warnung |  | Warning: 0x%X, 0x%X, 0x%X | allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4001 | Warnung | System | Warning: 0x%X, 0x%X, 0x%X |
0x4002 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful |
0x4003 | Warnung | System | %s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful |
0x4004 | Warnung | System | %s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out |
0x4005 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u) |
0x4006 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4007 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4008 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms) |
0x4101 | Warnung | Allgemein | Terminal-Overtemperature | Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle
0x4102 | Warnung | Allgemein | Discrepancy in the PDO-Configuration | Die ausgewählten PDOs passen nicht zur eingestellten Betriebsart. Beispiel: Antrieb arbeitet im Velocity-Mode. Das Velocity-PDO ist jedoch nicht in die PDOs gemapped.
0x417F | Warnung | Allgemein | Warnung: 0x%X, 0x%X, 0x%X |
0x428D | Warnung | Allgemein | Challenge is not Random |
0x4300 | Warnung | Encoder | Subincrements deactivated: %d, %d | Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301 | Warnung | Encoder | Encoder-Warning | Allgemeiner Encoderfehler
0x4400 | Warnung | Drive | Drive is not calibrated: %d, %d | Antrieb ist nicht kalibriert
0x4401 | Warnung | Drive | Starttype not supported: 0x%X, %d | Starttyp wird nicht unterstützt
0x4402 | Warnung | Drive | Command rejected: %d, %d | Kommando abgewiesen
0x4405 | Warnung | Drive | Invalid modulo subtype: %d, %d | Modulo-Subtyp ungültig
0x4410 | Warnung | Drive | Target overrun: %d, %d | Zielposition wird überfahren
0x4411 | Warnung | Drive | DC-Link undervoltage (Warning) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x4412 | Warnung | Drive | DC-Link overvoltage (Warning) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x4413 | Warnung | Drive | I2T-Model Amplifier overload (Warning) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414 | Warnung | Drive | I2T-Model Motor overload (Warning) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x4415 | Warnung | Drive | Speed limitation active | Die maximale Drehzahl wird durch die parametrierten Objekte (z.B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen
0x4416 | Warnung | Drive | Step lost detected at position: 0x%X%X | Schrittverlust erkannt
0x4417 | Warnung | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Warnschwelle.
0x4418 | Warnung | Drive | Limit: Current | Limit: Strom wird limitiert
0x4419 | Warnung | Drive | Limit: Amplifier I2T-model exceeds 100%% | Die Schwellwerte für den maximalen Strom wurden überschritten.
0x441A | Warnung | Drive | Limit: Motor I2T-model exceeds 100%% | Limit: Motor I2T-Modell übersteigt 100%
0x441B | Warnung | Drive | Limit: Velocity limitation | Die Schwellwerte für die maximale Drehzahl wurden überschritten.
0x441C | Warnung | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x4600 | Warnung | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x4610 | Warnung | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x4705 | Warnung |  | Processor usage at %d %% | Prozessorauslastung bei %d %%
0x470A | Warnung |  | EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time) | EtherCAT Frame verpasst (Einstellungen, DC Operation Mode oder Sync0 Shift Time ändern)
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x8000 | Fehler | System | %s: %s |
0x8001 | Fehler | System | Error: 0x%X, 0x%X, 0x%X | allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002 | Fehler | System | Communication aborded | Kommunikation abgebrochen
0x8003 | Fehler | System | Configuration error: 0x%X, 0x%X, 0x%X | allgemeine, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8004 | Fehler | System | %s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8005 | Fehler | System | %s: FwdClose-Request sent to %d.%d.%d.%d (%s) |
0x8006 | Fehler | System | %s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8007 | Fehler | System | %s: Connection with %d.%d.%d.%d (%s) closed |
0x8100 | Fehler | Allgemein | Status word set: 0x%X, %d | Fehlerbit im Statuswort gesetzt
0x8101 | Fehler | Allgemein | Operation mode incompatible to PDO interface: 0x%X, %d | Betriebsart inkompatibel zum PDO-Interface
0x8102 | Fehler | Allgemein | Invalid combination of Inputs and Outputs PDOs | Ungültige Kombination von In- und Output PDOs
0x8103 | Fehler | Allgemein | No variable linkage | Keine Variablen verknüpft
0x8104 | Fehler | Allgemein | Terminal-Overtemperature | Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden
0x8105 | Fehler | Allgemein | PD-Watchdog | Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt. - Die EtherCAT-Verbindung wurde im Betrieb unterbrochen - Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135 | Fehler | Allgemein | Cycletime has to be a multiple of 125 µs | Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar
0x8136 | Fehler | Allgemein | Configuration error: invalid sampling rate | Konfigurationsfehler: Ungültige Samplingrate
0x8137 | Fehler | Allgemein | Elektronisches Typenschild: CRC-Fehler | Inhalt des Speicher des externen Typenschildes nicht gültig.
0x8140 | Fehler | Allgemein | Sync Error | Echtzeitverletztung
0x8141 | Fehler | Allgemein | Sync%X Interrupt lost | Sync%X Interrupt fehlt
0x8142 | Fehler | Allgemein | Sync Interrupt asynchronous | Sync Interrupt asynchron
0x8143 | Fehler | Allgemein | Jitter too big | Jitter Grenzwertüberschreitung
0x817F | Fehler | Allgemein | Error: 0x%X, 0x%X, 0x%X |
0x8200 | Fehler | Kommunikation | Write access error: %d, %d | Fehler beim Schreiben
0x8201 | Fehler | Kommunikation | No communication to field-side (Auxiliary voltage missing) | - Es ist keine Spannung an den Powerkontakten angelegt - Ein Firmware Update ist fehlgeschlagen
0x8281 | Fehler | Kommunikation | Ownership failed: %X |
0x8282 | Fehler | Kommunikation | To many Keys founded |
0x8283 | Fehler | Kommunikation | Key Creation failed: %X |
0x8284 | Fehler | Kommunikation | Key loading failed |
0x8285 | Fehler | Kommunikation | Reading Public Key failed: %X |
0x8286 | Fehler | Kommunikation | Reading Public EK failed: %X |
0x8287 | Fehler | Kommunikation | Reading PCR Value failed: %X |
0x8288 | Fehler | Kommunikation | Reading Certificate EK failed: %X |
0x8289 | Fehler | Kommunikation | Challenge could not be hashed: %X |
0x828A | Fehler | Kommunikation | Tickstamp Process failed |
0x828B | Fehler | Kommunikation | PCR Process failed: %X |
0x828C | Fehler | Kommunikation | Quote Process failed: %X |
0x82FF | Fehler | Kommunikation | Bootmode not activated | Bootmode nicht aktiviert
0x8300 | Fehler | Encoder | Set position error: 0x%X, %d | Fehler beim Setzen der Position
0x8301 | Fehler | Encoder | Encoder increments not configured: 0x%X, %d | Enkoderinkremente nicht konfiguriert
0x8302 | Fehler | Encoder | Encoder-Error | Die Amplitude des Resolvers ist zu klein
0x8303 | Fehler | Encoder | Encoder supply error | Encoder Netzteil Fehler
0x8304 | Fehler | Encoder | Encoder communication error, channel: %X | Encoder Kommunikationsfehler
0x8305 | Fehler | Encoder | EnDat2.2 is not supported, channel: %X | EnDat2.2 wird nicht unterstützt
0x8306 | Fehler | Encoder | Delay time, tolerance limit exceeded, 0x%X, channel: %X | Laufzeitmessung, Toleranz überschritten
0x8307 | Fehler | Encoder | Delay time, maximum value exceeded, 0x%X, channel: %X | Laufzeitmessung, Maximalwert überschritten
0x8308 | Fehler | Encoder | Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported) | Falsche EnDat Bestellbezeichnung
0x8309 | Fehler | Encoder | Encoder CRC error, channel: %X | Encoder CRC Fehler
0x830A | Fehler | Encoder | Temperature %X could not be read, channel: %X | Temperatu kann nicht gelesen werden
0x8400 | Fehler | Drive | Incorrect drive configuration: 0x%X, %d | Antrieb fehlerhaft konfiguriert
0x8401 | Fehler | Drive | Limiting of calibration velocity: %d, %d | Begrenzung der Kalibrier-Geschwindigkeit
0x8402 | Fehler | Drive | Emergency stop activated: 0x%X, %d | Emergency-Stop aktiviert
0x8403 | Fehler | Drive | ADC Error | Fehler bei Strommessung im ADC
0x8404 | Fehler | Drive | Overcurrent | Überstrom Phase U, V, oder W
0x8405 | Fehler | Drive | Invalid modulo position: %d | Modulo-Position ungültig
0x8406 | Fehler | Drive | DC-Link undervoltage (Error) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x8407 | Fehler | Drive | DC-Link overvoltage (Error) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x8408 | Fehler | Drive | I2T-Model Amplifier overload (Error) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409 | Fehler | Drive | I2T-Model motor overload (Error) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x840A | Fehler | Drive | Overall current threshold exceeded | Summenstrom überschritten
0x8415 | Fehler | Drive | Invalid modulo factor: %d | Modulo-Faktor ungültig
0x8416 | Fehler | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Fehlerschwelle. Der Motor bleibt sofort stehen. Das Aktivieren der Endstufe wird unterbunden.
0x8417 | Fehler | Drive | Maximum rotating field velocity exceeded | Drehfeldgeschwindigkeit übersteigt den von Dual Use (EU 1382/2014) vorgeschriebenen Wert.
0x841C | Fehler | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x8550 | Fehler | Inputs | Zero crossing phase %X missing | Nulldurchgang Phase %X fehlt
0x8551 | Fehler | Inputs | Phase sequence Error | Drehrichtung Falsch
0x8552 | Fehler | Inputs | Overcurrent phase %X | Überstrom Phase %X
0x8553 | Fehler | Inputs | Overcurrent neutral wire | Überstrom Neutralleiter
0x8581 | Fehler | Inputs | Wire broken Ch %D | Leitungsbruch Ch %d
0x8600 | Fehler | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x8601 | Fehler | Allgemein IO | Supply voltage to low | Versorgungsspannung zu klein
0x8602 | Fehler | Allgemein IO | Supply voltage to high | Versorgungsspannung zu groß
0x8603 | Fehler | Allgemein IO | Over current of supply voltage | Überstrom der Versorgungsspannung
0x8610 | Fehler | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x8611 | Fehler | Allgemein IO | Output voltage to low | Ausgangsspannung zu klein
0x8612 | Fehler | Allgemein IO | Output voltage to high | Ausgangsspannung zu groß
0x8613 | Fehler | Allgemein IO | Over current of output voltage | Überstrom der Ausgangsspannung
0x8700 | Fehler |  | Channel/Interface not calibrated | Kanal/Interface nicht abgeglichen
0x8701 | Fehler |  | Operating time was manipulated | Betriebslaufzeit wurde manipuliert
0x8702 | Fehler |  | Oversampling setting is not possible | Oversampling Einstellung nicht möglich
0x8703 | Fehler |  | No slave controller found | Kein Slave Controller gefunden
0x8704 | Fehler |  | Slave controller is not in Bootstrap | Slave Controller ist nicht im Bootstrap
0x8705 | Fehler |  | Processor usage to high (>= 100%%) | Prozessorauslastung zu hoch (>= 100%%)
0x8706 | Fehler |  | Channel in saturation | Kanal in Sättigung
0x8707 | Fehler |  | Channel overload | Kanalüberlastung
0x8708 | Fehler |  | Overloadtime was manipulated | Überlastzeit wurde manipuliert
0x8709 | Fehler |  | Saturationtime was manipulated | Sättigungszeit wurde manipuliert
0x870A | Fehler |  | Channel range error | Messbereichsfehler des Kanals
0x870B | Fehler |  | no ADC clock | Kein ADC Takt vorhanden
0xFFFF | Information |  | Debug: 0x%X, 0x%X, 0x%X | Debug: 0x%X, 0x%X, 0x%X


TcEventLogger und IO

Anhang [image] TcEventLogger und IO
TcEventLogger und IO
Der TwinCAT 3 EventLogger stellt eine Schnittstelle zum Austausch von Nachrichten zwischen verschiedenen TwinCAT- und Nicht-TwinCAT-Komponenten bereit.
Schematische Darstellung TCEventLogger
Siehe dazu die Erläuterungen in der TwinCAT EventLogger Dokumentation z.B. im Beckhoff InfoSys https://infosys.beckhoff.com/ → TwinCAT 3 → TE1000 XAE → Technologien → EventLogger .
Der EventLogger speichert in eine lokale Datenbank unter ..\TwinCAT\3.1\Boot\LoggedEvents.db und ist im Gegensatz zum VisualStudio Error Window für dauerhafte Aufzeichnung konzipiert.
Auch IO-Geräte können eine Quelle von Nachrichten sein. Werden im IO-Gerät sogenannte DiagMessages erzeugt, können diese bei entsprechender Geräteeinstellung von TwinCAT über EtherCAT abgeholt und im TcEventLogger angezeigt werden. Das erleichtert die zentrale Verwaltung von betriebsbehindernden Ereignissen, da nun nicht mehr in der Applikation für jedes IO-Gerät einzeln eine textuelle Diagnose ausprogrammiert werden muss. Die Nachrichten/Events können z.B. direkt in der TwinCAT HMI angezeigt werden und erleichtern so die Diagnose.
Hinweise:
▪
dieses Feature wird ab TwinCAT 3.1 build 4022.16 unterstützt.
▪
TwinCAT kann sich im RUN- oder CONFIG-Mode befinden
▪
das betrachtete IO-Gerät muss herstellerseitig 1. lokale DiagMessages erstellen und 2. grundsätzlich fähig sein, diese als Event über EtherCAT abzusetzen. Dies ist nicht für alle EtherCAT-IO Geräte/Klemmen/Boxen von Beckhoff der Fall.
Die vom EventLogger verwalteten Nachrichten können ausgegeben werden in bzw. ausgelesen werden von
▪
der HMI → EventGrid
▪
C#
▪
der PLC
▪
TwinCAT Engineering → Logged Events
Im Folgenden Erläuterungen zur Verwendung des EventLoggers mit EtherCAT IO mit TwinCAT 3.1 build 4022.22 während der Inbetriebnahme.
▪
Im TwinCAT Engineering ist ggf. das EventLogger Window anzuzeigen
Anzeige EventLogger Window
▪
Im Folgenden sind am Beispiel einer ELM3602-0002 einige DiagMessages und daraus resultierend die Logged Events zu sehen
Anzeige DiagMessages und Logged Events
▪
Im Logger Window kann nach Einträgen und Sprache gefiltert werden.
Deutsch: 1031
Englisch: 1033
Einstellung Filter Sprache
▪
Ist ein EtherCAT Slave default befähigt, DiagMessages als Event über EtherCAT abzusetzen, kann dies für jeden Slave einzeln im CoE 0x10F3:05 aktiviert/deaktiviert werden. TRUE bedeutet dass der Slave Events zur Abholung über EtherCAT bereitstellt, FALSE deaktiviert die Funktion.
Aktivierung/Deaktivierung Event-Absetzung
▪
Im jeweiligen EtherCAT Slave können verschiedene „Ursachen“ dazu führen, ob und dass er DiagMessages bzw. Events absetzt. Soll nur eine Teilmenge davon erzeugt werden, ist in der Gerätedokumentation nachzulesen, ob und wie z.B. durch CoE Settings einzelne Ursachen deaktiviert werden können.
▪
Einstellungen zum TwinCAT EventLogger sind unter Tools/Options zu finden.
Einstellungen TwinCAT EventLogger


CoE Übersicht

Anhang [image] CoE Übersicht
CoE Übersicht
Weiterführende Informationen
•
0x6000 PAI Status Ch.1
•
0x6001 PAI Samples Ch.1
•
0x6002 PAI Synchronous Oversampling Ch.1
•
0x7000 PAI Control Ch.1
•
0x8000 PAI Settings Ch.1
•
0x8001 PAI Filter 1 Settings Ch.1
•
0x8003 PAI Filter 2 Settings Ch.1
•
0x8005 Scaler Settings Ch.1
•
0x800E PAI User Calibration Data Ch.1
•
0x800F PAI Vendor Calibration Data Ch.1
•
0x9000 PAI Internal Data Ch.1
•
0x900F PAI Calibration Dates Ch.1
•
0xF000 Modular device profile
•
0xF008 Code word
•
0xF009 Password Protection
•
0xF010 Module list
•
0xF600 PAI Timestamp
•
0xF900 PAI Info Data
•
0xF912 Filter info
•
0xFB00 PAI Command


0x6000 PAI Status Ch.1

Anhang [image] CoE Übersicht [image] 0x6000 PAI Status Ch.1
0x6000 PAI Status Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | PAI Status Ch.1 |  | UINT8 | RO | 0x0F (15dez)
6000:01 | No of Samples | Anzahl gültiger Samples innerhalb der PDO-Samples | UINT8 | RO | 0x00 (0dez)
6000:09 | Error | TRUE: allgemeiner Fehler | BOOLEAN | RO | 0x00 (0dez)
6000:0A | Underrange | TRUE: Unterlauf der Messung Ereignis | BOOLEAN | RO | 0x00 (0dez)
6000:0B | Overrange | TRUE: Überlauf der Messung Ereignis | BOOLEAN | RO | 0x00 (0dez)
6000:0D | Diag | TRUE: neue Diagnose Nachricht vorhanden | BOOLEAN | RO | 0x00 (0dez)
6000:0E | TxPDO State | TRUE: Daten sind ungültig | BOOLEAN | RO | 0x00 (0dez)
6000:0F | Input cycle counter | Erhöht um eins wenn sich Werte geändert haben | BIT2 | RO | 0x00 (0dez)


0x6001 PAI Samples Ch.1

Anhang [image] CoE Übersicht [image] 0x6001 PAI Samples Ch.1
0x6001 PAI Samples Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6001:0 | PAI Samples Ch.1 |  | UINT8 | RO | 0x64 (100dez)
6001:01 | Sample | Samples | INT32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
6001:64 | Sample | Samples | INT32 | RO | 0x00000000 (0dez)


0x6002 PAI Synchronous Oversampling Ch.1

Anhang [image] CoE Übersicht [image] 0x6002 PAI Synchronous Oversampling Ch.1
0x6002 PAI Synchronous Oversampling Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6002:0 | PAI Synchronous Oversampling Ch.1 |  | RO | UINT8 | 0x01 (1dez)
6002:01 | Internal Buffer |  | RO | UINT16 | 0x0000 (0dez)


0x7000 PAI Control Ch.1

Anhang [image] CoE Übersicht [image] 0x7000 PAI Control Ch.1
0x7000 PAI Control Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | PAI Control Ch.1 |  | UINT8 | RO | 0x02 (2dez)
7000:01 | Integrator Reset | Neustart der Integration bei ansteigender Flanke | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Peak Hold Reset | Beginn neuer Spitzenwert-Erfassung bei ansteigender Flanke | BOOLEAN | RO | 0x00 (0dez)


0x8000 PAI Settings Ch.1

Anhang [image] CoE Übersicht [image] 0x8000 PAI Settings Ch.1
0x8000 PAI Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | PAI Settings Ch.1 |  | UINT8 | RO | 0x31 (49dez)
8000:01 | Interface | Auswahl der Messkonfiguration: 0 - None 1 - V ±30V 2 - V ±10V 3 - V ±5V 4 - V ±2.5V 5 - V ±1.25V 6 - V ±640mV 7 - V ±320mV 8 - V ±160mV 9 - V ±80mV 10 - V ±40mV 11 - V ±20mV 12 - V ±10mV 13 - V ±5mV 14 - V 0...10V 15 - V 0...5V 17 - I ±20mA 18 - I 0-20mA 19 - I 4-20mA 20 - I 4-20mA NAMUR 33 - RTD/R 2Wire 34 - RTD/R 3Wire 35 - RTD/R 4Wire 49 - SG 1/4 2Wire 350R 50 - SG 1/4 2Wire 120R 51 - SG 1/4 3Wire 350R 52 - SG 1/4 3Wire 120R 53 - SG 1/2 3Wire 54 - SG 1/2 5Wire 55 - SG 1/1 4Wire 56 - SG 1/1 6Wire 65 - Poti 3Wire 66 - Poti 5Wire | UINT16 | RW | 0x0000 (0dez)
8000:02 | SG Voltage | Auswahl SG Spannung: 0 - 0 V 1 - 0.5 V 2 - 1.0 V 3 - 1.5 V 4 - 2.0 V 5 - 2.5 V 6 - 3.0 V 7 - 3.5 V 8 - 4.0 V 9 - 4.5 V 10 - 5.0 V | UINT16 | RW | 0x0000 (0dez)
8000:04 | Wire Break Detection | Drahtbrucherkennung: TRUE = Ein FALSE = Aus (siehe Kapitel „Drahtbrucherkennung/schaltbare Anschlussdiagnose“) | BOOLEAN | RW | 0x00 (FALSE)
8000:13 | Wire Resistance Compensation 640 µΩ/ Step | Kompensation des Leitungswiderstandes mit Auflösung 640 µΩ/ Step (nur im 2-Leiter Modus, „R/RTD 2 Wire“ möglich) | UINT16 | RW | 0x0000 (0dez)
8000:14 | RTD Element | Auswahl des RTD Elements: 0 - None 1 - PT100 (-200...850°C) 2 - NI100 (-60...250°C) 3 - PT1000 (-200...850°C) 4 - PT500 (-200...850°C) 5 - PT200 (-200...850°C) 6 - NI1000 (-60...250°C) 7 - NI1000 TK5000 bzw. 100°C: 1500Ohm (-30...160°C) 8 - NI120 (-60...320°C) 9 - KT100/110/130/210/230 KTY10/11/13/16/19 (-50...150°C) 10 - KTY81/82-110,120,150 (-50...150°C) 11 - KTY81-121 (-50...150°C) 12 - KTY81-122 (-50...150°C) 13 - KTY81-151 (-50...150°C) 14 - KTY81-152 (-50...150°C) 15 - KTY81/82-210,220,250 (-50...150°C) 16 - KTY81-221 (-50...150°C) 17 - KTY81-222 (-50...150°C) 18 - KTY81-251 (-50...150°C) 19 - KTY81-252 (-50...150°C) 20 - KTY83-110,120,150 (-50...175°C) 21 - KTY83-121 (-50...175°C) 22 - KTY83-122 (-50...175°C) 23 - KTY83-151 (-50...175°C) 24 - KTY83-152 (-50...175°C) 25 - KTY84-130,150 (-40...300°C) 26 - KTY84-151 (-40...300°C) 27 - KTY21/23-6 (-50...150°C) 28 - KTY1x-5 (-50...150°C) 29 - KTY1x-7 (-50...150°C) 30 - KTY21/23-5 (-50...150°C) 31 - KTY21/23-7 (-50...150°C) | UINT16 | RW | 0x0000 (0dez)
8000:16 | Filter 1 | Optionen für Filter 1: 0 - None 1 - FIR Notch 50 Hz 2 - FIR Notch 60 Hz 3 - FIR LP 100 Hz 4 - FIR LP 1000 Hz 5 - FIR HP 150 Hz 6 - FIR HP 1500 Hz 16 - IIR Notch 50 Hz 17 - IIR Notch 60 Hz 18 - IIR Butterw. LP 5th Ord. 1 Hz 19 - IIR Butterw. LP 5th Ord. 25 Hz 20 - IIR Butterw. LP 5th Ord. 100 Hz 21 - IIR Butterw. LP 5th Ord. 250 Hz 22 - IIR Butterw. LP 5th Ord. 1000 Hz 32 - User defined FIR Filter 33 - User defined IIR Filter 34 - User defined Average Filter | UINT16 | RW | 0x0000 (0dez)
8000:17 | Average Filter 1 No of Samples | Anzahl von Samples für den Anwenderdefinierten Mittelwertfilter 1 | UINT16 | RW | 0x0001 (1dez)
8000:18 | Decimation Factor | Faktor der individuellen Sampling-Rate (min. 1) | UINT16 | RW | 0x0001 (1dez)
8000:19 | Filter 2 | Optionen für Filter 2: 0 - None 1 - IIR 1 2 - IIR 2 3 - IIR 3 4 - IIR 4 5 - IIR 5 6 - IIR 6 7 - IIR 7 8 - IIR 8 16 - User defined FIR Filter 17 - User defined IIR Filter 18 - User defined Average Filter | UINT16 | RW | 0x0000 (0dez)
8000:1A | Average Filter 2 No of Samples | Anzahl von Samples für den Anwenderdefinierten Mittelwertfilter 2 | UINT16 | RW | 0x0000 (0dez)
8000:1B | True RMS No. of Samples | Anzahl von Samples für „True RMS“ Berechnung (min. 1, max. 1000); siehe auch Kapitel TrueRMS (erweiterter Maximalwerte für ELM360x) | UINT16 | RW | 0x0000 (0dez)
8000:1C | Enable True RMS | Aktivierung der „True RMS“ Berechnung | BOOLEAN | RW | 0x00 (FALSE)
8000:2B | Extended Functions | Optionen für spätere Funktionen /Einstellungen | UINT16 | RW | 0x0000 (0dez)
8000:2C | Integrator/Differentiator | Optionen: 0 – Off 1 - Integrator 1x 2 - Integrator 2x (* 3 - Differentiator 1x 4 - Differentiator 2x (* | UINT16 | RW | 0x0000 (0dez)
8000:2D | Differentiator Samples Delta | Abstand der Abtastwerte für die Differentiation | UINT16 | RW | 0x0001 (1dez)
8000:2E | Scaler | Skalierung (ENUM): 0 - Extended Range 1 - Linear 2 - Lookup Table 3 - Legacy Range 4 - Lookup Table (additive) | UINT16 | RW | 0x0000 (0dez)
8000:30 | Low Limiter | Kleinster PDO Ausgabewert | INT32 | RW | 0x80000000 (-2147483648dez)
8000:31 | High Limiter | Größter PDO Ausgabewert | INT32 | RW | 0x7FFFFFFF (2147483647dez)
8000:32 | Low Range Error | Niedrigste Grenze bei der das Error-Bit und Error-LED gesetzt wird | INT32 | RW | 0xFF800000 (-8388608dez)
8000:33 | High Range Error | Höchste Grenze bei der das Error-Bit und Error-LED gesetzt wird | INT32 | RW | 0x007FFFFF (8388607dez)
8000:34 | Timestamp Correction | Wert zur Korrektur von StartNextLatchTime (Zeitstempel des ersten Samples) | INT32 | RW | 0x FFFB6C20 (-300000dez)
(* Funktion steht erst ab FW03 zur Verfügung


0x8001 PAI Filter 1 Settings Ch.1

Anhang [image] CoE Übersicht [image] 0x8001 PAI Filter 1 Settings Ch.1
0x8001 PAI Filter 1 Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8001:0 | PAI Filter 1 Settings Ch.1 |  | UINT8 | RO | 0x28 (40dez)
8001:01 | Filter Coefficient 1 | Koeffizienten für Filter 1 | INT32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
8001:28 | Filter Coefficient 40 | Koeffizienten für Filter 1 | INT32 | RO | 0x00000000 (0dez)


0x8003 PAI Filter 2 Settings Ch.1

Anhang [image] CoE Übersicht [image] 0x8003 PAI Filter 2 Settings Ch.1
0x8003 PAI Filter 2 Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8003:0 | PAI Filter 2 Settings Ch.1 |  | UINT8 | RO | 0x28 (40dez)
8003:01 | Filter Coefficient 1 | Koeffizienten für Filter 2 | INT32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
8003:28 | Filter Coefficient 40 | Koeffizienten für Filter 2 | INT32 | RO | 0x00000000 (0dez)


0x8005 Scaler Settings Ch.1

Anhang [image] CoE Übersicht [image] 0x8005 Scaler Settings Ch.1
0x8005 Scaler Settings Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8005:0 | PAI Scaler Settings Ch.1 | Scalierungswerte Offset/Verstärkung oder LookUp-Tabelle mit 50 x/y Wertepaaren | UINT8 | RO | 0x64 (100dez)
8005:01 | Scaler Offset/ Scaler Value 1 | Skalierungs-Offset oder LookUp x-Wert 1 | INT32 | RW | 0x00000000 (0dez)
8005:02 | Scaler-Gain/ Scaler Value 2 | Skalierungs-Verstärkung oder LookUp y-Wert 1 | INT32 | RW | 0x00000000 (0dez)
8005:03 | Scaler Value 3 | LookUp x-Wert 2 | INT32 | RW | 0x00000000 (0dez)
8005:04 | Scaler Value 4 | LookUp y-Wert 2 | INT32 | RW | 0x00000000 (0dez)
.. | .. | .. | .. | .. | ..
8005:63 | Scaler Value 99 | LookUp x-Wert 50 | INT32 | RW | 0x00000000 (0dez)
8005:64 | Scaler Value 100 | LookUp y-Wert 50 | INT32 | RW | 0x00000000 (0dez)


0x800E PAI User Calibration Data Ch.1

Anhang [image] CoE Übersicht [image] 0x800E PAI User Calibration Data Ch.1
0x800E PAI User Calibration Data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | PAI User Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dez)
800E:01 | Calibration Date | Tag der Kalibrierung | OCTET-STRING[4] | RW | -
800E:02 | Signature | Signatur der Kalibrierungswerte | OCTET-STRING[4] | RW | -
800E:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0.0dez)
800E:04 | S1 | Koeffizient der Samples 1. Ordnung (S1 * Sample) | REAL32 | RW | 0x3F800000 (1.0dez)
800E:05 | S2 | Koeffizient der Samples 2. Ordnung (S2 * Sample2) | REAL32 | RW | 0x00000000 (0.0dez)
800E:06 | S3 | Koeffizient der Samples 3. Ordnung (S3 * Sample3) | REAL32 | RW | 0x00000000 (0.0dez)
800E:07 | T1 | Temperaturkoeffizient des Temperaturwertes 1. Ordnung (T1 * Temp) | REAL32 | RW | 0x00000000 (0.0dez)
800E:08 | T1S1 | Kombinierter Koeffizient der Verstärkung und Temperaturwertes 1. Ordnung (T1S1 * Temp * Sample) | REAL32 | RW | 0x00000000 (0.0dez)
800E:09 | T2 | Temperaturkoeffizient des Temperaturwertes 2. Ordnung (T2 * Temp2) | REAL32 | RW | 0x00000000 (0.0dez)
800E:0A | T2S1 | Kombinierter Koeffizient der Verstärkung und Temperaturwertes 2. Ordnung (T2S1 * Temp2 * Sample) | REAL32 | RW | 0x00000000 (0.0dez)
800E:0B | T3 | Temperaturkoeffizient des Temperaturwertes 3. Ordnung (T3 * Temp3) | REAL32 | RW | 0x00000000 (0.0dez)
800E:0C | T3S1 | Kombinierter Koeffizient der Verstärkung und Temperaturwertes 3. Ordnung (T3S1 * Temp3 * Sample) | REAL32 | RW | 0x00000000 (0.0dez)


0x800F PAI Vendor Calibration Data Ch.1

Anhang [image] CoE Übersicht [image] 0x800F PAI Vendor Calibration Data Ch.1
0x800F PAI Vendor Calibration Data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | PAI Vendor Calibration Data Ch.1 |  | UINT8 | RO | 0x0C (12dez)
800F:01 | Calibration Date | Tag der Kalibrierung | OCTET-STRING[4] | RW | -
800F:02 | Signature | Signatur der Kalibrierungswerte | OCTET-STRING[4] | RW | -
800F:03 | S0 | Offset | REAL32 | RW | 0x00000000 (0.0dez)
800F:04 | S1 | Koeffizient der Samples 1. Ordnung (S1 * Sample) | REAL32 | RW | 0x3F800000 (1.0dez)
800F:05 | S2 | Koeffizient der Samples 2. Ordnung (S2 * Sample2) | REAL32 | RW | 0x00000000 (0.0dez)
800F:06 | S3 | Koeffizient der Samples 3. Ordnung (S3 * Sample3) | REAL32 | RW | 0x00000000 (0.0dez)
800F:07 | T1 | Temperaturkoeffizient des Temperaturwertes 1. Ordnung (T1 * Temp) | REAL32 | RW | 0x00000000 (0.0dez)
800F:08 | T1S1 | Kombinierter Koeffizient der Verstärkung und Temperaturwertes 1. Ordnung (T1S1 * Temp * Sample) | REAL32 | RW | 0x00000000 (0.0dez)
800F:09 | T2 | Temperaturkoeffizient des Temperaturwertes 2. Ordnung (T2 * Temp2) | REAL32 | RW | 0x00000000 (0.0dez)
800F:0A | T2S1 | Kombinierter Koeffizient der Verstärkung und Temperaturwertes 2. Ordnung (T2S1 * Temp2 * Sample) | REAL32 | RW | 0x00000000 (0.0dez)
800F:0B | T3 | Temperaturkoeffizient des Temperaturwertes 3. Ordnung (T3 * Temp3) | REAL32 | RW | 0x00000000 (0.0dez)
800F:0C | T3S1 | Kombinierter Koeffizient der Verstärkung und Temperaturwertes 3. Ordnung (T3S1 * Temp3 * Sample) | REAL32 | RW | 0x00000000 (0.0dez)


0x9000 PAI Internal Data Ch.1

Anhang [image] CoE Übersicht [image] 0x9000 PAI Internal Data Ch.1
0x9000 PAI Internal Data Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9000:0 | PAI Internal Data Ch.1 |  | UINT8 | RO | 0x12 (18dez)
9000:01 | Temperature Value | Temperaturwert des Kanals | INT16 | RO | 0x0000 (0dez)
9000:02 | ADC Raw Value | Rohwert des ADC | INT32 | RO | 0x00000000 (0dez)
9000:03 | Calibration Value | Wert nach Kalibrierung | INT32 | RO | 0x00000000 (0dez)
9000:04 | Resistor Value | Wert nach Widerstands-Berechnung | INT32 | RO | 0x00000000 (0dez)
9000:05 | RTD Element Value | Wert nach RTD Element-Berechnung | INT32 | RO | 0x00000000 (0dez)
9000:06 | Actual Negative Peak Hold | Aktueller absoluter Minimalwert | INT32 | RO | 0x00000000 (0dez)
9000:07 | Actual Positive Peak Hold | Aktueller absoluter Maximalwert | INT32 | RO | 0x00000000 (0dez)
9000:08 | Previous Negative Peak Hold | Absoluter Minimalwert bis zur letzten steigenden Flanke des „Peak Hold Reset“ | INT32 | RO | 0x00000000 (0dez)
9000:09 | Previous Positive Peak Hold | Absoluter Maximalwert bis zur letzten steigenden Flanke des „Peak Hold Reset“ | INT32 | RO | 0x00000000 (0dez)
9000:0A | Filter 1 Value | Wert nach Filter 1 | INT32 | RO | 0x00000000 (0dez)
9000:0B | Filter 2 Value | Wert nach Filter 2 | INT32 | RO | 0x00000000 (0dez)
9000:0C | True RMS Value | Wert nach „True RMS“ Berechnung | INT32 | RO | 0x00000000 (0dez)
9000:0D | Extended Functions Value | Wert nach erweiterter (optionaler) Funktion | INT32 | RO | 0x00000000 (0dez)
9000:0E | Integrator/Differentiator Value | Wert nach Integration oder Differentiation | INT32 | RO | 0x00000000 (0dez)
9000:0F | Scaler Value | Wert nach Skalierung | INT32 | RO | 0x00000000 (0dez)
9000:10 | Limiter Value | Wert nach Begrenzung | INT32 | RO | 0x00000000 (0dez)
9000:11 | Overload Time | Absolutzeit während Überlast „Überlast“ bedeutet, dass der Kanal elektrisch überlastet ist. Das ist ein nicht empfehlenswerter Zustand der auf Dauer zu atypischer Alterung oder sogar Beschädigung führen kann. Dieser Zustand sollte vermieden werden. Seine kumulierte Anliegedauer wird hier informativ angezeigt. | UINT32 | RO | 0x00000000 (0dez)
9000:12 | Saturation Time | Absolutzeit während Saturation „Saturation“ (deutsch: Sättigung) bedeutet, dass der Messbereich des ADC des Kanals voll ausgenutzt wird, der ADC also seinen Maximalwert ausgibt und der Messwert nicht weiter benutzbar ist. „Saturation“ ist somit eine Vorabmeldung, bei weiterer Signalsteigerung kommt es zur „Überlast“. Der Sättigungszustand ist nicht grundsätzlich schädigend, da er aber auf eine ungenügende Dimensionierung des Messkanals hindeutet wird seine kumulierte Anliegedauer hier informativ angezeigt. | UINT32 | RO | 0x00000000 (0dez)
9000:13 | Effective Sample Rate | Effektive Abtastfrequenz | UINT32 | RO | Online calculated
9000:14 | Vendor Calibration Counter | Zähler des Schreibens von Hersteller Abgleichdaten | UINT16 | RO | 0x0000 (0dez)
9000:15 | User Calibration Counter | Zähler des Schreibens von Anwender Abgleichdaten | UINT16 | RO | 0x0000 (0dez)


0x900F PAI Calibration Dates Ch.1

Anhang [image] CoE Übersicht [image] 0x900F PAI Calibration Dates Ch.1
0x900F PAI Calibration Dates Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
900F:0 | PAI Calibration Dates |  | UINT8 | RO | 0xC2 (194dez)
900F:01 | Vendor ±30V |  | OCTET-STRING[4] | RO | {0}
900F:02 | Vendor ±10V |  | OCTET-STRING[4] | RO | {0}
900F:03 | Vendor ±5V |  | OCTET-STRING[4] | RO | {0}
900F:04 | Vendor ±2.5V |  | OCTET-STRING[4] | RO | {0}
900F:05 | Vendor ±1.25V |  | OCTET-STRING[4] | RO | {0}
900F:06 | Vendor ±640mV |  | OCTET-STRING[4] | RO | {0}
900F:07 | Vendor ±320mV |  | OCTET-STRING[4] | RO | {0}
900F:08 | Vendor ±160mV |  | OCTET-STRING[4] | RO | {0}
900F:09 | Vendor ±80mV |  | OCTET-STRING[4] | RO | {0}
900F:0A | Vendor ±40mV |  | OCTET-STRING[4] | RO | {0}
900F:0B | Vendor ±20mV |  | OCTET-STRING[4] | RO | {0}
900F:0C | Vendor ±10mV |  | OCTET-STRING[4] | RO | {0}
900F:0D | Vendor ±5mV |  | OCTET-STRING[4] | RO | {0}
900F:11 | Vendor ±20mA |  | OCTET-STRING[4] | RO | {0}
900F:21 | Vendor RTD/R 2Wire |  | OCTET-STRING[4] | RO | {0}
900F:22 | Vendor RTD/R 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:23 | Vendor RTD/R 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:31 | Vendor SG 1/4 2Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:32 | Vendor SG 1/4 2Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:33 | Vendor SG 1/4 3Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:34 | Vendor SG 1/4 3Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:35 | Vendor SG 1/2 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:36 | Vendor SG 1/2 5Wire |  | OCTET-STRING[4] | RO | {0}
900F:37 | Vendor SG 1/1 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:38 | Vendor SG 1/1 6Wire |  | OCTET-STRING[4] | RO | {0}
900F:41 | Vendor Poti 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:42 | Vendor Poti 5Wire |  | OCTET-STRING[4] | RO | {0}
900F:81 | User ±30V |  | OCTET-STRING[4] | RO | {0}
900F:82 | User ±10V |  | OCTET-STRING[4] | RO | {0}
900F:83 | User ±5V |  | OCTET-STRING[4] | RO | {0}
900F:84 | User ±2.5V |  | OCTET-STRING[4] | RO | {0}
900F:85 | User ±1.25V |  | OCTET-STRING[4] | RO | {0}
900F:86 | User ±640mV |  | OCTET-STRING[4] | RO | {0}
900F:87 | User ±320mV |  | OCTET-STRING[4] | RO | {0}
900F:88 | User ±160mV |  | OCTET-STRING[4] | RO | {0}
900F:89 | User ±80mV |  | OCTET-STRING[4] | RO | {0}
900F:8A | User ±40mV |  | OCTET-STRING[4] | RO | {0}
900F:8B | User ±20mV |  | OCTET-STRING[4] | RO | {0}
900F:8C | User ±10mV |  | OCTET-STRING[4] | RO | {0}
900F:8D | User ±5mV |  | OCTET-STRING[4] | RO | {0}
900F:91 | User ±20mA |  | OCTET-STRING[4] | RO | {0}
900F:A1 | User RTD/R 2Wire |  | OCTET-STRING[4] | RO | {0}
900F:A2 | User RTD/R 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:A3 | User RTD/R 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:B1 | User SG 1/4 2Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:B2 | User SG 1/4 2Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:B3 | User SG 1/4 3Wire 350R |  | OCTET-STRING[4] | RO | {0}
900F:B4 | User SG 1/4 3Wire 120R |  | OCTET-STRING[4] | RO | {0}
900F:B5 | User SG 1/2 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:B6 | User SG 1/2 5Wire |  | OCTET-STRING[4] | RO | {0}
900F:B7 | User SG 1/1 4Wire |  | OCTET-STRING[4] | RO | {0}
900F:B8 | User SG 1/1 6Wire |  | OCTET-STRING[4] | RO | {0}
900F:C1 | User Poti 3Wire |  | OCTET-STRING[4] | RO | {0}
900F:C2 | User Poti 5Wire |  | OCTET-STRING[4] | RO | {0}


0xF000 Modular device profile

Anhang [image] CoE Übersicht [image] 0xF000 Modular device profile
0xF000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dec)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0000 (0dec)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0000 (0dec)


0xF008 Code word

Anhang [image] CoE Übersicht [image] 0xF008 Code word
0xF008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word |  | UINT32 | RW | 0x00000000 (0dec)


0xF009 Password Protection

Anhang [image] CoE Übersicht [image] 0xF009 Password Protection
0xF009 Password Protection
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F009:0 | Password protection |  | UINT32 | RW | 0x00000000 (0dec)


0xF010 Module list

Anhang [image] CoE Übersicht [image] 0xF010 Module list
0xF010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x01 (1dec)
F010:01 | Subindex 001 |  | UINT32 | RW | 0x0000015E (350dez)


0xF600 PAI Timestamp

Anhang [image] CoE Übersicht [image] 0xF600 PAI Timestamp
0xF600 PAI Timestamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | PAI Timestamp |  | UINT8 | RO | 0x02 (2dec)
F600:01 | Low | Zeitstempel (Low) | UINT32 | RO | 0x00000000 (0dec)
F600:02 | Hi | Zeitstempel (Hi) | UINT32 | RO | 0x00000000 (0dec)


0xF900 PAI Info Data

Anhang [image] CoE Übersicht [image] 0xF900 PAI Info Data
0xF900 PAI Info Data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | PAI Info Data |  | UINT8 | RO | 0x02 (2dec)
F900:01 | CPU Usage | CPU Auslastung in [%]* | UINT16 | RO | 0x0000 (0dec)
F900:02 | Operating Time | Betriebszeit in [min] | UINT32 | RO | 0x00000000 (0dec)
F900:11 | Device Temperature Sensor 1 | Gemessene Temperatur in der Klemme | INT16 | RO | 0x0000 (0dec)
F900:21 | Min. Temperature Sensor 1 | Niedrigste gemessene Temperatur in der Klemme | INT16 | RO | 0x0000 (0dec)
F900:22 | Max. Temperature Sensor 1 | Höchste gemessene Temperatur in der Klemme | INT16 | RO | 0x0000 (0dec)
*) Dieser Wert hängt von zugeschalteten Features (Filter, True RMS, …) ab; je mehr Funktionen der Klemme im Einsatz sind, desto grösser ist der Wert. Zu beachten ist hierbei u.a. der „Input cycle counter“ (PAI Status Ch1.). Die CPU Auslastung ist ein informativer Wert zu dem insbesondere die „Gerätespezifische DiagMessages“ in Betracht zu ziehen sind.


0xF912 Filter info

Anhang [image] CoE Übersicht [image] 0xF912 Filter info
0xF912 Filter info
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F912:0 | Filter info |  | UINT8 | RO | 0x05 (5dec)
F912:01 | Info header | Basisinformationen für den Filterdesigner | OCTET‑STRING[8] | RO | {0}
F912:02 | Filter 1 | Informationen für den Filterdesigner | OCTET‑STRING[30] | RO | {0}
... | ... | ... | ... | ... | ...
F912:05 | Filter n | Informationen für den Filterdesigner | OCTET‑STRING[30] | RO | {0}
Hinweis: Das CoE Objekt "0xF912 Filter info" ist verfügbar ab FW11, Revision -0022


0xFB00 PAI Command

Anhang [image] CoE Übersicht [image] 0xFB00 PAI Command
0xFB00 PAI Command
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | PAI Command |  | UINT8 | RO | 0x03 (3dec)
FB00:01 | Request | Kommandoanfrage In den betreffenden Funktions‑Kapiteln wird erklärt welcher Wert hier einzutragen ist. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Kommandostatus Hier wird angezeigt, dass das Kommando noch ausgeführt wird bzw. wurde. Funktionsabhängig, siehe entsprechende Kapitel. Ansonsten: 0: Kommando nicht vorhanden 1: ohne Fehler ausgeführt 2,3: nicht erfolgreich ausgeführt 100..200: zeigt Ausführungsfortschritt an (100 = 0% usw.) | UINT8 | RO | 0x00 (0dec)
FB00:03 | Response | Kommandoantwort Falls das abgesetzte Kommando eine Antwort liefert, wird diese hier angezeigt. Funktionsabhängig, siehe entsprechende Kapitel. | OCTET-STRING[4] | RO | {0}


UL-Hinweise

Anhang [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


ATEX-Dokumentation

Anhang [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Firmware Kompatibilität - Passive Klemmen

Anhang [image] Firmware Kompatibilität - Passive Klemmen
Firmware Kompatibilität - Passive Klemmen
Die Passiven Klemmen der ELxxxx Serie verfügen über keine Firmware.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.