EL34xx - 3-Phasen Energie- und Leistungsmessklemmen
Home


Produktübersicht Leistungsmessklemmen

Produktübersicht Leistungsmessklemmen
Produktübersicht Leistungsmessklemmen
EL3423
3-Phasen-Leistungsmessklemme, Economy; 480 VAC, 1 A
EL3443
3-Phasen-Leistungsmessklemme mit erweiterter Funktion; 480 VAC, 1 A
EL3443-0010
3-Phasen-Leistungsmessklemme mit erweiterter Funktion; 480 VAC, 5 A
EL3443-0011
3-Phasen-Leistungsmessklemme mit erweiterter Funktion; 480 VAC, 100 mA
EL3443-0013
3-Phasen-Leistungsmessklemme mit erweiterter Funktion; 480 VAC, 333 mV
EL3453
3-Phasen-Leistungsmessklemme mit erweiterter Funktion; 690 VAC, 5 A
EL3483
3-Phasen-Netzwächter für Spannung, Frequenz und Phase; 480 VAC
EL3483-0060
3-Phasen-Netzwächter mit Spannungsmessung; 480 VAC


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
1.7
▪
Kapitel „Objektbeschreibung und Paramatrierung“ aktualisiert
▪
Strukturupdate
▪
Revisionsstand aktualisiert
1.6
▪
Kapitel „Anwendungsbeispiele“ aktualisiert
▪
Strukturupdate
▪
Revisionsstand aktualisiert
1.5
▪
Strukturupdate
▪
Revisionsstand aktualisiert
1.4
▪
EL3443-0011, EL3443-0013, EL3483-0060 ergänzt
▪
Strukturupdate
▪
Revisionsstand aktualisiert
1.3
▪
EL3453 ergänzt
▪
Strukturupdate
▪
Revisionsstand aktualisiert
1.2
▪
Kapitel „TcEventLogger und IO“ ergänzt (Anhang)
1.1
▪
Kapitel „Technische Daten“ aktualisiert
1.0
▪
Erste Veröffentlichung
0.2 – 0.5
▪
Ergänzungen, Korrekturen
0.1
▪
Vorläufige Dokumentation für EL34xx


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL34xx – Einführung
•
Technische Daten
•
Grundlagen zur Funktion
•
Stromwandler
•
Start


EL34xx – Einführung

Produktübersicht [image] EL34xx – Einführung
EL34xx – Einführung
EL3443 | 3-Phasen-Leistungsmessklemme mit erweiterter Funktion
EL3443
Die EtherCAT-Klemme EL3443 ermöglicht die Messung aller relevanten elektrischen Daten des Versorgungsnetzes und übernimmt einfache Vorauswertungen. Die Spannung wird über den direkten Anschluss von L1, L2, L3 und N gemessen. Der Strom der drei Phasen L1, L2 und L3 wird über einfache Stromwandler eingespeist.
Die Messwerte aller Ströme und Spannungen stehen als Effektivwert zur Verfügung. In der EL3443 werden die Wirkleistung und der Energieverbrauch für jede Phase berechnet. Die Effektivwerte von Spannung U und Strom I sowie Wirkleistung P, Scheinleistung S, Blindleistung Q, Frequenz f und Phasenverschiebungswinkel cos φ und auch Oberschwingung stehen zur Verfügung. Die EL3443 bietet die Möglichkeit zu einer umfangreichen Netzanalyse sowie zum Energiemanagement.
Varianten:
▪
EL3443-0000: Variante mit Direktstrommessung bis 1 A
▪
EL3443-0010: Variante mit Direktstrommessung bis 5 A
▪
EL3443-0011: Variante mit Direktstrommessung 100 mA
▪
EL3443-0013: Variante mit Direktspannungsmessung 333 mV
EL3423 | 3-Phasen-Energiemessklemme, Economy
EL3423
Die EtherCAT-Klemme EL3423 ermöglicht die Messung von relevanten Daten für ein effizientes Energiemanagementsystem. Die Spannung wird intern über den direkten Anschluss von L1, L2, L3 und N gemessen. Der Strom der drei Phasen L1, L2 und L3 wird über einfache Stromwandler eingespeist. Die Messwerte der Energie stehen separat als erzeugte und abgenommene Werte zur Verfügung. In der EL3423 werden die Wirkleistung und der Energieverbrauch für jede Phase berechnet. Zusätzlich gibt ein intern berechneter Netzqualitätsfaktor Aufschluss über die Qualität der überwachten Spannungsversorgung. Die EL3423 bietet die Möglichkeit zu einer grundlegenden Netzanalyse und zum Energiemanagement.
EL3483 | 3-Phasen-Netzwächter für Spannung, Frequenz und Phase
EL3483
Die EtherCAT-Klemme EL3483 ermöglicht die Kontrolle von relevanten elektrischen Daten des Versorgungsnetzes. Die Spannung wird über den direkten Anschluss von L1, L2, L3 und N intern gemessen. Die internen Messwerte werden mit vorher vom Anwender gesetzten Schwellwerten verglichen. Das Ergebnis steht als digitale Information in Prozessabbild zur Verfügung.
Die EL3483 überwacht die korrekte Phasenfolge L1, L2, L3, den Phasenausfall, die Unter- und Überspannung und mögliche Phasenasymmetrie. Bei falscher Phasenfolge oder bei Phasenausfall wird ein Fehler-Bit gesetzt. Tritt beispielsweise eine Asymmetrie- oder Spannungsstörung auf, wird vorerst nur ein Warnungs-Bit gesetzt. Zusätzlich gibt ein intern berechneter Netzqualitätsfaktor Aufschluss über die Qualität der überwachten Spannungsversorgung. Die EL3483 bietet die Möglichkeit zu einer einfachen Netzanalyse sowie Netzkontrolle. Die Variante EL3483-0060 gibt zusätzlich auch die aktuellen Effektivwerte der Spannung im Prozessabbild aus.
EL3453 | 3-Phasen-Leistungsmessklemme bis 690 V AC mit erweiterter Funktion
EL3453
Die EtherCAT-Leistungsmessklemme EL3453 ist eine Weiterentwicklung der EL3413. Mit max. 690 V AC sind die Spannungseingänge für die direkte Überwachung leistungsstarker Generatoren, wie z. B. in der Windindustrie üblich, optimiert. Ein vorgeschalteter Spannungswandler ist nicht erforderlich.
Die vier Stromeingänge sind galvanisch voneinander getrennt und erlauben den Einsatz der Klemme in allen üblichen geerdeten Stromwandlerschaltungen wie 2- oder 3-Wandleranordnung in Stern- oder Dreieckschaltung inkl. Nullleiterstrommessung. Einfache Netzanalysen werden von der EL3453 bis zur 63. Harmonischen Oberschwingungsanalyse durchgeführt oder zur vereinfachten Diagnose im Power Quality Factor zusammengefasst. Der Oberschwingungsanteil kann wie alle Messwerte der Klemme über die Prozessdaten ausgelesen werden.
Quick-Links
Sehen Sie dazu auch
•
Grundlagen zur Funktion
•
Technische Daten
•
Objektbeschreibung und Parametrierung
•
Prozessdaten
•
Anwendungsbeispiele


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
EL3423
Technische Daten | EL3423
Anzahl Eingänge | 3 x Strom, 3 x Spannung
Technik | 3-phasige Energiemessung
Oversampling-Faktor | –
Distributed-Clocks | –
Aktualisierungsintervall | >10 s einstellbar
Messwerte | Energie, Leistung, Netzqualitätsfaktor (PowerQualityFactor)
Messspannung | max. 480 V AC 3~ (ULX-N: max. 277 V AC; max. 240 V DC)
Messstrom | max. 1 A (AC/DC), über Messwandler x A/1 A
Messfehler | 0,5 % bezogen auf den Messbereichsendwert (U/I), 1 % berechnete Werte
Updatezeit | netzsynchron
Frequenzbereich | 0 (Gleichstrom) und 12 … 400 Hz
Potenzialtrennung | 2500 V
Stromaufn. Powerkontakte | –
Stromaufnahme E-Bus | 120 mA typ.
Besondere Eigenschaften | auch einphasiger Betrieb möglich, Netzwächter-Funktionalität
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 75 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP20/beliebig
Zulassungen | CE
EL3443-00xx
Technische Daten | EL3443-0000 | EL3443-0010 | EL3443-0011 | EL3443-0013
Anzahl Eingänge | 3 x Strom, 3 x Spannung
Technik | 3-phasige Leistungsmessung
Oversampling-Faktor | –
Distributed-Clocks | Optional (zur Nulldurchgangszeitpunktbestimmung)
Aktivierungsintervall | eine Netzperiode (20 ms bei 50 Hz)
Messwerte | Strom, Spannung, Wirkleistung, Blindleistung, Scheinleistung, Wirkenergie, Blindenergie, Scheinenergie, cos φ, Frequenz, THD, Oberschwingung (bis zur 40. Oberschwingung), Netzqualitätsfaktor (PowerQualityFactor)
Messspannung | max. 480 V AC 3~ (ULX-N: max. 277 V AC; max. 240 V DC)
Messstrom | max. 1 A (AC/DC), über Messwandler x A/1 A | max. 5 A (AC/DC), über Messwandler x A/5 A | max. 100 mA (AC/DC), über Messwandler x A/100 mA | max. 333 mV (AC/DC), über Messwandler x A/333 mV
Messfehler | 0,3 % bezogen auf den Messbereichsendwert (U/I), 0,6 % berechnete Werte (siehe Dokumentation)
Frequenzbereich | 0 (Gleichstrom) und 12 … 400 Hz
Grenzfrequenz | 3000 Hz
Potenzialtrennung | 2500 V
Updatezeit | netzsynchron
Stromaufn. Powerkontakte | –
Stromaufnahme E-Bus | 120 mA typ.
Besondere Eigenschaften | auch einphasiger Betrieb möglich, Netzwächter-Funktionalität, präzise Spannungsnulldurchgangsbestimmung
Gewicht | ca. 75 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP20/beliebig
Zulassungen | CE
EL3453
Technische Daten | EL3453
Anzahl Eingänge | 4 x Strom, 3 x Spannung
Technik | 3-phasige Leistungsmessung
Oversampling-Faktor | –
Distributed-Clocks | optional (zur Nulldurchgangszeitpunktbestimmung)
Genauigkeit der Distributed Clocks | << 1 µs
Akktualisierungszeit | mit jeder Halbwelle (10 ms bei 50 Hz)
Messwerte | Strom, Spannung, Wirkleistung, Blindleistung, Scheinleistung, Wirkenergie, Blindenergie, Scheinenergie, Grundwellenleistungen und –Energien, cos φ, Frequenz, THD, Oberschwingung (bis zur 63. Oberschwingung), Netzqualitätsfaktor (PowerQualityFactor)
Messfehler | 0,3 % bezogen auf den Messbereichsendwert (U/I), 0,6 % berechnete Werte (siehe Dokumentation)
Nennbereich Spannung (Netzspannung) | entsprechend AC: 400 Veff (ULX-N) bzw. 690 Veff (ULX-ULY) (TN-Netz: 600 Veff)
Technischer Messbereich Spannung | 520 Veff (ULX-N) bzw. 897 Veff (ULX-ULY) gemeinsames Bezugspotenzial N/GND max. Zeit für Spannungen oberhalb von 500 Veff (ULX-N) bzw. 863 Veff (ULx-ULy): tmax < 10s *
Zulässige Überspannung | max. ±736 V (Scheitelwert, ULX-N, entspricht 520 Veff) bzw. max. ±1270 V (Scheitelwert, ULX-ULY, entspricht 897 Veff)*
Auflösung intern | 24 Bit
Eingangswiderstand Spannungspfad | typ. 1,5 MΩ
Nennbereich Strom | entsprechend AC:100mAeff;1 Aeff (default); 5 Aeff empfohlen über Messwandler x A AC/1 A AC
Technischer Messbereich Strom | 2,25 A (Scheitelwert, entspricht 1,59 Aeff ) bzw. 9,6 A (Scheitelwert, entspricht 6,8 Aeff )
Zulässiger Überstrom | max. ±10 A Scheitelwert, entspricht 7 Aeff * je Kanal und max. Summenstrom (I1+I2+I3+IN) ±20 A Scheitelwert, entspricht 14 Aeff *
Kurzzeitstromfestigkeit | 60 A (sinusförmig) für 1 Sek., der vorgeschaltete Einsatz von strombegrenzenden Stromwandlern wird empfohlen
Größte kurzzeitige Abweichung während einer festgelegten elektrischen Störprüfung | < ±0,5% vom MBE bei der Strommessung
Eingangswiderstand Strompfad | typ. 3 mΩ
Frequenzbereich | 15 … 400 Hz
Grenzfrequenz | 4000 Hz
Potenzialtrennung | 4500 V
Stromaufn. Powerkontakte | –
Stromaufnahme E-Bus | 260 mA typ.
Gewicht | ca. 100 g
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung |  | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage |  | IP20/beliebig
Zulassungen |  | CE
*) längerer Betrieb oberhalb des Nennbereichs kann zur Beeinträchtigung der Funktion und/oder Verkürzung der Lebensdauer führen
EL3483-00xx
Technische Daten | EL3483-0000 | EL3483-0060
Anzahl Eingänge | 3 x Spannung
Technik | 3-phasiger Netzwächter
Oversampling-Faktor | –
Distributed-Clocks | –
Aktualisierungsintervall | Zehn Netzperioden (200 ms bei 50 Hz)
Messwerte | digitale Schwellwerte und Netzqualitätsfaktor (PowerQualityFactor) | digitale Schwellwerte und Netzqualitätsfaktor (PowerQualityFactor), analoge Spannungsmessung
Messspannung | max. 480 V AC 3~ (ULX-N: max. 277 V AC; max. 240 V DC)
Messverfahren | True RMS, Echteffektivwertberechnung
Updatezeit | netzsynchron
Potenzialtrennung | 2500 V
Stromaufn. Powerkontakte | –
Stromaufnahme E-Bus | 120 mA typ.
Besondere Eigenschaften | Betrieb als Spannungswächter, Frequenzwächter und Phasenwächter, auch im einphasigen Betrieb möglich
Überwachungsfunktion | Phasenfolge, Phasenausfall, Phasenasymmetrie, Unter-/Überspannung (einstellbar)
Gewicht | ca. 75 g
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP20/beliebig
Zulassungen | CE


Grundlagen zur Funktion

Produktübersicht [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Messprinzip
Die EL3443 arbeitet mit 6 Analog/Digitalwandern zur Erfassung der Strom und Spannungsgrößen aller 3 Phasen.
Die Erfassung und Verarbeitung der 3 Phasen findet zeitsynchron in exakt gleicher Form statt. Im Folgenden wird die Signalverarbeitung für eine Phase beschrieben. Die Beschreibung gilt sinngemäß für alle 3 Phasen.
Verlauf von Spannung u und Strom i
Effektivwertberechnung
Über die Periodendauer T wird der Effektivwert für Spannung und Strom berechnet. Die Berechnungen erfolgen nach den Formeln:
u(t): Momentanwert der Spannung
i(t): Momentanwert des Stromes
n: Anzahl der gemessenen Werte
Die Momentanwerte für Strom und Spannung sind Tiefpass-gefiltert mit einer Grenzfrequenz von 2,5kHz bei der EL3443, EL3423 und EL3483.
Wirkleistungsmessung
Die EL34xx misst die Wirkleistung P nach der Gesetzmäßigkeit
P: Wirkleistung
n: Anzahl der Abtastungen
u(t): Augenblickswert der Spannung
i(t): Augenblickswert des Stromes
Verlauf der Leistung s(t)
Im ersten Schritt wird zu jedem Abtastzeitpunkt die Leistung s(t) berechnet:
Der Mittelwert wird jeweils über einer Periode gebildet.
Die Frequenz der Leistung ist doppelt so hoch wie die der entsprechenden Spannungen und Ströme.
Scheinleistungsmessung
In realen Netzen sind nicht alle Verbraucher rein ohmsch. Es kommt zu einer Phasenverschiebung zwischen Strom und Spannung. Die oben beschriebene Methodik zur Ermittlung der Effektivwerte von Spannung und Strom wird dadurch nicht beeinflusst.
Anders ist das bei der Wirkleistung: Das Produkt aus Effektivspannung und Effektivstrom ergibt hier die Scheinleistung.
Die Wirkleistung ist kleiner als die Scheinleistung.
S: Scheinleistung
P: Wirkleistung
Q: Blindleistung
φ: Phasenverschiebungswinkel
Verlauf u, i, p mit Phasenverschiebungswinkel (t) (t) (t)
In diesem Umfeld sind weiter Informationen über das Netz und seine Verbraucher von Bedeutung:
▪
Scheinleistung S
▪
Blindleistung Q
▪
Leistungsfaktor cos φ
Die EL3443 ermittelt die Werte:
▪
Effektivspannung U und Effektivstrom I
▪
Wirkleistung P und Wirkenergie E
▪
Scheinleistung S und Scheinenergie
▪
Blindleitung Q und Blindenergie
▪
Leistungsfaktor und Cos(φ)
▪
Verzerrungsfaktoren für Strom THDI und Spannung THDU
▪
Berechneter Nullleitereffektivstrom IN
▪
Spannungsunsymmetrie
▪
Power Quality Faktor (Details siehe unten)
▪
Im Operationsmodus „DC-Synchron“ steht auch die Distributed-Clocks-Zeit des Spannungsnulldurchgangs zur Verfügung.
Vorzeichen bei Leistungsmessung
Das Vorzeichen der (Grundwellen-)Wirkleistung P und des Leistungsfaktors cos φ gibt Auskunft über die Richtung des Energieflusses. Ein positives Vorzeichen signalisiert den motorischen Betrieb, das negative Vorzeichen einen generatorischen Betrieb.
Weiterhin gibt das Vorzeichen der Grundwellenblindleistung Q eine Auskunft über die Richtung der Phasenverschiebung zwischen Strom und Spannung. In der Abb. Vier-Quadranten-Darstellung Wirkleistung/Grundwellenblindleistung bei motorischen und generatorischen Betrieb wird dies in der Vier-Quadranten-Darstellung veranschaulicht. Im motorischen Betrieb (Quadrant I + IV) deutet eine positive Grundwellenblindleistung auf eine induktive Belastung hin, eine negative Grundwellenblindleistung entsprechend auf eine kapazitive Belastung. Die Information über ein kapazitives oder induktives Lastverhalten zeigt sich auch im Vorzeichen des Phasenwinkels φ, welcher auch schon in der EL3443 enthalten ist. Im generatorischen Betrieb (Quadrant II + III) wird ein induktiv wirkender Generator durch eine positive Grundwellenblindleistung dargestellt, ein kapazitiv wirkender Generator durch eine negative Grundwellenblindleistung.
Da die Geasmtblindleistung als die quadratische Differenz zwischen Schein- und Wirkleistung definiert ist, besitzt diese kein Vorzeichen. Bei der Gesamtwirkleistung sind Vorzeichen, wie oben beschrieben, definiert.
Vier-Quadranten-Darstellung Wirkleistung/Grundwellenblindleistung bei motorischen und generatorischen Betrieb
Frequenzmessung
Die EL34xx kann die Frequenz sowohl an einem Spannungs- als auch an einem Strompfad anliegenden Eingangssignals messen. Mit Hilfe der CoE-Objekte „Reference“ und „Frequency Source“ (F800:11 und F800:13) lässt sich einstellen, welche Frequenz als PDO ausgegeben werden soll.
Power Quality Faktor
Die EL34xx berechnet einen sogenannten PQF (Power Quality Faktor), der als Analogwert zwischen 1,0 und 0 die Qualität der Spannungsversorgung auf einen einzelnen Zahlenwert vereinfacht wiederspiegelt.
Zur Berechnung dieses Faktors werden die Messwerte, Frequenz, Effektivspannung, Verzerrungsfaktor und Spannungsunsymmetrie miteinander verrechnet und wie in der folgenden Abbildung zu sehen zusammengeführt.
Darstellung der Berechnung des Power Quality Faktors
Wie beim Zeitwert 120 zu sehen, ist die Berechnungsmethode so gewählt, dass auch sehr kurze Spannungseinbrüche einen deutlichen Signalausschlag hervorrufen.
Ab welchem Wert die Spannungsversorgung als „ausreichend gut“ anzusehen ist, ist stark von der angeschlossenen Applikation abhängig. Je empfindlicher die Applikation, desto höher sollte der minimale Grenzwert des PQFs gewählt werden.
Um den Power Quality Faktor auf ihr Versorgungsnetz anzupassen, müssen die nominale Spannung und Frequenz im CoE-Objekt „0xF801 PMX Total Settings PQF“ eingetragen werden. Dies kann auch über den Reiter „Settings“ geschehen, der alle wichtigen Einstellungsmöglichkeiten der Klemme bedienungsfreundlich zusammenfasst.
Spannungsnulldurchgang
Die EL3443, sowie die EL3453, besitzen die Fähigkeit den genauen Zeitpunkt eines Spannungsnulldurchgangs zu bestimmen. Damit dieser jedoch an eine übergeordnete Steuerung in sinnvoller Art und Weise übermitteln werden kann, müssen die Steuerung sowie die EtherCAT-Klemme über dieselbe Zeitbasis verfügen. Mit Hilfe der Distributed-Clocks-Technologie stellt ein EtherCAT-System eine solche gemeinsame Zeitbasis zur Verfügung (Details hierzu siehe in der EtherCAT-Systembeschreibung). Um diese nutzen zu können, muss die EL3443 sich im Betriebsmodus „DC-Synchron“ befinden, sowie der EtherCAT-Master die entsprechende Funktion unterstützen.
Sind diese Grundvoraussetzungen geschaffen, liefern die EL3443 und EL3453 den DC-Zeitpunkt des vorletzten Nulldurchgangs. Um eine genaue Zeitpunktbestimmung der Grundwelle möglich zu machen, muss das auszuwertende Spannungssignal erst gefiltert werden, was zwangsläufig eine Verzögerung mit sich bringt. Die EL3453 ermittelt neben dem Zeitpunkt des Spannungsnulldurchgangs auch die jeweiligen Stromnulldurchgänge.
Statistische Auswertung
Die EL34xx Klemmen produzieren neben den zyklischen Daten auch statistische Auswertungen über längere Zeiträume (einstellbar im CoE: „F803 PMX Time Settings“). Standardmäßig ist das „F803:12 Measurement Interval“ auf 15 Minuten eingestellt. Die hierfür in der Klemme vorhandene Uhr lässt sich über das CoE-Objekt „F803:13 Actual System Time“ nicht nur auslesen sondern auch aktiv beeinflussen. Je nach Anwendung kann es sinnvoll sein die Uhr regelmäßig mit einer externen Uhr zu synchronisieren. Standardmäßig wird die Uhr beim Systemstart einmalig anhand der lokalen Systemzeit des Windows unter Berücksichtigung der eingestellten Zeitzone, meist also UTC, gestellt.
Zusätzlich lässt sich das Intervall auch per „Reset Interval“ Ausgangsbit manuell bzw. aus der Applikation direkt neustarten, um beispielsweise eine Statistik über einen zeitlich variierenden Prozess zu erhalten.
Berechnung des Nullleiterstroms
Da die EL34xx Klemmen direkten Zugriff auf die Momentanwerte der Ströme aller drei Phasen haben, kann unter der Annahme, dass kein Strom dem System verloren geht (mit anderen Worten: der Differenzstrom ist gleich Null), der Nullleiterstrom berechnet bzw. abgeschätzt werden. Der so berechnete (also nicht gemessene) Stromwert wird im Index „F601:13 Calculated Neutral Line Current“ ausgegeben.
Da sich im ungünstigsten Fall hier alle Messabweichungen addieren, ist die maximale Messabweichung hier entsprechend höher.
Durch die zusätzliche Messmöglichkeit eines vierten Stromwertes in der EL3453 kann entweder der Differenzstrom oder der Nullleiterstrom berechnet werden. Der jeweils andere Strom lässt sich mit Hilfe des vierten Stromkanals direkt messtechnisch erfassen. Aufgrund der üblichen Größenverhältnisse und den entsprechenden Messabweichungen ist es jedoch deutlich sinnvoller, den Differenzstrom mit Hilfe eines Summenstromwandlers zu messen und den Neutralleiterstrom berechnen zu lassen. Weitere Information hierzu finden Sie im Kapitel Anwendungsbeispiele unter dem Abschnitt Leistungsmessung inklusive Differenzstrommessung.
Oberwellenberechnung
Die EL34xx Klemmen führen intern eine Oberwellenanalyse für alle Strom- und Spannungskanäle durch. Hierfür wird zu Beginn (separat von der Systemfrequenz) eine Grundwelle im Frequenzbereich von 45 bis 65 Hz ermittelt. Der ermittelte Frequenzwert ist für die Spannungsoberwellen beispielsweise über den Index 99 (plus Kanaloffset) der variablen Ausgangswerte auszulesen sowie die Amplitude in Volt über den Index 98. Ähnliches gilt für die Stromwerte – siehe „variable Ausgangswerte“.
Die eigentlichen Oberwellenmesswerte werden in Prozent der Grundwellenamplitude ausgegeben. Außerdem ist zu beachten, dass die 0-te Oberwelle den Gleichanteil des Signals angibt.


Stromwandler

Produktübersicht [image] Stromwandler
Stromwandler
Grundsätzlich ist die Auswahl der Stromwandler für die EL34xx nicht kritisch. Der Innenwiderstand im Strompfad der EL34xx ist so klein, dass er bei der Betrachtung der gesamten Widerstände der Stromschleife vernachlässigt werden kann. Die Wandler müssen einen Sekundär-Nennstrom von 1 A liefern können. Der Primär-Nennstrom Ipn kann beliebig gewählt werden. Die übliche zulässige Überlastung von 1.2 x Ipn ist für die EL34xx unproblematisch, kann aber zu geringen Mess-Ungenauigkeiten führen.
Genauigkeit
Beachten Sie, dass die Gesamtgenauigkeit des Aufbaues aus EL34xx und Stromwandlern, wesentlich von der Genauigkeitsklasse der Wandler abhängt.
Keine Zulassung als Verrechungszähler
Auch eine Anordnung mit einem Stromwandler der Klasse 0,5 oder besser ist nicht zulassungs- und beglaubigungsfähig. Die EL34xx ist kein zugelassener Verrechungszähler im Sinne der Norm für Elektrizitätszähler (DIN 43 856).
Hinweis
DC-Ströme bei der EL3453
DC-Ströme können zur Sättigung der internen Stromwandler und somit zu Messungenauigkeiten führen!
Stromarten
Die EL34xx kann beliebige Stromformen bis zu einem Grenzanteil von ca. 400 Hz messen. Da derartige Ströme häufig durch Wechselrichter erzeugt werden und Frequenzen von weniger als 50 Hz oder sogar einen DC-Anteil enthalten können, sollte in diesen Anwendungen ein elektronischer Wandler eingesetzt werden.
Überstrombegrenzungsfaktor FS
Der Überstrombegrenzungsfaktor FS eines Stromwandlers gibt an, bei welchem Vielfachen des primären Nennstroms der Stromwandler in die Sättigung geht, um die angeschlossenen Messgeräte zu schützen.
Hinweis
Achtung! Beschädigung des Gerätes möglich!
Die EL34xx-xxxx darf nicht dauerhaft mit mehr als in den Technischen Daten angegebenen Strömen belastet werden! Setzen Sie in Anlagen, in denen die Überstrombegrenzungsfaktoren der Wandler höhere Sekundärströme erlauben zusätzliche Zwischenwandler mit einem entsprechenden Übersetzungsverhältnis ein!
Hinweis
Achtung! Beschädigung des Gerätes möglich!
Die EL3453-xxxx darf nicht dauerhaft mit mehr als I1 + I2 + I3 + IN = 20 A Summenstrom über alle Kanäle belastet werden!
Schutz vor gefährlichen Berührungsspannungen
Im bestimmungsgemäßen Betrieb der EL34xx mit entsprechenden Stromwandlern kommt es zu keinen gefährlichen Spannungen. Die Sekundärspannung liegt im Bereich von einigen Volt. Folgende Fehlerfälle können jedoch zu hohen Spannungen führen:
▪
Offener Strompfad eines oder mehrerer Wandler
▪
Durchtrennter Nullleiter auf der Seite der Spannungsmessung der EL34xx
▪
Allgemeine Isolationsfehler
SmallWarningYellow WARNUNG
WARNUNG! Verletzungsgefahr durch Stromschlag!
Die gesamte Verdrahtung der EL34xx muss berührungsgeschützt ausgeführt und mit den entsprechenden Warnhinweisen versehen werden! Legen Sie die Isolierung für die maximale Leiterspannung des zu messenden Netzes aus!
Die EL34xx lässt eine maximale Spannung von 480 V für normale Betriebsbedingungen zu. Die Leiterspannung auf der Stromseite darf diesen Wert nicht überschreiten! Verwenden Sie für höhere Spannungen eine Zwischenwandlerstufe!
Ein EL34xx ist auf der Seite der Spannungsmessung mit einer Schutzimpedanz von 1,2 MΩ ausgestattet. Wenn der Nullleiter nicht angeschlossen ist und nur ein Anschluss auf der Seite der Spannungsmessung unter Spannung steht, ergibt sich in einem 3-Phasen-Netz mit einer Außenleiterspannung von 400 VAC eine Spannung von 230 VAC gegen Erde. Diese ist mit einem Multimeter mit 10 MΩ Innenwiderstand auch auf der Seite der Strommessung zu messen, was keinen Isolationsfehler darstellt.
Anschlusskabel für Stromwandler
Bitte beachten Sie die im Folgenden aufgeführten Mindestleistungswerte für anzuschließende Stromwandler:
 | Sekundär Wandlernennstrom
 | 1 A | 1 A | 1 A | 1 A | 5 A | 5 A | 5 A | 5 A
Querschnitt | 0,5 mm² | 1 mm² | 1,5 mm² | 2,5 mm² | 0,5 mm² | 1 mm² | 1,5 mm² | 2,5 mm²
1 m | 0,3 | 0,2 | 0,2 | 0,2 | 2,4 | 1,3 | 0,9 | 0,6
2 m | 0,4 | 0,3 | 0,3 | 0,2 | 4,6 | 2,4 | 1,7 | 1,1
3 m | 0,5 | 0,3 | 0,3 | 0,3 | 6,8 | 3,5 | 2,4 | 1,5
4 m | 0,6 | 0,4 | 0,3 | 0,3 | 9,0 | 4,6 | 3,1 | 2,0
5 m | 0,6 | 0,4 | 0,3 | 0,3 | 11,2 | 5,7 | 3,9 | 2,4
10 m | 1,1 | 0,6 | 0,5 | 0,4 | 22,2 | 11,2 | 7,5 | 4,6
20 m | 2,0 | 1,1 | 0,8 | 0,6 | 44,2 | 22,2 | 14,9 | 9,0
30 m | 2,8 | 1,5 | 1,1 | 0,7 | 66,2 | 33,2 | 22,2 | 13,4
40 m | 3,7 | 2,0 | 1,4 | 0,9 | 88,2 | 44,2 | 29,5 | 17,8
50 m | 4,6 | 2,4 | 1,7 | 1,1 | 110,2 | 55,2 | 36,9 | 22,2
100 m | 9,0 | 4,6 | 3,1 | 2,0 | 220,2 | 110,2 | 73,5 | 44,2
Kabellänge | Minimale Betriebsbürde in VA für Stromwandler bei Kupferkabeln mit 80°C Betriebstemperatur
Zusätzliche Messgeräte im Strompfad
Beachten Sie, dass sich durch das Hinzufügen zusätzlicher Messgeräte (z. B. Amperemeter) in den Strompfad die Gesamtscheinleistung deutlich erhöhen kann.
Außerdem muss der Anschluss IN der EL34xx einen Sternpunkt für die drei Sekundärwicklungen darstellen. Zusätzliche Messgeräte müssen deshalb potentialfrei sein und entsprechend verdrahtet werden.


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL34xx wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EL34xx in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Anschluss
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
EL34xx - LEDs und Anschlussbelegung


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


EL34xx - LEDs und Anschlussbelegung

Montage und Verdrahtung [image] EL34xx - LEDs und Anschlussbelegung
EL34xx - LEDs und Anschlussbelegung
SmallWarningYellow WARNUNG
Vorsicht: Verletzungsgefahr durch Stromschlag!
Wenn Sie die Klemmstelle N nicht mit dem Nulleiter Ihres Versorgungsnetzes verbinden (z. B. bei Verwendung der EL3443/EL3453 zur reinen Strommessung), müssen Sie die Klemmstelle N erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!
SmallWarningYellow WARNUNG
Vorsicht: Verletzungsgefahr durch Stromschlag!
Beachten Sie, dass die Stromwandler vieler Hersteller nicht im Leerlauf betrieben werden dürfen! Schließen Sie die EL3443/EL3453 an die Sekundärwicklung der Stromwandler an, bevor Sie die Stromwandler in Betrieb nehmen!
EL3423 – LEDs und Anschlussbelegung
EL3423 LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
SystemOK | grün | an | System OK,
L1 - L3 OK | grün | an | Spannung im normalen Bereich L1 [image] L2 [image] L3
 |  | blinkt | Spannung im kritischen Bereich (Warnschwelle überschritten – Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
 |  | aus | Spannung an L1 im nicht zulässigen Bereich (Fehlerschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
L1 - L3 Error | rot | an
Klemmstelle |  | Beschreibung | Kommentar
Bezeichnung | Nr.
L1 | 1 | Phase L1 | Anschlüsse für die Spannungsmessung Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag! "
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Null-Leiter N (intern verbunden mit Klemmstelle 8)
IL1 | 5 | Verbraucher an Phase L1 | Anschlüsse für die Stromwandler. Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag!"
IL2 | 6 | Verbraucher an Phase L2
IL3 | 7 | Verbraucher an Phase L3
N | 8 | Null-Leiter N (intern verbunden mit Klemmstelle 4)
EL3443 – LEDs und Anschlussbelegung
EL3443 LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
SystemOK | grün | an | System OK,
L1 - L3 OK | grün | an | Spannung im normalen Bereich L1 [image] L2 [image] L3
 |  | blinkt | Spannung im kritischen Bereich (Warnschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
 |  | aus | Spannung an L1 im nicht zulässigen Bereich (Fehlerschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
L1 - L3 Error | rot | an
Klemmstelle |  | Beschreibung | Kommentar
Bezeichnung | Nr.
L1 | 1 | Phase L1 | Anschlüsse für die Spannungsmessung Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag! "
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Null-Leiter N (intern verbunden mit Klemmstelle 8)
IL1 | 5 | Verbraucher an Phase L1 | Anschlüsse für die Stromwandler. Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag!"
IL2 | 6 | Verbraucher an Phase L2
IL3 | 7 | Verbraucher an Phase L3
N | 8 | Null-Leiter N (intern verbunden mit Klemmstelle 4)
EL3453 – LEDs und Anschlussbelegung
EL3453 LED's
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
SystemOK | grün | an | System OK,
L1 - L3 OK | grün | an | Rechtes Prisma: Spannung im normalen Bereich L1 [image] L2 [image] L3
 |  | blinkt | Rechtes Prisma: Spannung im kritischen Bereich (Warnschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
 |  | aus | Rechtes Prisma: Spannung an L1 im nicht zulässigen Bereich (Fehlerschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
L1 - L3 Error | rot | an
IL1 - IL3 OK | grün | An | Linkes Prisma: Strom im normalen Bereich IL1 [image] IL2 [image] IL3 [image] IN
 |  | blinkt | Linkes Prisma: Strom im kritischen Bereich (Warnschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) IL1 [image] IL2 [image] IL3 [image] IN
 |  | aus | Linkes Prisma: Strom an IL1 im nicht zulässigen Bereich (Fehlerschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) IL1 [image] IL2 [image] IL3 [image] IN
IL1 - IL3 Error | rot | an
Klemmstelle |  | Beschreibung | Kommentar
Bezeichnung | Nr.
IL1 | 1 | Eingang Strommessung der Phase L1 | Anschlüsse für die Stromwandler. Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag!"
IL2 | 2 | Eingang Strommessung der Phase L2
IL3 | 3 | Eingang Strommessung der Phase L3
IN | 4 | Eingang Strommessung des Neutralleiters (Sternpunkt)
IL1‘ | 5 | Ausgang Strommessung der Phase L1
IL2‘ | 6 | Ausgang Strommessung der Phase L2
IL3‘ | 7 | Ausgang Strommessung der Phase L2
IN‘ | 8 | Ausgang Strommessung des Neutralleiters (Sternpunkt)
L1 | 1‘ | Phase L1 | Anschlüsse für die Spannungsmessung: Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag!"
 | 2‘ | n.c.
L3 | 3‘ | Phase L3
N | 4‘ | Null-Leiter N (intern verbunden mit Klemmstelle 8‘)
 | 5‘ | n.c.
L2 | 6‘ | Phase L2
 | 7‘ | n.c.
N | 8‘ | Null-Leiter N (intern verbunden mit Klemmstelle 4‘)
EL3483 – LEDs und Anschlussbelegung
EL3483 LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
SystemOK | grün | an | System OK,
L1 - L3 OK | grün | an | Spannung im normalen Bereich L1 [image] L2 [image] L3
 |  | blinkt | Spannung im kritischen Bereich (Warnschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
 |  | aus | Spannung an L1 im nicht zulässigen Bereich (Fehlerschwelle überschritten - Guard Settings siehe CoE Objekt 0x80n1) L1 [image] L2 [image] L3
L1 - L3 Error | rot | an
Klemmstelle |  | Beschreibung | Kommentar
Bezeichnung | Nr.
L1 | 1 | Phase L1 | Anschlüsse für die Spannungsmessung Beachten Sie die Warnhinweise oben " Vorsicht: Verletzungsgefahr durch Stromschlag! "
L2 | 2 | Phase L2
L3 | 3 | Phase L3
N | 4 | Null-Leiter N


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Prozessdaten
•
Skalierungsfaktoren
•
Hinweise zu analogen Spezifikationen
•
Objektbeschreibung und Parametrierung


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Prozessdaten

Inbetriebnahme [image] Prozessdaten
Prozessdaten
Weiterführende Informationen
•
Sync Manager
•
Einstellungen
•
Timestamp Distributed Clocks


Sync Manager

Inbetriebnahme [image] Prozessdaten [image] Sync Manager
Sync Manager
Der Umfang der angebotenen Prozessdaten kann über den Reiter „Process data“ eingesehen werden.
Die folgenden Abbildungen zeigen beispielhaft die zugeordneten Eingangsprozessdatenobjekte (PDO) des Sync-Manager (SM3) der EL34xx.
Karteireiter Prozessdaten SM3, EL3423
Karteireiter Prozessdaten SM3, EL3443
Karteireiter Prozessdaten SM3, EL3453
Karteireiter Prozessdaten SM3, EL3483
Predefined PDO Assignment
Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Folgende PDO-Zuordnungen stehen zur Auswahl:
EL3423
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Default | - | 0x1A00 (L1 Status) 0x1A03 (L1 Energy) 0x1A0A (L2 Status) 0x1A0D (L2 Energy) 0x1A14 (L3 Status) 0x1A17 (L3 Energy) 0x1A1E (Total Total Status) 0x1A21 (Total Total Active) 0x1A22 (Total Total Apparent) 0x1A23 (Total Total Reactive)
Default + Statistics | - | 0x1A00 (L1 Status) 0x1A03 (L1 Energy) 0x1A06 (L1 Statistic Voltage) 0x1A0A (L2 Status) 0x1A0D (L2 Energy) 0x1A10 (L2 Statistic Voltage) 0x1A14 (L3 Status) 0x1A17 (L3 Energy) 0x1A1A (L3 Statistic Voltage) 0x1A1E (Total Total Status) 0x1A20 (Total Total Advanced) 0x1A26 (Total Total Statistic Power) 0x1A27 (Total Total Statistic PQF) 0x1A28 (Total Total Interval Energy)
EL3443
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Default | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A04 (L1 Timing) 0x1A0A (L2 Status) 0x1A0B (L2 Basic) 0x1A0C (L2 Power) 0x1A0E (L2 Timing) 0x1A14 (L3 Status) 0x1A15 (L3 Basic) 0x1A16 (L3 Power) 0x1A18 (L3 Timing)) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A21 (Total Total Active) 0x1A24 (Total Total L-L Voltage)
Default + Variant | 0x1600 (Total Outputs Device) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A04 (L1 Timing) 0x1A0A (L2 Status) 0x1A0B (L2 Basic) 0x1A0C (L2 Power) 0x1A0E (L2 Timing) 0x1A14 (L3 Status) 0x1A15 (L3 Basic) 0x1A16 (L3 Power) 0x1A18 (L3 Timing) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A25 (Total Variant Value In)
Advanced | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A03 (L1 Energy) 0x1A04 (L1 Timing) 0x1A0A (L2 Status) 0x1A0B (L2 Basic) 0x1A0C (L2 Power) 0x1A0D (L2 Energy) 0x1A0E (L2 Timing) 0x1A14 (L3 Status) 0x1A15 (L3 Basic) 0x1A16 (L3 Power) 0x1A17 (L3 Energy) 0x1A18 (L3 Timing) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A20 (Total Total Advanced) 0x1A21 (Total Total Active)
Total Only | 0x1600 (Total Outputs Device) | 0x1A00 (L1 Status) 0x1A0A (L2 Status) 0x1A14 (L3 Status) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A20 (Total Total Advanced) 0x1A21 (Total Total Active) 0x1A22 (Total Total Apparent) 0x1A23 (Total Total Reactive) 0x1A24 (Total Total L-L Voltage) 0x1A25 (Total Variant Value In) 0x1A26 (Total Total Statistic Power) 0x1A27 (Total Total Statistic PQF) 0x1A28 (Total Total Interval Energy)
Classic | 0x1600 (Total Outputs Device) | 0x1A00 (L1 Status) 0x1A09 (L1 Classic) 0x1A0A (L2 Status) 0x1A13 (L2 Classic) 0x1A14 (L3 Status) 0x1A1D (L3 Classic) 0x1A1E (Total Total Status)
Single Phase | 0x1600 (Total Outputs Device) 0x1601 (Total Interval) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A03 (L1 Energy) 0x1A04 (L1 Timing) 0x1A06 (L1 Statistic Voltage) 0x1A1E (Total Total Status) 0x1A1F (Total Total Basic) 0x1A25 (Total Variant Value In) 0x1A28 (Total Total Interval Energy)
EL3453
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Default | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A0C (L2 Status) 0x1A0D (L2 Basic) 0x1A0E (L2 Power) 0x1A18 (L3 Status) 0x1A19 (L3 Basic) 0x1A1A (L3 Power) 0x1A24 (Total Status) 0x1A25 (Total Basic)
Default + Variant | 0x1600 (Total Variant Value Out) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A0C (L2 Status) 0x1A0D (L2 Basic) 0x1A0E (L2 Power) 0x1A18 (L3 Status) 0x1A19 (L3 Basic) 0x1A1A (L3 Power) 0x1A24 (Total Status) 0x1A25 (Total Basic) 0x1A2E (Total Variant Value In)
Advanced | - | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A07 (L1 Advanced) 0x1A0C (L2 Status) 0x1A0D (L2 Basic) 0x1A0E (L2 Power) 0x1A13 (L2 Advanced) 0x1A18 (L3 Status) 0x1A19 (L3 Basic) 0x1A1A (L3 Power) 0x1A1F (L3 Advanced) 0x1A24 (Total Status) 0x1A25 (Total Basic) 0x1A26 (Total Advanced)
Total Only | 0x1600 (Total Variant Value Out) | 0x1A00 (L1 Status) 0x1A0C (L2 Status) 0x1A18 (L3 Status) 0x1A24(Total Status) 0x1A25 (Total Basic) 0x1A26(Total Advanced) 0x1A27(Active) 0x1A29 (Total Apparent) 0x1A2B (Total Reactive) 0x1A2E (Total Variant Value In)
Classic | 0x1600 (Total Variant Value Out) | 0x1A00 (L1 Status) 0x1A0B (L1 Classic) 0x1A0C (L2 Status) 0x1A17 (L2 Classic) 0x1A18 (L3 Status) 0x1A23 (L3 Classic) 0x1A2E (Total Variant Value In)
Single Phase | 0x1600 (Total Outputs Device) 0x1601 (Total Interval) | 0x1A00 (L1 Status) 0x1A01 (L1 Basic) 0x1A02 (L1 Power) 0x1A06 (L1 Timing) 0x1A07 (L1 Advanced) 0x1A24 (Total Status)
EL3483
Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Default | - | 0x1A00 (L1 Status) 0x1A0A (L2 Status) 0x1A14 (L3 Status) 0x1A1E (Total Total Status) 0x1A20 (Total Total Advanced)


Einstellungen

Inbetriebnahme [image] Prozessdaten [image] Einstellungen
Einstellungen
Karteireiter „Settings“
Karteireiter "Settings"
Der Karteireiter „Settings“ ermöglicht den direkten Zugriff auf die wichtigsten Konfigurationsobjekte im Objektdatenverzeichnis und dient zur vereinfachten Konfiguration der Klemme.
Über den Import/Export-Knopf lassen sich einmal getroffene Einstellungen speichern und gezielt erneut laden.
Bestätigung der variablen Ausgabewerte 1 - 4
(PDOs: PMX Variant Value In, Subindex „Index“ [0xF60A:12, 0xF60A:14, 0xF60A:16, 0xF60A:18])
Die berechneten Werte können auf den PDOs: PMX Variant Value In, Subindex „Variant value In“ [0xF60A:12, 0xF60A:14, 0xF60A:16, 0xF60A:18] ausgegeben werden.
Dazu sind in die PDOs: PMX Variant Value Out, Subindex „PMX Variant Value Out“ [0xF700:11, 0xF700:12, 0xF700:13, 0xF700:14] die entsprechenden Werte für die auszugebende Messgröße einzutragen.
Zuordnung der variablen Ausgabewerte jeweils plus Kanal-Offset (256 für Kanal 1; 512 für Kanal 2 bzw. 768 für Kanal 3)
Werte (dez), Eintrag in PDOs: PMX Variant Value In Index 1-3 REAL [0xF700:11, 0xF700:12, 0xF700:13] | Werte (dez), Eintrag in PDOs: PMX Variant Value In Index 4 ULINT [0xF700:14] | Bezeichnung | Einheit | Beschreibung
1 (Bsp: 257 = 1 + 256 für Kanal 1) | - | U RMS | V | Effektivwert der Spannung
2 (Bsp: 770 = 2 + 768 für Kanal 3) | - | U peak | V | Höchster Spitzenwert der Momentanspannung im letzten Intervall
- | 3 | U Last Zero Cross | ns | DC-Zeitpunkt des letzten Spannungsnulldurchgangs
4 | - | U RMS Minimum | V | Kleinster Effektivwert der Spannung im letzten Intervall
5 | - | U RMS Maximum | V | Größter Effektivwert der Spannung im letzten Intervall
6 | - | ULL | V | Effektivwert der Außenleiterspannung (Kanal1: U_L1L2; Kanal1: U_L2L3; Kanal3: U_L3L1)
8 | - | I RMS | A | Effektivwert des Stroms
9 | - | I peak | A | Höchster Spitzenwert des Momentanstroms im letzten Intervall
- | 10* | I Last Zero Cross | ns | DC-Zeitpunkt des letzten Stromsnulldurchgangs
11 | - | I RMS Minimum | A | Kleinster Effektivwert des Stroms im letzten Intervall
12 | - | I RMS Maximum | A | Größter Effektivwert des Stroms im letzten Intervall
17 | - | Frequency | Hz | Frequenz dieser Phase
21 | - | Phi | ° | Phasenwinkel zwischen Spannung und Strom
22 | - | Cos phi | - | Kosinus des Grundwellenphasenwinkels
23 | - | Power Factor | - | Leistungsfaktor
26 | - | P | W | Wirkleistung
27 | - | Pavg | W | Wirkleistungsdurchschnitt des letzten Intervalls
28 | - | Pmin | W | Wirkleistungsminimum im letzten Intervall
29 | - | Pmax | W | Wirkleistungsmaximum im letzten Intervall
30* | - | Pfund | W | Grundwellenwirkleistung im letzten Intervall
32 | - | S | VA | Scheinleistung
33 | - | Savg | VA | Scheinleistungsdurchschnitt des letzten Intervalls
34 | - | Smin | VA | Scheinleistungsminimum im letzten Intervall
35 | - | Smax | VA | Scheinleistungsmaximum im letzten Intervall
36* | - | Sfund | VA | Grundwellenscheinleistung im letzten Intervall
38 | - | Q | Var | Blindleistung
39 | - | Qavg | Var | Blindleistungsdurchschnitt des letzten Intervalls
40 | - | Qmin | Var | Blindleistungsminimum im letzten Intervall
41 | - | Qmax | Var | Blindleistungsmaximum im letzten Intervall
42* | - | Qfund | Var | Grundwellenblindleistung im letzten Intervall
- | 45 | EP | mWh | Bilanzierte Wirkenergie
- | 46 | EP pos | mWh | Bezogene Wirkenergie
- | 47 | EP neg | mWh | Eingespeiste Wirkenergie
- | 51 | ES | mWh | Scheinenergie
- | 52 | ES pos | mWh |
- | 53 | ES neg | mWh |
- | 57 | EQ | mWh | Blindenergie
- | 58 | EQ pos | mWh |
- | 59 | EQ neg | mWh |
- | 63* | EP_fund | mWh | Bilanzierte Grundwellenwirkenergie
- | 64* | EP pos_fund | mWh | Bezogene Grundwellenwirkenergie
- | 65* | EP neg_fund | mWh | Eingespeiste Grundwellenwirkenergie
- | 69* | ES _fund | mWh | Grundwellenscheinenergie
- | 70* | ES pos_fund | mWh |
- | 71* | ES neg_fund | mWh |
- | 75* | EQ _fund | mWh | Bilanzierte Grundwellenblindenergie
- | 76* | EQ pos_fund | mWh | Induktive Grundwellenblindenergie
- | 77* | EQ neg_fund | mWh | Kapazitive Grundwellenblindenergie
95 | - | THD_U | - | „Total Harmonic Distortion“ ist der Verzerrungsfaktor der Spannung und gibt das Verhältnis der harmonischen Anteile einer Schwingung zur ihrer Grundschwingung an.
98 | - | RMS_fund_U | V | Amplitude der Grundwelle
99 | - | F_Ref_U | Hz | Bezugsfrequenz der Spannungsharmonischen: Gibt die zugrundliegende Grundwellenfrequenz an, z.B.: 50 bzw. 60Hz.
100 -141 -163* | - | Harmonics U 0 bis 41 Bis 63* | % der Grundwelle | 0 => Gleichanteil 1 => Grundwelle 2=> 2-te Oberwelle 3=> 3-te Oberwelle
165 | - | THD_I | - | „Total Harmonic Distortion“ ist der Verzerrungsfaktor des Stroms und gibt das Verhältnis der harmonischen Anteile einer Schwingung zur ihrer Grundschwingung an.
166 | - | TDD_I | % vom Maximalstrom | „Total Demand Distortion“ gibt das Verhältnis zwischen den Stromoberschwingungen und dem Maximalstrom an (EL3443: 1A und EL3443-0010: 5A)
168 | - | RMS_fund_I | A | Amplitude der Grundwelle
169 | - | F_Ref_I | Hz | Bezugsfrequenz der Stromharmonischen: Gibt die zugrundliegende Grundwellenfrequenz an, z.B.: 50 bzw. 60Hz.
170 -211 -233* | - | Harmonics I 0 bis 41 Bis 63* | % der Grundwelle | 0 => Gleichanteil 1 => Grundwelle 2=> 2-te Oberwelle 3=> 3-te Oberwelle
255 | - | Error: INDEX not valid | - | Fehlermeldung: Gewählter Index ist nicht verfügbar.
Werte mit Stern* sind nur in der EL3453 verfügbar.
Zuordnung der variablen Ausgabewerte für übergeordnete Werte
Werte (dez), Eintrag in PDOs: PMX Variant Value In Index 1-3 REAL [0xF700:11, 0xF700:12, 0xF700:13] | Werte (dez), Eintrag in PDOs: PMX Variant Value In Index 4 ULINT [0xF700:14] | Bezeichnung | Einheit | Beschreibung
1032 (= 1024 + 8) | - | In RMS | A | Berechneter Effektivwert des Nullleiterstroms
1033 (= 1024 + 9)* | - | In peak | A | Höchster Spitzenwert des Momentanstroms im letzten Intervall
1035 (= 1024 + 11)* | - | In RMS Minimum | A | Kleinster Effektivwert des Stroms im letzten Intervall
1036 (= 1024 + 12)* | - | In RMS Maximum | A | Größter Effektivwert des Stroms im letzten Intervall
1041 (= 1024 + 17)* | - | Frequency | Hz | Frequenz des per CoE eingestellten PDO-Wertes (siehe Bezugskanal der Frequenzmessung)
1047 (= 1024 + 23) | - | Power Factor | - | Gesamtleistungsfaktor über alle Phasen
1050 (= 1024 + 26) | - | Ptot | W | Gesamtwirkleistung
1051 (= 1024 + 27) | - | Ptotavg | W | Gesamtwirkleistungsdurchschnitt des letzten Intervalls
1052 (= 1024 + 28) | - | Ptotmin | W | Gesamtwirkleistungsminimum im letzten Intervall
1053 (= 1024 + 29) | - | Ptotmax | W | Gesamtwirkleistungsmaximum im letzten Intervall
1056 (= 1024 + 32) | - | Stot | VA | Gesamtscheinleistung
1057 (= 1024 + 33) | - | Stotavg | VA | Gesamtscheinleistungsdurchschnitt des letzten Intervalls
1058 (= 1024 + 34) | - | Stotmin | VA | Gesamtscheinleistungsminimum im letzten Intervall
1059 (= 1024 + 35) | - | Stotmax | VA | Gesamtscheinleistungsmaximum im letzten Intervall
1062 (= 1024 + 38) | - | Qtot | Var | Gesamtblindleistung
1063 (= 1024 + 39) | - | Qtotavg | Var | Gesamtblindleistungsdurchschnitt des letzten Intervalls
1064 (= 1024 + 40) | - | Qtotmin | Var | Gesamtblindleistungsminimum im letzten Intervall
1065 (= 1024 + 41) | - | Qtotmax | Var | Gesamtblindleistungsmaximum im letzten Intervall
- | 1069 (= 1024 + 45) | Eptot | mWh | Bilanzierte Gesamtwirkenergie
- | 1070 (= 1024 + 46) | EPtot pos | mWh | Bezogene Gesamtwirkenergie
- | 1071 (= 1024 + 47) | EPtot neg | mWh | Eingespeiste Gesamtwirkenergie
- | 1072 (= 1024 + 48) | Eptot_intervall | mWh | Bilanzierte Gesamtwirkenergie im letzten Intervall
- | 1073 (= 1024 + 49) | EPtot pos_intervall | mWh | Bezogene Gesamtwirkenergie im letzten Intervall
- | 1074 (= 1024 + 50) | EPtot neg_intervall | mWh | Eingespeiste Gesamtwirkenergie im letzten Intervall
- | 1075 (= 1024 + 51) | EStot | mWh | Gesamtscheinenergie
- | 1076 (= 1024 + 52) | EStot pos | mWh |
- | 1077 (= 1024 + 53) | EStot neg | mWh |
- | 1078 (= 1024 + 54) | EStot_intervall | mWh | Gesamtscheinenergie im letzten Intervall
- | 1079 (= 1024 + 55) | EStot pos_intervall | mWh |
- | 1080 (= 1024 + 56) | EStot neg_intervall | mWh |
- | 1081 (= 1024 + 57) | EQtot | mWh | Gesamtblindenergie
- | 1082 (= 1024 + 58) | EQtot pos | mWh |
- | 1083 (= 1024 + 59) | EQtot neg | mWh |
- | 1084 (= 1024 + 60) | EQtot_intervall | mWh | Gesamtblindenergie im letzten Intervall
- | 1085 (= 1024 + 61) | EQtot pos_intervall | mWh |
- | 1086 (= 1024 + 62) | EQtot neg_intervall | mWh |
1094 (= 1024 + 70) | - | PhiL1L2 | ° | Phasenverschiebungswinkel zwischen Phase L1 und L2
1095 (= 1024 + 71) | - | PhiL1L3 | ° | Phasenverschiebungswinkel zwischen Phase L1 und L3
1096 (= 1024 + 72) | - | Unbalance | - | Verhältnis zwischen Gegen- und Mitsystem der Spannungen
1104 (= 1024 + 80) | - | PQF | - | Power Quality Faktor
1105 (= 1024 + 81) | - | PQF Avg | - | Durchschnittswert des Power Quality Faktors im letzten Intervall
1106 (= 1024 + 82) | - | PQF Min | - | Minimum des Power Quality Faktors im letzten Intervall
1107 (= 1024 + 83) | - | PQF Max | - | Maximum des Power Quality Faktors im letzten Intervall
- | 1124 (= 1024 + 100)* | Eptot_fund | mWh | Bilanzierte Gesamtgrundwellenwirkenergie
- | 1125 (= 1024 + 101)* | EPtot_fund pos | mWh | Bezogene Gesamtgrundwellenwirkenergie
- | 1126 (= 1024 + 102)* | EPtot_fund neg | mWh | Eingespeiste Gesamtgrundwellenwirkenergie
- | 1127 (= 1024 + 103)* | Eptot_fund _intervall | mWh | Bilanzierte Gesamtgrundwellenwirkenergie im letzten Intervall
- | 1128 (= 1024 + 104)* | EPtot_fund pos_intervall | mWh | Bezogene Gesamtgrundwellenwirkenergie im letzten Intervall
- | 1129 (= 1024 + 105)* | EPtot_fund neg_intervall | mWh | Eingespeiste Gesamtgrundwellenwirkenergie im letzten Intervall
- | 1130 (= 1024 + 106)* | EStot_fund | mWh | Gesamtgrundwellenscheinenergie
- | 1131 (= 1024 + 107)* | EStot_fund pos | mWh |
- | 1132 (= 1024 + 108)* | EStot_fund neg | mWh |
- | 1133 (= 1024 + 109)* | EStot_fund _intervall | mWh | Gesamtgrundwellenscheinenergie im letzten Intervall
- | 1134 (= 1024 + 110)* | EStot_fund pos_intervall | mWh |
- | 1135 (= 1024 + 111)* | EStot_fund neg_intervall | mWh |
- | 1136 (= 1024 + 112)* | EQtot_fund | mWh | Bilanzierte Gesamtgrundwellenblindenergie
- | 1137 (= 1024 + 113)* | EQtot_fund pos | mWh | Induktive Gesamtgrundwellenblindenergie
- | 1138 (= 1024 + 114)* | EQtot_fund neg | mWh | Kapazitive Gesamtgrundwellenblindenergie
- | 1139 (= 1024 + 115)* | EQtot_fund _intervall | mWh | Bilanzierte Gesamtgrundwellenblindenergie im letzten Intervall
- | 1140 (= 1024 + 116)* | EQtot_fund pos_intervall | mWh | Induktive Gesamtgrundwellenblindenergie im letzten Intervall
- | 1141 (= 1024 + 117)* | EQtot_fund neg_intervall | mWh | Kapazitive Gesamtgrundwellenblindenergie im letzten Intervall
1154 (= 1024 + 130)* | - | Ptot_fund | W | Gesamtgrundwellenwirkleistung
1155 (= 1024 + 131)* | - | Ptotavg_fund | W | Gesamtgrundwellenwirkleistungsdurchschnitt des letzten Intervalls
1156 (= 1024 + 132)* | - | Ptotmin_fund | W | Gesamtgrundwellenwirkleistungsminimum im letzten Intervall
1157 (= 1024 + 133)* | - | Ptotmax_fund | W | Gesamtgrundwellenwirkleistungsmaximum im letzten Intervall
1160 (= 1024 + 136)* | - | Stot_fund | VA | Gesamtgrundwellenscheinleistung
1161 (= 1024 + 137)* | - | Stotavg_fund | VA | Gesamtgrundwellenscheinleistungsdurchschnitt des letzten Intervalls
1162 (= 1024 + 138)* | - | Stotmin_fund | VA | Gesamtgrundwellenscheinleistungsminimum im letzten Intervall
1163 (= 1024 + 139)* | - | Stotmax_fund | VA | Gesamtgrundwellenscheinleistungsmaximum im letzten Intervall
1166 (= 1024 + 142)* | - | Qtot_fund | Var | Gesamtgrundwellenblindleistung
1167 (= 1024 + 143)* | - | Qtotavg_fund | Var | Gesamtgrundwellenblindleistungsdurchschnitt des letzten Intervalls
1168 (= 1024 + 144)* | - | Qtotmin_fund | Var | Gesamtgrundwellenblindleistungsminimum im letzten Intervall
1169 (= 1024 + 145)* | - | Qtotmax_fund | Var | Gesamtgrundwellenblindleistungsmaximum im letzten Intervall
Werte mit Stern* sind nur in der EL3453 verfügbar.
Bezugskanal der Frequenzmessung (Index 0xF800:11 und Index 0xF800:13)
Die EL34xx kann die Frequenz sowohl an einem Spannungs- als auch an einem Strompfad anliegenden Eingangssignals messen. Mit Hilfe der CoE-Objekte „Reference“ und „Frequency Source“ (F800:11 und F800:13) lässt sich einstellen, welche Frequenz als PDO ausgegeben werden soll.
Standardwert: Spannung an Kanal 1
Einstellung zum Power Quality Faktor
Um den Power Quality Faktor auf ihr Versorgungsnetz anzupassen, müssen die nominale Spannung und Frequenz im CoE-Objekt „0xF801 PMX Total Settings PQF“ eingetragen werden. Dies kann auch über den Reiter „Settings“ geschehen, der alle wichtigen Einstellungsmöglichkeiten der Klemme bedienungsfreundlich zusammenfasst.


Timestamp Distributed Clocks

Inbetriebnahme [image] Prozessdaten [image] Timestamp Distributed Clocks
Timestamp Distributed Clocks
Die Klemme übergibt den Zeitpunkt des Spannungsnulldurchgangs als Timestamp auf die Objekte 0x6006:12 (Kanal 1), 0x6016:12 (Kanal 2) bzw. 0x6026:12 (Kanal 3), falls die entsprechenden Indexe 0x1A04, 0x1A0E bzw. 0x1A18 aktiviert sind.


Skalierungsfaktoren

Inbetriebnahme [image] Skalierungsfaktoren
Skalierungsfaktoren
Sofern keine Fließkomma-Zahlen verwendet werden können, kann die EL3443 auch in einem sogenannten „Classic“-Modus betrieben werden, um nur Integer-Werte zu übertragen. In der folgenden Übersicht sind die hierfür notwendigen Skalierungsfaktoren angegeben, die zur Berechnung der Istwerte aus den Prozessdatenrohwerten benötigt werden.
Sofern die Wandlerverhältnisse nicht im Speicher der Klemme hinterlegt sind, müssen diese auch in der PLC nachträglich verrechnet werden.
Wenn die Wandlerverhältnisse im CoE (Index 80n0 PMX Settings) der Klemme gespeichert sind, können diese als Skalierungsfaktoren in der PLC entfallen.
Skalierungsfaktoren für den „Classic“-Modus der EL3443-00xx
Werte | Berechnung
Strom | Rohwerte x 0,0001 A x Stromwandlerverhältnis
Spannung | Rohwerte x 0,001 V x Spannungswandlerverhältnis
Wirkleistung | Rohwerte x 0,001 W x Strom- und Spannungswandlerverhältnis
Scheinleistung | Rohwerte x 0,001 VA x Strom- und Spannungswandlerverhältnis
Blindleistung | Rohwerte x 0,001 Var x Strom- und Spannungswandlerverhältnis
Energie | Rohwerte x 0,001 Wh x Strom- und Spannungswandlerverhältnis
Frequenz | Rohwerte x 0,001 Hz


Hinweise zu analogen Spezifikationen

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen
Hinweise zu analogen Spezifikationen
Beckhoff IO-Geräte (Klemmen, Boxen, Module) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Weiterführende Informationen
•
Messbereichsendwert (MBE)
•
Messfehler/ Messabweichung
•
Temperaturkoeffizient tK [ppm/K]
•
Typisierung SingleEnded / Differentiell
•
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
•
Spannungsfestigkeit
•
Zeitliche Aspekte der analog/digital Wandlung


Messbereichsendwert (MBE)

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Messbereichsendwert (MBE)
Messbereichsendwert (MBE)
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereichsendwert, Messspanne
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200...1370°C: asymmetrisch bipolar, MBE = 1370°C, Messspanne = 1570°C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/ -boxen (bzw. verwandten Beckhoff‑Produktgruppen).


Messfehler/ Messabweichung

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Messfehler/ Messabweichung
Messfehler/ Messabweichung
Der relative Messfehler (% vom MBE) bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung usw.).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3% MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Geringerer Messfehler
Da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsgeräte.


Temperaturkoeffizient tK [ppm/K]

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Temperaturkoeffizient tK [ppm/K]
Temperaturkoeffizient tK [ppm/K]
Eine elektronische Schaltung ist in der Regel mehr oder weniger temperaturabhängig. Im Bereich der analogen Messtechnik bedeutet dies, daß der mittels einer elektronischen Schaltung ermittelte Messwert reproduzierbar in seiner Abweichung vom „wahren“ Wert von der Umgebungs/Betriebstemperatur abhängig ist.
Lindern kann ein Hersteller dies durch Verwendung höherwertiger Bauteile oder Software-Maßnahmen.
Der von Beckhoff ggf. angegebene Temperaturkoeffizient erlaubt es dem Anwender den zu erwartenden Messfehler außerhalb der Grundgenauigkeit bei 23°C zu berechnen.
Aufgrund der umfangreichen Unsicherheitsbetrachtungen, die in die Bestimmungen der Grundgenauigkeit (bei 23°C) eingehen, empfiehlt Beckhoff eine quadratische Summierung.
Beispiel: Grundgenauigkeit bei 23°C sei ±0,01% typ. (MBE), tK = 20 ppm/K typ., gesucht ist die Genauigkeit G35 bei 35°C, somit ΔT = 12K
Anmerkungen:
ppm ≙ 10-6
% ≙ 10-2


Typisierung SingleEnded / Differentiell

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Typisierung SingleEnded / Differentiell
Typisierung SingleEnded / Differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
SE und DIFF-Modul als 2-kanalige Variante
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss. Galvanisch getrennte Kanäle arbeiten grundsätzlich in differentieller Art, nur dass überhaupt kein direkter (galvanischer) Massebezug im Modul hergestellt ist. Spezifikationsangaben zu empfohlenen und maximalen Spannungen sind jeweils allerdings zu beachten.
Grundsätzlich gilt:
▪
Die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten.
Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
Dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
Für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
–
Bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt.
Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
Es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen.
Beckhoff IO-Module verfügen über 1..8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden
–
wie sich die Kanäle INNERHALB eines Module zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
–
Beckhoff Klemmen/ Boxen (bzw. verwandte Produktgruppen) sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen/ Boxen also nicht über die Powerkontakte/ Powerleitung miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
–
Falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder ein 1-Kanal-Modul keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
Analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Dokumentationen zu den Klemmen/ Boxen sind zu beachten.
Erläuterung
▪
differentiell (DIFF)
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (vgl. Abb. SE und DIFF-Modul als 2-kanalige Variante) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)", wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/ Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/ Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird.
Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung in Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
–
Weitere hilfreiche Ergänzungen dazu sind der Dokumentationsseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) zu entnehmen.
▪
Single Ended (SE)
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/ Box von außen zum Anschluss des Bezugspotenzials zugänglich sein, z. B. über die Powerkontakte/ Powerleitung.
–
SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/ Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z. B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/Bezugspotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst.
Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4-20mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss siehe Abb. 2-Leiter-Anschluss, vgl. IEC60381-1
▪
Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
2-Leiter-Anschluss
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/ Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Extern versorgte Sensoren
▪
3- und 4-Leiter-Anschluss siehe Abb. Anschluss extern versorgte Sensoren, vgl. IEC60381-1
▪
Die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:
–
1 Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm.
–
2 Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +Supply/-Supply/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
Ja:
Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
Nein:
es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Bei unipolaren Klemmen/ Boxen (und verwandten Produktgruppen) ist üblicherweise eine interne Diode vorhanden, dann ist die Polarität/Stromrichtung zu beachten:
Anschluss extern versorgte Sensoren
Einordnung der Beckhoff-Klemmen/ Boxen - Beckhoff 0/4-20mA Klemmen/ Boxen (und verwandten Produktgruppen) sind als differentiell und single-ended verfügbar:
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA, genauso KL und verwandten Produktgruppen | differentiell EL3x1x: 0-20 mA, EL3x2x: 4-20 mA, genauso KL und verwandten Produktgruppen
Stromvorzugsrichtung da interne Diode | Stromvorzugsrichtung da interne Diode
Sind für den Anschluss von extern versorgenden Sensoren im 3/4-Leiter-Anschluss konzipiert. | Die Klemme/ Box ist eine passive differentielle Strommessvorrichtung, „passiv“ bedeutet, dass keine Sensorspeisung erfolgt.
Sind für den Anschluss von selbstversorgenden Sensoren im 2-Leiter-Anschluss konzipiert |
Single-ended
Differential
2-, 3- und 4-Leiter-Anschluss an Single Ended - und Differenz Eingänge


Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung (CommonMode, Ucm) wird als der Mittelwert der Spannungen an den einzelnen Anschlüssen/Eingängen definiert und wird gegen eine Bezugsmasse gemessen/angegeben.
Gleichtaktspannung (Ucm)
Bei der Definition des zulässigen Gleichtaktspannungsbereiches und bei der Messung der Gleichtaktunterdrückung (CMRR, common mode rejection ratio) bei differenziellen Eingängen ist die Definition der Bezugsmasse wichtig.
Die Bezugsmasse ist auch das Potential, gegen welches der Eingangswiderstand und die Eingangsimpedanz bei single-ended-Eingängen bzw. der Gleichtaktwiderstand und die Gleichtaktimpedanz bei differenziellen Eingängen gemessen werden.
Die Bezugsmasse ist an/bei der Klemme/ Box i.d.R. zugänglich. Orte dafür können Klemmkontakte, Powerkontakte/ Powerleitung oder auch nur eine Tragschiene sein. Zur Verortung siehe Dokumentation, die Bezugsmasse sollte beim betrachteten Gerät angegeben sein.
Bei mehrkanaligen Klemmen/ Boxen mit resistiver (=direkter, ohmscher, galvanischer) oder kapazitiver Verbindung zwischen den Kanälen ist die Bezugsmasse vorzugsweise der Symmetriepunkt aller Kanäle, unter Betrachtung der Verbindungswiderstände.
Beispiele für Bezugsmassen bei Beckhoff IO Geräten:
1.
internes AGND (analog GND) herausgeführt:
EL3102/EL3112, resistive Verbindung der Kanäle untereinander
2.
0V-Powerkontakt:
EL3104/EL3114, resistive Verbindung der Kanäle untereinander an AGND, AGND niederohmig verbunden mit 0V-Powerkontakt
3.
Erde bzw. SGND (shield GND):
–
EL3174-0002: Kanäle haben keine resistive Verbindung untereinander, aber sind kapazitiv durch Ableitkondensatoren an SGND gekoppelt
–
EL3314: keine interne Masse auf die Klemmpunkte herausgeführt, aber kapazitive Kopplung an SGND


Spannungsfestigkeit

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Spannungsfestigkeit
Spannungsfestigkeit
Es ist zu unterscheiden zwischen:
▪
Spannungsfestigkeit (Zerstörgrenze): eine Überschreitung kann irreversible Veränderungen an der Elektronik zur Folge haben, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
▪
Empfohlener Einsatzspannungsbereich: Bei einer Überschreitung kann nicht mehr von einem spezifikationsgemäßem Betrieb ausgegangen werden, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
Empfohlener Einsatzspannungsbereich
Es können in den Gerätedokumentationen besondere Spezifikationsangaben dazu und zur Zeitangabe gemacht werden, unter Berücksichtigung von:
▪
Eigenerwärmung
▪
Nennspannung
▪
Isolationsfestigkeit
▪
Flankensteilheit der Anlege-Spannung bzw. Haltedauern
▪
Normatives Umfeld (z.B. PELV)


Zeitliche Aspekte der analog/digital Wandlung

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Zeitliche Aspekte der analog/digital Wandlung
Zeitliche Aspekte der analog/digital Wandlung
Die Umwandlung des stetigen analogen elektrischen Eingangssignals in eine wertdiskrete digitale und maschinenlesbare Form wird in den Beckhoff analogen Eingangsbaugruppen EL/KL/EP mit sog. ADC (analog digital converter) umgesetzt. Obgleich verschiedene ADC-Technologien gängig sind, haben sie alle aus Anwendersicht ein gemeinsames Merkmal: nach dem Ende der Umwandlung steht ein bestimmter digitaler Wert zur Weiterverarbeitung in der Steuerung bereit. Dieser Digitalwert, das sog. Analoge Prozessdatum, steht in einem festen zeitlichen Zusammenhang mit der „Ur-Größe“, dem elektrischen Eingangswert. Deshalb können für Beckhoff analoge Eingangsgeräte auch entsprechende zeitliche Kenndaten ermittelt und spezifiziert werden.
In diesen Prozess sind mehrere funktionale Komponenten involviert, die mehr oder weniger stark ausgeprägt in jeder AI (analog input) Baugruppe wirken:
▪
die elektrische Eingangsschaltung
▪
die Analog/Digital-Wandlung
▪
die digitale Weiterverarbeitung
▪
die finale Bereitstellung der Prozess- und Diagnosedaten zur Abholung an den Feldbus (EtherCAT, K-Bus etc.)
Signalverarbeitung Analogeingang
Aus Anwendersicht sind dabei zwei Aspekte entscheidend:
▪
„Wie oft bekomme ich neue Werte?“, also eine Sampling-Rate im Sinne einer Schnelligkeit in Bezug auf das Gerät/den Kanal
▪
Wieviel Verzögerung verursacht die (gesamte) AD-Wandlung des Gerätes/des Kanals?
Also Hard- und Firmware-Teile in toto. Aus technologischen Gründen muss zur Bestimmung dieser Angabe die Signalcharakteristik betrachtet werden: je nach Signalfrequenz kann es zu unterschiedlichen Laufzeiten durch das System kommen.
Dies ist die „äußere“ Betrachtung des Systems „Beckhoff AI Kanal“ – intern setzt sich insbesondere die Signalverzögerung aus den verschiedenen Anteilen Hardware, Verstärker, Wandlung selbst, Datentransport und Verarbeitung zusammen. Auch kann ggf. intern eine höhere Abtastrate verwendet werden (z.B. bei deltaSigma-Wandlern) als „außen“ aus Anwendersicht angeboten wird. Dies ist aber für ein nutzseitige Betrachtung der Komponente „Beckhoff AI Kanal“ normalerweise ohne Belang bzw. wird entsprechend spezifiziert, falls es doch für die Funktion relevant ist.
Damit können für Beckhoff AI Geräte folgende Spezifikationsangaben zum AI Kanal aus zeitlicher Sicht für den Anwender angegeben werden:
1. Minimale Wandlungszeit [ms, µs]
Dies ist der Kehrwert der maximalen Sampling-Rate [Sps, Samples per second]:
Gibt an, wie oft der analoge Kanal einen neu festgestellten Prozessdatenwert zur Abholung durch den Feldbus bereitstellt. Ob der Feldbus (EtherCAT, K-Bus) diesen dann auch genauso schnell (also im Gleichtakt), schneller (weil der AI Kanal im langsame FreeRun läuft) oder langsamer (z.B. bei Oversampling) abholt, ist dann eine Frage der Einstellung des Feldbusses und welche Betriebsmodi das AI Gerät unterstützt.
Bei EtherCAT Geräten zeigt das sog. ToggleBit bei den Diagnose-PDO an (indem es toggelt), dass ein neu ermittelter Analogwert vorliegt.
Entsprechend kann eine maximale Wandlungszeit, also eine minimal vom AI Gerät unterstützte Samplingrate spezifiziert werden.
Entspricht IEC 61131-2 Kap 7.10.2 2) „Abtast-Wiederholzeit“
2. Typ. Signalverzögerung
Entspricht IEC 61131-2 Kap 7.10.2 1) „Abtastdauer“. Sie inkludiert nach dieser Betrachtung alle geräteinternen Hard- und Firmware-Anteile, aber nicht „äußere“ Verzögerungsanteile aus dem Feldbus oder der Steuerung (TwinCAT).
Diese Verzögerung ist insbesondere relevant für absolute Zeitbetrachtungen, wenn AI Kanäle zum Amplitudenwert auch einen zugehörigen Zeitstempel (timestamp) mitliefern – von dem ja angenommen werden darf, dass er in seinem Zeitwert zu dem außen ehemals physikalisch anliegenden Amplitudenwert passt.
Aufgrund der frequenzabhängigen Laufzeit eines Signals, kann ein dezidierter Wert nur für ein gegebenes Signal spezifiziert werden. Der Wert ist auch abhängig von ggf. veränderlichen Filtereinstellungen des Kanals.
Eine typische Charakterisierung in der Gerätedokumentation kann sein:
2.1 Signalverzögerung (Sprungantwort)
Stichworte: Einschwingzeit
Das Rechtecksignal kann extern mit einem Frequenzgenerator (Impedanz beachten!) erzeugt werden.
Als Erkennungsschwelle wird die 90% Grenze verwendet.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem (idealen) elektrischen Rechtecksignal und der Zeitpunkt wo der analoge Prozesswert die 90% Amplitude erreicht hat.
Diagramm Signalverzögerung (Sprungantwort)
2.2 Signalverzögerung (linear)
Stichwort: Gruppenlaufzeit
Beschreibt die Verzögerung eines frequenzkonstanten Signals
Testsignal kann extern mit einem Frequenzgenerator erzeugt werden, z.B. als Sägezahn oder Sinus. Referenz wäre dann ein zeitgleiches Rechtecksignal.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem eingespeisten elektrischen Signal einer bestimmten Amplitude und dem Moment wo der analoge Prozesswert denselben Wert erreicht.
Dazu muss die Testfrequenz in einem sinnvollen Bereich gewählt werden; diese kann z.B. bei 1/20 der maximalen Sampling-Rate liegen.
Diagramm Signalverzögerung (linear)
3. Weitere Angaben
Weitere Angaben können in der Spezifikation optional angeführt sein, wie z.B.
▪
Tatsächliche Sampling-Rate des ADC (wenn unterschiedlich von der Kanal-Sampling-Rate)
▪
Zeit-Korrekturwerte für Laufzeiten bei unterschiedlichen Filtereinstellungen
▪
usw.


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zur Parametrierung bei der Inbetriebnahme nötig sind:
–
Restore Objekt Index 0x1011
–
Konfigurationsdaten Index 0xF800
▪
Objekte die zum regulären Betrieb z. B. durch ADS-Zugriff bestimmt sind.
–
PM Command Objekt Index 0xFB00
▪
Profilspezifische Objekte:
–
Konfigurationsdaten (herstellerspezifisch) Index 0x80nF
–
Eingangsdaten Index 0x60n0
–
Ausgangsdaten Index 0x70n0
–
Informations- und Diagnostikdaten Index 0xF000, 0xF008, 0xF100, 0xF801 und 0xF80F
▪
Standardobjekte
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Weiterführende Informationen
•
Restore Objekt
•
EL3423
•
EL3443-00xx
•
EL3453
•
EL3483-00xx


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


EL3423

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423
EL3423
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte
•
Command-Objekt


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 PMX Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | PMX Settings | Max. Subindex | UINT8 | RO | 0x13 (19dez)
80n0:11 | Voltage Transformer Ratio | Falls ein Spannungswandler zum Einsatz kommt, kann hier dessen Übersetzungsverhältnis eingetragen werden. | REAL32 | RW | 0x3F800000 (1065353216dez)
80n0:12 | Current Transformer Ratio | Hier kann das Übersetzungsverhältnis des verwendeten Stromwandlers eingetragen werden. | REAL32 | RW | 0x3F800000 (1065353216dez)
80n0:13 | Current Transformer Delay | Hier kann eine eventuelle zeitliche Verzögerung der Stromwandler in Millisekunden eingetragen werden. | REAL32 | RW | 0x00000000 (0dez)
Index 80n1 PMX Guard Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x14 (20dez)
80n1:11 | Voltage Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 0x40000000 (1073741824dez)
80n1:12 | Voltage Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 0x434F0000 (1129250816dez)
80n1:13 | Voltage Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 0x437D0000 (1132265472dez)
80n1:14 | Voltage Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 0x438B0000 (1133182976dez)
Index F800 PMX Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | PMX Settings | Max. Subindex |  | UINT8 | RO | 0x16 (22dez)
F800:01 | Reset Interval | Manuelles Neustarten des Mess- und Statistik-Intervalls |  | BOOLEAN | RW | 0x00 (0dez)
F800:11 | Reference | Timing-Referenz der RMS-Berechnung Auf „Current“ stellen, wenn ohne anliegende Spannung ein Strom gemessen werden soll. erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | Voltage (default)
 |  | 1 | Current
F800:12 | Measurement Range | Filtereinstellung für die Grundschwingungsermittlung erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | 45..65 Hz (default)
 |  | 1 | 45..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Quelle der Systemfrequenz erlaubte Werte: |  | BIT1 | RW | 0x00000000 (0dez)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:14 | Power Calculation Threshold | Rauschreduzierung: Hier kann ein minimaler Grenzwert in Prozent für die Leistungsberechnung eingetragen werde, unterhalb dessen alle Werte gezielt genullt werden. |  | REAL32 | RW | 0x3F800000 (1065353216dez)
F800:15 | Inaccurate Threshold Voltage | Grenzwert für das Warnbit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dez)
F800:16 | Inaccurate Threshold Current | Grenzwert für das Warnbit: Inaccurate Current |  | REAL32 | RW | 0x3BC49BA6 (1002740646dez)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F801:0 | PMX Total Settings PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F801:11 | Nominal Voltage | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird ein nominaler Spannungswert bzw. Sollwert benötigt. | REAL32 | RW | 0x43660000 (1130758144dez)
F801:12 | Nominal Frequency | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird eine nominale Frequenz bzw. Sollwert benötigt. | REAL32 | RW | 0x42480000 (1112014848dez)
F801:13 | PQF Dataset | erlaubte Werte: | UINT32 | RW | 0x00000001 (1dez)
 |  | 0: Default
 |  | 1: Default + Unbalance
Index F802 PMX Guard Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F802:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x28 (40dez)
F802:11 | Frequency Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 47,000000 (4,700000e+001)
F802:12 | Frequency Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 49,500000 (4,950000e+001)
F802:13 | Frequency Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 50,500000 (5,050000e+001)
F802:14 | Frequency Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 52,000000 (5,200000e+001)
F802:15 | Neutral Current Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,050000 (-1,050000e+000)
F802:16 | Neutral Current Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,000000 (-1,000000e+000)
F802:17 | Neutral Current Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,006000 (6,000000e-003) EL3453 1,000000 (1,000000e+000)
F802:18 | Neutral Current Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,030000 (3,000000e-002) EL3453 1,050000 (1,050000e+000)
F802:19 | Active Power Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1A | Active Power Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1B | Active Power Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1C | Active Power Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1D | Apparent Power Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1E | Apparent Power Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1F | Apparent Power Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:20 | Apparent Power Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:21 | PQF Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 0,050000 (5,000000e-002)
F802:22 | PQF Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 0,800000 (8,000000e-001)
F802:23 | PQF Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 1,000000 (1,000000e+000)
F802:24 | PQF Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 1,000000 (1,000000e+000)
F802:25 | Unbalance Guard Min Error | Unterer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0,000000 (0,000000e+000)
F802:26 | Unbalance Guard Min Warning | Unterer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0,000000 (0,000000e+000)
F802:27 | Unbalance Guard Max Warning | Oberer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 2,000000 (2,000000e+000)
F802:28 | Unbalance Guard Max Error | Oberer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 3,000000 (3,000000e+000)
Index F803 PMX Time Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F803:0 | PMX Time Settings | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F803:11 | Measurement Mode | erlaubte Werte: | UINT32 | RW | 0x00000000 (0dez)
 |  | 0
F803:12 | Measurement Interval | Zeitwert in Sekunden zum automatischen Neustarts des Mess- und Statistik-Intervalls | UINT32 | RW | 0x00000000 (0dez)
F803:13 | Actual System Time | Zeigt die aktuelle Systemzeit der Klemme. Objekt kann auch beschrieben werden, um die Systemzeit umzustellen. | STRING | RW |


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 80nF PMX Vendor data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x16 (22dez)
80nF:11 | Calibration Voltage Offset | Wert in V | REAL32 | RW | 0x00000000 (0dez)
80nF:12 | Calibration Voltage Gain | Faktor (ohne Einheit) | REAL32 | RW | 0x3F800000 (1065353216dez)
80nF:13 | Calibration Voltage Phase Offset | Wert in Millisekunden | REAL32 | RW | 0x00000000 (0dez)
80nF:14 | Calibration Current Offset | Wert in A | REAL32 | RW | 0x00000000 (0dez)
80nF:15 | Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 0x3F800000 (1065353216dez)
80nF:16 | Calibration Current Phase Offset | Wert in Millisekunden | REAL32 | RW | 0x00000000 (0dez)


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Eingangsdaten
Eingangsdaten
Index 60n0 PMX Status (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | PMX Status | Max. Subindex | UINT8 | RO | 0x10 (16dez)
60n0:01 | Voltage Sign Bit | Gibt das Vorzeichen der aktuellen Sinuswellenspannung an: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overvoltage | Maximal messbare Spannung ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Overcurrent | Maximal messbarer Strom ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:04 | Inaccurate Voltage | Der gemessene Spannungswert ist kleiner als der im CoE-Objekt „F800:15 Inaccurate Threshold Voltage“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Inaccurate Current | Der gemessene Stromwert ist kleiner als der im CoE-Objekt „F800:16 Inaccurate Threshold Current“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:06 | Voltage Guard Warning | Eine Warngrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Voltage Guard Error | Eine Fehlergrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 60n4 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n4:0 | PMX Energy | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n4:11 | Active Energy | Wirkenergie in mWh | INT64 | RO |
60n4:12 | Apparent Energy | Scheinenergie in mVAh | INT64 | RO |
60n4:13 | Reactive Energy | Blindenergie in mvarh | INT64 | RO |
Index 60n8 PMX Statistic Voltage (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n8:0 | PMX Statistic Voltage | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n8:11 | Voltage Peak | Höchster Spitzenwert der Momentanspannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
60n8:12 | Voltage RMS Minimum | Kleinster Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
60n8:13 | Voltage RMS Maximum | Größter Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
Index 60n9 PMX Statistic Current (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n9:0 | PMX Statistic Current | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n9:11 | Current Peak | Höchster Spitzenwert des Momentanstroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
60n9:12 | Current RMS Minimum | Kleinster Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
60n9:13 | Current RMS Maximum | Größter Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
Index 60nA PMX Statistic Power (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60nA:0 | PMX Statistic Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
60nA:11 | Active Power Avg | Wirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
60nA:12 | Active Power Min | Wirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
60nA:13 | Active Power Max | Wirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
60nA:14 | Apparent Power Avg | Scheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
60nA:15 | Apparent Power Max | Scheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
60nA:16 | Reactive Power Avg | Blindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
60nA:17 | Reactive Power Min | Blindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
60nA:18 | Reactive Power Max | Blindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
60nA:19 | Apparent Power Min | Scheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
Index F600 PMX Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | PMX Total Status | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F600:01 | System State | Status des Gesamtsystems (als Veroderung von Voltage Guards Errors, Phasenfolge, Overvoltage, Overcurrent und Frequency Guard Error) | BOOLEAN | RO | 0x00 (0dez)
F600:02 | Grid Direction | Phasenfolge L1 - L2 - L3 richtig erkannt (bei einem rechtsdrehenden 3-Phasen-Netz) | BOOLEAN | RO | 0x00 (0dez)
F600:03 | Frequency Guard Warning | Eine Warngrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:04 | Frequency Guard Error | Eine Fehlergrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:05 | Neutral Current Guard Warning | Eine Warngrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:06 | Neutral Current Guard Error | Eine Fehlergrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:07 | Active Power Guard Warning | Eine Warngrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:08 | Active Power Guard Error | Eine Fehlergrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:09 | Apparent Power Guard Warning | Eine Warngrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0A | Apparent Power Guard Error | Eine Fehlergrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0B | Power Quality Guard Warning | Eine Warngrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0C | Power Quality Guard Error | Eine Fehlergrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0F | TxPDO State | TRUE bei allgemeinem Fehler | BOOLEAN | RO | 0x00 (0dez)
F600:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F600:11 | Power Quality Factor | Analoger Wert der Spannungsqualität zwischen 1,0 und 0 (siehe Grundlagen der Funktion - Power Quality Faktor) | REAL32 | RO | 0x00000000 (0dez)
Index F602 PMX Total Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F602:0 | PMX Total Advanced | Max. Subindex | UINT8 | RO | 0x02 (2dez)
F602:01 | Unbalance Guard Warning | Eine Warngrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F602:02 | Unbalance Guard Error | Eine Fehlergrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
Index F603 PMX Total Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F603:0 | PMX Total Active | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F603:12 | Active Energy | Bilanzierte Wirkenergie in mWh | INT64 | RO |
F603:13 | Active Positive Energy | Bezogene Wirkenergie in mWh | INT64 | RO |
F603:14 | Active Negative Energy | Eingespeiste Wirkenergie in mWh | INT64 | RO |
Index F605 PMX Total Apparent
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F605:0 | PMX Total Apparent | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F605:12 | Apparent Energy | Bilanzierte Scheinenergie in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy | Bezogene Scheinenergie in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy | Eingespeiste Scheinenergie in mWh | UINT64 | RO |
Index F607 PMX Total Reactive
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F607:0 | PMX Total Reactive | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F607:12 | Reactive Energy | Bilanzierte Blindenergie in mWh | INT64 | RO |
F607:13 | Reactive Positive Energy | Bezogene Blindenergie in mWh | UINT64 | RO |
F607:14 | Reactive Negative Energy | Eingespeiste Blindenergie in mWh | UINT64 | RO |
Index F60B PMX Total Statistic Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60B:0 | PMX Total Statistic Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F60B:11 | Active Power Avg | Gesamtwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F60B:12 | Active Power Min | Gesamtwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F60B:13 | Active Power Max | Gesamtwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F60B:14 | Apparent Power Avg | Gesamtscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:15 | Apparent Power Min | Gesamtscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:16 | Apparent Power Max | Gesamtscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:17 | Reactive Power Avg | Gesamtblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F60B:18 | Reactive Power Min | Gesamtblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F60B:19 | Reactive Power Max | Gesamtblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index F60C PMX Total Statistic PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60C:0 | PMX Total Statistic PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F60C:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F60C:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F60C:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index F60D PMX Total Interval Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60D:0 | PMX Total Interval Energy | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F60D:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F60D:11 | Active Energy | Bilanzierte Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:12 | Active Energy Positive | Bezogene Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:13 | Active Energy Negative | Eingespeiste Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:14 | Apparent Energy | Bilanzierte Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:15 | Apparent Energy Positive | Bezogene Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:16 | Apparent Energy Negative | Eingespeiste Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:17 | Reactive Energy | Bilanzierte Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:18 | Reactive Energy Positive | Bezogene Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:19 | Reactive Energy Negative | Eingespeiste Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
Index F612 PMX Total Active Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F612:0 | PMX Total Active Reduced | Max. Subindex | UINT8 | RO | 0x12 (18dez)
F612:11 | Active Power | Wirkleistung in W | REAL32 | RO | 0x00000000 (0dez)
F612:12 | Active Energy | Wirkenergie in mWh | INT64 | RO | 0x00000000 (0dez)
Index F613 PMX Total Apparent Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F613:0 | PMX Total Apparent Reduced | Max. Subindex | UINT8 | RO | 0x12 (18dez)
F613:11 | Apparent Power | Scheinleistung in VA | REAL32 | RO | 0x00000000 (0dez)
F613:12 | Apparent Energy | Scheinenergie in mVAh | INT64 | RO | 0x00000000 (0dez)
Index F614 PMX Total Reactive Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F614:0 | PMX Total Reactive Reduced | Max. Subindex | UINT8 | RO | 0x12 (18dez)
F614:11 | Reactive Power | Blindleistung in var | REAL32 | RO | 0x00000000 (0dez)
F614:12 | Reactive Energy | Blindenergie in mvarh | INT64 | RO | 0x00000000 (0dez)
Index F615 PMX Total Interval Energy Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F615:0 | PMX Total Interval Energy Reduced | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F615:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F615:11 | Active Energy | Bilanzierte Gesamtwirkenergie im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dez)
F615:12 | Apparent Energy | Bilanzierte Gesamtscheinenergie im letzten Intervall in VAh | REAL32 | RO | 0x00000000 (0dez)
F615:13 | Reactive Energy | Bilanzierte Gesamtblindenergie im letzten Intervall in varh | REAL32 | RO | 0x00000000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Ausgangsdaten
Ausgangsdaten
Index F701 PMX Interval
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F701:0 | PMX Interval | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F701:01 | Reset Interval | Manuelle Möglichkeit das Intervall neuzustarten (siehe Grundlagen der Funktion – Statistische Auswertung) | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 90n0 PMX Info data Voltage (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n0:0 | PMX Info data Voltage | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n0:11 | Voltage Peak | Höchster Spitzenwert der Momentanspannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
90n0:12 | Voltage RMS Minimum | Kleinster Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
90n0:13 | Voltage RMS Maximum | Größter Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
Index 90n1 PMX Info data Current (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n1:0 | PMX Info data Current | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n1:11 | Current Peak | Höchster Spitzenwert des Momentanstroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
90n1:12 | Current RMS Minimum | Kleinster Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
90n1:13 | Current RMS Maximum | Größter Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
Index 90n2 PMX Info data Power (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n2:0 | PMX Info data Power | Max. Subindex | UINT8 | RO | 0x1B (27dez)
90n2:11 | Active Power Avg | Phasenwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
90n2:12 | Active Power Min | Phasenwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
90n2:13 | Active Power Max | Phasenwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
90n2:14 | Apparent Power Avg | Phasenscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:15 | Apparent Power Min | Phasenscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:16 | Apparent Power Max | Phasenscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:17 | Reactive Power Avg | Phasenblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
90n2:18 | Reactive Power Min | Phasenblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
90n2:19 | Reactive Power Max | Phasenblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
90n2:1A | Phi | Phasenwinkel in Grad (zwischen Spannung U_Lx und dem dazugehörigen Strom I_Lx) | REAL32 | RO | 0x00000000 (0dez)
90n2:1B | Phase Angle | Phasenunterschied in Grad (zwischen unterschiedlichen Spannungen U_Lx und U_Ly) | REAL32 | RO | 0x00000000 (0dez)
Index 90n3 PMX Info data Energy (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n3:0 | PMX Info data Energy Ch.1 | Max. Subindex | UINT8 | RO | 0x19 (25dez)
90n3:11 | Active Energy | Bilanzierte Phasenwirkenergie in mWh | INT64 | RO |
90n3:12 | Positive Active Energy | Bezogene Phasenwirkenergie in mWh | UINT64 | RO |
90n3:13 | Negative Active Energy | Eingespeiste Phasenwirkenergie in mWh | UINT64 | RO |
90n3:14 | Apparent Energy | Bilanzierte Phasenscheinenergie in mWh | INT64 | RO |
90n3:15 | Positive Apparent Energy | Bezogene Phasenscheinenergie in mWh | UINT64 | RO |
90n3:16 | Negative Apparent Energy | Eingespeiste Phasenscheinenergie in mWh | UINT64 | RO |
90n3:17 | Reactive Energy | Bilanzierte Phasenblindenergie in mWh | INT64 | RO |
90n3:18 | Positive Reactive Energy | Bezogene Phasenblindenergie in mWh | UINT64 | RO |
90n3:19 | Negative Reactive Energy | Eingespeiste Phasenblindenergie in mWh | UINT64 | RO |
Index A0n0 PMX Diag data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | PMX Diag data Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
A0n0:11 | Saturation Time Voltage | Zeit (in 0,1 ms) in der die Klemme eine Überspannung gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
A0n0:12 | Saturation Time Current | Zeit (in 0,1 ms) in der die Klemme einen Überstrom gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Konfigurierte Revision der Klemme, (siehe Hinweis) | UINT32 | RW | 0x00000000 (0dez)
Index F80F PM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F80F:11 | Type | Hersteller-spezifische Daten | UINT32 | RW | 0x00000000 (0dez)
Index F902 PMX Total Info data Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F902:0 | PMX Total Info data Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F902:11 | Active Power Avg | Gesamtwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F902:12 | Active Power Min | Gesamtwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F902:13 | Active Power Max | Gesamtwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F902:14 | Apparent Power Avg | Gesamtscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F902:15 | Apparent Power Min | Gesamtscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F902:16 | Apparent Power Max | Gesamtscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F902:17 | Reactive Power Avg | Gesamtblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F902:18 | Reactive Power Min | Gesamtblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F902:19 | Reactive Power Max | Gesamtblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index F903 PMX Total Info data Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F903:0 | PMX Total Info data Energy | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F903:11 | Active Energy | Bilanzierte Gesamtwirkenergie in mWh | INT64 | RO |
F903:12 | Positive Active Energy | Bezogene Gesamtwirkenergie in mWh | UINT64 | RO |
F903:13 | Negative Active Energy | Eingespeiste Gesamtwirkenergie in mWh | UINT64 | RO |
F903:14 | Apparent Energy | Bilanzierte Gesamtscheinenergie in mWh | INT64 | RO |
F903:15 | Positive Apparent Energy | Bezogene Gesamtscheinenergie in mWh | UINT64 | RO |
F903:16 | Negative Apparent Energy | Eingespeiste Gesamtscheinenergie in mWh | UINT64 | RO |
F903:17 | Reactive Energy | Bilanzierte Gesamtblindenergie in mWh | INT64 | RO |
F903:18 | Positive Reactive Energy | Bezogene Gesamtblindenergie in mWh | UINT64 | RO |
F903:19 | Negative Reactive Energy | Eingespeiste Gesamtblindenergie in mWh | UINT64 | RO |
Index F904 PMX Total Info data PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F904:0 | PMX Total Info data PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F904:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index FA00 PMX Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FA00:0 | PMX Diag data | Max. Subindex | UINT8 | RO | 0x13 (19dez)
FA00:11 | Min CPU Die Temperature | Kälteste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:12 | Max CPU Die Temperature | Heißeste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:13 | EBUS Voltage | Aktuelle E-Bus Spannung | REAL32 | RO | 0x00000000 (0dez)


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Standardobjekte
Standardobjekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01551389 (22352777dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Länge dieses Objekts | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0D5F3052 (224342098dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | z.B. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter | Länge dieses Objektes | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO | 0x0000000000000000 (0dez)
Index 10F9 Time Distribution Object
Index | Name | Bedeutung | Datentyp | Flags | Default
10F9:0 | Time Distribution Object | Max Subindex | UINT8 | RO | 0x01 (1dez)
10F9:01 | Distributed Time Value | Objekt zur Uhrzeitverteilung durch den EtherCAT Master | INT64 | RW |
Index 1601 Total RxPDO-Map Interval
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | Total RxPDO-Map Interval | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF701 (PMX Interval), entry 0x01 (Reset Interval)) | UINT32 | RO | 0xF701:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 1App TxPDO-Map Status (für L1, pp = 00; L2, pp = 0A; L3, pp = 14)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy (für L1, pp = 03; L2, pp = 0D; L3, pp = 17)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Energy | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Voltage (für L1, pp = 06; L2, pp = 10; L3, pp = 1A)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Voltage | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x11 (Voltage Peak)) | UINT32 | RO | 0x60n8:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x12 (Voltage RMS Minimum)) | UINT32 | RO | 0x60n8:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x13 (Voltage RMS Maximum)) | UINT32 | RO | 0x60n8:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Current (für L1, pp = 07; L2, pp = 11; L3, pp = 1B)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | L1 TxPDO-Map Statistic Current | PDO Mapping TxPDO 8 | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x11 (Current Peak)) | UINT32 | RO | 0x60n9:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x12 (Current RMS Minimum)) | UINT32 | RO | 0x60n9:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x13 (Current RMS Maximum)) | UINT32 | RO | 0x60n9:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Power (für L1, pp = 08; L2, pp = 12; L3, pp = 1C)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Power | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0x60nA:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0x60nA:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0x60nA:13, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0x60nA:14, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x15 (Apparent Power Max)) | UINT32 | RO | 0x60nA:15, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x16 (Reactive Power Avg)) | UINT32 | RO | 0x60nA:16, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0x60nA:17, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0x60nA:18, 32**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x19 (Apparent Power Min)) | UINT32 | RO | 0x60nA:19, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A1E Total TxPDO-Map Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | Total TxPDO-Map Total Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A1E:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A1E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A1E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A1E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A20 Total TxPDO-Map Total Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A20:0 | Total TxPDO-Map Total Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x03 (3dez)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x01 (Unbalance Guard Warning)) | UINT32 | RO | 0xF602:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x02 (Unbalance Guard Error)) | UINT32 | RO | 0xF602:02, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A21 Total TxPDO-Map Total Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A21:0 | Total TxPDO-Map Total Active | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dez)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x12 (Active Energy)) | UINT32 | RO | 0xF603:12, 64
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x13 (Active Positive Energy)) | UINT32 | RO | 0xF603:13, 64
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x14 (Active Negative Energy)) | UINT32 | RO | 0xF603:14, 64
Index 1A22 Total TxPDO-Map Total Apparent
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A22:0 | Total TxPDO-Map Total Apparent | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dez)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF605:12, 64
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x13 (Apparent Positive Energy)) | UINT32 | RO | 0xF605:13, 64
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x14 (Apparent Negative Energy)) | UINT32 | RO | 0xF605:14, 64
Index 1A23 Total TxPDO-Map Total Reactive
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A23:0 | Total TxPDO-Map Total Reactive | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dez)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF607:12, 64
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x13 (Reactive Positive Energy)) | UINT32 | RO | 0xF607:13, 64
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x14 (Reactive Negative Energy)) | UINT32 | RO | 0xF607:14, 64
Index 1A26 Total TxPDO-Map Total Statistic Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A26:0 | Total TxPDO-Map Total Statistic Power | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dez)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0xF60B:11, 32
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0xF60B:12, 32
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0xF60B:13, 32
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0xF60B:14, 32
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x15 (Apparent Power Min)) | UINT32 | RO | 0xF60B:15, 32
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x16 (Apparent Power Max)) | UINT32 | RO | 0xF60B:16, 32
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x17 (Reactive Power Avg)) | UINT32 | RO | 0xF60B:17, 32
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x18 (Reactive Power Min)) | UINT32 | RO | 0xF60B:18, 32
1A26:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x19 (Reactive Power Max)) | UINT32 | RO | 0xF60B:19, 32
Index 1A27 Total TxPDO-Map Total Statistic PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A27:0 | Total TxPDO-Map Total Statistic PQF | PDO Mapping TxPDO 40 | UINT8 | RO | 0x03 (3dez)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x11 (PQF Avg)) | UINT32 | RO | 0xF60C:11, 32
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x12 (PQF Min)) | UINT32 | RO | 0xF60C:12, 32
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x13 (PQF Max)) | UINT32 | RO | 0xF60C:13, 32
Index 1A28 Total TxPDO-Map Total Interval Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A28:0 | Total TxPDO-Map Total Interval Energy | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60D:10, 1
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF60D:11, 32
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x12 (Active Energy Positive)) | UINT32 | RO | 0xF60D:12, 32
1A28:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x13 (Active Energy Negative)) | UINT32 | RO | 0xF60D:13, 32
1A28:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x14 (Apparent Energy)) | UINT32 | RO | 0xF60D:14, 32
1A28:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x15 (Apparent Energy Positive)) | UINT32 | RO | 0xF60D:15, 32
1A28:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x16 (Apparent Energy Negative)) | UINT32 | RO | 0xF60D:16, 32
1A28:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x17 (Reactive Energy)) | UINT32 | RO | 0xF60D:17, 32
1A28:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x18 (Reactive Energy Positive)) | UINT32 | RO | 0xF60D:18, 32
1A28:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x19 (Reactive Energy Negative)) | UINT32 | RO | 0xF60D:19, 32
Index 1A29 Total TxPDO-Map Active Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A29:0 | Total TxPDO-Map Active Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dez)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (Alignet)) | UINT32 | RO | 0x0000:00, 32
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF612 (PMX Total Apparent), entry 0x12 (Active Reduced)) | UINT32 | RO | 0xF612:12, 64
Index 1A2A Total TxPDO-Map Apparent Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2A:0 | Total TxPDO-Map Apparent Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dez)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x11 (Apparent Power)) | UINT32 | RO | 0xF613:11, 32
1A2A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF613:12, 64
Index 1A2B Total TxPDO-Map Reactive Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2B:0 | Total TxPDO-Map Reactive Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x02 (2dez)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x11 (Reactive Power)) | UINT32 | RO | 0xF614:11, 32
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF614:12, 64
Index 1A2C Total TxPDO-Map Interval Energy Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2C:0 | Total TxPDO-Map Interval Energy Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x05 (5dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (align) | UINT32 | RO | 0x0000:00, 15
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF615:10, 1
1A2C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF615:11, 32
1A2C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF615:12, 32
1A2C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x13 (reactive Energy)) | UINT32 | RO | 0xF615:13, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Länge dieses Objekts | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0A (6666dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A14 (6676dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A1E (6686dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:06 | SubIndex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:07 | SubIndex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:08 | SubIndex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:09 | SubIndex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | SubIndex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0B | SubIndex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | SubIndex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0D | SubIndex 013 | 13. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0E | SubIndex 014 | 14. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0F | SubIndex 015 | 15. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:10 | SubIndex 016 | 16. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:11 | SubIndex 017 | 17. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:12 | SubIndex 018 | 18. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:13 | SubIndex 019 | 19. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:14 | SubIndex 020 | 20. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:15 | SubIndex 021 | 21. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:16 | SubIndex 022 | 22. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:17 | SubIndex 023 | 23. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Zykluszeit (in ns): Free Run: Zykluszeit des lokalen Timers Synchron with SM 2 Event: Zykluszeit des Masters DC-Mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0 = 1: Free Run wird unterstützt Bit 1 = 1: Synchron with SM 2 Event wird unterstützt Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08) | UINT16 | RO | 0x0805 (2053dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x0007A120 (500000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C32:08 | Command | 0: Messung der lokalen Zykluszeit wird gestoppt 1: Messung der lokalen Zykluszeit wird gestartet Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert. Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Maximum delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
Index 1C33 SM input parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 3 Event (keine Outputs vorhanden) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs vorhanden) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0: Free Run wird unterstützt Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden) Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden) Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden) Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08) | UINT16 | RO | 0x0805 (2053dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x0007A120 (500000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x0007A120 (500000dez)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Größter Subindex dieses Objekts | UINT8 | RO | 0x02
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RW | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RW | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Code Word
Der Hersteller behält sich die Grundkalibrierung der Klemmen vor. Das Code Word ist daher z. Zt. reserviert.
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dez)


Command-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3423 [image] Command-Objekt
Command-Objekt
Index FB00 PMX Command
Das Command Objekt wird genutzt, um in der Klemme eine Aktion auszulösen. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | PM Command | Größter Subindex dieses Objekts |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - Service Request Daten |  | OCTET-STRING [2] | RW | 0x0000 (0dez)
 |  | 4hex | Energie löschen
 |  | Byte 1 - Auswahl des Kanals
 |  | 00hex | alle Kanäle
 |  | 01hex | Kanal 1
 |  | 02hex | Kanal 2
 |  | 03hex | Kanal 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dez)
 |  | reserviert
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dez)
 |  | reserviert
 |  | Byte 1
 |  | reserviert
 |  | Byte 2-n
 |  | reserviert


EL3443-00xx

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx
EL3443-00xx
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte
•
Command-Objekt


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 PMX Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | PMX Settings | Max. Subindex | UINT8 | RO | 0x13 (19dez)
80n0:11 | Voltage Transformer Ratio | Falls ein Spannungswandler zum Einsatz kommt, kann hier dessen Übersetzungsverhältnis eingetragen werden. | REAL32 | RW | 0x3F800000 (1065353216dez)
80n0:12 | Current Transformer Ratio | Hier kann das Übersetzungsverhältnis des verwendeten Stromwandlers eingetragen werden. | REAL32 | RW | 0x3F800000 (1065353216dez)
80n0:13 | Current Transformer Delay | Hier kann eine eventuelle zeitliche Verzögerung der Stromwandler in Millisekunden eingetragen werden. | REAL32 | RW | 0x00000000 (0dez)
Index 80n1 PMX Guard Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x14 (20dez)
80n1:11 | Voltage Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 2,000000 (2,000000e+000)
80n1:12 | Voltage Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 207,000000 (2,070000e+002)
80n1:13 | Voltage Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 253,000000 (2,530000e+002)
80n1:14 | Voltage Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 278,000000 (2,780000e+002)
80n1:15 | Current Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Stroms | REAL32 | RW | -1,050000 (-1,050000e+000)
80n1:16 | Current Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Stroms | REAL32 | RW | -1,000000 (-1,000000e+000)
80n1:17 | Current Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Stroms | REAL32 | RW | 1,000000 (1,000000e+000)
80n1:18 | Current Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Stroms | REAL32 | RW | 1,050000 (1,050000e+000)
Index 80n2 PMX User Scale (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n2:0 | PMX User Scale Ch.1 | Max. Subindex | UINT8 | RO | 0x15 (21dez)
80n2:01 | User Calibration Enable | Um Benutzer Kalibrierungsdaten einzuschalten auf true setzen. | BOOLEAN | RW | 0x00 (0dez)
80n2:11 | User Calibration Voltage Offset | Wert in V | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:12 | User Calibration Voltage Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80n2:13 | User Calibration Current Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:14 | User Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80n2:15 | User Calibration Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
Index F800 PMX Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | PMX Settings | Max. Subindex |  | UINT8 | RO | 0x16 (22dez)
F800:01 | Reset Interval | Manuelles Neustarten des Mess- und Statistik-Intervalls |  | BOOLEAN | RW | 0x00 (0dez)
F800:11 | Reference | Timing-Referenz der RMS-Berechnung Auf „Current“ stellen, wenn ohne anliegende Spannung ein Strom gemessen werden soll. erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | Voltage (default)
 |  | 1 | Current
F800:12 | Measurement Range | Filtereinstellung für die Grundschwingungsermittlung erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | 45..65 Hz (default)
 |  | 1 | 45..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Quelle der Systemfrequenz erlaubte Werte: |  | BIT1 | RW | 0x00000000 (0dez)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:14 | Power Calculation Threshold | Rauschreduzierung: Hier kann ein minimaler Grenzwert in Prozent für die Leistungsberechnung eingetragen werde, unterhalb dessen alle Werte gezielt genullt werden. |  | REAL32 | RW | 0x3F800000 (1065353216dez)
F800:15 | Inaccurate Threshold Voltage | Grenzwert für das Warnbit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dez)
F800:16 | Inaccurate Threshold Current | Grenzwert für das Warnbit: Inaccurate Current |  | REAL32 | RW | 0x3BC49BA6 (1002740646dez)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F801:0 | PMX Total Settings PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F801:11 | Nominal Voltage | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird ein nominaler Spannungswert bzw. Sollwert benötigt. | REAL32 | RW | 0x43660000 (1130758144dez)
F801:12 | Nominal Frequency | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird eine nominale Frequenz bzw. Sollwert benötigt. | REAL32 | RW | 0x42480000 (1112014848dez)
F801:13 | PQF Dataset | erlaubte Werte: | UINT32 | RW | 0x00000001 (1dez)
 |  | 0: Default
 |  | 1: Default + Unbalance
Index F802 PMX Guard Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F802:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x28 (40dez)
F802:11 | Frequency Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 47,000000 (4,700000e+001)
F802:12 | Frequency Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 49,500000 (4,950000e+001)
F802:13 | Frequency Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 50,500000 (5,050000e+001)
F802:14 | Frequency Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 52,000000 (5,200000e+001)
F802:15 | Neutral Current Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,050000 (-1,050000e+000)
F802:16 | Neutral Current Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,000000 (-1,000000e+000)
F802:17 | Neutral Current Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,006000 (6,000000e-003) EL3453 1,000000 (1,000000e+000)
F802:18 | Neutral Current Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,030000 (3,000000e-002) EL3453 1,050000 (1,050000e+000)
F802:19 | Active Power Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1A | Active Power Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1B | Active Power Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1C | Active Power Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1D | Apparent Power Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1E | Apparent Power Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1F | Apparent Power Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:20 | Apparent Power Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:21 | PQF Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 0,050000 (5,000000e-002)
F802:22 | PQF Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 0,800000 (8,000000e-001)
F802:23 | PQF Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 1,000000 (1,000000e+000)
F802:24 | PQF Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 1,000000 (1,000000e+000)
F802:25 | Unbalance Guard Min Error | Unterer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0,000000 (0,000000e+000)
F802:26 | Unbalance Guard Min Warning | Unterer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0,000000 (0,000000e+000)
F802:27 | Unbalance Guard Max Warning | Oberer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 2,000000 (2,000000e+000)
F802:28 | Unbalance Guard Max Error | Oberer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 3,000000 (3,000000e+000)
Index F803 PMX Time Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F803:0 | PMX Time Settings | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F803:11 | Measurement Mode | erlaubte Werte: | UINT32 | RW | 0x00000000 (0dez)
 |  | 0
F803:12 | Measurement Interval | Zeitwert in Sekunden zum automatischen Neustarts des Mess- und Statistik-Intervalls | UINT32 | RW | 0x00000000 (0dez)
F803:13 | Actual System Time | Zeigt die aktuelle Systemzeit der Klemme. Objekt kann auch beschrieben werden, um die Systemzeit umzustellen. | STRING | RW |


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 80nF PMX Vendor data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x16 (22dez)
80nF:11 | Calibration Voltage Offset | Wert in V | REAL32 | RW | 0x00000000 (0dez)
80nF:12 | Calibration Voltage Gain | Faktor (ohne Einheit) | REAL32 | RW | 0x3F800000 (1065353216dez)
80nF:13 | Calibration Voltage Phase Offset | Wert in Millisekunden | REAL32 | RW | 0x00000000 (0dez)
80nF:14 | Calibration Current Offset | Wert in A | REAL32 | RW | 0x00000000 (0dez)
80nF:15 | Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 0x3F800000 (1065353216dez)
80nF:16 | Calibration Current Phase Offset | Wert in Millisekunden | REAL32 | RW | 0x00000000 (0dez)


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Eingangsdaten
Eingangsdaten
Index 60n0 PMX Status (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | PMX Status | Max. Subindex | UINT8 | RO | 0x10 (16dez)
60n0:01 | Voltage Sign Bit | Gibt das Vorzeichen der aktuellen Sinuswellenspannung an: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overvoltage | Maximal messbare Spannung ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Overcurrent | Maximal messbarer Strom ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:04 | Inaccurate Voltage | Der gemessene Spannungswert ist kleiner als der im CoE-Objekt „F800:15 Inaccurate Threshold Voltage“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Inaccurate Current | Der gemessene Stromwert ist kleiner als der im CoE-Objekt „F800:16 Inaccurate Threshold Current“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:06 | Voltage Guard Warning | Eine Warngrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Voltage Guard Error | Eine Fehlergrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 60n1 PMX Basic (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n1:0 | PMX Basic | Max. Subindex | UINT8 | RO | 0x12 (18dez)
60n1:11 | Voltage | Effektivwert der Spannung in V | REAL32 | RO | 0x00000000 (0dez)
60n1:12 | Current | Effektivwert des Stroms in A | REAL32 | RO | 0x00000000 (0dez)
Index 60n2 PMX Power (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n2:0 | PMX Power | Max. Subindex | UINT8 | RO | 0x14 (20dez)
60n2:11 | Active Power | Wirkleistung in W | REAL32 | RO | 0x00000000 (0dez)
60n2:12 | Apparent Power | Scheinleistung in VA | REAL32 | RO | 0x00000000 (0dez)
60n2:13 | Reactive Power | Blindleistung in var | REAL32 | RO | 0x00000000 (0dez)
60n2:14 | Power Factor | Leistungsfaktor | REAL32 | RO | 0x00000000 (0dez)
Index 60n4 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n4:0 | PMX Energy | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n4:11 | Active Energy | Wirkenergie in mWh | INT64 | RO |
60n4:12 | Apparent Energy | Scheinenergie in mVAh | INT64 | RO |
60n4:13 | Reactive Energy | Blindenergie in mvarh | INT64 | RO |
Index 60n6 PMX Timing (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n6:0 | PMX Timing | Max. Subindex | UINT8 | RO | 0x12 (18dez)
60n6:12 | Voltage Last Zero Crossing | Letzter detektierter Spannungsnulldurchgang als DistributedClocks-Zeitpunkt | UINT64 | RO |
Index 60n7 PMX Advanced (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n7:0 | PMX Advanced | Max. Subindex | UINT8 | RO | 0x14 (20dez)
60n7:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n7:11 | Voltage Total Harmonic Distortion | „Total Harmonic Distortion“ ist der Verzerrungsfaktor der Spannung und gibt das Verhältnis der harmonischen Anteile einer Schwingung zur ihrer Grundschwingung in % an. | REAL32 | RO | 0x00000000 (0dez)
60n7:12 | Current Distortion Factor | Der „Current Distortion Factor“ wird auch TDD (Total Demand Distortion) genannt und gibt das Verhältnis zwischen den Stromoberschwingungen und dem Maximalstrom an (EL3443: 1A und EL3443-0010: 5A, EL3453: 100mA/1A/5A). Angegeben in % des Maximalstroms. | REAL32 | RO | 0x00000000 (0dez)
60n7:13 | Current Total Harmonic Distortion | „Total Harmonic Distortion“ ist der Verzerrungsfaktor des Stroms und gibt das Verhältnis der harmonischen Anteile einer Schwingung zur ihrer Grundschwingung in % an. | REAL32 | RO | 0x00000000 (0dez)
60n7:14 | Cos Phi | Phasenwinkel der Grundwelle in Grad | REAL32 | RO | 0x00000000 (0dez)
Index 60n8 PMX Statistic Voltage (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n8:0 | PMX Statistic Voltage | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n8:11 | Voltage Peak | Höchster Spitzenwert der Momentanspannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
60n8:12 | Voltage RMS Minimum | Kleinster Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
60n8:13 | Voltage RMS Maximum | Größter Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
Index 60n9 PMX Statistic Current (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n9:0 | PMX Statistic Current | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n9:11 | Current Peak | Höchster Spitzenwert des Momentanstroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
60n9:12 | Current RMS Minimum | Kleinster Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
60n9:13 | Current RMS Maximum | Größter Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
Index 60nA PMX Statistic Power (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60nA:0 | PMX Statistic Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
60nA:11 | Active Power Avg | Wirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
60nA:12 | Active Power Min | Wirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
60nA:13 | Active Power Max | Wirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
60nA:14 | Apparent Power Avg | Scheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
60nA:15 | Apparent Power Max | Scheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
60nA:16 | Reactive Power Avg | Blindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
60nA:17 | Reactive Power Min | Blindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
60nA:18 | Reactive Power Max | Blindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
60nA:19 | Apparent Power Min | Scheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
Index 60nB PMX Classic (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
600B:0 | PMX Classic | Max. Subindex | UINT8 | RO | 0x16 (22dez)
600B:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
600B:11 | Voltage | Effektivwert der Spannung in 0,001 V | INT32 | RO | 0x00000000 (0dez)
600B:12 | Current | Effektivwert des Strom in 0,0001 A | INT32 | RO | 0x00000000 (0dez)
600B:13 | Frequency | Frequenz der Grundschwingung in 0,001 Hz | INT32 | RO | 0x00000000 (0dez)
600B:14 | Active Power | Wirkleistung in 0,001 W | INT32 | RO | 0x00000000 (0dez)
600B:15 | Apparent Power | Scheinleistung in 0,001 VA | INT32 | RO | 0x00000000 (0dez)
600B:16 | Reactive Power | Blindleistung in 0,001 var | INT32 | RO | 0x00000000 (0dez)
Index F600 PMX Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | PMX Total Status | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F600:01 | System State | Status des Gesamtsystems (als Veroderung von Voltage Guards Errors, Phasenfolge, Overvoltage, Overcurrent und Frequency Guard Error) | BOOLEAN | RO | 0x00 (0dez)
F600:02 | Grid Direction | Phasenfolge L1 - L2 - L3 richtig erkannt (bei einem rechtsdrehenden 3-Phasen-Netz) | BOOLEAN | RO | 0x00 (0dez)
F600:03 | Frequency Guard Warning | Eine Warngrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:04 | Frequency Guard Error | Eine Fehlergrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:05 | Neutral Current Guard Warning | Eine Warngrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:06 | Neutral Current Guard Error | Eine Fehlergrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:07 | Active Power Guard Warning | Eine Warngrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:08 | Active Power Guard Error | Eine Fehlergrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:09 | Apparent Power Guard Warning | Eine Warngrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0A | Apparent Power Guard Error | Eine Fehlergrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0B | Power Quality Guard Warning | Eine Warngrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0C | Power Quality Guard Error | Eine Fehlergrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0F | TxPDO State | TRUE bei allgemeinem Fehler | BOOLEAN | RO | 0x00 (0dez)
F600:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F600:11 | Power Quality Factor | Analoger Wert der Spannungsqualität zwischen 1,0 und 0 (siehe Grundlagen der Funktion - Power Quality Faktor) | REAL32 | RO | 0x00000000 (0dez)
Index F601 PMX Total Basic
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F601:0 | PMX Total Basic | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F601:11 | Frequency | Frequenz in Hz | REAL32 | RO | 0x00000000 (0dez)
F601:12 | Power Factor | Leistungsfaktor | REAL32 | RO | 0x00000000 (0dez)
F601:13 | Calculated Neutral Line Current | Berechneter Effektivwert des Nullleiterstroms in A | REAL32 | RO | 0x00000000 (0dez)
Index F602 PMX Total Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F602:0 | PMX Total Advanced | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F602:01 | Unbalance Guard Warning | Eine Warngrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F602:02 | Unbalance Guard Error | Eine Fehlergrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F602:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F602:11 | Max Voltage Harmonic Distortion | Maximaler Verzerrungsfaktor aller drei Phasenspannungen in % | REAL32 | RO | 0x00000000 (0dez)
F602:12 | Max Current Harmonic Distortion | Maximaler Verzerrungsfaktor aller drei Phasenströme in % | REAL32 | RO | 0x00000000 (0dez)
F602:13 | Max Current Distortion Factor | Maximalewert der „Total Demand Distortion“ aller drei Phasen in % | REAL32 | RO | 0x00000000 (0dez)
F602:14 | Voltage Unbalance | Verhältnis zwischen Gegen- und Mitsystem der Spannungen in % | REAL32 | RO | 0x00000000 (0dez)
Index F603 PMX Total Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F603:0 | PMX Total Active | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F603:11 | Active Power | Wirkleistung in W | INT64 | RO |
F603:12 | Active Energy | Bilanzierte Wirkenergie in mWh | INT64 | RO |
F603:13 | Active Positive Energy | Bezogene Wirkenergie in mWh | INT64 | RO |
F603:14 | Active Negative Energy | Eingespeiste Wirkenergie in mWh | INT64 | RO |
Index F605 PMX Total Apparent
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F605:0 | PMX Total Apparent | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F605:11 | Apparent Power | Bilanzierte Scheinleistung in VA | INT64 | RO |
F605:12 | Apparent Energy | Bilanzierte Scheinenergie in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy | Bezogene Scheinenergie in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy | Eingespeiste Scheinenergie in mWh | UINT64 | RO |
Index F607 PMX Total Reactive
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F607:0 | PMX Total Reactive | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F607:11 | Reactive Power | Bilanzierte Blindleistung in Var | INT64 | RO |
F607:12 | Reactive Energy | Bilanzierte Blindenergie in mWh | INT64 | RO |
F607:13 | Reactive Positive Energy | Bezogene Blindenergie in mWh | UINT64 | RO |
F607:14 | Reactive Negative Energy | Eingespeiste Blindenergie in mWh | UINT64 | RO |
Index F609 PMX Total L-L Voltages
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F609:0 | PMX Total L-L Voltages | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F609:11 | L1-L2 Voltage | Effektivwert der Außenleiterspannung zwischen L1 und L2 in V | REAL32 | RO | 0x00000000 (0dez)
F609:12 | L2-L3 Voltage | Effektivwert der Außenleiterspannung zwischen L2 und L3 in V | REAL32 | RO | 0x00000000 (0dez)
F609:13 | L3-L1 Voltage | Effektivwert der Außenleiterspannung zwischen L3 und L1 in V | REAL32 | RO | 0x00000000 (0dez)
Index F60A PMX Variant Value In
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60A:0 | PMX Variant Value In | Max. Subindex | UINT8 | RO | 0x18 (24dez)
F60A:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F60A:11 | Index 1 REAL | Acknowledge für variablen Ausgabewert 1 | UINT16 | RO | 0x0000 (0dez)
F60A:12 | Value 1 REAL | variabler Ausgabewert Kanal 1 | REAL32 | RO | 0x00000000 (0dez)
F60A:13 | Index 2 REAL | Acknowledge für variablen Ausgabewert 2 | UINT16 | RO | 0x0000 (0dez)
F60A:14 | Value 2 REAL | variabler Ausgabewert Kanal 2 | REAL32 | RO | 0x00000000 (0dez)
F60A:15 | Index 3 REAL | Acknowledge für variablen Ausgabewert 3 | UINT16 | RO | 0x0000 (0dez)
F60A:16 | Value 3 REAL | variabler Ausgabewert Kanal 3 | REAL32 | RO | 0x00000000 (0dez)
F60A:17 | Index 4 ULINT | Acknowledge für variablen Ausgabewert 4 | UINT16 | RO | 0x0000 (0dez)
F60A:18 | Value 4 ULINT | variabler Ausgabewert Kanal 4 | UINT64 | RO |
Index F60B PMX Total Statistic Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60B:0 | PMX Total Statistic Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F60B:11 | Active Power Avg | Gesamtwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F60B:12 | Active Power Min | Gesamtwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F60B:13 | Active Power Max | Gesamtwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F60B:14 | Apparent Power Avg | Gesamtscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:15 | Apparent Power Min | Gesamtscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:16 | Apparent Power Max | Gesamtscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:17 | Reactive Power Avg | Gesamtblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F60B:18 | Reactive Power Min | Gesamtblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F60B:19 | Reactive Power Max | Gesamtblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index F60C PMX Total Statistic PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60C:0 | PMX Total Statistic PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F60C:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F60C:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F60C:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index F60D PMX Total Interval Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60D:0 | PMX Total Interval Energy | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F60D:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F60D:11 | Active Energy | Bilanzierte Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:12 | Active Energy Positive | Bezogene Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:13 | Active Energy Negative | Eingespeiste Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:14 | Apparent Energy | Bilanzierte Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:15 | Apparent Energy Positive | Bezogene Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:16 | Apparent Energy Negative | Eingespeiste Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:17 | Reactive Energy | Bilanzierte Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:18 | Reactive Energy Positive | Bezogene Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:19 | Reactive Energy Negative | Eingespeiste Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
Index F612 PMX Total Active Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F612:0 | PMX Total Active Reduced | Max. Subindex | UINT8 | RO | 0x12 (18dez)
F612:11 | Active Power | Wirkleistung in W | REAL32 | RO | 0x00000000 (0dez)
F612:12 | Active Energy | Wirkenergie in mWh | INT64 | RO | 0x00000000 (0dez)
Index F613 PMX Total Apparent Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F613:0 | PMX Total Apparent Reduced | Max. Subindex | UINT8 | RO | 0x12 (18dez)
F613:11 | Apparent Power | Scheinleistung in VA | REAL32 | RO | 0x00000000 (0dez)
F613:12 | Apparent Energy | Scheinenergie in mVAh | INT64 | RO | 0x00000000 (0dez)
Index F614 PMX Total Reactive Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F614:0 | PMX Total Reactive Reduced | Max. Subindex | UINT8 | RO | 0x12 (18dez)
F614:11 | Reactive Power | Blindleistung in var | REAL32 | RO | 0x00000000 (0dez)
F614:12 | Reactive Energy | Blindenergie in mvarh | INT64 | RO | 0x00000000 (0dez)
Index F615 PMX Total Interval Energy Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F615:0 | PMX Total Interval Energy Reduced | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F615:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F615:11 | Active Energy | Bilanzierte Gesamtwirkenergie im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dez)
F615:12 | Apparent Energy | Bilanzierte Gesamtscheinenergie im letzten Intervall in VAh | REAL32 | RO | 0x00000000 (0dez)
F615:13 | Reactive Energy | Bilanzierte Gesamtblindenergie im letzten Intervall in varh | REAL32 | RO | 0x00000000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Ausgangsdaten
Ausgangsdaten
Index F700 PMX Variant Value Out
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F700:0 | PMX Variant Value Out | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F700:11 | Index 1 REAL | Request für variablen Ausgabewert 1 (REAL) Nutzbar für alle Nicht-Energiewerte (Details siehe Einstellungen) | UINT16 | RO | 0x0000 (0dez)
F700:12 | Index 2 REAL | Request für variablen Ausgabewert 2 (REAL) Nutzbar für alle Nicht-Energiewerte (Details siehe Einstellungen) | UINT16 | RO | 0x0000 (0dez)
F700:13 | Index 3 REAL | Request für variablen Ausgabewert 3 (REAL) Nutzbar für alle Nicht-Energiewerte (Details siehe Einstellungen) | UINT16 | RO | 0x0000 (0dez)
F700:14 | Index 4 ULINT | Request für variablen Ausgabewert 4 (ULINT) Nutzbar für alle Energiewerte (welche als ULINT ausgegeben werden): 45-59 und 1069-1083 | UINT16 | RO | 0x0000 (0dez)
Index F701 PMX Interval
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F701:0 | PMX Interval | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F701:01 | Reset Interval | Manuelle Möglichkeit das Intervall neuzustarten (siehe Grundlagen der Funktion – Statistische Auswertung) | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 90n0 PMX Info data Voltage (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n0:0 | PMX Info data Voltage | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n0:11 | Voltage Peak | Höchster Spitzenwert der Momentanspannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
90n0:12 | Voltage RMS Minimum | Kleinster Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
90n0:13 | Voltage RMS Maximum | Größter Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
Index 90n1 PMX Info data Current (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n1:0 | PMX Info data Current | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n1:11 | Current Peak | Höchster Spitzenwert des Momentanstroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
90n1:12 | Current RMS Minimum | Kleinster Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
90n1:13 | Current RMS Maximum | Größter Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
Index 90n2 PMX Info data Power (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n2:0 | PMX Info data Power | Max. Subindex | UINT8 | RO | 0x1B (27dez)
90n2:11 | Active Power Avg | Phasenwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
90n2:12 | Active Power Min | Phasenwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
90n2:13 | Active Power Max | Phasenwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
90n2:14 | Apparent Power Avg | Phasenscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:15 | Apparent Power Min | Phasenscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:16 | Apparent Power Max | Phasenscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:17 | Reactive Power Avg | Phasenblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
90n2:18 | Reactive Power Min | Phasenblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
90n2:19 | Reactive Power Max | Phasenblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
90n2:1A | Phi | Phasenwinkel in Grad (zwischen Spannung U_Lx und dem dazugehörigen Strom I_Lx) | REAL32 | RO | 0x00000000 (0dez)
90n2:1B | Phase Angle | Phasenunterschied in Grad (zwischen unterschiedlichen Spannungen U_Lx und U_Ly) | REAL32 | RO | 0x00000000 (0dez)
Index 90n3 PMX Info data Energy (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n3:0 | PMX Info data Energy Ch.1 | Max. Subindex | UINT8 | RO | 0x19 (25dez)
90n3:11 | Active Energy | Bilanzierte Phasenwirkenergie in mWh | INT64 | RO |
90n3:12 | Positive Active Energy | Bezogene Phasenwirkenergie in mWh | UINT64 | RO |
90n3:13 | Negative Active Energy | Eingespeiste Phasenwirkenergie in mWh | UINT64 | RO |
90n3:14 | Apparent Energy | Bilanzierte Phasenscheinenergie in mWh | INT64 | RO |
90n3:15 | Positive Apparent Energy | Bezogene Phasenscheinenergie in mWh | UINT64 | RO |
90n3:16 | Negative Apparent Energy | Eingespeiste Phasenscheinenergie in mWh | UINT64 | RO |
90n3:17 | Reactive Energy | Bilanzierte Phasenblindenergie in mWh | INT64 | RO |
90n3:18 | Positive Reactive Energy | Bezogene Phasenblindenergie in mWh | UINT64 | RO |
90n3:19 | Negative Reactive Energy | Eingespeiste Phasenblindenergie in mWh | UINT64 | RO |
Index 90n4 PMX Harmonic Voltage (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n4:0 | PMX Harmonic Voltage Ch.1 | Max. Subindex | UINT8 | RO | 0x2A (42dez)
90n4:01 | Harmonic 0 | Gleichanteil der Schwingung in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n4:02 | Harmonic 1 | Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n4:03 | Harmonic 2 | 2te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n4:04 | Harmonic 3 | 3te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
90n4:2A | Harmonic 41 | 41te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
Index 90n5 PMX Harmonic Current (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n5:0 | PMX Harmonic Voltage Ch.1 | Max. Subindex | UINT8 | RO | 0x2A (42dez)
90n5:01 | Harmonic 0 | Gleichanteil der Schwingung in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n5:02 | Harmonic 1 | Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n5:03 | Harmonic 2 | 2te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n5:04 | Harmonic 3 | 3te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
90n5:2A | Harmonic 41 | 41te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
Index A0n0 PMX Diag data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | PMX Diag data Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
A0n0:11 | Saturation Time Voltage | Zeit (in 0,1 ms) in der die Klemme eine Überspannung gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
A0n0:12 | Saturation Time Current | Zeit (in 0,1 ms) in der die Klemme einen Überstrom gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Konfigurierte Revision der Klemme, (siehe Hinweis) | UINT32 | RW | 0x00000000 (0dez)
Index F80F PM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F80F:11 | Type | Hersteller-spezifische Daten | UINT32 | RW | 0x00000000 (0dez)
Index F902 PMX Total Info data Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F902:0 | PMX Total Info data Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F902:11 | Active Power Avg | Gesamtwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F902:12 | Active Power Min | Gesamtwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F902:13 | Active Power Max | Gesamtwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F902:14 | Apparent Power Avg | Gesamtscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F902:15 | Apparent Power Min | Gesamtscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F902:16 | Apparent Power Max | Gesamtscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F902:17 | Reactive Power Avg | Gesamtblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F902:18 | Reactive Power Min | Gesamtblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F902:19 | Reactive Power Max | Gesamtblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index F903 PMX Total Info data Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F903:0 | PMX Total Info data Energy | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F903:11 | Active Energy | Bilanzierte Gesamtwirkenergie in mWh | INT64 | RO |
F903:12 | Positive Active Energy | Bezogene Gesamtwirkenergie in mWh | UINT64 | RO |
F903:13 | Negative Active Energy | Eingespeiste Gesamtwirkenergie in mWh | UINT64 | RO |
F903:14 | Apparent Energy | Bilanzierte Gesamtscheinenergie in mWh | INT64 | RO |
F903:15 | Positive Apparent Energy | Bezogene Gesamtscheinenergie in mWh | UINT64 | RO |
F903:16 | Negative Apparent Energy | Eingespeiste Gesamtscheinenergie in mWh | UINT64 | RO |
F903:17 | Reactive Energy | Bilanzierte Gesamtblindenergie in mWh | INT64 | RO |
F903:18 | Positive Reactive Energy | Bezogene Gesamtblindenergie in mWh | UINT64 | RO |
F903:19 | Negative Reactive Energy | Eingespeiste Gesamtblindenergie in mWh | UINT64 | RO |
Index F904 PMX Total Info data PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F904:0 | PMX Total Info data PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F904:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index FA00 PMX Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FA00:0 | PMX Diag data | Max. Subindex | UINT8 | RO | 0x13 (19dez)
FA00:11 | Min CPU Die Temperature | Kälteste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:12 | Max CPU Die Temperature | Heißeste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:13 | EBUS Voltage | Aktuelle E-Bus Spannung | REAL32 | RO | 0x00000000 (0dez)


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Standardobjekte
Standardobjekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01551389 (22352777dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0D733052 (225652818dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | z.B. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter | Länge dieses Objektes | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO | 0x0000000000000000 (0dez)
Index 10F9 Time Distribution Object
Index | Name | Bedeutung | Datentyp | Flags | Default
10F9:0 | Time Distribution Object | Max Subindex | UINT8 | RO | 0x01 (1dez)
10F9:01 | Distributed Time Value | Objekt zur Uhrzeitverteilung durch den EtherCAT Master | INT64 | RW |
Index 1600 Total RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | Total RxPDO-Map Outputs Device | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PMX Variant Value Out), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF700:11, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (PMX Variant Value Out), entry 0x12 (Index 2 REAL)) | UINT32 | RO | 0xF700:12, 16
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (PMX Variant Value Out), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0xF700:13, 16
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x14 (Index 4 ULINT)) | UINT32 | RO | 0xF700:14, 16
Index 1601 Total RxPDO-Map Interval
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | Total RxPDO-Map Interval | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF701 (PMX Interval), entry 0x01 (Reset Interval)) | UINT32 | RO | 0xF701:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 1App TxPDO-Map Status (für L1, pp = 00; L2, pp = 0A; L3, pp = 14)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x0B (11dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x01 (Voltage Sign Bit)) | UINT32 | RO | 0x60n0:01, 1**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x08 (Current Guard Warning)) | UINT32 | RO | 0x60n0:08, 1**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x09 (Current Guard Error)) | UINT32 | RO | 0x60n0:09, 1**
1App:0A | SubIndex 010 | 10. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x00n0:00, 6**
1App:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Basic (für L1, pp = 01; L2, pp = 0B; L3, pp = 15)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Basic | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60n1:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x12 (Current)) | UINT32 | RO | 0x60n1:12, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Power (für L1, pp = 02; L2, pp = 0C; L3, pp = 16)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Power | PDO Mapping TxPDO | UINT8 | RO | 0x04 (4dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x11 (Active Power)) | UINT32 | RO | 0x60n2:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x12 (Apparent Power)) | UINT32 | RO | 0x60n2:12, 32**
1App:03 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x13 (Reactive Power)) | UINT32 | RO | 0x60n2:13, 32**
1App:04 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x14 (Power Factor)) | UINT32 | RO | 0x60n2:14, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy (für L1, pp = 03; L2, pp = 0D; L3, pp = 17)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Energy | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Timing (für L1, pp = 04; L2, pp = 0E; L3, pp = 18)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Timing | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n6 (PMX Timing), entry 0x12 (Voltage Last Zero Crossing)) | UINT32 | RO | 0x60n6:12, 64**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Advanced (für L1, pp = 05; L2, pp = 0F; L3, pp = 19)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Advanced | PDO Mapping TxPDO | UINT8 | RO | 0x06 (6dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x00n0:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n7:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x11 (Voltage Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x12 (Current Distortion Factor)) | UINT32 | RO | 0x60n7:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x13 (Current Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x14 (Cos Phi)) | UINT32 | RO | 0x60n7:14, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Voltage (für L1, pp = 06; L2, pp = 10; L3, pp = 1A)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Voltage | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x11 (Voltage Peak)) | UINT32 | RO | 0x60n8:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x12 (Voltage RMS Minimum)) | UINT32 | RO | 0x60n8:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x13 (Voltage RMS Maximum)) | UINT32 | RO | 0x60n8:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Current (für L1, pp = 07; L2, pp = 11; L3, pp = 1B)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | L1 TxPDO-Map Statistic Current | PDO Mapping TxPDO 8 | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x11 (Current Peak)) | UINT32 | RO | 0x60n9:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x12 (Current RMS Minimum)) | UINT32 | RO | 0x60n9:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x13 (Current RMS Maximum)) | UINT32 | RO | 0x60n9:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Power (für L1, pp = 08; L2, pp = 12; L3, pp = 1C)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Power | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0x60nA:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0x60nA:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0x60nA:13, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0x60nA:14, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x15 (Apparent Power Max)) | UINT32 | RO | 0x60nA:15, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x16 (Reactive Power Avg)) | UINT32 | RO | 0x60nA:16, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0x60nA:17, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0x60nA:18, 32**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x19 (Apparent Power Min)) | UINT32 | RO | 0x60nA:19, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Classic (für L1, pp = 09; L2, pp = 13; L3, pp = 1D)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Classic | PDO Mapping TxPDO | UINT8 | RO | 0x08 (8dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x00n0:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60nB:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60nB:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x12 (Current)) | UINT32 | RO | 0x60nB:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x13 (Frequency)) | UINT32 | RO | 0x60nB:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x14 (Active Power)) | UINT32 | RO | 0x60nB:14, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x15 (Apparent Power)) | UINT32 | RO | 0x60nB:15, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x16 (Reactive Power)) | UINT32 | RO | 0x60nB:16, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A1E Total TxPDO-Map Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | Total TxPDO-Map Total Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A1E:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A1E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A1E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A1E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A1F Total TxPDO-Map Basic
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1F:0 | Total TxPDO-Map Basic | PDO Mapping TxPDO 32 | UINT8 | RO | 0x03 (3dez)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF601 (PMX Grid Basic), entry 0x11 (Frequency)) | UINT32 | RO | 0xF601:11, 32
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF601 (PMX Grid Basic), entry 0x12 (Power Factor)) | UINT32 | RO | 0xF601:12, 32
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF601 (PMX Grid Basic), entry 0x13 (Calculated Neutral Line Current)) | UINT32 | RO | 0xF601:13, 32
Index 1A20 Total TxPDO-Map Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A20:0 | Total TxPDO-Map Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x08 (8dez)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:02, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0x0000:00, 13
1A20:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF602 (PMX Grid Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:10, 1
1A20:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:11, 32
1A20:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:12, 32
1A20:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0xF602:13, 32
1A20:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:14, 32
Index 1A21 Total TxPDO-Map Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A21:0 | Total TxPDO-Map Active | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dez)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x12 (Active Energy)) | UINT32 | RO | 0xF603:12, 64
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x13 (Active Positive Energy)) | UINT32 | RO | 0xF603:13, 64
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x14 (Active Negative Energy)) | UINT32 | RO | 0xF603:14, 64
Index 1A22 Total TxPDO-Map Apparent
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A22:0 | Total TxPDO-Map Apparent | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dez)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF605:12, 64
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x13 (Apparent Positive Energy)) | UINT32 | RO | 0xF605:13, 64
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x14 (Apparent Negative Energy)) | UINT32 | RO | 0xF605:14, 64
Index 1A23 Total TxPDO-Map Reactive
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A23:0 | Total TxPDO-Map Reactive | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dez)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (32 bits align) | UINT32 | RO | 0x0000:00, 32
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF607:12, 64
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x13 (Reactive Positive Energy)) | UINT32 | RO | 0xF607:13, 64
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x14 (Reactive Negative Energy)) | UINT32 | RO | 0xF607:14, 64
Index 1A24 Total TxPDO-Map Total L-L Voltage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A24:0 | Total TxPDO-Map Total L-L Voltage | PDO Mapping TxPDO 37 | UINT8 | RO | 0x03 (3dez)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x11 (L1-L2 Voltage)) | UINT32 | RO | 0xF609:11, 32
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x12 (L2-L3 Voltage)) | UINT32 | RO | 0xF609:12, 32
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x13 (L3-L1 Voltage)) | UINT32 | RO | 0xF609:13, 32
Index 1A25 Total TxPDO-Map Variant Value In
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A25:0 | Total TxPDO-Map Variant Value In | PDO Mapping TxPDO 38 | UINT8 | RO | 0x0A (10dez)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A25:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60A:10, 1
1A25:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF60A:11, 16
1A25:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x12 (Value 1 REAL)) | UINT32 | RO | 0xF60A:12, 32
1A25:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x13 (Index 2 REAL)) | UINT32 | RO | 0xF60A:13, 16
1A25:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x14 (Value 2 REAL)) | UINT32 | RO | 0xF60A:14, 32
1A25:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x15 (Index 3 REAL)) | UINT32 | RO | 0xF60A:15, 16
1A25:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x16 (Value 3 REAL)) | UINT32 | RO | 0xF60A:16, 32
1A25:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x17 (Index 4 ULINT)) | UINT32 | RO | 0xF60A:17, 16
1A25:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x18 (Value 4 ULINT)) | UINT32 | RO | 0xF60A:18, 64
Index 1A26 Total TxPDO-Map Statistic Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A26:0 | Total TxPDO-Map Statistic Power | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dez)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0xF60B:11, 32
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0xF60B:12, 32
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0xF60B:13, 32
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0xF60B:14, 32
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x15 (Apparent Power Min)) | UINT32 | RO | 0xF60B:15, 32
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x16 (Apparent Power Max)) | UINT32 | RO | 0xF60B:16, 32
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x17 (Reactive Power Avg)) | UINT32 | RO | 0xF60B:17, 32
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x18 (Reactive Power Min)) | UINT32 | RO | 0xF60B:18, 32
1A26:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x19 (Reactive Power Max)) | UINT32 | RO | 0xF60B:19, 32
Index 1A27 Total TxPDO-Map Statistic PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A27:0 | Total TxPDO-Map Statistic PQF | PDO Mapping TxPDO 40 | UINT8 | RO | 0x03 (3dez)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x11 (PQF Avg)) | UINT32 | RO | 0xF60C:11, 32
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x12 (PQF Min)) | UINT32 | RO | 0xF60C:12, 32
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x13 (PQF Max)) | UINT32 | RO | 0xF60C:13, 32
Index 1A28 Total TxPDO-Map Interval Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A28:0 | Total TxPDO-Map Interval Energy | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60D:10, 1
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF60D:11, 32
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x12 (Active Energy Positive)) | UINT32 | RO | 0xF60D:12, 32
1A28:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x13 (Active Energy Negative)) | UINT32 | RO | 0xF60D:13, 32
1A28:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x14 (Apparent Energy)) | UINT32 | RO | 0xF60D:14, 32
1A28:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x15 (Apparent Energy Positive)) | UINT32 | RO | 0xF60D:15, 32
1A28:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x16 (Apparent Energy Negative)) | UINT32 | RO | 0xF60D:16, 32
1A28:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x17 (Reactive Energy)) | UINT32 | RO | 0xF60D:17, 32
1A28:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x18 (Reactive Energy Positive)) | UINT32 | RO | 0xF60D:18, 32
1A28:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x19 (Reactive Energy Negative)) | UINT32 | RO | 0xF60D:19, 32
Index 1A29 Total TxPDO-Map Active Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A29:0 | Total TxPDO-Map Active Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dez)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (Alignet)) | UINT32 | RO | 0x0000:00, 32
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF612 (PMX Total Apparent), entry 0x12 (Active Reduced)) | UINT32 | RO | 0xF612:12, 64
Index 1A2A Total TxPDO-Map Apparent Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2A:0 | Total TxPDO-Map Apparent Reduced | PDO Mapping TxPDO 35 | UINT8 | RO | 0x02 (2dez)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x11 (Apparent Power)) | UINT32 | RO | 0xF613:11, 32
1A2A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF613 (PMX Total Apparent Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF613:12, 64
Index 1A2B Total TxPDO-Map Reactive Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2B:0 | Total TxPDO-Map Reactive Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x02 (2dez)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x11 (Reactive Power)) | UINT32 | RO | 0xF614:11, 32
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF614 (PMX Total Reactive Reduced), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF614:12, 64
Index 1A2C Total TxPDO-Map Interval Energy Reduced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2C:0 | Total TxPDO-Map Interval Energy Reduced | PDO Mapping TxPDO 36 | UINT8 | RO | 0x05 (5dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (align) | UINT32 | RO | 0x0000:00, 15
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF615:10, 1
1A2C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF615:11, 32
1A2C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF615:12, 32
1A2C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF615 (PMX Total Interval Energy Reduced), entry 0x13 (reactive Energy)) | UINT32 | RO | 0xF615:13, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Länge dieses Objekts | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x0A (10dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0A (6666dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0B (6667dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0C (6668dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A14 (6676dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A15 (6677dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A16 (6678dez)
1C13:0A | Subindex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A1E (6686dez)
1C13:0B | Subindex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | Subindex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0D | Subindex 013 | 13. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0E | Subindex 014 | 14. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0F | Subindex 015 | 15. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:10 | Subindex 016 | 16. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:11 | Subindex 017 | 17. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:12 | Subindex 018 | 18. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:13 | Subindex 019 | 19. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:14 | Subindex 020 | 20. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:15 | Subindex 021 | 21. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:16 | Subindex 022 | 22. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:17 | Subindex 023 | 23. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:18 | Subindex 024 | 24. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:19 | Subindex 025 | 25. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1A | Subindex 026 | 26. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1B | Subindex 027 | 27. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1C | Subindex 028 | 28. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1D | Subindex 029 | 29. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1E | Subindex 030 | 30. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1F | Subindex 031 | 31. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:20 | Subindex 032 | 32. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:21 | Subindex 033 | 33. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:22 | Subindex 034 | 34. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:23 | Subindex 035 | 35. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:24 | Subindex 036 | 36. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:25 | Subindex 037 | 37. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:26 | Subindex 038 | 38. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:27 | Subindex 039 | 39. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:28 | Subindex 040 | 40. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:29 | Subindex 041 | 41. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Zykluszeit (in ns): Free Run: Zykluszeit des lokalen Timers Synchron with SM 2 Event: Zykluszeit des Masters DC-Mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0 = 1: Free Run wird unterstützt Bit 1 = 1: Synchron with SM 2 Event wird unterstützt Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08) | UINT16 | RO | 0x0805 (2053dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x0007A120 (500000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C32:08 | Command | 0: Messung der lokalen Zykluszeit wird gestoppt 1: Messung der lokalen Zykluszeit wird gestartet Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert. Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Maximum delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
Index 1C33 SM input parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 3 Event (keine Outputs vorhanden) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs vorhanden) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0: Free Run wird unterstützt Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden) Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden) Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden) Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08) | UINT16 | RO | 0x0805 (2053dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x0007A120 (500000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x0007A120 (500000dez)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Größter Subindex dieses Objekts | UINT8 | RO | 0x02
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RW | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RW | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Code Word
Der Hersteller behält sich die Grundkalibrierung der Klemmen vor. Das Code Word ist daher z. Zt. reserviert.
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dez)


Command-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3443-00xx [image] Command-Objekt
Command-Objekt
Index FB00 PMX Command
Das Command Objekt wird genutzt, um in der Klemme eine Aktion auszulösen. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | PM Command | Größter Subindex dieses Objekts |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - Service Request Daten |  | OCTET-STRING [2] | RW | 0x0000 (0dez)
 |  | 4hex | Energie löschen
 |  | Byte 1 - Auswahl des Kanals
 |  | 00hex | alle Kanäle
 |  | 01hex | Kanal 1
 |  | 02hex | Kanal 2
 |  | 03hex | Kanal 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dez)
 |  | reserviert
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dez)
 |  | reserviert
 |  | Byte 1
 |  | reserviert
 |  | Byte 2-n
 |  | reserviert


EL3453

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453
EL3453
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Ausgangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte
•
Command-Objekt


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 PMX Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | PMX Settings | Max. Subindex | UINT8 | RO | 0x15 (21dez)
80n0:11 | Voltage Transformer Ratio | Falls ein Spannungswandler zum Einsatz kommt, kann hier dessen Übersetzungsverhältnis eingetragen werden. | REAL32 | RW | 1,000000 (1,000000e+000)
80n0:12 | Current Transformer Ratio | Hier kann das Übersetzungsverhältnis des verwendeten Stromwandlers eingetragen werden. | REAL32 | RW | 1,000000 (1,000000e+000)
80n0:13 | Current Transformer Delay | Hier kann eine eventuelle zeitliche Verzögerung der Stromwandler in Millisekunden eingetragen werden. | REAL32 | RW | 0,000000 (0,000000e+000)
80n0:14 | Current Range | Auswahl des Strommessbereiches 100: 100 mA 1000: 1 A 5000: 5 A | UINT32 | RW | 1 A (1000)
80n0:15 | Voltage Source | Auswahl der Spannungsreferenz: 0: Channel 1 1: Channel 2 2: Channel 3 | UINT32 | RW | Channel 1 (0)
Index 80n1 PMX Guard Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x14 (20dez)
80n1:11 | Voltage Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 2,000000 (2,000000e+000)
80n1:12 | Voltage Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 207,000000 (2,070000e+002)
80n1:13 | Voltage Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 253,000000 (2,530000e+002)
80n1:14 | Voltage Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 278,000000 (2,780000e+002)
80n1:15 | Current Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Stroms | REAL32 | RW | -1,050000 (-1,050000e+000)
80n1:16 | Current Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Stroms | REAL32 | RW | -1,000000 (-1,000000e+000)
80n1:17 | Current Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Stroms | REAL32 | RW | 1,000000 (1,000000e+000)
80n1:18 | Current Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Stroms | REAL32 | RW | 1,050000 (1,050000e+000)
Index 80n2 PMX User Scale (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n2:0 | PMX User Scale Ch.1 | Max. Subindex | UINT8 | RO | 0x15 (21dez)
80n2:01 | User Calibration Enable | Um Benutzer Kalibrierungsdaten einzuschalten auf true setzen. | BOOLEAN | RW | 0x00 (0dez)
80n2:11 | User Calibration Voltage Offset | Wert in V | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:12 | User Calibration Voltage Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80n2:13 | User Calibration Current Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
80n2:14 | User Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80n2:15 | User Calibration Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
Index F800 PMX Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | PMX Settings | Max. Subindex |  | UINT8 | RO | 0x18 (24dez)
F800:01 | Reset Interval | Manuelles Neustarten des Mess- und Statistik-Intervalls |  | BOOLEAN | RW | 0x00 (0dez)
F800:02 | Enable Static Fund Frequency | Fixierung der Grundfrequenz zur Oberwellenberechnung |  | BOOLEAN | RW | 0x00 (0dez)
F800:11 | Reference | Timing-Referenz der RMS-Berechnung Auf „Current“ stellen, wenn ohne anliegende Spannung ein Strom gemessen werden soll. erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | Voltage (default)
 |  | 1 | Current
F800:12 | Measurement Range | Filtereinstellung für die Grundschwingungsermittlung erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | 45..65 Hz (default)
 |  | 1 | 45..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Quelle der Systemfrequenz erlaubte Werte: |  | BIT1 | RW | 0x00000003 (3dez)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
 |  | 3 | Channel 1+2+3
 |  | 4 | Channel 1+2+3 fast
F800:14 | Power Calculation Threshold | Rauschreduzierung: Hier kann ein minimaler Grenzwert in Prozent für die Leistungsberechnung eingetragen werde, unterhalb dessen alle Werte gezielt genullt werden. |  | REAL32 | RW | 0,000000 (0,000000e+000)
F800:15 | Inaccurate Threshold Voltage | Grenzwert für das Warnbit: Inaccurate Voltage |  | REAL32 | RW | 1,720000 (1,720000e+000)
F800:16 | Inaccurate Threshold Current | Grenzwert für das Warnbit: Inaccurate Current |  | REAL32 | RW | 0,006000 (6,000000e-003)
F800:17 | Voltage Guard Target | Auswertungsgrundlage der Spannungswächter 0: L-N Voltages 1: L-L Voltages |  | UINT32 | RW | L-N Voltages (0)
F800:18 | Filter Length | Filterlänge der RMS-Wert-Berechnung 0: Disable 1: 2 Samples 2: 3 Samples 3: 4 Samples 4: 5 Samples 5: 6 Samples |  | UINT32 | RW | Disable (0)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F801:0 | PMX Total Settings PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F801:11 | Nominal Voltage | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird ein nominaler Spannungswert bzw. Sollwert benötigt. | REAL32 | RW | 0x43660000 (1130758144dez)
F801:12 | Nominal Frequency | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird eine nominale Frequenz bzw. Sollwert benötigt. | REAL32 | RW | 0x42480000 (1112014848dez)
F801:13 | PQF Dataset | erlaubte Werte: | UINT32 | RW | 0x00000001 (1dez)
 |  | 0: Default
 |  | 1: Default + Unbalance
Index F802 PMX Guard Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F802:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x28 (40dez)
F802:11 | Frequency Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 47,000000 (4,700000e+001)
F802:12 | Frequency Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 49,500000 (4,950000e+001)
F802:13 | Frequency Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 50,500000 (5,050000e+001)
F802:14 | Frequency Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 52,000000 (5,200000e+001)
F802:15 | Neutral Current Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,050000 (-1,050000e+000)
F802:16 | Neutral Current Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,000000 (0,000000e+000) EL3453 -1,000000 (-1,000000e+000)
F802:17 | Neutral Current Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,006000 (6,000000e-003) EL3453 1,000000 (1,000000e+000)
F802:18 | Neutral Current Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Neutralleiterstroms | REAL32 | RW | EL3423, EL3443 0,030000 (3,000000e-002) EL3453 1,050000 (1,050000e+000)
F802:19 | Active Power Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1A | Active Power Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1B | Active Power Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1C | Active Power Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Wirkleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1D | Apparent Power Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1E | Apparent Power Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:1F | Apparent Power Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:20 | Apparent Power Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Scheinleistung | REAL32 | RW | 0,000000 (0,000000e+000)
F802:21 | PQF Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 0,050000 (5,000000e-002)
F802:22 | PQF Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 0,800000 (8,000000e-001)
F802:23 | PQF Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 1,000000 (1,000000e+000)
F802:24 | PQF Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 1,000000 (1,000000e+000)
F802:25 | Unbalance Guard Min Error | Unterer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0,000000 (0,000000e+000)
F802:26 | Unbalance Guard Min Warning | Unterer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0,000000 (0,000000e+000)
F802:27 | Unbalance Guard Max Warning | Oberer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 2,000000 (2,000000e+000)
F802:28 | Unbalance Guard Max Error | Oberer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | EL3423, EL3453 0,000000 (0,000000e+000) EL3443 3,000000 (3,000000e+000)
Index F803 PMX Time Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F803:0 | PMX Time Settings | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F803:11 | Measurement Mode | erlaubte Werte: | UINT32 | RW | 0x00000000 (0dez)
 |  | 0
F803:12 | Measurement Interval | Zeitwert in Sekunden zum automatischen Neustarts des Mess- und Statistik-Intervalls | UINT32 | RW | 0x00000000 (0dez)
F803:13 | Actual System Time | Zeigt die aktuelle Systemzeit der Klemme. Objekt kann auch beschrieben werden, um die Systemzeit umzustellen. | STRING | RW |
Index F804 PMX Settings Neutral Current
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F804:0 | PMX Settings Neutral Current | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F804:12 | Current Transformer Ratio | Hier kann das Übersetzungsverhältnis des verwendeten Stromwandlers eingetragen werden. | REAL32 | RW | 1,000000 (1,000000e+000)
F804:13 | Current Transformer Delay | Hier kann eine eventuelle zeitliche Verzögerung der Stromwandler in Millisekunden eingetragen werden. | REAL32 | RW | 0,000000 (0,000000e+000)
F804:14 | Current Range | Auswahl des Strommessbereiches 100: 100 mA 1000: 1 A 5000: 5 A | UINT32 | RW | 1 A (1000)
Index F805 PMX User Scale Neutral Current
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F805:0 | PMX User Scale Neutral Current | Max. Subindex | UINT8 | RO | 0x15 (21dez)
F805:01 | User Calibration Enable | Aktiviert den Anwender Abgleich | BOOLEAN | RW | 0x00 (0dez)
F805:13 | User Calibration Current Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
F805:14 | User Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
F805:15 | User Calibration Phase Offset | Wert in ms | REAL32 | RW | 0,000000 (0,000000e+000)


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 80nF PMX Vendor data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x1C (28dez)
80nF:11 | Calibration Voltage Offset | Wert in V | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:12 | Calibration Voltage Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:13 | Calibration Voltage Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:14 | Calibration Current Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:15 | Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:16 | Calibration Current Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:17 | Calibration Current 1 Offset | Wert in mA | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:18 | Calibration Current 1 Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:19 | Calibration Current 1 Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:1A | Calibration Current 2 Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
80nF:1B | Calibration Current 2 Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
80nF:1C | Calibration Current 2 Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Eingangsdaten
Eingangsdaten
Index 60n0 PMX Status (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | PMX Status | Max. Subindex | UINT8 | RO | 0x10 (16dez)
60n0:01 | Voltage Sign Bit | Gibt das Vorzeichen der aktuellen Sinuswellenspannung an: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overvoltage | Maximal messbare Spannung ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Overcurrent | Maximal messbarer Strom ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:04 | Inaccurate Voltage | Der gemessene Spannungswert ist kleiner als der im CoE-Objekt „F800:15 Inaccurate Threshold Voltage“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Inaccurate Current | Der gemessene Stromwert ist kleiner als der im CoE-Objekt „F800:16 Inaccurate Threshold Current“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:06 | Voltage Guard Warning | Eine Warngrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Voltage Guard Error | Eine Fehlergrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 60n1 PMX Basic (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n1:0 | PMX Basic | Max. Subindex | UINT8 | RO | 0x12 (18dez)
60n1:11 | Voltage | Effektivwert der Spannung in V | REAL32 | RO | 0x00000000 (0dez)
60n1:12 | Current | Effektivwert des Stroms in A | REAL32 | RO | 0x00000000 (0dez)
Index 60n2 PMX Power (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n2:0 | PMX Power | Max. Subindex | UINT8 | RO | 0x14 (20dez)
60n2:11 | Active Power | Wirkleistung in W | REAL32 | RO | 0x00000000 (0dez)
60n2:12 | Apparent Power | Scheinleistung in VA | REAL32 | RO | 0x00000000 (0dez)
60n2:13 | Reactive Power | Blindleistung in var | REAL32 | RO | 0x00000000 (0dez)
60n2:14 | Power Factor | Leistungsfaktor | REAL32 | RO | 0x00000000 (0dez)
Index 60n3 PMX Power Fundamental (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n3:0 | PMX Power Fundamental | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n3:11 | Active Power Fund | Wirkleistung Grundschwingung in W | REAL32 | RO | 0x00000000 (0dez)
60n3:12 | Apparent Power Fund | Scheinleistung Grundschwingung in VA | REAL32 | RO | 0x00000000 (0dez)
60n3:13 | Reactive Power Fund | Blindleistung Grundschwingung in var | REAL32 | RO | 0x00000000 (0dez)
60n3:14 | Power Factor Fund | Leistungsfaktor Grundschwingung | REAL32 | RO | 0x00000000 (0dez)
Index 60n4 PMX Energy (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n4:0 | PMX Energy | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n4:11 | Active Energy | Wirkenergie in mWh | INT64 | RO |
60n4:12 | Apparent Energy | Scheinenergie in mVAh | INT64 | RO |
60n4:13 | Reactive Energy | Blindenergie in mvarh | INT64 | RO |
Index 60n5 PMX Energy Fundamental (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n5:0 | PMX Energy Fundamental | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n5:11 | Active Energy Fund | Wirkenergie Grundschwingung in mWh | INT64 | RO |
60n5:12 | Apparent Energy Fund | Scheinenergie Grundschwingung in mVAh | INT64 | RO |
60n5:13 | Reactive Energy Fund | Blindenergie Grundschwingung in mvarh | INT64 | RO |
Index 60n6 PMX Timing (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n6:0 | PMX Timing | Max. Subindex | UINT8 | RO | 0x12 (18dez)
60n6:11 | Voltage Last Zero Crossing | Letzter detektierter Spannungsnulldurchgang als DistributedClocks-Zeitpunkt | UINT64 | RO |
60n6:12 | Current Last Zero Crossing | Letzter detektierter Stromnulldurchgang als DistributedClocks-Zeitpunkt | UINT64 | RO |
Index 60n7 PMX Advanced (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n7:0 | PMX Advanced | Max. Subindex | UINT8 | RO | 0x14 (20dez)
60n7:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n7:11 | Voltage Total Harmonic Distortion | „Total Harmonic Distortion“ ist der Verzerrungsfaktor der Spannung und gibt das Verhältnis der harmonischen Anteile einer Schwingung zur ihrer Grundschwingung in % an. | REAL32 | RO | 0x00000000 (0dez)
60n7:12 | Current Distortion Factor | Der „Current Distortion Factor“ wird auch TDD (Total Demand Distortion) genannt und gibt das Verhältnis zwischen den Stromoberschwingungen und dem Maximalstrom an (EL3443: 1A und EL3443-0010: 5A, EL3453: 100mA/1A/5A). Angegeben in % des Maximalstroms. | REAL32 | RO | 0x00000000 (0dez)
60n7:13 | Current Total Harmonic Distortion | „Total Harmonic Distortion“ ist der Verzerrungsfaktor des Stroms und gibt das Verhältnis der harmonischen Anteile einer Schwingung zur ihrer Grundschwingung in % an. | REAL32 | RO | 0x00000000 (0dez)
60n7:14 | Cos Phi | Phasenwinkel der Grundwelle in Grad | REAL32 | RO | 0x00000000 (0dez)
Index 60n8 PMX Statistic Voltage (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n8:0 | PMX Statistic Voltage | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n8:11 | Voltage Peak | Höchster Spitzenwert der Momentanspannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
60n8:12 | Voltage RMS Minimum | Kleinster Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
60n8:13 | Voltage RMS Maximum | Größter Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
Index 60n9 PMX Statistic Current (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n9:0 | PMX Statistic Current | Max. Subindex | UINT8 | RO | 0x13 (19dez)
60n9:11 | Current Peak | Höchster Spitzenwert des Momentanstroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
60n9:12 | Current RMS Minimum | Kleinster Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
60n9:13 | Current RMS Maximum | Größter Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
Index 60nA PMX Statistic Power (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60nA:0 | PMX Statistic Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
60nA:11 | Active Power Avg | Wirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
60nA:12 | Active Power Min | Wirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
60nA:13 | Active Power Max | Wirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
60nA:14 | Apparent Power Avg | Scheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
60nA:15 | Apparent Power Max | Scheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
60nA:16 | Reactive Power Avg | Blindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
60nA:17 | Reactive Power Min | Blindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
60nA:18 | Reactive Power Max | Blindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
60nA:19 | Apparent Power Min | Scheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
Index 60nB PMX Classic (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
600B:0 | PMX Classic | Max. Subindex | UINT8 | RO | 0x16 (22dez)
600B:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
600B:11 | Voltage | Effektivwert der Spannung in 0,001 V | INT32 | RO | 0x00000000 (0dez)
600B:12 | Current | Effektivwert des Strom in 0,0001 A | INT32 | RO | 0x00000000 (0dez)
600B:13 | Frequency | Frequenz der Grundschwingung in 0,001 Hz | INT32 | RO | 0x00000000 (0dez)
600B:14 | Active Power | Wirkleistung in 0,001 W | INT32 | RO | 0x00000000 (0dez)
600B:15 | Apparent Power | Scheinleistung in 0,001 VA | INT32 | RO | 0x00000000 (0dez)
600B:16 | Reactive Power | Blindleistung in 0,001 var | INT32 | RO | 0x00000000 (0dez)
Index F600 PMX Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | PMX Total Status | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F600:01 | System State | Status des Gesamtsystems (als Veroderung von Voltage Guards Errors, Phasenfolge, Overvoltage, Overcurrent und Frequency Guard Error) | BOOLEAN | RO | 0x00 (0dez)
F600:02 | Grid Direction | Phasenfolge L1 - L2 - L3 richtig erkannt (bei einem rechtsdrehenden 3-Phasen-Netz) | BOOLEAN | RO | 0x00 (0dez)
F600:03 | Frequency Guard Warning | Eine Warngrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:04 | Frequency Guard Error | Eine Fehlergrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:05 | Neutral Current Guard Warning | Eine Warngrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:06 | Neutral Current Guard Error | Eine Fehlergrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:07 | Active Power Guard Warning | Eine Warngrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:08 | Active Power Guard Error | Eine Fehlergrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:09 | Apparent Power Guard Warning | Eine Warngrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0A | Apparent Power Guard Error | Eine Fehlergrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0B | Power Quality Guard Warning | Eine Warngrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0C | Power Quality Guard Error | Eine Fehlergrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0F | TxPDO State | TRUE bei allgemeinem Fehler | BOOLEAN | RO | 0x00 (0dez)
F600:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F600:11 | Power Quality Factor | Analoger Wert der Spannungsqualität zwischen 1,0 und 0 (siehe Grundlagen der Funktion - Power Quality Faktor) | REAL32 | RO | 0x00000000 (0dez)
Index F601 PMX Total Basic
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F601:0 | PMX Total Basic | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F601:11 | Frequency | Frequenz in Hz | REAL32 | RO | 0x00000000 (0dez)
F601:12 | Power Factor | Leistungsfaktor | REAL32 | RO | 0x00000000 (0dez)
F601:14 | Calculated Error Current | Berechneter Fehlerstrom (I_L1 + I_L2 + I_L3 + I_N + I_Err = 0) in A | REAL32 | RO | 0x00000000 (0dez)
F601:15 | Neutral line Current | Gemessener Effektivwert des Nulleiterstroms in A | REAL32 | RO | 0x00000000 (0dez)
F601:16 | ROCOF | Frequenzänderungsrate bzw. englisch Rate of change of frequency (ROCOF or df/dt) in Hz/s | REAL32 | RO | 0x00000000 (0dez)
Index F602 PMX Total Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F602:0 | PMX Total Advanced | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F602:01 | Unbalance Guard Warning | Eine Warngrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F602:02 | Unbalance Guard Error | Eine Fehlergrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F602:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F602:11 | Max Voltage Harmonic Distortion | Maximaler Verzerrungsfaktor aller drei Phasenspannungen in % | REAL32 | RO | 0x00000000 (0dez)
F602:12 | Max Current Harmonic Distortion | Maximaler Verzerrungsfaktor aller drei Phasenströme in % | REAL32 | RO | 0x00000000 (0dez)
F602:13 | Max Current Distortion Factor | Maximalewert der „Total Demand Distortion“ aller drei Phasen in % | REAL32 | RO | 0x00000000 (0dez)
F602:14 | Voltage Unbalance | Verhältnis zwischen Gegen- und Mitsystem der Spannungen in % | REAL32 | RO | 0x00000000 (0dez)
Index F603 PMX Total Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F603:0 | PMX Total Active | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F603:11 | Active Power | Wirkleistung in W | INT64 | RO |
F603:12 | Active Energy | Bilanzierte Wirkenergie in mWh | INT64 | RO |
F603:13 | Active Positive Energy | Bezogene Wirkenergie in mWh | INT64 | RO |
F603:14 | Active Negative Energy | Eingespeiste Wirkenergie in mWh | INT64 | RO |
Index F604 PMX Total Active Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F604:0 | PMX Total Active Fundamental | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F604:11 | Active Power Fund | Wirkleistung Grundschwingung in W | INT64 | RO |
F604:12 | Active Energy Fund | Bilanzierte Wirkenergie Grundschwingung in mWh | INT64 | RO |
F604:13 | Active Positive Energy Fund | Bezogene Wirkenergie Grundschwingung in mWh | INT64 | RO |
F604:14 | Active Negative Energy Fund | Eingespeiste Wirkenergie Grundschwingung in mWh | INT64 | RO |
Index F605 PMX Total Apparent
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F605:0 | PMX Total Apparent | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F605:11 | Apparent Power | Bilanzierte Scheinleistung in VA | INT64 | RO |
F605:12 | Apparent Energy | Bilanzierte Scheinenergie in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy | Bezogene Scheinenergie in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy | Eingespeiste Scheinenergie in mWh | UINT64 | RO |
Index F606 PMX Total Apparent Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F605:0 | PMX Total Apparent Fundamental | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F605:11 | Apparent Power Fund | Scheinleistung Grundschwingung in VA | INT64 | RO |
F605:12 | Apparent Energy Fund | Scheinenergie Grundschwingung in mWh | INT64 | RO |
F605:13 | Apparent Positive Energy Fund | Bezogene Scheinenergie Grundschwingung in mWh | UINT64 | RO |
F605:14 | Apparent Negative Energy Fund | Eingespeiste Scheinenergie Grundschwingung in mWh | UINT64 | RO |
Index F607 PMX Total Reactive
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F607:0 | PMX Total Reactive | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F607:11 | Reactive Power | Bilanzierte Blindleistung in Var | INT64 | RO |
F607:12 | Reactive Energy | Bilanzierte Blindenergie in mWh | INT64 | RO |
F607:13 | Reactive Positive Energy | Bezogene Blindenergie in mWh | UINT64 | RO |
F607:14 | Reactive Negative Energy | Eingespeiste Blindenergie in mWh | UINT64 | RO |
Index F608 PMX Total Reactive Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F608:0 | PMX Total Reactive Fundamental | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F608:11 | Reactive Power Fund | Bilanzierte Blindleistung Grundschwingung in Var | INT64 | RO |
F608:12 | Reactive Energy Fund | Bilanzierte Blindenergie Grundschwingung in mVarh | INT64 | RO |
F608:13 | Reactive Positive Energy Fund | Bezogene Blindenergie Grundschwingung in mVarh | UINT64 | RO |
F608:14 | Reactive Negative Energy Fund | Eingespeiste Blindenergie Grundschwingung in mVarh | UINT64 | RO |
Index F609 PMX Total L-L Voltages
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F609:0 | PMX Total L-L Voltages | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F609:11 | L1-L2 Voltage | Effektivwert der Außenleiterspannung zwischen L1 und L2 in V | REAL32 | RO | 0x00000000 (0dez)
F609:12 | L2-L3 Voltage | Effektivwert der Außenleiterspannung zwischen L2 und L3 in V | REAL32 | RO | 0x00000000 (0dez)
F609:13 | L3-L1 Voltage | Effektivwert der Außenleiterspannung zwischen L3 und L1 in V | REAL32 | RO | 0x00000000 (0dez)
Index F60A PMX Variant Value In
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60A:0 | PMX Variant Value In | Max. Subindex | UINT8 | RO | 0x18 (24dez)
F60A:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F60A:11 | Index 1 REAL | Acknowledge für variablen Ausgabewert 1 | UINT16 | RO | 0x0000 (0dez)
F60A:12 | Value 1 REAL | variabler Ausgabewert Kanal 1 | REAL32 | RO | 0x00000000 (0dez)
F60A:13 | Index 2 REAL | Acknowledge für variablen Ausgabewert 2 | UINT16 | RO | 0x0000 (0dez)
F60A:14 | Value 2 REAL | variabler Ausgabewert Kanal 2 | REAL32 | RO | 0x00000000 (0dez)
F60A:15 | Index 3 REAL | Acknowledge für variablen Ausgabewert 3 | UINT16 | RO | 0x0000 (0dez)
F60A:16 | Value 3 REAL | variabler Ausgabewert Kanal 3 | REAL32 | RO | 0x00000000 (0dez)
F60A:17 | Index 4 ULINT | Acknowledge für variablen Ausgabewert 4 | UINT16 | RO | 0x0000 (0dez)
F60A:18 | Value 4 ULINT | variabler Ausgabewert Kanal 4 | UINT64 | RO |
Index F60B PMX Total Statistic Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60B:0 | PMX Total Statistic Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F60B:11 | Active Power Avg | Gesamtwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F60B:12 | Active Power Min | Gesamtwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F60B:13 | Active Power Max | Gesamtwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F60B:14 | Apparent Power Avg | Gesamtscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:15 | Apparent Power Min | Gesamtscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:16 | Apparent Power Max | Gesamtscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F60B:17 | Reactive Power Avg | Gesamtblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F60B:18 | Reactive Power Min | Gesamtblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F60B:19 | Reactive Power Max | Gesamtblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index F60C PMX Total Statistic PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60C:0 | PMX Total Statistic PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F60C:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F60C:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F60C:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index F60D PMX Total Interval Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60D:0 | PMX Total Interval Energy | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F60D:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F60D:11 | Active Energy | Bilanzierte Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:12 | Active Energy Positive | Bezogene Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:13 | Active Energy Negative | Eingespeiste Gesamtwirkenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:14 | Apparent Energy | Bilanzierte Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:15 | Apparent Energy Positive | Bezogene Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:16 | Apparent Energy Negative | Eingespeiste Gesamtscheinenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:17 | Reactive Energy | Bilanzierte Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:18 | Reactive Energy Positive | Bezogene Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
F60D:19 | Reactive Energy Negative | Eingespeiste Gesamtblindenergie im letzten Intervall in mWh | REAL32 | RO | 0x00000000 (0dez)
Index F60E PMX Total Interval Energy Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60E:0 | PMX Total Interval Energy Fundamental | Max. Subindex | UINT8 | RO | 0x19 (25dec)
F60E:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dec)
F60E:11 | Active Energy Fund | Bilanzierte Gesamtwirkenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:12 | Active Energy Positive Fund | Bezogene Gesamtwirkenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:13 | Active Energy Negative Fund | Eingespeiste Gesamtwirkenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:14 | Apparent Energy Fund | Bilanzierte Gesamtscheinenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:15 | Apparent Energy Positive Fund | Bezogene Gesamtscheinenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:16 | Apparent Energy Negative Fund | Eingespeiste Gesamtscheinenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:17 | Reactive Energy Fund | Bilanzierte Gesamtblindenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:18 | Reactive Energy Positive Fund | Bezogene Gesamtblindenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
F60E:19 | Reactive Energy Negative Fund | Eingespeiste Gesamtblindenergie Grundschwingung im letzten Intervall in Wh | REAL32 | RO | 0x00000000 (0dec)
Index F60F PMX Total System Angles
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F60F:0 | PMX Total System Angles | Ma.x Subindex | UINT8 | RO | 0x15 (21dez)
F60F:11 | Voltage Angle L1 L2 | Winkel zwischen den Phasenspannungen von L1 und L2 | REAL32 | RO | 0x00000000 (0dez)
F60F:12 | Voltage Angle L1 L3 | Winkel zwischen den Phasenspannungen von L1 und L3 | REAL32 | RO | 0x00000000 (0dez)
F60F:13 | Current Angle L1 | Phasenwinkel des Stroms von L1 | REAL32 | RO | 0x00000000 (0dez)
F60F:14 | Current Angle L2 | Phasenwinkel des Stroms von L2 | REAL32 | RO | 0x00000000 (0dez)
F60F:15 | Current Angle L3 | Phasenwinkel des Stroms von L3 | REAL32 | RO | 0x00000000 (0dez)
Index F610 PMX Total System
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F610:0 | PMX Total System | Max. Subindex | UINT8 | RO | 0x15 (21dez)
F610:11 | Positive Sequence | Spannung des Mitsystems | REAL32 | RO | 0x00000000 (0dez)
F610:12 | Negative Sequence | Spannung des Gegensystems | REAL32 | RO | 0x00000000 (0dez)
F610:13 | Zero Sequence | Spannung des Nullsystems | REAL32 | RO | 0x00000000 (0dez)
Index F611 PMX Total Statistic Power Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F611:0 | PMX Total Statistic Power Fundamental | Max. Subindex | UINT8 | RO | 0x18 (24dez)
F611:10 | Active Power Avg Fund | Gesamtwirkleistungsdurchschnitt Grundschwingung des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F611:11 | Active Power Min Fund | Gesamtwirkleistungsminimum Grundschwingung im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F611:12 | Active Power Max Fund | Gesamtwirkleistungsmaximum Grundschwingung im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F611:13 | Apparent Power Avg Fund | Gesamtscheinleistungsdurchschnitt Grundschwingung des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F611:14 | Apparent Power Min Fund | Gesamtscheinleistungsminimum Grundschwingung im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F611:15 | Apparent Power Max Fund | Gesamtscheinleistungsmaximum Grundschwingung im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F611:16 | Reactive Power Avg Fund | Gesamtblindleistungsdurchschnitt Grundschwingung des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F611:17 | Reactive Power Min Fund | Gesamtblindleistungsminimum Grundschwingung im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F611:18 | Reactive Power Max Fund | Gesamtblindleistungsmaximum Grundschwingung im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Ausgangsdaten
Ausgangsdaten
Index F700 PMX Variant Value Out
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F700:0 | PMX Variant Value Out | Max. Subindex | UINT8 | RO | 0x14 (20dez)
F700:11 | Index 1 REAL | Request für variablen Ausgabewert 1 (REAL) Nutzbar für alle Nicht-Energiewerte (Details siehe Einstellungen) | UINT16 | RO | 0x0000 (0dez)
F700:12 | Index 2 REAL | Request für variablen Ausgabewert 2 (REAL) Nutzbar für alle Nicht-Energiewerte (Details siehe Einstellungen) | UINT16 | RO | 0x0000 (0dez)
F700:13 | Index 3 REAL | Request für variablen Ausgabewert 3 (REAL) Nutzbar für alle Nicht-Energiewerte (Details siehe Einstellungen) | UINT16 | RO | 0x0000 (0dez)
F700:14 | Index 4 ULINT | Request für variablen Ausgabewert 4 (ULINT) Nutzbar für alle Energiewerte (welche als ULINT ausgegeben werden): 45-59 und 1069-1083 | UINT16 | RO | 0x0000 (0dez)
Index F701 PMX Interval
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F701:0 | PMX Interval | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F701:01 | Reset Interval | Manuelle Möglichkeit das Intervall neuzustarten (siehe Grundlagen der Funktion – Statistische Auswertung) | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 90n0 PMX Info data Voltage (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n0:0 | PMX Info data Voltage | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n0:11 | Voltage Peak | Höchster Spitzenwert der Momentanspannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
90n0:12 | Voltage RMS Minimum | Kleinster Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
90n0:13 | Voltage RMS Maximum | Größter Effektivwert der Spannung im letzten Intervall in V | REAL32 | RO | 0x00000000 (0dez)
Index 90n1 PMX Info data Current (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n1:0 | PMX Info data Current | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n1:11 | Current Peak | Höchster Spitzenwert des Momentanstroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
90n1:12 | Current RMS Minimum | Kleinster Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
90n1:13 | Current RMS Maximum | Größter Effektivwert des Stroms im letzten Intervall in A | REAL32 | RO | 0x00000000 (0dez)
Index 90n2 PMX Info data Power (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n2:0 | PMX Info data Power | Max. Subindex | UINT8 | RO | 0x1B (27dez)
90n2:11 | Active Power Avg | Phasenwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
90n2:12 | Active Power Min | Phasenwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
90n2:13 | Active Power Max | Phasenwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
90n2:14 | Apparent Power Avg | Phasenscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:15 | Apparent Power Min | Phasenscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:16 | Apparent Power Max | Phasenscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
90n2:17 | Reactive Power Avg | Phasenblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
90n2:18 | Reactive Power Min | Phasenblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
90n2:19 | Reactive Power Max | Phasenblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
90n2:1A | Phi | Phasenwinkel in Grad (zwischen Spannung U_Lx und dem dazugehörigen Strom I_Lx) | REAL32 | RO | 0x00000000 (0dez)
90n2:1B | Phase Angle | Phasenunterschied in Grad (zwischen unterschiedlichen Spannungen U_Lx und U_Ly) | REAL32 | RO | 0x00000000 (0dez)
Index 90n3 PMX Info data Energy (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n3:0 | PMX Info data Energy Ch.1 | Max. Subindex | UINT8 | RO | 0x19 (25dez)
90n3:11 | Active Energy | Bilanzierte Phasenwirkenergie in mWh | INT64 | RO |
90n3:12 | Positive Active Energy | Bezogene Phasenwirkenergie in mWh | UINT64 | RO |
90n3:13 | Negative Active Energy | Eingespeiste Phasenwirkenergie in mWh | UINT64 | RO |
90n3:14 | Apparent Energy | Bilanzierte Phasenscheinenergie in mWh | INT64 | RO |
90n3:15 | Positive Apparent Energy | Bezogene Phasenscheinenergie in mWh | UINT64 | RO |
90n3:16 | Negative Apparent Energy | Eingespeiste Phasenscheinenergie in mWh | UINT64 | RO |
90n3:17 | Reactive Energy | Bilanzierte Phasenblindenergie in mWh | INT64 | RO |
90n3:18 | Positive Reactive Energy | Bezogene Phasenblindenergie in mWh | UINT64 | RO |
90n3:19 | Negative Reactive Energy | Eingespeiste Phasenblindenergie in mWh | UINT64 | RO |
Index 90n4 PMX Harmonic Voltage (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n4:0 | PMX Harmonic Voltage Ch.1 | Max. Subindex | UINT8 | RO | 0x40 (64dez)
90n4:01 | Harmonic 0 | Gleichanteil der Schwingung in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n4:02 | Harmonic 1 | Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n4:03 | Harmonic 2 | 2te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n4:04 | Harmonic 3 | 3te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
90n4:40 | Harmonic 63 | 63te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
Index 90n5 PMX Harmonic Current (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n5:0 | PMX Harmonic Voltage Ch.1 | Max. Subindex | UINT8 | RO | 0x40 (64dez)
90n5:01 | Harmonic 0 | Gleichanteil der Schwingung in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n5:02 | Harmonic 1 | Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n5:03 | Harmonic 2 | 2te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
90n5:04 | Harmonic 3 | 3te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
… | … | … | … | … | …
90n5:40 | Harmonic 63 | 63te-Oberwelle in % der Grundwelle | REAL32 | RO | 0x00000000 (0dez)
Index 90n6 PMX Info data Fundamental (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
90n6:0 | PMX Info data Fundamental Ch.1 | Max. Subindex | UINT8 | RO | 0x13 (19dez)
90n6:10 | Voltage Fundamental RMS | Effektivspannung der Grundwelle aus der Oberwellenberechnung | REAL32 | RO | 0.000000 (0.000000e+000)
90n6:11 | Voltage Fundamental Frequency | Frequenz der Spannungsgrundwelle aus der Oberwellenberechnung | REAL32 | RO | 0.000000 (0.000000e+000)
90n6:12 | Current Fundamental RMS | Effektivstrom der Grundwelle aus der Oberwellenberechnung | REAL32 | RO | 0.000000 (0.000000e+000)
90n6:13 | Current Fundamental Frequency | Frequenz der Stromgrundwelle aus der Oberwellenberechnung | REAL32 | RO | 0.000000 (0.000000e+000)
Index A0n0 PMX Diag data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | PMX Diag data Ch.1 | Max. Subindex | UINT8 | RO | 0x12 (18dez)
A0n0:11 | Saturation Time Voltage | Zeit (in 0,1 ms) in der die Klemme eine Überspannung gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
A0n0:12 | Saturation Time Current | Zeit (in 0,1 ms) in der die Klemme einen Überstrom gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Konfigurierte Revision der Klemme, (siehe Hinweis) | UINT32 | RW | 0x00000000 (0dez)
Index F80F PMX Vendor data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x1A (26dez)
F80F:11 | Type | Herstellerspezifische Daten | UINT32 | RW | 0x00000000
F80F:12 | Calibration Current Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:13 | Calibration Current Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
F80F:14 | Calibration Current Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:15 | Calibration Current 1 Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:16 | Calibration Current 1 Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
F80F:17 | Calibration Current 1 Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:18 | Calibration Current 2 Offset | Wert in A | REAL32 | RW | 0,000000 (0,000000e+000)
F80F:19 | Calibration Current 2 1 Gain | Faktor (ohne Einheit) | REAL32 | RW | 1,000000 (1,000000e+000)
F80F:1A | Calibration Current 2 Phase Offset | Wert in Millisekunden | REAL32 | RW | 0,000000 (0,000000e+000)
Index F902 PMX Grid Info data Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F902:0 | PMX Grid Info data Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F902:11 | Active Power Avg | Gesamtwirkleistungsdurchschnitt des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F902:12 | Active Power Min | Gesamtwirkleistungsminimum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F902:13 | Active Power Max | Gesamtwirkleistungsmaximum im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F902:14 | Apparent Power Avg | Gesamtscheinleistungsdurchschnitt des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F902:15 | Apparent Power Min | Gesamtscheinleistungsminimum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F902:16 | Apparent Power Max | Gesamtscheinleistungsmaximum im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F902:17 | Reactive Power Avg | Gesamtblindleistungsdurchschnitt des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F902:18 | Reactive Power Min | Gesamtblindleistungsminimum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F902:19 | Reactive Power Max | Gesamtblindleistungsmaximum im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index F903 PMX Grid Info data Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F903:0 | PMX Grid Info data Energy | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F903:11 | Active Energy | Bilanzierte Gesamtwirkenergie in mWh | INT64 | RO |
F903:12 | Positive Active Energy | Bezogene Gesamtwirkenergie in mWh | UINT64 | RO |
F903:13 | Negative Active Energy | Eingespeiste Gesamtwirkenergie in mWh | UINT64 | RO |
F903:14 | Apparent Energy | Bilanzierte Gesamtscheinenergie in mWh | INT64 | RO |
F903:15 | Positive Apparent Energy | Bezogene Gesamtscheinenergie in mWh | UINT64 | RO |
F903:16 | Negative Apparent Energy | Eingespeiste Gesamtscheinenergie in mWh | UINT64 | RO |
F903:17 | Reactive Energy | Bilanzierte Gesamtblindenergie in mWh | INT64 | RO |
F903:18 | Positive Reactive Energy | Bezogene Gesamtblindenergie in mWh | UINT64 | RO |
F903:19 | Negative Reactive Energy | Eingespeiste Gesamtblindenergie in mWh | UINT64 | RO |
Index F904 PMX Grid Info data PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F904:0 | PMX Grid Info data PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F904:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index F905 PMX Grid Info data Power Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F905:0 | PMX Grid Info data Power | Max. Subindex | UINT8 | RO | 0x19 (25dez)
F905:11 | Active Power Avg Fund | Gesamtwirkleistungsdurchschnitt Grundschwingung des letzten Intervalls in W | REAL32 | RO | 0x00000000 (0dez)
F905:12 | Active Power Min Fund | Gesamtwirkleistungsminimum Grundschwingung im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F905:13 | Active Power Max Fund | Gesamtwirkleistungsmaximum Grundschwingung im letzten Intervall in W | REAL32 | RO | 0x00000000 (0dez)
F905:14 | Apparent Power Avg Fund | Gesamtscheinleistungsdurchschnitt Grundschwingung des letzten Intervalls in VA | REAL32 | RO | 0x00000000 (0dez)
F905:15 | Apparent Power Min Fund | Gesamtscheinleistungsminimum Grundschwingung im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F905:16 | Apparent Power Max Fund | Gesamtscheinleistungsmaximum Grundschwingung im letzten Intervall in VA | REAL32 | RO | 0x00000000 (0dez)
F905:17 | Reactive Power Avg Fund | Gesamtblindleistungsdurchschnitt Grundschwingung des letzten Intervalls in var | REAL32 | RO | 0x00000000 (0dez)
F905:18 | Reactive Power Min Fund | Gesamtblindleistungsminimum Grundschwingung im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
F905:19 | Reactive Power Max Fund | Gesamtblindleistungsmaximum Grundschwingung im letzten Intervall in var | REAL32 | RO | 0x00000000 (0dez)
Index FA00 PMX Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FA00:0 | PMX Diag data | Max. Subindex | UINT8 | RO | 0x13 (19dez)
FA00:11 | Min CPU Die Temperature | Kälteste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:12 | Max CPU Die Temperature | Heißeste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:13 | EBUS Voltage | Aktuelle E-Bus Spannung | REAL32 | RO | 0x00000000 (0dez)


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Standardobjekte
Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01551389 (22352777dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0D7D3052 (226308178dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | z.B. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter | Länge dieses Objektes | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO | 0x0000000000000000 (0dez)
Index 1600 Total RxPDO-Map Outputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | Total RxPDO-Map Outputs Device | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PMX Variant Value Out), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF700:11, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (PMX Variant Value Out), entry 0x12 (Index 2 REAL)) | UINT32 | RO | 0xF700:12, 16
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (PMX Variant Value Out), entry 0x13 (Index 3 REAL)) | UINT32 | RO | 0xF700:13, 16
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7030 (PMX Variant Value Out), entry 0x14 (Index 4 ULINT)) | UINT32 | RO | 0xF700:14, 16
Index 1601 Total RxPDO-Map Interval
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | Total RxPDO-Map Interval | PDO Mapping RxPDO 2 | UINT8 | RO | 0x02 (2dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF701 (PMX Interval), entry 0x01 (Reset Interval)) | UINT32 | RO | 0xF701:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
Index 1App TxPDO-Map Status (für L1, pp = 00; L2, pp = 0C; L3, pp = 18)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x0B (11dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x01 (Voltage Sign Bit)) | UINT32 | RO | 0x60n0:01, 1**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x08 (Current Guard Warning)) | UINT32 | RO | 0x60n0:08, 1**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x09 (Current Guard Error)) | UINT32 | RO | 0x60n0:09, 1**
1App:0A | SubIndex 010 | 10. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x00n0:00, 6**
1App:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Basic (für L1, pp = 01; L2, pp = 0D; L3, pp = 19)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Basic | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60n1:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n1 (PMX Basic), entry 0x12 (Current)) | UINT32 | RO | 0x60n1:12, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Power (für L1, pp = 02; L2, pp = 0E; L3, pp = 1A)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Power | PDO Mapping TxPDO | UINT8 | RO | 0x04 (4dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x11 (Active Power)) | UINT32 | RO | 0x60n2:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x12 (Apparent Power)) | UINT32 | RO | 0x60n2:12, 32**
1App:03 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x13 (Reactive Power)) | UINT32 | RO | 0x60n2:13, 32**
1App:04 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n2 (PMX Power), entry 0x14 (Power Factor)) | UINT32 | RO | 0x60n2:14, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Power Fundamental (für L1, pp = 03; L2, pp = 0F; L3, pp = 1B)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Power Fundamental | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n3 (PMX Power Fundamental), entry 0x11 (Active Power Fund)) | UINT32 | RO | 0x60n3:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n3 (PMX Power Fundamental), entry 0x12 (Apparent Power Fund)) | UINT32 | RO | 0x60n3:12, 32**
1App:03 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n3 (PMX Power Fundamental), entry 0x13 (Reactive Power Fund)) | UINT32 | RO | 0x60n3:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy (für L1, pp = 04; L2, pp = 10; L3, pp = 1C)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Energy | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0x60n4:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0x60n4:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n4 (PMX Energy), entry 0x13 (Reactive Energy)) | UINT32 | RO | 0x60n4:13, 64**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Energy Fundamental (für L1, pp = 05; L2, pp = 11; L3, pp = 1D)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Energy Fundamental | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n5 (PMX Energy Fundamental), entry 0x11 (Active Energy Fund)) | UINT32 | RO | 0x60n5:11, 64**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n5 (PMX Energy Fundamental), entry 0x12 (Apparent Energy Fund)) | UINT32 | RO | 0x60n5:12, 64**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n5 (PMX Energy Fundamental), entry 0x13 (Reactive Energy Fund)) | UINT32 | RO | 0x60n5:13, 64**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Timing (für L1, pp = 06; L2, pp = 12; L3, pp = 1E)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Timing | PDO Mapping TxPDO | UINT8 | RO | 0x02 (2dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n6 (PMX Timing), entry 0x11 (Voltage Last Zero Crossing)) | UINT32 | RO | 0x60n6:11, 64**
1App:02 | SubIndex 002 | 1. PDO Mapping entry (object 0x60n6 (PMX Timing), entry 0x12 (Current Last Zero Crossing)) | UINT32 | RO | 0x60n6:12, 64**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Advanced (für L1, pp = 07; L2, pp = 13; L3, pp = 1F)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Advanced | PDO Mapping TxPDO | UINT8 | RO | 0x6 (6dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n7:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x11 (Voltage Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x12 (Current Distortion Factor)) | UINT32 | RO | 0x60n7:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x13 (Current Total Harmonic Distortion)) | UINT32 | RO | 0x60n7:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n7 (PMX Advanced), entry 0x14 (Cos Phi)) | UINT32 | RO | 0x60n7:14, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Voltage (für L1, pp = 08; L2, pp = 14; L3, pp = 20)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Voltage | PDO Mapping TxPDO | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x11 (Voltage Peak)) | UINT32 | RO | 0x60n8:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x12 (Voltage RMS Minimum)) | UINT32 | RO | 0x60n8:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n8 (PMX Statistic Voltage), entry 0x13 (Voltage RMS Maximum)) | UINT32 | RO | 0x60n8:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Current (für L1, pp = 09; L2, pp = 15; L3, pp = 21)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | L1 TxPDO-Map Statistic Current | PDO Mapping TxPDO 8 | UINT8 | RO | 0x03 (3dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x11 (Current Peak)) | UINT32 | RO | 0x60n9:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x12 (Current RMS Minimum)) | UINT32 | RO | 0x60n9:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n9 (PMX Statistic Current), entry 0x13 (Current RMS Maximum)) | UINT32 | RO | 0x60n9:13, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Statistic Power (für L1, pp = 0A; L2, pp = 16; L3, pp = 22)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Statistic Power | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0x60nA:11, 32**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0x60nA:12, 32**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0x60nA:13, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0x60nA:14, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x15 (Apparent Power Max)) | UINT32 | RO | 0x60nA:15, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x16 (Reactive Power Avg)) | UINT32 | RO | 0x60nA:16, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0x60nA:17, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0x60nA:18, 32**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60nA (PMX Statistic Power), entry 0x19 (Apparent Power Min)) | UINT32 | RO | 0x60nA:19, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1App TxPDO-Map Classic (für L1, pp = 0B; L2, pp = 17; L3, pp = 23)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Classic | PDO Mapping TxPDO | UINT8 | RO | 0x08 (8dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15**
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60nB:10, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x11 (Voltage)) | UINT32 | RO | 0x60nB:11, 32**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x12 (Current)) | UINT32 | RO | 0x60nB:12, 32**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x13 (Frequency)) | UINT32 | RO | 0x60nB:13, 32**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x14 (Active Power)) | UINT32 | RO | 0x60nB:14, 32**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x15 (Apparent Power)) | UINT32 | RO | 0x60nB:15, 32**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60nB (PMX Classic), entry 0x16 (Reactive Power)) | UINT32 | RO | 0x60nB:16, 32**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A24 Total TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A24:0 | Total TxPDO-Map Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dez)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A24:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A24:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A24:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A24:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A24:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A24:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A24:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A24:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A24:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A24:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A24:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A24:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A24:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A26 Total TxPDO-Map Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A26:0 | Total TxPDO-Map Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x08 (8dez)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:01, 1
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:02, 1
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0x0000:00, 13
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:10, 1
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x11 (Max Voltage Harmonic Distortion)) | UINT32 | RO | 0xF602:11, 32
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x12 (Max Current Harmonic Distortion)) | UINT32 | RO | 0xF602:12, 32
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x13 (Max Current Distortion Factor)) | UINT32 | RO | 0xF602:13, 32
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x14 (Voltage Unbalance)) | UINT32 | RO | 0xF602:14, 32
Index 1A27 Total TxPDO-Map Active
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A27:0 | Total TxPDO-Map Active | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dez)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x11 (Active Power)) | UINT32 | RO | 0xF603:11, 32
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x12 (Active Energy)) | UINT32 | RO | 0xF603:12, 64
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x13 (Active Positive Energy)) | UINT32 | RO | 0xF603:13, 64
1A27:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF603 (PMX Total Active), entry 0x14 (Active Negative Energy)) | UINT32 | RO | 0xF603:14, 64
Index 1A28 Total TxPDO-Map Active Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A28:0 | Total TxPDO-Map Active Fundamental | PDO Mapping TxPDO 34 | UINT8 | RO | 0x04 (4dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x11 (Active Power Fund)) | UINT32 | RO | 0xF604:11, 32
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x12 (Active Energy Fund)) | UINT32 | RO | 0xF604:12, 64
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x13 (Active Positive Energy Fund)) | UINT32 | RO | 0xF604:13, 64
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF604 (PMX Total Active Fundamental), entry 0x14 (Active Negative Energy Fund)) | UINT32 | RO | 0xF604:14, 64
Index 1A29 Total TxPDO-Map Apparent
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A29:0 | Total TxPDO-Map Apparent | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dez)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x11 (Apparent Power)) | UINT32 | RO | 0xF605:11, 32
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x12 (Apparent Energy)) | UINT32 | RO | 0xF605:12, 64
1A29:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x13 (Apparent Positive Energy)) | UINT32 | RO | 0xF605:13, 64
1A29:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF605 (PMX Total Apparent), entry 0x14 (Apparent Negative Energy)) | UINT32 | RO | 0xF605:14, 64
Index 1A2A Total TxPDO-Map Apparent Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2A:0 | Total TxPDO-Map Apparent Fundamental | PDO Mapping TxPDO 35 | UINT8 | RO | 0x04 (4dez)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x11 (Apparent Power Fund)) | UINT32 | RO | 0xF606:11, 32
1A2A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x12 (Apparent Energy Fund)) | UINT32 | RO | 0xF606:12, 64
1A2A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x13 (Apparent Positive Energy Fund)) | UINT32 | RO | 0xF606:13, 64
1A2A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF606 (PMX Total Apparent Fundamental), entry 0x14 (Apparent Negative Energy Fund)) | UINT32 | RO | 0xF606:14, 64
Index 1A2B Total TxPDO-Map Reactive
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2B:0 | Total TxPDO-Map Reactive | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dez)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x11 (Reactive Power)) | UINT32 | RO | 0xF607:11, 32
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x12 (Reactive Energy)) | UINT32 | RO | 0xF607:12, 64
1A2B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x13 (Reactive Positive Energy)) | UINT32 | RO | 0xF607:13, 64
1A2B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF607 (PMX Total Reactive), entry 0x14 (Reactive Negative Energy)) | UINT32 | RO | 0xF607:14, 64
Index 1A2C Total TxPDO-Map Reactive Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2C:0 | Total TxPDO-Map Reactive Fundamental | PDO Mapping TxPDO 36 | UINT8 | RO | 0x04 (4dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x11 (Reactive Power Fund)) | UINT32 | RO | 0xF608:11, 32
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x12 (Reactive Energy Fund)) | UINT32 | RO | 0xF608:12, 64
1A2C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x13 (Reactive Positive Energy Fund)) | UINT32 | RO | 0xF608:13, 64
1A2C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF608 (PMX Total Reactive Fundamental), entry 0x14 (Reactive Negative Energy Fund)) | UINT32 | RO | 0xF608:14, 64
Index 1A2D Total TxPDO-Map L-L Voltage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2D:0 | Total TxPDO-Map L-L Voltage | PDO Mapping TxPDO 37 | UINT8 | RO | 0x03 (3dez)
1A2D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF609 (PMX Total L-L Voltages), entry 0x11 (L1-L2 Voltage)) | UINT32 | RO | 0xF609:11, 32
1A2D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF609 (PMX Total L-L Voltages), entry 0x12 (L2-L3 Voltage)) | UINT32 | RO | 0xF609:12, 32
1A2D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF609 (PMX Total L-L Voltages), entry 0x13 (L3-L1 Voltage)) | UINT32 | RO | 0xF609:13, 32
Index 1A2E Total TxPDO-Map Variant Value In
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2E:0 | Total TxPDO-Map Variant Value In | PDO Mapping TxPDO 38 | UINT8 | RO | 0x0A (10dez)
1A2E:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A2E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60A:10, 1
1A2E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x11 (Index 1 REAL)) | UINT32 | RO | 0xF60A:11, 16
1A2E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x12 (Value 1 REAL)) | UINT32 | RO | 0xF60A:12, 32
1A2E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x13 (Index 2 REAL)) | UINT32 | RO | 0xF60A:13, 16
1A2E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x14 (Value 2 REAL)) | UINT32 | RO | 0xF60A:14, 32
1A2E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x15 (Index 3 REAL)) | UINT32 | RO | 0xF60A:15, 16
1A2E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x16 (Value 3 REAL)) | UINT32 | RO | 0xF60A:16, 32
1A2E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x17 (Index 4 ULINT)) | UINT32 | RO | 0xF60A:17, 16
1A2E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60A (PMX Variant Value In), entry 0x18 (Value 4 ULINT)) | UINT32 | RO | 0xF60A:18, 64
Index 1A2F Total TxPDO-Map Statistic Power
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2F:0 | Total TxPDO-Map Statistic Power | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dez)
1A2F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x11 (Active Power Avg)) | UINT32 | RO | 0xF60B:11, 32
1A2F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x12 (Active Power Min)) | UINT32 | RO | 0xF60B:12, 32
1A2F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x13 (Active Power Max)) | UINT32 | RO | 0xF60B:13, 32
1A2F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x14 (Apparent Power Avg)) | UINT32 | RO | 0xF60B:14, 32
1A2F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x15 (Apparent Power Min)) | UINT32 | RO | 0xF60B:15, 32
1A2F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x16 (Apparent Power Max)) | UINT32 | RO | 0xF60B:16, 32
1A2F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x17 (Reactive Power Avg)) | UINT32 | RO | 0xF60B:17, 32
1A2F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x18 (Reactive Power Min)) | UINT32 | RO | 0xF60B:18, 32
1A2F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60B (PMX Total Statistic Power), entry 0x19 (Reactive Power Max)) | UINT32 | RO | 0xF60B:19, 32
Index 1A30 Total TxPDO-Map Statistic PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A30:0 | Total TxPDO-Map Statistic PQF | PDO Mapping TxPDO 40 | UINT8 | RO | 0x03 (3dez)
1A30:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x11 (PQF Avg)) | UINT32 | RO | 0xF60C:11, 32
1A30:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x12 (PQF Min)) | UINT32 | RO | 0xF60C:12, 32
1A30:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60C (PMX Total Statistic PQF), entry 0x13 (PQF Max)) | UINT32 | RO | 0xF60C:13, 32
Index 1A31 Total TxPDO-Map Interval Energy
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A31:0 | Total TxPDO-Map Interval Energy | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dez)
1A31:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A31:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF60D:10, 1
1A31:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x11 (Active Energy)) | UINT32 | RO | 0xF60D:11, 32
1A31:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x12 (Active Energy Positive)) | UINT32 | RO | 0xF60D:12, 32
1A31:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x13 (Active Energy Negative)) | UINT32 | RO | 0xF60D:13, 32
1A31:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x14 (Apparent Energy)) | UINT32 | RO | 0xF60D:14, 32
1A31:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x15 (Apparent Energy Positive)) | UINT32 | RO | 0xF60D:15, 32
1A31:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x16 (Apparent Energy Negative)) | UINT32 | RO | 0xF60D:16, 32
1A31:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x17 (Reactive Energy)) | UINT32 | RO | 0xF60D:17, 32
1A31:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x18 (Reactive Energy Positive)) | UINT32 | RO | 0xF60D:18, 32
1A31:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60D (PMX Total Interval Energy), entry 0x19 (Reactive Energy Negative)) | UINT32 | RO | 0xF60D:19, 32
Index 1A32 Total TxPDO-Map Interval Energy Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A32:0 | Total TxPDO-Map Interval Energy Fundamental | PDO Mapping TxPDO 41 | UINT8 | RO | 0x0B (11dez)
1A32:01 | SubIndex 001 | 1. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1A32:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x10 (TxPDO Toggle Fund)) | UINT32 | RO | 0xF60E:10, 1
1A32:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x11 (Active Energy Fund)) | UINT32 | RO | 0xF60E:11, 32
1A32:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x12 (Active Energy Positive Fund)) | UINT32 | RO | 0xF60E:12, 32
1A32:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x13 (Active Energy Negative Fund)) | UINT32 | RO | 0xF60E:13, 32
1A32:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x14 (Apparent Energy Fund)) | UINT32 | RO | 0xF60E:14, 32
1A32:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x15 (Apparent Energy Positive Fund)) | UINT32 | RO | 0xF60E:15, 32
1A32:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x16 (Apparent Energy Negative Fund)) | UINT32 | RO | 0xF60E:16, 32
1A32:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x17 (Reactive Energy Fund)) | UINT32 | RO | 0xF60E:17, 32
1A32:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x18 (Reactive Energy Positive Fund)) | UINT32 | RO | 0xF60E:18, 32
1A32:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF60E (PMX Total Interval Energy Fundamental), entry 0x19 (Reactive Energy Negative Fund)) | UINT32 | RO | 0xF60E:19, 32
Index 1A33 Total TxPDO-Map System Angles
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A33:0 | Total TxPDO-Map System Angles | PDO Mapping TxPDO 41 | UINT8 | RO | 0x05 (5dez)
1A33:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x11 (Voltage Angle L1L2)) | UINT32 | RO | 0xF60F:11, 32
1A33:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x12 (Voltage Angle L1L3)) | UINT32 | RO | 0xF60F:12, 32
1A33:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x13 (Current Angle L1)) | UINT32 | RO | 0xF60F:13, 32
1A33:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x14 (Current Angle L2)) | UINT32 | RO | 0xF60F:14, 32
1A33:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF60F (PMX Total System Angles), entry 0x15 (Current Angle L3)) | UINT32 | RO | 0xF60F:15, 32
Index 1A34 Total TxPDO-Map System
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A34:0 | Total TxPDO-Map System | PDO Mapping TxPDO 41 | UINT8 | RO | 0x03 (3dez)
1A34:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF610 (PMX Total System ), entry 0x11 (Positive Sequence)) | UINT32 | RO | 0xF610:11, 32
1A34:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF610 (PMX Total System ), entry 0x12 (Negative Sequence)) | UINT32 | RO | 0xF610:12, 32
1A34:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF610 (PMX Total System ), entry 0x13 (Zero Sequence)) | UINT32 | RO | 0xF610:13, 32
Index 1A35 Total TxPDO-Map Statistic Power Fundamental
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A35:0 | Total TxPDO-Map Statistic Power Fundamental | PDO Mapping TxPDO 39 | UINT8 | RO | 0x09 (9dez)
1A35:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x10 (Active Power Avg Fund)) | UINT32 | RO | 0xF611:10, 32
1A35:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x11 (Active Power Min Fund)) | UINT32 | RO | 0xF611:11, 32
1A35:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x12 (Active Power Max Fund)) | UINT32 | RO | 0xF611:12, 32
1A35:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x13 (Apparent Power Avg Fund)) | UINT32 | RO | 0xF611:13, 32
1A35:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x14 (Apparent Power Min Fund)) | UINT32 | RO | 0xF611:14, 32
1A35:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x15 (Apparent Power Max Fund)) | UINT32 | RO | 0xF611:15, 32
1A35:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x16 (Reactive Power Avg Fund)) | UINT32 | RO | 0xF611:16, 32
1A35:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x17 (Reactive Power Min)) | UINT32 | RO | 0xF611:17, 32
1A35:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF611 (PMX Total Statistic Power Fundamental), entry 0x18 (Reactive Power Max)) | UINT32 | RO | 0xF611:18, 32
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Länge dieses Objekts | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x0A (10dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0C (6668dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0D (6698dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0E (6670dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A18 (6680dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A19 (6681dez)
1C13:09 | Subindex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A1A (6682dez)
1C13:0A | Subindex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A24 (6692dez)
1C13:0B | Subindex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
… |  |  |  |  |
1C13:36 | Subindex 054 | 54. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 2 Event 2: DC-Mode - Synchron with SYNC0 Event 3: DC-Mode - Synchron with SYNC1 Event | UINT16 | RW | 0x0000 (0dez)
1C32:02 | Cycle time | Zykluszeit (in ns): Free Run: Zykluszeit des lokalen Timers Synchron with SM 2 Event: Zykluszeit des Masters DC-Mode: SYNC0/SYNC1 Cycle Time | UINT32 | RW | 0x0016E360 (1500000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0 = 1: Free Run wird unterstützt Bit 1 = 1: Synchron with SM 2 Event wird unterstützt Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08) | UINT16 | RO | 0x0805 (2053dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x0007A120 (500000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C32:08 | Command | 0: Messung der lokalen Zykluszeit wird gestoppt 1: Messung der lokalen Zykluszeit wird gestartet Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert. Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt | UINT16 | RW | 0x0000 (0dez)
1C32:09 | Maximum delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
Index 1C33 SM input parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 3 Event (keine Outputs vorhanden) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs vorhanden) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0: Free Run wird unterstützt Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden) Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden) Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden) Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08) | UINT16 | RO | 0x0805 (2053dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x0007A120 (500000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x0007A120 (500000dez)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)


Command-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3453 [image] Command-Objekt
Command-Objekt
Index FB00 PMX Command
Das Command Objekt wird genutzt, um in der Klemme eine Aktion auszulösen. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | PM Command | Größter Subindex dieses Objekts |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - Service Request Daten |  | OCTET-STRING [2] | RW | 0x0000 (0dez)
 |  | 4hex | Energie löschen
 |  | Byte 1 - Auswahl des Kanals
 |  | 00hex | alle Kanäle
 |  | 01hex | Kanal 1
 |  | 02hex | Kanal 2
 |  | 03hex | Kanal 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dez)
 |  | reserviert
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dez)
 |  | reserviert
 |  | Byte 1
 |  | reserviert
 |  | Byte 2-n
 |  | reserviert


EL3483-00xx

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx
EL3483-00xx
Weiterführende Informationen
•
Restore Objekt
•
Konfigurationsdaten
•
Konfigurationsdaten (herstellerspezifisch)
•
Eingangsdaten
•
Informations- und Diagnostikdaten
•
Standardobjekte
•
Command-Objekt


Restore Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Restore Objekt
Restore Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Konfigurationsdaten
Konfigurationsdaten
Index 80n0 PMX Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | PMX Settings | Max. Subindex | UINT8 | RO | 0x13 (19dez)
80n0:11 | Voltage Transformer Ratio | Falls ein Spannungswandler zum Einsatz kommt, kann hier dessen Übersetzungsverhältnis eingetragen werden. | REAL32 | RW | 0x3F800000 (1065353216dez)
Index 80n1 PMX Guard Settings (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x14 (20dez)
80n1:11 | Voltage Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 0x40000000 (1073741824dez)
80n1:12 | Voltage Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 0x434F0000 (1129250816dez)
80n1:13 | Voltage Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Spannung | REAL32 | RW | 0x437D0000 (1132265472dez)
80n1:14 | Voltage Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Spannung | REAL32 | RW | 0x438B0000 (1133182976dez)
Index F800 PMX Settings
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
F800:0 | PMX Settings | Max. Subindex |  | UINT8 | RO | 0x15 (21ez)
F800:01 | Reset Interval | Manuelles Neustarten des Mess- und Statistik-Intervalls |  | BOOLEAN | RW | 0x00 (0dez)
F800:12 | Measurement Range | Filtereinstellung für die Grundschwingungsermittlung erlaubte Werte: |  | UINT32 | RW | 0x00000000 (0dez)
 |  | 0 | 45..65 Hz (default)
 |  | 1 | 45..400 Hz
 |  | 2 | 12..45 Hz
F800:13 | Frequency Source | Quelle der Systemfrequenz erlaubte Werte: |  | BIT1 | RW | 0x00000000 (0dez)
 |  | 0 | Channel 1 (default)
 |  | 1 | Channel 2
 |  | 2 | Channel 3
F800:15 | Inaccurate Threshold Voltage | Grenzwert für das Warnbit: Inaccurate Voltage |  | REAL32 | RW | 0x3FDC28F6 (1071393014dez)
Index F801 PMX Total Settings PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F801:0 | PMX Total Settings PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F801:11 | Nominal Voltage | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird ein nominaler Spannungswert bzw. Sollwert benötigt. | REAL32 | RW | 0x43660000 (1130758144dez)
F801:12 | Nominal Frequency | Zur Berechnung des Power Quality Faktors (Details siehe Grundlagen zur Funktion) wird eine nominale Frequenz bzw. Sollwert benötigt. | REAL32 | RW | 0x42480000 (1112014848dez)
F801:13 | PQF Dataset | erlaubte Werte: | UINT32 | RW | 0x00000001 (1dez)
 |  | 0: Default
 |  | 1: Default + Unbalance
Index F802 PMX Guard Settings
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F802:0 | PMX Guard Settings | Max. Subindex | UINT8 | RO | 0x28 (40dez)
F802:11 | Frequency Guard Min Error | Unterer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 0x423C0000 (1111228416dez)
F802:12 | Frequency Guard Min Warning | Unterer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 0x42460000 (1111883776dez)
F802:13 | Frequency Guard Max Warning | Oberer Grenzwert für eine Warnmeldung der Frequenz | REAL32 | RW | 0x424A0000 (1112145920dez)
F802:14 | Frequency Guard Max Error | Oberer Grenzwert für eine Fehlermeldung der Frequenz | REAL32 | RW | 0x42500000 (1112539136dez)
F802:21 | PQF Guard Min Error | Unterer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 0x3D4CCCCD (1028443341dez)
F802:22 | PQF Guard Min Warning | Unterer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 0x3F4CCCCD (1061997773dez)
F802:23 | PQF Guard Max Warning | Oberer Grenzwert für eine Warnmeldung des Power-Quality-Faktors | REAL32 | RW | 0x3F800000 (1065353216dez)
F802:24 | PQF Guard Max Error | Oberer Grenzwert für eine Fehlermeldung des Power-Quality-Faktors | REAL32 | RW | 0x3F800000 (1065353216dez)
F802:25 | Unbalance Guard Min Error | Unterer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0x00000000 (0dez)
F802:26 | Unbalance Guard Min Warning | Unterer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0x00000000 (0dez)
F802:27 | Unbalance Guard Max Warning | Oberer Grenzwert für eine Warnmeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0x00000000 (0dez)
F802:28 | Unbalance Guard Max Error | Oberer Grenzwert für eine Fehlermeldung wegen Spannungsunsymmetrie | REAL32 | RW | 0x00000000 (0dez)


Konfigurationsdaten (herstellerspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Konfigurationsdaten (herstellerspezifisch)
Konfigurationsdaten (herstellerspezifisch)
Index 80nF PMX Vendor data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x13 (19dez)
80nF:11 | Calibration Voltage Offset | Wert in V | REAL32 | RW | 0x00000000 (0dez)
80nF:12 | Calibration Voltage Gain | Faktor (ohne Einheit) | REAL32 | RW | 0x3F800000 (1065353216dez)
80nF:13 | Calibration Voltage Phase Offset | Wert in Millisekunden | REAL32 | RW | 0x00000000 (0dez)


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Eingangsdaten
Eingangsdaten
Index 60n0 PMX Status (n = 0, 1, 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | PMX Status | Max. Subindex | UINT8 | RO | 0x10 (16dez)
60n0:01 | Voltage Sign Bit | Gibt das Vorzeichen der aktuellen Sinuswellenspannung an: 1 = U > 0V 0 = U < 0V | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overvoltage | Maximal messbare Spannung ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Overcurrent | Maximal messbarer Strom ist überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:04 | Inaccurate Voltage | Der gemessene Spannungswert ist kleiner als der im CoE-Objekt „F800:15 Inaccurate Threshold Voltage“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:05 | Inaccurate Current | Der gemessene Stromwert ist kleiner als der im CoE-Objekt „F800:16 Inaccurate Threshold Current“ eingetragene Wert. | BOOLEAN | RO | 0x00 (0dez)
60n0:06 | Voltage Guard Warning | Eine Warngrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Voltage Guard Error | Eine Fehlergrenze des Spannungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 60n1*** PMX Basic (n = 0, 1, 2)***
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n1:0 | PMX Basic | Max. Subindex | UINT8 | RO | 0x11 (17dez)
60n1:11 | Voltage | Effektivwert der Spannung in V | REAL32 | RO | 0x00000000 (0dez)
***) nur bei EL3483-0060
Index F600 PMX Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F600:0 | PMX Total Status | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F600:01 | System State | Status des Gesamtsystems (als Veroderung von Voltage Guards Errors, Phasenfolge, Overvoltage, Overcurrent und Frequency Guard Error) | BOOLEAN | RO | 0x00 (0dez)
F600:02 | Grid Direction | Phasenfolge L1 - L2 - L3 richtig erkannt (bei einem rechtsdrehenden 3-Phasen-Netz) | BOOLEAN | RO | 0x00 (0dez)
F600:03 | Frequency Guard Warning | Eine Warngrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:04 | Frequency Guard Error | Eine Fehlergrenze des Frequenzswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:05 | Neutral Current Guard Warning | Eine Warngrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:06 | Neutral Current Guard Error | Eine Fehlergrenze des Neutralleiterstromswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:07 | Active Power Guard Warning | Eine Warngrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:08 | Active Power Guard Error | Eine Fehlergrenze des Wirkleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:09 | Apparent Power Guard Warning | Eine Warngrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0A | Apparent Power Guard Error | Eine Fehlergrenze des Scheinleistungswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0B | Power Quality Guard Warning | Eine Warngrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0C | Power Quality Guard Error | Eine Fehlergrenze des PQF-Wächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F600:0F | TxPDO State | TRUE bei allgemeinem Fehler | BOOLEAN | RO | 0x00 (0dez)
F600:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
F600:11 | Power Quality Factor | Analoger Wert der Spannungsqualität zwischen 1,0 und 0 (siehe Grundlagen der Funktion - Power Quality Faktor) | REAL32 | RO | 0x00000000 (0dez)
Index F602 PMX Total Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F602:0 | PMX Total Advanced | Max. Subindex | UINT8 | RO | 0x02 (2dez)
F602:01 | Unbalance Guard Warning | Eine Warngrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)
F602:02 | Unbalance Guard Error | Eine Fehlergrenze des Unsymmetrieswächters ist über-/ unterschritten. | BOOLEAN | RO | 0x00 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index A0n0 PMX Diag data (für Ch.1, n = 0; Ch.2, n = 1; Ch.3, n = 2)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A0n0:0 | PMX Diag data Ch.1 | Max. Subindex | UINT8 | RO | 0x11 (17dez)
A0n0:11 | Saturation Time Voltage | Zeit (in 0,1 ms) in der die Klemme eine Überspannung gemessen hat. | UINT32 | RO | 0x00000000 (0dez)
Index F081 Download revision
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F081:0 | Download revision | Max. Subindex | UINT8 | RO | 0x01 (1dez)
F081:01 | Revision number | Konfigurierte Revision der Klemme, (siehe Hinweis) | UINT32 | RW | 0x00000000 (0dez)
Index F80F PM Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | PMX Vendor data | Max. Subindex | UINT8 | RO | 0x11 (17dez)
F80F:11 | Type | Hersteller-spezifische Daten | UINT32 | RW | 0x00000000 (0dez)
Index F904 PMX Total Info data PQF
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F904:0 | PMX Total Info data PQF | Max. Subindex | UINT8 | RO | 0x13 (19dez)
F904:11 | PQF Avg | Durchschnittswert des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:12 | PQF Min | Minimum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
F904:13 | PQF Max | Maximum des Power Quality Faktors im letzten Intervall | REAL32 | RO | 0x00000000 (0dez)
Index FA00 PMX Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FA00:0 | PMX Diag data | Max. Subindex | UINT8 | RO | 0x13 (19dez)
FA00:11 | Min CPU Die Temperature | Kälteste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:12 | Max CPU Die Temperature | Heißeste CPU-Temperatur die bisher gemessen wurde | REAL32 | RO | 0x00000000 (0dez)
FA00:13 | EBUS Voltage | Aktuelle E-Bus Spannung | REAL32 | RO | 0x00000000 (0dez)


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Standardobjekte
Standardobjekte
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01551389 (22352777dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL34xx
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO |
Index 100B Bootloader version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100B:0 | Bootloader version | Bootloader version | STRING | RO |
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0D9B3052 (228274258dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter | Länge dieses Objektes | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dez)
Index 10F3 Diagnosis History
Index | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | Maximaler Subindex | UINT8 | RO | 0x15 (21dez)
10F3:01 | Maximum Messages | Maximale Anzahl der gespeicherten Nachrichten. Es können maximal 50 Nachrichten gespeichert werden | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message | Subindex der neusten Nachricht | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message | Subindex der letzten bestätigten Nachricht | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available | Zeigt an, wenn eine neue Nachricht verfügbar ist | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags | ungenutzt | UINT16 | RW | 0x0000 (0dez)
10F3:06 | Diagnosis Message 001 | Nachricht 1 | OCTET-STRING[28] | RO | {0}
... | ... | ... | ... | ... | ...
10F3:15 | Diagnosis Message 016 | Nachricht 16 | OCTET-STRING[28] | RO | {0}
Index 10F8 Actual Time Stamp
Index | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Zeitstempel | UINT64 | RO | 0x0000000000000000 (0dez)
Index 1App TxPDO-Map Status (für L1, pp = 00; L2, pp = 0A; L3, pp = 14)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x02 (Overvoltage)) | UINT32 | RO | 0x60n0:02, 1**
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x03 (Overcurrent)) | UINT32 | RO | 0x60n0:03, 1**
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x04 (Inaccurate Voltage)) | UINT32 | RO | 0x60n0:04, 1**
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x05 (Inaccurate Current)) | UINT32 | RO | 0x60n0:05, 1**
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x06 (Voltage Guard Warning)) | UINT32 | RO | 0x60n0:06, 1**
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x07 (Voltage Guard Error)) | UINT32 | RO | 0x60n0:07, 1**
1App:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8**
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (PMX Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x60n0:10, 1**
**) für L1, n = 0; L2, n = 1; L3, n = 2)
Index 1A01*** L1 TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | L1 TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (PMX Basic), entry 0x01 (Voltage)) | UINT32 | RO | 0x6001:11, 32
***) nur für EL3483-0060
Index 1A0B*** L2 TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | L2 TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (PMX Basic), entry 0x01 (Voltage)) | UINT32 | RO | 0x6011:11, 32
***) nur für EL3483-0060
Index 1A15*** L3 TxPDO-Map Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | L3 TxPDO-Map Status | PDO Mapping TxPDO | UINT8 | RO | 0x01 (1dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (PMX Basic), entry 0x01 (Voltage)) | UINT32 | RO | 0x6021:11, 32
***) nur für EL3483-0060
Index 1A1E Total TxPDO-Map Total Status
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | Total TxPDO-Map Total Status | PDO Mapping TxPDO 31 | UINT8 | RO | 0x10 (16dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x01 (System State)) | UINT32 | RO | 0xF600:01, 1
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x02 (Grid Direction)) | UINT32 | RO | 0xF600:02, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x03 (Frequency Guard Warning)) | UINT32 | RO | 0xF600:03, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x04 (Frequency Guard Error)) | UINT32 | RO | 0xF600:04, 1
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x05 (Neutral Current Guard Warning)) | UINT32 | RO | 0xF600:05, 1
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x06 (Neutral Current Guard Error)) | UINT32 | RO | 0xF600:06, 1
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x07 (Active Power Guard Warning)) | UINT32 | RO | 0xF600:07, 1
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x08 (Active Power Guard Error)) | UINT32 | RO | 0xF600:08, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x09 (Apparent Power Guard Warning)) | UINT32 | RO | 0xF600:09, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0A (Apparent Power Guard Error)) | UINT32 | RO | 0xF600:0A, 1
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0B (Power Quality Guard Warning)) | UINT32 | RO | 0xF600:0B, 1
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0C (Power Quality Guard Error)) | UINT32 | RO | 0xF600:0C, 1
1A1E:0D | SubIndex 013 | 13. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A1E:0E | SubIndex 014 | 14. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x0F (TxPDO State)) | UINT32 | RO | 0xF600:0F, 1
1A1E:0F | SubIndex 015 | 15. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0xF600:10, 1
1A1E:10 | SubIndex 016 | 16. PDO Mapping entry (object 0xF600 (PMX Total Status), entry 0x11 (Power Quality Factor)) | UINT32 | RO | 0xF600:11, 32
Index 1A20 Total TxPDO-Map Total Advanced
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A20:0 | Total TxPDO-Map Total Advanced | PDO Mapping TxPDO 33 | UINT8 | RO | 0x03 (3dez)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x01 (Unbalance Guard Warning)) | UINT32 | RO | 0xF602:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF602 (PMX Total Advanced), entry 0x02 (Unbalance Guard Error)) | UINT32 | RO | 0xF602:02, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (14 bits align) | UINT32 | RO | 0x0000:00, 14
Index 1A24*** Total TxPDO-Map Total L-L Voltage
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A24:0 | Total TxPDO-Map Total L-L Voltage | PDO Mapping TxPDO 37 | UINT8 | RO | 0x03 (3dez)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x11 (L1-L2 Voltage)) | UINT32 | RO | 0xF609:11, 32
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x12 (L2-L3 Voltage)) | UINT32 | RO | 0xF609:12, 32
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF609 (PMX Grid L-L Voltages), entry 0x13 (L3-L1 Voltage)) | UINT32 | RO | 0xF609:13, 32
***) nur für EL3483-0060
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Länge dieses Objekts | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0A (6666dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A14 (6676dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A1E (6686dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C33 SM input parameter
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 | Sync mode | Aktuelle Synchronisierungsbetriebsart: 0: Free Run 1: Synchron with SM 3 Event (keine Outputs vorhanden) 2: DC - Synchron with SYNC0 Event 3: DC - Synchron with SYNC1 Event 34: Synchron with SM 2 Event (Outputs vorhanden) | UINT16 | RW | 0x0000 (0dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x0016E360 (1500000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:04 | Sync modes supported | Unterstützte Synchronisierungsbetriebsarten: Bit 0: Free Run wird unterstützt Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden) Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden) Bit 2-3 = 01: DC-Mode wird unterstützt Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden) Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden) Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08) | UINT16 | RO | 0x0805 (2053dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x0007A120 (500000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x0007A120 (500000dez)
1C33:07 | Minimum delay time |  | UINT32 | RO | 0x00000384 (900dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000384 (900dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Größter Subindex dieses Objekts | UINT8 | RO | 0x02
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RW | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RW | 0x0003 (3dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Code Word
Der Hersteller behält sich die Grundkalibrierung der Klemmen vor. Das Code Word ist daher z. Zt. reserviert.
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000155 (341dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000155 (341dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000155 (341dez)


Command-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] EL3483-00xx [image] Command-Objekt
Command-Objekt
Index FB00 PMX Command
Das Command Objekt wird genutzt, um in der Klemme eine Aktion auszulösen. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | PM Command | Größter Subindex dieses Objekts |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - Service Request Daten |  | OCTET-STRING [2] | RW | 0x0000 (0dez)
 |  | 4hex | Energie löschen
 |  | Byte 1 - Auswahl des Kanals
 |  | 00hex | alle Kanäle
 |  | 01hex | Kanal 1
 |  | 02hex | Kanal 2
 |  | 03hex | Kanal 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dez)
 |  | reserviert
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dez)
 |  | reserviert
 |  | Byte 1
 |  | reserviert
 |  | Byte 2-n
 |  | reserviert


Anwendungsbeispiele

Anwendungsbeispiele
Anwendungsbeispiele
Weiterführende Informationen
•
Leistungsmessung an einem Motor mit 2 bzw. 3 Stromwandlern
•
Leistungsmessung an einer Maschine
•
Leistungsmessung in einem einphasigen Netz mit ohmschen Verbrauchern
•
Leistungsmessung an einer Feldbusstation
•
Leistungsmessung an von einem Frequenzumrichter gesteuerten Drehstrommotoren
•
Leistungsmessung mit der EL3453 (inklusive Differenzstrommessung)
•
Beispiel-Funktionsbausteine zur Auswertung


Leistungsmessung an einem Motor mit 2 bzw. 3 Stromwandlern

Anwendungsbeispiele [image] Leistungsmessung an einem Motor mit 2 bzw. 3 Stromwandlern
Leistungsmessung an einem Motor mit 2 bzw. 3 Stromwandlern
SmallWarningYellow WARNUNG
WARNUNG: Verletzungsgefahr durch Stromschlag!
Wenn Sie die Klemmstelle N nicht mit dem Nulleiter Ihres Versorgungsnetzes verbinden, müssen Sie die Klemmstelle N erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!
Hinweis
Achtung! Beschädigung der Geräte möglich!
Achten Sie beim Anschluss darauf, Strom und Spannungspfad nicht zu verwechseln, da der direkte Anschluss von Netzspannung an die Klemmstellen für die Stromwandler (Eingangswiderstand typisch 220 mΩ) die Leistungsmessklemme zerstört!
EL3443
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 .
▪
Die Strommessung erfolgt mittels zweier Stromwandler über die Anschlüsse IL1, IL2.
▪
Die Summe der aller Ströme im 3-Phasennetz addiert sich zu 0; durch die Beschaltung der EL3443 ergibt sich der Wert im Stromkreis IL3 entsprechend.
EL3443, Leistungsmessung mit 2 Stromwandlern an einem Motor
Bei der oberen Beschaltung (Abb. EL3443, Leistungsmessung mit 2 Stromwandlern an einem Motor) ist darauf zu achten, dass das Drehstromnetz entweder erdfrei ist oder einen geerdeten Sternpunkt besitzt. Eine weitere Option ist das Vorschalten eines Transformators in Yy0-Schaltung.
EL3453
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 .
▪
Die Strommessung erfolgt mittels dreier Stromwandler über die Anschlüsse IL1, IL2, IL3
EL3453, Leistungsmessung mit 3 Stromwandlern an einem Motor
Bei der oberen Beschaltung (Abb. EL3453, Leistungsmessung mit 3 Stromwandlern an einem Motor) ist darauf zu achten, dass das Drehstromnetz entweder erdfrei ist oder einen geerdeten Sternpunkt besitzt. Eine weitere Option ist das Vorschalten eines Transformators in Yy0-Schaltung.


Leistungsmessung an einer Maschine

Anwendungsbeispiele [image] Leistungsmessung an einer Maschine
Leistungsmessung an einer Maschine
SmallWarningYellow WARNUNG
WARNUNG: Verletzungsgefahr durch Stromschlag!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Hinweis
Achtung! Beschädigung der Geräte möglich!
Achten Sie beim Anschluss darauf, Strom und Spannungspfad nicht zu verwechseln, da der direkte Anschluss von Netzspannung an die Klemmstellen für die Stromwandler (Eingangswiderstand typisch 100 mΩ) die Leistungsmessklemme zerstört!
EL3443
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 und N.
▪
Die Strommessung erfolgt mittels dreier Stromwandler über die Anschlüsse IL1, IL2, IL3 und IN (Sternpunkt der Stromwandler).
Leistungsmessung an einer Maschine mit der EL3443
**) PE als Sternpunkt für 3-Phasensysteme ohne Neutralleiter
In Abhängigkeit der verwendeten Stromwandler ist in 3-Phasensystemen ohne Neutralleiter PE als Sternpunkt wie in Abb. „Leistungsmessung an einer Maschine mit der EL3443“ anzuschließen.
Beachten Sie hier die Bestimmungen des Herstellers der Stromwandler!
Negative Leistungswerte
Falls Sie in einem Pfad negative Leistungswerte messen, überprüfen Sie bitte, ob Sie den zugehörigen Stromwandlerpfad richtig herum angeschlossen haben.
EL3453
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 und N.
▪
Die Strommessung erfolgt mittels 4 Stromwandler über die Anschlüsse IL1, IL2, IL3 und IN (Sternpunkt der Stromwandler).
Leistungsmessung an einer Maschine mit der EL3453
Negative Leistungswerte
Falls Sie in einem Pfad negative Leistungswerte messen, überprüfen Sie bitte, ob Sie den zugehörigen Stromwandlerpfad richtig herum angeschlossen haben.


Leistungsmessung in einem einphasigen Netz mit ohmschen Verbrauchern

Anwendungsbeispiele [image] Leistungsmessung in einem einphasigen Netz mit ohmschen Verbrauchern
Leistungsmessung in einem einphasigen Netz mit ohmschen Verbrauchern
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 und N.
▪
Die Strommessung erfolgt mittels dreier Stromwandler über die Anschlüsse IL1, IL2, IL3 und IN (Sternpunkt der Stromwandler).
SmallWarningYellow WARNUNG
WARNUNG: Verletzungsgefahr durch Stromschlag!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Hinweis
Achtung! Beschädigung der Geräte möglich!
Achten Sie beim Anschluss darauf, Strom und Spannungspfad nicht zu verwechseln, da der direkte Anschluss von Netzspannung an die Klemmstellen für die Stromwandler (Eingangswiderstand typisch 220 mΩ) die Leistungsmessklemme zerstört!
Leistungsmessung an ohmschen Verbrauchern


Leistungsmessung an einer Feldbusstation

Anwendungsbeispiele [image] Leistungsmessung an einer Feldbusstation
Leistungsmessung an einer Feldbusstation
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Das Beispiel zeigt die Leistungsmessung an drei Stromkreisen der Feldbusstation. Die Klemme misst die:
▪
Leistungsaufnahme von Buskoppler und E-Bus-Versorgung
▪
Leistungsaufnahme der Powerkontakte
▪
Leistungsaufnahme AS-i über die AS-i Potentialeinspeiseklemme (EL9520)
Hinweis
Nennstrom beachten!
Im Beispiel wird der Sondertyp EL3443-0010 mit einem erweiterten Strom-Messbereich (maximal 5 A) verwendet. Der Standardtyp EL3443 ist für dieses Anwendungsbeispiel aufgrund des zu kleinen Strom-Messbereichs (1 A) nicht geeignet!
Anwendungsbeispiel - Leistungsmessung an einer Feldbusstation


Leistungsmessung an von einem Frequenzumrichter gesteuerten Drehstrommotoren

Anwendungsbeispiele [image] Leistungsmessung an von einem Frequenzumrichter gesteuerten Drehstrommotoren
Leistungsmessung an von einem Frequenzumrichter gesteuerten Drehstrommotoren
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Das Beispiel zeigt die Leistungsmessung an mehreren von einem Frequenzumrichter (Wechselstromumrichter) gesteuerten Drehstrommotoren, z. B. an einer Förderanlage. Jeder Motor wird von einer EL3443 überwacht.
Anwendungsbeispiel mit Frequenzumrichter
Die galvanische Trennung des vor den Spannungspfad der Leistungsmessklemmen geschalteten Dreiphasen-Transformators (Yy0) ermöglicht die Messung hinter dem Frequenzumrichter.
Messfehler im unteren Frequenzbereich
Bei der Leistungsmessung hinter Frequenzumrichtern ist im unteren Frequenzbereich besonders bei der Spannungsmessung ein größerer Messfehler möglich. Dieser Fehler geht auch in die Leistungsberechnung ein.
Der Dreiphasen-Transformator sollte ein Übersetzungsverhältnis von 1:1 haben und darf keine Phasenverschiebung des Signals verursachen! Da hochfrequente Anteile auf die Motoren nur wenig Einfluss haben sind die durch den Dreiphasen-Transformator bedingten Verzerrungen bei der Übertragung der durch den Frequenzumrichter erzeugten Oberwellen ohne große Auswirkung auf die praktische Messung.
Durch die Verwendung von je einer Leistungsmessklemme pro Motor wird die Aufteilung der Leistung sehr gut abgebildet. Eine überhöhte Stromaufnahme eines einzelnen Motors kann rechtzeitig erkannt werden.
Die Messung von Gleichspannung/Gleichstrom (z. B. Halteströme von Synchronmotoren) ist auf diese Art nicht möglich! Praktische Ergebnisse ergeben sich je nach verwendeten Dreiphasen-Transformator und Stromwandlern für Spannungen/Ströme mit einer Frequenz oberhalb von 12 Hz.
SmallWarningYellow VORSICHT
Klemmstellen N erden!
Aufgrund der galvanischen Trennung durch den Dreiphasen-Transformator, müssen Sie die Klemmstellen N der Leistungsmessklemmen erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!


Leistungsmessung mit der EL3453 (inklusive Differenzstrommessung)

Anwendungsbeispiele [image] Leistungsmessung mit der EL3453 (inklusive Differenzstrommessung)
Leistungsmessung mit der EL3453 (inklusive Differenzstrommessung)
▪
Die Spannungsmessung erfolgt über die Anschlüsse L1, L2, L3 und N.
▪
Die Strommessung erfolgt mittels drei oder vier Stromwandlern über die Anschlüsse IL1, IL1‘, IL2, IL2‘, IL3, IL3‘ sowie IN und IN‘.
SmallWarningYellow WARNUNG
WARNUNG: Verletzungsgefahr durch Stromschlag!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übliche Verkabelung der Leistungsmessklemme EL3453
In der folgenden Darstellung wird der Strommesskanal IN zur Messung des Neutralleiterstroms verwendet.
Übliche Wandler-Anordnung für die Leistungsmessklemme EL3453 inklusive Neutralleitermessung
Darstellung einer anderen Wandler-Anordnung zur direkten Messung des Differenzstroms:
Wandler-Anordnung der EL3453 zur Differenzstrommessung
Hierbei muss der Sekundärstrompfad des Differenzstromwandlers an die Klemmenkontakte IN (und IN‘) angeschlossen werden.
Zur richtigen Berechnung des Differenzstromwerts muss das entsprechende Wandler-Verhältnis im CoE-Objekt 0xF804:12 eingetragen werden.
Beispiel: Wandlerverhältnis 1A:50A entspricht einzutragendem Wert 0,02.


Beispiel-Funktionsbausteine zur Auswertung

Anwendungsbeispiele [image] Beispiel-Funktionsbausteine zur Auswertung
Beispiel-Funktionsbausteine zur Auswertung
Beispiel-Funktionsbausteine
Der hier vorgestellte Beispiel-Funktionsbaustein übernimmt das vollständige Auslesen aller verfügbaren Werte aus den Leistungsmessklemmen EL3443 beziehungsweise EL3453 und speichert diese in einem dafür vorgesehenen STRUCT:
Darstellung STRUCT
Um den Funktionsbaustein verwenden zu können, muss
▪
das predefined PDO Assignment „Dafault + Variant“ unter „Process Data“ für die Klemme ausgewählt werden.
Auswahl predefined PDO Assignment „Dafault + Variant“
▪
nach dem Download (siehe unten) und dem Import der PLCopenXML
Import der PLCopenXML
▪
müssen die FB-Variablen auf die entsprechenden Klemmen-PDOs verlinkt werden
Verlinkung der Variablen
Ansicht im Strukturbaum
Nach dem Aktivieren und Starten sind dann alle Werte in der Gesamtstruktur auszulesen:
Ansicht der Gesamtstruktur
Auslesen der Klemmeninformationen
Durch das Multiplexen der über 400 (EL3443) bzw. 600 Werte (EL3453), benötigt das vollständige Auslesen der Klemmeninformationen mehrere SPS-Zyklen.
Benötigt die Applikation einzelne Werte schneller, sollten diese direkt über die entsprechenden PDOs zyklus-aktuell ausgelesen werden.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
TcEventLogger und IO
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


TcEventLogger und IO

Anhang [image] TcEventLogger und IO
TcEventLogger und IO
Der TwinCAT 3 EventLogger stellt eine Schnittstelle zum Austausch von Nachrichten zwischen verschiedenen TwinCAT- und Nicht-TwinCAT-Komponenten bereit.
Schematische Darstellung TCEventLogger
Siehe dazu die Erläuterungen in der TwinCAT EventLogger Dokumentation z.B. im Beckhoff InfoSys https://infosys.beckhoff.com/ → TwinCAT 3 → TE1000 XAE → Technologien → EventLogger .
Der EventLogger speichert in eine lokale Datenbank unter ..\TwinCAT\3.1\Boot\LoggedEvents.db und ist im Gegensatz zum VisualStudio Error Window für dauerhafte Aufzeichnung konzipiert.
Auch IO-Geräte können eine Quelle von Nachrichten sein. Werden im IO-Gerät sogenannte DiagMessages erzeugt, können diese bei entsprechender Geräteeinstellung von TwinCAT über EtherCAT abgeholt und im TcEventLogger angezeigt werden. Das erleichtert die zentrale Verwaltung von betriebsbehindernden Ereignissen, da nun nicht mehr in der Applikation für jedes IO-Gerät einzeln eine textuelle Diagnose ausprogrammiert werden muss. Die Nachrichten/Events können z.B. direkt in der TwinCAT HMI angezeigt werden und erleichtern so die Diagnose.
Hinweise:
▪
dieses Feature wird ab TwinCAT 3.1 build 4022.16 unterstützt.
▪
TwinCAT kann sich im RUN- oder CONFIG-Mode befinden
▪
das betrachtete IO-Gerät muss herstellerseitig 1. lokale DiagMessages erstellen und 2. grundsätzlich fähig sein, diese als Event über EtherCAT abzusetzen. Dies ist nicht für alle EtherCAT-IO Geräte/Klemmen/Boxen von Beckhoff der Fall.
Die vom EventLogger verwalteten Nachrichten können ausgegeben werden in bzw. ausgelesen werden von
▪
der HMI → EventGrid
▪
C#
▪
der PLC
▪
TwinCAT Engineering → Logged Events
Im Folgenden Erläuterungen zur Verwendung des EventLoggers mit EtherCAT IO mit TwinCAT 3.1 build 4022.22 während der Inbetriebnahme.
▪
Im TwinCAT Engineering ist ggf. das EventLogger Window anzuzeigen
Anzeige EventLogger Window
▪
Im Folgenden sind am Beispiel einer ELM3602-0002 einige DiagMessages und daraus resultierend die Logged Events zu sehen
Anzeige DiagMessages und Logged Events
▪
Im Logger Window kann nach Einträgen und Sprache gefiltert werden.
Deutsch: 1031
Englisch: 1033
Einstellung Filter Sprache
▪
Ist ein EtherCAT Slave default befähigt, DiagMessages als Event über EtherCAT abzusetzen, kann dies für jeden Slave einzeln im CoE 0x10F3:05 aktiviert/deaktiviert werden. TRUE bedeutet dass der Slave Events zur Abholung über EtherCAT bereitstellt, FALSE deaktiviert die Funktion.
Aktivierung/Deaktivierung Event-Absetzung
▪
Im jeweiligen EtherCAT Slave können verschiedene „Ursachen“ dazu führen, ob und dass er DiagMessages bzw. Events absetzt. Soll nur eine Teilmenge davon erzeugt werden, ist in der Gerätedokumentation nachzulesen, ob und wie z.B. durch CoE Settings einzelne Ursachen deaktiviert werden können.
▪
Einstellungen zum TwinCAT EventLogger sind unter Tools/Options zu finden.
Einstellungen TwinCAT EventLogger


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL3423
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
01* | 01 | EL3423-0000-0016 | 2018/06
 | 02 | EL3423-0000-0017 | 2018/08
 | 03 | EL3423-0000-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3423-0000-0019 | 2019/01
 | 05 | EL3423-0000-0020 | 2019/03
 | 06* |  | 2019/05
EL3443-0000
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
01* | 01 | EL3443-0000-0016 | 2018/06
 | 02 | EL3443-0000-0017 | 2018/08
 | 03 | EL3443-0000-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0000-0019 | 2019/01
 | 05 | EL3443-0000-0020 | 2019/03
 | 06* |  | 2019/05
EL3443-0010
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
01* | 01 | EL3443-0010-0016 | 2018/06
 | 02 | EL3443-0010-0017 | 2018/08
 | 03 | EL3443-0010-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0010-0019 | 2019/01
 | 05 | EL3443-0010-0020 | 2019/03
 | 06* |  | 2019/05
EL3443-0011
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
00* | 03 | EL3443-0011-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0011-0019 | 2019/01
 | 05 | EL3443-0011-0020 | 2019/03
 | 06* |  | 2019/07
EL3443-0013
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
00* | 03 | EL3443-0013-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3443-0013-0019 | 2019/01
 | 05 | EL3443-0013-0020 | 2019/03
 | 06* |  | 2019/07
EL3453
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
01* |  | EL3443-0010-0016 | 2018/07
 | 01 | EL3443-0010-0017 | 2018/12
 | 02 | EL3443-0010-0018 | 2019/02
 | 03* |  | 2019/05
EL3483, EL3483-0060
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
01 - 02* | 01 | EL3483-0000-0016 | 2018/06
 | 02 | EL3483-0000-0017 | 2018/08
 | 03 | EL3483-0000-0018 | 2018/12
 | 04 |  | 2019/01
 |  | EL3483-0000-0019 | 2019/01
 | 05 | EL3483-0000-0020 | 2019/03
 | 06* |  | 2019/05
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.