EL3413 - 3-Phasen-Leistungsmessklemme bis 690 V AC

BECKHOFF Feldbuskomponenten

Dokumentation zu

EL3413

3-Phasen-Leistungsmessklemme bis 690 V AC

Version: 1.4
Datum: 13.11.13

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.
UL-Hinweis
Dieses Symbol kennzeichnet wichtige Informationen bezüglich der UL-Zulassung.


EL3702 - Ausgabestände der Dokumentation

BECKHOFF EL3413: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
1.4 | - Update "Technische Daten"
1.3 | - Update "Objektbeschreibung"
1.2 | - Update "Objektbeschreibung"
1.1 | - Update "Technische Daten"
1.0 | - Ergänzungen, 1. Veröffentlichung
0.1 | - Vorläufige Dokumentation für EL3413


Versionsidentifikation

BECKHOFF: Vorwort

Versionsidentifikation EtherCAT Geräte

Bezeichnung

Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige Bezeichnung, die sich zusammensetzt aus

  • Familienschlüssel
  • Typ
  • Version
  • Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017

Hinweise

  • Die Bestellbezeichnung setzt sich zusammen aus
    - Familienschlüssel
    - Typ
    - Version
  • Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet.
    Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders angegeben.
    Jeder Revision zugehörig ist üblicherweise eine XML-Beschreibung (ESI, EtherCAT Slave Information), die zum Download auf der Beckhoff Webseite bereitsteht.
  • Typ, Version und Revision werden als dezimale Zahlen gelesen.

Seriennummer

Beckhoff EtherCAT Geräte verfügen in der Regel über eine 8 stellige Seriennummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an.

Syntax der Seriennummer

Aufbau der Seriennummer: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 06 3A 02:

12 - Produktionswoche 12
06 - Produktionsjahr 2006
3A - Firmware-Stand 3A
02 - Hardware-Stand 02

Beispiele für Seriennummerangaben

Abb. 1: EL6688 EL-Klemme

Abb. 2: CU2016 Switch

Abb. 3: EK1100 EtherCAT Koppler


EL3413 - Einführung

3-Phasen-Leistungsmessklemme bis 690 V AC / 5 A

Die EtherCAT-Leistungsmessklemme EL3413 ist eine Weiterentwicklung der EL3403. Mit max. 690 V AC sind die Spannungseingänge für die direkte Überwachung leistungsstarker Generatoren, wie sie z. B. in der Windindustrie üblich sind, optimiert.
Der Messbereichsendwert des Stroms kann über das CoE-Verzeichnis, auf 0,1 A, 1 A oder 5 A eingestellt werden.

Ein vorgeschalteter Spannungswandler ist nicht erforderlich. Die Stromeingänge sind galvanisch voneinander getrennt und erlauben den Einsatz der Klemme in allen üblichen geerdeten Stromwandlerschaltungen, wie 2- oder 3-Wandleranordnung in Stern- oder Dreieckschaltung.

Einfache Netzanalysen werden von der EL3413 bis zur 21. Harmonischen Oberschwingungsanalyse durchgeführt. Der Oberschwingungsanteil kann, wie alle Messwerte der Klemme, über die Prozessdaten ausgelesen werden.

Quick-Links

• EtherCAT Funktionsgrundlagen
• Funktionsgrundlagen EL3413
• CoE-Objektbeschreibung und Parametrierung
• Prozessdaten und Betriebsmodi


EL3413 - Technische Daten

Technische Daten | EL3413-0000
Messwerte | Strom, Spannung, Wirkleistung, Scheinleistung, Frequenz
Berechnete Größen | Blindleistung, Energie, Leistungsfaktor (cosj), Harmonische Schwingungen, Phasenwinkel
Messspannung | max. 690 V AC 3~ (ULX-N: max. 400 V AC), zugeführte Spannungen sind nach Überspanungskategorie II einzuhalten
Messstrom | max. 5 A (AC) (konfigurierbar), über Messwandler x A / 5 A
Eingangswiderstand Spannungspfad (typ.) | 1 MW
Eingangswiderstand Strompfad (typ.) | < 3 mW
Auflösung | 0,1 µA, 0,1 mV, 10 mW (bei 0,1 A Messbereich) [z.Z. nicht aktiv!] 1 µA, 0,1 mV, 10 mW (bei 1 A Messbereich) 5 µA, 0,1 mV, 10 mW (bei 5 A Messbereich)
Messgenauigkeit | 0,5% bezogen auf den Messbereichsendwert (U/ I), 1% berechnete Werte (P)
Frequenzbereich | 45 Hz bis 65 Hz
Signalform | beliebig (unter Berücksichtigung des Frequenzbereichs und der Grenzfrequenz)
Messverfahren | True RMS, Echteffektivwertberechnung mit 16.800 ( 2.800 pro Kanal) Samples/s
Messzykluszeit | 200 ms pro Messwert voreingestellt, frei konfigurierbar, netzsynchron
Potenzialtrennung | 4500 V (Anschlussklemme/E-Bus)
Spannungsversorgung für interne E-Bus-Elektronik | über den E-Bus
Stromaufnahme vom E-Bus | typ. 160 mA
Konfiguration | über TwinCAT System Manager
Abmessungen (B x H x T) | ca. 27 mm x 100 mm x 70 mm (Breite angereiht: 24 mm)
Gewicht | ca. 75 g
Montage | auf 35 mm Tragschiene nach EN 50022
Betriebstemperatur | 0 °C ... +55 °C
Lagertemperatur | -25 °C ... +85 °C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP 20/beliebig
Zulassungen | CE


EL3702 - Grundlagen zur Funktion

BECKHOFF EL3413: Produktübersicht

Grundlagen zur Funktion

Inhaltsverzeichnis
• Messprinzip
• Effektivwertberechnung
- Messintervall
• Wirkleistungsmessung
• Scheinleistungsmessung
• Vorzeichen bei Leistungsmessung
• Frequenzmessung

Messprinzip

Die EL3413 arbeitet mit 1 Analog/Digitalwander zur Erfassung der Strom und Spannungsgrößen aller 3 Phasen.

Die Erfassung und Verarbeitung der 3 Phasen findet nacheinander (45 µs versetzt) in exakt gleicher Form statt. Im folgenden wird die Signalverarbeitung für eine Phase beschrieben. Die Beschreibung gilt sinngemäß für alle 3 Phasen.

Abb. 1: Verlauf von Spannung u und Strom i

Effektivwertberechnung

Über ein Messintervall, hier Periodendauer T, wird der Effektivwert für Spannung und Strom berechnet. Die Berechnungen erfolgen nach den Formeln:

u(t): Momentanwert der Spannung
i(t): Momentanwert des Stromes
n: Anzahl der gemessenen Werte

Messintervall

Die Wahl des richtigen Messintervalls ist für die Qualität der Messung von Bedeutung. Die Defaulteinstellung für das Messintervall ist 10 Perioden (10 x 20ms). Dies ist erfahrungsgemäß ein guter Kompromiss zwischen Messgeschwindigkeit und Stabilität. Weichen Sie von diesem Wert nur ab, wenn besondere Messanforderungen (z.B. hohe Messgeschwindigkeit) gegeben sind.

Wirkleistungsmessung

Die EL3413 misst die Wirkleistung P nach der Gesetzmäßigkeit

P: Wirkleistung
n: Anzahl der Abtastungen
u(t): Augenblickswert der Spannung
i(t): Augenblickswert des Stromes

Abb. 2: Verlauf der Leistung s(t)

Im ersten Schritt wird zu jedem Abtastzeitpunkt die Leistung s(t) berechnet:

Über das Messintervall wird der Mittelwert gebildet. Hier spielt die richtige Wahl des Intervalls die gleiche Rolle wie im Abschnitt Effektivwertmessung beschrieben (das Intervall kann nur gemeinsam für U, I und P verändert werden).

Die Frequenz der Leistung ist doppelt so hoch wie die der entsprechenden Spannungen und Ströme.

Scheinleistungsmessung

In realen Netzen sind nicht alle Verbraucher rein ohmsch. Es kommt zu einer Phasenverschiebung zwischen Strom und Spannung. Die oben beschriebene Methodik zur Ermittlung der Effektivwerte von Spannung und Strom wird dadurch nicht beeinflusst.

Anders ist das bei der Wirkleistung: Das Produkt aus Effektivspannung und Effektivstrom ergibt hier die Scheinleistung.

Die Wirkleistung ist kleiner als die Scheinleistung.

S: Scheinleistung
P: Wirkleistung
Q: Blindleistung
j: Phasenverschiebungswinkel

Abb. 3: Verlauf u(t), i(t), p(t) mit Phasenverschiebungswinkel j

In diesem Umfeld sind weiter Informationen über das Netz und seine Verbraucher von Bedeutung:

  • Scheinleistung S
  • Blindleistung Q
  • Leistungsfaktor cos j

Die EL3413 ermittelt die Werte:

  • Wirkleistung P
  • Effektivspannung U
  • Effektivstrom I
  • Scheinleistung S
  • Blindleitung Q
  • Leistungsfaktor cos j
  • Harmonische
  • Phasenverschiebung λ

Vorzeichen bei Leistungsmessung

Das Vorzeichen der Wirkleistung P und des Leistungsfaktors cos φ gibt Auskunft über die Richtung des Energieflusses. Ein positives Vorzeichen signalisiert den motorischer Betrieb, das negative Vorzeichen einen generatorischen Betrieb.

Weiterhin gibt das Vorzeichen der Blindleistung Q eine Auskunft über Richtung der Phasenverschiebung zwischen Strom und Spannung. In der Abb. 4 wird dies in der Vier-Quadranten-Darstellung veranschaulicht. Im motorischen Betrieb (Quadrant I + IV) deutet eine positive Blindleistung auf eine induktive Belastung hin, eine negative Blindleistung entsprechend auf eine kapazitive Belastung. Im generatorischen Betrieb (Quadrant II + III) wird ein induktiv wirkender Generator durch eine positive Blindleistung dargestellt, ein kapazitiv wirkender Generator durch eine negative Blindleistung.

Abb 4: Vier-Quadranten-Darstellung Wirkleistung/Blindleistung bei motorischen und generatorischen Betrieb

Frequenzmessung

Die EL3413 kann die Frequenz des an einem Spannungspfad (L1, L2 oder L3) anliegenden Eingangssignals messen.


EL3413 - Stromwandler

BECKHOFF EL3413: Produktübersicht

Stromwandler

Grundsätzlich ist die Auswahl der Stromwandler für die EL3413 nicht kritisch. Der Innenwiderstand im Strompfad der EL3413 ist so klein, dass er bei der Betrachtung der gesamten Widerstände der Stromschleife vernachlässigt werden kann. Die Wandler müssen einen Sekundär-Nennstrom von 1 A oder 5 A liefern können. Der Primär-Nennstrom Ipn kann beliebig gewählt werden. Die übliche zulässige Überlastung von 1.2 x Ipn ist für die EL3413 unproblematisch, kann aber zu geringen Mess-Ungenauigkeiten führen.

Genauigkeit

Beachten Sie, dass die Gesamtgenauigkeit des Aufbaues aus EL3413 und Stromwandlern, wesentlich von der Genauigkeitsklasse der Wandler abhängt.

Hinweis 		Keine Zulassung als Verrechungszähler
Die Anordnung mit einem Stromwandler der Klasse 0,5 ist nicht zulassungs- und beglaubigungsfähig. Die EL3413 ist kein zugelassener Verrechungszähler im Sinne der Norm für Elektrizitätszähler (DIN 43 856).

Stromarten

Die EL3413 kann beliebige Stromformen bis zu einem Grenzanteil von ca. 260 Hz messen. Da derartige Ströme häufig durch Wechselrichter erzeugt werden und Frequenzen von weniger als 50 Hz oder sogar einen DC-Anteil enthalten können, sollte in diesen Anwendungen ein elektronischer Wandler eingesetzt werden.

Überstrombegrenzungsfaktor FS

Der Überstrombegrenzungsfaktor FS eines Stromwandlers gibt an, bei welchem Vielfachen seines des primären Nennstrom der Stromwandler in die Sättigung geht, um die angeschlossenen Messgeräte zu schützen.

Achtung 		Achtung! Beschädigung des Gerätes möglich!
Die EL3413 darf nicht dauerhaft mit mehr als 5 A belastet werden! Setzen Sie in Anlagen, in denen die Überstrombegrenzungsfaktoren der Wandler höhere Sekundärströme als 5 A erlauben, zusätzliche Zwischenwandler mit einem Übersetzungsverhältnis von 5A/1A oder 1A/5A ein!

Schutz vor gefährlichen Berührungsspannungen

Im bestimmungsgemäßen Betrieb der EL3413 mit entsprechenden Stromwandlern kommt es zu keinen gefährlichen Spannungen. Die Sekundärspannung liegt im Bereich von einigen Volt. Folgende Fehlerfälle können jedoch zu hohen Spannungen führen:

  • Offener Strompfad eines oder mehrer Wandler
  • Durchtrennter Nullleiter auf der Seite der Spannungsmessung der EL3413
  • Allgemeine Isolationsfehler

WARNUNG 		WARNUNG! Verletzungsgefahr durch Stromschlag!
Die gesamte Verdrahtung der EL3413 muss berührungsgeschützt ausgeführt und mit den entsprechenden Warnhinweisen versehen werden! Legen Sie die Isolierung für die maximale Leiterspannung des zu messenden Netzes aus!

Die EL3413 lässt eine maximale Spannung von 690 V für normale Betriebsbedingungen zu. Die Leiterspannung auf der Stromseite darf 690 V nicht überschreiten! Verwenden Sie für höhere Spannungen eine Zwischenwandlerstufe!

Eine EL3413 ist auf der Seite der Spannungsmessung mit einer Schutzimpedanz von 1 MW ausgestattet. Wenn der Nullleiter nicht angeschlossen ist und nur ein Anschluss auf der Seite der Spannungsmessung unter Spannung steht, ergibt sich in einem 3-Phasen-Netz mit einer Außenleiterspannung von 690 VAC eine Spannung von 400 VAC gegen Erde. Diese ist mit einem Multimeter mit 10 MW Innenwiderstand auch auf der Seite der Strommessung zu messen, was keinen Isolationsfehler darstellt.

Zusätzliche Messgeräte im Strompfad

Beachten Sie, das sich durch das Hinzufügen zusätzlicher Messgeräte (z.B. Amperemeter) in den Strompfad die Gesamtscheinleistung deutlich erhöhen kann.


Start

Zur Inbetriebsetzung:

  • montieren Sie den EL3413 wie im Kapitel Montage und Verdrahtung beschrieben
  • konfigurieren Sie den EL3413 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


EtherCAT - EtherCAT Grundlagen

BECKHOFF EtherCAT: Grundlagen der Kommunikation

EtherCAT Grundlagen

Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung

BECKHOFF EtherCAT: Grundlagen der Kommunikation

EtherCAT-Verkabelung - Drahtgebunden

Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.

Kabel und Steckverbinder

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.

EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.

Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -

Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.

Hinweis 		Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!

E-Bus-Versorgung

Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9400) zu setzen.

Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.

Abb. 1: Systemmanager Stromberechnung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT - Allgemeone Hinweise zur Watchdogeinstellung

BECKHOFF EtherCAT: Grundlagen der Kommunikation

Allgemeine Hinweise zur Watchdog-Einstellung

Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.

Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:

  • SM-Watchdog (default: 100 ms)
  • PDI-Watchdog (default: 100 ms)

SM-Watchdog (SyncManagerWatchdog)

Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.

Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.

PDI-Watchdog (Process Data Watchdog)

Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.

Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.

Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:

Abb. 1 Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog

Anmerkungen:

  • der Multiplier ist für beide Watchdogs gültig.
  • jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
  • Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
    Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.

Multiplier

Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:

1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)

Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.

Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.

Beispiel "Set SM-Watchdog"

Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.

Berechnung

Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit

VORSICHT 		VORSICHT! Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016.
In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.

VORSICHT 		VORSICHT! Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs!
Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.


EtherCAT State Machine

Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.

Es werden folgende Zustände unterschieden:

  • Init
  • Pre-Operational
  • Safe-Operational und
  • Operational
  • Boot

Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.

Init

Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init . Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.

Pre-Operational (Pre-Op)

Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.

Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.

Safe-Operational (Safe-Op)

Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).

Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.

Operational (Op)

Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.

Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.

Boot

Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.

Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Inhaltsverzeichnis
• Allgemeine Beschreibung
• Datenerhaltung
• Online/Offline Verzeichnis
• Kanalweise Ordnung

Allgemeine Beschreibung

Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.

CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.

Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.

Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind

  • Index: 0...65535
  • SubIndex: 0...255

Üblicherweise wird ein so lokalisierter Parameter geschrieben als x8010:07 mit voranstehendem "x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.

Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind

  • x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
  • x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.

Weitere wichtige Bereiche sind:

  • x4000: hier liegen in manchen EtherCAT-Geräte alternativ zum x8000-Bereich die Kanalparameter.
  • x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
  • x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)

Hinweis 		Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen.
Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..

Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:

Abb. 1: Karteireiter "CoE-Online "

In Abb. 1 sind die im Gerät "EL2502" verfügbaren CoE-Objekte von x1000 bis x1600 zusehen, die Subindizes von x1018 sind aufgeklappt.

Datenerhaltung

Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen

  • über den Systemmanager (Abb. 1) durch Anklicken
    Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
  • aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
    Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.

Hinweis 		Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.

Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.

  • Funktion wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
    Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
  • Funktion wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.

Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten in dieser Dokumentation zu entnehmen.

StartUp-Liste

Hinweis 		Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.

Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.

Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern

  • gewünschte Änderung im Systemmanager vornehmen
    Werte werden lokal im EtherCAT Slave gespeichert
  • wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
    Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.

Abb. 2: StartUp-Liste im TwinCAT System Manager

In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.

Online/Offline Verzeichnis

Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.

In beiden Fällen ist ein CoE-verzeichnis nach Abb. 1 zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.

  • wenn der Slave offline ist
    - wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
    - wird in der Identität der konfigurierte Stand angezeigt
    - wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
    - ist ein rotes Offline zu sehen

    Abb. 3: Offline-Verzeichnis
  • wenn der Slave online ist
    - wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
    - wird die tatsächliche Identität angezeigt
    - wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
    - ist ein grünes Online zu sehen

    Abb. 4: Online-Verzeichnis

Kanalweise Ordnung

Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.

Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs x8000 sieht man dies deutlich:

  • Kanal 0: Parameterbereich x8000:00 ... x800F:255
  • Kanal 1: Parameterbereich x8010:00 ... x801F:255
  • Kanal 2: Parameterbereich x8020:00 ... x802F:255
  • ...

Allgemein wird dies geschrieben als x80n0.

Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Die EL3413 unterstützt keinen Distributed Clock.


ELxxxx, KLxxxx - Tragschienenmontage

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 50022) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Hinweis 		Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein.
Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie die Klemme an ihren orangefarbige Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Anschlusstechnik

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Anschlusstechnik

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Übersicht

Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:

  • Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
  • Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
  • Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.

Standardverdrahtung

Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und
integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.

Steckbare Verdrahtung

Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt.
Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.

Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.

Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.

Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.

Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.

High-Density-Klemmen (HD-Klemmen)

Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.

Hinweis 		Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.

Ultraschall-litzenverdichtete Leiter

Hinweis 		Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschall verschweißte) Leiter angeschlossen werden.
Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!

Verdrahtung

Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm

High-Density-Klemmen ELx8xx, KLx8xx (HD)

Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässige Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.

Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm

Schirmung

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KLxxxx, ELxxxx - Einbaulagen

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Einbaulagen

Achtung 		Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt.

Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!

Optimale Einbaulage (Standard)

Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. 1). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.

Abb. 1: empfohlene Abstände bei Standard Einbaulage

Die Einhaltung der Abstände nach Abb. 1 wird empfohlen.

Weitere Einbaulagen

Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb 2.

Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.

Abb. 2: weitere Einbaulagen


Montage von passiven Klemmen

Hinweis 		Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus.
Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für Montage von passiven Klemmen (hell eingefärbt)

Beispiel 1: korrekte Konfiguration

Beispiel 2: inkorrekte Konfiguration


EL3413 - LEDs und Anschlussbelegung

LEDs

LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
IL1 OK | grün | an | Strom an L1 erkannt
IL1 Error | rot | an | Überstrom an L1. Strom > 1,1 A (bei 1 A Messbereich) Strom > 5,1 A (bei 5 A Messbereich)
IL2 OK | grün | an | Strom an L2 erkannt
IL2 Error | rot | an | Überstrom an L2. Strom > 1,1 A (bei 1 A Messbereich) Strom > 5,1 A (bei 5 A Messbereich)
IL3 OK | grün | an | Strom an L3 erkannt
IL3 Error | rot | an | Überstrom an L3. Strom > 1,1 A (bei 1 A Messbereich) Strom > 5,1 A (bei 5 A Messbereich)
ccw | grün | an | linksdrehendes Feld richtig erkannt
cw | grün | an | rechtsdrehendes Feld richtig erkannt
L1 OK | grün | an | Spannung an L1 und Nulldurchgang erkannt. Spannung > 5 V (L1-N)
L1 Error | rot | an | Über- oder Unterspannung an L1. Spannung < 5 V oder Spannung > 415 V (L1-N) Keine Nulldurchgänge an L1 richtig erkannt
L2 OK | grün | an | Spannung an L2 und Nulldurchgang erkannt. Spannung > 5 V (L2-N)
L2 Error | rot | an | Über- oder Unterspannung an L2. Spannung < 5 V oder Spannung > 415 V (L2-N) Keine Nulldurchgänge an L2 richtig erkannt
L3 OK | grün | an | Spannung an L3 und Nulldurchgang erkannt. Spannung > 5 V (L3-N)
L3 Error | rot | an | Über- oder Unterspannung an L3. Spannung < 5 V oder Spannung > 415 V (L3-N) Keine Nulldurchgänge an L3 richtig erkannt

Anschlussbelegung

Klemmstelle | Beschreibung | Kommentar
Bezeichnung | Nr.
IL1 1 Eingang Strommessung der Phase L1 Anschlüsse für die Stromwandler.

WARNUNG 		Vorsicht: Verletzungsgefahr durch Stromschlag!
Beachten Sie, das die Stromwandler vieler Hersteller nicht im Leerlauf betrieben werden dürfen! Schließen Sie die EL3413 an die Sekundärwicklung der Stromwandler an, bevor Sie die Stromwandler in Betrieb nehmen!
IL2 | 2 | Eingang Strommessung der Phase L2
IL3 | 3 | Eingang Strommessung der Phase L3
IL1' | 5 | Ausgang Strommessung der Phase L1
IL2' | 6 | Ausgang Strommessung der Phase L2
IL3' | 7 | Ausgang Strommessung der Phase L3
Klemmstelle | Beschreibung | Kommentar
Bezeichnung | Nr.
L1 1 Eingang Spannungsmessung der Phase L1 Anschlüsse für die Spannungsmessung.

WARNUNG 		Vorsicht: Verletzungsgefahr durch Stromschlag!
Wenn Sie die Klemmstelle N nicht mit dem Nulleiter Ihres Versorgungsnetzes verbinden (z.B. bei Verwendung der EL3413 zur reinen Strommessung), müssen Sie die Klemmstelle N erden, damit im Fehlerfall eines Stromwandlers gefährliche Überspannungen vermieden werden!
L2 | 2 | Eingang Spannungsmessung der Phase L2
L3 | 3 | Eingang Spannungsmessung der Phase L3
N | 4 | Eingang Nullleiter


Installation TwinCAT Realtime Treiber

Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.

Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.

Im Systemmanager ist über Options -> Show realtime Compatible Devices die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.

Abb. 1: Aufruf im Systemmanager

Abb. 2: Übersicht Netzwerkschnittstellen

Hier können nun Schnittstellen, die unter "Compatible devices" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.

Ein Windows-Warnhinweis bzgl. des unsignierten Treibers kann ignoriert werden.

Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der Netzwerkschnittstelle

(Windows Start --> Systemsteuerung --> Netzwerk)

Abb. 3: Windows-Eigenschaften der Netzwerkschnittstelle

Hinweis 		IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall , dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren.

Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält.

Als Adressraum empfiehlt sich z.B. 192.168.x.x.

Abb. 4: TCP/IP-Einstellung des Ethernet Ports

Alternativ sind im Systemmanager über die EtherCAT-Eigenschaften die kompatiblen Ethernet Ports einsehbar.

Abb. 5: Eigenschaften EtherCAT Gerät


Hinweise ESI-Gerätebeschreibung

Inhaltsverzeichnis
• Installation der neuesten ESI-Device-Description
• Geräteunterscheidung
• Online Description
• Fehlerhafte ESI-Datei

Installation der neuesten ESI-Device-Description

Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jew. Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.

Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen (Standardeinstellung: C:\TwinCAT\IO\EtherCAT). Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen wenn sie sich seit dem letzten Systemmanager-Fenster geändert haben.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.

Ab TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Abb. 1: ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen.

Hinweis 		ESI
Zu den *.xml-Dateien gehören so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.

Geräteunterscheidung

EtherCAT Geräte/Slaves werden durch 4 Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Die EL2521-0025-1018 setzt sich zusammen aus

  • Familienschlüssel "EL"
  • Name "2521"
  • Typ "0025"
  • und Revision "1018"

Abb. 2: Aufbau Bezeichnung

Die Bestellbezeichnung aus Name + Typ (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.

Online Description

Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave keine ESI-Beschreibung vor, fragt der Systemmanager ob er die im Gerät vorliegende Beschreibung verwenden soll. Der Systemmanager benötigt in jedem Fall diese Information um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.

Abb. 3: Hinweisfenster OnlineDescription

Wenn möglich, ist dies abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.

Wird dennoch die OnlineDescription verwendet, liest der Systemmanager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird der Weg über die ESI-Datei empfohlen.

Der Systemmanager legt dann in seinem ESI-Verzeichns eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.

Abb. 4: vom Systemmanager angelegt OnlineDescription.xml

Wird daraufhin manuell ein Slave in die Konfiguration eingefügt, unterscheiden sich solchermaßen erstellte Slaves durch einen vorangestellten Pfeil, s. Abb. 5, EL2521.

Abb. 5: Pfeil kennzeichnet durch OnlineDescription erfasste ESI

Wurde mit solchern ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription.xml wie folgt zu löschen:

  • alle Systemmanagerfenster schließen
  • TwinCAT in Konfig-Mode neu starten
  • OnlineDescription-Datei löschen

Fehlerhafte ESI-Datei

Liegt eine fehlerhafte ESI-Datei vor die vom Systemmanager nicht eingelesen werden kann, meldet dies der Systemmanager durch ein Hinweisfenster.

Abb. 6: Hinweisfenster fehlerhafte ESI-Datei

Ursachen dafür können sein

  • Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei
  • Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden

Es ist der Hersteller der Datei zu kontaktieren.


Offline Konfigurationserstellung (Master: TwinCAT 2.x)

Inhaltsverzeichnis
• Unterscheidung Online/Offline
• Anlegen des Geräts EtherCAT
• Definieren von EtherCAT Slaves

Unterscheidung Online/Offline

Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.

Ist die vorgesehene Steuerung bereits an das EtherCAT-System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch so genanntes "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.

In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser test kann in den erweiterten Slave-Einstellungen parametriert werden.

Hinweis 		Installation der neuesten ESI-XML-Device-Description
Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT ) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT Builds aktuell war.

Ab. TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Zur Konfigurationserstellung muss

  • das Gerät EtherCAT im Systemmanager definiert werden
  • die EtherCAT Slaves definiert werden

Anlegen des Geräts EtherCAT

In einem leeren Systemmanager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.

Abb. 1: Anfügen EtherCAT Device

Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.

Abb. 2: Auswahl EtherCAT Anschluss (TwinCAT 2.11)

Abb. 3: Auswahl EtherCAT Anschluss (TwinCAT 2.11 R2)

Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.

Abb. 4: Auswahl Ethernet Port

Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog (s. Abb. 5) gesetzt/geändert werden.

Abb. 5: Eigenschaftendialog EtherCAT

Hinweis 		Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden.

Siehe dazu die entsprechende Installationsseite.

Definieren von EtherCAT Slaves

Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.

Abb. 6: Anfügen von EtherCAT Geräten

Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.

Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. 7, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. 7 nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.

Übersicht Übertragungsphysik

  • "Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
  • "E-Bus": LVDS "Klemmenbus": EL/ES-Klemmen, diverse anreihbare Module

Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11).

Abb. 7: Auswahldialog neues EtherCAT Gerät

Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.

Abb. 8: Anzeige Geräte-Revision

Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z.B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. 7) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibung vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. 9.

Abb. 9: Anzeige vorhergehender Revisionen

Hinweis 		Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).

Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.

Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.

Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...

Abb. 10: EtherCAT Klemme im TwinCAT-Baum


Online Konfigurationserstellung "Scannen" (Master: TwinCAT 2.x)

Inhaltsverzeichnis
• Unterscheidung Online/Offline
• Erkennen/Scan des Geräts EtherCAT
• Erkennen/Scan der EtherCAT Teilnehmer
• Problembehandlung
• Scan über bestehender Konfiguration

Unterscheidung Online/Offline

Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.

Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.

In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden.

Hinweis 		Installation der neuesten ESI-XML-Device-Description
Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT ) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT Builds aktuell war.

Ab. TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Zur Konfigurationserstellung

  • muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
  • Die Geräte/Module müssen über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
  • Die Geräte/Module müssen mit Energie versorgt werden und kommunikationsbereit sein.
  • TwinCAT muss auf dem Zielsystem im CONFIG-Modus sein.

Der Online-Scan-Vorgang setzt sich zusammen aus

  • Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
  • Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
  • Problembehandlung

Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.

Erkennen/Scan des Geräts EtherCAT

Befindet sich das TwinCAT-System im CONFIG-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.

Abb. 1: TwinCAT Anzeige CONFIG-Modus

Hinweis 		Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.

Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.

Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.

Abb. 2: Scan Devices

Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.

Abb. 3: Hinweis automatischer GeräteScan

Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.

Abb. 4: erkannte Ethernet-Geräte

Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. 5.

Erkennen/Scan der EtherCAT Teilnehmer

Hinweis 		Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.

Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.

Abb. 5: Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes

Abb. 6: manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device

Im Systemmanager kann der Scan-Ablauf am Ladebalken am unteren Bildschirmrand verfolgt werden.

Abb. 7: Scanfortschritt

Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.

Abb. 8: Abfrage Config/FreeRun

Im Config/FreeRun-Mode wechselt die Systemmanager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.

Abb. 9: Anzeige Config/FreeRun

Hinweis 		Hinweis Config/FreeRun
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden

Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. 10 befinden.

Abb. 10: beispielhafte Online-Anzeige

Zu Beachten sind

  • alle Slaves sollen im OP-State sein
  • der EtherCAT Master soll im "Actual State" OP sein
  • "Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
  • es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten

Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.

Problembehandlung

Beim Scannen können verschiedene Effekte auftreten.

  • es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
    In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen. Dieser Fall ist hier beschrieben.
  • Teilnehmer werden nicht richtig erkannt
    Ursachen können sein
    - fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
    - Slave hat ungültige Gerätebeschreibung
    Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
    Der Scan ist dann erneut vorzunehmen.

    Abb. 11: fehlerhafte Erkennung

    Im Systemmanager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.

Scan über bestehender Konfiguration

Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.

Abb. 12: identische Konfiguration

Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.

Abb. 13: Korrekturdialog

Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.

Farbe | Erläuterung
grün | Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.

Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Geräte nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.

hellblau | Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
  • Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
  • Ist er vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
    Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.

    Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Geräte nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.

Hinweis 		Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).

Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1019 oder höher (-1020, -1021) eingesetzt werden.

Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.

Abb. 14: Korrekturdialog mit Änderungen

Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.


Standard-Verhalten EtherCAT Master

BECKHOFF EtherCAT: EtherCAT-Grundlagen

Prozessdaten Einstellungen EtherCAT Slave (PDO)

Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (Process Data Objects, PDO) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.

Für Beckhoff EtherCAT Slaves EL/ES gilt im Allgemeinen:

  • Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
  • Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
    Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
  • Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch den erfolgreichen Hochlauf des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.

Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. 1.

  • A: Wählen Sie das zu konfigurierende Gerät
  • B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
  • D: die PDOs können an- bzw. abgewählt werden
  • H: die neuen Prozessdaten sind als verlinkbare Variablen im Systemmanager sichtbar
    Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
  • E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ( "predefined PDO-settings") verändert werden.

Abb. 1: Konfigurieren der Prozessdaten

Hinweis 		Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. 1, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit").

Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden.

Dies gilt im Allgemeinen auch für den Fall, dass eine Gerät den Download der PDO Konfiguration "G" unterstützt.

Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben:

Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.


Allgemeine Hinweise - EtherCAT Slave Anwendung

BECKHOFF: Inbetriebnahme

Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inhaltsverzeichnis
• Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
• CoE - Parameterverzeichnis
• Inbetriebnahmehilfe im TwinCAT System Manager
• EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
• Hinweis Ebus Strom

In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.

Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status

Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.

Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.

Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.

EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im folgenden besprochen.

Abb. 1: Auswahl an Diagnoseinformationen eines EtherCAT Slave

Im Allgemeinen verfügt ein EtherCAT Slave über

  • slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
    Diese Diagnose ist für alle Slaves gleich.

    als auch über
  • kanal-typische Funktionsdiagnose (geräteabhängig)
    Siehe entsprechende Gerätedokumentation

Die Farbgebung in Abb. 1 entspricht auch den Variablenfarben im System Manager, siehe Abb. 2.

Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.

In Abb. 2. ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.

Abb. 2: grundlegende EtherCAT Slave Diagnose in der PLC

Dabei werden folgende Aspekte abgedeckt:

Kennzeichen Funktion Ausprägung Anwendung/Auswertung
A Diagnoseinformationen des EtherCAT Master

zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).

Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.

Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:

  • CoE im Master zur Kommunikation mit/über die Slaves
  • Funktionen aus TcEtherCAT.lib
  • OnlineScan durchführen
B Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln. Status
  • die Bitdeutungen sind der Gerätedokumentation zu entnehmen
  • andere Geräte können mehr oder keine slavetypischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
  1. am EtherCAT Slave als auch inhaltsidentisch
  2. als Sammelvariable am EtherCAT Master (siehe Punkt A)

zur Verlinkung bereitgestellt.

WcState (Working Counter)

0: gültige Echtzeitkommunikation im letzten Zyklus

1: ungültige Echtzeitkommuniktion

ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen

Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
  • nur selten/nie verändert werden, außer beim Systemstart
  • selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State

aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.

AdsAddr

Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.

Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.

Achtung 		Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.

CoE-Parameterverzeichnis

Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. 3:

Abb. 3: EL3102, CoE-Verzeichnis

Hinweis 		EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!

Einige Hinweise daraus in Kürze:

  • Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
  • Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.

Inbetriebnahmehilfe im TwinCAT System Manager

In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.

Abb. 4: Beispiel Inbetriebnahmehilfe für eine EL3204

Diese Inbetriebnahme verwaltet zugleich

  • CoE-Parameterverzeichnis
  • DC/FreeRun-Modus
  • die verfügbaren Prozessdatensätze (PDO)

Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.

Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, könne vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.

EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung

Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati

  • INIT
  • PREOP
  • SAFEOP
  • OP

zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.

Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.

Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.

Standardeinstellung

Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:

  • EtherCAT Master: OP
  • Slaves: OP
    Diese Einstellung gilt für alle Slaves zugleich.

Abb. 5: Default Verhalten System Manager

Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.

Abb. 6: Default Zielzustand im Slave

Manuelle Führung

Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.

  • aus Diagnosegründen
  • kontrolliertes Wiederanfahren von Achsen
  • ein zeitlich verändertes Startverhalten ist gewünscht

Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.

Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.

Abb. 7: PLC-Bausteine

Hinweis Ebus Strom

EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.

Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.

Abb. 8: unzulässige Überschreitung E-Bus Strom

Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:

Abb. 9: Warnmeldung E-Bus-Überschreitung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EL3413 - Prozessdaten

BECKHOFF EL3413: Inbetriebnahme

Prozessdaten

Inhaltsverzeichnis
• Sync Manager
- PDO-Zuordnung
• Betriebmodi und Einstellungen
- Bestätigung des variablen Ausgabewertes Kanal 1 - 3
- Bestätigung des variablen Ausgabewertes Kanal Auxiliary
• Predifined PDO Assignment

Sync Manager (SM)

Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ im TwinCAT System Manager eingesehen werden (siehe Abb. 1+2) .

Abb. 1 Karteireiter Prozessdaten SM2, EL3413

Abb. 2 Karteireiter Prozessdaten SM3, EL3413

PDO-Zuordnung

SM2, PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | - | 1.0 | PM Outputs Channel 1 | Index 0x7000:01 - Index
0x1601(default) | - | 1.0 | PM Outputs Channel 2 | Index 0x7010:01 - Index
0x1602 (default) | - | 1.0 | PM Outputs Channel 2 | Index 0x7020:01 - Index
0x1603 (default) | - | 2.0 | PM Auxiliary Outputs Auxiliary | Index 0x7030:01 - Index Index 0x7030:02 - Channel
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | - | 20.0 | PM Inputs Channel 1 | Index 0x6000:01 - STATUS_Overvoltage Index 0x6000:02 - STATUS_Undervoltage Index 0x6000:03 - STATUS_Overcurrent Index 0x6000:05 - STATUS_Phase sequence cw Index 0x6000:06 - STATUS_Phase sequence ccw Index 0x6000:07 - STATUS_Missing zero crossing Index 0x6000:0F - STATUS_TxPDO State Index 0x6000:10 - STATUS_TxPDO Toggle Index 0x6000:11 - Current Index 0x6000:12 - Voltage Index 0x6000:13 - Active power Index 0x6000:14 - Index Index 0x6000:1D - Variant value
0x1A01(default) | - | 20.0 | PM Inputs Channel 2 | Index 0x6010:01 - STATUS_Overvoltage Index 0x6010:02 - STATUS_Undervoltage Index 0x6010:03 - STATUS_Overcurrent Index 0x6010:05 - STATUS_Phase sequence cw Index 0x6010:06 - STATUS_Phase sequence ccw Index 0x6010:07 - STATUS_Missing zero crossing Index 0x6010:0F - STATUS_TxPDO State Index 0x6010:10 - STATUS_TxPDO Toggle Index 0x6010:11 - Current Index 0x6010:12 - Voltage Index 0x6010:13 - Active power Index 0x6010:14 - Index Index 0x6010:1D - Variant value
0x1A02 (default) | - | 20.0 | PM Inputs Channel 3 | Index 0x6020:01 - STATUS_Overvoltage Index 0x6020:02 - STATUS_Undervoltage Index 0x6020:03 - STATUS_Overcurrent Index 0x6020:05 - STATUS_Phase sequence cw Index 0x6020:06 - STATUS_Phase sequence ccw Index 0x6020:07 - STATUS_Missing zero crossing Index 0x6020:0F - STATUS_TxPDO State Index 0x6020:10 - STATUS_TxPDO Toggle Index 0x6020:11 - Current Index 0x6020:12 - Voltage Index 0x6020:13 - Active power Index 0x6020:14 - Index Index 0x6020:1D - Variant value
0x1A03 (default) | - | 8.0 | PM Auxiliary Inputs Auxiliary | Index 0x6030:10 - STATUS_TxPDO Toggle Index 0x6030:11 - Index Index 0x6030:12 - Channel Index 0x6030:13 - Value

Tab. 1: PDO-Zuordnung der SyncManager

Betriebsmodi und Einstellungen

Bestätigung des variablen Ausgabewertes Kanal 1 - 3 (Index 6000:14, 6010:14, 6020:14)

Die berechneten Werte können auf den Index 6000:1D (Kanal 1), 6010:1D (Kanal 2) bzw. 6020:1D (Kanal 3) ausgegeben werden (siehe Objektbeschreibung).
Dazu sind im "Set Value Dialog"-Fenster von Index 7000:01, 7010:01 oder 7020:01 (Karteireiter "CoE-Online") die entsprechenden Werte für die auszugebende Messgröße (siehe 6000:14, 6010:14, 6020:14) einzutragen.

Werte (dez), Eintrag in Index 7000:01, 7010:01, 7020:01 | Bezeichnung | Einheit
0 | Scheinleistung | 0,01 VA
1 | Blindleistung | 0,01 VAR
2 | Energie | 0,001 Wh
3 | cosPhi | 0,001
4 | Frequenz | 0,1 Hz
5 | Energie (negative) | 0,001 Wh
6 | Winkel λ zwischen Phase Lx und Phase L1 | 0,01°
7-255 | reserviert | -

Der Standard-Ausgabewert ist die Scheinleistung.

Bestätigung des variablen Ausgabewertes Kanal Auxiliary (Index 6030:11)

Die berechneten Werte können auf den Index 6030:13 ausgegeben werden (siehe Objektbeschreibung).
Dazu sind im "Set Value Dialog"-Fenster von Index 7030:01 (Karteireiter "CoE-Online") die entsprechenden Werte für die auszugebende Messgröße (siehe Index 6030:11) und von Index 7030:02 (Karteireiter "CoE-Online") der entsprechende Kanal 1-3 einzutragen.

Werte (dez), Eintrag in Index 7030:02 | Werte (dez), Eintrag in Index 7030:01 | Bezeichnung | Einheit
0 | 0 | Reserviert (THDN IA + IB + IC) - noch nicht integriert |
0 | 2 | Summe Energie (Kanal1-3) | 0,001 Wh
0 | 4 | Frequenz | 0,1 Hz
0 | 5 | Summe Energie (negative) (Kanal 1-3) | 0,001 Wh
0 | 10 | Summe Wirkleistung (Kanal 1-3) | 0,01 W
0 | 11 | Summe Blindleistung (Kanal 1-3) | 0,01 Var
0 | 12 | Summe Scheinleistung (Kanal 1-3) | 0,01 VA
0 | 100 | ADC Temperatur | °C
1..3 | 0 | Berechnung läuft |
1..3 | 1..21 | Effektivwert der x-ten Oberschwingung (Strom) | 0,000001 A
1..3 | 51..71 | Verhältnis der x-ten Oberschwingung zur Grundschwingung (Strom) | 0,01 %
1..3 | 100 | Berechnung läuft |
1..3 | 101..121 | Effektivwert der x-ten Oberschwingung (Spannung) | 0,0001 V
1..3 | 151..171 | Verhältnis der x-ten Oberschwingung zur Grundschwingung (Spannung) | 0,01 %
11..13 | 0 | Scheinleistung von Phase x | 0,01 VA
11..13 | 1 | Blindleistung von Phase x | 0,01 Var
11..13 | 2 | Energie von Phase x | 0,001 Wh
11..13 | 3 | cosPhi von Phase x | 0,001
11..13 | 4 | Frequenz von Phase x | 0,1 Hz
11..13 | 5 | Energie (negative) von Phase x | 0,001 Wh
11..13 | 6 | Winkel λ zwischen Phase x und Phase 1 | 0,01°
11..13 | 10 | Strom von Phase x | 0,000001 A
11..13 | 11 | Spannung von Phase x | 0,0001 V
11..13 | 12 | Wirkleistung von Phase x | 0,01 W

Predifined PDO Assignment

Eine vereinfachte Auswahl der Prozessdaten ermöglicht das "Predefined PDO Assignment". Am unteren Teil des Prozessdatenreiters wählen Sie die gewünschte Funktion aus. Es werden dadurch alle benötigten PDOs automatisch aktiviert, bzw. die nicht benötigten deaktiviert.
Sollten Kanäle nicht genutzt werden, wird empfohlen die entsprechenden Kanäle zu deaktivieren, um mögliche Fehlermeldungen der Klemme zu vermeiden.

Abb. 3: Auswahl Predefined PDOs

Neun PDO-Zuordnungen stehen zur Auswahl:

Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
Complete (Phase 1/2/3 + Auxiliary) | 0x1600 (PM Outputs Channel 1) 0x1601 (PM Outputs Channel 2) 0x1602 (PM Outputs Channel 3) 0x1603 (PM Outputs Auxiliary) | 0x1A00 (PM Inputs Channel 1) 0x1A01 (PM Inputs Channel 2) 0x1A02 (PM Inputs Channel 3) 0x1A03 (PM Inputs Auxiliary)
Minimal (all phases active, accessible by Auxiliary channel) | 0x1603 (PM Outputs Auxiliary) | 0x1A03 (PM Inputs Auxiliary)
Phase 1/2/3 | 0x1600 (PM Outputs Channel 1) 0x1601 (PM Outputs Channel 2) 0x1602 (PM Outputs Channel 3) | 0x1A00 (PM Inputs Channel 1) 0x1A01 (PM Inputs Channel 2) 0x1A02 (PM Inputs Channel 3)
Phase 1 only | 0x1600 (PM Outputs Channel 1) | 0x1A00 (PM Inputs Channel 1)
Phase 2 only | 0x1601 (PM Outputs Channel 2) | 0x1A01 (PM Inputs Channel 2)
Phase 3 only | 0x1602 (PM Outputs Channel 3) | 0x1A02 (PM Inputs Channel 3)
Phase 1+2 | 0x1600 (PM Outputs Channel 1) 0x1601 (PM Outputs Channel 2) | 0x1A00 (PM Inputs Channel 1) 0x1A01 (PM Inputs Channel 2)
Phase 1+3 | 0x1600 (PM Outputs Channel 1) 0x1602 (PM Outputs Channel 3) | 0x1A00 (PM Inputs Channel 1) 0x1A02 (PM Inputs Channel 3)
Phase 2+3 | 0x1601 (PM Outputs Channel 2) 0x1602 (PM Outputs Channel 3) | 0x1A01 (PM Inputs Channel 2) 0x1A02 (PM Inputs Channel 3)


EL7201- Konfiguration der wichtigsten Parameter

BECKHOFF EL3413: Inbetriebnahme

Einstellungen und Messungen

(Master TwinCAT 2.11 R3)

Inhaltsverzeichnis
• Bezugskanal der Frequenzmessung und Leistungs-/Energiemessung
• Messzykluszeit
• Strommessbereich
• PM Command (Index FB00)

Bezugskanal der Frequenzmessung und Leistungs-/Energiemessung

Bei der EL3413 werden immer alle 3 Kanäle unabhängig voneinander als Referenz für die Frequenzmessung bzw. Leistungs-/Energiemessung ausgewählt. Um eine Fehlerausgabe der Klemme zu vermeiden, sollten die Kanäle, die nicht genutzt werden, deaktiviert werden.
Mit Hilfe der Predefined PDOs können die richtigen Kanäle ausgewählt werden. Darüber hinaus können mit Hilfe des Command-Objektes (Index FB00:01) einzelne Phasen ein- bzw. ausgeschaltet werden.

Messzykluszeit

Anzahl der Perioden, die für die Berechnung des Echteffektivwerts zugrunde gelegt werden. Je höher dieser Wert ist, um so konstanter ist der Ausgabewert der Messgrößen. Es sind ein Minimum von 4 Perioden notwendig, empfohlen werden jedoch mindesten 5 Perioden.
Der Standardwert von 10 Perioden hat sich als guter Kompromiss von Stabilität und Geschwindigkeit bewährt.

Die Messzykluszeit kann mit Hilfe des Command-Objekt (Index FB00:01) verändert werden. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.

0x0022 Messintervall 4 Perioden
0x0122 Messintervall 5 Perioden
0x0222 Messintervall 10 Perioden (default)
0x0322 Messintervall 16 Perioden
0x0422 Messintervall 32 Perioden

Beispiel

Um den Messintervall auf 16 Perioden zu ändern ist im Index FB00:01 der Wert 0322hex einzutragen.

Die Übernahme der neuen Messzykluszeit kann bis zu 10 Sekunden in Anspruch nehmen. Der Wert wird nicht im EEPROM gespeichert, nach einem Spannungsreset der Klemme ist wieder eine Messzykluszeit von 10 Perioden eingestellt. Um dieses zu Vermeiden kann der Wert mit Hilfe eines Startup Parameters eingestellt werden.

Strommessbereich

Die EL3413 bietet drei Strommessbereiche an. Der Messbereichsendwert vom Strom kann auf 5 A, 1 A oder 0,1 A (noch nicht freigegeben) eingestellt werden. Die richtige Einstellung des Messbereichsendwertes ist wichtig, um unnötige Messungenauigkeiten zu vermeiden. Es wird empfohlen, immer im oberen Drittel des Messbereichsendwertes zu messen.

Beispiel

Um den Messbereichsendwert auf 5 A zu ändern ist im Index 8027:19 der Wert 2dez einzutragen.

Achtung 		Beschädigung des Gerätes möglich!
Eine Überschreitung des Messbereichsendwertes kann zu falschen Messergebnissen und zu Beschädigungen der Klemme führen.

PM Command (Index FB00)

Das Command-Objekt wird genutzt, um in der Klemme eine Aktion auszulösen. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.
Beim Schreiben des Subindexes ist zu beachten, dass das Feld "Hex" nicht direkt beschrieben werden kann, es muss das Feld "Binary" dafür genutzt werden. Die Eingabe erfolgt dabei in umgekehrter Reihenfolge, mit Leerzeichen (siehe Abb. 1).

Beispiel

Zur manuellen Löschung der Energiewerte aller Kanäle ist im Index FB00:01 der Wert 0004hex einzutragen.

Abb. 1: Beschreiben des Subindex 01, Objekt FB00


EL7201- Konfiguration der wichtigsten Parameter

BECKHOFF EL3413: Inbetriebnahme

Messungen

(Master TwinCAT 2.11 R3)

Inhaltsverzeichnis
• Energie
- manualsaved (Index 90x01:01 und 90x0:02
- autosaved (Index 90x0:03 und 90x0:04)
• PM Inputs Channel 1/2/3
- STATUS
- Current
- Voltage
- Active Power
- Index
- VariantValue
• PM Inputs Channel Auxiliary
- STATUS
- Index
- Channel
- Value
• PM Outputs Channel 1/2/3
- Index
• PM Ouputs Channel Auxiliary
- Index
- Channel

Energie

manualsaved (Index 90x0:01 und 90x0:02)

Die Energiewerte der Kanäle 1-3 können in den Objekten 90x0:01 gespeichert (z.B. vor dem Abschalten des Systems, um den Energiewert möglichst genau abzuspeichern) oder es kann eine Löschung der bereits abgespeicherten Energiewerte durchgeführt werden. Dies wird mit dem Command-Objekt (Index FB00:01) ausgelöst. Der negative Energiewert (generatorischer Betrieb) kann in den Objekten 90x0:02 gespeichert werden. Diese Werte können nur manuell gespeichert oder gelöscht werden.

Dieser Wert wird bei der EL3403 unter dem Index 0xF801 gespeichert. Aus Kompatibilität existiert dieser Index in der EL3413 ebenfalls. Sollten Programm-Bausteine auf diesen Index zugreifen, können diese weiterhin genutzt werden. In neuen Anwendungen wird jedoch empfohlen den Index 90x0 zu verwenden.

Beispiel 1

Bei manueller Abspeicherung des Energiewertes von Kanal 2 ist im Index FB00:01 der Wert 0214hex einzutragen.

Beispiel 2

Zur manuellen Löschung der Energiewerte aller Kanäle ist im Index FB00:01 der Wert 0004hex einzutragen.

autosaved (Index 90x0:03 und 90x0:04)

Die Energiewerte der Kanäle 1-3 werden in den Objekten 90x0:03 alle 15 Minuten automatisch gespeichert. Darüber hinaus hat der Anwender die Möglichkeit mit dem Command-Objekt (Index FB00:01) auch zu einem selbst definierten Moment den aktuellen Energiewert zu speichern oder den kompletten Inhalt zu löschen. Der 15 minütige Timer fängt in diesem Moment wieder bei Null an.

Beispiel 1

Bei manueller Abspeicherung des Energiewertes von Kanal 3 ist im Index FB00:01 der Wert 0334hex einzutragen.

Beispiel 2

Zur manuellen Löschung der Energiewerte aller Kanäle ist im Index FB00:01 der Wert 0024hex einzutragen.

PM Inputs Channel 1/2/3

STATUS

Mit dem Struct "STATUS" können folgende nützliche Status Informationen des jeweiligen Kanals eingelesen werden.

  • Overvoltage (Spannung ist größer 415 V)
  • Undervoltage (Spannung ist kleiner 5 V)
  • Overcurrent (Strom ist 1,1x größer als der Messbereichsendwert)
  • Phase sequence cw (rechtsdrehendes Feld)
  • Phase sequence ccw (linksdrehendes Feld)
  • Missing zero crossing
  • TxPDO State
  • TxPDO Toggle

Current

Zyklische Messung des Stroms der jeweiligen Phase.

Voltage

Zyklische Messung der Spannung der jeweiligen Phase.

Active power

Zyklische Messung der Wirkleistung der jeweiligen Phase.

Index

Zeigt an, welche Kenngröße der "VariantValue" aktuell misst.

VariantValue

Hinter dem VariantValue verbergen sich mehrere Kenngrößen. Es besteht die Möglichkeit, folgende Werte des jeweiligen Kanals einzulesen.

  • die Scheinleistung
  • die Blindleistung
  • die Energie
  • den cosPhi
  • die Frequenz
  • die negative Energie
  • den Winkel α der entsprechenden Phase zur Phase L1

Die Umschaltung der einzelnen Kenngrößen erfolgt mit Hilfe der jeweiligen zyklischen Ausgangsvariablen "Index".

PM Inputs Auxiliary

STATUS

Hier kann der TxPDO Toggle dieses Kanals eingelesen werden

Index

Zeigt an, welche Kenngröße der "Value" aktuell misst. Der Wert 0 oder 100 bedeutet, dass aktuell noch eine Messung läuft.

Channel

Zeigt an, auf welchem Kanal aktuell gemessen wird.

Value

Hinter dem Value verbergen sich mehrere Kenngrößen. Ist im "Channel" der Wert 0 eingetragen, können folgende Werte eingelesen werden.

  • THDN IL1+IL2+IL3 (zur Zeit nicht aktiv)
  • Summe der Energie (Phase 1-3)
  • Frequenz
  • Summe der negativen Energie (Phase 1-3)
  • Summe der Wirkleistung (Phase 1-3)
  • Summe der Blindleistung (Phase 1-3)
  • Summe der Scheinleistung (Phase 1-3)
  • Temperatur am ADC

Ist im Channel der Wert 1, 2 oder 3 eingetragen, können folgende Werte der jeweiligen Phase 1, 2 oder 3 eingelesen werden.

  • Effektivwert der Oberschwingung des Stroms
  • Verhältnis der Oberschwingung zur Grundschwingung des Stroms
  • Effektivwert der Oberschwingung der Spannung
  • Verhältnis der Oberschwingung zur Grundschwingung der Spannung

Ist im Channel der Wert 11, 12 oder 13 eingetragen, können folgende Werte der jeweiligen Phase 1, 2 oder 3 eingelesen werden.

  • die Scheinleistung
  • die Blindleistung
  • die Energie
  • den cosPhi
  • die Frequenz
  • die negative Energie
  • der Winkel λ der entsprechenden Phase zur Phase L1
  • der Strom
  • die Spannung
  • die Wirkleistung

Die Umschaltung der einzelnen Kenngrößen erfolgt mit Hilfe der zyklischen Ausgangsvariablen "Index".

PM Outputs Channel 1/2/3

Index

Hier ist der Wert der zu messenden Kenngröße einzutragen, die im entsprechenden "Variant value" eingelesen werden soll.

PM Outputs Auxiliary

Index

Hier ist der Wert der zu messenden Kenngröße einzutragen, die im "Value" eingelesen werden soll.

Channel

Hier kann die Phase ausgewählt werden, die gemessen werden soll.


EL3413 - Skalierungsfaktoren

BECKHOFF EL3413: Inbetriebnahme

Skalierungsfaktoren

In der folgenden Übersicht sind die Skalierungsfaktoren angegeben, die zur Berechnung der Istwerte aus den Prozessdatenrohwerten benötigt werden.

Skalierungsfaktoren EL3413

Werte | Berechnung
Strom (5 A) | Rohwerte x 0,000001 A
Strom (1 A) | Rohwerte x 0,000001 A
Strom (0,1 A) | zur Zeit nicht aktiv
Spannung | Rohwerte x 0,0001 V
Wirkleistung | Rohwerte x 0,01 W
Scheinleistung | Rohwerte x 0,01 VA
Blindleistung | Rohwerte x 0,01 Var
Energie | Rohwerte x 0,001 Wh
cosPhi | Rohwerte x 0,001
Frequenz | Rohwerte x 0,1 Hz
Winkel λ | Rohwerte x 0,01°
THDN (IA+IB+IC) | zur Zeit nicht aktiv
Effektivwert Oberschwingung (Strom 1 A) | Rohwerte x 0,000001 A
Effektivwert Oberschwingung (Strom 5 A) | Rohwerte x 0,000001 A
Verhältnis Oberschwingung zu Grundschwingung | Rohwerte x 0,01 %
Effektivwert Oberschwingung Spannung | Rohwerte x 0,0001 V

Tab. 1: Skalierungsfaktoren zur Berechnung der Istwerte aus Prozessdatenrohwerten


Hinweise zu analogen Spezifikationen

Beckhoff IO-Geräte (Klemmen, Boxen) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.

Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.

Stichwort Erläuterung
Messbereichsendwert Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.

Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.

Für die obigen Beispiele bedeutet dies:

  • Messbereich 0..10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
  • Messbereich 4..20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
  • Messbereich -200..1370 °C: asymmetrisch bipolar, MBE = 1370 °C, Messspanne = 1570 °C
  • Messbereich -10..+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
± Messfehler [% vom MBE]

(auch: Messabweichung)

Der relative Messfehler bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.

Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung, ...).

Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben..

Die maximale Abweichung kann auch direkt angegeben werden.

Beispiel: Messbereich 0..10 V und Messfehler < ± 0,3% MBE --> maximale Abweichung ± 30 mV im zul. Betriebstemperaturbereich.

Hinweis: da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel von einem signifikant geringerem Messfehler ausgegangen werden.


Objektbeschreibung und Parametrierung

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.

Hinweis 		Parametrierung
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
  • Profilspezifische Objekte, in denen die Ein- und Ausgangswerte angezeigt sind.

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte für die Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Länge dieses Objekts | UINT8 | RO | 0x01 (1dez)
1011:01 | Subindex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8027 PM Settings
Index | Name | Bedeutung |  |  | Datentyp | Flags | Default
8027:0 | PM Settings |  | Wert | Beschreibung | UINT8 | RO | 0x28 (40dez)
8027:03 | Measuring mode | Messmethode | 0 | 3-Leiter-Anschluss Dreieck, 4-Leiter-Anschluss Stern | BIT2 | RW | 0x00 (0dez)
 |  |  | 1 | reserviert
 |  |  | 2 | reserviert
8027:19 | Current range | Strom Messbereich | 0 | 1 A | BIT4 | RW | 0x00 (0dez)
 |  |  | 1 | 0,1 A (zur Zeit nicht aktiv)
 |  |  | 2 | 5 A
8027:28 | External CT phase Offset | Phasenverschiebung der externen Stromwandler |  |  | UINT16 | RW | 0x000A (0dez)

Objekte für den regulären Betrieb

Index FB00 PM Command

Das Command-Objekt wird genutzt, um in der Klemme eine Aktion auszulösen. Durch Schreiben des Subindexes 1 (Request) wird das Kommando gestartet. Dieser kann erst wieder beschrieben werden, wenn das aktuelle Kommando beendet wurde.

Index | Name | Bedeutung |  | Datentyp | Flags | Default
FB00:0 | PM Command | Größter Subindex dieses Objekts |  | UINT8 | RO | 0x03
FB00:01 | Request | Byte 0 - Service Request Daten |  | OCTET-STRING [2] | RW | 0x0000 (0dez)
 |  | 2hex | Messung der Phase abschalten
 |  | 4hex | Energie löschen
 |  | 12hex | Phase einschalten
 |  | 14hex | Energie speichern
 |  | 24hex | Energie löschen (autosaved)
 |  | 34hex | Energie speichern (autosaved)
 |  | Byte 1 - Auswahl des Kanals
 |  | 00hex | alle Kanäle
 |  | 01hex | Kanal 1
 |  | 02hex | Kanal 2
 |  | 03hex | Kanal 3
FB00:02 | Status | Byte 0 |  | UINT8 | RW | 0x00 (0dez)
 |  | reserviert
FB00:03 | Response | Byte 0 |  | OCTET-STRING [2] | RW | 0x00000000 (0dez)
 |  | reserviert
 |  | Byte 1
 |  | reserviert
 |  | Byte 2-n
 |  | reserviert

Vollständige Übersicht

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete Profil (5001). | UINT32 | RO | 0x01541389
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL3413
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Fimrware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Länge dieses Objekts | UINT8 | RO | 4
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 2
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0D4B3052 (223031378dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | z.B. 0x00001E06 (KW 30/2006)
Index 10F0 Backup parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter | Länge dieses Objektes | UINT8 | RO | 0x01
10F0:01 | Checksum | Checksum | UINT32 | RW | 0x00000000 (0dez)
Index 1600 RxPDO-Map Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map Ch.1 | PDO Mapping der RxPDO 1 | UINT8 | RO | 0x01
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PM Outputs Ch.1), entry 0x01 (Index)) | UINT32 | RW | 0x7000:01, 8
Index 1601 RxPDO-Map Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | RxPDO-Map Ch.2 | PDO Mapping der RxPDO 2 | UINT8 | RO | 0x01 (1dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PM Outputs Ch.2), entry 0x01 (Index)) | UINT32 | RW | 0x7010:01, 8
Index 1602 RxPDO-Map Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | RxPDO-Map Ch.3 | PDO Mapping der RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PM Outputs Ch.3), entry 0x01 (Index)) | UINT32 | RW | 0x7020:01, 8
Index 1603 RxPDO-Map Auxiliary Channel
Index | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | RxPDO-Map Ch.3 | PDO Mapping der RxPDO 3 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (PM Outputs Ch.3), entry 0x01 (Index)) | UINT32 | RW | 0x7030:01, 8
1603:02 | SubIndex 002 | 1. PDO Mapping entry (object 0x7030 (PM Auxiliary Outputs Ch.3), entry 0x02 (Channel)) | UINT32 | RW | 0x7030:02, 8
Index 1A00 TxPDO-Map Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map Ch.1 | PDO Mapping der TxPDO 1 | UINT8 | RO | 0x10 (16dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x01 (Undervoltage)) | UINT32 | RW | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x02 (Overvoltage)) | UINT32 | RW | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x03 (Overcurrent)) | UINT32 | RW | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x05 (Phase sequence cw)) | UINT32 | RW | 0x6000:05, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x06 (Phase sequence ccw)) | UINT32 | RW | 0x6000:06, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x7 (Missing zero crossing)) | UINT32 | RW | 0x6000:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (Align) | UINT32 | RW | 0x6000:08, 7
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x10 (TxPDO State)) | UINT32 | RW | 0x6000:09, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6000:10, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x11 (Current)) | UINT32 | RW | 0x6000:11, 32
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x12 (Voltage)) | UINT32 | RW | 0x6000:12, 32
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x13 (Active power)) | UINT32 | RW | 0x6000:13, 32
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x14 (Index)) | UINT32 | RW | 0x6000:14, 8
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 8
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6000 (PM Inputs Ch.1), entry 0x1D (VariantValue)) | UINT32 | RW | 0x6000:1D, 32
Index 1A01 TxPDO-Map Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | TxPDO-Map Ch.2 | PDO Mapping der TxPDO 2 | UINT8 | RO | 0x10 (16dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x01 (Undervoltage)) | UINT32 | RW | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x02 (Overvoltage)) | UINT32 | RW | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x03 (Overcurrent)) | UINT32 | RW | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x05 (Phase sequence cw)) | UINT32 | RW | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x06 (Phase sequence ccw)) | UINT32 | RW | 0x6010:06, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x7 (Missing zero crossing)) | UINT32 | RW | 0x6010:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (Align) | UINT32 | RW | 0x6010:08, 7
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x10 (TxPDO State)) | UINT32 | RW | 0x6010:09, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6010:10, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x11 (Current)) | UINT32 | RW | 0x6010:11, 32
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x12 (Voltage)) | UINT32 | RW | 0x6010:12, 32
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x13 (Active power)) | UINT32 | RW | 0x6010:13, 32
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x14 (Index)) | UINT32 | RW | 0x6010:14, 8
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 8
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6010 (PM Inputs Ch.1), entry 0x1D (VariantValue)) | UINT32 | RW | 0x6010:1D, 32
Index 1A02 TxPDO-Map Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | TxPDO-Map Ch.3 | PDO Mapping der TxPDO 3 | UINT8 | RO | 0x0D (16dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x01 (Undervoltage)) | UINT32 | RW | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x02 (Overvoltage)) | UINT32 | RW | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x03 (Overcurrent)) | UINT32 | RW | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x05 (Phase sequence cw)) | UINT32 | RW | 0x6020:05, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x06 (Phase sequence ccw)) | UINT32 | RW | 0x6020:06, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x7 (Missing zero crossing)) | UINT32 | RW | 0x6020:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (Align) | UINT32 | RW | 0x6020:08, 7
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x10 (TxPDO State)) | UINT32 | RW | 0x6020:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x10 (TxPDO Toggle)) | UINT32 | RW | 0x6020:10, 1
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x11 (Current)) | UINT32 | RW | 0x6020:11, 32
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x12 (Voltage)) | UINT32 | RW | 0x6020:12, 32
1A02:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x13 (Active power)) | UINT32 | RW | 0x6020:13, 32
1A02:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x14 (Index)) | UINT32 | RW | 0x6020:14, 8
1A02:0F | SubIndex 015 | 15. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 8
1A02:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6020 (PM Inputs Ch.1), entry 0x1D (VariantValue)) | UINT32 | RW | 0x6020:1D, 32
Index 1A03 TxPDO-Map Auxiliary
Index | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | TxPDO-Map Auxiliary | PDO Mapping der TxPDO 4 | UINT8 | RO | 0x05 (5dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (Align) | UINT32 | RW | 0x0000:00, 15
1A03:02 | SubIndex 002 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary, entry 0x02 (TxPDO Toggle)) | UINT32 | RW | 0x6030:10, 1
1A03:03 | SubIndex 003 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary), entry 0x03 (Index)) | UINT32 | RW | 0x6030:10, 8
1A03:04 | SubIndex 004 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary), entry 0x04 (Channel)) | UINT32 | RW | 0x6030:10, 8
1A03:05 | SubIndex 005 | 1. PDO Mapping entry (object 0x6030 (PM Auxiliary, entry 0x05 (Value)) | UINT32 | RW | 0x6030:10, 32
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Länge dieses Objekts | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RW | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RW | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RW | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RW | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign der Outputs | UINT8 | RO | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete PDO (RxPDO-Map Ch.1 (RxPDO 1)) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete PDO (RxPDO-Map Ch.2 (RxPDO 2)) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete PDO (RxPDO-Map Ch.3 (RxPDO 3)) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | Subindex 004 | 4. zugeordnete PDO (RxPDO-Map Auxiliary (RxPDO 4)) | UINT16 | RW | 0x1603 (5634dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign der Inputs | UINT8 | RO | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete PDO (TxPDO-Map Ch.1 (TxPDO 1)) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete PDO (TxPDO-Map Ch.2 (TxPDO 2)) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete PDO (TxPDO-Map Ch.3 (TxPDO 3)) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete PDO (TxPDO-Map Auxiliary (TxPDO 4)) | UINT16 | RW | 0x1A03 (6659dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron mit SM 2 Event
  • 2: DC-Mode - Synchron mit SYNC0 Event
  • 3: DC-Mode - Synchron mit SYNC1 Event
UINT16 RW 0x0001 (1dez)
1C32:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron mit SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32 RW 0x000AAE60 (700000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C32:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0 = 1: Free Run wird unterstützt
  • Bit 1 = 1: Synchron mit SM 2 Event wird unterstützt
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16 RW 0x8007 (32775dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RW | 0x000AAE60 (700000dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C32:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestopptt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C32:033, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt 		UINT16 RW 0x0000 (0dez)
1C32:09 | Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT166 | RW | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RW | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)) | UINT16 | RW | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RW | 0x00 (0dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputss | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron mit SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron mit SYNC0 Event
  • 3: DC - Synchron mit SYNC1 Event
  • 34: Synchron mit SM 2 Event (Outputs vorhanden)
UINT16 RW 0x0022 (34dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x000AAE60 (700000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron mit SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron mit SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
UINT16 RW 0x8007 (32775dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RW | 0x000AAE60 (700000dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)) | UINT32 | RW | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:0B | UINT16 | RW | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:0C | UINT16 | RW | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:0D | UINT16 | RW | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:20 | BOOLEAN | RWW | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 PM Inputs Ch.1
Index | Name | Bedeutung |  |  |  | Datentyp | Flags | Default
6000:0 | PM Inputs Ch.1 | Größter Subindex dieses Objekts |  |  |  | UINT8 | RO | 0x1D (29dez)
6000:0E | Sync Error | reserviert |  |  |  | BOOLEAN | RW | 0x00 (0dez)
6000:10 | TxPDO Toggle | wird bei jedem positiven Nulldurchgang von Kanal 1 getoggelt |  |  |  | BOOLEAN | RW | 0x00 (0dez)
6000:11 | Current | Strom Kanal 1 | Einheit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dez)
6000:12 | Voltage | Spannung Kanal 1 | Einheit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dez)
6000:13 | Active power | Wirkleistung Kanal 1 | Einheit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dez)
6000:14 | Index | Acknowledge für variablen Ausgabewert Kanal 1 | Index (dez) | Bezeichnung | Einheit | UINT8 | RW | 0x00 (0dez)
 |  |  | 0 | Scheinleistung | 0,01 VA
 |  |  | 1 | Blindleistung | 0,01 VAR
 |  |  | 2 | Energie | 0,001 Wh
 |  |  | 3 | cosPhi | 0,001
 |  |  | 4 | Frequenz | 0,1 Hz
 |  |  | 5 | Energie (negative) | 0,001 Wh
 |  |  | 6 | Winkel α zwischen Phase 1 und Phase 1 | 0,01 °
 |  |  | 7-255 | reserviert | -
6000:1D | VariantValue | variabler Ausgabewert Kanal 1 ( siehe Index 6000:14) |  |  |  | INT32 | RW | 0x00000000 (0dez)
Index 6010 PM Inputs Ch.2
Index | Name | Bedeutung |  |  |  | Datentyp | Flags | Default
6010:0 | PM Inputs Ch.2 | Größter Subindex dieses Objekts |  |  |  | UINT8 | RO | 0x1D (29dez)
6010:0E | Sync Error | reserviert |  |  |  | BOOLEAN | RW | 0x00 (0dez)
6010:10 | TxPDO Toggle | wird bei jedem positiven Nulldurchgang von Kanal 2 getoggelt |  |  |  | BOOLEAN | RW | 0x00 (0dez)
6010:11 | Current | Strom Kanal 2 | Einheit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dez)
6010:12 | Voltage | Spannung Kanal 2 | Einheit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dez)
6010:13 | Active power | Wirkleistung Kanal 2 | Einheit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dez)
6010:14 | Index | Acknowledge für variablen Ausgabewert Kanal 2 | Index (dez) | Bezeichnung | Einheit | UINT8 | RW | 0x00 (0dez)
 |  |  | 0 | Scheinleistung | 0,01 VA
 |  |  | 1 | Blindleistung | 0,01 VAR
 |  |  | 2 | Energie | 0,001 Wh
 |  |  | 3 | cosPhi | 0,001
 |  |  | 4 | Frequenz | 0,1 Hz
 |  |  | 5 | Energie (negative) | 0,001 Wh
 |  |  | 6 | Winkel α zwischen Phase 2 und Phase 1 | 0,01 °
 |  |  | 7-255 | reserviert | -
6010:1D | VariantValue | variabler Ausgabewert Kanal 2 ( siehe Index 6010:14) |  |  |  | INT32 | RW | 0x00000000 (0dez)
Index 6020 PM Inputs Ch.3
Index | Name | Bedeutung |  |  |  | Datentyp | Flags | Default
6020:0 | PM Inputs Ch.3 | Größter Subindex dieses Objekts |  |  |  | UINT8 | RO | 0x1D (29dez)
6020:0E | Sync Error | reserviert |  |  |  | BOOLEAN | RW | 0x00 (0dez)
6020:10 | TxPDO Toggle | wird bei jedem positiven Nulldurchgang von Kanal 3 getoggelt |  |  |  | BOOLEAN | RW | 0x00 (0dez)
6020:11 | Current | Strom Kanal 3 | Einheit: 0,000001 A |  |  | INT32 | RW | 0x00000000 (0dez)
6020:12 | Voltage | Spannung Kanal 3 | Einheit: 0,0001 V |  |  | INT32 | RW | 0x00000000 (0dez)
6020:13 | Active power | Wirkleistung Kanal 3 | Einheit: 0,01 W |  |  | INT32 | RW | 0x00000000 (0dez)
6020:14 | Index | Acknowledge für variablen Ausgabewert Kanal 3 | Index (dez) | Bezeichnung | Einheit | UINT8 | RW | 0x00 (0dez)
 |  |  | 0 | Scheinleistung | 0,01 VA
 |  |  | 1 | Blindleistung | 0,01 VAR
 |  |  | 2 | Energie | 0,001 Wh
 |  |  | 3 | cosPhi | 0,001
 |  |  | 4 | Frequenz | 0,1 Hz
 |  |  | 5 | Energie (negative) | 0,001 Wh
 |  |  | 6 | Winkel α zwischen Phase 3 und Phase 1 | 0,01 °
 |  |  | 7-255 | reserviert | -
6020:1D | VariantValue | variabler Ausgabewert Kanal 3 ( siehe Index 6020:14) |  |  |  | INT32 | RW | 0x00000000 (0dez)
Index 6030 PM Inputs Auxiliary
Index | Name | Bedeutung | Datentyp | Flags | Default
6030:0 | PM Inputs Ch.3 | Größter Subindex dieses Objekts | UINT8 | RO | 0x13 (19dez)
6030:10 | TxPDO Toggle | wird bei jedem positiven Nulldurchgang von Kanal Auxiliary getoggelt | BOOLEAN | RW | 0x00 (0dez)
6030:11 Index Acknowledges für Auxiliary Variablen
Channel (dez) | Index (dez) | Bezeichnung | Einheit
0 | 0 | Reserviert (THDN IA+IB+IC) zur Zeit nicht aktiv |
0 | 2 | Summe Energie (Kanal 1-3) | 0,001 Wh
0 | 4 | Frequenz | 0,1 Hz
0 | 5 | Summe Energie (negative) (Kanal 1-3) | 0,001 Wh
0 | 10 | Summe Wirkleistung (Kanal 1-3) | 0,01 W
0 | 11 | Summe Scheinleistung (Kanal 1-3) | 0,01 VA
0 | 12 | Summe Blindleistung (Kanal 1-3) | 0,01 Var
0 | 100 | ADC Temperatur | °C
1..3 | 0 | Berechnung läuft |
 | 1..21 | Effektivwert der x-ten Oberschwingung (Strom) | 0,000001 A
 | 51..71 | Verhältnis der x-ten Oberschwingung zur Grundschwingung (Strom) | 0,01 %
 | 100 | Berechnung läuft |
 | 101..121 | Effektivwert der x-ten Oberschwingung (Spannung) | 0,0001 V
 | 151..171 | Verhältnis der x-ten Oberschwingung z ur Grundschwingung (Spannung) | 0,01 %
11..13 | 0 | Scheinleistung der Phase x | 0,01 VA
 | 1 | Blindleistung der Phase x | 0,01 VAR
 | 2 | Energie der Phase x | 0,001 Wh
 | 3 | cosPhi der Phase x | 0,001
 | 4 | Frequenz der Phase x | 0,1 Hz
 | 5 | Energie (negative) der Phase x | 0,001 Wh
 | 6 | Winkel α zwischen Phase x und Phase 1 | 0,01 °
 | 10 | Strom der Phase x | 0,000001 A
 | 11 | Spannung der Phase x | 0,0001 V
 | 12 | Wirkleistung der Phase x | 0,01 W
 UINT8 RW 0x00 (0dez)
6030:12 | Channel | UINT8 | RW | 0x00 (0dez)
6030:13 | Value | variabler Ausgabewert Aux Kanal ( siehe Index 6030:12) | INT32 | RW | 0x00000000 (0dez)

Hinweis 		Berechnung von Oberschwingungen
Es ist nicht möglich, Oberschwingungen für mehr als einen Kanal gleichzeitig zu berechnen.

Bis die Oberschwingungsberechnung abgeschlossen ist wird der Index 00 bzw. 100 zurückgegeben

Index 7000 PM Outputs Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | PM Outputs Ch.1 | Größter Subindex dieses Objekts | UINT8 | RO | 0x01 (1dez)
7000:01 | Index | Request für variablen Ausgabewert Kanal 1 ( siehe Index 6000:1D) | UINT8 | RW | 0x00 (0dez)
Index 7010 PM Outputs Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | PM Outputs Ch.2 | Größter Subindex dieses Objekts | UINT8 | RO | 0x01 (1dez)
7010:01 | Index | Request für variablen Ausgabewert Kanal 2 ( siehe Index 6010:1D) | UINT8 | RW | 0x00 (0dez)
Index 7020 PM Outputs Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | PM Outputs Ch.3 | Größter Subindex dieses Objekts | UINT8 | RO | 0x01 (1dez)
7020:01 | Index | Request für variablen Ausgabewert Kanal 3 ( siehe Index 6020:1D) | UINT8 | RW | 0x00 (0dez)
Index 7030 PM Outputs Auxiliary
Index | Name | Bedeutung | Datentyp | Flags | Default
7030:0 | PM Outputs Ch.Auxiliary | Größter Subindex dieses Objekts | UINT8 | RO | 0x02 (dez)
7030:01 | Index | Request für variablen Ausgabewert Kanal Aux ( siehe Index 6030:13) | UINT8 | RW | 0x00 (0dez)
7030:02 | Channel | Auswahl Kanal für variablen Ausgabewert Kanal Aux ( siehe Index 6030:13) | UINT8 | RW | 0x00 (0dez)

Index 800F PM Vendor data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | PM Vendor data Ch.1 | Größter Subindex dieses Objekts | UINT8 | RO | 0x22 (34dez)
800F:02 | Calibration current gain | Hersteller Abgleich: Gain Strom Kanal 1 | UINT16 | RW | 0x4000 (0dez)
800F:04 | Calibration voltage gain | Hersteller Abgleich: Gain Spannung Kanal 1 | UINT16 | RW | 0x4000 (0dez)
800F:12 | Calibration current gain (0,1 A) | Hersteller Abgleich: Gain Strom Messbereich 0,1 A, Kanal 1 | INT16 | RW | 0x4000 (0dez)
800F:14 | Calibration current gain (5 A) | Hersteller Abgleich: Gain Strom Messbereich 5 A, Kanal 1 | INT16 | RW | 0x4000 (0dez)
800F:20 | Calibration phase Offset (1 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 0,1 A, Kanal 1 | UINT16 | RW | 0x0000 (0dez)
800F:21 | Calibration phase Offset (0,1 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 1 A, Kanal 1 | UINT16 | RW | 0x0000 (0dez)
800F:22 | Calibration phase Offset (5 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 5 A, Kanal 1 | UINT16 | RW | 0x0000 (0dez)
Index 801F PM Vendor data Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
801F:0 | PM Vendor data Ch.2 | Größter Subindex dieses Objekts | UINT8 | RO | 0x22 (34dez)
801F:02 | Calibration current gain | Hersteller Abgleich: Gain Strom Kanal 2 | UINT16 | RW | 0x4000 (0dez)
801F:04 | Calibration voltage gain | Hersteller Abgleich: Gain Spannung Kanal 2 | UINT16 | RW | 0x4000 (0dez)
801F:12 | Calibration current gain (0,1 A) | Hersteller Abgleich: Gain Strom Messbereich 0,1 A, Kanal 2 | INT16 | RW | 0x4000 (0dez)
801F:14 | Calibration current gain (5 A) | Hersteller Abgleich: Gain Strom Messbereich 5 A, Kanal 2 | INT16 | RW | 0x4000 (0dez)
801F:20 | Calibration phase Offset (1 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 0,1 A, Kanal 2 | UINT16 | RW | 0x0000 (0dez)
801F:21 | Calibration phase Offset (0,1 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 1 A, Kanal 2 | UINT16 | RW | 0x0000 (0dez)
801F:22 | Calibration phase Offset (5 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 5 A, Kanal 2 | UINT16 | RW | 0x0000 (0dez)
Index 802F PM Vendor data Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
802F:0 | PM Vendor data Ch.3 | Größter Subindex dieses Objekts | UINT8 | RO | 0x22 (34dez)
802F:02 | Calibration current gain | Hersteller Abgleich: Gain Strom Kanal 3 | UINT16 | RW | 0x4000 (0dez)
802F:04 | Calibration voltage gain | Hersteller Abgleich: Gain Spannung Kanal 3 | UINT16 | RW | 0x4000 (0dez)
802F:12 | Calibration current gain (0,1 A) | Hersteller Abgleich: Gain Strom Messbereich 0,1 A, Kanal 3 | INT16 | RW | 0x4000 (0dez)
802F:14 | Calibration current gain (5 A) | Hersteller Abgleich: Gain Strom Messbereich 5 A, Kanal 3 | INT16 | RW | 0x4000 (0dez)
802F:20 | Calibration phase Offset (1 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 0,1 A, Kanal 3 | UINT16 | RW | 0x0000 (0dez)
802F:21 | Calibration phase Offset (0,1 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 1 A, Kanal 3 | UINT16 | RW | 0x0000 (0dez)
802F:22 | Calibration phase Offset (5 A) | Hersteller Abgleich: Phasenverschiebung Messbereich 5 A, Kanal 3 | UINT16 | RW | 0x0000 (0dez)

Index 9000 PM Persistent data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
9000:0 | PM Persistent data Ch.1 | Größter Subindex dieses Objekts | UINT8 | RO | 0x04 (4dez)
9000:01 | Energy (overall) | gespeicherter Energiewert von Kanal 1 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9000:02 | Energy (negativ) | gespeicherter negativer Energiewert von Kanal 1 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9000:03 | Energy (overall) autosaved | automatisch gespeicherter Energiewert von Kanal 1 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9000:04 | Energy (negativ) autosaved | automatisch gespeicherter negativer Energiewert von Kanal 1 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
Index 9010 PM Persistent data Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
9010:0 | PM Persistent data Ch.2 | Größter Subindex dieses Objekts | UINT8 | RO | 0x04 (4dez)
9010:01 | Energy (overall) | gespeicherter Energiewert von Kanal 2 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9010:02 | Energy (negativ) | gespeicherter negativer Energiewert von Kanal 2 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9010:03 | Energy (overall) autosaved | automatisch gespeicherter Energiewert von Kanal 2 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9010:04 | Energy (negativ) autosaved | automatisch gespeicherter negativer Energiewert von Kanal 2 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
Index 9020 PM Persistent data Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
9020:0 | PM Persistent data Ch.3 | Größter Subindex dieses Objekts | UINT8 | RO | 0x04 (4dez)
9020:01 | Energy (overall) | gespeicherter Energiewert von Kanal 3 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9020:02 | Energy (negativ) | gespeicherter negativer Energiewert von Kanal 3 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9020:03 | Energy (overall) autosaved | automatisch gespeicherter Energiewert von Kanal 3 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)
9020:04 | Energy (negativ) autosaved | automatisch gespeicherter negativer Energiewert von Kanal 3 (1) Einheit: 0,001 Wh | INT32 | RO | 0x00000000 (0dez)

(1) Die Energiewerte können unter Zuhilfenahme des Command-Objekts (siehe Index FB00) gesichert/gelöscht werden. Der negative Energiewert ist der Wert, der durch eine negative Leistung erzeugt wird (generatorischer Betrieb). Der Energiewert in Subindex 01 und 03 setzt sich aus generatorischer und verbrauchter Energie zusammen, d.h. im Generatorbetrieb wird dieser Wert kleiner. Um die positive Energie zu berechnen, müssen beide Werte zusammengefasst werden.

Hinweis 		Index F801
Das Objekt 0xF801 (Energie) der EL3403 kann aus Kompatibilitätsgründen weiterhin ausgelesen werden. Bei neuen Projekten wird jedoch empfohlen, die oben beschriebenen Objekte zu nutzen.
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Größter Subindex dieses Objekts | UINT8 | RO | 0x02
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RW | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RW | 0x0003 (3dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)


Diagnose - Diag Messages

Inhaltsverzeichnis
• Definition
• Implementierung TwinCAT Systemmanager
• Interpretation
- Aufbau der Text-ID
- Allgemeine Text-IDs

Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem Systemmanager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.

Definition

Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.

Jede DiagMessage besteht aus

  • Diag Code (4 Byte)
  • Flags (2 Byte; Info, Warnung oder Fehler)
  • Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
  • Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
  • dynamische Parameter, die von der Firmware mitgegeben werden

In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.

Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.

DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.

Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:

Abb. 1: DiagMessages im CoE

Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.

Hinweis 		Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen.

Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.

Implementierung TwinCAT Systemmanager

Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.

Abb. 2: Implementierung DiagMessage-System im TwinCAT Systemmanager

Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:

  • Info/Warning/Error
  • Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
  • Zeitstempel
  • Text-ID
  • Klartext-Meldung nach ESI/XML Angabe

Die Bedeutung der Buttons sind selbsterklärend.

Interpretation

Aufbau der Text-ID

Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:

x | y | zz
0: Systeminfo 1: Info 4: Warning 8: Error | 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs | Fehlernummer

Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13

Allgemeine Text-IDs

Spezifische Text-ID sollten in der Gerätedokumentation angegeben werden.

Text-ID | Typ | Ort | Text (nur englisch) | Ursache
0x0001 | Information | System | No error | No error
0x0002 | Information | System | Communication established | Communication established
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1100 | Information | Allgemein |  | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein |  | Zykluszeit o.k.
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde
0x1300 | Information | Encoder |  | Position gesetzt - StartInputhandler
0x1400 | Information | Drive |  | Antrieb ist kalibriert
0x4000 | Warnung |  | Warning: 0x%X, 0x%X, 0x%X | allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4101 | Warnung | Allgemein | Terminal-Overtemperature | Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle
0x4300 | Warnung | Encoder |  | Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301 | Warnung | Encoder | Encoder-Warning | Allgemeiner Encoderfehler
0x4400 | Warnung | Drive |  | Antrieb ist nicht kalibriert
0x4401 | Warnung | Drive |  | Starttyp wird nicht unterstützt
0x4402 | Warnung | Drive |  | Kommando abgewiesen
0x4405 | Warnung | Drive |  | Modulo-Subtyp ungültig
0x4410 | Warnung | Drive |  | Zielposition wird überfahren
0x4411 | Warnung | Drive | DC-Link undervoltage (Warning) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x4412 | Warnung | Drive | DC-Link overvoltage (Warning) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x4413 | Warnung | Drive | I2T-Model Amplifier overload (Warning) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414 | Warnung | Drive | I2T-Model Motor overload (Warning) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x4415 | Warnung | Drive | Speed limitation active | Die maximale Drehzahl wird durch die parametrierten Objekte (z.B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen
0x8001 | Fehler | System | Error: 0x%X, 0x%X, 0x%X | allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002 | Fehler | System | Communication aborded |
0x8003 | Fehler | System | Configuration error: 0x%X, 0x%X, 0x%X | allgemeine, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8100 | Fehler | Allgemein |  | Fehlerbit im Statuswort gesetzt
0x8101 | Fehler | Allgemein |  | Betriebsart inkompatibel zum PDO-Interface
0x8102 | Fehler | Allgemein | Invalid combination of Inputs and Outputs PDOs | Ungueltige Kombination von In- und Output PDOs
0x8103 | Fehler | Allgemein | No variable linkage | Keine Variablen verknüpft
0x8104 | Fehler | Allgemein | Terminal-Overtemperature | Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden
0x8105 | Fehler | Allgemein | PD-Watchdog | Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt. - Die EtherCAT-Verbindung wurde im Betrieb unterbrochen - Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135 | Fehler | Allgemein | Cycletime has to be a multiple of 125 µs | Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar
0x8200 | Fehler | Kommunikation |  | Fehler beim Schreiben
0x8201 | Fehler | Kommunikation | No communication to field-side (Auxiliary voltage missing) | - Es ist keine Spannung an den Powerkontakten angelegt - Ein Firmware Update ist fehlgeschlagen
0x82FF | Fehler | Kommunikation |  | Bootmode nicht aktiviert
0x8300 | Fehler | Encoder |  | Fehler beim Setzen der Position
0x8301 | Fehler | Encoder |  | Enkoderinkremente nicht konfiguriert
0x8302 | Fehler | Encoder | Feedback-Error | Die Amplitude des Resolvers ist zu klein
0x8400 | Fehler | Drive |  | Antrieb fehlerhaft konfiguriert
0x8401 | Fehler | Drive |  | Begrenzung der Kalibrier-Geschwindigkeit
0x8402 | Fehler | Drive |  | Emergency-Stop aktiviert
0x8403 | Fehler | Drive | ADC Error | Fehler bei Strommessung im ADC
0x8404 | Fehler | Drive | Overcurrent | Überstrom Phase U, V, oder W
0x8405 | Fehler | Drive |  | Modulo-Position ungültig
0x8406 | Fehler | Drive | DC-Link undervoltage (Error) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x8407 | Fehler | Drive | DC-Link overvoltage (Error) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x8408 | Fehler | Drive | I2T-Model Amplifier overload (Error) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409 | Fehler | Drive | I2T-Model motor overload (Error) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x8415 | Fehler | Drive |  | Modulo-Faktor ungültig


Firmware Kompatibilität

Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.

Anmerkung

  • Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
  • Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.

Achtung 		Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.

Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen!
Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!

EL3413-0000
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
03 - 08* | 02* | EL3413-0000-0016 | 2012/06
 |  | EL3413-0000-0017 | 2012/07

*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.

Inhaltsverzeichnis
• Speicherorte
• Gerätebeschreibung ESI-File/XML
• Versionsbestimmung Firmware
• Update Controller-Firmware *.efw
• Update FPGA-Firmware *.rbf
• Mehrfaches Update

Speicherorte

In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:

  • Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
  • In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
  • Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung zu speichern, in einem sog. EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien (EtherCAT Slave Information) als Zip-Datei zugänglich.

Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.

Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
  • Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
  • Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
  • Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!

Gerätebeschreibung ESI-File/XML

Achtung 		ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.

Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:

Abb. 1: Gerätekennung aus Name EL3204-0000 und Revision -0016

Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.

Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.

Hinweis 		Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes.
Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.

Anzeige der Slave-Kennung ESI

Der einfachste Weg, die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/Freerun das Scannen der EtherCAT-Boxen auszuführen:

Abb. 2: Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes

Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint

Abb. 3: Konfiguration identisch

ansonsten ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.

Abb. 4: Änderungsdialog

In diesem Beispiel in Abb. 4. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.

Änderung der Slave-Kennung ESI

Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:

  • Einwandfreie EtherCAT-Kommunikation muss zum Slave hergestellt werden
  • Der State des Slave ist unerheblich
  • Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. 5

Abb. 5: EEPROM Update

Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. 6. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave'.

Abb. 6: Auswahl des neuen ESI

Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.

Hinweis 		Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen.
Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.

Versionsbestimmung der Firmware

Versionsbestimmung nach Laseraufdruck

Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 10 03 02:

12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).

Hinweis 		CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
  • online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt.
    Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
  • offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein.
    Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.

In Abb. 7 wird der FW-Stand der markierten EL3204 in CoE-Eintrag x100A mit 03 angezeigt.

Abb. 7: Anzeige FW-Stand EL3204

TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.

Update Controller-Firmware *.efw

Hinweis 		CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.

Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. 8.

Abb. 8: Firmware Update

Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.

  • Slave in INIT schalten (A)
  • Slave in BOOTSTRAP schalten
  • Kontrolle des aktuellen Status (B, C)
  • Download der neuen *efw-Datei
  • Nach Beendigung des Download in INIT schalten, dann in OP
  • Slave kurz stromlos schalten

FPGA-Firmware *.rbf

Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.

  • Controller-Firmware für die Aufbereitung der E/A-Signale
  • FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)

Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.

Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.

Abb. 9: Versionsbestimmung FPGA-Firmware

Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.

Abb. 10: Kontextmenu "Eigenschaften" (Properties)

In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.

Abb. 11: Dialog "Advanced settings"

Update

Für das Update der FPGA-Firmware

  • eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
  • einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.

Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!

Update eines EtherCAT-Geräts

Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.

Abb. 12: Dialog "Weitere Eimstellungen" wählen

Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,

Abb. 13: Dialog "Schreibe FPGA" wählen

Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen!

Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!

Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.

Gleichzeitiges Update mehrerer EtherCAT-Geräte

Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Vorraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.

Abb. 14: mehrfache Selektion und FW-Update

Wählen Sie dazu die betreffenden Slaves aus und führen Sie den FW-Update im BOOTSTRAP Modus wie o.a. aus.


ELxxxx - Wiederherstellen des Auslieferungszustandes

BECKHOFF ELxxxx: Konfiguration

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).

Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert

Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"

Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH

Eiserstr. 5
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Konfiguration

BECKHOFF EtherCAT: Konfiguration der Klemmen

Konfiguration mit dem TwinCAT System Manager

(Mit TwinCAT ab Version 2.10.0 (Build 1241), am Beispiel der EL5001 ab Firmware-Stand 0.7)

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der Klemme die Sie konfigurieren möchten (im Beispiel: Klemme 6 EL5001).

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung.

Karteireiter Allgemein

Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.

Karteireiter EtherCAT

Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem Anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.

Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.

Karteireiter Prozessdaten

Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.

Sync-Manager

Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.

Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.

PDO-Zuordnung

PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:

  • Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
  • Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.

Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.

Hinweis 		Aktivierung der PDO-Zuordnung
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
  • der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
  • der System-Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])

PDO-Liste

Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.

Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.

PDO-Inhalt

Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.

Download

Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.

PDO-Zuordnung

Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.

PDO-Konfiguration

Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.

Karteireiter Startup

Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.

Spalte | Beschreibung
Transition Übergang, in den der Request gesendet wird. Dies kann entweder
  • der Übergang von Pre-Operational to Safe-Operational (PS) oder
  • der Übergang von Safe-Operational to Operational (SO) sein.

Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll | Art des Mailbox-Protokolls
Index | Index des Objekts
Data | Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar | Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.

Karteireiter CoE - Online

Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.

Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.

Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.

Karteireiter Online

Status Maschine

Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.

DLL-Status

Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:

Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.

File Access over EtherCAT

Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


UL Hinweise

Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Grundlagen

Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:

  • UL-Zertifikation nach UL508
    Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen

  • UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme
    Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen

Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.

Anwendung

Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung

  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!

Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.