EL32xx-0xx0 - Analoge Eingangsklemmen Pt100 (RTD)
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Produktübersicht Analoge Eingangsklemmen Pt100 (RTD)
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Produktübersicht Analoge Eingangsklemmen Pt100 (RTD)

Vorwort [image] Produktübersicht Analoge Eingangsklemmen Pt100 (RTD)
Produktübersicht Analoge Eingangsklemmen Pt100 (RTD)
EL3201, EL3202, EL3204 | 1-, 2-, 4 kanalige Eingangsklemmen Pt100 (RTD)
EL3201-0010, EL3202-0010 | 1-, 2 kanalige Eingangsklemmen Pt100 (RTD), hochpräzise
EL3201-0020, EL3202-0020 | 1-, 2 kanalige Eingangsklemmen Pt100 (RTD), hochpräzise mit Kalibrierungszertifikat
EL3204-0200 | 4 kanalige Eingangsklemme für RTD bis 240 kΩ, NTC 20 k, 16 Bit
EL3214 | 4 kanalige HD-Eingangsklemme Pt100 für 3-Leiteranschluss
EL3214-0090 | 4 kanalige HD-Eingangsklemme für Pt100 (RTD), 3-Leiteranschluss, TwinSAFE Single Channel
EL3208 | 8 kanalige HD-Eingangsklemme Pt100 (RTD)


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
5.7
▪
Update Kapitel "Technische Daten"
▪
Strukturupdate
5.6
▪
Update Kapitel "Technische Daten"
▪
Strukturupdate
5.5
▪
Update Kapitel "Technische Daten"
▪
Update UL - Hinweise
5.4
▪
Update Kapitel "Technische Daten"
▪
Update Kapitel "CoE Objektbeschreibung EL32xx-00xx"
▪
Update Struktur
▪
Update Revisionsstand
5.3
▪
Update Kapitel "Technische Daten"
▪
Update Kapitel " EL3214-0090 - Einleitung" und Kapitel "CoE Objektbeschreibung EL32xx-00xx"
▪
Update Kapitel "TwinSAFE SC"
▪
Update Struktur
▪
Update Revisionsstand
5.2
▪
Update Kapitel "Objektverzeichnis", „Funktion“
▪
Update Struktur
▪
Update Revisionsstand
5.1
▪
Update Kapitel "Technische Daten"
▪
Update Struktur
▪
Update Revisionsstand
5.0
▪
EL3214-0090 ergänzt
▪
Update Kapitel "Technische Daten"
▪
Update Struktur
▪
Update Revisionsstand
4.9
▪
Update Kapitel "Technische Daten"Hinweis zum ESD-Schutz eingefügt
▪
Kapitel "Analogtechnische Hinweise - Spezifikationen" ersetzt durch Kapitel "Hinweise zu analogen Spezifikationen"
4.8
▪
Update Kapitel "Technologie RTD-Messung“
▪
Korrektur Revisionsstand
4.7
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Korrektur Technische Daten
▪
Update Kapitel "TwinCAT 2.1x" -> Kapitel "TwinCAT Entwicklungsumgebung" und Kapitel "TwinCAT Quick Start"
▪
Korrektur Revisionsstand
4.6
▪
Update Kapitel „Technische Daten“
▪
Revisionstand aktualisiert
4.5
▪
Update Kapitel „Einstellungen und Anwendungshinweise zur EL32xx-0010/0020“
▪
„Hinweis zum Werkskalibrierzertifikat“ in das Kapitel „Produktübersicht“ eingefügt
4.4
▪
Update Kapitel "Technische Daten"
▪
Update Struktur
▪
Update Revisionsstand
4.3
▪
Update Kapitel "Technologie RTD-Messung"
▪
Update Struktur
▪
Update Revisionsstand
4.2
▪
Update Kapitel "Technische Daten"
▪
Update Struktur
▪
Update Revisionsstand
4.1
▪
Update Kapitel "LED’s und Anschluss"
Version
Kommentar
4.0
▪
Überführung SCHEMA
▪
EL3208 hinzugefügt
▪
EL3214 hinzugefügt
▪
Update Kapitel "Technische Daten"
▪
Update Struktur
▪
Update Revisionsstand
3.1
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
▪
Update Struktur
▪
Update Revisionsstand
3.0
▪
Update Struktur
2.9
▪
EL3204-0200 ergänzt
▪
Update Struktur
2.8
▪
Kapitel "Technologie" aktualisiert
2.7
▪
Kapitel "Technologie RTD-Messung" aktualisiert, EL3204-0200 ergänzt
2.6
▪
Kapitel "Technologie" aktualisiert
2.5
▪
Kapitel "RTD-Technologie" hinzugefügt
2.4
▪
Update Kapitel "Technologie"
2.3
▪
Hinweis zum Anschluss analoger Signalleitungen ergänzt
2.2
▪
Hinweis Kalibrierungs-Zertifikat ergänzt
▪
Update Struktur
2.1
▪
EL3202-0020 ergänzt
2.0
▪
Datenflussschema ergänzt, Technische Hinweise ergänzt
1.9
▪
Technische Hinweise ergänzt
1.8
▪
Technische Hinweise ergänzt
1.7
▪
Technische Daten ergänzt und korrigiert
1.6
▪
Technische Korrekturen, Ergänzung EL3202-0010
1.5
▪
KT/KTY Kennlinien hinzugefügt, Ergänzung Limit
1.4
▪
Technische Änderungen hinzugefügt
1.3
▪
Technische Änderungen hinzugefügt
1.2
▪
EL3201-0010, EL3201-0020 hinzugefügt
1.1
▪
Technische Daten korrigiert
1.0
▪
Technische Daten ergänzt, erste Veröffentlichung


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL3201, EL3202, EL3204, EL3214, EL3208 - Einführung
•
EL3214-0090 - Einführung
•
Technologie RTD-Messung
•
Grundlagen der RTD-Technologie
•
Technische Daten
•
Hinweis zum Werkskalibrierzertifikat
•
Start


EL3201, EL3202, EL3204, EL3214, EL3208 - Einführung

Produktübersicht [image] EL3201, EL3202, EL3204, EL3214, EL3208 - Einführung
EL3201, EL3202, EL3204, EL3214, EL3208 - Einführung
Ein-, zwei- und vierkanalige analoge Eingangsklemmen Pt100 (RTD)
EL3201
EL3202
EL3204
Die analogen Eingangsklemmen EL320x erlauben den direkten Anschluss von Widerstandssensoren. Die Schaltung der EL3204 kann Sensoren in 2-Leitertechnik, die der EL3202 in 2- und 3-Leitertechnik betreiben, die EL3201 zusätzlich noch 4-Leitertechnik. Es werden diverse Sensorkennlinien (Pt100, Pt1000, NI120, NI1000, KTY-Typen u.a.) unterstützt.
Die EL3201-0010 ist die hochpräzise Ausführung der einkanaligen Klemme (EL3202-0010, zweikanalig) mit einem Messfehler < ±0,1 °C bei Pt-Sensoren (Umgebungstemperatur von 40°C). Diese Klemmen werden in 4-Leitertechnik betrieben. Die hochpräzisen EL3201-0020 und EL3202-0020 werden zusätzlich noch mit einem Kalibrierungszertifikat ausgeliefert.
Die Klemmen der Serie EL320x-xxxx können die Temperatur am Messort messen oder den Widerstandwert der Sensoren direkt ausgeben. Bei Temperaturmessung wird der Temperaturwert über die in der Klemme hinterlegten Kennlinien berechnet.
Mit der EL3204-0200 sind beliebige RTD im Bereich 100 Ohm bis 240 kOhm einsetzbar. Die Umrechnung der Widerstandswerte (Linearisierung) erfolgt in der Klemme wahlweise nach voreingestellten Kennlinien, Umrechnungsformeln mit spezifischen Materialkennwerten (bspw. nach IEC 60751, Steinhart-Hart-Gleichung, B-Parameter-Gleichung), oder nach einer frei programmierbaren Umrechnungstabelle.
Die EtherCAT-Klemmen zeigen ihren Signalzustand durch Leuchtdioden an. Sensorstörungen (z. B. Drahtbruch) signalisieren Error-LEDs.
Vierkanalige analoge HD-Eingangsklemme Pt100 (RTD) für 3-Leiteranschluss
EL3214
Die analoge Eingangsklemme EL3214 erlaubt den direkten Anschluss von vier Widerstandssensoren auf 12 mm Breite.
Die Schaltung der EtherCAT-Klemme kann Sensoren in 3-Leitertechnik betreiben. Ein Mikroprozessor realisiert die Linearisierung über den gesamten Temperaturbereich, der frei wählbar ist.
Die Standardeinstellung der EtherCAT-Klemme ist: Auflösung 0,1 °C. Sensorstörungen (z. B. Drahtbruch) signalisieren Error-LEDs.
Achtkanalige analoge HD-Eingangsklemme Pt100 (RTD)
EL3208
Die analoge Eingangsklemme EL3208 erlaubt den direkten Anschluss von acht Widerstandssensoren auf 12 mm Breite (High Density Gehäuse).
Die Schaltung der EtherCAT-Klemme kann Sensoren in 2-Leitertechnik betreiben. Ein Mikroprozessor realisiert die Linearisierung über den gesamten Temperaturbereich, der frei wählbar ist.
Die Standardeinstellung der EtherCAT-Klemme ist: Auflösung 0,1 °C. Sensorstörungen (z. B. Drahtbruch) signalisieren Error-LEDs.
Quick-Links
• EtherCAT Funktionsgrundlagen
• Technologie EL32xx
• Konfigurationserstellung TwinCAT
• CoE-Objektbeschreibung und Parametrierung
• Statuswort
• Prozessdaten und Betriebsmodi
• Einstellungen und Anwendungshinweise EL32xx-00xx
• Einstellungen und Anwendungshinweise EL3204-0200


EL3214-0090 - Einführung

Produktübersicht [image] EL3214-0090 - Einführung
EL3214-0090 - Einführung
Vierkanalige analoge Eingangsklemmen Pt100 (RTD), 2/3-Leiteranschluss, TwinSAFE Single Channel
EL3214-0090
Die analoge Eingangsklemme EL3214-0090 erlaubt den direkten Anschluss von vier Widerstandssensoren. Die Schaltung der EtherCAT-Klemme kann Sensoren in 3-Leitertechnik (ab Firmware 02 auch in 2-Leitertechnik) betreiben. Ein Mikroprozessor realisiert die Linearisierung über den gesamten Temperaturbereich, der frei wählbar ist.
Mit Hilfe der TwinSAFE-SC-Technologie (TwinSAFE Single Channel) ist es möglich, in beliebigen Netzwerken bzw. Feldbussen Standardsignale für sicherheitstechnische Aufgaben nutzbar zu machen. Die Standard-Funktionalitäten und Features der I/Os bleiben dabei erhalten. Die Daten der TwinSAFE-SC-I/Os werden zu der TwinSAFE-Logic geleitet und dort sicherheitstechnisch mehrkanalig verarbeitet. In der Safety-Logic werden die aus verschiedenen Quellen stammenden Daten analysiert, plausibilisiert und einem „Voting“ unterzogen. Dieses erfolgt durch zertifizierte Funktionsbausteine wie z. B. Scale, Compare/Voting (1oo2, 2oo3, 3oo5), Limit usw. Dabei muss aus Sicherheitsgründen mindestens eine der Datenquellen eine TwinSAFE-SC-Komponente sein. Die weiteren Daten können aus anderen Standard-Busklemmen, Antriebsreglern oder Messumformern stammen.
Mit Hilfe der TwinSAFE-SC-Technologie ist ein Sicherheitsniveau entsprechend PL d/Kat. 3 gem. EN ISO 13849-1 bzw. SIL 2 gem. EN 62061 typischerweise erreichbar.
Quick-Links
• EtherCAT Funktionsgrundlagen
• Technologie EL32xx
• Konfigurationserstellung TwinCAT
• CoE-Objektbeschreibung und Parametrierung
• Statuswort
• Prozessdaten und Betriebsmodi


Technologie RTD-Messung

Produktübersicht [image] Technologie RTD-Messung
Technologie RTD-Messung
Inhaltsverzeichnis
• Funktion
- Hinweis zur Serie EL320x-0010/-0020 (hochpräzise)
• Ratiometrische Spannungsmessung
• Anschlusstechniken
- Beispiel für Leitungskompensation im 2-Leiter-Modus
• Übersicht geeigneter Widerstandssensoren
Funktion
Die analoge Eingangsklemmen EL32xx-xxxx erlauben den direkten Anschluss von Widerstandssensoren im Bereich 0 - 4096 Ohm (EL3204-0200: bis 240 kOhm, siehe besondere Hinweise)
Funktionen:
▪
Widerstandsmessung
–
Messbereich 0 bis 1024 Ω: Auflösung 1/64 Ohm
–
Messbereich 0 bis 4096 Ω: Auflösung 1/16 Ohm
–
Der Einsatz der Klemme im Bereich 0 bis 10 Ohm wird aufgrund der relativ geringen Messgenauigkeit nicht empfohlen. Für solche Messungen sind Widerstandsmessklemmen wie die EL3692 in 4-Leiter-Messung zu verwenden.
–
Bei der EL3201 und EL3202 ist die externe Brücke zwischen +R und +RL beim 3-Leiter-Modus einzusetzen
▪
Temperaturmessung
der ermittelte Sensorwiderstand wird vom internen µC über die gewünschte Linearisierungskennlinie direkt in eine Temperatur umgerechnet
–
Standardauflösung 1/10 °C (1 Digit = 0,1 °C) entsprechend einem theoretisch darstellbaren Temperaturbereich [-3276,7 ... 3276,8 °C]
Es ist der für den jeweiligen Sensor physikalisch vorgegebene Temperaturbereich zu beachten!
–
Es sind in der EL32xx-Serie diverse PTC-Sensor-Kennlinien über ihren kompletten Messbereich zur Auswahl implementiert: Pt/Ni xxxx, KTY xx
–
Skalierung und Präsentation können geändert werden
–
Falls ein Sensor verwendet werden soll, der nicht bereits in der EL320x implementiert ist, kann die EL3204-0200 verwendet werden
Durch die freie Programmierbarkeit kann die EL3204-0200 auf jede Sensorkennlinie im zulässigen Widerstandbereich eingestellt werden.
Weitere Hinweise:
▪
Die Widerstandermittlung erfolgt durch ratiometrische Spannungsmessung, siehe unten.
▪
Der Fehlerzustand "Drahtbruch" wird als Overrange detektiert, als Error an die Steuerung gemeldet und durch die ERROR-LED angezeigt.
▪
Der Fehlerzustand "Kurzschluss" wird als Underrange detektiert, wenn der Widerstand kleiner ist als der kleinste Widerstand des Messbereichs, so wie als Error an die Steuerung gemeldet und durch die ERROR-LED angezeigt.
▪
Ab Firmware 06 (EL3201, EL3202-xxxx, EL3204) sind Kennlinien für KT/KTY-Sensoren implementiert und über das CoE-Verzeichnis anwählbar.
▪
Die Ausgabe des Messwertes erfolgt im Auslieferungszustand in 1/10° C Schritten in Zweierkomplement-Darstellung (integer).
▪
Über CoE 0x80n0:02 sind andere Darstellungsarten anwählbar z.B. hohe Auflösung mit 1/100 °C
Bei Verwendung der hohen Auflösung ist durch das 2-Byte-PDO ein Temperaturbereich von -320 ... 320°C (-32566 .... 32567) messbar.
Darstellung der Messung und Berechnung Widerstand/Temperatur
Hinweis zur Serie EL320x-0010/-0020 (hochpräzise)
Durch besondere Eigenschaften in Hardware und Firmware ist die EL320x-0010/0020 in der Lage, den Widerstandswert und damit ggf. die Temperatur hochgenau zu messen. Dabei ist zu beachten:
Erhöhte Genauigkeit EL320x-00x0
Bei den hochpräzisen Klemmen soll die Einstellungen im Objekt 0x80n0 / RTD-Settings nicht verändert werden! Die hochgenaue Widerstandermittlung/Temperaturmessung kann nur im Bereich 10 ... 220 Ohm erfolgen, dies entspricht einem Pt100-Messbereich von -200 ... 320°C.

Um die hohe Genauigkeit darstellen zu können, ist die 0,01°C/Digit Darstellung voreingestellt. Die erhöhte Genauigkeit der EL320x-00x0 gilt deshalb nur für folgende Einstellungen:

• Widerstandsmessung oder Pt100-Kennlinie (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) - andere Kennlinie ohne Gewähr!
• Umgebungstemperatur von 40°C
• 4-Leiter-Anschlusstechnik
• Messbereich -200 bis 320°C
• 50 Hz Filter

Temperaturen bzw. Widerstände außerhalb des o.g. Bereichs können nicht hochgenau gemessen werden. Werden diese Eckwerte verlassen, verhält sich die hochgenaue Klemme wie eine Klemme mit Standard-Genauigkeit.
Ratiometrische Spannungsmessung
Die Widerstandsermittlung der EL32xx-xxxx erfolgt ratiometrisch durch Spannungsvergleich, siehe Abb. „Anschlusstechnik 4-Leiter und 3-Leiter“:
▪
Eine Konstantspannung von 2,5 V wird durch einen hochgenauen bekannten Referenzwiderstand Rref und den Sensor Rt geführt
–
EL3204-0200: 120 kOhm Referenzwiderstand
–
alle anderen EL32xx: 5 kOhm Referenzwiderstand
▪
Durch Vergleich der beiden Spannungen, U1 an Referenz und U2 am Sensor kann auf den Sensorwiderstand geschlossen werden
▪
Der Messstrom durch den Sensor ist damit abhängig vom Sensorwiderstand, dies ist bei Fragen zur Sensoreigenerwärmung zu berücksichtigen
Beispiel: ein Pt1000 bewirkt bei 0°C und damit 1000 Ohm Eigenwiderstand an einer EL3204 einen Messstrom von 0,1 mA.
Beschaltung der Eingangskanäle
Auf Grund dieses Messprinzips (widerstandsbehafteter Temperatursensor) darf keine Parallelschaltung von einem Sensor an 2 oder mehr Eingangskanäle erfolgen!
Anschlusstechniken
Die elektrische Verbindung eines Widerstandssensors zur EL32xx kann im Zweileiter-, Dreileiter- oder Vierleiterverfahren (nur EL3201) erfolgen. Da das Messverfahren eine Widerstandsmessung ist, können die Sensorzuleitungen mit ihrem Eigenwiderstand die Messung verfälschen. Zu diesem Zweck sind verfügbar:
Anschlusstechnik 4-Leiter und 3-Leiter
▪
4-Leiter-Sensoren: Stromführung und Spannungsmessung laufen über separate Adern. Da die Spannung von der EL32xx hochohmig gemessen wird, unterliegen die Adern zur Spannungsmessung somit annähernd keinem Spannungsabfall.
▪
3-Leiter-Sensoren: diese vereinfachte Anschaltung reduziert Verkabelungskosten und kompensiert Leitungswiderstände in hohem Maße.
▪
2-Leiter-Sensoren: sehr einfache Anschaltung, nur für kurze Zuleitung empfohlen
Die Zuleitungswiderstände können im 2-Leiter-Modus herausgerechnet werden, wenn der EL32xx im CoE-Objekt 0x80n0:1B der Zuleitungswiderstand bekannt gegeben wird (Einheit [1/32 Ω]). Die Ermittlung des Zuleitungswiderstands kann applikationsseitig durch Messung oder durch Abgleich geschehen.
Zweileiter Anschluss
Wird die EL3201/EL3202 im 2-Leiter-Anschluss betrieben, müssen der Eingang +R und +RL vom Anwender gebrückt werden.
Beispiel für Leitungskompensation im 2-Leiter-Modus
Beispiel für Leitungskompensation im 2-Leiter-Modus Der Leitungsquerschnitt der 50 m langen Anschlussleitung aus Kupferlitze sei 0,5 mm2. Der spezifische Widerstand von Kupfer entspricht 0,0175 Ω mm2 m-1.
Ermittlung des Gesamtwiderstandes der Zuleitung:
RLges= 0,0175 Ω mm2m-1* (2 * 50 m / 0,5 mm2) = 3,5 Ω
Bei einer Widerstandsänderung des Pt100 von ≈0,39 Ω/K ergibt sich daraus eine Temperaturabweichung von
3,5 Ω / (0,39 Ω/°C) = 8,97 °C
wenn der Leitungswiderstand nicht berücksichtigt wird. Wenn nun die 3,5 Ohm als
3,5 Ω / (1/32) Ω = 112dez
in 0x8000:1B eingetragen werden, wird dies vom Messwert abgezogen, und die Temperatur entsprechend korrigiert.
Steckervariante ES32xx mit Pt100 / Ni100 Sensoren
Bei der Verwendung von Pt100 / Ni100 Sensoren empfehlen wir zur Vermeidung von Genauigkeitsverlusten auf Grund von Übergangswiderständen bei der Steckervariante ES32xx den Einsatz der EL32xx .
Übersicht geeigneter Widerstandssensoren
Übersicht geeigneter Widerstandssensoren Folgende Widerstandssensoren sind für die Temperaturmessung mit der EL32xx-0000 geeignet (Tab. 1) und können über das Objekt 0x80n0:19 gewählt werden:
Besondere oder abweichende Kennlinien (z. B. Pt375) können mit der frei parametrierbaren EL3204-0200 erfasst werden.
Typ | Widerstandsbereich | Implementierter Temperaturbereich
Pt100 (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) | ~ 18 ... ~390 Ohm | -200°C bis 850°C (für hochpräzise Klemmen siehe Hinweis!
Ni100 |  | -60°C bis 250°C
Pt1000 (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) | ~180 ... ~ 3900 Ohm | -200°C bis 850°C
Pt500 |  | -200°C bis 850°C
Pt200 |  | -200°C bis 1370°C
Ni1000 |  | -60°C bis 250°C
Ni1000 TK5000 100°C: 1500 Ohm |  | -30 bis 160°C
Ni120 |  | -60°C bis 320°C
KT100/110/130/210/230 KTY10/11/13/16/19 | ~500 ... ~2200 Ohm | -55...150°C
KTY81/82-110,120,150
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 | ~500 ... ~2500 Ohm | -50...175°C
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 | ~350 ... ~2500 Ohm | -40...300°C
KTY84-151
KTY21/23-6 | ~500 ... ~4000 Ohm | -50...150°C
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7


Grundlagen der RTD-Technologie

Produktübersicht [image] Grundlagen der RTD-Technologie
Grundlagen der RTD-Technologie
Bestimmte Werkstoffe verändern ihren elektrischen Widerstand wenn sich die Temperatur des Werkstoffes ändert. Durch diese Eigenschaft können sie als Sensor zur Temperaturmessung verwendet werden. Solch ein RTD-Element (Resistance Temperature Device) oder Thermistor weist dann eine materialabhängige bekannte Charakteristik auf, nämlich wie sich der Widerstand in Abhängigkeit von der Temperatur ändert, die sog. Kennlinie. In erster Näherung kann diese Kennlinie als lineare Gleichung aufgefasst werden:
Der Faktor k kann positiv oder negativ sein und muss vom Sensorhersteller angegeben werden:
▪
positiver Koeffizient (PTC): Widerstand steigt mit steigender Temperatur, wird also schlechter leitend, Sensor wird dann als Kaltleiter bezeichnet
▪
negativer Koeffizient (NTC): Widerstand steigt mit fallender Temperatur, wird also besser leitend, Sensor wird dann als Heißleiter bezeichnet
Je größer der Koeffizient, desto empfindlicher ist der Sensor.
Temperaturmessung
Diese Art der Temperaturmessung ist abzugrenzen von den Thermoelementsensoren: diese erzeugen von sich aus eine (kleine) Spannung über den Leiter, die an den Kontaktstellen gemessen wird.
In einem sehr kleinen Messbereich können fast alle Materialien durch solch eine lineare Kennlinie beschrieben werden. Oft soll jedoch über einen großen Messbereich z. B. mehrere 10 oder 100 K gemessen werden. In solchen Bereichen muss die Kennlinie bei vielen Materialien durch nichtlineare Gleichungen höherer Ordnung oder mit exponentiellen Komponenten beschrieben werden. Beispiele für solche Gleichungen sind
▪
Platin/Pt-Sensoren (PTC/Kaltleiter) nach IEC 60751:
–
für den Bereich -200.. 0 °C:
–
für den Bereich 0°C..850°C:
Die Koeffizienten A, B, C sind vom Sensorhersteller anzugeben bzw. der Norm zu entnehmen. Der Parameter R0 gibt den Widerstand in Ohm des Platinsensors bei T=0 °C an. Die Sensoren werden nach diesen Bezeichnungen qualifiziert, so spricht man vom PT100, wenn R0=100 Ω bei T=0 °C beträgt.
▪
Steinhart-Hart (für NTC/Heißleiter)
Die Koeffizienten a, b, c sind vom Sensorhersteller anzugeben, diese können auch durch Messung des Widerstandes bei drei bekannten Temperaturen bestimmt werden.
▪
B-Parameter-Gleichung (für NTC/Heißleiter)
Die Koeffizienten RT0, B, T0 sind vom Sensorhersteller anzugeben, diese können auch durch Messung des Widerstandes bei zwei bekannten Temperaturen bestimmt werden.
Die B-Parameter-Gleichung stellt eine Vereinfachung der Steinhart-Hart-Gleichung dar. Der B-Parameter selber ist nur in einem kleinen Bereich konstant, z.B. zwischen 25°C.. 50°C oder 25°C.. 85°C dieser wird wie folgt Bezeichnet: B25/50 bzw. B25/85. Die Genauigkeit der Gleichung hängt stark von dem B-Parameter ab, je größer der Messbereich, desto geringer die Genauigkeit. Wird ein größerer Messbereich benötigt, so ist die Steinhart-Hart-Gleichung vorzuziehen.
▪
und weitere
Jeweils eine typ. Kennlinie für die NTC- und PTC-Familien ist in folgender Abbildung gezeigt:
Beispiele für Temperatur-Abhängige Widerstandswerte
Es gibt also nicht den allgemeinen NTC- oder PTC-Sensor, sondern dies sind Bezeichnungen für Sensor-Familien mit einem bestimmten Verhalten.
Für weit verbreitete Sensoren/Kennlinien wie PT100, werden diese Kennlinien bereits fest in die Messgeräte implementiert. Es ist anwenderseitig zu prüfen, ob ein vorgesehener Sensor vom Messgerät unterstützt wird, dabei gelten die Kriterien
▪
Temperaturbereich: unterstützt der Sensor den vorgesehenen Temperaturbereich?
▪
Messbereich: kann der Sensor-Widerstand im beabsichtigten Temperaturbereich gemessen werden?
▪
Kennlinie: kann der gemessene Widerstand entsprechend in Temperatur umgerechnet werden? (Basispunkt, Steigung/Koeffizienten)
▪
Geschwindigkeit: wie oft wird der Widerstand gemessen?
In ganz grundsätzlicher Art kann ein Sensorhersteller die Kennlinie seines Sensors natürlich auch als Werte-Tabelle veröffentlichen.
Widerstandsmessung
Zur Ermittlung des Widerstands wird üblicherweise ein geringer Messstrom im mA-Bereich (< 5 mA) durch den Sensor geschickt und die resultierende Spannung gemessen. Dabei sind drei Effekte zu berücksichtigen:
● der Messstrom kann zu einer Eigenerwärmung des Sensors führen. Dies hat üblicherweise aber nur geringen Einfluss auf die Messgenauigkeit.
Für Tiefsttemperaturanwendungen sind spezielle Sensoren gebräuchlich.
● die Zuleitungen zum Sensor sind immer ebenfalls widerstandsbehaftet und bringen einen (meist) konstanten zusätzlichen Widerstand in die Messung ein. Kompensation kann erfolgen durch
● 3- oder 4-Leiter-Anschluss des Sensors
● manuelle Berücksichtigung des bekannten Leitungswiderstands in der Berechnung
● Sensor mit höherem Nennwiderstand verwenden - dann fallen die Zuleitungseffekte weniger ins Gewicht
● Isolationsfehler oder Thermospannungen können die Messung beeinflussen.
Zur Einordnung im Folgenden eine Übersicht der NTC/PTC-Eigenschaften verschiedener Sensoren:
NTC und PTC Eigenschaften
NTC | PTC
viele Halbleiter | viele Metalle
versch. Keramiken | versch. Keramiken
NTC20, NTC100 etc. | Pt100, Pt1000, ..
 | KTY ..
 | Ni100, Ni1000, ..
 | FeT
Sensortausch
Es ist zu beachten, dass eine 1:1 Austauschbarkeit gerade von herstellerspezifizierten Sensoren nicht immer gewährleistet ist. Ggf. muss der neue Sensor in der Anlage neu eingemessen werden.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
EL3201 - Technische Daten
Technische Daten | EL3201 | EL3201-0010 | EL3201-0020
Anzahl Eingänge | 1
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY ab Firmware 06 Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss )
Anschlusstechnik | 2-, 3-, 4-Leiter | 4-Leiter
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) Hochpräzise Messung nur für Pt100 Sensoren, Messbereich -200…+320°C, siehe Hinweis!
Auflösung (default) | 0,1°C pro Digit | 0,01°C pro Digit
Wandlungszeit | ca. 4 .. 500 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 24 ms voreingestellt
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA
Messfehler | bei Pt-Sensoren: < ±0,5 °C bei Umgebungstemperatur 0°C ... +55°C < ±1,5 °C im erweiterten Temperaturbereich | bei Pt100-Sensoren, 4-Leiter-Anschlusstechnik, Messbereich -200 bis 320°C, 50 Hz Filter: < ±0,1 °C bei Umgebungstemperatur von 40°C < ±0,3 °C im Betriebs-Temperaturbereich Hinweis: andere Sensorfälle lt. CoE bei verminderter Genauigkeit nutzbar (z.B. PT1000, 3-Leiter-Anschluss usw.)
Breite im Prozessabbild | max. 4 Byte Input
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 190 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) |  | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C |  | -25°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus |  | CE ATEX cULus
EL3202 - Technische Daten
Technische Daten | EL3202 | EL3202-0010, EL3202-0020
Anzahl Eingänge | 2 | 2
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY ab Firmware 06 Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss )
Anschlusstechnik | 2-, 3-Leiter (Voreinstellung: 3-Leiter) | 4-Leiter
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) | Bereichsabhängig: -200…+850°C (Pt-Sensoren) -60…+250°C (Ni-Sensoren) Hochpräzise Messung nur für Pt100 Sensoren, Messbereich -200…+320°C, siehe Hinweis!
Auflösung (default) | 0,1°C pro Digit | 0,01°C pro Digit
Wandlungszeit | ca. 800 ms .. 2 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 85 ms voreingestellt
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA
Messfehler | bei Pt-Sensoren: < ±0,5 °C bei Umgebungstemperatur 0°C ... +55°C < ±1,5 °C im erweiterten Temperaturbereich | bei Pt100-Sensoren, 4-Leiter-Anschlusstechnik, Messbereich -200 bis 320°C, 50 Hz Filter: < ±0,1 °C bei Umgebungstemperatur von 40°C < ±0,3 °C im Betriebs-Temperaturbereich Hinweis: andere Sensorfälle lt. CoE bei verminderter Genauigkeit nutzbar (z.B. PT1000, 3-Leiter-Anschluss usw.)
Breite im Prozessabbild | max. 8 Byte Input
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 190 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus
EL3204 - Technische Daten
Technische Daten | EL3204 | EL3204-0200
Anzahl Eingänge | 4 | 4
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY ab Firmware 06 Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss ) | beliebige RTD im Bereich 100 Ω…240 kΩ
Anschlusstechnik | 2-Leiter
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) | Bereichsabhängig
Auflösung (default) | 0,1°C pro Digit | default: 0,1°C pro Digit bei Temperaturmessung
Wandlungszeit | ca. 800 ms .. 2 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 85 ms voreingestellt | ca. 4 ms .. 500 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 24 ms voreingestellt
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA | typ. < 0,03 mA
Messfehler | < ±0,5 °C bei Pt-Sensoren < ±1,5 °C (erweiterter Temperaturbereich) | < ±0,3% vom Messbereichsendwert jeweiligen bei Widerstandsmessung
Breite im Prozessabbild | max. 16 Byte Input | max. 16 Byte Input
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 190 mA | typ. 150 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C | -25°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus | CE ATEX cULus
EL3208 - Technische Daten
Technische Daten | EL3208
Anzahl Eingänge | 8
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY, Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss )
Anschlusstechnik | 2-Leiter
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren)
Auflösung (default) | 0,1°C pro Digit
Wandlungszeit | ca. 3 ms .. 1600 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA
Messfehler | < ±0,5 °C bei Pt-Sensoren < ±1,5 °C (erweiterter Temperaturbereich)
Breite im Prozessabbild | max. 32 Byte Input
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 140 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus
EL3214 - Technische Daten
Technische Daten | EL3214
Anzahl Eingänge | 4
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY, Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss )
Anschlusstechnik | 3-Leiter
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren)
Auflösung (default) | 0,1°C pro Digit
Wandlungszeit | ca. 5 ms .. 1600 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA
Messfehler | < ±0,5 °C bei Pt-Sensoren, 4 x 3-Leiteranschluss < ±1,5 °C (erweiterter Temperaturbereich)
Breite im Prozessabbild | max. 16 Byte Input
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 140 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus
EL3214-0090 - Technische Daten
Technische Daten | EL3214-0090
Anzahl Eingänge | 4
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY, Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss )
Anschlusstechnik | 2-Leiter (ab Firmware 02), 3-Leiter
Grenzfrequenz Eingangsfilter | 1 kHz typ.
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren)
Auflösung (default) | 0,1°C pro Digit
Wandlungszeit | ca. 170 ms (voreingestellt)
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA
Messfehler | < ±0,5 °C bei Pt-Sensoren, 4 x 3-Leiteranschluss < ±1,5 °C (erweiterter Temperaturbereich)
MTBF (55°C) | >890.000 h
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 140 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus


Hinweis zum Werkskalibrierzertifikat

Produktübersicht [image] Hinweis zum Werkskalibrierzertifikat
Hinweis zum Werkskalibrierzertifikat
Grundsätzlich wird jedes Beckhoff Analog-Gerät (Eingang oder Ausgang) justiert, d.h. in der Produktion einem Abgleich unterzogen. Allerdings wird dieser Vorgang nicht einzeln dokumentiert, diese Dokumentation erfolgt nur im Rahmen der Werkskalibrierzertifikats bei den entsprechenden „-0020“ Ausführungen. Ob für ein analoges Beckhoff-Gerät ein Werkskalibrierzertifikat verfügbar/ausstellbar ist, kann beim Beckhoff Service angefragt werden oder ist der aktuellen Preisliste zu entnehmen (Version „-0020“ ist vorhanden für z.B. EL3202 bedeutet den Typ EL3202-0020).
Das Werkskalibrierzertifikat (auch: Werkskalibrierschein) benennt die nach der Justage/Abgleich verbleibende Restabweichung zum verwendeten Beckhoff Werksnormal. Das Werkskalibrierzertifikat (in pdf-Form) ist über die ID-Nummer der Klemme eindeutig zuzuordnen. Es steht über die Beckhoff Website zum Download bereit.
Seiner Natur nach dokumentiert es die Messgenauigkeit zum Zeitpunkt der Zertifikatserstellung, das Werkskalibrierzertifikat enthält keine Aussage über das Verhalten bzw. die Veränderung der Messgenauigkeit in der Zukunft. Ein Kalibrierzertifikat dient der Rückbetrachtung auf den vorangegangenen Verwendungszeitraum. Wird der Zertifikatsvorgang über Jahre mehrmals wiederholt (ohne das Gerät neu zu justieren) erlaubt er Rückschlüsse auf das Alterungsverhalten, die sog. Kalibrierhistorie.
Ein Gerät mit Werkskalibrierzertifikat kann in der Applikation eingesetzt werden, wenn die Rahmenbedingungen/Anforderungen dies erlauben. Wenn ein nationales Zertifikat (in Deutschland: DAkkS, Deutsche Akkreditierungsstelle GmbH) gefordert wird, können entsprechende Dienstleister auf jedem Beckhoff Produkt eine DAkkS-Kalibrierung in Ihren Laboren durchführen. Beckhoff Automation GmbH & Co. KG kann derzeit (2016) noch keine DAkkS-Kalibrierung durchführen.
Hinweis zum Sprachgebrauch
Im US-amerikanischen Sprachumfeld wird mit „Calibration“ oder „Alignment“ der Abgleich/die Justage bezeichnet, also das verändernde Einwirken auf das Gerät. „Verification“ ist dagegen das beobachtende Ermitteln und Dokumentieren des verbliebenden Restfehlers, das im deutschen Sprachgebrauch als Kalibrierung bezeichnet wird.


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL32xx wie im Kapitel Installation beschrieben
▪
konfigurieren Sie den EL32xx in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Installation

Installation
Installation
Weiterführende Informationen
•
Sicherheitshinweise
•
Umgebungsbedingungen
•
Transportvorgaben / Lagerung
•
Schaltschrank / Klemmenkasten
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Positionierung von passiven Klemmen
•
Einbaulagen
•
Anschluss
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation
•
UL-Hinweise
•
LEDs und Anschlussbelegung
•
Anschluss analoger RTD-Signalleitungen


Sicherheitshinweise

Installation [image] Sicherheitshinweise
Sicherheitshinweise
Lesen Sie vor Installation und Inbetriebnahme der TwinSAFE-Komponenten auch die Sicherheitshinweise im Vorwort dieser Dokumentation.


Umgebungsbedingungen

Installation [image] Umgebungsbedingungen
Umgebungsbedingungen
Stellen Sie sicher, dass die TwinSAFE-Komponenten nur bei den spezifizierten Umgebungsbedingungen (siehe technische Daten) transportiert, gelagert und betrieben werden!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Die TwinSAFE-Komponenten dürfen unter folgenden Betriebsbedingungen nicht eingesetzt werden.
•
unter dem Einfluss ionisierender Strahlung (die das Maß der natürlichen Umgebungsstrahlung überschreitet)
•
in korrosivem Umfeld
•
in einem Umfeld, das zu unzulässiger Verschmutzung der TwinSAFE-Komponente führt
Hinweis
Elektromagnetische Verträglichkeit
Die TwinSAFE-Komponenten entsprechen den Anforderungen der geltenden Normen zur elektromagnetischen Verträglichkeit in Bezug auf Störausstrahlung und insbesondere auf Störfestigkeit.
Sollten jedoch in der Nähe der TwinSAFE-Komponenten Geräte (z.B. Funktelefone, Funkgeräte, Sendeanlagen oder Hochfrequenz-Systeme) betrieben werden, welche die in den Normen festgelegten Grenzen zur Störaussendung überschreiten, können diese ggf. die Funktion der TwinSAFE-Komponenten stören.


Transportvorgaben / Lagerung

Installation [image] Transportvorgaben / Lagerung
Transportvorgaben / Lagerung
Verwenden Sie zum Transport und bei der Lagerung der TwinSAFE-Komponenten die Originalverpackung in der die Komponenten geliefert wurden.
SmallWarningYellow VORSICHT
Spezifizierten Umgebungsbedingungen beachten
Stellen Sie sicher, dass die digitalen TwinSAFE- Komponenten nur bei den spezifizierten Umgebungsbedingungen (siehe technische Daten) transportiert und gelagert werden.


Schaltschrank / Klemmenkasten

Installation [image] Schaltschrank / Klemmenkasten
Schaltschrank / Klemmenkasten
Die TwinSAFE-Klemmen müssen zum Betrieb in einen Schaltschrank oder Klemmenkasten montiert werden, der mindestens der Schutzart IP54 nach IEC 60529 entspricht.


Hinweise zum ESD-Schutz

Installation [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Installation [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Installation [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Positionierung von passiven Klemmen

Installation [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


Einbaulagen

Installation [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Anschluss

Installation [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Installation [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Installation [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Installation [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Installation [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Installation [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … +60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … +60°C


ATEX-Dokumentation

Installation [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


UL-Hinweise

Installation [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


LEDs und Anschlussbelegung

Installation [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
EL3201, EL3202
Anschlussbelegung EL3201
Anschlussbelegung EL3202
Zweileiter-Anschluss EL3201/EL3202
Wird die EL3201/EL3202 im 2-Leiter-Anschluss betrieben, müssen die Eingänge +R und +RL vom Anwender gebrückt werden.
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1, ERROR2** | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie
** nur EL3202
Anschlussbelegung EL3201
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
-RL1 | 4 | Eingang -RL1
... | 5 | nicht belegt
... | 6 | nicht belegt
... | 7 | nicht belegt
Shield | 8 | Schirm
Anschlussbelegung EL3202
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
Shield | 4 | Schirm (intern verbunden mit Klemmstelle 8)
+R2 | 5 | Eingang +R2
+RL2 | 6 | Eingang +RL2
-R2 | 7 | Eingang -R2
Shield | 8 | Schirm (intern verbunden mit Klemmstelle 4)
EL3201-00x0, EL3202-00x0
Anschlussbelegung EL3201-00x0
Anschlussbelegung EL3202-00x0
Vierleiter-Anschluss
Die hochpräzisen Klemmen EL320x-00x0 dürfen bestimmungsgemäß nur in 4-Leiter Anschlusstechnik betrieben werden!
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1, ERROR2** | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie
** nur EL3202-00x0
Anschlussbelegung EL3201-00x0
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
-RL1 | 4 | Eingang -RL1
... | 5 | nicht belegt
... | 6 | nicht belegt
... | 7 | nicht belegt
Shield | 8 | Schirm
Anschlussbelegung EL3202-00x0
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
-RL1 | 4 | Eingang -RL1
+R2 | 5 | Eingang +R2
+RL2 | 6 | Eingang +RL2
-R2 | 7 | Eingang -R2
-RL2 | 8 | Eingang -RL2
EL3204-0x00
Anschlussbelegung EL3204-0x00
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1 - 4 | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie.
Anschlussbelegung EL3204-0x00
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
-R1 | 2 | Eingang -R1
+R3 | 3 | Eingang +R3
-R3 | 4 | Eingang -R3
+R2 | 5 | Eingang +R2
-R2 | 6 | Eingang -R2
+R4 | 7 | Eingang +R4
-R4 | 8 | Eingang -R4
EL3214-00x0
EL3214 Anschlussbelegung
EL3214-0090 Anschlussbelegung
Zweileiter-Anschluss EL3214-00x0
Wird die EL3214 im 2-Leiter-Anschluss betrieben, müssen die Eingänge +R und +RL vom Anwender gebrückt werden.
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1 - 4 | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie.
Anschlussbelegung EL3214-00x0
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
RL1 | 2 | Eingang RL1
+R2 | 3 | Eingang +R2
RL2 | 4 | Eingang RL2
+R3 | 5 | Eingang +R3
RL3 | 6 | Eingang RL3
+R4 | 7 | Eingang +R4
RL4 | 8 | Eingang RL4
-R1 | 9 | Eingang -R1
… | 10 | nicht belegt
-R2 | 11 | Eingang -R2
… | 12 | nicht belegt
-R3 | 13 | Eingang -R3
… | 14 | nicht belegt
-R4 | 15 | Eingang -R4
… | 16 | nicht belegt
EL3208
Anschlussbelegung EL3208
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1 - 8 | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie.
Anschlussbelegung EL3208
Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+R2 | 2 | Eingang +R2
+R3 | 3 | Eingang +R3
+R4 | 4 | Eingang +R4
+R5 | 5 | Eingang +R5
+R6 | 6 | Eingang +R6
+R7 | 7 | Eingang +R7
+R8 | 8 | Eingang +R8
-R1 | 9 | Eingang -R1
-R2 | 10 | Eingang -R2
-R3 | 11 | Eingang -R3
-R4 | 12 | Eingang -R4
-R5 | 13 | Eingang -R5
-R6 | 14 | Eingang -R6
-R7 | 15 | Eingang -R7
-R8 | 16 | Eingang -R8


Anschluss analoger RTD-Signalleitungen

Installation [image] Anschluss analoger RTD-Signalleitungen
Anschluss analoger RTD-Signalleitungen
Die RTD-Eingangsklemmen der Serie EL32xx messen den analogen Widerstand des Sensors. Der Spannungsabfall am Sensor (je nach Anschlusstechnik inkl. der Zuleitungswiderstände) ist äquivalent zum Sensorwiderstand und damit bei bekannter Sensorkennlinie ein Maß für die Temperatur des Sensors. Damit die analogen Signale möglichst störungsfrei gemessen werden, wird im Folgenden eine Vorgehensweise zum Anschluss der analogen Signalleitungen vorgestellt.
Maßnahmen
▪
zu verwendendes Sensorkabel
–
eng verdrillt
–
geschirmtes Kupfergeflecht
–
niederohmige Leitung verwenden, insbesondere im 2-Leiter-Anschluss
▪
Sensor und Sensorleitungen potenzialfrei von Fremdspannungen halten.
Die GND-Anschlüsse (3/7 bei EL3201, EL3202) sind keinesfalls mit anderen Potenzialen zu verbinden.
▪
Die Auswahl der Widerstandsgrößenordnung des RTD-Sensors (z.B. 100 oder 1000 Ω Nennwiderstand) sollte im Hinblick auf das Verhältnis von Sensor- zu Leitungswiderstand unter Beachtung der Anschlusstechnik (2/3/4-Leiter) erfolgen.
Maßnahmen Schirmung
Schirmung Maßnahmen
Aufgrund der Komplexität im Bereich "EMV" gibt es keine allgemeingültige Handlungsrichtlinie, sondern nur technische Maßnahmen nach dem Stand der Technik, die sich mitunter auch widersprechen können. Diese sind auf Umsetzbarkeit und Wirksamkeit unter Berücksichtigung der Anlagenspezifika und nach Beurteilung durch den Anlagenerrichter anzuwenden.
Die folgenden Hinweise zur Schirmung sind als technische Vorschläge zu verstehen, die sich im praktischen Einsatz mitunter bewährt haben. Es ist in jedem Fall je nach Installation und Anlage zu prüfen, welche Maßnahmen angewendet werden können. Die Wirksamkeit ist für jede Maßnahme einzeln zu prüfen. Eine formale Übertragbarkeit von Maßnahmen auf Anlagen anderen Typs ist im Allgemeinen nicht gegeben.
Landestypische oder allgemein normative Vorgaben sind vorrangig zu beachten.
Im Folgenden ist ein Schirmungsansatz beschrieben, der in vielen Fällen eine Verbesserung der Messqualität bringt. Die Maßnahmenvorschläge sind in der tatsächlichen Anlage auf Umsetzbarkeit und Wirksamkeit zu prüfen.
▪
Schirm niederohmig und 360°-leitungsumfassend auflegen
▪
den Schirm beim Eintritt in den Schaltschrank leitend erden
▪
Schirm an der Klemme erneut erden
–
am Klemmen-Anschlusspunkt, wenn vorhanden
–
wenn kein Klemmen-Anschlusspunkt vorhanden, möglichst nahe bei der Klemme der Schirm erden.
–
zur Vermeidung von Erdschleifen kann der Schirm nach dem Schaltschrankeintritt aufgetrennt werden.
Eine kapazitive Anbindung an den Klemmen-Schirmkontakt ist möglich.
–
ungeschirmte Leitungsstrecke von > 50 cm vermeiden!
Beispielhafte Schirmanbindung bei EL3202-0000 mit Schirmkontakt, bei potenziellen Störquellen innerhalb des Schaltschranks
Beispielhafte Schirmanbindung bei EL3202-0000 mit Schirmkontakt, bei potenziellen Störquellen innerhalb und außerhalb des Schaltschranks


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Einstellungen und Anwendungshinweise zur EL32xx-0010/0020
•
Einstellungen und Anwendungshinweise zur EL3204-0200
•
Prozessdaten und Betriebsmodi
•
TwinSAFE SC
•
TwinSAFE SC Prozessdaten EL3214-0090
•
CoE Objektverzeichnis EL32xx-00xx
•
CoE Objektverzeichnis EL3204-0200
•
Status-Wort
•
Hinweise zu analogen Spezifikationen


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Einstellungen und Anwendungshinweise zur EL32xx-0010/0020

Inbetriebnahme [image] Einstellungen und Anwendungshinweise zur EL32xx-0010/0020
Einstellungen und Anwendungshinweise zur EL32xx-0010/0020
Default-Einstellung
Die EL32xx-0000 kann zur direkten Temperatur- oder Widerstandsmessung eingesetzt werden. Die Version -0010/-0020 misst mit erhöhter Genauigkeit. Dazu sind entsprechende CoE-Einstellungen vorzunehmen, siehe nachfolgende Tabelle.
Zur Einordnung sei hier der Zusammenhang zwischen der Temperatur und dem Widerstand eines Pt100/Pt1000-Sensors angegeben:
Temperatur | typ. Widerstand, ca.
850°C | Pt1000: 3.9 kΩ Pt100: 390 Ω
320°C | Pt1000: 2.2 kΩ Pt100: 220 Ω
-200°C | Pt1000: 180 Ω Pt100: 18 Ω
Sensortypische Kennlinien können von den Sensorherstellern bezogen werden.
Weiterführende Hinweise erhalten Sie in den Kapiteln Objektbeschreibung und Parametrierung und Prozessdaten und Betriebsmodi
Hinweis zur Serie EL320x-0010/-0020 (hochpräzise)
Durch besondere Eigenschaften in Hardware und Firmware ist die EL320x-0010/0020 in der Lage, den Widerstandswert und damit ggf. die Temperatur hochgenau zu messen. Dabei ist zu beachten:
Erhöhte Genauigkeit EL320x-0010/0020
Bei den hochpräzisen Klemmen soll die Einstellungen im Objekt 0x80n0 / RTD-Settings nicht verändert werden! Die hochgenaue Widerstandermittlung/Temperaturmessung kann nur im Bereich 10 ... 220 Ohm erfolgen, dies entspricht einem Pt100-Messbereich von -200 ... 320°C.

Um die hohe Genauigkeit darstellen zu können, ist die 0,01°C/Digit Darstellung voreingestellt. Die erhöhte Genauigkeit der EL320x-00x0 gilt deshalb nur für folgende Einstellungen:

• Widerstandsmessung oder Pt100-Kennlinie (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) - andere Kennlinie ohne Gewähr!
• Umgebungstemperatur von 40°C
• 4-Leiter-Anschlusstechnik
• Messbereich -200 bis 320°C
• 50 Hz Filter

Temperaturen bzw. Widerstände außerhalb des o.g. Bereichs können nicht hochgenau gemessen werden. Werden diese Eckwerte verlassen, verhält sich die hochgenaue Klemme wie eine Klemme mit Standard-Genauigkeit.

Um sicherzustellen, daß die Messungen auch langfristig mit der gewünschten erhöhten Genauigkeit durchgeführt werden, wird eine regelmäßige Überprüfung der Messgenauigkeit empfohlen, z.B. jährlich. So können Alterungseffekte oder Umgebungseinflüsse durch einen Neuabgleich (User calibration) ggf. kompensiert werden.
EL32xx-0000
EL320x-0010/-0020
Default/Werkseinstellung
▪
2-Leiter-Anschluss
▪
Pt100 (CoE 0x80n0:19)
▪
Presentation signed (CoE 0x80n0:02)
▪
Limits disabled
▪
50 Hz Filter enabled
▪
alle Kanäle enabled
▪
für EL3214:
▪
3-Leiter-Anschluss
▪
Pt100
(CoE 0x80n0:19)
▪
Presentation signed
(CoE 0x80n0:02)
▪
50 Hz Filter enabled
▪
alle Kanäle enabled
▪
4-Leiter-Anschluss (CoE 0x80n0:1A)
Eine automatische Anschlussarterkennung erfolgt nicht.
▪
Pt100 (CoE 0x80n0:19)
Es erfolgt eine Messung im reduzierten Messbereich von -200..320°C bzw. im äquivalenten Widerstandbereich.
–
Die Beschriftung der Typ-Einstellung „Pt100 (-200..850°C)“ steht für den üblichen Messbereich eines Pt100-Elements
▪
Presentation HighResolution (CoE 0x80n0:02)
Die Temperatur wird mit 1/100°C je Digit vorzeichenbehaftet dargestellt.
▪
Limits disabled
▪
50 Hz Filter enabled
▪
alle Kanäle enabled
Einsatzbereich
Die Klemme wird im Messbereich "1/16 Ω" (10 Ω .. 4 kΩ) abgeglichen und kann in diesem Widerstandsbereich eingesetzt werden.
Die hochgenaue Version wird im Messbereich "1/64 Ω" (10 Ω…1 kΩ) und über einen Messbereich von 18…220 Ω abgeglichen und ist ausschließlich in diesem Bereich oder zur Pt100-Messung einzusetzen.
In anderen Messbereichen bietet sie die Standardgenauigkeit von <±0.5°C.
Hinweis zur Betriebsart "Widerstandsmessung"
In der Betriebsart "Widerstandsmessung" wird der Messwert unabhängig von der Einstellung "Presentation" (Objekt 0x80n0:02) immer unsigned (vorzeichenlos) 0..xFFFF mit entsprechender Wertigkeit dargestellt.
1/16 Ω -> ~62 mΩ/Digit
1/64 Ω -> ~15 mΩ/Digit
Veränderung der Slave-Parameter im CoE-Verzeichnis
Bei der Inbetriebnahme müssen ggf. die CoE-Parameter verändert werden.
▪
Beim Online-Zugriff auf die Klemme wird das CoE-Verzeichnis aus dem Slave gelesen und kann verändert werden, s. Abb. „Zugriff auf die CoE-Parameter im TwinCAT SystemManager“.
▪
Beim Offline-Zugriff auf die (dann nicht ansprechbare) Klemme werden die Daten aus der XML-Beschreibung benutzt. Die Parameter können nicht verändert werden.
Im Reiter "CoE-Online" des EtherCAT-Slave können die CoE-Parameter (CAN over EtherCAT) verändert werden.
Zugriff auf die CoE-Parameter im TwinCAT SystemManager , EL3201
Hinweis
Veränderungen im CoE-Verzeichnis, Austauschfall
Damit auch im Austauschfall eines EtherCAT-Slaves bei dem neu eingesetzten Slave die CoE-Parameter richtig gesetzt werden, sind kundenseitige Veränderungen in der StartUp-Liste einzutragen.
Veränderungen im CoE-Verzeichnis, Programmzugriff
Die CoE-Parameter können auch im Betrieb (soweit sinnvoll) durch die PLC mit entsprechenden Steuerungsbefehlen gelesen und geschrieben werden. Siehe dazu die entsprechenden Einträge z. B. im Beckhoff Information System.
Für detaillierte Informationen zu Einstellungen und Betriebsmodi lesen Sie bitte das Kapitel "Prozessdaten und Betriebsmodi".
Weitere Anwendungshinweise
Einstellung "Filter enable"
Die Filterfunktion ist immer aktiv, auch wenn das Objekt 0x8000:06 "Filter enable" = FALSE gesetzt wird.
Einstellung "Connection Technology"
Außer 2-, 3- und 4-Leiteranschluss** kann hier auch kanalweise "not connected" gewählt werden. Der betreffende Kanal wird vollständig deaktiviert, die Wandlungszeit der EL32xx verkürzt sich entsprechend.

**) 4-wire nicht gültig für EL3214
Einstellung „not connected“
Durch einen Doppelklick auf das entsprechende Objekt 0x80n0:1A können die entsprechenden Kanäle im Set Value Dialog abgeschaltet werden, indem der "Enum"-Wert "not connected" gewählt wird, siehe Abb. „Einstellung ‚not connected‘"


Einstellungen und Anwendungshinweise zur EL3204-0200

Inbetriebnahme [image] Einstellungen und Anwendungshinweise zur EL3204-0200
Einstellungen und Anwendungshinweise zur EL3204-0200
Die EL3204-0200 unterscheidet sich von der EL3204-0000 (Standard-Type) durch
▪
erweiterter Messbereich 0 ... 240 kΩ
▪
zusätzliche Linearisierungen/Sensorkennlinien
–
einprogrammierte Sensorkennlinien entsprechend dem Messbereich
–
frei programmierbar nach Stützstellentabelle
–
parametrierbare Formeln nach IEC 60751, Steinhart-Hart-Gleichung und B-Parameter-Gleichung
Hinweis
Veränderungen im CoE-Verzeichnis, Austauschfall
Damit auch im Austauschfall eines EtherCAT-Slaves bei dem neu eingesetzten Slave die CoE-Parameter richtig gesetzt werden, sind kundenseitige CoE-Veränderungen in der StartUp-Liste einzutragen.
Veränderungen im CoE-Verzeichnis, Programmzugriff
Die CoE-Parameter können auch im Betrieb (soweit sinnvoll) durch die PLC mit entsprechende Steuerungsbefehlen gelesen und geschrieben werden. Siehe dazu die entsprechenden Einträge z.B. im Beckhoff-Information-System.
Hinweis: die CoE-Parameter sollten im Status PreOp oder SafeOp geschrieben und dann der Slave in den Status OP geschaltet werden.
Messbereich
Die Genauigkeitsangabe der Klemme bezieht sich auf den Messbereichsendwert für die Widerstandsmessung.
Der Einsatz der Klemme im Bereich 0 bis 10 Ω wird aufgrund der dann relativ geringen (relativen) Messgenauigkeit nicht empfohlen. Für solche Messungen sind spezialisierte Widerstandsmessklemmen wie die EL3692 in 4-Leiter-Messung zu verwenden.
Hinweise zur Genauigkeit
Das Messergebnis wird neben der Genauigkeit bei der Widerstandsmessung der Klemme auch von weiteren Faktoren beeinflusst; das Folgende sollte entlang der Messkette berücksichtigt werden:

• Messfehler des verwendeten Messsensors
• Messfehler der Klemme: < +/- 0,3% vom Messbereichsendwert (240 kΩ bei Widerstandsmessung); < +/- 0,5°C bei Pt-Sensoren
• Implementierung der Berechnungsparameter in der Firmware z.B. Anzahl Stützstellen, Genauigkeit der berechneten Parameter,...

Es wird eine Überprüfung der vorgenommenen Einstellungen gegen eine kalibrierte Temperaturquelle empfohlen.
Einprogrammierte Sensorkennlinien
• Direkte Widerstandsmessung
Die EL3204-0200 als direkte Widerstandsmessung in 3 Messbereichen (n = Kanal 0... 3) kann verwendet werden
Einstellung CoE 0x80n0:19 | Messbereich | Auflösung/digit
0x101 | 0 ...6.553,5 Ω | 0,1 Ω
0x102 | 0 ...65.535 Ω | 1 Ω
0x103 | 0 ...240.000 Ω | 10 Ω
Hinweis: die EL3204-0200 misst in diesen 3 Einstellungen elektrisch immer gleich, nur die dargestellte Auflösung wird in der Firmware verändert. Messbereichsendwert ist also für alle 3 Messungen 240 kΩ.
• Fixe Sensorkennlinien
Weitere einprogrammierte Sensorkennlinie im definierten Messbereich können im CoE-Entry 0x80n0:19 für jeden Kanal einzeln ausgewählt werden (n = Kanal 0... 3).
Typ | Widerstandsbereich | Implementierter Temperaturbereich | Auflösung/digit
Pt1000 (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) (PTC) | ~180 ... ~ 3.900 Ω | -200°C bis 850°C | 0,1°C
Ni1000 (PTC) | ~700 ... ~2.300 Ω | -60°C bis 250°C | 0,1°C
Ni1000 TK1500 (bei 100°C: 1500 Ω) (PTC) |  | -30 bis 160°C | 0,1°C
NTC 5k (0°C: 16325 Ω) | ~167.000 ... ~340 Ω | -40...100°C | 0,1°C
NTC 10k (0°C: 32650 Ω) | ~176.000 ... ~180 Ω | -30...150°C | 0,1°C
NTC 10k (0°C: 29490 Ω) | ~135.000 ... ~240 Ω | -30...150°C | 0,1°C
NTC 10k (0°C: 27280 Ω, wie KL3204-0030) | ~190.000 ... ~760 Ω | -40...110°C | 0,1°C
NTC 20k (0°C: 70200 Ω) | ~221.000 ... ~270 Ω | -20...150°C | 0,1°C
FeT (0°C: 2226 Ω) | ~1.900 ... ~ 3.900 Ω | -30...150°C | 0,1°C
Frei programmierbare Linearisierung
Falls ein resisitiver (widerstandsbehafteter) Sensor angeschlossen werden soll, dessen Kennlinie nicht in der EL32xx-xxxx implementiert aber anwenderseitig bekannt ist, kann diese Kennlinie über 4 verschiedene Verfahren in der Klemme eingegeben werden.
Dadurch ist jede Linearisierung und jede NTC/PTC-Kennlinie innerhalb des Messbereichs umsetzbar. Je nach Sensortyp eignen sich verschiedene Verfahren zur Implementierung.
CoE-Entry im 0x80n0:19 | Kennlinien Typ | PTC-Sensoren (z.B. Pt100, Pt1000, Ni100, Ni1000,...) | NTC-Sensoren (NTC 5k, NTC 10k,..)
0x110 | RTD-Tabelle/Stützstellentabelle | X | X
0x111 | B-Parameter Equation | - | X
0x112 | DIN EN 60751 Equation | X (Norm für Pt-Sensoren) | -
0x113 | Steinhart Hart Equation | - | X
Dazu ist im CoE-Entry 0x80n0:19 das jeweilige Verfahren für den Kanal auszuwählen. Hierbei ist zu beachten, dass für jedes Verfahren nur jeweils 1 Satz an Parametern in der Klemme hinterlegt werden kann, der dann für alle Kanäle zur Verfügung steht.
Beispiel: es werden 2 Sensoren an Kanal 1 und 2 angeschlossen, die beide mit der B-Parameter-Gleichung linearisiert werden sollen. Dann müssen beide Sensoren "gleich" sein, da nicht unterschiedliche Sätze an B-Parametern für Kanal 1 und 2 angegeben werden können. Entsprechendes gilt für die Stützstellentabelle.
• Stützstellentabelle (0x80n0:19, Entry 0x110)
Die gewünschte Kennlinie für einen PTC oder NTC-Sensor kann als Tabelle im CoE 0x8001 hinterlegt werden. Dazu kann sie aus der PLC ins CoE geladen, oder vom Anwender als XML-Datei in die Startup-Liste der Klemme eingetragen werden. Die Einträge aus der TwinCAT- Startup-Liste werden bei jedem Start von EtherCAT automatisch in die Klemme geschrieben.
Im Allgemeinen besitzt die Stützstellentabelle folgenden Aufbau: eine Temperatur wird dem entsprechenden Widerstand zugeordnet. Dabei muss die vorliegende Temperatur eine konstante Schrittweite aufweisen. Zwischen diesen Schritten wird linearisiert.
Maximal sind 100 Stützstellen, mit einem maximalen Messbereich von 0…240 kΩ zugelassen.
Der genaue Aufbau der Stützstellentabelle ist in der die CoE-Übersicht und zusätzlich in einer Beispieldatei ( )für einen Pt1000 Sensor erläutert.
Die Beispieldatei zeigt exemplarisch den Aufbau einer zu importierenden XML-Datei. Zusätzlich ist eine Excel-Datei (Excel 2010) beigefügt, um eine entsprechende XML zu erzeugen. Erläuterungen zur Benutzung der Excel-Datei können der beigefügten Beschreibung entnommen werden.
Die XML-Datei kann direkt über das Startup-Feld importiert und über "Konfiguration aktivieren" aktiviert werden.
Import der generierten XML-Datei
• B-Parameter-Gleichung (0x80n0:19, Entry 0x111)
Die B-Parameter-Gleichung kann auf NTC-Sensoren (Heißleiter), d.h. RTD-Elemente mit negativem Koeffizienten k, angewendet werden.
Dabei gibt der Koeffizienten RT0 den Widerstand bei der Temperatur T0 an, der B-Parameter kann den Angaben des Sensorherstellers entnommen oder durch Messung des Widerstandes bei zwei bekannten Temperaturen bestimmt werden.
Zur Berechnung des B-Parameters kann folgende Beispieldatei ( ) verwendet werden. Die berechneten Parameter sind in das CoE-Verzeichnis 0x8002 einzutragen.
Tabelle Berechnung B-Parameter
• Programmierbar nach DIN 60751 für Pt-Sensoren (0x80n0:19, Entry 0x112)
Die IEC 751 bzw. die deutsche Übersetzung DIN EN 60751 definiert die elektrischen Eigenschaften von Platin-Temperatursensoren. Der Kennlinienverlauf wird folgendermaßen beschrieben:
für Temperaturen -200.. 0°C:
für Temperaturen für 0.. 850°C:
Mit den Parametern:
Der Parameter R0 gibt den Widerstand in Ohm des Platinsensors bei T=0°C an. Die Sensoren werden nach diesen Bezeichnungen qualifiziert, so spricht man vom Pt100, wenn R0=100 Ω bei T=0°C beträgt.
Die in der Norm definierten Parameter A, B und C sind bereits im CoE Verzeichnis 0x8003:yy hinterlegt. Die Festlegung des Pt-Sensors erfolgt über den Parameter 0x8003:03, dieser entspricht R0.
• Steinhart-Hart-Gleichung (0x80n0:19, Entry 0x113)
Die Steinhart-Hart Gleichung kann auf NTC-Sensoren (Heißleiter), d.h. RTD-Elemente mit negativem Koeffizienten k, angewendet werden.
Die Koeffizienten C1, C2 und C4 können entweder direkt den Herstellerdaten entnommen, oder aber berechnet werden.
Zur Berechnung der Steinhart-Hart Parameter steht eine Beispieldatei ( ) zur Verfügung. Zur Bestimmung der Parameter werden die Widerstandswerte bei drei bekannten Temperaturen benötigt. Diese können entweder den Herstellerdaten entnommen oder direkt am Sensor gemessen werden. Die berechneten Parameter sind in das CoE-Verzeichnis 0x8004 einzutragen. Der Parameter C3 läuft in den meisten Fällen gegen Null, und ist somit zu vernachlässigen, er wird daher nicht in der Berechnung der Beispieldatei berücksichtigt.
Abb. 2:Tabelle Berechnung Steinhart-Hart-Parameter
Beispielimplementierung eines NTC-Sensors
Im Folgenden soll gezeigt werden, wie ein NTC-Sensor, dessen Kennlinie nicht bereits in der EL3204-0200 Klemme hinterlegt ist, in den drei Varianten, RTD-Tabelle, B-Parameter-Gleichung und Steinhart-Hart-Gleichung implementiert werden kann.
Dies wird anhand eines NTC030WP00 Sensors gezeigt.
Der Hersteller gibt in diesem Fall eine Tabelle mit Temperatur und den entsprechenden Widerstandswerten bekannt sowie folgende Sensoreigenschaften: NTC 10kΩ +/- 1% bei 25°C, Beta 3435.
• Implementierung mit der Stützstellentabelle RTD - Tabelle
Das allgemeine Vorgehen wird im Kapitel Stützstellentabelle erläutert, hier sollen an Hand eines Beispiels einige Spezialfälle aufgezeichnet werden. Eine Beispiel-XML-Datei ( ) für den NTC030WP00 Sensor steht zum Download bereit.
Beschreibung |  | Problem | Lösungsansatz
Die Tabelle umfasst den Temperaturbereich von -50°C...bis 110°C, in 1°Schritten |  | Gesamtanzahl der Stützstellen 160. Mit Hilfe der RTD-Tabelle können derzeit 100 Stützpunkte eingegeben werden. | 1. Messbereich begrenzen, so dass man auf gesamt 100 Stützstellen kommt 2. Schrittweite vergrößern, z. B. Tabelle in 5°C Schritten implementieren. Die Schrittweite sollte nicht zu groß gewählt werden, da es sich bei NTC-Sensoren um einen exponentielle und nicht lineare Kennlinie (wie z. B. bei den PTC-Sensoren) handelt.
Widerstandswerte im Temperaturbereich -50°C..-44°C liegen zwischen 330 kΩ.. 240 kΩ |  | Messwerte bei niedrigen Temperaturen überschreiten den Gesamtmessbereich von 240 kΩ | 1. Prüfen ob der Messbereich benötigt wird 2. Alternativsensor auswählen der bei den tiefen Temperaturen niedrigere Widerstandswerte aufweist.
Es soll der Bereich von -40°C...110°C in 2°C Schritten abgebildet werden. Neben der Implementierung der Tabelle werden folgende Einstellungen im CoE 0x8001 vorgenommen: |  | Mit Defaulteinstellungen des Conversion Factors 10 treten Fehler auf: Messbereich wurde nicht beachtet. Die Einheit der Widerstandswerte muss an den Conversion Factor angepasst werden | Messbereich muss beachtet werden, für den Gesamtmessbereich von 0....240 kΩ muss im 0x8001:04 Conversion Factor = 100 eingegeben werden. Die Widerstandswerte müssen dann in 1/10 Ω eingegeben werden. Die Bereiche sind wie folgt definiert:
0x8001:01 Distance in Degrees | 2
0x8001:02 Amount of Entries | 75 |  | Conversion Factor 0x8001:04 | Messbereich
0x8001:03 Start Temperatur | -40 |  | 1 | 0.. 6.533,5 Ω
0x8001:04 Conversion Factor | 10 |  | 10 | 0..65.535,0 Ω
0x8001:05 Value 1 | 188500 |  | 100 | 0..240.000,0 Ω
• Implementierung mit B-Parameter Gleichung
Den Herstellerangaben kann der B-Parameter (Beta 3435) und die Parameter Rn (10kΩ) und Tn (25°C) entnommen und direkt ins CoE-Verzeichnis 0x8002 übernommen werden.
CoE Entry | Eintrag
0x8002:01 Min Temperature | -40
0x8002:02 Max Temperature | 110
0x8002:03 Rn | 10000
0x8002:04 Tn | 25
0x8002:05 B-Parameter | 3435
Vergleicht man die Implementierung der Tabelle und der B-Parameter-Gleichung, wie in der unteren Grafik dargestellt, so wird deutlich, dass die B-Parameter-Gleichung nur in einem begrenzten Bereich gültig ist und bei tiefen Temperaturen große Abweichungen aufweist. Wird der gesamte Temperaturbereich benötigt, so ist die Implementierung über die Steinhart-Hart-Gleichung vorzuziehen.
• Implementierung mit Steinhart-Hart Gleichung
Die Steinhart-Hart Parameter können mit Hilfe der Beispieldatei berechnet und die dafür benötigten Widerstandswerte bei drei definierten Temperaturen z.B. bei 0°C, 25°C und 85°C, der Herstellertabelle entnommen oder direkt am Sensor gemessen werden.
CoE Entry | Eintrag
0x8004:01 Min Temperature | -40
0x8004:02 Max Temperature | 110
0x8004:03 C1 | 8,8424E-4
0x8004:04 C2 | 2,5202E-4
0x8002:04 C3 | 0
0x8002:04 C4 | 1,9018E-7
Aus der Grafik wird deutlich, dass die Implementierung über die Steinhart-Hart-Gleichung sich den Hersteller-Tabellenwerten besser annähert, als die Implementierung über die B-Parameter-Gleichung. Liegt jedoch eine Tabelle des Herstellers vor, so ist diese Methode immer vorzuziehen.
Vergleich Implementierung B-Parameter- und Steinhart-Hart-Parameter
Beispielimplementierung eines PTC-Sensors
Beispielimplementierung eines PTC-Sensors
Im Folgenden soll gezeigt werden, wie ein PTC-Sensor, speziell ein Platin-Sensor (Pt-Fühler), mit Hilfe der RTD-Tabelle und nach der DIN EN 60751 implementiert wird.
• Implementierung mit der Stützstellentabelle RTD - Tabelle
Das allgemeine Vorgehen ist im Kapitel Stützstellentabelle erläutert, im Folgenden wir die Implementierung einer Tabelle für ein Pt500-Sensor gezeigt.
Beschreibung | Problem | Lösungsansatz
Für die Pt-Sensoren sind Tabellen mit mehreren 100-Einträgen in 1°C-Schritten erhältlich. | Gesamtanzahl der Stützstellen wird überschritten. Mit Hilfe der RTD-Tabelle können derzeit 100 Stützpunkte eingegeben werden. | 1. Messbereich begrenzen, so dass man auf gesamt 100 Stützstellen kommt 2. Schrittweite vergrößern, z.B. Tabelle in 5°C oder 10°C Schritten implementieren. Da der Verlauf bei Pt-Sensoren nahezu linear ist, hat eine größere Schrittzahl nur einen geringen Einfluss auf die Messgenauigkeit. Im Gegensatz zu den NTC-Sensoren, wo man einen exponentiellen Verlauf hat und somit ein geringes Schrittmaß zu bevorzugen ist.
Die Herstellertabellen beinhalten allgemeingültige Werte | Die Tabellenwerte müssen zunächst auf den jeweiligen Sensortyp angepasst werden | Für die verschiedenen Pt-Sensoren müssen die Tabelleneinträge jeweils mit dem R0-Wert multipliziert werden. R0 gibt jeweils den Widerstand bei 0°C an - wobei die Sensorbezeichnung direkt auf diesen Wert schließen lässt.
 |  | Pt-Sensor | R (Widerstand bei 0°C) 0
 |  | Pt100 | 100
 |  | Pt500 | 500
 |  | Pt1000 | 1000
Für den Pt500-Sensor können folgende CoE-Einträge gewählt werden und mit folgender XML-Datei ( ) gearbeitet werden.:
CoE Entry | Eintrag
0x8001:01 Distance in Degrees | 10
0x8001:02 Amount of Entries | 60
0x8001:03 Start Temperature | -40
0x8001:04 Conversion Factor | 10
0x8001:05 Value 1 | 4247
0x8001:0x weitere Tabelleneinträge | .....
• Programmierbar nach DIN 60751 für Pt-Sensoren
Die Implementierung nach der DIN EN 60751 ist im Abschnitt Programmierbar_nach_DIN_60751_für_Pt-Sensoren beschrieben. Die Parameter A, B, C sind bereits im CoE hinterlegt, es muss lediglich der Temperaturbereich und der R0-Parameter für den zu verwendeten Sensor hinterlegt werden. R0 gibt jeweils den Widerstand bei 0°C an - wobei die Sensorbezeichnung direkt auf diesen Wert schließen lässt. Für den jeweiligen Sensor muss der CoE Eintrag angepasst werden.
Pt-Sensor | CoE Entry 0x8003:03
Pt100 | 100
Pt200 | 200
Pt500 | 500
Pt1000 | 1000
Vergleicht man nun den Verlauf der Widerstandswerte in Abhängigkeit von der Temperatur, durch die RTD-Tabelle und nach der DIN EN 60751, so wird deutlich, dass beide Implementierungsmethoden nahezu dasselbe Ergebnis liefern. Aufgrund der leichteren Implementierung, ist die Parametrierung nach der DIN 60571 vorzuziehen.
Vergleich Implementierung Pt500-Sensor


Prozessdaten und Betriebsmodi

Inbetriebnahme [image] Prozessdaten und Betriebsmodi
Prozessdaten und Betriebsmodi
Inhaltsverzeichnis
• Datenfluss
• Sync Manager
• Betriebmodi und Einstellungen
- Darstellung
- Siemens Bits
- Underrange, Overrange
- Notch-Filter (Wandlungszeiten)
- Limit 1 und Limit 2
- Kalibration
- Producer Codeword
• Beeinflussung durch störende Geräte
Datenfluss
Datenschema
Sync Manager (SM)
• PDO-Zuordnung
SM3, PDO-Zuordnung 0x1C13, für 0 ≤ n ≤ 7 (Ch. 1 - 8) (abhängig von Anzahl der Kanäle)
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A0n (default) | - | 4.0 | RTD Inputs Channel 1 - 8 | Index 0x60n0:01 - Underrange Index 0x60n0:02 - Overrange Index 0x60n0:03 - Limit 1* Index 0x60n0:05 - Limit 2* Index 0x6000:07 - Error Index 0x180n:07 - TxPDO Status Index 0x180n:09 - TxPDO Toggle Index 0x60n0:11 - Value
*) nicht für EL3214, EL3208
Betriebsmodi und Einstellungen
Darstellung (Presentation), Index 0x80n0:02
Die Ausgabe des Messwertes erfolgt im Auslieferungszustand in 1/10° C Schritten in Zweierkomplement-Darstellung (Signed Integer).
Es wird für jeden Widerstandssensor der komplette Messbereich ausgegeben. Index 0x80n0:02 bietet die Möglichkeit zur Veränderung der Darstellungsweise des Messwertes.
Messwert | Ausgabe (hexadezimal) | Ausgabe (Signed Integer, dezimal)
-250,0 °C | 0xF63C | -2500
-200,0 °C | 0xF830 | -2000
-100,0 °C | 0xFC18 | -1000
-0,1 °C | 0xFFFF | -1
-0,0 °C | 0x0000 | 0
-0,1 °C | 0x0001 | 1
100,0 °C | 0x03E8 | 1000
200,0 °C | 0x07D0 | 2000
500,0 °C | 0x1388 | 5000
850,0 °C | 0x2134 | 8500
• Signed Integer
Der Messwert wird im Zweierkomplement dargestellt.
Maximaler Darstellungsbereich bei 16 Bit = -32768 .. +32767
Beispiel:
1000 0000 0000 0000bin = 8000hex = - 32768dez
1111 1111 1111 1110bin = FFFEhex = - 2dez
1111 1111 1111 1111bin = FFFFhex = - 1dez
0000 0000 0000 0001bin = 0001hex = +1dez
0000 0000 0000 0010bin = 0002hex = +2dez
0111 1111 1111 1111bin = 7FFFhex = +32767dez
• Absolute value with MSB as sign
Der Messwert wird in der Betrag-Vorzeichendarstellung ausgegeben.
Maximaler Darstellungsbereich bei 16 Bit = -32767 .. +32767
Beispiel:
1111 1111 1111 1111bin = FFFFhex = - 32767dez
1000 0000 0000 0010bin = 8002hex = - 2dez
1000 0000 0000 0001bin = 8001hex = - 1dez
0000 0000 0000 0001bin = 0001hex = +1dez
0000 0000 0000 0010bin = 0002hex = +2dez
0111 1111 1111 1111bin = 7FFFhex = +32767dez
• High resolution (1/100 C°)
Der Messwert wird in 1/100 °C Schritten ausgegeben.
Der maximale Messbereich ist dadurch auf 32767dez * (1/100) °C = 327,67 °C begrenzt, kann aber durch die Anwenderskalierung erweitert werden!
Siemens Bits, Index 80n0:05
Mit Setzen dieses Bits werden auf den niedrigsten 3 Bits Statusanzeigen eingeblendet. Im Fehlerfall "Overrange" bzw. "Underrange" wird Bit 0 gesetzt.
Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:03 0x60n0:02
Pt100: T > 850 °C (R > 400 Ω): Index 0x60n0:02 und Index 0x60n0:07 (Overrange- und Error-Bit) werden gesetzt. Die Linearisierung der Kennlinie wird mit den Koeffizienten der oberen Bereichsgrenze bis zum Endanschlag des A/D-Wandlers (ca. 500 Ω bei Pt100) fortgesetzt.
Pt100: T < - 200 °C (R < 18 Ω): Index 0x60n0:01 und Index 0x60n0:07 (Underrange- und Error-Bit) werden gesetzt. Es wird die kleinste negativ Zahl ausgegeben (0x8001 entspricht -32767dez).
Bei Overrange bzw. Underrange wird die rote Error LED eingeschaltet.
Notch- Filter, Index 0x80n0:06, (nicht für EL3214 und EL3208))
Die Klemmen EL32xx sind mit einem digitalen Filter ausgestattet. Das Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit der Klemme. Es wird über den Index 0x8000:15 parametriert. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit.
Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also ausblendet. Um 50 Hz auszufiltern, kann also der 50 oder der 10 Hz Filter verwendet werden. Da üblicherweise aber alle tieferen Frequenzen als die Sperrfrequenz gemessen werden sollen, ist in diesem Fall die Einstellung "50 Hz" zu verwenden.
Typischer Frequenzgang eines Kerbfilters, eingestellt auf 50 Hz
Index 0x80n0:06
Die Filterfunktion ist auch bei nicht gesetztem Bit immer aktiv, da dies für den Messprozess obligatorisch ist!
Angaben zur Wandlungszeit
▪
die Wandlungszeit ist abhängig von Anzahl Aktive Kanäle, Anzahl Messungen (2/4-wire), Filterzeit, konst. Rechenzeit
▪
die Wandlungszeit ist bei 2-wire-Messung ca. doppelt so große wie bei 4-wire-Messung
▪
die Widerstandmessung entspricht einer 4-wire-Messung
▪
das Prozessdatum TxPDO Toggle wechselt seinen Zustand, wenn ein neuer Messwert anliegt
Einstellung der Filtereigenschaften über Index 0x8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL32xx zentral über den Index 0x8000:15 (Kanal 1) eingestellt. Die entsprechenden Indizes 0x8010:15 der EL3202 bzw. 0x8010:15, 0x8020:15, 0x8030:15 der EL3204 haben keine Parametrierungsfunktion.
Abschalten unbenutzter Kanäle von mehrkanaligen Klemmen
Bei Filterfrequenzen ≥ 1 kHz sollten unbenutzte Kanäle abgeschaltet werden (Optimierung der Wandlungszeiten)!
Der betreffende Kanal wird vollständig deaktiviert, die Wandlungszeit der EL32xx verkürzt sich entsprechend.
Set Value Dialog
Durch einen Doppelklick auf das entsprechende Objekt 0x80n0:1A können die entsprechenden Kanäle im Set Value Dialog abgeschaltet werden, indem der "Enum"-Wert "not connected" gewählt wird (siehe Abb. „Set Value Dialog“.
Typische Wandlungszeiten
EL3208
Filterfrequenz | Wandlungszeit (Updatezeit)
 | 1 Kanal aktiv | 8 Kanäle aktiv
5 Hz | 201 ms | 1600 ms
10 Hz | 101 ms | 807 ms
50 Hz | 22 ms | 171 ms
60 Hz | 18 ms | 145 ms
100 Hz | 12 ms | 92 ms
500 Hz | 4ms | 29 ms
1000 Hz | 3 ms | 20 ms
2000 Hz | 3 ms | 20 ms
3750 Hz | 3 ms | 20 ms
7500 Hz | 3 ms | 20 ms
15000 Hz | 3 ms | 20 ms
30000 Hz | 3 ms | 20 ms
Wandlungszeiten in Abhängigkeit der Filterfrequenzen, 2-wire-Messung - Beckhoff behält sich unangekündigte Änderungen vor
EL3214
Filterfrequenz | Wandlungszeit (Updatezeit)
 | 1 Kanal aktiv | 8 Kanäle aktiv
5 Hz | 402 ms | 1607 ms
10 Hz | 203 ms | 811 ms
50 Hz | 44 ms | 175 ms
60 Hz | 37 ms | 148 ms
100 Hz | 24 ms | 95 ms
500 Hz | 8 ms | 32 ms
1000 Hz | 6 ms | 24 ms
2000 Hz | 6 ms | 22 ms
3750 Hz | 5 ms | 21 ms
7500 Hz | 5 ms | 20 ms
Wandlungszeiten in Abhängigkeit der Filterfrequenzen, 3wire-Messung - Beckhoff behält sich unangekündigte Änderungen vor
EL3204
Filterfrequenz | Wandlungszeit (Updatezeit)
5 Hz | 800 ms
10 Hz | 400 ms
50 Hz | 82 ms (21 ms / 1 Kanal)
60 Hz | 70 ms
100 Hz | 43 ms
500 Hz | 11 ms
1000 Hz | 7 ms
2000 Hz | 6,5 ms (2 ms / 1 Kanal)
3750 Hz | 6 ms
7500 Hz | 6 ms
15000 Hz | 6 ms
30000 Hz | 6 ms
Wandlungszeiten in Abhängigkeit der Filterfrequenzen, 4-wire-Messung - Beckhoff behält sich unangekündigte Änderungen vor
EL3201, EL3201-0010
Filterfrequenz | Wandlungszeit (Updatezeit)
5 Hz | 205 ms
10 Hz | 105 ms
50 Hz | 25 ms
60 Hz | 21 ms
100 Hz | 15 ms
500 Hz | 5 ms
1000 Hz | 4 ms
2000 Hz | 4 ms
3750 Hz | 4 ms
7500 Hz | 4 ms
15000 Hz | 4 ms
30000 Hz | 4 ms
Wandlungszeiten in Abhängigkeit der Filterfrequenzen, 4-wire-Messung - Beckhoff behält sich unangekündigte Änderungen vor
Erhöhte Genauigkeit EL320x-00x0
Bei den hochpräzisen Klemmen dürfen die Einstellungen im Objekt 0x8000 / RTD-Settings nicht verändert werden!
Die erhöhte Genauigkeit der EL320x-00x0 gilt nur für folgende Einstellungen:
• Pt100-Sensoren
• Umgebungstemperatur von 40°C
• 4-Leiter-Anschlusstechnik
• Messbereich -200 bis 320°C
• 50 Hz Filter
Limit 1 und Limit 2, 80n0:13, 0x80n0:14 (nicht für EL3214 und EL3208)
Es kann ein Temperaturbereich eingestellt werden, der mit den Werten in den Indizes 0x80n0:13 und 0x80n0:14 verglichen wird. Beim Unter/Überschreiten der Grenzwerte werden die Bits in den Prozessdaten gesetzt.
Die Limitauswertung erfolgt nach Berücksichtigung der eingestellten Kennlinie und negativer Werte.
Limit [2 Bit] Interpretation (default), Index 0x60n0:03, 0x60n0:05:
0x00, 0: nicht aktiv
0x01, 1: Wert ist größer als Grenzwert
0x10, 2: Wert ist kleiner als der Grenzwert
0x11, 3: Wert ist gleich dem Grenzwert
Kalibrierung
• Anwender Skalierung, Index 0x80n0:01
Die Freigabe der Anwender-Skalierung erfolgt über den Index 0x80n0:01. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:11 Offset Anwender Skalierung
▪
0x80n0:12 Gain Anwender Skalierung
• Hersteller Abgleich, Index 0x80nF
Die Freigabe des Hersteller-Abgleich erfolgt über den Index 0x80n0:0B. Die Parametrierung erfolgt über die Indizes
▪
0x80nF:01 Offset Abgleich
▪
0x80nF:02 Gain Abgleich
▪
0x80nF:03 Offset Abgleich, Eingang RL
▪
0x80nF:04 Gain Abgleich, Eingang RL
▪
0x80nF:05 (nicht für EL3214 und EL3208), Offset Abgleich 4-Leiter Anschlusstechnik
▪
0x80nF:06 (nicht für EL3214 und EL3208), Gain Abgleich 4-Leiter Anschlusstechnik
• Anwender-Abgleich, Index 0x80n0:18, 0x80n0:17
Die Freigabe des Anwender-Abgleichs erfolgt über den Index 0x80n0:0A. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:17 User Offset Abgleich
▪
0x80n0:18 User Gain Abgleich
Berechnung Prozessdaten
Die Klemme nimmt permanent Messwerte auf und legt die Rohwerte ihres A/D-Wandlers ins ADC raw value-Objekt 0x80nE:01 bzw. 0x80nE:02. Nach jeder Erfassung des Analogsignals erfolgt die Korrekturberechnung mit den Hersteller-Kalibrierwerten. Anschließend folgt (optional) noch die Anwenderskalierung:
YH = (XADC - BK) x AK | Messwert nach Hersteller-Kalibrierung (entspricht YA , wenn Index 0x80n0:0A inaktiv)
YA= YHx AWx 2-16+ BW | Messwert nach Anwender-Skalierung
Legende
Name | Bezeichnung | Index
XADC | Ausgabe Wert des A/D Wandlers | 0x80nE:01, 0x80nE:02
BK | Offset der Hersteller-Kalibrierung (nur veränderbar, wenn das Objekt Producer codeword 0xF008 gesetzt wird) | 0x80nF:01, 0x80nF:03
AK | Gain der Hersteller-Kalibrierung (nur veränderbar, wenn das Objekt Producer codeword 0xF008 gesetzt wird) | 0x80nF:02, 0x80nF:04
BW | Offset der Anwender-Skalierung (aktivierbar über Index 0x80n0:0A) | 0x80n0:17
AW | Gain der Anwender-Skalierung (aktivierbar über Index 0x80n0:0A) | 0x80n0:18
YA | Prozessdaten zur Steuerung | -
Producer Codeword
Producer Codeword
Der Hersteller behält sich die Grundkalibrierung der Klemmen vor. Das Producer Codeword ist daher z. Zt. reserviert.
Beeinflussung durch störende Geräte
Beim Betrieb der schnellen analogen EtherCAT-Klemmen EL320x können hochfrequente, überlagernde Signale von störenden Geräten (z. B. Proportionalventile, Schrittmotor- oder DC-Motor-Endstufen) von der Klemme erfasst werden. Um einen störungsfreien Betrieb zu gewährleisten, empfehlen wir den Einsatz getrennter Netzteile für die Klemmen und die Störungen verursachenden Geräte. Als zusätzliche Maßnahme sollte der integrierte Filter der Klemme (siehe Index 0x80n0:06 ) zugeschaltet werden.


TwinSAFE SC

Inbetriebnahme [image] TwinSAFE SC
TwinSAFE SC
Weiterführende Informationen
•
TwinSAFE SC - Funktionsprinzip
•
TwinSAFE SC - Konfiguration


TwinSAFE SC - Funktionsprinzip

Inbetriebnahme [image] TwinSAFE SC [image] TwinSAFE SC - Funktionsprinzip
TwinSAFE SC - Funktionsprinzip
Mithilfe der TwinSAFE-SC-Technologie (TwinSAFE Single Channel) ist es möglich, in beliebigen Netzwerken bzw. Feldbussen Standardsignale für sicherheitstechnische Aufgaben nutzbar zu machen. Dazu werden EtherCAT-I/Os aus dem Bereich Analog-Eingang, Winkel-/Wegmessung oder Kommunikation (4…20 mA, Inkremental-Encoder, IO-Link usw.) um die TwinSAFE-SC-Funktion erweitert. Die signaltypischen Eigenschaften und Standard-Funktionalitäten der I/O-Komponenten bleiben dabei erhalten.
TwinSAFE-SC-I/Os unterscheiden sich optisch von Standard-I/Os durch einen gelben Streifen auf der Gehäusefront.
Die TwinSAFE-SC-Technologie ermöglicht eine Kommunikation über ein TwinSAFE-Protokoll. Diese Verbindungen können von der üblichen sicheren Kommunikation über Safety-over-EtherCAT unterschieden werden.
Die Daten der TwinSAFE-SC-Komponenten werden über ein TwinSAFE-Protokoll zu der TwinSAFE-Logic geleitet und können dort im Kontext sicherheitsrelevanter Applikationen verwendet werden. Detaillierte und durch den TÜV SÜD bestätigte/berechnete Beispiele zur korrekten Anwendung der TwinSAFE-SC-Komponenten und der jeweiligen normativen Klassifizierung können dem TwinSAFE-Applikationshandbuch entnommen werden.


TwinSAFE SC - Konfiguration

Inbetriebnahme [image] TwinSAFE SC [image] TwinSAFE SC - Konfiguration
TwinSAFE SC - Konfiguration
Die TwinSAFE-SC-Technologie ermöglicht eine Kommunikation mit Standard-EtherCAT-Klemmen über das Safety-over-EtherCAT-Protokoll. Diese Verbindungen verwenden eine andere Prüfsumme, um TwinSAFE SC von TwinSAFE unterscheiden zu können. Es sind acht feste CRCs auswählbar, oder es kann auch eine freie CRC durch den Anwender eingegeben werden.
Per default ist der TwinSAFE-SC-Kommunikationskanal der jeweiligen TwinSAFE-SC-Komponente nicht aktiviert. Um die Datenübertragung nutzen zu können, muss zunächst unter dem Reiter Slots das entsprechende TwinSAFE-SC-Modul hinzugefügt werden. Erst danach ist eine Verlinkung auf ein entsprechendes Alias-Device möglich.
Hinzufügen der TwinSAFE-SC-Prozessdaten unterhalb der Komponente z.B. EL5021-0090
Es werden zusätzliche Prozessdaten mit der Kennzeichnung TSC Inputs, TSC Outputs generiert (TSC - TwinSAFE Single Channel).
Prozessdaten TwinSAFE SC Komponente (iankfd11.png)
Prozessdaten TwinSAFE SC Komponente, Beispiel EL5021-0090
Durch Hinzufügen eines Alias Devices in dem Safety-Projekt und Auswahl von TSC (TwinSAFE Single Channel) wird eine TwinSAFE-SC-Verbindung hinzugefügt.
Hinzufügen einer TwinSAFE-SC-Verbindung
Nach Öffnen des Alias Devices durch Doppelklick kann durch Auswahl des Link Buttons Grafik aus Konfiguration TwinSAFE SC (iak9opa.png) neben Physical Device: die Verknüpfung zu einer TwinSAFE-SC-Klemme erstellt werden. In dem Auswahldialog werden nur passende TwinSAFE-SC-Klemmen angeboten.
Grafik aus Konfiguration TwinSAFE SC (i8d09251.png)
Erstellen einer Verknüpfung zu einer TwinSAFE-SC-Klemme
Unter dem Reiter Connection des Alias Devices wird die zu verwendende CRC ausgewählt bzw. eine freie CRC eingetragen.
Eintrag Mode | Verwendete CRCs
TwinSAFE SC CRC 1 master | 0x17B0F
TwinSAFE SC CRC 2 master | 0x1571F
TwinSAFE SC CRC 3 master | 0x11F95
TwinSAFE SC CRC 4 master | 0x153F1
TwinSAFE SC CRC 5 master | 0x1F1D5
TwinSAFE SC CRC 6 master | 0x1663B
TwinSAFE SC CRC 7 master | 0x1B8CD
TwinSAFE SC CRC 8 master | 0x1E1BD
Auswahl einer freien CRC
Diese Einstellungen müssen zu den Einstellungen passen, die in den CoE-Objekten der TwinSAFE-SC-Komponente eingestellt sind.
Die TwinSAFE-SC-Komponente stellt zunächst alle zur Verfügung stehenden Prozessdaten bereit. Der Reiter Safety Parameters enthält typischerweise keine Parameter. Unter dem Reiter Process Image kann die Prozessdatengröße bzw. die Prozessdaten selbst ausgewählt werden.
Auswahl der Prozessdatengröße bzw. der Prozessdaten
Die Prozessdaten (definiert in der ESI-Datei) können durch Auswahl des Buttons Edit entsprechend den Anwenderanforderungen im Dialog Configure I/O element(s) eingestellt werden.
Auswahl der Prozessdaten
Auf der TwinSAFE-SC-Slave-Seite muss die Safety-Adresse zusammen mit der CRC eingetragen werden. Dies geschieht über die CoE Objekte unterhalb von TSC Settings der entsprechenden TwinSAFE-SC-Komponente (hier bei der EL5021-0090 z.B. 0x8010:01 und 0x8010:02). Die hier eingestellte Adresse muss auch im Alias Device unter dem Reiter Linking als FSoE Adresse eingestellt werden.
Unter dem Objekt 0x80n0:02 Connection Mode wird die zu verwendende CRC ausgewählt bzw. eine freie CRC eingetragen. Es stehen insgesamt 8 CRCs zur Verfügung. Eine freie CRC muss im High Word mit 0x00ff beginnen.
Grafik aus Konfiguration TwinSAFE SC (iv9tkmo3.png)
CoE Objekte 0x8010:01 und 0x8010:02 bei der EL5021-0090
Objekt TSC Settings
Die Index-Bezeichnung des Konfigurationsobjekts TSC Settings kann je nach Klemme unterschiedlich sein.
Beispiel:
- EL3214-0090 und EL3314-0090, TSC Settings, Index 8040
- EL5021-0090, TSC Settings, Index 8010
- EL6224-0090, TSC Settings, Index 800F
Grafik aus Konfiguration TwinSAFE SC (isvth0a2.png)
Eintragen der Safety-Adresse und der CRC
TwinSAFE-SC-Verbindungen
Werden mehrere TwinSAFE-SC-Verbindungen innerhalb einer Konfiguration verwendet, muss für jede TwinSAFE-SC-Verbindung eine unterschiedliche CRC ausgewählt werden.


TwinSAFE SC Prozessdaten EL3214-0090

Inbetriebnahme [image] TwinSAFE SC Prozessdaten EL3214-0090
TwinSAFE SC Prozessdaten EL3214-0090
Die EL3214-0090 überträgt folgende Prozessdaten an die TwinSAFE Logik:
Index | Name | Type | Größe
6000:11 | RTD Module 1.Value | INT | 2.0
6010:11 | RTD Module 2.Value | INT | 2.0
6020:11 | RTD Module 3.Value | INT | 2.0
6030:11 | RTD Module 4.Value | INT | 2.0
Dabei werden zunächst die Prozessdaten aller vier Kanäle übertragen. Über den Reiter „Process Image“ können im Safety Editor einzelne Kanäle ganz abgewählt werden.
Abhängig von der TwinCAT 3.1 Version können Prozessdaten bei der Verlinkung zum Safety Editor automatisch umbenannt werden.


CoE Objektverzeichnis EL32xx-00xx

Inbetriebnahme [image] CoE Objektverzeichnis EL32xx-00xx
CoE Objektverzeichnis EL32xx-00xx
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise: - StartUp-Liste führen für den Austauschfall - Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung - "CoE-Reload" zum Zurücksetzen der Veränderungen
Relevante Objekte
Die Objektbeschreibung bezieht sich auf die Analogen Eingangsklemmen Pt100 (RTD) in 1 bis 8 kanaliger Ausführung. Beachten Sie die Indizes bezüglich der für die jeweilige Klemme relevanten Objekte (kanalabhängig).
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zu Parametrierung und profilspezifische Objekte, die bei der Inbetriebnahme nötig sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Objekte für die Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 80n0 RTD Settings für 0 ≤ n ≤ 7 (Ch. 1 - 8)
Einstellung der Filtereigenschaften nur über Index 0x8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL32xx zentral über den Index 0x8000:15 (Kanal 1) eingestellt.
Die entsprechenden Indizes 0x80n0:15 der EL3202, EL3204 und EL3208 haben keine Parametrierungsfunktion!
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | RTD Settings | Maximaler Subindex | UINT8 | RO | 0x1B (27dez)
80n0:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
80n0:02 | Presentation | 0: Signed presentation 1: Absolute value with MSB as sign Betragsvorzeichendarstellung 2: High resolution (1/100 C°) [default für Hochpräzise Klemmen EL320x-00x0, siehe Hinweis! | BIT3 | RW | 0x00 (0dez)
80n0:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits (Value 0x60n0:11) eingeblendet Bit 0 = 1 ("Overange" oder "Underrange") Bit 1 (not used) Bit 2 (not used) | BOOLEAN | RW | 0x00 (0dez)
80n0:06* | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
80n0:07* | Enable limit 1 | Die Statusbits werden abhängig von Limit 1 gesetzt | BOOLEAN | RW | 0x00 (0dez)
80n0:08* | Enable limit 2 | Die Statusbits werden abhängig von Limit 2 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8010:09* | Enable automatic calibration | Es wird zyklisch eine Kalibrierung angestoßen. (optional) | BOOLEAN | RW | 0x00 (0dez)
80n0:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
80n0:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
80n0:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
80n0:12 | User scale gain | Die ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535 (0x00010000). | INT32 | RW | 0x00010000 (65536dez)
80n0:13* | Limit 1 | Erster Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
80n0:14* | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
80n0:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. 0: 50 Hz 1: 60 Hz 2: 100 Hz 3: 500 Hz 4: 1 kHz 5: 2 kHz 6: 3,75 kHz 7: 7,5 kHz 8: 15 kHz 9: 30 kHz 10: 5 Hz 11: 10 Hz | UINT16 | RW | 0x0000 (0dez)
80n0:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
80n0:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535dez)
*) nicht für EL3208 und EL3214-00x0
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:19 | RTD element | RTD element 0: Pt100 (für Hochpräzise Klemmen siehe Hinweis! 1: Ni100 -60°C bis 250° 2:Pt1000 -200°C bis 850°C 3: Pt500 -200°C bis 850°C 4: Pt200 -200° C bis 850°C 5: Ni1000 -60°C bis 250°C 6: Ni1000 TK1500, 100°C: 1500 Ohm (-30 bis 160°C) 7: Ni120 -60°C bis 320°C 8: Ausgabe in Ohm Auflösung 1/16 Ohm (0 .. 4096 Ohm)*** 9: Ausgabe in Ohm Auflösung 1/64 Ohm (0 .. 1024 Ohm)*** 10-32: KT100/110/130/210/230 KTY10/11/13/16/19 KTY81/82-110,120,150 (-50...150°C) KTY81-121 KTY81-122 KTY81-151 KTY81-152 KTY81/82-210,220,250 KTY81-221 KTY81-222 KTY81-251 KTY81-252 KTY83-110,120,150 (-50...175°C) KTY83-121 KTY83-122 KTY83-151 KTY83-152 KTY84-130,150 (-40...300°C) KTY84-151 KTY21/23-6 (-50...150°C) KTY1x-5 KTY1x-7 KTY21/23-5 KTY21/23-7 ***) bitte Kapitel Funktion beachten! | UINT16 | RW | 0x0000 (0dez)
80n0:1A | Connection technology | Anschlusstechnik 0: Zweileiter-Anschluss (EL3214-0090 ab Firmware 02) 1*: Dreileiter-Anschluss 2*: Vierleiter-Anschluss [default für Hochpräzise Klemmen EL320x-00x0, siehe Hinweis! 3*: not connected | UINT16 | RW | 0x0000 (0dez)
80n0:1B | Wire calibration 1/32 Ohm | Abgleich der Zuleitungen | INT16 | RW | 0x0000 (0dez)
*) nicht für EL3208 und EL3214-00x0
Index 8040 TSC Settings (nur EL3214-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8040:0 | TSC Settings | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
8040:01 | Address | TwinSAFE SC Adresse | UINT16 | RW | 0x0000 (0dez)
8040:02 | Connection Mode | Auswahl der TwinSAFE SC CRC | UINT32 | RO | 0x00000000 (0dez)
Vollständige Übersicht
Standardobjekte (0x1000-0x1FFF)
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | ( )
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | ( )
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | ( )
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | ( )
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | ( )
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1604 TSC RxPDO-Map Master Message (nur EL3214-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | TSC RxPDO-Map Master Message | PDO Mapping RxPDO | UINT8 | RO | 0x04 (4dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x01 (TSC__Master Cmd)) | UINT32 | RO | 0x7040:01, 8
1604:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x03 (TSC__Master CRC_0)) | UINT32 | RO | 0x7040:03, 16
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7040 (TSC Master Frame Elements), entry 0x02 (TSC__Master ConnID)) | UINT32 | RO | 0x7040:02, 16
Index 1A0n TxPDO-Map für 0 ≤ n ≤ 3 (Ch. 1 - 4) [für EL3201, EL3202, EL3204]
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0n:0 | TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x09 (9dez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RW | 0x60n0:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RW | 0x60n0:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RW | 0x60n0:03, 2
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RW | 0x60n0:05, 2
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RW | 0x60n0:07, 1
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x180n (TxPDO-Par Ch.1), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x180n:07, 1
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x180n (TxPDO-Par Ch.1), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x180n:09, 1
1A0n:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x60n0:11, 16
Index 1A0n TxPDO-Map für 0 ≤ n ≤ 3 (Ch. 1 - 4) [für EL3214-00x0]
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0n:0 | TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x09 (9dez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RW | 0x60n0:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RW | 0x60n0:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RW | 0x60n0:07, 1
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x180n (TxPDO-Par Ch.1), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x180n:07, 1
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x180n (TxPDO-Par Ch.1), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x180n:09, 1
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x60n0:11, 16
Index 1A0n TxPDO-Map für 0 ≤ n ≤ 7 (Ch. 1 - 8) [für EL3208]
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0n:0 | TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x09 (9dez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RW | 0x60n0:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RW | 0x60n0:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RW | 0x0000:00, 4
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RW | 0x60n0:07, 1
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x180n (TxPDO-Par Ch.1), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x180n:07, 1
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x180n (TxPDO-Par Ch.1), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x180n:09, 1
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x60n0:11, 16
Index 1A04 TSC TxPDO-Map Slave Message (nur EL3214-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | TSC TxPDO-Map Slave Message | PDO Mapping TxPDO | UINT8 | RW | 0x0A (10dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x01 (TSC__Slave Cmd)) | USINT8 | RW | 0x6040:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (ENC Inputs), entry 0x11 (Counter value)) | INT16 | RW | 0x6000:11, 16
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x03 (TSC__Slave CRC_0)) | UINT16 | RW | 0x6040:03, 16
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | INT16 | RW | 0x6010:11, 16
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x04 (TSC__Slave CRC_1)) | UINT16 | RW | 0x6040:04, 16
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | INT16 | RW | 0x6020:11, 16
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x05 (TSC__Slave CRC_2)) | UINT16 | RW | 0x6040:05, 16
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (ENC Inputs), entry 0x11 (Counter value)) | INT16 | RW | 0x6030:11, 16
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x06 (TSC__Slave CRC_3)) | UINT16 | RW | 0x6040:06, 16
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6040 (TSC Slave Frame Elements), entry 0x02 (TSC__Slave ConnID)) | UINT16 | RW | 0x6040:02, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign***
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x08 (8dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:06 | Subindex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A05 (6661dez)
1C13:07 | Subindex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:08 | Subindex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A07 (6663dez)
***) für EL3201: Subindex x01, für EL3202: Subindex x01, x02...usw.
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x07 (7dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RW
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C33:08)
UINT16
RO
0x8007 (32775dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C33:09
Delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Profilspezifische Objekte (0x6000-0xFFFF)
Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.
Index 60n0 RTD Inputs für 0 ≤ n ≤ 7 (Ch. 1 - 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | RTD Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
60n0:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overrange | Der Messbereich wird überschritten. ("open circuit" Erkennung wenn "Error" [Index 0x60n0:07]) gesetzt ist | BOOLEAN | RO | 0x00 (0dez)
60n0:03* | Limit 1 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
60n0:05* | Limit 2 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
60n0:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
60n0:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n0:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0dez)
*) nicht für EL3208 und EL3214-00x0
Index 6040 TSC Slave Frame Elements (nur EL3214-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6040:0 | TSC Slave Frame Elements | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
6040:01 | TSC__Slave Cmd | reserviert | UINT8 | RO | 0x00 (0dez)
6040:02 | TSC__Slave ConnID | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:03 | TSC__Slave CRC_0 | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:04 | TSC__Slave CRC_1 | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:05 | TSC__Slave CRC_2 | reserviert | UINT16 | RO | 0x0000 (0dez)
6040:06 | TSC__Slave CRC_3 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index 7040 TSC Master Frame Elements (nur EL3214-0090)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7040:0 | TSC Master Frame Elements | Maximaler Subindex | UINT8 | RO | 0x03 (3dez)
7040:01 | TSC__Master Cmd | reserviert | UINT8 | RO | 0x00 (0dez)
7040:02 | TSC__Master ConnID | reserviert | UINT16 | RO | 0x0000 (0dez)
7040:03 | TSC__Master CRC_0 | reserviert | UINT16 | RO | 0x0000 (0dez)
Index 80nE RTD Internal data für 0 ≤ n ≤ 7 (Ch. 1 - 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nE:0 | RTD Internal data | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
80nE:01 | ADC raw value 1 | ADC Rohwert 1 | INT32 | RO | 0x00000000 (0dez)
80nE:02 | Resistor 1 | Widerstand 1 (Messwert Widerstandssensor, Auflösung 1/32 Ohm) | UINT16 | RO | 0x0000 (0dez)
80nE:03* | ADC raw value 2 (RL) | ADC Rohwert 2 (RL) | INT32 | RO | 0x00000000 (0dez)
80nE:04* | Resistor 2 (RL) | Widerstand 2 (RL) (Messwert der Zuleitung, Auflösung 1/32 Ohm) | UINT16 | RO | 0x0000 (0dez)
*) nicht für EL3208
Index 80nF RTD Vendor data für 0 ≤ n ≤ 3 (Ch. 1 - 4) [nicht für EL3208 und EL3214-00x0]
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | RTD Vendor data | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
80nF:01 | Calibration offset | Hersteller Offset Abgleich | INT16 | RW | 0x0000 (0dez)
80nF:02 | Calibration gain | Hersteller Gain Abgleich | UINT16 | RW | 0x9E50 (40528dez)
80nF:03 | Calibration offset RL | Hersteller Offset Abgleich (Eingang RL) | INT16 | RW | 0x0000 (0dez)
80nF:04 | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | 0x9E50 (40528dez)
80nF:05 | Calibration offset 4-wire | Hersteller Offset Abgleich (4- Leiter Anschlusstechnik) | INT16 | RW | 0x0000 (0dez)
80nF:06 | Calibration gain 4-wire | Hersteller Gain Abgleich (4- Leiter Anschlusstechnik) | UINT16 | RW | 0x9E50 (40528dez)
Index 80nF RTD Vendor data für 0 ≤ n ≤ 7 (Ch. 1 - 8) [nur EL3208 und EL3214-00x0]
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | RTD Vendor data | Maximaler Subindex | UINT8 | RO | -
80nF:01 | Calibration offset | Hersteller Offset Abgleich | INT16 | RW | -
80nF:02 | Calibration gain | Hersteller Gain Abgleich | UINT16 | RW | -
80nF:03 | Calibration offset Pt1000 | Hersteller Offset Abgleich Pt1000 | INT16 | RW | -
80nF:04 | Calibration gain Pt1000 | Hersteller Gain Abgleich Pt000) | UINT16 | RW | -
80nF:05* | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | -
80nF:06* | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | -
*) nicht für EL3208
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | z.Zt. reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list [für {n=1} (1 Kanal) bis {n=1,..,n=8} (8 Kanal)]
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RO | 0x08 (ndez)
F010:0n | Subindex 00n | Profil 320 | INT32 | RO | 0x00000140 (320dez)


CoE Objektverzeichnis EL3204-0200

Inbetriebnahme [image] CoE Objektverzeichnis EL3204-0200
CoE Objektverzeichnis EL3204-0200
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise: - StartUp-Liste führen für den Austauschfall - Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung - "CoE-Reload" zum Zurücksetzen der Veränderungen
Einführung
In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:
▪
Objekte die zu Parametrierung und profilspezifische Objekte, die bei der Inbetriebnahme nötig sind
▪
Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind
Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.
Objekte für die Inbetriebnahme
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 80n0 RTD Settings für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Einstellung der Filtereigenschaften nur über Index 0x8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL3204-0200 zentral über den Index 0x8000:15 (Kanal 1) eingestellt. Die entsprechenden Indizes 0x80n0:15 haben keine Parametrierungsfunktion!
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:0 | RTD Settings | Maximaler Subindex | UINT8 | RO | 0x1B (27 dez)
80n0:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0 dez)
80n0:02 | Process data Presentation | erlaubte Werte 0: Signed 1: Absolute MSB sign 2: High resolution (1/100°C) | BIT3 | RW | 0x00 (0 dez)
80n0:05 | Siemens bits | Die S5 Bits werden in den drei niederwertigen Bits (Value 0x60n0:11) eingeblendet Bit 0 = 1 ("Overange" oder "Underrange") Bit 1 (not used) Bit 2 (not used) | BOOLEAN | RW | 0x00 (0 dez)
80n0:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0 dez)
80n0:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0 dez)
80n0:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1 dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n0:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
80n0:12 | User scale gain | Die ist der Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 . Der Wert 1 entspricht 65535 (0x00010000). | INT32 | RW | 0x00010000 (65536dez)
80n0:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. erlaubte Werte: 0: 50 Hz 1: 60 Hz 2: 100 Hz 3: 500 Hz 4: 1 kHz 5: 2 kHz 6: 3,75 kHz 7: 7,5 kHz 8: 15 kHz 9: 30 kHz 10: 5 Hz 11: 10 Hz | UINT16 | RW | 0x0000 (0 dez)
80n0:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0 dez)
80n0:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535 dez)
80n0:19 | RTD element | erlaubte Werte: 0: Pt1000 (-200...850°C) 2: NI1000 100°C (TK5000, bei 100°C 1500 Ohm, -30...160°C) 3: NI1000 (-60...250°C) 4: NTC 5k (0°C: 16325 Ohm, -40...100°C) 5: NTC 10k (0°C: 32650 Ohm, -30...150°C) 6: NTC 10k (0°C: 29490 Ohm, -30...150°C) 7: NTC 10k (0°C: 27280 Ohm, -40...110°C, wie KL3204-0030) 8: NTC 20k (0°C: 70200 Ohm, -20...150°C) 9: Fet (-30...150°C) 101: Widerstand 1/10 Ohm Auflösung (0...6553,5 Ohm) 102: Widerstand 1/10 Ohm Auflösung (0...65 535 Ohm) 103: Widerstand 1/10 Ohm Auflösung (0...240 kOhm) 110: RTD-Tabelle (weitere Parameter siehe 0x80n1) 111: B-Parameter Equation (weitere Parameter siehe 0x80n2) 112: DIN IEC 60751 Equation (weitere Parameter siehe 0x80n3) 113: Steinhart Hart Equation (weitere Parameter siehe 0x80n4) | UINT16 | RW | 0x0000 (0 dez)
80n0:1A | Connection technology | erlaubte Werte 0: Zweileiter-Anschluss 3: n. c. (Kanal deaktiviert) | UINT16 | RW | 0x0000 (0 dez)
80n0:1B | Wire calibration | Offset-Wert zum Abgleich der Zuleitungen [1/10] Ohm | INT16 | RW | 0x0000 (0 dez)
Index 80n1 RTD Table
Die Standardwerte in der folgenden Tabelle zeigen beispielhaft die Umrechnungswerte eines Pt1000 im Bereich von 0°C bis 140°C mit einer Auflösung von 1/10 Ohm
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n1:0 | RTD Table | Mit dieser Tabelle kann die Sensor Charakteristik programmiert werden | UINT8 | RO | 105
80n1:01 | Distance in Degrees | Gesetzter Wert beschreibt den Abstand der Einträge in °C | UINT16 | RW | 10
80n1:02 | Amount of Entries | Eingetragener Wert beschreibt die Anzahl der Einträge, mit der nach der unteren Gleichung die Abhängigkeit von Abstand in °C, Start-Temperatur vom Messbereich und Endtemperatur dargestellt wird Endtemperatur = Starttemperatur + ((Anzahl der Einträge -1) * Abstand in °C) | UINT16 | RW | 15
80n1:03 | Start Temperature | Der eingetragene Wert beschreibt den Anfang des Messbereichs Standardwert 0°C | INT16 | RW | 0
80n1:04 | Conversion Factor | 1 = 1/10 Ohm pro Digit in der Tabelleneinträgen 10 = 1 Ohm pro Digit in der Tabelleneinträgen 100 = 10 Ohm pro Digit in der Tabelleneinträgen | UINT16 | RW | 1
80n1:05 | Value 1 |  | UINT16 | RW | 0x2710 (10000dez)
80n1:06 | Value 2 |  | UINT16 | RW | 0x2896 (10390 dez)
80n1:07 | Value 3 |  | UINT16 | RW | 0x2A1B (10779 dez)
80n1:08 | Value 4 |  | UINT16 | RW | 0x2B9F (11167 dez)
80n1:09 | Value 5 |  | UINT16 | RW | 0x2D22 (11554 dez)
80n1:0A | Value 6 |  | UINT16 | RW | 0x2EA3 (11939 dez)
80n1:0B | Value 7 |  | UINT16 | RW | 0x3024 (12324 dez)
80n1:0C | Value 8 |  | UINT16 | RW | 0x31A3 (12707 dez)
80n1:0D | Value 9 |  | UINT16 | RW | 0x3321 (13089 dez)
80n1:0E | Value 10 |  | UINT16 | RW | 0x349E (13470 dez)
80n1:0F | Value 11 |  | UINT16 | RW | 0x361A (13850 dez)
80n1:10 | Value 12 |  | UINT16 | RW | 0x3795 (14229 dez)
80n1:11 | Value 13 |  | UINT16 | RW | 0x390E (14606 dez)
80n1:13 | Value 14 |  | UINT16 | RW | 0x3A87 (14983 dez)
80n1:14 | Value 15 |  | UINT16 | RW | 0x3BFE (15358 dez)
80n1:15 | Value 16 |  | UINT16 | RW | 0x0000 (0 dez)
… | … |  | … | … | …
80n1:69 | Value 100 |  | UINT16 | RW | 0x0000 (0 dez)
Index 80n2 RTD B-Parameter Equation für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n2:0 | RTD B-Parameter Equation |  | UINT8 | RO | 0x05 (5 dez)
80n2:01 | Min Temperature | Anfang des Messbereichs in °C. | INT16 | RW | -30
80n2:02 | Max Temperature | Ende des Messbereichs in °C. | INT16 | RW | 150
80n2:03 | Rn | Widerstandswert bei Tn. In den meisten Fällen = 25°C. | INT16 | RW | 1000
80n2:04 | Tn | Referenztemperatur für Rn [°C] | INT16 | RW | 25
80n2:05 | B-Parameter | B-Parameter [Kelvin] | REAL32 | RW | 3710
Index 80n3 RTD DIN EN 60751 Equation für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n3:0 | RTD DIN EN 60751 Equation | Standard-Parameter Pt1000 im Bereich von 0 bis 850°C. | UINT8 | RO | 0x06 (6 dez)
80n3:01 | Min Temperature | Anfang des Messbereichs in °C. | INT16 | RW | 0
80n3:02 | Max Temperature | Ende des Messbereichs in °C. | INT16 | RW | 850
80n3:03 | R0 | siehe Gleichung | UINT16 | RW | 1000
80n3:04 | A Parameter | siehe Gleichung | REAL32 | RW | 3,908E-3
80n3:05 | B Parameter | siehe Gleichung | REAL32 | RW | -5,775E-7
80n3:06 | C Parameter | siehe Gleichung | REAL32 | RW | -4,183E-12
Index 80n4 RTD Steinhart Hart Equation für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80n4:0 | RTD Steinhart Hart Equation | Standardwerte für einen NTC10K mit 32650 Ohm bei 0°C: C1 default = 1.12119E-03 C2 default = 2.35346E-04 C3 default = 0 C4 default = 8.34620E-08 | UINT8 | RO | 0x06 (6 dez)
80n4:01 | Min Temperature | Anfang des Messbereichs in °C. | INT16 | RW | -30
80n4:02 | Max Temperature | Ende des Messbereichs in °C. | INT16 | RW | 150
80n4:03 | C1 | siehe Gleichung | REAL32 | RW | 1,1211E-03
80n4:04 | C2 | siehe Gleichung | REAL32 | RW | 2,35346E-04
80n4:05 | C3 | siehe Gleichung | REAL32 | RW | 0
80n4:06 | C4 | siehe Gleichung | REAL32 | RW | 8,24620E-08
Index 80nE RTD Internal Data für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nE:0 | RTD Internal Data | Max. Subindex | UINT8 | RO |
80nE:01 | ADC raw value | ADC raw value. | INT32 | RO |
80nE:02 | Resistor (1/10 Ohm) | resultierender gemessener Widerstand | UINT32 | RO |
Index 80nF RTD Vendor Data für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
80nF:0 | RTD Vendor Data | Max. Subindex | UINT8 | RO | 0x03 (3 dez)
80nF:01 | Calibration offset | Kalibierungs-Offset | INT32 | RW | 0x00000DAC (3500 dez)
80nF:02 | Calibration gain | Gain Wert für Messbereich 0..5000 Ohm | UINT16 | RW | 0x3D68 (15720 dez)
80nF:03 | Calibration gain ext. | Gain Wert für Messbereichrange 5..240 kOhm | UINT16 | RW | 0x05A0 (1440 dez)
Vollständige Übersicht
Standardobjekte
Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01401389 (20976521 dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL3204-0200
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4 dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2 dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0C843052 (209989714 dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0 dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0 dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1 dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0 dez)
Index 180n RTD TxPDO-Par für 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
180n:0 | RTD TxPDO-Par | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9 dez)
180n:06 | Exclude TxPDOs | Dieser Eintrag enthält die TxPDOs (Index der TxPDO Mapping Objekte) die nicht mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[0] | RO |
180n:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0 dez)
180n:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0 dez)
Index 1A0n RTD TxPDO-Map 0 ≤ n ≤ 3 (Ch. 1 - 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0n:0 | RTD TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8 dez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x60n0:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x60n0:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x60n0:07, 1
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x00n0:00, 7
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x180n (RTD TxPDO-Par Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x180n:07, 1
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x180n (RTD TxPDO-Par Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x180n:09, 1
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60n0 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x60n0:11, 16
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4 dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1 dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2 dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3 dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4 dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0 dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x04 (4 dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656 dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A01 (6657 dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A02 (6658 dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A03 (6659 dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32 dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0 dez)
1C33:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x00000000 (0 dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0 dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C33:08)
UINT16
RO
0xC007 (49159 dez)
1C33:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00000000 (0 dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0 dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0 dez)
1C33:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0 dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0 dez)
1C33:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0 dez)
1C33:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0 dez)
1C33:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0 dez)
1C33:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0 dez)
Profilspezifische Objekte
Index 60n0 RTD Inputs für 0 ≤ n ≤ 3 (Ch. 1 – 4)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | RTD Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17 dez)
60n0:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0 dez)
60n0:02 | Overrange | Der Messbereich wird überschritten. | BOOLEAN | RO | 0x00 (0 dez)
60n0:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0 dez)
60n0:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0 dez)
60n0:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0 dez)
60n0:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0 dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2 dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16 dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4 dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | z.Zt. reserviert | UINT32 | RW | 0x00000000 (0 dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x04 (4 dez)
F010:01 | SubIndex 001 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320 dez)
F010:02 | SubIndex 002 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320 dez)
F010:03 | SubIndex 003 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320 dez)
F010:04 | SubIndex 004 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320 dez)


Status-Wort

Inbetriebnahme [image] Status-Wort
Status-Wort
Die Statusinformationen für jeden Kanal der EL32xx und EL33xx werden als Prozessdaten (PDO) zyklisch von der Klemme zum EtherCAT Master übertragen. Für die EL32xx und EL33xx sind 2 Gerätebeschreibungsversionen verfügbar, die das Prozessdatenabbild in einzelner und erweiterter Form darstellen.
Anhand der Revisionsnummer EL3xxx-xxxx-XXXX ist die Unterscheidung sichtbar.
Als Prozessdaten überträgt die EL32xx bzw. EL33xx:
▪
Underrange: Messbereich unterschritten
▪
Overrange: Messbereich überschritten ("Leitungsbruch" zusammen mit "Error")
▪
Limit 1: Grenzwertüberwachung 0: ok, 1: Grenzbereich überschritten, 2: Grenzbereich unterschritten
▪
Limit 2: Grenzwertüberwachung 0: ok, 1: Grenzbereich überschritten, 2: Grenzbereich unterschritten
▪
Error: Das Fehlerbit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange)
▪
TxPDO State: Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid).
▪
TxPDO Toggle: Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. Dies lässt einen Rückschluss auf die aktuell benötigte Wandlungszeit zu
Die Einstellung der Limit-Auswertung wird im CoE-Verzeichnis in den 8000er Objekten vorgenommen.
Unterschiede in den Revisionen der EL32xx- und EL33xx-Serien
Nachfolgend werden an der EL32xx-Serie exemplarisch die Revisions-Unterschiede dargestellt. Sinngemäß gilt die Beschreibung auch für die EL33xx-Serie.
Revision -0016 (EL32xx-xxxx-0016)
Diese Klemmenrevisionen verfügen über das Einzel-Prozessabbild, s. „EL32xx-0000-0016 Prozessabbild in der Darstellung TwinCAT 2.11“.
Jede Statusinformation wird als einzelnes, verlinkbares Prozessdatum übertragen.
EL32xx-0000-0016 Prozessabbild in der Darstellung TwinCAT 2.11
Revision -0017 (EL32xx-xxxx-0017) und höher
Diese Klemmenrevisionen verfügen auch über das zusammengefasste Prozessabbild, s. Abb. „EL32xx-0000-0017 Prozessabbild in der Darstellung TwinCAT 2.11“.
Die Einzelinformationen sind hier in der Beckhoff üblichen Darstellung als 16-Bit-Status-Wort zusammengefasst und können so in die Steuerung verlinkt werden.
Status-Wort
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | TxPDO Toggle | TxPDO State | - | - | - | - | - | - | - | Error | Limit 2 |  | Limit 1 |  | Overrange | Underrange
Darüber hinaus kann der zusammengefasste "Status" über das "+" -Symbol aufgeklappt und die Prozessdaten einzeln verlinkt werden.
EL32xx-0000-0017 Prozessabbild in der Darstellung TwinCAT 2.11
Die Anzeige der Einzelinformationen ist auch im rechten Übersichtsfenster (A) möglich. Durch den Button

in der Menüleiste werden die Informationen auch dort angezeigt.
Zusammengefasstes Prozessabbild in erweiterter Darstellung unter TwinCAT 2.11
Hinweise
▪
Die zusammengefasste Darstellung ist nur ab TwinCAT 2.11 sichtbar. Wird eine EL32xx-xxxx-0017 (und später) in früheren TwinCAT Konfigurationen betrieben, wird aus Kompatibilitätsgründen das Einzelprozessabbild mit vorangestelltem Kennzeichner "Status__" angezeigt.
Zusammengefasstes Prozessabbild in Darstellung unter TwinCAT 2.10
▪
Eine Abhängigkeit der Revision vom in der Klemme vorliegenden Firmware-Stand ist für die Revisionen -0016 und -0017 nicht gegeben. Das bedeutet, auch Klemmen die als EL32xx-xxxx-0016 ausgeliefert wurden, können mit einer -0017 und somit "neueren" Konfiguration und damit dem zusammengefassten Prozessabbild angesprochen werden.
Dieser "Aufwärtskompatibilität" genannte Fall ist für die EL32xx-xxxx-0016 und -0017 erlaubt.
▪
Die in der Klemme vorliegende Revision kann am einfachsten durch Scannen des EtherCAT-Systems ermittelt werden. Der Vergleichsbericht zeigt die Unterschiede.
Beispielhaftes Ergebnis nach dem Scannen eines EtherCAT-Systems
Erläuterung zu Abb. „Beispielhaftes Ergebnis nach dem Scannen eines EtherCAT-Systems“: Laut rechter Übersicht befindet sich eine EL3201-0000-0016 in der Konfiguration (*.tsm-Datei), gefunden wurde aber laut linker Übersicht eine Revision -0017. Die generelle Abwärtskompatibilität von EL-Klemmen stellt sicher, dass dieser Einsatzfall möglich ist.


Hinweise zu analogen Spezifikationen

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen
Hinweise zu analogen Spezifikationen
Beckhoff IO-Geräte (Klemmen, Boxen, Module) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.
Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.
Weiterführende Informationen
•
Messbereichsendwert (MBE)
•
Messfehler/ Messabweichung
•
Temperaturkoeffizient tK [ppm/K]
•
Typisierung SingleEnded / Differentiell
•
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
•
Spannungsfestigkeit
•
Zeitliche Aspekte der analog/digital Wandlung


Messbereichsendwert (MBE)

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Messbereichsendwert (MBE)
Messbereichsendwert (MBE)
Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.
Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.
Messbereichsendwert, Messspanne
Für die obigen Beispiele bedeutet dies:
▪
Messbereich 0...10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
▪
Messbereich 4...20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
▪
Messbereich -200...1370°C: asymmetrisch bipolar, MBE = 1370°C, Messspanne = 1570°C
▪
Messbereich -10...+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V
Dies gilt entsprechend für analoge Ausgangsklemmen/ -boxen (bzw. verwandten Beckhoff‑Produktgruppen).


Messfehler/ Messabweichung

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Messfehler/ Messabweichung
Messfehler/ Messabweichung
Der relative Messfehler (% vom MBE) bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.
Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung usw.).
Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben.
Die maximale Abweichung kann auch direkt angegeben werden.
Beispiel: Messbereich 0...10 V und Messfehler < ± 0,3% MBE → maximale Abweichung ± 30 mV im zulässigen Betriebstemperaturbereich.
Geringerer Messfehler
Da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringeren Messfehler ausgegangen werden.
Dies gilt entsprechend für analoge Ausgangsgeräte.


Temperaturkoeffizient tK [ppm/K]

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Temperaturkoeffizient tK [ppm/K]
Temperaturkoeffizient tK [ppm/K]
Eine elektronische Schaltung ist in der Regel mehr oder weniger temperaturabhängig. Im Bereich der analogen Messtechnik bedeutet dies, daß der mittels einer elektronischen Schaltung ermittelte Messwert reproduzierbar in seiner Abweichung vom „wahren“ Wert von der Umgebungs/Betriebstemperatur abhängig ist.
Lindern kann ein Hersteller dies durch Verwendung höherwertiger Bauteile oder Software-Maßnahmen.
Der von Beckhoff ggf. angegebene Temperaturkoeffizient erlaubt es dem Anwender den zu erwartenden Messfehler außerhalb der Grundgenauigkeit bei 23°C zu berechnen.
Aufgrund der umfangreichen Unsicherheitsbetrachtungen, die in die Bestimmungen der Grundgenauigkeit (bei 23°C) eingehen, empfiehlt Beckhoff eine quadratische Summierung.
Beispiel: Grundgenauigkeit bei 23°C sei ±0,01% typ. (MBE), tK = 20 ppm/K typ., gesucht ist die Genauigkeit G35 bei 35°C, somit ΔT = 12K
Anmerkungen:
ppm ≙ 10-6
% ≙ 10-2


Typisierung SingleEnded / Differentiell

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Typisierung SingleEnded / Differentiell
Typisierung SingleEnded / Differentiell
Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.
In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.
SE und DIFF-Modul als 2-kanalige Variante
Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss. Galvanisch getrennte Kanäle arbeiten grundsätzlich in differentieller Art, nur dass überhaupt kein direkter (galvanischer) Massebezug im Modul hergestellt ist. Spezifikationsangaben zu empfohlenen und maximalen Spannungen sind jeweils allerdings zu beachten.
Grundsätzlich gilt:
▪
Die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten.
Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
–
Dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
–
Für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
–
Bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt.
Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
▪
Es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen.
Beckhoff IO-Module verfügen über 1..8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden
–
wie sich die Kanäle INNERHALB eines Module zueinander stellen oder
–
wie sich die Kanäle MEHRERER Module zueinander stellen.
Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.
–
Beckhoff Klemmen/ Boxen (bzw. verwandte Produktgruppen) sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen/ Boxen also nicht über die Powerkontakte/ Powerleitung miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
–
Falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder ein 1-Kanal-Modul keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
▪
Analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Dokumentationen zu den Klemmen/ Boxen sind zu beachten.
Erläuterung
▪
differentiell (DIFF)
–
Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
–
Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
–
Da ein differentieller Kanal intern symmetrisch aufgebaut ist (vgl. Abb. SE und DIFF-Modul als 2-kanalige Variante) stellt sich in der Mitte zwischen den beiden zugeführten Potenzialen ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrere DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)", wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
–
Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme/ Box zugänglich sein, um ein definiertes GND-Potenzial in der Klemme/ Box zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird.
Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
–
Differentielle Messung in Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
–
Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
–
Weitere hilfreiche Ergänzungen dazu sind der Dokumentationsseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) zu entnehmen.
▪
Single Ended (SE)
–
Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme/ Box von außen zum Anschluss des Bezugspotenzials zugänglich sein, z. B. über die Powerkontakte/ Powerleitung.
–
SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme/ Box zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z. B. im Anlagen-GND.
–
Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/Bezugspotenzial hart miteinander verbunden sind.
Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren
Stromgeber/Sensoren/Feldgeräte (im Folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:
Selbstversorgende Sensoren
▪
Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst.
Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4-20mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.
▪
2-Leiter-Anschluss siehe Abb. 2-Leiter-Anschluss, vgl. IEC60381-1
▪
Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.
2-Leiter-Anschluss
Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:
bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme/ Box gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal
sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Extern versorgte Sensoren
▪
3- und 4-Leiter-Anschluss siehe Abb. Anschluss extern versorgte Sensoren, vgl. IEC60381-1
▪
Die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:
–
1 Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm.
–
2 Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +Supply/-Supply/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.
Ja:
Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.
Nein:
es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Unbedingt die Hinweisseite Beschaltung von 0/4..20 mA Differenzeingängen (siehe z. B. Dokumentation zu den Klemmen EL30xx) beachten!
Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4 mA/>20 mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.
Bei unipolaren Klemmen/ Boxen (und verwandten Produktgruppen) ist üblicherweise eine interne Diode vorhanden, dann ist die Polarität/Stromrichtung zu beachten:
Anschluss extern versorgte Sensoren
Einordnung der Beckhoff-Klemmen/ Boxen - Beckhoff 0/4-20mA Klemmen/ Boxen (und verwandten Produktgruppen) sind als differentiell und single-ended verfügbar:
Single-ended EL3x4x: 0-20 mA, EL3x5x: 4-20 mA, genauso KL und verwandten Produktgruppen | differentiell EL3x1x: 0-20 mA, EL3x2x: 4-20 mA, genauso KL und verwandten Produktgruppen
Stromvorzugsrichtung da interne Diode | Stromvorzugsrichtung da interne Diode
Sind für den Anschluss von extern versorgenden Sensoren im 3/4-Leiter-Anschluss konzipiert. | Die Klemme/ Box ist eine passive differentielle Strommessvorrichtung, „passiv“ bedeutet, dass keine Sensorspeisung erfolgt.
Sind für den Anschluss von selbstversorgenden Sensoren im 2-Leiter-Anschluss konzipiert |
Single-ended
Differential
2-, 3- und 4-Leiter-Anschluss an Single Ended - und Differenz Eingänge


Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung und Bezugsmasse (bezogen auf Differenzeingänge)
Gleichtaktspannung (CommonMode, Ucm) wird als der Mittelwert der Spannungen an den einzelnen Anschlüssen/Eingängen definiert und wird gegen eine Bezugsmasse gemessen/angegeben.
Gleichtaktspannung (Ucm)
Bei der Definition des zulässigen Gleichtaktspannungsbereiches und bei der Messung der Gleichtaktunterdrückung (CMRR, common mode rejection ratio) bei differenziellen Eingängen ist die Definition der Bezugsmasse wichtig.
Die Bezugsmasse ist auch das Potential, gegen welches der Eingangswiderstand und die Eingangsimpedanz bei single-ended-Eingängen bzw. der Gleichtaktwiderstand und die Gleichtaktimpedanz bei differenziellen Eingängen gemessen werden.
Die Bezugsmasse ist an/bei der Klemme/ Box i.d.R. zugänglich. Orte dafür können Klemmkontakte, Powerkontakte/ Powerleitung oder auch nur eine Tragschiene sein. Zur Verortung siehe Dokumentation, die Bezugsmasse sollte beim betrachteten Gerät angegeben sein.
Bei mehrkanaligen Klemmen/ Boxen mit resistiver (=direkter, ohmscher, galvanischer) oder kapazitiver Verbindung zwischen den Kanälen ist die Bezugsmasse vorzugsweise der Symmetriepunkt aller Kanäle, unter Betrachtung der Verbindungswiderstände.
Beispiele für Bezugsmassen bei Beckhoff IO Geräten:
1.
internes AGND (analog GND) herausgeführt:
EL3102/EL3112, resistive Verbindung der Kanäle untereinander
2.
0V-Powerkontakt:
EL3104/EL3114, resistive Verbindung der Kanäle untereinander an AGND, AGND niederohmig verbunden mit 0V-Powerkontakt
3.
Erde bzw. SGND (shield GND):
–
EL3174-0002: Kanäle haben keine resistive Verbindung untereinander, aber sind kapazitiv durch Ableitkondensatoren an SGND gekoppelt
–
EL3314: keine interne Masse auf die Klemmpunkte herausgeführt, aber kapazitive Kopplung an SGND


Spannungsfestigkeit

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Spannungsfestigkeit
Spannungsfestigkeit
Es ist zu unterscheiden zwischen:
▪
Spannungsfestigkeit (Zerstörgrenze): eine Überschreitung kann irreversible Veränderungen an der Elektronik zur Folge haben, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
▪
Empfohlener Einsatzspannungsbereich: Bei einer Überschreitung kann nicht mehr von einem spezifikationsgemäßem Betrieb ausgegangen werden, Wertbetrachtung dabei
–
gegen eine festgelegte Bezugsmasse oder
–
differentiell
Empfohlener Einsatzspannungsbereich
Es können in den Gerätedokumentationen besondere Spezifikationsangaben dazu und zur Zeitangabe gemacht werden, unter Berücksichtigung von:
▪
Eigenerwärmung
▪
Nennspannung
▪
Isolationsfestigkeit
▪
Flankensteilheit der Anlege-Spannung bzw. Haltedauern
▪
Normatives Umfeld (z.B. PELV)


Zeitliche Aspekte der analog/digital Wandlung

Inbetriebnahme [image] Hinweise zu analogen Spezifikationen [image] Zeitliche Aspekte der analog/digital Wandlung
Zeitliche Aspekte der analog/digital Wandlung
Die Umwandlung des stetigen analogen elektrischen Eingangssignals in eine wertdiskrete digitale und maschinenlesbare Form wird in den Beckhoff analogen Eingangsbaugruppen EL/KL/EP mit sog. ADC (analog digital converter) umgesetzt. Obgleich verschiedene ADC-Technologien gängig sind, haben sie alle aus Anwendersicht ein gemeinsames Merkmal: nach dem Ende der Umwandlung steht ein bestimmter digitaler Wert zur Weiterverarbeitung in der Steuerung bereit. Dieser Digitalwert, das sog. Analoge Prozessdatum, steht in einem festen zeitlichen Zusammenhang mit der „Ur-Größe“, dem elektrischen Eingangswert. Deshalb können für Beckhoff analoge Eingangsgeräte auch entsprechende zeitliche Kenndaten ermittelt und spezifiziert werden.
In diesen Prozess sind mehrere funktionale Komponenten involviert, die mehr oder weniger stark ausgeprägt in jeder AI (analog input) Baugruppe wirken:
▪
die elektrische Eingangsschaltung
▪
die Analog/Digital-Wandlung
▪
die digitale Weiterverarbeitung
▪
die finale Bereitstellung der Prozess- und Diagnosedaten zur Abholung an den Feldbus (EtherCAT, K-Bus etc.)
Signalverarbeitung Analogeingang
Aus Anwendersicht sind dabei zwei Aspekte entscheidend:
▪
„Wie oft bekomme ich neue Werte?“, also eine Sampling-Rate im Sinne einer Schnelligkeit in Bezug auf das Gerät/den Kanal
▪
Wieviel Verzögerung verursacht die (gesamte) AD-Wandlung des Gerätes/des Kanals?
Also Hard- und Firmware-Teile in toto. Aus technologischen Gründen muss zur Bestimmung dieser Angabe die Signalcharakteristik betrachtet werden: je nach Signalfrequenz kann es zu unterschiedlichen Laufzeiten durch das System kommen.
Dies ist die „äußere“ Betrachtung des Systems „Beckhoff AI Kanal“ – intern setzt sich insbesondere die Signalverzögerung aus den verschiedenen Anteilen Hardware, Verstärker, Wandlung selbst, Datentransport und Verarbeitung zusammen. Auch kann ggf. intern eine höhere Abtastrate verwendet werden (z.B. bei deltaSigma-Wandlern) als „außen“ aus Anwendersicht angeboten wird. Dies ist aber für ein nutzseitige Betrachtung der Komponente „Beckhoff AI Kanal“ normalerweise ohne Belang bzw. wird entsprechend spezifiziert, falls es doch für die Funktion relevant ist.
Damit können für Beckhoff AI Geräte folgende Spezifikationsangaben zum AI Kanal aus zeitlicher Sicht für den Anwender angegeben werden:
1. Minimale Wandlungszeit [ms, µs]
Dies ist der Kehrwert der maximalen Sampling-Rate [Sps, Samples per second]:
Gibt an, wie oft der analoge Kanal einen neu festgestellten Prozessdatenwert zur Abholung durch den Feldbus bereitstellt. Ob der Feldbus (EtherCAT, K-Bus) diesen dann auch genauso schnell (also im Gleichtakt), schneller (weil der AI Kanal im langsame FreeRun läuft) oder langsamer (z.B. bei Oversampling) abholt, ist dann eine Frage der Einstellung des Feldbusses und welche Betriebsmodi das AI Gerät unterstützt.
Bei EtherCAT Geräten zeigt das sog. ToggleBit bei den Diagnose-PDO an (indem es toggelt), dass ein neu ermittelter Analogwert vorliegt.
Entsprechend kann eine maximale Wandlungszeit, also eine minimal vom AI Gerät unterstützte Samplingrate spezifiziert werden.
Entspricht IEC 61131-2 Kap 7.10.2 2) „Abtast-Wiederholzeit“
2. Typ. Signalverzögerung
Entspricht IEC 61131-2 Kap 7.10.2 1) „Abtastdauer“. Sie inkludiert nach dieser Betrachtung alle geräteinternen Hard- und Firmware-Anteile, aber nicht „äußere“ Verzögerungsanteile aus dem Feldbus oder der Steuerung (TwinCAT).
Diese Verzögerung ist insbesondere relevant für absolute Zeitbetrachtungen, wenn AI Kanäle zum Amplitudenwert auch einen zugehörigen Zeitstempel (timestamp) mitliefern – von dem ja angenommen werden darf, dass er in seinem Zeitwert zu dem außen ehemals physikalisch anliegenden Amplitudenwert passt.
Aufgrund der frequenzabhängigen Laufzeit eines Signals, kann ein dezidierter Wert nur für ein gegebenes Signal spezifiziert werden. Der Wert ist auch abhängig von ggf. veränderlichen Filtereinstellungen des Kanals.
Eine typische Charakterisierung in der Gerätedokumentation kann sein:
2.1 Signalverzögerung (Sprungantwort)
Stichworte: Einschwingzeit
Das Rechtecksignal kann extern mit einem Frequenzgenerator (Impedanz beachten!) erzeugt werden.
Als Erkennungsschwelle wird die 90% Grenze verwendet.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem (idealen) elektrischen Rechtecksignal und der Zeitpunkt wo der analoge Prozesswert die 90% Amplitude erreicht hat.
Diagramm Signalverzögerung (Sprungantwort)
2.2 Signalverzögerung (linear)
Stichwort: Gruppenlaufzeit
Beschreibt die Verzögerung eines frequenzkonstanten Signals
Testsignal kann extern mit einem Frequenzgenerator erzeugt werden, z.B. als Sägezahn oder Sinus. Referenz wäre dann ein zeitgleiches Rechtecksignal.
Die Signalverzögerung [ms, µs] ist dann der zeitliche Abstand zwischen dem eingespeisten elektrischen Signal einer bestimmten Amplitude und dem Moment wo der analoge Prozesswert denselben Wert erreicht.
Dazu muss die Testfrequenz in einem sinnvollen Bereich gewählt werden; diese kann z.B. bei 1/20 der maximalen Sampling-Rate liegen.
Diagramm Signalverzögerung (linear)
3. Weitere Angaben
Weitere Angaben können in der Spezifikation optional angeführt sein, wie z.B.
▪
Tatsächliche Sampling-Rate des ADC (wenn unterschiedlich von der Kanal-Sampling-Rate)
▪
Zeit-Korrekturwerte für Laufzeiten bei unterschiedlichen Filtereinstellungen
▪
usw.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Kalibrierungs-Zertifikat
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Kalibrierungs-Zertifikat

Anhang [image] Kalibrierungs-Zertifikat
Kalibrierungs-Zertifikat
Für die hochpräzisen Klemmen EL320x-0020 wird ein individuelles Kalibrierungs-Zertifikat ausgestellt, dass Sie im Downloadbereich auf der Beckhoff-Website herunterladen können.
Unter http://www.beckhoff.de/certificates ist das Zertifikat anhand einer ID zu identifizieren. Diese ID ist auf die Klemme aufgelasert (siehe Abb. „Aufgelaserte ID“)
Aufgelaserte ID


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL3201
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02 | 03 | EL3201-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 10* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3201-0000-0019 | 2012/07
 |  | EL3201-0000-0020 | 2014/07
 |  | EL3201-0000-0021 | 2015/01
 |  | EL3201-0000-0022 | 2016/01
EL3201-0010
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02 | 03 | EL3201-0010-0016 | 2008/11
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0010-0017 | 2010/04
03 - 09* | 07* |  | 2010/06
 |  | EL3201-0010-0018 | 2012/06
 |  | EL3201-0010-0019 | 2012/07
 |  | EL3201-0010-0020 | 2014/07
 |  | EL3201-0010-0021 | 2015/01
 |  | EL3201-0010-0022 | 2016/02
EL3201-0020
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02 | 03 | EL3201-0020-0016 | 2008/11
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0020-0017 | 2010/04
03 - 10* | 07* |  | 2010/06
 |  | EL3201-0020-0018 | 2012/06
 |  | EL3201-0020-0019 | 2012/07
 |  | EL3201-0020-0020 | 2014/07
 |  | EL3201-0020-0021 | 2015/01
 |  | EL3201-0020-0022 | 2016/02
EL3202
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02 | 03 | EL3202-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
03 - 12* | 06 | EL3202-0000-0017 | 2010/04
 | 07* | EL3202-0000-0018 | 2012/06
 |  | EL3202-0000-0019 | 2012/07
 |  | EL3202-0000-0020 | 2014/07
 |  | EL3202-0000-0021 | 2015/01
 |  | EL3202-0000-0022 | 2016/01
EL3202-0010
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 01 | 05 | EL3202-0010-0016 | 2009/07
 | 06 | EL3202-0010-0017 | 2010/04
01 - 09* | 07 |  | 2010/06
 | 08 |  | 2010/10
 | 09 |  | 2011/07
 | 10* |  | 2011/09
 |  | EL3202-0010-0018 | 2012/06
 |  | EL3202-0010-0019 | 2012/07
 |  | EL3202-0010-0020 | 2014/07
 |  | EL3202-0010-0021 | 2015/01
 |  | EL3202-0010-0022 | 2016/01
EL3202-0020
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
01 - 09* | 09 | EL3202-0020-0017 | 2011/02
 | 10* |  | 2011/09
 |  | EL3202-0020-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
 |  | EL3202-0020-0022 | 2016/01
EL3204
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02 | 03 | EL3204-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
03 - 11* | 06 | EL3204-0000-0017 | 2010/04
 | 07* |  | 2011/06
 |  | EL3204-0000-0018 | 2012/07
 |  | EL3204-0000-0019 | 2014/07
 |  | EL3204-0000-0020 | 2015/01
 |  | EL3204-0000-0021 | 2016/01
EL3204-0200
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02* | 01 | EL3204-0200-0016 | 2013/08
 | 02* | EL3204-0200-0017 | 2014/04
 |  | EL3204-0200-0018 | 2016/02
EL3208
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 04* | 01* | EL3208-0000-0017 | 2014/04
 |  | EL3208-0000-0018 | 2016/02
EL3214
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 01* | 01* | EL3214-0000-0016 | 2015/01
 |  | EL3214-0000-0017 | 2017/06
EL3214-0090
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 02* | 01 | EL3214-0090-0016 | 2017/02
 | 02* |  | 2018/09
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.