EL320x - Eingangsklemmen Pt100 (RTD)

BECKHOFF Feldbuskomponenten

Dokumentation zu

EL3201, EL3202, EL3204

1-, 2-, 4 kanalige Eingangsklemmen Pt100 (RTD)

EL3201-0010, EL3202-0010

1-, 2 kanalige Eingangsklemmen Pt100 (RTD), hochpräzise

EL3201-0020, EL3202-0020

1-, 2 kanalige Eingangsklemmen Pt100 (RTD), hochpräzise mit Kalibrierungszertifikat

EL3204-0200

4 kanalige Universaleingangsklemme für RTD bis 240 kΩ, NTC 20 k, 16 Bit

Version: 3.1
Datum: 01.04.2015

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Version | Kommentar
3.1 | - Update Kapitel "Technische Daten" - Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt - Strukturupdate - Update Revisionsstand
3.0 | - Strukturupdate
2.9 | - EL3204-0200 ergänzt - Strukturupdate
2.8 | - Kapitel "Technologie" aktualisiert
2.7 | - Kapitel "Technologie RTD-Messung" aktualisiert, EL3204-0200 ergänzt
2.6 | - Kapitel "Technologie" aktualisiert
2.5 | - Kapitel "RTD-Technologie" hinzugefügt
2.4 | - Update Kapitel "Technologie"
2.3 | - Hinweis zum Anschluss analoger Signalleitungen ergänzt
2.2 | - Hinweis Kalibrierungs-Zertifikat ergänzt - Update Struktur
2.1 | - EL3202-0020 ergänzt
2.0 | - Datenflussschema ergänzt, Technische Hinweise ergänzt
1.9 | - Technische Hinweise ergänzt
1.8 | - Technische Hinweise ergänzt
1.7 | - Technische Daten ergänzt und korrigiert
1.6 | - Technische Korrekturen, Ergänzung EL3202-0010
1.5 | - KT/KTY Kennlinien hinzugefügt, Ergänzung Limit
1.4 | - Technische Änderungen hinzugefügt
1.3 | - Technische Änderungen hinzugefügt
1.2 | - EL3201-0010, EL3201-0020 hinzugefügt
1.1 | - Technische Daten korrigiert
1.0 | - Technische Daten ergänzt, erste Veröffentlichung
0.2 | - Technische Daten ergänzt
0.1 | - vorläufige Dokumentation für EL320x


Versionsidentifikation

BECKHOFF: Vorwort

Versionsidentifikation EtherCAT Geräte

Bezeichnung

Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus

  • Familienschlüssel
  • Typ
  • Version
  • Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017

Hinweise

  • die oben genannten Elemente ergeben die technische Bezeichnung
  • Die Bestellbezeichnung setzt sich dagegen zusammen aus
    - Familienschlüssel (EL, EP, CU, ES, KL, CX, .....
    - Typ
    - Version
  • Die Revision gibt den technischen Fortschritt wie z.B. Featureerweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
    Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z.B. in der Dokumentation angegeben.
    Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
    Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. 1.
  • Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.

Identifizierungsnummer

Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:

Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer

Als Seriennummer bezeichnet man im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit uneindeutig eine ganze Produktions-Charge.

Aufbau der Seriennummer: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02

Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):

Syntax: D ww yy x y z u

D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1

Eindeutige Seriennummer/ID

Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige, fortlaufende Seriennummer.

Siehe dazu auch weiterführende Dokumentation im Bereich

  • IP67: EtherCAT Box
  • Safety: TwinSafe
Beispiele für Kennzeichnungen:

Abb. 1: EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)

Abb. 2: EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Chargennummer

Abb. 3: CU2016 Switch mit Chargennummer

Abb. 4: EL3202-0020 mit Chargennummern 26131006 und eindeutiger D-Nummer 204418

Abb. 5: EP1258-00001 IP67 EtherCAT Box mit Chargennummer 22090101 und Seriennummer 158102

Abb. 6: EP1908-0002 IP76 EtherCAT Safety Box mit Chargennummer 071201FF und Seriennummer 00346070

Abb. 7: EL2904 IP20 Safety Klemme mit Chargennummer/DateCode 50110302 und Seriennummer 00331701


Einführung

Ein-, zwei- und vierkanalige analoge Eingangsklemmen PT100 (RTD)

Die analogen Eingangsklemmen EL320x erlauben den direkten Anschluss von Widerstandssensoren. Die Schaltung der EL3204 kann Sensoren in 2-Leitertechnik, die der EL3202 in 2- und 3-Leitertechnik betreiben, die EL3201 zusätzlich noch 4-Leitertechnik. Es werden diverse Sensorkennlinien (PT100, PT1000, NI120, NI1000, KTY-Typen u.a.) unterstützt.

Die EL3201-0010 ist die hochpräzise Ausführung der einkanaligen Klemme (EL3202-0010, zweikanalig) mit einem Messfehler < ±0,1 °C bei Pt-Sensoren (Umgebungstemperatur von 40°C). Diese Klemmen werden in 4-Leitertechnik betrieben. Die hochpräzisen EL3201-0020 und EL3202-0020 werden zusätzlich noch mit einem Kalibrierungszertifikat ausgeliefert.

Die Klemmen der Serie EL320x-xxxx können die Temperatur am Messort messen oder den Widerstandwert der Sensoren direkt ausgeben. Bei Temperaturmessung wird der Temperaturwert über die in der Klemme hinterlegten Kennlinien berechnet.

Mit der EL3204-0200 sind beliebige RTD im Bereich 100 Ohm bis 240 kOhm einsetzbar. Die Umrechnung der Widerstandswerte (Linearisierung) erfolgt in der Klemme wahlweise nach voreingestellten Kennlinien, Umrechnungsformeln mit spezifischen Materialkennwerten (bspw. nach IEC 60751, Steinhart-Hart-Gleichung, B-Parameter-Gleichung), oder nach einer frei programmierbaren Umrechnungstabelle.

Die EtherCAT-Klemmen zeigen ihren Signalzustand durch Leuchtdioden an. Sensorstörungen (z. B. Drahtbruch) signalisieren Error-LEDs.

Quick-Links

• EtherCAT Funktionsgrundlagen
• Technologie EL320x
• Konfigurationserstellung TwinCAT
• CoE-Objektbeschreibung und Parametrierung
• Statuswort
• Prozessdaten und Betriebsmodi
• Einstellungen und Anwendungshinweise EL320x-00xx

• Einstellungen und Anwendungshinweise EL3204-0200


Technologie

BECKHOFF EL320x: Inbetriebnahme

Technologie RTD-Messung

Inhaltsverzeichnis
• Funktion
- Hinweis zur Serie EL320x-0010/-0020 (hochpräzise)
• Ratiometrische Spannungsmessung
• Anschlusstechniken
- Beispiel für Leitungskompensation im 2-Leiter-Modus
• Übersicht geeigneter Widerstandssensoren

Funktion

Die analoge Eingangsklemmen EL320x-xxxx erlauben den direkten Anschluss von Widerstandssensoren im Bereich 0 - 4096 Ohm (EL3204-0200: bis 240 kOhm, siehe besondere Hinweise)

Funktionen:

  • Widerstandsmessung
    • Messbereich 0 bis 1047 Ω: Auflösung 1/64 Ohm
    • Messbereich 0 bis 4095 Ω: Auflösung 1/16 Ohm
    • Der Einsatz der Klemme im Bereich 0 bis 10 Ohm wird aufgrund der relativ geringen Messgenauigkeit nicht empfohlen. Für solche Messungen sind Widerstandsmessklemmen wie die EL3692 in 4-Leiter-Messung zu verwenden.
    • Bei der EL3201 und EL3202 ist die externe Brücke zwischen +R und +RL beim 3-Leiter-Modus einzusetzen
  • Temperaturmessung
    der ermittelte Sensorwiderstand wird vom internen µC über die gewünschte Linearisierungskennlinie direkt in eine Temperatur umgerechnet
    • Standardauflösung 1/10 °C (1 Digit = 0,1 °C) entsprechend einem theoretisch darstellbaren Temperaturbereich [-3276,7 ... 3276,8 °C]
      Es ist der für den jeweiligen Sensor physikalisch vorgegebene Temperaturbereich zu beachten!
    • Es sind in der EL320x-Serie diverse PTC-Sensor-Kennlinien über ihren kompletten Messbereich zur Auswahl implementiert: Pt/Ni xxxx, KTY xx
    • Skalierung und Präsentation können geändert werden
    • Falls ein Sensor verwendet werden soll, der nicht bereits in der EL320x implementiert ist, kann die EL3204-0200 verwendet werden
      Durch die freie Programmierbarkeit kann die EL3204-0200 auf jede Sensorkennlinie im zulässigen Widerstandbereich eingestellt werden.

Weitere Hinweise:

  • Die Widerstandermittlung erfolgt durch ratiometrische Spannungsmessung, siehe unten..
  • Der Fehlerzustand "Drahtbruch" wird als Overrange detektiert, als Error an die Steuerung gemeldet und durch die ERROR-LED angezeigt.
  • Der Fehlerzustand "Kurzschluss" wird als Underrange detektiert, wenn der Widerstand kleiner ist als der kleinste Widerstand des Messbereichs, so wie als Error an die Steuerung gemeldet und durch die ERROR-LED angezeigt.
  • Ab Firmware 06 (EL3201, EL3202-xxxx, EL3204) sind Kennlinien für KT/KTY-Sensoren implementiert und über das CoE-Verzeichnis anwählbar.
  • Die Ausgabe des Messwertes erfolgt im Auslieferungszustand in 1/10° C Schritten in Zweierkomplement-Darstellung (integer).
  • Über CoE 80n0:02 sind andere Darstellungsarten anwählbar z.B. hohe Auflösung mit 1/100 °C
    Bei Verwendung der hohen Auflösung ist durch das 2-Byte-PDO ein Temperaturbereich von -320 ... 320°C (-32566 .... 32567) messbar.

Abb 1: Darstellung der Messung und Berechnung Widerstand/Temperatur

Hinweis zur Serie EL320x-0010/-0020 (hochpräzise)

Durch besondere Eigenschaften in Hardware und Firmware ist die EL320x-0010/0020 in der Lage, den Widerstandswert und damit ggf. die Temperatur hochgenau zu messen. Dabei ist zu beachten:

Hinweis 		Erhöhte Genauigkeit EL320x-00x0
Bei den hochpräzisen Klemmen soll die Einstellungen im Objekt 80n0 / RTD-Settings nicht verändert werden! Die hochgenaue Widerstandermittlung/Temperaturmessung kann nur im Bereich 10 ... 220 Ohm erfolgen, dies entspricht einem PT100-Messbereich von -200 ... 320°C.
Um die hohe Genauigkeit darstellen zu können, ist die 0,01°C/Digit Darstellung voreingestellt. Die erhöhte Genauigkeit der EL320x-00x0 gilt deshalb nur für folgende Einstellungen:
  • Widerstandsmessung oder Pt100-Kennlinie (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) - andere Kennlinie ohne Gewähr!
  • Umgebungstemperatur von 40°C
  • 4-Leiter-Anschlusstechnik
  • Messbereich -200 bis 320°C
  • 50 Hz Filter

Temperaturen bzw. Widerstände außerhalb des o.g. Bereichs können nicht hochgenau gemessen werden. Werden diese Eckwerte verlassen, verhält sich die hochgenaue Klemme wie eine Klemme mit Standard-Genauigkeit.

Ratiometrische Spannungsmessung

Die Widerstandsermittlung der EL320x-xxxx erfolgt ratiometrisch durch Spannungsvergleich, siehe Abb. 2:
  • Eine Konstantspannung von 2,5 V wird durch einen hochgenauen bekannten Referenzwiderstand Rref und den Sensor Rt geführt
    • EL3204-0200: 120 kOhm Referenzwiderstand
    • alle anderen EL320x: 5 kOhm Referenzwiderstand
  • Durch Vergleich der beiden Spannungen, U1 an Referenz und U2 am Sensor kann auf den Sensorwiderstand geschlossen werden
  • Der Messstrom durch den Sensor ist damit abhängig vom Sensorwiderstand, dies ist bei Fragen zur Sensoreigenerwärmung zu berücksichtigen
    Beispiel: ein PT1000 bewirkt bei 20°C und damit 1000 Ohm Eigenwiderstand an einer EL3204 einen Messstrom von 0,1 mA.

Hinweis 		Beschaltung der Eingangskanäle
Auf Grund dieses Messprinzips (widerstandsbehafteter Temperatursensor) darf keine Parallelschaltung von einem Sensor an 2 oder mehr Eingangskanäle erfolgen!

Anschlusstechniken

Die elektrische Verbindung eines Widerstandssensors zur EL320x kann im Zweileiter-, Dreileiter- oder Vierleiterverfahren (nur EL3201) erfolgen. Da das Messverfahren eine Widerstandsmessung ist, können die Sensorzuleitungen mit ihrem Eigenwiderstand die Messung verfälschen. Zu diesem Zweck sind verfügbar:

Abb. 2: Anschlusstechnik 4-Leiter und 3-Leiter

  • 4-Leiter-Sensoren: Stromführung und Spannungsmessung laufen über separate Adern. Da die Spannung von der El32xx hochohmig gemessen wird, unterliegen die Adern zur Spannungsmessung somit annähernd keinem Spannungsabfall.
  • 3-Leiter-Sensoren: diese vereinfachte Anschaltung reduziert Verkabelungskosten und kompensiert Leitungswiderstände in hohem Maße.
  • 2-Leiter-Sensoren: sehr einfache Anschaltung, nur für kurze Zuleitung empfohlen
    Die Zuleitungswiderstände können im 2-Leiter-Modus herausgerechnet werden, wenn der EL320x im CoE-Objekt 80x0:1B der Zuleitungswiderstand bekannt gegeben wird (Einheit [1/32 Ω]). Die Ermittlung des Zuleitungswiderstands kann applikationsseitig durch Messung oder durch Abgleich geschehen.

Hinweis 		Zweileiter Anschluss
Wird die EL3201/EL3202 im 2-Leiter-Anschluss betrieben, müssen der Eingang +R und +RL vom Anwender gebrückt werden.

Beispiel für Leitungskompensation im 2-Leiter-Modus

Der Leitungsquerschnitt der 50 m langen Anschlussleitung aus Kupferlitze sei 0,5 mm2. Der spezifische Widerstand von Kupfer entspricht 0,0175 Ω mm2 m-1

Ermittlung des Gesamtwiderstandes der Zuleitung):

RLges = 0,0175 Ω mm2 m-1 * (2 * 50 m / 0,5 mm2) = 3,5 Ω

Bei einer Widerstandsänderung des Pt100 von ≈0,39 Ω/K ergibt sich daraus eine Temperaturabweichung von

3,5 Ω / (0,39 Ω/°C) = 8,97 °C

wenn der Leitungswiderstand nicht berücksichtigt wird. Wenn nun die 3,5 Ohm als

3,5 Ω / (1/32) Ω = 112dez

in 8000:1B eingetragen werden, wird dies vom Messwert abgezogen, und die Temperatur entsprechend korrigiert.

Hinweis 		Steckervariante ES320x mit Pt100 / Ni100 Sensoren
Bei der Verwendung von Pt100 / Ni100 Sensoren empfehlen wir zur Vermeidung von Genauigkeitsverlusten auf Grund von Übergangswiderständen bei der Steckervariante ES320x den Einsatz der EL320x .

Übersicht geeigneter Widerstandssensoren

Folgende Widerstandssensoren sind für die Temperaturmessung mit der EL320x-0000 geeignet (Tab. 1) und können über das Objekt 80n0:19 gewählt werden:

Besondere oder abweichende Kennlinien (z. B. Pt375) können mit der frei parametrierbaren EL3204-0200 erfasst werden.

Typ | Widerstandsbereich | Implementierter Temperaturbereich
Pt100 (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) | ~ 10 ... ~390 Ohm | -200°C bis 850°C ( für hochpräzise Klemmen sie Hinweis!)
Ni100 |  | -60°C bis 250°C
Pt1000 (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) | ~180 ... ~ 3900 Ohm | -200°C bis 850°C
Pt500 |  | -200°C bis 850°C
Pt200 |  | -200°C bis 1370°C
Ni1000 |  | -60°C bis 250°C
Ni1000 100°C: 1500 Ohm |  | -30 bis 160°C
Ni120 |  | -60°C bis 320°C
KT100/110/130/210/230 KTY10/11/13/16/19 | ~500 ... ~2200 Ohm | -55...150°C
KTY81/82-110,120,150
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 | ~500 ... ~2500 Ohm | -50...175°C
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 | ~350 ... ~2500 Ohm | -40...300°C
KTY84-151
KTY21/23-6 | ~500 ... ~4000 Ohm | -50...150°C
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7

Tab 1: Geeignete Widerstandssensoren für EL320x-0000


Technische Daten

Technische Daten | EL3201 | EL3201-0010, EL3201-0020 | EL3202 | EL3202-0010, EL3202-0020 | EL3204 | EL3204-0200
Anzahl Eingänge | 1 | 1 | 2 | 2 | 4 | 4
Sensorarten | Pt100, Pt200, Pt500, Pt1000, Ni100, Ni120, Ni1000 KT/KTY ab Firmware 06 Widerstandsmessung 10 Ω...1 kΩ bzw. 10 Ω...4 kΩ (z. B. für Poti-Anschluss ) |  |  |  |  | beliebige RTD im Bereich 100 Ω…240 kΩ
Anschlusstechnik | 2-, 3-, 4-Leiter | 4-Leiter | 2-, 3-Leiter (Voreinstell5ng: 3-Leiter) | 4-Leiter | 2-Leiter | 2-Leiter
Temperaturbereich | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) Hochpräzise Messung nur für Pt100 Sensoren, Messbereich -200…+320°C, siehe Hinweis! | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) | Bereichsabhängig: -200…+850°C (Pt-Sensoren) -60…+250°C (Ni-Sensoren) Hochpräzise Messung nur für Pt100 Sensoren, Messbereich -200…+320°C, siehe Hinweis! | Bereichsabhängig: -200…+850°C (Pt-Sensoren); -60…+250°C (Ni-Sensoren) | Bereichsabhängig
Auflösung (default) | 0,1°C pro Digit | 0,01°C pro Digit | 0,1°C pro Digit | 0,01°C pro Digit | 0,1°C pro Digit | default: 0,1°C pro Digit bei Temperaturmessung
Wandlungszeit | ca. 4 .. 500 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 24 ms voreingestellt |  | ca. 800 ms .. 2 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 85 ms voreingestellt |  |  | ca. 4 .. 500 ms (konfigurierbar), je nach Konfiguration und Filtereinstellung ca. 24 ms voreingestellt
Messstrom (abh. vom Sensorelement und Temperatur) | typ. < 0,5 mA |  |  |  |  | typ. < 0,03 mA
Messfehler | < ±0,5 °C bei Pt-Sensoren | < ±0,1 °C (für Pt100-Sensoren, Umgebungstemperatur von 40°C, 4-Leiter-Anschlusstechnik, Messbereich -200 bis 320°C), 50 Hz Filter | < ±0,5 °C bei Pt-Sensoren | < ±0,1 °C (für Pt100-Sensoren, Umgebungstemperatur von 40°C, 4-Leiter-Anschlusstechnik, Messbereich -200 bis 320°C), 50 Hz Filter | < ±1.0 °C bei Pt-Sensoren | < ±0,3% vom Messbereichsendwert jeweiligen bei Widerstandsmessung
Breite im Prozessabbild | max. 4 Byte Input |  | max. 8 Byte Input |  | max. 16 Byte Input | max. 16 Byte Input
Spannungsversorgung für interne E-Bus-Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 190 mA |  |  |  |  | typ. 150 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich) 0°C ... +55°C (gemäß cULus für Kanada und USA) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) | 0°C ... +55°C | -25°C ... +60°C (erweiterter Temperaturbereich) 0°C ... +55°C (gemäß cULus für Kanada und USA) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) | 0°C ... +55°C | -25°C ... +60°C (erweiterter Temperaturbereich) 0°C ... +55°C (gemäß cULus für Kanada und USA) 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C | -25°C ... + 85°C | -40°C ... + 85°C | -25°C ... + 85°C | -40°C ... + 85°C | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27 |  | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27 | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


RTD-Technologie

BECKHOFF: RTD Technologie

RTD Technologie

Bestimmte Werkstoffe verändern ihren elektrischen Widerstand wenn sich die Temperatur des Werkstoffes ändert. Durch diese Eigenschaft können sie als Sensor zur Temperaturmessung verwendet werden. Solch ein RTD-Element (Resistance Temperature Device) oder Thermistor weist dann eine materialabhängige bekannte Charakteristik auf, nämlich wie sich der Widerstand in Abhängigkeit von der Temperatur ändert, die sog. Kennlinie. In erster Näherung kann diese Kennlinie als lineare Gleichung aufgefasst werden:

Der Faktor k kann positiv oder negativ sein und muss vom Sensorhersteller angegeben werden:

  • positiver Koeffizient (PTC): Widerstand steigt mit steigender Temperatur, wird also schlechter leitend, Sensor wird dann als Kaltleiter bezeichnet
  • negativer Koeffizient (NTC): Widerstand steigt mit fallender Temperatur, wird also besser leitend, Sensor wird dann als Heißleiter bezeichnet

Je größer der Koeffizient, desto empfindlicher ist der Sensor.

Hinweis 		Temperaturmessung
Diese Art der Temperaturmessung ist abzugrenzen von den Thermoelementsensoren: diese erzeugen von sich aus eine (kleine) Spannung an der Kontaktstelle zweier unterschiedlicher Metalle, welche dann gemessen wird.

In einem sehr kleinen Messbereich können fast alle Materialien durch solch eine lineare Kennlinie beschrieben werden. Oft soll jedoch über einen großen Messbereich z.B. mehrere 10 oder 100 K gemessen werden. In solchen Bereichen muss die Kennlinie bei vielen Materialien durch nichtlineare Gleichungen höherer Ordnung oder mit exponentiellen Komponenten beschrieben werden. Beispiele für solche Gleichungen sind

  • Platin/Pt-Sensoren (PTC/Kaltleiter) nach IEC 60751:2008
    für den Bereich -200.. 0 °C:

    für den Bereich 0°C..850°C

    Die Koeffizienten A, B, C sind vom Sensorhersteller anzugeben bzw. der Norm zu entnehmen. Der Parameter R0 gibt den Widerstand in Ohm des Platinsensors bei T=0°C an. Die Sensoren werden nach diesen Bezeichnungen qualifiziert, so spricht man vom Pt100, wenn R0=100 Ω bei T=0°C beträgt.
  • Steinhart-Hart (für NTC/Heißleiter)

    Die Koeffizienten a,b,c sind vom Sensorhersteller anzugeben, diese können auch durch Messung des Widerstandes bei drei bekannten Temperaturen bestimmt werden.
  • B-Parameter-Gleichung (für NTC/Heißleiter)

    Die Koeffizienten RT0, B, T0 sind vom Sensorhersteller anzugeben, diese können auch durch Messung des Widerstandes bei zwei bekannten Temperaturen bestimmt werden.
    Die B-Parameter-Gleichung stellt eine Vereinfachung der Steinhart-Hart-Gleichung da. Der B-Parameter selber ist nur in einem kleinen Bereich konstant, z.B. zwischen 25°C.. 50°C oder 25°C.. 85°C dieser wird wie folgt Bezeichnet: B 25/50 bzw. B25/85. Die Genauigkeit der Gleichung hängt stark von dem B-Parameter ab, je größer der Messbereich, desto geringer die Genauigkeit. Wird ein größerer Messbereich benötigt, so ist die Steinhart-Hart-Gleichung vorzuziehen.
  • und weitere

Jeweils eine typ. Kennlinie für die NTC- und PTC-Familien ist in Abb. 1 gezeigt:

Es gibt also nicht DEN allgemeinen NTC- oder PTC-Sensor, sondern dies sind Bezeichnungen für Sensor-Familien mit einem bestimmten Verhalten.

Für weit verbreitete Sensoren/Kennlinien wie PT100, werden diese Kennlinien bereits fest in die Messgeräte implementiert. Es ist anwenderseitig zu prüfen, ob ein vorgesehener Sensor vom Messgerät unterstützt wird, dabei gelten die Kriterien

  • Temperaturbereich: unterstützt der Sensor den vorgesehenen Temperaturbereich?
  • Messbereich: kann der Sensor-Widerstand im beabsichtigten Temperaturbereich gemessen werden?
  • Kennlinie: kann der gemessene Widerstand entsprechend in Temperatur umgerechnet werden? (Basispunkt, Steigung/Koeffizienten)
  • Geschwindigkeit: wie oft wird der Widerstand gemessen?

In ganz grundsätzlicher Art kann ein Sensorhersteller die Kennlinie seines Sensors natürlich auch als Werte-Tabelle veröffentlichen.

Hinweis 		Widerstandsmessung
Zur Ermittlung des Widerstands wird üblicherweise ein geringer Messstrom im mA-Bereich (< 5 mA) durch den Sensor geschickt und die resultierende Spannung gemessen. Dabei sind 3 Effekte zu berücksichtigen:
  • der Messstrom kann zu einer Eigenerwärmung des Sensors führen. Dies hat üblicherweise aber nur geringen Einfluss auf die Messgenauigkeit.
    Für Tiefsttemperaturanwendungen sind spezielle Sensoren gebräuchlich.
  • die Zuleitungen zum Sensor sind immer ebenfalls widerstandsbehaftet und bringen einen (meist) konstanten zusätzlichen Widerstand in die Messung ein. Kompensation kann erfolgen durch
    • 3- oder 4-Leiter-Anschluss des Sensors
    • manuelle Berücksichtigung des bekannten Leitungswiderstands in der Berechnung
    • Sensor mit höherem Nennwiderstand verwenden - dann fallen die Zuleitungseffekte weniger ins Gewicht
  • Isolationsfehler oder Thermospannungen können die Messung beeinflussen.

Zur Einordnung im Folgenden eine Übersicht der NTC/PTC-Eigenschaften verschiedener Sensoren:

NTC | PTC
viele Halbleiter | viele Metalle
versch. Keramiken | versch. Keramiken
NTC20, NTC100 etc. | Pt100, Pt1000, ...
 | KTY ..
 | Ni100, Ni1000, ...
 | FeT

Hinweis 		Sensortausch
Es ist zu beachten, dass eine 1:1 Austauschbarkeit gerade von herstellerspezifizierten Sensoren nicht immer gewährleistet ist. Ggf. muss der neue Sensor in der Anlage neu eingemessen werden.


Start

Zur Inbetriebsetzung:

  • montieren Sie den EL320x wie im Kapitel Montage und Verdrahtung beschrieben
  • konfigurieren Sie den EL320x in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


EtherCAT - EtherCAT Grundlagen

BECKHOFF EtherCAT: Grundlagen der Kommunikation

EtherCAT Grundlagen

Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung

BECKHOFF EtherCAT: Grundlagen der Kommunikation

EtherCAT-Verkabelung - Drahtgebunden

Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.

Kabel und Steckverbinder

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.

EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.

Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -

Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.

Hinweis 		Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!

E-Bus-Versorgung

Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9400) zu setzen.

Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.

Abb. 1: Systemmanager Stromberechnung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT - Allgemeone Hinweise zur Watchdogeinstellung

BECKHOFF EtherCAT: Grundlagen der Kommunikation

Allgemeine Hinweise zur Watchdog-Einstellung

Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.

Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:

  • SM-Watchdog (default: 100 ms)
  • PDI-Watchdog (default: 100 ms)

SM-Watchdog (SyncManagerWatchdog)

Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.

Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.

PDI-Watchdog (Process Data Watchdog)

Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.

Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.

Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:

Abb. 1 Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog

Anmerkungen:

  • der Multiplier ist für beide Watchdogs gültig.
  • jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
  • Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
    Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.

Multiplier

Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:

1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)

Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.

Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.

Beispiel "Set SM-Watchdog"

Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.

Berechnung

Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit

VORSICHT 		VORSICHT! Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016.
In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.

VORSICHT 		VORSICHT! Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs!
Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.


EtherCAT State Machine

Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.

Es werden folgende Zustände unterschieden:

  • Init
  • Pre-Operational
  • Safe-Operational und
  • Operational
  • Boot

Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.

Init

Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init . Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.

Pre-Operational (Pre-Op)

Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.

Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.

Safe-Operational (Safe-Op)

Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).

Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.

Operational (Op)

Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.

Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.

Boot

Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.

Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Inhaltsverzeichnis
• Allgemeine Beschreibung
• Datenerhaltung
• Online/Offline Verzeichnis
• Kanalweise Ordnung

Allgemeine Beschreibung

Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.

CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.

Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.

Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind

  • Index: 0...65535
  • SubIndex: 0...255

Üblicherweise wird ein so lokalisierter Parameter geschrieben als x8010:07 mit voranstehendem "x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.

Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind

  • x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
  • x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.

Weitere wichtige Bereiche sind:

  • x4000: hier liegen in manchen EtherCAT-Geräte alternativ zum x8000-Bereich die Kanalparameter.
  • x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
  • x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)

Hinweis 		Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen.
Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..

Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:

Abb. 1: Karteireiter "CoE-Online "

In Abb. 1 sind die im Gerät "EL2502" verfügbaren CoE-Objekte von x1000 bis x1600 zusehen, die Subindizes von x1018 sind aufgeklappt.

Datenerhaltung

Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen

  • über den Systemmanager (Abb. 1) durch Anklicken
    Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
  • aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
    Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.

Hinweis 		Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.

Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.

  • Funktion wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
    Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
  • Funktion wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.

Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten in dieser Dokumentation zu entnehmen.

StartUp-Liste

Hinweis 		Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.

Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.

Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern

  • gewünschte Änderung im Systemmanager vornehmen
    Werte werden lokal im EtherCAT Slave gespeichert
  • wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
    Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.

Abb. 2: StartUp-Liste im TwinCAT System Manager

In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.

Online/Offline Verzeichnis

Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.

In beiden Fällen ist ein CoE-verzeichnis nach Abb. 1 zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.

  • wenn der Slave offline ist
    - wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
    - wird in der Identität der konfigurierte Stand angezeigt
    - wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
    - ist ein rotes Offline zu sehen

    Abb. 3: Offline-Verzeichnis
  • wenn der Slave online ist
    - wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
    - wird die tatsächliche Identität angezeigt
    - wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
    - ist ein grünes Online zu sehen

    Abb. 4: Online-Verzeichnis

Kanalweise Ordnung

Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.

Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs x8000 sieht man dies deutlich:

  • Kanal 0: Parameterbereich x8000:00 ... x800F:255
  • Kanal 1: Parameterbereich x8010:00 ... x801F:255
  • Kanal 2: Parameterbereich x8020:00 ... x802F:255
  • ...

Allgemein wird dies geschrieben als x80n0.

Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
  • Einheit 1 ns
  • Nullpunkt 1.1.2000 00:00
  • Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
  • Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


ELxxxx, KLxxxx - Tragschienenmontage

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Hinweis 		Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein.
Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie die Klemme an ihren orangefarbige Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


ELxxxx, KLxxxx - Montagevorschriften erweiterte mechanische Belastbarkeit

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Zusätzliche Prüfungen

Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:

Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms

Zusätzliche Montagevorschriften

Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:

  • Jede Einbaulage ist zulässig
  • Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
  • Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
  • Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
    64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
  • Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
  • Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
  • Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
  • Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Anschlusstechnik

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Anschlusstechnik

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Übersicht

Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:

  • Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
  • Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
  • Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.

Standardverdrahtung

Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und
integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.

Steckbare Verdrahtung

Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt.
Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.

Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.

Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.

Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.

Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.

High-Density-Klemmen (HD-Klemmen)

Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.

Hinweis 		Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.

Ultraschall-litzenverdichtete Leiter

Hinweis 		Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschall verschweißte) Leiter angeschlossen werden.
Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!

Verdrahtung

Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm

High-Density-Klemmen ELx8xx, KLx8xx (HD)

Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässige Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.

Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm

Schirmung

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Montage von passiven Klemmen

Hinweis 		Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus.
Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für Montage von passiven Klemmen (hell eingefärbt)

Beispiel 1: korrekte Konfiguration

Beispiel 2: inkorrekte Konfiguration


KLxxxx, ELxxxx - Einbaulagen

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Einbaulagen

Achtung 		Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt.

Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!

Optimale Einbaulage (Standard)

Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. 1). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.

Abb. 1: empfohlene Abstände bei Standard Einbaulage

Die Einhaltung der Abstände nach Abb. 1 wird empfohlen.

Weitere Einbaulagen

Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb 2.

Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.

Abb. 2: weitere Einbaulagen


EL320x - LEDs und Anschlussbelegung

BECKHOFF EL320x: Montage und Verdrahtung

LEDs und Anschlussbelegung

Inhaltsverzeichnis
• EL3201, EL3202
• EL3201-0010, EL3202-0010
• EL3204-0x00

EL3201, EL3202

Hinweis 		Zweileiter-Anschluss
Wird die EL3201/EL3202 im 2-Leiter-Anschluss betrieben, müssen die Eingänge +R und +RL vom Anwender gebrückt werden.

LEDs

LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1, ERROR2** | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie

** nur EL3202

Anschlussbelegung EL3201

Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
-RL1 | 4 | Eingang -RL1
... | 5 | nicht belegt
... | 6 | nicht belegt
... | 7 | nicht belegt
Shield | 8 | Schirm

Anschlussbelegung EL3202

Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
Shield | 4 | Schirm (intern verbunden mit Klemmstelle 8)
+R2 | 5 | Eingang +R2
+RL2 | 6 | Eingang +RL2
-R2 | 7 | Eingang -R2
Shield | 8 | Schirm (intern verbunden mit Klemmstelle 4)

EL3201-00x0, EL3202-0010

Hinweis 		Vierleiter-Anschluss
Die hochpräzisen Klemmen EL320x-00x0 dürfen bestimmungsgemäß nur in 4-Leiter Anschlusstechnik betrieben werden!

LEDs

LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1, ERROR2** | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie

** nur EL3202-0010

Anschlussbelegung EL3201-00x0

Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
-RL1 | 4 | Eingang -RL1
... | 5 | nicht belegt
... | 6 | nicht belegt
... | 7 | nicht belegt
Shield | 8 | Schirm

Anschlussbelegung EL3202-0010

Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
+RL1 | 2 | Eingang +RL1
-R1 | 3 | Eingang -R1
-RL1 | 4 | Eingang -RL1
+R2 | 5 | Eingang +R2
+RL2 | 6 | Eingang +RL2
-R2 | 7 | Eingang -R2
-RL2 | 8 | Eingang -RL2

EL3204-0x00

LEDs

LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware-Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
ERROR1, ERROR2, ERROR3, ERROR4 | rot | Es liegt ein Kurzschluss oder Drahtbruch vor. Der Widerstandswert befindet sich im ungültigen Bereich der Kennlinie.

Anschlussbelegung EL3204-0x00

Klemmstelle | Nr. | Kommentar
+R1 | 1 | Eingang +R1
-R1 | 2 | Eingang -R1
+R3 | 3 | Eingang +R3
-R3 | 4 | Eingang -R3
+R2 | 5 | Eingang +R2
-R2 | 6 | Eingang -R2
+R4 | 7 | Eingang +R4
-R4 | 8 | Eingang -R4


EL320x - Anschluss analoger Signalleitungen

BECKHOFF EL320x: Montage und Verdrahtung

Anschluss analoger Signalleitungen

Die RTD-Eingangsklemmen der Serie EL32xx messen den analogen Widerstand des Sensors. Der Spannungsabfall am Sensor (je nach Anschlusstechnik inkl. der Zuleitungswiderstände) ist äquivalent zum Sensorwiderstand und damit bei bekannter Sensorkennlinie ein Maß für die Temperatur des Sensors.
Damit die analogen Signale möglichst störungsfrei gemessen werden, wird im Folgenden eine Vorgehensweise zum Anschluss der analogen Signalleitungen vorgestellt.

Maßnahmen

  • zu verwendendes Sensorkabel
    • eng verdrillt
    • geschirmtes Kupfergeflecht
    • niederohmige Leitung verwenden, insbesondere im 2-Leiter-Anschluss
  • Sensor und Sensorleitungen potenzialfrei von Fremdspannungen halten
    Die GND-Anschlüsse (3/7 bei EL3201, EL3202) sind keinesfalls mit anderen Potenzialen zu verbinden.
  • Die Auswahl der Widerstandsgrößenordnung des RTD-Sensors (z.B. 100 oder 1000 Ω Nennwiderstand) sollte im Hinblick auf das Verhältnis von Sensor- zu Leitungswiderstand unter Beachtung der Anschlusstechnik (2/3/4-Leiter) erfolgen.

Maßnahmen Schirmung

Hinweis 		Schirmung Maßnahmen
Aufgrund der Komplexität im Bereich "EMV" gibt es keine allgemeingültige Handlungsrichtlinie, sondern nur technische Maßnahmen nach dem Stand der Technik, die sich mitunter auch widersprechen können. Diese sind auf Umsetzbarkeit und Wirksamkeit unter Berücksichtigung der Anlagenspezifika und nach Beurteilung durch den Anlagenerrichter anzuwenden.

Die folgenden Hinweise zur Schirmung sind als technische Vorschläge zu verstehen, die sich im praktischen Einsatz mitunter bewährt haben. Es ist in jedem Fall je nach Installation und Anlage zu prüfen, welche Maßnahmen angewendet werden können. Die Wirksamkeit ist für jede Maßnahme einzeln zu prüfen. Eine formale Übertragbarkeit von Maßnahmen auf Anlagen anderen Typs ist im Allgemeinen nicht gegeben.

Landestypische oder allgemein normative Vorgaben sind vorrangig zu beachten.

Im Folgenden ist ein Schirmungsansatz beschrieben, der in vielen Fällen eine Verbesserung der Messqualität bringt. Die Maßnahmenvorschläge sind in der tatsächlichen Anlage auf Umsetzbarkeit und Wirksamkeit zu prüfen.

  • Schirm niederohmig und 360°-leitungsumfassend auflegen
  • den Schirm beim Eintritt in den Schaltschrank leitend erden
  • Schirm an der Klemme erneut erden
    • am Klemmen-Anschlusspunkt, wenn vorhanden
    • wenn kein Klemmen-Anschlusspunkt vorhanden, möglichst nahe bei der Klemme der Schirm erden
    • zur Vermeidung von Erdschleifen kann der Schirm nach dem Schaltschrankeintritt aufgetrennt werden
      Eine kapazitive Anbindung an den Klemmen-Schirmkontakt ist möglich.
    • ungeschirmte Leitungsstrecke von > 50 cm vermeiden

Abb. 1a + 1b: Beispielhafte Schirmanbindung bei EL3202-0000 mit Schirmkontakt, bei potenziellen Störquellen innerhalb bzw. innerhalb und außerhalb des Schaltschranks


Hinweise ESI-Gerätebeschreibung

Inhaltsverzeichnis
• Installation der neuesten ESI-Device-Description
• Geräteunterscheidung
• Online Description
• Fehlerhafte ESI-Datei

Installation der neuesten ESI-Device-Description

Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jew. Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.

Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen (Standardeinstellung TwinCAT 2: C:\TwinCAT\IO\EtherCAT). Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen wenn sie sich seit dem letzten Systemmanager-Fenster geändert haben.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.

Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Abb. 1: ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen.

Hinweis 		ESI
Zu den *.xml-Dateien gehören so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.

Geräteunterscheidung

EtherCAT Geräte/Slaves werden durch 4 Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Der Name "EL2521-0025-1018" setzt sich zusammen aus

  • Familienschlüssel "EL"
  • Typ/Name "2521-0025"
  • und Revision "1018"

Abb. 2: Aufbau Bezeichnung

Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.

Online Description

Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der Systemmanager ob er die im Gerät vorliegende Beschreibung verwenden soll. Der Systemmanager benötigt in jedem Fall diese Information um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.

Abb. 3: Hinweisfenster OnlineDescription, TwinCAT 2

In TwinCAT 3.x erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:

Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.

Achtung 		Veränderung der "üblichen" Konfiguration durch Scan
Für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind 2 Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019.
  • für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
  • für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
    Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.

Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Konfigurationsserstellung – Manuell“

Wird dennoch die Online Description verwendet, liest der Systemmanager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird der Weg über die ESI-Datei dringend empfohlen.

Der Systemmanager legt dann in seinem ESI-Verzeichns eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.

Abb. 4: vom Systemmanager angelegt OnlineDescription.xml

Wird daraufhin manuell ein Slave in die Konfiguration eingefügt, unterscheiden sich solchermaßen erstellte Slaves durch einen vorangestellten Pfeil, s. Abb. 5, EL2521.

Abb. 5: Pfeil kennzeichnet durch Online Description erfasste ESI

Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:

  • alle Systemmanagerfenster schließen
  • TwinCAT in Konfig-Mode neu starten
  • "OnlineDescription0000...xml" löschen
  • TwinCAT Systemmanager wieder öffnen

Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.

Hinweis 		OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

C:\User\[USERNAME]\AppData\Roaming\Beckhoff\TwinCAT3\Components\Base\EtherCATCache.xml

(Spracheinstellungen des Betriebssystems beachten!)

Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.

Fehlerhafte ESI-Datei

Liegt eine fehlerhafte ESI-Datei vor die vom Systemmanager nicht eingelesen werden kann, meldet dies der Systemmanager durch ein Hinweisfenster.

Abb. 6: Hinweisfenster fehlerhafte ESI-Datei

Ursachen dafür können sein

  • Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei --> prüfen Sie die Ihnen vorliegenden Schemata
  • Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden --> Es ist der Hersteller der Datei zu kontaktieren


Installation TwinCAT Realtime Treiber

Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.

Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.

Im Systemmanager ist über Options -> Show realtime Compatible Devices die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.

Abb. 1: Aufruf im Systemmanager

Abb. 2: Übersicht Netzwerkschnittstellen

Hier können nun Schnittstellen, die unter "Compatible devices" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.

Ein Windows-Warnhinweis bzgl. des unsignierten Treibers kann ignoriert werden.

Alternativ sind im Systemmanager über die EtherCAT-Eigenschaften die kompatiblen Ethernet Ports einsehbar.

Abb. 3: Eigenschaften EtherCAT Gerät

Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start --> Systemsteuerung --> Netzwerk)

Abb. 4: Windows-Eigenschaften der Netzwerkschnittstelle

Andere mögliche Einstellungen sind zu vermeiden:

Abb. 5: fehlerhafte Treiber-Einstellungen des Ethernet Ports

IP-Adresse des verwendeten Ports

Hinweis 		IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall , dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren.

Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält.

Als Adressraum empfiehlt sich z.B. 192.168.x.x.

Abb. 6 TCP/IP-Einstellung des Ethernet Ports


Offline Konfigurationserstellung (Master: TwinCAT 2.x)

Inhaltsverzeichnis
• Unterscheidung Online/Offline
• Anlegen des Geräts EtherCAT
• Definieren von EtherCAT Slaves

Unterscheidung Online/Offline

Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.

Ist die vorgesehene Steuerung bereits an das EtherCAT-System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch so genanntes "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.

In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden.

Hinweis 		Installation der neuesten ESI-XML-Device-Description
Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT ) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT Builds aktuell war.

Ab. TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Zur Konfigurationserstellung muss

  • das Gerät EtherCAT im Systemmanager angelegt/definiert werden
  • die EtherCAT Slaves definiert werden

Anlegen des Geräts EtherCAT

In einem leeren Systemmanager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.

Abb. 1: Anfügen EtherCAT Device

Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.

Abb. 2: Auswahl EtherCAT Anschluss (TwinCAT 2.11)

Abb. 3: Auswahl EtherCAT Anschluss (TwinCAT 2.11 R2)

Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.

Abb. 4: Auswahl Ethernet Port

Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog (s. Abb. 5) gesetzt/geändert werden.

Abb. 5: Eigenschaftendialog EtherCAT

Hinweis 		Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden.

Siehe dazu die entsprechende Installationsseite.

Definieren von EtherCAT Slaves

Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.

Abb. 6: Anfügen von EtherCAT Geräten

Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.

Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. 7, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. 7 nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.

Übersicht Übertragungsphysik

  • "Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
  • "E-Bus": LVDS "Klemmenbus": EL/ES-Klemmen, diverse anreihbare Module

Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11).

Abb. 7: Auswahldialog neues EtherCAT Gerät

Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.

Abb. 8: Anzeige Geräte-Revision

Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z.B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. 7) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibung vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. 9.

Abb. 9: Anzeige vorhergehender Revisionen

Hinweis 		Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).

Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.

Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.

Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...

Abb. 10: EtherCAT Klemme im TwinCAT-Baum


Online Konfigurationserstellung "Scannen" (Master: TwinCAT 2.x)

Inhaltsverzeichnis
• Unterscheidung Online/Offline
• Erkennen/Scan des Geräts EtherCAT
• Erkennen/Scan der EtherCAT Teilnehmer
• Problembehandlung
• Scan über bestehender Konfiguration

• Change to compatible device
• Change to Alternative Type

Unterscheidung Online/Offline

Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.

Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.

In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden.

Hinweis 		Installation der neuesten ESI-XML-Device-Description
Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT ) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT Builds aktuell war.

Ab. TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Zur Konfigurationserstellung

  • muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
  • müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
  • müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
  • muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.

Der Online-Scan-Vorgang setzt sich zusammen aus

  • Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
  • Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
  • Problembehandlung

Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.

Erkennen/Scan des Geräts EtherCAT

Befindet sich das TwinCAT-System im CONFIG-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.

Abb. 1: TwinCAT Anzeige CONFIG-Modus

Hinweis 		Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.

Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.

Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.

Abb. 2: Scan Devices

Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.

Abb. 3: Hinweis automatischer GeräteScan

Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.

Abb. 4: erkannte Ethernet-Geräte

Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. 5.

Hinweis 		Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden.

Siehe dazu die entsprechende Installationsseite.

Erkennen/Scan der EtherCAT Teilnehmer

Hinweis 		Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.

Achtung 		Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug um für eine Inbetriebnahme ein Erst-Konfiguration als Arbeitsgrundlage zu erzeugen.

Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.

Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.

Beispiel:

Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitze dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:

Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwiNCAT3-Solution-Dateien).

Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.

Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.

Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:

Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwiNCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).

Dazu kommt, dass durch durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.

Þ bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!

Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.

Abb. 5: Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes

Abb. 6: manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device

Im Systemmanager kann der Scan-Ablauf am Ladebalken am unteren Bildschirmrand verfolgt werden.

Abb. 7: Scanfortschritt

Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.

Abb. 8: Abfrage Config/FreeRun

Im Config/FreeRun-Mode wechselt die Systemmanager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.

Abb. 9: Anzeige Config/FreeRun

Hinweis 		Hinweis Config/FreeRun
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden

Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. 10 befinden.

Abb. 10: beispielhafte Online-Anzeige

Zu Beachten sind

  • alle Slaves sollen im OP-State sein
  • der EtherCAT Master soll im "Actual State" OP sein
  • "Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
  • es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten

Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.

Problembehandlung

Beim Scannen können verschiedene Effekte auftreten.

  • es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
    In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
  • Teilnehmer werden nicht richtig erkannt
    Ursachen können sein
    - fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
    - Slave hat ungültige Gerätebeschreibung
    Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
    Der Scan ist dann erneut vorzunehmen.

  • Abb. 11: fehlerhafte Erkennung

    Im Systemmanager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.

Scan über bestehender Konfiguration

Achtung 		Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen!
Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.

Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.

Abb. 12: identische Konfiguration

Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.

Abb. 13: Korrekturdialog

Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.

Farbe | Erläuterung
grün | Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.

Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Geräte nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.

hellblau | Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
  • Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
  • Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
    Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.

    Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Geräte nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.

Hinweis 		Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).

Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.

Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.

Abb. 14: Korrekturdialog mit Änderungen

Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.

Change to compatible device

Der TwinCAT Systemmanager biete eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task: Change to compatible device.

Abb. 15: TwinCAT 2 Dialog ChangeToCompatibleDevice

Diese Funktion ist vorzugsweise auf AX5000-Geräten anzuwenden. Wenn aufgerufen, schlägt der Systemmanager die Geräte vor die er im zugehörigen Unterordner findet, beim AX5000 z.B. in \TwiNCAT\IO\EtherCAT\Beckhoff AX5xxx.

Change to Alternative Type

Der TwinCAT Systemmanager biete eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type

Abb. 16: TwinCAT 2 Dialog ChangeToCompatibleDevice

Wenn aufgerufen, sucht der Systemmanager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


Standard-Verhalten EtherCAT Master

BECKHOFF EtherCAT: EtherCAT-Grundlagen

Prozessdaten Einstellungen EtherCAT Slave (PDO)

Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (Process Data Objects, PDO) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.

Für Beckhoff EtherCAT Slaves EL/ES gilt im Allgemeinen:

  • Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
  • Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
    Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
  • Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch den erfolgreichen Hochlauf des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.

Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. 1.

  • A: Wählen Sie das zu konfigurierende Gerät
  • B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
  • D: die PDOs können an- bzw. abgewählt werden
  • H: die neuen Prozessdaten sind als verlinkbare Variablen im Systemmanager sichtbar
    Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
  • E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ( "predefined PDO-settings") verändert werden.

Abb. 1: Konfigurieren der Prozessdaten

Hinweis 		Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. 1, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit").

Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden.

Dies gilt im Allgemeinen auch für den Fall, dass eine Gerät den Download der PDO Konfiguration "G" unterstützt.

Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben:

Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.


Allgemeine Hinweise - EtherCAT Slave Anwendung

BECKHOFF: Inbetriebnahme

Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inhaltsverzeichnis
• Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
• CoE - Parameterverzeichnis
• Inbetriebnahmehilfe im TwinCAT System Manager
• EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
• Hinweis Ebus Strom

In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.

Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status

Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.

Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.

Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.

EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im folgenden besprochen.

Abb. 1: Auswahl an Diagnoseinformationen eines EtherCAT Slave

Im Allgemeinen verfügt ein EtherCAT Slave über

  • slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
    Diese Diagnose ist für alle Slaves gleich.

    als auch über
  • kanal-typische Funktionsdiagnose (geräteabhängig)
    Siehe entsprechende Gerätedokumentation

Die Farbgebung in Abb. 1 entspricht auch den Variablenfarben im System Manager, siehe Abb. 2.

Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.

In Abb. 2. ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.

Abb. 2: grundlegende EtherCAT Slave Diagnose in der PLC

Dabei werden folgende Aspekte abgedeckt:

Kennzeichen Funktion Ausprägung Anwendung/Auswertung
A Diagnoseinformationen des EtherCAT Master

zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).

Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.

Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:

  • CoE im Master zur Kommunikation mit/über die Slaves
  • Funktionen aus TcEtherCAT.lib
  • OnlineScan durchführen
B Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln. Status
  • die Bitdeutungen sind der Gerätedokumentation zu entnehmen
  • andere Geräte können mehr oder keine slavetypischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
  1. am EtherCAT Slave als auch inhaltsidentisch
  2. als Sammelvariable am EtherCAT Master (siehe Punkt A)

zur Verlinkung bereitgestellt.

WcState (Working Counter)

0: gültige Echtzeitkommunikation im letzten Zyklus

1: ungültige Echtzeitkommuniktion

ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen

Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
  • nur selten/nie verändert werden, außer beim Systemstart
  • selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State

aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.

AdsAddr

Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.

Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.

Achtung 		Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.

CoE-Parameterverzeichnis

Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. 3:

Abb. 3: EL3102, CoE-Verzeichnis

Hinweis 		EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!

Einige Hinweise daraus in Kürze:

  • Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
  • Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.

Inbetriebnahmehilfe im TwinCAT System Manager

In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.

Abb. 4: Beispiel Inbetriebnahmehilfe für eine EL3204

Diese Inbetriebnahme verwaltet zugleich

  • CoE-Parameterverzeichnis
  • DC/FreeRun-Modus
  • die verfügbaren Prozessdatensätze (PDO)

Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.

Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, könne vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.

EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung

Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati

  • INIT
  • PREOP
  • SAFEOP
  • OP

zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.

Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.

Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.

Standardeinstellung

Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:

  • EtherCAT Master: OP
  • Slaves: OP
    Diese Einstellung gilt für alle Slaves zugleich.

Abb. 5: Default Verhalten System Manager

Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.

Abb. 6: Default Zielzustand im Slave

Manuelle Führung

Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.

  • aus Diagnosegründen
  • kontrolliertes Wiederanfahren von Achsen
  • ein zeitlich verändertes Startverhalten ist gewünscht

Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.

Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.

Abb. 7: PLC-Bausteine

Hinweis Ebus Strom

EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.

Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.

Abb. 8: unzulässige Überschreitung E-Bus Strom

Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:

Abb. 9: Warnmeldung E-Bus-Überschreitung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Konfiguration

BECKHOFF EtherCAT: Konfiguration der Klemmen

Konfiguration mit dem TwinCAT System Manager

(Mit TwinCAT ab Version 2.10.0 (Build 1241), am Beispiel der EL5001 ab Firmware-Stand 0.7)

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der Klemme die Sie konfigurieren möchten (im Beispiel: Klemme 6 EL5001).

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung.

Karteireiter Allgemein

Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.

Karteireiter EtherCAT

Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem Anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.

Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.

Karteireiter Prozessdaten

Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.

Sync-Manager

Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.

Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.

PDO-Zuordnung

PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:

  • Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
  • Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.

Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.

Hinweis 		Aktivierung der PDO-Zuordnung
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
  • der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
  • der System-Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])

PDO-Liste

Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.

Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.

PDO-Inhalt

Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.

Download

Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.

PDO-Zuordnung

Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.

PDO-Konfiguration

Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.

Karteireiter Startup

Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.

Spalte | Beschreibung
Transition Übergang, in den der Request gesendet wird. Dies kann entweder
  • der Übergang von Pre-Operational to Safe-Operational (PS) oder
  • der Übergang von Safe-Operational to Operational (SO) sein.

Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll | Art des Mailbox-Protokolls
Index | Index des Objekts
Data | Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar | Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.

Karteireiter CoE - Online

Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.

Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.

Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.

Karteireiter Online

Status Maschine

Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.

DLL-Status

Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:

Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.

File Access over EtherCAT

Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


EL320x - Verwendung EL320x im TwinCAT System Manager

BECKHOFF EL320x: Inbetriebnahme

Einstellungen und Anwendungshinweise zur EL320x-00xx

Inhaltsverzeichnis

• Default-Einstellung
- Hinweis zur Betriebsart "Widerstandsmessung"
• Veränderung der Slave-Parameter im CoE-Verzeichnis
• Weitere Anwendungshinweise

Default-Einstellung

Die EL320x-0000 kann zur direkten Temperatur- oder Widerstandsmessung eingesetzt werden. Die Version -0010/-0020 misst mit erhöhter Genauigkeit. Dazu sind entsprechende CoE-Einstellungen vorzunehmen, siehe nachfolgende Tabelle.

Zur Einordnung sei hier der Zusammenhang zwischen der Temperatur und dem Widerstand eines PT100/PT1000-Sensors angegeben:

Temperatur | typ. Widerstand, ca.
850°C | PT1000: 3.9 kΩ PT100: 390 Ω
320°C | PT1000: 2.2 kΩ PT100: 220 Ω
-200°C | PT1000: 180 Ω PT100: 18 Ω

Sensortypische Kennlinien können von den Sensorherstellern bezogen werden.

Weiterführende Hinweise erhalten Sie in den Kapiteln Objektbeschreibung und Parametrierung und Prozessdaten und Betriebsmodi

EL320x-0000 EL320x-0010/-0020
Default/Werkseinstellung
  • 2-Leiter-Anschluss
  • Pt100 (CoE x80n0:19)
  • Presentation signed (CoE x80n0:02)
  • Limits disabled
  • 50 Hz Filter enabled
  • alle Kanäle enabled
  • 4-Leiter-Anschluss (CoE x80n0:1A)
    Eine automatische Anschlussarterkennung erfolgt nicht.
  • Pt100 (CoE x80n0:19)
    Es erfolgt eine Messung im reduzierten Messbereich von -200..320°C bzw. im äquivalenten Widerstandbereich.

    Die Beschriftung der Typ-Einstellung „PT100 (-200..850°C)“ steht für den üblichen Messbereich eines PT100-Elements

  • Presentation HighResolution (CoE x80n0:02)
    Die Temperatur wird mit 1/100°C je Digit vorzeichenbehaftet dargestellt.
  • Limits disabled
  • 50 Hz Filter enabled
  • alle Kanäle enabled
Einsatzbereich Die Klemme wird im Messbereich "1/16 Ω" (10 Ω .. 4 kΩ) abgeglichen und kann in diesem Widerstandsbereich eingesetzt werden. Die hochgenaue Version wird im Messbereich "1/64 Ω" (10 Ω .. 1 kΩ) und über einen Messbereich von 18..220 Ω abgeglichen und ist ausschließlich in diesem Bereich oder zur PT100-Messung einzusetzen.

In anderen Messbereichen bietet sie die Standardgenauigkeit von <±0.5°C.

Hinweis zur Betriebsart "Widerstandsmessung"

In der Betriebsart "Widerstandsmessung" wird der Messwert unabhängig von der Einstellung "Presentation" (CoE x80n0:02) immer unsigned (vorzeichenlos) 0..xFFFF mit entsprechender Wertigkeit dargestellt.

1/16 Ω -> ~62 mΩ/Digit

1/64 Ω -> ~15 mΩ/Digit

Veränderung der Slave-Parameter im CoE-Verzeichnis

Bei der Inbetriebnahme müssen ggf. die CoE-Parameter verändert werden.

  • Beim Online-Zugriff auf die Klemme wird das CoE-Verzeichnis aus dem Slave gelesen und kann verändert werden, s. Abb. 6.
  • Beim Offline.Zugriff auf die (dann nicht ansprechbare) Klemme werden die Daten aus der XML-Beschreibung benutzt. Die Parameter können nicht verändert werden.

Im Reiter "CoE-Online" des EtherCAT-Slave können die CoE-Parameter (CAN over EtherCAT) verändert werden.

Abb. 6: Zugriff auf die CoE-Parameter im TwinCAT SystemManager

Achtung 		Veränderungen im CoE-Verzeichnis, Austauschfall
Damit auch im Austauschfall eines EtherCAT-Slaves bei dem neu eingesetzten Slave die CoE-Parameter richtig gesetzt werden, sind kundenseitige Veränderungen in der StartUp-Liste einzutragen.

Hinweis 		Veränderungen im CoE-Verzeichnis, Programmzugriff
Die CoE-Parameter können auch im Betrieb (soweit sinnvoll) durch die PLC mit entsprechende Steuerungsbefehlen gelesen und geschrieben werden. Siehe dazu die entsprechenden Einträge z.B. im Beckhoff Information System.

Für detaillierte Informationen zu Einstellungen und Betriebsmodi lesen Sie bitte das Kapitel "Prozessdaten und Betriebsmodi".

Weitere Anwendungshinweise

Hinweis 		Einstellung "Filter enable"
Die Filterfunktion ist immer aktiv, auch wenn das Objekt 8000:06 "Filter enable" = FALSE gesetzt wird

Hinweis 		Einstellung "Connection Technology"
Außer 2-, 3- und 4-Leiteranschluss kann hier auch kanalweise "not connected" gewählt werden. Der betreffende Kanal wird vollständig deaktiviert, die Wandlungszeit der EL320x verkürzt sich entsprechend.
Durch einen Doppelklick auf das entsprechende Objekt 80x0:1A können die entsprechenden Kanäle im Set Value Dialog abgeschaltet werden, indem der "Enum"-Wert "not connected" gewählt wird.

Abb. 7: Einstellung "not connected"


Technologie

BECKHOFF EL320x: Inbetriebnahme

Einstellungen und Anwendungshinweise zur EL3204-0200

Inhaltsverzeichnis
  • Meßbereich
  • direkte Widerstandmessung
  • fixe Sensorkennlinien
  • Linearisierung nach Stützstellentabelle
  • Linearisierung nach B-Parameter-Gleichung
  • Linearisierung nach DIN 60751
  • Linearisierung nach Steinhart-Hart
  • Beispiel NTC
  • Beispiel PTC
            •

    Die EL3204-0200 unterscheidet sich von der EL3204-0000 (Standard-Type) durch

    • erweiterter Messbereich 0 ... 240 kΩ
    • zusätzliche Linearisierungen/Sensorkennlinien
      • einprogrammierte Sensorkennlinien entsprechend dem Messbereich
      • frei programmierbar nach Stützstellentabelle
      • parametrierbare Formeln nach IEC 60751, Steinhart-Hart-Gleichung und B-Parameter-Gleichung

    Achtung     		Veränderungen im CoE-Verzeichnis, Austauschfall
    Damit auch im Austauschfall eines EtherCAT-Slaves bei dem neu eingesetzten Slave die CoE-Parameter richtig gesetzt werden, sind kundenseitige CoE-Veränderungen in der StartUp-Liste einzutragen.

    Hinweis     		Veränderungen im CoE-Verzeichnis, Programmzugriff
    Die CoE-Parameter können auch im Betrieb (soweit sinnvoll) durch die PLC mit entsprechende Steuerungsbefehlen gelesen und geschrieben werden. Siehe dazu die entsprechenden Einträge z.B. im Beckhoff-Information-System.

    Hinweis: die CoE-Parameter sollten im Status PreOp oder SafeOp geschrieben und dann der Slave in den Status OP geschaltet werden.

    Messbereich

    Die Genauigkeitsangabe der Klemme bezieht sich auf den Messbereichsendwert für die Widerstandsmessung.

    Der Einsatz der Klemme im Bereich 0 bis 10 Ω wird aufgrund der dann relativ geringen (relativen) Messgenauigkeit nicht empfohlen. Für solche Messungen sind spezialisierte Widerstandsmessklemmen wie die EL3692 in 4-Leiter-Messung zu verwenden.

    Hinweis     		Hinweise zur Genauigkeit
    Das Messergebnis wird neben der Genauigkeit bei der Widerstandsmessung der Klemme auch von weiteren Faktoren beeinflusst; das Folgende sollte entlang der Messkette berücksichtigt werden:
    • Messfehler des verwendeten Messsensors
    • Messfehler der Klemme: < +/- 0,3% vom Messbereichsendwert (240 kΩ bei Widerstandsmessung); < +/- 0,5°C bei Pt-Sensoren
    • Implementierung der Berechnungsparameter in der Firmware z.B. Anzahl Stützstellen, Genauigkeit der berechneten Parameter,...

    Es wird eine Überprüfung der vorgenommenen Einstellungen gegen eine kalibrierte Temperaturquelle empfohlen.

    Einprogrammierte Sensorkennlinien

    • Direkte Widerstandsmessung

      Die EL3204-0200 als direkte Widerstandsmessung in 3 Messbereichen (n = Kanal 0... 3) kann verwendet werden

      Einstellung CoE x80n0:19 | Messbereich | Auflösung/digit
      x80n0:19 = 101 | 0 ...6.553,5 Ω | 0,1 Ω
      x80n0:19 = 102 | 0 ...65.535 Ω | 1 Ω
      x80n0:19 = 103 | 0 ...240.000 Ω | 10 Ω

      Hinweis: die El3204-0200 misst in diesen 3 Einstellungen elektrisch immer gleich, nur die dargestellte Auflösung wird in der Firmware verändert. Messbereichsendwert ist also für alle 3 Messungen 240 kΩ.

    • Fixe Sensorkennlinien

      Weitere einprogrammierte Sensorkennlinie im definierten Messbereich können im CoE-Entry x80n0:19 für jeden Kanal einzeln ausgewählt werden (n = Kanal 0... 3).

      Typ | Widerstandsbereich | Implementierter Temperaturbereich | Auflösung/digit
      Pt1000 (0,00385 Ω/Ω/°C, IEC60751 Kennlinie Pt385) (PTC) | ~180 ... ~ 3.900 Ω | -200°C bis 850°C | 0,1°C
      Ni1000 (PTC) | ~700 ... ~2.300 Ω | -60°C bis 250°C | 0,1°C
      Ni1000 (bei 100°C: 1500 Ω) (PTC) | -30 bis 160°C | 0,1°C
      NTC 5k (0°C: 16325 Ω) | ~167.000 ... ~340 Ω | -40...100°C | 0,1°C
      NTC 10k (0°C: 32650 Ω) | ~176.000 ... ~180 Ω | -30...150°C | 0,1°C
      NTC 10k (0°C: 29490 Ω) | ~135.000 ... ~240 Ω | -30...150°C | 0,1°C
      NTC 10k (0°C: 27280 Ω, wie KL3204-0030) | ~190.000 ... ~760 Ω | -40...110°C | 0,1°C
      NTC 20k (0°C: 70200 Ω) | ~221.000 ... ~270 Ω | -20...150°C | 0,1°C
      FeT (0°C: 2226 Ω) | ~1.900 ... ~ 3.900 Ω | -30...150°C | 0,1°C

    Frei programmierbare Linearisierung

    Falls ein resisitiver (widerstandsbehafteter) Sensor angeschlossen werden soll, dessen Kennlinie nicht in der EL320x-xxxx implementiert aber anwenderseitig bekannt ist, kann diese Kennlinie über 4 verschiedene Verfahren in der Klemme eingegeben werden.
    Dadurch ist jede Linearisierung und jede NTC/PTC-Kennlinie innerhalb des Messbereichs umsetzbar. Je nach Sensortyp eignen sich verschiedene Verfahren zur Implementierung.

      CoE-Entry im x80n0:19 | Kennlinien Typ | PTC-Sensoren (z.B. Pt100, Pt1000, Ni100, Ni1000,...) | NTC-Sensoren (NTC 5k, NTC 10k,..)
x80n0:19 = 110 | RTD-Tabelle/Stützstellentabelle | X | X
x80n0:19 = 111 | B-Parameter Equation | - | X
x80n0:19 = 112 | DIN EN 60751 Equation | X (Norm für Pt-Sensoren) | -
x80n0:19 = 113 | Steinhart Hart Equation | - | X

    Dazu ist im CoE-Entry x80n0:19 das jeweilige Verfahren für den Kanal auszuwählen. Hierbei ist zu beachten, dass für jedes Verfahren nur jeweils 1 Satz an Parametern in der Klemme hinterlegt werden kann, der dann für alle Kanäle zur Verfügung steht.

    Beispiel: es werden 2 Sensoren an Kanal 1 und 2 angeschlossen, die beide mit der B-Parameter-Gleichung linearisiert werden sollen. Dann müssen beide Sensoren "gleich" sein, da nicht unterschiedliche Sätze an B-Parametern für Kanal 1 und 2 angegeben werden können. Entsprechendes gilt für die Stützstellentabelle.

    • Stützstellentabelle (x80n0:19 = x110)

      Die gewünschte Kennlinie für einen PTC oder NTC-Sensor kann als Tabelle im CoE x8001 hinterlegt werden. Dazu kann sie aus der PLC ins CoE geladen, oder vom Anwender als XML-Datei in die Startup-Liste der Klemme eingetragen werden. Die Einträge aus der TwinCAT- Startup-Liste werden bei jedem Start von EtherCAT automatisch in die Klemme geschrieben.
      Im Allgemeinen besitzt die Stützstellentabelle folgenden Aufbau: eine Temperatur wird dem entsprechenden Widerstand zugeordnet. Dabei muss die vorliegende Temperatur eine konstante Schrittweite aufweisen. Zwischen diesen Schritten wird linearisiert.
      Maximal sind 100 Stützstellen, mit einem maximal Messbereich von 0…240 kΩ zugelassen.
      Der genaue Aufbau der Stützstelentabelle ist in der die CoE-Übersicht und zusätzlich in einer Beispieldatei für einen Pt1000 Sensor erläutert.
      Die Beispieldatei zeigt exemplarisch den Aufbau einer zu importierenden XML-Datei. Zusätzlich ist eine Excel-Datei (Excel 2010) beigefügt, um eine entsprechende XML zu erzeugen. Erläuterungen zur Benutzung der Exceldatei können der beigefügten Beschreibung entnommen werden.

      Die XML-Datei kann direkt über das Startup-Feld importiert und über "Konfiguration aktivieren" aktiviert werden.

      Abb. 1: Import der generierten XML-Datei

    • B-Parameter-Gleichung (x80n0:19 = 111)

      Die B-Parameter-Gleichung kann auf NTC-Sensoren (Heißleiter), d.h. RTD-Elemente mit negativem Koeffizienten k, angewendet werden.

      Dabei gibt der Koeffizienten RT0 den Widerstand bei der Temperatur T0 an, der B-Parameter kann den Angaben des Sensorherstellers entnommen oder durch Messung des Widerstandes bei zwei bekannten Temperaturen bestimmt werden.
      Zur Berechnung des B-Parameters kann folgende Beispieldatei verwendet werden. Die berechneten Parameter sind in das CoE-Verzeichnis x8002 einzutragen.

      Abb. 2: Tabelle Berechnung B-Parameter

    • Programmierbar nach DIN 60751 für Pt-Sensoren (x80n0:19 = x112)

      Die IEC 751 bzw. die deutsche Übersetzung DIN EN 60751 definiert die elektrischen Eigenschaften von Platin-Temperatursensoren. Der Kennlinienverlauf wird folgendermaßen beschrieben:

      für Temperaturen -200.. 0°C:

      für Temperaturen für 0.. 850°C:

      Mit den Parametern:

      Der Parameter R0 gibt den Widerstand in Ohm des Platinsensors bei T=0°C an. Die Sensoren werden nach diesen Bezeichnungen qualifiziert, so spricht man vom Pt100, wenn R0=100 Ω bei T=0°C beträgt.
      Die in der Norm definierten Parameter A, B und C sind bereits im CoE Verzeichnis x8003:y hinterlegt. Die Festlegung des Pt-Sensors erfolgt über den Parameter x8003:03, dieser entspricht R0.

    • Steinhart-Hart-Gleichung (x80n0:19 = x113)

      Die Steinhart-Hart Gleichung kann auf NTC-Sensoren (Heißleiter), d.h. RTD-Elemente mit negativem Koeffizienten k, angewendet werden.

      Die Koeffizienten C1, C2 und C4 können entweder direkt den Herstellerdaten entnommen, oder aber berechnet werden.
      Zur Berechnung der Steinhart-Hart Parameter steht eine Beispieldatei zur Verfügung. Zur Bestimmung der Parameter werden die Widerstandswerte bei drei bekannten Temperaturen benötigt. Diese können entweder den Herstellerdaten entnommen oder direkt am Sensor gemessen werden. Die berechneten Parameter sind in das CoE-Verzeichnis x8004 einzutragen. Der Parameter C3 läuft in den meisten Fällen gegen Null, und ist somit zu vernachlässigen, er wird daher nicht in der Berechnung der Beispieldatei berücksichtigt.

      Abb. 2: Tabelle Berechnung Steinhart-Hart-Parameter

    Beispielimplementierung eines NTC-Sensors

    Im Folgenden soll gezeigt werden, wie ein NTC-Sensor, dessen Kennlinie nicht bereits in der EL3204-0200 Klemme hinterlegt ist, in den drei Varianten, RTD-Tabelle, B-Parameter-Gleichung und Steinhart-Hart-Gleichung implementiert werden kann.
    Dies wird anhand eines NTC030WP00 Sensors gezeigt.

    Der Hersteller gibt in diesem Fall eine Tabelle mit Temperatur und den entsprechenden Widerstandswerten bekannt sowie folgende Sensoreigenschaften: NTC 10kΩ +/- 1% bei 25°C, Beta 3435.

  • Implementierung mit der Stützstellentabelle RTD - Tabelle

    Das allgemeine Vorgehen wird im Kapitel Stützstellentabelle erläutert, hier sollen an Hand eines Beispieles einige Spezialfälle aufgezeichnet werden. Eine Beispiel- XML-Datei für den NTC030WP00 Sensor steht zum Download bereit.
    Beschreibung | Problem | Lösungsansatz
    Die Tabelle umfasst den Temperaturbereich von -50°C... bis 110°C, in 1° Schritten Gesamtanzahl der Stützstellen 160. Mit Hilfe der RTD-Tabelle können derzeit 100 Stützpunkte eingegeben werden. 1. Messbereich begrenzen, so dass man auf gesamt 100 Stützstellen kommt

    2. Schrittweite vergrößern, z.B. Tabelle in 5°C Schritten implementieren. Die Schrittweite sollte nicht zu groß gewählt werden, da es sich bei NTC-Sensoren um einen exponentielle und nicht lineare Kennlinie (wie z.B. bei den PTC-Sensoren) handelt.

    Widerstandswerte im Temperaturbereich -50°C.. -44°C liegen zwischen 330 kΩ.. 240 kΩ Messwerte bei niedrigen Temperaturen überschreiten den Gesamtmessbereich von 240 kΩ 1. Prüfen ob der Messbereich benötigt wird

    2. Alternativsensor auswählen der bei den tiefen Temperaturen niedrigere Widerstandswerte aufweist.

    Es soll der Bereich von -40°C...110°C in 2°C Schritten abgebildet werden. Neben der Implementierung der Tabelle werden folgende Einstellungen im CoE x8001 vorgenommen: Mit Defaulteinstellungen des Conversion Factors 10 treten Fehler auf: Messbereich wurde nicht beachtet. Die Einheit der Widerstandswerte muss an den Conversion Factor angepasst werden Messbereich muss beachtet werden, für den Gesamtmessbereich von 0....240 kΩ muss im x8001:04 Conversion Factor = 100 eingegeben werden. Die Widerstandswerte müssen dann in 1/10 Ω eingegeben werden.

    Die Bereiche sind wie folgt definiert:
    8001:01 Distance in Degrees | 2
    8001:02 Amount of Entries | 75 | Conversion Factor x8001:04 | Messbereich
    8001:03 Start Temperatur | -40 | 1 | 0.. 6.533,5 Ω
    8001:04 Conversion Factor | 10 | 10 | 0..65.535,0 Ω
    8001:05 Value 1 | 188500 | 100 | 0..240.000,0 Ω

  • Implementierung mit B-Parameter Gleichung

    Den Herstellerangaben kann der B-Parameter (Beta 3435) und die Parameter Rn (10kΩ) und Tn (25°C) entnommen und direkt ins CoE-Verzeichnis x8002 übernommen werden.
    CoE Entry | Eintrag
    8002:01 Min Temperature | -40
    8002:02 Max Temperature | 110
    8002:03 Rn | 10000
    8002:04 Tn | 25
    8002:05 B-Parameter | 3435

    Vergleicht man die Implementierung der Tabelle und der B-Parameter-Gleichung, wie in der unteren Grafik dargestellt, so wird deutlich, dass die B-Parameter-Gleichung nur in einem begrenzten Bereich gültig ist und bei tiefen Temperaturen große Abweichungen aufweist. Wird der gesamte Temperaturbereich benötigt, so ist die Implementierung über die Steinhart-Hart-Gleichung vorzuziehen.

  • Implementierung mit Steinhart-Hart Gleichung

    Die Steinhart-Hart Parameter können mit Hilfe der Beispieldatei berechnet und die dafür benötigten Widerstandswerte bei drei definierten Temperaturen z.B. bei 0°C, 25°C und 85°C, der Herstellertabelle entnommen oder direkt am Sensor gemessen werden.

    CoE Entry | Eintrag
    8004:01 Min Temperature | -40
    8004:02 Max Temperature | 110
    8004:03 C1 | 8,8424E-4
    8004:04 C2 | 2,5202E-4
    8002:04 C3 | 0
    8002:04 C4 | 1,9018E-7

    Aus der Grafik wird deutlich, dass die Implementierung über die Steinhart-Hart-Gleichung sich den Hersteller-Tabellenwerten besser annährt, als die Implementierung über die B-Parameter-Gleichung. Liegt jedoch eine Tabelle des Herstellers vor, so ist diese Methode immer vorzuziehen.

    Abb. 3: Vergleich Implementierung B-Parameter- und Steinhart-Hart-Parameter

    Beispielimplementierung eines PTC-Sensors

    Im Folgenden soll gezeigt werden, wie ein PTC-Sensor, speziell ein Platin-Sensor (Pt-Fühler), mit Hilfe der RTD-Tabelle und nach der DIN EN 60751 implementiert wird.

  • Implementierung mit der Stützstellentabelle RTD - Tabelle

    Das allgemeine Vorgehen ist im Kapitel Stützstellentabelle erläutert, im Folgenden wir die Implementierung einer Tabelle für ein Pt500-Sensor gezeigt.
    Beschreibung | Problem | Lösungsansatz
    Für die Pt-Sensoren sind Tabellen mit mehreren 100-Einträgen in 1°C-Schritten erhältlich. Gesamtanzahl der Stützstellen wird überschritten. Mit Hilfe der RTD-Tabelle können derzeit 100 Stützpunkte eingegeben werden. 1. Messbereich begrenzen, so dass man auf gesamt 100 Stützstellen kommt

    2. Schrittweite vergrößern, z.B. Tabelle in 5°C oder 10°C Schritten implementieren. Da der Verlauf bei Pt-Sensoren nahezu linear ist, hat eine größere Schrittzahl nur einen geringen Einfluss auf die Messgenauigkeit. Im Gegensatz zu den NTC-Sensoren, wo man einen exponentiellen Verlauf hat und somit ein geringes Schrittmaß zu bevorzugen ist.

    Die Herstellertabellen beinhalten allgemeingültige Werte | Die Tabellenwerte müssen zunächst auf den jeweiligen Sensortyp angepasst werden | Für die verschiedenen Pt-Sensoren müssen die Tabelleneinträge jeweils mit dem R0-Wert multipliziert werden. R0 gibt jeweils den Widerstand bei 0°C an - wobei die Sensorbezeichnung direkt auf diesen Wert schließen lässt.
    Pt-Sensor | R0 (Widerstand bei 0°C)
    Pt100 | 100
    Pt500 | 500
    Pt1000 | 1000

    Für den Pt500-Sensor können folgende CoE-Einträge gewählt , und mit folgender XML-Datei gearbeitet werden.:

    CoE Entry | Eintrag
    8001:01 Distance in Degrees | 10
    8001:02 Amount of Entries | 60
    8001:03 Start Temperature | -40
    8001:04 Conversion Factor | 10
    8001:05 Value 1 | 4247
    8001:0x weitere Tabelleneinträge .....

  • Programmierbar nach DIN 60751 für Pt-Sensoren

    Die Implementierung nach der DIN EN 60751 ist im Abschnitt Programmierbar_nach_DIN_60751_für_Pt-Sensoren beschrieben. Die Parameter A, B, C sind bereits im CoE hinterlegt, es muss lediglich der Temperaturbereich und der R0-Parameter für den zu verwendeten Sensor hinterlegt werden. R0 gibt jeweils den Widerstand bei 0°C an - wobei die Sensorbezeichnung direkt auf diesen Wert schließen lässt. Für den jeweiligen Sensor muss der CoE Eintrag angepasst werden.
    Pt-Sensor | CoE Entry x8003:03
    Pt100 | 100
    Pt200 | 200
    Pt500 | 500
    Pt1000 | 1000

    Vergleicht man nun den Verlauf der Widerstandswerte in Abhängigkeit von der Temperatur, durch die RTD-Tabelle und nach der DIN EN 60751, so wird deutlich, dass beide Implementierungsmethoden nahezu dasselbe Ergebnis liefern. Aufgrund der leichteren Implementierung, ist die Parametrierung nach der DIN 60571 vorzuziehen.

    Abb. 4: Vergleich Implementierung Pt500-Sensor


EL320x - Prozessdaten

BECKHOFF EL320x: Inbetriebnahme

Prozessdaten und Betriebsmodi

Inhaltsverzeichnis
• Datenfluss

• Sync Manager

• Betriebmodi und Einstellungen

- Darstellung
- Siemens Bits
- Underrange, Overrange
- Notch-Filter (Wandlungszeiten)
- Limit 1 und Limit 2
- Kalibration
- Producer Codeword

• Beeinflussung durch störende Geräte

Datenfluss

Abb. 1: Datenschema

Sync Manager (SM)

PDO-Zuordnung

SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | - | 4.0 | RTD Inputs Channel1 | Index 0x6000:01 - Underrange Index 0x6000:02 - Overrange Index 0x6000:03 - Limit 1 Index 0x6000:05 - Limit 2 Index 0x6000:07 - Error Index 0x1800:07 - TxPDO Status Index 0x1800:09 - TxPDO Toggle Index 0x6000:11 - Value
0x1A01 (default) * | - | 4.0 | RTD Inputs Channel2 | Index 0x6010:01 - Underrange Index 0x6010:02 - Overrange Index 0x6010:03 - Limit 1 Index 0x6010:05 - Limit 2 Index 0x6010:07 - Error Index 0x1801:07 - TxPDO Status Index 0x1801:09 - TxPDO Toggle Index 0x6010:11 - Value
0x1A02 (default) ** | - | 4.0 | RTD Inputs Channel3 | Index 0x6020:01 - Underrange Index 0x6020:02 - Overrange Index 0x6020:03 - Limit 1 Index 0x6020:05 - Limit 2 Index 0x6020:07 - Error Index 0x1802:07 - TxPDO Status Index 0x1802:09 - TxPDO Toggle Index 0x6020:11 - Value
0x1A03(default) ** | - | 4.0 | RTD Inputs Channel4 | Index 0x6030:01 - Underrange Index 0x6030:02 - Overrange Index 0x6030:03 - Limit 1 Index 0x6030:05 - Limit 2 Index 0x6030:07 - Error Index 0x1803:07 - TxPDO Status Index 0x1803:09 - TxPDO Toggle Index 0x6030:11 - Value

* nur EL3202 und EL3204
** nur EL3204

Tab. 1: PDO-Zuordnung der SyncManager

Betriebsmodi und Einstellungen

Darstellung (Presentation), Index 80x0:02

Die Ausgabe des Messwertes erfolgt im Auslieferungszustand in 1/10° C Schritten in Zweierkomplement-Darstellung (Signed Integer).
Es wird für jeden Widerstandssensor der komplette Messbereich ausgegeben. Index 80x0:02 bietet die Möglichkeit zur Veränderung der Darstellungsweise des Messwertes.

Messwert | Ausgabe (hexadezimal) | Ausgabe (Signed Integer, dezimal)
-250,0 °C | 0xF63C | -2500
-200,0 °C | 0xF830 | -2000
-100,0 °C | 0xFC18 | -1000
-0,1 °C | 0xFFFF | -1
-0,0 °C | 0x0000 | 0
-0,1 °C | 0x0001 | 1
100,0 °C | 0x03E8 | 1000
200,0 °C | 0x07D0 | 2000
500,0 °C | 0x1388 | 5000
850,0 °C | 0x2134 | 8500

Hinweis 		Darstellung (Presentation)
• | Signed Integer: Der Messwert wird im Zweierkomplement dargestellt. Maximaler Darstellungsbereich bei 16 Bit = -32768 .. +32767 Beispiel: 1000 0000 0000 0000bin = 0x8000hex = - 32768dez 1111 1111 1111 1110bin = 0xFFFEhex = - 2dez 1111 1111 1111 1111bin = 0xFFFFhex = - 1dez 0000 0000 0000 0001bin = 0x0001hex = +1dez 0000 0000 0000 0010bin = 0x0002hex = +2dez 0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
• | Absolute value with MSB as sign: Der Messwert wird in der Betrag-Vorzeichendarstellung ausgegeben . Maximaler Darstellungsbereich bei 16 Bit = -32767 .. +32767 Beispiel: 1111 1111 1111 1111bin = 0xFFFFhex = - 32767dez 1000 0000 0000 0010bin = 0x8002hex = - 2dez 1000 0000 0000 0001bin = 0x8001hex = - 1dez 0000 0000 0000 0001bin = 0x0001hex = +1dez 0000 0000 0000 0010bin = 0x0002hex = +2dez 0111 1111 1111 1111bin = 0x7FFFhex = +32767dez
• | High resolution (1/100 C°): Der Messwert wird in 1/100 °C Schritten ausgegeben. Der maximale Messbereich ist dadurch auf 32767dez * (1/100) °C = 327,67 °C begrenzt, kann aber durch die Anwenderskalierung erweitert werden!

Siemens Bits, Index 80x0:05

Mit Setzen dieses Bits werden auf den niedrigsten 3 Bits Statusanzeigen eingeblendet. Im Fehlerfall "Overrange" bzw. "Underrange" wird Bit 0 gesetzt.

Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 60x0:02, 60x0:03

• | Pt 100: T > 850 °C (R > 400 Ω): Index 60x0:02 und Index 60x0:07 (Overrange- und Error-Bit) werden gesetzt. Die Linearisierung der Kennlinie wird mit den Koeffizienten der oberen Bereichsgrenze bis zum Endanschlag des A/D-Wandlers (ca. 500 Ω bei Pt100) fortgesetzt.
• | Pt100: T < - 200 °C (R < 18 Ω): Index 60x0:01 und Index 60x0:07 (Underrange- und Error-Bit) werden gesetzt. Es wird die kleinste negativ Zahl ausgegeben (0x8001 entspricht -32767).

Bei Overrange bzw. Underrange wird die rote Error LED eingeschaltet.

Notch- Filter, Index 80x0:06

Die Klemmen EL320xx sind mit einem digitalen Filter ausgestattet. Das Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit der Klemme. Es wird über den Index 8000:15 parametriert. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit.

Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also ausblendet. Um 50 Hz auszufiltern, kann also der 50 oder der 10 Hz Filter verwendet werden. Da üblicherweise aber alle tieferen Frequenzen als die Sperrfrequenz gemessen werden sollen, ist in diesem Fall die Einstellung "50 Hz" zu verwenden.

Abb. 1: typischer Frequenzgang eines Kerbfilters, eingestellt auf 50 Hz

Hinweis 		Index 80x0:06
Die Filterfunktion ist auch bei nicht gesetztem Bit immer aktiv:, da dies für den Messprozess obligatorisch ist!

Angaben zur Wandlungszeit

  • die Wandlungszeit ist abhängig von Anzahl Aktive Kanäle, Anzahl Messungen (2/4-wire), Filterzeit, konst. Rechenzeit
  • die Wandlungszeit ist bei 2-wire-Messung ca. doppelt so große wie bei 4-wire-Messung
  • die Widerstandmessung entspricht einer 4-wire-Messung
  • das Prozessdatum TxPdo Toggle wechselt seinen Zustand, wenn ein neuer Messwert anliegt

Hinweis 		Einstellung der Filtereigenschaften über Index 8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL320x zentral über den Index 8000:15 (Kanal 1) eingestellt.

Die entsprechenden Indizes 8010:15 der EL3202 bzw. 8010:15, 8020:15, 8030:15 der EL3204 haben keine Parametrierungsfunktion.

Hinweis 		Abschalten unbenutzter Kanäle von mehrkanaligen Klemmen
Bei Filterfrequenzen ≥ 1 kHz sollten unbenutzte Kanäle abgeschaltet werden (Optimierung der Wandlungszeiten)!

Der betreffende Kanal wird vollständig deaktiviert, die Wandlungszeit der EL320x verkürzt sich entsprechend.

Durch einen Doppelklick auf das entsprechende Objekt 80x0:1A können die entsprechenden Kanäle im Set Value Dialog abgeschaltet werden, indem der "Enum"-Wert "not connected" gewählt wird.

Abb.2: Set Value Dialog

Typische Wandlungszeiten (EL3204)

Filterfrequenz | Wandlungszeit (Updatezeit)
5 Hz | 800 ms
10 Hz | 400 ms
50 Hz | 82 ms (21 ms / 1 Kanal)
60 Hz | 70 ms
100 Hz | 43 ms
500 Hz | 11 ms
1000 Hz | 7 ms
2000 Hz | 6,5 ms (2 ms / 1 Kanal)
3750 Hz | 6 ms
7500 Hz | 6 ms
15000 Hz | 6 ms
30000 Hz | 6 ms

Tab. 3: Wandlungszeiten in Abhängigkeit der Filterfrequenzen, 4-wire-Messung - Beckhoff behält sich unangekündigte Änderungen vor

Typische Wandlungszeiten (EL3201, EL3201-0010, 4-wire-Messung)

Filterfrequenz | Wandlungszeit (Updatezeit)
5 Hz | 205 ms
10 Hz | 105 ms
50 Hz | 25 ms
60 Hz | 21 ms
100 Hz | 15 ms
500 Hz | 5 ms
1000 Hz | 4 ms
2000 Hz | 4 ms
3750 Hz | 4 ms
7500 Hz | 4 ms
15000 Hz | 4 ms
30000 Hz | 4 ms

Tab. 4: Wandlungszeiten in Abhängigkeit der Filterfrequenzen - Beckhoff behält sich unangekündigte Änderungen vor

Hinweis 		Erhöhte Genauigkeit EL320x-00x0
Bei den hochpräzisen Klemmen dürfen die Einstellungen im Objekt 8000 / RTD-Settings nicht verändert werden!
Die erhöhte Genauigkeit der EL320x-00x0 gilt nur für folgende Einstellungen:
  • Pt100-Sensoren
  • Umgebungstemperatur von 40°C
  • 4-Leiter-Anschlusstechnik
  • Messbereich -200 bis 320°C
  • 50 Hz Filter

Limit 1 und Limit 2, Index 80x0:13, Index 80x0:14

Es kann ein Temperaturbereich eingestellt werden, der mit den Werten in den Indizes 80x0:13 und 80x0:14 verglichen wird. Beim Unter/Überschreiten der Grenzwerte werden die Bits in den Prozessdaten gesetzt.

Die Limitauswertung erfolgt nach Berücksichtigung der eingestellten Kennlinie und negativer Werte.

Limit [2 Bit] Interpretation (default), Index 60x0:03, 60x0:05:

x00, 0: nicht aktiv
x01, 1: Wert ist größer als Grenzwert
x10, 2: Wert ist kleiner als der Grenzwert
x11, 3: Wert ist gleich dem Grenzwert

Kalibaration

Anwender Skalierung, Index 80x0:01

Die Freigabe der Anwender-Skalierung erfolgt über den Index 80x0:01. Die Parametrierung erfolgt über die Indizes

• | 80x0:11 Offset Anwender Skalierung
• | 80x0:12 Gain Anwender Skalierung

Hersteller Abgleich, Index 80xF

Die Freigabe des Hersteller-Abgleich erfolgt über den Index 80x0:0B. Die Parametrierung erfolgt über die Indizes

• | 80xF:01 Offset Abgleich
• | 80xF:02 Gain Abgleich
• | 80xF:03 Offset Abgleich (Eingang RL)
• | 80xF:04 Gain Abgleich (Eingang RL)
• | 80xF:05 Offset Abgleich (4-Leiter Anschlusstechnik)
• | 80xF:06 Gain Abgleich (4-Leiter Anschlusstechnik)

Anwender-Abgleich, Index 80x0:17, 80x0:18

Die Freigabe des Anwender-Abgleichs erfolgt über den Index 80x0:0A. Die Parametrierung erfolgt über die Indizes

• | 80x0:17 User Offset Abgleich
• | 80x0:18 User Gain Abgleich

Berechnung Prozessdaten

Die Klemme nimmt permanent Messwerte auf und legt die Rohwerte ihres A/D-Wandlers ins ADC raw value-Objekt 80xE:01 bzw. 80xE:02. Nach jeder Erfassung des Analogsignals erfolgt die Korrekturberechnung mit den Hersteller-Kalibrierwerten. Anschließend folgt (optional) noch die Anwenderskalierung:
YH = (XADC - BK) x AK | Messwert nach Hersteller-Kalibrierung (entspricht YA , wenn Index 80x0:0A inaktiv)
YA = YH x AW x 2-16 + BW | Messwert nach Anwender-Skalierung

Legende

Name | Bezeichnung | Index
XADC | Ausgabe Wert des A/D Wandlers | 80xE:01, 80xE:02
BK | Offset der Hersteller-Kalibrierung (nur veränderbar, wenn das Objekt Producer codeword F008 gesetzt wird) | 80xF:01, 80xF:03
AK | Gain der Hersteller-Kalibrierung (nur veränderbar, wenn das Objekt Producer codeword F008 gesetzt wird) | 80xF:02, 80xF:04
BW | Offset der Anwender-Skalierung (aktivierbar über Index 80x0:0A) | 80x0:17
AW | Gain der Anwender-Skalierung (aktivierbar über Index 80x0:0A) | 80x0:18
YA | Prozessdaten zur Steuerung | -

Producer Codeword

Hinweis 		Producer Codeword
Der Hersteller behält sich die Grundkalibrierung der Klemmen vor. Das Producer codeword ist daher z. Zt. reserviert.

Beeinflussung durch störende Geräte

Beim Betrieb der schnellen analogen EtherCAT-Klemmen EL320x können hochfrequente, überlagernde Signale von störenden Geräten (z.B. Proportionalventile, Schrittmotor- oder DC-Motor-Endstufen) von der Klemme erfasst werden. Um einen störungsfreien Betrieb zu gewährleisten, empfehlen wir den Einsatz getrennter Netzteile für die Klemmen und die Störungen verursachenden Geräte. Als zusätzliche Maßnahme sollte der integrierte Filter der Klemme (siehe Index 80x0:06 ) zugeschaltet werden.


EL320x - Objektbeschreibung und Parametrierung

BECKHOFF EL320x: Inbetriebnahme

Objektbeschreibung und Parametrierung

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen

Hinweis 		Relevante Objekte
• EL3201: alle angegebenen Objekte, außer mit Kanalangabe "Ch.2, Ch.3, Ch.4"
• EL3202: alle angegebenen Objekte, außer mit Kanalangabe "Ch.3, Ch.4"

• EL3204: alle angegebenen Objekte

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung und profilspezifische Objekte, die bei der Inbetriebnahme nötig sind
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte für die Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 RTD Settings Ch.1
Index | Name | Bedeutung | Data type | Flags | Default
8000:0 | RTD Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x1B (27dez)
8000:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
1 Absolute value with MSB as sign
Betragsvorzeichendarstellung
2 High resolution (1/100 C°) [default für Hochpräzise Klemmen EL320x-00x0, siehe Hinweis!]
Der Wert wird mit einer Auflösung von (1/100) °C ausgegeben
8000:05 Siemens bits Die S5 Bits werden in den drei niederwertigen Bits (Value 60n0:11) eingeblendet

Bit 0 = 1 ("Overange" oder "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8000:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8000:07 | Enable limit 1 | Die Statusbits werden abhängig von Limit 1 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8000:08 | Enable limit 2 | Die Statusbits werden abhängig von Limit 2 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8000:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
8000:12 User scale gain Die ist der Gain der Anwenderskalierung.
Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 .
Der Wert 1 entspricht 65535 (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8000:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8000:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8000:15 Filter settings Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 8000:06) aktiv ist.
Die möglichen Einstellungen sind fortlaufend nummeriert.

Hinweis 		Einstellung der Filtereigenschaften nur über Index 8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL320x zentral über den Index 8000:15 (Kanal 1) eingestellt.
Die entsprechenden Indizes 80n0:15 der EL3202 und der EL3204 haben keine Parametrierungsfunktion!
UINT16 RW 0x0000 (0dez)
0 | 50 Hz
1 | 60 Hz
2 | 100 Hz
3 | 500 Hz
4 | 1 kHz
5 | 2 kHz
6 | 3,75 kHz
7 | 7,5 kHz
8 | 15 kHz
9 | 30 kHz
10 | 5 Hz
11 | 10 Hz
8000:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535dez)
8000:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0 Pt100 (für Hochpräzise Klemmen siehe Hinweis!)
-200°C bis 850°C
1 Ni100
-60°C bis 250°
2 Pt1000
-200°C bis 850°C
3 Pt500
-200°C bis 850°C
4 Pt200
-200° C bis 850°C
5 Ni1000
-60°C bis 250°C
6 Ni1000
100°C: 1500 Ohm (-30 bis 160°C)
7 Ni120
-60°C bis 320°C
8 Ausgabe in Ohm
Auflösung 1/16 Ohm (10 .. 4095 Ohm)
9 Ausgabe in Ohm
Auflösung 1/64 Ohm (10 .. 1047 Ohm)
10-32 KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7
8000:1A | Connection technology | Anschlusstechnik | UINT16 | RW | 0x0000 (0dez)
0 | Zweileiter-Anschluss
1 | Dreileiter-Anschluss
2 | Vierleiter-Anschluss [default für Hochpräzise Klemmen EL320x-00x0, siehe Hinweis!]
3 | not connected
8000:1B | Wire calibration 1/32 Ohm | Abgleich der Zuleitungen | INT16 | RW | 0x0000 (0dez)
Index 8010 RTD Settings Ch.2
Index | Name | Bedeutung | Data type | Flags | Default
8010:0 | RTD Settings Ch.2 | Maximaler Subindex | UINT8 | RO | 0x1B (27dez)
8010:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8010:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
1 Absolute value with MSB as sign
Betragsvorzeichendarstellung
2 High resolution (1/100 C°) [default für Hochpräzise Klemmen EL320x-00x0, siehe Hinweis!]
Der Wert wird mit einer Auflösung von 1/100°C ausgegeben
8010:05 Siemens bits Die S5 Bits werden in den drei niederwertigen Bits (Value 60n0:11) eingeblendet

Bit 0 = 1 ("Overange" oder "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8010:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8010:07 | Enable limit 1 | Die Statusbits werden abhängig von Limit 1 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8010:08 | Enable limit 2 | Die Statusbits werden abhängig von Limit 2 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8010:09 | Enable automatic calibration | Es wird zyklisch eine Kalibrierung angestoßen. (optional) | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8010:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8010:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
8010:12 User scale gain Die ist der Gain der Anwenderskalierung.
Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 .
Der Wert 1 entspricht 65535 (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8010:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8010:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8010:15 Filter settings Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 8010:06) aktiv ist.
Die möglichen Einstellungen sind fortlaufend nummeriert.

Hinweis 		Einstellung der Filtereigenschaften nur über Index 8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL320x zentral über den Index 8000:15 (Kanal 1) eingestellt.
Die entsprechenden Indizes 80n0:15 der EL3202 und der EL3204 haben keine Parametrierungsfunktion!
UINT16 RW 0x0000 (0dez)
0 | 50 Hz
1 | 60 Hz
2 | 100 Hz
3 | 500 Hz
4 | 1 kHz
5 | 2 kHz
6 | 3,75 kHz
7 | 7,5 kHz
8 | 15 kHz
9 | 30 kHz
10 | 5 Hz
11 | 10 Hz
8010:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
8010:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535dez)
8010:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0 Pt100 (für Hochpräzise Klemmen siehe Hinweis!)
-200°C bis 850°C
1 Ni100
-60°C bis 250°
2 Pt1000
-200°C bis 850°C
3 Pt500
-200°C bis 850°C
4 Pt200
-200° C bis 850°C
5 Ni1000
-60°C bis 250°C
6 Ni1000
100°C: 1500 Ohm (-30 bis 160°C)
7 Ni120
-60°C bis 320°C
8 Ausgabe in Ohm
Auflösung 1/16 Ohm (0 .. 4095 Ohm)
9 Ausgabe in Ohm
Auflösung 1/64 Ohm (0 .. 1047 Ohm)
10 - 32 KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7
8010:1A | Connection technology | Anschlusstechnik | UINT16 | RW | 0x0000 (0dez)
0 | Zweileiter-Anschluss
1 | Dreileiter-Anschluss
2 | Vierleiter-Anschluss [default für Hochpräzise Klemmen EL320x-00x0, siehe Hinweis!]
3 | not connected
8010:1B | Wire calibration 1/32 Ohm | Abgleich der Zuleitungen | INT16 | RW | 0x0000 (0dez)
Index 8020 RTD Settings Ch.3
Index | Name | Bedeutung | Data type | Flags | Default
8020:0 | RTD Settings Ch.3 | Maximaler Subindex | UINT8 | RO | 0x1B (27dez)
8020:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8020:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
1 Absolute value with MSB as sign
Betragsvorzeichendarstellung
2 High resolution (1/100 C°)
Der Wert wird mit einer Auflösung von 1/100°C ausgegeben
8020:05 Siemens bits Die S5 Bits werden in den drei niederwertigen Bits (Value 60n0:11) eingeblendet

Bit 0 = 1 ("Overange" oder "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8020:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8020:07 | Enable limit 1 | Die Statusbits werden abhängig von Limit 1 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8020:08 | Enable limit 2 | Die Statusbits werden abhängig von Limit 2 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8020:09 | Enable automatic calibration | Es wird zyklisch eine Kalibrierung angestoßen. (optional) | BOOLEAN | RW | 0x00 (0dez)
8020:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8020:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8020:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
8020:12 User scale gain Die ist der Gain der Anwenderskalierung.
Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 .
Der Wert 1 entspricht 65535 (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8020:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8020:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8020:15 Filter settings Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 8020:06) aktiv ist.
Die möglichen Einstellungen sind fortlaufend nummeriert.

Hinweis 		Einstellung der Filtereigenschaften nur über Index 8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL320x zentral über den Index 8000:15 (Kanal 1) eingestellt.
Die entsprechenden Indizes 80n0:15 der EL3202 und der EL3204 haben keine Parametrierungsfunktion!
UINT16 RW 0x0000 (0dez)
0 | 50 Hz
1 | 60 Hz
2 | 100 Hz
3 | 500 Hz
4 | 1 kHz
5 | 2 kHz
6 | 3,75 kHz
7 | 7,5 kHz
8 | 15 kHz
9 | 30 kHz
10 | 5 Hz
11 | 10 Hz
8020:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
8020:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535dez)
8020:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0 Pt100
-200°C bis 850°C
1 Ni100
-60°C bis 250°
2 Pt1000
-200°C bis 850°C
3 Pt500
-200°C bis 850°C
4 Pt200
-200° C bis 850°C
5 Ni1000
-60°C bis 250°C
6 Ni1000
100°C: 1500 Ohm (-30 bis 160°C)
7 Ni120
-60°C bis 320°C
8 Ausgabe in Ohm
Auflösung 1/16 Ohm (0 .. 4095 Ohm)
9 Ausgabe in Ohm
Auflösung 1/64 Ohm (0 .. 1047 Ohm)
10-32 KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7
8020:1A | Connection technology | Anschlusstechnik | UINT16 | RW | 0x0000 (0dez)
0 | Zweileiter-Anschluss
1 | Dreileiter-Anschluss
2 | Vierleiter-Anschluss
3 | not connected
8020:1B | Wire calibration 1/32 Ohm | Abgleich der Zuleitungen | INT16 | RW | 0x0000 (0dez)
Index 8030 RTD Settings Ch.4
Index | Name | Bedeutung | Data type | Flags | Default
8030:0 | RTD Settings Ch.4 | Maximaler Subindex | UINT8 | RO | 0x1B (27dez)
8030:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8030:02 | Presentation | 0 | Signed presentation | BIT3 | RW | 0x00 (0dez)
1 Absolute value with MSB as sign
Betragsvorzeichendarstellung
2 High resolution (1/100 C°)
Der Wert wird mit einer Auflösung von 1/100°C ausgegeben
8030:05 Siemens bits Die S5 Bits werden in den drei niederwertigen Bits (Value 60n0:11) eingeblendet

Bit 0 = 1 ("Overange" oder "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8030:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8030:07 | Enable limit 1 | Die Statusbits werden abhängig von Limit 1 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8030:08 | Enable limit 2 | Die Statusbits werden abhängig von Limit 2 gesetzt | BOOLEAN | RW | 0x00 (0dez)
8030:09 | Enable automatic calibration | Es wird zyklisch eine Kalibrierung angestoßen. (optional) | BOOLEAN | RW | 0x00 (0dez)
8030:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8030:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8030:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
8030:12 User scale gain Die ist der Gain der Anwenderskalierung.
Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 .
Der Wert 1 entspricht 65535 (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8030:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8030:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits (Auflösung 0,1 °C) | INT16 | RW | 0x0000 (0dez)
8030:15 Filter settings Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 8030:06) aktiv ist.
Die möglichen Einstellungen sind fortlaufend nummeriert.

Hinweis 		Einstellung der Filtereigenschaften nur über Index 8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL320x zentral über den Index 8000:15 (Kanal 1) eingestellt.
Die entsprechenden Indizes 80n0:15 der EL3202 und der EL3204 haben keine Parametrierungsfunktion!
UINT16 RW 0x0000 (0dez)
0 | 50 Hz
1 | 60 Hz
2 | 100 Hz
3 | 500 Hz
4 | 1 kHz
5 | 2 kHz
6 | 3,75 kHz
7 | 7,5 kHz
8 | 15 kHz
9 | 30 kHz
10 | 5 Hz
11 | 10 Hz
8030:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
8030:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535dez)
8030:19 | RTD element | RTD element | UINT16 | RW | 0x0000 (0dez)
0 Pt100
-200°C bis 850°C
1 Ni100
-60°C bis 250°
2 Pt1000
-200°C bis 850°C
3 Pt500
-200°C bis 850°C
4 Pt200
-200° C bis 850°C
5 Ni1000
-60°C bis 250°C
6 Ni1000
100°C: 1500 Ohm (-30 bis 160°C)
7 Ni120
-60°C bis 320°C
8 Ausgabe in Ohm
Auflösung 1/16 Ohm (0 .. 4095 Ohm)
9 Ausgabe in Ohm
Auflösung 1/64 Ohm (0 .. 1047 Ohm)
10-32 KT100/110/130/210/230 KTY10/11/13/16/19
KTY81/82-110,120,150 (-50...150°C)
KTY81-121
KTY81-122
KTY81-151
KTY81-152
KTY81/82-210,220,250
KTY81-221
KTY81-222
KTY81-251
KTY81-252
KTY83-110,120,150 (-50...175°C)
KTY83-121
KTY83-122
KTY83-151
KTY83-152
KTY84-130,150 (-40...300°C)
KTY84-151
KTY21/23-6 (-50...150°C)
KTY1x-5
KTY1x-7
KTY21/23-5
KTY21/23-7
8030:1A | Connection technology | Anschlusstechnik | UINT16 | RW | 0x0000 (0dez)
0 | Zweileiter-Anschluss
1 | Dreileiter-Anschluss
2 | Vierleiter-Anschluss
3 | not connected
8030:1B | Wire calibration 1/32 Ohm | Abgleich der Zuleitungen | INT16 | RW | 0x0000 (0dez)

Vollständige Übersicht

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01401389 (20976521dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL320x-0000
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0C843052 (209989714dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1800 TxPDO-Par Ch.1
Index | Name | Bedeutung | Data type | Flags | Default
1800:0 | TxPDO-Par Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:07 | TxPDO-State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1801 TxPDO-Par Ch.2
Index | Name | Bedeutung | Data type | Flags | Default
1801:0 | TxPDO-Par Ch.2 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:07 | TxPDO-State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1802 TxPDO-Par Ch.3
Index | Name | Bedeutung | Data type | Flags | Default
1802:0 | TxPDO-Par Ch.3 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1802:07 | TxPDO-State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1802:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1803 TxPDO-Par Ch.4
Index | Name | Bedeutung | Data type | Flags | Default
1803:0 | TxPDO-Par Ch.4 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1803:07 | TxPDO-State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1803:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1A00 TxPDO-Map Ch.1
Index | Name | Bedeutung | Data type | Flags | Default
1A00:0 | TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RW | 0x09 (9dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RW | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RW | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6000:03, 2
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6000:05, 2
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RW | 0x6000:07, 1
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800 (TxPDO-Par Ch.1), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1800:07, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800 (TxPDO-Par Ch.1), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1800:09, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RW | 0x6000:11, 16
Index 1A01 TxPDO-Map Ch.2
Index | Name | Bedeutung | Data type | Flags | Default
1A01:0 | TxPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RW | 0x09 (9dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RW | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RW | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6010:03, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6010:05, 2
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RW | 0x6010:07, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1801 (TxPDO-Par Ch.2), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1801:07, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1801 (TxPDO-Par Ch.2), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1801:09, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RW | 0x6010:11, 16
Index 1A02 TxPDO-Map Ch.3
Index | Name | Bedeutung | Data type | Flags | Default
1A02:0 | TxPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RW | 0x09 (9dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RW | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RW | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6020:03, 2
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6020:05, 2
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RW | 0x6020:07, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802 (TxPDO-Par Ch.3), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1802:07, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1802 (TxPDO-Par Ch.3), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1802:09, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RW | 0x6020:11, 16
Index 1A03 TxPDO-Map Ch.4
Index | Name | Bedeutung | Data type | Flags | Default
1A03:0 | TxPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RW | 0x09 (9dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RW | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RW | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x03 (Limit 1)) | UINT32 | RW | 0x6030:03, 2
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x05 (Limit 2)) | UINT32 | RW | 0x6030:05, 2
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RW | 0x6030:07, 1
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RW | 0x0000:00, 7
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1803 (TxPDO-Par Ch.4), entry 0x07 (TxPDO-State)) | UINT32 | RW | 0x1803:07, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1803 (TxPDO-Par Ch.4), entry 0x09 (TxPDO-Toggle)) | UINT32 | RW | 0x1803:09, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RW | 0x6030:11, 16
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x00 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x07 (7dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0000 (0dez)
1C33:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron with SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
 UINT32 RW 0x00000000 (0dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RW | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C33:08)
 UINT16 RO 0x8007 (32775dez)
1C33:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x00000000 (0dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestoppt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt

UINT16 RW 0x0000 (0dez)
1C33:09 | Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 RTD Inputs Ch.1
Index | Name | Bedeutung | Data type | Flags | Default
6000:0 | RTD Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6000:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Overrange | Der Messbereich wird überschritten. ("open circuit" Erkennung wenn "Error" [Index 60n0:07]) gesetzt ist | BOOLEAN | RO | 0x00 (0dez)
6000:03 | Limit 1 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6000:05 | Limit 2 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6000:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0dez)
6000:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6000:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0dez)
Index 6010 RTD Inputs Ch.2
Index | Name | Bedeutung | Data type | Flags | Default
6010:0 | RTD Inputs Ch.2 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6010:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Overrange | Der Messbereich wird überschritten. ("open circuit" Erkennung wenn "Error" [Index 60n0:07]) gesetzt ist | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Limit 1 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6010:05 | Limit 2 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6010:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0dez)
6010:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0dez)
Index 6020 RTD Inputs Ch.3
Index | Name | Bedeutung | Data type | Flags | Default
6020:0 | RTD Inputs Ch.3 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6020:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6020:02 | Overrange | Der Messbereich wird überschritten. ("open circuit" Erkennung wenn "Error" [Index 60n0:07]) gesetzt ist | BOOLEAN | RO | 0x00 (0dez)
6020:03 | Limit 1 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6020:05 | Limit 2 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6020:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0dez)
6020:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0dez)
Index 6030 RTD Inputs Ch.4
Index | Name | Bedeutung | Data type | Flags | Default
6030:0 | RTD Inputs Ch.4 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
6030:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0dez)
6030:02 | Overrange | Der Messbereich wird überschritten. ("open circuit" Erkennung wenn "Error" [Index 60n0:07]) gesetzt ist | BOOLEAN | RO | 0x00 (0dez)
6030:03 | Limit 1 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6030:05 | Limit 2 | Grenzwertüberwachung 0: nicht aktiv 1: Wert ist größer als Grenzwert 2: Wert ist kleiner als Grenzwert 3: Wert ist gleich dem Grenzwert | BIT2 | RO | 0x00 (0dez)
6030:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0dez)
6030:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
6030:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6030:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0dez)
Index 800E RTD Internal data Ch.1
Index | Name | Bedeutung | Data type | Flags | Default
800E:0 | RTD Internal data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
800E:01 | ADC raw value 1 | ADC Rohwert 1 | INT32 | RO | 0x00000000 (0dez)
800E:02 | Resistor 1 | Widerstand 1 (Messwert Widerstandssensor, Auflösung 1/32 Ohm) | UINT16 | RO | 0x0000 (0dez)
800E:03 | ADC raw value 2 | ADC Rohwert 2 [nur bei EL3201 und EL3202] | INT32 | RO | 0x00000000 (0dez)
800E:04 | Resistor 2 | Widerstand 2 (Messwert der Zuleitung, Auflösung 1/32 Ohm) [nur bei EL3201 und EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 800F RTD Vendor data Ch.1
Index | Name | Bedeutung | Data type | Flags | Default
800F:0 | RTD Vendor data Ch.1 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
800F:01 | Calibration offset | Hersteller Offset Abgleich | INT16 | RW | 0x0000 (0dez)
800F:02 | Calibration gain | Hersteller Gain Abgleich | UINT16 | RW | 0x9E50 (40528dez)
800F:03 | Calibration offset RL | Hersteller Offset Abgleich (Eingang RL) | INT16 | RW | 0x0000 (0dez)
800F:04 | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | 0x9E50 (40528dez)
800F:05 | Calibration offset 4-wire | Hersteller Offset Abgleich (4- Leiter Anschlusstechnik) | INT16 | RW | 0x0000 (0dez)
800F:06 | Calibration gain 4-wire | Hersteller Gain Abgleich (4- Leiter Anschlusstechnik) | UINT16 | RW | 0x9E50 (40528dez)
Index 801E RTD Internal data Ch.2
Index | Name | Bedeutung | Data type | Flags | Default
801E:0 | RTD Internal data Ch.2 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
801E:01 | ADC raw value 1 | ADC Rohwert 1 | INT32 | RO | 0x00000000 (0dez)
801E:02 | Resistor 1 | Widerstand 1 (Messwert Widerstandssensor, Auflösung 1/32 Ohm) | UINT16 | RO | 0x0000 (0dez)
801E:03 | ADC raw value 2 | ADC Rohwert 2 [nur bei EL3201 und EL3202] | INT32 | RO | 0x00000000 (0dez)
801E:04 | Resistor 2 | Widerstand 2 (Messwert der Zuleitung, Auflösung 1/32 Ohm) [nur bei EL3201 und EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 801F RTD Vendor data Ch.2
Index | Name | Bedeutung | Data type | Flags | Default
801F:0 | RTD Vendor data Ch.2 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
801F:01 | Calibration offset | Hersteller Offset Abgleich | INT16 | RW | 0x0000 (0dez)
801F:02 | Calibration gain | Hersteller Gain Abgleich | UINT16 | RW | 0x9E50 (40528dez)
801F:03 | Calibration offset RL | Hersteller Offset Abgleich (Eingang RL) | INT16 | RW | 0x0000 (0dez)
801F:04 | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | 0x9E50 (40528dez)
801F:05 | Calibration offset 4-wire | Hersteller Offset Abgleich (4- Leiter Anschlusstechnik) | INT16 | RW | 0x0000 (0dez)
801F:06 | Calibration gain 4-wire | Hersteller Gain Abgleich (4- Leiter Anschlusstechnik) | UINT16 | RW | 0x9E50 (40528dez)
Index 802E RTD Internal data Ch.3
Index | Name | Bedeutung | Data type | Flags | Default
802E:0 | RTD Internal data Ch.3 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
802E:01 | ADC raw value 1 | ADC Rohwert 1 | INT32 | RO | 0x00000000 (0dez)
802E:02 | Resistor 1 | Widerstand 1 (Messwert Widerstandssensor, Auflösung 1/32 Ohm) | UINT16 | RO | 0x0000 (0dez)
802E:03 | ADC raw value 2 | ADC Rohwert 2 [nur bei EL3201 und EL3202] | INT32 | RO | 0x00000000 (0dez)
802E:04 | Resistor 2 | Widerstand 2 (Messwert der Zuleitung, Auflösung 1/32 Ohm) [nur bei EL3201 und EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 802F RTD Vendor data Ch.3
Index | Name | Bedeutung | Data type | Flags | Default
802F:0 | RTD Vendor data Ch.3 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
802F:01 | Calibration offset | Hersteller Offset Abgleich | INT16 | RW | 0x0000 (0dez)
802F:02 | Calibration gain | Hersteller Gain Abgleich | UINT16 | RW | 0x9E50 (40528dez)
802F:03 | Calibration offset RL | Hersteller Offset Abgleich (Eingang RL) | INT16 | RW | 0x0000 (0dez)
802F:04 | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | 0x9E50 (40528dez)
802F:05 | Calibration offset 4-wire | Hersteller Offset Abgleich (4- Leiter Anschlusstechnik) | INT16 | RW | 0x0000 (0dez)
802F:06 | Calibration gain 4-wire | Hersteller Gain Abgleich (4- Leiter Anschlusstechnik) | UINT16 | RW | 0x9E50 (40528dez)
Index 803E RTD Internal data Ch.4
Index | Name | Bedeutung | Data type | Flags | Default
803E:0 | RTD Internal data Ch.4 | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
803E:01 | ADC raw value 1 | ADC Rohwert 1 | INT32 | RO | 0x00000000 (0dez)
803E:02 | Resistor 1 | Messwert Widerstandssensor (Auflösung 1/32 Ohm) | UINT16 | RO | 0x0000 (0dez)
803E:03 | ADC raw value 2 | ADC Rohwert 2 [nur bei EL3201 und EL3202] | INT32 | RO | 0x00000000 (0dez)
803E:04 | Resistor 2 | Messwert der Zuleitung (Auflösung 1/32 Ohm) [nur bei EL3201 und EL3202] | UINT16 | RO | 0x0000 (0dez)
Index 803F RTD Vendor data Ch.4
Index | Name | Bedeutung | Data type | Flags | Default
803F:0 | RTD Vendor data Ch.4 | Maximaler Subindex | UINT8 | RO | 0x06 (6dez)
803F:01 | Calibration offset | Hersteller Offset Abgleich | INT16 | RW | 0x0000 (0dez)
803F:02 | Calibration gain | Hersteller Gain Abgleich | UINT16 | RW | 0x9E50 (40528dez)
803F:03 | Calibration offset RL | Hersteller Offset Abgleich (Eingang RL) | INT16 | RW | 0x0000 (0dez)
803F:04 | Calibration gain RL | Hersteller Gain Abgleich (Eingang RL) | UINT16 | RW | 0x9E50 (40528dez)
803F:05 | Calibration offset 4-wire | Hersteller Offset Abgleich (4- Leiter Anschlusstechnik) | INT16 | RW | 0x0000 (0dez)
803F:06 | Calibration gain 4-wire | Hersteller Gain Abgleich (4- Leiter Anschlusstechnik) | UINT16 | RW | 0x9E50 (40528dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index | Name | Bedeutung | Data type | Flags | Default
F008:0 | Code word | z.Zt. reserviert | UINT32 | RW | 0x00000000 (0dez)


EL320x-0200 - Objektbeschreibung und Parametrierung

BECKHOFF EL320x-0200: Inbetriebnahme

Objektbeschreibung und Parametrierung

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung und profilspezifische Objekte, die bei der Inbetriebnahme nötig sind
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte für die Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 RTD Settings Ch.1

Index

Name

Bedeutung

Datentyp

Flags

Default
8000:0 | RTD Settings Ch.1 | Maximaler Subindex | UINT8 | RO | 0x1B (27dez)
8000:01 | Enable user scale | Die Anwender Skalierung ist aktiv. | BOOLEAN | RW | 0x00 (0dez)
8000:02 | Process data Presentation | erlaubte Werte | BIT3 | RW | 0x00 (0dez)
0 | Signed
1 | Absolute MSB sign
2 | High resolution (1/100°C)
8000:05 Siemens bits Die S5 Bits werden in den drei niederwertigen Bits (Value 60n0:11) eingeblendet

Bit 0 = 1 ("Overange" oder "Underrange")
Bit 1 (not used)
Bit 2 (not used) 		BOOLEAN RW 0x00 (0dez)
8000:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x01 (1dez)
8000:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
8000:12 User scale gain Die ist der Gain der Anwenderskalierung.
Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16 .
Der Wert 1 entspricht 65535 (0x00010000). 		INT32 RW 0x00010000 (65536dez)
8000:15 Filter settings Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 8000:06) aktiv ist.
Die möglichen Einstellungen sind fortlaufend nummeriert.

Hinweis 		Einstellung der Filtereigenschaften nur über Index 8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL320x zentral über den Index 8000:15 (Kanal 1) eingestellt.
Die entsprechenden Indizes 80n0:15 der EL3202 und der EL3204 haben keine Parametrierungsfunktion!

erlaubte Werte:

UINT16 RW 0x0000 (0dez)
0 | 50 Hz
1 | 60 Hz
2 | 100 Hz
3 | 500 Hz
4 | 1 kHz
5 | 2 kHz
6 | 3,75 kHz
7 | 7,5 kHz
8 | 15 kHz
9 | 30 kHz
10 | 5 Hz
11 | 10 Hz
8000:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
8000:18 | User calibration gain | Anwender Gain Abgleich | UINT16 | RW | 0xFFFF (65535dez)
8000:19 RTD element erlaubte Werte: UINT16 RW 0x0000 (0dez)
0 | PT1000 (-200...850°C)
2 | NI1000 100°C (bei 100°C 1500 Ohm, -30...160°C)
3 | NI1000 (-60...250°C)
4 | NTC 5k (0°C: 16325 Ohm, -40...100°C)
5 | NTC 10k (0°C: 32650 Ohm, -30...150°C)
6 | NTC 10k (0°C: 29490 Ohm, -30...150°C)
7 | NTC 10k (0°C: 27280 Ohm, -40...110°C, wie KL3204-0030)
8 | NTC 20k (0°C: 70200 Ohm, -20...150°C)
9 | Fet (-30...150°C)
101 | Widerstand 1/10 Ohm Auflösung (0...6553,5 Ohm)
102 | Widerstand 1/10 Ohm Auflösung (0...65 535 Ohm)
103 | Widerstand 1/10 Ohm Auflösung (0...240 kOhm)
110 | RTD-Tabelle (weitere Parameter siehe x80n1)
111 | B-Parameter Equation (weitere Parameter siehe x80n2)
112 | DIN IEC 60751 Equation (weitere Parameter siehe x80n3)
113 | Steinhart Hart Equation (weitere Parameter siehe x80n4)
8000:1A | Connection technology | erlaubte Werte | UINT16 | RW | 0x0000 (0dez)
0 | Zweileiter-Anschluss
3 | n. c. (Kanal deaktiviert)
8000:1B Wire calibration Offset-Wert zum Abgleich der Zuleitungen

[1/10] Ohm

 INT16 RW 0x0000 (0dez)
Index 8001 RTD Table

Die Standardwerte in der folgenden Tabelle zeigen beispielhaft die Umrechnungswerte eines Pt1000 im Bereich von 0°C bis 140°C mit einer Auflösung von 1/10 Ohm

Index | Name | Bedeutung | Datentyp | Flags | Default
8001:0 | RTD Table | Mit dieser Tabelle kann die Sensor Charakteristik programmiert werden | UINT8 | RO | 105
8001:01 | Distance in Degrees | Gesetzter Wert beschreibt den Abstand der Einträge in °C | UINT16 | RW | 10
8001:02 | Amount of Entries | Eingetragener Wert beschreibt die Anzahl der Einträge, mit der nach der unteren Gleichung die Abhängigkeit von Abstand in °C, Start-Temperatur vom Messbereich und Endtemperatur dargestellt wird Endtemperatur = Starttemperatur + ((Anzahl der Einträge -1) * Abstand in °C) | UINT16 | RW | 15
8001:03 | Start Temperature | Der eingetragene Wert beschreibt den Anfang des Messbereichs Standardwert 0°C | INT16 | RW | 0
8001:04 | Conversion Factor | 1 = 1/10 Ohm pro Digit in der Tabelleneinträgen 10 = 1 Ohm pro Digit in der Tabelleneinträgen 100 = 10 Ohm pro Digit in der Tabelleneinträgen | UINT16 | RW | 1
8001:05 | Value 1 |  | UINT16 | RW | 0x2710 (10000dez)
8001:06 | Value 2 |  | UINT16 | RW | 0x2896 (10390dez)
8001:07 | Value 3 |  | UINT16 | RW | 0x2A1B (10779dez)
8001:08 | Value 4 |  | UINT16 | RW | 0x2B9F (11167dez)
8001:09 | Value 5 |  | UINT16 | RW | 0x2D22 (11554dez)
8001:0A | Value 6 |  | UINT16 | RW | 0x2EA3 (11939dez)
8001:0B | Value 7 |  | UINT16 | RW | 0x3024 (12324dez)
8001:0C | Value 8 |  | UINT16 | RW | 0x31A3 (12707dez)
8001:0D | Value 9 |  | UINT16 | RW | 0x3321 (13089dez)
8001:0E | Value 10 |  | UINT16 | RW | 0x349E (13470dez)
8001:0F | Value 11 |  | UINT16 | RW | 0x361A (13850dez)
8001:10 | Value 12 |  | UINT16 | RW | 0x3795 (14229dez)
8001:11 | Value 13 |  | UINT16 | RW | 0x390E (14606dez)
8001:13 | Value 14 |  | UINT16 | RW | 0x3A87 (14983dez)
8001:14 | Value 15 |  | UINT16 | RW | 0x3BFE (15358dez)
8001:15 | Value 16 |  | UINT16 | RW | 0x0000 (0dez)
8001:16 | Value 17 |  | UINT16 | RW | 0x0000 (0dez)
8001:17 | Value 18 |  | UINT16 | RW | 0x0000 (0dez)
8001:18 | Value 19 |  | UINT16 | RW | 0x0000 (0dez)
8001:19 | Value 20 |  | UINT16 | RW | 0x0000 (0dez)
8001:1A | Value 21 |  | UINT16 | RW | 0x0000 (0dez)
8001:1B | Value 22 |  | UINT16 | RW | 0x0000 (0dez)
8001:1C | Value 23 |  | UINT16 | RW | 0x0000 (0dez)
8001:1D | Value 24 |  | UINT16 | RW | 0x0000 (0dez)
8001:1E | Value 25 |  | UINT16 | RW | 0x0000 (0dez)
8001:1F | Value 26 |  | UINT16 | RW | 0x0000 (0dez)
8001:20 | Value 27 |  | UINT16 | RW | 0x0000 (0dez)
8001:21 | Value 28 |  | UINT16 | RW | 0x0000 (0dez)
8001:22 | Value 29 |  | UINT16 | RW | 0x0000 (0dez)
8001:23 | Value 30 |  | UINT16 | RW | 0x0000 (0dez)
8001:24 | Value 31 |  | UINT16 | RW | 0x0000 (0dez)
8001:25 | Value 32 |  | UINT16 | RW | 0x0000 (0dez)
8001:26 | Value 33 |  | UINT16 | RW | 0x0000 (0dez)
8001:27 | Value 34 |  | UINT16 | RW | 0x0000 (0dez)
8001:28 | Value 35 |  | UINT16 | RW | 0x0000 (0dez)
8001:29 | Value 36 |  | UINT16 | RW | 0x0000 (0dez)
8001:2A | Value 37 |  | UINT16 | RW | 0x0000 (0dez)
8001:2B | Value 38 |  | UINT16 | RW | 0x0000 (0dez)
8001:2C | Value 39 |  | UINT16 | RW | 0x0000 (0dez)
8001:2D | Value 40 |  | UINT16 | RW | 0x0000 (0dez)
8001:2E | Value 41 |  | UINT16 | RW | 0x0000 (0dez)
8001:2F | Value 42 |  | UINT16 | RW | 0x0000 (0dez)
8001:30 | Value 43 |  | UINT16 | RW | 0x0000 (0dez)
8001:31 | Value 44 |  | UINT16 | RW | 0x0000 (0dez)
8001:32 | Value 45 |  | UINT16 | RW | 0x0000 (0dez)
8001:33 | Value 46 |  | UINT16 | RW | 0x0000 (0dez)
8001:34 | Value 47 |  | UINT16 | RW | 0x0000 (0dez)
8001:35 | Value 48 |  | UINT16 | RW | 0x0000 (0dez)
8001:36 | Value 49 |  | UINT16 | RW | 0x0000 (0dez)
8001:37 | Value 50 |  | UINT16 | RW | 0x0000 (0dez)
8001:38 | Value 51 |  | UINT16 | RW | 0x0000 (0dez)
8001:39 | Value 52 |  | UINT16 | RW | 0x0000 (0dez)
8001:3A | Value 53 |  | UINT16 | RW | 0x0000 (0dez)
8001:3B | Value 54 |  | UINT16 | RW | 0x0000 (0dez)
8001:3C | Value 55 |  | UINT16 | RW | 0x0000 (0dez)
8001:3D | Value 56 |  | UINT16 | RW | 0x0000 (0dez)
8001:3E | Value 57 |  | UINT16 | RW | 0x0000 (0dez)
8001:3F | Value 58 |  | UINT16 | RW | 0x0000 (0dez)
8001:40 | Value 59 |  | UINT16 | RW | 0x0000 (0dez)
8001:41 | Value 60 |  | UINT16 | RW | 0x0000 (0dez)
8001:42 | Value 61 |  | UINT16 | RW | 0x0000 (0dez)
8001:43 | Value 62 |  | UINT16 | RW | 0x0000 (0dez)
8001:44 | Value 63 |  | UINT16 | RW | 0x0000 (0dez)
8001:45 | Value 64 |  | UINT16 | RW | 0x0000 (0dez)
8001:46 | Value 65 |  | UINT16 | RW | 0x0000 (0dez)
8001:47 | Value 66 |  | UINT16 | RW | 0x0000 (0dez)
8001:48 | Value 67 |  | UINT16 | RW | 0x0000 (0dez)
8001:49 | Value 68 |  | UINT16 | RW | 0x0000 (0dez)
8001:4A | Value 69 |  | UINT16 | RW | 0x0000 (0dez)
8001:4B | Value 70 |  | UINT16 | RW | 0x0000 (0dez)
8001:4C | Value 71 |  | UINT16 | RW | 0x0000 (0dez)
8001:4D | Value 72 |  | UINT16 | RW | 0x0000 (0dez)
8001:4E | Value 73 |  | UINT16 | RW | 0x0000 (0dez)
8001:4F | Value 74 |  | UINT16 | RW | 0x0000 (0dez)
8001:50 | Value 75 |  | UINT16 | RW | 0x0000 (0dez)
8001:51 | Value 76 |  | UINT16 | RW | 0x0000 (0dez)
8001:52 | Value 77 |  | UINT16 | RW | 0x0000 (0dez)
8001:53 | Value 78 |  | UINT16 | RW | 0x0000 (0dez)
8001:54 | Value 79 |  | UINT16 | RW | 0x0000 (0dez)
8001:55 | Value 80 |  | UINT16 | RW | 0x0000 (0dez)
8001:56 | Value 81 |  | UINT16 | RW | 0x0000 (0dez)
8001:57 | Value 82 |  | UINT16 | RW | 0x0000 (0dez)
8001:58 | Value 83 |  | UINT16 | RW | 0x0000 (0dez)
8001:59 | Value 84 |  | UINT16 | RW | 0x0000 (0dez)
8001:5A | Value 85 |  | UINT16 | RW | 0x0000 (0dez)
8001:5B | Value 86 |  | UINT16 | RW | 0x0000 (0dez)
8001:5C | Value 87 |  | UINT16 | RW | 0x0000 (0dez)
8001:5D | Value 88 |  | UINT16 | RW | 0x0000 (0dez)
8001:5E | Value 89 |  | UINT16 | RW | 0x0000 (0dez)
8001:5F | Value 90 |  | UINT16 | RW | 0x0000 (0dez)
8001:60 | Value 91 |  | UINT16 | RW | 0x0000 (0dez)
8001:61 | Value 92 |  | UINT16 | RW | 0x0000 (0dez)
8001:62 | Value 93 |  | UINT16 | RW | 0x0000 (0dez)
8001:63 | Value 94 |  | UINT16 | RW | 0x0000 (0dez)
8001:64 | Value 95 |  | UINT16 | RW | 0x0000 (0dez)
8001:65 | Value 96 |  | UINT16 | RW | 0x0000 (0dez)
8001:66 | Value 97 |  | UINT16 | RW | 0x0000 (0dez)
8001:67 | Value 98 |  | UINT16 | RW | 0x0000 (0dez)
8001:68 | Value 99 |  | UINT16 | RW | 0x0000 (0dez)
8001:69 | Value 100 |  | UINT16 | RW | 0x0000 (0dez)
Index 8002 RTD B-Parameter Equation
Index | Name | Bedeutung | Datentyp | Flags | Default
8002:0 | RTD B-Parameter Equation |  | UINT8 | RO | 0x05 (5dez)
8002:01 | Min Temperature | Anfang des Messbereichs in °C. | INT16 | RW | -30
8002:02 | Max Temperature | Ende des Messbereichs in °C. | INT16 | RW | 150
8002:03 | Rn | Widerstandswert bei Tn. In den meisten Fällen = 25°C. | INT16 | RW | 1000
8002:04 | Tn | Referenztemperatur für Rn [°C] | INT16 | RW | 25
8002:05 | B-Parameter | B-Parameter [Kelvin] | REAL32 | RW | 3710
Index 8003 RTD DIN EN 60751 Equation
Index | Name | Bedeutung | Datentyp | Flags | Default
8003:0 | RTD DIN EN 60751 Equation | Standard-Parameter PT1000 im Bereich von 0 bis 850°C. | UINT8 | RO | 0x06 (6dez)
8003:01 | Min Temperature | Anfang des Messbereichs in °C. | INT16 | RW | 0
8003:02 | Max Temperature | Ende des Messbereichs in °C. | INT16 | RW | 850
8003:03 | R0 | siehe Gleichung | UINT16 | RW | 1000
8003:04 | A Parameter | siehe Gleichung | REAL32 | RW | 3,908E-3
8003:05 | B Parameter | siehe Gleichung | REAL32 | RW | -5,775E-7
8003:06 | C Parameter | siehe Gleichung | REAL32 | RW | -4,183E-12
Index 8004 RTD Steinhart Hart Equation
Index | Name | Bedeutung | Datentyp | Flags | Default
8004:0 | RTD Steinhart Hart Equation | Standardwerte für einen NTC10K mit 32650 Ohm bei 0°C: C1 default = 1.12119E-03 C2 default = 2.35346E-04 C3 default = 0 C4 default = 8.34620E-08 | UINT8 | RO | 0x06 (6dez)
8004:01 | Min Temperature | Anfang des Messbereichs in °C. | INT16 | RW | -30
8004:02 | Max Temperature | Ende des Messbereichs in °C. | INT16 | RW | 150
8004:03 | C1 | siehe Gleichung | REAL32 | RW | 1,1211E-03
8004:04 | C2 | siehe Gleichung | REAL32 | RW | 2,35346E-04
8004:05 | C3 | siehe Gleichung | REAL32 | RW | 0
8004:06 | C4 | siehe Gleichung | REAL32 | RW | 8,24620E-08
Index 800E RTD Internal Data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
800E:0 | RTD Internal Data Ch.1 | Max. Subindex | UINT8 | RO |
800E:01 | ADC raw value | ADC raw value. | INT32 | RO |
800E:02 | Resistor (1/10 Ohm) | resultierender gemessener Widerstand | UINT32 | RO |
Index 800F RTD Vendor Data Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
800F:0 | RTD Vendor Data Ch.1 | Max. Subindex | UINT8 | RO | 0x03 (3dez)
800F:01 | Calibration offset | Kalibierungs-Offset | INT32 | RW | 0x00000DAC (3500dez)
800F:02 | Calibration gain | Gain Wert für Messbereich 0..5000 Ohm | UINT16 | RW | 0x3D68 (15720dez)
800F:03 | Calibration gain ext. | Gain Wert für Messbereichrange 5..240 kOhm | UINT16 | RW | 0x05A0 (1440dez)

Werte der anderen Kanäle 2-4 entsprechend.

Vollständige Übersicht

Standardobjekte

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Data type | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x01401389 (20976521dez)
Index 1008 Device name
Index | Name | Bedeutung | Data type | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL3204-0200
Index 1009 Hardware version
Index | Name | Bedeutung | Data type | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index | Name | Bedeutung | Data type | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Data type | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0C843052 (209989714dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Data type | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1800 RTD TxPDO-Par Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | RTD TxPDO-Par Ch.1 | PDO Parameter TxPDO 1 | UINT8 | RO | 0x09 (9dez)
1800:06 | Exclude TxPDOs | Dieser Eintrag enthält die TxPDOs (Index der TxPDO Mapping Objekte) die nicht mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[0] | RO |
1800:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1800:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1801 RTD TxPDO-Par Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | RTD TxPDO-Par Ch.2 | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Dieser Eintrag enthält die TxPDOs (Index der TxPDO Mapping Objekte) die nicht mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[0] | RO |
1801:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1802 RTD TxPDO-Par Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | RTD TxPDO-Par Ch.3 | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1802:06 | Exclude TxPDOs | Dieser Eintrag enthält die TxPDOs (Index der TxPDO Mapping Objekte) die nicht mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[0] | RO |
1802:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1802:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1803 RTD TxPDO-Par Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
1803:0 | RTD TxPDO-Par Ch.4 | PDO Parameter TxPDO 4 | UINT8 | RO | 0x09 (9dez)
1803:06 | Exclude TxPDOs | Dieser Eintrag enthält die TxPDOs (Index der TxPDO Mapping Objekte) die nicht mit TxPDO 4 übertragen werden dürfen | OCTET-STRING[0] | RO |
1803:07 | TxPDO State | Der TxPDO State wird gesetzt, wenn die zugehörigen Eingangsdaten nicht korrekt eingelesen werden konnten | BOOLEAN | RO | 0x00 (0dez)
1803:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1A00 RTD TxPDO-Map Ch.1
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | RTD TxPDO-Map Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1800 (RTD TxPDO-Par Ch.1), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1800:07, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1800 (RTD TxPDO-Par Ch.1), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1800:09, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (RTD Inputs Ch.1), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 1A01 RTD TxPDO-Map Ch.2
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | RTD TxPDO-Map Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x08 (8dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x01 (Underrange)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x02 (Overrange)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1801 (RTD TxPDO-Par Ch.2), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1801:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1801 (RTD TxPDO-Par Ch.2), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (RTD Inputs Ch.2), entry 0x11 (Value)) | UINT32 | RO | 0x6010:11, 16
Index 1A02 RTD TxPDO-Map Ch.3
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | RTD TxPDO-Map Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x08 (8dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x01 (Underrange)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x02 (Overrange)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x07 (Error)) | UINT32 | RO | 0x6020:07, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1802 (RTD TxPDO-Par Ch.3), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1802:07, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802 (RTD TxPDO-Par Ch.3), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1802:09, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6020 (RTD Inputs Ch.3), entry 0x11 (Value)) | UINT32 | RO | 0x6020:11, 16
Index 1A03 RTD TxPDO-Map Ch.4
Index | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | RTD TxPDO-Map Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x08 (8dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x01 (Underrange)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x02 (Overrange)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x07 (Error)) | UINT32 | RO | 0x6030:07, 1
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1803 (RTD TxPDO-Par Ch.4), entry 0x07 (TxPDO State)) | UINT32 | RO | 0x1803:07, 1
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1803 (RTD TxPDO-Par Ch.4), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1803:09, 1
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6030 (RTD Inputs Ch.4), entry 0x11 (Value)) | UINT32 | RO | 0x6030:11, 16
Index 1C00 Sync manager type
Index | Name | Bedeutung | Data type | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RO | 0x00 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RO | 0x04 (4dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A01 (6657dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A02 (6658dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RO | 0x1A03 (6659dez)
Index 1C33 SM input parameter

Index

Name

Bedeutung

Data type

Flags

Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0000 (0dez)
1C33:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron with SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
 UINT32 RW 0x00000000 (0dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x00000000 (0dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C33:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestoppt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt

UINT16 RW 0x0000 (0dez)
1C33:09 | Maximum delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)

Profile specific objects

Index 60n0 RTD Inputs Ch. 1

(Werte für Kanal 2 - 4 entsprechend)

Index | Name | Bedeutung | Datentyp | Flags | Default
60n0:0 | RTD Inputs Ch.1 | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
60n0:01 | Underrange | Der Messbereich wird unterschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overrange | Der Messbereich wird überschritten. | BOOLEAN | RO | 0x00 (0dez)
60n0:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist. | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid). | BOOLEAN | RO | 0x00 (0dez)
60n0:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n0:11 | Value | Das analoge Eingangsdatum | INT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Data type | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | z.Zt. reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Maximaler Subindex | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320dez)
F010:02 | SubIndex 002 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320dez)
F010:03 | SubIndex 003 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320dez)
F010:04 | SubIndex 004 | Analog Input Profile for RTD | UINT32 | RW | 0x00000140 (320dez)


EL32xx, EL33xx - Status-Wort

BECKHOFF EL32xx, EL33xx: Inbetriebnahme

Status-Wort

Die Statusinformationen für jeden Kanal der EL32xx und EL33xx werden als Prozessdaten (PDO) zyklisch von der Klemme zum EtherCAT Master übertragen. Für die EL32xx und EL33xx sind 2 Gerätebeschreibungsversionen verfügbar, die das Prozessdatenabbild in einzelner und erweiterter Form darstellen.

Anhand der Revisionsnummer EL3xxxx-xxxx-XXXX ist die Unterscheidung sichtbar.

Als Prozessdaten überträgt die EL32xx bzw. EL33xx:

  • Underrange: Messbereich unterschritten
  • Overrange: Messbereich überschritten ("Leitungsbruch" zusammen mit "Error")
  • Limit 1: Grenzwertüberwachung 0: ok, 1: Grenzbereich überschritten, 2: Grenzbereich unterschritten
  • Limit 2: Grenzwertüberwachung 0: ok, 1: Grenzbereich überschritten, 2: Grenzbereich unterschritten
  • Error: Das Fehlerbit wird gesetzt, wenn das Prozessdatum ungültig ist (Leitungsbruch, Overrange, Underrange)
  • TxPDO State: Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid).
  • TxPDO Toggle: Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. Dies lässt einen Rückschluss auf die aktuell benötigte Wandlungszeit zu

Die Einstellung der Limit-Auswertung wird im CoE-Verzeichnis in den 8000er Objekten vorgenommen.

Hinweis 		Unterschiede in den Revisionen der EL32xx- und EL33xx-Serien
Nachfolgend werden an der EL32xx-Serie exemplarisch die Revisions-Unterschiede dargestellt. Sinngemäß gilt die Beschreibung auch für die EL33xx-Serie.

Revision -0016 (EL32xx-xxxx-0016)

Diese Klemmenrevisionen verfügen über das Einzel-Prozessabbild, s. Abb. 1.
Jede Statusinformation wird als einzelnes, verlinkbares Prozessdatum übertragen.

Abb. 1: EL32xx-0000-0016 Prozessabbild in der Darstellung TwinCAT 2.11

Revision -0017 (EL32xx-xxxx-0017) und höher

Diese Klemmenrevisionen verfügen auch über das zusammengefasste Prozessabbild, s. Abb. 2.
Die Einzelinformationen sind hier in der Beckhoff üblichen Darstellung als 16-Bit-Status-Wort zusammengefasst und können so in die Steuerung verlinkt werden.

Status-Wort
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8 | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | TxPDO Toggle | TxPDO State | - | - | - | - | - | - | - | Error | Limit 2 |  | Limit 1 |  | Overrange | Underrange

Darüber hinaus kann der zusammengefasste "Status" über das "+" -Symbol aufgeklappt und die Prozessdaten einzeln verlinkt werden.

Abb. 2: EL32xx-0000-0017 Prozessabbild in der Darstellung TwinCAT 2.11

Die Anzeige der Einzelinformationen ist auch im rechten Übersichtsfenster (A) möglich. Durch den Button

in der Menüleiste werden die Informationen auch dort angezeigt.

Abb. 3: Zusammengefasstes Prozessabbild in erweiterter Darstellung unter TwinCAT 2.11

Hinweise

  • Die zusammengefasste Darstellung ist nur ab TwinCAT 2.11 sichtbar. Wird eine EL32xx-xxxx-0017 (und später) in früheren TwinCAT Konfigurationen betrieben, wird aus Kompatibilitätsgründen das Einzelprozessabbild mit vorangestelltem Kennzeichner "Status__" angezeigt.

    Abb. 4: Zusammengefasstes Prozessabbild in Darstellung unter TwinCAT 2.10
  • Eine Abhängigkeit der Revision vom in der Klemme vorliegenden Firmware-Stand ist für die Revisionen -0016 und -0017 nicht gegeben. Das bedeutet, auch Klemmen die als EL32xx-xxxx-0016 ausgeliefert wurden, können mit einer -0017 und somit "neueren" Konfiguration und damit dem zusammengefassten Prozessabbild angesprochen werden.
    Dieser "Aufwärtskompatibilität" genannte Fall ist für die EL32xx-xxxx-0016 und -0017 erlaubt.
  • Die in der Klemme vorliegende Revision kann am einfachsten durch Scannen des EtherCAT-Systems ermittelt werden. Der Vergleichsbericht zeigt die Unterschiede.

    Abb. 5: Beispielhaftes Ergebnis nach dem Scannen eines EtherCAT-Systems

    Erläuterung zu Abb. 5: Laut rechter Übersicht befindet sich eine EL3201-0000-0016 in der Konfiguration (*.tsm-Datei), gefunden wurde aber laut linker Übersicht eine Revision -0017. Die generelle Abwärtskompatibilität von EL-Klemmen stellt sicher, dass dieser Einsatzfall möglich ist.


Hinweise zu analogen Spezifikationen

Beckhoff IO-Geräte (Klemmen, Boxen) mit analogen Eingängen sind durch eine Reihe technischer Kenndaten charakterisiert, siehe dazu die Technischen Daten in den jeweiligen Dokumentationen.

Zur korrekten Interpretation dieser Kenndaten werden im Folgenden einige Erläuterungen gegeben.

Messbereichsendwert

Ein IO-Gerät mit analogem Eingang misst über einen nominellen Messbereich, der durch eine obere und eine untere Schranke (Anfangswert und Endwert) begrenzt wird die meist schon der Gerätebezeichnung entnommen werden kann.
Der Bereich zwischen beiden Schranken wird Messspanne genannt und entspricht der Formel (Endwert - Anfangswert). Entsprechend zu Zeigergeräten ist dies die Messskala (vgl. IEC 61131) oder auch der Dynamikumfang.

Für analoge IO-Geräte von Beckhoff gilt, dass als Messbereichsendwert (MBE) des jeweiligen Produkts (auch: Bezugswert) die betragsmäßig größte Schranke gewählt und mit positivem Vorzeichen versehen wird. Dies gilt für symmetrische und asymmetrische Messspannen.

Für die obigen Beispiele bedeutet dies:

  • Messbereich 0..10 V: asymmetrisch unipolar, MBE = 10 V, Messspanne = 10 V
  • Messbereich 4..20 mA: asymmetrisch unipolar, MBE = 20 mA, Messspanne = 16 mA
  • Messbereich -200..1370 °C: asymmetrisch bipolar, MBE = 1370 °C, Messspanne = 1570 °C
  • Messbereich -10..+10 V: symmetrisch bipolar, MBE = 10 V, Messspanne = 20 V

Dies gilt entsprechend für analoge Ausgangsklemmen

± Messfehler [% vom MBE] (auch: Messabweichung)

Der relative Messfehler bezieht sich auf den MBE und wird berechnet als Quotient aus der zahlenmäßig größten Abweichung vom wahren Wert ("Messfehler") in Bezug auf den MBE.

Der Messfehler hat im Allgemeinen Gültigkeit für den gesamten zulässigen Betriebstemperaturbereich, auch "Gebrauchsfehlergrenze" genannt und enthält zufällige und systematische Anteile auf das bezogene Gerät (also "alle" Einflüsse wie Temperatur, Eigenrauschen, Alterung, ...).

Er ist immer als positiv/negativ-Spanne mit ± zu verstehen, auch wenn fallweise ohne ± angegeben..

Die maximale Abweichung kann auch direkt angegeben werden.

Beispiel: Messbereich 0..10 V und Messfehler < ± 0,3% MBE --> maximale Abweichung ± 30 mV im zul. Betriebstemperaturbereich.

Hinweis: da diese Angabe auch die Temperaturdrift beinhaltet, kann bei Sicherstellung einer konstanten Umgebungstemperatur des Geräts und thermischer Stabilisierung in der Regel nach einem Anwenderabgleich von einem signifikant geringerem Messfehler ausgegangen werden.

Dies gilt entsprechend für analoge Ausgangsklemmen

Typisierung SingleEnded/differentiell

Beckhoff unterscheidet analoge Eingänge grundsätzlich in den 2 Typen Single-Ended (SE) und differentiell (DIFF) und steht hier für den unterschiedlichen elektrischen Anschluss bezüglich der Potenzialdifferenz.

In dieser Abbildung sind ein SE und ein DIFF-Modul als 2-kanalige Variante aufgezeigt, exemplarisch für alle mehrkanaligen Ausführungen.

Hinweis: gestrichelte Linien bedeuten, dass diese Verbindung nicht unbedingt in jedem SE- oder DIFF-Modul vorhanden sein muss.

Grundsätzlich gilt:

  • die analoge Messung erfolgt immer als Spannungsmessung zwischen 2 Potenzialpunkten.
    Bei einer Spannungsmessung ist R groß gewählt, um eine hohe Impedanz zu gewährleisten, bei einer Strommessung ist R als Shunt niedrig gewählt. Ist der Messzweck eine Widerstandsbestimmung, erfolgt die Betrachtung entsprechend.
    • dabei sind diese beiden Punkte bei Beckhoff üblicherweise als Input+/SignalPotenzial und Input-/BezugsPotenzial gekennzeichnet.
    • für die Messung zwischen 2 Potenzialpunkten sind auch 2 Potenziale heranzuführen.
    • bei den Begrifflichkeiten "1-Leiter-Anschluss" oder "3-Leiter-Anschluss" ist bezüglich der reinen Analog-Messung zu beachten: 3- oder 4-Leiter können zur Sensorversorgung dienen, haben aber mit der eigentlichen Analog-Messung nichts zu tun, diese findet immer zwischen 2 Potenzialen/Leitungen statt
      Dies gilt insbesondere auch für SE, auch wenn hier die Benennung suggeriert, dass nur eine Leitung benötigt wird.
  • es ist im Vorfeld der Begriff der "galvanischen Trennung" klarzustellen.
    Beckhoff IO-Module verfügen über 1..8 oder mehr analoge Kanäle; bei Betrachtungen bezüglich des Kanalanschluss ist zu unterscheiden
    • wie sich die Kanäle INNERHALB eines Module zueinander stellen oder
    • wie sich die Kanäle MEHRERER Module zueinander stellen.

    Ob die Kanäle zueinander direkt in Verbindung stehen wird u.a. mit der Eigenschaft der galvanischen Trennung spezifiziert.

    • Beckhoff Klemmen sind immer mit einer galvanischen Trennung von Feld/Analog-Seite zu Bus/EtherCAT-Seite ausgerüstet. Wenn 2 analoge Klemmen also nicht über die Powerkontakte miteinander galvanisch verbunden sind, besteht faktisch eine galvanische Trennung zwischen den Modulen.
    • falls Kanäle innerhalb eines Moduls galvanisch getrennt sind oder ein 1-Kanal-Modul keine Powerkontakte aufweist, handelt es sich faktisch immer um differentielle Kanäle, siehe dazu auch folgende Erläuterungen. Differentielle Kanäle sind nicht zwangsläufig galvanisch getrennt.
  • analoge Messkanäle unterliegen technischen Grenzen sowohl bezüglich des empfohlenen bestimmungsgemäßen Betriebsbereichs (Dauerbetrieb) als auch der Zerstörgrenze. Entsprechende Hinweise in den Klemmendokumentationen sind zu beachten.

Erläuterung

  • differentiell
    • Die differentielle Messung ist das flexibelste Konzept. Beide Anschlusspunkte Input+/SignalPotenzial und Input-/BezugsPotenzial sind vom Anwender im Potenzial im Rahmen der technischen Spezifikation frei wählbar.
    • Ein differentieller Kanal kann auch als SE betrieben werden, wenn das BezugsPotenzial von mehreren Sensoren verbunden wird. Dieser Verbindungspunkt kann auch Anlagen-GND sein.
    • Da ein differentieller Kanal intern symmetrisch aufgebaut ist (vgl. Abb.) stellt sich in der Mitte zwischen den beiden zugeführten Potenzial ein Mittel-Potenzial ein (X), das gleichbedeutend mit dem internen Ground/Bezugsmasse dieses Kanals ist. Wenn mehrerer DIFF-Kanäle ohne galvanische Trennung in einem Modul verbaut sind, kennzeichnet die technische Eigenschaft "UCM (common mode Spannung)" , wie weit die Kanäle in Ihrer Mittenspannung auseinander liegen dürfen.
    • Die interne Bezugsmasse kann ggf. als Anschlusspunkt an der Klemme zugänglich sein, um ein definiertes GND-Potenzial in der Klemme zu stabilisieren. Es ist allerdings dann besonders auf die Qualität dieses Potenzials (Rauschfreiheit, Spannungskonstanz) zu achten. An diesen GND-Punkt kann auch eine Leitung angeschlossen werden die dafür sorgt, dass bei der differentiellen Sensorleitung die UCM,max nicht überschritten wird.
      Sind differentielle Kanäle nicht galvanisch getrennt, ist i.d.R nur eine UCM,max zulässig. Bei galvanischer Trennung sollte dieses Limit nicht vorhanden sein und die Kanäle dürfen bis nur bis zur spezifizierten Trennungsgrenze auseinander liegen.
    • Differentielle Messung im Kombination mit korrekter Sensorleitungsverlegung hat den besonderen Vorteil, dass Störungen die auf das Sensorkabel wirken (idealerweise sind Hin- und Rückleitung nebeneinander verlegt, so dass beide Leitungen von Störsignalen gleich getroffen werden) sehr wenig effektive Auswirkung auf die Messung haben, weil beide Leitungen gemeinsam (= common) im Potenzial verschoben werden - umgangssprachlich: Gleichtaktstörungen wirken auf beide Leitungen gleichzeitig in Amplitude und Phasenlage.
    • Trotzdem unterliegt die Unterdrückung von Gleichtaktstörungen innerhalb eines Kanals oder zwischen Kanälen technischen Grenzen, die in den technischen Daten spezifiziert sind.
    • Weitere hilfreiche Ergänzungen dazu sind der Dokumentationsseite Beschaltung von 0/4..20 mA Differenzeingängen zu entnehmen.
  • Single Ended
    • Ist die Analog-Schaltung als SE konzipiert, ist die Input-/Bezugsleitung intern fest auf ein bestimmtes nicht änderbares Potenzial gelegt. Dieses Potenzial muss an mindestens einer Stelle der Klemme von außen zum Anschluss des Bezugspotenzial zugänglich sein, z.B. über die Powerkontakte.
    • SE bietet also dem Anwender die Möglichkeit, bei mehreren Kanälen zumindest eine der beiden Sensorleitungen nicht bis zur Klemme zurückführen zu müssen wie bei DIFF, sondern die Bezugsleitung bereits an den Sensoren zusammenzufassen, z.B. im Anlagen-GND.
    • Nachteilig dabei ist, dass es über die getrennte Vor- und Rückleitung zu Spannungs/Stromveränderungen kommen kann, die von einem SE-Kanal nicht mehr erfasst werden können, siehe Gleichtaktstörung. Ein UCM-Effekt kann nicht auftreten da die interne Schaltung der Kanäle eines Moduls ja immer durch Input-/BezugsPotenzial hart miteinander verbunden sind.

Typisierung 2/3/4-Leiter-Anschluss von Stromsensoren

Stromgeber/Sensoren/Feldgeräte (im folgenden nur „Sensor“ genannt) mit der industriellen 0/4-20mA-Schnittstelle haben typisch eine interne Wandlungselektronik von der physikalischen Messgröße (Temperatur, Strom...) auf den Stromregelausgang. Diese interne Elektronik muss mit Energie (Spannung, Strom) versorgt werden. Die Zuleitungsart dieser Versorgung trennt die Sensoren somit in selbstversorgende oder extern versorgte Sensoren:

• Selbstversorgende Sensoren

- Die Energie für den Eigenbetrieb bezieht der Sensor über die Sensor/Signal-Leitung + und – selbst.
Damit immer genug Energie für den Eigenbetrieb zur Verfügung steht und eine Drahtbrucherkennung möglich ist, wurde bei der 4-20mA-Schnittstelle als untere Grenze 4 mA festgelegt, d.h. minimal lässt der Sensor 4 mA, maximal 20 mA Strom passieren.

- 2-Leiter-Anschluss siehe folgende Zeichnung, vgl. IEC60381-1

- Solche Stromgeber stellen i.d.R. eine Stromsenke dar, möchten also als „variable Last“ zwischen + und – sitzen. Vgl. dazu Angaben des Sensorherstellers.

Sie sind deshalb nach der Beckhoff-Terminologie wie folgt anzuschließen:

- bevorzugt an „single-ended“ Eingänge wenn die +Supply-Anschlüsse der Klemme gleich mitgenutzt werden sollen - anzuschließen an +Supply und Signal

- sie können aber auch an „differentielle“ Eingänge angeschlossen werden, wenn der Schluss nach GND dann applikationsseitig selbst hergestellt wird – polrichtig anzuschließen an +Signal und –Signal
Unbedingt die Hinweisseite „ Beschaltung von 0/4..20 mA Differenzeingängen“ beachten

• Extern versorgte Sensoren

- 3/4-Leiter-Anschluss siehe folgende Zeichnung, vgl. IEC60381-1

- die Energie/Betriebsspannung für den Eigenbetrieb bezieht der Sensor aus 2 eigenen Versorgungsleitungen. Für die Signalübertragung der Stromschleife werden 1 oder 2 weitere Sensorleitungen verwendet:

• 1 Sensorleitung: nach der Beckhoff-Terminologie sind solche Sensoren an „single-ended“ Eingänge anzuschließen in 3 Leitungen mit +/-/Signal und ggf. FE/Schirm

• 2 Sensorleitungen: Bei Sensoren mit 4-Leiter-Anschluss nach +/-/+Signal/-Signal ist zu prüfen ob der +Signal mit +Supply oder der –Signal-Anschluss mit –Supply verbunden werden darf.

- Ja: Dann kann entsprechend an einen Beckhoff „single-ended“ Eingang angeschlossen werden.

- Nein: es ist der Beckhoff „differentiell“ Eingang für +Signal und –Signal zu wählen, +Supply und –Supply sind über extra Leitungen anzuschließen.
Unbedingt die Hinweisseite „ Beschaltung von 0/4..20 mA Differenzeingängen“ beachten

Hinweis: fachspezifische Organisationen wie NAMUR fordern einen nutzbaren Messbereich <4mA/>20mA zur Fehlererkennung und Justage, vgl. NAMUR NE043.
Es ist in der Beckhoff Gerätedokumentation einzusehen, ob das jeweilige Gerät solch einen erweiterten Signalbereich unterstützt.

Generell ist wegen der internen Diode die Polarität/Stromrichtung zu beachten:

Einordnung der Beckhoff-Klemmen - Beckhoff 0/4-20mA Klemmen sind als differentiell und single-ended verfügbar:

  • differentiell
    - EL3x1x: 0-20mA, EL3x2x: 4-20mA, genauso KL
    - Stromvorzugsrichtung da interne Diode
    - Die Klemme ist eine passive differentielle Strommessvorrichtung, „passiv“ bedeutet, dass keine Sensorspeisung erfolgt
  • Single-ended
    - EL3x4x: 0-20mA, EL3x5x: 4-20mA, genauso KL
    - Stromvorzugsrichtung da interne Diode
    - Sind für den Anschluss von extern versorgenden Sensoren im 3/4-Leiter-Anschluss konzipiert
    - Sind für den Anschluss von selbstversorgenden Sensoren im 2-Leiter-Anschluss konzipiert


Kalibrierungs-Zertifikat

Für die hochpräzisen Klemmen EL320x-0020 wird ein individuelles Kalibrierungs-Zertifikat ausgestellt, dass Sie im Downloadbereich auf der Beckhoff-Website herunterladen können.
Unter http://www.beckhoff.com/certificates ist das Zertifikat anhand einer ID zu identifizieren. Diese ID ist auf die Klemme aufgelasert (siehe Abb. 1)

Abb. 1: Aufgelaserte ID


EtherCAT AL Status Codes

Error Code 0x0000

Meaning:

No error

Description | Current State (or state change) | Resulting State | Solution
No error | Any | Current state |

Error Code 0x0001

Meaning:

Unspecified error
Description | Current State (or state change) | Resulting State | Solution
No error code is defined for occurred error. | Any | Any + E | Read user manual or contact device manufacturer

Error Code 0x0002

Meaning:

No Memory
Description | Current State (or state change) | Resulting State | Solution
Less hardware memory, slave need more memory. | Any | Any + E | Download smaller files or objects Check user manual
Example: For slave configuration, application configuration files are downloaded (possibly via FoE or large CoE objects). The size of those files exceeds the local memory.

Error Code 0x0011

Meaning:

Invalid requested state change
Description | Current State (or state change) | Resulting State | Solution
The EtherCAT State Machine (ESM) defines which state changes are allowed. All other state changes are not allowed. | P→S, I→O, P→O, O→B, S→B, P→B | Current State + E | Go step-by-step from the original state to the desired state.
Example: If the master requests the slave to go from OP (AL Control = 0x08) directly to BOOT (AL Control = 0x03).

Error Code 0x0012

Meaning:

Unknown requested state change
Description | Current State (or state change) | Resulting State | Solution
The ESM defines the following states. They are coded with fixed values (only lower (=right) nibble): BOOT: AL Control = 0x03 INIT: AL Control = 0x01 PREOP: AL Control = 0x02 SAFEOP: AL Control = 0x04 OP: AL Control = 0x08 The fifth bit of the AL Control (left nibble is 1) is the “Error Acknowledge Bit”. If the slave is in AL STATUS = 0x14, i.e. ERROR SAFEOP the master acknowledges this by setting the Acknowledge bit | Any | Current State + E | Do only request the defined states
Example: If any other value for AL Control than those specified are sent.

Error Code 0x0013

Meaning:

Boot state not supported
Description | Current State (or state change) | Resulting State | Solution
Device does not support BOOT state, but the master requests the slave to go to BOOT (AL Control = 0x03) | I→B | I + E |

Error Code 0x0014

Meaning:

No valid firmware
Description | Current State (or state change) | Resulting State | Solution
This error code may be returned after a firmware download, if the downloaded file cannot be used by the application controller. | I→P | I + E | Download a firmware that can be supported by the hardware and bootloader. Check Product Code and Revision Number (CoE object 0x1018). If this cannot be read from the firmware any more you may see this in the network configuration (CoE object dictionary) or probably in the ESI file (element Profile: ObjectDictionary:Objects:Object).

Error Code 0x0015

Meaning:

Invalid mailbox configuration
Description | Current State (or state change) | Resulting State | Solution
Mailbox communication (= acyclic parameter exchange) is done via two memory areas on the EtherCAT Slave Controller (ESC) – the “Output Mailbox” (master -> slave) and the “Input Mailbox” (slave-> master). Those memory areas are protected by SyncManagers to prevent from simultaneous access from master and salve controller at the same time. SyncManagers are hardware entities on the ESC. They are configured via certain registers in the ESC register area (starting at 0x0800). The configuration includes start address, length, and direction (output or input). If those settings differ from those expected by the host controller of the slave this error is returned. | I→B |  | Replace previous network description of old slave with the one of the new slave.

Error Code 0x0016

Meaning:

Invalid mailbox configuration
Description | Current State (or state change) | Resulting State | Solution
Example: The slave hardware was replaced while the network configuration remained unchanged. The new hardware expects different mailbox SyncManager settings. | I→P | I + E | Replace previous network description of old slave with the one of the new slave.

Error Code 0x0017

Meaning:

Invalid Sync Manager configuration
Description | Current State (or state change) | Resulting State | Solution
Process data communication (cyclic communication) is done via extra memory areas on the ESC, separated for outputs and inputs. The process data length and the process data SyncManager length have to be the same. If this is not the case or the start address or direction does not match this error is returned. | P→S, S→O | Current State + E | Issue a re-calculation of the EtherCAT configuration.
Example: The process data configuration was changed of the slaves which also changed the length of the data. The change was not activated in the configuration so that the configuration tool would have recalculated the SyncManager settings.

Error Code 0x0018

Meaning:

No valid inputs available
Description | Current State (or state change) | Resulting State | Solution
The slave application cannot provide valid input values. | O, S→O | S + E |
Example: A certain hardware which needs to be connected to the slave was disconnected.

Error Code 0x0019

Meaning:

No valid outputs available
Description | Current State (or state change) | Resulting State | Solution
The slave application cannot recieve valid output values. | O, S→O | S + E | The RxPdoToggle may need to be handled by the PLC program The outputs valid may have to be set by the PLC program PLC may have stopped, restart PLC
Example: The slave has a RxPdoToggle output or an “Output Valid” information in its process data. The RxPdoToggle does not toggle or the OutputValid is not true. Therefore the slave has no process data which the application can use. If supported, check the RxPDO Toggle Failed Counter in object 0x1C3x.0E). Also, the Synchronization may have problems (see object 0x10F1:SI2 Sync Error Counter Limit) so that process data are received too late by the slave so that the local slave cycle misses the toggle event. Another reason can be that the PLC stopped working.

Error Code 0x001A

Meaning:

Synchronization error
Description | Current State (or state change) | Resulting State | Solution
If too many RxPDO Toggle error occure, i.e. the RxPDO Toggle Failed Counter increases the internal limit the slave returns to SAFEPERROR with 0x001A. Multiple synchronization errors. Device is not synchronized any more (used if the causes mirrored by the AL Status Codes 0x2C, 0x2D, 0x32, 0x33, 0x34 cannot be distinguished). | O, S→O | S + E |

Error Code 0x001B

Meaning:

Sync manager watchdog
Description | Current State (or state change) | Resulting State | Solution
The slave did not receive process data within the specified watchdog time. Usually, the WD time is 100ms. The WD is re-started every time it receives new process data, usually when the Output SyncManager (SyncManager2) is written. For devices which have only inputs usually no WD is used. Increasing the WD is not a solution. Reason: PLC stopped | O, S | S + E |

Error Code 0x001C

Meaning:

Invalid Sync Manager Types
Description | Current State (or state change) | Resulting State | Solution
 | O, S, O, P→S | S + E |

Error Code 0x001D

Meaning:

Invalid Output Configuration
Description | Current State (or state change) | Resulting State | Solution
SM configuration for output process data is invalid. | O, S, O, P→S | S + E |

Error Code 0x001E

Meaning:

Invalid Input Configuration
Description | Current State (or state change) | Resulting State | Solution
SM configuration for input process data is invalid | O, S, O, P→S | S + E |

Error Code 0x001F

Meaning:

Invalid Watchdog Configuration
Description | Current State (or state change) | Resulting State | Solution
The Watchdog is configured in the ESC register 0x0400 and 0x0420. EtherCAT defines default watchdog settings (100ms) or they are defined in the ESI file. If the slave does not accept a change of the expected settings it returns this AL Status Code Example: A slave may not accept that the WD is deactivated. | O, S, O, P→S | P + E | Use default WD settings.

Error Code 0x0020

Meaning:

Slave needs cold start
Description | Current State (or state change) | Resulting State | Solution
Slave device require a power off - power on reset | Any | Current State + E |

Error Code 0x0021

Meaning:

Slave needs INIT
Description | Current State (or state change) | Resulting State | Solution
Slave application requests INIT state | B, P, S, O | Current State + E |

Error Code 0x0022

Meaning:

Slave needs PREOP
Description | Current State (or state change) | Resulting State | Solution
Slave application requests PREOP state | S, O | S + E, O + E |

Error Code 0x0023

Meaning:

Slave needs SAFEOP
Description | Current State (or state change) | Resulting State | Solution
Slave application requests SAFEOP state | O | O + E |

Error Code 0x0024

Meaning:

Invalid Input Mapping
Description Current State (or state change) Resulting State Solution
The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign).

PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm.

PdoAssign: The list of PDOs (object index 0x16nn, 0x1Amm) which are actually part of the process data and hence, are transferred cyclically, are listed in the PDO Assign Objects 0x1C12 (output PDOs) and 0x1C13 (input PDOs). All this can be seen in the SystemManager on the TAB “Process Data”. If the mapping which was set by the user on the Process Data tab and which was expected by the slave do not match this Status Code is returned.

P→S

P + E

Error Code 0x0025

Meaning:

Invalid Output Mapping
Description | Current State (or state change) | Resulting State | Solution
The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign). PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm. Example: Slave does only support one or certain PDO combinations but a different setting was made by the user. For a bus coupler the connected terminals differ from the configured terminals in the SystemManager. | P→S | P + E |

Error Code 0x0026

Meaning:

Inconsistent Settings
Description | Current State (or state change) | Resulting State | Solution
General settings mismatch | P→S | P + E |

Error Code 0x0027

Meaning:

Freerun not supported
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0028

Meaning:

Synchronization not supported
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0029

Meaning:

Freerun needs 3 Buffer Mode
Description | Current State (or state change) | Resulting State | Solution
FreeRun mode, SM has to run in 3-buffer mode | P→S | P + E |

Error Code 0x002A

Meaning:

Background Watchdog
Description | Current State (or state change) | Resulting State | Solution
 | S, O | P + E |

Error Code 0x002B

Meaning:

No Valid Inputs and Outputs
Description | Current State (or state change) | Resulting State | Solution
 | O, S→O | S + E |

Error Code 0x002C

Meaning:

Fatal Sync Error
Description | Current State (or state change) | Resulting State | Solution
The hardware interrupt signal (so called Sync signal) generated by the ESC is not generated any more. The master sets and activated the cycle time of the Sync signal during state transition from PREOP to SAFEOP. If a slave was disconnected and reconnected (also due to lost frames or CRC errors) the generation of the SyncSignal may be lost. | O | S + E | Set master to INIT and back to OP so that the DCs are initialized again.

Error Code 0x002D

Meaning:

ana

Description | Current State (or state change) | Resulting State | Solution
SyncSignal not received: In SAFEOP the slave waits for the first Sync0/Sync1 events before switching to OP, if these events were not received during the SAFEOP to OP-Timeout time the slave refuses the state transition to OP. |  |  |

Error Code 0x0030

Meaning:

Invalid DC SYNC Configuration
Description | Current State (or state change) | Resulting State | Solution
Distributed Clock Configuration is invalid due to application requirements. | O, S→O, P→S | P + E, S + E |

Error Code 0x0031

Meaning:

Invalid DC Latch Configuration
Description | Current State (or state change) | Resulting State | Solution
DC Latch configuration is invalid due to application requirements. | O, S→O, P→S | P + E, S + E |

Error Code 0x0032

Meaning:

PLL Error
Description | Current State (or state change) | Resulting State | Solution
Master not synchronized, at least one DC event recieved. | O, S→O | S + E |

Error Code 0x0033

Meaning:

DC Sync IO Error
Description | Current State (or state change) | Resulting State | Solution
Multiple Synchronization Errors: At least one SycnSignal was received before. However, the PLL between slave and master is not synchronized any more. This may occur if the master application jitters too much. | O, S→O | S + E | Use specific industrial pc, standard office PCs may have power saving options, graphic accelerateds and other system services which disturb the real-time of the master CPU power may be too small for the PLC/NC program Increas EtherCAT and PLC/NC cycle time Use SyncUnits for the slaves using DCs

Error Code 0x0034

Meaning:

DC Sync Timeout Error
Description | Current State (or state change) | Resulting State | Solution
Multiple Synchronization Errors, too much SM events missed | O, S→O | S + E |

Error Code 0x0035

Meaning:

DC Invalid Sync Cycle Time
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0036

Meaning:

DC Sync0 Cycle Time
Description | Current State (or state change) | Resulting State | Solution
DC Sync0 cycle time does not fit to the application requirements | P→S | P + E |

Error Code 0x0037

Meaning:

DC Sync1 Cycle Time
Description | Current State (or state change) | Resulting State | Solution
DC Sync1 cycle time does not fit to the application requirements | P→S | P + E |

Error Code 0x0041

Meaning:

MBX_AOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0042

Meaning:

MBX_EOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0043

Meaning:

MBX_COE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0044

Meaning:

MBX_FOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0045

Meaning:

MBX_SOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x004F

Meaning:

MBX_VOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0050

Meaning:

EEPROM No Access
Description | Current State (or state change) | Resulting State | Solution
EEPROM not assigned to PDI | Any | Any + E |

Error Code 0x0051

Meaning:

EEPROM Error
Description | Current State (or state change) | Resulting State | Solution
EEPROM access error | Any | Any + E |

Error Code 0x0060

Meaning:

Slave Requested Locally
Description | Current State (or state change) | Resulting State | Solution
 | Any | I |

Error Code 0x0061

Meaning:

Device Identification Value updated
Description | Current State (or state change) | Resulting State | Solution
 | P | P + E |

Error Code 0x00F0

Meaning:

Application Controller available
Description | Current State (or state change) | Resulting State | Solution
 | I |  |


UL Hinweise

Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Grundlagen

Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:

  • UL-Zertifikation nach UL508
    Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen

  • UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme
    Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen

Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.

Anwendung

Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung

  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!

Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Firmware Kompatibilität

Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.

Anmerkung

  • Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
  • Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.

Achtung 		Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.

Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen!
Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!

EL3201
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 - 02 | 03 | EL3201-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 10* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
EL3201-0010
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 - 02 | 03 | EL3201-0000-0016 | 2008/11
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 08* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
EL3201-0020
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 - 02 | 03 | EL3201-0000-0016 | 2008/11
 | 04 |  | 2009/04
 | 05 |  | 2009/05
02 | 06 | EL3201-0000-0017 | 2010/04
03 - 08* | 07* |  | 2010/06
 |  | EL3201-0000-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
EL3202
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 - 02 | 03 | EL3202-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
03 - 10* | 06 | EL3202-0000-0017 | 2010/04
 | 07* | EL3202-0010-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
EL3202-0010
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 - 01 | 05 | EL3202-0010-0016 | 2009/07
 | 06 | EL3202-0010-0017 | 2010/04
01 - 07* | 07 |  | 2010/06
 | 08 |  | 2010/10
 | 09 |  | 2011/07
 | 10* |  | 2011/09
 |  | EL3202-0010-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
EL3202-0020
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
01 - 07* | 09 | EL3202-0020-0017 | 2011/02
 | 10* |  | 2011/09
 |  | EL3202-0020-0018 | 2012/06
 |  | EL3202-0020-0019 | 2012/07
 |  | EL3202-0020-0020 | 2014/07
 |  | EL3202-0020-0021 | 2015/01
EL3204
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 - 02 | 03 | EL3204-0000-0016 | 2008/03
 | 04 |  | 2009/04
 | 05 |  | 2009/05
03 - 09* | 06 | EL3204-0000-0017 | 2010/04
 | 07* |  | 2011/06
 |  | EL3204-0000-0018 | 2012/07
EL3204-0200
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00* | 01 | EL3204-0200-0016 | 2013/08
 | 02* | EL3204-0200-0017 | 2014/04

*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.

Inhaltsverzeichnis
• Speicherorte
• Gerätebeschreibung ESI-File/XML
• Versionsbestimmung Firmware
• Update Controller-Firmware *.efw
• Update FPGA-Firmware *.rbf
• Mehrfaches Update

Speicherorte

In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:

  • Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
  • In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
  • Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung zu speichern, in einem sog. EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien (EtherCAT Slave Information) als Zip-Datei zugänglich.

Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.

Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
  • Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
  • Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
  • Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!

Gerätebeschreibung ESI-File/XML

Achtung 		ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.

Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:

Abb. 1: Gerätekennung aus Name EL3204-0000 und Revision -0016

Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.

Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.

Hinweis 		Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes.
Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.

Anzeige der Slave-Kennung ESI

Der einfachste Weg, die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/Freerun das Scannen der EtherCAT-Boxen auszuführen:

Abb. 2: Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes

Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint

Abb. 3: Konfiguration identisch

ansonsten ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.

Abb. 4: Änderungsdialog

In diesem Beispiel in Abb. 4. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.

Änderung der Slave-Kennung ESI

Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:

  • Einwandfreie EtherCAT-Kommunikation muss zum Slave hergestellt werden
  • Der State des Slave ist unerheblich
  • Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. 5

Abb. 5: EEPROM Update

Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. 6. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave'.

Abb. 6: Auswahl des neuen ESI

Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.

Hinweis 		Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen.
Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.

Versionsbestimmung der Firmware

Versionsbestimmung nach Laseraufdruck

Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 10 03 02:

12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).

Hinweis 		CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
  • online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt.
    Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
  • offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein.
    Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.

In Abb. 7 wird der FW-Stand der markierten EL3204 in CoE-Eintrag x100A mit 03 angezeigt.

Abb. 7: Anzeige FW-Stand EL3204

TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.

Update Controller-Firmware *.efw

Hinweis 		CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.

Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. 8.

Abb. 8: Firmware Update

Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.

  • Slave in INIT schalten (A)
  • Slave in BOOTSTRAP schalten
  • Kontrolle des aktuellen Status (B, C)
  • Download der neuen *efw-Datei
  • Nach Beendigung des Download in INIT schalten, dann in OP
  • Slave kurz stromlos schalten

FPGA-Firmware *.rbf

Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.

  • Controller-Firmware für die Aufbereitung der E/A-Signale
  • FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)

Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.

Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.

Abb. 9: Versionsbestimmung FPGA-Firmware

Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.

Abb. 10: Kontextmenu "Eigenschaften" (Properties)

In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.

Abb. 11: Dialog "Advanced settings"

Update

Für das Update der FPGA-Firmware

  • eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
  • einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.

Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!

Update eines EtherCAT-Geräts

Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.

Abb. 12: Dialog "Weitere Eimstellungen" wählen

Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,

Abb. 13: Dialog "Schreibe FPGA" wählen

Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen!

Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!

Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.

Gleichzeitiges Update mehrerer EtherCAT-Geräte

Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Vorraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.

Abb. 14: mehrfache Selektion und FW-Update

Wählen Sie dazu die betreffenden Slaves aus und führen Sie den FW-Update im BOOTSTRAP Modus wie o.a. aus.


ELxxxx - Wiederherstellen des Auslieferungszustandes

BECKHOFF ELxxxx: Konfiguration

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).

Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert

Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"

Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


ATEX - Besondere Bedingungen

WARNUNG 		Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von
Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
  • Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu Berücksichtigungen!
  • Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
  • Beachten Sie beim Einsatz von Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
  • Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
  • Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Sicherung der Einspeiseklemmen KL92xx dürfen nur gewechselt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Adresswahlschalter und ID-Switche dürfen nur eingestellt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!

Normen

Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Kennzeichnung

Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten tragen eine der folgenden Kennzeichnungen:

II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

oder

II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

Seriennummer

Die Beckhoff-Feldbuskomponenten tragen eine Seriennummer, die wie folgt aufgebaut ist:

WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 35 04 1B 01:

35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01