EL3182 - 2 kanalige Eingangsklemme (4 - 20 mA), 16 Bit, HART
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
1.2 | - Update Kapitel „Inbetriebnahme“
1.1 | - Update Kapitel „Technische Daten“
1.0 | - Korrekturen, 1. Veröffentlichung
0.1 | - Dokumentation für EL3182 (vorläufige Version)


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL3182 – Einführung
•
Technische Daten
•
Start


EL3182 – Einführung

Produktübersicht [image] EL3182 – Einführung
EL3182 – Einführung
EL3182
2-Kanal-Analog-Eingangsklemme 4…20 mA, single-ended, 16 Bit, HART
Die analoge Eingangsklemme EL3182 für HART-fähige Feldgeräte versorgt im Feld befindliche Messumformer und überträgt deren analoge Messsignale galvanisch getrennt zum Automatisierungsgerät. Mit einem technischen Messbereich von ±107 % vom Nennbereich unterstützt die Klemme auch die Inbetriebnahmen mit Sensorwerten im Grenzbereich und die Auswertung nach NAMUR NE43.
Das HART (Highway-Adressable-Remote-Transducer)-Protokoll ermöglicht eine Zweiwegekommunikation durch digitalen Datentransfer über die analoge 4…20-mA-Verdrahtung. Die Vorteile der einfachen und robusten 4…20-mA-Schnittstelle sind mit den Diagnose- und Parametrierungsoptionen einer digitalen Schnittstelle kombiniert. Die Powerkontakte der EL3182 können wahlweise über die Standardversorgung oder eine Einspeiseklemme (EL9xxx) mit galvanischer Trennung für die Betriebsspannung versorgt werden. Die Eingangselektronik ist unabhängig von der Versorgungsspannung der Powerkontakte.
Das Bezugspotenzial für die Eingänge ist der 0-V-Powerkontakt. Die EtherCAT-Klemme zeigt den Signalzustand durch Leuchtdioden an. Überlastung und Drahtbruch signalisieren die Error-LEDs, weiterhin informieren LEDs über den Zustand der HART-Kommunikation und signalisieren etwaige Kommunikationsfehler.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten
EL3182
Anzahl Eingänge
2
Technik
HART Version 7
Signaltyp
single-ended
Signalstrom
4…20 mA
Spannungsversorgung für interne E-Bus-Elektronik
über den E-Bus
Innenwiderstand
250 Ω typ.
Grenzfrequenz Eingangsfilter (AI)
25 Hz
Spannungsfestigkeit
max. 30 V
Messbereich, technisch
i. A, 107 % des Messbereichs
Auflösung
16 Bit (inkl. Vorzeichen)
Messfehler
< ±0,3 % (bezogen auf den Messbereichsendwert)
Unterstützung Distributed Clocks
Ja
Potenzialtrennung
500 V (E-Bus/Signalspannung)
Stromaufn. Powerkontakte
-
Stromaufnahme aus dem E-Bus
typ. 130 mA
Breite im Prozessabbild
8 Byte, HART: 28 Byte pro Kanal (optional)
Besondere Eigenschaften
▪
Standard- und Kompakt-Prozessabbild
▪
FIR-/IIR-Filter aktivierbar
▪
Grenzwertüberwachung
▪
ExtendedRange 107 %
▪
NE43 NAMUR
Max. zulässiger Ausgangsstrom (Uv1/ Uv2)
typ. 150 mA (pro Anschluss)
Gewicht
ca. 60 g
zulässiger Umgebungstemperaturbereich im Betrieb
-25°C ... + 60°C
zulässiger Umgebungstemperaturbereich bei Lagerung
-40°C ... + 85°C
zulässige relative Luftfeuchtigkeit
95%, keine Betauung
Abmessungen (B x H x T)
ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage
auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit
gemäß EN 60068-2-6 / EN 60068-2-27,
siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung
gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart
IP20
Einbaulage
beliebig
Zulassung
CE


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie die EL3182 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie die EL3182 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
LED's und Anschlussbelegung
•
Anschlusshinweise 20 mA-Messung


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


LED's und Anschlussbelegung

Montage und Verdrahtung [image] LED's und Anschlussbelegung
LED's und Anschlussbelegung
LEDs und Anschlussbelegung EL3182
LEDs
LED | Farbe | Bedeutung
Run | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP = Funktion für Firmware Updates der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
Error | rot | EtherCAT-Kommunikationsfehler
Error-LED1 | rot | Fehleranzeige bei Drahtbruch oder bei Unter- bzw. Überschreitung des Messbereiches von Kanal 1
Error-LED2 (falls vorhanden) | rot | Fehleranzeige bei Drahtbruch oder bei Unter- bzw. Überschreitung des Messbereiches von Kanal 2
HART | grün | aus | Keine HART Kommunikation
 |  | an | HART Kommunikation aktiv
HART-Error | rot | HART-Kommunikationsfehler
Anschlussbelegung EL3182
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
I1 | 1 | Eingang Kanal 1
Uv1 | 2 | Sensor Versorgung (intern verbunden mit Klemmstelle 6)
GND | 3 | GND (intern verbunden mit Klemmstelle 7)
S | 4 | Schirm (intern verbunden mit Klemmstelle 8)
I2 | 5 | Eingang Kanal 2
Uv2 | 6 | Sensor Versorgung (intern verbunden mit Klemmstelle 2)
GND | 7 | GND (intern verbunden mit Klemmstelle 3)
S | 8 | Schirm (intern verbunden mit Klemmstelle 4)


Anschlusshinweise 20 mA-Messung

Montage und Verdrahtung [image] Anschlusshinweise 20 mA-Messung
Anschlusshinweise 20 mA-Messung
Weiterführende Informationen
•
Beschaltung von 0/4..20 mA Differenzeingängen


Beschaltung von 0/4..20 mA Differenzeingängen

Montage und Verdrahtung [image] Anschlusshinweise 20 mA-Messung [image] Beschaltung von 0/4..20 mA Differenzeingängen
Beschaltung von 0/4..20 mA Differenzeingängen
Im Folgenden werden Hinweise zu den 0/4..20 mA Differenzeingängen der Klemmenserien EL301x, EL302x, EL311x, EL312x und Klemmen EL3174, EL3612, EL3742 und EL3751 gegeben.
Diese treffen auf die Single-Ended-20 mA-Eingänge der Klemmenserien EL304x, EL305x, EL314x, EL315x, EL317x, EL318x und EL375x nur im Rahmen der technischen Übertragbarkeit zu und gelten nur für Geräte, deren Analoge Eingangskanäle eine gemeinsame Bezugsmasse haben, d.h. dass die Kanäle nicht untereinander bzw. nicht zur Versorgung galvanisch getrennt sind. Ein Beispiel für ein "galvanisch getrenntes" Gerät ist hierbei die EL3174-0002.
Technischer Hintergrund
Die interne Eingangselektronik der o.g. Klemmen verfügt über folgende charakteristische Eigenschaften (s. Abb. Interne Anschlussschaltung 0/4..20 mA Eingänge):
▪
differenzielle Messung des Stromes, d.h. ein konkreter Potenzialbezug ist primär nicht erforderlich.
Als Systemgrenze gilt hierbei die einzelne Klemme EL30xx/EL31xx.
▪
Strommessung über eine 33 Ω-Shunt je Kanal, daraus folgend ein maximaler Spannungsabfall von 660 mV über den Shunt
▪
interne Widerstandsanordnung mit GND-Punkt (A) mittig zum Shunt
Dabei ist die Auslegung der Widerstände derart symmetrisch, dass das Potenzial von (A) mittig zum Spannungsabfall über den Shunt zu liegen kommt.
▪
dieses GND-Potenzial GNDint ist für alle in der Klemme realisierten Kanäle gemeinsam
▪
das gemeinsame GNDint-Potenzial (A) ist
–
bei 1- und 2-kanaligen Klemmen auf einen Klemmpunkt geführt und nicht mit GNDPC (Powerkontakt) verbunden
–
bei 4-kanaligen Klemmen mit GNDPC verbunden
▪
der Mittelpunkt der über den 33 Ω-Shunt abfallenden Spannung ist der sog. Common-Mode-Messmittelpunkt (CMP).
Die max. zulässige UCM-Spannung (common mode) laut den technischen Daten des Produkts bezieht sich auf das Potenzial zwischen dem CMP eines Kanals zum internen GND bzw. auf das Potenzial zwischen den CMP von 2 Kanälen innerhalb einer Klemme.
Sie darf die angegebene Grenze (typischerweise ±10 oder ±35 V) nicht überschreiten.
Demzufolge sind bei mehrkanaligen Messungen UCM-Vorgaben zu beachten.
Interne Anschlussschaltung 0/4...20 mA Eingänge
Am Prinzipschaltbild einer 2-kanaligen Klemme sind die verbundenen GND-Punkte innerhalb der Klemme zu sehen (Abb. Interne Anschlussschaltung 0/4..20 mA Eingänge einer EL3xx2):
Interne Anschlussschaltung 0/4...20 mA Eingänge einer EL3xx2
Bei allen Kanälen innerhalb der Klemme darf UCM-max nicht überschritten werden.
UCM bei 0/4..20 mA Eingängen
Wenn UCM eines analogen Eingangskanals überschritten wird, kommt es zu erheblichen Fehlmessungen durch interne Ausgleichsströme.
Bei den 1- und 2-kanaligen Klemmen ist genau deshalb der interne GND an einen Klemmpunkt herausgeführt, damit durch applikationsgerechte Beschaltung dieses GND-Punktes die UCM-Vorgabe auch bei atypischer Sensorbeschaltung eingehalten werden kann.
Beispiel 1
Die 2-kanalige EL3012 wird mit 2 Sensoren beschaltet, die von 5 und 24 V gespeist werden. Beide Strommessungen sind als Low-Side-Messung ausgeführt. Diese Anschlussform ist zulässig, denn CMPch1 und CMPch2 liegen jeweils bei Imax ca. 330 mV über 0 V, UCM ist somit immer < 0,5 V. Somit ist UCM < 10 V (gültig für EL30xx) eingehalten.
Beispiel 1: LowSide-Messung
Wird GNDint bei den EL30x1/EL30x2 bzw. EL31x1/EL31x2 nicht extern beschaltet, kann sich das Potenzial auf GNDint nach Erfordernis einstellen, es "floatet". Allerdings ist dann mit reduzierter Messgenauigkeit zu rechnen.
Beispiel 1a
Entsprechendes gilt auch, wenn der frei schwebende Punkt GNDint auf ein anderes Potential gezogen wird.
Beispiel 1a, HighSide-Messung
Beispiel 2
Die gleiche EL3012 wird nun wieder mit den beiden 20 mA-Sensoren beschaltet, diesmal aber einmal in Low-Side-Messung an 5 V, einmal in High-Side-Messung an 12 V. Damit ergeben sich erhebliche Potenzialunterschiede UCM > 10 V (gültig für EL30xx) beider Kanäle. Dies ist nicht zulässig.
Beispiel 2, High-Side-/Low-Side-Messung
Zur Abhilfe kann GNDint in diesem Fall extern mit einem Hilfs-Potenzial von 6 V gegenüber "0 V" verbunden werden. Damit stellt sich A/GNDint ca. mittig zwischen 0,3 V bzw. 11,6 V ein.
Beispiel 3
Bei den EL3xx4 ist GNDint intern mit dem negativen Powerkontakt verbunden. Deshalb gilt hier die Freiheit der Potenzialwahl nicht.
Unzulässige EL3xx4-Beschaltung
Es stellt sich ein CMP = 23,6 V und damit >> 10 V (gültig für EL30xx) ein. Bei den Klemmen EL30x4/EL31x4 ist deshalb die Beschaltung so zu wählen, dass CMP < UCM,max eingehalten wird.
Zusammenfassung
Daraus ergeben sich einige konkrete Vorgaben für die externe Beschaltung mit 0/4..20 mA Sensoren:
▪
Es wird empfohlen, GNDint mit einem niederimpedanten Potenzial zu verbinden, da die Messgenauigkeit der EL30xx/31xx damit erheblich verbessert wird.
Die Hinweise zum Potenzialbezug UCM sind zu beachten!
▪
Der Potenzialbezug UCM muss eingehalten werden, und zwar sowohl zwischen CMP ↔ GNDint als auch CMPch(x) ↔ CMPch(y).
Kann dies nicht gewährleistet werden, ist die 1-kanalige Variante einzusetzen.
▪
Ausprägung bei den Klemmen:
–
EL3xx1/EL3xx2: GNDint ist auf Klemmpunkt zur externen Beschaltung geführt.
GNDint soll extern derart angeschlossen werden, dass Pkt. 2 erfüllt ist.
–
EL3xx4: GND ist mit dem negativen Powerkontakt verbunden.
Die externe Beschaltung ist so zu wählen, dass Pkt. 2 erfüllt ist.
Falls die Sensorleitung mit einer Schirmung versehen ist, ist diese nicht mit der GNDint-Klemmstelle zu verbinden sondern auf einer dafür vorgesehenen niederimpedanten Schirmstelle aufzulegen.
▪
Werden Klemmstellen mehrerer EL30xx/EL31xx-Klemmen miteinander verbunden, ist insbesondere auf die Einhaltung von Pkt. 2 zu achten.
Anschluss von GNDint
Bei den EL30x1/EL30x2 und EL31x1/EL31x2 wird das interne GND, GNDint auf Klemmkontakte herausgeführt.
Zur Erzielung eines genauen Messergebnisses ist GNDint unter Beachtung der Vorgaben für UCM mit einem geeigneten externen niederohmigen Potenzial zu verbinden.
Bei den EL30x4/EL31x4 ist GNDint bereits mit dem negativen Powerkontakt verbunden. Hier sind ebenfalls die Vorgaben in Bezug auf UCM einzuhalten.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Objektbeschreibung und Parametrierung
•
Prozessdaten und Betriebsmodi
•
Grundlagen NAMUR


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff-Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung des EtherCAT Gerätes wird über den CoE-Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
•
StartUp-Liste führen für den Austauschfall
•
Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
•
"CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Informations- und Diagnostikdaten
•
Kommando-Objekte
•
Hersteller-Konfigurationsdaten
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Restore-Objekt
Restore-Objekt
Index 0x1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 0x80n0 AI Settings (n=0: Kanal 1, n=1: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
80n0:0 | AI Settings | Maximaler Subindex | UINT8 | RO | 0x18 (24dez)
80n0:01 | Enable user scale | Die Anwender Skalierung ist aktiv | BOOLEAN | RW | 0x00 (0dez)
80n0:06 | Enable filter | Filter aktivieren, dadurch entfällt der SPS-zyklussynchrone Datenaustausch | BOOLEAN | RW | 0x00 (0dez)
80n0:07 | Enable limit 1 | Limit 1 aktiviert | BOOLEAN | RW | 0x00 (0dez)
80n0:08 | Enable limit 2 | Limit 2 aktiviert | BOOLEAN | RW | 0x00 (0dez)
80n0:0A | Enable user calibration | Freigabe des Anwender Abgleichs | BOOLEAN | RW | 0x00 (0dez)
80n0:0B | Enable vendor calibration | Freigabe des Hersteller Abgleichs | BOOLEAN | RW | 0x00 (0dez)
80n0:11 | User scale offset | Offset der Anwenderskalierung | INT16 | RW | 0x0000 (0dez)
80n0:12 | User scale gain | Gain der Anwenderskalierung. Der Gain besitzt eine Festkommadarstellung mit dem Faktor 2-16. Der Wert 1 entspricht 65536dez (0x00010000) und wird auf ±0x7FFFF begrenzt | INT32 | RW | 0x00000000 (0dez)
80n0:13 | Limit 1 | Erster Grenzwert zum Setzen der Statusbits | INT16 | RW | 0x0000 (0dez)
80n0:14 | Limit 2 | Zweiter Grenzwert zum Setzen der Statusbits | INT16 | RW | 0x0000 (0dez)
80n0:15 | Filter settings | Dieses Objekt bestimmt die digitalen Filtereinstellungen, wenn es über Enable filter (Index 0x80n0:06) aktiv ist. Die möglichen Einstellungen sind fortlaufend nummeriert. 0: 50 Hz FIR 1: 60 Hz FIR 2: IIR 1 3: IIR 2 4: IIR 3 5: IIR 4 6: IIR 5 7: IIR 6 8: IIR 7 9: IIR 8 | UINT16 | RW | 0x0000 (0dez)
80n0:17 | User calibration offset | Anwender Offset Abgleich | INT16 | RW | 0x0000 (0dez)
80n0:18 | User calibration gain | Anwender Gain Abgleich | INT16 | RW | 0x4000 (16384dez)
Index 0x80nD AI Advanced Settings (n=0: Kanal 1, n=1: Kanal 2)
Index (hex) | Name | Bedeutung |  | Data type | Flags | Default
80nD:0 | AI Advanced Settings | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
80nD:11 | Input Type | Erlaubte Werte: |  | UINT16 | RW | 0x14 (20dez)
 |  | 0x13 (19dez) | I 4-20mA
 |  | 0x14 (20dez) | I 4-20mA NAMUR
80nD:12 | Scaler | Skalierung, zulässige Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0x00 | Extended Range
 |  | 0x03 | 0x03 Legacy Range
80nD:17 | Low Range Error | Unterer Schwellwert für Error Bit und Error Led |  | INT32 | RW | Abhängig von 80nD:11
80nD:18 | High Range Error | Oberer Schwellwert für Error Bit und Error Led |  | INT32 | RW | Abhängig von 80nD:11
Index 0x80n0 HART Settings (n=8: Kanal 1, n=9: Kanal 2)
Index (hex) | Name | Bedeutung |  | Data type | Flags | Default
80n0:0 | HART Settings | Maximaler Subindex |  | UINT8 | RO | 0x06 (6dez)
80n0:01 | Preamble | Preamble Länge: |  | UINT8 | RW | 0x00 (0dez)
 |  | Automatische Zuweisung | 0
 |  | Zulässige Werte | 5…20
80n0:02 | MasterMode | Zulässige Werte: |  | UINT8 | RW | 0x00 (0dez)
 |  | Primary | 0
 |  | Secondary | 1
80n0:03 | PollingAddress | Zulässige Werte: |  | UINT8 | RW | 0x00 (0dez)
 |  | 0…63
80n0:04 | PollingTime | Einheit in Sekunden, zulässige Werte: |  | UINT8 | RW | 0x03 (3dez)
 |  | 1…64
80n0:05 | MaxRetry | Zulässige Werte: |  | UINT8 | RW | 0x03 (3dez)
 |  | 3…10
80n0:06 | MasterCtrl | reserved |  | UINT8 | RW | 0x00 (0dez)


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 0x60n0 AI Inputs (n=0: Kanal 1, n=1: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
60n0:0 | AI Inputs | Maximaler Subindex | UINT8 | RO | 0x11 (17dez)
60n0:01 | Underrange | Messbereich unterschritten | BOOLEAN | RO | 0x00 (0dez)
60n0:02 | Overrange | Messbereich überschritten | BOOLEAN | RO | 0x00 (0dez)
60n0:03 | Limit 1 | Grenzwertüberwachung Limit 1 0: nicht aktiv 1: Wert ist kleiner als Grenzwert 1 2: Wert ist größer als Grenzwert 1 3: Wert ist gleich dem Grenzwert 1 | BIT2 | RO | 0x00 (0dez)
60n0:05 | Limit 2 | Grenzwertüberwachung Limit 2 0: nicht aktiv 1: Wert ist kleiner als Grenzwert 2 2: Wert ist größer als Grenzwert 2 3: Wert ist gleich dem Grenzwert 2 | BIT2 | RO | 0x00 (0dez)
60n0:07 | Error | Das Fehlerbit wird gesetzt, wenn das Datum ungültig ist (Overrange, Underrange) | BOOLEAN | RO | 0x00 (0dez)
60n0:0E | Sync error | Das Sync error Bit wird nur für den DC Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. Das bedeutet, ein SYNC-Signal wurde in der Klemme ausgelöst, es lagen aber keine neuen Prozessdaten vor (0=ok, 1=nok). | BOOLEAN | RO | 0x00 (0dez)
60n0:0F | TxPDO State | Gültigkeit der Daten der zugehörigen TxPDO (0=valid, 1=invalid) | BOOLEAN | RO | 0x00 (0dez)
60n0:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
60n0:11 | Value | Analoges Eingangsdatum | INT16 | RO | 0x0000 (0dez)


Informations- und Diagnostikdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Informations- und Diagnostikdaten
Informations- und Diagnostikdaten
Index 0x80nE AI Internal data (n=0: Kanal 1, n=1: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
80nE:0 | AI Internal data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
80nE:01 | ADC raw value | ADC Rohwert | INT16 | RO | 0x0000 (0dez)
Index 0x90n0 HART Info data (n=8: Kanal 1, n=9: Kanal 2)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
90n0:0 | HART Info data | Maximaler Subindex |  | UINT8 | RO | 0x11 (17dez)
90n0:01 | ExtendetDeviceType | Erweiterter Gerätetyp |  | UINT16 | RO | 0x0000 (0dez)
90n0:02 | MinNrOfPreamblesReq | Minimale Anzahl erforderlicher Preambles für die Anforderungsnachricht vom Master zum Slave. |  | UINT8 | RO | 0x00 (0dez)
90n0:03 | HartMajorRevNr | HART Protocol zentrale Revisionsnummer von diesem Gerät implementiert |  | UINT8 | RO | 0x00 (0dez)
90n0:04 | DeviceRevLevel | Geräte-Revisionslevel |  | UINT8 | RO | 0x00 (0dez)
90n0:05 | SoftwareRevLevel | Software-Revisionslevel für dieses Gerät |  | UINT8 | RO | 0x00 (0dez)
90n0:06 | HardwareRevLevel | Hardware-Revisionslevel der Elektronik in diesem bestimmten Gerät |  | UINT8 | RO | 0x00 (0dez)
90n0:07 | PhysicalSignalingCode | Erlaubte Werte: |  | UINT8 | RO | 0x00 (0dez)
 |  | 0 | Bell 202 Strom
 |  | 1 | Bell 202 Spannung
 |  | 2 | RS-485
 |  | 3 | RS-232
 |  | 4 | Drahtlos
 |  | 6 | Speziell
90n0:08 | Flags | HART Flags |  | UINT8 | RO | 0x00 (0dez)
90n0:09 | DeviceId | Geräte-ID |  | OCTET-STRING[3] | RO | {0}
90n0:0A | MinNrOfPreamblesResp | Minimale Anzahl erforderlicher Preambles die in der Antwortnachricht vom Slave zum Master gesendet werden |  | UINT8 | RO | 0x00 (0dez)
90n0:0B | MaxNrOfDevVariables | Maximale Anzahl von Gerätevariablen |  | UINT8 | RO | 0x00 (0dez)
90n0:0C | ConfigChangeCounter | Konfigurations-Änderungszähler |  | UINT16 | RO | 0x0000 (0dez)
90n0:0D | ExtFieldDeviceStatus | Erweiterter Feldgerätezustand |  | UINT8 | RO | 0x00 (0dez)
90n0:0E | DeviceProfile | Geräte Profil |  | UINT8 | RO | 0x00 (0dez)
90n0:0F | ManuIdentCode | Hersteller Identifizierungscode |  | UINT16 | RO | 0x0000 (0dez)
90n0:10 | PrivLabelDistCode | „Private Label Distributor Code“ |  | UINT16 | RO | 0x0000 (0dez)
90n0:11 | SlavePollingAdress | Poll-Adresse des aktuellen Slave |  | UINT8 | RO | 0x00 (0dez)
Index 0xA0n0 HART Diag data (n=8: Kanal 1, n=9: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
A0n0:0 | HART Diag data | Maximaler Subindex | UINT8 | RO | 0x04 (4dez)
A0n0:01 | RcvFrameError | Received Frame Error Counter | UINT8 | RO | 0x00 (0dez)
A0n0:02 | RcvCheckSumError | Received CheckSum Error Counter | UINT8 | RO | 0x00 (0dez)
A0n0:03 | RcvTimeOutError | Received Timeout Error Counter | UINT8 | RO | 0x00 (0dez)
A0n0:04 | DataExchState | DataExchange State | UINT8 | RO | 0x00 (0dez)
Index 0xF900 Info data
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F900:0 | Info data | Maximaler Subindex | UINT8 | RO | 0x01 (1dez)
F900:01 | HART Version | Master HART Version | UINT16 | RO | -


Kommando-Objekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Kommando-Objekte
Kommando-Objekte
Index 0x60n0 HART Command 3 (n=8: Kanal 1, n=9: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
60n0:0 | HART Cmd3 | Maximaler Subindex | UINT8 | RO | 0x0D (13dez)
60n0:01 | Field Device Status | Represent the current state of the slave | UINT8 | RO | 0x00 (0dez)
60n0:02 | Cyclic Frame Cnt | Cyclic Frame Counter | UINT8 | RO | 0x00 (0dez)
60n0:05 | Primary Variable Units Code | Primary Variable Units Code (refer to HART 'Common Table Specification') | UINT8 | RO | 0x00 (0dez)
60n0:06 | Secondary Variable Units Code | Secondary Variable Units Code (refer to HART 'Common Table Specification') | UINT8 | RO | 0x00 (0dez)
60n0:07 | Tertiary Variable Units Code | Tertiary Variable Units Code (refer to HART 'Common Table Specification') | UINT8 | RO | 0x00 (0dez)
60n0:08 | Quaternary Variable Units Code | Quaternary Variable Units Code (refer to HART 'Common Table Specification') | UINT8 | RO | 0x00 (0dez)
60n0:09 | Primary Variable Loop Current | Primary Variable Loop Current (units of milli-amperes) | REAL32 | RO | 0x00000000 (0dez)
60n0:0A | Primary Variable | Primary Variable (Herstellerspezifisch) | REAL32 | RO | 0x00000000 (0dez)
60n0:0B | Secondary Variable | Secondary Variable (Herstellerspezifisch) | REAL32 | RO | 0x00000000 (0dez)
60n0:0C | Tertiary Variable | Tertiary Variable (Herstellerspezifisch) | REAL32 | RO | 0x00000000 (0dez)
60n0:0D | Quaternary Variable | Quaternary Variable (Herstellerspezifisch) | REAL32 | RO | 0x00000000 (0dez)


Hersteller-Konfigurationsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Hersteller-Konfigurationsdaten
Hersteller-Konfigurationsdaten
Index 0x80nF AI Vendor data (n=0: Kanal 1, n=1: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
80nF:0 | AI Vendor data | Maximaler Subindex | UINT8 | RO | 0x02 (2dez)
80nF:01 | Calibration offset | Offset (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)
80nF:02 | Calibration gain | Gain (Herstellerabgleich) | INT16 | RW | 0x0000 (0dez)


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Standardobjekte
Standardobjekte
Index 0x1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 0x1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL3182
Index 0x1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 0x100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 0x1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x0c6e3052 (2085479225dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 0x10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 0x180n AI TxPDO-Par Standard (n=0: Kanal 1, n=2: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
180n:0 | AI TxPDO-Par Standard | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
180n:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
Index 0x180n AI TxPDO-Par Compact (n=1: Kanal 1, n=3: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
180n:0 | AI TxPDO-Par Compact | PDO Parameter TxPDO 2 | UINT8 | RO | 0x06 (6dez)
180n:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 00 1A
Index 0x1A0n AI TxPDO-Map Standard (n=0: Kanal 1, n=2: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A0n:0 | AI TxPDO-Map Standard | PDO Mapping TxPDO 1 | UINT8 | RO | 0x0A (10dez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x01 (Underrange)) | UINT32 | RO | 0x6000:01, 1
1A0n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x02 (Overrange)) | UINT32 | RO | 0x6000:02, 1
1A0n:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x03 (Limit 1)) | UINT32 | RO | 0x6000:03, 2
1A0n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x05 (Limit 2)) | UINT32 | RO | 0x6000:05, 2
1A0n:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A0n:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A0n:07 | SubIndex 007 | 7. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A0n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x0F (TxPDO State)) | UINT32 | RO | 0x6000:0F, 1
1A0n:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6000:10, 1
1A0n:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 0x1A0n AI TxPDO-Map Compact (n=1: Kanal 1, n=3: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A0n:0 | AI TxPDO-Map Compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x01 (1dez)
1A0n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (AI Inputs), entry 0x11 (Value)) | UINT32 | RO | 0x6000:11, 16
Index 0x1A1n HART TxPDO-Map Inputs (n=0: Kanal 1, n=2: Kanal 2)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1A1n:0 | HART TxPDO-Map Inputs | PDO Mapping TxPDO 17 | UINT8 | RO | 0x0C (12dez)
1A1n:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x01 (Field Device Status)) | UINT32 | RO | 0x6080:01, 8
1A1n:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x02 (Cyclic Frame Cnt)) | UINT32 | RO | 0x6080:02, 8
1A1n:03 | SubIndex 003 | 3. PDO Mapping entry (16 bits align) | UINT32 | RO | 0x0000:00, 16
1A1n:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x05 (Primary Variable Units Code)) | UINT32 | RO | 0x6080:05, 8
1A1n:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x06 (Secondary Variable Units Code)) | UINT32 | RO | 0x6080:06, 8
1A1n:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x07 (Tertiary Variable Units Code)) | UINT32 | RO | 0x6080:07, 8
1A1n:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x08 (Quaternary Variable Units Code)) | UINT32 | RO | 0x6080:08, 8
1A1n:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x09 (Primary Variable Loop Current)) | UINT32 | RO | 0x6080:09, 32
1A1n:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x0A (Primary Variable)) | UINT32 | RO | 0x6080:0A, 32
1A1n:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x0B (Secondary Variable)) | UINT32 | RO | 0x6080:0B, 32
1A1n:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x0C (Tertiary Variable)) | UINT32 | RO | 0x6080:0C, 32
1A1n:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6080 (HART Cmd3), entry 0x0D (Quaternary Variable)) | UINT32 | RO | 0x6080:0D, 32
Index 0x1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 0x1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1620 (5664dez)
Index 0x1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Data type | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x05 (5dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A12 (6674dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A20 (6688dez)
Index 0x1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0x4003 (16387dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x0000FDE8 (65000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 0x1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
UINT16
RO
0x4003 (16387dez)
1C33:05
Minimum cycle time
wie 1C32:05
UINT32
RO
0x0000FDE8 (65000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 1C32:32
BOOLEAN
RO
0x00 (0dez)
Index 0xF000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Module | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Module | UINT16 | RO | 0x0011 (17dez)
Index 0xF008 Code word
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F008:0 | Code word | Code word | UINT32 | RW | 0x00000000 (0dez)
Index 0xF010 Module list
Index (hex) | Name | Bedeutung | Data type | Flags | Default
F010:0 | Modulel list | Maximaler Subindex | UINT8 | RW | 0x11 (17dez)
F010:01 | SubIndex 001 | Analog Eingang Modul Kanal 1 | UINT32 | RW | 0x0000012C (300dez)
F010:02 | SubIndex 002 | Analog Eingang Modul Kanal 2 | UINT32 | RW | 0x0000012C (300dez)
F010:03 | SubIndex 003 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:04 | SubIndex 004 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:05 | SubIndex 005 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:06 | SubIndex 006 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:07 | SubIndex 007 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:08 | SubIndex 008 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:09 | SubIndex 009 | HART Modul Kanal 1 | UINT32 | RW | 0x00001888 (6280dez)
F010:0A | SubIndex 010 | HART Modul Kanal 2 | UINT32 | RW | 0x00001888 (6280dez)
F010:0B | SubIndex 011 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:0C | SubIndex 012 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:0D | SubIndex 013 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:0E | SubIndex 014 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:0F | SubIndex 015 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:10 | SubIndex 016 | Reserviert | UINT32 | RW | 0x00000000 (0dez)
F010:11 | SubIndex 017 | TSC Modul | UINT32 | RW | 0x00000000 (0dez)


Prozessdaten und Betriebsmodi

Inbetriebnahme [image] Prozessdaten und Betriebsmodi
Prozessdaten und Betriebsmodi
Weiterführende Informationen
•
Datenstrom und Abgleich
•
Parametrierung
•
Sync Manager
•
Field Device Status (HART)
•
Einstellungen und Betriebsmodi
•
Prozessdaten


Datenstrom und Abgleich

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Datenstrom und Abgleich
Datenstrom und Abgleich
Datenstrom
Im unteren Flussdiagramm (Abb. Darstellung des Datenstroms EL31xx) ist der Datenstrom der EL31xx (Verarbeitung der Rohdaten) dargestellt.
Darstellung des Datenstroms EL31xx
Berechnung der Prozessdaten
Der bei Beckhoff historisch begründete Begriff „Kalibrierung“ wird hier verwendet, auch wenn er nichts mit Abweichungsaussagen eines Kalibrierungszertifikates zu tun hat. Es werden hier faktisch die hersteller- oder kundenseitigen Abgleichdaten/Justagedaten beschrieben die das Gerät im laufenden Betrieb verwendet um die zugesicherte Messgenauigkeit einzuhalten.
Die Klemme nimmt permanent Messwerte auf und legt die Rohwerte ihres A/D-Wandlers ins ADC raw value-Objekt 0x80nE:01. Nach jeder Erfassung des Analogsignals erfolgt die Korrekturberechnung mit den Hersteller- und Anwender Abgleichdaten sowie der Anwenderskalierung wenn diese aktiviert sind (siehe Abb. Darstellung des Datenstroms EL31xx).
Berechnung | Bezeichung
XF = f( XADC ) | Ausgabe Wert nach dem Filter
YH = (XF – BH) x AH x 2-14 | Messwert nach Hersteller-Abgleich,
YA = (YH – BA) x AA x 2-14 | Messwert nach Hersteller- und Anwender -Abgleich
YS= YA x AS x 2-16 + BS | Messwert nach Anwender-Skalierung
Name | Bezeichnung | Index
XADC | Ausgabe Wert des A/D Wandlers | 0x80nE:01
XF | Ausgabe Wert nach dem Filter | -
BH | Offset der Hersteller-Abgleich (nicht veränderbar) | 0x80nF:01
AH | Gain der Hersteller-Abgleich (nicht veränderbar) | 0x80nF:02
BA | Offset der Anwender-Abgleich (aktivierbar über Index 0x80n0:0A) | 0x80n0:17
AA | Gain der Anwender-Abgleich (aktivierbar über Index 0x80n0:0A) | 0x80n0:18
BS | Offset der Anwender-Skalierung (aktivierbar über Index 0x80n0:01) | 0x80n0:11
AS | Gain der Anwender-Skalierung (aktivierbar über Index 0x80n0:01) | 0x80n0:12
YS | Prozessdaten zur Steuerung | -
Messergebnis
Die Genauigkeit des Ergebnisses kann sich verringern, wenn durch eine oder mehrere Multiplikationen der Messwert kleiner als 32767 / 4 beträgt.
Hersteller-Abgleich, Index 0x80n0:0B
Die Freigabe des Hersteller-Abgleichs erfolgt über den Index 0x80n0:0B. Die Parametrierung erfolgt über die Indizes
▪
0x80nF:01 Hersteller-Abgleich: Offset
▪
0x80nF:02 Hersteller-Abgleich: Gain
Anwender-Abgleich, Index 0x80n0:0A
Die Freigabe des Anwender-Abgleichs erfolgt über den Index 0x80n0:0A. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:17 Anwender-Abgleich: Offset
▪
0x80n0:18 Anwender-Abgleich: Gain
Anwender-Skalierung, Index 0x80n0:01
Die Freigabe der Anwender-Skalierung erfolgt über den Index 0x80n0:01. Die Parametrierung erfolgt über die Indizes
▪
0x80n0:11 Anwender-Skalierung: Offset
▪
0x80n0:12 Anwender-Skalierung: Gain
Producer Codeword
Beckhoff behält sich den Herstellerabgleich der Klemmen vor. Das Producer codeword ist daher z. Zt. reserviert.


Parametrierung

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Parametrierung
Parametrierung
Im TwinCAT Systemmanager wird eine EL31xx über 2 Dialogfenster/Reiter/Tabs parametriert, der Prozessdatenreiter (A) für die kommunikationsspezifischen Einstellungen und das CoE-Verzeichnis (B) für Einstellungen im Slave.
Parametrierung EL31xx
▪
Änderungen in den prozessdatenspezifische Einstellungen sind generell erst nach einem Neustart des EtherCAT Masters wirksam:
Neustart TwinCAT im RUN oder CONFIG Mode; RELOAD im CONFIG Mode
▪
Änderungen im Online-CoE-Verzeichnis
- sind im Allgemeinen sofort wirksam
- werden im Allgemeinen. nur in der Klemme/im Slave stromausfallsicher gespeichert und sollten deshalb in der CoE-StartUp-Liste eingetragen werden. Diese Liste wird bei jedem EtherCAT Start abgearbeitet und die Einstellungen in den Slave geladen.


Sync Manager

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Sync Manager
Sync Manager
Sync Manager (SM)
PDO-Zuordnung der SyncManager
SM3, PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 0x1A01 | 4.0 | AI Standard Channel 1 | Index 0x6000:01 - Status_Underrange Index 0x6000:02 - Status_Overrange Index 0x6000:03 - Status_Limit 1 Index 0x6000:05 - Status_Limit 2 Index 0x6000:07 - Status_Error Index 0x6000:0F - Status_TxPDO Status Index 0x6000:10 - Status_TxPDO Toggle Index 0x6000:11 - Value
0x1A01 | 0x1A00 | 2.0 | AI Compact Channel 1 | Index 0x6000:11 - Value
0x1A02 (default) | 0x1A03 | 4.0 | AI Standard Channel 2 | Index 0x6010:01 - Status_Underrange Index 0x6010:02 - Status_Overrange Index 0x6010:03 - Status_Limit 1 Index 0x6010:05 - Status_Limit 2 Index 0x6010:07 - Status_Error Index 0x6010:0F - Status_TxPDO Status Index 0x6010:10 - Status_TxPDO Toggle Index 0x6010:11 - Value
0x1A03 | 0x1A02 | 2.0 | AI Compact Channel 2 | Index 0x6010:11 - Value
0x1A10 | - | 28.0 | HART Cmd3 Channel 1, siehe Hinweis 1) | Index 0x6080:01 - Field Device Status Index 0x6080:02 - Cyclic Frame Cnt Index 0x6080:04 - Primary Variable Units Code Index 0x6080:05 - Secondary Variable Units Code Index 0x6080:06 - Tertiary Variable Units Code Index 0x6080:07 - Quaternary Variable Units Code Index 0x6080:08 - Primary Variable Loop Current Index 0x6080:09 - Primary Variable Index 0x6080:0A - Secondary Variable Index 0x6080:0B - Tertiary Variable Index 0x6080:0C - Quaternary Variable
0x1A12 | - | 28.0 | HART Cmd3 Channel 2, siehe Hinweis 1) | Index 0x6090:01 - Field Device Status Index 0x6090:02 - Cyclic Frame Cnt Index 0x6090:04 - Primary Variable Units Code Index 0x6090:05 - Secondary Variable Units Code Index 0x6090:06 - Tertiary Variable Units Code Index 0x6090:07 - Quaternary Variable Units Code Index 0x6090:08 - Primary Variable Loop Current Index 0x6090:09 - Primary Variable Index 0x6090:0A - Secondary Variable Index 0x6090:0B - Tertiary Variable Index 0x6090:0C - Quaternary Variable
1) Auslesen des Stromschleifenwertes und bis zu vier vorkonfigurierte dynamische Variablen.


Field Device Status (HART)

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Field Device Status (HART)
Field Device Status (HART)
Field Device Status
Gibt den aktuellen Betriebszustand der angeschlossenen Feldbuskomponente (i.d.R. dem Sensor) insgesamt wieder und ist an der Vervollständigung eines jeglichen Kommandos nicht gebunden.
Bit-Wert | Bedeutung | Erläuterung
0x80 | Device Malfunction | Das Feldgerät hat einen Fehler bzw. einen Defekt detektiert der zu einem eingeschränkten Betrieb führt.
0x40 | Configuration Changed | Es wurde eine Funktion zur Konfigurationsänderung des Feldgerätes durchgeführt.
0x20 | Cold Start | Ein Fehler bei der Versorgung bzw. ein Rücksetzen des Feldbusgerätes ist erfolgt.
0x10 | More Status Available | Es stehen weitere Zustandsinformationen über das Kommando 48 (Read Additional Status Information) zur Verfügung.
0x08 | Loop Current Fixed | Der Schleifenstrom ist an einem festgelegten Wert angehalten worden und das Feldbusgerät reagiert nicht auf Prozessänderungen.
0x04 | Loop Current Saturated | Der Schleifenstrom hat den oberen (oder unteren) Endwert erreicht und kann nicht weiter erhöht (oder erniedrigt) werden.
0x02 | Non-Primary Variable Out of Limits | Eine Variable des Feldgerätes, die nicht auf die PV abgebildet ist, ist außerhalb ihrer Betriebsgrenze.
0x01 | Primary Variable Out of Limits | PV ist außerhalb ihrer Betriebsgrenze.
PV = Primärvariable


Einstellungen und Betriebsmodi

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Einstellungen und Betriebsmodi
Einstellungen und Betriebsmodi
Weiterführende Informationen
•
Darstellung (Presentation), Index 0x80n0:02
•
Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:01, 0x60n0:02
•
Limit 1 und Limit 2, Index 0x80n0:13, 0x80n0:14
•
Betriebsmodi
•
Filter Betrieb (FIR- und IIR), Index 0x80n0:06, 0x80n0:15


Darstellung (Presentation), Index 0x80n0:02

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Einstellungen und Betriebsmodi [image] Darstellung (Presentation), Index 0x80n0:02
Darstellung (Presentation), Index 0x80n0:02
Die Ausgabe des Messwertes erfolgt in ab Werk in Zweierkomplement-Darstellung (Signed Integer).
Index 0x80n0:02 bietet die Möglichkeit zur Veränderung der Darstellungsweise des Messwertes.
Signed Integer-Darstellung
Der negative Ausgabewert wird im Zweierkomplement (negiert + 1) dargestellt.
Maximaler Darstellungsbereich bei 16 Bit = -763dez .. +32425dez
4..20 mA (NAMUR) | Dezimal | Hexadezimal
- | 32767 | 0x7FFF
21 mA | 32425 | 0x7EAC
20,5 mA | 31472 | 0x7A20
20 mA | 30518 | 0x7736
4 mA | 0 | 0x0000
3,8 mA | -381 | 0xFE83
3,6 mA | -763 | 0xFD05
- | -32768 | 0x8000
Darstellung des Messbereichs 3,6…21mA (NAMUR)


Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:01, 0x60n0:02

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Einstellungen und Betriebsmodi [image] Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:01, 0x60n0:02
Unterschreitung und Überschreitung des Messbereiches (Underrange, Overrange), Index 0x60n0:01, 0x60n0:02
Underrange/ Overrange, Index 0x60n0:01/ 0x60n0:02
Im Kapitel Datenstrom und Korrekturberechnung finden Sie eine anschauliche Darstellung der Korrekturberechnung von den Rohwerten zu den Ausgabewerten beim Überschreiten der Grenzbereiche.


Limit 1 und Limit 2, Index 0x80n0:13, 0x80n0:14

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Einstellungen und Betriebsmodi [image] Limit 1 und Limit 2, Index 0x80n0:13, 0x80n0:14
Limit 1 und Limit 2, Index 0x80n0:13, 0x80n0:14
Beim Über- bzw. Unterschreiten der Werte, die in den Indizes 0x80n0:13 und 0x80n0:14 eingegeben werden können, werden die Bits in den Indizes 0x60n0:03 und 0x60n0:05 entsprechen gesetzt (siehe unteres Beispiel). Zur Aktivierung der Grenzwertüberwachung dienen die Indizes 0x80n0:07 bzw. 0x80n0:08.
Ausgabe Limit n (2 Bit):
▪
0: nicht aktiv
▪
1: Wert ist kleiner als Grenzwert
▪
2: Wert ist größer als Grenzwert
▪
3: Wert ist gleich dem Grenzwert
Limit-Auswertung
Die Limit-Auswertung geht von einer Signed-Darstellung aus. Die Umrechnung in die gewünschte Darstellung (Index 0x80n0:02) erfolgt erst nach der Limit-Auswertung.
Verlinkung in der PLC mit 2-Bit-Werten
Die Limit-Information besteht aus 2 Bit. Im System Manager kann Limitn mit der PLC oder einer Task verknüpft werden.
▪
PLC:
Es gibt in der IEC61131-PLC keinen 2-Bit-Datentyp der mit diesem Prozessdatum 1:1 verlinkt werden kann. Zur Übertragung der Limit-Information definieren Sie deshalb ein Eingangsbyte (z. B. siehe Abb. Definition Eingangsbyte ), und verlinken Sie den Limit mit dem VariableSizeMismatch-Dialog, wie im Kapitel Hinweis zum 1-Byte-Status früherer EtherCAT Klemmen beschrieben.
Definition Eingangsbyte
▪
Zusätzliche Task
Im System Manager können 2-Bit-Variablen angelegt werden.
Verlinkung 2-Bit-Variable mit zusätzlicher Task
Beispiel für EL3162:
Kanal 1; Limit 1 und Limit 2 enabled, Limit 1 = 2,8 V, Limit 2 = 7,4 V, Darstellung: signed integer
Eingabe in Index (Limit 1): 0x8000:13
(2,8 V / 10 V) x 216 / 2 - 1 = 9.174dez
Eingabe in Index (Limit 2): 0x8000:14
(7,4 V / 10 V) x 216 / 2 - 1 = 24.247dez
Ausgabe:
Eingang Kanal 1 | Index 0x6000:03 | Index 0x6000:05
1.8 V | 0x01hex, (Limit 1, Grenzbereich unterschritten) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
2.8 V | 0x03hex, (Limit 1, Grenzbereich erreicht) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
4.2 V | 0x02hex, (Limit 1, Grenzbereich überschritten) | 0x01hex, (Limit 2, Grenzbereich unterschritten)
8.5 V | 0x02hex, (Limit 1, Grenzbereich überschritten) | 0x02hex, (Limit 2, Grenzbereich überschritten)


Betriebsmodi

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Einstellungen und Betriebsmodi [image] Betriebsmodi
Betriebsmodi
Die EL30xx bzw. EL31xx unterstützt drei verschiedene Betriebsmodi: Freerun (Filter ein, Timer-Interrupt), Synchron (Filter aus, SyncManager-Interrupt) und DC (DC-Sync-Interrupt)
Abhängigkeit der Betriebsmodi
Durch Aktivieren/Deaktivieren der Filter über den Index wechselt die Klemme zwischen den Betriebsarten Freerun (Filter an) und Synchron. Dies geschieht während die Klemme im OP-Betrieb bleibt. Durch die Umstellung können verlängerte Abtastzeiten auftreten sowie Sprünge in den Prozessdaten bis die Filter eingeschwungen sind.
Der DC Betrieb kann nur bei abgeschalteten Filtern verwendet werden. Ebenso ist es nicht möglich, die Filter im DC-Betrieb einzuschalten. Der DC-Betrieb wird über den Reiter "DC" im TwinCAT System Manager parametriert.
Die Betriebsmodi der EL30xx/EL31xx lauten:
Modus | 1 (default) | 2 | 3 | 4 | 5 | 6
Filter (Index: 0x8000:06) | On (default.: 50 Hz FIR) | Off
Distributed Clocks-Betrieb | Off |  |  |  |  | On
Möglich in EL30xx | x | x | x | x | x |
Möglich in EL31xx | x | x | x | x | x | x
Defaulteinstellung für | EL30xx |  |  | EL31xx |  |
Synchronisation Mode (Index: 0x1C33:01, Bit 0+1) | 0: FreeRun (default) | 0: FreeRun (default) |  | 1: Frame Triggered (SM3 inputs) |  | 3: DC-mode
FastOp-Mode "CoE" (Index: 0x1C33:01, Bit 15) | Off (default) | Off (default) | On | Off (default) | On | Off (default) (FastOp Mode im DC nicht möglich)
StartUp Eintrag Index 0x1C33:01 | 0x0000 | 0x0000 | 0x8000 | 0x0001 | 0x8001 |
Aktualisierungsrate | abhängig von Filtereinstellung, klemmenintern automatisch eingestellt siehe nachfolgende Werte |  |  | EtherCAT Zykluszeit, wenn untere einstellungsabhängige Grenze nicht unterschritten wird. Typ. Grenze siehe nachfolgende Werte. Ein Betrieb mit schnellerem EtherCAT Zyklus ist möglich, allerdings liefert die EL30xx dann nicht mehr in jedem Zyklus neue Daten. |  | EtherCAT Zykluszeit, wenn untere einstellungsabhängige Grenze nicht unterschritten wird.
typ. data update time (EL30x1) | 50 Hz FIR: typ. 625 µs 60 Hz FIR: typ. 520 µs IIR: typ. 1 ms | < 600 µs | < 500 µs
typ. data update time (EL30x2)
typ. data update time (EL30x4)
typ. data update time (EL30x8) | 50 Hz FIR: typ. 1.25 ms 60 Hz FIR: typ. 1 ms IIR: typ. 1 ms | < 1,1 ms | < 1 ms
Hinweis | Sobald Filtern aktiviert wird, wird unabhängig von anderen Einstellungen "FreeRun" = An und "FastOp-Mode" = Aus in der EL30xx eingestellt. |  |  |  |  | Die Hinweise zur min. EtherCAT Zykluszeit im DC-mode sind zu beachten
Kombinationen Filter, FastOp-Mode und Synchronisation Mode
Andere Kombinationsmöglichkeiten aus Filter, FastOp-Mode und Synchronisation Mode werden ausdrücklich nicht empfohlen.
Synchron Betrieb
Im Synchronen Betrieb werden Prozessdaten Frame-getriggert erzeugt, so dass mit jedem PLC-Zyklus ein neuer Wert vorhanden ist. Der synchrone Betrieb wird bei den EL31xx Klemmen automatisch verwendet (Filter aus, kein DC). Minimale Zykluszeiten sind 80 µs (EL31x1/EL31x2), und 120 µs (EL31x4) bei Standard-IPCs.
DC-Betrieb
Im DC-Betrieb wird das Analog-Sampling per DC-interrupt ausgelöst. Dadurch spielt der zeitliche Jitter zwischen zwei Frames keine Rolle mehr und der Sampling-Zeitpunkt ist systemweit gleich.
Die EL31xx sollen im DC-Input-Based-Modus betrieben werden.
Der DC-Betrieb benötigt minimale EtherCAT Zykluszeiten von
▪
100 µs (EL31x1, EL31x2 im 1-kanaligen Betrieb)
▪
125 µs (EL31x2 im 2-kanaligen Betrieb)
▪
150 µs (EL31x4)
▪
250 µs (EL3174)
▪
200 µs (EL3174-0002, EL3174-0032)
▪
500 µs (EL3174-0090)
bei Standard-IPCs.
Der "Input Based" Betrieb verschiebt den Sync-Interrupt automatisch so, dass die Prozessdaten kurz vor dem aktuellen Prozessdatenzyklus abholbereit sind.
Sollte der Frame-Jitter zu groß sein, kann es dennoch sein daß doppelte Daten abgeholt werden bzw. es zu Aussetzern kommt in der Übertragung. Dann ist durch TwinCAT-System-Maßnahmen der Jitter zu verringern oder eine langsamere Zykluszeit zu wählen.


Filter Betrieb (FIR- und IIR), Index 0x80n0:06, 0x80n0:15

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Einstellungen und Betriebsmodi [image] Filter Betrieb (FIR- und IIR), Index 0x80n0:06, 0x80n0:15
Filter Betrieb (FIR- und IIR), Index 0x80n0:06, 0x80n0:15
Die Klemmen EL31xx sind mit einem digitalen Filter ausgestattet, das je nach Einstellung die Charakteristik eines Filter mit endlicher Impulsantwort (Finite Impulse Response filter, FIR-Filter) oder eines Filter mit unendlicher Impulsantwort (Infinite Impulse Response filter, IIR-Filter), annehmen kann. Der Filter ist per default deaktiviert. Zur Aktivierung mit Index 0x8000:06 bitte den folgenden Hinweis beachten.
Aktivierung des Filters mit Index 0x8000:06 und Einstellung der Filtereigenschaften über Index 0x8000:15
Die Filterfrequenzen werden für alle Kanäle der Klemmen EL3xxx zentral über den Index 0x8000:15 (Kanal 1) eingestellt. Die entsprechenden Indizes 0x80n0:15 der weiteren Kanäle haben keine Parametrierungsfunktion.
FIR-Filter
Wird über den Index 0x8000:15 parametriert.
Der Filter arbeitet als Notch-Filter (Kerbfilter) und bestimmt die Wandlungszeit der Klemme. Je höher die Filterfrequenz, desto schneller ist die Wandlungszeit. Es steht ein 50 und ein 60 Hz Filter zur Verfügung.
Kerbfilter bedeutet, dass der Filter bei der genannten Filterfrequenz und Vielfachen davon Nullstellen (Kerben) im Frequenzgang hat, diese Frequenzen also in der Amplitude dämpft.
Das FIR-Filter arbeitet als nicht-rekursives Filter.
Dämpfungskurve Notch.Filter bei 50 Hz
Filterdaten FIR - Filter (1- 4 kanalige Klemmen)
Filter | Dämpfung | Grenzfrequenz (-3 dB) | Wandlungszeit
50 Hz FIR | > 50 dB | 22 Hz | 625 µs
60 Hz FIR | > 45 dB | 26 Hz | 521 µs
IIR-Filter
Das Filter mit IIR-Charakteristik ist ein zeitdiskretes, lineares, zeitinvariantes Tiefpass-Filter 1.Ordnung (-20dB/Dekade), welches in 8 Leveln, also Grenzfrequenzen eingestellt werden kann (Level 1 = schwaches rekursives Filter, bis Level 8 = starkes rekursives Filter)
Der IIR kann als gleitende Mittelwertberechnung nach einem Tiefpass verstanden werden.
Durch den Synchronisierungsmodus FreeRun arbeitet der IIR-Filter mit 180 µs (1 oder 2 Kanäle) bzw. 500 µs (4 Kanäle) interner Zykluszeit.
IIR - Filter | EL31x1, EL31x2, Samplingzeit 180 µs | EL31x4, Samplingzeit 500 µs
 | Grenzfrequenz (-3 dB) | Grenzfrequenz (-3 dB)
IIR 1 | 1 kHz | 400 Hz
IIR 2 | 500 Hz | 220 Hz
IIR 3 | 285 Hz | 100 Hz
IIR 4 | 142 Hz | 50 Hz
IIR 5 | 66 Hz | 24 Hz
IIR 6 | 33 Hz | 12 Hz
IIR 7 | 17 Hz | 6,2 Hz
IIR 8 | 8,2 Hz | 3,0 Hz


Prozessdaten

Inbetriebnahme [image] Prozessdaten und Betriebsmodi [image] Prozessdaten
Prozessdaten
Inhaltsverzeichnis
• Interpretation Value- & Status-Variable
• Status-Wort
• Umschaltung Prozessdatensätze
• Hinweis zu TwinCAT 2.10
• Passwortschutz für Anwenderkalibrierung/User calibration
Die EL31xx-Klemmen bieten je Analogkanal zwei verschiedene Prozessdaten zur Übertragung an: den Analogwert Value (16 Bit) und Statusinformationen (16 Bit). Die Übertragung einzelner Statusinformationen wie auch einzelner Kanäle können im Reiter ProcessData deaktiviert werden, diese Änderungen sind nach Aktivierung und EtherCAT-Neustart bzw. einem Reload wirksam.
2 Prozessdatenarten stehen bei der EL31xx zur Auswahl:
▪
Standard: Standardeinstellung, je Kanal werden Value (16 Bit) und Statusinformationen (8 bzw.16 Bit) übertragen
▪
Compact: je Kanal wird nur der Value (16 Bit) übertragen
Am Beispiel der EL3102 (2 Kanäle ±10 V) werden im Folgenden die Einstellungen erläutert. Die Angaben sind gültig für TwinCAT 2.11 ab Build 1544 und XML-Revision ab EL31xx-0000-0016.
Interpretation Value- & Status-Variable
Default-Prozessdaten der EL3102-0000-0016
Die Klartextdarstellung der Bitbedeutungen des Status-Word ist insbesondere bei der Inbetriebnahme, aber auch zur Verlinkung mit dem PLC-Programm hilfreich.
Durch Rechtsklick auf die Statusvariable im Konfigurationsbaum (A) kann die Struktur zur Verlinkung geöffnet werden (B).
Um in der Online-Anzeige (C) ebenfalls die Bitbedeutungen in Klartext lesen zu können, können mit dem Button
Show Sub Variables
allgemein alle Untervariablen angezeigt werden, so auch die Strukturinhalte des Status-Word, s. Abb. Anzeige Untervariablen der EL3102-0000-0016 ab TwinCAT 2.11 build 1544
Anzeige Untervariablen der EL3102-0000-0016 ab TwinCAT 2.11 build 1544
Control/Status-Wort
Status-Wort
Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | TxPDO Toggle | TxPDO State | Sync error | - | - | - | - | -
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | - | ERROR | Limit 2 |  | Limit 1 |  | Overrange | Underrange
Legende
Bit | Name | Beschreibung
SW.15 | TxPDO Toggle | 1bin | Toggelt mit jedem neuen analogen Prozesswert
SW.14 | TxPDO State | 1bin | TRUE bei internem Fehler
SW.13* | Sync error | 1bin | TRUE (DC mode): im abgelaufenen Zyklus ist ein Synchronisierungsfehler aufgetreten.
SW.6 | ERROR | 1bin | Allgemeines Fehlerbit, wird zusammen mit Overrange und Underrange gesetzt
SW.5 | Limit 2 | 1bin | Siehe Limit
SW.4 |  | 1bin
SW.3 | Limit 1 | 1bin | Siehe Limit
SW.2 |  | 1bin
SW.1 | Overrange | 1bin | Analoges Eingangssignal liegt über der oberen zul. Schwelle für diese Klemme
SW.0 | Underrange | 1bin | Analoges Eingangssignal liegt unter der oberen zul. Schwelle für diese Klemme
*) ab Rev. EL31xx-0000-0016
Control-Wort
Die EL31xx haben kein Control-Wort
Umschaltung Prozessdatensätze
Die zu übertragenden Prozessdaten (PDO, ProcessDataObjects) können durch den Benutzer
▪
komplett für alle Kanäle über den Auswahldialog "Predefined PDO Assignment" (alle TwinCAT Versionen)
▪
selektiv für einzelne PDO unter Berücksichtigung der ausgeschlossenen Elemente ausgewählt werden.
Auswahldialog "Predefined PDO Assignment" (ab TwinCAT 2.11 build 1544)
Soweit in der XML-Beschreibung vorhanden, können definierte PDO-Sätze vorgewählt werden.
Vordefinierte PDO Zuordnungen der EL3102-0000-0016
Dadurch werden gleichzeitig alle Kanäle der EL31x2 auf Legacy, Legacy compact, Standard- oder Compact-Prozessabbild eingestellt.
Selektive PDO Auswahl
Alle TwinCAT Versionen unterstützen die selektive Auswahl einzelner PDOs, wie in der XML-Beschreibung definiert.
Ausschlusskriterien verhindern irreguläre Kombinationen.
Selektive PDO Auswahl
Erläuterungen zu Selektive PDO Auswahl: Im Karteireiter "Process Data" ist unter (A) ersichtlich, dass diese EL3102 mehrere unterschiedliche PDOs zur Übertragung anbietet, und zwar für jeden Kanal
▪
"Legacy" aus dem CoE-Index 0x1A00/0x1A01: Status-Wort und Kanal-Messwert, 3 Byte
▪
"Legacy compact" aus dem CoE-Index 0x1A10: nur Kanal-Messwert für 2 Kanäle, 4 Byte
▪
"AI Standard" aus dem CoE-Index 0x1A02/0x1A04: Kanal-Messwert und Status, 4 Byte
▪
"AI Compact" unter CoE-Index 0x1A03/0x1A05: nur der Kanal-Messwert, 2 Byte
Legacy PDO Zuordnung
Die Legacy PDO Zuordnung ist ein Kompatibilitätsmodus zu früheren 2 kanaligen 16 Bit Eingangsklemmen (EL31x2) und sollte nicht für neue Konfigurationserstellungen verwendet werden. Dieser Modus stellt einen komplikationsfreien Austausch älterer gegen neue EL31x2 sicher. Siehe auch nachfolgendes Kapitel.
Durch Auswahl des benötigten Input-SyncManager in (B) kann die PDO-Zuordnung/Assignment unter (C) manuell vorgenommen werden. Die Prozessdaten können dann im TwinCAT-Baum (D) verlinkt werden.
Hinweis zum 1-Byte-Status früherer EtherCAT Klemmen
Bisherige Analoge Eingangsklemmen von Beckhoff (z. B. EL31x2) verfügten über ein Status-Byte statt des nun implementierten Status-Word und damit ein 3-Byte-Interface. Erweiterte Diagnosemöglichkeiten bieten nun 8 zusätzliche Bits, wodurch das Default-Prozessabbild der EL31xx nun 4 Byte umfasst, Status-Word und Value-Word. Die Bitbedeutungen des LowByte blieben erhalten, Limit1 und Limit2 als 2-Bit-Typen werden bei den EL31xx eingeblendet.
3-Byte-Interface der EL31x2
Ist in bestehenden PLC-Projekten das 3-Byte-Interface zur Verlinkung mit dem analogen Eingangskanal implementiert, bietet der TwinCAT Systemmanager dennoch die Möglichkeit, die EL31xx mit 4-Byte-Interface zu verlinken.
Öffnen Sie dazu den Link-Dialog wie üblich durch Doppelklick auf die Variable und aktivieren Sie die Checkbox AllTypes. Dadurch werden auch Variablen mit differierender Größe zur Verlinkung angeboten. Wählen Sie die entsprechende 1-Byte-Eingangsvariable Ihrer Applikation, im folgenden SizeMismatch-Dialog wird die Überdeckung von 8 Bit bestätigt, Abb. Element-orientiertes Prozessabbild unter TwinCAT 2.10.
4-Byte-Interface der EL31xx mit bestehendem 3-Byte-Interface im Projekt verbinden
Hinweis zu TwinCAT 2.10
Die strukturierte Darstellung der EL31xx ab Revision EL31xx-0000-0016 wie in Abb. Selektive PDO Auswahl gezeigt ist bedingt durch eine entsprechende Interpretation der Variablenbezeichnungen. Diese Funktion ist unter TwinCAT 2.10 noch nicht gegeben, weshalb dort nur die elementweise Verknüpfung möglich ist.
Element-orientiertes Prozessabbild unter TwinCAT 2.10
Passwortschutz für Anwenderdaten
Einige Anwenderdaten sind durch ein zusätzliches Passwort, dass in CoE 0xF009 einzutragen ist, vor dem unerwünschten oder irrtümlichen beschreiben geschützt:
▪
CoE Schreibzugriffe durch den Anwender, PLC oder Startup-Einträge im Single- oder CompleteAccess-Zugriff
▪
Überschreiben der Werte durch RestoreDefaultParameter Zugriff auf 0x80n0 (bzw. 0x80nD, falls vorhanden)
Passwortschutz für die 0x8000:17 und 0x8000:18 Einträge (Beispiel)
Der Passwortschutz gilt für folgende Anwenderdaten
Schutzfähiges CoE Objekt | Klemmen
0x80n0:17 (User Calibration Offset) 0x80n0:18 (User Calibration Gain) | EL31xx, ELX31xx
0x80nD:17, (Low Range Error) 0x80nD:18 (High Range Error) | EL3174, EL3174-00xx, EL318x, ELX3181
Verwendung von CoE 0xF009
▪
Eintragen von 0x12345678 aktiviert den Passwortschutz → Objekt zeigt "1" (eingeschaltet) an
Geschützte Objekte können nun nicht mehr geändert werden, bei einem Schreibzugriff kommt keine Fehlermeldung!
▪
Eintragen von 0x11223344 deaktiviert den Passwortschutz → Objekt zeigt "0" (ausgeschaltet) an
Code word Index 0xF008
Dieses CoE Objekt hat lediglich eine herstellerspezifische Funktion und ist nicht für den Anwender vorgesehen.


Grundlagen NAMUR

Inbetriebnahme [image] Grundlagen NAMUR
Grundlagen NAMUR
NAMUR ist die Abkürzung für den Verband „Interessengemeinschaft Automatisierungstechnik der Prozessindustrie“. Der Verband unterstützt vorrangig die Belange der Prozessindustrie in Bezug auf Normung, Geräte, Messverfahren u.ä. In dieser Funktion gibt die NAMUR sog. NE (NAMUR-Empfehlungen) heraus, die fortlaufend nummeriert werden.
Informationen zur Umsetzung der Empfehlung in Beckhoff Produkten sind in dieser Dokumentation in den Kapiteln „Technische Daten“ und „Prozessdaten“ angegeben.
Analoge Messwerte
Der analoge Ausgangswert eines Sensors, der u.a. als ein bestimmter Stromwert erfasst werden kann, stellt die Messinformation (M) dar.
Mittels NAMUR NE43 („Vereinheitlichung des Signalpegels für die Ausfallinformation von digitalen Messumformern mit analogem Ausgangssignal“) wird eine Empfehlung – unabhängig vom Sensorgerätehersteller – einer vereinheitlichten Ausfallinformation (A) zusätzlich zur Messinformation gegeben (z.B. Ausfall des Messumsetzers, Fehler in Verbindungsleitungen, Ausfall von Hilfsenergien etc.). Die Ausfallinformation sagt aus, dass ein Fehler im Messsystem vorliegt. Bei Sensoren in einer Stromschleife mit analogem Ausgangssignal wird diese Information durch entsprechende Stromamplituden dargestellt. Ein Stromwert, der sich außerhalb der von NAMUR definierten Grenzen der Messinformation befindet, wird als ungültig definiert und somit als Ausfallinformation interpretiert. Die folgende Grafik veranschaulicht dies:
Darstellung der Grenzbereiche aus der NAMUR-Empfehlung NE43, Version 03.02.2003


HART

HART
HART
Hinweis zum HART Plug-In
Das HART Plug-In steht ab TwinCAT 3.1 Build 4022 zur Verfügung.
Für dessen Bereitstellung in älteren TwinCAT-Versionen wenden Sie sich bitte an den Beckhoff-Support.
Weiterführende Informationen
•
Einstellung
•
Slave Information
•
Messwerte
•
Azyklische Dienste


Einstellung

HART [image] Einstellung
Einstellung
Über den Dialog "HART Settings" können Master Eigenschaften eingestellt werden.
Nach der entsprechenden Kanalauswahl sind die folgenden Punkte veränderbar.
▪
PreambleLength Länge der Master Preamble. Steht diese auf "Automatic Assign" kommuniziert der Master automatisch mit der mind. unterstützte Länge vom angeschlossenen HART Slave.
▪
MasterMode Auswahl von Primary oder Secondary MasterMode.
▪
DefaultPollingAdress Ein Slave muss über Cmd0 abgefragt werden um durch die gewonnene Info eine UniqueAddress bilden zu können. Hier wird eingestellt über welche Adresse Cmd0 abgefragt wird (möglich 0..63).
▪
PollingTime Wird eine zyklische HART Kommunikation aktiviert legt dieser Wert die Zykluszeit fest.
▪
MaxRetrys Wurde eine HART Anfrage nicht richtig beantwortet gibt dieser Wert die maximalen Wiederholungszyklen an.
Die vorgenommen Einstellungen müssen mit dem Button "Write to Actual Channel..." bestätigt werden, erst dann werden diese auch übernommen und ggf. mit abgespeichert.
Über "Set to Default..." können wieder die Defaultwerte hergestellt werden.
Der Button "Scan Polling Adress..." ermöglicht das Einscannen des angeschlossen HART Gerätes und somit das Finden der verwendeten Polling Adresse. Gescannt wird hier von 0 bis 63, antwortet ein Gerät wird der Scanvorgang abgebrochen. Es besteht die Möglichkeit die gefundene Adresse ins Projekt zu übernehmen.


Slave Information

HART [image] Slave Information
Slave Information
Über den Dialog "Slave Information" können allgemeine Informationen vom angeschlossene Slave gelesen und geschrieben werden.
Über die Checkboxen erfolgt eine Auswahl der zu lesenden Daten, ebenso welche geschrieben werden sollen.
Für die zu schreibenden Daten bestehen folgende Regeln:
▪
Tag 8 Bytes Packed ASCII
▪
Descriptor 16 Bytes Packed ASCII
▪
Date Format xx.yy.zzzz
▪
Message 32 Bytes Packed ASCII
Kleinbuchstaben bei Packed ASCII
Bei Packed ASCII sind keine Kleinbuchstaben erlaubt. Werden diese verwendet, werden automatisch Großbuchstaben geschrieben!


Messwerte

HART [image] Messwerte
Messwerte
Eine besondere Funktion kommt dem Kommando 3 bei. Hiermit kann über HART der aktuelle Stromwert ausgelesen werden, außerdem bis zu 4 Prozesswerte inkl. ihrer Einheit. Die Zahl der gelieferten Prozesswerte hängt vom verwendeten HART Slave ab.
Eine grafische Aufbereitung der Werte erfolgt in TwinCAT unter dem Reiter "Measured Values Display".
Eine Aktualisierung der Werte erfolgt automatisch alle drei Sekunden. Dieser Wert ist unabhängig der eingestellten Poll-Zeit.
Zyklische Prozessdaten
Weiterhin kann das HART Cmd 3 zyklisch gemappt werden (siehe CoE Objekt Index 0x6080 für Kanal 1 bzw. Index 0x6090 für Kanal 2). Durch aktivieren des Kontrollkästchens „Cyclic Process Data“ kann ein HART-spezifischer Satz von zusätzlichen Prozessdaten angelegt werden, die von der Steuerung gelesen werden können.
Zusätzliche PDO (Cmd 3) der HART Kommunikation
Nach einem Aktivieren der Konfiguration erfolgt eine zyklische Aktualisierung, Zeitbasis ist hierfür die Poll-Zeit. Der azyklische Dienst aus diesem Dialog bedient sich alle drei Sekunden der Werte aus dem zyklischen Puffer.


Azyklische Dienste

HART [image] Azyklische Dienste
Azyklische Dienste
Ein einfaches Lesen oder Schreiben einzelner HART Kommandos kann über den Dialog "Acyclic Services" erfolgen.
Ein Lesen erfolgt einfach durch die Eingabe des HART Kommandos, falls dieses vom Slave unterstützt wird kommen die gelesene Länge und die Daten zurück.
Für einen Schreibaufruf muss auch das Kommando eingegeben werden, außerdem die zu schreibenden Nutzdaten (ohne Header und CRC). Der Aufbau der zu verwendenden Daten ist der zugehörigen HART Dokumentation zu entnehmen (z.B. "Universal Command Specification").
Hat ein HART Kommando Nutzdaten in beide Richtungen (also Lesen und Schreiben) kann die ReadWrite Funktion genutzt werden.
Die Kommandos können direkt via ADS abgesetzt werden, hierfür ist IdxGrp = 0xF302 und IdxOffs = Cmd zu verwenden.


Field Device Tool (FDT)

Field Device Tool (FDT)
Field Device Tool (FDT)
Hinweis zum FDT Plug-In
Das FDT Plug-In steht ab TwinCAT 3.1 Build 4022 zur Verfügung.
Für dessen Bereitstellung in älteren TwinCAT-Versionen wenden Sie sich bitte an den Beckhoff-Support.
Eine weitere mögliche Verwendung eines DTM für eine umfangreiche Sensor/ Aktor Kommunikation ist durch eine (externe) FDT Applikation gegeben und ist (bis auf die Übertragungsschicht) vom TwinCAT-System weitestgehend unabhängig. Dies wird im Kapitel „Anwendung einer externen FDT Applikation“ beschrieben.
Weiterführende Informationen
•
Anwendung über TwinCAT [FDT]
•
Anwendung einer externen FDT Applikation


Anwendung über TwinCAT [FDT]

Field Device Tool (FDT) [image] Anwendung über TwinCAT [FDT]
Anwendung über TwinCAT [FDT]
Nach Auswahl der Klemme/ Box im sog. „Solutionexplorer“ (für TwinCAT 3.1, bisher: Systemmanager bei TwinCAT 2.11) stehen die üblichen Karteireiter zur Verfügung; zusätzlich [FDT]:
Karteireiter FDT am Beispiel einer EL3182 Klemme
Wurden Gerätetreiber (von entsprechenden Geräteherstellern z.T. erhältlich) auf dem verwendeten PC installiert, lässt sich mittels „Update DTM Catalog“ die jeweilige Installation in Form einer Auswahlliste aufrufen.
Hier steht dann im rechten Fenster der DTM-Katalog zur Verfügung, der ein oder mehrere Gerätetreiber anzeigen sollte.
Mittels „drag/drop“ wird aus dem DTM-Katalog der für den am jeweiligen Kanal angeschlossenen Sensor bzw. Aktor passende Gerätetreiber einfach auf das Symbol gezogen:
Hinzufügen eines Sensor/AktorDTM Gerätetreibers zum zugehörigen Kanal einer Klemme/ Box
Per Doppelklick wird nun ein weiterer Karteireiter innerhalb von [FDT] geöffnet und zeigen Sensor-/ Aktor spezifische Konfigurationsfenster:
Allgemeiner Aufbau eines DTM-Konfigurationsfensters innerhalb des Field Device Tools (FDT)
Über Rechtsklick auf den als Beispiel eingetragenen „DTM 16 (Sensor p)“ kann zudem ein Kontextmenü geöffnet werden:
Kontextmenü eines DTM Sensors/ Aktors „offline“
Mittels „FDT Monitor“ öffnet sich eine Seite für Log-Einträge. Damit kann z.B. nachvollzogen werden, ob die DTM-Statemachine ordnungsgemäß hochgefahren ist (Debug- und Service Zwecke).
„Delete“ entfernt die Zuordnung des DTM zum Kanal; „Scan“ wird weiter unten beschrieben.
Über die Auswahl „Online“ wird eine (Bus-) Verbindung mit dem Gerät hergestellt und eröffnet dadurch weitere Funktionen über das Kontextmenü, die allerdings Herstellerspezifisch sind:
Kontextmenü eines DTM Sensors/ Aktors „online“
Die Aufteilung des Menüs zeigt stets oberhalb die ersten Funktionen, die über das Plug-In (TwinCAT) bereitgestellt werden; unterhalb erscheinen die Herstellerspezifischen Funktionen:
Aufteilung des „online“ – Kontextmenüs eines DTM Sensors/ Aktors über das FDT Plug-In
Durch einen Doppelklick auf das Symbol „DTM 16 (Sensor p)“ I.d.R. wird quasi über einen verkürzten Weg eine Parametrierungsfunktion („Parameterize“ o.ä.) aufgerufen. Dabei kann der DTM sich im „Offline“ oder „Online“ Zustand befinden.
Zugriff auf ein Sensor/ Aktor über Scan des DTM
Das Einbringen des DTM Gerätes kann bei einer Betriebsbereiten Konfiguration alternativ auch einfach über „Scan“ erfolgen (Button unter dem „Channel“-Fenster oder Auswahl im Kontextmenü eines Kanals). Die Auswahlmöglichkeit wird dadurch auf die herstellerspezifischen Gerätetreiber eingegrenzt, wodurch ggf. die Auswahl des Typenübereinstimmenden DTMs erleichtert wird.
Ergebnis nach einem DTM - "Scan" über das FDT-Plug-In in TwinCAT


Anwendung einer externen FDT Applikation

Field Device Tool (FDT) [image] Anwendung einer externen FDT Applikation
Anwendung einer externen FDT Applikation
Mittels einer eigenständigen FDT Rahmen Applikation wird zunächst über den Gerätekatalog das „Beckhoff ComDTM“ eingebunden. Dadurch wird ein ähnlich wie in TwinCAT aufgebauter Dialog für die Herstellung einer Busverbindung anwendbar (siehe hierzu auch Startup: Eintrag Zielsystem):
AddRoute - Dialog im Beckhoff DTM der FDT Applikation
Der PLC der die HART Klemme ansteuert kann somit entweder über eine Suche oder durch Eintrag der bekannten IP-Adresse oder des Host Namens mit der „Beckhoff ComDTM“ verbunden werden, wodurch später der Zugriff auf den Sensor- /Aktorspezifischen Gerätetreiber (DTM) ermöglicht wird. Nach erfolgreichem Verbinden werden automatisch alle vorhandenen EtherCAT Master Systeme auf dem Zielsystem (z.B. auch lokaler Rechner) nach HART Geräten durchsucht. Die gefundenen Kanäle werden dann entsprechend angezeigt:
Eine mögliche Form dieser Anwendung zeigt:
▪
Links einen Projekt Explorer der aktuellen projektierten Geräte
▪
In der Mitte die Menüs zu den einzelnen Objekten / DTMs
▪
Rechts den Gerätekatalog der zur Auswahl stehenden DTMs
Beispiel FDT Applikation
Im Projekt Explorer können unter den Kanälen die Geräte-DTMs eingefügt werden (für die Zuordnung Kanal → DTM). Hierfür steht zusätzlich ebenfalls eine Scan-Funktion zur Verfügung um für den bereits angeschlossenen Sensor/ Aktor die Auswahl passender Gerätetreiber auf die Gerätespezifischen Varianten einzugrenzen (siehe auch: Zugriff auf ein Sensor/ Aktor über Scan des DTM).
Die folgende Abbildung zeigt zusammenfassend die gesamte Vorgehensweise:
Vorgehensweise mit der FDT Applikation für HART-DTM Zugriff über die Beckhoff_ComDTM


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen.
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL3182
Hardware (HW) | Firmware | Revision-Nr. | Release-Datum
00* | 01 | EL3182-0000-0016 | 2017/04
 | 02 |  | 2017/04
 | 03 |  | 2017/06
 | 04* |  | 2017/07
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.