EL2521 - Einkanalige Pulse-Train-Ausgangsklemme

BECKHOFF Feldbuskomponenten

Dokumentation für

Einkanalige Pulse-Train-Ausgangsklemme

EL2521-0000

RS422

EL2521-0024

24 VDC, externe Speisung

EL2521-0124

24 VDC, externe Speisung, Latch-Eingang/24 V-Ausgang

EL2521-0025

24 VDC, externe Speisung, negativ schaltend

Version: 2.8
Datum: 31.03.15

EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany.


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


EL2521 - Ausgabestände der Dokumentation

BECKHOFF EL2521: Vorwort

Ausgabestände der Dokumentation

Version | Kommentar
2.8 | - Update Kapitel "Technische Daten" - Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt - Strukturupdate
2.7 | - Update Kapitel "Grundlagen zur Funktion"
2.6 | - Update Fahrwegsteuerung
2.5 | - Update Technische Daten
2.4 | - Firmware-Kompatibilitätsliste und Technische Hinweise ergänzt
2.3 | - Korrektur LED Beschreibung
2.2 | - Ergänzung EL2521-0124
2.1 | - Ergänzung EL2521-0024, EL2521-0025
2.0 | - Ergänzung Technische Daten, CoE, PDO
1.0 | - Korrektur Technische Daten
0.1 | - Vorläufige Dokumentation für EL2521


Versionsidentifikation

BECKHOFF: Vorwort

Versionsidentifikation EtherCAT Geräte

Bezeichnung

Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus

  • Familienschlüssel
  • Typ
  • Version
  • Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017

Hinweise

  • die oben genannten Elemente ergeben die technische Bezeichnung
  • Die Bestellbezeichnung setzt sich dagegen zusammen aus
    - Familienschlüssel (EL, EP, CU, ES, KL, CX, .....
    - Typ
    - Version
  • Die Revision gibt den technischen Fortschritt wie z.B. Featureerweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
    Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z.B. in der Dokumentation angegeben.
    Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
    Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. 1.
  • Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.

Identifizierungsnummer

Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:

Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer

Als Seriennummer bezeichnet man im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit uneindeutig eine ganze Produktions-Charge.

Aufbau der Seriennummer: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02

Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):

Syntax: D ww yy x y z u

D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1

Eindeutige Seriennummer/ID

Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige, fortlaufende Seriennummer.

Siehe dazu auch weiterführende Dokumentation im Bereich

  • IP67: EtherCAT Box
  • Safety: TwinSafe
Beispiele für Kennzeichnungen:

Abb. 1: EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)

Abb. 2: EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Chargennummer

Abb. 3: CU2016 Switch mit Chargennummer

Abb. 4: EL3202-0020 mit Chargennummern 26131006 und eindeutiger D-Nummer 204418

Abb. 5: EP1258-00001 IP67 EtherCAT Box mit Chargennummer 22090101 und Seriennummer 158102

Abb. 6: EP1908-0002 IP76 EtherCAT Safety Box mit Chargennummer 071201FF und Seriennummer 00346070

Abb. 7: EL2904 IP20 Safety Klemme mit Chargennummer/DateCode 50110302 und Seriennummer 00331701


EL2521 - Einführung

Einkanalige Pulse-Train-Ausgangsklemme

Die Ausgangsklemme EL2521-0000 gibt eine vorgebbare Pulsfolge über zwei RS422-kompatible Differenzausgänge aus. Der Zusammenhang zwischen Kanal A und B ist einstellbar, z.B. als Encoder-Ausprägung. Die Pulszahl und die Frequenz wird durch einen 16 Bit Wert von der Steuerung vorgegeben. Die EtherCAT-Klemme zeigt ihren Signalzustand durch Leuchtdioden an. Die LEDs sind mit den Ausgängen getaktet und zeigen jeweils einen aktiven Ausgang an. Die galvanische Trennung vom E-Bus ist gegeben.

Als EL2521-0024 sind die beiden Ausgabekanäle als potentialfreie FET-Schalter ausgeführt und können extern gespeist werden.
Bei der EL2521-0025 sind die beiden Ausgabekanäle negativ schaltende potentialfreie FET-Schalter und können ebenfalls extern gespeist werden. Beachten Sie die Logikumkehr in der Ansteuerung. Als weitere Variante dieser Ausführung ist die EL2521-0124 mit einem Latch-Eingang und einem 24 V-Ausgang ausgestattet.

Quick-Links

• EtherCAT Funktionsgrundlagen
• Inbetriebnahme
• CoE-Beschreibung EL2521-00xx - normaler Modus
• CoE-Beschreibung EL2521-00xx - erweiteter Modus
• CoE-Beschreibung EL2521-0124
• Prozessdaten und Betriebsmodi


EL2521 - Technische Daten

Technische Daten | EL2521-0000 | EL2521-0024 | EL2521-0124 | EL2521-0025
Digitale Ausgänge | 1 Kanal (2 Differenzausgänge A, B) | 1 Kanal (2 potentialfreie FET-Ausgänge) | 1 Kanal (2 FET-Ausgänge) 1 x 24 V-Ausgang | 1 Kanal (2 potentialfreie FET-Ausgänge), negativ schaltend
Digitale Eingänge | 2 (+T, +Z) |  | 1 x Latch-Eingang (5..24 VDC) | 2 (+T, +Z)
Signalspannung | RS422-Pegel | 5..24 V DC, externe Speisung | 24 V DC, externe Speisung | 5..24 V DC, externe Speisung
Lastart | RS422 und Optokoppler, min. 220 Ω | beliebig
Ausgangsstrom max. (je Kanal) | 50 mA, RS422-Spezifikation | max. 1 A
Schaltschwelle "T" und "Z" Eingänge | High: >5 V (max. 24 VDC), Low: <1 V
Grundfrequenz | 0 ... 500 kHz, Default: 50 kHz
Auflösung | max. 15 Bit
Schrittweite | 10 mHz
Spannungsversorgung für interne E-Bus-Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 280 mA (lastabhängig)
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Bitbreite im Prozessabbild | def. 16 Bit Data in, 16 Bit Data out, 16 Bit Control, 16 Bit Status
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 55 g
Zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
Zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Start

Zur Inbetriebsetzung:

  • montieren Sie den EL2521 wie im Kapitel Montage und Verdrahtung beschrieben
  • konfigurieren Sie den EL2521 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


EtherCAT - EtherCAT Grundlagen

BECKHOFF EtherCAT: Grundlagen der Kommunikation

EtherCAT Grundlagen

Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung

BECKHOFF EtherCAT: Grundlagen der Kommunikation

EtherCAT-Verkabelung - Drahtgebunden

Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.

Kabel und Steckverbinder

Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.

EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.

Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -

Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.

Hinweis 		Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!

E-Bus-Versorgung

Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9400) zu setzen.

Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.

Abb. 1: Systemmanager Stromberechnung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT - Allgemeone Hinweise zur Watchdogeinstellung

BECKHOFF EtherCAT: Grundlagen der Kommunikation

Allgemeine Hinweise zur Watchdog-Einstellung

Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.

Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:

  • SM-Watchdog (default: 100 ms)
  • PDI-Watchdog (default: 100 ms)

SM-Watchdog (SyncManagerWatchdog)

Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.

Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.

PDI-Watchdog (Process Data Watchdog)

Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.

Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.

Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:

Abb. 1 Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog

Anmerkungen:

  • der Multiplier ist für beide Watchdogs gültig.
  • jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
  • Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
    Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.

Multiplier

Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:

1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)

Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.

Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.

Beispiel "Set SM-Watchdog"

Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.

Berechnung

Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit

VORSICHT 		VORSICHT! Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016.
In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.

VORSICHT 		VORSICHT! Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs!
Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.


EtherCAT State Machine

Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.

Es werden folgende Zustände unterschieden:

  • Init
  • Pre-Operational
  • Safe-Operational und
  • Operational
  • Boot

Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.

Init

Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init . Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.

Pre-Operational (Pre-Op)

Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.

Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.

Safe-Operational (Safe-Op)

Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).

Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.

Hinweis 		Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS.

Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.

Operational (Op)

Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.

Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.

Boot

Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.

Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Inhaltsverzeichnis
• Allgemeine Beschreibung
• Datenerhaltung
• Online/Offline Verzeichnis
• Kanalweise Ordnung

Allgemeine Beschreibung

Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.

CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.

Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.

Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind

  • Index: 0...65535
  • SubIndex: 0...255

Üblicherweise wird ein so lokalisierter Parameter geschrieben als x8010:07 mit voranstehendem "x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.

Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind

  • x1000: hier sind feste Identitäts-Information zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
  • x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.

Weitere wichtige Bereiche sind:

  • x4000: hier liegen in manchen EtherCAT-Geräte alternativ zum x8000-Bereich die Kanalparameter.
  • x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
  • x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)

Hinweis 		Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen.
Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..

Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:

Abb. 1: Karteireiter "CoE-Online "

In Abb. 1 sind die im Gerät "EL2502" verfügbaren CoE-Objekte von x1000 bis x1600 zusehen, die Subindizes von x1018 sind aufgeklappt.

Datenerhaltung

Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen

  • über den Systemmanager (Abb. 1) durch Anklicken
    Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
  • aus der Steuerung/PLC über ADS z.B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
    Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein Systemmanager bzw. Bedienpersonal zur Verfügung steht.

Hinweis 		Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D.h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.

Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.

  • Funktion wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
    Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
  • Funktion wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.

Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten in dieser Dokumentation zu entnehmen.

StartUp-Liste

Hinweis 		Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.

Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.

Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern

  • gewünschte Änderung im Systemmanager vornehmen
    Werte werden lokal im EtherCAT Slave gespeichert
  • wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
    Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.

Abb. 2: StartUp-Liste im TwinCAT System Manager

In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.

Online/Offline Verzeichnis

Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.

In beiden Fällen ist ein CoE-verzeichnis nach Abb. 1 zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.

  • wenn der Slave offline ist
    - wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
    - wird in der Identität der konfigurierte Stand angezeigt
    - wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
    - ist ein rotes Offline zu sehen

    Abb. 3: Offline-Verzeichnis
  • wenn der Slave online ist
    - wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
    - wird die tatsächliche Identität angezeigt
    - wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
    - ist ein grünes Online zu sehen

    Abb. 4: Online-Verzeichnis

Kanalweise Ordnung

Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.

Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs x8000 sieht man dies deutlich:

  • Kanal 0: Parameterbereich x8000:00 ... x800F:255
  • Kanal 1: Parameterbereich x8010:00 ... x801F:255
  • Kanal 2: Parameterbereich x8020:00 ... x802F:255
  • ...

Allgemein wird dies geschrieben als x80n0.

Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
  • Einheit 1 ns
  • Nullpunkt 1.1.2000 00:00
  • Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
  • Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


ELxxxx, KLxxxx - Tragschienenmontage

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Tragschienenmontage

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Montage

Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:

  1. Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
  2. Auf der rechten Seite des Feldbuskoppler werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
    Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.

Hinweis 		Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein.
Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.

Demontage

Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:

  1. Ziehen Sie die Klemme an ihren orangefarbige Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
  2. Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.

Verbindungen innerhalb eines Busklemmenblocks

Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:

  • Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
  • Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.

Hinweis 		Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen.
Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.

PE-Powerkontakt

Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.

Achtung 		Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbraucher mit 230 V Nennspannung).

Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.

WARNUNG 		Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


ELxxxx, KLxxxx - Montagevorschriften erweiterte mechanische Belastbarkeit

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Zusätzliche Prüfungen

Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:

Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms

Zusätzliche Montagevorschriften

Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:

  • Jede Einbaulage ist zulässig
  • Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
  • Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
  • Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
    64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
  • Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
  • Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
  • Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
  • Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


KLxxxx, KSxxxx, ELxxxx, ESxxxx - Anschlusstechnik

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Anschlusstechnik

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!

Übersicht

Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:

  • Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
  • Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
  • Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.

Standardverdrahtung

Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und
integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.

Steckbare Verdrahtung

Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt.
Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.

Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.

Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.

Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.

Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.

High-Density-Klemmen (HD-Klemmen)

Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.

Hinweis 		Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.

Ultraschall-litzenverdichtete Leiter

Hinweis 		Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschall verschweißte) Leiter angeschlossen werden.
Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!

Verdrahtung

Klemmen für Standardverdrahtung ELxxxx / KLxxxx und Klemmen für stehende Verdrahtung ESxxxx / KSxxxx

Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm

High-Density-Klemmen ELx8xx, KLx8xx (HD)

Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässige Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.

Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm

Schirmung

Hinweis 		Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


KLxxxx, ELxxxx - Einbaulagen

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

Einbaulagen

Achtung 		Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt.

Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!

Optimale Einbaulage (Standard)

Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. 1). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.

Abb. 1: empfohlene Abstände bei Standard Einbaulage

Die Einhaltung der Abstände nach Abb. 1 wird empfohlen.

Weitere Einbaulagen

Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb 2.

Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.

Abb. 2: weitere Einbaulagen


Montage von passiven Klemmen

Hinweis 		Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus.
Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für Montage von passiven Klemmen (hell eingefärbt)

Beispiel 1: korrekte Konfiguration

Beispiel 2: inkorrekte Konfiguration


ATEX - Besondere Bedingungen

WARNUNG 		Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von
Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
  • Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu Berücksichtigungen!
  • Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
  • Beachten Sie beim Einsatz von Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
  • Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
  • Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Die Sicherung der Einspeiseklemmen KL92xx dürfen nur gewechselt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
  • Adresswahlschalter und ID-Switche dürfen nur eingestellt werden,
    wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!

Normen

Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:

  • EN 60079-0: 2006
  • EN 60079-15: 2005

Kennzeichnung

Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten tragen eine der folgenden Kennzeichnungen:

II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

oder

II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C

Seriennummer

Die Beckhoff-Feldbuskomponenten tragen eine Seriennummer, die wie folgt aufgebaut ist:

WW YY FF HH

WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 35 04 1B 01:

35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


EL2521 - Montage und Verdrahtung

BECKHOFF EL2521: Montage und Verdrahtung

EL2521 - LEDs und Anschlussbelegung

Anschlussbelegung

• EL2521-0000
• EL2521-0024
• EL2521-0124
• EL2521-0025

EL2521-0000

Abb. 1: Anschlussbelegung und Beschaltungsbeispiel EL2521-0000

EL2521-0024

Abb. 2: Anschlussbelegung und Beschaltungsbeispiel EL2521-0024

EL2521-0124

Abb. 3: Anschlussbelegung und Beschaltungsbeispiel EL2521-0124

Anschlussbelegung EL2521-0000, EL2521-0024

Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Output +A | 1 | Ausgang +A
Output +B | 2 | Ausgang +B
Input T | 3 | Eingang T
T.Z. GND/T.Z. Ref. GND | 4 | Signalmasse für die Ausgänge
Output -A | 5 | Ausgang -A
Output -B | 6 | Ausgang -B
Input Z | 7 | Eingang Z
Shield | 8 | Schirm

Anschlussbelegung EL2521-0124

Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Output +A | 1 | Ausgang +A
Output +B | 2 | Ausgang +B
Latch24 V | 3 | 24 V Latch-Eingang
Latch/Output GND Ref. GND | 4 | Signalmasse für die Ausgänge und für den Latch-Eingang
Output -A | 5 | Ausgang -A
Output -B | 6 | Ausgang -B
Output 24 V | 7 | 24 V Ausgang
Shield | 8 | Schirm

EL2521-0025

Abb. 4: Anschlussbelegung und Beschaltungsbeispiel EL2521-0025

Anschlussbelegung EL2521-0025

Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Output -A | 1 | Ausgang -A
Output -B | 2 | Ausgang -B
Input T | 3 | Eingang T
T.Z. GND/T.Z. Ref. GND | 4 | Signalmasse für die Ausgänge
Output +A | 5 | Ausgang +A
Output +B | 6 | Ausgang +B
Input Z | 7 | Eingang Z
Shield | 8 | Schirm

LEDs (EL2521-xxxx)

LED | Farbe | Bedeutung
Output A, B | grün | Die LED für den aktiven Frequenzausgang A oder B; kann bei hohen Frequenzen nur noch als Leuchten mit halber Helligkeit wahrgenommen werden
*Latch/Output 24 V | grün | Leuchtet bei anstehendem Signal
**Input T, Z | grün | Leuchtet bei anstehendem Signal
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flackernd/schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme

*) nur für EL2521-0124
**) nicht für EL2521-0124

Anschluss der Eingänge

Die optisch isolierten Eingänge sind mit einer Strombegrenzung vor Überlastung geschützt. Die Betriebsspannung kann ohne weitere externe Beschaltung im Bereich zwischen 5 V ... 24 VDC liegen. Der Anschluss GND ist die gemeinsame Masse der beiden Eingänge T und Z. Das Schaltbild zeigt die interne Schaltung der beiden Eingänge:

Abb. 5: Interne Schaltung der Eingänge T und Z

Anschluss der Ausgänge

Schaltungsbeispiele für den Ausgang A, sie gelten sinngemäß auch für Ausgang B.

EL2521-0000

Die Ausgänge A und B der EL2521 können in unterschiedlichen Anschlussarten benutzt werden. Ein integrierter DC/DC-Wandler versorgt die Ausgangsstufe beider Kanäle A und B mit einer galvanisch isolierten Spannung (5 V).
Anschluss an RS422-Receiver
Der Ausgang kann als RS422-Ausgang betrieben werden. Die Schaltung erzeugt die nötigen Differenzsignale.

Abb. 6: EL2521-0000 am RS422 Receiver

Anschluss an Optokoppler (ohne externe Versorgungsspannung)
Die Ausgänge können für den direkten Anschluss eines Optokopplers eingesetzt werden. Die Ausgangsstufe liefert den nötigen Ausgangsstrom mit einer internen Versorgungsspannung von 5 V.

Abb. 7: EL2521-0000, direkter Anschluss an einem Optokoppler

EL2521-0024, EL2521-0124

Der Betrieb mit externer Versorgungsspannung ist abhängig von der Hardware-Version der Klemme:
Anschluss an Optokoppler (mit externer Versorgungsspannung)
Zum Anschluss an Eingänge mit großen Eingangswiderständen kann bei der EL2521-0024 eine externe Versorgungsspannung (bis zu 24 V) genutzt werden um den erforderlichen Strom zu treiben.

Abb. 8: EL2521-0x24, Beschaltung mit externer Stromquelle

Achtung 		EL2521-0124 Massepotenzial
Bei der EL2521-0124 müssen die Ausgänge -A und -B mit der Signalmasse (Pin 4) verbunden werden, um eine Beschädigung der Klemme zu vermeiden (siehe Abb. 3)!

EL2521-0025

Achtung 		Logikumkehr bei der EL2521-0025
Beachten Sie beim Anschluss der EL2521-0025 die Logikumkehr bei der Beschaltung (siehe Abb. 4)!
Anschluss an Optokoppler (mit externer Versorgungsspannung)
Zum Anschluss an Eingänge mit großen Eingangswiderständen kann bei der EL2521-0025 eine externe Versorgungsspannung (bis zu 24 V) genutzt werden, um den erforderlichen Strom zu treiben. Durch die Logikumkehr ist die positive Spannung zum Treiben des Ausgangsstromes an Pin 5 bzw. Pin 6 anzuschließen.

Abb. 9: EL2521-0025, Beschaltung mit externer Stromquelle, Logikumkehr


Installation TwinCAT Realtime Treiber

Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.

Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.

Im Systemmanager ist über Options -> Show realtime Compatible Devices die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.

Abb. 1: Aufruf im Systemmanager

Abb. 2: Übersicht Netzwerkschnittstellen

Hier können nun Schnittstellen, die unter "Compatible devices" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.

Ein Windows-Warnhinweis bzgl. des unsignierten Treibers kann ignoriert werden.

Alternativ sind im Systemmanager über die EtherCAT-Eigenschaften die kompatiblen Ethernet Ports einsehbar.

Abb. 3: Eigenschaften EtherCAT Gerät

Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start --> Systemsteuerung --> Netzwerk)

Abb. 4: Windows-Eigenschaften der Netzwerkschnittstelle

Andere mögliche Einstellungen sind zu vermeiden:

Abb. 5: fehlerhafte Treiber-Einstellungen des Ethernet Ports

IP-Adresse des verwendeten Ports

Hinweis 		IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall , dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren.

Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält.

Als Adressraum empfiehlt sich z.B. 192.168.x.x.

Abb. 6 TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inhaltsverzeichnis
• Installation der neuesten ESI-Device-Description
• Geräteunterscheidung
• Online Description
• Fehlerhafte ESI-Datei

Installation der neuesten ESI-Device-Description

Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jew. Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.

Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen (Standardeinstellung TwinCAT 2: C:\TwinCAT\IO\EtherCAT). Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen wenn sie sich seit dem letzten Systemmanager-Fenster geändert haben.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.

Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Abb. 1: ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen.

Hinweis 		ESI
Zu den *.xml-Dateien gehören so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.

Geräteunterscheidung

EtherCAT Geräte/Slaves werden durch 4 Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Der Name "EL2521-0025-1018" setzt sich zusammen aus

  • Familienschlüssel "EL"
  • Typ/Name "2521-0025"
  • und Revision "1018"

Abb. 2: Aufbau Bezeichnung

Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.

Online Description

Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der Systemmanager ob er die im Gerät vorliegende Beschreibung verwenden soll. Der Systemmanager benötigt in jedem Fall diese Information um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.

Abb. 3: Hinweisfenster OnlineDescription, TwinCAT 2

In TwinCAT 3.x erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:

Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.

Achtung 		Veränderung der "üblichen" Konfiguration durch Scan
Für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind 2 Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019.
  • für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
  • für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
    Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.

Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Konfigurationsserstellung – Manuell“

Wird dennoch die Online Description verwendet, liest der Systemmanager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird der Weg über die ESI-Datei dringend empfohlen.

Der Systemmanager legt dann in seinem ESI-Verzeichns eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.

Abb. 4: vom Systemmanager angelegt OnlineDescription.xml

Wird daraufhin manuell ein Slave in die Konfiguration eingefügt, unterscheiden sich solchermaßen erstellte Slaves durch einen vorangestellten Pfeil, s. Abb. 5, EL2521.

Abb. 5: Pfeil kennzeichnet durch Online Description erfasste ESI

Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:

  • alle Systemmanagerfenster schließen
  • TwinCAT in Konfig-Mode neu starten
  • "OnlineDescription0000...xml" löschen
  • TwinCAT Systemmanager wieder öffnen

Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.

Hinweis 		OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

C:\User\[USERNAME]\AppData\Roaming\Beckhoff\TwinCAT3\Components\Base\EtherCATCache.xml

(Spracheinstellungen des Betriebssystems beachten!)

Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.

Fehlerhafte ESI-Datei

Liegt eine fehlerhafte ESI-Datei vor die vom Systemmanager nicht eingelesen werden kann, meldet dies der Systemmanager durch ein Hinweisfenster.

Abb. 6: Hinweisfenster fehlerhafte ESI-Datei

Ursachen dafür können sein

  • Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei --> prüfen Sie die Ihnen vorliegenden Schemata
  • Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden --> Es ist der Hersteller der Datei zu kontaktieren


Offline Konfigurationserstellung (Master: TwinCAT 2.x)

Inhaltsverzeichnis
• Unterscheidung Online/Offline
• Anlegen des Geräts EtherCAT
• Definieren von EtherCAT Slaves

Unterscheidung Online/Offline

Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.

Ist die vorgesehene Steuerung bereits an das EtherCAT-System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch so genanntes "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.

In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden.

Hinweis 		Installation der neuesten ESI-XML-Device-Description
Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT ) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT Builds aktuell war.

Ab. TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Zur Konfigurationserstellung muss

  • das Gerät EtherCAT im Systemmanager angelegt/definiert werden
  • die EtherCAT Slaves definiert werden

Anlegen des Geräts EtherCAT

In einem leeren Systemmanager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.

Abb. 1: Anfügen EtherCAT Device

Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.

Abb. 2: Auswahl EtherCAT Anschluss (TwinCAT 2.11)

Abb. 3: Auswahl EtherCAT Anschluss (TwinCAT 2.11 R2)

Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.

Abb. 4: Auswahl Ethernet Port

Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog (s. Abb. 5) gesetzt/geändert werden.

Abb. 5: Eigenschaftendialog EtherCAT

Hinweis 		Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden.

Siehe dazu die entsprechende Installationsseite.

Definieren von EtherCAT Slaves

Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.

Abb. 6: Anfügen von EtherCAT Geräten

Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.

Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. 7, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. 7 nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.

Übersicht Übertragungsphysik

  • "Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
  • "E-Bus": LVDS "Klemmenbus": EL/ES-Klemmen, diverse anreihbare Module

Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11).

Abb. 7: Auswahldialog neues EtherCAT Gerät

Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.

Abb. 8: Anzeige Geräte-Revision

Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z.B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. 7) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibung vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. 9.

Abb. 9: Anzeige vorhergehender Revisionen

Hinweis 		Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).

Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.

Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.

Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...

Abb. 10: EtherCAT Klemme im TwinCAT-Baum


Online Konfigurationserstellung "Scannen" (Master: TwinCAT 2.x)

Inhaltsverzeichnis
• Unterscheidung Online/Offline
• Erkennen/Scan des Geräts EtherCAT
• Erkennen/Scan der EtherCAT Teilnehmer
• Problembehandlung
• Scan über bestehender Konfiguration

• Change to compatible device
• Change to Alternative Type

Unterscheidung Online/Offline

Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.

Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.

In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden.

Hinweis 		Installation der neuesten ESI-XML-Device-Description
Der TwinCAT EtherCAT Master/Systemmanager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.

Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT (Standardeinstellung: C:\TwinCAT\IO\EtherCAT ) abzulegen. Beim Öffnen eines neuen Systemmanager-Fensters werden die Dateien einmalig eingelesen.

TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT Builds aktuell war.

Ab. TwinCAT 2.11 kann aus dem Systemmanager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist (Options -> "Update EtherCAT Device Descriptions")

Zur Konfigurationserstellung

  • muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
  • müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
  • müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
  • muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.

Der Online-Scan-Vorgang setzt sich zusammen aus

  • Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
  • Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
  • Problembehandlung

Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.

Erkennen/Scan des Geräts EtherCAT

Befindet sich das TwinCAT-System im CONFIG-Modus (TwinCAT Icon blau bzw. blaue Anzeige im Systemmanager) kann online nach Geräten gesucht werden.

Abb. 1: TwinCAT Anzeige CONFIG-Modus

Hinweis 		Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich.

Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten. Das TwinCAT-Icon neben der Windows-Uhr stellt immer den TwinCAT-Modus des lokalen IPC dar. Im Systemmanager-Fenster wird dagegen der TwinCAT-Zustand des Zielsystems gezeigt.

Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.

Abb. 2: Scan Devices

Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.

Abb. 3: Hinweis automatischer GeräteScan

Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.

Abb. 4: erkannte Ethernet-Geräte

Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. 5.

Hinweis 		Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden.

Siehe dazu die entsprechende Installationsseite.

Erkennen/Scan der EtherCAT Teilnehmer

Hinweis 		Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.

Achtung 		Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug um für eine Inbetriebnahme ein Erst-Konfiguration als Arbeitsgrundlage zu erzeugen.

Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.

Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.

Beispiel:

Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitze dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:

Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwiNCAT3-Solution-Dateien).

Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.

Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.

Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:

Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwiNCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).

Dazu kommt, dass durch durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.

→ bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!

Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.

Abb. 5: Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes

Abb. 6: manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device

Im Systemmanager kann der Scan-Ablauf am Ladebalken am unteren Bildschirmrand verfolgt werden.

Abb. 7: Scanfortschritt

Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.

Abb. 8: Abfrage Config/FreeRun

Im Config/FreeRun-Mode wechselt die Systemmanager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.

Abb. 9: Anzeige Config/FreeRun

Hinweis 		Hinweis Config/FreeRun
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden

Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. 10 befinden.

Abb. 10: beispielhafte Online-Anzeige

Zu Beachten sind

  • alle Slaves sollen im OP-State sein
  • der EtherCAT Master soll im "Actual State" OP sein
  • "Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
  • es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten

Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.

Problembehandlung

Beim Scannen können verschiedene Effekte auftreten.

  • es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
    In diesem Fall bietet der Systemmanager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
  • Teilnehmer werden nicht richtig erkannt
    Ursachen können sein
    - fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
    - Slave hat ungültige Gerätebeschreibung
    Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z.B. durch den Emergency Scan.
    Der Scan ist dann erneut vorzunehmen.

  • Abb. 11: fehlerhafte Erkennung

    Im Systemmanager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.

Scan über bestehender Konfiguration

Achtung 		Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen!
Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.

Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.

Abb. 12: identische Konfiguration

Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.

Abb. 13: Korrekturdialog

Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.

Farbe | Erläuterung
grün | Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.

Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Geräte nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.

hellblau | Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
  • Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
  • Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
    Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.

    Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Geräte nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.

Hinweis 		Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/Boxen ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).

Beispiel: In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.

Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.

Abb. 14: Korrekturdialog mit Änderungen

Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.

Change to compatible device

Der TwinCAT Systemmanager biete eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task: Change to compatible device.

Abb. 15: TwinCAT 2 Dialog ChangeToCompatibleDevice

Diese Funktion ist vorzugsweise auf AX5000-Geräten anzuwenden. Wenn aufgerufen, schlägt der Systemmanager die Geräte vor die er im zugehörigen Unterordner findet, beim AX5000 z.B. in \TwiNCAT\IO\EtherCAT\Beckhoff AX5xxx.

Change to Alternative Type

Der TwinCAT Systemmanager biete eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type

Abb. 16: TwinCAT 2 Dialog ChangeToCompatibleDevice

Wenn aufgerufen, sucht der Systemmanager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


Standard-Verhalten EtherCAT Master

BECKHOFF EtherCAT: EtherCAT-Grundlagen

Prozessdaten Einstellungen EtherCAT Slave (PDO)

Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (Process Data Objects, PDO) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.

Für Beckhoff EtherCAT Slaves EL/ES gilt im Allgemeinen:

  • Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
  • Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
    Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
  • Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch den erfolgreichen Hochlauf des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.

Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. 1.

  • A: Wählen Sie das zu konfigurierende Gerät
  • B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
  • D: die PDOs können an- bzw. abgewählt werden
  • H: die neuen Prozessdaten sind als verlinkbare Variablen im Systemmanager sichtbar
    Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
  • E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ( "predefined PDO-settings") verändert werden.

Abb. 1: Konfigurieren der Prozessdaten

Hinweis 		Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. 1, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit").

Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden.

Dies gilt im Allgemeinen auch für den Fall, dass eine Gerät den Download der PDO Konfiguration "G" unterstützt.

Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben:

Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.


Konfiguration

BECKHOFF EtherCAT: Konfiguration der Klemmen

Konfiguration mit dem TwinCAT System Manager

(Mit TwinCAT ab Version 2.10.0 (Build 1241), am Beispiel der EL5001 ab Firmware-Stand 0.7)

Klicken Sie im linken Fenster des TwinCAT System Managers auf den Baumzweig der Klemme die Sie konfigurieren möchten (im Beispiel: Klemme 6 EL5001).

Im rechten Fenster des TwinCAT System Managers stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung.

Karteireiter Allgemein

Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.

Karteireiter EtherCAT

Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem Anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.

Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.

Karteireiter Prozessdaten

Zeigt die Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.

Sync-Manager

Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.

Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.

PDO-Zuordnung

PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Type definierten PDOs aufgelistet:

  • Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
  • Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.

Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung das System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, das dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.

Hinweis 		Aktivierung der PDO-Zuordnung
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
  • der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
  • der System-Manager die EtherCAT-Slaves neu laden (Schaltfläche [image])

PDO-Liste

Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.

Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.

PDO-Inhalt

Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.

Download

Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.

PDO-Zuordnung

Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.

PDO-Konfiguration

Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.

Karteireiter Startup

Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiter können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in der selben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.

Spalte | Beschreibung
Transition Übergang, in den der Request gesendet wird. Dies kann entweder
  • der Übergang von Pre-Operational to Safe-Operational (PS) oder
  • der Übergang von Safe-Operational to Operational (SO) sein.

Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll | Art des Mailbox-Protokolls
Index | Index des Objekts
Data | Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar | Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.

Karteireiter CoE - Online

Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.

Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.

Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.

Karteireiter Online

Status Maschine

Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.

DLL-Status

Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:

Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.

File Access over EtherCAT

Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.


Allgemeine Hinweise - EtherCAT Slave Anwendung

BECKHOFF: Inbetriebnahme

Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inhaltsverzeichnis
• Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
• CoE - Parameterverzeichnis
• Inbetriebnahmehilfe im TwinCAT System Manager
• EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
• Hinweis Ebus Strom

In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fhttp://www.beckhoff.de/german/download/ethercat.htm#SystemDescriptionSystemDescription"> EtherCAT-Systemdokumentation zu entnehmen.

Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status

Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.

Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.

Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.

EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im folgenden besprochen.

Abb. 1: Auswahl an Diagnoseinformationen eines EtherCAT Slave

Im Allgemeinen verfügt ein EtherCAT Slave über

  • slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
    Diese Diagnose ist für alle Slaves gleich.

    als auch über
  • kanal-typische Funktionsdiagnose (geräteabhängig)
    Siehe entsprechende Gerätedokumentation

Die Farbgebung in Abb. 1 entspricht auch den Variablenfarben im System Manager, siehe Abb. 2.

Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.

In Abb. 2. ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.

Abb. 2: grundlegende EtherCAT Slave Diagnose in der PLC

Dabei werden folgende Aspekte abgedeckt:

Kennzeichen Funktion Ausprägung Anwendung/Auswertung
A Diagnoseinformationen des EtherCAT Master

zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).

Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.

Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:

  • CoE im Master zur Kommunikation mit/über die Slaves
  • Funktionen aus TcEtherCAT.lib
  • OnlineScan durchführen
B Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln. Status
  • die Bitdeutungen sind der Gerätedokumentation zu entnehmen
  • andere Geräte können mehr oder keine slavetypischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
  1. am EtherCAT Slave als auch inhaltsidentisch
  2. als Sammelvariable am EtherCAT Master (siehe Punkt A)

zur Verlinkung bereitgestellt.

WcState (Working Counter)

0: gültige Echtzeitkommunikation im letzten Zyklus

1: ungültige Echtzeitkommuniktion

ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen

Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
  • nur selten/nie verändert werden, außer beim Systemstart
  • selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State

aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.

AdsAddr

Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.

Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.

Achtung 		Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.

CoE-Parameterverzeichnis

Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. 3:

Abb. 3: EL3102, CoE-Verzeichnis

Hinweis 		EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung ihttp://www.beckhoff.de/german/download/ethercat.htm#SystemDescription"> EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!

Einige Hinweise daraus in Kürze:

  • Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
  • Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.

Inbetriebnahmehilfe im TwinCAT System Manager

In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.

Abb. 4: Beispiel Inbetriebnahmehilfe für eine EL3204

Diese Inbetriebnahme verwaltet zugleich

  • CoE-Parameterverzeichnis
  • DC/FreeRun-Modus
  • die verfügbaren Prozessdatensätze (PDO)

Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.

Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, könne vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.

EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung

Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati

  • INIT
  • PREOP
  • SAFEOP
  • OP

zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.

Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.

Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.

Standardeinstellung

Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:

  • EtherCAT Master: OP
  • Slaves: OP
    Diese Einstellung gilt für alle Slaves zugleich.

Abb. 5: Default Verhalten System Manager

Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.

Abb. 6: Default Zielzustand im Slave

Manuelle Führung

Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.

  • aus Diagnosegründen
  • kontrolliertes Wiederanfahren von Achsen
  • ein zeitlich verändertes Startverhalten ist gewünscht

Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.

Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.

Abb. 7: PLC-Bausteine

Hinweis Ebus Strom

EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.

Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.

Abb. 8: unzulässige Überschreitung E-Bus Strom

Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:

Abb. 9: Warnmeldung E-Bus-Überschreitung

Achtung 		Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EL2521 - Grundlagen zur Funktion

BECKHOFF EL2521: Produktübersicht

Grundlagen zur Funktion

Inhaltsverzeichnis
• Betriebsmodi der EL2521

• Auslieferungszustand
• Betriebsartenwahl und Ausgabemuster
• Rampenfunktion
• Auflösung
• Fahrwegsteuerung
• Relative Daten
• Direkte Daten
• Distributed Clocks (DC)
• Code Word
• Hinweise zur EL2521-0124

Betriebsmodi der EL2521

Durch die Weiterentwicklung der EL2521 ist ein erweiterter Betriebmodus (ab Firmware 03 / Hardware 02) verfügbar, der in Abhängigkeit der vorliegenden Hardware im TwinCAT Systemmanager parametriert werden kann.

Eine EL2521 in älterer Ausführung unterstützt diesen erweiterten Betriebsmodus nicht!

Version | PDO settings | FW/HW | ESI | Prozessdaten | CoE-Parameter
normaler Betriebsmodus | Legacy (MDP 252) | bis 02/01 | ab EL2521-0000-0000 | Eingangsprozessdaten (Counter value) in CoE-Objekt 6000 Ausgangsprozessdaten (Frequncy value) in CoE-Objekt 7000 PDO-Zuordnung in 1A00, 1600 | Feature Bits und Settings in CoE-Objekten 8000, 8001 und 8800
erweiterter Betriebsmodus | Standard 16 Bit (MDP 253/511) Standard 32 Bit (MDP 253/511) | ab 03/02 | ab EL2521-0000-1016 | Änderungen zum normalen Betriebsmodus Unterstützung Distributed Clocks Inputs / Outputs in CoE-Objekt 6010 / 7010 Inputs / Outputs in CoE-Objekt 6020 / 7020 PDO-Zuordnung in 1A01, 1A02, 1A05 bzw. 1601, 1602, 1604, 1605, 1607 | Feature Bits und Settings in CoE-Objekt 8010

Durch die PDO-Selektion wird festgelegt, in welchem Betriebsmodus die EL2521-xxxx arbeiten soll:

Abb. 1: predefined PDO-Auswahl im TwinCAT Systemmanager

Unabhängig vom Hardware /Firmware -Stand meldet sich eine neu im System integrierte EL2521 im normalen Betriebsmodus (siehe auch Kapitel Prozessdaten, Auslieferungszustand)

Bei der Inbetriebnahme ist zu entscheiden, in welchen Betriebsmodus die EL2521 gesetzt werden soll. Dies ist von der gewünschten Konfiguration und natürlich der vorliegenden Hardware-Ausführung abhängig - eine Klemme mit Stand vor Firmware 03 / Hardware 02 wird beispielsweise keine Konfiguration im erweiterten Betriebmodus unterstützen, da die entsprechenden Objekte nicht vorhanden sind.

Hinweis 		Kompatibilität im Servicefall
Eine im erweiterten Betriebsmodus eingesetzte und projektierte EL2521 kann nicht durch eine EL2521 mit älterem Hardwarestand (< 03) ausgetauscht werden!

Hinweis 		Überwachung der Prozessdaten
Es wird empfohlen, folgende Prozessdaten in jedem Zyklus zu überwachen:
  • WcState: wenn ≠ 0, dann nimmt dieser EtherCAT Teilnehmer nicht am Prozessdatenverkehr teil
  • State: wenn ≠ 8, dann ist der EtherCAT Teilnehmer nicht im OP (Operational) Status
  • TxPDO State, SyncError: wenn ≠ 0, dann liegen keine gültigen Prozessdaten vor, z.B. durch Drahtbruch
  • TxPDO Toggle: wenn dieses Bit toggelt, liegt ein neuer Satz Prozessdaten vor

Eingangsimpedanz EL2521

Die Signalquelle muss die Eingangsimpedanz der EL2521 (typ. 220Ω, Änderungen vorbehalten) mit ausreichenden Spannungspegeln nach RS422 betreiben können.

Auslieferungszustand

Der Auslieferungszustand der EL2521 ist die Betriebsart Frequenzmodulation mit einer Grundfrequenz von 50 KHz und einer Auflösung von 15 Bit.

Zum Test im Auslieferungszustand, PDO-Setting Standard 16 Bit kann einfach die Ausgangsfrequenz auf >0 gesetzt werden, dann beginnt die EL2521-xxxx Signale auszugeben.

Die Anzahl der ausgegebenen Pulse wird in einem 16-Bit Register zurück gelesen. Der Zähler läuft mit Meldung an die Steuerung über, dies wird durch Status-Wort SW.3 bzw. Index 6020:05, Überlauf bzw. SW.2 bzw. Index 6020:04 (Unterlauf) angezeigt. Parallel zu diesen beiden Bits wird SW.6 bzw. Index 6010:07 als allgemeines Fehlerbit gesetzt. Die Erweiterung auf mehr als 16 Bit in der Steuerungssoftware wird dadurch erleichtert. Der Überlauf kann des weiteren aus dem Diagnose-Objekt A000:01 ausgelesen werden (interne 32-Bit Erweiterung). Der Zähler kann durch Bit 5 im Control-Wort (CW.5) gelöscht werden. Das Löschen des Zählers erfolgt im Auslieferungszustand bei steigender Flanke (Feature Bit in Index 8000:05 gesetzt), bei Feature Bit in Index 8000:05 = 0 ist diese Funktion pegelgesteuert. Ist das Feature Bit in Index 8000:0B = 1 wird durch Bit 5 im Control-Wort (CW.5) der Zähler auf einen in Index 8800:01 vorgegebenen Wert gesetzt.

Betriebsartenwahl und Ausgabemuster

Die EL2521 kann neben der Betriebsart FM (Frequenz-Modulation, Index 8000:0E bzw. 8010:0E = 0dez) auch zur Schrittmotoransteuerung mit Puls-Richtungsvorgabe (Frq-Cnt-Impuls-Modus, Index 8000:0E bzw. 8010:0E = 1dez) genutzt werden. Eine weitere Betriebsart ist die Inkrementalgeber Simulation (Index 8000:0E bzw. 8010:0E = 2dez). Der direkte Anschluss eines Inkrementalenkoders ist möglich, wie sie bei vielen Servoverstärkern und Frequenzumrichtern als Eingang vorhanden sind. Das Pulsmuster wird über die Kanäle A und B ausgegeben. Über das Feature-Objekt 8000:0E bzw. 8010:0E ist eine Konfiguration der benötigten Betriebsart möglich. Die Betriebsarten unterscheiden sich grundsätzlich durch positive Logik Mode 0, 1, 2 und negative Logik Mode 4, 5, 6. Die Negativ-Logik lässt sich mit Index 8000:0F bzw. 8010:10 aktivieren. Die Betriebsarten 2 und 6 simulieren einen Inkrementalenkoder und ermöglichen den direkten Anschluss einer Auswerteeinheit, dazu gehört auch ein Servoverstärker oder ein Frequenzumrichter mit Inkrementalenkoder-Eingang.
Betriebsmodus | Funktion
 | Rechtslauf Linkslauf
Frequenzmodulation positive Logik (BA0) |
Puls-Richtungsvorgabe positive Logik (BA1) |
Inkrementalenkoder positive Logik (BA2) |
Frequenzmodulation negative Logik (BA4) |
Puls-Richtungsvorgabe negative Logik (BA5) |
Inkrementalenkoder negative Logik (BA6) |

Rampenfunktion

Eine interne Rampenfunktion erhöht / erniedrigt die aktuelle Frequenz bis zur voreingestellten Maximalfrequenz mit den voreingestellten Parametern in Index 8800:02, sie wird durch den Index 8000:06 bzw. 8010:06 aktiviert.

Hinweis 		CoE-Parameter
Je nach Betriebsart normal oder erweitert sind die Parameter aus den Objekten 8000, 8001, 8800 oder 8010 zu verwenden.

Durch Index 8000:07 bzw. 8010:07 kann die Rampen-Basis-Frequenz gewählt werden. Bit 1 vom Status-Wort (SW.1) bzw. Index 6010:02 ist gesetzt, wenn eine Rampe durchfahren wird. Die Deaktivierung dieser Funktion, welches im laufenden Betrieb auch über CW.1 bzw. Index 7010:02 geschehen kann, bewirkt die Freischaltung von CW.0 bzw. Index 7010:01. Hiermit kann der Anwender im Betrieb schnell die Grundfrequenz ändern, bei CW.0 bzw. Index 7010:01 = 1 (Bestätigung durch SW.0 bzw. Index 6010:01) wird der Grundfrequenzwert 2 im Objekt 8001:03 bzw. 8010:13 verwendet anstatt des Grundfrequenzwertes 1 im Objekt 8001:02 bzw. 8010:12 (CW.0 bzw. Index 7010:01 = 0). Die Eingangs-Signale T und Z werden von der Klemme im Status-Wort (SW.4 / SW.5) bzw. Index 6010:05 / 6010:06 direkt an die Steuerung übertragen . Es findet keine interne Vorverarbeitung der Signale statt.
Die Klemme bietet die Möglichkeit des sanften Hoch-/Herunterfahren. Durch Index 8001:04 bzw. 8010:14 kann die Rampensteilheit für das Hochfahren mit einer Genauigkeit von 10 bzw. 1000 Hz/Sec (Index 8000:07 bzw. 8010:07) eingestellt werden. Index 8001:05 bzw. 8010:15 hat die gleiche Funktion für das Herunterfahren. Das Prozessdatum kann während einer Rampenfahrt (CW.2 bzw. Index 7010:03) geändert werden, die Klemme nimmt dann den neuen Wert als Zielfrequenz.

Auflösung

Die Grundfrequenzen werden mit einer Auflösung von 1 Hz pro Bit vorgegeben (Grundfrequenz 1: Index 8001:02 oder 8010:12 bzw. Grundfrequenz 2: Index 8001:03 bzw. 8010:13). Die Klemme arbeitet intern bei 16 MHz mit einer Auflösung von 32 Bit. Das entspricht einer theoretischen minimalen Schrittweite von 0,0037 Hz/Schritt über den gesamten Frequenzbereich. Über die Ausgangsstufe kann eine Frequenz von maximal 500 kHz ausgegeben werden.

Fahrwegsteuerung

Die Funktion Fahrwegsteuerung ist im normalen und auch im erweiterten Betriebsmodus verfügbar. Dabei werden, ausgehend vom aktuellen Zählerstand, ein Ziel-Zählerstand automatisch angefahren und die entsprechenden Pegel an den Ausgängen ausgegeben. Die Ausgabefrequenz verändert sich dabei je nach aktuellem Zählerstand. Ist der vorgegebene Zählerstand erreicht, schaltet die Klemme die Frequenz auf Null.

Der Ablauf ist dabei durch mehrere Faktoren bestimmt, siehe Abb. 2. Vor dem Parametrieren der Fahrwegsteuerung empfiehlt sich ein CoE-Reset "Wiederherstellen des Auslieferungszustandes" um Seiteneffekte auszuschließen.

Der Ablauf und die zugehörigen Parameter sind in nachfolgender Tabelle aufgeführt, im erweiterten Betriebmodus liegen einige der Parameter nicht mehr im CoE, sondern sind als Prozessdaten verlinkbar.

Phase |  | normaler Betriebsmodus | erweiterter Betriebsmodus
Parametrierung | Fahrwegsteuerung aktivieren | 8000:0A = TRUE | 8010:0A = TRUE
 | Rampengrundfrequenz (10 Hz / 1 kHz) | 8000:07 = ? | 8010:07 = ?
 | Rampenzeit-Konstante "steigend" t1 [Δ/sec] | 8001:04 = ? | 8010:14 = ?
 | maximale Fahrfrequenz f1 | 8800:02 = ? | ---
 | Rampenzeit-Konstante "fallend" t3 [Δ/sec] (> 1.1 * Rampenzeit-Konstante t1 !) | 8001:05 = ? | 8010:15 = ?
 | Auslauffrequenz f2 | 8001:07 = ? | 8010:17 = ?
Fahrt | Zielposition angeben | 8800:01 = ? | PDO: TargetCounterValue = ?
 | Fahrt Start | CW.2 = TRUE | PDO: Control.GoCounter = TRUE
 | maximale Fahrfrequenz f1 | --- | PDO: FrequencyValue <> 0
Rückstellen |  | CW.2 = FALSE | PDO: FrequencyValue = 0
 |  |  | PDO: Control.GoCounter = FALSE

Bei Fahrwegsteuerung im erweiterten Betriebsmodus muss das Bit „Go counter“ gleichzeitig, oder vor Angabe des „Frequency value“ gesetzt sein. Ist das Bit „Go counter“ nicht gesetzt und der „Frequency value“ ist ungleich 0, dann ist die Fahrwegsteuerung NICHT aktiv und es werden bereits Takte ausgegeben!

Hinweis 		Rampenzeitkonstante
Die "reale" Rampenzeit ergibt sich aus der Multiplikation der Rampengrundfrequenz mit der der steigenden/fallenden Rampenzeit-Konstante.

Hinweis 		Steilheit der fallenden Rampe
Vorraussetzung für eine exakte Zielfahrt ist, dass die Zeitkonstante der fallenden Rampe um einen gewissen Faktor größer ist als die der steigenden Rampe. Dies ist erforderlich, damit die Auslauf-Frequenz vor dem Endzählerstand erreicht wird und die Klemme nicht mit voller Geschwindigkeit auf den Endpunkt fährt.
Zu Erläuterung: Die EL2521 berechnet aus der Zeit t1 und der Anzahl der gefahrenen Schritte die noch zu fahrenden Schritte in der Zeit t2 . Die Berechnung geht für das Herunterfahren von der gleichen Anzahl von Schritten aus wie für das ermittelte Herauffahren. Der Herunterfahrrampe muss etwas steiler sein, ca. 10%, damit es möglich ist in der verbleibenden Zeit t3 + t4 + t5 das Ziel exakt zu erreichen. Dieser Zusammenhang verändert sich mit der maximalen Frequenz.

Abb. 2: Phasen der Fahrwegsteuerung

Als Beispiel seihier die Aufzeichnung einer kurzen realen Fahrwegrampe gegeben, dazu das dazu verwendete Beispielprogramm [image] . Die kurze Schrittkette setzt den aktuellen Zählerstand auf 0 zurück und fährt dann die Zielposition 65 an. Im Systemmanager-File wird die EL2521-xxxx über StartUp-Parameter auf die für dieses Beispiel passenden CoE-Werte gesetzt.

Abb. 3: Beispielprogramm Fahrwegsteuerung

Das Resultat ist die Ausgabe einer variablen Frequnez bis auf die Zieposition 65.

Abb. 4: Oszilloskop-Aufzeichnung der Pulsfolge

Relative Daten

Die Ausgabefrequenz richtet sich nach der eingestellten Grundfrequenz in den Objekten 8001:02 bzw. 8010:12 bis 8001:03 bzw. 8010:13 und dem Prozessdatum (siehe Tabelle).

Beispiel:

Ausgabefrequenz = Grundfrequenz x Prozessdaten / 32767
größte Auflösung = 125 mHz

Grundfrequenz = 100.000 Hz (maximale gewählte Ausgabefrequenz)
Prozessdaten = 0x00FF (255dez)
Ausgabefrequenz = 778,22 Hz
Prozessdatum |  | Ausgabewert
 | 0x0000 (0dez) | 0% DC
 | 0x3FFF (16383dez) | 50% der Grundfrequenz, Rechtslauf
 | 0x7FFF (32767dez) | 100% der Grundfrequenz, Rechtslauf
2er Komplement | 0xC000 (-16384dez) | 50% der Grundfrequenz, Linkslauf
 | 0x8000 (-32768dez) | 100% der Grundfrequenz, Linkslauf
Betrag-Vorzeichendarstellung | 0xBFFF (-16383dez) | 50% der Grundfrequenz, Linkslauf
 | 0xFFFF (-32767dez) | 100% der Grundfrequenz, Linkslauf

Direkte Daten

Es besteht die Möglichkeit der direkten Eingabe der Frequenz (Objekt 8000:08 bzw. 8010:08). Hier werden die Prozessdaten mit dem Faktor aus Objekt 8001:06 bzw. 8010:16 multipliziert und direkt in den Synthese-Chip geschrieben.

Beispiel:

Ausgabefrequenz = Frequenz-Faktor x Prozessdaten x 10 mHz
größte Auflösung = 10 mHz

Frequenz-Faktor = 100
Prozessdaten = 0x00FF (255dez)
Ausgabefrequenz = 25 Hz

Distributed Clocks (DC)

Hinweis 		EtherCAT und Distributed Clocks
Auf der Beckhoff Website können Sie eine grundlegende Einführung in das Thema EtherCAT und Distributed Clocks herunterladen: die "Systembeschreibung Distributed Clocks".

Die EL2521 unterstützt die Distributed-Clocks-Funktionalität. Damit die EL2521 die aktuellen Prozessdaten rechtzeitig vor Ankunft des abfragenden EtherCAT-Datagrams verarbeiten kann, muss ein entsprechendes Signal klemmenintern zyklisch generiert werden. Dieses Signal kann in der EL2521 durch 2 Ereignisse ausgelöst werden: Den SyncManager (SM) und die Distributed Clock (DC). In der Betriebsartenwahl (s. Abb. 2) stehen zur Auswahl

  • FreeRun/SM-synchron
    Das SyncManager-Ereignis tritt ein, wenn ein EtherCAT-Frame Prozessdaten mit der EL2521 erfolgreich austauscht. Frame-getriggert werden so zyklisch die aktuellen Prozessdaten verarbeitet, allerdings mit dem geringen zeitlichen Jitter des Ethernet-Frames.
  • DC-synchron
    In der Betriebsart DC wird die Prozessdatenverarbeitung zyklisch konstant durch die integrierte DC-Einheit ausgelöst, standardmäßig im Gleichtakt mit dem Buszyklus. Durch die gleichmäßigere Abfrage kann z.B. ein übergeordneter Regelalgorithmus mit qualitativ höherwertigen Daten versorgt werden. In der EL2521 ist dieser Auslöser das SYNC0-Signal.

Abb. 2 Karteireiter "DC" (Disributed Clocks)

Beim Einschalten der Betriebsart "DC-Synchron" werden Einstellungen von TwinCAT gewählt, die einen zuverlässigen Betrieb der EL2521 mit aktuellen Daten gewährleisten. Das bedeutet, das die Verarbeitung der aktuellen Prozessdaten in hochkonstanten Abständen und rechtzeitig - also mit genügend Sicherheitspuffer - vor dem abholenden EtherCAT-Datagram durch das SYNC0-Signal gestartet wird

Das SYNC0-Signal kann bei Bedarf in entsprechenden Dialogen auf der Zeitachse nach rechts/spät bzw. links/früh durch Angabe einer "User defined Shift Time" verschoben (geshiftet) werden, s. Abb. 3.

  • Durch ein Shiften nach rechts (positiver Shift-Wert) erfolgt die Verarbeitung der Prozessdaten später - damit steigt der Aktualitätsgrad, relativ gesehen von der PLC aus. Allerdings steigt damit das Risiko, dass die Bereitstellung bis zur Ankunft des EtherCAT-Frames nicht rechtzeitig beendet wurde und in diesem Zyklus ein aktueller Wert fehlt.
  • Durch ein Shiften nach links (negativer Shift-Wert) erfolgt die Verarbeitung der Prozessdaten früher - damit sinkt der Aktualitätsgrad, jedoch wird der Sicherheitspuffer vor Ankunft des EtherCAT-Datagrams erhöht. Diese Einstellung kann auf Systemen mit hohem Echtzeit-Jitter nützlich sein, wenn zur Steuerung z.B. keine Industrie-PC von Beckhoff verwendet werden.

Achtung 		Achtung! Beschädigung der Geräte möglich!
Die hier aufgeführten Hinweise und Erläuterungen sollten mit Bedacht angewendet werden!
Die SYNC0- und SYNC1-Einstellungen werden vom EtherCAT-Master automatisch mit Werten belegt, die eine zuverlässige und aktuelle Prozessdatenerfassung unterstützen.
Anwenderseitige Eingriffe an dieser Stelle können zu unerwünschtem Verhalten führen !
Bei der Manipulation dieser Einstellungen im Systemmanager wird softwareseitig keine Plausibilitätskontrolle durchgeführt!
Eine korrekte Funktion der Klemme in allen denkbaren Einstellungsvarianten kann nicht gewährleistet werden!

Default-Einstellung

Das zyklische Schreiben der Ausgänge wird durch den SYNC0-Puls (Interrupt) der DC in der EL2521 ausgelöst. Standardmäßig wird die Zykluszeit "Sync Unit Zyklus" vom EtherCAT-Master auf die verwendete SPS-Zykluszeit und damit auf die EtherCAT-Zykluszeit gesetzt. Siehe Abb.7: 4000µs = 4 ms da sich TwinCAT im Config-Modus befindet.

DC-Einstellungen EL2521

Abb. 3: Erweiterte Einstellungen Distributed Clock (DC), Klemme EL2521

• SYNC0
Sync Unit Zyklus: Vielfaches der Buszykluszeit. In diesem Abstand (in µs) werden die Prozessdaten periodisch verarbeitet.

• Anwenderdefiniert

Beliebige Zahl bis 232 ns ≈ 4,3 sek. Kommawerte sind möglich.

• Shift Time
MIt der Shift Time kann der SYNC0-Puls dieser EL2521 gegenüber anderen Klemmen bzw. dem globalen SYNC-Puls in ns-Schritten verschoben werden. Sollen die Ausgänge mehrerer EL2521-Klemmen gleichzeitig geschrieben werden, muss hier derselbe Wert eingetragen werden.

• Based on Input Reference
Bei Aktivierung dieser Option wird zum klemmenlokalen konfigurierbaren SYNC0-Shift ("User defined") ein weiterer „Input Shift“ dazu addiert. Dieser Wert wird vom EtherCAT Master berechnet und zur Verfügung gestellt (SysMan/Gerät EtherCAT/Reiter EtherCAT/Erweiterte Einstellungen/Distributed Clocks/Input Shift Time/ , siehe Abb.4+5). Dadurch lesen alle Eingangsklemmen im System (EL1xxx, EL3xxx) möglichst kurz vor dem abholenden EtherCAT-Frame ihre Eingänge ein und liefern so möglichst „aktuelle“ Eingangsdaten an die Steuerung ab.

• Enable SYNC0
Automatisch aktiviert in der Betriebsart "DC-synchron".

• SYNC1
Weiterer SYNC-Puls, abgeleitet aus SYNC0 oder der DC selbst. Wird bei der EL2521 nicht benötigt.

DC-Einstellungen EtherCAT Master

In den erweiterten Einstellungen des EtherCAT Master können übergeordnete Parameter der Distributed Clocks verändert werden. Siehe dazu auch die grundlegende Einführung in das Thema EtherCAT und Distributed Clocks herunterladen: die "Systembeschreibung Distributed Clocks".

Abb. 4: EtherCAT Master, Karteireiter EtherCAT, Erweiterte Einstellungen

Abb. 5: EtherCAT Master, Erweiterte Einstellungen, Distributed Clock

Code Word

Hinweis 		Code Word
Der Hersteller behält sich die Grundkalibrierung der Klemmen vor. Das Code Word ist daher z. Zt. reserviert.

Hinweise zur EL2521-0124

Die EL2521-0124 verfügt über einen Latch-Eingang und einen 24V-Compare-Ausgang die beide im Zusammenhang mit dem Positionswert arbeiten.

Erläuterung anhand der zugehörigen Prozessdaten:

  • Latcheingang, identische Funktion wie bei EL-Encoderklemmen
    • PDO ENC Status (input)
      • Latch extern Valid
      • Status of extern latch (aktueller Status des Latcheingangs)
      • Latch value (Latchwert)
    • PDO ENC Control (output)
      • Enable latch extern on positive edge
      • Enable latch extern on negative edge
  • Compare-Ausgang „PLS“ (Programmable Limit Switch)
    • PLS Control:
      • „Enable PLS“:
        = 0 Ausgang kann Manuell über „Output“ geschaltet werden
        = 1 Automatische Schaltfunktion hat Kontrolle über den Ausgang
      • Output
        Schaltet den Ausgang (keine Funktion, wenn „Enable PLS“=1)
      • Switch on value
        Einschaltwert (erreicht der Zähler diesen Wert, wird der Ausgang eingeschaltet)
      • Switch off value
        Ausschaltwert (erreicht der Zähler diesen Wert, wird der Ausgang ausgeschaltet)

Abb. 6: Prozessdaten EL2521-0124


EL2521 - Prozessdaten

BECKHOFF EL2521: Inbetriebnahme

Prozessdaten

Inhaltsverzeichnis
• Sync Manager

• Einstellungunsoptionen Prozessdaten

- PDO Setting 1: Legacy (MDP 252)
- PDO setting 2: Standard 16 Bit (MDP 253/511)
- PDO setting 3: Standard 32 Bit (MDP 253/511)

Die Prozessdatenauswahl im Systemmanager legt die Betriebsart der El2521-xxxx fest. Die Prozessdaten können nach nachfolgenden Tabellen für Inputs und Outputs einzeln händisch oder über die predefined PDO-Auswahl mit einem Klick festgelegt werden.

Abb. 1: predefined PDO-Auswahl im TwinCAT Systemmanager

Für die El2521-xxxx sind 3 Prozessdatensätze verfügbar, die in nachfolgender Tabelle mit aufgeführt sind.

Sync Manager (SM)

PDO-Zuordnung

SM3, PDO-Zuordnung 0x1C13, Inputs
Index | zugeteilt zu PDO-Setting | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | Legacy (MDP 252) | 0x1A01 0x1A02 0x1A05 | 4.0 | Inputs | Index 0x6000:01 - Status Index 0x6000:02 - Data in
0x1A01 | Standard 16 Bit (MDP 253/511) Standard 32 Bit (MDP 253/511) | 0x1A00 | 2.0 | PTO Status | Index 0x6010:01 - Sel. Ack./End counter Index 0x6010:02 - Ramp active Index 0x6010:05 - Status of input target Index 0x6010:06 - Status of input zero Index 0x6010:07 - Error Index 0x1C32:20 - Sync error Index 0x1801:09 - TxPDO Toggle
0x1A02 | Standard 16 Bit (MDP 253/511) | 0x1A00 0x1A05 | 4.0 | ENC Status compact | Index 0x6020:03 - Set counter done Index 0x6020:04 - Counter underflow Index 0x6020:05 - Counter overflow Index 0x1C32:20 - Sync error Index 0x1802:09 - TxPDO Toggle Index 0x6020:11 - Counter value
0x1A05 | Standard 32 Bit (MDP 253/511) | 0x1A00 0x1A02 | 6.0 | ENC Status | Index 0x6020:03 - Set counter done Index 0x6020:04 - Counter underflow Index 0x6020:05 - Counter overflow Index 0x1C32:20 - Sync error Index 0x1805:09 - TxPDO Toggle Index 0x6020:11 - Counter value
SM2, PDO-Zuordnung 0x1C12, Outputs
Index | zugeteilt zu PDO-Setting | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600(default) | Legacy (MDP 252) | 0x1601 0x1604 0x1607 0x1602 0x1605 | 4.0 | Inputs | Index 0x7000:01 - Ctrl Index 0x7000:02 - Data out
0x1601 | Standard 16 Bit (MDP 253/511) Standard 32 Bit (MDP 253/511) | 0x1600 | 4.0 | PTO Control | Index 0x7010:01 - Frequency select Index 0x7010:02 - Disable ramp Index 0x7010:03 - Go counter Index 0x7010:11 - Frequency value
0x1604 | Standard 16 Bit (MDP 253/511) | 0x1600 0x1607 0x1605 | 2.0 | PTO Target compact | Index 0x7010:12 - Target counter value
0x1607 | Standard 32 Bit (MDP 253/511) | 0x1600 0x1604 0x1602 | 4.0 | PTO Target | Index 0x7010:12 - Target counter value
0x1602 | Standard 16 Bit (MDP 253/511) | 0x1600 0x1607 0x1605 | 4.0 | ENC Control compact | Index 0x7020:03 - Set counter Index 0x7020:11 - Set counter value
0x1605 | Standard 32 Bit (MDP 253/511) | 0x1600 0x1604 0x1602 | 6.0 | ENC Control | Index 0x7020:03 - Set counter Index 0x7020:11 - Set counter value

Tab. 1 + 2: PDO-Zuordnung der SyncManager

Einstellungsoptionen Prozessdaten

Über den Karteireiter "Prozessdaten" lässt sich wie im Folgenden beschrieben der Prozessdatenumfang einstellen.

PDO setting 1: Legacy (MDP 252)

  • eingestellte Standardkonfiguration in TwinCAT 2.10 (aktuellere TwinCAT-Versionen siehe Hinweis unten)
  • nur zu verwenden im normalen Betriebsmodus
  • kompatibel zu Klemmen bis inkl. FW02

Abb. 2: Prozessdaten und PDO-Zuodrnung Legacy (MDP 252)

Hinweis 		Standardkonfiguration in TwinCAT
Die Weiterentwicklung der EL2521-xxxx ab FW03 bedingt auch ein neues Prozessabbild, das in Neuanlagen bevorzugt verwendet werden soll. Deshalb ist ab TwinCAT 2.11 PDO setting 2 (siehe unten) normalerweise die Standardkonfiguration, mit der eine manuell oder per Scan eingefügte EL2521-xxxx in der Konfiguration erscheint.

Aus Kompatibilitätsgründen zu bestehender Software ist bei manchen Kunden aber gewünscht, dass auch bei Neuanalage von Konfigurationen das PDO setting 1 "Legacy MDP253" als Standardkonfiguration erscheint.

Dann ist im Systemmanager das so genannte Compatibility-Flag zu setzen. Dann wird Legacy als Standard-PDO-Konfiguration gewählt. Trotzdem können natürlich nach dem Einfügen der Klemme in die Konfiguration die PDO umgestellt/verändert werden.

Abb. 3: Compatibility Mode im Systemmanager ab TwinCAT 2.11

PDO setting 2: Standard 16 Bit (MDP 253/511)

  • eingestellte Standardkonfiguration in TwinCAT 2.11, TwinCAT 3
  • nur zu verwenden im erweiterten Betriebsmodus
  • sog. kompaktes Prozessabbild, da es nur über 16-Bit breite Variablen verfügt
  • erlaubt die Verknüpfung mit NC-Achsen nach MDP 253, Subprofil 511

Abb. 4: Prozessdaten und PDO-Zuodrnung Standard 16 Bit (MDP 253/511)

PDO setting 3: Standard 32 Bit (MDP 253/511)

  • nur zu verwenden im erweiterten Betriebsmodus
  • 32-Bit breite Variablen
  • erlaubt die Verknüpfung mit NC-Achsen nach MDP 253, Subprofil 511

Abb. 5: Prozessdaten und PDO-Zuodrnung Standard 32 Bit (MDP 253/511)


EL2521 - Objektbeschreibung

BECKHOFF EL2521: Inbetriebnahme

Objektbeschreibung und Parametrierung - Erweiteter Betriebsmodus

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte für die Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 Feature bits
Index | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | Feature bits | Max. Subindex | UINT8 | RO | 0x0F (15dez)
8000:02 | Emergency ramp active | TRUE Spricht der Watchdog-Timer an, fährt die Klemme eine Rampe mit der in Objekt 8001:08 eingestellten Zeitkonstante den in Objekt 8001:01 eingestellten Wert an. FALSE Die Funktion ist deaktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Watchdog timer deactive | Hier wird der SM-Watchdog ausgewertet. TRUE Der Watchdog-Timer ist deaktiviert FALSE Der Watchdog-Timer ist im Auslieferungszustand aktiviert. Bei einem Watchdog-Overflow wird entweder der Hersteller- oder der Anwendereinschaltwert ausgegeben. | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Sign/amount representation | TRUE Der Ausgabewert wird in der Betrag-Vorzeichendarstellung ausgegeben: -2dez= 0x8002 -1dez= 0x8001 1dez= 0x0001 2dez= 0x0002 FALSE Der Ausgabewert wird als Signed-Integer im Zweier-Komplement ausgegeben: -2dez= 0xFFFE -1dez= 0xFFFF 1dez= 0x0001 2dez= 0x0002 | BOOLEAN | RW | 0x00 (0dez)
8000:05 | Rising edge clears/sets counter | TRUE Das Löschen/Setzen des Zählers erfolgt bei einer positiven Flanke vom Counter_Clear-Bit im Control-Wort (CW.5) FALSE Das Löschen/Setzen des Zählers erfolgt bei positiven Pegel (gesetztem Counter_Clear-Bit im Control-Wort (CW.5) | BOOLEAN | RW | 0x01 (1dez)
8000:06 | Ramp function active | TRUE Rampenfunktion aktiviert FALSE Rampenfunktion deaktiviert Die Rampensteuerung sollte nur deaktiviert werden, wenn eine übergeordnete Regelung (z.B. NC-Steuerung) die Fahrweg- und Frequenzsteuerung übernimmt. | BOOLEAN | RW | 0x01 (1dez)
8000:07 | Ramp base frequency | 0(dez) Rampenbasisfrequenz: 10 Hz (Pulldownmenü) 1(dez) Rampenbasisfrequenz: 1 kHz (Pulldownmenü) | BIT1 | RW | 0x00 (0dez)
8000:08 | Direct input mode | TRUE Eingabemodus direkt FALSE Eingabemodus relativ | BOOLEAN | RW | 0x00 (0dez)
8000:09 | Users switch-on-value on wdt | TRUE Verhalten bei ausgelöstem Watchdog-Timer: Anwender-Einschaltwert FALSE Verhalten bei ausgelöstem Watchdog-Timer: Hersteller-Einschaltwert | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Travel distance control active | TRUE Fahrwegsteuerung aktiviert FALSE Fahrwegsteuerung deaktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Rising edge sets counter | TRUE Positive Flanke setzt Zähler FALSE Positive Flanke löscht Zähler | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Operating mode | 0(dez) Betriebsart Frequenz-Modulation (Pulldownmenü) 1(dez) Betriebsart Puls-Richtungsvorgabe (Pulldownmenü) 2(dez) Betriebsart Inkremental-Enkoder (Pulldownmenü) | BIT2 | RW | 0x00 (0dez)
8000:0F | Negative logic | TRUE Negative Logik FALSE Positive Logik | BOOLEAN | RW | 0x00 (0dez)
Index 8001 User settings
Index | Name | Bedeutung | Datentyp | Flags | Default
8001:0 | User settings | Max. Subindex | UINT8 | RO | 0x08 (8dez)
8001:01 | Users switch-on-value | Anwender Einschaltwert (Frequenz) | UINT16 | RW | 0x0000 (0dez)
8001:02 | Base frequency 1 | Grundfrequenz 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dez)
8001:03 | Base frequency 2 | Grundfrequenz 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dez)
8001:04 | Ramp time constant (rising) | Rampen-Zeitkonstante (ansteigend, [1/sec]) Die "reale" Rampenzeit ergibt sich aus der Multiplikation der Rampengrundfrequenz mit dieser Rampenzeitzeit-Konstante. | UINT16 | RW | 0x03E8 (1000dez)
8001:05 | Ramp time constant (falling) | Rampen-Zeitkonstante (abfallend, [1/sec]) Die "reale" Rampenzeit ergibt sich aus der Multiplikation der Rampengrundfrequenz mit dieser Rampenzeitzeit-Konstante. | UINT16 | RW | 0x03E8 (1000dez)
8001:06 | Frequency factor (Digit x 10 mHz) | Frequenz Faktor (direkte Eingabe, Digit x 10 mHz) | UINT16 | RW | 0x0064 (100dez)
8001:07 | Slowing down frequency | Auslauf-Frequenz, Fahrwegsteuerung | UINT16 | RW | 0x0032 (50dez)
8001:08 | Ramp time constant (emergency) | Rampen-Zeitkonstante für kontrolliertes Abschalten; Anwender Einschaltwert wird angefahren (Objekt 8001:01) | UINT16 | RW | 0x03E8 (1000dez)
Index 8800 Volatile settings
Index | Name | Bedeutung | Datentyp | Flags | Default
8800:0 | Volatile settings | Max. Subindex | UINT8 | RO | 0x02 (2dez)
8800:01 | Target counter state | Zielzählerstand | UINT32 | RW | 0x00000000 (0dez)
8800:02 | Maximum frequency | Maximale Frequenz | UINT16 | RW | 0x0000 (0dez)

Objekte für den regulären Betrieb

Die EL2521 im normalen Betriebsmodus verfügt über keine solchen Objekte.

Vollständige Übersicht

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL2521-0000
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 02
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x30520002 (810680322dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x000009D9 (2521dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 1600 Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dez)
1600:01 | RxPDO-Mapping Element 1: Ctrl | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 16
1600:02 | RxPDO-Mapping Element 2: Data out | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Data Out)) | UINT32 | RO | 0x7000:02, 16
Index 1A00 Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x02 (2dez)
1A00:01 | TxPDO-Mapping Element 1: Status | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 16
1A00:02 | TxPDO-Mapping Element 2: Data in | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Data In)) | UINT32 | RO | 0x6000:02, 16
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C01 Process data format
Index | Name | Bedeutung | Datentyp | Flags | Default
1C01:0 | Process data format | Prozessdatenformat | UINT16 | RW | 0x0100 (256dez)
Index 1C12 SM 0002RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | Assigned RxPDO | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | Assigned TxPDO | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
6000:01 | Status | Status-Word | UINT16 | RO | 0x0000 (0dez)
6000:02 | Data In | Eingangsprozessdaten (Counter value) | UINT16 | RO | 0x0000 (0dez)
Index 7000 Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | Outputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
7000:01 | Ctrl | Control-Word | UINT16 | RO | 0x0000 (0dez)
7000:02 | Data Out | Ausgangsprozessdaten (Frequency value) | UINT16 | RO | 0x0000 (0dez)
Index A000 Diagnostic parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | Diagnostic parameter | Max. Subindex | UINT8 | RO | 0x01 (1dez)
A000:01 | Counter extension | Zählererweiterung | UINT16 | RO | 0x0000 (0dez)
Index F000 Profile settings
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0001 (1dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | z. Zt. reserviert | UINT32 | RW | 0x00000000 (0dez)


EL2521 - Control- und Status-Byte

BECKHOFF EL2521: Konfiguration

Control- und Status-Wort

Control-Wort

Das Control-Wort (CW) befindet sich im Ausgangsprozessabbild und wird von der Steuerung zur Klemme übertragen.

Bit | CW.15 | CW.14 | CW.13 | CW.12 | CW.11 | CW.10 | CW.9 | CW.8
Name | - | - | - | - | - | - | - | -
Bit | CW.7 | CW.6 | CW.5 | CW.4 | CW.3 | CW.2 | CW.1 | CW.0
Name | - | - | CNT_CLR | - | - | GO_COUNTER | RAMP_DIS | FREQ_SEL
Legende
Bit | Name | Beschreibung
CW.8 - CW.15 | - | - | reserviert
CW.7 | - | - | reserviert
CW.6 | - | - | reserviert
CW.5 | CNT_CLR | 1bin | Der Zählerstand wird durch dieses Bit gelöscht oder gesetzt (Index 8000:0B). Eventuell gesetzte Over-/Underflow-Bits werden ebenfalls durch dieses Bit gelöscht. Dies kann Flanken- oder Pegel-gesteuert erfolgen (Index 8000:05 ).
CW.4 | - | - | reserviert
CW.3 | - | - | reserviert
CW.2 | GO_COUNTER | 1bin | Bei aktivierter Fahrwegsteuerung (Index 8000:0A wird bei gesetztem Bit auf einen vorgegebenen Zählerwert gefahren
CW.1 | RAMP_DIS | 1bin | Die Rampenfunktion wird aufgehoben, trotz aktivem Index 8000:06; ist die Fahrwegsteuerung aktiv, wird sie durch dieses Bit abgebrochen
CW.0 | FREQ_SEL | 0bin / 1bin | Schnelle Umschaltung der Grund-Frequenz (nur bei deaktivierter Rampenfunktion) 0bin = Grundfrequenz 1 (Index 8001:02) 1bin = Grundfrequenz 2 (Index 8001:03)

Status-Wort

Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.

Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | - | - | - | - | - | - | - | -
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | - | ERROR | INPUT_Z | INPUT_T | OVERFLOW | UNDERFLOW | RAMP_ACTIVE | SEL_ACK/ END_COUNTER
Legende
Bit | Name | Beschreibung
SW.8 - SW.15 | - | - | reserviert
SW.7 | - | - | reserviert
SW.6 | ERROR | 1bin | Allgemeines Fehlerbit, wird zusammen mit Overrange und Underrange gesetzt
SW.5 | INPUT_Z | 1bin | Status des Eingangs INPUT_Z
SW.4 | INPUT_T | 1bin | Status des Eingangs INPUT_T
SW.3 | OVERFLOW | 1bin | tritt ein Überlauf (65535 -> 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 -> 21846) oder sobald ein Unterlauf auftritt.
SW.2 | UNDERFLOW | 1bin | tritt ein Unterlauf (0 -> 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 -> 43689) oder sobald ein Überlauf auftritt.
SW.1 | RAMP_ACTIVE | 1bin | Eine Rampe wird momentan durchfahren
SW.0 | SEL_ACK/ END_COUNTER | 1bin | Bestätigt den Wechsel der Grundfrequenz. bei aktivierter Fahrwegsteuerung: Zielzählerstand erreichet


EL2521-0000, EL2521-0024, EL2521-0025 - Objektbeschreibung und Parametrierung - Erweiteter Betriebsmodus

BECKHOFF EL2521-0000, EL2521-0024, EL2521-0025: Inbetriebnahme

Objektbeschreibung und Parametrierung - Erweiteter Betriebsmodus

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte für die Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8010 PTO Settings
Index | Name | Bedeutung | Datentyp | Flags | Default
8010:0 | PTO Settings | Max. Subindex | UINT8 | RO | 0x18 (24dez)
8010:02 | Emergency ramp active | TRUE Spricht der Watchdog-Timer an, fährt die Klemme eine Rampe mit der in Objekt 8001:08 bzw. 8010:18 eingestellten Zeitkonstante den in Objekt 8001:01 bzw. 8010:11 eingestellten Wert an. FALSE Die Funktion ist deaktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:03 | Watchdog timer deactive | Hier wird der SM-Watchdog ausgewertet. TRUE Der Watchdog-Timer ist deaktiviert FALSE Der Watchdog-Timer ist im Auslieferungszustand aktiviert. Bei einem Watchdog-Overflow wird entweder der Hersteller- oder der Anwendereinschaltwert ausgegeben | BOOLEAN | RW | 0x00 (0dez)
8010:04 | Sign/amount representation | TRUE Der Ausgabewert wird in der Betrag-Vorzeichendarstellung ausgegeben: -2dez= 0x8002 -1dez= 0x8001 1dez= 0x0001 2dez= 0x0002 FALSE Der Ausgabewert wird als Signed-Integer im Zweier-Komplement ausgegeben: -2dez= 0xFFFE -1dez= 0xFFFF 1dez= 0x0001 2dez= 0x0002 | BOOLEAN | RW | 0x00 (0dez)
8010:06 | Ramp function active | TRUE Rampenfunktion aktiviert FALSE Rampenfunktion deaktiviert Die Rampensteuerung sollte nur deaktiviert werden, wenn eine übergeordnete Regelung (z.B. NC-Steuerung) die Fahrweg- und Frequenzsteuerung übernimmt. | BOOLEAN | RW | 0x01 (1dez)
8010:07 | Ramp base frequency | 0(dez) Rampenbasisfrequenz: 10 Hz (Pulldownmenü) 1(dez) Rampenbasisfrequenz: 1 kHz (Pulldownmenü) | BIT1 | RW | 0x00 (0dez)
8010:08 | Direct input mode | TRUE Eingabemodus direkt FALSE Eingabemodus relativ | BOOLEAN | RW | 0x00 (0dez)
8010:09 | Users switch-on-value on wdt | TRUE Verhalten bei ausgelöstem Watchdog-Timer: Anwender-Einschaltwert FALSE Verhalten bei ausgelöstem Watchdog-Timer: Hersteller-Einschaltwert | BOOLEAN | RW | 0x00 (0dez)
8010:0A | Travel distance control active | TRUE Fahrwegsteuerung aktiviert FALSE Fahrwegsteuerung deaktiviert | BOOLEAN | RW | 0x00 (0dez)
8010:0E | Operating mode | 0(dez) Betriebsart Frequenz-Modulation (Pulldownmenü) 1(dez) Betriebsart Puls-Richtungsvorgabe (Pulldownmenü) 2(dez) Betriebsart Inkremental-Enkoder (Pulldownmenü) | BIT2 | RW | 0x00 (0dez)
8010:10 | Negative logic | TRUE Negative Logik FALSE Positive Logik | BOOLEAN | RW | 0x00 (0dez)
8010:11 | Users switch-on-value | Anwender Einschaltwert (Frequenz) | UINT16 | RW | 0x0000 (0dez)
8010:12 | Base frequency 1 | Grundfrequenz 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dez)
8010:13 | Base frequency 2 | Grundfrequenz 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dez)
8010:14 | Ramp time constant (rising) | Rampen-Zeitkonstante (ansteigend) | UINT16 | RW | 0x03E8 (1000dez)
8010:15 | Ramp time constant (falling) | Rampen-Zeitkonstante (abfallend) | UINT16 | RW | 0x03E8 (1000dez)
8010:16 | Frequency factor (Digit x 10mHz) | Frequenz Faktor (direkte Eingabe, Digit x 10mHz) | UINT16 | RW | 0x0064 (100dez)
8010:17 | Slowing down frequency | Auslauf-Frequenz, Fahrwegsteuerung | UINT16 | RW | 0x0032 (50dez)
8010:18 | Ramp time constant (emergency) | Rampen-Zeitkonstante für kontrolliertes Abschalten; Anwender Einschaltwert wird angefahren (Objekt 8001:01 bzw. 8010:11) | UINT16 | RW | 0x03E8 (1000dez)

Objekte für den regulären Betrieb

Die EL2521 im erweiterten Betriebsmodus verfügt über keine solchen Objekte.

Vollständige Übersicht

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL2521
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 05
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 06
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x09D93052 (165228626dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x03F80000 (66584576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1400 RxPDO-Par
Index | Name | Bedeutung | Datentyp | Flags | Default
1400:0 | RxPDO-Par | PDO Parameter RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1400:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 1 übertragen werden dürfen | OCTET-STRING[10] | RO | 01 16 04 16 07 16 02 16 05 16
Index 1401 PTO RxPDO-Par Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | PTO RxPDO-Par Control | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[10] | RO | 00 16 00 00 00 00 00 00 00 00
Index 1402 ENC RxPDO-Par Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[10] | RO | 00 16 05 16 07 16 00 00 00 00
Index 1404 PTO RxPDO-Par Target compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | PTO RxPDO-Par Target compact | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[10] | RO | 00 16 05 16 07 16 00 00 00 00
Index 1405 ENC RxPDO-Par Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[10] | RO | 00 16 02 16 04 16 00 00 00 00
Index 1407 PTO RxPDO-Par Target
Index | Name | Bedeutung | Datentyp | Flags | Default
1407:0 | PTO RxPDO-Par Target | PDO Parameter RxPDO 8 | UINT8 | RO | 0x06 (6dez)
1407:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 8 übertragen werden dürfen | OCTET-STRING[10] | RO | 00 16 02 16 04 16 00 00 00 00
Index 1600 RxPDO-Map
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | RxPDO-Map | PDO Mapping RxPDO 1 | UINT8 | RO | 0x02 (2dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (Outputs), entry 0x01 (Ctrl)) | UINT32 | RO | 0x7000:01, 16
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (Outputs), entry 0x02 (Data Out)) | UINT32 | RO | 0x7000:02, 16
Index 1601 PTO RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | PTO RxPDO-Map Control | PDO Mapping RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x03 (Go counter)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1601:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7010:11, 16
Index 1602 ENC RxPDO-Map Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x05 (5dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 16
Index 1604 PTO RxPDO-Map Target compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | PTO RxPDO-Map Target compact | PDO Mapping RxPDO 5 | UINT8 | RO | 0x01 (1dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 16
Index 1605 ENC RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 6 | UINT8 | RO | 0x05 (5dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7020:03, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7020 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7020:11, 32
Index 1607 PTO RxPDO-Map Target
Index | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | PTO RxPDO-Map Target | PDO Mapping RxPDO 8 | UINT8 | RO | 0x01 (1dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7010:12, 32
Index 1800 TxPDO-Par
Index | Name | Bedeutung | Datentyp | Flags | Default
1800:0 | TxPDO-Par | PDO Parameter TxPDO 1 | UINT8 | RO | 0x06 (6dez)
1800:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 1 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 1A 02 1A 05 1A
Index 1801 PTO TxPDO-Par Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | PTO TxPDO-Par Status | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 00 1A 00 00 00 00
1801:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1802 ENC TxPDO-Par Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1802:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 3 | UINT8 | RO | 0x09 (9dez)
1802:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 3 übertragen werden dürfen | OCTET-STRING[6] | RO | 05 1A 00 1A 00 00
1802:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1805 ENC TxPDO-Par Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1805:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 6 | UINT8 | RO | 0x09 (9dez)
1805:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 02 1A 00 1A 00 00
1805:09 | TxPDO-Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1A00 TxPDO-Map
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | TxPDO-Map | PDO Mapping TxPDO 1 | UINT8 | RO | 0x02 (2dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (Inputs), entry 0x01 (Status)) | UINT32 | RO | 0x6000:01, 16
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (Inputs), entry 0x02 (Data In)) | UINT32 | RO | 0x6000:02, 16
Index 1A01 PTO TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | PTO TxPDO-Map Status | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0A (10dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x05 (Status of input target)) | UINT32 | RO | 0x6010:05, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x06 (Status of input zero)) | UINT32 | RO | 0x6010:06, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (PTO Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6010:07, 1
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x1801 (PTO TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1801:09, 1
Index 1A02 ENC TxPDO-Map Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0A (10dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1802 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1802:09, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 16
Index 1A05 ENC TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 6 | UINT8 | RO | 0x0A (10dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6020:03, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6020:04, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6020:05, 1
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1805 (ENC TxPDO-Par Status), entry 0x09 (TxPDO-Toggle)) | UINT32 | RO | 0x1805:09, 1
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6020 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6020:11, 32
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x01 (1dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x01 (1dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dez)
1C32:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron with SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
 UINT32 RW 0x001E8480 (2000000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0 = 1: Free Run wird unterstützt
  • Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
 UINT16 RO 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x00000000 (0dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestoppt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt

UINT16 RW 0x0000 (0dez)
1C32:09 | Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0022 (34dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x001E8480 (2000000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x00000000 (0dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | Inputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
6000:01 | Status | Status-Word | UINT16 | RO | 0x0000 (0dez)
6000:02 | Data In | Eingangsprozessdaten (Counter value, Index 6020:11) | UINT16 | RO | 0x0000 (0dez)
Index 6010 PTO Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | PTO Inputs | Max. Subindex | UINT8 | RO | 0x10 (16dez)
6010:01 | Sel. Ack/End counter | Bestätigt den Wechsel der Grundfrequenz. bei aktivierter Fahrwegsteuerung: Zielzählerstand erreichet | BOOLEAN | RO | 0x00 (0dez)
6010:02 | Ramp active | Eine Rampe wird momentan durchfahren | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Status of input target | Status des Eingangs TARGET (T) | BOOLEAN | RO | 0x00 (0dez)
6010:06 | Status of input zero | Status des Eingangs ZERO (Z) | BOOLEAN | RO | 0x00 (0dez)
6010:07 | Error | Allgemeines Fehlerbit, wird zusammen mit Overrange und Underrange gesetzt | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync Error | Das Sync Error Bit wird nur für den Distributed Clocks Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 6020 ENC Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | ENC Inputs | Max. Subindex | UINT8 | RO | 0x16 (22dez)
6020:03 | Set counter done | Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Counter underflow | Tritt ein Unterlauf (0 -> 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 -> 43689) oder sobald ein Überlauf auftritt. | BOOLEAN | RO | 0x00 (0dez)
6020:05 | Counter overflow | Tritt ein Überlauf (65535 -> 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 -> 21846) oder sobald ein Unterlauf auftritt. | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync Error | Das Sync Error Bit wird nur für den Distributed Clocks Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6020:11 | Counter value | Zählerstand | UINT32 | RO | 0x00000000 (0dez)
Index 7000 Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | Outputs | Max. Subindex | UINT8 | RO | 0x02 (2dez)
7000:01 | Ctrl | Control-Word | UINT16 | RO | 0x0000 (0dez)
7000:02 | Data Out | Ausgangsprozessdaten (Frequency value, Index 7010:11) | UINT16 | RO | 0x0000 (0dez)
Index 7010 PTO Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | PTO Outputs | Max. Subindex | UINT8 | RO | 0x12 (18dez)
7010:01 | Frequency select | Schnelle Umschaltung der Grund-Frequenz (nur bei deaktivierter Rampenfunktion) 0bin = Grundfrequenz 1 (Objekt 8001:02 bzw. 8010:12) 1bin = Grundfrequenz 2 (Objekt 8001:03 bzw. 8010:13) | BOOLEAN | RO | 0x00 (0dez)
7010:02 | Disable ramp | Die Rampenfunktion wird aufgehoben, trotz aktivem Objekt 8000:06 bzw. 8010:06; ist die Fahrwegsteuerung aktiv, wird sie durch dieses Bit abgebrochen. | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Go counter | Bei aktivierter Fahrwegsteuerung (Objekt 8000:0A bzw. 8010:0A) wird bei gesetztem Bit auf einen vorgegebenen Zählerwert gefahren | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Frequency value | Frequenzwert | UINT16 | RO | 0x0000 (0dez)
7010:12 | Target counter value | Zielzählerstand | UINT32 | RO | 0x00000000 (0dez)
Index 7020 ENC Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | ENC Outputs | Max. Subindex | UINT8 | RO | 0x11 (17dez)
7020:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Set counter value | Über Index 7020:03 zu setzender Zählerstand | UINT32 | RO | 0x00000000 (0dez)
Index A000 Diagnostic parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
A000:0 | Diagnostic parameter | Max. Subindex | UINT8 | RO | 0x01 (1dez)
A000:01 | Counter extension | Zählererweiterung | UINT16 | RO | 0x0000 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | z. Zt. reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | - | UINT32 | RW | 0x000000FC (252dez)
F010:02 | SubIndex 002 | - | UINT32 | RW | 0x000000FD (253dez)
F010:03 | SubIndex 003 | - | UINT32 | RW | 0x000001FF (511dez)


EL2521-0124 - Objektbeschreibung

BECKHOFF EL2521-0124: Inbetriebnahme

Objektbeschreibung und Parametrierung - Erweiteter Betriebsmodus

Hinweis 		EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.

Hinweis 		Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen.
Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen

Einführung

In der CoE-Übersicht sind Objekte mit verschiedenem Einsatzzweck enthalten:

  • Objekte die zu Parametrierung bei der Inbetriebnahme nötig sind
  • Objekte die zum regulären Betrieb z.B. durch ADS-Zugriff bestimmt sind.
  • Objekte die interne Settings anzeigen und ggf. nicht veränderlich sind

Im Folgenden werden zuerst die im normalen Betrieb benötigten Objekte vorgestellt, dann die für eine vollständige Übersicht noch fehlenden Objekte.

Objekte für die Inbetriebnahme

Index 1011 Restore default parameters
Index | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)
Index 8000 PTO Settings
Index | Name | Bedeutung | Datentyp | Flags | Default
8000:0 | PTO Settings | Max. Subindex | UINT8 | RO | 0x18 (24dez)
8000:02 | Emergency ramp active | TRUE Spricht der Watchdog-Timer an, fährt die Klemme eine Rampe mit der in Objekt 8000:18 eingestellten Zeitkonstante den in Objekt 8000:11 eingestellten Wert an. FALSE Die Funktion ist deaktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:03 | Watchdog timer deactive | TRUE Der Watchdog-Timer ist deaktiviert FALSE Der Watchdog-Timer ist im Auslieferungszustand aktiviert. Bei einem Watchdog-Overflow wird entweder der Hersteller- oder der Anwendereinschaltwert ausgegeben | BOOLEAN | RW | 0x00 (0dez)
8000:04 | Sign/amount representation | TRUE Der Ausgabewert wird in der Betrag-Vorzeichendarstellung ausgegeben: -2dez= 0x8002 -1dez= 0x8001 1dez= 0x0001 2dez= 0x0002 FALSE Der Ausgabewert wird als Signed-Integer im Zweier-Komplement ausgegeben: -2dez= 0xFFFE -1dez= 0xFFFF 1dez= 0x0001 2dez= 0x0002 | BOOLEAN | RW | 0x00 (0dez)
8000:06 | Ramp function active | TRUE Rampenfunktion aktiviert FALSE Rampenfunktion deaktiviert | BOOLEAN | RW | 0x01 (1dez)
8000:07 | Ramp base frequency | 0(dez) Rampenbasisfrequenz: 10 Hz (Pulldownmenü) 1(dez) Rampenbasisfrequenz: 1 kHz (Pulldownmenü) | BIT1 | RW | 0x00 (0dez)
8000:08 | Direct input mode | TRUE Eingabemodus direkt FALSE Eingabemodus relativ | BOOLEAN | RW | 0x00 (0dez)
8000:09 | Users switch-on-value on wdt | TRUE Verhalten bei ausgelöstem Watchdog-Timer: Anwender-Einschaltwert FALSE Verhalten bei ausgelöstem Watchdog-Timer: Hersteller-Einschaltwert | BOOLEAN | RW | 0x00 (0dez)
8000:0A | Travel distance control active | TRUE Fahrwegsteuerung aktiviert FALSE Fahrwegsteuerung deaktiviert | BOOLEAN | RW | 0x00 (0dez)
8000:0B | Output set active low | Invertierung der Ausgangslogik für Output 24 V 0: in geschaltetem Zustand HIGH-Pegel 1: in geschalteten Zustand LOW-Pegel | BOOLEAN | RW | 0x00 (0dez)
8000:0E | Operating mode | 0(dez) Betriebsart Frequenz-Modulation (Pulldownmenü) 1(dez) Betriebsart Puls-Richtungsvorgabe (Pulldownmenü) 2(dez) Betriebsart Inkremental-Enkoder (Pulldownmenü) | BIT2 | RW | 0x00 (0dez)
8000:10 | Negative logic | TRUE Negative Logik FALSE Positive Logik | BOOLEAN | RW | 0x00 (0dez)
8000:11 | Users switch-on-value | Anwender Einschaltwert (Frequenz) | UINT16 | RW | 0x0000 (0dez)
8000:12 | Base frequency 1 | Grundfrequenz 1 = 50000 Hz | UINT32 | RW | 0x0000C350 (50000dez)
8000:13 | Base frequency 2 | Grundfrequenz 2 = 100000 Hz | UINT32 | RW | 0x000186A0 (100000dez)
8000:14 | Ramp time constant (rising) | Rampen-Zeitkonstante (ansteigend) | UINT16 | RW | 0x03E8 (1000dez)
8000:15 | Ramp time constant (falling) | Rampen-Zeitkonstante (abfallend) | UINT16 | RW | 0x03E8 (1000dez)
8000:16 | Frequency factor (Digit x 10mHz) | Frequenz Faktor (direkte Eingabe, Digit x 10mHz) | UINT16 | RW | 0x0064 (100dez)
8000:17 | Slowing down frequency | Auslauf-Frequenz, Fahrwegsteuerung | UINT16 | RW | 0x0032 (50dez)
8000:18 | Ramp time constant (emergency) | Rampen-Zeitkonstante für kontrolliertes Abschalten; Anwender Einschaltwert wird angefahren (Objekt 8000:11) | UINT16 | RW | 0x03E8 (1000dez)

Objekte für den regulären Betrieb

Die EL2521-0124 im erweiterten Betriebsmodus verfügt über keine solchen Objekte.

Vollständige Übersicht

Standardobjekte (0x1000-0x1FFF)

Die Standardobjekte haben für alle EtherCAT-Slaves die gleiche Bedeutung.

Index 1000 Device type
Index | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL2521-0124
Index 1009 Hardware version
Index | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 03
Index 100A Software version
Index | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x09D93052 (165228626dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x0010007C (1048700dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1401 ENC RxPDO-Par Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1401:0 | ENC RxPDO-Par Control compact | PDO Parameter RxPDO 2 | UINT8 | RO | 0x06 (6dez)
1401:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 2 übertragen werden dürfen | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1402 PLS RxPDO-Par Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | PLS RxPDO-Par Control compact | PDO Parameter RxPDO 3 | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 3 übertragen werden dürfen | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1403 PTO RxPDO-Par Target compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1403:0 | PTO RxPDO-Par Target compact | PDO Parameter RxPDO 4 | UINT8 | RO | 0x06 (6dez)
1403:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 4 übertragen werden dürfen | OCTET-STRING[6] | RO | 04 16 05 16 06 16
Index 1404 ENC RxPDO-Par Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1404:0 | ENC RxPDO-Par Control | PDO Parameter RxPDO 5 | UINT8 | RO | 0x06 (6dez)
1404:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 5 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1405 PLS RxPDO-Par Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1405:0 | PLS RxPDO-Par Control | PDO Parameter RxPDO 6 | UINT8 | RO | 0x06 (6dez)
1405:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 6 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1406 PTO RxPDO-Par Target
Index | Name | Bedeutung | Datentyp | Flags | Default
1406:0 | PTO RxPDO-Par Target | PDO Parameter RxPDO 7 | UINT8 | RO | 0x06 (6dez)
1406:06 | Exclude RxPDOs | Hier sind die RxPDOs (Index der RxPDO Mapping Objekte) angegeben, die nicht zusammen mit RxPDO 7 übertragen werden dürfen | OCTET-STRING[6] | RO | 01 16 02 16 03 16
Index 1600 PTO RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | PTO RxPDO-Map Control | PDO Mapping RxPDO 1 | UINT8 | RO | 0x06 (6dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x01 (Frequency select)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x02 (Disable ramp)) | UINT32 | RO | 0x7000:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x03 (Go counter)) | UINT32 | RO | 0x7000:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1600:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x11 (Frequency value)) | UINT32 | RO | 0x7000:11, 16
Index 1601 ENC RxPDO-Map Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | ENC RxPDO-Map Control compact | PDO Mapping RxPDO 2 | UINT8 | RO | 0x07 (7dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 16
Index 1602 PLS RxPDO-Map Control compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | PLS RxPDO-Map Control compact | PDO Mapping RxPDO 3 | UINT8 | RO | 0x07 (7dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x01 (Enable PLS)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x04 (Output)) | UINT32 | RO | 0x7020:04, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x11 (Switch on value)) | UINT32 | RO | 0x7020:11, 16
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x12 (Switch off value)) | UINT32 | RO | 0x7020:12, 16
Index 1603 PTO RxPDO-Map Target compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | PTO RxPDO-Map Target compact | PDO Mapping RxPDO 4 | UINT8 | RO | 0x01 (1dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 16
Index 1604 ENC RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | ENC RxPDO-Map Control | PDO Mapping RxPDO 5 | UINT8 | RO | 0x07 (7dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x02 (Enable latch extern on positive edge)) | UINT32 | RO | 0x7010:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x03 (Set counter)) | UINT32 | RO | 0x7010:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x04 (Enable latch extern on negative edge)) | UINT32 | RO | 0x7010:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7010 (ENC Outputs), entry 0x11 (Set counter value)) | UINT32 | RO | 0x7010:11, 32
Index 1605 PLS RxPDO-Map Control
Index | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | PLS RxPDO-Map Control | PDO Mapping RxPDO 6 | UINT8 | RO | 0x07 (7dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x01 (Enable PLS)) | UINT32 | RO | 0x7020:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x04 (Output)) | UINT32 | RO | 0x7020:04, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x11 (Switch on value)) | UINT32 | RO | 0x7020:11, 32
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7020 (PLS Outputs), entry 0x12 (Switch off value)) | UINT32 | RO | 0x7020:12, 32
Index 1606 PTO RxPDO-Map Target
Index | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | PTO RxPDO-Map Target | PDO Mapping RxPDO 7 | UINT8 | RO | 0x01 (1dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (PTO Outputs), entry 0x12 (Target counter value)) | UINT32 | RO | 0x7000:12, 32
Index 1801 ENC TxPDO-Par Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1801:0 | ENC TxPDO-Par Status compact | PDO Parameter TxPDO 2 | UINT8 | RO | 0x09 (9dez)
1801:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 2 übertragen werden dürfen | OCTET-STRING[2] | RO | 04 1A
1801:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1804 ENC TxPDO-Par Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | ENC TxPDO-Par Status | PDO Parameter TxPDO 5 | UINT8 | RO | 0x09 (9dez)
1804:06 | Exclude TxPDOs | Hier sind die TxPDOs (Index der TxPDO Mapping Objekte) angegeben, die nicht zusammen mit TxPDO 5 übertragen werden dürfen | OCTET-STRING[2] | RO | 01 1A
1804:09 | TxPDO Toggle | Das TxPDO Toggle wird mit jedem aktualisieren der zugehörigen Eingangsdaten getoggelt | BOOLEAN | RO | 0x00 (0dez)
Index 1A00 PTO TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | PTO TxPDO-Map Status | PDO Mapping TxPDO 1 | UINT8 | RO | 0x08 (8dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x01 (Sel. Ack/End counter)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x02 (Ramp active)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6000 (PTO Inputs), entry 0x07 (Error)) | UINT32 | RO | 0x6000:07, 1
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (6 bits align) | UINT32 | RO | 0x0000:00, 6
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x1800, entry 0x09) | UINT32 | RO | 0x1800:09, 1
Index 1A01 ENC TxPDO-Map Status compact
Index | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | ENC TxPDO-Map Status compact | PDO Mapping TxPDO 2 | UINT8 | RO | 0x0D (13dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1801 (ENC TxPDO-Par Status compact), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1801:09, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 16
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 16
Index 1A02 PLS TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | PLS TxPDO-Map Status | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (PLS Inputs), entry 0x01 (PLS Enabled)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (PLS Inputs), entry 0x04 (Status of output)) | UINT32 | RO | 0x6020:04, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (9 bits align) | UINT32 | RO | 0x0000:00, 9
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x1802, entry 0x09) | UINT32 | RO | 0x1802:09, 1
Index 1A04 ENC TxPDO-Map Status
Index | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | ENC TxPDO-Map Status | PDO Mapping TxPDO 5 | UINT8 | RO | 0x0D (13dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x02 (Latch extern valid)) | UINT32 | RO | 0x6010:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x03 (Set counter done)) | UINT32 | RO | 0x6010:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x04 (Counter underflow)) | UINT32 | RO | 0x6010:04, 1
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x05 (Counter overflow)) | UINT32 | RO | 0x6010:05, 1
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x0D (Status of extern latch)) | UINT32 | RO | 0x6010:0D, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x1C32 (SM output parameter), entry 0x20 (Sync error)) | UINT32 | RO | 0x1C32:20, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x1804 (ENC TxPDO-Par Status), entry 0x09 (TxPDO Toggle)) | UINT32 | RO | 0x1804:09, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x11 (Counter value)) | UINT32 | RO | 0x6010:11, 32
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6010 (ENC Inputs), entry 0x12 (Latch value)) | UINT32 | RO | 0x6010:12, 32
Index 1C00 Sync manager type
Index | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
Index 1C32 SM output parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C32:0 | SM output parameter | Synchronisierungsparameter der Outputs | UINT8 | RO | 0x20 (32dez)
1C32:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 2 Event
  • 2: DC-Mode - Synchron with SYNC0 Event
  • 3: DC-Mode - Synchron with SYNC1 Event
 UINT16 RW 0x0001 (1dez)
1C32:02 Cycle time Zykluszeit (in ns):
  • Free Run: Zykluszeit des lokalen Timers
  • Synchron with SM 2 Event: Zykluszeit des Masters
  • DC-Mode: SYNC0/SYNC1 Cycle Time
 UINT32 RW 0x001E8480 (2000000dez)
1C32:03 | Shift time | Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0 = 1: Free Run wird unterstützt
  • Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
 UINT16 RO 0xC007 (49159dez)
1C32:05 | Minimum cycle time | Minimale Zykluszeit (in ns) | UINT32 | RO | 0x00000000 (0dez)
1C32:06 | Calc and copy time | Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C32:08 Command
  • 0: Messung der lokalen Zykluszeit wird gestoppt
  • 1: Messung der lokalen Zykluszeit wird gestartet

Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt

UINT16 RW 0x0000 (0dez)
1C32:09 | Maximum Delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 1C33 SM input parameter
Index | Name | Bedeutung | Datentyp | Flags | Default
1C33:0 | SM input parameter | Synchronisierungsparameter der Inputs | UINT8 | RO | 0x20 (32dez)
1C33:01 Sync mode Aktuelle Synchronisierungsbetriebsart:
  • 0: Free Run
  • 1: Synchron with SM 3 Event (keine Outputs vorhanden)
  • 2: DC - Synchron with SYNC0 Event
  • 3: DC - Synchron with SYNC1 Event
  • 34: Synchron with SM 2 Event (Outputs vorhanden)
 UINT16 RW 0x0022 (34dez)
1C33:02 | Cycle time | wie 1C32:02 | UINT32 | RW | 0x001E8480 (2000000dez)
1C33:03 | Shift time | Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:04 Sync modes supported Unterstützte Synchronisierungsbetriebsarten:
  • Bit 0: Free Run wird unterstützt
  • Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
  • Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
  • Bit 2-3 = 01: DC-Mode wird unterstützt
  • Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
  • Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
  • Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
 UINT16 RO 0xC007 (49159dez)
1C33:05 | Minimum cycle time | wie 1C32:05 | UINT32 | RO | 0x00000000 (0dez)
1C33:06 | Calc and copy time | Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:07 | Minimum delay time | UINT32 | RO | 0x00000000 (0dez)
1C33:08 | Command | wie 1C32:08 | UINT16 | RW | 0x0000 (0dez)
1C33:09 | Maximum Delay time | Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C33:0B | SM event missed counter | wie 1C32:11 | UINT16 | RO | 0x0000 (0dez)
1C33:0C | Cycle exceeded counter | wie 1C32:12 | UINT16 | RO | 0x0000 (0dez)
1C33:0D | Shift too short counter | wie 1C32:13 | UINT16 | RO | 0x0000 (0dez)
1C33:20 | Sync error | wie 1C32:32 | BOOLEAN | RO | 0x00 (0dez)

Profilspezifische Objekte (0x6000-0xFFFF)

Die profilspezifischen Objekte haben für alle EtherCAT Slaves, die das Profil 5001 unterstützen, die gleiche Bedeutung.

Index 6000 PTO Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6000:0 | PTO Inputs | Max. Subindex | UINT8 | RO | 0x10 (16dez)
6000:01 | Sel. Ack/End counter | Bestätigt den Wechsel der Grundfrequenz. bei aktivierter Fahrwegsteuerung: Zielzählerstand erreichet | BOOLEAN | RO | 0x00 (0dez)
6000:02 | Ramp active | Eine Rampe wird momentan durchfahren | BOOLEAN | RO | 0x00 (0dez)
6000:07 | Error | Allgemeines Fehlerbit, wird zusammen mit Overrange und Underrange gesetzt | BOOLEAN | RO | 0x00 (0dez)
6000:0E | Sync error | Das Sync Error Bit wird nur für den Distributed Clocks Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6000:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 6010 ENC Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6010:0 | ENC Inputs | Max. Subindex | UINT8 | RO | 0x12 (18dez)
6010:02 | Latch extern valid | Der Zählerstand wurde über den externen Latch-Eingang verriegelt. Die Daten mit dem Index 6010:12 entsprechen dem gelatchten Wert bei gesetztem Bit. Um den Latch-Eingang neu zu aktivieren, muss Index 7010:02 bzw. Objekt-Index 7010:04 erst zurückgenommen und dann neu gesetzt werden. | BOOLEAN | RO | 0x00 (0dez)
6010:03 | Set counter done | Zähler wurde gesetzt. | BOOLEAN | RO | 0x00 (0dez)
6010:04 | Counter underflow | Tritt ein Unterlauf (0 -> 65535) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler zwei Drittel des Messbereichs unterschreitet (43690 -> 43689) oder sobald ein Überlauf auftritt. | BOOLEAN | RO | 0x00 (0dez)
6010:05 | Counter overflow | Tritt ein Überlauf (65535 -> 0) des 16-Bit Zählers auf, so wird dieses Bit gesetzt. Es wird zurückgesetzt wenn der Zähler ein Drittel des Messbereichs überschreitet (21845 -> 21846) oder sobald ein Unterlauf auftritt. | BOOLEAN | RO | 0x00 (0dez)
6010:0D | Status of extern latch | Der Zustand des Latch-Eingangs | BOOLEAN | RO | 0x00 (0dez)
6010:0E | Sync error | Das Sync Error Bit wird nur für den Distributed Clocks Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6010:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6010:11 | Counter value | Zählerstand | UINT32 | RO | 0x00000000 (0dez)
6010:12 | Latch value | Latch-Wert | UINT32 | RO | 0x00000000 (0dez)
Index 6020 PLS Inputs
Index | Name | Bedeutung | Datentyp | Flags | Default
6020:0 | PLS Inputs | Max. Subindex | UINT8 | RO | 0x10 (16dez)
6020:01 | PLS Enabled | Automatische Zählfunktion aktiviert | BOOLEAN | RO | 0x00 (0dez)
6020:04 | Status of output | Status des Ausgangs | BOOLEAN | RO | 0x00 (0dez)
6020:0E | Sync error | Das Sync Error Bit wird nur für den Distributed Clocks Mode benötigt und zeigt an, ob in dem abgelaufenen Zyklus ein Synchronisierungsfehler aufgetreten ist. | BOOLEAN | RO | 0x00 (0dez)
6020:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
Index 7000 PTO Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7000:0 | PTO Outputs | Max. Subindex | UINT8 | RO | 0x12 (18dez)
7000:01 | Frequency select | Schnelle Umschaltung der Grund-Frequenz (nur bei deaktivierter Rampenfunktion) 0bin = Grundfrequenz 1 (Objekt 8000:12) 1bin = Grundfrequenz 2 (Objekt 8000:13) | BOOLEAN | RO | 0x00 (0dez)
7000:02 | Disable ramp | Die Rampenfunktion wird aufgehoben, trotz aktivem Objekt 8000:06; ist die Fahrwegsteuerung aktiv, wird sie durch dieses Bit abgebrochen. | BOOLEAN | RO | 0x00 (0dez)
7000:03 | Go counter | Bei aktivierter Fahrwegsteuerung (Objekt 8000:0A) wird bei gesetztem Bit auf einen vorgegebenen Zählerwert gefahren | BOOLEAN | RO | 0x00 (0dez)
7000:11 | Frequency value | Frequenzwert | UINT16 | RO | 0x0000 (0dez)
7000:12 | Target counter value | Zielzählerstand | UINT32 | RO | 0x00000000 (0dez)
Index 7010 ENC Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7010:0 | ENC Outputs | Max. Subindex | UINT8 | RO | 0x11 (17dez)
7010:02 | Enable latch extern on positive edge | Das externe Latch mit positiver Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:03 | Set counter | Zählerstand setzen | BOOLEAN | RO | 0x00 (0dez)
7010:04 | Enable latch extern on negative edge | Das externe Latch mit negativer Flanke aktivieren. | BOOLEAN | RO | 0x00 (0dez)
7010:11 | Set counter value | Dies ist der über „Set counter“ (Index 7010:03) zu setzende Zählerstand. | UINT32 | RO | 0x00000000 (0dez)
Index 7020 PLS Outputs
Index | Name | Bedeutung | Datentyp | Flags | Default
7020:0 | PLS Outputs | Max. Subindex | UINT8 | RO | 0x12 (18dez)
7020:01 | Enable PLS | Automatische Zählfunktion aktivieren | BOOLEAN | RO | 0x00 (0dez)
7020:04 | Output | Signal am Ausgang | BOOLEAN | RO | 0x00 (0dez)
7020:11 | Switch on value | Zählerwert, bei dem der Output 24 V eingeschaltet wird | UINT32 | RO | 0x00000000 (0dez)
7020:12 | Switch off value | Zählerwert, bei dem der Output 24 V ausgeschaltet wird | UINT32 | RO | 0x00000000 (0dez)
Index F000 Modular device profile
Index | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0003 (3dez)
Index F008 Code word
Index | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | Max. Subindex | UINT8 | RW | 0x03 (3dez)
F010:01 | SubIndex 001 | reserviert | UINT32 | RW | 0x000000FD (253dez)
F010:02 | SubIndex 002 | reserviert | UINT32 | RW | 0x000001FF (511dez)
F010:03 | SubIndex 003 | reserviert | UINT32 | RW | 0x00000200 (512dez)


EtherCAT AL Status Codes

Error Code 0x0000

Meaning:

No error

Description | Current State (or state change) | Resulting State | Solution
No error | Any | Current state |

Error Code 0x0001

Meaning:

Unspecified error
Description | Current State (or state change) | Resulting State | Solution
No error code is defined for occurred error. | Any | Any + E | Read user manual or contact device manufacturer

Error Code 0x0002

Meaning:

No Memory
Description | Current State (or state change) | Resulting State | Solution
Less hardware memory, slave need more memory. | Any | Any + E | Download smaller files or objects Check user manual
Example: For slave configuration, application configuration files are downloaded (possibly via FoE or large CoE objects). The size of those files exceeds the local memory.

Error Code 0x0011

Meaning:

Invalid requested state change
Description | Current State (or state change) | Resulting State | Solution
The EtherCAT State Machine (ESM) defines which state changes are allowed. All other state changes are not allowed. | P→S, I→O, P→O, O→B, S→B, P→B | Current State + E | Go step-by-step from the original state to the desired state.
Example: If the master requests the slave to go from OP (AL Control = 0x08) directly to BOOT (AL Control = 0x03).

Error Code 0x0012

Meaning:

Unknown requested state change
Description | Current State (or state change) | Resulting State | Solution
The ESM defines the following states. They are coded with fixed values (only lower (=right) nibble): BOOT: AL Control = 0x03 INIT: AL Control = 0x01 PREOP: AL Control = 0x02 SAFEOP: AL Control = 0x04 OP: AL Control = 0x08 The fifth bit of the AL Control (left nibble is 1) is the “Error Acknowledge Bit”. If the slave is in AL STATUS = 0x14, i.e. ERROR SAFEOP the master acknowledges this by setting the Acknowledge bit | Any | Current State + E | Do only request the defined states
Example: If any other value for AL Control than those specified are sent.

Error Code 0x0013

Meaning:

Boot state not supported
Description | Current State (or state change) | Resulting State | Solution
Device does not support BOOT state, but the master requests the slave to go to BOOT (AL Control = 0x03) | I→B | I + E |

Error Code 0x0014

Meaning:

No valid firmware
Description | Current State (or state change) | Resulting State | Solution
This error code may be returned after a firmware download, if the downloaded file cannot be used by the application controller. | I→P | I + E | Download a firmware that can be supported by the hardware and bootloader. Check Product Code and Revision Number (CoE object 0x1018). If this cannot be read from the firmware any more you may see this in the network configuration (CoE object dictionary) or probably in the ESI file (element Profile: ObjectDictionary:Objects:Object).

Error Code 0x0015

Meaning:

Invalid mailbox configuration
Description | Current State (or state change) | Resulting State | Solution
Mailbox communication (= acyclic parameter exchange) is done via two memory areas on the EtherCAT Slave Controller (ESC) – the “Output Mailbox” (master -> slave) and the “Input Mailbox” (slave-> master). Those memory areas are protected by SyncManagers to prevent from simultaneous access from master and salve controller at the same time. SyncManagers are hardware entities on the ESC. They are configured via certain registers in the ESC register area (starting at 0x0800). The configuration includes start address, length, and direction (output or input). If those settings differ from those expected by the host controller of the slave this error is returned. | I→B |  | Replace previous network description of old slave with the one of the new slave.

Error Code 0x0016

Meaning:

Invalid mailbox configuration
Description | Current State (or state change) | Resulting State | Solution
Example: The slave hardware was replaced while the network configuration remained unchanged. The new hardware expects different mailbox SyncManager settings. | I→P | I + E | Replace previous network description of old slave with the one of the new slave.

Error Code 0x0017

Meaning:

Invalid Sync Manager configuration
Description | Current State (or state change) | Resulting State | Solution
Process data communication (cyclic communication) is done via extra memory areas on the ESC, separated for outputs and inputs. The process data length and the process data SyncManager length have to be the same. If this is not the case or the start address or direction does not match this error is returned. | P→S, S→O | Current State + E | Issue a re-calculation of the EtherCAT configuration.
Example: The process data configuration was changed of the slaves which also changed the length of the data. The change was not activated in the configuration so that the configuration tool would have recalculated the SyncManager settings.

Error Code 0x0018

Meaning:

No valid inputs available
Description | Current State (or state change) | Resulting State | Solution
The slave application cannot provide valid input values. | O, S→O | S + E |
Example: A certain hardware which needs to be connected to the slave was disconnected.

Error Code 0x0019

Meaning:

No valid outputs available
Description | Current State (or state change) | Resulting State | Solution
The slave application cannot recieve valid output values. | O, S→O | S + E | The RxPdoToggle may need to be handled by the PLC program The outputs valid may have to be set by the PLC program PLC may have stopped, restart PLC
Example: The slave has a RxPdoToggle output or an “Output Valid” information in its process data. The RxPdoToggle does not toggle or the OutputValid is not true. Therefore the slave has no process data which the application can use. If supported, check the RxPDO Toggle Failed Counter in object 0x1C3x.0E). Also, the Synchronization may have problems (see object 0x10F1:SI2 Sync Error Counter Limit) so that process data are received too late by the slave so that the local slave cycle misses the toggle event. Another reason can be that the PLC stopped working.

Error Code 0x001A

Meaning:

Synchronization error
Description | Current State (or state change) | Resulting State | Solution
If too many RxPDO Toggle error occure, i.e. the RxPDO Toggle Failed Counter increases the internal limit the slave returns to SAFEPERROR with 0x001A. Multiple synchronization errors. Device is not synchronized any more (used if the causes mirrored by the AL Status Codes 0x2C, 0x2D, 0x32, 0x33, 0x34 cannot be distinguished). | O, S→O | S + E |

Error Code 0x001B

Meaning:

Sync manager watchdog
Description | Current State (or state change) | Resulting State | Solution
The slave did not receive process data within the specified watchdog time. Usually, the WD time is 100ms. The WD is re-started every time it receives new process data, usually when the Output SyncManager (SyncManager2) is written. For devices which have only inputs usually no WD is used. Increasing the WD is not a solution. Reason: PLC stopped | O, S | S + E |

Error Code 0x001C

Meaning:

Invalid Sync Manager Types
Description | Current State (or state change) | Resulting State | Solution
 | O, S, O, P→S | S + E |

Error Code 0x001D

Meaning:

Invalid Output Configuration
Description | Current State (or state change) | Resulting State | Solution
SM configuration for output process data is invalid. | O, S, O, P→S | S + E |

Error Code 0x001E

Meaning:

Invalid Input Configuration
Description | Current State (or state change) | Resulting State | Solution
SM configuration for input process data is invalid | O, S, O, P→S | S + E |

Error Code 0x001F

Meaning:

Invalid Watchdog Configuration
Description | Current State (or state change) | Resulting State | Solution
The Watchdog is configured in the ESC register 0x0400 and 0x0420. EtherCAT defines default watchdog settings (100ms) or they are defined in the ESI file. If the slave does not accept a change of the expected settings it returns this AL Status Code Example: A slave may not accept that the WD is deactivated. | O, S, O, P→S | P + E | Use default WD settings.

Error Code 0x0020

Meaning:

Slave needs cold start
Description | Current State (or state change) | Resulting State | Solution
Slave device require a power off - power on reset | Any | Current State + E |

Error Code 0x0021

Meaning:

Slave needs INIT
Description | Current State (or state change) | Resulting State | Solution
Slave application requests INIT state | B, P, S, O | Current State + E |

Error Code 0x0022

Meaning:

Slave needs PREOP
Description | Current State (or state change) | Resulting State | Solution
Slave application requests PREOP state | S, O | S + E, O + E |

Error Code 0x0023

Meaning:

Slave needs SAFEOP
Description | Current State (or state change) | Resulting State | Solution
Slave application requests SAFEOP state | O | O + E |

Error Code 0x0024

Meaning:

Invalid Input Mapping
Description Current State (or state change) Resulting State Solution
The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign).

PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm.

PdoAssign: The list of PDOs (object index 0x16nn, 0x1Amm) which are actually part of the process data and hence, are transferred cyclically, are listed in the PDO Assign Objects 0x1C12 (output PDOs) and 0x1C13 (input PDOs). All this can be seen in the SystemManager on the TAB “Process Data”. If the mapping which was set by the user on the Process Data tab and which was expected by the slave do not match this Status Code is returned.

P→S

P + E

Error Code 0x0025

Meaning:

Invalid Output Mapping
Description | Current State (or state change) | Resulting State | Solution
The process data are described by the configuration (PdoConfig) and PDO assignment (PdoAssign). PdoConfig: list of actual variables (usually indexes 0x6nnn for inputs and 0x7nnn for outputs). Variables are also called PDO entries. There can be one or several variables with in one list (i.e. within one PDO). The Input PDOs have the index 0x1Amm. The Output PDOs have the index 0x16mm. Example: Slave does only support one or certain PDO combinations but a different setting was made by the user. For a bus coupler the connected terminals differ from the configured terminals in the SystemManager. | P→S | P + E |

Error Code 0x0026

Meaning:

Inconsistent Settings
Description | Current State (or state change) | Resulting State | Solution
General settings mismatch | P→S | P + E |

Error Code 0x0027

Meaning:

Freerun not supported
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0028

Meaning:

Synchronization not supported
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0029

Meaning:

Freerun needs 3 Buffer Mode
Description | Current State (or state change) | Resulting State | Solution
FreeRun mode, SM has to run in 3-buffer mode | P→S | P + E |

Error Code 0x002A

Meaning:

Background Watchdog
Description | Current State (or state change) | Resulting State | Solution
 | S, O | P + E |

Error Code 0x002B

Meaning:

No Valid Inputs and Outputs
Description | Current State (or state change) | Resulting State | Solution
 | O, S→O | S + E |

Error Code 0x002C

Meaning:

Fatal Sync Error
Description | Current State (or state change) | Resulting State | Solution
The hardware interrupt signal (so called Sync signal) generated by the ESC is not generated any more. The master sets and activated the cycle time of the Sync signal during state transition from PREOP to SAFEOP. If a slave was disconnected and reconnected (also due to lost frames or CRC errors) the generation of the SyncSignal may be lost. | O | S + E | Set master to INIT and back to OP so that the DCs are initialized again.

Error Code 0x002D

Meaning:

ana

Description | Current State (or state change) | Resulting State | Solution
SyncSignal not received: In SAFEOP the slave waits for the first Sync0/Sync1 events before switching to OP, if these events were not received during the SAFEOP to OP-Timeout time the slave refuses the state transition to OP. |  |  |

Error Code 0x0030

Meaning:

Invalid DC SYNC Configuration
Description | Current State (or state change) | Resulting State | Solution
Distributed Clock Configuration is invalid due to application requirements. | O, S→O, P→S | P + E, S + E |

Error Code 0x0031

Meaning:

Invalid DC Latch Configuration
Description | Current State (or state change) | Resulting State | Solution
DC Latch configuration is invalid due to application requirements. | O, S→O, P→S | P + E, S + E |

Error Code 0x0032

Meaning:

PLL Error
Description | Current State (or state change) | Resulting State | Solution
Master not synchronized, at least one DC event recieved. | O, S→O | S + E |

Error Code 0x0033

Meaning:

DC Sync IO Error
Description | Current State (or state change) | Resulting State | Solution
Multiple Synchronization Errors: At least one SycnSignal was received before. However, the PLL between slave and master is not synchronized any more. This may occur if the master application jitters too much. | O, S→O | S + E | Use specific industrial pc, standard office PCs may have power saving options, graphic accelerateds and other system services which disturb the real-time of the master CPU power may be too small for the PLC/NC program Increas EtherCAT and PLC/NC cycle time Use SyncUnits for the slaves using DCs

Error Code 0x0034

Meaning:

DC Sync Timeout Error
Description | Current State (or state change) | Resulting State | Solution
Multiple Synchronization Errors, too much SM events missed | O, S→O | S + E |

Error Code 0x0035

Meaning:

DC Invalid Sync Cycle Time
Description | Current State (or state change) | Resulting State | Solution
 | P→S | P + E |

Error Code 0x0036

Meaning:

DC Sync0 Cycle Time
Description | Current State (or state change) | Resulting State | Solution
DC Sync0 cycle time does not fit to the application requirements | P→S | P + E |

Error Code 0x0037

Meaning:

DC Sync1 Cycle Time
Description | Current State (or state change) | Resulting State | Solution
DC Sync1 cycle time does not fit to the application requirements | P→S | P + E |

Error Code 0x0041

Meaning:

MBX_AOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0042

Meaning:

MBX_EOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0043

Meaning:

MBX_COE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0044

Meaning:

MBX_FOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0045

Meaning:

MBX_SOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x004F

Meaning:

MBX_VOE
Description | Current State (or state change) | Resulting State | Solution
 | B, P, S, O | Current State + E |

Error Code 0x0050

Meaning:

EEPROM No Access
Description | Current State (or state change) | Resulting State | Solution
EEPROM not assigned to PDI | Any | Any + E |

Error Code 0x0051

Meaning:

EEPROM Error
Description | Current State (or state change) | Resulting State | Solution
EEPROM access error | Any | Any + E |

Error Code 0x0060

Meaning:

Slave Requested Locally
Description | Current State (or state change) | Resulting State | Solution
 | Any | I |

Error Code 0x0061

Meaning:

Device Identification Value updated
Description | Current State (or state change) | Resulting State | Solution
 | P | P + E |

Error Code 0x00F0

Meaning:

Application Controller available
Description | Current State (or state change) | Resulting State | Solution
 | I |  |


UL Hinweise

Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
For devices with Ethernet connectors
Not for connection to telecommunication circuits.

Grundlagen

Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:

  • UL-Zertifikation nach UL508
    Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen

  • UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme
    Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen

Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.

Anwendung

Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung

  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!

Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Feldbuskomponenten - ATEX-Dokumentation

BECKHOFF Feldbuskomponenten: Montage und Verdrahtung

ATEX-Dokumentation

Hinweis 		Hinweise zum Einsatz des Busklemmensystems in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz des Busklemmen-Systems in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Firmware Kompatibilität

Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.

Anmerkung

  • Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
  • Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.

Achtung 		Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.

Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen!
Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!

EL2521
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
02 | 03 | EL2521-0000-0016 | 2008/08
02 - 05 | 04 |  | 2008/09
 | 05 |  | 2008/09
05 - 12 | 06 | EL2521-0000-0018 | 2009/01
 | 07 | EL2521-0000-0019 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
13* | 10 |  | 2012/04
 |  | EL2521-0000-0020 | 2012/05
 |  | EL2521-0000-0021 | 2012/07
 | 11* |  | 2014/05
EL2521-0024
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
05 - 13* | 06 | EL2521-0024-0016/17 | 2009/01
 | 07 | EL2521-0024-0018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-0024-0019 | 2012/05
 |  | EL2521-0024-0020 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-0024-0020 | 2014/11
EL2521-0124
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
05 - 06 | 01 | EL2521-0124-0016 | 2009/09
 | 02 |  | 2010/03
 | 03 | EL2521-0124-0017 | 2010/06
06 -12* | 04 | EL2521-0124-0018 | 2011/01
 | 05 |  | 2011/04
 |  | EL2521-0124-0019 | 2011/05
 |  | EL2521-0124-0020 | 2011/07
 | 06* |  | 2014/06
EL2521-0025
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
00 - 06* | 06 | EL2521-1025-0016/17 | 2009/12
 | 07 | EL2521-1025-0018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-1025-0019 | 2012/05
 |  | EL2521-1025-0020 | 2012/07
 | 11* |  | 2014/05
 |  | EL2521-1025-0021 | 2014/11
EL2521-1001
Hardware (HW) | Firmware | Revision-Nr. | Releasedatum
02 | 03 | EL2521-1001-1016 | 2008/08
02 - 05 | 04 |  | 2008/09
 | 05 |  | 2008/09
05 - 12* | 06 | EL2521-1001-1017 | 2009/01
 | 07 | EL2521-1001-1018 | 2011/01
 | 08 |  | 2011/04
 | 09 |  | 2011/04
 | 10 |  | 2012/04
 |  | EL2521-1001-1019 | 2012/05
 |  | EL2521-1001-1020 | 2012/07
 | 11* |  | 2014/05

*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


EtherCAT - Firmware

BECKHOFF EtherCAT: Device Update

Firmware EL/ES/EM/EPxxxx

In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.

Inhaltsverzeichnis
• Speicherorte
• Gerätebeschreibung ESI-File/XML
• Versionsbestimmung Firmware
• Update Controller-Firmware *.efw
• Update FPGA-Firmware *.rbf
• Mehrfaches Update

Speicherorte

In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:

  • Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
  • In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
  • Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung zu speichern, in einem sog. EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien (EtherCAT Slave Information) als Zip-Datei zugänglich.

Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.

Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
  • Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
  • Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
  • Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!

Gerätebeschreibung ESI-File/XML

Achtung 		ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.

Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:

Abb. 1: Gerätekennung aus Name EL3204-0000 und Revision -0016

Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.

Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.

Hinweis 		Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes.
Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.

Anzeige der Slave-Kennung ESI

Der einfachste Weg, die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/Freerun das Scannen der EtherCAT-Boxen auszuführen:

Abb. 2: Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes

Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint

Abb. 3: Konfiguration identisch

ansonsten ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.

Abb. 4: Änderungsdialog

In diesem Beispiel in Abb. 4. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.

Änderung der Slave-Kennung ESI

Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:

  • Einwandfreie EtherCAT-Kommunikation muss zum Slave hergestellt werden
  • Der State des Slave ist unerheblich
  • Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. 5

Abb. 5: EEPROM Update

Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. 6. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave'.

Abb. 6: Auswahl des neuen ESI

Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Verifying.

Hinweis 		Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen.
Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.

Versionsbestimmung der Firmware

Versionsbestimmung nach Laseraufdruck

Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH

KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand

Beispiel mit Ser. Nr.: 12 10 03 02:

12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).

Hinweis 		CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
  • online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt.
    Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
  • offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein.
    Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.

In Abb. 7 wird der FW-Stand der markierten EL3204 in CoE-Eintrag x100A mit 03 angezeigt.

Abb. 7: Anzeige FW-Stand EL3204

TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.

Update Controller-Firmware *.efw

Hinweis 		CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.

Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. 8.

Abb. 8: Firmware Update

Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.

  • Slave in INIT schalten (A)
  • Slave in BOOTSTRAP schalten
  • Kontrolle des aktuellen Status (B, C)
  • Download der neuen *efw-Datei
  • Nach Beendigung des Download in INIT schalten, dann in OP
  • Slave kurz stromlos schalten

FPGA-Firmware *.rbf

Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.

  • Controller-Firmware für die Aufbereitung der E/A-Signale
  • FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)

Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.

Versionsbestimmung mit dem System-Manager

Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.

Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.

Abb. 9: Versionsbestimmung FPGA-Firmware

Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.

Abb. 10: Kontextmenu "Eigenschaften" (Properties)

In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.

Abb. 11: Dialog "Advanced settings"

Update

Für das Update der FPGA-Firmware

  • eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
  • einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.

Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!

Update eines EtherCAT-Geräts

Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.

Abb. 12: Dialog "Weitere Eimstellungen" wählen

Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,

Abb. 13: Dialog "Schreibe FPGA" wählen

Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.

Achtung 		ACHTUNG: Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen!

Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!

Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.

Gleichzeitiges Update mehrerer EtherCAT-Geräte

Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Vorraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.

Abb. 14: mehrfache Selektion und FW-Update

Wählen Sie dazu die betreffenden Slaves aus und führen Sie den FW-Update im BOOTSTRAP Modus wie o.a. aus.


ELxxxx - Wiederherstellen des Auslieferungszustandes

BECKHOFF ELxxxx: Konfiguration

Wiederherstellen des Auslieferungszustandes

Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt "Restore default parameters", Subindex 001angewählt werden (s. Abb. 1)

Abb.1 Auswahl des PDO "Restore default parameters"

Durch Doppelklick auf "SubIndex 001"gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld "Dec" den Wert "1684107116" oder alternativ im Feld "Hex" den Wert "0x64616F6C" ein und bestätigen Sie mit "OK" (Abb. 2).

Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.

Abb.2 Eingabe des Restore-Wertes im Set Value Dialog

Hinweis 		Alternativer Restore-Wert

Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen:

Dezimalwert: "1819238756"

Hexadezimalwert: "0x6C6F6164"

Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.