EL2212 - Zweikanalige Digital Ausgangsklemme 24..72 V DC mit Übererregung und Timestamp
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.3
▪
Update Kapitel "Grundlagen zur Funktion“
▪
Update Kapitel "Objektbeschreibung und Parametrierung"
▪
Strukturupdate
▪
Update Revisionsstand
2.2
▪
Update Kapitel "Inbetriebnahme", „Beispielprogramme“
2.1
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Korrektur Technische Daten
▪
Update Kapitel "TwinCAT 2.1x" -> Kapitel "TwinCAT Entwicklungsumgebung" und Kapitel "TwinCAT Quick Start"
▪
Update Revisionsstand
2.0
▪
Migration
▪
Ergänzung neuer Features zu FW 08 (Externe PWM, Multi-Timestamp)
▪
Beispielprogramm 2 hinzugefügt
▪
Anwendungsdemonstration 1 und 2 sowie Kapitel „Technologie: PWM und induktive Last“ überarbeitet
▪
Kapitel „Weitere Eigenschaften“ ergänzt
▪
„Detaillierte Erläuterung zu Enable time check/ Force order“ im Kapitel „Prozessdaten“ hinzugefügt
1.2
▪
Update Kapitel "Prozessdaten"
▪
Update Kapitel "Prozessdatenvorauswahl"
▪
Update Kapitel "Objektbeschreibung und Parametrierung"
1.1
▪
Update Kapitel "Technische Daten"
1.0
▪
Ergänzungen & Korrekturen, 1. Veröffentlichung
0.2 - 0.6
▪
Ergänzungen & Korrekturen
0.1
▪
vorläufige Dokumentation für EL2212


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL2212 - Einführung
•
EL2212 - Technische Daten
•
Technologie: PWM und induktive Last
•
Start Up


EL2212 - Einführung

Produktübersicht [image] EL2212 - Einführung
EL2212 - Einführung
Zweikanalige Digital Ausgangsklemme 24..72 V DC mit Übererregung und Timestamp
Die digitale Ausgangsklemme EL2212 schaltet die binären Steuersignale des Automatisierungsgerätes – galvanisch getrennt zur Prozessebene – an die Aktoren weiter. Ab FW04 unterstützt sie auch das Multitimestamp-Verfahren - durch Multi-Timestamp können zudem in jedem EtherCAT-Zyklus so viele Ereignisse pro Kanal einzeln ausgegeben werden, wie im internen Buffer vorgeladen wurden.
Sie ist für mechanische Aktoren, z. B. Ventile oder Relais geeignet, die besonders schnell geschaltet werden sollen. Zu diesem Zweck wird die Klemme mit einer höheren Betriebsspannung gespeist, als der Nennspannung des Aktors entspricht. Im Einschaltmoment wird diese Spannung für einige Millisekunden an den Aktor weitergegeben und sorgt dort durch den entsprechend erhöhten Laststrom für dynamisches Schalten. Einstellungsgemäß schaltet sie dann automatisch in einen stromregelnden PWM-Modus, senkt den Haltestrom ab und reduziert damit insbesondere die Verlustleistung. Das Abschalten der Last und damit ggf. die mechanische Rückbewegung wird durch ein aktives Umpolen der Betriebsspannung erheblich beschleunigt. Die gesamte Dynamik des Schaltvorgangs wird im CoE der Klemme parametriert. Das An-/Abschalten wird über die Prozessdaten gesteuert.
Zusätzlich ist es möglich, mit einer übergeordneten An/Aus-Steuerung, der sog. „externen PWM“, den Aktor pulsierend zu betreiben um z.B. eine dauerhafte ON-Schaltung zu vermeiden (Langsamfahrschutz).
Die EL2212 kann als normale 2-kanalige Ausgangsklemme betrieben werden. Sie schaltet also nach Empfang der Prozessdaten. Als weitere Betriebsart kann die Klemme auch mit Distributed Clocks und Timestamp-Funktion wie die EL2252 betrieben werden und schaltet die Ausgänge dann mit der Nanosekunden-genauen Distributed-Clocks-Präzision unabhängig vom Buszyklus. Dadurch ist die zeitsynchrone Zusammenarbeit mit anderen Klemmen im Distributed-Clocks-System möglich.
Die EL2212 enthält zwei Kanäle, deren Signalzustand durch Leuchtdioden angezeigt wird.


EL2212 - Technische Daten

Produktübersicht [image] EL2212 - Technische Daten
EL2212 - Technische Daten
Technische Daten | EL2212
Anzahl der Ausgänge | 2
Nennlastspannung | 24 .. 72 V DC (-15%/+0%)
Lastart | induktiv > 1 mH
Auflösung Time Stamp | 1 ns
Genauigkeit Time Stamp in der Klemme | 10 ns (+ Ausgangsschaltungsdrift)
Distributed Clocks | ja
Genauigkeit der Distributed Clocks | << 1 µs
Ausgangsstrom (je Kanal) | Peakstrom: max. 10 A Peakstrom "Boost-On-Phase" je Kanal Haltestrom: 0,2 .. 2,5 A je Kanal
Kurzschlussstrom | Ausgang kurzschlussgeschützt, typ. 12 A
Verpolungsschutz | nein
Schaltzeiten | ohne Distributed Clocks: TON/TOFF: 20 µs typ. mit Distributed Clocks: TON/TOFF: < 1 µs typ. durch interne Kompensation (siehe Hinweise Delay)
Ausgangsstufe | Vollbrücke (Push/Pull)
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 120 mA
Stromaufnahme Powerkontakte (Versorgungskontakte) | abhängig von Last und Dynamik
Potenzialtrennung | 500 Veff (E-Bus/Feldspannung)
Konfiguration | über TwinCAT System Manager
Gewicht | ca. 50 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE


Technologie: PWM und induktive Last

Produktübersicht [image] Technologie: PWM und induktive Last
Technologie: PWM und induktive Last
Interne PWM der Klemme
Die 2-Kanal-Digital-Ausgangsklemme EL2212 hat für jeden Kanal eine kompakte PWM-Endstufe in kleinster Bauform integriert, die in 3 Phasen einen bzw. zwei Aktoren ansteuert. Dabei wird in jedem Fall die angelegte Versorgungsspannung auf den Aktor durchgeschaltet. Um einen in Abhängigkeit vom ohmschen Widerstand des Aktors ggf. unzulässig zu hohen Laststrom entgegen zu wirken, wird in den verschiedenen Phasen durch Pulsweitenmodulation (PWM) die Spannung an den Aktor nur pulsierend durchgeschaltet. Im zeitlichen Mittel stellt sich dadurch am Aktor insgesamt ein geringerer Strom ein, der durch die induktive Komponente des Aktors nahezu zu einer Gleichspannung geglättet wird. Dieser Vorgang kommt bei der Klemme EL2212 zum Einsatz und erfolgt stets durch die Vorgabe des Haltestroms und der Versorgungsspannung: der vorgegebene Strom wird als Sollwert eingeregelt auch wenn die Versorgungsspannung mit dem Innenwiderstand des Aktors einen weitaus größeren Laststrom ermöglicht.
Pulsweitenmodulation zur Stromregelung
Mittels PWM-Endstufe wird die Pulsweitenmodulation (PWM) der Versorgungsspannung zur Regelung des Ausgangsstroms einer angeschlossenen Ohmsch-Induktiven Last eingesetzt. Dem Ausgang wird dabei die Versorgungsspannung in voller Höhe mit einer bestimmten Frequenz pulsierend zugeführt. Nur mit dem High -Pegel baut sich an der Induktivität ein Laststrom auf. Eine Änderung des Laststroms erfolgt nun nicht durch Änderung der Spannungshöhe, sondern durch die Dauer des Ausschaltens (Pulsweite) im Verhältnis zur Periodendauer. Dies ergibt ein Tastverhältnis von Pulsweite dividiert durch Periodendauer entsprechend zwischen 0 bis 100 % und ist proportional zum Laststrom.
Betrieb an Last mit ausreichend großer Induktivität
Betrieb an Last mit zu kleiner Induktivität (nahezu ohmsch)
In der Abbildung „Betrieb an Last mit zu kleiner Induktivität“ ist zur Veranschaulichung der Betrieb mit einer nicht ausreichend großen Induktivität dargestellt. Ein kontinuierlicher Stromfluss kommt nicht zustande. Der Strom "lückt". Diese Betriebsart ist nicht zulässig.
Pulsweitenstromklemmen benötigen induktive Lasten
Die Induktivität der Last sollte mindestens 1 mH betragen! Ein Betrieb der Pulsweitenstromklemmen an Lasten mit einer Induktivität von weniger als 1 mH wird nicht empfohlen, weil auf Grund des unterbrochenen Stromflusses kein Bezug zwischen dem Sollwert und dem arithmetischen Mittelwert des Stroms gegeben ist!


Start Up

Produktübersicht [image] Start Up
Start Up
Zur Inbetriebsetzung:
▪
montieren Sie den EL2212 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EL2212 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Tragschienenmontage
•
Hinweise zur Strommessung über Hall-Sensor
•
Anschlusstechnik
•
Positionierung von passiven Klemmen
•
Einbaulagen
•
UL-Hinweise
•
EL2212 - Anschlussbelegung


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Hinweise zur Strommessung über Hall-Sensor

Montage und Verdrahtung [image] Hinweise zur Strommessung über Hall-Sensor
Hinweise zur Strommessung über Hall-Sensor
Das in dieser Dokumentation angesprochene Gerät verfügt über einen oder mehrere integrierte Hall-Sensoren zur Strommessung.
Dabei wird das magnetische Feld, das durch einen Stromfluss durch einen Leiter erzeugt wird, von dem Hall-Sensor quantitativ erfasst.
Um die Messung nicht zu beeinträchtigen wird empfohlen, äußere Magnetfelder vom Gerät abzuschirmen oder hinreichend weit entfernt zu halten.
Hintergrund
Ein stromdurchflossener Leiter erzeugt in seinem Umfeld ein magnetisches Feld nach
B = µ0 * I / (2π * d)
mit
B [Tesla] magnetisches Feld
µ0 = 4*π*10-7 [H/m] (Annahme: keine magnetische Abschirmung)
I [A] Strom
d [m] Abstand zum Leiter
Beeinträchtigung durch äußere Magnetfelder
Die magnetische Feldstärke sollte allseitig um das Gerät herum eine zulässige Größe nicht übersteigen.
Praktisch bedeutet dies für den empfohlenen Mindestabstand eines benachbarten Stromleiters zur Geräteoberfläche:
● Strom 10 A: 12 mm
● Strom 20 A: 25 mm
● Strom 40 A: 50 mm
Wenn es in der Gerätedokumentation nicht anders spezifiziert ist, ist das Aneinanderreihen von Modulen (z.B. Reihenklemmen im 12 mm Rastermaß) gleichen Typs (z.B. EL2212-0000) darüberhinaus zulässig.


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


EL2212 - Anschlussbelegung

Montage und Verdrahtung [image] EL2212 - Anschlussbelegung
EL2212 - Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
A1 | 1 | Ausgang A1 für Last A
B1 | 2 | Ausgang B1 für Last B
POWER + 24..72 V | 3 | Eingang Versorgungsspannung Last, intern verbunden mit positiven Powerkontakt
PE | 4 | PE (intern verbunden mit Klemmstelle 8 und PE Powerkontakt)
A2 | 5 | Ausgang A2 für Last A
B2 | 6 | Ausgang B2 für Last B
POWER 0 V | 7 | Eingang Versorgungsspannung Last, intern verbunden mit negativen Powerkontakt
PE | 8 | PE (intern verbunden mit Klemmstelle 4 und PE Powerkontakt)
Aufladung bei Anschluss Versorgungsspannung
In der EL2212 sind große Kapazitäten zur Sicherstellung der hohen Stoßströme enthalten. Deshalb kann es beim Anschluss an die Versorgungsspannung durch die Aufladung der Kapazitäten zu Funkenentladung am Kontaktpunkt kommen. Es wird empfohlen, zuerst die Leitungsverbindungen herzustellen, und erst dann die Spannungsversorgung (Transformator, Netzteil) einzuschalten.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Quickstart
•
Grundlagen zur Funktion
•
Anwendungshinweise
•
Prozessdaten
•
Prozessdatenvorauswahl
•
Distributed Clocks Einstellungen
•
Objektbeschreibung und Parametrierung
•
Anwendungsdemonstration 1: 12 V Relais
•
Anwendungsdemonstration 2: 24 V Druckluftventil
•
Beispielprogramme


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Quickstart

Inbetriebnahme [image] Quickstart
Quickstart
Zur Erstinbetriebnahme der EL2212 sind keine besonderen Maßnahmen erforderlich.
Die EL2212 kann mit unterschiedlichen Funktionsarten betrieben werden. Im folgende wird der Entscheidungs- und Handlungsablauf der Inbetriebnahme aufgezeigt.
Zum Verständnis sind die einführenden Kapitel zu Funktionsweise und Anwendungshinweise zu beachten.
1. Montage
Montieren Sie die EL2212 wie im Kapitel Montage und Verdrahtung beschrieben.
2. Konfiguration
Erstellen Sie eine Konfiguration im TwinCAT Systemmanager, indem Sie die Klemme manuell einfügen oder online scannen. Beachten Sie dazu das Installationskapitel TwinCAT Entwicklungsumgebung.
EtherCAT XML Device Description
Sollte in Ihrem System die XML-Beschreibung ihrer EL2212 nicht vorliegen, können Sie die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterladen (http://www.beckhoff.de/german/default.htm?download/elconfg.htm) und entsprechend der Installationsanweisungen installieren.
3. Auslieferungszustand
Die Klemme verhält sich im Auslieferungszustand bzw. nach Scannen im Systemmanager wie folgt
▪
frame-getriggert SM-synchron, kein Distributed-Clocks-Betrieb
▪
Prozessdaten Status + Control
Default Prozessdaten
Zur Ansteuerung des Aktors muss lediglich Output bedient werden.
▪
CoE-Einstellungen (hier Kanal 1)
Default CoE-Parameter
Die schnelle An- und Abschaltung sind für je 1 ms aktiviert, für den Aktor werden 24 V Versorgungsspannung, 1 Ω Innenwiderstand, 5 A Boost- und 0,5 A Haltstrom.
Diese Einstellungen sind im Folgenden auf den verwendeten Aktor anzupassen.
4. Distributed-Clocks-Betrieb
Wenn Sie Distributed-Clocks-Betrieb nutzen wollen, stellen Sie entsprechend die Prozessdaten und die Betriebsart um.
Prozessdaten für DC-Betrieb
Betriebsart DistributedClocks
Es wird für erste funktionale Aktor-Tests der Standard-Betrieb empfohlen.
5. Berechnung der Aktorspezifischen Parameter
Der Innenwiderstand des Aktors muss so beschaffen sein, dass die EL2212 unter Beachtung der anliegenden Versorgungsspannung [24 .. 72 V DC] sowohl in der Boost- wie auch in der Haltephase den empfohlenen Strombereich von [0,2 .. 10 A] erreicht.
Beispiel: Aktor mit Unenn = 12 V, Ri = 8 Ω, Inenn = 1,5 A.
Es wird ein Booststrom von 4,5 A und ein Haltestrom von 0,75 A gewählt. Für die Boostphase ist also eine Versorgungsspannung von mind. 36 V nötig.
Dauer der Boost-On- und Boost-Off-Phase werden zu je 25 ms gewählt. Die Abschaltschwelle für die Boost-Off-Phase wird auf -200 mA gesetzt.
Berücksichtigung der Mechanik
Es sind die Anwendungshinweise bei der Auslegung zu berücksichtigen.
6. Einstellen der Parameter und Prozessdaten
Prozessdaten
Zur Ansteuerung ist mindestens die Variable Output mit der PLC/Task zu verlinken. Es wird jedoch dringend empfohlen, die weiteren Variablen wie Reset und die Diagnose zu verlinken und zu nutzen.
CoE-Parameter
Die CoE-Parameter müssen nun kanalweise im CoE hinterlegt werden.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise: - StartUp-Liste führen für den Austauschfall - Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung - "CoE-Reload" zum Zurücksetzen der Veränderungen
Die Übererregung für Kanal 1 (n=0, aktivieren über Index 80n2:01) bildet sich im CoE wie folgt ab:
Spezifische CoE-Einstellung Kanal 1
Strom-Bereiche beim Ein- und Ausschalten
▪
beim Einschalten des Ausgangs (Zeitpunkt t1) wird zuerst ein Boost-Strom (Index 0x80n0:01)in den Aktor eingeprägt (Bereich A).
- Dieser Boost-Strom wird nach I = U/R nach den CoE-Angaben 0x8000:03 und 0x8000:05 vorberechnet und entsprechend ausgegeben
▪
nach Ablauf der der Zeit t2-t1 (Index 0x80n0:06) geht die Stromregelung vom Boost-Strom in den Nennstrom (Index 0x80n0:02) über (Bereich B).
- In diesem Bereich wird der tatsächliche Laststrom gemessen und durch Veränderung des Tastverhältnisses der internen PWM geregelt.
▪
Beim Ausschalten des Ausgangs (Zeitpunkt t3) wird bei aktivierter Gegenbestromung (Index 0x80n2:02) der konfigurierte Boost-Strom in negativer Richtung in den Aktor eingeprägt (Bereich C). Das Ausschalten kann in zwei verschiedenen Verhaltensweisen konfiguriert werden. Hierfür wird der aktuelle Aktorstrom gemessen und ausgewertet.
- Ist die Abschaltschwelle des Aktorstroms deaktiviert (Index 0x80n2:03 = FALSE), wird nach Ablauf der Zeit t4-t3 (Index 0x80n0:07) die Treiberstufe in den Freilauf geschaltet.
- Ist sie im anderen Fall aktiviert (Index 0x8002:03 = TRUE), überwacht die Klemme zwei Zustände: das Ablaufen der Zeit und das Unterschreiten des eingestellten Schwellwertes (Index 0x80n0:08). Beim Auftreten einer der beiden Bedingungen wird hier die Treiberstufe in den Freilauf geschaltet. Der Schwellwert kann auch negative Werte annehmen, um das sichere Abschalten des angeschlossenen Aktors zu gewährleisten.
Für eine gut funktionierende und schnelle Stromregelung müssen die Versorgungsspannung (Index 0x80n0:03) und der Innenwiderstand des Aktors (Index 0x8000:05) genau eingestellt werden. Die beiden Werte werden zur Berechnung der Vorsteuerung herangezogen. Das bedeutet, je besser die Vorsteuerung eingestellt ist, desto weniger muss der Stromregler nachregeln.
Die Regelfaktoren (Kp, Ki, Index 0x80n1:01; 0x80n1:02) sollten im Normalfall nicht verändert werden, da die Standardeinstellung für die meisten Anwendungen ausreichend ist.
Für Kanal 2 sind die entsprechenden Werte in Index 0x8010, 0x8011 und 0x8012 zu verändern.
Es können für jeden Kanal unterschiedliche Werte angegeben werden.
Die Einstellungen können auch über die SPS/PLC/Task zur Laufzeit geladen werden.
7. Betrieb
Wenn der Aktor angeschlossen ist, wird nun bei jeder Aus/An/Aus-Betätigung der parametrierte Stromverlauf ausgegeben.


Grundlagen zur Funktion

Inbetriebnahme [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Die EL2212 nutzt das Prinzip der Pulsweitenmodulation, um eine induktive Schalt-Last in 3 Phasen
▪
in der Einschaltphase mit einem überhöhten Anregungsstrom zu schalten, "Boost-On-Phase"
▪
in der Haltephase mit einem Haltestrom deutlich unterhalb des Anregungsstroms zu halten
▪
in der Abschaltphase ggf. mit Gegenbestromung die Schalt-Last abzuschalten, "Boost-Off-Phase"
Durch die Übererregung werden sowohl die aus der mechanischen Trägheit des Aktors resultierende Ansprech- wie auch Rückfallzeit, als auch verzögernde Einflüsse der elektromagnetischen Erregung verringert.
Durch den verringerten Haltestrom wird einerseits in der Last weniger Verlustwärme produziert, andererseits wird die im induktiven Aktor gehaltene magnetische Energie deutlich reduziert. Somit kann das Abschalten schneller erfolgen. Die Abhängigkeit ist dabei quadratisch, d.h. wenn der Haltestrom 50% vom Nennstrom beträgt, muss beim Abschalten nur von 25% der Energie abgebaut werden.
Auswahl des Aktors
Vor dem Hintergrund des ohmschen Gesetzes U = R x I und den Einsatzgrenzen der EL2212 (siehe folgende Tabelle und Technische Daten) ist der Aktor so nach Innenwiderstand und Nennbetriebsspannung auszuwählen, dass eine zeitliche Beschleunigung des Schaltens durch die Übererregung ermöglicht wird.
Beispiel:
•
Nennbetriebsspannung Aktor lt. Hersteller: 24V
•
Nennstromaufnahme dabei lt. Hersteller: 0,5 A
•
daraus errechnet sich ein ohmscher Widerstand von 48 Ω
•
als Boost-Strom soll der 3fache Nennstrom gewählt werden, also 1,5 A
•
nach U = R x I ist somit eine Versorgungsspannung für die EL2212 von 72 V zu wählen, die in der Boost-On-Phase für einige ms geschaltet wird
•
danach wird ein Haltestrom von 0,3 A gewählt
Weiterführende Informationen
•
Weitere Eigenschaften
•
Aktivierung der externen PWM


Weitere Eigenschaften

Inbetriebnahme [image] Grundlagen zur Funktion [image] Weitere Eigenschaften
Weitere Eigenschaften
Eigenschaft | Erläuterung
Ein/Ausschalttrigger | Das Ein/Ausschalten der Last kann auf gemeinsamer Zeitbasis mit Distributed Clocks durch Zeitstempel oder durch den EtherCAT-Frame "frame-getriggert" erfolgen.
Schaltverhalten | Die Ausgangsschaltung der EL2212 ist auf schnelle Signalausgabe auch bei höheren Strömen optimiert. Dazu verfügt die EL2212 je Kanal über eine Vollbrücke, die aktiv nach 24..72 V (positive Betriebsspannung), 0 V oder umpolend nach -24..-72 V schaltet. Die Klemme ist überstrom- und kurzschlussgesichert. Je nach Strombedarf der angeschlossenen Aktoren ist die Stromversorgung der EL2212 entsprechend zu dimensionieren - Power-Zuleitungen, Netzteil und Aktorleitungen sind entsprechend großzügig bzw. kurz zu wählen.
Tristate | Im Tristate-Betrieb kann jeder Kanal einzeln hochohmig geschaltet werden. Dieser Zustand sorgt dafür, dass sich der jeweilige Ausgang verhält als wäre er nicht verbunden und beeinflusst nicht die Ausgaben anderer Ausgänge/Geräte, die mit diesen parallel geschaltet sind. Der entsprechende Ausgang nimmt vielmehr dieselbe Ausgangspannung der aktiven anderen Geräte an.
Interne-PWM | Die Frequenz der Stromregelung bzw. die PWM-Grundfrequenz ist als „interne-PWM“ nicht veränderbar und von der externen PWM, die anwenderseitig steuerbar ist, getrennt implementiert. Die Frequenz beträgt typ. 32 kHz.
Externe-PWM | Es besteht die Möglichkeit die geschalteten Ausgänge Pulsweitenmoduliert ausgeben zu lassen. Aktivierung, Periodendauer und Tastverhältnis dieser „externen PWM“ kann mittels CoE Objekt bzw. PDO gesteuert werden (Siehe „Aktivierung der externen PWM“). Dabei schaltet die Klemme den Ausgang unabhängig von dem vorgegeben An/Aus-Zeitstempel selbsttätig ein und aus. Es sind also zeitlich 3 Ebenen zu betrachten: - On/Off-Befehl inkl. Zeitstempel aus der PLC, üblicherweise im ms-Bereich - wenn aktiviert: automatisches An/Abschalten des Ausgangs durch die Klemme im ms-Bereich = Externe PWM. Dies kann als Langsamfahrschutz des Aktors verwendet werden, damit der Aktor z.B. nicht überlange angeschaltet bleibt und ggf. beschädigt wird - schnelles PWM im kHz Bereich zur Stromregelung → „Interne-PWM“
Kurzschlussschutz | Der Kurzschlussstrom je Kanal wird auf typ. 12 A begrenzt. Die EL2212 meldet über die Prozessdaten Error und deaktiviert beide Kanäle. Ein Reset über das Control-Word setzt die Klemme zurück.
OpenLoad Detektion | Die OpenLoad Detektion ist nur bei gesetzten Ausgang und bei aktivierten Boost On/-Off nur zwischen den Boost-On und Boost-Off-Phasen aktiv. Wird nach dem Boost-On von der Klemme am jeweiligen Ausgang ein Strom kleiner 100 mA gemessen, wird dies als „OpenLoad“ erkannt. Bei permanent eingeschalteten Ausgang kann es zu einer Verzögerung der OpenLoad Detektion von ca. 500 ms kommen. Das entsprechende Bit (DOX Diag Data) 0xApp0:07 wird bei derart erkannter fehlender Last gesetzt. Bei aktivierter PWM ist diese Detektion nicht aktiv.
Eigenschaft
Erläuterung
Übertemperaturschutz
Die EL2212 ist gegen Übertemperatur geschützt. Es findet eine Innentemperaturmessung statt.
▪
Ab der Warnschwelle (einstellbar im CoE, default 80°C) wird das Warning-Bit im Status-Word gesetzt. Dies ist vom Anwender zu beachten.
Die Warnschwelle soll im normalen Betrieb nicht erreicht werden, das Erreichen ist durch entsprechende Diagnose in der PLC/Task zu detektieren!
▪
Wird diese Warnung nicht beachtet schaltet sich die Klemme bei >95 °C vollständig ab.
▪
Sobald sie unter die Abschaltschwelle abgekühlt ist, schaltet sie sich wieder ein.
Die aktuelle Klemmen-Innentemperatur und die Grenztemperatur kann über die Diagnoseelemente im CoE-Objekt 0xF900 ausgelesen werden.
Multi-Timestamping
Es können bis zu 10 unabhängige Schaltaufträge auf einen Kanal oder je zwei Kanäle in einem PLC-Taskzyklus der Klemme übergeben werden, die entsprechend den übergebenen Zeitstempeln ausgeführt werden. Aufgrund der 32 Bit breite der Zeitstempel können von der momentanen DC Zeit innerhalb der PLC-Steuerung ausgehend die zukünftigen Auftragszeiten höchsten ca. 4,29 s betragen.
Phasen-Zeiten
Sowohl Boost-On- wie auch die Boost-Off-Phase können je auf maximal 100 ms eingestellt werden.
Induktive Last
Die Spannungsspitzen beim Schalten der induktiven Last werden von der Endstufe der EL2212 wirkungsvoll kontrolliert.
Für den Fall des unkontrollierten Ausschaltens (z.B. durch Verlust der Betriebsspannung) verfügen die Ausgangskanäle über eine Überspannungsdiode von typ. 90 V zum Abbau der in der Induktivität gespeicherten und durch die Selbstinduktion abgegebenen Energie. Es kann also im Störungsfall an der Last zu entsprechend hohen Spannungen kommen. Die Last-Induktivität sollte >= 1 mH betragen.
Watchdog
Der SM-Watchdog kann deaktiviert bzw. verändert werden. Standardmäßig ist er auf 100 ms eingestellt.
Spulenwiderstand
Auf Grund der internen Berechnungen ist der max. zulässige Spulenwiderstand nach CoE-Objekt 0x80n0:05 auf 244 Ω begrenzt
Eigenschaft | Erläuterung
Aktor, empfohlener Leistungsbereich | Die Strommessung erfolgt mit einer Genauigkeit von typ. ±100 mA. Es wird deshalb empfohlen, mit Boost- und Halteströmen > 200 mA zu arbeiten. Damit ergibt sich folgender maximal zulässiger Aktor-Innenwiderstand in Abhängigkeit von der Versorgungsspannung der EL2212:
Ein/Ausschaltverzögerung, Leistungstreiber | Die Verzögerungszeit bis der Schaltauftrag über die PWM-Stufe ausgegeben wird, beträgt für Ein- und Ausschaltvorgang typ. 20 µs ohne Distributed Clocks. Bei Distributed Clocks-Betrieb wird dies intern kompensiert. Angesichts der Trägheit der Last (ms-Bereich) ist dies meist relativ vernachlässigbar. Um zeitlich höchste exakte Ansteuerung zu erreichen, kann dieser konstante Offset bei Betrieb mit Distributed Clocks berücksichtigt werden. Anschaltvorgang eines Relais, im Detail und gesamter Schaltvorgang
Minimale Zykluszeit | Die minimal zulässige Zykluszeit mit und ohne Distributed-Clocks-Betrieb beträgt 100 µs.
Firmware Update | Der Firmware Update kann nur mit angelegter Versorgungsspannung durchgeführt werden.
BoostOn Stromverlauf | Der Stromverlauf im Boost-On ist in der Inbetriebnahme von hohem Interesse. Idealerweise wird Strom/Spannung von extern mit einem Oszilloskop beobachtet. Steht dieses nicht zur Verfügung, kann folgendes Feature der EL2212 benutzt werden um den Strom in der Boost-On Phase abzuschätzen: Die EL2212 beobachtet den Strom je Kanal auch in der nicht strom-geregelten Boost-On-Phase. Der Anwender kann im CoE x80n0:0C..9E 3 Stromgrenzen (Boost Current Treshold, BCT) eingeben: Übreschreitet der Strom in der Boost-On Phase die jeweilige Grenze, zählt die Firmware entsprechend in CoE x90n0:0A..0D den BCC (Boost current counter region) hoch: Dabei gilt: BCC 1 für Current < BCT 1 BCC 2 für Current < BCT 2 BCC 3 für Current < BCT 3 BCC 4 für Current > BCT 3 Ein Rücksetzen der Zähler erfolgt durch einen EtherCAT Neustart der Klemme INIT->OP


Aktivierung der externen PWM

Inbetriebnahme [image] Grundlagen zur Funktion [image] Aktivierung der externen PWM
Aktivierung der externen PWM
Die Klemme EL2212 kann neben der zur Stromregelung internen verwendeten PWM eine Ausgangslast zusätzlich Pulsweitenmoduliert ansteuern. Indirekt kann so der Strom der Last nachträglich beeinflusst werden. Da die Klemme bereits bei der internen Stromregelung eine PWM verwendet wird diese anwenderseitig steuerbare PWM als „externe PWM“ bezeichnet.
Ausgehend von der Ansteuerung eines Relais (24 V / 200 mA) zunächst ohne aktivierter externer-PWM wird danach die Ansteuerung eines Relais mit PWM gezeigt.
Oszilloskop Aufnahme: Ansteuerung eines Relais ohne PWM
Um die externe PWM Ansteuerung der EL2212 zu aktivieren ist im „DOX Settings-“ Objekt 0x8000:09 die Periodendauer (Tperiod) und im Objekt 0x8000:0A die Ausschaltzeit (Toff) der PWM einzutragen. Weiterhin ist in dem dazugehörigen „DOX Features-„Objekt 0x8002:04 (Enable PWM Output) True einzutragen. Die Durchschaltung der PWM erfolgt mit dem PDO (0x1600) „DOX Control Channel 1“ → „PWM“ (Setzen auf „1“):
Beispielhaft sind zunächst für ein Tastverhältnis von 50% Werte von Toff/Tperiod von 2/4 ms eingetragen worden, was prinzipiell einen halben Haltestrom entspricht:
Ansteuerung eines Relais mit PWM 50%
Die NC/NO Kontakte zeigen ein späteres schalten mit prellenden Kontakten. Nach Anzug des Ankers kann dieser jedoch gehalten werden.
Bei noch kleinerem Tastverhältnis wie etwa 25% (Toff/Tperiod = 1/4 ms) wird der Relaisanker nicht mehr bewegt; mit entsprechend größerem wie etwa 75% wiederum verzögert jedoch ohne prellen:
Ansteuerung eines Relais links mit PWM 25%, rechts mit PWM 75%
Auch bei aktivierten Boost-On/Boost-Off kann die PWM hinzugeschaltet werden. Zu beachten ist, dass die Open-Load Detektion nicht mehr gegeben ist.
Eingeschränkte Fehlererkennung bei aktivierter PWM
Bei aktivierter PWM wird eine Unterbrechung der Stromzufuhr von der Klemme zur Last nicht mehr automaisch erkannt, d.h. es erfolgt im Leerlauf und aktivierten Ausgang weder das Setzen des entsprechenden Bits in DOX Diag Data noch wird ein allgemein ein Fehler angezeigt (kein Error-Bit / Error-LED).
PWM steuern mittels PDO (direkter Zugriff per PLC Programm)
Ferner können mit Zuschalten der PDO-Zuweisungen für 0x1C12 (unter Karteireiter „Process Data“) von 0x1605 (für Kanal 1) und 0x1606 (für Kanal 2) Einstellparameter für Periodendauer und Tastverhältnis den Prozessdaten hinzugefügt werden, wie folgende Abbildung zeigt:
Hinzufügen von Prozessdaten-Objekten "Duty Cycle" und "Tperiod"
Nach dem erneuten aktivieren der Konfiguration über die TwinCAT – Bedienoberfläche ist es sodann möglich die im CoE enthaltenen Werte für „Tperiod“ und „Toff“ per PDO – Zugriff zu „überschreiben“. Für den PDO-Zugriff ist kein CoE-Schreibbefehl notwendig – es können die neuen PDOs direkt mit Variablen der PLC verlinkt werden.
Zu beachten ist:
▪
Duty Cycle (PDO)
–
Mit einem „Duty Cycle“ Wert für das Tastverhältnis von „0“ kann die Ansteuerung komplett ausgeschaltet werden.
–
Ein Wert von 100 bis 255 führt zu einer PWM-freien Ansteuerung.
▪
Tperiod (PDO/CoE)
–
Wurde das PDO „PWM Tperiod“ mit den Wert „0“ beschrieben, wird wieder der Tperiod im CoE unter 0x8000:09 eingestellte Wert für die Erzeugung der PWM herangezogen.
–
Im Gegensatz zum CoE Eintrag kann über das PDO PWM Tperiod Werte kleiner 20 und damit eine PWM Frequenz von bis zu 10 kHz eingestellt werden. Der CoE Eintrag wird auf 20 *0.1 ms und damit die PWM Frequenz auf 500 Hz begrenzt.
▪
Toff (CoE)
–
Solange die PDOs (Kanal-spezifisch: 0x1605 bzw. 0x1606) über die Prozessdaten konfiguriert sind, ist der CoE Eintrag „Toff“ (0x8000:0A) ohne Wirkung.


Anwendungshinweise

Inbetriebnahme [image] Anwendungshinweise
Anwendungshinweise
Die EL2212 ist zum Betrieb induktiver elektrischer Schaltlasten geeignet wie z.B.
▪
Relais
▪
Ventil
▪
Magnetlagerspule
▪
Leimauftragskopf
▪
..
Insbesondere wenn durch die magnetische Kraft ein mechanisches Bauteil wie der Relaisanker oder der Ventilsitz bewegt werden sollen, ist eine übererregte Ansteuerung sinnvoll.
Die Ansteuerung eines induktiven Aktors mit der EL2212 beansprucht diesen in besonderer Weise. Deshalb sind u.a. folgende Hinweise zu beachten:
▪
die Herstellerangaben des Aktors für zulässigen/nominellen Strom und Spannung beziehen sich meist auf den Dauerbetrieb. In der Übererregungs/Anregungsphase wird der Aktor u.U. mit deutlich erhöhten Werten beaufschlagt.
→ Der Anwender hat durch eigene Tests oder Rückfrage beim Aktorhersteller sicherzustellen, dass der Aktor für die gewählte Betriebsart geeignet ist. Dabei sind z.B. die erhöhte Ansteuerspannung, die thermische Belastung und der mechanisch beschleunigte Schaltvorgang zu berücksichtigen.
▪
in der Haltephase wird der Aktor üblicherweise mit verringertem Haltestrom beaufschlagt. Dieser wird dann unterhalb des vom Aktorhersteller angegebenen Dauerstroms liegen.
→ Der Anwender hat durch eigene Tests oder Rückfrage beim Aktorhersteller sicherzustellen, dass der Aktor auch unter der erwarteten Vibrations- oder Schockbelastung noch genug Haltekraft besitzt. Außerdem darf die Abfallspannung/-strom nicht erreicht bzw. unterschritten werden.
▪
in der An- wie in der Abschaltphase wird der Aktor mit höheren Beschleunigungen betrieben. Dies trifft insbesondere auf den Abschaltvorgang zu.
→ Der Anwender hat durch eigene Tests oder Rückfrage beim Aktorhersteller sicherzustellen, dass das Schaltelement nicht "zurückschlägt", d.h. durch mechanisches Prellen den Schaltwunsch verfälscht. Durch Variation der Stellparameter (Phasenzeit, Stromschwelle) kann dies erreicht werden.
▪
In der Abschaltphase sollte die Abschaltstromschwelle nach 0x80n0:08 nur mit Vorsicht auf Werte < 0 gesetzt werden. Bei kleineren Aktoren kann dies das Abschalten erheblich beschleunigen, bei größeren u.U. dagegen wieder verlangsamen.
→ Der Anwender sollte durch oszillografische Maßnahmen die Wirksamkeit der Parametrierung überprüfen.
▪
Bei Verwendung der Klemme EL2212 im Nockenschaltwerk steht die Programmierbibliothek Motion Control XFC zur effektiven Nutzung zur Verfügung. Hiermit können u.a. Schaltzustände vom Schaltwerk mit präzisen Schaltzeitpunkten der Klemme direkt zugeführt werden.


Prozessdaten

Inbetriebnahme [image] Prozessdaten
Prozessdaten
Die Prozessdatenübersicht listet die detaillierte PDO-Auswahl auf. Für den Betrieb unter TwinCAT sind diese Angaben üblicherweise nicht nötig, da sie von der Konfigurationsoberfläche über die Prozessdatenvorauswahl einfach konfiguriert werden kann.
Prozessdatenvorauswahl
Ein EtherCAT Gerät bietet üblicherweise mehrere verschiedene Prozessdatenobjekte (PDO) für Input- und Outputdaten an, die im Systemmanager konfiguriert d.h. zur zyklischen Übertragung aktiviert oder deaktiviert werden können. Die entsprechende Übersicht siehe weiter unten. Dabei ist auf Kompatibilität von In- und Output-PDO zu achten.
Ab TwinCAT 2.11 können bei den lt. ESI/XML-Beschreibung dafür vorgesehenen EtherCAT-Geräten die Prozessdaten für Input und Output gleichzeitig durch entsprechende vordefinierte Sätze aktiviert werden, "predefined PDO".
Die EL2212 verfügt im Tab "Process Data"
Karteireiter "Process Data"
über folgende "predefined PDO" Sätze:
TwinCAT Systemmanager mit der PDO-Auswahl
Im Einzelnen setzen sich die Sätze wie folgt zusammen:
Betriebsart | Name | SM2, PDO-Zuordnung | SM3, PDO-Zuordnung
SM-syncron "frame-getriggert" | Standard digital output (default Einstellung) | 0x1600 0x1601 | 0x1A00 0x1A02
 | Standard digital output with InfoData | 0x1600 0x1601 | 0x1A00 0x1A01 0x1A02 0x1A03
DistributedClocks-getriggert | DC Digital output | 0x1600 0x1601 0x1602 | 0x1A00 0x1A02 0x1A04
 | DC Digital output with InfoData | 0x1600 0x1601 0x1602 | 0x1A00 0x1A01 0x1A02 0x1A03 0x1A04
 | Multi-Timestamping 2 Ch. 10x | 0x1603 0x1604 0x1607 0x160B | 0x1A05 0x1A06 0x1A07 0x1A08
 | Multi-Timestamping 2 Ch. 5x | 0x1603 0x1604 0x1608 0x160C | 0x1A05 0x1A06 0x1A07 0x1A08
 | Multi-Timestamping 2 Ch. 2x | 0x1603 0x1604 0x1609 0x160D | 0x1A05 0x1A06 0x1A07 0x1A08
 | Multi-Timestamping 2 Ch. 1x | 0x1603 0x1604 0x160A 0x160E | 0x1A05 0x1A06 0x1A07 0x1A08
Erläuterung der Prozessdaten
Standard digital output (default)
Mit dieser Standard-PDO-Zuordnung können die Ausgänge direkt beschrieben, d.h. die angeschlossenen Aktoren direkt frame-getriggert geschaltet werden.
Standard Prozessabbild EL2212
Die EL2212 (A) verfügt über 2-Byte-Variablen mit unterschiedlichen Bitbedeutungen. Diese sind im Baum aufklappbar sichtbar (A). Sie werden auch in der Detailansicht (B) dargestellt, wenn die entsprechende Anzeigefunktion (C) aktiviert ist.
Die Bitbedeutung d.h. Offsetposition kann dann auch unter Berücksichtigung der Variablengröße (D) der Speicherbelegungsanzeige (E) entnommen werden.
Es kann sowohl der Sammelname z.B. Status wie auch die einzelne Bitvariable wie z.B. OutputActive verlinkt werden, aber nicht beide zugleich.
Eingangsdaten
Sammelname | Name | Beschreibung / Funktion | Bitposition [0..15]
Status | Ready to activate | Die Klemme signalisiert hier ihre Betriebsbereitschaft. | 0
 | Output active | Der Ausgang ist aktiv geschaltet. | 1
 | Tristate active | Die Ausgangstreiber sind hochohmig geschaltet, die Last ist werde mit GND noch Versorgungsspannung verbunden | 2
 | PWM active | Die PWM ist auf dem Ausgang n aktiv geschaltet. | 3
 | Warning | Es ist ein Warnung aufgetreten -> "Diag data" (Index 0xA000) auswerten. | 6
 | Error | Es ist ein Fehler aufgetreten und Ausgangstreiber sind deaktiviert -> "Diag data" (Index 0xA000) auswerten. | 7
 | TxPDO Toggle | Wechselt bei jedem Prozessdatenaustausch seinen Zustand. | 15
WcState |  | Sollwert im Betrieb: 0 Jedes Datagramm der EL2212 zeigt hier seinen Bearbeitungszustand an. Dadurch kann die EL2212 auf korrekte Prozessdatenkommunikation überwacht werden. |
InfoData (State) |  | Sollwert im Betrieb: 8 Zustandsanzeige der "EtherCAT State Machine" |
AdsAddr |  | AMS-Adresse des zuständigen EtherCAT-Masters im Format "0.0.0.0.0.0". Außerdem die für diesen Slave gültige Portnummer. Wird für azyklische Zugriffe zur Laufzeit auf das CoE benötigt. |
Ausgangsdaten
Sammelname | Name | Beschreibung / Funktion | Bitposition [0..15]
Control | Output | Ausgang von Kanal n aktiv schalten | 1
 | Tristate | Kanal n hochohmig schalten | 2
 | PWM | PWM durchschalten | 3
 | Reset | Rücksetzen eines Fehlers von Kanal n | 7
Prioritäten beachten
Sind die beiden Signale "Output" und "Tristate" gleichzeitig aktiviert, hat "Tristate" eine höhere Priorität.
Standard digital output with InfoData
Zusätzliche Informationsdaten
Für genauere Informationen über den Zustand der Aktoren bzw. der Treiberstufe können pro Kanal zwei weitere zyklische Datenworte eingeblendet werden. Deie jeweilige Auswhal ist über den entsprechenden Index 0x80n2:11 im CoE zu konfigurieren. Wählbar sind unter anderen z.B. die Innentemperatur der Klemme oder der aktuelle Strom durch den angeschlossenen Aktor.
Eingangsdaten
Name | Beschreibung / Funktion
Info data 1 | Zusätzliche Kanal-Informationen, Festlegung in 0x80n2:11
Info data 2 | Zusätzliche Kanal-Informationen, Festlegung in 0x80n2:19
DC Digital output
Zusätzliche Prozessdaten bei Distributed-Clocks-Betrieb
Bei Distributed-Clocks-Betrieb arbeitet die EL2212 nach Zeitstempelauftrag wie die EL2252. Entsprechend ist das Prozessabbild gleich.
Eingangsdaten
Name | Beschreibung / Funktion
Feedback | Die Klemme gibt in diesem Byte den aktuellen Zustand der Ausgangskanäle zurück. Dadurch kann ein Schaltauftrag kontrolliert werden. Bit 0: Output Kanal 1 Bit 1: Tristate Kanal 1 Bit 2: Output Kanal 2 Bit 3: Tristate Kanal 2
Ausgangsdaten
Name
Beschreibung / Funktion
Activate
Mit diesem Byte wird durch den Übergang 0 --> 3 ein neuer Startzeitpunkt in der Klemme aktiviert. Die Abfolge:
1.
in einem EtherCAT-Zyklus Activate = 0, Soll-Zustand der beiden Ausgangskanäle und gewünschten Startzeitpunkt an die EL2212 übertragen
2.
im darauffolgenden EtherCAT-Zyklus mit Activate = 3 den Schaltauftrag aktivieren
Es kann an die EL2212/EL2252 immer nur ein Schaltauftrag mit den Soll-Zuständen beider Kanäle (Ausgang, Tristate) übermittelt werden. Nach Ablauf des Auftrags ist die Klemme für einen neuen Schaltauftrag bereit, es sei denn der bestehende Auftrag wird zuvor bereits überschrieben.
Start time
64 Bit Wert des nächsten gewünschten Schaltereignisses.
Die Daten der DC-Zeit:
▪
Startzeitpunkt 1.1.2000
▪
Auflösung 1 Bit = 1 ns
Schaltzeitpunkt
Der gewünschte Schaltzeitpunkt muss vom Zeitpunkt der Berechnung in der NC/PLC aus gesehen weit "genug" in der Zukunft liegen um an die Klemme inkl. Aktivierung übermittelt werden zu können. Da 2 EtherCAT-Zyklen für die Aktivierung benötigt werden wird empfohlen, diesen Abstand nicht kleiner als 3 Zykluszeiten zu wählen.
DC Digital output with InfoData
Wie beiden Standard-Daten können auch im DC-Betrieb zusätzliche Informationsdaten eingeblendet werden. Siehe oben.
Multi-Timestamping
Prozessdaten bei Multi-Timestamping-Betrieb (2-fach Oversampling)
Das Multi-Timestamping unterstützt zwei Kanäle mit jeweils 1-fach, 2-fach, 5-fach bzw. 10-fach Oversampling. Der Faktor gibt an wie viele Ereignisse maximal pro EtherCAT-Zyklus in den Ausgabepuffer geladen werden können.
Eingangsdaten
Name | Beschreibung / Funktion
Output short circuit | Ausgang hat einen Kurzschluss/Überlast.
Output buffer overflow | Es wurden mehr Events in den Puffer geschrieben als freie Elemente verfügbar sind.
Output state | Aktueller Zustand desr Ausgangs.
Input cycle counter | Aktualisierungszähler der PLC Input Daten.
Output order feedback | Feedback des Order counters.
Events in output buffer | Aktuelle Anzahl der im Puffer verbliebenen Events.
Ausgangsdaten
Name |  | Beschreibung / Funktion
Ctrl | Output buffer reset | Alle Ereignisse im Ausgangs-Puffer löschen.
 | Manual output state | Den Ausgang fest auf diesen Wert setzen (aktivierbar über CoE und PDO, siehe Enable manual operation).
 | Force order | Bereits abgelaufene Ereignisse werden ebenfalls ausgegeben, wenn „1“. Ist nur bei aktivierter Zeitstempelprüfung „Enable time check“ = „1“ relevant. Siehe detailliertere Erläuterung unten.
 | Enable manual operation | Manuellen Betrieb über das PDO bit 'Manual output state' zulassen.
 | Output order counter | Durch Inkrementieren dieses Wertes wird der Klemme mitgeteilt, dass neue Werte im PDO liegen.
 | No of output events | Anzahl der im PDO abgelegten Ereignisse
Outputs | Output event state n | Ausgangswert zum Zeitpunkt des n-ten Timestamps
Output event time n |  | Timestamp des n-ten Events
Die EL2212 bearbeitet die Multi-Timestamp-Aufträge mit einem Takt von ca 25 µs und entscheidet in diesem Rhythmus ob eine Ausführung ansteht oder nicht. Dem entsprechend beträgt somit auch die realisierbare Zeitauflösung und damit Zeitgenauigkeit des elektrischen Schaltsignals 25 µs.
Detaillierte Erläuterung zu Enable time check/ Force order
Die Verwendung der Zeitstempelprüfung „Enable time check“ = „1“ wird im Folgenden in Verbindung mit dem PDO „Force Order“ in drei Modi dargestellt:
Modus | Enable time check | Force Order | Auswirkung
1 | 0 | - | Zeitstempelprüfung inaktiv, d.h. vom momentanen DC Zeitwert ausgehend mehr als 100 µs zurückliegende Zeitstempel werden als zukünftige Zeitstempel interpretiert, was u.U. eine Verzögerung der Zustandsübertragungen von bis zu ca. 4,29 s hervorrufen kann.
2 | 1 | 0 | keine Ausgabe veralteter Ereignisse | Zeitstempelprüfung aktiv, das Zeitintervall des zu übertragenden Zeitstempels wird auf ±231 aufgeteilt, d.h. ca. 2,15 s zeitlich zurückliegend und ca. 2,15 zeitlich vorausliegend. Letzteres stellt eine herabgesetzte Begrenzung des zul. Zeitbereichs von ca. 4,29 s auf ca. 2,15 s dar.
3 | 1 | 1 | sofortige Ausgabe des veralteten Ereignisses
Behandlung des Zeitstempels der Ausgabezustände bei aktivierter Zeitstempelprüfung
Hinweis
Bedingungen für Zeitstempel beim Multi-Timestamping
•
Zeitstempel müssen in zeitlich aufsteigender Reihenfolge an die Klemme gesendet werden. Sollte ein Zeitstempel älter sein als der vorherige, bleibt die Ausgabe für bis zu ca. 4,29 Sekunden aus. Der Schaltvorgang findet anschließend statt.
•
Zeitstempel müssen in der Zukunft liegen und frühzeitig an die Klemme gesendet werden. Erkennt die Klemme, dass ein Zeitstempel in der Vergangenheit liegt, bleibt die Ausgabe für bis zu ca. 4,29 Sekunden aus. Der Schaltvorgang findet anschließend statt.
•
Unvorhersehbares Verhalten beim Multi-Timestamping:
In beiden oben beschriebenen Fällen blockiert die Ausgabe für bis zu ca. 4,29 Sekunden und es kann zu einer Buffer-Overflow-Rückmeldung der Klemme kommen.
Dadurch kann es zu einem unerwünschten Schaltzustand kommen.
Prozessdatenübersicht
Die manuelle Prozessdatenzuordnung ist erforderlich bei TwinCAT bis Version 2.10.
Sync Manager (SM)
Der Umfang der angebotenen Prozessdaten kann über den Reiter „Prozessdaten“ verändert werden (siehe folgende Abbildungen).
Dem Output-SyncManager können die PDOs aus dem Bereich 0x160n (0x1600, 01x1601, 0x1602) zugeordnet werden, siehe Abbildung „Karteireiter Prozessdaten Sync Manager mit Outputs“.
Dem Input-SyncManager die PDOs aus dem Bereich 0x1A0n (0x1A00 bis 0x1A049), siehe Abbildung „Karteireiter Prozessdaten Sync Manager mit Inputs“.
Nicht alle Kombinationen sind technisch möglich
Karteireiter Prozessdaten SM2 (Outputs), EL2212 (default)
Karteireiter Prozessdaten SM3 (Inputs), EL2212 (default)
Manuelle PDO-Zuordnung
Zur Konfiguration der Prozessdaten markieren Sie im oberen linken Feld „Sync Manager“ den gewünschten Sync Manager „Inputs“ oder „Outputs“ (beide sind editierbar). Im Feld darunter „PDO Zuordnung“ können dann die diesem Sync Manager zugeordneten Prozessdaten an- oder abgeschaltet werden. Ein Neustart des EtherCAT-Systems oder Neu-Laden der Konfiguration im Config-Modus (F4) bewirkt einen Neustart der EtherCAT-Kommunikation und die Prozessdaten werden von der Klemme übertragen.
SM2 (Outputs), PDO-Zuordnung 0x1C12
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 (default) | 0x1603 | 2.0 | DOX Control Channel 1 | Index 0x7000:02 - Output Index 0x7000:03 - Tristate Index 0x7000:04 - PWM Index 0x7000:08 - Reset
0x1601 (default) | 0x1604 | 2.0 | DOX Control Channel 2 | Index 0x7010:02 - Output Index 0x7010:03 - Tristate Index 0x7010:04 - PWM Index 0x7010:08 - Reset
0x1602 | 0x1607 0x1608 0x1609 0x160A 0x160B 0x160C 0x160D 0x160E | 10.0 | DC Sync ausschließlich in Verbindung mit DC-Betriebsart möglich! | Index 0xF700:01 - Activate Index 0xF700:03 - Start time
0x1603 | 0x1600 | 2.0 | DOX Control (MTO) Channel 1 | Index 0x7000:04 - PWM Index 0x7000:08 - Reset
0x1604 | 0x1601 | 2.0 | DOX Control (MTO) Channel 2 | Index 0x7010:04 - PWM Index 0x7010:08 - Reset
0x1605 | - | 3.0 | DOX PWM Channel 1 | Index 0x7000:11 - Duty cycle Index 0x7000:13 - PWM Tperiod
0x1606 | - | 3.0 | DOX PWM Channel 2 | Index 0x7010:11 - Duty cycle Index 0x7010:13 - PWM Tperiod
0x1607 | 0x1602 0x1608 0x1609 0x160A | 48.0 | MTO Outputs 10x Channel 1 | Index 0x7021:01 - Output buffer reset Index 0x7021:02 - Manual output state Index 0x7021:03 - Force order Index 0x7021:04 - Enable manual operation Index 0x7021:09 - Output order counter Index 0x7021:11 - No of output events Index 0x7021:21 - Output event state 1 Index 0x7021:22 - Output event state 2 Index 0x7021:23 - Output event state 3 Index 0x7021:24 - Output event state 4 Index 0x7021:25 - Output event state 5 Index 0x7021:26 - Output event state 6 Index 0x7021:27 - Output event state 7 Index 0x7021:28 - Output event state 8 Index 0x7021:29 - Output event state 9 Index 0x7021:2A - Output event state 10 Index 0x7021:41 - Output event time 1 Index 0x7021:42 - Output event time 2 Index 0x7021:43 - Output event time 3 Index 0x7021:44 - Output event time 4 Index 0x7021:45 - Output event time 5 Index 0x7021:46 - Output event time 6 Index 0x7021:47 - Output event time 7 Index 0x7021:48 - Output event time 8 Index 0x7021:49 - Output event time 9 Index 0x7021:4A - Output event time 10
0x1608 | 0x1602 0x1607 0x1609 0x160A | 28.0 | MTO Outputs 5x Channel 1 | siehe 0x1607 mit entsprechend weniger Ereignissen
0x1609 | 0x1602 0x1607 0x1608 0x160A | 16.0 | MTO Outputs 2x Channel 1 | siehe 0x1607 mit entsprechend weniger Ereignissen
0x160A | 0x1602 0x1607 0x1608 0x1609 | 12.0 | MTO Outputs 10x Channel 1 | siehe 0x1607 mit entsprechend weniger Ereignissen
0x160B | 0x1602 0x160C 0x160D 0x160E | 48.0 | MTO Outputs 10x Channel 2 | Index 0x7031:01 - Output buffer reset Index 0x7031:02 - Manual output state Index 0x7031:03 - Force order Index 0x7031:04 - Enable manual operation Index 0x7031:09 - Output order counter Index 0x7031:11 - No of output events Index 0x7031:21 - Output event state 1 Index 0x7031:22 - Output event state 2 Index 0x7031:23 - Output event state 3 Index 0x7031:24 - Output event state 4 Index 0x7031:25 - Output event state 5 Index 0x7031:26 - Output event state 6 Index 0x7031:27 - Output event state 7 Index 0x7031:28 - Output event state 8 Index 0x7031:29 - Output event state 9 Index 0x7031:2A - Output event state 10 Index 0x7031:41 - Output event time 1 Index 0x7031:42 - Output event time 2 Index 0x7031:43 - Output event time 3 Index 0x7031:44 - Output event time 4 Index 0x7031:45 - Output event time 5 Index 0x7031:46 - Output event time 6 Index 0x7031:47 - Output event time 7 Index 0x7031:48 - Output event time 8 Index 0x7031:49 - Output event time 9 Index 0x7031:4A - Output event time 10
0x160C | 0x1602 0x160B 0x160D 0x160E | 28.0 | MTO Outputs 5x Channel 2 | siehe 0x160B mit entsprechend weniger Ereignissen
0x160D | 0x1602 0x160B 0x160C 0x160E | 16.0 | MTO Outputs 2x Channel 2 | siehe 0x160B mit entsprechend weniger Ereignissen
0x160E | 0x1602 0x160B 0x160C 0x160D | 12.0 | MTO Outputs 10x Channel 2 | siehe 0x160B mit entsprechend weniger Ereignissen
SM3 (Inputs), PDO-Zuordnung 0x1C13
Index | Index ausgeschlossener PDOs | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 (default) | 0x1A05 | 2.0 | DOX Status Channel 1 | Index 0x6000:01 - Ready to activate Index 0x6000:02 - Output active Index 0x6000:03 - Tristate active Index 0x6000:04 - PWM active Index 0x6000:07 - Warning Index 0x6000:08 - Error Index 0x6000:10 - TxPDO Toggle
0x1A01 | - | 4.0 | DOX Synchron info data Channel 1 | Index 0x6000:11 - Info data 1 Index 0x6000:12 - Info data 2
0x1A02 (default) | 0x1A06 | 2.0 | DOX Status Channel 2 | Index 0x6010:01 - Ready to activate Index 0x6010:02 - Output active Index 0x6010:03 - Tristate active Index 0x6010:04 - PWM active Index 0x6010:07 - Warning Index 0x6010:08 - Error Index 0x6010:10 - TxPDO Toggle
0x1A03 | - | 4.0 | DOX Synchron info data Channel 2 | Index 0x6010:11 - Info data 1 Index 0x6010:12 - Info data 2
0x1A04 | 0x1A07 0x1A08 | 2.0 | DC Feedback ausschließlich in Verbindung mit DC-Betriebsart möglich! | Index 0xF600:01 - Feedback
0x1A05 | 0x1A00 | 2.0 | DOX Status (MTO) Channel 1 | Index 0x6000:01 - Ready to activate Index 0x6000:04 - PWM active Index 0x6000:07 - Warning Index 0x6000:08 - Error Index 0x6000:10 - TxPDO Toggle
0x1A06 | 0x1A02 | 2.0 | DOX Status (MTO) Channel 2 | Index 0x6010:01 - Ready to activate Index 0x6010:04 - PWM active Index 0x6010:07 - Warning Index 0x6010:08 - Error Index 0x6010:10 - TxPDO Toggle
0x1A07 | 0x1A04 | 4.0 | MTO Inputs Channel 1 | Index 0x6020:01 - Output short circuit Index 0x6020:02 - Output buffer overflow Index 0x6020:03 - Output state Index 0x6020:0F - Input cycle counter Index 0x6020:11 - Output order feedback Index 0x6020:12 - Events in output buffer
0x1A08 | 0x1A04 | 4.0 | MTO Inputs Channel 2 | Index 0x6030:01 - Output short circuit Index 0x6030:02 - Output buffer overflow Index 0x6030:03 - Output state Index 0x6030:0F - Input cycle counter Index 0x6030:11 - Output order feedback Index 0x6030:12 - Events in output buffer


Prozessdatenvorauswahl

Inbetriebnahme [image] Prozessdatenvorauswahl
Prozessdatenvorauswahl
Die EL2212 kann mit unterschiedlichen Funktionsarten betrieben werden.
Eine Vorauswahl der PDO's kann mit dem System Manager per „Predefined PDO Assignment“ auf der Registerkarte "Prozessdaten" vorgenommen werden
Standard digital output / with InfoData
Mit dieser Standard-PDO-Zuordnung können die Ausgänge direkt beschrieben, d.h. die angeschlossenen Aktoren direkt geschaltet werden.
Wählt man die Option "with InfoData" werden automatisch die synchronen Informationsdaten mit eingeblendet.
Standard PDO-Zuordnung
Name der Prozess-Eingangsdaten | Beschreibung / Funktion
Ready to activate | Die Klemme signalisiert hier ihre Betriebsbereitschaft.
Output active | Der Ausgang ist aktiv geschaltet.
Tristate active | Die Ausgangstreiber sind in Tristate geschaltet.
PWM active | Die PWM ist auf dem Ausgang n aktiv geschaltet.
Warning | Es ist ein Warnung aufgetreten -> "Diag data" (Index 0xA000) auswerten.
Error | Es ist ein Fehler aufgetreten und Ausgangstreiber sind deaktiviert -> "Diag data" (Index 0xA000) auswerten.
TxPDO Toggle | Wechselt bei jedem Prozessdatenaustausch seinen Zustand.
WcState | Jedes Datagramm der EL2212 zeigt hier seinen Bearbeitungszustand an. Dadurch kann die EL2212 auf korrekte Prozessdatenkommunikation überwacht werden.
InfoData (State) | Zustandsanzeige der "EtherCAT State Machine"
Name der Prozess-Ausgangsdaten | Beschreibung / Funktion
Output | Ausgang von Kanal n aktiv schalten
Tristate | Kanal n hochohmig schalten
PWM | PWM am Ausgang von Kanal n aktiv schalten
Reset | Rücksetzen eines Fehlers von Kanal n
Prioritäten beachten
Sind die beiden Signale "Output" und "Tristate" gleichzeitig aktiviert, hat "Tristate" eine höhere Priorität.
DC digital output / with InfoData
Zusätzlich zu den Standard-Signalen sind in dieser Zuordnung noch die PDOs "DC Feedback" und "DC Sync" aktiviert.
Wählt man die Option "with InfoData" werden automatisch die synchronen Informationsdaten mit eingeblendet.
PDO-Zuordnung mit aktivierten DC
Name der Prozess-Eingangsdaten | Beschreibung / Funktion
Feedback | Die Klemme gibt in diesem Byte die Zustände der Eingagnssignale zurück. Bit 0: Output Kanal 1 Bit 1: Tristate Kanal 1 Bit 2: Output Kanal 2 Bit 3: Tristate Kanal 2
Name der Prozess-Ausgangsdaten | Beschreibung / Funktion
Activate | Mit diesem Byte wird durch den Übergang 0 → 3 ein neuer Startzeitpunkt in der Klemme aktiviert.
Start time | 64 Bit Wert des nächsten gewünschten Schaltereignisses.
Synchron information data (PDO 0x1A01 bzw. 0x1A03)
Zusätzliche Informationen können mit den PDO 0x1A01 (Ch.1) bzw. 0x1A03 (Ch.2) eingeblendet werden.
Die PDO-Zuordnung mit den "Synchon information data" muss manuell aktiviert werden.
Für genauere Informationen über den Zustand der Aktoren bzw. der Treiberstufe werden pro Kanal zwei weitere Datenworte eingeblendet. Diese sind über den entsprechenden Index im CoE zu konfigurieren.
Wählbar sind unter anderen z.B. die Innentemperatur der Klemme, oder der aktuelle Strom durch den angeschlossenen Aktor.
Aktivierte "Synchron Info data"
Name der Prozess-Eingangsdaten | Beschreibung / Funktion
Info data 1 | Zusätzliche Kanal-Informationen
Info data 2
Multi-Timestamping 2 Ch. 10x/5x/2x/1x
Das Multi-Timestamping unterstützt zwei Kanäle mit jeweils 1-fach, 2-fach, 5-fach bzw. 10-fach Oversampling.
Aktiviertes "Multi-Timestamping" 2 Ch. 2x
Name der Prozess-Eingangsdaten | Beschreibung / Funktion
Output short circuit | Ausgang hat einen Kurzschluss/Ueberlast.
Output buffer overflow | Es wurden mehr Events in den Puffer geschrieben als freie Elemente verfuegbar sind.
Output state | Aktueller Zustand des Ausgangs.
Input cycle counter | Aktualisierungszähler der PLC Input Daten.
Output order feedback | Feedback des Order counters.
Events in output buffer | Aktuelle Anzahl der im Puffer verbliebenen Events.
Name der Prozess-Ausgangsdaten | Beschreibung / Funktion
Output buffer reset | Alle Ereignisse im Ausgangs-Puffer löschen.
Manual output state | Den Ausgang fest auf diesen Wert setzen (aktivierbar über CoE und PDO, siehe Enable manual operation).
Force order | Bereits abgelaufene Ereignisse werden ebenfalls ausgegeben.
Enable manual operation | Manuellen Betrieb über das PDO bit 'Manual output state' zulassen.
Output order counter | Durch Inkrementieren dieses Wertes wird der Klemme mitgeteilt, dass neue Werte im PDO liegen.
No of output events | Anzahl der im PDO abgelegten Ereignisse
Output event state n | Ausgangswert zum Zeitpunkt des n-ten Timestamps
Output event time n | Timestamp des n-ten Events


Distributed Clocks Einstellungen

Inbetriebnahme [image] Distributed Clocks Einstellungen
Distributed Clocks Einstellungen
Grundlagen
Die EL2212 verfügt beim DC-Betrieb über eine Besonderheit: üblicherweise wird die DC-Einheit im ESC vom EtherCAT-Master verwaltet. Bei der EL2212 verwaltet jedoch der lokale Controller die Startzeit und setzt entsprechende Werte im ESC.
EL2212 DC-Schema
Der Controller (B) erhält Zeitstempel, Aktivierung und Sollzustände als normale Prozessdaten vom ESC (A). Er parametriert den ESC auf die nächste Startzeit. Beim angesetzten Zeitpunkt teilt dies der ESC dem Controller über das SYNC-Signal mit, dieser steuert dann entsprechend die Ausgangsstufen an.
Aus diesem Grund können im TwinCAT Systemmanager die entsprechenden DC-Einträge trotz DC-Modus nicht verändert werden, die EL2212 kann dennoch als ReferenceClock verwendet werden.
EL2212 DC-Einstellungen
Ermittlung der aktuellen Distributed-Clocks-Zeit
Wird in einem PLC-Zyklus eine aktuelle Angabe über die Distributed-Clocks-Zeit benötigt, kann diese über eine Eingangsvariable des EtherCAT Masters verlinkt werden.
Funktionen für Datentypen mit 64 Bit Breite
Zur Verarbeitung der 64 Bit Zahlen in Beckhoff TwinCAT stehen in der Library TcUtilities.lib eine Auswahl an Funktionen zur Verfügung. Hier sind längere Ausführungszeiten erforderlich als mit 32 Bit Standard-Datentypen. Ein Datentyp mit 64 Bit Breite ist in TcEthercat.lib als T_DCTIME oder in TcUtilities.lib als T_LARGE_INTEGER definiert.
Der EtherCAT Master kann eine Kopie der aktuellen Distributed-Clock-Master-Clock anzeigen. Dazu ist im Gerät EtherCAT → Karteireiter EtherCAT → Erweiterte Einstellungen → Distributed Clocks die Einstellung "Show DC System Time (64bit)" zu aktivieren, (siehe entsprechende Abbildung).
Aktivierung der Anzeige der Master-Distributed-Clock
Dadurch stellt sich das Prozessabbild des EtherCAT Masters nun dar wie in der folgenden Abbildung:
Erweitertes Prozessabbild des EtherCAT Masters
SYSTIME
Der Wert DcSysTime des EtherCAT Masters ist mit Bedacht zu verwenden und soll nur als grobe Orientierung dienen, in welchem Zeitbereich (Größenordnung: 1-2 Task-Zyklen) sich das Distributed-Clocks-System gerade aufhält.
Der Grund dafür ist, dass die lokale Uhrzeit in der Klemme bereits einige µs vor dem abholenden Frame in entsprechende Puffer gelesen wird. Danach benötigt der EtherCAT-Strang einige Zeit um das Prozessdatum zum Master zu transportieren. Die Online-Anzeige im TwinCAT System Manager ist wegen des Visualisierungscharakters bestenfalls im 3stelligen Millisekundenbereich genau. Aber auch in einer PLC kann das Prozessdatum SysTime unterschiedlich veraltet sein: je nachdem wann im Programmcode die Auswertung erfolgt, ist das Prozessdatum bereits einige µs/ms älter geworden. Sollen Reaktionen im EtherCAT-Strang (z.B. einer Ausgangsklemme EL2212) auf einer so eingelesenen SysTime basieren, sind 2-3 PLC-Zykluszeiten Puffer zu berücksichtigen.

Deutlich zweckmäßiger ist die Verwendung einer EL2212 mit anderen EtherCAT-Slaves, die einen Zeitstempel aufgrund Umgebungseinflüssen wie z.B. die EL1252 erzeugen.

Alternativ können auch zur NC/PLC-Laufzeit Funktionen aufgerufen werden, die sofort die aktuelle DC-Zeit zurückliefern wie z.B. F_GetCurDcTickTime. Siehe dazu die Hinweise zu den TwinCAT Zeitquellen in
http://www.beckhoff.com/english/download/ethercat.htm#SystemDescription" → EtherCAT-System-Documentation.
Prozessdaten
Für den Betrieb der EL2212 ist die Aktivierung der dafür vorgesehenen Prozessdaten nötig.
Beispiel eines Ablaufs mit aktivierten Distributed Clocks
Es ist folgender Ablauf bei der Anwendung der EL2212 mit aktivierten Distributed Clocks einzuhalten:

1.
Berechnung des Ausgabezeitpunktes:
–
Ermittlung der aktuellen Distributed Clocks Zeit im 64 Bit Format, z.B. durch die eingeschaltete DC System Time des EtherCAT-Masters
–
Berechnung und Schreiben des gewünschten Ausgabezeitpunktes Start time mit 64 Bit-Operationen
2.
Setzen der gewünschten Ausgabezustände der digitalen Signale:
–
die Ausgangsdaten Output und Tristate von Kanal 1 und 2
–
zugleich muss Activate = 0 sein
3.
Übertragen dieser Ausgangsdaten durch den EtherCAT-Zyklus an die EL2212
4.
Im darauf folgenden Zyklus: Aktivierung des Ausgabezeitpunktes:
–
Activate = 3 setzen (Übergang von 0 nach 3 aktiviert die Startzeit)
5.
Die EL2212 wartet nun wie o.a. bis der Startzeitpunkt eintritt und gibt dann die Ausgangsdaten an die Leistungsstufe aus
–
bis zum Eintritt des Schaltereignisses müssen Activate und die Ausgangsbits Output/ Tristate dem Zielzustand entsprechend gehalten werden
–
bei Spannungsverlust oder Abschaltung der Klemme geht der Startzeitpunkt verloren und muss von der Steuerung neu gesetzt werden
6.
Optional: Vergleich der Eingangs mit den Ausgangsdaten:
–
Feedback-Byte mit dem gewünschten Ausgangsbild vergleichen, um den Schaltvorgang zu registrieren
–
ggf. kontrollieren, ob die Startzeit schon abgelaufen ist, falls das Schreiben der Startzeit zu zeitkritisch geschehen ist
7.
Deaktivieren der Startzeit:
–
Activate = 0 setzen, zur Vorbereitung der folgenden Aktivierungsphase
Es kann immer nur ein Schaltereignis je EL2212 definiert werden, das sich auf alle 4 Ausgangsvariablen Output und Tristate von Kanal 1 und 2 zugleich auswirkt.
Je EtherCAT-Zyklus kann nur ein Schaltereignis definiert werden.
Es ist zulässig, das Schreiben der Ausgangsdaten Soll-Ausgangszustände, Startzeit und Activate = 0 im gleichen EtherCAT-Zyklus durchzuführen.


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise: - StartUp-Liste führen für den Austauschfall - Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung - "CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten (kanalspezifisch)
•
Kommando-Objekt
•
Eingangsdaten
•
Ausgangsdaten
•
Informations-/Diagnostikdaten (kanalspezifisch)
•
Hersteller-Konfigurationsdaten (gerätespezifisch)
•
Informations-/Diagnostikdaten (gerätespezifisch)
•
Distributed Clocks Ein-/Ausgangsdaten
•
Diagnosis History Daten
•
Timestamp
•
Standardobjekte


Restore-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Restore-Objekt
Restore-Objekt
Index 0x1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten (kanalspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Konfigurationsdaten (kanalspezifisch)
Konfigurationsdaten (kanalspezifisch)
Index 0x8pp0 DOX Settings (Ch.1, pp=00; Ch. 2, pp=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp0:0 | DOX Settings |  | UINT8 | RO | 0x0D (14dez)
8pp0:01 | Boost current | Anregungsstrom (Einheit: 1 mA) größter sinnvoller Wert ist UVersorgung / RSpule | UINT16 | RW | 0x1388 (5000dez)
8pp0:02 | Hold current | Nennstrom (Einheit: 1 mA) in der Haltephase | UINT16 | RW | 0x01F4 (500dez)
8pp0:03 | Supply voltage | Nennspannung (Versorgungsspannung UVersorgung) (Einheit: 0,01 V) | UINT16 | RW | 0x0960 (2400dez)
8pp0:05 | Coil resistance | Innenwiderstand des Motors (Einheit: 0,01 Ohm) | UINT16 | RW | 0x0064 (100dez)
8pp0:06 | Booster on time | Einschaltdauer des Anregungsstroms (Einheit: 0,1 ms) der Wert "0" schaltet die Anregungsphase ab | UINT16 | RW | 0x000A (10dez)
8pp0:07 | Booster off time | Einschaltdauer des Gegenstroms (Einheit: 0,1 ms) | UINT16 | RW | 0x000A (10dez)
8pp0:08 | Current switch off threshold | Schwellstrom des Ausschaltzeitpunkts (Einheit: 1 mA) | INT16 | RW | 0x0000 (0dez)
8pp0:09 | PWM Tperiod | Periodendauer der PWM (Einheit: 0,1 ms) | UINT32 | RW | 0x00000000 (0dez)
8pp0:0A | PWM Toff | Auszeit der PWM (Einheit: 0,1 ms) | UINT16 | RW | 0x0000 (0dez)
8pp0:0B | Boost current threshold 1 | Stromgrenze Kanal 1 Boost –on Phase (Einheit: 1 mA) | UINT16 | RW | 0x0000 (0dez)
8pp0:0C | Boost current threshold 2 | Stromgrenze Kanal 2 Boost –on Phase (Einheit: 1 mA) | UINT16 | RW | 0x0000 (0dez)
8pp0:0D | Boost current threshold 3 | Stromgrenze Kanal 3 Boost –on Phase (Einheit: 1 mA) | UINT16 | RW | 0x0000 (0dez)
Index 0x8pp1 DOX Controller Settings (Ch.1, pp=00; Ch. 2, pp=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8pp1:0 | DOX Controller Settings |  | UINT8 | RO | 0x02 (2dez)
8pp1:01 | Kp factor (curr.) | Kp-Regelfaktor des Stromreglers | UINT16 | RW | 0x01F4 (500dez)
8pp1:02 | Ki factor (curr.) | Ki-Regelfaktor des Stromreglers | UINT16 | RW | 0x0005 (5dez)
Index 0x8pp2 DOX Features (Ch.1, pp=00; Ch. 2, pp=01)
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
8pp2:0 | DOX Features |  |  |  | UINT8 | RO | 0x19 (25dez)
8pp2:01 | Enable booster on time | Aktivierung der Überbestromung |  |  | BOOLEAN | RW | 0x01 (1dez)
8pp2:02 | Enable booster off time | Aktivierung der Gegenbestromung |  |  | BOOLEAN | RW | 0x01 (1dez)
8pp2:03 | Enable current switch off threshold | Aktivierung des Abschaltschwellstroms |  |  | BOOLEAN | RW | 0x01 (1dez)
8pp2:04 | Enable PWM output | Aktivierung der PWM-Ansteuerung(1 |  |  | BOOLEAN | RW | 0x01 (1dez)
8pp2:11 | Select info data 1 | Auswahl "Info data 1" | 0 | Status word | UINT8 | RW | 0x01 (1dez)
 |  |  | 1 | Coil voltage
 |  |  | 2 | Coil current
 |  |  | ... | reserviert
 |  |  | 5 | Duty cycle
 |  |  | ... | reserviert
 |  |  | 101 | Internal temperature
 |  |  | ... | reserviert
 |  |  | 104 | Supply voltage
 |  |  | 105 | Supply current
 |  |  | .... | reserviert
8pp2:19 | Select info data 2 | Auswahl "Info data 2" | siehe Index 8pp2:11 |  | UINT8 | RW | 0x02 (2dez)
1)Diese PWM ist Anwenderseitig und von der Klemmeninternen PWM (32 kHz) der Stromregelung getrennt umgesetzt (siehe Kapitel „Weitere Eigenschaften“).
Index 0x8pp1 MTO Settings (Ch.1, pp=02; Ch. 2, pp=03)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp1:0 | MTO Settings |  |  | UINT8 | RO | 0x12 (18dez)
8pp1:01 | Use as +24 V power supply | Ausgang permanent einschalten |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:02 | Enable manual operation | Manuellen Betrieb ueber das PDO bit 'Manual output state' zulassen |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:03 | Enable time check | Umgeht die durch Übergabe eines Veralteten Zeitstempels verursachte Verzögerung von bis zu ca. 4,29 s wenn „1“ gesetzt. In Verbindung mit dem Ausgangs-PDO „Force Order“ wird entschieden, ob bereits abgelaufenen Events ausgegeben oder verworfen werden sollen. Für „1“ ist insbesondere zu beachten: das Zeitintervall des zu übertragenden Zeitstempels wird auf ±231 aufgeteilt, d.h. ca. 2,15 s zeitlich zurückliegend und ca. 2,15 zeitlich vorausliegend. Letzteres stellt eine herabgesetzte Begrenzung des zul. Zeitbereichs von ca. 4,29 s auf ca. 2,15 s dar. Siehe hierzu Kapitel „Multi-Timestamping“. |  | BOOLEAN | RW | 0x00 (0dez)
 |  | Enable time check =“1“; Ausgangs-PDO „Force Order“= | “0”: keine Ausgabe veralteter Ereignisse
 |  |  | “1”: sofortige Ausgabe des veralteten Ereignisses
8pp1:11 | Buffer reset behaviour | 0: Reset on falling edge 1: Reset on high level |  | UINT16 | RW | 0x0000 (0dez)
8pp1:12 | Buffer overflow behaviour | 0: Lock Buffer 1: overwrite oldest |  | UINT16 | RW | 0x0000 (0dez)
8pp1:13 | Valid past window | Fenster zur Kontrolle des Timstamps vom nächsten Event. Liegt das folgende Event (Zeitstempel) nicht in diesem Fenster (bezogen auf die aktuelle Zeit), wird der Ausgang nicht geschaltet (bedingt durch die PLC-Laufzeit). |  | INT32 | RW | -500000dez
8pp1:14 | Valid future window | s.o. |  | INT32 | RW | 500000dez
Index 0x8ppF MTO Vendor data (Ch.1, pp=02; Ch. 2, pp=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | MTO Vendor data |  | UINT8 | RW | 0x12 (18dez)
8ppF:11 | Offset pos | Correction value for the timestamp to compensate internal run times (when switching on the output). | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Correction value for the timestamp to compensate internal run times (when switching off the output). | INT32 | RW | 0x00000000 (0dez)


Kommando-Objekt

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Kommando-Objekt
Kommando-Objekt
Index 0xFB00 DOX Command
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
FB00:0 | DOX Command | Max. Subindex |  |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | 0x1000 | Clear diag history | löscht die Diag History | OCTET-STRING[2] | RW | {0}
 |  | 0x1100 | Get build number | Auslesen der Build-Nummer
 |  | 0x1101 | Get build date | Auslesen des Build-Datums
 |  | 0x1102 | Get build time | Auslesen der Build-Zeit
 |  | 0x8000 | Software reset | Software-Reset durchführen (Hardware wird mit der Aktuellen CoE-Konfiguration neu Initialisiert, geschieht sonst nur beim Übergang nach INIT)
FB00:02 | Status | 0 | Finished, no error, no response | Kommando ohne Fehler und ohne Antwort (Response ) beendet | UINT8 | RO | 0x00 (0dez)
 |  | 1 | Finished, no error, response | Kommando ohne Fehler und mit Antwort beendet
 |  | 2 | Finished, error, no response | Kommando mit Fehler und ohne Antwort beendet
 |  | 3 | Finished, error, response | Kommando mit Fehler und mit Antwort beendet
 |  | 255 | Executing | Kommando wird ausgeführt
FB00:03 | Response | abhängig vom Request |  |  | OCTET-STRING[4] | RO | {0}


Eingangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 0x6pp0 DOX Inputs (Ch.1, pp=00; Ch.2, pp=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | DOX Inputs |  | UINT8 | RO | 0x12 (18dez)
6pp0:01 | Ready to activate | Treiberstufe ist bereit zur Aktivierung | BOOLEAN | RO | 0x00 (0dez)
6pp0:02 | Output active | Ausgang ist Aktiviert | BOOLEAN | RO | 0x00 (0dez)
6pp0:03 | Tristate active | Treiberstufe ist im Tristate geschaltet | BOOLEAN | RO | 0x00 (0dez)
6pp0:04 | PWM active | Die PWM ist über Bit 0x7pp0:04 aktiviert worden. | BOOLEAN | RO | 0x00 (0dez)
6pp0:07 | Warning | eine Warnung ist aufgetreten (siehe Index App0 | BOOLEAN | RO | 0x00 (0dez)
6pp0:08 | Error | ein Fehler ist aufgetreten (siehe Index App0 | BOOLEAN | RO | 0x00 (0dez)
6pp0:10 | TxPDO Toggle | Der TxPDO Toggle wird vom Slave getoggelt, wenn die Daten der zugehörigen TxPDO aktualisiert wurden. | BOOLEAN | RO | 0x00 (0dez)
6pp0:11 | Info data 1 | synchrone Informationen (Auswahl über Subindex 8pp2:11) | UINT16 | RO | 0x0000 (0dez)
6pp0:12 | Info data 2 | synchrone Informationen (Auswahl über Subindex 8pp2:19) | UINT16 | RO | 0x0000 (0dez)
Index 0x6pp0 MTO Inputs (Ch.1, pp=02; Ch.2, pp=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | MTO Inputs |  | UINT8 | RO | 0x12 (18dez)
6pp0:01 | Output short circuit | Ausgang hat einen Kurzschluss/Ueberlast | BOOLEAN | RO | 0x00 (0dez)
6pp0:02 | Output buffer overflow | Es wurden mehr Events in den Puffer geschrieben als freie Elemente verfuegbar sind | BOOLEAN | RO | 0x00 (0dez)
6pp0:03 | Output state | Aktueller Zustand der Ausgangs | BOOLEAN | RO | 0x00 (0dez)
6pp0:07 | Warning | Signalisiert eine Warnung (wird durch die Bits in 0xApp0 genauer aufgeschlüsselt). | BOOLEAN | RO | 0x00 (0dez)
6pp0:0F | Input cycle counter | Wird bei jedem EtherCAT-Zyklus inkrementiert. | BIT2 | RO | 0x00 (0dez)
6pp0:11 | Output order feedback | Feedback des Order counters | UINT8 | RO | 0x00 (0dez)
6pp0:12 | Events in output buffer | Aktuelle Anzahl der im Puffer verbliebenen Events | UINT8 | RO | 0x00 (0dez)


Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 0x7pp0 DOX Outputs (Ch.1, pp=00; Ch.2, pp=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7pp0:0 | DOX Outputs |  | UINT8 | RO | 0x08 (8dez)
7pp0:02 | Output | aktiviert die Ausgangsstufe | BOOLEAN | RW | 0x00 (0dez)
7pp0:03 | Tristate | schaltet die Ausgangsstufe in den Tristate | BOOLEAN | RW | 0x00 (0dez)
7pp0:04 | PWM | schaltet PWM zur Ausgangsstufe durch | BOOLEAN | RW | 0x00 (0dez)
7pp0:08 | Reset | alle aufgetretenen Fehler werden durch das Setzen dieses Bits zurückgesetzt (steigende Flanke) | BOOLEAN | RW | 0x00 (0dez)
7pp0:11 | Duty cycle | Tastverhältnis der PWM (siehe auch DOX Settings) | UINT8 | RW | 0x00 (0dez)
7pp0:13 | PWM Tperiod | Periodendauer der PWM-Ausgabe über PDO (in ms). Ist der PDO-Wert = 0, dann wird der konfigurierte Wert aus dem CoE genommen. | UINT16 | RW | 0x0000 (0dez)
Index 0x7pp1 MTO Outputs (Ch.1, pp=02; Ch.2, pp=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7pp1:0 | MTO outputs |  | UINT8 | RO | 0x4A (74dez)
7pp1:01 | Output buffer reset | Events im Output Puffer loeschen | BOOLEAN | RO | 0x00 (0dez)
7pp1:02 | Manual output state | Ausgang fest auf diesen Wert setzen (muss im CoE aktiviert sein) | BOOLEAN | RO | 0x00 (0dez)
7pp1:03 | Force order | Auch bereits abgelaufenen Events werden ausgegeben | BOOLEAN | RO | 0x00 (0dez)
7pp1:04 | Enable manual operation | Wenn dieses Bit aktiviert ist, wird der Ausgang mit dem Wert in „Manual output state“ überschrieben. | BOOLEAN | RO | 0x00 (0dez)
7pp1:09 | Output order counter | Durch das Inkrementieren diese Wertes wird der Klemme mitgeteilt, dass neue Werte im PDO liegen | UINT8 | RO | 0x00 (0dez)
7pp1:11 | No of output events | Anzahl der im PDO abgelegten Events | UINT8 | RO | 0x00 (0dez)
7pp1:21 | Output event state 1 | Ausgangswert zum Zeitpunkt des n-ten Timestamps | BOOLEAN | RO | 0x00 (0dez)
…. | …. | …. | …. | …. | ….
7pp1:2A | Output event state 10 |  | BOOLEAN | RO | 0x00 (0dez)
7pp1:41 | Output event time 1 | Timestamp des n-ten Events | UINT32 | RO | 0x00000000 (0dez)
…. | …. | …. | …. | …. | ….
7pp1:4A | Output event time 10 |  | UINT32 | RO | 0x00000000 (0dez)


Informations-/Diagnostikdaten (kanalspezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Informations-/Diagnostikdaten (kanalspezifisch)
Informations-/Diagnostikdaten (kanalspezifisch)
Index 0x9pp0 DOX Info data (Ch.1, pp=00; Ch.2, pp=01)
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
9pp0:0 | DOX Info data |  |  |  | UINT8 | RO | 0x06 (6dez)
9pp0:01 | Status word | Statuswort (vergleiche Index App0) | Bit-Offset | Bedeutung | UINT16 | RO | 0x0000 (0dez)
 |  |  | 0 | reserviert
 |  |  | 1 | 0: Kanal 1 1: Kanal 2
 |  |  | ... | reserviert
 |  |  | 4 | Overtemperature
 |  |  | 5 | Undervoltage
 |  |  | 6 | Overvoltage
 |  |  | ... | reserviert
 |  |  | 8 | Ready to activate
 |  |  | 9 | Output active
 |  |  | 10 | Tristate active
 |  |  | 11 | Saturated
 |  |  | ... | reserviert
 |  |  | 14 | Short circuit
 |  |  | 15 | Misc error
9pp0:02 | Coil voltage | aktuelle Ausgabespannung |  |  | UINT16 | RO | 0x0000 (0dez)
9pp0:03 | Coil current | aktueller Ausgabestrom |  |  | INT16 | RO | 0x0000 (0dez)
9pp0:06 | Duty cycle | aktueller Duty-Cycle |  |  | INT8 | RO | 0x00 (0dez)
9pp0:0A | Boost current counter region 1 | Anzahl der in Region 1 liegenden Boost Events (Boost-Strom liegt in Region 1). |  |  | UINT16 | RO | 0x0000 (0dez)
9pp0:0B | Boost current counter region 2 | Anzahl der in Region 2 liegenden Boost Events |  |  | UINT16 | RO | 0x0000 (0dez)
9pp0:0C | Boost current counter region 3 | Anzahl der in Region 3 liegenden Boost Events |  |  | UINT16 | RO | 0x0000 (0dez)
9pp0:0D | Boost current counter region 4 | Anzahl der in Region 4 liegenden Boost Events |  |  | UINT16 | RO | 0x0000 (0dez)
9pp0:0E | Last max. boost current | Letzter gemessener Boost-Strom |  |  | INT16 | RO | 0x0000 (0dez)
Index 0x9pp0 MTO Info data (Ch.1, pp=02; Ch.2, pp=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
9pp0:0 | MTO Info data |  | UINT8 | RO | 0x06 (6dez)
9pp0:01 | Event counter positive (buffer) | Anzahl der konfigurierten Output-Events (Ausgang wird auf 1 geschaltet) im Puffer. | UINT16 | RO | 0x0000 (0dez)
9pp0:02 | Event counter negative (buffer) | Anzahl der konfigurierten Output-Events (Ausgang wird auf 0 geschaltet) im Puffer. | UINT16 | RO | 0x0000 (0dez)
9pp0:03 | Event counter positive (output) | Anzahl der real geschalteten Output-Events (Ausgang wird auf 1 geschaltet). | UINT16 | RO | 0x0000 (0dez)
9pp0:04 | Event counter negative (output) | Number of output events actually switched (output is switched to 0). | UINT16 | RO | 0x0000 (0dez)
9pp0:05 | Past counter | Anzahl der konfigurierten, ungültigen Output-Events, bei denen der Zeitstempel in der Vergangenheit lag. | UINT16 | RO | 0x0000 (0dez)
9pp0:06 | Valid past counter | Anzahl der konfigurierten, gültigen Output-Events, bei denen der Zeitstempel in der Vergangenheit lag. | UINT16 | RO | 0x0000 (0dez)
9pp0:07 | Valid future counter | Anzahl der konfigurierten, gültigen Output-Events, bei denen der Zeitstempel in der Zukunft lag. | UINT16 | RO | 0x0000 (0dez)
9pp0:08 | Future counter | Anzahl der konfigurierten, ungültigen Output-Events, bei denen der Zeitstempel in der Zukunft lag. | UINT16 | RO | 0x0000 (0dez)
Index 0xApp0 DOX Diag data (Ch.1, pp=00; Ch.2, pp=00)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0 | DOX Diag data |  | UINT8 | RO | 0x09 (9dez)
App0:01 | Saturated | Treiberstufe arbeitet mit maximalem Duty-Cycle | BOOLEAN | RO | 0x00 (0dez)
App0:02 | Over temperature | Innentemperatur der Klemme ist größer als 80 °C | BOOLEAN | RO | 0x00 (0dez)
App0:03 | Low boost current | Aktueller Ausgabestrom war in der letzten Boost-Phase kleiner als „Boost current threshold 3“ | BOOLEAN | RO | 0x00 (0dez)
App0:04 | Under voltage | Versorgungsspannung kleiner als 8 V | BOOLEAN | RO | 0x00 (0dez)
App0:05 | Over voltage | Versorgungsspannung 10% größer, als die Nennspannung (siehe 8pp0:03) | BOOLEAN | RO | 0x00 (0dez)
App0:06 | Short circuit | Kurzschluss der Treiberstufe | BOOLEAN | RO | 0x00 (0dez)
App0:07 | Open Load | Keine Last an der Treiberstufe | BOOLEAN | RO | 0x00 (0dez)
App0:08 | No control power | Treiberstufe ohne Spannungsversorgung | BOOLEAN | RO | 0x00 (0dez)
App0:09 | Misc error | Innentemperatur der Klemme ist größer als 100 °C oder Kurzschluss der Treiberstufe oder Treiberstufe ohne Spannungsversorgung | BOOLEAN | RO | 0x00 (0dez)
Index 0xApp0 MTO Diag data (Ch.1, pp=02; Ch.2, pp=03)
Index (hex) | Name | Bedeutung | Data type | Flags | Default
App0:0 | MTO Diag data |  | UINT8 | RO | 0x02 (2dez)
App0:01 | Short circuit | Kurzschluss/Ueberlast | BOOLEAN | RO | 0x00 (0dez)
App0:02 | Undervoltage | Unterspannung des Ausgangsbausteines | BOOLEAN | RO | 0x00 (0dez)
App0:03 | Outdated timestamps in buffer | Anzahl der in den Puffer eingetragenen, ungültigen Timestamps (Timestamps waren schon abgelaufen, als sie in den Puffer eingetragen wurden). | BOOLEAN | RO | 0x00 (0dez)


Hersteller-Konfigurationsdaten (gerätespezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Hersteller-Konfigurationsdaten (gerätespezifisch)
Hersteller-Konfigurationsdaten (gerätespezifisch)
Index 0xF80F DOX Vendor data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F80F:0 | DOX Vendor data |  | UINT8 | RO | 0x06 (6dez)
F80F:01 | PWM Frequency | Zwischenkreisfrequenz (Einheit: 1 Hz) | UINT16 | RW | 0x7D00 (32000dez)
F80F:02 | Deadtime | Totzeit der Pulsweitenmodulation | UINT16 | RW | 0x0100 (256dez)
F80F:03 | Deadtime space | Duty Cycle Begrenzung | UINT16 | RW | 0x0009 (9dez)
F80F:04 | Warning temperature | Schwelle der Temperaturwarnung (Einheit: 1 °C) | INT8 | RW | 0x50 (80dez)
F80F:05 | Switch off temperature | Abschalttemperatur (Einheit: 1 °C) | INT8 | RW | 0x64 (100dez)
F80F:06 | Analog trigger point | Triggerpunkt der AD-Wandlung | UINT16 | RW | 0x000A (10dez)
F80F:07 | SYNC 0 shift time | Korrekturwert für den Sync 0 Impuls, um interne Laufzeiten zu kompensieren. | INT16 | RW | 0x0000 (0dez)


Informations-/Diagnostikdaten (gerätespezifisch)

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Informations-/Diagnostikdaten (gerätespezifisch)
Informations-/Diagnostikdaten (gerätespezifisch)
Index 0xF900 DOX Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DOX Info data |  | UINT8 | RO | 0x06 (6dez)
F900:01 | Software version (driver) | Softwareversion der Treiberkarte | STRING | RO |
F900:02 | Internal temperature | interne Klemmentemperatur (Einheit: 1 °C) | INT8 | RO | 0x00 (0dez)
F900:05 | Supply voltage | Versorgungsspannung (Einheit: 1 mV) | UINT16 | RO | 0x0000 (0dez)
F900:06 | Supply current | Gesamtstrom der Versorgungsspannung (Einheit: 1 mA) | UINT16 | RO | 0x0000 (0dez)


Distributed Clocks Ein-/Ausgangsdaten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Distributed Clocks Ein-/Ausgangsdaten
Distributed Clocks Ein-/Ausgangsdaten
Index 0xF600 DC Inputs
Index (hex) | Name | Bedeutung |  |  | Datentyp | Flags | Default
F600:0 | DC Inputs |  |  |  | UINT8 | RO | 0x01 (1dez)
F600:01 | Feedback | zurück gelesene Ausgabewerte | Bit 0 | Output Kanal 1 (Index 6000:02) | UINT8 | RO | 0x00 (0dez)
 |  |  | Bit 1 | Tristate Kanal 1 (Index 6000:03)
 |  |  | Bit 2 | Output Kanal 2 (Index 6010:02)
 |  |  | Bit 3 | Tristate Kanal 2 (Index 6010:03)
Index 0xF700 DC Outputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F700:0 | DC Outputs |  | UINT8 | RO | 0x03 (3dez)
F700:01 | Activate | Mit diesem Byte wird durch den Übergang 0 → 3 ein neuer Startzeitpunkt in der Klemme aktiviert | UINT8 | RO | 0x00 (0dez)
F700:03 | Start time | Wert des nächsten, gewünschten Schaltereignisses | UINT64 | RO |


Diagnosis History Daten

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Diagnosis History Daten
Diagnosis History Daten
Index 0x10F3 Diagnosis History
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F3:0 | Diagnosis History | siehe Kapitel Diag Messages | UINT8 | RO | 0x37 (55dez)
10F3:01 | Maximum Messages |  | UINT8 | RO | 0x00 (0dez)
10F3:02 | Newest Message |  | UINT8 | RO | 0x00 (0dez)
10F3:03 | Newest Acknowledged Message |  | UINT8 | RW | 0x00 (0dez)
10F3:04 | New Messages Available |  | BOOLEAN | RO | 0x00 (0dez)
10F3:05 | Flags |  | UINT16 | RW | 0x0000 (0dez)
10F3:06 - 10F3:37 | Diagnosis Message 001 - Diagnosis Message 050 |  | OCTET-STRING[28] | RO | {0}


Timestamp

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Timestamp
Timestamp
Index 0x10F8 Actual Time Stamp
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F8:0 | Actual Time Stamp | Aktueller Zeitstempel | UINT64 | RO |


Standardobjekte

Inbetriebnahme [image] Objektbeschreibung und Parametrierung [image] Standardobjekte
Standardobjekte
Index 0x1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00D21389 (13767561dez)
Index 0x1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL2212
Index 0x1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO | 00
Index 0x100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 0x1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x08A43052 (144978002dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00100000 (1048576dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 0x10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 0x14pp DOX RxPDO-Par Control (Ch.1: pp=00; Ch.2: pp=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
14pp:0 | DOX RxPDO-Par Control |  | UINT8 | RO | 0x06 (6dez)
14pp:06 | Exclude RxPDOs |  |  |  |
Index 0x1402 DOX RxPDO-Par Sync
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1402:0 | DOX RxPDO-Par Sync |  | UINT8 | RO | 0x06 (6dez)
1402:06 | Exclude RxPDOs |  |  |  |
Index 0x14pp DOX RxPDO-Par Control (MTO) (Ch.1: pp=03; Ch.2: pp=04)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
14pp:0 | DOX RxPDO-Par Control (MTO) |  | UINT8 | RO | 0x06 (6dez)
14pp:06 | Exclude RxPDOs |  |  |  |
Index 0x14pp MTO RxPDO-Par Outputs 10x
(Ch.1: pp=07; Ch.2: pp=0B)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
14pp:0 | MTO RxPDO-Par Outputs 10x |  | UINT8 | RO | 0x06 (6dez)
14pp:06 | Exclude RxPDOs |  |  |  |
Index 0x14pp MTO RxPDO-Par Outputs 5x
(Ch.1: pp=08; Ch.2: pp=0C)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
14pp:0 | MTO RxPDO-Par Outputs 5x |  | UINT8 | RO | 0x06 (6dez)
14pp:06 | Exclude RxPDOs |  |  |  |
Index 0x14pp MTO RxPDO-Par Outputs 2x
(Ch.1: pp=09; Ch.2: pp=0D)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
14pp:0 | MTO RxPDO-Par Outputs 2x |  | UINT8 | RO | 0x06 (6dez)
14pp:06 | Exclude RxPDOs |  |  |  |
Index 0x14pp MTO RxPDO-Par Outputs 1x
(Ch.1: pp=0A; Ch.2: pp=0E)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
14pp:0 | MTO RxPDO-Par Outputs 1x |  | UINT8 | RO | 0x06 (6dez)
14pp:06 | Exclude RxPDOs |  |  |  |
Index 0x16pp DOX RxPDO-Map Control (Ch.1, pp=00; Ch.2, pp=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | DOX RxPDO-Map Control | PDO Mapping | UINT8 | RO | 0x07 (7dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7pp0 (DOX Outputs, entry 0x02 (Output)) | UINT32 | RO | 0x7pp0:02, 1
16pp:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7pp0 (DOX Outputs, entry 0x03 (Tristate)) | UINT32 | RO | 0x7pp0:03, 1
16pp:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7pp0 (DOX Outputs, entry 0x04 (PWM)) | UINT32 | RO | 0x7pp0:04, 1
16pp:05 | SubIndex 005 | 5. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
16pp:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7pp0 (DOX Outputs, entry 0x08 (Reset)) | UINT32 | RO | 0x7pp0:08, 1
16pp:07 | SubIndex 007 | 7. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 0x1602 DC RxPDO-Map Sync
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | DC RxPDO-Map Sync | PDO Mapping | UINT8 | RO | 0x03 (3dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF700 (DC Outputs), entry 0x01 (Activate)) | UINT32 | RO | 0xF700:01, 8
1602:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF700 (DC Outputs), entry 0x03 (Start time)) | UINT32 | RO | 0xF700:03, 64
Index 0x16pp DOX RxPDO-Map Control (MTO)
(Ch.1: pp=03, nn=00; Ch.2: pp=04, nn=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | DOX RxPDO-Map Contro (MTO)l | PDO Mapping | UINT8 | RO | 0x05 (5dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 3
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7nn0 (DOX Outputs, entry 0x04 (PWM)) | UINT32 | RO | 0x7nn0:04, 1
16pp:03 | SubIndex 003 | 3. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
16pp:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7nn0 (DOX Outputs, entry 0x08 (Reset)) | UINT32 | RO | 0x7nn0:08, 1
16pp:05 | SubIndex 005 | 5. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 0x16pp DOX RxPDO-Map PWM
(Ch.1: pp=05, nn=00; Ch.2: pp=06, nn=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | DOX RxPDO-Map Control | PDO Mapping | UINT8 | RO | 0x02 (2dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7nn0 (DOX Outputs, entry 0x11 (Duty cycle)) | UINT32 | RO | 0x7nn0:11, 8
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7nn0 (DOX Outputs, entry 0x13 (PWM Tperiod)) | UINT32 | RO | 0x7nn0:13, 16
Index 0x16pp MTO RxPDO-Map 10x
(Ch.1: pp=07, nn=02; Ch.2: pp=0B, nn=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | MTO RxPDO-Map 10x | PDO Mapping | UINT8 | RO | 0x1D (29dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7nn1: 01, 1
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x02 (Manual output state)) | UINT32 | RO | 0x7nn1: 02, 1
16pp:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x03 (Force order)) | UINT32 | RO | 0x7nn1: 03, 1
16pp:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7nn1: 04, 1
16pp:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
16pp:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x09 (Output order counter)) | UINT32 | RO | 0x7nn1:09, 8
16pp:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x11 (No of output events)) | UINT32 | RO | 0x7nn1:11, 8
16pp:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
16pp:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7nn1:21, 1
…. | ….. | …. | …. | …. | ….
16pp:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7nn1:2A, 1
16pp:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
16pp:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7nn1:41, 32
…. | …. | …. | …. | …. | ….
16pp:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7nn1:4A, 32
Index 0x16pp MTO RxPDO-Map 5x
(Ch.1: pp=08, nn=02; Ch.2: pp=0C, nn=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | MTO RxPDO-Map 5x | PDO Mapping | UINT8 | RO | 0x13 (19dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7nn1: 01, 1
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x02 (Manual output state)) | UINT32 | RO | 0x7nn1: 02, 1
16pp:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x03 (Force order)) | UINT32 | RO | 0x7nn1: 03, 1
16pp:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7nn1: 04, 1
16pp:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
16pp:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x09 (Output order counter)) | UINT32 | RO | 0x7nn1:09, 8
16pp:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x11 (No of output events)) | UINT32 | RO | 0x7nn1:11, 8
16pp:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
16pp:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7nn1:21, 1
…. | ….. | …. | …. | …. | ….
16pp:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7nn1:25, 1
16pp:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
16pp:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7nn1:41, 32
…. | …. | …. | …. | …. | ….
16pp:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7nn1:45, 32
Index 0x16pp MTO RxPDO-Map 2x
(Ch.1: pp=09, nn=02; Ch.2: pp=0D, nn=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | MTO RxPDO-Map 2x | PDO Mapping | UINT8 | RO | 0x0D (13dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7nn1: 01, 1
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x02 (Manual output state)) | UINT32 | RO | 0x7nn1: 02, 1
16pp:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x03 (Force order)) | UINT32 | RO | 0x7nn1: 03, 1
16pp:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7nn1: 04, 1
16pp:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
16pp:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x09 (Output order counter)) | UINT32 | RO | 0x7nn1:09, 8
16pp:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x11 (No of output events)) | UINT32 | RO | 0x7nn1:11, 8
16pp:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
16pp:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7nn1:21, 1
16pp:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7nn1:22, 1
16pp:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
16pp:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7nn1:41, 32
16pp:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7nn1:42, 32
Index 0x16pp MTO RxPDO-Map 1x
(Ch.1: pp=0A, nn=02; Ch.2: pp=0E, nn=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
16pp:0 | MTO RxPDO-Map 1x | PDO Mapping | UINT8 | RO | 0x0D (13dez)
16pp:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7nn1: 01, 1
16pp:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x02 (Manual output state)) | UINT32 | RO | 0x7nn1: 02, 1
16pp:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x03 (Force order)) | UINT32 | RO | 0x7nn1: 03, 1
16pp:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7nn1: 04, 1
16pp:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
16pp:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x09 (Output order counter)) | UINT32 | RO | 0x7nn1:09, 8
16pp:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x11 (No of output events)) | UINT32 | RO | 0x7nn1:11, 8
16pp:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
16pp:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7nn1:21, 1
16pp:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
16pp:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7nn1 (MTO Outputs, entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7nn1:41, 32
Index 0x18pp DOX TxPDO-Par Status (Ch.1: pp=00; Ch.2: pp=02)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
18pp:0 | DOX TxPDO-Par Status | PDO Mapping | UINT8 | RO | 0x06 (6dez)
18pp:06 | Exclude TxPDOs |  |  |  |
Index 0x1804 DC TxPDO-Par Feedback
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1804:0 | DOX TxPDO-Par Status | PDO Mapping | UINT8 | RO | 0x06 (6dez)
1804:06 | Exclude TxPDOs |  |  |  |
Index 0x18pp DOX TxPDO-Par Status (MTO) (Ch.1: pp=05; Ch.2: pp=06)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
18pp:0 | DOX TxPDO-Par Status (MTO) | PDO Mapping | UINT8 | RO | 0x06 (6dez)
18pp:06 | Exclude TxPDOs |  |  |  |
Index 0x18pp MTO TxPDO-Par Inputs (Ch.1: pp=07; Ch.2: pp=08)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
18pp:0 | MTO TxPDO-Par Inputs | PDO Mapping | UINT8 | RO | 0x06 (6dez)
18pp:06 | Exclude TxPDOs |  |  |  |
Index 0x1App DOX TxPDO-Map Status (Ch.1: pp=00; Ch.2: pp=02)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | DOX TxPDO-Map Status | PDO Mapping | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1 PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x01 (Ready to activate)) | UINT32 | RO | 0x6pp0:01, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x02 (Output active)) | UINT32 | RO | 0x6pp0:02, 1
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x03 (Tristate active)) | UINT32 | RO | 0x6pp0:03, 1
1App:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x04 (PWM active)) | UINT32 | RO | 0x6pp0:04, 1
1App:05 | SubIndex 005 | 5. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1App:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x07 (Warning)) | UINT32 | RO | 0x6pp0:07, 1
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x08 (Error)) | UINT32 | RO | 0x6pp0:08, 1
1App:08 | SubIndex 008 | 8. PDO Mapping entry (5 bits align) | UINT32 | RO | 0x0000:00, 5
1App:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6pp0 (DOX Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6pp0:10, 1
Index 0x1App DOX TxPDO-Map Synchron info data
(Ch.1: pp=01, nn=00; Ch.2: pp=03, nn=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | DOX TxPDO-Map Synchron info data | PDO Mapping | UINT8 | RO | 0x02 (2dez)
1App:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x11 (Info data 1)) | UINT32 | RO | 0x6nn0:11, 16
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x12 (Info data 2)) | UINT32 | RO | 0x6nn0:12, 16
Index 0x1A04 DC TxPDO-Map Feedback
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | DC TxPDO-Map Feedback | PDO Mapping | UINT8 | RO | 0x02 (2dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0xF600 (DC Inputs), entry 0x01 (Feedback)) | UINT32 | RO | 0xF600:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 0x1App DOX TxPDO-Map Status (MTO)
(Ch.1: pp=05, nn=00; Ch.2: pp=06, nn=01)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | DOX TxPDO-Map Status (MTO) | PDO Mapping | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1 PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x01 (Ready to activate)) | UINT32 | RO | 0x6nn0:01, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1App:03 | SubIndex 004 | 3. PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x04 (PWM active)) | UINT32 | RO | 0x6nn0:04, 1
1App:04 | SubIndex 005 | 4. PDO Mapping entry (2 bits align) | UINT32 | RO | 0x0000:00, 2
1App:05 | SubIndex 006 | 5. PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x07 (Warning)) | UINT32 | RO | 0x6nn0:07, 1
1App:06 | SubIndex 007 | 6. PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x08 (Error)) | UINT32 | RO | 0x6nn0:08, 1
1App:07 | SubIndex 008 | 7. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1App:08 | SubIndex 009 | 8. PDO Mapping entry (object 0x6nn0 (DOX Inputs), entry 0x10 (TxPDO Toggle)) | UINT32 | RO | 0x6nn0:10, 1
Index 0x1App MTO TxPDO-Map Inputs
(Ch.1: pp=07, nn=02; Ch.2: pp=08, nn=03)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1App:0 | MTO TxPDO-Map Inputs) | PDO Mapping | UINT8 | RO | 0x09 (9dez)
1App:01 | SubIndex 001 | 1 PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6nn0:01, 1
1App:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6nn0:02, 1
1App:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x03 (Output state)) | UINT32 | RO | 0x6nn0:03, 1
1App:04 | SubIndex 004 | 4. PDO Mapping entry (3 bits align) | UINT32 | RO | 0x0000:00, 3
1App:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x07 (Warning)) | UINT32 | RO | 0x6nn0:07, 1
1App:06 | SubIndex 006 | 6. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1App:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6nn0:0F, 2
1App:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6nn0:11, 8
1App:09 | SubIndex 009 | 8. PDO Mapping entry (object 0x6nn0 (MTO Inputs), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6nn0:12, 8
Index 0x1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 0x1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x03 (3dez)
1C12:01 | Subindex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | Subindex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | Subindex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
Index 0x1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x03 (3dez)
1C13:01 | Subindex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | Subindex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:03 | Subindex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:04 | Subindex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:05 | Subindex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 0x1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0001 (1dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000F4240 (1000000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08)
UINT16
RO
0xC007 (49159dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x000186A0 (100000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 1C32:03, 1C32:05, 1C32:06, 1C32:09, 1C33:03, 1C33:06, 1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C32:09 | Maximum delay time | Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode) | UINT32 | RO | 0x00000000 (0dez)
1C32:0B | SM event missed counter | Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:0C | Cycle exceeded counter | Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh) | UINT16 | RO | 0x0000 (0dez)
1C32:0D | Shift too short counter | Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode) | UINT16 | RO | 0x0000 (0dez)
1C32:20 | Sync error | Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode) | BOOLEAN | RO | 0x00 (0dez)
Index 0x1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0022 (34dez)
1C33:02
Cycle time
wie 1C32:02
UINT32
RW
0x000F4240 (1000000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 1C32:08 oder 1C33:08)
UINT16
RO
0xC007 (49159dez)
1C33:05
Minimum cycle time
wie 1C32:05
UINT32
RO
0x000186A0 (100000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000000 (0dez)
1C33:08
Command
wie 1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:0B
SM event missed counter
wie 1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 1C32:32
BOOLEAN
RO
0x00 (0dez)
Index 0xF000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0004 (4dez)
Index 0xF008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index 0xF010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list |  | UINT8 | RW | 0x04 (4dez)
F010:01 | SubIndex 001 | Profil Nummer des DOX Interface | UINT32 | RW | 0x000000D2 (210dez)
F010:02 | SubIndex 002 | Profil Nummer des DOX Interface | UINT32 | RW | 0x000000D2 (210dez)
F010:03 | SubIndex 003 | Profil Nummer des MTO Interface | UINT32 | RW | 0x000000DC (220dez)
F010:04 | SubIndex 004 | Profil Nummer des MTO Interface | UINT32 | RW | 0x000000DC (220dez)


Anwendungsdemonstration 1: 12 V Relais

Inbetriebnahme [image] Anwendungsdemonstration 1: 12 V Relais
Anwendungsdemonstration 1: 12 V Relais
In diesem Beispiel wird die Beschleunigung des Schaltvorgangs an einem Kleinschaltrelais untersucht. Um die Auswirkung der Übererregung festzustellen wird nicht nur der Spulenstrom sondern auch die Schaltseite mit dem Wechsler mit dem Oszilloskop betrachtet.
Daten der Anwendung:
▪
Relais (Wechsler), 12V Erregungsspule mit 50 Ω Innenwiderstand
▪
Betrieb des Relais an 12 V Nominalspannung
▪
Betrieb des Relais an 24V Überspannung mit Boost-On- und Boost-Off-Phase
Der Aufbau stellt sich wie folgt dar:
Aufbau zur Anwendungsdemonstration 1
Die EL2212 wird an die Versorgungsspannung angebunden. Auf dem Oszilloskop werden gleich Öffner- und Schließerkontakt des Wechslerrelais als auch der Spulenstrom aufgezeichnet.
Ankerfederwirkung
Wenn im Relais die Spule die Ankerplatte bewegt, sind die elektrischen Kontakte über Bleche federnd angebunden. Deshalb ergibt sich in den folgenden Aufzeichnungen ein geringer Zeitverzug zwischen "Veränderung des Luftspaltes" und "Signaländerung auf der Schaltseite".
12 V Standardbetrieb
Erläuterung:
▪
Bei (A) beginnt die Bestromung.
▪
Nach ~7 ms (Raster 5 ms) öffnet sich der NC (normally closed) Kontakt (B).
▪
Der Spulenstrom sinkt entsprechend zum sich öffnenden Luftspalt ab.
▪
Sobald der NO-Kontakt (normally open) geschlossen und der Anker in Endlage ist (C, D) steigt der Spulenstrom weiter bis zur Sättigung bei 240 mA an (E).
▪
Der NO-Kontakt prellt beim Schließen (C).
▪
Nach 25 ms endet das Schaltsignal, der Spulenstrom sinkt langsam ab.
▪
Wenn sich der Luftspalt zwischen Anker und Spulenkern öffnet, steigt der Spulenstrom an, kurz danach öffnet sich der NO-Kontakt (F).
▪
Der NC-Kontakt prellt beim Schließen (G).
Betrieb | Einschaltverzögerung NO | Ausschaltverzögerung NO
Standardbetrieb | 8 ms (A - C) | 13 ms (E - F)
Nun wird die Übererregung aktiviert.
Übererregung, „Boost-On“ aktiviert
Erläuterung:
▪
durch den erhöhten Anregungsstrom, der bis auf ca. 480 mA ansteigt (C), schaltet der Kontakt deutlich schneller (B)
▪
nach 10 ms wird die Übererregung, die Boost-On-Phase beendet und der Haltestrom von 240 mA wird eingeregelt (D)
▪
nach 25 ms (E) wird das Signal wieder abgeschaltet
Nun wird zusätzlich die Boost-Off-Phase beim Abschalten aktiviert:
Boost-Off aktiviert
Erläuterung:
▪
die Abschaltung (A) arbeitet sofort mit Gegenspannung gegen die Spule und bewirkt erheblich schnelleres Umschalten des Relais.
▪
die mechanische Trägheit verzögert den Kontakt, wenn sich der Luftspalt am Ankerblech öffnet (B), steigt der Spulenstrom wieder an.
▪
die elektrischen Kontakte öffnen (C) bzw. schließen (D) unter Prellen kurz darauf.
▪
es wird hier eine Boost-Off-Phase von 5 ms Dauer und mit -100 mA Abschaltschwelle genutzt.
Der Abschaltvorgang wird durch die EL2212 erheblich beschleunigt.
Betrieb | Einschaltverzögerung NO | Ausschaltverzögerung NO
Standardbetrieb | 8 ms | 13 ms
mit Boost-On/Off-Phase | 3,5 ms | 3 ms
Anmerkung zur beschleunigten mechanischen Bewegung, in diesem Fall der Ankerplatte:
Durch extrem starkes Ansteuern kann der Anker so schnell gelöst werden, dass die Kontakte über den gesamten Öffnungsweg prellen, siehe folgende Abbildung.
Zu schneller Abschaltvorgang mit zurückprellenden Kontakten
Erläuterung:
▪
die Abschaltung (A) arbeitet sofort mit Gegenspannung gegen die Spule und bewirkt erheblich schnelleres Umschalten des Relais.
▪
als Abschaltschwelle sind -300 mA gewählt (B), weshalb eine abstoßende Kraft auf den Anker ausgeübt wird.
▪
der Wechsler schlägt ordnungsgemäß um, prellt dann aber bis zum NO zurück (C).
Mechanische Dynamik
Der Anwender hat die mechanisch ordnungsgemäße Funktion des Aktors sicherzustellen. Mit den Einstellparametern der Phasen kann die beschleunigende Wirkung reguliert werden.


Anwendungsdemonstration 2: 24 V Druckluftventil

Inbetriebnahme [image] Anwendungsdemonstration 2: 24 V Druckluftventil
Anwendungsdemonstration 2: 24 V Druckluftventil
Betrieben wird hier ein schnellschaltendes Druckluftventil mit 24 V Nennspannung und 25 Ω Innenwiderstand, das über eine PLC 20 ms eingeschaltet wird.
Aufbau zu Anwendungsdemonstration 2
Für diese Darstellung wurde ein Nennstrom von 600 mA für das Schalten des Ventils festgelegt. Die folgenden Abbildungen zeigen jeweils links die Aufzeichnung des Stromverlaufs mit dem Oszilloskop (umgerechnet 400 mA/div) und rechts die dazu gehörigen Einstellungen in den CoE Objekten Konfigurationsdaten, DOX Settings und DOX Features. Eingetragen wird:
▪
Haltestrom „Hold current“: 600 mA
▪
Versorgungsspannung „Supply voltage“: 24 V
▪
Wicklungswiderstand: 25 Ω
Exemplarischer Stromverlauf ILoad bei 24V Versorgungsspannung, normaler Betrieb der EL2212
Die Markierungen in der Oszilloskop-Aufzeichnung A bis D zeigen das Ein-/Abschalten des Ventils mit 24 V. Der Anker benötigt c.a. 5 ms bis zum Anzug und der Luftspalt geschlossen ist (A bis B). Der Erregungsstrom (Iload) von nominell 600 mA wird in der Haltephase bis D beibehalten.
Erläuterung der Oszilloskop-Aufzeichnung:
A: Einschalten des Ausgangs Beginn der Einschaltphase
B: Anzug des Ankers
D: Abschalten des Ausgangs (Ende der Einschaltphase)
F: Freigabe des Ankers
Nach dem Abschalten des Ausgangs (D) sinkt der Strom der Wicklung langsam ab. Der Zeitpunkt der mechanischen Loslösung des Ventilankers, erkennbar am Wiederanstieg der Stromkurve (F), gibt Auskunft über die benötigte Zeit des Abschaltens von ebenfalls c.a. 10 ms (tD bis tF).
1. Es wird die Haltephase mit geringerem Haltestrom konfiguriert
Per direkten CoE Zugriff über die TwinCAT Benutzeroberfläche wird eingetragen:
▪
Haltestrom „Hold current“: 400 mA
▪
Übererregungsstrom (Einschaltphase) „Boost current“: 600 mA
▪
Übererregungszeit – Ein, „Booster on time“: 10 ms
anschließend wird die Übererregung der Einschaltphase, „Boost-On“ aktiviert.
Einregeln des reduzierter Haltestroms nach Markierung C: das Ende der Übererregung in der Einschaltphase
Nach der Übererregungszeit „Boost on time“ (tA bis tC) der Einschaltphase beginnt die Klemmeninterne PWM-Regelung der EL2212, den Haltestrom von 600 mA auf 400 mA zu reduzieren. Im weiteren Verlauf wird von dem PLC Programm der Ausgang (nach den verbliebenden) 10 ms später wieder abgeschaltet (tC bis tD). Durch den reduzierten Haltestrom löst auch der Anker etwas früher, wie anhand der Verringerung der Zeit tF um etwa 1 ms zu sehen ist.
2. Aktivierung der Übererregung zum beschleunigten schalten
Zur Steigerung der Dynamik wird das 24 V-Ventil nun mit kurzzeitig 60 V Versorgungsspannung beaufschlagt. Ein doppelter Nennstromwert während der Übererregungszeit von 1200 mA wird zudem im CoE konfiguriert. Die Änderungen per CoE sind wie folgt:
▪
Versorgungsspannung „Supply voltage“: 60 V
▪
Übererregungsstrom der Einschaltphase „Boost on current“: 1200 mA
Da der Ventilanker bis zum Anzug nun statt 5 ms nur noch c.a. 2 ms benötigt (Markierung von A bis B), konnte die Übererregungszeit entsprechend verkürzt werden:
▪
Übererregungszeit der Einschaltphase „Booster on time“: 5 ms
Das Ergebnis ist dann wie im Folgenden zu sehen:
Stromverlauf ILoad bei 60V Versorgungsspannung und Übererregung mit 1200 mA/ 5 ms
Nach Markierung C, dem Ende der Übererregung in der Einschaltphase wird von der EL2212 der Haltestrom wieder bis zum konventionellen Abschalten (D) auf 400 mA eingeregelt.
3. Aktivierung der beschleunigten Abschaltung
Der Wicklung des Ventils wird zum beschleunigten lösen des Ankers eine Gegenspannung von 60 V „eingeprägt“. Dazu wird zur Vorsicht die Abschaltstromschwelle konfiguriert und aktiviert, denn es könnte zu unvorhergesehener Beschädigung mechanischer Komponenten kommen. Der Strom wird intern von der EL2212 ausgewertet und führt zum vorzeitigen Abschalten des gegenläufigen Stromes. Die CoE Einträge sind wie folgt vorzunehmen:
▪
Abschaltstromschwelle „Current switch off threshold“: 100 mA
▪
Übererregungszeit – Ein, „Booster off time“: 10 ms
Stromverlauf ILoad: Übererregung „ein“ mit 1200 mA/ 5 ms, „aus“ 5 ms und Abschaltstromschwelle +100 mA
In der Oszilloskop-Aufzeichnung zeigt Markierung E das Ende der Übererregung in der Abschaltphase „Booster off time”. Bereits etwa 0,5 ms nach dem Abschalten des Ausgangs (D) wird bei Markierung E die eingestellte Schaltschwelle von +100 mA erreicht und die Übererregung für das Abschalten, die „Boost-Off“-Phase ist damit beendet. Der Zeitraum von tD bis tF entspricht dem beschleunigten Abschalten des Ventils von nur noch c.a. 3 ms gegenüber ursprünglich 10 ms.
Zusammenfassung der Ergebnisse
Betrieb | Einschaltphase | Abschaltphase
konventionell | c.a. 5 ms | c.a. 10 ms
mit Übererregung Boost-On/Boost-Off | c.a. 2 ms | c.a. 3 ms
Verbesserung | c.a. 60% | c.a. 66%
Die erzielte Beschleunigung liegt bereits weit im Bereich üblicher PLC-Zykluszeiten. Bei entsprechender Berücksichtigung durch Sensoren oder Tests kann die Applikation einzelne Verfahrensschritte mit kürzerer Taktzeit ausführen.
Exemplarisch sind im Folgenden die Stromverläufe für zwei weitere unterschiedliche Abschaltstromschwellen in der übererregten Abschaltphase aufgezeigt:
Exemplarischer Stromverlauf ILoad mit Übererregter Ein- und Abschaltphase, Abschaltstromschwelle +300 mA
Exemplarischer Stromverlauf ILoad mit Übererregter Ein- und Abschaltphase, Abschaltstromschwelle -25 mA
Je größer die Abschaltstromschwelle umso kleiner die Abschaltzeit:
Die Abschaltphase verringert sich bei einer Abschaltstromschwelle von -25 mA bis zu c.a. 2 ms. Es ist naheliegend, dass diese Einstellung einen wesentlichen Einfluss auf den Verschleiß mechanischer Komponenten ausübt; insbesondere sollte eine Beschädigung vermieden werden und die Abschaltstromschwelle daher mit besonderer Beachtung gewählt werden.
Im Folgenden ist die Übererregte Abschaltphase, der Boost-Off wiederum deaktiviert und die externe PWM mit einem Tastverhältnis von 2,5 ms/ 5 ms, d.h. 50 % aktiviert und der Stromverlauf aufgezeichnet worden:
Exemplarischer Stromverlauf ILoad mit Übererregter Einschaltphase und PWM mit 50 % Tastverhältnis
Der Anzug und die Freigabe des Ventilankers ist wie gehabt an den Sattelpunkten des Stromverlaufs erkennbar (B und F). Da jedoch die Induktivität nicht groß genug ist, um bei dieser PWM Frequenz (200 Hz) den Strom angemessen zu glätten, sind die einzelnen Pulse am Stromverlauf erkennbar. Dennoch bleibt in diesem Beispiel der Ventilanker bis F aufgesetzt, da die mechanische Trägheit der Ventilkonstruktion eine derartige Ansteuerung ausreichend dämpft.


Beispielprogramme

Inbetriebnahme [image] Beispielprogramme
Beispielprogramme
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Weiterführende Informationen
•
Beispiel 1: Ausgabe und Auswertung von Pulsen
•
Beispiel 2: Multi-Timestamping


Beispiel 1: Ausgabe und Auswertung von Pulsen

Inbetriebnahme [image] Beispielprogramme [image] Beispiel 1: Ausgabe und Auswertung von Pulsen
Beispiel 1: Ausgabe und Auswertung von Pulsen
Download:
In diesem Beispielprogramm generiert eine EL2212 auf beiden Kanälen periodisch unterschiedliche Pulse.
Anschlussschema:
Verdrahtung für Beispielprogramm 1
Starten des Beispielprogramms
Die Applikationsbeispiele sind mit einem Prüfaufbau getestet und entsprechend beschrieben worden.
Etwaige Abweichungen bei der Einrichtung an realen Applikationen sind möglich.

Für den Prüfaufbau wurde folgende Hardware und Software verwendet:
▪
TwinCAT-Master-PC mit Betriebssystem Windows XP Professional SP 3, TwinCAT Version 2.10 (Build 1335) und INTEL PRO/100 VE Ethernet-Adapter
▪
Beckhoff EtherCAT Koppler EK1100, Klemmen EL9190, EL2212 und EL9010
▪
Einspeisung 24 .. 72 V DC in die EL9190
Vorgehensweise zum Starten des Programms
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.TSM (Konfigurationsdatei und *.PRO (PLC-Programmdatei) in einem temporären Arbeitsordner
▪
Start der *.TSM-Datei und *.PRO Datei; der TwinCAT-System Manger und die TwinCAT PLC öffnen sich
▪
Schließen Sie die Hardware entsprechend Abb. 1 an und verbinden Sie den Ethernet-Adapter ihres PCs mit dem EtherCAT-Koppler (weitere Hinweise hierzu finden sie in den entsprechenden Kopplerhandbüchern)
▪
Auswahl des lokalen Ethernet-Adapters (ggf. mit Echtzeit-Treiber) unter Systemkonfiguration, E/A - Konfiguration, E/A -Geräte, Gerät (EtherCAT); dann unter Karteireiter "Adapter", "Suchen..." den entsprechenden Adapter auswählen und bestätigen (siehe entsprechende Abbildungen)
Suchen des Ethernet-Adapters
Auswahl und Bestätigung des Ethernet-Adapters
▪
Aktivierung der Konfiguration und bestätigen
Aktivierung der Konfiguration
Konfigurationsaktivierung bestätigen
▪
Neue Variablenzuordnung bestätigen, Neustart im RUN-Modus
Variablenzuordnung erzeugen
Neustart TwinCAT im RUN-Modus
▪
In der TwinCAT PLC unter Menü "Projekt" → "Alles Übersetzen" das Projekt übersetzen
Projekt übersetzen
▪
In der TwinCAT PLC: Einloggen mit der Taste "F11", Laden des Programms bestätigen, Start des Programms mit Taste "F5"
Programmstart bestätigen


Beispiel 2: Multi-Timestamping

Inbetriebnahme [image] Beispielprogramme [image] Beispiel 2: Multi-Timestamping
Beispiel 2: Multi-Timestamping
Das folgende Beispielprogramm verwendet 10-fach Multi-Timestamping in dem ein Satz von 10 (Soll-) Schaltzuständen mit den dazugehörigen unterschiedlichen Schaltzeitpunkten den Prozessdaten der Klemme EL2212 übergeben wird. Damit die benötigten Prozessdaten zur Verknüpfung mit den Programmvariablen vorliegen muss unter dem Karteireiter Prozessdaten das Multi-Timestamping 10x ausgewählt werden:
Auswahl vordefinierter Prozessdaten über Karteireiter "Process_Data": Multitimestamping 2 Ch. 10x
Außerdem muss Distributed Clock verwendet werden und wird über den Karteireiter „DC“ ausgewählt:
Aktivierung von DC
Die Einstellungen in dem „DOX Settings“ Objekt für Kanal 1 (Index 0x8000) sind wie dargestellt vorzunehmen:
▪
Versorgungsspannung „Supply Voltage“: 60 V
▪
Haltestrom „Hold current“: 600 mA
▪
Wicklungswiderstand „Coil resistance“: 25 Ω
▪
Übererregungsstrom der Einschaltphase „Boost current“: 1200 mA (zunächst noch inaktiv)
▪
Abschaltstromschwelle „Current switch off threshold“: -300 mA (zunächst noch inaktiv)
▪
Übererregung, Zeit der Einschaltphase “Booster on time”: 5 ms
▪
Übererregung, Zeit der Abschaltphase “Booster off time”: 5 ms
Die Abschaltstromschwelle sollte „TRUE“ gesetzt sein, sie greift, sobald die Übererregung in der Ausschaltphase „Boost-Off“ aktiviert ist und verhindert so vorab eine eventuelle Überbeanspruchung von mechanischen Komponenten.
CoE Objekt 0x8000 Konfiguration zur 24 V Ventil-Ansteuerung
Ansteuerung eines Druckluftventils 24 V, 600 mA
Der aus der Anwendungsdemonstration 2 bereits eingesetzte Aufbau wird hier wiederverwendet: Angesteuert wird ein Druckluftventil mit 600 mA Haltestrom und abwechselnden Stromfluss ein/aus mit den folgenden 10 Schaltzeiten (in ms): [1, 50, 25, 75, 25, 50, 75, 50, 25, 50]. Der erste Schaltzustand ist ‚1‘ mit dem Schaltzeitpunkt 100 ms um für den Beginn der Schaltphasen die erste steigende Flanke sicher aus der PLC zu erzeugen. In den Abbildungen unten wurde für die Oszilloskop-Aufnahmen diese Flanke für den Trigger des Oszilloskops verwendet. Das Ventil ist an Kanal 1 der Klemme angeschlossen.
Kanalzuordnungen vom Oszilloskop:
▪
Kanal 1: Stromfluss in umgerechnet 400 mA / Teilung
▪
Kanal 4: Sollwert der Ansteuerung
Stromfluss (1) und Sollschaltwert (4): links ohne Übererregung, 600 mA Haltestrom; rechts mit Übererregung „Boost-On“ 10 ms/1200 mA und 400 mA Haltestrom
Stromfluss (1) und Sollschaltwert (4): links mit Übererregung „Boost-On“ 10 ms/1200 mA und Boost-Off 10 ms; zusätzlich mit aktivierter Abschaltstromschwelle „Current switch off threshold“ links auf -550 mA, rechts auf -300 mA
Ansteuerung eines Relais 24 V, 200 mA
Im Vergleich sind im Folgenden zwei Oszilloskop-Aufnahmen eines Relais mit den Schaltzeiten (in ms) von [100, 200, 250, 100, 150, 200, 100, 150, 200, 150] gezeigt. In dem CoE Objekt „DOX Settings Ch. 1“ ist zuvor der Haltestrom mit 200 mA sowie der Stromwert der Übererregung mit 400 mA entsprechend eingetragen. Mit dem ersten Schaltzustand ‚1‘ und dem ersten dazugehörigen Schaltzeitpunkt 100 ms aus der PLC wird wieder die erste steigende Flanke für den Trigger erzeugt.
Kanalzuordnungen vom Oszilloskop:
▪
Kanal 1: Stromfluss in umgerechnet 200 mA / Teilung
▪
Kanal 2: Öffner (NC) des Relais
▪
Kanal 3: Schließer (NO) des Relais
▪
Kanal 4: Sollwert der Ansteuerung
Aufzeichnung mit dem Oszilloskop: Ansteuerung eines Relais mit Multitimestamping
Im rechten Oszillogramm ist das bereits aus der Anwendungsdemonstration 1 bekannte Prellen vom Öffner- und Schließerkontakt zu sehen, dass durch einen zu hohen Gegenstrom aus der Übererregung der Abschaltphase, dem „Boost-Off“ in der Steuerspule und damit einem zu schnellen Abschalten hervorgerufen wurde.
Programm zum Beispiel 2
Alle Feldvariablen sind entsprechend eines Kanals mit jeweils allen notwenigen Zustands, Ausgangs und Eingangsvariablen zu verknüpfen. In dem zum Download zur Verfügung stehenden Beispiel ist dies bereits erfolgt:
Download:
Sie können entweder einen embedded PC verwenden, an dem die Klemme rechtsseitig angebracht wird, oder einen IPC mit einer EtherCAT-Verbindung eines z.B. RJ-45 Anschlusses zum EK1100 Koppler mit der Klemme (z.B. C6915 + EK1100 + EL9190 + EL2212). Optional kann eine digitale Eingangsklemme z.B. EL1004 zusätzlich vor die EL9190 zur Programmsteuerung eingesetzt werden. Anstelle eines Ventils ist ein Relais angeschlossen, dessen Wicklungswiderstand entsprechend im
CoE Objekt DOX Settings (0x8000:05) einzustellen ist.
Variablendeklaration:
PROGRAM MAIN
VAR_INPUT
// External switch to start by user
bEnable AT%I* : BOOL;
// To check if last tasks were already executed
bReadyToActivate AT%I* : BOOL;
// Target state given back by the EL2212 (Feedback)
bOutputState AT%I* : BOOL;
END_VAR
VAR_OUTPUT
// Reference signal for e.g. trigger of oscilloscope
bOutputReference AT%Q* : BOOL;
// Link to terminal EL2212 (Output event time n):
aQE_Time AT%Q* : ARRAY[0..9] OF UDINT;
// Link to terminal EL2212 (Output event state n):
aQE_State AT%Q* : ARRAY[0..9] OF BOOL;
// Outputvariables to reset the output-buffers of EL2212
bOutputBufReset AT%Q* : BOOL;
// Real number of fixed State/Time-Events as a Task for EL2212
nNoOfOutputEvents AT%Q* : USINT;
// Start-Event to trigger beginning of task scheduling
nOutputOrderCnt AT%Q* : USINT;
END_VAR
VAR
aSwitchTime : ARRAY[0..9] OF UDINT:=
// All 10 time offsets in ms allocated to the 10 states:
[
100, 200, 250, 100, 150, 200, 100, 150, 200, 150
];
nState : UINT:=0; // Use for "CASE .. OF" statement
nShortTime : ULINT; // Timevalue of current DC time/ lower 32 Bit only
nCurrentTime : ULINT; // Current DC-Time of the PLC-Task
bStateValue : BOOL; // Variable to set a toggled state of a task-event
nScheduleNo: INT; // Consists No of respective state/time pair
// of a Switch-Task
END_VAR
Programmcode:
// Example program 2: 10x Multi-Timestamp for EL2212
nCurrentTime := F_GetCurDcTaskTime64(); // Get current DC-Time (Task-Related)
// Overtake feedback of EL2212 to any output terminal
// for using as trigger / reference signal:
bOutputReference := bOutputState;
CASE nState OF
// ====================== Do some initializations here: ============================
0:
// Reset ouput buffer of the terminal EL2212
bOutputBufReset := TRUE;
nState := nState + 1;// Go to next state
1:
bOutputBufReset := FALSE;
nState := nState + 1; // Go to next state
2:
// Wait for external start-event by user (e.g. ext. switch)
IF bEnable THEN
nState := 10; // Go to next state and set events
END_IF
// =================================================================================
// ============ Now fill up all state/time pairs for the four channels =============
10:
// Last tasks already executed?
IF bReadyToActivate THEN
bStateValue:=1;
// Set first state level ('1')
aQE_State[0] := bStateValue;
// Cut 64 Bit time value to 32 Bit
nShortTime := nCurrentTime AND 16#FFFFFFFF;
// Set first time value (duration for "save" begin)
aQE_Time[0] := (ULINT_TO_UDINT(nShortTime)
+ aSwitchTime[0] * 1000000);
// Use 'nScheduleNo' as loop counter
FOR nScheduleNo:=1 TO 9 DO
bStateValue := NOT bStateValue;
// Set inverting output states of one switch-task
aQE_State[nScheduleNo] := bStateValue;
// Set timestamps of one switch-task
aQE_Time[nScheduleNo] := (aQE_Time[nScheduleNo-1]
+ aSwitchTime[nScheduleNo] * 1000000);
END_FOR
nState := nState + 1; // Go to next state
END_IF
// =================================================================================
// ======== Allow some taskcycles (min. 2) to let EL2212 schedule all tasks ========
11:
// 'nScheduleNo' is still 9; wait until 12: 3 more PLC-Taskcycles
IF nScheduleNo = 12 THEN
nNoOfOutputEvents := 10;
// Trigger Multi-Timestamp scheduling: now start:
nOutputOrderCnt := nOutputOrderCnt + 1;
nState := nState + 1;
ELSE
// Just count PLC-Taskcycles here
nScheduleNo := nScheduleNo + 1;
END_IF
12:
// ================================== End ==========================================
// Wait for external switch to be released
IF NOT bEnable THEN
nState := 0; // Go to beginning state
END_IF
END_CASE
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1
Sehen Sie hierzu auch weitere Hinweise in dem Kapitel:
Inbetreibnahme, TwinCAT Quickstart, TwinCAT 3, Startup.
Zuordnung der Prozessdaten und Einstellungen
EL2212: Karteireiter „DC“ – Auswahl der DC Betriebsart
Für die Funktionsfähigkeit dieses Programms muss die Betriebsart „DC active (controller handled)“ gesetzt sein.
Zuordnung der externen Variablen aus „Main“ zu den Multitimestamping-PDOs


Diagnose

Diagnose
Diagnose
Die EL2212 bietet zwei Verfahren zur Diagnose:
▪
Prozessdaten
Im Status-Word der Prozessdaten wird Warning/Error angezeigt.
In diesem Fall muss im CoE-Objekt 0xA0n0 azyklisch kontrolliert werden, welcher Fehler vorliegt.
▪
Diag Messages
Diag Messages können jederzeit aus dem CoE-Objekt 0x10F3 ausgelesen werden.
Versorgungsspannung
Die Versorgungsspannung 24..72 V DC muss anliegen, um auf das CoE zugreifen zu können. Anderenfalls werden einige Parameteränderungen nicht akzeptiert. Angezeigt wird dies im CoE-Objekt DiagData 0xA00n0:08 "No control power", durch die rote Error-LED und das Error-Bit im Status-Word.
Systemmanager Logger-Ausgabe
Erklärung einiger typischer Logger-Meldungen der EL2212:
Logger-Meldungen der EL2212
▪
Parameter written too high, 0x06090031
CoE-Parameter ist zu groß, die Firmware begrenzt die zu schreibenden Werte
▪
Parameter written too low, 0x06090032
CoE-Parameter ist zu klein, die Firmware begrenzt die zu schreibenden Werte
▪
Data can not be transferred or stored to the application because of the present device state, 0x08000022
Versorgungsspannung fehlt, Klemme teilweise außer Betrieb
Prozessdaten/CoE
Die Klemme bietet dem Anwender zur Diagnose verschiedene Werte im CoE an. Siehe dazu auch das entsprechende Prozessabbild.
CoE -Diagnsosedaten
Index 0x9000 bietet verschiedene, kanalbezogene Messwerte, wie Aktor-Spannung bzw. -Strom. Aus Index 0xA000 kann der Anwender beim Auftreten einer Warnung oder eines Fehlers genaue Informationen über die Ursache der Störung erfahren.
Die Warning/Error-Meldung wird über die Prozessdaten transportiert.

Für den Kanal 2 sind die entsprechenden Werte aus Index 0x9010 und 0xA010 zu entnehmen. Klemmenspezifische Informationen findet man in Index 0xF900.
Alle 9000er und A000er Objekte können über die "Synchron info data" ins Prozessabbild eingeblendet werden und sind über Index 0x8002:11 bzw. 0x8002:19 zu konfigurieren.
Bedeutung der Bits in "Diag data":
▪
Saturated: Stromreglerausgabe von 100 % Duty Cycle
▪
Over temperature: die Innentemperatur der Klemme ist größer als 80 °C, bei mehr als 100°C wird Misc error ebenfalls gesetzt
▪
Under voltage: die Versorgungsspannung ist 80% kleiner als die eingestellten Nennspannung
▪
Over voltage: die Versorgungsspannung ist 10% größer als die eingestellten Nennspannung
▪
Short circuit: Kurzschluss der Treiberstufe
▪
No control power: keine Steuerspannung / Versorgungsspannung angelegt
▪
Misc error: allgemeine Fehleranzeige
Diag Messages
Mit Diag Messages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem Systemmanager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Siehe dazu die Diag Messages Hinweise.
Diag Messages der EL2212
Ein Auszug aus den DiagMessages der EL2212:
Wert | Bedeutung | Interpretation
0x0001 | No error | Kein Fehler
0x0002 | Communication established | Kommunikation hergestellt
0x0003 | Initialization: 0x0, Mode, Channel | Initialisierung
0x8002 | Communication aborted | Kommunikation abgebrochen
0x8100 | Statusword changed: 0xChannel | Fehlerbit im Status-Word geändert
0x8200 | write access error | interner Fehler
Weiterführende Informationen
•
Diagnose-LEDs
•
Diagnose - Grundlagen zu Diag Messages


Diagnose-LEDs

Diagnose [image] Diagnose-LEDs
Diagnose-LEDs
LED | Farbe | Bedeutung
Run | grün | Diese LED gibt den Betriebszustand der Klemme wieder.
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme.
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion der Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt.
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed-Clocks. Ausgänge bleiben im sicheren Zustand.
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme
Power | grün | aus | interne Kommunikation zur Feldseite gestört (z.B. durch fehlende Versorgungsspannung)
 |  | an | interne Kommunikation i.O.
Enable A/B | grün | aus | Ansteuerung ist gesperrt oder EL2212 ist nicht betriebsbereit.
 |  | an | Ansteuerung ist freigeschaltet oder EL2212 ist betriebsbereit.
Warning A/B | gelb | aus | keine Mängel
 |  | an | Betriebswarnung z. B.: - Versorgungsspannung außerhalb des konfigurierten Bereichs - 80°C Temperatur überschritten ...
Error A/B | rot | aus | keine Mängel
 |  | an | Konfigurationsfehler, z. B.: - keine Versorgungsspannung angeschlossen - 100°C Temperatur überschritten - Kurzschluss ...


Diagnose - Grundlagen zu Diag Messages

Diagnose [image] Diagnose - Grundlagen zu Diag Messages
Diagnose - Grundlagen zu Diag Messages
Mit DiagMessages wird ein System der Nachrichtenübermittlung vom EtherCAT Slave an den EtherCAT Master/TwinCAT bezeichnet. Die Nachrichten werden vom Gerät im eigenen CoE unter 0x10F3 abgelegt und können von der Applikation oder dem System Manager ausgelesen werden. Für jedes im Gerät hinterlegtes Ereignis (Warnung, Fehler, Statusänderung) wird eine über einen Code referenzierte Fehlermeldung ausgegeben.
Definition
Das System DiagMessages ist in der ETG (EtherCAT Technology Group) in der Richtlinie ETG.1020, Kap. 13 "Diagnosis Handling" definiert. Es wird benutzt, damit vordefinierte oder flexible Diagnosemitteilungen vom EtherCAT-Slave an den Master übermittelt werden können. Das Verfahren kann also nach ETG herstellerübergreifend implementiert werden. Die Unterstützung ist optional. Die Firmware kann bis zu 250 DiagMessages im eigenen CoE ablegen.
Jede DiagMessage besteht aus
▪
Diag Code (4 Byte)
▪
Flags (2 Byte; Info, Warnung oder Fehler)
▪
Text-ID (2 Byte; Referenz zum erklärenden Text aus der ESI/XML)
▪
Zeitstempel (8 Byte, lokale Slave-Zeit oder 64-Bit Distributed-Clock-Zeit, wenn vorhanden)
▪
dynamische Parameter, die von der Firmware mitgegeben werden
In der zum EtherCAT-Gerät gehörigen ESI/XML-Datei werden die DiagMessages in Textform erklärt: Anhand der in der DiagMessage enthaltenen Text-ID kann die entsprechende Klartextmeldung in den Sprachen gefunden werden, die in der ESI/XML enthalten sind. Üblicherweise sind dies bei Beckhoff-Produkten deutsch und englisch.
Der Anwender erhält durch den Eintrag NewMessagesAvailable Information, dass neue Meldungen vorliegen.
DiagMessages können im Gerät bestätigt werden: die letzte/neueste unbestätigte Meldung kann vom Anwender bestätigt werden.
Im CoE finden sich sowohl die Steuereinträge wie die History selbst im CoE-Objekt 0x10F3:
DiagMessages im CoE
Unter x10F3:02 ist der Subindex der neuesten DiagMessage auslesbar.
Unterstützung zur Inbetriebnahme
Das System der DiagMesssages ist vor allem während der Anlageninbetriebnahme einzusetzen. Zur Online-Diagnose während des späteren Dauerbetriebs sind die Diagnosewerte z.B. im StatusWord des Gerätes (wenn verfügbar) hilfreich.
Implementierung TwinCAT System Manager
Ab TwinCAT 2.11 werden DiagMessages, wenn vorhanden, beim Gerät in einer eigenen Oberfläche angezeigt. Auch die Bedienung (Abholung, Bestätigung) erfolgt darüber.
Implementierung DiagMessage-System im TwinCAT System Manager
Im Reiter Diag History (A) sind die Betätigungsfelder (B) wie auch die ausgelesene History (C) zu sehen. Die Bestandteile der Message:
▪
Info/Warning/Error
▪
Acknowledeg-Flag (N = unbestätigt, Q = bestätigt)
▪
Zeitstempel
▪
Text-ID
▪
Klartext-Meldung nach ESI/XML Angabe
Die Bedeutung der Buttons ist selbsterklärend.
DiagMessages im ADS Logger/Eventlogger
Ab TwinCAT 3.1 build 4022 werden von einer Klemme abgesetzte DiagMessages auch im TwinCAT ADS Logger gezeigt. Da nun IO-übergreifend DiagMessages an einem Ort dargestellt werden, vereinfacht dies die Inbetriebnahme. Außerdem kann die Logger-Ausgabe in eine Datei gespeichert werden – somit stehen die DiagMessages auch langfristig für Analysen zur Verfügung.
Nachrichten in die PLC einlesen
- In Vorbereitung -
Interpretation
Zeitstempel
Der Zeitstempel wird aus der lokalen Uhr der Klemme zum Zeitpunkt des Ereignisses gewonnen. Die Zeit ist üblicherweise die Distributed-Clocks-Zeit (DC) aus Register x910.
Bitte beachten: die DC-Zeit wird in der Referenzuhr gleich der lokalen IPC/TwinCAT-Zeit gesetzt, wenn EtherCAT gestartet wird. Ab diesem Moment kann die DC-Zeit gegenüber der IPC-Zeit divergieren, da die IPC-Zeit nicht nachgeregelt wird. Es können sich so nach mehreren Wochen Betrieb ohne EtherCAT Neustart größere Zeitdifferenzen entwickeln. Als Abhilfe kann die sog. Externe Synchronisierung der DC-Zeit genutzt werden, oder es wird fallweise eine manuelle Korrekturrechnung vorgenommen: die aktuelle DC-Zeit kann über den EtherCAT Master oder durch Einsicht in das Register x901 eines DC-Slaves ermittelt werden.
Aufbau der Text-ID
Der Aufbau der MessageID unterliegt keiner Standardisierung und kann herstellerspezifisch definiert werden. Bei Beckhoff EtherCAT-Geräten (EL, EP) lautet er nach xyzz üblichwerweise:
x | y | zz
0: Systeminfo 1: Info 2: reserved 4: Warning 8: Error | 0: System 1: General 2: Communication 3: Encoder 4: Drive 5: Inputs 6: I/O allgemein 7: reserved | Fehlernummer
Beispiel: Meldung 0x4413 --> Drive Warning Nummer 0x13
Übersicht Text-IDs
Spezifische Text-IDs sind in der Gerätedokumentation aufgeführt.
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x0001 | Information | System | No error | Kein Fehler
0x0002 | Information | System | Communication established | Verbindung aufgebaut
0x0003 | Information | System | Initialisation: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1000 | Information | System | Information: 0x%X, 0x%X, 0x%X | allgemeine Information, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x1012 | Information | System | EtherCAT state change Init - PreOp |
0x1021 | Information | System | EtherCAT state change PreOp - Init |
0x1024 | Information | System | EtherCAT state change PreOp - Safe-Op |
0x1042 | Information | System | EtherCAT state change SafeOp - PreOp |
0x1048 | Information | System | EtherCAT state change SafeOp - Op |
0x1084 | Information | System | EtherCAT state change Op - SafeOp |
0x1100 | Information | Allgemein | Detection of operation mode completed: 0x%X, %d | Erkennung der Betriebsart beendet
0x1135 | Information | Allgemein | Cycle time o.k.: %d | Zykluszeit o.k.
0x1157 | Information | Allgemein | Data manually saved (Idx: 0x%X, SubIdx: 0x%X) | Daten manuell gespeichert
0x1158 | Information | Allgemein | Data automatically saved (Idx: 0x%X, SubIdx: 0x%X) | Daten automatisch gespeichert
0x1159 | Information | Allgemein | Data deleted (Idx: 0x%X, SubIdx: 0x%X) | Daten gelöscht
0x117F | Information | Allgemein | Information: 0x%X, 0x%X, 0x%X | Information
0x1201 | Information | Kommunikation | Communication re-established | Kommunikation zur Feldseite wiederhergestellt Die Meldung tritt auf, wenn z. B. im Betrieb die Spannung der Powerkontakte entfernt und wieder angelegt wurde
0x1300 | Information | Encoder | Position set: %d, %d | Position gesetzt - StartInputhandler
0x1303 | Information | Encoder | Encoder Supply ok | Encoder Netzteil OK
0x1304 | Information | Encoder | Encoder initialization successfully, channel: %X | Encoder Initialisierung erfolgreich abgeschlossen
0x1305 | Information | Encoder | Sent command encoder reset, channel: %X | Sende Kommando Encoder Reset
0x1400 | Information | Drive | Drive is calibrated: %d, %d | Antrieb ist kalibriert
0x1401 | Information | Drive | Actual drive state: 0x%X, %d | Aktueller Status des Antriebs
0x1705 | Information |  | CPU usage returns in normal range (< 85%%) | Prozessorauslastung ist wieder im normalen Bereich
0x1706 | Information |  | Channel is not in saturation anymore | Kanal ist nicht mehr in Sättigung
0x1707 | Information |  | Channel is not in overload anymore | Kanal ist nicht mehr überlastet
0x170A | Information |  | No channel range error anymore | Es liegt kein Messbereichsfehler mehr vor
0x170C | Information |  | Calibration data saved | Abgleichdaten wurden gespeichert
0x170D | Information |  | Calibration data will be applied and saved after sending the command “0x5AFE” | Abgleichdaten werden erst nach dem Senden des Kommandos „0x5AFE“ übernommen und gespeichert
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x2000 | Information | System | %s: %s |
0x2001 | Information | System | %s: Network link lost | Netzwerk Verbindung verloren
0x2002 | Information | System | %s: Network link detected | Netzwerk Verbindung gefunden
0x2003 | Information | System | %s: no valid IP Configuration - Dhcp client started | Ungültige IP Konfiguration
0x2004 | Information | System | %s: valid IP Configuration (IP: %d.%d.%d.%d) assigned by Dhcp server %d.%d.%d.%d | Gültige, vom DHCP-Server zugewiesene IP-Konfiguration
0x2005 | Information | System | %s: Dhcp client timed out | Zeitüberschreitung DHCP-Client
0x2006 | Information | System | %s: Duplicate IP Address detected (%d.%d.%d.%d) | Doppelte IP-Adresse gefunden
0x2007 | Information | System | %s: UDP handler initialized | UDP-Handler initialisiert
0x2008 | Information | System | %s: TCP handler initialized | TCP-Handler initialisiert
0x2009 | Information | System | %s: No more free TCP sockets available | Keine freien TCP Sockets verfügbar
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x4000 | Warnung |  | Warning: 0x%X, 0x%X, 0x%X | allgemeine Warnung, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x4001 | Warnung | System | Warning: 0x%X, 0x%X, 0x%X |
0x4002 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d API:%dms) from %d.%d.%d.%d successful |
0x4003 | Warnung | System | %s: %s Connection Close (IN:%d OUT:%d) from %d.%d.%d.%d successful |
0x4004 | Warnung | System | %s: %s Connection (IN:%d OUT:%d) with %d.%d.%d.%d timed out |
0x4005 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Error: %u) |
0x4006 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Input Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4007 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (Output Data Size expected: %d Byte(s) received: %d Byte(s)) |
0x4008 | Warnung | System | %s: %s Connection Open (IN:%d OUT:%d) from %d.%d.%d.%d denied (RPI:%dms not supported -> API:%dms) |
0x4101 | Warnung | Allgemein | Terminal-Overtemperature | Übertemperatur. Die Innentemperatur der Klemme überschreitet die parametrierte Warnschwelle
0x4102 | Warnung | Allgemein | Discrepancy in the PDO-Configuration | Die ausgewählten PDOs passen nicht zur eingestellten Betriebsart. Beispiel: Antrieb arbeitet im Velocity-Mode. Das Velocity-PDO ist jedoch nicht in die PDOs gemapped.
0x417F | Warnung | Allgemein | Warnung: 0x%X, 0x%X, 0x%X |
0x428D | Warnung | Allgemein | Challenge is not Random |
0x4300 | Warnung | Encoder | Subincrements deactivated: %d, %d | Subinkremente deaktiviert (trotz aktivierter Konfiguration)
0x4301 | Warnung | Encoder | Encoder-Warning | Allgemeiner Encoderfehler
0x4400 | Warnung | Drive | Drive is not calibrated: %d, %d | Antrieb ist nicht kalibriert
0x4401 | Warnung | Drive | Starttype not supported: 0x%X, %d | Starttyp wird nicht unterstützt
0x4402 | Warnung | Drive | Command rejected: %d, %d | Kommando abgewiesen
0x4405 | Warnung | Drive | Invalid modulo subtype: %d, %d | Modulo-Subtyp ungültig
0x4410 | Warnung | Drive | Target overrun: %d, %d | Zielposition wird überfahren
0x4411 | Warnung | Drive | DC-Link undervoltage (Warning) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x4412 | Warnung | Drive | DC-Link overvoltage (Warning) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x4413 | Warnung | Drive | I2T-Model Amplifier overload (Warning) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x4414 | Warnung | Drive | I2T-Model Motor overload (Warning) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x4415 | Warnung | Drive | Speed limitation active | Die maximale Drehzahl wird durch die parametrierten Objekte (z.B. velocity limitation, motor speed limitation) begrenzt. Die Warnung wird ausgegeben, wenn die Sollgeschwindigkeit größer ist, als eines der parametrierten Begrenzungen
0x4416 | Warnung | Drive | Step lost detected at position: 0x%X%X | Schrittverlust erkannt
0x4417 | Warnung | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Warnschwelle.
0x4418 | Warnung | Drive | Limit: Current | Limit: Strom wird limitiert
0x4419 | Warnung | Drive | Limit: Amplifier I2T-model exceeds 100%% | Die Schwellwerte für den maximalen Strom wurden überschritten.
0x441A | Warnung | Drive | Limit: Motor I2T-model exceeds 100%% | Limit: Motor I2T-Modell übersteigt 100%
0x441B | Warnung | Drive | Limit: Velocity limitation | Die Schwellwerte für die maximale Drehzahl wurden überschritten.
0x441C | Warnung | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x4600 | Warnung | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x4610 | Warnung | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x4705 | Warnung |  | Processor usage at %d %% | Prozessorauslastung bei %d %%
0x470A | Warnung |  | EtherCAT Frame missed (change Settings or DC Operation Mode or Sync0 Shift Time) | EtherCAT Frame verpasst (Einstellungen, DC Operation Mode oder Sync0 Shift Time ändern)
Text-ID | Typ | Ort | Text Message | Zusätzlicher Kommentar
0x8000 | Fehler | System | %s: %s |
0x8001 | Fehler | System | Error: 0x%X, 0x%X, 0x%X | allgemeiner Fehler, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8002 | Fehler | System | Communication aborded | Kommunikation abgebrochen
0x8003 | Fehler | System | Configuration error: 0x%X, 0x%X, 0x%X | allgemeine, Parameter je nach Ereignis. Interpretation siehe Gerätedokumentation.
0x8004 | Fehler | System | %s: Unsuccessful FwdOpen-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8005 | Fehler | System | %s: FwdClose-Request sent to %d.%d.%d.%d (%s) |
0x8006 | Fehler | System | %s: Unsuccessful FwdClose-Response received from %d.%d.%d.%d (%s) (Error: %u) |
0x8007 | Fehler | System | %s: Connection with %d.%d.%d.%d (%s) closed |
0x8100 | Fehler | Allgemein | Status word set: 0x%X, %d | Fehlerbit im Statuswort gesetzt
0x8101 | Fehler | Allgemein | Operation mode incompatible to PDO interface: 0x%X, %d | Betriebsart inkompatibel zum PDO-Interface
0x8102 | Fehler | Allgemein | Invalid combination of Inputs and Outputs PDOs | Ungültige Kombination von In- und Output PDOs
0x8103 | Fehler | Allgemein | No variable linkage | Keine Variablen verknüpft
0x8104 | Fehler | Allgemein | Terminal-Overtemperature | Die Innentemperatur der Klemme überschreitet die parametrierte Fehlerschwelle. Das Aktivieren der Klemme wird unterbunden
0x8105 | Fehler | Allgemein | PD-Watchdog | Die Kommunikation zwischen Feldbus und Endstufe wird durch einen Watchdog abgesichert. Sollte die Feldbuskommunikation abbrechen, wird die Achse automatisch gestoppt. - Die EtherCAT-Verbindung wurde im Betrieb unterbrochen - Der Master wurde im Betrieb in den Config-Mode geschaltet
0x8135 | Fehler | Allgemein | Cycletime has to be a multiple of 125 µs | Die IO- oder NC-Zykluszeit ist nicht ganzzahlig durch 125µs teilbar
0x8136 | Fehler | Allgemein | Configuration error: invalid sampling rate | Konfigurationsfehler: Ungültige Samplingrate
0x8137 | Fehler | Allgemein | Elektronisches Typenschild: CRC-Fehler | Inhalt des Speicher des externen Typenschildes nicht gültig.
0x8140 | Fehler | Allgemein | Sync Error | Echtzeitverletztung
0x8141 | Fehler | Allgemein | Sync%X Interrupt lost | Sync%X Interrupt fehlt
0x8142 | Fehler | Allgemein | Sync Interrupt asynchronous | Sync Interrupt asynchron
0x8143 | Fehler | Allgemein | Jitter too big | Jitter Grenzwertüberschreitung
0x817F | Fehler | Allgemein | Error: 0x%X, 0x%X, 0x%X |
0x8200 | Fehler | Kommunikation | Write access error: %d, %d | Fehler beim Schreiben
0x8201 | Fehler | Kommunikation | No communication to field-side (Auxiliary voltage missing) | - Es ist keine Spannung an den Powerkontakten angelegt - Ein Firmware Update ist fehlgeschlagen
0x8281 | Fehler | Kommunikation | Ownership failed: %X |
0x8282 | Fehler | Kommunikation | To many Keys founded |
0x8283 | Fehler | Kommunikation | Key Creation failed: %X |
0x8284 | Fehler | Kommunikation | Key loading failed |
0x8285 | Fehler | Kommunikation | Reading Public Key failed: %X |
0x8286 | Fehler | Kommunikation | Reading Public EK failed: %X |
0x8287 | Fehler | Kommunikation | Reading PCR Value failed: %X |
0x8288 | Fehler | Kommunikation | Reading Certificate EK failed: %X |
0x8289 | Fehler | Kommunikation | Challenge could not be hashed: %X |
0x828A | Fehler | Kommunikation | Tickstamp Process failed |
0x828B | Fehler | Kommunikation | PCR Process failed: %X |
0x828C | Fehler | Kommunikation | Quote Process failed: %X |
0x82FF | Fehler | Kommunikation | Bootmode not activated | Bootmode nicht aktiviert
0x8300 | Fehler | Encoder | Set position error: 0x%X, %d | Fehler beim Setzen der Position
0x8301 | Fehler | Encoder | Encoder increments not configured: 0x%X, %d | Enkoderinkremente nicht konfiguriert
0x8302 | Fehler | Encoder | Encoder-Error | Die Amplitude des Resolvers ist zu klein
0x8303 | Fehler | Encoder | Encoder supply error | Encoder Netzteil Fehler
0x8304 | Fehler | Encoder | Encoder communication error, channel: %X | Encoder Kommunikationsfehler
0x8305 | Fehler | Encoder | EnDat2.2 is not supported, channel: %X | EnDat2.2 wird nicht unterstützt
0x8306 | Fehler | Encoder | Delay time, tolerance limit exceeded, 0x%X, channel: %X | Laufzeitmessung, Toleranz überschritten
0x8307 | Fehler | Encoder | Delay time, maximum value exceeded, 0x%X, channel: %X | Laufzeitmessung, Maximalwert überschritten
0x8308 | Fehler | Encoder | Unsupported ordering designation, 0x%X, channel: %X (only 02 and 22 is supported) | Falsche EnDat Bestellbezeichnung
0x8309 | Fehler | Encoder | Encoder CRC error, channel: %X | Encoder CRC Fehler
0x830A | Fehler | Encoder | Temperature %X could not be read, channel: %X | Temperatu kann nicht gelesen werden
0x8400 | Fehler | Drive | Incorrect drive configuration: 0x%X, %d | Antrieb fehlerhaft konfiguriert
0x8401 | Fehler | Drive | Limiting of calibration velocity: %d, %d | Begrenzung der Kalibrier-Geschwindigkeit
0x8402 | Fehler | Drive | Emergency stop activated: 0x%X, %d | Emergency-Stop aktiviert
0x8403 | Fehler | Drive | ADC Error | Fehler bei Strommessung im ADC
0x8404 | Fehler | Drive | Overcurrent | Überstrom Phase U, V, oder W
0x8405 | Fehler | Drive | Invalid modulo position: %d | Modulo-Position ungültig
0x8406 | Fehler | Drive | DC-Link undervoltage (Error) | Die Zwischenkreisspannung der Klemme unterschreitet die parametrierte Mindestspannung. Das Aktivieren der Endstufe wird unterbunden
0x8407 | Fehler | Drive | DC-Link overvoltage (Error) | Die Zwischenkreisspannung der Klemme überschreitet die parametrierte Maximalspannung. Das Aktivieren der Endstufe wird unterbunden
0x8408 | Fehler | Drive | I2T-Model Amplifier overload (Error) | - Der Verstärker wir außerhalb der Spezifikation betrieben - Das I2T-Modell des Verstärkers ist falsch parametriert
0x8409 | Fehler | Drive | I2T-Model motor overload (Error) | - Der Motor wird außerhalb der parametrierten Nennwerte betrieben - Das I2T-Modell des Motors ist falsch parametriert
0x840A | Fehler | Drive | Overall current threshold exceeded | Summenstrom überschritten
0x8415 | Fehler | Drive | Invalid modulo factor: %d | Modulo-Faktor ungültig
0x8416 | Fehler | Drive | Motor-Overtemperature | Die Innentemperatur des Motors übersteigt die parametrierte Fehlerschwelle. Der Motor bleibt sofort stehen. Das Aktivieren der Endstufe wird unterbunden.
0x8417 | Fehler | Drive | Maximum rotating field velocity exceeded | Drehfeldgeschwindigkeit übersteigt den von Dual Use (EU 1382/2014) vorgeschriebenen Wert.
0x841C | Fehler | Drive | STO while the axis was enabled | Es wurde versucht die Achse zu aktivieren, obwohl die Spannung am STO-Eingang nicht anliegt.
0x8550 | Fehler | Inputs | Zero crossing phase %X missing | Nulldurchgang Phase %X fehlt
0x8551 | Fehler | Inputs | Phase sequence Error | Drehrichtung Falsch
0x8552 | Fehler | Inputs | Overcurrent phase %X | Überstrom Phase %X
0x8553 | Fehler | Inputs | Overcurrent neutral wire | Überstrom Neutralleiter
0x8581 | Fehler | Inputs | Wire broken Ch %D | Leitungsbruch Ch %d
0x8600 | Fehler | Allgemein IO | Wrong supply voltage range | Versorgungsspannung im falschen Bereich
0x8601 | Fehler | Allgemein IO | Supply voltage to low | Versorgungsspannung zu klein
0x8602 | Fehler | Allgemein IO | Supply voltage to high | Versorgungsspannung zu groß
0x8603 | Fehler | Allgemein IO | Over current of supply voltage | Überstrom der Versorgungsspannung
0x8610 | Fehler | Allgemein IO | Wrong output voltage range | Ausgangsspannung im falschen Bereich
0x8611 | Fehler | Allgemein IO | Output voltage to low | Ausgangsspannung zu klein
0x8612 | Fehler | Allgemein IO | Output voltage to high | Ausgangsspannung zu groß
0x8613 | Fehler | Allgemein IO | Over current of output voltage | Überstrom der Ausgangsspannung
0x8700 | Fehler |  | Channel/Interface not calibrated | Kanal/Interface nicht abgeglichen
0x8701 | Fehler |  | Operating time was manipulated | Betriebslaufzeit wurde manipuliert
0x8702 | Fehler |  | Oversampling setting is not possible | Oversampling Einstellung nicht möglich
0x8703 | Fehler |  | No slave controller found | Kein Slave Controller gefunden
0x8704 | Fehler |  | Slave controller is not in Bootstrap | Slave Controller ist nicht im Bootstrap
0x8705 | Fehler |  | Processor usage to high (>= 100%%) | Prozessorauslastung zu hoch (>= 100%%)
0x8706 | Fehler |  | Channel in saturation | Kanal in Sättigung
0x8707 | Fehler |  | Channel overload | Kanalüberlastung
0x8708 | Fehler |  | Overloadtime was manipulated | Überlastzeit wurde manipuliert
0x8709 | Fehler |  | Saturationtime was manipulated | Sättigungszeit wurde manipuliert
0x870A | Fehler |  | Channel range error | Messbereichsfehler des Kanals
0x870B | Fehler |  | no ADC clock | Kein ADC Takt vorhanden
0xFFFF | Information |  | Debug: 0x%X, 0x%X, 0x%X | Debug: 0x%X, 0x%X, 0x%X


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
EtherCAT AL Status Codes
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
EL2212
Hardware (HW) | Firmware (FW) | Revision Nr. | Releasedatum
00 | 01 | EL2212-0000-0016 | 2011/09
01 - 05 | 02 | EL2212-0000-0017 | 2011/12
 | 03 | EL2212-0000-0018 | 2012/01
 |  | EL2212-0000-0019 | 2012/08
06 - 08* | 04 | EL2212-0000-0020 | 2014/10
 | 05 | EL2212-0000-0021 | 2015/04
 | 06 |  | 2015/05
 | 07 |  | 2015/09
 | 08 | EL2212-0000-0022 | 2015/11
 | 09 | EL2212-0000-0023 | 2016/03
 | 10* |  | 2017/09
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.
Hinweis EL2212
Hinweis
Sekundärspannung nötig für Firmware-Update
Um die Firmware der EL2212 zu ändern, müssen sowohl an der Feldbusseite (Ebus) als auch auf der Lastseite (Powerkontakte) die zulässigen Betriebsspannungen anliegen. Sonst bleibt die Klemme im INIT_ERROR bzw. läßt sich nicht in den Bootstrap-Mode schalten.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.