EL125x, EL2258 - Achtkanalige Digital-Eingangs-/Ausgangsklemmen
Home


Produktübersicht - Achtkanalige Digital-Eingangs-/Ausgangsklemmen

Produktübersicht - Achtkanalige Digital-Eingangs-/Ausgangsklemmen
Produktübersicht - Achtkanalige Digital-Eingangs-/Ausgangsklemmen
EL1258
Achtkanalige Digital-Eingangsklemme 24 VDC, mit Time-Stamp
EL1259
2 x Achtkanalige Digital-Eingangs-/Ausgangsklemme 24 VDC, mit Time-Stamp
EL2258
Achtkanalige Digital-Ausgangsklemme 24 VDC, mit Time-Stamp


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.6
▪
Update Kapitel "Technische Daten"
▪
Strukturupdate
▪
Update Revisionsstand
2.5
▪
Beispielprogramm zur EL1258 (MT-Visualisierung) zum Kapitel „Inbetriebnahme“ hinzugefügt
2.4
▪
Update Kapitel "Inbetriebnahme", Beispielprogramm zur EL2258 (Multi‑Timestamp)
2.3
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Update Kapitel "Technische Daten"
▪
Hinweis zum ESD-Schutz eingefügt
▪
Kapitel "TwinCAT Quickstart" eingefügt
▪
Kapitel "UL Hinweise" eingefügt
▪
Update Revisionsstand
2.2
▪
Update Kapitel "Technische Daten"
▪
Strukturupdate
▪
Update Revisionsstand
2.1
▪
Beispielprogramm zur EL2258 (Multi-Timestamp) zum Kapitel „Inbetriebnahme“ hinzugefügt
2.0
▪
Migration
▪
Strukturupdate
▪
Aktualisierung Revisionsstand
1.4
▪
Update Kapitel "Distributed Clocks Einstellungen"
▪
Strukturupdate
▪
Aktualisierung Revisionsstand
1.3
▪
Update Kapitel "Distributed Clocks Einstellungen"
▪
Strukturupdate
▪
Aktualisierung Revisionsstand
1.2
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
▪
Strukturupdate
▪
Aktualisierung Revisionsstand
1.1
▪
Ergänzungen Kapitel "Inbetriebnahme Ausgänge"
▪
Aktualisierung Revisionsstand
1.0
▪
Ergänzungen
▪
1. Veröffentlichung
0.5
▪
Objektverzeichnis ergänzt
0.4
▪
Korrekturen technische Daten
0.3
▪
Korrekturen technische Daten
0.2
▪
Korrekturen Inbetriebnahme
0.1
▪
Vorläufige Dokumentation für EL125x, EL2258


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
Aufbau des BICs
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EL1258, EL1259, EL2258
•
Start


EL1258, EL1259, EL2258

Produktübersicht [image] EL1258, EL1259, EL2258
EL1258, EL1259, EL2258
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Technologie


Einführung

Produktübersicht [image] EL1258, EL1259, EL2258 [image] Einführung
Einführung
EL1258
EL1259
EL2258
Digitale Eingangs-/Ausgangsklemmen mit Timestamp
Die 8-kanalige digitale Eingangsklemme EL1258 erfasst schnelle binäre Steuersignale aus der Prozessebene und überträgt diese galvanisch getrennt zur Steuerung. Im Gegensatz zur EL1252 mit zwei Kanälen hat die EL1258 acht Kanäle mit einer geringeren Abtastrate. Zusätzlich bietet die EL1258 die Möglichkeit, mehrere Wechsel des Eingangssignals pro SPS-Zyklus zu erfassen und diese an die Steuerung zu übertragen (MultiTimeStamping). Die EL1258 wird durch das Distributed-Clocks-System (DC) mit anderen EtherCAT-Teilnehmern synchronisiert, so dass Ereignisse in der gesamten Anlage auf einer einheitlichen Zeitbasis gemessen werden können.
Die 8-kanalige digitale Ausgangsklemme EL2258 schaltet die binären Ausgangssignale der Steuerung galvanisch getrennt zur Prozessebene. Bis zu 10 Schaltaufträge können pro SPS-Zyklus an die Klemme übergeben werden. Diese werden mit einer Genauigkeit von bis zu 10 µs (abhängig von dem ausgewählten Prozessabbild) ausgegeben. Als zeitliche Bezugsgröße gelten die Distributed-Clocks. In Verbindungen mit Zeitstempel-Eingangsklemmen ermöglicht die EL2258 zeitäquidistante Reaktionen, die weitgehend unabhängig von der Buszykluszeit sind.
Die 16-kanalige digitale EtherCAT-Klemme EL1259 kombiniert die Funktion von der EL1258 – acht Zeitstempel-Eingänge – mit denen der EL2258 – acht Zeitstempel-Ausgänge. Die hohe Kanaldichte in Verbindung mit der Zeitstempelung der Signale erlaubt schnelle, effiziente Abläufe durch optimierte Sensor- und Aktor-Kontrolle. Auch die EL1259 wird durch das Distributed-Clocks-System mit anderen Teilnehmern synchronisiert, sodass Ereignisse in der gesamten Anlage auf einer einheitlichen Zeitbasis gemessen werden können.
Quick-Links


Technische Daten

Produktübersicht [image] EL1258, EL1259, EL2258 [image] Technische Daten
Technische Daten
Technische Daten | EL1258 | EL1259 | EL2258
Digitale Eingänge | 8 | 8 | -
Digitale Ausgänge | - | 8 | 8
Anschlusstechnik | 2-Leiter | 1-Leiter | 2-Leiter
Nennspannung | 24 VDC (-15%/+20%)
Signalspannung "0" | -3 V … +5 V (in Anlehnung an EN 61131-2, Typ 3) |  | -
Signalspannung "1" | +11 V … +30 V (in Anlehnung an EN 61131-2, Typ 3) |  | -
Eingangsstrom | typ. 3 mA (in Anlehnung an EN 61131-2, Typ 3) |  | -
Eingangsfilter | < 1 µs typ. |  | -
Distributed Clocks | Ja
Genauigkeit Distributed Clocks (DC) | << 1 µs
Interne Abtastung/Auftragsausführung | <10 ... <40 µs, abh.von der PDO-Konfiguration ("Microzyklus", siehe Erläuterungen)
Minimale EtherCAT Zykluszeit | 90..540 µs, abh.von der PDO-Konfiguration ("Macrozyklus", siehe Erläuterungen)
Lastart Ausgänge | - | ohmsch, induktiv, Lampenlast
Ausgangsstrom | - | max. 0,5 A (kurzschlussfest) je Kanal
Ausgangsstufe |  | Push *)
Verpolungsschutz | - | ja
Abschaltenergie (ind.) max. | - | < 150 mJ/Kanal
Schaltzeiten Ausgang | - | TON: < 1 µs typ., TOFF: < 1 µs typ. *)
Stromaufnahme Powerkontakte | typ. 6 mA | typ. 30 mA + Last
Spannungsversorgung für Elektronik | über den E-Bus
Stromaufnahme aus dem E-Bus | typ. 130 mA
Potenzialtrennung | 500 V (E-Bus/Feldspannung)
Konfiguration | keine Adress- oder Konfigurationseinstellung erforderlich
Gewicht | ca. 55 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 15 mm x 100 mm x 70 mm (Breite angereiht: 12 mm)
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastung
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus
*) Um die schnellstmögliche Toff Zeit (negative Flanke, Abschaltung) zu erreichen, ist der Ausgang mit einem Lastwiderstand zu betreiben, idealerweise mit der Nennlast von 0,5A entsprechend 48 Ohm. Dabei ist auf entsprechende Wärmebelastbarkeit des Widerstands zu achten.


Technologie

Produktübersicht [image] EL1258, EL1259, EL2258 [image] Technologie
Technologie
Inhaltsverzeichnis
• Verfahren zur Abtastung von digitalen Eingängen
• Verfahren zur Abtastung von digitalen Ausgängen
• Multi-Timestamp
Die EtherCAT-Klemmen EL1258, EL1259 und EL2258 bilden eine Klemmenfamilie, deren Vertreter einen gleichartigen Funktionsumfang aufweisen. Es handelt sich hierbei um digitale Ein- und Ausgangsklemmen, die 24 V-Signale einlesen oder ausgeben. Die EL1258 kann acht Kanäle einlesen, die EL2258 acht Kanäle ausgeben. Die EL1259 ist die Mischvariante mit zugleich 8 Ein- und 8 Ausgangskanälen auf 12 mm Baubreite. Auszeichnungsmerkmal dieser Klemmen ist die Multi-Timestamp-Fähigkeit, die Erweiterung der konventionellen Timestamp-Funktion.
Oft ist es von großem Interesse, wann an einer laufenden Applikation Eingänge eingelesen oder Ausgänge geschaltet werden. Hier sind 3 generelle Verfahren zur Betrachtungsweise von Ein- und Ausgängen:
Verfahren zur Abtastung von digitalen Eingängen
▪
Standardabtastung
Die Standardabtastung wird bei „normalen“ digitale Ein-/Ausgangsklemmen angewendet. Für den Eingang bedeutet das, von außen wird ein 24 V-Signal (TRUE) oder 0 V-Signal (FALSE) von einem Sensor (z.B. Lichtschranke) angelegt. Diese Kanalinformation wird mit dem nächsten EtherCAT-Zyklus abgefragt und an die Steuerung übertragen.
Das bedeutet weiterhin, dass innerhalb der letzten Zykluszeit dieses Signal an den Eingang angelegt worden ist und zum Zeitpunkt der Abfrage immer noch anlag. Es kann aber keine Aussage getroffen werden, zu welchem exakten Zeitpunkt diese Flanke am Eingang ankam, oder ob vorher bereits kurze Pulse vorhanden waren.
Abfrage Eingangs-Kanalinformation, Standard
▪
In Abb. Abfrage Eingangs-Kanalinformation, Standard werden die Pulse A und B nicht erfasst, erst Puls C dauert lange genug an und ist während der Abtastung (blau) präsent, so dass die "1" vom Buszyklus erfasst wird. Diese Betriebsart wird auch als FrameTriggered beschrieben.
Das Zeitraster für die Abtastung ist also die verwendete Task/EtherCAT-Zykluszeit von z.B. 10 ms oder 1 ms. Sollen Vorgänge in der Maschine in feineren Abständen abgetastet werden, muss üblicherweise die Zykluszeit auf das gewünschte oder minimal mögliche Maß verringert werden, z.B. 100 µs. Das bedeutet aber Einschränkungen bzgl. der dann noch maximal zur Verfügung stehenden Rechenzeit und ggf. auch des EtherCAT-Datenvolumens innerhalb dieser Zykluszeit.
Abhilfe schaffen zwei verfügbare Technologien: Oversampling und Zeitstempel.
Die EtherCAT-Klemmen EL1258, EL1259 und EL2258 können prinzipiell zur Standardabtastung verwendet werden.
▪
Oversampling
Die Eingangsklemmen lesen innerhalb der vorgegebenen (konfigurierbaren) Zykluszeit den Status des Eingangs n-fach ein und speichert die Zustände in einem Array, das der Steuerung im Buszyklus übergeben wird. Das entsprechend feinere Zeitraster, der Mikrozyklus, erlaubt somit eine langsame Buszykluszeit bei trotzdem extrem feiner Abtastung.
Die Eingangsklemme EL1262 z. B.kann bis zu 1000fach Oversampling bei 1 µs Mikrozyklus.
Abfrage Eingangs-Kanalinformation, Oversampling
▪
In Abb. Abfrage Eingangs-Kanalinformation, Oversampling werden im Vergleich zu der Standardabtastung auch Puls A und B erfasst. Über die bekannte Mikrozykluszeit kann aus dem resultierenden Datenstrom jeder einzelne Puls ermittelt werden. Allerdings wird mit jedem EtherCAT-Zyklus ein konstant hohes Datenvolumen übertragen, auch wenn am Eingang gar keine Flankenwechsel anlagen.
▪
Zeitstempel
Die Eingangsklemme arbeitet bei diesem Verfahren nur ereignisbezogen. Die Flankenwechsel werden am Eingangskanal registriert, dabei werden intern für jedes Ereignis/Event zwei Informationen gespeichert: der Eingangszustand 0/1 nach dem Flankenwechsel und die exakte Uhrzeit des Flankenwechsels, der Zeitstempel/Timestamp. Die Uhrzeit wird dabei aus dem synchronisierten Distributed-Clocks-System von EtherCAT gewonnen, das ohne besondere Konfiguration alle dazu fähigen EtherCAT-Geräte im Netzwerk auf << 1 µs Zeitgenauigkeit synchronisiert (siehe dazu die EtherCAT-Grundlagen-Dokumentation).
Abfrage Eingangs-Kanalinformation, mit Zeitstempel
▪
In Abb. Abfrage Eingangs-Kanalinformation, mit Zeitstempel wird die steigende und die fallende Flanke von Puls A nun als Ereignis jeweils mit Zeitstempel erfasst und durch den EtherCAT-Zyklus zur Steuerung übertragen. Die Zeitauflösung ist hier 1 ns, es liegt hier also eine für mechanische Verhältnisse „unendlich“ feine Zeitauflösung vor. Die EL1252 kann „nur“ je eine fallende und eine steigende Flanke je Zyklus speichern – treten mehrere Flankenwechsel auf wie z.B. die steigende Flanke von Puls C, wird das erste oder letzte Event gespeichert, je nach Konfiguration (siehe Dokumentation EL1252).
Zusammenfassend lässt sich sagen, die Verfahren Oversampling und Zeitstempel liefern ein deutlich feineres Abbild des zeitlichen Maschinenablaufs als eine Standardabtastung des digitalen Eingangs.
Verfahren zur Abtastung von digitalen Ausgängen
Die zuvor genannten Prinzipien lassen sich entsprechend auf digitale Ausgänge übertragen.
▪
Standardabtastung
Ein framegetriggerter Standard-Ausgang kann nur jeweils mit dem Zeitpunkt des EtherCAT-Zyklus schalten, wenn er einen neuen Ausgangs-Soll-Zustand erhält:
Ausgabe Ausgangs-Kanalinformation, Standard
▪
In Abb. Ausgabe Ausgangs-Kanalinformation, Standard ist die Anzahl der Schaltereignisse auf die Zykluszeit begrenzt und im eigentlichen Schaltzeitpunkt überhaupt nicht veränderbar. Für schnelllaufende oder hochgenau arbeitende Maschinen hat dies erheblichen Einfluss auf die maximal mögliche Produktionsgeschwindigkeit und Fertigungstoleranzen. Auch hier helfen die beiden Technologien Oversampling und Zeitstempel weiter.
▪
Oversampling
Die Steuerung berechnet das Array an digitalen 0/1-Ausgabedaten voraus und sendet es zum Ausgangskanal. Dieser taktet im fixen Mikrozyklus die Ausgangssollzustände nacheinander heraus.
Ausgabe Ausgangs-Kanalinformation, Oversampling
▪
Damit wird eine deutlich feinere Zeitauflösung der Aktorsteuerung auch weit unterhalb der eigentlichen Zykluszeit erreicht.
Die digitale Ausgangsklemme EL2262 erreicht bei 1000fach Oversampling eine Zeitauflösung von 1 µs.
▪
Zeitstempel
Beim Zeitstempelprinzip berechnet die Steuerung einen exakten Zeitpunkt , zu dem der Ausgang in einen neuen Zustand 0/1 gehen soll. Nach dem Übermitteln dieses Schaltauftrags wartet die Klemme, bis dieser Zeitpunkt erreicht ist und schaltet dann selbsttätig, unabhängig vom Buszyklus. Auch hier ist die Distributed-Clocks-Funktion maßgebend, sie synchronisiert die in der Ausgangsklemme laufende lokale Uhr.
Ausgabe Ausgangs-Kanalinformation, mit Zeitstempel
▪
Die Steuerung übergibt bei (A) einen Schaltauftrag aus Ausgangszustand und Schaltzeitpunkt an den Ausgangskanal, der bei (B) zyklus-unabhängig ausgeführt wird. Dann kann die Steuerung einen neuen Schaltauftrag senden (C). Auch hier gilt die „unendlich“ feine Zeitauflösung von 1 ns.
Generell sind bei der digitalen Ausgangsklemme EL2252 mit Oversampling zwei Zyklen zur Aktivierung eines Schaltauftrages notwendig.
Multi-Timestamp
Die Multi-Timestamp-Fähigkeit eröffnet nun für digitale Ein- und Ausgänge neue Anwendungsmöglichkeiten:
Eingänge EL1258, EL1259
▪
8 Multi-Timestamp-Kanäle auf 12 mm Baubreite
▪
Alle Kanäle arbeiten vollständig unabhängig voneinander
▪
Jeder Kanal kann nicht nur eine, sondern bis zu 32 Signalflanken („Events“) je Zyklus erfassen
▪
Jeder Kanal verfügt über einen eigenen Buffer. Events werden zwischengespeichert, falls in einem Zyklus mehr Signalflankenwechsel am Eingang ankommen, als über die Prozessdaten abgeholt werden. Der Buffer kann fortlaufend über die zyklischen Prozessdaten zur Steuerung gesendet werden. Auch ein Handshake-Modus ist möglich - damit gehen bei Kommunikationsstörungen keine Signale zur Steuerung verloren.
▪
Die Prozessdatengröße ist für jeden Kanal einzeln konfigurierbar, d.h., wie viel zeitgestempelte Events je Zyklus durch die PLC vom Kanal abgeholt werden sollen
▪
Diese Funktionen erfordern ein Prozessabbild, das sich von der bisherigen EL1252 unterscheidet. Aus Kompatibilitätsgründen zur bestehenden Anwender-Software kann aber die Klemme auf ein kompatibles Prozessabbild geschaltet werden (ohne die neuen Funktionen).
▪
Die Abtastung des Eingangszustands 0/1 erfolgt in einem Raster (Mikrozyklus) von einigen µs je nach gewählter Einstellung und liegt damit deutlich unter der EtherCAT-Buszykluszeit
▪
Eine so detektierte Signalflanke erhält als Zeitstempel die Startzeit des Mikrozyklus' , in dem sie erfasst wurde
▪
Es ist je Kanal ein einstellbarer digitaler Filter aktivierbar, der zu kurze Signale (Spikes) ausblendet
▪
Je Zyklus können deutlich mehr Signalwechsel mit Zeitstempel erfasst werden, durch den Buffer geht keine Eventinformation verloren
Abfrage Eingangs-Kanalinformation, mit Multi-Zeitstempel
Ausgänge EL1259, EL2258
▪
8 Multi-Timestamp-Kanäle auf 12 mm Baubreite
▪
Alle Kanäle arbeiten vollständig unabhängig voneinander
▪
Jeder Kanal verfügt über einen Buffer und kann somit nicht nur einen Schaltauftrag, sondern max. 32 Events zwischenspeichern. Somit können auch mehrere Schaltevents innerhalb eines Zyklus zeitgenau vorgegeben werden.
▪
Damit Schaltaufträge möglichst schnell vom Kanal übernommen werden, arbeitet die Muti-Timestamp-Funktion mit AutoActivation: neue Schaltaufträge werden in jedem Zyklus ohne besondere Aktivierung übernommen, auch hier ist ein optionales Handshake-Verfahren möglich.
▪
Es ist für jeden Kanal einzeln die Prozessdatengröße konfigurierbar, also wie viele Zeitstempel-Schaltaufträge je Zyklus von der Steuerung zum Kanal geschickt werden können
▪
Diese Funktionen erfordern ein Prozessabbild, das sich von der bisherigen EL2252 unterscheidet. Aus Kompatibilitätsgründen zu bestehender Anwender-Software kann aber die Klemme auf ein kompatibles Prozessabbild geschaltet werden (ohne die neuen Funktionen).
▪
Die Abfrage, ob ein auszuführender Schaltauftrag im Buffer vorliegt, erfolgt in einem Raster (Mikrozyklus) von einigen µs je nach gewählter Einstellung und liegt damit deutlich unter der EtherCAT-Buszykluszeit. Somit sind auch mehrere Timestamp-Schaltaufträge je Buszyklus möglich.
▪
Um den am Ausgangskanal angeschlossenen Aktor zu testen, kann der Ausgang auch über das CoE manuell d.h. ohne Zeitstempel geschaltet werden
▪
Damit können nun im Rahmen des Mikrozyklus annähernd beliebig viele Schaltaufträge je Kanal ausgegeben werden, und zwar sowohl „sofort“ für den folgenden Zyklus (A) als auch durch den Buffer für spätere Zyklen (B).
Ausgabe Ausgangs-Kanalinformation, mit Multi-Zeitstempel


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EL125x, EL2258 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EL125x, EL2258in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen der Kommunikation [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
SmallWarningYellow VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
SmallWarningYellow VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z. B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface

Grundlagen der Kommunikation [image] CoE-Interface
CoE-Interface
Allgemeine Beschreibung
Das CoE-Interface (CANopen-over-EtherCAT) ist die Parameterverwaltung für EtherCAT-Geräte. EtherCAT-Slaves oder auch der EtherCAT-Master verwalten darin feste (ReadOnly) oder veränderliche Parameter, die sie zum Betrieb, Diagnose oder Inbetriebnahme benötigen.
CoE-Parameter sind in einer Tabellen-Hierarchie angeordnet und prinzipiell dem Anwender über den Feldbus lesbar zugänglich. Der EtherCAT-Master (TwinCAT System Manager) kann über EtherCAT auf die lokalen CoE-Verzeichnisse der Slaves zugreifen und je nach Eigenschaften lesend oder schreibend einwirken.
Es sind verschiedene Typen für CoE-Parameter möglich wie String (Text), Integer-Zahlen, Bool'sche Werte oder größere Byte-Felder. Damit lassen sich ganz verschiedene Eigenschaften beschreiben. Beispiele für solche Parameter sind Herstellerkennung, Seriennummer, Prozessdateneinstellungen, Gerätename, Abgleichwerte für analoge Messung oder Passwörter.
Die Ordnung erfolgt in 2 Ebenen über hexadezimale Nummerierung: zuerst wird der (Haupt)Index genannt, dann der Subindex. Die Wertebereiche sind
▪
Index: 0x0000…0xFFFF (0...65535dez)
▪
SubIndex: 0x00…0xFF (0...255 dez)
Üblicherweise wird ein so lokalisierter Parameter geschrieben als 0x8010:07 mit voranstehendem "0x" als Kennzeichen des hexidezimalen Zahlenraumes und Doppelpunkt zwischen Index und Subindex.
Die für den EtherCAT-Feldbusanwender wichtigen Bereiche sind
▪
0x1000: hier sind feste Identitäts-Informationen zum Gerät hinterlegt wie Name, Hersteller, Seriennummer etc. Außerdem liegen hier Angaben über die aktuellen und verfügbaren Prozessdatenkonstellationen.
▪
0x8000: hier sind die für den Betrieb erforderlichen funktionsrelevanten Parameter für alle Kanäle zugänglich wie Filtereinstellung oder Ausgabefrequenz.
Weitere wichtige Bereiche sind:
▪
0x4000: hier befinden sich bei manchen EtherCAT-Geräten die Kanalparameter. Historisch war dies der erste Parameterbereich, bevor der 0x8000 Bereich eingeführt wurde. EtherCAT Geräte, die früher mit Parametern in 0x4000 ausgerüstet wurden und auf 0x8000 umgestellt wurden, unterstützen aus Kompatibilitätsgründen beide Bereiche und spiegeln intern.
▪
0x6000: hier liegen die Eingangs-PDO ("Eingang" aus Sicht des EtherCAT-Masters)
▪
0x7000: hier liegen die Ausgangs-PDO ("Ausgang" aus Sicht des EtherCAT-Masters)
Verfügbarkeit
Nicht jedes EtherCAT Gerät muss über ein CoE-Verzeichnis verfügen. Einfache I/O-Module ohne eigenen Prozessor verfügen i.d.R. über keine veränderlichen Parameter und haben deshalb auch kein CoE-Verzeichnis..
Wenn ein Gerät über ein CoE-Verzeichnis verfügt, stellt sich dies im TwinCAT System Manager als ein eigener Karteireiter mit der Auflistung der Elemente dar:
Karteireiter "CoE-Online"
In der oberen Abbildung sind die im Gerät "EL2502" verfügbaren CoE-Objekte von 0x1000 bis 0x1600 zusehen, die Subindizes von 0x1018 sind aufgeklappt.
Datenerhaltung und Funktion "NoCoeStorage"
Einige, insbesondere die vorgesehenen Einstellungsparameter des Slaves sind veränderlich und beschreibbar. Dies kann schreibend/lesend geschehen
▪
über den System Manager (Abb. „Karteireiter ‚CoE-Online‘“) durch Anklicken
Dies bietet sich bei der Inbetriebnahme der Anlage/Slaves an. Klicken Sie auf die entsprechende Zeile des zu parametrierenden Indizes und geben sie einen entsprechenden Wert im "SetValue"-Dialog ein.
▪
aus der Steuerung/PLC über ADS z. B. durch die Bausteine aus der TcEtherCAT.lib Bibliothek
Dies wird für Änderungen während der Anlangenlaufzeit empfohlen oder wenn kein System Manager bzw. Bedienpersonal zur Verfügung steht.
Datenerhaltung
Werden online auf dem Slave CoE-Parameter geändert, wird dies in Beckhoff-Geräten üblicherweise ausfallsicher im Gerät (EEPROM) gespeichert. D. h. nach einem Neustart (Repower) sind die veränderten CoE-Parameter immer noch erhalten.
Andere Hersteller können dies anders handhaben.

Ein EEPROM unterliegt in Bezug auf Schreibvorgänge einer begrenzten Lebensdauer. Ab typischerweise 100.000 Schreibvorgängen kann eventuell nicht mehr sichergestellt werden, dass neue (veränderte) Daten sicher gespeichert werden oder noch auslesbar sind. Dies ist für die normale Inbetriebnahme ohne Belang. Werden allerdings zur Maschinenlaufzeit fortlaufend CoE-Parameter über ADS verändert, kann die Lebensdauergrenze des EEPROM durchaus erreicht werden.

Es ist von der FW-Version abhängig, ob die Funktion NoCoeStorage unterstützt wird, die das Abspeichern veränderter CoE-Werte unterdrückt.
Ob das auf das jeweilige Gerät zutrifft, ist den technischen Daten dieser Dokumentation zu entnehmen.
•
wird unterstützt: die Funktion ist per einmaligem Eintrag des Codeworts 0x12345678 in CoE 0xF008 zu aktivieren und solange aktiv, wie das Codewort nicht verändert wird. Nach dem Einschalten des Gerätes ist sie nicht aktiv.
Veränderte CoE-Werte werden dann nicht im EEPROM abgespeichert, sie können somit beliebig oft verändert werden.
•
wird nicht unterstützt: eine fortlaufende Änderung von CoE-Werten ist angesichts der o.a. Lebensdauergrenze nicht zulässig.
Startup List
Veränderungen im lokalen CoE-Verzeichnis der Klemme gehen im Austauschfall mit der alten Klemme verloren. Wird im Austauschfall eine neue Klemme mit Werkseinstellungen ab Lager Beckhoff eingesetzt, bringt diese die Standardeinstellungen mit. Es ist deshalb empfehlenswert, alle Veränderungen im CoE-Verzeichnis eines EtherCAT Slave in der Startup List des Slaves zu verankern, die bei jedem Start des EtherCAT Feldbus abgearbeitet wird. So wird auch ein im Austauschfall ein neuer EtherCAT Slave automatisch mit den Vorgaben des Anwenders parametriert.
Wenn EtherCAT Slaves verwendet werden, die lokal CoE-Wert nicht dauerhaft speichern können, ist zwingend die StartUp-Liste zu verwenden.
Empfohlenes Vorgehen bei manueller Veränderung von CoE-Parametern
▪
gewünschte Änderung im Systemmanager vornehmen
Werte werden lokal im EtherCAT Slave gespeichert
▪
wenn der Wert dauerhaft Anwendung finden soll, einen entsprechenden Eintrag in der StartUp-Liste vornehmen.
Die Reihenfolge der StartUp-Einträge ist dabei i.d.R. nicht relevant.
StartUp-Liste im TwinCAT System Manager
In der StartUp-Liste können bereits Werte enthalten sein, die vom Systemmanager nach den Angaben der ESI dort angelegt werden. Zusätzliche anwendungsspezifische Einträge können angelegt werden.
Online/Offline Verzeichnis
Während der Arbeit mit dem TwinCAT System Manager ist zu unterscheiden ob das EtherCAT-Gerät gerade "verfügbar", also angeschaltet und über EtherCAT verbunden und damit online ist oder ob ohne angeschlossene Slaves eine Konfiguration offline erstellt wird.
In beiden Fällen ist ein CoE-Verzeichnis nach Abb. „Karteireiter ‚CoE-Online‘“ zu sehen, die Konnektivität wird allerdings als offline/online angezeigt.
▪
wenn der Slave offline ist:
–
wird das Offline-Verzeichnis aus der ESI-Datei angezeigt. Änderungen sind hier nicht sinnvoll bzw. möglich.
–
wird in der Identität der konfigurierte Stand angezeigt
–
wird kein Firmware- oder Hardware-Stand angezeigt, da dies Eigenschaften des realen Gerätes sind.
–
ist ein rotes Offline zu sehen
Offline-Verzeichnis
▪
wenn der Slave online ist
–
wird das reale aktuelle Verzeichnis des Slaves ausgelesen. Dies kann je nach Größe und Zykluszeit einige Sekunden dauern.
–
wird die tatsächliche Identität angezeigt
–
wird der Firmware- und Hardware-Stand des Gerätes laut elektronischer Auskunft angezeigt
–
ist ein grünes Online zu sehen
Online-Verzeichnis
Kanalweise Ordnung
Das CoE-Verzeichnis ist in EtherCAT Geräten angesiedelt, die meist mehrere funktional gleichwertige Kanäle umfassen. z.B. hat eine 4 kanalige Analogeingangsklemme 0..10 V auch 4 logische Kanäle und damit 4 gleiche Sätze an Parameterdaten für die Kanäle. Um in den Dokumentationen nicht jeden Kanal auflisten zu müssen, wird gerne der Platzhalter "n" für die einzelnen Kanalnummern verwendet.
Im CoE-System sind für die Menge aller Parameter eines Kanals eigentlich immer 16 Indizes mit jeweils 255 Subindizes ausreichend. Deshalb ist die kanalweise Ordnung in 16dez/10hex-Schritten eingerichtet. Am Beispiel des Parameterbereichs 0x8000 sieht man dies deutlich:
▪
Kanal 0: Parameterbereich 0x8000:00 ... 0x800F:255
▪
Kanal 1: Parameterbereich 0x8010:00 ... 0x801F:255
▪
Kanal 2: Parameterbereich 0x8020:00 ... 0x802F:255
▪
...
Allgemein wird dies geschrieben als 0x80n0.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Anschluss
•
Einbaulagen
•
Positionierung von passiven Klemmen
•
UL-Hinweise
•
EL1258, EL1259, EL2258 - LEDs und Anschlussbelegung


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Anschluss

Montage und Verdrahtung [image] Anschluss
Anschluss
Weiterführende Informationen
•
Anschlusstechnik
•
Verdrahtung
•
Schirmung


Anschlusstechnik

Montage und Verdrahtung [image] Anschluss [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Anschluss [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


Schirmung

Montage und Verdrahtung [image] Anschluss [image] Schirmung
Schirmung
Schirmung
Encoder, analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


EL1258, EL1259, EL2258 - LEDs und Anschlussbelegung

Montage und Verdrahtung [image] EL1258, EL1259, EL2258 - LEDs und Anschlussbelegung
EL1258, EL1259, EL2258 - LEDs und Anschlussbelegung
Inhaltsverzeichnis
• LEDs und Anschlussbelegung EL1258
• LEDs und Anschlussbelegung EL1259
• LEDs und Anschlussbelegung EL2258
EL1258
EL1258
LED | Farbe | Bedeutung
INPUT 1 - 8 | grün | aus | Es liegt kein Eingangssignal am entsprechenden Eingang
 |  | an | Eingangssignal am entsprechenden Eingang
Anschlussbelegung EL1258
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Input 1 | 1 | Eingang 1
Input 2 | 2 | Eingang 2
Input 3 | 3 | Eingang 3
Input 4 | 4 | Eingang 4
Input 5 | 5 | Eingang 5
Input 6 | 6 | Eingang 6
Input 7 | 7 | Eingang 7
Input 8 | 8 | Eingang 8
+24 V | 9-16 | + 24 V (interne Verbindung der Klemmstellen 9 -16 und positiven Powerkontakt)
EL1259
EL1259
LED | Farbe | Bedeutung
INPUT 1 - 8 (Signal LEDs 1 - 8) | grün | aus | Es liegt kein Eingangssignal am entsprechenden Eingang
 |  | an | Eingangssignal am entsprechenden Eingang
OUTPUT 1 - 8 (Signal LEDs 9 - 16) | grün | aus | Es liegt kein Ausgangssignal am entsprechenden Ausgang
 |  | an | Eingangssignal am entsprechenden Eingang
Anschlussbelegung EL1259
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Input 1 | 1 | Eingang 1
Input 2 | 2 | Eingang 2
Input 3 | 3 | Eingang 3
Input 4 | 4 | Eingang 4
Input 5 | 5 | Eingang 5
Input 6 | 6 | Eingang 6
Input 7 | 7 | Eingang 7
Input 8 | 8 | Eingang 8
Output 1 | 9 | Ausgang 1
Output 2 | 10 | Ausgang 2
Output 3 | 11 | Ausgang 3
Output 4 | 12 | Ausgang 4
Output 5 | 13 | Ausgang 5
Output 6 | 14 | Ausgang 6
Output 7 | 15 | Ausgang 7
Output 8 | 16 | Ausgang 8
EL2258
EL2258
LED | Farbe | Bedeutung
OUTPUT 1 - 8 | grün | aus | Es liegt kein Ausgangssignal am entsprechenden Eingang
 |  | an | Ausgangssignal am entsprechenden Eingang
Anschlussbelegung EL2258
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Output 1 | 1 | Ausgang 1
Output 2 | 2 | Ausgang 2
Output 3 | 3 | Ausgang 3
Output 4 | 4 | Ausgang 4
Output 5 | 5 | Ausgang 5
Output 6 | 6 | Ausgang 6
Output 7 | 7 | Ausgang 7
Output 8 | 8 | Ausgang 8
0 V | 9-16 | + 0 V (interne Verbindung der Klemmstellen 9 -16 und negativen Powerkontakt)


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
TwinCAT Quickstart
•
TwinCAT Entwicklungsumgebung
•
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
•
Grundlagen zur Funktion
•
Inbetriebnahme Eingänge
•
Inbetriebnahme Ausgänge
•
Distributed Clocks Einstellungen
•
CoE Objektbeschreibung und Parametrierung
•
Beispielprogramme


TwinCAT Quickstart

Inbetriebnahme [image] TwinCAT Quickstart
TwinCAT Quickstart
TwinCAT stellt eine Entwicklungsumgebung für Echtzeitsteuerung mit Multi-SPS-System, NC Achsregelung, Programmierung und Bedienung dar. Das gesamte System wird hierbei durch diese Umgebung abgebildet und ermöglicht Zugriff auf eine Programmierumgebung (inkl. Kompilierung) für die Steuerung. Einzelne digitale oder analoge Eingänge bzw. Ausgänge können auch direkt ausgelesen bzw. beschrieben werden, um diese z.B. hinsichtlich ihrer Funktionsweise zu überprüfen.
Weitere Informationen hierzu erhalten Sie unter http://infosys.beckhoff.de:
▪
EtherCAT Systemhandbuch:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Einrichtung im TwinCAT Systemmanager
▪
TwinCAT 2 → TwinCAT System Manager → E/A- Konfiguration
▪
Insbesondere zur TwinCAT – Treiberinstallation:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation
Geräte, d.h. "devices" beinhalten jeweils die Klemmen der tatsächlich aufgebauten Konfiguration. Dabei gibt es grundlegend die Möglichkeit sämtliche Informationen des Aufbaus über die "Scan" - Funktion einzubringen („online“) oder über Editorfunktionen direkt einzufügen („offline“):
▪
"offline": der vorgesehene Aufbau wird durch Hinzufügen und entsprechendes Platzieren einzelner Komponenten erstellt. Diese können aus einem Verzeichnis ausgewählt und Konfiguriert werden.
–
Die Vorgehensweise für den „offline“ – Betrieb ist unter http://infosys.beckhoff.de einsehbar:
TwinCAT 2 → TwinCAT System Manager → EA - Konfiguration → Anfügen eines E/A-Gerätes
▪
"online": die bereits physikalisch aufgebaute Konfiguration wird eingelesen
–
Sehen Sie hierzu auch unter http://infosys.beckhoff.de:
Feldbuskomponenten → Feldbuskarten und Switche → FC900x – PCI-Karten für Ethernet → Installation → Geräte suchen
Vom Anwender –PC bis zu den einzelnen Steuerungselementen ist folgender Zusammenhang vorgesehen:
Bezug von der Anwender Seite (Inbetriebnahme) zur Installation
Das anwenderseitige Einfügen bestimmter Komponenten (E/A – Gerät, Klemme, Box,..) erfolgt bei TwinCAT 2 und TwinCAT 3 auf die gleiche Weise. In den nachfolgenden Beschreibungen wird ausschließlich der „online“ Vorgang angewandt.
Beispielkonfiguration (realer Aufbau)
Ausgehend von der folgenden Beispielkonfiguration wird in den anschließenden Unterkapiteln das Vorgehen für TwinCAT 2 und TwinCAT 3 behandelt:
▪
Steuerungssystem (PLC) CX2040 inkl. Netzteil CX2100-0004
▪
Rechtsseitig angebunden am CX2040 (E-Bus):
EL1004 (4-Kanal-Digital-Eingangsklemme 24 V DC)
▪
Über den X001 Anschluss (RJ-45) angeschlossen: EK1100 EtherCAT-Koppler
▪
Rechtsseitig angebunden am EK1100 EtherCAT-Koppler (E-Bus):
EL2008 (8-Kanal-Digital-Ausgangsklemme 24 V DC; 0,5 A)
▪
(Optional über X000: ein Link zu einen externen PC für die Benutzeroberfläche)
Aufbau der Steuerung mit Embedded-PC, Eingabe (EL1004) und Ausgabe (EL2008)
Anzumerken ist, dass sämtliche Kombinationen einer Konfiguration möglich sind; beispielsweise könnte die Klemme EL1004 ebenso auch nach dem Koppler angesteckt werden oder die Klemme EL2008 könnte zusätzlich rechts an dem CX2040 angesteckt sein – dann wäre der Koppler EK1100 überflüssig.
Weiterführende Informationen
•
TwinCAT 2
•
TwinCAT 3


TwinCAT 2

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 2
TwinCAT 2
Startup
TwinCAT 2 verwendet grundlegend zwei Benutzeroberflächen: den „TwinCAT System Manager“ zur Kommunikation mit den elektromechanischen Komponenten und „TwinCAT PLC Control“ für die Erstellung und Kompilierung einer Steuerung. Begonnen wird zunächst mit der Anwendung des „TwinCAT System Manager“.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 2 (Systemmanager) folgende Benutzeroberfläche nach dem Start:
Initiale Benutzeroberfläche TwinCAT 2
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Im Menü unter "Aktionen" → "Auswahl des Zielsystems...", über das Symbol " [image] " oder durch Taste "F8" wird folgendes Fenster hierzu geöffnet:
Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über den Systemmanager ansprechbar.
Geräte einfügen
In dem linksseitigen Konfigurationsbaum der TwinCAT 2 – Benutzeroberfläche des System Managers wird „E/A Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Geräte Suchen…“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü
„Aktionen“ → „Startet/ Restarten von TwinCAT in Konfig-Modus“(Shift + F4) zu versetzen.
Auswahl "Gerät Suchen..."
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration im TwinCAT 2 Systemmanager
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren und integrieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Nach dem Start von TwinCAT PLC Control wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
TwinCAT PLC Control nach dem Start
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt und unter dem Namen „PLC_example.pro“ gespeichert worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Die Warnung 1990 (fehlende „VAR_CONFIG“) nach einem Kompiliervorgang zeigt auf, dass die als extern definierten Variablen (mit der Kennzeichnung „AT%I*“ bzw. „AT%Q*“) nicht zugeordnet sind. Das TwinCAT PLC Control erzeugt nach erfolgreichen Kompiliervorgang eine „*.tpy“ Datei in dem Verzeichnis in dem das Projekt gespeichert wurde. Diese Datei (*.tpy“) enthält u.a. Variablenzuordnungen und ist dem Systemmanager nicht bekannt, was zu dieser Warnung führt. Nach dessen Bekanntgabe kommt es nicht mehr zu dieser Warnung.
Im System Manager ist das Projekt des TwinCAT PLC Control zunächst einzubinden. Dies geschieht über das Kontext Menü der „SPS- Konfiguration“ (rechts-Klick) und der Auswahl „SPS Projekt Anfügen…“:
Hinzufügen des Projektes des TwinCAT PLC Control
Über ein dadurch geöffnetes Browserfenster wird die PLC- Konfiguration „PLC_example.tpy“ ausgewählt. Dann ist in dem Konfigurationsbaum des System Manager das Projekt inklusive der beiden „AT“ – gekennzeichneten Variablen eingebunden:
Eingebundenes PLC Projekt in der SPS- Konfiguration des System Managers
Die beiden Variablen „bEL1004_Ch4“ sowie „nEL2008_value“ können nun bestimmten Prozessobjekten der E/A - Konfiguration zugeordnet werden.
Variablen Zuordnen
Über das Kontextmenü einer Variable des eingebundenen Projekts „PLC_example“ unter „Standard“ wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Anschließend wird mittels Menüauswahl „Aktionen“ → „Zuordnung erzeugen…“ oder über [image] der Vorgang des Zuordnens von Variablen zu PDO abgeschlossen.
Dies lässt sich entsprechend in der Konfiguration einsehen:
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration aktiviert werden. Zuvor kann mittels [image] (oder über „Aktionen“ → „Konfiguration überprüfen…“) die Konfiguration überprüft werden. Falls kein Fehler vorliegt, kann mit [image] (oder über „Aktionen“ → „Aktiviert Konfiguration…“) die Konfiguration aktiviert werden, um dadurch Einstellungen im System Manger auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt.
Einige Sekunden später wird der Realtime Status [image] unten rechts im System Manager angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Ausgehend von einem remote System muss nun als erstes auch die PLC Steuerung über „Online“ → „Choose Run-Time System…“ mit dem embedded PC über Ethernet verbunden werden:
Auswahl des Zielsystems (remote)
In diesem Beispiel wird das „Laufzeitsystem 1 (Port 801)“ ausgewählt und bestätigt. Mittels Menüauswahl „Online“ → „Login“, Taste F11 oder per Klick auf [image] wird auch die PLC mit dem Echtzeitsystem verbunden und nachfolgend das Steuerprogramm geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programstart:
PLC Control Logged-in, bereit zum Programmstart
Über „Online“ → „Run“, Taste F5 oder [image] kann nun die PLC gestartet werden.


TwinCAT 3

Inbetriebnahme [image] TwinCAT Quickstart [image] TwinCAT 3
TwinCAT 3
Startup
TwinCAT 3 stellt die Bereiche der Entwicklungsumgebung durch das Microsoft Visual-Studio gemeinsam zur Verfügung: in den allgemeinen Fensterbereich erscheint nach dem Start linksseitig der Projektmappen-Explorer (vgl. „TwinCAT System Manager“ von TwinCAT 2) zur Kommunikation mit den elektromechanischen Komponenten.
Nach erfolgreicher Installation des TwinCAT-Systems auf den Anwender PC der zur Entwicklung verwendet werden soll, zeigt der TwinCAT 3 (Shell) folgende Benutzeroberfläche nach dem Start:
Initale Benutzeroberfläche TwinCAT 3
Zunächst ist die Erstellung eines neues Projekt mittels [image] (oder unter „Datei“→“Neu“→“Projekt…“) vorzunehmen. In dem darauf folgenden Dialog werden die entsprechenden Einträge vorgenommen (wie in der Abbildung gezeigt):
Neues TwinCAT 3 Projekt erstellen
Im Projektmappen-Explorer liegt sodann das neue Projekt vor:
Neues TwinCAT 3 Projekt im Projektmappen-Explorer
Es besteht generell die Möglichkeit das TwinCAT "lokal" oder per "remote" zu verwenden. Ist das TwinCAT System inkl. Benutzeroberfläche (Standard) auf dem betreffenden PLC (lokal) installiert, kann TwinCAT "lokal" eingesetzt werden und mit Schritt „Geräte einfügen“ fortgesetzt werden.
Ist es vorgesehen, die auf einem PLC installierte TwinCAT Laufzeitumgebung von einem anderen System als Entwicklungsumgebung per "remote" anzusprechen, ist das Zielsystem zuvor bekannt zu machen. Über das Symbol in der Menüleiste:
wird das pull-down Menü aufgeklappt:
und folgendes Fenster hierzu geöffnet:
Auswahldialog: Wähle Zielsystem
Mittels "Suchen (Ethernet)..." wird das Zielsystem eingetragen. Dadurch wird ein weiterer Dialog geöffnet um hier entweder:
▪
den bekannten Rechnernamen hinter "Enter Host Name / IP:" einzutragen (wie rot gekennzeichnet)
▪
einen "Broadcast Search" durchzuführen (falls der Rechnername nicht genau bekannt)
▪
die bekannte Rechner - IP oder AmsNetId einzutragen
PLC für den Zugriff des TwinCAT System Managers festlegen: Auswahl des Zielsystems
Ist das Zielsystem eingetragen, steht dieses wie folgt zur Auswahl (ggf. muss zuvor das korrekte Passwort eingetragen werden):
Nach der Auswahl mit „OK“ ist das Zielsystem über das Visual Studio Shell ansprechbar.
Geräte einfügen
In dem linksseitigen Projektmappen-Explorer der Benutzeroberfläche des Visual Studio Shell wird innerhalb des Elementes „E/A“ befindliche „Geräte“ selektiert und sodann entweder über Rechtsklick ein Kontextmenü geöffnet und „Scan“ ausgewählt oder in der Menüleiste mit [image] die Aktion gestartet. Ggf. ist zuvor der TwinCAT System Manager in den „Konfig Modus“ mittels [image] oder über das Menü „TWINCAT“ → „Restart TwinCAT (Config Mode)“ zu versetzen.
Auswahl „Scan“
Die darauf folgende Hinweismeldung ist zu bestätigen und in dem Dialog die Geräte „EtherCAT“ zu wählen:
Automatische Erkennung von E/A Geräten: Auswahl der einzubindenden Geräte
Ebenfalls ist anschließend die Meldung „nach neuen Boxen suchen“ zu bestätigen, um die an den Geräten angebundenen Klemmen zu ermitteln. „Free Run“ erlaubt das Manipulieren von Ein- und Ausgangswerten innerhalb des „Config Modus“ und sollte ebenfalls bestätigt werden.
Ausgehend von der am Anfang dieses Kapitels beschriebenen Beispielkonfiguration sieht das Ergebnis wie folgt aus:
Abbildung der Konfiguration in VS Shell der TwinCAT 3 Umgebung
Der gesamte Vorgang setzt sich aus zwei Stufen zusammen, die auch separat ausgeführt werden können (erst das Ermitteln der Geräte, dann das Ermitteln der daran befindlichen Elemente wie Boxen, Klemmen o.ä.). So kann auch durch Markierung von „Gerät ..“ aus dem Kontextmenü eine „Suche“ Funktion (Scan) ausgeführt werden, die hierbei dann lediglich die darunter liegenden (im Aufbau vorliegenden) Elemente einliest:
Einlesen von einzelnen an einem Gerät befindlichen Klemmen
Diese Funktionalität ist nützlich, falls die Konfiguration (d.h. der „reale Aufbau“) kurzfristig geändert wird.
PLC programmieren
TwinCAT PLC Control ist die Entwicklungsumgebung zur Erstellung der Steuerung in unterschiedlichen Programmumgebungen: Das TwinCAT PLC Control unterstützt alle in der IEC 61131-3 beschriebenen Sprachen. Es gibt zwei textuelle Sprachen und drei grafische Sprachen.
▪
Textuelle Sprachen
–
Anweisungsliste (AWL, IL)
–
Strukturierter Text (ST)
▪
Grafische Sprachen
–
Funktionsplan (FUP, FBD)
–
Kontaktplan (KOP, LD)
–
Freigrafischer Funktionsplaneditor (CFC)
–
Ablaufsprache (AS, SFC)
Für die folgenden Betrachtungen wird lediglich vom strukturierten Text (ST) Gebrauch gemacht.
Um eine Programmierumgebung zu schaffen, wird dem Beispielprojekt über das Kontextmenü von „SPS“ im Projektmappen-Explorer durch Auswahl von „Neues Element hinzufügen….“ ein PLC Unterprojekt hinzugefügt:
Einfügen der Programmierumgebung in "SPS"
In dem darauf folgenden geöffneten Dialog wird ein „Standard PLC Projekt“ ausgewählt und beispielsweise als Projektname „PLC_example“ vergeben und ein entsprechendes Verzeichnis ausgewählt:
Festlegen des Namens bzw. Verzeichnisses für die PLC Programmierumgebung
Das durch Auswahl von „Standard PLC Projekt“ bereits existierende Programm „Main“ kann über das „PLC_example_Project“ in „POUs“ durch Doppelklick geöffnet werden. Es wird folgende Benutzeroberfläche für ein initiales Projekt dargestellt:
Initiales Programm "Main" des Standard PLC Projektes
Nun sind für den weiteren Ablauf Beispielvariablen sowie ein Beispielprogramm erstellt worden:
Beispielprogramm mit Variablen nach einem Kompiliervorgang (ohne Variablenanbindung)
Das Steuerprogramm wird nun als Projektmappe erstellt und damit der Kompiliervorgang vorgenommen:
Kompilierung des Programms starten
Anschließend liegen in den „Zuordnungen“ des Projektmappen-Explorers die folgenden – im ST/ PLC Programm mit „AT%“ gekennzeichneten Variablen vor:
Variablen Zuordnen
Über das Menü einer Instanz – Variablen innerhalb des „SPS“ Kontextes wird mittels „Verknüpfung Ändern…“ ein Fenster zur Auswahl eines passenden Prozessobjektes (PDOs) für dessen Verknüpfung geöffnet:
Erstellen der Verknüpfungen PLC-Variablen zu Prozessobjekten
In dem dadurch geöffneten Fenster kann aus dem SPS-Konfigurationsbaum das Prozessobjekt für die Variable „bEL1004_Ch4“ vom Typ BOOL selektiert werden:
Auswahl des PDO vom Typ BOOL
Entsprechend der Standarteinstellungen stehen nur bestimmte PDO Objekte zur Auswahl zur Verfügung. In diesem Beispiel wird von der Klemme EL1004 der Eingang von Kanal 4 zur Verknüpfung ausgewählt. Im Gegensatz hierzu muss für das Erstellen der Verknüpfung der Ausgangsvariablen die Checkbox „Alle Typen“ aktiviert werden, um in diesem Fall eine Byte-Variable einen Satz von acht separaten Ausgangsbits zuzuordnen. Die folgende Abbildung zeigt den gesamten Vorgang:
Auswahl von mehreren PDO gleichzeitig: Aktivierung von "Kontinuierlich" und „Alle Typen“
Zu sehen ist, dass überdies die Checkbox „Kontinuierlich“ aktiviert wurde. Dies ist dafür vorgesehen, dass die in dem Byte der Variablen „nEL2008_value“ enthaltenen Bits allen acht ausgewählten Ausgangsbits der Klemme EL2008 der Reihenfolge nach zugeordnet werden sollen. Damit ist es möglich, alle acht Ausgänge der Klemme mit einem Byte entsprechend Bit 0 für Kanal 1 bis Bit 7 für Kanal 8 von der PLC im Programm später anzusprechen. Ein spezielles Symbol ( [image]) an dem gelben bzw. roten Objekt der Variablen zeigt an, dass hierfür eine Verknüpfung existiert. Die Verknüpfungen können z.B. auch überprüft werden, indem „Goto Link Variable“ aus dem Kontextmenü einer Variable ausgewählt wird. Dann wird automatisch das gegenüberliegende verknüpfte Objekt, in diesem Fall das PDO selektiert:
Anwendung von "Goto Link Variable" am Beispiel von "MAIN.bEL1004_Ch4"
Der Vorgang zur Erstellung von Verknüpfungen kann auch in umgekehrter Richtung, d.h. von einzelnen PDO ausgehend zu einer Variablen erfolgen. In diesem Beispiel wäre dann allerdings eine komplette Auswahl aller Ausgangsbits der EL2008 nicht möglich, da die Klemme nur einzelne digitale Ausgänge zur Verfügung stellt. Hat eine Klemme einen Byte, Word, Integer oder ein ähnliches PDO, so ist es möglich dies wiederum einen Satz von bit-typisierten Variablen (Typ „BOOL“) zuzuordnen. Auch hier kann ebenso in die andere Richtung ein „Goto Link Variable“ ausgeführt werden, um dann die betreffende Instanz der PLC zu selektieren.
Aktivieren der Konfiguration
Die Zuordnung von PDO zu PLC Variablen hat nun die Verbindung von der Steuerung zu den Ein- und Ausgängen der Klemmen hergestellt. Nun kann die Konfiguration mit [image] oder über das Menü unter „TWINCAT“ aktiviert werden, um dadurch Einstellungen der Entwicklungsumgebung auf das Laufzeitsystem zu übertragen. Die darauf folgenden Meldungen „Alte Konfigurationen werden überschrieben!“ sowie „Neustart TwinCAT System in Run Modus“ werden jeweils mit „OK“ bestätigt. Die entsprechenden Zuordnungen sind in dem Projektmappen-Explorer einsehbar:
Einige Sekunden später wird der entsprechende Status des Run Modus mit einem rotierenden Symbol [image] unten rechts in der Entwicklungsumgebung VS Shell angezeigt. Das PLC System kann daraufhin wie im Folgenden beschrieben gestartet werden.
Starten der Steuerung
Entweder über die Menüauswahl „PLC“ → „Einloggen“ oder per Klick auf [image] ist die PLC mit dem Echtzeitsystem zu verbinden und nachfolgend das Steuerprogramm zu geladen, um es ausführen lassen zu können. Dies wird entsprechend mit der Meldung „Kein Programm auf der Steuerung! Soll das neue Programm geladen werden?“ bekannt gemacht und ist mit “Ja” zu beantworten. Die Laufzeitumgebung ist bereit zum Programmstart mit Klick auf das Symbol [image], Taste „F5“ oder entsprechend auch über „PLC“ im Menü durch Auswahl von „Start“. Die gestartete Programmierumgebung zeigt sich mit einer Darstellung der Laufzeitwerte von einzelnen Variablen:
TwinCAT 3 Entwicklungsumgebung (VS Shell): Logged-in, nach erfolgten Programmstart
Die beiden Bedienelemente zum Stoppen [image] und Ausloggen [image] führen je nach Bedarf zu der gewünschten Aktion (entsprechend auch für Stopp „umschalt-Taste + F5“ oder beide Aktionen über das „PLC“ Menü auswählbar).


TwinCAT Entwicklungsumgebung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung
TwinCAT Entwicklungsumgebung
Die Software zur Automatisierung TwinCAT (The Windows Control and Automation Technology) wird unterschieden in:
▪
TwinCAT 2: System Manager (Konfiguration) & PLC Control (Programmierung)
▪
TwinCAT 3: Weiterentwicklung von TwinCAT 2 (Programmierung und Konfiguration erfolgt über eine gemeinsame Entwicklungsumgebung)
Details:
▪
TwinCAT 2:
–
Verbindet E/A-Geräte und Tasks variablenorientiert
–
Verbindet Tasks zu Tasks variablenorientiert
–
Unterstützt Einheiten auf Bit-Ebene
–
Unterstützt synchrone oder asynchrone Beziehungen
–
Austausch konsistenter Datenbereiche und Prozessabbilder
–
Datenanbindung an NT-Programme mittels offener Microsoft Standards (OLE, OCX, ActiveX, DCOM+, etc.).
–
Einbettung von IEC 61131-3-Software-SPS, Software- NC und Software-CNC in Windows NT/2000/XP/Vista, Windows 7, NT/XP Embedded, CE
–
Anbindung an alle gängigen Feldbusse
–
Weiteres…
Zusätzlich bietet:
▪
TwinCAT 3 (eXtended Automation):
–
Visual-Studio®-Integration
–
Wahl der Programmiersprache
–
Unterstützung der objektorientierten Erweiterung der IEC 61131-3
–
Verwendung von C/C++ als Programmiersprache für Echtzeitanwendungen
–
Anbindung an MATLAB®/Simulink®
–
Offene Schnittstellen für Erweiterbarkeit
–
Flexible Laufzeitumgebung
–
Aktive Unterstützung von Multi-Core- und 64-Bit-Betriebssystemen
–
Automatische Codegenerierung und Projekterstellung mit dem TwinCAT Automation Interface
–
Weiteres…
In den folgenden Kapiteln wird dem Anwender die Inbetriebnahme der TwinCAT Entwicklungsumgebung auf einem PC System der Steuerung sowie die wichtigsten Funktionen einzelner Steuerungselemente erläutert.
Bitte sehen Sie weitere Informationen zu TwinCAT 2 und TwinCAT 3 unter http://infosys.beckhoff.de/.
Weiterführende Informationen
•
Installation TwinCAT Realtime Treiber
•
Hinweise ESI-Gerätebeschreibung
•
TwinCAT ESI Updater
•
Unterscheidung Online/Offline
•
OFFLINE Konfigurationserstellung
•
ONLINE Konfigurationserstellung
•
EtherCAT Teilnehmerkonfiguration


Installation TwinCAT Realtime Treiber

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Installation TwinCAT Realtime Treiber
Installation TwinCAT Realtime Treiber
Um einen Standard Ethernet Port einer IPC Steuerung mit den nötigen Echtzeitfähigkeiten auszurüsten, ist der Beckhoff Echtzeit Treiber auf diesem Port unter Windows zu installieren.
Dies kann auf mehreren Wegen vorgenommen werden, ein Weg wird hier vorgestellt.
Im Systemmanager ist über Options → Show realtime Kompatible Geräte die TwinCAT-Übersicht über die lokalen Netzwerkschnittstellen aufzurufen.
Aufruf im Systemmanager (TwinCAT 2)
Unter TwinCAT 3 ist dies über das Menü unter „TwinCAT“ erreichbar:
Aufruf in VS Shell (TwinCAT 3)
Der folgende Dialog erscheint:
Übersicht Netzwerkschnittstellen
Hier können nun Schnittstellen, die unter "Kompatible Geräte" aufgeführt sind, über den "Install" Button mit dem Treiber belegt werden. Eine Installation des Treibers auf inkompatiblen Devices sollte nicht vorgenommen werden.
Ein Windows-Warnhinweis bezüglich des unsignierten Treibers kann ignoriert werden.
Alternativ kann auch wie im Kapitel Offline Konfigurationserstellung, Abschnitt „Anlegen des Geräts EtherCAT“ beschrieben, zunächst ein EtherCAT-Gerät eingetragen werden, um dann über dessen Eigenschaften (Karteireiter „Adapter“, Button „Kompatible Geräte…“) die kompatiblen Ethernet Ports einzusehen:
Eigenschaft von EtherCAT Gerät (TwinCAT 2): Klick auf „Kompatible Geräte…“ von „Adapter“
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Nach der Installation erscheint der Treiber aktiviert in der Windows-Übersicht der einzelnen Netzwerkschnittstelle (Windows Start → Systemsteuerung → Netzwerk)
Windows-Eigenschaften der Netzwerkschnittstelle
Eine korrekte Einstellung des Treibers könnte wie folgt aussehen:
Beispielhafte korrekte Treiber-Einstellung des Ethernet Ports
Andere mögliche Einstellungen sind zu vermeiden:
Fehlerhafte Treiber-Einstellungen des Ethernet Ports
IP-Adresse des verwendeten Ports
IP Adresse/DHCP
In den meisten Fällen wird ein Ethernet-Port, der als EtherCAT-Gerät konfiguriert wird, keine allgemeinen IP-Pakete transportieren. Deshalb und für den Fall, dass eine EL6601 oder entsprechende Geräte eingesetzt werden, ist es sinnvoll, über die Treiber-Einstellung "Internet Protocol TCP/IP" eine feste IP-Adresse für diesen Port zu vergeben und DHCP zu deaktivieren. Dadurch entfällt die Wartezeit, bis sich der DHCP-Client des Ethernet Ports eine Default-IP-Adresse zuteilt, weil er keine Zuteilung eines DHCP-Servers erhält. Als Adressraum empfiehlt sich z.B. 192.168.x.x.
TCP/IP-Einstellung des Ethernet Ports


Hinweise ESI-Gerätebeschreibung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Hinweise ESI-Gerätebeschreibung
Hinweise ESI-Gerätebeschreibung
Installation der neuesten ESI-Device-Description
Der TwinCAT EtherCAT Master/System Manager benötigt zur Konfigurationserstellung im Online- und Offline-Modus die Gerätebeschreibungsdateien der zu verwendeten Geräte. Diese Gerätebeschreibungen sind die so genannten ESI (EtherCAT Slave Information) in Form von XML-Dateien. Diese Dateien können vom jeweiligen Hersteller angefordert werden bzw. werden zum Download bereitgestellt. Eine *.xml-Datei kann dabei mehrere Gerätebeschreibungen enthalten.
Auf der Beckhoff Website werden die ESI für Beckhoff EtherCAT Geräte bereitgehalten.
Die ESI-Dateien sind im Installationsverzeichnis von TwinCAT abzulegen.
Standardeinstellungen:
▪
TwinCAT 2: C:\TwinCAT\IO\EtherCAT
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\EtherCAT
Beim Öffnen eines neuen System Manager-Fensters werden die Dateien einmalig eingelesen, wenn sie sich seit dem letzten System Manager-Fenster geändert haben.
TwinCAT bringt bei der Installation den Satz an Beckhoff-ESI-Dateien mit, der zum Erstellungszeitpunkt des TwinCAT builds aktuell war.
Ab TwinCAT 2.11 / TwinCAT 3 kann aus dem System Manager heraus das ESI-Verzeichnis aktualisiert werden, wenn der Programmier-PC mit dem Internet verbunden ist; unter
TwinCAT 2: Options → "Update EtherCAT Device Descriptions"
TwinCAT 3: TwinCAT → EtherCAT Devices → “Update Device Descriptions (via ETG Website)…”
Hierfür steht der TwinCAT ESI Updater zur Verügung.
ESI
Zu den *.xml-Dateien gehören die so genannten *.xsd-Dateien, die den Aufbau der ESI-XML-Dateien beschreiben. Bei einem Update der ESI-Gerätebeschreibungen sind deshalb beide Dateiarten ggf. zu aktualisieren.
Geräteunterscheidung
EtherCAT Geräte/Slaves werden durch vier Eigenschaften unterschieden, aus denen die vollständige Gerätebezeichnung zusammengesetzt wird. Beispielsweise setzt sich die Gerätebezeichnung "EL2521-0025-1018" zusammen aus:
▪
Familienschlüssel "EL"
▪
Name "2521"
▪
Typ "0025"
▪
und Revision "1018"
Gerätebezeichnung: Struktur
Die Bestellbezeichnung aus Typ + Version (hier: EL2521-0010) beschreibt die Funktion des Gerätes. Die Revision gibt den technischen Fortschritt wieder und wird von Beckhoff verwaltet. Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn z.B. in der Dokumentation nicht anders angegeben. Jeder Revision zugehörig ist eine eigene ESI-Beschreibung. Siehe weitere Hinweise.
Online Description
Wird die EtherCAT Konfiguration online durch Scannen real vorhandener Teilnehmer erstellt (s. Kapitel Online Erstellung) und es liegt zu einem vorgefundenen Slave (ausgezeichnet durch Name und Revision) keine ESI-Beschreibung vor, fragt der System Manager, ob er die im Gerät vorliegende Beschreibung verwenden soll. Der System Manager benötigt in jedem Fall diese Information, um die zyklische und azyklische Kommunikation mit dem Slave richtig einstellen zu können.
Hinweisfenster OnlineDescription (TwinCAT 2)
In TwinCAT 3 erscheint ein ähnliches Fenster, das auch das Web-Update anbietet:
Hinweisfenster OnlineDescription (TwinCAT 3)
Wenn möglich, ist das Yes abzulehnen und vom Geräte-Hersteller die benötigte ESI anzufordern. Nach Installation der XML/XSD-Datei ist der Konfigurationsvorgang erneut vorzunehmen.
Hinweis
Veränderung der "üblichen" Konfiguration durch Scan
✓
für den Fall eines durch Scan entdeckten aber TwinCAT noch unbekannten Geräts sind zwei Fälle zu unterscheiden. Hier am Beispiel der EL2521-0000 in der Revision 1019:
1.
für das Gerät EL2521-0000 liegt überhaupt keine ESI vor, weder für die Revision 1019 noch für eine ältere Revision. Dann ist vom Hersteller (hier: Beckhoff) die ESI anzufordern.
2.
für das Gerät EL2521-0000 liegt eine ESI nur in älterer Revision vor, z.B. 1018 oder 1017.
Dann sollte erst betriebsintern überprüft werden, ob die Ersatzteilhaltung überhaupt die Integration der erhöhten Revision in die Konfiguration zulässt. Üblicherweise bringt eine neue/größere Revision auch neue Features mit. Wenn diese nicht genutzt werden sollen, kann ohne Bedenken mit der bisherigen Revision 1018 in der Konfiguration weitergearbeitet werden. Dies drückt auch die Beckhoff Kompatibilitätsregel aus.
Siehe dazu insbesondere das Kapitel „Allgemeine Hinweise zur Verwendung von Beckhoff EtherCAT IO-Komponenten" und zur manuellen Konfigurationserstellung das Kapitel „Offline Konfigurationserstellung“.
Wird dennoch die Online Description verwendet, liest der System Manager aus dem im EtherCAT Slave befindlichen EEPROM eine Kopie der Gerätebeschreibung aus. Bei komplexen Slaves kann die EEPROM-Größe u.U. nicht ausreichend für die gesamte ESI sein, weshalb im Konfigurator dann eine unvollständige ESI vorliegt. Deshalb wird für diesen Fall die Verwendung einer offline ESI-Datei vorrangig empfohlen.
Der System Manager legt bei „online“ erfassten Gerätebeschreibungen in seinem ESI-Verzeichnis eine neue Datei "OnlineDescription0000...xml" an, die alle online ausgelesenen ESI-Beschreibungen enthält.
Vom Systemmanager angelegt OnlineDescription.xml
Soll daraufhin ein Slave manuell in die Konfiguration eingefügt werden, sind „online“ erstellte Slaves durch ein vorangestelltes „>“ Symbol in der Auswahlliste gekennzeichnet (siehe Abbildung „Kennzeichnung einer online erfassten ESI am Beispiel EL2521“).
Kennzeichnung einer online erfassten ESI am Beispiel EL2521
Wurde mit solchen ESI-Daten gearbeitet und liegen später die herstellereigenen Dateien vor, ist die OnlineDescription....xml wie folgt zu löschen:
▪
alle System Managerfenster schließen
▪
TwinCAT in Konfig-Mode neu starten
▪
"OnlineDescription0000...xml" löschen
▪
TwinCAT System Manager wieder öffnen
Danach darf diese Datei nicht mehr zu sehen sein, Ordner ggf. mit <F5> aktualisieren.
OnlineDescription unter TwinCAT 3.x
Zusätzlich zu der oben genannten Datei "OnlineDescription0000...xml" legt TwinCAT 3.x auch einen so genannten EtherCAT-Cache mit neuentdeckten Geräten an, z.B. unter Windows 7 unter

(Spracheinstellungen des Betriebssystems beachten!)
Diese Datei ist im gleichen Zuge wie die andere Datei zu löschen.
Fehlerhafte ESI-Datei
Liegt eine fehlerhafte ESI-Datei vor die vom System Manager nicht eingelesen werden kann, meldet dies der System Manager durch ein Hinweisfenster.
Hinweisfenster fehlerhafte ESI-Datei (links: TwinCAT 2; rechts: TwinCAT 3)
Ursachen dafür können sein
▪
Aufbau der *.xml entspricht nicht der zugehörigen *.xsd-Datei → prüfen Sie die Ihnen vorliegenden Schemata
▪
Inhalt kann nicht in eine Gerätebeschreibung übersetzt werden → Es ist der Hersteller der Datei zu kontaktieren


TwinCAT ESI Updater

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] TwinCAT ESI Updater
TwinCAT ESI Updater
Ab TwinCAT 2.11 kann der Systemmanager bei Onlinezugang selbst nach aktuellen Beckhoff ESI-Dateien suchen:
Anwendung des ESI Updater (>=TwinCAT 2.11)
Der Aufruf erfolgt unter:
„Options“ → "Update EtherCAT Device Descriptions".
Auswahl bei TwinCAT 3:
Anwendung des ESI Updater (TwinCAT 3)
Der ESI Updater ist eine bequeme Möglichkeit, die von den EtherCAT Herstellern bereitgestellten ESIs automatisch über das Internet in das TwinCAT-Verzeichnis zu beziehen (ESI = EtherCAT slave information). Dazu greift TwinCAT auf die bei der ETG hinterlegte zentrale ESI-ULR-Verzeichnisliste zu; die Einträge sind dann unveränderbar im Updater-Dialog zu sehen.
Der Aufruf erfolgt unter:
„TwinCAT“ → „EtherCAT Devices“ → „Update Device Description (via ETG Website)…“.


Unterscheidung Online/Offline

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] Unterscheidung Online/Offline
Unterscheidung Online/Offline
Die Unterscheidung Online/Offline bezieht sich auf das Vorhandensein der tatsächlichen I/O-Umgebung (Antriebe, Klemmen, EJ-Module). Wenn die Konfiguration im Vorfeld der Anlagenerstellung z.B. auf einem Laptop als Programmiersystem erstellt werden soll, ist nur die "Offline-Konfiguration" möglich. Dann müssen alle Komponenten händisch in der Konfiguration z.B. nach Elektro-Planung eingetragen werden.
Ist die vorgesehene Steuerung bereits an das EtherCAT System angeschlossen, alle Komponenten mit Spannung versorgt und die Infrastruktur betriebsbereit, kann die TwinCAT Konfiguration auch vereinfacht durch das so genannte "Scannen" vom Runtime-System aus erzeugt werden. Dies ist der so genannte Online-Vorgang.
In jedem Fall prüft der EtherCAT Master bei jedem realen Hochlauf, ob die vorgefundenen Slaves der Konfiguration entsprechen. Dieser Test kann in den erweiterten Slave-Einstellungen parametriert werden. Siehe hierzu den Hinweis „Installation der neuesten ESI-XML-Device-Description“.
Zur Konfigurationserstellung
▪
muss die reale EtherCAT-Hardware (Geräte, Koppler, Antriebe) vorliegen und installiert sein.
▪
müssen die Geräte/Module über EtherCAT-Kabel bzw. im Klemmenstrang so verbunden sein wie sie später eingesetzt werden sollen.
▪
müssen die Geräte/Module mit Energie versorgt werden und kommunikationsbereit sein.
▪
muss TwinCAT auf dem Zielsystem im CONFIG-Modus sein.
Der Online-Scan-Vorgang setzt sich zusammen aus:
▪
Erkennen des EtherCAT-Gerätes (Ethernet-Port am IPC)
▪
Erkennen der angeschlossenen EtherCAT-Teilnehmer. Dieser Schritt kann auch unabhängig vom vorangehenden durchgeführt werden.
▪
Problembehandlung
Auch kann der Scan bei bestehender Konfiguration zum Vergleich durchgeführt werden.


OFFLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] OFFLINE Konfigurationserstellung
OFFLINE Konfigurationserstellung
Anlegen des Geräts EtherCAT
In einem leeren System Manager Fenster muss zuerst ein EtherCAT Gerät angelegt werden.
Anfügen eines EtherCAT Device: links TwinCAT 2; rechts TwinCAT 3
Für eine EtherCAT I/O Anwendung mit EtherCAT Slaves ist der "EtherCAT" Typ auszuwählen. "EtherCAT Automation Protocol via EL6601" ist für den bisherigen Publisher/Subscriber-Dienst in Kombination mit einer EL6601/EL6614 Klemme auszuwählen.
Auswahl EtherCAT Anschluss (TwinCAT 2.11, TwinCAT 3)
Diesem virtuellen Gerät ist dann ein realer Ethernet Port auf dem Laufzeitsystem zuzuordnen.
Auswahl Ethernet Port
Diese Abfrage kann beim Anlegen des EtherCAT-Gerätes automatisch erscheinen, oder die Zuordnung kann später im Eigenschaftendialog gesetzt/geändert werden; siehe Abb. „Eigenschaften EtherCAT Gerät (TwinCAT 2)“.
Eigenschaften EtherCAT Gerät (TwinCAT 2)
TwinCAT 3: Die Eigenschaften des EtherCAT-Gerätes können mit Doppelklick auf „Gerät .. (EtherCAT)“ im Projektmappen-Explorer unter „E/A“ geöffnet werden:
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Definieren von EtherCAT Slaves
Durch Rechtsklick auf ein Gerät im Konfigurationsbaum können weitere Geräte angefügt werden.
Anfügen von EtherCAT Geräten (links: TwinCAT 2; rechts: TwinCAT 3)
Es öffnet sich der Dialog zur Auswahl des neuen Gerätes. Es werden nur Geräte angezeigt für die ESI-Dateien hinterlegt sind.
Die Auswahl bietet auch nur Geräte an, die an dem vorher angeklickten Gerät anzufügen sind - dazu wird die an diesem Port mögliche Übertragungsphysik angezeigt (Abb. „Auswahldialog neues EtherCAT Gerät“, A). Es kann sich um kabelgebundene FastEthernet-Ethernet-Physik mit PHY-Übertragung handeln, dann ist wie in Abb. „Auswahldialog neues EtherCAT Gerät“ nur ebenfalls kabelgebundenes Geräte auswählbar. Verfügt das vorangehende Gerät über mehrere freie Ports (z.B. EK1122 oder EK1100), kann auf der rechten Seite (A) der gewünschte Port angewählt werden.
Übersicht Übertragungsphysik
▪
"Ethernet": Kabelgebunden 100BASE-TX: EK-Koppler, EP-Boxen, Geräte mit RJ45/M8/M12-Konnector
▪
"E-Bus": LVDS "Klemmenbus",„EJ-Module“: EL/ES-Klemmen, diverse anreihbare Module
Das Suchfeld erleichtert das Auffinden eines bestimmten Gerätes (ab TwinCAT 2.11 bzw. TwinCAT 3).
Auswahldialog neues EtherCAT Gerät
Standardmäßig wird nur der Name/Typ des Gerätes als Auswahlkriterium verwendet. Für eine gezielte Auswahl einer bestimmen Revision des Gerätes kann die Revision als "Extended Information" eingeblendet werden.
Anzeige Geräte-Revision
Oft sind aus historischen oder funktionalen Gründen mehrere Revisionen eines Gerätes erzeugt worden, z. B. durch technologische Weiterentwicklung. Zur vereinfachten Anzeige (s. Abb. „Auswahldialog neues EtherCAT Gerät“) wird bei Beckhoff Geräten nur die letzte (=höchste) Revision und damit der letzte Produktionsstand im Auswahldialog angezeigt. Sollen alle im System als ESI-Beschreibungen vorliegenden Revisionen eines Gerätes angezeigt werden, ist die Checkbox "Show Hidden Devices" zu markieren, s. Abb. „Anzeige vorhergehender Revisionen“.
Anzeige vorhergehender Revisionen
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Das Gerät stellt sich dann mit seinem Prozessabbild im Konfigurationsbaum dar und kann nur parametriert werden: Verlinkung mit der Task, CoE/DC-Einstellungen, PlugIn-Definition, StartUp-Einstellungen, ...
EtherCAT Klemme im TwinCAT-Baum (links: TwinCAT 2; rechts: TwinCAT 3)


ONLINE Konfigurationserstellung

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] ONLINE Konfigurationserstellung
ONLINE Konfigurationserstellung
Erkennen/Scan des Geräts EtherCAT
Befindet sich das TwinCAT-System im CONFIG-Modus, kann online nach Geräten gesucht werden. Erkennbar ist dies durch ein Symbol unten rechts in der Informationsleiste:
▪
bei TwinCAT 2 durch eine blaue Anzeige „Config Mode“ im System Manager-Fenster: .
▪
bei der Benutzeroberfläche der TwinCAT 3 Entwicklungsumgebung durch ein Symbol [image].
TwinCAT lässt sich in diesem Modus versetzen:
▪
TwinCAT 2: durch Auswahl von [image] aus der Menüleiste oder über „Aktionen“ → „Starten/Restarten von TwinCAT in Konfig-Modus“
▪
TwinCAT 3: durch Auswahl von [image] aus der Menüleiste oder über „TWINCAT“ → „Restart TwinCAT (Config Mode)“
Online Scannen im Config Mode
Die Online-Suche im RUN-Modus (produktiver Betrieb) ist nicht möglich. Es ist die Unterscheidung zwischen TwinCAT-Programmiersystem und TwinCAT-Zielsystem zu beachten.
Das TwinCAT 2-Icon ( [image]) bzw. TwinCAT 3-Icon ( [image]) in der Windows Taskleiste stellt immer den TwinCAT-Modus des lokalen IPC dar. Im System Manager-Fenster von TwinCAT 2 bzw. in der Benutzeroberfläche von TwinCAT 3 wird dagegen der TwinCAT-Zustand des Zielsystems angezeigt.
Unterscheidung Lokalsystem/ Zielsystem (links: TwinCAT 2; rechts: TwinCAT 3)
Im Konfigurationsbaum bringt uns ein Rechtsklick auf den General-Punkt "I/O Devices" zum Such-Dialog.
Scan Devices (links: TwinCAT 2; rechts: TwinCAT 3)
Dieser Scan-Modus versucht nicht nur EtherCAT-Geräte (bzw. die als solche nutzbaren Ethernet-Ports) zu finden, sondern auch NOVRAM, Feldbuskarten, SMB etc. Nicht alle Geräte können jedoch automatisch gefunden werden.
Hinweis automatischer GeräteScan (links: TwinCAT 2; rechts: TwinCAT 3)
Ethernet Ports mit installierten TwinCAT Realtime-Treiber werden als "RT-Ethernet" Geräte angezeigt. Testweise wird an diesen Ports ein EtherCAT-Frame verschickt. Erkennt der Scan-Agent an der Antwort, dass ein EtherCAT-Slave angeschlossen ist, wird der Port allerdings gleich als "EtherCAT Device" angezeigt.
Erkannte Ethernet-Geräte
Über entsprechende Kontrollkästchen können Geräte ausgewählt werden (wie in der Abb. „Erkannte Ethernet-Geräte“ gezeigt ist z. B. Gerät 3 und Gerät 4 ausgewählt). Für alle angewählten Geräte wird nach Bestätigung "OK" im nachfolgenden ein Teilnehmer-Scan vorgeschlagen, s. Abb. „Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes“.
Auswahl Ethernet Port
Es können nur Ethernet Ports für ein EtherCAT Gerät ausgewählt werden, für die der TwinCAT Realtime-Treiber installiert ist. Dies muss für jeden Port getrennt vorgenommen werden. Siehe dazu die entsprechende Installationsseite.
Erkennen/Scan der EtherCAT Teilnehmer
Funktionsweise Online Scan
Beim Scan fragt der Master die Identity Informationen der EtherCAT Slaves aus dem Slave-EEPROM ab. Es werden Name und Revision zur Typbestimmung herangezogen. Die entsprechenden Geräte werden dann in den hinterlegten ESI-Daten gesucht und in dem dort definierten Default-Zustand in den Konfigurationsbaum eingebaut.
Beispiel Defaultzustand
Hinweis
Slave-Scan in der Praxis im Serienmaschinenbau
Die Scan-Funktion sollte mit Bedacht angewendet werden. Sie ist ein praktisches und schnelles Werkzeug, um für eine Inbetriebnahme eine Erst-Konfiguration als Arbeitsgrundlage zu erzeugen. Im Serienmaschinebau bzw. bei Reproduktion der Anlage sollte die Funktion aber nicht mehr zur Konfigurationserstellung verwendet werden sondern ggf. zum Vergleich mit der festgelegten Erst-Konfiguration.
Hintergrund: da Beckhoff aus Gründen der Produktpflege gelegentlich den Revisionsstand der ausgelieferten Produkte erhöht, kann durch einen solchen Scan eine Konfiguration erzeugt werden, die (bei identischem Maschinenaufbau) zwar von der Geräteliste her identisch ist, die jeweilige Geräterevision unterscheiden sich aber ggf. von der Erstkonfiguration.
Beispiel:
Firma A baut den Prototyp einer späteren Serienmaschine B. Dazu wird der Prototyp aufgebaut, in TwinCAT ein Scan über die IO-Geräte durchgeführt und somit die Erstkonfiguration "B.tsm" erstellt. An einer beliebigen Stelle sitzt dabei die EtherCAT-Klemme EL2521-0025 in der Revision 1018. Diese wird also so in die TwinCAT-Konfiguration eingebaut:
Einbau EtherCAT-Klemme mit Revision -1018
Ebenso werden in der Prototypentestphase Funktionen und Eigenschaften dieser Klemme durch die Programmierer/Inbetriebnehmer getestet und ggf. genutzt d.h. aus der PLC "B.pro" oder der NC angesprochen. (sinngemäß gilt das gleiche für die TwinCAT 3-Solution-Dateien).
Nun wird die Prototypenentwicklung abgeschlossen und der Serienbau der Maschine B gestartet, Beckhoff liefert dazu weiterhin die EL2521-0025-0018. Falls die Inbetriebnehmer der Abteilung Serienmaschinenbau immer einen Scan durchführen, entsteht dabei bei jeder Maschine wieder ein eine inhaltsgleiche B-Konfiguration. Ebenso werden eventuell von A weltweit Ersatzteillager für die kommenden Serienmaschinen mit Klemmen EL2521-0025-1018 angelegt.
Nach einiger Zeit erweitert Beckhoff die EL2521-0025 um ein neues Feature C. Deshalb wird die FW geändert, nach außen hin kenntlich durch einen höheren FW-Stand und eine neue Revision -1019. Trotzdem unterstützt das neue Gerät natürlich Funktionen und Schnittstellen der Vorgängerversion(en), eine Anpassung von "B.tsm" oder gar "B.pro" ist somit nicht nötig. Die Serienmaschinen können weiterhin mit "B.tsm" und "B.pro" gebaut werden, zur Kontrolle der aufgebauten Maschine ist ein vergleichernder Scan gegen die Erstkonfiguration "B.tsm" sinnvoll.
Wird nun allerdings in der Abteilung Seriennmaschinenbau nicht "B.tsm" verwendet, sondern wieder ein Scan zur Erstellung der produktiven Konfiguration durchgeführt, wird automatisch die Revision -1019 erkannt und in die Konfiguration eingebaut:
Erkennen EtherCAT-Klemme mit Revision -1019
Dies wird in der Regel von den Inbetriebnehmern nicht bemerkt. TwinCAT kann ebenfalls nichts melden, da ja quasi eine neue Konfiguration erstellt wird. Es führt nach der Kompatibilitätsregel allerdings dazu, dass in diese Maschine später keine EL2521-0025-1018 als Ersatzteil eingebaut werden sollen (auch wenn dies in den allermeisten Fällen dennoch funktioniert).
Dazu kommt, dass durch produktionsbegleitende Entwicklung in Firma A das neue Feature C der EL2521-0025-1019 (zum Beispiel ein verbesserter Analogfilter oder ein zusätzliches Prozessdatum zur Diagnose) gerne entdeckt und ohne betriebsinterne Rücksprache genutzt wird. Für die so entstandene neue Konfiguration "B2.tsm" ist der bisherige Bestand an Ersatzteilgeräten nicht mehr zu verwenden.
Bei etabliertem Serienmaschinenbau sollte der Scan nur noch zu informativen Vergleichszwecken gegen eine definierte Erstkonfiguration durchgeführt werden. Änderungen sind mit Bedacht durchzuführen!
Wurde ein EtherCAT-Device in der Konfiguration angelegt (manuell oder durch Scan), kann das I/O-Feld nach Teilnehmern/Slaves gescannt werden.
Scan-Abfrage nach dem automatischen Anlegen eines EtherCAT Gerätes (links: TwinCAT 2; rechts TwinCAT 3)
Manuelles Auslösen des Teilnehmer-Scans auf festegelegtem EtherCAT Device (links: TwinCAT 2; rechts TwinCAT 3)
Im System Manager (TwinCAT 2) bzw. der Benutzeroberfläche (TwinCAT 3) kann der Scan-Ablauf am Ladebalken unten in der Statusleiste verfolgt werden.
Scanfortschritt am Beispiel von TwinCAT 2
Die Konfiguration wird aufgebaut und kann danach gleich in den Online-Zustand (OPERATIONAL) versetzt werden.
Abfrage Config/FreeRun (links: TwinCAT 2; rechts TwinCAT 3)
Im Config/FreeRun-Mode wechselt die System Manager Anzeige blau/rot und das EtherCAT Gerät wird auch ohne aktive Task (NC, PLC) mit der Freilauf-Zykluszeit von 4 ms (Standardeinstellung) betrieben.
Anzeige des Wechsels zwischen „Free Run“ und „Config Mode“ unten rechts in der Statusleiste
TwinCAT kann auch durch einen Button in diesen Zustand versetzt werden (links: TwinCAT 2; rechts TwinCAT 3)
Das EtherCAT System sollte sich danach in einem funktionsfähigen zyklischen Betrieb nach Abb. „Beispielhafte Online-Anzeige“ befinden.
Beispielhafte Online-Anzeige
Zu beachten sind
▪
alle Slaves sollen im OP-State sein
▪
der EtherCAT Master soll im "Actual State" OP sein
▪
"Frames/sec" soll der Zykluszeit unter Berücksichtigung der versendeten Frameanzahl sein
▪
es sollen weder übermäßig "LostFrames"- noch CRC-Fehler auftreten
Die Konfiguration ist nun fertig gestellt. Sie kann auch wie im manuellen Vorgang beschrieben verändert werden.
Problembehandlung
Beim Scannen können verschiedene Effekte auftreten.
▪
es wird ein unbekanntes Gerät entdeckt, d.h. ein EtherCAT Slave für den keine ESI-XML-Beschreibung vorliegt.
In diesem Fall bietet der System Manager an, die im Gerät eventuell vorliegende ESI auszulesen. Lesen Sie dazu das Kapitel "Hinweise zu ESI/XML".
▪
Teilnehmer werden nicht richtig erkannt
 Ursachen können sein
- fehlerhafte Datenverbindungen, es treten Datenverluste während des Scans auf
- Slave hat ungültige Gerätebeschreibung
Es sind die Verbindungen und Teilnehmer gezielt zu überprüfen, z. B. durch den Emergency Scan.
Der Scan ist dann erneut vorzunehmen.
Fehlerhafte Erkennung
Im System Manager werden solche Geräte evtl. als EK0000 oder unbekannte Geräte angelegt. Ein Betrieb ist nicht möglich bzw. sinnvoll.
Scan über bestehender Konfiguration
Hinweis
Veränderung der Konfiguration nach Vergleich
Bei diesem Scan werden z.Z. (TwinCAT 2.11 bzw. 3.1) nur die Geräteeigenschaften Vendor (Hersteller), Gerätename und Revision verglichen! Ein „ChangeTo“ oder "Copy" sollte nur im Hinblick auf die Beckhoff IO-Kompatibilitätsregel (s.o.) nur mit Bedacht vorgenommen werden. Das Gerät wird dann in der Konfiguration gegen die vorgefundene Revision ausgetauscht, dies kann Einfluss auf unterstützte Prozessdaten und Funktionen haben.
Wird der Scan bei bestehender Konfiguration angestoßen, kann die reale I/O-Umgebung genau der Konfiguration entsprechen oder differieren. So kann die Konfiguration verglichen werden.
Identische Konfiguration (links: TwinCAT 2; rechts TwinCAT 3)
Sind Unterschiede feststellbar, werden diese im Korrekturdialog angezeigt, die Konfiguration kann umgehend angepasst werden.
Korrekturdialog
Die Anzeige der "Extended Information" wird empfohlen, weil dadurch Unterschiede in der Revision sichtbar werden.
Farbe
Erläuterung
grün
Dieser EtherCAT Slave findet seine Entsprechung auf der Gegenseite. Typ und Revision stimmen überein.
blau
Dieser EtherCAT Slave ist auf der Gegenseite vorhanden, aber in einer anderen Revision. Diese andere Revision kann andere Default-Einstellungen der Prozessdaten und andere/zusätzliche Funktionen haben.
Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
hellblau
Dieser EtherCAT Slave wird ignoriert (Button "Ignore")
rot
▪
Dieser EtherCAT Slave ist auf der Gegenseite nicht vorhanden
▪
Er ist vorhanden, aber in einer anderen Revision, die sich auch in den Eigenschaften von der angegebenen unterscheidet.
Auch hier gilt dann das Kompatibilitätsprinzip: Ist die gefundene Revision > als die konfigurierte Revision, ist der Einsatz unter Berücksichtung der Kompatibilität möglich, da Nachfolger-Geräte die Funktionen der Vorgänger-Geräte unterstützen sollen.
Ist die gefundene Revision < als die konfigurierte Revision, ist der Einsatz vermutlich nicht möglich. Eventuell unterstützt das vorgefundene Gerät nicht alle Funktionen, die der Master von ihm aufgrund der höheren Revision erwartet.
Geräte-Auswahl nach Revision, Kompatibilität
Mit der ESI-Beschreibung wird auch das Prozessabbild, die Art der Kommunikation zwischen Master und Slave/Gerät und ggf. Geräte-Funktionen definiert. Damit muss das reale Gerät (Firmware wenn vorhanden) die Kommunikationsanfragen/-einstellungen des Masters unterstützen. Dies ist abwärtskompatibel der Fall, d.h. neuere Geräte (höhere Revision) sollen es auch unterstützen, wenn der EtherCAT Master sie als eine ältere Revision anspricht. Als Beckhoff-Kompatibilitätsregel für EtherCAT-Klemmen/ Boxen/ EJ-Module ist anzunehmen:

Geräte-Revision in der Anlage >= Geräte-Revision in der Konfiguration

Dies erlaubt auch den späteren Austausch von Geräten ohne Veränderung der Konfiguration (abweichende Vorgaben bei Antrieben möglich).
Beispiel:
In der Konfiguration wird eine EL2521-0025-1018 vorgesehen, dann kann real eine EL2521-0025-1018 oder höher (-1019, -1020) eingesetzt werden.
Name/Revision Klemme
Wenn im TwinCAT System aktuelle ESI-Beschreibungen vorliegen, entspricht der im Auswahldialog als letzte Revision angebotene Stand dem Produktionsstand von Beckhoff. Es wird empfohlen, bei Erstellung einer neuen Konfiguration jeweils diesen letzten Revisionsstand eines Gerätes zu verwenden, wenn aktuell produzierte Beckhoff-Geräte in der realen Applikation verwendet werden. Nur wenn ältere Geräte aus Lagerbeständen in der Applikation verbaut werden sollen, ist es sinnvoll eine ältere Revision einzubinden.
Korrekturdialog mit Änderungen
Sind alle Änderungen übernommen oder akzeptiert, können sie durch "OK" in die reale *.tsm-Konfiguration übernommen werden.
Change to Compatible Type
TwinCAT bietet mit „Change to Compatible Type…“ eine Funktion zum Austauschen eines Gerätes unter Beibehaltung der Links in die Task.
Dialog “Change to Compatible Type…” (links: TwinCAT 2; rechts TwinCAT 3)
Diese Funktion ist vorzugsweise auf die AX5000-Geräte anzuwenden.
Change to Alternative Type
Der TwinCAT System Manager bietet eine Funktion zum Austauschen eines Gerätes: Change to Alternative Type
TwinCAT 2 Dialog Change to Alternative Type
Wenn aufgerufen, sucht der System Manager in der bezogenen Geräte-ESI (hier im Beispiel: EL1202-0000) nach dort enthaltenen Angaben zu kompatiblen Geräten. Die Konfiguration wird geändert und gleichzeitig das ESI-EEPROM überschrieben - deshalb ist dieser Vorgang nur im Online-Zustand (ConfigMode) möglich.


EtherCAT Teilnehmerkonfiguration

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration
EtherCAT Teilnehmerkonfiguration
Klicken Sie im linken Fenster des TwinCAT 2 System Managers bzw. bei der TwinCAT 3 Entwicklungsumgebung im Projektmappen-Explorer auf das Element der Klemme im Baum, die Sie konfigurieren möchten (im Beispiel: Klemme 3: EL3751).
„Baumzweig“ Element als Klemme EL3751
Im rechten Fenster des System Managers (TwinCAT 2) bzw. der Entwicklungsumgebung (TwinCAT 3) stehen Ihnen nun verschiedene Karteireiter zur Konfiguration der Klemme zur Verfügung. Dabei bestimmt das Maß der Komplexität eines Teilnehmers welche Karteireiter zur Verfügung stehen. So bietet, wie im obigen Beispiel zu sehen, die Klemme EL3751 viele Einstellmöglichkeiten und stellt eine entsprechende Anzahl von Karteireitern zur Verfügung. Im Gegensatz dazu stehen z.B. bei der Klemme EL1004 lediglich die Karteireiter „Allgemein“, „EtherCAT“, „Prozessdaten“ und „Online“ zur Auswahl. Einige Klemmen, wie etwa die EL6695 bieten spezielle Funktionen über einen Karteireiter mit der eigenen Klemmenbezeichnung an, also „EL6695“ in diesem Fall. Ebenfalls wird ein spezieller Karteireiter „Settings“ von Klemmen mit umfangreichen Einstellmöglichkeiten angeboten (z.B. EL3751).
Karteireiter „Allgemein“
Karteireiter „Allgemein“
Name | Name des EtherCAT-Geräts
Id | Laufende Nr. des EtherCAT-Geräts
Typ | Typ des EtherCAT-Geräts
Kommentar | Hier können Sie einen Kommentar (z.B. zum Anlagenteil) hinzufügen.
Disabled | Hier können Sie das EtherCAT-Gerät deaktivieren.
Symbole erzeugen | Nur wenn dieses Kontrollkästchen aktiviert ist, können Sie per ADS auf diesen EtherCAT-Slave zugreifen.
Karteireiter „EtherCAT“
Karteireiter „EtherCAT“
Typ | Typ des EtherCAT-Geräts
Product/Revision | Produkt- und Revisions-Nummer des EtherCAT-Geräts
Auto Inc Adr. | Auto-Inkrement-Adresse des EtherCAT-Geräts. Die Auto-Inkrement-Adresse kann benutzt werden, um jedes EtherCAT-Gerät anhand seiner physikalischen Position im Kommunikationsring zu adressieren. Die Auto-Inkrement-Adressierung wird während der Start-Up-Phase benutzt, wenn der EtherCAT-master die Adressen an die EtherCAT-Geräte vergibt. Bei der Auto-Inkrement-Adressierung hat der erste EtherCAT-Slave im Ring die Adresse 0000hex und für jeden weiteren Folgenden wird die Adresse um 1 verringert (FFFFhex, FFFEhex usw.).
EtherCAT Adr. | Feste Adresse eines EtherCAT-Slaves. Diese Adresse wird vom EtherCAT-Master während der Start-Up-Phase vergeben. Um den Default-Wert zu ändern, müssen Sie zuvor das Kontrollkästchen links von dem Eingabefeld markieren.
Vorgänger Port | Name und Port des EtherCAT-Geräts, an den dieses Gerät angeschlossen ist. Falls es möglich ist, dieses Gerät mit einem anderen zu verbinden, ohne die Reihenfolge der EtherCAT-Geräte im Kommunikationsring zu ändern, dann ist dieses Kombinationsfeld aktiviert und Sie können das EtherCAT-Gerät auswählen, mit dem dieses Gerät verbunden werden soll.
Weitere Einstellungen | Diese Schaltfläche öffnet die Dialoge für die erweiterten Einstellungen.
Der Link am unteren Rand des Karteireiters führt Sie im Internet auf die Produktseite dieses EtherCAT-Geräts.
Karteireiter „Prozessdaten“
Zeigt die (Allgemeine Slave PDO-) Konfiguration der Prozessdaten an. Die Eingangs- und Ausgangsdaten des EtherCAT-Slaves werden als CANopen Prozess-Daten-Objekte (Process Data Objects, PDO) dargestellt. Falls der EtherCAT-Slave es unterstützt, ermöglicht dieser Dialog dem Anwender ein PDO über PDO-Zuordnung auszuwählen und den Inhalt des individuellen PDOs zu variieren.
Karteireiter „Prozessdaten“
Die von einem EtherCAT Slave zyklisch übertragenen Prozessdaten (PDOs) sind die Nutzdaten, die in der Applikation zyklusaktuell erwartet werden oder die an den Slave gesendet werden. Dazu parametriert der EtherCAT Master (Beckhoff TwinCAT) jeden EtherCAT Slave während der Hochlaufphase, um festzulegen, welche Prozessdaten (Größe in Bit/Bytes, Quellort, Übertragungsart) er von oder zu diesem Slave übermitteln möchte. Eine falsche Konfiguration kann einen erfolgreichen Start des Slaves verhindern.
Für Beckhoff EtherCAT Slaves EL, ES, EM, EJ und EP gilt im Allgemeinen:
▪
Die vom Gerät unterstützten Prozessdaten Input/Output sind in der ESI/XML-Beschreibung herstellerseitig definiert. Der TwinCAT EtherCAT Master verwendet die ESI-Beschreibung zur richtigen Konfiguration des Slaves.
▪
Wenn vorgesehen, können die Prozessdaten im Systemmanager verändert werden. Siehe dazu die Gerätedokumentation.
Solche Veränderungen können sein: Ausblenden eines Kanals, Anzeige von zusätzlichen zyklischen Informationen, Anzeige in 16 Bit statt in 8 Bit Datenumfang usw.
▪
Die Prozessdateninformationen liegen bei so genannten "intelligenten" EtherCAT-Geräten ebenfalls im CoE-Verzeichnis vor. Beliebige Veränderungen in diesem CoE-Verzeichnis, die zu abweichenden PDO-Einstellungen führen, verhindern jedoch das erfolgreiche Hochlaufen des Slaves. Es wird abgeraten, andere als die vorgesehene Prozessdaten zu konfigurieren, denn die Geräte-Firmware (wenn vorhanden) ist auf diese PDO-Kombinationen abgestimmt.
Ist lt. Gerätedokumentation eine Veränderung der Prozessdaten zulässig, kann dies wie folgt vorgenommen werden, s. Abb. „Konfigurieren der Prozessdaten“.
▪
A: Wählen Sie das zu konfigurierende Gerät
▪
B: im Reiter "Process Data"in der Input- oder Output-Syncmanager zu wählen (C)
▪
D: die PDOs können an- bzw. abgewählt werden
▪
H: die neuen Prozessdaten sind als link-fähige Variablen im Systemmanager sichtbar
Nach einem Aktivieren der Konfiguration und TwinCAT-Neustart (bzw. Neustart des EtherCAT Masters) sind die neuen Prozessdaten aktiv
▪
E: wenn ein Slave dies unterstützt, können auch Input- und Output-PDO gleichzeitig durch Anwahl eines so genannten PDO-Satzes ("predefined PDO-settings") verändert werden.
Konfigurieren der Prozessdaten
Manuelle Veränderung der Prozessdaten
In der PDO-Übersicht kann lt. ESI-Beschreibung ein PDO als "fixed" mit dem Flag "F" gekennzeichnet sein (Abb. „Konfigurieren der Prozessdaten“, J). Solche PDOs können prinzipiell nicht in ihrer Zusammenstellung verändert werden, auch wenn TwinCAT den entsprechenden Dialog anbietet ("Edit"). Insbesondere können keine beliebigen CoE-Inhalte als zyklische Prozessdaten eingeblendet werden. Dies gilt im Allgemeinen auch für den Fall, dass ein Gerät den Download der PDO Konfiguration "G" unterstützt. Bei falscher Konfiguration verweigert der EtherCAT Slave üblicherweise den Start und Wechsel in den OP-State. Eine Logger-Meldung wegen "invalid SM cfg" wird im Systemmanager ausgegeben: Diese Fehlermeldung "invalid SM IN cfg" oder "invalid SM OUT cfg" bietet gleich einen Hinweis auf die Ursache des fehlgeschlagenen Starts.
Eine detaillierte Beschreibung befindet sich am Ende dieses Kapitels.
Karteireiter „Startup“
Der Karteireiter Startup wird angezeigt, wenn der EtherCAT-Slave eine Mailbox hat und das Protokoll CANopen over EtherCAT (CoE) oder das Protokoll Servo drive over EtherCAT unterstützt. Mit Hilfe dieses Karteireiters können Sie betrachten, welche Download-Requests während des Startups zur Mailbox gesendet werden. Es ist auch möglich neue Mailbox-Requests zur Listenanzeige hinzuzufügen. Die Download-Requests werden in derselben Reihenfolge zum Slave gesendet, wie sie in der Liste angezeigt werden.
Karteireiter „Startup“
Spalte
Beschreibung
Transition
Übergang, in den der Request gesendet wird. Dies kann entweder
▪
der Übergang von Pre-Operational to Safe-Operational (PS) oder
▪
der Übergang von Safe-Operational to Operational (SO) sein.
Wenn der Übergang in "<>" eingeschlossen ist (z.B. <PS>), dann ist der Mailbox Request fest und kann vom Anwender nicht geändert oder gelöscht werden.
Protokoll
Art des Mailbox-Protokolls
Index
Index des Objekts
Data
Datum, das zu diesem Objekt heruntergeladen werden soll.
Kommentar
Beschreibung des zu der Mailbox zu sendenden Requests
Move Up | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach oben.
Move Down | Diese Schaltfläche bewegt den markierten Request in der Liste um eine Position nach unten.
New | Diese Schaltfläche fügt einen neuen Mailbox-Download-Request, der währen des Startups gesendet werden soll hinzu.
Delete | Diese Schaltfläche löscht den markierten Eintrag.
Edit | Diese Schaltfläche editiert einen existierenden Request.
Karteireiter „CoE – Online“
Wenn der EtherCAT-Slave das Protokoll CANopen over EtherCAT (CoE) unterstützt, wird der zusätzliche Karteireiter CoE - Online angezeigt. Dieser Dialog listet den Inhalt des Objektverzeichnisses des Slaves auf (SDO-Upload) und erlaubt dem Anwender den Inhalt eines Objekts dieses Verzeichnisses zu ändern. Details zu den Objekten der einzelnen EtherCAT-Geräte finden Sie in den gerätespezifischen Objektbeschreibungen.
Karteireiter „CoE – Online“
Darstellung der Objekt-Liste
Spalte | Beschreibung
Index | Index und Subindex des Objekts
Name | Name des Objekts
Flags | RW | Das Objekt kann ausgelesen und Daten können in das Objekt geschrieben werden (Read/Write)
 | RO | Das Objekt kann ausgelesen werden, es ist aber nicht möglich Daten in das Objekt zu schreiben (Read only)
 | P | Ein zusätzliches P kennzeichnet das Objekt als Prozessdatenobjekt.
Wert | Wert des Objekts
Update List | Die Schaltfläche Update List aktualisiert alle Objekte in der Listenanzeige
Auto Update | Wenn dieses Kontrollkästchen angewählt ist, wird der Inhalt der Objekte automatisch aktualisiert.
Advanced | Die Schaltfläche Advanced öffnet den Dialog Advanced Settings. Hier können Sie festlegen, welche Objekte in der Liste angezeigt werden.
Dialog „Advanced settings“
Online - über SDO-Information | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis des Slaves enthaltenen Objekte über SDO-Information aus dem Slave hochgeladen. In der untenstehenden Liste können Sie festlegen welche Objekt-Typen hochgeladen werden sollen.
Offline - über EDS-Datei | Wenn dieses Optionsfeld angewählt ist, wird die Liste der im Objektverzeichnis enthaltenen Objekte aus einer EDS-Datei gelesen, die der Anwender bereitstellt.
Karteireiter „Online“
Karteireiter „Online“
Status Maschine
Init | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Init zu setzen.
Pre-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Pre-Operational zu setzen.
Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Operational zu setzen.
Bootstrap | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Bootstrap zu setzen.
Safe-Op | Diese Schaltfläche versucht das EtherCAT-Gerät auf den Status Safe-Operational zu setzen.
Fehler löschen | Diese Schaltfläche versucht die Fehleranzeige zu löschen. Wenn ein EtherCAT-Slave beim Statuswechsel versagt, setzt er eine Fehler-Flag. Beispiel: ein EtherCAT-Slave ist im Zustand PREOP (Pre-Operational). Nun fordert der Master den Zustand SAFEOP (Safe-Operational) an. Wenn der Slave nun beim Zustandswechsel versagt, setzt er das Fehler-Flag. Der aktuelle Zustand wird nun als ERR PREOP angezeigt. Nach Drücken der Schaltfläche Fehler löschen ist das Fehler-Flag gelöscht und der aktuelle Zustand wird wieder als PREOP angezeigt.
Aktueller Status | Zeigt den aktuellen Status des EtherCAT-Geräts an.
Angeforderter Status | Zeigt den für das EtherCAT-Gerät angeforderten Status an.
DLL-Status
Zeigt den DLL-Status (Data-Link-Layer-Status) der einzelnen Ports des EtherCAT-Slave an. Der DLL-Status kann vier verschiedene Zustände annehmen:
Status | Beschreibung
No Carrier / Open | Kein Carrier-Signal am Port vorhanden, der Port ist aber offen.
No Carrier / Closed | Kein Carrier-Signal am Port vorhanden und der Port ist geschlossen.
Carrier / Open | Carrier-Signal ist am Port vorhanden und der Port ist offen.
Carrier / Closed | Carrier-Signal ist am Port vorhanden, der Port ist aber geschlossen.
File Access over EtherCAT
Download | Mit dieser Schaltfläche können Sie eine Datei zum EtherCAT-Gerät schreiben.
Upload | Mit dieser Schaltfläche können Sie eine Datei vom EtherCAT-Gerät lesen.
Karteireiter „DC“ (Distributed Clocks)
Karteireiter „DC“ (Distributed Clocks)
Betriebsart
Auswahlmöglichkeiten (optional):
▪
FreeRun
▪
SM-Synchron
▪
DC-Synchron (Input based)
▪
DC-Synchron
Erweiterte Einstellungen…
Erweiterte Einstellungen für die Nachregelung der echtzeitbestimmende TwinCAT-Uhr
Detaillierte Informationen zu Distributed Clocks sind unter http://infosys.beckhoff.de angegeben:
Feldbuskomponenten → EtherCAT-Klemmen → EtherCAT System Dokumentation → Distributed Clocks
Weiterführende Informationen
•
Detaillierte Beschreibung Karteireiter „Prozessdaten“


Detaillierte Beschreibung Karteireiter „Prozessdaten“

Inbetriebnahme [image] TwinCAT Entwicklungsumgebung [image] EtherCAT Teilnehmerkonfiguration [image] Detaillierte Beschreibung Karteireiter „Prozessdaten“
Detaillierte Beschreibung Karteireiter „Prozessdaten“
Sync-Manager
Listet die Konfiguration der Sync-Manager (SM) auf.
Wenn das EtherCAT-Gerät eine Mailbox hat, wird der SM0 für den Mailbox-Output (MbxOut) und der SM1 für den Mailbox-Intput (MbxIn) benutzt.
Der SM2 wird für die Ausgangsprozessdaten (Outputs) und der SM3 (Inputs) für die Eingangsprozessdaten benutzt.
Wenn ein Eintrag ausgewählt ist, wird die korrespondierende PDO-Zuordnung in der darunter stehenden Liste PDO-Zuordnung angezeigt.
PDO-Zuordnung
PDO-Zuordnung des ausgewählten Sync-Managers. Hier werden alle für diesen Sync-Manager-Typ definierten PDOs aufgelistet:
▪
Wenn in der Sync-Manager-Liste der Ausgangs-Sync-Manager (Outputs) ausgewählt ist, werden alle RxPDOs angezeigt.
▪
Wenn in der Sync-Manager-Liste der Eingangs-Sync-Manager (Inputs) ausgewählt ist, werden alle TxPDOs angezeigt.
Die markierten Einträge sind die PDOs, die an der Prozessdatenübertragung teilnehmen. Diese PDOs werden in der Baumdarstellung dass System-Managers als Variablen des EtherCAT-Geräts angezeigt. Der Name der Variable ist identisch mit dem Parameter Name des PDO, wie er in der PDO-Liste angezeigt wird. Falls ein Eintrag in der PDO-Zuordnungsliste deaktiviert ist (nicht markiert und ausgegraut), zeigt dies an, dass dieser Eintrag von der PDO-Zuordnung ausgenommen ist. Um ein ausgegrautes PDO auswählen zu können, müssen Sie zuerst das aktuell angewählte PDO abwählen.
Aktivierung der PDO-Zuordnung
✓
Wenn Sie die PDO-Zuordnung geändert haben, muss zur Aktivierung der neuen PDO-Zuordnung
1.
der EtherCAT-Slave einmal den Statusübergang PS (von Pre-Operational zu Safe-Operational) durchlaufen (siehe Karteireiter Online)
2.
der System-Manager die EtherCAT-Slaves neu laden
(Schaltfläche [image] bei TwinCAT 2 bzw. bei TwinCAT 3)
PDO-Liste
Liste aller von diesem EtherCAT-Gerät unterstützten PDOs. Der Inhalt des ausgewählten PDOs wird der Liste PDO-Content angezeigt. Durch Doppelklick auf einen Eintrag können Sie die Konfiguration des PDO ändern.
Spalte | Beschreibung
Index | Index des PDO.
Size | Größe des PDO in Byte.
Name | Name des PDO. Wenn dieses PDO einem Sync-Manager zugeordnet ist, erscheint es als Variable des Slaves mit diesem Parameter als Namen.
Flags | F | Fester Inhalt: Der Inhalt dieses PDO ist fest und kann nicht vom System-Manager geändert werden.
 | M | Obligatorisches PDO (Mandatory). Dieses PDO ist zwingend Erforderlich und muss deshalb einem Sync-Manager Zugeordnet werden! Als Konsequenz können Sie dieses PDO nicht aus der Liste PDO-Zuordnungen streichen
SM | Sync-Manager, dem dieses PDO zugeordnet ist. Falls dieser Eintrag leer ist, nimmt dieses PDO nicht am Prozessdatenverkehr teil.
SU | Sync-Unit, der dieses PDO zugeordnet ist.
PDO-Inhalt
Zeigt den Inhalt des PDOs an. Falls das Flag F (fester Inhalt) des PDOs nicht gesetzt ist, können Sie den Inhalt ändern.
Download
Falls das Gerät intelligent ist und über eine Mailbox verfügt, können die Konfiguration des PDOs und die PDO-Zuordnungen zum Gerät herunter geladen werden. Dies ist ein optionales Feature, das nicht von allen EtherCAT-Slaves unterstützt wird.
PDO-Zuordnung
Falls dieses Kontrollkästchen angewählt ist, wird die PDO-Zuordnung die in der PDO-Zuordnungsliste konfiguriert ist beim Startup zum Gerät herunter geladen. Die notwendigen, zum Gerät zu sendenden Kommandos können in auf dem Karteireiter Startup betrachtet werden.
PDO-Konfiguration
Falls dieses Kontrollkästchen angewählt ist, wird die Konfiguration des jeweiligen PDOs (wie sie in der PDO-Liste und der Anzeige PDO-Inhalt angezeigt wird) zum EtherCAT-Slave herunter geladen.


Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves

Inbetriebnahme [image] Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
Allgemeine Inbetriebnahmehinweise des EtherCAT Slaves
In dieser Übersicht werden in Kurzform einige Aspekte des EtherCAT Slave Betriebs unter TwinCAT behandelt. Ausführliche Informationen dazu sind entsprechenden Fachkapiteln z.B. in der EtherCAT-Systemdokumentation zu entnehmen.
Diagnose in Echtzeit: WorkingCounter, EtherCAT State und Status
Im Allgemeinen bietet ein EtherCAT Slave mehrere Diagnoseinformationen zur Verarbeitung in der ansteuernden Task an.
Diese Diagnoseinformationen erfassen unterschiedliche Kommunikationsebenen und damit Quellorte und werden deshalb auch unterschiedlich aktualisiert.
Eine Applikation, die auf die Korrektheit und Aktualität von IO-Daten aus einem Feldbus angewiesen ist, muss die entsprechend ihr unterlagerten Ebenen diagnostisch erfassen.
EtherCAT und der TwinCAT System Manager bieten entsprechend umfassende Diagnoseelemente an. Die Diagnoseelemente, die im laufenden Betrieb (nicht zur Inbetriebnahme) für eine zyklusaktuelle Diagnose aus der steuernden Task hilfreich sind, werden im Folgenden erläutert.
Auswahl an Diagnoseinformationen eines EtherCAT Slave
Im Allgemeinen verfügt ein EtherCAT Slave über
▪
slave-typische Kommunikationsdiagnose (Diagnose der erfolgreichen Teilnahme am Prozessdatenaustausch und richtige Betriebsart)
Diese Diagnose ist für alle Slaves gleich.

als auch über
▪
kanal-typische Funktionsdiagnose (geräteabhängig)
Siehe entsprechende Gerätedokumentation
Die Farbgebung in Abb. „Auswahl an Diagnoseinformationen eines EtherCAT Slave“ entspricht auch den Variablenfarben im System Manager, siehe Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“.
Farbe | Bedeutung
gelb | Eingangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
rot | Ausgangsvariablen vom Slave zum EtherCAT Master, die in jedem Zyklus aktualisiert werden
grün | Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS sinnvoll.
In Abb. „Grundlegende EtherCAT Slave Diagnose in der PLC“ ist eine Beispielimplementation einer grundlegenden EtherCAT Slave Diagnose zu sehen. Dabei wird eine Beckhoff EL3102 (2 kanalige analoge Eingangsklemme) verwendet, da sie sowohl über slave-typische Kommunikationsdiagnose als auch über kanal-spezifische Funktionsdiagnose verfügt. In der PLC sind Strukturen als Eingangsvariablen angelegt, die jeweils dem Prozessabbild entsprechen.
Grundlegende EtherCAT Slave Diagnose in der PLC
Dabei werden folgende Aspekte abgedeckt:
Kennzeichen
Funktion
Ausprägung
Anwendung/Auswertung
A
Diagnoseinformationen des EtherCAT Master
zyklisch aktualisiert (gelb) oder azyklisch bereitgestellt (grün).
Zumindest der DevState ist in der PLC zyklusaktuell auszuwerten.
Die Diagnoseinformationen des EtherCAT Master bieten noch weitaus mehr Möglichkeiten, die in der EtherCAT-Systemdokumentation behandelt werden. Einige Stichworte:
▪
CoE im Master zur Kommunikation mit/über die Slaves
▪
Funktionen aus TcEtherCAT.lib
▪
OnlineScan durchführen
B
Im gewählten Beispiel (EL3102) umfasst die EL3102 zwei analoge Eingangskanäle, die einen eigenen Funktionsstatus zyklusaktuell übermitteln.
Status
▪
die Bitdeutungen sind der Gerätedokumentation zu entnehmen
▪
andere Geräte können mehr oder keine slave-typischen Angaben liefern
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Funktionsstatus ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
C
Für jeden EtherCAT Slave mit zyklischen Prozessdaten zeigt der Master durch einen so genannten WorkingCounter an, ob der Slave erfolgreich und störungsfrei am zyklischen Prozessdatenverkehr teilnimmt. Diese elementar wichtige Information wird deshalb im System Manager zyklusaktuell
1.
am EtherCAT Slave als auch inhaltsidentisch
2.
als Sammelvariable am EtherCAT Master (siehe Punkt A)
zur Verlinkung bereitgestellt.
WcState (Working Counter)
0: gültige Echtzeitkommunikation im letzten Zyklus
1: ungültige Echtzeitkommunikation
ggf. Auswirkung auf die Prozessdaten anderer Slaves, die in der gleichen SyncUnit liegen
Damit sich die übergeordnete PLC-Task (oder entsprechende Steueranwendungen) auf korrekte Daten verlassen kann, muss dort der Kommunikationsstatus des EtherCAT Slaves ausgewertet werden. Deshalb werden solche Informationen zyklusaktuell mit den Prozessdaten bereitgestellt.
D
Diagnoseinformationen des EtherCAT Masters, die zwar am Slave zur Verlinkung dargestellt werden, aber tatsächlich vom Master für den jeweiligen Slave ermittelt und dort dargestellt werden. Diese Informationen haben keinen Echtzeit-Charakter weil sie
▪
nur selten/nie verändert werden, außer beim Systemstart
▪
selbst auf azyklischem Weg ermittelt werden (z.B. EtherCAT Status)
State
aktueller Status (INIT..OP) des Slaves. Im normalen Betriebszustand muss der Slave im OP (=8) sein.
AdsAddr
Die ADS-Adresse ist nützlich, um aus der PLC/Task über ADS mit dem EtherCAT Slave zu kommunizieren, z.B. zum Lesen/Schreiben auf das CoE. Die AMS-NetID eines Slaves entspricht der AMS-NetID des EtherCAT Masters, über den port (= EtherCAT Adresse) ist der einzelne Slave ansprechbar.
Informationsvariabeln des EtherCAT Masters, die azyklisch aktualisiert werden, d.h. in einem Zyklus eventuell nicht den letztmöglichen Stand abbilden. Deshalb ist ein Auslesen solcher Variablen über ADS möglich.
Hinweis
Diagnoseinformationen
Es wird dringend empfohlen, die angebotenen Diagnoseinformationen auszuwerten um in der Applikation entsprechend reagieren zu können.
CoE-Parameterverzeichnis
Das CoE-Parameterverzeichnis (CanOpen-over-EtherCAT) dient der Verwaltung von Einstellwerten des jeweiligen Slaves. Bei der Inbetriebnahme eines komplexeren EtherCAT Slaves sind unter Umständen hier Veränderungen vorzunehmen. Zugänglich ist es über den TwinCAT System Manager, s. Abb. „EL3102, CoE-Verzeichnis“:
EL3102, CoE-Verzeichnis
EtherCAT-Systemdokumentation
Es ist die ausführliche Beschreibung in der EtherCAT-Systemdokumentation (EtherCAT Grundlagen --> CoE Interface) zu beachten!
Einige Hinweise daraus in Kürze:
▪
Es ist geräteabhängig, ob Veränderungen im Online-Verzeichnis slave-lokal gespeichert werden. EL-Klemmen (außer den EL66xx) verfügen über diese Speichermöglichkeit.
▪
Es ist vom Anwender die StartUp-Liste mit den Änderungen zu pflegen.
Inbetriebnahmehilfe im TwinCAT System Manager
In einem fortschreitenden Prozess werden für EL/EP-EtherCAT Geräte Inbetriebnahmeoberflächen eingeführt. Diese sind in TwinCAT System Managern ab TwinCAT 2.11R2 verfügbar. Sie werden über entsprechend erweiterte ESI-Konfigurationsdateien in den System Manager integriert.
Beispiel Inbetriebnahmehilfe für eine EL3204
Diese Inbetriebnahme verwaltet zugleich
▪
CoE-Parameterverzeichnis
▪
DC/FreeRun-Modus
▪
die verfügbaren Prozessdatensätze (PDO)
Die dafür bisher nötigen Karteireiter "Process Data", "DC", "Startup" und "CoE-Online" werden zwar noch angezeigt, es wird aber empfohlen die automatisch generierten Einstellungen durch die Inbetriebnahmehilfe nicht zu verändern, wenn diese verwendet wird.
Das Inbetriebnahmetool deckt nicht alle möglichen Einsatzfälle eines EL/EP-Gerätes ab. Sind die Einstellmöglichkeiten nicht ausreichend, können vom Anwender wie bisher DC-, PDO- und CoE-Einstellungen manuell vorgenommen werden.
EtherCAT State: automatisches Default-Verhalten des TwinCAT System Managers und manuelle Ansteuerung
Ein EtherCAT Slave hat für den ordnungsgemäßen Betrieb nach der Versorgung mit Betriebsspannung die Stati
▪
INIT
▪
PREOP
▪
SAFEOP
▪
OP
zu durchlaufen. Der EtherCAT Master ordnet diese Zustände an in Abhängigkeit der Initialisierungsroutinen, die zur Inbetriebnahme des Gerätes durch die ES/XML und Anwendereinstellungen (Distributed Clocks (DC), PDO, CoE) definiert sind. Siehe dazu auch Kapitel "Grundlagen der Kommunikation, EtherCAT State Machine. Der Hochlauf kann je nach Konfigurationsaufwand und Gesamtkonfiguration bis zu einigen Sekunden dauern.
Auch der EtherCAT Master selbst muss beim Start diese Routinen durchlaufen, bis er in jedem Fall den Zielzustand OP erreicht.
Der vom Anwender beabsichtigte, von TwinCAT beim Start automatisch herbeigeführte Ziel-State kann im System Manager eingestellt werden. Sobald TwinCAT in RUN versetzt wird, wird dann der TwinCAT EtherCAT Master die Zielzustände anfahren.
Standardeinstellung
Standardmäßig ist in den erweiterten Einstellungen des EtherCAT Masters gesetzt:
▪
EtherCAT Master: OP
▪
Slaves: OP
Diese Einstellung gilt für alle Slaves zugleich.
Default Verhalten System Manager
Zusätzlich kann im Dialog "Erweiterte Einstellung" beim jeweiligen Slave der Zielzustand eingestellt werden, auch dieser ist standardmäßig OP.
Default Zielzustand im Slave
Manuelle Führung
Aus bestimmten Gründen kann es angebracht sein, aus der Anwendung/Task/PLc die States kontrolliert zu fahren, z.B.
▪
aus Diagnosegründen
▪
kontrolliertes Wiederanfahren von Achsen
▪
ein zeitlich verändertes Startverhalten ist gewünscht
Dann ist es in der PLC-Anwendung sinnvoll, die PLC-Funktionsblöcke aus der standardmäßig vorhandenen TcEtherCAT.lib zu nutzen und z.B. mit FB_EcSetMasterState die States kontrolliert anzufahren.
Die Einstellungen im EtherCAT Master sind dann sinnvollerweise für Master und Slave auf INIT zu setzen.
PLC-Bausteine
Hinweis E-Bus-Strom
EL/ES-Klemmen werden im Klemmenstrang auf der Hutschiene an einen Koppler gesetzt. Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar. Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT System Manager wird der vorberechnete theoretische maximale E-Bus-Strom als Spaltenwert angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Unzulässige Überschreitung E-Bus Strom
Ab TwinCAT 2.11 wird bei der Aktivierung einer solchen Konfiguration eine Warnmeldung "E-Bus Power of Terminal..." im Logger-Fenster ausgegeben:
Warnmeldung E-Bus-Überschreitung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Grundlagen zur Funktion

Inbetriebnahme [image] Grundlagen zur Funktion
Grundlagen zur Funktion
Inhaltsverzeichnis
• Begriffserläuterungen
- Channel/Kanal
- Zyklische Prozessdaten/PDO
- Parameterdaten/CoE
- Buffer
- Event
- Timestamp
- MTSF
- Makrozyklus
- Mikrozyklus
• Kompatibilitätsmodus zu EL1252/EL2252
- Definition der PDO
Weiterführende Informationen
•
Begriffserläuterungen
•
Kompatibilitätsmodus zu EL1252/EL2252


Begriffserläuterungen

Inbetriebnahme [image] Grundlagen zur Funktion [image] Begriffserläuterungen
Begriffserläuterungen
Im Folgenden werden als Legende einige grundlegende Begriffe zur Multi-Timestamp-Funktion beschrieben. Diese bauen auf den Erläuterungen der Technologie-Seite auf, diese ist also unbedingt zu beachten.
Channel/Kanal
Die EL1259 verfügt beispielsweise über 8 Eingangs- und 8 Ausgangskanäle. Jeder Kanal kann unabhängig von den anderen arbeiten und hat seinen eigenen Buffer und seine eigenen Settings im CoE (Unterstützung des kanalorientierten Programmierens).
Trotz der kanalweisen Parametrierung (CoE, PDO) werden die Einstellungen für alle Kanäle gemeinsam in der Klemme vorgenommen.
Zyklische Prozessdaten/PDO
Jeder Kanal verfügt über 2 verschiedene Arten von zyklischen PDO:
- Diagnose/Status/Control-Werte die insbesondere für den Buffer angelegt sind
- die eigentlichen "Werte" als zeitgestempelte Bool-Daten in Form eines Arrays. Das Array ist in der Konfiguration auf eine passende Größe einzustellen, es kann zur Laufzeit nicht verändert werden.
Siehe dazu PDO-Übersicht auf den Inbetriebnahmeseiten und folgende Abschnitte.
Parameterdaten/CoE
Jeder Kanal besitzt im CoE einen Parameterbereich 0x80n0:ff mit passenden Einstellungen um z. B. den Buffer oder das Ein-/Ausgangsverhalten zu konfigurieren.
Siehe dazu Hinweise auf den Inbetriebnahmeseiten.
Buffer
Jeder Kanal verfügt über einen eigenen Buffer (Speicher) von 32 Events nach dem FIFO-Prinzip. Er wird über kanaleigene PDO bedient, siehe PDO-Übersicht auf den Inbetriebnahmeseiten.
▪
Bei Eingängen: der Kanalzustand wird im Mikrozyklus-Takt nach seinem Schaltzustand 0/1 abgefragt und bei festgestellter Änderung in den Buffer gespeichert. Je nach konfiguriertem Multi-Timestamp-Faktor des Kanals (MTSF) wird der Bufferinhalt komplett oder in mehreren Schritten von der Steuerung/PLC über EtherCAT abgeholt.
Das Verhalten bei Buffer-Überlauf kann konfiguriert werden, ein Überlauf des Buffers wird in den Prozessdaten angezeigt. Falls notwendig, kann der Buffer durch die Steuerung geleert werden.
▪
Bei Ausgängen: die Steuerung lädt je nach konfiguriertem MTSF Schaltaufträge in den Buffer. In jedem Mikrozyklus wird überprüft, ob der oberste Eintrag im Buffer auszuführen ist. Das Verhalten bei „veralteten“ Zeitstempeln kann konfiguriert werden. Falls nötig kann der Buffer durch die Steuerung geleert werden.
Hinweis: die aktuelle FW unterstützt einen Buffer von 32 Events. Andere Größen auf Anfrage.
Event
Ein "Event" ist eine wechselnde Signalflanke am Eingang oder Ausgang. Für einen Eingangskanal ist ein Event also der Wechsel des Eingangszustands 0->1 oder 1->0, dieser Wechsel besteht aus den Informationen Zeitstempel des Events und Zustand 0/1 nach der Veränderung.
Für einen Ausgangskanal ist ein Event ein Schaltauftrag, ebenfalls bestehend aus den Informationen Zeitstempel des Events und Zustand 0/1 nach der gewünschten Veränderung.
Timestamp
Originär hat die EtherCAT-Distributed-Clocks-Zeit folgende Eigenschaften: Startzeitpunkt 1.1.2000 00:00, 64 Bit Umfang mit 1 ns Auflösung (~ 584 Jahre). Um redundante Prozessdaten zu vermeiden, arbeiten die Multi-Timestamp-Klemmen mit reduzierter Zeitstempelbreite von 32 Bit (~ 4,29 sek.). Somit können Schaltaufträge bis 4,29 Sekunden in der Zukunft vorgegeben werden – Eingangs-Events sind innerhalb von 4,2 Sekunden zu verarbeiten, da sonst ein Überlauf eintritt und der tatsächlich erfasste Zeitpunkt nicht mehr gesichert ist. Es wird im Rahmen dieser Dokumentation auch ein Funktionsblock (FB) bereitgestellt, der in der PLC das Auffüllen von 32-Bit-Eingangszeitstempeln auf die aktuell gültigen 64 Bit durchführt.
MTSF
Multi-TimeStamp-Faktor, derzeit 1..10, höhere auf Anfrage
In der Konfiguration kann jeder Kanal auf eine feste, maximal je EtherCAT-Zyklus übertragbare Anzahl von Events konfiguriert werden. D.h., je Zyklus können maximal genauso viele Events (Schaltaufträge bei Ausgängen oder Events bei Eingangsklemmen) mit der Steuerung/PLC ausgetauscht werden. Diese Prozessdaten sind als Platzhalter zu verstehen, die nicht alle jederzeit zu füllen sind. Das bedeutet für
▪
Eingänge:
Der Kanal legt so viele Eingangsevents in die Prozessdaten zur Steuerung wie im letzten Zyklus am Eingang ankamen ODER noch im Buffer liegen.
▪
Ausgänge:
Es werden die von der Steuerung vorgegebenen Events in den Kanalbuffer transferiert, dieser wird dann als FIFO abgearbeitet.
Makrozyklus
Die Klemme benötigt eine gewisse Zeit für die interne zyklische Abarbeitung der Abläufe. Je nach Anzahl der aktiven Kanäle und konfigurierten MTSF ergibt sich für die Klemme eine interne Verarbeitungszeit im Bereich von einigen 100 µs, siehe folgende Tabelle.
Diese je nach Konfiguration tatsächlich resultierende Makrozykluszeit kann aus dem CoE 0xF900:08 online ausgelesen werden.
Mikrozyklus 0xF900:09 & Makrozyklus 0xF900:08 im CoE
Diese Zeit ist als absolute Untergrenze für die EtherCAT-Kommunikation zu betrachten. Die auf diese Klemme angewendete EtherCAT-Task-Zykluszeit sollte je nach Performance des Systems durchaus 10..20 % höher gewählt werden. Die in der folgenden Tabelle angegebenen Makrozykluszeiten sind empirisch ermittelt und als Richtwerte zu verstehen. Die tatsächlich an der Anlage auftretende Makrozykluszeit sollte bei der Inbetriebnahme im o.a. CoE-Objekt kontrolliert werden.
EL1258 Makrozyklus [µs, typisch] | MTSF 1 | MTSF 2 | MTSF 5 | MTSF 10
1 Kanal | 130 | 140 | 160 | 170
2 Kanäle | 130 | 140 | 160 | 170
4 Kanäle | 130 | 140 | 170 | 200
8 Kanäle | 130 | 160 | 190 | 290
EL1259 Makrozyklus [µs, typisch] | MTSF 1 | MTSF 2 | MTSF 5 | MTSF 10
1 In / 1 Out Kanal | 160 | 160 | 170 | 180
2 In / 2 Out Kanäle | 170 | 190 | 210 | 270
4 In / 4 Out Kanäle | 180 | 230 | 260 | 360
8 In / 8 Out Kanäle | 240 | 320 | 360 | 540
EL2258 Makrozyklus [µs, typisch] | MTSF 1 | MTSF 2 | MTSF 5 | MTSF 10
1 Kanal | 90 | 90 | 100 | 120
2 Kanäle | 90 | 90 | 100 | 120
4 Kanäle | 140 | 150 | 180 | 230
8 Kanäle | 150 | 170 | 210 | 290
Zeitangaben für andere Konfigurationen sind am besten über xF900:08 zu ermitteln.
Mikrozyklus
Der Mikrozyklus ist der interne konstante Takt der Klemme, in dem die Abtastung der Eingänge bzw. die Prüfung der Schaltaufträge für Ausgänge erfolgt. Dieser Wert ist von der Anzahl der aktiven Kanäle, aber nicht vom MTSF-Wert abhängig. Die entsprechenden Werte sind in der folgenden Tabelle zu entnehmen.
Die Distributed-Clock-Uhr in der Klemme wird über EtherCAT auf die übliche Genauigkeit von <<1 µs geregelt. Durch den internen Verarbeitungstakt des Mikrozyklus ergibt sich aber die u.a. Vergröberung der tatsächlich mit den Multi-Timestamp-Klemmen realisierbaren Zeitauflösung.
Die je nach Konfiguration tatsächlich resultierende Mikrozykluszeit kann aus dem CoE 0xF900:09 online ausgelesen werden.
Mirkrozyklus 0xF900:09 & Makrozyklus 0xF900:08 im CoE
Für den zeitlichen Ablauf gilt:
▪
Für Eingänge: eine Schaltflanke, die zu einem beliebigen Zeitpunkt von außen an einem Eingangskanal ankommt, wird zum nächsten Mikrozyklus erfasst und in den Buffer gelegt, die Zeit-Ungenauigkeit für die Erfassung beträgt also ca. -x/+0 µs (mit x=Mikrozykluszeit).
▪
Für Ausgänge: ein Schaltauftrag wird in einem Mikrozyklus zur Ausführung gebracht, wenn er in diesem Mikrozyklus erstmalig "nach" der Ausführungszeit liegt. Dann wird er umgehend aus dem Buffer gelöscht.
EL1258 | Mikrozykluszeit [µs, typisch]
1 Kanal | 7
2 Kanäle | 10
4 Kanäle | 14
8 Kanäle | 23
EL1259 | Mikrozykluszeit [µs, typisch]
1 Kanal | 10
2 Kanäle | 14
4 Kanäle | 22
8 Kanäle | 39
EL2258 | Mikrozykluszeit [µs, typisch]
1 Kanal | 7
2 Kanäle | 9
4 Kanäle | 13
8 Kanäle | 21
Zeitangaben für andere Konfigurationen sind am besten über 0xF900:09 zu ermitteln.


Kompatibilitätsmodus zu EL1252/EL2252

Inbetriebnahme [image] Grundlagen zur Funktion [image] Kompatibilitätsmodus zu EL1252/EL2252
Kompatibilitätsmodus zu EL1252/EL2252
Über die Predefined PDO-Auswahl können die Multi-Timestamp-Klemmen auf ein weitgehend identisches und damit kompatibles Prozessabbild zu den EL1252/EL2252 eingestellt werden. Somit können Softwareschnittstellen, die für diese Timestamp-Klemmen erstellt wurden, auch bei den Multi-Timestamp-Klemmen wiederverwendet werden. Dazu werden in der EL1258/EL2258 die Settings "Compatible X-Ch." ausgewählt. Das Verhalten ist dann wie bei den EL1252/EL2252 Klemmen.
Predefined PDO-Auswahl
Es sind alle Kanäle der Klemme in der gleichen Art zu betreiben: entweder mit den Multi-Time-Stamp-Prozessdaten oder mit den EL1252/EL2252-kompatiblen Prozessdaten!
Option der Einstellung von Kompatibilitätsmodi zur EL1252/EL2252
Im kompatiblen Modus arbeiten die Klemmen mit folgenden Zeiteigenschaften:
EL1258 | Makrozykluszeit [µs, typisch] | Mikrozykluszeit [µs, typisch]
1 Ch. | 50 | 7
2 Ch. | 70 | 9
4 Ch. | 90 | 13
8 Ch. | 120 | 21
EL1259 | Makrozykluszeit [µs, typisch] | Mikrozykluszeit [µs, typisch]
1 Ch. In + 1 Ch. Out | 90 | 8
2 Ch. In + 2 Ch. Out | 160 | 11
4 Ch. In + 4 Ch. Out | 180 | 18
8 Ch. In + 8 Ch. Out | 200 | 30
EL2258 | Makrozykluszeit [µs, typisch] | Mikrozykluszeit [µs, typisch]
1 Ch. | 70 | 7
2 Ch. | 90 | 8
4 Ch. | 110 | 10
8 Ch. | 120 | 15
Die Mikrozykluszeit definiert die realisierbare Zeitauflösung der Eingangserfassung/Ausgangsausgabe.
Definition der PDO
Die Prozessdaten für Ein- und Ausgänge können als vordefinierte Zusammenstellung "predefined PDO" oder frei kombiniert werden:
▪
Auswahl über "Predefined PDO"
Einstellung des Multi-Timestamping über „Predefined PDO“
Hier werden einige Kombinationen an Kanalzahl und MTSF bereits vorkonfiguriert angeboten. Es wird empfohlen, die Prozessdatenzusammenstellungen daraus auszuwählen.
▪
Freie Zusammenstellung
Es können auch die Anzahl der benutzten Kanäle und MTSF je Kanal in freier Zusammenstellung über das PDO-Assignment eingestellt werden. Die zyklisch zu übertragenden Prozessdatenobjekte (PDO) werden dazu aus der Inputs/Outputs-Liste im Systemmanager aktiviert.
Freie Auswahl der PDO
Die Bedeutung der einzelnen PDOs ist der CoE-Übersicht zu entnehmen. Dabei ist zu beachten:
▪
„Multi-TimeStamp-PDO“ und „kompatible PDO“ können nicht kombiniert werden
▪
Zu jedem aktiven Eingangs-/Ausgangskanal muss das entsprechende Control/Status aktiv sein
▪
Der MTSF kann für jeden Kanal frei von 1 bis 10 eingestellt werden
▪
Je Kanal darf nur 1 Multi-Timestamp-Faktor aktiv sein. Es ist daher z.B. nicht zulässig, gleichzeitig PDO "MTO Outputs 5x Channel 1" und PDO "MTO Outputs 2x Channel 1" zu aktivieren.
Wenn eine irreguläre PDO-Kombination gewählt wird, kann es zum Zustand ERR_PREOP „invalid output mapping“ oder „invalid input mapping“ kommen.
Event-Logger Meldung des System-Manager bei nicht zulässiger PDO-Kombination


Inbetriebnahme Eingänge

Inbetriebnahme [image] Inbetriebnahme Eingänge
Inbetriebnahme Eingänge
Inhaltsverzeichnis
• Grundlagen
• Inbetriebnahme eines MTI-Kanals
- 1. Synchroner oder asynchroner Betrieb?
- 2. Einstellung Multi-Timestamping-Faktor (MTSF)
- 3. Wann ist der Filter im CoE zu aktivieren? (default: deaktiviert)
- 4. Wie kann ich den Eingangskanal testen?
- 5. Verarbeitung der Events in der PLC
• Inbetriebnahme im Kompatibilitätsmodus
Im Folgenden wird die Inbetriebnahme, von einer digitalen Eingangsklemme mit Multi-Timestamp-Funktion, an einer PLC beschrieben.
Weiterführende Informationen
•
Grundlagen
•
Inbetriebnahme eines MTI-Kanals
•
Inbetriebnahme im Kompatibilitätsmodus


Grundlagen

Inbetriebnahme [image] Inbetriebnahme Eingänge [image] Grundlagen
Grundlagen
Jeder MTI-Kanal (Multi-Timestamp-Input) hat Inputs und Outputs im zyklischen Prozessabbild, die mit der PLC/Task zu verlinken sind.
Eingänge und Ausgänge im Projektbaum
Die Darstellung im Systemmanager ist abhängig von der Anzahl konfigurierter Kanäle und dem jeweiligen Multi-Timestamp-Faktor (MTSF).
MTI Inputs liefern die Informationen über die Events:
- Status
▪
NoOfInputEvents: Anzahl der in diesem Prozessdatenzyklus gelieferten Events mit Zeitstempel.
▪
InputState: aktueller Zustand des Eingangs 0/1 beim Abholen der Prozessdaten über EtherCAT. Dies entspricht dem klassischen Bool-Eingang und kann ebenso verwendet werden
▪
InputBufferOverflow = TRUE: zeigt an, dass mehr Events am Eingang angekommen sind als im Buffer gespeichert werden konnten. Im CoE 0x80n0:13 kann für diesen Fall eingestellt werden, ob weiterhin am Eingang ankommende neue Events
- nicht mehr in den Buffer aufgenommen werden (Default)
- oder aufgenommen werden und dafür ältere Events gelöscht werden
▪
InputCycleCounter: Der 2-Bit Zähler dient zur Input-Prozessdatenüberwachung. Dieser wird mit jedem Prozessdatenaustausch der Klemme um eins erhöht und läuft nach seinem Maximalwert von drei auf Null über.
▪
EventsInInputBuffer: Anzahl der im Buffer verbliebenen gespeicherten Events, nachdem die für den aktuellen Zyklus übertragenen Events entnommen wurden
▪
InputOrderFeedback: Spiegelt den InputOrderCounter, dadurch kann erkannt werden, ob der InputOrderCounter von der Klemme empfangen und verarbeitet wurde.
- InputBit-Array: bitweise Eingangszustände als Array zu den korrespondierenden Zeitstempel
Bit 0: Eingangswert nach Zeitstempel 1
Bit 1: Eingangswert nach Zeitstempel 2
usw.
- InputEventTime x: Liste der 32-Bit-Zeitstempel der jeweiligen Signalflanke
MTI Outputs dienen zur Kontrolle:
- Ctrl
▪
InputBufferReset TRUE: der Kanal-Buffer wird gelöscht. Dies kann sinnvoll sein z. B. bei einem gemeldeten InputBufferOverflow, wenn die Applikation dies erfordert. Über die CoE-Einstellung 0x80n0:13 BufferOverflowBehaviour kann das Verhalten beim Überlauf vorgegeben werden.
▪
InputOrderCounter: dieser Zähler wird nur für den asynchronen Betrieb benötigt. Erst wenn der Zähler von der Steuerung inkrementiert wird, gibt der Kanal einen neuen Satz Events an den Feldbus aus.
Zur Betriebsartenwahl verfügt jeder Kanal im CoE ab 0x8000 über entsprechende Einstellungen:
Betriebsartenwahl im CoE ab 0x80n0
0x80n0:0 MTI Settings Ch. n=0...7 | Name | Eintrag | Beschreibung
0x80n0:01 | Enable digital filter |  | Aktivierung des Filters um Spikes auszublenden, Filterlänge ist in 0x80n0:14 DigitalFilterCount einzugeben.
 | 0x80n0:01 FALSE |  | Filter ist deaktiviert
 | 0x80n0:01 TRUE |  | Aktivierung des Eingangsfilters
0x80n0:11 | Buffer reset behaviour |  | Resetverhalten bei einem Resetsignal im Statusregister (PDO)
 | 0x80n0:11 FALSE | reset on rising edge | Reset wird bei steigender Flanke durchgeführt, direkt danach können neue Daten gebuffert werden
 | 0x80n0:11 TRUE | reset on high level | Buffer wird solange im Reset gehalten, wie das Signal ansteht. Anwendung beispielsweise bei Muting
0x80n0:12 | Buffer mode |  | Einstellung asynchroner oder synchroner Betrieb
 | 0x80n0:12 FALSE | Asynchronous (Buffered) | Asynchroner Betrieb. Um die Buffereinträge in die PDO zu laden, muss von der PLC der InputOrderCounter inkrementiert werden. Dieser Handshake benötigt einen Zyklus für die Bearbeitung, jedoch sind die Daten auch bei Telegrammstörungen noch vorhanden.
 | 0x80n0:12 TRUE | Synchronous | Synchroner Betrieb. Die ersten Buffereinträge werden zyklisch an die PDO weitergereicht, sobald die Daten zur Verfügung stehen.
0x80n0:13 | Buffer overflow behaviour |  | Konfiguration des Verhaltens bei mehr als 32 zu speichernden Events pro Kanal
 | 0x80n0:13 FALSE | Lock buffer | das Überschreiben der Daten wird gesperrt, neue Events gehen verloren
 | 0x80n0:13 TRUE | Overwrite oldest event | Überschreiben der ältesten Daten, neue Events bleiben erhalten
0x80n0:14 | Digital filter count |  | Anzahl der Mikrozyklen, bis ein anliegender Eingangspegel als gültig gewertet wird. Hierdurch werden Spikes ausgefiltert. Eine 1 kommt einem Deaktivieren des Filters gleich.


Inbetriebnahme eines MTI-Kanals

Inbetriebnahme [image] Inbetriebnahme Eingänge [image] Inbetriebnahme eines MTI-Kanals
Inbetriebnahme eines MTI-Kanals
1. Synchroner oder asynchroner Betrieb?
▪
Synchron (default): Sollen die Events schnellstmöglich vom Kanal an die Steuerung geliefert werden, so ist der synchrone Betrieb zu wählen.
- In jedem EtherCAT-Zyklus werden so viel Events wie möglich in den Buffer geladen. Die Anzahl der Events pro Kanal kann über EventsInInputBuffer ausgelesen werden. Die maximale Anzahl der speicherbaren Events beträgt 32.
- Über den MTSF wird bestimmt, wie viele Events pro Zyklus aus dem Buffer in die Prozessdaten gelegt werden. Der Faktor ist zurzeit auf max. 10 begrenzt.
- Überschreitet die Anzahl der aufkommenden Events kontinuierlich den MTSF-Wert, so kann der Buffer vollaufen. Über die CoE 0x80n0:13 kann das Verhalten beim Buffer Überlauf pro Kanal konfiguriert werden.
▪
Asynchron: Ist hohe Datensicherheit gefordert, ist der asynchrone Handshake-Betrieb zu wählen.
Anwendung aus der PLC:
- Kanal meldet mit NoOfInputEvents > 0 das Daten vorliegen
- Die SPS kann die Daten (Input event states und Timestamps) übernehmen
- Der Zähler InputOrderCounter ist zu inkrementieren (+ 1)
- Im nächsten Zyklus sollte der InputOrderFeedback den Wert des InputOrderCounters übernommen haben
- Falls weitere Events im Buffer vorliegen sollten, werden diese in das Prozessabbild eingeblendet.
- Beginnend von vorn...
Einstellung im CoE x80n0:12 Asynchroner Betrieb
2. Einstellung Multi-Timestamping-Faktor (MTSF)
Für die richtige Wahl des MTSF ist zu überschlagen, wie schnell die Pegelwechsel, so genannte Events am Eingang erwartet werden. Danach ist der Multi-Timestamping-Faktor (MTSF) zu wählen. Der Faktor gibt an wie viele Events pro Zyklus aus dem Buffer in die Steuerung geleert werden. Bei asynchroner Übertragung ist zu beachten, dass durch den Handshake nur halb so viele Events je Zeit abgeholt werden.
Damit nicht unnötig viele Prozessdaten übertragen werden, gelten für die Konfiguration folgende Empfehlungen:
Synchrone Übertragung: MTSF ≥ (erwartete maximale Anzahl an Eingangs-Events je EtherCAT-Zyklus) + 1
Asynchrone Übertragung MTSF ≥ 2x (erwartete maximale Anzahl an Eingangs-Events je EtherCAT-Zyklus) + 1
Beispiel: Es werden bei einer Zykluszeit von 1 ms, max. 4 Events/ms pro Kanal erwartet. Es sollen alle 8 Kanäle der EL1258 genutzt werden.
- Synchrone Übertragung: MTSF ≥ 5
Über die Predefined PDO ist der "Multi-Timestamping 8 Ch. 5x" zu wählen. Falls dann in einem Zyklus etwas mehr Events anfallen, werden diese im Kanal-Buffer zwischengespeichert, der Buffer kann dann in den darauf folgenden Zyklen durch die Steuerung geleert werden.
Prozessdatenauswahl (Predefined PDO) für Synchrone Übertragung
- Asynchrone Übertragung: MTSF ≥ 9
Über die Predefined PDO ist der "Multi-Timespamping 8 Ch. 10x" zu wählen.
Prozessdatenauswahl (Predefined PDO) für Asynchrone Übertragung
Beispielsweise stellen sich die Prozessdaten eines Eingangskanals für MTSF = 1x, 5x und 10x wie folgt dar:
Verschiedene MTSF
Für jedes Event steht ein Bit im Inputs-Array (rechtsbündig) und ein Zeitstempel zur Verfügung.
Diese Prozessdaten sind Platzhalter die Events aufnehmen, falls es welche zu übertragen gibt.
Werden weniger Kanäle benötigt, so stehen Predefined PDOs auch für 4, 2 oder 1 Kanal mit je einem MTSF von 1x, 2x, 5x und 10x zur Auswahl.
Kommen weniger Events am Eingang an, als durch den MTSF definiert, werden die restlichen PDOs zur Verdeutlichung auf 0 gesetzt.
Beispiel:NoOfInputEvents = 3 bei MTSF=5 bedeutet dies, dass die ersten 3 PDO Events (Eingangswert + Zeitstempel) geliefert werden, die beiden restlichen 2 PDOs sind auf 0 gesetzt.
3. Wann ist der Filter im CoE zu aktivieren? (default: deaktiviert)
Mit Hilfe des Filters können kurze Signalsprünge, so genannte Spikes, ausgeblendet werden. Sie werden als nicht gültig betrachtet.
Vorgehensweise:
- Der Filter ist über das CoE 0x80n0:01 EnableDigitalFilter zu aktivieren.
- Wenn der Filter aktiviert ist, wird über das Objekt 0x80n0:14 DigitalFilterCounter das Zeitfenster gesetzt, bis das Signal als gültig gewertet wird. Das Zeitfenster ist in Anzahl Mikrozyklen anzugeben. Dabei ist eine „1“ gleichbedeutend mit einem deaktivierten Filter.
- Abschließend ist zu prüfen, ob durch die gewählten Einstellungen die in der Klemme erzielte Zeit des Makrozyklus kleiner als die EtherCAT-Zykluszeit ist.
- Online kann im CoE die aktuelle Mikrozykluszeit eingesehen werden.
Einstellung im CoE x80n0:01 & x80n0:14 für digitalen Filter
Abschließend ist zu prüfen, ob die in der Klemme durch die gewählten Einstellungen erzielte Zeit des Makrozyklus kleiner ist als die EtherCAT-Zykluszeit. Diese sollte in der Regel 20% höher sein als der Makrozyklus. Die aktuelle Makrozykluszeit kann im CoE Verzeichnis 0xF900:08 CycleTime ausgelesen werden.
4. Wie kann ich den Eingangskanal testen?
Soll ein Eingangskanal getestet werden, sind die Events im Systemmanager kaum sichtbar, da sie durch den synchronen Betrieb (default) sofort abgeholt werden und die Prozessdaten immer "genullt" aussehen.
Abhilfe:
- Kanal auf asynchronen Betrieb setzen, dadurch werden die Events im Handshake-Betrieb abgeholt.
oder
- Event-Zeitstempel Nr. 1 in der Online-Anzeige verfolgen:
Zeitstempel über Online-Anzeige
5. Verarbeitung der Events in der PLC
Der Kanal liefert 32-Bit-Zeitstempel. Um diese in das gut zu rechnende 64-Bit-Format hoch zu skalieren kann dieser Funktionsblock verwendet werden:
Download ( )


Inbetriebnahme im Kompatibilitätsmodus

Inbetriebnahme [image] Inbetriebnahme Eingänge [image] Inbetriebnahme im Kompatibilitätsmodus
Inbetriebnahme im Kompatibilitätsmodus
Die Multi-Timestamp-Klemmen können auch im Kompatibilitätsmodus zu den EL1252 betrieben werden. Dafür sind die folgenden Einstellungen vorzunehmen:
Vorgehensweise:
- Die Umstellung ist zweckmäßigerweise und ausschließlich über die Predefined PDO vorzunehmen:
Predefined PDO´s für Kompatibilitätsmodus
- Über das CoE 0x80n0:0 TSI Settings (n=8...F) kann hier, vergleichbar zu der EL1252, die Reaktion für mehrere Events in einem Zyklus festgelegt werden. Es gilt dann der MTSF =1.
0x80n0:0 TSI Settings Ch. n=8...F | Name | Eintrag | Beschreibung
80n0:01 | Pos Sample Mode |  | Definiert das Verhalten für steigende Flanken bei mehreren Signalen pro Zyklus
 | 80n0:01 FALSE | Last edge | Es wird der zuletzt detektierte Event an die PLC weitergereicht
 | 80n0:01 TRUE | First edge | Es wird der zuerst detektierte Event an die PLC weitergereicht
80n0:02 | Neg Sample Mode |  | Definiert das Verhalten für fallende Flanken bei mehreren Signalen pro Zyklus
 | 80n0:02 FALSE | Last edge | Es wird der zuletzt detektierte Event an die PLC weitergereicht
 | 80n0:02 TRUE | First edge | Es wird der zuerst detektierte Event an die PLC weitergereicht
Freie PDO-Auswahl
Eine freie Zusammenstellung der entsprechenden PDO ist für den Kompatibilitätsmodus nicht vorgesehen!


Inbetriebnahme Ausgänge

Inbetriebnahme [image] Inbetriebnahme Ausgänge
Inbetriebnahme Ausgänge
Inhaltsverzeichnis
• Grundlagen
• Inbetriebnahme eines MTO-Kanals
- 1. Wie teste ich meinen Aktor?
- 2. Einstellung Multi-Timestamping-Faktor (MTSF)
- 3. Wie werden die Ausgänge mit Zeitstempel angesteuert?
• Inbetriebnahme im Kompatibilitätsmodus EL2252
Weiterführende Informationen
•
Grundlagen
•
Inbetriebnahme eines MTO-Kanals
•
Inbetriebnahme im Kompatibilitätsmodus EL2252


Grundlagen

Inbetriebnahme [image] Inbetriebnahme Ausgänge [image] Grundlagen
Grundlagen
Jeder MTO-Kanal (Multi-Timestamp-Output) hat Inputs und Outputs im zyklischen Prozessabbild, die mit der PLC/Task zu verlinken sind.
Eingänge und Ausgänge im Projektbaum
zusätzliche PDO ab FW03/Rev 0017
Ab FW03 verfügt das CtrlWord über die Funktion EnableManualOperation. Diese Funktion liegt auf Bitposition 4 des CtrlWord und ist nur wirksam wenn Sie mit TRUE belegt wird, die Bitposition war vorher unbenutzt.
Deshalb können entsprechend der Beckhoff IO Kompatiblitätsregel auch neuere EL1259/EL2258 in der Applikation gesetzt werden, wenn eine Vorgänger Revision (z. B. 0016) in der Konfiguration verwendet wird. Umgekehrt dürfen natürlich keine älteren Klemmen < FW03 in der Applikation eingesetzt werden, wenn diese Funktion genutzt werden soll.

Generell sollten Variablen/Bits die als Platzhalter/reserved fungieren und noch keine Funktion tragen applikationsseitig nicht mit Werten ungleich dem Default-Wert beschrieben werden. Somit können die Platzhalter wie in diesem Fall geschehen später noch mit Funktion belegt werden.
MTO Inputs liefert für jeden Kanal Diagnosedaten in Echtzeit zurück:
- Status
▪
OutputShortCircuit: Es liegt ein Kurzschluss am Kanal an.
▪
OutputBufferOverflow = TRUE: zeigt an, dass mehr Events am Ausgang übergeben werden sollten als im Buffer gespeichert werden können. Im CoE 0x80n1:12 kann für diesen Fall eingestellt werden, ob am Ausgang neue Events
- nicht mehr in den Buffer aufgenommen werden (Default)
- oder aufgenommen werden und dafür ältere Events gelöscht werden
▪
OutputState: Zustand des Ausgangs 0/1 zur Übergabe an die Prozessdaten über EtherCAT. Dies entspricht dem klassischen Bool-Ausgang und kann ebenso verwendet werden.
▪
InputCycleCounter: Der 2-Bit Zähler dient zur Input-Prozessdatenüberwachung. Dieser wird mit jedem Prozessdatenaustausch der Klemme um eins erhöht und läuft nach seinem Maximalwert von drei auf Null über.
▪
EventsInInputBuffer: Anzahl der im Buffer verbliebenen gespeicherten Events, nachdem die für den aktuellen Zyklus übertragenen Events entnommen wurden.
▪
OutputOrderFeedback: Spiegelt den OutputOrderCounter, dadurch kann erkannt werden, ob der OutputOrderCounter von der Klemme empfangen und verarbeitet wurde.
MTO Outputs übergibt in jedem Zyklus dem Kanal die auszugebenden Events mit Schaltzustand 0/1 und Schaltzeit (Zeitstempel)
- Ctrl
▪
OutputBufferReset =TRUE: der Kanal-Buffer wird gelöscht. Dies kann z.B. bei einem gemeldeten OutputBufferOverflow sinnvoll sein, wenn die Applikation dies erfordert.
▪
ManualOutputState und EnableManualOperation: Über dieses Bit kann der Ausgang des Kanals manuell geschaltet werden.
Dazu kann zwischen zwei Betriebsarten unterschieden werden
1.
Im CoE kann das Objekt 0x80n1:02 EnableManualOperation auf TRUE gesetzt werden. Dadurch wird der Timestamp-Betrieb für diesen Kanal deaktiviert. Der Kanal kann nur noch durch das Bit "Manual output state" geschaltet werden.
2.
Im Prozessabbild wird das Bit "Enable manual operation" gesetzt. Der Ausgang nimmt damit den Zustand an, der über das Bit "Manual output state" vorgegeben wurde. Im Gegensatz zu zur obigen Betriebsart läuft die Abarbeitung der Timestamps im Hintergrund weiter. Sobald das Bit "Enable manual operation" wieder auf false gesetzt wird, wechselt der Ausgang auf den Status, der ihm durch die Abarbeitung der Timestamps vorgegeben wurde.
▪
ForceOrder: Im Defaultzustand (=FALSE) werden lediglich Events die in der Zukunft liegen bearbeitet. Sollte ein Event in der Vergangenheit liegen, so kann über das Setzen dieses PDOs (=TRUE) bestimmt werden, dass das Event trotzdem ausgeführt wird. Dieses PDO erhält erst an Bedeutung, wenn im CoE das Objekt 0x80n1:03 EnableTimeCheck aktiviert wird.
▪
OutputOrderCounter: Erst wenn der Zähler von der Steuerung inkrementiert wird, werden neue Schaltaufträge in das Prozessabbild eingetragen.
▪
NoOfOutputEvents: Anzahl der auszugebenden Events in diesem Prozessdatenzyklus
- Output Bit Array: bitweise Ausgangszustände als Array zu den korrespondierenden Zeitstempel
Bit 0: Ausgangswert Zeitstempel 1
Bit 1: Ausgangswert Zeitstempel 2
usw.
- Output event time x: Liste der 32 Bit Zeitstempel der jeweiligen Signalflanke.
Zur Betriebsartenwahl hat jeder Kanal im CoE ab 0x80n1 entsprechende Einstellungen:
Betriebsartenwahl im CoE ab 0x80n1
0x80n1:0 MTO Settings Ch. n=0...7 | Name | Eintrag | Beschreibung
80n1:01 | Use as +24 V power supply |  | Schaltet den gewählten Ausgang im OP-Mode als 24 V Spannungsversorgung
 | 0x80n1:01 FALSE |  | Eingang als Spannungsversorgung deaktiviert
 | 0x80n1:01 TRUE |  | Eingang als Spannungsversorgung aktiviert
80n1:02 | Enable manual operation |  | Manuelles Setzen der Eingänge (ohne Zeitstempel) wird ermöglicht. Dies kann zu Testzwecken von Aktoren oder manuellen Verfahren genutzt werden.
 | 0x80n1:02 FALSE |  | Manuelles Setzen der Eingänge geblockt
 | 0x80n1:02 TRUE |  | Manuelles Setzen der Eingänge möglich
80n1:03 | Enable time check | Siehe Abbildung EnableTimeCheck Mode 1-3 | Output-Events müssen chronologisch übergeben werden. Wird ein Event mit "veraltetem" Timestamp an ein Kanal übergeben, so wird wie folgt entschieden: Mode1: Enable time check = 0, Force order = ohne Bedeutung: Es werden keine "veralteten" Events übergeben, es wird gewartet ggf. inklusive Überlauf (4,29 s), dann wird der Schaltauftrag ausgeführt. Wenn EnableTimeCheck aktiviert wird, wird die Zeitstempelbreite von 4,29 Sekunden in: 2,15 Sekunden Vergangenheit & 2,15 Sekunden Zukunft aufgeteilt. Somit dürfen hier die Schaltaufträge nur bis zu 2.15 Sek. in der Zukunft liegen. Über das Bit ForceOrder, welches als PDO im Statusregister für jeden Kanal zur Verfügung steht, wird entschieden, wie mit dem "veraltetem" Zeitstempel umgegangen werden soll. Mode2: Enable time check = 1, Force order = 0: "veraltetes" Event wird verworfen Mode3:Enable time check = 1, Force order = 1: "veraltetes" Event wird sofort ausgegeben, quasi verspätet.
 | 0x80n1:03 FALSE
 | 0x80n1:03 TRUE
80n1:11 | Buffer reset behaviour |  | Resetverhalten bei einem Resetsignal im Statusregister (PDO)
 | 0x80n1:11 Entry FALSE | Reset on rising edge | Reset wird bei steigender Flanke durchgeführt, direkt danach können neue Daten gebuffert werden
 | 0x80n1:11 Entry TRUE | Reset on high level | Buffer wird solange im Reset gehalten, wie das Signal ansteht. Bei hohen Zykluszeiten können dadurch Daten verloren gehen.
80n1:12 | Buffer overflow behaviour |  | Konfiguration des Verhaltens bei mehr als 32 zu speichernden Events pro Kanal
 | 0x80n1:12 Entry FALSE | Lock buffer | Das Überschreiben der Daten wird gesperrt, neue Events gehen verloren
 | 0x80n1:12 Entry TRUE | Overwrite oldest event | Überschreiben der ältesten Daten, neue Events bleiben erhalten
EnableTimeCeck Mode 1-3


Inbetriebnahme eines MTO-Kanals

Inbetriebnahme [image] Inbetriebnahme Ausgänge [image] Inbetriebnahme eines MTO-Kanals
Inbetriebnahme eines MTO-Kanals
1. Wie teste ich meinen Aktor?
Wie teste ich meinen Aktor Die Ausgänge sind über die regulären Prozessdaten nicht ohne Zeitvorgabe ansteuerbar. Um nun einen angeschlossenen Aktor ohne Zeitvorgabe zu testen, ist wie folgt vorzugehen:
- Im CoE-Verzeichnis 0x80n1:02 EnableManualOperation für den entsprechenden Kanal das Bit setzen.
- Befindet sich die Klemme im OP-State, so kann das PDO ManualOutputState im MTO Outputs Ctrl gesetzt werden
Manuelle Ansteuerung
Weiterhin kann der Ausgang auf +24 V Spannungsversorgung dauergeschaltet werden. Befindet sich die Klemme im OP-State, so kann durch das Setzen des Bits im CoE 0x80n1:01 UseAs+24VPowerSupply der Ausgang aktiviert werden.
Ausgang auf +24 V Dauerschaltung
2. Einstellung Multi-Timestamping-Faktor (MTSF)
Für die richtige Wahl des MTSF ist zu überschlagen, wie viele Schaltaufträge je Zyklus ausgegeben werden sollen. Danach ist der Multi-Timestamping Faktor (MTSF) zu wählen. Der Faktor gibt an wie viele Events maximal pro EtherCAT-Zyklus in den Buffer geladen werden können.
Damit nicht unnötig viele Prozessdaten übertragen werden, gilt für die Konfiguration folgende Empfehlung:
MTSF ≥ erwartete maximale Anzahl an Schaltaufträgen je EtherCAT-Zyklus
Beispiel: Es werden bei einer Zykluszeit von 1 ms, max. 5 Schaltaufträge/ms pro Kanal erwartet. Es sollen alle 8 Kanäle der EL2258 genutzt werden.
- MTSF = 5
- Über die Predefined PDO ist der "Multi-Timestamping 8 Ch. 5x" zu wählen.
Prozessdatenauswahl (Predefined PDO) für Synchrone Übertragung
Für jeden Schaltauftrag steht ein Output-Bit im Output-Array (rechtsbündig) und ein Zeitstempel zur Verfügung.
Diese Prozessdaten sind Platzhalter für die Schaltaufträge von der PLC an den Kanal.
Werden weniger Kanäle benötigt, so stehen Predefined PDOs auch für 4, 2 oder 1 Kanal mit je einem MTSF von 1x, 2x, 5x und 10x zur Auswahl.
3. Wie werden die Ausgänge mit Zeitstempel angesteuert?
Ablauf je Zyklus:
- alle in der PLC berechneten Schaltaufträge (Ausgangszustand+Timestamp[32 Bit]) in die PDO legen
- NoOfOutputEvents = x setzen (z.B. x=5 wenn 5 gültige Schaltaufträge verschickt werden, x muss <= MTSF sein)
- OutputOrderCounter inkrementieren (+ 1). Das ist für den Kanal der obligatorische Hinweis, dass er Schaltauträge zu übernehmen hat.
Der Kanal sendet OutputOrderFeedback = OutputOrderCounter zurück, wenn er die Schaltaufträge übernommen hat. Dies ist schon im nächsten EtherCAT-Zyklus der Fall, solange die Makroszykluszeit nicht verletzt wurde. Es sind also 2 Anwendungsarten möglich:
- die PLC wartet immer wie bei einem Handshake, ob der Kanal im nächsten Zyklus mit OutputOrderFeedback = OutputOrderCounter geantwortet hat und sendet erst dann den nächsten Satz Schaltaufträge. Dies reduziert die je Sekunde ausführbaren Schaltaufträge um 50%.
- die PLC wartet nicht, sondern sendet fortlaufend in jedem Zyklus neue Schaltaufträge zum Kanal. Trotzdem ist es empfehlenswert, OutputOrderFeedback = OutputOrderCounter zu prüfen um festzustellen, ob ggf. ein Satz Schaltaufträge nicht schon im nächsten Zyklus angenommen wurde.
Wenn in einem Zyklus keine neuen Schaltaufträge zum Kanal geschickt werden sollen, ist OutputOrderCounter einfach unverändert zu lassen.
Es ist empfehlenswert, in der PLC immer mit (vorzeichenbehafteten) 64-Bit Zeiten zu arbeiten. Die untere Hälfte dieser Zeitvariablen kann dann einfach auf die Kanal-PDO gemappt werden. Es ist dann aber zu beachten, dass so in der PLC berechnete Zeitstempel/Schaltaufträge nicht weiter als ~2 Sekunden in der Zukunft liegen dürfen!


Inbetriebnahme im Kompatibilitätsmodus EL2252

Inbetriebnahme [image] Inbetriebnahme Ausgänge [image] Inbetriebnahme im Kompatibilitätsmodus EL2252
Inbetriebnahme im Kompatibilitätsmodus EL2252
Die MultiTimeStamp Klemmen können auch im Kompatibilitätsmodus zu den EL2252 betrieben werden. Dafür sind die folgenden Einstellungen vorzunehmen:
Vorgehensweise:
- Die Umstellung ist zweckmäßigerweise und ausschließlich über die Predefined PDO vorzunehmen:
Predefined PDOs für Kompatibilitätsmodus
- Über das CoE 0x70n0:0 MTO outputs Ch.n (n=8...F) kann hier, vergleichbar zu der EL2252 konfiguriert werden. Die EL2252 bietet zusätzlich einen Tristate PDO, zum hochohmigen Schalten der Kanäle. Dieses PDO steht für die EL2258 nicht zur Verfügung.
0x70n0:0 MTO Output Ch. n=8...F | Name | Eintrag | Beschreibung
70n1:01 | Output |  | Aktiviert Ausgang 0 V/24 V vom Kanal n=1..8
 | 0x70n0:01 FALSE |  | Am Ausgang liegen 0 V an
 | 0x70n0:01 TRUE |  | Am Ausgang liegen 24 V an
70n1:11 | Activate |  | Mit diesem Byte wird durch den Übergang 0 --> 3 ein neuer Startzeitpunkt in der Klemme aktiviert
70n0:41 | Start Time |  | 64 Bit Wert des nächsten gewünschten Schaltereignisses
Freie PDO-Auswahl
Eine freie Zusammenstellung der entsprechenden PDO ist für den Kompatibilitätsmodus nicht vorgesehen!


Distributed Clocks Einstellungen

Inbetriebnahme [image] Distributed Clocks Einstellungen
Distributed Clocks Einstellungen
Ermittlung der aktuellen Distributed-Clocks-Zeit
Wird in einem PLC-Zyklus eine aktuelle Angabe über die Distributed-Clocks-Zeit benötigt, kann diese
1.
über eine Eingangsvariable des EtherCAT Masters verlinkt werden
2.
von der Klemme direkt als 64 Bit SystemTime angezeigt werden
Funktionen für Datentypen mit 64 Bit Breite
Zur Verarbeitung der 64 Bit Zahlen in Beckhoff TwinCAT stehen in der Library TcUtilities.lib eine Auswahl an Funktionen zur Verfügung. Hier sind längere Ausführungszeiten erforderlich als mit 32 Bit Standard-Datentypen.
Ein Datentyp mit 64 Bit Breite ist in TcEthercat.lib als T_DCTIME oder in TcUtilities.lib als T_LARGE_INTEGER definiert.
1. Über den EtherCAT-Master
Der EtherCAT-Master kann eine Kopie der aktuellen Distributed-Clock-Master-Clock anzeigen. Dazu ist im Gerät EtherCAT --> Karteireiter EtherCAT --> Erweiterte Einstellungen --> Distributed Clocks die Einstellung "Show DC System Time (64 bit)" zu aktivieren, (Abb. Aktivierung der Anzeige der Master-Distributed-Clock).
Aktivierung der Anzeige der Master-Distributed-Clock
Dadurch stellt sich das Prozessabbild des EtherCAT Masters nun dar (Abb. Erweitertes Prozessabbild des EtherCAT Masters):
Erweitertes Prozessabbild des EtherCAT Masters
SYSTIME
Der Wert DcSysTime des EtherCAT Masters ist mit Bedacht zu verwenden und soll nur als grobe Orientierung dienen, in welchem Zeitbereich (Größenordnung: 1-2 Task-Zyklen) sich das Distributed-Clocks-System gerade befindet.
Der Grund dafür ist, dass die lokale Uhrzeit in der Klemme bereits einige µs vor dem abholenden Frame in entsprechende Puffer gelesen wird. Danach benötigt der EtherCAT-Strang einige Zeit um das Prozessdatum zum Master zu transportieren. Die Online-Anzeige im TwinCAT System Manager ist wegen des Visualisierungscharakters bestenfalls im 3stelligen Millisekundenbereich genau. Aber auch in einer PLC kann das Prozessdatum SysTime unterschiedlich veraltet sein: je nachdem wann im Programmcode die Auswertung erfolgt, ist das Prozessdatum bereits einige µs/ms älter geworden. Sollen Reaktionen im EtherCAT-Strang (z.B. einer Ausgangsklemme EL2258) auf einer so eingelesenen SysTime basieren, sind 2-3 PLC-Zykluszeiten Puffer zu berücksichtigen.
Deutlich zweckmäßiger ist die Verwendung einer EL2258 mit anderen EtherCAT-Slaves, die einen Zeitstempel aufgrund Umgebungseinflüssen wie z.B. die EL1252 erzeugen.
Alternativ können auch zur NC/PLC-Laufzeit Funktionen aufgerufen werden, die sofort die aktuelle DC-Zeit zurückliefern wie z.B. F_GetCurDcTickTime. Siehe dazu die Hinweise zu den TwinCAT Zeitquellen in der EtherCAT-System-Dokumentation.
2. Klemmeneigene SysTime
Die MultiTimestamp-Klemmen können direkt die klemmenlokale DC-Systemzeit als Prozessdatum anbieten:
Einstellung SysTime
Dazu ist manuell im Systemmanager das "PDO DEV Inputs Device" zu aktivieren:
▪
bei EL1258: 0x1A28
▪
bei EL1259: 0x1A38
▪
bei EL2258: 0x1A10
SysTime
Der Wert DcSysTime der Klemme ist mit Bedacht zu verwenden und soll nur als grobe Orientierung dienen, in welchem Zeitbereich (Größenordnung: +/-1 Task-Zyklus) sich das Distributed-Clocks-System gerade befindet. Der Grund dafür ist, dass die lokale Uhrzeit in der Klemme nur einmalig je Makrozyklus ermittelt wird, wobei der exakte Zeitpunkt nicht festgelegt ist.
Deutlich zweckmäßiger ist die Verwendung einer EL2258 mit anderen EtherCAT-Slaves, die einen Zeitstempel aufgrund Umgebungseinflüssen wie z.B. die EL1252 erzeugen.
Alternativ können auch zur NC/PLC-Laufzeit Funktionen aufgerufen werden, die sofort die aktuelle DC-Zeit zurückliefern wie z.B. F_GetCurDcTickTime. Siehe dazu die Hinweise zu den TwinCAT Zeitquellen in der EtherCAT-System-Dokumentation.
SysTime 32/64 Bit
Die PDO SysTime wird wie folgt befüllt:
- im "CompatibleModus" wird die 64 Bit Variable mit voller 64 Bit Distributed-Clocks-Zeit befüllt
- im "MultiTimeStamp Modus" wird die 64 Bit Variable nur mit den unteren 32 Bit gefüllt, da dies auch die Zeitbreite der Zeitstempel ist.


CoE Objektbeschreibung und Parametrierung

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung
CoE Objektbeschreibung und Parametrierung
Weiterführende Informationen
•
EL1258
•
EL1259
•
EL2258


EL1258

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258
EL1258
Weiterführende Informationen
•
Objektbeschreibung - Spezifische Objekte
•
Objektbeschreibung - Standardobjekte


Objektbeschreibung - Spezifische Objekte

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte
Objektbeschreibung - Spezifische Objekte
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Diagnostikdaten
•
Informationsdaten
•
Kommando-Objekt


Restore-Objekt

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Konfigurationsdaten
Konfigurationsdaten
Index 8pp0 MTI settings (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp0:0 | MTI settings |  |  | UINT8 | RO | 0x14 (20dez)
8pp0:01 | Enable digital filter | Aktivierung des Filters um Spikes auszublenden, Filterlänge ist in 8pp0:14 "DigitalFilterCount" einzugeben (weitere Erläuterung siehe hier). |  | BOOLEAN | RW | 0x00 (0dez)
8pp0:11 | Buffer reset behaviour | Legt das Verhalten des "Input buffer reset" Bits fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Reset on rising edge: Der Buffer wird mit einer steigenden Flanke von "Input buffer reset" gelöscht
 |  | 1 | Reset on high level: Der Buffer wird mit einer steigenden Flanke von "Input buffer reset" gelöscht und nimmt keine neuen Werte auf, bis "Input buffer reset" wieder zurückgesetzt wird.
8pp0:12 | Buffer mode | Legt fest, ob zum Abholen der Werte aus dem Buffer ein Handshakeverfahren genutzt werden soll (Übertragungssicherheit) oder ob neue Werte mit jedem SPS-Zyklus direkt übertragen werden sollen (schneller) Erlaubte Werte (weitere Erläuterung siehe hier): |  | UINT16 | RW | 0x0001 (1dez)
 |  | 0 | Asynchronous (Buffered): Die Entgegennahme neuer Ereignisse muss durch die PLC quittiert werden. Dazu muss im SPS-Programm das Byte "No of input events" überwacht werden. Sollte dies größer als null sein, können die aufgelaufenen Events aus dem Prozessabbild übernommen werden. Im Anschluss muss das Byte "Input order counter" inkrementiert werden. Hierdurch wird der Klemme signalisiert, dass die Events übernommen wurden und in nächsten Zyklus neue Daten angelegt werden können.
 |  | 1 | Synchronous: Neue Ereignisse werden mit jedem SPS-Zyklus automatisch übertragen
8pp0:13 | Buffer overflow behaviour | Legt das Verhalten beim Überlauf des Puffers fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Lock buffer: Neue Ereignisse werden verworfen
 |  | 1 | Overwrite oldest event: Neue Ereignisse überschreiben die letzten Events im Puffer
8pp0:14 | Digital filter count | Legt fest, wie vielen Abtastungen ein Event anliegen muss, damit es wirklich in den Puffer übernommen wird (weitere Erläuterung siehe hier). |  | UINT16 | RW | 0x0001 (1dez)
Index 8ppF MTI Vendor data (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | MTI Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Eingangszeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Eingangszeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
Index 8pp0 TSI Settings (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp0:0 | TSI Settings |  |  | UINT8 | RO | 0x02 (2dez)
8pp0:01 | Pos Sample Mode | Pro SPS-Zyklus darf nur eine steigende Flanke am Eingang der Klemme erkannt werden. Sollten mehrere Flanken pro Zyklus eintreffen, kann mit diesem Bit entschieden werden, welche Flanke in dem Prozessabbild angezeigt werden soll. Erlaubte Werte: |  | BIT1 | RW | 0x00 (0dez)
 |  | 0 | Last edge: Es wird die letzte Flanke des vorhergehenden SPS-Zyklusses angezeigt
 |  | 1 | First edge: Es wird die erste Flanke des vorhergehenden SPS-Zyklusses angezeigt
8pp0:02 | Neg Sample Mode | Pro SPS-Zyklus darf nur eine fallende Flanke am Eingang der Klemme erkannt werden. Sollten mehrere Flanken pro Zyklus eintreffen, kann mit diesem Bit entschieden werden, welche Flanke in dem Prozessabbild angezeigt werden soll. Erlaubte Werte: |  | BIT1 | RW | 0x00 (0dez)
 |  | 0 | Last edge: Es wird die letzte Flanke des vorhergehenden SPS-Zyklusses angezeigt
 |  | 1 | First edge: Es wird die erste Flanke des vorhergehenden SPS-Zyklusses angezeigt
Index 8ppF TSI Vendor data (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | TSI Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Eingangszeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Eingangszeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)


Eingangsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Eingangsdaten
Eingangsdaten
Index 6pp1 MTI inputs (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp1:0 | MTI inputs |  | UINT8 | RO | 0x00 (0dez)
6pp1:01 | No of input events | Meldet die Anzahl der im Prozessabbild verfügbaren neuen Zeitstempel. Wird hier z.B. ein drei zurückgegeben, sind nur die Objekte "Input event State 1...3" und "Input event time 1...3" gültig. | UINT8 | RO | 0x00 (0dez)
6pp1:09 | Input state | Gibt den zum Zeitpunkt des Prozessdatenzyklusses aktuellen Zustand des Inputs an. | BOOLEAN | RO | 0x00 (0dez)
6pp1:0A | Input buffer overflow | Es sind mehr Ereignisse am Eingang aufgetreten als Elemente im Puffer des Kanals frei waren. | BOOLEAN | RO | 0x00 (0dez)
6pp1:0F | Input cycle counter | Wird mit jedem Prozessdatenzyklus inkrementiert und läuft nach seinem Maximalwert von 3 auf 0 über. | BIT2 | RO | 0x00 (0dez)
6pp1:11 | Events in input buffer | Meldet die Anzahl der aktuell im Puffer befindlichen Ereignisse | UINT8 | RO | 0x00 (0dez)
6pp1:12 | Input order feedback | Dieses Byte spiegelt den Zustand des "Input order counter" Bytes (weitere Erläuterung siehe hier). | UINT8 | RO | 0x00 (0dez)
6pp1:21 | Input event state 1 | Gibt an ob es sich bei dem Event um eine steigende (1) oder eine fallende (0) Flanke gehandelt hat | BOOLEAN | RO | 0x00 (0dez)
6pp1:22 | Input event state 2 | ... | BOOLEAN | RO | 0x00 (0dez)
6pp1:2A | Input event state 10 | ... | BOOLEAN | RO | 0x00 (0dez)
6pp1:41 | Input event time 1 | 32 Bit Zeitstempel zum korrespondierenden "Input event state n" | UINT32 | RO | 0x00000000 (0dez)
6pp1:42 | Input event time 2 | ... | UINT32 | RO | 0x00000000 (0dez)
6pp1:4A | Input event time 10 | ... | UINT32 | RO | 0x00000000 (0dez)
Index 6pp0 TSI Inputs (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | TSI Inputs |  | UINT8 | RO | 0x00 (0dez)
6pp0:01 | Input | Aktueller Status des Eingangs | BOOLEAN | RO | 0x00 (0dez)
6pp0:09 | Status | Bit0: Wird für einen Zyklus gesetzt wenn eine steigende Flanke erkannt wurde Bit1: Wird für einen Zyklus gesetzt wenn eine fallende Flanke erkannt wurde | UINT8 | RO | 0x00 (0dez)
6pp0:41 | LatchPos | Zeitstempel der steigenden Flanke | UINT64 | RO |
6pp0:42 | LatchNeg | Zeitstempel der fallenden Flanke | UINT64 | RO |
Index F611 DEV Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F611:0 | DEV Inputs |  | UINT8 | RO | 0x21 (33dez)
F611:02 | Undervoltage Up | Die Nenn-Betriebsspannung an den Powerkontakten wurde erheblich unterschritten | BOOLEAN | RO | 0x00 (0dez)
F611:03 | Overtemperature | Übertemperaturfehler: Die Temperatur der Ein- oder Ausgangsbausteine ist zu hoch. Bei Ausgangsklemmen sollte geprüft werden, ob nicht mindestens ein Kanal einen Kurzschluss treibt. | BOOLEAN | RO | 0x00 (0dez)
F611:04 | Checksum error | Bei der internen Datenübertragung ist ein Fehler aufgetreten | BOOLEAN | RO | 0x00 (0dez)
F611:21 | SysTime | DC-Zeitstempel des letzten Inputmappings. Dieser Zeitstempel sollte nicht als Referenz genutzt werden. (Informationen zu DC-Referenzzeiten). | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Ausgangsdaten
Ausgangsdaten
Index 7pp0 MTI outputs (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7pp0:0 | MTI outputs |  | UINT8 | RO | 0x00 (0dez)
7pp0:01 | Input buffer reset | Entfernt alle im Puffer befindlichen Elemente Das Löschen kann durch eine steigende Flanke oder kontinuierlich durch das Anlegen einer 1 an diesem Bit erzielt werden. Das Verhalten kann über das CoE-Objekt 0x8pp0:11 ("Buffer reset behaviour" parametriert werden. | BOOLEAN | RO | 0x00 (0dez)
7pp0:11 | Input order counter | Über dieses Bit wird der Klemme mitgeteilt, dass die Input-Events aus dem Prozessabbild übernommen wurden und die Klemme im nächsten Zyklus einen neuen Satz Input Events aus dem Buffer in das Prozessabbild kopieren darf (siehe Buffer mode). | UINT8 | RO | 0x00 (0dez)


Diagnostikdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Diagnostikdaten
Diagnostikdaten
Index App0 MTI Diag data (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0 | MTI Diag data |  | UINT8 | RO | 0x02 (2dez)
App0:01 | Overtemperature | Die Klemmeninnentemperatur ist oberhalb des gültigen Bereiches. Bei Klemmen die auch über Ausgangskanäle verfügen, sollte geprüft werden, ob an keinem der Ausgänge ein Kurzschluss anliegt. | BOOLEAN | RO | 0x00 (0dez)
App0:02 | Undervoltage | Die Spannung an den Powerkontakten ist außerhalb des gültigen Bereiches | BOOLEAN | RO | 0x00 (0dez)
Index A001 MTI common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A001:0 | MTI common Diag data |  | UINT8 | RO | 0x11 (17dez)
A001:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)
Index A080 TSI common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A080:0 | TSI common Diag data |  | UINT8 | RO | 0x11 (17dez)
A080:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)


Informationsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Informationsdaten
Informationsdaten
Index F900 DEV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DEV Info data |  | UINT8 | RO | 0x00 (0dez)
F900:08 | Cycle Time | Gibt die kleinstmögliche einzustellende Zykluszeit an [ns]. | UINT32 | RO | 0x00000000 (0dez)
F900:09 | Sample time | Gibt die Abtastzeit der Ein- und Ausgänge an [ns]. | UINT32 | RO | 0x00000000 (0dez)


Kommando-Objekt

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Spezifische Objekte [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Das Command-Objekt wurde für die zukünftige Verwendung implementiert. Aktuell werden keine Kommandos unterstützt.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | Command |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Über das Request-Objekt können Kommandos an die Klemme abgesetzt werden. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status des aktuell ausgeführten Kommandos | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | Optionaler Rückgabewert des Kommandos | OCTET-STRING[6] | RO | {0}


Objektbeschreibung - Standardobjekte

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1258 [image] Objektbeschreibung - Standardobjekte
Objektbeschreibung - Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL1258
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 99
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x04EA3052 (82456658dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 MTI RxPDO-Map Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | MTI RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x04 (4dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7000 (MTI outputs Ch.1), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7000:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7000 (MTI outputs Ch.1), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7000:11, 8
1600:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1601 MTI RxPDO-Map Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | MTI RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x04 (4dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7010 (MTI outputs Ch.2), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7010:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7010 (MTI outputs Ch.2), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7010:11, 8
1601:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1602 MTI RxPDO-Map Outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | MTI RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x04 (4dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7020 (MTI outputs Ch.3), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7020:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7020 (MTI outputs Ch.3), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7020:11, 8
1602:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1603 MTI RxPDO-Map Outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | MTI RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x04 (4dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7030 (MTI outputs Ch.4), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7030:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7030 (MTI outputs Ch.4), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7030:11, 8
1603:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1604 MTI RxPDO-Map Outputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | MTI RxPDO-Map Outputs Ch.5 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x04 (4dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7040 (MTI outputs Ch.5), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7040:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7040 (MTI outputs Ch.5), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7040:11, 8
1604:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1605 MTI RxPDO-Map Outputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | MTI RxPDO-Map Outputs Ch.6 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x04 (4dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7050 (MTI outputs Ch.6), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7050:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7050 (MTI outputs Ch.6), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7050:11, 8
1605:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1606 MTI RxPDO-Map Outputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | MTI RxPDO-Map Outputs Ch.7 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x04 (4dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7060 (MTI outputs Ch.7), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7060:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7060 (MTI outputs Ch.7), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7060:11, 8
1606:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1607 MTI RxPDO-Map Outputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | MTI RxPDO-Map Outputs Ch.8 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x04 (4dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7070 (MTI outputs Ch.8), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7070:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7070 (MTI outputs Ch.8), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7070:11, 8
1607:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1A00 MTI TxPDO-Map Inputs 10x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | MTI TxPDO-Map Inputs 10x Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x1C (28dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A00:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A00:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6001:22, 1
1A00:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6001:23, 1
1A00:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6001:24, 1
1A00:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6001:25, 1
1A00:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6001:26, 1
1A00:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6001:27, 1
1A00:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6001:28, 1
1A00:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6001:29, 1
1A00:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6001:2A, 1
1A00:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A00:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
1A00:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6001:42, 32
1A00:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6001:43, 32
1A00:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6001:44, 32
1A00:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6001:45, 32
1A00:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6001:46, 32
1A00:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6001:47, 32
1A00:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6001:48, 32
1A00:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6001:49, 32
1A00:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6001:4A, 32
Index 1A01 MTI TxPDO-Map Inputs 5x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | MTI TxPDO-Map Inputs 5x Ch.1 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x12 (18dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A01:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A01:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6001:22, 1
1A01:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6001:23, 1
1A01:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6001:24, 1
1A01:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6001:25, 1
1A01:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A01:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
1A01:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6001:42, 32
1A01:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6001:43, 32
1A01:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6001:44, 32
1A01:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6001:45, 32
Index 1A02 MTI TxPDO-Map Inputs 2x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | MTI TxPDO-Map Inputs 2x Ch.1 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x0C (12dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A02:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A02:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6001:22, 1
1A02:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A02:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
1A02:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6001:42, 32
Index 1A03 MTI TxPDO-Map Inputs 1x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | MTI TxPDO-Map Inputs 1x Ch.1 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x0A (10dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6001:01, 8
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6001:09, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6001:0A, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6001:0F, 2
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6001:11, 8
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6001:12, 8
1A03:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6001:21, 1
1A03:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A03:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6001 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6001:41, 32
Index 1A04 MTI TxPDO-Map Inputs 10x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | MTI TxPDO-Map Inputs 10x Ch.2 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x1C (28dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A04:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A04:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6011:22, 1
1A04:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6011:23, 1
1A04:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6011:24, 1
1A04:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6011:25, 1
1A04:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6011:26, 1
1A04:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6011:27, 1
1A04:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6011:28, 1
1A04:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6011:29, 1
1A04:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6011:2A, 1
1A04:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A04:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
1A04:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6011:42, 32
1A04:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6011:43, 32
1A04:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6011:44, 32
1A04:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6011:45, 32
1A04:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6011:46, 32
1A04:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6011:47, 32
1A04:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6011:48, 32
1A04:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6011:49, 32
1A04:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6011:4A, 32
Index 1A05 MTI TxPDO-Map Inputs 5x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | MTI TxPDO-Map Inputs 5x Ch.2 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x12 (18dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A05:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A05:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6011:22, 1
1A05:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6011:23, 1
1A05:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6011:24, 1
1A05:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6011:25, 1
1A05:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A05:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
1A05:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6011:42, 32
1A05:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6011:43, 32
1A05:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6011:44, 32
1A05:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6011:45, 32
Index 1A06 MTI TxPDO-Map Inputs 2x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | MTI TxPDO-Map Inputs 2x Ch.2 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x0C (12dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A06:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A06:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6011:22, 1
1A06:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A06:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
1A06:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6011:42, 32
Index 1A07 MTI TxPDO-Map Inputs 1x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | MTI TxPDO-Map Inputs 1x Ch.2 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x0A (10dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6011:01, 8
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6011:09, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6011:0A, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6011:0F, 2
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6011:11, 8
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6011:12, 8
1A07:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6011:21, 1
1A07:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A07:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6011 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6011:41, 32
Index 1A08 MTI TxPDO-Map Inputs 10x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | MTI TxPDO-Map Inputs 10x Ch.3 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x1C (28dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6021:22, 1
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6021:23, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6021:24, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6021:25, 1
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6021:26, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6021:27, 1
1A08:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6021:28, 1
1A08:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6021:29, 1
1A08:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6021:2A, 1
1A08:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A08:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
1A08:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6021:42, 32
1A08:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6021:43, 32
1A08:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6021:44, 32
1A08:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6021:45, 32
1A08:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6021:46, 32
1A08:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6021:47, 32
1A08:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6021:48, 32
1A08:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6021:49, 32
1A08:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6021:4A, 32
Index 1A09 MTI TxPDO-Map Inputs 5x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | MTI TxPDO-Map Inputs 5x Ch.3 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x12 (18dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A09:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A09:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A09:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A09:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A09:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6021:22, 1
1A09:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6021:23, 1
1A09:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6021:24, 1
1A09:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6021:25, 1
1A09:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A09:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
1A09:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6021:42, 32
1A09:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6021:43, 32
1A09:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6021:44, 32
1A09:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6021:45, 32
Index 1A0A MTI TxPDO-Map Inputs 2x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | MTI TxPDO-Map Inputs 2x Ch.3 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x0C (12dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A0A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6021:22, 1
1A0A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
1A0A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6021:42, 32
Index 1A0B MTI TxPDO-Map Inputs 1x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | MTI TxPDO-Map Inputs 1x Ch.3 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x0A (10dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x6021:01, 8
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x6021:09, 1
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6021:0A, 1
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6021:0F, 2
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6021:11, 8
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6021:12, 8
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6021:21, 1
1A0B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6021 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6021:41, 32
Index 1A0C MTI TxPDO-Map Inputs 10x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | MTI TxPDO-Map Inputs 10x Ch.4 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x1C (28dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6031:22, 1
1A0C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6031:23, 1
1A0C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6031:24, 1
1A0C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6031:25, 1
1A0C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6031:26, 1
1A0C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6031:27, 1
1A0C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6031:28, 1
1A0C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6031:29, 1
1A0C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6031:2A, 1
1A0C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A0C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
1A0C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6031:42, 32
1A0C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6031:43, 32
1A0C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6031:44, 32
1A0C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6031:45, 32
1A0C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6031:46, 32
1A0C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6031:47, 32
1A0C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6031:48, 32
1A0C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6031:49, 32
1A0C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6031:4A, 32
Index 1A0D MTI TxPDO-Map Inputs 5x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | MTI TxPDO-Map Inputs 5x Ch.4 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x12 (18dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6031:22, 1
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6031:23, 1
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6031:24, 1
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6031:25, 1
1A0D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A0D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
1A0D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6031:42, 32
1A0D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6031:43, 32
1A0D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6031:44, 32
1A0D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6031:45, 32
Index 1A0E MTI TxPDO-Map Inputs 2x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0E:0 | MTI TxPDO-Map Inputs 2x Ch.4 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x0C (12dez)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6031:22, 1
1A0E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
1A0E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6031:42, 32
Index 1A0F MTI TxPDO-Map Inputs 1x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0F:0 | MTI TxPDO-Map Inputs 1x Ch.4 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x0A (10dez)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x6031:01, 8
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x6031:09, 1
1A0F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6031:0A, 1
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6031:0F, 2
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6031:11, 8
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6031:12, 8
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6031:21, 1
1A0F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6031 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6031:41, 32
Index 1A10 MTI TxPDO-Map Inputs 10x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | MTI TxPDO-Map Inputs 10x Ch.5 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x1C (28dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6041:22, 1
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6041:23, 1
1A10:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6041:24, 1
1A10:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6041:25, 1
1A10:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6041:26, 1
1A10:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6041:27, 1
1A10:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6041:28, 1
1A10:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6041:29, 1
1A10:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6041:2A, 1
1A10:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A10:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
1A10:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6041:42, 32
1A10:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6041:43, 32
1A10:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6041:44, 32
1A10:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6041:45, 32
1A10:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6041:46, 32
1A10:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6041:47, 32
1A10:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6041:48, 32
1A10:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6041:49, 32
1A10:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6041:4A, 32
Index 1A11 MTI TxPDO-Map Inputs 5x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A11:0 | MTI TxPDO-Map Inputs 5x Ch.5 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x12 (18dez)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A11:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6041:22, 1
1A11:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6041:23, 1
1A11:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6041:24, 1
1A11:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6041:25, 1
1A11:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A11:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
1A11:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6041:42, 32
1A11:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6041:43, 32
1A11:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6041:44, 32
1A11:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6041:45, 32
Index 1A12 MTI TxPDO-Map Inputs 2x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A12:0 | MTI TxPDO-Map Inputs 2x Ch.5 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x0C (12dez)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A12:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6041:22, 1
1A12:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A12:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
1A12:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6041:42, 32
Index 1A13 MTI TxPDO-Map Inputs 1x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A13:0 | MTI TxPDO-Map Inputs 1x Ch.5 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x0A (10dez)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x6041:01, 8
1A13:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x6041:09, 1
1A13:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6041:0A, 1
1A13:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6041:0F, 2
1A13:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6041:11, 8
1A13:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6041:12, 8
1A13:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6041:21, 1
1A13:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A13:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6041 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6041:41, 32
Index 1A14 MTI TxPDO-Map Inputs 10x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A14:0 | MTI TxPDO-Map Inputs 10x Ch.6 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x1C (28dez)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A14:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A14:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A14:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A14:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A14:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A14:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A14:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6051:22, 1
1A14:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6051:23, 1
1A14:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6051:24, 1
1A14:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6051:25, 1
1A14:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6051:26, 1
1A14:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6051:27, 1
1A14:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6051:28, 1
1A14:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6051:29, 1
1A14:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6051:2A, 1
1A14:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A14:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
1A14:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6051:42, 32
1A14:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6051:43, 32
1A14:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6051:44, 32
1A14:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6051:45, 32
1A14:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6051:46, 32
1A14:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6051:47, 32
1A14:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6051:48, 32
1A14:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6051:49, 32
1A14:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6051:4A, 32
Index 1A15 MTI TxPDO-Map Inputs 5x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | MTI TxPDO-Map Inputs 5x Ch.6 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x12 (18dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A15:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A15:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A15:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A15:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A15:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A15:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A15:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A15:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6051:22, 1
1A15:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6051:23, 1
1A15:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6051:24, 1
1A15:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6051:25, 1
1A15:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A15:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
1A15:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6051:42, 32
1A15:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6051:43, 32
1A15:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6051:44, 32
1A15:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6051:45, 32
Index 1A16 MTI TxPDO-Map Inputs 2x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A16:0 | MTI TxPDO-Map Inputs 2x Ch.6 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x0C (12dez)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A16:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A16:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A16:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A16:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A16:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A16:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A16:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A16:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6051:22, 1
1A16:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A16:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
1A16:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6051:42, 32
Index 1A17 MTI TxPDO-Map Inputs 1x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A17:0 | MTI TxPDO-Map Inputs 1x Ch.6 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x0A (10dez)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x6051:01, 8
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x6051:09, 1
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6051:0A, 1
1A17:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A17:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6051:0F, 2
1A17:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6051:11, 8
1A17:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6051:12, 8
1A17:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6051:21, 1
1A17:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A17:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6051 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6051:41, 32
Index 1A18 MTI TxPDO-Map Inputs 10x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A18:0 | MTI TxPDO-Map Inputs 10x Ch.7 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x1C (28dez)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A18:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A18:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A18:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A18:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A18:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6061:22, 1
1A18:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6061:23, 1
1A18:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6061:24, 1
1A18:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6061:25, 1
1A18:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6061:26, 1
1A18:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6061:27, 1
1A18:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6061:28, 1
1A18:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6061:29, 1
1A18:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6061:2A, 1
1A18:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A18:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
1A18:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6061:42, 32
1A18:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6061:43, 32
1A18:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6061:44, 32
1A18:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6061:45, 32
1A18:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6061:46, 32
1A18:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6061:47, 32
1A18:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6061:48, 32
1A18:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6061:49, 32
1A18:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6061:4A, 32
Index 1A19 MTI TxPDO-Map Inputs 5x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A19:0 | MTI TxPDO-Map Inputs 5x Ch.7 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x12 (18dez)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A19:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A19:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A19:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A19:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A19:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6061:22, 1
1A19:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6061:23, 1
1A19:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6061:24, 1
1A19:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6061:25, 1
1A19:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A19:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
1A19:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6061:42, 32
1A19:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6061:43, 32
1A19:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6061:44, 32
1A19:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6061:45, 32
Index 1A1A MTI TxPDO-Map Inputs 2x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1A:0 | MTI TxPDO-Map Inputs 2x Ch.7 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x0C (12dez)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A1A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A1A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A1A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A1A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A1A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A1A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A1A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6061:22, 1
1A1A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
1A1A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6061:42, 32
Index 1A1B MTI TxPDO-Map Inputs 1x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1B:0 | MTI TxPDO-Map Inputs 1x Ch.7 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x0A (10dez)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x6061:01, 8
1A1B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x6061:09, 1
1A1B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6061:0A, 1
1A1B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6061:0F, 2
1A1B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6061:11, 8
1A1B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6061:12, 8
1A1B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6061:21, 1
1A1B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6061 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6061:41, 32
Index 1A1C MTI TxPDO-Map Inputs 10x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1C:0 | MTI TxPDO-Map Inputs 10x Ch.8 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x1C (28dez)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6071:22, 1
1A1C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6071:23, 1
1A1C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6071:24, 1
1A1C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6071:25, 1
1A1C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6071:26, 1
1A1C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6071:27, 1
1A1C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6071:28, 1
1A1C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6071:29, 1
1A1C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6071:2A, 1
1A1C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A1C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
1A1C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6071:42, 32
1A1C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6071:43, 32
1A1C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6071:44, 32
1A1C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6071:45, 32
1A1C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6071:46, 32
1A1C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6071:47, 32
1A1C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6071:48, 32
1A1C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6071:49, 32
1A1C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6071:4A, 32
Index 1A1D MTI TxPDO-Map Inputs 5x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1D:0 | MTI TxPDO-Map Inputs 5x Ch.8 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x12 (18dez)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6071:22, 1
1A1D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6071:23, 1
1A1D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6071:24, 1
1A1D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6071:25, 1
1A1D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A1D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
1A1D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6071:42, 32
1A1D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6071:43, 32
1A1D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6071:44, 32
1A1D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6071:45, 32
Index 1A1E MTI TxPDO-Map Inputs 2x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | MTI TxPDO-Map Inputs 2x Ch.8 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x0C (12dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6071:22, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6071:42, 32
Index 1A1F MTI TxPDO-Map Inputs 1x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1F:0 | MTI TxPDO-Map Inputs 1x Ch.8 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x0A (10dez)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x6071:01, 8
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x6071:09, 1
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6071:0A, 1
1A1F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6071:0F, 2
1A1F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6071:11, 8
1A1F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6071:12, 8
1A1F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6071:21, 1
1A1F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6071 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6071:41, 32
Index 1A20 TSI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A20:0 | TSI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 33 | UINT8 | RO | 0x06 (6dez)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x01 (Input)) | UINT32 | RO | 0x6080:01, 1
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x09 (Status)) | UINT32 | RO | 0x6080:09, 8
1A20:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A20:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6080:41, 64
1A20:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6080 (TSI Inputs Ch.1), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6080:42, 64
Index 1A21 TSI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A21:0 | TSI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 34 | UINT8 | RO | 0x06 (6dez)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x01 (Input)) | UINT32 | RO | 0x6090:01, 1
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x09 (Status)) | UINT32 | RO | 0x6090:09, 8
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A21:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6090:41, 64
1A21:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6090 (TSI Inputs Ch.2), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6090:42, 64
Index 1A22 TSI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A22:0 | TSI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 35 | UINT8 | RO | 0x06 (6dez)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x01 (Input)) | UINT32 | RO | 0x60A0:01, 1
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x09 (Status)) | UINT32 | RO | 0x60A0:09, 8
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A22:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60A0:41, 64
1A22:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A0 (TSI Inputs Ch.3), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60A0:42, 64
Index 1A23 TSI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A23:0 | TSI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 36 | UINT8 | RO | 0x06 (6dez)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x01 (Input)) | UINT32 | RO | 0x60B0:01, 1
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x09 (Status)) | UINT32 | RO | 0x60B0:09, 8
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A23:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60B0:41, 64
1A23:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B0 (TSI Inputs Ch.4), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60B0:42, 64
Index 1A24 TSI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A24:0 | TSI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 37 | UINT8 | RO | 0x06 (6dez)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x01 (Input)) | UINT32 | RO | 0x60C0:01, 1
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x09 (Status)) | UINT32 | RO | 0x60C0:09, 8
1A24:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A24:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60C0:41, 64
1A24:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C0 (TSI Inputs Ch.5), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60C0:42, 64
Index 1A25 TSI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A25:0 | TSI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 38 | UINT8 | RO | 0x06 (6dez)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x01 (Input)) | UINT32 | RO | 0x60D0:01, 1
1A25:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A25:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x09 (Status)) | UINT32 | RO | 0x60D0:09, 8
1A25:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A25:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60D0:41, 64
1A25:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D0 (TSI Inputs Ch.6), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60D0:42, 64
Index 1A26 TSI TxPDO-Map Inputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A26:0 | TSI TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 39 | UINT8 | RO | 0x06 (6dez)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x01 (Input)) | UINT32 | RO | 0x60E0:01, 1
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x09 (Status)) | UINT32 | RO | 0x60E0:09, 8
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60E0:41, 64
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E0 (TSI Inputs Ch.7), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60E0:42, 64
Index 1A27 TSI TxPDO-Map Inputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A27:0 | TSI TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 40 | UINT8 | RO | 0x06 (6dez)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x01 (Input)) | UINT32 | RO | 0x60F0:01, 1
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x09 (Status)) | UINT32 | RO | 0x60F0:09, 8
1A27:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A27:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x41 (LatchPos)) | UINT32 | RO | 0x60F0:41, 64
1A27:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F0 (TSI Inputs Ch.8), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x60F0:42, 64
Index 1A28 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A28:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 41 | UINT8 | RO | 0x06 (6dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A28:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x03 (Overtemperature)) | UINT32 | RO | 0xF611:03, 1
1A28:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x04 (Checksum error)) | UINT32 | RO | 0xF611:04, 1
1A28:05 | SubIndex 005 | 5. PDO Mapping entry (60 bits align) | UINT32 | RO | 0x0000:00, 60
1A28:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x21 (SysTime)) | UINT32 | RO | 0xF611:21, 64
Index 1C00Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x08 (8dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1601 (5633dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1602 (5634dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1603 (5635dez)
1C12:05 | SubIndex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
1C12:06 | SubIndex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1605 (5637dez)
1C12:07 | SubIndex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1606 (5638dez)
1C12:08 | SubIndex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1607 (5639dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x08 (8dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A08 (6664dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0C (6668dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
1C13:06 | SubIndex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A14 (6676dez)
1C13:07 | SubIndex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A18 (6680dez)
1C13:08 | SubIndex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A1C (6684dez)
1C13:09 | SubIndex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | SubIndex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0B | SubIndex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | SubIndex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0D | SubIndex 013 | 13. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0E | SubIndex 014 | 14. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0F | SubIndex 015 | 15. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:10 | SubIndex 016 | 16. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:11 | SubIndex 017 | 17. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:12 | SubIndex 018 | 18. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:13 | SubIndex 019 | 19. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:14 | SubIndex 020 | 20. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:15 | SubIndex 021 | 21. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:16 | SubIndex 022 | 22. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:17 | SubIndex 023 | 23. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:18 | SubIndex 024 | 24. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:19 | SubIndex 025 | 25. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1A | SubIndex 026 | 26. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1B | SubIndex 027 | 27. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1C | SubIndex 028 | 28. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1D | SubIndex 029 | 29. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1E | SubIndex 030 | 30. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1F | SubIndex 031 | 31. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:20 | SubIndex 032 | 32. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:21 | SubIndex 033 | 33. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:22 | SubIndex 034 | 34. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:23 | SubIndex 035 | 35. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:24 | SubIndex 036 | 36. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:25 | SubIndex 037 | 37. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:26 | SubIndex 038 | 38. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:27 | SubIndex 039 | 39. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:28 | SubIndex 040 | 40. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:29 | SubIndex 041 | 41. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C3500 (800000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x0804 (2052dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00001F40 (8000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000C3500 (800000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0804 (2052dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00001F40 (8000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0010 (16dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | MDP Profile | UINT8 | RW | 0x10 (16dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x00000078 (120dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x00000078 (120dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x00000078 (120dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x00000078 (120dez)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x00000078 (120dez)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x00000078 (120dez)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x00000078 (120dez)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x00000078 (120dez)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000079 (121dez)
F010:0A | SubIndex 010 |  | UINT32 | RW | 0x00000079 (121dez)
F010:0B | SubIndex 011 |  | UINT32 | RW | 0x00000079 (121dez)
F010:0C | SubIndex 012 |  | UINT32 | RW | 0x00000079 (121dez)
F010:0D | SubIndex 013 |  | UINT32 | RW | 0x00000079 (121dez)
F010:0E | SubIndex 014 |  | UINT32 | RW | 0x00000079 (121dez)
F010:0F | SubIndex 015 |  | UINT32 | RW | 0x00000079 (121dez)
F010:10 | SubIndex 016 |  | UINT32 | RW | 0x00000079 (121dez)


EL1259

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259
EL1259
Weiterführende Informationen
•
Objektbeschreibung und Parametrierung
•
Objektbeschreibung - Standardobjekte


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Diagnostikdaten
•
Informationsdaten
•
Kommando-Objekt


Restore-Objekt

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 8pp1 MTO Settings (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp1:0 | MTO Settings |  |  | UINT8 | RO | 0x12 (18dez)
8pp1:01 | Use as +24 V power supply | Schaltet den Ausgang dauerhaft ein. Der Kanal kann nicht für die Abarbeitung von Timestamp-Ereignissen verwendet werden. Der Ausgang fällt ab, sobald der EtherCAT-Status nicht OP ist. |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:02 | Enable manual operation | Über dieses Objekt kann der Ausgang manuell geschaltet werden. |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:03 | Enable time check | Über dieses Bit kann bestimmt werden, wie mit Schaltaufträgen verfahren werden soll, die vor der aktuellen Zeit platziert wurden (weitere Erläuterung siehe hier). |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:11 | Buffer reset behaviour | Legt das Verhalten des "Output buffer reset" Bits fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Reset on rising edge: Der Buffer wird mit einer steigenden Flanke von "Output buffer reset" gelöscht
 |  | 1 | Reset on high level: Der Buffer wird mit einer steigenden Flanke von "Output buffer reset" gelöscht und nimmt keine neuen Werte auf, bis "Output buffer reset" wieder zurückgesetzt wird.
8pp1:12 | Buffer overflow behaviour | Legt das Verhalten beim Überlauf des Puffers fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Lock buffer: Neue Ereignisse werden verworfen
 |  | 1 | Overwrite oldest value: Neue Ereignisse überschreiben die letzten Events im Puffer
Index 8ppF MTO Vendor data (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | MTO Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Ausgabezeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Ausgabezeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
Index 8pp0 MTI settings (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp0:0 | MTI settings |  |  | UINT8 | RO | 0x14 (20dez)
8pp0:01 | Enable digital filter | Aktivierung des Filters um Spikes auszublenden, Filterlänge ist in 8pp0:14 "DigitalFilterCount" einzugeben (weitere Erläuterung siehe hier). |  | BOOLEAN | RW | 0x00 (0dez)
8pp0:11 | Buffer reset behaviour | Legt das Verhalten des "Input buffer reset" Bits fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Reset on rising edge: Der Buffer wird mit einer steigenden Flanke von "Input buffer reset" gelöscht
 |  | 1 | Reset on high level: Der Buffer wird mit einer steigenden Flanke von "Input buffer reset" gelöscht und nimmt keine neuen Werte auf, bis "Input buffer reset" wieder zurückgesetzt wird.
8pp0:12 | Buffer mode | Legt fest, ob zum Abholen der Werte aus dem Buffer ein Handshakeverfahren genutzt werden soll (Übertragungssicherheit) oder ob neue Werte mit jedem SPS-Zyklus direkt übertragen werden sollen (schneller) Erlaubte Werte (weitere Erläuterung siehe hier): |  | UINT16 | RW | 0x0001 (1dez)
 |  | 0 | Asynchronous (Buffered): Die Entgegennahme neuer Ereignisse muss durch die PLC quittiert werden. Dazu muss im SPS-Programm das Byte "No of input events" überwacht werden. Sollte dies größer als null sein, können die aufgelaufenen Events aus dem Prozessabbild übernommen werden. Im Anschluss muss das Byte "Input order counter" inkrementiert werden. Hierdurch wird der Klemme signalisiert, dass die Events übernommen wurden und in nächsten Zyklus neue Daten angelegt werden können.
 |  | 1 | Synchronous: Neue Ereignisse werden mit jedem SPS-Zyklus automatisch übertragen
8pp0:13 | Buffer overflow behaviour | Legt das Verhalten beim Überlauf des Puffers fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Lock buffer: Neue Ereignisse werden verworfen
 |  | 1 | Overwrite oldest event: Neue Ereignisse überschreiben die letzten Events im Puffer
8pp0:14 | Digital filter count | Legt fest, wie vielen Abtastungen ein Event anliegen muss, damit es wirklich in den Puffer übernommen wird (weitere Erläuterung siehe hier). |  | UINT16 | RW | 0x0001 (1dez)
Index 8ppF MTI Vendor data (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | MTI Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Eingangszeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Eingangszeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
Index 8ppF TSO Vendor data (für 10 ≤ pp ≤ 17; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | TSO Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Ausgabezeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Ausgabezeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
Index 8pp0 TSI Settings (für 18 ≤ pp ≤ 1F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp0:0 | TSI Settings |  |  | UINT8 | RO | 0x02 (2dez)
8pp0:01 | Pos Sample Mode | Pro SPS-Zyklus darf nur eine steigende Flanke am Eingang der Klemme erkannt werden. Sollten mehrere Flanken pro Zyklus eintreffen, kann mit diesem Bit entschieden werden, welche Flanke in dem Prozessabbild angezeigt werden soll. Erlaubte Werte: |  | BIT1 | RW | 0x00 (0dez)
 |  | 0 | Last edge: Es wird die letzte Flanke des vorhergehenden SPS-Zyklusses angezeigt
 |  | 1 | First edge: Es wird die erste Flanke des vorhergehenden SPS-Zyklusses angezeigt
8pp0:02 | Neg Sample Mode | Pro SPS-Zyklus darf nur eine fallende Flanke am Eingang der Klemme erkannt werden. Sollten mehrere Flanken pro Zyklus eintreffen, kann mit diesem Bit entschieden werden, welche Flanke in dem Prozessabbild angezeigt werden soll. Erlaubte Werte: |  | BIT1 | RW | 0x00 (0dez)
 |  | 0 | Last edge: Es wird die letzte Flanke des vorhergehenden SPS-Zyklusses angezeigt
 |  | 1 | First edge: Es wird die erste Flanke des vorhergehenden SPS-Zyklusses angezeigt
Index 8ppF TSI Vendor data (für 18 ≤ pp ≤ 1F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | TSI Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Eingangszeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Eingangszeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)


Eingangsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 6pp0 MTO inputs (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | MTO inputs |  | UINT8 | RO | 0x00 (0dez)
6pp0:01 | Output short circuit | Der Kanal meldet einen Kurzschluss | BOOLEAN | RO | 0x00 (0dez)
6pp0:02 | Output buffer overflow | Es wurden mehr Events in den Puffer geschrieben, als dieser aufnehmen kann | BOOLEAN | RO | 0x00 (0dez)
6pp0:03 | Output state | Aktueller Zustand des Ausgangs zum Zeitpunkt des Prozessdatenzyklusses | BOOLEAN | RO | 0x00 (0dez)
6pp0:0F | Input cycle counter | Wird mit jedem Prozessdatenzyklus inkrementiert und läuft nach seinem Maximalwert von 3 auf 0 über. | BIT2 | RO | 0x00 (0dez)
6pp0:11 | Output order feedback | Dieses Byte spiegelt den Zustand des "Output order counter" Bytes. | UINT8 | RO | 0x00 (0dez)
6pp0:12 | Events in output buffer | Meldet die Anzahl der aktuell noch im Buffer befindlichen Schaltaufträge zurück | UINT8 | RO | 0x00 (0dez)
Index 6pp1 MTI inputs (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp1:0 | MTI inputs |  | UINT8 | RO | 0x00 (0dez)
6pp1:01 | No of input events | Meldet die Anzahl der im Prozessabbild verfügbaren neuen Zeitstempel. Wird hier z.B. ein drei zurückgegeben, sind nur die Objekte "Input event State 1...3" und "Input event time 1...3" gültig. | UINT8 | RO | 0x00 (0dez)
6pp1:09 | Input state | Gibt den zum Zeitpunkt des Prozessdatenzyklusses aktuellen Zustand des Inputs an. | BOOLEAN | RO | 0x00 (0dez)
6pp1:0A | Input buffer overflow | Es sind mehr Ereignisse am Eingang aufgetreten als Elemente im Puffer des Kanals frei waren. | BOOLEAN | RO | 0x00 (0dez)
6pp1:0F | Input cycle counter | Wird mit jedem Prozessdatenzyklus inkrementiert und läuft nach seinem Maximalwert von 3 auf 0 über. | BIT2 | RO | 0x00 (0dez)
6pp1:11 | Events in input buffer | Meldet die Anzahl der aktuell im Puffer befindlichen Ereignisse | UINT8 | RO | 0x00 (0dez)
6pp1:12 | Input order feedback | Dieses Byte spiegelt den Zustand des "Input order counter" Bytes (weitere Erläuterung siehe hier). | UINT8 | RO | 0x00 (0dez)
6pp1:21 | Input event state 1 | Gibt an ob es sich bei dem Event um eine steigende (1) oder eine fallende (0) Flanke gehandelt hat | BOOLEAN | RO | 0x00 (0dez)
6pp1:2A | Input event state 10 |  | BOOLEAN | RO | 0x00 (0dez)
6pp1:41 | Input event time 1 | 32 Bit Zeitstempel zum korrespondierenden "Input event state n" | UINT32 | RO | 0x00000000 (0dez)
6pp1:4A | Input event time 10 |  | UINT32 | RO | 0x00000000 (0dez)
Index 6pp0 TSO Inputs (für 10 ≤ pp ≤ 17; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | TSO Inputs |  | UINT8 | RO | 0x00 (0dez)
6pp0:01 | Feedback | Gibt den aktuellen Zustand des Ausgangs wieder | BOOLEAN | RO | 0x00 (0dez)
Index 6pp0 TSI Inputs (für 18 ≤ pp ≤ 1F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | TSI Inputs |  | UINT8 | RO | 0x00 (0dez)
6pp0:01 | Input | Aktueller Status des Eingangs | BOOLEAN | RO | 0x00 (0dez)
6pp0:09 | Status | Bit 0: Wird für einen Zyklus gesetzt wenn eine steigende Flanke erkannt wurde Bit 1: Wird für einen Zyklus gesetzt wenn eine fallende Flanke erkannt wurde | UINT8 | RO | 0x00 (0dez)
6pp0:41 | LatchPos | Zeitstempel der steigenden Flanke | UINT64 | RO |
6pp0:42 | LatchNeg | Zeitstempel der fallenden Flanke | UINT64 | RO |
Index F611 DEV Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F611:0 | DEV Inputs |  | UINT8 | RO | 0x00 (0dez)
F611:02 | Undervoltage Up | Die Nennspannung an den Powerkontakten wurde erheblich unterschritten | BOOLEAN | RO | 0x00 (0dez)
F611:03 | Overtemperature | Übertemperaturfehler: Die Temperatur der Ein- oder Ausgangsbausteine ist zu hoch. Bei Ausgangsklemmen sollte geprüft werden, ob nicht mindestens ein Kanal einen Kurzschluss treibt. | BOOLEAN | RO | 0x00 (0dez)
F611:04 | Checksum error | Bei der internen Datenübertragung ist ein Fehler aufgetreten | BOOLEAN | RO | 0x00 (0dez)
F611:21 | SysTime | DC-Zeitstempel des letzten Inputmappings. Dieser Zeitstempel sollte nicht als Referenz genutzt werden (Informationen zu DC-Referenzzeiten). | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 7pp1 MTO outputs (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
7pp1:0
MTO outputs
UINT8
RO
0x00 (0dez)
7pp1:01
Output buffer reset
Entfernt alle im Puffer befindlichen Elemente
Das Löschen kann durch eine steigende Flanke oder kontinuierlich durch das Anlegen einer 1 an diesem Bit erzielt werden. Das Verhalten kann über das CoE-Objekt 0x8pp1:11 parametriert werden.
BOOLEAN
RO
0x00 (0dez)
7pp1:02
Manual output state
Über dieses Bit kann der Ausgang ohne die Verwendung von Timestamps geschaltet werden.
▪
Möglichkeit 1: Das CoE-Objekt 0x8pp1:02 ("Enable manual operation") wird auf true gesetzt. Der Timestamp-Betrieb ist nun ausgeschaltet und der Ausgang lässt sich nur noch über das Bit "Manual operation state" schalten. Dies ist besonders für die Inbetriebnahmephase hilfreich.
▪
Möglichkeit 2: Über das Bit "Enable manual operation" (0x7pp1:04) kann die Ausgabe des Kanals auf den Wert dieses Objektes gezwungen werden. Die Abarbeitung der Timestamps läuft im Hintergrund weiter. Diese werden jedoch erst wieder zur Ausgabe gebracht, wenn das Bit "Enable manual operation" wieder auf 0 gesetzt wurde.
BOOLEAN
RO
0x00 (0dez)
7pp1:03
Force order
Dieses Bit legt fest, wie mit Timestamps verfahren werden soll, die in der Vergangenheit platziert wurden (siehe Grafik).
BOOLEAN
RO
0x00 (0dez)
7pp1:04
Enable manual operation
Siehe "Manual output state" (0x7pp1:02).
BOOLEAN
RO
0x00 (0dez)
7pp1:09
Output order counter
Durch das Inkrementieren dieses Bytes wird dem Kanal mitgeteilt, dass neue Output-Events übernommen werden sollen
UINT8
RO
0x00 (0dez)
7pp1:11
No of output events
Anzahl der gefüllten "Output event state" und "Output event time" Objekte
UINT8
RO
0x00 (0dez)
7pp1:21
Output event state 1
Über dieses Bit wird bestimmt welchen Zustand der Ausgang zum Zeitpunk von "Output event Time 1" annehmen soll
BOOLEAN
RO
0x00 (0dez)
7pp1:2A
Output event state 10
BOOLEAN
RO
0x00 (0dez)
7pp1:41
Output event time 1
Zeitpunkt zu dem der in "Output event state 1" beschriebene Zustand angelegt werden soll
UINT32
RO
0x00000000 (0dez)
7pp1:4A
Output event time 10
UINT32
RO
0x00000000 (0dez)
Index 7pp0 MTI outputs (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7pp0:0 | MTI outputs |  | UINT8 | RO | 0x00 (0dez)
7pp0:01 | Input buffer reset | Entfernt alle im Puffer befindlichen Elemente Das Löschen kann durch eine steigende Flanke oder kontinuierlich durch das Anlegen einer 1 an diesem Bit erzielt werden. Das Verhalten kann über das CoE-Objekt 0x8pp0:11 ("Buffer reset behaviour" parametriert werden. | BOOLEAN | RO | 0x00 (0dez)
7pp0:11 | Input order counter | Über dieses Bit wird der Klemme mitgeteilt, dass die Input-Events aus dem Prozessabbild übernommen wurden und die Klemme im nächsten Zyklus einen neuen Satz Input Events aus dem Buffer in das Prozessabbild kopieren darf (siehe Buffer mode). | UINT8 | RO | 0x00 (0dez)
Index 7pp0 TSO Outputs (für 10 ≤ pp ≤ 17; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7pp0:0 | TSO Outputs |  | UINT8 | RO | 0x00 (0dez)
7pp0:01 | Output | Legt fest ob zum Zeitpunkt der "StartTime" eine steigende (1) oder fallende (0) Flanke ausgegeben werden soll | BOOLEAN | RO | 0x00 (0dez)
7pp0:11 | Activate | Mit einem Wechsel von 0 nach 3 in diesem Byte, wird der Auftrag mit der aktuellen StartTime übernommen | UINT8 | RO | 0x00 (0dez)
7pp0:41 | StartTime | 64 Bit TimeSTamp | UINT64 | RO |


Diagnostikdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Diagnostikdaten
Diagnostikdaten
Index App0 MTO Diag data (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0 | MTO Diag data |  | UINT8 | RO | 0x00 (0dez)
App0:01 | Short circuit | Der Kanal meldet einen Kurzschluss | BOOLEAN | RO | 0x00 (0dez)
App0:02 | Undervoltage | Die Spannung an den Powerkontakten ist außerhalb des gültigen Bereiches | BOOLEAN | RO | 0x00 (0dez)
Index App0 MTI Diag data (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0 | MTI Diag data |  | UINT8 | RO | 0x00 (0dez)
App0:01 | Overtemperature | Die Klemmeninnentemperatur ist oberhalb des gültigen Bereiches. Bei Klemmen die auch über Ausgangskanäle verfügen, sollte geprüft werden, ob an keinem der Ausgänge ein Kurzschluss anliegt. | BOOLEAN | RO | 0x00 (0dez)
App0:02 | Undervoltage | Die Spannung an den Powerkontakten ist außerhalb des gültigen Bereiches | BOOLEAN | RO | 0x00 (0dez)
Index A001 MTO common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A001:0 | MTO common Diag data |  | UINT8 | RO | 0x00 (0dez)
A001:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)
Index A081 MTI common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A081:0 | MTI common Diag data |  | UINT8 | RO | 0x00 (0dez)
A081:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)
Index A100 TSO common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A100:0 | TSO common Diag data |  | UINT8 | RO | 0x00 (0dez)
A100:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)
Index A180 TSI common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A180:0 | TSI common Diag data |  | UINT8 | RO | 0x00 (0dez)
A180:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)


Informationsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Informationsdaten
Informationsdaten
Index F900 DEV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DEV Info data |  | UINT8 | RO | 0x00 (0dez)
F900:08 | Cycle Time | Gibt die kleinstmögliche einzustellende Zykluszeit an [ns]. | UINT32 | RO | 0x00000000 (0dez)
F900:09 | Sample time | Gibt die Abtastzeit der Ein- und Ausgänge an [ns]. | UINT32 | RO | 0x00000000 (0dez)


Kommando-Objekt

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung und Parametrierung [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Das Command-Objekt wurde für die zukünftige Verwendung implementiert. Aktuell werden keine Kommandos unterstützt.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | Command |  | UINT8 | RO | 0x00 (0dez)
FB00:01 | Request | Über das Request-Objekt können Kommandos an die Klemme abgesetzt werden. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status des aktuell ausgeführten Kommandos | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | Optionaler Rückgabewert des Kommandos | OCTET-STRING[6] | RO | {0}


Objektbeschreibung - Standardobjekte

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL1259 [image] Objektbeschreibung - Standardobjekte
Objektbeschreibung - Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL1259
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100A Software version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 01
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x04EB3052 (82522194dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 MTO RxPDO-Map Outputs 10x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | MTO RxPDO-Map Outputs 10x Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x1D (29dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1600:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1600:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1600:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7001:26, 1
1600:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7001:27, 1
1600:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7001:28, 1
1600:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7001:29, 1
1600:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7001:2A, 1
1600:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1600:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1600:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1600:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1600:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1600:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
1600:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7001:46, 32
1600:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7001:47, 32
1600:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7001:48, 32
1600:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7001:49, 32
1600:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7001:4A, 32
Index 1601 MTO RxPDO-Map Outputs 5x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | MTO RxPDO-Map Outputs 5x Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x13 (19dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1601:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1601:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
Index 1602 MTO RxPDO-Map Outputs 2x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | MTO RxPDO-Map Outputs 2x Ch.1 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x0D (13dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1602:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1602:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1602:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1602:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1602:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
Index 1603 MTO RxPDO-Map Outputs 1x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | MTO RxPDO-Map Outputs 1x Ch.1 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x0B (11dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1603:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1603:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1603:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
Index 1604 MTO RxPDO-Map Outputs 10x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | MTO RxPDO-Map Outputs 10x Ch.2 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x1D (29dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1604:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1604:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1604:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1604:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1604:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1604:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7011:26, 1
1604:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7011:27, 1
1604:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7011:28, 1
1604:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7011:29, 1
1604:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7011:2A, 1
1604:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1604:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1604:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1604:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1604:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1604:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
1604:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7011:46, 32
1604:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7011:47, 32
1604:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7011:48, 32
1604:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7011:49, 32
1604:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7011:4A, 32
Index 1605 MTO RxPDO-Map Outputs 5x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | MTO RxPDO-Map Outputs 5x Ch.2 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x13 (19dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1605:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1605:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1605:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1605:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1605:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1605:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1605:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1605:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1605:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1605:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1605:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1605:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
Index 1606 MTO RxPDO-Map Outputs 2x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | MTO RxPDO-Map Outputs 2x Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x0D (13dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1606:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1606:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1606:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1606:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1606:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1606:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
Index 1607 MTO RxPDO-Map Outputs 1x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | MTO RxPDO-Map Outputs 1x Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0B (11dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1607:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1607:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
Index 1608 MTO RxPDO-Map Outputs 10x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1608:0 | MTO RxPDO-Map Outputs 10x Ch.3 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x1D (29dez)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1608:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1608:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1608:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1608:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1608:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1608:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1608:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1608:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1608:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7021:26, 1
1608:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7021:27, 1
1608:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7021:28, 1
1608:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7021:29, 1
1608:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7021:2A, 1
1608:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1608:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1608:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1608:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1608:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1608:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
1608:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7021:46, 32
1608:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7021:47, 32
1608:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7021:48, 32
1608:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7021:49, 32
1608:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7021:4A, 32
Index 1609 MTO RxPDO-Map Outputs 5x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1609:0 | MTO RxPDO-Map Outputs 5x Ch.3 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x13 (19dez)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1609:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1609:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1609:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1609:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1609:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1609:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1609:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1609:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1609:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1609:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1609:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1609:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1609:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1609:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1609:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
Index 160A MTO RxPDO-Map Outputs 2x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160A:0 | MTO RxPDO-Map Outputs 2x Ch.3 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x0D (13dez)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
160A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
160A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
Index 160B MTO RxPDO-Map Outputs 1x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160B:0 | MTO RxPDO-Map Outputs 1x Ch.3 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x0B (11dez)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
Index 160C MTO RxPDO-Map Outputs 10x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160C:0 | MTO RxPDO-Map Outputs 10x Ch.4 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x1D (29dez)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7031:26, 1
160C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7031:27, 1
160C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7031:28, 1
160C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7031:29, 1
160C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7031:2A, 1
160C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
160C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
160C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7031:46, 32
160C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7031:47, 32
160C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7031:48, 32
160C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7031:49, 32
160C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7031:4A, 32
Index 160D MTO RxPDO-Map Outputs 5x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160D:0 | MTO RxPDO-Map Outputs 5x Ch.4 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x13 (19dez)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
160D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
Index 160E MTO RxPDO-Map Outputs 2x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160E:0 | MTO RxPDO-Map Outputs 2x Ch.4 | PDO Mapping RxPDO 15 | UINT8 | RO | 0x0D (13dez)
160E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
Index 160F MTO RxPDO-Map Outputs 1x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160F:0 | MTO RxPDO-Map Outputs 1x Ch.4 | PDO Mapping RxPDO 16 | UINT8 | RO | 0x0B (11dez)
160F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
Index 1610 MTO RxPDO-Map Outputs 10x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1610:0 | MTO RxPDO-Map Outputs 10x Ch.5 | PDO Mapping RxPDO 17 | UINT8 | RO | 0x1D (29dez)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1610:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1610:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1610:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1610:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1610:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1610:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1610:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1610:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1610:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7041:26, 1
1610:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7041:27, 1
1610:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7041:28, 1
1610:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7041:29, 1
1610:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7041:2A, 1
1610:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1610:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1610:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1610:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1610:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1610:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
1610:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7041:46, 32
1610:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7041:47, 32
1610:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7041:48, 32
1610:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7041:49, 32
1610:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7041:4A, 32
Index 1611 MTO RxPDO-Map Outputs 5x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1611:0 | MTO RxPDO-Map Outputs 5x Ch.5 | PDO Mapping RxPDO 18 | UINT8 | RO | 0x13 (19dez)
1611:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1611:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1611:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1611:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1611:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1611:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1611:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1611:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1611:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1611:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1611:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1611:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1611:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1611:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1611:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1611:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1611:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1611:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1611:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
Index 1612 MTO RxPDO-Map Outputs 2x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1612:0 | MTO RxPDO-Map Outputs 2x Ch.5 | PDO Mapping RxPDO 19 | UINT8 | RO | 0x0D (13dez)
1612:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1612:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1612:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1612:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1612:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1612:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1612:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1612:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1612:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1612:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1612:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1612:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1612:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
Index 1613 MTO RxPDO-Map Outputs 1x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1613:0 | MTO RxPDO-Map Outputs 1x Ch.5 | PDO Mapping RxPDO 20 | UINT8 | RO | 0x0B (11dez)
1613:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1613:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1613:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1613:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1613:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1613:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1613:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1613:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1613:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1613:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1613:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
Index 1614 MTO RxPDO-Map Outputs 10x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1614:0 | MTO RxPDO-Map Outputs 10x Ch.6 | PDO Mapping RxPDO 21 | UINT8 | RO | 0x1D (29dez)
1614:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1614:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1614:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1614:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1614:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1614:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1614:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1614:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1614:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1614:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1614:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1614:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1614:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1614:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7051:26, 1
1614:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7051:27, 1
1614:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7051:28, 1
1614:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7051:29, 1
1614:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7051:2A, 1
1614:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1614:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1614:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1614:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1614:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1614:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
1614:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7051:46, 32
1614:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7051:47, 32
1614:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7051:48, 32
1614:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7051:49, 32
1614:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7051:4A, 32
Index 1615 MTO RxPDO-Map Outputs 5x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1615:0 | MTO RxPDO-Map Outputs 5x Ch.6 | PDO Mapping RxPDO 22 | UINT8 | RO | 0x13 (19dez)
1615:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1615:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1615:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1615:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1615:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1615:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1615:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1615:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1615:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1615:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1615:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1615:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1615:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1615:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1615:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1615:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1615:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1615:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1615:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
Index 1616 MTO RxPDO-Map Outputs 2x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1616:0 | MTO RxPDO-Map Outputs 2x Ch.6 | PDO Mapping RxPDO 23 | UINT8 | RO | 0x0D (13dez)
1616:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1616:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1616:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1616:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1616:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1616:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1616:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1616:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1616:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1616:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1616:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1616:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1616:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
Index 1617 MTO RxPDO-Map Outputs 1x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1617:0 | MTO RxPDO-Map Outputs 1x Ch.6 | PDO Mapping RxPDO 24 | UINT8 | RO | 0x0B (11dez)
1617:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1617:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1617:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1617:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1617:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1617:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1617:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1617:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1617:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1617:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1617:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
Index 1618 MTO RxPDO-Map Outputs 10x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1618:0 | MTO RxPDO-Map Outputs 10x Ch.7 | PDO Mapping RxPDO 25 | UINT8 | RO | 0x1D (29dez)
1618:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1618:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1618:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1618:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1618:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1618:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1618:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1618:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1618:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1618:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1618:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1618:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1618:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1618:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7061:26, 1
1618:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7061:27, 1
1618:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7061:28, 1
1618:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7061:29, 1
1618:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7061:2A, 1
1618:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1618:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1618:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1618:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1618:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1618:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
1618:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7061:46, 32
1618:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7061:47, 32
1618:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7061:48, 32
1618:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7061:49, 32
1618:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7061:4A, 32
Index 1619 MTO RxPDO-Map Outputs 5x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1619:0 | MTO RxPDO-Map Outputs 5x Ch.7 | PDO Mapping RxPDO 26 | UINT8 | RO | 0x13 (19dez)
1619:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1619:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1619:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1619:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1619:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1619:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1619:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1619:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1619:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1619:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1619:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1619:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1619:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1619:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1619:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1619:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1619:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1619:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1619:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
Index 161A MTO RxPDO-Map Outputs 2x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161A:0 | MTO RxPDO-Map Outputs 2x Ch.7 | PDO Mapping RxPDO 27 | UINT8 | RO | 0x0D (13dez)
161A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
161A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
161A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
Index 161B MTO RxPDO-Map Outputs 1x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161B:0 | MTO RxPDO-Map Outputs 1x Ch.7 | PDO Mapping RxPDO 28 | UINT8 | RO | 0x0B (11dez)
161B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
Index 161C MTO RxPDO-Map Outputs 10x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161C:0 | MTO RxPDO-Map Outputs 10x Ch.8 | PDO Mapping RxPDO 29 | UINT8 | RO | 0x1D (29dez)
161C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7071:26, 1
161C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7071:27, 1
161C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7071:28, 1
161C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7071:29, 1
161C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7071:2A, 1
161C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
161C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
161C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7071:46, 32
161C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7071:47, 32
161C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7071:48, 32
161C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7071:49, 32
161C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7071:4A, 32
Index 161D MTO RxPDO-Map Outputs 5x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161D:0 | MTO RxPDO-Map Outputs 5x Ch.8 | PDO Mapping RxPDO 30 | UINT8 | RO | 0x13 (19dez)
161D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
161D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
Index 161E MTO RxPDO-Map Outputs 2x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161E:0 | MTO RxPDO-Map Outputs 2x Ch.8 | PDO Mapping RxPDO 31 | UINT8 | RO | 0x0D (13dez)
161E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
Index 161F MTO RxPDO-Map Outputs 1x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161F:0 | MTO RxPDO-Map Outputs 1x Ch.8 | PDO Mapping RxPDO 32 | UINT8 | RO | 0x0B (11dez)
161F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
Index 1620 MTI RxPDO-Map Outputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1620:0 | MTI RxPDO-Map Outputs Ch.1 | PDO Mapping RxPDO 33 | UINT8 | RO | 0x04 (4dez)
1620:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7080 (MTI outputs Ch.1), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7080:01, 1
1620:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1620:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7080 (MTI outputs Ch.1), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7080:11, 8
1620:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1621 MTI RxPDO-Map Outputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1621:0 | MTI RxPDO-Map Outputs Ch.2 | PDO Mapping RxPDO 34 | UINT8 | RO | 0x04 (4dez)
1621:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7090 (MTI outputs Ch.2), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x7090:01, 1
1621:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1621:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7090 (MTI outputs Ch.2), entry 0x11 (Input order counter)) | UINT32 | RO | 0x7090:11, 8
1621:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1622 MTI RxPDO-Map Outputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1622:0 | MTI RxPDO-Map Outputs Ch.3 | PDO Mapping RxPDO 35 | UINT8 | RO | 0x04 (4dez)
1622:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70A0 (MTI outputs Ch.3), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70A0:01, 1
1622:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1622:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70A0 (MTI outputs Ch.3), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70A0:11, 8
1622:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1623 MTI RxPDO-Map Outputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1623:0 | MTI RxPDO-Map Outputs Ch.4 | PDO Mapping RxPDO 36 | UINT8 | RO | 0x04 (4dez)
1623:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70B0 (MTI outputs Ch.4), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70B0:01, 1
1623:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1623:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70B0 (MTI outputs Ch.4), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70B0:11, 8
1623:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1624 MTI RxPDO-Map Outputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1624:0 | MTI RxPDO-Map Outputs Ch.5 | PDO Mapping RxPDO 37 | UINT8 | RO | 0x04 (4dez)
1624:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70C0 (MTI outputs Ch.5), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70C0:01, 1
1624:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1624:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70C0 (MTI outputs Ch.5), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70C0:11, 8
1624:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1625 MTI RxPDO-Map Outputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1625:0 | MTI RxPDO-Map Outputs Ch.6 | PDO Mapping RxPDO 38 | UINT8 | RO | 0x04 (4dez)
1625:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70D0 (MTI outputs Ch.6), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70D0:01, 1
1625:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1625:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70D0 (MTI outputs Ch.6), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70D0:11, 8
1625:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1626 MTI RxPDO-Map Outputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1626:0 | MTI RxPDO-Map Outputs Ch.7 | PDO Mapping RxPDO 39 | UINT8 | RO | 0x04 (4dez)
1626:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70E0 (MTI outputs Ch.7), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70E0:01, 1
1626:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1626:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70E0 (MTI outputs Ch.7), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70E0:11, 8
1626:04 | SubIndex 004 | 4. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
Index 1627 MTI RxPDO-Map Outputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1627:0 | MTI RxPDO-Map Outputs Ch.8 | PDO Mapping RxPDO 40 | UINT8 | RO | 0x04 (4dez)
1627:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70F0 (MTI outputs Ch.8), entry 0x01 (Input buffer reset)) | UINT32 | RO | 0x70F0:01, 1
1627:02 | SubIndex 002 | 2. PDO Mapping entry (15 Bits align) | UINT32 | RO | 0x0000:00, 15
1627:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70F0 (MTI outputs Ch.8), entry 0x11 (Input order counter)) | UINT32 | RO | 0x70F0:11, 8
1627:04 | SubIndex 004 | 4. PDO Mapping entry (8 Bits align) | UINT32 | RO | 0x0000:00, 8
Index 1628 TSO RxPDO-Map Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1628:0 | TSO RxPDO-Map Ch.1 | PDO Mapping RxPDO 41 | UINT8 | RO | 0x05 (5dez)
1628:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7100 (TSO Outputs Ch.1), entry 0x01 (Output)) | UINT32 | RO | 0x7100:01, 1
1628:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1628:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7100 (TSO Outputs Ch.1), entry 0x11 (Activate)) | UINT32 | RO | 0x7100:11, 8
1628:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1628:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7100 (TSO Outputs Ch.1), entry 0x41 (StartTime)) | UINT32 | RO | 0x7100:41, 64
Index 1629 TSO RxPDO-Map Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1629:0 | TSO RxPDO-Map Ch.2 | PDO Mapping RxPDO 42 | UINT8 | RO | 0x05 (5dez)
1629:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7110 (TSO Outputs Ch.2), entry 0x01 (Output)) | UINT32 | RO | 0x7110:01, 1
1629:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1629:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7110 (TSO Outputs Ch.2), entry 0x11 (Activate)) | UINT32 | RO | 0x7110:11, 8
1629:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1629:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7110 (TSO Outputs Ch.2), entry 0x41 (StartTime)) | UINT32 | RO | 0x7110:41, 64
Index 162A TSO RxPDO-Map Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
162A:0 | TSO RxPDO-Map Ch.3 | PDO Mapping RxPDO 43 | UINT8 | RO | 0x05 (5dez)
162A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7120 (TSO Outputs Ch.3), entry 0x01 (Output)) | UINT32 | RO | 0x7120:01, 1
162A:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7120 (TSO Outputs Ch.3), entry 0x11 (Activate)) | UINT32 | RO | 0x7120:11, 8
162A:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7120 (TSO Outputs Ch.3), entry 0x41 (StartTime)) | UINT32 | RO | 0x7120:41, 64
Index 162B TSO RxPDO-Map Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
162B:0 | TSO RxPDO-Map Ch.4 | PDO Mapping RxPDO 44 | UINT8 | RO | 0x05 (5dez)
162B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7130 (TSO Outputs Ch.4), entry 0x01 (Output)) | UINT32 | RO | 0x7130:01, 1
162B:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7130 (TSO Outputs Ch.4), entry 0x11 (Activate)) | UINT32 | RO | 0x7130:11, 8
162B:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7130 (TSO Outputs Ch.4), entry 0x41 (StartTime)) | UINT32 | RO | 0x7130:41, 64
Index 162C TSO RxPDO-Map Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
162C:0 | TSO RxPDO-Map Ch.5 | PDO Mapping RxPDO 45 | UINT8 | RO | 0x05 (5dez)
162C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7140 (TSO Outputs Ch.5), entry 0x01 (Output)) | UINT32 | RO | 0x7140:01, 1
162C:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7140 (TSO Outputs Ch.5), entry 0x11 (Activate)) | UINT32 | RO | 0x7140:11, 8
162C:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7140 (TSO Outputs Ch.5), entry 0x41 (StartTime)) | UINT32 | RO | 0x7140:41, 64
Index 162D TSO RxPDO-Map Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
162D:0 | TSO RxPDO-Map Ch.6 | PDO Mapping RxPDO 46 | UINT8 | RO | 0x05 (5dez)
162D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7150 (TSO Outputs Ch.6), entry 0x01 (Output)) | UINT32 | RO | 0x7150:01, 1
162D:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7150 (TSO Outputs Ch.6), entry 0x11 (Activate)) | UINT32 | RO | 0x7150:11, 8
162D:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7150 (TSO Outputs Ch.6), entry 0x41 (StartTime)) | UINT32 | RO | 0x7150:41, 64
Index 162E TSO RxPDO-Map Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
162E:0 | TSO RxPDO-Map Ch.7 | PDO Mapping RxPDO 47 | UINT8 | RO | 0x05 (5dez)
162E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7160 (TSO Outputs Ch.7), entry 0x01 (Output)) | UINT32 | RO | 0x7160:01, 1
162E:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7160 (TSO Outputs Ch.7), entry 0x11 (Activate)) | UINT32 | RO | 0x7160:11, 8
162E:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7160 (TSO Outputs Ch.7), entry 0x41 (StartTime)) | UINT32 | RO | 0x7160:41, 64
Index 162F TSO RxPDO-Map Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
162F:0 | TSO RxPDO-Map Ch.8 | PDO Mapping RxPDO 48 | UINT8 | RO | 0x05 (5dez)
162F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7170 (TSO Outputs Ch.8), entry 0x01 (Output)) | UINT32 | RO | 0x7170:01, 1
162F:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
162F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7170 (TSO Outputs Ch.8), entry 0x11 (Activate)) | UINT32 | RO | 0x7170:11, 8
162F:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
162F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7170 (TSO Outputs Ch.8), entry 0x41 (StartTime)) | UINT32 | RO | 0x7170:41, 64
Index 1A00 MTO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | MTO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x07 (7dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x03 (Output state)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6000:11, 8
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6000:12, 8
Index 1A01 MTO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | MTO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x07 (7dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x03 (Output state)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6010:0F, 2
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6010:11, 8
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6010:12, 8
Index 1A02 MTO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | MTO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x03 (Output state)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6020:0F, 2
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6020:11, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6020:12, 8
Index 1A03 MTO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | MTO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x07 (7dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x03 (Output state)) | UINT32 | RO | 0x6030:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6030:0F, 2
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6030:11, 8
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6030:12, 8
Index 1A04 MTO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | MTO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x07 (7dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6040:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6040:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x03 (Output state)) | UINT32 | RO | 0x6040:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6040:0F, 2
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6040:11, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6040:12, 8
Index 1A05 MTO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | MTO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6050:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6050:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x03 (Output state)) | UINT32 | RO | 0x6050:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6050:0F, 2
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6050:11, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6050:12, 8
Index 1A06 MTO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | MTO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x07 (7dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6060:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6060:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x03 (Output state)) | UINT32 | RO | 0x6060:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6060:0F, 2
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6060:11, 8
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6060:12, 8
Index 1A07 MTO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | MTO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x07 (7dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6070:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6070:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x03 (Output state)) | UINT32 | RO | 0x6070:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6070:0F, 2
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6070:11, 8
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6070:12, 8
Index 1A08 MTI TxPDO-Map Inputs 10x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | MTI TxPDO-Map Inputs 10x Ch.1 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x1C (28dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A08:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A08:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A08:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A08:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A08:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A08:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A08:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6081:22, 1
1A08:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6081:23, 1
1A08:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6081:24, 1
1A08:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6081:25, 1
1A08:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6081:26, 1
1A08:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6081:27, 1
1A08:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6081:28, 1
1A08:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6081:29, 1
1A08:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6081:2A, 1
1A08:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A08:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
1A08:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6081:42, 32
1A08:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6081:43, 32
1A08:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6081:44, 32
1A08:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6081:45, 32
1A08:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6081:46, 32
1A08:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6081:47, 32
1A08:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6081:48, 32
1A08:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6081:49, 32
1A08:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6081:4A, 32
Index 1A09 MTI TxPDO-Map Inputs 5x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | MTI TxPDO-Map Inputs 5x Ch.1 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x12 (18dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A09:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A09:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A09:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A09:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A09:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A09:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A09:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6081:22, 1
1A09:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6081:23, 1
1A09:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6081:24, 1
1A09:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6081:25, 1
1A09:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A09:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
1A09:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6081:42, 32
1A09:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6081:43, 32
1A09:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6081:44, 32
1A09:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6081:45, 32
Index 1A0A MTI TxPDO-Map Inputs 2x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | MTI TxPDO-Map Inputs 2x Ch.1 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x0C (12dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A0A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A0A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A0A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A0A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A0A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A0A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6081:22, 1
1A0A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
1A0A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6081:42, 32
Index 1A0B MTI TxPDO-Map Inputs 1x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | MTI TxPDO-Map Inputs 1x Ch.1 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x0A (10dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x01 (No of input events)) | UINT32 | RO | 0x6081:01, 8
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x09 (Input state)) | UINT32 | RO | 0x6081:09, 1
1A0B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6081:0A, 1
1A0B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6081:0F, 2
1A0B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6081:11, 8
1A0B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6081:12, 8
1A0B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6081:21, 1
1A0B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6081 (MTI inputs Ch.1), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6081:41, 32
Index 1A0C MTI TxPDO-Map Inputs 10x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | MTI TxPDO-Map Inputs 10x Ch.2 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x1C (28dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6091:22, 1
1A0C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6091:23, 1
1A0C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6091:24, 1
1A0C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6091:25, 1
1A0C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x6091:26, 1
1A0C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x6091:27, 1
1A0C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x6091:28, 1
1A0C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x6091:29, 1
1A0C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x6091:2A, 1
1A0C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A0C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
1A0C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6091:42, 32
1A0C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6091:43, 32
1A0C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6091:44, 32
1A0C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6091:45, 32
1A0C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x6091:46, 32
1A0C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x6091:47, 32
1A0C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x6091:48, 32
1A0C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x6091:49, 32
1A0C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x6091:4A, 32
Index 1A0D MTI TxPDO-Map Inputs 5x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | MTI TxPDO-Map Inputs 5x Ch.2 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x12 (18dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6091:22, 1
1A0D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x6091:23, 1
1A0D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x6091:24, 1
1A0D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x6091:25, 1
1A0D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A0D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
1A0D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6091:42, 32
1A0D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x6091:43, 32
1A0D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x6091:44, 32
1A0D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x6091:45, 32
Index 1A0E MTI TxPDO-Map Inputs 2x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0E:0 | MTI TxPDO-Map Inputs 2x Ch.2 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x0C (12dez)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x6091:22, 1
1A0E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A0E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
1A0E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x6091:42, 32
Index 1A0F MTI TxPDO-Map Inputs 1x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0F:0 | MTI TxPDO-Map Inputs 1x Ch.2 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x0A (10dez)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x01 (No of input events)) | UINT32 | RO | 0x6091:01, 8
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x09 (Input state)) | UINT32 | RO | 0x6091:09, 1
1A0F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x6091:0A, 1
1A0F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A0F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6091:0F, 2
1A0F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x6091:11, 8
1A0F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x6091:12, 8
1A0F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x6091:21, 1
1A0F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A0F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x6091 (MTI inputs Ch.2), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x6091:41, 32
Index 1A10 MTI TxPDO-Map Inputs 10x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | MTI TxPDO-Map Inputs 10x Ch.3 | PDO Mapping TxPDO 17 | UINT8 | RO | 0x1C (28dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A10:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A10:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A10:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60A1:22, 1
1A10:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60A1:23, 1
1A10:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60A1:24, 1
1A10:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60A1:25, 1
1A10:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60A1:26, 1
1A10:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60A1:27, 1
1A10:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60A1:28, 1
1A10:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60A1:29, 1
1A10:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60A1:2A, 1
1A10:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A10:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
1A10:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60A1:42, 32
1A10:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60A1:43, 32
1A10:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60A1:44, 32
1A10:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60A1:45, 32
1A10:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60A1:46, 32
1A10:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60A1:47, 32
1A10:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60A1:48, 32
1A10:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60A1:49, 32
1A10:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60A1:4A, 32
Index 1A11 MTI TxPDO-Map Inputs 5x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A11:0 | MTI TxPDO-Map Inputs 5x Ch.3 | PDO Mapping TxPDO 18 | UINT8 | RO | 0x12 (18dez)
1A11:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A11:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A11:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A11:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A11:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A11:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A11:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A11:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A11:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60A1:22, 1
1A11:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60A1:23, 1
1A11:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60A1:24, 1
1A11:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60A1:25, 1
1A11:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A11:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
1A11:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60A1:42, 32
1A11:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60A1:43, 32
1A11:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60A1:44, 32
1A11:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60A1:45, 32
Index 1A12 MTI TxPDO-Map Inputs 2x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A12:0 | MTI TxPDO-Map Inputs 2x Ch.3 | PDO Mapping TxPDO 19 | UINT8 | RO | 0x0C (12dez)
1A12:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A12:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A12:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A12:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A12:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A12:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A12:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A12:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A12:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60A1:22, 1
1A12:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A12:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
1A12:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60A1:42, 32
Index 1A13 MTI TxPDO-Map Inputs 1x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A13:0 | MTI TxPDO-Map Inputs 1x Ch.3 | PDO Mapping TxPDO 20 | UINT8 | RO | 0x0A (10dez)
1A13:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x01 (No of input events)) | UINT32 | RO | 0x60A1:01, 8
1A13:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x09 (Input state)) | UINT32 | RO | 0x60A1:09, 1
1A13:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60A1:0A, 1
1A13:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A13:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60A1:0F, 2
1A13:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60A1:11, 8
1A13:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60A1:12, 8
1A13:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60A1:21, 1
1A13:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A13:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60A1 (MTI inputs Ch.3), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60A1:41, 32
Index 1A14 MTI TxPDO-Map Inputs 10x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A14:0 | MTI TxPDO-Map Inputs 10x Ch.4 | PDO Mapping TxPDO 21 | UINT8 | RO | 0x1C (28dez)
1A14:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A14:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A14:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A14:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A14:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A14:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A14:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A14:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A14:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60B1:22, 1
1A14:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60B1:23, 1
1A14:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60B1:24, 1
1A14:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60B1:25, 1
1A14:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60B1:26, 1
1A14:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60B1:27, 1
1A14:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60B1:28, 1
1A14:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60B1:29, 1
1A14:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60B1:2A, 1
1A14:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A14:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
1A14:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60B1:42, 32
1A14:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60B1:43, 32
1A14:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60B1:44, 32
1A14:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60B1:45, 32
1A14:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60B1:46, 32
1A14:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60B1:47, 32
1A14:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60B1:48, 32
1A14:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60B1:49, 32
1A14:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60B1:4A, 32
Index 1A15 MTI TxPDO-Map Inputs 5x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A15:0 | MTI TxPDO-Map Inputs 5x Ch.4 | PDO Mapping TxPDO 22 | UINT8 | RO | 0x12 (18dez)
1A15:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A15:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A15:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A15:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A15:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A15:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A15:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A15:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A15:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60B1:22, 1
1A15:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60B1:23, 1
1A15:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60B1:24, 1
1A15:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60B1:25, 1
1A15:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A15:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
1A15:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60B1:42, 32
1A15:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60B1:43, 32
1A15:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60B1:44, 32
1A15:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60B1:45, 32
Index 1A16 MTI TxPDO-Map Inputs 2x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A16:0 | MTI TxPDO-Map Inputs 2x Ch.4 | PDO Mapping TxPDO 23 | UINT8 | RO | 0x0C (12dez)
1A16:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A16:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A16:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A16:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A16:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A16:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A16:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A16:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A16:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60B1:22, 1
1A16:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A16:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
1A16:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60B1:42, 32
Index 1A17 MTI TxPDO-Map Inputs 1x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A17:0 | MTI TxPDO-Map Inputs 1x Ch.4 | PDO Mapping TxPDO 24 | UINT8 | RO | 0x0A (10dez)
1A17:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x01 (No of input events)) | UINT32 | RO | 0x60B1:01, 8
1A17:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x09 (Input state)) | UINT32 | RO | 0x60B1:09, 1
1A17:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60B1:0A, 1
1A17:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A17:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60B1:0F, 2
1A17:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60B1:11, 8
1A17:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60B1:12, 8
1A17:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60B1:21, 1
1A17:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A17:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60B1 (MTI inputs Ch.4), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60B1:41, 32
Index 1A18 MTI TxPDO-Map Inputs 10x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A18:0 | MTI TxPDO-Map Inputs 10x Ch.5 | PDO Mapping TxPDO 25 | UINT8 | RO | 0x1C (28dez)
1A18:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A18:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A18:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A18:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A18:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A18:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A18:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A18:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A18:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60C1:22, 1
1A18:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60C1:23, 1
1A18:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60C1:24, 1
1A18:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60C1:25, 1
1A18:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60C1:26, 1
1A18:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60C1:27, 1
1A18:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60C1:28, 1
1A18:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60C1:29, 1
1A18:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60C1:2A, 1
1A18:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A18:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
1A18:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60C1:42, 32
1A18:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60C1:43, 32
1A18:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60C1:44, 32
1A18:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60C1:45, 32
1A18:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60C1:46, 32
1A18:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60C1:47, 32
1A18:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60C1:48, 32
1A18:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60C1:49, 32
1A18:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60C1:4A, 32
Index 1A19 MTI TxPDO-Map Inputs 5x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A19:0 | MTI TxPDO-Map Inputs 5x Ch.5 | PDO Mapping TxPDO 26 | UINT8 | RO | 0x12 (18dez)
1A19:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A19:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A19:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A19:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A19:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A19:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A19:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A19:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A19:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60C1:22, 1
1A19:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60C1:23, 1
1A19:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60C1:24, 1
1A19:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60C1:25, 1
1A19:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A19:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
1A19:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60C1:42, 32
1A19:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60C1:43, 32
1A19:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60C1:44, 32
1A19:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60C1:45, 32
Index 1A1A MTI TxPDO-Map Inputs 2x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1A:0 | MTI TxPDO-Map Inputs 2x Ch.5 | PDO Mapping TxPDO 27 | UINT8 | RO | 0x0C (12dez)
1A1A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A1A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A1A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A1A:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1A:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A1A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A1A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A1A:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A1A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60C1:22, 1
1A1A:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1A:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
1A1A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60C1:42, 32
Index 1A1B MTI TxPDO-Map Inputs 1x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1B:0 | MTI TxPDO-Map Inputs 1x Ch.5 | PDO Mapping TxPDO 28 | UINT8 | RO | 0x0A (10dez)
1A1B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x01 (No of input events)) | UINT32 | RO | 0x60C1:01, 8
1A1B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x09 (Input state)) | UINT32 | RO | 0x60C1:09, 1
1A1B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60C1:0A, 1
1A1B:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1B:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60C1:0F, 2
1A1B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60C1:11, 8
1A1B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60C1:12, 8
1A1B:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60C1:21, 1
1A1B:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1B:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60C1 (MTI inputs Ch.5), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60C1:41, 32
Index 1A1C MTI TxPDO-Map Inputs 10x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1C:0 | MTI TxPDO-Map Inputs 10x Ch.6 | PDO Mapping TxPDO 29 | UINT8 | RO | 0x1C (28dez)
1A1C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1C:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1C:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1C:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60D1:22, 1
1A1C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60D1:23, 1
1A1C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60D1:24, 1
1A1C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60D1:25, 1
1A1C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60D1:26, 1
1A1C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60D1:27, 1
1A1C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60D1:28, 1
1A1C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60D1:29, 1
1A1C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60D1:2A, 1
1A1C:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A1C:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
1A1C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60D1:42, 32
1A1C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60D1:43, 32
1A1C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60D1:44, 32
1A1C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60D1:45, 32
1A1C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60D1:46, 32
1A1C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60D1:47, 32
1A1C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60D1:48, 32
1A1C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60D1:49, 32
1A1C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60D1:4A, 32
Index 1A1D MTI TxPDO-Map Inputs 5x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1D:0 | MTI TxPDO-Map Inputs 5x Ch.6 | PDO Mapping TxPDO 30 | UINT8 | RO | 0x12 (18dez)
1A1D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1D:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1D:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1D:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60D1:22, 1
1A1D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60D1:23, 1
1A1D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60D1:24, 1
1A1D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60D1:25, 1
1A1D:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A1D:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
1A1D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60D1:42, 32
1A1D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60D1:43, 32
1A1D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60D1:44, 32
1A1D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60D1:45, 32
Index 1A1E MTI TxPDO-Map Inputs 2x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1E:0 | MTI TxPDO-Map Inputs 2x Ch.6 | PDO Mapping TxPDO 31 | UINT8 | RO | 0x0C (12dez)
1A1E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1E:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1E:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1E:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60D1:22, 1
1A1E:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A1E:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
1A1E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60D1:42, 32
Index 1A1F MTI TxPDO-Map Inputs 1x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A1F:0 | MTI TxPDO-Map Inputs 1x Ch.6 | PDO Mapping TxPDO 32 | UINT8 | RO | 0x0A (10dez)
1A1F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x01 (No of input events)) | UINT32 | RO | 0x60D1:01, 8
1A1F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x09 (Input state)) | UINT32 | RO | 0x60D1:09, 1
1A1F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60D1:0A, 1
1A1F:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A1F:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60D1:0F, 2
1A1F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60D1:11, 8
1A1F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60D1:12, 8
1A1F:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60D1:21, 1
1A1F:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A1F:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60D1 (MTI inputs Ch.6), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60D1:41, 32
Index 1A20 MTI TxPDO-Map Inputs 10x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A20:0 | MTI TxPDO-Map Inputs 10x Ch.7 | PDO Mapping TxPDO 33 | UINT8 | RO | 0x1C (28dez)
1A20:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A20:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A20:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A20:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A20:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A20:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A20:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A20:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A20:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60E1:22, 1
1A20:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60E1:23, 1
1A20:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60E1:24, 1
1A20:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60E1:25, 1
1A20:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60E1:26, 1
1A20:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60E1:27, 1
1A20:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60E1:28, 1
1A20:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60E1:29, 1
1A20:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60E1:2A, 1
1A20:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A20:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
1A20:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60E1:42, 32
1A20:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60E1:43, 32
1A20:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60E1:44, 32
1A20:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60E1:45, 32
1A20:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60E1:46, 32
1A20:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60E1:47, 32
1A20:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60E1:48, 32
1A20:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60E1:49, 32
1A20:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60E1:4A, 32
Index 1A21 MTI TxPDO-Map Inputs 5x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A21:0 | MTI TxPDO-Map Inputs 5x Ch.7 | PDO Mapping TxPDO 34 | UINT8 | RO | 0x12 (18dez)
1A21:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A21:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A21:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A21:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A21:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A21:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A21:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A21:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A21:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60E1:22, 1
1A21:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60E1:23, 1
1A21:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60E1:24, 1
1A21:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60E1:25, 1
1A21:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A21:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
1A21:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60E1:42, 32
1A21:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60E1:43, 32
1A21:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60E1:44, 32
1A21:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60E1:45, 32
Index 1A22 MTI TxPDO-Map Inputs 2x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A22:0 | MTI TxPDO-Map Inputs 2x Ch.7 | PDO Mapping TxPDO 35 | UINT8 | RO | 0x0C (12dez)
1A22:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A22:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A22:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A22:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A22:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A22:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A22:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A22:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A22:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60E1:22, 1
1A22:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A22:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
1A22:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60E1:42, 32
Index 1A23 MTI TxPDO-Map Inputs 1x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A23:0 | MTI TxPDO-Map Inputs 1x Ch.7 | PDO Mapping TxPDO 36 | UINT8 | RO | 0x0A (10dez)
1A23:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x01 (No of input events)) | UINT32 | RO | 0x60E1:01, 8
1A23:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x09 (Input state)) | UINT32 | RO | 0x60E1:09, 1
1A23:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60E1:0A, 1
1A23:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A23:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60E1:0F, 2
1A23:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60E1:11, 8
1A23:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60E1:12, 8
1A23:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60E1:21, 1
1A23:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A23:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60E1 (MTI inputs Ch.7), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60E1:41, 32
Index 1A24 MTI TxPDO-Map Inputs 10x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A24:0 | MTI TxPDO-Map Inputs 10x Ch.8 | PDO Mapping TxPDO 37 | UINT8 | RO | 0x1C (28dez)
1A24:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A24:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A24:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A24:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A24:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A24:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A24:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A24:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A24:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60F1:22, 1
1A24:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60F1:23, 1
1A24:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60F1:24, 1
1A24:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60F1:25, 1
1A24:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x26 (Input event state 6)) | UINT32 | RO | 0x60F1:26, 1
1A24:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x27 (Input event state 7)) | UINT32 | RO | 0x60F1:27, 1
1A24:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x28 (Input event state 8)) | UINT32 | RO | 0x60F1:28, 1
1A24:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x29 (Input event state 9)) | UINT32 | RO | 0x60F1:29, 1
1A24:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x2A (Input event state 10)) | UINT32 | RO | 0x60F1:2A, 1
1A24:12 | SubIndex 018 | 18. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1A24:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
1A24:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60F1:42, 32
1A24:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60F1:43, 32
1A24:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60F1:44, 32
1A24:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60F1:45, 32
1A24:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x46 (Input event time 6)) | UINT32 | RO | 0x60F1:46, 32
1A24:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x47 (Input event time 7)) | UINT32 | RO | 0x60F1:47, 32
1A24:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x48 (Input event time 8)) | UINT32 | RO | 0x60F1:48, 32
1A24:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x49 (Input event time 9)) | UINT32 | RO | 0x60F1:49, 32
1A24:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x4A (Input event time 10)) | UINT32 | RO | 0x60F1:4A, 32
Index 1A25 MTI TxPDO-Map Inputs 5x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A25:0 | MTI TxPDO-Map Inputs 5x Ch.8 | PDO Mapping TxPDO 38 | UINT8 | RO | 0x12 (18dez)
1A25:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A25:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A25:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A25:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A25:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A25:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A25:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A25:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A25:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60F1:22, 1
1A25:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x23 (Input event state 3)) | UINT32 | RO | 0x60F1:23, 1
1A25:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x24 (Input event state 4)) | UINT32 | RO | 0x60F1:24, 1
1A25:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x25 (Input event state 5)) | UINT32 | RO | 0x60F1:25, 1
1A25:0D | SubIndex 013 | 13. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1A25:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
1A25:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60F1:42, 32
1A25:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x43 (Input event time 3)) | UINT32 | RO | 0x60F1:43, 32
1A25:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x44 (Input event time 4)) | UINT32 | RO | 0x60F1:44, 32
1A25:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x45 (Input event time 5)) | UINT32 | RO | 0x60F1:45, 32
Index 1A26 MTI TxPDO-Map Inputs 2x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A26:0 | MTI TxPDO-Map Inputs 2x Ch.8 | PDO Mapping TxPDO 39 | UINT8 | RO | 0x0C (12dez)
1A26:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A26:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A26:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A26:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A26:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A26:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A26:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A26:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A26:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x22 (Input event state 2)) | UINT32 | RO | 0x60F1:22, 1
1A26:0A | SubIndex 010 | 10. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1A26:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
1A26:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x42 (Input event time 2)) | UINT32 | RO | 0x60F1:42, 32
Index 1A27 MTI TxPDO-Map Inputs 1x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A27:0 | MTI TxPDO-Map Inputs 1x Ch.8 | PDO Mapping TxPDO 40 | UINT8 | RO | 0x0A (10dez)
1A27:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x01 (No of input events)) | UINT32 | RO | 0x60F1:01, 8
1A27:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x09 (Input state)) | UINT32 | RO | 0x60F1:09, 1
1A27:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0A (Input buffer overflow)) | UINT32 | RO | 0x60F1:0A, 1
1A27:04 | SubIndex 004 | 4. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1A27:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x60F1:0F, 2
1A27:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x11 (Events in input buffer)) | UINT32 | RO | 0x60F1:11, 8
1A27:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x12 (Input order feedback)) | UINT32 | RO | 0x60F1:12, 8
1A27:08 | SubIndex 008 | 8. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x21 (Input event state 1)) | UINT32 | RO | 0x60F1:21, 1
1A27:09 | SubIndex 009 | 9. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1A27:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x60F1 (MTI inputs Ch.8), entry 0x41 (Input event time 1)) | UINT32 | RO | 0x60F1:41, 32
Index 1A28 TSO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A28:0 | TSO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 41 | UINT8 | RO | 0x02 (2dez)
1A28:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6100 (TSO Inputs Ch.1), entry 0x01 (Feedback)) | UINT32 | RO | 0x6100:01, 1
1A28:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A29 TSO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A29:0 | TSO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 42 | UINT8 | RO | 0x02 (2dez)
1A29:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6110 (TSO Inputs Ch.2), entry 0x01 (Feedback)) | UINT32 | RO | 0x6110:01, 1
1A29:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2A TSO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2A:0 | TSO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 43 | UINT8 | RO | 0x02 (2dez)
1A2A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6120 (TSO Inputs Ch.3), entry 0x01 (Feedback)) | UINT32 | RO | 0x6120:01, 1
1A2A:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2B TSO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2B:0 | TSO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 44 | UINT8 | RO | 0x02 (2dez)
1A2B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6130 (TSO Inputs Ch.4), entry 0x01 (Feedback)) | UINT32 | RO | 0x6130:01, 1
1A2B:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2C TSO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2C:0 | TSO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 45 | UINT8 | RO | 0x02 (2dez)
1A2C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6140 (TSO Inputs Ch.5), entry 0x01 (Feedback)) | UINT32 | RO | 0x6140:01, 1
1A2C:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2D TSO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2D:0 | TSO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 46 | UINT8 | RO | 0x02 (2dez)
1A2D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6150 (TSO Inputs Ch.6), entry 0x01 (Feedback)) | UINT32 | RO | 0x6150:01, 1
1A2D:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2E TSO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2E:0 | TSO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 47 | UINT8 | RO | 0x02 (2dez)
1A2E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6160 (TSO Inputs Ch.7), entry 0x01 (Feedback)) | UINT32 | RO | 0x6160:01, 1
1A2E:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A2F TSO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A2F:0 | TSO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 48 | UINT8 | RO | 0x02 (2dez)
1A2F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6170 (TSO Inputs Ch.8), entry 0x01 (Feedback)) | UINT32 | RO | 0x6170:01, 1
1A2F:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A30 TSI TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A30:0 | TSI TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 49 | UINT8 | RO | 0x06 (6dez)
1A30:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x01 (Input)) | UINT32 | RO | 0x6180:01, 1
1A30:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A30:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x09 (Status)) | UINT32 | RO | 0x6180:09, 8
1A30:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A30:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6180:41, 64
1A30:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6180 (TSI Inputs Ch.1), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6180:42, 64
Index 1A31 TSI TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A31:0 | TSI TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 50 | UINT8 | RO | 0x06 (6dez)
1A31:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x01 (Input)) | UINT32 | RO | 0x6190:01, 1
1A31:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A31:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x09 (Status)) | UINT32 | RO | 0x6190:09, 8
1A31:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A31:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x41 (LatchPos)) | UINT32 | RO | 0x6190:41, 64
1A31:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6190 (TSI Inputs Ch.2), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x6190:42, 64
Index 1A32 TSI TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A32:0 | TSI TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 51 | UINT8 | RO | 0x06 (6dez)
1A32:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x01 (Input)) | UINT32 | RO | 0x61A0:01, 1
1A32:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A32:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x09 (Status)) | UINT32 | RO | 0x61A0:09, 8
1A32:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A32:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61A0:41, 64
1A32:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61A0 (TSI Inputs Ch.3), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61A0:42, 64
Index 1A33 TSI TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A33:0 | TSI TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 52 | UINT8 | RO | 0x06 (6dez)
1A33:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x01 (Input)) | UINT32 | RO | 0x61B0:01, 1
1A33:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A33:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x09 (Status)) | UINT32 | RO | 0x61B0:09, 8
1A33:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A33:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61B0:41, 64
1A33:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61B0 (TSI Inputs Ch.4), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61B0:42, 64
Index 1A34 TSI TxPDO-Map Inputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A34:0 | TSI TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 53 | UINT8 | RO | 0x06 (6dez)
1A34:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x01 (Input)) | UINT32 | RO | 0x61C0:01, 1
1A34:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A34:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x09 (Status)) | UINT32 | RO | 0x61C0:09, 8
1A34:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A34:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61C0:41, 64
1A34:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61C0 (TSI Inputs Ch.5), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61C0:42, 64
Index 1A35 TSI TxPDO-Map Inputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A35:0 | TSI TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 54 | UINT8 | RO | 0x06 (6dez)
1A35:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x01 (Input)) | UINT32 | RO | 0x61D0:01, 1
1A35:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A35:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x09 (Status)) | UINT32 | RO | 0x61D0:09, 8
1A35:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A35:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61D0:41, 64
1A35:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61D0 (TSI Inputs Ch.6), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61D0:42, 64
Index 1A36 TSI TxPDO-Map Inputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A36:0 | TSI TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 55 | UINT8 | RO | 0x06 (6dez)
1A36:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x01 (Input)) | UINT32 | RO | 0x61E0:01, 1
1A36:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A36:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x09 (Status)) | UINT32 | RO | 0x61E0:09, 8
1A36:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A36:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61E0:41, 64
1A36:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61E0 (TSI Inputs Ch.7), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61E0:42, 64
Index 1A37 TSI TxPDO-Map Inputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A37:0 | TSI TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 56 | UINT8 | RO | 0x06 (6dez)
1A37:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x01 (Input)) | UINT32 | RO | 0x61F0:01, 1
1A37:02 | SubIndex 002 | 2. PDO Mapping entry (7 bits align) | UINT32 | RO | 0x0000:00, 7
1A37:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x09 (Status)) | UINT32 | RO | 0x61F0:09, 8
1A37:04 | SubIndex 004 | 4. PDO Mapping entry (48 bits align) | UINT32 | RO | 0x0000:00, 48
1A37:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x41 (LatchPos)) | UINT32 | RO | 0x61F0:41, 64
1A37:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x61F0 (TSI Inputs Ch.8), entry 0x42 (LatchNeg)) | UINT32 | RO | 0x61F0:42, 64
Index 1A38 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A38:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 57 | UINT8 | RO | 0x06 (6dez)
1A38:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A38:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A38:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x03 (Overtemperature)) | UINT32 | RO | 0xF611:03, 1
1A38:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x04 (Checksum error)) | UINT32 | RO | 0xF611:04, 1
1A38:05 | SubIndex 005 | 5. PDO Mapping entry (60 bits align) | UINT32 | RO | 0x0000:00, 60
1A38:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x21 (SysTime)) | UINT32 | RO | 0xF611:21, 64
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x10 (16dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1608 (5640dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x160C (5644dez)
1C12:05 | SubIndex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1610 (5648dez)
1C12:06 | SubIndex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1614 (5652dez)
1C12:07 | SubIndex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1618 (5656dez)
1C12:08 | SubIndex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x161C (5660dez)
1C12:09 | SubIndex 009 | 9. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1620 (5664dez)
1C12:0A | SubIndex 010 | 10. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1621 (5665dez)
1C12:0B | SubIndex 011 | 11. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1622 (5666dez)
1C12:0C | SubIndex 012 | 12. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1623 (5667dez)
1C12:0D | SubIndex 013 | 13. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1624 (5668dez)
1C12:0E | SubIndex 014 | 14. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1625 (5669dez)
1C12:0F | SubIndex 015 | 15. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1626 (5670dez)
1C12:10 | SubIndex 016 | 16. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1627 (5671dez)
1C12:11 | SubIndex 017 | 17. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:12 | SubIndex 018 | 18. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:13 | SubIndex 019 | 19. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:14 | SubIndex 020 | 20. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:15 | SubIndex 021 | 21. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:16 | SubIndex 022 | 22. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:17 | SubIndex 023 | 23. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:18 | SubIndex 024 | 24. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:19 | SubIndex 025 | 25. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1A | SubIndex 026 | 26. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1B | SubIndex 027 | 27. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:1C | SubIndex 028 | 28. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1D | SubIndex 029 | 29. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1E | SubIndex 030 | 30. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1F | SubIndex 031 | 31. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:20 | SubIndex 032 | 32. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:21 | SubIndex 033 | 33. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:22 | SubIndex 034 | 34. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:23 | SubIndex 035 | 35. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:24 | SubIndex 036 | 36. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:25 | SubIndex 037 | 37. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:26 | SubIndex 038 | 38. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:27 | SubIndex 039 | 39. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:28 | SubIndex 040 | 40. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:29 | SubIndex 041 | 41. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:2A | SubIndex 042 | 42. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:2B | SubIndex 043 | 43. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:2C | SubIndex 044 | 44. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:2D | SubIndex 045 | 45. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:2E | SubIndex 046 | 46. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:2F | SubIndex 047 | 47. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:30 | SubIndex 048 | 48. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x10 (16dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:06 | SubIndex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A05 (6661dez)
1C13:07 | SubIndex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:08 | SubIndex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A07 (6663dez)
1C13:09 | SubIndex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A08 (6664dez)
1C13:0A | SubIndex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A0C (6668dez)
1C13:0B | SubIndex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A10 (6672dez)
1C13:0C | SubIndex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A14 (6676dez)
1C13:0D | SubIndex 013 | 13. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A18 (6680dez)
1C13:0E | SubIndex 014 | 14. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A1C (6684dez)
1C13:0F | SubIndex 015 | 15. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A20 (6688dez)
1C13:10 | SubIndex 016 | 16. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A24 (6692dez)
1C13:11 | SubIndex 017 | 17. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:12 | SubIndex 018 | 18. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:13 | SubIndex 019 | 19. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:14 | SubIndex 020 | 20. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:15 | SubIndex 021 | 21. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:16 | SubIndex 022 | 22. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:17 | SubIndex 023 | 23. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:18 | SubIndex 024 | 24. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:19 | SubIndex 025 | 25. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1A | SubIndex 026 | 26. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1B | SubIndex 027 | 27. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:1C | SubIndex 028 | 28. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1D | SubIndex 029 | 29. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1E | SubIndex 030 | 30. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:1F | SubIndex 031 | 31. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:20 | SubIndex 032 | 32. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:21 | SubIndex 033 | 33. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:22 | SubIndex 034 | 34. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:23 | SubIndex 035 | 35. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:24 | SubIndex 036 | 36. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:25 | SubIndex 037 | 37. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:26 | SubIndex 038 | 38. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:27 | SubIndex 039 | 39. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:28 | SubIndex 040 | 40. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:29 | SubIndex 041 | 41. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:2A | SubIndex 042 | 42. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:2B | SubIndex 043 | 43. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:2C | SubIndex 044 | 44. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:2D | SubIndex 045 | 45. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:2E | SubIndex 046 | 46. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:2F | SubIndex 047 | 47. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:30 | SubIndex 048 | 48. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:31 | SubIndex 049 | 49. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:32 | SubIndex 050 | 50. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:33 | SubIndex 051 | 51. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:34 | SubIndex 052 | 52. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:35 | SubIndex 053 | 53. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:36 | SubIndex 054 | 54. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:37 | SubIndex 055 | 55. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:38 | SubIndex 056 | 56. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:39 | SubIndex 057 | 57. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C3500 (800000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x0804 (2052dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00001F40 (8000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000C3500 (800000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0804 (2052dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00001F40 (8000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0020 (32dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | MDP Profile | UINT8 | RW | 0x20 (32dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x000000DC (220dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x000000DC (220dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000000DC (220dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x000000DC (220dez)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x000000DC (220dez)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x000000DC (220dez)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x000000DC (220dez)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x000000DC (220dez)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x00000078 (120dez)
F010:0A | SubIndex 010 |  | UINT32 | RW | 0x00000078 (120dez)
F010:0B | SubIndex 011 |  | UINT32 | RW | 0x00000078 (120dez)
F010:0C | SubIndex 012 |  | UINT32 | RW | 0x00000078 (120dez)
F010:0D | SubIndex 013 |  | UINT32 | RW | 0x00000078 (120dez)
F010:0E | SubIndex 014 |  | UINT32 | RW | 0x00000078 (120dez)
F010:0F | SubIndex 015 |  | UINT32 | RW | 0x00000078 (120dez)
F010:10 | SubIndex 016 |  | UINT32 | RW | 0x00000078 (120dez)
F010:11 | SubIndex 017 |  | UINT32 | RW | 0x000000DD (221dez)
F010:12 | SubIndex 018 |  | UINT32 | RW | 0x000000DD (221dez)
F010:13 | SubIndex 019 |  | UINT32 | RW | 0x000000DD (221dez)
F010:14 | SubIndex 020 |  | UINT32 | RW | 0x000000DD (221dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:15 | SubIndex 021 |  | UINT32 | RW | 0x000000DD (221dez)
F010:16 | SubIndex 022 |  | UINT32 | RW | 0x000000DD (221dez)
F010:17 | SubIndex 023 |  | UINT32 | RW | 0x000000DD (221dez)
F010:18 | SubIndex 024 |  | UINT32 | RW | 0x000000DD (221dez)
F010:19 | SubIndex 025 |  | UINT32 | RW | 0x00000079 (121dez)
F010:1A | SubIndex 026 |  | UINT32 | RW | 0x00000079 (121dez)
F010:1B | SubIndex 027 |  | UINT32 | RW | 0x00000079 (121dez)
F010:1C | SubIndex 028 |  | UINT32 | RW | 0x00000079 (121dez)
F010:1D | SubIndex 029 |  | UINT32 | RW | 0x00000079 (121dez)
F010:1E | SubIndex 030 |  | UINT32 | RW | 0x00000079 (121dez)
F010:1F | SubIndex 031 |  | UINT32 | RW | 0x00000079 (121dez)
F010:20 | SubIndex 032 |  | UINT32 | RW | 0x00000079 (121dez)


EL2258

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258
EL2258
Weiterführende Informationen
•
Objektbeschreibung und Parametrierung
•
Objektbeschreibung - Standardobjekte


Objektbeschreibung und Parametrierung

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung
Objektbeschreibung und Parametrierung
EtherCAT XML Device Description
Die Darstellung entspricht der Anzeige der CoE-Objekte aus der EtherCAT XML Device Description. Es wird empfohlen, die entsprechende aktuellste XML-Datei im Download-Bereich auf der Beckhoff Website herunterzuladen und entsprechend der Installationsanweisungen zu installieren.
Parametrierung über das CoE-Verzeichnis (CAN over EtherCAT)
Die Parametrierung der Klemme wird über den CoE - Online Reiter (mit Doppelklick auf das entsprechende Objekt) bzw. über den Prozessdatenreiter (Zuordnung der PDOs) vorgenommen. Beachten Sie bei Verwendung/Manipulation der CoE-Parameter die allgemeinen CoE-Hinweise:
- StartUp-Liste führen für den Austauschfall
- Unterscheidung zwischen Online/Offline Dictionary, Vorhandensein aktueller XML-Beschreibung
- "CoE-Reload" zum Zurücksetzen der Veränderungen
Weiterführende Informationen
•
Restore-Objekt
•
Konfigurationsdaten
•
Eingangsdaten
•
Ausgangsdaten
•
Diagnostikdaten
•
Informationsdaten
•
Kommando-Objekt


Restore-Objekt

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Restore-Objekt
Restore-Objekt
Index 1011 Restore default parameters
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1011:0 | Restore default parameters | Herstellen der Defaulteinstellungen | UINT8 | RO | 0x01 (1dez)
1011:01 | SubIndex 001 | Wenn Sie dieses Objekt im Set Value Dialog auf "0x64616F6C" setzen, werden alle Backup Objekte wieder in den Auslieferungszustand gesetzt. | UINT32 | RW | 0x00000000 (0dez)


Konfigurationsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Konfigurationsdaten
Konfigurationsdaten
Index 8pp1 MTO Settings (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung |  | Datentyp | Flags | Default
8pp1:0 | MTO Settings |  |  | UINT8 | RO | 0x12 (18dez)
8pp1:01 | Use as +24 V power supply | Schaltet den Ausgang dauerhaft ein. Der Kanal kann nicht für die Abarbeitung von Timestamp-Ereignissen verwendet werden. Der Ausgang fällt ab, sobald der EtherCAT-Status nicht OP ist. |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:02 | Enable manual operation | Über dieses Objekt kann der Ausgang manuell geschaltet werden. |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:03 | Enable time check | Über dieses Bit kann bestimmt werden, wie mit Schaltaufträgen verfahren werden soll, die vor der aktuellen Zeit platziert wurden (weitere Erläuterung siehe hier). |  | BOOLEAN | RW | 0x00 (0dez)
8pp1:11 | Buffer reset behaviour | Legt das Verhalten des "Output buffer reset" Bits fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Reset on rising edge: Der Buffer wird mit einer steigenden Flanke von "Output buffer reset" gelöscht
 |  | 1 | Reset on high level: Der Buffer wird mit einer steigenden Flanke von "Output buffer reset" gelöscht und nimmt keine neuen Werte auf, bis "Output buffer reset" wieder zurückgesetzt wird.
8pp1:12 | Buffer overflow behaviour | Legt das Verhalten beim Überlauf des Puffers fest Erlaubte Werte: |  | UINT16 | RW | 0x0000 (0dez)
 |  | 0 | Lock buffer: Neue Ereignisse werden verworfen
 |  | 1 | Overwrite oldest value: Neue Ereignisse überschreiben die letzten Events im Puffer
Index 8ppF MTO Vendor data (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | MTO Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Ausgabezeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Ausgabezeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
Index 8ppF TSO Vendor data (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
8ppF:0 | TSO Vendor data |  | UINT8 | RO | 0x12 (18dez)
8ppF:11 | Offset pos | Über dieses Objekt lässt sich der Ausgabezeitpunkt der steigenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)
8ppF:12 | Offset neg | Über dieses Objekt lässt sich der Ausgabezeitpunkt der fallenden Flanken verschieben. Diese Einstellung ist dem Hersteller vorbehalten. | INT32 | RW | 0x00000000 (0dez)


Eingangsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Eingangsdaten
Eingangsdaten
Index 6pp0 MTO inputs (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | MTO inputs |  | UINT8 | RO | 0x00 (0dez)
6pp0:01 | Output short circuit | Der Kanal meldet einen Kurzschluss | BOOLEAN | RO | 0x00 (0dez)
6pp0:02 | Output buffer overflow | Es wurden mehr Events in den Puffer geschrieben, als dieser aufnehmen kann | BOOLEAN | RO | 0x00 (0dez)
6pp0:03 | Output state | Aktueller Zustand des Ausgangs zum Zeitpunkt des Prozessdatenzyklusses | BOOLEAN | RO | 0x00 (0dez)
6pp0:0F | Input cycle counter | Wird mit jedem Prozessdatenzyklus inkrementiert und läuft nach seinem Maximalwert von 3 auf 0 über. | BIT2 | RO | 0x00 (0dez)
6pp0:11 | Output order feedback | Dieses Byte spiegelt den Zustand des "Output order counter" Bytes. | UINT8 | RO | 0x00 (0dez)
6pp0:12 | Events in output buffer | Meldet die Anzahl der aktuell noch im Buffer befindlichen Schaltaufträge zurück | UINT8 | RO | 0x00 (0dez)
Index 6pp0 TSO Inputs (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
6pp0:0 | TSO Inputs |  | UINT8 | RO | 0x00 (0dez)
6pp0:01 | Feedback | Gibt den aktuellen Wert des Ausgangs zurück | BOOLEAN | RO | 0x00 (0dez)
Index F611 DEV Inputs
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F611:0 | DEV Inputs |  | UINT8 | RO | 0x00 (0dez)
F611:02 | Undervoltage Up | Die Nennspannung an den Powerkontakten wurde erheblich unterschritten | BOOLEAN | RO | 0x00 (0dez)
F611:03 | Overtemperature | Übertemperaturfehler: Die Temperatur der Ein- oder Ausgangsbausteine ist zu hoch. Bei Ausgangsklemmen sollte geprüft werden, ob nicht mindestens ein Kanal einen Kurzschluss treibt. | BOOLEAN | RO | 0x00 (0dez)
F611:04 | Checksum error | Bei der internen Datenübertragung ist ein Fehler aufgetreten | BOOLEAN | RO | 0x00 (0dez)
F611:21 | SysTime | DC-Zeitstempel des letzten Inputmappings. Dieser Zeitstempel sollte nicht als Referenz genutzt werden (Informationen zu DC-Referenzzeiten). | UINT64 | RO |


Ausgangsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Ausgangsdaten
Ausgangsdaten
Index 7pp1 MTO outputs (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
7pp1:0
MTO outputs
UINT8
RO
0x00 (0dez)
7pp1:01
Output buffer reset
Entfernt alle im Puffer befindlichen Elemente
Das Löschen kann durch eine steigende Flanke oder kontinuierlich durch das Anlegen einer 1 an diesem Bit erzielt werden. Das Verhalten kann über das CoE-Objekt 0x8pp1:11 parametriert werden.
BOOLEAN
RO
0x00 (0dez)
7pp1:02
Manual output state
Über dieses Bit kann der Ausgang ohne die Verwendung von Timestamps geschaltet werden.
▪
Möglichkeit 1: Das CoE-Objekt 0x8pp1:02 ("Enable manual operation") wird auf true gesetzt. Der Timestamp-Betrieb ist nun ausgeschaltet und der Ausgang lässt sich nur noch über das Bit "Manual operation state" schalten. Dies ist besonders für die Inbetriebnahmephase hilfreich.
▪
Möglichkeit 2: Über das Bit "Enable manual operation" (0x7pp1:04) kann die Ausgabe des Kanals auf den Wert dieses Objektes gezwungen werden. Die Abarbeitung der Timestamps läuft im Hintergrund weiter. Diese werden jedoch erst wieder zur Ausgabe gebracht, wenn das Bit "Enable manual operation" wieder auf 0 gesetzt wurde.
BOOLEAN
RO
0x00 (0dez)
7pp1:03
Force order
Dieses Bit legt fest, wie mit Timestamps verfahren werden soll, die in der Vergangenheit platziert wurden (siehe Grafik).
BOOLEAN
RO
0x00 (0dez)
7pp1:04
Enable manual operation
Siehe "Manual output state" (0x7pp1:02).
BOOLEAN
RO
0x00 (0dez)
7pp1:09
Output order counter
Durch das Inkrementieren dieses Bytes wird dem Kanal mitgeteilt, dass neue Output-Events übernommen werden sollen
UINT8
RO
0x00 (0dez)
7pp1:11
No of output events
Anzahl der gefüllten "Output event state" und "Output event time" Objekte
UINT8
RO
0x00 (0dez)
7pp1:21
Output event state 1
Über dieses Bit wird bestimmt welchen Zustand der Ausgang zum Zeitpunk von "Output event Time 1" annehmen soll
BOOLEAN
RO
0x00 (0dez)
7pp1:2A
Output event state 10
...
BOOLEAN
RO
0x00 (0dez)
7pp1:41
Output event time 1
Zeitpunkt zu dem der in "Output event state 1" beschriebene Zustand angelegt werden soll
UINT32
RO
0x00000000 (0dez)
7pp1:4A
Output event time 10
...
UINT32
RO
0x00000000 (0dez)
Index 7pp0 TSO Outputs (für 08 ≤ pp ≤ 0F; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
7pp0:0 | TSO Outputs |  | UINT8 | RO | 0x00 (0dez)
7pp0:01 | Output | Legt fest ob zum Zeitpunkt der "StartTime" eine steigende (1) oder fallende (0) Flanke ausgegeben werden soll | BOOLEAN | RO | 0x00 (0dez)
7pp0:11 | Activate | Mit einem Wechsel von 0 nach 3 in diesem Byte, wird der Auftrag mit der aktuellen StartTime übernommen | UINT8 | RO | 0x00 (0dez)
7pp0:41 | StartTime | 64 Bit TimeSTamp | UINT64 | RO |


Diagnostikdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Diagnostikdaten
Diagnostikdaten
Index App0 MTO Diag data (für 00 ≤ pp ≤ 07; Ch. 1 bis Ch. 8)
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
App0:0 | MTO Diag data |  | UINT8 | RO | 0x00 (0dez)
App0:01 | Short circuit | Der Kanal meldet einen Kurzschluss | BOOLEAN | RO | 0x00 (0dez)
App0:02 | Undervoltage | Die Spannung an den Powerkontakten ist außerhalb des gültigen Bereiches | BOOLEAN | RO | 0x00 (0dez)
Index A001 MTO common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A001:0 | MTO common Diag data |  | UINT8 | RO | 0x00 (0dez)
A001:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)
Index A080 TSO common Diag data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
A080:0 | TSO common Diag data |  | UINT8 | RO | 0x00 (0dez)
A080:11 | Checksum error counter | Bei der internen Datenübertragung ist ein Fehler aufgetreten | UINT16 | RO | 0x0000 (0dez)


Informationsdaten

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Informationsdaten
Informationsdaten
Index F900 DEV Info data
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F900:0 | DEV Info data |  | UINT8 | RO | 0x00 (0dez)
F900:08 | Cycle Time | Gibt die kleinstmögliche einzustellende Zykluszeit an [ns]. | UINT32 | RO | 0x00000000 (0dez)
F900:09 | Sample time | Gibt die Abtastzeit der Ein- und Ausgänge an [ns]. | UINT32 | RO | 0x00000000 (0dez)


Kommando-Objekt

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung und Parametrierung [image] Kommando-Objekt
Kommando-Objekt
Index FB00 Command
Das Command-Objekt wurde für die zukünftige Verwendung implementiert. Aktuell werden keine Kommandos unterstützt.
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
FB00:0 | Command |  | UINT8 | RO | 0x03 (3dez)
FB00:01 | Request | Über das Request-Objekt können Kommandos an die Klemme abgesetzt werden. | OCTET-STRING[2] | RW | {0}
FB00:02 | Status | Status des aktuell ausgeführten Kommandos | UINT8 | RO | 0x00 (0dez)
FB00:03 | Response | Optionaler Rückgabewert des Kommandos | OCTET-STRING[6] | RO | {0}


Objektbeschreibung - Standardobjekte

Inbetriebnahme [image] CoE Objektbeschreibung und Parametrierung [image] EL2258 [image] Objektbeschreibung - Standardobjekte
Objektbeschreibung - Standardobjekte
Index 1000 Device type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1000:0 | Device type | Geräte-Typ des EtherCAT-Slaves: Das Lo-Word enthält das verwendete CoE Profil (5001). Das Hi-Word enthält das Modul Profil entsprechend des Modular Device Profile. | UINT32 | RO | 0x00001389 (5001dez)
Index 1008 Device name
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1008:0 | Device name | Geräte-Name des EtherCAT-Slave | STRING | RO | EL2258
Index 1009 Hardware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1009:0 | Hardware version | Hardware-Version des EtherCAT-Slaves | STRING | RO |
Index 100ASoftware version
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
100A:0 | Software version | Firmware-Version des EtherCAT-Slaves | STRING | RO | 99
Index 1018 Identity
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1018:0 | Identity | Informationen, um den Slave zu identifizieren | UINT8 | RO | 0x04 (4dez)
1018:01 | Vendor ID | Hersteller-ID des EtherCAT-Slaves | UINT32 | RO | 0x00000002 (2dez)
1018:02 | Product code | Produkt-Code des EtherCAT-Slaves | UINT32 | RO | 0x08D23052 (147992658dez)
1018:03 | Revision | Revisionsnummer des EtherCAT-Slaves, das Low-Word (Bit 0-15) kennzeichnet die Sonderklemmennummer, das High-Word (Bit 16-31) verweist auf die Gerätebeschreibung | UINT32 | RO | 0x00000000 (0dez)
1018:04 | Serial number | Seriennummer des EtherCAT-Slaves, das Low-Byte (Bit 0-7) des Low-Words enthält das Produktionsjahr, das High-Byte (Bit 8-15) des Low-Words enthält die Produktionswoche, das High-Word (Bit 16-31) ist 0 | UINT32 | RO | 0x00000000 (0dez)
Index 10F0 Backup parameter handling
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
10F0:0 | Backup parameter handling | Informationen zum standardisierten Laden und Speichern der Backup Entries | UINT8 | RO | 0x01 (1dez)
10F0:01 | Checksum | Checksumme über alle Backup-Entries des EtherCAT-Slaves | UINT32 | RO | 0x00000000 (0dez)
Index 1600 MTO RxPDO-Map Outputs 10x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1600:0 | MTO RxPDO-Map Outputs 10x Ch.1 | PDO Mapping RxPDO 1 | UINT8 | RO | 0x1D (29dez)
1600:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1600:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1600:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1600:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1600:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1600:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1600:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1600:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1600:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1600:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1600:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1600:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1600:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1600:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7001:26, 1
1600:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7001:27, 1
1600:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7001:28, 1
1600:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7001:29, 1
1600:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7001:2A, 1
1600:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1600:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1600:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1600:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1600:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1600:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
1600:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7001:46, 32
1600:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7001:47, 32
1600:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7001:48, 32
1600:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7001:49, 32
1600:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7001:4A, 32
Index 1601 MTO RxPDO-Map Outputs 5x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1601:0 | MTO RxPDO-Map Outputs 5x Ch.1 | PDO Mapping RxPDO 2 | UINT8 | RO | 0x13 (19dez)
1601:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1601:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1601:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1601:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1601:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1601:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1601:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1601:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1601:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1601:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1601:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7001:23, 1
1601:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7001:24, 1
1601:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7001:25, 1
1601:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1601:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1601:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
1601:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7001:43, 32
1601:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7001:44, 32
1601:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7001:45, 32
Index 1602 MTO RxPDO-Map Outputs 2x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1602:0 | MTO RxPDO-Map Outputs 2x Ch.1 | PDO Mapping RxPDO 3 | UINT8 | RO | 0x0D (13dez)
1602:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1602:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1602:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1602:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1602:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1602:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1602:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1602:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1602:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1602:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7001:22, 1
1602:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1602:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
1602:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7001:42, 32
Index 1603 MTO RxPDO-Map Outputs 1x Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1603:0 | MTO RxPDO-Map Outputs 1x Ch.1 | PDO Mapping RxPDO 4 | UINT8 | RO | 0x0B (11dez)
1603:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7001:01, 1
1603:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7001:02, 1
1603:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x03 (Force order)) | UINT32 | RO | 0x7001:03, 1
1603:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7001:04, 1
1603:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1603:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7001:09, 8
1603:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x11 (No of output events)) | UINT32 | RO | 0x7001:11, 8
1603:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1603:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7001:21, 1
1603:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1603:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7001 (MTO outputs Ch.1), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7001:41, 32
Index 1604 MTO RxPDO-Map Outputs 10x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1604:0 | MTO RxPDO-Map Outputs 10x Ch.2 | PDO Mapping RxPDO 5 | UINT8 | RO | 0x1D (29dez)
1604:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1604:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1604:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1604:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1604:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1604:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1604:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1604:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1604:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1604:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1604:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1604:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1604:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1604:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7011:26, 1
1604:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7011:27, 1
1604:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7011:28, 1
1604:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7011:29, 1
1604:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7011:2A, 1
1604:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1604:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1604:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1604:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1604:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1604:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
1604:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7011:46, 32
1604:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7011:47, 32
1604:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7011:48, 32
1604:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7011:49, 32
1604:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7011:4A, 32
Index 1605 MTO RxPDO-Map Outputs 5x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1605:0 | MTO RxPDO-Map Outputs 5x Ch.2 | PDO Mapping RxPDO 6 | UINT8 | RO | 0x13 (19dez)
1605:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1605:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1605:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1605:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1605:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1605:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1605:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1605:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1605:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1605:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1605:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7011:23, 1
1605:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7011:24, 1
1605:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7011:25, 1
1605:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1605:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1605:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
1605:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7011:43, 32
1605:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7011:44, 32
1605:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7011:45, 32
Index 1606 MTO RxPDO-Map Outputs 2x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1606:0 | MTO RxPDO-Map Outputs 2x Ch.2 | PDO Mapping RxPDO 7 | UINT8 | RO | 0x0D (13dez)
1606:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1606:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1606:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1606:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1606:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1606:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1606:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1606:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1606:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1606:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7011:22, 1
1606:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1606:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
1606:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7011:42, 32
Index 1607 MTO RxPDO-Map Outputs 1x Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1607:0 | MTO RxPDO-Map Outputs 1x Ch.2 | PDO Mapping RxPDO 8 | UINT8 | RO | 0x0B (11dez)
1607:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7011:01, 1
1607:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7011:02, 1
1607:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x03 (Force order)) | UINT32 | RO | 0x7011:03, 1
1607:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7011:04, 1
1607:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1607:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7011:09, 8
1607:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x11 (No of output events)) | UINT32 | RO | 0x7011:11, 8
1607:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1607:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7011:21, 1
1607:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1607:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7011 (MTO outputs Ch.2), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7011:41, 32
Index 1608 MTO RxPDO-Map Outputs 10x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1608:0 | MTO RxPDO-Map Outputs 10x Ch.3 | PDO Mapping RxPDO 9 | UINT8 | RO | 0x1D (29dez)
1608:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1608:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1608:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1608:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1608:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1608:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1608:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1608:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1608:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1608:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1608:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1608:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1608:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1608:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7021:26, 1
1608:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7021:27, 1
1608:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7021:28, 1
1608:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7021:29, 1
1608:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7021:2A, 1
1608:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1608:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1608:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1608:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1608:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1608:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
1608:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7021:46, 32
1608:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7021:47, 32
1608:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7021:48, 32
1608:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7021:49, 32
1608:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7021:4A, 32
Index 1609 MTO RxPDO-Map Outputs 5x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1609:0 | MTO RxPDO-Map Outputs 5x Ch.3 | PDO Mapping RxPDO 10 | UINT8 | RO | 0x13 (19dez)
1609:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
1609:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
1609:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
1609:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
1609:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1609:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
1609:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
1609:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1609:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
1609:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
1609:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7021:23, 1
1609:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7021:24, 1
1609:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7021:25, 1
1609:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1609:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
1609:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
1609:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7021:43, 32
1609:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7021:44, 32
1609:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7021:45, 32
Index 160A MTO RxPDO-Map Outputs 2x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160A:0 | MTO RxPDO-Map Outputs 2x Ch.3 | PDO Mapping RxPDO 11 | UINT8 | RO | 0x0D (13dez)
160A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7021:22, 1
160A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
160A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7021:42, 32
Index 160B MTO RxPDO-Map Outputs 1x Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160B:0 | MTO RxPDO-Map Outputs 1x Ch.3 | PDO Mapping RxPDO 12 | UINT8 | RO | 0x0B (11dez)
160B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7021:01, 1
160B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7021:02, 1
160B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x03 (Force order)) | UINT32 | RO | 0x7021:03, 1
160B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7021:04, 1
160B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7021:09, 8
160B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x11 (No of output events)) | UINT32 | RO | 0x7021:11, 8
160B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7021:21, 1
160B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7021 (MTO outputs Ch.3), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7021:41, 32
Index 160C MTO RxPDO-Map Outputs 10x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160C:0 | MTO RxPDO-Map Outputs 10x Ch.4 | PDO Mapping RxPDO 13 | UINT8 | RO | 0x1D (29dez)
160C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7031:26, 1
160C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7031:27, 1
160C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7031:28, 1
160C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7031:29, 1
160C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7031:2A, 1
160C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
160C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
160C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7031:46, 32
160C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7031:47, 32
160C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7031:48, 32
160C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7031:49, 32
160C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7031:4A, 32
Index 160D MTO RxPDO-Map Outputs 5x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160D:0 | MTO RxPDO-Map Outputs 5x Ch.4 | PDO Mapping RxPDO 14 | UINT8 | RO | 0x13 (19dez)
160D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7031:23, 1
160D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7031:24, 1
160D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7031:25, 1
160D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
160D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
160D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7031:43, 32
160D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7031:44, 32
160D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7031:45, 32
Index 160E MTO RxPDO-Map Outputs 2x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160E:0 | MTO RxPDO-Map Outputs 2x Ch.4 | PDO Mapping RxPDO 15 | UINT8 | RO | 0x0D (13dez)
160E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7031:22, 1
160E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
160E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
160E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7031:42, 32
Index 160F MTO RxPDO-Map Outputs 1x Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
160F:0 | MTO RxPDO-Map Outputs 1x Ch.4 | PDO Mapping RxPDO 16 | UINT8 | RO | 0x0B (11dez)
160F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7031:01, 1
160F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7031:02, 1
160F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x03 (Force order)) | UINT32 | RO | 0x7031:03, 1
160F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7031:04, 1
160F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
160F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7031:09, 8
160F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x11 (No of output events)) | UINT32 | RO | 0x7031:11, 8
160F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
160F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7031:21, 1
160F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
160F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7031 (MTO outputs Ch.4), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7031:41, 32
Index 1610 MTO RxPDO-Map Outputs 10x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1610:0 | MTO RxPDO-Map Outputs 10x Ch.5 | PDO Mapping RxPDO 17 | UINT8 | RO | 0x1D (29dez)
1610:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1610:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1610:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1610:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1610:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1610:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1610:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1610:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1610:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1610:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1610:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1610:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1610:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1610:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7041:26, 1
1610:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7041:27, 1
1610:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7041:28, 1
1610:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7041:29, 1
1610:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7041:2A, 1
1610:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1610:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1610:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1610:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1610:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1610:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
1610:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7041:46, 32
1610:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7041:47, 32
1610:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7041:48, 32
1610:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7041:49, 32
1610:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7041:4A, 32
Index 1611 MTO RxPDO-Map Outputs 5x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1611:0 | MTO RxPDO-Map Outputs 5x Ch.5 | PDO Mapping RxPDO 18 | UINT8 | RO | 0x13 (19dez)
1611:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1611:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1611:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1611:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1611:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1611:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1611:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1611:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1611:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1611:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1611:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7041:23, 1
1611:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7041:24, 1
1611:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7041:25, 1
1611:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1611:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1611:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
1611:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7041:43, 32
1611:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7041:44, 32
1611:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7041:45, 32
Index 1612 MTO RxPDO-Map Outputs 2x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1612:0 | MTO RxPDO-Map Outputs 2x Ch.5 | PDO Mapping RxPDO 19 | UINT8 | RO | 0x0D (13dez)
1612:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1612:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1612:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1612:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1612:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1612:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1612:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1612:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1612:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1612:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7041:22, 1
1612:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1612:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
1612:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7041:42, 32
Index 1613 MTO RxPDO-Map Outputs 1x Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1613:0 | MTO RxPDO-Map Outputs 1x Ch.5 | PDO Mapping RxPDO 20 | UINT8 | RO | 0x0B (11dez)
1613:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7041:01, 1
1613:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7041:02, 1
1613:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x03 (Force order)) | UINT32 | RO | 0x7041:03, 1
1613:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7041:04, 1
1613:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1613:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7041:09, 8
1613:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x11 (No of output events)) | UINT32 | RO | 0x7041:11, 8
1613:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1613:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7041:21, 1
1613:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1613:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7041 (MTO outputs Ch.5), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7041:41, 32
Index 1614 MTO RxPDO-Map Outputs 10x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1614:0 | MTO RxPDO-Map Outputs 10x Ch.6 | PDO Mapping RxPDO 21 | UINT8 | RO | 0x1D (29dez)
1614:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1614:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1614:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1614:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1614:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1614:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1614:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1614:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1614:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1614:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1614:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1614:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1614:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1614:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7051:26, 1
1614:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7051:27, 1
1614:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7051:28, 1
1614:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7051:29, 1
1614:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7051:2A, 1
1614:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1614:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1614:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1614:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1614:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1614:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
1614:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7051:46, 32
1614:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7051:47, 32
1614:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7051:48, 32
1614:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7051:49, 32
1614:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7051:4A, 32
Index 1615 MTO RxPDO-Map Outputs 5x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1615:0 | MTO RxPDO-Map Outputs 5x Ch.6 | PDO Mapping RxPDO 22 | UINT8 | RO | 0x13 (19dez)
1615:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1615:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1615:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1615:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1615:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1615:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1615:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1615:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1615:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1615:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1615:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7051:23, 1
1615:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7051:24, 1
1615:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7051:25, 1
1615:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1615:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1615:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
1615:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7051:43, 32
1615:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7051:44, 32
1615:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7051:45, 32
Index 1616 MTO RxPDO-Map Outputs 2x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1616:0 | MTO RxPDO-Map Outputs 2x Ch.6 | PDO Mapping RxPDO 23 | UINT8 | RO | 0x0D (13dez)
1616:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1616:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1616:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1616:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1616:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1616:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1616:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1616:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1616:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1616:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7051:22, 1
1616:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
1616:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
1616:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7051:42, 32
Index 1617 MTO RxPDO-Map Outputs 1x Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1617:0 | MTO RxPDO-Map Outputs 1x Ch.6 | PDO Mapping RxPDO 24 | UINT8 | RO | 0x0B (11dez)
1617:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7051:01, 1
1617:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7051:02, 1
1617:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x03 (Force order)) | UINT32 | RO | 0x7051:03, 1
1617:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7051:04, 1
1617:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1617:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7051:09, 8
1617:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x11 (No of output events)) | UINT32 | RO | 0x7051:11, 8
1617:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1617:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7051:21, 1
1617:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
1617:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7051 (MTO outputs Ch.6), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7051:41, 32
Index 1618 MTO RxPDO-Map Outputs 10x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1618:0 | MTO RxPDO-Map Outputs 10x Ch.7 | PDO Mapping RxPDO 25 | UINT8 | RO | 0x1D (29dez)
1618:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1618:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1618:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1618:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1618:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1618:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1618:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1618:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1618:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1618:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1618:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1618:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1618:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1618:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7061:26, 1
1618:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7061:27, 1
1618:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7061:28, 1
1618:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7061:29, 1
1618:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7061:2A, 1
1618:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
1618:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1618:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1618:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1618:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1618:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
1618:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7061:46, 32
1618:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7061:47, 32
1618:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7061:48, 32
1618:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7061:49, 32
1618:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7061:4A, 32
Index 1619 MTO RxPDO-Map Outputs 5x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1619:0 | MTO RxPDO-Map Outputs 5x Ch.7 | PDO Mapping RxPDO 26 | UINT8 | RO | 0x13 (19dez)
1619:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
1619:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
1619:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
1619:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
1619:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
1619:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
1619:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
1619:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
1619:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
1619:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
1619:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7061:23, 1
1619:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7061:24, 1
1619:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7061:25, 1
1619:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
1619:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
1619:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
1619:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7061:43, 32
1619:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7061:44, 32
1619:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7061:45, 32
Index 161A MTO RxPDO-Map Outputs 2x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161A:0 | MTO RxPDO-Map Outputs 2x Ch.7 | PDO Mapping RxPDO 27 | UINT8 | RO | 0x0D (13dez)
161A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161A:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161A:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161A:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161A:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161A:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161A:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161A:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161A:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161A:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7061:22, 1
161A:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161A:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
161A:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7061:42, 32
Index 161B MTO RxPDO-Map Outputs 1x Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161B:0 | MTO RxPDO-Map Outputs 1x Ch.7 | PDO Mapping RxPDO 28 | UINT8 | RO | 0x0B (11dez)
161B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7061:01, 1
161B:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7061:02, 1
161B:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x03 (Force order)) | UINT32 | RO | 0x7061:03, 1
161B:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7061:04, 1
161B:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161B:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7061:09, 8
161B:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x11 (No of output events)) | UINT32 | RO | 0x7061:11, 8
161B:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161B:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7061:21, 1
161B:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161B:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7061 (MTO outputs Ch.7), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7061:41, 32
Index 161C MTO RxPDO-Map Outputs 10x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161C:0 | MTO RxPDO-Map Outputs 10x Ch.8 | PDO Mapping RxPDO 29 | UINT8 | RO | 0x1D (29dez)
161C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161C:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161C:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161C:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161C:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161C:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161C:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161C:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161C:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161C:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161C:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161C:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161C:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161C:0E | SubIndex 014 | 14. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x26 (Output event state 6)) | UINT32 | RO | 0x7071:26, 1
161C:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x27 (Output event state 7)) | UINT32 | RO | 0x7071:27, 1
161C:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x28 (Output event state 8)) | UINT32 | RO | 0x7071:28, 1
161C:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x29 (Output event state 9)) | UINT32 | RO | 0x7071:29, 1
161C:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x2A (Output event state 10)) | UINT32 | RO | 0x7071:2A, 1
161C:13 | SubIndex 019 | 19. PDO Mapping entry (22 bits align) | UINT32 | RO | 0x0000:00, 22
161C:14 | SubIndex 020 | 20. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161C:15 | SubIndex 021 | 21. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161C:16 | SubIndex 022 | 22. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161C:17 | SubIndex 023 | 23. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161C:18 | SubIndex 024 | 24. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
161C:19 | SubIndex 025 | 25. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x46 (Output event time 6)) | UINT32 | RO | 0x7071:46, 32
161C:1A | SubIndex 026 | 26. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x47 (Output event time 7)) | UINT32 | RO | 0x7071:47, 32
161C:1B | SubIndex 027 | 27. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x48 (Output event time 8)) | UINT32 | RO | 0x7071:48, 32
161C:1C | SubIndex 028 | 28. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x49 (Output event time 9)) | UINT32 | RO | 0x7071:49, 32
161C:1D | SubIndex 029 | 29. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x4A (Output event time 10)) | UINT32 | RO | 0x7071:4A, 32
Index 161D MTO RxPDO-Map Outputs 5x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161D:0 | MTO RxPDO-Map Outputs 5x Ch.8 | PDO Mapping RxPDO 30 | UINT8 | RO | 0x13 (19dez)
161D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161D:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161D:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161D:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161D:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161D:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161D:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161D:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161D:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161D:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161D:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x23 (Output event state 3)) | UINT32 | RO | 0x7071:23, 1
161D:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x24 (Output event state 4)) | UINT32 | RO | 0x7071:24, 1
161D:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x25 (Output event state 5)) | UINT32 | RO | 0x7071:25, 1
161D:0E | SubIndex 014 | 14. PDO Mapping entry (27 bits align) | UINT32 | RO | 0x0000:00, 27
161D:0F | SubIndex 015 | 15. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161D:10 | SubIndex 016 | 16. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
161D:11 | SubIndex 017 | 17. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x43 (Output event time 3)) | UINT32 | RO | 0x7071:43, 32
161D:12 | SubIndex 018 | 18. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x44 (Output event time 4)) | UINT32 | RO | 0x7071:44, 32
161D:13 | SubIndex 019 | 19. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x45 (Output event time 5)) | UINT32 | RO | 0x7071:45, 32
Index 161E MTO RxPDO-Map Outputs 2x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161E:0 | MTO RxPDO-Map Outputs 2x Ch.8 | PDO Mapping RxPDO 31 | UINT8 | RO | 0x0D (13dez)
161E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161E:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161E:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161E:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161E:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161E:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161E:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161E:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161E:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161E:0A | SubIndex 010 | 10. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x22 (Output event state 2)) | UINT32 | RO | 0x7071:22, 1
161E:0B | SubIndex 011 | 11. PDO Mapping entry (30 bits align) | UINT32 | RO | 0x0000:00, 30
161E:0C | SubIndex 012 | 12. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
161E:0D | SubIndex 013 | 13. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x42 (Output event time 2)) | UINT32 | RO | 0x7071:42, 32
Index 161F MTO RxPDO-Map Outputs 1x Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
161F:0 | MTO RxPDO-Map Outputs 1x Ch.8 | PDO Mapping RxPDO 32 | UINT8 | RO | 0x0B (11dez)
161F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x01 (Output buffer reset)) | UINT32 | RO | 0x7071:01, 1
161F:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x02 (Manual output state)) | UINT32 | RO | 0x7071:02, 1
161F:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x03 (Force order)) | UINT32 | RO | 0x7071:03, 1
161F:04 | SubIndex 004 | 4. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x04 (Enable manual operation)) | UINT32 | RO | 0x7071:04, 1
161F:05 | SubIndex 005 | 5. PDO Mapping entry (4 bits align) | UINT32 | RO | 0x0000:00, 4
161F:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x09 (Output order counter)) | UINT32 | RO | 0x7071:09, 8
161F:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x11 (No of output events)) | UINT32 | RO | 0x7071:11, 8
161F:08 | SubIndex 008 | 8. PDO Mapping entry (8 bits align) | UINT32 | RO | 0x0000:00, 8
161F:09 | SubIndex 009 | 9. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x21 (Output event state 1)) | UINT32 | RO | 0x7071:21, 1
161F:0A | SubIndex 010 | 10. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
161F:0B | SubIndex 011 | 11. PDO Mapping entry (object 0x7071 (MTO outputs Ch.8), entry 0x41 (Output event time 1)) | UINT32 | RO | 0x7071:41, 32
Index 1620 TSO RxPDO-Map Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1620:0 | TSO RxPDO-Map Ch.1 | PDO Mapping RxPDO 33 | UINT8 | RO | 0x05 (5dez)
1620:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7080 (TSO Outputs Ch.1), entry 0x01 (Output)) | UINT32 | RO | 0x7080:01, 1
1620:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1620:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7080 (TSO Outputs Ch.1), entry 0x11 (Activate)) | UINT32 | RO | 0x7080:11, 8
1620:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1620:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7080 (TSO Outputs Ch.1), entry 0x41 (StartTime)) | UINT32 | RO | 0x7080:41, 64
Index 1621 TSO RxPDO-Map Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1621:0 | TSO RxPDO-Map Ch.2 | PDO Mapping RxPDO 34 | UINT8 | RO | 0x05 (5dez)
1621:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x7090 (TSO Outputs Ch.2), entry 0x01 (Output)) | UINT32 | RO | 0x7090:01, 1
1621:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1621:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x7090 (TSO Outputs Ch.2), entry 0x11 (Activate)) | UINT32 | RO | 0x7090:11, 8
1621:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1621:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x7090 (TSO Outputs Ch.2), entry 0x41 (StartTime)) | UINT32 | RO | 0x7090:41, 64
Index 1622 TSO RxPDO-Map Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1622:0 | TSO RxPDO-Map Ch.3 | PDO Mapping RxPDO 35 | UINT8 | RO | 0x05 (5dez)
1622:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70A0 (TSO Outputs Ch.3), entry 0x01 (Output)) | UINT32 | RO | 0x70A0:01, 1
1622:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1622:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70A0 (TSO Outputs Ch.3), entry 0x11 (Activate)) | UINT32 | RO | 0x70A0:11, 8
1622:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1622:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70A0 (TSO Outputs Ch.3), entry 0x41 (StartTime)) | UINT32 | RO | 0x70A0:41, 64
Index 1623 TSO RxPDO-Map Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1623:0 | TSO RxPDO-Map Ch.4 | PDO Mapping RxPDO 36 | UINT8 | RO | 0x05 (5dez)
1623:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70B0 (TSO Outputs Ch.4), entry 0x01 (Output)) | UINT32 | RO | 0x70B0:01, 1
1623:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1623:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70B0 (TSO Outputs Ch.4), entry 0x11 (Activate)) | UINT32 | RO | 0x70B0:11, 8
1623:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1623:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70B0 (TSO Outputs Ch.4), entry 0x41 (StartTime)) | UINT32 | RO | 0x70B0:41, 64
Index 1624 TSO RxPDO-Map Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1624:0 | TSO RxPDO-Map Ch.5 | PDO Mapping RxPDO 37 | UINT8 | RO | 0x05 (5dez)
1624:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70C0 (TSO Outputs Ch.5), entry 0x01 (Output)) | UINT32 | RO | 0x70C0:01, 1
1624:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1624:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70C0 (TSO Outputs Ch.5), entry 0x11 (Activate)) | UINT32 | RO | 0x70C0:11, 8
1624:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1624:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70C0 (TSO Outputs Ch.5), entry 0x41 (StartTime)) | UINT32 | RO | 0x70C0:41, 64
Index 1625 TSO RxPDO-Map Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1625:0 | TSO RxPDO-Map Ch.6 | PDO Mapping RxPDO 38 | UINT8 | RO | 0x05 (5dez)
1625:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70D0 (TSO Outputs Ch.6), entry 0x01 (Output)) | UINT32 | RO | 0x70D0:01, 1
1625:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1625:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70D0 (TSO Outputs Ch.6), entry 0x11 (Activate)) | UINT32 | RO | 0x70D0:11, 8
1625:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1625:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70D0 (TSO Outputs Ch.6), entry 0x41 (StartTime)) | UINT32 | RO | 0x70D0:41, 64
Index 1626 TSO RxPDO-Map Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1626:0 | TSO RxPDO-Map Ch.7 | PDO Mapping RxPDO 39 | UINT8 | RO | 0x05 (5dez)
1626:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70E0 (TSO Outputs Ch.7), entry 0x01 (Output)) | UINT32 | RO | 0x70E0:01, 1
1626:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1626:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70E0 (TSO Outputs Ch.7), entry 0x11 (Activate)) | UINT32 | RO | 0x70E0:11, 8
1626:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1626:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70E0 (TSO Outputs Ch.7), entry 0x41 (StartTime)) | UINT32 | RO | 0x70E0:41, 64
Index 1627 TSO RxPDO-Map Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1627:0 | TSO RxPDO-Map Ch.8 | PDO Mapping RxPDO 40 | UINT8 | RO | 0x05 (5dez)
1627:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x70F0 (TSO Outputs Ch.8), entry 0x01 (Output)) | UINT32 | RO | 0x70F0:01, 1
1627:02 | SubIndex 002 | 2. PDO Mapping entry (15 bits align) | UINT32 | RO | 0x0000:00, 15
1627:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x70F0 (TSO Outputs Ch.8), entry 0x11 (Activate)) | UINT32 | RO | 0x70F0:11, 8
1627:04 | SubIndex 004 | 4. PDO Mapping entry (40 bits align) | UINT32 | RO | 0x0000:00, 40
1627:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x70F0 (TSO Outputs Ch.8), entry 0x41 (StartTime)) | UINT32 | RO | 0x70F0:41, 64
Index 1A00 MTO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A00:0 | MTO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 1 | UINT8 | RO | 0x07 (7dez)
1A00:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6000:01, 1
1A00:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6000:02, 1
1A00:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x03 (Output state)) | UINT32 | RO | 0x6000:03, 1
1A00:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A00:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6000:0F, 2
1A00:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6000:11, 8
1A00:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6000 (MTO inputs Ch.1), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6000:12, 8
Index 1A01 MTO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A01:0 | MTO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 2 | UINT8 | RO | 0x07 (7dez)
1A01:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6010:01, 1
1A01:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6010:02, 1
1A01:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x03 (Output state)) | UINT32 | RO | 0x6010:03, 1
1A01:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A01:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6010:0F, 2
1A01:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6010:11, 8
1A01:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6010 (MTO inputs Ch.2), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6010:12, 8
Index 1A02 MTO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A02:0 | MTO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 3 | UINT8 | RO | 0x07 (7dez)
1A02:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6020:01, 1
1A02:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6020:02, 1
1A02:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x03 (Output state)) | UINT32 | RO | 0x6020:03, 1
1A02:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A02:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6020:0F, 2
1A02:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6020:11, 8
1A02:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6020 (MTO inputs Ch.3), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6020:12, 8
Index 1A03 MTO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A03:0 | MTO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 4 | UINT8 | RO | 0x07 (7dez)
1A03:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6030:01, 1
1A03:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6030:02, 1
1A03:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x03 (Output state)) | UINT32 | RO | 0x6030:03, 1
1A03:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A03:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6030:0F, 2
1A03:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6030:11, 8
1A03:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6030 (MTO inputs Ch.4), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6030:12, 8
Index 1A04 MTO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A04:0 | MTO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 5 | UINT8 | RO | 0x07 (7dez)
1A04:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6040:01, 1
1A04:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6040:02, 1
1A04:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x03 (Output state)) | UINT32 | RO | 0x6040:03, 1
1A04:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A04:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6040:0F, 2
1A04:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6040:11, 8
1A04:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6040 (MTO inputs Ch.5), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6040:12, 8
Index 1A05 MTO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A05:0 | MTO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 6 | UINT8 | RO | 0x07 (7dez)
1A05:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6050:01, 1
1A05:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6050:02, 1
1A05:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x03 (Output state)) | UINT32 | RO | 0x6050:03, 1
1A05:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A05:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6050:0F, 2
1A05:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6050:11, 8
1A05:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6050 (MTO inputs Ch.6), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6050:12, 8
Index 1A06 MTO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A06:0 | MTO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 7 | UINT8 | RO | 0x07 (7dez)
1A06:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6060:01, 1
1A06:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6060:02, 1
1A06:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x03 (Output state)) | UINT32 | RO | 0x6060:03, 1
1A06:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A06:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6060:0F, 2
1A06:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6060:11, 8
1A06:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6060 (MTO inputs Ch.7), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6060:12, 8
Index 1A07 MTO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A07:0 | MTO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 8 | UINT8 | RO | 0x07 (7dez)
1A07:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x01 (Output short circuit)) | UINT32 | RO | 0x6070:01, 1
1A07:02 | SubIndex 002 | 2. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x02 (Output buffer overflow)) | UINT32 | RO | 0x6070:02, 1
1A07:03 | SubIndex 003 | 3. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x03 (Output state)) | UINT32 | RO | 0x6070:03, 1
1A07:04 | SubIndex 004 | 4. PDO Mapping entry (11 bits align) | UINT32 | RO | 0x0000:00, 11
1A07:05 | SubIndex 005 | 5. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x0F (Input cycle counter)) | UINT32 | RO | 0x6070:0F, 2
1A07:06 | SubIndex 006 | 6. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x11 (Output order feedback)) | UINT32 | RO | 0x6070:11, 8
1A07:07 | SubIndex 007 | 7. PDO Mapping entry (object 0x6070 (MTO inputs Ch.8), entry 0x12 (Events in output buffer)) | UINT32 | RO | 0x6070:12, 8
Index 1A08 TSO TxPDO-Map Inputs Ch.1
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A08:0 | TSO TxPDO-Map Inputs Ch.1 | PDO Mapping TxPDO 9 | UINT8 | RO | 0x02 (2dez)
1A08:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6080 (TSO Inputs Ch.1), entry 0x01 (Feedback)) | UINT32 | RO | 0x6080:01, 1
1A08:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A09 TSO TxPDO-Map Inputs Ch.2
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A09:0 | TSO TxPDO-Map Inputs Ch.2 | PDO Mapping TxPDO 10 | UINT8 | RO | 0x02 (2dez)
1A09:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x6090 (TSO Inputs Ch.2), entry 0x01 (Feedback)) | UINT32 | RO | 0x6090:01, 1
1A09:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0A TSO TxPDO-Map Inputs Ch.3
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0A:0 | TSO TxPDO-Map Inputs Ch.3 | PDO Mapping TxPDO 11 | UINT8 | RO | 0x02 (2dez)
1A0A:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60A0 (TSO Inputs Ch.3), entry 0x01 (Feedback)) | UINT32 | RO | 0x60A0:01, 1
1A0A:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0B TSO TxPDO-Map Inputs Ch.4
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0B:0 | TSO TxPDO-Map Inputs Ch.4 | PDO Mapping TxPDO 12 | UINT8 | RO | 0x02 (2dez)
1A0B:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60B0 (TSO Inputs Ch.4), entry 0x01 (Feedback)) | UINT32 | RO | 0x60B0:01, 1
1A0B:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0C TSO TxPDO-Map Inputs Ch.5
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0C:0 | TSO TxPDO-Map Inputs Ch.5 | PDO Mapping TxPDO 13 | UINT8 | RO | 0x02 (2dez)
1A0C:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60C0 (TSO Inputs Ch.5), entry 0x01 (Feedback)) | UINT32 | RO | 0x60C0:01, 1
1A0C:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0D TSO TxPDO-Map Inputs Ch.6
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0D:0 | TSO TxPDO-Map Inputs Ch.6 | PDO Mapping TxPDO 14 | UINT8 | RO | 0x02 (2dez)
1A0D:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60D0 (TSO Inputs Ch.6), entry 0x01 (Feedback)) | UINT32 | RO | 0x60D0:01, 1
1A0D:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0E TSO TxPDO-Map Inputs Ch.7
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0E:0 | TSO TxPDO-Map Inputs Ch.7 | PDO Mapping TxPDO 15 | UINT8 | RO | 0x02 (2dez)
1A0E:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60E0 (TSO Inputs Ch.7), entry 0x01 (Feedback)) | UINT32 | RO | 0x60E0:01, 1
1A0E:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A0F TSO TxPDO-Map Inputs Ch.8
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A0F:0 | TSO TxPDO-Map Inputs Ch.8 | PDO Mapping TxPDO 16 | UINT8 | RO | 0x02 (2dez)
1A0F:01 | SubIndex 001 | 1. PDO Mapping entry (object 0x60F0 (TSO Inputs Ch.8), entry 0x01 (Feedback)) | UINT32 | RO | 0x60F0:01, 1
1A0F:02 | SubIndex 002 | 2. PDO Mapping entry (31 bits align) | UINT32 | RO | 0x0000:00, 31
Index 1A10 DEV TxPDO-Map Inputs Device
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1A10:0 | DEV TxPDO-Map Inputs Device | PDO Mapping TxPDO 17 | UINT8 | RO | 0x06 (6dez)
1A10:01 | SubIndex 001 | 1. PDO Mapping entry (1 bits align) | UINT32 | RO | 0x0000:00, 1
1A10:02 | SubIndex 002 | 2. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x02 (Undervoltage Up)) | UINT32 | RO | 0xF611:02, 1
1A10:03 | SubIndex 003 | 3. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x03 (Overtemperature)) | UINT32 | RO | 0xF611:03, 1
1A10:04 | SubIndex 004 | 4. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x04 (Checksum error)) | UINT32 | RO | 0xF611:04, 1
1A10:05 | SubIndex 005 | 5. PDO Mapping entry (60 bits align) | UINT32 | RO | 0x0000:00, 60
1A10:06 | SubIndex 006 | 6. PDO Mapping entry (object 0xF611 (DEV Inputs), entry 0x21 (SysTime)) | UINT32 | RO | 0xF611:21, 64
Index 1C00 Sync manager type
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C00:0 | Sync manager type | Benutzung der Sync Manager | UINT8 | RO | 0x04 (4dez)
1C00:01 | SubIndex 001 | Sync-Manager Type Channel 1: Mailbox Write | UINT8 | RO | 0x01 (1dez)
1C00:02 | SubIndex 002 | Sync-Manager Type Channel 2: Mailbox Read | UINT8 | RO | 0x02 (2dez)
1C00:03 | SubIndex 003 | Sync-Manager Type Channel 3: Process Data Write (Outputs) | UINT8 | RO | 0x03 (3dez)
1C00:04 | SubIndex 004 | Sync-Manager Type Channel 4: Process Data Read (Inputs) | UINT8 | RO | 0x04 (4dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:0 | RxPDO assign | PDO Assign Outputs | UINT8 | RW | 0x08 (8dez)
1C12:01 | SubIndex 001 | 1. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1600 (5632dez)
1C12:02 | SubIndex 002 | 2. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1604 (5636dez)
1C12:03 | SubIndex 003 | 3. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1608 (5640dez)
1C12:04 | SubIndex 004 | 4. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x160C (5644dez)
1C12:05 | SubIndex 005 | 5. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1610 (5648dez)
1C12:06 | SubIndex 006 | 6. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1614 (5652dez)
1C12:07 | SubIndex 007 | 7. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x1618 (5656dez)
1C12:08 | SubIndex 008 | 8. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x161C (5660dez)
1C12:09 | SubIndex 009 | 9. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0A | SubIndex 010 | 10. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0B | SubIndex 011 | 11. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0C | SubIndex 012 | 12. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0D | SubIndex 013 | 13. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0E | SubIndex 014 | 14. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:0F | SubIndex 015 | 15. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:10 | SubIndex 016 | 16. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:11 | SubIndex 017 | 17. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:12 | SubIndex 018 | 18. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:13 | SubIndex 019 | 19. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:14 | SubIndex 020 | 20. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:15 | SubIndex 021 | 21. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:16 | SubIndex 022 | 22. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:17 | SubIndex 023 | 23. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:18 | SubIndex 024 | 24. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:19 | SubIndex 025 | 25. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1A | SubIndex 026 | 26. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C12 RxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C12:1B | SubIndex 027 | 27. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1C | SubIndex 028 | 28. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1D | SubIndex 029 | 29. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1E | SubIndex 030 | 30. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:1F | SubIndex 031 | 31. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:20 | SubIndex 032 | 32. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:21 | SubIndex 033 | 33. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:22 | SubIndex 034 | 34. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:23 | SubIndex 035 | 35. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:24 | SubIndex 036 | 36. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:25 | SubIndex 037 | 37. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:26 | SubIndex 038 | 38. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:27 | SubIndex 039 | 39. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C12:28 | SubIndex 040 | 40. zugeordnete RxPDO (enthält den Index des zugehörigen RxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C13 TxPDO assign
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
1C13:0 | TxPDO assign | PDO Assign Inputs | UINT8 | RW | 0x08 (8dez)
1C13:01 | SubIndex 001 | 1. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A00 (6656dez)
1C13:02 | SubIndex 002 | 2. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A01 (6657dez)
1C13:03 | SubIndex 003 | 3. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A02 (6658dez)
1C13:04 | SubIndex 004 | 4. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A03 (6659dez)
1C13:05 | SubIndex 005 | 5. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A04 (6660dez)
1C13:06 | SubIndex 006 | 6. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A05 (6661dez)
1C13:07 | SubIndex 007 | 7. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A06 (6662dez)
1C13:08 | SubIndex 008 | 8. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x1A07 (6663dez)
1C13:09 | SubIndex 009 | 9. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0A | SubIndex 010 | 10. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0B | SubIndex 011 | 11. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0C | SubIndex 012 | 12. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0D | SubIndex 013 | 13. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0E | SubIndex 014 | 14. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:0F | SubIndex 015 | 15. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:10 | SubIndex 016 | 16. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
1C13:11 | SubIndex 017 | 17. zugeordnete TxPDO (enthält den Index des zugehörigen TxPDO Mapping Objekts) | UINT16 | RW | 0x0000 (0dez)
Index 1C32 SM output parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C32:0
SM output parameter
Synchronisierungsparameter der Outputs
UINT8
RO
0x20 (32dez)
1C32:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 2 Event
▪
2: DC-Mode - Synchron with SYNC0 Event
▪
3: DC-Mode - Synchron with SYNC1 Event
UINT16
RW
0x0000 (0dez)
1C32:02
Cycle time
Zykluszeit (in ns):
▪
Free Run: Zykluszeit des lokalen Timers
▪
Synchron with SM 2 Event: Zykluszeit des Masters
▪
DC-Mode: SYNC0/SYNC1 Cycle Time
UINT32
RW
0x000C3500 (800000dez)
1C32:03
Shift time
Zeit zwischen SYNC0 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0 = 1: Free Run wird unterstützt
▪
Bit 1 = 1: Synchron with SM 2 Event wird unterstützt
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 10: Output Shift mit SYNC1 Event (nur DC-Mode)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08)
UINT16
RO
0x0804 (2052dez)
1C32:05
Minimum cycle time
Minimale Zykluszeit (in ns)
UINT32
RO
0x00001F40 (8000dez)
1C32:06
Calc and copy time
Minimale Zeit zwischen SYNC0 und SYNC1 Event (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C32:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C32:08
Command
▪
0: Messung der lokalen Zykluszeit wird gestoppt
▪
1: Messung der lokalen Zykluszeit wird gestartet
Die Entries 0x1C32:03, 0x1C32:05, 0x1C32:06, 0x1C32:09, 0x1C33:03, 0x1C33:06, 0x1C33:09 werden mit den maximal gemessenen Werten aktualisiert.
Wenn erneut gemessen wird, werden die Messwerte zurückgesetzt
UINT16
RW
0x0000 (0dez)
1C32:09
Maximum delay time
Zeit zwischen SYNC1 Event und Ausgabe der Outputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C32:0B
SM event missed counter
Anzahl der ausgefallenen SM-Events im OPERATIONAL (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:0C
Cycle exceeded counter
Anzahl der Zykluszeitverletzungen im OPERATIONAL (Zyklus wurde nicht rechtzeitig fertig bzw. der nächste Zyklus kam zu früh)
UINT16
RO
0x0000 (0dez)
1C32:0D
Shift too short counter
Anzahl der zu kurzen Abstände zwischen SYNC0 und SYNC1 Event (nur im DC Mode)
UINT16
RO
0x0000 (0dez)
1C32:20
Sync error
Im letzten Zyklus war die Synchronisierung nicht korrekt (Ausgänge wurden zu spät ausgegeben, nur im DC Mode)
BOOLEAN
RO
0x00 (0dez)
Index 1C33 SM input parameter
Index (hex)
Name
Bedeutung
Datentyp
Flags
Default
1C33:0
SM input parameter
Synchronisierungsparameter der Inputs
UINT8
RO
0x20 (32dez)
1C33:01
Sync mode
Aktuelle Synchronisierungsbetriebsart:
▪
0: Free Run
▪
1: Synchron with SM 3 Event (keine Outputs vorhanden)
▪
2: DC - Synchron with SYNC0 Event
▪
3: DC - Synchron with SYNC1 Event
▪
34: Synchron with SM 2 Event (Outputs vorhanden)
UINT16
RW
0x0000 (0dez)
1C33:02
Cycle time
wie 0x1C32:02
UINT32
RW
0x000C3500 (800000dez)
1C33:03
Shift time
Zeit zwischen SYNC0-Event und Einlesen der Inputs (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:04
Sync modes supported
Unterstützte Synchronisierungsbetriebsarten:
▪
Bit 0: Free Run wird unterstützt
▪
Bit 1: Synchron with SM 2 Event wird unterstützt (Outputs vorhanden)
▪
Bit 1: Synchron with SM 3 Event wird unterstützt (keine Outputs vorhanden)
▪
Bit 2-3 = 01: DC-Mode wird unterstützt
▪
Bit 4-5 = 01: Input Shift durch lokales Ereignis (Outputs vorhanden)
▪
Bit 4-5 = 10: Input Shift mit SYNC1 Event (keine Outputs vorhanden)
▪
Bit 14 = 1: dynamische Zeiten (Messen durch Beschreiben von 0x1C32:08 oder 0x1C33:08)
UINT16
RO
0x0804 (2052dez)
1C33:05
Minimum cycle time
wie 0x1C32:05
UINT32
RO
0x00001F40 (8000dez)
1C33:06
Calc and copy time
Zeit zwischen Einlesen der Eingänge und Verfügbarkeit der Eingänge für den Master (in ns, nur DC-Mode)
UINT32
RO
0x00000000 (0dez)
1C33:07
Minimum delay time
UINT32
RO
0x00000384 (900dez)
1C33:08
Command
wie 0x1C32:08
UINT16
RW
0x0000 (0dez)
1C33:09
Maximum delay time
Zeit zwischen SYNC1-Event und Einlesen der Eingänge (in ns, nur DC-Mode)
UINT32
RO
0x00000384 (900dez)
1C33:0B
SM event missed counter
wie 0x1C32:11
UINT16
RO
0x0000 (0dez)
1C33:0C
Cycle exceeded counter
wie 0x1C32:12
UINT16
RO
0x0000 (0dez)
1C33:0D
Shift too short counter
wie 0x1C32:13
UINT16
RO
0x0000 (0dez)
1C33:20
Sync error
wie 0x1C32:32
BOOLEAN
RO
0x00 (0dez)
Index F000 Modular device profile
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F000:0 | Modular device profile | Allgemeine Informationen des Modular Device Profiles | UINT8 | RO | 0x02 (2dez)
F000:01 | Module index distance | Indexabstand der Objekte der einzelnen Kanäle | UINT16 | RO | 0x0010 (16dez)
F000:02 | Maximum number of modules | Anzahl der Kanäle | UINT16 | RO | 0x0010 (16dez)
Index F008 Code word
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F008:0 | Code word | reserviert | UINT32 | RW | 0x00000000 (0dez)
Index F010 Module list
Index (hex) | Name | Bedeutung | Datentyp | Flags | Default
F010:0 | Module list | MDP Profile | UINT8 | RW | 0x10 (16dez)
F010:01 | SubIndex 001 |  | UINT32 | RW | 0x000000DC (220dez)
F010:02 | SubIndex 002 |  | UINT32 | RW | 0x000000DC (220dez)
F010:03 | SubIndex 003 |  | UINT32 | RW | 0x000000DC (220dez)
F010:04 | SubIndex 004 |  | UINT32 | RW | 0x000000DC (220dez)
F010:05 | SubIndex 005 |  | UINT32 | RW | 0x000000DC (220dez)
F010:06 | SubIndex 006 |  | UINT32 | RW | 0x000000DC (220dez)
F010:07 | SubIndex 007 |  | UINT32 | RW | 0x000000DC (220dez)
F010:08 | SubIndex 008 |  | UINT32 | RW | 0x000000DC (220dez)
F010:09 | SubIndex 009 |  | UINT32 | RW | 0x000000DD (221dez)
F010:0A | SubIndex 010 |  | UINT32 | RW | 0x000000DD (221dez)
F010:0B | SubIndex 011 |  | UINT32 | RW | 0x000000DD (221dez)
F010:0C | SubIndex 012 |  | UINT32 | RW | 0x000000DD (221dez)
F010:0D | SubIndex 013 |  | UINT32 | RW | 0x000000DD (221dez)
F010:0E | SubIndex 014 |  | UINT32 | RW | 0x000000DD (221dez)
F010:0F | SubIndex 015 |  | UINT32 | RW | 0x000000DD (221dez)
F010:10 | SubIndex 016 |  | UINT32 | RW | 0x000000DD (221dez)


Beispielprogramme

Inbetriebnahme [image] Beispielprogramme
Beispielprogramme
Verwendung der Beispielprogramme
Dieses Dokument enthält exemplarische Anwendungen unserer Produkte für bestimmte Einsatzbereiche. Die hier dargestellten Anwendungshinweise beruhen auf den typischen Eigenschaften unserer Produkte und haben ausschließlich Beispielcharakter. Die mit diesem Dokument vermittelten Hinweise beziehen sich ausdrücklich nicht auf spezifische Anwendungsfälle, daher liegt es in der Verantwortung des Anwenders zu prüfen und zu entscheiden, ob das Produkt für den Einsatz in einem bestimmten Anwendungsbereich geeignet ist. Wir übernehmen keine Gewährleistung, dass der in diesem Dokument enthaltene Quellcode vollständig und richtig ist. Wir behalten uns jederzeit eine Änderung der Inhalte dieses Dokuments vor und übernehmen keine Haftung für Irrtümer und fehlenden Angaben.
Vorbereitungen zum Starten des Beispielprogramms (tnzip - Datei/ TwinCAT 3)
▪
Nach Klick auf den Download-Button speichern Sie das Zip-Archiv lokal auf ihrer Festplatte und entpacken die *.tnzip -Archivdatei in einem temporären Ordner.
Öffnen des *. tnzip - Archives
▪
Wählen Sie die zuvor entpackte .tnzip Datei (Beispielprogramm) aus.
▪
Ein weiteres Auswahlfenster öffnet sich: wählen nun Sie das Zielverzeichnis, wo das Projekt gespeichert werden soll.
▪
Die generelle Vorgehensweise für die Inbetriebnahme der PLC bzw. dem Start des Programms kann u.a. den Klemmen‑Dokumentationen oder der EtherCAT‑Systemdokumentation entnommen werden.
▪
Das EtherCAT Gerät im Beispiel ist i.d.R. zuvor ihrem vorliegenden System bekannt zu machen. Verwenden Sie nach Auswahl des EtherCAT Gerätes im „Projektmappen-Explorer“ rechtsseitig den Karteireiter „Adapter“ und Klicken „Suchen...“:
Suche der bestehenden HW-Konfiguration zur bestehenden EtherCAT-Konfiguration
▪
Überprüfen der NetId: der Karteireiter „EtherCAT“ des EtherCAT Gerätes zeigt die konfigurierte NetId: .
Diese muss mit den ersten vier Zahlenwerten mit der Projekt‑NetId des Zielsystems übereinstimmen. Die NetId des Projektes kann oben in einem Textfeld der TwinCAT-Umgebung eingesehen werden. Ein pull-down Menü kann durch einen Klick rechts im Textfeld geöffnet werden; dort ist zu jeden Rechnernamen eines Zielsystems die NetId in Klammern angegeben.
▪
Ändern der NetId: mit einem Rechtsklick auf „Gerät EtherCAT“ im Projektmappen-Explorer öffnet sich das Kontextmenü, in dem „Ändern der NetId“ auszuwählen ist. Die ersten vier Zahlen der NetId des Projektes sind einzutragen. die beiden letzten Werte sind i.d.R. 4.1.
Beispiel:
–
NetId des Projektes: myComputer (123.45.67.89.1.1)
–
Eintrag per „Change NetId...“: 123.45.67.89.4.1
Sehen Sie hierzu auch weitere Hinweise in dem Kapitel:
Inbetreibnahme, TwinCAT Quickstart, TwinCAT 3, Startup.
Weiterführende Informationen
•
Beispielprogramm zur EL2258: Multi-Timestamp
•
Beispielprogramm zur EL1258 (EL1259): MT-Visualisierung (TC 3)


Beispielprogramm zur EL2258: Multi-Timestamp

Inbetriebnahme [image] Beispielprogramme [image] Beispielprogramm zur EL2258: Multi-Timestamp
Beispielprogramm zur EL2258: Multi-Timestamp
Das folgende Beispielprogramm vergibt 4 x 10 Schaltaufträge innerhalb eines PLC-Taskzyklus und setzt für die ersten vier Kanäle der EL2258 die Ausgangszustände abwechselnd von „1“ nach „0“, beginnend mit „1“ für den ersten Zustand.
Die willkürlichen, für die vier Kanäle jeweils unterschiedlich festgelegten Schaltzeiten sind in der folgenden Oszilloskop-Aufzeichnung gezeigt:
Aufzeichnung von vier Kanälen aus dem Multi-Timestamp Programmbeispiel
Alle Feldvariablen sind entsprechend den acht Kanälen mit jeweils allen notwenigen Zustands, Ausgangs und Eingangsvariablen zu verknüpfen. In dem zum Download zur Verfügung stehenden Beispiel ist dies bereits erfolgt:
Dieses Beispiel erfordert eine PLC Steuerung mit einer Klemme EL2258. Sie können entweder einen embedded PC verwenden, an dem die Klemme rechtsseitig angebracht wird, oder einen IPC mit einer EtherCAT-Verbindung eines z.B. RJ-45 Anschlusses zum EK1100 Koppler mit der Klemme (z.B. C6915 + EK1100 + EL2258). Optional kann eine digitale Eingangsklemme z.B. EL1004 zusätzlich zur Programmsteuerung verwendet werden.
Das weitere Vorgehen ist im Kapitel TwinCAT Quickstart, TwinCAT 3, Starten der Steuerung beschrieben.
Beispielprogramm EL2258: Multi-Timestamp
Variablendeklaration:
PROGRAM MAIN
VAR CONSTANT
// Number of used channels of the terminal in this code example
nNumOfSwitchTasks : INT:=4;
END_VAR
VAR_INPUT
// External switch to start by user
bEnable AT%I* : BOOL;
// Reference to check if last tasks were already executed
nOutputOrderFeedback AT%I*: ARRAY[0..7] OF USINT;
END_VAR
VAR_OUTPUT
// Link to terminal EL2258 (Output event time n):
aQE_Time AT%Q* : ARRAY[0..7] OF ARRAY[0..9] OF UDINT;
// Link to terminal EL2258 (Output event state n):
aQE_State AT%Q* : ARRAY[0..7] OF ARRAY[0..9] OF BOOL;
// Outputvariables to reset the output buffers of EL2258
bOutputBufReset AT%Q*: ARRAY[0..7] OF BOOL;
// Real number of fixed State/Time-Events as a Task for EL2258
nNoOfOutputEvents AT%Q*: ARRAY[0..7] OF USINT;
// Start-Event to trigger beginning of task scheduling
nOutputOrderCounter AT%Q*: ARRAY[0..7] OF USINT;
END_VAR
VAR
aSwitchTimes : ARRAY[0..7] OF ARRAY[0..9] OF UDINT:=
// All 8 x 10 time offsets in ms allocated to the 10 states and 8 channels
[
[ // Channel 1 time offsets:
100, 50, 25, 75, 75, 25, 50, 25, 50, 50
]
,[ // Channel 2 time offsets:
100, 25, 50, 25, 50, 50, 25, 75, 75, 50
]
,[ // Channel 3 time offsets:
100, 50, 25, 75, 75, 50, 25, 50, 25, 50
]
,[ // Channel 4 time offsets:
100, 25, 50, 50, 25, 75, 75, 50, 50, 25
]
(* More time offsets for switch tasks:
,[ // Channel 5 time offsets:
100, 50, 25, 75, 75, 25, 50, 50, 25, 50
]
,[ // Channel 6 time offsets:
100, 25, 50, 25, 50, 50, 25, 75, 75, 50
]
,[ // Channel 7 time offsets:
100, 50, 25, 75, 75, 50, 25, 50, 25, 50
]
,[ // Channel 8 time offsets:
100, 25, 50, 50, 25, 75, 75, 50, 25, 50
]
*)
];
nState : UINT:=0; // Use for "CASE .. OF" statement
nShortTime : UDINT; // Timevalue of current DC time/ lower 32 Bit only
nCurrentTime : ULINT; // Current DC-Time of the PLC-Task
bStateValue : BOOL; // Variable to set a toggled state of a task-event
nScheduleNo: INT; // Consists No of respective state/time pair of a Switch-Task
nChannel: INT; // Channel of the EL2258
END_VAR
Programm:
// Example program: 10x Multi-Timestamp for EL2258
nCurrentTime := F_GetCurDcTaskTime64(); // Get current DC-Time (Task-Related)
CASE nState OF
// ====================== Do some initializations here: ============================
0:
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
// Reset ouput buffer of the terminal EL2258
bOutputBufReset[nChannel] := TRUE;
END_FOR
nState := nState + 1;// Go to next state
1:
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
bOutputBufReset[nChannel] := FALSE;
END_FOR
nState := nState + 1; // Go to next state
2:
// Wait for external start-event by user (e.g. ext. switch)
IF bEnable THEN
nState := 10; // Go to next state and set events
END_IF
// =================================================================================
// ============ Now fill up all state/time pairs for the four channels =============
10:
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
// Last tasks already executed?
IF nOutputOrderFeedback[nChannel] = nOutputOrderCounter[nChannel] THEN
bStateValue:=1;
// Set first state level ('1')
aQE_State[nChannel][0] := bStateValue;
// Cut 64 Bit time value to 32 Bit
nShortTime := ULINT_TO_UDINT(nCurrentTime AND 16#FFFFFFFF);
// Set first time value (duration for "save" begin)
aQE_Time[nChannel][0] := (nShortTime + aSwitchTimes[nChannel][0] * 1000000);
// Put all switch states with their times into the terminal:
FOR nScheduleNo:=1 TO 9 DO // Use 'nScheduleNo' as loop counter
bStateValue := NOT bStateValue;
// Set inverting output states of one switch-task
aQE_State[nChannel][nScheduleNo] := bStateValue;
// Set timestamps by fixed array into one switch-task
aQE_Time[nChannel][nScheduleNo] :=
(aQE_Time[nChannel][nScheduleNo-1]
+ aSwitchTimes[nChannel][nScheduleNo] * 1000000);
END_FOR
END_IF
END_FOR
nState := nState + 1; // Go to next state
// =================================================================================
// ======== Allow some taskcycles (min. 2) to let EL2258 schedule all tasks ========
11:
// 'nScheduleNo' is still 9; wait until 12: 3 more PLC-Taskcycles
IF nScheduleNo = 12 THEN
FOR nChannel:= 0 TO (nNumOfSwitchTasks-1) DO
nNoOfOutputEvents[nChannel] := 10;
// Trigger Multi-Timestamp scheduling: now start:
nOutputOrderCounter[nChannel] := nOutputOrderCounter[nChannel] + 1;
END_FOR
nState := nState + 1;
ELSE
// Just count PLC-Taskcycles here
nScheduleNo := nScheduleNo + 1;
END_IF
12:
// ================================== End ==========================================
// Wait for external switch to be released
IF NOT bEnable THEN
// Go to beginning state (could be '0' also)
nState := 2;
END_IF
END_CASE


Beispielprogramm zur EL1258 (EL1259): MT-Visualisierung (TC 3)

Inbetriebnahme [image] Beispielprogramme [image] Beispielprogramm zur EL1258 (EL1259): MT-Visualisierung (TC 3)
Beispielprogramm zur EL1258 (EL1259): MT-Visualisierung (TC 3)
Dieses Beispielprogramm soll mittels einer TwinCAT3 ‑ Visualisierung die Funktionalität des Multi‑Timestamp eines digitalen Eingangs der EL1258 (bzw. EL1259) veranschaulichen. Im 10x Multi-Timestamp und asynchronen (gepufferten) Betrieb wird ein Eingang der Klemme von einer digitalen Ausgangsklemme EL2002 angesteuert. Das Beispielprogramm enthält die EtherCAT-Konfiguration und die entsprechenden Links zu den PDOs der Klemmen und verwendet jeweils Kanal 1 (Kanaleingang ist dementsprechend mit Kanalausgang zu verbinden).
Folgender Aufbau wird für die Inbetriebnahme des Beispielprogramms empfohlen:
[EK1100] + [EL1258] + [EL2002] + [EL9011]
Empfohlener Aufbau für das Beispielprogramm zur EL1258
Download:
Die Einstellung der MTI-Settings der EL1258 ist wie folgt:
CoE Objekt 0x8000 (MTI settings Ch.1): Einstellungen für das Beispielprogramm
Um Einstellungen zu ändern wählen Sie die Klemme im Projektmappen-Explorer und wählen den Karteireiter „CoE ‑ online“.
Erläuterungen zum Beispielprogramm
Über eine TwinCAT3 – Visualisierung wird die Auswertung von binären Eingangssignalen veranschaulicht. Es soll hierbei nur die grundlegende Funktionsweise dargestellt werden. Dazu stellt die Visualisierung_1 lediglich eine Zeitstempeldifferenz zweier Ereignisse am Eingang von Kanal 1 der EL1258 dar (Eingangsbit 0 → 1 → 0):
Beispielprogramm EL1258/ Visualisierung_1: einfache Zeitmessung anhand zweier Zustandswechsel
Eine digitale Ausgangsklemme, deren Ausgang direkt mit dem Eingangskanal 1 der EL1258 verbunden ist schaltet mit „SET OUTPUT“ den Ausgang. Der Anwender betätigt eine beliebige Zeit lang den Taster; in der oberen Balkenanzeige wird die verstrichene Zeit dargestellt, in der unteren eine durch die Zeitstempel der EL1258 ermittelte Zeitspanne.
Dies wird wie auch für Visualisierung_2 bei der kontinuierlichen Ausgabe eines Bitmusters oder einer pseudo-Zufallsfolge angewendet. Hier sind sämtliche Variationen möglich, die das Verhalten der EL1258 aufzeigen sollen: u.a. eine Rekonstruktion des Bitmusters über die Zeitstempel der eingegangenen Ereignisse (rechte Seite):
Beispielprogramm EL1258/ Visualisierung_2: Darstellung eingegangener Ereignisse in zeitlicher Abfolge anhand der Zeitstempel der EL1258
Mit dem in der POU „PulseOutputs“ festgelegten Bitmuster (linke Seite):
Dieses Bitmuster ist in der Konstanten „nOutValueInit“ als ein 64-Bit Wert in binären Format abgelegt und kann hier mit einer anderen Bitfolge verändert werden. Des Weiteren stellt die Visualisierung_2 ein grundlegendes Vorgehen für die Verarbeitung der Eingangssignale der EL1258 dar: nachdem programmintern aktuelle Zeiten (aInputEventTimes) mit ihren dazugehörigen Zuständen (aInputEventState) verarbeitet wurden, wird geprüft, ob noch Ereignisse im Puffer vorliegen (nEventsInInputBuffer). Dies wird wie folgt illustriert:
Abfrage des „EventsInInputBuffer“ der EL1258: liegen weitere in der Klemme gespeicherte Ereignisse vor?
Mittels „LimitOfEventsInInputBuffer“ kann Anwenderseitig festgelegt werden, ab wann die gepufferten Ereignisse an die auslesbaren PDOs der Klemme übergeben werden sollen. Die Implementierung in MAIN wird hier durch die grafisch dargestellte bedingte Verzweigung wiedergegeben und soll zeigen, dass durch das hochzählen des „InputOrderCounter“ gespeicherte Ereignisse in der Klemme nach „außen“ zu den PDOs weitergegeben werden.
Verwendung des Beispielprogramms für die EL1259
Falls das Beispielprogramm für die EL1259 verwendet werden soll, ist diese Klemme entsprechend anstelle der EL1258 in der Konfiguration einzusetzen. Sämtliche zum gewählten Eingangskanal zugehörige PDO müssen mit den entsprechenden Programmvariablen verknüpft werden. Gemäß der Abbildung „CoE Objekt 0x8000 (MTI settings Ch.1): Einstellungen für das Beispielprogramm“ oben ist bei dieser Klemme eine äquivalente Konfiguration von Kanal 1 im CoE Objekt 0x8080 vorzunehmen.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Wiederherstellen des Auslieferungszustandes
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite. Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist. Dadurch kann es zur Beschädigung des Gerätes kommen! Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
EL1258
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 | 01 | EL1258-0000-0016 | 07/2013
 | 02 |  | 12/2013
 | 03 |  | 01/2014
01 | 04 |  | 06/2015
02 – 03* | 05 | EL1258-0000-0017 | 09/2015
 | 06 |  | 06/2015
 | 07* |  | 07/2018
EL1259
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 – 01 | 01 | EL1259-0000-0016 | 01/2013
 | 02 |  | 12/2013
 | 03 | EL1259-0000-0017 | 07/2014
02* | 04 | EL1259-0000-0018 | 02/2018
 | 05* |  | 06/2019
EL2258
Hardware (HW) | Firmware (FW) | Revision-Nr. | Release-Datum
00 - 01 | 01 | EL2258-0000-0016 | 07/2013
 | 02 |  | 12/2013
 | 03 | EL2258-0000-0017 | 07/2014
02* | 04 |  | 07/2018
 | 05* |  | 06/2019
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Firmware/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Wiederherstellen des Auslieferungszustandes

Anhang [image] Wiederherstellen des Auslieferungszustandes
Wiederherstellen des Auslieferungszustandes
Um den Auslieferungszustand der Backup-Objekte bei den ELxxxx-Klemmen wiederherzustellen, kann im TwinCAT System Manger (Config-Modus) das CoE-Objekt Restore default parameters, Subindex 001angewählt werden (s. Abb. Auswahl des PDO‚ Restore default parameters)
Auswahl des PDO Restore default parameters
Durch Doppelklick auf SubIndex 001 gelangen Sie in den Set Value -Dialog. Tragen Sie im Feld Dec den Wert 1684107116 oder alternativ im Feld Hex den Wert 0x64616F6C ein und bestätigen Sie mit OK (Abb. Eingabe des Restore-Wertes im Set Value Dialog).
Alle Backup-Objekte werden so in den Auslieferungszustand zurückgesetzt.
Eingabe des Restore-Wertes im Set Value Dialog
Alternativer Restore-Wert
Bei einigen Klemmen älterer Bauart lassen sich die Backup-Objekte mit einem alternativen Restore-Wert umstellen: Dezimalwert: 1819238756, Hexadezimalwert: 0x6C6F6164. Eine falsche Eingabe des Restore-Wertes zeigt keine Wirkung!


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.