EK9300 - PROFINET-Buskoppler für EtherCAT-Klemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
3.2.5
▪
Update Kapitel „Konfiguration“
▪
Update Struktur
3.2.4
▪
Update UL-Hinweise
3.2.3
▪
Update Technische Daten
▪
Update Struktur
3.2.2
▪
Update Kapitel „Image des Buskopplers aktualisieren“
3.2.1
▪
Technische Daten aktualisiert
3.2.0
▪
Konfiguration Ab Firmware-Version 8 hinzugefügt
▪
Technische Daten aktualisiert
3.1.0
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Update Kapitel "EK9300 - PROFINET" -> "EKxxxx - Systemübersicht"
▪
Update Kapitel "Technische Daten"
▪
Hinweis zum ESD-Schutz eingefügt
▪
Kapitel "ATEX - Besondere Bedingungen (Standardtemperaturbereich)" und Hinweis "ATEX - Dokumentation" eingefügt
▪
Kapitel "UL Hinweise" eingefügt
3.0.0
▪
Migration
▪
Strukturupdate
2.1.0
▪
Kapitel COE-Datenzugriff über PROFINET hinzugefügt
▪
Kapitel Multikonfigurationsmodus hinzugefügt
▪
Kapitel IO-LINK hinzugefügt
2.0.0
▪
Ergänzungen und Korrekturen
▪
Erste Veröffentlichung
1.0.1
▪
Ergänzungen und Korrekturen
1.0.0
▪
Vorläufige Version


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie durch Leerzeichen ersetzt. Die Daten unter den Positionen 1-4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971 , 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BICs
Beispiel einer zusammengesetzten Information aus den Positionen 1 - 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
Aufbau des BICs
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EKxxxx - Systemübersicht
•
Technische Daten
•
Technische Daten PROFINET


EKxxxx - Systemübersicht

Produktübersicht [image] EKxxxx - Systemübersicht
EKxxxx - Systemübersicht
EtherCAT-Klemmen an einem Buskoppler der Serie EKxxxx
Die Buskoppler der Serie EKxxxx ermöglichen den Betrieb von EtherCAT-Klemmen an herkömmlichen Feldbussystemen. Die ultraschnellen und leistungsfähigen EtherCAT-Klemmen mit ihrer großen Signalauswahl stehen somit auch für andere Feldbus- und Industrial-Ethernet-Systeme zur Verfügung.
Die EKxxxx-Buskoppler sind Feldbus-Slaves und beinhalten einen EtherCAT-Master für die EtherCAT-Klemmen. Sie setzten die Telegramme des übergeordneten Feldbus-Systems auf die E-Bus-Signaldarstellung um. Eine Station besteht aus einem EKxxxx und einer Anzahl von EtherCAT-Klemmen.
Über die entsprechenden Konfigurationstools der Feldbussysteme und die dazugehörigen Konfigurationsdateien, wie z. B. GSD, ESD oder GSDML, werden die EKxxxx auf die gleiche Weise eingebunden, wie die Buskoppler der Serie BKxxxx.
EtherCAT ermöglicht einen sehr flexiblen Topologieaufbau. Durch die Ethernet-Physik können auch weite Distanzen überbrückt werden, ohne dass die Busgeschwindigkeit beeinflusst wird. Bei einem Wechsel in die Feldebene – ohne Schaltschrank – lassen sich auch die EtherCAT-Box-Module (EPxxxx) in Schutzart IP65 mit den EK9xxx verbinden.
Buskoppler für verschiedene Feldbus-Systeme
Die Varianten der Serie EKxxxx unterscheiden sich voneinander durch die Schnittstelle für das übergeordnete Feldbus-System.
Eine Übersicht der verschiedenen Beckhoff Buskoppler, die die wichtigsten Feldbus-Systeme abdecken, finden Sie auf der Beckhoff Website.
Embedded-PCs mit Feldbus-Interface und dezentraler Steuerung
Die mit TwinCAT programmierbare Variante ist die Embedded-PC-Serie CX80xx.
Die Varianten der Serie CX80xx unterscheiden sich voneinander durch die Schnittstelle für das übergeordnete Feldbus-System und der Möglichkeit diese zu Programmieren.
Eine Übersicht der verschiedenen Beckhoff Embedded-PCs, die die wichtigsten Feldbus-Systeme abdecken, finden Sie auf der Beckhoff Website.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EK9300
Protokoll | PROFINET
Schnittstellen | 2 x Ethernet 100 MBit/s, 1 x USB-Device (hinter der Frontklappe)
Businterface | 2 x RJ 45 (switched)
I/O-Anschluss | E-Bus (EtherCAT-Klemmen)
Web-base Management | ab Firmware 08
I/O-Klemmen | E-Bus (EL, ES, EP)
Spannungsversorgung | 24 VDC (-15%/+20%)
Eingangsstrom | 120 mA typ. + (ges. E-Bus-Strom)/4
Powerkontakte | 24 VDC max./10 A max.
Stromversorgung I/O-Klemmen | 2 A
Max. Verlustleistung | 3 W
Max Größe Prozessdaten | max. 1440 Byte In- und Output Daten
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/Ethernet)
Abmessungen (B x H x L) | 64 mm x 100 mm x 73 mm
Betriebs-/Lagertemperatur | 0…+55°C/-25…+85°C
Relative Feuchte | 95 % ohne Betauung
Schwingungs-/Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27
EMV-Festigkeit/-Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP20/beliebig
Zulassungen | CE cULus ATEX IECEx
Systemdaten | PROFINET (EK9300)
Anzahl der E/A-Module | steuerungsabhängig
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | 4 x 2 Twisted-Pair-Kupferkabel Kategorie 5 (100 MBaud)
Leitungslänge | 100 m
Übertragungsrate | 100 MBaud
Topologie | sternförmige Verkabelung, Linientopologie


Technische Daten PROFINET

Produktübersicht [image] Technische Daten PROFINET
Technische Daten PROFINET
Technische Daten Ethernet | EK9300
Anzahl der Ports | 2
integrierter Swtich | 2 x Ethernet 100 MBit/s, 1 x USB-Device (hinter der Frontklappe)
Businterface | 2 x RJ 45 (switched)
100 Mbit/s | Ja, PROFINET vollduplex
Autocrossing | Ja
Protokoll |
PROFINET IO-DEVICE | Ja
ADS Interface | Ja
Dienste |
IRT | nein
TCP/IP ADS | Ja
Shared Device | Ja
Priorisierter Hochlauf | nein
MRP | Ja
SNMP | Ja
LLDP | Ja
ARP | Ja
LLDP | Ja
DHCP | Ja
Diagnose/Status/Alarm |
RUN LED | Ja, grün/rot
PN LED | Ja, grün/rot
DIAG LED | Ja, grün/rot
Verbindungsanzeige LINK TX/RX | Ja
Alarme | Ja
Diagnosemeldungen | Ja


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Montage
•
Verdrahtung


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Abmessungen
•
Tragschienenmontage - Buskoppler


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Montage [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Die folgenden Grafiken zeigen die Abmessungen der Buskoppler.
Zeichnungen im DWF- und STEP-Format finden Sie im Download-Bereich der Beckhoff-Website.
EK9xxx - Abmessungen am Beispiel EK9300


Tragschienenmontage - Buskoppler

Montage und Verdrahtung [image] Montage [image] Tragschienenmontage - Buskoppler
Tragschienenmontage - Buskoppler
Aufrasten auf die Tragschiene
Der Buskoppler kann einfach auf die Tragschiene aufgerastet werden. Dazu wird der Block frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Dies wird durch ein vernehmliches Klicken angezeigt. Mit einem Schraubendreher wird dann die Arretierung auf der linken Seite nach oben gedrückt wodurch sich die Arretierung dreht und ebenfall hörbar einrastet.
EK9300 - Aufrasten auf die Tragschiene
Hinweis
Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!
Einbaulagen
Die Einbaulage des Buskopplers ist beliebig.
Hinweis
Einbaulagen von EtherCAT-Klemmen
Beachten Sie die Einbaulage der eingesetzten EtherCAT Klemmen, nicht alle haben eine beliebige Einbaulage. Achten Sie auf die jeweiligen EtherCAT-Infrastrukturkomponenten und Installationshinweise.
Empfohlene Abstände bei Standard Einbaulage
Hinweis
Zulässige Einbaulage und Mindestabstände einhalten!
Wir empfehlen den Einbau in horizontaler Ausrichtung für eine optimale Durchlüftung, des Weiteren erübrigt sich bei dieser Einbaulage das Überprüfen ob Klemmen dabei sind, die nur horizontal verbaut werden dürfen.
Weitere Einbaulagen sind erlaubt aber werden nicht empfohlen.
Weitere Einbaulagen


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Spannungsversorgung
•
Ethernet
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation
•
UL-Hinweise


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
Das Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24 V" und "0 V".
Die Versorgungsspannung versorgt das EK-System und über den Klemmenbus die Busklemmen mit einer Spannung von 24 VDC (-15%/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 V. Da der Klemmenbus (E-Bus) nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.
Spannungsversorgung Buskoppler EK9300
Anforderungen an das 24 V Netzteil
Um in allen Fällen den Betrieb des Buskopplers und des Klemmenstrangs zu gewährleisten, muss das Netzteil 2,0 A bei 24 V liefern.
LED
Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün auf. Die linke LED (Us) zeigt die Versorgung der CPU an. Die rechte LED (Up) zeigt die Versorgung der Klemmen an. Die weiteren LEDs beschreiben den Status des Klemmenbusses. Die detaillierte Beschreibung der LEDs ist in dem Kapitel Fehleranalyse der LEDs beschrieben.
PE-Powerkontakte
Hinweis
Powerkontakt "PE"
Der Powerkontakt "PE" darf nicht für andere Potenziale verwendet werden.


Ethernet

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet
Ethernet
Weiterführende Informationen
•
Ethernet-Anschlüsse
•
Ethernet-Kabel
•
EK9300 Topologiebeispiel


Ethernet-Anschlüsse

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet [image] Ethernet-Anschlüsse
Ethernet-Anschlüsse
RJ45-Schnittstelle
Belegung der RJ45-Schnittstelle, Port 1
X001
PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8
Belegung der RJ45-Schnittstelle, Port 2 (switched)
CX8010, CX809x: X101 / 102
EK9xxx: X001 / X002
PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8


Ethernet-Kabel

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet [image] Ethernet-Kabel
Ethernet-Kabel
Übertragungsstandards
10Base5
Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.
10Base2
10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.
10BaseT
Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.
100BaseT
Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.
10BaseF
Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.
Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT
Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.
UTP
Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und ist für industrielle Umgebungen nicht empfehlenswert.
S/UTP
Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.
FTP
Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat einen alukaschierten Kunststoff-Folie-Gesamtschirm.
S/FTP
Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70 dB erreichen.
STP
Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.
S/STP
Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Eine solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.
ITP
Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


EK9300 Topologiebeispiel

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet [image] EK9300 Topologiebeispiel
EK9300 Topologiebeispiel
EK9300
Der Aufbau der EK9300 kann in einer Linie erfolgen, hierbei sollten folgende Punkte eingehalten werden:
- Maximal 20 Koppler hintereinander
- Es sollten keine Switches in der Linie verwendet werden
EK9300 - Topologiebeispiel
Einsatz von Switch ohne LLDP
PROFINET verwendet zur Topologie Erkennung das LLDP Protokoll. Sollte der Switch den Sie einsetzen dies nicht unterstützen, funktioniert die Topologie-Erkennung und die damit verbundenen PROFINET-Dienste nicht ordnungsgemäß. Außerdem kommt es zu einem erhöhten Netzwerkverkehr der sich mit jedem Switchport und angeschlossenem PROFINET-Teilnehmer vervielfältigt. Als Auswirkungen können Störungen der Kommunikation bis hin zum Kommunikationsabbruch einzelner PROFINET Teilnehmer zustanden kommen.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 2014/34/EU)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60079-15 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die gemäß ATEX-Richtlinie für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … +55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … +55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


UL-Hinweise

Montage und Verdrahtung [image] Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Bedeutung des DIP-Schalters
•
Weitere Schnittstellen
•
Einstellung der IP-Adresse


Bedeutung des DIP-Schalters

Parametrierung und Inbetriebnahme [image] Bedeutung des DIP-Schalters
Bedeutung des DIP-Schalters
10 poliger DIP-Schalter S001
Der DIP-Schalter hat folgende Bedeutung für die Ethernet Schnittstellen X001 und X002 die geswitcht sind:
DIP-Schalter S001: Links off ”0“, rechts on “1”
DIP 9
DIP 10
Beschreibung
DIP 1..8
Verhalten bei Neustart
Verhalten bei Herstellereinstellung
0
0
Letztes Byte der IP-Adresse über die DIP-Schalter 1 bis 8
▪
PN-Name aus dem Speicher
▪
IP-Adresse über DIP-Schalter
172.16.17.xxx (xxx DIP-Schalter)
SNM 255.255.0.0
▪
PN-Name wird Leerstring
▪
IP-Adresse über DIP-Schalter
172.16.17.xxx (xxx DIP-Schalter)
SNM 255.255.0.0
0
1
DHCP
DIP-Schalter 1 bis 8 auf OFF
▪
PN-Name aus dem Speicher
▪
IP-Adresse und SNM über DHCP
▪
PN-Name wird Leerstring
▪
IP-Adresse und SNM über DHCP
DHCP
DIP-Schalter 1 bis 8 auf ON
▪
PN-Name aus dem Speicher
▪
IP-Adresse aus dem Speicher
▪
PN-Name wird Leerstring
▪
IP-Adresse 0.0.0.0
1
0
Reserviert
1
1
PROFINET-konform
DIP-Schalter 1 bis 8 auf OFF
▪
PN-Name aus dem Speicher
▪
IP-Adresse aus dem Speicher
▪
PN-Name wird Leerstring
▪
IP-Adresse 0.0.0.0
PROFINET mit festem Namen
DIP-Schalter 1 bis 8 auf ON
▪
PN-Name über
DIP-Schalter 1 bis 8
▪
IP-Adresse aus dem Speicher
▪
PN-Name über
DIP-Schalter 1 bis 8
▪
IP-Adresse 0.0.0.0
2-poliger DIP-Schalter (unter der Klappe zwischen Batterie und SD Kartenslot)
DIP Schalter (rot) | Bedeutung
1 off und 2 off | normaler Modus, Koppler wird gestartet
1 on und 2 off | Der EK startet im Config Mode, über die USB Schnittstelle ist der interne Flash Speicher zu erreichen (zum Beispiel für ein Image Update).
1 off und 2 on | Herstellereinstellung
1 on und 2 on | bislang keine Funktion


Weitere Schnittstellen

Parametrierung und Inbetriebnahme [image] Weitere Schnittstellen
Weitere Schnittstellen
Unter der Klappe des EK9xx0 befinden sich zusätzliche Schnittstellen.
Zusätzliche Schnittstellen der EK9xx0
Batterie
Für den EK9xx0 wird keine Batterie benötigt, daher ist diese Option nicht enthalten.
Roter DIP-Schalter
Default Einstellung ist OFF/OFF.
Um zum Beispiel ein neue Firmware über USB auf den EK zu spielen, muss vor dem Einschalten der erste DIP Schalter auf "1" gestellt werden. Leuchtet die RUN LED blau, kann man den EK mit einem USB-Kabel mit dem PC verbinden. Der PC findet dann den internen Flash als Speichermedium. Das Speichermedium darf nicht formatiert werden!
Micro SD-Karte
Alternativ kann auch die Firmware auf eine SD-Karte gespielt werden. Ist eine SD-Karte im Slot vorhanden wird immer von dieser gebootet. Dies kann man zum Beispiel nutzen, um eine Firmware zu testen bevor man diese auf den internen Flash des EKs kopiert.
USB Interface
Das USB Interface kann nur genutzt werden, wenn der "rote" DIP-Schalter entsprechend gesetzt wurde. Siehe "Roter DIP-Schalter".


Einstellung der IP-Adresse

Parametrierung und Inbetriebnahme [image] Einstellung der IP-Adresse
Einstellung der IP-Adresse
In der Regel wird die IP-Adresse vom PROFINET Controller vergeben. Per Default hat der EK9300 keine IP-Adresse. Um das Gerät aber per ADS zu erreichen, ist eine IP-Adresse notwendig. Diese kann per DHCP (es muss ein DHCP-Server vorhanden sein) vergeben werden oder es kann mit einer festen IP Adresse gearbeitet werden. Siehe Kapitel DIP-Schalter.
Wird der PROFINET Controller angeschlossen, wird die IP-Adresse für die PROFINET Kommunikation verwendet die der Controller vorgibt. Die IP-Adresse die fest oder vom DHCP vergeben worden ist wird überschrieben.
Eine weitere Möglichkeit ist über die vom Controller vergebene IP-Adresse mit dem EK9300 zu kommunizieren, dafür muss aber das Gerät mindestens einmal vom PROFINET Controller / Engineering initialisiert worden sein.


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Darstellung eines EtherCAT-Slaves am PROFINET
•
EK9300 Konfiguration
•
EK9300 Konfiguration EtherCAT
•
EK9300 - Konfigurationsbeispiel
•
Ab Firmware-Version 6
•
Ab Firmware-Version 8


Darstellung eines EtherCAT-Slaves am PROFINET

Konfiguration [image] Darstellung eines EtherCAT-Slaves am PROFINET
Darstellung eines EtherCAT-Slaves am PROFINET
Dieser Abschnitt soll helfen, die Beschreibung von EtherCAT-Geräten auf ein anderes Feldbussystem zu erläutern und die entsprechenden Informationen aus den bestehenden EtherCAT-Dokumentationen zu erhalten. Dabei werden im Folgenden Begriffe zum besseren Verständnis erklärt.
• Einleitung
EtherCAT-Geräte wie EL-Klemmen (ES, ELX, ELM), EP Module (ER, EQ, EPP) sind EtherCAT-Slave-Geräte die immer aus Prozessdaten und gegebenenfalls aus Parameter-Daten bestehen. In der Regel besitzen digitale EtherCAT-Geräte keine Konfigurationsdaten. Komplexe EtherCAT-Geräte in der Regel immer.
• Prozessdaten (PDO, Prozessdaten-Objekt)
So gut wie alle EtherCAT-Geräte haben Prozessdaten1), die von 2 Bit und bis zu mehreren 100 Byte groß sein können. Bei komplexen EtherCAT-Geräten kann man auch unterschiedliche Strukturen und Größen der Prozessdaten vorgeben. Diese werden als Predefined-PDOs bezeichnet.
Die Predefined-PDOs müssen vom EtherCAT (EC) Master vorgegeben werden und beim Starten des EC-Masters bekannt sein, bzw. hier eingestellt werden. Es gibt immer ein Default Predefined-PDO. Je nach eingesetzten überlagerten Bussystem kann das PDO-Mapping über den überlagerten Feldbussystem (wie bei PROFINET oder PROFIBUS) oder einer Konfigurationsseite (http-Protokoll, wie beim ModbusTCP oder EtherNet/IP) auf dem EK-Koppler eingestellt werden.
1) Außer z.B. der EK1100 Koppler, dieser besitzt weder Prozessdaten noch Konfigurationsdaten, ist aber mit einem EtherCAT-ASIC ausgestattet und sind somit auch ohne Prozessdaten im EtherCAT-Netzwerk sichtbar.
Parameter-Daten (COE)
Die Parameterdaten eines EC-Slaves werden über COE übertragen (CAN over EtherCAT). Diese sind wie bei CAN in Objekte, Subobjekte und Daten aufgeteilt. Parameter-Daten sind zum Beispiel Daten, die bei einer EL3202 Klemme, also einer Temperaturwiderstandsklemme, den Widerstandwert einstellt, wie zum Beispiel PT100, PT1000, NI100 usw.
Es werden beim EK-Koppler nur die applikationsspezifischen COE-Daten zur Verfügung gestellt. Je nach überlagerten Bussystem kann hier auf alle oder nur einige COE-Objekte zugegriffen werden.
Auch hier kann die Parametrierung über eine Webseite (http-Protokoll) im EK stattfinden.
PROFINET
• Prozessdaten
PROFINET-Device-Geräte (Slaves) müssen eine GSDML Datei mitbringen. In dieser GSDML werden die Geräte beschrieben (Download: Konfigurationsdatei). Der EK9300 ist ein Gerät mit modularen Aufbau. Dieser besteht aus der Kopfstation (dem EK9300) und einer Anzahl von EtherCAT-Teilnehmern, die an den EK9300 angeschlossen werden. Im PROFINET-Controller muss diese Datei (GSDML) dann eingebunden werden. Ist dies erfolgt, kann man jetzt den Koppler und die EtherCAT-Klemmen einbinden und die entsprechenden Einstellungen vornehmen.
• Wie erhalte ich eine Beschreibung der EtherCAT-Prozessdaten?
Die Predefined-PDOs bestehen in der Regel aus verschiedenen PDOs und sind eine Zusammenstellung unterschiedlicher PDOs des Prozessabbildes.
Im Folgenden ist das mit der Automatisierungssoftware TwinCAT dargestellt:
Typische Konfigurationsseite einer EtherCAT-Klemme
Legende:
1.
Die EtherCAT-Klemme ist im TwinCAT-Baum eingefügt und hat Prozessdaten, die man mit dem SPS- Programm verknüpfen kann.
2.
Ansicht der vorhandenen Prozessdaten in Byte (genau diese Anzahl und Größe sieht man bei PROFINET und der Siemens Steuerung, Siemens stellt die Prozessdaten nicht weiter detaillierter dar obwohl diese in der GSDML beschrieben sind)
3.
Anzeige, welche PDOs in den Prozessdaten aktiv sind
4.
Ansicht aller PDOs
5.
Detaillierter einzelner PDOs die man in „4“ auswählen kann
6.
Predefined-PDOs
In der GSDML sind immer nur die Predefined-PDOs auswählbar (6). Will man eine andere Kombination der PDOs, geht dies nur über eine Beckhoff-Steuerung, wie zum Beispiel den CX8093, der über eine Default PROFINET-Schnittstelle verfügt und mit TwinCAT 2 programmierbar ist (bei TwinCAT 3 ist ein CX9020 mit B930 Interface notwendig, oder eine beliebige Beckhoff-Steuerung mit einer EL6631-0010).
Beispiel Mapping einer EL3162 im Standard-Format ( 8 Byte IN / 0 Byte OUT)
Name | Size (Variable) | Bit offset
AI Standard Channel 1.BitArray
Status_Underrange | BIT (BOOL) | 0.0
Status_Overrande | BIT (BOOL) | 0.1
Status_Limit_1[0] | BIT (BOOL) | 0.2
Status_Limit_1[0] | BIT (BOOL) | 0.3
Status_Limit_1[0] | BIT (BOOL) | 0.4
Status_Limit_1[0] | BIT (BOOL) | 0.5
Status_Error | BIT (BOOL) | 0.6
Status_Sync error | BIT (BOOL) | 1.5
Status_TxPDO State | BIT (BOOL) | 1.6
Status_TxPDO Toggle | BIT (BOOL) | 1.7
AI Standard Channel 1.Value | 16 BIT (INT) | 2.0..3.7
AI Standard Channel 2.BitArray
Status_Underrange | BIT (BOOL) | 4.0
Status_Overrande | BIT (BOOL) | 4.1
Status_Limit_1[0] | BIT (BOOL) | 4.2
Status_Limit_1[0] | BIT (BOOL) | 4.3
Status_Limit_1[0] | BIT (BOOL) | 4.4
Status_Limit_1[0] | BIT (BOOL) | 4.5
Status_Error | BIT (BOOL) | 4.6
Status_Sync error | BIT (BOOL) | 5.5
Status_TxPDO State | BIT (BOOL) | 5.6
Status_TxPDO Toggle | BIT (BOOL) | 5.7
AI Standard Channel 2.Value | 16 BIT (INT) | 6.0..7.7
Parameter-Daten
Im Folgenden soll auf die Parameter- oder auch Konfigurationsdaten eingegangen werden. Die meisten notwendigen Konfigurationsdaten sind in der GSDML enthalten, Beckhoff verwendet hier die gleichen Namen und Bedeutungen wie auf der EtherCAT-Seite, die in der ESI Datei2) in der CoE-Beschreibung enthalten ist.
EtherCAT: Parameter-Daten der EL3162 der ESI unter TwinCAT
PROFINET: Parameterdaten der EL3162 der GSDML unter TwinCAT
2) Die ESI Datei ist die Beschreibungsdatei für EtherCAT-Master (ESI-EtherCAT-Slave-Information).
Parameterdaten der EL3162 der GSDML unter TwinCAT
Diese Parameter zu den einzelnen Klemmen finden Sie auch im Konfigurationstool Ihres PROFINET- Controller wieder, egal welchen Hersteller Sie hier verwenden. Sie können auf einzelne Parameter auch über PROFINET und den Record-Daten azyklisch zugreifen. Dafür muss der PROFIENT-Controller über ein Interface zu den Record-Daten verfügen. Eine CoE-Protokoll-Beschreibung und wie diese über PROFINET genutzt werden kann, ist im EK9300 Handbuch beschrieben.


EK9300 Konfiguration

Konfiguration [image] EK9300 Konfiguration
EK9300 Konfiguration
GSDML-Datei
Nur Klemmen, die in der GSDML-Datei vorhanden sind, werden unterstützt, Erweiterungen sind aber möglich. Die GSDML unterstützt Submodule, informieren Sie sich bei Ihrem PROFINET Master/Controller ob dieser Submodule unterstützt. Sollte dies nicht der Fall sein, sind einige Klemmen nicht verwendbar!
Alternativ kann auch der CX8093 eingesetzt werden, dieser unterstützt im Allgemeinen alle EtherCAT-Slaves.
Allgemein
Der EK9300 PROFINET Koppler wird immer mit Hilfe einer GSDML-Datei im Controller (Master) eingebunden. Die GSDML enthält alle Parametrierungsdaten, die für den Betrieb des Kopplers am Controller notwendig sind. Das Konfigurationswerkzeug liest diese Datei ein und stellt dem Anwender die Daten dann zur Verfügung.
In der GSDML-Datei sind auch die entsprechenden Klemmen die am EK9300 betrieben werden können, angegeben. Es werden nicht alle EtherCAT-Klemmen unterstützt. Informieren sie sich deshalb vorab, ob die Klemmen die Sie einsetzen möchten auch von dem Koppler unterstützt werden.
Daten im DAP (Device Access Point)
Im DAP Der GSDML-Datei befinden sich 2 x 2 Byte Daten.
Das ist zum einen der ECCycleCounter (2 Byte). Dieser wird mit jedem EtherCAT-Zyklus (1 ms) inkrementiert, vorausgesetzt der EC Master befindet sich im Zustand "OP".
Außerdem befindet sich am DAP der Status (2 BYTE). Dieser gibt bitweise einzelne Statusinformation wieder. Diese sind derzeit wie folgt belegt:
▪
Bit 0 - IsSynchron - Wird gesetzt, wenn der als PTP-Slave oder IRT-Device betrieben wird und synchron ist.
▪
Bit 1 - IsPTPMaster - Wird gesetzt, wenn der EK9300 als PTP-Master betrieben wird.
▪
Bit 2 - ECFrameError - Wird gesetzt, wenn am EtherCAT ein Problem festgestellt wird. Um hierzu weitere Informationen zu erhalten, muss die PROFINET-Diagnose bzw. die Alarme ausgelesen werden.
Parameter im DAP
Aktiviere PN Rücksetzwert - Aus -> EtherCAT-Daten werden auf Null geschrieben. An -> es besteht die Möglichkeit bei Ausgängen einen anderen Default-Wert zu benutzen. Bei digitalen Ausgängen kann zum Beispiel der aktuelle Ausgangsprozesswert bei PROFINET Kommunikationsfehler eingefroren, zu 0 oder zu 1 gesetzt werden.
Daten Präsentation - Intel Format Daten werden im Intel Format dargestellt, Motorola Format Daten werden im Motorola Format dargestellt. Zum Beispiel werden bei Wort Variablen High und Low Byte getauscht.
EBus Fehler Verhalten - Setze IOs zu 0 -> Bei EC Fehler werden ein und Ausgangsdaten auf Null geschrieben. Legacy -> Eingangsdaten behalten ihren letzten Zustand bei werden aber nicht mehr aktualisiert; Ausgangsdaten können noch gesetzt werden (abhängig von der Position der Klemme).
Mapping
Typischerweise wird der Koppler im Verbund mit Klemmen eingesetzt, die an dem Koppler angeschlossen werden. Die Klemmen sind Bestandteil der GSDML; Die Parametrierung der Klemmen geschieht vom PROFINET Controller aus.
Das Mapping ist steckplatzorientiert, d.h. Sie müssen die Klemmen genauso in den Hardware-Konfigurator eintragen wie diese auch physikalisch angeschlossen sind. Etwas komplizierter wird es, wenn EtherCAT-Verteilerboxen eingesetzt werden. Hier ist es wichtig zu wissen, in welcher Reihenfolge die weiteren EtherCAT-Klemmen in das Prozessabbild eingetragen wurden (siehe EtherCAT Mapping).
Verhalten beim Starten des Buskopplers
Beim Starten des Buskopplers (oder Reset) müssen immer alle EtherCAT-Teilnehmer vorhanden sein. D.h. alle EtherCAT-Slaves müssen vor bzw. gleichzeitig mit Spannung versorgt werden, damit der Koppler am PROFINET auch ordnungsgemäß aufstartet.
Flexibler kann man eine Lösung mit dem CX8093 aufbauen.
Konfiguration der EtherCAT-Teilnehmer
Es gibt 4 Arten von EtherCAT-Teilnehmern:
▪
EtherCAT-Teilnehmer ohne Prozessdaten
▪
EtherCAT-Teilnehmer mit "einfachen" Prozessdaten ohne Parametrierung (in der Regel einfache digitale Klemmen)
▪
EtherCAT-Teilnehmer mit "einfachen" Prozessdaten mit Parametern (in der Regel analoge Signale)
▪
EtherCAT-Teilnehmer mit unterschiedlichen Prozessdaten und Parametern (zum Beispiel Inkrementalencoder)
Für alle gilt, sie müssen in der Konfiguration eingetragen werden.
Digitale Ein- und Ausgänge zusammenfassen (Pack-Klemmen)
Die digitalen Ein- und Ausgangsklemmen können auch von Ihren Prozessdaten zusammengefasst werden. Diese Möglichkeit kann bei 2 oder 4 Kanal Klemmen verwendet werden. Dafür muss in der GSDML-Datei eine 2 oder 4 Kanal Pack-Klemme (ohne Stern) angefügt werden. Um das Byte zu füllen, muss als nächstes eine 2 oder 4 Kanal Pack-Klemme (mit Stern) angefügt werden. Die Klemmen müssen physikalisch und systematisch hintereinander gesteckt sein, bzw. logisch. Es darf die Byte-Grenze nicht überschritten werden.
Beispiel:
2 Kanal Pack (ohne Stern), danach dürfen 3 Module aus 2 Kanal Pack-Klemmen (mit Stern) angefügt werden.
Nicht erlaubt ist:
2 Kanal Pack (ohne Stern), danach 2 Module aus 4 Kanal Pack-Klemmen (mit Stern). Die Byte Grenze wird überschritten.
EtherCAT-Klemmen mit unterschiedlichen Mapping-Möglichkeiten
Einige EtherCAT-Klemmen bieten die Möglichkeit, unterschiedliche Prozessdaten darzustellen. Diese werden anhand der Parameter unterschiedlich dargestellt. Im PROFINET Controller wird so eine Klemme durch Submodule dargestellt. Es wird immer das Standardmapping eingebunden. Wollen Sie abweichend vom Standard ein anderes Mapping benutzen, so löschen sie das Standard-Submodul und fügen Sie das ein, was sie verwenden wollen. Es kann sein, das abweichend von der Dokumentation der EtherCAT-Klemme oder EtherCAT-Box, nicht alle Mappings unter dem PROFINET Koppler verwendet werden können.
Beispiel eine EL5101:
Einfügen eines Submoduls
EtherCAT Gateway Klemmen
Die Gateway-Klemmen unterstützen mehrere Submodule, das erste bzw. Grundmodul wird sofort geladen; es müssen die Module für die Prozessdaten angelegt werden. Diese müssen anschließend auch auf der Master-Seite des entsprechenden Gateways parametriert werden. Es sind nicht alle Features einer Gateway-Klemme am EK9300 nutzbar.
EL6631-0010
Die PROFINET-Device-Klemme ermöglicht 2 verschiedenen PROFINET-Netzwerke zu verbinden, es wird am EK nur ein Device Interface unterstützt. Ein Default-Stationsname sowie IP-Einstellungen können über Parametrierdaten (GSDML) erfolgen. Es ist darauf zu achten, dass nicht die komplette maximale Datenlänge der EL6631-0010 verwendet werden kann. Die Länge ist abhängig von den anderen EtherCAT-Teilnehmern die am EK9300 hängen.
EL6731-0010
Die PROFIBUS-Slave-Klemme ermöglicht die Kommunikation mit einem PROFIBUS Master. Die PROFIBUS-Adresse wird über die Parametersettings (in der GSDML) der Klemme festgelegt. Es können nur reine Prozessdaten ausgetauscht werden.
EL6692
Die EtherCAT-Slave-Klemme ermöglicht die Kommunikation mit einem EtherCAT Master. Es können nur reine Prozessdaten ausgetauscht werden.
EL6652-0010
Die EtherNet/IP Slave Klemme ermöglicht die Kommunikation mit einem EtherNet/IP Master, es wird am EK nur ein Slave Interface unterstützt. Die IP-Adresse und Subnetmaske wird über die Parametersettings (In der GSDML) der Klemme festgelegt. Es können nur reine Prozessdaten ausgetauscht werden. Die Klemme am EK unterstützt nur ein Slave Interface.


EK9300 Konfiguration EtherCAT

Konfiguration [image] EK9300 Konfiguration EtherCAT
EK9300 Konfiguration EtherCAT
Der EK9300 ist ein EtherCAT-Master mit automatischer Konfiguration. D.h. es müssen beim Einschalten des Systems immer alle EtherCAT-Klemmen vorhanden sein. Da in der Regel das Booten des EK9300 wesentlich länger dauert als das Starten der EtherCAT-Slave-Geräte, können diese an der gleichen Spannungsversorgung betrieben werden. Bei dezentralen EtherCAT-Slaves ist darauf zu achten, dass die früher oder zur gleichen Zeit mit der Versorgungsspannung eingeschaltet werden.
EtherCAT-Teilnehmer während der Laufzeit ein- bzw. ausschalten
Sollte während der Betriebsphase ein oder mehrere EtherCAT-Teilnehmer ausfallen wird ein Plug Alarm gesendet, der EK9300 bleibt im Datenaustausch. Die Eingangsdaten aller EtherCAT-Teilnehmer sind ungültig und werden auf FALSE oder Null gesetzt, die Ausgangsdaten werden nicht mehr übernommen. Das gilt auch für die Teilnehmer, die noch am EK9300 im Betrieb sind. Möchte man die Möglichkeit nutzen während der Laufzeit Teilnehmer an und ab zu stecken, muss eine weitere "Sync Unit" konfiguriert werden. Dies ist mit einem EK9300 nicht möglich. Verwenden Sie in dem Fall einen CX8093.
EtherCAT-Teilnehmer die nicht in der GSDML vorhanden sind
Einige EtherCAT-Slaves sind nicht in der GSDML enthalten und können somit (noch) nicht verwendet werden. Hier kann der CX8093 eingesetzt werden, der vom Prinzip her alle EtherCAT-Geräte unterstützt.
EtherCAT Topologie
Alle EtherCAT-Teilnehmer müssen in der Reihenfolge eingetragen werden, wie sich diese am EK9300 und damit am EtherCAT-Master mappen. EtherCAT-Teilnehmer werden automatisch adressiert, bis auf wenige Ausnahmen sind alle EtherCAT-Busklemmen mit einem EtherCAT ASIC ausgestattet, die auch im System, d.h. den PROFINET Controller, eingetragen werden müssen. EtherCAT-Klemmen ohne ASIC sind zum Beispiel EL9400, EL9070 und weitere EL9xxx. Sie können diese EtherCAT-Klemmen anhand der Technischen Daten "Meldung an E-Bus" erkennen. Steht hier ein "-" muss diese Klemme auch nicht im PROFINET Controller eingetragen werden.
EtherCAT Geräte werden in Richtung des EtherCAT Telegrams eingetragen.
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Boxen EPxxxx
Beispielkonfiguration mit EtherCAT-Boxen EPxxxx
Beispielkonfiguration mit EK1122 2-Port-EtherCAT - Abzweig
Bei dem Einsatz eines EK1122 ist die Zählrichtung zu beachten. Ist am EK1122 der EtherCAT - Abzweig 1 angeschlossen, so wird der EtherCAT Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem E-Bus auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EK1122 2-Port-EtherCAT - Abzweig
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi kurzgeschlossen und der EC-Frame geht direkt aus der Klemme rechts weiter.
Es ist zu beachten, dass im PROFINET Controller die Module in Richtung des EtherCAT Frames eingetragen werden.
Beispielkonfiguration mit EP1122 2-Port-EtherCAT - Abzweig
Bei dem Einsatz eines EP1122 ist die Zählrichtung zu beachten, sie ist vergleichbar mit der EK1122. Ist am EP1122 der EtherCAT - Abzweig 1 angeschlossen, so wird der EtherCAT Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem EC-Bus auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EP1122 2-Port-EtherCAT - Abzweig
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi kurzgeschlossen und der EC-Frame geht direkt aus der Klemme rechts weiter.
Es ist zu beachten, dass im Profinet Controller die Module in Richtung des EtherCAT Frames eingetragen werden.
Konnektierung im laufenden Betrieb
Sie können die EP1122 und EK1122 nicht für Hot-Swap verwenden sowie ein "connect" und "disconnect" im laufenden Betrieb. Die EP1122 und EK1122 eigenen sich im Zusammenspiel mit dem EK Koppler nur als Topologie Erweiterung (Stern).


EK9300 - Konfigurationsbeispiel

Konfiguration [image] EK9300 - Konfigurationsbeispiel
EK9300 - Konfigurationsbeispiel
PDO Mapping
Die Prozessdaten auf der EtherCAT-Seite werden über das PDO Mapping beschrieben. Die einzelnen Klemmen bringen über die ESI-Datei (EtherCAT-Beschreibungsdatei) ein vordefiniertes PDO Mapping mit, also eine sinnvolle Kombination einzelner PDOs.
EK9300 - Auswahldialog Predifined PDO
Diese Kombinationen wiederum werden auf Profinet-Seite anhand unterschiedlicher Submodule, und somit Prozessdaten, beschrieben. D.h. jedes vordefinierte PDO Mapping hat ein zugehöriges Submodul.
EK9300 Submodule
Solche modulare Klemmen haben am EK9300 immer auf Subslot 1 ein festes Submodul stecken. Dieses ist der Platzhalter für die Klemme selbst, d.h. hierüber wird z. B. für die Klemme die allgemein gültige Diagnose betrieben. Auf Subslot 2 werden die eigentlichen Prozessdaten gesteckt und anhand dieser wird das PDO Mapping am EC-Master erzeugt.
SDO Mapping
Jeder der gesteckten Subslots kann Parametrierdaten mit sich bringen. Über diese Daten werden die Service-Daten-Objekte (SDOs) übertragen, d.h. die SDOs werden auf Recorddatensätze abgebildet. Es werden immer die Objekte 0x8xxx und 0xF8xx abgebildet. Da die Indizes auf der PROFINET Seite nur von 0 - 0x7FFF herstellerspezifisch sind, entsprechen die EtherCAT-Objekte 0x8xxx den PROFINET Record Indizes 0x3xxx, EC-Objekte 0xF8xx dem PROFINET Indexbereich 0x48xx. In PROFINET werden die Records immer in der Startup-Phase vom Controller geschrieben, diese werden intern dem EtherCAT-Master als Startup SDOs übergeben. D.h. während eines PROFINET Neustarts wird auch der interne EC-Master neu gestartet.
PROFINET Record Indizes 0x3xxx (entspricht EtherCAT-Objekte 0x8xxx)
Diese Datensätze können auch im laufenden Betrieb gelesen und geschrieben werden.
Inbetriebnahme EL7031
Die Defaulteinstellungen sind für eine Erstinbetriebnahme ausreichend, d.h. es muss nur das entsprechende Submodul ausgewählt werden. Anhand dessen werden die PDOs und SDOs der Klemme parametriert. Wird z. B. das "Velocity Control" Submodul gewählt, muss nur das Control_Enable Bit gesetzt werden, anschließend durch Vorgabe einer Sollgeschwindigkeit den Motor drehen.


Ab Firmware-Version 6

Konfiguration [image] Ab Firmware-Version 6
Ab Firmware-Version 6
Weiterführende Informationen
•
EK9300 - CoE-Datenzugriff über PROFINET
•
EK9300 - Multikonfigurationsmodus
•
EK9300 - IO-LINK


EK9300 - CoE-Datenzugriff über PROFINET

Konfiguration [image] Ab Firmware-Version 6 [image] EK9300 - CoE-Datenzugriff über PROFINET
EK9300 - CoE-Datenzugriff über PROFINET
Beschreibung
CoE bedeutet Can over EtherCAT. Dieser Zugriff erlaubt auf alle Parameter eines EtherCAT-Teilnehmers zuzugreifen. Das CoE-Datenmodell basiert auf den Grundlagen von CANopen und verwendet Index und Subindex um Parameter zu lesen oder zu beschreiben wenn diese es erlauben.
Weiter Information erhalten Sie über folgende Seite: Systemdokumentation
Aufgabe
Parameter eines EtherCAT-Teilnehmers können in der Regel über die Parameter der GSDML-Datei eingestellt und parametriert werden. In manchen Applikationen ist es aber notwendig bestimmte Parameter zur Laufzeit zu verändern oder im laufenden Betrieb Optimierungen durchzuführen.
Lösung
Die CoE-Daten werden über azyklischen PROFINET-Dienste geschickt (PROFINET-Index 0x200F). Die Position des EtherCAT-Teilnehmers wird über die Slot-Nummer vorgeben. Die CoE-Daten werden dann in die Record-Daten eingetragen und bestehen beim Lesen aus CoE-Index und CoE-Subindex und beim Schreiben aus CoE-Index, CoE-Subindex und den zu sendenden Daten.
Beispiel Lesen/Schreiben
Für das Lesen muss als erstes ein Record WriteReq versendet werden. Dies beinhaltet den CoE-Index und CoE-Subindex. Nach dem WriteRsp muss ein ReadReq gesendet werden um die Daten abzuholen, die dann im ReadRsp enthalten sind.
Für das Schreiben erfolgt dies auf gleicher Art und Weise, nur das beim WriteReq die Daten mitgeschickt werden und mit der ReadRsp eine Quittung erfolgt ob das Schreiben geklappt hat.
CoE-Datenzugriff über PROFINET, Beispiel Lesen/Schreiben
Erste Schritte Lesen
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot | Position des EtherCAT-Teilnehmers (1...255) | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 | Sub-Slot-Nummer, immer "1"
Index | 0x200F | PROFINET-Index-Nummer
Lenght | 4 | Länge der folgenden Daten
Daten | Byte 1 und 2 SDO Index Byte 3 CoE SubIndex Byte 4 "0" Reserve | CoE-Daten
Wartezeit, wir empfehlen hier 100..250 ms bis der Read Request versendet wird, der eine Bestätigung des Fehlerfreien Schreiben beinhaltet.
PROFINET Record Daten (Read Request) | Wert |  | Bedeutung
Slot | Position des EtherCAT-Teilnehmers (1...255) |  | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 |  | Sub-Slot-Nummer, immer "1"
Index | 0x200F |  | PROFINET-Index-Nummer
Lenght | Schreiben 4 | Antwort 4 Byte + x Byte | Länge der folgenden Daten
Daten | Schreiben Byte 1 "1" Byte 2 "0" Byte 3 "0" Byte 4 "0" | Antwort Byte 1..4 ADS-Fehler Byte 4..x COE-Datenwert | CoE-Daten
In der Antwort des Read Request also dem Read Response kommen die Daten. Die ersten 4 Byte beinhalten den Fehler-Code. Bei fehlerfreier Antwort ist dieser "0". Der Fehler Code ist ein ADS-Fehler-Code und kann unter folgenden Link nachgelesen werden.
http://infosys.beckhoff.com/content/1031/tcsample/html/ads_returncodes.htm
Wireshark Beispiel für das Lesen ( )
Erste Schritte Schreiben
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot | Position des EtherCAT-Teilnehmers (1...255) | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 | Sub-Slot-Nummer, immer "1"
Index | 0x200F | PROFINET-Index-Nummer
Lenght | 4 | Länge der folgenden Daten
Daten | Byte 1..2 SDO Index Byte 3 SDO SubIndex Byte 4 "1" Konstante Byte 5..8 Länge als DWORD Byte 9..x CoE Datenwert | CoE-Daten
Wartezeit, wir empfehlen hier 250..500 ms bis der Read Request versendet wird, der eine Bestätigung des Fehlerfreien Schreiben beinhaltet.
PROFINET Record Daten (Read Request) | Wert |  | Bedeutung
Slot | Position des EtherCAT Teilnehmers (1...255) |  | Slot-Nummer, Position des EtherCAT-Teilnehmers
SubSlot | 1 |  | Sub-Slot-Nummer, immer "1"
Index | 0x200F |  | PROFINET-Index-Nummer
Lenght | Schreiben 0 | Antwort 4 | Länge der folgenden Daten
Daten | Schreiben - | Schreiben ADS-Fehler-Code | CoE-Daten
In der Antwort des Read Request also dem Read Response kommt die Bestätigung ob das Schreiben geklappt hat, die ersten 4 Byte beinhalten den Fehler Code, bei fehlerfreier Antwort ist dieser "0". Der Fehler Code ist ein ADS-Fehler-Code und kann unter folgenden Link nachgelesen werden.
Systemdoku
Wireshark-Beispiel für das Schreiben ( )
Datenformat beachten
Achten Sie beim Lesen und Schreiben auf die Datengröße und das Format der entsprechenden SDO-Parameter. Wir empfehlen die SDO-Daten erst zu lesen, sie dann zu interpretieren und entsprechend des gelesenen Datenformats dieses auch beim Schreiben der CoE-Daten zu verwenden (eventuell High/Low BYTE/WORD tauschen).
Start-up Parameter überschreiben COE-Daten
Typischerweise werden CoE-Daten nicht im EtherCAT-Teilnehmer gespeichert. Achten Sie darauf, das CoE-Daten beim Starten des EK9300 wieder über die Start-up Parameter (GSDML) überschrieben werden.


EK9300 - Multikonfigurationsmodus

Konfiguration [image] Ab Firmware-Version 6 [image] EK9300 - Multikonfigurationsmodus
EK9300 - Multikonfigurationsmodus
Beschreibung
Der Multikonfigurationsmodus erlaubt dem Anwender unterschiedliche Hardware, z. B. einen EK9300 mit variierenden EtherCAT-Klemmen, mit derselben Projektierung zu betreiben.
Diese Beschreibung verwendet in den Beispielen EtherCAT-Klemmen (ELxxxx). Das Prinzip gilt genauso für EtherCAT-Box-Module (EPxxxx).
Aufgabe
Der Maschinenbauer hat eine Maschine, die mit unterschiedlichen Optionen verkauft werden soll. Die Optionen sind in der Regel zusätzliche Signale die verarbeitet und erfasst werden müssen und dafür zusätzliche Klemmen erfordern.
Für all diese Optionen soll aber die Projektierung beibehalten und nur über die Software variiert werden. Es wird also parametriert, welche Optionen die Maschine tatsächlich beinhaltet.
Lösung
Mit dem Multikonfigurationsmodus wird in der Projektierung die maximale Anzahl der Optionen konfiguriert. Hat die Maschine weniger als die maximale Anzahl an Optionen, können EtherCAT-Klemmen entfallen, da diese Signale nicht benötigt werden. Die nicht benötigten EtherCAT-Klemmen sind zwar in der maximalen Projektierung enthalten, können aber von der Steuerung deaktiviert werden, so dass Hardware und parametrierte Konfiguration wieder übereinstimmen. Sobald dies erfolgt ist geht der EK9300 in den normalen Datenaustausch.
Vorteil
Weniger Aufwand bei der Erstellung und Pflege der Projekte, weil die gleiche Projektierung für unterschiedliche Hardware verwendet werden kann.
Beispiel
Die Grundkonfiguration der Maschine besteht ohne Optionen aus:
▪
1 x EK9300
▪
2 x EL2004
▪
2 x EL1004
▪
1 x EL5051
Es können folgende Optionen hinzukommen:
▪
Mit Energie-Monitoring zum Erfassen des Energieverbrauches: zusätzlich eine EL3403
▪
Mit automatischer Verstellachse: zusätzlich eine EL7047
▪
Mit Temperaturerfassung: zusätzlich eine EL3314
Damit sieht der maximale Ausbau (mit kursiv dargestellten Optionsklemmen) wie folgt aus:
▪
1 x EK9300
▪
2 x EL2004
▪
2 x EL1004
▪
1 x EL5051
▪
1 x EL3314
▪
1 x EL7047
▪
1 x EL3403
Genau dieser maximale Ausbau wird in der Hardware-Konfiguration auch projektiert.
Wird die Maschine ohne Optionen bestellt, müssen die Klemmen EL3314, EL7047 und EL3403 in der Projektierung deaktiviert werden. Dazu wird dem EK9300 die Record Daten (azyklische Kommunikation) mitgeteilt, welche Klemmen entfallen. Dabei werden die Klemmen über ihre Position identifiziert.
Ohne Optionen sind zweimal KL2004 (an Position 1 und 2), zweimal EL1004 (an Position 3 und 4) und einmal die EL5051 (an Position 5) vorhanden. Die Klemmen auf Position 6, 7 und 8 (Optionsklemmen) müssen deaktiviert werden.
Wird die Maschine mit der Option "automatischer Verstellachse" bestellt müssen nur die Klemmen 6 und 8 deaktiviert werden.
Position von Optionsklemmen
Optionsklemmen können auch an einer belieben Position gesteckt sein um sie eventuell zu deaktivieren. Sie müssen nicht wie im Beispiel gezeigt, zwingend am Ende eingebaut werden.
Erste Schritte
Damit der EK9300 im Multikonfigurationsmodus arbeiten kann, muss im DAP (Device Access Point) der MultiConfigurationMode auf "TRUE" gestellt werden.
Nun gibt es zwei Möglichkeiten die Einstellung vorzunehmen.
Option 1
Dies ist eher die Variante zum Testen, da hier die Hardware-Konfiguration angepasst werden muss, was eigentlich vermieden werden sollte.
Im DAP gibt es die Einstellung MultiConfigurationMode mit den Slots. Hier können Sie EtherCAT-Klemmen die projektiert aber nicht vorhanden sind deaktivieren.
Bei einigen PROFINET-Controllern muss das beim Starten erfolgen, es gibt aber auch PROFINET-Controller, die das zur Laufzeit erlauben, was das Testen wesentlich vereinfacht. Das Deaktivieren/Aktivieren von Klemmen zur Laufzeit ist ein Feature des PROFINET-Controllers und kann je nach Hersteller des PROFINET Controllers möglich bzw. nicht möglich sein.
Option 2
Die Konfiguration wird von der SPS über die Record Daten verschickt. Auch hier bieten die Hersteller verschiedene Wege an. Kontaktieren Sie hierzu den Hersteller Ihres PROFINET-Controllers, falls Sie dazu Fragen haben.
Erforderlich für Option 2 ist, dass Ihr PROFINET-Controller den Zugriff auf die Record Daten erlaubt und unterstützt.
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot* | 0 | Slot Nummer, immer "0"
SubSlot* | 1 | Sub Slot Nummer, immer "1"
Index | 0#2010 | PROFINET Index Nummer
Lenght | variable | Länge der Daten die Folgen
Daten | Jede Busklemme benötigt 2 Bit: 00bin Klemme vorhanden 10bin Klemme nicht vorhanden | Aktivieren/Deaktivieren der EtherCAT Teilnehmer
* Bei einigen PROFINET Controllern werden diese Daten automatisch aus der GSDML entnommen und müssen nicht projektiert werden.
Vorgehensweise
Nach dem Sie die Station projektiert haben, sind folgende Schritte notwendig.
Wird die Maschine im maximalen Ausbau (mit allen Optionen) bestellt, muss in der Regel nichts gemacht werden, da die Hardware mit der Projektierung übereinstimmt.
Ist eine der Optionen nicht enthalten, so unterscheiden sich Hardware und Projektierung. Der PROFINET-Koppler zeigt dies über die Meldung "Module Difference".
Deaktivieren Sie nun die Klemmen, die nicht vorhanden sind. Sobald dies erfolgt ist wird die Meldung "Module Difference" vom Koppler entfernt. Bleibt die Meldung "Module Difference" erhalten, so haben Sie eventuell den falschen Slot oder zu wenige Slots deaktiviert.
Keine SubSlots
SubSlots werden nicht mitgezählt und können für den Multikonfigurationsmodus auch nicht verwendet werden.
Es können nur Slots verwendet werden, dabei ist es egal ob ein Modul SubSlots verwendet oder nicht.
Kein Shared Device
Das Feature Shared Device kann bei der Verwendung des Multikonfigurationsmodus nicht verwendet werden.
Keine Pack oder (*)-Klemmen
Pack- oder (*)-Klemmen dürfen im Multikonfigurationsmodus nicht verwendet werden.


EK9300 - IO-LINK

Konfiguration [image] Ab Firmware-Version 6 [image] EK9300 - IO-LINK
EK9300 - IO-LINK
Beschreibung
Der EK9300 unterstützt ab der Firmware 6 die IO-Link-Master EL6224 (EtherCAT-Klemme) und EP6224 (EtherCAT Box). Die GSDML-Datei (ab der Version GSDML-V2.32-beckhoff-EK9300-20160408.xml) beinhaltet diese IO-Link-Master. Jedes IO-Link-Device wird als Sub-Modul angesprochen und muss über die GSDML-Datei konfiguriert werden.
Aufgabe
Anschluss eines IO-Link-Sensors an einen EK9300.
Konfiguration der Prozessdaten
Jedes IO-Link-Device wird als Submodul eingefügt. Für jeden IO-Link-Device wird ein SubModul verwendet. Die Prozessdatengrößen des SubModuls müssen immer gleich oder größer der des IO-Link-Devices sein und dürfen nicht kleiner sein.
Sollten Sie nicht alle IO-Link-Kanäle verwenden sind Empty Channel einzutragen. Beispiel sie haben am IO-Link-Master nur am Eingang 2 und 4 einen Sensor angeschlossen, die Eingänge 1 und 3 sind unbenutzt, dann fügen Sie als erstes einen Empty Channel als Submodul an, der zweite ist dann der Sensor auf Eingang 2, anschließend einen Empty Channel und als Letztes den Sensor auf Eingang 4. Der IO-Link Master verwendet als erstes SubModul ein Diagnose-Modul. Dieses ist beim Einfügen der EL6224/EP6224 immer vorhanden. Dieses SubModul beinhaltet den Status aller angeschlossenen IO-Link-Devices. Ist der Sensor im IO-Link-Datenaustausch wird das über das entsprechende Byte angezeigt (0x03 bedeutet alles in Ordnung).
Angaben zum Status Byte:
0x_0 = Port disabled
0x_1 = Port in std dig in
0x_2 = Port in std dig out
0x_3 = Port in communication OP
0x_4 = Port in communication COMSTOP / dig in Bit (nur im std. IO Mode)
0x_8 = Process Data Invalid Bit
0x1_ = Watchdog detected
0x2_ = internal Error
0x3_ = invalid Device ID
0x4_ = invalid Vendor ID
0x5_ = invalid IO-Link Version
0x6_ = invalid Frame Capability
0x7_ = invalid Cycle Time
0x8_ = invalid PD in length
0x9_ = invalid PD out length
0xA_ = no Device detected
0xB_ = error PreOP/Data storage
Die Prozessdatengröße eines verwendeten IO-Link-Devices entnehmen Sie bitte seiner Dokumentation oder fragen Sie den Hersteller.
Einfügen eines „Generic Channel“ (bei IO-Link-Devices anderer Hersteller
IO-Link-Devices von Beckhoff werden automatisch mit den notwendigen Parametern eingefügt. Bei anderen Herstellern verwenden Sie ein Generic Channel und wählen Sie die Prozessdatengröße aus.
Konfiguration des IO-Link-Devices
Die notwenigen mindest Einstellungen für das Betreiben eines IO-Link-Devices sind:
IO-Link-Version: In der Regel 1.1; tragen Sie hierfür 11 ein
Frame capability: In der Regel 1
Min Cycle Time: In der Regel 2,3 ms, also 23
Processs data in / Out lengh: Variable (Anzahl in Bit), bei einer Größe von 2 Byte Input tragen bei "Process data in length" 16 ein.
Master Control: auf IO-Link stellen
Alle anderen Einstellungen sind optional.
Konfiguration des IO-Link-Devices
Lesen/Schreiben von Parametern
Jedes IO-Link-Device hat Parameter die man Lesen oder Schreiben kann. Der EK9300 unterstützt diese Funktion nicht. D.h. es können keine Parameter gelesen oder geschrieben werden. Die Kommunikation des EK9300 mit dem IO-Link-Device beschränkt sich auf die Prozessdaten.
Wenn Sie auf Parameter der IO-Link-Devices zugreifen möchten müssen Sie eine Beckhoff Steuerung (z. B. CX8093) verwenden. Hier können Sie auf die IODD-Datei (IO-Link Device Description) einlesen und über die SPS die Sensordaten lesen oder schreiben.


Ab Firmware-Version 8

Konfiguration [image] Ab Firmware-Version 8
Ab Firmware-Version 8
Um die Änderung der Firmware-Version 8 zu nutzen müssen Sie auch die entsprechende GSDML-Gerätebeschreibung verwenden, ab der Version GSDML-V2.32-beckhoff-EK9300-20170216.XML.
Fügen Sie hierfür den entsprechende DAP der GSDML ein für die Firmware (FW8.0) ein.
Einfügen der DAP der GSDML ein für die Firmware FW8.0
Weiterführende Informationen
•
EBus Error Behaviour


EBus Error Behaviour

Konfiguration [image] Ab Firmware-Version 8 [image] EBus Error Behaviour
EBus Error Behaviour
Neu in Firmware-Version 8 ist der Parameter EBus error behaviour.
Der Parameter EBus error behaviour
Dieser Parameter wird verwendet um die Reaktion auf einen E-Bus-Fehler einzustellen. Folgende Möglichkeiten können genutzt werden:
Legacy | Ausgangsdaten werden noch geschrieben, Eingangsdaten werden eingefroren und sind damit nicht mehr aktuell.
Set IOs to 0 | Ausgangsdaten werden zu Null geschrieben, Eingangsdaten werden zu Null geschrieben, sobald der E-Bus fehlerfrei ist geht er automatisch in den Datenaustausch.
Set IOs to 0 without EBus restart (Default-Einstellung) | Ausgangsdaten werden zu Null geschrieben, Eingangsdaten werden zu Null geschrieben, sobald der E-Bus fehlerfrei ist kann der E-Bus über die Record Daten wieder freigegeben werden (sieh unten).
Aktivieren des E-Bus nach einem E-Bus-Fehler
Im DAP erhalten Sie über das Status DWord die Info über den E-Bus. Sobald der E-Bus einen Fehler hat wird das Bit EcFrameError gesetzt (im High Word Bitoffset x.2). Ist der Fehler behoben und der Koppler wieder bereit den E-Bus zu starten wird das Bit EcFrameError zurückgesetzt und im High Word Bitoffset x.4 das Flag NeedEBusRese gesetzt.
Flag NeedEBusReset
Der Reset wird über einen Record Daten abgesetzt und ist wie folgt aufgebaut.
PROFINET Record Daten (Write Request) | Wert | Bedeutung
Slot | 0 | Slotnummer
SubSlot | 1 | Sub Slot Nummer
Index | 0x2013 | Reset Index
Lenght | 2 | Datenlänge
Daten | 0x1234 | Wert
Nach dem Absetzen des Reset wird das Bit NeedEBusReset zurückgesetzt.
Web-Seite freischalten
Die Web-Seite kann über die Parameter-Daten des DAPs freigeschaltet werden. Setzen Sie den Parameter Webserver auf aktive und verbinden Sie den EK9300 mit Ihrem PROFINET-Controller. Nach dem Verdingungsaufbau und erhalt der IP-Adresse kann auch auf die Web-Seite des EK9300 zugegriffen werden.
Setzen des Parameters Webserver auf aktive
Wir empfehlen diese Web-Seite nur für Diagnosezwecke zu verwenden und dort keine Einstellungen vorzunehmen, da diese in der Regel immer durch den PROFINET-Controller erfolgen solten.
Die Web-Seite erreicht man über den Aufruf der IP-Adresse des EK9300 mit dem Parameter Config
Beispiel: 192.168.1.10 /Config
Benutzername: guest
Passwort: 1
Um die Web-Seite zu erreichen zu können müssen folgende Voraussetzungen gegeben sein:
▪
Die Web-Seite muss über die Parameter-Daten des EK9300 freischalten worden sein.
▪
Der PROFINET-Controller muss mindestens einmal mit dem EK9300 in den Datenaustausch gegangen sein, damit die Parameter und die IP-Adresse auf dem EK9300 eingestellt wurden.
▪
Der PC mit dem Internet-Browser muss sich im gleichen IP-Segment befinden wie der EK9300. Kontrollieren Sie vom PC aus mit dem PING-Befehl ob der PC den EK9300 erreichen kann. Sollte dies der Fall sein, können Sie die Web-Seite des EK9300aufrufen.
Falls die PING-Befehl fehlschlägt, überprüfen sie folgende Punkte:
- Wurde die Web-Seite freigeschaltet?
- War die Kommunikation vom PROFINET-Controller zum EK9300 erfolgreich?
- Ist die IP-Adresse des PCs korrekt?
Browser-Empfehlung
Für die Anzeige der Web-Seite empfehlen wir als Browser Chrome oder Firefox.


Ethernet

Ethernet
Ethernet
Weiterführende Informationen
•
Systemvorstellung PROFINET


Systemvorstellung PROFINET

Ethernet [image] Systemvorstellung PROFINET
Systemvorstellung PROFINET
PROFINET ist der Industrial-Ethernet-Standard der PNO (PROFIBUS Nutzerorganisation). PROFINET IO beschreibt den Datenaustausch zwischen Steuerungen und Feldgeräten in mehreren Echtzeitklassen: RT (Software-basiertes Real-Time) und IRT (hardwaregestütztes Isochronous Real-Time). Zusätzlich kann weiterer Ethernet-Verkehr im NRT (Non Real-Time)-Zeitschlitz des PROFINET-Zyklus übertragen werden. RT kann mit handelsüblichen Switches vernetzt werden, für IRT sind Switche mit entsprechender Hardwareunterstützung erforderlich.
PROFINET Systemübersicht
Komponenten | Kommentar
Embedded-PCs
CX8093 | Embedded-PC mit Feldbusschnittstelle PROFINET-RT-Device
CX50xx-M930 | Embedded-PC mit Optionsschnittstelle PROFINET-RT-Controller
CX50xx-B930 | Embedded-PC mit Optionsschnittstelle PROFINET-RT-Device
EtherCAT-Klemmen
EL6631 | PROFINET-IO-Controller
EL6631-0010 | PROFINET-IO-Device
EL6632 | PROFINET-IRT-Controller
Buskoppler
BK9053 | PROFINET-„Compact“-Buskoppler für Busklemmen
BK9103 | PROFINET-Buskoppler für Busklemmen
EK9300 | PROFINET-Buskoppler für EtherCAT-Klemmen
EtherCAT Box
EP9300 | PROFINET-Koppler-Box für EtherCAT-Box-Module
Feldbus Box
IL230x-B903 | PROFINET-Koppler-Box für IP-Link-Box-Module
PC-Feldbuskarten
FC900x | PCI-Ethernet-Karte für sämtliche Ethernet (IEEE 802.3)-basierten Protokolle
FC9x51 | Mini-PCI-Ethernet-Karte für sämtliche Ethernet (IEEE 802.3)-basierten Protokolle
TwinCAT
TwinCAT PROFINET IO Controller | TwinCAT als PROFINET-Master
TwinCAT PROFINET IO Device | TwinCAT als PROFINET-Slave


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose -LEDs


Diagnose -LEDs

Fehlerbehandlung und Diagose [image] Diagnose -LEDs
Diagnose -LEDs
EK9300 LEDs
Ethernet Schnittstelle X001
Schnittstelle X001/X002 | Ethernet (CX8090) | Bedeutung
LED grün | an | Link vorhanden/Aktivität
LED gelb | wird nicht benutzt | -
LED Koppler
Beschriftung | Bedeutung | Farbe | Bedeutung
RUN | Zeigt den Status des Kopplers an | rot | Darf nur in der Hochlauf-Phase leuchten
 |  | Grün | Koppler ist bereit
 |  | Blau (Wenn roter DIP Schalter 1 auf on steht beim starten des Kopplers) | Über USB kann das interne Flash erreicht werden (Firmware update)
LED PN | PROFINET Status |  | Bedeutung
 | grün | rot
Power On | aus | 200 ms blinken | Aufstart-Phase
No Name | 200 ms blinken | aus | kein Profinet Name
No IP | 1 s aus, 200 ms an | aus | keine IP-Adresse
Run | an | aus | OK
LED DIAG | PROFINET Diagnose |  | Bedeutung
 | grün | rot
Flashing, PN-Controller Identifizierung | 500 ms | 500 ms | Der PN-Controller sendet ein Identifizierungssignal
No AR established | aus | 200 ms blinken | Der Verbindungsaufbau mit dem Controller ist nicht abgeschlossen
Device in in IO exchange Problem indicator of Outputs CR is set of module differences | 1 s aus 200 ms an | aus | Problem bei Verbindungsaufbau oder ist und soll Konfiguration unterschiedlich
Device is in IO exchange but provider is in stop | 200 ms | aus | Koppler ist im Datenaustausch, SPS ist aber im stopp Zustand
Device is in IO exchange | an | aus | OK
LED Netzteilklemme
LED Netzteilklemme
Betrieb mit E-Bus Klemmen
Anzeige LED | Beschreibung | Bedeutung
1 Us 24 V (Links Oben, 1. Reihe) | Versorgung Spannung CX8000 | an: 24 V angeschlossen
2 Up 24 V (Rechts Oben, 1. Reihe) | Versorgung Spannung Powerkontakte | an: 24 V angeschlossen
3 L/A (Links Mitte, 2. Reihe) | EtherCAT LED | blinkt grün: EtherCAT Kommunikation aktiv an: E-Bus angeschlossen / Kein Datenverkehr aus: E-Bus nicht angeschlossen


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Image des Buskopplers aktualisieren
•
EK9300 - Typische Fragen
•
Abkürzungsverzeichnis
•
Support und Service


Image des Buskopplers aktualisieren

Anhang [image] Image des Buskopplers aktualisieren
Image des Buskopplers aktualisieren
Datenverlust
Die Daten im internen Flash-Speicher werden gelöscht.
Sichern Sie Ihre Daten, bevor Sie das Image des Buskopplers aktualisieren.
Das Image des Buskopplers kann über die USB-Schnittstelle aktualisiert werden. Dafür wird der Buskoppler per USB-Kabel mit einem Host-PC verbunden. Anschließend wird der Buskoppler unter Windows als Wechseldatenträger angezeigt und die Dateien können kopiert werden.
Aktualisieren Sie den Buskoppler nur nach Rücksprache mit dem Beckhoff Service. Der Beckhoff Service stellt auch alle notwendigen Dateien zur Verfügung.
Voraussetzungen
▪
Überprüfen Sie zuerst ob der Buskoppler das Image unterstützt.
▪
Der Buskoppler ist per USB-Kabel mit dem Host-PC verbunden.
Aktualisieren Sie das Image wie folgt:
1.
Schalten Sie den Buskoppler aus.
2.
Stellen Sie den 2-poligen roten DIP-Schalter 1 auf „on“ (nach rechts) und schalten Sie den Buskoppler ein.
Der Buskoppler erscheint als Wechseldatenträger auf dem Host-PC.
3.
Markieren und löschen Sie alle Dateien.
Nicht formatieren.

4.
Entfernen Sie das USB-Kabel, sobald alle Dateien kopiert wurden und stellen Sie den 2-poligen DIP-Schalter auf „off“ (nach links).
5.
Starten Sie den Buskoppler neu.
⇨
Sie haben das Image erfolgreich aktualisiert. Es ist möglich, dass der Buskoppler nach der Aktualisierung etwas länger für den Start benötigt.


EK9300 - Typische Fragen

Anhang [image] EK9300 - Typische Fragen
EK9300 - Typische Fragen
Wie kann ich bei PROFINET Fehler die Ausgänge im aktuellen Zustand belassen?
Dafür müssen 2 Einstellungen in der GSDML also dem Konfigurator vorgenommen werden. Als erstes muss im DAP "Aktiviere PN Rücksetzwert" auf AN gestellt sein. Bei der entsprechenden digitalen Ausgangsklemme muss dann noch der Wert "Frozen" angewählt sein. Die Einstellung kann man nur für eine Klemme vornehmen, d.h. bei einer EL2004 sind dann alle 4 Kanäle in dem Zustand Frozen.
Ich möchte das Mapping einer EtherCAT Klemme umstellen, er bietet mir diese nicht an?
Per Default wird immer das Standard-Mapping angehängt, sind andere Mappings möglich, müssen Sie zuerst das Standard-Mapping auf Ihrem Konfigurator löschen und dann das neue Submodul einfügen.
Die 2 oder 4 Kanal digitalen Ausgangsklemmen sollen auf ein Byte gemappt werden, wie gehe ich vor?
Es gibt in der GSDML Datei die so genannten "PACK" Klemmen. Ohne Sternchen bedeutet, dass ein Byte angelegt wird, mit Sternchen, das Byte wird aufgefüllt. Pack-Klemmen müssen immer hintereinander liegen (physikalisch) und es darf das Byte nicht überschritten werden.
Woher bekomme ich die GSDML Datei?
Die GSDML Datei finden Sie unter http://www.beckhoff.de/german/download/bkconfg.htm
Wo finde ich die MAC Adresse des Kopplers?
Die MAC Adresse ist auf dem Aufkleber an der Seite des Kopplers aufgedruckt.
Wozu verwende ich die USB Schnittstelle, was kann ich damit machen?
Die USB Schnittstelle ist derzeit nur für ein Firmware-Update zu verwenden.
Wozu ist der DIP-Schalter hinter der Klappe?
Der DIP-Schalter ist z. B. für die Verwendung des Firmware-Updates notwendig (siehe Kapitel DIP-Schalter).
Kann ich auch K-Bus-Klemmen anschließen?
Nein, es sind ausschließlich EtherCAT-Klemmen oder EtherCAT-Boxen anschließbar. Für K-Bus-Klemmen können Sie den BK9053 oder BK9103 verwenden. Die EtherCAT-Koppler für K-Bus wie zum Beispiel BK1120 oder BK1250 sind nicht möglich.
Ich habe einen EtherCAT-Slave von einer Fremdfirma, kann ich den auch anschließen?
Nein, Geräte von anderen Herstellern können nur mit einem CX verwendet werden (siehe CX8093 oder ähnliche Produkte).
Ich möchte die Antriebesklemmen/Antriebe am EK9300 betreiben, ist das möglich?
Nein, hierfür verwenden Sie einen CX mit entsprechender Performanz, CX9020 oder größer.
Ich möchte TwinSAFE-Klemmen am EK9300 betreiben, ist das möglich?
Nein, die TwinSAFE-Klemmen benötigen zum Konfigurieren ein TwinCAT-System, verwenden Sie hierfür den CX8093.
Wie stelle ich fest, dass EtherCAT einen Fehler hat?
Im DAP des Kopplers gibt es ein Status-Wort. Hier wird ein Bit gesetzt, wenn im EtherCAT ein Fehler auftaucht (siehe Daten im DAP). Weitere Informationen über den Fehler kann man durch die PROFINET Alarme erhalten.


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
ADS
Automation Device Specification (offen gelegtes Protokoll für die Kommunikation aller BECKHOFF Steuerungen)
DAP
Device Access Point
E/A
Ein- und Ausgänge
E-Bus
Bezeichnung für EtherCAT-Klemmen im Klemmenverbund (ELxxxx, ESxxxx, oder EMxxxx)
EtherCAT
EtherCAT (Ethernet for Control Automation Technology) ist die Ethernet-Lösung für die Industrieautomatisierung, die sich durch überragende Performance und besonders einfache Handhabung auszeichnet.
Fast Ethernet
Datenrate 100 Mbits/s nach dem Standard 100 Base-T.
Gerätename
Der Gerätename bei PROFINET entspricht in der Art der Adresse bei Profibus. Die meisten Geräte haben bei der Erstinbetriebnahme keinen Namen und müssen vom Controller oder Supervisor "getauft" werden. Die meisten BECKHOFF-Geräte ermöglichen aber durch einen DIP- Schalter auch einen Default Namen einzustellen, damit entfällt die "Taufe" der Geräte.
GSDML
Gerätestammdatei für PROFINET in XML-Format (entspricht der GSD-Datei bei PROFIBUS).
IP20
Schutzart der Busklemmen, EtherCAT-Klemmen
IPC
Industrie-PC
K-Bus
Klemmen-Bus (KLxxxx, KMxxxx oder KSxxxx Klemmen)
KS2000
Konfigurationssoftware für Busklemmen, Buskoppler, Busklemmen-Controller, Feldbus-Box-Module usw.
PE
Der PE-Powerkontakt kann als Schutzerde verwendet werden.
PROFINET
...ist die Weiterentwicklung von PROFIBUS und basiert auf Ethernet-Technologie. PROFINET in der IEC 61158 beschrieben.
PROFINET IO
...ist der Oberbegriff für die PROFINET-Kommunikation und beschreibt das Konzept.
PROFINET Controller
Bezeichnung für den PROFINET-Master der PROFINET-Device (Slaves) Geräte
PROFINET Device
Bezeichnung für die Slaves am PROFINET Controller (Master)
TwinCAT
The Windows Control and Automation Technology, Programmier- und Konfigurationswerkzeug der Firma BECKHOFF.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.