EK9000 - Ethernet Modbus Buskoppler für EtherCAT
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.2.0
▪
Update Kapitel „UL-Hinweise“
2.1.0
▪
Update Kapitel „Modbus-Interfaces“
▪
Update Kapitel „Technische Daten“
2.0.2
▪
Update Kapitel „Image des Buskopplers aktualisieren“
2.0.1
▪
Kapitel „Technische Daten“ aktualisiert
2.0.0
▪
Migration
1.1.0
▪
Beschreibung der HTML-Konfiguration aktualisiert
1.0.0
▪
Erste Veröffentlichung
Image Version EK9000
Firmware
Hardware-Version
Beschreibung
1 (V0.03)
3.9
▪
Erste Version


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EKxxxx - Systemübersicht
•
EK9000 - Einführung
•
Technische Daten - EK9000
•
Technische Daten - Modbus


EKxxxx - Systemübersicht

Produktübersicht [image] EKxxxx - Systemübersicht
EKxxxx - Systemübersicht
EtherCAT-Klemmen an einem Buskoppler der Serie EKxxxx
Die Buskoppler der Serie EKxxxx ermöglichen den Betrieb von EtherCAT-Klemmen an herkömmlichen Feldbussystemen. Die ultraschnellen und leistungsfähigen EtherCAT-Klemmen mit ihrer großen Signalauswahl stehen somit auch für andere Feldbus- und Industrial-Ethernet-Systeme zur Verfügung.
Die EKxxxx-Buskoppler sind Feldbus-Slaves und beinhalten einen EtherCAT-Master für die EtherCAT-Klemmen. Sie setzten die Telegramme des übergeordneten Feldbus-Systems auf die E-Bus-Signaldarstellung um. Eine Station besteht aus einem EKxxxx und einer Anzahl von EtherCAT-Klemmen.
Über die entsprechenden Konfigurationstools der Feldbussysteme und die dazugehörigen Konfigurationsdateien, wie z. B. GSD, ESD oder GSDML, werden die EKxxxx auf die gleiche Weise eingebunden, wie die Buskoppler der Serie BKxxxx.
EtherCAT ermöglicht einen sehr flexiblen Topologieaufbau. Durch die Ethernet-Physik können auch weite Distanzen überbrückt werden, ohne dass die Busgeschwindigkeit beeinflusst wird. Bei einem Wechsel in die Feldebene – ohne Schaltschrank – lassen sich auch die EtherCAT-Box-Module (EPxxxx) in Schutzart IP65 mit den EK9xxx verbinden.
Buskoppler für verschiedene Feldbus-Systeme
Die Varianten der Serie EKxxxx unterscheiden sich voneinander durch die Schnittstelle für das übergeordnete Feldbus-System.
Eine Übersicht der verschiedenen Beckhoff Buskoppler, die die wichtigsten Feldbus-Systeme abdecken, finden Sie auf der Beckhoff Website.
Embedded-PCs mit Feldbus-Interface und dezentraler Steuerung
Die mit TwinCAT programmierbare Variante ist die Embedded-PC-Serie CX80xx.
Die Varianten der Serie CX80xx unterscheiden sich voneinander durch die Schnittstelle für das übergeordnete Feldbus-System und der Möglichkeit diese zu Programmieren.
Eine Übersicht der verschiedenen Beckhoff Embedded-PCs, die die wichtigsten Feldbus-Systeme abdecken, finden Sie auf der Beckhoff Website.


EK9000 - Einführung

Produktübersicht [image] EK9000 - Einführung
EK9000 - Einführung
EK9000
Der Buskoppler EK9000 verbindet Ethernet-Netzwerke mit den EtherCAT-Klemmen (ELxxxx) sowie EtherCAT-Box-Modulen (EPxxxx) und setzt die Telegramme von Ethernet auf die E-Bus-Signaldarstellung um.
Eine Station besteht aus einem EK9000 und einer beliebigen Anzahl von EtherCAT-Klemmen. Der Anschluss an Ethernet erfolgt über RJ45. Mit EtherCAT verfügt der Ethernet-Koppler über ein unterlagertes, leistungsfähiges und ultraschnelles I/O-System mit einer großen Klemmenauswahl. Der Koppler unterstützt das Modbus-TCP-Protokoll und fügt sich damit nahtlos in Ethernet-Netzwerke ein.
Konfiguration
Die Konfiguration des EK9000 erfolgt über die vom Buskoppler zur Verfügung gestellten HTML-Seiten oder über das Modbus-Interface.


Technische Daten - EK9000

Produktübersicht [image] Technische Daten - EK9000
Technische Daten - EK9000
Technische Daten | EK9000
Protokoll | ModbusTCP/UDP
Schnittstellen | 2 x Ethernet 100 MBit/s, 1 x USB-Device (hinter der Frontklappe)
Businterface | 2 x RJ 45 (switched)
I/O-Anschluss | E-Bus (EtherCAT-Klemmen)
Web-base Management | ja
I/O-Klemmen | E-Bus (EL, ES, EP), Standard digitale Signale, Standard analoge Signale Keine Gateway EC-Klemmen, keine EC-Klemmen mit XFC oder DC Funktion, keine allgemeinen EtherCAT Teilnehmer
Anzahl an EC Klemmen | max. 255
Max Größe Prozessdaten | max. 1440 Byte In- und Output Daten
Spannungsversorgung | 24 V DC (-15 %/+20 %)
Stromversorgung I/O-Klemmen | 2 A
Max. Verlustleistung | 3 W
Abmessungen (B x H x L) | 65 mm x 100 mm x 80 mm
Zulassungen | CE, UL, ATEX
Systemdaten | Modbus (EK9000)
Anzahl der E/A-Module | steuerungsabhängig
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | 4 x 2 Twisted-Pair-Kupferkabel Kategorie 5 (100 MBaud)
Leitungslänge | 100 m
Übertragungsrate | 100 Mbit/s
Topologie | sternförmige Verkabelung, Linientopologie


Technische Daten - Modbus

Produktübersicht [image] Technische Daten - Modbus
Technische Daten - Modbus
Technische Daten Ethernet | EK9000
Anzahl der Ports | 2
integrierter Swtich | 2 x Ethernet 100 MBit/s, 1 x USB-Device (hinter der Frontklappe)
Businterface | 2 x RJ 45 (switched)
100 Mbit/s | Ja, vollduplex
Autocrossing | Ja
Protokoll |
ModbusTCP | Ja
ModbusUDP | Ja
Funktionen/Dienst |
Read Coils 1 | Ja
Read Discrete Inputs 2 | Ja
Read Holding Register 3 | Ja
Read Input Register 4 | Ja
Write Single Coil 5 | Ja
Diagnose 8 | Ja
Write Single Register 6 | Ja
Write Multiple Coils 15 | Ja
Write Multiple Register 16 | Ja
Read/Write Multiple Register 23 | Ja
TCP/IP ADS | Ja
ARP | Ja
Web Dienste | Ja
DHCP | Ja
Diagnose/Status/Alarm |
RUN LED | Ja, grün/rot
WD LED | Ja, grün/rot
ERR LED | Ja, grün/rot
Verbindungsanzeige LINK TX/RX | Ja
Diagnosemeldungen | Ja


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Montage
•
Verdrahtung
•
UL-Hinweise


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Tragschienenmontage - Buskoppler


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Die folgenden Grafiken zeigen die Abmessungen der Buskoppler.
Zeichnungen im DWF- und STEP-Format finden Sie im Download-Bereich der Beckhoff-Website.
EK9xxx - Abmessungen am Beispiel EK9300


Tragschienenmontage - Buskoppler

Montage und Verdrahtung [image] Montage [image] Tragschienenmontage - Buskoppler
Tragschienenmontage - Buskoppler
Aufrasten auf die Tragschiene
Der Buskoppler kann einfach auf die Tragschiene aufgerastet werden. Dazu wird der Block frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Dies wird durch ein vernehmliches Klicken angezeigt. Mit einem Schraubendreher wird dann die Arretierung auf der linken Seite nach oben gedrückt wodurch sich die Arretierung dreht und ebenfall hörbar einrastet.
EK9300 - Aufrasten auf die Tragschiene
Hinweis
Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!
Einbaulagen
Die Einbaulage des Buskopplers ist beliebig.
Hinweis
Einbaulagen von EtherCAT-Klemmen
Beachten Sie die Einbaulage der eingesetzten EtherCAT Klemmen, nicht alle haben eine beliebige Einbaulage. Achten Sie auf die jeweiligen EtherCAT-Infrastrukturkomponenten und Installationshinweise.
Empfohlene Abstände bei Standard Einbaulage
Hinweis
Zulässige Einbaulage und Mindestabstände einhalten!
Wir empfehlen den Einbau in horizontaler Ausrichtung für eine optimale Durchlüftung, des Weiteren erübrigt sich bei dieser Einbaulage das Überprüfen ob Klemmen dabei sind, die nur horizontal verbaut werden dürfen.
Weitere Einbaulagen sind erlaubt aber werden nicht empfohlen.
Weitere Einbaulagen


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Spannungsversorgung
•
Ethernet


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
Versorgung von Buskoppler und Busklemmen (Us)
Der Buskoppler benötigt zum Betrieb eine Versorgungsspannung von 24 VDC (-15%/+20%).
Der Anschluss erfolgt über die beiden oberen Klemmstellen mit der Bezeichnung 24 V und 0 V. Diese Einspeisung versorgt die Elektronik des Buskopplers sowie über den E-Bus die Elektronik der EtherCAT-Klemmen. Sie ist galvanisch von der Peripherieversorgung (Up) der Powerkontakte getrennt.
Um in allen Fällen den Betrieb des Buskopplers und des Klemmenstrangs zu gewährleisten, muss das Netzteil 2 A bei 24 V liefern.
Spannungsversorgung Buskoppler
Versorgung der Powerkontakte (Up)
An der rechten Seitenfläche des Buskopplers befinden sich die drei Federkontakte der Powerkontakte. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden deren Messerkontakte mit den Federkontakten des Buskopplers verbunden. Die Nut/Federführung an der Ober- und Unterseite der Busklemmen Controller und Busklemmen garantiert eine sichere Führung der Powerkontakte.
Die unteren sechs Klemmstellen mit den Bezeichnungen +, - und PE dienen zur Einspeisung der Peripherieversorgung (Up). Diese Klemmstellen sind jeweils paarweise mit einem Powerkontakt verbunden. Die Einspeisung lässt Spannungen bis zu 24 V zu und ist galvanisch von der Versorgungsspannung des Buskopplers (Us) getrennt.
Die paarweise Verbindung dieser Klemmstellen ermöglicht das Weiterführen der Versorgung. Die Strombelastung der Powerkontakte darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Klemmstellen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Die Klemmstellen in Federkrafttechnik sind für Drähte von 0,08 mm² bis 2,5 mm² Querschnitt ausgelegt.
LED
Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün. Die linke LED (Us) zeigt die Versorgung für die Elektronik des Buskopplers an. Die rechte LED (Up) zeigt die Versorgung für die Powerkontakte an. Die weiteren die LEDs zeigen den Status des E-Bus an. Die detaillierte Bedeutung der LED-Anzeigen beschreibt das Kapitel LED-Anzeigen.
PE-Powerkontakte
Hinweis
Powerkontakt PE
Der Powerkontakt PE darf nicht für andere Potenziale verwendet werden.


Ethernet

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet
Ethernet
Weiterführende Informationen
•
Ethernet-Anschlüsse
•
Ethernet-Kabel
•
Ethernet-Topologie


Ethernet-Anschlüsse

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet [image] Ethernet-Anschlüsse
Ethernet-Anschlüsse
RJ45-Schnittstelle
Belegung der RJ45-Schnittstelle, Port 1
X001
PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8
Belegung der RJ45-Schnittstelle, Port 2 (switched)
CX8010, CX809x: X101 / 102
EK9xxx: X001 / X002
PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8


Ethernet-Kabel

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet [image] Ethernet-Kabel
Ethernet-Kabel
Übertragungsstandards
10Base5
Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.
10Base2
10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.
10BaseT
Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.
100BaseT
Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.
10BaseF
Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.
Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT
Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.
UTP
Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und ist für industrielle Umgebungen nicht empfehlenswert.
S/UTP
Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.
FTP
Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat einen alukaschierten Kunststoff-Folie-Gesamtschirm.
S/FTP
Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70 dB erreichen.
STP
Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.
S/STP
Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Eine solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.
ITP
Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


Ethernet-Topologie

Montage und Verdrahtung [image] Verdrahtung [image] Ethernet [image] Ethernet-Topologie
Ethernet-Topologie
EK9000
Der Aufbau der EK9000 kann in einer Linie erfolgen, hierbei sollten folgende Punkte eingehalten werden:
▪
Maximal 20 Buskoppler hintereinander
▪
Es sollten keine Switches in der Linie verwendet werden
Ethernet-Topologie


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
DIP-Schalter
•
Weitere Schnittstellen
•
IP-Adresse


DIP-Schalter

Parametrierung und Inbetriebnahme [image] DIP-Schalter
DIP-Schalter
Zehnpoliger DIP-Schalter S001
Der DIP-Schalter hat folgende Bedeutung für die Ethernet Schnittstellen X001 und X002 die geswitcht sind:
DIP-Schalter S001, Links off “0“, rechts on “1“
DIP 9
DIP 10
Funktion von DIP 1 bis DIP 8
Verhalten bei Neustart
Verhalten bei Herstellereinstellung
0
0
Letztes Byte der IP-Adresse über die DIP-Schalter 1 bis 8
▪
IP-Adresse über DIP-Schalter (Byte 4)
Byte 1..3 aus den Einstellungen (Web Seite)
▪
IP-Adresse über DIP-Schalter
192.168.1.xxx (xxx DIP-Schalter)
SNM 255.255.255.0
0
1
DHCP
DIP-Schalter 1 bis 8 auf OFF
▪
IP-Adresse über DHCP
▪
IP-Adresse über DHCP
1
0
Reserviert
-
-
1
1
Reserviert
-
-
Zweipoliger DIP-Schalter
(unter der Klappe zwischen Batterie und SD Kartenslot)
DIP Schalter (rot) | Bedeutung
1 off und 2 off | normaler Modus, Koppler wird gestartet
1 on und 2 off | Der EK startet im Config Mode, über die USB Schnittstelle ist der interne Flash Speicher zu erreichen (zum Beispiel für ein Image Update).
1 off und 2 on | Herstelleinstellung
1 on und 2 on | bislang keine Funktion


Weitere Schnittstellen

Parametrierung und Inbetriebnahme [image] Weitere Schnittstellen
Weitere Schnittstellen
Unter der Klappe des EK9xx0 befinden sich zusätzliche Schnittstellen.
Zusätzliche Schnittstellen der EK9xx0
Batterie
Für den EK9xx0 wird keine Batterie benötigt, daher ist diese Option nicht enthalten.
Roter DIP-Schalter
Default Einstellung ist OFF/OFF.
Um zum Beispiel ein neue Firmware über USB auf den EK zu spielen, muss vor dem Einschalten der erste DIP Schalter auf "1" gestellt werden. Leuchtet die RUN LED blau, kann man den EK mit einem USB-Kabel mit dem PC verbinden. Der PC findet dann den internen Flash als Speichermedium. Das Speichermedium darf nicht formatiert werden!
Micro SD-Karte
Alternativ kann auch die Firmware auf eine SD-Karte gespielt werden. Ist eine SD-Karte im Slot vorhanden wird immer von dieser gebootet. Dies kann man zum Beispiel nutzen, um eine Firmware zu testen bevor man diese auf den internen Flash des EKs kopiert.
USB Interface
Das USB Interface kann nur genutzt werden, wenn der "rote" DIP-Schalter entsprechend gesetzt wurde. Siehe "Roter DIP-Schalter".


IP-Adresse

Parametrierung und Inbetriebnahme [image] IP-Adresse
IP-Adresse
Die IP-Adresse, bzw. der Mode (z. B. DHCP) kann über den DIP-Schalter eingestellt werden. Des weiteren steht auch eine HTML-Seite zur Konfiguration zur Verfügung.


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
Konfiguration über die HTML-Seiten des Buskopplers
•
EtherCAT-Konfiguration
•
Modbus-Konfiguration
•
EtherCAT-Mapping im Modbus-Prozessabbild
•
EK9000 - EtherCAT-Konfigurationen


Konfiguration über die HTML-Seiten des Buskopplers

Konfiguration [image] Konfiguration über die HTML-Seiten des Buskopplers
Konfiguration über die HTML-Seiten des Buskopplers
Für die Konfiguration steht eine HTML-Seite zur Verfügung. Diese kann über die IP-Adresse/Config erreicht werden (z. B.: 192.168.1.3/Config). Wir empfehlen als Browser Chrome oder Firefox zu nutzen.
Sollten Sie DHCP verwenden, geben Sie den Namen des Buskopplers anstelle der IP-Adresse ein. Der Default-Name des Buskopplers beginnt mit der Zeichenfolge "EK-" und dann folgen die letzten 3 Byte seiner MAC-Adresse (Mac-Id). Die MAC-Adresse finden Sie auf dem Aufkleber, links am Buskoppler.
Beispiel: Die MAC-Adresse lautet 00-01-05-02-03-04. Dies ergibt "EK-020304" als Default-Namen. Geben Sie nun "EK-020304/Config" in Ihren Browser ein. Der Anmeldename ist "guest", und das Default-Passwort ist "1" (ohne Anführungszeichen).
Auf der Informationsdiagnose-Seite kann die Firmware, Hardware-Stand, Seriennummer ausgelesen werden. Bei eventuellen Problemen kann die Diagnose-History ausgelesen werden. Die Diagnose-History wird nicht gespeichert und wird bei einem Neustart gelöscht.
Konfiguration über HTML-Seiten - Informationsdiagnose-Seite
Network-Interface
Das Network-Interface ermöglicht Ihnen das Einstellen der IP-Adresse. Beachten Sie dabei, dass der DIP-Schalter des EK9000 Vorrang hat und seine Einstellung gilt, unabhängig vom dem, was Sie in diesem Dialog einstellen.
Konfiguration über HTML-Seiten - Network-Interface
Bespiel
DIP-Schalter DIP 1 = on; DIP 2...10 off, Einstellung im Dialog 10.1.2.3 -> Echte IP-Adresse = 10.1.2.1
(der DIP-Schalter überschreibt das letzte Byte der IP-Adresse).
Stellen Sie die gewünschte IP-Adresse ein und klicken Sie dann auf den Haken.
Hinweis: im Dialog Feld wird wieder die alte IP-Adresse angezeigt, da diese noch die gültige Adresse ist.
Nach dem Ändern der IP-Adresse ist ein Software-Reboot notwendig. Gehen Sie dazu auf "Boot Opt." und klicken Sie auf "Reboot...".
Mit DIP Schalter Stellung
▪
DIP 1 bis DIP 8 = on und
▪
DIP 9 und DIP 10 = off
werden die kompletten 4 Byte der IP-Adresse aus dem Dialogfeld übernommen.


EtherCAT-Konfiguration

Konfiguration [image] EtherCAT-Konfiguration
EtherCAT-Konfiguration
EtherCAT-Klemmen können über die HTML-Seite Beckhoff Device Manager Konfiguriert und Parametriert werden.
Konfiguration über HTML-Seiten - EtherCAT-Konfiguration
EtherCAT Master
Hier wird angezeigt in welchem Zustand sich der EtherCAT Master auf dem EK Koppler befindet. In der Regel sollte der im OP sein.
Network Statistics
Hier wird die EtherCAT-Statistik ausgegeben.
EtherCAT Slaves
Anzeige der EtherCAT Slaves und deren Zustand. Der Restore State gibt an ob für die Klemmen ein Restore File angelegt wurde.
Restore File
Das Restore File wird benötigt um EtherCAT-Klemmen wieder neu zu Parametrieren. Werden EtherCAT-Klemmen ausgetauscht und wurden diese Parametriert geht diese Information in der Regel mit dem Austausch der EtherCAT-Klemmen verloren. Das Restore File spielt die Parameter wieder auf eine neue Klemme beim starten des Koppler auf die entsprechende Klemme. Das Restore File muss angelegt werden, wenn Sie das Default Mapping der Klemmen ändern wollen oder müssen.
▪
EMPTY
bedeutet für die Klemme gibt es kein Restore File
▪
VALID
ein gültiges Restore File wurde angelegt
▪
MAPPING
Das Klemmen-Mapping wurde umgestellt, ist aber noch nicht in dem Restore File abgelegt.
EtherCAT Slaves Mappings
Bei einigen EtherCAT-Klemmen kann das Prozessabbild umgestellt werden, dieses muss im EtherCAT Master hinterlegt sein. Die Klemmen, die man umstellen kann, werden unter "EtherCAT Slaves Mapping" angezeigt, das entsprechende Mapping muss eingestellt werden und im Restore File abgelegt sein. Dann wird der Koppler neu gestartet, damit der Koppler das Mapping aktivieren kann (Achtung: Das Prozessabbild wird dadurch geändert)
Konfiguration über HTML-Seiten - EtherCAT Slaves Mappings
Parametrieren der EtherCAT-Klemmen
Um eine EtherCAT-Klemme zu parametrieren wählen Sie die entsprechende Klemme aus, bekommen dann deren Objekte angezeigt und können diese wenn notwendig editieren. Die Einstellungen werden dann in der Klemme gespeichert. Beachten Sie, dass wenn die Klemme getauscht wird die geänderten Einstellungen mit dem Tausch verloren gehen. Nutzen Sie in diesem Fall das Restore File, da Ihre Änderungen auch im Restore File ablegt sind.
Restore Files überschreibt Modbus-Änderungen
Bei Verwendung des Restore Files werden die Objekt Parameter immer beim starten des Kopplers auf die Klemmen gespielt. Änderungen die Sie per Modbus Interface oder per Web Seite vorgenommen haben werden damit überschrieben.
Konfiguration über HTML-Seiten - Parametrieren der EtherCAT-Klemmen


Modbus-Konfiguration

Konfiguration [image] Modbus-Konfiguration
Modbus-Konfiguration
Einstellungen der Modbus-Konfiguration.
Konfiguration über HTML-Seiten - Modbus-Konfiguration
Modbus Device
Alle Parameter sind "read only" und dienen nur der Diagnose.
Modbus Settings
Hier können Einstellungen für das Modbus Interface vorgenommen werden.
Watchdog Mode (0x1122)
Hier kann man zwischen Disabled, Telegramm und Write auswählen. Der Watchdog wird mit dem ersten Schreibtelegramm auf die Prozessdaten aktiviert, den Schreibzugriff bekommt der Master, der als erstes einen Schreibzugriff auf die Prozessdaten durchgeführt hat.
▪
Disabled
der Watchdog ist ausgeschaltet, Ausgänge, die gesetzt sind, bleiben erhalten.
▪
Telegramm
der Watchdog wird auch von Lesetelegramme auf die Prozessdaten nachgetriggert.
▪
Write
der Watchdog wird nur durch Schreibtelegramme auf die Prozessdaten nachgetriggert.
Die Einstellung ist auch über das Modbus Interface Offset 0x1122 zu beschreiben.
Watchdog Timeout (0x1120)
Hier ist der Timeout in [ms] einzutragen, empfohlen Werte 500 ms - 5000 ms, kleiner Werte sind nicht empfehlenswert, da dies sehr schnell zu einem Watchdog Fehler führen kann. Der maximale Wert liegt bei einer Minute.
Writelock (0x1124)
Erlaubt das Schreiben auch von einem weiteren Master (Client) aus. Achten Sie beim Schreiben von einem zweiten Master, das nur der erste Master den Watchdog triggert. Achten Sie des Weiteren auch auf überlappende schreibende Befehle.
Beispiel: Wenn ein Master den ersten, digitalen Ausgang auf True setzt und der zweite Modbus Client den ersten Ausgang auf FALSE setzt, wird der Ausgang immer an- und ausgeschaltet.
Fallback Mode (0x1123)
Der Fallback Mode ist nur dann aktiv, wenn auch der Watchdog Mode aktiviert ist. Hier kann zwischen "Freeze" (Ausgänge bleiben erhalten) und "Set to Zero" (Ausgänge werden zu Null geschrieben) ausgewählt werden.
Enable ModbusTCP
Aktivieren oder deaktivieren des ModbusTCP-Protokolls.
Max. TCP connection
Anzahl der gleichzeitig benutzten TCP Verbindungen. Es wird empfohlen nicht mehr als 3 zuzulassen. Je mehr TCP Verbindungen desto schlechter ist die Performance des Kopplers.
Enable ModbusUDP
Aktivieren oder deaktivieren des ModbusUDP-Protokolls.
TCP/UDP-Port
TCP- oder UDP-Port Nummer der Modbus-Kommunikation.
Ethernet-Statistik
Zeigt die Statistik der ankommenden und gesendeten Ethernet Frames an.
IP-Stack-Statistik
Zeigt die IP-Statistik an.
Modbus-Service-Statistik
Zeigt die Modbus-Statistik an (siehe auch Diagnose Funktion 8).


EtherCAT-Mapping im Modbus-Prozessabbild

Konfiguration [image] EtherCAT-Mapping im Modbus-Prozessabbild
EtherCAT-Mapping im Modbus-Prozessabbild
In welchem Modbus-Prozessabbild (Offset) die verwendeten EtherCAT-Klemmen liegen, zeigt die Modbus-Service-Seite. Hier kann der Anwender nachsehen, wo die Klemmen im Modbus- Prozessabbild liegen und mit welcher Modbus-Funktion sie zu erreichen sind.
Das Interpretieren der Daten der einzelnen EtherCAT-Klemmen entnehmen Sie bitte den klemmenspezifischen Dokumentationen.
EtherCAT-Mapping im Modbus-Prozessabbild


EK9000 - EtherCAT-Konfigurationen

Konfiguration [image] EK9000 - EtherCAT-Konfigurationen
EK9000 - EtherCAT-Konfigurationen
Der EK9000 ist ein EtherCAT-Master mit automatischer Konfiguration. D.h. es müssen beim Einschalten des Systems immer alle EtherCAT-Klemmen vorhanden sein. Da in der Regel das Booten des EK9000 wesentlich länger dauert als das Starten der EtherCAT-Slave-Geräte, können diese an der gleichen Spannungsversorgung betrieben werden. Bei dezentralen EtherCAT-Slaves ist darauf zu achten, dass die früher oder zur gleichen Zeit mit der Versorgungsspannung eingeschaltet werden.
EtherCAT-Teilnehmer während der Laufzeit ein- bzw. ausschalten
Sollte während der Betriebsphase ein oder mehrere EtherCAT-Teilnehmer ausfallen wird ein Fehlerantwort beim Modbus generiert. Die Eingangsdaten aller EtherCAT-Teilnehmer sind dann ungültig, die Ausgangsdaten werden nicht mehr übernommen. Das gilt auch für die Teilnehmer, die noch am EK9000 im Betrieb sind. Möchte man die Möglichkeit nutzen während der Laufzeit Teilnehmer an und ab zu stecken, muss eine weitere "Sync Unit" konfiguriert werden. Dies ist mit einem EK9000 nicht möglich. Verwenden Sie in dem Fall einen CX8090.
EtherCAT-Topologie
Alle EtherCAT-Teilnehmer müssen in der Reihenfolge eingetragen werden, wie sich diese am EK9000 und damit am EtherCAT-Master mappen. EtherCAT-Teilnehmer werden automatisch adressiert, bis auf wenige Ausnahmen sind alle EtherCAT-Busklemmen mit einem EtherCAT ASIC ausgestattet. EtherCAT-Klemmen ohne ASIC sind zum Beispiel EL9400, EL9070 und weitere EL9xxx. Sie können diese EtherCAT-Klemmen anhand der Technischen Daten "Meldung an E-Bus" erkennen. Steht hier dann ein "-" muss diese Klemme für das Mapping nicht berücksichtigt werden.
EtherCAT-Geräte werden in Richtung des EtherCAT Telegrams eingetragen.
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Boxen EPxxxx
Beispielkonfiguration mit EtherCAT-Boxen EPxxxx
Beispielkonfiguration mit EK1122 (2-Port-EtherCAT-Abzweig in Schutzart IP20)
Beachten Sie bei dem Einsatz eines EK1122 die Zählrichtung!
Ist am EK1122 der EtherCAT-Abzweig 1 angeschlossen, so wird hier der EtherCAT-Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem E-Bus auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EK1122 (2-Port-EtherCAT-Abzweig in Schutzart IP20)
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi überbrückt und der EtherCAT-Frame geht direkt aus dem E-Bus auf der rechten Seite weiter.
Beispielkonfiguration mit EP1122 (2-Port-EtherCAT-Abzweig in Schutzart IP65)
Beachten Sie bei dem Einsatz eines EP1122 die Zählrichtung! Sie ist vergleichbar mit dem EK1122.
Ist am EP1122 der EtherCAT-Abzweig 1 angeschlossen, so wird hier der EtherCAT-Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem EtherCAT-Anschluss auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EP1122 (2-Port-EtherCAT-Abzweig in Schutzart IP65)
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi überbrückt und der EtherCAT-Frame geht direkt aus dem EtherCAT-Anschluss auf der rechten Seite weiter.
Kein Hot Swap im laufenden Betrieb
An einem EKxxxx können Sie EP1122 und EK1122 nicht für Hot-Swap und auch nicht für "connect" und "disconnect" im laufenden Betrieb verwenden. EP1122 und EK1122 eigenen sich an einem EKxxxx nur zur Topologie Erweiterung (Stern).


Ethernet

Ethernet
Ethernet
Weiterführende Informationen
•
ModbusTCP/UDP


ModbusTCP/UDP

Ethernet [image] ModbusTCP/UDP
ModbusTCP/UDP
Weiterführende Informationen
•
ModbusTCP/UDP-Protokoll
•
Modbus-Interfaces
•
Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
•
Zugriff über einen zweiten Client
•
Modbus-Funktionen


ModbusTCP/UDP-Protokoll

Ethernet [image] ModbusTCP/UDP [image] ModbusTCP/UDP-Protokoll
ModbusTCP/UDP-Protokoll
Das Ethernet-Protokoll wird über die MAC-ID adressiert. Der Anwender braucht sich meist um diese Adresse nicht zu kümmern. Die IP-Nummer ist 4 Byte groß und muss vom Anwender auf dem Buskoppler und in der Anwendung parametriert werden. Die TCP-Port ist bei ModbusTCP auf 502 festgelegt. Die UNIT ist bei ModbusTCP frei wählbar und braucht vom Anwender nicht konfiguriert werden.
Stack des ModbusTCP/UDP-Protokolls
ModbusUDP
Bei einigen Produkten kann statt ModbusTCP auch ModbusUDP verwendet werden. Die Port-Nummer bleibt in der Regel die gleiche. Für den Anwender ändert sich recht wenig.
Die Vorteile vom ModbusUDP sind, dass es in den meisten Fällen einfacher zu verwenden und in der Regel auch etwas schneller ist als eine TCP/IP-Verbindung.
Die Vorteile von ModbusTCP sind die sicherere Datenübertragung mit schon eingebauten Wiederholungen sowie weitere typischen Vorteile, die eine TCP/IP-Verbindung beinhaltet.
TCP-Port-Nummer
Die TCP-Port-Nummer von ModbusTCP wurde auf den Wert 502 standardisiert.
Modbus-Unit
Die Unit wird vom Slave zurückgegeben.
ModbusTCP-Protokoll
Byte | Name | Beschreibung
0 | Transaction identifier | wird vom Slave zurückgesendet
1 | Transaction identifier | wird vom Slave zurückgesendet
2 | Protocol identifier | immer 0
3 | Protocol identifier | immer 0
4 | Length field | 0 (wenn die Nachricht kleiner 256 Byte ist)
5 | Length field | Anzahl der folgenden Bytes
6 | UNIT identtifier | wird vom Slave zurückgegeben
7 | Modbus | es folgt das Modbus-Protokoll beginnend mit der Funktion


Modbus-Interfaces

Ethernet [image] ModbusTCP/UDP [image] Modbus-Interfaces
Modbus-Interfaces
Adresse |  | Beschreibung
0x0000 0x00FF |  | Prozessdaten-Inferface Eingänge
0x0800 0x08FF |  | Prozessdaten-Inferface Ausgänge
0x1000 0x1006 | Read only | Buskopplerkennung
0x1010 |  | Prozessabbildlänge in Bit, analoge Ausgänge
0x1011 |  | Prozessabbildlänge in Bit, analoge Eingänge
0x1012 |  | Prozessabbildlänge in Bit, digitale Ausgänge
0x1013 |  | Prozessabbildlänge in Bit, digitale Eingänge
0x1020 |  | Watchdog, aktuelle Zeit in [ms]
0x1021 |  | Anzahl der Ausgelösten Fallbacks (Watchdog Timeout oder Bus Fehler)
0x1022 |  | Anzahl der aktiven TCP Verbindungen
0x1030 |  | Hardware Version
0x1031 |  | Software Version Main
0x1032 |  | Software Version Sub-Main
0x1033 |  | Software Version Beta
0x1034 |  | Seriennummer
0x1035 |  | Produktionsdatum Tag
0x1036 |  | Produktionsdatum Monat
0x1037 |  | Produktionsdatum Jahr
0x1040 |  | E-Bus Status 1 OK, 0 nicht OK
0x1120 | Read/Write | Watchdog vordefinierte Zeit in [ms] (Default: 1000)
0x1121 |  | Watchdog Reset Register
0x1122 |  | Art des Watchdogs | 2 | Disable
 |  |  | 1 | Telegramm Watchdog (Default)
 |  |  | 0 | Schreibtelegramm Watchdog
0x1123 |  | Fallback Mode Verhalten wie bei einem Watchdog oder E-Bus Fehler verfahren soll | 2 | Stopp E-Bus, E-Bus wird gestoppt, E-Bus kann mit 0x1140 wieder aktiviert werden
 |  |  | 1 | Freeze
 |  |  | 0 | Set to Zero (Default)
0x1124 |  | Writelock Verriegelt das schreiben von einem 2ten Modbus Client | 1 | Yes (Default)
 |  |  | 0 | No
0x1140 |  | Write 0, E-Bus wird in INIT geschaltet, Wert > 0 EtherCAT Master wird in OP geschaltet (Achtung: die letzten Ausgangswerte werden wieder beschrieben), 5 sec Timeout in dem kein Fallback berücksichtigt wird.
Erweitertes Modbus-Interface
Adresse |  | Beschreibung
0x6000 | Read only | Buskopplerkennung (9000dec)
0x6001 |  | 1. Klemme
0x60xx |  | xx'te Klemme
Adresse |  | Registerkommunikation via Modbus Interface - Beschreibung
0x1400 | Read/Write | READ | WRITE
 |  | STATUS | CONTROL
 |  | 0x010x - Error | 0x0001 execute
 |  | 0x020x - Busy | -
 |  | 0x040x - done | -
0x1401 |  | Bit 15 0 - Read/ 1 - Write | Bit 0..14 Klemmen Nummer (Position im EtherCAT Aufbau), beginnt mit 1
0x1402 |  | CoE Index Nummer
0x1403 |  | Register Bit 0..7 Sub Index, Bit 8..15 nicht verwendet
0x1404 |  | Länge in Byte
0x1405 |  | Error Code: ADS Fehler Code
0x1406..14FF |  | Data[1]...Data[FF]
Beispiel: Lesen der 2. EtherCAT Klemme (EL3204) Objekt 0x1008 SubIndex 0x00 (Name der Klemme)
1. Schritt
ModbusRegWrite
MB.Addr:=0x1400
MB.Len:= 5 (Worte oder Register)
0x1400:=0x0001
0x1401:=0x0002; lesen bit 15=FALSE, 2te Klemme
0x1402:=0x1008; Objekt 0x1008
0x1403:=0x0000; SubIndex 0
0x1404:=0x0000; Länge (nur für das Schreiben notwendig)
2. Schritt
ModbusRegRead
MB.Addr:=0x1400
MB.Len:= 12 (Worte oder Register)
0x1400:=0x0200; SDO Kommunikation noch nicht abgeschlossen, es muss weiter gepollt werden, Schritt 2 ist zu wiederholen bis der Wert 0x0400 ist (wobei 0x0500 ein Fehler bedeutet).
0x1401:=0x0002;2te Klemme
0x1402:=0x1008;
0x1403:=0x0000;
3. Schritt
ModbusRegRead
MB.Addr:=0x1400
MB.Len:= 12 (Worte oder Register)
0x1400:=0x0400; ohne Fehler Daten stehe bereit
0x1401:=0x0002; 2te Klemme
0x1402:=0x1008; Objekt 0x1008
0x1403:=0x0000; SubIndex
0x1404:=0x000B; Länge
0x1405:=0x0000; Error Code
0x1406:=0x4C45; 'EL'
0x1407:=0x3233; '32'
0x1408:=0x3430; '02'
0x1409:=0x30D2; '-0'
0x140A:=0x3030; '00'
0x140B:=0x0030; '0'
Beispiel: Schreiben der 5. EtherCAT Klemme (EL3318) Objekt 0x8000 SubIndex 0x19, Wert für 75µV Messung = 102 dec
Beispiel für ein Schreiben auf eine EL3318 (5te Klemme) bei der der erste Kanal der Klemme auf den Typ 75µV-Messung eingestellt werden soll.
1. Schritt
Write Multiple Register (Modbus Function Code 16)
MB.Addr:=0x1400
MB.Len:= 7 (Worte oder Register)
0x1400:=0x0001
0x1401:=0x8005; Schreiben (bit 15 = TRUE), 5. Klemme
0x1402:=0x8000; Objekt 0x8000
0x1403:=0x0019; SubIndex 0x19
0x1404:=0x0002; Länge
0x1405:=0; Error Code
0x1406:=102; Wert für 0x8000, SubIdx 0x19
2. Schritt
Read Multiple Register (Modbus Function Code 3), es sollten hier mindestens 6 Worte gelesen werden. Wenn ein Fehler auftritt, steht der Fehler Code ab dem Offset 0x1405.
Abfrage bis Bit 10 im Offset 0x1400, steht dies auf „done“ (0x04xx), war das Schreiben erfolgreich.
Sollte als Antwort im Offset 0x1400 der Wert 0x02xx stehen, ist das Schreiben noch nicht abgeschlossen. Das Lesen ist dann zu wiederholen.
Sollte als Antwort im Offset 0x1400 der Wert 0x01xx stehen, ist ein Fehler aufgetreten. Der Fehler Code ist dann im Offset 0x1405 zu finden, es handelt sich um einen ADS Fehler Code.
Modbus UDP
Wahlweise kann die Kommunikation auch über Modbus UDP verwendet werden.


Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)

Ethernet [image] ModbusTCP/UDP [image] Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
Fehlerantwort des ModbusTCP Slaves (BK9000, BX/BC9xx0, IP/ILxxxx-B/C900, EK9000)
Wenn der Anwender dem Slave eine Anforderung oder Mitteilung sendet, die der Koppler nicht versteht, antwortet der Slave mit einer Fehlermitteilung. Diese Antwort enthält die Funktion und den Fehler-Code. Der Funktionsrückgabewert wird mit 0x80 addiert.
Code | Name | Bedeutung
1 | ILLEGAL FUNKTION | Nicht implementierte Modbus-Funktion
2 | ILLEGAL DATA ADDRESS | Ungültige Adresse oder Länge
3 | ILLEGAL DATA VALUE | Ungültige Parameter - Diagnose-Funktionen - falsches Register
4 | SLAVE DEVICE ERROR | Watchdog- oder K-Bus-Fehler EK9000: E-Bus Fehler
6 | SLAVE DEVICE BUSY | Es wird schon von einem anderen IP-Teilnehmer Ausgangs-Daten empfangen


Zugriff über einen zweiten Client

Ethernet [image] ModbusTCP/UDP [image] Zugriff über einen zweiten Client
Zugriff über einen zweiten Client
Der EK9000 kann auch über einen weiteren Client angesprochen werden. Dieser kann lesend auf dem Koppler zugreifen. Ein Schreibvorgang wird aber abgelehnt und mit einem Modbus-Fehler quittiert, solange der erste Client noch den Watchdog triggert.
Fällt der erste Client aus übernimmt der zweite Client nach der halben Watchdog-Zeit und kann nach der halben Watchdog Zeit die Ausgänge selbst schreiben. Wenn die Watchdog-Zeit entsprechend hoch eingestellt ist kann das auch nahezu Rückwirkungsfrei geschehen, d.h. gesetzte Ausgänge bleiben gesetzt. Wird der erste Client wieder aktiv, bekommt dieser beim Schreiben dann eine Modbus-Fehlermeldung.
Funktion
Der Hersteller der Applikation ist für den Einsatz und Art und Weise dieser Art von Kommunikation selber verantwortlich.
Wann greift diese Methode nicht
Die Applikation des ersten Client ist eingefroren, Modbus Telegramme werden aber weiterhin gesendet. Dann würde der zweite Modbus Client keine Chance bekommen den EK9000 zu übernehmen, da weiterhin Modbus Telegramme gesendet werden.


Modbus-Funktionen

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen
Modbus-Funktionen
Weiterführende Informationen
•
ModbusTCP-Funktionen
•
Read coil status (Funktion 1)
•
Read input status (Funktion 2)
•
Read holding register (Funktion 3)
•
Read input register (Funktion 4)
•
Force single coil (Funktion 5)
•
Preset single register (Funktion 6)
•
Diagnose (Funktion 8)
•
Force multiple coils (Funktion 15)
•
Preset multiple register (Funktion 16)
•
Read / Write Registers (Funktion 23)


ModbusTCP-Funktionen

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] ModbusTCP-Funktionen
ModbusTCP-Funktionen
Die Funktionen entscheiden beim Modbus-Protokoll, ob Daten gelesen oder geschrieben werden und um welche Art von Daten es sich dabei handelt.
Funktion | Code | Beschreibung
Read coil status | 1 | Lesen digitaler Ausgänge
Read input status | 2 | Lesen digitaler Eingänge
Read holding register | 3 | Lesen analoger Aus- und Eingänge / GPR
Read input register | 4 | Lesen der Eingänge / GPR
Force single coil | 5 | Schreiben eines digitalen Ausgangs
Preset single register | 6 | Schreiben eines Ausgangs / GPR
Diagnose | 8 | Diagnose
Force multiple coils | 15 | Schreiben mehrere digitaler Ausgänge
Preset multiple register | 16 | Schreiben mehrerer Ausgänge / GPRs
Read / write registers | 23 | Schreiben und lesen mehrerer Prozessdaten Ausgänge / GPRs
GPR (General Preset Register) - Registerstruktur Modbus Interface (siehe Anhang)


Read coil status (Funktion 1)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Read coil status (Funktion 1)
Read coil status (Funktion 1)
Mit der Funktion Read coil status können die gesetzten, digitalen Ausgänge gelesen werden.
In diesem Beispiel werden die ersten 10 digitalen Ausgänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 1
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 10
Der Feldbus-Koppler antwortet mit dem Byte Count 2, d.h. 2 Byte Daten kommen zurück. Die Anfrage war 10 Bits, die jetzt auf 2 Byte aufgeteilt werden. Im Ausgangsprozessabbild ist das dritte Bit gesetzt und der Feldbus-Koppler gibt im ersten Datenbyte eine den Wert 4 wieder.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 1
Byte Count | 2
Daten-Bit 0...7 | 4
Daten-Bit 8...18 | 0


Read input status (Funktion 2)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Read input status (Funktion 2)
Read input status (Funktion 2)
Mit der Funktion Read input status können die digitalen Eingangsdaten gelesen werden. In diesem Beispiel werden die ersten 10 digitale Eingänge gelesen. Die Start-Adresse ist Null. Im Feld Start-Adresse können Sie einen Offset eintragen.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 2
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 10
Der Feldbus-Koppler antwortet mit dem Byte Count 2, d.h. es kommen zwei Byte Daten zurück. Die Anfrage war 10 Bits, die jetzt auf zwei Byte aufgeteilt werden. Im Ausgangsprozessabbild ist das dritte Bit gesetzt und der Feldbus-Koppler gibt im ersten Datenbyte eine den Wert 4 wieder.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 2
Byte Count | 2
Daten-Bits 0..7 | 1
Daten-Bits 8..18 | 0


Read holding register (Funktion 3)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Read holding register (Funktion 3)
Read holding register (Funktion 3)
Mit der Funktion Read holding register können die Ein- und Ausgangsworte und die Register gelesen werden. Eingänge ab dem Offset 0 - 0xFF und Ausgänge ab den Offset 0x800 - 0x8FF und bei den Steuerungen (BC, BX) der Merkerbereich ab den Offset 0x4000.
In diesem Beispiel werden die ersten zwei analogen Ausgänge (oder 2 Ausgangsworte) gelesen. Die analogen Ausgänge (oder Ausgangsworte) beginnen beim Offset 0x800. Die Länge bezeichnet die Anzahl, der zu lesenden Kanäle (oder der zu lesenden Worte).
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 3
Start-Adresse high | 8
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 2
Der Feldbus-Koppler antwortet mit dem Byte Count 4, d.h. es kommen 4 Byte Daten zurück. Die Anfrage waren zwei Analogkanäle, die auf zwei Worte aufgeteilt sind. Im analogen Ausgangsprozessabbild hat der erste Kanal einen Wert von 0x3FFF und der zweite Kanal einen Wert von 0x0.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 3
Byte Count | 4
Daten 1 High-Byte | 63
Daten 1 Low-Byte | 255
Daten 2 High-Byte | 0
Daten 2 Low-Byte | 0


Read input register (Funktion 4)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Read input register (Funktion 4)
Read input register (Funktion 4)
Die Funktion Read input register liest wort-orientiert die Eingänge aus.
In diesem Beispiel werden die ersten zwei analogen Eingänge (oder die erste 2 Eingangsworte) gelesen. Die analogen Eingänge (oder Eingangsworte) beginnen bei einem Offset von 0x0000. Die Länge bezeichnet die Anzahl der zu lesenden Worte. Eine KL3002 z. B. hat zwei Worte Eingangsdaten, daher ist die einzugebende Länge bei Anzahl low zwei.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 4
Start-Adresse high | 0
Start-Adresse low | 0
Anzahl high | 0
Anzahl low | 2
Der Feldbus-Koppler antwortet mit dem Byte Count 4, d.h. es kommen vier Byte Daten zurück. Die Anfrage waren zwei analog Kanäle, die jetzt auf zwei Worte aufgeteilt werden. Im analogen Eingangsprozessabbild hat der erste Kanal einen Wert von 0x0038 und der zweite Kanal einen Wert von 0x3F1B.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 4
Byte Count | 4
Daten 1 High-Byte | 0
Daten 1 Low-Byte | 56
Daten 2 High-Byte | 63
Daten 2 Low-Byte | 11


Force single coil (Funktion 5)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Force single coil (Funktion 5)
Force single coil (Funktion 5)
Mir der Funktion Force single coil kann ein digitaler Ausgang beschrieben werden. In diesem Beispiel wird der dritte digitale Ausgang beschrieben. Die digitalen Ausgänge beginnen bei Adresse 0x0000. Im Daten high steht der digitale Wert. Um den Ausgang einzuschalten muss im Daten high der Wert 0xFF stehen und um den Ausgang wieder auszuschalten der Wert 0x00. Im Daten low muss der Wert 0x00 stehen.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 5
Start-Adresse high | 0
Start-Adresse low | 2
Daten high | 255
Daten low | 0
Der Koppler antwortet mit dem gleichen Telegramm.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 5
Start-Adresse high | 0
Start-Adresse low | 2
Daten high | 255
Daten low | 0


Preset single register (Funktion 6)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Preset single register (Funktion 6)
Preset single register (Funktion 6)
Mit der Funktion Preset single register kann auf das Ausgangs- oder Merkerprozessabbild (nur bei den Steuerungen) und das Modbus-TCP-Interface zugegriffen werden.
Bei der Funktion 6 wird das erste Ausgangswort beschrieben. Die Ausgänge beginnen bei einem Offset von 0x0800. Auch hier beschreibt der Offset immer ein Wort. Das heißt, dass der Offset 0x0803, das 4. Wort auf dem Ausgangsprozessabbild ist.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 6
Start-Adresse high | 8
Start-Adresse low | 0
Daten high | 63
Daten low | 255
Der Feldbus-Koppler antwortet mit dem gleichen Telegramm und der Bestätigung der empfangenen Werte.
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 6
Start-Adresse high | 8
Start-Adresse low | 0
Daten high | 63
Daten low | 255


Diagnose (Funktion 8)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Diagnose (Funktion 8)
Diagnose (Funktion 8)
Die Funktion Diagnose stellt eine Reihe von Tests, für die Überprüfung des Übertragungssystems zwischen dem Master und dem Slave oder für die Überprüfung der verschiedenen internen Fehlerzustände innerhalb des Slaves zur Verfügung.
Die Funktion benutzt in der Anfrage zwei Byte, um mit einem Unterfunktions-Code die Art des durchzuführenden Tests zu definieren. Der Slave gibt in der Antwort den Funktions-Code und den Unterfunktions-Code zurück.
Die Diagnose-Anfragen benutzen ein Datenfeld von zwei Byte, um Diagnosedaten oder Steuerinformationen zum Slave zu schicken.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 8
Unterfunktion high | 0
Unterfunktion low | 0
Data high | 2
Data low | 3
Antwort (Response)
Byte Name | Beispiel
Funktions-Code | 8
Unterfunktion high | 0
Unterfunktion low | 0
Data high | 2
Data low | 3
Buskoppler-Reset (Unterfunktion 1)
Der Buskoppler wird mit der Unterfunktion 1 neu initialisiert, Fehlerzähler werden zurückgesetzt und der Buskoppler führt einen Selbsttest durch. In der Zeit, in der der Buskoppler zurückgesetzt wird, werden keine Telegramme empfangen oder gesendet. Der IP-Socket wird geschlossen.
Tipp oder Fingerzeig
Bevor der Koppler neu startet schickt er noch eine Antwort mit der Unterfunktion 1, dann wird der IP-Socket geschlossen.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0001 | 0x0000 | 0x0000
Löschen aller Zählerinhalte (Unterfunktion 10)
Beim Aufruf dieser Unterfunktion löscht der Controller alle Fehler Zähler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x000A | 0x0000 | Echo Query Daten
Read Coils (Unterfunktion 32)
Gibt die Anzahl der Read Coils Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0020 | 0x0000 | Wert des Zählers
Read Coils Error (Unterfunktion 33)
Gibt die Anzahl der Read Coils Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0021 | 0x0000 | Wert des Zählers
Read Discrete Inputs (Unterfunktion 34)
Gibt die Anzahl der Read Discrete Inputs Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0022 | 0x0000 | Wert des Zählers
Read Discrete Inputs Error (Unterfunktion 35)
Gibt die Anzahl der Read Discrete Inputs Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0023 | 0x0000 | Wert des Zählers
Read Holding Register (Unterfunktion 36)
Gibt die Anzahl der Read Holding Register Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0024 | 0x0000 | Wert des Zählers
Read Holding Register Error (Unterfunktion 37)
Gibt die Anzahl der Read Holding Register Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0025 | 0x0000 | Wert des Zählers
Read Input Register (Unterfunktion 38)
Gibt die Anzahl der Read Input Register Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0026 | 0x0000 | Wert des Zählers
Read Input Register Error (Unterfunktion 39)
Gibt die Anzahl der Input Holding Register Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0027 | 0x0000 | Wert des Zählers
Write Single Coil (Unterfunktion 40)
Gibt die Anzahl der Write Single Coil Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0028 | 0x0000 | Wert des Zählers
Write Single Coil Error (Unterfunktion 41)
Gibt die Anzahl der Write Single Coil Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0029 | 0x0000 | Wert des Zählers
Write Single Register (Unterfunktion 42)
Gibt die Anzahl der Write Single Register Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x002A | 0x0000 | Wert des Zählers
Write Single Register Error (Unterfunktion 43)
Gibt die Anzahl der Write Single Register Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x002B | 0x0000 | Wert des Zählers
Diagnose Register (Unterfunktion 44)
Gibt die Anzahl der Diagnose Register Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x002C | 0x0000 | Wert des Zählers
Diagnose Register Error (Unterfunktion 45)
Gibt die Anzahl der Diagnose Register Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x002D | 0x0000 | Wert des Zählers
Write Multiple Coils (Unterfunktion 46)
Gibt die Anzahl der Write Multiple Coils Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x002E | 0x0000 | Wert des Zählers
Write Multiple Coils Error (Unterfunktion 47)
Gibt die Anzahl der Write Multiple Coils Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x002F | 0x0000 | Wert des Zählers
Write Multiple Register (Unterfunktion 48)
Gibt die Anzahl der Write Multiple Register Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0030 | 0x0000 | Wert des Zählers
Write Multiple Register Error (Unterfunktion 49)
Gibt die Anzahl der Write Multiple Register Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0031 | 0x0000 | Wert des Zählers
R/W Multiple Register (Unterfunktion 50)
Gibt die Anzahl der R/W Multiple Register Kommandos an.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0032 | 0x0000 | Wert des Zählers
R/W Multiple Register Error (Unterfunktion 51)
Gibt die Anzahl der R/W Multiple Register Kommandos an mit Fehler.
Unterfunktion | Daten Feld (Query) | Daten Feld (Response)
0x0033 | 0x0000 | Wert des Zählers


Force multiple coils (Funktion 15)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Force multiple coils (Funktion 15)
Force multiple coils (Funktion 15)
Bei der Funktion Force multiple coils können gleichzeitig mehrere digitale Ausgänge gesetzt oder zurückgesetzt werden.
In diesem Beispiel werden die ersten 20 digitalen Ausgänge beschrieben. Die digitalen Ausgänge beginnen bei einem Offset von 0x0000. Hier beschreibt der Offset immer ein Bit. Der Offset 0x0003 schreibt ab dem vierten Bit auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Bits an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 20 Bits belegen 3 Byte Count (auf Byte-Grenzen aufrunden).
Die Daten-Bytes enthalten die Werte für die einzelnen Bits. In diesem Beispiel werden die Bit 0 bis 15 auf TRUE gesetzt und Bit 16 bis 23 auf FALSE.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 15
Start-Adresse high | 0
Start-Adresse low | 0
Länge high | 0
Länge low | 20
Byte Count | 3
Daten 1 Bit 0..7 | 255
Daten 2 Bit 8..15 | 255
Daten 3 Bit 16..23 | 0
Antwort (Response)
Der Buskoppler antwortet mit dem gleichen Telegramm.
Byte Name | Beispiel
Funktions-Code | 15
Start-Adresse high | 0
Start-Adresse low | 0
Länge high | 0
Länge low | 20


Preset multiple register (Funktion 16)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Preset multiple register (Funktion 16)
Preset multiple register (Funktion 16)
Mit der Funktion Preset multiple register können mehrere Ausgänge beschrieben werden. In diesem Beispiel werden die ersten zwei analogen Ausgangsworte beschrieben. Die Ausgänge beginnen bei einem Offset von 0x0800. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem vierten Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x7FFF und das zweite Wort mit dem Wert 0x3FFF.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 16
Start-Adresse high | 8
Start-Adresse low | 0
Länge high | 0
Länge low | 2
Byte Count | 4
Daten 1 Byte 1 | 127
Daten 1 Byte 2 | 255
Daten 2 Byte 1 | 63
Daten 2 Byte 2 | 255
Antwort (Response)
Der Koppler antwortet mit der Start-Adresse und der Länge der gesendeten Worte.
Byte Name | Beispiel
Funktions-Code | 16
Start-Adresse high | 8
Start-Adresse low | 0
Länge high | 0
Länge low | 2


Read / Write Registers (Funktion 23)

Ethernet [image] ModbusTCP/UDP [image] Modbus-Funktionen [image] Read / Write Registers (Funktion 23)
Read / Write Registers (Funktion 23)
Mit der Funktion Read / Write Registers können mehrere analoge Ausgänge beschrieben und in einem Telegramm mehrere analoge Eingänge gelesen werden. In diesem Beispiel werden die ersten zwei analogen Ausgangsworte beschrieben und die ersten zwei analogen Eingänge gelesen. Die analogen Ausgänge beginnen beim Offset 0x0800 und die Eingänge ab dem Offset 0x0000. Hier beschreibt der Offset immer ein Wort. Der Offset 0x0003 schreibt ab dem 4. Wort auf das Ausgangsprozessabbild. Die Länge gibt die Anzahl der Worte an und der Byte Count setzt sich aus den zu schreibenden Bytes zusammen.
Beispiel: 4 Worte - entsprechen 8 Byte Count
Die Datenbytes enthalten die Werte für die analogen Ausgänge. In diesem Beispiel sind es zwei Worte, die zu beschreiben sind. Das erste Wort mit dem Wert 0x3FFF und das zweite Wort mit dem Wert 0x7FFF.
Anfrage (Query)
Byte Name | Beispiel
Funktions-Code | 23
Lesen Start-Adresse high | 0
Lesen Start-Adresse low | 0
Lesen Länge high | 0
Lesen Länge low | 2
Schreiben Start-Adresse high | 8
Schreiben Start-Adresse low | 0
Schreiben Länge high | 0
Schreiben Länge low | 2
Byte Count | 4
Daten 1 high | 63
Daten 1 low | 255
Daten 2 high | 127
Daten 2 low | 255
Antwort (Response)
Der Koppler antwortet mit der Start-Adresse und der Länge der übertragenen Bytes im Byte Count. Es folgen die Dateninformationen. In diesem Beispiel steht im ersten Wort eine 0x0038 und im zweiten Wort eine 0x3F0B.
Byte Name | Beispiel
Funktions-Code | 23
Byte Count | 4
Daten 1 high | 0
Daten 1 low | 56
Daten 2 high | 63
Daten 2 low | 11


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
LED-Anzeigen


LED-Anzeigen

Fehlerbehandlung und Diagose [image] LED-Anzeigen
LED-Anzeigen
LEDs des EK9000
Ethernet Schnittstelle X001
Schnittstelle X001/X002 | Ethernet | Bedeutung
LED grün | an | Link vorhanden/Aktivität
LED gelb | wird nicht benutzt | -
LEDs auf dem Koppler
Beschriftung | Bedeutung | Farbe | Bedeutung
RUN | Zeigt den Status des Kopplers an | rot | Darf nur in der Hochlauf-Phase leuchten
 |  | grün | Koppler ist bereit
 |  | blau (Wenn roter DIP Schalter 1 auf on steht beim starten des Kopplers) | Über USB kann das interne Flash erreicht werden (Firmware update)
LED WD | Modbus Status | Bedeutung
 | grün/rot/gelb
Hochstarten von EtherCAT | gelb 200 ms blinken | EC Master startet hoch, noch keine Modbus Kommunikation möglich
Parametrieren der Klemmen | gelb 400 ms blinken | EC Master parametriert die EC Klemmen, noch keine Modbus Kommunikation möglich
Run | grün on | OK
Watchdog | rot 400 ms blinken | Watchdog Fehler
LED ERR | Modbus Diagnose |  | Bedeutung
 | grün | rot
Fehler Modbus | off | kurz aufleuchten | Fehlerhaftes Modbus Telegramm erhalten (siehe Diag History)
Koppler IP Setting | off | 400ms blinken | Koppler hat keine IP Adresse (DHCP aktive)
Device is in IO exchange | off | off | OK
2nd Client | on | off | 2nd Client ist aktiv, Schreibtelegramme werden aber mit Fehler beantwortet
LEDs auf der Netzteilklemme
LEDs auf der Netzteilklemme
Betrieb mit E-Bus Klemmen
Anzeige LED | Beschreibung | Bedeutung
1 Us 24 V (Links Oben, 1te Reihe) | Versorgung Spannung Koppler | an - 24 V angeschlossen
2 Up 24 V (Rechts Oben, 1te Reihe) | Versorgung Spannung Powerkontakte | an - 24 V angeschlossen
3 L/A (Links Mitte, 2te Reihe) | EtherCAT LED | blinkt grün EtherCAT Kommunikation aktiv an E-Bus angeschlossen / Kein Datenverkehr aus E-Bus nicht angeschlossen


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Image des Buskopplers aktualisieren
•
Typische Fragen
•
Abkürzungsverzeichnis
•
Support und Service


Image des Buskopplers aktualisieren

Anhang [image] Image des Buskopplers aktualisieren
Image des Buskopplers aktualisieren
Datenverlust
Die Daten im internen Flash-Speicher werden gelöscht.
Sichern Sie Ihre Daten, bevor Sie das Image des Buskopplers aktualisieren.
Das Image des Buskopplers kann über die USB-Schnittstelle aktualisiert werden. Dafür wird der Buskoppler per USB-Kabel mit einem Host-PC verbunden. Anschließend wird der Buskoppler unter Windows als Wechseldatenträger angezeigt und die Dateien können kopiert werden.
Aktualisieren Sie den Buskoppler nur nach Rücksprache mit dem Beckhoff Service. Der Beckhoff Service stellt auch alle notwendigen Dateien zur Verfügung.
Voraussetzungen
▪
Überprüfen Sie zuerst ob der Buskoppler das Image unterstützt.
▪
Der Buskoppler ist per USB-Kabel mit dem Host-PC verbunden.
Aktualisieren Sie das Image wie folgt:
1.
Schalten Sie den Buskoppler aus.
2.
Stellen Sie den 2-poligen roten DIP-Schalter 1 auf „on“ (nach rechts) und schalten Sie den Buskoppler ein.
Der Buskoppler erscheint als Wechseldatenträger auf dem Host-PC.
3.
Markieren und löschen Sie alle Dateien.
Nicht formatieren.

4.
Entfernen Sie das USB-Kabel, sobald alle Dateien kopiert wurden und stellen Sie den 2-poligen DIP-Schalter auf „off“ (nach links).
5.
Starten Sie den Buskoppler neu.
⇨
Sie haben das Image erfolgreich aktualisiert. Es ist möglich, dass der Buskoppler nach der Aktualisierung etwas länger für den Start benötigt.


Typische Fragen

Anhang [image] Typische Fragen
Typische Fragen
Wie kann ich bei Modbus-Fehler die Ausgänge im aktuellen Zustand belassen?
Stellen Sie den Watchdog Mode auf Disable [Web Seite] oder Modbus Interface 0x1122 auf "2".
Ich möchte das Mapping einer EtherCAT-Klemme umstellen?
Verwenden Sie hierfür die Web-Konfiguration und erzeugen Sie ein Restore File.
Woher weiß ich wie die MAC-Adresse des Buskopplers ist?
Die MAC-Adresse ist auf dem Aufkleber an der Seite des Buskopplers aufgedruckt.
Wozu ist die USB-Schnittstelle, was kann ich damit machen?
Die USB-Schnittstelle ist derzeit nur für eine Firmware update zu verwenden.
Wozu ist der DIP-Schalter hinter der Klappe?
Der ist z. B. für die Verwendung des Firmware Updates notwendig (siehe Kapitel DIP-Schalter).
Kann ich auch K-Bus-Klemmen betreiben?
Nein, es sind ausschließlich EtherCAT-Klemmen oder EtherCAT-Boxen anschließbar. Für K-Bus-Klemmen können Sie die BK9050 oder BK9100 verwenden. Die EtherCAT-Koppler für K-Bus wie zum Beispiel BK1120 oder BK1250 sind nicht möglich.
Ich habe einen EtherCAT-Slave von einer Fremdfirma, kann ich den auch anschließen?
Nein, Geräte von anderen Herstellern können nur mit einem CX verwendet werden (siehe CX8090 oder ähnliche Produkte).
Ich möchte die Antriebesklemmen/Antriebe am EK9000 betreiben, geht das?
Nein, hierfür verwenden Sie einen CX mit entsprechende Performanz, z. B. CX9020 oder größer.
Ich möchte TwinSAFE-Klemmen am EK9000 betreiben, geht das?
Nein, die TwinSAFE-Klemmen benötigen zum Konfigurieren ein TwinCAT System, verwenden Sie hierfür den CX8090.
Wie bekomme ich mit das der EtherCAT einen Fehler hat?
Die ERR LED leuchtet dann rot und Modbus-Telegramme werden mit Fehlercode 4 beantwortet.


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
ADS
Automation Device Specification (offen gelegtes Protokoll für die Kommunikation aller Beckhoff-Steuerungen)
DAP
Device Access Point
E/A
Ein- und Ausgänge
E-Bus
EtherCAT im Klemmenverbund (ELxxxx-, ESxxxx-, oder EMxxxx-Klemmen)
EtherCAT
EtherCAT (Ethernet for Control Automation Technology) ist die Ethernet-Lösung für die Industrieautomatisierung, die sich durch überragende Performance und besonders einfache Handhabung auszeichnet.
Fast Ethernet
Darunter versteht man die Datenrate 100 Mbits/s zu verwenden nach dem Standard 100 Base-T.
IP20
Schutzart der Busklemmen, EtherCAT-Klemmen
IPC
Industrie-PC
K-Bus
Klemmen-Bus (KLxxxx-, KMxxxx- oder KSxxxx-Klemmen)
KS2000
Konfigurationssoftware für Busklemmen, Bus Koppler, Busklemmen Controller, Feldbus Box Module usw.
ModbusTCP
Modbus Telegramm basierend auf TCP/IP.
ModbusRTU
Modbus Telegramm basierend auf RS232/422/485.
ModbusUDP
Modbus Telegramm basierend auf UDP/IP.
PE
Der PE-Powerkontakt kann als Schutzerde verwendet werden.
TwinCAT
The Windows Control and Automation Technology, Programmier- und Konfigurationswerkzeug der Firma Beckhoff.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.