EK3100 - PROFIBUS Buskoppler für EtherCAT-Klemmen
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Änderungen
1.3 | - Update Kapitel UL-Hinweise
1.2 | - Update Kapitel „Bus Koppler Image aktualisieren“
1.1 | - Ergänzungen & Korrekturen
1.0 | - Erste Version und Veröffentlichung


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
EKxxxx - Systemübersicht
•
EK3100 - Einführung
•
Technische Daten - EK3100
•
Technische Daten – PROFIBUS


EKxxxx - Systemübersicht

Produktübersicht [image] EKxxxx - Systemübersicht
EKxxxx - Systemübersicht
EtherCAT-Klemmen an einem Buskoppler der Serie EKxxxx
Die Buskoppler der Serie EKxxxx ermöglichen den Betrieb von EtherCAT-Klemmen an herkömmlichen Feldbussystemen. Die ultraschnellen und leistungsfähigen EtherCAT-Klemmen mit ihrer großen Signalauswahl stehen somit auch für andere Feldbus- und Industrial-Ethernet-Systeme zur Verfügung.
Die EKxxxx-Buskoppler sind Feldbus-Slaves und beinhalten einen EtherCAT-Master für die EtherCAT-Klemmen. Sie setzten die Telegramme des übergeordneten Feldbus-Systems auf die E-Bus-Signaldarstellung um. Eine Station besteht aus einem EKxxxx und einer Anzahl von EtherCAT-Klemmen.
Über die entsprechenden Konfigurationstools der Feldbussysteme und die dazugehörigen Konfigurationsdateien, wie z. B. GSD, ESD oder GSDML, werden die EKxxxx auf die gleiche Weise eingebunden, wie die Buskoppler der Serie BKxxxx.
EtherCAT ermöglicht einen sehr flexiblen Topologieaufbau. Durch die Ethernet-Physik können auch weite Distanzen überbrückt werden, ohne dass die Busgeschwindigkeit beeinflusst wird. Bei einem Wechsel in die Feldebene – ohne Schaltschrank – lassen sich auch die EtherCAT-Box-Module (EPxxxx) in Schutzart IP65 mit den EK9xxx verbinden.
Buskoppler für verschiedene Feldbus-Systeme
Die Varianten der Serie EKxxxx unterscheiden sich voneinander durch die Schnittstelle für das übergeordnete Feldbus-System.
Eine Übersicht der verschiedenen Beckhoff Buskoppler, die die wichtigsten Feldbus-Systeme abdecken, finden Sie auf der Beckhoff Website.
Embedded-PCs mit Feldbus-Interface und dezentraler Steuerung
Die mit TwinCAT programmierbare Variante ist die Embedded-PC-Serie CX80xx.
Die Varianten der Serie CX80xx unterscheiden sich voneinander durch die Schnittstelle für das übergeordnete Feldbus-System und der Möglichkeit diese zu Programmieren.
Eine Übersicht der verschiedenen Beckhoff Embedded-PCs, die die wichtigsten Feldbus-Systeme abdecken, finden Sie auf der Beckhoff Website.


EK3100 - Einführung

Produktübersicht [image] EK3100 - Einführung
EK3100 - Einführung
EK3100 Produktübersicht.
Der Buskoppler EK3100 verbindet PROFIBUS-Netzwerke mit den EtherCAT-Klemmen (ELxxxx) sowie EtherCAT-Box-Modulen (EPxxxx) und setzt die Telegramme von PROFIBUS auf die E-Bus-Signaldarstellung um.
Eine Station besteht aus einem EK3100 und einer beliebigen Anzahl von EtherCAT-Klemmen. Der Anschluss des Kopplers an PROFIBUS erfolgt über einen 9-poligen D-Sub-Stecker. Mit EtherCAT verfügt der PROFIBUS-Koppler über ein unterlagertes, leistungsfähiges und ultraschnelles I/O-System mit einer großen Klemmenauswahl. Der Koppler unterstützt das PROFIBUS-Profil und fügt sich damit nahtlos in PROFIBUS-Netzwerke ein.
Konfiguration
Die Konfiguration des EK3100 erfolgt über die vom Buskoppler zur Verfügung gestellten HTML-Seiten (Beckhoff Device Manager) oder über die PROFIBUS DPV1-Dienste.


Technische Daten - EK3100

Produktübersicht [image] Technische Daten - EK3100
Technische Daten - EK3100
Technische Daten | EK3100
Businterface | 1 x D-Sub-Stecker, 9-polig mit Schirmung
Protokoll | PROFIBUS DP
Übertragungsraten | bis 12 MBaud (automatische Erkennung)
Schnittstellen | 1 x USB (hinter der Frontklappe)
Webinterface | ja
Spannungsversorgung | 24 V DC (-15 %/+20 %)
Powerkontakte | 24 V DC max./10 A max.
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung)
Max. Verlustleistung | 3 W
I/O-Anschluss | E-Bus (EtherCAT-Klemmen)
Stromversorgung für I/O-Klemmen | max. 2 A
I/O-Klemmen | E-Bus (EL, ES, EP), Standard digitale Signale, Standard analog Signale. Alle kompatiblen EtherCAT-Teilnehmer werden in der GSD-Datei aufgelistet. Keine Gateway EC-Klemmen, keine EC-Klemmen mit XFC oder DC Funktion.
Anzahl EtherCAT-Teilnehmer | max. 255
Abmessungen (B x H x L) | 65 mm x 100 mm x 73 mm
Betriebs-/Lagertemperatur | 0…+55 °C/-25…+85 °C
Relative Feuchte | 95 % ohne Betauung
Schwingungs-/Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27
EMV-Festigkeit/-Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart/Einbaulage | IP 20/beliebig
Zulassungen | CE, cULus ATEX


Technische Daten – PROFIBUS

Produktübersicht [image] Technische Daten – PROFIBUS
Technische Daten – PROFIBUS
Technische Daten | PROFIBUS (EK3100)
Anzahl der E/A-Module | steuerungsabhängig
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | abgeschirmtes Kupferkabel 2 x 0,25 mm²
Leitungslänge | 1200 m | 1000 m | 400 m | 200 m | 100 m
Übertragungsrate | 9,6/19,2/93,75 kBaud | 187,5 kBaud | 500 kBaud | 1500 kBaud | 3, 6, 12 MBaud
Topologie | Linientopologie
Feldbus | PROFIBUS DP
Businterface | 1 x D-Sub-Buchse, 9-polig
Erweiterbares Prozessabbild | bis zu 3 virtuelle Slaves zusätzlich
max. Prozessabbild | 4 Slaves x (240 Byte In / 240 Byte Out)
Protokoll |
PROFIBUS-DP Slave | Ja
PROFIBUS-DP (virtueller Slave) | 4 (3 virtuelle PROFIBUS Nodes)
Funktionen/Dienste |
PROFIBUS | DP
DPV1 Klasse 1 | Ja
Diagnose/Status/Alarm |
RUN LED | Ja, grün/rot
BF LED | Ja, grün/rot
DIA LED | Ja, grün/rot


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Montage
•
Verdrahtung
•
UL-Hinweise
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX-Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Tragschienenmontage - Buskoppler


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Die folgenden Grafiken zeigen die Abmessungen der Buskoppler.
Zeichnungen im DWF- und STEP-Format finden Sie im Download-Bereich der Beckhoff-Website.
Abmessungen am Beispiel EK9300.


Tragschienenmontage - Buskoppler

Montage und Verdrahtung [image] Montage [image] Tragschienenmontage - Buskoppler
Tragschienenmontage - Buskoppler
Aufrasten auf die Tragschiene
Der Buskoppler kann einfach auf die Tragschiene aufgerastet werden. Dazu wird der Block frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Dies wird durch ein vernehmliches Klicken angezeigt. Mit einem Schraubendreher wird dann die Arretierung auf der linken Seite nach oben gedrückt wodurch sich die Arretierung dreht und ebenfalls hörbar einrastet.
Aufrasten auf die Tragschiene am Beispiel EK9300.
Hinweis
Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!
Einbaulagen
Die Einbaulage des Buskopplers ist beliebig.
Hinweis
Einbaulagen von EtherCAT-Klemmen
Beachten Sie die Einbaulage der eingesetzten EtherCAT Klemmen, nicht alle haben eine beliebige Einbaulage. Achten Sie auf die jeweiligen EtherCAT-Infrastrukturkomponenten und Installationshinweise.
Empfohlene Abstände bei Standard Einbaulage am Beispiel EK9300.
Hinweis
Zulässige Einbaulage und Mindestabstände einhalten!
Wir empfehlen den Einbau in horizontaler Ausrichtung für eine optimale Durchlüftung, des Weiteren erübrigt sich bei dieser Einbaulage das Überprüfen ob Klemmen dabei sind, die nur horizontal verbaut werden dürfen.
Weitere Einbaulagen sind erlaubt aber werden nicht empfohlen.
Weitere Einbaulagen am Beispiel EK9300.


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Spannungsversorgung
•
PROFIBUS-Schnittstelle (X001)
•
Verkabelung
•
Topologie


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
Versorgung von Buskoppler und Busklemmen (Us)
Der Buskoppler benötigt zum Betrieb eine Versorgungsspannung von 24 VDC (-15%/+20%).
Der Anschluss erfolgt über die beiden oberen Klemmstellen mit der Bezeichnung 24 V und 0 V. Diese Einspeisung versorgt die Elektronik des Buskopplers sowie über den E-Bus die Elektronik der EtherCAT-Klemmen. Sie ist galvanisch von der Peripherieversorgung (Up) der Powerkontakte getrennt.
Um in allen Fällen den Betrieb des Buskopplers und des Klemmenstrangs zu gewährleisten, muss das Netzteil 2 A bei 24 V liefern.
Spannungsversorgung Buskoppler am Beispiel EK9300.
Versorgung der Powerkontakte (Up)
An der rechten Seitenfläche des Buskopplers befinden sich die drei Federkontakte der Powerkontakte. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden deren Messerkontakte mit den Federkontakten des Buskopplers verbunden. Die Nut/Federführung an der Ober- und Unterseite der Busklemmen Controller und Busklemmen garantiert eine sichere Führung der Powerkontakte.
Die unteren sechs Klemmstellen mit den Bezeichnungen +, - und PE dienen zur Einspeisung der Peripherieversorgung (Up). Diese Klemmstellen sind jeweils paarweise mit einem Powerkontakt verbunden. Die Einspeisung lässt Spannungen bis zu 24 V zu und ist galvanisch von der Versorgungsspannung des Buskopplers (Us) getrennt.
Die paarweise Verbindung dieser Klemmstellen ermöglicht das Weiterführen der Versorgung. Die Strombelastung der Powerkontakte darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Klemmstellen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Die Klemmstellen in Federkrafttechnik sind für Drähte von 0,08 mm² bis 2,5 mm² Querschnitt ausgelegt.
LED
Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün. Die linke LED (Us) zeigt die Versorgung für die Elektronik des Buskopplers an. Die rechte LED (Up) zeigt die Versorgung für die Powerkontakte an. Die weiteren die LEDs zeigen den Status des E-Bus an. Die detaillierte Bedeutung der LED-Anzeigen beschreibt das Kapitel LED-Anzeigen.
PE-Powerkontakte
Hinweis
Powerkontakt PE
Der Powerkontakt PE darf nicht für andere Potenziale verwendet werden.


PROFIBUS-Schnittstelle (X001)

Montage und Verdrahtung [image] Verdrahtung [image] PROFIBUS-Schnittstelle (X001)
PROFIBUS-Schnittstelle (X001)
PROFIBUS, neunpoliger D-Sub
Pin 6 überträgt 5 VDC und Pin 5 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen benutzt werden, da dies zu Zerstörung des Gerätes führen kann.
Pin 3 und Pin 8 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist.
PROFIBUS, Pin-Belegung D-Sub
Die Profibus Busleitung wird über einen 9poligen D-Sub mit folgender Belegung angeschlossen:
Pin | Belegung
1 | Schirmung
2 | nicht benutzt
3 | RxD/TxD-P
4 | nicht benutzt
5 | GND
6 | +5VDC
7 | nicht benutzt
8 | RxD/TxD-N
9 | nicht benutzt
Leitungsfarben
PROFIBUS Leitung | D-Sub
B rot | Pin 3
A grün | Pin 8


Verkabelung

Montage und Verdrahtung [image] Verdrahtung [image] Verkabelung
Verkabelung
Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert (siehe PROFIBUS Schicht 1: Physical Layer).
Der Einsatzbereich eines Feldbus-Systems wird wesentlich durch die Wahl des Übertragungs-Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.
Kabelgebundene Übertragung:
Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.
Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung (siehe Tabelle RS485).
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 125 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis zu 10 km vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen.
Übertragungsgeschwindigkeit (in Stufen einstellbar) | 9,6 kBit/s; 19,2 kBit/s; 93,75 kBit/s; 187,5 kBit/s; 500 kBit/s; 1500 kBit/s; 12 MBit/s
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67
Kabelbedingte Störungen
Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung des normalen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Zum Beispiel bekommt eine angeschlossene PROFIBUS-Station keine Verbindung, kann diese aber nach Abziehen der benachbarten Station wieder aufnehmen. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, dass der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Eine Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.
Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt häufig ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder Abschlusswiderstände sind nicht oder an falschen Stellen aktiviert.
Vorkonfektionierte Kabel von BECKHOFF
Mit den vorkonfektionierten Kabeln von BECKHOFF vereinfacht sich die Installation erheblich! Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das BECKHOFF-Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch Feldkonfektionierbare Stecker und Kabel erhältlich.

Die folgende Abbildung zeigt die Verkabelung zwischen zwei Stationen und wie die D-Sub-Anschlüsse belegt sind:
Profibus Verkabelung
Abschlusswiderstände
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das Buskabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.
Längenausdehnung
Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.
Baud-Rate in kBits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Leitungslänge in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100
Stichleitungen bis 1500 kBaud <6,6 m, bei 12 MBaud sollten keine Stichleitungen verwendet werden.
Bussegment
Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem PROFIBUS-Netzwerk sind 125 Teilnehmer erlaubt. Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen. Dabei wird jeder Repeater wie ein Teilnehmer angesehen.
IP-Link ist das Sub-Bussystem der Feldbus Boxen dessen Topologie eine Ringstruktur ist. In den Koppler Modulen (IP230x-Bxxx oder IP230x-Cxxx) befindet sich ein IP-Link Master, an den bis zu 120 Erweiterungsmodule (IExxxx) angeschlossen werden dürfen. Der Abstand zwischen zwei Modulen darf dabei 5 m nicht überschreiten. Achten Sie bei der Planung und Installation der Module, dass aufgrund der Ringstruktur das letzte Modul wieder am IP-Link Master angeschlossen werden muss.
Einbaurichtlinie
Beachten Sie bei der Montage der Module und beim Verlegen der Leitung die technischen Richtlinien der PROFIBUS-Nutzerorganisation e.V. zu PROFIBUS-DP/FMS (siehe: www.profibus.de).
PROFIBUS Kabel überprüfen
Ein PROFIBUS-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:
1.
Widerstand zwischen A und B am Anfang der Leitung: ca. 110 Ohm
2.
Widerstand zwischen A und B am Ende der Leitung: ca. 110 Ohm
3.
Widerstand zwischen A am Anfang und A am Ende der Leitung: ca. 0 Ohm
4.
Widerstand zwischen B am Anfang und B am Ende der Leitung: ca. 0 Ohm
5.
Widerstand zwischen Schirm am Anfang und Schirm am Ende der Leitung: ca. 0 Ohm
Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen. Beachten Sie die Installationshinweise der PROFIBUS-Nutzer-Organisation (www.profibus.com).


Topologie

Montage und Verdrahtung [image] Verdrahtung [image] Topologie
Topologie
▪
Ein Bussegment darf aus maximal 32 Teilnehmern bestehen (einschließlich den Repeatern).
▪
Die maximale Leitungslänge eines Segmentes ist abhängig von der verwendeten Übertragungsgeschwindigkeit und der Qualität der verwendeten Busleitung.
▪
Zwischen zwei Teilnehmer dürfen maximal 9 Repeater installiert werden.
▪
Stichleitungen sind zu vermeiden und ab 1,5 MBaud nicht zulässig.
▪
Maximale Anzahl an Teilnehmern 125
▪
Unterbrechung der Versorgungsspannungen von Leitungsabschlüssen durch abschalten des Repeaters/Slave oder abziehen des Steckers ist nicht zulässig.
PROFIBUS Topologie mit dem Buskoppler EK3100.


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Versionsidentifikation von EtherCAT-Geräten

Montage und Verdrahtung [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
USB-Schnittstelle
•
Adresswahlschalter
•
2-poliger DIP-Schalter
•
IP-Adresse (via USB-Schnittstelle)


USB-Schnittstelle

Parametrierung und Inbetriebnahme [image] USB-Schnittstelle
USB-Schnittstelle
Die USB-Schnittstelle vom Typ-B befindet sich hinter Frontklappe des Buskopplers EK3100. Über die USB-Schnittstelle kann der interne Flash-Speicher erreicht werden und dadurch z.B. das Image aktualisiert werden.
USB-Schnittstelle des Buskopplers EK3100.
Die USB-Schnittstelle kann nur dann eingesetzt werden, wenn der 2-polige DIP-Schalter entsprechend gesetzt wurde (siehe: 2-poliger DIP-Schalter).


Adresswahlschalter

Parametrierung und Inbetriebnahme [image] Adresswahlschalter
Adresswahlschalter
Der Buskoppler EK3100 verfügt über zwei 10-polige Adresswahlschalter. Mit den Adresswahlschaltern kann die Profibus-Adresse eingestellt werden.
Adresswahlschalter des EK3100.
Einstellungen:
▪
S001 für Adresse x 1
▪
S002 für Adresse x 10
Beispiel: Wenn die Schalter auf S001 = 2 und S002 = 1 eingestellt werden, ergibt das die Adresse = 12.
Damit die eingestellte Adresse über die zwei Adresswahlschalter in TwinCAT verwendet wird, muss die Andresse auch in TwinCAT eingetragen werden.


2-poliger DIP-Schalter

Parametrierung und Inbetriebnahme [image] 2-poliger DIP-Schalter
2-poliger DIP-Schalter
Der Buskoppler EK3100 hat unter der Frontklappe einen 2-poligen DIP-Schalter.
2-poliger DIP-Schalter des EK3100.
Mögliche Einstellungen des 2-poligen DIP-Schalters.
DIP-Schalter (rot), on = rechts | Bedeutung
1 off und 2 off | normaler Modus, Koppler wird gestartet.
1 on und 2 off | Der Koppler startet im Config Mode. Über die USB-Schnittstelle ist der interne Flash-Speicher zu erreichen (zum Beispiel für ein Image-Update).
1 off und 2 on | Werkseinstellungen.
1 on und 2 on | Bislang keine Funktion.


IP-Adresse (via USB-Schnittstelle)

Parametrierung und Inbetriebnahme [image] IP-Adresse (via USB-Schnittstelle)
IP-Adresse (via USB-Schnittstelle)
Mit der IP-Adresse ist es möglich über einen Host-PC auf den Buskoppler EK3100 zuzugreifen. Um auf den Buskoppler EK3100 zugreifen zu können, muss zuerst der passende USB-Treiber auf dem Host-PC installiert werden (siehe: USB-Treiber installieren).
Anschließend kann auf dem Host-PC ein gewöhnlicher Webbrowser verwendet und der Beckhoff Device Manager gestartet werden (siehe: Beckhoff Device Manager).
Der EK3100 hat folgende feste Netzwerkeinstellungen:
▪
IP-Adresse: 172.21.42.1
▪
Subnetz-Maske: 255.255.255.0
Überprüfen Sie, ob die IP-Adresse des Buskopplers EK3100 an andere Geräte im lokalen Netzwerk vergeben wurde oder von ihrem Host-PC verwendet wird. Ist dies der Fall, müssen Sie die IP-Adressen der Geräte ändern oder die Geräte deaktivieren.


Konfiguration

Konfiguration
Konfiguration
EtherCAT-Klemmen konfigurieren
Da der PROFIBUS gewissen Einschränkungen unterliegt, können EtherCAT-Klemmen nicht über die GSD-Datei konfiguriert werden. Es gibt EtherCAT-Klemmen, die alleine schon durch die Anzahl der Konfigurationsdaten die maximale Datenlänge überschreiten würden.
Es wurde bewusst auf eine Konfiguration über die GSD-Datei verzichtet und die EtherCAT-Klemmen werden stattdessen wie folgt konfiguriert:
▪
Über das Webinterface (siehe: Beckhoff Device Manager),
▪
Oder über die PROFIBUS DPV1-Dienste (siehe Beispielprogramm für eine TwinCAT-Steuerung: ).
Prozessabbild (Mapping) der EtherCAT-Klemmen konfigurieren
Das Prozessabbild (Mapping) einer EtherCAT-Klemme wird weiterhin über die GSD-Datei konfiguriert. Wenn eine EtherCAT-Klemme unterschiedliche Mappings hat, dann wird dieses Mapping durch die Auswahl des entsprechenden Moduls in der GSD-Datei automatisch eingestellt. Wenn Sie z.B. EtherCAT-Klemmen in TwinCAT einfügen, können Sie zwischen den zur Verfügung stehenden Mappings auswählen.
Die GSD-Datei des Buskopplers EK3100 muss in das TwinCAT-Verzeichnis kopiert werden:
▪
TwinCAT 2: C:\TwinCAT\Io\Profibus
▪
TwinCAT 3: C:\TwinCAT\3.1\Config\Io\Profibus
Oder: Die GSD-Datei des Buskopplers EK3100 kann nachträglich in TwinCAT installiert werden, sobald der Buskoppler in TwinCAT eingefügt wird (siehe: Buskoppler EK3100 in TwinCAT einfügen). Eine entsprechende Abfrage erscheint in TwinCAT, in der Sie aufgefordert werden die GSD-Datei zu installieren.
Wichtige Dateien für die Konfiguration
GSD-Datei, USB-Treiber und Beispielprogramm für den Buskoppler EK3100.
Datei
Downloadlink
GSD-Datei
USB-Treiber
Beispielprogramm
Weiterführende Informationen
•
EtherCAT-Konfigurationen
•
Beckhoff Device Manager
•
In TwinCAT3 konfigurieren
•
Mit DPV1-Diensten auf COE-Daten zugreifen


EtherCAT-Konfigurationen

Konfiguration [image] EtherCAT-Konfigurationen
EtherCAT-Konfigurationen
Der EK3100 ist ein EtherCAT-Master mit automatischer Konfiguration. D.h. es müssen beim Einschalten des Systems immer alle EtherCAT-Klemmen vorhanden sein. Da in der Regel das Booten des EK3100 wesentlich länger dauert als das Starten der EtherCAT-Slave-Geräte, können diese an der gleichen Spannungsversorgung betrieben werden. Bei dezentralen EtherCAT-Slaves ist darauf zu achten, dass die früher oder zur gleichen Zeit mit der Versorgungsspannung eingeschaltet werden.
EtherCAT-Teilnehmer während der Laufzeit ein- bzw. ausschalten
Sollte während der Betriebsphase ein oder mehrere EtherCAT-Teilnehmer ausfallen wird eine Fehlerantwort beim PROFIBUS generiert. Die Eingangsdaten aller EtherCAT-Teilnehmer sind dann ungültig, die Ausgangsdaten werden nicht mehr übernommen. Das gilt auch für die Teilnehmer, die noch am EK3100 im Betrieb sind. Möchte man die Möglichkeit nutzen während der Laufzeit Teilnehmer an und ab zu stecken, muss eine weitere "Sync Unit" konfiguriert werden. Dies ist mit einem EK3100 nicht möglich. Verwenden Sie in dem Fall einen CX803x.
EtherCAT-Topologie
Alle EtherCAT-Teilnehmer müssen in der Reihenfolge eingetragen werden, wie sich diese am EK3100 und damit am EtherCAT-Master mappen. EtherCAT-Teilnehmer werden automatisch adressiert, bis auf wenige Ausnahmen sind alle EtherCAT-Busklemmen mit einem EtherCAT ASIC ausgestattet. EtherCAT-Klemmen ohne ASIC sind zum Beispiel EL9400, EL9070 und weitere EL9xxx. Sie können diese EtherCAT-Klemmen anhand der Technischen Daten "Meldung an E-Bus" erkennen. Steht hier dann ein "-" muss diese Klemme für das Mapping nicht berücksichtigt werden.
EtherCAT-Geräte werden in Richtung des EtherCAT Telegrams eingetragen.
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Koppler EK1100
Beispielkonfiguration mit EtherCAT-Boxen EPxxxx
Beispielkonfiguration mit EtherCAT-Boxen EPxxxx
Beispielkonfiguration mit EK1122 (2-Port-EtherCAT-Abzweig in Schutzart IP20)
Beachten Sie bei dem Einsatz eines EK1122 die Zählrichtung!
Ist am EK1122 der EtherCAT-Abzweig 1 angeschlossen, so wird hier der EtherCAT-Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem E-Bus auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EK1122 (2-Port-EtherCAT-Abzweig in Schutzart IP20)
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi überbrückt und der EtherCAT-Frame geht direkt aus dem E-Bus auf der rechten Seite weiter.
Beispielkonfiguration mit EP1122 (2-Port-EtherCAT-Abzweig in Schutzart IP65)
Beachten Sie bei dem Einsatz eines EP1122 die Zählrichtung! Sie ist vergleichbar mit dem EK1122.
Ist am EP1122 der EtherCAT-Abzweig 1 angeschlossen, so wird hier der EtherCAT-Frame als erstes hier weiter geschickt (1), ist der Abzweig 1 nicht angeschlossen wird der Frame auf Abzweig 2 verschickt (2), erst danach wird mit dem EtherCAT-Anschluss auf der rechten Seite fortgefahren (3).
Beispielkonfiguration mit EP1122 (2-Port-EtherCAT-Abzweig in Schutzart IP65)
Werden beide Abzweige nicht genutzt, so werden Abzweig 1 und 2 quasi überbrückt und der EtherCAT-Frame geht direkt aus dem EtherCAT-Anschluss auf der rechten Seite weiter.
Kein Hot Swap im laufenden Betrieb
An einem EKxxxx können Sie EP1122 und EK1122 nicht für Hot-Swap und auch nicht für "connect" und "disconnect" im laufenden Betrieb verwenden. EP1122 und EK1122 eigenen sich an einem EKxxxx nur zur Topologie Erweiterung (Stern).
Einschränkungen beachten
Beachten Sie folgende Einschränkungen wenn Sie den Buskoppler EK3100 zusammen mit EtherCAT-Teilnehmern einsetzen:
▪
Es werden nur EtherCAT-Teilnehmer von Beckhoff unterstützt. Wenn Sie EtherCAT-Teilnehmer von anderen Herstellern einsetzten wollen, verwenden Sie stattdessen den Embedded-PC CX8031.
▪
Der Buskoppler EK3100 unterstützt kein Hot-Plug. Alle EtherCAT-Teilnehmer müssen gesteckt sein und erst dann der Buskoppler gestartet werden. Die EtherCAT-Konfiguration darf nicht im laufenden Betrieb verändert werden. Eine Unterbrechung des EtherCAT erzeugt einen Fehler und die Daten sind ungültig.
▪
Es wird nur eine Sync-Unit unterstützt.
▪
Der Buskoppler EK3100 unterstützt keine Distributed-Clocks. EtherCAT-Teilnehmer die Distributed-Clocks benötigen, können nicht verwendet werden.
▪
Verwenden Sie nur EtherCAT-Teilnehmer von Beckhoff, die in der GSD-Datei gelistet sind.
▪
Gateway-Klemmen werden nicht unterstützt. Dazu zählen auch ASI- und IO-Link-Klemmen. Wenn Sie Gateway-Klemmen einsetzen wollen, verwenden Sie stattdessen den Embedded-PC CX8031.
▪
Die EtherCAT K-Bus Koppler wie z.B. der BK11x0 oder BK1250 werden nicht unterstützt


Beckhoff Device Manager

Konfiguration [image] Beckhoff Device Manager
Beckhoff Device Manager
Weiterführende Informationen
•
USB-Treiber installieren
•
Beckhoff Device Manager starten
•
Mappings für EtherCAT-Klemmen einstellen
•
EtherCAT-Klemmen konfigurieren
•
Restore-File einsetzen


USB-Treiber installieren

Konfiguration [image] Beckhoff Device Manager [image] USB-Treiber installieren
USB-Treiber installieren
Belegte IP-Adresse
Der USB-Treiber wird nicht vollständig installiert, wenn die IP-Adresse 172.21.42.15 auf dem Host-PC bereits belegt ist.
Überprüfen Sie unter Eingabeaufforderung > ipconfig ob die IP-Adresse belegt ist. Ändern Sie zuerst die IP-Adresse wenn sie belegt ist.
Um auf den Beckhoff Device Manager des Buskopplers EK3100 zugreifen zu können, muss zuerst der passende USB-Treiber auf dem Host-PC installiert werden.
Nach erfolgreicher Installation simuliert der Treiber eine zusätzliche lokale Ethernet-Schnittstelle auf dem Host-PC mit der festen IP-Adresse: 172.21.42.15 und Subnetz-Maske: 255.255.255.0
Voraussetzungen:
▪
Die IP-Adresse 172.21.42.15 wird nicht bereits auf dem Host-PC verwendet.
▪
USB-Treiber für den Host-PC:
Installieren Sie den USB-Treiber wie folgt:
1.
Verbinden Sie den Buskoppler EK3100 per USB-Kabel mit einem Host-PC und starten Sie den Buskoppler.
Das Gerät Beckhoff Automation GmbH EK-Series USB erscheint im Geräte-Manager des Host-PCs.
2.
Klicken Sie auf Beckhoff Automation GmbH EK Series USB und dann auf Treibersoftware aktualisieren.
3.
Geben Sie den richtigen Dateipfad an und installieren Sie den Treiber auf dem Host-PC.
⇨
Sie haben den USB-Treiber erfolgreich installiert, wenn die zusätzliche Ethernet-Schnittstelle Beckhoff Automation GmbH EK9XXX Series USB RNDIS6 im Geräte-Manager erscheint.

Im nächsten Schritt können den Beckhoff Device Manager starten.


Beckhoff Device Manager starten

Konfiguration [image] Beckhoff Device Manager [image] Beckhoff Device Manager starten
Beckhoff Device Manager starten
Mit dem Beckhoff Device Manager können EtherCAT-Klemmen, die am Buskoppler angeschlossen sind, konfiguriert werden. Zusätzlich kann der Beckhoff Device Manager für Diagnosezwecke des Buskopplers und der EtherCAT-Klemmen genutzt werden.
Der Beckhoff Device Manager wird über einen Webbrowser auf einem Host-PC gestartet. Der Zugang zum Beckhoff Device Manager des Buskopplers EK3100 ist geschützt.
Zugangsdaten zum Beckhoff Device Manager.
URL | Zugangsdaten
172.21.42.1/config | Benutzername: guest Passwort: 1
Voraussetzungen:
▪
Host-PC und der Buskoppler EK3100 sind per USB-Kabel miteinander verbunden.
▪
USB-Treiber installiert auf dem Host-PC (siehe: USB-Treiber installieren).
Starten Sie den Beckhoff Device Manager wie folgt:
1.
Tippen Sie auf dem Host-PC im Webbrowser die IP-Adresse des Buskopplers ein, um den Beckhoff Device Manager zu starten.
Beispiel mit IP-Adresse: http://172.21.42.1/config
2.
Tippen Sie im Fenster Authentifizierung den Benutzernamen und das Passwort ein.
Die Startseite erscheint.

⇨
Navigieren Sie weiter im Menü und konfigurieren Sie Ihre Hardwarekonfiguration. Beachten Sie, dass Änderungen erst nach einer Bestätigung oder nach dem Neustart des Buskopplers EK3100 wirksam werden.


Mappings für EtherCAT-Klemmen einstellen

Konfiguration [image] Beckhoff Device Manager [image] Mappings für EtherCAT-Klemmen einstellen
Mappings für EtherCAT-Klemmen einstellen
Mapping
Beachten Sie, dass die Einstellungen für das Mapping in TwinCAT (GSD-Datei) immer Vorrang haben. Abweichende Einstellungen im Beckhoff Device Manager werden nicht beachtet oder werden überschrieben.
Im Beckhoff Device Manager können Sie das Mapping für eine EtherCAT-Klemme einstellen, wenn diese EtherCAT-Klemme unterschiedliche Mappings unterstützt. Bei der analogen EtherCAT-Klemme EL3062 können Sie beispielsweise zwischen dem Standard-Mapping und Compact-Mapping wählen. Die Auswahl hat Auswirkungen auf die Größe und damit auf die Art der Daten die als Prozessdaten zur Verfügung stehen (siehe GSD-Datei).
Voraussetzungen:
▪
Eine EtherCAT-Klemme, die unterschiedliche Mappings unterstützt.
▪
Der Beckhoff Device Manager wurde bereits gestartet (siehe: Beckhoff Device Manager starten).
Stellen Sie das Mapping für eine EtherCAT-Klemme wie folgt ein:
1.
Klicken Sie auf EtherCAT und anschließend auf Master.
EK3100_EtherCAT Slave Mappings
2.
Unter EtherCAT Slave Mappings werden alle EtherCAT-Klemmen angezeigt, die andere Mappings unterstützen.
3.
Klicken Sie unter EtherCAT Slave Mappings doppelt auf die EtherCAT-Klemme EL3062 und wählen Sie zwischen dem Mapping Standard oder Compact.
EK3100_EtherCAT Slave Mappings2
⇨
Sie haben erfolgreich das Mapping für die EtherCAT-Klemme EL3062 eingestellt. Starten Sie den Buskoppler EK3100 neu, damit die Einstellungen nach dem Neustart wirksam werden.
Beispiel zu Prozessdaten (Mapping)
Beschreibung der Prozessdaten
Weiterführende Informationen zu den Prozessdaten (Mapping) finden Sie zu jeder EtherCAT-Klemme in der dazugehörigen Dokumentation. Beispielsweise für die EL3062 unter: Inbetriebnahme > Prozessdaten und Betriebsmodi > Prozessdaten.
Die bereits erwähnte EtherCAT-Klemme EL3062 bietet pro Analogkanal zwei verschiedene Prozessdaten zur Übertragung an. Den Analogwert Value (16 Bit) und Statusinformationen Status (16 Bit). Für beide Analogkanäle sind es also insgesamt 64 Bit bzw. 8 Byte.
Zwei Prozessdatenarten stehen bei der EL3062 zur Auswahl:
▪
Standard: Standardeinstellung, je Kanal werden Value (16 Bit) und Statusinformationen (8 bzw.16 Bit) übertragen.
▪
Compact: Je Kanal wird nur der Value (16 Bit) übertragen.
Um die Beschreibung der einzelnen Bits zu erhalten, fügen Sie die EtherCAT-Klemme unabhängig von Ihrer PROFIBUS-Konfiguration in TwinCAT ein oder lesen Sie die jeweilige Dokumentation
Bedeutung der einzelnen Bits mit allen Untervariablen und Strukturinhalten bei der EL3062.
Status-Wort
Das Status-Wort (SW) befindet sich im Eingangsprozessabbild und wird von der Klemme zur Steuerung übertragen.
Bit | SW.15 | SW.14 | SW.13 | SW.12 | SW.11 | SW.10 | SW.9 | SW.8
Name | TxPDO Toggle | TxPDO State | - | - | - | - | - | -
Bit | SW.7 | SW.6 | SW.5 | SW.4 | SW.3 | SW.2 | SW.1 | SW.0
Name | - | ERROR | Limit 2 |  | Limit 1 |  | Over-range | Under-range


EtherCAT-Klemmen konfigurieren

Konfiguration [image] Beckhoff Device Manager [image] EtherCAT-Klemmen konfigurieren
EtherCAT-Klemmen konfigurieren
In diesem Kapitel wird beispielhaft an der EtherCAT-Klemme EL3062 gezeigt, wie Sie mit dem Beckhoff Device Manager EtherCAT-Klemmen konfigurieren.
Weiterführende Informationen zu den Parametern und deren Bedeutung finden Sie zu jeder EtherCAT-Klemme in der dazugehörigen Dokumentation. Beispielsweise für die EL3062 unter: Inbetriebnahme > Objektbeschreibung und Parametrierung > Konfigurationsdaten.
Voraussetzungen:
▪
Der Beckhoff Device Manager wurde bereits gestartet (siehe: Beckhoff Device Manager starten).
Konfigurieren Sie EtherCAT-Klemmen wie folgt:
1.
Klicken Sie auf EtherCAT und anschließend auf Master.
2.
Klicken Sie auf eine EtherCAT-Klemme, die Sie konfigurieren möchten.
Die Parameter der EtherCAT-Klemme werden angezeigt.
3.
Unter Parameter können Sie die Werte für die EtherCAT-Klemme verändern.

⇨
Die Einstellungen werden in der EtherCAT-Klemme gespeichert. Beachten Sie, dass die Einstellungen verloren gehen, sobald Sie die EtherCAT-Klemme gegen eine neue tauschen.
Nutzen Sie in diesem Fall das Restore-File und speichern Sie die Einstellungen im Restore-File (siehe: Restore-File einsetzen).


Restore-File einsetzen

Konfiguration [image] Beckhoff Device Manager [image] Restore-File einsetzen
Restore-File einsetzen
Restore-Files werden im Beckhoff Device Manager dafür eingesetzt, um bereits gemachte Konfigurationen und Einstellungen einer EtherCAT-Klemme zu speichern.
In der Regel gehen die Einstellungen einer EtherCAT-Klemme verloren, wenn sie ausgetauscht wird. Wenn aber ein Restore-File erstellet wurde, können die Parameter beim Starten des Buskopplers wieder auf eine neue EtherCAT-Klemme kopiert werden.
Voraussetzungen:
▪
Der Beckhoff Device Manager wurde bereits gestartet (siehe: Beckhoff Device Manager starten).
Setzen Sie Restore-Files wie folgt ein:
1.
Klicken Sie auf EtherCAT und anschließend auf Master.
2.
Unter EtherCAT Slaves werden alle EtherCAT-Klemmen angezeigt, bei denen ein Restore-File angelegt werden kann.
3.
Unter der Option Restore State wird angezeigt, ob ein Restore-File für eine EtherCAT-Klemme angelegt wurde.

EMPTY: Es wurde kein Restore-File angelegt.
VALID: Ein gültiges Restore-File wurde angelegt.
MAPPING: Das Mapping wurde umgestellt und ist noch nicht im Restore-File abgelegt.
4.
Unter Configuration Management können Sie einstellen, ob Sie ein Restore-File erstellen, löschen, speichern oder ein gespeichertes Restore-File wiederherstellen möchten.

⇨
Beachten Sie, dass die Einstellungen aus einem Restore-File erst bei einem Neustart des Buskopplers auf die neue EtherCAT-Klemme kopiert werden.


In TwinCAT3 konfigurieren

Konfiguration [image] In TwinCAT3 konfigurieren
In TwinCAT3 konfigurieren
Weiterführende Informationen
•
Buskoppler EK3100 in TwinCAT einfügen
•
CtrlStatus DWORD verwenden
•
EtherCAT-Klemmen einfügen
•
Virtuelle Slaves anlegen
•
Digitale Signale packen


Buskoppler EK3100 in TwinCAT einfügen

Konfiguration [image] In TwinCAT3 konfigurieren [image] Buskoppler EK3100 in TwinCAT einfügen
Buskoppler EK3100 in TwinCAT einfügen
Der Buskoppler EK3100 wird in TwinCAT unter einem PROFIBUS-Master eingefügt. In diesem Arbeitsschritt wird dafür beispielsweise der Embedded-PC CX2020 mit einem PROFIBUS-Feldbusmodul CX2500-M310 verwendet.
Der Buskoppler EK3100 benötigt die passende GSD-Datei für TwinCAT. Es gibt zwei Möglichkeiten. Die GSD-Datei kann in das TwinCAT-Verzeichnis kopiert werden oder nachträglich in TwinCAT eingefügt werden. In diesem Arbeitsschritt wird die GSD-Datei nachträglich in TwinCAT eingefügt.
Voraussetzungen:
▪
GSD-Datei für den Buskoppler EK3100:
▪
Der PROFIBUS-Master wurde in TwinCAT als Zielsystem ausgewählt und eingefügt.
Fügen Sie den Buskoppler EK3100 wie folgt in TwinCAT ein.
1.
Klicken Sie links in der Strukturansicht mit der rechten Maustaste auf den PROFIBUS-Master Device 1 (CX2500-M310).
2.
Klicken Sie im Kontextmenü auf Add New Item.

3.
Klicken Sie auf Miscellaneous und dann auf Generic Profibus Box (GSD).

Das Fenster Öffnen erscheint.
4.
Suchen Sie in ihrem Dateiverzeichnis nach der GSD-Datei aus dem Zip-Archiv und wählen die Datei EK3100DAA.gsd des Buskopplers EK3100.
Die Box 1 (GSD Box) (EK3100) erscheint unter dem PROFIBUS-Master.
5.
Klicken Sie auf die Registerkarte Profibus und geben unter Station No. die Profibus-Adresse ein. Die Adresse darf sich nicht von der Adresse unterscheiden, die mit den Adresswahlschaltern eingestellt wurde.
⇨
Sie haben den Buskoppler EK3100 und die passende GSD-Datei erfolgreich in TwinCAT eingefügt. Unter Box 1 (GSD Box) (EK3100) wird automatisch das CtrlStatus DWORD-Modul eingefügt.

Im nächsten Schritt können Sie EtherCAT-Klemmen entsprechend Ihrer Hardwarekonfiguration in TwinCAT einfügen.


CtrlStatus DWORD verwenden

Konfiguration [image] In TwinCAT3 konfigurieren [image] CtrlStatus DWORD verwenden
CtrlStatus DWORD verwenden
Wenn der Buskoppler EK3100 in TwinCAT eingefügt wird, wird auch automatisch das CtrlStatus DWORD-Modul eingefügt. Das CtrlStatus DWORD (4 Byte) hat folgende Bedeutung:
Input CtrlStatus DWORD
Aufbau und Bedeutung des Input CtrlStatus DWORD-Moduls.
Byte 3 | Byte 2 | Byte 1 | Byte 0
Reserve | Diag | Counter High Byte | Counter Low Byte
Counter WORD (2 Byte):
Der Zähler ist ein E-Bus Zähler und wird bei jedem E-Bus Telegramm inkrementiert. Standardmäßig läuft der E-Bus mit 1 ms. Damit wird der Counter jede ms inkrementiert. Ist im Diag-Byte das Bit 2 gesetzt, so sind statt des Counters weitergehende Informationen über den Fehler enthalten.
DIAG BYTE (1 Byte):
0x10 E-Bus nach Fehler behoben. Ausgänge sind deaktiviert und müssen manuell durch das Control DWORD zurückgesetzt werden.
0x04 E-Bus Fehler liegt vor. Bei einem E-Bus Fehler tauscht der Buskoppler EK3100 weiterhin Daten mit dem PROFIBUS-Master aus. Die Eingangsdaten sind aber ungültig. Die Fehlerursache ist im High-Byte und die Position im Low-Byte des Counters kodiert.
Byte 1, Error-Code-Zähler | Byte 0, Zähler | Bedeutung
1 | Klemmenposition | Falsches Modul.
2 |  | Fehlendes Modul.
3 |  | Modul gezogen.
4 |  | Falsches Modul gesteckt.
5 |  | EtherCAT-Slave nicht in OP.
6 |  | State-Change abgebrochen.
7 |  | Abnormal State-Change.
8 |  | SDO-Abort
9 |  | Falsche SDO-Länge
10 |  | Falsche SDO-Daten.
Beispiel:
Byte 1 0x03 Unterbrechung des E-Bus, Byte 0 Position der Unterbrechung.
Output CtrlStatus DWORD
Aufbau und Bedeutung des Output CtrlStatus DWORD-Moduls.
Byte 3 | Byte 2 | Byte 1 | Byte 0
Reserve | Reserve | Reserve | Control Byte
Control Byte (Bit 0):
Ist im DIAG BYTE das Bit 4 gesetzt (0x10), dann kann von der Steuerung der Fehler quittiert werden. Dafür muss das Bit 0 (im ersten Byte des Control DWORD) auf „TRUE“ gesetzt werden und mit fallender Flanke des Bit 0 wird der E-BUS wieder gestartet. Die Ausgangsprozessdaten sind sofort wieder aktiv.


EtherCAT-Klemmen einfügen

Konfiguration [image] In TwinCAT3 konfigurieren [image] EtherCAT-Klemmen einfügen
EtherCAT-Klemmen einfügen
Beachten Sie die Reihenfolge der EtherCAT-Klemmen in TwinCAT. Die EtherCAT-Klemmen müssen in der gleichen Reihenfolge in TwinCAT einfügt werden wie diese auch gesteckt sind bzw. vom EtherCAT-Master (Buskoppler EK3100) adressiert werden.
Einige EtherCAT-Klemmen müssen nicht in TwinCAT eingefügt werden.
▪
EtherCAT-Klemmen die nicht im EtherCAT-Master (Buskoppler EK3100) sichtbar sind, müssen nicht eingetragen werden.
▪
Alle anderen EtherCAT-Klemmen, die im EtherCAT-Master (Buskoppler EK3100) sichtbar sind, müssen immer eingetragen werden. Dazu zählen auch EtherCAT-Klemmen ohne Prozessdaten.
EtherCAT Klemmen die sichtbar sind aber keine Prozessdaten besitzen:
Beispiel: EK1100, EK1110, …
EtherCAT Klemmen die nicht sichtbar sind und keine Prozessdaten besitzen. Diese Klemmen sind bei den technischen Daten durch ein „-“ unter „Meldung an E-Bus“ gekennzeichnet:
Beispiel: EL9011, EL9080, …
Voraussetzungen:
▪
Der Buskoppler wurde zusammen mit der dazugehörigen GSD-Datei in TwinCAT eingefügt
Fügen Sie EtherCAT-Klemmen wie folgt ein:
1.
Fügen Sie die erste EtherCAT-Klemme immer hinter dem CtrlStatus DWORD-Modul ein.
2.
Klicken Sie links in der Strukturansicht mit der rechten Maustaste auf Box 1 (GSD) (EK3100).

3.
Klicken Sie im Kontextmenü auf Add New Item.
Das Fenster Insert Module erscheint.
4.
Wählen Sie die entsprechende EtherCAT-Klemme in der richtigen Reihenfolge.
Beachten Sie, dass einige EtherCAT-Klemmen, abhängig vom verfügbaren Mapping, mehrfach aufgelistet werden.

Beispiel: Bei der analogen EtherCAT-Klemme EL3062 können Sie zwischen dem Standard-Mapping und Compact-Mapping wählen. Die Auswahl hat Auswirkungen auf die Größe und damit auf die Art der Daten die als Prozessdaten zur Verfügung stehen (siehe GSD-Datei).
⇨
Fügen Sie weitere EtherCAT-Klemmen in TwinCAT ein, bis Ihre Hardwarekonfiguration vollständig mit allen EtherCAT-Teilnehmern in TwinCAT abgebildet ist.


Virtuelle Slaves anlegen

Konfiguration [image] In TwinCAT3 konfigurieren [image] Virtuelle Slaves anlegen
Virtuelle Slaves anlegen
Bei dem Buskoppler EK3100 können bis zu drei virtuelle Slaves konfiguriert werden. Mit den virtuellen Slaves können mehr als die üblichen 244 Byte bei PROFIBUS übertragen werden. Die maximale Prozessdatengröße liegt bei 240 Byte Input und 240 Byte Output pro Slave.
Um die virtuellen Slaves nutzen zu können, müssen die EtherCAT-Klemmen hintereinander liegen und alle EtherCAT-Klemmen in den Slaves vorkommen. Zusätzlich ist es wichtig, dass in einem Slave sowohl Eingangs- als auch Ausgangsklemmen enthalten sind.
Standardmäßig ist nur der erste Slave aktiviert. Die virtuellen Slaves werden in der Konfiguration über die Parameterdaten aktiviert. Die Parameterdaten sowie das CtrlStatus DWORD haben nur beim ersten Slave die volle Funktion.
Die Adressierung ist fix und fängt bei der Adresse an, die der erste Slave per Adresswahlschalter verwendet. Ist die Adresse auf 11 eingestellt, dann sind die folgenden Adressen 12, 13 und 14 wenn alle 4 Slaves aktiv sind.
Beispiel einer Hardwarekonfiguration mit einem Slave.
EtherCAT-Teilnehmer, tatsächliche Hardwarekonfiguration
EK3100
CtrlStatus
EL1008
EL2008
EL3062
EK1110
EK1100
EL2008
EL1008
EL3154
EL9011
Aufteilung der EtherCAT-Teilnehmer in TwinCAT auf zwei Slaves.
Slave 1 |  |  |  |  |  | Slave 2 (virtueller Slave)
EK3100 | CtrlStatus | EL1008 | EL2008 | EL3062 | EK1110 | EK3100 | CtrlStatus | EK1100 | EL2008 | EL1008 | EL3154
PROFIBUS-Adresse: 11 |  |  |  |  |  | PROFIBUS-Adresse: 12. Die nicht sichtbare EL9011 entfällt.
Voraussetzungen
▪
Der Buskoppler EK3100 wurde bereits in TwinCAT eingefügt.
Legen Sie virtuelle Slaves wie folgt an:
1.
Klicken Sie links in der Strukturansicht doppelt auf Box 1 (GSD Box) (EK3100).

2.
Klicken Sie auf die Registerkarte PrmData (Text).
3.
Klicken Sie doppelt auf Aktivierte DP Slaves und wählen Sie die Anzahl der virtuellen Slaves aus.

4.
Fügen Sie unter dem bestehenden Buskoppler EK3100 einen weiteren Buskoppler EK3100 ein. Dieser Buskoppler ist der virtuelle Slave.
5.
Klicken Sie auf die Registerkarte Profibus und geben Sie unter Station No. die PROFIBUS-Adresse „12“ ein.
⇨
Fügen Sie alle EtherCAT-Klemmen nach dem Buskoppler EK3100 und dem virtuellen Salve ein. Orientieren Sie sich oben an der Tabelle.


Digitale Signale packen

Konfiguration [image] In TwinCAT3 konfigurieren [image] Digitale Signale packen
Digitale Signale packen
EtherCAT-Klemmen benötigen in der Regel immer 1 volles Byte für Prozessdaten. Auch für EtherCAT-Klemmen, die effektiv eine Prozessdatengröße von nur 2 oder 4 Bit haben, wird 1 volles Byte für Prozessdaten belegt.
Um 1 Byte vollständig auszufüllen, können die 2- oder 4-Kanal EtherCAT-Klemmen gepackt werden. Beachten Sie, dass diese EtherCAT-Klemmen hintereinander gesteckt sind und 1 Byte nicht überschritten wird.
Dafür gibt es in der GSD-Datei den Eintrag EL1xxx oder EL2xxx. Die EtherCAT-Klemmen, die gepackt werden sollen, haben den Eintrag EL1xxx (pack) bzw. EL2xxx (pack). Diese EtherCAT-Klemmen besitzen dann keine Daten. Die Daten werden an die vorherigen Klemmen im Byte angefügt.
Beispiel:
Drei EL1002 (jeweils 2-Kanäle) sind hintereinander gesteckt. In diesem Beispiel kann eine EL1xxx konfiguriert werden und zwei EL1xxx (pack).
Die Prozessdaten für diese EtherCAT-Klemmen sehen dann wie folgt aus:
1. EL1002: | x.0 und x.1
2. EL1002: | x.2 und x.3
3. EL1002: | x.4 und x.5
Voraussetzungen
▪
Die EtherCAT-Klemmen müssen hintereinander gesteckt sein.
Packen Sie digitale Signale wie folgt:
1.
Klicken Sie links in der Strukturansicht mit der rechten Maustaste auf Box 1 (GSD) (EK3100).
2.
Klicken Sie im Kontextmenü auf Add New Item.
Das Fenster Insert Module erscheint.

3.
Wählen Sie die Klemme EL1xxx.
Die EtherCAT-Klemme wird in TwinCAT eingefügt.
4.
Wählen Sie danach die Klemme EL1xxx (pack) und tragen Sie unter der Option Multiple den Wert „2“ ein.
⇨
Drei EL1002 EtherCAT-Klemmen wurden in TwinCAT eingefügt. Die Daten der beiden EL1xxx (pack) werden an die vorherige EtherCAT-Klemme im Byte angefügt.

In dem Beispiel kann eine weitere EL1002 angeschlossen werden um das Byte aufzufüllen. Es können auch andere 2-Kanal Eingangsklemmen verwendet werden. Dabei ist es wichtig, dass sie das gleiche Mapping haben. Es ist auch möglich 2-Kanal oder 4-Kanal EtherCAT-Klemmen zu mischen, solange 1 Byte nicht überschritten wird.


Mit DPV1-Diensten auf COE-Daten zugreifen

Konfiguration [image] Mit DPV1-Diensten auf COE-Daten zugreifen
Mit DPV1-Diensten auf COE-Daten zugreifen
Über DPV1 MSAC-C1-READ und DPV1 MSAC-C1-WRITE können Sie auf alle COE-Daten lesend und schreibend zugreifen. Die COE-Daten müssen den READ- und WRITE-Zugriff erlauben.
Der Zugriff erfolgt immer durch zwei DPV1-Telegramme. Das erste ist immer ein DPV1-WRITE-Telegramm. Das zweite ist ein DPV1-READ-Telegramm. Mit dem DPV1-WRITE-Telegramm wird bestimmt welche COE-Daten gelesen oder beschrieben werden sollen.
Verhalten bei einem Neustart des Buskopplers
Beachten Sie, dass die COE-Daten, die von Ihrer Steuerung verändert werden, bei einem Neustart des Buskopplers EK3100 erneut zur Klemme übertragen werden müssen.
▪
Daten Lesen: Beim Lesen wird ein DPV1-WRITE-Telegramm an den Buskoppler geschickt und teilt dem Buskoppler mit, welche Daten gelesen werden sollen. Mit dem zweiten DPV1-READ-Telegramm werden dann die Daten abgeholt.
▪
Daten Schreiben: Beim Schreiben werden die Daten mit den COE-Parametern übergeben und mit dem DPV1-READ-Telegramm wird die Quittung des COE-Write-Zugriffs übertragen. Diese Besteht aus 4 Byte. Sind diese Null, dann wurden die Daten fehlerfrei geschrieben. Sind diese <> 0, dann liegt ein Fehler vor.

Der Fehler entspricht einem ADS-Fehlercode. Entnehmen Sie die Bedeutung des ADS-Fehlercodes aus der TwinCAT Dokumentation (siehe: ADS-Fehlercodes).
Weiterführende Informationen
•
DPV1-Dienst aktivieren
•
Aufbau des DPV1-Telegramms beachten


DPV1-Dienst aktivieren

Konfiguration [image] Mit DPV1-Diensten auf COE-Daten zugreifen [image] DPV1-Dienst aktivieren
DPV1-Dienst aktivieren
Über DPV1 MSAC-C1-READ und DPV1 MSAC-C1-WRITE können Sie auf alle COE-Daten lesend und schreibend zugreifen. Die COE-Daten müssen den READ- und WRITE-Zugriff erlauben.
Um auf COE-Daten lesend und schreibend zuzugreifen, muss in den Parameterdaten des Buskopplers EK3100 der DPV1-Dienst auf dem Buskoppler EK3100 aktiv sein. In TwinCAT können Sie kontrollieren, ob der DPV1-Dienst aktiv ist bzw. den DPV1-Dienst aktivieren.
Voraussetzungen:
▪
Der Buskoppler wurde zusammen mit der dazugehörigen GSD-Datei in TwinCAT eingefügt.
Aktivieren Sie den DPV1-Dienst wie folgt:
1.
Klicken Sie links in der Strukturansicht doppelt auf Box 1 (GSD Box) (EK3100).

2.
Klicken Sie auf die Registerkarte PrmData (Text).
3.
Klicken Sie doppelt auf die Option DPV1-Dienste (Klasse 1) und aktivieren Sie den Dienst.

⇨
Sie haben den DPSV1-Dienst erfolgreich aktiviert. Bei virtuellen Slaves haben die Einstellungen in den Parameterdaten keine Bedeutung.
Im nächsten Schritt können Sie sich den Aufbau des DPV1-Telegramms anschauen.


Aufbau des DPV1-Telegramms beachten

Konfiguration [image] Mit DPV1-Diensten auf COE-Daten zugreifen [image] Aufbau des DPV1-Telegramms beachten
Aufbau des DPV1-Telegramms beachten
Aufbau des DPV1-Telegramms für Schreib- und Lesezugriffe.
Index | 100
Slot-Nummer | Position der EtherCAT-Klemme, absolute Position.
Strukturaufbau | Bedeutung | Länge in Byte
COE-Index | COE-Index-Nummer. | 2
COE-Sub-Index | COE-Sub-Index-Nummer. | 1
READ/ WRITE | 0-Read/ 1-Write. | 1
Länge | Länge der zu Schreibenden Daten. Beim Lesen kann diese Null sein. | 4
Daten | Daten, nur beim Schreiben notwendig. | n
Wenn Sie virtuelle Slaves verwenden, muss die Slot-Nummer die echte Klemmenposition enthalten und nicht die Steckplatzposition der EtherCAT-Klemme.
Beispiel
Sie wollen die COE-Daten der EtherCAT-Klemme EL3154 auslesen. Diese EtherCAT-Klemme ist in TwinCAT unter Slave 2 (virtueller Slave) konfiguriert.
Aufteilung der EtherCAT-Teilnehmer in TwinCAT auf zwei Slaves.
Slave 1 |  |  |  |  |  | Slave 2 (virtueller Slave)
EK3100 | CtrlStatus | EL1008 | EL2008 | EL3062 | EK1110 | EK3100 | CtrlStatus | EK1100 | EL2008 | EL1008 | EL3154
PROFIBUS-Adresse: 11 |  |  |  |  |  | PROFIBUS-Adresse: 12. Die nicht sichtbare EL9011 entfällt.
In diesem Beispiel hat die EtherCAT-Klemme EL3154 die Slot-Nummer 8. Die beiden CtrlStatus DWORD-Module und der virtuelle Slave EK3100 werden nicht mitgezählt.
Verteilung der Slot-Nummern auf die EtherCAT-Teilnehmer.
Slave 1 |  |  |  |  | Slave 2 (virtueller Slave)
Slot-Nummer | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
EK3100 | EL1008 | EL2008 | EL3062 | EK1110 | EK1100 | EL2008 | EL1008 | EL3154
PROFIBUS-Adresse: 11 |  |  |  |  | PROFIBUS-Adresse: 12. Die nicht sichtbare EL9011 entfällt.


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
Diagnose-LEDs
•
LEDs der Netzteilklemme im E-Bus-Modus
•
Diagnose über PROFIBUS


Diagnose-LEDs

Fehlerbehandlung und Diagnose [image] Diagnose-LEDs
Diagnose-LEDs
Diagnose-LEDs beim EK3100.
Anzeige | LED | Beschreibung | Farbe | Bedeutung
 | RUN | Zeigt den Status des Kopplers an. | Grün | EK3100 gestartet.
 |  |  | Blau | Update des EK3100 per USB möglich.
 | BF | Zeigt den Status des PROFIBUS an | Blinkt grün | Keine PROFIBUS Kommunikation.
 |  |  | Leuchtet grün | EK3100 befindet sich im Datenaustausch.
LED | Beschreibung | Fehlercode - Erste Sequenz | Fehlerstelle - Zweite Sequenz | Bedeutung
DIA | Blinkt rot bei einem Fehler. Zeigt den Fehlercode und die Fehlerstelle durch zwei aufeinanderfolgende Sequenzen an. | 1 Impuls | hinter Busklemme n | Falsches Modul.
 |  | 2 Impulse |  | Fehlendes Modul.
 |  | 3 Impulse |  | Modul gezogen.
 |  | 4 Impulse |  | Falsches Modul gesteckt.
 |  | 5 Impulse |  | EtherCAT-Slave nicht im OP-Mode.
 |  | 6 Impulse |  | State-Change abgebrochen.
 |  | 7 Impulse |  | Abnormal State-Change.
 |  | 8 Impulse |  | SDO-Abort.
 |  | 9 Impulse |  | Falsche SDO-Länge.
 |  | 10 Impulse |  | Falsche SDO-Daten.


LEDs der Netzteilklemme im E-Bus-Modus

Fehlerbehandlung und Diagnose [image] LEDs der Netzteilklemme im E-Bus-Modus
LEDs der Netzteilklemme im E-Bus-Modus
Die angeschlossenen EtherCAT-Klemmen werden vom Netzteil überprüft. Im E-Bus-Modus leuchtet die LED „L/A“. Wenn Daten übertragen werden, blinkt die LED „L/A“.
LEDs der Netzteilklemme beim EK3100.
Anzeige | LED |  | Bedeutung
 | Us 24 V |  | Spannungsversorgung für CPU-Grundmodul. Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | Up 24 V |  | Spannungsversorgung für Klemmenbus. Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | L / A | aus | E-Bus nicht angeschlossen.
 |  | an | E-Bus angeschlossen / Kein Datenverkehr.
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.


Diagnose über PROFIBUS

Fehlerbehandlung und Diagnose [image] Diagnose über PROFIBUS
Diagnose über PROFIBUS
Die Diagnose über PROFIBUS ist wie folgt aufgebaut. Das Modul auf Slot 1 ist immer das CtrlStatus DWORD-Modul. Damit befindet sich die erste EtherCAT-Klemme aus ihrer Hardwarekonfiguration immer auf Slot 2.
Für die Diagnose ist die projektierte Position entscheidend und nicht die tatsächliche Position in der Hardwarekonfiguration.
Beispiel:
Eine EtherCAT-Klemme, die in der tatsächlichen Hardwarekonfiguration an 4ter Stelle nach dem EK3100 gesteckt ist, hat ein Problem. Dann würde die Diagnose den Fehler an Slot 5 anzeigen, da Slot 1 immer mit dem CtrlStatus DWORD-Modul belegt ist.
Diagnosebeispiel über PROFIBUS mit einer Siemens Projektierung.
Beachten Sie dieses Verhalten für die Diagnose über PROFIBUS.
Weiterführende Informationen
•
Diagnose bei virtuellen Slaves
•
Aufbau des Diagnose-Telegramms


Diagnose bei virtuellen Slaves

Fehlerbehandlung und Diagnose [image] Diagnose über PROFIBUS [image] Diagnose bei virtuellen Slaves
Diagnose bei virtuellen Slaves
Die Diagnose meldet immer den Slot aus der Konfiguration, die „echte“ EtherCAT Klemme wird über den Text angezeigt.
Beispiel:
Sie haben den Buskoppler EK3100 mit einem zusätzlichen virtuellen Slave konfiguriert und die EtherCAT-Klemme an 9ter Stelle hat ein Problem. Diese EtherCAT-Klemme ist aber am virtuellen Slave im 5ten Slot konfiguriert. Verwenden Sie den Text aus der Diagnose und nicht die Slot-Nummer, um den Fehlerort genau zu bestimmen.
Diagnosebeispiel über PROFIBUS bei virtuellen Slaves mit einer Siemens Projektierung.
Beachten Sie dieses Verhalten für die Diagnose über PROFIBUS.


Aufbau des Diagnose-Telegramms

Fehlerbehandlung und Diagnose [image] Diagnose über PROFIBUS [image] Aufbau des Diagnose-Telegramms
Aufbau des Diagnose-Telegramms
Aufbau des Diagnose-Telegramms nach DPV0 und DPV1.
Byte | Beschreibung
Byte [0…5] | Standarddiagnose nach DPV0.
ab Byte [6] | Diagnose nach DPV1.
Byte [6] | 0x07 Headerbyte nach DPV1 = Längenangabe.
Byte [7] | 0x0A Status_Type nach DPV1.
Byte [8] | 0xXX Slot-Nummer nach DPV1 Die Slot-Nummer bezieht sich auf die Position in der Konfigurationssoftware. Die Slot-Nummer ist immer +1, weil Slot 1 immer durch das CtrlStatus DWORD- Modul belegt ist. Die echte EtherCAT-Klemme wird im Byte [10] angezeigt.
Byte [9] | Specifier nach DPV1.
ab Byte [10] | Herstellerspezifisch.
Byte [10] | EtherCAT-Slave Nummer.
Byte [11] | Value (1) =EtherCAT-Slave in INIT.
 | Value (2) =EtherCAT-Slave in PreOP.
 | Value (3) =EtherCAT-Slave in SafeOP.
 | Value (4) =EtherCAT-Slave in OP.
 | Value (5) =EtherCAT-Slave nicht vorhanden.
Byte [12] | Value (1) = State-Change abgebrochen.
 | Value (2) = Abnormal State-Change.
 | Value (3) = SDO-Abort.
 | Value (4) = Falsche SDO Länge.
 | Value (5) = Falsche SDO-Daten.
 | Value (6) = Falsches Modul konfiguriert.
 | Value (7) = Module gezogen.
 | Value (8) = Module gesteckt.
 | Value (9) = Nicht alle Module gesteckt.
 | Value (10) = Falsches Modul gesteckt.
 | Value (11) = Fehlendes Modul.


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Image des Buskopplers aktualisieren
•
Support und Service


Image des Buskopplers aktualisieren

Anhang [image] Image des Buskopplers aktualisieren
Image des Buskopplers aktualisieren
Datenverlust
Die Daten im internen Flash-Speicher werden gelöscht.
Sichern Sie Ihre Daten, bevor Sie das Image des Buskopplers aktualisieren.
Das Image des Buskopplers kann über die USB-Schnittstelle aktualisiert werden. Dafür wird der Buskoppler per USB-Kabel mit einem Host-PC verbunden. Anschließend wird der Buskoppler unter Windows als Wechseldatenträger angezeigt und die Dateien können kopiert werden.
Aktualisieren Sie den Buskoppler nur nach Rücksprache mit dem Beckhoff Service. Der Beckhoff Service stellt auch alle notwendigen Dateien zur Verfügung.
Voraussetzungen
▪
Überprüfen Sie zuerst ob der Buskoppler das Image unterstützt.
▪
Der Buskoppler ist per USB-Kabel mit dem Host-PC verbunden.
Aktualisieren Sie das Image wie folgt:
1.
Schalten Sie den Buskoppler aus.
2.
Stellen Sie den 2-poligen roten DIP-Schalter 1 auf „on“ (nach rechts) und schalten Sie den Buskoppler ein.
Der Buskoppler erscheint als Wechseldatenträger auf dem Host-PC.
3.
Markieren und löschen Sie alle Dateien.
Nicht formatieren.

4.
Entfernen Sie das USB-Kabel, sobald alle Dateien kopiert wurden und stellen Sie den 2-poligen DIP-Schalter auf „off“ (nach links).
5.
Starten Sie den Buskoppler neu.
⇨
Sie haben das Image erfolgreich aktualisiert. Es ist möglich, dass der Buskoppler nach der Aktualisierung etwas länger für den Start benötigt.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.