EK18xx - EtherCAT-Buskoppler
Home


Übersicht EtherCAT- Buskoppler EK18xx

Übersicht EtherCAT- Buskoppler EK18xx
Übersicht EtherCAT- Buskoppler EK18xx
EK1814 EtherCAT-Buskoppler mit 4 digitalen Eingängen und 4 digitalen Ausgängen
EK1818 EtherCAT-Buskoppler mit 8 digitalen Eingängen und 4 digitalen Ausgängen
EK1828 EtherCAT-Buskoppler mit 4 digitalen Eingängen und 8 digitalen Ausgängen
EK1828-0010 EtherCAT-Buskoppler mit 8 digitalen Ausgängen


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.2
▪
Update Kapitel "Übersicht EtherCAT-Koppler“
▪
Update Sicherheitshinweise
▪
Update Revisionsstand
2.1
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Update Kapitel "Technische Daten"
▪
Hinweis zum ESD-Schutz eingefügt
▪
Update Revisionsstand
2.0
▪
Migration
▪
Update Revisionsstand
▪
Strukturupdate
1.3
▪
Strukturupdate
▪
Update Revisionsstand
▪
Update Kapitel "Technische Daten"
1.2
▪
Ergänzung Kapitel "Speisung, Potenzialgruppen"
1.1
▪
EK1818, EK1828, EK1828-0010 ergänzt
1.0
▪
1. Veröffentlichung
0.3
▪
Ergänzungen und Korrekturen
0.2
▪
Ergänzungen und Korrekturen
0.1
▪
Vorläufige Version


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
EtherCAT State Machine
•
CoE-Interface: Hinweis
•
Distributed Clock


EtherCAT-Grundlagen

Grundlagen [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT State Machine

Grundlagen [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface: Hinweis

Grundlagen [image] CoE-Interface: Hinweis
CoE-Interface: Hinweis
Dieses Gerät hat kein CoE.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Übersicht EtherCAT-Koppler
•
EK18xx


Übersicht EtherCAT-Koppler

Produktübersicht [image] Übersicht EtherCAT-Koppler
Übersicht EtherCAT-Koppler
Um EtherCAT-Klemmen mit E-Bus-Kommunikation (Serien ELxxxx, ESxxxx, EMxxxx) an ein EtherCAT-Netzwerk anzuschließen, wird ein EtherCAT-Koppler benötigt. Dieser Koppler leitet vom übergeordneten EtherCAT-Netzwerk die Kommunikation an die Klemmen weiter oder arbeitet selbst als Master und erzeugt Telegramme. Für verschiedenen Einsatzszenarien bietet Beckhoff unterschiedliche Komponenten an.
Die Auswahl des richtigen Kopplers richtet sich nach folgenden Kriterien:
▪
wird eine lokale Kleinsteuerung benötigt?
▪
wird der Koppler über Kupfer-Kabel oder Lichtwellenleiter angeschlossen?
▪
soll der Koppler über IP addressiert werden oder befindet er sich im ungeswitchten Netzwerk?
▪
wird der Koppler über EAP (EtherCAT Automation Protokoll) oder EtherCAT Device Protokoll angesteuert?
▪
benötigte Schutzart, IP20 oder höher?
▪
soll der Koppler über das HotConnect-Verfahren an verschiedenen Stellen am Netzwerk angesteckt werden?
Ein Koppler bindet nach rechts die angefügten Klemmen an, nach links kann er mit dem übergeordneten Netzwerk verbunden werden. Koppler, die nach "links" das EtherCAT-Device-Protokoll unterstützen, müssen dort mit einem EtherCAT Master verbunden werden.
Kommunikationsschema EtherCAT-Koppler
Zur Auswahl kann folgende Übersicht verwendet werden:
Eigenschaft | EK1100 | EK1101 EK1101-0080 | EK1101-0010 | EK1300 | EK1501 | EK1501-0010
Schutzart | IP20 | IP20 | IP20 | IP20 | IP20 | IP20
übergeordnete Netzwerk - Technologie | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-FX) | 100 MBit FastEthernet (100BASE-FX)
übergeordnetes Netzwerk - max. Verbindungslänge | 100 m | 100 m | 300 m | 100m | 2 km | 20 km
übergeordnete Netzwerk - Verbindungstechnik | RJ45 | RJ45 | RJ45 | RJ45 | SC-Duplex Multimode LWL | SC-Duplex Singlemode LWL
übergeordnetes Netzwerk - Protokoll | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (an 100BASE-TX-EtherCAT-P-Netze) | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode)
integrierte SPS/PLC | - | - | - | - | - | -
unterstützt HotConnect mit am Gerät einstellbarer Adresse | - | ja EK1101-0080: Fast-Hot-Connect | - | - | ja | ja
Hinweis | Der EK1100 ist der "Standard"-Koppler für den Einsatz direkt am EtherCAT Master. |  | max. 300 m Länge zwischen den Stationen (Kupfer, Kat. 5, 4-adrig) | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-TX-EtherCAT-P-Netze |  |
Eigenschaft | EK1541 | EK18xx | EK9000 | EKx000 | EPxxxx | CX8000
Schutzart | IP20 | IP20 | IP20 | IP20 | IP67 | IP20
übergeordnete Netzwerk - Technologie | 100 MBit FastEthernet (100BASE-FX) POF | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | diverse s. Doc. | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX)
übergeordnetes Netzwerk - max. Verbindungslänge | 50 m | 100 m | 100 m | s.Doc. | 100 m | 100 m
übergeordnete Netzwerk - Verbindungstechnik | Versatile Link POF-Duplex-Stecker Polymeric Optical Fiber | RJ45 | RJ45 | s.Doc | M8 | RJ45
übergeordnetes Netzwerk - Protokoll | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode) | EAP | s. Doc. | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode)
integrierte SPS/PLC | - | - | - | - | - | ja
unterstützt HotConnect mit am Gerät einstellbarer Adresse | ja | - | - | - | - | -
Hinweis |  | Die EK18xx integrieren einen Koppler für den Einsatz direkt am EtherCAT-Master und digitale Ein- u. Ausgänge ohne Zusatzbeschaltung. | Der EK9000 kann in einem geswitchten EtherCAT Netzwerk mit gerichteter IP-Adressierung angesteuert werden. | Wird der EK9000 mit einem anderen Feldbusanschluss versehen, ergibt sich der entsprechende Koppler EKx000. | Jede EP-Box stellt technologisch für sich einen EtherCAT Koppler mit intern angefügten IO-Funktionen dar. | Der CX8000 tritt zum übergeordneten EtherCAT Netzwerk als EtherCAT Slave auf und verwaltet gleichzeitig seine angefügten IO als Master.


EK18xx

Produktübersicht [image] EK18xx
EK18xx
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Optionale Distributed Clocks Unterstützung
•
Port-Zuordnung EtherCAT-Koppler


Einführung

Produktübersicht [image] EK18xx [image] Einführung
Einführung
EK18xx
EtherCAT-Koppler EK18xx mit digitalen Ein- und Ausgängen
Die EtherCAT-Koppler EK18xx verbinden das EtherCAT Device Protokoll mit den EtherCAT-Klemmen (ELxxxx/ESxxxx/EMxxxx) und beinhalten je nach Typ eine bestimmte Anzahl digitaler Eingänge 24 VDC (IEC61131-2 Typ 3) und digitaler Ausgänge 24 VDC; 0,5 A. Der Koppler im modernen High-Density (HD)-Gehäuse kann mit werkzeugloser Direktstecktechnik verdrahtet werden.
Eine Station besteht aus einem Koppler, einer beliebigen Anzahl von EtherCAT-Klemmen und einer Busendklemme, z. B. der EL9011.
Der Koppler setzt mit einer minimalen Latenz die Telegramme im Durchlauf von der Ethernet-100BASE-TX- auf die E-Bus-Signaldarstellung um. Mit der oberen Ethernet-Schnittstelle wird der Koppler an das Netzwerk angeschlossen, die untere RJ-45-Buchse dient zum optionalen Anschluss weiterer EtherCAT-Geräte am gleichen Strang.
Die angefügten Klemmen werden von dem Koppler mit dem benötigten E-Bus-Strom zur Kommunikation versorgt. Maximal kann der Koppler 5 V / 1000 mA liefern. Wird mehr Strom benötigt, sind Einspeiseklemmen (z. B. EL9410) zu integrieren.
Im EtherCAT-Netzwerk wird der Koppler im Bereich der Ethernet-Signalübertragung (100BASE-TX) an beliebiger Stelle eingesetzt. Dabei verarbeitet der Koppler ausschließlich unadressierte MAC-Broadcast-Telegramme vom Typ EtherCAT Device Protokoll vom EtherCAT-Master. Da eine gerichtete Ansprache über MAC-Unicast oder IP-Addressierung nicht verwendet wird, kann kein Switch oder Router eingesetzt werden.


Technische Daten

Produktübersicht [image] EK18xx [image] Technische Daten
Technische Daten
Technische Daten | EK1814-0000 | EK1818-0000 | EK1828-0000 | EK1828-0010
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-TX EtherCAT-Netze
Anzahl digitaler Eingänge | 4 | 8 | 4 | -
Anzahl der gleichzeitig ansteuerbaren Eingänge abhängig von Umgebungstemperatur | 4 (-25 °C ... +60 °C) | 8 (-25 °C ... +55 °C) 4 ( > +55 °C) | 4 (-25 °C ... +60 °C) | -
Anzahl digitaler Ausgänge | 4 | 4 | 8 | 8
Anzahl der EtherCAT-Klemmen | bis zu 65.534 im Gesamtsystem
Anzahl Peripheriesignale | max. 4,2 GByte adressierbare IO-Punkte
Protokoll / Baudrate | EtherCAT Device Protokoll / 100 MBaud
Leitungslänge zwischen 2 Buskopplern | max. 100 m (100BASE-TX)
Übertragungsmedium | mind. Ethernet CAT-5 Kabel
Nennspannung der Eingänge | 24 VDC (-15% / +20%) |  |  | -
Signalspannung "0" | -3 V ... 5 V (EN 61131-2, Typ 1/3) |  |  | -
Signalspannung "1" | 11 V ... 30 V (EN 61131-2, Typ 3) |  |  | -
Eingangsfilter | 3 ms |  |  | -
Eingangsstrom | typ. 3 mA (EN 61131-2, Typ 3) |  |  | -
Lastart | ohmsch, induktiv, Lampenlast
Nennspannung der Ausgänge | 24 VDC (-15% / +20%)
Schaltzeiten | TON: 60 µs typ.; TOFF: 300 µs typ.
Ausgangsstrom je Kanal | max. 0,5 A (kurzschlussfest)
Kurzschlussstrom | < 2 A typ.
Abschaltenergie (induktiv) | maximal 150 mJ/Kanal
Distributed Clocks | nein
HotConnect | nein
Durchlaufverzögerung | typ. 1 µs
Busanschluss | 2 x RJ45
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme aus Up | 40 mA + Last
Stromaufnahme aus Us | 100 mA + (ges. E-Bus Strom)/4
E-Bus Stromversorgung (5 V) | max. 1000 mA (Bei höherer Stromaufnahme bitte zusätzliche Einspeiseklemmen EL9410 verwenden!)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT) 500 V (E-Bus/Feldspannung)
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
Gewicht | ca. 125 g
Zulässiger Umgebungstemperaturbereich im Betrieb | -25 °C ... +60 °C (erweiterter Temperaturbereich)
Zulässiger Umgebungstemperaturbereich bei Lagerung | -40 °C ... +85 °C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus


Optionale Distributed Clocks Unterstützung

Produktübersicht [image] EK18xx [image] Optionale Distributed Clocks Unterstützung
Optionale Distributed Clocks Unterstützung
Grundlagen Distributed Clocks (DC)
Das EtherCAT Distributed-Clocks-System umfasst in den EtherCAT Slaves integrierte lokale Uhren, die über spezielle Datagramme vom EtherCAT Master synchronisiert werden. Nicht alle EtherCAT Slaves unterstützen das Distributed Clocks Verfahren, sondern nur Slaves, deren Funktion dieses erfordert. Im TwinCAT Systemmanager zeigt ein Slave seine DC-Fähigkeiten, indem er über einen Einstellungsdialog „DC“ verfügt.
DC-Reiter zur Anzeige der Distributed Clocks Funktion
Eine dieser lokalen Uhren ist die Referenz-Uhr, nach der alle anderen synchronisiert werden. Siehe dazu entsprechende Erläuterungen in der EtherCAT Grundlagendokumentation. Prinzipbedingt muss das der erste DC-fähige EtherCAT Slave sein. Deshalb wählt TwinCAT standardmäßig den ersten DC-fähigen Teilnehmer als Referenzuhr aus. In den erweiterten Eigenschaften des EtherCAT Masters wird dies dargestellt bzw. kann vom Anwender verändert werden. Die Standard-Einstellung soll nicht verändert werden, außer es wird in entsprechenden Dokumentationen z.B. zur externen Synchronisierung empfohlen.
Erweiterte Einstellung Distributed Clocks im EtherCAT Master
In Abb. Erweiterte Einstellung Distributed Clocks im EtherCAT Master ist zu erkennen, wie TwinCAT standardmäßig die EL1252 als Referenzuhr auswählt, da die vorhergehenden Komponenten kein DC unterstützen.
Einstellung EtherCAT Device
System- und Infrastrukturteilnehmer wie die Koppler und Abzweige EK1100, EK1122 etc. benötigen zur Funktion keine Distributed Clocks. Dennoch kann es topologisch sinnvoll sein, z. B. den ersten Koppler im EtherCAT System als Referenzuhr festzulegen. Deshalb sind die Infrastrukturkomponenten ab einem bestimmten Bauzustand in der Lage als Referenzuhr zu arbeiten, wenn in der Konfiguration besondere Einstellungen vorgenommen werden.
Die Komponenten unterstützen lt. der folg. Tabelle die Aktivierung der Distributed Clocks:
Gerät | XML-Revision in der Konfiguration | Seriennummer der Komponente
BK1150 | ab BK1150-0000-0016 | ab Firmware 01: xxxx01yy
CU1128 | ab CU1128-0000-0000 | ab Firmware 00: xxxx00yy
EK1100 | ab EK1100-0000-0017 | ab Firmware 06: xxxx06yy
EK1101 | ab EK1101-0000-0017 | ab Firmware 01: xxxx01yy
EK1501 | ab EK1501-0000-0017 | ab Firmware 01: xxxx01yy
EK1501-0010 | ab EK1501-0010-0017 | ab Firmware 02: xxxx02yy
EK1122 | ab EK1122-0000-0017 | ab Firmware 01: xxxx02yy
EK1521 | ab EK1521-0000-0018 | ab Firmware 03: xxxx03yy
EK1541 | ab EK1541-0000-0016 | ab Firmware 01: xxxx01yy
EK1561 | ab EK1561-0000-0016 | ab Firmware 01: xxxx01yy
EK1521-0010 | ab EK1521-0010-0018 | ab Firmware 03: xxxx03yy
EK1814 | ab EK1814-0000-0016 | ab Firmware 00: xxxx00yy
Tab. 1: DC-Unterstützung ab Rev/FW-Stand
Damit TwinCAT eine solche Komponente als DC-Referenzuhr verwendet, ist ein manueller Eingriff bei der Konfigurationserstellung erforderlich, der hier anhand des EK1100 gezeigt wird.
Die Checkboxen „Cyclic Mode Enable“ und „Use as potential Reference Clock“ müssen gesetzt werden.
TwinCAT-Einstellung, um diese Komponente als Referenzuhr zu verwenden
Aktivierung Distributed Clocks Unterstützung
Das hier beschriebene Vorgehen führt nur bei den o.a. Komponenten zum (Synchronisierungs-)Erfolg. Auch bei anderen Komponenten können diese Checkboxen gesetzt werden, die Hardware unterstützt diese Funktion jedoch nicht, wenn nicht entsprechend in der jeweiligen Dokumentation angegeben.
Insbesondere darf nach der Inbetriebnahme die Komponente nicht durch eine frühere Version ausgetauscht werden, die den DC-Support nicht leisten kann.


Port-Zuordnung EtherCAT-Koppler

Produktübersicht [image] EK18xx [image] Port-Zuordnung EtherCAT-Koppler
Port-Zuordnung EtherCAT-Koppler
Laut EtherCAT-Spezifikation kann ein ESC (EtherCAT Slave Controller, Hardwareverarbeitungseinheit des EtherCAT-Protokolls) über 1 bis 4 Ports verfügen, die er von sich aus kontrolliert. Öffnet er einen Port, ist dort abgehender und ankommender Ethernet-Verkehr möglich.
Als Beispiel ist die Datenflussrichtung in einem voll beschalteten EK1100 in Abb. Interne und externe Port-Zuordnung Buskoppler EK1100 gezeigt:
Beispiel EtherCAT-Koppler EK1100 mit 3 Ports
Die Portzuordnung beim EK1101, EK1501 und EK1501-0010, EK1814 gilt entsprechend.
Interne und externe Port-Zuordnung Buskoppler EK1100
Ablauf der Frameverarbeitung
▪
Der ankommende EtherCAT-Frame am EtherCAT-Signaleingang wird von Port 0 (A) weitergereicht zur ErherCAT-Processing-Unit.
▪
Ankunft des EtherCAT-Frames an Port 1 (B) und Verlassen des Datenframes über Port 1 (B) zum nachfolgenden Slave im EtherCAT-Klemmenverbund (falls dort ein Slave angeschlossen ist und "Link" meldet).
▪
Nach Ankunft des Datenframes an Port 1 (B) aus dem Klemmenverbund wird dieser zum Port 2 (C) weitergereicht und verlässt am nachfolgenden EtherCAT-Ausgang den Koppler (falls dort ein Slave angeschlossen ist und "Link" meldet).
▪
Ankunft des Datenframes an Port 2 (C). Dieser wird nun zum Port 0 (A) weitergereicht und verlässt den EK1100 über den EtherCAT-Eingang.
Verarbeitung der Daten
Die Daten in den EtherCAT-Datagrammen werden nur zwischen Port 0 (A) und 3 (D) in der EtherCAT-Processing-Unit verarbeitet. Der nicht ausgeführte (interne) Port 3 (D) gilt als geschlossen und reicht das Datagramm an Port 1 (B) weiter.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Anschlusstechnik
•
Positionierung von passiven Klemmen
•
Speisung, Potenzialgruppen
•
EK18xx - Anschlussbelegung


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


Speisung, Potenzialgruppen

Montage und Verdrahtung [image] Speisung, Potenzialgruppen
Speisung, Potenzialgruppen
Spannungsversorgung Buskoppler
Die Buskoppler benötigen zum Betrieb eine 24 VDC Gleichspannung. Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Die Versorgungsspannung wird sowohl von der Buskopplerelektronik als auch von der direkten Spannungserzeugung für den E-Bus genutzt. Die Spannungserzeugung für den E-Bus findet in einem DC/DC-Wandler ohne galvanische Trennung statt.
Hinweis
E-Bus Stromversorgung
Die EK18xx versorgen den E-Bus mit max. 1000 mA E-Bus-Strom!
Wird durch die angefügten Klemmen mehr Strom benötigt, sind Einspeiseklemmen zu setzen!
Einspeisung Powerkontakte
Die Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler. Die Auslegung der Einspeisung lässt Spannungen bis zu 24 V zu. Die Strombelastung über den Powerkontakten darf 10 A nicht dauerhaft überschreiten, die Zuleitung ist deshalb mit 10 A (träge) abzusichern.
Powerkontakte
An der rechten Seitenfläche des Buskopplers befinden sich zwei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um den Berührungsschutz sicherzustellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut/Federführung an der Ober- und Unterseite der Buskoppler und Busklemmen garantiert sichere Führung der Powerkontakte.
Die Strombelastung der Powerkontakte darf 10 A nicht dauerhaft überschreiten.
Potenzialtrennung
Die Buskoppler arbeiten mit drei unabhängigen Potenzialgruppen. Die Versorgungsspannung speist galvanisch getrennt die E-Bus-Elektronik im Buskoppler und den E-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbus erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum E-Bus. Der E-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialschaltbild (Beispiel EK1814)
Erdungskonzept
Erdungskonzept EK18xx
Absicherung
Kopplerversorgung, Sicherung 1:
in Abhängigkeit von der benötigten Stromaufnahme und damit der konfigurierten Klemmen typ. max 500 mA
Berechnung der Absicherung
Beachten Sie bei der Dimensionierung der Absicherung für die Systemspannung die Berechnung zur Stromaufnahme in den Technischen Daten!
Powerkontakte, Sicherung 2:
max. 10 A (träge) zulässig
Kopplerelektronik und Powerkontakte können zusammen aus der gleichen Quelle versorgt werden, die Sicherung ist dann entsprechend auf max. 10 A zu dimensionieren.


EK18xx - Anschlussbelegung

Montage und Verdrahtung [image] EK18xx - Anschlussbelegung
EK18xx - Anschlussbelegung
Weiterführende Informationen
•
EK1814 - Anschlussbelegung
•
EK1818 - Anschlussbelegung
•
EK1828 - Anschlussbelegung
•
EK1828-0010 - Anschlussbelegung


EK1814 - Anschlussbelegung

Montage und Verdrahtung [image] EK18xx - Anschlussbelegung [image] EK1814 - Anschlussbelegung
EK1814 - Anschlussbelegung
Anschlussbelegung EK1814-0000
Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Us 24 V | 1 | Einspeisung für Buskoppler und E-Bus-Elektronik
Input 1 | 2 | Eingangskanal 1
Input 3 | 3 | Eingangskanal 3
n.c. | 4 | nicht beschaltet
n.c. | 5 | nicht beschaltet
Up 24 V | 6 | Einspeisung für die Powerkontakte
Output 1 | 7 | Ausgangskanal 1
Output 3 | 8 | Ausgangskanal 3
Us 0 V | 9 | Einspeisung für Buskoppler und E-Bus-Elektronik
Input 2 | 10 | Eingangskanal 2
Input 4 | 11 | Eingangskanal 4
n.c. | 12 | nicht beschaltet
n.c. | 13 | nicht beschaltet
Up 0 V | 14 | Einspeisung für die Powerkontakte
Output 2 | 15 | Ausgangskanal 2
Output 4 | 16 | Ausgangskanal 4


EK1818 - Anschlussbelegung

Montage und Verdrahtung [image] EK18xx - Anschlussbelegung [image] EK1818 - Anschlussbelegung
EK1818 - Anschlussbelegung
Anschlussbelegung EK1818-0000
Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Us 24 V | 1 | Einspeisung für Buskoppler und E-Bus-Elektronik
Input 1 | 2 | Eingangskanal 1
Input 3 | 3 | Eingangskanal 3
Input 5 | 4 | Eingangskanal 5
Input 7 | 5 | Eingangskanal 7
Up 24 V | 6 | Einspeisung für die Powerkontakte
Output 1 | 7 | Ausgangskanal 1
Output 3 | 8 | Ausgangskanal 3
Us 0 V | 9 | Einspeisung für Buskoppler und E-Bus-Elektronik
Input 2 | 10 | Eingangskanal 2
Input 4 | 11 | Eingangskanal 4
Input 6 | 12 | Eingangskanal 6
Input 8 | 13 | Eingangskanal 8
Up 0 V | 14 | Einspeisung für die Powerkontakte
Output 2 | 15 | Ausgangskanal 2
Output 4 | 16 | Ausgangskanal 4


EK1828 - Anschlussbelegung

Montage und Verdrahtung [image] EK18xx - Anschlussbelegung [image] EK1828 - Anschlussbelegung
EK1828 - Anschlussbelegung
Anschlussbelegung EK1828-0000
Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Us 24 V | 1 | Einspeisung für Buskoppler und E-Bus-Elektronik
Input 1 | 2 | Eingangskanal 1
Input 3 | 3 | Eingangskanal 3
Output 1 | 4 | Ausgangskanal 1
Output 3 | 5 | Ausgangskanal 3
Up 24 V | 6 | Einspeisung für die Powerkontakte
Output 5 | 7 | Ausgangskanal 5
Output 7 | 8 | Ausgangskanal 7
Us 0 V | 9 | Einspeisung für Buskoppler und E-Bus-Elektronik
Input 2 | 10 | Eingangskanal 2
Input 4 | 11 | Eingangskanal 4
Output 2 | 12 | Ausgangskanal 2
Output 4 | 13 | Ausgangskanal 4
Up 0 V | 14 | Einspeisung für die Powerkontakte
Output 6 | 15 | Ausgangskanal 6
Output 8 | 16 | Ausgangskanal 8


EK1828-0010 - Anschlussbelegung

Montage und Verdrahtung [image] EK18xx - Anschlussbelegung [image] EK1828-0010 - Anschlussbelegung
EK1828-0010 - Anschlussbelegung
Anschlussbelegung EK1828-0010
Anschlussbelegung
Klemmstelle |  | Beschreibung
Bezeichnung | Nr.
Us 24 V | 1 | Einspeisung für Buskoppler und E-Bus-Elektronik
n.c. | 2 | nicht beschaltet
n.c. | 3 | nicht beschaltet
Output 1 | 4 | Ausgangskanal 1
Output 3 | 5 | Ausgangskanal 3
Up 24 V | 6 | Einspeisung für die Powerkontakte
Output 5 | 7 | Ausgangskanal 5
Output 7 | 8 | Ausgangskanal 7
Us 0 V | 9 | Einspeisung für Buskoppler und E-Bus-Elektronik
n.c. | 10 | nicht beschaltet
n.c. | 11 | nicht beschaltet
Output 2 | 12 | Ausgangskanal 2
Output 4 | 13 | Ausgangskanal 4
Up 0 V | 14 | Einspeisung für die Powerkontakte
Output 6 | 15 | Ausgangskanal 6
Output 8 | 16 | Ausgangskanal 8


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Übersicht Konfiguration
•
Übersicht Prozessdaten


Übersicht Konfiguration

Parametrierung und Inbetriebnahme [image] Übersicht Konfiguration
Übersicht Konfiguration
Nähere Hinweise zur Konfigurationseinstellung finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Übersicht Prozessdaten

Parametrierung und Inbetriebnahme [image] Übersicht Prozessdaten
Übersicht Prozessdaten
Tragen Sie im TwinCAT System Manager im Config-Mode unter Geräte den EK18xx als EtherCAT (Direct Mode) Gerät ein. Sollte der Buskoppler schon am Netzwerk angeschlossen sein, können Sie diesen auch einlesen. Dabei werden automatisch alle Buskoppler mit Busklemmen und Konfiguration hochgeladen. Diese können Sie dann nach Ihren Bedürfnissen anpassen.
Weiterführende Informationen
•
EK1814
•
EK1818
•
EK1828
•
EK1828-0010


EK1814

Parametrierung und Inbetriebnahme [image] Übersicht Prozessdaten [image] EK1814
EK1814
TwinCAT Baum EK1814
Prozessdatenumfang EK1814
Prozessdatenumfang EK1814 TwinCAT
Prozessdatenumfang EK1814 TwinCAT
PDO-Zuordnung EK1814
SM1, PDO-Zuordnung 0x1C11
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 | 0.1 | Channel 1 | Index 0x6000:01 - Input
0x1A01 | 0.1 | Channel 2 | Index 0x6010:01 - Input
0x1A02 | 0.1 | Channel 3 | Index 0x6020:01 - Input
0x1A03 | 0.1 | Channel 4 | Index 0x6030:01 - Input
SM0, PDO-Zuordnung 0x1C10
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1608 | 0.1 | Channel 5 | Index 0x7080:01 - Output
0x1609 | 0.1 | Channel 6 | Index 0x7090:01 - Output
0x160A | 0.1 | Channel 7 | Index 0x70A0:01 - Output
0x160B | 0.1 | Channel 8 | Index 0x70B0:01 - Output
Tab. 1 + 2: PDO-Zuordnung der SyncManager EK1814


EK1818

Parametrierung und Inbetriebnahme [image] Übersicht Prozessdaten [image] EK1818
EK1818
TwinCAT Baum EK1818
Prozessdatenumfang EK1818
Prozessdatenumfang EK1818 TwinCAT
Prozessdatenumfang EK1818 TwinCAT
PDO-Zuordnung EK1818
SM1, PDO-Zuordnung 0x1C11
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 | 0.1 | Channel 1 | Index 0x6000:01 - Input
0x1A01 | 0.1 | Channel 2 | Index 0x6010:01 - Input
0x1A02 | 0.1 | Channel 3 | Index 0x6020:01 - Input
0x1A03 | 0.1 | Channel 4 | Index 0x6030:01 - Input
0x1A04 | 0.1 | Channel 5 | Index 0x6040:01 - Input
0x1A05 | 0.1 | Channel 6 | Index 0x6050:01 - Input
0x1A06 | 0.1 | Channel 7 | Index 0x6060:01 - Input
0x1A07 | 0.1 | Channel 8 | Index 0x6070:01 - Input
SM0, PDO-Zuordnung 0x1C10
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 | 0.1 | Channel 9 | Index 0x7000:01 - Output
0x1601 | 0.1 | Channel 10 | Index 0x7010:01 - Output
0x1602 | 0.1 | Channel 11 | Index 0x7020:01 - Output
0x1603 | 0.1 | Channel 12 | Index 0x7030:01 - Output
Tab. 3 + 4: PDO-Zuordnung der SyncManager EK1818


EK1828

Parametrierung und Inbetriebnahme [image] Übersicht Prozessdaten [image] EK1828
EK1828
TwinCAT Baum EK1828
Prozessdatenumfang EK1828
Prozessdatenumfang EK1828 TwinCAT
Prozessdatenumfang EK1828 TwinCAT
Prozessdatenumfang EK1828 TwinCAT
PDO-Zuordnung EK1828
SM2, PDO-Zuordnung 0x1C12
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1A00 | 0.1 | Channel 1 | Index 0x6000:01 - Input
0x1A01 | 0.1 | Channel 2 | Index 0x6010:01 - Input
0x1A02 | 0.1 | Channel 3 | Index 0x6020:01 - Input
0x1A03 | 0.1 | Channel 4 | Index 0x6030:01 - Input
SM0, PDO-Zuordnung 0x1C10
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 | 0.1 | Channel 5 | Index 0x7000:01 - Output
0x1601 | 0.1 | Channel 6 | Index 0x7010:01 - Output
0x1602 | 0.1 | Channel 7 | Index 0x7020:01 - Output
0x1603 | 0.1 | Channel 8 | Index 0x7030:01 - Output
SM1, PDO-Zuordnung 0x1C11
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1604 | 0.1 | Channel 9 | Index 0x7040:01 - Output
0x1605 | 0.1 | Channel 10 | Index 0x7050:01 - Output
0x1606 | 0.1 | Channel 11 | Index 0x7060:01 - Output
0x1607 | 0.1 | Channel 12 | Index 0x7070:01 - Output
Tab. 5 + 6 + 7: PDO-Zuordnung der SyncManager EK1828


EK1828-0010

Parametrierung und Inbetriebnahme [image] Übersicht Prozessdaten [image] EK1828-0010
EK1828-0010
TwinCAT Baum EK1828-0010
Prozessdatenumfang EK1828-0010
Prozessdatenumfang EK1828-0010 TwinCAT
Prozessdatenumfang EK1828-0010 TwinCAT
PDO-Zuordnung EK1828-0010
SM0, PDO-Zuordnung 0x1C10
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1600 | 0.1 | Channel 1 | Index 0x7000:01 - Output
0x1601 | 0.1 | Channel 2 | Index 0x7010:01 - Output
0x1602 | 0.1 | Channel 3 | Index 0x7020:01 - Output
0x1603 | 0.1 | Channel 4 | Index 0x7030:01 - Output
SM1, PDO-Zuordnung 0x1C11
Index | Größe (Byte.Bit) | Name | PDO Inhalt
0x1604 | 0.1 | Channel 5 | Index 0x7040:01 - Output
0x1605 | 0.1 | Channel 6 | Index 0x7050:01 - Output
0x1606 | 0.1 | Channel 7 | Index 0x7060:01 - Output
0x1607 | 0.1 | Channel 8 | Index 0x7070:01 - Output
Tab. 8 + 9 + 10: PDO-Zuordnung der SyncManager EK1828-0010


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
Diagnose-LEDs


Diagnose-LEDs

Fehlerbehandlung und Diagnose [image] Diagnose-LEDs
Diagnose-LEDs
Diagnose-LEDs
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Er wird eine Firmware geladen.
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK / ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit folgendem EtherCAT-Teilnehmer
LINK / ACT E-Bus | grün | aus | - | keine Verbindung interner E-Bus
 |  | an | linked | Verbindung interner E-Bus
 |  | blinkt | active | Verbindung/Kommunikation interner E-Bus
LEDs zur Diagnose der digitalen Ein- und Ausgänge
LED |  | Anzeige | Beschreibung
INPUT** | grün | aus | Signalspannung "0" (-3 V ... 5 V)
 |  | an | Signalspannung "1" (11 V ... 30 V)
OUTPUT** | grün | aus | Kein Ausgangssignal
 |  | an | Ausgangssignal 24 VDC am jeweiligen Ausgang
**) je nach Ausführung


Anhang

Anhang
Anhang
Weiterführende Informationen
•
UL-Hinweise
•
Firmware Kompatibilität
•
Firmware Update EL/ES/ELM/EM/EPxxxx
•
Support und Service


UL-Hinweise

Anhang [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1.
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2.
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Die Koppler EK18xx verfügen über keine Firmware.
Ein Update der XML-Gerätebeschreibung ist in Abhängigkeit vom Hardwarestand und der unten stehenden Revisionsnummer im Kapitel "Update der Gerätebeschreibung beschrieben“.
Hinweis
Fehlfunktion möglich!
Beachten Sie die Hinweise zum XML-Update auf der gesonderten Seite.
Stellen Sie sicher, dass die XML-Gerätebeschreibung für den Hardware-Stand des Gerätes geeignet ist!
EK1814
Hardware (HW) | Revision-Nr.
00 | EK1814-0000-0016
01 | EK1814-0000-0017
02
03 | EK1814-0000-0018
04
05
06 | EK1814-0000-0019*
07
08
09*
EK1818
Hardware (HW) | Revision-Nr.
00 | EK1818-0000-0016
01
02
03 | EK1818-0000-0017
04
05
06 | EK1818-0000-0018*
07
08
09*
EK1828
Hardware (HW) | Revision-Nr.
02 | EK1828-0000-0017
03
04
05
06* | EK1828-0000-0018*
EK1828-0010
Hardware (HW) | Revision-Nr.
02 | EK1828-0010-0017
03
04
05 | EK1828-0010-0018*
06*
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Revision/Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Firmware Update EL/ES/ELM/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx
Firmware Update EL/ES/ELM/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, ELM, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/ELM/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.