EK1122, EK15xx - EtherCAT Abzweige
Home


Übersicht EtherCAT Abzweige

Übersicht EtherCAT Abzweige
Übersicht EtherCAT Abzweige
Anschluss RJ45
EK1122 - 2 Port EtherCAT-Abzweig
EK1122-0080 - 2 Port EtherCAT-Abzweig, Fast-Hot-Connect
Anschluss M8
EK1122-0008 - 2 Port EtherCAT-Abzweig
Anschluss LWL
EK1521 - 1 Port EtherCAT-Multimode-LWL-Abzweig
EK1521-0010 - 1 Port EtherCAT-Singlemode-LWL-Abzweig
Anschluss POF
EK1561 - 1 Port EtherCAT-POF-Abzweig


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation EtherCAT Geräte


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt. Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft. Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen. Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH & Co. KG.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Änderungen
3.1 | - Korrektur im Kapitel „Funktionsgrundlagen EtherCAT-Abzweige“
3.0 | - Ergänzung von EK1122-0008 (EtherCAT Koppler, mit M8-Buchsen); - Migration
2.4 | - Kapitel "Montage und Verdrahtung" aktualisiert - Kapitel "Technische Daten" aktualisiert - Strukturupdate
2.3 | - Technische Daten aktualisiert
2.2 | - Technische Daten aktualisiert
2.1 | - Ergänzung Kapitel "Optionale DC-Unterstützung"
2.0 | - Ergänzung EK1122-0080
1.9 | - Ergänzung Anwendungshinweise POF Abzweig
1.8 | - EK1561 ergänzt
1.7 | - Update Kapitel "Diagnose LEDs"
1.6 | - Technische Hinweise ergänzt, Struktur angepasst
1.5 | - EK1521-0010 ergänzt
1.4 | - Hinweis PC Stecker ergänzt
1.3 | - Port -Zuordnung ergänzt
1.2 | - Technische Hinweise ergänzt
1.1 | - Technische Beschreibung ergänzt
1.0 | - Erste Veröffentlichung
0.1 | - Vorläufige Version


Versionsidentifikation EtherCAT Geräte

Vorwort [image] Versionsidentifikation EtherCAT Geräte
Versionsidentifikation EtherCAT Geräte
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, .....)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge..
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u

D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine

Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen:
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Chargennummer
CU2016 Switch mit Chargennummer
EL3202-0020 mit Chargennummern 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP76 EtherCAT Safety Box mit Chargennummer 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/DateCode 50110302 und eindeutiger Seriennummer 00331701


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Abzweig mit RJ45-Anschluss
•
Abzweige mit M8-Anschluss
•
Abzweige mit LWL-Anschluss
•
Abzweige mit POF-Anschluss


Abzweig mit RJ45-Anschluss

Produktübersicht [image] Abzweig mit RJ45-Anschluss
Abzweig mit RJ45-Anschluss
Weiterführende Informationen
•
EK1122, EK1122-0080


EK1122, EK1122-0080

Produktübersicht [image] Abzweig mit RJ45-Anschluss [image] EK1122, EK1122-0080
EK1122, EK1122-0080
Weiterführende Informationen
•
EK1122, EK1122-0080 - Einführung
•
Technische Daten
•
Hinweise zur EtherCAT Fast-Hot-Connect Technologie


EK1122, EK1122-0080 - Einführung

Produktübersicht [image] Abzweig mit RJ45-Anschluss [image] EK1122, EK1122-0080 [image] EK1122, EK1122-0080 - Einführung
EK1122, EK1122-0080 - Einführung
EK1122-xxxx
EK1122-0000
Der 2-Port-EtherCAT-Abzweig ermöglicht es, EtherCAT-Sterntopologien aufzubauen. Durch das Verwenden mehrerer EK1122 in einer Station lässt sich ein modularer EtherCAT-Sternverteiler realisieren. An den Abzweigports können einzelne Geräte oder auch ganze EtherCAT-Stränge angeschlossen werden. Der Anschluss der EtherCAT-Abzweige erfolgt über RJ-45-Buchsen, an denen direkt Link- und Activity-Status angezeigt werden. Die Run-LED zeigt den Status des EK1122 an. Mit TwinCAT und anderen geeigneten EtherCAT-Mastern unterstützt der EK1122 auch das An- und Abkoppeln von EtherCAT-Strängen im laufenden Betrieb (Hot-Connect).
EK1122-0080
Hot-Connect ist ein EtherCAT-Feature für wechselnde Topologien durch direktes An- oder Abkoppeln während der Anlagenbetriebszeit. Angekoppelte EtherCAT-Komponenten werden zwar nach dem Anschluss schnell in die Datenübertragung aufgenommen, die Fast-Hot-Connect-Technologie verkürzt diese Anbindungszeit jedoch nochmals deutlich, wodurch noch schnellere Werkzeugwechselvorgänge möglich sind. Fast-Hot-Connect-Ports dürfen dabei nur untereinander kombiniert werden, daher sind sie besonders gekennzeichnet.
Der EtherCAT-Abzweig EK1122-0080 mit Fast-Hot-Connect wird durch den EtherCAT-Koppler EK1101-0080 mit Fast-Hot-Connect ergänzt.
Hinweis
Fast-Hot-Connect Ports des EK1122-0080
Im Gegensatz zum EK1122 sind die RJ45-Anschlüsse der FHC-Ports des EK1122-0080 sind mit einer gestrichelten Umrandung markiert (s. Abb. 2) Erläuterungen dazu siehe im Kapitel EtherCAT Fast-Hot-Connect.
Fast-Hot-Connect Ports des EK1122-0080
Anschluss
Klemmstelle | Beschreibung
Bezeichnung
X1/X2 | RJ45-Anschluss für EtherCAT Netze (100BASE-TX-Ethernet-Signaldarstellung)
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Hinweise zu Fast-Hot-Connect
▪
Anwendungshinweise
▪
Diagnose LEDs


Technische Daten

Produktübersicht [image] Abzweig mit RJ45-Anschluss [image] EK1122, EK1122-0080 [image] Technische Daten
Technische Daten
Technische Daten | EK1122 | EK1122-0080
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen | Ankopplung von EtherCAT-Abzweigen, Fast-Hot-Connect Technologie
Übertragungsmedium | Ethernet 100Base-TX (mind. CAT5)
Leitungslänge zwischen 2 Buskopplern | max. 100 m
Protokolle / Baudrate | EtherCAT/ 100 MBaud
Konfiguration | keine Adress- und Konfigurationseinstellung erforderlich
Busanschluss | 1 x RJ45
Spannungsversorgung | aus E-Bus
E-Bus Stromversorgung (5 V) abhängig von Umgebungstemperatur (Bei höherer Stromaufnahme kann zusätzlich die Einspeiseklemme EL9410 verwenden werden!) | max. 2000 mA | max. 2000 mA (-25°C ... +55°C)
 |  | max. 1000 mA (> +55°C)
Stromaufnahme | typ. 220 mA
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (angereiht: 23 mm)
Gewicht | ca. 70 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
 | 0°C ... +55°C (gemäß cULus für Kanada und USA) | -
 | 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen) | -
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE ATEX cULus | CE


Hinweise zur EtherCAT Fast-Hot-Connect Technologie

Produktübersicht [image] Abzweig mit RJ45-Anschluss [image] EK1122, EK1122-0080 [image] Hinweise zur EtherCAT Fast-Hot-Connect Technologie
Hinweise zur EtherCAT Fast-Hot-Connect Technologie
Mit EtherCAT-Komponenten, die Fast-Hot-Connect unterstützen, ist ein deutlich schnellerer Feldbus-Hochlauf nach Verbindungsherstellung möglich. Die Hochlaufzeit ist im Detail abhängig vom Umfang der Geräte, Topologie und aktivierten Distributed Clocks. Benötigt ein normaler Verbindungs- und Kommunikationsaufbau mehrere Sekunden, ist mit FHC-Komponenten < 1 Sekunde möglich.
Eigenschaften und Systemverhalten
▪
Fast-Hot-Connect wird ab TwinCAT 2.11R3 build 2221 unterstützt
▪
Fast-Hot-Connect-Ports sind besonders gekennzeichnet.
Kennzeichnung FHC-Port am EK1122-0080 bzw. EK1101-0080
▪
an Fast-Hot-Connect-Ports dürfen keine Standard-EtherCAT-Geräte angeschlossen werden. Dies ist durch applikationsseitige Maßnahmen sicherzustellen, was durch die in derartigen Applikationen i.d.R. maschinell durchgeführten Topologiewechsel einfach umzusetzen ist.
Empfehlung Kombination Ethernet Ports
▪
Wurden dennoch entsprechende Ports verbunden, ist ggf. ein PowerReset der beteiligten Geräte (Abzweigklemme und Koppler/Box) erforderlich.
▪
Es findet bei Fast-Hot-Connect-Geräten ein beschleunigter Ethernet-Verbindungsaufbau gegenüber der normalen FastEthernet-Verbindung statt.
Wird zusätzlich noch auf den Einsatz von Distributed-Clocks-Funktionen in der gesamten Topologie verzichtet, entfällt auch die Resynchronisierungszeit der Komponenten. Dann sind Gruppenhochlaufzeiten von < 1 Sekunde möglich, vom Stecken der Ethernet-Verbindung bis zum OP-State.
▪
im TwinCAT ADS Logger wird eine falsche Port-Zuordnung detektiert
Konfiguration
Die Konfiguration von Fast-Hot-Connect-Gruppen im TwinCAT Systemmanager erfolgt genauso wie Hot-Connect-Gruppen unter Angabe der zugehörigen Gruppen-ID.
Konfiguration Fast-HotConnect Gruppe
Im TwinCAT-Systemmanager sind entsprechende FastHotConnect-Ports rot gekennzeichnet.
Kennzeichnung im TwinCAT Systemmanager
Eine Konfiguration von FHC-Gruppen ist nur möglich, wenn mindestens 1 entsprechender Abzweig z.B. EK1122-0080 vorhanden ist.
Distributed Clocks
Wenn keine Distributed-Clocks-Funktionen genutzt werden, ist dies in den Master-Einstellungen durch ein fehlenden "DC in use" sichtbar:
DC-Master-Einstellung
Diese Einstellung wird vom Systemmanager automatisch gewählt, wenn keine EtherCAT-Slaves in der Konfiguration enthalten sind, bei denen Distributed Clocks aktiviert ist. Es sollte hier nicht durch den Anwender "DC in use" willkürlich deaktiviert werden, weil sonst diese Teilnehmer nicht mehr funktionieren.


Abzweige mit M8-Anschluss

Produktübersicht [image] Abzweige mit M8-Anschluss
Abzweige mit M8-Anschluss
Weiterführende Informationen
•
EK1122-0008


EK1122-0008

Produktübersicht [image] Abzweige mit M8-Anschluss [image] EK1122-0008
EK1122-0008
Weiterführende Informationen
•
EK1122-0008 - Einführung
•
Technische Daten


EK1122-0008 - Einführung

Produktübersicht [image] Abzweige mit M8-Anschluss [image] EK1122-0008 [image] EK1122-0008 - Einführung
EK1122-0008 - Einführung
EK1122-0008
EK1122-0008
Der 2-Port-EtherCAT-Abzweig ermöglicht es, EtherCAT-Sterntopologien aufzubauen. Durch das Verwenden mehrerer EK1122 in einer Station lässt sich ein modularer EtherCAT-Sternverteiler realisieren. An den Abzweigports können einzelne Geräte oder auch ganze EtherCAT-Stränge angeschlossen werden. Im Vergleich zum EK1122 verfügt der EK1122-0008 statt der beiden RJ45-Buchsen über zwei M8-Buchsen, die kompatibel zu den EtherCAT Boxen ausgeführt sind. Der Anschluss der EtherCAT-Abzweige erfolgt über M8-Buchsen; Link- und Activity-Status werden durch separate LED auf der Frontseite angezeigt. Die Run-LED zeigt den Status des EK1122 an. Mit TwinCAT und anderen geeigneten EtherCAT-Mastern unterstützt der EK1122-0008 auch das An- und Abkoppeln von EtherCAT-Strängen im laufenden Betrieb (Hot-Connect).
Mit entsprechend leistungsfähigen Ethernet-Leitungen z.B. ZK1090-3131-1xxx sind auch über M8 Leitungslängen von 100m möglich.
Anschluss
Klemmstelle | Beschreibung
Bezeichnung
X1 | 2 x M8-Buchse, geschirmt
X2
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Diagnose LEDs


Technische Daten

Produktübersicht [image] Abzweige mit M8-Anschluss [image] EK1122-0008 [image] Technische Daten
Technische Daten
Technische Daten | EK1122-0008
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen über POF
Übertragungsmedium | Ethernet/EtherCAT-Kabel (min. CAT 5), geschirmt
Leitungslänge zwischen 2 Stationen | 100 m (100BASE-TX)
Protokolle / Baudrate | EtherCAT
Konfiguration | Nicht erforderlich
Businterface | 2 x M8-Buchse, geschirmt, schraubbar
Durchlaufverzögerung | ca. 1 µs
Spannungsversorgung | aus E-Bus
Stromaufnahme E-Bus | typ. 220 mA
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (angereiht: 23 mm)
Gewicht | ca. 65 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE


Abzweige mit LWL-Anschluss

Produktübersicht [image] Abzweige mit LWL-Anschluss
Abzweige mit LWL-Anschluss
Weiterführende Informationen
•
EK1521
•
EK1521-0010


EK1521

Produktübersicht [image] Abzweige mit LWL-Anschluss [image] EK1521
EK1521
Weiterführende Informationen
•
EK1521 - Einführung
•
Technische Daten


EK1521 - Einführung

Produktübersicht [image] Abzweige mit LWL-Anschluss [image] EK1521 [image] EK1521 - Einführung
EK1521 - Einführung
EK1521
Der 1-Port-EtherCAT-Multimode-LWL-Abzweig ermöglicht in Verbindung mit einem EtherCAT-Koppler EK1100 die Umsetzung von der 100BASE-TX- auf die 100BASE-FX-Physik (Glasfaser). In Verbindung mit dem EtherCAT-Koppler EK1501 für Multimode-LWL-Glasfaser können so Entfernungen bis zu 2 km überbrückt werden. Auch kabelredundante Systeme mit Lichtwellenleiter lassen sich mit dem 1-Port-EtherCAT-Multimode-LWL-Abzweig realisieren. Die Run-LED zeigt den Status des EK1521.
Anschluss
Klemmstelle | Beschreibung
Bezeichnung
X1 | SC Duplex Stecker
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Anwendungshinweise
▪
Diagnose LEDs


Technische Daten

Produktübersicht [image] Abzweige mit LWL-Anschluss [image] EK1521 [image] Technische Daten
Technische Daten
Technische Daten | EK1521
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen
Übertragungsmedium | Multimode-Glasfaser (MM)
Wellenlänge Transceiver | 1300 nm
Leitungslänge zwischen 2 Buskopplern | 2.000 m (100BASE-FX) Multimode-Glasfaser
Protokolle / Baudrate | sämtliche EtherCAT-Protokolle / 100 MBaud
Konfiguration | keine Adress- und Konfigurationseinstellung erforderlich
Busanschluss | 1 x SC-Duplex-Stecker
Spannungsversorgung | aus E-bus
Stromaufnahme | typ. 350 mA
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (angereiht: 23 mm)
Gewicht | ca. 70 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
 | 0°C ... +55°C (gemäß cULus für Kanada und USA)
 | 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


EK1521-0010

Produktübersicht [image] Abzweige mit LWL-Anschluss [image] EK1521-0010
EK1521-0010
Weiterführende Informationen
•
EK1521-0010 – Einführung
•
Technische Daten


EK1521-0010 – Einführung

Produktübersicht [image] Abzweige mit LWL-Anschluss [image] EK1521-0010 [image] EK1521-0010 – Einführung
EK1521-0010 – Einführung
EK1521-0010
Der 1-Port-EtherCAT-Singlemode-LWL-Abzweig ermöglicht in Verbindung mit einem EtherCAT-Koppler EK110x die Umsetzung von der 100BASE-TX- auf die 100BASE-FX-Physik (Glasfaser). In Verbindung mit dem EtherCAT-Koppler EK1501-0010 für Singlemode-LWL-Glasfaser können so Entfernungen bis zu 20 km überbrückt werden. Auch kabelredundante Systeme mit Lichtwellenleiter lassen sich mit dem 1-Port-EtherCAT-Singlemode-LWL-Abzweig realisieren. Die Run-LED zeigt den Status des EK1521-0010.
Anschluss
Klemmstelle | Beschreibung
Bezeichnung
X1 | SC Duplex Stecker
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Anwendungshinweise
▪
Diagnose LEDs


Technische Daten

Produktübersicht [image] Abzweige mit LWL-Anschluss [image] EK1521-0010 [image] Technische Daten
Technische Daten
Technische Daten | EK1521-0010
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen
Übertragungsmedium | Singleimode-Glasfaser (SM)
Wellenlänge Transceiver | 1300 nm
Leitungslänge zwischen 2 Buskopplern | 20.000 m (100BASE-FX) Singlemode-Glasfaser
Protokolle / Baudrate | sämtliche EtherCAT-Protokolle / 100 MBaud
Konfiguration | keine Adress- und Konfigurationseinstellung erforderlich
Busanschluss | 1 x SC-Duplex-Stecker
Spannungsversorgung | aus E-bus
Stromaufnahme | typ. 350 mA
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (angereiht: 23 mm)
Gewicht | ca. 70 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
 | 0°C ... +55°C (gemäß cULus für Kanada und USA)
 | 0°C ... +55°C (gemäß ATEX, siehe besondere Bedingungen)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Abzweige mit POF-Anschluss

Produktübersicht [image] Abzweige mit POF-Anschluss
Abzweige mit POF-Anschluss
Weiterführende Informationen
•
EK1561


EK1561

Produktübersicht [image] Abzweige mit POF-Anschluss [image] EK1561
EK1561
Weiterführende Informationen
•
EK1561 - Einführung
•
Technische Daten


EK1561 - Einführung

Produktübersicht [image] Abzweige mit POF-Anschluss [image] EK1561 [image] EK1561 - Einführung
EK1561 - Einführung
EK1561
Der 1-Port-EtherCAT-POF-Abzweig EK1561 ermöglicht, in Verbindung mit einem EtherCAT-Koppler EK1100, die Umsetzung von der 100BASE-TX- auf die 100BASE-FX-Physik (POF – Polymeric Optical Fiber). Mit dem EK1561 und dem EtherCAT-Koppler EK1541 für POF können Entfernungen bis zu 50 m zwischen zwei Kopplern überbrückt werden. Die POF-Faser ist, im Gegensatz zur Glasfaser, gut vor Ort konfektionierbar. Die Run-LED zeigt den Status des EK1561 an.
Anschluss
Klemmstelle | Beschreibung
Bezeichnung
X1 | Versatile-Link-Anschluss für POF Duplex Stecker (ZS1090-0008)
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Anwendungshinweise
▪
Diagnose LEDs


Technische Daten

Produktübersicht [image] Abzweige mit POF-Anschluss [image] EK1561 [image] Technische Daten
Technische Daten
Technische Daten | EK1561
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Abzweigen über POF
Übertragungsmedium | Polymeric Optical Fiber
Wellenlänge Transceiver | 650 nm Laser-Klasse 1, siehe Hinweis
Leitungslänge zwischen 2 Stationen | max. 50 m (100BASE-FX) POF
Protokolle / Baudrate | sämtliche EtherCAT-Protokolle / 100 MBaud
Konfiguration | keine Adress- und Konfigurationseinstellung erforderlich
Busanschluss | 1 x Versatile Link für POF-Duplex-Stecker (Steckerset ZS1090-0008)
Durchlaufverzögerung | ca. 1 µs
Spannungsversorgung | aus E-Bus
Stromaufnahme E-Bus | typ. 200 mA
Abmessungen (B x H x T) | ca. 26 mm x 100 mm x 52 mm (angereiht: 23 mm)
Gewicht | ca. 65 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20
Einbaulage | beliebig
Zulassung | CE


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
Funktionsgrundlagen EtherCAT-Abzweige
•
EtherCAT Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
Allgemeine Hinweise zur Watchdog-Einstellung
•
EtherCAT State Machine
•
CoE-Interface: Hinweis
•
EKxxxx - Optionale Distributed Clocks Unterstützung


Funktionsgrundlagen EtherCAT-Abzweige

Grundlagen [image] Funktionsgrundlagen EtherCAT-Abzweige
Funktionsgrundlagen EtherCAT-Abzweige
Es sind einige Beckhoff EtherCAT-Geräte verfügbar, die für Abzweige im EtherCAT-Strang verwendet werden können. Dazu gehören EK1122, EK1521, EP1122 oder auch CU1128. Aufgrund der gleichen Systematik und ähnlichen technischen Eigenschaften dieser Geräte wird in den folgenden Beispielen nur der EK1122 verwendet. test
EtherCAT-Handling in den Slaves
Beim Einsatz von EtherCAT als Feldbusprotokoll sind viele verschiedene Bustopologien anwendbar: Linie-, Stern-, Baumtopologie und mit Redundanz-Unterstützung sogar Ringtopologie. Die einfachste Topologie ist die Linientopologie, bei der jeder EtherCAT-Slave die Daten an den einzigen nächsten weiterreicht, siehe folgende Abbildung „EtherCAT Linientopologie“.
EtherCAT Linientopologie
Beim Einsatz von z. B. EtherCAT-Kopplern EK1100 ist auch ein Abzweig und damit eine Art Baumtopologie möglich, siehe folgende Abbildung „Linientopologie mit Erweiterungen“.
Linientopologie mit Erweiterungen
Grundlegend dabei ist, dass intern der oder die Ethernet-Frame(s) mit den EtherCAT-Protokolldaten weiterhin in einem logischen Ring befördert werden:
▪
der EtherCAT-Master sendet den Frame auf den beiden Hin-Leitungen des Ethernetkabels aus
▪
dieser Frame durchläuft einmalig jeden Slave
▪
wird vom logisch letzten Slave dann gewendet
▪
und auf den beiden Rück-Leitungen des Ethernet-Kabels dann ohne weiteres Processing wieder durch jeden EtherCAT-Slave zum Master zurückbefördert
Bei kurzen Zykluszeiten von z. B. 50 µs sind dabei mindestens 20.000 Ethernet Frames je Sekunde im dem EtherCAT-System unterwegs, zuzüglich azyklischer Organisationsframes. Der Master wartet dabei auf die Rückkehr der ausgesandten Frames, die z. B. die Eingangsdaten der Teilnehmer zum Master zurücktransportieren. Die Weiterleitung der Telegramme von einem Slave zum nächsten ist dabei link-basiert: nur wenn ein "Link"-Signal zum nächsten Teilnehmer besteht, sendet ein EtherCAT-Slave einen Frame weiter. Im Normalfall ist davon auszugehen, dass der nachfolgende Teilnehmer jedes EtherCAT-Telegramm auch korrekt weiterbearbeitet und am Schluss ggf. zurücksendet bzw. weiterleitet.
Entscheidend bei der Weiterleitung von EtherCAT-Telegrammen ist also, dass ein Link-Signal erst dann von einem Slave zum anderen gemeldet wird, wenn beide wirklich bereit sind in Echtzeit an der Datenverarbeitung teilzunehmen. Konkret darf ein EtherCAT-Slave also erst dann den jeweiligen Ethernet-Port öffnen, wenn er umgehend einen Ethernet-Frame annehmen und weiterleiten kann.
Um üblichen Ethernet-Verkehr weiterzuleiten wird i.d.R. ein Switch oder Router eingesetzt. Treten dort Kollisionen oder Frame-Verluste auf, wird dies von übergeordneten Protokollschichten (z. B. TCP) durch Frame-Wiederholung ausgeglichen. Diese Betriebsart ist bei EtherCAT aufgrund der kurzen Zykluszeiten und des Echtzeit-Anspruchs standardmäßig nicht im Einsatz. Einige Ethernet-Geräte wie z. B. spezielle Switche melden bereits einen Link zur Gegenstelle, obwohl sie erst in einigen Millisekunden zur Datenverarbeitung bereit sind. Besonders auffällig wird dieses Verhalten bei Medienkonvertern von 100Base-TX (Kupfer) nach 100Base-Fx (Lichtwellenleiter), die je nach Einstellung auf der Kupferseite zum vorhergehenden EtherCAT-Slave einen Link melden, obwohl die LWL-Verbindung unterbrochen ist.
Deshalb ist die schnelle Link-Detektion ein zentraler Bestandteil eines jeden ESC (EtherCAT Slave Controller, Hardwareverarbeitungseinheit des EtherCAT-Protokolls). Laut EtherCAT-Spezifikation kann ein ESC über 1 bis 4 Ports verfügen, die er von sich aus kontrolliert. Öffnet er einen Port, ist dort abgehender und ankommender Ethernet-Verkehr möglich. Die Datenflussrichtung in einem vollausgebauten ESC ist in Abb. „Datenflussrichtung im ESC“ gezeigt - dabei werden die Daten in den EtherCAT-Datagrammen nur zwischen Port 0 (A) und 3 (D) in der EtherCAT-Processing-Unit verarbeitet.
Datenflussrichtung im ESC
Idealerweise findet die Link-Erkennung und damit das Port-Handling im ESC so schnell statt, dass selbst bei 100 µs Zykluszeit kein Lost-Frame-Ereignis auftritt. Dennoch ist zumindest ein verlorener Frame nie auszuschließen, falls nämlich eine Verbindung getrennt wird, während ein Ethernet-Frame gerade genau auf diesem Kabel bzw. in dem Bussegment hinter der Trennstelle unterwegs ist.
Umsetzung: EL-Klemme
Ein üblicher EtherCAT-Slave wie z. B. Beckhoff EL-Klemmen verfügt über 2 Ports:
▪
einen für ankommende Frames (Port 0 [A])
▪
und einen für abgehende Frames (z. B. Port [D]).
Die anderen beiden Ports sind intern im ESC geschlossen. Ein EtherCAT-Telegramm gelangt über Port 0 (A)/oben zur Processing-Unit und wird dann über Port 3 (D)/links zum nächsten Slave weitergereicht, falls ein Link zu diesem besteht - s. grüne Pfeile. Das ist dann der Fall, wenn rechts eine weitere EL-Klemme gesteckt ist.
Besteht kein Link, wird der Frame über den violetten Weg zum Port 1(B) weitergereicht. Dieser und auch Port 2 (C) haben keinen Link und reichen den Frame damit zum Port 0 (A) zurück, wo der Frame über den gleichen Ethernet-Port über den er am Slave ankam, diesen wieder verlässt. Das ist der Fall, wenn die betrachtete Klemme als Endklemme fungiert.
Ein EtherCAT-Teilnehmer mit nur einem Port ist somit nur begrenzt einsetzbar, da er nur als End-Teilnehmer eingesetzt werden kann.
Umsetzung: EK1100 EtherCAT Koppler
Im EtherCAT-Koppler EK1100 werden 3 von den 4 verfügbaren Ports genutzt und damit ein Anschluss nach rechts zu Klemmen und über eine RJ45-Buchse zu weiteren Kopplern ermöglicht, vgl. Abb. „Linientopologie mit Erweiterungen“. Die Processing-Unit wird im EK1100 nicht zum Prozessdatenaustausch genutzt.
Umsetzung: EK1122 EtherCAT Abzweig
Im EK1122 können alle 4 Ports des ESC verbunden werden. Zwei über den klemmeninternen E-Bus und zwei über die RJ45-Buchsen mit Ethernet-Physik. Im TwinCAT System Manager werden die Link-Stati der Ports 0, 1, 2 und 3 über die Online-Anzeige mitgeteilt - dort werden sie mit Port A, B, C und D bezeichnet, s. Abb. „Topologie Anzeige bei unterbrochener Leitung“.
Umsetzung: EK1521/EK1521-0010/EK1561 EtherCAT Abzweig
Im o.g. Abzweigen können wie im EK1100 3 Ports des ESC verbunden werden. Zwei über den klemmeninternen E-Bus und einer über die SC-Buchse/Versatile Link per LWL-Leitung/POF-Leitung.
Umsetzung: CU1128 EtherCAT Abzweig
Im CU1128 sind 3 ESC integriert, es können somit insgesamt 8 Ports durch Anwender belegt werden. Die 3 ESC sind untereinander über E-Bus verbunden.
Beispielkonfiguration mit EK1122
Im Folgenden soll nun beispielhaft das Linkverhalten unter TwinCAT und seine Darstellung im System Manager erläutert werden.
Beispielkonfiguration
In der TwinCAT Online-Topologie ist der Verdrahtungsplan ersichtlich, s. Abb. „Online Topologie“. Markiert ist darin der EK1122, so dass weitere Informationen dargestellt werden. Die grünen Balken über den Slaves zeigen den ordnungsgemäßen RUN-State in allen Slaves an.
Online Topologie
Nun soll ein Fehler erzeugt werden: die Verbindung der oberen RJ45-Buchse (X1) zur EL3102 wird getrennt. Innerhalb weniger µs erkennt die ESC in der EK1122 den verlorenen Link und schließt den betroffenen Port selbsttätig. Damit wird das nächste ankommende EtherCAT-Telegramm sofort zum Port D (Port 3) und der EL4732 weitergereicht. Damit fehlt hier der Link und der System Manager kennzeichnet dies in der Online-Anzeige, siehe folgende Abbildung „Beispielkonfiguration mit unterbrochener Leitung“.
Beispielkonfiguration mit unterbrochener Leitung
Die Meldungen des System Manager sind wie folgt zu deuten:
▪
Adresse 1002 - EK1122: "OP LNK:MIS D" - Slave ist weiterhin im OP-State, vermisst aber einen laut Konfiguration vorhandenen Link an Port D (3)
▪
Adresse 1003 - EK1100: "INIT NO_COMM" - da keine Kommunikation mehr zu diesem Slave besteht, wird er als im INIT-State befindlich geführt
▪
Adresse 1004 - EL3104: dto.
Hinweis
Logger-Ausgabe
Im unteren Teil des System Managers kann die Logger-Ausgabe eingeblendet werden (Anzeige → Zeige Logger Ausgabe). Dort werden nicht nur bei Linkunterbrechungen hilfreiche Meldungen zur weiteren Interpretation ausgegeben.
In der Topologieansicht zeigt sich diese Unterbrechung durch eine rote Umrandung der betroffenen Slaves, siehe folgende Abbildung „Topologie Anzeige bei unterbrochener Leitung“.
Topologie Anzeige bei unterbrochener Leitung
Man beachte in Abb. „Beispielkonfiguration“ und Abb. „Beispielkonfiguration mit unterbrochener Leitung“ die Anzeige der azyklischen Frames, siehe folgende Abbildung „Gegenüberstellung der Frame-Anzeigen im System Manager“.
Gegenüberstellung der Frame-Anzeigen im System Manager
Im linken Bildauszug sind nur sehr wenige (2) azyklische Frames in der betreffenden Sekunde vom Master ausgesendet worden - alle Slaves sind ordnungsgemäß in Betrieb. Im rechten Bildauszug ist dagegen mit aktuell 77 azyklischen Frames/sec ein deutlicher Anstieg zu verzeichnen: der EtherCAT Master hat schnell erkannt, dass nicht alle Slaves störungsfrei am Datenaustausch teilnehmen. Nachdem er die Störung lokalisiert hat, versucht er nun fortlaufend die Verbindung wiederherzustellen.
Verbindungswiederherstellung
Wird nun in diesem Beispiel die Verbindung wiederhergestellt, meldet der EK1122 an den Master, dass am Port D (3) wieder ein Link anliegt. Der EtherCAT Master wird dann seine Prozessdaten für diesen Abschnitt wieder entsprechend bereitstellen. Wenn die Vorbereitungen abgeschlossen sind, wird er den EK1122 anweisen, den Port D (3) für den regulären Datenaustausch wieder zu öffnen. Der zyklische und azyklische Datenverkehr mit den anderen EtherCAT Slaves läuft dabei selbstverständlich weiter.
Hinweis
Externer Zugriff auf die EtherCAT-Diagnose
Es bestehen umfangreiche Möglichkeiten, aus der PLC heraus auf Zustände, Diagnoseinformationen und Funktionen des EtherCAT-Masters zuzugreifen. Auch über ADS sind fast alle Informationen, die der System Manager online darstellt (s. Abbildungen auf dieser Seite) abrufbar. Ebenso können Aktionen des System Managers über PLC oder ADS ausgelöst werden. Beachten Sie dazu entsprechende Informationen im Beckhoff Information System und Erläuterungen zur EtherCAT Diagnose.


EtherCAT Grundlagen

Grundlagen [image] EtherCAT Grundlagen
EtherCAT Grundlagen
Grundlagen zum EtherCAT Feldbus entnehmen Sie bitte der Dokumentation EtherCAT System Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.
Hinweis
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Achtung
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


Allgemeine Hinweise zur Watchdog-Einstellung

Grundlagen [image] Allgemeine Hinweise zur Watchdog-Einstellung
Allgemeine Hinweise zur Watchdog-Einstellung
Die ELxxxx Klemmen sind mit einer Sicherungseinrichtung (Watchdog) ausgestattet, die z.B. bei unterbrochenem Prozessdatenverkehr nach einer voreinstellbaren Zeit die Ausgänge in einen sicheren Zustand schaltet, in Abhängigkeit vom Gerät und Einstellung z.B. auf AUS.
Der EtherCAT Slave Controller (ESC) verfügt dazu über zwei Watchdogs:
▪
SM-Watchdog (default: 100 ms)
▪
PDI-Watchdog (default: 100 ms)
SM-Watchdog (SyncManagerWatchdog)
Der SyncManager-Watchdog wird bei jeder erfolgreichen EtherCAT-Prozessdaten-Kommunikation mit der Klemme zurückgesetzt. Findet z.B. durch eine Leitungsunterbrechung länger als die eingestellte und aktivierte SM-Watchdog-Zeit keine EtherCAT-Prozessdaten-Kommunikation mit der Klemme statt, löst der Watchdog aus und setzt die Ausgänge auf FALSE. Der OP-Status der Klemme bleibt davon unberührt. Der Watchdog wird erst wieder durch einen erfolgreichen EtherCAT-Prozessdatenzugriff zurückgesetzt. Die Überwachungszeit ist nach u.g. Verfahren einzustellen.
Der SyncManager-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC von der EtherCAT-Seite aus betrachtet.
PDI-Watchdog (Process Data Watchdog)
Findet länger als die eingestellte und aktivierte PDI-Watchdog-Zeit keine PDI-Kommunikation mit dem EtherCAT Slave Controller (ESC) statt, löst dieser Watchdog aus.
PDI (Process Data Interface) ist die interne Schnittstelle des ESC, z.B. zu lokalen Prozessoren im EtherCAT Slave. Mit dem PDI-Watchdog kann diese Kommunikation auf Ausfall überwacht werden.
Der PDI-Watchdog ist also eine Überwachung auf korrekte und rechtzeitige Prozessdatenkommunikation mit dem ESC, aber von der Applikations-Seite aus betrachtet.
Die Einstellungen für SM- und PDI-Watchdog sind im TwinCAT Systemmanager für jeden Slave gesondert vorzunehmen:
Karteireiter EtherCAT -> Erweiterte Einstellungen -> Verhalten --> Watchdog
Anmerkungen:
▪
der Multiplier ist für beide Watchdogs gültig.
▪
jeder Watchdog hat dann noch eine eigene Timereinstellung, die zusammen mit dem Multiplier eine resultierende Zeit ergibt.
▪
Wichtig: die Multiplier/Timer-Einstellung wird nur beim Start in den Slave geladen, wenn die Checkbox davor aktiviert ist.
Ist diese nicht aktiviert, wird nichts herunter geladen und die im ESC befindliche Einstellung bleibt unverändert.
Multiplier
Beide Watchdogs erhalten ihre Impulse aus dem lokalen Klemmentakt, geteilt durch den Watchdog-Multiplier:
1/25 MHz * (Watchdog-Multiplier + 2) = 100 µs (bei Standard-Einstellung 2498 für den Multiplier)
Die Standard Einstellung 1000 für den SM-Watchdog entspricht einer Auslösezeit von 100 ms.
Der Wert in Multiplier + 2 entspricht der Anzahl 40ns-Basisticks, die einen Watchdog-Tick darstellen.
Der Multiplier kann verändert werden, um die Watchdog-Zeit in einem größeren Bereich zu verstellen.
Beispiel "Set SM-Watchdog"
Die Checkbox erlaubt eine manuelle Einstellung der Watchdog-Zeiten. Sind die Ausgänge gesetzt und tritt eine EtherCAT-Kommunikationsunterbrechung auf, löst der SM-Watchdog nach der eingestellten Zeit ein Löschen der Ausgänge aus. Diese Einstellung kann dazu verwendet werden, um eine Klemme an langsame EtherCAT-Master oder sehr lange Zykluszeiten anzupassen. Der Standardwert des SM-Watchdog ist auf 100 ms eingestellt. Der Einstellbereich umfasst 0..65535. Zusammen mit einem Multiplier in einem Bereich von 1..65535 deckt dies einen Watchdog-Zeitraum von 0..~170 Sekunden ab.
Berechnung
Multiplier = 2498 → Watchdog-Basiszeit = 1 / 25 MHz * (2498 + 2) = 0,0001 Sekunden = 100 µs
SM Watchdog = 10000 → 10000 * 100 µs = 1 Sekunde Watchdog-Überwachungszeit
VORSICHT
Ungewolltes Verhalten des Systems möglich!
Die Abschaltung des SM-Watchdog durch SM Watchdog = 0 funktioniert erst in Klemmen ab Version -0016. In vorherigen Versionen wird vom Einsatz dieser Betriebsart abgeraten.
VORSICHT
Beschädigung von Geräten und ungewolltes Verhalten des Systems möglich!
Bei aktiviertem SM-Watchdog und eingetragenem Wert 0 schaltet der Watchdog vollständig ab! Dies ist die Deaktivierung des Watchdogs! Gesetzte Ausgänge werden dann bei einer Kommunikationsunterbrechung NICHT in den sicheren Zustand gesetzt!


EtherCAT State Machine

Grundlagen [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Hinweis
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface: Hinweis

Grundlagen [image] CoE-Interface: Hinweis
CoE-Interface: Hinweis
CoE-Interface
Dieses Gerät hat kein CoE.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


EKxxxx - Optionale Distributed Clocks Unterstützung

Grundlagen [image] EKxxxx - Optionale Distributed Clocks Unterstützung
EKxxxx - Optionale Distributed Clocks Unterstützung
Grundlagen Distributed Clocks (DC)
Das EtherCAT Distributed-Clocks-System umfasst in den EtherCAT Slaves integrierte lokale Uhren, die über spezielle Datagramme vom EtherCAT Master synchronisiert werden. Nicht alle EtherCAT Slaves unterstützen das Distributed Clocks Verfahren, sondern nur Slaves, deren Funktion dieses erfordert. Im TwinCAT Systemmanager zeigt eine Slave seine DC-Fähigkeiten, indem er über einen Einstellungsdialog „DC“ verfügt.
DC-Reiter zur Anzeige der Distributed Clocks Funktion
Eine dieser lokalen Uhren ist die Referenz-Uhr, nach der alle anderen synchronisiert werden. Siehe dazu entsprechende Erläuterungen in der EtherCAT Grundlagendokumentation. Prinzipbedingt muss das der erste DC-fähige EtherCAT Slave sein. Deshalb wählt TwinCAT standardmäßig den ersten DC-fähigen Teilnehmer als Referenzuhr aus. In den erweiterten Eigenschaften des EtherCAT Masters wird dies dargestellt bzw. kann vom Anwender verändert werden. Die Standard-Einstellung soll nicht verändert werden, außer es wird in entsprechenden Dokumentationen z. B. zur externen Synchronisierung empfohlen.
Erweiterte Einstellung Distributed Clocks im EtherCAT Master
In der Abbildung ist zu erkennen, wie TwinCAT standardmäßig die EL1252 als Referenzuhr auswählt, da die vorhergehenden Komponenten kein DC unterstützen.
Einstellung EtherCAT Device
System- und Infrastrukturteilnehmer wie die Koppler und Abzweige EK1100, EK1122 etc. benötigen zur Funktion keine Distributed Clocks. Dennoch kann es topologisch sinnvoll sein, z. B. den ersten Koppler im EtherCAT System als Referenzuhr festzulegen. Deshalb sind die Infrastrukturkomponenten ab einem bestimmten Bauzustand in der Lage als Referenzuhr zu arbeiten, wenn in der Konfiguration besondere Einstellungen vorgenommen werden.
Die Komponenten unterstützen lt. der folg. Tabelle (DC-Unterstützung ab Rev/FW-Stand ) die Aktivierung der Distributed Clocks:
Gerät | XML-Revision in der Konfiguration | Seriennummer der Komponente
BK1150 | ab BK1150-0000-0016 | ab Firmware 01: xxxx01yy
CU1128 | ab CU1128-0000-0000 | ab Firmware 00: xxxx00yy
EK1100 | ab EK1100-0000-0017 | ab Firmware 06: xxxx06yy
EK1101 | ab EK1101-0000-0017 | ab Firmware 01: xxxx01yy
EK1501 | ab EK1501-0000-0017 | ab Firmware 01: xxxx01yy
EK1501-0010 | ab EK1501-0010-0017 | ab Firmware 02: xxxx02yy
EK1122 | ab EK1122-0000-0017 | ab Firmware 01: xxxx02yy
EK1521 | ab EK1521-0000-0018 | ab Firmware 03: xxxx03yy
EK1541 | ab EK1541-0000-0016 | ab Firmware 01: xxxx01yy
EK1561 | ab EK1561-0000-0016 | ab Firmware 01: xxxx01yy
EK1521-0010 | ab EK1521-0010-0018 | ab Firmware 03: xxxx03yy
EK1814 | ab EK1814-0000-0016 | ab Firmware 00: xxxx00yy
Damit TwinCAT eine solche Komponente als DC-Referenzuhr verwendet, ist ein manueller Eingriff bei der Konfigurationserstellung erforderlich, der hier anhand des EK1100 gezeigt wird.
Die Checkboxen „Cyclic Mode Enable“ und „Use as potential Reference Clock“ müssen gesetzt werden.
TwinCAT-Einstellung, um diese Komponente als Referenzuhr zu verwenden
Hinweis
Aktivierung Distributed Clocks Unterstützung
Das hier beschriebene Vorgehen führt nur bei den o.a. Komponenten zum (Synchronisierungs-)Erfolg. Auch bei anderen Komponenten können diese Checkboxen gesetzt werden, die Hardware unterstützt diese Funktion jedoch nicht, wenn nicht entsprechend in der jeweiligen Dokumentation angegeben. Insbesondere darf nach der Inbetriebnahme die Komponente nicht durch eine frühere Version ausgetauscht werden, die den DC-Support nicht leisten kann.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
M8 Anschluss Verkabelung
•
Anzugsdrehmomente für Steckverbinder
•
Montage und Demontage - Frontentriegelung oben
•
Empfohlene Tragschienen
•
Montage von passiven Klemmen
•
ATEX - Besondere Bedingungen


M8 Anschluss Verkabelung

Montage und Verdrahtung [image] M8 Anschluss Verkabelung
M8 Anschluss Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link: http://beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT-Kabel
ZK1090-3131-0xxx
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Hinweis
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
M8 Anschlussbelegung
Signal | Beschreibung | Pin (M8)
Tx+ | Transmit Data+ | 1
Tx- | Transmit Data- | 4
Rx+ | Receive Data+ | 2
Rx- | Receive Data- | 3
Shield | Shielding | Gehäuse


Anzugsdrehmomente für Steckverbinder

Montage und Verdrahtung [image] Anzugsdrehmomente für Steckverbinder
Anzugsdrehmomente für Steckverbinder
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen.
Drehmomentschlüssel
Drehmomentschlüssel, ZB8801
Hinweis
Korrektes Drehmoment sicherstellen
Verwenden Sie die von Beckhoff lieferbaren Drehmomentschlüssel um die Steckverbinder festzuziehen! Diesen finden Sie unter dem nachfolgenden Link.
IP67 Box – Zubehör


Montage und Demontage - Frontentriegelung oben

Montage und Verdrahtung [image] Montage und Demontage - Frontentriegelung oben
Montage und Demontage - Frontentriegelung oben
Die Klemmenmodule werden mit Hilfe einer 35 mm Tragschiene (z.B. Hutschiene TH 35-15) auf der Montagefläche befestigt.
Hinweis
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung der empfohlenen Tragschienen unter den Klemmen flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle

und drücken Sie (1) das Klemmenmodul gegen die Tragschiene, bis es auf der Tragschiene einrastet (2).
▪
Schließen Sie die Leitungen an.
Demontage
▪
Entfernen Sie alle Leitungen.
▪
Ziehen Sie mit Daumen und Zeigefinger die orange Entriegelungslasche (3) zurück. Dabei ziehen sich über einen internen Mechanismus die beiden Rastnasen (3a) an der Hutschiene ins Klemmenmodul zurück.

▪
Ziehen Sie (4) das Klemmenmodul von der Montagefläche weg.


Empfohlene Tragschienen

Montage und Verdrahtung [image] Empfohlene Tragschienen
Empfohlene Tragschienen
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx können Sie auf folgende Tragschienen aufrasten:
Hutschiene TH 35-7.5 mit 1 mm Materialstärke (nach EN 60715)
Hutschiene TH 35-15 mit 1,5 mm Materialstärke
Hinweis
Materialstärke der Hutschiene beachten
Klemmenmodule und EtherCAT-Module der Serien KMxxxx, EMxxxx, sowie Klemmen der Serien EL66xx und EL67xx passen nicht auf die Hutschiene TH 35-15 mit 2,2 bis 2,5 mm Materialstärke (nach EN 60715)!


Montage von passiven Klemmen

Montage und Verdrahtung [image] Montage von passiven Klemmen
Montage von passiven Klemmen
Hinweis
Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für Montage von passiven Klemmen (hell eingefärbt)
Korrekte Konfiguration
Inkorrekte Konfiguration


ATEX - Besondere Bedingungen

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen
ATEX - Besondere Bedingungen
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu Berücksichtigungen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie beim Einsatz von Beckhoff-Feldbuskomponenten in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 - 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx dürfen nur gewechselt werden,
wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden,
wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0: 2006
▪
EN 60079-15: 2005
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten tragen eine der folgenden Kennzeichnungen:
II 3 G Ex nA II T4 KEMA 10ATEX0075 X Ta: 0 - 55°C
oder
II 3 G Ex nA nC IIC T4 KEMA 10ATEX0075 X Ta: 0 - 55°C
Seriennummer
Die Beckhoff-Feldbuskomponenten tragen eine Seriennummer, die wie folgt aufgebaut ist:
WW YY FF HH
WW - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 35 04 1B 01:
35 - Produktionswoche 35
04 - Produktionsjahr 2004
1B - Firmware-Stand 1B
01 - Hardware-Stand 01


Inbetriebnahme/Anwendungshinweise

Inbetriebnahme/Anwendungshinweise
Inbetriebnahme/Anwendungshinweise
Tragschienenmontage
Hinweis
Montage
Beachten Sie, dass der EK1122 bis zum Kontakt mit der Hutschiene aufgeschoben wird und hörbar auf der Hutschiene einrastet. Siehe Tragschienenmontage und Empfohlene Tragschienen.
Weiterführende Informationen
•
Hinweise für Abzweig mit RJ45-Anschluss
•
Hinweise für Abzweig mit M8-Anschluss
•
Hinweise für Abzweig mit LWL-Anschluss
•
Hinweise für Abzweig mit POF-Anschluss
•
Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008


Hinweise für Abzweig mit RJ45-Anschluss

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit RJ45-Anschluss
Hinweise für Abzweig mit RJ45-Anschluss
Weiterführende Informationen
•
Einstellungen und Portzuordnung


Einstellungen und Portzuordnung

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit RJ45-Anschluss [image] Einstellungen und Portzuordnung
Einstellungen und Portzuordnung
Im normalen Betrieb sind am EK1122 keine Einstellungen vorzunehmen.
Die im TwinCAT Systemmanager verwendete Portbezeichnung bildet sich wie folgt auf den EK1122 ab:
Portbezeichnung beim EK1122
Interne und externe Portzuordnung EK1122


Hinweise für Abzweig mit M8-Anschluss

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit M8-Anschluss
Hinweise für Abzweig mit M8-Anschluss
Weiterführende Informationen
•
Einstellungen und Portzuordnung


Einstellungen und Portzuordnung

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit M8-Anschluss [image] Einstellungen und Portzuordnung
Einstellungen und Portzuordnung
Im normalen Betrieb sind am EK1122-0008 keine Einstellungen vorzunehmen.
Die im TwinCAT Systemmanager verwendete Portbezeichnung bildet sich wie folgt auf den EK1122-0008 ab:
Portbezeichnung beim EK1122-0008
Interne und externe Portzuordnung EK1122-0008


Hinweise für Abzweig mit LWL-Anschluss

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit LWL-Anschluss
Hinweise für Abzweig mit LWL-Anschluss
Tragschienenmontage
Hinweis
Montage
Beachten Sie, dass der EK1521, EK1521-0010 bis zum Kontakt mit der Hutschiene aufgeschoben wird und hörbar auf der Hutschiene einrastet. Siehe Tragschienenmontage und Empfohlene Tragschienen.
Weiterführende Informationen
•
Einstellungen und Portzuordnung
•
Hinweise zum verwendbaren LWL-Kabel
•
Einsatz mit dem EK1521 und EL1521-0010


Einstellungen und Portzuordnung

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit LWL-Anschluss [image] Einstellungen und Portzuordnung
Einstellungen und Portzuordnung
Im normalen Betrieb sind am EK1521, EK1521-0010 keine Einstellungen vorzunehmen.
Die im TwinCAT Systemmanager verwendete Portbezeichnung bildet sich wie folgt auf den EK1521, EK1521-0010 ab:
Portbezeichnung EK1521, EK1521-0010
Interne und externe Portzuordnung EK1521, EK1521-0010


Hinweise zum verwendbaren LWL-Kabel

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit LWL-Anschluss [image] Hinweise zum verwendbaren LWL-Kabel
Hinweise zum verwendbaren LWL-Kabel
Allgemeine Informationen zu LWL-Typen
Man unterscheidet bei Lichtwellenleitern (LWL) nach Multimode- und Singlemodetypen und nach Stufen- und Gradientenindex.
Stufen- und Gradientenindex
Lichtwellenleiter bestehen aus 2 konzentrischen Materialien, dem Kern und einer Umhüllung. Dazu kommt noch ggf. ein (farbiger) Schutzmantel. Kern und Umhüllung haben einen unterschiedlichen Brechungsindex, deshalb werden die Lichtwellen (Moden; eine Mode ist eine Eigenwelle im LWL) an der Übergangsstelle reflektiert und in den Kern zurückgeworfen. Durch den sprunghaften Brechungsindexübergang wird diese Faser als Stufenindex bezeichnet. Wird durch Materialvermischung ein allmählicher/parabolischer Übergang vom Kernbrechungsindex zum Mantelbrechungsindex erreicht, wird dies als Gradientenindex bezeichnet. Bei der Gradienteindexfaser werden die Moden allmählich zum Kern zurückgebeugt, dadurch findet ein Laufzeitausgleich statt und die Qualität eines Lichtpulse am Austrittsende ist deutlich besser als bei einer Multimode-Stufenindexfaser, bei der verschiedene Lichtmoden unterschiedlich lange Signallaufzeiten haben (Modendispersion) - eine Flankenverschleifung ist dort die Folge.
Singlemode
Singlemode-Fasern haben einen sehr dünnen Kern (9µm) und leiten deshalb nur eine einzige Mode des verwendeten Lichts mit hoher Signalgüte und fast ohne Modendispersion. Es gibt sie nur als Stufenindexfaser. Durch die hohe Signalgüte eignen sie sich für große Übertragungsbandbreiten > 10 GHz*km und Entfernungen > 50 km. Das Brechzahlprofil von Singlemode-Fasern ist so dimensioniert, dass die bei Multimode-Fasern problematische Mehrwegeausbreitung (intermodale Dispersion) entfällt – das Signallicht breitet sich in einer Singlemode-Faser nur in einem einzigen geführten Wellenleitermodus aus, daher die Bezeichnung single-mode. Damit sind wesentlich größere Übertragungsdistanzen und/oder -bandbreiten möglich, und der als nächstes auftretende limitierende Effekt ist die Farbverzerrung des übertragenen Modus.
Multimode
Multimode-LWL werden als Stufenindex oder Gradientenindex gefertigt. Stufenindex-Multimodefasern eignen sich für Übertragungsbandbreiten bis 100 MHz*km und Entfernungen bis max. 1 km. Gradientenindex-Multimodefasern mit einem Kern von 50 oder 62,5 µm erreichen Übertragungsbandbreiten > 1 GHz*km und Reichweiten > 10 km. Multimode bedeutet, dass der Kern des LWL-Kabels dick genug ist, damit sich mehrere Moden des verwendeten Lichts reflektierend im Kabel fortbewegen können.


Einsatz mit dem EK1521 und EL1521-0010

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit LWL-Anschluss [image] Einsatz mit dem EK1521 und EL1521-0010
Einsatz mit dem EK1521 und EL1521-0010
Einsatz mit dem EK1521 und EL1521-0010
Der EK1521, EK1521-0010 ist zur Kombination mit LWL-Kabeln mit folgenden Eigenschaften bestimmt:
▪
SC Duplex Stecker
▪
EK1521: Duplex Multimode 50/125 µm oder 62,5/125µm (innerer/äußerer Kerndurchmesser). Der Einsatz von beiden Durchmessern ist möglich. Es wird jedoch die Verwendung von 50/125 µm aufgrund der geringeren Dämpfung empfohlen.
▪
EK1521-0010: Duplex Singlemode 9/125 µm (innerer/äußerer Kerndurchmesser). Ein typ. verwendbares Kabel kann nach der Spezifikation ITU-T G.652.D (0.4dBm/km bei 1300nm) gefertigt sein.
Hinweis
Empfohlene Stecker
Es wird der Einsatz von SC/PC -Steckern für die Konnektierung des EK1521, EK1521-0010 empfohlen. Der Vorteil dieser Stecker in "PC" (physical contact) Ausführung ist die ballige Endfläche, so dass beim Zusammenstecken der Stecker der für die Übertragung relevante Bereich des Faserkerns optimal verbunden wird. Weitere Ausführungen sind z. B. SC/UPC (ultrapolish PC), SC/HRL (high return loss) oder SC/APC-Stecker (angled physical contact). Bei diesen Steckern wird zusätzlich durch die mit ca. 8° zur Faserachse angewinkelte Steckerendfläche reflektiertes Licht aus dem Kern über das Mantelglas in die Luft hinaus gebrochen, was Störungen in der Datenübertragung vermeidet und die Kerngröße der Rückstreuung optimiert.
Hinweis
50/125 µm oder 62,5/125 µm
Der Einsatz von beiden Durchmessern ist möglich. Es wird jedoch die Verwendung von 50/125 µm aufgrund der geringeren Dämpfung empfohlen.
Im LWL-Bereich werden üblicherweise die Wellenlängen 850 und 1300 nm für die Datenübertragung verwendet. Die am Markt verfügbaren Glasfaserkabel sind meist zur Verwendung in einem dieser Bereiche optimiert, da die Die Dämpfung des Signals ist (wie auch im Kupferkabel) frequenzabhängig ist - damit werden dann mit der jeweiligen Wellenlänge große Reichweiten von mehreren km erzielt. Allgemein weisen Glasfaserkabel im 1300 nm-Fenster eine geringere Dämpfung auf als im 850 nm-Fenster.
Im EK1521, EK1521-0010 wird ein Transceiver mit der Wellenlänge 1300 nm eingesetzt.
Hinweis
Reichweite und Bandbreitenprodukt
LWL-Kabel sind in verschiedenen Qualitäten von namhaften Herstellern erhältlich. Für den Anwender maßgebend ist u.a. das frequenzabhängige Bandbreitenprodukt eines Kabels, angegeben in [MHz*km. Je größer das Bandbreitenprodukt, desto geringer ist die Dämpfung - damit steigt die mit diesem Leiter erzielbare Reichweite (s. ITU-T G-651). Zur Erzielung der maximalen Reichweite mit dem EK1521, EK1521-0010 sind deshalb Lichtwellenleiter mit einem möglichst hohen Bandbreitenprodukt bei 1300 nm zu verwenden - empfohlen wird ein Einsatz von LWL der Klasse OM2 (EN50173:2002).Standard-LWL verfügen über ein Bandbreitenprodukt von mindestens 500 MHz*km bei 1300 nm, höherwertigere für Entfernungen > 500 m über > 1000 MHz*km.Um die Maximalreichweiten zu erzielen, muss die Gegenstelle zum EK1521, EK1521-0010 ebenfalls solche Reichweiten unterstützen.
Hinweis
Verlegehinweise
•
zulässiger Biegeradius
•
zulässige Zugfestigkeit
•
Empfindlichkeit der ungeschützten Kontaktenden
Zur weiteren Information können folgende weitere Quellen dienlich sein:
▪
ITU Empfehlung ITU-T G.651 - G.655
▪
EN 50173:2002
▪
EN 60793-2
Konnektieren und Lösen des LWL-Kabels am Abzweig
Achtung
Beschädigung des Kabels möglich!
Zur Demontage des LWL-Kabels nur am Stecker ziehen, der die Verriegelung löst - niemals am LWL-Kabel allein!
Hinweis
Gekreuzte Kabel
Beachten Sie, dass bei der Verbindung der EK1521, EK1521-0010 zum EK1501/ EK1501-0010 ggf. "gekreuzte" Kabel verwendet werden müssen um eine Verbindung herzustellen.
Praxistipp:
Der infrarote Lichtaustritt kann mittels einer Digital-/Handykamera am Abzweig bzw. am Koppler sichtbar gemacht werden (siehe Abbildung). Stellen Sie sicher, dass beim Stecken der LWL-Leitung nicht "Licht auf Licht" trifft (Tx → Tx). In diesem Fall kann keine Verbindung aufgebaut werden und die Kabel sind zu kreuzen (Tx → Rx).

Abbildung: Visualisierung von infrarotem Licht am SC Duplex Stecker
Hinweis
Verwendung von Blindstopfen
Zum Schutz des Transceivers vor Umwelteinflüssen sollten nicht verwendete Anschlussbuchsen mit den mitgelieferten Blindstopfen verschlossen werden!

Abbildung: Blindstopfen in nicht verwendeten Anschlussbuchsen


Hinweise für Abzweig mit POF-Anschluss

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit POF-Anschluss
Hinweise für Abzweig mit POF-Anschluss
Tragschienenmontage
Hinweis
Montage
Beachten Sie, dass der EK1561 bis zum Kontakt mit der Hutschiene aufgeschoben wird und hörbar auf der Hutschiene einrastet. Siehe Tragschienenmontage und Empfohlene Tragschienen.
Weiterführende Informationen
•
Einstellungen und Portzuordnung
•
Hinweise zum verwendbaren POF-Kabel
•
Einsatz mit dem EK1561


Einstellungen und Portzuordnung

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit POF-Anschluss [image] Einstellungen und Portzuordnung
Einstellungen und Portzuordnung
Im normalen Betrieb sind am EK1561 keine Einstellungen vorzunehmen.
Die im TwinCAT Systemmanager verwendete Portbezeichnung bildet sich wie folgt auf den EK1561 ab:
Portbezeichnung EK1561
Interne und externe Portzuordnung EK1561


Hinweise zum verwendbaren POF-Kabel

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit POF-Anschluss [image] Hinweise zum verwendbaren POF-Kabel
Hinweise zum verwendbaren POF-Kabel
Allgemeine Informationen POF-Kabel
Die Standard-Polymerfaser ist 1 mm dick und besteht aus einem 0,98 mm dicken Kern aus Polymethylmethacrylat (PMMA) sowie einem dünnen Mantel. Um eine Lichtführung durch den Effekt der Totalreflexion im Kern zu ermöglichen, besteht der meist sehr dünne Mantel aus fluoriertem PMMA, welches einen geringeren Brechungsindex aufweist. Die Kerndurchmesser bewegen sich zwischen 0,06 und 1 mm, wodurch einfache Steckverbindungen unproblematisch zu realisieren sind. Weiterhin kann somit auf das zur Verbindung von Glasfasern häufig eingesetzte Spleißverfahren, und dem damit verbundenen unnötig hohen Aufwand, in der Regel verzichtet werden. Die maximale Einsatztemperatur von Standard-POF liegt bei etwa 60 °C und hat ein Brechungsprofil mit Stufenindex (SI-POF). Der Brechungsindex des Kernmaterials liegt bei 1,49, der des Mantels bei 1,41. Die Differenz bestimmt die numerische Apertur (NA) und damit den maximalen Ausbreitungswinkel. Dieser liegt bei einer Differenz von 5 % bei etwa 20 Grad gegenüber der Faserachse, was zur Reduzierung der Bandbreite führt.
Aufgrund der im Vergleich zur Glasfaser einfachen und nahezu universell einsetzbaren Verbindungstechniken finden POF insbesondere Anwendung bei kurzen Datenübertragungsstrecken, so beispielsweise innerhalb von Räumen, technischen Geräten, mechanischen Anlagen oder auch Personenkraftwagen.
Die POF haben eine Dämpfung von etwa 140 dB/km bei einer Wellenlänge von 650 nm, so dass bei der Anwendung mit dem EK1561 eine Datenübertragungstrecke von max. 50 m zu erreichen ist.
Werden zusätzliche Steckverbindungen in die Strecke eingebracht, vergrößert dies die Signaldämpfung. Je zusätzlichem Steckverbinder reduziert sich somit die zulässige max. Streckenlänge um typ. 6,5 m.


Einsatz mit dem EK1561

Inbetriebnahme/Anwendungshinweise [image] Hinweise für Abzweig mit POF-Anschluss [image] Einsatz mit dem EK1561
Einsatz mit dem EK1561
Hinweis
Empfohlene Stecker und POF-Kabel
Es wird der Einsatz des bei Beckhoff erhältlichen Steckersets ZS1090-0008 (Versatile Link Duplex-Stecker) in Verbindung mit einer Duplex-Polymerfaser 2 x 2,2 mm Außendurchmesser (Z1190) für die Konnektierung des EK1561 empfohlen.
Hinweis
Verlegehinweise
•
zulässiger Biegeradius (im Allgemeinen gilt r ≥ 25 mm, Herstellerangaben beachten!)
•
zulässige Zugfestigkeit
•
Empfindlichkeit der ungeschützten Kontaktenden
Konnektieren und Lösen des POF-Kabels am Abzweig
Zum Konnektieren des Kabels schieben Sie den Stecker (als Zubehör im Steckerset ZS1090-0008 erhältlich) bis zum hörbaren Einrasten in die Anschlussöffnung.
Rastnase mit Entriegelung am POF-Duplex-Stecker
Zum Lösen des Steckers die Entriegelung mit der Rastnase betätigen. Diese befindet sich dabei rechtseitig am Stecker (siehe Abb. „Rastnase mit Entriegelung am POF-Duplex-Stecker“)
Achtung
Beschädigung des Kabels möglich!
Zum Lösen des Kabels die Entriegelung am Stecker drücken und gleichzeitig am Stecker ziehen - niemals am POF-Kabel allein!
Achtung
Tx / Rx -Kanalbelegung
Achten Sie bei der Kabelkonfektionierung auf die Belegung der optischen Kanäle in der Anschlussbuchse. Beim EK1561 ist der lichtemittierende Transmitterkanal (Tx) der obere Auslass in der Anschlussbuchse.

Abbildung: Transmitterkanal beim EK1561
Beachten Sie unbedingt den Sicherheitshinweis zur Laser-Klasse 1!
Achtung
Verwendung von Blindstopfen
Zur Vermeidung von Unfällen durch Blendung (Laserstrahl Klasse 1, bitte Sicherheitshinweis beachten) und zum Schutz des Transceivers vor Umwelteinflüssen sollten nicht verwendete Anschlussbuchsen mit den mitgelieferten Blindstopfen verschlossen werden!

Abbildung: Blindstopfen in nicht verwendeten Anschlussbuchsenn


Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008

Inbetriebnahme/Anwendungshinweise [image] Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008
Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008
Duplex-Steckerset ZS1090-0008
Das Duplex-Steckerset ZS1090-0008 von Beckhoff besteht aus 10 Duplex Versatile-Link-Steckverbindern und mehreren Bögen Schleif- und Polierpapier.
Schritt-für-Schritt-Anleitung zur Konfektionierung des POF-Kabels
Die nachfolgende Schritt-für-Schritt-Anleitung beschreibt die korrekte Konfektionierung eines POF-Kabels mit einem Versatile-Link-Duplex-Steckverbinder. Die Steckverbinder werden mit Standard-Werkzeugen wie Cutter-Messer oder Abisolierzange an die Kabelenden angebracht. Die Endpolitur des konfektionierten Kabels wird mit dem im Steckerset beigefügten Polierset, bestehend aus einer Plastik-Schleiflehre, Schleifpapierbögen mit der Körnung 600 und rosa Polierbögen durchgeführt. Die konfektionierte Steckverbindung kann sofort nach der Bearbeitung benutzt werden.
Für die Arbeitsschritte benötigtes Material:
1. POF-Kabel (Polymeric optical fiber, z.B. Z1190 von Beckhoff)
2. Cutter-Messer oder Schere
3. Abisolierzange
4. Polierset (im Steckerset ZS1090-0008 von Beckhoff enthalten)
5. Versatile Link Duplex-Stecker (im Steckerset ZS1090-0008 von Beckhoff enthalten)
1. Abisolieren des POF-Kabels
Das Kabel sollte auf einer Länge zwischen 100 und 150 mm vom Kabelende aufgetrennt sein, um die nachfolgenden Arbeiten ordnungsgemäß durchführen zu können.
Nachdem Sie das Kabel auf die gewünschte Länge gekürzt haben, entfernen sie mittels Abisolierzange ca. 7 mm der äußeren Ummantelung der Einzeladern. Die beiden Kabelenden sollten ungefähr gleich lang abisoliert sein.
POF-Kabel auf gleiche Länge abisoliert
2. Anbringen des Steckverbinders
Schieben Sie beide Kabelenden in den Steckverbinder und ziehen Sie den Steckverbinder bis zum Anschlag zurück. Die Fasern sollten jetzt nicht mehr als 1,5 mm aus den vorderen Öffnungen herausragen.
Sie schließen den Steckverbinder, indem Sie die obere und untere Hälfte zusammenklappen und einrasten lassen.
In den Steckverbinder eingelegtes Kabel
Geschlossener Steckverbinder
Achten Sie beim Einlegen der Leiter in die Steckverbinder auf die gekreuzte Verbindung der optischen Kanäle zur Gegenseite (Tx1 → Rx2; Tx2 → Rx1). Als Orientierung dient die Nase des Scharniers am Stecker.
Korrekt verbundene Optische Kanäle
3. Schleifen und Polieren
Fasern, die mehr als 1,5 mm aus dem Steckverbinder herausragen, müssen mit einem Cutter-Messer oder einer Schere eingekürzt werden.
Schieben Sie nun den Steckverbinder komplett in die Schleiflehre, so dass die zu polierenden Enden auf der unteren Seite herausragen. Die Schleiflehre ist zum Polieren von einem oder zwei Simplex- oder einem Duplex-Steckverbinder geeignet.
Schleiflehre mit herausragenden Faserenden
Hinweis
Verschleißanzeige
Die Verschleißanzeige der Schleiflehre besteht aus 4 Punkten auf der Unterseite. Sollte einer dieser Punkte nicht mehr sichtbar sein, ist die Schleiflehre zu ersetzen.
Pressen Sie nun mit gleichmäßigen Druck und möglichst senkrecht die Schleiflehre auf das Schleifpapier. Um ein gleichmäßiges Schleifergebnis zu erzielen, beschreiben Sie beim Schleifen die Form einer "8", bis die Fasern bündig mit der Schleiflehre abschließen. Anschließend reinigen Sie die Schleiflehre und den Steckverbinder von unten mit einem weichen, trockenen Tuch.
Polieren in Form einer "8"
4. Feinpolitur
Fahren Sie nun mit der Feinpolitur und dem rosa Polierbogen in gleicher Art und Weise fort. Dazu den bündigen Steckverbinder mit der Schleiflehre auf der matten Seite des Polierbogens mit leichtem Druck aufsetzen und die Form einer "8" maximal 25 mal beschreiben. Nach Abschluss der Prozedur sollte das Faserende flach, glatt und sauber sein.
Hinweis
Verbesserung der Übertragungsperformance durch Feinpolitur
Die Feinpolitur mit dem Polierbogen bringt eine Verbesserung der Übertragungsperformance von Transmitter zu Receiver oder in der Kabelverbindung von bis zu 0,5 dB gegenüber der Behandlung nur mit dem Schleifbogen allein. Der Arbeitsschritt des Polierens kann allerdings für kurze Übertragungsentfernungen ausgelassen werden.
Feinpolierte Fasern im Steckverbinder


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
Diagnose-LEDs EK1122, EK1122-0008
•
Diagnose-LEDs EK1521, EK1521-0010
•
Diagnose-LEDs EK1561


Diagnose-LEDs EK1122, EK1122-0008

Fehlerbehandlung und Diagnose [image] Diagnose-LEDs EK1122, EK1122-0008
Diagnose-LEDs EK1122, EK1122-0008

LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1/X2) | grün | aus | - | keine Verbindung auf dem EtherCAT-Strang
 |  | an | linked | EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit EtherCAT-Teilnehmer
LED Diagnose EtherCAT State Machine
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | Einzelblitz | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | blinkend | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme


Diagnose-LEDs EK1521, EK1521-0010

Fehlerbehandlung und Diagnose [image] Diagnose-LEDs EK1521, EK1521-0010
Diagnose-LEDs EK1521, EK1521-0010

LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1) | grün | aus | - | keine Verbindung auf dem EtherCAT-Strang
 |  | an | linked | EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit EtherCAT-Teilnehmer
LED Diagnose EtherCAT State Machine
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | Einzelblitz | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | blinkend | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme


Diagnose-LEDs EK1561

Fehlerbehandlung und Diagnose [image] Diagnose-LEDs EK1561
Diagnose-LEDs EK1561
LEDs zur Feldbus-Diagnose
LED | Farbe | Anzeige | Zustand | Beschreibung
LINK / ACT (X1) | grün | aus | - | keine Verbindung auf dem EtherCAT-Strang
 |  | an | linked | EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit EtherCAT-Teilnehmer
LED Diagnose EtherCAT State Machine
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | Einzelblitz | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | blinkend | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | flimmernd | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
•
UL Hinweise
•
ATEX-Dokumentation
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
Support und Service


Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1

Anhang [image] Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
VORSICHT
Laser-Klasse 1 Produkt - Unfallgefahr durch Blendung!
Folgende laserspezifische Verhaltensregeln sind für die in dieser Dokumentation beschriebenen Produkte der Laser-Klasse 1 zu beachten:
•
Der Laserstrahl darf nicht auf Personen gerichtet werden, da es durch Blendung zu Unfällen kommen kann.
•
Nicht in den direkten oder reflektierten Strahl blicken.
•
Falls Laserstrahlung ins Auge trifft, sind die Augen bewusst zu schließen und der Kopf sofort aus dem Strahl zu bewegen.
•
Bei der Verwendung des Lasers dürfen keine optischen Instrumente zur Betrachtung der Strahlungsquelle verwendet werden, da dies zu einer Überschreitung der Expositionsgrenzwerte führen kann.
•
Manipulationen (Änderungen) an der Lasereinrichtung sind unzulässig.


UL Hinweise

Anhang [image] UL Hinweise
UL Hinweise
Symbol cULus
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
Symbol cULus
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
Symbol cULus
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1. UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2. UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


ATEX-Dokumentation

Anhang [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweis
Hinweise zum Einsatz des Busklemmensystems in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation Hinweise zum Einsatz des Busklemmen-Systems in explosionsgefährdeten Bereichen (ATEX) die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Die Koppler EK1122 und EK15xx verfügen über keine Firmware.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung zu speichern, in einem sog. EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien (EtherCAT Slave Information) als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Achtung
ACHTUNG: Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten
• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Gerätebeschreibung ESI-File/XML
Achtung
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Hinweis
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg, die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT Modus Config/Freerun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt im Config/FreeRun-Mode das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Einwandfreie EtherCAT-Kommunikation muss zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. „EEPROM Update“
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. „Auswahl des neuen ESI“. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave'.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Hinweis
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
Hinweis
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.

Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. „Anzeige FW-Stand EL3204“ wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.
Update Controller-Firmware *.efw
Hinweis
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update i.allg. nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. „Firmware Update“.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen.
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei
▪
Nach Beendigung des Download in INIT schalten, dann in OP
▪
Slave kurz stromlos schalten
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmwarekomponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu "Eigenschaften" (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog "Advanced settings"
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmwarestände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und
kicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen.
Dialog "Weitere Eimstellungen" wählen
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA,
Dialog "Schreibe FPGA" wählen
Datei auswählen
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät.
Achtung
ACHTUNG: Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!
Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich.
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Vorraussetzung hierfür ist, das für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie den FW-Update im BOOTSTRAP Modus wie o.a. aus.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.