EK1110 - EtherCAT-Verlängerung
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.3
▪
Technische Daten aktualisiert
▪
Update Struktur
2.2
▪
Technische Daten aktualisiert
▪
Update Struktur
2.1
▪
EK1110-0008 ergänzt
2.0
▪
Migration
1.4
▪
Technische Daten ergänzt
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
1.3
▪
Technische Daten ergänzt
▪
Update Struktur
1.2
▪
Technische Daten ergänzt
1.1
▪
Technische Daten angepasst
1.0
▪
Technische Daten ergänzt
0.1
▪
Erste vorläufige Version


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Start


Einführung

Produktübersicht [image] Einführung
Einführung
EtherCAT-Verlängerung EK1110/ EK1110-0008
EK1110/ EK1110-0008
Die EtherCAT-Verlängerung EK1110 bzw. EK1110-0008 wird, wie die E-Bus-Endklemme, an das Ende des EtherCAT-Klemmenblocks gesteckt. Die Klemme bietet die Möglichkeit, ein Ethernet-Kabel mit RJ-45-Stecker bzw. M8- Stecker anzustecken und damit den EtherCAT-Strang galvanisch getrennt um bis zu 100 m zu verlängern. In der EK1110 (EK1110-0008) Klemme werden die E-Bus-Signale im Durchlauf auf 100BASE-TX-Ethernet-Signaldarstellung umgesetzt. Die Elektronik der beiden Verlängerungen wird über den E-Bus versorgt. Es sind keine Parametrier- oder Konfigurationsarbeiten erforderlich.
Die M8-Buchse vom EK1110-0008 ist kompatibel zu den EtherCAT-Box-Modulen ausgeführt. Mit entsprechend leistungsfähigen Ethernet-Leitungen, z. B. ZK1090-3131-1xxx, sind auch über M8 Leitungslängen von 100 m möglich.
Anschluss
Klemmstelle | Beschreibung | Typ
Bezeichnung |  | EK1110 | EK1110-0008
X1 | Anschluss für EtherCAT Netze (100BASE-TX-Ethernet-Signaldarstellung) | RJ45 | M8


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | EK1110 | EK1110-0008
Aufgabe im EtherCAT-System | Umsetzung der E-Bus-Signale auf 100BASE-TX-Ethernet zur Verlängerung des EtherCAT-Netzes
Übertragungsmedium | Ethernet CAT-5 Kabel (geschirmt)
Leitungslänge zwischen 2 Buskopplern | max. 100 m (100BASE-TX)
Protokolle / Baudrate | sämtliche EtherCAT-Protokolle / 100 MBaud
Durchlaufverzögerung | ca. 1 µs
Konfiguration | keine Adress- und Konfigurationseinstellung erforderlich
Busanschluss | 1 x RJ45 | 1 x M8-Buchse, geschirmt, schraubbar
Spannungsversorgung | aus E-bus
Stromaufnahme | typ. 130 mA
Spannungsfestigkeit | 500 V (Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
Gewicht | ca. 50 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung:
▪
montieren Sie den EK1110 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den EK1110 in TwinCAT wie im Kapitel Parametrierung und Inbetriebnahme beschrieben.


Grundlagen der Kommunikation

Grundlagen der Kommunikation
Grundlagen der Kommunikation
Weiterführende Informationen
•
Systemeigenschaften
•
EtherCAT-Grundlagen
•
EtherCAT-Verkabelung - Drahtgebunden
•
EtherCAT State Machine
•
CoE-Interface: Hinweis
•
Distributed Clock


Systemeigenschaften

Grundlagen der Kommunikation [image] Systemeigenschaften
Systemeigenschaften
Protokoll
Das für Prozessdaten optimierte EtherCAT-Protokoll wird dank eines speziellen Ether-Types direkt im Ethernet-Frame transportiert. Es kann aus mehreren Sub-Telegrammen bestehen, die jeweils einen Speicherbereich des bis zu 4 Gigabyte großen logischen Prozessabbildes bedienen. Die datentechnische Reihenfolge ist dabei unabhängig von der physikalischen Reihenfolge der Ethernet-Klemmen im Netz, es kann wahlfrei adressiert werden. Broadcast, Multicast und Querkommunikation zwischen Slaves sind möglich. Die Übertragung direkt im Ethernet-Frame wird stets dann eingesetzt, wenn EtherCAT-Komponenten im gleichen Subnetz wie der Steuerungsrechner betrieben werden.
Der Einsatzbereich von EtherCAT ist jedoch nicht auf ein Subnetz beschränkt: EtherCAT UDP verpackt das EtherCAT Protokoll in UDP/IP-Datagramme. Hiermit kann jede Steuerung mit Ethernet-Protokoll-Stack EtherCAT-Systeme ansprechen. Selbst die Kommunikation über Router hinweg in andere Subnetze ist möglich. Selbstverständlich hängt die Leistungsfähigkeit des Systems in dieser Variante von den Echtzeiteigenschaften der Steuerung und ihrer Ethernet-Protokollimplementierung ab. Die Antwortzeiten des EtherCAT-Netzwerks an sich werden jedoch nur minimal eingeschränkt: lediglich in der ersten Station muss das UDP-Datagramm entpackt werden.
EtherCAT Telegramm Struktur
Protokollstruktur: Die Prozessabbild-Zuordnung ist frei konfigurierbar. Daten werden direkt in der E/A-Klemme an die gewünschte Stelle des Prozessabbilds kopiert: zusätzliches Mapping ist überflüssig. Der zur Verfügung stehende logische Adressraum ist mit 4 Gigabyte sehr groß.
Topologie
Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Die von den Feldbussen her bekannte Bus- oder Linienstruktur wird damit auch für Ethernet verfügbar. Besonders praktisch für die Anlagenverdrahtung ist die Kombination aus Linie und Abzweigen bzw. Stichleitungen. Die hierzu benötigten Schnittstellen sind auf den Kopplern vorhanden; zusätzliche Switches werden nicht benötigt. Natürlich kann aber auch die klassische Switch-basierte Ethernet-Sterntopologie eingesetzt werden.
EtherCAT Topologie
Maximale Flexibilität bei der Verdrahtung:
mit und ohne Switch, Linien- und Baumtopologien frei wähl- und kombinierbar.
Die maximale Flexibilität bei der Verdrahtung wird durch die Auswahl verschiedener Leitungen vervollständigt. Flexible und sehr preiswerte Standard Ethernet-Patch-Kabel übertragen die Signale auf Ethernet-Art (100Base-TX). Die gesamte Bandbreite der Ethernet-Vernetzung – wie verschiedenste Lichtleiter und Kupferkabel – kann in der Kombination mit Switches oder Medienumsetzern zum Einsatz kommen.
Distributed Clocks
Der exakten Synchronisierung kommt immer dann eine besondere Bedeutung zu, wenn räumlich verteilte Prozesse gleichzeitige Aktionen erfordern. Das kann z. B. in Applikationen der Fall sein, wo mehrere Servo-Achsen gleichzeitig koordinierte Bewegungen ausführen.
Der leistungsfähigste Ansatz zur Synchronisierung ist der exakte Abgleich verteilter Uhren – wie im neuen Standard IEEE 1588 beschrieben. Im Gegensatz zur vollsynchronen Kommunikation, deren Synchronisationsqualität bei Kommunikationsstörungen sofort leidet, verfügen verteilte abgeglichene Uhren über ein hohes Maß an Toleranz gegenüber möglichen störungsbedingten Verzögerungen im Kommunikationssystem.
Beim EtherCAT basiert der Datenaustausch vollständig auf einer reinen Hardware-Maschine. Da die Kommunikation eine logische (und dank Vollduplex-Fast-Ethernet auch physikalische) Ringstruktur nutzt, kann die Mutter-Uhr den Laufzeitversatz zu den einzelnen Tochter-Uhren einfach und exakt ermitteln – und umgekehrt. Auf Basis dieses Wertes werden die verteilten Uhren nachgeführt und es steht eine hochgenaue netzwerkweite Zeitbasis zur Verfügung, deren Jitter deutlich unter einer Mikrosekunde beträgt.
Hochauflösende verteilte Uhren dienen aber nicht nur der Synchronisierung, sondern können auch exakte Informationen zum lokalen Zeitpunkt der Datenerfassung liefern. Steuerungen berechnen beispielsweise häufig Geschwindigkeiten aus nacheinander gemessenen Positionen. Speziell bei sehr kurzen Abtastzeiten führt schon ein kleiner zeitlicher Jitter in der Wegerfassung zu großen Geschwindigkeitssprüngen. Konsequenterweise werden mit EtherCAT auch neue, erweiterte Datentypen eingeführt (Timestamp und Oversampling Data Type). Mit dem Messwert wird die lokale Zeit mit einer Auflösung von bis zu 10 ns verknüpft - die große Bandbreite von Ethernet macht das möglich. Damit hängt dann die Genauigkeit einer Geschwindigkeitsberechnung nicht mehr vom Jitter des Kommunikationssystems ab. Sie wird um Größenordnungen besser als diejenige von Messverfahren, die auf jitterfreier Kommunikation basieren.
Performance
Mit EtherCAT werden neue Dimensionen in der Netzwerk-Performance erreicht. Dank FMMU-Chip in der Klemme und DMA-Zugriff auf die Netzwerkkarte des Masters erfolgt die gesamte Protokollbearbeitung in Hardware. Sie ist damit unabhängig von der Laufzeit von Protokoll-Stacks, von CPU-Performance oder Software-Implementierung. Die Update-Zeit für 1000 E/As beträgt nur 30 µs – einschließlich Klemmen-Durchlaufzeit. Mit einem einzigen Ethernet-Frame können bis zu 1486 Bytes Prozessdaten ausgetauscht werden – das entspricht fast 12000 digitalen Ein- und Ausgängen. Für die Übertragung dieser Datenmenge werden dabei nur 300 µs benötigt.
Für die Kommunikation mit 100 Servoachsen werden nur 100 µs benötigt. In dieser Zeit werden alle Achsen mit Sollwerten und Steuerdaten versehen und melden ihre Ist-Position und Status. Mit den Distributed-Clocks können die Achsen dabei mit einer Abweichung von deutlich weniger als einer Mikrosekunde synchronisiert werden.
Die extrem hohe Performance der EtherCAT-Technologie ermöglicht Steuerungs- und Regelungskonzepte, die mit klassischen Feldbussystemen nicht realisierbar waren. So kann beispielsweise nicht nur die Geschwindigkeitsregelung, sondern neu auch die Stromregelung verteilter Antriebe über das Ethernet-System erfolgen. Die enorme Bandbreite erlaubt es, zu jedem Datum z. B. auch Status-Informationen zu übertragen. Mit EtherCAT steht eine Kommunikationstechnologie zur Verfügung, die der überlegenen Rechenleistung moderner Industrie-PCs entspricht. Das Bussystem ist nicht mehr der Flaschenhals im Steuerungskonzept. Verteilte E/As werden schneller erfasst, als dies mit den meisten lokalen E/A-Schnittstellen möglich ist. Das EtherCAT Technologieprinzip ist skalierbar und nicht an die Baudrate von 100 MBaud gebunden – eine Erweiterung auf GBit Ethernet ist möglich.
Diagnose
Die Erfahrungen mit Feldbussystemen zeigen, dass die Verfügbarkeit und Inbetriebnahme Zeiten entscheidend von der Diagnosefähigkeit abhängen. Nur eine schnelle und präzise erkannte und eindeutig lokalisierbare Störung kann kurzfristig behoben werden. Deshalb wurde bei der Entwicklung des EtherCAT-Systems besonderer Wert auf vorbildliche Diagnoseeigenschaften gelegt.
Bei der Inbetriebnahme gilt es zu prüfen, ob die Ist-Konfiguration der E/A-Klemmen mit der Soll-Konfiguration übereinstimmt. Auch die Topologie sollte der gespeicherten Konfiguration entsprechen. Durch die eingebaute Topologie-Erkennung bis hinunter zu den einzelnen Klemmen kann nicht nur diese Überprüfung beim Systemstart stattfinden – auch ein automatisches Einlesen des Netzwerkes ist möglich (Konfigurations-Upload).
Bitfehler in der Übertragung werden durch die Auswertung der CRC-Prüfsumme zuverlässig erkannt: das 32 Bit CRC-Polynom weist eine minimale Hamming-Distanz von 4 auf. Neben der Bruchstellenerkennung und -lokalisierung erlauben Protokoll, Übertragungsphysik und Topologie des EtherCAT-Systems eine individuelle Qualitätsüberwachung jeder einzelnen Übertragungsstrecke. Die automatische Auswertung der entsprechenden Fehlerzähler ermöglicht die exakte Lokalisierung kritischer Netzwerkabschnitte. Schleichende oder wechselnde Fehlerquellen wie EMV-Einflüsse, fehlerhafte Steckverbindungen oder Kabelschäden werden erkannt und lokalisiert, auch wenn sie die Selbstheilungsfähigkeit des Netzwerkes noch nicht überfordern.
Integration von Beckhoff Standard-Busklemmen
Neben den neuen Busklemmen mit E-Bus-Anschluss (ELxxxx) lassen sich auch sämtliche Busklemmen aus dem bewährten Standardprogramm mit K-Bus-Anschluss (KLxxxx) über den Buskoppler BK1120 oder BK1250 anschließen. Damit sind Kompatibilität und Durchgängigkeit zum bestehenden Beckhoff Busklemmensystemen gewährleistet. Bestehende Investitionen werden geschützt.


EtherCAT-Grundlagen

Grundlagen der Kommunikation [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


EtherCAT-Verkabelung - Drahtgebunden

Grundlagen der Kommunikation [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte als auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2 A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9410) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


EtherCAT State Machine

Grundlagen der Kommunikation [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface: Hinweis

Grundlagen der Kommunikation [image] CoE-Interface: Hinweis
CoE-Interface: Hinweis
Dieses Gerät hat kein CoE.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Distributed Clock

Grundlagen der Kommunikation [image] Distributed Clock
Distributed Clock
Die Distributed Clock stellt eine lokale Uhr im EtherCAT Slave Controller (ESC) dar mit den Eigenschaften:
▪
Einheit 1 ns
▪
Nullpunkt 1.1.2000 00:00
▪
Umfang 64 Bit (ausreichend für die nächsten 584 Jahre); manche EtherCAT-Slaves unterstützen jedoch nur einen Umfang von 32 Bit, d.h. nach ca. 4,2 Sekunden läuft die Variable über
▪
Diese lokale Uhr wird vom EtherCAT Master automatisch mit der Master Clock im EtherCAT Bus mit einer Genauigkeit < 100 ns synchronisiert.
Detaillierte Informationen entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
M8 Anschluss Verkabelung
•
Anzugsdrehmoment für den Steckverbinder
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Einbaulagen
•
Anschlusstechnik
•
Positionierung von passiven Klemmen
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation
•
UL-Hinweise


M8 Anschluss Verkabelung

Montage und Verdrahtung [image] M8 Anschluss Verkabelung
M8 Anschluss Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link: http://beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT-Kabel
ZK1090-3131-0xxx
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
M8 Anschlussbelegung
Signal | Beschreibung | Pin (M8)
Tx+ | Transmit Data+ | 1
Tx- | Transmit Data- | 4
Rx+ | Receive Data+ | 2
Rx- | Receive Data- | 3
Shield | Shielding | Gehäuse


Anzugsdrehmoment für den Steckverbinder

Montage und Verdrahtung [image] Anzugsdrehmoment für den Steckverbinder
Anzugsdrehmoment für den Steckverbinder
Für die Verwendung des EtherCAT Anschlusses M8 des EK1110-0008 ist folgendes zu beachten:
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien KLxxxx und ELxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien KSxxxx und ESxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung
Standardverdrahtung
Die Klemmen der Serien KLxxxx und ELxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung
Steckbare Verdrahtung
Die Klemmen der Serien KSxxxx und ESxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien KLxxxx und ELxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien KSxxxx und ESxxxx werden wie von den Serien bekannt KLxxxx und ELxxxx weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Anschlusspunkten zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine stehende Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!
Verdrahtung
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Befestigung einer Leitung an einem Klemmenanschluss
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen ELx8xx, KLx8xx (HD)
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, d. h. der Leiter wird nach dem Abisolieren einfach in die Kontaktstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2 (siehe Hinweis!)
Abisolierlänge | 8 ... 9 mm
Schirmung
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1.
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2.
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


Inbetriebnahme

Inbetriebnahme
Inbetriebnahme
Weiterführende Informationen
•
EK1110/ EK1110-0008 - Konfiguration mit dem TwinCAT System Manager


EK1110/ EK1110-0008 - Konfiguration mit dem TwinCAT System Manager

Inbetriebnahme [image] EK1110/ EK1110-0008 - Konfiguration mit dem TwinCAT System Manager
EK1110/ EK1110-0008 - Konfiguration mit dem TwinCAT System Manager
TwinCAT-Baum
Tragen Sie im TwinCAT System Manager im Config-Mode unter Geräte den EK1110/ EK1110-0008 als EtherCAT (Direct Mode) Gerät ein. Sollte die Klemme schon am Netzwerk angeschlossen sein, können Sie diese auch einlesen. Dabei werden automatisch alle Buskoppler mit Busklemmen und Konfiguration hochgeladen. Diese können Sie dann nach Ihren Bedürfnissen anpassen.
TwinCAT Baum EK1110/ EK1110-0008
Online Status (Info Data)
State, Karteireiter "Online"
Zeigt den Online-Status der Klemme an.
State, Karteireiter „Online“
Wert | Beschreibung
0x___1 | Slave in 'INIT' state
0x___2 | Slave in 'PREOP' state
0x___3 | Slave in 'BOOT' state
0x___4 | Slave in 'SAFEOP' state
0x___8 | Slave in 'OP' state
0x001_ | Slave signals error
0x002_ | Invalid vendorId, productCode... read
0x004_ | Initialization error occurred
0x010_ | Slave not present
0x020_ | Slave signals link error
0x040_ | Slave signals missing link
0x080_ | Slave signals unexpected link
0x100_ | Communication port A
0x200_ | Communication port B
0x400_ | Communication port C
0x800_ | Communication port D


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
Diagnose-LED


Diagnose-LED

Fehlerbehandlung und Diagnose [image] Diagnose-LED
Diagnose-LED
EK1110/ EK1110-0008
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1) | grün | aus | - | keine Verbindung auf dem EtherCAT-Strang
 |  | an | linked | EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit EtherCAT-Teilnehmer
LED Diagnose EtherCAT State Machine
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand der Klemme wieder:
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme
 |  | gleichmäßig blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | langsam blinkend | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
 |  | schnell blinkend | Zustand der EtherCAT State Machine: BOOTSTRAP = Funktion für Firmware-Updates der Klemme


Anhang

Anhang
Anhang
Weiterführende Informationen
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
Support und Service


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Der EK1110 verfügt über keine Firmware.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.