EK110x, EK15xx - EtherCAT Buskoppler
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Übersicht EtherCAT Koppler
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Übersicht EtherCAT Koppler

Vorwort [image] Übersicht EtherCAT Koppler
Übersicht EtherCAT Koppler
Anschluss RJ45
EK1100 - EtherCAT-Buskoppler
EK1101 - EtherCAT-Buskoppler mit ID-Switch, Hot-Connect
EK1101-0080 - EtherCAT-Buskoppler mit ID-Switch, Fast-Hot-Connect
Anschluss M8
EK1100-0008 - EtherCAT-Buskoppler
Anschluss LWL
EK1501 - EtherCAT-Buskoppler mit ID-Switch (LWL-Multimode)
EK1501-0010 - EtherCAT-Buskoppler mit ID-Switch (LWL-Singlemode)
Anschluss POF
EK1541 - EtherCAT-Buskoppler mit ID-Switch, POF-Anschluss


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
3.7
▪
Update Struktur
▪
Update Kapitel "Technische Daten"
3.6
▪
Update Struktur
▪
Update Kapitel "Technische Daten"
▪
Update Kapitel "Firmware Update EL/ES/EM/EPxxxx"
3.5
▪
Korrektur LED Beschreibung
▪
Update Struktur
3.4
▪
Update Kapitel "Montage und Verdrahtung"
3.3
▪
Update Kapitel "Technische Daten"
3.2
▪
Update Kapitel "Hinweise zur Dokumentation"
▪
Update Kapitel "Technische Daten"
▪
Hinweis zum ESD-Schutz eingefügt
▪
Kapitel "ATEX - Besondere Bedingungen" ausgetauscht gegen Kapitel "ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)"
▪
Kapitel "ATEX - Dokumentation" eingefügt
3.1
▪
Update Kapitel „Einführung“
▪
Strukturupdate
3.0
▪
Migration
▪
Ergänzung von EK1100-0008 (EtherCAT Koppler, mit M8-Buchsen)
▪
Kapitel „EtherCAT-Verkabelung – Drahtgebunden“ verschoben von „Inbetriebnahme/Anwendungshinweise“ nach „Montage und Verdrahtung“
2.3
▪
Update Kapitel "Technische Daten"
▪
Kapitel "Montagehinweise bei erhöhter mechanischer Belastbarkeit" ergänzt
2.2
▪
Update Kapitel "Technische Daten"
▪
Update Kapitel "Speisung , Potenzialgruppen"
2.1
▪
Update Technische Daten
2.0
▪
Update Struktur
1.9
▪
Update Anschlussschema
1.8
▪
Ergänzung EK1101-0080
1.7
▪
Update Speisung, Potentialgruppen
▪
Ergänzung Hinweise zu POF-Koppler
1.6
▪
Ergänzung EK1541
1.5
▪
Ergänzung DC-Support
1.4
▪
Erdungskonzept ergänzt
1.3
▪
EK1101, EK1501, EK1501-0010 ergänzt
1.2
▪
Neue Sicherheitshinweise ergänzt, Korrekturen
1.1
▪
Port-Zuordnung ergänzt
1.0
▪
Technische Daten ergänzt
0.2
▪
Geringfügige Korrekturen
0.1
▪
Erste vorläufige Version


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Übersicht EtherCAT-Koppler
•
Koppler mit RJ45-Anschluss
•
Koppler mit M8-Anschluss
•
Koppler mit LWL-Anschluss
•
Koppler mit POF-Anschluss


Übersicht EtherCAT-Koppler

Produktübersicht [image] Übersicht EtherCAT-Koppler
Übersicht EtherCAT-Koppler

Um EtherCAT-Klemmen mit E-Bus-Kommunikation (Serien ELxxxx, ESxxxx, EMxxxx) an ein EtherCAT-Netzwerk anzuschließen, wird ein EtherCAT-Koppler benötigt. Dieser Koppler leitet vom übergeordneten EtherCAT-Netzwerk die Kommunikation an die Klemmen weiter oder arbeitet selbst als Master und erzeugt Telegramme. Für verschiedenen Einsatzszenarien bietet Beckhoff unterschiedliche Komponenten an.
Die Auswahl des richtigen Kopplers richtet sich nach folgenden Kriterien:
▪
wird eine lokale Kleinsteuerung benötigt?
▪
wird der Koppler über Kupfer-Kabel oder Lichtwellenleiter angeschlossen?
▪
soll der Koppler über IP addressiert werden oder befindet er sich im ungeswitchten Netzwerk?
▪
wird der Koppler über EAP (EtherCAT Automation Protokoll) oder EtherCAT Device Protokoll angesteuert?
▪
benötigte Schutzart, IP20 oder höher?
▪
soll der Koppler über das HotConnect-Verfahren an verschiedenen Stellen am Netzwerk angesteckt werden?
Ein Koppler bindet nach rechts die angefügten Klemmen an, nach links kann er mit dem übergeordneten Netzwerk verbunden werden. Koppler, die nach "links" das EtherCAT-Device-Protokoll unterstützen, müssen dort mit einem EtherCAT Master verbunden werden.
Kommunikationsschema EtherCAT-Koppler
Zur Auswahl kann folgende Übersicht verwendet werden Eigenschaften (Beckhoff EtherCAT Koppler):
Eigenschaft | EK1100 | EK1101 EK1101-0080 | EK1501 | EK1501-0010 | EK1541
Schutzart | IP20 | IP20 | IP20 | IP20 | IP20
übergeordnete Netzwerk - Technologie | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-FX) | 100 MBit FastEthernet (100BASE-FX) | 100 MBit FastEthernet (100BASE-FX) POF
übergeordnetes Netzwerk - max. Verbindungslänge | 100 m | 100 m | 2 km | 20 km | 50 m
übergeordnete Netzwerk - Verbindungstechnik | RJ45 | RJ45 | SC-Duplex Multimode LWL | SC-Duplex Singlemode LWL | Versatile Link POF-Duplex-Stecker Polymeric Optical Fiber
übergeordnetes Netzwerk - Protokoll | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode)
integrierte SPS/PLC | - | - | - | - | -
unterstützt HotConnect mit am Gerät einstellbarer Adresse | - | ja EK1101-0080: Fast-Hot-Connect | ja | ja | ja
Hinweis | Der EK1100 ist der "Standard"-Koppler für den Einsatz direkt am EtherCAT Master. |  |  |  |
Eigenschaft | EK18xx | EK9000 | EKx000 | EPxxxx | CX8000
Schutzart | IP20 | IP20 | IP20 | IP67 | IP20
übergeordnete Netzwerk - Technologie | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX) | diverse s. Doc. | 100 MBit FastEthernet (100BASE-TX) | 100 MBit FastEthernet (100BASE-TX)
übergeordnetes Netzwerk - max. Verbindungslänge | 100 m | 100 m | s.Doc. | 100 m | 100 m
übergeordnete Netzwerk - Verbindungstechnik | RJ45 | RJ45 | s.Doc | M8 | RJ45
übergeordnetes Netzwerk - Protokoll | EtherCAT Device Protokoll (ehem. Direct Mode) | EAP | s. Doc. | EtherCAT Device Protokoll (ehem. Direct Mode) | EtherCAT Device Protokoll (ehem. Direct Mode)
integrierte SPS/PLC | - | - | - | - | ja
unterstützt HotConnect mit am Gerät einstellbarer Adresse | - | - | - | - | -
Hinweis | Die EK18xx integrieren einen Koppler für den Einsatz direkt am EtherCAT-Master und digitale Ein- u. Ausgänge ohne Zusatzbeschaltung. | Der EK9000 kann in einem geswitchten EtherCAT Netzwerk mit gerichteter IP-Adressierung angesteuert werden. | Wird der EK9000 mit einem anderen Feldbusanschluss versehen, ergibt sich der entsprechende Koppler EKx000. | Jede EP-Box stellt technologisch für sich einen EtherCAT Koppler mit intern angefügten IO-Funktionen dar. | Der CX8000 tritt zum übergeordneten EtherCAT Netzwerk als EtherCAT Slave auf und verwaltet gleichzeitig seine angefügten IO als Master.


Koppler mit RJ45-Anschluss

Produktübersicht [image] Koppler mit RJ45-Anschluss
Koppler mit RJ45-Anschluss
Weiterführende Informationen
•
EK1100
•
EK1101, EK1101-xxxx


EK1100

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1100
EK1100
Weiterführende Informationen
•
EK1100 - Einführung
•
EK1100 - Technische Daten


EK1100 - Einführung

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1100 [image] EK1100 - Einführung
EK1100 - Einführung
EtherCAT-Koppler EK1100
Der Koppler EK1100 verbindet das EtherCAT Device Protokoll mit den EtherCAT-Klemmen (ELxxxx/ESxxxx/EMxxxx). Eine Station besteht aus einem Koppler, einer beliebigen Anzahl von EtherCAT-Klemmen und einer Busendklemme, z.B. der EL9011.
Der Koppler setzt mit einer minimalen Latenz die Telegramme im Durchlauf von der Ethernet-100BASE-TX- auf die E-Bus-Signaldarstellung um. Mit der oberen Ethernet-Schnittstelle wird der Koppler an das Netzwerk angeschlossen, die untere RJ-45-Buchse dient zum optionalen Anschluss weiterer EtherCAT-Geräte am gleichen Strang.
Der Koppler versorgt die angefügten Klemmen mit dem benötigten E-Bus-Strom zur Kommunikation. Maximal kann der Koppler 5V/2A liefern. Wird mehr Strom benötigt, sind Einspeiseklemmen (z.B. EL9410) zu integrieren.
Im EtherCAT-Netzwerk wird der Koppler im Bereich der Ethernet-Signalübertragung (100BASE-TX) an beliebiger Stelle eingesetzt. Dabei verarbeitet der Koppler ausschließlich unadressierte MAC-Broadcast-Telegramme vom Typ EtherCAT Device Protokoll vom EtherCAT-Master. Da eine gerichtete Ansprache über MAC-Unicast oder IP-Addressierung nicht verwendet wird, kann kein Switch oder Router eingesetzt werden.
Für den Einsatz am Switch ist sind die Koppler EK9000 / EK1000 geeignet.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Hinweise zur Konfiguration
▪
Diagnose LEDs


EK1100 - Technische Daten

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1100 [image] EK1100 - Technische Daten
EK1100 - Technische Daten
Technische Daten | EK1100
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-TX EtherCAT-Netze
Anzahl der EtherCAT-Klemmen | bis zu 65535 im Gesamtsystem
Anzahl Peripheriesignale | max. 4,2 GByte adressierbare IO-Punkte
Übertragungsmedium | mind. Ethernet CAT-5 Kabel
Leitungslänge zwischen 2 Buskopplern | max. 100 m (100BASE-TX)
Protokoll / Baudrate | EtherCAT Device Protokoll / 100 MBaud
HotConnect | nein
Durchlaufverzögerung | typ. 1 µs
Busanschluss | 2 x RJ45
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme | 70 mA + (E-Bus Strom)/4
E-Bus Stromversorgung (5 V) (Bei höherer Stromaufnahme kann zusätzlich die Einspeiseklemme EL9410 verwenden werden!) | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
Gewicht | ca. 105 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus IECEx


EK1101, EK1101-xxxx

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1101, EK1101-xxxx
EK1101, EK1101-xxxx
Weiterführende Informationen
•
EK1101 - Einführung
•
EK1101-0080 - Einführung
•
EK1101, EK1101-0080 - Technische Daten
•
Hinweise zur EtherCAT Fast-Hot-Connect Technologie


EK1101 - Einführung

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1101, EK1101-xxxx [image] EK1101 - Einführung
EK1101 - Einführung
EtherCAT-Koppler EK1101 mit ID-Switch
Der Koppler EK1101 verbindet das EtherCAT Device Protokoll mit den EtherCAT-Klemmen (ELxxxx/ESxxxx/EMxxxx). Eine Station besteht aus einem Koppler, einer beliebigen Anzahl von EtherCAT-Klemmen und einer Busendklemme, z.B. EL9011.
Der Koppler setzt mit einer minimalen Latenz die Telegramme im Durchlauf von der Ethernet-100BASE-TX- auf die E-Bus-Signaldarstellung um. Mit der oberen Ethernet-Schnittstelle wird der Koppler an das Netzwerk angeschlossen, die untere RJ-45-Buchse dient zum optionalen Anschluss weiterer EtherCAT-Geräte am gleichen Strang.
Der Koppler versorgt die angefügten Klemmen mit dem benötigten E-Bus-Strom zur Kommunikation. Maximal kann der Koppler 5 V/2 A liefern. Wird mehr Strom benötigt, sind Einspeiseklemmen (z.B. EL9410) zu integrieren.
Im EtherCAT-Netzwerk wird der Koppler im Bereich der Ethernet-Signalübertragung (100BASE-TX) an beliebiger Stelle eingesetzt. Dabei verarbeitet der Koppler ausschließlich unadressierte MAC-Broadcast-Telegramme vom Typ EtherCAT Device Protokoll vom EtherCAT-Master. Da eine gerichtete Ansprache über MAC-Unicast oder IP-Addressierung nicht verwendet wird, kann kein Switch oder Router eingesetzt werden.
Der EK1101 unterstützt das HotConnect-Verfahren, siehe dazu die Grundlagendokumentation EtherCAT. Die Eigenschaften des EK1101 sind in Bezug darauf:
▪
am Gerät über 3 Drehwahlschalter einstellbare ID im Bereich 0..4095 (hexadezimal)
▪
die ID ist online über die Prozessdaten vom EtherCAT Master auslesbar
▪
unterstützt der EtherCAT Master HotConnect, kann so eine IO-Gruppe dynamisch in die EtherCAT-Kommunikation mit aufgenommen werden. Diese Gruppe kann dann an beliebiger Stelle im EtherCAT-Netzwerk vorhanden sein. Variable Topologien sind somit einfach realisierbar.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Hinweise zur Konfiguration
▪
Diagnose LEDs


EK1101-0080 - Einführung

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1101, EK1101-xxxx [image] EK1101-0080 - Einführung
EK1101-0080 - Einführung
EtherCAT-Koppler EK1101-0080 mit ID-Switch
Der EtherCAT Koppler EK1101-0080 mit Fast-Hot-Connect Technologie stellt eine Erweiterung des Kopplers EK1101 dar.
Hot-Connect ist ein EtherCAT-Feature für wechselnde Topologien durch direktes An- oder Abkoppeln während der Anlagenbetriebszeit. Angekoppelte EtherCAT-Komponenten werden zwar nach dem Anschluss schnell in die Datenübertragung aufgenommen, die Fast-Hot-Connect-Technologie verkürzt diese Anbindungszeit jedoch nochmals deutlich, wodurch noch schnellere Werkzeugwechselvorgänge möglich sind. Fast-Hot-Connect-Ports dürfen dabei nur untereinander kombiniert werden, daher sind sie besonders gekennzeichnet.
Der EtherCAT-Koppler EK1101-0080 mit Fast-Hot-Connect wird durch den EtherCAT-Abzweig EK1122-0080 mit Fast-Hot-Connect ergänzt.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Hinweise zur Konfiguration
▪
Hinweise zu Fast-Hot-Connect
▪
Diagnose LEDs


EK1101, EK1101-0080 - Technische Daten

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1101, EK1101-xxxx [image] EK1101, EK1101-0080 - Technische Daten
EK1101, EK1101-0080 - Technische Daten
Technische Daten | EK1101 | EK1101-0080
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-TX EtherCAT-Netze | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-TX EtherCAT-Netze, Fast-Hot-Connect Technologie
Anzahl der EtherCAT-Klemmen | bis zu 65535 im Gesamtsystem
Anzahl Peripheriesignale | max. 4,2 GB adressierbare IO-Punkte
Übertragungsmedium | mind. Ethernet CAT-5 Kabel
Leitungslänge zwischen 2 Buskopplern | max. 100 m (100BASE-TX)
Protokoll / Baudrate | EtherCAT Device Protokoll / 100 MBaud
HotConnect | max. Anzahl einstellbarer IDs: 4096
Durchlaufverzögerung | typ. 1 µs
Busanschluss | 2 x RJ45
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme | 70 mA + (E-Bus Strom)/4
E-Bus Stromversorgung (5 V) abhängig von Umgebungstemperatur (Bei höherer Stromaufnahme kann zusätzlich die Einspeiseklemme EL9410 verwenden werden!) | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
Gewicht | ca. 105 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus IECEx


Hinweise zur EtherCAT Fast-Hot-Connect Technologie

Produktübersicht [image] Koppler mit RJ45-Anschluss [image] EK1101, EK1101-xxxx [image] Hinweise zur EtherCAT Fast-Hot-Connect Technologie
Hinweise zur EtherCAT Fast-Hot-Connect Technologie
Mit EtherCAT-Komponenten, die Fast-Hot-Connect unterstützen, ist ein deutlich schnellerer Feldbus-Hochlauf nach Verbindungsherstellung möglich. Die Hochlaufzeit ist im Detail abhängig vom Umfang der Geräte, Topologie und aktivierten Distributed Clocks. Benötigt ein normaler Verbindungs- und Kommunikationsaufbau mehrere Sekunden, ist mit FHC-Komponenten < 1 Sekunde möglich.
Eigenschaften und Systemverhalten
▪
Fast-Hot-Connect wird ab TwinCAT 2.11R3 build 2221 unterstützt
▪
Fast-Hot-Connect-Ports sind besonders gekennzeichnet.
Kennzeichnung FHC-Port am EK1122-0080 bzw. EK1101-0080
▪
an Fast-Hot-Connect-Ports dürfen keine Standard-EtherCAT-Geräte angeschlossen werden. Dies ist durch applikationsseitige Maßnahmen sicherzustellen, was durch die in derartigen Applikationen i.d.R. maschinell durchgeführten Topologiewechsel einfach umzusetzen ist.
Empfehlung Kombination Ethernet Ports
▪
Wurden dennoch entsprechende Ports verbunden, ist ggf. ein PowerReset der beteiligten Geräte (Abzweigklemme und Koppler/Box) erforderlich.
▪
Es findet bei Fast-Hot-Connect-Geräten ein beschleunigter Ethernet-Verbindungsaufbau gegenüber der normalen FastEthernet-Verbindung statt.
Wird zusätzlich noch auf den Einsatz von Distributed-Clocks-Funktionen in der gesamten Topologie verzichtet, entfällt auch die Resynchronisierungszeit der Komponenten. Dann sind Gruppenhochlaufzeiten von < 1 Sekunde möglich, vom Stecken der Ethernet-Verbindung bis zum OP-State.
▪
im TwinCAT ADS Logger wird eine falsche Port-Zuordnung detektiert
Konfiguration
Die Konfiguration von Fast-Hot-Connect-Gruppen im TwinCAT Systemmanager erfolgt genauso wie Hot-Connect-Gruppen unter Angabe der zugehörigen Gruppen-ID.
Konfiguration Fast-HotConnect Gruppe
Im TwinCAT-Systemmanager sind entsprechende FastHotConnect-Ports rot gekennzeichnet.
Kennzeichnung im TwinCAT Systemmanager
Eine Konfiguration von FHC-Gruppen ist nur möglich, wenn mindestens 1 entsprechender Abzweig z.B. EK1122-0080 vorhanden ist.
Distributed Clocks
Wenn keine Distributed-Clocks-Funktionen genutzt werden, ist dies in den Master-Einstellungen durch ein fehlenden "DC in use" sichtbar:
DC-Master-Einstellung
Diese Einstellung wird vom Systemmanager automatisch gewählt, wenn keine EtherCAT-Slaves in der Konfiguration enthalten sind, bei denen Distributed Clocks aktiviert ist. Es sollte hier nicht durch den Anwender "DC in use" willkürlich deaktiviert werden, weil sonst diese Teilnehmer nicht mehr funktionieren.


Koppler mit M8-Anschluss

Produktübersicht [image] Koppler mit M8-Anschluss
Koppler mit M8-Anschluss
Weiterführende Informationen
•
EK1100-0008


EK1100-0008

Produktübersicht [image] Koppler mit M8-Anschluss [image] EK1100-0008
EK1100-0008
Weiterführende Informationen
•
EK1100-0008 - Einführung
•
EK1100-0008 - Technische Daten


EK1100-0008 - Einführung

Produktübersicht [image] Koppler mit M8-Anschluss [image] EK1100-0008 [image] EK1100-0008 - Einführung
EK1100-0008 - Einführung
EtherCAT-Koppler EK1100-0008 (M8 Anschluss)
Der Koppler EK1100-0008 verbindet EtherCAT mit den EtherCAT-Klemmen (ELxxxx/ESxxxx). Eine Station besteht aus einem Koppler EK1100-0008, einer beliebigen Anzahl von EtherCAT-Klemmen und einer Busendklemme. Der Koppler setzt die Telegramme im Durchlauf von der Ethernet-100BASE-TX- auf die E-Bus-Signaldarstellung um. Im Vergleich zum EK1100 verfügt der EK1100-0008 statt der beiden RJ45-Buchsen über zwei M8-Buchsen, die kompatibel zu den EtherCAT Boxen ausgeführt sind.
Mit der oberen Ethernet-Schnittstelle wird der Koppler an das Netzwerk angeschlossen, die untere M8-Buchse dient zum optionalen Anschluss weiterer EtherCAT-Geräte im gleichen Strang.
Der Koppler versorgt die angefügten Klemmen mit dem benötigten E-Bus-Strom zur Kommunikation. Maximal kann der Koppler 5V/2A liefern. Wird mehr Strom benötigt, sind Einspeiseklemmen (z.B. EL9410) zu integrieren
Im EtherCAT-Netzwerk wird der Koppler EK1100-0008 im Bereich der Ethernet-Signalübertragung (100BASE-TX) an beliebiger Stelle eingesetzt – außer direkt am Switch. Mit entsprechend leistungsfähigen Ethernet-Leitungen z.B. ZK1090-3131-1xxx sind auch über M8 Leitungslängen von 100m möglich.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Hinweise zur Konfiguration
▪
Diagnose LEDs


EK1100-0008 - Technische Daten

Produktübersicht [image] Koppler mit M8-Anschluss [image] EK1100-0008 [image] EK1100-0008 - Technische Daten
EK1100-0008 - Technische Daten
Technische Daten | EK1100-0008
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-TX EtherCAT-Netze
Anzahl der EtherCAT-Klemmen | bis zu 65535 im Gesamtsystem
Übertragungsmedium | Ethernet/EtherCAT-Kabel (min. CAT 5), geschirmt
Leitungslänge zwischen 2 Buskopplern | max. 100 m (100BASE-TX)
Übertragungsraten | 100 MBaud
Konfiguration | nicht erforderlich
Durchlaufverzögerung | typ. 1 µs
Businterface | 2 x M8
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme aus US | 70 mA + (∑ E-Bus-Strom/4)
Stromaufnahme aus UP | Last
Stromversorgung E-Bus | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 44 mm x 100 mm x 68 mm
Gewicht | ca. 105 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27, siehe auch Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus IECEx


Koppler mit LWL-Anschluss

Produktübersicht [image] Koppler mit LWL-Anschluss
Koppler mit LWL-Anschluss
Weiterführende Informationen
•
EK1501
•
EK1501-0010


EK1501

Produktübersicht [image] Koppler mit LWL-Anschluss [image] EK1501
EK1501
Weiterführende Informationen
•
EK1501 - Einführung
•
EK1501 - Technische Daten


EK1501 - Einführung

Produktübersicht [image] Koppler mit LWL-Anschluss [image] EK1501 [image] EK1501 - Einführung
EK1501 - Einführung
EtherCAT-Koppler EK1501 mit ID-Switch, Multimode-LWL-Anschluss
Der Koppler EK1501 verbindet das EtherCAT Device Protokoll mit den EtherCAT-Klemmen (ELxxxx/ESxxxx/EMxxxx). Eine Station besteht aus einem Koppler, einer beliebigen Anzahl von EtherCAT-Klemmen und einer Busendklemme, z.B. EL9011.
Der Koppler setzt mit einer minimalen Latenz die Telegramme im Durchlauf von der Ethernet-100BASE-FX- auf die E-Bus-Signaldarstellung um. Mit der oberen Ethernet-Schnittstelle wird der Koppler an das Netzwerk angeschlossen, die untere SC-Buchse dient zum optionalen Anschluss weiterer EtherCAT-Geräte am gleichen Strang.
Der Koppler versorgt die angefügten Klemmen mit dem benötigten E-Bus-Strom zur Kommunikation. Maximal kann der Koppler 5V/2A liefern. Wird mehr Strom benötigt, sind Einspeiseklemmen (z.B. EL9410) zu integrieren.
Im EtherCAT-Netzwerk wird der Koppler im Bereich der Ethernet-Signalübertragung (100BASE-FX) an beliebiger Stelle eingesetzt. Dabei verarbeitet der Koppler ausschließlich unadressierte MAC-Broadcast-Telegramme vom Typ EtherCAT Device Protokoll vom EtherCAT-Master. Da eine gerichtete Ansprache über MAC-Unicast oder IP-Addressierung nicht verwendet wird, kann kein Switch oder Router eingesetzt werden.
Durch den Multimode-Glasfaseranschluss können Entfernungen zwischen zwei Kopplern von bis zu 2 km erreicht werden.
Der Koppler unterstützt das HotConnect-Verfahren, siehe dazu die Grundlagendokumentation EtherCAT. Die Eigenschaften des EK1501 sind in Bezug darauf:
▪
am Gerät über 3 Drehwahlschalter einstellbare ID im Bereich 0..4095 (hexadezimal)
▪
die ID ist online über die Prozessdaten vom EtherCAT Master auslesbar
▪
unterstützt der EtherCAT Master HotConnect, kann so eine IO-Gruppe dynamisch in die EtherCAT-Kommunikation mit aufgenommen werden. Diese Gruppe kann dann an beliebiger Stelle im EtherCAT-Netzwerk vorhanden sein. Variable Topologien sind somit einfach realisierbar.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Anwendungshinweise
▪
Diagnose LEDs


EK1501 - Technische Daten

Produktübersicht [image] Koppler mit LWL-Anschluss [image] EK1501 [image] EK1501 - Technische Daten
EK1501 - Technische Daten
Technische Daten | EK1501
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-FX EtherCAT-Netze
Anzahl der EtherCAT-Klemmen | bis zu 65535 im Gesamtsystem
Anzahl Peripheriesignale | max. 4,2 GByte adressierbare IO-Punkte
Übertragungsmedium | Multimode-Glasfaser (MM)
Leitungslänge zwischen 2 Buskopplern | max. 2 km (100BASE-FX)
Wellenlänge Transceiver | typ. 1300 nm
Protokoll / Baudrate | EtherCAT Device Protokoll / 100 MBaud
HotConnect | max. Anzahl einstellbarer IDs: 4096
Durchlaufverzögerung | typ. 1 µs
Busanschluss | 2 x SC Duplex
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme | 130 mA + (E-Bus Strom)/4
E-Bus Stromversorgung (5 V) abhängig von Umgebungstemperatur (Bei höherer Stromaufnahme kann zusätzlich die Einspeiseklemme EL9410 verwenden werden!) | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 49 mm x 100 mm x 70 mm
Gewicht | ca. 190 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


EK1501-0010

Produktübersicht [image] Koppler mit LWL-Anschluss [image] EK1501-0010
EK1501-0010
Weiterführende Informationen
•
EK1501-0010 - Einführung
•
EK1501-0010 - Technische Daten


EK1501-0010 - Einführung

Produktübersicht [image] Koppler mit LWL-Anschluss [image] EK1501-0010 [image] EK1501-0010 - Einführung
EK1501-0010 - Einführung
EtherCAT-Koppler EK1501-0010 mit ID-Switch, Singlemode-LWL-Anschluss
Der Koppler EK1501-0010 unterscheidet sich vom EK1501 lediglich im verwendeten Transceiver. Durch die Singlemode-Technik sind unter Verwendung entsprechender LWL Übertragungsreichweiten bis zu 20 km zu erzielen.
Zwischen Ek1501-0010 und dem zugehörigen Abzweig EK1521-0010 steht ein Dämpfungsbudget von 10 dBm zur Verfügung. Zur Abschätzung der Dämfung können folgende Faktoren zu Grunde gelegt werden:
▪
2x SC-Steckverbidnung: je 0.25 dBm
▪
typ. Lichtwellenleiter mit 0.4 dB/km Dämpfung
Die Summe aller Dämpfungen darf 10 dBm nicht überschreiten. Ggf. ist die installierte Lichtwellenstrecke messtechnisch zu validieren.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Anwendungshinweise
▪
Diagnose LEDs


EK1501-0010 - Technische Daten

Produktübersicht [image] Koppler mit LWL-Anschluss [image] EK1501-0010 [image] EK1501-0010 - Technische Daten
EK1501-0010 - Technische Daten
Technische Daten | EK1501-0010
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-FX EtherCAT-Netze
Anzahl der EtherCAT-Klemmen | bis zu 65535 im Gesamtsystem
Anzahl Peripheriesignale | max. 4,2 GB adressierbare IO-Punkte
Übertragungsmedium | Singlemode-Glasfaser (SM)
Leitungslänge zwischen 2 Buskopplern | max. 20 km (100BASE-FX)
Wellenlänge Transceiver | typ. 1300 nm
Protokoll / Baudrate | EtherCAT Device Protokoll / 100 MBaud
HotConnect | max. Anzahl einstellbarer IDs: 4096
Durchlaufverzögerung | typ. 1 µs
Busanschluss | 2 x SC Duplex
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme | 150 mA + (E-Bus Strom)/4
E-Bus Stromversorgung (5 V) abhängig von Umgebungstemperatur (Bei höherer Stromaufnahme kann zusätzlich die Einspeiseklemme EL9410 verwenden werden!) | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 49 mm x 100 mm x 70 mm
Gewicht | ca. 190 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE ATEX cULus


Koppler mit POF-Anschluss

Produktübersicht [image] Koppler mit POF-Anschluss
Koppler mit POF-Anschluss
Weiterführende Informationen
•
EK1541


EK1541

Produktübersicht [image] Koppler mit POF-Anschluss [image] EK1541
EK1541
Weiterführende Informationen
•
EK1541 - Einführung
•
EK1541 - Technische Daten


EK1541 - Einführung

Produktübersicht [image] Koppler mit POF-Anschluss [image] EK1541 [image] EK1541 - Einführung
EK1541 - Einführung
EtherCAT-Koppler EK1541 mit ID-Switch, POF-Anschluss
Der Koppler EK1541 verbindet EtherCAT mit den EtherCAT-Klemmen (ELxxxx). Eine Station besteht aus einem Koppler EK1541, einer beliebigen Anzahl von EtherCAT-Klemmen, einer Busendkappe EL9011 oder einer EtherCAT-Verlängerung EK1110.
Der Koppler setzt mit einer minimalen Latenz die Telegramme im Durchlauf von der Ethernet-100BASE-FX-POF-Physik auf die E-Bus-Signaldarstellung um. Durch den Polymeric Optical Fiber (POF)-Anschluss können Entfernungen von bis zu 50 m zwischen zwei Kopplern erreicht werden. Die POF-Faser ist, im Gegensatz zur Glasfaser, gut vor Ort konfektionierbar. Der EK1541 verfügt über drei hexadezimale ID-Switche, mit denen einer Gruppe von EtherCAT-Komponenten eine ID zugeordnet werden kann.
Der Koppler versorgt die angefügten Klemmen mit dem benötigten E-Bus-Strom zur Kommunikation. Maximal kann der Koppler 5V/2A liefern. Wird mehr Strom benötigt, sind Einspeiseklemmen (z.B. EL9410) zu integrieren.
Das Gerät unterstützt das HotConnect-Verfahren, siehe dazu die Grundlagendokumentation EtherCAT. Die Eigenschaften des EK1541 sind in Bezug darauf:
▪
am Gerät über 3 Drehwahlschalter einstellbare ID im Bereich 0..4095 (hexadezimal)
▪
die ID ist online über die Prozessdaten vom EtherCAT Master auslesbar
▪
unterstützt der EtherCAT Master HotConnect, kann so eine IO-Gruppe dynamisch in die EtherCAT-Kommunikation mit aufgenommen werden. Diese Gruppe kann dann an beliebiger Stelle im EtherCAT-Netzwerk vorhanden sein. Variable Topologien sind somit einfach realisierbar.
Quick-Links
▪
EtherCAT Funktionsgrundlagen
▪
Anwendungshinweise
▪
Diagnose LEDs


EK1541 - Technische Daten

Produktübersicht [image] Koppler mit POF-Anschluss [image] EK1541 [image] EK1541 - Technische Daten
EK1541 - Technische Daten
Technische Daten | EK1541
Aufgabe im EtherCAT-System | Ankopplung von EtherCAT-Klemmen (ELxxxx) an 100BASE-FX EtherCAT-POF-Netze
Anzahl der EtherCAT-Klemmen | bis zu 65534 im Gesamtsystem
Anzahl Peripheriesignale | max. 4,2 GByte adressierbare IO-Punkte
Übertragungsmedium | Polymeric Optical Fiber
Leitungslänge zwischen 2 Buskopplern | max. 50 m (100BASE-FX-POF)
Wellenlänge Transceiver | 650 nm Laser-Klasse 1, siehe Hinweis
Protokoll / Baudrate | EtherCAT Device Protokoll / 100 MBaud
HotConnect | max. Anzahl einstellbarer IDs: 4096
Durchlaufverzögerung | typ. 1 µs
Busanschluss | 2 x Versatile Link für POF-Duplex-Stecker (Steckerset ZS1090-0008)
Spannungsversorgung | 24 VDC (-15%/+20%)
Eingangsstrom | 130 mA + (ges. E-Bus Strom)/4
Stromaufnahme 24 V DC | typ. 70 mA
Stromaufnahme E-Bus | -
E-Bus Stromversorgung (5 V) abhängig von Umgebungstemperatur (Bei höherer Stromaufnahme kann zusätzlich die Einspeiseklemme EL9410 verwenden werden!) | max. 2000 mA (-25°C ... +55°C)
 | max. 1000 mA (> +55°C)
Powerkontakte | max. 24 VDC, max. 10 A
Potenzialtrennung | 500 V (Powerkontakt/Versorgungsspannung/EtherCAT)
Abmessungen (B x H x T) | ca. 49 mm x 100 mm x 70 mm
Gewicht | ca. 190 g
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C (erweiterter Temperaturbereich)
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus


Grundlagen

Grundlagen
Grundlagen
Weiterführende Informationen
•
EtherCAT-Grundlagen
•
Port-Zuordnung EtherCAT-Koppler
•
EtherCAT State Machine
•
CoE-Interface: Hinweis
•
EKxxxx - Optionale Distributed Clocks Unterstützung


EtherCAT-Grundlagen

Grundlagen [image] EtherCAT-Grundlagen
EtherCAT-Grundlagen
Grundlagen zum Feldbus EtherCAT entnehmen Sie bitte der EtherCAT System-Dokumentation.


Port-Zuordnung EtherCAT-Koppler

Grundlagen [image] Port-Zuordnung EtherCAT-Koppler
Port-Zuordnung EtherCAT-Koppler
Laut EtherCAT-Spezifikation kann ein ESC (EtherCAT Slave Controller, Hardwareverarbeitungseinheit des EtherCAT-Protokolls) über 1 bis 4 Ports verfügen, die er von sich aus kontrolliert. Öffnet er einen Port, ist dort abgehender und ankommender Ethernet-Verkehr möglich.
Als Beispiel ist die Datenflussrichtung in einem voll beschalteten EK1100 (oder EK1100-0008) in der folgenden Abbildung gezeigt:
Beispiel EtherCAT-Koppler EK1100 bzw. EK1100-0008 mit 3 Ports
Die Portzuordnung beim EK1101, EK1501 und EK1501-0010, EK1814 gilt entsprechend.
Interne und externe Port-Zuordnung Buskoppler EK1100 bzw. EK1100-0008
Ablauf der Frameverarbeitung
• Der ankommende EtherCAT-Frame am EtherCAT-Signaleingang wird von Port 0 (A) weitergereicht zur ErherCAT-Processing-Unit.
• Ankunft des EtherCAT-Frames an Port 1 (B) und Verlassen des Datenframes über Port 1 (B) zum nachfolgenden Slave im EtherCAT-Klemmenverbund (falls dort ein Slave angeschlossen ist und "Link" meldet).
• Nach Ankunft des Datenframes an Port 1 (B) aus dem Klemmenverbund wird dieser zum Port 2 (C) weitergereicht und verlässt am nachfolgenden EtherCAT-Ausgang den Koppler (falls dort ein Slave angeschlossen ist und "Link" meldet).
• Ankunft des Datenframes an Port 2 (C). Dieser wird nun zum Port 0 (A) weitergereicht und verlässt den EK1100 bzw. EK1100-0008 über den EtherCAT-Eingang.
Verarbeitung der Daten
Die Daten in den EtherCAT-Datagrammen werden nur zwischen Port 0 (A) und 3 (D) in der EtherCAT-Processing-Unit verarbeitet. Der nicht ausgeführte (interne) Port 3 (D) gilt als geschlossen und reicht das Datagramm an Port 1 (B) weiter.


EtherCAT State Machine

Grundlagen [image] EtherCAT State Machine
EtherCAT State Machine
Über die EtherCAT State Machine (ESM) wird der Zustand des EtherCAT-Slaves gesteuert. Je nach Zustand sind unterschiedliche Funktionen im EtherCAT-Slave zugänglich bzw. ausführbar. Insbesondere während des Hochlaufs des Slaves müssen in jedem State spezifische Kommandos vom EtherCAT Master zum Gerät gesendet werden.
Es werden folgende Zustände unterschieden:
▪
Init
▪
Pre-Operational
▪
Safe-Operational und
▪
Operational
▪
Boot
Regulärer Zustand eines jeden EtherCAT Slaves nach dem Hochlauf ist der Status OP.
Zustände der EtherCAT State Machine
Init
Nach dem Einschalten befindet sich der EtherCAT-Slave im Zustand Init. Dort ist weder Mailbox- noch Prozessdatenkommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle 0 und 1 für die Mailbox-Kommunikation.
Pre-Operational (Pre-Op)
Beim Übergang von Init nach Pre-Op prüft der EtherCAT-Slave, ob die Mailbox korrekt initialisiert wurde.
Im Zustand Pre-Op ist Mailbox-Kommunikation aber keine Prozessdaten-Kommunikation möglich. Der EtherCAT-Master initialisiert die Sync-Manager-Kanäle für Prozessdaten (ab Sync-Manager-Kanal 2), die FMMU-Kanäle und falls der Slave ein konfigurierbares Mapping unterstützt das PDO-Mapping oder das Sync-Manager-PDO-Assignement. Weiterhin werden in diesem Zustand die Einstellungen für die Prozessdatenübertragung sowie ggf. noch klemmenspezifische Parameter übertragen, die von den Defaulteinstellungen abweichen.
Safe-Operational (Safe-Op)
Beim Übergang von Pre-Op nach Safe-Op prüft der EtherCAT-Slave, ob die Sync-Manager-Kanäle für die Prozessdatenkommunikation sowie ggf. ob die Einstellungen für die Distributed-Clocks korrekt sind. Bevor er den Zustandswechsel quittiert, kopiert der EtherCAT-Slave aktuelle Inputdaten in die entsprechenden DP-RAM-Bereiche des EtherCAT-Slave-Controllers (ECSC).
Im Zustand Safe-Op ist Mailbox- und Prozessdaten-Kommunikation möglich, allerdings hält der Slave seine Ausgänge im sicheren Zustand und gibt sie noch nicht aus. Die Inputdaten werden aber bereits zyklisch aktualisiert.
Ausgänge im SAFEOP
Die standardmäßig aktivierte Watchdogüberwachung bringt die Ausgänge im Modul in Abhängigkeit von den Einstellungen im SAFEOP und OP in einen sicheren Zustand - je nach Gerät und Einstellung z.B. auf AUS. Wird dies durch Deaktivieren der Watchdogüberwachung im Modul unterbunden, können auch im Geräte-Zustand SAFEOP Ausgänge geschaltet werden bzw. gesetzt bleiben.
Operational (Op)
Bevor der EtherCAT-Master den EtherCAT-Slave von Safe-Op nach Op schaltet, muss er bereits gültige Outputdaten übertragen.
Im Zustand Op kopiert der Slave die Ausgangsdaten des Masters auf seine Ausgänge. Es ist Prozessdaten- und Mailbox-Kommunikation möglich.
Boot
Im Zustand Boot kann ein Update der Slave-Firmware vorgenommen werden. Der Zustand Boot ist nur über den Zustand Init zu erreichen.
Im Zustand Boot ist Mailbox-Kommunikation über das Protokoll File-Access over EtherCAT (FoE) möglich, aber keine andere Mailbox-Kommunikation und keine Prozessdaten-Kommunikation.


CoE-Interface: Hinweis

Grundlagen [image] CoE-Interface: Hinweis
CoE-Interface: Hinweis
Dieses Gerät hat kein CoE.
Ausführliche Hinweise zum CoE-Interface finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


EKxxxx - Optionale Distributed Clocks Unterstützung

Grundlagen [image] EKxxxx - Optionale Distributed Clocks Unterstützung
EKxxxx - Optionale Distributed Clocks Unterstützung
Grundlagen Distributed Clocks (DC)
Das EtherCAT Distributed-Clocks-System umfasst in den EtherCAT Slaves integrierte lokale Uhren, die über spezielle Datagramme vom EtherCAT Master synchronisiert werden. Nicht alle EtherCAT Slaves unterstützen das Distributed Clocks Verfahren, sondern nur Slaves, deren Funktion dieses erfordert. Im TwinCAT Systemmanager zeigt eine Slave seine DC-Fähigkeiten, indem er über einen Einstellungsdialog „DC“ verfügt.
DC-Reiter zur Anzeige der Distributed Clocks Funktion
Eine dieser lokalen Uhren ist die Referenz-Uhr, nach der alle anderen synchronisiert werden. Siehe dazu entsprechende Erläuterungen in der EtherCAT Grundlagendokumentation. Prinzipbedingt muss das der erste DC-fähige EtherCAT Slave sein. Deshalb wählt TwinCAT standardmäßig den ersten DC-fähigen Teilnehmer als Referenzuhr aus. In den erweiterten Eigenschaften des EtherCAT Masters wird dies dargestellt bzw. kann vom Anwender verändert werden. Die Standard-Einstellung soll nicht verändert werden, außer es wird in entsprechenden Dokumentationen z. B. zur externen Synchronisierung empfohlen.
Erweiterte Einstellung Distributed Clocks im EtherCAT Master
In der Abbildung ist zu erkennen, wie TwinCAT standardmäßig die EL1252 als Referenzuhr auswählt, da die vorhergehenden Komponenten kein DC unterstützen.
Einstellung EtherCAT Device
System- und Infrastrukturteilnehmer wie die Koppler und Abzweige EK1100, EK1122 etc. benötigen zur Funktion keine Distributed Clocks. Dennoch kann es topologisch sinnvoll sein, z. B. den ersten Koppler im EtherCAT System als Referenzuhr festzulegen. Deshalb sind die Infrastrukturkomponenten ab einem bestimmten Bauzustand in der Lage als Referenzuhr zu arbeiten, wenn in der Konfiguration besondere Einstellungen vorgenommen werden.
Die Komponenten unterstützen lt. der folg. Tabelle (DC-Unterstützung ab Rev/FW-Stand ) die Aktivierung der Distributed Clocks:
Gerät | XML-Revision in der Konfiguration | Seriennummer der Komponente
BK1150 | ab BK1150-0000-0016 | ab Firmware 01: xxxx01yy
CU1128 | ab CU1128-0000-0000 | ab Firmware 00: xxxx00yy
EK1100 | ab EK1100-0000-0017 | ab Firmware 06: xxxx06yy
EK1101 | ab EK1101-0000-0017 | ab Firmware 01: xxxx01yy
EK1501 | ab EK1501-0000-0017 | ab Firmware 01: xxxx01yy
EK1501-0010 | ab EK1501-0010-0017 | ab Firmware 02: xxxx02yy
EK1122 | ab EK1122-0000-0017 | ab Firmware 01: xxxx02yy
EK1521 | ab EK1521-0000-0018 | ab Firmware 03: xxxx03yy
EK1541 | ab EK1541-0000-0016 | ab Firmware 01: xxxx01yy
EK1561 | ab EK1561-0000-0016 | ab Firmware 01: xxxx01yy
EK1521-0010 | ab EK1521-0010-0018 | ab Firmware 03: xxxx03yy
EK1814 | ab EK1814-0000-0016 | ab Firmware 00: xxxx00yy
Damit TwinCAT eine solche Komponente als DC-Referenzuhr verwendet, ist ein manueller Eingriff bei der Konfigurationserstellung erforderlich, der hier anhand des EK1100 gezeigt wird.
Die Checkboxen „Cyclic Mode Enable“ und „Use as potential Reference Clock“ müssen gesetzt werden.
TwinCAT-Einstellung, um diese Komponente als Referenzuhr zu verwenden
Aktivierung Distributed Clocks Unterstützung
Das hier beschriebene Vorgehen führt nur bei den o.a. Komponenten zum (Synchronisierungs-)Erfolg. Auch bei anderen Komponenten können diese Checkboxen gesetzt werden, die Hardware unterstützt diese Funktion jedoch nicht, wenn nicht entsprechend in der jeweiligen Dokumentation angegeben.
Insbesondere darf nach der Inbetriebnahme die Komponente nicht durch eine frühere Version ausgetauscht werden, die den DC-Support nicht leisten kann.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Hinweise zum ESD-Schutz
•
Tragschienenmontage
•
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
•
Einbaulagen
•
Anschlusstechnik
•
Verdrahtung
•
EtherCAT-Verkabelung - Drahtgebunden
•
M8 Anschluss Verkabelung
•
Anzugsdrehmoment für die Steckverbinder
•
Speisung, Potenzialgruppen
•
Positionierung von passiven Klemmen
•
UL-Hinweise
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Hinweise zum ESD-Schutz

Montage und Verdrahtung [image] Hinweise zum ESD-Schutz
Hinweise zum ESD-Schutz
Hinweis
Zerstörung der Geräte durch elektrostatische Aufladung möglich!
Die Geräte enthalten elektrostatisch gefährdete Bauelemente, die durch unsachgemäße Behandlung beschädigt werden können.
•
Sie müssen beim Umgang mit den Komponenten elektrostatisch entladen sein; vermeiden Sie außerdem die Federkontakte (s. Abb.) direkt zu berühren.
•
Vermeiden Sie den Kontakt mit hoch isolierenden Stoffen (Kunstfaser, Kunststofffolien etc.)
•
Beim Umgang mit den Komponenten ist auf gute Erdung der Umgebung zu achten (Arbeitsplatz, Verpackung und Personen)
•
Jede Busstation muss auf der rechten Seite mit der Endkappe EL9011 oder EL9012 abgeschlossen werden, um Schutzart und ESD-Schutz sicher zu stellen.
Federkontakte der Beckhoff I/O-Komponenten


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Montage auf Tragschiene
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Tragschienenbefestigung
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Demontage von Tragschiene
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie die Klemme an ihren orangefarbigen Laschen ca. 1 cm von der Tragschiene herunter. Dabei wird die Tragschienenverriegelung dieser Klemme automatisch gelöst und Sie können die Klemme nun ohne großen Kraftaufwand aus dem Busklemmenblock herausziehen.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den Gehäuseflächen und ziehen sie aus dem Busklemmenblock heraus.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler (bis 24 V) oder für höhere Spannungen über Einspeiseklemmen.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z.B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!


Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit

Montage und Verdrahtung [image] Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
Montagevorschriften für Klemmen mit erhöhter mechanischer Belastbarkeit
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Zusätzliche Prüfungen
Die Klemmen sind folgenden zusätzlichen Prüfungen unterzogen worden:
Prüfung | Erläuterung
Vibration | 10 Frequenzdurchläufe, in 3-Achsen
 | 6 Hz < f < 60 Hz Auslenkung 0,35 mm, konstante Amplitude
 | 60,1 Hz < f < 500 Hz Beschleunigung 5 g, konstante Amplitude
Schocken | 1000 Schocks je Richtung, in 3-Achsen
 | 25 g, 6 ms
Zusätzliche Montagevorschriften
Für die Klemmen mit erhöhter mechanischer Belastbarkeit gelten folgende zusätzliche Montagevorschriften:
▪
Die erhöhte mechanische Belastbarkeit gilt für alle zulässigen Einbaulagen
▪
Es ist eine Tragschiene nach EN 60715 TH35-15 zu verwenden
▪
Der Klemmenstrang ist auf beiden Seiten der Tragschiene durch eine mechanische Befestigung, z.B. mittels einer Erdungsklemme oder verstärkten Endklammer zu fixieren
▪
Die maximale Gesamtausdehnung des Klemmenstrangs (ohne Koppler) beträgt:
64 Klemmen mit 12 mm oder 32 Klemmen mit 24 mm Einbaubreite
▪
Bei der Abkantung und Befestigung der Tragschiene ist darauf zu achten, dass keine Verformung und Verdrehung der Tragschiene auftritt, weiterhin ist kein Quetschen und Verbiegen der Tragschiene zulässig
▪
Die Befestigungspunkte der Tragschiene sind in einem Abstand vom 5 cm zu setzen
▪
Zur Befestigung der Tragschiene sind Senkkopfschrauben zu verwenden
▪
Die freie Leiterlänge zwischen Zugentlastung und Leiteranschluss ist möglichst kurz zu halten; der Abstand zum Kabelkanal ist mit ca.10 cm zu einhalten


Einbaulagen

Montage und Verdrahtung [image] Einbaulagen
Einbaulagen
Hinweis
Einschränkung von Einbaulage und Betriebstemperaturbereich
Entnehmen Sie den technischen Daten zu einer Klemme, ob sie Einschränkungen bei Einbaulage und/oder Betriebstemperaturbereich unterliegt. Sorgen Sie bei der Montage von Klemmen mit erhöhter thermischer Verlustleistung dafür, dass im Betrieb oberhalb und unterhalb der Klemmen ausreichend Abstand zu anderen Komponenten eingehalten wird, so dass die Klemmen ausreichend belüftet werden!
Optimale Einbaulage (Standard)
Für die optimale Einbaulage wird die Tragschiene waagerecht montiert und die Anschlussflächen der EL/KL-Klemmen weisen nach vorne (siehe Abb. „Empfohlene Abstände bei Standard Einbaulage“). Die Klemmen werden dabei von unten nach oben durchlüftet, was eine optimale Kühlung der Elektronik durch Konvektionslüftung ermöglicht. Bezugsrichtung "unten" ist hier die Erdbeschleunigung.
Empfohlene Abstände bei Standard Einbaulage
Die Einhaltung der Abstände nach Abb. „Empfohlene Abstände bei Standard Einbaulage“ wird empfohlen.
Weitere Einbaulagen
Alle anderen Einbaulagen zeichnen sich durch davon abweichende räumliche Lage der Tragschiene aus, s. Abb. „Weitere Einbaulagen“.
Auch in diesen Einbaulagen empfiehlt sich die Anwendung der oben angegebenen Mindestabstände zur Umgebung.
Weitere Einbaulagen


Anschlusstechnik

Montage und Verdrahtung [image] Anschlusstechnik
Anschlusstechnik
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Übersicht
Mit verschiedenen Anschlussoptionen bietet das Busklemmensystem eine optimale Anpassung an die Anwendung:
▪
Die Klemmen der Serien ELxxxx und KLxxxx mit Standardverdrahtung enthalten Elektronik und Anschlussebene in einem Gehäuse.
▪
Die Klemmen der Serien ESxxxx und KSxxxx haben eine steckbare Anschlussebene und ermöglichen somit beim Austausch die stehende Verdrahtung.
▪
Die High-Density-Klemmen (HD-Klemmen) enthalten Elektronik und Anschlussebene in einem Gehäuse und haben eine erhöhte Packungsdichte.
Standardverdrahtung (ELxxxx / KLxxxx)
Standardverdrahtung
Die Klemmen der Serien ELxxxx und KLxxxx sind seit Jahren bewährt und integrieren die schraublose Federkrafttechnik zur schnellen und einfachen Montage.
Steckbare Verdrahtung (ESxxxx / KSxxxx)
Steckbare Verdrahtung
Die Klemmen der Serien ESxxxx und KSxxxx enthalten eine steckbare Anschlussebene.
Montage und Verdrahtung werden wie bei den Serien ELxxxx und KLxxxx durchgeführt.
Im Servicefall erlaubt die steckbare Anschlussebene, die gesamte Verdrahtung als einen Stecker von der Gehäuseoberseite abzuziehen.
Das Unterteil kann, über das Betätigen der Entriegelungslasche, aus dem Klemmenblock herausgezogen werden.
Die auszutauschende Komponente wird hineingeschoben und der Stecker mit der stehenden Verdrahtung wieder aufgesteckt. Dadurch verringert sich die Montagezeit und ein Verwechseln der Anschlussdrähte ist ausgeschlossen.
Die gewohnten Maße der Klemme ändern sich durch den Stecker nur geringfügig. Der Stecker trägt ungefähr 3 mm auf; dabei bleibt die maximale Höhe der Klemme unverändert.
Eine Lasche für die Zugentlastung des Kabels stellt in vielen Anwendungen eine deutliche Vereinfachung der Montage dar und verhindert ein Verheddern der einzelnen Anschlussdrähte bei gezogenem Stecker.
Leiterquerschnitte von 0,08 mm2 bis 2,5 mm2 können weiter in der bewährten Federkrafttechnik verwendet werden.
Übersicht und Systematik in den Produktbezeichnungen der Serien ESxxxx und KSxxxx werden wie von den Serien ELxxxx und KLxxxx bekannt weitergeführt.
High-Density-Klemmen (HD-Klemmen)
High-Density-Klemmen
Die Busklemmen dieser Baureihe mit 16 Klemmstellen zeichnen sich durch eine besonders kompakte Bauform aus, da die Packungsdichte auf 12 mm doppelt so hoch ist wie die der Standard-Busklemmen. Massive und mit einer Aderendhülse versehene Leiter können ohne Werkzeug direkt in die Federklemmstelle gesteckt werden.
Verdrahtung HD-Klemmen
Die High-Density-Klemmen (HD-Klemmen) der Serien ELx8xx und KLx8xx unterstützen keine steckbare Verdrahtung.
Ultraschall-litzenverdichtete Leiter
Ultraschall-litzenverdichtete Leiter
An die Standard- und High-Density-Klemmen (HD-Klemmen) können auch ultraschall-litzenverdichtete (ultraschallverschweißte) Leiter angeschlossen werden. Beachten Sie die unten stehenden Tabellen zum Leitungsquerschnitt!


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Klemmen für Standardverdrahtung ELxxxx/KLxxxx und für steckbare Verdrahtung ESxxxx/KSxxxx
Anschluss einer Leitung an eine Klemmstelle
Bis zu acht Klemmstellen ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemme. Die Klemmstellen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Klemmstelle, indem Sie einen Schraubendreher gerade bis zum Anschlag in die
viereckige Öffnung über der Klemmstelle drücken. Den Schraubendreher dabei nicht drehen oder hin und her bewegen (nicht hebeln).
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemmstelle automatisch und hält den Draht sicher und dauerhaft fest.
Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | ELxxxx, KLxxxx | ESxxxx, KSxxxx
Leitungsquerschnitt (massiv) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,08 ... 2,5 mm2 | 0,08 ... 2,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 1,5 mm2 | 0,14 ... 1,5 mm2
Abisolierlänge | 8 ... 9 mm | 9 ... 10 mm
High-Density-Klemmen (HD-Klemmen) mit 16 Klemmstellen
Bei den HD-Klemmen erfolgt der Leiteranschluss bei massiven Leitern werkzeuglos, in Direktstecktechnik, das heißt der Leiter wird nach dem Abisolieren einfach in die Klemmstelle gesteckt. Das Lösen der Leitungen erfolgt, wie bei den Standardklemmen, über die Kontakt-Entriegelung mit Hilfe eines Schraubendrehers. Den zulässigen Leiterquerschnitt entnehmen Sie der nachfolgenden Tabelle.
Klemmengehäuse | HD-Gehäuse
Leitungsquerschnitt (massiv) | 0,08 ... 1,5 mm2
Leitungsquerschnitt (feindrähtig) | 0,25 ... 1,5 mm2
Leitungsquerschnitt (Aderleitung mit Aderendhülse) | 0,14 ... 0,75 mm2
Leitungsquerschnitt (ultraschall-litzenverdichtet) | nur 1,5 mm2
Abisolierlänge | 8 ... 9 mm


EtherCAT-Verkabelung - Drahtgebunden

Montage und Verdrahtung [image] EtherCAT-Verkabelung - Drahtgebunden
EtherCAT-Verkabelung - Drahtgebunden
Die zulässige Leitungslänge zwischen zwei EtherCAT-Geräten darf maximal 100 Meter betragen. Dies resultiert aus der FastEthernet-Technologie, die vor allem aus Gründen der Signaldämpfung über die Leitungslänge eine maximale Linklänge von 5 + 90 + 5 m erlaubt, wenn Leitungen mit entsprechenden Eigenschaften verwendet werden. Siehe dazu auch die Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet.
Kabel und Steckverbinder
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur Ethernet-Verbindungen (Kabel + Stecker), die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen. EtherCAT nutzt 4 Adern des Kabels für die Signalübertragung.
EtherCAT verwendet beispielsweise RJ45-Steckverbinder. Die Kontaktbelegung ist zum Ethernet-Standard (ISO/IEC 8802-3) kompatibel.
Pin | Aderfarbe | Signal | Beschreibung
1 | gelb | TD+ | Transmission Data +
2 | orange | TD- | Transmission Data -
3 | weiß | RD+ | Receiver Data +
6 | blau | RD- | Receiver Data -
Aufgrund der automatischen Kabelerkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie auch Cross-Over-Kabel verwenden.
Empfohlene Kabel
Geeignete Kabel zur Verbindung von EtherCAT-Geräten finden Sie auf der Beckhoff Website!
E-Bus-Versorgung
Ein Buskoppler kann die an ihm angefügten EL-Klemmen mit der E-Bus-Systemspannung von 5 V versorgen, i.d.R. ist ein Koppler dabei bis zu 2A belastbar (siehe Dokumentation des jeweiligen Gerätes).
Zu jeder EL-Klemme ist die Information, wie viel Strom sie aus der E-Bus-Versorgung benötigt, online und im Katalog verfügbar. Benötigen die angefügten Klemmen mehr Strom als der Koppler liefern kann, sind an entsprechender Position im Klemmenstrang Einspeiseklemmen (z.B. EL9400) zu setzen.
Im TwinCAT Systemmanager wird der vorberechnete theoretische maximale E-Bus-Strom angezeigt. Eine Unterschreitung wird durch negativen Summenbetrag und Ausrufezeichen markiert, vor einer solchen Stelle ist eine Einspeiseklemme zu setzen.
Systemmanager Stromberechnung
Hinweis
Achtung! Fehlfunktion möglich!
Die E-Bus-Versorgung aller EtherCAT-Klemmen eines Klemmenblocks muss aus demselben Massepotential erfolgen!


M8 Anschluss Verkabelung

Montage und Verdrahtung [image] M8 Anschluss Verkabelung
M8 Anschluss Verkabelung
Eine Auflistung der EtherCAT-Kabel, Powerkabel, Sensorkabel, Ethernet-/EtherCAT-Steckverbinder sowie feldkonfektionierbare Steckverbinder finden Sie unter dem folgenden Link: http://download.beckhoff.com/download/document/catalog/main_catalog/german/Beckhoff_EtherCAT-Box-Zubehoer.pdf
Die dazugehörigen Datenblätter finden Sie unter dem folgenden Link: http://beckhoff.de/german/fieldbus_box/data_sheets.htm?id=69033899254355
EtherCAT-Kabel
ZK1090-3131-0xxx
Verwenden Sie zur Verbindung von EtherCAT-Geräten nur geschirmte Ethernet-Kabel, die mindestens der Kategorie 5 (CAT5) nach EN 50173 bzw. ISO/IEC 11801 entsprechen.
Empfehlungen zur Verkabelung
Detailliert Empfehlungen zur Verkabelung von EtherCAT können Sie der Dokumentation "Auslegungsempfehlungen zur Infrastruktur für EtherCAT/Ethernet" entnehmen, die auf www.beckhoff.de zum Download zur Verfügung steht.
EtherCAT nutzt vier Adern der Kabel für die Signalübertragung.
Aufgrund der automatischen Leitungserkennung (Auto-Crossing) können Sie zwischen EtherCAT-Geräten von Beckhoff sowohl symmetrisch (1:1) belegte, wie gekreuzte Kabel (Cross-Over) verwenden.
M8 Anschlussbelegung
Signal | Beschreibung | Pin (M8)
Tx+ | Transmit Data+ | 1
Tx- | Transmit Data- | 4
Rx+ | Receive Data+ | 2
Rx- | Receive Data- | 3
Shield | Shielding | Gehäuse


Anzugsdrehmoment für die Steckverbinder

Montage und Verdrahtung [image] Anzugsdrehmoment für die Steckverbinder
Anzugsdrehmoment für die Steckverbinder
X1 und X2 des EK1100-0008
Für die Verwendung der EtherCAT-Anschlüsse M8 des EK1100-0008 ist folgendes zu beachten:
M8-Steckverbinder
Es wird empfohlen die M8-Steckverbinder mit einem Drehmoment von 0,4 Nm festzuziehen. Bei Verwendung des Drehmoment-Schraubendrehers ZB8800 ist auch ein max. Drehmoment von 0,5 Nm zulässig.
EtherCAT Box mit M8-Steckverbindern


Speisung, Potenzialgruppen

Montage und Verdrahtung [image] Speisung, Potenzialgruppen
Speisung, Potenzialgruppen
Spannungsversorgung Buskoppler
Die Buskoppler benötigen zum Betrieb eine 24 V Gleichspannung. Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Die Versorgungsspannung wird sowohl von der Elektronik des Buskopplers als auch von der direkten Spannungserzeugung für den E-Bus genutzt. Die Spannungserzeugung für den E-Bus findet in einem DC/DC-Wandler ohne galvanische Trennung statt.
Die EK1xxx versorgen den E-Bus mit max. 2.000 mA E-Bus-Strom. Wird durch die angefügten Klemmen mehr Strom benötigt, sind Einspeiseklemmen zu setzen.
Einspeisung Powerkontakte
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler. Die Auslegung der Einspeisung lässt Spannungen bis zu 24 V zu. Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschleifen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakten darf 10 A nicht dauerhaft überschreiten, die Zuleitung ist deshalb mit 10 A (träge) abzusichern.
Powerkontakte
An der rechten Seitenfläche des Buskopplers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um den Berührungsschutz sicherzustellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut/Federführung an der Ober- und Unterseite der Buskoppler und Busklemmen garantiert sichere Führung der Powerkontakte.
Die Strombelastung der Powerkontakte darf 10 A nicht dauerhaft überschreiten.
Potenzialtrennung
Die Buskoppler arbeiten mit drei unabhängigen Potenzialgruppen. Die Versorgungsspannung speist galvanisch getrennt die E-Bus-Elektronik im Buskoppler und den E-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbusses erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum E-Bus. Der E-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialschaltbild EKxxxx
Erdungskonzept
Erdungskonzept EKxxxx
Absicherung
Versorgung des Kopplers, Sicherung 1:
in Abhängigkeit von der benötigten Stromaufnahme und damit der konfigurierten Klemmen
typ. max. 1 A
Powerkontakte, Sicherung 2:
max. 10 A (träge) zulässig
Die Elektronik des Kopplers und die Powerkontakte können zusammen aus der gleichen Quelle versorgt werden, die Sicherung ist dann entsprechend auf max. 10 A zu dimensionieren.


Positionierung von passiven Klemmen

Montage und Verdrahtung [image] Positionierung von passiven Klemmen
Positionierung von passiven Klemmen
Hinweis zur Positionierung von passiven Klemmen im Busklemmenblock
EtherCAT-Klemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus. Um einen optimalen Datenaustausch zu gewährleisten, dürfen nicht mehr als 2 passive Klemmen direkt aneinander gereiht werden!
Beispiele für die Positionierung von passiven Klemmen (hell eingefärbt)
Korrekte Positionierung
Inkorrekte Positionierung


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
Im Beckhoff EtherCAT Produktbereich sind je nach Komponente zwei UL-Zertifikate anzutreffen:
1.
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
2.
UL-Zertifikation nach UL508 mit eingeschränkter Leistungsaufnahme. Die Stromaufnahme durch das Gerät wird begrenzt auf eine max. mögliche Stromaufnahme von 4 A. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:
Annähernd alle aktuellen EtherCAT Produkte (Stand 2010/05) sind uneingeschränkt UL zertifiziert.
Anwendung
Werden eingeschränkt zertifizierte Klemmen verwendet, ist die Stromaufnahme bei 24 VDC entsprechend zu beschränken durch Versorgung
▪
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
▪
von einer Spannungsquelle die NEC class 2 entspricht.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
Diese Anforderungen gelten für die Versorgung aller EtherCAT Buskoppler, Netzteilklemmen, Busklemmen und deren Power-Kontakte.


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Inbetriebnahme/Anwendungshinweise

Inbetriebnahme/Anwendungshinweise
Inbetriebnahme/Anwendungshinweise
Weiterführende Informationen
•
Übersicht Konfiguration
•
Anwendungshinweise


Übersicht Konfiguration

Inbetriebnahme/Anwendungshinweise [image] Übersicht Konfiguration
Übersicht Konfiguration
Nähere Hinweise zur Konfigurationseinstellung finden Sie in der EtherCAT-Systemdokumentation auf der Beckhoff Website.


Anwendungshinweise

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise
Anwendungshinweise
Weiterführende Informationen
•
LWL-Anwendungshinweise
•
POF-Anwendungshinweise
•
Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008


LWL-Anwendungshinweise

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] LWL-Anwendungshinweise
LWL-Anwendungshinweise
EK1501
Weiterführende Informationen
•
Hinweise zum verwendbaren LWL-Kabel
•
Einsatz mit dem EK1501 und EK1501-0010


Hinweise zum verwendbaren LWL-Kabel

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] LWL-Anwendungshinweise [image] Hinweise zum verwendbaren LWL-Kabel
Hinweise zum verwendbaren LWL-Kabel
Allgemeine Informationen zu LWL-Typen
Man unterscheidet bei Lichtwellenleitern (LWL) nach Multimode- und Singlemodetypen und nach Stufen- und Gradientenindex.
Stufen- und Gradientenindex
Lichtwellenleiter bestehen aus 2 konzentrischen Materialien, dem Kern und einer Umhüllung. Dazu kommt noch ggf. ein (farbiger) Schutzmantel. Kern und Umhüllung haben einen unterschiedlichen Brechungsindex, deshalb werden die Lichtwellen (Moden; eine Mode ist eine Eigenwelle im LWL) an der Übergangsstelle reflektiert und in den Kern zurückgeworfen. Durch den sprunghaften Brechungsindexübergang wird diese Faser als Stufenindex bezeichnet. Wird durch Materialvermischung ein allmählicher/parabolischer Übergang vom Kernbrechungsindex zum Mantelbrechungsindex erreicht, wird dies als Gradientenindex bezeichnet. Bei der Gradienteindexfaser werden die Moden allmählich zum Kern zurückgebeugt, dadurch findet ein Laufzeitausgleich statt und die Qualität eines Lichtpulse am Austrittsende ist deutlich besser als bei einer Multimode-Stufenindexfaser, bei der verschiedene Lichtmoden unterschiedlich lange Signallaufzeiten haben (Modendispersion) - eine Flankenverschleifung ist dort die Folge.
Singlemode
Singlemode-Fasern haben einen sehr dünnen Kern (9 µm) und leiten deshalb nur eine einzige Mode des verwendeten Lichts mit hoher Signalgüte und fast ohne Modendispersion. Es gibt sie nur als Stufenindexfaser. Durch die hohe Signalgüte eignen sie sich für große Übertragungsbandbreiten > 10 GHz*km und Entfernungen > 50 km. Das Brechzahlprofil von Singlemode-Fasern ist so dimensioniert, dass die bei Multimode-Fasern problematische Mehrwegeausbreitung (intermodale Dispersion) entfällt – das Signallicht breitet sich in einer Singlemode-Faser nur in einem einzigen geführten Wellenleitermodus aus, daher die Bezeichnung single-mode. Damit sind wesentlich größere Übertragungsdistanzen und/oder -bandbreiten möglich, und der als nächstes auftretende limitierende Effekt ist die Farbverzerrung des übertragenen Modus.
Multimode
Multimode-LWL werden als Stufenindex oder Gradientenindex gefertigt. Stufenindex-Multimodefasern eignen sich für Übertragungsbandbreiten bis 100 MHz*km und Entfernungen bis max. 1 km. Gradientenindex-Multimodefasern mit einem Kern von 50 oder 62,5 µm erreichen Übertragungsbandbreiten > 1 GHz*km und Reichweiten > 10 km. Multimode bedeutet, dass der Kern des LWL-Kabels dick genug ist, damit sich mehrere Moden des verwendeten Lichts reflektierend im Kabel fortbewegen können.


Einsatz mit dem EK1501 und EK1501-0010

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] LWL-Anwendungshinweise [image] Einsatz mit dem EK1501 und EK1501-0010
Einsatz mit dem EK1501 und EK1501-0010
Der EK1501 / EK1501-0010 ist zur Kombination mit LWL-Kabeln mit folgenden Eigenschaften bestimmt:
▪
SC Duplex Stecker
▪
EK1501: Duplex Multimode 50/125 µm oder 62,5/125 µm (innerer/äußerer Kerndurchmesser). Der Einsatz von beiden Durchmessern ist möglich. Es wird jedoch die Verwendung von 50/125 µm aufgrund der geringeren Dämpfung empfohlen.
▪
EK1501-0010: Duplex Singlemode 9/125 µm (innerer/äußerer Kerndurchmesser). Ein typ. verwendbares Kabel kann nach der Spezifikation ITU-T G.652.D (0.4 dBm/km bei 1300 nm) gefertigt sein.
Empfohlene Stecker
Es wird der Einsatz von SC/PC -Steckern für die Konnektierung des EK1501/EK1501-0010 empfohlen. Der Vorteil dieser Stecker in "PC" (physical contact) Ausführung ist die ballige Endfläche, so dass beim Zusammenstecken der Stecker der für die Übertragung relevante Bereich des Faserkerns optimal verbunden wird. Weitere Ausführungen sind z. B. SC/UPC (ultrapolish PC), SC/HRL (high return loss) oder SC/APC-Stecker (angled physical contact). Bei diesen Steckern wird zusätzlich durch die mit ca. 8° zur Faserachse angewinkelte Steckerendfläche reflektiertes Licht aus dem Kern über das Mantelglas in die Luft hinaus gebrochen, was Störungen in der Datenübertragung vermeidet und die Kerngröße der Rückstreuung optimiert.
Im LWL-Bereich werden üblicherweise die Wellenlängen 850 nm und 1300 nm für die Datenübertragung verwendet. Die am Markt verfügbaren Glasfaserkabel sind meist zur Verwendung in einem dieser Bereiche optimiert, da die Die Dämpfung des Signals ist (wie auch im Kupferkabel) frequenzabhängig ist - damit werden dann mit der jeweiligen Wellenlänge große Reichweiten von mehreren km erzielt. Allgemein weisen Glasfaserkabel im 1300 nm-Fenster eine geringere Dämpfung auf als im 850 nm-Fenster.
Im EK1501/EK1501-0010 wird ein Transceiver mit der Wellenlänge 1300 nm eingesetzt.
Reichweite und Bandbreitenprodukt
LWL-Kabel sind in verschiedenen Qualitäten von namhaften Herstellern erhältlich. Für den Anwender maßgebend ist u.a. das frequenzabhängige Bandbreitenprodukt eines Kabels, angegeben in [MHz*km. Je größer das Bandbreitenprodukt, desto geringer ist die Dämpfung - damit steigt die mit diesem Leiter erzielbare Reichweite (s. ITU-T G-651). Zur Erzielung der maximalen Reichweite mit dem EK1501 / EK1501-0010 sind deshalb Lichtwellenleiter mit einem möglichst hohen Bandbreitenprodukt bei 1300 nm zu verwenden - empfohlen wird ein Einsatz von LWL der Klasse OM2 (EN50173:2002).Standard-LWL verfügen über ein Bandbreitenprodukt von mindestens 500 MHz*km bei 1300 nm, höherwertigere für Entfernungen > 500 m über > 1000 MHz*km. Um die Maximalreichweiten zu erzielen, muss die Gegenstelle zum EK1501/EK1501-0010 ebenfalls solche Reichweiten unterstützen.
Verlegehinweise
•
zulässiger Biegeradius
•
zulässige Zugfestigkeit
•
Empfindlichkeit der ungeschützten Kontaktenden
Zur weiteren Information können folgende weitere Quellen dienlich sein:
▪
ITU Empfehlung ITU-T G.651 - G.655
▪
EN 50173:2002
▪
EN 60793-2
Konnektieren und Lösen des LWL-Kabels am Abzweig
Hinweis
Beschädigung des Kabels möglich!
Zur Demontage des LWL-Kabels nur am Stecker ziehen, der die Verriegelung löst - niemals am LWL-Kabel allein!
Gekreuzte Kabel
Beachten Sie, dass bei der Verbindung der EK1521, EK1521-0010 zum EK1501/ EK1501-0010 ggf. "gekreuzte" Kabel verwendet werden müssen um eine Verbindung herzustellen.
Praxistipp:
Der infrarote Lichtaustritt kann mittels einer Digital-/Handykamera am Abzweig bzw. am Koppler sichtbar gemacht werden (siehe Abbildung). Stellen Sie sicher, dass beim Stecken der LWL-Leitung nicht "Licht auf Licht" trifft (Tx → Tx). In diesem Fall kann keine Verbindung aufgebaut werden und die Kabel sind zu kreuzen (Tx → Rx).

Abbildung: Visualisierung von infrarotem Licht am SC Duplex Stecker
Verwendung von Blindstopfen
Zum Schutz des Transceivers vor Umwelteinflüssen sollten nicht verwendete Anschlussbuchsen mit den mitgelieferten Blindstopfen verschlossen werden!

Abbildung: Blindstopfen in nicht verwendeten Anschlussbuchsen


POF-Anwendungshinweise

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] POF-Anwendungshinweise
POF-Anwendungshinweise
EK1541
Weiterführende Informationen
•
Hinweise zum verwendbaren POF-Kabel
•
Einsatz mit dem EK1541


Hinweise zum verwendbaren POF-Kabel

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] POF-Anwendungshinweise [image] Hinweise zum verwendbaren POF-Kabel
Hinweise zum verwendbaren POF-Kabel
Allgemeine Informationen POF-Kabel
Die Standard-Polymerfaser ist 1 mm dick und besteht aus einem 0,98 mm dicken Kern aus Polymethylmethacrylat (PMMA) sowie einem dünnen Mantel. Um eine Lichtführung durch den Effekt der Totalreflexion im Kern zu ermöglichen, besteht der meist sehr dünne Mantel aus fluoriertem PMMA, welches einen geringeren Brechungsindex aufweist. Die Kerndurchmesser bewegen sich zwischen 0,06 und 1 mm, wodurch einfache Steckverbindungen unproblematisch zu realisieren sind. Weiterhin kann somit auf das zur Verbindung von Glasfasern häufig eingesetzte Spleißverfahren, und dem damit verbundenen unnötig hohen Aufwand, in der Regel verzichtet werden. Die maximale Einsatztemperatur von Standard-POF liegt bei etwa 60 °C und hat ein Brechungsprofil mit Stufenindex (SI-POF). Der Brechungsindex des Kernmaterials liegt bei 1,49, der des Mantels bei 1,41. Die Differenz bestimmt die numerische Apertur (NA) und damit den maximalen Ausbreitungswinkel. Dieser liegt bei einer Differenz von 5 % bei etwa 20 Grad gegenüber der Faserachse, was zur Reduzierung der Bandbreite führt.
Aufgrund der im Vergleich zur Glasfaser einfachen und nahezu universell einsetzbaren Verbindungstechniken finden POF insbesondere Anwendung bei kurzen Datenübertragungsstrecken, so beispielsweise innerhalb von Räumen, technischen Geräten, mechanischen Anlagen oder auch Personenkraftwagen.
Die POF haben eine Dämpfung von etwa 140 dB/km bei einer Wellenlänge von 650 nm, so dass bei der Anwendung mit dem EK1541 eine Datenübertragungstrecke von max. 50 m zu erreichen ist.
Werden zusätzliche Steckverbindungen in die Strecke eingebracht, vergrößert dies die Signaldämpfung. Je zusätzlichem Steckverbinder reduziert sich somit die zulässige max. Streckenlänge um typ. 6,5 m.


Einsatz mit dem EK1541

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] POF-Anwendungshinweise [image] Einsatz mit dem EK1541
Einsatz mit dem EK1541
Empfohlene Stecker und POF-Kabel
Es wird der Einsatz des bei Beckhoff erhältlichen Steckersets ZS1090-0008 (Versatile Link Duplex-Stecker) in Verbindung mit einer Duplex-Polymerfaser 2 x 2,2 mm Außendurchmesser (Z1190) für die Konnektierung des EK1541 empfohlen.
Verlegehinweise
•
zulässiger Biegeradius (im Allgemeinen gilt r ≥ 25 mm, Herstellerangaben beachten!)
•
zulässige Zugfestigkeit
•
Empfindlichkeit der ungeschützten Kontaktenden
Konnektieren und Lösen des POF-Kabels am Koppler
Zum Konnektieren des Kabels schieben Sie den Stecker (als Zubehör im Steckerset ZS1090-0008 erhältlich) bis zum hörbaren Einrasten in die Anschlussöffnung.
Rastnase mit Entriegelung am POF-Duplex-Stecker
Zum Lösen des Steckers die Entriegelung mit der Rastnase betätigen. Diese befindet sich dabei rechtseitig am Stecker (siehe Abbildung).
Hinweis
Beschädigung des Kabels möglich!
Zum Lösen des Kabels die Entriegelung am Stecker drücken und gleichzeitig am Stecker ziehen - niemals am POF-Kabel allein!
Hinweis
Tx / Rx -Kanalbelegung
Achten Sie bei der Kabelkonfektionierung auf die Belegung der optischen Kanäle in den Anschlussbuchsen. Beim EK1541 ist der lichtemittierende Transmitterkanal (Tx) jeweils der untere Auslass in den Anschlussbuchsen.

Abbildung: Transmitterkanäle beim EK1541
Beachten Sie unbedingt den Sicherheitshinweis zur Laser-Klasse 1!
Hinweis
Verwendung von Blindstopfen
Zur Vermeidung von Unfällen durch Blendung (Laserstrahl Klasse 1, bitte Sicherheitshinweis beachten) und zum Schutz des Transceivers vor Umwelteinflüssen sollten nicht verwendete Anschlussbuchsen mit den mitgelieferten Blindstopfen verschlossen werden!

Abbildung: Blindstopfen in nicht verwendeten Anschlussbuchsen


Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008

Inbetriebnahme/Anwendungshinweise [image] Anwendungshinweise [image] Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008
Hinweise zur Konfektionierung von POF-Kabeln mit dem Steckerset ZS1090-0008
Duplex-Steckerset ZS1090-0008
Das Duplex-Steckerset ZS1090-0008 von Beckhoff besteht aus 10 Duplex Versatile-Link-Steckverbindern und mehreren Bögen Schleif- und Polierpapier.
Schritt-für-Schritt-Anleitung zur Konfektionierung des POF-Kabels
Die nachfolgende Schritt-für-Schritt-Anleitung beschreibt die korrekte Konfektionierung eines POF-Kabels mit einem Versatile-Link-Duplex-Steckverbinder. Die Steckverbinder werden mit Standard-Werkzeugen wie Cutter-Messer oder Abisolierzange an die Kabelenden angebracht. Die Endpolitur des konfektionierten Kabels wird mit dem im Steckerset beigefügten Polierset, bestehend aus einer Plastik-Schleiflehre, Schleifpapierbögen mit der Körnung 600 und rosa Polierbögen durchgeführt. Die konfektionierte Steckverbindung kann sofort nach der Bearbeitung benutzt werden.
Für die Arbeitsschritte benötigtes Material:
1. POF-Kabel (Polymeric optical fiber, z.B. Z1190 von Beckhoff)
2. Cutter-Messer oder Schere
3. Abisolierzange
4. Polierset (im Steckerset ZS1090-0008 von Beckhoff enthalten)
5. Versatile Link Duplex-Stecker (im Steckerset ZS1090-0008 von Beckhoff enthalten)
1. Abisolieren des POF-Kabels
Das Kabel sollte auf einer Länge zwischen 100 und 150 mm vom Kabelende aufgetrennt sein, um die nachfolgenden Arbeiten ordnungsgemäß durchführen zu können.
Nachdem Sie das Kabel auf die gewünschte Länge gekürzt haben, entfernen sie mittels Abisolierzange ca. 7 mm der äußeren Ummantelung der Einzeladern. Die beiden Kabelenden sollten ungefähr gleich lang abisoliert sein.
POF-Kabel auf gleiche Länge abisoliert
2. Anbringen des Steckverbinders
Schieben Sie beide Kabelenden in den Steckverbinder und ziehen Sie den Steckverbinder bis zum Anschlag zurück. Die Fasern sollten jetzt nicht mehr als 1,5 mm aus den vorderen Öffnungen herausragen.
Sie schließen den Steckverbinder, indem Sie die obere und untere Hälfte zusammenklappen und einrasten lassen.
In den Steckverbinder eingelegtes Kabel
Geschlossener Steckverbinder
Achten Sie beim Einlegen der Leiter in die Steckverbinder auf die gekreuzte Verbindung der optischen Kanäle zur Gegenseite (Tx1 → Rx2; Tx2 → Rx1). Als Orientierung dient die Nase des Scharniers am Stecker.
Korrekt verbundene Optische Kanäle
3. Schleifen und Polieren
Fasern, die mehr als 1,5 mm aus dem Steckverbinder herausragen, müssen mit einem Cutter-Messer oder einer Schere eingekürzt werden.
Schieben Sie nun den Steckverbinder komplett in die Schleiflehre, so dass die zu polierenden Enden auf der unteren Seite herausragen. Die Schleiflehre ist zum Polieren von einem oder zwei Simplex- oder einem Duplex-Steckverbinder geeignet.
Schleiflehre mit herausragenden Faserenden
Verschleißanzeige
Die Verschleißanzeige der Schleiflehre besteht aus 4 Punkten auf der Unterseite. Sollte einer dieser Punkte nicht mehr sichtbar sein, ist die Schleiflehre zu ersetzen.
Pressen Sie nun mit gleichmäßigen Druck und möglichst senkrecht die Schleiflehre auf das Schleifpapier. Um ein gleichmäßiges Schleifergebnis zu erzielen, beschreiben Sie beim Schleifen die Form einer "8", bis die Fasern bündig mit der Schleiflehre abschließen. Anschließend reinigen Sie die Schleiflehre und den Steckverbinder von unten mit einem weichen, trockenen Tuch.
Polieren in Form einer "8"
4. Feinpolitur
Fahren Sie nun mit der Feinpolitur und dem rosa Polierbogen in gleicher Art und Weise fort. Dazu den bündigen Steckverbinder mit der Schleiflehre auf der matten Seite des Polierbogens mit leichtem Druck aufsetzen und die Form einer "8" maximal 25 mal beschreiben. Nach Abschluss der Prozedur sollte das Faserende flach, glatt und sauber sein.
Verbesserung der Übertragungsperformance durch Feinpolitur
Die Feinpolitur mit dem Polierbogen bringt eine Verbesserung der Übertragungsperformance von Transmitter zu Receiver oder in der Kabelverbindung von bis zu 0,5 dB gegenüber der Behandlung nur mit dem Schleifbogen allein. Der Arbeitsschritt des Polierens kann allerdings für kurze Übertragungsentfernungen ausgelassen werden.
Feinpolierte Fasern im Steckverbinder


Fehlerbehandlung und Diagnose

Fehlerbehandlung und Diagnose
Fehlerbehandlung und Diagnose
Weiterführende Informationen
•
Diagnose-LEDs


Diagnose-LEDs

Fehlerbehandlung und Diagnose [image] Diagnose-LEDs
Diagnose-LEDs
Diagnose-LEDs EK1100, EK1100-0008
Diagnose-LEDs EK1100, EK1100-0008
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Es wird eine Firmware geladen.
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK / ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit folgendem EtherCAT-Teilnehmer
LINK / ACT E-Bus | grün | aus | - | keine Verbindung interner E-Bus
 |  | an | linked | Verbindung interner E-Bus
 |  | blinkt | active | Verbindung/Kommunikation interner E-Bus
Diagnose LEDs EK1101-xxxx
Diagnose-LEDs EK1101-xxxx
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Es wird eine Firmware geladen.
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK / ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit folgendem EtherCAT-Teilnehmer
LINK / ACT E-Bus | grün | aus | - | keine Verbindung interner E-Bus
 |  | an | linked | Verbindung interner E-Bus
 |  | blinkt | active | Verbindung/Kommunikation interner E-Bus
Diagnose LEDs EK1501
Diagnose-LEDs Buskoppler EK1501
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Es wird eine Firmware geladen.
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK / ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit folgendem EtherCAT-Teilnehmer
LINK / ACT E-Bus | grün | aus | - | keine Verbindung interner E-Bus
 |  | an | linked | Verbindung interner E-Bus
 |  | blinkt | active | Verbindung/Kommunikation interner E-Bus
Diagnose-LEDs EK1501-0010
Diagnose-LEDs Buskoppler EK1501-0010
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Es wird eine Firmware geladen.
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK / ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit folgendem EtherCAT-Teilnehmer
LINK / ACT E-Bus | grün | aus | - | keine Verbindung interner E-Bus
 |  | an | linked | Verbindung interner E-Bus
 |  | blinkt | active | Verbindung/Kommunikation interner E-Bus
Diagnose-LEDs EK1541
Diagnose-LEDs Buskoppler EK1541
LEDs zur Diagnose der Spannungsversorgung
LED |  | Anzeige | Zustand | Beschreibung
Us | grün | aus | - | Keine Betriebsspannung am Buskoppler vorhanden
 |  | an | - | 24 VDC Betriebsspannung am Buskoppler vorhanden
Up | grün | aus | - | Keine Spannungsversorgung an den Powerkontakten vorhanden
 |  | an | - | Spannungsversorgung 24 VDC an den Powerkontakten vorhanden
LEDs zur Diagnose der EtherCAT State Machine/PLC
LED |  | Anzeige | Zustand | Beschreibung
RUN | grün | aus | Init | Der Buskoppler ist im Initialisierungs-Zustand
 |  | blinkt | Pre-Operational | Der Buskoppler ist im Zustand Pre-Operational
 |  | Einzelblitz | Safe-Operational | Der Buskoppler ist im Zustand Safe-Operational
 |  | an | Operational | Der Buskoppler ist im Zustand Operational
 |  | flackert | Bootstrap | Es wird eine Firmware geladen.
LEDs zur Feldbus-Diagnose
LED |  | Anzeige | Zustand | Beschreibung
LINK / ACT (X1 IN) | grün | aus | - | keine Verbindung auf dem ankommenden EtherCAT-Strang
 |  | an | linked | vorhergehender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit vorhergehendem EtherCAT-Teilnehmer
LINK / ACT (X2 OUT) | grün | aus | - | keine Verbindung auf dem weiterführenden EtherCAT-Strang
 |  | an | linked | folgender EtherCAT-Teilnehmer angeschlossen
 |  | blinkt | active | Kommunikation mit folgendem EtherCAT-Teilnehmer
LINK / ACT E-Bus | grün | aus | - | keine Verbindung interner E-Bus
 |  | an | linked | Verbindung interner E-Bus
 |  | blinkt | active | Verbindung/Kommunikation interner E-Bus


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
•
EtherCAT AL Status Codes
•
Firmware Kompatibilität
•
Firmware Update EL/ES/EM/EPxxxx
•
Support und Service


Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1

Anhang [image] Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
Sicherheitshinweis und Verhaltensregeln zur Laser-Klasse 1
SmallWarningYellow VORSICHT
Laser-Klasse 1 Produkt - Unfallgefahr durch Blendung!
Folgende laserspezifische Verhaltensregeln sind für die in dieser Dokumentation beschriebenen Produkte der Laser-Klasse 1 zu beachten:
•
Der Laserstrahl darf nicht auf Personen gerichtet werden, da es durch Blendung zu Unfällen kommen kann.
•
Nicht in den direkten oder reflektierten Strahl blicken.
•
Falls Laserstrahlung ins Auge trifft, sind die Augen bewusst zu schließen und der Kopf sofort aus dem Strahl zu bewegen.
•
Bei der Verwendung des Lasers dürfen keine optischen Instrumente zur Betrachtung der Strahlungsquelle verwendet werden, da dies zu einer Überschreitung der Expositionsgrenzwerte führen kann.
•
Manipulationen (Änderungen) an der Lasereinrichtung sind unzulässig.


EtherCAT AL Status Codes

Anhang [image] EtherCAT AL Status Codes
EtherCAT AL Status Codes
Detaillierte Informationen hierzu entnehmen Sie bitte der vollständigen EtherCAT-Systembeschreibung.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Die Koppler EK110x und EK15xx verfügen über keine Firmware.


Firmware Update EL/ES/EM/EPxxxx

Anhang [image] Firmware Update EL/ES/EM/EPxxxx
Firmware Update EL/ES/EM/EPxxxx
In diesem Kapitel wird das Geräteupdate für Beckhoff EtherCAT Slaves der Serien EL/ES, EM, EK und EP beschrieben. Ein FW-Update sollte nur nach Rücksprache mit dem Beckhoff Support durchgeführt werden.
Speicherorte
In einem EtherCAT-Slave werden an bis zu 3 Orten Daten für den Betrieb vorgehalten:
▪
Je nach Funktionsumfang und Performance besitzen EtherCAT Slaves einen oder mehrere lokale Controller zur Verarbeitung von IO-Daten. Das darauf laufende Programm ist die sog. Firmware im Format *.efw.
▪
In bestimmten EtherCAT Slaves kann auch die EtherCAT Kommunikation in diesen Controller integriert sein. Dann ist der Controller meist ein so genannter FPGA-Chip mit der *.rbf-Firmware.
▪
Darüber hinaus besitzt jeder EtherCAT Slave einen Speicherchip, um seine eigene Gerätebeschreibung (ESI; EtherCAT Slave Information) zu speichern, in einem sog. ESI-EEPROM. Beim Einschalten wird diese Beschreibung geladen und u.a. die EtherCAT Kommunikation entsprechend eingerichtet. Die Gerätebeschreibung kann von der Beckhoff Website (http://www.beckhoff.de) im Downloadbereich heruntergeladen werden. Dort sind alle ESI-Dateien als Zip-Datei zugänglich.
Kundenseitig zugänglich sind diese Daten nur über den Feldbus EtherCAT und seine Kommunikationsmechanismen. Beim Update oder Auslesen dieser Daten ist insbesondere die azyklische Mailbox-Kommunikation oder der Registerzugriff auf den ESC in Benutzung.
Der TwinCAT Systemmanager bietet Mechanismen, um alle 3 Teile mit neuen Daten programmieren zu können, wenn der Slave dafür vorgesehen ist. Es findet üblicherweise keine Kontrolle durch den Slave statt, ob die neuen Daten für ihn geeignet sind, ggf. ist ein Weiterbetrieb nicht mehr möglich.
Vereinfachtes Update per Bundle-Firmware
Bequemer ist der Update per sog. Bundle-Firmware: hier sind die Controller-Firmware und die ESI-Beschreibung in einer *.efw-Datei zusammengefasst, beim Update wird in der Klemme sowohl die Firmware, als auch die ESI verändert. Dazu ist erforderlich
▪
dass die Firmware in dem gepackten Format vorliegt: erkenntlich an dem Dateinamen der auch die Revisionsnummer enthält, z.B. ELxxxx-xxxx_REV0016_SW01.efw
▪
dass im Download-Dialog das Passwort=1 angegeben wird. Bei Passwort=0 (default Einstellung) wird nur das Firmware-Update durchgeführt, ohne ESI-Update.
▪
dass das Gerät diese Funktion unterstützt. Die Funktion kann in der Regel nicht nachgerüstet werden, sie wird Bestandteil vieler Neuentwicklungen ab Baujahr 2016.
Nach dem Update sollte eine Erfolgskontrolle durchgeführt werden
▪
ESI/Revision: z.B. durch einen Online-Scan im TwinCAT ConfigMode/FreeRun – dadurch wird die Revision bequem ermittelt
▪
Firmware: z.B. durch einen Blick ins Online-CoE des Gerätes
Hinweis
Beschädigung des Gerätes möglich!
Beim Herunterladen von neuen Gerätedateien ist zu beachten

• Das Herunterladen der Firmware auf ein EtherCAT-Gerät darf nicht unterbrochen werden
• Eine einwandfreie EtherCAT-Kommunikation muss sichergestellt sein, CRC-Fehler oder LostFrames dürfen nicht auftreten.
• Die Spannungsversorgung muss ausreichend dimensioniert, die Pegel entsprechend der Vorgabe sein

Bei Störungen während des Updatevorgangs kann das EtherCAT-Gerät ggf. nur vom Hersteller wieder in Betrieb genommen werden!
Weiterführende Informationen
•
Gerätebeschreibung ESI-File/XML
•
Erläuterungen zur Firmware
•
Update Controller-Firmware *.efw
•
FPGA-Firmware *.rbf
•
Gleichzeitiges Update mehrerer EtherCAT-Geräte


Gerätebeschreibung ESI-File/XML

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gerätebeschreibung ESI-File/XML
Gerätebeschreibung ESI-File/XML
Hinweis
ACHTUNG bei Update der ESI-Beschreibung/EEPROM
Manche Slaves haben Abgleich- und Konfigurationsdaten aus der Produktion im EEPROM abgelegt. Diese werden bei einem Update unwiederbringlich überschrieben.
Die Gerätebeschreibung ESI wird auf dem Slave lokal gespeichert und beim Start geladen. Jede Gerätebeschreibung hat eine eindeutige Kennung aus Slave-Name (9-stellig) und Revision-Nummer (4-stellig). Jeder im Systemmanager konfigurierte Slave zeigt seine Kennung im EtherCAT-Reiter:
Gerätekennung aus Name EL3204-0000 und Revision -0016
Die konfigurierte Kennung muss kompatibel sein mit der tatsächlich als Hardware eingesetzten Gerätebeschreibung, d.h. der Beschreibung die der Slave (hier: EL3204) beim Start geladen hat. Üblicherweise muss dazu die konfigurierte Revision gleich oder niedriger der tatsächlich im Klemmenverbund befindlichen sein.
Weitere Hinweise hierzu entnehmen Sie bitte der EtherCAT System-Dokumentation.
Update von XML/ESI-Beschreibung
Die Geräterevision steht in engem Zusammenhang mit der verwendeten Firmware bzw. Hardware. Nicht kompatible Kombinationen führen mindestens zu Fehlfunktionen oder sogar zur endgültigen Außerbetriebsetzung des Gerätes. Ein entsprechendes Update sollte nur in Rücksprache mit dem Beckhoff Support ausgeführt werden.
Anzeige der Slave-Kennung ESI
Der einfachste Weg die Übereinstimmung von konfigurierter und tatsächlicher Gerätebeschreibung festzustellen, ist im TwinCAT-Modus Config/FreeRun das Scannen der EtherCAT-Boxen auszuführen:
Rechtsklick auf das EtherCAT Gerät bewirkt das Scannen des unterlagerten Feldes
Wenn das gefundene Feld mit dem konfigurierten übereinstimmt, erscheint
Konfiguration identisch
ansonsten erscheint ein Änderungsdialog, um die realen Angaben in die Konfiguration zu übernehmen.
Änderungsdialog
In diesem Beispiel in Abb. „Änderungsdialog“. wurde eine EL3201-0000-0017 vorgefunden, während eine EL3201-0000-0016 konfiguriert wurde. In diesem Fall bietet es sich an, mit dem Copy Before-Button die Konfiguration anzupassen. Die Checkbox Extended Information muss gesetzt werden, um die Revision angezeigt zu bekommen.
Änderung der Slave-Kennung ESI
Die ESI/EEPROM-Kennung kann unter TwinCAT wie folgt aktualisiert werden:
▪
Es muss eine einwandfreie EtherCAT-Kommunikation zum Slave hergestellt werden
▪
Der State des Slave ist unerheblich
▪
Rechtsklick auf den Slave in der Online-Anzeige führt zum Dialog EEPROM Update, Abb. EEPROM Update
EEPROM Update
Im folgenden Dialog wird die neue ESI-Beschreibung ausgewählt, s. Abb. Auswahl des neuen ESI. Die CheckBox Show Hidden Devices zeigt auch ältere, normalerweise ausgeblendete Ausgaben eines Slave.
Auswahl des neuen ESI
Ein Laufbalken im Systemmanager zeigt den Fortschritt - erst erfolgt das Schreiben, dann das Veryfiing.
Änderung erst nach Neustart wirksam
Die meisten EtherCAT-Geräte lesen eine geänderte ESI-Beschreibung umgehend bzw. nach dem Aufstarten aus dem INIT ein. Einige Kommunikationseinstellungen wie z.B. Distributed Clocks werden jedoch erst bei PowerOn gelesen. Deshalb ist ein kurzes Abschalten des EtherCAT Slave nötig, damit die Änderung wirksam wird.


Erläuterungen zur Firmware

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Erläuterungen zur Firmware
Erläuterungen zur Firmware
Versionsbestimmung der Firmware
Versionsbestimmung nach Laseraufdruck
Auf einem Beckhoff EtherCAT Slave ist eine Seriennummer aufgelasert. Der Aufbau der Seriennummer lautet: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit Ser. Nr.: 12 10 03 02:
12 - Produktionswoche 12
10 - Produktionsjahr 2010
03 - Firmware-Stand 03
02 - Hardware-Stand 02
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der Controller-Firmware an, wenn der Slave online für den Master zugänglich ist. Klicken Sie hierzu auf die E-Bus-Klemme deren Controller-Firmware Sie überprüfen möchten (im Beispiel Klemme 2 (EL3204) und wählen Sie den Karteireiter CoE-Online (CAN over EtherCAT).
CoE-Online und Offline-CoE
Es existieren 2 CoE-Verzeichnisse:
• online: es wird im EtherCAT Slave vom Controller angeboten, wenn der EtherCAT Slave dies unterstützt. Dieses CoE-Verzeichnis kann nur bei angeschlossenem und betriebsbereitem Slave angezeigt werden.
• offline: in der EtherCAT Slave Information ESI/XML kann der Default-Inhalt des CoE enthalten sein. Dieses CoE-Verzeichnis kann nur angezeigt werden, wenn es in der ESI (z.B. "Beckhoff EL5xxx.xml") enthalten ist.
Die Umschaltung zwischen beiden Ansichten kann über den Button Advanced vorgenommen werden.
In Abb. Anzeige FW-Stand EL3204 wird der FW-Stand der markierten EL3204 in CoE-Eintrag 0x100A mit 03 angezeigt.
Anzeige FW-Stand EL3204
TwinCAT 2.11 zeigt in (A) an, dass aktuell das Online-CoE-Verzeichnis angezeigt wird. Ist dies nicht der Fall, kann durch die erweiterten Einstellungen (B) durch Online und Doppelklick auf All Objects das Online-Verzeichnis geladen werden.


Update Controller-Firmware *.efw

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Update Controller-Firmware *.efw
Update Controller-Firmware *.efw
CoE-Verzeichnis
Das Online-CoE-Verzeichnis wird vom Controller verwaltet und in einem eigenen EEPROM gespeichert. Es wird durch ein FW-Update im allgemeinen nicht verändert.
Um die Controller-Firmware eines Slave zu aktualisieren, wechseln Sie zum Karteireiter Online, s. Abb. Firmware Update.
Firmware Update
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen. Gültig für TwinCAT 2 und 3 als EtherCAT Master.
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
EtherCAT Master in PreOP schalten
▪
Slave in INIT schalten (A)
▪
Slave in BOOTSTRAP schalten
▪
Kontrolle des aktuellen Status (B, C)
▪
Download der neuen *efw-Datei, abwarten bis beendet. Ein Passwort wird in der Regel nicht benötigt.
▪
Nach Beendigung des Download in INIT schalten, dann in PreOP
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!)
▪
Im CoE 0x100A kontrollieren ob der FW-Stand korrekt übernommen wurde.


FPGA-Firmware *.rbf

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] FPGA-Firmware *.rbf
FPGA-Firmware *.rbf
Falls ein FPGA-Chip die EtherCAT-Kommunikation übernimmt, kann ggf. mit einer *.rbf-Datei ein Update durchgeführt werden.
▪
Controller-Firmware für die Aufbereitung der E/A-Signale
▪
FPGA-Firmware für die EtherCAT-Kommunikation (nur für Klemmen mit FPGA)
Die in der Seriennummer der Klemme enthaltene Firmware-Versionsnummer beinhaltet beide Firmware-Teile. Wenn auch nur eine dieser Firmware-Komponenten verändert wird, dann wird diese Versionsnummer fortgeschrieben.
Versionsbestimmung mit dem System-Manager
Der TwinCAT System-Manager zeigt die Version der FPGA-Firmware an. Klicken Sie hierzu auf die Ethernet-Karte Ihres EtherCAT-Stranges (im Beispiel Gerät 2) und wählen Sie den Karteireiter Online.
Die Spalte Reg:0002 zeigt die Firmware-Version der einzelnen EtherCAT-Geräte in hexadezimaler und dezimaler Darstellung an.
Versionsbestimmung FPGA-Firmware
Falls die Spalte Reg:0002 nicht angezeigt wird, klicken sie mit der rechten Maustaste auf den Tabellenkopf und wählen im erscheinenden Kontextmenü, den Menüpunkt Properties.
Kontextmenu Eigenschaften (Properties)
In dem folgenden Dialog Advanced Settings können Sie festlegen, welche Spalten angezeigt werden sollen. Markieren Sie dort unter Diagnose/Online Anzeige das Kontrollkästchen vor '0002 ETxxxx Build' um die Anzeige der FPGA-Firmware-Version zu aktivieren.
Dialog Advanced settings
Update
Für das Update der FPGA-Firmware
▪
eines EtherCAT-Kopplers, muss auf diesem Koppler mindestens die FPGA-Firmware-Version 11 vorhanden sein.
▪
einer E-Bus-Klemme, muss auf dieser Klemme mindestens die FPGA-Firmware-Version 10 vorhanden sein.
Ältere Firmware-Stände können nur vom Hersteller aktualisiert werden!
Update eines EtherCAT-Geräts
Es ist folgender Ablauf einzuhalten, wenn keine anderen Angaben z.B. durch den Beckhoff Support vorliegen:
▪
TwinCAT System in ConfigMode/FreeRun mit Zykluszeit >= 1 ms schalten (default sind im ConfigMode 4 ms). Ein FW-Update während Echtzeitbetrieb ist nicht zu empfehlen.
▪
Wählen Sie im TwinCAT System-Manager die Klemme an, deren FPGA-Firmware Sie aktualisieren möchten (im Beispiel: Klemme 5: EL5001) und klicken Sie auf dem Karteireiter EtherCAT auf die Schaltfläche Weitere Einstellungen:
▪
Im folgenden Dialog Advanced Settings klicken Sie im Menüpunkt ESC-Zugriff/E²PROM/FPGA auf die Schaltfläche Schreibe FPGA:
▪
Wählen Sie die Datei (*.rbf) mit der neuen FPGA-Firmware aus und übertragen Sie diese zum EtherCAT-Gerät:
▪
Abwarten bis zum Ende des Downloads
▪
Slave kurz stromlos schalten (nicht unter Spannung ziehen!). Um die neue FPGA-Firmware zu aktivieren ist ein Neustart (Aus- und Wiedereinschalten der Spannungsversorgung) des EtherCAT-Geräts erforderlich
▪
Kontrolle des neuen FPGA-Standes
Hinweis
Beschädigung des Gerätes möglich!
Das Herunterladen der Firmware auf ein EtherCAT-Gerät dürfen Sie auf keinen Fall unterbrechen! Wenn Sie diesen Vorgang abbrechen, dabei die Versorgungsspannung ausschalten oder die Ethernet-Verbindung unterbrechen, kann das EtherCAT-Gerät nur vom Hersteller wieder in Betrieb genommen werden!


Gleichzeitiges Update mehrerer EtherCAT-Geräte

Anhang [image] Firmware Update EL/ES/EM/EPxxxx [image] Gleichzeitiges Update mehrerer EtherCAT-Geräte
Gleichzeitiges Update mehrerer EtherCAT-Geräte
Die Firmware von mehreren Geräten kann gleichzeitig aktualisiert werden, ebenso wie die ESI-Beschreibung. Voraussetzung hierfür ist, dass für diese Geräte die gleiche Firmware-Datei/ESI gilt.
Mehrfache Selektion und FW-Update
Wählen Sie dazu die betreffenden Slaves aus und führen Sie das Firmware-Update im BOOTSTRAP Modus wie o.a. aus.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.