Titel

BECKHOFF CX90x0: Ethernet-Controller

Dokumentation zu

der Hardware des CX90x0-Systems

CX900x-xxxx

CX9010-xxxx

CX90x0-Nxxx

Version: 2.6
Datum: 01.03.2010


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr |
 | Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung |
 | Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis |
 | Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.

Grundlegende Sicherheitsmaßnahmen

Sorgfaltspflicht des Betreibers

Der Betreiber muss sicherstellen, dass
· das Produkt nur bestimmungsgemäß verwendet wird.
· das Produkt nur in einwandfreiem, funktionstüchtigem Zustand betrieben wird.
· die Betriebsanleitung stets in einem leserlichen Zustand und vollständig am Einsatzort des Produkts zur Verfügung steht.
· nur ausreichend qualifiziertes und autorisiertes Personal das Produkt bedient.
· dieses Personal regelmäßig in allen zutreffenden Fragen von Arbeitssicherheit und Umweltschutz unterwiesen wird, sowie die Betriebsanleitung und insbesondere die darin enthaltenen Sicherheitshinweise kennt.

Nationale Vorschriften je nach Maschinentyp

Je nach Maschinen- und Anlagentyp, in dem das Produkt zum Einsatz kommt, bestehen nationale Vorschriften für Steuerungen solcher Maschinen und Anlagen, die der Betreiber einhalten muss. Diese Vorschriften regeln unter anderem, in welchen Zeitabständen die Steuerung überprüft werden muss. Der Betreiber muss diese Überprüfung rechtzeitig veranlassen.

Anforderungen an das Bedienungspersonal

Betriebsanleitung lesen

Jeder Benutzer des Produkts muss die Betriebsanleitung für die Anlage, an der er eingesetzt wird, gelesen haben.

Systemkenntnisse

Jeder Benutzer muss alle für ihn erreichbaren Funktionen des Produkts kennen.


Ausgabestände der Dokumentation

Version | Änderungen
2.6 | Entsorgungshinweise zur Batterie hinzugefügt
2.5 | Image-Update überarbeitet
2.4 | Schnittstellen CX1200-xxxx entfernt
2.3 | Neue Einbaulagen hinzugefügt
2.2 | Neue Bezeichnung für Schnittstellen CX9000-N070 und CX9000-N080 hinzugefügt
2.1 | Neue Schnittstellen CX9000-N070 und CX9000-N080 hinzugefügt
2.0 | Hinweise zu CX9010, Batterie und Updateprozedur hinzugefügt
1.9 | Neue Bestellnummern eingepflegt
1.8 | Hinweise zur K-Bus Diagnose hinzugefügt
1.7 | Anmerkung zum USV-Betrieb, CF-Karten / Konfiguration hinzugefügt Titelbild geändert
1.6 | Image-Update per Software ergänzt
1.5 | Kabellänge für DVI Kabel korrigiert
1.4 | Kennzahlen für Leistungsaufnahme von Systemschnittstelle CX9000-A001 hinzugefügt
1.3 | Hinweise zu den DIP-Schaltern und Image-Update eingefügt
1.2 | Korrekturen und Anmerkungen zur CF-Karte
1.1 | Hinweise zur Systemschnittstelle N010 ergänzt
1.0 | überarbeitete Version
0.0.1 | Vorläufige Version (Urfassung)


Bestimmungsgemäße Verwendung

Die Geräteserie CX90x0 ist ein modulares Steuerungssystem, das für die Montage auf einer Hutschiene vorgesehen ist. Die System ist skalierbar, so dass je nach Aufgabenstellung, die benötigten Module zusammengesteckt und in den Schaltschrank oder Klemmenkasten eingebaut werden.

Abschalten des PCs nur nach Beendigung der Software

Bevor der Embedded-PC abgeschaltet werden darf muss die laufende Software regulär beendet werden, andernfalls können Daten auf der Festplatte verloren gehen. Lesen Sie dazu den Abschnitt "Ausschalten".

Wenn der PC nicht für Steuerungszwecke eingesetzt wird, beispielsweise während der Funktionsprüfung, müssen zuerst alle Anlagenteile abgeschaltet und danach der Embedded-PC von der Anlage abgekoppelt werden. Die Abkopplung geschieht durch Abziehen der ersten Klemme hinter dem Grundmodul und Abziehen der Stecker der Feldbusanschlüsse.
Abgeschaltete Anlagenteile müssen gegen Wiedereinschalten gesichert werden.

Das Netzteil des Embedded-PCs wird mit einer Spannung von 24 V DC versorgt.

Gefahr |
 | Keine Teile unter Spannung austauschen!

Beim Ein- und Ausbau von Komponenten muss die Versorgungsspannung abgeschaltet werden.

Softwarekenntnisse

Achtung |
 | Erforderliche Softwarekenntnisse!

Jeder Benutzer muss alle für ihn erreichbaren Funktionen der auf dem PC installierten Sotfware kennen.


CX90x0 Produktübersicht

BECKHOFF CX90x0: Produktübersicht

Systemübersicht

Ethernet-Controller CX90x0

Mit dem Embedded-PC CX90x0 präsentiert Beckhoff eine weitere Ergänzung der Embedded-Controller-Familie vom Typ CX. Der CX90x0 ist eine kompakte, leistungsfähige und dennoch preiswerte SPS und Motion-Control-Steuerung für die Hutschiene und positioniert sich in der Beckhoff-Steuerungswelt zwischen der Busklemmen-Controller-Serie BX und dem Embedded-PC vom Typ CX1000.
Hauptmerkmal dieses Geräts ist eine stromsparende, mit 266 MHz bzw. 533 MHz getaktete Intel® IXP420 CPU mit XScale®-Technologie, die das Betriebssystem Microsoft Windows CE ausführt. Somit steht ausreichend Rechenleistung zur Verfügung, um auch komplexe Automatisierungsaufgaben zu übernehmen. Für den Einsatz des CX90x0 sind keine externen Speichermedien erforderlich, das Gerät bootet das Betriebssystem aus dem internen Flash. Durch die niedrige Leistungsaufnahme wird im spezifizierten Betriebsbereich kein Lüfter benötigt. CX9000 kommt also ohne rotierende Bauteile aus. Der mechanische Aufbau des Gerätes ist – wie bei der CX-Serie üblich – modular gestaltet und kann in der Grundausstattung mit einer sehr kompakten Bauform von lediglich 58 x 100 x 91 mm aufwarten.

EtherCAT als schnelles I/O-System / K-Bus als alternatives I/O-System

Den CX90x0 gibt es in zwei Varianten: mit K-Bus-Interface für den direkten Anschluss von Busklemmen sowie als E-Bus-Variante für den direkten Anschluss von EtherCAT-Klemmen. Als Schnittstellen stehen in der Grundaustattung zwei RJ-45-Buchsen zur Verfügung, die intern auf einen integrierten Switch führen. Das erleichtert die Verdrahtung mehrerer CX90x0 in einer Linientopologie; der Einsatz separater Switchhardware ist überflüssig. Die beiden von außen zugänglichen Ethernet-Ports sind unabhängig von der EtherCAT-Schnittstelle, die durch einen zweiten MAC (Media Access Controller) der CPU bedient wird.

Grundmodul und Schnittstellen

Ab Werk können, je nach Bedarf, weitere Schnittstellen hinzugefügt werden: Falls eine Bildschirmdarstellung gewünscht ist, wird diese durch CX90x0-N001 – ein kombiniertes DVI/VGA + 2 x USB-2.0-Modul – realisiert. Die Kombination aus DVI und USB ermöglicht den Einsatz aller Beckhoff Control Panel mit DVI/USB-Schnittstelle; die Touchfunktionalität wird dabei über USB angeschlossen. Als weitere, optionale Schnittstellen können entweder zwei RS232- oder zwei RS422/RS485-Module konfiguriert werden, die als COM1 und COM2 zur Verfügung stehen. Alle seriellen Schnittstellen sind opto-entkoppelt. Massenspeicher, in Form einer Compact-Flash-Karte, kann mit Hilfe des Moduls CX90x0-A000 eingesetzt werden, dessen physikalische Speicherkapazitäten heute im Bereich mehrerer Gigabytes liegen können.

SPS, Motion Control und Visualisierung

Die Programmierung des CX90x0 als Automatisierungsgerät erfolgt, wie bei allen Beckhoff-Steuerungen, mit TwinCAT; auf dem Gerät selbst befindet sich die Laufzeitumgebung für SPS und Motion Control. Als Programmierschnittstelle dient eine der beiden Ethernet-Schnittstellen.

Die Software

Microsoft Windows CE ermöglicht die Erstellung vollgrafischer Benutzerprogramme, die dank des im CX90x0 integrierten Grafikchips auch höheren Ansprüchen genügen.

Der CX90x0 ist somit eine kompakte Ethernet-Steuerung, die in der Kombination mit EtherCAT-Klemmen kurze I/O-Zykluszeiten ermöglicht und mit Windows CE und TwinCAT eine leistungsfähige Softwareaustattung aufweist.


CX90x0 Produktübersicht

BECKHOFF CX90x0: Produktübersicht

Technische Daten

Ethernet-Controller CX90x0

Der Ethernet-Controller CX90x0 wird in zwei Varianten angeboten:

  • CX9000-0000 @266 MHz mit E-Bus-Anschluss
  • CX9000-1000 @266 MHz mit K-Bus-Anschluss
  • CX9010-0000 @533 MHz mit E-Bus-Anschluss
  • CX9010-1000 @533 MHz mit K-Bus-Anschluss

Bedingt durch die verschiedenen Klemmbusse, ergeben sich verschiedene Eigenschaften in den technischen Daten.


CX9000-0000: Technische Daten

BECKHOFF CX9000-0000: Produktübersicht

Technische Daten

Der CX9000 ist eine kompakte, hutschienenmontierbare Ethernet-Steuerung mit direktem Anschluss an die Beckhoff-I/O-Systeme in IP 20. Es stehen zwei Basisausführungsvarianten des CX9000 zur Verfügung: eine für Busklemmen mit K-Bus, die andere für EtherCAT-Klemmen mit E-Bus. Der CX9000 umfasst die CPU, den internen Flash- Speicher in zwei Ausbaustufen sowie den Arbeitsspeicher (RAM) in zwei wählbaren Größen und NOVRAM als nicht-flüchtigen Speicher. Zwei Ethernet-RJ-45-Schnittstellen gehören ebenfalls zur Basisausstattung. Diese Schnittstellen sind auf einen internen Switch geführt und bieten eine einfache Möglichkeit zum Aufbau einer Linientopologie ohne den zusätzlichen Einsatz von Ethernet-Switchen. Als optionales Modul steht ein Speichermedium im Compact-Flash-Format I und II zur Verfügung (nur in Verbindung mit Systemschnittstelle CX9000-N010). Das Betriebssystem ist Microsoft Windows CE. Durch die Automatisierungssoftware TwinCAT wird das CX9000-System zu einer leistungsfähigen SPS und Motion-Control-Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. Weitere Systemschnittstellen können ab Werk an das CPU-Modul angeschlossen werden. Die Option CX9000-N010 bietet über die DVI- und USB-Schnittstellen den Anschluss an Beckhoff Control Panel oder marktübliche Monitore mit DVI- oder VGA-Eingang. An die USB-Schnittstellen vom Typ USB 2.0 können Geräte, wie Drucker, Scanner, Maus, Tastatur, Massenspeicher, CR-RW usw., angeschlossen werden. Insgesamt zwei serielle RS232-Schnittstellen mit max. 115-kBaud-Übertragungsgeschwindigkeit bietet das Modul CX9000-N030. Diese zwei Schnittstellen können auch als RS422/ RS485 ausgeführt werden; die Bezeichnung lautet dann CX9000-N031.

Technische Daten | CX9000-0000
Prozessor | Intel® IXP420 mit XScale® Technologie, 266-MHz-Taktfrequenz
Interner Flash Speicher | 16 MByte Flash (intern, erweiterbar auf 32 MByte)
Interner Arbeitsspeicher | 64 MByte RAM (intern, erweiterbar auf 128 MByte)
Schnittstellen | 2 x RJ 45 (interner Switch), 10/100 MBit
Diagnose LED | 1 x Power, 2 x LAN, 1 x L/A, 1 x Flash-Zugriff
Uhr | interne batteriegepufferte Uhr für Zeit und Datum
Betriebssystem | Microsoft Windows CE
Steuerungssoftware | TwinCAT-CE-PLC-Runtime oder TwinCAT-CE-NC-PTP-Runtime
Spannungsversorgung | maximal 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung/interne Elektronik)
I/O-Anschluss | E-Bus (EtherCAT-Klemmen)
NOVRAM | 128 kByte
I/O-DPRAM | -
Stromversorgung I/O-Klemmen | 2 A
Max. Verlustleistung | 6 W (einschließlich der Systemschnittstellen CX9000-xxxx)
Abmessungen | 59 mm x 100 mm x 91 mm
Gewicht | ca. 250 g
Betriebs-/Lagertemperatur | 0° C ... +50° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20


CX9000-1000: Technische Daten

BECKHOFF CX9000-1000: Produktübersicht

Technische Daten

Der CX9000 ist eine kompakte, hutschienenmontierbare Ethernet-Steuerung mit direktem Anschluss an die Beckhoff-I/O-Systeme in IP 20. Es stehen zwei Basisausführungsvarianten des CX9000 zur Verfügung: eine für Busklemmen mit K-Bus, die andere für EtherCAT-Klemmen mit E-Bus. Der CX9000 umfasst die CPU, den internen Flash- Speicher in zwei Ausbaustufen sowie den Arbeitsspeicher (RAM) in zwei wählbaren Größen und NOVRAM als nicht-flüchtigen Speicher. Zwei Ethernet-RJ-45-Schnittstellen gehören ebenfalls zur Basisausstattung. Diese Schnittstellen sind auf einen internen Switch geführt und bieten eine einfache Möglichkeit zum Aufbau einer Linientopologie ohne den zusätzlichen Einsatz von Ethernet-Switchen. Als optionales Modul steht ein Speichermedium im Compact-Flash-Format I und II zur Verfügung (nur in Verbindung mit Systemschnittstelle CX9000-N010). Das Betriebssystem ist Microsoft Windows CE. Durch die Automatisierungssoftware TwinCAT wird das CX9000-System zu einer leistungsfähigen SPS und Motion-Control-Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. Weitere Systemschnittstellen können ab Werk an das CPU-Modul angeschlossen werden. Die Option CX9000-N010 bietet über die DVI- und USB-Schnittstellen den Anschluss an Beckhoff Control Panel oder marktübliche Monitore mit DVI- oder VGA-Eingang. An die USB-Schnittstellen vom Typ USB 2.0 können Geräte, wie Drucker, Scanner, Maus, Tastatur, Massenspeicher, CR-RW usw., angeschlossen werden. Insgesamt zwei serielle RS232-Schnittstellen mit max. 115-kBaud-Übertragungsgeschwindigkeit bietet das Modul CX9000-N030. Diese zwei Schnittstellen können auch als RS422/ RS485 ausgeführt werden; die Bezeichnung lautet dann CX9000-N031.

Technische Daten | CX9000-1000
Prozessor | Intel® IXP420 mit XScale® Technologie, 266-MHz-Taktfrequenz
Interner Flash Speicher | 16 MByte Flash (intern, erweiterbar auf 32 MByte)
Interner Arbeitsspeicher | 64 MByte RAM (intern, erweiterbar auf 128 MByte)
Schnittstellen | 2 x RJ 45 (interner Switch), 10/100 MBit
Diagnose LED | 1 x Power, 2 x LAN, 1 x K-Bus, 1 x Flash-Zugriff
Uhr | interne batteriegepufferte Uhr für Zeit und Datum
Betriebssystem | Microsoft Windows CE
Steuerungssoftware | TwinCAT-CE-PLC-Runtime oder TwinCAT-CE-NC-PTP-Runtime
Spannungsversorgung | maximal 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung/interne Elektronik)
I/O-Anschluss | K-Bus (Busklemmen)
NOVRAM | 128 kByte
I/O-DPRAM | 4 kByte
Stromversorgung I/O-Klemmen | 2 A
Max. Verlustleistung | 6 W (einschließlich der Systemschnittstellen CX9000-xxxx)
Abmessungen | 59 mm x 100 mm x 91 mm
Gewicht | ca. 250 g
Betriebs-/Lagertemperatur | 0° C ... +50° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20


CX9010-0000: Technische Daten

BECKHOFF CX9010-0000: Produktübersicht

Technische Daten

Der CX9010 ist eine kompakte, hutschienenmontierbare Ethernet-Steuerung mit direktem Anschluss an die Beckhoff-I/O-Systeme in IP 20. Es stehen zwei Basisausführungsvarianten des CX9010 zur Verfügung: eine für Busklemmen mit K-Bus, die andere für EtherCAT-Klemmen mit E-Bus. Anders als der CX9000 ist der CX9010 nur mit großem Speicherausbau (interner Flash- Speicher und Arbeitsspeicher (RAM) ) und NOVRAM als nicht-flüchtigen Speicher verfügbar. Zwei Ethernet-RJ-45-Schnittstellen gehören ebenfalls zur Basisausstattung. Diese Schnittstellen sind auf einen internen Switch geführt und bieten eine einfache Möglichkeit zum Aufbau einer Linientopologie ohne den zusätzlichen Einsatz von Ethernet-Switchen. Als optionales Modul steht ein Speichermedium im Compact-Flash-Format I und II zur Verfügung (nur in Verbindung mit Systemschnittstelle CX9010-N010). Das Betriebssystem ist Microsoft Windows CE. Durch die Automatisierungssoftware TwinCAT wird das CX9010-System zu einer leistungsfähigen SPS und Motion-Control-Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. Weitere Systemschnittstellen können ab Werk an das CPU-Modul angeschlossen werden. Die Option CX9010-N010 bietet über die DVI- und USB-Schnittstellen den Anschluss an Beckhoff Control Panel oder marktübliche Monitore mit DVI- oder VGA-Eingang. An die USB-Schnittstellen vom Typ USB 2.0 können Geräte, wie Drucker, Scanner, Maus, Tastatur, Massenspeicher, CR-RW usw., angeschlossen werden. Insgesamt zwei serielle RS232-Schnittstellen mit max. 115-kBaud-Übertragungsgeschwindigkeit bietet das Modul CX9010-N030. Diese zwei Schnittstellen können auch als RS422/ RS485 ausgeführt werden; die Bezeichnung lautet dann CX9010-N031.

Technische Daten | CX9010-0000
Prozessor | Intel® IXP420 mit XScale® Technologie, 533-MHz-Taktfrequenz
Interner Flash Speicher | 32 MByte Flash (intern)
Interner Arbeitsspeicher | 128 MByte RAM (intern)
Schnittstellen | 2 x RJ 45 (interner Switch), 10/100 MBit
Diagnose LED | 1 x Power, 2 x LAN, 1 x L/A, 1 x Flash-Zugriff
Uhr | interne batteriegepufferte Uhr für Zeit und Datum
Betriebssystem | Microsoft Windows CE
Steuerungssoftware | TwinCAT-CE-PLC-Runtime oder TwinCAT-CE-NC-PTP-Runtime
Spannungsversorgung | maximal 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung/interne Elektronik)
I/O-Anschluss | E-Bus (EtherCAT-Klemmen)
NOVRAM | 128 kByte
I/O-DPRAM | -
Stromversorgung I/O-Klemmen | 2 A
Max. Verlustleistung | 6,5 W (einschließlich der Systemschnittstellen CX9010-xxxx)
Abmessungen | 59 mm x 100 mm x 91 mm
Gewicht | ca. 250 g
Betriebs-/Lagertemperatur | 0° C ... +50° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20


CX9000-1000: Technische Daten

BECKHOFF CX9010-1000: Produktübersicht

Technische Daten

Der CX9010 ist eine kompakte, hutschienenmontierbare Ethernet-Steuerung mit direktem Anschluss an die Beckhoff-I/O-Systeme in IP 20. Es stehen zwei Basisausführungsvarianten des CX9010 zur Verfügung: eine für Busklemmen mit K-Bus, die andere für EtherCAT-Klemmen mit E-Bus. Anders als der CX9000 ist der CX9010 nur mit großem Speicherausbau (interner Flash- Speicher und Arbeitsspeicher (RAM) ) und NOVRAM als nicht-flüchtigen Speicher verfügbar. Zwei Ethernet-RJ-45-Schnittstellen gehören ebenfalls zur Basisausstattung. Diese Schnittstellen sind auf einen internen Switch geführt und bieten eine einfache Möglichkeit zum Aufbau einer Linientopologie ohne den zusätzlichen Einsatz von Ethernet-Switchen. Als optionales Modul steht ein Speichermedium im Compact-Flash-Format I und II zur Verfügung (nur in Verbindung mit Systemschnittstelle CX9010-N010). Das Betriebssystem ist Microsoft Windows CE. Durch die Automatisierungssoftware TwinCAT wird das CX9010-System zu einer leistungsfähigen SPS und Motion-Control-Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. Weitere Systemschnittstellen können ab Werk an das CPU-Modul angeschlossen werden. Die Option CX9010-N010 bietet über die DVI- und USB-Schnittstellen den Anschluss an Beckhoff Control Panel oder marktübliche Monitore mit DVI- oder VGA-Eingang. An die USB-Schnittstellen vom Typ USB 2.0 können Geräte, wie Drucker, Scanner, Maus, Tastatur, Massenspeicher, CR-RW usw., angeschlossen werden. Insgesamt zwei serielle RS232-Schnittstellen mit max. 115-kBaud-Übertragungsgeschwindigkeit bietet das Modul CX9010-N030. Diese zwei Schnittstellen können auch als RS422/ RS485 ausgeführt werden; die Bezeichnung lautet dann CX9010-N031.

Technische Daten | CX9010-1000
Prozessor | Intel® IXP420 mit XScale® Technologie, 533MHz-Taktfrequenz
Interner Flash Speicher | 32 MByte Flash (intern)
Interner Arbeitsspeicher | 128 MByte RAM (intern)
Schnittstellen | 2 x RJ 45 (interner Switch), 10/100 MBit
Diagnose LED | 1 x Power, 2 x LAN, 1 x K-Bus, 1 x Flash-Zugriff
Uhr | interne batteriegepufferte Uhr für Zeit und Datum
Betriebssystem | Microsoft Windows CE
Steuerungssoftware | TwinCAT-CE-PLC-Runtime oder TwinCAT-CE-NC-PTP-Runtime
Spannungsversorgung | maximal 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung/interne Elektronik)
I/O-Anschluss | K-Bus (Busklemmen)
NOVRAM | 128 kByte
I/O-DPRAM | 4 kByte
Stromversorgung I/O-Klemmen | 2 A
Max. Verlustleistung | 6,5 W (einschließlich der Systemschnittstellen CX9000-xxxx)
Abmessungen | 59 mm x 100 mm x 91 mm
Gewicht | ca. 250 g
Betriebs-/Lagertemperatur | 0° C ... +50° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20


CX9000: Ausführungen

BECKHOFF CX9000: Produktübersicht

Ausführungen

Die Bestellbezeichnung des CPU-Grundmoduls ergibt sich aus folgender Bezeichnungssystematik:

Da nicht alle Kombinationen sinnvoll sind, werden in der nachfolgenden Tabelle die zulässigen Kombinationen aufgeschlüsselt wiedergegeben:

Bestellnummer | 16 MB Flash 64 MB RAM | 32 MB Flash 128 MB RAM | E-Bus | K-Bus | DVI, 2 x USB | kein TwinCAT | TwinCAT- PLC-Runtime | TwinCAT- NC-Runtime
CX9000-0000 | x | - | x | - | - | x | - | -
CX9000-0001 | x | - | x | - | - | - | x | -
CX9000-1000 | x | - | - | x | - | x | - | -
CX9000-1001 | x | - | - | x | - | - | x | -
CX9001-0000 | - | x | x | - | - | x | - | -
CX9001-0001 | - | x | x | - | - | - | x | -
CX9001-0002 | - | x | x | - | - | - | x | x
CX9001-0100 | - | x | x | - | x | x | - | -
CX9001-0101 | - | x | x | - | x | - | x | -
CX9001-0102 | - | x | x | - | x | - | x | x
CX9001-1000 | - | x | - | x | - | x | - | -
CX9001-1001 | - | x | - | x | - | - | x | -
CX9001-1002 | - | x | - | x | - | - | x | x
CX9001-1100 | - | x | - | x | x | x | - | -
CX9001-1101 | - | x | - | x | x | - | x | -
CX9001-1102 | - | x | - | x | x | - | x | x


CX9010: Ausführungen

BECKHOFF CX9010: Produktübersicht

Ausführungen

Die Bestellbezeichnung des CPU-Grundmoduls ergibt sich aus folgender Bezeichnungssystematik:

Da nicht alle Kombinationen sinnvoll sind, werden in der nachfolgenden Tabelle die zulässigen Kombinationen aufgeschlüsselt wiedergegeben:

Bestellnummer | E-Bus | K-Bus | DVI, 2 x USB | kein TwinCAT | TwinCAT- PLC-Runtime | TwinCAT- NC-Runtime
CX9010-0000 | x | - | - | x | - | -
CX9010-0001 | x | - | - | - | x | -
CX9010-0002 | x | - | - | - | x | x
CX9010-0100 | x | - | x | x | - | -
CX9010-0101 | x | - | x | - | x | -
CX9010-0102 | x | - | x | - | x | x
CX9010-1000 | - | x | - | x | - | -
CX9010-1001 | - | x | - | - | x | -
CX9010-1002 | - | x | - | - | x | x
CX9010-1100 | - | x | x | x | - | -
CX9010-1101 | - | x | x | - | x | -
CX9010-1102 | - | x | x | - | x | x


CX90x0: Anschlüsse

an

BECKHOFF CX90x0: Produktübersicht

Anschlüsse

Die Stromversorgung erfolgt über das integrierte Netzteil. Dieses wird wie folgt angeschlossen:

Das Grundmodul wird über die oberen Stromanschlüsse mit 24 V DC versorgt. Der Klemmbus kann über die unteren Schnittstellen versorgt werden.

UL-Anforderungen

Gefahr

Zur Einhaltung der UL-Anforderungen dürfen die CX-Controller nur nur mit Versorgungsspannungen (24 VDC) versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammen.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!

Diese UL-Anforderungen gelten für alle Versorgungsspannungen der CX-Controller!

Zur Einhaltung der UL-Anforderungen dürfen die CX-Controller nicht mit unbegrenzten Spannungsquellen verbunden werden!

CPU Grundmodul mit 2 Ethernet RJ 45 Schnittstellen:

RJ 45 Schnittstelle (Buchse):

Belegung der RJ45-Schnittstelle, Port 1:

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

TD & RD werden an den Hubs, oder zwischen zwei PCs getauscht.

Belegung der RJ45-Schnittstelle, Port 2:

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

TD & RD werden an den Hubs, oder zwischen zwei PCs getauscht.

Verbindung der Ethernet Schnittstellen:

Achtung |
 | Es ist nicht erlaubt, die beiden Ethernet Schnittstellen eines CPU-Grundmoduls mit ein und demselben externen Switch zu verbinden!

Hinweis

Nur für den Gebrauch mit LAN Verbindungen, nicht mit Telekommunikationsanlagen verbinden.

Schematische Struktur der Netzwerkomponenten:

Der CX90x0 verfügt über zwei in der CPU integrierte MAC-Bausteine. Der Erste (MAC1) bedient über einen Switch die beiden Netzwerkschnittstellen zu den Ethernet-Ports. Auf diese Weise kann, wie unten beschrieben, eine Linienstruktur aufgebaut werden. Für das Betriebssystem handelt es sich dabei aber nur um einen Anschluss. Der zweite Baustein (MAC2) bedient im Fall der Variante CX900x-0xxx (E-Bus-Anschaltung) die Klemmen des E-Bus. Sie wird auf einen FPGA geführt. Dieser setzt die Ethernetsignale in EtherCAT-Signale um. So wird eine Anbindung an den E-Bus für EtherCAT-Klemmen realisiert.

Wird als Klemmbus der K-Bus verwendet (CX900x-1xxx), so wird die Anbindung an den FPGA nicht genutzt. Die zweite MAC-Schnittstelle ist nicht angeschlossen.

Sicht des Betriebssystems:

Für das Betriebssystem ist nur einer der Anschlüsse für die Netzwerkschnittstelle sichtbar. Außerdem hat sie immer den Status verbunden, da der Switch direkt angeschlossen ist.

Die auf einen internen 3-Port-Switch geführten Schnittstellen bieten eine einfache Möglichkeit zum Aufbau einer Linientopologie, ohne den zusätzlichen Einsatz von Ethernet-Switchen.

CPU Grundmodul mit DVI/USB Schnittstelle:

Dieses Grundmodul enthält zusätzlich zu den beiden Ethernet Schnittstellen DVI / USB Schnittstellen. Die Pinbelegung des CPU Grundmoduls mit zwei USB und einer DVI-I Schnittstelle ist bei der zugehörigen Systemschnittstelle CX90x0-N010 erklärt.

Gültig für alle CPU Grundmodule:

LED

Bei ordnungsgemäßem Anschluss des CPU Grundmoduls an ein Netzteil mit eingeschalteter Spannungsversorgung leuchtet die grüne LED Power (PWR) auf.

Compact Flash Einschub

Weitere Informationen finden Sie unter Compact Flash Einschub.


CX-System: Batterie

BECKHOFF CX-System: Produktübersicht

Batteriefach

Auf der linken Seite des CPU-Moduls, zwischen den beiden Ethernet Schnittstellen, befindet sich das Batteriefach.

Dieses kann mit Hilfe eines Schraubenziehers vorsichtig geöffnet werden.

Bei der Batterie handelt es sich um eine Typ CR2032 von Panasonic.

Die genauen Daten lauten wie folgt:

Batterietyp | Elektrische Eigenschaften (bei 20° C) |  | Standard Belastung | Abmessungen
 | nominal Spannung | nominal Kapazität | kontinuierliche Last | Durchmesser | Höhe | Gewicht
CR2032 | 3,0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

Gefahr |
 | Eine falsch eingesetzte Batterie kann explodieren! Verwenden Sie ausschließlich denselben Batterietyp (CR2032) von Sanyo oder Panasonic. Achten Sie unbedingt darauf, dass die Plus- und Minuspole der Batterie korrekt eingelegt wird. (Minuspol links) Öffnen Sie die Batterie niemals und werfen Sie die Batterie niemals in ein Feuer. Die Batterie kann nicht wieder aufgeladen werden.

Hinweis |
 | Die Batterie muss alle 5 Jahre gewechselt werden. Ersatzbatterien können beim Beckhoff Service bestellt werden. Altbatterie- Rücknahme: Altbatterien dürfen nicht in den Hausmüll. Verbraucher sind verpflichtet, Batterien zu einer geeigneten Sammelstelle bei Handel oder Kommune zu bringen. Sie können nach Gebrauch an den bekannten Sammelstellen und auch bei der Beckhoff Automation GmbH unentgeltlich zurückgegeben werden. Altbatterien enthalten möglicherweise Schadstoffe oder Schwermetalle, die Umwelt und Gesundheit schaden können. Batterien werden wieder verwertet, sie enthalten wichtige Rohstoffe wie Eisen, Zink, Mangan oder Nickel. Die Umwelt und Beckhoff sagen Dankeschön.


CX90x0: DIP SCHALTER Einstellungen

BECKHOFF CX90x0: DIP-Schalter Einstellungen

CX90x0: DIP-Schalter Einstellungen

Allgemeines

Achtung

Im Normalfall ist eine Änderung der DIP Schalter nicht notwendig. Die Schalter dienen zur Beseitigung von schwerer Einstellungsfehler um das System in den Auslieferzusatnd zurück zu setzen, Debug-Infromationen zu erhalten, ein neues System in den internen Speicher zu laden oder TwinCAT im Config Mode zu starten.

Diese Eingriffe sollten NUR im Notfall erfolgen - Ein laufendes System sollte nicht verändert werden!

Um Zugriff auf die DIP-Schalter zu erhalten, muss die Klappe zum Batteriefach geöffnet werden. Sie befindet sich auf der Frontseite des CX90x0-N000 Moduls zwischen den Ethernet-Schnittstellen. Die Klappe wird wie folgt geöffnet:

  1. Schalten Sie das CX90x0-System ab und trennen sie es von der Stromversorgung.
  2. Öffnen Sie das Batteriefach. Um es zu öffnen kann ein Schraubendreher zur Hilfe verwendet werden. (Vorsichtig Vorgehen um das Gerät nicht zu beschädigen.

Ist die Klappe geöffnet, kann auf die vier DIP-Schalter zugegriffen werden. Sie befinden sich links von dem Batteriehalter. Im Normalbetrieb sind alle Schalter auf AUS gesetzt (Alle Schalter sind in Stellung unten)

Um die Einstellung der Schalter zu ändern, sollte ein Schraubendreher mit kurzer Spitze verwendet werden (2,5 mm x 7,5 cm Länge und paralleler Spitze, Beckhoff Bestellnummer ZB8700). Die Spitze vorsichtig benutzen um das Gerät nicht zu beschädigen!

Die Schalter haben folgende Funktionen:

  1. Rücksetzen des CX90x0-Sytems in den Auslieferzustand
  2. Senden von Debug-Meldungen an die serielle Schnittstelle COM1
  3. Update mode um ein neues Systemabbild über einen PC Server einzuspielen (Bootmenu über COM1)
  4. TwinCAT im Config mode starten

Die einzelnen Funktion lauten im Detail:

Rücksetzen des CX90x0-Sytems in den Auslieferzustand:

  1. Setzen Sie den DIP-Schalter 1 auf ON (Schalter 1 auf Schalterstellung oben).
  2. Verbinden Sie das CX-System mit Stromquelle und booten Sie das System. Nach einem vollständigen Bootprozess ist das System wieder im Auslieferzustand.
  3. Fahren Sie das System herunter und setzen Sie den DIP-Schalter 1 wieder auf OFF (Schalter 1 auf Schalterstellung untern) und schließen Sie die Abdeckung.

Senden von Debug-Meldungen an die serielle Schnittstelle COM1:

  1. Setzen Sie den DIP-Schalter 2 auf ON (Schalter 2 auf Schalterstellung oben).
  2. Schließen Sie ein Monitorgerät Drucker oder Terminal an die serielle Schnittstelle an. (Schnittstellenparameter: 38400 baud, 8 bits , NO parity und 1 stop bit (38400,8,N,1).
  3. Verbinden Sie das CX-System mit Stromquelle und booten Sie das System. Die Debug-Meldungen werden an die serielle Schnittstelle gesendet.
  4. Nach Beendigung der Diagnose fahren Sie das System herunter und setzen Sie den DIP-Schalter 2 wieder auf OFF (Schalter 2 auf Schalterstellung untern) und schließen Sie die Abdeckung.

Bootstrap Mode zum Einspielen von Updates:

Der Bootstrap Mode ist zum Einspielen von Updates implementiert. Der gesamte Vorgang ist sehr komplex, daher wird dieser Vorgang in einem eigenem Abschnitt erklärt. Halten Sie sich an diese Anleitung um Schäden an dem Gerät zu vermeiden..

TwinCAT im "Config Mode" starten:

In einigen Fällen (z.B. Fehler im Bootprojekt) ist es notwendig, dass TwinCAT nicht automatisch in den "Run-Mode" startet. In diesem Fall kann das Bootprojekt verändert und Einstellungen gesetzt werden.

  1. Setzen Sie den DIP-Schalter 4 auf ON (Schalter 4 auf Schalterstellung oben).
  2. Verbinden Sie das CX-System mit Stromquelle und booten Sie das System.
  3. Verändern Sie die Einstellungen im SPS-Projekt
  4. Nach Beendigung der Änderungen fahren Sie das System herunter und setzen Sie den DIP-Schalter 4 wieder auf OFF (Schalter 4 auf Schalterstellung untern) und schließen Sie die Abdeckung.


CX90x0-Nxxx: Technische Daten

BECKHOFF CX90x0: Systemschnittstellen

Technische Daten:

Abmessungen:

Wie zu der CX1020-CPU sind zum CPU-Grundmodul CX90x0 eine Reihe Systemschnittstellenmodule erhältlich. Diese werden ab Werk montiert. Die optional stehen folgende Systemerweiterungen zur Verfügung:

  • CX90x0-N010 DVI / USB Modul
  • CX90x0-N030 serielle Schnittstellen für RS323
  • CX90x0-N031 serielle Schnittstellen für RS422 / RS485

CX90x0-N010 bietet über die DVI- und USB-Schnittstellen den Anschluss an Beckhoff Control-Panel oder marktübliche Monitore mit DVI- oder VGA-Eingang an. An die USB-Schnittstellen vom Typ USB 2.0 können Geräte wie Maus, Tastatur, Drucker, Scanner, Massenspeicher, und weitere angeschlossen werden. Es sind aber dann Treiber für das entsprechende Betriebssystem (Windows CE / XPe) zu installieren. Insgesamt zwei serielle RS232-Schnittstellen mit max. 115-kBaud-Übertragungsgeschwindigkeit bietet das Module CX90x0-N030. Diese zwei Schnittstellen können paarweise als RS422/RS485 ausgeführt werden; die Bezeichnungen lauten dann CX90x0-N031. Die Systemschnittstellen sind nicht im Feld nachrüstbar oder erweiterbar. Ein CF-Karten-Leser wird durch das Modul CX90x0-A001 bereitgestellt. Die Schnittstellen werden in der bestellten Konfiguration ab Werk geliefert und sind vom CPU-Modul nicht trennbar. Die Systemschnittstellen führen den internen PC104-Bus durch, so dass an sie weitere CX-Komponenten angeschlossen werden können. Die Spannungsversorgung der Systemschnittstellenmodule wird über den internen PC104-Bus gewährleistet.

Technische Daten | CX90x0-N010 | CX90x0-N030 | CX90x0-N031
Schnittstellen | 1 x DVI + 2 x USB 2.0 max. 100 mA pro Port | 1 x COM1+2, RS232 | 1 x COM1+2, RS422/RS485
Anschlussart | DVI-I 29-polige Buchse + 2 USB Ports Typ A | 2 x D-Sub Stecker 9-polig | 2 x D-Sub Buchse 9-polig
Eigenschaften | DVI-I Schnittstelle führt auch VGA Signale aus (DVI-A) | max. Baudrate 115 kBaud, nicht gleichzeitig mit N031 einsetzbar | max. Baudrate 115 kBaud, nicht gleichzeitig mit N030 einsetzbar
Spannungsversorgung | über Systembus (durch Netzteilmodul in CX900)
Abmessungen | 19 mm x 100 mm x 51 mm
Betriebstemperatur | 0 °C ... +55 °C
Lagertemperatur | -25 °C ... +85 °C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20
Gewicht | ca. 80 g


Anschlüsse CX90x0-N010

Dieses Modul liefert zusätzlich zur den zwei Ethernetschnittstellen des CPU-Grundmoduls eine DVI-I und zwei USB Schnittstellen.

Achtung |
 | Die Systemschnittstelle CX90x0-N010 ist ausschließlich für die Verwendung mit großem Speicherausbau (CX9001-x00x) vorgesehen.

DVI-I Schnittstelle

Die DVI-I Schnittstelle überträgt analoge und digitale Daten und eignet sich für den Anschluss an digitale Displays. Die Auflösung am Bildschirm oder Beckhoff Control Panel ist abhängig von der Entfernung zum Anzeigegerät. Die maximale Entfernung beträgt 5 m.

Die DVI Schnittstelle führt VGA Signale aus, so dass der Anschluss von CRT-VGA Monitoren an das CX90x0 System unter Verwendung eines DVI-to-VGA Adapters ebenfalls möglich ist. Dieser Adapter ist als Zubehör erhältlich.

DVI-I Buchse:

Pin | Belegung | Pin | Belegung | Pin | Belegung
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -

Pinbelegung Kreuz

Pin | Belegung
C1 | Analog Red Video Out
C2 | Analog Green Video Out
C3 | Analog Blue Video Out
C4 | Analog Horizontal Sync

Auflösung am Monitor:

Auflösung in Pixel | Entfernung der Schnittstelle vom Monitor
1600 x 1200 | 5 m
1280 x 1024 | 5 m
1024 x 768 | 5 m
800 x 600 | 5 m
640 x 480 | 5 m

USB Schnittstelle:

Die USB Buchse ist vom Typ A. Die USB Schnittstelle entspricht der USB 2.0 Spezifikation.

Pin | Belegung | Typische Zuordnung
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


Anschlüsse CX90x0-N030

Die Systemschnittstelle CX90x0-N030 stellt zwei RS232 Schnittstellen, COM1 und COM2, bereit. Beide sind auf einer 9-poligen Sub-D Stiftleiste ausgeführt. Die Pinbelegung aller Stecker ist identisch und wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle RS232 (Stecker):

Pinbelegung COM Schnittstelle:

PIN | Signal | Typ | Beschreibung
1 | DCD | Signal in | Data Carrier Detected
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground
6 | DSR | Signal in | Dataset Ready
7 | RTS | Signal out | Request to Send
8 | CTS | Signal in | Clear to Send
9 | RI | Signal in | Ring Indicator

Achtung

Die Systemschnittstelle CX90x0-N030 kann nur anstatt und nicht gleichzeitig mit CX90x0-N031 verwendet werden.

Die Systemschnittstelle CX90x0-N031 kann nur anstatt und nicht gleichzeitig mit CX90x0-N030 verwendet werden.


Anschlüsse CX90x0-N031

Die Systemschnittstelle CX90x0-N031 stellt zwei RS422 bzw. RS485 Schnittstellen, COM1 und COM2, bereit. Beide sind auf einer 9-poligen Sub-D Buchsenleiste ausgeführt. Die Pinbelegung aller Stecker ist identisch und wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle (Buchse):

Pinbelegung COM Schnittstelle:

PIN | Signal | Typ | Beschreibung
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

Für RS 485 muss Pin 2 und 3 ( Data +) sowie Pin7 und 8 (Data -) verbunden werden.

Einstellung der Schnittstellen Parameter

Wenn das Schnittstellenmodul CX90x0-N031 sich als letztes in der Reihe Systemmodule befindet, ist der Zugriff auf die DIP-Schalter möglich. Entweder muss zuvor die Endabdeckung oder eventuelle Busmaster/Slaves entfernt werden. Details hierzu finden sich im Kapitel Abbau / Entsorgung. Liegt die Modulseite frei, so ist folgendes zu sehen:

Der obere Schalter ist für die obere Schnittstelle, der untere entsprechend für die untere Schnittstelle zuständig. Die Schnittstellen können unabhängig von einander eingestellt werden. Mit einem langen, kleinen Schraubenzieher können die einzelnen Schalter vorsichtig gesetzt werden. Zum Einstellen ist das System abzuschalten!

Einstellung DIP-Switches RS485:

RS485 without Echo, End-Point ( Terminated) DEFAULT EINSTELLUNG

DIP | Status | Funktion
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | on | Auto receive on
6 | off | Always receive on
7 | on | Term on
8 | on | Term on

RS485 with Echo, End-Point ( Terminated)

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

RS485 without Echo, Drop-Point ( without Termination)

DIP | Status | Funktion
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

RS485 with Echo, Drop-Point ( without Termination)

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

Einstellung DIP-Switches RS422:

RS422 full duplex end point

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | off | Auto send on
4 | on | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

Achtung

Die Systemschnittstelle CX90x0-N031 kann nur anstatt und nicht gleichzeitig mit CX90x0-N030 verwendet werden.

Die Systemschnittstelle CX90x0-N030 kann nur anstatt und nicht gleichzeitig mit CX90x0-N031 verwendet werden.


Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Abmessungen (B x H x T): 19 x 100 x 91 mm (Systemschnittstelle), 58 x 100 x 91 mm (Grundmodul)

Gewicht: 80 g (Systemschnittstelle) bis 250 g (Grundmodul)

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:
1. Entfernen Sie die Verpackung.
2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Wiedertransport auf.
3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung |
 | Beschädigungsgefahr des Gerätes!

Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung).
Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


CX90x0: Maße

BECKHOFF CX90x0: Einbau und Verdrahtung

Maße

Die Produktreihe CX90x0 zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein CPU Modul und ein Netzteil sowie die entsprechenden Systemschnittstellen und die Feldbusschnittstellen vorgesehen werden. Die Gesamtbreite der Anwendung setzt sich aus den einzelnen verwendeten Module zusammen.
Mit einer Höhe von 100 mm entsprechen die Maße der Module exakt denen der Beckhoff Busklemmen. Achtung: es muss noch ein Sicherheitsabstand zur ausreichenden Kühlung des CPU-Moduls vorgesehen werden. (Details hierzu unter Einbaulage) Außerdem ermöglichen die abgesenkten Steckerflächen den Einsatz in einem Standard Klemmenkasten von 120 mm Tiefe.

Achtung

Um die Kühlung des Geräts im laufenden Betrieb sicherzustellen ist es wichtig, die Sicherheitsabstände einzuhalten.

CX90x0-x000 CPU-Grundmodule:

ohne Kühlelement:

mit Kühlelement:

CX90x0-N0x0 Systemschnittstellen:

CX1100-09x0 USV Modul:

CX1100-0900

CX1100-0910

CX1100-0920


CX90x0: Mechanischer Zusammenbau des Grundmoduls

BECKHOFF CX-System: Einbau und Verdrahtung

Mechanischer Zusammenbau des Grundmoduls

Der Einbau der Module erfolgt in drei Schritten:

1. Reihenfolge der Module

Das CPU-Grundmodul mit den werkseitig links angeschlossenen Systemschnittstellen wird auf der linken Seite um die USV-Module, soweit vorhanden, erweitert.

2. Aufrasten auf die Hutschiene

Auf der Unterseite der Module befindet sich eine weiße Zuglasche, die mit einem Rastmechanismus verbunden ist. Diese Zuglaschen müssen vor dem Anbringen auf die Hutschiene nach unten gezogen werden. Dieses kann mittels eines Schlitzschraubendrehers und einer leichten Drehung geschehen.

Anschließend wird der CX9000-Block mit Hilfe der Verrieglungslaschen auf der Hutschiene fixiert. Dabei sollte ein leisen Klicken zu vernehmen sein.

Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Die Gehäuse nur an unempfindlichen Stellen (Gehäusekanten) drücken. Auf keinen Fall Druck auf das Display, die Taster oder bewegliche Teile am CX10x0-System ausüben.

Nach erfolgreichem Aufrasten auf die Hutschiene müssen die Zuglaschen wieder in die Ausgangsstellung geschoben werden.

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Ausführliche Informationen zur Demontage der CX9000-Konfiguration von der Hutschiene finden Sie auf der Seite "Abbau und Entsorgung".

Einbaulage:

Achtung

Das auf eine Hutschiene montierte CPU Modul darf nur bis Umgebungstemperaturen von 55°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist.
Mindestabstand einhalten!

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX9000 Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU Grundmoduls zu erreichen.

Zulässige Einbaulage:

Auf Grund der hohen Leistung des CX9000-Systems kommt es zu einer erhöhten Wärmeentwicklung. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Die unten aufgeführten Einbaulagen ermöglichen einen optimalen Betrieb.

Die folgenden Einbaulagen sind nicht zulässig:


Mechanischer Zusammenbau CX9000 mit USV

BECKHOFF CX1100-09xx: Einbau und Verdrahtung

Mechanischer Anbau des USV Moduls

Hinweis |
 | Das USV Modul wird für das CX90x0-System derzeit noch nicht von TwinCAT unterstützt. Das USV Modul kann wie hier beschrieben angeschlossen werden. Um das "Power Fail" - Signal (Pin 3 USV) in einem SPS-Programm auswerten zu können, muss das Signal über eine digitale Eingangsklemme eingelesen werden. Das Programm kann im Fall eines Stromausfalls dann entsprechend reagieren. Die Haltezeit wird ausschließlich über den Wahlschalter (Stellung 0 für längste Haltezeit) an der Frontseite der USV eingestellt. Im Fall eines Stromausfalls wird die USV auf jeden Fall herunter gefahren.

0. Abschalten des Geräts und Trennung der Stromversorgung

Bevor ein CX90x0 System auseinandergebaut werden kann, muss das Gerät ausgeschaltet werden. Danach kann es von der Stromversorgung getrennt werden.

1. Trennung der CPU vom Klemmbus

Vor der Trennung der einzelner CX90x0 Module muss der gesamte CX90x0-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

1.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man die eventuell vorhandene Verkabelung der Stromversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Ist die Verkabelung aufwendig, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil) lost damit die Klemme und zieht sie nach vorne heraus.

1.2. Entriegeln des CX90x0-Systems

Um den CX-Block zu lösen, werden die weißen Laschen an der Unterseite der Modul in Pfeilrichtung gezogen. Sie arretieren dann in der ausgezogenen Position. Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung lässt sich der Block vorsichtig von der Hutschiene nehmen.

2. Zusammenbau des USV Moduls mit der CX90x0-Konfiguration

2.1 Zusammenbau des CX-Blocks

Die Befestigung des USV Moduls mit der bestehenden CX90x0-Konfiguration wird durch das Zusammenstecken erreicht. Zuvor ist die Blende an der linken Seite des CX-Blocks vorsichtig mit einem Schraubenzieher zu entfernen. Beim Zusammenstecken der Module ist zu beachten, dass der Stecker des PC104 Interface nicht beschädigt wird. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen. Nach erfolgter Montage kann die Blende wieder aufgesteckt werden.

2.2 Aufbringen des CX-Systems auf die Hutschiene

Nach dem Zusammenstellen des CX-Systems kann dieses (wieder) auf die Hutschiene aufgebracht werden. Dabei ist auf den Abstand zum Klemmenbus zu achten. Es muss der Abstand für eine Klemme verbleiben um die zuvor entfernte Klemme wieder einzustecken.

Anschließend wird der CX90x0-Block mit Hilfe der Verrieglungslaschen wieder auf der Hutschiene fixiert. Dabei sollte ein leisen Klicken zu vernehmen sein.

Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Die Gehäuse nur an unempfindlichen Stellen (Gehäusekanten) drücken. Auf keinen Fall Druck auf das Display, die Taster oder bewegliche Teile am CX90x0-System ausüben.

2.3 Verbinden des Systems mit dem Klemmbus

Nun muss das System wieder mit dem Klemmbus verbunden werden. Dazu wird einfach die entnommene Klemme wieder in den Freiraum eingesteckt und damit der Klemmbus wieder geschlossen.

Als Letztes muss noch die Verkabelung wieder hergestellt werden. Dazu wird die erste Klemme wie zuvor verkabelt. Die Stromversorgung wird allerdings über die USV verkabelt. Details hierzu sind in der Dokumentation zu dem USV-Modul genau beschrieben.


PC einschalten / ausschalten

Einschalten

Die Stromversorgung des CPU Grundmoduls erfolgt über das Netzteil. Beim Anschluss des Netzteils an die Stromversorgung startet das CPU Grundmodul automatisch.

Erstes Einschalten

Wenn Sie den PC das erste Mal einschalten, wird das vorinstallierte Betriebssystem (optional) gestartet.

Ausschalten

Beim Ausschalten der Stromversorgung des Netzteils wird auch der Embedded-PC ausgeschaltet. Die laufende Steuerungssoftware, wie sie typischerweise auf Embedded-PCs eingesetzt wird, sollte ordnungsgemäß angehalten bzw. beendet werden. Ein Benutzer, der die Software nicht beenden darf, darf auch nicht den Embedded-PC abschalten, weil durch Abschalten bei laufender Software Daten auf der Festplatte verloren gehen können.

Ist die Software angehalten, kann das Betriebssystem heruntergefahren werden. Erst dann sollte die Stromversorgung unterbrochen werden.


LEDs CPU-Grundmodul (E-Bus)

Die Anzeigen sind für die Varianten CX9000 und CX9010 identisch. Daher wird hier das Verhalten am Beispiel des CX9000 gezeigt.

Anzeige | LED |  | Bedeutung
 | PWR | rot | TwinCAT ist gestoppt
 |  | grün | TwinCAT ist im RUN-Mode
 |  | blau | TwinCAT ist im Config-Mode
 |  | aus | System nicht in Betrieb
 | LAN 1 |  | LAN Link , (grün) LINK/ACTIVITY für geswitchten LAN PORT (CX9000_N000)
 | LAN 2 |  | LAN Link, (grün) LINK/ACTIVITY für internen EtherCAT PORT
 | L / A |  | (Link Aktivity) blinkt bei Datenverkehr auf dem E-Bus.
 | HDD |  | Read/Write Compact Flash (rot) Zeigt einen Zugriff auf die CF Karte an.


LEDs CPU-Grundmodul

BECKHOFF CX900x-1xxx: Fehlerbehandlung und Diagnose

LEDs CPU-Grundmodul (K-Bus)

Die Anzeigen sind für die Varianten CX9000 und CX9010 identisch. Daher wird hier das Verhalten am Beispiel des CX9000 gezeigt.

Anzeige | LED |  | Bedeutung
 | PWR | rot | TwinCAT ist gestoppt
 |  | grün | TwinCAT ist im RUN-Mode
 |  | blau | TwinCAT ist im Config-Mode
 |  | aus | System nicht in Betrieb
 | LAN 1 |  | LAN Link , (grün) LINK/ACTIVITY für geswitchten LAN PORT (CX9000_N000)
 | LAN 2 |  | LAN Link, (grün) LINK/ACTIVITY für internen EtherCAT PORT
 | K-Bus |  | K-Bus Aktivität / Fehlerstatus K-Bus nicht aktiv (aus) K-Bus läuft (grün) K-Bus Fehler (rot) siehe Tabelle unten
 | HDD |  | Read/Write Compact Flash (rot) Zeigt einen Zugriff auf die CF Karte an.

Blinkcode der K-Bus LED im Fehlerfall

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.


Fehlerbehandlung und Diagnose im SPS-Programm

CX900x-1xxx: Fehlerbehandlung und Diagnose im SPS-Programm

Klemmenbusanalyse über ein SPS-Programm

Zur Analyse des Klemmbus (K-Bus) kann auf die in der Architektur beschriebenen Register über TwinCAT von einem SPS-Programm zugegriffen werden.

Die einzelnen Register, die in der Architekturbeschreibung der Netzteile (CX1100-000x) erklärt sind, sind als SPS-Datentypen verfügbar. Im folgenden wird die Fehleranalyse als Beispiel vorgestellt.

Für die Fehleranalyse werden im Wesentlichen vier Signale/Variablen benötigt:

  • BusState (gibt den Zustand des Busses an: 0 -> kein Fehler, 1 -> Busfehler)
  • ErrorCode (entspricht dem Errorcode beim Blinkcode der DiganoseLEDs)
  • ErrorArg (entspricht dem Argument-Code beim Blinkcode der DiganoseLEDs)
  • Request[0] (Ausgang zum Anfordern / Rücksetzen des Busses)

In dem SPS-Programm müssen dazu analog externe Variablen angelegt werden:

VAR

    k_bus_request AT %QX0.0 	: BOOL;

    k_bus_err_code AT %IB0 	: USINT;
    k_bus_err_arg AT %IB1 	: USINT;
    k_bus_state AT %IB2 	: USINT;

END_VAR

In dem SPS Programm kann dann der Fehler wie folgt bestimmt werden (es handelt sich hier um Pseudocode, der so direkt nicht lauffähig ist)

....

IF k_bus_state = 1	 THEN		(* auf dem K-Bus ist ein Fehler aufgetreten *)

   k_bus_request := TRUE;		(* Anfordern der Fehlerwerte für die Register ErrCode und ErrArg *)

   CASE k_bus_err_code OF
     0 : return;			(* Sollte nicht vorkommen, da ja Fehler vorliegt *)
     1 : CASE k_bus_arg OF
      0 : melde Fehler;	(* EEPROM Prüfsummenfehler *)
      1 : melde Fehler;	(* Überlauf im Code Buffer *)
      2 : melde Fehler;	(* Unbekannter Datentyp *)
    END_CASE;
     2 : CASE k_bus_arg OF
      0 : melde Fehler;	(* Programmierte Konfiguration, falscher Tabelleneintrag *)
      ELSE melde Fehler;	(* Falscher Tabelleneintrag *)
    END_CASE;
     3 : melde Fehler 		(* K-Bus_Kommandofehler *)
     4 : CASE k_bus_arg OF
      0 : melde Fehler;	(* Bruchstelle hinter dem Netzteil *)
      ELSE melde Fehler;	(* Bruchstelle hinter Busklemme 'k_bus_arg' *)
    END_CASE;
     5 : melde Fehler 		(* K-Bus-Fehler bei Register-Kommunikation mit Busklemme 'k_bus_arg' *)
     9 : CASE k_bus_arg OF
      0 : melde Fehler;	(* Checksummenfehler im Programm-Flash *)
      ELSE melde Fehler;	(* Die Busklemme 'k_bus_arg' stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein*)
    END_CASE;
    14 : melde Fehler 		(* 'k_bus_arg'-te Busklemme hat das falsche Format *)
    15 : melde Fehler 		(* Anzahl der Busklemmen stimmt nicht mehr*)
    16 : melde Fehler 		(* Länge der K-Bus-Daten stimmt nicht mehr*)
   END_CASE

   k_bus_request := TRUE;		(* Rücksetzen des Busses, wenn Fehler beseitigt, dann startet der Klemmbus wieder *)

....

Damit die Steuerung und die Register zusammen arbeiten, müssen sie im System Manager verknüpft werden. Bindet man das SPS-Programm im System Manager ein, so ergeben sich folgende Signale:

Analog sind in System Manager die Register für die Klemmbusse angezeigt:

Mit Hilfe der Maus werden die Signale

k_bus_err_code mit ErrorCode

k_bus_err_arg mit ErrorArg

k_bus_state mit BusState

und

k_bus_request mit Request[0]

verknüpft.


Abbau und Entsorgung CX90x0

BECKHOFF CX-System: Einbau und Verdrahtung

Abbau und Entsorgung

Der Abbau einer CX90x0-Hardwarekonfiguration erfolgt in 2 Schritten:

0. Abschalten und Entfernen der Stromversorgung

Bevor der Abbau eines CX90x0-System erfolgen kann, sollte das System abgeschaltet sein und die Stromversorgung entfernt werden.

1. Demontage von der Hutschiene:

Vor der Trennung der einzelner CX90x0 Module muss der gesamte CX90x0-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

1.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man alle eventuell vorhandene Verkabelung der Stormversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Soll die Verkabelung später mit einem anderen System wieder hergestellt werden, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil), löst damit die Klemme und zieht sie nach vorne heraus.

1.2. Entriegeln des CX90x0-Systems

Um den CX90x0-Block zu lösen, werden die weißen Laschen an der Unterseite der Modul in Pfeilrichtung gezogen. Sie arretieren dann in der ausgezogenen Position. Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung lässt sich der Block vorsichtig von der Hutschiene nehmen.

2. Trennung der einzelnen Module

2.1. Trennen von CX90x0-System und USV sowie weiterer Komponenten

Man setzt den CX-Block mit der Vorderseite auf eine geeignete Unterlage. Dann wird ein Schlitzschraubendreher der Größe 1,0 x 5,5 x 150 mm in den Verriegelungsmechanismus einführt und mit einer etwa 90 Grad Drehung der Schieber betätigt. Der rückseitige Verriegelungsmechanismus bewirkt eine ca. 2-3mm breite Trennung der mechanischen Einrastung der Module und drückt diese auseinander. Die Stecker des PC 104 Interface können anschließend vorsichtig auseinander gezogen werden.

Nur Module (CPU und USV-Module) die sich zerstörungsfrei trennen lassen verfügen über eine Entriegelung. Module, die nicht voneinander getrennt werden können, haben lediglich einen Markierungspunkt (mit oder ohne roten Versieglungslack). Eine Krafteinwirkung an diesen Elementen führt zur Zerstörung.

Achtung |
 | Das gewaltsame Öffnen der Modulgehäuse (z.B. Entfernen der Deckel) führt zur Zerstörung der Gehäuse.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


CX90x0: Update Image

Allgemeines

Achtung

Im Allgemeinen ist ein Update es Systemimages nicht notwendig: Die Grundfunktionen von TwinCAT und TwinCAT PLC arbeiten korrekt.

Ein Update sollte NUR erfolgen, wenn es von der Beckhoff Automation GmbH empfohlen wird - Ein laufendes System sollte nicht verändert werden!

Ist doch ein Update des Systemimages erforderlich, sind hier einige grundlegende Information aufgeführt:

Das Diagramm zeigt den Ablauf eines Updates. Es gibt drei Hauptschritte:

  1. Auswahl des richtigen Images
  2. Installation des Images
  3. Kopieren der Dateien auf der "Hard Disk"

Die einzelnen Schritte können auf unterschiedliche Weise absolviert werden.

Auswahl des richtigen Images

Images auf dem BECKHOFF FTP Server

Auf dem FTP-Server der Beckhoff Automation GmbH sind die neuen Images abgelegt.

ftp.beckhoff.de/Software/embPC-Control/

Das folgende Bild zeigt den FTP-Server:

FTP-Verzeichnis /Software/embPC-Control/ auf ftp.beckhoff.de.

Beckhoff FTP Server ftp.beckhoff.com
    No unauthorised access to our systems is allowed!
    Please report operational problems to webadmin@beckhoff.com

                          <DIR> ..
07/30/09 11:09PM [GMT]          <DIR> C65xx
04/23/10 10:00AM [GMT]          <DIR> C6915
07/30/09 11:17PM [GMT]          <DIR> C69xx
04/20/11 01:11PM [GMT]          <DIR> CB3052-CB3054
02/26/10 12:38PM [GMT]          <DIR> CE
06/28/11 01:13PM [GMT]          <DIR> CP62xx
10/17/11 09:53AM [GMT]          <DIR> CP6608
10/17/11 09:54AM [GMT]          <DIR> CP66xx
07/31/09 01:52AM [GMT]          <DIR> CP72xx
06/30/11 11:29AM [GMT]          <DIR> CPx7xx
06/30/11 01:03PM [GMT]          <DIR> CX10xx
07/20/10 12:10PM [GMT]          <DIR> CX50xx
07/31/09 10:50AM [GMT]          <DIR> CX9000
07/31/09 10:51AM [GMT]          <DIR> CX90xx
08/08/11 11:50AM [GMT]          <DIR> Solution
09/23/11 10:21AM [GMT]          <DIR> WES7
07/05/11 12:55PM [GMT]          <DIR> XPe

Für CX9000 ist der Link CX9000 zu wählen.

FTP-Verzeichnis /Software/embPC-Control/CX9000/CE/ auf ftp.beckhoff.de.

Beckhoff FTP Server ftp.beckhoff.com
    No unauthorised access to our systems is allowed!
    Please report operational problems to webadmin@beckhoff.com

                          <DIR> ..
10/17/11 09:55AM [GMT]      6,735,682 CX9000_CE500_LF_v226.zip
10/17/11 09:55AM [GMT]      8,971,992 CX9000_CE600_LF_v312.zip
02/23/11 06:46PM [GMT]         98,959 CX9000_ImageUpdate.zip

CX9000_CE500_LF_v226.zip

Image für CE5.0

CX9000_CE600_LF_v312.zip

Image für CE6.0

CX9000_ImageUpdate.zip

Image-server und Enable Update-Tool um das Update über den Update-Server einzuspielen, sowie das Update-Tool für das direkte Einspielen des Updates.

Für CX9001 und CX9010 ist der Link CX90xx zu wählen.

FTP-Verzeichnis /Software/embPC-Control/CX90xx/CE/ auf ftp.beckhoff.de.

Beckhoff FTP Server ftp.beckhoff.com
    No unauthorised access to our systems is allowed!
    Please report operational problems to webadmin@beckhoff.com

                       <DIR> ..
02/23/11 06:46PM [GMT]         98,959 CX9000_ImageUpdate.zip
09/22/08 12:32PM [GMT]      5,278,516 CX90x0_NoHive_32MB_Flash.zip
10/17/11 09:55AM [GMT]     15,903,461 CX90xx_CE500_HMI_v226.zip
10/17/11 09:56AM [GMT]     19,347,515 CX90xx_CE600_HPS_v312.zip

CX90xx_CE500_HMI_v226.zip

Image für CE5.0

CX90xx_CE600_HPS_v312.zip

Image für CE6.0

CX90x0_NoHive_32MB-Flash.zip

Leeres Image zum Löschen der /Hard Disk

CX9000_ImageUpdate.zip

Image-server und Enable Update-Tool um das Update über den Update-Server einzuspielen, sowie das Update-Tool für das direkte Einspielen des Updates.

Installation des Images

Interaktives Tool auf dem CX90x0:

Die Datei "Cx9ImageUpdate_V1007.zip" enthält das Update-Tool. Sie muss zuerst vom BECKHOFF FTP-Server geladen werden. Steht kein USB am CX90x0-System zur Verfügung, so kann das Programm via ftp auf das System kopiert werden. Mit Hilfe des CERHOST-Tools wird eine Verbindung zum CX-System hergestellt. Dann wird der der FTP-Server auf dem CX, wenn er nicht bereits aktiviert ist, über das CXConfig-Tool wie folgt aktiviert:

Es empfiehlt sich als Zielverzeichnis "\Temp" oder "\pubic" zu wählen, da diese Bereiche als RAM-Disk im Speicher und nicht im Flashbereich des Systems liegen. Zum Betrieb muss das System dann gebootet werden - folgen Sie einfach den Anweisungen auf dem Bildschirm. Nach dem Neustart des CX90x0 kann über den Explorer einfach die Datei auf den CX kopiert werden:

Ist genug Platz auf dem CX-System (bei großem Speicherausbau) kann auch das neue Image mit auf den CX90x0 kopiert werden. Ansonsten empfiehlt es sich das Netzwerklaufwerk vor dem Update mit dem CX90x0 zu verbinden:

Nach dem das Image auf den CX90x0 kopiert oder ein Netzwerklaufwerk auf dem das Image liegt mit dem CX90x0 verbunden ist, kann das Update-Tool per Doppelklick gestartet werden.

Es folgt die Eingabe der Image-Datei. Hier muss der lokale oder der Netzwerkpfad bis zum dem Image angegeben werden. Eventuell erfolgt je nach Netzwerkkonfiguration nachmals eine Passwortabfrage.

Es folgt die Bestätigung der Image-Datei hier besteht noch die Möglichkeit den Updateprozess abzubrechen. Nach Bestätigung des Images erfolgt noch eine Warnung:

Der Fortschritt des Updates wird in dem Statusfeld an der Unterkante des Update-Tools dargestellt.

Wenn das Update abgeschlossen ist, steht folgende Meldung im Statusfeld:

Das System kann nun neu gestartet werden, Nach dem Neustart folgt der letzte Schritt für das Update.

Imageserver auf einem Host PC

1. Vorbereiten des Image-Servers (einmalig)

Um das Image auf dem Host-PC bereitzustellen werden folgende Komponenten benötigt:

  • Zwei Skriptdateien "CxImgSrv_HMI.bat" und "CxImgSrv_LF.bat"
    Beachten Sie, dass der CX90x0 in verschiedenen Konfigurationen geliefert wird. Verwenden Sie nur das entsprechende Image (s.o.).
  • Das Verzeichnis "\Tools" enthält den Image-Server: CxImageSrv.exe
  • Im Verzeichnis "\Images" sind die Unterverzeichnisse HMI and LF angelegt. Sie enthalten das benötigte Image "Boot.bin". Dieses muss zusätzlich von dem FTP-Server geladen und in das entsprechende Verzeichnis kopiert werden. Gegebenen falls muss die Datei von "NK.BIN" in "Boot.bin" umbenannt werden.

2. Vorbereiten des CX90x0-Systems

Vorbereiten des CX90x0 um in den "Boot-Strap Mode". Hier zu gibt es zwei Möglichkeiten:

Zunächst wird der DIP-Schalter erklärt:

  1. Schalten Sie den CX90x0 ab und trennen sie es von der Stromversorgung.
  2. Öffnen Sie das Batteriefach. Um es zu öffnen kann ein Schraubendreher zur Hilfe verwendet werden. (Vorsichtig Vorgehen um das Gerät nicht zu beschädigen.

  3. Ist die Klappe geöffnet, kann auf die vier DIP-Schalter zugegriffen werden. Sie befinden sich links von dem Batteriehalter. Im Normalbetrieb sind alle Schalter auf AUS gesetzt (alle Schalter sind in Stellung unten)

    Um die Einstellung der Schalter zu ändern, sollte ein Schraubendreher mit kurzer Spitze verwendet werden (2,5 mm x 7,5 cm Länge und paralleler Spitze, Beckhoff Bestellnummer ZB8700). Die Spitze vorsichtig benutzen um das Gerät nicht zu beschädigen! Setzen Sie den DIP-Schalter 3 auf ON (Schalter 3 auf Schalterstellung oben.
    Falls die DIP-Schalter mit einer Folie geschützt sind, müssen Sie diese Folie mit dem Schraubendreher durchstoßen.

Starten eines Programms, das den CX90x0 in den "Boot-Strap Mode" versetzt.

Alternativ kann der Administrator des CX-Systems ein Hilfsprogramm auf den CX90x0 laden und um das System in den "Boot-Strap Mode" zu versetzen. Dazu muss das Programm zunächst vom BECKHOFF FTP-Server geladen werden. Steht kein USB am CX90x0-System zur Verfügung, so kann das Hilfsprogramm via ftp auf das System kopiert werden. Mit Hilfe des CERHOST-Tools wird eine Verbindung zum CX-System hergestellt. Dann wird der der FTP-Server auf dem CX, wenn er nicht bereits aktiviert ist, über das CXConfig-Tool wie folgt aktiviert:

Es empfiehlt sich als Zielverzeichnis "\Temp" oder "\pubic" zu wählen, da diese Bereiche als RAM-Disk im Speicher und nicht im Flashbereich des Systems liegen. Zum Betrieb muss das System dann gebootet werden - folgen Sie einfach den Anweisungen auf dem Bildschirm. Nach dem Neustart des CX90x0 kann über den Explorer einfach die Datei auf den CX kopiert werden:

Achtung

Über CERHOST kann das Programm per Doppelklick auf dem CX90x0 gestartet werden. Es darf aber nur gestartet werden, wenn ein Image-Server (s.o.) UND ein korrektes Image vorliegen.

Der CX90x0 ist jetzt solange nicht als PLC einsetzbar bis ein Update erfolgt ist!

Das Rücksetzen des Modus erfolgt hierbei automatisch nach erfolgtem Update.

3. Verbinden Sie das CX90x0-System mit dem Netzwerk.

Hinweis

Der Image-Server regiert auf Anfragen aus dem gesamten Netzwerk entgegen.

An jeden CX90x0 in dem Netzwerk, der Image-Anfragen sendet wird das in dem Server angewählte Image gesendet.
Zwei Lösungen, die sicherstellen, dass nur der gewünschte CX90x0 ein Update erhält werden am Ende dieses Abschnitts beschrieben.

4. Starten des Image-Servers

Starten des Image-Server auf dem Host-PC :

  • starten Sie das richtige Skript "CxImgSrv_HMI.bat" oder "CxImgSrv_LF.bat" (entsprechend dem gewünschten Image)

    Das Skript öffnet eine Kommando-Shell und zeigt:

    "Waiting for download request..."

5. Schritte die während des Update ablaufen

Starten Sie den CX90x0 oder booten Sie das System neu (bei Software-Umschaltung) via "Suspend" um die Update-Prozedur zu beginnen. Die folgenden Schritte laufen automatisch ab. Sie werden hier beschrieben, damit der Anwender den Prozess verfolgen kann.

  • Initial Phase :

    Der CX90x0 sendet Anfragen an den Image-Server. Dabei wird die Anfrage an das gesamte Netzwerk gesendet.

  • Download Phase :
    Der Image-Server zeigt die Nachricht an, dass ein CX90x0 System ein Image erwartet und sendet das Image an den CX90x0.

    Die Nachricht hat die Form:

    Boot image request from device CX90x0_BA23
    Working directory is Image\HMI
    Calling TFTP.exe -i <CX90x0-IP> PUT boot.bin

    Bei CX90x0 beginnt die HDD Led zu leuchten: Das CX90x0-System löscht das alte System und kopiert das neue System in den internen Speicher.
  • Reorganisation Phase :
    Der Image-Server zeigt an, dass das Image vollständig übertragen ist und ist bereit auf weitere Anfragen zu reagieren.
  • Beim Host-PC : Schließen Sie die Kommando-Shell. (Drücken Sie <CTRL> + <c> oder Schließen sie das Fenster)
  • Rücksetzen des System in den "Operation mode", damit beim Neustart nicht ein erneutes Update ausgeführt wird.

Setzen Sie den DIP-Schalter 3 zurück auf OFF (Schalterstellung unten) sobald der Image-Server die vollständige Übermittlung meldet und schließen Sie die Abdeckung.

Hinweise zur Netzwerkkonfiguration:
  • Der Image-Server reagiert auf Anfragen aus dem gesamten Netzwerk. Jeder CX90x0 im Netzwerk, der eine Anfrage sendet wird bedient.

    Zwei Lösungen um gezielt nur das gewünschte CX90x0-System mit einem neuen Image zu versorgen und nicht andere CX90x0-Systeme sind:

    1a.
    Verwenden eines Subnetzwerks (z.B. über eine zweite Netzwerkkarte im Host-PC)

    oder

    1b.
    Verbinden des Host-PCs direkt mit dem CX90x0 ohne Zugang zum Firmennetzwerk.

    Alternative

    2.
    Der Image-Server kann so konfiguriert werden, dass der CX direkt an einer bestimmten IP-Adresse für ein Image anfragt.

    Schritt 1 : verbinden Sie den CX90x0 mit dem PC und ermitteln Sie die IP-Adresse des Image-Server (z.B. 192.16.18.123)
    Schritt 2 : Editieren Sie das Skript-File und fügen Sie die IP-Adresse der Kommandozeile hinzu . (Beispiel : Tools\CxImageSrv Images\HMI 192.16.18.123 )
    Schritt 3 : Fahren Sie mit der Update-Prozedur fort in dem Sie den CX90x0 im "Boot-Strap Mode" starten. Jetzt wird der CX direkt vom Server mit der IP-Adresse (Beispiel: 192.16.18.123 ) die Images laden.

Installation der neuen Konfigurationsdaten auf der Harddisk

Damit das neue Image richtig funktioniert, müssen noch die neuen Konfigurationsdaten und Programme auf die Hard Disk kopiert werden. Dazu kann können entweder die Daten über ein USB-Speichermedium oder über ein Netzwerk auf das Gerät übertragen werden können. Als Speichermedien kann eine CF-Karte (in Verbindung mit CX9000-A001) oder ein USB-Stick (CX9000-N010 oder CX9000-N070) dienen. Stehen die Schnittstellen nicht zur Verfügung, so muss auf ein Netzwerklaufwerk zurück gegriffen werden (siehe oben). Sind die Daten auf dem CX-Gerät verfügbar, kann mit dem Löschen der alten "Hard Disk" begonnen werden.

Es müssen alle Dateien auf /Hard Disk gelöscht werden. Dazu müssen im Explorer die Dateien markiert und gelöscht werden. Dateien die sich dabei nicht löschen lassen, können umbannt werden.

Sind alle Dateien gelöscht oder umbenannt, können die neuen Dateien aus dem Ordner "Hard Disk" nun auf den internen Speicher in das Verzeichnis "\Hard Disk" kopiert werden.

Sind alle Dateien kopiert muss das System neu gebootet werden. Die Umbenannten Dateien können jetzt gelöscht werden.

Das Update ist abgeschlossen.


Zubehör

Compact Flash Karten

Bestellnummer bei der Erstbestellung der Karten (statt 64-MB CF-Karten)

Bestellnummer | Beschreibung
CX1900-0023 | 1 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0025 | 2 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0027 | 4 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0029 | 8 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0031 | 16 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte

Bestellnummer bei der Bestellung von Ersatzkarten

Bestellnummer | Beschreibung
CX1900-0022 | 64 MByte Compact Flash Karte Typ I
CX1900-0024 | 1 GByte Compact Flash Karte Typ I
CX1900-0026 | 2 GByte Compact Flash Karte Typ I
CX1900-0028 | 4 GByte Compact Flash Karte Typ I
CX1900-0030 | 8 GByte Compact Flash Karte Typ I
CX1900-0032 | 16 GByte Compact Flash Karte Typ

Formatierung einer Compact-Flash-Karte

Bestellnummer | Beschreibung
CX1900-0010 | Formatierung einer Compact-Flash-Karte (bootfähig), FAT16
CX1900-0012 | CX1900-0012 Formatierung einer Compact-Flash-Karte (bootfähig), NTFS

Speichererweiterung für CX1020/CX1030

Bestellnummer | Beschreibung
CX1900-0201 | 512 MB DDR RAM für CX1020/CX1030 statt 265 MB DDR RAM
CX1900-0202 | 1 GB DDR RAM für CX1020/CX1030 statt 265 MB DDR RAM

DVI-zu-VGA passiver Adapter

Bestellnummer | Beschreibung
CX1900-0101 | DVI-zu-VGA passiver Adapter für den Anschluss von Standard-VGA-Monitoren an das CX-System – führt die VGA-Signale der DVI-I-Schnittstelle des CX-Moduls aus – DVI-A-Stecker, 29-polig (unten), Buchse, 15-polig (oben) – Gewicht: ca. 40 g – Abmessungen (B x H x T): 40 x 42 x 15 mm

Ersatzbatterie CX-Systeme

Bestellnummer | Beschreibung
CX1900-0102 | Batterie für CX-Systeme - Originalherstellerbezeichnung: Panasonic Typ CR2032 3V/225mAh

Ersatzlüfterkassette für CX1030

Bestellnummer | Beschreibung
CX1900-0103 | Ersatzlüfterkassette für CX1030 – Kassette bestehend aus Gehäuse und Lüfter 40 mm – einfacher Austausch im Feld durch kabellose Montage – Gewicht: ca. 30 g – Abmessungen (B x H x T): 57 x 14 x 60 mm


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Compact Flash Einschub

Auf der Frontseite befindet sich ein Compact Flash Einschub. Hier durch ergibt sich die Möglichkeit das Speichermedium auszutauschen. Dies ist bei dem Einschub im Grundmodul nur in ausgeschaltetem Zustand möglich, andernfalls kann die Entnahme zum Absturz des Systems führen. Bei der CF-Karten Erweiterung (CXxxxx-A001) kann die CF-Karte während des Betriebes entfernt werden. Das Speichermedium sollte aber beim System abgemeldet worden sein. Zu Wartungsarbeiten kann die Compact-Flash-Karte aus dem Modul entnommen werden. Auch die Erweiterung des Systems auf einen größeren Speicher (nur Betriebssystem und Programmspeicher) ist auf diese Weise möglich. Die Compact-Flash-Karten (CF-Karten) sind als Zubehör in verschiedenen Speichergrößen erhältlich.

Die folgende Bildserie zeigt die Handhabung der CF-Karten am Beispiel des CX1000. Die Betätigung der Auswurfmechanik mit einem Schraubendreher unterhalb des Einschubs bewirkt den Auswurf der Karte um ca. 4 mm (BILD1), so dass sie mit den Fingern herausgezogen werden kann (BILD2). Beim Einschub der Karte (BILD3) rastet die Auswurfmechanik wieder ein. Die Karte sitzt richtig, wenn sie sich ca.1 mm tiefer als die Frontseite des Gerätegehäuses befindet.

BILD1: Auswurf der CF Karte BILD2: Herausziehen der CF Karte BILD3: Einschub der CF Karte

Achtung |
 | Bei dem Compact-Flash-Einschub handelt es sich um ein Speicherinterface, nicht um einen CF Einschub des Typs I/O.


Compact Flash Karte

BECKHOFF CX-System: Produktübersicht

Compact-Flash-Karte

Bei der Compact-Fash-Karte (CF-Karte) handelt es sich um einen nicht volatilen Speicher.

Daten, die Spannungsausfallsicher gespeichert werden sollen, müssen auf der CF-Karte gespeichert werden. Die CF-Karte arbeitet wie eine Harddisk.

Achtung

Es wird ausdrücklich darauf hingewiesen nur CF-Karten zu verwenden, die von der Beckhoff Automation GmbH geliefert werden. Es handelt sich um industrietaugliche CF-Karten mit einer erhöhten Anzahl an Schreib-/ Lesezyklen und einem erweiterten Temperaturbereich ( +85°C).

Ein einwandfreier Betrieb kann nur mit CF-Karten von der Beckhoff Automation GmbH gewährleistet werden!


LEDs CF-Karten-Leser CX90x0-A001

BECKHOFF CX90x0-A001: Fehlerbehandlung und Diagnose

LEDs CF-Kartenleser

Anzeige | LED | Bedeutung
 | PWR | Das Modul wird mit Spannung versorgt und ist betriebsbereit.
 | LOCK | Es ist eine CF-Karte richtig eingeschoben und elektrisch verbunden.
 | CF | Blinkt bei Schreib-/Lesezugriffen auf die CF-Karte.


Anschlüsse CX90x0-A001

Dieses Modul liefert einen weiteren Compact-Flash-Card-Einschub. Dieser kann zusätzlich auf das System gesteckt werden. Damit ist es möglich einen Wechseldatenträger mit CX90x0-System zu verbinden. Im Gegensatz zu dem System CF-Einschub ist dieser zusätzliche Port "HOT-PLUG" fähig, d.h. es kann im laufenden Betrieb das Speichermedium gewechselt werden. Die Funktion der LEDs ist bei der Systemdiagnose beschrieben.

Dieses gilt aber NICHT für die CF-Karte in dem Grundmodul.

Die für die verwendeten CF-Karten gelten die gleichen Voraussetzungen, wie für die Systemkarten. Die Bedienung erfolgt analog zum System-Karten-Einschub.

Da das Modul über die gleiche Gehäusemechanik wie das gesamte System verfügt, sind Auf- und Abbau dieses Moduls analog zu den anderen Systemkomponenten.

Stromaufnahme

Die Stromaufnahme bzw. Leistungsaufnahme des Geräts hängt von dem eingelegten Medium ab. Die folgende Tabelle gibt die Werte an.

Medium | Zustand | Stromaufnahme | Leistungsaufnahme
keins | Standby | 2 mA | 10 mW
CF Karte | Idle | 1 mA | 5 mW
CF Karte | Access | 20 mA | 100 mW
Micro Drive | Idle | 1 mA | 5 mW
Micro Drive | Access | 30 mA | 150 mW

Hinweis |
 | Die Systemschnittstelle CX90x0-A001 kann nur anstatt und nicht gleichzeitig mit der Systemschnittstelle CX90x0-N070 oder CX90x0-N080 betrieben werden.