BECKHOFF Feldbuskomponenten

Dokumentation für

CX8030 und CX8031 - Embedded-PCs für PROFIBUS

CX8030: PROFIBUS-Master

CX8031: PROFIBUS-Slave

Version: 1.2.0
Datum: 29.07.2015


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


CX8030, CX8031 - Ausgabestände der Dokumentation

BECKHOFF CX8030, CX8031: Vorwort

Ausgabestände der Dokumentation

Version Kommentar
1.2.0
  • Kapitel 1-Sekunden-USV hinzugefügt
  • Kapitel Betriebssystem hinzugefügt
1.1.0
  • Vorwort aktualisiert
  • CX8030 hinzugefügt
1.0.0
  • Erste Veröffentlichung
0.0.0
  • Vorläufige Version

Image Version CX8030

Firmware Beschreibung
Build 2240
  • Release Version (benötigt mindestens TC2.11 Build 2240)

Image Version CX8031

Firmware Beschreibung
Build 2240
  • Release Version (benötigt mindestens TC2.11 Build 2240)
Build 2233
  • Erste Version


CX80xx - Systemübersicht

CX80xx bezeichnet eine Gerätefamilie von programmierbaren Steuerungen mit ARM-basierter 32-Bit-CPU, die sowohl zur Abarbeitung von SPS-Programmen dienen, als auch die Funktion als Slave-Teilnehmer eines übergeordneten Feldbussystems erfüllen. Im Vergleich zu den nicht-programmierbaren EtherCAT-Kopplern der EK-Serie, die lediglich als Gateway zwischen dem entsprechenden Feldbussystem und den angeschlossenen EtherCAT-Klemmen fungieren, ist der CX80xx programmierbar und in der Lage, ein eigenes Steuerungsprogramm abzuarbeiten.

Die Geräte der Baureihe CX80xx stellen eine Weiterentwicklung der bekannten und bewährten 16-Bit-Microcontroller-basierten Busklemmen-Controllern der BC- und BX-Serien dar; hin zu leistungsfähigeren 32-Bit-Prozessoren. Wie bei den BC/BX ist auch beim CX80xx sichergestellt, dass bei Unterbrechung des übergeordneten Feldbussystems die Steuerung und das lokale Programm weiterhin abgearbeitet werden. Somit können die CX80xx-Geräte als dezentrale Steuerung verwendet werden. Wahlweise sind Busklemmen (K-Bus) oder EtherCAT-Klemmen (E-Bus) anschließbar; der CX80xx erkennt in der Hochlaufphase automatisch, welches Klemmensystem angeschlossen ist. Beim Einsatz von EtherCAT ergeben sich weitere Möglichkeiten, wie die Realisierung verschiedener Topologien, die Einbindung weiterer Bussysteme, wie CANopen, PROFIBUS und PROFINET, und – mit den EtherCAT-Box-Modulen – die Verbindung in die IP67-Welt.

Die Programmierung und Inbetriebnahme der CX80xx-Geräte erfolgt, wie bei allen CX-Produkten, über die Ethernet-Schnittstelle, die sich natürlich auch zur Verbindung der Steuerung mit einem regulären Netzwerk nutzen lässt. Teilweise verfügen die Embedded-PCs über weitere Ethernet-Schnittstellen mit Switch-Funktionalität, sodass eine linienförmige „Daisy-Chain“-Topologie kostensparend, ohne zusätzliche Hardware, aufgebaut werden kann. Die weiteren Anschlüsse auf der niedrigen Steckebene sind feldbusspezifisch. Unter der Klappe auf der oberen Gehäuseebene befinden sich eine tauschbare Knopfzellenbatterie für Datum und Uhrzeit, eine Reihe von DIP-Schaltern zur Einstellung von Funktionsmodi, ein Slot für MicroSD-Flash-Speicherkarten sowie ein USB-Anschluss Typ B. Die Geräte sind, dank geringer elektrischer Leistungsaufnahme, lüfterlos.

Als Betriebssystem kommt Microsoft Windows CE zum Einsatz. Da kein Bildschirmanschluss vorhanden ist, kann nur per Netzwerk auf das Betriebssystem und seinen „virtuellen“ Bildschirm zugegriffen werden. Wie bei allen anderen Beckhoff-Geräten erfolgen die Systemkonfiguration und die Programmierung der SPS-Funktionalität mittels der TwinCAT-Software. Auf dem CX80xx-Zielgerät befindet sich dazu eine vorinstallierte TwinCAT-SPS-Laufzeitumgebung. Sämtliche für den Betrieb des Gerätes benötigte Software, vom Betriebssystem über die TwinCAT-Dateien bis hin zu Anwenderdateien und -daten, wird auf der MicroSD-Flash-Karte gespeichert. Das vereinfacht den Tausch im Servicefall. Der Zugriff auf die Kartendaten kann auch über handelsübliche Kartenleser erfolgen. Die Größe der MicroSD-Flash-Karte (z. B. 512 MB) ist, je nach Anwendung und Umfang der zu speichernden Daten, wählbar.

Die CX80xx-Gerätefamilie verfügt über eine integrierte, kapazitive 1-Sekunden-USV, die bei Wegfall der Versorgungsspannung noch ausreichend Energie zur Verfügung stellt, um persistente Daten zu speichern. Damit ist der spannungsausfallsichere Erhalt wichtiger Daten ohne Batteriepufferung möglich.

Mit einem leistungsstarken und dennoch stromsparenden 32-Bit-ARM-Prozessor, EtherCAT als I/O-Bus sowie TwinCAT PLC mit umfangreichen SPS-Bibliotheken, stellen die Embedded-Controller der Serie CX80xx leistungsfähige Steuerungen mit Slave-Feldbusanschluss dar, die sehr flexibel einsetzbar sind.

Feldbus-Interface

Die Varianten der Serie CX80xx unterscheiden sich durch die unterschiedlichen Feldbusschnittstellen. Verschiedene Ausführungen decken die wichtigsten Feldbussysteme ab:

  • CX8010: EtherCATSlave
  • CX8030: PROFIBUS DP Master
  • CX8031: PROFIBUS DP Slave
  • CX8050: CAN Master
  • CX8051: CANopen Slave
  • CX8080: RS232/485
  • CX8090: Ethernet (RT-Ethernet, EAP, ModbusTCP, TCP/IP, UDP/IP, Web Services)
  • CX8091: BACnet IP/OPC UA
  • CX8093: PROFINET RT Device (Slave)
  • CX8095: Ethernet/IP Slave
  • CX8097: Sercos III Slave

Programmierung

Programmiert werden die CX80xx-Controller nach der leistungsfähigen IEC 61131-3 Norm. Wie auch bei allen anderen Beckhoff Steuerungen ist die Automatisierungssoftware TwinCAT Grundlage für die Parametrierung und Programmierung. Dem Anwender stehen also die gewohnten TwinCAT Werkzeuge, wie z. B. SPS-Programmieroberfläche, System Manager und TwinCAT Scope zur Verfügung.

Konfiguration

Die Konfiguration erfolgt ebenfalls mit TwinCAT. Über den System Manager können das Feldbusinterface und die Echtzeit-Uhr konfiguriert und parametriert werden. Alle angeschlossenen Geräte und Busklemmen können vom System Manager ausgelesen werden. Die Konfiguration wird nach der Parametrierung auf den CX gespeichert. Diese erstellte Konfiguration kann auch wieder ausgelesen werden.


CX803x - Einführung

BECKHOFF CX803x: Produktübersicht

CX8030, CX8031 - Einführung

Die Grundausstattung des CX80xx enthält eine 512 MB MicroSD-Karte. Eine Feldbusschnittstelle, ein Ethernet Interface, sowie eine K-Bus bzw. E-Bus Schnittstelle gehören zur Basisausstattung.

Die kleinste zu verwendende Task-Zeit ist 1 ms (empfohlen wird eine Task-Zeit von 1 bis 50 ms für die I/O Daten, weitere Tasks können auch langsamer gestellt werden). Bei Verwendung kleinerer Zykluszeiten ist die gesamte Systemauslastung zu beachten. Ist die Zykluszeit zu klein gewählt können Web-Visualisierung und Remote-Desktop sehr langsam arbeiten oder TimeOuts verursachen. Der Anwender ist selbst dafür verantwortlich sein System so zu projektieren und zu konfigurieren, dass es nicht überlastet wird.

CX8030

Der CX8030 ist eine Steuerung mit einem Ethernet Anschluss über die programmiert und/oder konfiguriert wird und einer PROFIBUS-Master-Schnittstelle auf Basis RS485 mit D-Sub-Anschluss. Wahlweise kann der CX8030 auch als PROFIBUS-Slave betrieben werden.

Wahlweise können K-Bus- oder E-Bus-Klemmen angereiht werden; der CX8030 erkennt in der Hochlaufphase automatisch, welcher Klemmentyp angeschlossen ist. Programmiert wird die Steuerung mit TwinCAT über die das Ethernet-Interface.

CX8031

Der CX8031 ist eine Steuerung mit einem Ethernet Anschluss über die programmiert und/oder konfiguriert wird und einer PROFIBUS-Schnittstelle auf Basis RS485 mit D-Sub-Anschluss. Physikalisch besitzt der CX8031 zwar nur eine D-Sub-Schnittstelle, diese kann aber so verwendet werden als ob vier Teilnehmer am Bus wären. Das hat den Vorteil das mehr Daten ausgetauscht werden können, sowie der CX8031 als DP/DP-Koppler mit einem zweiten PROFIBUS-Master kommunizieren kann.

Wahlweise können K-Bus- oder E-Bus-Klemmen angereiht werden; der CX8031 erkennt in der Hochlaufphase automatisch, welcher Klemmentyp angeschlossen ist. Programmiert wird die Steuerung mit TwinCAT über das Ethernet-Interface.


CX803x - Technische Daten

BECKHOFF CX803x: Produktübersicht

Technische Daten

Technische Daten | CX8030 | CX8031
Prozessor | 32 Bit, 400 MHz, ARM9
Interner Arbeitsspeicher | 64 MB RAM (intern, nicht erweiterbar)
Betriebssystem | Microsoft Windows CE 6.0
Web-base Management | ja
Flash-Speicher | MicroSD-Karte (ATP) 512 MByte (optional 1, 2, 4 GB)
Schnittstellen | 1 x USB-Device (hinter der Frontklappe) 1 x RJ45 Ethernet, 10/100 MBit/s (ADS over TCP/IP) 1 x D-Sub RS485 PROFIBUS
Protokolle | PROFIBUS Master (Slave Mode optional) | PROFIBUS Slave
Interface für I/O-Klemmen | K-Bus oder E-Bus, automatische Erkennung
Prozessdaten am K-Bus | max. 2 kByte Eingangsdaten max. 2 kByte Ausgangsdaten
Diagnose LED | 1 x Power, 1 x TC-Status, 2 x Bus-Status
Uhr | interne, batteriegepufferte Uhr (RTC) für Zeit und Datum (Batterie wechselbar)
Betriebssystem | Microsoft Windows CE
Steuerungssoftware | TwinCAT-PLC-Runtime (ab Version 2.11 R3)
Programmierung | TwinCAT PLC
Programmiersprachen | IEC 61131-3
Online Change | Ja
Up/Download-Code | Ja/Ja
Spannungsversorgung | 24 VDC (-15 %/+20 %)
USV | 1-Sekunden-USV
Stromversorgung für I/O-Klemmen | max. 2 A
Max. Verlustleistung | 3,0 W (einschließlich der Systemschnittstellen)
Spannungsfestigkeit | 500 V (Versorgung/interne Elektronik)
Abmessungen (B x H x T) | 64 mm x 100 mm x 73 mm
Gewicht | ca. 180 g
Zulässige Umgebungstemperatur im Betrieb | 0° C ... +55° C
Zulässige Umgebungstemperatur bei Lagerung | -25° C ... +85° C
Einbaulage | siehe Kapitel Einbaulagen
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP20
Systemdaten | PROFIBUS (CX8030, CX8031)
Anzahl der E/A-Module | 100 mit Repeater
Anzahl der E/A-Punkte | ca. 6.000, masterabhängig
Übertragungsmedium | abgeschirmtes Kupferkabel 2 x 0,25 mm²
Leitungslänge | 1200 m | 1000 m | 400 m | 200 m | 100 m
Übertragungsrate | 9,6/19,2/93,75 kBaud | 187,5 kBaud | 500 kBaud | 1500 kBaud | 3, 6, 12 MBaud
Topologie | Linientopologie


CX803x - Technische Daten - PROFIBUS

BECKHOFF CX8030: Produktübersicht

Technische Daten - PROFIBUS

Technische Daten PROFIBUS | CX8030
Anzahl der Slaves | 125 mit Repeatern
Anzahl der Daten pro Slave | 244 Byte In- und 244 Byte Outputdaten
Businterface | D-Sub 9-polig
Baudrate | 9,6k; 19,2k; 93,75k; 187,5k; 500k; 1,5M; 3M; 6M; 12 MBaud
Protokoll |
PROFIBUS-DP | Ja
PROFIBUS-FMS | Nein
ADS Interface | Ja (nur über Ethernet)
Dienste |
PROFIBUS | DP
DPV1 Klasse 1 | Ja
DPV1 Klasse 2 | Nein
DPV2 MC | Nein
Maximale Prozessdaten | nur durch Speicher begrenzt
Redundanz | Nein
Muti Master | Nein
FDL | Nein
S5 AG-AG | Nein
Aktivieren von Slaves via ADS | Ja
PKW | Nein
Diagnose/Status/Alarm |
TC LED | Ja, grün/rot
BF LED | Ja, grün/rot
DIA LED | Ja, grün/rot (keine Funktion)

CX8030 als Slave

Der CX8030 kann auch als Slave parametriert werden, hier kann aber nicht wie beim CX8031 mit 3 virtuellen Slaves gearbeitet werden sondern nur mit einem realen Slave. Der CX8030 kann entweder als Master oder als Slave arbeiten, beides gleichzeitig ist nicht möglich.

Technische Daten PROFIBUS | CX8030
Anzahl der Slaves | 1
Anzahl der Daten pro Slave | 240 Byte In- und 240 Byte Outputdaten
Businterface | D-Sub 9-polig
Baudrate | max. 12 MBaud


CX8031 - Technische Daten - PROFIBUS

BECKHOFF CX8031: Produktübersicht

Technische Daten - PROFIBUS

Technische Daten Ethernet | CX8031
Anzahl der Slaves | 4 (davon 3 virtuelle)
Anzahl der Daten pro Slave | 240 Byte In- und 240 Byte Outputdaten
Businterface | D-Sub 9-polig
Baudrate | max. 12 MBaud
Autobaud | Ja
Protokoll |
PROFIBUS-DP Slave | Ja
PROFIBUS-DP (virtueller Slave) | 3 (siehe virtuelles PROFBUS Device)
ADS Interface | ja (nur über Ethernet)
Dienste |
PROFIBUS | DP
DPV1 | Ja
Diagnose/Status/Alarm |
TC LED | Ja, grün/rot
BF LED | Ja, grün/rot
DIA LED | Ja, grün/rot
Diagnosemeldungen | Ja


CX80xx - MicroSD-Karten

In der Grundausstattung enthält der CX80xx eine MicroSD-Karte mit 512 MB. Sie können ihn als Option mit größeren Karten (bis 4 GB) bestellen.

Die verwendeten Karten sind SLC-Speicher mit erweiterten Temperaturbereich für Industrielle Anwendungen. Verwenden Sie ausschließlich von Beckhoff freigegebene MicroSD-Karten.

Beispiel für eine MicroSD-Karte:

Bestellbezeichnung | Kapazität | Beschreibung
CX1900-0123 | 1 GB | MicroSD-Karte (SLC-Speicher ) mit erweitertem Temperaturbereich für Industrielle Anwendungen anstelle der 512 MB Karte (Bestelloption)
CX1900-0125 | 2 GB
CX1900-0127 | 4 GB
CX1900-0122 | 512 MB | MicroSD-Karte (SLC-Speicher) mit erweitertem Temperaturbereich für Industrielle Anwendungen als Ersatzteil.
CX1900-0124 | 1 GB
CX1900-0126 | 2 GB
CX1900-0128 | 4 GB

Weitere Informationen: http://www.beckhoff.de/CX8000


CX80xx - Abmessungen

BECKHOFF CX80xx: Montage und Verdrahtung

Abmessungen

Die folgenden Zeichnungen zeigen die Abmessungen der Embedded-PCs CX80xx.

Abmessungen

Zeichnungen in verschiedenen CAD-Formaten finden Sie unter: http://www.beckhoff.de/german/download/cx1000.htm


CX80xx - Tragschienenmontage

BECKHOFF CX80xx: Montage und Verdrahtung

Tragschienenmontage

Aufrasten auf die Tragschiene

Der CX80xx kann einfach auf die Tragschiene aufgerastet werden. Dazu wird der Block einfach frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Die wird durch ein vernehmliches Klicken angezeigt. Mit einem Schraubendreher wird dann die Arretierung auf der linken Seite nach oben gedrückt wodurch sich die Arretierung dreht und ebenfall hörbar einrastet.

Achtung 		Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Zulässige Einbaulagen und Mindestabstände

Einbaulage bei bis zu 55°C

Achtung 		Zulässige Einbaulage und Mindestabstände einhalten!
Das auf eine Hutschiene montierte CPU-Modul darf nur bis Umgebungstemperaturen von 55°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die Bilder zeigen die erlaubte sowie die eingeschränkte Einbaulagen.

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX80xx Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU-Grundmoduls und des Netzteils zu erreichen.

Aufgrund der hohen Leistung und der kompakten Bauform des CX80xx-Systems kann es zu einer erhöhten Wärmeentwicklung kommen. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Daher muss das System waagerecht montiert werden. Auf diese Weise kommt ein optimaler Luftstrom zustande.

Einbaulagen mit eingeschränktem Temperaturbereich bis 45°C

Andere Einbaulagen sind erlaubt bei einem Temperaturbereich bis 45°C.


CX80xx - Spannungsversorgung

BECKHOFF CX80xx: Montage und Verdrahtung

Spannungsversorgung

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie den CX80xx in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung beginnen!

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V.

Die Versorgungsspannung versorgt das CX System und über den Klemmbus und die Busklemmen mit einer Spannung von 24 VDC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 V. Da der Klemmbus (K- und E-Bus) nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen. An den Powerkontakten dürfen nur 24 V DC angeschlossen werden, die maximale Strombelastung der Powerkontakte beträgt 10 A.

Anforderungen an das Netzteil (24 V)

Um in allen Fällen den Betrieb der CPU (CX80xx-Modul) und des Klemmenstrangs zu gewährleisten muss das Netzteil 2,0 A bei 24 V liefern.

LED

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün auf. Die linke LED (Us) zeigt die Versorgung der CPU an. Die rechte LED (Up) zeigt die Versorgung der Klemmen an. Die weiteren LEDs beschreiben den Status des Klemmbusses. Die detaillierte Beschreibung der LEDs ist in dem Kapitel Fehleranalyse der LEDs beschrieben.

PE-Powerkontakt

VORSICHT 		Powerkontakt PE
Der Powerkontakt PE darf nicht für andere Potentiale verwendet werden.


CX80xx, EK9xxx - Ethernet-Anschlüsse

BECKHOFF CX80xx, EK9xxx: Ethernet

Ethernet-Anschlüsse

Belegung der RJ45-Schnittstelle, Port 1

X001

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8

Belegung der RJ45-Schnittstelle, Port 2 (switched)

CX8010, CX809x: X101 / 102
EK9xxx: X001 / X002

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8


Ethernet-Kabel

Übertragungsstandards

10Base5

Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.

10Base2

10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.

10BaseT

Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.

100BaseT

Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.

10BaseF

Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.

Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT

Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.

UTP

Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.

S/UTP

Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.

FTP

Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.

S/FTP

Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70dB erreichen.

STP

Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.

S/STP

Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Ein solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.

ITP

Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


PROFIBUS-Verkabelung

Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert (siehe PROFIBUS Schicht 1: Physical Layer).

Der Einsatzbereich eines Feldbus-Systems wird wesentlich durch die Wahl des Übertragungs-Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.

Kabelgebundene Übertragung

Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.

Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung (siehe Tabelle RS485).

RS485 - Grundlegende Eigenschaften
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 127 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis zu 10 km vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen.
Übertragungsgeschwindigkeit (in Stufen einstellbar) | 9,6 kBit/s; 19,2 kBit/s; 93,75 kBit/s; 187,5 kBit/s; 500 kBit/s; 1500 kBit/s; 12 MBit/s
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67

Verkabelung für PROFIBUS-DP und PROFIBUS-FMS

Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung des normalen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Zum Beispiel bekommt eine eine angeschlossenen PROFIBUS-Station keine Verbindung, kann diese aber nach Abziehen der benachbarten Station wieder aufnehmen. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, das der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Eine Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.

Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt in häufig ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder Abschlusswiderstände sind nicht oder an falschen Stellen aktiviert.

Hinweis 		Vorkonfektionierte Kabel von BECKHOFF
Mit den vorkonfektionierten Kabeln von BECKHOFF vereinfacht sich die Installation erheblich! Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das BECKHOFF-Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch Feldkonfektionierbare Stecker und Kabel erhältlich.

Hinweis 		Abschlusswiderstände
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das Buskabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.

Längenausdehnung

Die Busleitung ist in der EN 50170 spezifiziert. Daraus ergibt sich die nachfolgende Längenausdehnung eines Bussegment.

Baud-Rate in kBits/sec | 9,6 | 19,2 | 93,75 | 187,5 | 500 | 1500 | 12000
Leitungslänge in m | 1200 | 1200 | 1200 | 1000 | 400 | 200 | 100

Stichleitungen bis 1500 kBaud <6,6 m, bei 12 MBaud sollten keine Stichleitungen verwendet werden.

Bussegment

Ein Bussegment besteht aus maximal 32 Teilnehmern. An einem PROFIBUS-Netzwerk sind 126 Teilnehmer erlaubt. Um diese Anzahl zu erreichen sind Repeater erforderlich, die das Signal auffrischen. Dabei wird jeder Repeater wie ein Teilnehmer angesehen.

IP-Link ist das Sub-Bussystem der Feldbus Boxen dessen Topologie eine Ringstruktur ist. In den Koppler Modulen (IP230x-Bxxx oder IP230x-Cxxx) befindet sich ein IP-Link Master, an den bis zu 120 Erweiterungsmodule (IExxxx) angeschlossen werden dürfen. Der Abstand zwischen zwei Modulen darf dabei 5 m nicht überschreiten. Achten Sie bei der Planung und Installation der Module, dass aufgrund der Ringsstruktur das letzte Modul wieder am IP-Link Master angeschlossen werden muss.

Einbaurichtlinie

Beachten Sie bei der Montage der Module und beim Verlegen der Leitung die technischen Richtlinien der PROFIBUS-Nutzerorganisation e.V. zu PROFIBUS-DP/FMS (siehe www.profibus.de).

Überprüfung der PROFIBUS-Verkabelung

Ein PROFIBUS-Kabel (bzw. ein Kabel-Segment bei Verwendung von Repeatern) kann mit ein paar einfachen Widerstandsmessungen überprüft werden. Dazu sollte das Kabel von allen Stationen abgezogen werden:

  1. Widerstand zwischen A und B am Anfang der Leitung: ca. 110 Ohm
  2. Widerstand zwischen A und B am Ende der Leitung: ca. 110 Ohm
  3. Widerstand zwischen A am Anfang und A am Ende der Leitung: ca. 0 Ohm
  4. Widerstand zwischen B am Anfang und B am Ende der Leitung: ca. 0 Ohm
  5. Widerstand zwischen Schirm am Anfang und Schirm am Ende der Leitung: ca. 0 Ohm

Falls diese Messungen erfolgreich sind, ist das Kabel in Ordnung. Wenn trotzdem noch Bus-Störungen auftreten, liegt es meistens an EMV-Störungen. Beachten Sie die Installationshinweise der PROFIBUS-Nutzer-Organisation (www.profibus.com).


PROFIBUS-Anschluss

M12-Rundsteckverbinder

Die M12-Buchse ist invers codiert und besitzt 5 Stifte. Stift 1 überträgt 5 VDC und Stift 3 überträgt GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.

Stift 2 und Stift 4 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Stift 5 ist überträgt den Schirm (Shield) der kapazitiv mit der Grundfläche der Feldbus Box verbunden ist.

Pinbelegung M12 Buchse (-B310)

Pinbelegung M12 Buchse/Stecker (-B318)

Neunpoliger D-Sub

Stift 6 überträgt 5 VDC und Stift 5 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann.

Stift 3 und Stift 8 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist.

Pinbelegung der PROFIBUS D-Sub Buchse

Leitungsfarben PROFIBUS

PROFIBUS Leitung | M12 | D-Sub
B rot | Stift 4 | Stift 3
A grün | Stift 2 | Stift 8

Anschluss der Feldbus Box Module

Der Anschluss der Feldbus Box Module erfolgt entweder direkt oder mittels T-Stück (oder Y-Stück).

Die B318 Serie verfügt über jeweils eine Buchse und einen Stecker, d.h. hier wird der PROFIBUS in dem Modul weitergeleitet. Die Versorgungsspannung (+5VDC) für den Abschluss-Widerstand liegt nur auf der Buchse an. Der Abschluss-Widerstand ZS1000-1610 steht nur als Stecker zur Verfügung!

Die ankommende PROFIBUS-Leitung sollte stets mit einer Buchse enden.

Es stehen zwei T-Stücke zur Verfügung:

  • ZS1031-2600 mit +5VDC Weiterleitung zur Versorgung des Abschluss-Widerstandes
  • ZS1031-2610 ohne +5VDC Weiterleitung


CX80xx - Wechseln der Batterie

BECKHOFF CX80xx: Montage und Verdrahtung

Wechseln der Batterie

Die Batterie des CX80xx ist für die Real Time Clock (RTC) des CX80xx erforderlich. Sie dient dafür, dass im ausgeschalteten Zustand die RTC weiterläuft und somit die eingestellte Zeit beim erneuten Aufstarten wieder zu Verfügung steht.

  • Schritt 1: Öffnen Sie die Klappe
  • Schritt 2/3: Nehmen Sie einen kleine Flachschraubendreher setzen Sie diesen oberhalb der Batterie an und hebeln sie diese vorsichtig aus dem Gerät
  • Schritt 4: Setzen Sie die neue Batterie ein, der Pluspol muss links liegen
  • Schritt 5: Schließen Sie die Klappe wieder
Batterietyp | Technische Daten
Duracell 303/357 SR44 | 1,5 V / 165 mAh

Hinweis 		Wartung der Batterie

Die Batterie muss alle 5 Jahre gewechselt werden.

Ersatzbatterien können beim Beckhoff Service bestellt werden.

Achtung 		Eine falsch eingesetzte Batterie kann explodieren!

Verwenden Sie ausschließlich den angegebenen Batterietyp.

Achten Sie unbedingt darauf, dass die Plus- und Minuspole der Batterie korrekt eingelegt wird. (Pluspol links)

Öffnen Sie die Batterie niemals und werfen Sie die Batterie niemals in ein Feuer.

Die Batterie kann nicht wieder aufgeladen werden.


CX8031 - DIP-Schalter

BECKHOFF CX8031: Parametrierung und Inbetriebnahme

DIP-Schalter

Zwei mal 10-poliger Adress-Schalter S101/S102

Adresswählschalter kann für die Benutzung der PROFIBUS-Adresse verwendet werden.

S101 für die Adresse x 1, S102 für die Adresse x10, Beispiel S101=2, S102=3 PB Adresse 32

Damit die Adresse über den Adresswählschalter auch verwendet wird, muss dies im System Manager aktiviert werden.

Die Stationsadresse kann jetzt für jeden Slave mit einem DIP-Switch + Zahl eingestellt werden. Für die virtuellen Slaves kann man zum Beispiel +1, +2, +3 verwenden.

2-poliger DIP-Schalter (unter der Klappe zwischen Batterie und SD Kartenslot)

DIP-Schalter (rot) | Bedeutung
1 off und 2 off | normaler Modus, TwinCAT wird gestartet
1 on und 2 off | Der CX startet im Config Mode, über die USB Schnittstelle ist der interne Flash Speicher, bzw. beim CX80xx die SC Karte zu erreichen (zum Beispiel für ein Image Update).
1 off und 2 on | Restore der Registry
1 on und 2 on | bislang keine Funktion


CX80xx - IP-Adresse

BECKHOFF CX8010, CX803x, CX805x, CX8080: Parametrierung und Inbetriebnahme

IP-Adresse

Der CX8010, CX803x, CX805x und CX8080 besitzen eine Ethernet Schnittstelle, X001.

X001

IP-Adressierung über das Betriebsystem, Default ist DHCP (im Betriebsystem als FEC1 dargestellt)

EtherCAT-Schnittstelle

Die EtherCAT-Schnittstelle ist eine weitere Ethernet-Schnittstelle, die für die IP-Adressierung im Betriebsystem nicht sichtbar ist.


CX80xx - Adresseinstellung über DHCP-Server

BECKHOFF CX8031/CX8051: Parametrierung und Inbetriebnahme

Adresseinstellung über DHCP-Server

Port 1 (X001) ist per Default auf DHCP gestellt.

Ist DHCP eingeschaltet bekommt der CX automatisch eine IP-Adresse vom DHCP-Server zugewiesen. Der DHCP-Server muss hierfür die MAC-ID des Busklemmen-Controller kennen. Die IP-Adresse sollte vom DHCP-Server statisch vergeben werden. Ist kein DHCP Server erreichbar wird eine lokale IP-Adresse verwendet.

Der DNS-Name wird aus dem Typ und den letzten 3 Byte der MAC-ID gebildet. Die MAC-ID steht auf dem Produktionsaufkleber des Busklemmen Controllers.

Beispiel CX80xx
  • MAC ID: 00-01-05-01-02-03
  • DNS-Name: CX-010203


CX80xx - Subnetz-Maske

BECKHOFF CX80xx Parametrierung und Inbetriebnahme

Subnetz-Maske

Die Subnetz-Maske unterliegt der Kontrolle des Netzwerkverwalters und legt die Struktur der Subnetze fest.

Kleine Netze ohne Router benötigen keine Subnetz-Maske. Das gleiche gilt, wenn Sie keine registrierten IP-Nummern verwenden. Sie können die Subnetz-Maske dazu verwenden, anstelle des Gebrauchs vieler Netznummern das Netz mit dieser Maske zu unterteilen.

Die Subnetz-Maske ist eine 32-Bit Ziffer:

  • Einsen in der Maske kennzeichnen den Subnetz-Nummernteil eines Adressraums.
  • Nullen kennzeichnen den Teil des Adressraums, der für die Host-IDs zur Verfügung steht.
Beschreibung | Binäre Darstellung | Dezimale Darstellung
IP-Adresse | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnetz-Maske | 11111111.11111111.00010100.00000000 | 255.255.20.0
Netz-ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host-ID | 00000000.00000000.00000001.11001000 | 0.0.1.200

Standard Subnetz-Maske

Adressklasse | Standard Subnetz-Maske (dezimal) | Standard Subnetz-Maske (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00

Hinweis 		Vergabe von Subnetzen, Host-Nummern und IP-Adressen

Die Subnetze 0 und das nur aus nur Einsen bestehende Subnetz dürfen nicht verwendet werden!

Die Host-Nummer 0 und die aus nur Einsen bestehende Host-Nummer dürfen nicht verwendet werden!

Bei BootP und DHCP wird die Subnetz-Maske mit vom Server übertragen.


CX80xx - Betriebsystem

Auf dem CX80xx Geräte befindet sich ein Microsoft CE Betriebsystem der Version 6.0. Diese Betriebssystem ist für den Betrieb der CX80xx abgestimmt und optimiert. Es stehen nicht alle CE6.0-Komponenten zur Verfügung.

Sicherheit

Ab Image in Version 3.54b wurden die Sicherheitsvorkehrungen verschärft. Dieses betrifft das CERHOST und das TELNET. Beide Dienste sind nun im Auslieferungszustand abgeschaltet. Um diese Dienste wieder zu aktivieren benötigen Sie ein Lesegerät für MicroSD-Karten.

CERHOST

CERHOST wird von aktuellen Images beim ersten Start über die Registry-Datei CeRemoteDisplay_Disable.reg deaktivert, die sich im Ordner RegFiles befindet.

Um CERHOST wieder zu aktivieren, löschen Sie die Datei CeRemoteDisplay_Disable.reg aus dem Ordner RegFiles und ebenfalls den Ordner Documents and Settings.
Stecken Sie anschließend die MicroSD-Karte wieder in den CX und booten Sie neu. Der CX erzeugt ein neues Verzeichnis Document and Settings und bootet dann selbständig erneut.
Anschließend ist der CX wieder über CERHOST erreichbar.

TELNET

TELNET wird von aktuellen Images beim ersten Start über die Registry-Datei Telnet_Disable.reg deaktivert, die sich im Ordner RegFiles befindet.

Um TELNET wieder zu aktivieren, löschen Sie die Datei Telnet_Disable.reg aus dem Ordner RegFiles und ebenfalls den Ordner Documents and Settings.
Stecken Sie anschließend die MicroSD-Karte wieder in den CX und booten Sie neu. Der CX erzeugt ein neues Verzeichnis Document and Settings und bootet dann selbständig erneut.
Anschließend ist der CX wieder über TELNET erreichbar.

IMAGE

Falls sie nicht wissen welches Image auf dem CX80xx enthalten ist können sie dies einfach ermitteln.

  • Über die Web-Diagnose-Seite des CX. Hier finden Sie unter dem Gerät TwinCAT die Build-Nummer.
    Aufruf der Web-Diagnose-Seite:
    - IP-Adresse</config
    oder
    - CX-Name/config
    Bespiel:
    - 172.16.17.201/config
    oder
    - CX-01551E/config

  • Über ein Lesegerät für MicroSD-Karten.
    Auf der MicroSD-Karte befindet sich eine Datei mit dem Namen des Images.
    Beispiel CX8000_CE600_LF_v354b_TC211R3_B2248.
    Anhand TC211R3_2248 können Sie das verwendete TwinCAT-Build erkennen, hier in dem Beispiel das Build 2248.
Feature / Platform | CX80x0 LF Version 3.xx
ATL | Xtd
MFC | X
XML DOM | X
COM | X
COM Storage | -
Winsock | X
TCP/IP | X
TCP/IPv6 | -
Firewall | X
Network Utilities (IpConfig, Ping, Route) | X
UPnP |
Control Point | -
Device Host | X
SOAP |
Client | -
Server | -
DCOM | -
Object Exchange Protocol OBEX | -
Message Queuing MSMQ | -
Server |
File Server (SMB/CIFS) | X
File Server | X
Print-Server (SMB/CIFS) | -
RAS Server / PPTP Server | -
Simple Network Management Protocol (SNMP) | X
Telnet Server | X
HTTP / ASP / FTP / SNTP -Server | X
Web Server (HTTPD) / Active Server Pages (ASP) Support / JScript 5.6 / VBScript 5.6 | X
Simple Network Time Protocol (SNTP) | X
HTML / DHTML, SSL, ISAPI Erweiterungen | X
Internet Explorer 6.0 | -
Java Applets | -
NET Compact Framework | v3.5
RDP Client (Remote Desktop protocol) | -
CAB File Installer/Uninstaller | X
TwinCAT (Level PLC) | X
USB support | X
Printer, Storage auf z.B. Compact Flash | -
HID (Human interface devices) | -
Touch | -


CX80xx - E-Bus-Interface

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

E-Bus-Interface

Der Betrieb von E-Bus-Klemmen und EtherCAT Geräten ist am CX80xx möglich.

Der CX80xx erkennt diese Klemmen beim Scannen automatisch, ließt die Klemmentypen aus und legt sie im System-Manager automatisch an.

Hinweis 		DC Distributed-Clocks
Die CX80xx Baureihe eignet sich nicht für den Einsatz von EtherCAT Slaves, die die Distributed-Clocks Funktionalität verwenden oder auch brauchen.


CX80xx - K-Bus-Interface

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

K-Bus-Interface

Der Betrieb von K-Bus-Klemmen ist am CX80xx möglich.

Der CX80xx erkennt diese Klemmen beim Scannen automatisch, ließt die Klemmentypen aus und legt sie im System-Manager automatisch an.

Abb. K-Bus Interface

K-Bus State

Der K-Bus Status wird in dem State Byte (siehe Bild K-Bus Interface "1") abgelegt, ist der Wert 0 so arbeitet der K-Bus synchron und ohne Fehler. Sollte wer Wert <>0 sein kann das ein Fehler, aber auch nur ein Hinweis sein das zum Beispiel der K-Bus länger benötigt als die verwendete Task und ist damit nicht mehr Synchron zu der Task. Die Task-Zeit sollte schneller als 100 ms sein. Wir empfehlen eine Task-Zeit kleiner 50 ms. Typischerweise liegt die K-Bus-Update-Zeit zwischen einer und fünf ms.

Bit 0 = K-Bus Err
Bit 1 = Terminal State Err
Bit 2 = Process Data Length Err
Bit 8 = No valid Inputs
Bit 9 = K-Bus Input Update busy
Bit 10 = K-Bus Output Update busy
Bit 11 = Watchdog Err
Bit 15 = Acyc. Function atcive (e.g. K-Bus Reset)

Liegt ein K-Bus-Fehler vor, kann dieser über den Funktionsbaustein IOF_DeviceReset (in der TcIoFunctions.lib) zurückgesetzt werden.

Die NetID ist die des CX80xx und kann damit als empty String eingetragen werden, die Device-ID (siehe Bild K-Bus Interface "2") ist aus dem System-Manager zu nehmen.


CX8030 - PROFIBUS-Interface

BECKHOFF CX8030: Parametrierung und Inbetriebnahme

PROFIBUS-Interface

Die PROFIBUS-Kommunikation erfolgt über den D-Sub Port X101. Der CX8030 unterstützt die Funktion des automatischen Scanner der Slaves, hierfür muss die GSD Datei im Ordner \TwinCAT\IO\PROFIBUS abgelegt sein.

Hinweis 		Kein ADS über PROFIBUS
Der CX8030 unterstützt das ADS über PROFIBUS nicht. Der Programmdownload und das Debuggen kann ausschließlich über die Ethernet Schnittstelle erfolgen.

PROFIBUS Adresse (nur im Salve Mode)

Die PROFIBUS-Adresse kann über den DIP-Schalter oder fest im System Manager vergeben werden. Wird die Adresse fest vorgegeben wird der Adressschalter ignoriert (siehe DIP Schalter).

GSD-Datei

Die GSD-Datei für PROFIBUS Gräte sollten im TwinCAT Ordner \TwinCAT\IO\PROFIBUS abgelegt werden.

DpState

Über den DpState können sie sich den Zustand der PROFIBUS-Kommunikation anzeigen lassen und wissen damit ob der Slave sind im Datenaustausch befindet (DpState=0) oder ein Fehler oder Problem vorliegt.

0 = No error
1 = Station deactivated
2 = Station not exists
3 = Master lock
4 = Invalid slave response
5 = Parameter fault
6 = Not supported
7 = Config fault
8 = Station not ready
9 = Static diagnosis
10 = Diagnosis overflow
11 = Physical fault
12 = Data-Exchange left
13 = Severe bus fault
14 = Telegram fault
15 = Station has no ressources
16 = Service not activated
17 = Unexpected telegram
18 = Station ready
31 = only for EtherCAT gateways: WC-State of cyclic EtherCAT frame is 1
128 = slave, waiting for data transfer (or DP-Master in CLEAR-Mode)
129 = slave, waiting for configuration
130 = slave, waiting for parameter
131 = slave, waiting for baudrate

ExtDiagFlag

Das Flag zeigt an ob Diagnose vom Slave vorliegt, diese kann über den System Manager oder über die SPS via ADS ausgelesen werden (siehe ADS Interface).

Hinweis 		Ausgegraute System Manager Funktionen
Im Gegensatz zu anderen PROFIBUS Master von Beckhoff werden nicht alle PROFIBUS Features unterstützt. Daher sind einige Optionen im System Manager ausgegraut oder werden nicht angezeigt. Siehe Technische Daten CX8030 PROFIBUS.


CX8093 - PROFIBUS-Interface

BECKHOFF CX8031: Parametrierung und Inbetriebnahme

PROFIBUS-Interface

Die PROFIBUS-Kommunikation erfolgt über den D-Sub Port X101.

Hinweis 		Kein ADS über PROFIBUS
Der CX8031 unterstützt das ADS über PROFIBUS nicht. Der Programmdownload und das Debuggen kann ausschließlich über die Ethernet Schnittstelle erfolgen.

PROFIBUS Adresse

Die PROFIBUS-Adresse kann über den DIP-Schalter oder fest im System Manager vergeben werden. Wird die Adresse fest vorgegeben wird der Adressschalter ignoriert (siehe DIP Schalter).

GSD-Datei

Die GSD-Datei befindet sind im TwinCAT Ordner \TwinCAT\IO\PROFIBUS. Dateiname C8310CD7.gsd, das passende Bild CX8031.dib. Diese beiden Dateien Bild und GSD-Datei fügen Sie diese in ihrer Masterkonfigurationssoftware ein.

PROFIBUS DpState

Über den DpState können sie sich den Zustand der PROFIBUS-Kommunikation anzeigen lassen und wissen damit ob der Slave sind im Datenaustausch befindet (DpState=0) oder ein Fehler oder Problem vorliegt.

0 = No error
1 = Station deactivated
2 = Station not exists
3 = Master lock
4 = Invalid slave response
5 = Parameter fault
6 = Not supported
7 = Config fault
8 = Station not ready
9 = Static diagnosis
10 = Diagnosis overflow
11 = Physical fault
12 = Data-Exchange left
13 = Severe bus fault
14 = Telegram fault
15 = Station has no ressources
16 = Service not activated
17 = Unexpected telegram
18 = Station ready
31 = only for EtherCAT gateways: WC-State of cyclic EtherCAT frame is 1
128 = slave, waiting for data transfer (or DP-Master in CLEAR-Mode)
129 = slave, waiting for configuration
130 = slave, waiting for parameter
131 = slave, waiting for baudrate

PROFIBUS ExtDiagFlag

Hat beim Slave keine Bedeutung.


CX8031 - PROFIBUS-Prozessdaten

BECKHOFF CX8031: Parametrierung und Inbetriebnahme

PROFIBUS-Prozessdaten

Der CX8031 kann bis zu 240 Byte Prozessdaten über PROFIBUS in Eingangs- und Ausgangsrichtung mit dem PROFIBUS-Master austauschen. Über die GSD Datei können verschiedene Arten der Prozessdaten festgelegt werden.

Die Daten werden per Default im Intel Format übertragen. Sollte Ihrer Steuerung die Daten im Motorola Format benötigen müssen diese entsprechend gedreht werden.

Hier gibt es 3 Möglichkeiten wie sie vorgehen können.

  • Drehen der Daten auf der SPS sprich auf der CX Seite mit einem einfachen Befehl ROR (Beispiel für ST: VarProfibus:=ROR(VarAnalog,8); (* Beide Variablen vom Typ WORD*))
  • Drehen der Daten auf der Master Seite
  • Drehen der Daten im System Manager

Gehen sie dazu auf die Variable die Sie drehen wollen, wählen Sie Flags an und harken Sie die Option an die Sie benötigen. Bei WORD Variablen können Sie nur LO- und HI-Byte tauschen, bei DWORDs zusätzlich das WORD.

Beispiel: für DWORD

(Intel Format)
Daten des CX80xx | Daten die der Master empfängt
Ursprüngliche Daten | Kein Harken angewählt | Swap Byte (blau) | Swap Word (grün) | Swap beides (blau und grün)
0x01020304 | 0x01020304 | 0x02010403 | 0x03040102 | 0x04030201


CX8031 - Virtuelles Slave-Interface für PROFIBUS

BECKHOFF CX8031: Parametrierung und Inbetriebnahme

Virtuelles Slave-Interface für PROFIBUS

Das virtuelle Slave-Interface ermöglicht das Anlegen von bis zu drei virtuellen Slave auf der gleichen Hardware Schnittstelle. Das ermöglicht dem Anwender mehr Daten mit einem PROFIBUS-Master auszutauschen oder auch mit einem zweiten PROFIBUS-Master eine Verbindung aufzubauen.

Es können für jeden Slave maximal 240 Byte Daten konfiguriert werden, d.h. in Summe kann man vier mal 240 Byte Daten in jede Richtung austauschen.

Fügen Sie an dem PROFIBUS-Gerät maximal 4 CX8031 Geräte an (Abb. 1.0). Jedes der Gräte bekommt über den System Manager eine PROFIBUS-Adresse die auch mit dem Adresswählschalter verknüpft sein kann (siehe Adressschalter). Die Prozessdaten fügen Sie unter der Box an (Abb. 1.1 und 1.2) und die dürfen 240 Byte Ein- oder 240 Byte Ausgangsdaten nicht überschreiten. Für den PROFIBUS-Master konfigurieren Sie jeden der 4 Slaves wie ein eigenständiges Gerät.

Es ist auch erlaubt einen oder mehrere Slaves mit einem zweiten PROFIBUS-Master zu verbinden. Der Master muss die Multimasterfähigkeit unterstützen. Auf dem CX8031 müssen Sie hierfür nichts weiteres einstellen.

Abb. 1.0 Anlegen der 4 PROFIBUS Slave Geräte

Abb. 1.1 Anfügen der PROFIBUS Module

Abb. 1.2 Auswahl der PROFIBUS-Module


CX80xx - Upnp-Web-Seiten

BECKHOFF CX80xx: Web Services

Upnp-Web-Seiten

Auf den CX80xx befindet sich zur Diagnose eine Upnp-Web-Seite.

Benutzername: guest
Passwort: 1

Geben Sie die IP-Adresse oder den Device Name an.

Beispiel

http://cx-0f94ac/config

http://172.16.17.55/config

Ab dem Image v354c wurde die Diagnoseseite überarbeitet.


CX80xx - Web-Visulisierung

BECKHOFF CX80xx: Web Services

Web-Visulisierung

Auf dem CX80xx befindet sich eine Web-Visualisierung. Diese kann mit Hilfe des PLC Controls in TwinCAT erstellt und aktiviert werden.

Abb. 1: Aktivierung der Web Visualisierung im PLC Control

Der Aufruf erfolgt über die IP-Adresse oder den Device Name an in einem Web Browser.
Weitere Informationen entnehmen Sie der Dokumentation zur Web Visualisierung (siehe TwinCAT Supplements PLC HMI Web).

Beispiel

http://cx-0f94ac/TcWebVisu/

http://172.16.17.44/TcWebVisu/

Achten Sie vor dem Einloggen (also im ausgeloggten Zustand) ob eine ADS Verbindung zum CX besteht, rechts unten in der Ecke muss das "TwinCAT Running" in grün stehen. Sollte das nicht der Fall sein bitte noch mal auf Online/Auswahl des Zielsystems gehen und den CX erneut aufrufen.

Beim download der Web Daten für die Web Oberfläche muss folgende Pfadangabe stehen:

\hard disk\twincat\boot\webvisu\

Sollte das nicht der Fall sein kopiert das PLC Control die Daten in den falschen Ordner und die Web-Seite wird nicht korrekt oder gar nicht angezeigt.

Abb. 2: Pfadangabe


CX80xx - Remote Display

BECKHOFF CX80xx: Web Services

Remote-Display

Diese Seite beschreibt die Schritte um ein CE-Gerät mit CE-Betriebssystem von einem weiteren PCaus per "Remote Display" fernzusteuern.

Voraussetzungen

Erforderliche Software auf dem PC:

  • Windows NT, Windows 2000, Windows XP oder Windows 7
  • Microsoft Remote Display (CERHOST, lizenzfrei bei Microsoft erhältlich)

Verbindungsaufbau

Auf dem PC wird das Tool "Remote Display" gestartet. Unter dem Menüpunkt "File -> Connect" kann nun die Adresse des CE-Gerätes eingetragen werden, dies kann sowohl die TCP-IP Adresse oder falls vorhanden auch der Name des CE-Gerätes sein.

Ist das CE-Gerät mit einem Passwortschutz versehen, so muss auch das Passwort entsprechend eingetragen werden. Im Auslieferungszustand ist kein Passwort gesetzt.

Nach Eintrag der Zieladresse steht die Oberfläche des CE-Gerätes zur Remote-Bedienung auf dem PC zur Verfügung.

Download CERHOST:


CX80xx - Real Time Clock (RTC)

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

Real Time Clock (RTC)

Die RTC wird über die Funktionsbausteine FB_LocalSystemTime ausgelesen und kann mit dem Baustein NT_SetLocalTime eingestellt werden (siehe TcUtilities.lib).

Die RTC wird über die Batterie versorgt und kann so im ausgeschalteten Zustand weiterlaufen.


CX80xx - 1-Sekunden-USV

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

1-Sekunden-USV (Unterbrechungsfreie Stromversorgung)

Technische Grundlagen

Die 1-Sekunden-USV ist ein UltraCap-Kondensator, der bei Ausfall der Spannungsversorgung den Prozessor für ca. 4 bis 5 Sekunden weiterhin mit Strom versorgt, um persistente Daten abzuspeichern. In der Regel braucht das Speichern der Daten weniger als 4 bis 5 Sekunden, da aber die verwendeten Bauteile altern, sollte von einer Sekunde ausgegangen werden, die die USV maximal hält. So können Sie davon ausgehen, das auch nach Jahren, das Abspeichern der Daten reibungslos funktioniert. Sollten Sie selbst Daten speichern, empfehlen wir, dass dies innerhalb von einer Sekunde geschieht. Sollte es länger dauern raten wir davon ab.

Die 1-Sekunden-USV versorgt weder den K-Bus noch den E-Bus weiter mit Spannung. Beachten Sie, das deren Daten bei Aktivierung der 1-Sekunden-USV bereits ungültig sein können. Auch kann das Feldbussystem (oder Ethernet) nicht oder nur unzureichend funktionieren sobald die 1-Sekunden-USV aktiv wurde.

Das Abspeichern der persistenten Daten erfolgt nur in Verbindung mit dem Funktionsbaustein FB_S_UPS_CX80xx. Dieser muss zyklisch aufgerufen werden. Hier empfehlen wir ausschließlich mit den Default-Werten des Bausteins zu arbeiten.

Arbeitsweise beim speichern und laden der persistenten Daten

Die persistenten Daten werden als wdp-Datei auf der SD-Karte gespeichert. Beim Starten der SPS wird die wdp-Datei von der SD-Karte geladen, dort als wd~-Datei gesichert (Backup) und dann gelöscht. Erst beim Runterfahren des Systems, bzw. dem ansprechen der 1-Sekunden-USV wird erneut eine aktuelle wdp-Datei geschrieben. Ist beim Starten des CX keine wdp-Datei vorhanden so sind die persistenten Daten ungültig und werden gelöscht (Default Einstellung).
Ursache hierfür ist, das beim Hochlauf des CX vor dem Starten der TwinCAT PLC die 1-Sekunden-USV aktiv wurde. Dann wurden keine persistenten Daten gesichert, da nicht sichergestellt war, ob die Pufferzeit noch reichte um die Daten abzuspeichern.

Das Backup der persistenten Daten laden

Um die persistenten Daten aus dem Backup (wp~-Datei) zu laden, muss dies im System Manager aktiviert werden.

Oder folgender Registry Eintrag:

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Plc]"ClearInvalidPersistentData"= 0

Herstellereinstellung ist default "1".

Überprüfung ob aktuelle persistente Daten (aus wdp-Datei) oder gesicherte persistente Daten aus dem Backup (wd~-Datei) geladen wurden

Das Beispiel signalisiert beim CX8090 über die ERR-LED ob die persistenten Daten geladen worden sind. Bei andern CX8xxx kann die LED nicht genutzt werden.

IF systeminfo.bootDataFlags.4 AND NOT systeminfo.bootDataFlags.5 THEN
F_CX8090_LED_ERR(eLED_GREEN_ON); (* persistent data is OK *)
ELSIF systeminfo.bootDataFlags.4 AND systeminfo.bootDataFlags.5 THEN
F_CX8090_LED_ERR(eLED_RED_ON); (* load backup persistent data *)
ELSE
F_CX8090_LED_ERR(eLED_RED_FLASHING_200ms); (* no persistent data *)
END_IF

Hinweis 		Verwendungszweck der 1-Sekunden-USV
Die 1-Sekunden-USV ist nur für den Zweck der persistenten Datenhaltung zu verwenden.
Andere Anwendungsfälle werden nicht unterstützt und sind kein Reklamationsgrund.

Retain-Daten können für die 1-Sekunden-USV nicht verwendet werden!


CX80xx - CPU-Auslastung

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

CPU-Auslastung

Im Auslieferungszustand ist die CPU-Auslastungsanzeige bei allen CX80xx-Geräten deaktiviert (diese wird mit konstant 10% angezeigt). Die CPU-Auslastungsanzeige ist deaktiviert, da diese selbst einen erheblichen Anteil der CPU-Auslastung ausmacht. Man kann die CPU-Auslastung für eine kurzzeitige Diagnosehilfe aktivieren, wir empfehlen aber, diese nach der Diagnose wieder zu deaktivieren.

HKEY_LOCAL_MACHINE/SOFTWARE/BECKHOFF/TWINCAT/RTime/EnableRTimeMeasurement 0 deaktiviert, 1 aktiviert

Nach der Einstellung ist ein TwinCAT-Restart des CX80xx notwendig.

Hinweis 		CPU-Auslastung
Die CPU-Auslastung wird intern mit 10 ms gerechnet.
Werden eine oder mehrere Task über 10 ms verwendet, kann die Anzeige der CPU-Auslastung sehr stark schwanken.


Bibliothek für CX80xx

Download der Bibliothek


CX80xx - FUNCTION_BLOCK FB_S_UPS_CX80xx

BECKHOFF CX80xx: Programmierung

FUNCTION_BLOCK FB_S_UPS_CX80xx

Der Funktionsbaustein FB_S_UPS kann auf CX80xx mit der Sekunden-USV verwendet werden, um die Sekunden-USV aus der SPS anzusteuern. Hiermit können bei Spannungsausfall noch die Persistenten Daten gespeichert und ein QuickShutdown ausgeführt werden. Wenn möglich sollten die Defaultwerte der INPUTs des FB_S_UPS beibehalten werden.

Achtung 		Datenverlust
Die Sekunden-USV kann bei Spannungsausfall nur für wenige Sekunden verwendet werden, um z.B. Persistente Daten zu speichern. Das Speichern der Daten muss im schnellen Persistent Modus "SPDM_2PASS" erfolgen, auch wenn es hier zu Echtzeitverletzungen kommen kann. Zum Speichern der Persistenten Daten muss hinreichend Routerspeicher konfiguriert werden!

Für das Überbrücken von Spannungsausfällen hat die Sekunden-USV nicht genügend Kapazität. Das Speichern kann nur auf der micro SD Karte erfolgen.

Im Modus eSUPS_WrPersistData_Shutdown (Standardeinstellung) wird nach dem Speichern der persistenten Daten automatisch ein QuickShutdown ausgeführt.

Im Modus eSUPS_WrPersistData_NoShutdown werden nur die persistenten Daten gespeichert, es wird kein QuickShutdown ausgeführt.

Im Modus eSUPS_ImmediateShutdown wird sofort ein QuickShutdown ausgeführt, ohne das Speichern von Daten.

Im Modus eSUPS_CheckPowerStatus wird nur geprüft, ob ein Spannungsausfall auftrat. Ist dies der Fall, geht der Baustein erst nach Ablauf der tRecoverTime (10s) wieder in den Zustand PowerOK.

Unabhängig vom Modus und damit unabhängig vom Speichern oder Herunterfahren der Steuerung schaltet die USV nach Entladung der Kondensatoren das Mainboard ab, auch wenn die Spannung zwischenzeitlich wiederkehrt.

Achtung 		Achtung bei Verwendung von Dateien:
Falls andere Applikationen oder die SPS noch weitere Dateien offen halten oder in diese schreiben, kann es zu fehlerhaften Dateien kommen, wenn die USV die Steuerung abschaltet.

FUNCTION_BLOCK FB_S_UPS_CX80xx

VAR_INPUT

VAR_INPUT
    sNetID          : T_AmsNetId := '';               (* '' = local netid *)
    iPLCPort        : UINT := AMSPORT_R0_PLC_RTS1;    (* PLC Runtime System for writing persistent data *)
    iUPSPort        : UINT := 16#4A8;                 (* Port for reading Power State of UPS, dafault 16#4A8 *)
    tTimeout        : TIME := DEFAULT_ADS_TIMEOUT;    (* ADS Timeout *)
    eUpsMode        : E_S_UPS_Mode := eSUPS_WrPersistData_Shutdown; (* UPS mode (w/wo writing persistent data, w/wo shutdown) *)
    ePersistentMode : E_PersistentMode := SPDM_2PASS; (* mode for writing persistent data *)
    tRecoverTime    : TIME := T#10s;                  (* ON time to recover from short power failure in mode eSUPS_WrPersistData_NoShutdown/eSUPS_CheckPowerStatus *)
END_VAR

sNetID : AmsNetID der Steuerung.

iPLCPort : Portnummer des SPS-Laufzeitsystems (AMSPORT_R0_PLC_RTS1 = 801, AMSPORT_R0_PLC_RTS2 = 811, AMSPORT_R0_PLC_RTS3 = 821, AMSPORT_R0_PLC_RTS4 = 831).

iUPSPort : Portnummer über die der USV-Status gelesen wird (Standardwert ist 16#4A8).

tTimeout : Timeout für die Ausführung des QuickShutdowns.

eUpsMode : eUpsMode definiert, ob Persistente Daten geschrieben werden sollen und ob ein QuickShutdown ausgeführt werden soll.
Standardwert ist eSUPS_WrPersistData_Shutdown, d.h. mit Schreiben der Persistenten Daten und dann QuickShutdown. Siehe E_S_UPS_Mode.

ePersistentMode : Modus für das Schreiben der Persistenten Daten. Standardwert ist SPDM_2PASS.
SPDM_2PASS, es werden alle persistente Daten auf einmal weggeschrieben, das kann zu einer Zykluszeitüberschreitung führen.
SPDM_VAR_BOOST, hier wird jede persistente Variable einzeln geschrieben, Das kann bei vielen persistenten Daten entsprechend viele Zyklen dauern. Dies wird nicht empfohlen da es dazu führen kann das einige Daten verloren gehen, wenn die Zeit der Sekunden USV nicht ausreichend ist.

tRecoverTime : Zeit, nach der die USV bei UPS-Modi ohne Shutdown wieder in den PowerOK Status zurück geht.
Die tRecoverTime muss etwas größer sein, als die maximale Haltezeit der USV, da die USV auch bei wiederkehrender Spannung abschaltet.

VAR_OUTPUT

VAR_OUTPUT
    bPowerFailDetect	: BOOL;            (* TRUE while powerfailure is detected *)
    eState 		: E_S_UPS_State;   (* current ups state *)
END_VAR

bPowerFailDetect : True während des Spannungsausfalls; False, wenn die Versorgungsspannung anliegt .

eState : Interner Zustand des Funktionsbausteins, Werte siehe E_S_UPS_State.

VAR_GLOBAL

VAR_GLOBAL
    eGlobalSUpsState : E_S_UPS_State;    (* current ups state *)
END_VAR

eGlobalUpsState : Interner Zustand des Funktionsbausteins als globale Kopie des VAR_OUTPUT eState, Werte siehe E_S_UPS_State.

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | Sekunden USV | -


CX80xx - TYPE E_S_UPS_Mode

BECKHOFF CX80xx: Programmierung

TYPE E_S_UPS_Mode

eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten und dann QuickShutdown
eSUPS_WrPersistData_NoShutdown: Nur Schreiben der Persistenten Daten (kein QuickShutdown)
eSUPS_ImmediateShutdown: Nur QuickShutdown (kein Schreiben der Persistenten Daten)
eSUPS_CheckPowerStatus: Nur Status ermitteln (weder Schreiben der Persistenten Daten noch QuickShutdown)

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | Sekunden USV | -


CX80xx - TYPE E_S_UPS_State

BECKHOFF CX80xx: Programmierung

TYPE E_S_UPS_State

eSUPS_PowerOK:
    in allen Modi: Versorgungsspannung ist OK

eSUPS_PowerFailure:
    in allen Modi: Versorgungsspannung fehlerhaft (steht nur einen Zyklus an)

eSUPS_WritePersistentData:
    im Modus eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten ist aktiv
    im Modus eSUPS_WrPersistData_NoShutdown: Schreiben der Persistenten Daten ist aktiv

eSUPS_QuickShutdown:
    im Modus eSUPS_WrPersistData_Shutdown: QuickShutdown ist aktiv
    im Modus eSUPS_ImmediateShutdown: QuickShutdown ist aktiv

eSUPS_WaitForRecover:
    im Modus eSUPS_WrPersistData_NoShutdown: Warten auf Wiederkehr der Spannung
    im Modus eSUPS_CheckPowerStatus: Warten auf Wiederkehr der Spannung

eSUPS_WaitForPowerOFF:
    im Modus eSUPS_WrPersistData_Shutdown: Warten auf das Abschalten durch die USV
    im Modus eSUPS_ImmediateShutdown: Warten auf das Abschalten durch die USV

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | Sekunden USV | -


CX80xx - FUNCTION_CX80xx_ADDRESS

BECKHOFF CX80xx: Programmierung

FUNCTION F_CX80xx_ADDRESS

Mit der Funktion kann der Adresswählschalter oder der DIP Schalter des CX80xx Gerätes ausgelesen werden. Hier kann man zum Beispiel in Abhängigkeit der Adresse durch das Lesen der Schalterstellung verschiedene Programmteile aktivieren.

VAR_INPUT

VAR_INPUT
    iCX_Typ          : INT;
END_VAR

iCX_Typ : Hier wird der benutzte CX Typ eingetragen, nur die Nummer ohne die Bezeichnung CX: Beispiel, CX8031 dann wird 8031 eingetragen.

VAR_OUTPUT

F_CX80xx_ADDRESS		: INT;

F_CX80xx_ADDRESS : -1, nicht implementierter CX, Adresse des Schalters

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | CX80xx | -


CX8030 - ADS-Interface

BECKHOFF CX8030: ADS-Interface

CX8030 ADS-Interface

ADS NetId der PROFIBUS-Schnittstelle

Für die ADS-Kommunikation wird eine NetId benötigt. Diese ist im TwinCAT System Manager dem Karteireiter ADS des PROFIBUS-Interfaces zu entnehmen.

ADS-Interface

Sämtliche azyklischen Daten werden mit ADS-Read, ADS-Write oder ADS-Write-Control an die bzw. von dem CX8030 übertragen. Das PROFIBUS Interface des CX8030 hat eine eigene Net-ID und unterstützt die folgenden Ports:

Port | Beschreibung
200 | damit wird das PROFIBUS-Interface selbst adressiert, d.h. Daten, die lokal auf dem PROFIBUS-Interface liegen, bei denen in der Regel kein zusätzlicher Buszugriff nötig ist.
0x1000 - 0x107E | damit wird ein angeschlossener PROFIBUS-Teilnehmer adressiert, wobei sich Adresse aus Port-0x1000 berechnet (oder 0x1000 + Slave Adresse), es wird auch immer ein Buszugriff durchgeführt.

ADS-Read

Es folgt eine Übersicht der von dem CX8030 unterstützten IndexGroup/IndexOffset bei ADS-Read.

IndexGroup bei lokaler Adressierung des CX8030 (Port 200)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0xF181 | 0x0000-0x007E | BYTE-Offset innerhalb der Daten | Damit werden die Diagnosedaten eines projektierten DP-Slaves ausgelesen, die Stationsadresse berechnet sich aus dem IndexGroup(Hi-Word). Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die im Kapitel Slave-Diagnose beschriebenen Diagnosedaten eines projektierten DP-Slaves.
0xF830 | 0x0000-0x007E | immer 0 | Damit kann festgestellt werden, welche DP-Slaves am PROFIBUS vorhanden sind, unabhängig davon, ob sie projektiert wurden oder nicht, die Stationsadresse wird im IndexGroup (Hi-Word) eingetragen. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, hat der entsprechende DP-Slave korrekt geantwortet, die Daten enthalten die Ident-Nummer des Slaves (BYTE-Offset 0-1) und die ausgelesenen CfgData (ab BYTE-Offset 2) (s. Kapitel Upload Configuration).

IndexGroup bei Adressierung eines projektierten PROFIBUS-Teilnehmers (Port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0x00-0xFF | 0x00 | 0x00-0xFF | Damit wird ein DPV1-Read an den entsprechenden, projektierten DPV1-Slave über eine Class-1-Verbindung gesendet, die DPV1-Slot-Nummer entspricht der IndexGroup, der DPV1-Index entspricht dem IndexOffset. Wenn der ADS-Read ohne Fehler (Error-Code = 0) beantwortet wird, enthalten die Daten die ausgelesenen DPV1-Daten (siehe Kapitel DPV1)

ADS-Write

Es folgt eine Übersicht der von dem CX8030 unterstützten IndexGroup/IndexOffset bei ADS-Write.

IndexGroup bei Adressierung eines projektierten PROFIBUS-Teilnehmers (Port 0x1000-0x107E)

IndexGroup (Lo-Word) | IndexGroup (Hi-Word) | IndexOffset | Beschreibung
0x00-0xFF | 0x00 | 0x00-0xFF | Damit wird ein DPV1-Write an den entsprechenden, projektierten DPV1-Slave über eine Class-1-Verbindung gesendet, die DPV1-Slot-Nummer entspricht der IndexGroup, der DPV1-Index entspricht dem IndexOffset (siehe Kapitel DPV1).

ADS-WriteControl

Es folgt eine Übersicht der von dem CX8030 unterstützten Dienste beim ADS-WriteControl.

ADS-WriteControl bei Adressierung eines projektierten PROFIBUS-Teilnehmer (Port 0x1000-0x107E)

AdsState | DeviceState | State der FC310x/EL6731 | Beschreibung
STOP (6) | 0x00 | RUN (5) | Damit wird der Slave gestoppt, d.h. die Prozessdatenverbindung zu dem entsprechenden DP-Slave (Data_Exchange) wird abgebaut (mit SetPrm,Unlock).
RUN (5) | 0x00 | STOP (6) | Damit wird der Slave nach einem Stoppen erneut gestartet, d.h. die Prozessdatenverbindung zu dem entsprechenden DP-Slave (Data_Exchange) wird wieder aufgebaut (normaler DP-Hochlauf).


CX8030 - DP-V1-Kommunikation

BECKHOFF CX8030: ADS Interface

DPV1-Kommunikation

Der Master unterstützt auf einer C1-Verbindung die Dienste Read und Write sowie auf einer C2-Verbindung die Dienste Read, Write, Data_Transport, Initiate und Abort.

C1-Verbindung (MSAC-C1)

Die C1-Verbindung ist für den Master reserviert, die mit dem Slave zyklischen Datenaustausch durchführt (C1-Master). Um die C1-Verbindung bei einem Slave nutzen zu können, muss der Slave DPV1 unterstützen (in der GSD-Datei müssen dafür die Zeile "DPV1_Slave = 1" und das Schlüsselwort "C1_Max_Data_Len" mit einer entsprechenden Länge eingetragen sein). Weiterhin ist in der Regel die C1-Funktionalität durch Setzen des Bit 7 von PrmData-Byte 0 bei dem entsprechenden Slave zu aktivieren (bei Beckhoff-Geräten, die DPV1 unterstützen, passiert das automatisch).

MSAC-C1-Read ist auf ADS-Read, MSAC-C1-Write auf ADS-Write abgebildet:

MSAC-C1 Read

ADS-Read-Parameter | Bedeutung
Net-ID | Net-ID des Masters (s. Karteireiter ADS des Devices)
Port | 0x1000 + Stationsadresse des Slaves
IndexGroup | Slot-Number (DPV1-Parameter)
IndexOffset | Index (DPV1-Parameter)
Length | Länge der auszulesenden Daten
Data | bei Response: ausgelesene Daten

MSAC-C1 Write

ADS-Write-Parameter | Bedeutung
Net-ID | Net-ID des Masters (s. Karteireiter ADS des Devices)
Port | 0x1000 + Stationsadresse des Slaves
IndexGroup | Slot-Number (DPV1-Parameter)
IndexOffset | Index (DPV1-Parameter)
Length | Länge der zu schreibenden Daten
Data | bei Request: zu schreibende Daten


CX8030 - Slave-Diagnose

BECKHOFF CX8030: SLAVE Diagnose

Slave-Diagnose

DP-State

Je DP-Slave gibt es eine Status-Variable, die den aktuellen Zustand des DP-Slaves anzeigt. Dieser Status ist ein Echtzeit-Status, d.h. er passt immer zu den aktuellen Daten des DP-Slaves und kann mit einer PLC-Variable verknüpft werden (-> DpState des Slaves):

Diagnosedaten

Jeder DP-Slave kann während des Data_Exchange-Betriebs azyklisch DP-Diagnosedaten melden. Dabei setzt der Slave in der Antwort des zyklischen Data_Exchange-Telegramms das Diag_Flag, woraufhin der DP-Master automatisch die DP-Diagnosedaten beim Slave ausliest. Der Data-Exchange-Zyklus wird beim Beckhoff-DP-Master dabei nicht beeinflusst, da das DP-Diagnosetelegramm am Ende des zyklischen Data-Exchange-Zyklusses (vor dem Anfang des nächsten Zyklusses) gesendet wird. Wenn sich die beim Slave ausgelesenen DP-Diagnosedaten gegenüber dem letzten Zustand geändert haben, setzt der DP-Master die Variable ExtDiagFlag, die mit einer Variable des Steuerungsprogramms verknüpft werden kann.

Die aktuellen Diagnosedaten des DP-Slaves werden im System-Manager Karteireiter Diag des Slaves angezeigt. Außerdem können sie per ADS vom Steuerungsprogramm ausgelesen werden, woraufhin die Variable "ExtDiagFlag" wieder zurückgesetzt wird:

ADS-Read-Parameter | Bedeutung
Net-ID | Net-ID des Masters (s. Karteireiter ADS des Devices)
Port | 200
IndexGroup | 0x00yyF181 (yy = Stationsadresse des Slaves)
IndexOffset | Offset innerhalb der Diagnosedaten
Length | Länge der auszulesenden Diagnosedaten
Data | Diagnosedaten

Die Diagnosedaten beihalten die Slave-Statistiken (32 Bytes) und die vom Slave gesendeten DP-Diagnosedaten (bis zu 244 Bytes) und sind wie folgt aufgebaut:

Offset | Bedeutung
Slave-Statistiken
0 | Receive-Error-Counter (WORD): Anzahl der fehlerhaften Telegramme bei der Kommunikation mit diesem Slave
2 | Repeat-Counter[8] (WORD): Die Repeat-Counter zeigen an, wie oft wie viele Repeats gemacht werden mussten. Repeat-Counter[0] zeigt an, wie oft ein Telegramm zu diesem Slave einmal wiederholt werden mußte, Repeat-Counter[1], wie oft ein Telegramm zu diesem Slave zweimal wiederholt werden musste, etc. Die maximale Anzahl der Wiederholungen wird mit dem Parameter Max Retry-Limit (s. Dialog Bus-Parameter) eingestellt, der Wertebereich geht von 0 bis 8, daher gibt es hier 8 Repeat-Counter (für 1 bis 8 Wiederholungen)
18 | reserviert für Erweiterungen
20 | NoAnswer-Counter (DWORD): Anzahl der Telegramme bei der Kommunikation mit diesem Slave, auf die nicht geantwortet wurde. Wenn ein Slave das erste Mal nicht antwortet, wird entsprechend des MaxRetryLimit das Telegramm wiederholt, wenn er auch dann nicht geantwortet hat, wird beim nächsten Mal keine Wiederholung mehr durchgeführt.
24-27 | Last-DPV1-Error[4] (BYTE): Hier wird die letzte fehlerhafte DPV1-Antwort eingetragen (Byte 0: DPV1-Dienst (Bit 7 ist gesetzt und zeigt damit einen Fehler an), Byte 1: Error_Decode, Byte 2: Error_Code_1 (Error_Class/Error_Code), Byte 3: Error_Code_2), s. Beschreibung DPV1-Fehlercodes
27-31 | reserviert für Erweiterungen
ab 32 | DP-Diagnosedaten

DP-Diagnosedaten - DiagData

Es folgt eine Beschreibung der DP-Diagnosedaten

Offset | Bedeutung
0x00.0 | StationNonExistent: Slave beim letzten Telegramm nicht geantwortet
0x00.1 | StationNotReady: Slave verarbeitet noch das Set_Prm bzw. Chk_Cfg-Telegramm
0x00.2 | CfgFault: Slave meldet einen Konfigurationsfehler
0x00.3 | ExtDiag: Extended DiagData sind vorhanden und gültig
0x00.4 | NotSupported: Slave unterstützt ein Feature nicht, das mit Set_Prm oder Global_Control gefordert wurde
0x00.5 | InvalidSlaveResponse: Slave antwortet nicht DP-konform
0x00.6 | PrmFault: Slave meldet einen Parametrierfehler
0x00.7 | MasterLock: Slave ist im Datenaustausch mit einem anderen Master
0x01.0 | PrmReq: Slave muß neu parametriert und konfiguriert werden
0x01.1 | StatDiag: Slave meldet statische Diagnose bzw. Applikation des DPV1-Slave noch nicht bereit für den Datenaustausch
0x01.2 | PROFIBUS-DP-Slave
0x01.3 | WdOn: DP-Watchdog ist eingeschaltet
0x01.4 | FreezeMode: DP-Slave ist im Freeze-Mode
0x01.5 | SyncMode: DP-Slave ist im Sync-Mode
0x01.6 | reserviert
0x01.7 | Deactivated: DP-Slave wurde deaktiviert
0x02.0 | reserviert
0x02.1 | reserviert
0x02.2 | reserviert
0x02.3 | reserviert
0x02.4 | reserviert
0x02.5 | reserviert
0x02.6 | reserviert
0x02.7 | ExtDiagOverflow: zu viele Extended DiagData vorhanden
0x03 | MasterAdd: Stationsadresse des Masters, der mit dem Slave Datenaustausch macht
0x04,0x05 | IdentNumber
ab 0x06 | Extended DiagData

Extended DiagData

Bei den Extended DiagData wird zwischen Kennungsdiagnose, Kanaldiagnose und Herstellerspezifischer Diagnose unterschieden, wobei das erste Byte jeweils den Typ der Diagnose und die Länge der dazugehörenden Daten anzeigt. In den Extended DiagData können auch auch mehrere Diagnosetypen nacheinander folgen.

Header-Byte

Bit | Bedeutung
0-5 | Länge der zugehörigen Diagnosedaten inklusive Header-Byte
6-7 | 0 = Herstellerspezifische Diagnose (DPV1 wird nicht unterstützt) bzw. DPV1-Diagnose (DPV1 wird unterstützt (DPV1_Enable = 1) in zugehöriger GSD-Datei)
 | Moduldiagnose
 | Kanaldiagnose
 | Revision-Number

Herstellerspezifische Diagnose

Der Aufbau der Herstellerspezifischen Diagnose ist der Dokumentation des DP-Slaves zu entnehmen.


CX803x - Upload der Konfiguration

BECKHOFF CX8030: Upload Konfiguration

Upload der Konfiguration

Während des Betriebs kann der PROFIBUS per ADS-Readnach neuen Geräten gescannt werden:

ADS-Read-Parameter | Bedeutung
Net-ID | Net-ID des Masters (siehe Karteireiter ADS des Devices)
Port | 200
IndexGroup | 0x00yyF830 (yy = Stationsadresse, Beckhoff-Geräte liefern die gleichen Informationen wie Fremd-Geräte)
IndexOffset | 0
Length | 1538
Data | Konfigurationsdaten des Slaves

Falls es sich um Fremdgeräte handelt oder in der IndexGroup angegeben ist, dass sich Beckhoff-Geräte genauso verhalten sollen wie Fremd-Geräte, werden die folgenden Informationen in der ADS-Read-Response zurückgeliefert:

Offset | Beschreibung
0 -1 | 1
2 - 7 | DP-Diagnosedaten Byte 0-5 (s. Slave-Diagnose)
8 - 251 | DP-Konfigurationsdaten (CfgData)


CX8031 - PROFIBUS Diagnose-Daten

BECKHOFF CX8031: Fehlerbehandlung und Diagose

PROFIBUS Diagnose-Daten

Die dezentrale CX8031 Steuerung ermöglicht Ihnen aus der PLC heraus Diagnose-Daten zu verschicken. So können Sie sich Ihre eigene Diagnose Mitteilung für den Master schreiben und diese Individuell mit Daten füllen (siehe Gerätespezifische Diagnosedaten).

DP-Diagnosedaten (DiagData)

Die DP-Diagnosedaten bestehen aus 6 Bytes DP-Standard-Diagnose und bis zu 238 Bytes gerätespezifischen Diagnosedaten.

Wenn sich die DP-Diagnosedaten ändern, meldet das der Slave dem Master, der die geänderten Diagnosedaten in der Regel daraufhin automatisch abholt. Die DP-Diagnosedaten sind also nicht in Echtzeit zu den DP-Prozessdaten, sondern immer erst einige Zyklen später in der Steuerung.

In TwinCAT werden die DP-Diagnosedaten per ADS von der DP-Master-Anschaltung (FC310x, CX1500-M310) ausgelesen (s. Kapitel Slave-Diagnose in der FC310x-Dokumentation).

DP-Standard-Diagnosedaten

Offset | Bedeutung
0x00.0 | StationNonExistent: Slave beim letzten Telegramm nicht geantwortet
0x00.1 | StationNotReady: Slave verarbeitet noch das Set_Prm bzw. Chk_Cfg-Telegramm
0x00.2 | CfgFault: Slave meldet einen Konfigurationsfehler
0x00.3 | ExtDiag: Extended DiagData sind vorhanden und gültig
0x00.4 | NotSupported: Slave unterstützt ein Feature nicht, das mit Set_Prm oder Global_Control gefordert wurde
0x00.5 | InvalidSlaveResponse: Slave antwortet nicht DP-konform
0x00.6 | PrmFault: Slave meldet einen Parametrierfehler
0x00.7 | MasterLock: Slave ist im Datenaustausch mit einem anderen Master
0x01.0 | PrmReq: Slave muß neu parametriert und konfiguriert werden
0x01.1 | StatDiag: Slave meldet statische Diagnose bzw. Applikation des DPV1-Slave noch nicht bereit für den Datenaustausch
0x01.2 | PROFIBUS-DP-Slave
0x01.3 | WdOn: DP-Watchdog ist eingeschaltet
0x01.4 | FreezeMode: DP-Slave ist im Freeze-Mode
0x01.5 | SyncMode: DP-Slave ist im Sync-Mode
0x01.6 | reserviert
0x01.7 | Deactivated: DP-Slave wurde deaktiviert
0x02.0 | reserviert
0x02.1 | reserviert
0x02.2 | reserviert
0x02.3 | reserviert
0x02.4 | reserviert
0x02.5 | reserviert
0x02.6 | reserviert
0x02.7 | ExtDiagOverflow: zu viele Extended DiagData vorhanden
0x03 | MasterAdd: Stationsadresse des Masters, der mit dem Slave Datenaustausch macht
0x04,0x05 | IdentNumber
ab 0x06 | gerätespezifische Diagnosedaten (Extended DiagData)

Gerätespezifische Diagnosedaten

Für das absetzen der Diagnose Daten wird der ADSWRITE Baustein verwendet. Die aktuelle DP-Diagnose, wie sie auf den Bus gesendet wird kann per ADSREAD gelesen werden. Achten Sie beim Lesen darauf, dass sie 6 Byte (die PROFIBUS Standard DP-Diagnose) mitberücksichtigen müssen, d.h. 6 Byte mehr auslesen, als Sie geschrieben haben. Die ADS Parameter sind mit dem Lesen identisch.

Eingangsparameter | Beschreibung
NETID | lokale NetId des Profibus Device
PORT Nummer | 0x1000+Slave Adresse
IDXGRP | 16#F481
IDXOFFS | 0
LEN | max. 244
SRCADDR | Pointer auf die Diagnose Daten

Note 		Übertragung des Diagnose-Telegramms
Ein Diagnose-Telegramm wird erst dann zur Steuerung übertragen, wenn sich die Diagnose-Daten geändert haben.

Note 		Übertragung von anwenderspezifischen Diagnose-Daten
Im Byte[0] der Daten muss eine 0x08 stehen. Byte[1..5] werden vom CX überschrieben. Ab Byte 6 können Ihre eigenen Diagnose-Daten stehen.
Achten Sie bei Ihren eigenen Diagnose Daten auf die Einhaltung der PROFIBUS-Norm für Anwenderspezifische Diagnose.


CX8031 - PROFIBUS DP-V1 Kommunikation

BECKHOFF CX8031: Fehlerbehandlung und Diagose

PROFIBUS DP-V1 Kommunikation

C1-Verbindung (MSAC-C1)

Die C1-Verbindung ist für den Master reserviert, die mit dem Slave zyklischen Datenaustausch durchführt (C1-Master). Um die C1-Verbindung bei einem Slave nutzen zu können, muss der Slave DPV1 unterstützen (in der GSD-Datei müssen dafür die Zeile "DPV1_Slave = 1" und das Schlüsselwort "C1_Max_Data_Len" mit einer entsprechenden Länge eingetragen sein). Weiterhin ist in der Regel die C1-Funktionalität durch Setzen des Bit 7 von PrmData-Byte 0 (s. Karteireiter PROFIBUS des Slaves) bei dem entsprechenden Slave zu aktivieren (bei Beckhoff-Geräten, die DPV1 unterstützen, passiert das automatisch).

MSAC-C1-Read ist auf ADS-Readind, MSAC-C1-Write auf ADS-Writeinc abgebildet:

PROFIBUS DPV1

Der DP-Slave unterstützt eine DPV1-MSAC_C1-Server-Verbindung, die zusammen mit der zyklischen Verbindung aufgebaut wird. Diese kann benutzt werden, um neben den zyklischen Daten noch größere Mengen azyklische Daten übertragen zu können. Ein vom Master empfangenes DPV1-Read-Telegramm wird als ADS-Read-Indication an die PLC gemeldet, ein vom Master empfangenes DPV1-Write-Telegramm wird als ADS-Write-Indication an die PLC gemeldet. Das PLC-Programm ist dann für die Read bzw. Write-Antwort verantwortlich, dazu sind die Funktionen ADS-Read-Response bzw. ADS-Write-Response aufzurufen.

Einstellung im System Manager

Um die DP-V1 Dienste in die SPS zu transportieren muss diese Funktion durch die Angabe des Ports aktiviert werden.

Port 0 deaktiviert, 802 PLC Laufzeitsystem 1, Task 1

MSAC-C1 Read

Eine DPV1-MSAC_C1-Read-Indication wird wie folgt auf eine ADS-Read-Indication abgebildet:

ADS-Read-Indication-Parameter | Bedeutung
Source-Net-ID (NETID) | Net-ID des Slaves (s. Karteireiter ADS des Devices)
Source-Port (PORT) | 0x1000+Slave Adresse
Invoke-ID (INVOKEID) | eindeutige Nummer, muß bei Response wieder auftauchen
IndexGroup (IDXGRP) | Slot-Number (DPV1-Parameter)
IndexOffset (IDXOFFS) | Index (DPV1-Parameter)
Length (LENGTH) | Länge der auszulesenden Daten

Eine ADS-Read-Response wird wie folgt auf eine DPV1-MSAC_C1-Read-Response abgebildet:

ADS-Read-Response-Parameter | Bedeutung
Destination-Net-ID (NETID) | Net-ID des Slaves (s. Karteireiter ADS des Devices)
Destination-Port (PORT) | 0x1000+Slave Adresse
Invoke-ID (INVOKEID) | eindeutige Nummer, wie bei Indication
Result (RESULT) | Result des Read: 0 = kein Fehler, sonst: Bit 0-15 = Standard-ADS-Fehlercodes, Bit 16-23 = Error_Code_1, Bit 24-31 = Error_Code_2, s. Beschreibung DPV1-Fehlercodes
Length (LENGTH) | Länge der gelesenen Daten
Data (DATAADDR) | gelesene Daten

MSAC-C1 Write

Eine DPV1-MSAC_C1-Write-Indication wird wie folgt auf eine ADS-Write-Indication abgebildet:

ADS-Write-Indication-Parameter | Bedeutung
Source-Net-ID (NETID) | Net-ID des Slaves (s. Karteireiter ADS des Devices)
Source-Port (PORT) | 0x1000+Slave Adresse
Invoke-ID (INVOKEID) | eindeutige Nummer, muß bei Response wieder auftauchen
IndexGroup (IDXGRP) | Slot-Number (DPV1-Parameter)
IndexOffset (IDXOFFS) | Index (DPV1-Parameter)
Length (LENGTH) | Länge der zu schreibenden Daten
Data (DATAADDR) | zu schreibende Daten

Eine ADS-Read-Response wird wie folgt auf eine DPV1-MSAC_C1-Read-Response abgebildet:

ADS-Read-Response-Parameter | Bedeutung
Destination-Net-ID (NETID) | Net-ID des Slaves (s. Karteireiter ADS des Devices)
Destination-Port (PORT) | 0x1000+Slave Adresse
Invoke-ID (INVOKEID) | eindeutige Nummer, wie bei Indication
Result (RESULT) | Result des Read: 0 = kein Fehler, sonst: Bit 0-15 = Standard-ADS-Fehlercode, Bit 16-23 = Error_Code_1, Bit 24-31 = Error_Code_2, s. Beschreibung DPV1-Fehlercodes
Length (LENGTH) | Länge der gelesenen Daten


BECKHOFF PROFIBUS - DPV1-Fehlercodes

BECKHOFF PROFIBUS: Diagnose und Fehlerbeschreibung

DPV1-Fehlercodes

Bei einem fehlerhaften DPV1-Zugriff antwortet der Slaves mit 4 Bytes Daten (alle nicht beschriebenen Werte sind nicht in der DPV1-Norm beschrieben und daher dem Handbuch des Slaves zu entnehmen).

Byte 0 | DPV1-Dienst
0xD1 | Data_Transport
0xD7 | Initiate
0xDE | Read
0xDF | Write
Byte 1 | Error_Decode
0x80 | DPV1
0xFE | FMS
0xFF | HART
Byte 2 |  | Error_Code_1
Error-Class (Bit 4-7) | Error-Code (Bit 0-3) |
0x0A | 0x00 | Application, Read Error
 | 0x01 | Application, Write Error
 | 0x02 | Application, Module Failure
 | 0x08 | Application, Version Conflict
 | 0x09 | Application, Feature Not Supported
0x0B | 0x00 | Access, Invalid Index
 | 0x01 | Access, Write Length Error
 | 0x02 | Access, Invalid Slot
 | 0x03 | Access, Type Conflict
 | 0x04 | Access, Invalid Area
 | 0x05 | Access, State Conflict
 | 0x06 | Access, Access Denied
 | 0x07 | Access, Invalid Range
 | 0x08 | Access, Invalid Parameter
 | 0x09 | Access, Invalid Type
0x0C | 0x00 | Resource, Read Constrain Conflict
 | 0x01 | Resource, Write Constrain Conflict
 | 0x02 | Resource, Busy
 | 0x03 | Resource, Unavailable


Ethernet

Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.

Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.

Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.

MAC-ID

Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.

Internet-Protokoll (IP)

Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.

Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.

Transmission Control Protocol (TCP)

Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.

User Datagram Protocol (UDP)

UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.

Auf TCP/IP und UDP/IP aufsetzende Protokolle

Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:

  • ADS
  • ModbusTCP

Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.

ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


CX8031 - Topologiebeispiel

BECKHOFF CX8031: Ethernet

Topologiebeispiel

Hinweis 		Systemauslastung beachten
Achten Sie bei der Verwendung von weiteren Ethernet-Protokollen wie ModbusTCP/UDP, WebServices auf die Systemauslastung Ihres CX8031. Eine hohe Auslastung kann unter umständen die Ethernet-Kommunikation stark verlangsamen.


ADS-Kommunikation

Das ADS-Protokoll (ADS: Automation Device Specification) ist eine Transportschicht innerhalb des TwinCAT Systems. Es ist für den Datenaustausch der verschiedenen Software-Module entwickelt worden, zum Beispiel für die Kommunikation zwischen der NC und der PLC. Mit diesem Protokoll haben Sie die Freiheit von jedem Punkt im TwinCAT mit anderen Tools kommunizieren zu können. Wird die Kommunikation zu anderen PCs oder Geräten benötigt, setzt das ADS-Protokoll auf TCP/IP auf. Somit ist es in einem vernetzten System möglich, alle Daten von einem beliebigen Punkt aus zu erreichen.

Das ADS-Protokoll wird auf das TCP/IP- oder UDP/IP-Protokoll aufgesetzt. Es ermöglicht dem Benutzer innerhalb des Beckhoff-Systems über nahezu beliebige Verbindungswege mit allen angeschlossenen Geräten zu kommunizieren und diese zu parametrieren. Außerhalb des Beckhoff-Systems stehen verschiedene Wege offen, um mit anderen Software-Tools Daten auszutauschen.

Software-Schnittstellen

ADS-OCX

Das ADS-OCX ist eine Active-X-Komponente und bietet eine Standardschnittstelle zum Beispiel zu Visual Basic, Delphi, u.s.w.

ADS-DLL

Sie können die ADS-DLL (DLL: Dynamic Link Library) in Ihr C-Programm einbinden.

OPC

Die OPC-Schnittstelle ist eine genormte Standardschnittstelle für die Kommunikation in der Automatisierungstechnik. Beckhoff bietet hierfür einen OPC-Server an.


ADS-Protokoll

Die ADS-Funktionen bieten die Möglichkeit, direkt vom PC auf Informationen des Buskopplers zuzugreifen. Dafür können ADS-Funktionsbausteine im TwinCAT PLC Control verwendet werden. Die Funktionsbausteine sind in der Bibliothek PLCSystem.lib enthalten. Genauso ist es möglich, die ADS-Funktionen von AdsOCX, ADSDLL oder OPC aufzurufen.

AMSNetID

Die AMSNetID beschreibt das anzusprechende Gerät. Diese wird aus der Mac-Adresse des ersten Ethernet Ports (X001) und ist beim CX80xx auf der Seite aufgedruckt. Es werden für die AMSNetID typischerweise die Bytes 3..6 plus ".1.1" verwendet.
Beispiel:
MAC-Adresse 00-01-05-01-02-03
AMSNetID 5.1.2.3.1.1

Port-Nummer

Die Portnummer unterscheidet im angeschlossenen Gerät Unterelemente.
Port 801: lokale Prozessdaten PLC Laufzeit 1

Index Group

Die Index Group unterscheidet innerhalb eines Ports verschiedene Daten.

Index Offset

Gibt den Offset an, ab welchem Byte gelesen oder geschrieben werden soll.

Len

Gibt die Länge der Daten in Byte an, die gelesen bzw. geschrieben werden sollen.

TCP-Port-Nummer

Die TCP-Port-Nummer beträgt für das ADS-Protokoll 48898 oder 0xBF02.


Systemübersicht PROFIBUS

PROFIBUS ist als schnelles, offenes Bussystem mit Linientopologie und Terminatoren in der Automatisierungstechnik weit verbreitet. International genormt nach IEC 61158, IEC 61784 und EN 50170 ist die Variante PROFIBUS DP (Dezentrale Peripherie) für den schnellen Datenaustausch auf der Sensor-/Aktor-Ebene geeignet.

Bei PROFIBUS DP kommunizieren zentrale Steuergeräte (wie z. B. Industrie-PCs oder PLCs) über eine schnelle serielle Verbindung mit dezentralen Ein- und Ausgabebaugruppen. RS485 ist die dabei am häufigsten genutzte Übertragungstechnik unter Verwendung einer geschirmten verdrillten Zweidrahtleitung. Der Datenaustausch erfolgt vorwiegend zyklisch, wobei azyklische Dienste (DP-V1) für Parametrierung und Diagnose zur Verfügung stehen.

PROFIBUS DP bietet recht kurze Systemreaktionszeiten: Bei einer 12-MBaud-Übertragungsrate werden weniger als 2 ms benötigt, um jeweils 512 Bit Eingangs- und Ausgangsdaten auf 32 Teilnehmer zu übertragen.

Alle Beckhoff-PROFIBUS-Geräte verfügen über eine leistungsfähige Protokollimplementierung und sind von der PROFIBUS Nutzerorganisation (PNO) zertifiziert.

PROFIBUS-Geräte

Embedded-PCs | CX8031 | Embedded-PC mit Feldbusschnittstelle PROFIBUS-Slave
 | CX50xx-M310 | Embedded-PC mit Optionsschnittstelle PROFIBUS-Master
 | CX50xx-B310 | Embedded-PC mit Optionsschnittstelle PROFIBUS-Slave
 | CX1500-M310 | PROFIBUS-Master-Anschaltung für Embedded-PCs CX1010, CX1020 und CX1030
 | CX1500-B310 | PROFIBUS-Slave-Anschaltung für Embedded-PCs CX1010, CX1020 und CX1030
EtherCAT-Klemmen | EL6731 | PROFIBUS-Master
 | EL6731-0010 | PROFIBUS-Slave
Buskoppler | EK3100 | PROFIBUS-Buskoppler für EtherCAT-Klemmen
 | BK3010 | PROFIBUS-Buskoppler für Busklemmen
 | BK3100 | PROFIBUS-DP/FMS-Buskoppler für Busklemmen
 | BK3110 | PROFIBUS-„Economy“-Buskoppler für Busklemmen
 | BK3120 | PROFIBUS-„Economy plus“-Buskoppler für Busklemmen
 | BK3150 | PROFIBUS-„Compact“-Buskoppler für Busklemmen
 | BK3500 | PROFIBUS-Buskoppler mit LWL-Anschluss für Busklemmen
 | BK3520 | PROFIBUS-„Economy plus“-Buskoppler mit LWL-Anschluss für Busklemmen
 | LC3100 | PROFIBUS-„Low Cost“-Buskoppler für Busklemmen
Bus Terminal Controller | BC3100 | PROFIBUS-Busklemmen-Controller
 | BC3150 | PROFIBUS-„Compact“-Busklemmen-Controller
 | BX3100 | PROFIBUS-Busklemmen-Controller
Feldbus Box | IPxxxx-B31x | PROFIBUS-Kompakt-Box
 | IL230x-B31x | PROFIBUS-Koppler-Box
 | IL230x-C31x | PROFIBUS-SPS-Box
Feldbusmodule | FM33xx-B310 | Feldbus-Module mit PROFIBUS-Interface
PC-Feldbuskarten | FC310x | PROFIBUS-PCI-Karte
 | FC312x | PROFIBUS-PCI-Express-Karte
 | FC3151 | PROFIBUS-Mini-PCI-Karte
Drive Technology | AX2xxx-B310 | Servo-Verstärker mit PROFIBUS-Slave


Feldbusübersicht

PROFIBUS ist ein herstellerunabhängiger, offener Feldbusstandard mit breitem Anwendungsbereich in der Fertigungs- und Prozessautomatisierung. Herstellerunabhängigkeit und Offenheit sind durch die internationalen Normen EN 50170 und EN 50254 garantiert. PROFIBUS ermöglicht die Kommunikation von Geräten verschiedener Hersteller ohne besondere Schnittstellenanpassungen. PROFIBUS ist sowohl für schnelle, zeitkritische Anwendungen , als auch für komplexe Kommunikationsaufgaben geeignet.

PROFIBUS bietet funktional abgestufte Kommunikationsprotokolle: DP und FMS. Als Übertragungstechniken stehen hierfür, je nach Anwendungsbereich, RS-485, IEC 1158-2 oder Lichtwellenleiter zur Verfügung.

PROFIBUS legt die technischen Merkmale eines seriellen Feldbussystems fest, mit dem verteilte digitale Automatisierungsgeräte von der Feldebene bis zur Zellenebene miteinander vernetzt werden können. PROFIBUS ist ein Multi-Master System und ermöglicht dadurch den gemeinsamen Betrieb von mehreren Automatisierungs-, Engineering- oder Visualisierungssystemen mit den dezentralen Peripheriegeräten an einem Bus.

PROFIBUS Gerätetypen

PROFIBUS unterscheidet folgende Gerätetypen:

Master-Geräte bestimmen den Datenverkehr auf dem Bus. Ein Master darf Nachrichten ohne externe Aufforderung aussenden, wenn er im Besitz der Buszugriffsberechtigung (Token) ist. Master werden auch als aktive Teilnehmer bezeichnet.

Slave-Geräte sind Peripheriegeräte wie beispielsweise Ein-/Ausgangsgeräte, Ventile, Antriebe, Messumformer und die Beckhoff PROFIBUS-Slaves der Reihe BK3xx0, BC3xx0, IPxxxx-B310, IL230x-B310 und IL230x-C310. Sie erhalten keine Buszugriffsberechtigung, d.h. sie dürfen nur empfangene Nachrichten quittieren oder auf Anfrage eines Masters Nachrichten an diesen übermitteln. Slaves werden als passive Teilnehmer bezeichnet. Sie benötigen nur einen geringen Anteil des Busprotokolls, dadurch wird eine aufwandsarme Implementierung ermöglicht.

PROFIBUS-DP

PROFIBUS-DP ist für den effizienten Datenaustausch in der Feldebene konzipiert. Hier kommunizieren die zentralen Automatisierungsgeräte, wie z.B. SPS/PC oder Prozessleitsysteme, über eine schnelle serielle Verbindung mit dezentralen Feldgeräten wie E/A, Antriebe, Ventile etc. Der Datenaustausch mit den dezentralen Geräten erfolgt vorwiegend zyklisch. Die dafür benötigten Kommunikationsfunktionen sind durch die DP-Grundfunktionen gemäß EN 50170 festgelegt.

Über diese Grundfunktionen hinaus bietet PROFIBUS-DP auch erweiterte azyklische Kommunikationsdienste für zum Beispiel Parametrierung und Bedienung welche auch durch die Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x-B310 und IL230x-C310 unterstützt werden. Eine zentrale Steuerung (Master) liest zyklisch die Eingangsinformationen von den Slaves und schreibt die Ausgangsinformationen zyklisch an die Slaves. Hierbei sollte die Buszykluszeit kürzer sein als die Programmzykluszeit des zentralen Automatisierungssystems, die in vielen Anwendungen etwa 10 ms beträgt.

Ein hoher Datendurchsatz alleine genügt nicht für den erfolgreichen Einsatz eines Bussystems. Vielmehr muss die einfache Handhabung, gute Diagnosemöglichkeiten und eine störsichere Übertragungstechnik gegeben sein, um die Anforderungen der Anwender zu erfüllen. Bei PROFIBUS-DP wurden diese Eigenschaften optimal kombiniert.

Systemkonfiguration und Gerätetypen

Mit PROFIBUS-DP können Mono- oder Multi-Master-Systeme realisiert werden. Dadurch wird ein hohes Maß ab Flexibilität bei der Systemkonfiguration ermöglicht. Es können maximal 126 Geräte (Master oder Slaves) an einem Bus angeschlossen werden. Mit den Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x- B310 und IL230x-C310 kann eine Stationsadresse zwischen 0 und 99 gewählt werden. Die Festlegungen zur Systemkonfiguration beinhalten die Anzahl der Stationen, die Zuordnung der Stationsadresse zu den E/A-Adressen, Datenkonsistenz der E/A-Daten, Format der Diagnosemeldungen und die verwendeten Busparameter. Jedes PROFIBUS-DP-System besteht aus unterschiedlichen Gerätetypen. Es werden drei Gerätetypen unterschieden:

Klasse | Beschreibung
DP-Master Klasse 1 (DPM1) z.B. Beckhoff FC310x: PROFIBUS-Masterkarte für PCs | Hierbei handelt es sich um eine zentrale Steuerung, die in einem festgelegten Nachrichtenzyklus zyklisch Informationen mit den dezentralen Stationen (Slaves) austauscht. Typische Geräte sind z.B. Speicherprogrammierbare Steuerungen (SPS) oder PC.
DP-Master Klasse 2 (DPM2) | Geräte dieses Typs sind Engineering-, Projektierungs- oder Bediengeräte. Sie werden bei der Inbetriebnahme und zur Wartung und Diagnose eingesetzt, um die angeschlossenen Geräte zu konfigurieren, Messwerte und Parameter auszuwerten sowie den Gerätezustand abzufragen.
DP-Slave z.B. Beckhoff IPxxxx-B310: Feldbus Box für PROFIBUS | Ein PROFIBUS-DP-Slave ist ein Peripheriegerät (E/A, Antriebe, Messumformer etc.), das Eingangsinformationen einliest und Ausgangsinformationen an die Peripherie abgibt. Es sind auch Geräte möglich, die nur Eingangs- oder nur Ausgangsinformationen bereitstellen. Die Menge der Eingangs- und Ausgangsinformationen ist geräteabhängig und darf max. 246 Byte Eingangs- und 246 Byte Ausgangsdaten betragen.
Mono-Master-Systeme

Bei Mono-Master-Systemen ist in der Betriebsphase des Bussystems nur ein Master am Bus aktiv. Die SPS-Steuerung ist die zentrale Steuerungskomponente. Die Slaves sind über das Übertragungsmedium dezentral an die SPS-Steuerung gekoppelt. Mit dieser Systemkonfiguration wird die kürzeste Buszykluszeit erreicht.

Multi-Master-Betrieb

Im Multi-Master-Betrieb befinden sich an einem Bus mehrere Master. Sie bilden entweder voneinander unabhängige Subsysteme, bestehend aus je einem DPM1 und den zugehörigen Slaves, oder zusätzliche Projektierungs- und Diagnosegeräte. Die Eingangs- und Ausgangsabbilder der Slaves können von allen DP-Mastern gelesen werden. Das Schreiben der Ausgänge ist nur für einen DP-Master (den bei der Projektierung zugeordneten DPM1) möglich. Multi-Master- Systeme erreichen eine mittlere Buszykluszeit. In zeitkritischen Anwendungen sollten Sie die Vergrößerung der Buszykluszeit durch Zuschalten eines Diagnosewerkzeugs beachten.

Gerätestammdatei (GSD)

Bei PROFIBUS-DP werden die Leistungsmerkmale der Geräte in Form eines Gerätedatenblattes und einer Gerätestammdatendatei von den Herstellern dokumentiert und den Anwendern zur Verfügung gestellt. Aufbau, Inhalt und Kodierung dieser Gerätestammdaten (GSD) sind standardisiert. Sie ermöglichen die komfortable Projektierung beliebiger PROFIBUS-DP-Slaves mit Projektierungsgeräten verschiedener Hersteller. Die PROFIBUS-Nutzer-Organisation (PNO) archiviert diese Informationen herstellerübergreifend und gibt auf Anfrage Auskünfte über die GSD aller Hersteller. Die GSD - Daten werden von einer PROFIBUS-Master - Konfigurationssoftware gelesen und entsprechende Einstellungen in den PROFIBUS-Master übertragen. Die Beschreibung entnehmen Sie bitte dem entsprechenden Softwarehandbuch des Masterherstellers.

Die Beckhoff GSD-Dateien sind über das Internet unter http://www.beckhoff.de erhältlich.

Diagnosefunktionen

Die umfangreichen Diagnosefunktionen von PROFIBUS-DP ermöglichen die schnelle Fehlerlokalisierung. Die Diagnose der Beckhoff Buskoppler ist in der Defaulteinstellung der Typdatei und der GSD-Datei nicht eingeschaltet. Die Diagnosemeldungen werden über den Bus übertragen und beim Master zusammengefasst.

Sie werden in drei Ebenen eingeteilt:

Diagnoseart | Beschreibung
Stationsbezogen | Meldungen zur allgemeinen Betriebsbereitschaft eines Teilnehmers wie z.B. Übertemperatur oder Unterspannung
Modulbezogen | Diese Meldungen zeigen an, dass innerhalb eines bestimmten E/A Teilbereichs (z.B. 8 Bit Ausgangs - Modul) eines Teilnehmers eine Diagnose ansteht
Kanalbezogen | Hier wird die Fehlerursache bezogen auf ein einzelnes Ein- / Ausgangs - Bit (Kanal) angegeben, wie z.B. Kurzschluss auf Ausgang 2

Die Beckhoff PROFIBUS-Slaves der Reihe IPxxxx-B310, IL230x-B310 und IL230x-C310 unterstützen die Diagnosefunktionen des PROFIBUS-DP. Die Auswertung der Diagnosedaten über die Steuerung hängt von der Unterstützung des PROFIBUS-Masters ab. Entnehmen Sie bitte den Gerätehandbüchern der Masteranschaltungen die Handhabung der Diagnose.

Sync- und Freeze-Mode

Zusätzlich zu dem Teilnehmer bezogenen Nutzdatenverkehr, der automatisch vom DPM1 abgewickelt wird, besteht für die DP-Master die Möglichkeit, Steuerkommandos an einen, eine Gruppe oder an alle DP-Slaves gleichzeitig zu senden. Diese Steuerkommandos werden als Multicast übertragen. Mit diesen Steuerkommandos können die Sync- und Freeze-Betriebsarten zur Synchronisation der DP-Slaves vorgegeben werden. Sie ermöglichen eine ereignisgesteuerte Synchronisation der DP-Slaves.

Die DP-Slaves beginnen den Sync-Mode, wenn sie vom zugeordneten DP-Master ein Sync-Steuerkommando empfangen. In diesem Betriebszustand werden bei allen adressierten DP-Slaves die Ausgänge auf den momentanen Zustand eingefroren. Bei den folgenden Nutzdatenübertragungen werden die Ausgangsdaten bei den DP-Slaves gespeichert, die Ausgangszustände bleiben jedoch unverändert. Erst beim Empfang des nächsten Sync-Steuerkommandos vom Master werden die gespeicherten Ausgangsdaten an die Ausgänge durchgeschaltet. Mit einem Unsync-Steuerkommando wird der Sync-Betrieb beendet.

Analog dazu bewirkt ein Freeze-Steuerkommando den Freeze-Mode der angesprochenen DP-Slaves. In dieser Betriebsart werden die Zustände der Eingänge auf den momentanen Wert eingefroren. Die Eingangsdaten werden erst dann wieder aktualisiert, wenn der DP-Master das nächste Freeze-Steuerkommando an die betroffenen Geräte gesendet hat. Mit Unfreeze wird der Freeze-Betrieb beendet.

Systemverhalten

Um eine weitgehende Geräteaustauschbarkeit zu erreichen, wurde bei PROFIBUS-DP auch das Systemverhalten standardisiert. Es wird im wesentlichen durch den Betriebszustand des DPM1 bestimmt. Dieser kann entweder lokal oder über den Bus vom Projektierungs-Gerät gesteuert werden.

Es werden folgende drei Hauptzustände unterschieden:

Betriebsart | Beschreibung
Stop | Es findet kein Datenverkehr zwischen dem DPM1 und den DP-Slaves statt. Der Buskoppler spricht die Busklemmen nur einmal nach dem Einschalten der Versorgungsspannung an (keine der E/A - LEDs leuchtet).
Clear | Der DPM1 liest die Eingangsinformationen der DP-Slaves, und hält die Ausgänge der DP-Slaves im sicheren Zustand (Abhängig von der Reaktion auf Feldbusfehler leuchtet die grüne E/A-LED und werden die Ausgänge gesetzt).
Operate | Der DPM1 befindet sich in der Datentransferphase. In einem zyklischen Datenverkehr werden die Eingänge von den DP - Slaves gelesen und die Ausgangsinformationen an die DP-Slaves übertragen (Die grüne E/A-LED leuchtet).

Der DPM1 sendet seinen lokalen Status in einem konfigurierbaren Zeitintervall mit einem Multicast-Kommando zyklisch an alle ihm zugeordneten DP-Slaves. Die Systemreaktion nach dem Auftreten eines Fehlers in der Datentransferphase des DPM1, wie z. B. Ausfall eines DP-Slaves, wird durch den Betriebsparameter Auto-Clear bestimmt. Wurde dieser Parameter auf True gesetzt, dann schaltet der DPM1die Ausgänge aller zugehörigen DP-Slaves in den sicheren Zustand, sobald ein DP-Slave nicht mehr bereit für die Nutzdatenübertragung ist. Danach wechselt der DPM1 in den Clear-Zustand. Ist dieser Parameter False, dann verbleibt der DPM1 auch im Fehlerfall im Operate-Zustand und der Anwender kann die Systemreaktion selbst bestimmen.

Datenverkehr zwischen DPM1 und den DP-Slaves

Der Datenverkehr zwischen dem DPM1 und den ihm zugeordneten DP-Slaves wird in einer festgelegten immer wiederkehrenden Reihenfolge automatisch durch den DPM1 abgewickelt. Bei der Projektierung des Bussystems legt der Anwender die Zugehörigkeit eines DP-Slaves zum DPM1 fest. Weiterhin wird definiert, welche DP-Slaves in den zyklischen Nutzdatenverkehr aufgenommen oder ausgenommen werden sollen.

Der Datenverkehr zwischen dem DPM1 und den DP-Slaves gliedert sich in die Phasen Parametrierung, Konfigurierung und Datentransfer.

Bevor ein DP-Slave in die Datentransferphase aufgenommen wird, prüft der DPM1 in der Parametrierungs- und Konfigurations-Phase, ob die projektierte Sollkonfiguration mit der tatsächlichen Gerätekonfiguration übereinstimmt. Bei dieser Überprüfung muss der Gerätetyp, die Format- und Längeninformationen sowie die Anzahl der Ein- und Ausgänge übereinstimmen. Der Benutzer erhält dadurch einen zuverlässigen Schutz gegen Parametrierungsfehler. Zusätzlich zum Nutzdatentransfer, der vom DPM1 automatisch durchgeführt wird, besteht die Möglichkeit neue Parametrierungsdaten auf Anforderung des Benutzers an die DP-Slaves zu senden.

Schutzmechanismen

Im Bereich der dezentralen Peripherie ist es aus Sicherheitsgründen erforderlich, die Systeme mit hochwirksamen Schutzfunktionen gegen Fehlparametrierung oder Ausfall der Übertragungseinrichtungen zu versehen. PROFIBUS-DP verwendet Überwachungsmechanismen beim DP-Master und bei den DP-Slaves. Sie werden als Zeitüberwachungen realisiert. Das Überwachungsintervall wird bei der Projektierung des DP-Systems festgelegt.

Schutzmechanismen | Beschreibung
Auf dem DP-Master | Der DPM1 überwacht den Nutzdatentransfer der Slaves mit dem Data_Control_Timer. Für jeden zugeordneten Slave wird ein eigener Überwachungszeitgeber benutzt. Die Zeitüberwachung spricht an, wenn innerhalb eines Überwachungsintervalls kein ordnungsgemäßer Nutzdatentransfer erfolgt. In diesem Fall wird der Benutzer informiert. Falls die automatische Fehlerreaktion (Auto_Clear =True) freigegeben wurde, verlässt der DPM1 den Zustand Operate, schaltet die Ausgänge der zugehörigen Slaves in den sicheren Zustand und geht in den Betriebszustand Clear über.
Auf dem DP-Slave | Der Slave führt zur Erkennung von Fehlern des Masters oder der Übertragungsstrecke die Ansprechüberwachung durch. Findet innerhalb des Ansprechüberwachungsintervalls kein Datenverkehr mit dem zugeordneten Master statt, dann schaltet der Slave die Ausgänge selbständig in den sicheren Zustand. Zusätzlich ist für die Ein- und Ausgänge der Slaves beim Betrieb in Multi - Master - Systemen ein Zugriffsschutz erforderlich damit sichergestellt ist, dass der direkte Zugriff nur vom berechtigten Master erfolgt. Für alle anderen Master stellen die Slaves ein Abbild der Eingänge und Ausgänge zur Verfügung, das von jedem beliebigen Master auch ohne Zugriffsberechtigung gelesen werden kann.

Ident-Nummer

Jeder DP-Slave und jeder DPM1 muss eine individuelle Ident-Nummer haben. Sie wird benötigt, damit ein DP-Master ohne signifikanten Protokoll-Overhead die Typen der angeschlossenen Geräte identifizieren kann. Der Master vergleicht die Ident-Nummer der angeschlossenen DP-Geräte mit den Ident-Nummern in den vom DPM2 vorgegebenen Projektierungsdaten. Der Nutzdatentransfer wird nur dann begonnen, wenn die richtigen Geräte-Typen mit den richtigen Stationsadressen am Bus angeschlossen wurden. Dadurch wird Sicherheit gegenüber Projektierungsfehlern garantiert. Die Vergabe der Herstellerspezifischen Ident-Nummern erfolgt durch die PROFIBUS Nutzerorganisation (PNO). Die PNO verwaltet die Ident-Nummern zusammen mit den Gerätestammdaten (GSD).


PROFIBUS DP

In PROFIBUS DP-Systemen kommuniziert in der Regel ein Master (SPS, PC, etc.) mit vielen Slaves (I/Os, Antriebe, etc.), wobei nur der Master aktiv auf den Bus zugreifen (unaufgefordert Telegramme senden), während ein DP-Slave nur Telegramme sendet, wenn er von einem Master dazu aufgefordert wurde.

DP-StartUp

Bevor Master und Slave zyklischen Datenaustausch miteinander durchführen, werden während des DP-StartUps die Parameter- und Konfigurationsdaten vom Master an die Slaves übertragen. Nach dem Senden der Parameter- und Konfigurationsdaten fragt der Master solange die Diagnosedaten des Slaves ab, bis der Slave seine Bereitschaft zum Datenaustausch signalisiert. Je nach Umfang der Berechnungen, die der Slave durch den Empfang von Parameter- und Konfigurationsdaten durchzuführen hat, bis er bereit zum Datenaustausch ist, kann das bis zu einigen Sekunden dauern. Der Slave besitzt daher die folgenden Zustände:

Parameterdaten

Die Parameterdaten werden mit dem SetPrmLock-Request-Telegramm von dem Master an die Slaves gesendet, das SetPrmLock-Response-Telegramm enthält keine Daten und besteht daher nur aus einem Byte, der Kurzquittung. Die Parameterdaten bestehen aus DP-Parametern (z.B. Einstellung des DP-Watchdogs, Überprüfung der IdentNumber (eindeutig für jedes DP-Gerät)), aus DPV1-/DPV2-Parametern und aus anwendungsspezifischen Parametern, die nur einmal während des StartUps übertragen werden müssen. Wenn ein Fehler in den Parameterdaten auftritt, wird das in den Diagnosedaten gekennzeichnet und der Slave bleibt bzw. geht in den Zustand WAIT-PRM.

Konfigurationsdaten

Die Konfiguratonsdaten werden mit dem ChkCfg-Request-Telegramm von dem Master an die Slaves gesendet, das ChkCfg-Response-Telegramm enthält keine Daten und besteht daher nur aus einem Byte, der Kurzquittung. Die Konfigurationsdaten beschreiben die Zuordnung der DP-Module zu den zyklischen I/O-Daten, die mit dem Data_Exchange-Telegramm während des zyklischen Datenaustauschs zwischen Master und Slave und ausgetauscht werden. Die Reihenfolge der im DP-Konfigurationstool an einen Slave angefügten DP-Module bestimmt die Reihenfolge der zugehörigen I/O-Daten im Data_Exchange-Telegramm.

Diagnosedaten

Die Diagnosedaten werden mit einem SlaveDiag-Request-Telegramm ohne Daten vom Master angefordert, der Slave sendet die Diagnosedaten mit einem SlaveDiag-Response-Telegramm. Die Diagnosedaten bestehen aus der Standard DP-Diagnose (z.B. Zustand des Slaves, IdentNumber) und anwendungsspezifischen Diagnosedaten.

Zyklischer Datenaustausch

Kernstück des PROFIBUS DP-Protokolls ist der zyklische Datenaustausch, bei dem innerhalb eines PROFIBUS DP-Zyklusses der Master mit jedem Slave einen I/O-Datenaustausch durchführt. Dabei sendet der Master an jeden Slave die Outputs mit einem DataExchange-Request-Telegramm, der Slave antwortet mit den Inputs in einem DataExchange-Response-Telegramm. Sämtliche Output- bzw. Inputdaten werden also mit je einem Telegramm übertragen, wobei die DP-Konfiguration (Reihenfolge der DP-Module) die Zuordnung der Output- bzw. Inputdaten zu den realen Prozessdaten des Slaves festlegt.

Diagnose während des zyklischen Datenaustausches

Während des zyklischen Datenaustausches kann eine Slave eine Diagnose an den Master melden. In dem Fall setzt der Slave ein Flag im DataExchange-Response-Telegramm, woran der Master erkennt, dass bei dem Slave neue Diagnosedaten vorliegen, die er dann mit dem SlaveDiag-Telegramm abholt. Die Diagnosedaten sind also nicht in Echtzeit mit den zyklischen I/O-Daten in der Steuerung, sondern mindestens immer einen DP-Zyklus später.

Synchronisierung mit Sync und Freeze

Mit den Sync- und Freeze-Kommandos im GlobalControl-Request-Telegramm (Broadcast-Telegramm) kann der Master die Ausgabe der Outputs (Sync) bzw. das Einlesen der Inputs (freeze) bei mehreren Slaves synchronisieren. Bei Verwendung des Sync-Kommandos werden die Slaves zunächst in den Sync-Mode geschaltet (wird in den Diagnosedaten quittiert), dann werden sequentiell die I/O-Daten per DataExchange-Telegramm mit den Slaves ausgetauscht, ein Senden des Sync-Kommandos im GlobalControl-Telegramm hat dann zur Folge, dass die Slaves die zuletzt empfangenen Outputs ausgeben. Im Freeze-Betrieb wird zunächst ein Freeze-Kommando im GlobalControl-Telegramm gesendet, woraufhin alle Slaves ihre Inputs latchen, die dann wiederum mit dem DataExchange-Telegramm vom Master sequentiell abgeholt werden.

Zustände im Master

Der Master unterscheidet die Zustände CLEAR (alle Outputs auf dem Fail_Safe-Wert) und OPERATE (alle Outputs haben den Prozesswert). In der Regel wird der Master in den CLEAR-Mode geschaltet, wenn z.B. die SPS auf STOP geht.

DP-Master Class 1 und Class 2

Mit dem Class 1-Master wird die Steuerung bezeichnet, die zyklischen I/O-Datenaustausch mit den Slaves durchführt, während ein Class 2-Master ein B&B-Gerät ist, dass in der Regel nur lesend auf die I/O-Daten des Slaves zugreift.


PROFIBUS DPV1

PROFIBUS DPV1 bezeichnet im wesentlichen die azyklischen Read- und Write-Telegramme, mit denen azyklisch auf Datensätze im Slave zugegriffen wird. Auch bei DPV1 wird zwischen Class 1 und einem Class 2 Master unterschieden. Die azyklische Class 1 (C1) bzw. Class 2 (C2) Verbindungen unterscheiden sich dadurch, dass die azyklische C1-Verbindung mit dem DP-StartUp des zyklischen DP-Betriebs aufgebaut wird (ab dem Zustand WAIT-CFG des Slaves können azyklische DPV1-C1-Read- und Write-Telegramme vom Master zum Slave gesendet werden, während die C2-Verbindung einen seperaten Verbindungsaufbau unabhängig von der zyklischen DP-Verbindung hat, der in der Regel von einem zweiten C2-Master durchgeführt wird, so dass z.B. ein herstellerspezifisches Projektierungs- und Diagnosetool auf die Daten des Slaves zugreifen kann.

Bei Verwendung von zwei Mastern ist allerdings immer zu beachten, dass diese sich den Buszugriff teilen (es wird ein Token ausgetauscht), so dass die zeitlichen Verhältnisse ungünstiger als bei einem Mono-Master-System sind.


PROFIBUS - Stecker, Kabel und Schalter

BECKHOFF Feldbuskomponenten: PROFIBUS

Stecker, Kabel und Schalter

Die Physik der Übertragung

Die physikalische Datenübertragung ist in der PROFIBUS-Norm definiert. Siehe PROFIBUS Schicht 1 (Physical Layer).

Der Einsatzbereich eines Feldbus - Systems wird wesentlich durch die Wahl des Übertragungs- Mediums und der physikalischen Busschnittstelle bestimmt. Neben den Anforderungen an die Übertragungssicherheit sind die Aufwendungen für Beschaffung und Installation des Buskabels von entscheidender Bedeutung. Die PROFIBUS-Norm sieht daher verschiedene Ausprägungen der Übertragungstechnik unter Beibehaltung eines einheitlichen Busprotokolls vor.

Kabelgebundene Übertragung: Diese Version, gemäß dem US-Standard EIA RS-485, wurde als Grundversion für Anwendungen im Bereich der Fertigungstechnik, Gebäudeleittechnik und Antriebstechnik festgelegt. Es wird ein verdrilltes Kupferkabel mit einem Leiterpaar verwendet. Die Abschirmung kann in Abhängigkeit des beabsichtigten Einsatzgebietes (EMV-Gesichtspunkte beachten) entfallen.

Kabelbedingte Störungen

Es stehen zwei Leitungstypen mit unterschiedlichen Höchstleitungslängen zur Verfügung, siehe Tabelle „RS485“. Die Belegung des Steckverbinders und die Verdrahtung ist unten im Bild dargestellt. Beachten Sie die besonderen Anforderungen an das Datenkabel bei Baud-Raten von mehr als 1,5 MBaud. Das richtige Kabel ist Grundvoraussetzung für den störungsfreien Betrieb des Bussystems. Bei der Verwendung eines einfachen 1,5 MBaud-Kabels kann es durch Reflexionen und zu großer Dämpfung zu erstaunlichen Phänomenen kommen. Das kann zum Beispiel sein: eine beliebige Station ist ohne Verbindung und durch Abziehen der benachbarten Station nimmt diese die Verbindung wieder auf. Oder es kommt zu Übertragungsfehlern, wenn ein bestimmtes Bitmuster übertragen wird. Das kann bedeuten, das der PROFIBUS ohne Funktion der Anlage störungsfrei arbeitet und nach dem Hochlauf zufällig Busfehler meldet. Die Reduzierung der Baud-Rate (< 93,75 kBaud) beseitigt das geschilderte Fehlerverhalten.

Führt die Verringerung der Baud-Rate nicht zur Beseitigung des Fehlers, liegt in häufigen Fällen ein Verdrahtungsfehler vor. Die beiden Datenleitungen sind an einem oder mehreren Steckern gedreht oder die Abschlusswiderstände sind nicht eingeschaltet oder an falschen Stellen aktiviert.

Hinweis 		Vorkonfektionierte Kabel von Beckhoff
Mit den vorkonfektionierten Kabeln von Beckhoff vereinfacht sich die Installation erheblich. Verdrahtungsfehler werden vermieden und die Inbetriebnahme führt schneller zum Erfolg. Das Programm umfasst Feldbuskabel, Stromversorgungskabel und Sensorkabel sowie Zubehör wie Abschlusswiderstände und T-Stücke. Ebenso sind jedoch auch Feldkonfektionierbare Stecker und Kabel erhältlich.

PROFIBUS-Anschluss der Feldbus Box Module
Die M12 Buchse ist invers Codiert und besitzt 5 Kontaktstifte. Stift 1 ist überträgt 5 VDC und Stift 3 GND für den aktiven Abschlusswiderstand. Diese dürfen auf keinen Fall für andere Funktionen missbraucht werden, da dies zu Zerstörung des Gerätes führen kann. Stift 2 und Stift 4 übertragen die Signale des PROFIBUS. Diese dürfen auf keinen Fall getauscht werden, da sonst die Kommunikation gestört ist. Stift 5 überträgt den Schirm der kapazitiv mit der Grundfläche der Feldbus Box verbunden ist.
Pinbelegung PROFIBUS-Buchse

Leitungsfarben PROFIBUS
PROFIBUS-Leitung | M12 | D-Sub
B rot | Stift 4 | Stift 3
A grün | Stift 2 | Stift 8
RS485 - Grundlegende Eigenschaften
RS-485 Übertragungstechnik nach PROFIBUS-Norm
Netzwerk Topologie | Linearer Bus, aktiver Busabschluss an beiden Enden, Stichleitungen sind möglich
Medium | Abgeschirmtes verdrilltes Kabel, Schirmung darf abhängig von den Umgebungsbedingungen (EMV) entfallen
Anzahl der Stationen | 32 Stationen in jedem Segment ohne Repeater. Mit Repeater erweiterbar bis 127 Stationen
Max. Bus Länge ohne Repeater | 100 m bei 12 MBit/s 200 m bei 1500 KBit/s, bis zu 1,2 km bei 93,75 KBit/s
Max. Bus Länge mit Repeater | Durch Leitungsverstärker (Repeater) kann die max. Buslänge bis in den 10 km Bereich vergrößert werden. Die Anzahl der möglichen Repeater ist mindestens 3 und kann je nach Hersteller bis zu 10 betragen
Übertragungsgeschwindigkeit | 9,6, 19,2, 93,75, 187,5,500, 1500 KBit/s, bis 12 MBit/s in Stufen einstellbar
Steckverbinder | 9-Pin D-Sub-Steckverbinder für IP20 M12 Rundsteckverbinder für IP65/67
Verkabelung für PROFIBUS-DP und PROFIBUS-FMS

Hinweis 		Abschlusswiderstände an den Leitungsenden
In Systemen mit mehr als zwei Stationen werden alle Teilnehmer parallel verdrahtet. An den Leitungsenden muss das Buskabel in jedem Fall mit Widerständen abgeschlossen werden, um Reflexionen und damit Übertragungsprobleme zu vermeiden.

Adressierung

Einstellung der Stationsadressen

Die Adresse bei PROFIBUS ist über die zwei Drehwahlschalter hinter der Klarsichtabdeckung einzustellen. Die Default Einstellung beträt 11. Es sind alle Adressen erlaubt, dabei darf jede Adresse im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand der Feldbus Box (Buskoppler) geändert. Dafür lösen Sie die Abdeckung (nur Feldbus Box), und verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünscht Position. Dabei ist zu beachten, dass die Schalter richtig einrasten. Die Adressänderung wird aktiv, sobald das Gerät eingeschaltet wird.
Adresse Feldbus Box

Der linke Schalter ist der Zehner Multiplikator und der rechte Schalter der Einer Multiplikator.

Adresse Buskoppler

Der untere Schalter S311 ist der Zehner Multiplikator und der obere Schalter S310 der Einer Multiplikator.


Topologie

  • Ein Bussegment darf aus maximal 32 Teilnehmern bestehen (einschließlich den Repeatern).
  • Die maximale Leitungslänge eines Segmentes ist abhängig von der verwendeten Übertragungsgeschwindigkeit und der Qualität der verwendeten Busleitung.
  • Zwischen zwei Teilnehmer dürfen maximal 9 Repeater installiert werden.
  • Stichleitungen sind zu vermeiden und ab 1,5 MBaud nicht zulässig.
  • Maximale Anzahl an Teilnehmern 127
  • Unterbrechung der Versorgungsspannung von Leitungsabschlüssen durch abschalten des Repeaters/Slave oder abziehen des Steckers ist nicht zulässig.

Abb. 1: RS485-Topologie mit 3 Segmenten und 2 Repeatern.


CX803x - LED-Anzeigen

BECKHOFF CX8030, CX8031: Fehlerbehandlung und Diagnose

LED-Anzeigen

Ethernet Schnittstelle X001

Schnittstelle X001 | Ethernet (CX8030, CX8031) | Bedeutung
LED grün | an | Link vorhanden
LED gelb | blinkt | Aktivität

LED Koppler CX8030

Beschriftung | Bedeutung | Farbe | Bedeutung
TC | Zeigt den Status des Kopplers an | rot | TwinCAT im "stopp" Modus
 |  | Grün | TwinCAT im "run" Modus
 |  | Blau (Wenn roter DIP-Schalter 1 auf on steht beim starten des Kopplers) | TwinCAT im "config" Modus
BF | Zeigt den Status des Profibus an | Grün an | PROFIBUS Fehlerfrei
 |  | Grün blinkt | PROFIBUS, mindestens ein Slave im Fehler
DIA | Zeigt Fehler des PROFIBUS an | rot leuchtet | kein PROFIBUS Konfiguriert

LED Koppler CX8031 und CX8030 als Slave konfiguriert

Beschriftung | Bedeutung | Farbe | Bedeutung
TC | Zeigt den Status des Kopplers an | rot | TwinCAT im "stopp" Modus
 |  | Grün | TwinCAT im "run" Modus
 |  | Blau (Wenn roter DIP Schalter 1 auf on steht beim starten des Kopplers) | TwinCAT im "config" Modus
BF | Zeigt den Status des PROFIBUS an | Grün an | PROFIBUS im Datenaustausch
 |  | Grün blinkt | PROFIBUS wartet auf Cfg Daten
DIA | Zeigt Fehler des PROFIBUS an | - | -

LED Netzteilklemme

Betrieb mit K-Bus Klemmen Betrieb mit E-Bus Klemmen

Anzeige LED | Beschreibung | Bedeutung
1 Us 24V (Links Oben, 1te Reihe) | Versorgung Spannung CX80xx | an -24 V angeschlossen
2 Up 24V (Rechts Oben, 1te Reihe) | Versorgung Spannung Powerkontakte | an -24 V angeschlossen
3 L/A (Links Mitte, 2te Reihe) | EtherCAT LED | blinkt grün EtherCAT Kommunikation aktiv an E-Bus angeschlossen / Kein Datenverkehr aus E-Bus nicht angeschlossen
4 K-BUS RUN (Rechts Mitte, 2te Reihe) | K-Bus LED RUN | leuchtet grün K-Bus läuft, alles in Ordnung
6 K-BUS ERR (Rechts Unten, 3te Reihe) | K-Bus LED ERR | leuchtet rot, Fehler des K-Bus siehe K-Bus Fehlercode

K-Bus Fehlercode

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken EMV-Probleme
  • Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
  • EMV-Maßnahmen ergreifen
  • Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
3 Impulse 0 K-Bus-Kommandofehler
  • Keine Busklemme gesteckt
  • Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
6 Impulse | 0 | Fehler bei der Initialisierung | Buskoppler tauschen
1 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus - und wieder einschalten)
8 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus- und wieder einschalten)
7 Impulse | 0 | Prozessdatenlängen stimmen nicht mit der Konfiguration überein | Überprüfen Sie die Busklemmen zu den konfigurierten Busklemmen
1..n | K-Bus-Reset fehlgeschlagen | Überprüfen Sie die Busklemmen


CX80xx - Erste Schritte

BECKHOFF CX80xx: Anhang

Erste Schritte

Folgende Komponenten sind für die First Steps notwendig

  • PC mit TwinCAT 2.11 R3
  • Ethernet Kabel
  • Stromversorgung (24 VDC), Verkabelungsmaterial
  • eine KL2xxx oder EL2xxx, digitale Ausgangsklemme, Endklemme

Hinweis 		Erforderliche TwinCAT-Version
Zur Programmierung der CX80xx Baureihe ist ein TwinCAT 2.11 R3 erforderlich. Ältere TwinCAT-Versionen sowie ein TwinCAT 3.x werden nicht unterstützt!

1. Schließen sie K-Bus oder E-Bus Klemmen an den Controller an.

2. Schließen Sie den CX80xx an Spannung an (siehe Spannungsversorgung).

3. Verbinden Sie Ethernet (CX80xx X001) mit Ihrem Netzwerk oder eine direkt Verbindung zu ihrem PC (achten sie darauf das bei einer peer_to_peer Verbindung die IP-Adressierung bei Ihrem PC auf DHCP steht).

4. Warten Sie einige Zeit, ca. 1..2 Minuten, entweder wird vom DHCP Server dem CX80xx eine IP Adresse zugewiesen (geht in der Regel relative schnell) oder wenn er keinen DHCP Server findet benutzt er eine lokale IP Adresse.

5. Schalten Sie TC auf dem PC in Config Mode (TwinCAT Icon blau) und starten Sie den System Manager

6. Im System Manager klicken Sie auf das PC Symbol (Choose Target System) oder >F8<

7. Es öffnet sich folgender Dialog und drücken Sie dann auf Search (Ethernet).

8. Wählen Sie Option 1 aus wenn Sie über DHCP Adressiert haben oder Option 2 bei DHCP oder lokaler IP Adresse. Drücken Sie dann auf "Broadcast Search".

Ihr Netzwerk wird nach Beckhoff Steuerungen durchsucht. Wird keine gefunden ist das DHCP der Steuerung noch nicht abgeschlossen oder auf Ihrem PC passen die Netzwerkeinstellungen nicht. Ein nicht angeschlossenes Netzwerkkabel kann natürlich auch die Ursache sein, das sollte aber nicht der Fall sein wenn Punkt 3 berücksichtigt worden ist.

9. Der Host Name wird per Default gebildet aus "CX-" und den letzten 4 Byte der Mac Adresse. Die MAC Adresse finden Sie auf der Seite des CX80xx. Die MAC-Adresse ist immer 6 Byte lang wobei die ersten 3 Byte die Herstellerkennzeichnung ist und bei Beckhoff Geräten immer 00 01 05 ist.

Ein "X" bei connected bedeutet das der CX bereits im System bekannt ist und verwendet werden kann. Um Ihn bekannt zu machen klicken sie in der Liste auf den CX mit dem Sie sich verbinden wollen und klicken Sie auf "Add Route". Es folgt eine Eingabe Maske "User name" und "Password". Per Default gibt es kein Passwort, einfach mit OK bestätigen. Danach sollte das "X" bei connected erscheinen.

10. Als nächstes sollte der CX jetzt in der Liste der Geräte erscheinen, wählen Sie Ihn an und bestätigen sie das mit OK.

11. Kontrollieren Sie ob die Verbindung da ist. Im System Manager rechts unten in der Ecke. Es muss blau oder grün sein und darf nicht gelb sein.

12. Ist die Einstellung grün schalten sie den CX in den Config Mode "Shift F4" oder blaues TC Icon im System Manger drücken. Der System Manager fragt Sie nun ob sie in den Config Mode schalten wollen, das bestätigen Sie mit OK.

13. Rechts unten müsste die Einstellung auf blau wechseln, auch die TC LED auf dem CX80xx muss jetzt blau leuchten.

14. Klicken Sie nun auf I/O Devices und dann auf Scan Devices...

15. Es kommt ein Hinweis das nicht alles automatisch erkannt wird.

16. Es wird in der Regel das CCAT Interface gefunden (CX8090) oder das entsprechende Feldbusinterface (andere CX80xx Geräte) und entweder ein K-Bus Interface oder ein EtherCAT Interface, das kommt jetzt darauf an welche Klemmen Sie am CX angeschlossen haben. Das CCAT Interface muss im System Manager File vorhanden sein und darf nicht gelöscht werden. Sollte bei scannen eine Fehlermeldung erscheinen kontrollieren Sie den Versionsstand ihrer TwinCAT Version und führen sie gegebenenfalls ein update durch.

17. Kommen wir jetzt zum Programmieren, öffnen Sie dazu das PLC Control, wählen Sie Datei neu. Das PLC Control fragt Sie nach dem Zielsystem. Wählen Sie CX (ARM) aus. Danach fragt er Sie nach dem Baustein, stellen Sie die Sprache ST ein (Strukturierter Text). Jetzt schreiben Sie ein kleines Programm...

Übersetzen Sie das Programm, ist es Fehlerfrei (es müsste eine Warning kommen, das ist soweit OK) speichern Sie das Projekt unter einem beliebigen Namen, übersetzen sie es erneut und speichern sie dann noch einmal.

18: Wechseln Sie wieder zum System Manager und fügen Sie das Programm unter PLC Configuration an. Es wird nach einem Dateiname.typ File gesucht.

19: Öffnen Sie nun das Projekt dann die Task und dann auf Outputs, dort muss es dann eine Variable MAIN.bToggle geben. Diese können Sie mit der Hardware verknüpfen. Klicken Sie dazu auf "Linked to...".

Wählen Sie einen digitalen Ausgang aus. Jetzt können sie die Konfiguration auf dem CX runterladen und den CX in den Run Mode schalten. Dafür klicken Sie auf den "Würfel" oder Control + Shift + F4. Die TC LED auf dem CX müsste dann grün leuchten.

20. Wechsel sie wieder in das PLC Control, gehen Sie auf "Online/Auswahl des Zielsystems", wählen Sie den richtigen CX aus, klicken Sie ihn auf und wählen Sie Laufzeitsystem1 aus. Jetzt wieder "Online/Einloggen" (F11) übertragen Sie das SPS Programm, danach "Online/Start" (F5). Jetzt müsste die LED auf ihrerer Klemme blinken.

21. Als letzten Schritt Online/Erzeugen eines Bootprojektes. Damit ist das Projekt abgeschlossen und ihr erstes Programm auf dem CX gespeichert.

Herzlichen Glückwunsch, die Grundlagen sind jetzt vorhanden und warten drauf ausgebaut zu werden. Viel Erfolg!


CX80xx - Image Update

BECKHOFF CX80xx: Anhang

Image Update

Es gibt zwei verschiedenen Möglichkeiten das Image des CX80xx zu aktualisieren.

Hinweis 		Voraussetzungen
  • Bitte stellen Sie vor dem Update sicher, dass Ihr CX80xx das Image unterstützt, das Sie aufspielen wollen.
  • Bitte löschen Sie beim Image-Update zuerst alle vorhandenen Dateien und kopieren Sie dann erst das neue Image.

Kopieren Sie immer alle Dateien und Verzeichnisse um einen CX80xx zu aktualisieren.

Update über USB

Hierfür ist ein USB-Kabel erforderlich!

  • CX80xx ausschalten
  • Roten DIP-Schalter (unter der Klappe) DIP 1 auf ON stellen
  • CX einschalten
  • PC mit USB verbinden
  • Löschen Sie alle Dateien (wir empfehlen erst alle Dateien zu sichern), keine Formatierung
  • Warten bis das kopieren zu Ende ist und entfernen Sie das USB Kabel
  • Schalten Sie den DIP-Schalter 1 auf OFF
  • CX80xx ausschalten
  • CX80xx einschalten, es kann möglich sein, dass das erste mal einschalten etwas länger dauert

Update der MicroSD-Karte

Hierfür ist ein MicroSD-Karten-Lesegerät erforderlich!

  • Entnehmen Sie die MicroSD-Karte aus dem ausgeschalteten CX Gerät.
  • Stecken Sie die MicroSD-Karte in das Lesegerät
  • Löschen Sie alle Dateien (wir empfehlen zuvor alle Dateien zu sichern), keine Formatierung
  • Aufspielen des neuen Images
  • Warten bis der Kopiervorgang abgeschlossen ist und entnehmen Sie die MicroSD-Karte
  • Stecken Sie die MicroSD-Karte wieder in den SD-Slot ihres ausgeschalteten CX
  • Jetzt schalten Sie den CX wieder ein, es kann möglich sein, dass das erste mal einschalten etwas länger dauert


Literaturverzeichnis

Deutsche Bücher

PROFIBUS

  • PROFIBUS-DP/DPV1
    Grundlagen, Tipps und Tricks für Anwender
    von Manfred Popp
    ISBN: 3778527819

Feldbustechnik allgemein

  • Gerhard Gruhler (Hrsg.): Feldbusse und Geräte-Kommunikationssysteme
    Praktisches Know-How mit Vergleichsmöglichkeiten
    Franzis Verlag 2001
    244 Seiten
    ISBN 3-7723-5745-8

Englische Bücher

(In Vorbereitung)

Standards PROFIBUS-DP

  • IEC 61158 und IEC 61784
  • DIN 19245, Teil 3
  • Euronorm EN 50 170

Web Seiten

  • http://www.profibus.de


Abkürzungsverzeichnis

DP

Dezentrale Peripherie. PROFIBUS-Protokoll für den schnellen zyklischen Datenaustausch.

FMS

Übertragungsprotokoll des PROFIBUS (Fieldbus Message Specification).

Freeze-Mode

Mit diesem Kommando friert der Salve seine Eingänge ein.

GSD-Datei

Deutsche Geräte-Stammdatei

GSE-Datei

Englische Geräte-Stammdatei

IP20, IP65, IP66, IP67

Schutzart (gegen Berührung, Wasser, Staub)

K-Bus

Klemmenbus: Interner Bus für die Kommunikation zwischen Buskoppler und Busklemmen

PNO

PROFIBUS-Nutzerorganisation (siehe www.profibus.de)

Repeater

Dienen der Signalaufbereitung und verbindet einzelne Bussegmente

SPS

Speicherprogrammierbare Steuerung (englisch PLC: programmable logic controller)

Sync-Mode

Mit diesem Kommando hält der Slave seine Ausgänge fest, bis er das Sync-Telegramm erhält.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


CX8031 - Einführung

Der CX8031 ist eine Steuerung mit einem Ethernet Anschluss über diese programmiert und/oder konfiguriert wird und einer PROFIBUS Schnittstelle auf Basis RS485 mit D-Sub-Anschluss. Physikalisch besitzt der CX8031 zwar nur eine D-Sub-Schnittstelle, diese kann aber so verwendet werden als ob 4 Teilnehmer am Bus wären. Das hat den Vorteil das mehr Daten ausgetauscht werden können, sowie der CX8031 als DP/DP Koppler mit einem zweiten PROFIBUS-Master kommunizieren kann.

Wahlweise können K-Bus- oder E-Bus-Klemmen angereiht werden; der CX8031 erkennt in der Hochlaufphase automatisch, welcher Klemmentyp angeschlossen ist. Programmiert wird die Steuerung mit TwinCAT über die Feldbusschnittstelle oder das zusätzliche Ethernet-Interface.

Die Grundausstattung des CX80xx enthält eine 512 MB MicroSD-Karte. Zwei Ethernet Schnittstellen sowie eine K-Bus bzw. E-Bus Schnittstelle gehören zur Basisausstattung.

Die kleinste zu verwendende Task-Zeit ist 1 ms (empfohlen wird eine Task-Zeit von 1 bis 50 ms für die I/O Daten, weitere Tasks können auch langsamer gestellt werden). Bei Verwendung kleinerer Zykluszeiten ist die gesamte Systemauslastung zu beachten. Ist die Zykluszeit zu klein gewählt können Web-Visualisierung und Remote-Desktop sehr langsam arbeiten oder TimeOuts verursachen. Der Anwender ist selbst dafür verantwortlich sein System so zu projektieren und zu konfigurieren, dass es nicht überlastet wird.


CX8031 - LED-Anzeigen

BECKHOFF CX8031: Fehlerbehandlung und Diagnose

LED-Anzeigen

Ethernet Schnittstelle X001

Schnittstelle X001 | Ethernet (CX8031) | Bedeutung
LED grün | an | Link vorhanden
LED gelb | blinkt | Aktivität

LED Koppler

Beschriftung | Bedeutung | Farbe | Bedeutung
TC | Zeigt den Status des Kopplers an | rot | TwinCAT im "stopp" Modus
 |  | Grün | TwinCAT im "run" Modus
 |  | Blau (Wenn roter DIP Schalter 1 auf on steht beim starten des Kopplers) | TwinCAT im "config" Modus
BF | Zeigt den Status des Profibus an | Grün an | PROFIBUS im Datenaustausch
 |  | Grün blinkt | PROFIBUS wartet auf Cfg Daten
DIA | Zeigt Fehler des Profibus an | - | -

LED Netzteilklemme

Betrieb mit K-Bus Klemmen Betrieb mit E-Bus Klemmen

Anzeige LED | Beschreibung | Bedeutung
1 Us 24V (Links Oben, 1te Reihe) | Versorgung Spannung CX80xx | an -24 V angeschlossen
2 Up 24V (Rechts Oben, 1te Reihe) | Versorgung Spannung Powerkontakte | an -24 V angeschlossen
3 L/A (Links Mitte, 2te Reihe) | EtherCAT LED | blinkt grün EtherCAT Kommunikation aktiv an E-Bus angeschlossen / Kein Datenverkehr aus E-Bus nicht angeschlossen
4 K-BUS RUN (Rechts Mitte, 2te Reihe) | K-Bus LED RUN | leuchtet grün K-Bus läuft, alles in Ordnung
6 K-BUS ERR (Rechts Unten, 3te Reihe) | K-Bus LED ERR | leuchtet rot, Fehler des K-Bus siehe K-Bus Fehlercode

K-Bus Fehlercode

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken EMV-Probleme
  • Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
  • EMV-Maßnahmen ergreifen
  • Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
3 Impulse 0 K-Bus-Kommandofehler
  • Keine Busklemme gesteckt
  • Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
6 Impulse | 0 | Fehler bei der Initialisierung | Buskoppler tauschen
1 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus - und wieder einschalten)
8 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus- und wieder einschalten)
7 Impulse | 0 | Prozessdatenlängen stimmen nicht mit der Konfiguration überein | Überprüfen Sie die Busklemmen zu den konfigurierten Busklemmen
1..n | K-Bus Reset fehlgeschlagen | Überprüfen Sie die Busklemmen


CX8031 - Technische Daten

BECKHOFF CX8031: Produktübersicht

Technische Daten

Technische Daten | CX8031
Prozessor | 32 Bit, 400 MHz, ARM9
Interner Arbeitsspeicher | 64 MB RAM (intern, nicht erweiterbar)
Betriebssystem | Microsoft Windows CE 6.0
Web-base Management | ja
Flash-Speicher | MicroSD-Karte (ATP) 512 MByte (optional 1, 2, 4 GB)
Schnittstellen | 1 x USB-Device (hinter der Frontklappe) 1 x RJ45 Ethernet, 10/100 MBit/s (ADS over TCP/IP) 1 x D-Sub RS485 PROFIBUS
Protokolle | PROFIBUS
Interface für I/O-Klemmen | K-Bus oder E-Bus, automatische Erkennung
Prozessdaten am K-Bus | max. 2 kByte Eingangsdaten max. 2 kByte Ausgangsdaten
Diagnose LED | 1 x Power, 1 x TC-Status, 2 x Bus-Status
Uhr | interne, batteriegepufferte Uhr (RTC) für Zeit und Datum (Batterie wechselbar)
Betriebssystem | Microsoft Windows CE
Steuerungssoftware | TwinCAT-PLC-Runtime (ab Version 2.11 R3)
Programmierung | TwinCAT PLC
Programmiersprachen | IEC 61131-3
Online Change | Ja
Up/Download-Code | Ja/Ja
Spannungsversorgung | 24 VDC (-15 %/+20 %)
USV | 1-Sekunden-USV
Stromversorgung für I/O-Klemmen | max. 2 A
Max. Verlustleistung | 3,0 W (einschließlich der Systemschnittstellen)
Spannungsfestigkeit | 500 V (Versorgung/interne Elektronik)
Abmessungen (B x H x T) | 64 mm x 100 mm x 73 mm
Gewicht | ca. 180 g
Zulässige Umgebungstemperatur im Betrieb | 0° C ... +55° C
Zulässige Umgebungstemperatur bei Lagerung | -25° C ... +85° C
Einbaulage | siehe Kapitel Einbaulagen
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP20
Systemdaten | PROFIBUS (CX8031)
Anzahl der E/A-Module | 100 mit Repeater
Anzahl der E/A-Punkte | ca. 6.000, masterabhängig
Übertragungsmedium | abgeschirmtes Kupferkabel 2 x 0,25 mm²
Leitungslänge | 1200 m | 1000 m | 400 m | 200 m | 100 m
Übertragungsrate | 9,6/19,2/93,75 kBaud | 187,5 kBaud | 500 kBaud | 1500 kBaud | 3, 6, 12 MBaud
Topologie | Linientopologie