CX8010 - Embedded-PC mit EtherCAT-Slave-Interface

BECKHOFF Feldbuskomponenten

Dokumentation zum

CX8010

Embedded-PC mit EtherCAT-Slave-Interface

Version: 1.1.0
Datum: 29.07.2015


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH & Co. KG.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


CX8010 - Ausgabestände der Dokumentation

BECKHOFF CX8010: Vorwort

Ausgabestände der Dokumentation

Version Kommentar
1.1.0
  • Vorwort aktualisiert
  • Kapitel 1-Sekunden-USV hinzugefügt
  • Kapitel Betriebssystem hinzugefügt
1.0.0
  • Erste Veröffentlichung

Image Version CX8010

Firmware Beschreibung
Build 2244
  • Freigabe (Programmierversion TwinCAT 2.11 Build 2245 oder höher)


CX80xx - Systemübersicht

CX80xx bezeichnet eine Gerätefamilie von programmierbaren Steuerungen mit ARM-basierter 32-Bit-CPU, die sowohl zur Abarbeitung von SPS-Programmen dienen, als auch die Funktion als Slave-Teilnehmer eines übergeordneten Feldbussystems erfüllen. Im Vergleich zu den nicht-programmierbaren EtherCAT-Kopplern der EK-Serie, die lediglich als Gateway zwischen dem entsprechenden Feldbussystem und den angeschlossenen EtherCAT-Klemmen fungieren, ist der CX80xx programmierbar und in der Lage, ein eigenes Steuerungsprogramm abzuarbeiten.

Die Geräte der Baureihe CX80xx stellen eine Weiterentwicklung der bekannten und bewährten 16-Bit-Microcontroller-basierten Busklemmen-Controllern der BC- und BX-Serien dar; hin zu leistungsfähigeren 32-Bit-Prozessoren. Wie bei den BC/BX ist auch beim CX80xx sichergestellt, dass bei Unterbrechung des übergeordneten Feldbussystems die Steuerung und das lokale Programm weiterhin abgearbeitet werden. Somit können die CX80xx-Geräte als dezentrale Steuerung verwendet werden. Wahlweise sind Busklemmen (K-Bus) oder EtherCAT-Klemmen (E-Bus) anschließbar; der CX80xx erkennt in der Hochlaufphase automatisch, welches Klemmensystem angeschlossen ist. Beim Einsatz von EtherCAT ergeben sich weitere Möglichkeiten, wie die Realisierung verschiedener Topologien, die Einbindung weiterer Bussysteme, wie CANopen, PROFIBUS und PROFINET, und – mit den EtherCAT-Box-Modulen – die Verbindung in die IP67-Welt.

Die Programmierung und Inbetriebnahme der CX80xx-Geräte erfolgt, wie bei allen CX-Produkten, über die Ethernet-Schnittstelle, die sich natürlich auch zur Verbindung der Steuerung mit einem regulären Netzwerk nutzen lässt. Teilweise verfügen die Embedded-PCs über weitere Ethernet-Schnittstellen mit Switch-Funktionalität, sodass eine linienförmige „Daisy-Chain“-Topologie kostensparend, ohne zusätzliche Hardware, aufgebaut werden kann. Die weiteren Anschlüsse auf der niedrigen Steckebene sind feldbusspezifisch. Unter der Klappe auf der oberen Gehäuseebene befinden sich eine tauschbare Knopfzellenbatterie für Datum und Uhrzeit, eine Reihe von DIP-Schaltern zur Einstellung von Funktionsmodi, ein Slot für MicroSD-Flash-Speicherkarten sowie ein USB-Anschluss Typ B. Die Geräte sind, dank geringer elektrischer Leistungsaufnahme, lüfterlos.

Als Betriebssystem kommt Microsoft Windows CE zum Einsatz. Da kein Bildschirmanschluss vorhanden ist, kann nur per Netzwerk auf das Betriebssystem und seinen „virtuellen“ Bildschirm zugegriffen werden. Wie bei allen anderen Beckhoff-Geräten erfolgen die Systemkonfiguration und die Programmierung der SPS-Funktionalität mittels der TwinCAT-Software. Auf dem CX80xx-Zielgerät befindet sich dazu eine vorinstallierte TwinCAT-SPS-Laufzeitumgebung. Sämtliche für den Betrieb des Gerätes benötigte Software, vom Betriebssystem über die TwinCAT-Dateien bis hin zu Anwenderdateien und -daten, wird auf der MicroSD-Flash-Karte gespeichert. Das vereinfacht den Tausch im Servicefall. Der Zugriff auf die Kartendaten kann auch über handelsübliche Kartenleser erfolgen. Die Größe der MicroSD-Flash-Karte (z. B. 512 MB) ist, je nach Anwendung und Umfang der zu speichernden Daten, wählbar.

Die CX80xx-Gerätefamilie verfügt über eine integrierte, kapazitive 1-Sekunden-USV, die bei Wegfall der Versorgungsspannung noch ausreichend Energie zur Verfügung stellt, um persistente Daten zu speichern. Damit ist der spannungsausfallsichere Erhalt wichtiger Daten ohne Batteriepufferung möglich.

Mit einem leistungsstarken und dennoch stromsparenden 32-Bit-ARM-Prozessor, EtherCAT als I/O-Bus sowie TwinCAT PLC mit umfangreichen SPS-Bibliotheken, stellen die Embedded-Controller der Serie CX80xx leistungsfähige Steuerungen mit Slave-Feldbusanschluss dar, die sehr flexibel einsetzbar sind.

Feldbus-Interface

Die Varianten der Serie CX80xx unterscheiden sich durch die unterschiedlichen Feldbusschnittstellen. Verschiedene Ausführungen decken die wichtigsten Feldbussysteme ab:

  • CX8010: EtherCATSlave
  • CX8030: PROFIBUS DP Master
  • CX8031: PROFIBUS DP Slave
  • CX8050: CAN Master
  • CX8051: CANopen Slave
  • CX8080: RS232/485
  • CX8090: Ethernet (RT-Ethernet, EAP, ModbusTCP, TCP/IP, UDP/IP, Web Services)
  • CX8091: BACnet IP/OPC UA
  • CX8093: PROFINET RT Device (Slave)
  • CX8095: Ethernet/IP Slave
  • CX8097: Sercos III Slave

Programmierung

Programmiert werden die CX80xx-Controller nach der leistungsfähigen IEC 61131-3 Norm. Wie auch bei allen anderen Beckhoff Steuerungen ist die Automatisierungssoftware TwinCAT Grundlage für die Parametrierung und Programmierung. Dem Anwender stehen also die gewohnten TwinCAT Werkzeuge, wie z. B. SPS-Programmieroberfläche, System Manager und TwinCAT Scope zur Verfügung.

Konfiguration

Die Konfiguration erfolgt ebenfalls mit TwinCAT. Über den System Manager können das Feldbusinterface und die Echtzeit-Uhr konfiguriert und parametriert werden. Alle angeschlossenen Geräte und Busklemmen können vom System Manager ausgelesen werden. Die Konfiguration wird nach der Parametrierung auf den CX gespeichert. Diese erstellte Konfiguration kann auch wieder ausgelesen werden.


CX8010 - Einführung

Der CX8010 ist eine Steuerung mit einem EtherCAT-Slave Interface. Wahlweise können K-Bus- oder E-Bus-Klemmen angereiht werden; der CX8010 erkennt in der Hochlaufphase automatisch, welcher Klemmentyp angeschlossen ist. Programmiert wird die Steuerung mit TwinCAT über das zusätzliche Ethernet-Interface.

Die Grundausstattung des CX80xx enthält eine 512 MB MicroSD-Karte. Zwei Ethernet Schnittstellen sowie eine K-Bus bzw. E-Bus Schnittstelle gehören zur Basisausstattung.

Die kleinste zu verwendende Task-Zeit ist 1 ms (empfohlen wird eine Task-Zeit von 1 bis 50 ms für die I/O Daten, weitere Tasks können auch langsamer gestellt werden).
Bei Verwendung kleinerer Zykluszeiten ist die gesamte Systemauslastung zu beachten. Ist die Zykluszeit zu klein gewählt, können Web-Visualisierung und Remote-Desktop sehr langsam arbeiten oder TimeOuts verursachen.
Der Anwender ist selbst dafür verantwortlich sein System so zu projektieren und zu konfigurieren, dass es nicht überlastet wird.


CX8010 - Technische Daten

BECKHOFF CX8010: Produktübersicht

Technische Daten

Technische Daten | CX8010
Prozessor | 32 Bit, 400 MHz, ARM9
Interner Arbeitsspeicher | 64 MB RAM (intern, nicht erweiterbar)
Betriebssystem | Microsoft Windows CE 6.0
Web-base Management | ja
Flash-Speicher | MicroSD-Karte (ATP) 512 MByte (optional 1, 2, 4 GB)
Schnittstellen | 1 x USB-Device (hinter der Frontklappe) 1 x RJ45 Ethernet, 10/100 MBit/s 2 x RJ45 switched, 100 MBit/s
Protokolle X001 (non RT-Ethernet Port) | ADS, ModbusTCP, TCP/IP, UDP/IP
Protokolle X101/X102 | EtherCAT Slave Interface max. 512 Byte Daten In und Out, max. 256 PDOs (Variablen)
Interface für I/O-Klemmen | K-Bus oder E-Bus, automatische Erkennung
Prozessdaten am K-Bus | max. 2 kByte Eingangsdaten max. 2 kByte Ausgangsdaten
Diagnose LED | 1 x Power, 1 x TC-Status, 2 x Bus-Status
Uhr | interne, batteriegepufferte Uhr (RTC) für Zeit und Datum (Batterie wechselbar)
Betriebssystem | Microsoft Windows CE
Konfigurationssoftware | TwinCAT-PLC-Runtime (ab Version 2.11 R3 ab Build 2240)
Programmierung | TwinCAT PLC
Programmiersprachen | IEC 61131-3
Online Change | Ja
Up/Download-Code | Ja/Ja
Spannungsversorgung | 24 VDC (-15 %/+20 %)
USV | 1-Sekunden-USV
Stromversorgung für I/O-Klemmen | max. 2 A
Max. Verlustleistung | 3,0 W (einschließlich der Systemschnittstellen)
Spannungsfestigkeit | 500 V (Versorgung/interne Elektronik)
Abmessungen (B x H x T) | 64 mm x100 mm x 73 mm
Gewicht | ca. 180 g
Zulässige Umgebungstemperatur im Betrieb | 0° C ... +55° C
Zulässige Umgebungstemperatur bei Lagerung | -25° C ... +85° C
Einbaulage | siehe Kapitel Einbaulagen
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP20
Systemdaten | Ethernet (CX8010)
Anzahl der E/A-Module | steuerungsabhängig
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | 4 x 2 Twisted-Pair-Kupferkabel, Kategorie 5 (100 MBaud), geschirmt
Leitungslänge | 100 m
Übertragungsrate | 100 MBaud
Topologie | sternförmige Verkabelung, Linientopologie


CX8010 - Technische Daten - EtherCAT

BECKHOFF CX8010: Produktübersicht

Technische Daten - EtherCAT

Systemdaten X001 | Ethernet (CX8010)
Übertragungsmedium | Kupferkabel, 4 x 2 Adern (Twisted-Pair), Kategorie 5 (100 MBaud)
Leitungslänge | 100 m vom Switch bis CX8010
Übertragungsrate | 10/100 MBaud
Topologie | sternförmige Verkabelung
Protokolle | alle nicht Echtzeitfähigen Protokolle die auf TCP oder UDP basieren und keine Echtzeiterweiterung benötigen
Systemdaten X101/102 | Ethernet (CX8010) EtherCAT Schnittstelle
Übertragungsmedium | 4 x 2 Twisted-Pair-Kupferkabel Kategorie 5 (100 MBaud)
max. Daten Länge INPUT | 512 Byte (256 PDOs - Variablen)
max. Daten Länge OUTPUT | 512 Byte (256 PDOs - Variablen)
Leitungslänge | 100 m
Übertragungsrate | 100 MBaud
Protokolle (Echtzeit) | EtherCAT
Protokolle (nicht Echtzeit) | -


CX80xx - MicroSD-Karten

In der Grundausstattung enthält der CX80xx eine MicroSD-Karte mit 512 MB. Sie können ihn als Option mit größeren Karten (bis 4 GB) bestellen.

Die verwendeten Karten sind SLC-Speicher mit erweiterten Temperaturbereich für Industrielle Anwendungen. Verwenden Sie ausschließlich von Beckhoff freigegebene MicroSD-Karten.

Beispiel für eine MicroSD-Karte:

Bestellbezeichnung | Kapazität | Beschreibung
CX1900-0123 | 1 GB | MicroSD-Karte (SLC-Speicher ) mit erweitertem Temperaturbereich für Industrielle Anwendungen anstelle der 512 MB Karte (Bestelloption)
CX1900-0125 | 2 GB
CX1900-0127 | 4 GB
CX1900-0122 | 512 MB | MicroSD-Karte (SLC-Speicher) mit erweitertem Temperaturbereich für Industrielle Anwendungen als Ersatzteil.
CX1900-0124 | 1 GB
CX1900-0126 | 2 GB
CX1900-0128 | 4 GB

Weitere Informationen: http://www.beckhoff.de/CX8000


CX80xx - Abmessungen

BECKHOFF CX80xx: Montage und Verdrahtung

Abmessungen

Die folgenden Zeichnungen zeigen die Abmessungen der Embedded-PCs CX80xx.

Abmessungen

Zeichnungen in verschiedenen CAD-Formaten finden Sie unter: http://www.beckhoff.de/german/download/cx1000.htm


CX80xx - Tragschienenmontage

BECKHOFF CX80xx: Montage und Verdrahtung

Tragschienenmontage

Aufrasten auf die Tragschiene

Der CX80xx kann einfach auf die Tragschiene aufgerastet werden. Dazu wird der Block einfach frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Die wird durch ein vernehmliches Klicken angezeigt. Mit einem Schraubendreher wird dann die Arretierung auf der linken Seite nach oben gedrückt wodurch sich die Arretierung dreht und ebenfall hörbar einrastet.

Achtung 		Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Zulässige Einbaulagen und Mindestabstände

Einbaulage bei bis zu 55°C

Achtung 		Zulässige Einbaulage und Mindestabstände einhalten!
Das auf eine Hutschiene montierte CPU-Modul darf nur bis Umgebungstemperaturen von 55°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die Bilder zeigen die erlaubte sowie die eingeschränkte Einbaulagen.

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX80xx Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU-Grundmoduls und des Netzteils zu erreichen.

Aufgrund der hohen Leistung und der kompakten Bauform des CX80xx-Systems kann es zu einer erhöhten Wärmeentwicklung kommen. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Daher muss das System waagerecht montiert werden. Auf diese Weise kommt ein optimaler Luftstrom zustande.

Einbaulagen mit eingeschränktem Temperaturbereich bis 45°C

Andere Einbaulagen sind erlaubt bei einem Temperaturbereich bis 45°C.


CX80xx - Spannungsversorgung

BECKHOFF CX80xx: Montage und Verdrahtung

Spannungsversorgung

WARNUNG 		Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie den CX80xx in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung beginnen!

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V.

Die Versorgungsspannung versorgt das CX System und über den Klemmbus und die Busklemmen mit einer Spannung von 24 VDC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 V. Da der Klemmbus (K- und E-Bus) nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen. An den Powerkontakten dürfen nur 24 V DC angeschlossen werden, die maximale Strombelastung der Powerkontakte beträgt 10 A.

Anforderungen an das Netzteil (24 V)

Um in allen Fällen den Betrieb der CPU (CX80xx-Modul) und des Klemmenstrangs zu gewährleisten muss das Netzteil 2,0 A bei 24 V liefern.

LED

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün auf. Die linke LED (Us) zeigt die Versorgung der CPU an. Die rechte LED (Up) zeigt die Versorgung der Klemmen an. Die weiteren LEDs beschreiben den Status des Klemmbusses. Die detaillierte Beschreibung der LEDs ist in dem Kapitel Fehleranalyse der LEDs beschrieben.

PE-Powerkontakt

VORSICHT 		Powerkontakt PE
Der Powerkontakt PE darf nicht für andere Potentiale verwendet werden.


CX80xx, EK9xxx - Ethernet-Anschlüsse

BECKHOFF CX80xx, EK9xxx: Ethernet

Ethernet-Anschlüsse

Belegung der RJ45-Schnittstelle, Port 1

X001

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8

Belegung der RJ45-Schnittstelle, Port 2 (switched)

CX8010, CX809x: X101 / 102
EK9xxx: X001 / X002

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | reserviert
5
6 | RD - | Receive -
7 | connected | reserviert
8


Ethernet-Kabel

Übertragungsstandards

10Base5

Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.

10Base2

10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.

10BaseT

Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.

100BaseT

Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.

10BaseF

Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.

Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT

Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.

UTP

Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.

S/UTP

Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.

FTP

Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.

S/FTP

Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70dB erreichen.

STP

Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.

S/STP

Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Ein solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.

ITP

Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


CX80xx - Wechseln der Batterie

BECKHOFF CX80xx: Montage und Verdrahtung

Wechseln der Batterie

Die Batterie des CX80xx ist für die Real Time Clock (RTC) des CX80xx erforderlich. Sie dient dafür, dass im ausgeschalteten Zustand die RTC weiterläuft und somit die eingestellte Zeit beim erneuten Aufstarten wieder zu Verfügung steht.

  • Schritt 1: Öffnen Sie die Klappe
  • Schritt 2/3: Nehmen Sie einen kleine Flachschraubendreher setzen Sie diesen oberhalb der Batterie an und hebeln sie diese vorsichtig aus dem Gerät
  • Schritt 4: Setzen Sie die neue Batterie ein, der Pluspol muss links liegen
  • Schritt 5: Schließen Sie die Klappe wieder
Batterietyp | Technische Daten
Duracell 303/357 SR44 | 1,5 V / 165 mAh

Hinweis 		Wartung der Batterie

Die Batterie muss alle 5 Jahre gewechselt werden.

Ersatzbatterien können beim Beckhoff Service bestellt werden.

Achtung 		Eine falsch eingesetzte Batterie kann explodieren!

Verwenden Sie ausschließlich den angegebenen Batterietyp.

Achten Sie unbedingt darauf, dass die Plus- und Minuspole der Batterie korrekt eingelegt wird. (Pluspol links)

Öffnen Sie die Batterie niemals und werfen Sie die Batterie niemals in ein Feuer.

Die Batterie kann nicht wieder aufgeladen werden.


CX8010 - DIP-Schalter

BECKHOFF CX8010: Parametrierung und Inbetriebnahme

DIP-Schalter

10-poliger DIP-Schalter S101

Der DIP-Schalter hat nur eine Bedeutung für die EtherCAT-Schnittstellen X101 und X102.

  • links: OFF "0"
  • rechts: ON "1".
DIP-Schalter S101 | Bedeutung
9 | Reserviert
10 | Reserviert
1..8 | Hot-Connect-Adresse (siehe EtherCAT-Slave-Interface)

2-poliger DIP-Schalter (unter der Klappe zwischen Batterie und SD Kartenslot)

DIP-Schalter (rot) | Bedeutung
1 OFF und 2 OFF | normaler Modus, TwinCAT wird gestartet
1 ON und 2 OFF | Der CX startet im Config-Mode, über die USB-Schnittstelle ist der interne Flash-Speicher, bzw. beim CX80xx die SC-Karte zu erreichen (zum Beispiel für ein Image-Update).
1 OFF und 2 ON | Restore der Registry
1 ON und 2 ON | reserviert


CX80xx - IP-Adresse

BECKHOFF CX8010, CX803x, CX805x, CX8080: Parametrierung und Inbetriebnahme

IP-Adresse

Der CX8010, CX803x, CX805x und CX8080 besitzen eine Ethernet Schnittstelle, X001.

X001

IP-Adressierung über das Betriebsystem, Default ist DHCP (im Betriebsystem als FEC1 dargestellt)

EtherCAT-Schnittstelle

Die EtherCAT-Schnittstelle ist eine weitere Ethernet-Schnittstelle, die für die IP-Adressierung im Betriebsystem nicht sichtbar ist.


CX8090 - Adresseinstellung über DHCP-Server

BECKHOFF CX8090: Parametrierung und Inbetriebnahme

Adresseinstellung über DHCP-Server

Port 1 (X001) ist per Default auf DHCP gestellt.

Port 2 (X101 und X102) sind per DIP-Schalter zu konfigurieren (siehe DIP Schalter)

Ist DHCP eingeschaltet bekommt der CX automatisch eine IP-Adresse vom DHCP-Server zugewiesen. Der DHCP-Server muss hierfür die MAC-ID des Busklemmen-Controller kennen. Die IP-Adresse sollte vom DHCP-Server statisch vergeben werden. Ist kein DHCP Server erreichbar wird eine lokale IP-Adresse verwendet.

Der DNS-Name wird aus dem Typ und den letzten 3 Byte der MAC-ID gebildet. Die MAC-ID steht auf dem Produktionsaufkleber des Busklemmen Controllers.

Beispiel CX8090
  • MAC ID: 00-01-05-01-02-03
  • DNS-Name: CX-010203


CX80xx - Subnetz-Maske

BECKHOFF CX80xx Parametrierung und Inbetriebnahme

Subnetz-Maske

Die Subnetz-Maske unterliegt der Kontrolle des Netzwerkverwalters und legt die Struktur der Subnetze fest.

Kleine Netze ohne Router benötigen keine Subnetz-Maske. Das gleiche gilt, wenn Sie keine registrierten IP-Nummern verwenden. Sie können die Subnetz-Maske dazu verwenden, anstelle des Gebrauchs vieler Netznummern das Netz mit dieser Maske zu unterteilen.

Die Subnetz-Maske ist eine 32-Bit Ziffer:

  • Einsen in der Maske kennzeichnen den Subnetz-Nummernteil eines Adressraums.
  • Nullen kennzeichnen den Teil des Adressraums, der für die Host-IDs zur Verfügung steht.
Beschreibung | Binäre Darstellung | Dezimale Darstellung
IP-Adresse | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnetz-Maske | 11111111.11111111.00010100.00000000 | 255.255.20.0
Netz-ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host-ID | 00000000.00000000.00000001.11001000 | 0.0.1.200

Standard Subnetz-Maske

Adressklasse | Standard Subnetz-Maske (dezimal) | Standard Subnetz-Maske (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00

Hinweis 		Vergabe von Subnetzen, Host-Nummern und IP-Adressen

Die Subnetze 0 und das nur aus nur Einsen bestehende Subnetz dürfen nicht verwendet werden!

Die Host-Nummer 0 und die aus nur Einsen bestehende Host-Nummer dürfen nicht verwendet werden!

Bei BootP und DHCP wird die Subnetz-Maske mit vom Server übertragen.


CX80xx - Betriebsystem

Auf dem CX80xx Geräte befindet sich ein Microsoft CE Betriebsystem der Version 6.0. Diese Betriebssystem ist für den Betrieb der CX80xx abgestimmt und optimiert. Es stehen nicht alle CE6.0-Komponenten zur Verfügung.

Sicherheit

Ab Image in Version 3.54b wurden die Sicherheitsvorkehrungen verschärft. Dieses betrifft das CERHOST und das TELNET. Beide Dienste sind nun im Auslieferungszustand abgeschaltet. Um diese Dienste wieder zu aktivieren benötigen Sie ein Lesegerät für MicroSD-Karten.

CERHOST

CERHOST wird von aktuellen Images beim ersten Start über die Registry-Datei CeRemoteDisplay_Disable.reg deaktivert, die sich im Ordner RegFiles befindet.

Um CERHOST wieder zu aktivieren, löschen Sie die Datei CeRemoteDisplay_Disable.reg aus dem Ordner RegFiles und ebenfalls den Ordner Documents and Settings.
Stecken Sie anschließend die MicroSD-Karte wieder in den CX und booten Sie neu. Der CX erzeugt ein neues Verzeichnis Document and Settings und bootet dann selbständig erneut.
Anschließend ist der CX wieder über CERHOST erreichbar.

TELNET

TELNET wird von aktuellen Images beim ersten Start über die Registry-Datei Telnet_Disable.reg deaktivert, die sich im Ordner RegFiles befindet.

Um TELNET wieder zu aktivieren, löschen Sie die Datei Telnet_Disable.reg aus dem Ordner RegFiles und ebenfalls den Ordner Documents and Settings.
Stecken Sie anschließend die MicroSD-Karte wieder in den CX und booten Sie neu. Der CX erzeugt ein neues Verzeichnis Document and Settings und bootet dann selbständig erneut.
Anschließend ist der CX wieder über TELNET erreichbar.

IMAGE

Falls sie nicht wissen welches Image auf dem CX80xx enthalten ist können sie dies einfach ermitteln.

  • Über die Web-Diagnose-Seite des CX. Hier finden Sie unter dem Gerät TwinCAT die Build-Nummer.
    Aufruf der Web-Diagnose-Seite:
    - IP-Adresse</config
    oder
    - CX-Name/config
    Bespiel:
    - 172.16.17.201/config
    oder
    - CX-01551E/config

  • Über ein Lesegerät für MicroSD-Karten.
    Auf der MicroSD-Karte befindet sich eine Datei mit dem Namen des Images.
    Beispiel CX8000_CE600_LF_v354b_TC211R3_B2248.
    Anhand TC211R3_2248 können Sie das verwendete TwinCAT-Build erkennen, hier in dem Beispiel das Build 2248.
Feature / Platform | CX80x0 LF Version 3.xx
ATL | Xtd
MFC | X
XML DOM | X
COM | X
COM Storage | -
Winsock | X
TCP/IP | X
TCP/IPv6 | -
Firewall | X
Network Utilities (IpConfig, Ping, Route) | X
UPnP |
Control Point | -
Device Host | X
SOAP |
Client | -
Server | -
DCOM | -
Object Exchange Protocol OBEX | -
Message Queuing MSMQ | -
Server |
File Server (SMB/CIFS) | X
File Server | X
Print-Server (SMB/CIFS) | -
RAS Server / PPTP Server | -
Simple Network Management Protocol (SNMP) | X
Telnet Server | X
HTTP / ASP / FTP / SNTP -Server | X
Web Server (HTTPD) / Active Server Pages (ASP) Support / JScript 5.6 / VBScript 5.6 | X
Simple Network Time Protocol (SNTP) | X
HTML / DHTML, SSL, ISAPI Erweiterungen | X
Internet Explorer 6.0 | -
Java Applets | -
NET Compact Framework | v3.5
RDP Client (Remote Desktop protocol) | -
CAB File Installer/Uninstaller | X
TwinCAT (Level PLC) | X
USB support | X
Printer, Storage auf z.B. Compact Flash | -
HID (Human interface devices) | -
Touch | -


CX80xx - E-Bus-Interface

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

E-Bus-Interface

Der Betrieb von E-Bus-Klemmen und EtherCAT Geräten ist am CX80xx möglich.

Der CX80xx erkennt diese Klemmen beim Scannen automatisch, ließt die Klemmentypen aus und legt sie im System-Manager automatisch an.

Hinweis 		DC Distributed-Clocks
Die CX80xx Baureihe eignet sich nicht für den Einsatz von EtherCAT Slaves, die die Distributed-Clocks Funktionalität verwenden oder auch brauchen.


CX80xx - K-Bus-Interface

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

K-Bus-Interface

Der Betrieb von K-Bus-Klemmen ist am CX80xx möglich.

Der CX80xx erkennt diese Klemmen beim Scannen automatisch, ließt die Klemmentypen aus und legt sie im System-Manager automatisch an.

Abb. K-Bus Interface

K-Bus State

Der K-Bus Status wird in dem State Byte (siehe Bild K-Bus Interface "1") abgelegt, ist der Wert 0 so arbeitet der K-Bus synchron und ohne Fehler. Sollte wer Wert <>0 sein kann das ein Fehler, aber auch nur ein Hinweis sein das zum Beispiel der K-Bus länger benötigt als die verwendete Task und ist damit nicht mehr Synchron zu der Task. Die Task-Zeit sollte schneller als 100 ms sein. Wir empfehlen eine Task-Zeit kleiner 50 ms. Typischerweise liegt die K-Bus-Update-Zeit zwischen einer und fünf ms.

Bit 0 = K-Bus Err
Bit 1 = Terminal State Err
Bit 2 = Process Data Length Err
Bit 8 = No valid Inputs
Bit 9 = K-Bus Input Update busy
Bit 10 = K-Bus Output Update busy
Bit 11 = Watchdog Err
Bit 15 = Acyc. Function atcive (e.g. K-Bus Reset)

Liegt ein K-Bus-Fehler vor, kann dieser über den Funktionsbaustein IOF_DeviceReset (in der TcIoFunctions.lib) zurückgesetzt werden.

Die NetID ist die des CX80xx und kann damit als empty String eingetragen werden, die Device-ID (siehe Bild K-Bus Interface "2") ist aus dem System-Manager zu nehmen.


CX8010 - Slave Interface

BECKHOFF CX8010: Parametrierung und Inbetriebnahme

EtherCAT Slave Interface

An die Schnittstellen X101 schließt man das ankommende EtherCAT Signal an. X102 geht an weitere EtherCAT Slave Geräte. Der 10-polige DIP-Schalter ist ausschließlich für den "Hot Swap" vorgesehen (Siehe Hot Swap). Über die EtherCAT Schnittstelle kann man maximal 512 Byte Ein- und Ausgangsdaten oder 256 Variablen anschließen.

Zum Beispiel 512 Byte einzeln anlegen, würde nicht gehen, da man dafür 512 Variablen bräuchte.

Prozessdaten

Wie legt man die Prozessdaten im TwinCAT an?

Sobald ein CX8010 gescannt wird, fügt der System Manager ein "EtherCAT Slave" Gerät an. Das Interface ist sehr einfach aufgebaut und besteht in der Regel nur aus "Inputs", "Outputs" und InfoData. Wenn man auf die Inputs klicken können Sie mit der rechten Maustaste Daten zum Interface dazufügen. Das System adressiert diese dann automatisch.

Das gleiche wird mit den Ausgängen gemacht. Verknüpfen Sie diese dann mit ihrem SPS Programm oder mit den K-Bus bzw. E-Bus Klemmen. Sollten Sie nur Verknüpfungen von Klemmen auf des EtherCAT Prozessabbild durchführen, achten sie darauf, das beide Geräte eine Task besitzen, die diese Antriggern und das diese Task auch automatisch gestartet wird.

InfoData: Hier ist die aktuelle AMSNet ID des Interfaces hinterlegt. Den State können Sie auswerten um den Zustand der EtherCAT Slave Schnittstelle zu ermitteln.

Prozessdaten mit Strukturen

Um sich viele Verknüpfungen zu ersparen macht es Sinn, Daten die sie austauschen wollen, in einer Datenstruktur abzulegen. Achten Sie hierbei aber darauf, das Datenstrukturen mit verschiedenen Variablen auf einem x86er System und auf einem ARM Prozessor unterschiedlich gehandhabt werden. Der ARM Prozessor legt Word (2 Byte) Variablen immer auf eine grade Adresse und bei 4 DWORD (4 Byte) Variablen auf eine durch 4 Teilbare Adresse.

Beispiel

Datenstruktur

byTest :BYTE;

udTest:UDINT;

Adresse ARM | Variable ARM | Adresse x86 | Variable ARM
Byte Offset 0 | Byte | Byte Offset 0 | BYTE
Byte Offset 4 | UDINT | Byte Offset 1 | UDINT
Summe: 8 Byte |  | Summe 5 Byte

Die Länge einer Datenstruktur können Sie auf beiden Systemen mit dem Befehl SIZEOF bestimmen. Gibt es hier einen Unterschied, ist dies schon mal ein Hinweis darauf, dass die Datenstruktur nicht passt.

Lösen kann man dieses Problem nur in dem Sie die Variablen geschickter anordnen oder mit Füll bzw. Dummy Variablen arbeiten.

Adresse ARM | Variable ARM | Adresse x86 | Variable ARM
Byte Offset 0 | Byte | Byte Offset 0 | BYTE
 |  | Byte Offset 1 | BYTE (Dummy1)
 |  | Byte Offset 2 | BYTE (Dummy2)
 |  | Byte Offset 3 | BYTE (Dummy3)
Byte Offset 4 | UDINT | Byte Offset 4 | UDINT
Summe: 8 Byte |  | Summe 8 Byte

Device-Status

Der Device-Status zeigt an ob das EtherCAT Slave Interface im OP-Modus ist und zeigt über das Toggel-Bit die Datenkommunikation an. Im Ausgangsbereich kann der EtherCAT-Status auch von der Slave-Seite beeinflusst werden.

TxPDO State "1" Node ist im OP-Modus; "0" Node ist nicht mehr im OP-Modus

TxPDO Toggle "1/0" Node ist im Datenaustausch

AIStatus Control

0x0000_0000 Normal-Betrieb (OP-Modus)
0x0001_0000 INIT-Betrieb
0x0002_0000 PREOP-Betrieb
0x0004_0000 SAFEOP-Betrieb
0x0008_0000 OP-Betrieb

Alle anderen Bits sind reserviert!

Hot Swap (Explicit Device Identification)

In Anwendungen, bei denen im laufenden Betrieb ein CX8010 gegen einen anderen CX8010 getauscht werden soll (mit unterschiedliche Applikationen auf den jeweiligen CX8010), können mit der Explicit Device Identification die einzelnen CX8010 voneinander unterschieden werden. Diese werden in eine Hot-Connect-Gruppe einsortiert.

Die Explicit Device Identification Nummer kann man über den DIP-Schalter oder per Software im System Manager einstellen. Wenn sie über den DIP-Schalter genutzt werden soll, muss sie einmalig im System Manager aktiviert werden. Der CX8010 ließt den Schalter dann beim Starten des Systems ein und arbeitet dann mit dessen Einstellung.

ADS Interface AMS NetId

Reserviert für Erweiterungen.

Advanced Settings

Reserviert für Erweiterungen.

Distributed Clocks

Wird aktuell nicht unterstützt.


CX80xx - Upnp-Web-Seiten

BECKHOFF CX80xx: Web Services

Upnp-Web-Seiten

Auf den CX80xx befindet sich zur Diagnose eine Upnp-Web-Seite.

Benutzername: guest
Passwort: 1

Geben Sie die IP-Adresse oder den Device Name an.

Beispiel

http://cx-0f94ac/config

http://172.16.17.55/config

Ab dem Image v354c wurde die Diagnoseseite überarbeitet.


CX80xx - Web-Visulisierung

BECKHOFF CX80xx: Web Services

Web-Visulisierung

Auf dem CX80xx befindet sich eine Web-Visualisierung. Diese kann mit Hilfe des PLC Controls in TwinCAT erstellt und aktiviert werden.

Abb. 1: Aktivierung der Web Visualisierung im PLC Control

Der Aufruf erfolgt über die IP-Adresse oder den Device Name an in einem Web Browser.
Weitere Informationen entnehmen Sie der Dokumentation zur Web Visualisierung (siehe TwinCAT Supplements PLC HMI Web).

Beispiel

http://cx-0f94ac/TcWebVisu/

http://172.16.17.44/TcWebVisu/

Achten Sie vor dem Einloggen (also im ausgeloggten Zustand) ob eine ADS Verbindung zum CX besteht, rechts unten in der Ecke muss das "TwinCAT Running" in grün stehen. Sollte das nicht der Fall sein bitte noch mal auf Online/Auswahl des Zielsystems gehen und den CX erneut aufrufen.

Beim download der Web Daten für die Web Oberfläche muss folgende Pfadangabe stehen:

\hard disk\twincat\boot\webvisu\

Sollte das nicht der Fall sein kopiert das PLC Control die Daten in den falschen Ordner und die Web-Seite wird nicht korrekt oder gar nicht angezeigt.

Abb. 2: Pfadangabe


CX80xx - Remote Display

BECKHOFF CX80xx: Web Services

Remote-Display

Diese Seite beschreibt die Schritte um ein CE-Gerät mit CE-Betriebssystem von einem weiteren PCaus per "Remote Display" fernzusteuern.

Voraussetzungen

Erforderliche Software auf dem PC:

  • Windows NT, Windows 2000, Windows XP oder Windows 7
  • Microsoft Remote Display (CERHOST, lizenzfrei bei Microsoft erhältlich)

Verbindungsaufbau

Auf dem PC wird das Tool "Remote Display" gestartet. Unter dem Menüpunkt "File -> Connect" kann nun die Adresse des CE-Gerätes eingetragen werden, dies kann sowohl die TCP-IP Adresse oder falls vorhanden auch der Name des CE-Gerätes sein.

Ist das CE-Gerät mit einem Passwortschutz versehen, so muss auch das Passwort entsprechend eingetragen werden. Im Auslieferungszustand ist kein Passwort gesetzt.

Nach Eintrag der Zieladresse steht die Oberfläche des CE-Gerätes zur Remote-Bedienung auf dem PC zur Verfügung.

Download CERHOST:


CX80xx - Real Time Clock (RTC)

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

Real Time Clock (RTC)

Die RTC wird über die Funktionsbausteine FB_LocalSystemTime ausgelesen und kann mit dem Baustein NT_SetLocalTime eingestellt werden (siehe TcUtilities.lib).

Die RTC wird über die Batterie versorgt und kann so im ausgeschalteten Zustand weiterlaufen.


CX80xx - 1-Sekunden-USV

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

1-Sekunden-USV (Unterbrechungsfreie Stromversorgung)

Technische Grundlagen

Die 1-Sekunden-USV ist ein UltraCap-Kondensator, der bei Ausfall der Spannungsversorgung den Prozessor für ca. 4 bis 5 Sekunden weiterhin mit Strom versorgt, um persistente Daten abzuspeichern. In der Regel braucht das Speichern der Daten weniger als 4 bis 5 Sekunden, da aber die verwendeten Bauteile altern, sollte von einer Sekunde ausgegangen werden, die die USV maximal hält. So können Sie davon ausgehen, das auch nach Jahren, das Abspeichern der Daten reibungslos funktioniert. Sollten Sie selbst Daten speichern, empfehlen wir, dass dies innerhalb von einer Sekunde geschieht. Sollte es länger dauern raten wir davon ab.

Die 1-Sekunden-USV versorgt weder den K-Bus noch den E-Bus weiter mit Spannung. Beachten Sie, das deren Daten bei Aktivierung der 1-Sekunden-USV bereits ungültig sein können. Auch kann das Feldbussystem (oder Ethernet) nicht oder nur unzureichend funktionieren sobald die 1-Sekunden-USV aktiv wurde.

Das Abspeichern der persistenten Daten erfolgt nur in Verbindung mit dem Funktionsbaustein FB_S_UPS_CX80xx. Dieser muss zyklisch aufgerufen werden. Hier empfehlen wir ausschließlich mit den Default-Werten des Bausteins zu arbeiten.

Arbeitsweise beim speichern und laden der persistenten Daten

Die persistenten Daten werden als wdp-Datei auf der SD-Karte gespeichert. Beim Starten der SPS wird die wdp-Datei von der SD-Karte geladen, dort als wd~-Datei gesichert (Backup) und dann gelöscht. Erst beim Runterfahren des Systems, bzw. dem ansprechen der 1-Sekunden-USV wird erneut eine aktuelle wdp-Datei geschrieben. Ist beim Starten des CX keine wdp-Datei vorhanden so sind die persistenten Daten ungültig und werden gelöscht (Default Einstellung).
Ursache hierfür ist, das beim Hochlauf des CX vor dem Starten der TwinCAT PLC die 1-Sekunden-USV aktiv wurde. Dann wurden keine persistenten Daten gesichert, da nicht sichergestellt war, ob die Pufferzeit noch reichte um die Daten abzuspeichern.

Das Backup der persistenten Daten laden

Um die persistenten Daten aus dem Backup (wp~-Datei) zu laden, muss dies im System Manager aktiviert werden.

Oder folgender Registry Eintrag:

[HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\Plc]"ClearInvalidPersistentData"= 0

Herstellereinstellung ist default "1".

Überprüfung ob aktuelle persistente Daten (aus wdp-Datei) oder gesicherte persistente Daten aus dem Backup (wd~-Datei) geladen wurden

Das Beispiel signalisiert beim CX8090 über die ERR-LED ob die persistenten Daten geladen worden sind. Bei andern CX8xxx kann die LED nicht genutzt werden.

IF systeminfo.bootDataFlags.4 AND NOT systeminfo.bootDataFlags.5 THEN
F_CX8090_LED_ERR(eLED_GREEN_ON); (* persistent data is OK *)
ELSIF systeminfo.bootDataFlags.4 AND systeminfo.bootDataFlags.5 THEN
F_CX8090_LED_ERR(eLED_RED_ON); (* load backup persistent data *)
ELSE
F_CX8090_LED_ERR(eLED_RED_FLASHING_200ms); (* no persistent data *)
END_IF

Hinweis 		Verwendungszweck der 1-Sekunden-USV
Die 1-Sekunden-USV ist nur für den Zweck der persistenten Datenhaltung zu verwenden.
Andere Anwendungsfälle werden nicht unterstützt und sind kein Reklamationsgrund.

Retain-Daten können für die 1-Sekunden-USV nicht verwendet werden!


CX80xx - CPU-Auslastung

BECKHOFF CX80xx: Parametrierung und Inbetriebnahme

CPU-Auslastung

Im Auslieferungszustand ist die CPU-Auslastungsanzeige bei allen CX80xx-Geräten deaktiviert (diese wird mit konstant 10% angezeigt). Die CPU-Auslastungsanzeige ist deaktiviert, da diese selbst einen erheblichen Anteil der CPU-Auslastung ausmacht. Man kann die CPU-Auslastung für eine kurzzeitige Diagnosehilfe aktivieren, wir empfehlen aber, diese nach der Diagnose wieder zu deaktivieren.

HKEY_LOCAL_MACHINE/SOFTWARE/BECKHOFF/TWINCAT/RTime/EnableRTimeMeasurement 0 deaktiviert, 1 aktiviert

Nach der Einstellung ist ein TwinCAT-Restart des CX80xx notwendig.

Hinweis 		CPU-Auslastung
Die CPU-Auslastung wird intern mit 10 ms gerechnet.
Werden eine oder mehrere Task über 10 ms verwendet, kann die Anzeige der CPU-Auslastung sehr stark schwanken.


Bibliothek für CX80xx

Download der Bibliothek


CX80xx - FUNCTION_BLOCK FB_S_UPS_CX80xx

BECKHOFF CX80xx: Programmierung

FUNCTION_BLOCK FB_S_UPS_CX80xx

Der Funktionsbaustein FB_S_UPS kann auf CX80xx mit der Sekunden-USV verwendet werden, um die Sekunden-USV aus der SPS anzusteuern. Hiermit können bei Spannungsausfall noch die Persistenten Daten gespeichert und ein QuickShutdown ausgeführt werden. Wenn möglich sollten die Defaultwerte der INPUTs des FB_S_UPS beibehalten werden.

Achtung 		Datenverlust
Die Sekunden-USV kann bei Spannungsausfall nur für wenige Sekunden verwendet werden, um z.B. Persistente Daten zu speichern. Das Speichern der Daten muss im schnellen Persistent Modus "SPDM_2PASS" erfolgen, auch wenn es hier zu Echtzeitverletzungen kommen kann. Zum Speichern der Persistenten Daten muss hinreichend Routerspeicher konfiguriert werden!

Für das Überbrücken von Spannungsausfällen hat die Sekunden-USV nicht genügend Kapazität. Das Speichern kann nur auf der micro SD Karte erfolgen.

Im Modus eSUPS_WrPersistData_Shutdown (Standardeinstellung) wird nach dem Speichern der persistenten Daten automatisch ein QuickShutdown ausgeführt.

Im Modus eSUPS_WrPersistData_NoShutdown werden nur die persistenten Daten gespeichert, es wird kein QuickShutdown ausgeführt.

Im Modus eSUPS_ImmediateShutdown wird sofort ein QuickShutdown ausgeführt, ohne das Speichern von Daten.

Im Modus eSUPS_CheckPowerStatus wird nur geprüft, ob ein Spannungsausfall auftrat. Ist dies der Fall, geht der Baustein erst nach Ablauf der tRecoverTime (10s) wieder in den Zustand PowerOK.

Unabhängig vom Modus und damit unabhängig vom Speichern oder Herunterfahren der Steuerung schaltet die USV nach Entladung der Kondensatoren das Mainboard ab, auch wenn die Spannung zwischenzeitlich wiederkehrt.

Achtung 		Achtung bei Verwendung von Dateien:
Falls andere Applikationen oder die SPS noch weitere Dateien offen halten oder in diese schreiben, kann es zu fehlerhaften Dateien kommen, wenn die USV die Steuerung abschaltet.

FUNCTION_BLOCK FB_S_UPS_CX80xx

VAR_INPUT

VAR_INPUT
    sNetID          : T_AmsNetId := '';               (* '' = local netid *)
    iPLCPort        : UINT := AMSPORT_R0_PLC_RTS1;    (* PLC Runtime System for writing persistent data *)
    iUPSPort        : UINT := 16#4A8;                 (* Port for reading Power State of UPS, dafault 16#4A8 *)
    tTimeout        : TIME := DEFAULT_ADS_TIMEOUT;    (* ADS Timeout *)
    eUpsMode        : E_S_UPS_Mode := eSUPS_WrPersistData_Shutdown; (* UPS mode (w/wo writing persistent data, w/wo shutdown) *)
    ePersistentMode : E_PersistentMode := SPDM_2PASS; (* mode for writing persistent data *)
    tRecoverTime    : TIME := T#10s;                  (* ON time to recover from short power failure in mode eSUPS_WrPersistData_NoShutdown/eSUPS_CheckPowerStatus *)
END_VAR

sNetID : AmsNetID der Steuerung.

iPLCPort : Portnummer des SPS-Laufzeitsystems (AMSPORT_R0_PLC_RTS1 = 801, AMSPORT_R0_PLC_RTS2 = 811, AMSPORT_R0_PLC_RTS3 = 821, AMSPORT_R0_PLC_RTS4 = 831).

iUPSPort : Portnummer über die der USV-Status gelesen wird (Standardwert ist 16#4A8).

tTimeout : Timeout für die Ausführung des QuickShutdowns.

eUpsMode : eUpsMode definiert, ob Persistente Daten geschrieben werden sollen und ob ein QuickShutdown ausgeführt werden soll.
Standardwert ist eSUPS_WrPersistData_Shutdown, d.h. mit Schreiben der Persistenten Daten und dann QuickShutdown. Siehe E_S_UPS_Mode.

ePersistentMode : Modus für das Schreiben der Persistenten Daten. Standardwert ist SPDM_2PASS.
SPDM_2PASS, es werden alle persistente Daten auf einmal weggeschrieben, das kann zu einer Zykluszeitüberschreitung führen.
SPDM_VAR_BOOST, hier wird jede persistente Variable einzeln geschrieben, Das kann bei vielen persistenten Daten entsprechend viele Zyklen dauern. Dies wird nicht empfohlen da es dazu führen kann das einige Daten verloren gehen, wenn die Zeit der Sekunden USV nicht ausreichend ist.

tRecoverTime : Zeit, nach der die USV bei UPS-Modi ohne Shutdown wieder in den PowerOK Status zurück geht.
Die tRecoverTime muss etwas größer sein, als die maximale Haltezeit der USV, da die USV auch bei wiederkehrender Spannung abschaltet.

VAR_OUTPUT

VAR_OUTPUT
    bPowerFailDetect	: BOOL;            (* TRUE while powerfailure is detected *)
    eState 		: E_S_UPS_State;   (* current ups state *)
END_VAR

bPowerFailDetect : True während des Spannungsausfalls; False, wenn die Versorgungsspannung anliegt .

eState : Interner Zustand des Funktionsbausteins, Werte siehe E_S_UPS_State.

VAR_GLOBAL

VAR_GLOBAL
    eGlobalSUpsState : E_S_UPS_State;    (* current ups state *)
END_VAR

eGlobalUpsState : Interner Zustand des Funktionsbausteins als globale Kopie des VAR_OUTPUT eState, Werte siehe E_S_UPS_State.

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | Sekunden USV | -


CX80xx - TYPE E_S_UPS_Mode

BECKHOFF CX80xx: Programmierung

TYPE E_S_UPS_Mode

eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten und dann QuickShutdown
eSUPS_WrPersistData_NoShutdown: Nur Schreiben der Persistenten Daten (kein QuickShutdown)
eSUPS_ImmediateShutdown: Nur QuickShutdown (kein Schreiben der Persistenten Daten)
eSUPS_CheckPowerStatus: Nur Status ermitteln (weder Schreiben der Persistenten Daten noch QuickShutdown)

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | Sekunden USV | -


CX80xx - TYPE E_S_UPS_State

BECKHOFF CX80xx: Programmierung

TYPE E_S_UPS_State

eSUPS_PowerOK:
    in allen Modi: Versorgungsspannung ist OK

eSUPS_PowerFailure:
    in allen Modi: Versorgungsspannung fehlerhaft (steht nur einen Zyklus an)

eSUPS_WritePersistentData:
    im Modus eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten ist aktiv
    im Modus eSUPS_WrPersistData_NoShutdown: Schreiben der Persistenten Daten ist aktiv

eSUPS_QuickShutdown:
    im Modus eSUPS_WrPersistData_Shutdown: QuickShutdown ist aktiv
    im Modus eSUPS_ImmediateShutdown: QuickShutdown ist aktiv

eSUPS_WaitForRecover:
    im Modus eSUPS_WrPersistData_NoShutdown: Warten auf Wiederkehr der Spannung
    im Modus eSUPS_CheckPowerStatus: Warten auf Wiederkehr der Spannung

eSUPS_WaitForPowerOFF:
    im Modus eSUPS_WrPersistData_Shutdown: Warten auf das Abschalten durch die USV
    im Modus eSUPS_ImmediateShutdown: Warten auf das Abschalten durch die USV

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | Sekunden USV | -


CX80xx - FUNCTION_CX80xx_ADDRESS

BECKHOFF CX80xx: Programmierung

FUNCTION F_CX80xx_ADDRESS

Mit der Funktion kann der Adresswählschalter oder der DIP Schalter des CX80xx Gerätes ausgelesen werden. Hier kann man zum Beispiel in Abhängigkeit der Adresse durch das Lesen der Schalterstellung verschiedene Programmteile aktivieren.

VAR_INPUT

VAR_INPUT
    iCX_Typ          : INT;
END_VAR

iCX_Typ : Hier wird der benutzte CX Typ eingetragen, nur die Nummer ohne die Bezeichnung CX: Beispiel, CX8031 dann wird 8031 eingetragen.

VAR_OUTPUT

F_CX80xx_ADDRESS		: INT;

F_CX80xx_ADDRESS : -1, nicht implementierter CX, Adresse des Schalters

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2220 oder höher (R3) | ARM | CX80xx | -


Ethernet

Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert.. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.

Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.

Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.

MAC-ID

Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.

Internet-Protokoll (IP)

Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.

Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z.B. IP, TCP, UDP, ARP und ICMP.

Transmission Control Protocol (TCP)

Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.

User Datagram Protocol (UDP)

UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.

Auf TCP/IP und UDP/IP aufsetzende Protokolle

Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:

  • ADS
  • ModbusTCP

Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.

ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


CX8010 - Topologiebeispiel

BECKHOFF CX8010: EtherCAT

Topologiebeispiel

CX8010


CX80xx - ModbusTCP - Übersicht

BECKHOFF CX80xx: ModbusTCP

ModbusTCP-Server - Übersicht

Auf dem CX80xx kann man mit Hilfe des ModbusTCP über ein sehr verbreitetes Protokoll Daten austauschen.
Verwenden Sie dazu die Dokumentation TwinCAT ModbusTCP Server. Der Server ist bereits auf dem CX80xx installiert. Es dürfen die Schnittstellen X001 oder X101/102 verwendet werden.

Deutsch: http://infosys.beckhoff.com/content/1031/tcmodbussrv/html/tcmodbussrv_overview.htm

Englisch: http://infosys.beckhoff.com/content/1033/tcmodbussrv/html/tcmodbussrv_overview.htm

Hinweis 		CX8091
Der Modbus/TCP Server ist nicht Bestandteil des Image des CX8091.

Hinweis 		Erforderliche Bibliotheken
Die entsprechenden Bibliotheken sind auf der MicroSD Karte im Verzeichnis TwinCAT\Lib und können mit einem SD Karten Reader auf das Programmiersystem kopiert werden.

Hinweis 		CX8010, CX803x, CX805x, CX8080, CX8093, CX8095
Das ModbusTCP kann nur mit der Schnittstelle X001 verwendet werden.


ModbusTCP-Protokoll

Das Ethernet-Protokoll wird über die MAC-ID adressiert. Der Anwender braucht sich meist um diese Adresse nicht zu kümmern. Die IP-Nummer ist 4 Byte groß und muss vom Anwender auf dem Buskoppler und in der Anwendung parametriert werden. Die TCP-Port ist bei ModbusTCP auf 502 festgelegt. Die UNIT ist bei ModbusTCP frei wählbar und braucht vom Anwender nicht konfiguriert werden.

TCP-Port-Nummer

Die TCP-Port-Nummer von ModbusTCP wurde auf den Wert 502 standardisiert.

Modbus-Unit

Die Unit wird vom Slave zurückgegeben.

ModbusTCP-Protokoll

Byte | Name | Beschreibung
0 | Transaction identifier | wird vom Slave zurückgesendet
1 | Transaction identifier | wird vom Slave zurückgesendet
2 | Protocol identifier | immer 0
3 | Protocol identifier | immer 0
4 | Length field | 0 (wenn die Nachricht kleiner 256 Byte ist)
5 | Length field | Anzahl der folgenden Bytes
6 | UNIT identtifier | wird vom Slave zurückgegeben
7 | Modbus | es folgt das Modbus-Protokoll beginnend mit der Funktion


Mapping

TwinCAT MODBUS TCP Server: Modbus Server-Funktionalität

Mapping zwischen Modbus und ADS

Das Standard-Mapping des Servers wird in der folgenden Tabelle für das erste Laufzeitsystem dargestellt:

Modbus-Bereiche | Modbus-Adresse | ADS-Bereich
digitale Eingänge (Inputs) | 0x0000 - 0x7FFF | Indexgruppe | Indexoffset
 |  | 0xF021 - Prozessabbild der physikalischen Eingänge (Bit-Zugriff) | 0x0
 | 0x8000 - 0x80FF | Name der Variablen im SPS-Programm | Datentyp
 |  | .mb_Input_Coils | ARRAY [0..255] OF BOOL
digitale Ausgänge (Coils) | 0x0000 - 0x7FFF | Indexgruppe | Indexoffset
 |  | 0xF031 - Prozessabbild der physikalischen Ausgänge (Bit-Zugriff) | 0x0
 | 0x8000 - 0x80FF | Name der Variablen im SPS-Programm | Datentyp
 |  | .mb_Output_Coils | ARRAY [0..255] OF BOOL
Eingangs-Register ( Input Registers) | 0x0000 - 0x7FFF | Indexgruppe | Indexoffset
 |  | 0xF020 - Prozessabbild der physikalischen Eingänge | 0x0
 | 0x8000 - 0x80FF | Name der Variablen im SPS-Programm | Datentyp
 |  | .mb_Input_Registers | ARRAY [0..255] OF WORD
Ausgangs-Register (Registers) | 0x0000 - 0x2FFF | Indexgruppe | Indexoffset
 |  | 0xF030 - Prozessabbild der physikalischen Ausgänge | 0x0
 | 0x3000 - 0x5FFF | 0x4020 - SPS-Memory-Bereich | 0x0
 | 0x6000 - 0x7FFF | 0x4040 - SPS-Daten-Bereich | 0x0
 | 0x8000 - 0x80FF | Name der Variablen im SPS-Programm | Datentyp
 |  | .mb_Output_Registers | ARRAY [0..255] OF WORD

Der Server mappt diese auf die einzelnen Ads-Bereiche und ermöglicht den Zugriff auf das physikalische Prozessabbild und die SPS-Merker Bereiche.

Das Anpassen der Einstellung ermöglicht der Konfigurator.

Default XML

Die Standartkonfiguration sieht wie folgt aus:

<Configuration>
    <!-- Modbus TCP port, default = 502-->
    <Port>502</Port>
    <!-- optional IP configuration for Modbus TCP server-->
    <IpAddr/>
    <Mapping>
        <InputCoils>
            <MappingInfo>
                <!-- AdsPort: TwinCAT2 PLC1 = 801, PLC2 = 811...-->
                <AdsPort>801</AdsPort>
                <StartAddress>0</StartAddress>
                <EndAddress>32767</EndAddress>
                <!-- IndexGroup 61473 = 0xF021 -> physical plc inputs %IX -->
                <IndexGroup>61473</IndexGroup>
                <!-- Bit offset-->
                <IndexOffset>0</IndexOffset>
            </MappingInfo>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <!-- Modbus input coils -->
                <StartAddress>32768</StartAddress>
                <EndAddress>33023</EndAddress>
                <VarName>.mb_Input_Coils</VarName>
            </MappingInfo>
        </InputCoils>
        <OutputCoils>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <EndAddress>32767</EndAddress>
                <!-- IndexGroup 61489 = 0xF031 -> physical plc outputs %QX -->
                <IndexGroup>61489</IndexGroup>
                <!-- Bit offset-->
                <IndexOffset>0</IndexOffset>
            </MappingInfo>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <!-- Modbus output coils-->
                <StartAddress>32768</StartAddress>
                <EndAddress>33023</EndAddress>
                <VarName>.mb_Output_Coils</VarName>
            </MappingInfo>
        </OutputCoils>
        <InputRegisters>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <StartAddress>0</StartAddress>
                <EndAddress>32767</EndAddress>
                <!-- IndexGroup 61472 = 0xF020 -> physical plc input register %I -->
                <IndexGroup>61472</IndexGroup>
                <!-- Byte offset-->
                <IndexOffset>0</IndexOffset>
            </MappingInfo>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <!-- Modbus input registers -->
                <StartAddress>32768</StartAddress>
                <EndAddress>33023</EndAddress>
                <VarName>.mb_Input_Registers</VarName>
            </MappingInfo>
        </InputRegisters>
        <OutputRegisters>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <StartAddress>0</StartAddress>
                <EndAddress>12287</EndAddress>
                <!-- IndexGroup 61488 = 0xF030 -> physical plc output register %Q -->
                <IndexGroup>61488</IndexGroup>
                <!-- Byte offset-->
                <IndexOffset>0</IndexOffset>
            </MappingInfo>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <StartAddress>12288</StartAddress>
                <EndAddress>24575</EndAddress>
                <!-- IndexGroup 16416 = 0x4020 -> plc memory area %M -->
                <IndexGroup>16416</IndexGroup>
                <!-- Byte offset-->
                <IndexOffset>0</IndexOffset>
            </MappingInfo>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <StartAddress>24576</StartAddress>
                <EndAddress>32767</EndAddress>
                <!-- IndexGroup 16448 = 0x4040 -> plc data area -->
                <IndexGroup>16448</IndexGroup>
                <!-- Byte offset-->
                <IndexOffset>0</IndexOffset>
            </MappingInfo>
            <MappingInfo>
                <AdsPort>801</AdsPort>
                <!-- Modbus output registers -->
                <StartAddress>32768</StartAddress>
                <EndAddress>33023</EndAddress>
                <VarName>.mb_Output_Registers</VarName>
            </MappingInfo>
        </OutputRegisters>
    </Mapping>
</Configuration>


CX80xx - TCP/IP-Server - Übersicht

BECKHOFF CX80xx: Ethernet

TCP/IP-Server - Übersicht

Über den CX80x0 können Sie mit Hilfe des TCP/IP-Servers auch eigene Protokolle implementieren. Verwenden Sie dazu die Dokumentation TwinCAT TCP/IP Server.
Der TCP/IP-Server ist bereits auf dem CX80x0 installiert. Es dürfen sie Schnittstellen X001 oder X101/102 verwendet werden.

Deutsch: http://infosys.beckhoff.com/content/1031/tcpipserver/html/tcpipserver_overview.htm

Englisch: http://infosys.beckhoff.com/content/1033/tcpipserver/html/tcpipserver_overview.htm

Hinweis 		CX8091
Der TCP/IP Server ist nicht Bestandteil des Image des CX8091.

Hinweis 		Nötige Bibliotheken
Die entsprechenden Bibliotheken sind auf der MicroSD Karte im Verzeichnis TwinCAT\Lib und können mit einem SD Karten Reader auf das Programmiersystem kopiert werden.

Hinweis 		CX8010, CX803x, CX805x, CX8080, CX8093, CX8095
Der TCP/IP Server kann nur mit der Schnittstelle X001 verwendet werden.


ADS-Kommunikation

Das ADS-Protokoll (ADS: Automation Device Specification) ist eine Transportschicht innerhalb des TwinCAT Systems. Es ist für den Datenaustausch der verschiedenen Software-Module entwickelt worden, zum Beispiel für die Kommunikation zwischen der NC und der PLC. Mit diesem Protokoll haben Sie die Freiheit von jedem Punkt im TwinCAT mit anderen Tools kommunizieren zu können. Wird die Kommunikation zu anderen PCs oder Geräten benötigt, setzt das ADS-Protokoll auf TCP/IP auf. Somit ist es in einem vernetzten System möglich, alle Daten von einem beliebigen Punkt aus zu erreichen.

Das ADS-Protokoll wird auf das TCP/IP- oder UDP/IP-Protokoll aufgesetzt. Es ermöglicht dem Benutzer innerhalb des Beckhoff-Systems über nahezu beliebige Verbindungswege mit allen angeschlossenen Geräten zu kommunizieren und diese zu parametrieren. Außerhalb des Beckhoff-Systems stehen verschiedene Wege offen, um mit anderen Software-Tools Daten auszutauschen.

Software-Schnittstellen

ADS-OCX

Das ADS-OCX ist eine Active-X-Komponente und bietet eine Standardschnittstelle zum Beispiel zu Visual Basic, Delphi, u.s.w.

ADS-DLL

Sie können die ADS-DLL (DLL: Dynamic Link Library) in Ihr C-Programm einbinden.

OPC

Die OPC-Schnittstelle ist eine genormte Standardschnittstelle für die Kommunikation in der Automatisierungstechnik. Beckhoff bietet hierfür einen OPC-Server an.


ADS-Protokoll

Die ADS-Funktionen bieten die Möglichkeit, direkt vom PC auf Informationen des Buskopplers zuzugreifen. Dafür können ADS-Funktionsbausteine im TwinCAT PLC Control verwendet werden. Die Funktionsbausteine sind in der Bibliothek PLCSystem.lib enthalten. Genauso ist es möglich, die ADS-Funktionen von AdsOCX, ADSDLL oder OPC aufzurufen.

AMSNetID

Die AMSNetID beschreibt das anzusprechende Gerät. Diese wird aus der Mac-Adresse des ersten Ethernet Ports (X001) und ist beim CX80xx auf der Seite aufgedruckt. Es werden für die AMSNetID typischerweise die Bytes 3..6 plus ".1.1" verwendet.
Beispiel:
MAC-Adresse 00-01-05-01-02-03
AMSNetID 5.1.2.3.1.1

Port-Nummer

Die Portnummer unterscheidet im angeschlossenen Gerät Unterelemente.
Port 801: lokale Prozessdaten PLC Laufzeit 1

Index Group

Die Index Group unterscheidet innerhalb eines Ports verschiedene Daten.

Index Offset

Gibt den Offset an, ab welchem Byte gelesen oder geschrieben werden soll.

Len

Gibt die Länge der Daten in Byte an, die gelesen bzw. geschrieben werden sollen.

TCP-Port-Nummer

Die TCP-Port-Nummer beträgt für das ADS-Protokoll 48898 oder 0xBF02.


Grenzen bisheriger Ethernet-Kommunikationsansätze

Es gibt viele verschiedene Ansätze, mit denen Ethernet echtzeitfähig gemacht werden soll: so wird z.B. das Zugriffsverfahren CSMA/CD durch überlagerte Protokollschichten außer Kraft gesetzt und durch ein Zeitscheibenverfahren oder durch Polling ersetzt; andere Vorschläge sehen spezielle Switches vor, die Ethernet Pakete zeitlich präzise kontrolliert verteilen. Diese Lösungen mögen Datenpakete mehr oder weniger schnell und exakt zu den angeschlossenen Ethernet Knoten transportieren – die Zeiten, die für die Weiterleitung zu den Ausgängen oder Antriebsreglern und für das Einlesen der Eingangsdaten benötigt werden, sind jedoch stark implementierungsabhängig. Speziell bei modularen E/A-Systemen kommt hier in der Regel noch ein Sub-Bus hinzu, der wie der Beckhoff K-Bus zwar synchronisiert und schnell sein kann, jedoch prinzipbedingt stets kleine Verzögerungen zur Kommunikation hinzufügt.

Wenn für jeden Teilnehmer individuelle Ethernet Frames Verwendung finden, so ist zudem die Nutzdatenrate prinzipiell sehr gering: Das kürzeste Ethernet Frame ist 84 Bytes lang (incl. Inter Packet Gap IPG). Wenn z.B. ein Antrieb zyklisch 4 Bytes Istwert und Status sendet und entsprechend 4 Bytes Sollwert und Kontrollwort empfängt, so wird bei 100% Buslast (also unendlich kurzer Antwortzeit des Antriebs) nur eine Nutzdatenrate von 4/84= 4,7% erreicht. Bei durchschnittlich 10 µs Antwortzeit sinkt die Rate schon auf 1,9%. Diese Limitierungen gelten für alle Echtzeit-Ethernet Ansätze, die an jeden Teilnehmer ein Ethernet Frame senden bzw. erwarten – und zwar unabhängig von den verwendeten Protokollen innerhalb des Ethernet Frames.


Neuer Lösungsansatz

Mit der EtherCAT-Technologie werden diese prinzipiellen Begrenzungen anderer Ethernet-Lösungen überwunden: das Ethernet Paket wird nicht mehr in jeder Anschaltung zunächst empfangen, dann interpretiert und die Prozessdaten weiterkopiert. Die neu entwickelten FMMU (Fieldbus Memory Management Unit) in jeder E/A-Klemme entnimmt die für sie bestimmten Daten, während das Telegramm das Gerät durchläuft. Ebenso werden Eingangsdaten im Durchlauf in das Telegramm eingefügt. Die Telegramme werden dabei nur wenige Nanosekunden verzögert.

Bild 1: Telegrammbearbeitung im Durchlauf

Da ein Ethernet-Frame sowohl in Sende- als auch in Empfangsrichtung die Daten vieler Teilnehmer erreicht, steigt die Nutzdatenrate auf ca. 80% an. Dabei werden die Voll-Duplex Eigenschaften von 100BaseTx vollständig ausgenutzt, so dass effektive Datenraten von über 100 Mbit/s (bis zu 80% von 2 x 100 Mbit/s) erreichbar sind.

Ethernet bis in die Klemme

Das Ethernet-Protokoll gemäß IEEE 802.3 bleibt bis in die einzelne Klemme erhalten, der Sub-Bus entfällt. Lediglich die Übertragungsphysik wird im Koppler von Twisted Pair bzw. Lichtleiterphysik auf E-Bus gewandelt, um den Anforderungen der elektronischen Reihenklemme gerecht zu werden.

Bild 2: Voll-Duplex Ethernet im Ring, ein Frame für viele Teilnehmer. Die EtherCAT System-Architektur steigert den Kommunikations-Wirkungsgrad.

Die FMMU-Technologie kann steuerungsseitig durch den TwinCAT Y-Treiber für Ethernet ergänzt werden. Dieser bindet sich transparent in das System ein, so dass er als betriebssystemkonformer Netzwerktreiber und zusätzlich als TwinCAT-Feldbuskarte erscheint. Auf der Sendeseite wird über interne Priorisierung und Puffer sichergestellt, dass Ethernet-Frames aus dem Echtzeitsystem immer dann eine freie Sendeleitung vorfinden, wenn sie an der Reihe sind. Die Ethernet-Frames des Betriebssystems werden erst danach in den Lücken verschickt, wenn entsprechend Zeit ist.

Auf der Empfangsseite werden alle empfangenen Ethernet-Frames vom TwinCAT I/O-System überprüft und die echtzeitrelevanten herausgefiltert. Alle anderen Frames werden nach der Überprüfung außerhalb des Echtzeitkontextes an das Betriebssystem übergeben.

Bild 3: betriebssystemkonformer TwinCAT Y-Treiber:

Als Hardware in der Steuerung kommen sehr preiswerte handelsübliche Standard Netzwerk-Interface-Karten (NIC) zum Einsatz. Der Datentransfer zum PC erfolgt per DMA (Direct Memory Access); es wird also keine CPU-Performance für den Netzwerkzugriff abgezweigt.

Da die Ethernet-Funktionalität des Betriebssystems vollständig erhalten bleibt, können alle betriebssystemkonformen Protokolle parallel auf dem selben physikalischen Netzwerk betrieben werden. Dies umfasst nicht nur Standard IT-Protokolle wie TCP/IP, HTTP, FTP oder SOAP, sondern auch praktisch alle Industrial-Ethernet-Protokolle wie Modbus TCP, ProfiNet oder Ethernet/IP.


Systemeihenschaften

BECKHOFF EtherCAT: Systemübersicht

Systemeigenschaften

Protokoll

Das für Prozessdaten optimierte EtherCAT-Protokoll wird dank eines speziellen Ether-Types direkt im Ethernet-Frame transportiert. Es kann aus mehreren Sub-Telegrammen bestehen, die jeweils einen Speicherbereich des bis zu 4 Gigabyte großen logischen Prozessabbildes bedienen. Die datentechnische Reihenfolge ist dabei unabhängig von der physikalischen Reihenfolge der Ethernet-Klemmen im Netz, es kann wahlfrei adressiert werden. Broadcast, Multicast und Querkommunikation zwischen Slaves sind möglich. Die Übertragung direkt im Ethernet-Frame wird stets dann eingesetzt, wenn EtherCAT-Komponenten im gleichen Subnetz wie der Steuerungsrechner betrieben werden.

Der Einsatzbereich von EtherCAT ist jedoch nicht auf ein Subnetz beschränkt: EtherCAT UDP verpackt das EtherCAT Protokoll in UDP/IP-Datagramme. Hiermit kann jede Steuerung mit Ethernet-Protokoll-Stack EtherCAT-Systeme ansprechen. Selbst die Kommunikation über Router hinweg in andere Subnetze ist möglich. Selbstverständlich hängt die Leistungsfähigkeit des Systems in dieser Variante von den Echtzeiteigenschaften der Steuerung und ihrer Ethernet-Protokollimplementierung ab. Die Antwortzeiten des EtherCAT-Netzwerks an sich werden jedoch nur minimal eingeschränkt: lediglich in der ersten Station muss das UDP-Datagramm entpackt werden.

Protokollstruktur: Die Prozessabbild-Zuordnung ist frei konfigurierbar. Daten werden direkt in der E/A-Klemme an die gewünschte Stelle des Prozessabbilds kopiert: zusätzliches Mapping ist überflüssig. Der zur Verfügung stehende logische Adressraum ist mit 4 Gigabyte sehr groß.

Topologie

Linie, Baum oder Stern: EtherCAT unterstützt nahezu beliebige Topologien. Die von den Feldbussen her bekannte Bus- oder Linienstruktur wird damit auch für Ethernet verfügbar. Besonders praktisch für die Anlagenverdrahtung ist die Kombination aus Linie und Abzweigen bzw. Stichleitungen. Die hierzu benötigten Schnittstellen sind auf den Kopplern vorhanden; zusätzliche Switches werden nicht benötigt. Natürlich kann aber auch die klassische Switch-basierte Ethernet-Sterntopologie eingesetzt werden.

Maximale Flexibilität bei der Verdrahtung:
mit und ohne Switch, Linien- und Baumtopologien frei wähl- und kombinierbar.

Die maximale Flexibilität bei der Verdrahtung wird durch die Auswahl verschiedener Leitungen vervollständigt. Flexible und sehr preiswerte Standard Ethernet-Patch-Kabel übertragen die Signale auf Ethernet-Art (100Base-TX). Die gesamte Bandbreite der Ethernet-Vernetzung – wie verschiedenste Lichtleiter und Kupferkabel – kann in der Kombination mit Switches oder Medienumsetzern zum Einsatz kommen.

Distributed Clocks

Der exakten Synchronisierung kommt immer dann eine besondere Bedeutung zu, wenn räumlich verteilte Prozesse gleichzeitige Aktionen erfordern. Das kann z. B. in Applikationen der Fall sein, wo mehrere Servo-Achsen gleichzeitig koordinierte Bewegungen ausführen.

Der leistungsfähigste Ansatz zur Synchronisierung ist der exakte Abgleich verteilter Uhren – wie im neuen Standard IEEE 1588 beschrieben. Im Gegensatz zur vollsynchronen Kommunikation, deren Synchronisationsqualität bei Kommunikationsstörungen sofort leidet, verfügen verteilte abgeglichene Uhren über ein hohes Maß an Toleranz gegenüber möglichen störungsbedingten Verzögerungen im Kommunikationssystem.

Beim EtherCAT basiert der Datenaustausch vollständig auf einer reinen Hardware-Maschine. Da die Kommunikation eine logische (und dank Vollduplex-Fast-Ethernet auch physikalische) Ringstruktur nutzt, kann die Mutter-Uhr den Laufzeitversatz zu den einzelnen Tochter-Uhren einfach und exakt ermitteln – und umgekehrt. Auf Basis dieses Wertes werden die verteilten Uhren nachgeführt und es steht eine hochgenaue netzwerkweite Zeitbasis zur Verfügung, deren Jitter deutlich unter einer Mikrosekunde beträgt.

Hochauflösende verteilte Uhren dienen aber nicht nur der Synchronisierung, sondern können auch exakte Informationen zum lokalen Zeitpunkt der Datenerfassung liefern. Steuerungen berechnen beispielsweise häufig Geschwindigkeiten aus nacheinander gemessenen Positionen. Speziell bei sehr kurzen Abtastzeiten führt schon ein kleiner zeitlicher Jitter in der Wegerfassung zu großen Geschwindigkeitssprüngen. Konsequenterweise werden mit EtherCAT auch neue, erweiterte Datentypen eingeführt (Timestamp und Oversampling Data Type). Mit dem Messwert wird die lokale Zeit mit einer Auflösung von bis zu 10 ns verknüpft - die große Bandbreite von Ethernet macht das möglich. Damit hängt dann die Genauigkeit einer Geschwindigkeitsberechnung nicht mehr vom Jitter des Kommunikationssystems ab. Sie wird um Größenordnungen besser als diejenige von Messverfahren, die auf jitterfreier Kommunikation basieren.

Performance

Mit EtherCAT werden neue Dimensionen in der Netzwerk-Performance erreicht. Dank FMMU-Chip in der Klemme und DMA-Zugriff auf die Netzwerkkarte des Masters erfolgt die gesamte Protokollbearbeitung in Hardware. Sie ist damit unabhängig von der Laufzeit von Protokoll-Stacks, von CPU-Performance oder Software-Implementierung. Die Update-Zeit für 1000 E/As beträgt nur 30 µs – einschließlich Klemmen-Durchlaufzeit. Mit einem einzigen Ethernet-Frame können bis zu 1486 Bytes Prozessdaten ausgetauscht werden – das entspricht fast 12000 digitalen Ein- und Ausgängen. Für die Übertragung dieser Datenmenge werden dabei nur 300 µs benötigt.

Für die Kommunikation mit 100 Servoachsen werden nur 100 µs benötigt. In dieser Zeit werden alle Achsen mit Sollwerten und Steuerdaten versehen und melden ihre Ist-Position und Status. Mit den Distributed-Clocks können die Achsen dabei mit einer Abweichung von deutlich weniger als einer Mikrosekunde synchronisiert werden.

Die extrem hohe Performance der EtherCAT-Technologie ermöglicht Steuerungs- und Regelungskonzepte, die mit klassischen Feldbussystemen nicht realisierbar waren. So kann beispielsweise nicht nur die Geschwindigkeitsregelung, sondern neu auch die Stromregelung verteilter Antriebe über das Ethernet-System erfolgen. Die enorme Bandbreite erlaubt es, zu jedem Datum z. B. auch Status-Informationen zu übertragen. Mit EtherCAT steht eine Kommunikationstechnologie zur Verfügung, die der überlegenen Rechenleistung moderner Industrie-PCs entspricht. Das Bussystem ist nicht mehr der Flaschenhals im Steuerungskonzept. Verteilte E/As werden schneller erfasst, als dies mit den meisten lokalen E/A-Schnittstellen möglich ist. Das EtherCAT Technologieprinzip ist skalierbar und nicht an die Baudrate von 100 MBaud gebunden – eine Erweiterung auf GBit Ethernet ist möglich.

Diagnose

Die Erfahrungen mit Feldbussystemen zeigen, dass die Verfügbarkeit und Inbetriebnahmezeiten entscheidend von der Diagnosefähigkeit abhängen. Nur eine schnell und präzise erkannte und eindeutig lokalisierbare Störung kann kurzfristig behoben werden. Deshalb wurde bei der Entwicklung des EtherCAT-Systems besonderer Wert auf vorbildliche Diagnoseeigenschaften gelegt.

Bei der Inbetriebnahme gilt es zu prüfen, ob die Ist-Konfiguration der E/A-Klemmen mit der Soll-Konfiguration übereinstimmt. Auch die Topologie sollte der gespeicherten Konfiguration entsprechen. Durch die eingebaute Topologie-Erkennung bis hinunter zu den einzelnen Klemmen kann nicht nur diese Überprüfung beim Systemstart stattfinden – auch ein automatisches Einlesen des Netzwerkes ist möglich (Konfigurations-Upload).

Bitfehler in der Übertragung werden durch die Auswertung der CRC-Prüfsumme zuverlässig erkannt: das 32 Bit CRC-Polynom weist eine minimale Hamming-Distanz von 4 auf. Neben der Bruchstellenerkennung und -lokalisierung erlauben Protokoll, Übertragungsphysik und Topologie des EtherCAT-Systems eine individuelle Qualitätsüberwachung jeder einzelnen Übertragungsstrecke. Die automatische Auswertung der entsprechenden Fehlerzähler ermöglicht die exakte Lokalisierung kritischer Netzwerkabschnitte. Schleichende oder wechselnde Fehlerquellen wie EMV-Einflüsse, fehlerhafte Steckverbindungen oder Kabelschäden werden erkannt und lokalisiert, auch wenn sie die Selbstheilungsfähigkeit des Netzwerkes noch nicht überfordern.

Integration von Beckhoff Standard-Busklemmen

Neben den neuen Busklemmen mit E-Bus-Anschluss (ELxxxx) lassen sich auch sämtliche Busklemmen aus dem bewährten Standardprogramm mit K-Bus-Anschluss (KLxxxx) über den Buskoppler BK1120 oder BK1250 anschließen. Damit sind Kompatibilität und Durchgängigkeit zum bestehenden Beckhoff Busklemmensystemen gewährleistet. Bestehende Investitionen werden geschützt.


Einsatzfelder

Regelkreise über den Bus

Im Verbund mit schnellen Maschinensteuerungen lässt sich die überragende Performance von EtherCAT natürlich besonders gut darstellen. Es steht ein Bussystem zur Verfügung, das Zugriffsgeschwindigkeiten wie bei lokalen E/As bietet. Mit EtherCAT lässt sich nicht nur der Lageregelkreis, sondern auch der Geschwindigkeitsregelkreis oder gar der Stromregelkreis über den Bus schließen; kostengünstige Antriebsregler sind die Folge. EtherCAT bringt damit die Leistungsfähigkeit der schnellen PC-basierten Steuerungstechnik voll zur Geltung. Die IPCs werden dabei klein und kostengünstig, da auf Steckplätze verzichtet werden kann: Erweiterungskarten werden ebenfalls über EtherCAT angesprochen.

Doch EtherCAT eignet sich nicht nur für extrem schnelle Anwendungen. Da die Protokollbearbeitung komplett in Hardware erfolgt, stellt die Technologie nur geringe Anforderungen an die Master-Anschaltung: ein handelsüblicher Ethernet Controller genügt. Der Master muss lediglich zyklisch oder bei Bedarf EtherCAT-Frames abschicken – Mapping, Adressierung, Knotenüberwachung etc. erfolgt in den Slave-ASICs. Das Eingangs-Prozessabbild kommt vollständig sortiert und damit fertig aufbereitet für die Steuerungsapplikation im Master an. Bei einfachen zyklischen Applikationen bis 1486 Byte Prozessabbildgröße ist lediglich ein einziges Telegramm im Master zu bearbeiten – und das besteht fast ausschließlich aus den Prozessdaten. Größere Prozessabbilder werden auf mehrere Frames verteilt.

EtherCAT dürfte damit diejenige Feldbus-Technologie sein, die für die geringsten Anforderungen im Master sorgt.

EtherCAT statt PCI

Mit der fortschreitenden Verkleinerung der PC-Komponenten wird die Baugröße von Industrie-PCs zunehmend von der Anzahl der benötigten Steckplätze bestimmt. Die Bandbreite von Fast-Ethernet zusammen mit der Datenbreite der EtherCAT Kommunikations-Hardware (FMMU-Chip) ermöglicht hier, neue Wege zu gehen: klassisch im IPC vorgesehene Schnittstellen werden in intelligente Schnittstellenklemmen am EtherCAT ausgelagert. Über einen einzigen Ethernet-Port im PC können dann neben den dezentralen E/As, Achsen und Bediengeräten auch komplexe Systeme wie Feldbus-Master, schnelle serielle Schnittstellen, Gateways und andere Kommunikations-Interfaces angesprochen werden. Selbst weitere Ethernet-Geräte mit beliebigen Protokollvarianten lassen sich über dezentrale Switchport-Klemmen anschließen. Der zentrale IPC wird kleiner und damit kostengünstiger. Eine Ethernet-Schnittstelle genügt zu kompletten Kommunikation mit der Peripherie.

Feldbusgeräte (z.B. Profibus, CANopen, DeviceNet, AS-Interface etc.)
werden durch dezentrale Feldbus-Masterklemmen integriert.


Offenheit

EtherCAT ist offen

Die EtherCAT Technologie ist nicht nur vollständig Ethernet-kompatibel, sondern schon vom Konzept her durch besondere Offenheit gekennzeichnet: das Protokoll verträgt sich mit weiteren Ethernet-basierten Diensten und Protokollen auf dem gleichen physikalischen Netz – in der Regel sogar mit nur minimalen Einbußen bei der Performance. Beliebige Ethernet-Geräte können innerhalb des EtherCAT-Strangs via Switchport angeschlossen werden. Geräte mit Feldbusschnittstelle werden über EtherCAT Feldbus-Master-Klemmen integriert. Die Protokollvariante UDP lässt sich auf jedem Socket-Interface implementieren.

EtherCAT Geräte können zusätzlich über einen TCP/IP-Stack verfügen und damit nach außen wie ein normales Ethernet-Gerät auftreten. Der Master fungiert dabei wie ein Switch, der die Frames gemäß der Adressinformation zu den entsprechenden Teilnehmern weiterleitet. Statt Switch-Ports werden lediglich die automatisch im Hochlauf vergebenen EtherCAT-Adressen verwendet.

Entsprechend funktionieren auch die Switchport-Klemmen: beliebige Ethernet-Geräte können angeschlossen werden Die Ethernet-Frames werden durch das EtherCAT Protokoll getunnelt, wie es im Internet üblich ist (z.B. VPN, PPPoE (DSL) etc.). Das EtherCAT-Netzwerk ist dabei für das Ethernet-Gerät voll transparent, und die Echtzeiteigenschaften des EtherCAT werden nicht beeinträchtigt.

EtherCAT Technology Group

Die EtherCAT Technology Group (ETG, http://www.ethercat.org) ist die internationale Hersteller- und Anwendervereinigung, die sich die Verbreitung, Weiterentwicklung, und Unterstützung von EtherCAT zum Ziel gesetzt hat. Jede Firma ist zur Mitgliedschaft eingeladen.

International genormt

Die EtherCAT Technology Group ist offizieller Normungspartner der IEC (International Electrotechnical Commission). Die EtherCAT-Spezifikation ist als IEC/PAS 62407 von der IEC veröffentlicht und auch über die IEC (http://www.iec.ch) erhältlich. Aktuell erfolgt die Integration in die Feldbusstandards IEC 61158, IEC 61800-7 und ISO 15745.


Zusammenfassung und Ausblick

Überragende Performance, einfachste Verdrahtung und Offenheit für andere Protokolle kennzeichnen EtherCAT. Wo herkömmliche Feldbussysteme an ihre Grenzen kommen, setzt EtherCAT neue Maßstäbe: 1000 E/A s in 30 µs, wahlweise verdrillte Zweidrahtleitung (Twisted Pair) oder Lichtleiter, und dank Ethernet- und Internet-Technologien optimale vertikale Integration. Mit EtherCAT kann die aufwändige Ethernet-Sterntopologie durch eine einfache Linienstruktur ersetzt werden – teure Infrastrukturkomponenten entfallen. Wahlweise kann EtherCAT aber auch klassisch mit Switches verkabelt werden, um andere Ethernet-Geräte zu integrieren. Wo andere Echtzeit-Ethernet-Ansätze spezielle Anschaltungen in der Steuerung erfordern, kommt EtherCAT mit äußerst kostengünstigen normalen Ethernet-Karten (NICs) aus.

Ethernet bis in die Reihenklemme wird durch EtherCAT technisch möglich und wirtschaftlich sinnvoll. Volle Ethernet-Kompatibilität, Internet-Technologien auch in einfachsten Geräten, maximale Nutzung der großen Ethernet-Bandbreite, hervorragende Echtzeiteigenschaften bei niedrigen Kosten sind herausragende Eigenschaften dieses neuen Netzwerkes. Als schneller Antriebs- und E/A-Bus am Industrie-PC oder auch in Kombination mit kleiner Steuerungstechnik wird EtherCAT vielfältige Einsatzmöglichkeiten finden.


CX8010 - Diagnose-LEDs

BECKHOFF CX8010: Fehlerbehandlung und Diagnose

Diagnose-LEDs

Ethernet Schnittstelle X001

Schnittstelle X001 | Ethernet (CX8010) | Bedeutung
LED grün | an | Link vorhanden
LED gelb | blinkt | Aktivität

Ethernet Schnittstelle X101 und X102

Schnittstelle X101-102 | Ethernet (CX8010) | Bedeutung
LED grün | blinkt | Aktivität
LED gelb | wird nicht benutzt | -

LED Koppler

Beschriftung | Bedeutung | Farbe | Bedeutung
TC | Zeigt den TwinCAT Modus an | rot | TwinCAT im Stopp
 |  | Grün | TwinCAT im Running Mode
 |  | Blau | TwinCAT im Config Mode
EC RUN | Status EtherCAT | an (Grün) | CX8010 im OP Modus
 |  | blinken (Grün) 200 ms an/aus | CX8010 im PRE-OP Modus
 |  | blinken (Grün) 200 ms an/ 1000 ms aus | CX8010 im SAFE-OP Modus
 |  | aus | INIT
EC ERR |  | aus | OK
 |  | an (rot) | nicht konfiguriert

LED Netzteilklemme

Betrieb mit K-Bus Klemmen Betrieb mit E-Bus Klemmen

Anzeige LED | Beschreibung | Bedeutung
1 Us 24V (Links Oben, 1te Reihe) | Versorgung Spannung CX80xx | an - 24V angeschlossen
2 Up 24V (Rechts Oben, 1te Reihe) | Versorgung Spannung Powerkontakte | an - 24V angeschlossen
3 L/A (Links Mitte, 2te Reihe) | EtherCAT LED | blinkt grün EtherCAT Kommunikation aktiv an E-Bus angeschlossen / Kein Datenverkehr aus E-Bus nicht angeschlossen
4 K-BUS RUN (Rechts Mitte, 2te Reihe) | K-Bus LED RUN | leuchtet grün K-Bus läuft, alles in Ordnung
6 K-BUS ERR (Rechts unten, 3te Reihe) | K-Bus LED ERR | leuchtet rot, Fehler des K-Bus siehe K-Bus Fehlercode

K-Bus Fehlercode

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken EMV-Probleme
  • Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
  • EMV-Maßnahmen ergreifen
  • Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
3 Impulse 0 K-Bus-Kommandofehler - Keine Busklemme gesteckt
- Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
6 Impulse | 0 | Fehler bei der Initialisierung | Buskoppler tauschen
1 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus - und wieder einschalten)
8 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus- und wieder einschalten)
7 Impulse | 0 | Prozessdatenlängen stimmen nicht mit der Konfiguration überein | Überprüfen Sie die Busklemmen zu den konfigurierten Busklemmen
1..n | K-Bus-Reset fehlgeschlagen | Überprüfen Sie die Busklemmen


CX80xx - Erste Schritte

BECKHOFF CX80xx: Anhang

Erste Schritte

Folgende Komponenten sind für die First Steps notwendig

  • PC mit TwinCAT 2.11 R3
  • Ethernet Kabel
  • Stromversorgung (24 VDC), Verkabelungsmaterial
  • eine KL2xxx oder EL2xxx, digitale Ausgangsklemme, Endklemme

Hinweis 		Erforderliche TwinCAT-Version
Zur Programmierung der CX80xx Baureihe ist ein TwinCAT 2.11 R3 erforderlich. Ältere TwinCAT-Versionen sowie ein TwinCAT 3.x werden nicht unterstützt!

1. Schließen sie K-Bus oder E-Bus Klemmen an den Controller an.

2. Schließen Sie den CX80xx an Spannung an (siehe Spannungsversorgung).

3. Verbinden Sie Ethernet (CX80xx X001) mit Ihrem Netzwerk oder eine direkt Verbindung zu ihrem PC (achten sie darauf das bei einer peer_to_peer Verbindung die IP-Adressierung bei Ihrem PC auf DHCP steht).

4. Warten Sie einige Zeit, ca. 1..2 Minuten, entweder wird vom DHCP Server dem CX80xx eine IP Adresse zugewiesen (geht in der Regel relative schnell) oder wenn er keinen DHCP Server findet benutzt er eine lokale IP Adresse.

5. Schalten Sie TC auf dem PC in Config Mode (TwinCAT Icon blau) und starten Sie den System Manager

6. Im System Manager klicken Sie auf das PC Symbol (Choose Target System) oder >F8<

7. Es öffnet sich folgender Dialog und drücken Sie dann auf Search (Ethernet).

8. Wählen Sie Option 1 aus wenn Sie über DHCP Adressiert haben oder Option 2 bei DHCP oder lokaler IP Adresse. Drücken Sie dann auf "Broadcast Search".

Ihr Netzwerk wird nach Beckhoff Steuerungen durchsucht. Wird keine gefunden ist das DHCP der Steuerung noch nicht abgeschlossen oder auf Ihrem PC passen die Netzwerkeinstellungen nicht. Ein nicht angeschlossenes Netzwerkkabel kann natürlich auch die Ursache sein, das sollte aber nicht der Fall sein wenn Punkt 3 berücksichtigt worden ist.

9. Der Host Name wird per Default gebildet aus "CX-" und den letzten 4 Byte der Mac Adresse. Die MAC Adresse finden Sie auf der Seite des CX80xx. Die MAC-Adresse ist immer 6 Byte lang wobei die ersten 3 Byte die Herstellerkennzeichnung ist und bei Beckhoff Geräten immer 00 01 05 ist.

Ein "X" bei connected bedeutet das der CX bereits im System bekannt ist und verwendet werden kann. Um Ihn bekannt zu machen klicken sie in der Liste auf den CX mit dem Sie sich verbinden wollen und klicken Sie auf "Add Route". Es folgt eine Eingabe Maske "User name" und "Password". Per Default gibt es kein Passwort, einfach mit OK bestätigen. Danach sollte das "X" bei connected erscheinen.

10. Als nächstes sollte der CX jetzt in der Liste der Geräte erscheinen, wählen Sie Ihn an und bestätigen sie das mit OK.

11. Kontrollieren Sie ob die Verbindung da ist. Im System Manager rechts unten in der Ecke. Es muss blau oder grün sein und darf nicht gelb sein.

12. Ist die Einstellung grün schalten sie den CX in den Config Mode "Shift F4" oder blaues TC Icon im System Manger drücken. Der System Manager fragt Sie nun ob sie in den Config Mode schalten wollen, das bestätigen Sie mit OK.

13. Rechts unten müsste die Einstellung auf blau wechseln, auch die TC LED auf dem CX80xx muss jetzt blau leuchten.

14. Klicken Sie nun auf I/O Devices und dann auf Scan Devices...

15. Es kommt ein Hinweis das nicht alles automatisch erkannt wird.

16. Es wird in der Regel das CCAT Interface gefunden (CX8090) oder das entsprechende Feldbusinterface (andere CX80xx Geräte) und entweder ein K-Bus Interface oder ein EtherCAT Interface, das kommt jetzt darauf an welche Klemmen Sie am CX angeschlossen haben. Das CCAT Interface muss im System Manager File vorhanden sein und darf nicht gelöscht werden. Sollte bei scannen eine Fehlermeldung erscheinen kontrollieren Sie den Versionsstand ihrer TwinCAT Version und führen sie gegebenenfalls ein update durch.

17. Kommen wir jetzt zum Programmieren, öffnen Sie dazu das PLC Control, wählen Sie Datei neu. Das PLC Control fragt Sie nach dem Zielsystem. Wählen Sie CX (ARM) aus. Danach fragt er Sie nach dem Baustein, stellen Sie die Sprache ST ein (Strukturierter Text). Jetzt schreiben Sie ein kleines Programm...

Übersetzen Sie das Programm, ist es Fehlerfrei (es müsste eine Warning kommen, das ist soweit OK) speichern Sie das Projekt unter einem beliebigen Namen, übersetzen sie es erneut und speichern sie dann noch einmal.

18: Wechseln Sie wieder zum System Manager und fügen Sie das Programm unter PLC Configuration an. Es wird nach einem Dateiname.typ File gesucht.

19: Öffnen Sie nun das Projekt dann die Task und dann auf Outputs, dort muss es dann eine Variable MAIN.bToggle geben. Diese können Sie mit der Hardware verknüpfen. Klicken Sie dazu auf "Linked to...".

Wählen Sie einen digitalen Ausgang aus. Jetzt können sie die Konfiguration auf dem CX runterladen und den CX in den Run Mode schalten. Dafür klicken Sie auf den "Würfel" oder Control + Shift + F4. Die TC LED auf dem CX müsste dann grün leuchten.

20. Wechsel sie wieder in das PLC Control, gehen Sie auf "Online/Auswahl des Zielsystems", wählen Sie den richtigen CX aus, klicken Sie ihn auf und wählen Sie Laufzeitsystem1 aus. Jetzt wieder "Online/Einloggen" (F11) übertragen Sie das SPS Programm, danach "Online/Start" (F5). Jetzt müsste die LED auf ihrerer Klemme blinken.

21. Als letzten Schritt Online/Erzeugen eines Bootprojektes. Damit ist das Projekt abgeschlossen und ihr erstes Programm auf dem CX gespeichert.

Herzlichen Glückwunsch, die Grundlagen sind jetzt vorhanden und warten drauf ausgebaut zu werden. Viel Erfolg!


CX80xx - Image Update

BECKHOFF CX80xx: Anhang

Image Update

Es gibt zwei verschiedenen Möglichkeiten das Image des CX80xx zu aktualisieren.

Hinweis 		Voraussetzungen
  • Bitte stellen Sie vor dem Update sicher, dass Ihr CX80xx das Image unterstützt, das Sie aufspielen wollen.
  • Bitte löschen Sie beim Image-Update zuerst alle vorhandenen Dateien und kopieren Sie dann erst das neue Image.

Kopieren Sie immer alle Dateien und Verzeichnisse um einen CX80xx zu aktualisieren.

Update über USB

Hierfür ist ein USB-Kabel erforderlich!

  • CX80xx ausschalten
  • Roten DIP-Schalter (unter der Klappe) DIP 1 auf ON stellen
  • CX einschalten
  • PC mit USB verbinden
  • Löschen Sie alle Dateien (wir empfehlen erst alle Dateien zu sichern), keine Formatierung
  • Warten bis das kopieren zu Ende ist und entfernen Sie das USB Kabel
  • Schalten Sie den DIP-Schalter 1 auf OFF
  • CX80xx ausschalten
  • CX80xx einschalten, es kann möglich sein, dass das erste mal einschalten etwas länger dauert

Update der MicroSD-Karte

Hierfür ist ein MicroSD-Karten-Lesegerät erforderlich!

  • Entnehmen Sie die MicroSD-Karte aus dem ausgeschalteten CX Gerät.
  • Stecken Sie die MicroSD-Karte in das Lesegerät
  • Löschen Sie alle Dateien (wir empfehlen zuvor alle Dateien zu sichern), keine Formatierung
  • Aufspielen des neuen Images
  • Warten bis der Kopiervorgang abgeschlossen ist und entnehmen Sie die MicroSD-Karte
  • Stecken Sie die MicroSD-Karte wieder in den SD-Slot ihres ausgeschalteten CX
  • Jetzt schalten Sie den CX wieder ein, es kann möglich sein, dass das erste mal einschalten etwas länger dauert


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


CX8090/8091 - IP-Adresse

BECKHOFF CX8090, CX8091: Parametrierung und Inbetriebnahme

IP-Adresse

Der CX8090/CX8091 besitzt zwei für das Betriebssystem sichtbare Ethernet Schnittstellen, X001 und X101/102.

X001

IP-Adressierung über das Betriebsystem, Default ist DHCP (im Betriebsystem als FEC1 dargestellt)

X101/102

IP-Adressierung über die DIP Schalter (im Betriebsystem als TCCCATMP1 dargestellt)

EtherCAT-Schnittstelle

Die EtherCAT-Schnittstelle ist eine weitere Ethernet-Schnittstelle, die für die IP-Adressierung im Betriebsystem nicht sichtbar ist.