CX50x0 - Emmbedded PC

BECKHOFF Automation

Dokumentation zu der Hardware des CX50x0

CX5010-xxxx

CX5020-xxxx

Version: 1.5
Datum: 03.05.2013


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR 		Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG 		Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT 		Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung 		Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis 		Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


CX5010 / CX5020 - Ausgabestände der Dokumentation

BECKHOFF CX50x0: Vorwort

Ausgabestände der Dokumentation

Version | Änderungen
1.5 | K-Bus Diagnose erweitert
1.4 | Hinweise zu passiven Klemmen hinzugefügt
1.3 | Hinweise zu Netzteilleistung hinzugefügt
1.2 | Ergänzungen zum Temperaturbereich und K-Bus-Diagnose
1.1 | Änderungen zur Schnittstelle N031 und DVI Auflösungen ergänzt
1.0 | Erste Veröffentlichung
0.1 | Vorläufige Version (Urfassung)


CX50x0 - Bestimmungsgemäße Verwendung

BECKHOFF CX50x0: Produktübersicht

Bestimmungsgemäße Verwendung

Die Geräteserie CX5010 / CX5020 ist ein modulares Steuerungssystem, das für die Montage auf einer Hutschiene vorgesehen ist. Die System ist skalierbar, so dass je nach Aufgabenstellung, die benötigten Module zusammengesteckt und in den Schaltschrank oder Klemmenkasten eingebaut werden.

Abschalten des PCs nur nach Beendigung der Software

Bevor der Embedded-PC abgeschaltet werden darf muss die laufende Software regulär beendet werden, andernfalls können Daten auf der Festplatte verloren gehen. Lesen Sie dazu den Abschnitt "Ausschalten".

Wenn der PC nicht für Steuerungszwecke eingesetzt wird, beispielsweise während der Funktionsprüfung, müssen zuerst alle Anlagenteile abgeschaltet und danach der Embedded-PC von der Anlage abgekoppelt werden. Die Abkopplung geschieht durch Abziehen der ersten Klemme hinter dem Netzteil (optional) und Abziehen der Stecker der Feldbusanschlüsse.
Abgeschaltete Anlagenteile müssen gegen Wiedereinschalten gesichert werden.

Das Netzteil des Embedded-PCs wird mit einer Spannung von 24 VDC versorgt.

Achtung 		Schädigung von Umwelt oder Geräten
Keine Teile unter Spannung austauschen! Durch das Austauschen der Steuerungsteile unter Spannung kann es zu Kurzschlüssen oder Überspannungen kommen. Diese können die Steuerung selbst und angeschlossenen Peripherie (Klemmen, Bildschirme, Eingabegeräte, etc.) beschädigen.

Beim Ein- und Ausbau von Komponenten muss die Versorgungsspannung abgeschaltet werden.

Softwarekenntnisse

Achtung 		Fehlfunktionen der Anlage
Erforderliche Softwarekenntnisse! Jeder Benutzer muss alle für ihn erreichbaren Funktionen der auf dem PC installierten Software kennen.


CX50x0 - Systemübersicht

BECKHOFF CX50x0: Produktübersicht

Systemübersicht

Das System

Die Geräte der Serie CX5000 sind hutschienenmontierbare, lüfterlose Embedded-PCs mit direktem Anschluss für Beckhoff Bus- oder EtherCAT-Klemmen. Im Gegensatz zu den anderen CX-Gerätefamilien hat die Serie CX5000 eine feste, nicht erweiterbare Anzahl an Systemschnittstellen. Das Gehäusekonzept dieser Serie ist auf Robustheit und Kompaktheit optimiert; auf eine linksseitige modulare Erweiterbarkeit wurde verzichtet. Durch die Anbindung von EtherCAT bleiben jedoch vielfältige Erweiterungsmöglichkeiten offen. Weitere Master/Slave-Feldbusanschlüsse (PROFIBUS, CANopen, DeviceNet) oder Kommunikationsschnittstellen (RS232, RS422/ RS485) sowie alle über EtherCAT erreichbaren Signalformen können unmittelbar als EtherCAT-Klemmen angereiht werden. Als Systemschnittstellen stehen zwei unabhängige Gigabit-Ethernet-Ports sowie vier USB-2.0-Schnittstellen zur Verfügung. An die DVI-D-Schnittstelle kann ein Beckhoff Control Panel oder ein handelsüblicher DVI-Monitor angeschlossen werden. Je nach Bedarf kann als optionale Schnittstelle ein serieller Port (RS232/RS422/RS485) oder ein Feldbusanschluss mit Master- oder Slave-Funktion zugefügt werden. Als Boot- und Speichermedium kommt eine auswechselbare Compact-Flash-Karte zum Einsatz, die von außen hinter einer Klappe zugänglich ist. Die eingebaute kapazitive 1-Sekunden-USV sorgt für ein sicheres Abspeichern der persistenten Anwendungsdaten auf die Compact-Flash-Karte. Datum und Uhrzeit werden über eine wechselbare Batterie gepuffert. Bei den Betriebssystemen besteht die Wahl zwischen Windows CE sowie Windows Embedded Standard. Durch die Automatisierungssoftware TwinCAT wird ein CX5000-System zu einer leistungsfähigen SPS und Motion-Control-Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann.

EtherCAT als schnelles I/O-System

Der CX5000 wurde, wie alle Embedded-PC CXs (mit Ausnahme CX100x), im Hinblick auf das optimierte Zusammenspiel mit EtherCAT entwickelt. Die eine der zwei unabhängigen Ethernet-Schnittstellen des CPU-Moduls (X001), ist für den EtherCAT-Betrieb gedacht. Der primäre EtherCAT-Anschluss erfolgt in der Regel über Klemmenanschaltung. Beide zusammen könne dann auch als Ring verschaltet werden um Leitungsredundanz zu erreichen.

Interessanterweise ergeben sich durch EtherCAT mehrere Möglichkeiten, die klassischen Feldbussysteme an den CX50x0 anzuschließen:
Als EtherCAT-Teilnehmer in Klemmenform. Beispielsweise gibt es den PROFIBUS-Master als EtherCAT-Klemme EL6731. Praktisch kann der PROFIBUS-Master genau da an der Maschine angebracht werden, wo er benötigt wird. Es muss also nicht mehr unbedingt die Steckkarte im IPC oder die Mastersteuerung im Schaltschrank sein.

SPS, Motion Control, Interpolation und Visualisierung

Als IPC auf der Hutschiene hat der CX50x0, im Zusammenspiel mit der Beckhoff-TwinCAT-Software, die Funktionalität großer Industrie-PCs. Im Bereich SPS können bis zu vier virtuelle IEC 61131-CPUs, mit jeweils bis zu vier Tasks, programmiert werden; die kürzest einstellbare Zykluszeit beträgt 50 μs. Alle IEC 61131-3-Sprachen sind nutzbar.

Ebenso stehen alle Funktionalitäten von TwinCAT für den Bereich Motion Control zur Verfügung:
Es können theoretisch bis zu 256 Achsen angesteuert und neben einfachen Punkt-zu-Punkt-Bewegungen auch komplexere Mehrachsfunktionen, wie „Elektronisches Getriebe“, „Kurvenscheibe“ und „Fliegende Säge“ ausgeführt werden.

Neben den in Echtzeit ausgeführten Steuerungsaufgaben sorgt die Verwaltung im TwinCAT-Echtzeitkern dafür, dass genügend Zeit für die Benutzeroberfläche (HMI) bleibt, die über Softwareschnittstellen, wie ADS oder OPC, mit den Echtzeitanteilen kommuniziert.

Auch bei CX50x0 gilt der Grundsatz: ein Programmierwerkzeug für alle Steuerungen.
Die gesamte Programmierung von SPS, Motion Control und Visualisierung ist auf alle PC-Steuerungen von Beckhoff übertragbar – beruhigend, falls sich während des Projekts herausstellt, dass es dann doch mehr Rechenleistung benötigt wird. In diesem Fall kann auf ein System mit mehr Leistung zurück gegriffen werden.

Feldbusschnittstellen

Die Feldbusschnittstellen sind derzeit als Master und Slave-Feldbusanschaltungen für folgende Feldbusse erhältlich:

Optionsschnittstellen:

Über die Optionsschnittstellen lassen sich 1-kanalige Feldbusschnittstellen anbinden. Es ist immer nur der Betrieb von einer Schnittstelle möglich. Sollten mehrere Feldbuss-Schnittstellen benötigt werden, so können diese als E-Bus-Klemmen (EL67xx) hinzugefügt werden. Die verfügbaren Feldbusschnittstellen sind im einzelnen:

  • CX50x0-N030 = RS232, D-Sub-Stecker
  • CX50x0-N031 = RS422/RS485, D-Sub-Buchse
  • CX50x0-M310 = PROFIBUS-Master, D-Sub-Buchse, 9-polig
  • CX50x0-B310 = PROFIBUS-Slave, D-Sub-Buchse, 9-polig
  • CX50x0-M510 = CANopen-Master, D-Sub-Stecker, 9-polig
  • CX50x0-B510 = CANopen-Slave, D-Sub-Stecker, 9-polig
  • CX50x0-M930 = PROFINET RT, Controller, Ethernet (2 x RJ-45-Switch)
  • CX50x0-B930 = PROFINET RT, Device, Ethernet (2 x RJ-45-Switch)
  • CX50x0-B951 = EtherNet/IP-Slave, Ethernet (2 x RJ-45-Switch)
  • CX50x0-B100 = EtherCAT-Slave, EtherCAT IN und OUT (2 x RJ 45)

Die Software

In Kombination mit der Automatisierungssoftware TwinCAT wird der Industrie-PC CX50x0 zu einer leistungsfähigen IEC 61131-3 SPS mit bis zu vier Anwender-Tasks. Zusätzlich können auch Motion Control Aufgaben ausführt werden. Je nach erforderlicher Abtastzeit ist die Ansteuerung von mehreren Servoachsen möglich, wobei selbst Sonderfunktionen wie Fliegende Säge, Elektronisches Getriebe und Kurvenscheibe realisierbar sind.

Die Programmierung des CX50x0 Systems erfolgt in der für Buskontroller üblichen Weise:

Remote Programmierung über Ethernet

Dies ist der Fall, wenn die Basiseinheit mit "Windows CE.NET" ausgestattet wird. Dann erfolgt die Programmierung über ein Laptop oder einen Desktop-PC, der über Ethernet (Netzwerk oder Crossover-Cable) mit dem CX verbunden ist. Die Programme werden mit einer Standard TwinCAT Softwarelizenz auf dem Laptop entwickelt und dann in das Zielgerät geladen.

Visualisierung

Bei beiden Betriebssystemvarianten "Windows CE.NET" bzw. "Windows XP Embedded" steht für die Anbindung an SCADA-Pakete der Beckhoff OPC Server zur Verfügung. Somit gilt auch für den CX50x0: Problemlos Visualisieren und gleichzeitiges Steuern in Echtzeit auf einem System.


CX5010 - Technische Daten

BECKHOFF CX5010: Produktübersicht

CX5010 Technische Daten

Die Grundausstattung des CX5010 enthält eine 64-MB-Compact-Flash-Karte. Zwei Ethernet-RJ-45 Schnittstellen, vier USB-2.0 Schnittstellen sowie eine DVI-D Schnittstelle gehören zur Basisausstattung.

Technische Daten | CX5010
Prozessor | Prozessor Intel® Atom™ Z510, 1,1 GHz Taktfrequenz
Interner Flash Speicher | 64 MByte Compact Flash Karte
Interner Arbeitsspeicher | 512 MB RAM (intern, nicht erweiterbar)
Schnittstellen | 2 x RJ 45, 10/100/1000 MBit/s, DVI-D, 4 x USB 2.0
Diagnose LED | 1 x Power, 1 x TC-Status, 1 x Flash-Zugriff, 2 x Bus-Status
Uhr | interne, batteriegepufferte Uhr für Zeit und Datum (Batterie wechselbar)
Betriebssystem | Microsoft Windows CE oder Microsoft Windows Embedded Standard
Steuerungssoftware | TwinCAT-PLC-Runtime oder TwinCAT-NC-PTP-Runtime
Spannungsversorgung | 24 V DC (-15 %/+20 %)
Stromversorgung | I/O-Klemmen 2 A
Max. Verlustleistung | 12 W (einschließlich der Systemschnittstellen)
Spannungsfestigkeit | 500 Veff (Versorgung/interne Elektronik)
Abmessungen (H x B x T) | 100 mm x 106 mm x 92 mm
Gewicht | ca. 575 g
Betriebs-/Lagertemperatur | -25° C ... +60° C / -40° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20

Technische Da

Weitere Informationen: www.beckhoff.de/CX5010


CX5020 - Technische Daten

Die Grundausstattung des CX5010 enthält eine 64 MB Compact-Flash-Karte. Zwei Ethernet-RJ-45 Schnittstellen, vier USB-2.0 Schnittstellen sowie eine DVI-D Schnittstelle gehören zur Basisausstattung.

Technische Daten | CX5010
Prozessor | Prozessor Intel® Atom™ Z530, 1,6 GHz Taktfrequenz
Interner Flash Speicher | 64 MByte Compact Flash Karte
Interner Arbeitsspeicher | 512 MB RAM (intern, nicht erweiterbar)
Schnittstellen | 2 x RJ 45, 10/100/1000 MBit/s, DVI-D, 4 x USB 2.0
Diagnose LED | 1 x Power, 1 x TC-Status, 1 x Flash-Zugriff, 2 x Bus-Status
Uhr | interne, batteriegepufferte Uhr für Zeit und Datum (Batterie wechselbar)
Betriebssystem | Microsoft Windows CE oder Microsoft Windows Embedded Standard
Steuerungssoftware | TwinCAT-PLC-Runtime oder TwinCAT-NC-PTP-Runtime
Spannungsversorgung | 24 V DC (-15 %/+20 %)
Stromversorgung | I/O-Klemmen 2 A
Max. Verlustleistung | 12,5 W (einschließlich der Systemschnittstellen)
Spannungsfestigkeit | 500 Veff (Versorgung/interne Elektronik)
Abmessungen (H x B x T) | 100 mm x 106 mm x 92 mm
Gewicht | ca. 575 g
Betriebs-/Lagertemperatur | -25° C ... +60° C / -40° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20

Weitere Informationen: www.beckhoff.de/CX5020


CX50x0 - Ausführungen

BECKHOFF CX50x0: Produktübersicht

Ausführungen

Das CPU-Modul lässt sich mit unterschiedlichen Hardware- und Softwareoptionen ausstatten: bei den Betriebssystemen besteht die Wahl zwischen "Windows CE" sowie "Windows Embedded Standard". Durch die Automatisierungssoftware TwinCAT wird ein CX50x0 System zu einer leistungsfähigen SPS und Motion Control Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. An das CPU-Grundmodul können weitere Systemschnittstellen (ab Werk vormontiert) sowie Feldbusanschaltungen angefügt werden.

Die CX 1020 Module sind in folgenden Ausführungen erhältlich:

Modul | K-BUS | E-BUS | Taktfrequenz der CPU | ohne Betriebssystem | Windows CE | Windows Embedded Standard | ohne TwinCAT | TwinCAT PLC Runtime | TwinCAT NC PTP Runtime
CX5010-0100 |  | X | 1,1 GHz | X | - | - | X | - | -
CX5010-0110 |  | X | 1,1 GHz | - | X | - | X | - | -
CX5010-0111 |  | X | 1,1 GHz | - | X | - | - | X | -
CX5010-0112 |  | X | 1,1 GHz | - | X | - | - | - | X
CX5010-0120 |  | X | 1,1 GHz | - | - | X | X | - | -
CX5010-0121 |  | X | 1,1 GHz | - | - | X | - | X | -
CX5010-0122 |  | X | 1,1 GHz | - | - | X | X | - | X
CX5010-1100 | X | - | 1,1 GHz | X | - | - | X | - | -
CX5010-1110 | X | - | 1,1 GHz | - | X | - | X | - | -
CX5010-1111 | X | - | 1,1 GHz | - | X | - | - | X | -
CX5010-1112 | X | - | 1,1 GHz | - | X | - | - | - | X
CX5010-1120 | X | - | 1,1 GHz | - | - | X | X | - | -
CX5010-1121 | X | - | 1,1 GHz | - | - | X | - | X | -
CX5010-1122 | X | - | 1,1 GHz | - | - | X | X | - | X
CX5020-0100 |  | X | 1,6 GHz | X | - | - | X | - | -
CX5020-0110 |  | X | 1,6 GHz | - | X | - | X | - | -
CX5020-0111 |  | X | 1,6 GHz | - | X | - | - | X | -
CX5020-0112 |  | X | 1,6 GHz | - | X | - | - | - | X
CX5020-0120 |  | X | 1,6 GHz | - | - | X | X | - | -
CX5020-0121 |  | X | 1,6 GHz | - | - | X | - | X | -
CX5020-0122 |  | X | 1,6 GHz | - | - | X | X | - | X
CX5020-1100 | X | - | 1,6 GHz | X | - | - | X | - | -
CX5020-1110 | X | - | 1,6 GHz | - | X | - | X | - | -
CX5020-1111 | X | - | 1,6 GHz | - | X | - | - | X | -
CX5020-1112 | X | - | 1,6 GHz | - | X | - | - | - | X
CX5020-1120 | X | - | 1,6 GHz | - | - | X | X | - | -
CX5020-1121 | X | - | 1,6 GHz | - | - | X | - | X | -
CX5020-1122 | X | - | 1,6 GHz | - | - | X | X | - | X

CX50x0 Systeme mit Windows Embedded Standard setzen eine Compact Flash Karte mit einer Kapazität von mindestens 2 GByte voraus.

Hinweis 		Software Images
Die Auflistung der verschiedenen Software Images entnehmen Sie bitte der CX-Software Dokumentation.


CX50x0: Batteriefach

BECKHOFF CX50x0: Produktübersicht

Batteriefach

Unter der Frontklappe des CX50x0 befindet sich das Batteriefach. Nach dem Aufklappen der Frontklappe ist die Öffnung, in der die Halterung der Batterie angebracht ist, sichtbar. Die Batterie kann mit Hilfe eines Schraubenziehers vorsichtig aus dem Halter gehebelt werden und entnommen werden.

Zum Einlegen der Batterie wird die neue Batterie in das Batteriefach geschoben. Dabei ist auf die Polung der Batterie zu achten. Anschließend kann die Frontklappe geschlossen werden. Der Batteriewechsel ist damit abgeschlossen.

Bei der Batterie handelt es sich um eine Typ CR2032 von Panasonic.

Die genauen Daten lauten wie folgt:

Batterietyp | Elektrische Eigenschaften (bei 20° C) |  | Standard Belastung | Abmessungen
 | nominal Spannung | nominal Kapazität | kontinuierliche Last | Durchmesser | Höhe | Gewicht
CR2032 | 3,0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

Achtung 		Eine falsch eingesetzte Batterie kann explodieren!
Verwenden Sie ausschließlich denselben Batterietyp (CR2032) von Sanyo oder Panasonic.

Achten Sie unbedingt darauf, dass die Plus- und Minuspole der Batterie korrekt eingelegt wird. (Minuspol links)

Öffnen Sie die Batterie niemals und werfen Sie die Batterie niemals in ein Feuer.

Die Batterie kann nicht wieder aufgeladen werden.

Hinweis 		Wartung der Batterie
Die Batterie muss alle 5 Jahre gewechselt werden.

Ersatzbatterien können beim Beckhoff Service bestellt werden.


CX50x0 - CF-Einschub

BECKHOFF CX50x0: Produktübersicht

CF-Einschub

Auf der Frontseite befindet sich ein Compact Flash Einschub. Hier durch ergibt sich die Möglichkeit das Speichermedium auszutauschen. Dies ist bei dem Einschub im Grundmodul nur in ausgeschaltetem Zustand möglich, andernfalls kann die Entnahme zum Absturz des Systems führen. Zu Wartungsarbeiten kann die Compact-Flash-Karte aus dem Modul entnommen werden. Auch die Erweiterung des Systems auf einen größeren Speicher (nur Betriebssystem und Programmspeicher) ist auf diese Weise möglich. Die Compact-Flash-Karten (CF-Karten) sind als Zubehör in verschiedenen Speichergrößen erhältlich.

Die folgende Bildserie zeigt die Handhabung der CF-Karten. Zuerst muss die Frontklappe geöffnet werden. Dann liegen die Auswurfmechanik und der CF-Karten-Einschub frei. Die Betätigung der Auswurfmechanik folgt dem Push-Push-Prinzips: Ist der Kopf der Mechanik im Gehäuse versenkt, wird diese durch das Drücken auf den Kopf aus dem Gehäuse geklappt. Erneutes Drücken auf den Kopf versenkt den Knopf wieder im Gehäuse. Gleichzeitig wird die Karte um ca. 4 mm aus dem Gehäuse gehoben, so dass sie mit den Fingern herausgezogen werden kann. Beim Einschub der Karte (BILD3) rastet die Auswurfmechanik wieder ein. Die Karte sitzt richtig, wenn sie sich ca.1 mm tiefer als die Frontseite des Gerätegehäuses befindet.

Beim Einschub der Karte rastet die Auswurfmechanik wieder ein. Die Karte sitzt richtig, wenn sie sich ca.1 mm tiefer als die Frontseite des Gerätegehäuses befindet.

Hinweis 		Typ des CF-Einschubs
Bei dem Compact-Flash-Einschub handelt es sich um ein Speicherinterface, nicht um einen CF Einschub des Typs I/O.


CX50x0 - CF-Karte

BECKHOFF CX50x0: Produktübersicht

CF-Karte

Bei der Compact-Fash-Karte (CF-Karte) handelt es sich um einen nicht volatilen Speicher.

Daten, die Spannungsausfallsicher gespeichert werden sollen, müssen auf der CF-Karte gespeichert werden. Die CF-Karte arbeitet wie eine Harddisk.

Hinweis 		Verwendung von CF-Karten
Es wird ausdrücklich darauf hingewiesen nur CF-Karten zu verwenden, die von der Beckhoff Automation GmbH geliefert werden.
Dies sind industrietaugliche CF-Karten mit einer erhöhten Anzahl an Schreib-/ Lesezyklen und einem erweiterten Temperaturbereich ( +85°C).

Ein einwandfreier Betrieb kann nur mit CF-Karten von der Beckhoff Automation GmbH gewährleistet werden!


CX50x0 - DVI-D-Anschluss

BECKHOFF CX50x0: S-UPS (Second - Unbreakable Power Supply)

S-UPS:Kapazitive Sekunden-USV

Die CX50x0 Familie verfügt eine eingebaute kapazitive 1-Sekunden-USV. Sie sorgt für ein sicheres Abspeichern der persistenten Anwendungsdaten auf die Compact-Flash-Karte.

Es können bis zu 1 MB Daten gesichert werden. Die USV kann über das BIOS ein- bzw. ausgeschaltet werden:

Phoenix – AwardBIOS CMOS Setup Utility

PC Health Status

SUSV | [Enabled] | Item Help
SUSV holds USB | [Enabled] |
SUSV Stauts | 100% Cap. / Charging |
On Die Digital Temp. | 47°C |
Temp. Board | 56°C |
Temp DDR | 57°C |
CPU Core | 1.07V |
SCH Core | 1.04V |
 | ... |

SUSV

Hier kann die Sekunden-USV ausgeschaltet werden.

SUSV holds USB

Wenn die SUSV das System puffert, können hier die USB-Port entweder mit versorgt werden oder sie können abgeschaltet werden. Dies ist z.B. wichtig wenn Daten noch auf ein USB-Speichermedium gesichert werden sollen.

SUSV Status

Dieser Wert zeigt den Status der Sekunden-USV an.

n% Cap. (n={0..100}) beschreibt die Kapazität der USV.

State (charging / discharging) beschreibt den Zustand der Sekunden USV.

Integration in eine SPS

Für die Integration der S-UPS in ein SPS-Programm stehen im TwinCAT spezielle Funktionsbausteine bereit. Diese werden im folgenden Absatz erklärt. Ab TwinCAT 2.11R2 Build2016 ist den notwendige Bibliothek in die Installation integriert. Für ältere Versionen muss die Bibliothek TcSUPS.lib in das Bibliotheksverzeichnis von TwinCAT kopiert werden.


Übersicht

In der Bibliothek TcSUPS.Lib sind Funktionen und Funktionsbausteine enthalten, die zur Ansteuerung der Sekunden-USV nötig sind. Siehe Beispielprojekt Sample_S_UPS.pro.

Funktionsbausteine

Name | Beschreibung
FB_S_UPS | Baustein zur Ansteuerung der Sekunden-USV
FB_NT_QuickShutdown | Interner Baustein für den QuickShutdown, wird von dem FB_S_UPS verwendet.

Funktionen

Name | Beschreibung
F_GetVersionTcSUPS | Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

Anforderungen

Komponente | Version
TwinCAT auf dem Entwicklungsrechner und auf der Steuerung | TwinCAT 2.11 Build 2016 oder höher (R2)


FUNCTION_BLOCK FB_S_UPS

Der Funktionsbaustein FB_S_UPS kann auf PCs mit Sekunden-USV verwendet werden, um die Sekunden-USV aus der SPS anzusteuern. Hiermit können bei Spannungsausfall noch die Persistenten Daten gespeichert und ein QuickShutdown ausgeführt werden. Wenn möglich sollten die Defaultwerte der INPUTs des FB_S_UPS beibehalten werden.

Achtung 		Datenverlust

Die Sekunden-USV kann bei Spannungsausfall nur für wenige Sekunden verwendet werden, um z.B. Persistente Daten zu speichern. Das Speichern der Daten muss im schnellen Persistent Modus "SPDM_2PASS" erfolgen, auch wenn es hier zu Echtzeitverletzungen kommen kann. Zum Speichern der Persistenten Daten muss hinreichend Routerspeicher konfiguriert werden!

Für das Überbrücken von Spannungsausfällen hat die Sekunden-USV nicht genügend Kapazität. Das Speichern kann nur auf der Compact Flash Karte erfolgen, da auch für den Betrieb einer Festplatte nicht genügend USV-Kapazität vorhanden ist.

Im Modus eSUPS_WrPersistData_Shutdown (Standardeinstellung) wird nach dem Speichern der Persistenten Daten automatisch ein QuickShutdown ausgeführt.

Im Modus eSUPS_WrPersistData_NoShutdown werden nur die Persistenten Daten gespeichert, es wird kein QuickShutdown ausgeführt.

Im Modus eSUPS_ImmediateShutdown wird sofort ein QuickShutdown ausgeführt, ohne das Speichern von Daten.

Im Modus eSUPS_CheckPowerStatus wird nur geprüft, ob ein Spannungsausfall auftrat. Ist dies der Fall, geht der Baustein erst nach Ablauf der tRecoverTime (10s) wieder in den Zustand PowerOK.

Unabhängig vom Modus und damit unabhängig vom Speichern oder Herunterfahren der Steuerung schaltet die USV nach Entladung der Kondensatoren das Mainboard ab, auch wenn die Spannung zwischenzeitlich wiederkehrt.

Achtung 		Achtung bei Verwendung von Dateien:
Falls andere Applikationen oder die SPS noch weitere Dateien offen halten oder in diese schreiben, kann es zu fehlerhaften Dateien kommen, wenn die USV die Steuerung abschaltet.

Achtung 		Achtung bei Verwendung von Windows XP embedded:
Zum Schutz der Windows XP embedded-Dateien muss auf Geräten mit der Sekunden-USV entweder der EWF (Enhanced Write Filter) oder der FBWF (File Based Write Filter) aktiviert sein.

Im Falle des EWF muss das TwinCAT\Boot-Verzeichnis auf einer ungeschützten Partition liegen (siehe in der Registry: HKEY_LOCAL_MACHINE\SOFTWARE\Beckhoff\TwinCAT\System\BootPrjPath).

Im Falle des FBWF muss das TwinCAT\Boot-Verzeichnis vom Schutz ausgenommen werden (siehe Beckhoff FBWF Manager, Exclusion Settings).

FUNCTION_BLOCK FB_S_UPS

VAR_INPUT

VAR_INPUT
    sNetID          : T_AmsNetId := '';               (* '' = local netid *)
    iPLCPort        : UINT := AMSPORT_R0_PLC_RTS1;    (* PLC Runtime System for writing persistent data *)
    iUPSPort        : UINT := 16#4A8;                 (* Port for reading Power State of UPS, dafault 16#4A8 *)
    tTimeout        : TIME := DEFAULT_ADS_TIMEOUT;    (* ADS Timeout *)
    eUpsMode        : E_S_UPS_Mode := eSUPS_WrPersistData_Shutdown; (* UPS mode (w/wo writing persistent data, w/wo shutdown) *)
    ePersistentMode : E_PersistentMode := SPDM_2PASS; (* mode for writing persistent data *)
    tRecoverTime    : TIME := T#10s;                  (* ON time to recover from short power failure in mode eSUPS_WrPersistData_NoShutdown/eSUPS_CheckPowerStatus *)
END_VAR

sNetID : AmsNetID der Steuerung.

iPLCPort : Portnummer des SPS-Laufzeitsystems (AMSPORT_R0_PLC_RTS1 = 801, AMSPORT_R0_PLC_RTS2 = 811, AMSPORT_R0_PLC_RTS3 = 821, AMSPORT_R0_PLC_RTS4 = 831).

iUPSPort : Portnummer über die der USV-Status gelesen wird (Standardwert ist 16#4A8).

tTimeout : Timeout für die Ausführung des QuickShutdowns.

eUpsMode : eUpsMode definiert, ob Persistente Daten geschrieben werden sollen und ob ein QuickShutdown ausgeführt werden soll.
Standardwert ist eSUPS_WrPersistData_Shutdown, d.h. mit Schreiben der Persistenten Daten und dann QuickShutdown. Siehe E_S_UPS_Mode.

ePersistentMode : Modus für das Schreiben der Persistenten Daten. Standardwert ist SPDM_2PASS.

tRecoverTime : Zeit, nach der die USV bei UPS-Modi ohne Shutdown wieder in den PowerOK Status zurück geht.
Die tRecoverTime muss etwas größer sein, als die maximale Haltezeit der USV, da die USV auch bei wiederkehrender Spannung abschaltet.

VAR_OUTPUT

VAR_OUTPUT
    bPowerFailDetect	: BOOL;            (* TRUE while powerfailure is detected *)
    eState 		: E_S_UPS_State;   (* current ups state *)
END_VAR

bPowerFailDetect : True während des Spannungsausfalls; False, wenn die Versorgungsspannung anliegt .

eState : Interner Zustand des Funktionsbausteins, Werte siehe E_S_UPS_State.

VAR_GLOBAL

VAR_GLOBAL
    eGlobalSUpsState : E_S_UPS_State;    (* current ups state *)
END_VAR

eGlobalUpsState : Interner Zustand des Funktionsbausteins als globale Kopie des VAR_OUTPUT eState, Werte siehe E_S_UPS_State.

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2016 oder höher (R2) | PC (i386) | Sekunden USV | TcSUPS.Lib


FUNCTION_BLOCK FB_NT_QuickShutdown

Mit dem Funktionsbaustein FB_NT_QuickShutdown führt die Steuerung einen unmittelbaren Reboot durch, ohne dass TwinCAT oder das Betriebssystem Windows gestoppt werden.

Achtung:

Achtung 		Datenverlust

Der Funktionsbaustein FB_NT_QuickShutdown wird intern vom FB_S_UPS verwendet und darf nicht eigenständig verwendet werden, da sonst mit Datenverlust zu rechnen ist!

FUNCTION_BLOCK FB_NT_QuickShutdown

VAR_INPUT

VAR_INPUT
    NETID :T_AmsNetId;
    START :BOOL;
    TMOUT :TIME := DEFAULT_ADS_TIMEOUT;
END_VAR

NETID : AmsNetID der Steuerung.

START : Steigende Flanke führt zum unmittelbaren Reboot der Steuerung.

TMOUT : Timeout-Zeit.

VAR_OUTPUT

VAR_OUTPUT
    BUSY  :BOOL;
    ERR   :BOOL;
    ERRID :UDINT;
END_VAR

BUSY : Der QuickShutdown wird ausgeführt.

ERR : Wird TRUE, sobald ein Fehler eintritt.

ERRID : Liefert bei einem gesetzten ERR-Ausgang die Fehlernummer.

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2016 oder höher (R2) | PC (i386) | Sekunden USV | TcSUPS.Lib


FUNCTION F_GetVersionTcSUPS

Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.

FUNCTION F_GetVersionTcSUPS : UINT

VAR_INPUT
    nVersionElement : INT;
END_VAR

nVersionElement : Versionselement, das gelesen werden soll. Mögliche Parameter:

  • 1 : major number;
  • 2 : minor number;
  • 3 : revision number;
Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2016 oder höher (R2) | PC (i386) | Sekunden USV | TcSUPS.Lib


TYPE E_S_UPS_Mode

eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten und dann QuickShutdown

eSUPS_WrPersistData_NoShutdown: Nur Schreiben der Persistenten Daten (kein QuickShutdown)

eSUPS_ImmediateShutdown: Nur QuickShutdown (kein Schreiben der Persistenten Daten)

eSUPS_CheckPowerStatus: Nur Status ermitteln (weder Schreiben der Persistenten Daten noch QuickShutdown)

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2016 oder höher (R2) | PC (i386) | Sekunden USV | TcSUPS.Lib


TYPE E_S_UPS_State

eSUPS_PowerOK:
    in allen Modi: Versorgungsspannung ist OK

eSUPS_PowerFailure:
    in allen Modi: Versorgungsspannung fehlerhaft (steht nur einen Zyklus an)

eSUPS_WritePersistentData:
    im Modus eSUPS_WrPersistData_Shutdown: Schreiben der Persistenten Daten ist aktiv
    im Modus eSUPS_WrPersistData_NoShutdown: Schreiben der Persistenten Daten ist aktiv

eSUPS_QuickShutdown:
    im Modus eSUPS_WrPersistData_Shutdown: QuickShutdown ist aktiv
    im Modus eSUPS_ImmediateShutdown: QuickShutdown ist aktiv

eSUPS_WaitForRecover:
    im Modus eSUPS_WrPersistData_NoShutdown: Warten auf Wiederkehr der Spannung
    im Modus eSUPS_CheckPowerStatus: Warten auf Wiederkehr der Spannung

eSUPS_WaitForPowerOFF:
    im Modus eSUPS_WrPersistData_Shutdown: Warten auf das Abschalten durch die USV
    im Modus eSUPS_ImmediateShutdown: Warten auf das Abschalten durch die USV

Entwicklungsumgebung | Zielplattform | Hardware | Einzubindende SPS Bibliotheken
TwinCAT v2.11.0 Build 2016 oder höher (R2) | PC (i386) | Sekunden USV | TcSUPS.Lib


CX50x0 - Auspacken, Aufstellung und Transport

BECKHOFF CX50x0: Montage und Verdrahtung

Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Abmessungen (H x B x T): 100 x 102 x 92 mm

Gewicht: 575 g (Grundmodul)

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:

  1. Entfernen Sie die Verpackung.
  2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Weitertransport auf.
  3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
  4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
  5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
  6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung 		Beschädigungsgefahr des Gerätes!
Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung).

Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


CX50x0 - Abmessungen

BECKHOFF CX50x0: Montage und Verdrahtung

Abmessungen

Die folgenden Zeichnungen zeigen die Abmessungen der CX50x0 Geräte.

Abmessungen

Rückansicht


CX50x0 - Montage auf der Tragschiene

BECKHOFF CX50x0: Montage und Verdrahtung

Montage auf der Tragschiene

Aufrasten auf die Tragschiene

Der CX50x0 kann einfach auf die Tragschiene aufgerastet werden. Dazu wird der Block einfach frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Die wird durch ein vernehmliches Klicken angezeigt. Mit einem Schraubendreher wird dann die Arretierung auf der linken Seite nach oben gedrückt wodurch sich die Arretierung dreht und ebenfall hörbar einrastet.

Achtung 		Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Einbaulage

Achtung 		Zulässige Einbaulage und Mindestabstände einhalten!
Das auf eine Hutschiene montierte CPU-Modul darf nur bis Umgebungstemperaturen von 55°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die Bilder zeigen die erlaubte sowie zwei verbotene Einbaulagen.

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX50x0 Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU-Grundmoduls und des Netzteils zu erreichen.

Aufgrund der hohen Leistung und der kompakten Bauform des CX50x0-Systems kann es zu einer erhöhten Wärmeentwicklung kommen. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Daher muss das System waagerecht montiert werden. Auf diese Weise kommt ein optimaler Luftstrom zustande.

Unzulässige Einbaulagen

Es ist nicht zulässig das CX50x0-System senkrecht auf der Hutschiene zu betreiben. Es ist dann keine ausreichende Belüftung für die CPU gewährleistet, da sich die Belüftungsöffnungen auf der Gehäuseober- und Gehäuseunterseite befinden. Auch in liegender Position ist das System nicht ausreichend belüftet.


CX50x0 - Spannungsversorgung

BECKHOFF CX50x0: Produktübersicht

Spannungsversorgung

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den Klemmbus und die Busklemmen mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff. Da der Klemmbus (K- und E-Bus) nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.

Anforderungen an das 24V Netzteil

Um in allen Fällen den Betrieb der CPU (CX50x0-Modul) und des Klemmenstrangs zu gewährleisten muss das Netzteil 4A bei 24V liefern.

Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Leitungsquerschnitt | 0,5 ... 2,5 mm2 | AWG 20 .. AWG 14
Abisolierlänge | 8 ... 9 mm | 0.33 inch

LED

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün auf. Die linke LED (Us) zeigt die Versorgung der CPU an. Die rechte LED (Up) zeigt die Versorgung der Klemmen an. Die weiteren LEDs beschreiben den Status des Klemmbusses. Die detaillierte Beschreibung der LEDs ist in dem Kapitel Fehleranalyse der LEDs beschrieben.

UL-Anforderungen

Gefahr

Zur Einhaltung der UL-Anforderungen dürfen die CX-Controller nur nur mit Versorgungsspannungen (24 VDC) versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammen.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!

Diese UL-Anforderungen gelten für alle Versorgungsspannungen der CX-Controller!

Zur Einhaltung der UL-Anforderungen dürfen die CX-Controller nicht mit unbegrenzten Spannungsquellen verbunden werden!

PE-Powerkontakte

Achtung 		Powerkontakt "PE"
Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden."PE" und "0V" (24V Systemversorgung) müssen auf dem gleichen Potential liegen.(im Schaltschrank verbunden)

Die Verkabelung im Schaltschrank muss gemäß der Norm EN 60204-1:2006 Schutzkleinspannungen (PELV = Protective Extra Low Voltage) erfolgen.

EN 60204-1:2006 Abschnitt 6.4.1:

b): Eine Seite des Stromkreises oder ein Punkt der Energiequelle dieses Stromkreises muss an da Schutzleitersystem angeschlossen werden.

Achtung 		Unterbrechung der Stromversorgung / Abschalten
Zum Abschalten des Gerätes darf nicht die Masse getrennt werden. Es muss immer die 24V Leitung getrennt werden da sonst unter Umständen je nach Gerät der Strom über den Schirm weiterfließt.

Evtl. angeschlossene Geräte mit eigener Stromversorgung (z.B. ein Panel) müssen für "PE" und "GND" das gleiche Potential wie das CX-System haben.(keine Potentialdifferenz) Andernfalls können Schäden sowohl an der Steuerung also auch an der Peripherie auftreten.


CX50x0 - Spannungsversorgung

BECKHOFF CX50x0: Produktübersicht

Montage von passiven Klemmen am Netzteil CX50x0

Hinweis 		Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus.
Um einen optimalen Datenaustausch zu gewährleisten, dürfen diese nicht direkt an das Netzteil angereiht werden!
Beispiele für Montage von passiven Klemmen (dunkel eingefärbt):

Die folgende Zeichnung stellt die unzulässige Montage dar:

Die folgende Abbildung zeigt die korrekte Montage der passiven Klemme:


CX50x0 - DVI-D-Anschluss

BECKHOFF CX50x0: Produktübersicht

DVI-D-Anschluss

DVI-D-Anschluss (X200)

Die DVI-D Schnittstelle überträgt digitale Daten und eignet sich für den Anschluss an digitale Displays. Die Auflösung am Bildschirm oder Beckhoff Control Panel ist abhängig von der Entfernung zum Anzeigegerät. Die maximale Entfernung beträgt 5 m. Beckhoff bietet verschiedene Panels mit integrierter "DVI-Verlängerung" an. Damit ist eine Kabellänge bis zu 50 Metern möglich.

Hinweis 		DVI-D Schnittstelle
Die DVI Schnittstelle führt keine VGA Signale aus, so dass der Anschluss von CRT-VGA Monitoren an das CX50x0 System unter Verwendung eines DVI-to-VGA Adapters nicht möglich ist.

DVI-D Buchse

Pin | Belegung | Pin | Belegung | Pin | Belegung
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -
Auflösung am Monitor
Auflösung in Pixel | Entfernung der Schnittstelle vom Monitor
1920 x 1200 | 5 m
1600 x 1200 | 5 m
1280 x 1024 | 5 m
1024 x 768 | 5 m
800 x 600 | 5 m
640 x 480 | 5 m


CX50x0 - USB-Anschlüsse

BECKHOFF CX50x0: Produktübersicht

USB-Anschlüsse

USB Schnittstelle (X100 / X101 / X102 / X103):

Die CX50x0 verfügen über 4 unabhängige USB-Schnittstellen. Hier können Tastaturen, Mäuse, Touchscreens und andere Eingabegeräte sowie Datenspeicher angeschlossen werden. Dabei ist aus die Leistungsaufnahme der einzelnen Geräte zu achten: Es können pro Port nicht mehr als 500 mA abgegeben werden.

Die USB Buchse ist vom Typ A. Die USB Schnittstelle entspricht der USB 2.0 Spezifikation.

Pin | Belegung | Typische Zuordnung
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


CX50x0 - LAN-Anschlüsse

BECKHOFF CX50x0: Produktübersicht

LAN-Anschlüsse

LAN Schnittstelle (X000/ X001)

Die CX50x0 Systeme verfügen über 2 unabhängige LAN-Schnittstellen. Beide Ports sind in der Lage Geschwindigkeiten von 10 / 100 / 1000 MBit zu bedienen. Die LEDs an den linken Seiten der RJ45-Buchsen zeigen den Status der LANverbindung an. Die obere LED zeigt an ob der Port mit einem Netzwerk verbunden ist. Ist dies der Fall leuchtet die LED gelb auf. Wenn Datenverkehr auf den Port stattfindet, blinkt die LED. Die untere LED zeigt die Geschwindigkeit der Verbindung an. Ist die Geschwindigkeit 10 oder 100 MBit leuchtet die LED grün. Im Modus 1000 Mbit (Gigabit) leuchtet die LED rot.

Belegung der RJ45-Schnittstelle, Port 1 (X000)

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

Belegung der RJ45-Schnittstelle, Port 2 (X001)

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

Hinweis 		Unabhängigkeit der Ports
Beide Ports sind von einander unabhängig. Anders als bei den CX-System CX1020 und CX9000 ist kein Switch integriert. Für eine Linientopologie ist ein zusätzlicher4 Switch erforderlich. Die unabhängigen Ports lassen sich unterschiedlich konfigurieren:
  • Der obere Port (1) ist als Gigabit IT-Port,
  • Der untere Port (2) ist für EtherCAT-Kommunikation

im Auslieferzustand konfiguriert.


CX50x0 - RS232-Anschlüsse

BECKHOFF CX50x0: Produktübersicht

RS232- Anschlüsse (CX50x0-N030)

Die Systemschnittstelle CX50x0-N030 stellt eine RS232 Schnittstellen, COM1 (X300), bereit. Sie ist auf einer 9-poligen Sub-D Stiftleiste ausgeführt. Sollten mehr als eine Schnittstelle benötigt werden, so kann das System über den Klemmbus (K- oder E-Bus) Busklemmen (KL/EL6001), die serielle Schnittstellen bereitstellen erweitert werden. Die Pinbelegung wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle RS232 (Stecker)

Pinbelegung COM Schnittstelle

PIN | Signal | Typ | Beschreibung
1 | DCD | Signal in | Data Carrier Detected
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground
6 | DSR | Signal in | Dataset Ready
7 | RTS | Signal out | Request to Send
8 | CTS | Signal in | Clear to Send
9 | RI | Signal in | Ring Indicator


CX50x0: RS422/RS485-Anschlüsse

BECKHOFF CX50x0: Produktübersicht

RS422/RS485-Anschlüsse (CX50x0-N031)

Die Systemschnittstelle CX50x0-N030 stellt eine RS422 bzw. RS 485 Schnittstelle, COM1 (X300), bereit. Sie ist auf einer 9-poligen Sub-D Buchsenleiste ausgeführt. Sollte mehr als eine Schnittstelle benötigt werden, so kann das System über den Klemmbus (K- oder E-Bus) Busklemmen (KL/EL6021), die serielle Schnittstellen bereitstellen erweitert werden. Die Pinbelegung wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle (Buchse)

Pinbelegung COM Schnittstelle

PIN | Signal | Typ | Beschreibung
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

Für RS 485 muss Pin 2 und 3 ( Data +) sowie Pin7 und 8 (Data -) verbunden werden.

Einstellung der Schnittstellen Parameter

Die Schnittstelle ist im Auslieferzustand wie folgt parametriert:

RS485 ohne Echo, End-Point ( Terminiert) Standardeinstellung

Funktion | Status
Echo on | aus
Echo off | an
Auto send on | an
Always send on | aus
Auto receive on | an
Always receive on | aus
Term on | an
Term on | an
Hinweis | Änderung der Schnittstellenparameter
 | Sollten andere Parameter als die eingestellten benötigt werden, wenden Sie sich bitte an der Service


CX50x0 - EtherCAT-Kabel-Redundanz

BECKHOFF CX50x0: EtherCAT-Kabelredundanz

EtherCAT-Kabel-Redundanz

Durch die zwei unabhängigen Ethernetports lässt sich bei den CX50x0-Systemen Kabelredundanz für EtherCAT realisieren. Dazu wird mindestens folgendes benötigt:

  1. Supplement EtherCAT-Redundanz
  2. EK1110 (Busverlängerung)
  3. EK1100 (Buskoppler)

Das Supplement Produkt kann auf der Webseite von Beckhoff unter

http://download.beckhoff.com/download/Software/TwinCAT/TwinCAT2/Supplement/TwinCAT_EtherCAT_Redundancy/Install/TcEcRedundancy.exe

heruntergeladen werden. Der benötigte Lizenzschlüssel kann über unseren Vertrieb bestellt werden. Die benötigten Koppler werden zusammen mit der anderen Hardware bestellt. Daraus lässt sich dann die Steuerung aufbauen. Das obere Bild zeigt ein minimales Beispiel für die Kabelredundanz. Ist die Hardware verkabelt und in Betrieb genommen, so muss man das Supplement auf dem Gerät installieren. Dies kann z.B. über einen USB-Stick oder das IT-Netzwerk erfolgen. Bei der Installation wird dann auch der Lizenzschlüssel abgefragt. Im Systemmanager kann man die Einstellung für Kabelredundanz vornehmen. Dazu wird zunächst die Klemmenkonfiguration eingelesen. Dann kann man unter den Eigenschaften für das EtherCAT-Device unter dem Reiter "EtherCAT" die Schaltfläche "Advanced Settings" auswählen. Hier wird dann unter dem Menü "Redundancy" der zweite Adapter eingestellt. Über den Button "Search" öffnet sich das Auswahl Menü. Für den unteren Netzwerkanschluss (X001) wählt man "Local Area Connection 2 (Intel(R).....)" aus. Mit dem Bestätigen der Auswahl durch Klicken auf "OK" ist die Konfiguration abgeschlossen.

Hinweis 		Das Supplement unterstützt nur KABELREDUNDANZ

Dieses Supplement unterstützt nur Kabelredundanz. Das bedeutet, dass Ausfallsicherheit nur für die Kabelstrecken besteht. Das bedeutet Verbindungen zwischen den Kopplern.
Ausfälle von einzelnen Klemmen können auf diese Weise nicht abgefangen werden.

Allgemeine Details können Sie im Beckhoff Information System unter EtherCAT Kabelredundanz nachlesen.

Fehlerfälle

Die beiden möglichen Ausfälle in dem Beispiel werden im Folgenden gezeigt.

Hier ist die Zuleitung zum Koppler EK1100 gestört. Trotz des Kabelausfalls laufen die Klemmen am EK1100 weiter. Im System Manager sieht der Ausfall dann wie folgt aus:

Die Unterbrechung wird durch "LNK_MIS B" und "LNK_MIS A" angezeigt.

Das nächste Beispiel zeigt den Ausfall der "Rückleitung":

Hier die die zweite Leitung gestört. Die Klemmen am Koppler laufen ohne Störung weiter. Im System Manager sieht das Verhalten dann wie folgt aus:

Die Unterbrechung wird durch "LNK_MIS C" Beim Koppler EK1100 angezeigt.

Der EtherCAT-Ring lässt sich beliebig erweitern. Die Anzahl der Ringteilnehmer ist durch die Lizenzen gestaffelt: bis 250, bis 1000, mehr als 1000. Es kann aber bei einem Master nur eine Bruchstelle überbrückt werden. Bei zwei Bruchstellen laufen die Ringteile von beiden Seiten bis zu den Bruchstellen weiter.


CX50x0: Ein- und Ausschalten

BECKHOFF CX50x0: Inbetriebnahme

Ein- und Ausschalten

Einschalten

Die Stromversorgung des CPU Grundmoduls erfolgt über das Netzteil. Beim Anschluss des Netzteils an die Stromversorgung startet das CPU Grundmodul automatisch.

Erstes Einschalten

Wenn Sie den PC das erste Mal einschalten, wird das vorinstallierte Betriebssystem (optional) gestartet.

Ausschalten

Beim Ausschalten der Stromversorgung des Netzteils wird auch der Embedded-PC ausgeschaltet. Die laufende Steuerungssoftware, wie sie typischerweise auf Embedded-PCs eingesetzt wird, sollte ordnungsgemäß angehalten bzw. beendet werden. Ein Benutzer, der die Software nicht beenden darf, darf auch nicht den Embedded-PC abschalten, weil durch Abschalten bei laufender Software Daten auf der Festplatte verloren gehen können.

Ist die Software angehalten, kann das Betriebssystem heruntergefahren werden. Erst dann sollte die Stromversorgung unterbrochen werden.


CX50x0: BIOS-Einstellungen: BIOS Setup

BECKHOFF CX50x0: BIOS Setup

Bemerkung zur Benutzung des Setup

Achtung 		Änderungen der Einstellungen in BIOS dürfen nur von Fachkundigem Personal durchgeführt werden.
Die CX50x0-System werden von der Beckhoff Automation GmbH in vorkonfiguriertem Zustand ausgeliefert und sind so Betriebsbereit!

Einstellungen am BIOS dürfen nur von fachkundigem Personal durchgeführt werden.

Für den Betrieb mit Windows CE wird ganz von Änderungen im BIOS abgeraten, da das Betriebsystem an die Hardwarekonfiguration angepasst ist. Ein Ändern der Adressen oder Interrupts führt zu instabilem Laufverhalten bzw. zum Absturz des Systems.

Innerhalb der einzelnen Setup-Seiten werden mit F6 für Fail-Safe Defaults und F7 für Optimized Defaults Standard-Werte für die einzelnen Setup-Einträge geladen. Diese Standard-Werte sind unabhängig davon, ob das Board schon mal mit einer Setup-Einstellung erfolgreich gebootet hat. Anders ist es, wenn diese Defaults aus dem TOP-Menü aufgerufen werden. Wurde bereits einmal eine Setup-Einstellung abgespeichert, die im Anschluss auch zu einem erfolgreichem Booten führte, so werden mit beiden Menü-Punkten diese Werte als Default für die Setup-Seiten geladen. Siehe dazu auch die Kapitel Load Fail-Safe Defaults und Load Optimized Defaults.

Top Menu

Phoenix – AwardBIOS CMOS Setup Utility

► Standard CMOS Features | ► Frequency/Voltage Control
► Advanced BIOS Features | Load Fail-Save Defaults
► Advanced Chipset Features | Load Optimized Defaults
► Integrated Peripherals | Set Passwort
► Power Management Setup | Save & Exit Setup
► PnP/PCI Configuration | Exit Without Saving
► PC Health Status |
ESC: Quit ↑ ↓ → ← Select Item F10: Save & Exit Setup
"Kurzbeschreibung der oben selektierten Funktion"

Ein „►“ Zeichen vor dem Menüpunkt bedeutet, dass ein Untermenü vorhanden ist. Das „x“ Zeichen vor einem Menüpunkt heißt, dass es eine Einstellmöglichkeit gibt, die jedoch erst durch eine darüber
liegende Einstellung aktiviert werden muss.

Load Fail-Save Defaults

Diese Option dient der absoluten Sicherheitseinstellung. Unakzeptabel für den Dauerbetrieb, aber gut wenn der PC nicht funktioniert.

Load Optimized Defaults

Mit dieser Option stellen Sie die nach Meinung des Herstellers optimalen Werte ein.

Set Passwort

Hier können Sie das Setup-Passwort eingeben, welches das unberechtigte Aufrufen des BIOS Setup verhindert.

Save & Exit Setup

Wenn die Einstellungen gespeichert und das Setup beendet werden soll. Eingabe: Y (Achtung: bei deutscher Tastatur Z eingeben).

Exit Without Saving

Setup beenden ohne Sicherung der Einstellungen. Einstellung: Y (Achtung: bei deutscher Tastatur Z eingeben).


CX50x0: BIOS-Einstellungen - Standard CMOS Features

BECKHOFF CX50x0: BIOS Setup

Standard CMOS Features

In diesem Menü werden Datum, Uhrzeit, Festplatten, Graphikmodus und Startverhalten eingestellt. Gleichzeitig wird Auskunft über den vom System ermittelten Speicherausbau gegeben. Die Angaben für den Speicherausbau sind daher auch nicht veränderbar. Die Eingaben für Datum, Zeit, Graphikmodus und Startverhalten können in der unten beschriebenen Weise eingegeben werden. Für das Einstellen der Festplattendaten wird ein neues Menu geöffnet.

Phoenix – AwardBIOS CMOS Setup Utility

Standard CMOS Features

Date (mm:dd:yy) | Wed, Jun 30 2010 | Item Help
Time (hh:mm:ss) | 11 : 11 : 00 |
► IDE Channel 0 Master | [ None] |
► IDE Channel 0 Slave | [ None] |
Halt On | [All, But Keyboard] |
Base Memory | 639K |
Extended Memory | 514048K |
Total Memory | 515072K |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Date (mm:dd:yy) Datum

Optionen:

  • mm … Monat

  • dd … Tag

  • yy … Jahr

Time (hh:mm:ss) Uhrzeit

Optionen:

  • hh … Stunden

  • mm … Minuten

  • ss … Sekunden

Halt On

Hier kann das Booten des Systems angehalten werden, wenn Fehler auftreten. Dabei können Fehler ignoriert werden. Diese lassen sich in diesem Menupunkt einstellen.

Optionen:

  • All Errors (bei jeder Art von Fehler anhalten)

  • No Errors (alle Fehler ignorieren und den Systemstart fortsetzen)

  • All , But Keyboard (fehlende Tastatur wird ignoriert)

Base Memory

Hier wird der konventionelle Speicher (0 KByte bis 640 KByte) zur Information, ob er vom POST erkannt wurde, angezeigt.

Extended Memory

Angabe des verfügbaren Speichers vom ersten MB bis zum maximalen Speicherausbau.

Total Memory

Dies ist die Summe aus Base Memory, Extended Memory und Other Memory.


CX50x0-BIOS - IDE Primary Master

BECKHOFF CX50x0: BIOS Setup

IDE Primary Master

In diesem Menü werden die Daten der an den ersten IDE-Bus als Master angeschlossenen Festplatte eingestellt. Die Daten der Festplatte, Größe, Anzahl der Cylinder, Köpfe, Sektoren, die Vorkompensation sowie die Parkposition der Köpfe beim Ausschalten der Platte, werden automatisch für die erkannte Festplatte angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

IDE Primary Master

IDE HDD Auto-Detection | [Press Enter] | Item Help
IDE Channel 0 Master | [Auto] |
Access Mode | [Auto] |
Capacity | 0 MB |
Cylinder |  |
Head | 0 |
Precomp | 0 |
Landing Zone | 0 |
Sector | 0 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IDE HDD Auto-Detection

Hier wird mit dem Drücken der <Enter>-Taste die automatische Erkennung der Festplatte gestartet. Nach einigen Sekunden sollten die physikalischen Daten der angeschlossenen Festplatte im unteren Bereich des Menus angezeigt werden.

IDE Channel 0 Master

Hier wird die Einstellung für den IDE-Bus durchgeführt. Man hat folgende Optionen:

  • None (für keine Festplatte an diesem Bus-Anschluss angeschlossen)

  • Auto (Beim Booten wird jedes Mal ein Auto-Detecion durchgeführt)

  • Manual (Es wird die Festplatte mit den eingestellten Parametern angesprochen)

Access Mode

Unter dieser Option können das Betriebssystem für die Festplatte auswählen. Einstellmöglichkeiten: CHS, LBA, LARGE, und Auto. Empfehlenswert ist die Einstellung Auto. Der Normal (Standard) - Modus unterstützt Festplatten bis zu 528MB oder darunter. Dieser Modus verwendet zum Datenzugriff direkt Positionen, die von Cylinders (CYLS), Heads, und Sectors angegeben werden. Der ältere LBA (Logical Block Addressing) Modus kann Festplatten von bis zu 8.4GB unterstützen. Dieser Modus wendet eine andere Methode zur Berechnung der Position von Disk-Daten, auf die zugegriffen werden soll. Er übersetzt Zylinder (Cylinder), Köpfe und Sektoren in eine logische Adresse, an der sich Daten befinden. Große Festplatten unterstützen diesen Modus. Das BIOS unterstützt die INT 13h Erweiterungsfunktion, die es dem LBA-Modus ermöglicht, Festplattenlaufwerke über 8.4GB zu verwalten. Wenn die Anzahl der Zylinder (CYLs) der Festplatte 1024 überschreitet und DOS sie nicht unterstützen kann, oder wenn Ihr Betriebsystem den LBA Modus nicht unterstützt, sollten Sie den Modus LARGE wählen. Hier wird der Zugriffsmodus für die Festplatte eingestellt:

  • CHS

  • LBA

  • LARGE

  • Auto

Die folgenden Parameter werden automatisch ermittelt und angezeigt.

Capacity

Speicherkapazität der Festplatte. Aus den einzelnen Parametern der Festplatte wird dieser Wert errechnet.

Cylinder

Zylinderzahl, Einstellung oder definieren. Sie variiert je nach BIOS-Version und Hersteller zwischen 1.024 und 16.384 Zylindern.

Head

Anzahl der Köpfe einstellen oder zu definieren. Die Anzahl reicht von 1 bis 16 Köpfe.

Precomp

Schreibvorausgleich, für ältere Festplatten nötig. Hier wird der Zylinder angegeben, ab dem mit einem Unterschied in der Informationsdichte zu rechnen ist.

Landing Zone

Hier wird die Landzone, der sogenannte Parkzylinder definiert. An dieser Position setzt der Festplattenkopf auf, wenn der Festplattenmotor abgestellt wird.

Sector

Sektoren pro Spur, Einstellung oder definieren. Bis zu 63, bei Phoenix bis zu 64 Sektoren werden unterstützt.


CX50x0-BIOS - IDE Primary Slave

BECKHOFF CX50x0: BIOS Setup

IDE Primary Slave

In diesem Menü werden die Daten der an den ersten IDE-Bus als Master angeschlossenen Festplatte eingestellt. Die Daten der Festplatte, Größe, Anzahl der Cylinder, Köpfe, Sektoren, die Vorkompensation sowie die Parkposition der Köpfe beim Ausschalten der Platte, werden automatisch für die erkannte Festplatte angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

IDE Primary Slave

IDE HDD Auto-Detection | [Press Enter] | Item Help
IDE Channel 0 Slave | [Auto] |
Access Mode | [Auto] |
Capacity | 0 MB |
Cylinder |  |
Head | 0 |
Precomp | 0 |
Landing Zone | 0 |
Sector | 0 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IDE HDD Auto-Detection:

Hier wird mit dem Drücken der <Enter>-Taste die automatische Erkennung der Festplatte gestartet. Nach einigen Sekunden sollten die physikalischen Daten der angeschlossenen Festplatte im unteren Bereich des Menus angezeigt werden.

IDE Primary Master:

Hier wird die Einstellung für den IDE-Bus durchgeführt. Man hat folgende Optionen:

  • None (für keine Festplatte an diesem Bus-Anschluss angeschlossen)

  • Auto (Beim Booten wird jedes Mal ein Auto-Detecion durchgeführt)

  • Manual (Es wird die Festplatte mit den eingestellten Parametern angesprochen)

Access Mode:

Unter dieser Option können das Betriebssystem für die Festplatte auswählen. Einstellmöglichkeiten: CHS, LBA, LARGE, und Auto. Empfehlenswert ist die Einstellung Auto. Der Normal (Standard) - Modus unterstützt Festplatten bis zu 528MB oder darunter. Dieser Modus verwendet zum Datenzugriff direkt Positionen, die von Cylinders (CYLS), Heads, und Sectors angegeben werden. Der ältere LBA (Logical Block Addressing) Modus kann Festplatten von bis zu 8.4GB unterstützen. Dieser Modus wendet eine andere Methode zur Berechnung der Position von Disk-Daten, auf die zugegriffen werden soll. Er übersetzt Zylinder (Cylinder), Köpfe und Sektoren in eine logische Adresse, an der sich Daten befinden. Große Festplatten unterstützen diesen Modus. Das BIOS unterstützt die INT 13h Erweiterungsfunktion, die es dem LBA-Modus ermöglicht, Festplattenlaufwerke über 8.4GB zu verwalten. Wenn die Anzahl der Zylinder (CYLs) der Festplatte 1024 überschreitet und DOS sie nicht unterstützen kann, oder wenn Ihr Betriebsystem den LBA Modus nicht unterstützt, sollten Sie den Modus LARGE wählen. Hier wird der Zugriffsmodus für die Festplatte eingestellt:

  • CHS

  • LBA

  • LARGE

  • Auto

Die folgenden Parameter werden automatisch ermittelt und angezeigt.

Capacity

Speicherkapazität der Festplatte. Aus den einzelnen Parametern der Festplatte wird dieser Wert errechnet.

Cylinder

Zylinderzahl, Einstellung oder definieren. Sie variiert je nach BIOS-Version und Hersteller zwischen 1.024 und 16.384 Zylindern.

Head

Anzahl der Köpfe einstellen oder zu definieren. Die Anzahl reicht von 1 bis 16 Köpfe.

Precomp

Schreibvorausgleich, für ältere Festplatten nötig. Hier wird der Zylinder angegeben, ab dem mit einem Unterschied in der Informationsdichte zu rechnen ist.

Landing Zone

Hier wird die Landzone, der sogenannte Parkzylinder definiert. An dieser Position setzt der Festplattenkopf auf, wenn der Festplattenmotor abgestellt wird.

Sector

Sektoren pro Spur, Einstellung oder definieren. Bis zu 63, bei Phoenix bis zu 64 Sektoren werden unterstützt.


CX50x0: BIOS-Einstellungen - Advanved BIOS Features

BECKHOFF CX50x0: BIOS Setup

Advanced BIOS Features

In diesem Menü werden die Daten der an den ersten IDE-Bus als Master angeschlossenen Festplatte eingestellt. Die Daten der Festplatte, Größe, Anzahl der Cylinder, Köpfe, Sektoren, die Vorkompensation sowie die Parkposition der Köpfe beim Ausschalten der Platte, werden automatisch für die erkannte Festplatte angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

Advanced BIOS Features

► CPU Feature | [Press Enter] | Item Help
► Hard Disk Boot Priority | [Press Enter] |
CPU L1 & L2 Cache | [Enabled] |
Hyper Threading Technology | Enabled |
Quick Power On Self Test | [Enabled] |
First Boot Device | [Harddisk] |
Second Boot Device | [LS120] |
Third Boot Device | [LS120] |
Boot Other Device | [Enabled] |
Boot Up NumLock Status | [On] |
Gate A20 Option | [Fast] |
Typematic Rate Setting | [Disabled] |
Typematic Rate (Chars/Sec) | 6 |
Typmatic Delay (Msec) | 250 |
Security Option | [Setup] |
APIC Mode | Enabled |
MPS Version Control For OS | [1.4] |
OS Select For DRAM > 64 MB | [Non-OS2] |
HDD S.M.A.R.T. Capability | [Enabled] |
Full Screen Logo | [Disabled] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

CPU Feature

Unter diesem Menupunkt können Einstellungen zum Verhalten der CPU bei thermischen Profilen gemacht werden.

Virus Warning

Beim Start werden die Bootsektoren auf Veränderungen gegenüber dem letzten Start geprüft. Einstellmöglichkeiten: Enabled (ggf. wird eine Viruswarnung ausgegeben, bis sie mit Confirm bestätigt, bzw. ausgeschaltet (Disabled) wird), Confirm (Eine gewünschte Änderung im Bootsektor z.B. durch Neuinstallation eines Betriebssystems wird bestätigt.), Disabled (Es erfolgt keine Überprüfung der Bootsektoren.).

CPU L1 & L2 Cache

Cache-Speicher ist zusätzlicher Speicher, der wesentlich schneller ist als der konventionelle DRAM (System-Speicher). Wenn die CPU Daten anfordert, überträgt das System die angeforderten Daten vom Haupt-DRAM in den Cache-Speicher, damit die CPU noch schneller darauf zugreifen kann. Einstellmöglichkeiten: Enabled (Standard) Cache aktiviert, Disabled Cache deaktiviert.

Quick Power On Self Test

Wenn Sie diese Option eingeschaltet (Enabled) haben, startet der Rechner deutlich schneller. Sie können bis zu 50 Sekunden beim Booten einsparen, wenn Sie 64 MB RAM oder mehr Speicher haben. Es werden dabei allerdings nicht alle Tests des POST durchlaufen.

First Boot Device

Hier legen Sie fest welches Laufwerk als erstes gebootet werden soll. Stellen Sie das Laufwerk erstes ein, welches als Bootlaufwerk dienen soll. Optionen:

  • LS120 (LS-Drive)

  • Hard Disk

  • CDROM (CD-Laufwerk)

  • ZIP100 (Zip-Drive)

  • USB-FDD (USB-Floppy)

  • USB-ZIP (USB Zip-Drive)

  • USB-CDROM (USB CDROM)

  • Legacy LAN (Netzwerk)

  • WIN CE

  • Disabled (abgeschaltet)

Second Boot Device

Kann von dem ersten Bootmedium nicht gebootet werden, so wird diese Einstellung zum Booten verwendet. Stellen Sie das Laufwerk erstes ein, welches als Bootlaufwerk dienen soll. Optionen:

  • S120 (LS-Drive)

  • Hard Disk

  • CDROM (CD-Laufwerk)

  • ZIP100 (Zip-Drive)

  • USB-FDD (USB-Floppy)

  • USB-ZIP (USB Zip-Drive)

  • USB-CDROM (USB CDROM)

  • Legacy LAN (Netzwerk)

  • WIN CE

  • Disabled (abgeschaltet)

Third Boot Device

Kann von den ersten beiden Bootmedium nicht gebootet werden, so wird diese Einstellung zum Booten verwendet. Stellen Sie das Laufwerk erstes ein, welches als Bootlaufwerk dienen soll. Optionen:

  • S120 (LS-Drive)

  • Hard Disk

  • CDROM (CD-Laufwerk)

  • ZIP100 (Zip-Drive)

  • USB-FDD (USB-Floppy)

  • USB-ZIP (USB Zip-Drive)

  • USB-CDROM (USB CDROM)

  • Legacy LAN (Netzwerk)

  • WIN CE

  • Disabled (abgeschaltet)

Boot Other Device

Unter dieser Optionen stehen Ihnen zwei Möglichkeiten zur Verfügung: Enabled oder Disabled. Die Standardeinstellung ist Enabled. Die Einstellung Enabled ermöglicht es dem BIOS alle drei Arten, nämlich "First Boot Device", "Second Boot Device" oder "Third Boot Device" auszuprobieren.

Boot Up NumLock Status

Zustand der Zehnertastatur. Bei On ist sie aktiviert und bei Off nicht.

Gate A20 Option

Legt die Art fest, mit der auf den Speicher oberhalb 1MB zugegriffen wird.. Hier sollte Fast stehen, damit der Zugriff durch den Chipsatz aktiviert wird. Bei der Einstellung Normal erfolgt er über den Tastaturcontroller. Auf älteren Rechnern kann diese Option Geschwindigkeit bringen. Der erste 64-K-Block oberhalb von 1 MB kann durch die Adressleitung A20 noch im Standard-Mode adressiert werden. DOS verankert sich dort, wenn Sie DOS=High in die Config.sys eingefügt haben

Typematic Rate Setting

Hier wird festgelegt, ob Sie die Optionen Keyboard Typematic Speed, Delay Before Keys Repeat, Typematic Rate oder Typematic Delay , benutzen können Bei Disabled werden die Werte auf 6 Zeichen pro Sekunde und Tastverzögerung von 250 MSec eingestellt. Die Einstellungen können aber auch im Betriebssystem vorgenommen werden.

Typematic Rate (Chars/Sec)

Festlegung der Wiederholfrequenz der Tastatur bei gedrückter Taste. Es können 6, 8, 10, 12, 15, 20, 24 oder 30 Zeichen/Sekunde ausgewählt werden.

Typmatic Delay (Msec)

Hier wird der Wert eingestellt, wann die Tastenfunktion nach dem Drücken einsetzt. Es können 250, 500, 750 oder 1000 Millisekunden ausgewählt werden.

Security Option

Hier wird die Option festgelegt, für die ein Passwort gilt. Wählen Sie die Option SYSTEM, dann muss beim Hochfahren des PC ein Passwort eingegeben werden. Wählen Sie dagegen die Option SETUP, dann braucht man nur ein Passwort um ins BIOS Setup zu gelangen.

APIC Mode

Hiermit wird der APIC-Contoller (Advanced Programmable Interrupt Controller) ein oder ausgeschaltet. Gemäß der PC2001-Bestimmungen, kann das System im APIC-Mode laufen. Bei eingeschaltetem APIC-Modus stehen erweiterte IRQ Resourcen (je nach Board unterschiedlich) zur Verfügung. Einstellungen: Enabled und Disabled

MPS Version Control For OS

Diese Option legt fest, welche MPS-Version (Multi-Processor Specification) dieses Board anwendet. Einstellmöglichkeiten: 1.1 und 1.4 Wenn Sie ein älteres Betriebssystem verwenden sollten Sie 1.1 einstellen ansonsten auf 1.4 belassen.

OS Select For DRAM > 64 MB

Wer mit OS/2 arbeitet und mehr als 64 MB RAM hat, sollte die Option auf OS/2 stellen.

HDD S.M.A.R.T. Capability

Die Technik S.M.A.R.T. (Self Monitoring Analysis and Reporting Technologie) ist in modernen Festplatten implementiert. Unter anderem kann diese Technik mit entsprechender Software, rechtzeitig Lesprobleme oder Drehzahlprobleme der Festplatte feststellen. Haben Sie die Option aktiviert, dann wird z.B. eine Meldung über einen bevorstehenden Crash ausgegeben. Norton-Utilities ab 3.0 wertet z.B. die Ergebnisse aus.

Full Screen Logo

Mit dieser Option können Sie einstellen, ob beim Booten das Startlogo den ganzen Bildschirm füllt und damit die Startdaten verdeckt. Einstellmöglichkeiten: Enabled, Disabled


CX50x0-BIOS - CPU Features

BECKHOFF CX50x0: BIOS Setup

CPU Features

In diesem Menü werden die Einstellungen für das Verhalten der CPU bei thermischen Profilen eingestellt.

Phoenix – AwardBIOS CMOS Setup Utility

CPU Feature

Thermal Management | Disabled | Item Help
Limit CPUID MaxVal | [Disabled] |
C1E Function | [Disabled] |
CPU C State Capability | [Disabled] |
Execute Disable Bit | [Enabled] |
Virtualization Technology | [Enabled] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Thermal Management

Der verwendete Prozessor hat einen Thermalen Monitor. Dieser ist aber zur Gewährleistung der Echtzeit abgeschaltet.

Limit CPUID MaxVal

Diese Option unterstützt Prescott CPUs bei Einsatz eines älteren Betriebssystems. Enabled: Aktivieren Sie diese Option wenn Sie mit einem älteren Betriebssystem arbeiten. Disabled: Deaktivieren Sie das CPUID Limit wenn Sie mit Windows XP arbeiten.

C1E Function

Diese Einstell-Option steht nur bei bestimmten Prozessoren mit C1E (Enhanced Halt State) Funktion zur Verfügung.

CPU C State Capability

Mit dieser Option kann man den tiefsten C-State der CPU einstellen. Im Regelfall sollte DISABLED ausgewählt werden.

DISABLED: Funktion aus

C2 (STOP Grant): CPU clock ist angehalten, APIC-Funktionen laufen weiterhin mit normaler Geschwindigkeit

C4 (Deeper Sleep): CPU Spannung ist reduziert.

C6 (Deep Power Down): CPU Spannung ist bis auf 0 V reduziert.

Execute Disable Bit

Diese Option ist eine Sicherheitseinrichtung, das Ihnen hilft, Ihre CPU und Ihr Betriebssystem gegen arglistige Software zu schützen, die einen Code ausführt der möglicherweise dem BIOS schadet. Diese Option ist nur verfügbar, wenn die CPU dieses Merkmal unterstützt. Einstellmöglichkeiten: Enabled, Disabled.

Virtualization Technology

Diese Option aktiviert oder deaktiviert die zusätzlichen Hardware-Fähigkeiten von Virtualization-Technologie. Intel Virtualization Technology (Codenamen Vanderpool oder Vanderpool Technology) ist die Implementierung einer Secure Virtual Machine seitens Intel. Die AMD Virtualization oder kurz AMD-V (auch unter dem Codenamen "Pacifica" bekannt) ist eine Technik zur Virtualisierung eines Computers und bezeichnet AMDs Implementierung einer Secure Virtual Machine im Zusammenspiel mit einer IOMMU. Einstellmöglichkeiten: Enabled, Disabled.


CX50x0: BIOS-Einstellungen - Hard Disk Boot Priority

BECKHOFF CX50x0: BIOS Setup

Hard Disk Boot Priority

In diesem Menü werden die Einstellungen für die Bootreihenfolge der Harddisks eingestellt. Die Auswahloptionen können ja nach angeschlossenen Geräten variieren.

Phoenix – AwardBIOS CMOS Setup Utility

Hard Disk Boot Priority

1. Ch0 M. | Name | Item Help
2. USB-HDD0 | Name |
. |  |
. |  |
. |  |
n. Bootable Add-in Cards |  |
Boot Priority | [Dynamic] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

1. Ch0 M. / 2. USB-HDD0 / ... / n. Bootable Add-in Cards

Hier wird die Boot-Reihenfolge für die Einstellung HDD festgelegt. <↑>, <↓>, <PU> und <PD> zum Ändern der Bootreihenfolge.

Boot Proirity

Hier wird das Verhalten der Liste eingestellt:

Dynamic: Neu erkannte Geräte werden am Ende an die Liste angehängt.

Manual: Die Prioritätenliste wird gespeichert und solange keine neuen Geräte angeschlossenen werden nicht verändert.

Fixed: Die Bootreihenfolge ist fest: 1. HDD CHx Master 2.HDD CHx Slave 3. USB-HDD Geräte


CX50x0: BIOS-Einstellungen - Advanced Chipset Features

BECKHOFF CX50x0: BIOS Setup

Advanced Chiset Features

In diesem Menü können Einstellungen zu den Funktionen des Speichers gemacht werden. Dabei sollte vorsichtig vorgegangen werden, da Einstellungen hier die Stabilität des Gesamtsystems beinträchtigen können.

Phoenix – AwardBIOS CMOS Setup Utility

Advanced Chipset Features

DRAM Timing Selectable | [by SPD] | Item Help
System BIOS Cachable | [Enabled] |
Video BIOS Cachable | [Disabled] |
** On-Chip VGA Setting ** |  |
On-Chip Video Memory Size | [128 MB] |
On-Chip Frame Buffer Size | [8 MB] |
Current Configuration | DVO |
Boot Type | DVI |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

DRAM Timing Selectable

Unter diesem Untermenü können Sie das optimale Timing für Optionen ein, je nach den von ihnen benutzten Speichermodulen. Konfiguriert werden die Optionen über die Voreinstellung 'By SPD', indem der Inhalt des SPD (Serial Presence Detect )-Gerätes ausgelesen wird. dabei werden im EEPROM kritische Parameter-Infos zu Speichertyp, Größe, Geschwindigkeit, Spannungsinterface und Modulbänke abgespeichert.

System BIOS Cachable

Bei aktivierter Funktion wird das vorhandene BIOS-ROM durch den Cache-Speicher berücksichtigt und bringt dadurch mehr Performance, aber fast nur noch unter DOS und Win3.x. Unter Windows 95/98 bringt diese Option nicht mehr so viel.

Video BIOS Cachable

Wenn Sie diese Option Enabled haben, kann der Cache-Speicher das VIDEO BIOS der Grafikkarte an der Adresse C0000h bis C7FFFh mit berücksichtigen. Sie sollten aber bedenken, dass das Caching Risiken birgt, falls sich im Cache der Code befindet und ein Programm will in den BIOS-Bereich schreiben. Haben Sie diese Option Enabled, müssen Sie gleichzeitig auch die Option Video BIOS Shadow aktivieren. Geschwindigkeitsvorteil unter DOS etwa 40%. Diese Option sollte unter Win.x und DOS auf Enabled stehen, ansonsten sollte Disabled eingestellt werden.

On-Chip Video Memory Size

Mit dieser Option wird die Größe des Videospeichers eingestellt. (128 MB, 256 MB)

On-Chip Frame Buffer Size

Unter dieser Option können Sie den Frame Buffer anpassen. Diverse Einstellmöglichkeiten. Zur Performanceverbesserung können Sie hier die einzelnen Möglichkeiten austesten. Achten Sie auf Systemstabilität und gehen Sie nur schrittweise vor. (1 MB, 4 MB und 8 MB)

Current Configuration

Hier wird die eingestellte Graphik-Konfiguration angezeigt. Bei diesem Gerät ist sie DVO.

Boot Type

Diese Einstellung zeigt die Ausgabequelle für den Bootvorgang. Da die CX50x0 Geräte graphische Ausgaben nur über DVI-I unterstützen, ist diese Einstellung fest auf DVI gesetzt.


CX50x0: BIOS-Einstellungen - Integrated Peripherals

BECKHOFF CX50x0: BIOS Setup

Integrated Peripherals

In diesem Menü werden die Einstellungen für die Systemschnittstellen vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

Integrated Peripherals

► OnChip IDE Device | [Press Enter] | Item Help
► Onboard Device | [Press Enter] |
► SuperIO Device | [Press Enter] |
► USB Device Setting | [Press Enter] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

OnChip IDE Device

Hier können Sie Einstellungen für den Onboard IDE-Controller vornehmen.

Onboard Device

Hier können Sie Einstellungen für die Audio-, Multimedia- und LAN-Schnittstellen vornehmen.

SuperIO Device

Hier können Sie die Einstellungen für die Seriellen Schnittstellen Port 1 und Port 2 vornehmen.

USB Device Setting

Hier können Sie die Einstellungen für die USB Schnittstellenvornehmen.


CX50x0-BIOS - Onchip IDE Device

BECKHOFF CX50x0: BIOS Setup

Onchip IDE Device

In diesem Menü werden die Einstellungen für die IDE-Schnittstellen vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

Onchip IDE Device

IDE HDD Block Mode | [Enabled] | Item Help
IDE Primary Master PIO | [Auto] |
IDE Primary Slave PIO | [Auto] |
IDE Primary Master UDMA | [Auto] |
IDE Primary Slave UDMA | [Auto] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IDE HDD Block Mode

Mit dieser Option wird der Block-Mode von IDE-Festplatten aktiviert. Falls Ihr LW diesen Modus unterstützt, wird bei Aktivierung dieser Option die Zahl der Blöcke pro Anforderung aus dem Konfigurationssektor der Festplatte ausgelesen. Empfohlene Einstellung ist Enabled, wobei darauf hingewiesen werden muss, dass nur alte Festplatten diesen Modus nicht vertragen.

IDE Primary Master PIO

PIO (Programmed Input/Output) steht für das Konzept der programmierten Ein- und Ausgabe. Statt dass eine Befehlsfolge vom BIOS ausgegeben wird, um eine Datenübertragung von der oder auf die Festplatte zu bewirken, gestattet PIO dem BIOS, dem Controller mitzuteilen, welche Aufgabe ausgeführt werden soll, und überlässt die Ausführung der Aufgabe dann vollständig dem Controller und der CPU. Ihr System unterstützt fünf PIO-Modi, 0 (Standard) bis 4, die sich im Wesentlichen in ihrer Zeitsteuerung unterscheiden. Wenn Sie die Einstellung "Auto" (Automatisch) auswählen, legt das BIOS nach einer Überprüfung Ihres Laufwerks den bestmöglichen PIO-Modus selbst fest. Auto: Das BIOS stellt den Wert für das System je nach Timing Ihres Festplattenlaufwerks automatisch ein. Mode 0-4: Sie können selbst einen Modus auswählen, der sich für das Timing Ihres Festplattenlaufwerks eignet.

IDE Primary Slave PIO

PIO (Programmed Input/Output) steht für das Konzept der programmierten Ein- und Ausgabe. Statt dass eine Befehlsfolge vom BIOS ausgegeben wird, um eine Datenübertragung von der oder auf die Festplatte zu bewirken, gestattet PIO dem BIOS, dem Controller mitzuteilen, welche Aufgabe ausgeführt werden soll, und überlässt die Ausführung der Aufgabe dann vollständig dem Controller und der CPU. Ihr System unterstützt fünf PIO-Modi, 0 (Standard) bis 4, die sich im Wesentlichen in ihrer Zeitsteuerung unterscheiden. Wenn Sie die Einstellung "Auto" (Automatisch) auswählen, legt das BIOS nach einer Überprüfung Ihres Laufwerks den bestmöglichen PIO-Modus selbst fest. Auto: Das BIOS stellt den Wert für das System je nach Timing Ihres Festplattenlaufwerks automatisch ein. Mode 0-4: Sie können selbst einen Modus auswählen, der sich für das Timing Ihres Festplattenlaufwerks eignet.

IDEPrimary Master UDMA

Unter dieser Option nehmen Sie die Einstellungen für den Ultra-DMA/33 Modus Ihrer Festplatte vor. Einstellmöglichkeiten: Auto, Enabled, Disabled. Sie sollten diese Option auf Enabled stellen.

IDE Primary Slave UDMA

Unter dieser Option nehmen Sie die Einstellungen für den Ultra-DMA/33 Modus Ihrer Festplatte vor. Einstellmöglichkeiten: Auto, Enabled, Disabled. Sie sollten diese Option auf Enabled stellen.


CX50x0-BIOS - Onboard Device

BECKHOFF CX50x0: BIOS Setup

Onboard Device

In diesem Menü werden die Einstellungen für die Audio, Multimedia und LAN-Schnittstellen vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

Onboard Device

Intel HD Audio Controller | [Disabled] | Item Help
USB Client Routing | [Disabled] |
SDIO/MMC Controller | [Disabled] |
Onboard Lan Controller | Enabled |
Console Redirect | [Disabled] |
x Serial Port Mode | 115200,8,n,1 |
x After Boot | Enabled |
x Flow Control Signals | Ignore |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Intel HD Audio Controller

Hier kann der interne Audio Controller eingeschaltet werden. Da zur Zeit keine entsprechende Erweiterung implementiert ist, ist diese Funktion ausgeschaltet.

USB Client Routing

Hier kann der zweite USB-Port mit USB-Client-Funktionalität konfiguriert werden.

SDIO/MMC Controller

Hier kann der SDIO / MMC Kontroller ein- bzw. ausgeschaltet werden. In der Regel ist die bei den CX50x0 Geräten die notwendige Hardware nicht bestückt. Daher ist die Funktion abgeschaltet.

Onboard Lan Controller

Die beiden Gigabit-LAN-Port sind immer eingeschaltet.

Console Redirect

Hier kann die Ausgabe des Bootvorgangs auf die serielle Schnittstelle umgeleitet werden. Ist die Funktion eingeschaltet, können die Kommunikationsparameter in den gesperrten Menüs eingestellt werden.

Serial Port Mode

Hier werden Baudrate, Bitanzahl, Parität und Stopbit eingestellt.

After Boot

Hier kann die Konsole auch nach dem Bootvorgang aktiv bleiben. Diese Funktion wird aber nur von wenigen Betriebssystemen unterstützt.

Flow Control Signals

Hier wird die HW-Flow-Kontolle an- bzw. ausgeschaltet.


CX50x0-BIOS - SuperIO Device

BECKHOFF CX50x0: BIOS Setup

SuperIO Device

In diesem Menü werden die Einstellungen für die USB- und Audio-Schnittstellen vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

SuperIO Device

Onboard Serial Port 1 | [3F8/IRQ4] | Item Help
Onboard Serial Port 2 | [2F8/IRQ3] |
UART Mode Select | [Normal] |
RxD, TxD Active | Hi, Lo |
IR Transmission Delay | Enabled |
UR2 Duplex Mode | Half |
Use IR Pins | IR-Rx2Tx2 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Onboard Serial Port1

Konfiguration der seriellen Schnittstelle Einstellungen: IRQ4 (wird verwendet für den ersten seriellen Anschluss), Disabled (es wird kein Interrupt verwendet). Einstellmöglichkeiten: Auto, 3F8/IRQ4, 2F8/IRQ4, 3E8/IRQ4 oder 2E8/IRQ4 .

Onboard Serial Port 2

Konfiguration der seriellen Schnittstelle Einstellungen: IRQ3 (wird verwendet für den zweiten seriellen Anschluss), Disabled (es wird kein Interrupt verwendet). Einstellmöglichkeiten: Auto, 3F8/IRQ3, 2F8/IRQ3, 3E8/IRQ3 oder 2E8/IRQ3.

UART Mode Select

Modus für den Treiber der seriellen Schnittstelle. Einstellmöglichkeiten:

  • Normal für RS-232 serielle Schnittstelle
  • ASKIR für Amplitude keyed shift Schnittstelle für IR-Geräte
  • IrDA für IrDA-Schnittstelle

RxD, TxD Active

Einstellungen können nicht im Standardmodus gemacht werden. Unter dieser Option wird die IR Transmission/Reception als High oder Low eingestellt.

IR Transmission Delay

Haben Sie diese Option aktiviert, so verzögert sich die Übertragung. Einstellmöglichkeiten: Enabled, Disabled.

UR2 Duplex Mode

Diese Option dient der Einstellung für Infrarotgeräte. Einstellmöglichkeiten: Full und Half. Prüfen Sie im IR- Gerätehandbuch nach, welche Einstellung des Duplex-Modus verlangt wird.

Use IR Pins

Diese Option ist identisch mit der Option TxD, RxD Active. Die notwendigen Informationen finden Sie in den Unterlagen zu Ihrem IR-Gerät.


CX50x0-BIOS - USB Device Settimngs

BECKHOFF CX50x0: BIOS Setup

USB Device Settings

In diesem Menü werden die Einstellungen für die USB- und Audio-Schnittstellen vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

Onboard Device

USB 1.0 Controller | [Enabled] | Item Help
USB 2.0 Controller | [Enabled] |
USB Operation Mode | [High Speed] |
USB Keyboard Function | [Enabled] |
USB Storage Function | [Enabled] |
*** USB Mass Storage Device Boor Settings *** |  |
BeckhoffAutomation 2000 | [Auto mode] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

USB 1.0 Controller

Auf dem Board befindet sich ein USB 1.0 Chipsatz mit Unterstützung für USB 1.0. Sie können die Option hier ein- bzw. ausschalten.

USB 2.0 Controller

Auf dem Board befindet sich ein USB 2.0 Chipsatz mit Unterstützung für USB 2.0. Sie können die Option hier ein- bzw. ausschalten.

USB Operation Mode

Hier wird die Transfergeschwindigkeit des USB-Ports eingestellt:

High Speed: Jedes Gerät wird entsprechend der gerätespezifischen Geschwindigkeit verbunden.

Full / Low Speed: Alles Geräte werden mit der Geschwindigkeit 1,5MB/s bzw. 12 MB/s verbunden.

USB Keyboard Function

Sie können hier, wenn vorhanden den USB-Tastaturtreiber des BIOS aktivieren/deaktivieren. Dadurch ist es möglich die USB-Tastatur während des Starts und Hochfahrens des Systems zu bedienen und auch nach dem Hochfahren zu benutzen, wenn Ihr Betriebssystem über keinen USB Treiber verfügt.

USB Storage Function

Sie können hier die Unterstütung für USB-Massenspeicher ein- bzw. ausschalten.

BeckhoffAutoamtion 2000

Diese Funktion ist nur für interne Zwecke bestimmt!


CX50x0: BIOS-Einstellungen - Power Management Setup

BECKHOFF CX50x0: BIOS Setup

Power Management Setup

In diesem Menu können Einstellungen zum Energieverbrauch des Systems gemacht werden.

Phoenix – AwardBIOS CMOS Setup Utility

Power Management Setup

Power-Supply Type | [AT] | Item Help
APCI Function | Enabled |
ACPI Suspend Type | [S1(POS)] |
Soft-Off by PWR-BTTN | [Instant-Off] |
► HPET Feature | [Press Enter] |
► Intel DTS Feature | [Press Enter] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Power-Supply Type

Hier können Sie, den Modu des Netzteils einstellen. Im AT-Modus bleibt das Netzteil eingeschaltet, wenn das System runtergefahren wird. Im ATX-Modus schaltet sich das interne Netzteil der Steuerung ab. Für einen Neustart muss die Spannungsversorgung kurz unterbrochen werden.

APCI Funktion

APCI ist immer eingeschaltet.

ACPI Suspend Type

Bei der ACPI (Advanced Configuration and Power Interface) Option handelt es sich um eine erweiterte PnP und Power Management-Funktion.

S1(POS): Versetzt den PC in den Schlaf. Es werden nur wenige Funktionen ausgeschaltet und diese stehen auf Tastendruck wieder zur Verfügung

S3(STR): Hier wird der aktuelle Zustand des Betriebssystems in den RAM geschrieben und nur dieser wird dann mit Strom versorgt.

Soft-Off by PWR-BTTN

Funktion entfällt, da kein Power-Knopf installiert ist.


CX50x0-BIOS - HPET Powermanagement

BECKHOFF CX50x0: BIOS Setup

HPET Powermanagement

In diesem Menü werden die Einstellungen für den HPET vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

HPET Feature

HPET Support | [Enable] | Item Help
HPET Mode | [32-bit mode] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

HPET Support

Aktiviert oder deaktiviert die HPET-Unterstützung . Hierbei handelt es sich um eine Art Zeitgeber im PC. Er ist in der Lage einen Interrupt mit sehr hoher Präzision auszulösen und andere Programme sind damit in der Lage diverse Anwendungen besser zu synchronisieren. Wenn Sie mit Multimedia Anwendungen arbeiten dann sollten Sie diese Option auf Enabled stellen. Einstellmöglichkeiten: Enabled, Disabled.

HPET Mode

Für den Betrieb stehen zwei Modi zur Verfügung: 32-bit-mode und 64-bit-mode.


CX50x0-BIOS - DTS Powermanagement

BECKHOFF CX50x0: BIOS Setup

DTS Powermanagement

In diesem Menü werden die Einstellungen für die Digitalen-Termo-Sensoren vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

DTS Feature

Intel DTS Funktion | [Enable] | Item Help
DTS Active temperature | [55°C] |
Passive Cooling Trip Point | [95°C] |
Passive TC1 Value | [ 2] |
Passive TC2 Value | [ 2] |
Passive TSP Value | [ 2] |
Critical Trip Point | [POR] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Intel DTS Funktion

Hier wird die Systemkontrolle durch die Thermalsensoren an- bzw. abgeschaltet. Für den Betrieb als Steuerung ist die DTS-Funktion abgeschaltet, da es sonst zu Problemen in der Echtzeit führen kann.

DTS Active temperature

Bei dieser Temperatur schaltet das System den Lüfter ein.

Passive Cooling Trip Point

Bei dieser Temperatur wird die CPU abgebremst um diese zu kühlen.

Passive TC1 Value

Dieser Wert legt die Performance-Reduktion für den TC1 fest.

Die Formel Lautet: DPerformance [%]= _TC1 * ( Tn - Tn-1 ) + _TC2 * (Tn. - Tt)

Passive TC2 Value

Dieser Wert legt die Performance-Reduktion für den TC2 fest..

Die Formel Lautet: DPerformance [%]= _TC1 * ( Tn - Tn-1 ) + _TC2 * (Tn. - Tt)

Passive TSP Value

Hier wird festgelegt wie oft das System die Temperatursensoren auswerten soll. Die Eingabe erfolgt in 10tel Sekunden.

Critical Trip Point

Bei dieser Temperatur wird die CPU abgeschaltet um Schaden zu verhindern.


CX50x0: BIOS-Einstellungen - PnP/PCI Configurations

BECKHOFF CX50x0: BIOS Setup

PnP/PCI Configurations

In diesem Menü werden die Einstellungen für den PCI-Bus und das Plug and Play Management vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

PnP/PCI Configurations

Init Display First | [PCI Slot] | Item Help
Reset Configuartion Data | [Enabled] |
Resources Controlled By | [Manual] |
► IRQ Resources | [Press Enter] |
PCI/VGA Palette Snoop | [Disabled] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Init Display First

Unter dieser Option können Sie einstellen welche Grafikkarte zuerst initialisiert werden soll. Entweder die vom PCI-Slot, Onboard oder PCIEx.

Reset Configuartion Data

Diese Option sorgt dafür, wenn sie eingeschaltet wird, dass das BIOS die Informationen eingebauter Komponenten und deren Ressourcen löscht (Rücksetzung aller Einstellungen) und wieder neu konfiguriert. Einstellmöglichkeiten: Enabled, Disabled.

Resources Controlled By

Legt fest, ob die PnP-Einstellungen per Setup oder automatisch zugewiesen werden. Falls es keine Probleme mit IRQ oder DMA Zuweisungen gibt, sollten Sie Auto einstellen. Default ist Auto.

IRQ Resources

Wenn Sie diese Ressourcen von Hand einstellen, weisen Sie jedem Systeminterrupt einen Typ zu, abhängig vom Typ des Geräts, das den Interrupt verwendet.

PCI/VGA Palette Snoop

Wird von Multimedia-Videokarten verwendet. Je nach Karte muss diese Funktion eingeschaltet (Enabled) werden. Standardmäßig ist sie abgeschaltet.


CX50x0-BIOS - IRQ Resources

BECKHOFF CX50x0: BIOS Setup

IRQ Resources

In diesem Menü können Interrupts für die freie Zuweisung an die PCI-Slots gesperrt werden.

Phoenix – AwardBIOS CMOS Setup Utility

IRQ Resources

IRQ-3 assigned to | [PCI Device] | Item Help
IRQ-4 assigned to | [PCI Device] |
IRQ-5 assigned to | [PCI Device] |
IRQ-7 assigned to | [PCI Device] |
IRQ-9 assigned to | [PCI Device] |
IRQ-10 assigned to | [PCI Device] |
IRQ-11 assigned to | [PCI Device] |
IRQ-12 assigned to | [PCI Device] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IRQ-n assigned to ( n = {3,4,5,7,9,10,11,12,14,15} )

Hier kann ein Interrupt für freie Vergabe gesperrt (reserved) werden. Mit der Einstellung [PCI Device] wird der Interrupt dynamisch vergeben.


CX50x0-BIOS - PC Health Status

BECKHOFF CX50x0: BIOS Setup

PC Health Status

In diesem Menü werden die Einstellungen für die Temperaturen von CPU und Mainboard sowie Spannungsversorgung und Lüfterdrehzahlen angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

PC Health Status

SUSV | [Enabled] | Item Help
SUSV holds USB | [Enabled] |
SUSV Stauts | 100% Cap. / Charging |
On Die Digital Temp. | 47°C |
Temp. Board | 56°C |
Temp DDR | 57°C |
CPU Core | 1.07V |
SCH Core | 1.04V |
CPU VTT | 1.04V |
Memory 1.8 V | 1.80V |
+3.3 V | 3.39V |
+5 V | 5.29V |
+1,5 V | 1,480V |
VBatt | 3.07V |
Fan1 Speed | 0 RPM |
Board Revision | 0 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

SUSV

Hier kann die Sekunden-USV ausgeschaltet werden.

SUSV holds USB

Wenn die SUSV das System puffert, können hier die USB-Port entweder mit versorgt werden oder sie können abgeschaltet werden. Dies ist z.B. wichtig wenn Daten noch auf ein USB-Speichermedium gesichert werden sollen.

SUSV Status

Dieser Wert zeigt den Status der Sekunden-USV an.

n% Cap. (n={0..100}) beschreibt die Kapazität der USV.

State (charging / discharging) beschreibt den Zustand der Sekunden USV.

On Die Digital Temp.

Temperatur im Inneren der CPU.

Temp. Board

Boardtemperatur.

Temp. DDR

Speichertemperatur.

CPU Core

CPU Core Spannung.

SCH Core

CPU VTT Spannung.

CPU VTT

CPU VTT Spannung.

Memory 1.8 V

Spannungsversorgung Speicher mit 1,8 Volt.

+3.3 V

Spannungsversorgung 3,3 Volt.

+5 V

Spannungsversorgung 5 Volt.

+1,5 V

Spannungsversorgung 1,5 Volt.

VBatt

Spannung der Batterie.

Fan1 Speed

0 RPM, da kein Lüfter angeschlossen.

Board Revision

Hardware Version des CPU Boards.


CX50x0-BIOS - Frequency/Voltage Control

BECKHOFF CX50x0: BIOS Setup

Frequency/Voltage Control

In diesem Menü kann das CLK-Setting für den PCI Bus eingestellt werden. Außerdem können die Toleranzen für die Stromversorgung festgelegt werden.

Phoenix – AwardBIOS CMOS Setup Utility

Frequency/Voltage Control

XDP-Clock | [Disabled] | Item Help

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

XDP-Clock

Einstellung ist für interne Zwecke und darf nicht verändert werden.


CX50x0: LEDs des CPU-Grundmoduls

BECKHOFF CX50x0: Fehlerbehandlung und Diagnose

LEDs des CPU-Grundmoduls

Anzeige | LED | Bedeutung
 | PWR | Spannungsversorgung Die Power LED leuchtet bei Anschluss an ein Netzteil mit eingeschalteter Spannungsversorgung (grün) auf.
 | TC | TwinCAT Status LED TwinCAT ist im Run-Modus (grün) TwinCAT ist im Stop-Modus (rot) TwinCAT ist im Konfig-Modus (blau)
 | HDD | Read/Write Compact Flash (rot) Zeigt einen Zugriff auf die CF Karte an.
 | FB1 | Status LED1 für Feldbus (Funktion wird bei der Feldbusschnittstelle beschrieben)
 | FB2 | Status LED2 für Feldbus (Funktion wird bei der Feldbusschnittstelle beschrieben)


CX50x0: LEDs des K-Bus-Netzteils

BECKHOFF CX50x0: Fehlerbehandlung und Diagnose

LEDs des K-Bus-Netzteils (CX50x0-1xxx)

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Us 24V | Spannungsversorgung für CPU-Modul Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | Up 24V | Spannungsversorgung für Klemmbus. Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | K-BUS RUN | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | K-BUS ERR | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken EMV Probleme
  • Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
  • EMV-Maßnahmen ergreifen
  • Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
3 Impulse 0 K-Bus-Kommandofehler
  • Keine Busklemme gesteckt
  • Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
6 Impulse | 0 | Fehler bei der Initialisierung | Buskoppler tauschen
1 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus - und wieder einschalten)
8 | Interner Datenfehler | Hardware-Reset des Buskopplers (aus- und wieder einschalten)
7 Impulse | 0 | Prozeßdatenlängen der Soll und Ist stimmen Konfiguration nicht überein | Konfiguration und Klemmen auf Konsistenz prüfen

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

K-Bus-Interface

Der CX50xx erkennt diese Klemmen beim Scannen automatisch, ließt die Klemmentypen aus und legt sie im System-Manager automatisch an.

K-Bus State

Der K-Bus Status wird in dem State Byte (siehe Bild K-Bus Interface "1") abgelegt, ist der Wert 0 so arbeitet der K-Bus synchron und ohne Fehler. Sollte wer Wert <>0 sein kann das ein Fehler, aber auch nur ein Hinweis sein das zum Beispiel der K-Bus länger benötigt als die verwendete Task und ist damit nicht mehr Synchron zu der Task. Die Task-Zeit sollte schneller als 100 ms sein. Wir empfehlen eine Task-Zeit kleiner 50 ms. Typischerweise liegt die K-Bus-Update-Zeit zwischen einer und fünf ms.

Bit 0 = Kbus Fehler
Bit 1 = Klemmenkonfiguration hat sich seit dem Start geändert
Bit 2 = Prozessabbildlängen stimmen nicht überein
Bit 8 = (noch) keine gültigen Eingänge
Bit 9 = Kbus ist im Inputupdate noch nicht fertig
Bit 10 = Kbus ist im Outputupdate noch nicht fertig
Bit 11 = Watchdog
Bit 15 = azyklische Kbus Funktion aktiv (z.B. Kbus Reset)

Liegt ein K-Bus-Fehler vor, kann dieser über den Funktionsbaustein IOF_DeviceReset (in der TcIoFunctions.lib) zurückgesetzt werden.


CX50x0: LEDs des E-Bus-Netzteils

BECKHOFF CX50x0: Fehlerbehandlung und Diagnose

LEDs des E-Bus-Netzteils (CX50x0-0xxx)

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED |  | Bedeutung
 | Us 24V |  | Spannungsversorgung für CPU-Modul Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | Up 24V |  | Spannungsversorgung für Klemmbus. Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | L/A | aus | E-Bus nicht angeschlossen
 |  | an | E-Bus angeschlossen / Kein Datenverkehr
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.


CX50x0: Störungen

BECKHOFF CX50x0: Anhang

Störungen

Lesen Sie dazu auch das Kapitel Sicherheitshinweise.

Mögliche Störungen und ihre Beseitigung

Störung | Ursache | Maßnahmen
keine Funktion nach Starten des Embedded-PCs | fehlende Stromversorgung des Embedded-PCs andere Ursachen | 1.Sicherung prüfen 2. Anschlussspannung messen, Steckerbelegung prüfen Beckhoff Support anrufen
Der Embedded-PC bootet nicht vollständig | Festplatte beschädigt (z.B. durch Abschalten bei laufender Software), Setupeinstellungen fehlerhaft, andere Ursachen | Setupeinstellungen prüfen Beckhoff Support anrufen
Rechner bootet, Software wird gestartet, aber Steuerung arbeitet nicht einwandfrei | Fehlerursache liegt bei der Software oder bei Anlagenteilen außerhalb des Embedded-PCs | Rufen Sie den Maschinen- oder Softwarehersteller an.
Fehler bei CF Card Zugriff | Fehlerhafte CF Card, fehlerhafter CF Einschub | Mit einer anderen CF Card den CF Einschub überprüfen Beckhoff Support anrufen
Embedded-PC funktioniert nur teilweise oder nur zeitweise | Komponenten im Embedded-PC defekt | Beckhoff Support anrufen

Bitte notieren Sie sich vor Kontaktaufnahme mit dem Service oder Support folgende Angaben:

  1. Genaue Gerätebezeichnung CXxxxx-xxxx
  2. Serienummer
  3. Hardwarestand
  4. evtl. vorhandene Schnittstellen (N030, N031, B110, ...)
  5. eingesetzte TwinCAT Version
  6. evtl. weitere eingesetzte Komponenten / Software

Der Support / Service in Ihrem Land kann Ihnen am schnellsten helfen. Bitte kontaktieren Sie daher Ihren regionalen Ansprechpartner. Schauen Sie auf unserer Web-Seite: www.beckhoff.de an oder fragen Sie Ihren Vertriebspartner.


CX50x0 - Demontage und Entsorgung

BECKHOFF CX50x0: Außerbetriebnahme

Demontage und Entsorgung

Der Abbau einer CX50x0-Hardwarekonfiguration erfolgt in 2 Schritten:

1. Abschalten und Entfernen der Stromversorgung

Bevor der Abbau eines CX50x0-System erfolgen kann, sollte das System abgeschaltet sein und die Stromversorgung entfernt werden.

2. Demontage von der Hutschiene:

Vor der Trennung der einzelner Module muss der gesamte CX50x0-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

2.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man alle eventuell vorhandene Verkabelung der Stormversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Soll die Verkabelung später mit einem anderen System wieder hergestellt werden, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil), löst damit die Klemme und zieht sie nach vorne heraus.

2.2. Entriegeln des CX50x0 - Systems

Um den CX50x0-Block zu lösen, muss die orange Hutschienenbefestigung auf der linken Geräteseite gelöst werden. Dazu muss an sie an dem unteren Haken nach hinten gedrückt werden. Ein vernehmbares Klicken zeigt an, dass das Gerät entriegelt ist.

Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung lässt sich der Block vorsichtig von der Hutschiene nehmen.

Achtung 		Gerät nicht gewaltsam öffnen!
Das gewaltsame Öffnen der Modulgehäuse führt zur Zerstörung der Gehäuse. Die Geräte dürfen nur durch den Beckhoff Service geöffnet werden.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


Zubehör

Compact Flash Karten

Bestellnummer bei der Erstbestellung der Karten (statt 64-MB CF-Karten)

Bestellnummer | Beschreibung
CX1900-0023 | 1 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0025 | 2 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0027 | 4 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0029 | 8 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0031 | 16 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte

Bestellnummer bei der Bestellung von Ersatzkarten

Bestellnummer | Beschreibung
CX1900-0022 | 64 MByte Compact Flash Karte Typ I
CX1900-0024 | 1 GByte Compact Flash Karte Typ I
CX1900-0026 | 2 GByte Compact Flash Karte Typ I
CX1900-0028 | 4 GByte Compact Flash Karte Typ I
CX1900-0030 | 8 GByte Compact Flash Karte Typ I
CX1900-0032 | 16 GByte Compact Flash Karte Typ

Formatierung einer Compact-Flash-Karte

Bestellnummer | Beschreibung
CX1900-0010 | Formatierung einer Compact-Flash-Karte (bootfähig), FAT16
CX1900-0012 | CX1900-0012 Formatierung einer Compact-Flash-Karte (bootfähig), NTFS

Speichererweiterung für CX1020/CX1030

Bestellnummer | Beschreibung
CX1900-0201 | 512 MB DDR RAM für CX1020/CX1030 statt 265 MB DDR RAM
CX1900-0202 | 1 GB DDR RAM für CX1020/CX1030 statt 265 MB DDR RAM

DVI-zu-VGA passiver Adapter

Bestellnummer | Beschreibung
CX1900-0101 | DVI-zu-VGA passiver Adapter für den Anschluss von Standard-VGA-Monitoren an das CX-System – führt die VGA-Signale der DVI-I-Schnittstelle des CX-Moduls aus – DVI-A-Stecker, 29-polig (unten), Buchse, 15-polig (oben) – Gewicht: ca. 40 g – Abmessungen (B x H x T): 40 x 42 x 15 mm

Ersatzbatterie CX-Systeme

Bestellnummer | Beschreibung
CX1900-0102 | Batterie für CX-Systeme - Originalherstellerbezeichnung: Panasonic Typ CR2032 3V/225mAh

Ersatzlüfterkassette für CX1030

Bestellnummer | Beschreibung
CX1900-0103 | Ersatzlüfterkassette für CX1030 – Kassette bestehend aus Gehäuse und Lüfter 40 mm – einfacher Austausch im Feld durch kabellose Montage – Gewicht: ca. 30 g – Abmessungen (B x H x T): 57 x 14 x 60 mm


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Support

Die Beckhoff Automation GmbH und ihre weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen garantiert.

Beckhoff Support

Der Beckhoff Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt: weltweiter Support; Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme, umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten.

Hotline: +49(0)5246/963-157

Fax: +49(0)5246/963-9157

E-Mail: support@beckhoff.com

Beckhoff Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen garantiert.

Hotline: +49(0)5246/963-460

Fax: +49(0)5246/963-479

E-Mail: service@beckhoff.com

Weitere Support und Service Adressen entnehmen Sie bitte unseren Internetseiten, unter www.beckhoff.com. Dort befindet sich auch die gesamte Dokumentation der Beckhoff Komponenten.

Sollten Sie Vorschläge oder Anregungen betreffend unserer Dokumentation haben, schicken Sie uns bitte eine E-Mail, mit dem Hinweis auf die Versionsnummer, an Dokumentation@Beckhoff.de.