CX20x0 - Emmbedded PC

BECKHOFF Automation

Dokumentation zu der Hardware des CX20x0

CX2020-012x

CX2030-012x

CX2040-012x

Version: 1.1
Datum: 26.07.2013


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Allgemeine Sicherheitshinweise

BECKHOFF Automation: Vorwort

Sicherheitshinweise

Sicherheitsbestimmungen

Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.

Haftungsausschluss

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.

Erklärung der Symbole

In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!

GEFAHR

Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!

WARNUNG

Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!

VORSICHT

Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!

Achtung

Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.

Hinweis

Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


CX20x0 - Ausgabestände der Dokumentation

BECKHOFF CX20x0: Vorwort

Ausgabestände der Dokumentation

Version | Änderungen
1.0 | erste Version
1.1 | Hinweise zur Stromversorgung und Bestellnummern zu CX20x0-N031 hinzugefügt


CX20x0 - Bestimmungsgemäße Verwendung

BECKHOFF CX20x0: Produktübersicht

Bestimmungsgemäße Verwendung

Die Geräteserie CX20x0 ist ein modulares Steuerungssystem, das für die Montage auf einer Hutschiene vorgesehen ist. Die System ist skalierbar, so dass je nach Aufgabenstellung die benötigten Module (CX2500) zusammengesteckt und in den Schaltschrank oder Klemmenkasten eingebaut werden können.

Abschalten des PCs nur nach Beendigung der Software

Bevor der Embedded-PC abgeschaltet werden darf muss die laufende Software regulär beendet werden, andernfalls können Daten auf der Festplatte verloren gehen. Lesen Sie dazu den Abschnitt "Ausschalten".

Wenn der PC nicht für Steuerungszwecke eingesetzt wird, beispielsweise während der Funktionsprüfung, müssen zuerst alle Anlagenteile abgeschaltet und danach der Embedded-PC von der Anlage abgekoppelt werden. Die Abkopplung geschieht durch Abziehen der ersten Klemme hinter dem Netzteil (optional) und Abziehen der Stecker der Feldbusanschlüsse.
Abgeschaltete Anlagenteile müssen gegen Wiedereinschalten gesichert werden.

Das Netzteil des Embedded-PCs wird mit einer Spannung von 24 VDC versorgt.

Achtung

Schädigung von Umwelt oder Geräten
Keine Teile unter Spannung austauschen! Durch das Austauschen der Steuerungsteile unter Spannung kann es zu Kurzschlüssen oder Überspannungen kommen. Diese können die Steuerung selbst und angeschlossenen Peripherie (Klemmen, Bildschirme, Eingabegeräte, etc.) beschädigen.

Beim Ein- und Ausbau von Komponenten muss die Versorgungsspannung abgeschaltet werden.

Softwarekenntnisse

Achtung

Fehlfunktionen der Anlage
Erforderliche Softwarekenntnisse! Jeder Benutzer muss alle für ihn erreichbaren Funktionen der auf dem PC installierten Software kennen.


CX20x0 - Systemübersicht

BECKHOFF CX20x0: Produktübersicht

Systemübersicht

CX2020, CX2030, CX2040 | CPU-Grundmodul

Das System

Der CX2020 verfügt über eine Intel®-Celeron®-CPU mit 1,4 GHz Taktfrequenz, der CX2030 über eine Intel®-Core™-i7-dual-core-CPU mit 1,5 GHz Taktfrequenz und der CX2040 über eine Intel®-Core™-i7-quad-core-CPU mit 2,1 GHz Taktfrequenz. Beim CX2020 und CX2030 ist die Steuerung lüfterlos und ohne rotierende Bauteile. Beim CX2040 ist aufgrund der hohen Leistung ein kugelgelagerter und drehzahlüberwachter Lüfter integriert. Die Grundmodule beinhalten neben CPU und Chipsatz auch den Arbeitsspeicher, der beim CX2020 und CX2030 2 GB umfasst. Optional sind bis zu 4 GB möglich. Beim CX2040 sind standardmäßig 4 GB Arbeitsspeicher integriert. Die Steuerung bootet von der CFast-Flash-Speicherkarte. Die Grundausstattung der Module umfasst eine CFast-Speicherkarte, zwei unabhängige GBit-Ethernet-Schnittstellen, vier USB-2.0 sowie eine DVI-I-Schnittstelle. Die CPU verfügt intern über 128 kB NOVRAM als persistenten Datenspeicher, falls keine USV genutzt wird. Optional können die Geräte mit einer seriellen oder einer Feldbusschnittstelle bestellt werden. Über die beidseitig vorhandenen hochpoligen Anschlüsse können alle anderen Komponenten der CX2000-Familie angeschlossen werden. Als Betriebssystem kommt Microsoft Windows Embedded Standard 7 P zum Einsatz. An das CPU-Grundmodul können links bis zu vier Module angesteckt werden. Die Ansteckreihenfolge spielt dabei keine Rolle. Die Module sind intern per PCI Express angebunden und können im Nachhinein im „Feld“ an die CPU gesteckt werden. Für die Spannungsversorgung des CPU-Moduls wird ein Netzteilmodul vom Typ CX2100 benötigt, das rechts an die CPU gesteckt wird. Zwischen Netzteil und CPU können noch bis zu zwei CFast-Speicherkartenmodule (CX2550-0010) angesteckt werden, sodass insgesamt bis zu drei CFast-Karten eingesetzt werden können. Beim Einsatz von mehr als einer CFast-Karte kann auch RAID genutzt werden.

Die Embedded-PCs CX2020, CX2030 und CX2040 erweitern die CX-Produktfamilie um Varianten mit sehr hoher CPU-Leistung – auch mit Multi-Core – und ermöglichen den direkten Anschluss der Busklemmen oder EtherCAT-Klemmen. Mit dem CX2000 in Verbindung mit EtherCAT und TwinCAT können sehr schnelle Steuerungsvorgänge im Mikrosekundenbereich (eXtreme Fast Control Technology) durchgeführt werden. Die CPU-Grundmodule bringen als Grundausstattung zwei unabhängige GBit-Ethernet-Schnittstellen, vier USB-2.0- und eine DVI-I-Schnittstelle mit. Optional besteht die Möglichkeit, eine serielle oder Feldbusschnittstelle zu bestellen. Diese Option kann nicht nachträglich in das Gerät gebaut werden. Auf der linken Seite verfügt die CPU über einen hochpoligen Stecker, an den weitere Module wahlweise angesteckt werden können.

Die Komponenten

Die einzelnen Systemkomponenten sind aneinander reihbare Module mit einer Breite von 22 mm oder Vielfachen davon. Die Basiseinheit besteht aus dem CPU-Modul CX20x0 und einem Netzteilmodul (CX2100-0xxx).

Netzteil mit integriertem I/O-Interface und optionaler USV

Bei dem 24V-DC-Netzteil kann aus drei verschiedenen Ausführungen gewählt werden:

  • CX2100-0004: E-Bus-/K-Bus-Netzteil mit automatischer Umschaltung
  • CX2100-0904: E-Bus-/K-Bus-Netzteil mit automatischer Umschaltung und integrierter kapazitiver USV
  • CX2100-0914: E-Bus-/K-Bus-Netzteil mit automatischer Umschaltung und integrierter Lade-Elektronik für externe Akkupacks zur USV-Funktionalität

Alle Netzteilvarianten verfügen über ein beleuchtetes, reflexarmes LC-Display mit zwei Zeilen à 16 Zeichen für die Anzeige von Statusmeldungen. Die Anwenderprogramme können das Display auch für die Anzeige applikationsspezifischer Texte nutzen.

EtherCAT als schnelles I/O-System

Die Embedded-PCs CX2020, CX2030 und CX2040 wurden im Hinblick auf das optimierte Zusammenspiel mit EtherCAT entwickelt. Beim Einsatz von EtherCAT ergeben sich verschiedene Möglichkeiten in der Anwendung. Durch die separaten Gigabit-Ethernet-Schnittstellen ist es so beispielsweise möglich, EtherCAT mit Kabelredundanz zu nutzen, indem eine der Ethernet-Schnittstellen als Redundanzport genutzt wird. Außerdem können die Geräte mit EtherCATSlave-Schnittstelle so betrieben werden, dass mehrere intelligente Steuerungen über ein EtherCAT-Netzwerk synchronisiert werden können.

SPS, Motion Control, Interpolation und Visualisierung

Als IPC auf der Hutschiene hat der CX2000 im Zusammenspiel mit TwinCAT die Funktionalität großer Industrie-PCs. Durch die Multi-Core-CPUs können in Verbindung mit TwinCAT 3 auch SPS-Projekte auf mehrere Kerne verteilt werden, um deutliche Performance-Gewinne zu erreichen. Ebenso stehen alle Funktionalitäten von TwinCAT für den Bereich Motion Control zur Verfügung: Es können theoretisch bis zu 256 Achsen angesteuert und neben einfachen Punkt-zu-Punkt-Bewegungen auch komplexere Mehrachsfunktionen, wie „Elektronisches Getriebe“, „Kurvenscheibe“ und „Fliegende Säge“, ausgeführt werden. Aufgrund der leistungsstarken CPUs kann der CX2000 auch interpolierende 3-D-Bahnbewegungen ausführen und DIN66025-Programme abarbeiten. Neben den in Echtzeit ausgeführten Steuerungsaufgaben sorgt die Verwaltung im TwinCAT-Echtzeitkern dafür, dass genügend Zeit für die Benutzeroberfläche (HMI) bleibt. Durch die hohe Grafikleistung des in die CPU integrierten Grafikkerns können auch anspruchsvolle Visualisierungen mit modernen User-Interfaces realisiert werden.

Feldbusschnittstellen

Die Feldbusschnittstellen sind derzeit als Master und Slave-Feldbusanschaltungen für folgende Feldbusse erhältlich.

Optionsschnittstellen:

Über die Optionsschnittstellen lassen sich 1-kanalige Feldbusschnittstellen anbinden. Es ist immer nur der Betrieb von einer Schnittstelle möglich. Sollten mehrere Feldbus-Schnittstellen benötigt werden, so können diese als E-Bus-Klemmen (EL67xx) hinzugefügt werden. Die verfügbaren Feldbusschnittstellen sind im einzelnen:

  • CX20x0-N010 = DVI-D, DVI-D-Stecker
  • CX20x0-N030 = RS232, D-Sub-Stecker
  • CX20x0-N031 = RS422/RS485, D-Sub-Buchse
  • CX20x0-B110 = EtherCAT-Slave, EtherCAT IN und OUT (2 x RJ 45)
  • CX20x0-M310 = PROFIBUS-Master, D-Sub-Buchse, 9-polig
  • CX20x0-B310 = PROFIBUS-Slave, D-Sub-Buchse, 9-polig
  • CX20x0-M510 = CANopen-Master, D-Sub-Stecker, 9-polig
  • CX20x0-B510 = CANopen-Slave, D-Sub-Stecker, 9-polig
  • CX20x0-M930 = PROFINET RT, Controller, Ethernet (2 x RJ-45)
  • CX20x0-B930 = PROFINET RT, Device, Ethernet (2 x RJ-45-Switch)
  • CX20x0-B950 = EtherNet/IP-Slave, Ethernet (2 x RJ-45-Switch)

Die Software

In Kombination mit der Automatisierungssoftware TwinCAT wird der Industrie-PC CX20x0 zu einer leistungsfähigen IEC 61131-3 SPS mit bis zu vier Anwender-Tasks. Zusätzlich können auch Motion Control Aufgaben ausführt werden. Je nach erforderlicher Abtastzeit ist die Ansteuerung von mehreren Servoachsen möglich, wobei selbst Sonderfunktionen wie Fliegende Säge, Elektronisches Getriebe und Kurvenscheibe realisierbar sind.


CX20x0 - Technische Daten

Die Grundausstattung des CX20x0 enthält eine 8 GB CFast-Flashkarte. Zwei Ethernet-RJ-45 Schnittstellen, vier USB-2.0 Schnittstellen sowie eine DVI-I Schnittstelle gehören zur Basisausstattung.

Technische Daten | CX2020 | CX2030 | CX2040
Prozessor | Intel® Celeron® 1,4 GHz, single-core | Intel® CoreTM i7 1,5 GHz, dual-core | Intel® CoreTM i7 2,1 GHz, quad-core
Interner Flash Speicher | 4- oder 8-GB CFast-Flashkarte (optional erweiterbar) | 4- oder 8-GB CFast-Flashkarte (optional erweiterbar) | 4- oder 8-GB CFast-Flashkarte (optional erweiterbar)
Interner Arbeitsspeicher | 2 GB DDR3-RAM | 2 GB DDR3-RAM | 4 GB DDR3-RAM
Persistenter Speicher | 128 kB NOVRAM integriert | 128 kB NOVRAM integriert | 128 kB NOVRAM integriert
Schnittstellen | 2 x RJ 45, 10/100/1000 MBit/s, DVI-I, 4 x USB 2.0, 1x Optionsschnittstelle | 2 x RJ 45, 10/100/1000 MBit/s, DVI-I, 4 x USB 2.0, 1x Optionsschnittstelle | 2 x RJ 45, 10/100/1000 MBit/s, DVI-I, 4 x USB 2.0, 1x Optionsschnittstelle
Diagnose LED | 1 x Power, 1 x TC-Status, 1 x Flash-Zugriff, 2 x Bus-Status | 1 x Power, 1 x TC-Status, 1 x Flash-Zugriff, 2 x Bus-Status | 1 x Power, 1 x TC-Status, 1 x Flash-Zugriff, 2 x Bus-Status
Uhr | interne, batteriegepufferte Uhr für Zeit und Datum (Batterie wechselbar) | interne, batteriegepufferte Uhr für Zeit und Datum (Batterie wechselbar) | interne, batteriegepufferte Uhr für Zeit und Datum (Batterie wechselbar)
Betriebssystem | Microsoft Windows Embedded Standard 7 P | Microsoft Windows Embedded Standard 7 P | Microsoft Windows Embedded Standard 7 P
Steuerungssoftware | TwinCAT 2-PLC-Runtime, NC-PTP-Runtime, NC-I-Runtime | TwinCAT 3. siehe Preisliste TwinCAT 3 | TwinCAT 2-PLC-Runtime, NC-PTP-Runtime, NC-I-Runtime | TwinCAT 3. siehe Preisliste TwinCAT 3 | TwinCAT 2-PLC-Runtime, NC-PTP-Runtime, NC-I-Runtime | TwinCAT 3. siehe Preisliste TwinCAT 3
Spannungsversorgung | 24 V DC (-15 %/+20 %) | 24 V DC (-15 %/+20 %) | 24 V DC (-15 %/+20 %)
Max. Verlustleistung | 15 W (einschließlich der Systemschnittstellen) | 20 W (einschließlich der Systemschnittstellen) | 42 W (einschließlich der Systemschnittstellen)
Spannungsfestigkeit | 500 V (Versorgung/interne Elektronik) | 500 V (Versorgung/interne Elektronik) | 500 V (Versorgung/interne Elektronik)
Abmessungen (B x H x T) | 144 mm x 100 mm x 91 mm | 144 mm x 100 mm x 91 mm | 144 mm x 100 mm x 91 mm
Gewicht | ca. 1160 g | ca. 1165 g | ca. 1230 g
Betriebs-/Lagertemperatur | -25° C ... +60° C / -40° C ... +85° C | -25° C ... +60° C / -40° C ... +85° C | -25° C ... +60° C / -40° C ... +85° C
Relative Feuchte | 95% ohne Betauung | 95% ohne Betauung | 95% ohne Betauung
Vibartions-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27 | gemäß EN 60068-2-6 / EN 60068-2-27 | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4 | gemäß EN 61000-6-2/EN 61000-6-4 | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20 | IP 20 | IP 20

Weitere Informationen: www.beckhoff.de/CX2000


CX20x0 - Ausführungen

BECKHOFF CX20x0: Produktübersicht

Ausführungen

Das CPU-Modul lässt sich mit unterschiedlichen Hardware- und Softwareoptionen ausstatten. Durch die Automatisierungssoftware TwinCAT wird ein CX20x0 System zu einer leistungsfähigen SPS und Motion Control Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. An das CPU-Grundmodul können weitere Systemschnittstellen (ab Werk vormontiert) sowie Feldbusanschaltungen angefügt werden.

Die CX 20x0 Module sind in folgenden Ausführungen erhältlich:

Modul | Taktfrequenz der CPU | Kerne | ohne Betriebssystem | Microsoft Windows Embedded 7 P | ohne TwinCAT | TwinCAT PLC Runtime | TwinCAT NC PTP Runtime | TwinCAT NC I Runtime
CX2020-0100 | 1,4 GHz | 1 | X | - | X | - | - | -
CX2020-0120 | 1,4 GHz | 1 | - | X | X | - | - | -
CX2020-0121 | 1,4 GHz | 1 | - | X | - | X | - | -
CX2020-0122 | 1,4 GHz | 1 | - | X | - | - | X | -
CX2020-0123 | 1,4 GHz | 1 | - | X | - | - | - | X
CX2030-0100 | 1,5 GHz | 2 | X | - | X | - | - | -
CX2030-0120 | 1,5 GHz | 2 | - | X | X | - | - | -
CX2030-0121 | 1,5 GHz | 2 | - | X | - | X | - | -
CX2030-0122 | 1,5 GHz | 2 | - | X | - | - | X | -
CX2030-0123 | 1,5 GHz | 2 | - | X | - | - | - | X
CX2040-0100 | 2,1 GHz | 4 | X | - | X | - | - | -
CX2040-0120 | 2,1 GHz | 4 | - | X | X | - | - | -
CX2040-0121 | 2,1 GHz | 4 | - | X | - | X | - | -
CX2040-0122 | 2,1 GHz | 4 | - | X | - | - | X | -
CX2040-0123 | 2,1 GHz | 4 | - | X | - | - | - | X

CX20x0 Systeme mit Microsoft Windows Embedded 7 P setzen eine Compact Flash Karte mit einer Kapazität von mindestens 8 GByte voraus.

Hinweis 		Software Images
Die Auflistung der verschiedenen Software Images entnehmen Sie bitte der CX-Software Dokumentation.


CX20x0: Batteriefach

BECKHOFF CX20x0: Produktübersicht

Batteriefach

Unter der Frontklappe des CX20x0 befindet sich das Batteriefach. Nach dem Aufklappen der Frontklappe ist die Öffnung, in der die Halterung der Batterie angebracht ist, sichtbar. Die Batterie wird dann mit Hilfe der Auswurflasche vorsichtig aus dem Halter gezogen und kann anschließend entnommen werden.

Zum Einlegen der Batterie wird die neue Batterie in das Batteriefach geschoben. Dabei ist auf die Polung der Batterie zu achten. Anschließend kann die Frontklappe geschlossen werden. Der Batteriewechsel ist damit abgeschlossen.

Bei der Batterie handelt es sich um den Typ CR2032 von Panasonic.

Die genauen Daten lauten wie folgt:

Batterietyp | Elektrische Eigenschaften (bei 20° C) |  | Standard Belastung | Abmessungen
 | nominal Spannung | nominal Kapazität | kontinuierliche Last | Durchmesser | Höhe | Gewicht
CR2032 | 3,0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

Achtung

Eine falsch eingesetzte Batterie kann explodieren!
Verwenden Sie ausschließlich denselben Batterietyp (CR2032) von Sanyo oder Panasonic.

Achten Sie unbedingt darauf, dass die Plus- und Minuspole der Batterie korrekt eingelegt wird. (Minuspol links)

Öffnen Sie die Batterie niemals und werfen Sie die Batterie niemals in ein Feuer.

Die Batterie kann nicht wieder aufgeladen werden.

Hinweis

Wartung der Batterie
Die Batterie muss alle 5 Jahre gewechselt werden.

Ersatzbatterien können beim Beckhoff Service bestellt werden.


CX20x0 - CF-Einschub

BECKHOFF CX20x0: Produktübersicht

CF-Einschub

Auf der Frontseite befindet sich ein CFast Flash Einschub. Hier durch ergibt sich die Möglichkeit das Speichermedium auszutauschen. Dies ist bei dem Einschub im Grundmodul nur in ausgeschaltetem Zustand möglich, andernfalls kann die Entnahme zum Absturz des Systems führen. Zu Wartungsarbeiten kann die CFast-Flash-Karte aus dem Modul entnommen werden. Auch die Erweiterung des Systems auf einen größeren Speicher (nur Betriebssystem und Programmspeicher) ist auf diese Weise möglich. Die CFast-Flash-Karten (CFast-Karten) sind als Zubehör in verschiedenen Speichergrößen erhältlich.

Die folgende Bildserie zeigt die Handhabung der CFast-Karten. Die Betätigung der Auswurfmechanik folgt dem Push-Push-Prinzips: Durch einen leichten Druck auf die CFast-Flash-Karte wird die Karte mit einem lesen Klicken entriegelt. Gleichzeitig wird die Karte um ca. 4 mm aus dem Gehäuse gehoben, so dass sie mit den Fingern herausgezogen werden kann.

Beim Einschub der Karte rastet die CFast-Flash-Karte mit einem leisen Klicken wieder ein. Die Karte sitzt richtig, wenn sie bündig mit der Frontseite des Gerätegehäuses abschließt.


CX20x0 - CFast-Karte

BECKHOFF CX20x0: Produktübersicht

CFast-Karte

Bei der CFast-Flash-Karte (CFast-Karte) handelt es sich um einen nicht volatilen Speicher.

Daten, die Spannungsausfallsicher gespeichert werden sollen, müssen auf der CFast-Karte gespeichert werden. Die CFast-Karte arbeitet wie eine Harddisk.

Hinweis 		Verwendung von CFast-Karten
Es wird ausdrücklich darauf hingewiesen nur CFast-Karten zu verwenden, die von der Beckhoff Automation GmbH geliefert werden.
Dies sind industrietaugliche CFast-Karten mit einer erhöhten Anzahl an Schreib-/ Lesezyklen und einem erweiterten Temperaturbereich ( +85°C).

Ein einwandfreier Betrieb kann nur mit CFast-Karten von der Beckhoff Automation GmbH gewährleistet werden!


CX20x0 - Auspacken, Aufstellung und Transport

BECKHOFF CX20x0: Montage und Verdrahtung

Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Abmessungen (B x H x T): 144 mm x 100 mm x 91 mm

Gewicht: ca. 1160 g / 1165g / 1230 g (Grundmodul)

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:

  1. Entfernen Sie die Verpackung.
  2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Weitertransport auf.
  3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
  4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
  5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
  6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung

Beschädigungsgefahr des Gerätes!
Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung).

Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


CX20x0 - Abmessungen

BECKHOFF CX20x0: Montage und Verdrahtung

Abmessungen

Die folgenden Zeichnungen zeigen die Abmessungen der CX20x0 Geräte.

Abmessungen


CX20x0 - Montage auf der Tragschiene

BECKHOFF CX20x0: Montage und Verdrahtung

Montage auf der Tragschiene

Aufrasten auf die Tragschiene

Der CX20x0 kann einfach auf die Tragschiene aufgerastet werden. Dazu müssen die Riegel an der Ober- und Unterseite entriegelt werden. Dann wird der Block einfach frontal auf die Tragschiene aufgesetzt und leicht angedrückt bis die rechte Seite eingerastet ist. Dies wird durch ein vernehmliches Klicken angezeigt. Dann werden die Riegel wieder eingerastet. Mit einem vernehmlichen Klicken wird das Einrasten der einzelnen Riegel quittiert.

Achtung 		Beschädigungen vermeiden!
Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Einbaulage

Achtung 		Zulässige Einbaulage und Mindestabstände einhalten!
Das auf eine Hutschiene montierte CPU-Modul darf nur bis Umgebungstemperaturen von 60°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die nachfolgenden Bilder zeigen die erlaubte sowie zwei verbotene Einbaulagen.

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX20x0 Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU-Grundmoduls und des Netzteils zu erreichen.

Zulässige Einbaulage

Aufgrund der hohen Leistung und der kompakten Bauform des CX20x0-Systems kann es zu einer erhöhten Wärmeentwicklung kommen. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Daher muss das System waagerecht montiert werden. Auf diese Weise kommt ein optimaler Luftstrom zustande.

Unzulässige Einbaulagen

Es ist nicht zulässig das CX20x0-System senkrecht auf der Hutschiene zu betreiben. Es ist dann keine ausreichende Belüftung für die CPU gewährleistet, da sich die Belüftungsöffnungen auf der Gehäuseober- und Gehäuseunterseite befinden. Auch in liegender Position ist das System nicht ausreichend belüftet.


CX20x0 - Montage auf der Tragschiene

BECKHOFF CX20x0: Montage und Verdrahtung

Montage der Modulverriegelung

Montage der Verriegelung

Das System der CX20x0-Steuerung ist voll modular, d.h. alle Systemschnittstellen des Systems sind feldkonfektionierbar. Im Regelfall ist die Verrastung der Module untereinander ausreichend stark. Es kann aber vorkommen, dass die Steuerung und ihre Module Erschütterungen, Vibrationen oder Stößen ausgesetzt sind. Mit Hilfe von Riegelclips lassen sich die Module sicher miteinander verbinden.

Die Riegelclips werden auf der Ober- und Unterseite eingesteckt:

Unterseite | Oberseite

Sind alle Systemschnittstellen verriegelt, so kann die gesamte Baugruppe auf die Tragschiene aufgerastet werden.

Demontage der Verriegelung

So die Baugruppe wieder zerlegt werden, so muss die Baugruppe erst von der Trageschiene entfernt werden. Danach können die Riegelclips mit Hilfe eins Schraubendrehers entfernt werden:

Unterseite | Oberseite

Sind die Riegelclips angehoben können sie herausgezogen werden. Anschließend können die Systemschnittstellen wieder getrennt werden.


CX20x0 - Spannungsversorgung

BECKHOFF CX20x0: Produktübersicht

Spannungsversorgung

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24" V und "0" V.
Die Versorgungsspannung versorgt das CX System und über den Klemmbus und die Busklemmen mit einer Spannung von 24 V DC ( -15%/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500Veff. Da der Klemmbus (K- und E-Bus) nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.

Anforderungen an das 24V Netzteil

Um in allen Fällen den Betrieb der CPU (CX20x0-Modul) und des Klemmenstrangs zu gewährleisten muss das Netzteil 4A bei 24V liefern.

Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:

  1. Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.

  2. Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.

  3. Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.

Leitungsquerschnitt | 0,5 ... 2,5 mm2 | AWG 20 .. AWG 14
Abisolierlänge | 8 ... 9 mm | 0.33 inch

LED

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchten die beiden oberen LEDs im Klemmenprisma grün auf. Die linke LED (Us) zeigt die Versorgung der CPU an. Die rechte LED (Up) zeigt die Versorgung der Klemmen an. Die weiteren LEDs beschreiben den Status des Klemmbusses. Die detaillierte Beschreibung der LEDs ist in dem Kapitel Fehleranalyse der LEDs beschrieben.

PE-Powerkontakte

Achtung 		Powerkontakt "PE"
Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden. "PE" und "0V" (24V Systemversorgung) müssen auf dem gleichen Potential liegen. (im Schaltschrank verbunden)

Die Verkabelung im Schaltschrank muss gemäß der Norm EN 60204-1:2006 Schutzkleinspannungen (PELV = Protective Extra Low Voltage) erfolgen.

EN 60204-1:2006 Abschnitt 6.4.1:

b): Eine Seite des Stromkreises oder ein Punkt der Energiequelle dieses Stromkreises muss an da Schutzleitersystem angeschlossen werden.

Achtung 		Unterbrechung der Stromversorgung / Abschalten
Zum Abschalten des Gerätes darf nicht die Masse getrennt werden. Es muss immer die 24V Leitung getrennt werden da sonst unter Umständen je nach Gerät der Strom über den Schirm weiterfließt.

Evtl. angeschlossene Geräte mit eigener Stromversorgung (z.B. ein Panel) müssen für "PE" und "GND" das gleiche Potential wie das CX-System haben.(keine Potentialdifferenz) Andernfalls können Schäden sowohl an der Steuerung also auch an der Peripherie auftreten.


CX20x0 - Spannungsversorgung

BECKHOFF CX20x0: Montage und Verdrahtung

Montage von passiven Klemmen am Netzteil CX2100-0xx4

Hinweis 		Hinweis zur Montage von Passiven Klemmen
EtherCAT-Busklemmen (ELxxxx / ESxxxx), die nicht aktiv am Datenaustausch innerhalb des Busklemmenblocks teilnehmen, werden als passive Klemmen bezeichnet. Zu erkennen sind diese Klemmen an der nicht vorhandenen Stromaufnahme aus dem E-Bus.
Um einen optimalen Datenaustausch zu gewährleisten, dürfen diese nicht direkt an das Netzteil angereiht werden!
Beispiele für Montage von passiven Klemmen (dunkel eingefärbt):

Die folgende Zeichnung stellt die unzulässige Montage dar:

Die folgende Abbildung zeigt die korrekte Montage der passiven Klemme:


CX20x0 - DVI-I-Anschluss

BECKHOFF CX20x0: Montage und Verdrahtung

DVI-I-Anschluss

DVI-I-Anschluss (X200)

Die DVI-I Schnittstelle überträgt digitale Daten und eignet sich für den Anschluss an digitale Displays. Die Auflösung am Bildschirm oder Beckhoff Control Panel ist abhängig von der Entfernung zum Anzeigegerät. Die maximale Entfernung beträgt 5 m. Beckhoff bietet verschiedene Panels mit integrierter "DVI-Verlängerung" an. Damit ist eine Kabellänge bis zu 50 Metern möglich.

DVI-I Buchse

Pin | Belegung | Pin | Belegung | Pin | Belegung
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -

Pinbelegung Kreuz

Pin | Belegung
C1 | Analog Red Video Out
C2 | Analog Green Video Out
C3 | Analog Blue Video Out
C4 | Analog Horizontal Sync
Auflösung am Monitor
Auflösung in Pixel | Entfernung der Schnittstelle vom Monitor
1920 x 1200 | 5 m
1600 x 1200 | 5 m
1280 x 1024 | 5 m
1024 x 768 | 5 m
800 x 600 | 5 m
640 x 480 | 5 m


CX20x0 - USB-Anschlüsse

BECKHOFF CX20x0: Montage und Verdrahtung

USB-Anschlüsse

USB Schnittstelle (X100 / X101 / X102 / X103):

Die CX20x0 verfügen über 4 unabhängige USB-Schnittstellen. Hier können Tastaturen, Mäuse, Touchscreens und andere Eingabegeräte sowie Datenspeicher angeschlossen werden. Dabei ist aus die Leistungsaufnahme der einzelnen Geräte zu achten: Es können pro Port nicht mehr als 500 mA abgegeben werden.

Die USB Buchse ist vom Typ A. Die USB Schnittstelle entspricht der USB 2.0 Spezifikation.

Pin | Belegung | Typische Zuordnung
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


CX20x0 - LAN-Anschlüsse

BECKHOFF CX20x0: Montage und Verdrahtung

LAN-Anschlüsse

LAN Schnittstelle (X000/ X001)

Die CX20x0 Systeme verfügen über 2 unabhängige LAN-Schnittstellen. Beide Ports sind in der Lage Geschwindigkeiten von 10 / 100 / 1000 MBit zu bedienen. Die LEDs an den linken Seiten der RJ45-Buchsen zeigen den Status der LANverbindung an. Die obere LED zeigt an ob der Port mit einem Netzwerk verbunden ist. Ist dies der Fall leuchtet die LED gelb auf. Wenn Datenverkehr auf den Port stattfindet, blinkt die LED. Die untere LED zeigt die Geschwindigkeit der Verbindung an. Ist die Geschwindigkeit 10 oder 100 MBit leuchtet die LED grün. Im Modus 1000 Mbit (Gigabit) leuchtet die LED rot.

Belegung der RJ45-Schnittstelle, Port 1 (X000)

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

Belegung der RJ45-Schnittstelle, Port 2 (X001)

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

Hinweis 		Unabhängigkeit der Ports
Beide Ports sind von einander unabhängig. Anders als bei den CX-System CX1020 und CX9000 ist kein Switch integriert. Für eine Linientopologie ist ein zusätzlicher Switch erforderlich. Die unabhängigen Ports lassen sich unterschiedlich konfigurieren:
  • Der obere Port (1) ist als Gigabit IT-Port,
  • Der untere Port (2) ist für EtherCAT-Kommunikation

im Auslieferzustand konfiguriert.


CX20x0 - RS232-Anschlüsse

BECKHOFF CX20x0: Montage und Verdrahtung

RS232- Anschlüsse (CX20x0-N030)

Die Systemschnittstelle CX20x0-N030 stellt eine RS232 Schnittstellen, COM1 (X300), bereit. Sie ist auf einer 9-poligen Sub-D Stiftleiste ausgeführt. Sollten mehr als eine Schnittstelle benötigt werden, so kann das System über den Klemmbus (K- oder E-Bus) Busklemmen (KL/EL6001), die serielle Schnittstellen bereitstellen erweitert werden. Die Pinbelegung wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle RS232 (Stecker)

Pinbelegung COM Schnittstelle

PIN | Signal | Typ | Beschreibung
1 | DCD | Signal in | Data Carrier Detected
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground
6 | DSR | Signal in | Dataset Ready
7 | RTS | Signal out | Request to Send
8 | CTS | Signal in | Clear to Send
9 | RI | Signal in | Ring Indicator


CX20x0: RS422/RS485-Anschlüsse

BECKHOFF CX20x0: Montage und Verdrahtung

RS422/RS485-Anschlüsse (CX20x0-N031)

Die Systemschnittstelle CX20x0-N030 stellt eine RS422 bzw. RS 485 Schnittstelle, COM1 (X300), bereit. Sie ist auf einer 9-poligen Sub-D Buchsenleiste ausgeführt. Sollte mehr als eine Schnittstelle benötigt werden, so kann das System über den Klemmbus (K- oder E-Bus) Busklemmen (KL/EL6021), die serielle Schnittstellen bereitstellen erweitert werden. Die Pinbelegung wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle (Buchse)

Pinbelegung COM Schnittstelle

PIN | Signal | Typ | Beschreibung
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

Für RS 485 muss Pin 2 und 3 ( Data +) sowie Pin7 und 8 (Data -) verbunden werden.

Einstellung der Schnittstellen Parameter

Die Schnittstelle ist im Auslieferzustand wie folgt parametriert:

RS485 ohne Echo, End-Point ( Terminiert) Standardeinstellung

Funktion | Status
Echo on | aus
Echo off | an
Auto send on | an
Always send on | aus
Auto receive on | an
Always receive on | aus
Term on | an
Term on | an

Hinweis

Änderung der Schnittstellenparameter
Sollten andere Parameter als die eingestellten benötigt werden, bestellen Sie sich bitte die benötigtet Konfiguration:

CX20x0-N031-0001 RS485 mit Echo, Endpunkt (Terminiert)

CX20x0-N031-0002 RS485 ohne Echo, Stichleitung (ohne Terminierung)

CX20x0-N031-0003 RS485 mit Echo, Stichleitung (ohne Terminierung)

CX20x0-N031-0004 RS422 Full Duplex Endpunkt (Terminiert)


CX20x0 - EtherCAT-Kabel-Redundanz

BECKHOFF CX20x0: EtherCAT-Kabelredundanz

EtherCAT-Kabel-Redundanz

Durch die zwei unabhängigen Ethernetports lässt sich bei den CX20x0-Systemen Kabelredundanz für EtherCAT realisieren. Dazu wird mindestens folgendes benötigt:

  1. Supplement EtherCAT-Redundanz
  2. EK1110 (Busverlängerung)
  3. EK1100 (Buskoppler)

Das Supplement Produkt kann auf der Webseite von Beckhoff unter

http://download.beckhoff.com/download/Software/TwinCAT/TwinCAT2/Supplement/TwinCAT_EtherCAT_Redundancy/Install/TcEcRedundancy.exe

heruntergeladen werden. Der benötigte Lizenzschlüssel kann über unseren Vertrieb bestellt werden. Die benötigten Koppler werden zusammen mit der anderen Hardware bestellt. Daraus lässt sich dann die Steuerung aufbauen. Das obere Bild zeigt ein minimales Beispiel für die Kabelredundanz. Ist die Hardware verkabelt und in Betrieb genommen, so muss man das Supplement auf dem Gerät installieren. Dies kann z.B. über einen USB-Stick oder das IT-Netzwerk erfolgen. Bei der Installation wird dann auch der Lizenzschlüssel abgefragt. Im Systemmanager kann man die Einstellung für Kabelredundanz vornehmen. Dazu wird zunächst die Klemmenkonfiguration eingelesen. Dann kann man unter den Eigenschaften für das EtherCAT-Device unter dem Reiter "EtherCAT" die Schaltfläche "Advanced Settings" auswählen. Hier wird dann unter dem Menü "Redundancy" der zweite Adapter eingestellt. Über den Button "Search" öffnet sich das Auswahl Menü. Für den unteren Netzwerkanschluss (X001) wählt man "Local Area Connection 2 (Intel(R).....)" aus. Mit dem Bestätigen der Auswahl durch Klicken auf "OK" ist die Konfiguration abgeschlossen.

Hinweis 		Das Supplement unterstützt nur KABELREDUNDANZ

Dieses Supplement unterstützt nur Kabelredundanz. Das bedeutet, dass Ausfallsicherheit nur für die Kabelstrecken besteht. Das bedeutet Verbindungen zwischen den Kopplern.
Ausfälle von einzelnen Klemmen können auf diese Weise nicht abgefangen werden.

Allgemeine Details können Sie im Beckhoff Information System unter EtherCAT Kabelredundanz nachlesen.

Fehlerfälle

Die beiden möglichen Ausfälle in dem Beispiel werden im Folgenden gezeigt.

Hier ist die Zuleitung zum Koppler EK1100 gestört. Trotz des Kabelausfalls laufen die Klemmen am EK1100 weiter. Im System Manager sieht der Ausfall dann wie folgt aus:

Die Unterbrechung wird durch "LNK_MIS B" und "LNK_MIS A" angezeigt.

Das nächste Beispiel zeigt den Ausfall der "Rückleitung":

Hier ist die zweite Leitung gestört. Die Klemmen am Koppler laufen ohne Störung weiter. Im System Manager sieht das Verhalten dann wie folgt aus:

Die Unterbrechung wird durch "LNK_MIS C" Beim Koppler EK1100 angezeigt.

Der EtherCAT-Ring lässt sich beliebig erweitern. Die Anzahl der Ringteilnehmer ist durch die Lizenzen gestaffelt: bis 250, bis 1000, mehr als 1000. Es kann aber bei einem Master nur eine Bruchstelle überbrückt werden. Bei zwei Bruchstellen laufen die Ringteile von beiden Seiten bis zu den Bruchstellen weiter.


CX20x0: Ein- und Ausschalten

BECKHOFF CX20x0: Inbetriebnahme

Ein- und Ausschalten

Einschalten

Die Stromversorgung des CPU Grundmoduls erfolgt über das Netzteil. Beim Anschluss des Netzteils an die Stromversorgung startet das CPU Grundmodul automatisch.

Erstes Einschalten

Wenn Sie den PC das erste Mal einschalten, wird das vorinstallierte Betriebssystem (optional) gestartet.

Ausschalten

Beim Ausschalten der Stromversorgung des Netzteils wird auch der Embedded-PC ausgeschaltet. Die laufende Steuerungssoftware, wie sie typischerweise auf Embedded-PCs eingesetzt wird, sollte ordnungsgemäß angehalten bzw. beendet werden. Ein Benutzer, der die Software nicht beenden darf, darf auch nicht den Embedded-PC abschalten, weil durch das Abschalten bei laufender Software Daten auf der Festplatte verloren gehen können.

Ist die Software angehalten, kann das Betriebssystem heruntergefahren werden. Erst danach sollte die Stromversorgung unterbrochen werden.


CX20x0: LEDs des CPU-Grundmoduls

BECKHOFF CX20x0: Fehlerbehandlung und Diagnose

LEDs des CPU-Grundmoduls

Anzeige | LED | Bedeutung
 | PWR | Spannungsversorgung Die Power LED leuchtet bei Anschluss an ein Netzteil mit eingeschalteter Spannungsversorgung (grün) auf.
 | TC | TwinCAT Status LED TwinCAT ist im Run-Modus (grün) TwinCAT ist im Stop-Modus (rot) TwinCAT ist im Konfig-Modus (blau)
 | HDD | Read/Write Compact Flash (rot) Zeigt einen Zugriff auf die CFast Karte an.
 | FB1 | Status LED1 für Feldbus (Funktion wird bei der Feldbusschnittstelle beschrieben)
 | FB2 | Status LED2 für Feldbus (Funktion wird bei der Feldbusschnittstelle beschrieben)


CX20x0: LEDs des K-Bus-Netzteils

BECKHOFF CX2100-0004 K-Bus-Modus: Fehlerbehandlung und Diagnose

LEDs des Netzteils (CX2100-0004) im K-Bus Modus

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Werden K-Bus-Klemmen detektiert, wird der fehlerfreie Hochlauf durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Us 24V | Spannungsversorgung für CPU-Modul Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | Up 24V | Spannungsversorgung für Klemmbus. Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | K-BUS RUN | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | K-BUS ERR | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken EMV Probleme
  • Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
  • EMV-Maßnahmen ergreifen
  • Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse 0 K-Bus-Kommandofehler
  • Keine Busklemme gesteckt
  • Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
7 Impulse | 0 | Prozeßdatenlängen der Soll und Ist stimmen Konfiguration nicht überein | Konfiguration und Klemmen auf Konsistenz prüfen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.


CX20x0: LEDs des E-Bus-Netzteils

BECKHOFF CX2100-0004 E-Bus-Modus: Fehlerbehandlung und Diagnose

LEDs des Netzteils (CX2100-0004) im E-Bus Modus

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Werden K-Bus-Klemmen detektiert, wird der fehlerfreie Hochlauf durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED |  | Bedeutung
 | Us 24V |  | Spannungsversorgung für CPU-Modul Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | Up 24V |  | Spannungsversorgung für Klemmbus. Die LED leuchtet grün bei korrekter Spannungsversorgung.
 | L/A | aus | E-Bus nicht angeschlossen
 |  | an | E-Bus angeschlossen / Kein Datenverkehr
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.


CX20x0: Störungen

BECKHOFF CX20x0: Fehlerbehandlung und Diagnose

Störungen

Lesen Sie dazu auch das Kapitel Sicherheitshinweise.

Mögliche Störungen und ihre Beseitigung

Störung | Ursache | Maßnahmen
keine Funktion nach Starten des Embedded-PCs | fehlende Stromversorgung des Embedded-PCs andere Ursachen | 1.Sicherung prüfen 2. Anschlussspannung messen, Steckerbelegung prüfen Beckhoff Support anrufen
Der Embedded-PC bootet nicht vollständig | Festplatte beschädigt (z.B. durch Abschalten bei laufender Software), Setupeinstellungen fehlerhaft, andere Ursachen | Setupeinstellungen prüfen Beckhoff Support anrufen
Rechner bootet, Software wird gestartet, aber Steuerung arbeitet nicht einwandfrei | Fehlerursache liegt bei der Software oder bei Anlagenteilen außerhalb des Embedded-PCs | Rufen Sie den Maschinen- oder Softwarehersteller an.
Fehler bei CF Card Zugriff | Fehlerhafte CFast-Card, fehlerhafter CFast-Einschub | Mit einer anderen CFast Card den CFast Einschub überprüfen Beckhoff Support anrufen
Embedded-PC funktioniert nur teilweise oder nur zeitweise | Komponenten im Embedded-PC defekt | Beckhoff Support anrufen

Bitte notieren Sie sich vor Kontaktaufnahme mit dem Service oder Support folgende Angaben:

  1. Genaue Gerätebezeichnung CXxxxx-xxxx
  2. Seriennummer
  3. Hardwarestand
  4. evtl. vorhandene Schnittstellen (N030, N031, B110, ...)
  5. eingesetzte TwinCAT Version
  6. evtl. weitere eingesetzte Komponenten / Software

Der Support / Service in Ihrem Land kann Ihnen am schnellsten helfen. Bitte kontaktieren Sie daher Ihren regionalen Ansprechpartner. Schauen Sie auf unserer Web-Seite: www.beckhoff.de an oder fragen Sie Ihren Vertriebspartner.


CX20x0 - Demontage und Entsorgung

BECKHOFF CX20x0: Außerbetriebnahme

Demontage und Entsorgung

Der Abbau einer CX20x0-Hardwarekonfiguration erfolgt in 2 Schritten:

1. Abschalten und Entfernen der Stromversorgung

Bevor der Abbau eines CX20x0-System erfolgen kann, sollte das System abgeschaltet sein und die Stromversorgung entfernt werden.

2. Demontage von der Hutschiene:

Vor der Trennung der einzelner Module muss der gesamte CX20x0-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

2.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man alle eventuell vorhandene Verkabelung der Stromversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Soll die Verkabelung später mit einem anderen System wieder hergestellt werden, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil), löst damit die Klemme und zieht sie nach vorne heraus.

2.2. Entriegeln des CX20x0 - Systems

Um den CX20x0-Block von der Hutschiene zu lösen, muss die Hutschienenbefestigung oberhalb und unterhalb des Gerätes gelöst werden. Dazu müssen die Haken mit dem Schraubendreher nach außen gedrückt werden . Ein vernehmbares Klicken zeigt an, dass das Gerät entriegelt ist.

Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung (siehe Pfeil) lässt sich der Block vorsichtig von der Hutschiene nehmen.

Achtung 		Gerät nicht gewaltsam öffnen!
Das gewaltsame Öffnen der Modulgehäuse führt zur Zerstörung der Gehäuse. Die Geräte dürfen nur durch den Beckhoff Service geöffnet werden.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


Zubehör

CFast-Flash Karten

Bestellnummer bei der Erstbestellung der Karten (statt 4GB CFast-Karte)

Bestellnummer | Beschreibung
CX2900-0029 | 8-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich, statt 4-GB-CFast-Karte
CX2900-0031 | 16-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich, statt 4-GB-CFast-Karte
CX2900-0033 | 16-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich, statt 8-GB-CFast-Karte

Bestellnummer bei der Bestellung von Ersatzkarten

Bestellnummer | Beschreibung
CX2900-0026 | 2-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich
CX2900-0028 | 4-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich
CX2900-0030 | 8-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich
CX2900-0032 | 16-GB-CFast-Karte, SLC-Flash, erweiterter Temperaturbereich

größere Kapazitäten auf Anfrage

DVI-zu-VGA passiver Adapter

Bestellnummer | Beschreibung
CX1900-0101 | DVI-zu-VGA passiver Adapter für den Anschluss von Standard-VGA-Monitoren an das CX-System – führt die VGA-Signale der DVI-I-Schnittstelle des CX-Moduls aus – DVI-A-Stecker, 29-polig (unten), Buchse, 15-polig (oben) – Gewicht: ca. 40 g – Abmessungen (B x H x T): 40 x 42 x 15 mm

Ersatzbatterie CX-Systeme

Bestellnummer | Beschreibung
CX1900-0102 | Batterie für CX-Systeme - Originalherstellerbezeichnung: Panasonic Typ CR2032 3V/225mAh

Ersatzlüfterkassette für CX2040

Bestellnummer | Beschreibung
CX2900-0103 | Ersatzlüfterkassette für CX2040 – Kassette bestehend aus Gehäuse und Lüfter 60 mm – einfacher Austausch im Feld durch kabellose Montage – Gewicht: ca. 30 g – Abmessungen (B x H x T): 66 x 67 x 16 mm


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.