Ausgabestände der Dokumentation

BECKHOFF CX1100-00xx: Netzteile und I/O- Schnittstellen für CX10x0

Dokumentation zu

den Netzteilen und I/O-Schnittstellen des CX10x0-Systems

CX1100-0001

CX1100-0002 / CX1100-0012(K-Bus)

CX1100-0003 / CX1100-0013 (IP Link und K-Bus)

CX1100-0004 / CX1100-0014 (E-Bus)

Version: 2.0
Datum: 02.10.2007


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr |
 | Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung |
 | Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis |
 | Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Version | Änderungen
2.0 | Neues Netzteil für CX1030 hinzugefügt
1.9 | Ergänzungen zum Kapitel Verkabelung hinzugefügt
1.8 | Hinweise für K-Busdiagnose mit Firmware > B7 hinzugefügt
1.7 | Klemmenbus-Diagnose im SPS-Programm hinzugefügt
1.6 | Hinweise auf Verwendung im Zusammenhang mit Hardwarestand hinzugefügt
1.5 | Fehlercodes für IP-Link hinzugefügt
1.4 | ADS Ansteuerung für Display hinzugefügt
1.3 | Änderungen im GCB - Watchdog Error Counter hinzugefügt
1.2 | Blinkcodes für CX1100-0004 (EtherCAT) erweitert
1.1 | Bibliotheksfunktion für den Taster eingefügt
1.0 | Speicherübersicht / Feldbusanbindungen
0.2 | Überarbeitete Version Beschreibung der vier verschiedenen Netzteile Beschreibung der CX10xx-Architektur
0.1 | Vorläufige Version


Bestimmungsgemäße Verwendung

Die Geräteserie CX1000, CX1020 ist ein hutschienenmontierbares modulares Steuerungssystem, dessen Elemente, je nach Aufgabenstellung, zusammengesteckt in den Schaltschrank oder Klemmenkasten eingebaut werden.


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Übersicht der Netzteile

Systemübersicht

CX1100-00xx | Netzteile und I/O-Schnittstellen

Die Spannungsversorgung eines CX10x0-Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100-Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen. Ein 4 + 1 Taster erlaubt Benutzereingaben ohne ein weitere Tastatur oder Eingabetafel. Die Anreihung lokaler I/O-Signale geschieht über die Netzteilvariante CX1100-0002, an die alle Beckhoff Busklemmen angeschlossen werden können, oder über CX1100-0003, die zusätzlich zu den Busklemmen auch den Anschluss der Beckhoff-Feldbus-Box-Module vom Typ Erweiterungs-Box IExxxx erlaubt. Mit der Anschlussmöglichkeit der Busklemmen und Feldbus Box entsteht eine Steuerung mit einer sehr variablen, erweiterbaren I/O-Ebene mit großer Signalvielfalt. Die I/O-Daten werden in einem DPRAM abgelegt, welches der CPU über den Systembus zugänglich ist. Die Netzteile des CX-Systems sind im Feld austauschbar: Wird z. B. lokales I/O über Busklemmen gewünscht, so kann CX1100-0001 im Feld durch CX1100-0002 ersetzt werden. Die Anreihung von EtherCAT-Klemmen ist über das Netzteil CX1100-0004 möglich. Die I/O-Daten werden beim CX1100-0004 direkt im Arbeitsspeicher der CPU abgelegt; ein DPRAM ist nicht mehr nötig. Das Netzteil CX1100-0004 bzw. die Anreihung von EtherCAT-Klemmen ist nur in Verbindung mit dem CPU-Grundmodul CX1020 / CX1000 und CX1010 möglich.

Für die neue CPU CX1030 ist eine modifizierte Stromversorgung notwendig. Daher sind die neuen Module CX1100-001x entwickelt worden. Sie entsprechen in ihrer Funktion der entsprechenden Variante CX1100-000x.

Die Technischen Daten sind bei den einzelnen Netzteilen abgelegt:

  • CX1100-0001
  • CX1100-0002 / CX1100-0012
  • CX1100-0003 / CX1100-0013
  • CX1100-0004 / CX1100-0014

Eine Übersicht über die Architektur der Netzteile mit Beschreibung der allgemeinen Systemkomponenten GCB, ACB, NOVRAM, Display und Taster sind allgemein erläutert, die speziellen Schnittstellen der einzelnen Module werden bei den entsprechenden Netzteilen erklärt.

  • Architektur
  • Display
  • Taster


CX1100-000x: Architektur der Netzteile

BECKHOFF CX1100-00xx: Architektur der Netzteile

Architektur der Netzteile

Die vier verfügbaren Netzteile des CX10x0-Systems erfüllen mehr als nur die Aufgabe, das System mit Strom zu versorgen. In jedem Netzteil sind drei Grundfunktionen verfügbar. Zusätzlich bieten die verschieden Modelle unterschiedliche Anbindungen an Kommunikationsbusse an. Durch diese erweiterten Funktionen unterscheiden sich die internen Architekturen der Netzteile. Zunächst werden die gemeinsamen Funktionen vorgestellt. Als Beispiel dient das Netzteils CX1100-0001, da dieses Modul stellt nur diese Grundfunktionen bereitstellt. Die weiteren Modelle beinhalten dann Erweiterungen zu dieser Architektur.

Alle Netzteile verfügen, abgesehen von der Spannungsversorgung, über folgende Funktionen:

  1. Display 2 x 16 Zeichen
  2. 4+1 Navigationsschalter
  3. Non Volatile RAM

Diese Funktionen werden über den PC104-Bus angesteuert. Das Strukturbild des CX1100-0001 zeigt die Funktionsblöcke.

"General Control Block" (GCB)

Die Steuerung erfolgt über das Programm in der CPU des Hauptmoduls. Über einen Speicherbereich werden die Daten ausgetauscht. Die zum Betrieb des Systems notwendigen Daten werden im "General Control Block" (GCB) zusammen gefasst. Seine Startadresse lautet "0xD1000". Das Schaubild zeigt die Daten und den Offset auf die Startadresse, an denen sie abgelegt sind. Einige Register werden nicht für alle Netzteile benötigt. Über die Adressumsetzung werden im Modul nur die benötigten Register angesprochen. Die anderen Adressen werden ausgeblendet.

Firmware Version:

Dieses Datenfeld enthält die Versionsnummer der Firmware. Sie ist hexadezimal kodiert.

Firmware Revision:

Dieses Datenfeld enthält die Revisionsnummer der Firmware. Auch sie ist hexadezimal kodiert.

Service Request / Response Bitfield: (nur für CX1100-0002 / -0003)

Über dieses Bitfeld können bestimmt Servicefunktionen ausgelöst werden. Die Funktion wird ausgelöst in dem das entsprechende Bit gesetzt ist. Die entsprechende Funktion wird ausgeführt zu die Reaktion im "Service Response Bitfield" angezeigt. Es ist möglich die Funktionen mehrfach zu verwenden, dazu muss das entsprechende Bit zunächst auf "Null" gesetzt werden und die Reaktion im "Response Bitfield" abgewartet werden. Anschließend kann die Funktion durch erneutes Setzen des Bits aufgerufen werden. Ein Ausführungsfehler wird im BIT 7 des "Response Bitfields" angezeigt. Die Bitfelder haben folgenden Aufbau:

Bitfeld | Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0
Request | - | - | - | - | - | Link Images | Remap | Reset Node
Response | Error | - | - | - | - | Images Linked | Remapped | Reset Done

Die Servicefunktionen haben folgende Aufgaben:

Reset Node:

Diese Funktion bewirkt ein Reset des 80C165 Microcontrollers. Dies ist kein genereller Systemreset. Es wird nur der Kontroller für die Kommunikationsschnittstellen zurückgesetzt.

Remap:

Mit diesem Befehl lassen sich die beiden PLC-Register, die sich im Speicherbereich des I/O-Prozesses befinden, in dem GCB abbilden.

Link Images:

Beim Setzen dieses Bits werden K-Bus und IP-Link-Bus logisch miteinander verbunden. Im Falle eines Fehlers werden beide Busse angehalten. Die Standardeinstellung für dieses Bit ist gesetzt, d.h. bei Fehlern auf dem einen Bus-System werden beide Systeme angehalten.

Watchdog Time:

Wird ein I/O-Zyklus durch ein "Processdata cycle request" angestoßen, so startet ein Timer. Dieser läuft bis zur in "Watchdog Time" eingestellten Zeit. Trifft in der Zwischenzeit kein weiteres "PD cycle request" Signal ein, so werden alle Ausgänge in den sicheren Zustand (alle Ausgänge auf "Null") gesetzt. Gleichzeitig wird der Wert im Register "Watchdog Error Counter" inkrementiert. Die Standardeinstellung für diesen Wert beträgt 100ms. Soll ein anderer Wert verwendet werden, so muss dieser in das Register geschrieben werden. Der Wert wird aber erst nach einem "Reset Node" - Befehl aktiviert.

Cycle Time:

Sie gibt die Zeit zwischen Start und Beendigung eines I/O-Prozessupdates an. Die Zeit wird in Millisekunden angegeben. Ein neuer Zyklus beginnt mit dem Eintreffen eines "PD cycle Requests"-Signals. Er endet mit dem "PD cycle Ready" -Signal. Für das Netzteil CX1100-0002 beträgt diese Zeitspanne die Zeit, die der K-Bus für ein Update benötigt. Beim CX1100-0003 beträgt diese Zeit die Updatezeit von K-Bus und IP-Link-Bus.

Watchdog Error Counter:

Tritt ein Überlauf im Watchdog-Timer auf, so wird dieser Wert um eins inkrementiert. Es lässt sich also die Anzahl von Watchdog-Zeitüberschreitungen auslesen. (verfügbar ab Firmware Version B6)

Processdata Error:

Diese Byte enthält die Informationen über den Zustand des I/O-Blöcke. Mögliche Zustände sind:

Bitfeld | Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0
Processdata Error | - | - | - | - | - | - | IP-Link Error | K-Bus Error

Das Bit wird logisch "Eins", wenn ein Fehler auftritt. Sind beide Werte "Null" liegt kein Fehler vor. Ein Fehler kann möglicherweise mit einem Reset des Busses behoben werden. Die Funktion hierfür wird im Control-Block des jeweiligen Busses aktiviert.

Processdata Cycle Overrun:

Diese Speicherzellen enthält einen Zähler. Dieser zählt die Zeitüberschreitungen, wenn ein "PD Cycle Request" - Signal eintrifft, bevor ein "PD Cycle Ready" - Signal anliegt. Dieser Überlauf kann nur auftreten, wenn durch einen Synchronisationsfehler im Programm die Zykluszeit kleiner ist, als die Zeit für den I/O-Update.

PD Cycle Ready / PD Cycle Request:

Diese beiden Bytes enthalten die Daten für den aktuellen Prozess. Das Programm legt einen Wert in dem "Request-Register" ab. Ist der Prozess beendet, so schreibt er diesen Wert in das "Ready-Register". Bei einem erneuten Prozess wird das "Request-Register" wieder überschrieben.

"Auxiliary Control Block" (ACB)

Für den Zugriff auf das Display bzw. den Taster wird ein weiterer Bereich benötigt. Dieser wird als "Auxiliary Control Block" bezeichnet. Er umfasst 16 Byte und liegt oberhalb des GCBs. Den Aufbau zeigt folgendes Schaubild:

Es lassen sich vier Register zusammenfassen. Im folgenden werden die Register mit ihren Bits erläutert.

Display Cmd Register:

R/#W: Dieses Bit steuert das Lesen bzw. Schreiben zur Programmierung des Displays.

DATA/#CMD: Hier wird zwischen Daten und Kommandos umgeschaltet.

EN: Aktivierungsbit zum Ausführen der Kommandos.

BL OFF: Mit diesem Bit kann die Hintergrundbeleuchtung des Displays abgeschaltet werden. Diese Funktion kann zum Blinken des Displays benutzt werden.

Display Data Register:

In diesem Byte werden Daten für die Programmierung des Displays gehalten. Diese Daten wirken im Zusammenspiel mit den Daten aus dem Display Cmd Register.

In Register:

Über dieses Register kann auf den Taster zugegriffen werden. Es handelt sich um eine 4+1 Navigationsschalter. Über diesen kann ein SPS-Programm ohne Tastatur oder Touchscreen mit Eingaben versorgt werden. Wird der Taster gedrückt, so ist das entsprechende Bit auf "Eins" gesetzt. Beim Lösen der Taste springt das Bit wieder auf "Null". Das Register ist im Prozessabbild von TwinCAT sichtbar und kann mit dem SPS-Programm verknüpft werden.

Bit 0 UP
Bit 1 DOWN
Bit 2 LEFT
Bit 3 RIGHT
Bit 4 SELECT
Bit 5 PWR-FAIL (für spätere Verwendung vorgesehen - nicht verwenden)

Ein Beispiel zum Ansteuern des Tasters findet sich bei der Beschreibung des Tasters.

Out Register:

Durch Setzen des Bit 0 wird der Microcontroller 80C165 zurück gesetzt. Dadurch werden die Busse (K-Bus / IP-Link) initialisiert. Dieser Schalter kann benutzt werden um bei Busproblemen den Bus zurück zu setzen. Zu Beginn des Betriebs muss es mindestens einmal gesetzt werden, damit der Bus initialisiert wird.

Die Bits 1, 2 und 3 (IRQ0, IRQ1 und IRQ2) sind für spätere Verwendung vorgesehen und dürfen NICHT gesetzt werden.

Speicherbereich 0xD1004 bis 0xD1008:

In diesem Bereich ist der Typ des Netzteils abgelegt. Nimmt man die vier Register zusammen, ergibt sich die Typen Bezeichnung.

CX1101 CX1100-0001 Netzteil mit Display, Taster und NOVRam

CX1102 CX1100-0002 Netzteil mit Display, Taster, NOVRam und K-Bus-Anschluss

CX1103 CX1100-0003 Netzteil mit Display, Taster, NOVRam, K-Bus-Anschluss und IP-Link-Anschluss

CX1104 CX1100-0004 Netzteil mit Display, Taster, NOVRam und E-Bus-Anschluss

Das Non Volatile RAM

Das NoVRam ist eine der wichtigsten Funktionen der Netzteile. Der Zugriff erfolgt über den PC104 - BUS. Die Anbindung an die SPS-Software erfolgt über den TwinCAT System Manager. Hier können benötigte Variablen bzw. entsprechende Bereiche definiert werden. Diese werden dann mit Variablen des Programms verknüpft. Details hierzu finden sich in der TwinCAT Dokumentation.

I/O-Zyklus mit Busklemmen

Verfügt ein Netzteil über einen Klemmenanschaltung (CX1100-0002 und CX1100-0003), so kann der Abfragezyklus der Klemmen in einem Programm auf der CPU gesteuert werden. Das folgende Schaubild zeigt eine solchen Zyklus. Er besteht aus 8 Schritten.

Das Programm initialisiert den Klemmbus. Details hierzu sind im GCB beschrieben. (Servicefunktion: Reset node) Dann wird eine beliebige Nummer (hier 4711) als aktuelle Zyklusnummer in das Feld "PD cycle request" des GCBs geschrieben. Es kann dabei jede beliebige Zahl verwendet werden. Es bietet sich aber an, eine aufsteigende Nummerierung zu verwenden, um im Fehlerfall den Zyklus identifizieren zu können. Der Microcontroller liest den Wert und veranlasst die Klemmen ihre Daten an den Controller zu senden. Dieser schreibt die Daten in das Prozessabbild im DPRAM. Sind alle Daten im DPRAM abgelegt, wird die Zyklusnummer in das Feld "PD cycle ready" im GCB geschrieben. Das Programm prüft alle 10 ms, ob Daten von dem Klemmbus geliefert wurden. Ein K-Bus-Zyklus ist auch bei maximaler Klemmenzahl deutlich kleiner als 10 ms. Die Zeit liegt in etwa zwischen 700 µs und 5 ms. Ist nach 10 ms keine gültige Zyklusnummer (also die gleiche wie die aktuelle Nummer) im Register "DP cycle ready" im GCB, so ist wahrscheinlich ein Fehler aufgetreten und das Programm versucht den Fehler auszuwerten und beendet danach die Schleife. Ist die Zyklusnummer korrekt gesendet worden können die Daten aus dem DPRAM gelesen und verarbeitet werden. Die Ergebnisse der Verarbeitung werden dann wieder ins DPRAM geschrieben und ein neuer Zyklus wird angestoßen indem die Zyklusnummer erhöht und ins Register "PD cycle request" geschrieben wird.

Da die Klemmen im K-Bus mit einem Watchdog versehen sind, sollte der K-Bus mindestens alle 100 ms abgefragt werden, da sonst der K-Bus angehalten wird. Sollten mehr als ein Prozess Zugriff auf den Klemmbus benötigen, so greifen alle Prozesse auf das gleiche Speicherabbild des DPRAMs zu. Nur der Prozess mit der höchsten Priorität initiiert den Datenaustausch mit dem K-Bus. Auf diese Weise sollte gewährleistet sein, dass alle Prozesse ihre Daten in gewünschter Form erhalten. Zugriffskonflikte muss der Anwender selbst ausschließen!


Speicheradressen

BECKHOFF CX-System: Übersicht der Speicheradressen

Adapter RAM Hardware Adressübersicht

verfügbarer Adressraum bei CX1020: D0000-DFFFF (hex)

Base Address (hex) | End Address (hex) | Size(Bytes)(hex) | Access Type | Description
D0000 | D0FFF | 1000 | R/W | CX1100-0002/3 Dual Ported RAM
D1000 | D100F | 10 | R/W | CX1100 Auxiliary Control Block( LCD Display, misc. registers)
D1010 | D101F | 10 | R/W | CX1100-0900 UPS Control Block
D2000 | D3FFF | 2000 | R/W | CX1100 Non Volatile RAM
D4000 | D5FFF | 2000 | R/W | CX1500-M310 Profibus Master DPRAM
D6000 | D7FFF | 2000 | R/W | CX1500-M510 CANopen Master DPRAM
D8000 | D9FFF | 2000 | R/W | CX1500-M520 DeviceNet Master DPRAM
DA000 | DBFFF | 2000 | R/W | CX1500-M200 Lightbus Master DPRAM
DC000 | DDFFF | 2000 | R/W | CX1500-M750 Sercos Master DPRAM

Für einige Felsbusanschaltungen (alle Slaveanschaltungen) liegen die eingeblendeten Adressen im Speicherbereich größer als DFFFF (hex). Für diese Anschaltungen müssen bei der Bestellung Module mit anderen Basisadressen bestellt werden. Gleiches gilt auch für den Einsatz von mehreren Mastermodulen des gleichen Feldbustyps. Die Bestellnummer lauten dann wie folgt:

Bestellnummer | Alternative ISA-Adresse
Masteranschaltungen
CX1500-Mxxx-0001 | D4000
CX1500-Mxxx-0002 | D6000
CX1500-Mxxx-0003 | D8000
CX1500-Mxxx-0004 | DA000
CX1500-Mxxx-0005 | DC000
Slaveanschaltungen
CX1500-Bxxx-0001 | D4000
CX1500-Bxxx-0002 | D6000
CX1500-Bxxx-0003 | D8000
CX1500-Bxxx-0004 | DA000
CX1500-Bxxx-0005 | DC000

Für xxx ist das entsprechende Feldbussystem einzusetzen:

  • 200 für Lightbus
  • 310 für Profibus
  • 510 für CAN-open
  • 520 für DeviceNet.

Hinweis |
 | Es können zwei Feldbusanbindungen (Master oder Slave) ohne Einschränkungen eingesetzt werden. Für mehr als zwei Anbindungen ist eine Freigabe durch die Beckhoff Automation GmbH erforderlich.


CX1100-000x: Display

BECKHOFF CX1100-00xx: Display

Aufbau des Displays

Das Display des CX1100-00xx ist ein LCD-Display. Es verfügt über 2 x 16 Zeichen. Jedes Zeichen hat eine Auflösung von 5 x 8 Pixel. Der Zeichensatz hat die Bezeichnung SPLC780C-11 und ist fest eingestellt. Die folgende Abbildung zeigt den Zeichensatz mit allen verfügbaren Zeichen.

Zum erleichterten Lesen der Anzeige ist eine steuerbare Hintergrundbeleuchtung in das Display integriert. Des Weitern kann durch Ein- und Ausschalten der Beleuchtung ein Blinken der Anzeige erreicht werden. Auf diese Weise kann die Aufmerksamkeit von Anwendern in bestimmten Situationen erreicht werden. Die Ansteuerung erfolgt über einen Displaycontroller. Dieser liest im "Auxiliary Control Block" die Display-Register aus und bearbeitet die Daten entsprechend.


CX1100-000x: Ansteuerung des Displays

BECKHOFF CX1100-00xx: Ansteuerung des Displays

Darstellen von Texten auf dem Display

Mit Hilfe von TwinCAT lässt sich das Display auf zwei Arten steuern. Eine Variante ist die Programmierung über den System Manager. Als zweite Möglichkeit kann das Display über einen Funktionsbaustein direkt aus dem SPS-Programm beschrieben werden.

Einstellungen im System Manager

Beim Start des TwinCAT-Systems kann das Display mit dem in der Konfiguration festgelegt Text beschrieben werden. Dieser Text wird im System Manager eingestellt.

Dazu wird im Hierarchiebrowser das CX10x0-Gerät ausgewählt. Unter dem Karteireiter CX1100 können dann im Bereich "Display Einstellungen" die beiden Zeilen des Displays beschrieben werden. Dazu müssen die Felder an der Stelle für Initialisierung und Schreiben angewählt sein. Die Änderungen werden nur wirksam, wenn die Konfiguration geschrieben wird. Beim Restart des TwinCATs wird dann der eingestellte Text angezeigt.

Über den Reiter Display kann das Display direkt angesteuert werden. Über die Schalter werden die entsprechenden Funktionen sofort ausgeführt. Man kann folgende Funktionen ausführen:

  • Display an/aus schalten (Text wird angezeigt/ausgeblendet)
  • Hintergrundbeleuchtung an/aus
  • Löschen des Displays (Text wird gelöscht und muss erneut eingeben werden)
  • Cursor an/aus (Schreibmarke wird angezeigt)
  • Cursor Blink an/aus (Schreibmarke blinkt)

In dem Texteingabefeld wird der gewünschte Text eingetragen. Mit dem Schalter "Write Current" wird der Text an die Position der aktuellen Schreibmarke geschrieben.

Mit dem Schalter "Write At", dem Zahleneingabefeld und der Checkbox "Second Line" kann gezielt an eine Position im Display geschrieben werden. Der sinnvolle Wertebereich für Position geht von 0 bis 15. Der Anwender sollte aber auch die Länge des Textes beachten. (Jede Zeile hat 16 Zeichen!) Im unten dargestellten Beispiel wird der Text "CX1100-000x" an Position 0 (Anfang der Zeile) in Zeile 2 geschrieben.

Einstellungen im SPS-Programm

Zur Ansteuerung des Displays in einem SPS-Programm stellt die Bibliothek für die CX-Familie (TcCX1000System.lib) den Funktionsblock FB_CX1000SetTextDisplay zur Verfügung. Über diesen Funktionsblock können alle Funktionen des Displays aufgerufen werden. Die Bibliothek muss über den Bibliotheksverwalter eingebunden werden. Ist dies geschehen, steht der Baustein als Funktionsblock zur Verfügung. Er wird als solcher im Deklarationsteil des Programms instanziert.

PROGRAM MAIN
VAR
    Display_0 :  FB_CX1000SetTextDisplay;
END_VAR

Im Programm erfolgt dann der Aufruf mit den Parametern. Es gibt fünf Parameter für diesen Funktionsblock:

  • bExecute : BOOL
  • nDevID : UDINT
  • nMode : E_CX1000_DisplayModes
  • stLine : STRING(20)
  • nCursorPos : DWORD

Mit "bExecute" wird bei steigender Flanke wird das Kommando ausgeführt. "nDevID" gibt die Device ID des CX1100-Gerätes, auf das geschrieben wird, an. Die ID wird im System Manager angezeigt. (Reiter für Allgemein bei CX1100, oben rechts). Mit dem Parameter "stLine" wird ein Text von maximal 20 Zeichen übergeben. Es werden aber nur die ersten 16 Zeichen davon dargestellt. Mit "nCursorPos" wird die Schreibposition des Textes angegeben. Als sinnvoller Wertebereich kommt hier 0 bis 15 in Frage. Mit "nMode" wird der Betriebsmodus des Funktionsblocks gewählt. Die Modi sind im einzelnen:

  • e_CX1000_DisplayNoAction : Keine Aktion.

  • e_CX1000_DisplayOn : Einschalten des Displays.

  • e_CX1000_DisplayOff : Ausschalten des Displays.

  • e_CX1000_CursorOn : Einschalten des Cursors.

  • e_CX1000_CursorOff : Ausschalten des Cursors

  • e_CX1000_CursorBlinkOn : Einschalten des Cursors blinkend.

  • e_CX1000_CursorBlinkOff : Ausschalten des Cursors blinkend.

  • e_CX1000_BackLightOn : Einschalten der Hintergrundbeleuchtung

  • e_CX1000_BackLightOff : Ausschalten der Hintergrundbeleuchtung.

  • e_CX1000_ClearDisplay : Löschen des Bildschirminhaltes.

  • e_CX1000_WriteLine1 : Schreiben der ersten Zeile.

  • e_CX1000_WriteLine1 : Schreiben der zweiten Zeile.

Der Aufruf sieht dann wie folgt aus:

Display_0(
    bExecute := write_now, 		(* write_now ist ein boolscher Wert und fungiert als Schalter)
    nDevID	:= 1,			(* DeviceID des CX1100 *)
    nMode	:= e_CX1000_WRITELine1,	(* Schreiben auf erste Zeile des Displays *)
    stLine	:= 'Beckhoff CX1100',	(* Konstanter Text, hier kann aber auch eine Variable stehen *)
    nCursorPos := 0			(* Schreibposition ist 0, also Anfang der Zeile*)
);

Für die Auswertung im Programmumfeld liefert der Baustein einige Statussignale. Diese können als Rückmeldung zum SPS-Programm benutzt werden. Es gibt drei Antwortsignale aus der Funktion:

  • bBusy : BOOL
  • bErr : BOOL
  • nErrorID : UDINT

"bBusy" signalisiert, dass das Kommando gerade per ADS übertragen wird. Solange "bBusy" auf TRUE ist, wird kein neues Kommando angenommen. "bErr" meldet Fehler bei einem Funktionsblockaufruf. (Signal geht auf TRUE). Über die "nErrorID" kann dann der aufgetretene Fehler über eine Fehlernummer analysiert werden. Die Fehlernummer bezeichnet einen Fehler im ADS-Protokoll.


Ansteuerung über ADS

Das LCD-Display der Netzteile besitzt zwei Zeilen à 16 Zeichen und dient zur Anzeige von System- und Anwendermeldungen.

"Index-Group/Offset"Spezifikation für das LCD Display

ADS Port 300

Index Group | Index Offset | Access | Data type | Phys. unit | Def. range | Description | Remarks
0x00005000 + DeviceID | 0xFFFF90FF | R&W |  |  |  | Cursor OFF |
0x00005000 + DeviceID | 0xFFFF91FF | R&W |  |  |  | Cursor ON |
0x00005000 + DeviceID | 0xFFFF92FF | R&W |  |  |  | Cursor blink OFF |
0x00005000 + DeviceID | 0xFFFF93FF | R&W |  |  |  | Cursor blink ON |
0x00005000 + DeviceID | 0xFFFF94FF | R&W |  |  |  | Display OFF |
0x00005000 + DeviceID | 0xFFFF95FF | R&W |  |  |  | Display ON |
0x00005000 + DeviceID | 0xFFFF96FF | R&W |  |  |  | Backlight OFF |
0x00005000 + DeviceID | 0xFFFF97FF | R&W |  |  |  | Backlight ON |
0x00005000 + DeviceID | 0xFFFFA0FF | R&W |  |  |  | Write Text line 1 |
0x00005000 + DeviceID | 0xFFFF00FF | R&W |  |  |  | Write Text line 2 |


Taster des CX1100-000x

BECKHOFF CX1100-00xx: Taster

Funktionsweise des Tasters

Die CX1100-000x Netzteile verfügen alle über eine 4 + 1 Navigationstaster. Es können als fünf Grundzustände über den Taster eingegeben werden:

  1. UP
  2. DOWN
  3. LEFT
  4. RIGHT
  5. SELECT

Darüber hinaus können auch kombinierte Eingaben also UP + RIGHT oder UP + RIGHT + SELECT erfasst werden. Die Werte des Tasters werden in einem Register des "Auxiliary Control Blocks" ACB abgelegt. Details sind in der Architekturbeschreibung nachzulesen.

In einem SPS-Programm wird kann auf das Register zugegriffen werden und der Wert ausgewertet werden. Dazu muss in dem SPS-Programm zunächst eine Variable vom Type USINT angelegt werden. Diese wird dann im TwinCAT System Manager mit dem IN-Register des CX1100 verbunden.

Die Abbildung zeigt die verknüpften Signale (hellrot unterlegt). Über die Variable Taster kann jetzt im SPS-Programm auf den Taster zugegriffen werden. Das SPS-Programm hat die folgende Gestallt. Zuerst wird eine externe Variable als Eingang deklariert. (In diesem Beispiel an Adresse 0)

PROGRAM MAIN
VAR
    Taster AT %IB0 : USINT;
END_VAR

Über ein einfaches CASE-Statement kann der Schalter dann ausgewertet, und die gewünschte Funktion initiiert werden z.B.:

CASE Taster OF
0: 	ACTION := NONE;
1:	ACTION := UP;
2:	ACTION := DOWN;
4:	ACTION := LEFT;
8:	ACTION := RIGHT;
16: 	ACTION := SELECT;
END_CASE;

In diesem Fall ist "ACTION" ein neu definierter ENUM-Type. Es kann auch die gewünschte Aktion sofort aktiviert werden.

Für die kombinierten Funktionen werden die Zahlwerte addiert. Also UP (1) und RIGHT (8) wäre dann 8 + 1 = 9 (Rechts-Oben). Es sind auf diese Weise nur sinnvolle Kombinationen möglich also Gegenüber liegende Schalterpositionen sind ohne Zerstörung des Schalters nicht anwählbar.

Will man die Auswertung nicht selbst vornehmen, so stellt das TwinCAT-System eine Bibliotheksfunktion bereit, die die Umwandlung der Tastereingabe in einen ENUM-Type realisiert. Dazu muss zuerst die Bibliothek für die CX-Systeme: TcSystemCX.lib im Bibliotheksverwalter eingebunden werden. Die Funktion heißt " F_CXNaviSwitch(iCX1100_IN : USINT) " und liefert einen ENUM-Type. Dieser codiert namentlich die gedrückte Richtung des Schalters also z.B. e_CX1100_NaviSwitch_MIDDLE für <Mitte>. Alle gültigen Varianten lauten:

  • e_CX1100_NaviSwitch_IDLE
  • e_CX1100_NaviSwitch_MIDDLE
  • e_CX1100_NaviSwitch_TOP
  • e_CX1100_NaviSwitch_TOPRIGHT
  • e_CX1100_NaviSwitch_RIGHT
  • e_CX1100_NaviSwitch_BOTTOMRIGHT
  • e_CX1100_NaviSwitch_BOTTOM
  • e_CX1100_NaviSwitch_BOTTOMLEFT
  • e_CX1100_NaviSwitch_LEFT
  • e_CX1100_NaviSwitch_TOPLEFT
  • e_CX1100_NaviSwitch_MIDDLE_TOP
  • e_CX1100_NaviSwitch_MIDDLE_TOPRIGHT
  • e_CX1100_NaviSwitch_MIDDLE_RIGHT
  • e_CX1100_NaviSwitch_MIDDLE_BOTTOMRIGHT
  • e_CX1100_NaviSwitch_MIDDLE_BOTTOM
  • e_CX1100_NaviSwitch_MIDDLE_BOTTOMLEFT
  • e_CX1100_NaviSwitch_MIDDLE_LEFT
  • e_CX1100_NaviSwitch_MIDDLE_TOPLEFT

Weitere Details zu der Funktion sind in der Dokumentation zu TwinCAT nachzulesen. In einem Programm kann die Funktion wie folgt eingesetzt werden: (die Deklaration und Verknüpfung sind wie im oberen Beispiel angegeben)

CASE F_CXNaviSwitch(Taster) OF
e_CX1100_NaviSwitch_IDLE 			:;              (* do nothing *)
e_CX1100_NaviSwitch_MIDDLE 			:call_select;   (* select item *)
e_CX1100_NaviSwitch_TOP 			:call_prev_item;(* previous menue item *)
e_CX1100_NaviSwitch_RIGHT 			:call_inc_value;(* increase value *)
e_CX1100_NaviSwitch_BOTTOM 			:call_next_item;(* next menue item *)
e_CX1100_NaviSwitch_LEFT 			:call_dec_value;(* decrease value *)
END_CASE;
Die weitere Auswertung der Schaltereingabe erfolgt dann auch hier im fortlaufenden Programm.


Anschlüsse CX1100-0001

Dieses Netzteil besitzt keine E/A-Schnittstelle, die Stromversorgung erfolgt daher über den 5-poligen "Open Pluggable Connector". Das Netzteil versorgt über den PC104-Bus alle weiteren Systemkomponenten mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff.
Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten.

Pinbelegung "Open Pluggable Connector":

Pin | Belegung
1 | +24 V DC
2 | 0 V DC
3 | GROUND
4 | reserved / don't use
5 | reserved / don't use

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.


Technische Daten CX1100-0001

Abmessungen:

Die Spannungsversorgung eines CX1020 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Das Netzteil CX1100-N001 besitzt keine E/A Schnittstellen.

Technische Daten | CX1100-0001
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 2,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | -
E-Bus Anschluss | -
IP-Link Anschluss | -
K-Bus Stromversorgung bis max. | -
Anschlussart | 1 x Open Pluggable Connector, 5-polig
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x PWR
Abmessungen | 45 mm x 100 mm x 91 mm
Gewicht | 180 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Architektur CX1100-0001

Architektur des Netzteils CX1100-0001

Diese Netzteil verfügt, abgesehen von der Spannungsversorgung, über folgende Funktionen:

  1. Display 2 x 16 Zeichen
  2. 4+1 Navigationsschalter
  3. Non Volatile RAM

Diese Funktionen werden über den PC104-Bus angesteuert. Das Strukturbild des CX1100-0001 zeigt die Funktionsblöcke.

Dieses Netzteil verfügt nur über die Grundfunktionen. Diese sind in der Architekturbeschreibung erläutert.


Anschlüsse CX1100-0002

BECKHOFF CX1100-00xx: Übersicht / elektrischer Anschlüsse

Anschlüsse CX1100-00x2

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den K-Bus die Busklemmen mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff. Da der K-Bus nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.
Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten.

CX1100-0002 für CX1000, CX1010 und CX1020 | CX1100-0012 für CX1030

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.

Die I/O LEDs dienen zur Anzeige der Betriebsstände der Busklemmen. Der fehlerfreie Hochlauf der Konfiguration wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0002

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0002
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | -
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 2 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 40 mm x 100 mm x 91 mm
Gewicht | 250 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0012

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vieri wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0012
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | -
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 2 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 42 mm x 109 mm x 92 mm
Gewicht | 240 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Architektur CX1100-00x2

Architektur des Netzteils CX1100-00x2

Diese Netzteil verfügt, abgesehen von der Spannungsversorgung, über folgende Funktionen:

  1. Display 2 x 16 Zeichen
  2. 4+1 Navigationsschalter
  3. Non Volatile RAM
  4. K-Bus Anschluss

Diese Funktionen werden über den PC104-Bus angesteuert. Das Strukturbild des CX1100-0001 zeigt die Funktionsblöcke.

Dieses Netzteil verfügt über die Grundfunktionen. Diese sind in der Architekturbeschreibung erläutert. Darüber hinaus wird der Klemmbus unterstützt. Der Zugriff erfolgt über ein 4Kbyte großes Dual-ported-RAM (DPRAM). Ein Microcontroller (80C165) steuert die Datenübertragung zum K-Bus. Das DPRAM wird von der CPU (über den PC104-Bus) und dem Microcontroller geschrieben. Das folgende Schaubild zeigt den Speicheraufbau des DPRAMS.

Im unteren Speicherbereich (D000 bis D0400) ist das Abbild des K-Busses abgelegt. Der Bereich teilt sich in Ein- und Ausgangsbereich. Seit dem Firmwarestand ≥ B3 ist es möglich die Speicherbereiche zu verschieben. Auf diese Weise kann das Prozessabbild an die benötigten Bereich angepasst werden. Zu jedem I/O-Bereich gibt es einen Steuerblock. Dieser umfasst je 8 Byte und ist für Diagnosezwecke vorgesehen. Auch diese Bereiche können entsprechend verschoben werden. Die folgende Tabelle zeigt den Aufbau der beiden Interface-Blöcke. Die angegebenen Offsetadressen sind die Standardeinstellungen.

Legacy PLC interface (inputs)
Offset | Default
0x1F8 [2] | Diagnose von CX1100-0002 zu K-Bus
0x1FA [2] | 2 Byte PLC Interface von CX1100-0002 zu K-Bus
0x1FC [4] | reserviert
Legacy PLC interface (outputs)
Offset | Default
0x3F8 [2] | Diagnose K-Bus zu CX1100-0002
0x3FA [2] | 2 Byte PLC Interface von K-Bus zu CX1100-0002
0x3FC [4] | reserviert

Der K-Bus Control Block (CB K-Bus)

Der folgende Abschnitt beschreibt den K-Bus Control Block. Er liegt im Speicherbereich nach dem GCB.

CB K-Bus
Offset |  | Default
0xFD0[2] | K-Bus 2 byte plc interface to CX1100-0002/3 |
0xFD2[2] | K-Bus 2 byte plc interface from CX1100-0002/3 |
0xFD4[2] | K-Bus diagnosis to CX1100-0002/3 |
0xFD6[2] | K-Bus diagnosis from CX1100-0002/3 |
0xFD8 | K-Bus service request bitfield |
0xFD9 | K-Bus service response bitfield |
0xFDA | K-Bus error code |
0xFDB | K-Bus error argument |
0xFDC[2] | K-Bus base ptr Inputs | 0x000
0xFDE[2] | K-Bus base ptr Outputs | 0x200
0xFE0-0xFE1 | K-Bus cycle count |
0xFE2-0xFE3 | K-Bus cycle time [µs] |
0xFE4 | K-Bus bus status |
0xFE5-0xFEE | Reserved |
0xFEF | Retry counter |

K-Bus 2 byte plc interface to CX1100-0002/3 / K-Bus 2 byte plc interface from CX1100-0002/3

Diese vier Byte, für jede Richtung zwei Byte, werden benötigt um mit dem I/O-Microcontroller zu kommunizieren. Durch dieses Interface findet ein Datenaustausch mit den K-Bus-Klemmen statt. Das so genannte Registermodell wird detailliert in den Handbüchern der Bus-Koppler und Klemmen beschrieben. Der Datenaustausch dient vor allem der erweiterten Diagnose oder der Konfiguration von Klemmen. Damit können Einstellungen, sofern sie von dem Auslieferzustand abweichen, angepasst werden. (z.B. Baudrate bei RS232 Schnittstellen, Offsetwerte bei analogen Klemmen)

K-Bus diagnosis to CX1100-0002/3 / K-Bus diagnosis from CX1100-0002/3

Über diese vier Bytes, zwei pro Richtung, werden Diagnosedaten übermittelt. Da die gleichen Daten in dem Prozessabbild dargestellt sind, wird diese Schnittstelle im Allgemeinen nicht benötigt.

K-Bus service request bitfield / K-Bus service response bitfield

In diesen beiden Bitfeldern können Servicefunktionen aufgerufen werden. Ähnlich wie beim GCB werden durch das Setzen von einzelnen Bits Funktionen ausgeführt. Bevor die gleiche Funktion wieder ausgeführt werden kann, muss das Bit für einen Zyklus zurückgesetzt werden. Ein Fehler beim Ausführen einer Funktion wird im den 7. Bit des Response Bytes signalisiert. Die folgende Tabelle beschreibt die zur Zeit implementierten Funktionen.

Bitfeld | Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0
Request | - | - | - | - | - | - | Free Run | Reset Bus
Response | Error | - | - | - | - | - | Free Run Active | Reset Done

Reset Bus:

Durch das Setzen dieses Bits wird ein Reset des K-Busses ausgelöst. Dies ist notwendig nach Auftreten eines Fehlers (z.B. eine Bus-Klemme ist entfernt worden). Nach einem Reset kann der Fehlercode und der Fehlertext im Contol Block des K-Bus gelesen werden. Liegt kein weiter Fehler vor, so kann der K-Bus seinen Betrieb wieder aufnehmen.

Free Run:

nicht implementiert, für spätere Verwendung vorgesehen.

K-Bus error code K-Bus error argument

Falls auf dem K-Bus Fehler auftreten (defekte Klemme, fehlende Terminierung, EMC Interferenz) wird ein Fehler-Flag im GBC gesetzt. Nach dem K-Bus-Reset sind Fehlernummer und Fehlertext in diesen beiden Bytes abgelegt, sofern der Fehler nicht durch den Reset beseitigt wurde.

K-Bus base ptr Inputs / K-Bus base ptr Outputs

Diese bedien Bytes enthalten den Offset für die I/O-Bereiche des K-Bus-Interface. In dem meisten Fällen sollten diese Bereiche nicht verändert werden. Ändert man diese Werte muss darauf geachtet werden, dass es zu keiner Überlappung mit anderen I/O-Bereichen (z.B. IP-Link) kommt. Die Änderung der Werte muss mit der "Remap" oder "Reset node" Funktion im GCB aktiviert werden.

Die Beckhoff Automation Software TwinCAT verwendet diese Pointer und optimiert die I/O Bereiche.

K-Bus cycle count

Dieser zwei Byte große Zähler wird mit jedem I/O-Zyklus erhöht.

K-Bus cycle time

Diese Zeit gibt die Zeitspanne eines Zyklus an. Ein Zyklus beginnt mit der Initiierung und endet mit der Terminierung eines I/O-Prozess-Updates (K-Bus). Die Zeit wird in Microsekunden gemessen. Die Zeitspanne zwischen dem Eintreffen der Signale "PD cycle request" und "PD cycle ready" entspricht im Fall der CX1100-0002 der Zykluszeit. Bei der CX1100-0003 beschreibt diese Zeit nur den Anteil der Zykluszeit, die auf den K-Bus entfällt; nicht aber die gesamte Zykluszeit.

K-Bus bus status

Dieses Register kann zwei Werte annehmen:

  1. Byte = 0 → K-Bus läuft ohne Fehler
  2. Byte ≠ 0 → K-Bus Fehler aufgetreten

Diese Information wird ebenfalls im "Processdata error" Byte (Bit 0) des GCB dargestellt.

Retry counter

Dieser Zähler wird mit jedem Kommunikationsfehler des K-Bus erhöht. Tritt ein Fehler auf, so wird der Sendeversuch wiederholt. Auf diese Weise gibt der Zähler die Signalqualität des K-Bus wieder.


Anschlüsse CX1100-0003

BECKHOFF CX1100-00xx: Übersicht / elektrischer Anschluss

Anschlüsse CX1100-00x3

Dieses Netzteil ermöglicht neben einem Anschluss der Beckhoff Busklemmen auch die Anreihung der Beckhoff Feldbus Box Module vom Typ Erweiterungs-Box IExxxx. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0V". Die Versorgungsspannung versorgt das CX System und über den K-Bus die Busklemmen. Da der K-Bus nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.

CX1100-0003 für CX1000, CX1010 und CX1020 CX1100-0013 für CX1030

Feldbusanschluss:

Stecken Sie den IP-Link Stecker in die vorgesehenen Anschlüsse, d.h je einen Lichtwellenleiter in IN (x03) bzw. OUT (x04). Das andere Ende verbinden Sie mit dem entsprechenden IP-Link Interface der Erweiterungs-Box. Die Verbindung mit dem muss so erfolgen, dass der Output der Feldbusanschaltung mit dem Input der Erweiterungs-Box verbunden wird, und umgekehrt.

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot. Die I/O LEDs dienen zur Anzeige der Betriebsstände der Busklemmen. Der fehlerfreie Hochlauf der Konfiguration wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0003

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0003
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 4 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | ja
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 4 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 58 mm x 100 mm x 91 mm
Gewicht | 350 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0013

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0013
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 4 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | ja
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 4 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 58 mm x 109 mm x 92 mm
Gewicht | 325 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Architektur CX1100-00x3

Architektur des Netzteils CX1100-00x3

Diese Netzteil verfügt, abgesehen von der Spannungsversorgung, über folgende Funktionen:

  1. Display 2 x 16 Zeichen
  2. 4+1 Navigationsschalter
  3. Non Volatile RAM
  4. K-Bus Anschluss
  5. IP-Link Anschluss

Diese Funktionen werden über den PC104-Bus angesteuert. Das Strukturbild des CX1100-0003 zeigt die Funktionsblöcke.

Dieses Netzteil verfügt über die Grundfunktionen. Diese sind in der Architekturbeschreibung erläutert. Darüber hinaus wird der Klemmbus unterstützt. Diese Schnittstelle wird ausführlich in der Architekturbeschreibung des CX1100-0002 erläutert. Das Netzteil CX1100-0003 verfügt zusätzlich über ein IP-Link-Interface. Hier wird ein Lichtwellenleiterbus (LWL-Bus) angeschlossen. Der Zugriff erfolgt auch über das 4Kbyte großes Dual-ported-RAM (DPRAM). Ein Microcontroller (80C165) steuert die Datenübertragung zum IP-Link. Das DPRAM wird von der CPU (über den PC104-Bus) und dem Microcontroller geschrieben. Das folgende Schaubild zeigt den Speicheraufbau des DPRAMS.

Im mittleren Speicherbereich, über dem K-Bus-Abbild, (D400 bis D0A00) ist das Abbild des IP-Link-Busses abgelegt. Der Bereich teilt sich in Ein- und Ausgangsbereich. Pro Bereich stehen in der Standardkonfiguration je 768 Byte zur Verfügung. Seit dem Firmwarestand ≥ B3 ist es möglich die Speicherbereiche zu verschieben. Auf diese Weise kann das Prozessabbild an die benötigten Bereich angepasst werden.

The IP-Link Control Block (CB IP-Link)

Dieser Abschnitt beschreibt die Struktur des Control-Blocks für die IP-Link Anbindung des CX1100-0003. Dieser Control-Block liegt im Speicher unterhalb dem Bereich des CB des K-Busses.

CB IP-Link
Offset |  | Default
0xFB0[2] | IPL 2 byte plc interface to CX1100-0002/3 |
0xFB2[2] | IPL 2 byte plc interface from CX1100-0002/3 |
0xFB4[2] | IPL diagnosis to CX1100-0002/3 |
0xFB6[2] | IPL diagnosis from CX1100-0002/3 |
0xFB8 | IPL service request bitfield |
0xFB9 | IPL service response bitfield |
0xFBA | IPL error code |
0xFBB | IPL error argument |
0xFBC[2] | IPL base ptr Inputs | 0x400
0xFBE[2] | IPL base ptr Outputs | 0x700
0xFC0-0xFC1 | IPL cycle count |
0xFC2-0xFC3 | IPL cycle time [µs] |
0xFC4 | IPL bus status |
0xFC5-0xFCE | Reserved |
0xFCF | Retry counter |

IP-Link 2 byte plc interface to CX1100-0002/3 / IP-Link 2 byte plc interface from CX1100-0002/3

Diese vier Byte, für jede Richtung zwei Byte, werden benötigt um mit dem I/O-Microcontroller zu kommunizieren. Durch dieses Interface findet ein Datenaustausch mit den IP-Link-Anschlüssen statt. Das so genannte Registermodell wird detailliert in den Handbüchern der Bus-Koppler und Klemmen beschrieben. Der Datenaustausch dient vor allem der erweiterten Diagnose oder der Konfiguration von Klemmen. Damit können Einstellungen, sofern sie von dem Auslieferzustand abweichen, angepasst werden. (z.B. Baudrate bei RS232 Schnittstellen, Offsetwerte bei analogen Klemmen)

IP-Link diagnosis to CX1100-0002/3 / IP-Link diagnosis from CX1100-0002/3

Über diese vier Bytes, zwei pro Richtung, werden Diagnosedaten übermittelt. Da die gleichen Daten in dem Prozessabbild dargestellt sind, wird diese Schnittstelle im Allgemeinen nicht benötigt.

IP-Link service request bitfield / IP-Link service response bitfield

In diesen beiden Bitfeldern können Servicefunktionen aufgerufen werden. Ähnlich wie beim GCB werden durch das Setzen von einzelnen Bits Funktionen ausgeführt. Bevor die gleiche Funktion wieder ausgeführt werden kann, muss das Bit für einen Zyklus zurückgesetzt werden. Ein Fehler beim Ausführen einer Funktion wird im den 7. Bit des Response Bytes signalisiert. Die folgende Tabelle beschreibt die zur Zeit implementierten Funktionen.

Bitfeld | Bit 7 | Bit 6 | Bit 5 | Bit 4 | Bit 3 | Bit 2 | Bit 1 | Bit 0
Request | - | - | - | - | - | - | Free Run | Reset Bus
Response | Error | - | - | - | - | - | Free Run Active | Reset Done

Reset Bus:

Durch das Setzen dieses Bits wird ein Reset des IP-Links-Busses ausgelöst. Dies ist notwendig nach Auftreten eines Fehlers (z.B. eine Bus-Klemme ist entfernt worden). Nach einem Reset kann der Fehlercode und der Fehlertext im Contol Block des IP-Link gelesen werden. Liegt kein weiter Fehler vor, so kann der K-Bus seinen Betrieb wieder aufnehmen.

Free Run:

nicht implementiert, für spätere Verwendung vorgesehen.

K-Bus error code K-Bus error argument

Falls auf dem K-Bus Fehler auftreten (defekte Klemme, fehlende Terminierung, EMC Interferenz) wird ein Fehler-Flag im GBC gesetzt. Nach dem K-Bus-Reset sind Fehlernummer und Fehlertext in diesen beiden Bytes abgelegt, sofern der Fehler nicht durch den Reset beseitigt wurde.

K-Bus base ptr Inputs / K-Bus base ptr Outputs

Diese bedien Bytes enthalten den Offset für die I/O-Bereiche des IP-Link-Interface. In dem meisten Fällen sollten diese Bereiche nicht verändert werden. Ändert man diese Werte muss darauf geachtet werden, dass es zu keiner Überlappung mit anderen I/O-Bereichen (z.B. IP-Link) kommt. Die Änderung der Werte muss mit der "Remap" oder "Reset node" Funktion im GCB aktiviert werden.

Die Beckhoff Automation Software TwinCAT verwendet diese Pointer und optimiert die I/O Bereiche.

IP-Link cycle count

Dieser zwei Byte große Zähler wird mit jedem I/O-Zyklus erhöht.

IP-Link cycle time

Diese Zeit gibt die Zeitspanne eines Zyklus an. Ein Zyklus beginnt mit der Initiierung und endet mit der Terminierung eines I/O-Prozess-Updates (IP-Link). Die Zeit wird in Microsekunden gemessen. Die Zeitspanne zwischen dem Eintreffen der Signale "PD cycle request" und "PD cycle ready" entspricht nicht der Zykluszeit. Bei der CX1100-0003 beschreibt diese Zeit nur den Anteil der Zykluszeit, die auf den IP-Link-Bus entfällt; nicht aber die gesamte Zykluszeit. K-Bus-Zykluszeit und die IP-Link-Zykluszeit zusammen ergeben die Gesamtzykluszeit.

IP-Link bus status

Dieses Register kann zwei Werte annehmen:

  1. Byte = 0 → IP-Link läuft ohne Fehler
  2. Byte ≠ 0 → IP-Link Fehler aufgetreten

Diese Information wird ebenfalls im "Processdata error" Byte (Bit 0) des GCB dargestellt.

Retry counter

Dieser Zähler wird mit jedem Kommunikationsfehler des IP-Link erhöht. Tritt ein Fehler auf, so wird der Sendeversuch wiederholt. Auf diese Weise gibt der Zähler die Signalqualität des IP-Link wieder.


Anschlüsse CX1100-0004

BECKHOFF CX1100-00xx: Übersicht / elektrischer Anschluss

Anschlüsse CX1100-00x4

Das Netzteil CX1100-0004 ermöglicht die Anreihung von EtherCAT Klemmen. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den E-Bus die EtherCAT Klemmen.

CX1100-0004 für CX1000, CX1010 und CX1020 | CX1100-0014 für CX1030

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.

Hinweis |
 | Dieses Netzteil ist nur für die Verwendung mit dem CX10x0 entwickelt. Ein Betrieb mit dem CX1000 ist nicht möglich, da das CX1000-System das EtherCAT-Protokoll nicht über den erweiterten PC104 Bus ausführt.

Hinweis |
 | Die Systemschnittstelle CX1020-N060 kann nur anstatt und nicht gleichzeitig mit dem Netzteil CX1100-0004 verwendet werden.

Warnung |
 | Beim Einsatz des Netzteils ist auf den Hardwarestand zu achten. Netzteile mit dem Hardwarestand > 2.0 funktionieren nur mit CX1020-Systemen mit einem Hardwarestand > 2.1 !


Technische Daten CX1100-0004

Abmessungen:

Die Spannungsversorgung eines CX- Systems erfolgt durch Netzteilmodule. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Die Anreihung lokaler I/O-Signale an den CX1020 geschieht über die Netzteilvarianten CX1100-0002 (Busklemmen), CX1100-0003 (Busklemmen und Feldbus-Box-Module via IP-Link) sowie CX1100-0004 für die EtherCAT-Klemmen. Die I/O-Daten werden direkt im Arbeitsspeicher der CPU abgelegt; ein DPRAM ist nicht mehr nötig.

Das Netzteil CX1100-0004 bzw. die Anreihung von EtherCAT-Klemmen ist in Verbindung mit den CPU-Grundmodulen CX1010/CX1020/CX1030 möglich. Mit dem CPU-Grundmodul CX1000/CX1001 ist die Verbindung nicht möglich.

Technische Daten | CX1100-0004
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | -
E-Bus Anschluss | ja (Adapterklemme)
IP-Link Anschluss | -
E-Bus Stromversorgung bis max. | 2 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x PWR, 1 x L/A, 1 x Run
Abmessungen | 40 mm x 100 mm x 91 mm
Gewicht | 250 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0004

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0014

Abmessungen:

Die Spannungsversorgung eines CX- Systems erfolgt durch Netzteilmodule. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Die Spannungsversorgung CX1100-0014 ist für den CX1030 bestimmt.

Die Netzteile CX1100-0004 und CX1100-0014 bzw. die Anreihung von EtherCAT-Klemmen ist nur in Verbindung mit dem CPU-Grundmodulen CX1010 / CX1020 / CX1030 möglich.

Technische Daten | CX1100-0014
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | -
E-Bus Anschluss | ja (Adapterklemme)
IP-Link Anschluss | -
E-Bus Stromversorgung bis max. | 2 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x PWR, 1 x L/A, 1 x Run
Abmessungen | 42 mm x 109 mm x 92mm
Gewicht | 235 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Architektur CX1100-00x4

Architektur des Netzteils CX1100-00x4

Diese Netzteil verfügt, abgesehen von der Spannungsversorgung, über folgende Funktionen:

  1. Display 2 x 16 Zeichen
  2. 4+1 Navigationsschalter
  3. Non Volatile RAM
  4. E-Bus Anschluss

Diese Funktionen werden über den PC104-Bus angesteuert. Das Strukturbild des CX1100-0003 zeigt die Funktionsblöcke.

Dieses Netzteil verfügt über die Grundfunktionen. Diese sind in der Architekturbeschreibung erläutert. Darüber hinaus wird der E-Bus unterstützt. Dies geschieht transparent für den Anwender. Das Netzteil leistet eine Umsetzung der Signale des EtherCAT-Busses auf den E-Bus. Die Kontrolle geschieht über das Programm auf der CPU. Die Klemmen des E-Busses werden unter TwinCAT analog zu den K-Busklemmen angesteuert.


Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Modultyp | CX1100-0001 | CX1100-0002 | CX1100-0003 | CX1100-0004
Abmessungen (B x H x T) | 45 mm x 100 mm x 91 mm | 40 mm x 100 mm x 91 mm | 58 mm x 100 mm x 91 mm | 40 mm x 100 mm x 91 mm
Gewicht | 180 g | 209 g | 260 g | 193 g

Modultyp | CX1100-0012 | CX1100-0013 | CX1100-0014
Abmessungen (B x H x T) | 42 mm x 100 mm x 91 mm | 60 mm x 100 mm x 91 mm | 42 mm x 100 mm x 91 mm
Gewicht | 240 g | 325 g | 235 g

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:
1. Entfernen Sie die Verpackung.
2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Wiedertransport auf.
3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung |
 | Beschädigungsgefahr des Gerätes!

Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung). Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.
Die Einbauanleitung finden Sie auf den nächsten Seiten.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


Maße

Die Produktreihe CX zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein CPU Modul und ein Netzteil sowie die entsprechenden Systemschnittstellen und die Feldbusschnittstellen vorgesehen werden.
Die Gesamtbreite der Anwendung setzt sich aus den einzelnen verwendeten Module zusammen.
Mit einer Höhe von 100 mm entsprechen die Maße der Module exakt denen der Beckhoff Busklemmen. Dadurch und durch die abgesenkten Steckerflächen ist der Einsatz in einem Standard Klemmenkasten von 120 mm Höhe möglich.

Die vier verfügbaren Netzteile für die CX-Familie haben jeweils unterschiedliche Abmessungen:

CX1100-0001:

CX1100-0002:

CX1100-0003:

CX1100-0004:

CX1100-0012:

CX1100-0013:

CX1100-0014:


Mechanischer Zusammenbau

BECKHOFF CX1100-00xx: Einbau und Verdrahtung

Mechanischer Anbau des Netzteils

Zusammenbau des CX10x0-Blocks

Die Befestigung des Netzteils mit der bestehenden CX10x0-Konfiguration wird durch das Zusammenstecken erreicht. Dabei ist zu beachten, dass der Stecker des PC104 Interface nicht beschädigt wird. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.

Aufbringen des CX10x0-Systems auf die Hutschiene

Nach dem Zusammenstellen des CX10x0-Systems kann dieses auf die Hutschiene aufgebracht werden. Zuvor müssen die weißen Laschen an der Unterseite der Modul in Pfeilrichtung gezogen werden. Sie arretieren dann in der ausgezogenen Position. Der Systemblock kann nun vorsichtig auf die Hutschiene gesetzt werden.

Der CX10x0-Block wird mit Hilfe der Verrieglungslaschen auf der Hutschiene fixiert. Dabei sollte ein leisen Klicken zu vernehmen sein.

Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Die Gehäuse nur an unempfindlichen Stellen (Gehäusekanten) drücken. Auf keinen Fall Druck auf das Display, die Taster oder bewegliche Teile am CX10x0-System ausüben.

Als Letztes muss noch die Verkabelung hergestellt werden. Dazu wird müssen die oberen beiden Anschlüsse "24V" und "0V" mit einer Spannung von 24V versorgt werden. Bei dem Netzteil CX1100-0001 wird der Kontakt über eine 5-poligen Stecker hergestellt. (Details siehe Anschlüsse / Verdrahtung).


BECKHOFF CX1100-00xx: Elektrischer Anschluss

Elektrischer Anschluss

Die Anschlüsse der Netzteile des CX10x0-System unterscheiden sich leicht in ihrer Anschlussweise. Alle Netzteile werden mit 24V Gleichstrom (DC) versorgt. Eine Abweichung von -15 % bis + 20 % ist dabei zulässig. Für einen sicheren Betrieb muss die Erdung an PE angeschlossen werden. Die folgenden Abbildungen stellen die unterschiedlichen Anschlussvariationen dar. Natürlich kann auch jedes Netzteil mit Busanschlüssen direkt an die Versorgungsspannung angelegt werden. Diese Beschaltung ist dann analog zum Anschluss des CX1100-00x4 Moduls.

Anschlüsse CX1100-0001

Dieses Netzteil besitzt keine E/A-Schnittstelle, die Stromversorgung erfolgt daher über den 5-poligen "Open Pluggable Connector". Bei älteren Versionen sind die unteren Eingänge mit UPS +/- beschriftet. Diesen Eingänge werden nicht mehr verwendet und dürfen nicht angeschlossen werden.

Anschlüsse CX1100-00x2

Dieses Netzteil hat einen K-Bus-Anschluss. Der K-Bus wird separat zu dem XC10x0-System mit einer Spannungsversorgung verbunden. Auf diese Weise können Bus-Spannung und Steuerelektronik voneinander getrennt abgeschaltet werden.

Anschlüsse CX1100-00x3

Dieses Netzteil hat ebensfalls einen K-Bus-Anschluss. Und zusätzlich einen Anschluss für IP-Link. Die Stromversorgung ist analog zu CX1100-0002.

Anschlüsse CX1100-00x4

Dieses Netzteil ist speziell für E-Bus-Klemmen entwickelt worden. Nur bei einem CX1000 ist kein E-Bus Betrieb möglich. Über die unteren Kontakte können auch hier 24V eingespeist werden.

UL-Anforderungen

Gefahr

Zur Einhaltung der UL-Anforderungen dürfen die CX-Controller nur nur mit Versorgungsspannungen (24 VDC) versorgt werden, die
  • von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
  • von einer Spannungsquelle die NEC class 2 entspricht stammen.
    Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!

Diese UL-Anforderungen gelten für alle Versorgungsspannungen der CX-Controller!

Zur Einhaltung der UL-Anforderungen dürfen die CX-Controller nicht mit unbegrenzten Spannungsquellen verbunden werden!


Diagnose im SPS-Programm

Zur Analyse des Klemmbus (K-Bus und IP-Link) kann auf die in der Architektur beschriebenen Register über TwinCAT von einem SPS-Programm zugegriffen werden. Dazu muss die Klemmbusanbindung auf erweitertes DPRAM Model geschaltet (Firmware > B3) sein. Mit diesen Einstellungen wird in TwinCAT das erweiterte Registermodell aktiviert.

Die einzelnen Register, die in der Architekturbeschreibung erklärt sind sind als SPS-Datentypen verfügbar. Im folgenden wird die Fehleranalyse als Beispiel vorgestellt. Die Vorgehensweise ist für beide Sub-Busse identisch, daher wird in den Beschreibungen die Signale nur allgemein erklärt.

Für die Fehleranalyse werden im Wesentlichen vier Signale/Variablen benötigt:

  • BusState (gibt den Zustand des Busses an: 0 -> kein Fehler, 1 -> Busfehler)
  • ErrorCode (entspricht dem Errorcode beim Blinkcode der DiganoseLEDs)
  • ErrorArg (entspricht dem Argument-Code beim Blinkcode der DiganoseLEDs)
  • Request[0] (Ausgang zum Anfordern / Rücksetzen des Busses)

In dem SPS-Programm müssen dazu analog externe Variablen angelegt werden:

VAR

    k_bus_request AT %QX0.0 	: BOOL;

    k_bus_err_code AT %IB0 	: USINT;
    k_bus_err_arg AT %IB1 	: USINT;
    k_bus_state AT %IB2 	: USINT;

    ip_bus_request AT %QX0.1 	: BOOL;

    ip_bus_err_code AT %IB3 	: USINT;
    ip_bus_err_arg AT %IB4 	: USINT;
    ip_bus_state AT %IB5 	: USINT;

END_VAR

In dem SPS Programm kann dann der Fehler wie folgt bestimmt werden (es handelt sich hier um Pseudocode, der so direkt nicht lauffähig ist)

....

IF k_bus_state = 1	 THEN		(* auf dem K-Bus ist ein Fehler aufgetreten *)

   k_bus_request := TRUE;		(* Anfordern der Fehlerwerte für die Register ErrCode und ErrArg *)

   CASE k_bus_err_code OF
     0 : return;			(* Sollte nicht vorkommen, da ja Fehler vorliegt *)
     1 : CASE k_bus_arg OF
      0 : melde Fehler;	(* EEPROM Prüfsummenfehler *)
      1 : melde Fehler;	(* Überlauf im Code Buffer *)
      2 : melde Fehler;	(* Unbekannter Datentyp *)
    END_CASE;
     2 : CASE k_bus_arg OF
      0 : melde Fehler;	(* Programmierte Konfiguration, falscher Tabelleneintrag *)
      ELSE melde Fehler;	(* Falscher Tabelleneintrag *)
    END_CASE;
     3 : melde Fehler 		(* K-Bus_Kommandofehler *)
     4 : CASE k_bus_arg OF
      0 : melde Fehler;	(* Bruchstelle hinter dem Netzteil *)
      ELSE melde Fehler;	(* Bruchstelle hinter Busklemme 'k_bus_arg' *)
    END_CASE;
     5 : melde Fehler 		(* K-Bus-Fehler bei Register-Kommunikation mit Busklemme 'k_bus_arg' *)
     9 : CASE k_bus_arg OF
      0 : melde Fehler;	(* Checksummenfehler im Programm-Flash *)
      ELSE melde Fehler;	(* Die Busklemme 'k_bus_arg' stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein*)
    END_CASE;
    14 : melde Fehler 		(* 'k_bus_arg'-te Busklemme hat das falsche Format *)
    15 : melde Fehler 		(* Anzahl der Busklemmen stimmt nicht mehr*)
    16 : melde Fehler 		(* Länge der K-Bus-Daten stimmt nicht mehr*)
   END_CASE

   k_bus_request := TRUE;		(* Rücksetzen des Busses, wenn Fehler beseitigt, dann startet der Klemmbus wieder *)

....

Damit die Steuerung und die Register zusammen arbeiten, müssen sie im System Manager verknüpft werden. Bindet man das SPS-Programm im System Manager ein, so ergeben sich folgende Signale:

Analog sind in System Manager die Register für die Klemmbusse angezeigt:

Mit Hilfe der Maus werden die Signale

k_bus_err_code mit ErrorCode

k_bus_err_arg mit ErrorArg

k_bus_state mit BusState

und

k_bus_request mit Request[0]

verknüpft. Analog werden die Signale für den IP-Link verknüpft:

ip_bus_err_code mit ErrorCode

ip_bus_err_arg mit ErrorArg

ip_bus_state mit BusState

ip_bus_request mit Request[0]

Sind alle Signale verknüpft, können Sie die Konfiguration und das SPS-Programm auf die Steuerung laden.

Firmware > B7

Mit der neuen Firmware B7 ist es möglich diese Diagnose zu vereinfachen. Bei der oben beschriebenen Lösung wird der Fehlercode beim Auslesen beseitigt, wenn der Grund für den Fehler nicht mehr besteht. In der Firmware Version > B7 ist es möglich den Fehlercode und das Fehlerargument sofort in die entsprechenden Register eintragen zu lassen. Dies geschieht durch das Setzten des Bit 4 im GCB. Für die Fehlerdiagnose ist es empfehlenswert das Bit 4 gleich in der Initialisierung der Fehlerroutine oder des SPS-Programms zu setzen. Die Verknüpfung des Bits in der SPS erfolgt dann mit dem Bit 4 im Request-Feld des GCB.


LEDs Netzteil CX1100-0001

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.


LEDs Netzteil CX1100-0002

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX1020 Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.


LEDs Netzteil CX1100-0002

BECKHOFF CX1100-00xx: Fehlerbehandlung und Diagnose

LEDs Netzteil CX1100-0012

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX1020 Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.


LEDs Netzteil CX1100-0003

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung. Da das Netzteil über zwei verschiedene Klemmen-Bussysteme verfügt, werden mögliche Fehler der beiden Busse über die LEDs angezeigt. Ein Fehler auf dem K-Bus wird durch schnelles Blinken eingeleitet. Ein langes Leuchten (ca. 2 Sekunden) signalisiert Fehlercodes für Fehler auf dem IP-Link Bus.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus / IP-Link Die grüne LED leuchtet / blinkt schnell, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystemen fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus / Dignose IP-Link Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

LEDs zur K-Bus-Diagnose

Nach einer schnellen Blinkfolge liegt ein K-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX-Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.

LEDs zur IP-Link-Bus-Diagnose

Nach einem langen Leuchten (ca. 2 Sekunden) liegt ein IP-Link-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

I/O Err |  |  | Beschreibung | Abhilfe
aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
2 |  |  | reserviert | -
3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich

Hinweis |
 | Liegt auf beiden Bussystemen (K-Bus und IP-Link-Bus) ein Fehler vor wird zuerst der Fehler auf dem K-Bus und dann der Fehler auf dem IP-Link-Bus angezeigt. Die jeweiligen Fehlercodes werden wie oben beschrieben mit schnellem Blinken oder langem Aufleuchten eingeleitet.


LEDs Netzteil CX1100-0003

BECKHOFF CX1100-00xx: Fehlerbehandlung und Diagnose

LEDs Netzteil CX1100-0013

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung. Da das Netzteil über zwei verschiedene Klemmen-Bussysteme verfügt, werden mögliche Fehler der beiden Busse über die LEDs angezeigt. Ein Fehler auf dem K-Bus wird durch schnelles Blinken eingeleitet. Ein langes Leuchten (ca. 2 Sekunden) signalisiert Fehlercodes für Fehler auf dem IP-Link Bus.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus / IP-Link Die grüne LED leuchtet / blinkt schnell, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystemen fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus / Dignose IP-Link Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

LEDs zur K-Bus-Diagnose

Nach einer schnellen Blinkfolge liegt ein K-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX-Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.

LEDs zur IP-Link-Bus-Diagnose

Nach einem langen Leuchten (ca. 2 Sekunden) liegt ein IP-Link-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

I/O Err |  |  | Beschreibung | Abhilfe
aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
2 |  |  | reserviert | -
3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich

Hinweis |
 | Liegt auf beiden Bussystemen (K-Bus und IP-Link-Bus) ein Fehler vor wird zuerst der Fehler auf dem K-Bus und dann der Fehler auf dem IP-Link-Bus angezeigt. Die jeweiligen Fehlercodes werden wie oben beschrieben mit schnellem Blinken oder langem Aufleuchten eingeleitet.


LEDs Netzteil CX1100-0004

Anzeige | LED |  | Bedeutung
 | PWR |  | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | L/A | aus | E-Bus nicht angeschlossen
 |  | an | E-Bus angeschlossen / Kein Datenverkehr
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.
 | RUN |  | Beschreibt den Zustand des EtherCAT Busses:
 |  | aus | INIT
 |  | blinkt | PRE-OPERATIONAL (Frequenz: 200 ms an / 200 ms aus)
 |  | einzelnes Blinken | SAVE-OPERATIONAL (Frequenz: 200 ms an / 1000ms aus)
 |  | an | OPERATIONAL
 |  | schnelles Blinken | BOOTSTRAP (Frequenz: 50 ms an / 50 ms aus)
 |  | doppeltes Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | dreifaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | vierfaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)

Die Funktionen für L/A und RUN LED sind erst ab Hardwarestand 2.0 verfügbar. In älteren Versionen sind die LEDs ohne Funktion.


LEDs Netzteil CX1100-0004

BECKHOFF CX1100-00xx: Fehlerbehandlung und Diagnose

LEDs Netzteil CX1100-0014

Anzeige | LED |  | Bedeutung
 | PWR |  | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | L/A | aus | E-Bus nicht angeschlossen
 |  | an | E-Bus angeschlossen / Kein Datenverkehr
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.
 | RUN |  | Beschreibt den Zustand des EtherCAT Busses:
 |  | aus | INIT
 |  | blinkt | PRE-OPERATIONAL (Frequenz: 200 ms an / 200 ms aus)
 |  | einzelnes Blinken | SAVE-OPERATIONAL (Frequenz: 200 ms an / 1000ms aus)
 |  | an | OPERATIONAL
 |  | schnelles Blinken | BOOTSTRAP (Frequenz: 50 ms an / 50 ms aus)
 |  | doppeltes Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | dreifaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | vierfaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)

Die Funktionen für L/A und RUN LED sind erst ab Hardwarestand 2.0 verfügbar. In älteren Versionen sind die LEDs ohne Funktion.


Abbau und Entsorgung

Der Abbau einer CX10x0-Hardwarekonfiguration erfolgt in 2 Schritten:

0. Abschalten und Entfernen der Stromversorgung

Bevor der Abbau eines CX10x0-System erfolgen kann, sollte das System abgeschaltet sein und die Stromversorgung entfernt werden.

1. Demontage von der Hutschiene:

Vor der Trennung der einzelner CX10x0 Module muss der gesamte CX10x0-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

1.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man alle eventuell vorhandene Verkabelung der Stormversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Soll die Verkabelung später mit einem anderen System wieder hergestellt werden, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil), löst damit die Klemme und zieht sie nach vorne heraus.

1.2. Entriegeln des CX10x0 - Systems

Um den CX10x0-Block zu lösen, werden die weißen Laschen an der Unterseite der Modul in Pfeilrichtung gezogen. Sie arretieren dann in der ausgezogenen Position. Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung lässt sich der Block vorsichtig von der Hutschiene nehmen.

2. Trennung der einzelnen Module

2.1. Trennen von Stromversorgung und CX10x0-CPU sowie weiterer Komponenten

Man setzt den CX10x0-Block mit der Vorderseite auf eine geeignete Unterlage. Dann wird ein Schlitzschraubendreher der Größe 1,0 x 5,5 x 150 mm in den Verriegelungsmechanismus einführt und mit einer etwa 90 Grad Drehung der Schieber betätigt. Der rückseitige Verriegelungsmechanismus bewirkt eine ca. 2-3mm breite Trennung der mechanischen Einrastung der Module und drückt diese auseinander. Die Stecker des PC 104 Interface können anschließend vorsichtig auseinander gezogen werden.

Nur Module (CPU, Feldbusanschaltungen und USV-Module) die sich zerstörungsfrei trennen lassen verfügen über eine Entriegelung. Module, die nicht voneinander getrennt werden können, haben lediglich einen Markierungspunkt (mit oder ohne roten Versieglungslack). Eine Krafteinwirkung an diesen Elementen führt zur Zerstörung.

Achtung |
 | Das gewaltsame Öffnen der Modulgehäuse (z.B. Entfernen der Deckel) führt zur Zerstörung der Gehäuse.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


ADS Return-Codes

Hex | Dec | Description
0x000 | 0 | no error
0x001 | 1 | Internal error
0x002 | 2 | No Rtime
0x003 | 3 | Allocation locked memory error
0x004 | 4 | Insert mailbox error
0x005 | 5 | Wrong receive HMSG
0x006 | 6 | target port not found
0x007 | 7 | target machine not found
0x008 | 8 | Unknown command ID
0x009 | 9 | Bad task ID
0x00A | 10 | No IO
0x00B | 11 | Unknown AMS command
0x00C | 12 | Win 32 error
0x00D | 13 | Port not connected
0x00E | 14 | Invalid AMS length
0x00F | 15 | Invalid AMS Net ID
0x010 | 16 | Low Installation level
0x011 | 17 | No debug available
0x012 | 18 | Port disabled
0x013 | 19 | Port already connected
0x014 | 20 | AMS Sync Win32 error
0x015 | 21 | AMS Sync Timeout
0x016 | 22 | AMS Sync AMS error
0x017 | 23 | AMS Sync no index map
0x018 | 24 | Invalid AMS port
0x019 | 25 | No memory
0x01A | 26 | TCP send error
0x01B | 27 | Host unreachable
0x500 | 1280 | Router: no locked memory
0x502 | 1282 | Router: mailbox full
0x700 | 1792 | error class <device error>
0x701 | 1793 | Service is not supported by server
0x702 | 1794 | invalid index group
0x703 | 1795 | invalid index offset
0x704 | 1796 | reading/writing not permitted
0x705 | 1797 | parameter size not correct
0x706 | 1798 | invalid parameter value(s)
0x707 | 1799 | device is not in a ready state
0x708 | 1800 | device is busy
0x709 | 1801 | invalid context (must be in Windows)
0x70A | 1802 | out of memory
0x70B | 1803 | invalid parameter value(s)
0x70C | 1804 | not found (files, ...)
0x70D | 1805 | syntax error in command or file
0x70E | 1806 | objects do not match
0x70F | 1807 | object already exists
0x710 | 1808 | symbol not found
0x711 | 1809 | symbol version invalid
0x712 | 1810 | server is in invalid state
0x713 | 1811 | AdsTransMode not supported
0x714 | 1812 | Notification handle is invalid
0x715 | 1813 | Notification client not registered
0x716 | 1814 | no more notification handles
0x717 | 1815 | size for watch too big
0x718 | 1816 | device not initialized
0x719 | 1817 | device has a timeout
0x71A | 1818 | query interface failed
0x71B | 1819 | wrong interface required
0x71C | 1820 | class ID is invalid
0x71D | 1821 | object ID is invalid
0x71E | 1822 | request is pending
0x71F | 1823 | request is aborted
0x720 | 1824 | signal warning
0x721 | 1825 | invalid array index
0x740 | 1856 | Error class <client error>
0x741 | 1857 | invalid parameter at service
0x742 | 1858 | polling list is empty
0x743 | 1859 | var connection already in use
0x744 | 1860 | invoke ID in use
0x745 | 1861 | timeout elapsed
0x746 | 1862 | error in win32 subsystem
0x748 | 1864 | ads-port not opened
0x750 | 1872 | internal error in ads sync
0x751 | 1873 | hash table overflow
0x752 | 1874 | key not found in hash
0x753 | 1875 | no more symbols in cache


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.