Titel

BECKHOFF CX1010: Embedded-PC-System

Dokumentation zu

der Hardware des CX1010-Systems

CX1010-0xxx

CX1010-Nxxx

Version: 1.6
Datum: 07.11.2012


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr |
 | Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung |
 | Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis |
 | Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.

Grundlegende Sicherheitsmaßnahmen

Sorgfaltspflicht des Betreibers

Der Betreiber muss sicherstellen, dass
· das Produkt nur bestimmungsgemäß verwendet wird.
· das Produkt nur in einwandfreiem, funktionstüchtigem Zustand betrieben wird.
· die Betriebsanleitung stets in einem leserlichen Zustand und vollständig am Einsatzort des Produkts zur Verfügung steht.
· nur ausreichend qualifiziertes und autorisiertes Personal das Produkt bedient.
· dieses Personal regelmäßig in allen zutreffenden Fragen von Arbeitssicherheit und Umweltschutz unterwiesen wird, sowie die Betriebsanleitung und insbesondere die darin enthaltenen Sicherheitshinweise kennt.

Nationale Vorschriften je nach Maschinentyp

Je nach Maschinen- und Anlagentyp, in dem das Produkt zum Einsatz kommt, bestehen nationale Vorschriften für Steuerungen solcher Maschinen und Anlagen, die der Betreiber einhalten muss. Diese Vorschriften regeln unter anderem, in welchen Zeitabständen die Steuerung überprüft werden muss. Der Betreiber muss diese Überprüfung rechtzeitig veranlassen.

Anforderungen an das Bedienungspersonal

Betriebsanleitung lesen

Jeder Benutzer des Produkts muss die Betriebsanleitung für die Anlage, an der er eingesetzt wird, gelesen haben.

Systemkenntnisse

Jeder Benutzer muss alle für ihn erreichbaren Funktionen des Produkts kennen.


Ausgabestände der Dokumentation

Version | Änderungen
1.6 | Korrekturen zu PC104 Bus hinzugefügt
1.5 | Entsorgungshinweise zur Batterie hinzugefügt
1.4 | Anmerkungen zu den Netzwerkanschlüssen geändert
1.3 | BIOS Einträge hinzugefügt
1.2 | Schnittstellen CX1200-xxxx entfernt
1.1 | Neue Bezeichnungen für Schnittstellen CX1010-.N070 und CX1010-N080 hinzugefügt
1.0 | Version zu Beginn der Serienproduktion
0.0.1 | Vorläufige Version (Urfassung)


Bestimmungsgemäße Verwendung

Die Geräteserie CX1010 ist ein modulares Steuerungssystem, das für die Montage auf einer Hutschiene vorgesehen ist. Die System ist skalierbar, so dass je nach Aufgabenstellung, die benötigten Module zusammengesteckt und in den Schaltschrank oder Klemmenkasten eingebaut werden.

Abschalten des PCs nur nach Beendigung der Software

Bevor der Embedded-PC abgeschaltet werden darf muss die laufende Software regulär beendet werden, andernfalls können Daten auf der Festplatte verloren gehen. Lesen Sie dazu den Abschnitt "Ausschalten".

Wenn der PC nicht für Steuerungszwecke eingesetzt wird, beispielsweise während der Funktionsprüfung, müssen zuerst alle Anlagenteile abgeschaltet und danach der Embedded-PC von der Anlage abgekoppelt werden. Die Abkopplung geschieht durch Abziehen der ersten Klemme hinter dem Netzteil (CX1100-0002 und CX1100-0003) (optional) und Abziehen der Stecker der Feldbusanschlüsse.
Abgeschaltete Anlagenteile müssen gegen Wiedereinschalten gesichert werden.

Das Netzteil des Embedded-PCs wird mit einer Spannung von 24 V DC versorgt.

Gefahr |
 | Keine Teile unter Spannung austauschen!

Beim Ein- und Ausbau von Komponenten muss die Versorgungsspannung abgeschaltet werden.

Softwarekenntnisse

Achtung |
 | Erforderliche Softwarekenntnisse!

Jeder Benutzer muss alle für ihn erreichbaren Funktionen der auf dem PC installierten Sotfware kennen.


CX1010 Produktübersicht

BECKHOFF CX1010: Produktübersicht

Systemübersicht

Das System

Mit den Embedded-PCs der Serie CX hat Beckhoff PC-Technik und modulare I/O-Ebene als Einheit auf die Hutschiene im Schaltschrank gebracht. Der CX1010 erweitert die CX-Produktfamilie um eine Variante mit höherer CPU-Leistung. Der CX1010 ermöglicht den direkten Anschluss der Busklemmen und der EtherCAT-Klemmen.

Verglichen mit dem CX1000, der über einen AMD-Geode mit 266 MHz verfügt, kann der CX1010 mit einer schnelleren CPU der AMD® Geode LX 800 aufwarten, die mit 500 MHz getaktet ist. Wie bei dem CX1000 kann auch hier auf einen Lüfter verzichtet werden. Da als Boot- und Speichermedium Compact-Flash zum Einsatz kommt, sind keine rotierenden Medien in der Steuerung verbaut – ein wichtiger Aspekt zur Erhöhung der MTBF (Mean Time Between Failures) des Gesamtsystems.

Das Gehäuse- und Montagekonzept des CX1010 gleicht dem seines kleineren Bruders CX1000:
Wie dieser besteht er aus mehreren, vom Benutzer zusammensteckbaren Komponenten – im einfachsten Fall dem CPU-Modul und dem multifunktionalen Netzteil. Die Verbindung dazwischen, sowie zu allen anderen CX-Komponenten, erfolgt über den PC104-Bus, der beim CX1010 jedoch um EtherCAT-Signale erweitert wurde. Das CPU-Grundmodul bringt als Grundausstattung eine RJ-45-Buchse mit.

Analog zum CX1000 können auch beim CX1010 optionale Systemschnittstellen hinzugefügt werden. Es stehen ein DVI-I ( = DVI-D + VGA )-Ausgang, zwei USB-2.0-Schnittstellen, bis zu vier RS232-Schnittstellen sowie Audio zur Verfügung. Die vier optoentkoppelten RS232-Schnittstellen können wahlweise auch als RS422/RS485 ausgeführt werden.

Die gleiche Wiederverwendbarkeit gilt auch für die multifunktionalen Netzteile(CX1100-000x) des CX1010: eines ohne I/O-Klemmenanschluss, eines mit K-Bus-Anschluss, eines mit K-Bus- und IP-Link-Anschluss für IP-67-geschützte Feldbus-Box-Module und ein Netzteil mit direkter Anschlussmöglichkeit der Beckhoff EtherCAT-Klemmen.

EtherCAT als schnelles I/O-System

Der Embedded-PC CX1010 wurde in Hinblick auf das optimierte Zusammenspiel mit EtherCAT entwickelt. Die zwei Ethernet-Schnittstellen des CPU-Moduls, sind nicht primär für den EtherCAT-Betrieb gedacht. Der EtherCAT-Anschluss erfolgt über die EtherCAT Verlängerungsklemme EK1110 (EtherCAT).

Interessanterweise ergeben sich durch EtherCAT mehrere Möglichkeiten, die klassischen Feldbussysteme an den CX1010 anzuschließen:
Entweder als CX1500-Baugruppe direkt an der CPU oder als EtherCAT-Teilnehmer in Klemmenform. Beispielsweise gibt es den PROFIBUS-Master entweder als CX1500-M310 oder als EtherCAT-Klemme EL6731. Es gibt keine Funktionseinbußen zwischen den beiden Ausführungen; beide haben die gleichen Leistungsmerkmale – z. B. unterstützen beide PROFIBUS-DP-V2. Praktisch kann der PROFIBUS-Master genau da an der Maschine angebracht werden, wo er benötigt wird. Es muss also nicht mehr unbedingt die Steckkarte im IPC oder die Mastersteuerung im Schaltschrank sein.

SPS, Motion Control, Interpolation und Visualisierung

Als IPC auf der Hutschiene hat der CX1010, im Zusammenspiel mit der Beckhoff-TwinCAT-Software, die Funktionalität großer Industrie-PCs. Im Bereich SPS können bis zu vier virtuelle IEC 61131-CPUs, mit jeweils bis zu vier Tasks, programmiert werden; die kürzest einstellbare Zykluszeit beträgt 50 μs. Alle IEC 61131-3-Sprachen sind nutzbar.

Ebenso stehen alle Funktionalitäten von TwinCAT für den Bereich Motion Control zur Verfügung:
Es können theoretisch bis zu 256 Achsen angesteuert und neben einfachen Punkt-zu-Punkt-Bewegungen auch komplexere Mehrachsfunktionen, wie „Elektronisches Getriebe“, „Kurvenscheibe“ und „Fliegende Säge“ ausgeführt werden. Im Unterschied zum CX1000 kann der CX1010, dank gestiegener CPU-Leistung, nun auch interpolierende 3D-Bahnbewegungen ausführen und DIN66025-Programme abarbeiten.

Neben den in Echtzeit ausgeführten Steuerungsaufgaben sorgt die Verwaltung im TwinCAT-Echtzeitkern dafür, dass genügend Zeit für die Benutzeroberfläche (HMI) bleibt, die über Softwareschnittstellen, wie ADS oder OPC, mit den Echtzeitanteilen kommuniziert.

Auch bei CX1010 gilt der Grundsatz: ein Programmierwerkzeug für alle Steuerungen.
Die gesamte Programmierung von SPS, Motion Control und Visualisierung ist auf alle PC-Steuerungen von Beckhoff übertragbar – beruhigend, falls sich während des Projekts herausstellt, dass es dann doch mehr Rechenleistung benötigt wird. In diesem Fall kann auf ein System mit mehr Leistung zurück gegriffen werden.

CPU Grundmodul

An das CPU-Grundmodul können weitere Systemschnittstellen sowie Feldbusanschaltungen angefügt werden. Für die Spannungsversorgung des CPU-Moduls wird eines der Netzteilmodule des Typs CX1100 benötigt.

Alle Feldbusmodule CX1500 sowie alle Netzteile CX1100 der CX1000-Serie können in Kombination mit CX1010 eingesetzt werden.

Mit dem Netzteil CX1100-0004 besteht beim CX1010 eine direkte Anbindung an die EtherCAT-Klemmen. Die Kombination aus CX1010, EtherCAT und TwinCAT ermöglicht Zyklus- und Reaktionszeiten unterhalb einer Millisekunde.

Das CPU-Modul ist in mehreren Varianten erhältlich. Diese betreffen:

- Die Ausstattung mit Systemschnittstellen: Als Option können zu der immer vorhandenen Ethernet RJ-45 Schnittstelle auch DVI und zwei USB Schnittstellen hinzugefügt werden.

- Die Betriebssystemausstattung: Es kann gewählt werden zwischen "Microsoft Windows CE.NET" sowie "Microsoft Windows XP Embedded".

- Die vorinstallierte TwinCAT Software: CX1010 kann ohne TwinCAT System, mit TwinCAT CE PLC, TwinCAT CE NC PTP oder TwinCAT CE NCI ,oder mit den entsprechenden Vollversionen der einzelnen TwinCAT Level für SPS und Motion Control vorinstalliert werden.

Systemschnittstellen

Getrennt bestellbar sind weitere Systemschnittstellen für serielle Kommunikation (2x RS 232 sowie RS422, RS485), 2 x USB 2.0 Schnittstellen, Videoausgang (DVI +) , CF-Kartenleser/-schreiber und Audiosignale.

Feldbusschnittstellen

Alle Feldbusmodule CX1500 sowie alle Netzteile CX1100 der CX1000-Serie können in Kombination mit CX1010 eingesetzt werden.

Die Feldbusschnittstellen sind derzeit als Master und Slave-Feldbusanschaltungen für folgende Feldbusse erhältlich:

Beckhoff Lightbus, Profibus DP, CANopen, DeviceNet und SERCOS Interface (nur Master)

Die Master-Feldbusanschaltungen ermöglichen dem CX1010 System die Nutzung der Beckhoff Feldbuskomponenten (wie Buskoppler, Busklemmen Controller und Antriebstechnik) als dezentrale Steuerungskomponenten für die Aufbau komplexer Anlagen.

Die Slave-Feldbusanschaltungen ermöglichen die Nutzung des CX1010 Systems als unterlagerte dezentrale Steuerung für den Aufbau komplexer oder modularer Anlagen.

Hinweis:

Die Dokumentation der Feldbusanschaltungen ist separat erhältlich.

Die Software

In Kombination mit der Automatisierungssoftware TwinCAT wird der Industrie-PC CX1010 zu einer leistungsfähigen IEC 61131-3 SPS mit bis zu vier Anwendertasks. Zusätzlich können auch Motion Control Aufgaben ausführt werden. Je nach erforderlicher Abtastzeit ist die Ansteuerung von mehreren Servoachsen möglich, wobei selbst Sonderfunktionen wie Fliegende Säge, Elektronisches Getriebe und Kurvenscheibe realisierbar sind.

Die Programmierung des CX1010 Systems erfolgt in der für Buskontroller üblichen Weise:

Remote Programmierung über Ethernet

Dies ist der Fall, wenn die Basiseinheit mit "Windows CE.NET" ausgestattet wird. Dann erfolgt die Programmierung über ein Laptop oder einen Desktop-PC, der über Ethernet (Netzwerk oder Crossover-Cable) mit dem CX1010 verbunden ist. Die Programme werden mit einer Standard TwinCAT Softwarelizenz auf dem Laptop entwickelt und dann in das Zielgerät geladen.

Visualisierung

Bei beiden Betriebssystemvarianten "Windows CE.NET" bzw. "Windows XP Embedded" steht für die Anbindung an SCADA-Pakete der Beckhoff OPC Server zur Verfügung. Somit gilt auch für den CX1010: Problemlos Visualisieren und gleichzeitiges Steuern in Echtzeit auf einem System.


CX1010: Technische Daten

BECKHOFF CX1010: Produktübersicht - Technische Daten

Technische Daten

Abmessungen:

Die Grundausstattung des CX1010 enthält eine 64-MB-Compact-Flash-Karte. Eine Ethernet-RJ-45 Schnittstellen gehört ebenfalls zur Basisausstattung. Über die beidseitig ausgeführte PC104-Schnittstelle können alle anderen Komponenten der CX-Familie angeschlossen werden. Für die Spannungsversorgung des CPU-Moduls wird eines der Netzteilmodule des Typs CX1100-000x benötigt.

Technische Daten | CX1010-0000
Prozessor | Prozessor AMD Geode® LX 800, 500 MHz-Taktfrequenz
Interner Flash Speicher | 64 MByte Compact Flash Karte
Interner Arbeitsspeicher | 256 MByte DDR-RAM
Schnittstellen | 1 x RJ45 (Ethernet)
Diagnose LED | 1 x Power, 1 x LAN Link/Aktivität, 1 x TC, 1 x Flash-Zugriff
Erweiterungssteckplatz | 1 x Compact Flash Typ I+ II Einschub mit Auswurfmechanik
Uhr | interne batteriegepufferte Uhr für Zeit und Datum
Betriebssystem | Microsoft Windows CE.NET oder Microsoft Windows XP Embedded
Steuerungssoftware | TwinCAT PLC Runtime , TwinCAT NC PTP Runtime oder TwinCAT NCI Runtime
Systembus | 16 Bit ISA (PC104 Standard)
Spannungsversorgung | über Systembus (durch Netzteilmodul CX1100-000x)
Verlustleistung | 8 Watt
Abmessungen | 58 mm x 120 mm x 91 mm
Gewicht | ca. 355 g
Betriebs-/Lagertemperatur | 0° C ... +50° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfest | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20

Das passive Kühlungsmodul ist im Lieferumfang enthalten. Es ist werkseitig mit dem CPU-Grundmodul verbunden.


CX1010: Ausführungen

BECKHOFF CX1010: Produktübersicht

Ausführungen

Das CPU-Modul lässt sich mit unterschiedlichen Hardware- und Softwareoptionen ausstatten: bei den Betriebssystemen besteht die Wahl zwischen "Windows CE.NET" sowie "Windows XP Embedded". Durch die Automatisierungssoftware TwinCAT wird ein CX1010 System zu einer leistungsfähigen SPS und Motion Control Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. An das CPU-Grundmodul können weitere Systemschnittstellen (ab Werk vormontiert) sowie Feldbusanschaltungen angefügt werden.

Die CX 1010 Module sind in folgenden Ausführungen erhältlich:

Modul | DVI / USB | ohne Betriebssystem | Windows CE | Windows XPE | ohne TwinCAT | TwinCAT PLC Runtime | TwinCAT NC PTP Runtime
CX1010-0000 | - | X | - | - | X | - | -
CX1010-0010 | - | - | X | - | X | - | -
CX1010-0011 | - | - | X | - | - | X | -
CX1010-0012 | - | - | X | - | - | - | X
CX1010-0100 | X | X | - | - | X | - | -
CX1010-0110 | X | - | X | - | X | - | -
CX1010-0111 | X | - | X | - | - | X | -
CX1010-0112 | X | - | X | - | - | - | X
CX1010-0020 | - | - | - | X | X | - | -
CX1010-0021 | - | - | - | X | - | X | -
CX1010-0022 | - | - | - | X | - | - | X
CX1010-0120 | X | - | - | X | X | - | -
CX1010-0121 | X | - | - | X | - | X | -
CX1010-0122 | X | - | - | X | - | - | X

CX1010 Systeme mit Windows XP Embedded setzen eine Compact Flash Karte mit einer Kapazität von mindestens 1 GByte voraus.

Hinweis:

Die Auflistung der verschiedenen Software Images entnehmen Sie bitte der Software Dokumentation für CX-Systeme.


CX1010: Anschlüsse

BECKHOFF CX1010: Produktübersicht

Anschlüsse

Das CPU-Grundmodul ist in verschiedenen Hardware- und Softwareoptionen erhältlich. Die Stromversorgung erfolgt über das Netzteil, so dass an dieser Stelle nur die Anschlüsse beschrieben werden.

CPU Grundmodul mit Ethernet RJ 45 Schnittstelle:

RJ 45 Schnittstelle (Buchse):

Belegung der RJ45-Schnittstelle:

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

TD & RD werden an den Hubs, oder zwischen zwei PCs getauscht.

Schematische Struktur der Netzwerkkomponenten:

Der CX1010 verfügt über zwei MAC-Bausteine. Der Erste (MAC1) bedient die Netzwerkschnittstelle zu dem linksseitigen Ethernet-Port, über den der CX1010 mit einem Standard IP-Netzwerk kommunizieren kann. Die Programmierung des CX1010 erfolgt ebenfalls über diesen Anschluss.

Der zweite Baustein (MAC2) bedient den erweiterten PC104 BUS. Hier kann über zusätzliche Systemschnittstellen der zweite physikalische Netzwerkanschluss genutzt werden. Dazu sind entweder das Netzteil CX1100-0004 oder die Systemschnittstelle CX1010-N060 erforderlich. Über das Netzteil wird eine Anbindung an den E-Bus für EtherCAT-Klemmen realisiert. Die Schnittstelle CX1010-N060 führt den Ethernet-Anschluss aus und stellt damit eine weitere Netzwerkschnittstelle zur Verfügung.

Sicht des Betriebssystems:

Für das Betriebssystem ist nur einer der Anschlüsse für die Netzwerkschnittstelle sichtbar. Die zweite angezeigte Schnittstelle ist die interne Anbindung über die Erweiterung des PC104 Busses. Ist kein Erweiterungsmodul angeschlossen, so wird die Leitung als nicht verbunden gemeldet. Ist das Netzteil CX1100-0004 angeschlossen meldet Windows XPe verbunden, aber "eingeschränkte oder keine Verbindung". Dieses Verhalten ist normal, da Windows selbst diese Schnittstelle nicht nutzt. Es wird auch keine IP-Adresse vergeben. Wird die Erweiterung CX1010-N060 angeschlossen, so verhält sich der Anschluss wie ein 'normaler' Netzwerkport.

Hinweis

Die Netzwerkports sind nur für den Gebrauch mit Standard IP-Netzwerken. Die Anschlüsse nicht mit Telekommunikationsanlagen verbinden.

CPU Grundmodul mit DVI/USB Schnittstelle:

Dieses Grundmodul enthält zusätzlich zu den beiden Ethernet Schnittstellen DVI / USB Schnittstellen. Die Pinbelegung des CPU Grundmoduls mit zwei USB und einer DVI-I Schnittstelle ist bei der zugehörigen Systemschnittstelle CX1010-N010 erklärt.

Gültig für alle CPU Grundmodule:

LED

Bei ordnungsgemäßem Anschluss des CPU Grundmoduls an ein Netzteil mit eingeschalteter Spannungsversorgung leuchtet die grüne LED Power (PWR) auf.

Compact Flash Einschub

Nähere Informationen hierzu finden Sie auf der Seite Compact Flash Einschub.

PC 104 Bus

Der PC 104 Bus ist ein standardisierter Bus mit 104 ISA-Signalen für kompakte Embedded Systeme.


CX-System: Batterie

BECKHOFF CX-System: Produktübersicht

Batteriefach

Auf der linken Seite des CPU-Moduls, zwischen den beiden Ethernet Schnittstellen, befindet sich das Batteriefach.

Dieses kann mit Hilfe eines Schraubenziehers vorsichtig geöffnet werden.

Bei der Batterie handelt es sich um eine Typ CR2032 von Panasonic.

Die genauen Daten lauten wie folgt:

Batterietyp | Elektrische Eigenschaften (bei 20° C) |  | Standard Belastung | Abmessungen
 | nominal Spannung | nominal Kapazität | kontinuierliche Last | Durchmesser | Höhe | Gewicht
CR2032 | 3,0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

Gefahr |
 | Eine falsch eingesetzte Batterie kann explodieren! Verwenden Sie ausschließlich denselben Batterietyp (CR2032) von Sanyo oder Panasonic. Achten Sie unbedingt darauf, dass die Plus- und Minuspole der Batterie korrekt eingelegt wird. (Minuspol links) Öffnen Sie die Batterie niemals und werfen Sie die Batterie niemals in ein Feuer. Die Batterie kann nicht wieder aufgeladen werden.

Hinweis |
 | Die Batterie muss alle 5 Jahre gewechselt werden. Ersatzbatterien können beim Beckhoff Service bestellt werden. Altbatterie- Rücknahme: Altbatterien dürfen nicht in den Hausmüll. Verbraucher sind verpflichtet, Batterien zu einer geeigneten Sammelstelle bei Handel oder Kommune zu bringen. Sie können nach Gebrauch an den bekannten Sammelstellen und auch bei der Beckhoff Automation GmbH unentgeltlich zurückgegeben werden. Altbatterien enthalten möglicherweise Schadstoffe oder Schwermetalle, die Umwelt und Gesundheit schaden können. Batterien werden wieder verwertet, sie enthalten wichtige Rohstoffe wie Eisen, Zink, Mangan oder Nickel. Die Umwelt und Beckhoff sagen Dankeschön.


Compact Flash Einschub

Auf der Frontseite befindet sich ein Compact Flash Einschub. Hier durch ergibt sich die Möglichkeit das Speichermedium auszutauschen. Dies ist bei dem Einschub im Grundmodul nur in ausgeschaltetem Zustand möglich, andernfalls kann die Entnahme zum Absturz des Systems führen. Bei der CF-Karten Erweiterung (CXxxxx-A001) kann die CF-Karte während des Betriebes entfernt werden. Das Speichermedium sollte aber beim System abgemeldet worden sein. Zu Wartungsarbeiten kann die Compact-Flash-Karte aus dem Modul entnommen werden. Auch die Erweiterung des Systems auf einen größeren Speicher (nur Betriebssystem und Programmspeicher) ist auf diese Weise möglich. Die Compact-Flash-Karten (CF-Karten) sind als Zubehör in verschiedenen Speichergrößen erhältlich.

Die folgende Bildserie zeigt die Handhabung der CF-Karten am Beispiel des CX1000. Die Betätigung der Auswurfmechanik mit einem Schraubendreher unterhalb des Einschubs bewirkt den Auswurf der Karte um ca. 4 mm (BILD1), so dass sie mit den Fingern herausgezogen werden kann (BILD2). Beim Einschub der Karte (BILD3) rastet die Auswurfmechanik wieder ein. Die Karte sitzt richtig, wenn sie sich ca.1 mm tiefer als die Frontseite des Gerätegehäuses befindet.

BILD1: Auswurf der CF Karte BILD2: Herausziehen der CF Karte BILD3: Einschub der CF Karte

Achtung |
 | Bei dem Compact-Flash-Einschub handelt es sich um ein Speicherinterface, nicht um einen CF Einschub des Typs I/O.


Compact Flash Karte

BECKHOFF CX-System: Produktübersicht

Compact-Flash-Karte

Bei der Compact-Fash-Karte (CF-Karte) handelt es sich um einen nicht volatilen Speicher.

Daten, die Spannungsausfallsicher gespeichert werden sollen, müssen auf der CF-Karte gespeichert werden. Die CF-Karte arbeitet wie eine Harddisk.

Achtung

Es wird ausdrücklich darauf hingewiesen nur CF-Karten zu verwenden, die von der Beckhoff Automation GmbH geliefert werden. Es handelt sich um industrietaugliche CF-Karten mit einer erhöhten Anzahl an Schreib-/ Lesezyklen und einem erweiterten Temperaturbereich ( +85°C).

Ein einwandfreier Betrieb kann nur mit CF-Karten von der Beckhoff Automation GmbH gewährleistet werden!


Speicheradressen

BECKHOFF CX-System: Übersicht der Speicheradressen

Adapter RAM Hardware Adressübersicht

verfügbarer Adressraum bei CX1010: D0000-DFFFF (hex)

Base Address (hex) | End Address (hex) | Size(Bytes)(hex) | Access Type | Description
D0000 | D0FFF | 1000 | R/W | CX1100-0002/3 Dual Ported RAM
D1000 | D100F | 10 | R/W | CX1100 Auxiliary Control Block( LCD Display, misc. registers)
D1010 | D101F | 10 | R/W | CX1100-0900 UPS Control Block
D2000 | D3FFF | 2000 | R/W | CX1100 Non Volatile RAM
D4000 | D5FFF | 2000 | R/W | CX1500-M310 Profibus Master DPRAM
D6000 | D7FFF | 2000 | R/W | CX1500-M510 CANopen Master DPRAM
D8000 | D9FFF | 2000 | R/W | CX1500-M520 DeviceNet Master DPRAM
DA000 | DBFFF | 2000 | R/W | CX1500-M200 Lightbus Master DPRAM
DC000 | DDFFF | 2000 | R/W | CX1500-M750 Sercos Master DPRAM

Für einige Felsbusanschaltungen (alle Slaveanschaltungen) liegen die eingeblendeten Adressen im Speicherbereich größer als DFFFF (hex). Für diese Anschaltungen müssen bei der Bestellung Module mit anderen Basisadressen bestellt werden. Gleiches gilt auch für den Einsatz von mehreren Mastermodulen des gleichen Feldbustyps. Die Bestellnummer lauten dann wie folgt:

Bestellnummer | Alternative ISA-Adresse
Masteranschaltungen
CX1500-Mxxx-0001 | D4000
CX1500-Mxxx-0002 | D6000
CX1500-Mxxx-0003 | D8000
CX1500-Mxxx-0004 | DA000
CX1500-Mxxx-0005 | DC000
Slaveanschaltungen
CX1500-Bxxx-0001 | D4000
CX1500-Bxxx-0002 | D6000
CX1500-Bxxx-0003 | D8000
CX1500-Bxxx-0004 | DA000
CX1500-Bxxx-0005 | DC000

Für xxx ist das entsprechende Feldbussystem einzusetzen:

  • 200 für Lightbus
  • 310 für Profibus
  • 510 für CAN-open
  • 520 für DeviceNet.

Hinweis |
 | Es können zwei Feldbusanbindungen (Master oder Slave) ohne Einschränkungen eingesetzt werden. Für mehr als zwei Anbindungen ist eine Freigabe durch die Beckhoff Automation GmbH erforderlich.


PC 104 Bus

Der PC 104 Bus ist ein standardisierter Bus mit 104 ISA-Signalen für kompakte Embedded Systeme.

Für die Funktionalität der CX1010 Module sind acht zusätzliche Signale, hier farblich markiert, zu den Standardsignalen hinzugefügt worden.

Pinbelegung des 16 Bit PC 104 Bus:

Pin Nummer | Row A | Row B | Row C4 | Row D4
1 | IOCHCHK* | GND | GND | GND
2 | SD7 | RESETDRV | SBHE* | MEMCS16*
3 | SD6 | +5V | LA23 | IOCS16*
4 | SD5 | IRQ9 | LA22 | IRQ10
5 | SD4 | n.c. (+12V intern) | LA21 | IRQ11
6 | SD3 | DRQ2 | LA20 | IRQ12
7 | SD2 | n.c. (+5V intern) | LA19 | IRQ13
8 | SD1 | ENDXFR* | LA18 | IRQ14
9 | SD0 | +12V | LA17 | DACK0*
10 | IOCHRDY | (KEY)² | MEMR* | DRQ0
11 | AEN | SMEMW* | MEMW* | DACK5*
12 | SA19 | SMEMR* | SD8 | DRQ5
13 | SA18 | IOW* | SD9 | DACK6*
14 | SA17 | IOR* | SD10 | DRQ6
15 | SA16 | DACK3* | SD11 | DACK7*
16 | SA15 | DRQ3 | SD12 | DRQ7
17 | SA14 | DACK1* | SD13 | +5V
18 | SA13 | DRQ1 | SD14 | MASTER*
19 | SA12 | REFRESH* | SD15 | GND
20 | SA11 | SYSCLK | (KEY)² | GND
21 | SA10 | IRQ7 | -- | --
22 | SA9 | IRQ6 | -- | --
23 | SA8 | IRQ5 | -- | --
24 | SA7 | IRQ4 | -- | --
25 | SA6 | IRQ3 | -- | --
26 | SA5 | DACK2* | -- | --
27 | SA4 | TC | -- | --
28 | SA3 | BALE | -- | --
29 | SA2 | +5V | -- | --
30 | SA1 | OSC | -- | --
31 | SA0 | GND | -- | --
32 | GND | GND | -- | --

Anmerkungen:

1. B10 und C20 sind nicht benutzt und können zur Sicherstellung der korrekten Verbindung von zwei Modulen ausgelassen werden.

2. Zeit- und Funktionsverhalten des Signals entsprechen der ISA Spezifikation.

3. Signalaus- und -eingang weichen von der ISA Spezifikation ab.

4. Negative Spannungen werden nicht unterstützt.

5. In der Spezifikation werden die Pins von 0 bis 19 gezählt.

Pinbelegung der acht zusätzlichen Signale:

Pin Nummer (gelbe Felder) | Row C | Row D
1 | LAN TX- | LAN TX+
2 | LAN RX- | LAN RX+
3 | USB D- | USB D+
4 | SMBDAT | SMBCLK

Hinweis:

Weitere Informationen zum PC104 Bus finden Sie im Datenblatt oder unter http://www.pc104.org.


CX1010-Nxxx: Technische Daten

BECKHOFF CX1010: Systemschnittstellen - Technische Daten

Technische Daten

Abmessungen:

Wie zu der CX1000-CPU sind zum CPU-Grundmodul CX1010 eine Reihe optionaler Systemschnittstellenmodule erhältlich. Diese werden ab Werk montiert. Die optional stehen folgende Systemerweiterungen zur Verfügung:

  • CX1010-N010 DVI / USB Modul
  • CX1010-N020 Audioschnittstellen
  • CX1010-N030/40 serielle Schnittstellen für RS323
  • CX1010-N031/41 serielle Schnittstellen für RS422 / RS485
  • CX1010-N060 Ethernet-Schnittstelle

CX1010-N010 bietet über die DVI- und USB-Schnittstellen den Anschluss an Beckhoff Control-Panel oder marktübliche Monitore mit DVI- oder VGA-Eingang an. An die USB-Schnittstellen vom Typ USB 2.0 können Geräte wie Maus, Tastatur, Drucker, Scanner, Massenspeicher, und weitere angeschlossen werden. Es sind aber dann Treiber für das entsprechende Betriebsystem (Windows CE / XPe) zu installieren. Multimediafähigkeiten werden über die Audioschnittstelle CX1010-N020 realisiert. Insgesamt vier serielle RS232-Schnittstellen mit max. 115-kBaud-Übertragungsgeschwindigkeit bieten die Module CX1010-N030 und CX1010-N040. Diese vier Schnittstellen können jeweils paarweise als RS422/RS485 ausgeführt werden; die Bezeichnungen lauten dann CX1010-N031 bzw. CX1010-N041. Die Systemschnittstellen sind nicht im Feld nachrüstbar oder erweiterbar. Sie werden in der bestellten Konfiguration ab Werk geliefert und sind vom CPU-Modul nicht trennbar. Die Systemschnittstellen führen den internen PC104-Bus durch, so dass an sie weitere CX-Komponenten angeschlossen werden können. Die Spannungsversorgung der Systemschnittstellenmodule wird über den internen PC104-Bus gewährleistet.

Technische Daten | CX1010-N010 | CX1010-N020 | CX1010-N030 CX1010-N040 | CX1010-N031 CX1010-N041
Schnittstellen | 1 x DVI + 2 x USB 2.0 max. 100 mA pro Port | Line IN, MIC IN, Line OUT | 1 x COM1+2, RS232 1 x COM3+4, RS232 | 1 x COM1+2, RS422/RS485 1 x COM3+4,RS422/RS485
Anschlussart | DVI-I 29-polige Buchse + 2 USB Ports Typ A | 3,5 mm Buchse für Klinkenstecker | 2 x D-Sub Stecker 9-polig | 2 x D-Sub Buchse 9-polig
Eigenschaften | DVI-I Schnittstelle führt auch VGA Signale aus (DVI-A) | eingebauter PC-Beeper Line OUT Ausgang, max. 200 mW, für Kopfhörer geeignet | max. Baudrate 115 kBaud, nicht gleichzeitig mit N031/N041 einsetzbar | max. Baudrate 115 kBaud, nicht gleichzeitig mit N030/N040 einsetzbar
Spannungsversorgung | über Systembus (durch Netzteilmodul CX1100-xxxx)
Abmessungen | 19 mm x 100 mm x 51 mm
Betriebstemperatur | 0 °C ... +55 °C
Lagertemperatur | -25 °C ... +85 °C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20
Gewicht | ca. 80 g

Technische Daten | CX1010-N060
Schnittstellen | 1 x Ethernet 10/100 Mbit
Anschlussart | 1 x RJ45
Eigenschaften | Netzwerkanschluss für erweiterten PC104 Bus
Spannungsversorgung | über Systembus (durch Netzteilmodul CX1100-xxxx)
Abmessungen | 19 mm x 100 mm x 51 mm
Betriebstemperatur | 0 °C ... +55 °C
Lagertemperatur | -25 °C ... +85 °C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Schutzart | IP 20
Gewicht | ca. 80 g


Anschlüsse CX1010-N010

Dieses Modul liefert zusätzlich zur der Ethernetschnittstelle des CPU-Grundmoduls eine DVI-I und zwei USB Schnittstellen.

DVI-I Schnittstelle

Die DVI-I Schnittstelle überträgt analoge und digitale Daten und eignet sich für den Anschluss an digitale Displays. Die Auflösung am Bildschirm oder Beckhoff Control Panel ist abhängig von der Entfernung zum Anzeigegerät. Die maximale Entfernung beträgt 5 m.

Die DVI Schnittstelle führt VGA Signale aus, so dass der Anschluss von CRT-VGA Monitoren an das CX1010 System unter Verwendung eines DVI-to-VGA Adapters ebenfalls möglich ist. Dieser Adapter ist als Zubehör erhältlich.

DVI-I Buchse:

Pin | Belegung | Pin | Belegung | Pin | Belegung
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -

Pinbelegung Kreuz

Pin | Belegung
C1 | Analog Red Video Out
C2 | Analog Green Video Out
C3 | Analog Blue Video Out
C4 | Analog Horizontal Sync

Auflösung am Monitor:

Auflösung in Pixel | Entfernung der Schnittstelle vom Monitor
1600 x 1200 | 5 m
1280 x 1024 | 5 m
1024 x 768 | 5 m
800 x 600 | 5 m
640 x 480 | 5 m

USB Schnittstelle:

Die USB Buchse ist vom Typ A. Die USB Schnittstelle entspricht der USB 2.0 Spezifikation.

Pin | Belegung | Typische Zuordnung
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


Anschlüsse CX1010-N020

BECKHOFF CX1010: Systemschnittstellen

Anschlüsse CX1010-N010

Diese Systemschnittstelle liefert Audioschnittstellen für das CX1010-System. Es stehen zwei Eingänge "LINE IN" und "MIC IN" zur Verfügung. Für die Ausgabe von Audiosignalen ist der "LINE OUT" - Anschluss vorgesehen. Hier kann auch ein Kopfhörer mit einer Leistung von max. 200 mW angeschlossen werden. Zusätzlich ist ein PC-Beeper eingebaut. Auf die Audioschnittstellen wird über das Betriebssystem zugegriffen.

Die Buchsen haben eine Größe von 3,5 mm und sind für Klinkenstecker ausgelegt.

Standard- / Stereo-Betrieb:

Im Standardbetrieb wird das Audiomodul im Stereomodus betrieben. Also Stereo Aus- und Eingänge und ein Einkanaleingang für das Mikrofon. Die Eingänge sind dann wie beschriftet zu beschalten. Die Steckerbelegungen sind im Folgenden beschrieben.

Line In / Line Out Stereo-Klinkenstecker:

Pinbelegung Line In /Line Out:

Signal | Beschreibung
L | Linker Kanal
R | Rechter Kanal
Ground | Masse

Der linke Kanal wird über die Spitze des Klinkensteckers übertragen, der rechte Kanal über den ersten Ring. Die übrige Hülse dient zur Erdung.

Mic In Mono-Klinkenstecker:

Der einzige vorhandene Kanal wird über die Spitze übertragen, die übrige Hülse dient zur Erdung.


Anschlüsse CX1010-N030

BECKHOFF CX1010: Systemschnittstellen

Anschlüsse CX1010-N030/40

Die Systemschnittstelle CX1010-N030 stellt zwei RS232 Schnittstellen, COM1 und COM2, bereit. Beide sind auf einer 9-poligen Sub-D Stiftleiste ausgeführt. Sollten mehr als zwei Schnittstellen benötigt werden, so kann das System über die Systemschnittstelle CX1010-N040 um zwei weitere RS232 Schnittstellen, COM3 und COM4, erweitert werden. Auch diese werden als 9-polige Sub-D Stiftleiste ausgeführt. Die Pinbelegung aller Stecker ist identisch und wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle RS232 (Stecker):

Pinbelegung COM Schnittstelle:

PIN | Signal | Typ | Beschreibung
1 | DCD | Signal in | Data Carrier Detected
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground
6 | DSR | Signal in | Dataset Ready
7 | RTS | Signal out | Request to Send
8 | CTS | Signal in | Clear to Send
9 | RI | Signal in | Ring Indicator

Achtung

Die Systemschnittstelle CX1010-N030 kann nur anstatt und nicht gleichzeitig mit CX1010-N031 verwendet werden.

Die Systemschnittstelle CX1010-N040 kann nur anstatt und nicht gleichzeitig mit CX1010-N041 verwendet werden.


Anschlüsse CX1010-N041

BECKHOFF CX1010: Systemschnittstellen

Anschlüsse CX1010-N031/41

Die Systemschnittstelle CX1010-N031 stellt zwei RS422 bzw. RS485 Schnittstellen, COM1 und COM2, bereit. Beide sind auf einer 9-poligen Sub-D Buchsenleiste ausgeführt. Sollten mehr als zwei Schnittstellen benötigt werden, so kann das System über die Systemschnittstelle CX1010-N041 um zwei weitere RS442/485 Schnittstellen, COM3 und COM4, erweitert werden. Auch diese werden als 9-polige Sub-D Buchsenleiste ausgeführt. Die Pinbelegung aller Stecker ist identisch und wird unten auf der Seite dargestellt.

Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit. Die Einstellung der Schnittstellenparameter erfolgt über das Betriebssystem oder kann aus dem SPS-Programm heraus gesteuert werden.

COM Schnittstelle (Buchse):

Pinbelegung COM Schnittstelle:

PIN | Signal | Typ | Beschreibung
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

Für RS 485 muss Pin 2 und 3 ( Data +) sowie Pin7 und 8 (Data -) verbunden werden.

Einstellung der Schnittstellen Parameter

Wenn das Schnittstellenmodul CX1010-N031/N041 sich als letztes in der Reihe Systemmodule befindet, ist der Zugriff auf die DIP-Schalter möglich. Entweder muss zuvor die Endabdeckung oder eventuelle Busmaster/Slaves entfernt werden. Details hierzu finden sich im Kapitel Abbau / Entsorgung. Liegt die Modulseite frei, so ist folgendes zu sehen:

Der obere Schalter ist für die obere Schnittstelle, der untere entsprechend für die untere Schnittstelle zuständig. Die Schnittstellen können unabhängig von einander eingestellt werden. Mit einem langen, kleinen Schraubenzieher können die einzelnen Schalter vorsichtig gesetzt werden. Zum Einstellen ist das System abzuschalten!

Einstellung DIP-Switches RS485:

RS485 without Echo, End-Point ( Terminated) DEFAULT EINSTELLUNG

DIP | Status | Funktion
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | on | Auto receive on
6 | off | Always receive on
7 | on | Term on
8 | on | Term on

RS485 with Echo, End-Point ( Terminated)

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

RS485 without Echo, Drop-Point ( without Termination)

DIP | Status | Funktion
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

RS485 with Echo, Drop-Point ( without Termination)

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

Einstellung DIP-Switches RS422:

RS422 full duplex end point

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | off | Auto send on
4 | on | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

Achtung

Die Systemschnittstelle CX1010-N031 kann nur anstatt und nicht gleichzeitig mit CX1010-N030 verwendet werden.

Die Systemschnittstelle CX1010-N042 kann nur anstatt und nicht gleichzeitig mit CX1010-N040 verwendet werden.


Anschlüsse CX1010-N060

Die Systemschnittstelle CX1010-N060 stellt eine weitere Netzwerkschnittstelle zur Verfügung. Diese kann aber nur genutzt werden, wenn das Netzteil CX1100-0004 nicht angeschlossen ist. Da die eine, interne Schnittstelle, in diesem Fall für den Anschluss des Ethernet-Ports genutzt wird. (Details siehe Beschreibung des Grundmoduls.)

RJ 45 Schnittstelle (Buchse):

Belegung der RJ45-Schnittstelle, Port 1:

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

TD & RD werden an den Hubs, oder zwischen zwei PCs getauscht.

Achtung |
 | Die Systemschnittstelle CX1010-N060 darf nur rechts, direkt an das CPU-Modul angebaut werden. Die Einbausituation wird in den folgenden Abbildungen dargestellt.

Gültige Einbauposition:

Die Schnittstelle befindet sich zwischen CPU-Modul und Netzteil.

Ungültige Einbauposition:

Die Schnittstelle befindet sich links von dem CPU-Modul in der Anreihung der anderen Systemschnittstellen.

Achtung |
 | Die maximale Länge eines angeschlossenen Netzwerkkabels beträgt 15 Meter!

Hinweis |
 | Die Systemschnittstelle CX1010-N060 kann nur anstatt und nicht gleichzeitig mit dem Netzteil CX1100-0004 verwendet werden.


Übersicht Netzteile CX1100-000x

BECKHOFF CX-System: Netzteile CX1100-000x

CX1100-000x | Netzteile und I/O-Schnittstellen

Die Spannungsversorgung eines CX10x0-Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100-Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen. Ein 4 + 1 Taster erlaubt Benutzereingaben ohne ein weitere Tastatur oder Eingabetafel. Die Anreihung lokaler I/O-Signale geschieht über die Netzteilvariante CX1100-0002, an die alle Beckhoff Busklemmen angeschlossen werden können, oder über CX1100-0003, die zusätzlich zu den Busklemmen auch den Anschluss der Beckhoff-Feldbus-Box-Module vom Typ Erweiterungs-Box IExxxx erlaubt. Mit der Anschlussmöglichkeit der Busklemmen und Feldbus Box entsteht eine Steuerung mit einer sehr variablen, erweiterbaren I/O-Ebene mit großer Signalvielfalt. Die I/O-Daten werden in einem DPRAM abgelegt, welches der CPU über den Systembus zugänglich ist. Die Netzteile des CX-Systems sind im Feld austauschbar: Wird z. B. lokales I/O über Busklemmen gewünscht, so kann CX1100-0001 im Feld durch CX1100-0002 ersetzt werden. Die Anreihung von EtherCAT-Klemmen ist über das Netzteil CX1100-0004 möglich. Die I/O-Daten werden beim CX1100-0004 direkt im Arbeitsspeicher der CPU abgelegt; ein DPRAM ist nicht mehr nötig. Das Netzteil CX1100-0004 bzw. die Anreihung von EtherCAT-Klemmen ist nur mit dem CX1000 nicht möglich.

Die Technischen Daten sind bei den einzelnen Netzteilen abgelegt:

  • CX1100-0001 (kein Feldbus)
  • CX1100-0002 (K-Bus)
  • CX1100-0012 (K-Bus für CX1030 und CX10x0 mit alternativen Einbaulagen)
  • CX1100-0003 (K-Bus, IP-Link)
  • CX1100-0013 (K-Bus, IP-Link für CX1030 und CX10x0 mit alternativen Einbaulagen)
  • CX1100-0004 (E-Bus)
  • CX1100-0014 (E-Bus für CX1030 und CX10x0 mit alternativen Einbaulagen)

Eine Übersicht über die Architektur der Netzteile mit Beschreibung der allgemeinen Systemkomponenten GCB, ACB, NOVRAM, Display und Taster sind in der Dokumentation der Netzteile detailliert beschrieben.


Technische Daten CX1100-0001

Abmessungen:

Die Spannungsversorgung eines CX1020 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Das Netzteil CX1100-N001 besitzt keine E/A Schnittstellen.

Technische Daten | CX1100-0001
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 2,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | -
E-Bus Anschluss | -
IP-Link Anschluss | -
K-Bus Stromversorgung bis max. | -
Anschlussart | 1 x Open Pluggable Connector, 5-polig
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x PWR
Abmessungen | 45 mm x 100 mm x 91 mm
Gewicht | 180 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0002

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0002
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | -
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 2 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 40 mm x 100 mm x 91 mm
Gewicht | 250 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0012

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vieri wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0012
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | -
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 2 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 42 mm x 109 mm x 92 mm
Gewicht | 240 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0003

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0003
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 4 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | ja
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 4 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 58 mm x 100 mm x 91 mm
Gewicht | 350 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0001

CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0013

Abmessungen:

Die Spannungsversorgung eines CX10x0 Systems erfolgt durch eines von vier wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Technische Daten | CX1100-0013
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 4 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | ja (Adapterklemme)
E-Bus Anschluss | -
IP-Link Anschluss | ja
K-Bus Stromversorgung bis max. | 1,75 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 4 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x 1/O Err
Abmessungen | 58 mm x 109 mm x 92 mm
Gewicht | 325 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0004

Abmessungen:

Die Spannungsversorgung eines CX- Systems erfolgt durch Netzteilmodule. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Die Anreihung lokaler I/O-Signale an den CX1020 geschieht über die Netzteilvarianten CX1100-0002 (Busklemmen), CX1100-0003 (Busklemmen und Feldbus-Box-Module via IP-Link) sowie CX1100-0004 für die EtherCAT-Klemmen. Die I/O-Daten werden direkt im Arbeitsspeicher der CPU abgelegt; ein DPRAM ist nicht mehr nötig.

Das Netzteil CX1100-0004 bzw. die Anreihung von EtherCAT-Klemmen ist in Verbindung mit den CPU-Grundmodulen CX1010/CX1020/CX1030 möglich. Mit dem CPU-Grundmodul CX1000/CX1001 ist die Verbindung nicht möglich.

Technische Daten | CX1100-0004
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | -
E-Bus Anschluss | ja (Adapterklemme)
IP-Link Anschluss | -
E-Bus Stromversorgung bis max. | 2 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x PWR, 1 x L/A, 1 x Run
Abmessungen | 40 mm x 100 mm x 91 mm
Gewicht | 250 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Technische Daten CX1100-0004

BECKHOFF CX1100-00xx: Produktübersicht - Technische Daten

Technische Daten CX1100-0014

Abmessungen:

Die Spannungsversorgung eines CX- Systems erfolgt durch Netzteilmodule. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Die Spannungsversorgung CX1100-0014 ist für den CX1030 bestimmt.

Die Netzteile CX1100-0004 und CX1100-0014 bzw. die Anreihung von EtherCAT-Klemmen ist nur in Verbindung mit dem CPU-Grundmodulen CX1010 / CX1020 / CX1030 möglich.

Technische Daten | CX1100-0014
Spannungsversorgung | maximal 24 VDC. (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 3,5 W
Empfohlene Sicherung bei 24 V | 4 A
K-Bus Anschluss | -
E-Bus Anschluss | ja (Adapterklemme)
IP-Link Anschluss | -
E-Bus Stromversorgung bis max. | 2 A
Anschlussart | Cage-Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x PWR, 1 x L/A, 1 x Run
Abmessungen | 42 mm x 109 mm x 92mm
Gewicht | 235 g
Betriebs-/Lagertemperatur | 0° C ... +55° C / -25° C ... +85° C
Relative Feuchte | 95% ohne Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27/29
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP 20


Anschlüsse CX1100-0001

Dieses Netzteil besitzt keine E/A-Schnittstelle, die Stromversorgung erfolgt daher über den 5-poligen "Open Pluggable Connector". Das Netzteil versorgt über den PC104-Bus alle weiteren Systemkomponenten mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff.
Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten.

Pinbelegung "Open Pluggable Connector":

Pin | Belegung
1 | +24 V DC
2 | 0 V DC
3 | GROUND
4 | reserved / don't use
5 | reserved / don't use

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.


Anschlüsse CX1100-0002

BECKHOFF CX1100-00xx: Übersicht / elektrischer Anschlüsse

Anschlüsse CX1100-00x2

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den K-Bus die Busklemmen mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff. Da der K-Bus nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.
Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten.

CX1100-0002 für CX1000, CX1010 und CX1020 | CX1100-0012 für CX1030

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.

Die I/O LEDs dienen zur Anzeige der Betriebsstände der Busklemmen. Der fehlerfreie Hochlauf der Konfiguration wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.


Anschlüsse CX1100-0003

BECKHOFF CX1100-00xx: Übersicht / elektrischer Anschluss

Anschlüsse CX1100-00x3

Dieses Netzteil ermöglicht neben einem Anschluss der Beckhoff Busklemmen auch die Anreihung der Beckhoff Feldbus Box Module vom Typ Erweiterungs-Box IExxxx. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0V". Die Versorgungsspannung versorgt das CX System und über den K-Bus die Busklemmen. Da der K-Bus nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.

CX1100-0003 für CX1000, CX1010 und CX1020 CX1100-0013 für CX1030

Feldbusanschluss:

Stecken Sie den IP-Link Stecker in die vorgesehenen Anschlüsse, d.h je einen Lichtwellenleiter in IN (x03) bzw. OUT (x04). Das andere Ende verbinden Sie mit dem entsprechenden IP-Link Interface der Erweiterungs-Box. Die Verbindung mit dem muss so erfolgen, dass der Output der Feldbusanschaltung mit dem Input der Erweiterungs-Box verbunden wird, und umgekehrt.

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot. Die I/O LEDs dienen zur Anzeige der Betriebsstände der Busklemmen. Der fehlerfreie Hochlauf der Konfiguration wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.


Anschlüsse CX1100-0004

BECKHOFF CX1100-00xx: Übersicht / elektrischer Anschluss

Anschlüsse CX1100-00x4

Das Netzteil CX1100-0004 ermöglicht die Anreihung von EtherCAT Klemmen. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den E-Bus die EtherCAT Klemmen.

CX1100-0004 für CX1000, CX1010 und CX1020 | CX1100-0014 für CX1030

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.

Hinweis |
 | Dieses Netzteil ist nur für die Verwendung mit dem CX10x0 entwickelt. Ein Betrieb mit dem CX1000 ist nicht möglich, da das CX1000-System das EtherCAT-Protokoll nicht über den erweiterten PC104 Bus ausführt.

Hinweis |
 | Die Systemschnittstelle CX1020-N060 kann nur anstatt und nicht gleichzeitig mit dem Netzteil CX1100-0004 verwendet werden.

Warnung |
 | Beim Einsatz des Netzteils ist auf den Hardwarestand zu achten. Netzteile mit dem Hardwarestand > 2.0 funktionieren nur mit CX1020-Systemen mit einem Hardwarestand > 2.1 !


Ansteuerung über ADS

Das LCD-Display der Netzteile besitzt zwei Zeilen à 16 Zeichen und dient zur Anzeige von System- und Anwendermeldungen.

"Index-Group/Offset"Spezifikation für das LCD Display

ADS Port 300

Index Group | Index Offset | Access | Data type | Phys. unit | Def. range | Description | Remarks
0x00005000 + DeviceID | 0xFFFF90FF | R&W |  |  |  | Cursor OFF |
0x00005000 + DeviceID | 0xFFFF91FF | R&W |  |  |  | Cursor ON |
0x00005000 + DeviceID | 0xFFFF92FF | R&W |  |  |  | Cursor blink OFF |
0x00005000 + DeviceID | 0xFFFF93FF | R&W |  |  |  | Cursor blink ON |
0x00005000 + DeviceID | 0xFFFF94FF | R&W |  |  |  | Display OFF |
0x00005000 + DeviceID | 0xFFFF95FF | R&W |  |  |  | Display ON |
0x00005000 + DeviceID | 0xFFFF96FF | R&W |  |  |  | Backlight OFF |
0x00005000 + DeviceID | 0xFFFF97FF | R&W |  |  |  | Backlight ON |
0x00005000 + DeviceID | 0xFFFFA0FF | R&W |  |  |  | Write Text line 1 |
0x00005000 + DeviceID | 0xFFFF00FF | R&W |  |  |  | Write Text line 2 |


Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Abmessungen (B x H x T): 19 x 100 x 91 mm (Systemschnittstelle), 58 x 100 x 91 mm (Grundmodul) 58 x 100 x 91 (Netzteil mit E/A-Schnittstelle)

Gewicht: 80 g (Systemschnittstelle) bis 355 g (Grundmodul)

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:
1. Entfernen Sie die Verpackung.
2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Wiedertransport auf.
3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung | Beschädigungsgefahr des Gerätes!
 | Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung). Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


CX1010: Maße

BECKHOFF CX1010: Einbau und Verdrahtung

Maße

Die Produktreihe CX1010 zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein CPU Modul und ein Netzteil sowie die entsprechenden Systemschnittstellen und die Feldbusschnittstellen vorgesehen werden. Die Gesamtbreite der Anwendung setzt sich aus den einzelnen verwendeten Module zusammen. Mit einer Höhe von 100 mm entsprechen die Maße der Module exakt denen der Beckhoff Busklemmen.

Achtung: es muss noch ein Sicherheitsabstand zur ausreichenden Kühlung des CPU-Moduls vorgesehen werden. (Details hierzu unter Einbaulage) Außerdem ermöglichen die abgesenkten Steckerflächen den Einsatz in einem Standard Klemmenkasten von 120 mm Höhe.

CX1010 CPU-Grundmodule:

CX1000-N00x / CX1010-N0x0 Systemschnittstellen:

CX1100-000x Netzteile:

CX1100-0001

Netzteil ohne E/A-Schnittstelle

CX1100-0002

Netzteil mit E/A Schnittstelle (K-Bus-Anschluss)

Abmessungen in mm: 39 x 100 x 91

CX1100-0003

Netzteil mit E/A-Schnittstelle (K-Bus-Schnittstelle) und IP-Link

Abmessungen in mm: 58 x 100 x 91

CX1100-0004 ( nur mit CX1010 verwendbar)

Netzteil mit E-Bus ( EtherCAT)

CX1100-09x0 USV Modul:

CX1100-0900

CX1100-0910

CX1100-0920

CX1500-Mxxx und CX1500-Bxxx Feldbusanschaltungen

Die Module für die Feldbusanschaltungen besitzen die Abmessung 38 x 100 x 91 mm, unabhängig davon, ob es sich um eine Master- oder Slaveanschaltung handelt.

CX1500-Bxxx

CX1500-Mxxx


Mechanischer Zusammenbau des Grundmoduls

Der Einbau der Module erfolgt in drei Schritten:

1. Reihenfolge der Module

Das CPU-Grundmodul mit den werkseitig links angeschlossenen Systemschnittstellen wird auf der rechten Seite um das Netzteil, und auf der linken Seite um die Feldbusanschaltung (Master bzw. Slave), soweit vorhanden, erweitert.

2. Zusammenbau der CPU mit dem Netzteil

Die Befestigung der einzelnen Module untereinander wird durch das einfache Zusammenstecken erreicht. Dabei ist zu beachten, dass die Stecker des PC104 Interface nicht beschädigt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.

3. Aufrasten auf die Hutschiene

Auf der Unterseite der Module befindet sich eine weiße Zuglasche, die mit einem Rastmechanismus verbunden ist. Diese Zuglaschen müssen vor dem Anbringen auf die Hutschiene nach unten gezogen werden. Dieses kann mittels eines Schlitzschraubendrehers und einer leichten Drehung geschehen.

Anschließend wird der CX1010-Block mit Hilfe der Verrieglungslaschen auf der Hutschiene fixiert. Dabei sollte ein leisen Klicken zu vernehmen sein.

Keine Gewalt oder zu großen Druck auf die Baugruppe ausüben!

Die Gehäuse nur an unempfindlichen Stellen (Gehäusekanten) drücken. Auf keinen Fall Druck auf das Display, die Taster oder bewegliche Teile am CX10x0-System ausüben.

Nach erfolgreichem Aufrasten auf die Hutschiene müssen die Zuglaschen wieder in die Ausgangsstellung geschoben werden.

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Ausführliche Informationen zur Demontage der CX1010-Konfiguration von der Hutschiene finden Sie auf der Seite "Abbau und Entsorgung".

Einbaulage:

Achtung

Das auf eine Hutschiene montierte CPU Modul darf nur bis Umgebungstemperaturen von 50°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die Bilder zeigen die erlaubte ( BILD8) sowie zwei verbotene Einbaulagen (BILD 9 & BILD10).

Mindestabstand einhalten!

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX1010 Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU Grundmoduls und des Netzteils zu erreichen.
Zulässige Einbaulage:

Auf Grund der hohen Leistung des CX1010-Systems kommt es zu einer erhöhten Wärmeentwicklung. Diese Wärme wird durch ein passives Lüftungssystem abgeführt. Dieses System erfordert allerdings eine korrekte Einbaulage. Lüftungsöffnungen befinden sich auf der Gehäuseunter- und Gehäuseoberseite. Daher muss das System waagerecht montiert werden. Auf diese Weise kommt ein optimaler Luftstrom zustande.

Unzulässige Einbaulagen:

Es ist nicht zulässig das CX1010-System senkrecht auf der Hutschiene zu betreiben. Es ist dann keine ausreichende Belüftung für die CPU gewährleistet, da sich die Belüftungsöffnungen auf der Gehäuseober- und Gehäuseunterseite befinden. Auch in liegender Position ist das System nicht ausreichend belüftet.


Mechanischer Anbau der Feldbusanschaltung

Der Anbau einer Feldbusanschaltung erfolgt in mehreren Schritten:

1. Entfernung der Abdeckung am CX1010-Grundmodul

Um die Feldbusanschaltung am CX1010-Grundmodul befestigen zu können, muss zunächst die Abdeckung am CX1000/CX1010-Grundmodul entfernt werden. Dieses wird durch einen leichten Druck gegen die Abdeckung erreicht.

2. Zusammenbau der Anschaltung mit der CX1000/CX1010-Konfiguration

Da sich die CX1000-Konfiguration bereits auf der Hutschiene befindet, muss zunächst die Anschaltung auf die Hutschiene gedrückt werden. Dazu ist zuerst das Lösen des Rastmechanismus anhand der weißen Zuglaschen (nach unten ziehen) notwendig.
Die Befestigung der Anschaltung mit der bestehenden CX1000/CX1010-Konfiguration wird durch das einfache Zusammenstecken erreicht. Dabei ist zu beachten, dass der Stecker des PC104 Interface nicht beschädigt wird.
Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen. Am Schluss werden die weißen Zuglaschen wieder in ihre Ausgangsstellung gebracht, damit der Verriegelungsmechanismus einrastet.

3. Abdeckung anbringen

Falls die Anschaltung linksseitig keinen Abschlussdeckel besitzt, wird die vorhin entfernte Abdeckung auf die Anschaltung gedrückt, bis sie hörbar einrastet.

Hinweis:

Wenn sich die CX1000/CX1010-Konfiguration nicht auf der Hutschiene befindet, ist es ist möglich, die Anschaltung zunächst mit der CX1000/CX1010-Konfiguration zu verbinden und danach die gesamten Module auf die Hutschiene aufzurasten. Die Montage erfolgt dann wie in Kapitel Einbau und Verdrahtung.

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden.


PC einschalten / ausschalten

Einschalten

Die Stromversorgung des CPU Grundmoduls erfolgt über das Netzteil. Beim Anschluss des Netzteils an die Stromversorgung startet das CPU Grundmodul automatisch.

Erstes Einschalten

Wenn Sie den PC das erste Mal einschalten, wird das vorinstallierte Betriebssystem (optional) gestartet.

Ausschalten

Beim Ausschalten der Stromversorgung des Netzteils wird auch der Embedded-PC ausgeschaltet. Die laufende Steuerungssoftware, wie sie typischerweise auf Embedded-PCs eingesetzt wird, sollte ordnungsgemäß angehalten bzw. beendet werden. Ein Benutzer, der die Software nicht beenden darf, darf auch nicht den Embedded-PC abschalten, weil durch Abschalten bei laufender Software Daten auf der Festplatte verloren gehen können.

Ist die Software angehalten, kann das Betriebssystem heruntergefahren werden. Erst dann sollte die Stromversorgung unterbrochen werden.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup

Bemerkung zur Benutzung des Setup

Achtung

Die CX1010-System werden von der Beckhoff Automation GmbH in vorkonfiguriertem Zustand ausgeliefert und sind so BETRIEBSBEREIT!

Einstellungen am BIOS dürfen nur von fachkundigem Personal durchgeführt werden.

Für den Betrieb mit Windows CE wird ganz von Änderungen im BIOS abgeraten, da das Betriebsystem an die Hardwarekonfiguration angepasst ist. Ein Ändern der Adressen oder Interrupts führt zu instabilem Laufverhalten bzw. zum Absturz des Systems.

Innerhalb der einzelnen Setup-Seiten werden mit F6 für Fail-Safe Defaults und F7 für Optimized Defaults Standard-Werte für die einzelnen Setup-Einträge geladen. Diese Standard-Werte sind unabhängig davon, ob das Board schon mal mit einer Setup-Einstellung erfolgreich gebootet hat. Anders ist es, wenn diese Defaults aus dem TOP-Menü aufgerufen werden. Wurde bereits einmal eine Setup-Einstellung abgespeichert, die im Anschluss auch zu einem erfolgreichem Booten führte, so werden mit beiden Menü-Punkten diese Werte als Default für die Setup-Seiten geladen. Siehe dazu auch die Kapitel Load Fail-Safe Defaults und Load Optimized Defaults.

Top Menu

Phoenix – AwardBIOS CMOS Setup Utility

► Standard CMOS Features | ► PC Health Status
► Advanced BIOS Features | Load Fail-Save Defaults
► Advanced Chipset Features | Load Optimized Defaults
► Integrated Peripherals | Set Passwort
► Power Management Setup | Save & Exit Setup
► PnP/PCI Configuration | Exit Without Saving
ESC: Quit ↑ ↓ → ← Select Item F10: Save & Exit Setup
"Kurzbeschreibung der oben selektierten Funktion"

Ein „►“ Zeichen vor dem Menüpunkt bedeutet, dass ein Untermenü vorhanden ist. Das „x“ Zeichen vor einem Menüpunkt heißt, dass es eine Einstellmöglichkeit gibt, die jedoch erst durch eine darüber
liegende Einstellung aktiviert werden muss.

Load Fail-Save Defaults

Diese Option dient der absoluten Sicherheitseinstellung. Unakzeptabel für den Dauerbetrieb, aber gut wenn der PC nicht funktioniert.

Load Optimized Defaults

Mit dieser Option stellen Sie die nach Meinung des Herstellers optimalen Werte ein.

Set Passwort

Hier können Sie das Setup-Passwort eingeben, welches das unberechtigte Aufrufen des BIOS Setup verhindert.

Save & Exit Setup

Wenn die Einstellungen gespeichert und das Setup beendet werden soll. Eingabe: Y (Achtung: bei deutscher Tastatur Z eingeben).

Exit Without Saving

Setup beenden ohne Sicherung der Einstellungen. Einstellung: Y (Achtung: bei deutscher Tastatur Z eingeben).


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: Standard CMOS Features

Standard CMOS Features

In diesem Menu werden die Datum, Uhrzeit, Festplatten, Graphikmodus und Startverhalten eingestellt. Gleichzeitig wird Auskunft über den vom System ermittelten Speicherausbau gegeben. Die Angaben für den Speicherausbau sind daher auch nicht veränderbar. Die Eingaben für Datum, Zeit, Graphikmodus und Startverhalten können in der unten beschriebenen Weise eingegeben werden. Für das Einstellen der Festplattendaten wird ein neues Menu geöffnet.

Phoenix – AwardBIOS CMOS Setup Utility

Standard CMOS Features

Date (mm:dd:yy) | Mon, Jan 30 2006 | Item Help
Time (hh:mm:ss) | 11 : 11 : 00 |
► IDE Primary Master | [ None] |
► IDE Primary Slave | [ None] |
Halt On | [All, But Keyboard] |
Base Memory | 640K |
Extended Memory | 228352K |
Total Memory | 229376K |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Date (mm:dd:yy) Datum

Optionen:

  • mm … Monat

  • dd … Tag

  • yy … Jahr

Time (hh:mm:ss) Uhrzeit

Optionen:

  • hh … Stunden

  • mm … Minuten

  • ss … Sekunden

Halt On

Hier kann das Booten des Systems angehalten werden, wenn Fehler auftreten. Dabei können Fehler ignoriert werden. Diese lassen sich in diesem Menupunkt einstellen.

Optionen:

  • All Errors (bei jeder Art von Fehler anhalten)

  • No Errors (alle Fehler ignorieren und den Systemstart fortsetzen)

  • All , But Keyboard (fehlende Tastatur wird ignoriert)

Base Memory

Hier wird der konventionelle Speicher (0 KByte bis 640 KByte) zur Information, ob er vom POST erkannt wurde, angezeigt.

Extended Memory

Angabe des verfügbaren Speichers vom ersten MB bis zum maximalen Speicherausbau.

Total Memory

Dies ist die Summe aus Base Memory, Extended Memory und Other Memory.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: IDE Primary Master

IDE Primary Master

In diesem Menu werden die Daten der an den ersten IDE-Bus als Master angeschlossenen Festplatte eingestellt. Die Daten der Festplatte, Größe, Anzahl der Cylinder, Köpfe, Sektoren, die Vorkompensation sowie die Parkposition der Köpfe beim Ausschalten der Platte, werden automatisch für die erkannte Festplatte angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

IDE Primary Master

IDE HDD Auto-Detection | [Press Enter] | Item Help
IDE Primary Master | [Auto] |
Access Mode | [Auto] |
Capacity | 0 MB |
Cylinder |  |
Head | 0 |
Precomp | 0 |
Landing Zone | 0 |
Sector | 0 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IDE HDD Auto-Detection:

Hier wird mit dem Drücken der <Enter>-Taste die automatische Erkennung der Festplatte gestartet. Nach einigen Sekunden sollten die physikalischen Daten der angeschlossenen Festplatte im unteren Bereich des Menus angezeigt werden.

IDE Primary Master:

Hier wird die Einstellung für den IDE-Bus durchgeführt. Man hat folgende Optionen:

  • None (für keine Festplatte an diesem Bus-Anschluss angeschlossen)

  • Auto (Beim Booten wird jedes Mal ein Auto-Detecion durchgeführt)

  • Manual (Es wird die Festplatte mit den eingestellten Parametern angesprochen)

Access Mode:

Unter dieser Option können das Betriebssystem für die Festplatte auswählen. Einstellmöglichkeiten: CHS, LBA, LARGE, und Auto. Empfehlenswert ist die Einstellung Auto. Der Normal (Standard) - Modus unterstützt Festplatten bis zu 528MB oder darunter. Dieser Modus verwendet zum Datenzugriff direkt Positionen, die von Cylinders (CYLS), Heads, und Sectors angegeben werden. Der ältere LBA (Logical Block Addressing) Modus kann Festplatten von bis zu 8.4GB unterstützen. Dieser Modus wendet eine andere Methode zur Berechnung der Position von Disk-Daten, auf die zugegriffen werden soll. Er übersetzt Zylinder (Cylinder), Köpfe und Sektoren in eine logische Adresse, an der sich Daten befinden. Große Festplatten unterstützen diesen Modus. Das BIOS unterstützt die INT 13h Erweiterungsfunktion, die es dem LBA-Modus ermöglicht, Festplattenlaufwerke über 8.4GB zu verwalten. Wenn die Anzahl der Zylinder (CYLs) der Festplatte 1024 überschreitet und DOS sie nicht unterstützen kann, oder wenn Ihr Betriebsystem den LBA Modus nicht unterstützt, sollten Sie den Modus LARGE wählen. Hier wird der Zugriffsmodus für die Festplatte eingestellt:

  • CHS

  • LBA

  • LARGE

  • Auto

Die folgenden Parameter werden automatisch ermittelt und angezeigt.

Capacity

Speicherkapazität der Festplatte. Aus den einzelnen Parametern der Festplatte wird dieser Wert errechnet.

Cylinder

Zylinderzahl, Einstellung oder definieren. Sie variiert je nach BIOS-Version und Hersteller zwischen 1.024 und 16.384 Zylindern.

Head

Anzahl der Köpfe einstellen oder zu definieren. Die Anzahl reicht von 1 bis 16 Köpfe.

Precomp

Schreibvorausgleich, für ältere Festplatten nötig. Hier wird der Zylinder angegeben, ab dem mit einem Unterschied in der Informationsdichte zu rechnen ist.

Landing Zone

Hier wird die Landzone, der sogenannte Parkzylinder definiert. An dieser Position setzt der Festplattenkopf auf, wenn der Festplattenmotor abgestellt wird.

Sector

Sektoren pro Spur, Einstellung oder definieren. Bis zu 63, bei Phoenix bis zu 64 Sektoren werden unterstützt.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: IDE Primary Slave

IDE Primary Slave

In diesem Menu werden die Daten der an den ersten IDE-Bus als Master angeschlossenen Festplatte eingestellt. Die Daten der Festplatte, Größe, Anzahl der Cylinder, Köpfe, Sektoren, die Vorkompensation sowie die Parkposition der Köpfe beim Ausschalten der Platte, werden automatisch für die erkannte Festplatte angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

IDE Primary Slave

IDE HDD Auto-Detection | [Press Enter] | Item Help
IDE Primary Slave | [Auto] |
Access Mode | [Auto] |
Capacity | 0 MB |
Cylinder |  |
Head | 0 |
Precomp | 0 |
Landing Zone | 0 |
Sector | 0 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IDE HDD Auto-Detection:

Hier wird mit dem Drücken der <Enter>-Taste die automatische Erkennung der Festplatte gestartet. Nach einigen Sekunden sollten die physikalischen Daten der angeschlossenen Festplatte im unteren Bereich des Menus angezeigt werden.

IDE Primary Master:

Hier wird die Einstellung für den IDE-Bus durchgeführt. Man hat folgende Optionen:

  • None (für keine Festplatte an diesem Bus-Anschluss angeschlossen)

  • Auto (Beim Booten wird jedes Mal ein Auto-Detecion durchgeführt)

  • Manual (Es wird die Festplatte mit den eingestellten Parametern angesprochen)

Access Mode:

Unter dieser Option können das Betriebssystem für die Festplatte auswählen. Einstellmöglichkeiten: CHS, LBA, LARGE, und Auto. Empfehlenswert ist die Einstellung Auto. Der Normal (Standard) - Modus unterstützt Festplatten bis zu 528MB oder darunter. Dieser Modus verwendet zum Datenzugriff direkt Positionen, die von Cylinders (CYLS), Heads, und Sectors angegeben werden. Der ältere LBA (Logical Block Addressing) Modus kann Festplatten von bis zu 8.4GB unterstützen. Dieser Modus wendet eine andere Methode zur Berechnung der Position von Disk-Daten, auf die zugegriffen werden soll. Er übersetzt Zylinder (Cylinder), Köpfe und Sektoren in eine logische Adresse, an der sich Daten befinden. Große Festplatten unterstützen diesen Modus. Das BIOS unterstützt die INT 13h Erweiterungsfunktion, die es dem LBA-Modus ermöglicht, Festplattenlaufwerke über 8.4GB zu verwalten. Wenn die Anzahl der Zylinder (CYLs) der Festplatte 1024 überschreitet und DOS sie nicht unterstützen kann, oder wenn Ihr Betriebsystem den LBA Modus nicht unterstützt, sollten Sie den Modus LARGE wählen. Hier wird der Zugriffsmodus für die Festplatte eingestellt:

  • CHS

  • LBA

  • LARGE

  • Auto

Die folgenden Parameter werden automatisch ermittelt und angezeigt.

Capacity

Speicherkapazität der Festplatte. Aus den einzelnen Parametern der Festplatte wird dieser Wert errechnet.

Cylinder

Zylinderzahl, Einstellung oder definieren. Sie variiert je nach BIOS-Version und Hersteller zwischen 1.024 und 16.384 Zylindern.

Head

Anzahl der Köpfe einstellen oder zu definieren. Die Anzahl reicht von 1 bis 16 Köpfe.

Precomp

Schreibvorausgleich, für ältere Festplatten nötig. Hier wird der Zylinder angegeben, ab dem mit einem Unterschied in der Informationsdichte zu rechnen ist.

Landing Zone

Hier wird die Landzone, der sogenannte Parkzylinder definiert. An dieser Position setzt der Festplattenkopf auf, wenn der Festplattenmotor abgestellt wird.

Sector

Sektoren pro Spur, Einstellung oder definieren. Bis zu 63, bei Phoenix bis zu 64 Sektoren werden unterstützt.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: Advanved BIOS Features

Advanved BIOS Features

In diesem Menu werden die Daten der an den ersten IDE-Bus als Master angeschlossenen Festplatte eingestellt. Die Daten der Festplatte, Größe, Anzahl der Cylinder, Köpfe, Sektoren, die Vorkompensation sowie die Parkposition der Köpfe beim Ausschalten der Platte, werden automatisch für die erkannte Festplatte angezeigt.

Phoenix – AwardBIOS CMOS Setup Utility

Advanced BIOS Features

CPU Internal Cache | [Enabled] | Item Help
First Boot Device | [HDD-0] |
Second Boot Device | [USB-HDD] |
Third Boot Device | [Disabled] |
Boot Other Device | [Enabled] |
Boot Up NumLock Status | [On] |
Gate A20 Option | [Fast] |
Typematic Rate Setting | [Disabled] |
Typematic Rate (Chars/Sec) | 6 |
Typmatic Delay (Msec) | 250 |
Security Option | [Setup] |
OS Select For DRAM > 64 MB | [Non-OS2] |
Full Screen Logo | [Disabled] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

CPU Internal Cache

Unter diesem Menupunkt kann der interne Cache der CPU abgeschaltet werden.

First Boot Device

Hier legen Sie fest welches Laufwerk als erstes gebootet werden soll. Stellen Sie das Laufwerk erstes ein, welches als Bootlaufwerk dienen soll. Optionen:

  • LS120 (LS-Drive)

  • HDD-0 (Festplatte 1)

  • CDROM (CD-Laufwerk)

  • HDD-1 (Festplatte 2)

  • ZIP100 (Zip-Drive)

  • USB-FDD (USB-Floppy)

  • USB-ZIP (USB Zip-Drive)

  • USB-CDROM (USB CDROM)

  • USB-HDD (USB-Festplatte)

  • LAN (Netzwerk)

  • Disabled (abgeschaltet)

Second Boot Device

Kann von dem ersten Bootmedium nicht gebootet werden, so wird diese Einstellung zum Booten verwendet. Stellen Sie das Laufwerk erstes ein, welches als Bootlaufwerk dienen soll. Optionen:

  • LS120 (LS-Drive)

  • HDD-0 (Festplatte 1)

  • CDROM (CD-Laufwerk)

  • HDD-1 (Festplatte 2)

  • ZIP100 (Zip-Drive)

  • USB-FDD (USB-Floppy)

  • USB-ZIP (USB Zip-Drive)

  • USB-CDROM (USB CDROM)

  • USB-HDD (USB-Festplatte)

  • LAN (Netzwerk)

  • Disabled (abgeschaltet)

Third Boot Device

Kann von den ersten beiden Bootmedium nicht gebootet werden, so wird diese Einstellung zum Booten verwendet. Stellen Sie das Laufwerk erstes ein, welches als Bootlaufwerk dienen soll. Optionen:

  • LS120 (LS-Drive)

  • HDD-0 (Festplatte 1)

  • CDROM (CD-Laufwerk)

  • HDD-1 (Festplatte 2)

  • ZIP100 (Zip-Drive)

  • USB-FDD (USB-Floppy)

  • USB-ZIP (USB Zip-Drive)

  • USB-CDROM (USB CDROM)

  • USB-HDD (USB-Festplatte)

  • LAN (Netzwerk)

  • Disabled (abgeschaltet)

Boot Other Device

Unter dieser Optionen stehen Ihnen zwei Möglichkeiten zur Verfügung: Enabled oder Disabled. Die Standardeinstellung ist Enabled. Die Einstellung Enabled ermöglicht es dem BIOS alle drei Arten, nämlich "First Boot Device", "Second Boot Device" oder "Third Boot Device" auszuprobieren.

Boot Up NumLock Status

Zustand der Zehnertastatur. Bei On ist sie aktiviert und bei Off nicht.

Gate A20 Option

Legt die Art fest, mit der auf den Speicher oberhalb 1MB zugegriffen wird.. Hier sollte Fast stehen, damit der Zugriff durch den Chipsatz aktiviert wird. Bei der Einstellung Normal erfolgt er über den Tastaturcontroller. Auf älteren Rechnern kann diese Option Geschwindigkeit bringen. Der erste 64-K-Block oberhalb von 1 MB kann durch die Adressleitung A20 noch im Standard-Mode adressiert werden. DOS verankert sich dort, wenn Sie DOS=High in die Config.sys eingefügt haben

Typematic Rate Setting

Hier wird festgelegt, ob Sie die Optionen Keyboard Typematic Speed, Delay Before Keys Repeat, Typematic Rate oder Typematic Delay , benutzen können Bei Disabled werden die Werte auf 6 Zeichen pro Sekunde und Tastverzögerung von 250 MSec eingestellt. Die Einstellungen können aber auch im Betriebssystem vorgenommen werden.

Typematic Rate (Chars/Sec)

Festlegung der Wiederholfrequenz der Tastatur bei gedrückter Taste. Es können 6, 8, 10, 12, 15, 20, 24 oder 30 Zeichen/Sekunde ausgewählt werden.

Typmatic Delay (Msec)

Hier wird der Wert eingestellt, wann die Tastenfunktion nach dem Drücken einsetzt. Es können 250, 500, 750 oder 1000 Millisekunden ausgewählt werden.

Security Option

Hier wird die Option festgelegt, für die ein Passwort gilt. Wählen Sie die Option SYSTEM, dann muss beim Hochfahren des PC ein Passwort eingegeben werden. Wählen Sie dagegen die Option SETUP, dann braucht man nur ein Passwort um ins BIOS Setup zu gelangen.

OS Select For DRAM > 64 MB

Wer mit OS/2 arbeitet und mehr als 64 MB RAM hat, sollte die Option auf OS/2 stellen.

Full Screen Logo

Mit dieser Option können Sie einstellen, ob beim Booten das Startlogo den ganzen Bildschirm füllt und damit die Startdaten verdeckt. Einstellmöglichkeiten: Enabled, Disabled


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: Advanced Chiset Features

Advanced Chiset Features

In diesem Menu können Einstellungen zu den Funktionen des Speichers gemacht werden. Dabei sollte vorsichtig vorgegangen werden, da Einstellungen hier die Stabilität des Gesamtsystems beinträchtigen können.

Phoenix – AwardBIOS CMOS Setup Utility

Advanced Chipset Features

 | CPU Frequency | [AUTO] | Item Help
X | Memory Frequency | 100 MHz |
 | CAS Latency | [AUTO] |
 | Interleave Select | [LOI] |
 | Video Memory Size | [16 M] |
 | Output Display | [Panel & CRT] |
 | Flat Panel Configuration | [Press Enter] |
 |  | [Enabled] |
 | Onboard Audio | [Enabled] |
 | Onboard USB2.0 | [Enabled] |
 | Onboard IDE | [Enabled] |
 | Overcurent reporting | [Enabled] |
 | Port 4 assignment | [Not used] |
 | Memory Hole At 15M-16M | [Disabled] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

CPU Frequency

Unter dieser Option wird die Frequenz die der Taktgenerator an den Systembus und den PCI-Bus sendet angezeigt. Es erfolgt die automatische Ermittlung durch das BIOS. Mit der + und - Taste oder den Nummerntasten können Sie gewünschte Werte verändern/eintragen. Es sind Werte von 100-500 möglich

Memory Frequency

Sie können hier die Arbeitsspeicherfrequenz einstellen. Ist die CPU Frequenz auf AUTO gesetzt, so sind hier keine Einstellungen möglich.

CAS Latency

Wenn synchrones DRAM installiert ist, hängt die Menge der Taktzyklen bei der CAS Wartezeit vom DRAM Timing ab. Die Einstellmöglichkeiten sind 2 oder 3 Taktzyklen. Ein CL3-Speichermodul kann mit einer CAS Latency von 2 betrieben werden (allerdings nicht alle Modelle, Sie müssen es ausprobieren.). Aber Vorsicht, wenn das Bios die Daten des EEPROMs falsch ausliest, dann ist es möglich das ein CL2-Speichermodul im CL3-Modus betrieben wird (Performaneceverlust > 5%). Mögliche Werte sind Auto*, 1.5, 2.0, 2.5, 3.0 und 3.5.

Interleave Select

LOI / HOI

Video Memory Size

Disable / 8 M / 16 M (*)

Output Display

Flat Panel / TV Output / CRT / Panel & CRT

Flat Panel Configuration

Hier kann ein Menu zur Einstellung der Panelparameter aufgerufen werden.

Onboard Audio

Über diese Einstellung kann die Audioschnittstelle abgeschaltet werden.

Onboard USB 2.0

Über diese Einstellung kann die USB-Schnittstelle (Modus 1.1) abgeschaltet werden.

Onboard IDE

Über diese Einstellung kann die IDE-Schnittstelle abgeschaltet werden.

Overcurent reporting

Über diese Einstellung kann eine Warnmeldung über die Stromversorgung ein bzw. ausgeschaltet werden.

Port 4 assignment

Host / Device / Not Used

Memory Hole AT 15M - 16M

Um Speicheradresskonflikte zwischen dem System und den Erweiterungskarten zu verhindern, reservieren Sie unter dieser Option den Speicherbereich entweder für das System oder eine Erweiterungskarte.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: Integrated Peripherals

Integrated Peripherals

In diesem Menu werden die Einstellungen für die Systemschnittstellen vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

Integrated Peripherals

Master Drive PIO Mode | [Auto] | Item Help
Slave Drive PIO Mode | [Auto] |
IDE Primary Master UDMA | [Auto] |
IDE Primary Slave UDMA | [Auto] |
IDE DMA transfer access | [Enabled] |
IDE HDD Block Mode | [Enabled] |
Onboard Serial Port 1 | [3E8/IRQ11] |
Onboard Serial Port 2 | [2E8/IRQ10] |
UART Mode Select | [Normal] |
RxD , DxD Active | Hi, Lo |
IR Transmission Delay | Enabled |
UR2 Duplex Mode | Half |
Use IR Pins | IR-Rx2Tx2 |
Watch Dog Timer Select | [Disabled] |
Onboard Serial Port 3 | [3E8/IRQ11] |
Onboard Serial Port 4 | [2E8/IRQ10] |
GPIO 4-5-6-7 | 1-1-1-1 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Master PIO Mode

PIO (Programmed Input/Output) steht für das Konzept der programmierten Ein- und Ausgabe. Statt dass eine Befehlsfolge vom BIOS ausgegeben wird, um eine Datenübertragung von der oder auf die Festplatte zu bewirken, gestattet PIO dem BIOS, dem Controller mitzuteilen, welche Aufgabe ausgeführt werden soll, und überlässt die Ausführung der Aufgabe dann vollständig dem Controller und der CPU. Ihr System unterstützt fünf PIO-Modi, 0 (Standard) bis 4, die sich im Wesentlichen in ihrer Zeitsteuerung unterscheiden. Wenn Sie die Einstellung "Auto" (Automatisch) auswählen, legt das BIOS nach einer Überprüfung Ihres Laufwerks den bestmöglichen PIO-Modus selbst fest. Auto: Das BIOS stellt den Wert für das System je nach Timing Ihres Festplattenlaufwerks automatisch ein. Mode 0-4: Sie können selbst einen Modus auswählen, der sich für das Timing Ihres Festplattenlaufwerks eignet.

Slave PIO Mode

PIO (Programmed Input/Output) steht für das Konzept der programmierten Ein- und Ausgabe. Statt dass eine Befehlsfolge vom BIOS ausgegeben wird, um eine Datenübertragung von der oder auf die Festplatte zu bewirken, gestattet PIO dem BIOS, dem Controller mitzuteilen, welche Aufgabe ausgeführt werden soll, und überlässt die Ausführung der Aufgabe dann vollständig dem Controller und der CPU. Ihr System unterstützt fünf PIO-Modi, 0 (Standard) bis 4, die sich im Wesentlichen in ihrer Zeitsteuerung unterscheiden. Wenn Sie die Einstellung "Auto" (Automatisch) auswählen, legt das BIOS nach einer Überprüfung Ihres Laufwerks den bestmöglichen PIO-Modus selbst fest. Auto: Das BIOS stellt den Wert für das System je nach Timing Ihres Festplattenlaufwerks automatisch ein. Mode 0-4: Sie können selbst einen Modus auswählen, der sich für das Timing Ihres Festplattenlaufwerks eignet.

IDEPrimary Master UDMA

Unter dieser Option nehmen Sie die Einstellungen für den Ultra-DMA/33 Modus Ihrer Festplatte vor. Einstellmöglichkeiten: Auto, Enabled, Disabled. Sie sollten diese Option auf Enabled stellen.

IDE Primary Slave UDMA

Unter dieser Option nehmen Sie die Einstellungen für den Ultra-DMA/33 Modus Ihrer Festplatte vor. Einstellmöglichkeiten: Auto, Enabled, Disabled. Sie sollten diese Option auf Enabled stellen.

IDE DMA Transfer access

Diese Option wird benutzt, um die DMA-Übertragungsfunktion der IDE-Festplatte zu aktivieren oder zu deaktivieren. Die Einstellungen sind: Enabled, Disabled.

IDE HDD Block Mode

Mit dieser Option wird der Block-Mode von IDE-Festplatten aktiviert. Falls Ihr LW diesen Modus unterstützt, wird bei Aktivierung dieser Option die Zahl der Blöcke pro Anforderung aus dem Konfigurationssektor der Festplatte ausgelesen. Empfohlene Einstellung ist Enabled, wobei darauf hingewiesen werden muss, dass nur alte Festplatten diesen Modus nicht vertragen.

Onboard Serial Port 1

Konfiguration der seriellen Schnittstelle Einstellungen: IRQ (wird verwendet für den ersten seriellen Anschluss), Disabled (es wird kein Interrupt verwendet). Einstellmöglichkeiten: Auto, 3F8/IRQ4, 2F8/IRQ3, 3E8/IRQ4 oder 2E8/IRQ3 .

Onboard Serial Port 2

Konfiguration der seriellen Schnittstelle Einstellungen: IRQ10 (wird verwendet für den zweiten seriellen Anschluss), Disabled (es wird kein Interrupt verwendet). Einstellmöglichkeiten: Auto, 3F8/IRQ4, 2F8/IRQ3, 3E8/IRQ4 oder 2E8/IRQ3.

UART Mode Select

Modus für den Treiber der seriellen Schnittstelle. Einstellmöglichkeiten:

  • Normal für RS-232 serielle Schnittstelle
  • ASKIR für Amplitude keyed shift Schnittstelle für IR-Geräte
  • IrDA für IrDA-Schnittstelle

RxD, TxD Active

Einstellungen können nicht im Standardmodus gemacht werden. Unter dieser Option wird die IR Transmission/Reception als High oder Low eingestellt.

IR Transmission Delay

Haben Sie diese Option aktiviert, so verzögert sich die Übertragung. Einstellmöglichkeiten: Enabled, Disabled.

UR2 Duplex Mode

Diese Option dient der Einstellung für Infrarotgeräte. Einstellmöglichkeiten: Full und Half. Prüfen Sie im IR- Gerätehandbuch nach, welche Einstellung des Duplex-Modus verlangt wird.

Use IR Pins

Diese Option ist identisch mit der Option TxD, RxD Active. Die notwendigen Informationen finden Sie in den Unterlagen zu Ihrem IR-Gerät.

Watch Dog Timer Select

Hier kann der Timer für den Watchdog eingestellt werden: Disabled, 10 Sec, 20 Sec, 30 Sec, 40 Sec, 1 Min, 2 Min,4 Min)

Onboard Serial Port 3

Konfiguration der seriellen Schnittstelle Einstellungen: IRQ11 (wird verwendet für den dritten seriellen Anschluss), Disabled (es wird kein Interrupt verwendet). Einstellmöglichkeiten: Auto, 3F8/IRQ11, 2F8/IRQ11, 3E8/IRQ11 oder 2E8/IRQ11 .

Onboard Serial Port 4

Konfiguration der seriellen Schnittstelle Einstellungen: IRQ10 (wird verwendet für den vierten seriellen Anschluss), Disabled (es wird kein Interrupt verwendet). Einstellmöglichkeiten: Auto, 3F8/IRQ10, 2F8/IRQ10, 3E8/IRQ10 oder 2E8/IRQ10.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: Power Management Setup

Power Management Setup

In diesem Menu können Einstellungen zum Energieverbrauch des Systems gemacht werden.

Phoenix – AwardBIOS CMOS Setup Utility

Power Management Setup

ACPI Suspend Type | [S1(POS)] | Item Help
Power Management | [Disabled] |
** PM Timers ** |  |
Standby Mode | Disabled |
Suspend Mode | Disabled |
HDD Power Down | [Disabled] |
Modem Use IRQ | [N/A] |
Soft-Off by PWR-BTTN | [Instant-Off] |
Power-On by Alarm | [Disabled] |
Time (hh:mm:ss) Alarm | 0 |
 | 0 |
 | 0 |
IRQ Wake Events | [Press Enter] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

ACPI Suspend Type

Unter dieser Option stehen ihnen zwei Einstellungen zur Verfügung: S1 (POS) und S3 (STR). ACPI hat normalerweise sechs Zustände: System S0, S2, S3, S4, S5. Mehr Infos finden Sie unter BIOS-Inside / ACPI-Funktionen.

S1 (POS) Power on Suspend: Der Schlafzustand S1 entspricht einem Schlafzustand mit niedriger Reaktivierungslatenz. In diesem Zustand geht kein Systemkontext (CPU oder Chipsatz) verloren, und die Hardware hält den gesamten Systemkontext aufrecht und steht bei Bedarf sofort zur Verfügung.

S3 (STR) Suspend to RAM: Der Zustand S3 ist ein Schlafzustand mit niedriger Reaktivierungslatenz, bei dem der gesamte Systemkontext mit Ausnahme des Systemspeicherkontextes verloren geht. CPU-, Cache und Chipsatzkontext geht in diesem Zustand verloren. Die Hardware hält den Speicherkontext aufrecht und stellt bestimmte Teile des CPU- und L2-Konfigurationskontextes wieder her.

Power Management

Einstellungen: Disabled (es wird keine Energiesparfunktion benutzt), Legacy, APM, ACPI.

HDD Power Down

Diese Einstellung regelt die Zeit, nach der eine Festplatte ohne Zugriffe abgeschaltet wird. Die Standardeinstellung ist "Disabled". (Disabled, 1 / 5 / 10/ 15 30 / 45 Sec. / 1 Min )

Modem Use IRQ

Hier lässt sich die Interrupt-Leitung (IRQ) eines eventuell vorhanden Modems angeben. Durch Aktivitäten auf dieser Leitung, wird der Rechner dann z.B. für den Faxempfang geweckt. Einstellmöglichkeiten: NA (keine Zuweisung),3 (zugewiesen), 4, 5, 7, 9, 10, 11

Soft-Off by PWR-BTTN

Hier regeln Sie wie der Power-Knopf reagiert: Delay 4 sec.: Sie müssen den Knopf länger als 4 Sekunden gedrückt halten damit der PC ausgeschaltet wird. Instant-Off: der PC wird sofort ausgeschaltet.

Power On by Alarm

Hier können bis zu drei Timer gesetzt werden, an denen sich das System einschaltet.

IRQ Wake Events

Hier wird ein Menu geöffnet, in dem der Anwender Ereignisse auswählen kann, mit denen das System wieder aufgeweckt werden kann.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: IIRQ Wakeup Events

IRQ Wakeup Events

In diesem Menu werde die Interrupts eingestellt, bei denen das System aus dem Suspend Mode wieder "aufwachen" soll.

Phoenix – AwardBIOS CMOS Setup Utility

IRQ Wakeup Events

IRQ1 (Keyboard) | [OFF] | Item Help
IRQ3 (COM 2) | [OFF] |
IRQ4 (COM 1) | [OFF] |
IRQ5 (LPT 2) | [OFF] |
IRQ6 (Floppy Disk) | [OFF] |
IRQ7 (LPT 1) | [OFF] |
IRQ8 (RTC Alarm) | [OFF] |
IRQ9 (IRQ2 Redir) | [OFF] |
IRQ10 (Reserved) | [OFF] |
IRQ11 (Reserved) | [OFF] |
IRQ12 (PS/2 Mouse) | [OFF] |
IRQ13 (Coprocessor) | [OFF] |
IRQ14 (Hard Disk) | [OFF] |
IRQ15 (Reserved) | [OFF] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IRQ1 (Keyboard)

[ON /OFF]

IRQ3 (COM 2)

[ON /OFF]

IRQ4 (COM 1)

[ON /OFF]

IRQ5 (LPT 2)

[ON /OFF]

IRQ6 (Floppy Disk)

[ON /OFF]

IRQ7 (LPT 1)

[ON /OFF]

IRQ8 (RTC Alarm)

[ON /OFF]

IRQ9 (IRQ2 Redir)

[ON /OFF]

IRQ10 (Reserved)

[ON /OFF]

IRQ11 (Reserved)

[ON /OFF]

IRQ12 (PS/2 Mouse)

[ON /OFF]

IRQ13 (Coprocessor)

[ON /OFF]

IRQ14 (Hard Disk)

[ON /OFF]

IRQ15 (Reserved)

[ON /OFF]


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: PnP/PCI Configurations

PnP/PCI Configurations

In diesem Menu werden die Einstellungen für den PCI-Bus und das Plug and Play Management vorgenommen.

Phoenix – AwardBIOS CMOS Setup Utility

PnP/PCI Configurations

PNP OS Installed | [Yes] | Item Help
Init Display First | [Onboard] |
Reset Configuartion Data | [Enabled] |
Resources Controlled By | [Manual] |
► IRQ Resources | [Press Enter] |
► DMA Resources | [Press Enter] |
► Memory Resources | [Press Enter] |
PCI/VGA Palette Snoop | [Disabled] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Reset Configuartion Data

Diese Option sorgt dafür, wenn sie eingeschaltet wird, dass das BIOS die Informationen eingebauter Komponenten und deren Ressourcen löscht (Rücksetzung aller Einstellungen) und wieder neu konfiguriert. Einstellmöglichkeiten: Enabled, Disabled.

Resources Controlled By

Legt fest, ob die PnP-Einstellungen per Setup oder automatisch zugewiesen werden. Falls es keine Probleme mit IRQ oder DMA Zuweisungen gibt, sollten Sie Auto einstellen.

IRQ Resources

Wenn Sie diese Ressourcen von Hand einstellen, weisen Sie jedem Systeminterrupt einen Typ zu, abhängig vom Typ des Geräts, das den Interrupt verwendet.

DMA Resources

Wenn Sie diese Ressourcen von Hand einstellen, weisen Sie jedem DMA (0 bis 7) den entsprechenden BUS (PCI/ISA PnP or Legacy ISA) zu.

Memory Resources

Wenn für den Betrieb vom Betriebsystem Speicherbereiche geschützt werden sollen, so kann hier ein Bereich eingestellt werden.

PCI/VGA Palette Snoop

Wird von Multimedia-Videokarten verwendet. Je nach Karte muss diese Funktion eingeschaltet (Enabled) werden. Standardmässig ist sie abgeschaltet.

Init Display First

Unter dieser Option können Sie einstellen welche Grafikkarte zuerst initialisiert werden soll. Entweder die vom PCI-Slot oder die AGP Karte. Einstellmöglichkeiten hier "First PCI" oder "OnboardAGP".


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: IRQ Resources

IRQ Resources

In diesem Menu können Interrupts für die freie Zuweisung an die PCI-Slots gesperrt werden.

Phoenix – AwardBIOS CMOS Setup Utility

IRQ Resources

IRQ-7 assigned to | [PCI Device] | Item Help
IRQ-12 assigned to | [PCI Device] |
IRQ-15 assigned to | [PCI Device] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

IRQ-n assigned to ( n = {3,4,5,7,9,10,11,12,14,15} )

Hier kann ein Interrupt für freie Vergabe gesperrt (reserved) werden. Mit der Einstellung [PCI Device] wird der Interrupt dynamisch vergeben.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: DMA Resources

DMA Resources

In diesem Menu können die einzelnen DMA Kanäle (0, 1, 3, 5, 6 und 7) auf die beiden Bussysteme (PCI/ISA PnP oder ISA) zugewiesen werden.

Phoenix – AwardBIOS CMOS Setup Utility

DMA Resources

DMA-0 assigned to | [PCI/ISA PnP] | Item Help
DMA-1 assigned to | [PCI/ISA PnP] |
DMA-3 assigned to | [PCI/ISA PnP] | Menu Level >
DMA-5 assigned to | [PCI/ISA PnP] |
DMA-6 assigned to | [PCI/ISA PnP] | Legacy ISA for devices
DMA-7 assigned to | [PCI/ISA PnP] | compliant with the
 |  | original PC AT bus
 |  | specification, PCI/ISA
 |  | PnP for devices
 |  | compliant with the
 |  | Plug and Play standard
 |  | whether designed fot
 |  | PCI or ISA bus
 |  | architecture

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

DMA-n assigned to ( n = {0,1,3,5,6,7} )

Hier wird der Bus für den DMA Kanal eingestellt (PCI/ISA PnP oder ISA Legacy).


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: Memory Resources

Memory Resources

In diesem Menu kann ein Speicherbereich für Peripherie festgelegt werden. Der Bereich wird durch Basisadresse und Länge genau spezifiziert.

Phoenix – AwardBIOS CMOS Setup Utility

Memory Resources

Reserved Base | [D000] | Item Help
Reserved Memory Length | [64K] |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Reserved Base

Startadresse des reservierten Bereichs. Als Adressen können N/A (nicht verfügbar), D000, D400, D800 und DC00 gewählt werden.

Reserved Memory Length

Größe des Speicherbereichs in KByte. 8K, 16K, 32K und 64K können eingestellt werden.


CX1010: BIOS-Einstellungen

BECKHOFF CX1010: BIOS Setup: PC Health Status

PC Health Status

In diesem Menu werden die Einstellungen für die Temperaturen von CPU und Mainboard sowie Spannungsversorgung und Lüfterdrehzahlen angezeigt..

Phoenix – AwardBIOS CMOS Setup Utility

PC Health Status

Shutdown Temperature | [Disabled] | Item Help
Temp. CPU | 70°C |
Temp. Board | 59°C |
VCORE | 1.21V |
VCORESB | 1.24V |
+12 V | 12.75V |
VCCMEM | 2.57V |
VIO | 3.39V |
+5 V | 5.29V |
Fan1 Speed | 0 |

 ↑ ↓ → ← :Move Enter:Select +/-/PU/PD:Value F10:Save ESC:Exit F1:Help

F5: Previous Values F6: Fail-Safe Defaults F7: Optimized Defaults

Shutdown Temperature

Temperatur bei der das System sich selbst abschaltet. (60°C / 140°F, 65°C / 149°F, 70°C / 158°F, Disabled)

Temp. CPU

Temperatur der CPU. Die maximal zulässige Betriebstemperatur ist 85°C. Ab dieser Temperatur sollte eine Warnung ausgegeben werden. Bei 95°C sollte das System abgeschaltet werden. Die genaue Lage der Sensoren ist in dem unteren Schaubild dargestellt.

Temp. Board

Temperatursensor 1 auf der CF-Platine (CX1021) des CX1010. Die maximal zulässige Betriebstemperatur ist 80°C. Ab dieser Temperatur sollte eine Warnung ausgegeben werden. Bei 85°C sollte das System abgeschaltet werden. Die genaue Lage der Sensoren ist in dem unteren Schaubild dargestellt.

VCORE

Betriebsspannung des Prozessorkerns.

VCORSB

Standbyspannung des Prozessorkerns.

+12 V

Spannungsversorgung 12 Volt.

VCCMEM

Spannungsversorgung des Speichers.

VIO

Spannungsversorgung der Ausgänge.

+5 V

Spannungsversorgung 5 Volt.

Fan1 Speed

Umdrehungen Lüfter 1 (ist hier 0 da keine Lüfter vorhanden)


LEDs CPU-Grundmodul

Anzeige | LED | Bedeutung
 | PWR | Spannungsversorgung Die Power LED leuchtet bei Anschluss an ein Netzteil mit eingeschalteter Spannungsversorgung (grün) auf.
 | LAN L/A | LAN L/A (LINK/ ACTIVITY), leuchtet grün bei angeschlossenem Netzwerk, blinkt bei Aktivität auf dem Netzwerk
 | 100 MBit | Bei Netzwerkverbindung mit einer Geschwindigkeit von100 MBit leuchtet die LED grün.
 | TC | TwinCAT Status LED TwinCAT ist im Run-Modus (grün) TwinCAT ist im Stop-Modus (rot) TwinCAT ist im Konfig-Modus (blau)
 | HDD | Read/Write Compact Flash (rot) Zeigt einen Zugriff auf die CF Karte an.


LEDs Netzteil CX1100-0001

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.


LEDs Netzteil CX1100-0002

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX1020 Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.


LEDs Netzteil CX1100-0002

BECKHOFF CX1100-00xx: Fehlerbehandlung und Diagnose

LEDs Netzteil CX1100-0012

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX1020 Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.


LEDs Netzteil CX1100-0003

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung. Da das Netzteil über zwei verschiedene Klemmen-Bussysteme verfügt, werden mögliche Fehler der beiden Busse über die LEDs angezeigt. Ein Fehler auf dem K-Bus wird durch schnelles Blinken eingeleitet. Ein langes Leuchten (ca. 2 Sekunden) signalisiert Fehlercodes für Fehler auf dem IP-Link Bus.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus / IP-Link Die grüne LED leuchtet / blinkt schnell, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystemen fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus / Dignose IP-Link Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

LEDs zur K-Bus-Diagnose

Nach einer schnellen Blinkfolge liegt ein K-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX-Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.

LEDs zur IP-Link-Bus-Diagnose

Nach einem langen Leuchten (ca. 2 Sekunden) liegt ein IP-Link-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

I/O Err |  |  | Beschreibung | Abhilfe
aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
2 |  |  | reserviert | -
3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich

Hinweis |
 | Liegt auf beiden Bussystemen (K-Bus und IP-Link-Bus) ein Fehler vor wird zuerst der Fehler auf dem K-Bus und dann der Fehler auf dem IP-Link-Bus angezeigt. Die jeweiligen Fehlercodes werden wie oben beschrieben mit schnellem Blinken oder langem Aufleuchten eingeleitet.


LEDs Netzteil CX1100-0003

BECKHOFF CX1100-00xx: Fehlerbehandlung und Diagnose

LEDs Netzteil CX1100-0013

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung. Da das Netzteil über zwei verschiedene Klemmen-Bussysteme verfügt, werden mögliche Fehler der beiden Busse über die LEDs angezeigt. Ein Fehler auf dem K-Bus wird durch schnelles Blinken eingeleitet. Ein langes Leuchten (ca. 2 Sekunden) signalisiert Fehlercodes für Fehler auf dem IP-Link Bus.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus / IP-Link Die grüne LED leuchtet / blinkt schnell, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystemen fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus / Dignose IP-Link Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

LEDs zur K-Bus-Diagnose

Nach einer schnellen Blinkfolge liegt ein K-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX-Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden. Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.

LEDs zur IP-Link-Bus-Diagnose

Nach einem langen Leuchten (ca. 2 Sekunden) liegt ein IP-Link-Busfehler vor. Die folgenden Tabellen beschreiben den Fehler und ermöglichen eine Diagnose. IP-Link-Fehler sind meist durch unsachgemäßen Gebrauch der Lichtwellenleitung zurück zu führen.

I/O Err |  |  | Beschreibung | Abhilfe
aus |  |  | kein Datenaustausch | Modul im synchron Mode - zyklische Daten aktivieren
1 | 0 |  | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
2 |  |  | reserviert | -
3 | n |  | Bruchstelle wurde erkannt | n-tes Modul vor dem Empfänger des Masters
3 | n | m | Bruchstelle wurde erkannt | (n*10)+m-tes Modul vor dem Empfänger des Masters
4 | n |  | zu viele fehlerhafte Telegramme erkannt (mehr als 25%) | vor dem n-ten Erweiterungsmodul (vor dem Empfänger des Masters) ist die LWL-Verkabelung zu prüfen
5 | n |  | Registerzugriff auf komplexe Module gescheitert | n-tes Modul überprüfen
11 | n |  | Komplexes Modul arbeitet fehlerhaft | n-tes Modul tauschen
12 | n |  | mehr als 120 Module im Ring | weniger Module anschließen
13 | n |  | n-tes Modul unbekannt | Firmware Update erforderlich

Hinweis |
 | Liegt auf beiden Bussystemen (K-Bus und IP-Link-Bus) ein Fehler vor wird zuerst der Fehler auf dem K-Bus und dann der Fehler auf dem IP-Link-Bus angezeigt. Die jeweiligen Fehlercodes werden wie oben beschrieben mit schnellem Blinken oder langem Aufleuchten eingeleitet.


LEDs Netzteil CX1100-0004

Anzeige | LED |  | Bedeutung
 | PWR |  | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | L/A | aus | E-Bus nicht angeschlossen
 |  | an | E-Bus angeschlossen / Kein Datenverkehr
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.
 | RUN |  | Beschreibt den Zustand des EtherCAT Busses:
 |  | aus | INIT
 |  | blinkt | PRE-OPERATIONAL (Frequenz: 200 ms an / 200 ms aus)
 |  | einzelnes Blinken | SAVE-OPERATIONAL (Frequenz: 200 ms an / 1000ms aus)
 |  | an | OPERATIONAL
 |  | schnelles Blinken | BOOTSTRAP (Frequenz: 50 ms an / 50 ms aus)
 |  | doppeltes Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | dreifaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | vierfaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)

Die Funktionen für L/A und RUN LED sind erst ab Hardwarestand 2.0 verfügbar. In älteren Versionen sind die LEDs ohne Funktion.


LEDs Netzteil CX1100-0004

BECKHOFF CX1100-00xx: Fehlerbehandlung und Diagnose

LEDs Netzteil CX1100-0014

Anzeige | LED |  | Bedeutung
 | PWR |  | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | L/A | aus | E-Bus nicht angeschlossen
 |  | an | E-Bus angeschlossen / Kein Datenverkehr
 |  | blinkt | E-Bus angeschlossen / Datenverkehr auf dem E-Bus.
 | RUN |  | Beschreibt den Zustand des EtherCAT Busses:
 |  | aus | INIT
 |  | blinkt | PRE-OPERATIONAL (Frequenz: 200 ms an / 200 ms aus)
 |  | einzelnes Blinken | SAVE-OPERATIONAL (Frequenz: 200 ms an / 1000ms aus)
 |  | an | OPERATIONAL
 |  | schnelles Blinken | BOOTSTRAP (Frequenz: 50 ms an / 50 ms aus)
 |  | doppeltes Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | dreifaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)
 |  | vierfaches Blinken | reserviert für spätere Verwendung (Frequenz: 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 200 ms aus / 200 ms an / 1000 ms aus)

Die Funktionen für L/A und RUN LED sind erst ab Hardwarestand 2.0 verfügbar. In älteren Versionen sind die LEDs ohne Funktion.


Störungen

Lesen Sie dazu auch das Kapitel Sicherheitshinweise.

Mögliche Störungen und ihre Beseitigung

Bitte geben Sie im Servicefall die Projektnummer Ihres PCs an, welche Sie dem Typenschild entnehmen können.

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Störung | Ursache | Maßnahmen
keine Funktion nach Starten des Embedded-PCs | fehlende Stromversorgung des Embedded-PCs andere Ursachen | 1.Sicherung prüfen 2. Anschlussspannung messen, Steckerbelegung prüfen Beckhoff Support anrufen
Der Embedded-PC bootet nicht vollständig | Festplatte beschädigt (z.B. durch Abschalten bei laufender Software), Setupeinstellungen fehlerhaft, andere Ursachen | Setupeinstellungen prüfen Beckhoff Support anrufen
Rechner bootet, Software wird gestartet, aber Steuerung arbeitet nicht einwandfrei | Fehlerursache liegt bei der Software oder bei Anlagenteilen außerhalb des Embedded-PCs | Rufen Sie den Maschinen- oder Softwarehersteller an.
Fehler bei CF Card Zugriff | Fehlerhafte CF Card, fehlerhafter CF Einschub | Mit einer anderen CF Card den CF Einschub überprüfen Beckhoff Support anrufen
Embedded-PC funktioniert nur teilweise oder nur zeitweise | Komponenten im Embedded-PC defekt | Beckhoff Support anrufen


Abbau und Entsorgung

Der Abbau einer CX10x0-Hardwarekonfiguration erfolgt in 2 Schritten:

0. Abschalten und Entfernen der Stromversorgung

Bevor der Abbau eines CX10x0-System erfolgen kann, sollte das System abgeschaltet sein und die Stromversorgung entfernt werden.

1. Demontage von der Hutschiene:

Vor der Trennung der einzelner CX10x0 Module muss der gesamte CX1010-Hardwareblock zunächst von der Hutschiene abmontiert werden. Dazu geht man folgendermaßen vor:

1.1. Lösen und Entfernen der ersten Klemme neben der Stromversorgung auf der Hutschiene.

Zuerst entfernt man alle eventuell vorhandene Verkabelung der Stormversorgung und der ersten Klemme auf der Hutschiene neben der Stromversorgung. Soll die Verkabelung später mit einem anderen System wieder hergestellt werden, so empfiehlt es sich die Beschaltung zu notieren. Dann zieht man an der orangefarbenen Klemmenentriegelung (siehe Pfeil), löst damit die Klemme und zieht sie nach vorne heraus.

1.2. Entriegeln des CX10x0 - Systems

Um den CX10x0-Block zu lösen, werden die weißen Laschen an der Unterseite der Modul in Pfeilrichtung gezogen. Sie arretieren dann in der ausgezogenen Position. Nach dem Ziehen an der Klemmenentriegelung der Stromversorgung lässt sich der Block vorsichtig von der Hutschiene nehmen.

2. Trennung der einzelnen Module

2.1. Trennen von Stromversorgung und CX10x0-CPU sowie weiterer Komponenten

Man setzt den CX10x0-Block mit der Vorderseite auf eine geeignete Unterlage. Dann wird ein Schlitzschraubendreher der Größe 1,0 x 5,5 x 150 mm in den Verriegelungsmechanismus einführt und mit einer etwa 90 Grad Drehung der Schieber betätigt. Der rückseitige Verriegelungsmechanismus bewirkt eine ca. 2-3mm breite Trennung der mechanischen Einrastung der Module und drückt diese auseinander. Die Stecker des PC 104 Interface können anschließend vorsichtig auseinander gezogen werden.

Nur Module (CPU, Feldbusanschaltungen und USV-Module) die sich zerstörungsfrei trennen lassen verfügen über eine Entriegelung. Module, die nicht voneinander getrennt werden können, haben lediglich einen Markierungspunkt (mit oder ohne roten Versieglungslack). Eine Krafteinwirkung an diesen Elementen führt zur Zerstörung.

Achtung |
 | Das gewaltsame Öffnen der Modulgehäuse (z.B. Entfernen der Deckel) führt zur Zerstörung der Gehäuse.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


Zubehör

Compact Flash Karten

Bestellnummer bei der Erstbestellung der Karten (statt 64-MB CF-Karten)

Bestellnummer | Beschreibung
CX1900-0023 | 1 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0025 | 2 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0027 | 4 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0029 | 8 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte
CX1900-0031 | 16 GByte Compact Flash Karte Typ I, statt 64-MB-Compact-Flash-Karte

Bestellnummer bei der Bestellung von Ersatzkarten

Bestellnummer | Beschreibung
CX1900-0022 | 64 MByte Compact Flash Karte Typ I
CX1900-0024 | 1 GByte Compact Flash Karte Typ I
CX1900-0026 | 2 GByte Compact Flash Karte Typ I
CX1900-0028 | 4 GByte Compact Flash Karte Typ I
CX1900-0030 | 8 GByte Compact Flash Karte Typ I
CX1900-0032 | 16 GByte Compact Flash Karte Typ

Formatierung einer Compact-Flash-Karte

Bestellnummer | Beschreibung
CX1900-0010 | Formatierung einer Compact-Flash-Karte (bootfähig), FAT16
CX1900-0012 | CX1900-0012 Formatierung einer Compact-Flash-Karte (bootfähig), NTFS

Speichererweiterung für CX1020/CX1030

Bestellnummer | Beschreibung
CX1900-0201 | 512 MB DDR RAM für CX1020/CX1030 statt 265 MB DDR RAM
CX1900-0202 | 1 GB DDR RAM für CX1020/CX1030 statt 265 MB DDR RAM

DVI-zu-VGA passiver Adapter

Bestellnummer | Beschreibung
CX1900-0101 | DVI-zu-VGA passiver Adapter für den Anschluss von Standard-VGA-Monitoren an das CX-System – führt die VGA-Signale der DVI-I-Schnittstelle des CX-Moduls aus – DVI-A-Stecker, 29-polig (unten), Buchse, 15-polig (oben) – Gewicht: ca. 40 g – Abmessungen (B x H x T): 40 x 42 x 15 mm

Ersatzbatterie CX-Systeme

Bestellnummer | Beschreibung
CX1900-0102 | Batterie für CX-Systeme - Originalherstellerbezeichnung: Panasonic Typ CR2032 3V/225mAh

Ersatzlüfterkassette für CX1030

Bestellnummer | Beschreibung
CX1900-0103 | Ersatzlüfterkassette für CX1030 – Kassette bestehend aus Gehäuse und Lüfter 40 mm – einfacher Austausch im Feld durch kabellose Montage – Gewicht: ca. 30 g – Abmessungen (B x H x T): 57 x 14 x 60 mm


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


LEDs CF-Karten-Leser CX1010-A001

BECKHOFF: CX1010-A001: Fehlerbehandlung und Diagnose

LEDs CF-Kartenleser

Anzeige | LED | Bedeutung
 | PWR | Das Modul wird mit Spannung versorgt und ist betriebsbereit.
 | LOCK | Es ist eine CF-Karte richtig eingeschoben und elektrisch verbunden.
 | CF | Blinkt bei Schreib-/Lesezugriffen auf die CF-Karte.


CX-System: Batterie

BECKHOFF: CX-System Produktübersicht

Batteriefach

Auf der linken Seite des CPU-Moduls, zwischen den beiden Ethernet Schnittstellen, befindet sich das Batteriefach.

Dieses kann mit Hilfe eines Schraubenziehers vorsichtig geöffnet werden.

Bei der Batterie handelt es sich um eine Typ CR2032 von Panasonic.

Die genauen Daten lauten wie folgt:

Batterietyp | Elektrische Eigenschaften (bei 20° C) |  | Standard Belastung | Abmessungen
 | nominal Spannung | nominal Kapazität | kontinuierliche Last | Durchmesser | Höhe | Gewicht
CR2032 | 3,0 V | 225 mAh | 0.20 mA | 20.0 mm | 3.20 mm | 3.1 g

Ersatzbatterien können beim Beckhoff Service bestellt werden.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.