Ändern der Auflösung auf Embedded PCs - Problem und Lösungsansatz

Embedded-PC: CXD Utility

Problem und Lösungsansatz

CX1000 und CX1020 Computer werden häufig mit Beckhoff Control Panels ausgeliefert. Die Beckhoff Control Panels haben je nach Größe des LCD Displays verschiedene Auflösungen. Diese Displays können in der Regel nur eine Auflösung darstellen. Die CX1000 Images (Windows XP embedded Images für CX1000 Computer) haben aus diesem Grund auch die Standard Auflösung von 640x480x16Bit, gedacht für 6.4“ bzw. 10“ Displays.
Die CX1020 Images (Windows XP embedded Images für den CX1020 Computer) haben eine Standard Auflösung von 800x600x16Bit, gedacht für 12“ Displays. Wenn man ein anderes Control Panel verwendet mit einem größeren Display (siehe Auflösungstabelle), wie zum Beispiel dies bei den Beckhoff Ethernet Panels der Fall ist, dann passt die Auflösung nicht und das Display bleibt schwarz.

Die Lösungsansätze sind hier:

  • Anschließen eines CRT Monitors, um die Auflösung passend einstellen. Leider ist dies schwierig bei Ethernet Panels, weil der Anschluss an das Display im Gehäuse integriert ist und man deswegen nicht ohne öffnen des Gehäuses an den Anschluss gelangt.

  • Verwendung des Beckhoff CXD Utility.

Auflösungstabelle

Hier sind die Auflösungen aufgelistet die, von dem CX Grafikchipsatz unterstützt werden:

Display Grösse in Zoll (Auflösung) | Hardware Platform
6,4" (640x480) | CX1000 / CX1020
10" (640x480) | CX1000 / CX1020
12" (800x600) | CX1000 / CX1020
15" (1024x768) | CX1000 / CX1020
19" (1280x1024) | CX1020


Funktionen des CXD Utilities

Embedded-PC: CXD Utility

Funktion des Beckhoff CXD Utility

Abbildung 1: Screenshot des Beckhoff CXD Utilities

1. Direkte, lokale Verwendung des CXD Utilities

Das Beckhoff CXD Utility befindet sich im System Verzeichnis der Windows XP embedded Images Version 1.14 für CX1000 Computer.
Beim Aufrufen der CXD.exe erscheint ein Dialog mit drei Auswahlboxen. Die dort aufgelisteten Auflösungen werden von dem CX1000, CX1020 Grafikchipsatz unterstützt. Bei dem CX1000 wird die Auflösung von 1280x1024 nicht unterstuetzt, deshalb wird diese Auflösung bei dem CX1000 ausgegraut.

Es besteht die Möglichkeit das CXD Utility „blind“ aufzurufen. Dies ist besonders wichtig, wenn die Auflösung auf dem Gerät nicht passt und man keine Anzeige auf dem Gerät hat. Durch die Tastaturkommandos lassen sich die unterstützten Auflösungen direkt bzw. nacheinander auswählen. Die Änderungen werden bei dieser Art der Bedienung zur Laufzeit ausgeführt. (siehe Bedienungsanleitung des Beckhoff CXD Utility)

2. Verwendung des CXD Utilities mit einer Remote Desktop Verbindung

Wenn ein CX1000, CX1020 System ohne Tastatur vorhanden ist, dann kann man das Beckhoff CXD Utility auch unter Remote Desktop Verbindung aufrufen. Durch das Auswählen der Auflösungen (siehe Abbildung 1). Diese Änderungen werden nicht zur Laufzeit übernommen. Es ist eine erneute Anmeldung bzw. ein Neustart des System erforderlich, um die Änderungen der Auflösung zu übernehmen (siehe Bedienungsanleitung des Beckhoff CXD Utility)


CXD Bedienung

Embedded-PC: CXD Utility

Bedienung des Beckhoff CXD Utilities

1. Direkte, lokale Bedienung des Beckhoff CXD Utilities

Aufruf des Beckhoff CXD Utilities mit Parametern: Man kann die Auflösung auch bei Aufruf des CXD Utilities ändern. Dazu muss man nach ca. drei bis fünf Minuten nach Start des CX1000, CX1020 Computers oder des Ethernet Panels durch die Tastenkombination Windows-Taste + R und die Eingabe von "CXD 1" (640x480) , "CXD 2" (800x600), "CXD 3" (1024x768), oder "CXD 4" (1280x1024) verwenden, um die Auflösung auf den Gerät verändern.

Auswahl einer bestimmten Auflösung mit der Tastatur: Um die Auflösung auf dem Zielgerät per Tastatur zu ändern, muss man nach ca. drei bis fünf Minuten nach Start des CX1000 Computers oder des Ethernet Panels durch die Tastenkombination Windows-Taste + R das CXD Utility aufrufen. Durch das Verwenden folgender Tastenkombinationen: CTRL + 1 (640x480), CTRL + 2 (800x600), CTRL + 3 (1024x768) oder CTRL + 4 (1280x1024) werden die Auflösungen auf dem Gerät verändert.

Nacheinanderschalten der Auflösungen: Um die Auflösung auf dem Zielgerät per Tastatur zu ändern, muss man nach ca. drei bis fünf Minuten nach Start des CX1000, CX1020 Computers oder des Ethernet Panels durch die Tastenkombination Windows-Taste + R das CXD Utility aufrufen. Nun kann man mit den Tastenkombinationen: CTRL+Pfeil-Oben (CTRL + NumKey 8), CTRL+Pfeil-Unten (CTRL + NumKey 2) die Auflösungen stufenweise nacheinander verändern. Mit CTRL + Pfeil-Unten werden die Auflösungen erniedrigt und mit CTRL + Pfeil-Oben werden die Auflösungen erhöht.

Hinweis

 Direkte Ausführung auf dem Laufzeitsystem
Diese Änderungen werden zur Laufzeit auf dem lokalen System ausgeführt. Sobald die ausgewählten Auflösungen zum LCD Display passen, wird die Anzeige auf dem Display angezeigt.

2. Bedienung des Beckhoff CXD Utilities unter Remote Desktop

Sobald man sich mit dem Remote Desktop Client auf dem Zielsystem angemeldet hat, kann man mit der Windows Eingabeaufforderung (start-->run…) das Beckhoff CXD Utility aufrufen, indem man "CXD" in das Eingabefeld eintippt. Dadurch erscheint dann der CXD Dialog. Nun kann man die zutreffende Auflösung auswählen. Die passenden Auflösungen kann man aus der Auflösungstabelle entnehmen. Da es sich bei einer Remote Desktop Verbindung um eine „virtuelle“ Auflösung handelt kann die Änderungen der Auflösung auf dem Zielsystem nicht zur Laufzeit erfolgen. Daher ist eine erneute Benutzeranmeldung erforderlich. Aus diesem Grund erscheint auch eine Messagebox, die einen Neustart des Systems anbietet.

Achtung

 Datenverlust
Bei einem Neustart des System gehen ungespeicherte Daten verloren.


Download des CXD Utilities

Embedded-PC: CXD Utility

Download

Download der CXD Utility


Übersicht - Dokumentation des Beckhoff CXD Utility

Embedded-PC: CXD Utility

CXD – Beckhoff Display Resolution Changer Utility für CX1000, CX1020 Computer

Inhalt:

Problem und Lösungsansatz

Funktionen des Beckhoff CXD Utilities

Bedienung des Beckhoff CXD Utilities