Titel

CX1000: Embedded-PC-System

Dokumentation zu

der Hardware des CX1000-Systems

CX1000-0xxx

CX1000-Nxxx

Version: 1.2
Datum: 01.03.2010


Hinweise zur Dokumentation

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Disclaimer

Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Deshalb ist die Dokumentation nicht in jedem Fall vollständig auf die Übereinstimmung mit den beschriebenen Leistungsdaten, Normen oder sonstigen Merkmalen geprüft.
Falls sie technische oder redaktionelle Fehler enthält, behalten wir uns das Recht vor, Änderungen jederzeit und ohne Ankündigung vorzunehmen.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.

Marken

Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE® und XFC® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.

Patente

Die EtherCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP1590927, EP1789857, DE102004044764, DE102007017835
mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Die TwinCAT Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente:
EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.

Copyright

© Beckhoff Automation GmbH.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Sicherheitsbestimmungen

Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.

Auslieferungszustand

Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard-, oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH.

Qualifikation des Personals

Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.

Erklärung der Sicherheitssymbole

In der vorliegenden Betriebsanleitung werden die folgenden Sicherheitssymbole verwendet. Diese Symbole sollen den Leser vor allem auf den Text des nebenstehenden Sicherheitshinweises aufmerksam machen.

Gefahr |
 | Dieses Symbol weist darauf hin, dass Gefahren für Leben und Gesundheit von Personen bestehen.

Achtung |
 | Dieses Symbol weist darauf hin, dass Gefahren für Maschine, Material oder Umwelt bestehen.

Hinweis |
 | Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.

Grundlegende Sicherheitsmaßnahmen

Abschalten des PCs nur nach Beendigung der Software

Bevor der Embedded-PC abgeschaltet werden darf muss die laufende Software regulär beendet werden, andernfalls können Daten auf der Festplatte verloren gehen. Lesen Sie dazu den Abschnitt "Ausschalten".

Wenn der PC nicht für Steuerungszwecke eingesetzt wird, beispielsweise während der Funktionsprüfung, müssen zuerst alle Anlagenteile abgeschaltet und danach der Embedded-PC von der Anlage abgekoppelt werden. Die Abkopplung geschieht durch Abziehen der ersten Klemme hinter dem Netzteil (CX1100-002 und CX1100-002) (optional) und Abziehen der Stecker der Feldbusanschlüsse.
Abgeschaltete Anlagenteile müssen gegen Wiedereinschalten gesichert werden.

Das Netzteil des Embedded-PCs wird mit einer Spannung von 24 V DC versorgt.

Gefahr |
 | Keine Teile unter Spannung austauschen!

Beim Ein- und Ausbau von Komponenten muss die Versorgungsspannung abgeschaltet werden.

Sorgfaltspflicht des Betreibers

Der Betreiber muss sicherstellen, dass
· der Embedded-PC nur bestimmungsgemäß verwendet wird.
· der Embedded-PC nur in einwandfreiem, funktionstüchtigem Zustand betrieben wird.
· die Betriebsanleitung stets in einem leserlichen Zustand und vollständig am Einsatzort des Embedded-PCs zur Verfügung steht.
· nur ausreichend qualifiziertes und autorisiertes Personal den Embedded-PC bedient.
· dieses Personal regelmäßig in allen zutreffenden Fragen von Arbeitssicherheit und Umweltschutz unterwiesen wird, sowie die Betriebsanleitung und insbesondere die darin enthaltenen Sicherheitshinweise kennt.

Nationale Vorschriften je nach Maschinentyp

Je nach Maschinen- und Anlagentyp, in dem der Embedded-PC zum Einsatz kommt, bestehen nationale Vorschriften für Steuerungen solcher Maschinen und Anlagen, die der Betreiber einhalten muss. Diese Vorschriften regeln unter anderem, in welchen Zeitabständen die Steuerung überprüft werden muss. Der Betreiber muss diese Überprüfung rechtzeitig veranlassen.

Achtung |
 | Erforderliche Softwarekenntnisse!

Jeder Benutzer muss alle für ihn erreichbaren Funktionen der auf dem PC installierten Software kennen.

Anforderungen an das Bedienungspersonal

Betriebsanleitung lesen

Jeder Benutzer des Embedded-PCs muss diese Betriebsanleitung gelesen haben.

Softwarekenntnisse

Jeder Benutzer muss alle für ihn erreichbaren Funktionen der auf dem PC installierten Software kennen.


Ausgabestände der Dokumentation

Version | Änderungen
1.2 | Entsorgungshinweise zur Batterie hinzugefügt
1.1 | Angaben zum Hardware Watchdog hinzugefügt
1.0 | Überarbeitete Version
0.1 | Vorläufige Version


Bestimmungsgemäße Verwendung

Die Geräteserie CX1000 ist ein hutschienenmontierbares modulares Steuerungssystem, dessen Elemente, je nach Aufgabenstellung, zusammengesteckt in den Schaltschrank oder Klemmenkasten eingebaut werden.

Hinweis:

Die Gerätekonfiguration CX1000 wird nicht für Neuprojekte empfohlen.

Als neue Standardkonfiguration steht der Typ CX1010 zur Verfügung.


Hinweise zum Handbuch

Embedded-PC: Produktübersicht

Systemübersicht

Das System

Die Geräteserie CX1000 ist für Steuerungsaufgaben im mittleren Leistungsbereich geeignet. Es gestaltet den Abdeckungsbereich der Beckhoff Steuerungstechnik sowohl preislich als auch leistungsmäßig durchgängig: Aufgabenstellungen, die die Eigenschaften und Rechenleistungen von Industrie-PCs erfordern, andererseits aber deren preisliches Einstiegsniveau nicht zulassen, sind das Zielgebiet dieser Produktreihe.
Es werden nur die Komponenten in das System eingefügt, die auch benötigt werden - so kann ein CX1000 z. B. „headless“ betrieben werden, also ohne Display und Tastatur; die entsprechende Schnittstelle entfällt. Es entsteht eine Steuerung, die zwar keine Visualisierung hat, jedoch sehr wohl über die immer vorhandenen Schnittstellen Ethernet und RS 232 kommunikationsfähig ist.

Falls die lokale Visualisierung dennoch gewünscht wird, so geschieht dies über eine DVI (Digital Video Interface) Schnittstelle, an die alle Beckhoff Control Panel sowie handelsübliche Monitore mit DVI-Eingang anschließbar sind. Das Touch Screen Signal wird dabei über eine der zwei verfügbaren USB-Schnittstellen eingelesen.

Die Komponenten

Bei der CX1000 Serie handelt es sich um ein System, dessen Module untereinander über den genormten PC104 Bus (16 Bit) miteinander verbunden sind. Die einzelnen Systemkomponenten sind aneinanderreihbare Module. Die Basiseinheit besteht aus einem CPU-Modul (CX1000-0000) und einem Netzteil-Modul (CX1100-000x).

CPU Grundmodul

Das CPU-Modul ist in mehreren Varianten erhältlich. Diese betreffen:

- Den internen Speicherausbau: Hier gibt es zwei Möglichkeiten – entweder 16 MByte Flash/32 MByte RAM oder 64 MByte Flash/128 MByte RAM. Letzteres ist unbedingte Voraussetzung, falls das System mit Windows XP Embedded ausgestattet werden soll.

- Die Ausstattung mit Systemschnittstellen: Als Option können zu der immer vorhandenen Kombination aus Ethernet und RS 232 auch DVI und zwei USB Schnittstellen hinzugefügt werden.

- Die Betriebssystemausstattung: Es kann gewählt werden zwischen Microsoft Windows CE.NET sowie Microsoft Windows XP Embedded.

- Die vorinstallierte TwinCAT Software: CX1000 kann ohne TwinCAT System, mit TwinCAT CE PLC oder TwinCAT CE NC PTP oder mit den entsprechenden Vollversionen der einzelnen TwinCAT Level für SPS und Motion Control vorinstalliert werden.

Systemschnittstellen

Getrennt bestellbar sind weitere Systemschnittstellen für serielle Kommunikation (2x RS 232 sowie RS422, RS485) und Audiosignale.

Feldbusschnittstellen

Die Feldbusschnittstellen sind derzeit als Master und Slave-Feldbusanschaltungen für folgende Feldbusse erhältlich:

Beckhoff Lightbus, Profibus DP, CANopen, DeviceNet und SERCOS Interface (nur Master).

Die Master-Feldbusanschaltungen ermöglichen dem CX1000 System die Nutzung der Beckhoff Feldbuskomponenten (wie Buskoppler, Busklemmen Controller und Antriebstechnik) als dezentrale Steuerungskomponenten für die Aufbau komplexer Anlagen.

Die Slave-Feldbusanschaltungen ermöglichen die Nutzung des CX1000 Systems als unterlagerte dezentrale Steuerung für den Aufbau komplexer oder modularer Anlagen.

Die Software

In Kombination mit der Automatisierungssoftware TwinCAT wird der Industrie-PC CX1000 zu einer leistungsfähigen IEC 61131-3 SPS mit bis zu vier Anwendertasks. Zusätzlich können auch Motion Control Aufgaben ausführt werden. Je nach erforderlicher Abtastzeit ist die Ansteuerung von mehreren Servoachsen möglich, wobei selbst Sonderfunktionen wie Fliegende Säge, Elektronisches Getriebe und Kurvenscheibe realisierbar sind.

Remote Programmierung über Ethernet

Dies ist der Fall, wenn die Basiseinheit mit Windows CE.NET ausgestattet wird. Dann erfolgt die Programmierung über ein Laptop oder einen Desktop-PC, der über Ethernet (Netzwerk oder Crossover-Cable) mit dem CX1000 verbunden ist. Die Programme werden mit einer Standard TwinCAT Softwarelizenz auf dem Laptop entwickelt und dann in das Zielgerät geladen.

Visualisierung

Bei beiden Betriebssystemvarianten Windows CE.NET bzw. Windows XP Embedded steht für die Anbindung an SCADA-Pakete der Beckhoff OPC Server zur Verfügung. Somit gilt auch für den CX1000: Problemlos Visualisieren und gleichzeitiges Steuern in Echtzeit auf einem System.


Technische Daten

Das CX1000 CPU-Grundmodul ist die Basiseinheit des CX-Systems. Es beinhaltet die CPU, den internen Flash Speicher in zwei Ausbaustufen sowie die Möglichkeit, ein zusätzliches Speichermedium im Compact Flash Format II zu betreiben. Ethernet und RS 232-Schnittstelle gehören ebenfalls zur Basisausstattung. Über die beidseitig ausgeführte PC104 Schnittstelle können alle anderen Komponenten der CX-Familie angeschlossen werden. Für die Spannungsversorgung des CPU-Moduls wird eines der Netzteilmodule des Typs CX1100 benötigt.

Technische Daten | CX1000-0000
Prozessor | Pentium MMX kompatibel, 266 MHz Taktfrequenz
Flash Speicher | 64 MByte Compact-Flash-Karte
Interner Arbeitsspeicher | 32 MByte RAM (erweiterbar auf 128 MByte)
Schnittstellen | 1 x RJ45 (Ethernet) und 1 x D-Sub Stecker 9-polig (RS 232)
Diagnose LED | 1 x Power, 1 x Link, 1x 100 MBit , 1 x LAN Aktivität, 1 x Flashzugriff
Erweiterungssteckplatz | 1 x Compact Flash Typ II Einschub mit Auswurfmechanik
Uhr | interne akkugepufferte Uhr für Zeit und Datum
Betriebssystem | Microsoft Windows CE.NET oder Microsoft Windows XP Embedded
Steuerungssoftware | TwinCAT PLC Runtime oder TwinCAT NC PTP Runtime
Systembus | 16 Bit ISA (PC104 Standard)
Spannungsversorgung | über Systembus (durch Netzteilmodul CX1100)
Abmessungen | 57 mm x 100 mm x 91 mm
Gewicht | ca. 355 g ( mit DVI/USB ca. 435 g)

Die Kühlung der CPU erfolgt über einen passiven Kühlkörper (CX1000-COOL), dieser ist werkseitig mit dem CPU-Grundmodul verbunden.

Hinweis

Die Watchdog-Funktion wird von Beckhoff nur in Verbindung mit TwinCAT mit WINDOWS NT basierten Systemen unterstützt. Für andere Betriebssysteme ohne TwinCAT ist es nicht möglich eine allgemeine Lösung anzugeben. Der Anwender muss selbst eine Lösung implementieren. Als Unterstützung können hier NUR
  • die Prozessorbeschreibung
  • die CX-Architektur Beschreibung (CX1100-000x Netzteilbeschreibung)

gegeben werden. Die Dokumente sind im Downloadbereich unseres Webservers (www.beckhoff.de) verfügbar.


Ausführungen

Das CPU-Modul lässt sich mit unterschiedlichen Hardware- und Softwareoptionen ausstatten: der interne Speicher ist auf 32 MB Flash/128 MB RAM erweiterbar; bei den Betriebssystemen besteht die Wahl zwischen Windows CE.NET sowie Windows XP Embedded. Durch die Automatisierungssoftware TwinCAT wird ein CX1000 System zu einer leistungsfähigen SPS und Motion Control Steuerung, die mit oder ohne Visualisierung eingesetzt werden kann. An das CPU-Grundmodul können weitere Systemschnittstellen (ab Werk vormontiert) sowie Feldbusanschaltungen angefügt werden.

Die Bestellbezeichnung des CPU-Grundmoduls ergibt sich aus folgender Bezeichnungssystematik:

Die CX 1000 Module sind in folgenden Ausführungen erhältlich:

Modul | 16/32 MB | 64/128 MB | DVI / USB | Windows CE.NET | Windows XPE | ohne TwinCAT | TwinCAT PLC Runtime | TwinCAT NC PTP Runtime
CX1000-0010 | * |  |  | * |  | * |  |
CX1000-0011 | * |  |  | * |  |  | * |
CX1000-0012 | * |  |  | * |  |  |  | *
CX1000-0110 | * |  | * | * |  | * |  |
CX1000-0111 | * |  | * | * |  |  | * |
CX1000-0112 | * |  | * | * |  |  |  | *
CX1001-0000 | * |  |  |  |  |  |  |
CX1001-0010 |  | * |  | * |  | * |  |
CX1001-0011 |  | * |  | * |  |  | * |
CX1001-0012 |  | * |  | * |  |  |  | *
CX1001-0020 |  | * |  |  | * | * |  |
CX1001-0021 |  | * |  |  | * |  | * |
CX1001-0022 |  | * |  |  | * |  |  | *
CX1001-0110 |  | * | * | * |  | * |  |
CX1001-0111 |  | * | * | * |  |  | * |
CX1001-0112 |  | * | * | * |  |  |  | *
CX1001-0120 |  | * | * |  | * | * |  |
CX1001-0121 |  | * | * |  | * |  | * |
CX1001-0122 |  | * | * |  | * |  |  | *

CX1000 Systeme mit Windows XP Embedded setzen eine Compact Flash Karte mit einer Kapazität von mindestens 1 GB voraus.

Hinweis:

Die Auflistung der verschiedenen Software Images entnehmen Sie bitte der CX1000 Software Dokumentation.


Anschlüsse

Das CPU-Grundmodul ist in verschiedenen Hardware- und Softwareoptionen erhältlich. Die Stromversorgung erfolgt über das Netzteil, so dass an dieser Stelle nur die Anschlüsse beschrieben werden.

CPU Grundmodul mit Ethernet RJ 45 und COM1 (RS232) Schnittstelle:

RJ 45 Schnittstelle (Buchse):

Belegung der RJ45-Schnittstelle:

PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | connected | nicht benutzt
5
6 | RD - | Receive -
7 | connected | nicht benutzt
8

TD & RD werden an den Hubs, oder zwischen zwei PCs getauscht.

COM1 Schnittstelle (Stecker):

Belegung des COM1 Schnittstelle:

PIN | Signal | Typ | Beschreibung
1 | DCD | Signal in | Data Carrier Detect
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground
6 | DSR | Signal in | Data Set Ready
7 | RTS | Signal out | Request to Send
8 | CTS | Signal in | Clear to Send
9 | RI | Signal in | Ring Indicator

CPU Grundmodul mit DVI/USB Schnittstelle:

Dieses Grundmodul enthält zusätzlich zur Ethernet und COM Schnittstelle eine DVI/ USB Schnittstellen. Die Pinbelegung des CPU Grundmoduls mit zwei USB und einer DVI-I Schnittstelle ist bei der zugehörigen Systemschnittstelle CX1000-N001 erklärt.

Gültig für alle CPU Grundmodule:

LED

Bei ordnungsgemäßem Anschluss des CPU Grundmoduls an ein Netzteil mit eingeschalteter Spannungsversorgung leuchtet die grüne LED Power (PWR) auf.

Compact Flash Einschub

Nähere Informationen hierzu finden Sie auf der Seite Compact Flash Einschub.

PC 104 Bus

Der PC 104 Bus ist ein standardisierter Bus mit 104 ISA-Signalen für kompakte Embedded Systeme.


Compact Flash Einschub

Auf der Frontseite des CPU-Grundmoduls befindet sich ein Compact Flash Einschub. Hierdurch ergibt sich die Möglichkeit das Speichermedium auszutauschen. Dies ist nur in ausgeschaltetem Zustand möglich, andernfalls kann die Entnahme zum Absturz des Systems führen. Zu Wartungsarbeiten kann die Compact-Flash-Karte aus dem Grundmodul entnommen werden. Auch die Erweiterung des Systems auf einen größeren Speicher (nur Betriebssystem und Programmspeicher) ist auf diese Weise möglich. Die Compact-Flash-Karten (CF-Karten) sind als Zubehör in verschiedenen Speichergrößen erhältlich.

Die Betätigung der Auswurfmechanik mit einem Schraubendreher unterhalb des Einschubs bewirkt den Auswurf der Karte um ca. 4 mm (BILD1), so dass sie mit den Fingern herausgezogen werden kann (BILD2). Beim Einschub der Karte (BILD3) rastet die Auswurfmechanik wieder ein. Die Karte sitzt richtig, wenn sie sich ca.1 mm tiefer als die Frontseite des Gerätegehäuses befindet.

BILD1: Auswurf der CF Karte BILD2: Herausziehen der CF Karte

BILD3: Einschub der CF Karte

Achtung |
 | Bei dem Compact-Flash-Einschub handelt es sich um ein Speicherinterface, nicht um einen CF Einschub des Typs I/O.


Compact Flash Karte

Embedded-PC: Produktübersicht

Compact-Flash-Karte

Bei der Compact-Fash-Karte (CF-Karte) handelt es sich um einen nicht volatilen Speicher.

Daten, die Spannungsausfallsicher gespeichert werden sollen, müssen auf der CF-Karte gespeichert werden. Die CF-Karte arbeitet wie eine Harddisk.

Achtung |
 | Es wird ausdrücklich darauf hingewiesen nur CF-Karten zu verwenden, die von der Beckhoff Automation GmbH geliefert werden. Es handelt sich um industrietaugliche CF-Karten mit einer erhöhten Anzahl an Schreib-/ Lesezyklen und einem erweiterten Temperaturbereich ( +85°C). Ein einwandfreier Betrieb kann nur mit CF-Karten von der Beckhoff Automation GmbH gewährleistet werden!


PC 104 Bus

Der PC 104 Bus ist ein standardisierter Bus mit 104 ISA-Signalen für kompakte Embedded Systeme.

Für die Funktionalität der CX1000 Module sind acht zusätzliche Signale, hier farblich markiert, zu den Standardsignalen hinzugefügt worden.

Pinbelegung des 16 Bit PC 104 Bus:

Pin Nummer | J1/P1 Row A | J1/P1 Row B | J1/P1 Row C | J1/P1 Row D
0 | -- | -- | GND | GND
1 | IOCHCHK* | GND | SBHE* | MEMCS16*
2 | SD7 | RESETDRV | LA23 | IOCS16*
3 | SD6 | +5V | LA22 | IRQ10
4 | SD5 | IRQ9 | LA21 | IRQ11
5 | SD4 | -5V | LA20 | IRQ12
6 | SD3 | DRQ2 | LA19 | IRQ13
7 | SD2 | -12V | LA18 | IRQ14
8 | SD1 | ENDXFR* | LA17 | DACK0*
9 | SD0 | +12V | MEMR* | DRQ0
10 | IOCHRDY | (KEY)² | MEMW* | DACK5*
11 | AEN | SMEMW* | SD8 | DRQ5
12 | SA19 | SMEMR* | SD9 | DACK6*
13 | SA18 | IOW* | SD10 | DRQ6
14 | SA17 | IOR* | SD11 | DACK7*
15 | SA16 | DACK3* | SD12 | DRQ7
16 | SA15 | DRQ3 | SD13 | +5V
17 | SA14 | DACK1* | SD14 | MASTER*
18 | SA13 | DRQ1 | SD15 | GND
19 | SA12 | REFRESH* | (KEY)² | GND
20 | SA11 | SYSCLK | -- | --
21 | SA10 | IRQ7 | -- | --
22 | SA9 | IRQ6 | -- | --
23 | SA8 | IRQ5 | -- | --
24 | SA7 | IRQ4 | -- | --
25 | SA6 | IRQ3 | -- | --
26 | SA5 | DACK2* | -- | --
27 | SA4 | TC | -- | --
28 | SA3 | BALE | -- | --
29 | SA2 | +5V | -- | --
30 | SA1 | OSC | -- | --
31 | SA0 | GND | -- | --
32 | GND | GND | -- | --

Anmerkungen:

2. B10 and C19 are key locations.

3. Signal timing and function are as specified in ISA specification.

4. Signal source/sink current differ from ISA values.

Pinbelegung der acht zusätzlichen Signale:

Pinnummer | Belegung
1 | I²C SCL
2 | USB D+
3 | I²C SDA
4 | USB D-
5 | ONCTRL
6 | Ustby 5 V
7 | POR
8 | PWRBTN

Hinweis:

Weitere Informationen zum PC104 Bus finden Sie unter http://www.pc104.org


Technische Daten

Im Gegensatz zu anderen CX-Komponenten, sind die Systemschnittstellen nicht im Feld nachrüstbar oder erweiterbar. Sie werden in der bestellten Konfiguration ab Werk geliefert und sind vom CPU-Modul nicht trennbar. Die Systemschnittstellen führen den internen PC104 durch, so dass an sie weitere CX-Komponenten angeschlossen werden können. Die Spannungsversorgung der Systemschnittstellen-Module wird über den internen PC104-Bus gewährleistet.
Technische Daten | CX1000-N001 | CX1000-N002 | CX1000-N003 | CX1000-N005*
Schnittstellen | 1 x DVI + 2 x USB 1.1 | 1 x COM2 + 1 x COM3 | Line IN, Line Mic IN, Line OUT | 1 x COM2 + 1 x COM3
Anschlussart | DVI-I 29-polige Buchse + 2 USB ports Typ A | 2 x D-Sub Stecker 9-polig | 3,5 mm Buchse für Klinkenstecker | 2 x D-Sub Buchse 9-polig
Eigenschaften | DVI-I Schnittstelle führt auch VGA Signale aus (DVI-A) | max. Baudrate 115 kBaud auf beiden Schnittstellen COM1: RXD, TXD, DTR COM2: RXD, TXD | eingebauter PC Beeper Line OUT Ausgang, max. 200 mW, für Kopfhörer geeignet | max. Baudrate 115 kBaud auf beiden Schnittstellen 2 x RS485/422, opto-isoliert
Spannungsversorgung | über Systembus (durch Netzteilmodul CX1100)
Abmessungen | 19 mm x 100 mm x 91 mm
Gewicht | ca. 80 g

* kann nur statt und nicht gleichzeitig mit CX1000-N002 verwendet werden.


Anschlüsse CX1000-N001

Dieses Modul enthält zusätzlich zur Ethernet und RS232 Schnittstelle eine DVI-I und zwei USB Schnittstellen.

DVI-I Schnittstelle

Die DVI-I Schnittstelle überträgt analoge und digitale Daten und eignet sich für den Anschluss an analoge Grafikkarten mit einem 15-poligen D-Sub Stecker und digitale Grafikkarten mit DVI-D Ausgang. Die Auflösung am Bildschirm oder Beckhoff Control Panel ist abhängig von einer maximalen Entfernung von 7 m.

Die DVI Schnittstelle führt VGA Signale aus, so dass der Anschluss von CRT-VGA Monitoren an das CX1000 System unter Verwendung eines DVI-to-VGA Adapters ebenfalls möglich ist.
Dieser Adapter ist als Zubehör erhältlich.

DVI-I Buchse:

Pin | Belegung | Pin | Belegung | Pin | Belegung
1 | TMDS Data 2- | 9 | TMDS Data 1- | 17 | TMDS Data 0-
2 | TMDS Data 2+ | 10 | TMDS Data 1+ | 18 | TMDS Data 0+
3 | TMDS Data 2/4 Shield | 11 | TMDS Data 1/3 Shield | 19 | TMDS Data 0/5 Shield
4 | not connected | 12 | not connected | 20 | not connected
5 | not connected | 13 | not connected | 21 | not connected
6 | DDC Clock | 14 | + 5V Power | 22 | TMDS Clock Shield
7 | DDC Data | 15 | Ground ( +5V, Analog H/V Sync) | 23 | TMDS Clock +
8 | Analog Vertical Sync | 16 | Hot Plug Detect | 24 | TMDA Clock -

Pinbelegung Kreuz

Pin | Belegung
C1 | Analog Red Video Out
C2 | Analog Green Video Out
C3 | Analog Blue Video Out
C4 | Analog Horizontal Sync

Auflösung am Monitor:

Auflösung in Pixel | Entfernung der Schnittstelle vom Monitor
1024 x 768 | 5 m
800 x 600 | 6 m
640 x 480 | 7 m

USB Schnittstelle:

Die USB Buchse ist vom Typ A. Die USB Schnittstelle entspricht der USB 1.1 Spezifikation.

Pin | Belegung | Typische Zuordnung
1 | VBUS | Red
2 | D- | White
3 | D+ | Green
4 | GND | Black
Shell | Shield | Drain Wire


Anschlüsse CX1000-N002

Die Systemschnittstelle CX1000-N002 enthält zwei RS232 Schnittstellen, COM2 und COM3 (9-polige Sub-D Stiftleiste).
Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit.

COM Schnittstelle RS232 (Stecker):

Pinbelegung COM2 Schnittstelle:

PIN | Signal | Typ | Beschreibung
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
4 | DTR | Signal out | Data Terminal Ready
5 | GND | Ground | Ground

Die nicht aufgeführten Pins sind nicht belegt.

Pinbelegung COM3 Schnittstelle:

PIN | Signal | Typ | Beschreibung
2 | RxD | Signal in | Receive Data
3 | TxD | Signal out | Transmit Data
5 | GND | Ground | Ground

Die nicht aufgeführten Pins sind nicht belegt.


Anschlüsse CX1000-N003

Diese Systemschnittstelle enthält die Audio Schnittstellen Line In, ein Mic In (Mikrofon Signaleingang) und Line Out (auch für Kopfhörer), max. 200 mW.
Zusätzlich ist ein PC Beeper eingebaut.
Die Buchsen haben eine Größe von 3,5 mm und sind für Klinkenstecker ausgelegt.

Line In / Line Out Stereo-Klinkenstecker:

Pinbelegung Line In /Line Out:

Signal | Beschreibung
L | Left Signal
R | Right Signal
Gound | Ground

Der linke Kanal wird über die Spitze des Klinkensteckers übertragen, der rechte Kanal über den ersten Ring. Die übrige Hülse dient zur Erdung.

Mic In Mono-Klinkenstecker:

Der einzige vorhandene Kanal wird über die Spitze übertragen, die übrige Hülse dient zur Erdung.


Anschlüsse CX1000-N005

Die Systemschnittstelle CX1000-N005 enthält zwei RS422, RS485 Schnittstellen, COM2 und COM3 (9-polige Sub-D Stiftleiste).
Die maximale Baudrate auf beiden Kanälen beträgt 115 kBit.

COM Schnittstelle (Buchse):

Pinbelegung COM Schnittstelle:

PIN | Signal | Typ | Beschreibung
2 | TxD+ | Data-Out + | Transmit 422
3 | RxD+ | Data-In + | Receive 422
5 | GND | Ground | Ground
6 | VCC | VCC | +5V
7 | TxD- | Data-Out - | Transmit 422
8 | RxD- | Data-In - | Receive 422

Für RS 485 muss Pin 2 und 3 ( Data +) sowie Pin7 und 8 (Data -) verbunden werden.

Die nicht aufgeführten Pins sind nicht belegt.

Einstellung DIP-Switches RS485:

RS485 without Echo, End-Point ( Terminated) DEFAULT EINSTELLUNG

DIP | Status | Funktion
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | on | Auto receive on
6 | off | Always receive on
7 | on | Term on
8 | on | Term on

RS485 with Echo, End-Point ( Terminated)

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

RS485 without Echo, Drop-Point ( without Termination)

DIP | Status | Funktion
1 | off | Echo on
2 | on | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

RS485 with Echo, Drop-Point ( without Termination)

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | on | Auto send on
4 | off | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | off | Term on
8 | off | Term on

Einstellung DIP-Switches RS422:

RS422 full duplex end point

DIP | Status | Funktion
1 | on | Echo on
2 | off | Echo off
3 | off | Auto send on
4 | on | Always send on
5 | off | Auto receive on
6 | on | Always receive on
7 | on | Term on
8 | on | Term on

Die Dip-Schalter für die Konfiguration der RS485/422 Schnittstelle befinden sich an der linken Seite des Moduls. Nach dem Entfernen der grauen Abdeckung wird der Schalter sichtbar.


Technische Daten CX1100-0001

Die Spannungsversorgung eines CX1000 Systems erfolgt durch eines von drei wählbaren Netzteilmodulen. Die Spannungsversorgung aller weiteren Systemkomponenten wird über den internen PC104-Bus gewährleistet; es sind keine separaten Versorgungszuführungen nötig. Die CX1100 Komponenten bieten jedoch weitere wichtige Eigenschaften über die reine Spannungsversorgung hinaus: ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten, ein LCD-Display mit zwei Zeilen à 16 Zeichen dient zur Ausgabe von System- und Anwendermeldungen.

Das Netzteil CX1100-N001 besitzt keine E/A Schnittstellen.

Technische Daten | CX1100-0001
Spannungsversorgung | 24 V DC (-15%/+20%)
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 30 W
Empfohlene Sicherung bei 24 V | 2 A
K-Bus Anschluss | -
IP-Link Anschluss | -
Anschlussart | 1 x Open Pluggable Connector, 5-polig
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | -
Diagnose LED | 1 x Power
Abmessungen | 45 mm x 100 mm x 91 mm
Gewicht | 180 g


Technische Daten CX1100-0002 / CX1100-0003

Die Anreihung lokaler E/A-Signale erfolgt über die Netzteilvariante CX1100-0002, an die alle Beckhoff Busklemmen angeschlossen werden können, oder über CX1100-0003, die zusätzlich zu den Busklemmen auch den Anschluss der Beckhoff Feldbus Box Module vom Typ Erweiterungs-Box IExxxx erlaubt. Die E/A-Daten werden in einem DPRAM abgelegt, welches der CPU über den Systembus zugänglich ist. Die Netzteile des CX-Systems sind im Feld austauschbar.

Technische Daten | CX1100-0002 | CX1100-0003
Spannungsversorgung | 24 V DC (-15%/+20%)
Spannungsfestigkeit | 500 Veff (Versorgung / Interne Elektronik)
Maximale Leistungsaufnahme | 30 W
Empfohlene Sicherung bei 24 V | 2 A
K-Bus Anschluss | ja (Adapterklemme)
IP-Link Anschluss | - | ja
Anschlussart | Cage Clamp (Adapterklemme)
NOVRAM | 8 kByte
Display | FSTN Display 2 Zeilen x 16 Zeichen Text, beleuchtet
I/O-DPRAM | 2 kByte | 4 kByte
Diagnose LED | 1 x PWR, 1 x I/O Run, 1 x I/O Err
Abmessungen | 39 mm x 100 mm x 91 mm | 58 mm x 100 mm x 91 mm
Gewicht | 250 g | 330 g


Anschlüsse CX1100-0001

Dieses Netzteil besitzt keine E/A-Schnittstelle, die Stromversorgung erfolgt daher über den 5-poligen Open Pluggable Connector. Das Netzteil versorgt über den PC104-Bus alle weiteren Systemkomponenten mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff.
Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten.

Pinbelegung Open Style Connector:

Pin | Belegung
1 | +24 V DC
2 | 0 V DC
3 | GROUND
4 | +UPS (+ 24 V DC)
5 | -UPS (0 V DC)

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.


Anschlüsse CX1100-0002

Dieses Netzteil ist mit einer E/A-Schnittstelle ausgestattet, die den Anschluss der Beckhoff Busklemmen ermöglicht. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den K-Bus die Busklemmen mit einer Spannung von 24 V DC ( -15 %/+20%). Die Spannungsfestigkeit des Netzteils beträgt 500 Veff. Da der K-Bus nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.
Ein integriertes NOVRAM erlaubt die spannungsausfallsichere Speicherung von Prozessdaten.

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot.

Die I/O LEDs dienen zur Anzeige der Betriebsstände der Busklemmen. Der fehlerfreie Hochlauf der Konfiguration wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.


Anschlüsse CX1100-0003

Dieses Netzteil ermöglicht neben einem Anschluss der Beckhoff Busklemmen auch die Anreihung der Beckhoff Feldbus Box Module vom Typ Erweiterungs-Box IExxxx. Die Stromversorgung erfolgt über die oberen Federkraftklemmen mit der Bezeichnung "24V" und "0" V.
Die Versorgungsspannung versorgt das CX System und über den K-Bus die Busklemmen. Da der K-Bus nur Daten weiterleitet, ist für die Busklemmen eine weitere Spannungsversorgung notwendig. Dies erfolgt über die Powerkontakte, die keine Verbindung zur Spannungsversorgung besitzen.

Feldbusanschluss:

Stecken Sie den IP-Link Stecker in die vorgesehenen Anschlüsse, d.h je einen Lichtwellenleiter in IN (x03) bzw. OUT (x04). Das andere Ende verbinden Sie mit dem entsprechenden IP-Link Interface der Erweiterungs-Box. Die Verbindung mit dem muss so erfolgen, dass der Output der Feldbusanschaltung mit dem Input der Erweiterungs-Box verbunden wird, und umgekehrt.

LED:

Bei ordnungsgemäßem Anschluss des Netzteils und eingeschalteter Spannungsversorgung leuchtet die LED Power (PWR) grün auf, bei Kurzschluss rot. Die I/O LEDs dienen zur Anzeige der Betriebsstände der Busklemmen. Der fehlerfreie Hochlauf der Konfiguration wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden.

PE-Powerkontakte

Der Powerkontakt "PE" darf nicht für andere Potentiale verwendet werden.


LCD Display

Das LCD-Display der Netzteile besitzt zwei Zeilen à 16 Zeichen und dient zur Anzeige von System- und Anwendermeldungen.

"Index-Group/Offset" Spezifikation für das LCD Display

ADS Port 300

Index Group | Index Offset | Access | Data type | Phys. unit | Def. range | Description | Remarks
0x00005000 + DeviceID | 0xFFFF90FF | R&W |  |  |  | Cursor OFF |
0x00005000 + DeviceID | 0xFFFF91FF | R&W |  |  |  | Cursor ON |
0x00005000 + DeviceID | 0xFFFF92FF | R&W |  |  |  | Cursor blink OFF |
0x00005000 + DeviceID | 0xFFFF93FF | R&W |  |  |  | Cursor blink ON |
0x00005000 + DeviceID | 0xFFFF94FF | R&W |  |  |  | Display OFF |
0x00005000 + DeviceID | 0xFFFF95FF | R&W |  |  |  | Display ON |
0x00005000 + DeviceID | 0xFFFF96FF | R&W |  |  |  | Backlight OFF |
0x00005000 + DeviceID | 0xFFFF97FF | R&W |  |  |  | Backlight ON |
0x00005000 + DeviceID | 0xFFFFA0FF | R&W |  |  |  | Write Text line 1 |
0x00005000 + DeviceID | 0xFFFF00FF | R&W |  |  |  | Write Text line 2 |


Auspacken, Aufstellung und Transport

Beachten Sie die vorgeschriebenen Lagerbedingungen (siehe "Technische Daten").

Abmessungen und Gewicht der einzelnen Module:

Abmessungen (B x H x T): 19 x 100 x 91 mm (Systemschnittstelle) bis 58 x 100 x 91 mm (Netzteil mit E/A-Schnittstelle)

Gewicht: 80 g (Systemschnittstelle) bis 435 g (Grundmodul)

Auspacken

Gehen Sie beim Auspacken des Gerätes wie folgt vor:
1. Entfernen Sie die Verpackung.
2. Werfen Sie die Originalverpackung nicht weg. Bewahren Sie sie für einen Wiedertransport auf.
3. Überprüfen Sie die Lieferung anhand Ihrer Bestellung auf Vollständigkeit.
4. Bitte bewahren Sie unbedingt die mitgelieferten Unterlagen auf, sie enthalten wichtige Informationen zum Umgang mit Ihrem Gerät.
5. Prüfen Sie den Verpackungsinhalt auf sichtbare Transportschäden.
6. Sollten Sie Transportschäden oder Unstimmigkeiten zwischen Verpackungsinhalt und Ihrer Bestellung feststellen, informieren Sie bitte den Beckhoff Service.

Achtung |
 | Beschädigungsgefahr des Gerätes!

Bei Transporten in kalter Witterung oder wenn das Gerät extremen Temperaturunterschieden ausgesetzt ist, muss darauf geachtet werden, dass sich keine Feuchtigkeit an und im Gerät niederschlägt (Betauung).
Das Gerät ist langsam der Raumtemperatur anzugleichen, bevor es in Betrieb genommen wird. Bei Betauung darf das Gerät erst nach einer Wartezeit von ca. 12 Stunden eingeschaltet werden.

Aufstellen

Die Geräte eignen sich für den Einbau in Schaltschränke.
Die Einbauanleitung finden Sie auf den nächsten Seiten.

Transport durchführen

Trotz des robusten Aufbaus sind die eingebauten Komponenten empfindlich gegen starke Erschütterungen und Stöße. Schützen Sie deshalb Ihren Rechner bei Transporten vor großer mechanischer Belastung. Für den Versand sollten Sie die Originalverpackung benutzen.


Maße

Die Produktreihe CX1000/CX1020 zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein CPU Modul und ein Netzteil sowie die entsprechenden Systemschnittstellen und die Feldbusschnittstellen vorgesehen werden.
Die Gesamtbreite der Anwendung setzt sich aus den einzelnen verwendeten Module zusammen.
Mit einer Höhe von 100 mm entsprechen die Maße der Module exakt denen der Beckhoff Busklemmen. Dadurch und durch die abgesenkten Steckerflächen ist der Einsatz in einem Standard Klemmenkasten von 120 mm Höhe möglich.

CX1000 CPU-Grundmodule:

Das CPU Grundmodul hat die Abmessungen 57 x 100 x 91mm.

CX1000-N00x / CX1020-N0x0 Systemschnittstellen:

Die Systemschnittstellen besitzen eine einheitliche Abmessung von 19 x 100 x 91 mm.

CX1100-000x Netzteile:

CX1100-0001

Netzteil ohne E/A-Schnittstelle

Abmessungen in mm: 45 x 100 x 91

CX1100-0002

Netzteil mit E/A Schnittstelle

Abmessungen in mm: 39 x 100 x 91

CX1100-0003

Netzteil mit E/A-Schnittstelle und IP-Link

Abmessungen in mm: 58 x 100 x 91

CX1100-0004 ( nur mit CX1020 verwendbar)

Netzteil mit E-Bus ( EtherCAT)

Abmessungen in mm: 39 x 100 x 91

CX1100-09x0 USV Modul:

CX1100-0900

Abmessungen in mm: 57 x 100 x 91

CX1100-0910

Abmessungen in mm: 76 x 100 x 91

CX1100-0920

Abmessungen in mm: 95 x 100 x 91

CX1500-Mxxx und CX1500-Bxxx Feldbusanschaltungen

Die Module für die Feldbusanschaltungen besitzen die Abmessung 38 x 100 x 91 mm, unabhängig davon, ob es sich um eine Master- oder Slaveanschaltung handelt.


Mechanischer Zusammenbau des Grundmoduls

Der Einbau der Module erfolgt in drei Schritten:

1. Reihenfolge der Module

Das CPU-Grundmodul mit den werkseitig links angeschlossenen Systemschnittstellen wird auf der rechten Seite um das Netzteil, und auf der linken Seite um die Feldbusanschaltung (Master bzw. Slave), soweit vorhanden, erweitert. Der Anbau einer Feldbusanschaltung wird auf der nächsten Seite beschrieben.

2. Zusammenbau der CPU mit dem Netzteil

Die Befestigung der einzelnen Module untereinander wird durch das einfache Zusammenstecken erreicht (BILD1). Dabei ist zu beachten, dass die Stecker des PC104 Interface nicht beschädigt werden.
Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.

BILD1: Zusammenrasten der Module

3. Aufrasten auf die Hutschiene

Auf der Unterseite der Module befindet sich eine weiße Zuglasche, die mit einem Rastmechanismus verbunden ist. Diese Zuglaschen müssen vor dem Anbringen auf die Tragschiene nach unten gezogen werden. Dieses kann mittels eines Schlitzschraubendrehers und einer leichten Drehung geschehen (BILD4). Nach erfolgreichem Aufrasten auf die Hutschiene (BILD5) müssen die Zuglaschen wieder in die Ausgangsstellung geschoben werden (BILD6).

BILD4: Zuglaschen nach unten ziehen BILD5: Aufrasten auf die Hutschiene

BILD6: Zuglaschen in Ausgangsstellung bringen BILD7: Zuglaschen aus- und wieder eingerastet

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Ausführliche Informationen zur Demontage der CX1000-Konfiguration von der Hutschiene finden Sie auf der Seite Abbau und Entsorgung.

Durch die Absenkung der Frontflächen, welche die Interfaces enthalten, ist der Einbau in einem Standard Klemmenkasten von 120 mm Höhe problemlos möglich.

Einbaulage:

Achtung
Das auf eine Hutschiene montierte CPU Modul darf nur bis Umgebungstemperaturen von 55°C betrieben werden. Die Einbaulage muss so gewählt werden, dass die Kühlung durch die Lüftungsöffnungen in vertikaler Richtung möglich ist. Die Bilder zeigen die erlaubten ( BILD8 & BILD9) sowie eine verbotene Einbaulage (BILD10).

Mindestabstand einhalten!

Beim Einbau ist ein Freiraum von jeweils 30 Millimetern oberhalb und unterhalb einer CX1000 Gerätekombination erforderlich, um eine ausreichende Belüftung des CPU Grundmoduls und des Netzteils zu erreichen.

BILD8: Zulässige Einbaulage BILD9: Zulässige Einbaulage

BILD10: Unzulässige Einbaulage


Mechanischer Anbau der Feldbusanschaltung

Der Anbau einer Feldbusanschaltung erfolgt in mehreren Schritten:

1. Entfernung der Abdeckung am CX1000/CX1020-Grundmodul

Um die Feldbusanschaltung am CX1000/CX1020-Grundmodul befestigen zu können, muss zunächst die Abdeckung am CX1000/CX1020-Grundmodul entfernt werden (BILD1+2). Dieses wird durch einen leichten Druck gegen die Abdeckung erreicht.

BILD1+2: Abdeckung entfernen

2. Zusammenbau der Anschaltung mit der CX1000/CX1020-Konfiguration

Da sich die CX1000-Konfiguration bereits auf der Hutschiene befindet, muss zunächst die Anschaltung auf die Hutschiene gedrückt werden. Dazu ist zuerst das Lösen des Rastmechanismus anhand der weißen Zuglaschen (nach unten ziehen) notwendig.
Die Befestigung der Anschaltung mit der bestehenden CX1000/CX1020-Konfiguration wird durch das einfache Zusammenstecken erreicht. Dabei ist zu beachten, dass der Stecker des PC104 Interface nicht beschädigt wird.
Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen. Am Schluss werden die weißen Zuglaschen wieder in ihre Ausgangsstellung gebracht, damit der Verriegelungsmechanismus einrastet.

BILD3: Zusammenstecken der Module BILD4: Zuglaschen in Ausgangsstellung

3. Abdeckung anbringen

Falls die Anschaltung linksseitig keinen Abschlussdeckel besitzt, wird die vorhin entfernte Abdeckung auf die Anschaltung gedrückt, bis sie hörbar einrastet.

Hinweis:

Wenn sich die CX1000/CX1020-Konfiguration nicht auf der Hutschiene befindet, ist es ist möglich, die Anschaltung zunächst mit der CX1000/CX1020-Konfiguration zu verbinden, wie in BILD3 gezeigt, und danach die gesamten Module auf die Hutschiene aufzurasten.

Hinweis:

Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden.


LEDs CPU-Grundmodul

Anzeige | LED | Bedeutung
 | PWR | Spannungsversorgung Die Power LED leuchtet bei Anschluss an ein Netzteil mit eingeschalteter Spannungsversorgung auf.
 | Link | LAN Link 10 MBit Diese LED leuchtet, wenn die Netzwerkgeschwindigkeit 10 MBit oder 100 MBit beträgt (bei Netzwerkverbindung).
 | 100MBit | LAN Link 100 MBit Diese LED leuchtet, wenn die Netzwerkgeschwindigkeit 100 MBit beträgt (bei Netzwerkverbindung).
 | Activity | Transmit /Receive Packets Diese LED blinkt einmal, wenn Datenpakete im LAN unterwegs sind.
 | HDD | Read/Write Compact Flash Zeigt einen Zugriff auf die CF Karte an.

LED Netzwerkgeschwindigkeit

  • Die LED LINK leuchtet auf, wenn die Netzwerkgeschwindigkeit 10 MBit oder 100 MBit beträgt.
  • Die 100 MBit LED leuchtet nur dann auf, wenn die Netzwerkgeschwindigkeit 100 MBit beträgt.


LEDs Netzteil CX1100-0001

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.


LEDs Netzteil CX1100-0002

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX1000 Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden (siehe auch Kaptitel PC einschalten / ausschalten). Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.


LEDs Netzteil CX1100-0003

Nach dem Einschalten überprüft das Netzteil sofort die angeschlossene Konfiguration der Busklemmen. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED "I/O ERR" signalisiert. Das Blinken der LED "I/O ERR" zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehlercode ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.

Anzeige | LED | Bedeutung
 | Power | Spannungsversorgung Die LED leuchtet grün bei korrekter Spannungsversorgung und rot bei Kurzschluss.
 | I/O Run | Diagnose K-Bus Die grüne LED leuchtet, um den fehlerfreien Betrieb anzuzeigen. Fehlerfrei bedeutet, dass auch die Kommunikation mit dem Feldbussystem fehlerfrei läuft.
 | I/O Error | Diagnose K-Bus Die rote LED blinkt zur Fehleranzeige. Die rote LED blinkt mit zwei unterschiedlichen Frequenzen.

Blinkcode der I/O Error LED

schnelles Blinken | Start des Fehlercodes
erste langsame Sequenz | Fehlercode
zweite langsame Sequenz | Fehlerargument

LEDs zur K-Bus-Diagnose

Fehler-Code | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV Probleme | - Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren - EMV-Maßnahmen ergreifen - Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Netzteils) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung setzen
 | 1 | Überlauf im Code Buffer | Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Software Update des Netzteils notwendig
2 Impulse | 0 | Programmierte Konfiguration, falscher Tabelleneintrag | Programmierte Konfiguration auf Richtigkeit überprüfen
 | n (n > 0) | Tabellenvergleich (Busklemme n) | Falscher Tabelleneintrag
3 Impulse | 0 | K-Bus-Kommandofehler | - Keine Busklemme gesteckt - Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse | 0 | K-Bus-Datenfehler, Bruchstelle hinter dem Netzteil | Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
 | n | Bruchstelle hinter Busklemme n | Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse | n | K-Bus-Fehler bei Register-Kommunikation mit Busklemme n | n-te Busklemme tauschen
9 Impulse | 0 | Checksummenfehler im Programm-Flash | Herstellereinstellung setzen
 | n (n>0) | Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existierte, überein | Herstellereinstellung setzen, damit wird das Boot-Projekt gelöscht.
14 Impulse | n | n-te Busklemme hat das falsche Format | Netzteil erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse | n | Anzahl der Busklemmen stimmt nicht mehr | Netzteil erneut Starten.
16 Impulse | n | Länge der K-Bus-Daten stimmt nicht mehr | Netzteil erneut Starten.

Fehlerargument

Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.

Durch die Beseitigung des Fehlers beendet das Netzteil die Blinksequenz bei manchen Fehlern nicht. Nur durch Ab- und Einschalten der Versorgungsspannung kann das Netzteil neu gestartet werden.

Hinweis:

Die Versorgungsspannung des Netzteils, die zur Spannungsversorgung des CX1000 Systems notwendig ist, darf nicht im laufenden Betrieb unterbrochen werden (siehe auch Kaptitel PC einschalten / ausschalten). Ein Abschalten der Versorgungsspannung des Netzteils bezieht sich hier auf die Spannungsversorgung an den Powerkontakten.


Störungen

Lesen Sie dazu auch das Kapitel Sicherheitshinweise.

Mögliche Störungen und ihre Beseitigung

Bitte geben Sie im Servicefall die Projektnummer Ihres PCs an, welche Sie dem Typenschild entnehmen können.

Die BECKHOFF-Support Nummer:
für Deutschland: 05246/963-157
international: +49-5246/963-157

Störung | Ursache | Maßnahmen
keine Funktion nach Starten des Embedded-PCs | fehlende Stromversorgung des Embedded-PCs andere Ursachen | 1.Sicherung prüfen 2. Anschlussspannung messen, Steckerbelegung prüfen Beckhoff Support anrufen
Der Embedded-PC bootet nicht vollständig | Festplatte beschädigt (z.B. durch Abschalten bei laufender Software), Setupeinstellungen fehlerhaft, andere Ursachen | Setupeinstellungen prüfen Beckhoff Support anrufen
Rechner bootet, Software wird gestartet, aber Steuerung arbeitet nicht einwandfrei | Fehlerursache liegt bei der Software oder bei Anlagenteilen außerhalb des Embedded-PCs | Rufen Sie den Maschinen- oder Softwarehersteller an.
Fehler bei CF Card Zugriff | Fehlerhafte CF Card, fehlerhafter CF Einschub | Mit einer anderen CF Card den CF Einschub überprüfen Beckhoff Support anrufen
Embedded-PC funktioniert nur teilweise oder nur zeitweise | Komponenten im Embedded-PC defekt | Beckhoff Support anrufen


Abbau und Entsorgung

Der Abbau einer CX1000/CX1020-Hardwarekonfiguration erfolgt in 2 Schritten:

1. Demontage von der Hutschiene:

Die weißen Zuglaschen auf der Unterseite aller Module müssen nach unten gezogen werden (BILD1). Dieses kann mittels eines Schlitzschraubendrehers und einer leichten Drehung geschehen. Der Verriegelungsmechanismus, der für die Festigkeit auf der Hutschiene sorgt, öffnet sich (dieser Vorgang ist nicht sichtbar).

Bei Konfigurationen, die ein Netzteil mit E/A-Schnittstellen besitzen, muss zunächst die erste Klemme von der Hutschiene abgelöst werden (BILD2), um die CX1000/CX1020-Konfiguration von der E/A-Hardware zu trennen und somit das Modul von der Hutschiene entfernen zu können (BILD3).

BILD1: Zuglaschen nach unten BILD2: Lösen der E/A-Klemme von der Hutschiene

BILD3: Trennung des Moduls von der Hutschiene

2. Trennung der einzelnen Module:

Vor der Trennung der einzelnen Module untereinander muss der gesamte CX1000/CX1020-Hardwareblock zunächst von der Hutschiene abmontiert werden wie in Schritt 1 beschrieben. Die einzelnen Module lassen sich dann durch den rückseitig angebrachten Trennungsmechanismus voneinander separieren, wie in Bild 4 gezeigt. Dazu wird ein Schlitzschraubendreher der Größe 1,0 x 5,5 x 150 mm in den Verriegelungsmechanismus einführt und mit einer etwa 90 Grad Drehung der Schieber betätigt. Der rückseitige Verriegelungsmechanismus bewirkt eine ca. 2-3mm breite Trennung der mechanischen Einrastung der Module und drückt diese auseinander, so dass die Stecker des PC 104 Interface anschließend vorsichtig auseinander gezogen werden können (BILD5). Module, die nicht voneinander getrennt werden können, haben keinen Schieberschlitz sondern lediglich einen Markierungspunkt (mit oder ohne roten Versieglungslack). Eine Krafteinwirkung an diesen Elementen führt zur Zerstörung.

BILD4: Lösen des Verriegelungsmechanismus BILD5: Trennung der Module

Auf diese Weise lässt sich die CPU vom Netzteil und von den Feldbusanschaltungen trennen.

Hinweis:

Bei Konfigurationen, die ein Netzteil mit E/A-Schnittstellen besitzen, muss zunächst eine Klemme von der Hutschiene abgezogen werden, um die Konfiguration von der E/A-Hardware trennen zu können.

Hinweis:

Vor der Demontage ist der Embedded-PC herunterzufahren und die Spannungsversorgung zu unterbrechen!

Achtung |
 | Das gewaltsame Öffnen der Modulgehäuse (z.B. Entfernen der Deckel) führt zur Zerstörung der Gehäuse.

Entsorgung

Zur Entsorgung muss das Gerät auseinandergebaut und vollständig zerlegt werden.

Altbatterie / Akkumulator-Rücknahme:

Das Gerät enthält einen Akkumulator. Dieser darf nicht in den Hausmüll. Verbraucher sind verpflichtet, Batterien / Akkumulatoren zu einer geeigneten Sammelstelle bei Handel oder Kommune zu bringen. Sie können nach Gebrauch an den bekannten Sammelstellen und auch bei der Beckhoff Automation GmbH unentgeltlich zurückgegeben werden.

Altbatterien / Akkumulatoren enthalten möglicherweise Schadstoffe oder Schwermetalle, die Umwelt und Gesundheit schaden können. Batterien werden wieder verwertet, sie enthalten wichtige Rohstoffe wie Eisen, Zink, Mangan oder Nickel.

Die Umwelt und Beckhoff sagen Dankeschön.

Elektronik-Bestandteile sind entsprechend der nationalen Elektronik-Schrott-Verordnung zu entsorgen.


Zubehör

Compact Flash Karten

Bestellnummer | Beschreibung
CX1900-0023 | 1 GByte Compact Flash Karte Typ I
CX1900-0025 | 2 GByte Compact Flash Karte Typ I
CX1900-0027 | 4 GByte Compact Flash Karte Typ I

Stecker und Adapter

Bestellnummer | Beschreibung
CX1900-0101 | DVI-to-VGA passiver Adapter für den Anschluss von Standard VGA Monitoren: - führt die VGA Signale der DVI-I-Schnittstelle des CX1000-N001 Moduls aus. - DVI-A Stecker, 29-polig (unten), 15-polig (oben) - Gewicht ca. 40 g - Abmessungen (B x H x T) 40 x 42 x 15 mm

Beschriftungsfahnen

Bestellnummer | Beschreibung
CX1900-0200 | Universal Plastiketiketten für das CX1000 System - passt in die dafür vorgesehenen Aussparungen der CX 1000 Komponentengehäuse - Beschriftung kann mit einem X-Y Plotter erfolgen - Format des einzelnen Beschriftungsfeldes: 15 x 5 mm - Material: Plastik (weiß) - Originalherstellerbezeichnung: Murrplastik Typ KMR 5/15, Bestellnummer 86401014


Support und Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.

Beckhoff Support

Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:

  • Support
  • Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
  • umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com

Beckhoff Service

Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:

  • Vor-Ort-Service
  • Reparaturservice
  • Ersatzteilservice
  • Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com

Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.

Beckhoff Firmenzentrale

Beckhoff Automation GmbH & Co. KG

Hülshorstweg 20
33415 Verl
Deutschland

Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com

Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de

Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.


Zulassungen

BECKHOFF Automation: Anhang

Zertifizierungen

Prinzipiell sind alle Produkte der Embedded-PC Familie CE, UL und GOST-R zertifiziert. Da sich aber die Produktfamilie ständig weiterentwickelt, kann hier keine Auflistung angegeben werden. Die aktuelle Auflistung der zertifizierten Produkte kann auf der Internetseite Zertifikate Embedded PC oder www.beckhoff.de unter Embedded-PC nachgelesen werden.


Support

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen garantiert.

Beckhoff Support

Der Beckhoff Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt: weltweiter Support; Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme, umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten.

Hotline: +49(0)5246/963-157

Fax: +49(0)5246/963-9157

E-Mail: support@beckhoff.com

Beckhoff Service

Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen garantiert.

Hotline: +49(0)5246/963-460

Fax: +49(0)5246/963-479

E-Mail: service@beckhoff.com

Weitere Support und Service Adressen entnehmen Sie bitte unseren Internetseiten, unter http:// www.beckhoff.com. Dort befindet sich auch die gesamte Dokumentation der Beckhoff Komponenten.

Sollten Sie Vorschläge oder Anregungen betreffend unserer Dokumentation haben, schicken Sie uns bitte eine E-Mail, mit dem Hinweis auf die Versionsnummer, an Dokumentation@Beckhoff.de.


Abkürzungsverzeichnis

in Vorbereitung....