CU2508 - Echtzeit Ethernet-Port-Multiplier
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation
•
Versionsidentifikation von EtherCAT-Geräten


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version | Kommentar
2.5 | - Kapitel „Technische Daten“ aktualisiert - Kapitel „Technologie“ aktualisiert - Revisionsstand aktualisiert - Strukturupdate
2.4 | - Kapitel „Technologie“ aktualisiert - Revisionsstand aktualisiert - Strukturupdate
2.3 | - Kapitel „Technologie“ aktualisiert - Revisionsstand aktualisiert - Strukturupdate
2.2 | - Kapitel „Firmware Update“ aktualisiert - Revisionsstand aktualisiert - Strukturupdate
2.1 | - Kapitel „Portdefinition TwinCAT 2.11“ aktualisiert - Kapitel „Technische Daten“ aktualisiert - Strukturupdate
2.0 | - Migration
1.8 | - Kapitel "LEDs und Anschlussbelegung" aktualisiert - Update Struktur
1.7 | - Kapitel "Einrichtung unter TwinCAT 2.11" ergänzt
1.6 | - Kapitel "Einrichtung: PROFINET Controller/Device" ergänzt
1.5 | - Kapitel "Technologie" ergänzt
1.4 | - Hinweis zu Kapitel Ethernet/IP Slave ergänzt
1.3 | - Ergänzungen zu RT Ethernet
1.2 | - Ergänzung des aktuellen Firmware Status
1.1 | - Ergänzung Ethernet/IP slave
1.0 | - Korrekturen, 1. Veröffentlichung
0.1 | - vorläufige Dokumentation für CU2508


Versionsidentifikation von EtherCAT-Geräten

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten
Versionsidentifikation von EtherCAT-Geräten
Bezeichnung
Ein Beckhoff EtherCAT-Gerät verfügt über eine 14stellige technische Bezeichnung, die sich zusammensetzt aus
▪
Familienschlüssel
▪
Typ
▪
Version
▪
Revision
Beispiel | Familie | Typ | Version | Revision
EL3314-0000-0016 | EL-Klemme (12 mm, nicht steckbare Anschlussebene) | 3314 (4 kanalige Thermoelementklemme) | 0000 (Grundtyp) | 0016
ES3602-0010-0017 | ES-Klemme (12 mm, steckbare Anschlussebene) | 3602 (2 kanalige Spannungsmessung) | 0010 (Hochpräzise Version) | 0017
CU2008-0000-0000 | CU-Gerät | 2008 (8 Port FastEthernet Switch) | 0000 (Grundtyp) | 0000
Hinweise
▪
die oben genannten Elemente ergeben die technische Bezeichnung, im Folgenden wird das Beispiel EL3314-0000-0016 verwendet.
▪
Davon ist EL3314-0000 die Bestellbezeichnung, umgangssprachlich bei „-0000“ dann oft nur EL3314 genannt. „-0016“ ist die EtherCAT-Revision.
▪
Die Bestellbezeichnung setzt sich zusammen aus
- Familienschlüssel (EL, EP, CU, ES, KL, CX, ...)
- Typ (3314)
- Version (-0000)
▪
Die Revision -0016 gibt den technischen Fortschritt wie z. B. Feature-Erweiterung in Bezug auf die EtherCAT Kommunikation wieder und wird von Beckhoff verwaltet.
Prinzipiell kann ein Gerät mit höherer Revision ein Gerät mit niedrigerer Revision ersetzen, wenn nicht anders z. B. in der Dokumentation angegeben.
Jeder Revision zugehörig und gleichbedeutend ist üblicherweise eine Beschreibung (ESI, EtherCAT Slave Information) in Form einer XML-Datei, die zum Download auf der Beckhoff Webseite bereitsteht.
Die Revision wird seit 2014/01 außen auf den IP20-Klemmen aufgebracht, siehe Abb. „EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Chargennummer und Revisionskennzeichnung (seit 2014/01)“.
▪
Typ, Version und Revision werden als dezimale Zahlen gelesen, auch wenn sie technisch hexadezimal gespeichert werden.
Identifizierungsnummer
Beckhoff EtherCAT Geräte der verschiedenen Linien verfügen über verschiedene Arten von Identifizierungsnummern:
Produktionslos/Chargennummer/Batch-Nummer/Seriennummer/Date Code/D-Nummer
Als Seriennummer bezeichnet Beckhoff im IO-Bereich im Allgemeinen die 8-stellige Nummer, die auf dem Gerät aufgedruckt oder auf einem Aufkleber angebracht ist. Diese Seriennummer gibt den Bauzustand im Auslieferungszustand an und kennzeichnet somit eine ganze Produktions-Charge, unterscheidet aber nicht die Module einer Charge.
Aufbau der Seriennummer: KK YY FF HH
KK - Produktionswoche (Kalenderwoche)
YY - Produktionsjahr
FF - Firmware-Stand
HH - Hardware-Stand
Beispiel mit
Ser. Nr.: 12063A02: 12 - Produktionswoche 12 06 - Produktionsjahr 2006 3A - Firmware-Stand 3A 02 - Hardware-Stand 02
Ausnahmen können im IP67-Bereich auftreten, dort kann folgende Syntax verwendet werden (siehe jeweilige Gerätedokumentation):
Syntax: D ww yy x y z u
D - Vorsatzbezeichnung
ww - Kalenderwoche
yy - Jahr
x - Firmware-Stand der Busplatine
y - Hardware-Stand der Busplatine
z - Firmware-Stand der E/A-Platine
u - Hardware-Stand der E/A-Platine
Beispiel: D.22081501 Kalenderwoche 22 des Jahres 2008 Firmware-Stand Busplatine: 1 Hardware Stand Busplatine: 5 Firmware-Stand E/A-Platine: 0 (keine Firmware für diese Platine notwendig) Hardware-Stand E/A-Platine: 1
Eindeutige Seriennummer/ID, ID-Nummer
Darüber hinaus verfügt in einigen Serien jedes einzelne Modul über eine eindeutige Seriennummer.
Siehe dazu auch weiterführende Dokumentation im Bereich
▪
IP67: EtherCAT Box
▪
Safety: TwinSafe
▪
Klemmen mit Werkskalibrierzertifikat und andere Messtechnische Klemmen
Beispiele für Kennzeichnungen
EL5021 EL-Klemme, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer und Revisionskennzeichnung (seit 2014/01)
EK1100 EtherCAT Koppler, Standard IP20-IO-Gerät mit Seriennummer/ Chargennummer
CU2016 Switch mit Seriennummer/ Chargennummer
EL3202-0020 mit Seriennummer/ Chargennummer 26131006 und eindeutiger ID-Nummer 204418
EP1258-00001 IP67 EtherCAT Box mit Chargennummer/ DateCode 22090101 und eindeutiger Seriennummer 158102
EP1908-0002 IP67 EtherCAT Safety Box mit Chargennummer/ DateCode 071201FF und eindeutiger Seriennummer 00346070
EL2904 IP20 Safety Klemme mit Chargennummer/ DateCode 50110302 und eindeutiger Seriennummer 00331701
ELM3604-0002 Klemme mit eindeutiger ID-Nummer (QR Code) 100001051 und Seriennummer/ Chargennummer 44160201
Weiterführende Informationen
•
Beckhoff Identification Code (BIC)


Beckhoff Identification Code (BIC)

Vorwort [image] Versionsidentifikation von EtherCAT-Geräten [image] Beckhoff Identification Code (BIC)
Beckhoff Identification Code (BIC)
Der Beckhoff Identification Code (BIC) wird vermehrt auf Beckhoff-Produkten zur eindeutigen Identitätsbestimmung des Produkts aufgebracht. Der BIC ist als Data Matrix Code (DMC, Code-Schema ECC200) dargestellt, der Inhalt orientiert sich am ANSI-Standard MH10.8.2-2016.
Beckhoff Identification Code
BIC als Data Matrix Code (DMC, Code-Schema ECC200)
Die Einführung des BIC erfolgt schrittweise über alle Produktgruppen hinweg.
Er ist je nach Produkt an folgenden Stellen zu finden:
▪
auf der Verpackungseinheit
▪
direkt auf dem Produkt (bei ausreichendem Platz)
▪
auf Verpackungseinheit und Produkt
Der BIC ist maschinenlesbar und enthält Informationen, die auch kundenseitig für Handling und Produktverwaltung genutzt werden können.
Jede Information ist anhand des so genannten Datenidentifikators (ANSI MH10.8.2-2016) eindeutig identifizierbar. Dem Datenidentifikator folgt eine Zeichenkette. Beide zusammen haben eine maximale Länge gemäß nachstehender Tabelle. Sind die Informationen kürzer, werden sie um Leerzeichen ergänzt. Die Daten unter den Positionen 1 bis 4 sind immer vorhanden.
Folgende Informationen sind enthalten:
Pos-Nr. | Art der Information | Erklärung | Datenidentifikator | Anzahl Stellen inkl. Datenidentifikator | Beispiel
1 | Beckhoff-Artikelnummer | Beckhoff - Artikelnummer | 1P | 8 | 1P072222
2 | Beckhoff Traceability Number (BTN) | Eindeutige Seriennummer, Hinweis s. u. | S | 12 | SBTNk4p562d7
3 | Artikelbezeichnung | Beckhoff Artikelbezeichnung, z. B. EL1008 | 1K | 32 | 1KEL1809
4 | Menge | Menge in Verpackungseinheit, z. B. 1, 10… | Q | 6 | Q1
5 | Chargennummer | Optional: Produktionsjahr und -woche | 2P | 14 | 2P401503180016
6 | ID-/Seriennummer | Optional: vorheriges Seriennummer-System, z. B. bei Safety-Produkten oder kalibrierten Klemmen | 51S | 12 | 51S678294104
7 | Variante | Optional: Produktvarianten-Nummer auf Basis von Standardprodukten | 30P | 32 | 30PF971, 2*K183
... |  |  |  |  |
Weitere Informationsarten und Datenidentifikatoren werden von Beckhoff verwendet und dienen internen Prozessen.
Aufbau des BIC
Beispiel einer zusammengesetzten Information aus den Positionen 1 bis 4 und 6.
Die Datenidentifikatoren sind zur besseren Darstellung jeweils rot markiert:
BTN
Ein wichtiger Bestandteil des BICs ist die Beckhoff Traceability Number (BTN, Pos.-Nr. 2). Die BTN ist eine eindeutige, aus acht Zeichen bestehende Seriennummer, die langfristig alle anderen Seriennummern-Systeme bei Beckhoff ersetzen wird (z. B. Chargenbezeichungen auf IO-Komponenten, bisheriger Seriennummernkreis für Safety-Produkte, etc.). Die BTN wird ebenfalls schrittweise eingeführt, somit kann es vorkommen, dass die BTN noch nicht im BIC codiert ist.
Hinweis
Diese Information wurde sorgfältig erstellt. Das beschriebene Verfahren wird jedoch ständig weiterentwickelt. Wir behalten uns das Recht vor, Verfahren und Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern. Aus den Angaben, Abbildungen und Beschreibungen in dieser Information können keine Ansprüche auf Änderung geltend gemacht werden.


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Einführung
•
Technische Daten
•
Technologie
•
Start


Einführung

Produktübersicht [image] Einführung
Einführung
CU2508
Echtzeit-Ethernet-Port-Multiplier
Der Echtzeit-Ethernet-Port-Multiplier erlaubt den Anschluss von acht unabhängigen FastEthernet-Ethernet-Netzen (100 MBit/s). Der CU2508 ist mit einem Gigabit-Uplink mit dem PC verbunden.
Der PC kann so mit hoher Performance Daten an den Multiplier übertragen, der sie durch Auswertung eines Telegramm-Präfix dem entsprechenden 100BASE-TX-Port zuordnet und zeitgesteuert mikrosekundengenau versenden kann. Empfangene Frames werden ebenfalls mit einem Präfix inkl. Zeitstempel versehen und an den PC übertragen.
Mit Hilfe eines Treibers stehen aus Sicht des Anwenders acht unabhängige Ports mit vollen Echtzeiteigenschaften zur Verfügung. Anwendung findet der CU2508 in Applikationen, in denen mehrere Ethernet-Ports benötigt werden, die außerhalb des PCs realisiert werden sollen.
TwinCAT 2.11 unterstützt den CU2508 und macht weitere Netzwerkports am PC überflüssig. Für extrem hohe Anforderungen kann z. B. eine EtherCAT-Installation auf bis zu acht Stränge aufgeteilt oder erweitert und so die Performance vervielfacht werden. Die Distributed Clocks der EtherCAT-Stränge werden dabei synchronisiert. Auch eine EtherCAT-Kabelredundanz in Verbindung mit Distributed Clocks lässt sich mit zwei Ports des CU2508 realisieren.
Quick-Links


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Technische Daten | CU2508
Betriebsspannung | 24 (18…30) VDC, 250 mA, 3-polige Anschlussklemme (+, -, PE)
Anzahl Ethernet-Ports | 8 x 100 MBit/s (100BASE-TX) und 1 x 1 GBit/s (1000BASE-T, Uplink)
Ethernet-Interface | RJ 45
Leitungslänge | bis 100 m, mind. CAT5 Twisted-Pair, geschirmt
Diagnose | über LED, Software
Protokolle | abh. von verwendetem CU2508-Treiber TwinCAT: Ethernet TCP/IP; Echtzeitprotokolle: EtherCAT, PROFINET, RT-Ethernet u. a.
TwinCAT Unterstützung | TwinCAT ab Version 2.11R2 (build 2028) Betriebssysteme XP/7/WES und CE/WEC
Potenzialtrennung | 1.500 V
Gewicht | ca. 500 g
zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... + 55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... + 85°C
zulässige relative Luftfeuchtigkeit | 95%, keine Betauung
Abmessungen (B x H x T) | ca. 146 mm x 100 mm x 30 mm
Montage | auf 35 mm Tragschiene nach EN 60715
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Einbaulage | beliebig
Zulassung | CE cULus


Technologie

Produktübersicht [image] Technologie
Technologie
Einführung
Der CU2508 erweitert als möglichst transparenter Port-Multiplier einen GBit-Ethernet-Port an der Steuerung auf 8 FastEthernet-Ports im Feld. Er transportiert IEEE802.3-konforme Ethernet-Frames beliebigen Inhaltes.
Jeder Port des CU2508 sendet und empfängt FastEthernet-Frames (100 MBit, 100BASE-TX) über bis zu 100 m Kupferleitung/RJ45. Der CU2508 erzeugt selbst keine Frames oder verarbeitet ihren Inhalt, sondern er leitet ausschließlich von einem besonderen Software-Treiber an ihn gesendete Frames über seine 8 Ports gezielt weiter an das Feld bzw. leitet aus dem Feld empfangene Frames an den Treiber weiter. Optional ist dabei die hochgenaue zeitliche Information, wann die Frames versendet bzw. empfangen werden.
Der CU2508 verfügt dazu
▪
über den Uplink-GBit-MasterPort (X9) zum Treiber im Controller, der an der Gegenseite einen Gbit-Anschluss benötigt
▪
über 8 10/100 MBit-Downlink-Ports (X1-X8) für den Realtime-Traffic zu den angeschlossenen Feld-Geräten
Ein CU2508-System besteht somit aus dem CU2508-Gerät und dem CU2508-Treiber, z. B. integriert in TwinCAT 2.11R2 oder TwinCAT 3
Das CU2508-System ersetzt nicht Masterimplementationen von Ethernet-basierenden Feldbussen, sondern es tunnelt vorgegebene Datentelegramme über die GBit-Verbindung und versendet die Frames dann zur vorgebenen Zeit. Es verhält sich für die darüber geführten Protokolle transparent, mit Ausnahme des EtherCAT-Protokolls - hier ist ein CU2508-Teilnehmer als erster Slave in der Konfiguration ersichtlich. Jedem real vorhandenen I/O-System auf der Feldseite muss also eine logische Masterkomponente in der Steuerung gegenüberstehen.
Es können mehrere CU2508 je TwinCAT-System eingesetzt werden.
cPrinziptopologie CU2508
Im Folgenden werden einige Teilfunktionen des CU2508 und Betriebsarten beschrieben.
Downlink Port Eigenschaften
Die Grundeinstellung des CU2508 ist für Verwendung mit EtherCAT-Downlinks optimiert, insbesondere für den EtherCAT–IO-Redundanz Betrieb. Deshalb hatten die 8 Downlinks bis inkl. FW11 in der Werkseinstellung die Eigenschaft, ankommende 100Mbit-Frames an den Sender zurückzuspiegeln, wenn der 1GBit-Uplink fehlt, genannt „Auto Link Close“.
Darstellung „Auto Link Close“
Im Nicht-EtherCAT-Betrieb kann diese Eigenschaft hinderlich sein und das darunterliegende Netzwerk irritieren. Deshalb ist sie ab FW12 global für alle Downlink-Ports deaktiviert, so dass im Falle eines Uplink-Verlusts keine Zurücksendung ankommender 100Mbit-Frames stattfindet sondern die Frames im CU2508 „versickern“. Der elektrische Link wird nicht verändert.
ESL-Protokoll
Der Software-Treiber im Controller/Steuerungsgerät/IPC bildet das Gegenstück zum CU2508. Er arbeitet auf einem GBit-Port im Controller und "verpackt" die User-Daten in das EtherCAT Switch Link-Protocol (ESL) bzw. entpackt das ESL-Protokoll vom CU2508 und leitet die Nutzdaten weiter zur Anwendung. Es wird also kein extra Telegramm mit Steuerdaten zum/vom CU2508 für das Handling der Nutzdaten gesendet, sondern die vom Anwenderprogramme erzeugten Nutzdaten werden für die Verbindung zwischen Controller und CU2508 um einige Byte Steuer- und Informationsdaten ergänzt.
Der CU2508-Treiber ist in TwinCAT ab Version 2.11R2 integriert, beachten Sie dazu die Angaben in den Technischen Daten. Das ESL-Protokoll ist offengelegt, siehe Beschreibungsseite. Außerdem ist es in der Wireshark-Installation seit der Version 1.4.2 enthalten.
EtherCAT Systeme am CU2508
Eine mögliche Verwendung des CU2508 ist der Betrieb von mehreren FastEthernet-EtherCAT-Systemen an 1 Port des IPC, also quasi als Port-Vervielfacher. Daraus resultiert auch die Bezeichnung als „Port Multiplier“.
Beim Betrieb von mehreren EtherCAT Systemen an den Ports eines CU2508 sind ggf. zeitliche Effekte zu beobachten die relevant für die Applikation sein können. Dazu im Folgenden einige Erläuterungen.
Der CU2508 unterstützt grundsätzlich die folgenden 3 Betriebsarten. Zum Verständnis sind grundlegende Kenntnisse über die EtherCAT-Betriebsarten und Synchronisierungsmethoden hilfreich.
1.
Standard-Modus: keine Frame-Beeinflussung, kein DistributedClocks
–
Der CU2508 leitet per GBit-ESL ankommende Frames am gewünschten FastEthernet-Port weiter, genauso in Gegenrichtung. Es erfolgt keine zeitliche Steuerung der Ethernet Frames.
–
Somit arbeiten die EtherCAT-Slaves der unterlagerten Systeme frame-getriggert (oder FreeRun) und der Zeitpunkt von Ausgaben ist wesentlich abhängig z.B. von Frameverzögerungen/Jitter.
2.
Zeit-gesteuertes Senden/zeit-gestempeltes Empfangen: mit Frame-Beeinflussung, kein DistributedClocks
–
Der CU2508 leitet per GBit-ESL ankommende Frames am gewünschten FastEthernet-Port zum angeforderten Zeitpunkt weiter, in Gegenrichtung erfolgt eine Zeitstempelung. Es erfolgt also eine zeitliche Steuerung der Ethernet Frames.
–
Frame-getriggerte EtherCAT-Slaves arbeiten somit „jitter-arm“, auch zeitlich „gleich“ zwischen den EtherCAT Systemen.
–
Damit die Frames zeitgesteuert weitergeleitet werden können, ist eine Zwischenspeicherung im CU2508 erforderlich, dies kann u.U. erhebliche Verzögerung bewirken. Die Verwendbarkeit ist bei kurzen Zykluszeiten zu prüfen!
–
Diese Betriebsart wird noch nicht unterstützt (Stand 2019)
3.
DistributedClocks-Modus, keine Frame-Beeinflussung
–
Die weitergeleiteten EtherCAT-Frames unterliegen zeitlicher Beeinflussung durch den sendenden IPC, den CU2508 und die EtherCAT-Slaves.
–
Die Ports X1..8 werden als DistributedClocks - ReferenceClock parametriert
–
Somit arbeiten die EtherCAT-Slaves der unterlagerten Systeme, die DistributedClocks unterstützen, ebenfalls DC-synchron. Das bedeutet, die Ein/Ausgabe-Operationen in diesen Slaves können synchronisiert erfolgen, auch zeitlich „gleich“ zwischen den EtherCAT-Systemen an Port X1..8.
Das Gesamtsystem ist dann im Grunde unabhängig von Frameverzögerungen/Jitter, solange diese nicht so wesentlich werden, dass die DistributedClocks-Regelung beeinträchtigt wird.
–
Diese Methode ist (in Bezug auf EtherCAT-Betrieb) im Endeffekt die sinnvollste, denn
• die Ein/Ausgabeoperationen der EtherCAT-Teilnehmer sind zeitlich am besten definiert
• es werden keine Zeitpuffer im CU2508 nötig
Folgende Aspekte sind zu berücksichtigen um zeitliche Effekte in den Betriebsarten 1 und 3 abschätzen zu können:
▪
Ethernet-Frames haben je nach Dateninhalt eine zeitliche Länge von
–
X1..8 FastEthernet: 7..128µs, InterFrameGap (IFG) 9,6 µs
–
X9 Gbit: 0,7..12 µs, IFG 0,96 µs
▪
Der CU2508 hat aufgrund der unterschiedlichen Transportgeschwindigkeit für jeden Port einen internen verzögernden Datenpuffer
▪
Auf dem GBIT/ESL-Anschluss werden die GBit-Frames für X9 von TwinCAT seriell (hintereinander) gesendet. Die GBit-Framelängen können in Relation zu ggf. kurzen TwinCAT-Zykluszeiten bereits in relevanter Größenordnung liegen!
▪
Sind in TwinCAT mehrere Tasks zu bearbeiten, rechnet TwinCAT diese in der Standard-Einstellung seriell (hintereinander) ab. Dies führt in der Folge dazu, dass die ESL-Frames entsprechend verzögert abgeschickt werden.
Abhilfe schafft die Einstellung „isolated core“ in den RealTime Tasks damit die Tasks parallel bearbeitet werden.
▪
Zu berücksichtigen ist auch die EtherCAT-Framelänge.
Beispiel: Es wird an Port X1 und X2 jeweils ein EtherCAT-System installiert mit je einer EL2202 als Ausgabeklemme. Die Flanken sollen zu Demonstrationszwecken per Oszilloskop nachgemessen werden. Das Bit der jeweils verwendeten Ausgabeklemme liegt im System X1 in einem kurzen 7 µs Frame, im System X2 aber in einem langen 128 µs Frame. Allein dadurch wird das Signal in System X2 121 µs später ausgegeben.
Abhilfe schafft die Verwendung von DistributedClocks, siehe oben.
(Die Position der Ausgabe-Daten im EtherCAT-Frame spielt üblicherweise keine Rolle da Ausgabedaten erst nach vollständiger Passage des Frames am Ausgabegerät nach Kontrolle der Checksumme ausgegeben werden.)
▪
Die Verzögerungen, die durch das Management des CU2508 verursacht werden, betragen typischerweise
–
Im Downlink
Gbit X9 to FastEthernet X1..4: tFE = 1 µs
Gbit X9 to FastEthernet X5..8: tFE = 1,6 µs

CU2508 Downlink Delay
–
Im Uplink
FastEthernet X1..X4 to Gbit X9: tGE = 0,7 µs
FastEthernet X5..X8 to Gbit X9: tGE = 1,1 µs
CU2508 Uplink Delay
–
Diese Verzögerungen sind also relativ unbedeutend im Vergleich zu den o.a. anderen Faktoren. Was aber anhand der Grafik sofort ins Auge fällt, ist die Bedeutung der Framelänge und der nötigen Zwischenspeicherung im Uplink.
CU2508 als EtherCAT Slave
Jeder Downlink-Port des CU2508 kann als eigenes "EtherCAT Gerät" konfiguriert werden, s. Kapitel Einrichtung EtherCAT-Gerät. In diesem Fall stellt der CU2508-Port den ersten EtherCAT-Teilnehmer im System dar. Er ist Distributed-Clocks-fähig und kann damit als ReferenceClock im Strang dienen.
Durch Kombination zweier solcher EtherCAT Ports unter Verwendung des (kostenpflichtigen) Supplements "TwinCAT Kabelredundanz" ist die Kombination von EtherCAT-Kabelredundanz und Distributed-Clocks-Funktion möglich.
Zeitgesteuertes Senden/Empfangen (in Vorbereitung)
Die Frameweiterleitung im CU2508 kann einer exakten Zeitkontrolle durch die lokale Uhr unterworfen werden:
▪
der Treiber bzw. die Anwenderapplikation gibt an, zu welchem Zeitpunkt und über welchen Downlink-Port ein Frame vom CU2508 versendet werden soll.
Diese Angaben werden vom Treiber als Zusatzinformation jedem Frame angefügt.
▪
jeder vom CU2508 an einem Downlink-Port empfangene Frame wird um Empfangsinformationen ergänzt (Empfangsport, Zeitpunkt) und über den Uplink zum Controller weitergeleitet.
Die lokale Hardware-basierte Uhr im CU2508 steuert dann das Versenden der Frames mit einer hohen zeitlichen Güte. Dadurch erlaubt der CU2508 den Aufbau eines Realtime-Ethernet-Netzwerkes (TwinCAT Publisher/Subscriber, Ethernet/IP, Profinet, ...) auch wenn das Steuergerät keine harte Echtzeit in der Versendung der Protokolldaten gewährleisten kann. Das Steuergerät muss jedoch die Daten ausreichend schnell anliefern bzw. abnehmen können.
Die Zeitsteuerung nutzt das vom EtherCAT Distributed Clocks System bekannte 64-Bit-Zeitformat: Auflösung 1 ns, beginnend ab 1.1.2000 00:00 und damit ausreichend für ~584 Jahre
Die Zeitstempelinformationen (Senden und Empfangen) werden vorläufig nur vom CU2508-Treiber ausgewertet und stehen der Anwenderapplikation nicht zur Verfügung.
Als Beginn eines Ethernet-Frames wird der SFD (Start of Frame Delimiter) nach IEEE802.3-Standard gewertet.
EoE und TCP/IP
Der CU2508 ist über die GBit-Schnittstelle mit dem IPC verbunden. Diese Ethernet-Schnittstelle tritt im Betriebssystem/Windows des IPC mit ihren Eigenschaften (IP-Adresse, IP-mask etc.) auf. Aus der Sicht des Betriebssystems gibt es also "nur" diesen einen Netzwerkanschluss an den Telegramme gesendet oder von dem empfangen werden kann. Der CU2508-Treiber kann nun Datenverkehr der Betriebssystemebene entweder an einen dezidierten CU2508-Port durchleiten oder in den virtuellen EtherCAT-EoE-"Switch" einspeisen. Vergleiche dazu auch die Dokumentation der EL6601/EL6614. Die Auswahl wird über die Einstellung im System Manager getroffen. Über "TCP/IP Port" kann entweder der bestimmte CU2508-Port oder allgemein EoE ausgewählt werden.
Siehe dazu insbesondere die TCP/IP-Hinweise.
Unterschiedlicher IP-Datenverkehr je nach Einstellung
Anwendungen
Die oben beschriebenen Funktionen lassen die Verwendung des CU2508 u.a. für folgende Anwendungen zu:
▪
Multi-EtherCAT Adaper
Es können bis zu 8 eigenständige EtherCAT-Systeme erstellt werden.
▪
Synchronisierte EtherCAT Systeme
Wird der CU2508 als ReferenceClock gewählt, werden die am CU2508 angeschlossenen EtherCAT-Systeme mit gleicher synchronisierter Zeitbasis betrieben.
▪
EtherCAT Kabelredundanz
Je 2 Downlink-Ports des CU2508 können zu einem kabelredundanten EtherCAT-System zusammengefasst werden. Damit werden weniger Ethernet-Ports an der Steuerung belegt, nur noch ein GBit-Ethernet-Port wird für den Uplink benötigt. Es sind bis zu 4 kabelredundante EtherCAT-Systeme möglich. Der CU2508 wird bei der Steuerung im Schaltschrank platziert, trennungsgefährdete I/O-Kabelverbindungen werden dann redundant im Ringschluss aus dem Schaltschrank geführt.
Verwendung CU2508 als EtherCAT Kabelredundanz Sternpunkt
▪
EtherCAT Kabelredundanz mit Distributed Clocks
Durch die gemeinsame Zeitbasis des CU2508 sind auch EtherCAT Slaves, die Distributed Clocks benötigen, im Redundanzfall weiterhin der Synchronisierung unterworfen.
▪
TCP/IP Nutzung ohne Echtzeit
Am CU2508 kann ein Downlink-Port als Nicht-Echtzeit-EthernetPort konfiguriert werden, oder der CU2508 arbeitet im Ethernet over EtherCAT (EoE) - Verbund und leitet aus den angeschlossenen EtherCAT-Systemen TCP/IP-Frames weiter.
Verwendung CU2508 als Ethernet Multi-Protokoll Handler mit EtherCAT und TCP/IP
▪
Echtzeit-Feldbus an Nicht-Echtzeit-Steuerung
Wenn ein Ethernet-basierender Feldbus eine verlässliche Konstanz in Bezug auf das Versenden der Kommunikationstelegramme erfordert, ist ein geringer Jitter in den zyklischen Operationen der Steuerung gefordert. Vermag eine performante Steuerung zwar die zyklische Operationen ausreichend häufig (= geforderte kurze Zykluszeit) bearbeiten können, der Jitter, d.h. der regelmäßige Abstand zwischen den Zyklen aber unzulässig hoch liegen, kann das CU2508-System als Echtzeit-Framehandler den konstanten Abstand im Frameversenden bereitstellen, wenn die neuen Daten ausreichend rechtzeitig im CU2508 vorliegen.
Verwendung CU2508 als EtherCAT Echtzeit-Umgebung
Einschränkungen bestehen derzeit (TwinCAT 2.11/3.1, FW10) noch bzgl.
▪
externe Synchronisierung des CU2508
Die Einflussnahme auf die interne CU2508-Uhr befindet sich noch in Vorbereitung.
▪
Profinet
▪
BACnet
▪
zeitstempelgesteuerte Versendung/Empfangen von Frames
Die Implementierung dieser und weiterer Protokolle befindet sich in Vorbereitung.
Datenumsatz in den unterlagerten EtherCAT-Strängen
Die Ports 1 und 5 sind ab FW07 und ESI-Revision -0018 für EtherCAT-Stränge mit besonders hohem Datenumsatz mit einem vergrößerten Daten-Zwischenspeicher von 16 kByte statt sonst 8 kByte ausgestattet.
„Hoher Datenumsatz“ wird erzeugt durch IO-Systeme mit vielen zyklischen Daten, z.B. wenn viele Teilnehmer (über 100) oder/und Teilnehmer mit großem Datenbedarf (z.B. analoge Oversampling-Klemmen) eingesetzt werden.
Wird ein „großes“ IO-System im EtherCAT-Redundanz-Modus betrieben, ist es zweckmäßig dazu die Ports 1 und 5 zu benutzen.
Die vorgefunden Speicher-Situation wird fallweise von TwinCAT mit „Cu2508 fifo sizes…“ gemeldet:
Message zu CU2508 fifo sizes


Start

Produktübersicht [image] Start
Start
Zur Inbetriebsetzung
▪
montieren Sie den CU2508 wie im Kapitel Montage und Verdrahtung beschrieben
▪
konfigurieren Sie den CU2508 in TwinCAT wie im Kapitel Inbetriebnahme beschrieben.
Des Weiteren werden die applikationstypischen Feldgeräte an den Downlink-Ports benötigt.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Abmessungen
•
Montage und Demontage
•
Verkabelung
•
LEDs und Anschlussbelegung
•
UL-Hinweise


Abmessungen

Montage und Verdrahtung [image] Abmessungen
Abmessungen
Abmessungen ohne Stecker (B x H x T)
▪
CU2508: ca. 146,5 mm x 100 mm x 38 m
Platzbedarf im Schaltschrank
•
Die RJ45-Stecker erhöhen die Tiefe in Abhängigkeit ihrer Bauform und des verwendeten Ethernet-Kabels.
•
Berücksichtigen Sie oberhalb der Tragschiene zusätzlich ca. 10 mm Höhe um den Switch auf die Schiene aufrasten zu können.
Abmessungen CU2508


Montage und Demontage

Montage und Verdrahtung [image] Montage und Demontage
Montage und Demontage
Die Switches CU2xxx werden mit Hilfe einer auf 35 mm Hutschiene (Tragschiene nach EN 60715) auf der Montagefläche befestigt.
Montage
▪
Montieren Sie die Tragschiene an der vorgesehenen Montagestelle.
▪
Hängen Sie den Switch mit der Feder an der unteren Seite seines Rastflansches in die Tragschiene ein.
▪
Drücken Sie den Switch nach oben (1).
▪
Drücken Sie die obere Seite des Switches (2) gegen die Montagefläche bis er auf der Tragschiene einrastet.
▪
Schließen Sie die Kabel an.
Montage
Demontage
▪
Entfernen Sie alle Kabel.
▪
Drücken Sie den Switch nach oben (3).
▪
Ziehen Sie die obere Seite des Switches (4) von der Montagefläche weg.
Demontage
Weiterführende Informationen
•
Diagnose-LEDs


Diagnose-LEDs

Montage und Verdrahtung [image] Montage und Demontage [image] Diagnose-LEDs
Diagnose-LEDs
Der CU2508 verfügt über 4 LED-Anzeigen zur Diagnose.
Frontansicht CU2508
Der CU2508 verfügt vorläufig über keine weitere Diagnose.


Verkabelung

Montage und Verdrahtung [image] Verkabelung
Verkabelung
Spannungsversorgung
Pinbelegung der Federzugklemme
CU20xx_PowerClamp
culus-logo
UL Anforderungen
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
•
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden! Diese Anforderungen gelten für die Versorgung aller Buskoppler, Netzteilkemmen, Busklemmen und deren Power-Kontakte.
culus-logo
UL Anforderungen
Zur Einhaltung der UL-Anforderungen dürfen die EtherCAT-Komponenten nicht mit unbegrenzten Spannungsquellen verbunden werden!
Ethernet
Pinbelegung der RJ45-Buchsen
Pinbelegung der RJ45-Buchsen


LEDs und Anschlussbelegung

Montage und Verdrahtung [image] LEDs und Anschlussbelegung
LEDs und Anschlussbelegung
Der CU2508 verfügt über 4 LED-Anzeigen zur Diagnose.
Frontansicht CU2508
LEDs
LED | Farbe | Bedeutung
RUN | grün | Diese LED gibt den Betriebszustand des CU2508 bei Betrieb als EtherCAT-Gerät wieder
 |  | aus | Zustand der EtherCAT State Machine: INIT = Initialisierung der Klemme oder BOOTSTRAP
 |  | blinkend | Zustand der EtherCAT State Machine: PREOP = Funktion für Mailbox-Kommunikation und abweichende Standard-Einstellungen gesetzt
 |  | Einzelblitz | Zustand der EtherCAT State Machine: SAFEOP = Überprüfung der Kanäle des Sync-Managers und der Distributed Clocks. Ausgänge bleiben im sicheren Zustand
 |  | an | Zustand der EtherCAT State Machine: OP = normaler Betriebszustand; Mailbox- und Prozessdatenkommunikation ist möglich
Int Act | grün | blinkt, wenn Datenverkehr auftritt
Power | grün | an, wenn das Gerät korrekt bestromt wird
Error | gelb | es ist ein Fehler aufgetreten (siehe Kapitel "Fehlerbehandlung und Diagnose")
X1 - X8 | grün | Link/Activity
 | gelb | Interner Buffer Overflow, Alignment Fehler erlannt
Anschlussbelegung
Klemmstelle | Kommentar
X0 | 24 VDC Spannungsversorgung: +, GND und Schirmanschluss (Funktionserde)
X1..X8 | DownLink Port FastEthernet 10/100 MBit
X9 | UpLink Port GBit Ethernet
Schirmkonzept
Der PE/Schirmanschluss ist mit dem Metallgehäuse verbunden. Er ist nur als Funktionserde gegen Störungseinflüsse zu verwenden.
Schirmkonzept CU2508


UL-Hinweise

Montage und Verdrahtung [image] UL-Hinweise
UL-Hinweise
culus-logo
Application
The modules are intended for use with Beckhoff’s UL Listed EtherCAT System only.
culus-logo
Examination
For cULus examination, the Beckhoff I/O System has only been investigated for risk of fire and electrical shock (in accordance with UL508 and CSA C22.2 No. 142).
culus-logo
For devices with Ethernet connectors
Not for connection to telecommunication circuits.
Grundlagen
UL-Zertifikation nach UL508. Solcherart zertifizierte Geräte sind gekennzeichnet durch das Zeichen:


Inbetriebnahme TwinCAT 2.11

Inbetriebnahme TwinCAT 2.11
Inbetriebnahme TwinCAT 2.11
Weiterführende Informationen
•
Einrichtung unter TwinCAT 2.11
•
Portdefinition TwinCAT 2.11
•
Beckhoff Netzwerkvariablen EAP


Einrichtung unter TwinCAT 2.11

Inbetriebnahme TwinCAT 2.11 [image] Einrichtung unter TwinCAT 2.11
Einrichtung unter TwinCAT 2.11
Bevor die Downlink-Ports des CU2508 mit Funktionen belegt werden können, muss der CU2508 als MultipleProtocolHandler in der Konfiguration angelegt werden.
Das Online-Scannen des CU2508 ist vorläufig nur bei angeschlossenen EtherCAT-Systemen an Downlink-Ports möglich. Dann sind die Hinweise bzgl. der ESI-XML-Dateien in der EtherCAT-Portdefinition zu beachten.
Einrichtung
Im TwinCAT System Manager durch Rechtsklick ein neues Gerät anfügen.
Neues Gerät anfügen
Wählen Sie den "Real-Time Ethernet Adapter (Multiport Protocal Handler)" aus.
Auswahl des MultiplerProtocollHandler
Wählen Sie nun den für den CU2508 benutzten GBit-Uplink-Port aus. Es können nur Ports gewählt werden, auf denen der Beckhoff-Echtzeit-Treiber installiert/aktiviert ist. Wenn die Auswahl des Ports später getroffenen werden soll, kann auch <none> gewählt werden.
Auswahl des verwendeten GBit-Ethernet-Ports an der Steuerung
Ist der Echtzeit-Treiber noch nicht installiert, muss zuvor der Treiber installiert werden, z. B. über die System Manager Optionen.
Installation des Beckhoff Echtzeit Treibers
In den Adaptereigenschaften des MultipleProtocolHandlers sind nun für den weiteren Betrieb wichtige Eigenschaften aufgeführt, z. B. die MAC- und die IP-Adresse des GBit-Netzwerk-Ports.
Adapter-Angaben des verwendeten GBit-Ethernet-Ports
Name | Erläuterung
Description | Name des Adapters im Betriebssystem (auf mehreren identischen PC-System gleichlautend)
Device Name | Eindeutiger Adaptername (auf mehreren identischen PC-System unterschiedlich)
MAC Address | MAC-Adresse des Hardware-Adapters; nicht veränderbar
IP Address | IP-Adresse des Hardware-Adapters; veränderbar über die Windows Betriebssystemeinstellungen "Netzwerkverbindung"
Freerun Cycle | Im ConfigMode wird der Adapter mit dieser Zykluszeit betrieben, d.h. üblicherweise 250 Zyklen/sek.
Promiscuous Mode | Wenn aktiviert, werden die Ethernet-Frames aus dem Echtzeitkontext in die Windows NDIS-Schicht kopiert und können so von Netmon/Wireshark gelesen werden
Virtual Device Names | deaktiviert: Angabe "Device Name" wird von TwinCAT zur Identifizierung des Netzwerkadapters verwendet. Damit ist eine TwinCAT Konfiguration nicht auf andere PC-System ohne Veränderung übertragbar. aktiviert: Angabe "Description" wird von TwinCAT zur Identifizierung des Netzwerkadapters verwendet. Damit ist eine TwinCAT Konfiguration auf andere PC-System ohne Veränderung übertragbar, wenn dort ein Adapter dieses Namens vorhanden ist.
Die Anzahl der benötigten Ports ist in der Port-Maske einzustellen (A). Auch die TCP/IP-Betriebsart ist einzustellen (B), für einen reinen EtherCAT-Betrieb ist "via EoE" einzustellen. Siehe dazu die Hinweise zu TCP/IP-Einstellungen. In jedem Fall ist für den CU2508 an diesem GBit-Port das ESL-Protokoll zu aktivieren (C).
Adapter-Anzahl
Der CU2508 verfügt über keine gesonderte Diagnosevariablen, da er als möglichst transparentes Infrastrukturgerät konzipiert ist.
Im Folgenden können nun
▪
einzelne Downlink-Ports mit Protokollen belegt werden
▪
das TCP/IP-Verhalten des CU2508 eingestellt werden
Diagnose
Im TwinCAT System Manager sind einige Informationen zum Online-Betrieb einsehbar.
Statistik-Angaben
Name | Erläuterung
Send Utilization (%) | Auslastung der GBit-ESL-Übertragung in Senderichtung R: Echtzeitdaten, N: Nicht-Echtzeitdaten
Recv Utilization (%) | Auslastung der GBit-ESL-Übertragung in Empfangsrichtung R: Echtzeitdaten, N: Nicht-Echtzeitdaten


Portdefinition TwinCAT 2.11

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11
Portdefinition TwinCAT 2.11
Weiterführende Informationen
•
Einrichtung: Gerät EtherCAT
•
Einrichtung: Gerät EtherCAT mit Kabelredundanz
•
Einrichtung: Gerät Ethernet und TCP/IP Hinweise
•
Einrichtung: Realtime-Ethernet (Publisher/Subscriber, EAP push)
•
Einrichtung: Realtime-Ethernet (BK90xx, ADS/RAW, EAP polling)
•
Einrichtung: PROFINET Controller/Device


Einrichtung: Gerät EtherCAT

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11 [image] Einrichtung: Gerät EtherCAT
Einrichtung: Gerät EtherCAT
Inhaltsverzeichnis
• Hinweise zum EtherCAT Gerät
• Einrichtung eines EtherCAT Gerätes
• Konfigurationseinstellungen unter TwinCAT 2.11R2
• Distributed Clocks Verhalten
• EoE-Einstellungen
Ein Downlink-Port des CU2508 wird als EtherCAT-Gerät eingerichtet. Die korrekte Einrichtung des CU2508-Gerätes wird vorausgesetzt.
Hinweise zum EtherCAT Gerät
▪
Der CU2508-Downlink-Port tritt als erster regulärer EtherCAT Slave auf. Er kann optional die Distributed Clocks Reference Clock in diesem EtherCAT System darstellen. Der Port verfügt über keine ansteuerbaren I/O.
▪
Alle CU2508-Downlink-Ports sind untereinander synchronisiert.
▪
Ein zweiter CU2508-Port kann als Ringschluss zur EtherCAT-Kabelredundanz genutzt werden. Dann muss der primäre EtherCAT-Anschluss auf einen ungeraden CU2508-Port gelegt werden (X1, X3...), der sekundäre Redundanzadapter auf den nachfolgenden geradzahligen CU2508-Port (siehe dazu das entsprechende Kapitel Gerät EtherCAT mit Kabelredundanz).
▪
Das Versenden von EtherCAT Frames nimmt der CU2508 im Durchleitbetrieb ohne Zeitstempel vor.
Einrichtung eines EtherCAT Gerätes
Im EtherCAT-Betrieb ist der verwendete CU2508-Downlink-Port nicht transparent, sondern erscheint als Distributed Clocks fähiger EtherCAT Slave in der Konfiguration. Dadurch kann er als ReferenceClock auftreten. Im weiteren ist der EtherCAT Slave aber nicht parametrier- oder adressierbar.
Wie für jedes EtherCAT-Gerät geltend, sollten auch für den CU2508 die aktuellen ESI-xml-Dateien im TwinCAT-System vorliegen. Dies gilt für Offline-Erstellung der Konfiguration wie für Scannen im Online-Betrieb. Die Dateien (insbesondere die "Beckhoff CUxxxx.xml") können im Downloadbereich auf der Beckhoff Webseite bezogen werden. Sie sind unter "..\TwinCAT\Io\EtherCAT\ "abzulegen.
Aktualisierung der ESI-XML-Dateien
Sollte im Online-Betrieb beim Scannen der Geräte am CU2508 folgendes Hinweisfenster erscheinen: (siehe Abb. Hinweisfenster "online description" ist ein Update der o.g. Datei erforderlich:
Klicken sie auf "No", schließen Sie das System-Manager-Fenster, installieren Sie die aktuellen ESI-xml-Dateien und erstellen Sie die Konfiguration in einem neu geöffneten System-Manager-Fenster.
Hinweisfenster "online description"
Erstellung Konfiguration
Die einfache Möglichkeit der Konfigurationserstellung durch Scannen der realen Hardware ist erst möglich, wenn in der Konfiguration manuell ein EtherCAT-Gerät auf einen CU2508-Port gelegt wurde.
Konfigurationserstellung unter TwinCAT 2.11R2
Anlegen EtherCAT Device
Durch Rechtsklick auf I/O-Device -> Append Device kann ein Device EtherCAT angelegt werden.
Anlegen EtherCAT Device
Auswahl „EtherCAT“ Device
Der gewünschte Downlink-Port des CU2508 kann nun ausgewählt werden.
Auswahl CU2508 Port
Das Gerät "Device 2 (EtherCAT)" ist nun laut Adapter-Angabe nicht mit einem physikalischen Ethernet-Port der Steuerung, sondern mit einer logischen Adapter Referenz des CU2508 verbunden. Diese Zuweisung kann auch nachträglich geändert werden. Die Freerun-Zykluszeit im TwinCAT ConfigMode wird hier für den Adapter angegeben.
Adaptereinstellung EtherCAT Device
Erstellung Konfiguration
Ab diesem Zustand ist auch ein Scannen der EtherCAT-Konfiguration möglich.
Anlegen CU2508 Box
Der CU2508-Downlink-Port tritt als EtherCAT-Slave auf und kann gescannt oder manuell angelegt werden.
Anfügen CU2508 EtherCAT Slave
Beim manuellen Anlegen ist der "CU2508 Ethernet Port" CU2508-0000 auszuwählen. Die Checkbox "ExtendedInformation" zeigt die Revisionsnummern an, hier -0000 (Abb. Auswahl „CU2508 Ethernet Port“).
Wird in der Search-Maske "CU2508" angegeben, reduziert sich die Übersicht auf das gesuchte Device.
Abb. 7: Auswahl "CU2508 Ethernet Port"
Nun sind an die CU2508-Box weitere EtherCAT Slaves anfügbar.
Anfügen weiterer EtherCAT Slaves
Distributed Clocks Einstellungen
Alle CU2508-Downlink-Ports sind untereinander synchronisiert und können als ReferenceClock im jeweiligen EtherCAT-Strang auftreten. In der Default-Einstellung ist der CU2508-Port jedoch nicht als Distributed Clocks fähig markiert, somit wird unter TwinCAT der erstnächste, nachfolgende Distributed Clocks fähige Slave als ReferenceClock ausgewählt. In jedem Fall ist der CU2508-Port der 1. Slave im jeweiligen Strang.
EtherCAT Distributed Clocks Reference
Wenn der CU2508-Port in einem System als ReferenceClock benutzt werden soll, ist die Einstellung "Use as potential ReferenceClock" zu ändern, s. Abb. CU2508 Slave - Distributed Clocks Einstellung.
CU2508 Slave - Distributed Clocks Einstellung
Synchronisierte EtherCAT-Systeme
Wenn mehrere EtherCAT-Systeme an CU2508-Ports synchronisiert mit gleicher Zeitbasis betrieben werden sollen, ist bei den entsprechenden "CU2508 Box" das Flag "Use as potential Reference Clock" zu setzen.
Eine externe Synchronisierung auf eine andere Zeitbasis ist dann nicht möglich.
Die interne Uhr im CU2508 arbeitet eigenständig und wird nur vom CU2508-Treiber verwaltet.
EoE-Einstellungen (Ethernet-over-EtherCAT)
Werden in einem unterlagerten EtherCAT-System Teilnehmer mit EoE-Support eingesetzt, beeinflusst dies die Einstellungen des EoE-Switch im CU2508, wenn dieser für EoE-Transport konfiguriert ist. Beachten Sie hierzu die Hinweisseiten zum TCP/IP-Verkehr.
Wenn solche Teilnehmer im EtherCAT System vorliegen, muss
▪
der VirtualEthernetSwitch aktiviert sein ("enable")
▪
"Connect to TCP/IP Stack" kann aktiviert sein
▪
die Anzahl "MaxFrames" und "Max MAX IDs" kann erhöht werden, wenn Durchsatzprobleme festgestellt werden
EoE-Einstellungen Ether-CAT Device
Werden mehrere EtherCAT-System EoE-Teilnehmer eingesetzt, erhöht dies die Einstellungen des CU2508-EoE-Switch.
EoE-Einstellungen CU2508


Einrichtung: Gerät EtherCAT mit Kabelredundanz

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11 [image] Einrichtung: Gerät EtherCAT mit Kabelredundanz
Einrichtung: Gerät EtherCAT mit Kabelredundanz
Wenn ein Downlink-Port des CU2508 als EtherCAT-Gerät eingerichtet wurde, kann ein weiterer Port als 2. EtherCAT-Port zum Zwecke der Kabelredundanz verwendet werden.
Das Supplement "TwinCAT Kabelredundanz" dient dazu, bei einer unvorhergesehenen Kommunikationsunterbrechung durch Kabelbruch das EtherCAT-System weiter im Betrieb zu halten. Das System ist 1-Fehler-tolerant. Dies wird erreicht durch Ringschluss des EtherCAT-Systems zur Steuerung. Treten mehr als 1 Fehler auf, fallen Slaves aus der Kommunikation. Sie werden erst wieder aufgenommen, wenn alle Verbindungen wiederhergestellt sind.
TwinCAT EtherCAT Kabelredundanz
Beachten Sie dazu die prinzipiellen Erläuterungen dazu in der EtherCAT Systemdokumentation.
Die Kombination der Technologien EtherCAT Kabelredundanz und Distributed Clocks ist unter Verwendung des CU2508 möglich.
Hinweise EtherCAT Kabelredundanz
▪
Es sind nur die Downlink-Portkombination X1/2, X3/4, X5/6 und X7/8 für EtherCAT Kabelredundanz zulässig.
▪
Bei Aktivierung der EtherCAT Kabelredundanz werden automatisch die verwendeten CU2508-Ports als Distributed Clock ReferenceClock gesetzt. Damit kann die Synchronisierung der Teilnehmer auch bei Medienbruch aufrechterhalten werden.
▪
Beim EtherCAT StartUp mit Distributed-Clocks-Teilnehmern muss der kabelredundante Ring geschlossen und durchgehende Kommunikation möglich sein, sonst ist keine Synchronisierung möglich.
▪
Eine externe Distributed Clocks Synchronisierung eines solchen EtherCAT Systems ist vorläufig nicht möglich.
▪
Die Supplement-Lizenz "EtherCAT Kabelredundanz" ist kostenpflichtig und für Windows XP (NT, 7, WES) und CE (WEC) verfügbar.
Sie kann im Download-Bereich auf der Beckhoff Webseite heruntergeladen werden.
Einrichtung EtherCAT Kabelredundanz
Die EtherCAT-Konfiguration ist wie im Kapitel "Einrichtung: Gerät EtherCAT" beschrieben an einem CU2508-Downlink-Port zu erstellen. Die sich dadurch ergebende Topologie kann durch den Button Topologie im Gerät EtherCAT angezeigt werden, s. Abb. Anzeige einfache EtherCAT Topologie.
Anzeige einfache EtherCAT Topologie
In den folgenden Schritten sind festzulegen
▪
der steuerungsseitige Redundanzadapter, hier am CU2508
▪
der feldseitige Redundanzadapter am letzten EtherCAT Slave
Die Angabe des EtherCAT Redundanz Ports erfolgt im Gerät EtherCAT, erweiterte Einstellungen.
Angabe Redundanz-Port
Angabe | Bedeutung
Off | keine EtherCAT Kabelredundanz
Second Adapter | physikalischer Adapter/Ethernet Port der Steuerung
Adapter Reference | logischer Adapter wie z. B. im CU2508
Anzahl Ports
In den Einstellungen des CU2508-Adapters müssen entsprechend viele Ports als verfügbar gesetzt werden.
Nach Festlegung des Redundanz-Adapters ist zu überprüfen, ob vom System Manager der richtige EtherCAT-Slave-Port als feldseitiger Anschlusspunkt ausgewählt wurde, s. Abb. Angabe feldseitiger Redundanz-Port.
Angabe feldseitiger Redundanz-Port
Die korrekte Auswahl kann in der Topologie-Ansicht überprüft werden.
Kontrolle Topologie mit EtherCAT Kabelredundanz


Einrichtung: Gerät Ethernet und TCP/IP Hinweise

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11 [image] Einrichtung: Gerät Ethernet und TCP/IP Hinweise
Einrichtung: Gerät Ethernet und TCP/IP Hinweise
Inhaltsverzeichnis
• Erläuterung TCP/IP v4
• Anwendung CU2508
• Einstellung dedizierter TCP/IP-Port
• Einstellung EoE
Erläuterung TCP/IP v4
TransmissionControlProtocol/InternetProtocol (TCP/IP) wird ein Bundle an Verfahren aus den 1970er Jahren genannt, das eine paketvermittelte Weiterleitung von Daten definiert. Dieses Vermittlungsverfahren wird im zeitgenössischen Kommunikationsalltag insbesondere auf der Ethernet-Physik (z. B. FastEthernet, GBit) und der dort üblichen hardware-nahen MAC-Adressierung eingesetzt. Die Grundlagen dieses Sets sind
▪
Pakete von Nutzerdaten aus 64..1486 Byte (Sonderformen nicht unüblich) werden von einem Sender an einen (Unicast) oder mehrere (Multicast, Broadcast) Empfänger gesendet.
▪
Quell- und Zieladresse bestehen bei IPv4 aus je 4 Byte, getrennt durch einen Punkt, z. B. "192.168.1.1" oder 123.001.002.001".
Hinweis: IPv6 erweitert den Adressraum um weitere 2 Bytes und löst IPv4 mittelfristig ab.
▪
Es muss keinen direkte physikalische (Kabel-) Verbindung zwischen Sender und Empfänger bestehen, sondern intelligente Paketvermittler analysieren Quell- und Zieladresse und leiten die Pakete weiter (Stichworte: routing und switching). Dadurch treten Verzögerungen und ggf. Datenverluste auf.
▪
Das IP ist eine bidirektionale rückbestätigte Kommunikation, weil der Empfänger an den Sender den Erhalt von Daten quittiert. Dies bewirkt weitere Kommunikationslast und erhöhte Transportzeit. Verlorene Daten können so automatisch wiederholt werden.
▪
Statt IP kann auch UDP (User Datagram Protocoll) verwendet werden. Es arbeitet ohne Rückbestätigung, verlorene Daten müssen dann auf einer höheren Kommuniaktionsebene erneut angefordert werden. Dafür ist die benötigte Zeit für eine Datenübermittlung geringer.
Das Betriebssystem Windows verwaltet die TCP/IP-Kommunikation mit seinen Ethernet-Adaptern in der so genannten NDIS-Netzwerkvermittlungsschicht. Die Adaptereinstellungen sind über die Windows Systemsteuerung->Netzwerkeinstellungen oder das Windows CE CXconfig Tool von Beckhoff zugänglich.
Diese Umstände machen eine TCP/IP-gestützte Kommunikation ungeeignet für eine Anwendung mit höherem Echtzeitanspruch, dafür sehr geeignet für flexible (veränderliche) Verbindungen über viele Hubs (Zwischenstationen) bei beliebig hohem Datenaufkommen.
Anwendung CU2508
Sollen über den CU2508 TCP/IP-Frames (ohne Echtzeitanspruch) übertragen werden, sind dazu 2 Methoden verfügbar:
▪
ein Port des CU2508 wird als dedizierter TCP/IP Port deklariert.
Er arbeitet somit für das Betriebssystem als "Verlängerung" des Ports, an dem der CU2508 angeschlossen ist, mit den MAC- und IP-Angaben des verwendeten GBit-Ports laut Betriebssystemangaben.
Unter TwinCAT mit seinem integrierten CU2508-Treiber wird dieser Port dann mit der Windows NDIS-Vermittlungsschicht im Windows Betriebssystem verbunden. Ein Echtzeit-Verkehr ist über diesen Port dann nicht mehr möglich, das CU2508-System arbeitet als transparenter Frametransporter.
▪
der CU2508 wird allgemein auf EoE-Betrieb (Ethernet-over-EtherCAT) eingestellt, "via EoE".
Dann wird im CU2508-System der integrierte virtuellen EoE-Switch aktiviert und die Verbindung zu den am CU2508 angeschlossenen EtherCAT-Systemen hergestellt. Ethernet-Frames werden bei EoE innerhalb von azyklischen EtherCAT-Telegrammen per Mailbox-Verfahren transportiert, bei Überlänge ggf. fragmentiert. Als Interface EtherCAT/Ethernet kann die EL6601 oder EL6614 verwendet werden.
Es werden für die Adressierung die MAC- und IP-Angaben des verwendeten GBit-Ports laut Betriebssystemangaben verwendet.
Diese Verfahren ist nur für angeschlossene EtherCAT-Kreise anwendbar.
Die Einstellung wird im Reiter Ports für den CU2508 vorgenommen und verändert nicht die Arbeitsweise des CU2508, sondern nur die Behandlung von TCP/IP-Frames im CU2508-Treiber.
Einstellung TCP/IP-Betriebsart
Es ist nicht möglich, den CU2508 als eigenständigen Switch mit Weiterleitungsregeln nach MAC- (Switch) oder IP-Regeln (Router) zu betreiben.
Einstellung dedizierter TCP/IP-Port
Der angegebene CU2508-Port 100MBit/FastEthernet) wird dann direkt mit der Windows-Netzwerkvermittlungsschicht verbunden, ein Echtzeitbetrieb dieses Ports ist nicht mehr möglich. Auf den anderen CU2508-Ports ist dann kein freier TCP/IP-Netzwerkverkehr möglich.
Hinweise
▪
Es wird die IP- und MAC-Adresse des verwendeten GBit-Ports zur TCP/IP-Kommunikation benutzt. Adressraum/Subnetzmaske müssen also mit den adressierten Geräten übereinstimmen.
Im Beispiel in Abb. Deklarierung eines CU2508-Downlink-Ports als TCP/IP-Port liegt der Adressraum unter der IP-Maske 255.255.0.0, alle Geräte müssen also eine IP-Adresse aus dem Raum 192.168.x.x besitzen.
▪
Diese Einstellungen werden über die Windows Systemsteuerung -> Netzwerkeinstellungen des Adapters geändert. Unter Windows CE ist das CXconfig Tool einzusetzen.
▪
Der CU2508 arbeitet transparent, es können alle Verfahren zur Adressvergabe (DHCP, BootP, ..) eingesetzt werden.
▪
Der Durchsatz ist abhängig von der Auslastung des Downlink-Ports und der Windows Netzwerkvermittlungsschicht.
Deklarierung eines CU2508-Downlink-Ports als TCP/IP-Port
Einstellung EoE
Der virtuelle EoE-Switch des CU2508-Treibers ist im CU2508-Ethernet-Adapter angebunden und den Switch-Reiter des RT-Ethernet-Adapters zugänglich. Der VirtualEthernetSwitch wird automatisch aktiviert, wenn in den unterlagerten EtherCAT-Systemen Geräte zum Einsatz kommen die Ethernet-over-EtherCAT benutzen - entsprechend wird die Anzahl der max. Frames und Ports angepasst.
Hinweise
▪
Es wird die IP-Adresse des verwendeten GBit-Adapters und die Subnetzmaske zur Kommunikation benutzt. Die EoE-Teilnehmer (Drucker, Scanner, Remote PC, ..) müssen also in diesem Bereich ihre Adresse besitzen.
▪
Der Durchsatz ist abhängig u.a. von der EtherCAT Zykluszeit, Anzahl EoE-Teilnehmer und Auslastung der einzelnen Verbindungen. Es sind dazu entsprechende Hinweise in den Dokumentation der EoE-Teilnehmer zu beachten.
▪
Das EoE-System kann über den Schalter "Connect to TCP/IP Stack" (Abb. Datenfluss bei Verwendung CU2508 als EoE Switch, A)an die NDIS-Schicht angeschlossen werden.
▪
IP routing ist eine betriebssystemeigene Funktion, IP-Telegramme auch zwischen Netzen zu vermitteln, die nicht im selben Subnetz liegen. Also z. B. zwischen den Teilnehmern 192.168.1.1 und 172.168.1.1, die jeweils in der Maske 255.255.0.0 liegen.
Mit "IP enable Router" (Abb. Datenfluss bei Verwendung CU2508 als EoE Switch, B) wird diese Funktion aktiviert. Sie steht auch unter Windows CE (CXconfig Tool) zur Verfügung.
Datenfluss bei Verwendung CU2508 als EoE Switch
Für die EoE-Vermittlung sind die Switch-Einstellungen im Systemmanager zugänglich, s. Abb. Einstellungen EoE-Switch. Die Grenzwerte werden automatisch bei Konfigurationserstellung an die Teilnehmertypen und -anzahl angepasst.
Einstellungen EoE-Switch
Bezeichnung | Erläuterung
Max. Ports | Anzahl der Ports des virtuellen Switches. Jedes EoE-Gerät (z. B. EL6601, AX5000) in den unterlagerten EtherCAT-Systemen belegt einen Port.
Max Frames | Max. Anzahl der zwischengespeicherten Ethernet-Frames. Kann bei auffälligen Durchsatzengpässen erhöht werden.
Max MAC Ids | In der internen Switch-Look-Up-Tabelle gespeicherte MAC-Adressen der angeschlossenen Geräte. Muss größer als die maximal an allen Systemen jemals angeschlossenen Ethernet-Geräte sein.
Connect to TCP/IP Stack | Verbindet den EoE-Switch mit der internen Windows-NDIS-Netzwerkschicht IP-Bereich muss dabei übereinstimmen
IP Enable Router | Diese Funktion wird vom Windows Betriebssystem gestellt und ist über die Registry, bei embeddedCX-Systemen unter Windows CE/WEC über das CX-config-Tool zugänglich. Wenn aktiviert, vermittelt die NDIS-Netzwerkschicht auch IP-Pakete, deren IP-Adresse nicht in der Subnetzmaske übereinstimmen.


Einrichtung: Realtime-Ethernet (Publisher/Subscriber, EAP push)

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11 [image] Einrichtung: Realtime-Ethernet (Publisher/Subscriber, EAP push)
Einrichtung: Realtime-Ethernet (Publisher/Subscriber, EAP push)
Inhaltsverzeichnis
• Hinweise zum Gerät
• Einrichtung des Gerätes
Hinweise zum Gerät
▪
Zum Betrieb eines CU2508-Downlink-Ports als Publisher/Subscriber-Device von EAP-Realtime-Ethernet-Telegrammen ("Netzwerkvariablen") ist ein EAP-Adapter in der Konfiguration anzulegen.
▪
Die allgemeinen Hinweise zum EAP/Publisher/Subscriber-Verfahren sind zu beachten.
▪
Das EAP (EtherCAT Automation Protocoll) wird hier im sog. Push-Modus betrieben im Gegensatz zum sog. Polling-Modus für flexible Datenübertragung.
▪
Zum Betrieb masterseitig ist mindestens TwinCAT 2.11R3 erforderlich.
Einrichtung des RealtimeEthernet-Devices
Zur Einrichtung ist wie üblich ein Real-Time Ethernet-Adapter anzulegen.
Anlegen neues Gerät
Auswahl des Adapters für EAP
Wenn nicht alle Geräte angeboten werden, kann über TargetType die Zielplattform gewählt werden.
Für den CU2508 wird dann lediglich als Ethernet-Adapter nicht ein tatsächlicher Port des PC, sondern ein virtueller Adapter des CU2508 gewählt.
Auswahl des Ethernet Adapters
Die Anzahl der zur Auswahl stehenden Ports (hier: 4) ist abhängig von den Einstellungen des CU2508-Gerätes (siehe dort).
Anfügen der Ethernet-Geräte
Im Folgenden können nun die benötigten Ethernet-Koppler/Boxen/Antriebe manuell angefügt oder gescannt werden. Vor einem Scann sollte TwinCAT einmal im Config/FreeRun-Modus neu gestartet werden.


Einrichtung: Realtime-Ethernet (BK90xx, ADS/RAW, EAP polling)

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11 [image] Einrichtung: Realtime-Ethernet (BK90xx, ADS/RAW, EAP polling)
Einrichtung: Realtime-Ethernet (BK90xx, ADS/RAW, EAP polling)
Inhaltsverzeichnis
• Hinweise zum Gerät
• Einrichtung des Gerätes
Hinweise zum Gerät
▪
Zum Betrieb eines CU2508-Downlink-Ports als EAP-Realtime-Ethernet-Schnittstelle für IO-Geräte (BK90xx, EK90x) ist ein EAP(poll)-Adapter in der Konfiguration anzulegen.
▪
Das EAP (EtherCAT Automation Protocoll) wird hier im sog. Polling-Modus betrieben
▪
Zum Betrieb masterseitig ist mindestens TwinCAT 2.11R3 erforderlich.
Einrichtung des RealtimeEthernet-Devices
Zur Einrichtung ist wie üblich ein Real-Time Ethernet-Adapter anzulegen.
Anlegen neues Gerät
Auswahl des Gerätes für BK90xx und andere
Für den CU2508 wird dann lediglich als Ethernet-Adapter nicht ein tatsächlicher Port des PC, sondern ein virtueller Adapter des CU2508 gewählt.
Auswahl des zu benutzenden Ports des CU2508
Die Anzahl der zur Auswahl stehenden Ports (hier: 7) ist abhängig von den Einstellungen des CU2508-Gerätes (siehe dort).
Anfügen der Ethernet-Geräte
Im Folgenden können nun die benötigten Ethernet-Koppler/Boxen/Antriebe manuell angefügt oder gescannt werden. Vor einem Scann sollte TwinCAT einmal im Config/FreeRun-Modus neu gestartet werden.


Einrichtung: PROFINET Controller/Device

Inbetriebnahme TwinCAT 2.11 [image] Portdefinition TwinCAT 2.11 [image] Einrichtung: PROFINET Controller/Device
Einrichtung: PROFINET Controller/Device
Das Echtzeitprotokoll PROFINET lässt sich mit dem CU2508 nutzen. Sie können das Device (Slave) oder auch das Contoller (Master) Supplement verwenden. Es kann allerdings immer nur ein Controller oder Device verwendet werden, wenn sich diese in einem Netzwerk befinden. Sind die Netzwerke physikalisch getrennt, können auch mehrere Controller oder Device Supplements mit einem CU2508 verwendet werden. Dies resultiert daraus, dass ein CU2508 nur eine MAC-Adresse verwendet. Mehrere PROFINET-Segmente funktionieren nur dann, wenn die MAC-Adresse in einem Netzwerksegment eindeutig ist und keine Verbindung zu den anderen Netzwerken besteht.
Verfügbarkeit
Diese Funktion kann ab TwinCAT 2.11R3 Build 2234 genutzt werden.
Einstellung des RT-Ethernet Adapters
Setzen Sie die untere Einstellung unter dem Karteireiter "Ports" (Radio Button "EtherCAT Switch Link Protocol"), alle anderen Einstellungen belassen Sie auf der Default-Einstellung.
Auswahl der „Virtual Port“ - Einstellung
Einstellung des Adapters beim PROFINET Device oder Controller
Sobald Sie den CU2508 als Multiple Protocol Handler im System und die verwendeten Ports eingeschaltet haben, können Sie beim Controller oder auch beim Device unter dem Karteireiter "Adapter" einen "Adapter Referent" auswählen. Tragen Sie hierfür den Port ein, über den Sie PROFINET betreiben wollen.
Auswahl des „Adapter Referent“
Weitere Besonderheiten sind beim CU2508 nicht zu beachten; Sie können wie gewohnt fortfahren.


Beckhoff Netzwerkvariablen EAP

Inbetriebnahme TwinCAT 2.11 [image] Beckhoff Netzwerkvariablen EAP
Beckhoff Netzwerkvariablen EAP
Weiterführende Informationen
•
Einführung
•
Konfiguration vom Publisher
•
Konfiguration vom Subscriber
•
Beckhoff Netzwerk Variablen - Einstellungen


Einführung

Inbetriebnahme TwinCAT 2.11 [image] Beckhoff Netzwerkvariablen EAP [image] Einführung
Einführung
Netzwerkvariablen sind beliebige Variablen, die zwischen PC/CX1000 mit TwinCAT zyklisch ausgetauscht werden können. Es können Variablen mit beliebigen, auch komplexen, Datentypen ausgetauscht werden. Es wird das Publisher/Subscriber Modell verwendet. Zur hochdeterministischen Kommunikation muss der Echtzeit-Ethernet Treiber für TwinCAT installiert sein.
Publisher/Subscriber Modell
Beim Publisher/Subscriber Modell stellt der Publisher Variablen zur Verfügung. Subscriber können sich für eine Variable einschreiben. Der Publisher kann die Variable einem Subscriber, mehreren Subscribern oder allen Subscribern zur Verfügung stellen. Bei Broadcast wird die Variable allen PCs zur Verfügung gestellt, bei Multicast einigen Ausgewählten und bei Unicast einem einzigen ausgesuchten PC. Ein Subscriber kann gleichzeitig auch Publisher sein. Damit kann auch eine bidirektionale Datenverbindung hergestellt werden.
Publisher/Subscriber Modell
Unicast
Der Publisher stellt die Netzwerkvariable nur einem einzigen ausgesuchten PC zur Verfügung.
Multicast
Der Publisher stellt die Netzwerkvariable einigen ausgesuchten PCs zur Verfügung.
Broadcast
Der Publisher stellt die Netzwerkvariable allen PCs zur Verfügung.


Konfiguration vom Publisher

Inbetriebnahme TwinCAT 2.11 [image] Beckhoff Netzwerkvariablen EAP [image] Konfiguration vom Publisher
Konfiguration vom Publisher
Im TwinCAT System Manager wird unterhalb des Gerätes RT-Ethernet eine neue Box für den Publisher eingefügt.
Einfügen einer Publisher Box
Unterhalb des Gerätes RT-Ethernet muß für einen Publisher eine einsprechende Box angefügt werden.
Einfügen über Publisher Box
Einfügen einer Netzwerkvariablen
Unterhalb der Box kann man dann Netzwerkvariablen einfügen. Dazu ist es nötig einen Namen (im Beispiel nCounterPub) und einen Datentyp (im Beispiel UINT32 entsprechend UDINT) anzugeben.
Einfügen einer Netzwerkvariablen
Unterhalb der jetzt eingefügten Variablen sind Eingänge und Ausgänge angelegt worden.
Anzeige der Ein- und Ausgänge der eingefügten Publisher Box
Der FrameState Eingang unterhalb der Box gibt Auskunft über den momentanen Status der versendeten Ethernet Frames.
Folgende Werte sind für den FrameState möglich:
Kurzbeschreibung | Wert | Beschreibung
Not sent (frame skipped) | 0x0001 |
Error (frame oversized) | 0x0001 | Die maximale Größe eines Ethernet Frames ist überschritten worden. Die verknüpfte Variable muss kleiner gewählt werden.
Im FrameCtrl Ausgang unterhalb der Box kann ein Control Wort geschrieben werden.
Folgende Werte sind für das FrameCtrl möglich:
Kurzbeschreibung | Wert | Beschreibung
Disable sending | 0x0001 | Das Senden des Frames wird unterbrochen. Erst wenn der Wert wieder auf 0 ist, beginnt das Senden des Frames erneut.
Der VarState Eingang unterhalb der Netzwerkvariablen gibt Auskunft über den momentanen Status der Netzwerkvariablen.
Folgende Werte sind für den VarState möglich:
Kurzbeschreibung | Wert | Beschreibung
Not sent (variable skipped) | 0x0001 |
Im VarCtrl Ausgang unterhalb der Netzwerkvariablen kann ein Control Wort geschrieben werden.
Folgende Werte sind für das FrameCtrl möglich:
Kurzbeschreibung | Wert | Beschreibung
Disable publishing | 0x0001 | Das Senden der Netzwerkvariablen wird unterbrochen. Erst wenn der Wert wieder auf 0 ist, beginnt das Senden der Netzwerkvariablen erneut.
Verknüpfungen
Die Netzwerkvariable des Publishers kann mit jeder beliebigen Ausgangsvariablen des passenden Datentyps verknüpft werden. Im Beispiel wird die Netzwerkvariable mit einer Ausgangsvariablen einer SPS verknüpft.
Verknüpfung der Netzwerkvariable mit einer Ausgangsvariable der SPS


Konfiguration vom Subscriber

Inbetriebnahme TwinCAT 2.11 [image] Beckhoff Netzwerkvariablen EAP [image] Konfiguration vom Subscriber
Konfiguration vom Subscriber
Im TwinCAT System Manager wird unterhalb des Gerätes RT-Ethernet eine neue Box für den Subscriber eingefügt.
Einfügen einer Subscriber Box und Verbindung der Netzwerkvariablen
Unterhalb des Gerätes RT-Ethernet muss für einen Subscriber eine einsprechende Box angefügt werden.
Einfügen Subscriber Box nach RT-Ethernet Gerät
„Insert Box“ Dialog - Auswahl und Benennung der Subscriber Box (Box1)
Unterhalb der Subscriber Box wird dann eine Netzwerkvariable angelegt.
Anlegen der Netzwerkvariable unterhalb der Subscriber Box
Einfügen Netzwerk Variable
Die Verbindung zu einer Variablen eines Publishers kann automatisch hergestellt werden. Hierzu ist der Publisher Computer zu suchen. In einer Liste werden alle Variablen dieses Publishers aufgelistet.
„Import Network Variable“ Dialog - Darstellung Variablen des Publishers
Unterhalb der jetzt eingefügten Variablen sind Eingänge und Ausgänge angelegt worden.
Darstellung der angelegten Ein- und Ausgänge
Der FrameState Eingang und der FrameCtrl Ausgang unterhalb der Box geben Auskunft über den momentanen Status bzw. Control der empfangenen Ethernet Frames. FrameState und FrameCtrl sind reserviert und werden momentan nicht unterstützt.
Der VarState Eingang und der VarCtrl Ausgang unterhalb der Netzwerkvariablen geben Auskunft über den momentanen Status bzw. Control der empfangenen Netzwerkvariablen. VarState und VarCtrl sind reserviert und werden momentan nicht unterstützt.
Qualität der Netzwerkvariablen
Die Qualität einer Netzwerkvariablen wird auf der Subscriber Seite beurteilt. Hierzu stehen zwei Eingangsvariablen unterhalb der Netzwerkvariablen zur Verfügung. Die Variable Quality liefert einen Zähler in 100 µs Auflösung. Der Zählerwert zeigt an, wie lange die Variable zu spät eintrifft. Das untere Beispiel zeigt den online Wert von Quality, nach Ziehen des Netzwerksteckers (Anstieg des Zählers) und erneutem Neuverbinden (Zählerstand 0).
Online Wert von Quality, nach Ziehen des Netzwerksteckers und erneutem Neuverbinden.
Neben der Quality Variablen wird die CycleIndex Variable bei jedem Publisher Zyklus inkrementiert.
Inkrementierung der CycleIndex Variablen


Beckhoff Netzwerk Variablen - Einstellungen

Inbetriebnahme TwinCAT 2.11 [image] Beckhoff Netzwerkvariablen EAP [image] Beckhoff Netzwerk Variablen - Einstellungen
Beckhoff Netzwerk Variablen - Einstellungen
Mit den Beckhoff Netzwerkvariablen (NWV) können zyklisch oder azyklisch Daten zwischen Windows-basierten PC verschickt werden. In einem Teilnehmer als Publisher (Sender) deklariert, wird eine solche Netzwerkvariable auf der Gegenseite von einem mit dem gleichen Typ deklarierten Subscriber (Abonnent) empfangen. Dieser Datenverkehr ist dem Namen nach netzwerkbasiert und setzt in seiner Konfiguration direkt auf den verwendeten Protokollen auf.
Zur Auswahl stehen dabei:
▪
MAC: Es wird ein ISO-Layer-2-Frame mit einer Absender- und Empfänger-MAC-Adresse verschickt, Ethertype 0x0806. Ein IP-Teil mit Ziel-IP-Adresse (z. B. 192.168.0.1) ist nicht enthalten. Deshalb kann das Telegramm über einen Switch, normalerweise aber nicht über einen Router weiterverarbeitet werden.
MAC bedeutet Media Access Control und steht hier für die (eindeutige) Hardware-Adresse, die jedes Ethernet-Gerät ab Herstellung hat. Der Ethernet-Port eines Beckhoff-PC könnte z. B. die MAC-Kennung 00:01:05:34:05.84 haben - "00:01:05" ist die Beckhoff-Kennung, der Rest bei der Herstellung gewählt. Über die Quell/Source-MAC und die Ziel/Destination-MAC-Adresse ist der Weg eines jeden Ethernet-Telegramm zwischen 2 Ethernet-Kabelenden bestimmt.
Das Ethernet-Telegramm wird durch den Ethertype x88A4 als Beckhoff Echtzeit-Ethernet identifiziert - als "Echtzeit Ethernet-Telegramm" (RT-Ethernet) wird es am regulären Windows-TCP-Stack vorbeigeschleust und bevorzugt d.h. "sofort" über den angegebenen Ethernetport des PC versendet.
Es ist einstellbar, ob das gesendete Telegramm von allen (Broadcast), vielen (Multicast) oder einem einzigen Subscriber (Unicast) empfangen werden soll.
▪
UDP/IP: Der Empfänger wird über einen zusätzlichen IP-Header im Ethernet-Telegramm identifiziert, der UDP-Ethernet-Frame kann damit über einen Router weiterverarbeitet werden.
Auch hier stehen Broad-, Multi- und Unicast zur Verfügung und das Ethernet-Telegramm wird durch den Ethertype 0x88A4 als Beckhoff Echtzeit-Ethernet identifiziert und als RT-Protokoll im TwinCAT-PC behandelt.
Als verbindungsloses Protokoll verlangt UDP im Gegensatz zu TCP keine Empfangsbestätigung der Nachricht, der Publisher weiß also nicht ob der Subscriber die Nachricht empfangen hat. Deshalb wird zur Gegenstellenüberwachung von TwinCAT das ARP-Protokoll eingesetzt.
Über diese Adressierungsarten kommt das Telegramm mit den Prozessdaten beim Empfängergerät (Netzwerkport) an. Im Ethernet-Gerät/TwinCAT wird die Zuordnung mehrerer transportierter Prozessdaten dann über eine "Variable ID" hergestellt
Alle zu verwendenden Netzwerkvariablen müssen vor der Benutzung im System Manager deklariert werden.
Folgende Eingriffsmöglichkeiten stehen dann während des Betriebs zur Verfügung:
▪
das Versenden einer konfigurierten Netzwerkvariable kann dynamisch gesperrt werden
▪
die Ziel-IP oder Ziel-MAC kann dynamisch verändert werden
▪
Die Variablen-ID "Variable ID" kann dynamisch verändert werden
▪
der NWV-Inhalt kann verändert werden, nicht aber der Umfang (Bitgröße)
Diagnosevariablen auf Publisher- und Subscriberseite geben über die Verbindungsqualität Auskunft.
Bei der Verwendung von Netzwerkvariablen sind die zeitlichen Randbedingungen der verwendeten Netzwerkarchitektur zu berücksichtigen: Geswitcht (MAC-Adressierung) können rd. 10 ms Kommunikationszyklus und darunter erreicht werden, geroutet (IP-Adressierung) fallweise auch einige 100 ms.
Diagnosevariable "Quality"
Wenn die verarbeitenden Tasks mit unterschiedlichen Zykluszeiten arbeiten oder vom Anwender der DataExchangeDivider verändert wird, ist das bei der Auswertung der Diagnosevariablen entsprechend zu berücksichtigen - ein langsamer Publisher (z. B. 100 ms) führt bei einem schnellen Subscriber (z. B. 10 ms) zu einer schlechten Verbindungsqualität im Sinne der Diagnosevariable "Quality".
Ebenso ist zu berücksichtigen, wenn das Versenden eines Publishers dynamisch zeitweise gesperrt wird. Der Subscriber registriert dann eine schlechte Quality.
Diagnosevariable "CycleIndex"
Beachten Sie die unteren Hinweise um zu entscheiden, ob die Variable CycleIndex von Ihnen bedient werden muss.
Grundlagen zu Beckhoff Netzwerkvariablen
▪
Quality:
Zeit in [100 µs], um die diese NWV zu spät beim Publisher ankam.
Bezogener Ankunftsort:
Eingangsprozessabbild des TwinCAT-Systems
Bezogene Ankunftszeit:
Zeitpunkt, wenn im nächsten Zyklus das Eingangsabbild geladen wird

Hinweis:
Die angezeigte "Verspätung" wird deshalb so fein skaliert ermittelt, weil die NWV-Verwaltung zyklusunabhängig direkt vom IO-Treiber verwaltet wird. Ungeachtet dessen werden die Daten einer um einige Prozent der Zykluszeit zu spät angekommene NWV erst im nächsten Task-Zyklus mit dem Lesen des Eingangsprozessabbildes berücksichtigt.

Hinweis EL6601/EL6614:
Auch bei Verwendung der EL66xx ist der Ankunftszeitpunkt der NWV dann, wenn die Daten im Eingangsprozessabbild des RT-Gerätes vorliegen, nicht wenn sie bei der EL66xx oder im Eingangsabbild des EtherCAT-Gerätes ankommen.
Zusammenhang Quality und verspätet angekommenen Netzwerkvariable
▪
Variable ID
Die Variablen-ID (16 Bit) dient zur globalen Identifizierung der einzelnen Prozessdaten - deshalb darf innerhalb eines TwinCAT-Devices eine ID in der Gruppe der Publisher oder Subscriber nicht mehrmals verwendet werden, s. Abb. Beispielhafte Kommunikation über Netzwerkvariablen: Publisher 1 und 2 auf PC1 müssen unterschiedliche ID (10 und 8) haben, in Publisher 2 und Subscriber 1 darf aber jeweils eine ID = 8 verwendet werden.
Auswahl der Variablen-ID
Um eine eindeutige Zuordnung zu erreichen wird empfohlen, für jede Datenübertragung zwischen zusammenhängenden PCs unterschiedliche IDs zu verwenden.
Begründung: in Abb. Beispielhafte Kommunikation über Netzwerkvariablen erhält PC2/Subscriber2 nicht nur die vorgesehene ID=8-Variable von PC1/Publisher2, sondern, da als Broadcast (!) gesendet, auch die NWV von PC3/Publisher1. Eine Unterscheidung ist in PC2 dann nicht mehr möglich!
▪
Cycle Index
Der 16 Bit Cycle Index ist ein Zähler, der vom Publisher mit den Daten mitgesendet wird. Üblicherweise wird er mit jeder Sendung inkrementiert und lässt so einen Rückschluss auf eine ununterbrochene Übertragung zu. Er ist auf der Subscriber-Seite als CycleIndex auslesbar. Dabei unterscheidet sich sein Auftreten je nach Publisher-Plattform:
–
Publisher auf einem PC: die Variable CycleIndex ist nicht sichtbar und wird autoamtisch zyklisch vom System Manager inkrementiert
–
Publisher auf einer EL66xx: die Variable CycleIndex ist sichtbar und muss vom Anwender inkrementiert/bedient werden, damit sie auf der Subscriber-Seite ungleich 0 ist.
Beispielhafte Kommunikation über Netzwerkvariablen
Datendarstellung auf unterschiedlichen Plattformen
Bitte beachten Sie, dass einfache wie komplexe Daten (WORD, ARRAYs, REAL, STRING, benutzerdefinierte Strukturen) auf unterschiedlichen Plattformen intern unterschiedlich dargestellt werden! X86-Plattformen arbeiten im Byte-Alignment, andere (ARM) im 2- oder 4-Byte-Alignment
Das bedeutet, wenn eine komplexe Struktur in je einem x86/PC-PLC-Projekt und einem ARM-PLC-Projekt angelegt wird, sie jeweils eine andere effektive Größe und einen anderen inneren Aufbau haben kann.
In der Abb. Beispiel für unterschiedliche Größe und Aufbau der Struktur im PC und CX ist die Struktur im CX (und damit die dort anzulegende Netzwerkvariable) größer als im PC, auch passen die Word- und Real-Variablen nicht zueinander da im PC auf jeder Byte-Position eine Variable beginnen kann, im CX nur an jeder geradzahligen.
Empfehlung zum Aufbau von Strukturen, gleichlaufend auf beiden Endgeräten
- Zuerst alle 4-Byte-Variablen (müssen auf einer durch 4 teilbaren Adresse liegen)
- dann alle 2-Byte-Variablen (müssen auf einer durch 2 teilbaren Adresse liegen)
- dann alle 1-Byte-Variablen
Weiter Empfehlungen
- Wenn STRING(x) verwendet wird, dann gilt das „EndOfString“-Null ebenfalls als Zeichen, somit muss x+1 durch 4 teilbar sein
- Obige Regeln gelten auch für Unter-Strukturen.
Bitte beachten Sie dazu die Hinweise im Infosys, Abschnitt Struktur.
Verwendung von Busklemmen-Controllern (BCxxxx, BXxxxx)
Da auf Busklemmen-Controllern (BCxxxx, BXxxxx) die Darstellung von Fließkommazahlen (REAL) von der im x86 abweicht, können diese nicht übertragen werden. Für vorzeichenbehaftete Werte können z. B. „SINT“ verwendet werden.
Beispiel für unterschiedliche Größe und Aufbau der Struktur im PC und CX
Einstellungen im System Manager
Erscheinungsbild der Variablen
Je nach verwendeter Plattform (PC oder EL66xx) stellen sich Publisher/Subscriber unterschiedlich dar. Ein Publisher/Subscriber kann angelegt werden.
•
auf einer PC-Netzwerkschnittstelle, s. Abb. Einstellungen Publisher - RT Ethernet
•
auf einer EL66xx, s. Beckhoff Netzwerk Variablen - Einstellungen
Folgende Einstellungen können im Beckhoff System Manager TwinCAT 2.10 build 1328 vorgenommen werden:
Publisher, Box
Einstellungen Publisher - RT Ethernet
Einstellungen zum RT-Ethernet:
▪
MAC-Broadcast: Sendung geht an alle Netzwerkteilnehmer, Destination-MAC FF:FF:FF:FF:FF:FF.
▪
Multicast: Eine Destination-MAC-Adresse wird dann zu einer Multicast-Adresse, wenn das erste Bit im ersten Byte der MAC gesetzt ist, das sog. Gruppenbit. Mit der Beckhoff-Kennung "00 01 05" wird so in Abb. Einstellungen Publisher - RT Ethernet die Default-Ziel-Adresse "01 01 05 04 00 00" gebildet.
Für den allgemeinen Multicast-Einsatz ist der MAC-Bereich 01:00:5E:00:00:00 bis 01:00:5E:FF:FF:FF vorgesehen - dabei sind die ersten 3 Byte von der IEEE fest definiert, die hinteren 3 Byte leiten sich aus dem unteren Teil der IP-Adresse des Ziel-PC ab. Die dabei entstehende Ziel-MAC ist also im Netzwerk nie physikalisch vorhanden, sondern die Ziel-Netzwerkkarte erkennt solchermaßen gebildete Ethernet-Frames als zu ihr gesendete Multicast-Frames, obwohl der Ethernet-Port selbst eine andere, eindeutige MAC-Adresse haben kann. Da auch noch andere Regeln auf die Bildung von Multicast-MAC/IP-Adressen einwirken, sei im Weiteren auf die entsprechende Literatur verwiesen.
▪
Unicast: entweder direkte Eingabe der Ziel-MAC oder über die AMS-Net-ID des Ziel-Gerätes, z. B. 123.456.123.456.1.1 - dann muss diese Route aber im lokalen AMS-Router eingetragen sein (Rechtsklick TwinCAT Icon in der Taskleiste --> Eigenschaften --> AMS Router)
Verwendung von Broadcast und Multicast
Netzwerkvariablen, die als Broad- oder Multicast auf MAC- oder IP-Ebene verschickt werden, erzeugen je nach Zykluszeit eine hohe Netzwerklast, da sie ins gesamte anhängende Netz multipliziert werden! Einfache Netzwerkgeräte wie z. B. Drucker können dann abstürzen, bei kurzen Zykluszeiten kann auch der gesamte Netzwerkverkehr blockiert werden!
Die Verwendung der Unicast-Adressierung wird dringend empfohlen, auch unter Berücksichtigung der o.a. Variablenidentifizierung.
Weitere Einstellungen:
▪
Data Exchange: verwendete Taskzykluszeit * Divider ist der Rhythmus, in dem diese Netzwerkvariable versendet wird. (nicht bei EL66xx)
▪
VLAN Support: in Verbindung mit managebaren Switchen kann dem hier parametrierten Ethernet-Frame durch das VLAN-Tagging (Virtual Local Area Network) eine feste Route vorgegeben werden
Einstellungen Publisher - UDP/IP
Einstellungen zum UDP/IP - es wird das Adressierungsverfahren der IP-Vermittlungsschicht mit IP-Adressen benutzt, UDP ist ein verbindungsloses Protokoll ohne Rückmeldung.
▪
Broadcast: Versand an alle Teilnehmer mit Destination-IP(v4) 255.255.255.255
▪
Multicast: die Ziel-IP ist anzugeben, s. Anmerkungen zum MAC-Multicast
▪
Unicast: das Zielgerät (z. B: 192.168.0.1) angeben, dabei auf Erreichbarkeit durch die SubNetz-Maske achten
Verwendung von Broadcast und Multicast
Netzwerkvariablen, die als Broad- oder Multicast auf MAC- oder IP-Ebene verschickt werden, erzeugen je nach Zykluszeit eine hohe Netzwerklast, da sie ins gesamte anhängende Netz multipliziert werden! Einfache Netzwerkgeräte wie z. B. Drucker können dann abstürzen, bei kurzen Zykluszeiten kann auch der gesamte Netzwerkverkehr blockiert werden!
Die Verwendung der Unicast-Adressierung wird dringend empfohlen, auch unter Berücksichtigung der o.a. Variablenidentifizierung.
Weitere Einstellungen:
▪
"ARP Retry Interval": Um sich über die Anwesenheit des Empfängers zu informieren, sendet der Publisher in diesem Abstand eine ARP-Anfrage (ARP Request) an das Zielgerät. Arbeitet die Netzwerkverwaltung des Empfänger-PC, antwortet dieser mit einem "ARP Reply". Deshalb nur bei Unicast sinnvoll.
In der Diagnosevariable "FrameState" wird im Fehlerfall Bit 3 gesetzt (0x0004).
Anmerkung: das ARP-Handling (ARP = Address Resolution Protocol: Zuordnung von Hardware/MAC-Adressen zu Netzwerkadressen [IP]) wird vom Betriebssystem (Windows) verwaltet.
▪
"Disable Subscriber Monitoring": schaltet das vorgenannte Verfahren ab
▪
"Target Address changeable": dann kann die Ziel-IP dynamisch geändert werden
Publisher, Variable
Einstellungen Publisher - Variable
Einstellungen:
▪
"Variable ID": Identifizierungsnummer, mit der diese Variable versendet wird, ggf. über PLC online veränderbar
▪
"Data Exchange": s.o. (nicht bei EL66xx)
▪
"On change only": NWV wird nur bei Änderung des Wertes versendet (nicht bei EL66xx)
Subscriber, Box
Einstellungen Subscriber
Einstellungen:
▪
"Receiving Options": lässt für diesen Subscriber nur NWV eines bestimmten Publishers zu
▪
"Multicast Configuration": dto.
Prozessdaten:
▪
"VarId": wenn aktiviert, dann ist die Variablen-Id online änderbar
Subscriber, Variable
Einstellungen Subscriber - Variable
Einstellungen:
▪
"Variable ID": lässt für diesen Subscriber nur NWV mit einer bestimmten ID zu, ggf. über PLC dynamisch veränderbar
▪
"Ignore Data Type Hash": die Hash-Berechnung wird z.Z. noch nicht unterstützt
Prozessdaten:
▪
"Quality": siehe o.a. Erläuterungen
▪
"CycleIndex": wird mit jeder erfolgreichen Übertragung inkrementiert, WENN die Gegenseite = der Publisher dies vornimmt. Wenn der Publisher ein EL66x ist, muss dort der Anwender CycleIdx inkrementieren.
▪
"VarData": übertragene Daten


Anhang

Anhang
Anhang
Weiterführende Informationen
•
ESL Protokoll
•
Firmware Update
•
Firmware Kompatibilität
•
Support und Service


ESL Protokoll

Anhang [image] ESL Protokoll
ESL Protokoll
Das EtherCAT Switch Link Protokoll (ESL) von Beckhoff ist eine einfache Erweiterung zur Steuerung von EtherCAT-Infrastrukturkomponenten. Es wird aktuell (Stand 2010) für den Betrieb der ET2000 Industrial-Ethernet-Mutlichannel-Probe und des CU2508 verwendet.
Die ESL-Daten bestehen aus 16 Byte Steuerangaben und Informationen, die als Prefix (vorne) oder als Postfix (hinten) an einen vorhandenen Ethernet-Datenframe angefügt werden. Die Checksumme (CRC) wird entsprechend angepasst.
ESL-Prefix des CU2508
Der Aufbau der ESL-Daten ist wie folgt:
ESL Aufbau
Ethernet Netzwerkmonitore
Der frei verfügbare Netzwerkmonitor Wireshark enthält seit der Version 1.4.2 einen Interpreter des ESL-Protokolls.


Firmware Update

Anhang [image] Firmware Update
Firmware Update
Der CU2508 verfügt über 2 verschiedene Firmware-Versionen, eine für den FPGA und eine für den Controller.
Zur Feststellung des aktuellen Firmware-Standes und zum Update muss der CU2508 in einer speziellen Konfiguration betrieben werden. Er ist deshalb aus der Applikation zu entfernen und als Einzelgerät an einem TwinCAT-System als EtherCAT-Gerät zu betreiben.
Zum Update sind folgende Schritte durchzuführen:
1. TwinCAT
Auf dem zur Programmierung verwendeten PC-System muss TwinCAT mindestens in der Version 2.11R2 build 2021 vorliegen.
TwinCAT Version
2. ESI/XML-Beschreibung
Die aktuellen ESI/XML-Daten CU2508 müssen auf dem System vorliegen, sie können im Download-Bereich auf der Beckhoff-Webseite heruntergeladen werden und sind unter .."\TwinCAT\Io\EtherCAT\ " abzulegen.
3. Installation des CU2508
Verbinden Sie den CU2508 mit seinem Uplink mit einem Ethernet-Port des Master PC und stellen Sie die Spannungsversorgung sicher. Der Port muss mit dem Beckhoff TwinCAT-Treiber als Echtzeit-Port eingerichtet sein. Die Downports X1..8 dürfen nicht verbunden werden.
Aufbau CU2508
4. TwinCAT Konfiguration erstellen
Öffnen Sie ein neues System-Manager-Fenster. Dadurch werden die oben aktualisierten ESI-Dateien neu eingelesen.
Der CU2508 muss jetzt manuell als EtherCAT-Gerät angelegt werden. Richten Sie dazu ein EtherCAT-Gerät ein und legen Sie den verwendeten Adapter fest.
Rechter Mausklick, Gerät anfügen
Auswahl des Gerätes „EtherCAT“
Auswahl des Ethernet-Adapters
Wenn ihr gewünschter Adapter nicht sichtbar ist, ist der Beckhoff Realtime-Treiber auf diesem Adapter noch nicht installiert.
Fügen Sie nun den CU2508 an.
Rechter Mausklick, Gerät anfügen
Wenn in der Suchmaske (A) der Gerätename angegeben wird, reduziert sich die Übersicht. Aktivieren Sie die Checkboxen "ExtendedInformation" und "ShowHiddenDevices". Dadurch wird ein vorher verstecktes Element, der CU2508 Configuration Port sichtbar (hier: CU2508-0000-0016).
Auswahl des CU2508-0000 Configuration Port
Wählen Sie dieses Gerät aus. Die Konfiguration besteht nun aus dem "EtherCAT Device" und dem einzigen Slave CU2508.
Versichern Sie sich nun der korrekten Funktion, indem Sie TwinCAT im ConfigMode neustarten (B) und ReloadIoDevices (Taste F4 drücken) durchführen. Wenn das Gerät EtherCAT angewählt wird (A), ist im Reiter Online (C) der aktuelle State OP (D) und die Traffic-Auslastung (E) angezeigt. Ca. 250 CyclicFrames je Sekunde sind im ConfigMode bei 4 ms Zykluszeit üblich, es dürfen keine LostFrames oder TXRXErrors auftreten.
Konfiguration Online
5. Auslesen aktueller FW-Stand
Ausgehend von Abb. Konfiguration Online können nun Controller- und FPGA-FW geprüft werden.
Controller-Firmware (*.efw)
Gerät CU2508 selektieren (A), im Reiter CoE-Online (B) wird das Online-CoE-Verzeichnis des Gerätes dargestellt, im Index 0x100A wird der Firmware-Stand (hier: 01) angezeigt (D). Beachten Sie, dass bei (C) "OnlineData" (grün) angezeigt wird.
Auslesen Controller-FW-Stand
FPGA-Firmware (*.rbf)
Gerät CU2508 selektieren (A), im Reiter EtherCAT (B) die Advanced Settings... aufrufen (C). Dort Memory (D) auswählen und die Daten ab StartOffset 0E00 (E) auslesen.
Bei korrekter Funktion ist an Position x0E00 2508dec und an Position x0E06 der Firmwarestand (hier: 03hex) zu lesen (F).
Auslesen FPGA-FW-Stand
6. Firmware und ESI Update
Ausgehend von Abb. Konfiguration Online kann bei einwandfreier Kommunikation durch Rechtsklick auf das CU2508-Gerät ein Controller- und die FPGA-Firmware Update durchgeführt werden.
Update durch Rechtsklick
Die ESI *.xml kann ebenso durch „EEPROM Update“ überschrieben werden. Anschließend ist die entsprechende XML Revision des „CU2508 Configuration Port“ auszuwählen und zu programmieren.
Auswahl XML Revision
Danach ist der CU2508 kurz in den spannungslosen Zustand zu versetzen.


Firmware Kompatibilität

Anhang [image] Firmware Kompatibilität
Firmware Kompatibilität
Beckhoff EtherCAT Geräte werden mit dem aktuell verfügbaren letzten Firmware-Stand ausgeliefert. Dabei bestehen zwingende Abhängigkeiten zwischen Firmware und Hardware; eine Kompatibilität ist nicht in jeder Kombination gegeben. Die unten angegebene Übersicht zeigt auf welchem Hardware-Stand eine Firmware betrieben werden kann.
Anmerkung
▪
Es wird empfohlen, die für die jeweilige Hardware letztmögliche Firmware einzusetzen
▪
Ein Anspruch auf ein kostenfreies Firmware-Udpate bei ausgelieferten Produkten durch Beckhoff gegenüber dem Kunden besteht nicht.
Hinweis
Beschädigung des Gerätes möglich!
Beachten Sie die Hinweise zum Firmware Update auf der gesonderten Seite.
Wird ein Gerät in den BOOTSTRAP-Mode zum Firmware-Update versetzt, prüft es u.U. beim Download nicht, ob die neue Firmware geeignet ist.
Dadurch kann es zur Beschädigung des Gerätes kommen!
Vergewissern Sie sich daher immer, ob die Firmware für den Hardware-Stand des Gerätes geeignet ist!
CU2508
Hardware (HW) | Firmware (FW) | Revision-Nr. | Datum
00 - 06* | 01 | CU2508-0000-0016 | 2011/01
 | 02 | CU2508-0000-0017 | 2011/03
 | 03 |  | 2012/05
 | 04 |  | 2013/01
 | 05 |  | 2013/01
 | 06 |  | 2014/10
 | 07 | CU2508-0000-0018 | 2015/08
 | 08 |  | 2016/02
 | 09 |  | 2016/06
 | 10 |  | 2017/05
 | 11* |  | 2019/08
*) Zum Zeitpunkt der Erstellung dieser Dokumentation ist dies der aktuelle kompatible Hardware-Stand. Überprüfen Sie auf der Beckhoff Webseite, ob eine aktuellere Dokumentation vorliegt.


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.