BX5200 - Busklemmen Controller für DeviceNet
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.2.0
▪
Kapitel Technische Daten aktualisiert
2.1.0
▪
Download-Links aktualisiert
▪
Gestaltung der Sicherheitshinweise an IEC 82079-1 angepasst.
2.0.0
▪
Migration
1.2.0
▪
Aktualisierung zu Firmware-Version 1.20
1.1.0
▪
Hinweise zur Einhaltung der UL-Anforderungen hinzugefügt.
1.0.10
▪
Erste Veröffentlichung
Firmware BX5200
Nach dem Einschalten zeigt der BX-Controller seine Firmware-Version für ca. drei Sekunden auf dem Display an.
Zum Update der Firmware benötigen Sie ein serielles Kabel, die Konfigurations-Software KS2000 oder das Firmware-Update-Programm.
Firmware
Beschreibung
1.20
▪
Firmware für BX-Controller ab Hardware Version 3.5
▪
Umschaltung der COM 2 Schnittstelle zwischen RS232 and RS485 geändert
▪
Neu: Unterstützung der TwinSAFE-Busklemmen: maximal eine Logik-Klemme am K-Bus mit maximal 7 Verbindungen erlaubt (weitere Informationen)
▪
Neu: Zusätzlich zu den 2k Byte remanenten Daten 1000 Byte persistene Dateneingebaut
Achtung
Die Firmware-Version 1.20 läuft nicht auf älteren Hardware-Versionen (kleiner als 3.5). Die Hardware-Version Ihres BX-Controllers entnehmen Sie bitte dessen Aufkleber.
1.10
Erste Version


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Busklemmen-Controller der BX-Serie
•
Prinzip der Busklemme
•
Das Beckhoff Busklemmensystem
•
Technische Daten


Busklemmen-Controller der BX-Serie

Produktübersicht [image] Busklemmen-Controller der BX-Serie
Busklemmen-Controller der BX-Serie
Busklemmen-Controller der BX-Serie (BX-Controller_570x259.jpg)
Busklemmen-Controller der BX-Serie
Die Busklemmen-Controller der BX-Serie (BX-Controller) sind eine Steuerungsfamilie mit hohem Flexibilitätsgrad. Vom Ausstattungs- und Leistungsspektrum ist die BX-Serie zwischen den Busklemmen-Controller der BC-Serie und dem Embedded-PC CX1000 positioniert. Von der BC-Serie wurde das Konzept der autarken Steuerung in Kombination dem Anschluss für ein übergeordnetes Feldbussystem übernommen. Das Gehäusekonzept stammt vom CX1000. Die Hauptunterscheidungsmerkmale zwischen BC- und BX-Serie sind die größere Speicherausstattung und die erweiterten Schnittstellen der BX-Serie.
Die BX-Controller bestehen aus einem programmierbaren IEC 61131-3 Controller, einem Anschluss für das übergeordnete Feldbussystem und dem K-Bus-Interface zum Anschluss der Beckhoff Busklemmen. Zusätzlich verfügen die BX-Controller über zwei serielle Schnittstellen: eine für die Programmierung, die andere zur freien Nutzung. Im Gerät selbst enthalten sind ein beleuchtetes LC-Display (2 Zeilen mit je 16 Zeichen) mit Joystickschalter sowie eine Echtzeit-Uhr. Über den integrierten Beckhoff Smart System Bus (SSB) können weitere Peripheriegeräte, z. B. Displays, angeschlossen werden.
Die Busklemmen werden wie gewohnt auf der rechten Seite des BX-Controllers angesteckt. Durch das umfangreiche Spektrum an verschiedenen E/As kann jedes Eingangssignal gelesen und jedes benötigte Ausgangssignal erzeugt werden. Dadurch sind mit den BX-Controllern vielfältige Automatisierungsaufgaben lösbar, von der Garagentorsteuerung bis hin zur autarken Temperaturregelung an einer Spritzgussmaschine. Auch im Hinblick auf ein modulares Maschinenkonzept sind die BX-Controller hervorragend einzusetzen. Im Verbund kann der BX-Controllers über die Feldbusschnittstelle mit anderen Maschinenteilen Daten austauschen. Die Echtzeit-Uhr ermöglicht auch einen dezentralen Einsatz, bei dem der Wochentag oder die Uhrzeit eine wichtige Rolle spielen.
Die Einsatzgebiete der BX-Serie sind denen der BC-Serie ähnlich, jedoch lassen sich mit dem BX, aufgrund der großen Speicherausstattung, wesentlich komplexere, größere Programme abarbeiten und lokal mehr Daten verwalten (z. B. Historie- und Trenddatenaufzeichnung), die dann sukzessive über den Feldbus abgeholt werden.
Busklemme und Endklemme erforderlich
Zum Betrieb eines BX-Controllers müssen an dessen K-Bus mindestens eine Busklemme mit Prozessabbild und die Endklemme gesteckt sein!
Feldbus-Interface
Die Varianten der Busklemmen Controller der BX-Serie unterscheiden sich durch die unterschiedlichen Feldbusschnittstellen. Zusätzlich sind zwei serielle Schnittstellen für die Programmierung und für den Anschluss weiterer serieller Geräte integriert. Fünf verschiedene Ausführungen decken die wichtigsten Feldbussysteme ab:
▪
BX3100: PROFIBUS DP
▪
BX5100: CANopen
▪
BX5200: DeviceNet
▪
BX8000: RS232 oder RS485 (ohne Feldbusinterface)
▪
BX9000: Ethernet ModbusTCP/ADS-TCP/UDP
Programmierung
Programmiert werden die BX-Controller nach der leistungsfähigen IEC 61131-3 Norm. Wie auch bei allen anderen Beckhoff Steuerungen ist die Automatisierungssoftware TwinCAT Grundlage für die Parametrierung und Programmierung. Dem Anwender stehen also die gewohnten TwinCAT Werkzeuge, wie z. B. SPS-Programmieroberfläche, System Manager und TwinCAT Scope zur Verfügung. Der Datenaustausch erfolgt wahlweise über die serielle Schnittstelle (COM1) oder über den Feldbus via Beckhoff PC-Feldbuskarten FCxxxx.
Konfiguration
Die Konfiguration erfolgt ebenfalls mit TwinCAT. Über den System Manager können das Feldbusinterface, der SSB-Bus und die Echtzeit-Uhr konfiguriert und parametriert werden. Alle angeschlossenen Geräte und Busklemmen können vom System Manager ausgelesen werden. Die Konfiguration wird nach der Parametrierung über die serielle Schnittstelle auf den BX gespeichert. Diese erstellte Konfiguration kann auch wieder ausgelesen werden.


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
Weiterführende Informationen
•
Technische Daten CANopen SSB Interface
•
Technische Daten - BX
•
Technische Daten - SPS


Technische Daten CANopen SSB Interface

Produktübersicht [image] Technische Daten [image] Technische Daten CANopen SSB Interface
Technische Daten CANopen SSB Interface
BX5200
Systemdaten | DeviceNet (BX5200)
Anzahl der Knoten | 64
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | abgeschirmtes, verdrilltes Kupferkabel mit Energieversorgung, 5-polig
Leitungslänge | 500 m | 250 m | 100 m
Übertragungsrate | 125 kBaud | 250 kBaud | 500 kBaud
I/O-Kommunikationsarten | Polling
max. Byte-Anzahl Feldbus | 255 Byte Input und 255 Byte Output
Baudrate | automatische Baudratenerkennung (mögliche Baudraten siehe Übertragungsrate)
SSB | Daten
Max. Anzahl an Slaves | 8
Max. Anzahl an PDOs | 32 RxPODs / 32 TxPDOs
Baudrate | 10 k - 1 MBaud
Erlaubte Slave Adressen | 1 bis 64


Technische Daten - BX

Produktübersicht [image] Technische Daten [image] Technische Daten - BX
Technische Daten - BX
Technische Daten | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Prozessor | 16 Bit Mikrocontroller
Diagnose LEDs | 2 x Spannungsversorgung, 2 x K-Bus
Display | FSTN 2 x 16 Zeilen Display für Diagnose oder eigene Texte, beleuchtet
Schalter | Joystickschalter für Parametrierung und Diagnose
Uhr | interne akkugepufferte Uhr für Zeit und Datum
Konfigurations- und Programmiersoftware | TwinCAT PLC
Feldbus-Interface | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Feldbus | PROFIBUS-DP | CANopen | DeviceNet | - | Ethernet
Schnittstellen | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Serielle Schnittstelle | COM1 (RS232 für Konfiguration und Programmierung, automatische Baudratenerkennung 9600/19200/38400/57600 Baud) COM2 (RS232 oder RS485) für den Anschluss serieller Geräte
SSB | CANopen basierende Sub-Bus Schnittstelle
Klemmenbus (K-Bus) | 64 (255 mit K-Bus-Verlängerung)
Technische Daten | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Digitale Peripheriesignale | 2040 Ein-/Ausgänge
Analoge Peripheriesignale | 1024 Ein-/Ausgänge
Konfigurationsmöglichkeit | über TwinCAT oder die Steuerung
maximale Byte-Anzahl Feldbus | feldbusabhängig
maximale Byte-Anzahl SPS | 2048 Byte Eingangsdaten, 2048 Byte Ausgangsdaten
Feldbus-Anschluss | D-Sub, 9-pin | Open Style Connector, 5-pin |  | - | RJ45
Spannungsversorgung (Us) | 24 VDC (-15%/+20%) Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Eingangsstrom (Us) | 180 mA + (ges. K-Bus Strom)/4
Einschaltstrom (Us) | ca. 2,5 x Dauerstrom
K-Bus-Strom (5 V) | maximal 1450 mA
Spannung Powerkontakt (Up) | maximal 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine Spannungsversorgung, die NEC Class 2 entspricht um die UL-Anforderungen zu erfüllen!
Stromlast Powerkontakt (Up) | maximal 10 A
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
zulässiger Umgebungstemperaturbereich im Betrieb | -25°C ... +60°C Ab Hardware 4.4 erweiterter Temperaturbereich | -25°C ... +60°C Ab Hardware 4.4 erweiterter Temperaturbereich | -25°C ... +60°C Ab Hardware 4.4 erweiterter Temperaturbereich | -25°C ... +60°C Ab Hardware 4.4 erweiterter Temperaturbereich | 0°C ... +55°C
zulässiger Umgebungstemperaturbereich bei Lagerung | -40°C ... +85°C Ab Hardware 4.4 erweiterter Temperaturbereich | -40°C ... +85°C Ab Hardware 4.4 erweiterter Temperaturbereich | -40°C ... +85°C Ab Hardware 4.4 erweiterter Temperaturbereich | -40°C ... +85°C Ab Hardware 4.4 erweiterter Temperaturbereich | -20°C ... +85°C
Relative Feuchte | 95% ohne Betauung
Vibrations-/ Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Schutzart | IP20
Zulassungen | CE, cULus
Mechanische Daten | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Gewicht | ca. 170 g
Abmessungen (B x H x T) | ca. 83 mm x 100 mm x 90 mm (BX8000: ca. 65 mm x 100 mm x 90 mm)
Montage | mit Verriegelung, auf Tragschiene (35 mm Hutschiene)
Einbaulage | Beliebig
Anschlussquerschnitt | 0,08 mm² .. 2,5 mm² AWG 28-14 8-9 mm Abisolierlänge


Technische Daten - SPS

Produktübersicht [image] Technische Daten [image] Technische Daten - SPS
Technische Daten - SPS
PLC Daten | BXxxxx
Programmiermöglichkeit | über Programmierschnittstelle (COM1 oder COM2) oder über Feldbus
Programmspeicher | 256 kByte
Source Code Speicher | 256 kByte
Datenspeicher | 256 kByte
Remanente Merker | 2 kByte
SPS-Zykluszeit | ca. 0,85 ms für 1000 AWL Befehle (ohne E/A Zyklus)
Programmiersprachen | IEC 6-1131-3 (AWL, KOP, FUP, ST, AS)
Laufzeit | 1 SPS Task (2. Task in Vorbereitung)
Online Change | Ja
Up/Down Load Code | Ja/Ja


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Montage
•
Verdrahtung


Montage

Montage und Verdrahtung [image] Montage
Montage
Weiterführende Informationen
•
Abmessungen
•
Tragschienenmontage


Abmessungen

Montage und Verdrahtung [image] Montage [image] Abmessungen
Abmessungen
Das Beckhoff Busklemmen-System zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Abmessungen der Busklemmen-Controller sind unabhängig vom Feldbus-System.
BX3100, BX5100, BX5200, BX9000
BX8000
Die Gesamtbreite der Feldbusstation setzt sich aus der Breite des Busklemmen-Controllers und der Breite der verwendeten Busklemmen (incl. Busendklemme KL9010) zusammen. Die Busklemmen sind je nach Bauform 12 mm oder 24 mm breit. Die Die Höhe beträgt 100 mm.
Die Busklemmen-Controller der BX-Serie sind bis zu 83 mm breit und 91 mm tief.
Gesamttiefe beachten
Beachten sie, dass ein Busklemmen-Controller mit Hutschiene und angeschlossenen Steckern meist tiefer aufbaut als die angegebenen 91 mm. Beispiel:
BX3100 + ZB3100 + Hutschiene = 105 mm


Tragschienenmontage

Montage und Verdrahtung [image] Montage [image] Tragschienenmontage
Tragschienenmontage
Montage
1.
Auf der Unterseite der BX-Controller befinden sich weiße Zuglaschen, die mit einem Rastmechanismus verbunden sind.
Ziehen Sie diese Zuglaschen nach unten, bevor Sie den BX-Controller auf die Tragschiene drücken.
Entriegelter BX-Controller
Hinweis
Display bei der Montage nicht beschädigen!
Achten Sie darauf, nicht auf das Display zu drücken, wenn Sie den BX-Controller auf die Tragschiene drücken. Andernfalls kann das Display beschädigt werden.
2.
Drücken Sie den BX-Controller nun auf die Tragschiene.
3.
Nach dem Aufrasten auf die Tragschiene, schieben Sie die Zuglaschen wieder in die Ausgangsstellung zurück.
Verriegelter BX-Controller
Demontage
1.
Entriegeln Sie zuerst alle Zuglaschen an der Unterseite des BX-Controllers.
2.
Ziehen Sie dann an der orangen Lasche neben der Einspeisung für die Powerkontakte.
Demontage


Verdrahtung

Montage und Verdrahtung [image] Verdrahtung
Verdrahtung
Weiterführende Informationen
•
Potentialgruppen, Isolationsprüfung und PE
•
Spannungsversorgung
•
Programmierkabel für COM1
•
SSB- und COM-Schnittstellen
•
CANopen Verkabelung


Potentialgruppen, Isolationsprüfung und PE

Montage und Verdrahtung [image] Verdrahtung [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung [image] Spannungsversorgung
Spannungsversorgung
SmallWarningYellow GEFAHR
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand,
bevor Sie mit der Montage, Demontage oder Verdrahtung der Komponenten beginnen!
SmallWarningYellow GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Diese UL-Anforderungen gelten für alle Versorgungsspannungen der BX-Controller (Us und Up)!
Zur Einhaltung der UL-Anforderungen dürfen die BX-Controller nur mit Versorgungsspannungen (24 VDC) versorgt werden, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammen.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
SmallWarningYellow GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen dürfen die BX-Controller nicht mit unbegrenzten Spannungsquellen verbunden werden!
Versorgung von Busklemmen-Controller und Busklemmen (Us)
Der Busklemmen-Controller benötigt zum Betrieb eine Versorgungsspannung von 24 VDC.
Der Anschluss findet beim BX-Controller über die oberen Klemmstellen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik des Busklemmen-Controllers sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Klemmstellen zur Versorgung des Busklemmen-Controllers
UL-Kennzeichnung
Versorgung der Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraft - Klemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der BX-Elektronik. Die Auslegung der Einspeisung lässt Spannungen bis zu 24 V zu.
Die Federkraftklemmen sind für Drähte von 0,08 mm2 bis 2,5 mm2 Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Busklemmen Controllers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut/Federführung an der Ober- und Unterseite der Busklemmen Controller und Busklemmen garantiert eine sichere Führung der Powerkontakte.


Programmierkabel für COM1

Montage und Verdrahtung [image] Verdrahtung [image] Programmierkabel für COM1
Programmierkabel für COM1
Für die Programmierung der BX-Controller können Sie ein 1:1 Kabel nehmen (Buchse/Stecker und nur die unten angegebenen PINs verdrahten). Auf der BX-Seite benötigen Sie einen neunpoligen Stecker und auf der PC-Seite meist eine neunpolige Buchse. Die Verdrahtung ist 1:1 und die benötigten PINs sind aus der unten angegebenen Tabelle zu entnehmen. Die Länge des Kabels darf 5 Meter nicht überschreiten!
Beschreibung | BX COM Port 1 | PC COM Port RS 232 Serielle Schnittstelle
Kabel | Stecker, Pin | Buchse, Pin
RS 232 RxD/TxD | 2 | 2
RS 232 RxD/TxD | 3 | 3
GND | 5 | 5
Hinweis
Alle in der Tabelle nicht aufgeführten Pins sind reserviert
Beachten Sie, dass an diesem COM Port die hier nicht aufgeführten Pins nicht frei verfügbar, sondern mit weiteren Signalen belegt sind.
ZK1000-0030
Das Programmierkabel bietet die Möglichkeit über die Schnittstelle COM 1 den BX-Controller zu programmieren und an der Schnittstelle COM 2 ein weiteres serielles Gerät anzuschließen. Achten Sie im eingebauten Zustand auf die maximale Bauhöhe des Steckers.
Programmierkabel ZK1000-0030 - COM 1 und COM 2
Programmierkabel ZK1000-0030 - Abmessungen der Stecker
Programmierkabel ZK1000-0030 - Pinning


SSB- und COM-Schnittstellen

Montage und Verdrahtung [image] Verdrahtung [image] SSB- und COM-Schnittstellen
SSB- und COM-Schnittstellen
Das Grundmodul der BX-Controller besitzt die Schnittstellen COM1, COM2 und SSB (Smart System. COM1 und COM2 sind auf einer D-Sub-Buchse untergebracht. Ein spezielles Programmierkabel (ZK1000-0030) mit dem Sie beide Schnittstellen verwenden können, können Sie bei Beckhoff bestellen. Die Schnittstelle COM2 ist für den Anschluss serieller Geräte vorgesehen. Sie können bei der Schnittstelle COM2 zwischen RS232 oder RS485 wählen.
Für die serielle Schnittstelle COM2 stehen Bibliotheken zur Verfügung.
SSB-Schnittstelle
SSB-Schnittstelle
Belegung der SSB-Schnittstelle (Stecker X00)
PIN | Signal
1 | reserviert
2 | CAN low
3 | GND
4 | reserviert
5 | Shield
6 | GND
7 | CAN high
8 | reserviert
9 | reserviert
COM1 (RS 232) und COM2 (RS 232/485) Schnittstelle
COM1- (RS 232) und COM2-Schnittstelle (RS 232/485)
Belegung der COM-Schnittstellen (Buchse X01)
PIN | Schnittstelle | Signal
1 | COM2 | RS485 D+
2 | COM1 | RS232 TxD
3 | COM1 | RS232 RxD
4 | VCC +5 V | VCC
5 | GND | GND
6 | COM2 | RS485 D-
7 | COM2 | RS232 RxD
8 | COM2 | RS232 TxD
9 | GND | GND


CANopen Verkabelung

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung
CANopen Verkabelung
Hinweise für die Überprüfung der CAN-Verdrahtung finden sich im Kapitel Fehlersuche / Trouble Shooting.
Weiterführende Informationen
•
CAN-Topologie
•
Buslänge
•
Stichleitungen
•
Sternverteiler (Multiport Tap)
•
CAN-Kabel
•
Schirmung
•
Kabelfarben
•
BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig
•
BK51x0/BX5100: 5poliger Open Style Connector
•
LC5100: Busanschluss über Federkraftklemmen
•
Feldbus Box: M12 CAN Buchse


CAN-Topologie

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] CAN-Topologie
CAN-Topologie
CAN ist ein 2-Draht-Bussystem, an dem alle Teilnehmer parallel (d.h. mit kurzen Stichleitungen) angeschlossen werden. Der Bus muss an jedem Ende mit einem Abschlusswiderstand von 120 (bzw. 121) Ohm abgeschlossen werden, um Reflexionen zu vermeiden. Dies ist auch bei sehr kurzen Leitungslängen erforderlich!
Abschluss des Busses mit Abschlusswiderstand 120 Ohm
Da die CAN-Signale als Differenzpegel auf dem Bus dargestellt werden, ist die CAN-Leitung vergleichsweise unempfindlich gegen eingeprägte Störungen (EMI). Es sind jeweils beide Leitungen betroffen, somit verändert die Störung den Differenzpegel kaum.
Unempfindlichkeit gegen eingeprägte Störungen


Buslänge

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] Buslänge
Buslänge
Die maximale Buslänge wird bei CAN vorwiegend durch die Signallaufzeit beschränkt. Das Multi-Master-Buszugriffsverfahren (Arbitrierung) erfordert, dass die Signale quasi gleichzeitig (vor der Abtastung innerhalb einer Bitzeit) an allen Knoten anliegen. Da die Signallaufzeit in den CAN-Anschaltungen (Transceiver, Optokoppler, CAN-Controller) nahezu konstant sind, muss die Leitungslänge an die Baud-Rate angepasst werden.
Baud-Rate | Buslänge
1 MBit/s | < 20 m*
500 kBit/s | < 100 m
250 kBit/s | < 250 m
125 kBit/s | < 500 m
50 kBit/s | < 1000 m
20 kBit/s | < 2500 m
10 kBit/s | < 5000 m
*) Häufig findet man in der Literatur für CAN die Angabe 40 m bei 1 MBit/s. Dies gilt jedoch nicht für Netze mit optoentkoppelten CAN-Controllern. Die worst case Berechnung mit Optokopplern ergibt bei 1 MBit/s eine maximale Buslänge von 5 m - erfahrungsgemäß sind jedoch 20 m problemlos erreichbar.
Bei Buslängen über 1000 m kann der Einsatz von Repeatern notwendig werden.


Stichleitungen

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] Stichleitungen
Stichleitungen
Stichleitungen ("drop lines") sind nach Möglichkeit zu vermeiden, da sie grundsätzlich zu Signalreflexionen führen. Die durch Stichleitungen hervorgerufenen Reflexionen sind jedoch in der Regel unkritisch, wenn sie vor dem Abtastzeitpunkt vollständig abgeklungen sind. Bei den in den Buskopplern gewählten Bit-Timing-Einstellungen kann dies angenommen werden, wenn folgende Stichleitungslängen nicht überschritten werden:
Baud-Rate | Länge Stichleitung | gesamte Länge aller Stichleitungen
1 MBit/s | < 1 m | < 5 m
500 kBit/s | < 5 m | < 25 m
250 kBit/s | < 10 m | < 50 m
125 kBit/s | < 20 m | < 100 m
50 kBit/s | < 50 m | < 250 m
Stichleitungen dürfen nicht mit Abschlusswiderständen versehen werden.
Beispieltopologie Stichleitungen


Sternverteiler (Multiport Tap)

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] Sternverteiler (Multiport Tap)
Sternverteiler (Multiport Tap)
Beim Einsatz von passiven Verteilern ("Multiport Taps"), z. B. der Beckhoff Verteilerbox ZS5052-4500 sind kürzere Stichleitungslängen einzuhalten. Die folgende Tabelle gibt die maximalen Stichleitungslängen und die maximale Länge der Trunk Line (ohne Stichleitungen) an:
Baud-Rate | Länge Stichleitung bei Multiport Topologie | Länge Trunk Line (ohne Stichleitungen)
1 MBit/s | < 0,3 m | < 25 m
500 kBit/s | < 1,2 m | < 66 m
250 kBit/s | < 2,4 m | < 120 m
125 kBit/s | < 4,8 m | < 310 m


CAN-Kabel

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] CAN-Kabel
CAN-Kabel
Für die CAN-Verdrahtung wird die Verwendung von paarig verdrillten, geschirmten Kabeln (2x2) mit einem Wellenwiderstand von 108...132 Ohm empfohlen. Wenn das Bezugspotential der CAN-Transceiver (CAN-Ground) nicht verbunden werden soll, so kann auf das zweite Adernpaar verzichtet werden (nur bei kleinen Netzausdehnungen mit gemeinsamer Speisung aller Teilnehmer empfehlenswert).
ZB5100 CAN-Kabel
Beckhoff hat ein hochwertiges CAN-Kabel mit folgenden Eigenschaften im Programm:
▪
2 x 2 x 0,25 mm² (AWG 24) paarig verseilt, Kabelfarben: rot/schwarz + weiß/schwarz
▪
doppelt geschirmt
▪
Schirmgeflecht mit Beilauflitze (kann direkt auf Pin3 der 5-pol Anschlussklemme aufgelegt werden)
▪
flexibel (Mindestbiegeradius 35 mm bei einmaligem Biegen, 70 mm bei mehrmaligem Biegen)
▪
Wellenwiderstand (60 kHz): 120 Ohm
▪
Leiterwiderstand < 80 Ohm/km
▪
Mantel: PVC grau, Außendurchmesser 7,3 +/- 0,4 mm
▪
Gewicht: 64 kg/km.
▪
Bedruckt mit "Beckhoff ZB5100 CAN-BUS 2x2x0.25" und Metermarkierung (Längenangaben, alle 20cm)
Aufbau CAN-Kabel ZB5100
ZB5200 CAN/DeviceNet-Kabel
Das Kabelmaterial ZB5200 entspricht der DeviceNet Spezifikation und eignet sich ebenso für CANopen Systeme. Aus diesem Kabelmaterial sind auch die vorkonfektionierten Busleitungen ZK1052-xxxx-xxxx für die Feldbus Box Baugruppen gefertigt. Es hat folgende Spezifikation:
▪
2 x 2 x 0,34 mm² (AWG 22) paarig verseilt
▪
doppelt geschirmt, Schirmgeflecht mit Beilauflitze
▪
Wellenwiderstand (1 MHz): 126 Ohm
▪
Leiterwiderstand 54 Ohm/km
▪
Mantel: PVC grau, Außendurchmesser 7,3 mm
▪
Bedruckt mit "InterlinkBT DeviceNet Type 572" sowie UL und CSA Ratings
▪
Litzenfarben entsprechen DeviceNet Spezifikation
▪
UL anerkanntes AWM Type 2476 Rating
▪
CSA AWM I/II A/B 80°C 300V FT1
▪
Entspricht DeviceNet "Thin Cable" Spezifikation
Aufbau CAN-/DeviceNet-Kabel ZB5200


Schirmung

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] Schirmung
Schirmung
Der Schirm ist über das gesamte Buskabel zu verbinden und nur an einer Stelle galvanisch zu erden um Masseschleifen zu vermeiden.
Das Schirmungskonzept mit HF-Ableitung von Störungen über R/C-Glieder auf die Tragschiene geht davon aus, dass die Tragschiene entsprechend geerdet und störungsfrei ist. Sollte dies nicht der Fall sein, so kann es vorkommen, dass HF-Störpegel über die Tragschiene auf den Schirm des Buskabels übertragen werden. In diesem Fall sollte der Schirm an den Kopplern nicht aufgelegt werden - aber dennoch komplett durchverbunden sein.
Hinweise für die Überprüfung der CAN-Verdrahtung finden sich im Kapitel Fehlersuche / Trouble Shooting.


Kabelfarben

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] Kabelfarben
Kabelfarben
Vorschlag für die Verwendung der Beckhoff CAN-Kabel an Busklemme und Feldbus Box:
Pin BK51x0 PIN BX5100 (X510) | Pin BK5151 CX8050, CX8051, CXxxxx-B510/M510 | Pin Feldbus Box | Pin FC51xx | Funktion | Kabelfarbe ZB5100 | Kabelfarbe ZB5200
1 | 3 | 3 | 3 | CAN Ground | schwarz /(rot) | schwarz
2 | 2 | 5 | 2 | CAN Low | schwarz | blau
3 | 5 | 1 | 5 | Schirm | Beilauflitze | Beilauflitze
4 | 7 | 4 | 7 | CAN high | weiß | weiß
5 | 9 | 2 | 9 | nicht benutzt | (rot) | (rot)


BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig
BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig
Die CAN Busleitung wird an die FC51x1, FC51x2 CANopen Karten und bei der EL6751 CANopen Master-/Slaveklemme über 9polige Sub-D-Buchsen mit folgender Steckerbelegung angeschlossen.
Pin | Belegung
2 | CAN low (CAN-)
3 | CAN Ground (intern verbunden mit Pin 6)
6 | CAN Ground (intern verbunden mit Pin 3)
7 | CAN high (CAN+)
Die nicht aufgeführten Pins sind nicht verbunden.
Die Tragschienenkontaktfeder und der Steckerschirm sind durchverbunden.
Hinweis: an Pin 9 darf eine Hilfsspannung bis 30 VDC angeschlossen sein (wird von manchen CAN Geräten zur Versorgung der Transceiver genutzt).
Pinbelegung BK5151, EL6751
FC51x2:
FC51x2


BK51x0/BX5100: 5poliger Open Style Connector

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] BK51x0/BX5100: 5poliger Open Style Connector
BK51x0/BX5100: 5poliger Open Style Connector
Bei den BK51x0/BX5100 (X510) Buskopplern befindet sich auf der linken Seite eine abgesenkte Frontfläche mit einem 5poligen Stecker.
Hier kann die mitgelieferte CANopen- Verbindungsbuchse eingesteckt werden.
Belegung Verbindungsbuchse BK51x0/BX5100
Das linke Bild zeigt die Buchse im Buskoppler BK51x0/BX5100. Pin 5 ist dabei der oberste Pin auf der Steckerleiste. Pin 5 ist nicht benutzt. Pin 4 ist die CAN-High-Leitung, Pin 2 die CAN-Low-Leitung und an Pin 3 wird der Schirm aufgelegt (ist über eine R/C-Schaltung mit der Tragschiene verbunden). Optional kann am Pin 1 CAN-GND angeschlossen werden. Wenn alle CAN-Ground Pins verbunden sind ergibt dies ein gemeinsames Bezugspotential für die CAN Transceiver im Netz. Es empfiehlt sich, CAN-GND an einer Stelle zu erden, damit das gemeinsame CAN Bezugspotential nahe beim Versorgungs-Potential liegt. Da die CANopen Buskoppler BK51X0/BX5100 über eine vollständige galvanische Trennung des Busanschlusses verfügen, kann u.U. auf die Verdrahtung von CAN-Ground verzichtet werden.
Businterface Connector ZS1052-3000
Alternativ zum mitgelieferten Stecker kann der CAN Interface Connector ZS1052-3000 eingesetzt werden. Dieser vereinfacht die Verdrahtung erheblich. Für die ankommenden und abgehenden Leitungen stehen separate Klemmen zur Verfügung, der Schirm wird durch die Zugentlastung großflächig angeschlossen. Der integrierte Abschlusswiderstand kann von außen zugeschaltet werden. Ist er eingeschaltet, so wird die abgehende Busleitung elektrisch abgetrennt - damit lassen sich Verdrahtungsfehler schnell lokalisieren, und es ist gewährleistet, dass nicht mehr als zwei Widerstände im Netz aktiv sind.


LC5100: Busanschluss über Federkraftklemmen

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] LC5100: Busanschluss über Federkraftklemmen
LC5100: Busanschluss über Federkraftklemmen
Beim Low-Cost-Koppler LC5100 wird die CAN-Leitung direkt auf die Klemmstellen 1 (CAN-H, gekennzeichnet mit C+) bzw. 5 (CAN-L, gekennzeichnet mit C-) aufgelegt. Der Schirm kann optional auf die Klemmstellen 4 bzw. 8 aufgelegt werden, diese sind über eine R/C-Schaltung mit der Tragschiene verbunden.
LC5100
Hinweis
Beschädigung der Geräte möglich!
Durch die nicht vorhandene galvanische Trennung kann durch unsachgemäße Verkabelung der CAN Treiber zerstört oder geschädigt werden. Verkabeln sie immer im ausgeschalteten Zustand.
Verkabeln Sie erst die Spannungsversorgung und legen sie erst dann den CAN auf. Überprüfen Sie die Verkabelung und schalten dann erst die Spannung ein.


Feldbus Box: M12 CAN Buchse

Montage und Verdrahtung [image] Verdrahtung [image] CANopen Verkabelung [image] Feldbus Box: M12 CAN Buchse
Feldbus Box: M12 CAN Buchse
Bei der Feldbus Box IPxxxx-B510, IL230x-B510 und IL230x-C510 wird der Busanschluss mit 5poligen M12 Steckverbindern ausgeführt.
Pinbelegung M12 Stecker Feldbus Box
Für das Feldbus Box System bietet Beckhoff feldkonfektionierbare Stecker, Passivverteiler, Abschlusswiderstände sowie eine große Auswahl an vorkonfektionierten Kabeln an. Details finden sich im Katalog oder unter www.beckhoff.de.


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Busklemmen-Controllers
•
Konfiguration


Anlaufverhalten des Busklemmen-Controllers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Busklemmen-Controllers
Anlaufverhalten des Busklemmen-Controllers
Nach dem Einschalten prüft der Busklemmen-Controller seinen Zustand, konfiguriert den K-Bus, erstellt anhand der gesteckten Busklemmen eine Aufbauliste und startet seine lokale SPS.
Beim Hochlaufen des Busklemmen-Controllers leuchten und blinken die I/O-LEDs. Im fehlerfreien Zustand sollte nach ca. 2 bis 3 Sekunden keine I/O-LED mehr Blinken. Im Fehlerfall hängt es von der Fehlerart ab, welche LED blinkt (siehe Kapitel Diagnose-LEDs).
Anlaufverhalten des Busklemmen-Controllers


Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration
Konfiguration
Weiterführende Informationen
•
Überblick
•
Anlegen einer TwinCAT-Konfiguration
•
Download einer TwinCAT-Konfiguration
•
Upload einer TwinCAT-Konfiguration
•
Ressourcen im Busklemmen-Controller
•
ADS-Verbindung über die serielle Schnittstelle
•
DeviceNet Slave-Schnittstelle
•
K-Bus
•
PLC
•
SSB
•
Echtzeit-Uhr (RTC)
•
COM-Port
•
Menü
•
Konfigurations-Software KS2000


Überblick

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Überblick
Überblick
Konfigurationsarten
Bei den Busklemmen-Controllern der Serien BCxx50, BCxx20 und BXxx00 gibt es zwei verschiedene Arten der Konfiguration, die DEFAULT CONFIG und die TWINCAT CONFIG.
DEFAULT-CONFIG
Die Busklemmen mappen sich in der Reihenfolge wie diese gesteckt sind, erst die komplexen Busklemmen, dann die digitalen Busklemmen.
Das Mapping der komplexen Busklemmen ist:
▪
Word-Alignment
▪
komplexe Darstellung
SmallWarningYellow VORSICHT
Prozessabbild ist abhängig von angesteckten Klemmen!
Das Prozessabbild verändert sich, sobald eine Klemme dazu gesteckt wird oder entfernt wird!
Die Daten der Feldbus-Slave Schnittstelle werden SPS-Variablen genannt. Die SPS-Variablen befinden sich ab der Adresse %QB1000 und %IB1000.
Weiterhin kann die DEFAULT-CONFIG ohne SPS-Programm für das Schreiben und Testen der Angeschlossenen Busklemmen verwendet werden. Dafür muss im System Manager der Busklemmen-Controller gescannt werden und die Betriebsart FreeRun aktiviert werden (um diese Funktion zu nutzen darf kein SPS-Programm auf dem Busklemmen-Controller sein).
TWINCAT-CONFIG
In der TWINCAT-CONFIG können die Busklemmen und die SPS-Variablen frei verknüpft sein (TwinCAT System Manager-File notwendig). Die Konfiguration wird mit Hilfe des System Managers per ADS zum Koppler übertragen.
Für die TwinCAT Config (TC-File) benötigen Sie folgendes:
▪
Über der Feldbus (PROFIBUS, CANopen, Ethernet)
PROFIBUS: (BC3150, BX3100)
–
PC mit FC310x ab Version 2.0 und TwinCAT 2.9 Build 1000
–
BX3100 mit CIF60 oder CP5412
–
TwinCAT 2.9 Build 946
(ACHTUNG: bei den PROFIBUS Karten von Hilscher ist nur eine ADS-Kommunikation erlaubt, d.h. entweder System Manager oder PLC Control)
CANopen: (BC5150, BX5100)
–
PC mit FC510x ab Version 1.76 TwinCAT Build 1030
DeviceNet: (BC5250, BX5200)
–
Auf Anfrage
Ethernet: (BC9050, BC9020, BC9120, BX9000)
–
PC mit TwinCAT 2.10 Build 1322
▪
Über das serielle ADS TwinCAT 2.9 Build 1010
–
BX3100 Version 1.00
–
BX5100 Version 1.00
–
BX5200 Version 1.10
–
BX8000 Version 1.00
–
BC3150, BC5150, BC5250, BC9050, BC9020, BC9120 ab Firmware B0
–
Für BC8150 ab TwinCAT 2.10 Build 1243
BCxx50 und BXxx00 können über den System Manager des TwinCAT Programms parametriert werden.
▪
Variables I/O Mapping
▪
Typ gerechte PROFIBUS Daten (nur BC3150 und BX3100)
▪
RTC (Real Time Clock) (nur BX-Serie)
▪
SSB Bus (Smart System Bus) (nur BX-Serie)
▪
PLC Einstellungen
▪
K-Bus Einstellungen
Die Konfiguration kann per Feldbus ADS-Protokoll oder seriellem ADS-Protokoll zum BCxx50 oder BXxx00 übertragen werden.
Mit der TwinCAT Konfiguration kann man Variablen, I/Os und Daten verknüpfen. Folgendes ist möglich:
▪
PLC - K-BUS
▪
PLC - Feldbus (z. B. PROFIBUS Slave Schnittstelle zur PLC)
▪
K-Bus - Feldbus (nur bei den BX-Controllern)
▪
Unterstützung der TwinSAFE-Klemmen (nur BX-Controller ab Firmware 1.17)
Zusätzlich können mit der TwinCAT Konfiguration spezielle verhalten parametriert werden, zum Beispiel ob bei einem Feldbus Fehler die Daten erhalten bleiben oder auf "0" gesetzt werden sollen.
Die Echtzeituhr kann man über einen Karteireiter im System Manager einstellen.
Arbeitsschritte
1.
Feldbus Adresse einstellen
2.
System Manager öffnen und TC-File anlegen
3.
Feldbus Daten in dem TC-File konfigurieren
4.
TC-File speichern
5.
Neuer System Manager öffnen und PC-File anlegen und gespeichertes TC-File einlesen
6.
Verknüpfen zu einer SPS-Task herstellen
7.
Speichern der Konfiguration
8.
Starten des TwinCAT Systems
9.
System Manager des TC-File öffnen, fertig konfigurieren und zum BCxx50, BCxx20 oder BXxx00 übertragen
10.
Programm zum BCxx50, BCxx20 oder BXxx00 übertragen
11.
Bootprojekt erzeugen


Anlegen einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Anlegen einer TwinCAT-Konfiguration
Anlegen einer TwinCAT-Konfiguration
Um einen Busklemmen-Controller der Serien BCxx50, BCxx20 oder BXxx00 zu konfigurieren muss im System-Manager ein BX-File angelegt werden. Zur Vereinfachung sind die Grundgeräte schon als File vorbereitet. Dazu öffnen Sie mit New from Template den entsprechenden Busklemmen-Controller.
systemm new from template.gif
Anlegen einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
systemm new from template 2.png
Auswahl des Busklemmen-Controllers
Nun sind alle Komponenten des Busklemmen-Controllers vorhanden:
▪
Feldbusschnittstelle
▪
K-Bus Interface
▪
PLC Programm
▪
SSB (nur Busklemmen-Controller der BX-Serie)
Die Konfiguration der Geräte entnehmen Sie den entsprechenden Kapiteln.


Download einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Download einer TwinCAT-Konfiguration
Download einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BXxx00 und BCxx50)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Vorraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus-Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Master-Karte) zum Busklemmen-Controller stattfinden.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste F8 öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Download einer TwinCAT-Konfiguration
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Den Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Im Config Mode / FreeRun kann man jetzt die Konfiguration zum Busklemmen-Controller herunterspielen. Wenn der Busklemmen-Controller im Stop Mode ist, ist die ADS-Kommunikation noch nicht aktiviert. Ein Download der Konfiguration ist dann nicht möglich.
Zum Aktivieren der TwinCAT-Konfiguration wählen Sie Ctrl+Shift+F4 oder Activate Configuration.
Aktivieren der TwinCAT-Konfiguration
Die aktuelle Konfiguration wird in dem Busklemmen-Controller geladen. Im Display erscheint Store Config und die BUS und I/O LED blinken. Nachdem die Konfiguration erfolgreich im Busklemmen-Controller ist, sollte ein BXxx00 im Display TwinCAT Config anzeigen. Jetzt kann man das entsprechende Programm zum Busklemmen-Controller übertragen (Programm-Download über den Feldbus).


Upload einer TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Upload einer TwinCAT-Konfiguration
Upload einer TwinCAT-Konfiguration
Die TwinCAT-Konfiguration wird per ADS-Protokoll zum Busklemmen-Controller geladen.
Serielles ADS-Protokoll
(alle Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00)
Tragen Sie die serielle ADS-Verbindung ein, wie unter dem Kapitel Serielles ADS beschrieben ist.
ADS-Protokoll über den Feldbus
(nur BC3150, BC5150, BC9x20, BC9050, BX3100, BX5100, BX9000)
Voraussetzung hierfür ist, dass TwinCAT als Master arbeitet und sich im Datenaustausch befindet, d.h. die physikalische, wie auch die Feldbus Konfiguration muss abgeschlossen sein und der Datenaustausch vom Master (z. B. Feldbus-Karte) zum Busklemmen-Controller stattfindet.
Auswahl des Zielsystems
Wählen Sie den Busklemmen-Controller aus, auf den Sie die Konfiguration laden wollen. Mit der Funktionstaste [F8] öffnet sich der Dialog, mit indem Sie Ihr File auf das entsprechende Gerät herunterladen können.
Auswahl des Zielsystems
Wählen Sie den entsprechenden Busklemmen-Controller aus.
Auswahl des Busklemmen-Controllers
Der Zustand des Busklemmen-Controllers wird unten rechts im System-Manager angezeigt.
Zustand des Busklemmen-Controllers
Klicken Sie den roten Ordner an. Die TwinCAT-Konfiguration wird jetzt hochgeladen.
Hochladen der TwinCAT-Konfiguration


Ressourcen im Busklemmen-Controller

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Ressourcen im Busklemmen-Controller
Ressourcen im Busklemmen-Controller
Die im Busklemmen-Controller belegten Speicher-Ressourcen zeigt der System Manager auf dem Karteireiter Resources des Busklemmen-Controller an.
Mapping Code
Der Mapping Code wird für die Berechnung der TwinCAT Konfiguration benötigt (siehe Abb. Speicher für das Code Mapping). Die Prozentzahlen werden hier zusammen addiert, in dem Beispiel aus Abb. Speicher für das Code Mapping sind 8% des Speichers für die Mapping-Berechnung belegt.
Speicher für das Code Mapping
Daten Speicher Mapping
Daten Speicher für die Mappings. Die Werte sind einzeln zu betrachten, das bedeutet das jeder der Werte bis zu 100% betragen kann.
Daten Speicher Mapping
Verbrauchter Code und Daten Speicher
Abb. Code und Daten Speicher (1) "Used Plc Code" verbrauchter PLC Code, Angabe in %.
Abb. Code und Daten Speicher (2) "Used Plc Data" verbrauchter PLC Daten, Angabe Speicher in %.
Abb. Code und Daten Speicher (3) "Used Plc Source" verbrauchter Source Code, Angabe in %.
Code und Daten Speicher
Sonstiger Speicher
Abb. Sonstiger Speicher (1) "Used Near Heap" wird für die COM Schnittstelle und SSB benötigt. Angabe in %.
Abb. Sonstiger Speicher (2) "Used Huge Heap" wird für die ADS Kommunikation benötigt. Angabe in %. Dieser Wert sollte kleiner 30 % betragen.
Abb. Sonstiger Speicher (3) "Used File Area" wird für die TwinCAT Konfiguration, dem TSM-File und dem 16 kByte Flash Zugriff benötigt. Angabe in %.
Sonstiger Speicher


ADS-Verbindung über die serielle Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] ADS-Verbindung über die serielle Schnittstelle
ADS-Verbindung über die serielle Schnittstelle
(ab Firmware-Version 1.xx oder 0.99x - Busklemmen-Controller der BX-Serie und bei allen BCxx50)
Ab TwinCAT 2.9 Build 1020 (TwnCAT Level PLC, NC oder NCI)
Verwenden Sie nur eine serielle Verbindung
Um die problemlose Funktion der ADS-Verbindung über die serielle Schnittstelle zu garantieren, ist nur dabei eine serielle Verbindung zum BX-Controller erlaubt.
Nach einer erfolgreichen Konfiguration mit dem System Manager schließen Sie diesen, bevor Sie die Programmierung starten.
AMS-Net-ID im Auslieferungszustand (Default)
Für BX9000
Die Default AMS-Net-ID lautet 172.16.21.20.1.1. Wird die IP-Adresse des BX9000 verändert, so verändert sich auch die AMS-Net-ID des BX9000. Die aktuelle AMS-Net-ID können Sie mit Hilfe des Menüs sich auf dem Display anzeigen lassen.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
Für BC9050, BC9020, BC9120
Die Default AMS-Net-ID lautet 172.16.xxx.[DIP-Switch].1.1. Wird die IP-Adresse des BC9xxx verändert, so verändert sich auch die AMS-Net-ID des BC9xxx.
Beispiel: Sie ändern die IP-Adresse auf 10.2.3.7 so ändert sich die AMS-Net-ID auf 10.2.3.7.1.1.
BC9050: DEFAULT 172.16.21.[DIP-Switch].1.1
BC9020: DEFAULT 172.16.22.[DIP-Switch].1.1
BC9120: DEFAULT 172.16.23.[DIP-Switch].1.1
ADS-Verbindung initialisieren
Tragen Sie den Busklemmen-Controller unter TwinCAT in die Remote-Verbindung ein. Klicken Sie dazu auf das TwinCAT-Icon und öffnen Sie das Eigenschafts-Menü. Unter dem Karteireiter >AMS Remote< können Sie dann folgende Einträge vornehmen.
Eigenschaften der Remote-Verbindung
Remote Name: Beliebig
AMS-Net-ID: 1.1.1.1.1.1 (Default)
Adresse: COM Port: Baudrate, Parity, Datenbits, Stop Bits
Transport: Hier ist "COM-PORT" anzuwählen
Wird der Busklemmen-Controller eingeschaltet, so hat dieser per Default immer die AMS-Net-ID "1.1.1.1.1.1" (außer alle Ethernet Controller).
Sie können diese AMS-Net-ID beliebig ändern. Die neue AMS-Net-ID kann dann allerdings nicht noch einmal geändert werden.
Wenn Sie die AMS-Net-ID erneut ändern möchten, müssen Sie den Busklemmen-Controller zuerst neu starten, so dass die AMS Net Id wieder auf die Default AMS-Net-ID "1.1.1.1.1.1" zurückgesetzt wird.
Nun können sie die AMS-Net-ID wiederum einmal ändern.
Erst beim zweiten Aufruf können Sie Strings eingeben
Beim ersten Aufruf des Dialogs (siehe oben) können Sie unter Adresse keine Strings eingeben. Tragen Sie Namen, AMS-Net-ID und Transport-Typ ein und schließen Sie den Dialog. Beim zweiten Aufruf können Sie dann Ihre COM-Schnittstelle eintragen.
Die Kommunikation startet sobald TwinCAT im Config- (TwinCAT-Icon ist blau) oder RUN-Modus (TwinCAT-Icon ist grün) ist. Die COM-Schnittstelle wird erst mit einem TwinCAT Stopp (TwinCAT-Icon ist rot) geschlossen und ist dann wieder für andere Programme verfügbar. Sollte die COM-Schnittstelle bei einem TwinCAT-Neustart von einem anderen Programm (z. B. von der Konfigurations-Software KS2000) verwendet werden, so wird kein Fehlerhinweis ausgegeben.
AMS-Net-ID nach ADS-Verbindung über den Feldbus
Sollte Sie vor oder während der Nutzung der seriellen ADS-Verbindung den Busklemmen-Controller mit einer ADS-Verbindung über den Feldbus angesprochen haben, ist die AMS-Net-ID vom System Manager automatisch verändert worden. Eine erneute serielle ADS-Verbindung ist dann nur möglich, wenn die AMS-Net-ID angepasst wird.
BX-Serie: auslesen der AMS-Net-ID
Die aktuelle AMS-Net-ID kann aus dem Menü über das Display des Busklemmen-Controller der BX-Serie ausgelesen werden.
AMS
1.1.1.1.1.1
AMS-Net-ID


DeviceNet Slave-Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle
DeviceNet Slave-Schnittstelle
Weiterführende Informationen
•
DeviceNet Slave-Schnittstelle EDS Datei
•
DeviceNet Slave-Schnittstelle
•
TwinCAT-Konfiguration
•
Adresse
•
Baud-Rate
•
Masterparametrierung


DeviceNet Slave-Schnittstelle EDS Datei

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] DeviceNet Slave-Schnittstelle EDS Datei
DeviceNet Slave-Schnittstelle EDS Datei
BX5200
EDS Datei BX5200.eds (für andere Steuerungen als TwinCAT) ( )
EDS Datei BX5200S.eds (Beispieldatei)
Für TwinCAT müssen beide EDS-Dateien in das Verzeichnis \TwinCAT\IO\DeviceNet kopiert werden.
Bild für BX5200.ico ( )
BC5250
EDS Datei BC5250.eds (für andere Steuerungen als TwinCAT) ( )
EDS Datei BC5250S.eds ( )
Für TwinCAT müssen beide EDS Dateien in das Verzeichnis \TwinCAT\IO\DeviceNet kopiert werden.
Bild für BC5250.ico ( )
Dokumente hierzu
•
•


DeviceNet Slave-Schnittstelle

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] DeviceNet Slave-Schnittstelle
DeviceNet Slave-Schnittstelle
Es gibt zwei Konfigurationsarten. In der Default Konfiguration (Auslieferungszustand) mappen sich die DeviceNet Daten, der DeviceNet Slave Schnittstelle, ab der Adresse 1000 des BX5200/BC5250 und es sind die ersten 8 Byte aktiviert. Per Funktionsbausteine können die Länge der DeviceNet Daten und die Eigenschaften von der lokalen Steuerung verändert werden.
In der TwinCAT Konfiguration kann man über den System Manager eine beliebige Konfiguration erstellen und Variablen beliebig mit der DeviceNet Slave Schnittstelle verknüpfen.
Default Konfiguration
In dieser Konfiguration mappen sich die DeviceNet Daten wie folgt:
DeviceNet Daten
Anzahl | Lesen/Schreiben | BX5200/BC5250 Prozessabbild
8 Byte (Polling Mode) | Rx/Tx | %IB1000...%IB1007/QB1000...%QB1007
Will man mehr/weniger als 8 Byte Daten empfangen oder senden, muss man per Funktionsbaustein diese Default Einstellung ändern (siehe DeviceNet spezifische Bausteine).
Eigenschaften DeviceNet Kommunikation
Die folgenden Eigenschaften kann man einstellen. Es ist kein Mischbetrieb der DeviceNet Kommunikationstypen möglich.
Polling
Die Masterbaugruppe („Scanner") versendet die Ausgangsdaten zyklisch zu den zugeordneten Teilnehmern und erhält die Eingangsdaten im Antworttelegramm.
Change-of-State
Telegramme werden versendet, sobald sich der Inhalt geändert hat.
Cyclic
Die Baugruppen versenden die Daten nach Ablauf einer Zykluszeit selbstständig.
Strobed
Der Scanner fordert die Eingangsdaten mit einem Broadcast-Telegramm an alle Teilnehmer an.


TwinCAT-Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] TwinCAT-Konfiguration
TwinCAT-Konfiguration
Die TwinCAT-Konfiguration ermöglicht das freie, Adressen-unabhängige Mapping der PLC-Daten zur CAN Slave-Schnittstelle.
TwinCAT Konfiguration
Für die Konfiguration benötigen Sie den TwinCAT System Manager und eine ADS-Verbindung zum BX/BCxx50.
Die ADS-Verbindung kann über die serielle Schnittstelle (siehe serielles ADS).


Adresse

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Adresse
Adresse
Die Adresse für das DeviceNet Slave-Interface ist über die zwei Drehwahlschalter einzustellen. Die Default-Einstellung beträgt 11. Es sind alle Adressen von 0 bis 63 erlaubt. Jede Adresse darf im Netzwerk nur einmal vorkommen. Die Adresse wird im ausgeschalteten Zustand des BX-Controllers geändert. Dafür verändern Sie mit Hilfe eines Schraubendrehers die Schalter auf die gewünschte Position. Beachten Sie dabei, dass die Schalter richtig einrasten. Der untere Schalter ist der Zehner-Multiplikator und der obere Schalter der Einer-Multiplikator. Die Adressänderung wird aktiv, sobald der BX-Controller wieder eingeschaltet wird.
Beispiel
Sie wollen Adresse 34 einstellen.
- unterer Drehwahlschalter S311: 3
- oberer Drehwahlschalter S310: 4
Einstellen der Node ID


Baud-Rate

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Baud-Rate
Baud-Rate
Auto Baud-Rate
Für die automatische Erkennung der Baud-Rate ist es erforderlich, dass mehrere gültige Telegramme der gewünschten Baud-Rate auf dem Bus vorhanden sind. Während die Baud-Rate gesucht wird blinken die LEDs RUN und CAN ERR in schnellem Wechsel. Sobald eine Baud-Rate erkannt und übernommen wurde fährt der Busklemmen Controller mit der Initialisierung fort.
Ein Software-Reset führt nicht zur erneuten Suche der Baud-Rate. Die vorher aktive Baud-Rate bleibt erhalten.


Masterparametrierung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] DeviceNet Slave-Schnittstelle [image] Masterparametrierung
Masterparametrierung
Konfiguration an einer Rockwell/Allen Bradley Steuerung
Der BX5200 und BC5250 verfügen über zwei Konfigurationsarten. In der Default Konfiguration wird der Koppler ausgeliefert und besitzt folgende DeviceNet Eigenschafen:
▪
AutoBaud
▪
8 Byte Eingänge DN (ab Adresse %IB1000) - auf dem Master sind das dann die Ausgänge
▪
8 Byte Ausgänge DN (ab Adresse %QB1000) - auf dem Master sind das dann die Eingänge
Ist es notwendig die voreingestellten Daten zu ändern so ist eine spezielle Bibliothek erforderlich.
In der TwinCAT Konfiguration kann man mit Hilfe des System Managers die DN Slave spezifischen Eigenschaften einstellen. Die Nutzung der Bibliothek für die Default Konfiguration ist nicht zu nutzen.
Das EDS-File und das Icon-File wird immer mit dem EDS-Wizard in RSNetworx eingebunden:
EDS Wizard
Im Anschluss wird mit dem Network-Browse das DeviceNet-Netzwerk nach den sich im Netz befindlichen Knoten abgesucht. Sind die BC/BX korrekt angeschlossen und mit der richtigen Baudrate am Netz werden sie erkannt und entsprechend eingeblendet:
Network-Browse
Durch einen Doppelklick auf das Icon öffnet sich der Dialog zur Konfiguration der Einheiten.
Unter den Parametern erscheinen die aktuell am BC/BX eingestellten I/O-Datenlängen.
Am BC/BX eingestellte I/O-Datenlängen
Die Produced- und Consumed-Angaben sind immer aus Netzwerk-Sicht zu betrachten, d.h. BC/BX produzieren Daten auf DeviceNet und konsumieren Daten von DeviceNet.
▪
Die produzierten Daten sind somit die Eingangsdaten des Masters, d.h. Daten die vom BC/BX zum Master gesendet werden: BC/BX Produced-Size = Input-Size Scanner
▪
Die konsumierten Daten sind die Ausgangsdaten des Masters, d.h. Daten die vom Master zum Slave gesendet werden: BC/BX Consumed-Size = Output-Size Scanner
Durch einen Doppelklick auf das Icon des Scanners/DeviceNet Masters öffnet sich der Dialog zur Konfiguration. Die erkannten Module erscheinen in der Liste der Available Devices und müssen nun in die Scan-Liste aufgenommen werden.
Übernahme der erkannten Module in die Scan-Liste
Durch einen Doppelklick auf das Icon des zu konfigurierenden Gerätes öffnet sich der Dialog zur Einstellung der I/O-Datenlängen
Einstellung der I/O-Datenlängen
▪
BC/BX Produced-Size = Input-Size
▪
BC/BX Consumed-Size = Output-Size
Des Weiteren muss darauf geachtet werden, dass hier die I/O-Betriebsart entsprechend der I/O-Mode Selektion ausgewählt wird.
Die Interscan-Verzögerung (Delay), d.h. die Zeit zwischen jedem I/O-Zyklus muss entsprechen den Anforderungen des BC/BX in Bezug auf die Größe des PLC-Programmes und I/O-Datenlängen ausgewählt werden.
Auswahl der Interscan-Verzögerung (Delay)
Sind Komponenten im Netzwerk die einen schnellen I/O-Zyklus erfordern, so kann in der I/O-Parameter-Einstellung unter Poll Rate der I/O-Zyklus auf Background eingestellt werden. Nähere Angaben hierzu sind dem Scanner-Manual zu entnehmen.
Einstellung der Poll Rate


K-Bus

Parametrierung und Inbetriebnahme [image] Konfiguration [image] K-Bus
K-Bus
Busklemme und Endklemme erforderlich
Zum Betrieb eines Busklemmen-Controllers der BC- oder BX-Serie müssen an dessen K-Bus mindestens eine Busklemme mit Prozessabbild und die Endklemme gesteckt sein!
Karteireiter BX Settings
Karteireiter BX Settings
Check Terminals during Start up
Beim Erzeugen eines Bootprojektes wird die aktuelle Busklemmenkonfiguration gespeichert. Beim Erneuten starten des Busklemmen-Controllers werden die angeschlossenen Busklemmen überprüft. Ist diese Option angewählt, geht der Busklemmen-Controller nicht in den Datenaustausch. Das PLC Projekt wird nicht gestartet.
Auto K-Bus Reset
Nach Behebung eines K-Bus-Fehlers geht der Busklemmen-Controller automatisch wieder in den Datenaustausch.
SmallWarningYellow VORSICHT
Nach Behebung eines K-Bus Fehlers werden die Ausgänge sofort wieder aktiv!
Achten Sie darauf, dass die Ausgänge dann sofort wieder aktiv werden und analoge Ausgänge ihren programmierten Wert erhalten, wenn dies nicht in Ihrem PLC-Projekt beachtet wurde.
Clear Outputs on Breakpoint
Wenn Breakpoints im PLC Control gesetzt werden, wird der K-Bus nicht mehr bearbeitet, das heißt die Ausgänge werden in den sichern Zustand, sprich null, gesetzt.
K-Bus Sync Mode
Das Schreiben und lesen der Busklemmen kann synchron zur Task1 oder dem Feldbus stattfinden.
K-Bus Re-Trigger
Sollte das PLC Projekt oder der SSB länger den Prozessor belasten, kann der K-Bus eine Zeit nicht mehr bearbeitet werden. Das führt dazu, dass der Watchdog der Busklemmen zuschlägt und Ausgänge abfallen. Der Busklemmen-Controller ist so eingestellt, das nach 85 ms der K-Bus Watchdog nachgetriggert wird und das 3 mal. Danach würde der K-Bus Watchdog zuschlagen.
K-Bus Re-Trigger 0: 100 ms
K-Bus Re-Trigger 1: 2 x 85 ms = 170 ms
K-Bus Re-Trigger 2: 3 x 85 ms = 255 ms
K-Bus Re-Trigger 3: 4 x 85 ms = 340 ms
Reaktion auf K-Bus Fehler
Bei K-Bus Fehler werden die K-Bus Eingänge auf "0" geschrieben oder behalten Ihren letzten Stand.
Reaktion auf PLC-Stop
Wird das PLC Projekt gestoppt, kann man Einstellen, wie sich die PLC Feldbus Ausgangsdaten verhalten sollen. Im Master sind diese Daten dann Eingangsdaten. Die Daten können bei PLC Stop auf "0" geschrieben oder unverändert gelassen werden.
Karteireiter BX Diag
Anzeige der Zykluszeit für Task 1, K-Bus, Bearbeitung Feldbus und die Auslastung des SSB.
Karteireiter BX Diag
Factory Settings - Der Busklemmen-Controller wird in seinen Auslieferungszustand gesetzt. Mit Restart System oder aus- und einschalten sind diese Einstellungen wieder gültig (Display DEFAULT-CONFIG).
Reset Maximum Values - löscht die Maximalen Werte
K-Bus Variablen
PLC-Interface: Wird nicht unterstützt (nur enthalten um CX oder BX Projekte zu verschieben)
K-Bus-State: Siehe Diagnose


PLC

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC
PLC
Weiterführende Informationen
•
Einfügen eines PLC-Projektes
•
Messen der PLC-Zykluszeit


Einfügen eines PLC-Projektes

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC [image] Einfügen eines PLC-Projektes
Einfügen eines PLC-Projektes
Für ein variables Mapping muss im System Manager die Konfiguration festgelegt sein. Hier vereinbart man die Verknüpfung zwischen PLC und der Hardware. Die Variablen können Bit, Byte, Wort oder Datenstrukturen verarbeiten und verknüpfen. Eine automatische Adressierung durch den System Manager ist möglich, sollte aber auf ihren Offset überprüft werden.
Word Alignment - Byte Orientierung
Achten Sie bei Datenstrukturen darauf, dass der Busklemmen-Controller die Daten in Word Alignment speichert und der System Manager Byte orientiert arbeitet (siehe Datenstrukturen)
Im PLC-Control muss ein gültiges Projekt übersetzt und gespeichert sein. Diese Daten werden als *.tpy Datei abgespeichert. Um ein PLC-Projekt einzufügen klicken Sie mit der rechten Maustaste auf PLC-Configuration. Wählen Sie Ihr aktuelles PLC Projekt aus.
systemmanager plc 1.gif
Auswahl des PLC-Projekts
Verbinden Sie die PLC-Variable mit der Hardware (z. B. digitale Busklemme).
systemmanager plc 2.gif
Verbinden vom PLC-Variable und Hardware
Nachdem alle Verknüpfungen erstellt sind aktivieren Sie die Konfiguration Actions/Activate Configuration (Ctrl+Shift+F4) und Starten Sie TwinCAT Set/Reset TwinCAT to Run Mode. Achten Sie darauf, dass Sie das richtige Zielsystem angewählt haben (unten rechts im Fenster des System-Managers).
Anzeige des Ziel-Systems


Messen der PLC-Zykluszeit

Parametrierung und Inbetriebnahme [image] Konfiguration [image] PLC [image] Messen der PLC-Zykluszeit
Messen der PLC-Zykluszeit
Die Task-Zeit wird im PLC Control eingestellt. Die Default Einstellung beträgt 20 ms.
Einstellen der Task-Zeit
Das PLC-Programm wird in der Default-Einstellung alle 20 ms erneut aufgerufen, solange die allgemeine Zykluszeit keiner als 20 ms ist. Um die Auslastung ihres Systems zu ermitteln kann im System Manager die Zykluszeit der PLC gemessen werden. Um einen Problemlosen Betrieb zu garantieren, muss die eingestellte Task-Zeit 20 bis 30 % höher sein als die gemessene gesamt Zykluszeit. Eine genauere Aufschlüsselung der Zykluszeit fingen Sie unter der Beschreibung K-Bus-Reiter. Die gesamte Zykluszeit wird mit der TcBase Bibliothek angezeigt (siehe TcBase.lbx oder TcBaseBCxx50.lbx).
Anzeige der PLC-Zykluszeit


SSB

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB
SSB
Weiterführende Informationen
•
SSB - Überblick
•
CANopen Verkabelung
•
SSB - Konfiguration
•
SSB - SDO-Kommunikation
•
SDO-Kommunikation aus der PLC
•
CANopen Trouble Shooting
•
Emergency-Telegramme und Diagnose
•
Beispiele


SSB - Überblick

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] SSB - Überblick
SSB - Überblick
Der SSB (Smart System Bus) ist ein auf CANopen basierendes Sub-Bussystem. Es handelt sich dabei um einen CANopen-Master mit eingeschränkter Funktionalität. CANopen-Slaves können an dieser Schnittstelle angeschlossen sein, um dezentrale I/Os einzulesen oder zu beschreiben. Über ein Startup-Fenster können dem Slave parametrierungs-SDOs (Service Data Objects) geschickt werden.
Konfiguration
Der SSB wird mit Hilfe des TwinCAT System Manager projektiert (siehe TwinCAT config). Die Konfiguration wird dann per ADS auf den BX-Controller gespielt.
Technische Daten
SSB | Daten
Max. Anzahl an Slaves | 8
Max. Anzahl an PDOs | 32 RxPODs / 32 TxPDOs
Baudrate | 10 kBaud bis 1 MBaud
Erlaubte Slave Adressen | 1 bis 64
Sync-Telegramm
Das Sync-Telegramm wird in Abhängigkeit zur PLC-Task-Zeit übertragen. Ist eine Taskzeit von 20 ms eingestellt wird auch das Sync-Telegramm alle 20 ms asynchron zur PLC Laufzeit versendet. Das Sync-Telegramm wird erst erzeugt, wenn ein Teilnehmer dieses Benötigt und dieser Konfiguriert wird.
Das Sync-Telegramm wird ab der Firmware 1.12 unterstützt.
Guarding
Das Guarding wird unterstützt und wird nach einer konfigurierbaren Zeit versendet.


CANopen Verkabelung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung
CANopen Verkabelung
Hinweise für die Überprüfung der CAN-Verdrahtung finden sich im Kapitel Fehlersuche / Trouble Shooting.
Weiterführende Informationen
•
CAN-Topologie
•
Buslänge
•
Stichleitungen
•
Sternverteiler (Multiport Tap)
•
CAN-Kabel
•
Schirmung
•
Kabelfarben
•
BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig
•
BK51x0/BX5100: 5poliger Open Style Connector
•
LC5100: Busanschluss über Federkraftklemmen
•
Feldbus Box: M12 CAN Buchse


CAN-Topologie

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] CAN-Topologie
CAN-Topologie
CAN ist ein 2-Draht-Bussystem, an dem alle Teilnehmer parallel (d.h. mit kurzen Stichleitungen) angeschlossen werden. Der Bus muss an jedem Ende mit einem Abschlusswiderstand von 120 (bzw. 121) Ohm abgeschlossen werden, um Reflexionen zu vermeiden. Dies ist auch bei sehr kurzen Leitungslängen erforderlich!
Abschluss des Busses mit Abschlusswiderstand 120 Ohm
Da die CAN-Signale als Differenzpegel auf dem Bus dargestellt werden, ist die CAN-Leitung vergleichsweise unempfindlich gegen eingeprägte Störungen (EMI). Es sind jeweils beide Leitungen betroffen, somit verändert die Störung den Differenzpegel kaum.
Unempfindlichkeit gegen eingeprägte Störungen


Buslänge

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] Buslänge
Buslänge
Die maximale Buslänge wird bei CAN vorwiegend durch die Signallaufzeit beschränkt. Das Multi-Master-Buszugriffsverfahren (Arbitrierung) erfordert, dass die Signale quasi gleichzeitig (vor der Abtastung innerhalb einer Bitzeit) an allen Knoten anliegen. Da die Signallaufzeit in den CAN-Anschaltungen (Transceiver, Optokoppler, CAN-Controller) nahezu konstant sind, muss die Leitungslänge an die Baud-Rate angepasst werden.
Baud-Rate | Buslänge
1 MBit/s | < 20 m*
500 kBit/s | < 100 m
250 kBit/s | < 250 m
125 kBit/s | < 500 m
50 kBit/s | < 1000 m
20 kBit/s | < 2500 m
10 kBit/s | < 5000 m
*) Häufig findet man in der Literatur für CAN die Angabe 40 m bei 1 MBit/s. Dies gilt jedoch nicht für Netze mit optoentkoppelten CAN-Controllern. Die worst case Berechnung mit Optokopplern ergibt bei 1 MBit/s eine maximale Buslänge von 5 m - erfahrungsgemäß sind jedoch 20 m problemlos erreichbar.
Bei Buslängen über 1000 m kann der Einsatz von Repeatern notwendig werden.


Stichleitungen

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] Stichleitungen
Stichleitungen
Stichleitungen ("drop lines") sind nach Möglichkeit zu vermeiden, da sie grundsätzlich zu Signalreflexionen führen. Die durch Stichleitungen hervorgerufenen Reflexionen sind jedoch in der Regel unkritisch, wenn sie vor dem Abtastzeitpunkt vollständig abgeklungen sind. Bei den in den Buskopplern gewählten Bit-Timing-Einstellungen kann dies angenommen werden, wenn folgende Stichleitungslängen nicht überschritten werden:
Baud-Rate | Länge Stichleitung | gesamte Länge aller Stichleitungen
1 MBit/s | < 1 m | < 5 m
500 kBit/s | < 5 m | < 25 m
250 kBit/s | < 10 m | < 50 m
125 kBit/s | < 20 m | < 100 m
50 kBit/s | < 50 m | < 250 m
Stichleitungen dürfen nicht mit Abschlusswiderständen versehen werden.
Beispieltopologie Stichleitungen


Sternverteiler (Multiport Tap)

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] Sternverteiler (Multiport Tap)
Sternverteiler (Multiport Tap)
Beim Einsatz von passiven Verteilern ("Multiport Taps"), z. B. der Beckhoff Verteilerbox ZS5052-4500 sind kürzere Stichleitungslängen einzuhalten. Die folgende Tabelle gibt die maximalen Stichleitungslängen und die maximale Länge der Trunk Line (ohne Stichleitungen) an:
Baud-Rate | Länge Stichleitung bei Multiport Topologie | Länge Trunk Line (ohne Stichleitungen)
1 MBit/s | < 0,3 m | < 25 m
500 kBit/s | < 1,2 m | < 66 m
250 kBit/s | < 2,4 m | < 120 m
125 kBit/s | < 4,8 m | < 310 m


CAN-Kabel

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] CAN-Kabel
CAN-Kabel
Für die CAN-Verdrahtung wird die Verwendung von paarig verdrillten, geschirmten Kabeln (2x2) mit einem Wellenwiderstand von 108...132 Ohm empfohlen. Wenn das Bezugspotential der CAN-Transceiver (CAN-Ground) nicht verbunden werden soll, so kann auf das zweite Adernpaar verzichtet werden (nur bei kleinen Netzausdehnungen mit gemeinsamer Speisung aller Teilnehmer empfehlenswert).
ZB5100 CAN-Kabel
Beckhoff hat ein hochwertiges CAN-Kabel mit folgenden Eigenschaften im Programm:
▪
2 x 2 x 0,25 mm² (AWG 24) paarig verseilt, Kabelfarben: rot/schwarz + weiß/schwarz
▪
doppelt geschirmt
▪
Schirmgeflecht mit Beilauflitze (kann direkt auf Pin3 der 5-pol Anschlussklemme aufgelegt werden)
▪
flexibel (Mindestbiegeradius 35 mm bei einmaligem Biegen, 70 mm bei mehrmaligem Biegen)
▪
Wellenwiderstand (60 kHz): 120 Ohm
▪
Leiterwiderstand < 80 Ohm/km
▪
Mantel: PVC grau, Außendurchmesser 7,3 +/- 0,4 mm
▪
Gewicht: 64 kg/km.
▪
Bedruckt mit "Beckhoff ZB5100 CAN-BUS 2x2x0.25" und Metermarkierung (Längenangaben, alle 20cm)
Aufbau CAN-Kabel ZB5100
ZB5200 CAN/DeviceNet-Kabel
Das Kabelmaterial ZB5200 entspricht der DeviceNet Spezifikation und eignet sich ebenso für CANopen Systeme. Aus diesem Kabelmaterial sind auch die vorkonfektionierten Busleitungen ZK1052-xxxx-xxxx für die Feldbus Box Baugruppen gefertigt. Es hat folgende Spezifikation:
▪
2 x 2 x 0,34 mm² (AWG 22) paarig verseilt
▪
doppelt geschirmt, Schirmgeflecht mit Beilauflitze
▪
Wellenwiderstand (1 MHz): 126 Ohm
▪
Leiterwiderstand 54 Ohm/km
▪
Mantel: PVC grau, Außendurchmesser 7,3 mm
▪
Bedruckt mit "InterlinkBT DeviceNet Type 572" sowie UL und CSA Ratings
▪
Litzenfarben entsprechen DeviceNet Spezifikation
▪
UL anerkanntes AWM Type 2476 Rating
▪
CSA AWM I/II A/B 80°C 300V FT1
▪
Entspricht DeviceNet "Thin Cable" Spezifikation
Aufbau CAN-/DeviceNet-Kabel ZB5200


Schirmung

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] Schirmung
Schirmung
Der Schirm ist über das gesamte Buskabel zu verbinden und nur an einer Stelle galvanisch zu erden um Masseschleifen zu vermeiden.
Das Schirmungskonzept mit HF-Ableitung von Störungen über R/C-Glieder auf die Tragschiene geht davon aus, dass die Tragschiene entsprechend geerdet und störungsfrei ist. Sollte dies nicht der Fall sein, so kann es vorkommen, dass HF-Störpegel über die Tragschiene auf den Schirm des Buskabels übertragen werden. In diesem Fall sollte der Schirm an den Kopplern nicht aufgelegt werden - aber dennoch komplett durchverbunden sein.
Hinweise für die Überprüfung der CAN-Verdrahtung finden sich im Kapitel Fehlersuche / Trouble Shooting.


Kabelfarben

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] Kabelfarben
Kabelfarben
Vorschlag für die Verwendung der Beckhoff CAN-Kabel an Busklemme und Feldbus Box:
Pin BK51x0 PIN BX5100 (X510) | Pin BK5151 CX8050, CX8051, CXxxxx-B510/M510 | Pin Feldbus Box | Pin FC51xx | Funktion | Kabelfarbe ZB5100 | Kabelfarbe ZB5200
1 | 3 | 3 | 3 | CAN Ground | schwarz /(rot) | schwarz
2 | 2 | 5 | 2 | CAN Low | schwarz | blau
3 | 5 | 1 | 5 | Schirm | Beilauflitze | Beilauflitze
4 | 7 | 4 | 7 | CAN high | weiß | weiß
5 | 9 | 2 | 9 | nicht benutzt | (rot) | (rot)


BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig
BK5151, FC51xx, CX mit CAN Interface und EL6751: D-Sub 9polig
Die CAN Busleitung wird an die FC51x1, FC51x2 CANopen Karten und bei der EL6751 CANopen Master-/Slaveklemme über 9polige Sub-D-Buchsen mit folgender Steckerbelegung angeschlossen.
Pin | Belegung
2 | CAN low (CAN-)
3 | CAN Ground (intern verbunden mit Pin 6)
6 | CAN Ground (intern verbunden mit Pin 3)
7 | CAN high (CAN+)
Die nicht aufgeführten Pins sind nicht verbunden.
Die Tragschienenkontaktfeder und der Steckerschirm sind durchverbunden.
Hinweis: an Pin 9 darf eine Hilfsspannung bis 30 VDC angeschlossen sein (wird von manchen CAN Geräten zur Versorgung der Transceiver genutzt).
Pinbelegung BK5151, EL6751
FC51x2:
FC51x2


BK51x0/BX5100: 5poliger Open Style Connector

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] BK51x0/BX5100: 5poliger Open Style Connector
BK51x0/BX5100: 5poliger Open Style Connector
Bei den BK51x0/BX5100 (X510) Buskopplern befindet sich auf der linken Seite eine abgesenkte Frontfläche mit einem 5poligen Stecker.
Hier kann die mitgelieferte CANopen- Verbindungsbuchse eingesteckt werden.
Belegung Verbindungsbuchse BK51x0/BX5100
Das linke Bild zeigt die Buchse im Buskoppler BK51x0/BX5100. Pin 5 ist dabei der oberste Pin auf der Steckerleiste. Pin 5 ist nicht benutzt. Pin 4 ist die CAN-High-Leitung, Pin 2 die CAN-Low-Leitung und an Pin 3 wird der Schirm aufgelegt (ist über eine R/C-Schaltung mit der Tragschiene verbunden). Optional kann am Pin 1 CAN-GND angeschlossen werden. Wenn alle CAN-Ground Pins verbunden sind ergibt dies ein gemeinsames Bezugspotential für die CAN Transceiver im Netz. Es empfiehlt sich, CAN-GND an einer Stelle zu erden, damit das gemeinsame CAN Bezugspotential nahe beim Versorgungs-Potential liegt. Da die CANopen Buskoppler BK51X0/BX5100 über eine vollständige galvanische Trennung des Busanschlusses verfügen, kann u.U. auf die Verdrahtung von CAN-Ground verzichtet werden.
Businterface Connector ZS1052-3000
Alternativ zum mitgelieferten Stecker kann der CAN Interface Connector ZS1052-3000 eingesetzt werden. Dieser vereinfacht die Verdrahtung erheblich. Für die ankommenden und abgehenden Leitungen stehen separate Klemmen zur Verfügung, der Schirm wird durch die Zugentlastung großflächig angeschlossen. Der integrierte Abschlusswiderstand kann von außen zugeschaltet werden. Ist er eingeschaltet, so wird die abgehende Busleitung elektrisch abgetrennt - damit lassen sich Verdrahtungsfehler schnell lokalisieren, und es ist gewährleistet, dass nicht mehr als zwei Widerstände im Netz aktiv sind.


LC5100: Busanschluss über Federkraftklemmen

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] LC5100: Busanschluss über Federkraftklemmen
LC5100: Busanschluss über Federkraftklemmen
Beim Low-Cost-Koppler LC5100 wird die CAN-Leitung direkt auf die Klemmstellen 1 (CAN-H, gekennzeichnet mit C+) bzw. 5 (CAN-L, gekennzeichnet mit C-) aufgelegt. Der Schirm kann optional auf die Klemmstellen 4 bzw. 8 aufgelegt werden, diese sind über eine R/C-Schaltung mit der Tragschiene verbunden.
LC5100
Hinweis
Beschädigung der Geräte möglich!
Durch die nicht vorhandene galvanische Trennung kann durch unsachgemäße Verkabelung der CAN Treiber zerstört oder geschädigt werden. Verkabeln sie immer im ausgeschalteten Zustand.
Verkabeln Sie erst die Spannungsversorgung und legen sie erst dann den CAN auf. Überprüfen Sie die Verkabelung und schalten dann erst die Spannung ein.


Feldbus Box: M12 CAN Buchse

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Verkabelung [image] Feldbus Box: M12 CAN Buchse
Feldbus Box: M12 CAN Buchse
Bei der Feldbus Box IPxxxx-B510, IL230x-B510 und IL230x-C510 wird der Busanschluss mit 5poligen M12 Steckverbindern ausgeführt.
Pinbelegung M12 Stecker Feldbus Box
Für das Feldbus Box System bietet Beckhoff feldkonfektionierbare Stecker, Passivverteiler, Abschlusswiderstände sowie eine große Auswahl an vorkonfektionierten Kabeln an. Details finden sich im Katalog oder unter www.beckhoff.de.


SSB - Konfiguration

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] SSB - Konfiguration
SSB - Konfiguration
Der SSB wird im System Manager konfiguriert. Öffnen Sie Ihre bestehende Konfiguration oder öffnen Sie eine neue Konfiguration in der Sie das PLC-Projekt, K-Bus und den übergeordneten Feldbus bereits konfiguriert haben.
Sie können nun unter I/O Devices (linke Maustaste) ein weiteres Gerät anfügen.
Anfügen eines weiteren Gerätes
Wählen Sie den CANopen Master SSB aus und bestätigen Sie mit OK.
Auswahl des CANopen Masters SSB
Als nächstes kann mit der linken Maustaste auf dem SSB-Device ein CANopen-Knoten angewählt werden.
Anfügen eines CANopen Geräts
Es stehen hier alle Beckhoff CAN-Knoten zur Verfügung sowie ein allgemeiner CANopen-Node für CANopen-Geräte anderer Hersteller.
Auswahl eines CANopen-Knotens
Verknüpfen Sie nun die PLC Variablen mit Ihren CAN-Knoten. Nach erfolgreicher Konfiguration laden Sie diese in den BX.


SSB - SDO-Kommunikation

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] SSB - SDO-Kommunikation
SSB - SDO-Kommunikation
CANopen SDO-Kommunikation (Service Daten Objekt) dient zum Auslesen bzw. Beschreiben beliebiger Parameter im Objektverzeichnis des CANopen Busknotens. Der SSB benutzt die SDO-Kommunikation zur Konfiguration der Kommunikationsparameter beim Aufstarten.
Download von anwendungsspezifischen Parametern beim Aufstarten
Hierzu sind die entsprechenden Parameter im System Manager bei dem entsprechenden Knoten im Karteireiter SDO einzugeben. In eckigen Klammern erscheinen die Objekte, die sich aus den Konfigurationen im Griff CAN Node ergeben. Anschließend können beliebige Objektverzeichniseinträge angefügt werden.
Anfügen/Bearbeiten von Objektverzeichniseinträgen
Der SSB erwartet eine positive Quittierung des Parameterdownloads vom jeweiligen Busteilnehmer. Falls ein Parameter nicht geschrieben werden konnte (SDO-Abbruch durch Busteilnehmer), so versucht die Karte den entsprechenden Wert auszulesen und mit dem zu schreibenden Wert zu vergleichen - es könnte sich ja z. B. um einen schreibgeschützten Wert (Read only) handeln, der bereits korrekt im Busteilnehmer konfiguriert ist. Bei Übereinstimmung geht die Karte zum nächsten Parametereintrag.


SDO-Kommunikation aus der PLC

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] SDO-Kommunikation aus der PLC
SDO-Kommunikation aus der PLC
Für die SDO-Kommunikation aus der PLC heraus verwendet man die ADS-Bausteine. Mit diesen Bausteinen ist es möglich SDO-Telegramme zu versenden und die Antwort des Slaves zu empfangen (ADSWRITE/ADSREAD).
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX oder leer lassen zum Beispiel mit ''
Port Nummer | 0x1000hex + NodeId (Slave Nummer)
IDXGRP | SDO Index
IDXOFFS | SDO Subindex
LEN | Länge der SDO Daten (1...4)
Download BX ( )
Setzen einzelner oder aller Knoten in den Pre-Operational oder Operational Zustand
Mit dem ADSWRTCTL Baustein können Sie einzelne CANopen Knoten oder alle Slaves in den Pre-Operational oder Operational Zustand versetzen.
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX oder leer lassen zum Beispiel mit ''
Port Nummer | 0x1000hex + NodeId (Slave Nummer) / 153dez (alle Knoten)
ADSSTATE | ADSSTATE_RUN
DEVSTATE | 1 - Pre / 0 - Operational
LEN | 0
SRCADDR | 0
Download BX ( )
SSB Interface neu Starten
Mit dem ADSWRTCTL Baustein kann der SSB gestoppt und neu gestartet werden. Führen Sie als erstes ein Stopp aus und als nächstes einen Start aus.
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX oder leer lassen zum Beispiel mit ''
Port Nummer | 153dez
ADSSTATE | ADSSTATE_STOP, ADSSTATE_RUN
DEVSTATE | 0
LEN | 0
SRCADDR | 0
oder
Eingangsparameter | Beschreibung (ab Software Version 1.16 bei allen BX Controllern)
NETID | lokale NetId des BX oder leer lassen zum Beispiel mit ''
Port Nummer | 300dez
ADSSTATE | ADSSTATE_RESET
DEVSTATE | 0
LEN | 4
SRCADDR | ADR auf eine DWORD Variable mit der ID des SSB Device (die ID ist aus dem System Manger File zu entnehmen und ist typischerweise ein Wert von 1...3)


CANopen Trouble Shooting

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] CANopen Trouble Shooting
CANopen Trouble Shooting
Error Frames
Fehler in der CAN-Verkabelung, der Adressvergabe und der Baud-Rateneinstellung zeigen sich u.a. durch eine erhöhte Anzahl an Error Frames: die Diagnose LEDs zeigen dann Warning Limit wird überschritten oder Bus-Off-Zustand erreicht.
Error Frames
Überschrittenes Warning Limit, Error Passive oder Bus-Off Zustand werden zunächst bei demjenigen Knoten angezeigt, der die meisten Fehler entdeckt hat. Dieser Knoten muss nicht unbedingt die Ursache für das Auftreten dieser Error Frames sein!
Wenn z. B. ein Knoten überdurchschnittlich stark zum Busverkehr beiträgt (z. B. weil er als einziger über analoge Eingänge verfügt, deren Daten in kurzen Abständen ereignisgesteuerte PDOs auslösen), so werden auch seine Telegramme mit großer Wahrscheinlichkeit zunächst gestört - entsprechend erreicht sein Fehlerzähler als erster kritische Zustände.
Node-ID / Baud Rate Einstellung
Es muss sorgfältig darauf geachtet werden, dass keine Knotenadresse doppelt vergeben ist: für jedes CAN-Datentelegramm darf es nur einen Sender geben.
Test 1
Knotenadressen überprüfen. Falls die CAN Kommunikation wenigstens zeitweise funktioniert und alle Geräte die Boot-Up-Nachricht unterstützen, so kann die Adressvergabe auch durch Aufzeichnen der Boot-Up-Nachrichten nach dem Einschalten der Geräte überprüft werden - hierdurch wird aber kein Vertauschen von Knotenadressen erkannt.
Test 2
Überprüfen, ob überall die gleiche Baud-Rate eingestellt ist. Bei Sondergeräten: Wenn Bittiming Parameter zugänglich, stimmen diese mit den CANopen-Definitionen überein (Abtastzeitpunkt, SJW, Oszillator).
Test der CAN-Verkabelung
Diese Tests nicht ausführen, wenn das Netzwerk aktiv ist: Während der Tests sollte keine Kommunikation stattfinden. Die folgenden Tests sollten in der angegebenen Reihenfolge ausgeführt werden, da manche Tests davon ausgehen, dass der vorhergehende Test erfolgreich war. In der Regel sind nicht alle Tests notwendig.
Netzwerkabschluss und Signalleitungen
Für diesen Test sollten die Knoten ausgeschaltet oder die CAN-Leitung abgesteckt sein, da die Messergebnisse sonst durch die aktiven CAN-Transceiver verfälscht werden können.
Verdrahtungsplan für Testaufbau
Test 3
Widerstand zwischen CAN-high und CAN-low ermitteln - ggf. bei jedem Gerät.
Wenn der Messwert über 65 Ohm liegt, deutet dies auf fehlende Abschlusswiderstände oder den Bruch einer Signalleitung hin. Wenn der Messwert kleiner 50 Ohm ist, nach Kurzschluss zwischen CAN-Leitung, überzähligen Abschlusswiderständen oder fehlerhaften Transceivern suchen.
Test 4
Auf Kurzschluss zwischen CAN-Ground und den Signalleitungen sowie zwischen Schirm und Signalleitungen prüfen.
Test 5
Erdung von CAN-Ground und Schirm auftrennen. Auf Kurzschluss zwischen CAN-Ground und Schirm prüfen.
Topologie
Die Leitungslänge bei CAN Netzwerken hängt stark von der gewählten Baud-Rate ab. CAN toleriert dabei kurze Stichleitungen - ebenfalls in Abhängigkeit von der Baud-Rate. Die erlaubte Stichleitungslänge sollte nicht überschritten werden. Häufig wird die verlegte Leitungslänge unterschätzt - die Schätzung liegt teilweise Faktor 10 unter der tatsächlichen Länge. Deshalb empfiehlt sich folgender Test:
Test 6
Die Stichleitungslängen sowie die Busgesamtlänge nachmessen (nicht nur grob schätzen!) und mit den Topologieregeln (Baud-Ratenabhängig) vergleichen.
Schirmung und Erdung
Stromversorgung und Schirm sollten sorgfältig, einmalig und niederohmig beim Netzteil geerdet werden. Alle Verbindungsstellen, Abzweige etc. im CAN-Kabel müssen neben den Signalleitungen (und evtl. CAN-GND) auch den Schirm durchverbinden. In den Beckhoff IP20 Buskopplern wird der Schirm über ein R/C-Glied hochfrequenzmäßig geerdet.
Test 7
Mit DC-Strommessgerät (16 Amp max.) Strom zwischen Spannungsversorgungs-Masse und Schirm am vom Netzteil entfernten Ende des Netzes messen. Es sollte ein Ausgleichsstrom vorhanden sein. Wenn kein Strom vorhanden ist, so ist der Schirm nicht durchgängig verbunden oder das Netzteil ist nicht richtig geerdet. Wenn das Netzteil in der Mitte des Netzwerkes angeordnet ist, so sollte an beiden Enden gemessen werden. Dieser Test kann u.U. auch an den Stichleitungsenden durchgeführt werden.
Test 8
Den Schirm an mehreren Stellen auftrennen und den Verbindungsstrom messen. Wenn ein Stromfluss vorhanden ist, so ist der Schirm an mehreren Stellen geerdet (Erdschleife)
Potentialunterschiede
Der Schirm muss für diesen Test durchgängig sein und darf keinen Strom führen (vorher getestet).
Test 9
Spannung zwischen Schirm und Spannungsversorgungs-Erde an jedem Knoten ermitteln und notieren. Der maximale Potentialunterschied zwischen zwei beliebigen Geräten sollte kleiner als 5 Volt sein.
Fehler erkennen und lokalisieren
Am besten funktioniert in der Regel der "Low-tech-Ansatz": Teile des Netzes abhängen und beobachten, wann der Fehler verschwindet.
Aber: Dies funktioniert nicht gut bei Problemen wie zu großen Potentialunterschieden, Masseschleifen, EMV und Signalverfälschung da die Verkleinerung des Netzes häufig das Problem löst, ohne dass der „fehlende“ Teil ursächlich war. Auch die Buslast ändert sich beim Verkleinern des Netzes - damit können externe Störungen seltener CAN-Telegramme "treffen".
Die Diagnose mittels Oszilloskop führt meist nicht zum Erfolg: CAN Signale sehen auch im ungestörten Zustand teilweise recht wirr aus. Unter Umständen kann mit einem Speicheroszilloskop auf Error Frames getriggert werden - diese Art der Diagnose ist aber Messtechnik-Experten vorbehalten.
Protokollprobleme
In seltenen Fällen sind auch Protokollprobleme (z. B. fehlerhafte oder unvollständige CANopen-Implementierung, unglückliches Timing im Boot-Up etc.) Ursache von Störungen. Hier ist dann ein Mitschrieb (Trace) des Busverkehrs mit anschließender Auswertung durch CANopen Experten erforderlich - das Beckhoff Support Team kann hier helfen.
Für solch einen Trace eignet sich ein freier Kanal einer Beckhoff FC5102 CANopen PCI-Karte - die erforderliche Trace-Software stellt Beckhoff im Internet zur Verfügung. Alternativ kann selbstverständlich auch ein handelsübliches CAN Analysetool eingesetzt werden.
Protokollprobleme lassen sich vermeiden, indem auf den Einsatz von Geräten verzichtet wird, die nicht Conformance getestet sind. Der offizielle CANopen Conformance Test und das entsprechende Zertifikat sind beim CAN in Automation Verband (http://www.can-cia.de) erhältlich.


Emergency-Telegramme und Diagnose

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Emergency-Telegramme und Diagnose
Emergency-Telegramme und Diagnose
Über den NodeState wird der Status des CAN-Slaves angezeigt. Das DiagFlag wird gesetzt wenn ein Emergency-Telegramm empfangen wurde. Der EmergencyCounter zählt bei jedem Emergency-Telegramm eins hoch.
NodeState, DiagFlag und EmergencyCounter
Wert NodeState | Beschreibung
0 | No error
1 | Node deactivated
2 | Node not found
4 | SDO syntax error at Start Up
5 | SDO data mismatch at Start Up
8 | Node start up in progress
11 | SSB Bus off
12 | Pre-Operational
13 | Servere bus fault
14 | Guarding: toggle error
20 | TxPDO too short
22 | Expected TxPDO is missing
23 | Node is Operational but not all TxPDOs were received
ADS Port 153
Auslesen der Emergency Telegramme mit AdsRead
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX
Port Nummer | 153
IDXGRP | 16#xxxxF180 (xxxx) NodeId, das Diag Flag wird nur beim Auslesen von mindesten 106 Byte zurückgesetzt 16#xxxxF181 (xxxx) NodeId, das Diag Flag wird sofort zurückgesetzt
IDXOFFS | Byte Offset
Beschreibung des Arrays
Offset | Bit | Wert / Beschreibung
0 - 1 | Bit 0 | reserviert
 | Bit 1 | Boot-Up-Message nicht empfangen oder fehlerhaft
 | Bit 2 | Emergency-Overflow
 | Bit 3 - 15 | reserviert
2 - 3 | Bit 0 - 14 | TX-PDO (i+1) empfangen
 | Bit 15 | alle TX-PDOs 16-n empfangen
4 - 5 | Bit 0 - 4 | 1: falsche TX-PDO-Länge
 |  | 2: synchrone TX-PDO fehlt
 |  | 3: Node meldet PRE-OPERATIONAL
 |  | 4: Event-Timer bei einer TX-PDO abgelaufen
 |  | 5: keine Antwort beim Guarden
 |  | 6: mehrmals kein Toggeln beim Guarden
 | Bit 5 - 15 | zugehörige COB-ID
6 | Bit 0 - 7 | 1: falscher Wert bei einem SDO-Upload
 |  | 2: falsche Länge bei einem SDO-Upload
 |  | 3: Abort bei einem SDO-Up-/Download
 |  | 4: falsches Datum bei einer Boot-Up-Message
 |  | 5: Timeout beim Warten auf Boot-Up-Message
7 | Bit 0 - 7 | 2: falscher SDO-Command specifier
 |  | 3: SDO-Toggle-Bit hat sich nicht geändert
 |  | 4: SDO-Länge zu groß
 |  | 5: SDO-Abort
 |  | 6: SDO-Timeout
8 - 9 | Bit 0 - 7 | Index des SDO-Up/Downloads
10 | Bit 0 - 7 | Subindex des SDO-Up/Downloads
11 | Bit 0 - 7 | reserviert
12 | Bit 0 - 7 | errorClass des Aborts
13 | Bit 0 - 7 | errorCode des Aborts
14 - 15 | Bit 0 - 15 | additionalCode des Aborts
16 - 19 |  | gelesener Wert (falls Offset 6 = 1)
20 - 23 |  | erwarteter Wert (falls Offset 6 = 1)
24 - 25 |  | Anzahl der folgenden Emergencies
26 - n |  | Emergencies (jeweils 8 Byte)
Download BX ( )
Download Beispiel System-Manager File BX ( )
Auslesen der Anzahl der PDO Telegramme mit AdsRead
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX
Port Nummer | 153
IDXGRP | 16#xxxxF930 (xxxx) NodeId
IDXOFFS | 0
Download BX ( )
Konfiguration der Node-ID erforderlich
Die Node-ID muss vor dem Aufruf des ADS-Baustein in der TwinCAT-Konfiguration konfiguriert worden sein.
Beliebige CAN Nachricht verschicken
Mit diesem ADSWRITE Befehl ist es möglich eine beliebige CAN Nachricht zu versenden.
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX
Port Nummer | 153
IDXGRP | 16#0000F921
IDXOFFS | 0
LEN | 11 Bytes
SRCADDR | Pointer auf ein ARRAY von 11 Byte
Aufbau der 11 Byte CAN Daten
Byte | Beschreibung | Beispiel Node 7 SDO 0x607 Len 8 Download Request 0x2100 (Index) Sub Index 1 - Value "1"
1 | COB-ID LowByte | 0x06 (SDO Low Byte)
2 | COB-ID HighByte | 0x07 (SDO High Byte)
3 | LEN (Länge) | 0x08 (Len, kann hier auch 5 sein)
4 | Daten[1] | 0x22 (Download Request)
5 | Daten[2] | 0x00 (Index Low Byte)
6 | Daten[3] | 0x21 (Index High Byte)
7 | Daten[4] | 0x01 (Sub Index)
8 | Daten[5] | 0x01 (Value "1")
9 | Daten[6] | 0x00
10 | Daten[7] | 0x00
11 | Daten[8] | 0x00


Beispiele

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele
Beispiele
Weiterführende Informationen
•
BK5120 am SSB
•
Kommunikation von BX-Controller zu BX-Controller (über SSB)
•
AX2000 am SSB
•
Cimrex-Panel am SSB des BX-Controllers
•
IclA-Drive am SSB
•
Lenze Frequenzumrichter am SSB


BK5120 am SSB

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele [image] BK5120 am SSB
BK5120 am SSB
Notwendiges Material:
▪
TwinCAT 2.9 Build 953 oder Größer
▪
BX3100 Version 0.80 oder Größer, BX5100 Version 0.13, BX8000 Version 0.04
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x BK5120
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
Verkabelungsmaterial sowie Spannungsversorgung
▪
TwinCAT System Manager File ( )
(Das System Manager File muss per ADS auf den BX-Controller geladen werden).
▪
BX-Programm File ( )
Für den Konfigurations-Download über ADS benötigt man entweder einen BECKHOFF Feldbus-Master oder eine freie serielle Schnittstelle.


Kommunikation von BX-Controller zu BX-Controller (über SSB)

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele [image] Kommunikation von BX-Controller zu BX-Controller (über SSB)
Kommunikation von BX-Controller zu BX-Controller (über SSB)
Über den SSB können 2 oder mehrere BX-Controller untereinander Daten austauschen. Verwenden Sie im System Manager bei der Projektierung dieses Datenaustausches CAN-Schicht 2 Telegramme.
Über die COB Id wird die Kommunikation des CAN-Telegramms festgelegt. Um welchen BX-Typ es sich dabei handelt spielt keine Rolle, da der SSB auf jedem BX-Controller vorhanden ist, sich auch gleich verhält und projektiert wird.
Kommunikation von BX-Controller zu BX-Controller (über SSB)
Beispielkonfiguration
BX_ONE:
Node Id 2
CAN_Out AT %QB100: ARRAY[0..7] OF BYTE
COD Id 514 0x202
CAN_In AT %IB100: ARRAY[0..7] OF BYTE
COD Id 386 0x182
BX_TWO:
Node Id 2
CAN_Out AT %QB100: ARRAY[0..7] OF BYTE
COD Id 386 0x182
CAN_In AT %IB100: ARRAY[0..7] OF BYTE
COD Id 514 0x202
Beispiel Konfiguration und Programm:
Notwendiges Material
▪
TwinCAT 2.9 Build 959 oder Größer
▪
2 x BXxx00
▪
Verkabelungsmaterial sowie Spannungsversorgung
▪
TwinCAT System Manager File BX_ONE ( )
▪
Programm File BX_ONE ( )
▪
TwinCAT System Manager File BX_TWO ( )
▪
Programm File BX_ONE ( )
Für den Konfigurations-Download über ADS benötigt man entweder einen BECKHOFF Master (FC310x, FC510x, FC520x) oder eine freie serielle Schnittstelle.


AX2000 am SSB

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele [image] AX2000 am SSB
AX2000 am SSB
AX2000
Notwendiges Material:
▪
TwinCAT 2.9 Build 953 oder Größer
▪
BX3100 Version 0.80 oder Größer
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x AX2000 mit folgende Einstellungen: Slave Adresse 4, Baudrate 500 kByte
▪
Verkabelungsmaterial sowie Spannungsversorgung
▪
Beispiel Programm und Konfiguration auf dem BX-Controller
–
TwinCAT System Manager File ( )

(Das System Manager File muss per ADS zum BX-Controller geladen werden).
–
BX-Programm-File ( )
Für den Konfigurations-Download über ADS benötigt man entweder einen BECKHOFF Feldbus-Master oder eine freie serielle Schnittstelle.
AX2000 Beschreibung
Folgende Abschnitte sind Auszüge aus der Dokumentation des AX2000 Drive Handbuch. Weitere Informationen finden Sie unter der Internet Adresse http://www.Beckhoff.de.
Hardware und Schnittstellen
Einstellen der Stationsadresse
Die Stationsadresse (Geräteadresse am CAN-Bus) des Servoverstärkers können Sie auf drei Arten
einstellen:
▪
Mit der Tastatur in der Frontplatte (siehe Installationsanleitung AX2000)
▪
In der Inbetriebnahme-Software DRIVE.EXE auf der Bildschirmseite "Basiseinstellungen"
▪
Über die serielle Schnittstelle mit der Abfolge der ASCII-Kommandos:
ADDR nn > SAVE > COLDSTART (mit nn = Adresse)
Der Adressbereich kann mit Hilfe des ASCII – Objektes MDRV von 1..63 auf 1..127 expandiert
werden.
Einstellen der Baudrate
Die CAN-Übertragungsgeschwindigkeit (Baudrate) können Sie auf drei Arten einstellen:
▪
Mit der Tastatur in der Frontplatte (siehe Installationsanleitung AX2000)
▪
In der Inbetriebnahme-Software DRIVE.EXE auf der Bildschirmseite "Basiseinstellungen"
▪
Über die serielle Schnittstelle mit der Abfolge der ASCII - Kommandos:
CBAUD bb > SAVE > COLDSTART (mit bb = Baudrate in kB)
Mögliche Baudraten sind 10, 20, 50, 100, 125, 250, 333, 500 (default), 666, 800 und 1000 kBaud.
CANopen Interface (X6)
Interface zum Anschluss an den CAN Bus (default 500 kBaud). Das integrierte Profil basiert auf dem Kommunikationsprofil CANopen DS301 und dem Antriebsprofil DSP402. Im Zusammenhang mit dem Lageregler werden u.a. folgende Funktionen bereitgestellt:
Tippen mit variabler Geschwindigkeit, Referenzfahren, Fahrauftrag starten, Direktfahrauftrag starten, digitale Sollwertvorgabe, Datentransferfunktionen und viele andere.
Detaillierte Informationen finden Sie im CANopen-Handbuch. Die Schnittstelle ist über Optokoppler galvanisch getrennt und liegt auf dem gleichen Potential wie das RS232-Interface. Die analogen Sollwerteingänge sind weiterhin nutzbar. Mit der optionalen Erweiterungskarte -2CAN- werden die beiden Schnittstellen RS232 und CAN, die denselben Stecker X6 belegen, auf zwei Stecker verteilt.
CANopen Interface (X6)


Cimrex-Panel am SSB des BX-Controllers

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele [image] Cimrex-Panel am SSB des BX-Controllers
Cimrex-Panel am SSB des BX-Controllers
Die CAN-Schnittstelle des BX-Controllers kann auch dazu benutzt werden, ein Bedien-Panel anzuschließen. In diesem Beispiel wird ein Panel der Firma Beijers angeschlossen. Weitere Informationen zu dem Panel finden Sie unter http://www.beijerelectronics.de.
Cimrex-Panel am SSB des BX-Controllers
Benötigte Komponenten
▪
1 x BX3100
▪
Einige Busklemmen für den K-Bus (hier 3 x KL2114, kann aber in der System-Manager-Datei angepasst werden)
▪
1 x Cimrex 41
▪
1 x CAB 15 CAN Adapter
▪
Beispielprogramm in ST für den BX: ( )
▪
Beispielkonfiguration für den BX: ( )
▪
Beispiel für Cimrex 41: ( )
–
Baudrate 500 kBaud
–
CAN Slave Adresse 10


IclA-Drive am SSB

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele [image] IclA-Drive am SSB
IclA-Drive am SSB
IclA-Drive am SSB
Notwendiges Material:
▪
TwinCAT 2.9 Build 953 oder Größer
▪
BX3100 Version 0.80 oder Größer
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x IclA D065 Folgende Einstellungen Slave Adresse 10, Baudrate 500 kByte (Achtung: Dies sind nicht die Default Parameter des Antriebs)
▪
Verkabelungsmaterial sowie Spannungsversorgung
Für den Konfigurations-Download über ADS benötigt man entweder einen BECKHOFF Feldbus-Master oder eine freie serielle Schnittstelle.
Umkonfigurierungsbeispiel für TwinCAT mit der CANopen-Masterkarte FC510x
Um den Antrieb umzustellen, kann dies mit folgendem Beispiel erfolgen.
▪
TwinCAT-System-Manager-File ( )
▪
TwinCAT-PLC-File ( )
Beispiel Programm und Konfiguration auf dem BX-Controller
▪
TwinCAT-System-Manager-File ( )
(Das System-Manager-File muss per ADS zum BX-Controller geladen werden).
▪
BX-Programm-File ( )
IclA D065 - Beschreibung
Folgende Abschnitte sind Auszüge aus der Dokumentation des IclA-Drive-Handbuchs. Diese wurden uns von der Firma SIG Positec Automation GmbH für die Beschreibung der grundliegenden Parameter zur Verfügung gestellt. Weitere Informationen finden Sie unter der Internet Adresse http://www.sig-positec.de.
Hardware und Schnittstellen
Anschlüsse des IclA-Drives
▪
Signalschnittstelle für
–
Versorgungsspannung
–
Steuersignale für Manuellbetrieb
–
Anschluss für Not-Aus-Signal
▪
Schutzleiteranschluss für die Erdung über PE-Sammelschiene
▪
Feldbusanschluss für den Anschluss des Feldbuskabels.
Signalschnittstelle
Wird die Not-Aus-Funktion nicht benötigt, verbinden Sie Pin 2 mit Pin 8 oder 9 (24 VDC).
Feldbusanschluss
Control-Wort 0x6040
Das Objekt stellt das Steuerungswort des Geräts dar. Mit dem Control-Wort werden mehrere Steuerungsaufgaben erfüllt:
▪
Wechsel zwischen den verschiedenen Betriebszuständen. Die möglichen Zustände und Übergänge finden Sie unter dem Index-Schlagwort „Zustandsmaschine". Relevant für einen Zustandswechsel sind die Bits 0 bis 3 und Bit 7.
▪
Starten und Unterbrechen von betriebsartenspezifischen Funktionen, z. B. Starten eines Fahrauftrags über das Bit 4. Die Bits 4 bis 6 werden für betriebsartenspezifische Einstellungen benutzt. Einzelheiten finden Sie unter den Schlagworten „Betriebsart, starten", „Betriebsart, überwachen" und bei der Beschreibung der jeweiligen Betriebsarten in den Kapiteln „Manuellbetrieb" und „Positionierbetrieb".
▪
Stoppen des Positionierantriebs aus einem laufenden Fahrbetrieb. Zum Anhalten wird das Bit 8 „Halt" benutzt Einzelheiten finden Sie unter den Schlagworten „Betriebsart, starten" und „Betriebsart, überwachen".
Objektbeschreibung | Wertebeschreibung
Index | 6040h
Objektname | Control-Wort
Datentyp | Integned16
Subindex | 00h, Control-Wort
Zugriff | read-write
PDO-Mapping | R_PDO
Bit | Bezeichnung | Bedeutung
11..15 | Manufacturer specific | nicht benutzt
9, 10 | - | reserviert
8 | Halt | Motor stoppen
7 | Reset fault | Fehler rücksetzen
4..6 | - | betriebsartenabhängig,
3 | Enable operation | Betriebsart ausführen
2 | Quick Stop (low aktiv) | Abbremsen mit Quick Stop-Rampe
1 | Disable voltage (low aktiv) | Spannung ausschalten
0 | Switch on | betriebsbereit schalten
Statusword 0x6041
Das Objekt beschreibt den aktuellen Betriebszustand des Geräts. Mit dem Status-Wort führen Sie folgende Überwachungsfunktionen durch:
▪
Prüfen des Betriebszustands der Positioniersteuerung. Dazu sind die Bits 0 bis 3, 5 und 6 relevant.
▪
Das Bit 4 zeigt an, ob die Endstufe bereit ist, einen Fahrauftrag zu bearbeiten.
▪
Die Bits 7 bis 15 werden zur Überwachung des Fahrbetriebs und zur Statusüberwachung gerätespezifischer Zustände benutzt.
Einzelheiten zur Überwachung des Fahrbetriebs finden Sie unter den Schlagworten „Betriebsart, starten", „Betriebsart, überwachen" und bei der Beschreibung der jeweiligen Betriebsarten in den Kapiteln „Manuellbetrieb" und „Positionierbetrieb". Die Bits zur Statusüberwachung des Geräts sind im Kapitel „Diagnose und Fehlerbehebung" beschrieben.
Das Steuerungswort ist in den ersten beiden Byte der R_PDOs abgebildet.
Objektbeschreibung | Wertebeschreibung
Index | 6041h
Objektname | Status-Wort
Datentyp | Unsigned16
Subindex | 00h, Status-Wort
Zugriff | read-only
PDO-Mapping | T_PDO
Bit
Bezeichnung
Bedeutung
15
Out of security area
Sicherheitsbereich verlassen
0->1: Endschalterposition S0 oder S1überfahren
14
Out of drive area
Fahrbereich verlassen
0->1: Endschalterposition D0 oder D1überfahren
12..13
-
betriebsartenabhängige Bedeutung
11
Internal limit active
Arbeitsbereich verlassen
10
Target reached
Ziel erreicht
1->0: Neue Zielposition übergeben
0->1: Angeforderte Zielposition erreicht oder Motorstillstand nach Halt-Anforderung
9
Remote
0: Manuellbetrieb
1: kein Manuellbetrieb
8
Right out of drive area
Nur gültig, wenn Bit 11 = 1
- 0: Endschalterposition W1 überfahren
- 1: Endschalterposition W0 überfahren
7
Warning
Warnung
6
Switch on disabled
nicht betriebsbereit
5
Quick Stop
Quick Stop aktiv
4
Voltage disabled
Spannung ausgeschaltet
3
Fault
Fehler aufgetreten
2
Operation enabled
Betriebsart aktiviert
1
Switched on
betriebsbereit
0
Ready to switch on
einschaltbereit
Referenzierungsbereiche
Eine gültige Referenzierung wird über drei Endschalterzonen definiert, die im möglichen Verfahrbereich des Antriebs liegen müssen. Die Endschalter schützen Antrieb und Anlage vor einer Beschädigung.
Referenzierungsbereiche
▪
Arbeitsbereich W0 - W1 für den Positionierbetrieb.
▪
Fahrbereich D0 - D1. Aus den Bereichen D0 - W0 und D1 - W1 kann
▪
der Antrieb nur in Richtung Arbeitsbereich zurückgefahren werden.
▪
Sicherheitsbereich S0 - S1. Aus den Bereichen S0 - D0 und S1 - D1 kann der Antrieb nur manuell zurückbewegt werden.
▪
CANopen-Objekte Für die Einrichtung der Endschalter werden drei CANopen-Objekte eingesetzt, in denen die Positionswerte für die obere und untere Bereichsgrenze eingetragen werden.
▪
Grenzen des Arbeitsbereichs in software position limit (607Dhex)
▪
Grenzen des Fahrbereichs in software position drive limit (2009hex)
▪
Grenzen des Sicherheitsbereichs in software position safety limit (2008hex)
Bespiel für eine Referenzierung
Das folgende Listing zeigt die Eingabe der Referenzierungswerte. Die Knotenadresse des Positionierantriebs ist auf 01hex eingestellt.
Listing der Referenzierungswerte


Lenze Frequenzumrichter am SSB

Parametrierung und Inbetriebnahme [image] Konfiguration [image] SSB [image] Beispiele [image] Lenze Frequenzumrichter am SSB
Lenze Frequenzumrichter am SSB
Frequenzumrichter der Fa. Lenze
Notwendiges Material
▪
TwinCAT 2.9 Build 953 oder Größer
▪
BXxx00
▪
1 x KL1xx4
▪
1 x KL2xx4
▪
1 x KL9010
▪
1 x Lenze 8200 vector + Motor
▪
1 x Lenze CANopen Interface 2175
▪
Verkabelungsmaterial sowie Spannungsversorgung
Für den Konfigurations-Download über ADS benötigen Sie eine BECKHOFF Feldbus-Masterkarte oder eine freie serielle Schnittstelle.
Lenze Beschreibung
Folgende Abschnitte sind Auszüge aus der Dokumentation des Lenze 2175-Handbuchs. Diese wurden uns von der Firma Lenze Drive Systems GmbH für die Beschreibung der grundlegenden Parameter zur Verfügung gestellt. Weitere Informationen finden Sie unter der Internet Adresse http://www.Lenze.com.
Erstinbetriebnahme
Stellen Sie die Spannungsversorgung für das Busmodul auf Interne Spannungsversorgung.
Externe Spannungsversorgung - Interne Spannungsversorgung
(Auslieferungszustand)
Für die CANopen-Kommunikation stellen Sie den DIP-Schalter 10 auf "ON".
DIP-Schalter
Baudrate DIP-Schalter 7-9
Übertragungrate [kBit/s] | S7 | S8 | S9
10 | ON | ON | OFF
20 | ON | OFF | ON
50 | OFF | ON | ON
125 | OFF | ON | OFF
250 | OFF | OFF | ON
500 (default) | OFF | OFF | OFF
1000 | ON | OFF | OFF
Wertigkeit der DIP-Schalter
DIP Schalter 6 hat die kleinste Wertigkeit.
Beispiel: Adresse 3 Schalter 5 und 6 auf "ON".
Freigabe des Kommunikationsmoduls
Um das Kommunikationsmodul freizuschalten muss die Bedienungsart auf 3 gestellt werden. Dies kann über den SSB erfolgen mit folgendem Eintrag:
Freigabe des Kommunikationsmoduls
Sync-Telegramm
In der Default-Einstellung sendet der Lenze-Drive seine Ausgangs-PDOs nur, nachdem er vom CAN-Master ein Sync-Telegramm empfangen hat. Wenn Sie den Trans. Type zum Beispiel auf 2 stellen, sendet der Lenze-Drive nach jedem 2. empfangenen Sync-Telegramm ein Ausgangs-PDO.
Beispiel Projekt
▪
TwinCAT-System-Manager-File: ( )
▪
TwinCAT-PLC-File: ( )


Echtzeit-Uhr (RTC)

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Echtzeit-Uhr (RTC)
Echtzeit-Uhr (RTC)
Auf dem BX-Controller ist eine Echtzeit-Uhr (Real Time Clock - RTC) implementiert. Die Uhrzeit ist akku-gepuffert.
Einstellen der Echtzeit-Uhr
Die einfachste Art die Uhr einzustellen ist über den System Manager. Sofern die ADS-Kommunikation steht wird die momentan aktuelle Uhrzeit auf dem BX-Controller angezeigt. Um die Uhrzeit einzustellen editieren Sie einfach die Zeit und mit der Drop Down Taste können Sie Tage, Monate und Jahre einstellen. Für die Einstellungen der Jahre klicken Sie auf die Jahresanzeige und stellen Sie das gewünschte Jahr ein. Ebenso verfahren Sie mit dem Monat. Nach dem Sie alle Einstellungen vorgenommen haben klicken Sie auf den Button Update RTC on BX.
systemmanager rtc 1.gif
Einstellen der Echtzeit-Uhr (RTC)
Lebensdauer des Akkus
Je nach Belastung des Akkus kann die Lebensdauer des Akkus variieren.
Lesen der RTC auf dem BX-Controller (siehe Beispiel Programmierung\Bibliothek)
Die RTC kann per Funktionsbaustein ausgelesen werden. Notwendige Bibliotheken:
▪
TcSystemBX.lbx
▪
TCBaseBX.lbx
Schreiben der RTC auf dem BX-Controller
Die RTC kann per Funktionsbaustein eingestellt werden. Notwendige Bibliotheken:
▪
TcSystemBX.lbx
▪
TCBaseBX.lbx
Lesen der RTC per ADS
Beschreibung | Bedeutung | Wert
NETID | Ziel-Gerät | siehe System Manager "ADS"
Port | ADS Port Nummer | 150dez
IDXGRP | IDX Gruppe | 0x0000_F100hex
IDXOFFS | IDX Offset | 0x0000_0000hex
Länge | Länge der Daten | 16 Byte
Variablen Typ | Art der Variabel | TIMESTRUCT
Schreiben der RTC per ADS
Beschreibung | Bedeutung | Wert
NETID | Ziel-Gerät | siehe System Manager "ADS"
Port | ADS Port Nummer | 150dez
IDXGRP | IDX Gruppe | 0x0000_F100hex
IDXOFFS | IDX Offset | 0x0000_0000hex
Länge | Länge der Daten | 16 Byte
Variablen Typ | Art der Variabel | TIMESTRUCT
Einstellung über den Navigationsschalter
Siehe Menü.
Technische Daten zur RTC
Genauigkeit: ca. 1 Sekunde/Tag
Speicherung der Uhrzeit: ca. 3 Monate bei aufgeladenem Akku
Lebensdauer des Akkus: ca. 10 Jahre bei 10 Zyklen pro Tag (1000 Zyklen bei einem kompletten Lade-/ und Entladezyklus)


COM-Port

Parametrierung und Inbetriebnahme [image] Konfiguration [image] COM-Port
COM-Port
Auf dem BX-Controller befinden sich zwei serielle Schnittstellen. Die PIN-Belegung entnehmen Sie bitte der Hardware-Beschreibung.
Einstellmöglichkeiten:
Beschreibung | Auswahl
Baudrate | 9600 Baud 19200 Baud 38400 Baud (beginnt bei der Autobaudratenerkennung) 57600 Baud 115200 Baud (nur COM 2)
Datenbits | 7 8 (Default)
Parity | NONE ODD EVEN (Default)
Stoppbits | 1 (Default) 2
COM 1
Die Schnittstelle COM 1 für die Kommunikation mit der KS2000 Software oder dem TwinCAT PLC Control (einloggen über die serielle Schnittstelle).
COM 2
Die Schnittstelle COM 2 (mit RS 232 oder RS 485 Physik) für die Nutzung eigener Protokolle oder der Protokoll-Bibliotheken (wie ModbusRTU, RK512, etc.) zum Anschluss andere serieller Geräte.
Bibliothek
Für die Kommunikation mit der seriellen Schnittstelle stehen Funktionsbausteine zur Verfügung.
▪
Dokumentation
▪
Beispiel
▪
Bibliothek


Menü

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Menü
Menü
Weiterführende Informationen
•
BX-Menü-Settings
•
Erstellen eigener Menüs


BX-Menü-Settings

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Menü [image] BX-Menü-Settings
BX-Menü-Settings
Um in das Menü zu wechseln, drei Sekunden den Navigationsschalter gedrückt halten. Als erstes erscheint das Verzeichnis Menue.
▪
Zwischen den Einstellungen eines Menüs, können Sie man mit den Tasten RIGHT/LEFT wechseln (es ist immer das in in der 1. Zeile angezeigte Menü aktiv).
▪
Drücken Sie zum Wechseln in ein Untermenü, die Taste DOWN.
▪
Um wieder in das Hauptmenü zu wechseln drücken Sie die Taste UP.
Im Untermenü wird in der ersten Zeile der Menüpunkt angezeigt und in der 2. Zeile die aktuelle Einstellung zu diesem Menüpunkt.
Einige Einstellungen sind nicht veränderbar (read only). Diese Punkte sind rein für die Kontrolle und Information für den Anwender gedacht. Um das Menü zu beenden muss man sich im Hauptmenü befinden und dann den Navigationsschalter drei Sekunden gedrückt halten.
Bevor Einstellungen geändert werden können, muss Passwort gesetzt werden. Das Passwort bleibt auch beim Firmware-Update oder beim zurücksetzen auf die Herstellerkonfiguration gespeichert. Sollten Sie das Passwort vergessen haben, so müssen Sie den BX-Controller einschicken.
Navigationsschalter der BX-Controller
Schalterbelegung
Schalterbelegung
Hauptmenü | Untermenü 1.Zeile | Untermenü 2.Zeile | Read/Write
MENUE | Passwort | **** nicht gesetzt ???? gesetzt | siehe unten
 | Factory Settings | Aktivieren? | wenn die Taste gedrückt wird, werden die Herstellereinstellungen gesetzt und der Controller automatisch rebootet
 | Reboot | Aktivieren? | wenn die Taste gedrückt wird, rebootet der Controller neu
AMS | AMS | >AMS Net-ID< | read only
PLC | NAME | >aktueller NAME< | read only
 | Curr. Exex. Time | >aktueller Wert< | [ms]
 | Task Time | >aktueller Wert< | wenn die Taste gedrückt wird, kann die Zyklus Zeit eingestellt werden
 | Status | >Boot-Prj< >PLC Status< | Bootprojekt vorhanden PLC Status
Config | NAME | >aktueller NAME< | read only
 | Config löschen | Aktivieren? | wenn die rechte Taste gedrückt wird, löscht man die aktuelle Konfiguration
Real Time Clock | Date and Time | >aktuelle Zeit< | read only
 | Year | Setting | 2003-2xxx
 | Month | Setting | 1-12
 | Day | Setting | 1-31
 | Day of week | Setting | Mon, ... Fri
 | Houre | Setting | 0-23
 | Minute | Setting | 0-59
 | Second | Setting | 0-59
COM 1 read only | Baudrate | >aktueller Wert< | 9600/19200/38400/56800
COM 2 read only | Baudrate | >aktueller Wert< | 9600/19200/38400/56800/115k
SSB read only | Baudrate | >aktueller Wert< | 1MBaud, 500k, 250k, 125k, 100k, 50k
 | Cycle Time | >aktueller Wert< [in µs] | read only
 | Utilization | >aktueller Wert< [in %] | read only
K-Bus read only | Diagnose | >aktuelle Diagnose< | read only
 | Anzahl der Busklemmen | >aktueller Wert< | read only
Busspezifische Menü Punkte
BX3100
F-Bus PROFIBUS read only | Adresse* | >aktueller Wert< | 1-126
 | Baudrate* | >aktueller Wert< | read only
 | Status | >aktueller Wert< | read only
 | Diagnose* | >aktueller Wert< | read only
BX5100
F-Bus CANopen read only | Adresse* | >aktueller Wert< | 1-126
 | Baudrate* | >aktueller Wert< | read only
 | Status | >aktueller Wert< | read only
 | Diagnose* | >aktueller Wert< | read only
*) in Vorbereitung
BX9000
Ethernet | MAC ID | >aktueller Wert< | 000105-xx-xx-xx, read only
 | ADDR.STATE | >aktueller Wert< | read only
 | ADDRESSING MODE | FIXED IP (Default) DHCP BOOTP BOOTP & SAVE | read / write
 | NAME | >aktueller Wert< | BX_xxxxxx (xxxxxxx last 3 Bytes from the MAC ID) read / write
 | DEFAULT GATEWAY | 0.0.0.0 | read / write
 | IP MASK | 255.255.0.0 | read / write
 | IP ADRESS | 172.16.21.20 | read / write
Code
Die Default Einstellung ist "****", das heißt das kein Passwort aktive ist. Um Einstellungen vorzunehmen ist ein Passwort zu setzen.
Menü Navigation
Wenn Sie den Navigationsschalter (Press) drei Sekunden drücken wechseln Sie in das Menü - Verzeichnis. Hier sind einige Menüpunkte beschrieben.


Erstellen eigener Menüs

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Menü [image] Erstellen eigener Menüs
Erstellen eigener Menüs
Man kann den das Display und Navigations-Schalter auch für eigene Zwecke gebrauchen, z. B. um Diagnoseinformationen anzuzeigen und oder Parameter zu verändern. Für den einfachen Einstieg ist ein Beispiel angefügt, das Sie für Ihre ersten Schritte verwenden und anpassen können.
Download ( )


Konfigurations-Software KS2000

Parametrierung und Inbetriebnahme [image] Konfiguration [image] Konfigurations-Software KS2000
Konfigurations-Software KS2000
Eine Parametrierung und Konfigurierung von Busklemmen-Controllern der BCxx50-, BXxx20- und BXxx00-Serien ist mit der Konfigurations-Software KS2000 nicht möglich. Deren Konfiguration muss mit den TwinCAT System Manager vorgenommen werden.
Die Konfigurations-Software KS2000 kann Ihnen aber bei der Konfiguration oder Diagnose der an die Busklemmen-Controller angereihten Busklemmen helfen.
Es empfiehlt sich hierzu die Baudrate in Konfigurations-Software KS2000, BCxx50 BCxx20 und BXxx00 auf 38400 Baud zu stellen (8 Datenbits, Even, 1 Stoppbit).
COM1 - automatische Baudraten Erkennung
Die Schnittstelle COM 1 der BXxx00 hat eine automatische Baudraten Erkennung von 9,6 kBaud bis 56,4 kBaud.
Erforderliche KS2000-Version
Die Konfiguration oder Diagnose von Busklemmen an BXxx00 wird ab KS2000 Version 4.3.14 unterstützt.
Um bei einigen Busklemmen die Konfigurationsdialoge nutzen zu können (z. B. KL25xx, KL6811, KL6201, KL6401) müssen folgende Punkte eingestellt werden:
▪
Ein SPS-Projekt oder ein Boot-Projekt muss deaktiviert sein.
▪
Der BX-Controller muss in der Default Configuration sein. Setzen Sie die Herstellereinstellung oder schalten Sie im TwinCAT System Manager auf Config Mode (blaues TwinCAT Icon).
▪
Der BX-Controller muss im FreeRun Modus sein. Aktivieren Sie dies mit dem TwinCAT System Manager.
Nun können Sie sich mit der Konfigurations-Software KS2000 über ADS (Port 100) oder das serielle Kabel einloggen und die KS2000-Dialoge der Busklemmen nutzen.


Programmierung

Programmierung
Programmierung
Weiterführende Informationen
•
PLC-Eigenschaften der BX-Controller
•
TwinCAT PLC
•
TwinCAT PLC - Fehler-Codes
•
Remanente Daten
•
Persistente Daten
•
Lokierte Merker
•
Lokales Prozessabbild im Auslieferungszustand (Default Config)
•
Mapping der Busklemmen
•
Erzeugen eines Boot-Projekts
•
Lokales Prozessabbild in der TwinCAT-Konfiguration
•
Kommunikation zwischen TwinCAT und BX/BCxx50
•
Up- und Download von Programmen
•
Bibliotheken
•
Programmübertragung über die serielle Schnittstelle


PLC-Eigenschaften der BX-Controller

Programmierung [image] PLC-Eigenschaften der BX-Controller
PLC-Eigenschaften der BX-Controller
Beschreibung | Wert
Datenspeicher | 256 kByte
Programmspeicher | 256 kByte minus Task-Konfiguration minus POUs beim Online Change
Source Code Speicher | 256 kByte
RETAIN | 2 kByte
INPUT | 2 kByte
OUTPUT | 2 kByte
MERKER | 4 kByte
max. größe einer Variable | 16 kByte
max. POUs | Beschränkung durch Speicher


TwinCAT PLC

Programmierung [image] TwinCAT PLC
TwinCAT PLC
Das Beckhoff TwinCAT Software-System verwandelt jeden kompatiblen PC in eine Echtzeitsteuerung mit Multi-SPS-System, NC-Achsregelung, Programmierumgebung und Bedienstation. Die Programmierumgebung von TwinCAT wird auch für die Programmierung der BC/BX genutzt. Wenn Sie TwinCAT PLC (Windows NT4/2000/XP) installiert haben, können Sie die Feldbus-Verbindung oder die serielle Schnittstelle für Software-Download und Debugging verwenden.
TwinCAT I/O oder TwinCAT PLC können auch als Ethernet-Master (Host) genutzt werden, um Prozessdaten mit dem Busklemmen-Controller auszutauschen. TwinCAT stellt ihnen hierzu den System Manager als Konfigurationstool sowie die Treiber und das ADS-Protokoll zu Verfügung.
Busklemmen-Controller der Serien BCxx50, BCxx20 und BXxx00
Diese Busklemmen Controller der 2. Generation werden mit dem TwinCAT System Manager konfiguriert und mit TwinCAT PLC-Control programmiert. Sie müssen für diese Koppler TwinCAT PLC installieren (Windows NT4, Windows 2000, Windows XP).
Programmierung und Programmübertragung
▪
über die serielle Schnittstelle
▪
über die Feldbus-Schnittstelle (nur bei Busklemmen-Controllern für PROFIBUS, CANopen und Ethernet)
Online Change
Die Busklemmen-Controller Busklemmen-Controller der BX-Serie und die BCxx50 unterstützen Online Change. Das bedeutet, dass das PLC-Programm durch ein neues Programm ersetzt wird, ohne dass dadurch das Programm unterbrochen wird. Nach Beendigung der Task wird auf das neue Programm umgeschaltet. Damit verbunden ist die doppelte Haltung des SPS Programms. Es stehen 512 kByte zu Verfügung, die für die doppelte Haltung des PLC Programm durch zwei dividiert werden muss, also 256 kByte. Zusätzlich müssen noch für Task-Konfiguration etc. einige kByte abgezogen werden. Beim Online Change werden noch dynamische Daten in den Speicher abgelegt. Sollte ein Programm an die Speichergrenze stoßen (größer 240 kByte) kann es passieren das ein Online Change nicht mehr funktioniert auch wenn das Programm nach einem "Rebuild all" wieder in den BX geschrieben werden kann.
Wann geht kein Online Change?
Es gibt einige Punkte, nachdem ist ein Online Change nicht mehr möglich.
▪
einfügen einer neuen Bibliothek
▪
Änderung der Task-Einstellung
▪
ein "Rebuild all"
▪
Grenzbereich in der Speicherauslastung des Controllers (PLC Programm größer 90%)


TwinCAT PLC - Fehler-Codes

Programmierung [image] TwinCAT PLC - Fehler-Codes
TwinCAT PLC - Fehler-Codes
Fehlerart | Beschreibung
PLC-Kompilierfehler | Maximum number of POUs (...) exceeded
PLC-Kompilierfehler | Out of global data memory ...
Fehler POUs
Für jeden Baustein wird eine POU (Process Object Unit) angelegt. Per Default sind 256 Bausteine möglich.
Maximale Anzahl der POUs überschritten
Wenn man Bibliotheken einbindet, kann dieser Wert nicht mehr ausreichen. Erhöhen Sie dann die Anzahl an POUs.
Öffnen Sie dazu im PLC Control unter Projekte/Optionen...
Menüpfad Projekte / Optionen / Controller Settimgs
...die Controller Settings.
Controller Settings
Eine Änderung dieser Einstellungen hat zufolge, das kein Online Change mehr geht.
Fehler Globaler Speicher
Globaler Speicher nicht ausreichend
Per Default sind 2 x 16 kByte Daten angelegt. Wenn viele Daten benutzt werden sollen, müssen Sie diesen Bereich vergrößern. Beim BX sind maximal 14 Datensegmente möglich.
Menüpfad Projekte / Optionen / Build
Build


Remanente Daten

Programmierung [image] Remanente Daten
Remanente Daten
Auf dem BX-Controller stehen 2000 Byte an remanenten Daten zur Verfügung. Diese Daten werden im PLC Control als VAR RETAIN deklariert.
Beispiel
VAR RETAIN
Test :BOOL;
Count :INT;
END_VAR
Zwischen VAR RETAIN und END_VAR stehen die Retain Daten. Diese Daten werden in einem NOVRAM gespeichert und sind über den ganzen 2 kByte großen Bereich konsistent. Die RETAIN Daten werden nach jedem Zyklus ins NOVRAM gespeichert. Für 2 kByte werden ca. 2 ms benötigt (für 1 kByte ca. 1 ms). Die Variablen können lokal oder global Konfiguriert sein. Variablen die lokiert sind (%MB, %QB, %IB) können nicht als Remanente Daten genutzt werden.
VAR_RETAIN nicht in Funktionsbausteinen benutzen
VAR_RETAIN sollte nicht in Funktionsbausteinen benutzt werden. Sämtliche Daten in einem FB werden in den Retain Speicher kopiert, damit erhöht sich unnötig die Zykluszeit und der Retain Speicher wird mit unnötigen Datenmengen gefüllt.
Variablen mit Adresse nicht als remanente Daten verwenden
Variablen die auf einer Adresse liegen (%MB, %QB, %IB) dürfen nicht als remanente Daten verwendet werden.
Beispiel für remanente Daten im Funktionsbaustein
Da immer alle Daten eines Funktionsbausteins, in dem auch nur ein remanentes Bit zu finden ist, gespeichert wird, sollte dies möglichst vermieden werden. Im Anschluss finden Sie ein Programmbeispiel.
Funktionsbaustein Test (Kein Programm Code notwendig - in ST reicht ein Semikolon)
FUNCTION_BLOCK Test
VAR_INPUT
END_VAR
VAR_OUTPUT
END_VAR
VAR
END_VAR
VAR_IN_OUT
Counter :INT;
END_VAR
Programm MAIN
PROGRAM MAIN
VAR
fb_Test:Test;
END_VAR
VAR RETAIN
iCounter1:INT;
END_VAR
fb_Test(Counter:=iCounter1);


Persistente Daten

Programmierung [image] Persistente Daten
Persistente Daten
Es stehen auf dem Busklemmen-Controller 1000 Byte an persistenten Daten zur Verfügung.
Im Unterschied zu den Retain-Daten werden diese auch bei einem neuen Projekt, bei einem Reset der SPS sowie bei einem neuen Download nicht gelöscht.
Um die persistenten Daten zu nutzen müssen diese erst einmal mit einem Funktionsbaustein aus der SPS heraus aktiviert werden.
Zweitens müssen die Variablen auf dem lokierten Merkerbereich liegen. Hier steht es Ihnen frei wo ihre persistenten Daten liegen.
Es stehen 4 kByte an lokierten Merkern zur Verfügung und sie können davon 1000 Byte als persistente Daten deklarieren.
Beispiel
VAR
Test AT %MX1000 :BOOL;
Count AT %MB1002 :INT;
END_VAR
Mit dem Baustein Persistent_Data legen sie die Anfangsadresse fest und die Länge in Byte ab der die Daten persistent sein sollen.
Mit der Eingangsvariable WriteOffset gibt mal den Byte Offset des Merkerbereichs an, mit WriteSize die Länge in Byte.
Den Baustein finden Sie in der TcSystemBX.lbx Bibliothek. Sollte diese nicht vorhanden sein, laden Sie sie sich aus dieser Dokumentation herunter (siehe Bibliotheken).
Beispielwerte
WriteOffset 1000
WriteSize 10
Alle Daten die im Bereich %MB1000 - %MB1009 sind dann persistent. Es spielt keine Rolle um welchen Variablen Typ es sich handelt.
Die Daten werden wie bei den Retain Daten in NOVRAM kopiert und sind daher in jedem Zyklus beschreibbar.
Persistenten Daten ab Firmware 1.17
Die persistenten Daten werden bei allen BX-Controllern ab Firmware 1.17 oder höher unterstützt.
Parameter sind sofort gültig
Das Schreiben der Parameter muss nur einmal erfolgen und ist sofort gültig. Diese Daten werden dauerhaft gespeichert.
Das aktivieren der Herstellereinstellung löscht dies wieder und auch die persistenten Daten werden gelöscht.
Beispielprogramm
Klicken Sie auf den Link [image] ( ) um ein Beispielprogramm aus dieser Dokumentation herunterzuladen.


Lokierte Merker

Programmierung [image] Lokierte Merker
Lokierte Merker
Es stehen 4 kByte an lokierten Merkern zur Verfügung. Diese können genutzt werden, um unterschiedliche Variabelentypen auf die gleiche Adresse zu legen, zum Beispiel um aus Strings Bytes zu machen. Weiter können Daten hinterlegt werden, die per ADS von der Steuerung gelesen und/oder geschrieben werden können.
Lokierte Variablen sind keine remanenten Daten
Bei den Busklemmen-Controller der BX-Serie und den BCxx50 werden die lokierten Variablen nicht als remanente Daten gespeichert.
Read / Write lokierter Merker per ADS
Die Merker können auch über die Steuerung per ADS ausgelesen werden. Bei PROFIBUS werden dazu die DPV-1 Dienste genutzt, bei CANopen die SDO Kommunikation.
Die AmsNetId ist aus dem System Manager zu entnehmen oder man kann Sie sich in dem Menü des Busklemmen-Controllers Anzeigen lassen.
Die Port Nummer ist 800 für die PLC.
Index Group | Bedeutung | Index Offset (Wertebereich)
0x4020 | Merker (nur BXxxx0) | 0..4096
Beispiel
BX Programm
VAR
Flag_01 AT %MB0: WORD;
END_VAR
TwinCAT PC/CX Master Programm
VAR
fbADRSREAD: ADSREAD;
Flag_M: WORD;
END_VAR
fbADRSREAD(
NETID:='172.16.3.0.2.3' , (* AMSNetId BX *)
PORT:=800 , (* 800 - PLC *)
IDXGRP:=16#4020 , (* 0x4020hex falgs *)
IDXOFFS:=0 , (* byte offset *)
LEN:=2 , (* Lenght byte *)
DESTADDR:=ADR(Merker) ,
READ:=TRUE ,
TMOUT:=t#1s );
IF NOT fbADRSREAD.BUSY THEN
fbADRSREAD(READ:=FALSE);
END_IF


Lokales Prozessabbild im Auslieferungszustand (Default Config)

Programmierung [image] Lokales Prozessabbild im Auslieferungszustand (Default Config)
Lokales Prozessabbild im Auslieferungszustand (Default Config)
Das Prozessabbild der Busklemmen-Controller besteht aus Eingangs-, Ausgangs- und Merkerbereich. Daneben gibt es noch die unlokierten Daten. Diese Daten besitzen keine feste Adresse. Sie werden ohne Angabe einer Adresse angelegt. Für diese Art der Variablen stellt
▪
der BCxx50 48 kByte,
▪
der BC9x20 128 kByte und
▪
der BXxx00 256 kByte Speicher zur Verfügung.
Eine Variable oder Struktur (Array) darf maximal 16 kByte groß sein. Für die lokierten Daten stehen 2048 Byte Ein- und 2048 Byte Ausgangsdaten bereit. Für den lokierten Merkerbereich verfügt der Busklemmen-Controller über 4 kByte Speicher.
Im Auslieferungszustand (Default Configuration) des BX/BCxx50 werden allen angeschlossenen Busklemmen feste Adressen zugewiesen. Die Daten für die Ethernet-Kommunikation beginnen ab dem Adress-Offset 1000dez. Die Länge der Ethernet-Daten hängt von der Anzahl der konfigurierten Daten ab und beträgt maximal 1000 Byte beim BX9000.
Eingänge | Ausgänge
Busklemme %IB0 ... | Busklemmen %QB0 ...
Ethernet DATEN (SPS- Variablen) %IB1000 ...(ModbusTCP/ADS-TCP/ADS-UDP) | Ethernet DATEN (SPS- Variablen) %QB1000 ...(ModbusTCP/ADS-TCP/ADS-UDP)
... %IB2047 Maximal | ... %QB2047 Maximal
Adressierung der Angeschlossenen Busklemmen
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild zugewiesen. Das Mapping im Busklemmen Controller erfolgt nach folgender Gesetzmäßigkeit:
Erst alle komplexen Busklemmen, in der Reihenfolge wie diese gesteckt sind und anschließend die digitalen Busklemmen, die zu einem Byte aufgefüllt werden. Das Default-Mapping der komplexen Busklemmen ist:
▪
komplette Auswertung
▪
Intel-Format
▪
Word Alignment
Beispielaufbau
Busklemmen Controller: 1 x BCxx50, BCxx20 oder BXxx00
Position 1: 1 x KL1012
Position 2: 1 x KL1104
Position 3: 1 x KL2012
Position 4: 1 x KL2034
Position 5: 1 x KL1501
Position 6: 1 x KL3002
Position 7: 1 x KL4002
Position 8: 1 x KL6001
Position 9: 1 x KL9010
Prozessabbild
Busklemme | Position | Eingangsabbild | Ausgangsabbild | Größe
KL1501 | 5 | %IB0...%IB5 | %QB0...%QB5 | 6 Byte
KL3002 | 6 | %IB6...%IB13 | %QB6...%QB13 | 8 Byte
KL4002 | 7 | %IB14...%IB21 | %QB14...%QB21 | 8 Byte
KL6001 | 8 | %IB22...%IB29 | %QB22...%QB29 | 6 Byte
KL1012 | 1 | %IX30.0...%IX30.1 | - | 2 Bit
KL1104 | 2 | %IX30.1...%IX30.5 | - | 4 Bit
KL2012 | 3 | - | %QX30.0...%IX30.1 | 2 Bit
KL2034 | 4 | - | %QX30.2...%IX30.5 | 4 Bit
KL9010 | 9 | - | - | -


Mapping der Busklemmen

Programmierung [image] Mapping der Busklemmen
Mapping der Busklemmen
Die genaue Belegung der byteorientierten Busklemmen entnehmen Sie bitte der Konfigurations-Anleitung zur jeweiligen Busklemme. Diese Dokumentation finden Sie auf der Beckhoff CD Products & Solutions oder im Internet unter http://www.beckhoff.de.
byteorientierte Busklemmen | bitorientierte Busklemmen
KL15x1 | KL10xx, KL11xx, KL12xx, KL17xx, KM1xxx
KL25xx | KL20xx, KL21xx, KL22xx, KL26xx, KL27xx, KM2xxx
KL3xxx |
KL4xxx |
KL5xxx |
KL6xxx |
KL7xxx |
KL8xxx |
 | KL9110, KL9160, KL9210, KL9260


Erzeugen eines Boot-Projekts

Programmierung [image] Erzeugen eines Boot-Projekts
Erzeugen eines Boot-Projekts
Für das Erzeugen des Boot-Projektes stehen
▪
auf den Busklemmen-Controllern der BX-Serie ca. 250 kByte Flash zu Verfügung.
▪
auf den Busklemmen-Controllern der BCxx50-Serie ca. 48 kByte Flash zu Verfügung.
PLC Control
Im TwinCAT PLC Control kann man, wenn man eingeloggt ist ein Boot-Projekt erzeugen.
▪
Öffnen eines PLC Projektes
▪
Auswahl des Zielsystem (oder Auswahl der seriellen Schnittstelle)
▪
Einloggen auf den BX/BCxx50
▪
Erzeugen des Boot-Projektes (Online\Create Bootproject)
Ist ein gültiges Boot-Projekt auf dem BX/BCxx50 leuchtet die LED PLC grün.
Bei den Busklemmen-Controllern der BX-Serie blinkt während der Erzeugung des Boot-Projektes die die PLC LED orange. Ist auf dem BX kein Boot-Projekt vorhanden, leuchtet die PLC LED orange.
Löschen eines Boot-Projektes
Sie können das Boot-Projekt auch vom Busklemmen-Controller löschen. Folgende Schritte sind einzuhalten:
▪
Öffnen des Projektes
▪
Einloggen auf den Busklemmen-Controller
▪
Löschen des Boot-Projektes (Online\Delete Boot Project)
Nach dem Löschen des Boot-Projektes ist die PLC LED orange.
Übernahme des aktuellen Projektes als Boot-Projekt
Nach einem Online Change ist als Boot-Projekt noch immer das alte Projekt eingetragen. Soll das aktuelle Projekt (nach dem Online-Change) als Boot-Projekt übernommen werden, muss dieses neu erzeugt werden.
Umgehen eines Starten des Boot-Projekt*
Bei den Busklemmen-Controllern der BX-Serie kann beim Booten das Starten des Boot-Projekts durch Drücken des Navi-Schalters verhindert werden. Das Boot-Projekt ist damit nicht gelöscht und wird beim erneuten Booten des Busklemmen-Controller wieder gestartet.
* ab Version 0.85


Lokales Prozessabbild in der TwinCAT-Konfiguration

Programmierung [image] Lokales Prozessabbild in der TwinCAT-Konfiguration
Lokales Prozessabbild in der TwinCAT-Konfiguration
Die TwinCAT-Konfiguration (TwinCAT-CONFIG) ermöglicht das freie Mapping zwischen Feldbus, K-Bus und SPS-Variablen. Variablen können unabhängig von ihrer Adresse mit Hilfe des System Managers verknüpft werden.
Ändern der Verknüpfung von Variablen
Verknüpfen einer Variable mit einem Eingang
In der Default-Konfiguration liegen alle Busklemmen auf feste Adressen. Fügt man eine Busklemme ein, verschiebt sich eventuell der ganze Adressbereich. Mit der TwinCAT-Konfiguration hat man die Möglichkeit, seine lokierten Variablen, frei mit einer Busklemme zu verknüpfen. Man parametriert dies im System Manager und lädt dann diese erstellte Konfiguration auf den Busklemmen-Controller herunter (siehe TwinCAT-Konfiguration). Ein Hochladen einer bestehenden TwinCAT-Konfiguration ist auch möglich.


Kommunikation zwischen TwinCAT und BX/BCxx50

Programmierung [image] Kommunikation zwischen TwinCAT und BX/BCxx50
Kommunikation zwischen TwinCAT und BX/BCxx50
Um von TwinCAT-Daten zum Busklemmen-Controller zu transportieren liegt es nahe, die Daten in einer Struktur anzulegen. Da die Datenhaltung auf beiden Systemen unterschiedlich ist sind folgende Hinweise zu beachten.
▪
Wenn zwei unterschiedliche Datentypen aufeinander folgen (zum Beispiel Byte und INT) wird die folgende Variable auf den nächsten graden Adress-Offset gelegt
▪
Boolsche Variablen sollten nie einzeln in eine Struktur gelegt werden, da sie so immer 1 Byte belegen würden. Boolsche Ausdrücke sollten immer in ein Byte oder Wort maskiert sein.
Beispiel 1: Eine Struktur auf den BX/BCxx50 und auf dem PC
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
INT (1) | %..B2 | %..B1
INT (2) | %..B4 | %..B3
Dadurch das hinter dem ersten Byte eine anderer Variable-Typ (INT) folgt ist dieser im BX/BCxx50 auf die nächste freie grade Adresse gelegt worden. Will man beide auf beiden Systemen die gleiche Datenstruktur haben, muss im PC-Projekt ein Dummy-Byte eingefügt werden (siehe Beispiel 2).
Beispiel 2: Eine Struktur auf den BX/BCxx50 und auf dem PC mit gleicher Speicherbelegung
Variable | Speicher des BX/BCxx50 | Speicher des PC (TwinCAT)
Byte | %..B0 | %..B0
Byte (Dummy) | %..B1 (nicht unbedingt notwendig, da dies das System selber macht, wenn diese Variabel nicht vorhanden ist) | %..B1
INT (1) | %..B2 | %..B2
INT (2) | %..B4 | %..B4
Daten Struktur
Type PB_Data
STRUCT
wVar_1:WORD;
iValue_1:INT;
iValue_2:INT;
iValue_3:INT;
END_STRUCT
END_TYPE
Anlegen einer Struktur in den Variablen
VAR_Global
strData_Out AT %QB1000:PB_Data; (*PLC Variables *)
bInput_01 AT %IX0.0:BOOL; (* Input from a terminal *)
END_VAR
Kleines Programmbeispiel
strData_Out.wVar_1.0:=bInput_01;
Keine Real-Werte in gemischter Datenstruktur verwenden
In einer gemischten Datenstruktur sollten keine Real-Werte enthalten sein. Wenn dies doch der Fall ist, muss zusätzlich im BX/BCxx50 oder im TwinCAT-Masterprojekt das High und Low Word vertauscht werden. Verwenden Sie besser ein Array von Real-Werten oder übertragen Sie die Real-Werte einzeln.
Größere Feldbusdatenblöcke
Sie können auch größere Feldbusdatenblöcke übertragen, um eine Reserve für Ihre Struktur zu haben. Nachteil: Diese Reserven werden dann mit jedem Feldbustelegramm übertagen, was eine Mehrbelastung der Feldbuskommunikation verursacht.


Up- und Download von Programmen

Programmierung [image] Up- und Download von Programmen
Up- und Download von Programmen
Der Busklemmen-Controller verfügt über einen Speicher für den Quell-Code. Hier können das Programm, die Task-Konfiguration und die Bibliotheken abgespeichert werden. Sollte Speicher für den Quell-Code nicht ausreichen, kann man auch nur den Quell-Code ohne Task-Konfiguration und die Bibliotheken ablegen. Dies benötigt wesentlich weniger Speicherplatz!
Allgemeine Einstellungen
Unter Bearbeiten/Optionen kann eingestellt werden wann der Quell-Code zum Zielsystem heruntergeladen werden soll. Öffnen Sie das Optionsmenü.
Öffnen des Optionsmenüs
Wählen Sie nun den Source Download an.
Auswahl des Source Downloads
Hier könne Sie einstellen wann und was vom Source-Code zum Busklemmen-Controller runtergeladen werden soll.
Source code only: es wird das prx-File mit Informationen zum online Change übertragen. Damit ist ein einloggen per Online-Change möglich (die SPS stoppt nicht).
All files: Wie Source code only plus alle notwenigen Bibliotheken.
Source code only (excluded conpile info): es wird nur das prx File übertragen. Ein einloggen ist nur möglich, wenn die SPS stoppt.
Welche Option Sie verwenden können hängt von der Größe Ihrer Projekte ab.
Download eines Programms
Der Quell-Code kann man auf Anforderung zum Zielsystem übertragen. Dafür muss man mit seinem Programm eingeloggt sein. Unter Online/Quell-Code Download kann jetzt der Programm-Code zum Busklemmen-Controller übertragen werden.
Download des Programm Codes
Nach einer kurzen Zeit öffnet sich ein Fenster, das den Vorschritt des Downloads anzeigt.
Vorschritt des Downloads
Upload eines Programms
Um den Programm-Code wieder hoch zu laden, öffnen Sie im PLC Control ein neues File. Als nächstes klicken Sie auf die Schaltfläche PLC.
Upload eines Programms
Wählen Sie den Datenübertragungsweg aus:
▪
BCxx50 or BX via AMS, wenn sie über den Feldbus mit dem Busklemmen-Controller verbunden sind oder
▪
BCxx50 or BX via serial, wenn sie über die serielle Schnittstelle mit dem Busklemmen-Controller verbunden sind.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs
Als nächsten Schritt wählen Sie das Gerät aus und bestätigen Sie mit OK.
Auswahl des Gerätes
Der Quell-Code wird nun hochgeladen.
Passwort
Mit einem Passwort können Sie Ihr Projekt schützen (im PLC Control Projekt/Optionen/Kennworte).


Bibliotheken

Programmierung [image] Bibliotheken
Bibliotheken
Weiterführende Informationen
•
Bibliotheken - Übersicht
•
TcBaseBX
•
TcSystemBX
•
TcComPortBX
•
TcTwinSAFE


Bibliotheken - Übersicht

Programmierung [image] Bibliotheken [image] Bibliotheken - Übersicht
Bibliotheken - Übersicht
Für die Busklemmen Controller (Buskoppler mit SPS-Funktionalität, Bezeichnung BXxxxx) gibt es verschiedene Bibliotheken (siehe Beckhoff Information System).
Download
Zum Download der Bibliotheken bitte auf den Link mit der linken Maustaste klicken. Bitte die Bibliotheken in das Verzeichnis TwinCAT\PLC\LIB kopieren.
▪
Standard ( )
▪
TcSystemBX ( )
(die TcSystemBX benötigt die TcBaseBX Bibliothek)
▪
TcBaseBX (Download)
(die TcDisplayBX, TcNaciSwitchBX und TcDebugBX sind nun hier enthalten)
▪
TcComPortBX ( )
▪
ChrAscBX.lbx ( )
Verwenden Sie die zur Firmware passende Bibliothek
Für die neuste Firmware ist auch die neuste Bibliothek zu benutzen. Sollten Sie Ihren BX-Controller Updaten tauschen Sie auch die Bibliotheken.
Kopieren Sie diese Bibliotheken in das LIB-Verzeichnis, entfernen diese Bibliotheken aus Ihrem Projekt und fügen Sie sie erneut hinzu.
TcSystemBX
ADS | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
ADSREAD | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSWRITE | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSRDWRT | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSWRTCTL | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSRDSTATE | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
ADSRDDEVINFO | 04.03.04 | 0.90 | 0.14 | 1.00 | 0.02 | 1.00
Bit Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
CLEARBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
CSETBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
GETBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
SETBIT32 | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
Display Function | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_DispWrite | 31.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
Diagnose | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
BX_Security | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
DeviceTyp | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
FirmwareVersion | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
FirmwareVersionString | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
DeviceTyp | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
Read_Diagnose | 15.08.06 | 1.12 | 1.14 | - | 1.12 | 1.14
CRCBootproject | 15.08.06 | 1.14 | 1.14 | - | 1.14 | 1.14
Read Address | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
ReadSlaveAddress | 15.08.06 | 1.12 | 1.12 | 1.10 | 1.12 | -
Controller | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_BasicPID | 04.03.04 | 0.64 | 0.01 | 1.00 | 0.01 | 1.00
Event Logger Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
- | - | - | - | - | - | -
File Access | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_ReadFromFile | 03.08.04 | 1.04 | 1.04 | 1.00 | 1.04 | 1.00
FB_WriteToFile | 03.08.04 | 1.04 | 1.04 | 1.00 | 1.04 | 1.00
FB_ReadWriteFile | 03.08.04 | 1.04 | 1.04 | 1.00 | 1.04 | 1.00
Memory Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
MEMCMP | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
MEMCYP | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
MEMMOVE | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
MEMSET | 07.03.03 | 0.41 | 0.01 | 1.00 | 0.01 | 1.00
NOVRAM Functions | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
- | - | - | - | - | - | -
Serial Communication Interface | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
FB_COMPortClose | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
FB_COMPortOpen | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
F_COMPortRead | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
F_COMPortWrite | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
SFC | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
AnalyzeExpression | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
AppendErrorString | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
SFCActionControl | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
System / Time / TBus | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
DRAND | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
RTC | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
SYSTEMTIME_TO_DT | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
DT_TO_SYSTEMTIME | 07.03.03 | 0.28 | 0.01 | 1.00 | 0.01 | 1.00
GetSysTick | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
PresetSysTick | 14.07.03 | 0.49 | 0.01 | 1.00 | 0.01 | 1.00
Reboot | 21.07.03 | 0.59 | 0.14 | 1.00 | 0.02 | 1.00
Persistent_Data | 21.08.07 | 1.17 | 1.17 | - | 1.17 | 1.17
Debug | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
F_ReadDebugTimer | 08.08.03 | 0.59 | 0.14 | 1.00 | 0.02 | 1.00
F_StartDebugTimer | 08.08.03 | 0.59 | 0.14 | 1.00 | 0.02 | 1.00
NaviSwitch | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Alle Bausteine | 10.10.03 | 0.64 | 0.14 | 1.00 | 0.02 | 1.00
TcComPortBX
Com FBs | Version | Firmware
 |  | BX3100 | BX5100 | BX5200 | BX8000 | BX9000
Alle Bausteine | 20.08.03 | 0.60 | 0.02 | 1.00 | 0.01 | 1.00


TcBaseBX

Programmierung [image] Bibliotheken [image] TcBaseBX
TcBaseBX
Weiterführende Informationen
•
System Task Info
•
System Task Info Type
•
System Info
•
System Info Type
•
ADS
•
COM Port
•
BX Debug-Funktion
•
Navigations-Schalter
•
Display


System Task Info

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Task Info
System Task Info
VAR_GLOBAL
SystemTaskInfoArr : ARRAY[1..2] OF SYSTEMTASKINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable SystemTaskInfoArr. Diese Variable ist ein Feld von vier Strukturen des Types SYTEMTASKINFOTYPE. Die Strukturdefinition ist in der System-Bibliothek zu finden. Der Index in dieses Feld ist die Task-Id.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


System Task Info Type

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Task Info Type
System Task Info Type
TYPE SYSTEMTASKINFOTYPE
STRUCT
active : BOOL;
taskName : STRING(16);
firstCycle : BOOL;
cycleTimeExceeded : BOOL;
cycleTime : UDINT;
lastExecTime : UDINT;
priority : BYTE;
cycleCount : UDINT;
END_STRUCT
END_TYPE
Legende
active: Diese Variable zeigt an, ob die Task aktiv ist.
taskName: Der Taskname.
firstCycle: Diese Variable hat im ersten Zyklus der SPS-Task den Wert: TRUE.
cycleTimeExceeded: In dieser Variablen wird ein Überschreiten der eingestellten Taskzykluszeit gemeldet.
cycleTime :Eingestellte Taskzykluszeit in Vielfachen von 100 ns.
lastExecTime: Benötigte Zykluszeit für den letzten Zyklus in Vielfachen von 100 ns.
priority: Eingestellte Priorität der Task.
cycleCount: Zykluszähler.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


System Info

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Info
System Info
VAR_GLOBAL
SystemInfo : SYSTEMINFOTYPE;
END_VAR
Systemflags sind implizit deklarierte Variablen. Mit der Eingabehilfe finden Sie unter Systemvariablen eine Variable Systeminfo. Der Typ SYSTEMINFOTYPE ist in der System-Bibliothek deklariert. Um auf die Variable zugreifen zu können muss die System-Bibliothek in das Projekt eingebunden werden.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


System Info Type

Programmierung [image] Bibliotheken [image] TcBaseBX [image] System Info Type
System Info Type
TYPE SYSTEMINFOTYPE
STRUCT
runTimeNo : BYTE;
projectName : STRING(32);
numberOfTasks : BYTE;
onlineChangeCount : UINT;
bootDataFlags : BYTE;
systemStateFlags : WORD;
END_STRUCT
END_TYPE
Legende
runTimeNo: Gibt die Nummer des Laufzeitsystems (1) an.
projectName: Name des Projekts als STRING.
numberOfTasks: Anzahl der im Laufzeitsystem befindlichen Tasks (max. 2).
onlineChangeCount: Anzahl der seit dem letzten Komplettdownload gemachten Online-Änderungen.
bootDataFlags: Reserviert
systemStateFlags: Reserviert.
Entwicklungsumgebung | Zielplattform | Einzubindende SPS Bibliotheken
TwinCAT v2.9.0 | BX Controller | TcBaseBX.lbx


ADS

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS
ADS
Weiterführende Informationen
•
Lokale ADS-Port Nummern - Übersicht
•
ADS-Dienste
•
Deaktivieren der LED für Zykluszeit-Überschreitung


Lokale ADS-Port Nummern - Übersicht

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] Lokale ADS-Port Nummern - Übersicht
Lokale ADS-Port Nummern - Übersicht
Port Nummer | Beschreibung
100dez | Lesen und schreiben von Registern und Tabellen aus den Koppler und den komplexen Busklemmen
150dez | Lesen und schreiben der RTC (Echt-Zeit-Uhr)
153dez | SSB - auslesen der Emergency-Nachricht
800dez | Lokales Prozessabbild der PLC, siehe auch Port 801
801dez | Lokales Prozessabbild der PLC, siehe auch Port 800
0x1000 + Node ID | SSB - SDO Kommunikation mit CANopen-Knoten (Slave Nummer)


ADS-Dienste

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] ADS-Dienste
ADS-Dienste
Lokales Prozessabbild PLC Task 1 Port 800/801
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden muss darauf geachtet werden, das diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und müssen und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...2047
0xF021 | Input - Eingänge Bit | 0...16376
0xF030 | Output - Ausgänge | 0...2047
0xF031 | Output - Ausgänge Bit | 0...16376
0x4020 | Merker | 0...4095
0x4021 | Merker Bit | 0...32760
Dienste des ADS
AdsServerAdsState
Datentyp (only Read) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceState
Datentyp (only Read) | Bedeutung
INT | 0 - Start - die lokale PLC läuft 1 - Stop - die lokale PLC ist im Stop
AdsServerType
Datentyp (only Read) | Bedeutung
String | BX PLC Server
ADSWriteControl
Datentyp (write only) | Bedeutung
NetID | Net ID des Ethernet Controllers*
Port | 800
ADSSTATE | 5 - RUN / 6 - STOP
DEVSTATE | 0
LEN | 0
SRCADDR | 0
WRITE | positive Flanke startet den Baustein
TMOUT | zum Beispiel: t#1000 ms
* BC9050, BC9020, BC9120, BX9000
Registerzugriff Port 100
Die ADS-Portnummer ist bei den Busklemmen-Controllern der BX-Serie und den BCxx50/xx20 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 [READ ONLY] | 0...127 | 0...255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...255 | 0...3 | 1...255 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Minimaler Time-Out
Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer eine Sekunde eingestellt wird.
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).


Deaktivieren der LED für Zykluszeit-Überschreitung

Programmierung [image] Bibliotheken [image] TcBaseBX [image] ADS [image] Deaktivieren der LED für Zykluszeit-Überschreitung
Deaktivieren der LED für Zykluszeit-Überschreitung
Der BX-Controller überwacht die eingestellte Task-Zykluszeit. Wenn diese Überschritten wird, wird das Bit cycleTimeExceeded und die rote LED PLC gesetzt. In einigen Applikationen kann es zu kurzzeitigen, tolerierbaren Überschreitungen kommen. Zum Beispiel, wenn bei der seriellen Kommunikation, viele Daten empfangen werden. Um das Flackern der roten LED PLC zu verhindern, kann diese mit einem ADSWRITE abgeschaltet werden.
Aufbau des Befehls ADSWRITE
Mit dem Befehl ADSWRITE ist es möglich, die rote LED PLC des BX-Controllers zu deaktivieren.
Eingangsparameter | Beschreibung
NETID | lokale NetId des BX
Port Nummer | 800
IDXGRP | 16#0000_4080
IDXOFFS | 0
LEN | 1 Bytes
SRCADDR | Pointer auf 1 Byte 0: rote LED ON 1: rote LED OFF


COM Port

Programmierung [image] Bibliotheken [image] TcBaseBX [image] COM Port
COM Port
Weiterführende Informationen
•
Com Port - Übersicht
•
COM Port - Funktionen
•
COM Port - Funktionsbaustein
•
Datenstruktur ComConfig
•
Beispiel


Com Port - Übersicht

Programmierung [image] Bibliotheken [image] TcBaseBX [image] COM Port [image] Com Port - Übersicht
Com Port - Übersicht
Die Bibliothek beinhaltet Funktionsbausteine die einen Datenaustausch zwischen dem BXxxxx-Bus-Controller und einem Remote-Partner ermöglichen. Der maximale COM-Puffer beträgt 512 Byte für beide Richtungen.
Funktionsbausteine
Name | Beschreibung
FB_ComPortOpen | Eine serielle Verbindung zu einem Partner öffnen.
FB_ComPortClose | Eine serielle Verbindung zu einem Partner schließen.
Funktionen
Name | Beschreibung
F_ComPortRead | Daten aus dem COM-Puffer lesen
F_ComPortWrite | Daten in COM-Puffer schreiben
Unterstützte Baudraten
Baudrate [Baud] | COM 1 | COM 2
300 | NEIN | JA
600 | NEIN | JA
1200 | NEIN | JA
2400 | NEIN | JA
4800 | NEIN | JA
9600 | JA | JA
19200 | JA | JA
38400 | JA | JA
57600 | JA | JA
115200 | NEIN | JA
Weitere hilfreiche Bausteine finden Sie in der TcComPortBX.lbx.
▪
Baustein für die Nutzung der ComLib, ModbusRTU etc. für die BX Com Ports
▪
Baustein für die Kommunikation mit den BK8x00 Buskopplern
▪
Baustein für die Emulation eines BK8x00 Slaves


COM Port - Funktionen

Programmierung [image] Bibliotheken [image] TcBaseBX [image] COM Port [image] COM Port - Funktionen
COM Port - Funktionen
COM Port Read
Funktionsbaustein F_COMPORTREAD
FUNCTION F_COMPORTREAD
VAR_INPUT
hCom :INT;
cbRxBuffer :UINT;
pRxBuffer :UDINT;
Legende
hCom: wir mit dem iHandle des FB_COMPORTOPEN verbunden
cbRxBuffer: Maximale Länge der Daten, die gelesen werden können.
pRxBuffer: Pointer auf die Daten, die mit dem COM Puffer Inhalt geschrieben werden sollen.
Rückgabewert | Bedeutung
> 0 | Anzahl der Bytes, die vom COM Puffer in die PLC kopiert wurden
0x8000 | Speicherüberlauf
COM Port Write
Funktionsbaustein F_COMPORTWRITE
FUNCTION F_COMPORTWRITE
VAR_INPUT
hCom :INT;
cbTxBuffer :UINT;
pTxBuffer :UDINT;
Legende
hCom: wir mit dem iHandle des FB_COMPORTOPEN verbunden
cbTxBuffer: Anzahl der Datenbytes, die in den COM Puffer kopiert wurden.
pTxBuffer: Pointer auf die Daten, aus denen der COM Puffer gefüllt werden soll.
Rückgabewert | Bedeutung
> 0 | Anzahl der Bytes, die vom der PLC in den COM Puffer kopiert wurden
0x8000 | Speicherüberlauf


COM Port - Funktionsbaustein

Programmierung [image] Bibliotheken [image] TcBaseBX [image] COM Port [image] COM Port - Funktionsbaustein
COM Port - Funktionsbaustein
COM Port Open
Funktionsbaustein FB_COMPORTOPEN
FUNCTION_BLOCK FB_COMPORTOPEN
VAR_INPUT
bOpen :BOOL;
stComConfig :ST_COMCONFIG;
Legende
bOpen: Positive Flanke startet den Baustein
stComConfig: Datenstruktur COM Schnittstelle.
VAR_OUTPUT
bBusy :BOOL;
bErr :BOOL;
iErrId :WORD;
iHandle :WORD;
Legende
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bErr: Fehler Bit.
iErrId: Fehler Nummer.
iHandle: Pointerübergabe.
Rückgabeparameter iErrId | Bedeutung
0 | kein Fehler
-1, 0xFFFF | Falscher COM-Port
-2, 0xFFFE | Fehlerhafte oder nicht unterstützte Baudrate. Überprüfen Sie den Parameter stComConfig.BaudRate.
-3, 0xFFFD | Fehlerhaftes oder falsches Datenformat. Überprüfen Sie den Parameter stComConfig.
-4, 0xFFFC | Fehlerhaft Initialisierung der COM-Schnittstelle
-5, 0xFFFB | Nicht unterstützter Instanz
-6, 0xFFFA | Falsche Größe des RX-Buffers
-7, 0xFFF9 | Falsche Größe des TX-Buffers
-8, 0xFFF8 | COM-Port ist gesperrt
COM Port Close
Funktionsbaustein FB_COMPORTCLOSE
FUNCTION_BLOCK FB_COMPORTCLOSE
VAR_INPUT
bOpen :BOOL;
iHandle :WORD;
Legende
bClose: Positive Flanke startet den Baustein
iHandle: Pointerübergabe von FB_COMPORTOPEN.
VAR_OUTPUT
bBusy :BOOL;
bErr :BOOL;
iErrId :WORD;
Legende
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bErr: Fehler Bit.
iErrId: Fehler Nummer.
Rückgabeparameter iErrId | Bedeutung
0 | kein Fehler
> 0 | Fehler Nummer (#nicht dokumentiert#)


Datenstruktur ComConfig

Programmierung [image] Bibliotheken [image] TcBaseBX [image] COM Port [image] Datenstruktur ComConfig
Datenstruktur ComConfig
Die Einstellungen für die seriellen Schnittstellen des BX werden mit der folgenden Datenstruktur übergeben.
TYPE ST_COMConfig:
STRUCT
cbRxBufferLen :WORD;
cbTxBufferLen :WORD;
dwMode :DWORD;
BaudRate :DWORD;
eCommPort :E_CommPort;
eDataBits :E_DataBits;
eParity :E_Parity;
eStoppBits :E_StoppBits;
END_STRUCT
END_TYPE
Legende
cbRxBufferLen: hat keine Bedeutung (ist aus kompatibilitäts- Gründen beibehalten worden)
cbTxBufferLen: hat keine Bedeutung (ist aus kompatibilitäts- Gründen beibehalten worden)
dwMode: Daten Mode COM 1 nur "0" - COM 2 RS232 "0" und RS485 "1"
BaudRate: Baudrate
eCommPort: Com Port COM1/COM2
eDataBits: Anzahl der Datenbits SEVEN_DATABITS/EIGHT_DATABITS
eParity: EVEN/ODD/NONE
eStoppBits: Anzahl der Stoppbits ONE_STOPPBIT/TWO_STOPPBITS


Beispiel

Programmierung [image] Bibliotheken [image] TcBaseBX [image] COM Port [image] Beispiel
Beispiel
Beispiel Programm in ST
Download ( )
PROGRAM MAIN
VAR
(* EXAMPLE - BRIDGE between PIN 7 and 8 from X01 COM 2 Port*)
fb_COMPortOpen_1 : FB_COMPortOpen;
stCOMConfig_1 : ST_COMConfig;
hCOM : WORD;
Result_R : INT;
Result_W : INT;
Var_M : ARRAY[0..9] OF BYTE:=11,22,0,33,0(6);
Var_R : ARRAY[0..9] OF BYTE;
Value : INT;
Counter_V : BYTE; (* It is all OK, this value counts up *)
i : INT;
i_k : INT;
fbTimer : TON;
END_VAR
stCOMConfig_1.cbRxBufferLen :=300;
stCOMConfig_1.cbTxBufferLen :=300;
stCOMConfig_1.dwMode :=0;
stCOMConfig_1.BaudRate :=19200;
stCOMConfig_1.eCommPort :=COM2;
stCOMConfig_1.eDataBits:=EIGHT_DATABITS;
stCOMConfig_1.eParity:=EVEN;
stCOMConfig_1.eStoppBits:=ONE_STOPPBIT;

CASE i OF
(* Open Port *)
0: fb_COMPortOpen_1(bOpen:=TRUE , stCOMConfig:=stCOMConfig_1);
IF NOT fb_COMPortOpen_1.bBusy THEN
IF NOTfb_COMPortOpen_1.bError THEN
hCOM:=fb_COMPortOpen_1.iHandle ;
i:=i+1;
ELSE

i:=100;
END_IF
END_IF
(* Write data*)
1: fbTimer(IN:=FALSE);
Result_W:=F_COMPortWrite(hCom, 4,ADR(Var_M[0]));
IF Result_W>0 THEN
i:=i+1;
Var_M[2]:=Var_M[2]+1;
ELSE
i:=101;
END_IF
(*Receive data*)
2: Result_R:=F_COMPortRead(hCom, 100,ADR(Var_R[Value]));
IF Result_R<>0 THEN
Value:=Result_R+Value;
END_IF
IF Value>=4 THEN
FOR i_k:=0 TO Value DO(*Check protocol*)
IF Var_R[i_k-4]=11 AND Var_R[i_k-3]=22 AND Var_R[i_k-1]=33 THEN
Counter_V:=Var_R[i_k-2];
i:=1;
Value:=0;
END_IF
END_FOR
END_IF
fbTimer(IN:=TRUE,PT:=t#1s); (*Watchdog receive*)
IF fbTimer.Q THEN
fbTimer(IN:=FALSE);
i:=102;
END_IF
100: ; (*ERROR open port*)
101: ; (*ERROR send data*)
102: i:=1; (*WD ERROR no data receive*)
END_CASE


BX Debug-Funktion

Programmierung [image] Bibliotheken [image] TcBaseBX [image] BX Debug-Funktion
BX Debug-Funktion
Diese Funktionen können benutzt werden um Befehls-Ausführungszeiten in einem PLC-Projekt zu messen. Die Einheit ist ein Tick. Ein Tick entspricht 5.12 µs.
Funktion Start Debug Timer
Funktionsbaustein F_STARTDEBUGTIMER
Der Aufruf dieser Funktion startet den Timer. Der Rückgabe Wert ist "0".
Funktion Read Debug Timer
Funktionsbaustein F_READDEBUGTIMER
Mit dieser Funktion wird der Timer-Wert gelesen. Der Rückgabewert muss mit 5.12 µs multipliziert werden.
Beispiel
VAR
Timer_BX :WORD;
i :INT;
END_VAR
Programm
F_STARTDEBUGTIMER();
For i:=0 to 1000 do
;
END_FOR
Timer_BX:=F_READDEBUGTIMER();


Navigations-Schalter

Programmierung [image] Bibliotheken [image] TcBaseBX [image] Navigations-Schalter
Navigations-Schalter
Weiterführende Informationen
•
FUN GetNavSwitch


FUN GetNavSwitch

Programmierung [image] Bibliotheken [image] TcBaseBX [image] Navigations-Schalter [image] FUN GetNavSwitch
FUN GetNavSwitch
Dieser Funktionsbaustein ermöglicht es Ihnen das Auslesen des Navigationsschalters.
Funktionsbaustein F_GETNAVSWITCH
VAR_Output
F_GETNAVSWITCH :WORD;
Legende
F_GETNAVSWITCH: Daten des Schalters
Beschreibung des WORD
Bit | 15 | 14 | ... | 5 | 4 | 3 | 2 | 1 | 0
Name | LOCKED | - | ... | - | PRESS | RIGHT | LEFT | DOWN | UP
Wenn Bit 15 gesetzt ist befindet man sich im Menü des BX-Controllers. Dieses Bit ist solange gesetzt, solange der Anwender sich im Menü des BX3100 befindet. Sobald das Menü verlassen wurde, wird der Navigationsschalter sofort wieder für die PLC freigegeben, d.h. dass das Drücken des Press Buttons noch in dem Programm sichtbar ist. Bitte berücksichtigen Sie das in Ihrer Anwendung. Werten Sie zum Beispiel den Schalter erst einer kurzen warte Zeit aus, in dem Sie mit der fallenden Flanke von Bit 15 einen Timer starten.
Download Beispiel Programm in ST


Display

Programmierung [image] Bibliotheken [image] TcBaseBX [image] Display
Display
Weiterführende Informationen
•
FB DISPWRITE


FB DISPWRITE

Programmierung [image] Bibliotheken [image] TcBaseBX [image] Display [image] FB DISPWRITE
FB DISPWRITE
Funktionsbaustein FB_DISPWRITE
VAR_INPUT
bWrite :BOOL;
bBlanking :BOOL;
nRow :UINT;
sData :STRING(16)
Legende
bWrite: Positive Flanke startet den Baustein
bBlanking: FALSE Hintergrundbeleuchtung an, TRUE Hintergrundbeleuchtung aus, Default ist diese an (wird FW 1.15 bei allen BX Controllern unterstützt).
nRow: Zeile im Display 1 oder 2.
sData: String der im Display angezeigt wird
VAR_OUTPUT
bBusy :BOOL;
bErr :BOOL;
iErrId :WORD;
Legende
bBusy: So lange der Baustein TRUE ist der Baustein aktiv.
bErr: Fehler Bit.
iErrId: Fehler Nummer.
Rückgabeparameter | Bedeutung
0 | kein Fehler
> 0 | Fehler Nummer
Beispiel Programm in ST
Download
PROGRAM MAIN
VAR
fb_DispWrite1: FB_DispWrite;

i: INT;
udiCounter: UDINT;
strCounter: STRING;
strLine: STRING;
k: INT;
END_VAR
CASE i OF
0: strCounter:=CONCAT('Counter :',UDINT_TO_STRING(udiCounter));
fb_DispWrite1(bWrite:=TRUE , nRow:=1 ,sData:=strCounter );
IF NOT fb_DispWrite1.bBusy THEN
IF NOTfb_DispWrite1.bErr THEN
fb_DispWrite1(bWrite:=FALSE);
udiCounter:=udiCounter+1;
i:=1;
END_IF
END_IF
1: fb_DispWrite1(bWrite:=TRUE , nRow:=2 , sData:=strLine);
IF NOT fb_DispWrite1.bBusy THEN
IF NOTfb_DispWrite1.bErr THEN
fb_DispWrite1(bWrite:=FALSE);
k:=k+1;
strLine:=REPLACE(' ','#',1,k);
IF k=16 THEN
k:=0;
END_IF
i:=0;
END_IF
END_IF
END_CASE
Display ASCII Tabelle
Beispiel für das Zeichen "&" (siehe Zeile 1 Spalte 7): 00100110bin = 38dez = 26hex. Dies entspricht in dem SPS-Wert '$26' (String.)


TcSystemBX

Programmierung [image] Bibliotheken [image] TcSystemBX
TcSystemBX
Weiterführende Informationen
•
Echtzeit-Uhr - Beispiel
•
Laden und Speichern von Rezepturen


Echtzeit-Uhr - Beispiel

Programmierung [image] Bibliotheken [image] TcSystemBX [image] Echtzeit-Uhr - Beispiel
Echtzeit-Uhr - Beispiel
Auf dem BX-Controller ist eine Echtzeit-Uhr implementiert. Die aktuelle Uhrzeit kann per Funktionsbaustein ausgelesen werden. Das folgende Beispiel soll das verdeutlichen.
Funktionsbaustein RTC
FUNCTION_BLOCK RTC
VAR_INPUT
EN :BOOL;
PDT :DT;
Legende
EN: Positive Flanke setzt die Uhrzeit auf den Wert der an den PDT-Eingang anliegt.
PDT: Datum und Uhrzeit die eingestellt werden sollen.
VAR_OUTPUT
Q :BOOL;
CDT :BOOL;
Legende
CDT: Aktuelle Uhrzeit.
Notwendige Bibliotheken:
▪
TcSystemBX.lb6
▪
TcBaseBX.lb6
Download Beispiel Programm in ST ( )
PROGRAM MAIN
VAR
fbTimer: TON;
fbRTC: RTC;
END_VAR
fbTimer(PT:=t#60s,IN:=NOT fbTimer.Q);

IF fbTimer.Q THEN
fbRTC;
END_IF
RTC-Baustein nicht in jedem SPS-Zyklus aufrufen
Der Aufruf des RTC-Bausteins erhöht die Zykluszeit um ca. 5 ms, verursacht durch die Datenkonvertierung in eine TIME AND DATE Variable. Deshalb sollte der Baustein nicht in jedem SPS-Zyklus aufgerufen werden!
Alternativ können Sie die Uhrzeit auch per auslesen. Der ADS-Baustein liefert Datum und die Uhrzeit als WORD-Variablen zurück.
Beispiel 19:30 Uhr - Hour: 19 / Minute: 30


Laden und Speichern von Rezepturen

Programmierung [image] Bibliotheken [image] TcSystemBX [image] Laden und Speichern von Rezepturen
Laden und Speichern von Rezepturen
Der Funktionsbaustein fb_ReadWriteFile ermöglicht Daten (max. 16.000 Byte) dauerhaft im Flash-Speicher des BX-Controllers zu sichern. Ein neues Programm oder ein Reset des Projektes lässt diesen Speicherinhalt unberührt. Dieser Funktionsbaustein ist nicht für den Dauerhaften und ständigen Gebrauch geeignet. Es sind max. 10000 Schreibzyklen erlaubt. Es darf beliebig oft gelesen werden.
Anwendung: Sichern von Rezepten oder Einstellungen die sich selten oder gar nicht ändern, zum Beispiel Reglerparameter.
Beachten Sie beim Schreiben der Daten
•
Während des Schreibens darf die Spannung nicht unterbrochen werden, es empfiehlt sich daher, das Schreiben von einem Bedien-Panel oder über die Navigationsschalter oder einfach über einen digitalen Eingang anzustoßen, um sicher zu gehen, dass während des Schreibens der BX-Controller nicht ausgeschaltet wird. Ein automatisches Schreiben empfiehlt sich nicht, da man nicht sicherstellen kann, ob nicht grade in diesem Moment das Schreiben unterbrochen wird.
•
Das Schreiben der Daten benötigt ca. zwei Sekunden, unabhängig von der Anzahl der Daten, die geschrieben werden.
•
Wird der BX-Controller während des Schreibvorgangs ausgeschaltet gehen die Daten verloren.
•
Es ist nur eine Instanz dieses Bausteins erlaubt.
Funktionsbaustein fb_ReadWriteFile
Funktionsbaustein zum Lesen und Schreiben von Rezepturen
Funktionsbaustein fb_ReadWriteFile
VAR_INPUT
bRead :BOOL;
bWrite :BOOL;
OffsetRead :WORD;
DataReadSize :WORD;
DataRead :Pointer to Byte;
OffsetWrite :WORD;
DataWriteSize :WORD;
DataWrite :Pointer to Byte;
Legende
bRead: Eine positive Flanke stößt das Lesen des Bausteins an (bWrite muss FALSE sein)
bWrite: Eine positive Flanke stößt das Schreiben des Bausteins an (bRead muss FALSE sein)
OffsetRead: Offset im Speicher max.16.000 Byte
DataReadSize: Größe der Daten in Byte, die gelesen werden sollen (max. 16.000 Byte)
DataRead: Pointer per ADR auf die Daten zeigen
OffsetWrite: Offset im Speicher max.16.000 Byte
DataWriteSize: Größe der Daten in Byte, die geschrieben werden sollen (max. 16.000 Byte)
DataWrite: Pointer per ADR auf die Daten zeigen
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
bErrorId :UDINT
Legende
bBusy: Zeigt an des der Baustein noch aktiv ist
bError: Baustein hat einen Fehler
bErrorId: Fehlernummer
Rückgabeparameter iErrorId | Bedeutung
0 | kein Fehler
1dez | READ: Daten-Offset und Daten-Länge über 16.000 Byte
2dez | WRITE: Daten-Offset und Daten-Länge über 16.000 Byte
0x31440708 | CRC-Fehler im Datenspeicher
0x31470708 | Das Schreiben der Daten ist noch nicht abgeschlossen
Notwendige Bibliotheken:
▪
TcSystemBX.lb6
▪
TcBaseBX.lb6
Download Beispiel Programm in ST ( )


TcComPortBX

Programmierung [image] Bibliotheken [image] TcComPortBX
TcComPortBX
Weiterführende Informationen
•
TcComPortBX - Übersicht
•
BK8x00 - FB COM-Port
•
BK8x00 - FB Slave COM-Port
•
FB_BX_COM_5
•
FB_BX_COM_64
•
FB_BX_COM_64ex
•
Weitere Beispiele


TcComPortBX - Übersicht

Programmierung [image] Bibliotheken [image] TcComPortBX [image] TcComPortBX - Übersicht
TcComPortBX - Übersicht
Erforderliche Bibliotheken:
▪
TcBaseBX
▪
TcSystemBX
Überblick
Name | Beschreibung
fb_BX_BK8x00 Master | BK8x00 COM Port Funktionsbaustein, Kommunikation mit Buskoppler BK8x00 oder BC8x00
fb_BX_BK8x00 Slave | BK8x00 COM Port Funktionsbaustein, Kommunikation mit PC. Es wird ein BK8x00 simuliert.
Name | Beschreibung
FB_BX_COM_5 | Baustein zum Emulieren einer KL60x1(wenn COMlib.lb6 oder ModbusRTU.lb6 verwendet wird).
FB_BX_COM_64 | Baustein zum Emulieren einer PC-Schnittstelle (wenn COMlib.lib oder ModbusRTU.lib verwendet wird).
FB_BX_COM_64ex | Baustein zum Emulieren einer PC-Schnittstelle (wenn COMlib.lib oder ModbusRTU.lib verwendet wird). Hier kann die COM-Schnittstelle auch während des Betriebs geschlossen werden.


BK8x00 - FB COM-Port

Programmierung [image] Bibliotheken [image] TcComPortBX [image] BK8x00 - FB COM-Port
BK8x00 - FB COM-Port
Über diesen Funktionsbaustein kann über die serielle Schnittstelle des BXxxxx die seriellen Buskoppler BK8000 mit RS485 und BK8100 mit RS232-Anschluss verwendet werden. Die Maximale Baudrate beträgt 38400 Baud.
Funktionsbaustein FB_BX_BK8X00_MASTER
VAR_INPUT
stCOMConfig :ST_COMConfig;
byAddress :BYTE;
byLen :BYTE;
byMaxInputLen :BYTE;
ptDataOut :POINTER TO BYTE;
ptDataIN :POINTER TO BYTE;
bStart :BOOL;
TmOut :TIME;
Legende
stComConfig: Struktur für die Auswahl der COM Parameter
byAddress: BX8x00 Adresse 1-98 (0 und 99 sind reserviert)
byLen: Daten Länge in [BYTE] (es sind nur grade Zahlen zugelassen 0, 2, 4, ...)
byMaxInputLen: wird mit SIZEOF und der Variable, die mit ptDataIN verbunden ist, angeschlossen
ptDataOut: wird mit ADR und den Daten Out verbunden
ptDataIn: wird mit ADR und den Daten In verbunden
bStart: positive Flanke startet den Baustein
TMOut: Wartezeit bis abgebrochen wird
VAR_OUTPUT
bBusy :BOOL;
bError :BOOL;
iErrorId :WORD;
Input_len :WORD;
Legende
bBusy: So lange der Baustein TRUE ist der Baustein aktiv
bError: Fehler Bit
iErrorId: Fehler Nummer
Input_Len: Anzahl der Daten die Empfangen wurden
Rückgabeparameter iErrorId | Bedeutung
0 | kein Fehler
100dez | Fehler beim Öffnen des COM-Ports
101dez | Fehler beim Senden der Daten
102dez | Watchdog Fehler, keine Antwort vom Slave innerhalb der WD-Zeit
105dez | Der Input Puffer ist zu klein
200dez | CRC-Fehler
0x80xxhex | Buskoppler Fehler xx Status Byte des Buskopplers (siehe BX8x00 Dokumentation)
Hardware
RS 232 Kommunikation PIN Belegung
BX COM1 RS232 | BX COM2 RS232 | BK8100
2 | 8 | 2
3 | 7 | 3
5 | 5 | 5
RS485 Kommunikation PIN Belegung
Einstellungen im FB: Wichtig ist das bei der Nutzung der RS485-Verbindung die Variable stCOMConfig:=1 ist und die COM2-Schnittstelle angewählt ist.
BX COM2 RS485 | BK8000
1 | 3
6 | 8
Beispiel Programm in ST
Download ( )
Notwendiges Material:
▪
BX3100 + Busklemme
▪
BK8100, KL1xx8, KL2xx8, KL9010
▪
Serielles Kabel, PIN Belegung: siehe im Beispielprogramm


BK8x00 - FB Slave COM-Port

Programmierung [image] Bibliotheken [image] TcComPortBX [image] BK8x00 - FB Slave COM-Port
BK8x00 - FB Slave COM-Port
Mit diesem Funktionsbaustein kann der PC (TwinCAT oder KS8000) über die serielle Schnittstelle mit dem BXxxxx verbunden werden. Dabei ist der PC der serielle Master und der BXxxxx emuliert mit Hilfe des Funktionsbausteins eines BK8x00.
Funktionsbaustein FB_BX_BK8X00_SLAVE
VAR_INPUT
stCOMConfig :ST_COMConfig;
byAddress :BYTE;
byLenDataOut :BYTE;
byLenDataIN :BYTE;
ptDataOut :POINTER TO BYTE;
ptDataIN :POINTER TO BYTE;
WDTime :TIME;
Legende
stComConfig: Struktur für die Auswahl der COM Parameter
byAddress: BX8x00 Adresse 1-98 (0 und 99 sind reserviert)
byLenDataOut: Daten Länge in [BYTE] (es sind nur grade Zahlen zugelassen 0, 2, 4, ...)
byLenDataIn: Daten Länge in [BYTE] (es sind nur grade Zahlen zugelassen 0, 2, 4, ...)
ptDataOut: wird mit ADR und den Daten Out verbunden
ptDataIn: wird mit ADR und den Daten In verbunden
WDTime: Fehlermeldung wenn innerhalb der Watchdog - Zeit keine neuen Daten empfangen wurden (0 ms disable WD)
VAR_OUTPUT
bError :BOOL;
iErrorId :WORD;
Input_Len :BYTE;
Legende
bError: Fehler Bit
iErrorId: Fehler Nummer
Input_Len: Anzahl der Daten die Empfangen wurden
Rückgabeparameter iErrorId | Bedeutung
0 | kein Fehler
1 | Watchdog Fehler wenn diese größer 0 ms ist (WD disable wenn 0 ms)
100dez | Fehler beim Öffnen des COM Ports
101dez | Fehler beim Senden der Daten
103dez | Interner Recive Buffer übergelaufen
104dez | Daten passen nicht in den PLC Buffer (größer 500 Byte)
105dez | Daten können nicht in den PLC Buffer kopiert werden
200dez | CRC - Fehler
Hardware
RS232-Kommunikation PIN-Belegung
BX COM 1 RS232 | BX COM 2 RS232 | PC COM Schnittstelle
2 | 8 | 2
3 | 7 | 3
5 | 5 | 5
RS485-Kommunikation PIN-Belegung
Einstellungen im FB: Wichtig ist das bei der Nutzung der RS485-Verbindung die Variable stCOMConfig:=1 ist und die COM2-Schnittstelle angewählt ist.
BX COM 2 RS485 | PC COM Port (zum Beispiel: RS485 Karte W&T #13601, 2-Draht, ohne Echo, Automatik)
1 | 1 - 2 Brücken
6 | 6 - 7 Brücken
Beispiel Programm für den BXxxx in Strukturiertem Text
Download ( )
System Manager File für TwinCAT als Master. Wie man im Bild sieht, wird ein Buskoppler mit Busklemmen projektiert. Die Art und Anzahl der Busklemmen gibt dann die Datenlänge an. Welche Busklemmen das sind spielt im Prinzip keine Rolle. Zum Beispiel:
▪
2 x KL3002 ergibt 4 Worte Eingänge
▪
2 x KL4002 ergibt 4 Worte Ausgänge
Kommunikationseigenschaften
Notwendiges Material:
▪
BX3100 + Busklemme
▪
PC mit RS232-Schnittstelle und TwinCAT ab Version 2.9, serielles Kabel, PIN-Belegung: siehe oben


FB_BX_COM_5

Programmierung [image] Bibliotheken [image] TcComPortBX [image] FB_BX_COM_5
FB_BX_COM_5
Dieser Baustein verbindet die ModbusRTU.lb6, ModbusRTU.lib oder die ComLib.lb6 mit der seriellen Schnittstelle des BX-Controllers. Es wird eine KL60x1 Emuliert, die Daten werden nicht auf eine Busklemme ausgegeben, sonder über eine der beiden auf dem BX befindlichen seriellen Schnittstellen.
Funktionsbaustein FB_BX_COM_5
VAR_INPUT
pstrEmo_IN :POINTER TO BYTE;
pstrEmo_OUT :POINTER TO BYTE;
ComConfig :ST_COMConfig;
Legende
pstrEmo_IN: Pointer auf die KL6inData5B
pstrEmo_OUT: Pointer auf die KL6outData5B
ComConfig: Parametrierung der COM Schnittstelle
Download Beispielprogramm in ST für die Verknüpfung COMLib zum BX: ( )


FB_BX_COM_64

Programmierung [image] Bibliotheken [image] TcComPortBX [image] FB_BX_COM_64
FB_BX_COM_64
Dieser Baustein verbindet die ModbusRTU.lib oder ComLib.lib mit der seriellen Schnittstelle des BX-Controllers. Es wird eine PC-Schnittstelle emuliert. Die Daten werden nicht auf einer PC-Schnittstelle ausgegeben, sondern über eine der beiden auf dem BX befindlichen seriellen Schnittstellen (COM1 oder COM2).
Funktionsbaustein FB_BX_COM_64
VAR_INPUT
pstrEmo_IN :POINTER TO BYTE;
pstrEmo_OUT :POINTER TO BYTE;
ComConfig :ST_COMConfig;
Legende
pstrEmo_IN: Pointer auf die ModbusPCComInData
pstrEmo_OUT: Pointer auf die ModbusPCComInData
ComConfig: Parametrierung der COM Schnittstelle
Download Beispielprogramm in ST für die Verknüpfung ModbusRTU zum BX: ( )
Download Beispielprogramm in ST für die Verknüpfung ModbusRTU Version 2 zum BX: ( )
Für das Beispiel ist die ModbusRTU-Bibliothek notwendig!


FB_BX_COM_64ex

Programmierung [image] Bibliotheken [image] TcComPortBX [image] FB_BX_COM_64ex
FB_BX_COM_64ex
Dieser Baustein verbindet die ModbusRTU.lib oder ComLib.lib mit der seriellen Schnittstelle des BX-Controllers. Es wird eine PC Schnittstelle mit 64 Byte Nutzdaten emuliert. Die Daten werden nicht auf eine PC-Schnittstelle ausgegeben, sondern über eine der beiden auf dem BX befindlichen seriellen Schnittstellen (COM1 oder COM2).
Funktionsbaustein FB_BX_COM_64EX
VAR_INPUT
pstrEmo_IN :POINTER TO BYTE;
pstrEmo_OUT :POINTER TO BYTE;
ComConfig :ST_COMConfig;
VAR_OUTPUT
ComPortIsClose :BOOL;
bError :BOOL;
iErrorId :INT;
Legende
pstrEmo_IN:
Pointer auf die ModbusPCComInData
pstrEmo_OUT:
Pointer auf die ModbusPCComOutData
ComConfig:
Parametrierung der COM Schnittstelle
COM_Port_Open:
Wird dieses Bit gesetzt, wird die Schnittstelle geöffnet. Wird dieses Bit zurückgesetzt wird die COM Schnittstelle geschlossen.
ComPortIsClose:
Wenn die Schnittstelle geschlossen ist, ist diese Bit gesetzt
bError:
Es liegt ein Fehler vor
iErrorId:
Fehlercode (siehe FB_COMPortOpen)
Download Beispielprogramm in ST für die Verknüpfung ModbusRTU zum BX: ( )
Für das Beispiel ist die ModbusRTU Bibliothek erforderlich!


Weitere Beispiele

Programmierung [image] Bibliotheken [image] TcComPortBX [image] Weitere Beispiele
Weitere Beispiele
Weiterführende Informationen
•
BX COM-Port als ModbusRTU-Master
•
BX COM-Port - ComLibV2
•
BX COM-Port - Cimrex-Panel
•
BX COM-Port - RK512-Protokoll
•
BX COM-Port - SMS über Mobiltelefon


BX COM-Port als ModbusRTU-Master

Programmierung [image] Bibliotheken [image] TcComPortBX [image] Weitere Beispiele [image] BX COM-Port als ModbusRTU-Master
BX COM-Port als ModbusRTU-Master
Die serielle Schnittstelle des BX kann auch dazu benutzt werden, diese als Modbus-Master zu verwenden.
Benötigte Komponenten
1 x BX3100
Busklemmen für den K-Bus (hier beliebig, da diese für das Beispiel nicht gebraucht werden)
1 x BK7300
2 x KL2xx4
2 x KL1xx4
1 x KL9010
Kabel RS 485*
BX3100 COM 2 / RS 485 | BK7300 / RS 485
1 | 3
6 | 8
*) aktiver Abschlusswiderstand ist bei kurzen Leitungslängen (< 5 m) und kleinen Baudraten (<19200 Baud) nicht erforderlich
Download Beispiel Programm in ST für die Verknüpfung ModbusRTU Master zum BX: ( )
Download Beispiel Programm in ST für die Verknüpfung ModbusRTU Master Version 2 zum BX: ( )
Für das Beispiel ist die ModbusRTU, TcComPortBC, TcBaseBX Bibliothek notwendig.
Baudrate 9600, n, 8,1 Default BK7300,
BK7300 Adresse 11
Reaktionszeiten
Die Reaktionszeiten sind abhängig von der eingestellten Task-Zeit, die Anzahl an Slaves, die Länge der Modbus-Telegramme und der Antwortzeit der Slaves.
Für die Ermittlung folgender Tabelle wurden Beckhoff BK7300 Modbus Slaves verwendet. Da dies nicht auf jeden Slave übertragbar ist, sollte diese Tabelle nur als Richtwert verwendet werden.
Baudrate 38400 Baud (jeweils ein Read Reg. und ein Write Reg. Telegramm pro Slave)
Slave-Anzahl | Task-Zeit auf dem BX | Zeit für einen Durchlauf
1 | 5 | 100 ms* / 125 ms**
2 | 5 | 200 ms / 225 ms
1 | 10 | 180 ms / 220 ms
2 | 10 | 350 ms / 390 ms
1 | 20 | 350 ms / 350 ms
2 | 20 | 700 ms / 700 ms
*) 2 Worte Ein- und 2 Worte Ausgänge
**) 20 Worte Ein- und 20 Worte Ausgänge


BX COM-Port - ComLibV2

Programmierung [image] Bibliotheken [image] TcComPortBX [image] Weitere Beispiele [image] BX COM-Port - ComLibV2
BX COM-Port - ComLibV2
Beispiele für ComLibV2 senden von Strings über die interne COM Schnittstelle des BX Controllers. Um Daten zu empfangen kann man eine Brücke vom PIN 7 und 8 herstellen auf X01 (COM2).
Notwendiges Material
Hardware:
▪
BX-Controller
Software:
▪
TwinCAT ab 2.10
▪
COMlibV2.lib
▪
TcComPortBX.lbx
▪
Standard.lbx
▪
TcBase.lbx
▪
TcSystemBX.lbx
Download Beispielprogramm BX: ( )


BX COM-Port - Cimrex-Panel

Programmierung [image] Bibliotheken [image] TcComPortBX [image] Weitere Beispiele [image] BX COM-Port - Cimrex-Panel
BX COM-Port - Cimrex-Panel
Die serielle Schnittstelle des BX-Controllers kann auch als Modbus-Slave benutzt werden. In diesem Beispiel wird ein Panel der Firma Beijers angeschlossen. Weitere Informationen zu dem Panel finden Sie unter http://www.beijerelectronics.de.
Cimrex-Panel am COM-Port des BX-Controllers
Benötigte Komponeten
▪
1 x BX3100
▪
1 x Cimrex 12
▪
beliebige Busklemmen (beliebig, da diese im Beispiel nicht benutzt werden)
Kabel RS232
BX3100 COM 2 / RS485 | Cimrex 12 RS232
7 | 2
8 | 3
9 | 5
Kabel RS485*
BX3100 COM 2 / RS 485 | Cimrex 12 RS485
1 | 2 -3
6 | 15 -16
*) aktiver Abschlusswiderstand ist bei kurzen Leitungslängen (≤ 5 m) und kleinen Baudraten (≤19200 Baud) nicht erforderlich
Download Beispielprogramm in ST für den BX: ( )
Download Beispiel mit Cimrex-Panel: ( )
Für das Beispiel sind die Bibliotheken ModbusRTU, TcComPortBC und TcBaseBX erforderlich.
- Baudrate 9600,n,8,1 D
- Cimrex 12


BX COM-Port - RK512-Protokoll

Programmierung [image] Bibliotheken [image] TcComPortBX [image] Weitere Beispiele [image] BX COM-Port - RK512-Protokoll
BX COM-Port - RK512-Protokoll
Über die Schnittstelle COM1 oder COM2 des BX-Controllers kann das RK512-Protokoll Daten mit einer Gegenstelle austauschen. Dokumentation zum RK512-Baustein finden Sie im Beckhoff Information System.
Über die 64 Byte Emulation des BX-Controllers wird die serielle Schnittstelle des PC simuliert.
Notwendiges Material
Hardware:
▪
PC mit RS232 Schittstelle und TwinCAT PLC ab 2.9
▪
BX-Controller
▪
Serielles Kabel für die Verbindung BX - PC
Software:
▪
TwinCAT ab 2.9
▪
COMlib.lib
▪
COMlib3964R.lib
▪
COMlibRK512.lib
▪
TcComPortBX.lbx
▪
Standard.lbx
▪
TcBase.lbx
▪
TcSystemBX.lbx
▪
ChrAscBx.lbx
Download Beispielprogramm BX3100: ( )
Download Beispielprogramm PC: ( )
Download Beispiel System Manager File PC: ( )


BX COM-Port - SMS über Mobiltelefon

Programmierung [image] Bibliotheken [image] TcComPortBX [image] Weitere Beispiele [image] BX COM-Port - SMS über Mobiltelefon
BX COM-Port - SMS über Mobiltelefon
Die serielle Schnittstelle kann auch dafür verwendet werden, vom BX-Controller aus eine SMS zu versenden. Das folgende Beispiel benutzt die SMS-Bibliothek mit einem Siemens S35 Mobiltelefon.
Mobiltelefon am COM-Port des BX-Controllers
Download: ( )
Pinbelegung (Siemens-Kabel S30880-S4501 A801-2)
S35 | COM 1 | COM 2
2 | 3 | 7
3 | 2 | 8
5 | 5 | 9


TcTwinSAFE

Programmierung [image] Bibliotheken [image] TcTwinSAFE
TcTwinSAFE
Weiterführende Informationen
•
Übersicht
•
FUNCTION F_GetVersionTcTwinSAFE
•
FUNCTION_BLOCK FB_TwinSAFE_KLx904_input
•
FUNCTION_BLOCK FB_TwinSAFE_KLx904_output


Übersicht

Programmierung [image] Bibliotheken [image] TcTwinSAFE [image] Übersicht
Übersicht
Die Busklemmen-Controller der BX-Serie unterstützen die TwinSAFE-Busklemmen wenn folgende Vorraussetzungen erfüllt sind:
▪
Am Busklemmen-Controller ist nur eine Logik-Klemme zugelassen und diese muss am K-Bus-Interface angeschossen sein, nicht am SSB.
▪
An dieser Logik-Klemme sind maximal 7 Verbindungen zugelassen.
▪
TwinSAFE-Ein- und Ausgangsklemmen können an den K-Bus wie auch an den SSB angeschossen werden, zum Beispiel über BK5120 oder BK515x.
▪
Falls Online-Changes verwendet werden soll, muss der Connection-Timeout auf 500 ms oder höher eingestellt werden.
▪
Für den Download der TwinSAFE-Projekte muss eine ADS-Verbindung bestehen. Diese kann seriell aber auch über den Feldbus hergestellt werden.
▪
Die Firmware-Version des Busklemmen-Controllers muss 1.17 oder höher sein.
TwinSAFE-Bibliothek
Die TwinSAFE-Bibliothek beinhaltet Funktionsbausteine, mit denen Dienste/Funktionen in Zusammenhang mit den TwinSAFE-Klemmen KL1904, KL2904 und KL6904 ausgeführt werden können.
Name | Beschreibung
F_GetVersionTcTwinSAFE | Versionsnummer der Bibliothek
FB_TwinSAFE_KLx904_input | Auswertung der TwinSAFE Daten, welche von einer KL1904 oder KL2904 zu einer KL6904 gesendet werden
FB_TwinSAFE_KLx904_output | Auswertung der TwinSAFE Daten, welche von einer KL6904 zu einer KL1904 oder KL2904 gesendet werden
Download der TwinSAFE-Bibliothek: ( )


FUNCTION F_GetVersionTcTwinSAFE

Programmierung [image] Bibliotheken [image] TcTwinSAFE [image] FUNCTION F_GetVersionTcTwinSAFE
FUNCTION F_GetVersionTcTwinSAFE
Funktionsbaustein F_GETVERSIONTCTWINSAFE
Mit dieser Funktion können Versionsinformationen der SPS-Bibliothek ausgelesen werden.
FUNCTION F_GetVersionTcTwinSAFE : UINT
VAR_INPUT
nVersionElement : INT;
END_VAR
nVersionElement: Versionselement, das gelesen werden soll. Mögliche Parameter:
▪
1 : major number;
▪
2 : minor number;
▪
3 : revision number;
Entwicklungsumgebung | Zielplattform | IO-Hardware | Einzubindende SPS-Bibliotheken
TwinCAT v2.10.0 Build > 914 | PC (i386) | - | TcTwinSAFE.Lib (Standard.Lib, TcBase.Lib und TcSystem.Lib werden automatisch eingebunden)
TwinCAT v2.10.0 | BX-Serie | - | TcTwinSAFE.LBX (Standard.LBX; TcBaseBX.LBX; TcSystemBX.LBX werden automatisch eingebunden)


FUNCTION_BLOCK FB_TwinSAFE_KLx904_input

Programmierung [image] Bibliotheken [image] TcTwinSAFE [image] FUNCTION_BLOCK FB_TwinSAFE_KLx904_input
FUNCTION_BLOCK FB_TwinSAFE_KLx904_input
Funktionsbaustein FB_TWINSAFE_KLX904_INPUT
Mit dem Funktionsbaustein FB_TwinSAFE_KLx904_input kann eine Auswertung der TwinSAFE Daten, welche von einer KL1904 oder KL2904 zu einer KL6904 gesendet werden durchgeführt werden. Der Eingangsparameter wird mit den SafetyIn Daten einer KL1904 oder KL2904 im System Manager doppelt verknüpft.
VAR_INPUT
VAR_INPUT
KLx904_SafetyIn AT%I* : TwinSAFE_Data; (* Additional link to "SafetyIn" *)
END_VAR
KLx904_SafetyIn: TwinSAFE Telegramm, welches von einer KL1904 oder KL2904 zu einer KL6904 gesendet wird. Dieser Parameter wird im System Manager auf SafetyIn (Eingangsdaten der KLx904) doppelt verknüpft.
VAR_OUTPUT
VAR_OUTPUT
bInput1 : BOOL;
bInput2 : BOOL;
bInput3 : BOOL;
bInput4 : BOOL;
tCycleTime : TIME;
bConnectionInRun : BOOL;
END_VAR
bInput1: Liefert den Eingang 1 einer KL1904. Ist dieser Baustein für eine Verbindung zu einer KL2904 verwendet, ist der Wert immer 0.
bInput2: Liefert den Eingang 2 einer KL1904. Ist dieser Baustein für eine Verbindung zu einer KL2904 verwendet, ist der Wert immer 0.
bInput3: Liefert den Eingang 3 einer KL1904. Ist dieser Baustein für eine Verbindung zu einer KL2904 verwendet, ist der Wert immer 0.
bInput4: Liefert den Eingang 4 einer KL1904. Ist dieser Baustein für eine Verbindung zu einer KL2904 verwendet, ist der Wert immer 0.
tCycleTime: Liefert die Zykluszeit in ms, die benötigt wird um das TwinSAFE Telegramm zwischen den Teilnehmern auszutauschen.
bConnectionInRun: Liefert ein TRUE wenn kein Fehler in der Verbindung von der KLx904 zur KL6904 ansteht.
Beispiel für einen Aufruf im FUB:
PROGRAM MAIN
VAR
fbTwinSAFE_KLx904_input : FB_TwinSAFE_KLx904_input;
bInput1_KL1904_S_Address_113 : BOOL;
bInput2_KL1904_S_Address_113 : BOOL;
bInput3_KL1904_S_Address_113 : BOOL;
bInput4_KL1904_S_Address_113 : BOOL;
tCycleTime_KL1904_KL6904 : TIME;
bConnection3_In_Run : BOOL;
END_VAR
Funktionsbaustein FB_TWINSAFE_KLX904_input
Im Beispiel werden die Werte der KL1904 Eingangsdaten auf die angeschlossenen Variablen geschrieben. Ist der Ausgang bConnectionInRun FALSE werden die Ausgänge generell auf FALSE gesetzt.
Zum Verknüpfen der Eingangsdaten markieren Sie den Parameter KLx904_SafetyIn und wählen aus dem Kontext Menü "Verknüpfung ändern..."
Verknüpfen der Eingangsdaten
und wählen im folgenden Dialog die entsprechende SafetyIn-Variable
Auswahl der SafetyIn-Variable
Entwicklungsumgebung | Zielplattform | IO-Hardware | Einzubindende SPS-Bibliotheken
TwinCAT v2.10.0 Build > 914 | PC (i386) | KLx904 | TcTwinSAFE.Lib (Standard.Lib, TcBase.Lib und TcSystem.Lib werden automatisch eingebunden)
TwinCAT v2.10.0 Build > 914 | BX-Serie | KLx904 | TcTwinSAFE.LBX (Standard.LBX, TcBaseBX.LBX und TcSystemBX.LBX werden automatisch eingebunden)


FUNCTION_BLOCK FB_TwinSAFE_KLx904_output

Programmierung [image] Bibliotheken [image] TcTwinSAFE [image] FUNCTION_BLOCK FB_TwinSAFE_KLx904_output
FUNCTION_BLOCK FB_TwinSAFE_KLx904_output
Funktionsbaustein FB_TWINSAFE_KLX904_OUTPUT
Mit dem Funktionsbaustein FB_TwinSAFE_KLx904_output kann eine Auswertung der TwinSAFE Daten, welche von einer KL6904 zu einer KL1904 oder KL2904 gesendet werden durchgeführt werden. Der Eingangsparameter wird mit den SafetyQBx Daten einer KL6904 im System Manager doppelt verknüpft.
VAR_INPUT
VAR_INPUT
KL6904_SafetyQBx AT%I* : TwinSAFE_Data; (* Additional link to "SafetyQBx" *)
END_VAR
KL6904_SafetyQBx: TwinSAFE Telegramm, welches von einer KL6904 zu einer KL1904 oder KL2904 gesendet wird. Dieser Parameter wird im System Manager auf SafetyQBx (Eingangsdaten der KL6904) doppelt verknüpft, wobei das x für Ziffern zwischen 1 und 15 steht entsprechend der verwendeten TwinSAFE Connection.
VAR_OUTPUT
VAR_OUTPUT
bOutput1 : BOOL;
bOutput2 : BOOL;
bOutput3 : BOOL;
bOutput4 : BOOL;
tCycleTime : TIME;
bConnectionInRun : BOOL;
END_VAR
bOutput1: Liefert den Ausgang 1 einer KL2904. Wird der Baustein für eine Verbindung zur KL1904 verwendet, ist dieser Wert grundsätzlich 0.
bOutput2: Liefert den Ausgang 2 einer KL2904. Wird der Baustein für eine Verbindung zur KL1904 verwendet, ist dieser Wert grundsätzlich 0.
bOutput3: Liefert den Ausgang 3 einer KL2904. Wird der Baustein für eine Verbindung zur KL1904 verwendet, ist dieser Wert grundsätzlich 0.
bOutput4: Liefert den Ausgang 4 einer KL2904. Wird der Baustein für eine Verbindung zur KL1904 verwendet, ist dieser Wert grundsätzlich 0.
tCycleTime: Liefert die Zykluszeit in ms, die benötigt wird um das TwinSAFE Telegramm zwischen den Teilnehmern auszutauschen.
bConnectionInRun: Liefert ein TRUE wenn kein Fehler in der Verbindung von der KL6904 zur KLx904 ansteht.
Beispiel für einen Aufruf im FUB
PROGRAM MAIN
VAR
fbTwinSAFE_KLx904_output : FB_TwinSAFE_KLx904_output;
bOutput1_KL6904_Connection_to_113 : BOOL;
bOutput2_KL6904_Connection_to_113 : BOOL;
bOutput3_KL6904_Connection_to_113 : BOOL;
bOutput4_KL6904_Connection_to_113 : BOOL;
tCycleTime_KL6904_KL1904 : TIME;
bConnection3_In_Run_2 : BOOL;
END_VAR
Aufruf des Funktionsbausteins FB_TWINSAFE_KLX904_OUTPUT
Im Beispiel werden die Werte der TwinSAFE Klemme KL6904 zur KL1904 ausgewertet. Da in dieser Verbindung keine Ausgangssignale verwendet werden, sind die Ausgänge grundsätzlich FALSE. Es kann nur tCycleTime und bConnectionInRun ausgewertet werden.
Aufruf des Funktionsbausteins FB_TWINSAFE_KLX904_OUTPUT
Im Beispiel werden die Werte der TwinSAFE Klemme KL6904 zur KL2904 ausgewertet. In dieser Verbindung werden die Ausgangssignale zur KL2904 geschrieben und vom Baustein auf die angeschlossenen Variablen kopiert. Ist der Ausgang bConnectionInRun auf FALSE werden die Ausgänge auf FALSE gesetzt.
Zum Verknüpfen der Eingangsdaten markieren Sie den Parameter KL6904_SafetyQBx und wählen aus dem Kontext Menü "Verknüpfung ändern..."
Verknüpfen der Eingangsdaten
und wählen im folgenden Dialog die entsprechende SafetyQBx-Variable
Auswahl der entsprechenden SafetyQBx-Variable
Entwicklungsumgebung | Zielplattform | IO-Hardware | Einzubindende SPS-Bibliotheken
TwinCAT v2.10.0 Build > 914 | PC (i386) | KLx904 | TcTwinSAFE.Lib (Standard.Lib, TcBase.Lib und TcSystem.Lib werden automatisch eingebunden)
TwinCAT v2.10.0 Build > 914 | BX-Serie | KLx904 | TcTwinSAFE.LBX (Standard.LBX, TcBaseBX.LBX und TcSystemBX.LBX werden automatisch eingebunden)


Programmübertragung über die serielle Schnittstelle

Programmierung [image] Programmübertragung über die serielle Schnittstelle
Programmübertragung über die serielle Schnittstelle
Jeder Busklemmen-Controller kann über die RS232-Schnittstelle des PCs programmiert werden.
Wählen Sie im TwinCAT PLC Control die serielle Schnittstelle an.
Auswahl des Datenübertragungswegs - Serielle Schnittstelle
Unter Online/Kommunikationsparameter finden Sie im PLC Control die Einstellungen zur seriellen Schnittstelle, Portnummer, Baud-Rate usw.
Der Busklemmen Controller benötigt folgende Einstellung:
▪
Baud-Rate: 9600/19200/38400/57600 Baud (automatische Baudratenerkennung)
▪
Stop Bits: 1
▪
Parity: Gerade
plc seriell com port.gif
Parametrierung der seriellen Schnittstelle
Programmübertragung über die serielle Schnittstelle per ADS
Der Busklemmen-Controller kann über die RS232-Schnittstelle des PC programmiert werden. Bevor Sie damit arbeiten können muss der Busklemmen-Controller dem TwinCAT bekannt gemacht werden (siehe serielles ADS).
Wählen Sie im TwinCAT PLC-Control die ADS-Verbindung an.
plc choose target bx ads.gif
Auswahl des Datenübertragungswegs - AMS
Im PLC Control kann man sich unter Online/Communication Parameters... einwählen.
Auswahl des Gerätes


DeviceNet Kommunikation

DeviceNet Kommunikation
DeviceNet Kommunikation
Weiterführende Informationen
•
DeviceNet Einführung
•
Protokollbeschreibung
•
Objektverzeichnis
•
ADS-Kommunikation


DeviceNet Einführung

DeviceNet Kommunikation [image] DeviceNet Einführung
DeviceNet Einführung
DeviceNet
DeviceNet ist ein offenes System das auf der Basis von CAN aufsetzt. CAN wurde vor einigen Jahren von der Firma R. Bosch für die Datenübertragung in Kraftfahrzeugen entwickelt. Seitdem sind Millionen von CAN-Chips im Einsatz. Nachteilig für einen Einsatz in der Automatisierungstechnik ist, dass CAN keine Definitionen für die Applikationsschicht enthält. CAN definiert nur die physikalische und Datensicherungsschicht.
Mit DeviceNet ist eine einheitliche Applikationsschicht festgelegt, mit der das CAN-Protokoll für Industrieanwendungen nutzbar wird. Die ODVA (Open DeviceNet Vendor Association) unterstützt Hersteller und Anwender des Systems DeviceNet als unabhängiger Verein. Die ODVA stellt sicher, dass alle Geräte, die der Spezifikation entsprechen, herstellerneutral zusammen in einem System arbeiten.
Beispiel für eine Vernetzung mit DeviceNet
DeviceNet ist ein Sensor-/Aktorbussystem. Es ist international genormt (EN50325) und basiert auf CAN (Controller Area Net-work). DeviceNet unterstützt mehrere Kommunikationsarten für die Ein- und Ausgangsdaten:
▪
Polling: die Masterbaugruppe („Scanner") versendet die Ausgangsdaten zyklisch zu den zugeordneten Teilnehmern und erhält die Eingangsdaten im Antworttelegramm.
▪
Change-of-State: Telegramme werden versendet, sobald sich der Inhalt geändert hat.
▪
Cyclic: Die Baugruppen versenden die Daten nach Ablauf einer Zykluszeit selbstständig.
▪
Strobed: Der Scanner fordert die Eingangsdaten mit einem Broadcast-Telegramm an alle Teilnehmer an.
Die DeviceNet-Geräte unterstützen alle I/O-Kommunikationsarten.
Parametriert werden Device-Net-Geräte über azyklische Dienste (Explicit-Messaging).
Durch die effektive Nutzung der Busbandbreite erreicht DeviceNet vor allem im Change-of-State-Modus kurze Systemreaktionszeiten trotz der vergleichsweise niedrigen Datenraten. Die BECKHOFF DeviceNet-Geräte verfügen über eine leistungsfähige Protokollimplementierung. Durch aktive Mitarbeit in den technischen Gremien der ODVA trägt BECKHOFF zur weiteren Entwicklung dieses Bussystems bei und verfügt damit über profundes DeviceNet-Know-how.
Konfiguration
Die Knotenadresse wird mit zwei dezimal kodierten Drehwahlschaltern im Bereich von 0 bis 63 eingestellt. Die am DeviceNet-Scanner eingestellte Übertragungsrate wird von der DeviceNet-Box selbstständig erkannt (Auto-Baudrate). Für DeviceNet-Konfigurationstools stehen „elektronische Datenblätter" (EDS-Files) zum Download von der Beckhoff-Internetseite (http://www.beckhoff.de) sowie auf den BECKHOFF Produkt-CDs bereit. Spezielle I/O-Parameter, die nicht vom DeviceNet-Standard abgedeckt werden, können über die KS2000-Software (serielle Verbindung) oder über azyklische Explicit-Messages eingestellt werden.
Diagnose
Die umfangreichen Diagnosefunktionen der BECKHOFF DeviceNet-Geräte ermöglichen die schnelle Fehlerlokalisierung. Die Diagnosemeldungen werden über den Bus übertragen und beim Master zusammengefasst. Der Status der Netzwerkverbindung, der Gerätestatus, der Status der Ein- und Ausgänge sowie der Spannungsversorgung werden mit LEDs dargestellt.
Übertragungsraten
Drei Übertragungsraten von 125 kBaud bis 500 kBaud stehen für unterschiedliche Buslängen zur Verfügung. Durch die effektive Nutzung der Busbandbreite erreicht DeviceNet kurze Systemreaktionszeiten bei vergleichsweise niedrigen Datenraten.
Topologie
DeviceNet basiert auf einer linienförmigen Topologie. Die Anzahl der Teilnehmer pro Netz ist dabei von DeviceNet logisch auf 64 begrenzt, physikalisch erlaubt die aktuelle Treiber-Generation bis zu 64 Knoten in einem Netzsegment. Die bei einer bestimmten Datenrate maximal mögliche Netzausdehnung ist durch die auf dem Busmedium erforderliche Signallaufzeit begrenzt. Bei 500 kBaud ist z. B. eine Netzausdehnung von 100 m, bei 125 kBaud eine Netzausdehnung von 500 m möglich. Bei niedrigen Datenraten kann die Netzausdehnung durch den Einsatz von Repeatern erhöht werden, diese ermöglichen auch den Aufbau von Baumstrukturen.
Buszugriffsverfahren
CAN arbeitet nach dem Verfahren Carrier Sense Multiple Access (CSMA), d.h. jeder Teilnehmer ist bezüglich des Buszugriffs gleichberechtigt und kann auf den Bus zugreifen, sobald dieser frei ist (Multi-Master-Buszugriff). Der Nachrichtenaustausch ist dabei nicht Teilnehmerbezogen sondern Nachrichtenbezogen. Das bedeutet, dass jede Nachricht mit einem priorisierten Identifier eindeutig gekennzeichnet ist. Damit beim Verschicken der Nachrichten verschiedener Teilnehmer keine Kollisionen auf dem Bus entstehen, wird beim Start der Datenübertragung eine bitweise Busarbitrierung durchgeführt. Die Busarbitrierung vergibt die Busbandbreite an die Nachrichten in der Reihenfolge ihrer Priorität, am Ende der Arbitrierungsphase belegt jeweils nur ein Busteilnehmer den Bus, Kollisionen werden vermieden und die Bandbreite wird optimal genutzt.
Konfiguration und Parametrierung
Mit dem TwinCAT System Manager können alle DeviceNet Parameter komfortabel eingestellt werden. Für die Parametrierung der BECKHOFF DeviceNet-Geräte mit Konfigurationstools dritter Hersteller steht Ihnen auf der BECKHOFF Website (http://www.beckhoff.de) ein eds-File (electronic data sheet) zur Verfügung.


Protokollbeschreibung

DeviceNet Kommunikation [image] Protokollbeschreibung
Protokollbeschreibung
Weiterführende Informationen
•
Netzwerkmanagement


Netzwerkmanagement

DeviceNet Kommunikation [image] Protokollbeschreibung [image] Netzwerkmanagement
Netzwerkmanagement
In Vorbereitung


Objektverzeichnis

DeviceNet Kommunikation [image] Objektverzeichnis
Objektverzeichnis

In Vorbereitung


ADS-Kommunikation

DeviceNet Kommunikation [image] ADS-Kommunikation
ADS-Kommunikation
Weiterführende Informationen
•
ADS-Dienste


ADS-Dienste

DeviceNet Kommunikation [image] ADS-Kommunikation [image] ADS-Dienste
ADS-Dienste
Lokales Prozessabbild PLC Task 1 Port 800/801
Im lokalen Prozessabbild können Daten gelesen und geschrieben werden. Sollten Ausgänge geschrieben werden muss darauf geachtet werden, das diese von der lokalen SPS nicht verwendet werden, da die lokale Steuerung diese Werte überschreibt. Die Daten sind nicht an einen Watchdog gebunden und müssen und dürfen daher nicht für Ausgänge verwendet werden, die im Fehlerfall ausgeschaltet werden müssen.
Index Group | Bedeutung | Index Offset (Wertebereich)
0xF020 | Input - Eingänge | 0...2047
0xF021 | Input - Eingänge Bit | 0...16376
0xF030 | Output - Ausgänge | 0...2047
0xF031 | Output - Ausgänge Bit | 0...16376
0x4020 | Merker | 0...4095
0x4021 | Merker Bit | 0...32760
Dienste des ADS
AdsServerAdsState
Datentyp (only Read) | Bedeutung
String | Start - die lokale PLC läuft Stop - die lokale PLC ist im Stop
AdsServerDeviceState
Datentyp (only Read) | Bedeutung
INT | 0 - Start - die lokale PLC läuft 1 - Stop - die lokale PLC ist im Stop
AdsServerType
Datentyp (only Read) | Bedeutung
String | BX PLC Server
ADSWriteControl
Datentyp (write only) | Bedeutung
NetID | Net ID des Ethernet Controllers*
Port | 800
ADSSTATE | 5 - RUN / 6 - STOP
DEVSTATE | 0
LEN | 0
SRCADDR | 0
WRITE | positive Flanke startet den Baustein
TMOUT | zum Beispiel: t#1000 ms
* BC9050, BC9020, BC9120, BX9000
Registerzugriff Port 100
Die ADS-Portnummer ist bei den Busklemmen-Controllern der BX-Serie und den BCxx50/xx20 für die Register-Kommunikation fest vorgegeben und beträgt 100.
Index Group | Index Offset (Wertebereich) |  | Bedeutung
 | Hi-Word | Lo-Word
0 [READ ONLY] | 0...127 | 0...255 | Register des Buskopplers Hi-Word Tabellennummer des Buskopplers Lo-Word Registernummer der Tabelle
1...255 | 0...3 | 1...255 | Register der Busklemmen Hi-Word Kanalnummer Lo-Word Registernummer der Busklemme
Minimaler Time-Out
Beachten Sie beim Lesen der Register, dass der Time-Out beim ADS-Baustein auf eine Zeit größer eine Sekunde eingestellt wird.
Passwort setzen
Beachten Sie beim Schreiben auf die Register, dass das Passwort gesetzt wird (siehe Dokumentation zur entsprechenden Busklemme).


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose
•
Diagnose-LEDs
•
Diagnose-Display


Diagnose

Fehlerbehandlung und Diagose [image] Diagnose
Diagnose
Zustand des DeviceNet
In vielen Fällen ist es wichtig zu wissen, ob die Kommunikation mit dem übergeordneten Master noch funktioniert. Verknüpfen Sie hierfür die Variable NodeState mit Ihrem SPS-Programm. Hierfür ist eine TwinCAT-Konfiguration erforderlich.
DeviceNet Diagnose-Byte im System Manager
Fehler Nummer | Beschreibung | Abhilfe
0 | no error | keine
1 | Node is deactivated by the scanner, node is no longer in the masters scan-list. For Slave Devices it means that there is no Data-Exchange between the Master and the Slave. The Master has released the DeviceNet Slave | Überprüfen Sie die Konfiguration
2 | No data exchange between node and DeviceNet Master, node access timeout | Überprüfen Sie die Verbindung
18 | Node is configured, ready for data exchange | keine
42 | Electronic Key Error: Vendor Id | Überprüfen Sie die Identität des DeviceNet Slaves
43 | Electronic Key Error: Device Type | Überprüfen Sie die Identität des DeviceNet Slaves
44 | Electronic Key Error: Product Code | Überprüfen Sie die Identität des DeviceNet Slaves
45 | Electronic Key Error: Revision | Überprüfen Sie die Identität des DeviceNet Slaves
46 | Error writing start-up attributes | Überprüfen Sie die Identität des DeviceNet Slaves
47 | Wrongproduced IO-Data length | Überprüfen Sie die Identität des DeviceNet Slaves
48 | Wrong consumed IO-Data length | Überprüfen Sie die Identität des DeviceNet Slaves
49 | Idle Mode (for Slave Devices): no valid IO-Data is exchanged via DeviceNet | Überprüfen Sie ob der Master im Idle Mode ist
Auslesen des Feldbusstatus per ADS
In der Default-Konfiguration oder der TwinCAT Konfiguration können Sie den Feldbusstatus über ADSREAD auslesen.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_AE00
LEN | 1
Zustand des K-Buss
Sollte der interne Bus oder einer seiner Busklemmen ein Problem haben wird dies in der Variablen K-Bus-State angezeigt. Eine genauere Fehlerursache kann mit einem Funktionsbaustein ausgelesen werden (in Vorbereitung). Verknüpfen Sie hierfür die Variable K-Bus-State mit Ihrem SPS-Programm.
Zustand des K-Bus
Fehlerbit | Beschreibung | Fehlerart
0 | kein Fehler | kein Fehler
Bit 0 | K-Bus Fehler | Fehler
Bit 2 | K-Bus wird nachgetriggert | Hinweis
Auslesen des K-Bus-Status per ADS
In der Default-Konfiguration oder der TwinCAT Konfiguration können Sie den Feldbusstatus über ADSREAD auslesen.
Parameter ADSREAD Baustein | Beschreibung
NetID | lokal - Leerstring
Port | 1
IndexGroup | 16#0006
IndexOffset | 16#000C_9000
LEN | 1


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Zur Statusanzeige besitzt ein BX-Controller zwei Gruppen von LEDs:
▪
Auf der rechten oberen Seite des BX-Controllers befinden sich zwei grüne Power LEDs. Diese dienen zur Diagnose der Spannungsversorgung des BX-Controllers und der Powerkontakte.
▪
Die DIAG LEDs befinden sich über der linken Seite des Navigationsschalters. Sie zeigen den Zustand des Feldbusses, der PLC und des K-Busses an.
Diagnose LEDs für den Feldbus, die SPS, den K-Bus und die Spannungsversorgung
POWER LEDs zur Diagnose der Spannungsversorgung
Power LEDs | Bedeutung
Linke LED aus | BX-Controller hat keine Spannungsversorgung
Rechte LED aus | Powerkontakte haben keine Spannungsversorgung
DIAG LEDs
Die DIAG LEDs sind unterteilt in:
- Bus: Feldbusdignose
- PLC: SPS-Diagnose
- I/O: K-Bus-Diagnose
Die LEDs können die Zustände aus, grün, orange und rot annehmen.
Diagnose LEDs für den Feldbus, die SPS und den K-Bus
Nach dem Einschalten überprüft der BX-Controller sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der LED I/O signalisiert. Das rote Leuchten der I/O LED zeigt einen Fehler im Bereich der Busklemmen an. Die Fehlerart wird im Display angezeigt. Das ermöglicht eine schnelle Fehlerbeseitigung.
LEDs zur Diagnose des Feldbusses
LED Bus | Bedeutung
aus | kein Feldbus angeschlossen
leuchtet rot | kein Feldbus angeschlossen, DeviceNet 24V fehlen, DeviceNet Kommunikationsfehler falsche Baudrate, fehlerhafte Terminierung
blinkt rot | Kommunikationsfehler, IO Timeout Kommunikation zum DeviceNet Master unterbrochen
blinkt orange | Baudraten suche aktive, keine Baudrate gefunden
blinkt grün | Kommunikation zum Master noch nicht aufgebaut
leuchtet grün | DeviceNet Kommunikation aktiv
LED zur SPS-Diagnose
LED PLC | Bedeutung
aus | SPS im Stop oder kein Programm vorhanden
blinkt red | Die eingestellte Task-Zeit wird ab und zu überschritten (siehe auch Kapitel Deaktivieren der LED für Zykluszeit-Überschreitung).
leuchtet rot | Die eingestellte Task-Zeit wird immer überschritten.
leuchtet orange | PLC läuft ohne Bootprojekt (leuchtet nur während des Zyklus), beim Erzeugen des Bootprojektes blinkt die LED orange
leuchtet grün | Bootprojekt - PLC läuft (leuchtet nur während des Zyklus)
LED zur K-Bus Diagnose
LED I/O | Bedeutung
aus | über den K-Bus werden keine Daten ausgetauscht
leuchtet rot | Fehler Blinken - Fehlerart - Anzeige Display
leuchtet orange | Register- bzw. KS2000-Online-Zugriff
leuchtet grün | K-Bus ist in Ordnung und läuft
Fehlercode zur K-Bus-Diagnose
Fehler-Code
Fehlerargument
Beschreibung
Abhilfe
0
-
EMV Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV-Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Kopplers) der Fehler lokalisiert werden
1
0
EEPROM-Prüfsummenfehler
Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
1
Überlauf im Code Buffer
Weniger Busklemmen stecken. Die programmierte Konfiguration hat zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
Software Update des BX-Controllers notwendig
2
-
reserviert
-
3
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4
0
K-Bus-Datenfehler, Bruchstelle hinter dem BX-Controller
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n
Bruchstelle hinter Busklemme n
Kontrollieren ob die Busendklemme KL9010 gesteckt ist
5
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
n-te Busklemme tauschen
6
0
Fehler bei der Initialisierung
BX-Controller tauschen
1
Interner Datenfehler
Hardware-Reset des BX-Controllers (aus - und wieder einschalten)
2
DIP-Schalter nach einem Software-Reset verändert
Hardware-Reset des BX-Controllers (aus - und wieder einschalten)
7
0
Hinweis: Zykluszeit wurde überschritten
Warning: Die eingestellte Zykluszeit wurde überschritten. Dieser Hinweis (blinken der LEDs) kann nur durch erneutes booten des BX-Controllers gelöscht werden.
Abhilfe: Zykluszeit erhöhen
9
0
Checksummenfehler im Programm-Flash
Programm erneut zum BX übertragen
1
Falsche oder fehlerhaft Lib implementiert
Entfernen Sie die fehlerhaft Lib
10
n
Die Busklemme n stimmt nicht mit der Konfiguration, die beim Erstellen des Boot-Projektes existiert überein
Die n-te Busklemme überprüfen. Sollte eine n-te Busklemme gewollt eingefügt worden sein, muss das Bootprojekt gelöscht werden.
14
n
n-te Busklemme hat das falsche Format
BX-Controller erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15
n
Anzahl der Busklemmen stimmt nicht mehr
BX-Controller erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16
n
Länge der K-Bus-Daten stimmt nicht mehr
BX-Controller erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen


Diagnose-Display

Fehlerbehandlung und Diagose [image] Diagnose-Display
Diagnose-Display
Während des Hochstarten zeigt das Display für ca. drei Sekunden die aktuelle Firmware-Version an.
Sollte beim Starten ein Fehler vorliegen wird ihnen dieser per Blink-Sequenz der entsprechenden LED angezeigt.
Konfigurationsfehler werden im Display mit TC-Config und einer Fehlernummer angegeben. Bitte überprüfen Sie in diesem Fall Ihre Hardwarekonfiguration im System Manager oder setzen Sie sich mit dem Support in Verbindung.
Anzeige Display | Bedeutung
TC-Config 0xE02E | Eine komplexe Busklemme liegt auf einer Bitadresse. Überprüfen Sie die TwinCAT Konfiguration.
TC-Config 0xF0nn | Die nn' te Busklemme stimmt nicht mit der Konfiguration überein. Vergleichen Sie für die nn'te Busklemme den Busaufbau mit der Konfiguration.
TC-Config 0xC0nn | Die nn' te Busklemme stimmt nicht mit der Konfiguration überein. Vergleichen Sie für die nn'te Busklemme den Busaufbau mit der Konfiguration.
Firmware Fehler werden im Display mit FW-Error und einer Fehlernummer angegeben. Bitte setzen Sie sich mit dem Support in Verbindung.
Anzeige Display | Bedeutung
FW-Error 0xnnnn | Wenden Sie sich an den Support


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Firmware-Update
•
CFC-Client*
•
Beispielprogramme - Übersicht
•
Allgemeine Betriebsbedingungen
•
Zulassungen
•
Prüfnormen für Geräteprüfung
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Firmware-Update

Anhang [image] Firmware-Update
Firmware-Update
Firmware-Update-Programm
Um eine neue Firmware auf den Buskoppler zu laden, ist das Firmware Update Programm erforderlich. Das Programm wir über die serielle Schnittstelle übertragen.
Hinweis für BX3100:
Die Firmware 0.64 (oder kleiner) des BX3100 erlaubt kein Update. Sollte ein Update dieser Geräte erforderlich sein, schicken Sie den BX3100 mit dem Hinweis auf ein Update zum Hersteller.
Beckhoff Automation GmbH & Co. KG
Abt. Service
Stahlstr. 31
D-33415 Verl
Firmware Update Programm 241 ( ) 71 kByte (für Windows NT4.0 SP6, 2000, XP).
Das Programm FirmwareUpdate.exe und die TcRouterHelper.dll müssen im gleichen Verzeichnis stehen. Mit einem Doppelklick auf FirmwareUpdate.exe öffnen Sie das Programm.
Update für Busklemmen-Controller
BX-Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface (BX)".
fw update 1.gif
Auswahl des Busklemmen-Controllers der BX-Serie
BCxx50 Serie
Wählen sie das entsprechende Gerät aus - hier "Serial Interface".
fw update 5.gif
Auswahl des Busklemmen-Controllers der BC-Serie
BX- und BCxx50-Serie
Anschließen wählen Sie den COM-Port aus.
fw update 2.gif
Auswahl des COM-Ports
Öffnen Sie das entsprechende File, das Sie herunterladen möchten.
fw update 3.gif
Öffnen des Firmware-Files
Starten Sie den Download mit der grünen Ampel. Nach ca. einer Minute beginnt der Download, der dann auch im Display des BX angezeigt wird. Nach erfolgreichem Download (ca. 2 bis 3 Minuten) bootet der Busklemmen-Controller automatisch neu.
fw update 4.gif
Statusmeldungen des Firmware-Updates


CFC-Client*

Anhang [image] CFC-Client*
CFC-Client*
Der BX bietet mit den CFC-Client die Möglichkeit den gesamten Speicherinhalt eines BX-Controllers zu kopieren. Die Daten aus dem Speicher werden in einer BIN Datei gespeichert und können auf einen identischen Controller geladen werden.
Der CFC-Client läuft auf Windows 9x, NT, 2000 und XP und ist völlig unabhängig von TwinCAT.
CFC-Client ( ) (Hinweis: Die DLLs müssen Sie manuell per regsvr32 Registrieren)
Wenn Sie den CFC-Client starten stellen Sie als erstes die COM-Parameter ein.
CFC-Client
Port/Port Setup...
Aufruf des Port-Setups
Wählen Sie die Einstellung aus.
Einstellen der COM-Parameter
Bevor Sie den COM-Port öffnen müssen Sie eine physikalische Verbindung zum BX-Controller herstellen. Öffnen Sie dann den COM Port.
Öffnen des COM-Ports
Mit Upload erstellen Sie eine Kopie des BX-Speichers speichern diese als BIN-Datei.
Upload des BX-Speicherinhalts in ein BIN-File
Mit Download wird das BIN-File zum BX-Controller geladen. Der Controller startet automatisch nach erfolgreichem Download.
Download eines BIN-Files auf den BX-Controller
* ab Firmware 1.09 ist der CFC-Server auf der BX-Controller Reihe verfügbar


Beispielprogramme - Übersicht

Anhang [image] Beispielprogramme - Übersicht
Beispielprogramme - Übersicht
Benennung | Beschreibung
Display | Beispiel zum Ansteuern des Displays
Navigationsschalter | Auslesen des Navigationsschalter aus der PLC heraus
Menü | Beispiel für ein eignes Menü mit Navigations-Schalter und Display
RTC | Beispiel zum Auslesen der Real Time Clock (RTC) über Funktionsbausteine
COM Port - BK/BC8x00 Master Interface | COM1- oder COM2-Schittstelle als Master mit dem BK8x00 Protokoll
COM Port - BK8x00 Slave Interface | COM1- oder COM2-Schittstelle als Slave mit dem BK8x00 Protokoll
COM Port - Cimrex 12 | Beispiel zum Ansteuern eines Cimrex 12 Displays über ModbusRTU
COM Port - ModbusRTU Slave | Verknüpfung der ModbusRTU Lib mit der COM 1 oder COM 2 Schnittstelle des BXes
COM Port - ModbusRTU Master | Verknüpfung der ModbusRTU Lib mit der COM 1 oder COM 2 Schnittstelle des BXes
COM Port - RK512 Protokoll | RK512-Protokoll über die COM 1 oder COM 2
COM Port - SMS über COM Port | Anschluss eines Siemens S35 Mobiltelefons an COM-Schnittstelle zum Versenden von SMS-Nachrichten
COM Port - COMlibV2 | String verschicken und empfangen mit der COMlibV2
SSB - Display | Cimrex Panel am SSB
SSB - AX2000 | AX2000 am SSB
SSB - BK51x0 | BK5120 am SSB
SSB - BX / BX Kommunikation | Kommunikation von BX zu BX (über SSB)
SSB - IclA Drive | IclA Drive am SSB
SSB - Lenze Drive | Lenze Frequenzumrichter am SSB


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z. B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | Siehe Technische Daten
zulässige Umgebungstemperatur im Betrieb | -25°C ... +85°C
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27, EN 60068-2-29
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts.
Typenschild eines BX-Controllers
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Model BX
Versorgungsspannung Us | 24 VDC (Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!)
Hersteller | Beckhoff Automation GmbH
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, UL File Nummer: E172151
Produktionsbezeichnung | Serial No.: Seriennummer HW: Hardware Stand Date: Herstelldatum optional nur beim BX9000 MAC-ID


Zulassungen

Anhang [image] Zulassungen
Zulassungen
Konformitätskennzeichnung
CE
Schutzart
IP20 gemäß EN60529


Prüfnormen für Geräteprüfung

Anhang [image] Prüfnormen für Geräteprüfung
Prüfnormen für Geräteprüfung
EMV
EMV-Festigkeit
EN 61000-6-2
EMV-Aussendung
EN 61000-6-4
Vibrations-/ Schockfestigkeit
Vibrationsfestigkeit
EN 60068-2-6
Schockfestigkeit
EN 60068-2-27


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
Deutsche Bücher
Feldbustechnik allgemein
▪
Gerhard Gruhler (Hrsg.): Feldbusse und Geräte-Kommunikationssysteme, Praktisches Know-How mit Vergleichsmöglichkeiten. Franzis Verlag 2001. 244 Seiten. ISBN 3-7723-5745-8


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
CAN
Controller Area Network. In ISO 11898 standardisiertes serielles Bussystem, das als Basistechnologie für CANopen dient.
CiA
CAN in Automation e.V.. Internationaler Hersteller- und Nutzerverband mit Sitz in Erlangen/Deutschland.
COB
Communication Object. CAN-Telegramm mit bis zu 8 Datenbytes.
COB-ID
Communication Object Identifier. Telegrammadresse (nicht zu verwechseln mit Knotenadresse). CANopen verwendet die 11-Bit Identifier nach CAN 2.0A.
NMT
Network Management. Eines der Dienstelemente der CANopen-Spezifikation. Das Netzwerkmanagement dient zur Netzwerkinitialisierung und zur Knotenüberwachung.
PDO
Process Data Object oder Prozessdatenobjekt. CAN-Telegramm zur Übertragung von Prozessdaten (z. B. E/A-Daten).
RxPDO
Empfangs-PDO. PDOs werden immer aus Sicht des jeweiligen Gerätes bezeichnet. So wird ein TxPDO mit Eingangsdaten einer E/A Baugruppe zum RxPDO aus Sicht der Steuerung.
SDO
Service Data Object oder Servicedatenobjekt. CAN-Telegramm mit Protokoll zur Kommunikation mit Daten des Objektverzeichnisses (typisch Parameterdaten).
TxPDO
Sende-PDO (aus Sicht des CAN-Knotens bezeichnet).


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.