BK9500 - Buskoppler für USB
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC®und XTS® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH.
Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, DE102004044764, DE102007017835 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
Die TwinCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP0851348, US6167425 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizensiert durch die Beckhoff Automation GmbH, Deutschland
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Symbole
In der vorliegenden Dokumentation werden die folgenden Symbole mit einem nebenstehenden Sicherheitshinweis oder Hinweistext verwendet. Die Sicherheitshinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
GEFAHR
Akute Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
WARNUNG
Verletzungsgefahr!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
VORSICHT
Schädigung von Personen!
Wenn der Sicherheitshinweis neben diesem Symbol nicht beachtet wird, können Personen geschädigt werden!
Achtung
Schädigung von Umwelt oder Geräten
Wenn der Hinweis neben diesem Symbol nicht beachtet wird, können Umwelt oder Geräte geschädigt werden.
Hinweis
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Kommentar
2.0
▪
Migration
1.0
▪
erste Version
1.1
▪
Hinweise zum Trouble Shooting an TwinCAT Version 2.8 (Build 747) und Version 2.9 (Build 947) angepasst.
▪
Kapitel Montage und Verdrahtung aktualisiert


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
Technische Daten
•
Das Beckhoff Busklemmensystem
•
Das Prinzip der Busklemme
•
Feldbusübersicht
•
USB-Unterstützung durch Windows


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
BK9500
Technische Daten | BK9500
Anzahl der Busklemmen | 64
Digitale Peripheriesignale | 256 Ein-/Ausgänge
Analoge Peripheriesignale | 128 Ein-/Ausgänge
Konfigurationsmöglichkeit | über die Konfigurationssoftware KS2000 oder die Steuerung (TwinCAT)
maximale Byteanzahl | 512 Byte E und 512 Byte A
Busanschluss | 1 x B Type (Upstream), 3 x A Type (Downstream)
Spannungsversorgung | 24 VDC (-15%/+20%)
Eingangsstrom | 70 mA + (ges. K-Bus Strom)/4, 500 mA max.
Einschaltstrom | ca. 2,5 x Dauerstrom
Empf. Vorsicherung | ≤ 10 A
K-Bus-Stromversorgung bis | 1750 mA
Spannung Powerkontakt | max. 24 VDC
Stromlast Powerkontakt | max. 10 A
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Gewicht | ca. 170 g
Zulässige Umgebungstemperatur im Betrieb | 0°C ... +55°C
Zulässige Umgebungstemperatur bei Lagerung | -25°C ... +85°C
Zulässige relative Feuchte | 95% ohne Betauung
Vibrations- / Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit / Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, cULus, ATEX
Systemdaten | USB Universal Serial Bus (BK9500)
Anzahl der E/A-Module | maximal 127
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | 1 x 2 Twisted-Pair (28 AWG) Kupferkabel, 1 x 2 Spannungsversorgung
maximale Leitungslänge | 5 m von BK9500 zu BK9500, 30 m zwischen PC und letztem BK9500
Übertragungsrate | 12 MBaud
Topologie | Baumstruktur, maximale Tiefe 5


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Das Prinzip der Busklemme

Produktübersicht [image] Das Prinzip der Busklemme
Das Prinzip der Busklemme
Prinzip der Busklemme


Feldbusübersicht

Produktübersicht [image] Feldbusübersicht
Feldbusübersicht
Der USB entstand aus dem Bedarf heraus eine kostengünstige, moderne Lösung für den Anschluss von Peripheriekomponenten an den PC zu entwickeln.
Die wichtigsten Punkte des Konzeptes waren:
▪
Kostenreduzierung
▪
Anschluss und Konfiguration sollten so einfach wie möglich sein (Plug and Play)
▪
hinzufügen und entfernen von Geräten bei laufendem PC (Hot Plugging)
▪
viele technische Nachteile der vorhanden Lösungen z. B. RS232 sollten gelöst werden
▪
Anschluss ohne Öffnen des PC
USB ist ein Polled-Bus, d.h. alle Aktionen gehen vom Host, in den meisten Fällen ein PC, aus.
usb typ application.gif
USB-Topologie
Grundlagen
Geschwindigkeit
USB unterstütz in der Version 1.1 zwei Geschwindigkeiten:
▪
1,5 MBit/s (Low-Speed)
▪
12 MBit/s (Full-Speed)
Der BK9500 unterstütz 12 MBit/s.
Architektur
Die Kabellänge von USB-Gerät zu USB-Gerät darf maximal 5 Meter betragen. Es können maximal 127 Geräte in einer Baumstruktur angesteckt werden. Die Verteilung erfolgt über Hubs. Bei Kaskadierung von Hubs darf eine Verschachtelungstiefe von 5 nicht überschritten werden. Dadurch ergibt sich eine maximale Entfernung des letzten Gerätes vom HOST von 25 Metern!
Oft integriert ein Hub auch eine Funktion. Eine Tastatur (KBD) zum Beispiel, empfängt die Daten vom PC (Host) und gibt sie weiter an angeschlossen Peripheriegeräte wie Maus, Drucker usw.
USB-Architektur
Transferarten
Man unterscheidet vier Transferarten.
Control-Transfer
Spezielle Anfragen, Requests, werden, typischerweise während der Konfigurationsphase, an das USB-Gerät gesendet.
Interrupt-Transfer
Die Transferart für Geräte im PC-Umfeld die klassischerweise über Interrupt betrieben wurden, z. B. die Tastatur. Es wird allerdings kein Interrupt belegt.
Bulk-Transfer
Typisches Beispiel hierfür sind Drucker, also Daten die in großer Menge ohne Echtzeitanforderungen übertragen werden müssen.
Isochronous-Transfer
Daten mit Anforderungen an die Latenzzeit werden mit diesem Transfer bedient. Hier wird mit hohen Kontinuität und zeitlicher Synchronität gearbeitet.
Hinweis
Weitere Informationen
Detaillierte Informationen zum USB erhalten Sie von der USB Organisation unter http://www.usb.org.


USB-Unterstützung durch Windows

Produktübersicht [image] USB-Unterstützung durch Windows
USB-Unterstützung durch Windows
Der Universal Serial Bus (USB) wird nicht von allen Windows-Versionen unterstützt.
Stellen Sie folgendermaßen fest, welche Windows-Version Sie verwenden:
1.
Klicken Sie im Start-Menü auf Einstellungen/Systemsteuerung
2.
Doppelklicken Sie auf das Symbol System
3.
Klicken Sie auf das Register Allgemein
4.
Unter System finden Sie die Bezeichnung des Betriebssystems und die Versions-Nr.
Betriebssystem | Version | Versions-Nr. | USB-Unterstützung
Windows 95 | Vollversion | 4.00.950 | nein*
 | Vollversion SP1 | 4.00.950A | nein*
 | OEM Service Release 1 | 4.00.950A | nein*
 | OEM Service Release 2 | 4.00.1111 (4.00.950B) | nein*
 | OEM Service Release 2.1 | 4.03.1212-1214 (4.00.950B) | ja
 | OEM Service Release 2.5 | 4.03.1214 (4.00.950C) | ja
Windows 98 | Retail | 4.10.1998 | ja
 | OEM | 4.10.1998 | ja
 | Second Edition (SE) | 4.10.2222A | ja
Windows ME | alle | z. B. 4.90.3000 | ja
Windows NT 4.0 | alle | z. B. 4.00.1381 | nein**
Windows 2000 | alle | z. B. 5.00.2195 | ja
Windows XP | alle | 2002 | ja
Windows Vista | alle | z. B. 6.0 | ja
Windows 7 | alle | z. B. 6.1 | ja
Windows 8 | alle | z. B. 6.2 | ja
Windows 8.1 | alle | z. B. 6.3 | ja
Windows 10 | alle | z. B. 10 | ja
*) Falls Sie eine Version von Windows 95 ohne USB-Unterstützung haben, die USB-Unterstützung jedoch wünschen, empfiehlt Microsoft, dass Sie auf Windows 98 Second Edition aktualisieren.
**) Windows NT 4.0 unterstützt kein USB. Laut Microsoft ist kein Service Pack zur USB-Unterstützung durch Windows NT 4.0 geplant.
Hinweis
Weitere Informationen zur USB-Unterstützung
Detaillierte Informationen zur USB-Unterstützung ihrer Windows-Version finden Sie bei Microsoft. Zu verschiedenen Windows-Versionen finden Sie dort auch Updates, um die USB-Unterstützung zu verbessern.


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Mechanischer Einbau
•
Verdrahtung und Verkabelung


Mechanischer Einbau

Montage und Verdrahtung [image] Mechanischer Einbau
Mechanischer Einbau
Weiterführende Informationen
•
Abmessungen
•
Montage
•
Tragschienenmontage
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)


Abmessungen

Montage und Verdrahtung [image] Mechanischer Einbau [image] Abmessungen
Abmessungen
Das System der Beckhoff-Busklemmen zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
Abmessungen
Die Gesamtbreite der Anwendung setzt sich aus der Breite des Buskopplers, der Busendklemme KL9010 und der Breite der verwendeten Busklemmen zusammen. Die Busklemmen sind je nach Funktion 12 mm oder 24 mm breit. Die lichte Höhe von 68 mm wird durch die Frontverdrahtung in Abhängigkeit von der Drahtstärke um ca. 5 mm bis 10 mm überbaut.


Montage

Montage und Verdrahtung [image] Mechanischer Einbau [image] Montage
Montage
Der Buskoppler und alle Busklemmen können durch leichten Druck auf eine 35 mm Tragschiene aufgerastet werden. Die einzelnen Gehäuse können durch einen Verriegelungsmechanismus nicht mehr abgezogen werden. Zum Entfernen von der Tragschiene entsichert die orangefarbene Zuglasche den Rastmechanismus und ermöglicht ein kraftloses Abziehen der Gehäuse.
Entsichern der Verriegelung durch die orangefarbene Zuglasche
An den Buskoppler können auf der rechten Seite bis zu 64 Busklemmen angereiht werden. Beim Zusammenstecken der Komponenten ist darauf zu achten, dass die Gehäuse mit Nut und Feder aneinander gesetzt zu montieren sind. Durch das Zusammenschieben der Gehäuse auf der Tragschiene kann keine funktionsfähige Verbindung hergestellt werden. Bei richtiger Montage ist kein nennenswerter Spalt zwischen den angereihten Gehäusen zu sehen.
Nut und Feder der Gehäuse
Achtung
Busklemmen nur im abgeschalteten Zustand ziehen oder stecken!
Das Ziehen und Stecken von Busklemmen aus dem Verbund ist nur im abgeschalteten Zustand zulässig. Die Elektronik der Busklemmen und des Buskopplers ist weitestgehend vor Zerstörungen geschützt, Fehlfunktionen und Schädigungen können beim Zusammenstecken unter Spannung jedoch nicht ausgeschlossen werden.


Tragschienenmontage

Montage und Verdrahtung [image] Mechanischer Einbau [image] Tragschienenmontage
Tragschienenmontage
WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Achten Sie bei der Montage der Busklemmen darauf, dass der Verriegelungsmechanismus der Klemmen nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät.
Demontage
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie vorsichtig die orangefarbige Lasche ca. 1 cm aus der zu demontierenden Klemme heraus, bis die Lasche locker hervorsteht. Jetzt ist für diese Klemme die Verriegelung mit der Tragschiene gelöst und die Klemme kann ohne großen Kraftaufwand von der Tragschiene gezogen werden.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen Sie die Klemme von der Tragschiene weg.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler.
Hinweis
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z. B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Achtung
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!
Verdrahtung
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Hinweis
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] Mechanischer Einbau [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


Verdrahtung und Verkabelung

Montage und Verdrahtung [image] Verdrahtung und Verkabelung
Verdrahtung und Verkabelung
Weiterführende Informationen
•
Spannungsversorgung
•
Potentialgruppen, Isolationsprüfung und PE
•
USB-Anschluss


Spannungsversorgung

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Spannungsversorgung
Spannungsversorgung
Versorgung von Buskoppler / Busklemmen-Controller und Busklemmen (Us)
Weiterführende Informationen
•
BKxx00, BKxx10, BKxx20 and LCxxxx
•
BKxx50 und BKxx51
•
Konfigurations- und Programmierschnittstelle
•
Potentialtrennung
•
Powerkontakte


BKxx00, BKxx10, BKxx20 and LCxxxx

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Spannungsversorgung [image] BKxx00, BKxx10, BKxx20 and LCxxxx
BKxx00, BKxx10, BKxx20 and LCxxxx
Die Buskoppler / Busklemmen-Controller benötigen zum Betrieb eine Gleichspannung von 24 VDC.
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Anschlüsse zur Spannungsversorgung von BKxx00, BKxx10, BKxx20 und LCxxxx


BKxx50 und BKxx51

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Spannungsversorgung [image] BKxx50 und BKxx51
BKxx50 und BKxx51
Die Buskoppler / Busklemmen-Controller benötigen zum Betrieb eine Gleichspannung von 24 VDC. Benutzen Sie eine 4 A Sicherung oder eine der Class 2 entsprechende Spannungsversorgung um die UL-Anforderungen zu erfüllen!
Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung Us und GNDs statt. Diese Versorgungsspannung versorgt die Elektronik der Buskoppler / Busklemmen-Controller sowie über den K-Bus die Elektronik der Busklemmen. Sie ist galvanisch von der Spannung der Feldebene getrennt.
Anschlüsse zur Spannungsversorgung von BKxx50 und BKxx51
UL-Kennzeichnung
GEFAHR
Beachten Sie die UL-Anforderungen für die Spannungsversorgung!
Zur Einhaltung der UL-Anforderungen darf Us nur versorgt werden, mit einer 24 VDC Versorgungsspannung, die
•
von einer isolierten, mit einer Sicherung (entsprechend UL248) von maximal 4 A geschützten Quelle, oder
•
von einer Spannungsquelle die NEC class 2 entspricht stammt.
Eine Spannungsquelle entsprechend NEC class 2 darf nicht seriell oder parallel mit einer anderen NEC class 2 entsprechenden Spannungsquelle verbunden werden!
GEFAHR
Keine unbegrenzten Spannungsquellen!
Zur Einhaltung der UL-Anforderungen darf Us nicht mit unbegrenzten Spannungsquellen verbunden werden!


Konfigurations- und Programmierschnittstelle

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Spannungsversorgung [image] Konfigurations- und Programmierschnittstelle
Konfigurations- und Programmierschnittstelle
Auf der unteren Seite der Frontfläche sind die Standardbuskoppler mit einer RS232-Schnittstelle ausgerüstet. Der Miniaturstecker kann über ein Verbindungskabel mit einem PC und der Konfigurationssoftware KS2000 verbunden werden. Die Schnittstelle erlaubt das Konfigurieren der Busklemmen, wie zum Beispiel das Einstellen des Verstärkungsfaktors der analogen Kanäle. Über die Schnittstelle kann auch die Zuordnungen der Busklemmen- Daten zum Prozessabbild im Buskoppler verändert werden. Die Funktionalität der Konfigurationsschnittstelle ist auch über den Feldbus mit der String-Kommunikation zu erreichen.


Potentialtrennung

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Spannungsversorgung [image] Potentialtrennung
Potentialtrennung
Die Buskoppler / Busklemmen-Controller arbeiten mit drei unabhängigen Potentialgruppen. Die Versorgungsspannung speist die K-Bus-Elektronik und den K-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbus-Interfaces erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum K-Bus. Der K-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialschaltbild eines EKxxxx


Powerkontakte

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Spannungsversorgung [image] Powerkontakte
Powerkontakte
Speisung Powerkontakte (Up)
Die unteren sechs Anschlüsse mit Federkraft-Klemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler / Busklemmen-Controller.
Die Federkraftklemmen sind für Drähte von 0,08 mm² bis 2,5 mm² Querschnitt ausgelegt.
Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschliefen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakt darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Buskoppler / Busklemmen-Controller befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um einen Berührungsschutz sicher zu stellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut-/ Federführung an der Ober- und Unterseite der Buskoppler / Busklemmen-Controller und Busklemmen ermöglicht eine sichere Führung der Powerkontakte.


Potentialgruppen, Isolationsprüfung und PE

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen, Isolationsprüfung und PE
Potentialgruppen
Ein Beckhoff Busklemmenblock verfügen in der Regel über drei verschiedene Potentialgruppen:
▪
Die Feldbusschnittstelle ist (außer bei einzelnen Low Cost Kopplern) galvanisch getrennt und bildet die erste Potentialgruppe.
▪
Buskoppler- / Busklemmen-Controller-Logik, K-Bus und Klemmenlogik bilden eine zweite galvanisch getrennte Potentialgruppe.
▪
Die Ein- und Ausgänge werden über die Powerkontakte gespeist und bilden weitere Potentialgruppen.
Gruppen von E/A-Klemmen lassen sich durch Potentialeinspeiseklemmen oder Trennklemmen zu weiteren Potentialgruppen zusammenfassen.
Potentialgruppen eines Busklemmenblocks
Isolationsprüfung
Die Verbindung zwischen Buskoppler- / Busklemmen-Controller und Busklemmen wird durch das Zusammenstecken der Komponenten automatisch realisiert. Die Übertragung der Daten und die Versorgungsspannung der intelligenten Elektronik der Busklemmen übernimmt der K-Bus. Die Versorgung der Feldelektronik wird über die Powerkontakte durchgeführt. Die Powerkontakte stellen durch das Zusammenstecken eine Versorgungsschiene dar. Da einige Busklemmen (z. B. analoge Busklemmen oder digitale Vierkanal-Busklemmen) diese Powerkontakte nicht oder nicht vollständig durchschleifen, sind die Kontaktbelegungen der Busklemmen zu beachten.
Die Einspeiseklemmen unterbrechen die Powerkontakte und stellen den Anfang einer neuen Versorgungsschiene dar. Der Buskoppler- / Busklemmen-Controller kann auch zur Einspeisung der Powerkontakte eingesetzt werden.
PE-Powerkontakte
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Linksseitiger Powerkontakt
Es ist zu beachten, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann zu falschen Ergebnissen und auch zur Beschädigung der Klemme bei der Isolationsprüfung führen (z. B. Isolationsdurchschlag an einem 230 V-Verbraucher zur PE-Leitung). Die PE-Zuleitung am Buskoppler- / Busklemmen-Controller muss zur Isolationsprüfung abgeklemmt werden. Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können die Einspeiseklemmen aus dem Verbund der übrigen Klemmen mindestens 10 mm herausgezogen werden. Die PE-Zuleitungen müssen in diesem Fall nicht abgeklemmt werden.
Der Powerkontakt mit der Bezeichnung PE darf nicht für andere Potentiale verwendet werden.


USB-Anschluss

Montage und Verdrahtung [image] Verdrahtung und Verkabelung [image] USB-Anschluss
USB-Anschluss
Der Anschluss erfolgt über ein handelsübliches USB-Kabel. Verlängerungen sind nicht zulässig.
bk9500 typical molded cable
USB-Kabel
Verkabelung
USB-Ports des BK9500
Der BK9500 verfügt über einen Upstream-Port (Typ B) zum Anschluss an den PC und drei Downstream-Ports (Typ A) für weitere USB Geräte.
bk9500 connector typ b.jpg
Upstream Port (Typ B)
bk9500 connector typ a.jpg
Downstream Port (Typ A)
Belegung der USB-Ports
PIN | Signal | Beschreibung
1 | VBUS | Rot/Red
2 | D - | Weis/White
3 | D + | Grün/Green
4 | GND | Schwarz/Black
Gehäuse | Schirm | Schirm


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Buskopplers
•
Prozessdaten und Prozessabbild
•
Lokales Prozessabbild
•
Adresseinstellung
•
Konfiguration mit dem TwinCAT System Manager
•
Konfiguration mit KS2000


Anlaufverhalten des Buskopplers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Buskopplers
Anlaufverhalten des Buskopplers
Nach dem Einschalten überprüft der Buskoppler in einem Selbsttest alle Funktionen seiner Bauteile und die Kommunikation des K-Busses/E-Busses. Während dieser Phase blinkt die rote I/O-LED. Nach dem erfolgreichen Selbsttest beginnt der Buskoppler die angesteckten Busklemmen in einem Busklemmentest zu testen und liest die Konfiguration ein. Aus der Konfiguration der Busklemmen entsteht eine interne, von außen nicht zugängliche, Aufbauliste. Für den Fall eines Fehlers geht der Buskoppler in den Betriebszustand Stop. Nach dem fehlerfreien Hochlauf geht der Buskoppler in den Zustand Feldbusstart.
Anlaufverhalten des Buskopplers
Der Buskoppler kann nach der Fehlerbeseitigung nur durch erneutes Einschalten in den normalen Betriebszustand gebracht werden.


Prozessdaten und Prozessabbild

Parametrierung und Inbetriebnahme [image] Prozessdaten und Prozessabbild
Prozessdaten und Prozessabbild
Der Buskoppler ermittelt nach dem Einschalten automatisch die Konfiguration der gesteckten Ein-/Ausgangsklemmen. Die Zuordnung zwischen den physikalischen Steckplätzen der Ein-/Ausgangskanäle und den Adressen des Prozessabbildes wird vom Buskoppler automatisch durchgeführt.
Der Buskoppler erstellt eine interne Zuordnungsliste in der die Ein-/Ausgangskanäle eine bestimmte Position im Prozessabbild des Buskopplers besitzen. Unterschieden wird hier nach Ein- und Ausgängen und nach bitweise orientierter (digitale) und byteweise orientierter (analoge, bzw. komplexe) Signalverarbeitung.
Es werden zwei Gruppen mit jeweils nur Ein- und nur Ausgängen gebildet. In einer Gruppe befinden sich unter der niedrigsten Adresse die byteorientierten Kanäle in aufsteigender Reihenfolge und daran anschließend die bitorientierten Kanäle.
Digitale Signale (bitorientiert)
Die digitalen (binären) Signale sind bitorientiert. Das heißt, jedem Kanal ist ein Bit im Prozessabbild zugeordnet. Der Buskoppler erstellt einen Speicherbereich mit den aktuellen Eingangsbits und sorgt nach dem Updatebefehl für das sofortige Herausschreiben der Bits eines zweiten (Ausgangs-) Speicherbereiches, der für die Ausgangskanäle zuständig ist. Die exakte Zuordnung der Ein- und Ausgangskanäle zum Prozessabbild der Steuerung wird im Anhang in einem Beispiel ausführlich erläutert.
Analoge Signale (byteorientiert)
Die Verarbeitung der analogen Signale ist grundsätzlich byteorientiert. Die analogen Ein- und Ausgangswerte werden in einer Zweibytedarstellung im Speicher abgelegt. Die Werte werden in SIGNED INTEGER dargestellt. Der Zahlenwert 0 steht für den Ein-/Ausgangswert 0 V, 0 mA oder 4 mA. Der Maximalwert des Ein-/Ausgangswertes wird in der Standardeinstellung durch 0x7FFF wiedergegeben. Die Zwischenwerte sind entsprechend proportional zueinander. Der Bereich mit einer Auflösung von 15 Bit wird nicht mit jeder Ein- oder Ausgangsstufe realisiert. Bei einer tatsächlichen Auflösung von 12 Bit sind die letzten 3 Bit für Ausgänge ohne Wirkung und für Eingänge werden sie 0 gelesen. Des weiteren besitzt jeder Kanal ein Kontroll- und Statusbyte. Das Control- und Statusbyte ist das höchstwertige Byte im höherwertigen Wort. Ein analoger Kanal wird mit 4 Byte im Prozessabbild dargestellt, von denen 3 Byte benutzt werden. Im BK3000 und BK4000 werden nur 2 Byte pro analogen Kanal im Prozessabbild des entsprechenden Bussystems belegt. Durch Konfiguration von Buskoppler und Busklemmen können Sie auch die Control- und Statusbytes der Busklemmen einblenden.
Sondersignale und Schnittstelle
Der Buskoppler unterstützt Busklemmen mit weiteren Schnittstellen, wie RS232, RS485, Inkremental-Encoder oder andere. Diese Signale können wie die oben genannten analogen Signale betrachtet werden. Teilweise ist für die Sondersignale eine Bitbreite von 16 nicht ausreichend. Der Buskoppler kann jede Bytebreite unterstützen. Bei den Zugriffen auf diese Werte beachten Sie bitte die Sicherstellung der Datenkonsistenz. Das heißt, zwischen den Zugriffen keinen Updatebefehl absetzen, und den Buskoppler nicht in die Betriebsart Freilaufend schalten.
Defaultzuordnung der Ein-/Ausgänge zum Prozessabbild
Nach dem Einschalten ermittelt der Buskoppler den Umfang der angesteckten Busklemmen und erstellt eine Zuordnungsliste. In dieser Liste werden die analogen und digitalen Kanäle, zwischen Ein- und Ausgängen unterschieden, voneinander getrennt zusammengestellt. Die Zuordnung beginnt links neben dem Buskoppler. Die Software im Buskoppler sammelt die Einträge der einzelnen Kanäle zur Erstellung der Zuordnungsliste von links nach rechts zählend nacheinander ein. Die Zuordnung unterscheidet vier Gruppen:
Gruppe | Funktionstyp des Kanals | Zuordnung
1 | Analoge Ausgänge | byteweise
2 | Digitale Ausgänge | bitweise
3 | Analoge Eingänge | byteweise
4 | Digitale Eingänge | bitweise
Analoge Ein/Ausgänge stehen stellvertretend für alle komplexen Busklemmen.
Überblick über die Aufteilung des Prozessabbildes im Buskoppler
Ausgangsdaten im Buskoppler
Ausgangsdaten im Buskoppler
Eingangsdaten im Buskoppler
Eingangsdaten im Buskoppler
Datenkonsistenz
Daten bezeichnet man als konsistent, wenn sie inhaltlich zusammengehören und auch als ein zusammenhängender Block übertragen werden. Inhaltlich gehören zusammen:
▪
das High- und das Low-Byte eines Analogwertes (Wortkonsistenz)
▪
Kontroll/Statusbyte und das dazugehörige Parameterwort für den Zugriff auf die Register
Die Datenkonsistenz ist im Zusammenspiel von Peripherie und Steuerung grundsätzlich zunächst nur für ein Byte sichergestellt. Das heißt, die Bits eines Bytes werden zusammen eingelesen oder werden zusammen ausgegeben. Für die Übertragung digitaler (binärer) Signale ist eine byteweise Konsistenz ausreichend.
Zur Übertragung von Prozessdaten mit einer Länge über 8 Bit (z. B. Analogwerte) muss die Konsistenz, unter Beachtung der feldbusspezifischen Eigenschaften zur Datenkonsistenz, entsprechend ausgeweitet werden. Der TwinCAT-Treiber zur Prozessdatenübertragung über den USB tauscht immer das gesamte Prozessabbild des BK9500 aus, so dass der BK9500 die Datenkonsistenz bei nicht freilaufendem K-Bus-Zyklus gewährleisten kann.


Lokales Prozessabbild

Parametrierung und Inbetriebnahme [image] Lokales Prozessabbild
Lokales Prozessabbild
Alle angeschlossenen Busklemmen werden in der Default-Einstellung dem lokalen Prozessabbild zugewiesen. Das Mapping im Busklemmen Koppler erfolgt nach folgender Gesetzmäßigkeit:
Erst alle Byte-orientierten (analogen) Busklemmen, in der Reihenfolge wie diese gesteckt sind, und dann die Bit-orientierten (digitalen) Busklemmen, die zu einem Byte aufgefüllt werden.
Beispiel
Der BK9500 ist über den USB an einen PC angebunden. Die Adresse des Kopplers wurde auf 1 gesetzt. An dem Koppler wurden die folgenden Klemmen angereiht (die Anzahl der gemappten Bits ist in Klammern angegeben):
Position | Klemme auf der Schiene
POS00 | BK9500
POS01 | KL1002 (2 Eingangsbits)
POS02 | KL1002 (2 Eingangsbits)
POS03 | KL1002 (2 Eingangsbits)
POS04 | KL1114 (4 Eingangsbits)
POS05 | Kl1114 (4 Eingangsbits)
POS06 | KL3002 (2 x 16 Eingangsbits)
POS07 | KL9200 (-)
POS08 | KL2012 (2 Ausgangsbits)
POS09 | KL2012 (2 Ausgangsbits)
POS10 | KL2012 (2 Ausgangsbits)
POS11 | KL2012 (2 Ausgangsbits)
POS12 | KL4002 (2 x 16 Ausgangsbits)
POS13 | KL9010 (-)
Demzufolge stellt sich das Prozessabbild des Buskopplers folgendermaßen dar:
Prozessabbild der Eingänge (Inputs)
Relative Byte Adresse des Koppler / Inputs | Bit Position | Position in der Station | Busklemme
0, 1 | - | POS06 | KL3002, Kanal 1
2, 3 | - | POS06 | KL3002, Kanal 2
4 | 0 | POS01 | KL1002, Kanal 1
4 | 1 | POS01 | KL1002, Kanal 2
4 | 2 | POS02 | KL1002, Kanal 1
4 | 3 | POS02 | KL1002, Kanal 2
4 | 4 | POS03 | KL1002, Kanal 1
4 | 5 | POS03 | KL1002, Kanal 2
4 | 6 | POS04 | KL1114, Kanal 1
4 | 7 | POS04 | KL1114, Kanal 2
5 | 0 | POS04 | KL1114, Kanal 3
5 | 1 | POS04 | KL1114, Kanal 4
5 | 2 | POS05 | KL1114, Kanal 1
5 | 3 | POS05 | KL1114, Kanal 2
5 | 4 | POS05 | KL1114, Kanal 3
5 | 5 | POS05 | KL1114, Kanal 4
Prozessabbild der Ausgänge (Outputs)
Relative Byte Adresse des Koppler / Outputs | Bit Position | Position in der Station | Busklemme
0, 1 | - | POS12 | KL4002, Kanal 1
2, 3 | - | POS12 | KL4002, Kanal 2
4 | 0 | POS08 | KL2012, Kanal 1
4 | 1 | POS08 | KL2012, Kanal 2
4 | 2 | POS09 | KL2012, Kanal 1
4 | 3 | POS09 | KL2012, Kanal 2
4 | 4 | POS10 | KL2012, Kanal 1
4 | 5 | POS10 | KL2012, Kanal 2
4 | 6 | POS11 | KL2012, Kanal 1
4 | 7 | POS11 | KL2012, Kanal 2


Adresseinstellung

Parametrierung und Inbetriebnahme [image] Adresseinstellung
Adresseinstellung
Obwohl der USB von sich aus keine Adresseinstellung im herkömmlichen Sinne benötigt, wurde ein Adressschalter integriert. Hierdurch ist eine Unterscheidung mehrerer Buskoppler in einem USB-Netzwerk möglich.
Die Einstellung der Adresse erfolgt über den DIP-Schalter. Es sind Adressen von 0 bis 127 zulässig.
DIP-Schalter
Wertigkeit der Adresse - Beispiel
DIP-Schalter
Schalter-Nr. | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 |
Wertigkeit | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 |
Dezimal | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128 |
Im Beispiel | ON | ON | OFF | OFF | OFF | ON | OFF | OFF |
Beispielwert | 1 | 2 | 0 | 0 | 0 | 32 | 0 | 0 | Summe=35
Adresse im TwinCAT System Manager
Adresse im TwinCAT System Manager
Tragen Sie im TwinCAT System Manager für jeden USB-Koppler die mittels DIP-Schalter eingestellte Adresse ein. Bei automatischer Gerätesuche ermittelt der TwinCAT System Manager die eingestellten Adressen aller angeschlossenen USB-Koppler automatisch.


Konfiguration mit dem TwinCAT System Manager

Parametrierung und Inbetriebnahme [image] Konfiguration mit dem TwinCAT System Manager
Konfiguration mit dem TwinCAT System Manager
Fügen Sie im TwinCAT System Manager unter E/A-Geräte eine virtuelle USB-Schnittstelle ein. Sollten bereits Buskoppler am USB-Netzwerk angeschlossen sein, kann der System Manager diese auch automatisch einlesen. Dabei wird die Konfiguration aller angeschlossenen Buskoppler und Busklemmen geladen. Anschließend können Sie diese Konfiguration dann im System Manager nach Ihren Bedürfnissen anpassen.
bk9500 twincat configuration
Virtuelle USB-Schnittstelle einfügen
TwinCAT System stoppen
Hinweis
Ältere TwinCAT-Versionen
Bei älteren TwinCAT-Versionen (siehe Kapitel Trouble shooting), muss zum automatischen Einlesen der angeschlossenen USB-Koppler das TwinCAT-System gestoppt sein!
Stoppen des TwinCAT-Systems
Hinweis
Anzeige von Control- und Status-Bytes des angesteckten Klemmen
Der USB-Koppler BK9500 unterstützt für Klemmen,
•
die sonst wahlweise mit kompaktem oder komplettem Prozessabbild betrieben werden können, nur das kompakte Prozessabbild. Das bedeutet, der BK9500 zeigt Control- und Status-Bytes dieser Klemmen im Prozessabbild nicht an.
•
die zum Betrieb das komplette Prozessabbild benötigen, dieses selbstverständlich. Das bedeutet, der BK9500 zeigt Control- und Status-Bytes dieser Klemmen im Prozessabbild an.


Konfiguration mit KS2000

Parametrierung und Inbetriebnahme [image] Konfiguration mit KS2000
Konfiguration mit KS2000
Die Einstellung der Buskoppler-Parameter ist ebenfalls über die Konfigurations-Software KS2000 möglich.
Hinweis
Kein gleichzeitiger Zugriff auf den USB-Koppler
Sie können nicht gleichzeitige über USB und die serielle Konfigurationsschnittstelle auf den USB-Koppler zugreifen. Beenden Sie die zyklische Datenübertragung auf dem USB, bevor Sie mit der Konfigurations-Software KS2000 über die serielle Schnittstelle auf den Buskoppler zugreifen.
Darstellung des BK9500 in KS2000
Konfiguration des BK9500 in KS2000
Auto-Konfiguration
Der USB-Koppler ordnet beim Start den angehängten Klemmen eine Adresse in seinem Ein- und Ausgangs-Prozessabbild zu.
Auswertung komplexe Klemmen
Mit dem Beckhoff Busklemmen System stehen eine Vielzahl von unterschiedlichen Busklemmen zur Versorgung von Sensoren und Aktuatoren zur Verfügung.
Es wird generell zwischen digitalen und komplexen Busklemmen unterschieden. Zu den komplexen Klemmen zählen alle Klemmen die Byte-Informationen mit dem Buskoppler austauschen (z. B. analoge Klemmen, Kommunikationsklemmen oder Inkremental-Encoder-Klemmen).
Bei Auswahl der Option Auswertung komplexe Klemmen, werden die Busklemmen dieser Station komplett ausgewertet, d.h. es werden alle Daten der angeschlossenen Klemmen in das Prozessabbild des USB-Kopplers übertragen. Bei den Analog-Klemmen (z. B. KL3002) bedeutet dies, das Control- und Status-Byte mit übertragen werden, und die Klemme Eingangs- und Ausgangsdaten mit dem Buskoppler austauscht.
Die technischen Dokumentationen der jeweiligen Busklemmen geben Auskunft über die Datendarstellung der einzelnen Kanäle.
TwinCAT 2.8. unterstützt für den USB-Koppler nur das kompakte Mapping!
Motorola Format (komplexe Klemmen)
Mit dieser Option stellen Sie das Darstellungsformat der komplexen Klemmen ein. Sie können wählen zwischen Motorola (aktiviert) oder Intel Format (deaktiviert). Das Motorola Format sagt dabei aus, dass das höherwertige Daten-Byte eines Daten-Wortes auf dem niedrigen Adress-Offset des Speicherplatzes liegt. Beim Intel Format verhält es sich genau umgekehrt.
Format | Adress-Offset | High Byte | Low Byte
Motorola | $0 | D0 | D1
Intel | $0 | D1 | D0
Motorola Format (digitale Klemmen)
Wenn Sie für digitale Klemmen das Motorola Format wählen, so werden High- und Low-Byte eines Worts mit digitale Eingangsdaten (also von insgesamt 16 aufeinanderfolgender Digital-Kanälen) getauscht.
WORD Alignment
Um im Speicher des Prozessabbildes ein Datenwort auf eine Wortgrenze (d.h. gerade Byte-Adresse) zu legen, müssen Sie die Option Word Alignment anwählen.
Eingangsabbild freilaufend
Der Koppler führt eigenständig einen Austausch des Prozesseingangsabbildes von den Eingangsklemmen durch. Das Prozessabbild wird freilaufend (asynchron) zum Feldbus gefahren. Die Datenkonsistenz ist nicht für alle Klemmentypen sichergestellt!
Ausgangsabbild freilaufend
Der Koppler führt eigenständig (asynchron) einen Austausch des Prozessausgangsabbildes zu den Ausgangsklemmen durch. Eine Synchronisation mit dem Feldbuszyklus findet nicht statt. Die Datenkonsistenz ist nicht für alle Klemmentypen sichergestellt!


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose-LEDs
•
Trouble Shooting


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Nach dem Einschalten überprüft der Buskoppler sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen der roten LED E/A ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.
Zur Statusanzeige besitzt der Buskoppler zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbusstatus-LEDs wird in den entsprechenden Kapiteln dieses Handbuches erläutert. Sie entspricht den feldbusüblichen Anzeigen.
Auf der rechten oberen Seite des Buskopplers befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 V Versorgung des Buskopplers an. Die rechte LED signalisiert die Versorgung der Powerkontakte.
BK9500 - LEDs
LEDs zur Diagnose der Spannungsversorgung
LED | Bedeutung
Linke LED aus | Buskoppler hat keine Spannung
Rechte LED aus | Keine Spannungsversorgung 24 VDC an den Powerkontakten angeschlossen
LEDs zur Feldbus-Diagnose
LED | Ein | Aus
CYCLE | Zyklischer Datenaustausch(isochronous pipes) | Keine Verbindung vorhanden
DIA 0 | Bulk oder Control DataAustausch | kein Busverkehr vorhanden
DIA 1 | Das USB Gerät wird durch den Host adressiert. | Kein Fehler
ERROR | Fehler |
LEDs zur K-Bus-Diagnose I/O ERR
Fehlercode | Fehlerargument | Beschreibung | Abhilfe
Ständiges, konstantes Blinken |  | EMV-Probleme | Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren EMV Maßnahmen ergreifen Liegt ein K-Bus Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1 Impuls | 0 | EEPROM-Prüfsummenfehler | Herstellereinstellung mit der KS2000 setzen
 | 1 | Überlauf Inline-Code-Buffer | Weniger Klemmen stecken, bei programmierter Konfiguration zu viele Einträge in der Tabelle
 | 2 | Unbekannter Datentyp | Firmware-Update des Feldbuskopplers notwendig
2 Impulse | 0 | Programmierte Konfiguration falscher Tabelleneintrag / Buskoppler | Programmierte Konfiguration auf Richtigkeit überprüfen
 | (n>0) | Tabellenvergleich (Klemme n) falsch | Falscher Tabelleneintrag / Buskoppler
3 Impulse | 0 | Klemmenbus Kommandofehler | Keine Klemme gesteckt, Klemmen anhängen Eine der Klemmen ist defekt, angehängte Klemmen halbieren und prüfen ob der Fehler bei den übrigen Klemmen noch vorhanden ist. Dies weiter durchführen bis die defekte Klemme lokalisiert ist.
4 Impulse | n | Klemmenbus Datenfehler Bruchstelle hinter Klemme n | Prüfen ob die n+1 Klemme richtig gesteckt ist, gegebenenfalls tauschen. Kontrollieren ob die Endklemme 9010 gesteckt ist
5 Impulse | n | Klemmenbus Fehler bei Registerkommunikation mit Klemme n | Klemme n austauschen
Fehlerstelle
Die Anzahl der Impulse zeigt die Position der letzten Busklemme vor dem Fehler an. Passive Busklemmen, wie zum Beispiel eine Einspeiseklemme, werden nicht mitgezählt.
Durch die Beseitigung des Fehlers beendet der Buskoppler die Blinksequenz nicht. Der Betriebszustand des Buskopplers: Stop. Nur durch Abschalten der Versorgungsspannung kann der Buskoppler neu gestartet werden.


Trouble Shooting

Fehlerbehandlung und Diagose [image] Trouble Shooting
Trouble Shooting
Bei Verwendung des USB-Kopplers BK9500 und älteren TwinCAT Versionen tritt folgendes Verhalten auf.
Fehler
Ursache
Abhilfe
Der TwinCAT System Manager erkennt angeschlossene USB-Koppler nicht.
Während des Verbindungsaufbaus zwischen der USB-Schnittstelle Ihres PCs und den USB-Kopplern muss das übergeordnete TwinCAT System gestoppt sein! USB-Koppler, die bei laufendem TwinCAT System eingeschaltet oder mit ihrem USB-Netzwerk verbunden werden, kann der TwinCAT System Manager nicht sicher erkennen.
▪
Stoppen Sie das TwinCAT System
▪
Schalten Sie alle USB-Koppler aus oder trennen Sie deren USB-Verbindung zu Ihrem PC
▪
Schalten Sie die USB-Koppler wieder ein bzw. verbinden Sie diese wieder mit der USB-Schnittstelle Ihres PCs
▪
Lassen Sie den TwinCAT System Manager nach den USB-Kopplern suchen
▪
Starten Sie das TwinCAT System erneut
Der TwinCAT System Manager erkennt zwar den angeschlossene USB-Koppler, aber nicht die daran angeschlossenen Klemmen.
Klemmen, die bei laufendem TwinCAT System hinzugefügt wurden, kann der TwinCAT System Manager nicht sicher erkennen.
Hinweis
Aktualisieren Sie Ihre TwinCAT-Version
Diese Fehler sind ab den folgenden TwinCAT-Versionen behoben. Beckhoff empfiehlt deshalb bei Verwendung des USB-Kopplers BK9500 ein Update auf diese oder neuere TwinCAT-Versionen!
•
TwinCAT Version 2.8 (Build 747) und
•
TwinCAT Version 2.9 (Build 947)
Der Zugriff des PCs auf den USB-Koppler BK9500 erfolgt ausschließlich über die Beckhoff PC-Steuerungssoftware TwinCAT. Andere Treiber werden nicht unterstützt!


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | Siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Aufkleber mit Informationen über die Zulassung des Buskopplers BK2000
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung | 24 VDC
Übertragungsrate | 2,5 Mbit/s
Hersteller | Beckhoff Automation GmbH
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, LISTED 22ZA (unter diesem Eintrag sind die Prüfergebnisse einsehbar)
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - des Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.