BK9053_BK9103 - Buskoppler für PROFINET
Home


Vorwort

Vorwort
Vorwort
Weiterführende Informationen
•
Hinweise zur Dokumentation
•
Sicherheitshinweise
•
Ausgabestände der Dokumentation


Hinweise zur Dokumentation

Vorwort [image] Hinweise zur Dokumentation
Hinweise zur Dokumentation
Zielgruppe
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs- und Automatisierungstechnik, das mit den geltenden nationalen Normen vertraut ist.
Zur Installation und Inbetriebnahme der Komponenten ist die Beachtung der Dokumentation und der nachfolgenden Hinweise und Erklärungen unbedingt notwendig.
Das Fachpersonal ist verpflichtet, für jede Installation und Inbetriebnahme die zu dem betreffenden Zeitpunkt veröffentliche Dokumentation zu verwenden.
Das Fachpersonal hat sicherzustellen, dass die Anwendung bzw. der Einsatz der beschriebenen Produkte alle Sicherheitsanforderungen, einschließlich sämtlicher anwendbaren Gesetze, Vorschriften, Bestimmungen und Normen erfüllt.
Disclaimer
Diese Dokumentation wurde sorgfältig erstellt. Die beschriebenen Produkte werden jedoch ständig weiter entwickelt.
Wir behalten uns das Recht vor, die Dokumentation jederzeit und ohne Ankündigung zu überarbeiten und zu ändern.
Aus den Angaben, Abbildungen und Beschreibungen in dieser Dokumentation können keine Ansprüche auf Änderung bereits gelieferter Produkte geltend gemacht werden.
Marken
Beckhoff®, TwinCAT®, EtherCAT®, EtherCAT G®, EtherCAT G10®, EtherCAT P®, Safety over EtherCAT®, TwinSAFE®, XFC®, XTS® und XPlanar® sind eingetragene und lizenzierte Marken der Beckhoff Automation GmbH. Die Verwendung anderer in dieser Dokumentation enthaltenen Marken oder Kennzeichen durch Dritte kann zu einer Verletzung von Rechten der Inhaber der entsprechenden Bezeichnungen führen.
Patente
Die EtherCAT-Technologie ist patentrechtlich geschützt, insbesondere durch folgende Anmeldungen und Patente: EP1590927, EP1789857, EP1456722, EP2137893, DE102015105702 mit den entsprechenden Anmeldungen und Eintragungen in verschiedenen anderen Ländern.
EtherCAT® ist eine eingetragene Marke und patentierte Technologie lizenziert durch die Beckhoff Automation GmbH, Deutschland.
Copyright
© Beckhoff Automation GmbH & Co. KG, Deutschland.
Weitergabe sowie Vervielfältigung dieses Dokuments, Verwertung und Mitteilung seines Inhalts sind verboten, soweit nicht ausdrücklich gestattet.
Zuwiderhandlungen verpflichten zu Schadenersatz. Alle Rechte für den Fall der Patent-, Gebrauchsmuster- oder Geschmacksmustereintragung vorbehalten.


Sicherheitshinweise

Vorwort [image] Sicherheitshinweise
Sicherheitshinweise
Sicherheitsbestimmungen
Beachten Sie die folgenden Sicherheitshinweise und Erklärungen!
Produktspezifische Sicherheitshinweise finden Sie auf den folgenden Seiten oder in den Bereichen Montage, Verdrahtung, Inbetriebnahme usw.
Haftungsausschluss
Die gesamten Komponenten werden je nach Anwendungsbestimmungen in bestimmten Hard- und Software-Konfigurationen ausgeliefert. Änderungen der Hard- oder Software-Konfiguration, die über die dokumentierten Möglichkeiten hinausgehen, sind unzulässig und bewirken den Haftungsausschluss der Beckhoff Automation GmbH & Co. KG.
Qualifikation des Personals
Diese Beschreibung wendet sich ausschließlich an ausgebildetes Fachpersonal der Steuerungs-, Automatisierungs- und Antriebstechnik, das mit den geltenden Normen vertraut ist.
Erklärung der Hinweise
In der vorliegenden Dokumentation werden die folgenden Hinweise verwendet.
Diese Hinweise sind aufmerksam zu lesen und unbedingt zu befolgen!
SmallWarningYellow GEFAHR
Akute Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht unmittelbare Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow WARNUNG
Verletzungsgefahr!
Wenn dieser Sicherheitshinweis nicht beachtet wird, besteht Gefahr für Leben und Gesundheit von Personen!
SmallWarningYellow VORSICHT
Schädigung von Personen!
Wenn dieser Sicherheitshinweis nicht beachtet wird, können Personen geschädigt werden!
Hinweis
Schädigung von Umwelt/Geräten oder Datenverlust
Wenn dieser Hinweis nicht beachtet wird, können Umweltschäden, Gerätebeschädigungen oder Datenverlust entstehen.
Tipp oder Fingerzeig
Dieses Symbol kennzeichnet Informationen, die zum besseren Verständnis beitragen.


Ausgabestände der Dokumentation

Vorwort [image] Ausgabestände der Dokumentation
Ausgabestände der Dokumentation
Version
Änderungen
2.3.0
▪
Update Kapitel Vorwort
2.2.0
▪
Update Kapitel IP-Adresse
▪
Update Technische Daten
▪
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich) hinzugefügt
2.1.0
▪
Update Technische Daten
▪
Update Struktur
2.0.0
▪
Migration
▪
Update Struktur
1.3.1
▪
Update zur Firmware
1.3.0
▪
Beschreibung der Diagnose D-Worte hinzugefügt
▪
ATEX-Hinweise hinzugefügt
1.2.0
▪
BK9053 hinzugefügt
1.1.0
▪
Update zur Firmware B2
1.0.0
▪
Erste Version
Firm- und Hardware-Stände
Dokumentation Version | BK9053 |  | BK9103
 | Firmware | Hardware* | Firmware | Hardware*
2.2.0 | B9 | 06 | C1 | 11
2.1.0 | B9 | 06 | C1 | 11
2.0.0 | B8 | 04 | C0 | 11
1.3.1 | B5 | 00 | BD | 06
1.3.0 | B2 | 00 | BA | 06
1.2.0 | B1 | 00 | B7 | 06
1.1.0 | - | - | B2 | 00
1.0.0 | - | - | B0 | 00
Hardware* mindestens erforderlich für einen Update.
Welche Firmware im Auslieferungszustand auf dem Buskoppler ist, erkennen Sie an dem Aufkleber unter dem Koppler (siehe fünfte und sechste Stelle der Produktionsnummer).
Beispiel:
3200B2020000
Die Firmware im Beispiel ist B2.
Zum Update Ihrer Firmware benötigen Sie die Konfigurationssoftware KS2000 und das zu deren Lieferumfang gehörende serielle Kabel.
Neue Firmware-Versionen finden Sie auf http://www.beckhoff.de.
Hinweise zur den Firmware-Versionen
BK9103
Firmware
Beschreibung
C0
▪
Unterstützte Klemme - KL6781, KL8519, KL8524, KL8528 und KL8548
BF
▪
Über den Rekordindex 0x1010 kann eine Parametrierung (= write) des K-Busses abgewählt werden -> z. B. für die IO-Link-Klemme
BE
▪
Internen Puffer für Frames vergrößert
BD
▪
unterstütze kompaktes Mapping für KL6051
▪
Nach einem K-Bus Reset über KS2000 oder DAP Ctrl wird die AR immer abgebaut
▪
Es wird nur ein LLDP angenommen, erst wenn der TTL abgelaufen ist wird die REMMIB abgelöscht und ein neuer Nachbar angenommen
BC
▪
Auslesen der RemPort MIB behoben (über SNMP)
BB
▪
GSDML zu Schema V2.3
▪
MRP Client wird jetzt Unterstützt
▪
Multiple Write wird unterstützt
BA
▪
Bei einem Pull/Plug Alarm werden nur die Statis der betroffenen Module auf BAD/GOOD gesetzt
B9
▪
Unterstützung von KL6224 (IO-Link Master)
B8
▪
I&M2 und I&M3 unterstützt
B7
▪
HD- Klemmen aufgenommen
B6
▪
KL2791, KL1212, KL2641 implementiert
▪
Step7 Online view unterstützt
B5
▪
Alias Name überarbeitet
B4
▪
LLDP, SNMP implementiert
▪
I&M0, I&M1, I&M4 unterstützt
B3
▪
Unterstützung aller KL Klemmen
B2
▪
Unterstützung für neue Busklemmen implementiert.
▪
KL3xxx und KL4xxx können nun auch kompakt eingetragen werden.
B0
▪
Erste Veröffentlichung
BK9053
Firmware
Beschreibung
▪
Unterstützte Klemme - KL6781, KL8519, KL8524, KL8528 und KL8548
B7
▪
Über den Rekordindex 0x1010 kann eine Parametrierung (= write) des K-Busses abgewählt werden -> z. B. für die IO-Link-Klemme
B6
▪
Internen Puffer für Frames vergrößert
B5
▪
unterstütze kompaktes Mapping für KL6051
▪
Nach einem K-Bus Reset über KS2000 oder DAP Ctrl wird die AR immer abgebaut
▪
Es wird nur ein LLDP angenommen, erst wenn der TTL abgelaufen ist wird die REMMIB abgelöscht und ein neuer Nachbar angenommen
B4
▪
Auslesen der RemPort MIB behoben (über SNMP)
B3
▪
Unterstützung von KL6224 (IO-Link Master)
▪
GSDML zu Schema V2.3
B2
▪
Freigabe der Firmware (released)
B0
▪
Erste Veröffentlichung (preliminary)


Produktübersicht

Produktübersicht
Produktübersicht
Weiterführende Informationen
•
BK9053 - Einführung
•
BK9103 - Einführung
•
Technische Daten
•
Das Beckhoff Busklemmensystem
•
Prinzip der Busklemme


BK9053 - Einführung

Produktübersicht [image] BK9053 - Einführung
BK9053 - Einführung
BK9053
PROFINET ist der offene Industrial-Ethernet-Standard der PNO (PROFIBUS Nutzerorganisation). Für die Kommunikation werden international etablierte IT-Standards genutzt.
PROFINET IO beschreibt den Datenaustausch zwischen Steuerungen und Feldgeräten und kann in Standard-Ethernet-Netzwerken verwendet und über handelsübliche Switche vernetzt werden. Das Einbinden an einem beliebigen PROFINET-Controller geschieht über die Gerätestammdatei GSDML.
Der Buskoppler BK9053 verbindet PROFINET mit den modular erweiterbaren elektronischen Reihenklemmen. Eine Einheit besteht aus einem Buskoppler, einer beliebigen Anzahl von 1 bis 64 Klemmen (255 mit K-Bus-Verlängerung) und einer Busendklemme.
Die Buskoppler erkennen die angeschlossenen Klemmen und erstellen automatisch die Zuordnung der Ein-/Ausgänge zu den Worten des Prozessabbildes.


BK9103 - Einführung

Produktübersicht [image] BK9103 - Einführung
BK9103 - Einführung
BK9103
Der Buskoppler BK9103 verbindet PROFINET mit den modular erweiterbaren elektronischen Reihenklemmen. Eine Einheit besteht aus einem Buskoppler, einer beliebigen Anzahl von 1 bis 64 Klemmen und einer Busendklemme (255 Busklemmen mit der Klemmenbusverlängerung).
Die Buskoppler erkennen die angeschlossenen Klemmen und erstellen automatisch die Zuordnung der Ein-/Ausgänge zu den Worten des Prozessabbildes.
Der Buskoppler BK9103 unterstützt 10 MBit/s- und 100 MBit/s-Ethernet, der Anschluss erfolgt über gängige RJ-45-Steckverbinder. Am DIP-Schalter wird die IP-Adresse eingestellt (Offset zu einer frei wählbaren Startadresse), in Netzen mit DHCP (Dienst für die Zuordnung der logischen IP-Adresse zur physikalischen Knotenadresse (MAC-ID)) erhält der Buskoppler seine IP-Adresse vom DHCP-Server.
Der BK9103 besitzt einen zusätzlichen RJ-45-Port. Beide Ethernet-Ports arbeiten als Zweikanal-Switch. Damit können die I/O-Stationen, anstatt in der klassischen Sterntopologie, als Linientopologie aufgebaut werden. Der Verdrahtungsaufwand wird hierdurch bei vielen Anwendungen erheblich vereinfacht, und die Kabelkosten werden reduziert. Die maximale Entfernung zwischen zwei Kopplern beträgt 100 m. Bis zu 20 BK9103-Buskoppler sind kaskadierbar, sodass man eine maximale Linie von 2 km erreichen kann.
Komplexe Signalverarbeitung für analoge I/Os, Wegmessung usw.
Der Buskoppler BK9103 unterstützt den Betrieb aller K-Busklemmen. Der Umgang mit den analogen Ein-/Ausgängen unterscheidet sich für den Anwender nicht von denen anderer Baureihen. Die Information steht als Byte-Array im Prozessabbild des Automatisierungsgerätes zur Bearbeitung bereit.
Mit der Konfigurationssoftware KS2000 lassen sich die analogen und mehrfunktionalen Busklemmen anwendungsspezifisch anpassen. Die Register der analogen Busklemmen enthalten je nach Typ Temperaturbereiche, Verstärkungsfaktoren und Linearisierungskennlinien. Mit der Software KS2000 kann über den PC die gewünschte Parametrierung eingestellt werden. Die Busklemme speichert die Einstellung spannungsausfallsicher und dauerhaft. Wahlweise kann auch die Steuerung (SPS, IPC) die Konfiguration der Busklemmen durchführen. Über Funktionsbausteine (FB) wickeln die SPS oder der IPC in der Hochlaufphase die Konfiguration der gesamten Peripherie ab. Die Steuerung kann bei Bedarf die dezentral erstellten Konfigurationsdaten hochladen, um sie zentral zu verwalten und zu speichern. Durch den Austausch einer Busklemme wird damit keine Neueinstellung notwendig. Die Steuerung führt die gewünschte Einstellung nach dem Einschalten automatisch durch.


Technische Daten

Produktübersicht [image] Technische Daten
Technische Daten
System
Systemdaten | BK9053 | BK9103
Anzahl der E/A-Module | nur durch IP-Adressraum begrenzt
Anzahl der E/A-Punkte | steuerungsabhängig
Übertragungsmedium | Twisted-Pair-Kupferkabel, 4 x 2, geschirmt; Kategorie 5 (100 MBaud)
Länge zwischen Modulen | 100 m (zwischen Switch bis Buskoppler)
Übertragungsrate | 10 / 100 MBaud
Topologie | linien- und sternförmige Verkabelung
Kaskadierung | bis zu 20 Buskoppler bzw. max. Linienaufbau 2 km
Buskoppler
Technische Daten | BK9053 | BK9103
Anzahl der Busklemmen | 64 (255 mit K-Bus Erweiterung)
Digitale Peripheriesignale | 512 Ein-/Ausgänge | 512 Ein-/Ausgänge
Analoge Peripheriesignale | 256 Ein-/Ausgänge | 256 Ein-/Ausgänge
Protokolle | PROFINET RT (Class B) TCP-ADS für den Zugriff über Ethernet mit KS2000 Konfigurationssoftware
Konfigurationsmöglichkeit | über die Konfigurationssoftware KS2000 oder der Steuerung
maximale Byteanzahl | 512 Byte Eingangsdaten und 512 Byte Ausgangsdaten
Busanschluss | 1 x RJ45 | 2 x RJ45
Spannungsversorgung | 24 VDC (-15%/+20%)
Stromaufnahme | 70 mA + (ges. K-Bus Strom)/4, max. 500 mA
Einschaltstrom | ca. 2,5 x Dauerstrom
K-Bus-Stromversorgung bis | 1750 mA
Spannung Powerkontakt | maximal 24 VDC
Stromlast Powerkontakt | maximal 10 A
Spannungsfestigkeit | 500 V (Powerkontakt/Versorgungsspannung/Feldbus)
Empf. Vorsicherung | ≤ 10 A
Gewicht | ca. 100 g | ca. 170 g
Montage | auf 35 mm Tragschiene nach EN 60715
Zulässiger Umgebungstemperaturbereich im Betrieb | 0°C ... +55°C | -25°C ... +60°C
Zulässiger Umgebungstemperaturbereich bei Lagerung | -25°C ... +85°C | -40°C ... +85°C
Zulässige relative Feuchte | 95%, keine Betauung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6 / EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2 / EN 61000-6-4
Einbaulage | beliebig
Schutzart | IP20
Zulassungen | CE, UL, ATEX | CE, UL, ATEX, GL


Das Beckhoff Busklemmensystem

Produktübersicht [image] Das Beckhoff Busklemmensystem
Das Beckhoff Busklemmensystem
Bis zu 256 Busklemmen mit ein bis 16 E/A-Kanälen für jede Signalform
Das Busklemmen-System ist das universelle Bindeglied zwischen einem Feldbus-System und der Sensor / Aktuator - Ebene. Eine Einheit besteht aus einem Buskoppler als Kopfstation und bis zu 64 elektronischen Reihenklemmen, wovon die letzte eine Endklemme ist. Mit der K-Bus Erweiterung können bis zu 255 Busklemmen angeschlossen werden. Für jede technische Signalform stehen Klemmen mit ein, zwei, vier oder acht E/A-Kanälen zur Verfügung, die beliebig gemischt werden können. Dabei haben alle Klemmentypen die gleiche Bauform, wodurch der Projektierungsaufwand sehr gering gehalten wird. Bauhöhe und Tiefe sind auf kompakte Klemmenkästen abgestimmt.
Dezentrale Verdrahtung der E/A-Ebene
Die Feldbustechnik erlaubt den Einsatz kompakter Steuerungsbauformen. Die E/A-Ebene muss nicht bis zur Steuerung geführt werden. Die Verdrahtung der Sensoren und Aktuatoren ist dezentral mit minimalen Kabellängen durchführbar. Der Installationsstandort der Steuerung kann im Bereich der Anlage beliebig gewählt werden.
Industrie-PCs als Steuerung
Durch den Einsatz eines Industrie-PCs als Steuerung lässt sich das Bedien- und Beobachtungselement in der Hardware der Steuerung realisieren. Der Standort der Steuerung kann deshalb ein Bedienpult, eine Leitwarte oder ähnliches sein. Die Busklemmen stellen die dezentrale Ein-/Ausgabeebene der Steuerung im Schaltschrank und untergeordneten Klemmenkästen dar. Neben der Sensor/Aktuator-Ebene wird auch der Leistungsteil der Anlage über das Bussystem gesteuert. Die Busklemme ersetzt die konventionelle Reihenklemme als Verdrahtungsebene im Schaltschrank. Der Schaltschrank kann kleiner dimensioniert werden.
Buskoppler für alle gängigen Bussysteme
Das Beckhoff Busklemmen-System vereint die Vorteile eines Bussystems mit den Möglichkeiten der kompakten Reihenklemme. Busklemmen können an allen gängigen Bussystemen betrieben werden und verringern so die Teilevielfalt in der Steuerung. Dabei verhalten sich Busklemmen wie herkömmliche Anschaltungen dieses Bussystems. Alle Leistungsmerkmale des jeweiligen Bussystems werden unterstützt.
Montage auf genormten Tragschienen
Die einfache und platzsparende Montage auf einer genormten Tragschiene (EN 60715, 35 mm) und die direkte Verdrahtung von Aktoren und Sensoren ohne Querverbindungen zwischen den Klemmen standardisiert die Installation. Dazu trägt auch das einheitliche Beschriftungskonzept bei.
Die geringe Baugröße und die große Flexibilität des Busklemmen-Systems ermöglichen den Einsatz überall dort, wo auch eine Reihenklemme zur Anwendung kommt. Jede Art von Ankopplung, wie analoge, digitale, serielle oder der Direktanschluss von Sensoren kann realisiert werden.
Modularität
Die modulare Zusammenstellung der Klemmleiste mit Busklemmen verschiedener Funktionen begrenzt die Zahl der ungenutzten Kanäle auf maximal einen pro Funktion. Die Anzahl von zwei Kanälen in einer Klemme trifft das Optimum zwischen der Zahl der ungenutzten Kanäle und den Kosten pro Kanal. Auch die Möglichkeit der Potentialtrennung durch Einspeiseklemmen hilft, die Anzahl der ungenutzten Kanäle gering zu halten.
Anzeige des Kanalzustands
Die integrierten Leuchtdioden zeigen in Sensor/Aktuator-Nähe den Zustand des entsprechenden Kanals an.
K-Bus
Der K-Bus ist der Datenweg innerhalb der Klemmleiste. Über sechs Kontakte an den Seitenwänden der Klemmen wird der K-Bus vom Buskoppler durch alle Klemmen geführt. Die Endklemme schließt den K-Bus ab. Der Benutzer muss sich keinerlei Wissen über die Funktion des K-Bus oder die interne Arbeitsweise von Klemmen und Buskoppler aneignen. Viele lieferbare Software-Tools erlauben eine komfortable Projektierung, Konfiguration und Bedienung.
Potential-Einspeiseklemmen für potentialgetrennte Gruppen
Über drei Powerkontakte wird die Betriebsspannung an die nachfolgenden Klemmen weitergegeben. Durch den Einsatz von Potential-Einspeiseklemmen, können Sie die Klemmleiste in beliebige potentialgetrennte Gruppen gliedern. Die Potential-Einspeiseklemmen werden bei der Ansteuerung der Klemmen nicht berücksichtigt, sie dürfen an beliebiger Stelle in die Klemmleiste eingereiht werden.
In einem Klemmenblock können Sie bis zu 64 Busklemmen einsetzen und diesen über die K-Busverlängerung auf bis zu 256 Busklemmen erweitern. Dabei werden Potential-Einspeiseklemmen mitgezählt, die Endklemme nicht.
Buskoppler für verschiedene Feldbus-Systeme
Verschiedene Buskoppler lassen sich einsetzen, um die elektronische Klemmleiste schnell und einfach an unterschiedliche Feldbus-Systeme anzukoppeln. Auch eine nachträgliche Umrüstung auf ein anderes Feldbus-System ist möglich. Der Buskoppler übernimmt alle Kontroll- und Steuerungsaufgaben, die für den Betrieb der angeschlossenen Busklemmen notwendig sind. Die Bedienung und Konfiguration der Busklemmen wird ausschließlich über den Buskoppler durchgeführt. Die eingestellten Parameter werden jedoch spannungsausfallsicher in den jeweiligen Busklemmen gespeichert. Feldbus, K-Bus und E/A-Ebene sind galvanisch getrennt.
Wenn der Datenaustausch über den Feldbus zeitweise gestört ist oder ausfällt, bleiben Registerinhalte (wie z. B. Zählerstände) erhalten, digitale Ausgänge werden gelöscht und analoge Ausgänge nehmen einen Wert an, der bei der Inbetriebnahme für jeden Ausgang konfigurierbar ist. Die Default-Einstellung der analogen Ausgänge ist 0 V bzw. 0 mA. Digitale Ausgänge fallen in einen inaktiven Zustand zurück. Die Timeout-Zeiten der Buskoppler entsprechen den für das Feldbus-System üblichen Zeiten. Bei der Umstellung auf ein anderes Bussystem beachten Sie im Falle großer Zykluszeiten des Bussystems die Änderung der Timeout-Zeiten.
Die Schnittstellen
Ein Buskoppler besitzt sechs unterschiedliche Anschlussmöglichkeiten. Diese Schnittstellen sind als Steckverbindungen und Federkraftklemmen ausgelegt.


Prinzip der Busklemme

Produktübersicht [image] Prinzip der Busklemme
Prinzip der Busklemme
Prinzip der Busklemme


Montage und Verdrahtung

Montage und Verdrahtung
Montage und Verdrahtung
Weiterführende Informationen
•
Abmessungen
•
Tragschienenmontage
•
Spannungsversorgung, Potenzialgruppen
•
Ethernet-Anschluss
•
Ethernet-Topologien
•
Ethernet-Kabel
•
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
•
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
•
ATEX-Dokumentation


Abmessungen

Montage und Verdrahtung [image] Abmessungen
Abmessungen
Das System der Beckhoff-Busklemmen zeichnet sich durch geringes Bauvolumen und hohe Modularität aus. Für die Projektierung muss ein Buskoppler und eine Anzahl von Busklemmen vorgesehen werden. Die Baumaße der Buskoppler sind unabhängig vom Feldbus-System.
Abmessungen
Die Gesamtbreite der Anwendung setzt sich aus der Breite des Buskopplers, der Busendklemme KL9010 und der Breite der verwendeten Busklemmen zusammen. Die Busklemmen sind je nach Funktion 12 mm oder 24 mm breit. Die lichte Höhe von 68 mm wird durch die Frontverdrahtung in Abhängigkeit von der Drahtstärke um ca. 5 mm bis 10 mm überbaut.
Mechanische Daten | BKxxxx BCxxxx | BKxx50 BCxx50 | BXxxxx | LCxxxx
Bauform | kompaktes Klemmengehäuse mit Signal-LED
Werkstoff | Polyamid (PA 6.6) | Polyamid (PA 6.6) | Polycarbonat | Polyamid (PA 6.6)
Abmessungen (B x H x T) | 49 x 100 x 68 mm | 44 x 100 x 68 mm | 81 (BX8000 61) x 100 x 89 mm | 21 x 100 x 68 mm
Montage | auf 35-mm-C-Schiele entsprechend EN 60715 mit Verriegelung
Anreihbar durch | Doppelte Nut-Feder-Verbindung
Beschriftung | Standard-Reihenklemmenbeschriftung
Vibrations-/Schockfestigkeit | gemäß EN 60068-2-6/EN 60068-2-27
EMV-Festigkeit/Aussendung | gemäß EN 61000-6-2/EN 61000-6-4
Anschlusstechnik | BKxxxx BCxxxx | BKxx50 BCxx50 | BXxxxx | LCxxxx
Verdrahtung | Federkrafttechnik Cage Clamp®
Anschlussquerschnitt | 0,08 mm² ... 2,5 mm² , Litze, Draht massiv, AWG 28-14
Feldbusanschluss | feldbusabhängig |  |  | Federklemmen
Powerkontakte | 3 Federkontakte
Strombelastung IMAX | 10 A (125 A Kurzschluss)
Nennspannung | 24 VDC


Tragschienenmontage

Montage und Verdrahtung [image] Tragschienenmontage
Tragschienenmontage
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag und Beschädigung des Gerätes möglich!
Setzen Sie das Busklemmen-System in einen sicheren, spannungslosen Zustand, bevor Sie mit der Montage, Demontage oder Verdrahtung der Busklemmen beginnen!
Montage
Die Buskoppler und Busklemmen werden durch leichten Druck auf handelsübliche 35 mm Tragschienen (Hutschienen nach EN 60715) aufgerastet:
1.
Stecken Sie zuerst den Feldbuskoppler auf die Tragschiene.
2.
Auf der rechten Seite des Feldbuskopplers werden nun die Busklemmen angereiht. Stecken Sie dazu die Komponenten mit Nut und Feder zusammen und schieben Sie die Klemmen gegen die Tragschiene, bis die Verriegelung hörbar auf der Tragschiene einrastet.
Wenn Sie die Klemmen erst auf die Tragschiene schnappen und dann nebeneinander schieben ohne das Nut und Feder ineinander greifen, wird keine funktionsfähige Verbindung hergestellt! Bei richtiger Montage darf kein nennenswerter Spalt zwischen den Gehäusen zu sehen sein.
Art und Quelle der Gefahr
Der Verriegelungsmechanismus der Klemmen und Koppler reicht in das Profil der Tragschiene hinein. Achten Sie bei der Montage der Komponenten darauf, dass der Verriegelungsmechanismus nicht in Konflikt mit den Befestigungsschrauben der Tragschiene gerät. Verwenden Sie zur Befestigung von Tragschienen mit einer Höhe von 7,5 mm unter den Klemmen und Kopplern flache Montageverbindungen wie Senkkopfschrauben oder Blindnieten.
Demontage
Jede Klemme wird durch eine Verriegelung auf der Tragschiene gesichert, die zur Demontage gelöst werden muss:
1.
Ziehen Sie vorsichtig die orangefarbige Lasche ca. 1 cm aus der zu demontierenden Klemme heraus, bis die Lasche locker hervorsteht. Jetzt ist für diese Klemme die Verriegelung mit der Tragschiene gelöst und die Klemme kann ohne großen Kraftaufwand von der Tragschiene gezogen werden.
2.
Greifen Sie dazu mit Daumen und Zeigefinger die entriegelte Klemme gleichzeitig oben und unten an den geriffelten Gehäuseflächen und ziehen Sie die Klemme von der Tragschiene weg.
Verbindungen innerhalb eines Busklemmenblocks
Die elektrischen Verbindungen zwischen Buskoppler und Busklemmen werden durch das Zusammenstecken der Komponenten automatisch realisiert:
▪
Die sechs Federkontakte des K-Bus/E-Bus übernehmen die Übertragung der Daten und die Versorgung der Busklemmenelektronik.
▪
Die Powerkontakte übertragen die Versorgung für die Feldelektronik und stellen so innerhalb des Busklemmenblocks eine Versorgungsschiene dar. Die Versorgung der Powerkontakte erfolgt über Klemmen auf dem Buskoppler.
Powerkontakte
Beachten Sie bei der Projektierung eines Busklemmenblocks die Kontaktbelegungen der einzelnen Busklemmen, da einige Typen (z. B. analoge Busklemmen oder digitale 4-Kanal-Busklemmen) die Powerkontakte nicht oder nicht vollständig durchschleifen. Einspeiseklemmen (KL91xx, KL92xx bzw. EL91xx, EL92xx) unterbrechen die Powerkontakte und stellen so den Anfang einer neuen Versorgungsschiene dar.
PE-Powerkontakt
Der Powerkontakt mit der Bezeichnung PE kann als Schutzerde eingesetzt werden. Der Kontakt ist aus Sicherheitsgründen beim Zusammenstecken voreilend und kann Kurzschlussströme bis 125 A ableiten.
Hinweis
Beschädigung des Gerätes möglich
Beachten Sie, dass aus EMV-Gründen die PE-Kontakte kapazitiv mit der Tragschiene verbunden sind. Das kann bei der Isolationsprüfung zu falschen Ergebnissen und auch zur Beschädigung der Klemme führen (z. B. Durchschlag zur PE-Leitung bei der Isolationsprüfung eines Verbrauchers mit 230 V Nennspannung). Klemmen Sie zur Isolationsprüfung die PE- Zuleitung am Buskoppler bzw. der Einspeiseklemme ab! Um weitere Einspeisestellen für die Prüfung zu entkoppeln, können Sie diese Einspeiseklemmen entriegeln und mindestens 10 mm aus dem Verbund der übrigen Klemmen herausziehen.
SmallWarningYellow WARNUNG
Verletzungsgefahr durch Stromschlag!
Der PE-Powerkontakt darf nicht für andere Potentiale verwendet werden!
Verdrahtung
Bis zu acht Anschlüsse ermöglichen den Anschluss von massiven oder feindrähtigen Leitungen an die Busklemmen. Die Klemmen sind in Federkrafttechnik ausgeführt. Schließen Sie die Leitungen folgendermaßen an:
1.
Öffnen Sie eine Federkraftklemme, indem Sie mit einem Schraubendreher oder einem Dorn leicht in die viereckige Öffnung über der Klemme drücken.
2.
Der Draht kann nun ohne Widerstand in die runde Klemmenöffnung eingeführt werden.
3.
Durch Rücknahme des Druckes schließt sich die Klemme automatisch und hält den Draht sicher und dauerhaft fest.
Schirmung
Analoge Sensoren und Aktoren sollten immer mit geschirmten, paarig verdrillten Leitungen angeschlossen werden.


Spannungsversorgung, Potenzialgruppen

Montage und Verdrahtung [image] Spannungsversorgung, Potenzialgruppen
Spannungsversorgung, Potenzialgruppen
Spannungsversorgung des Buskopplers
Die Buskoppler benötigen zum Betrieb eine 24 V Gleichspannung. Der Anschluss findet über die oberen Federkraftklemmen mit der Bezeichnung 24 V und 0 V statt. Die Versorgungsspannung versorgt die Buskopplerelektronik und über den K-Bus/E-Bus die Busklemmen. Die Spannungsversorgung der Buskopplerelektronik und die des K-Bus/E-Bus sind galvanisch von der Spannung der Feldebene getrennt.
Einspeisung für die Powerkontakte
Die unteren sechs Anschlüsse mit Federkraftklemmen können zur Einspeisung der Peripherieversorgung benutzt werden. Die Federkraftklemmen sind paarweise mit einem Powerkontakt verbunden. Die Einspeisung zu den Powerkontakten besitzt keine Verbindung zur Spannungsversorgung der Buskoppler. Die Auslegung der Einspeisung lässt Spannungen bis zu 24 V zu. Die paarweise Anordnung und die elektrische Verbindung zwischen den Speiseklemmkontakten ermöglicht das Durchschleifen der Anschlussdrähte zu unterschiedlichen Klemmpunkten. Die Strombelastung über den Powerkontakten darf 10 A nicht dauerhaft überschreiten. Die Strombelastbarkeit zwischen zwei Federkraftklemmen ist mit der Belastbarkeit der Verbindungsdrähte identisch.
Powerkontakte
An der rechten Seitenfläche des Buskopplers befinden sich drei Federkontakte der Powerkontaktverbindungen. Die Federkontakte sind in Schlitzen verborgen um den Berührungsschutz sicherzustellen. Durch das Anreihen einer Busklemme werden die Messerkontakte auf der linken Seite der Busklemme mit den Federkontakten verbunden. Die Nut/Federführung an der Ober- und Unterseite der Buskoppler und Busklemmen garantiert sichere Führung der Powerkontakte.
Konfigurations-Schnittstelle (nicht für BK1250, EK1x00)
Auf der unteren Seite der Frontfläche sind die Standardbuskoppler mit einer RS232-Schnittstelle ausgerüstet. Der Miniaturstecker kann mit einem Verbindungskabel und der Konfigurations-Software KS2000 mit einem PC verbunden werden. Die Schnittstelle erlaubt das Konfigurieren der Busklemmen, wie zum Beispiel das Einstellen des Verstärkungsfaktors der analogen Kanäle. Über die Schnittstelle kann auch die Zuordnungen der Busklemmen- Daten zum Prozessabbild im Buskoppler verändert werden. Die Funktionalität der Konfigurationsschnittstelle ist auch über den Feldbus mit der String-Kommunikation zu erreichen.
Potenzialtrennung
Die Buskoppler arbeiten mit drei unabhängigen Potenzialgruppen. Die Versorgungsspannung speist galvanisch getrennt die K-Bus/E-Bus-Elektronik im Buskoppler und den K-Bus/E-Bus selbst. Aus der Versorgungsspannung wird weiter die Betriebsspannung für den Betrieb des Feldbusses erzeugt.
Anmerkung: Alle Busklemmen haben eine galvanische Trennung zum K-Bus/E-Bus. Der K-Bus/E-Bus ist dadurch vollständig galvanisch gekapselt.
Potenzialtrennung


Ethernet-Anschluss

Montage und Verdrahtung [image] Ethernet-Anschluss
Ethernet-Anschluss
Der Anschluss an den Ethernet-Bus erfolgt über einen RJ45-Stecker (Westernstecker).
RJ45-Stecker
Verkabelung
Ethernet-Verbindung von PC zu BK910x über einen Switch
Ethernet-Verbindung von PC zu BK910x über einen Switch
Verbinden Sie die Netzwerkkarte des PCs über ein Standart-Ethernetkabel mit dem Hub, und das Hub ebenfalls über ein Standard-Ethernetkabel mit dem Busklemmen-Controller. Die Verbindung über einen Switch erfolgt auf die gleiche Weise.
Direkte Ethernet-Verbindung von PC zu BK910x
Direkte Ethernet-Verbindung von PC zu BK910x
Um den PC direkt mit dem Busklemmen-Controller zu verbinden, müssen Sie ein Standard-Ethernetkabel verwenden.
Belegung des RJ45-Steckers
PIN | Signal | Beschreibung
1 | TD + | Transmit +
2 | TD - | Transmit -
3 | RD + | Receive +
4 | - | reserviert
5 | - | reserviert
6 | RD - | Receive -
7 | - | reserviert
8 | - | reserviert


Ethernet-Topologien

Montage und Verdrahtung [image] Ethernet-Topologien
Ethernet-Topologien
BK9053
Da der BK9053 nur einen Port besitzt, muss der Aufbau in klassischer Sterntopologie erfolgen.
BK9103
Der BK9103 besitzt einen internen Dreifach-Switch mit zwei externen und einem internen Port. Der interne Switch ermöglicht den einfachen Aufbau einer Linien-Topologie. Sie können maximal 20 BK9103 zu einer physikalischen Linie hintereinander schalten. Dabei darf die Distanz zwischen zwei BK9103 maximal 100 Meter betragen. Die gesamte Länge der so aufgebauten Linie darf also zwei Kilometer betragen. In diese Linie darf kein weiterer Switch eingebaut werden.
Ethernet-Topologie mit mehreren BK9103 in zwei Linien
Es ist auch mit dem BK9103 der Aufbau einer klassischen Sterntopologie möglich. Der zweite Port wird dann nicht benutzt. Beide Port-Schnittstellen sind gleichwertig.


Ethernet-Kabel

Montage und Verdrahtung [image] Ethernet-Kabel
Ethernet-Kabel
Übertragungsstandards
10Base5
Das Übertragungsmedium für 10Base5 ist ein dickes Koaxialkabel (Yellow Cable) mit einer max. Übertragungsgeschwindigkeit von 10 MBaud und einer Linien-Topologie mit Abzweigen (Drops), an die jeweils ein Teilnehmer angeschlossen wird. Da hier alle Teilnehmer an einem gemeinsamen Übertragungsmedium angeschlossen sind, kommt es bei 10Base5 zwangsläufig häufig zu Kollisionen.
10Base2
10Base2 (Cheaper net) ist eine Weiterentwicklung von 10Base5 und hat den Vorteil dass dieses Koaxialkabel billiger und durch eine höhere Flexibilität einfacher zu verlegen ist. Es können mehrere Geräte an eine 10Base2-Leitung angeschlossen werden. Häufig werden die Abzweige eines 10Base5-Backbones als 10Base2 ausgeführt.
10BaseT
Beschreibt ein Twisted-Pair-Kabel für 10 MBaud. Hierbei wird das Netz sternförmig aufgebaut, so dass nun nicht mehr jeder Teilnehmer am gleichem Medium hängt. Dadurch führt ein Kabelbruch nicht mehr zum Ausfall des gesamten Netzes. Durch den Einsatz von Switches als Sternkoppler können Kollisionen vermindert oder bei Voll-Duplex Verbindungen auch vollständig vermieden werden.
100BaseT
Twisted-Pair-Kabel für 100 MBaud. Für die höhere Datengeschwindigkeit ist eine bessere Kabelqualität und die Verwendung entsprechender Hubs oder Switches erforderlich.
10BaseF
Der Standard 10BaseF beschreibt mehrere Lichtwellenleiter-Varianten.
Kurzbezeichnung der Kabeltypen für 10BaseT und 100BaseT
Twisted-Pair Kupferkabel für sternförmige Topologie, wobei der Abstand zwischen zwei Geräten 100 Meter nicht überschreiten darf.
UTP
Unshielded Twisted-Pair (nicht abgeschirmte, verdrillte Leitung)
Dieser Kabeltyp gehört zur Kategorie 3 und sind für industrielle Umgebungen nicht empfehlenswert.
S/UTP
Screened/Unshielded Twisted-Pair (mit Kupfergeflecht abgeschirmte, verdrillte Leitung)
Besitzen einen Gesamtschirm aus einem Kupfergeflecht zur Reduktion der äußeren Störeinflüsse. Dieses Kabel wird zum Einsatz mit dem Buskopplern empfohlen.
FTP
Foilesshielded Twisted-Pair (mit Alufolie abgeschirmte, verdrillte Leitung)
Dieses Kabel hat eine alukaschierten Kunststoff-Folie-Gesamtschirm.
S/FTP
Screened/Foilesshielded Twisted-Pair (mit Kupfergeflecht und Alufolie abgeschirmte, verdrillte Leitung)
Besitzt einen alukaschierten Gesamtschirm mit einem darüber liegenden Kupfergeflecht. Solche Kabel können eine Störleistungsunterdrückung bis zu 70 dB erreichen.
STP
Shielded Twisted-Pair (abgeschirmte, verdrillte Leitung)
Beschreibt ein Kabel mit Gesamtschirm ohne weitere Angabe der Art der Schirmung.
S/STP
Screened/Shielded Twisted-Pair (einzeln abgeschirmte, verdrillte Leitung)
Ein solche Bezeichnung kennzeichnet ein Kabel mit einer Abschirmung für jedes Leitungspaar sowie einen Gesamtschirm.
ITP
Industrial Twisted-Pair
Ist von Aufbau dem S/STP ähnlich, besitzt allerdings im Gegensatz zum S/STP nur 2 Leitungspaare.


ATEX - Besondere Bedingungen (Standardtemperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (Standardtemperaturbereich)
ATEX - Besondere Bedingungen (Standardtemperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten für Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von 0 bis 55°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit Standardtemperaturbereich tragen eine der folgenden Kennzeichnungen:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: 0 … 55°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: 0 … 55°C


ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)

Montage und Verdrahtung [image] ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
ATEX - Besondere Bedingungen (erweiterter Temperaturbereich)
SmallWarningYellow WARNUNG
Beachten Sie die besonderen Bedingungen für die bestimmungsgemäße Verwendung von Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) in explosionsgefährdeten Bereichen (Richtlinie 94/9/EG)!
•
Die zertifizierten Komponenten sind in ein geeignetes Gehäuse zu errichten, das eine Schutzart von mindestens IP54 gemäß EN 60529 gewährleistet! Dabei sind die Umgebungsbedingungen bei der Verwendung zu berücksichtigen!
•
Wenn die Temperaturen bei Nennbetrieb an den Einführungsstellen der Kabel, Leitungen oder Rohrleitungen höher als 70°C oder an den Aderverzweigungsstellen höher als 80°C ist, so müssen Kabel ausgewählt werden, deren Temperaturdaten den tatsächlich gemessenen Temperaturwerten entsprechen!
•
Beachten Sie für Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) beim Einsatz in explosionsgefährdeten Bereichen den zulässigen Umgebungstemperaturbereich von -25 bis 60°C!
•
Es müssen Maßnahmen zum Schutz gegen Überschreitung der Nennbetriebsspannung durch kurzzeitige Störspannungen um mehr als 40% getroffen werden!
•
Die einzelnen Klemmen dürfen nur aus dem Busklemmensystem gezogen oder entfernt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Anschlüsse der zertifizierten Komponenten dürfen nur verbunden oder unterbrochen werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Die Sicherung der Einspeiseklemmen KL92xx/EL92xx dürfen nur gewechselt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
•
Adresswahlschalter und ID-Switche dürfen nur eingestellt werden, wenn die Versorgungsspannung abgeschaltet wurde bzw. bei Sicherstellung einer nicht-explosionsfähigen Atmosphäre!
Normen
Die grundlegenden Sicherheits- und Gesundheitsanforderungen werden durch Übereinstimmung mit den folgenden Normen erfüllt:
▪
EN 60079-0:2012+A11:2013
▪
EN 60079-15:2010
Kennzeichnung
Die für den explosionsgefährdeten Bereich zertifizierten Beckhoff-Feldbuskomponenten mit erweitertem Temperaturbereich (ET) tragen die folgende Kennzeichnung:
II 3G KEMA 10ATEX0075 X Ex nA IIC T4 Gc Ta: -25 … 60°C
oder
II 3G KEMA 10ATEX0075 X Ex nC IIC T4 Gc Ta: -25 … 60°C


ATEX-Dokumentation

Montage und Verdrahtung [image] ATEX-Dokumentation
ATEX-Dokumentation
Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)
Beachten Sie auch die weiterführende Dokumentation

Hinweise zum Einsatz der Beckhoff Klemmensysteme in explosionsgefährdeten Bereichen (ATEX)

die Ihnen auf der Beckhoff-Homepage http://www.beckhoff.de im Bereich Download zur Verfügung steht!


Parametrierung und Inbetriebnahme

Parametrierung und Inbetriebnahme
Parametrierung und Inbetriebnahme
Weiterführende Informationen
•
Anlaufverhalten des Buskopplers
•
DIP-Schalter-Einstellungen
•
Netzwerkklassen
•
IP-Adresse


Anlaufverhalten des Buskopplers

Parametrierung und Inbetriebnahme [image] Anlaufverhalten des Buskopplers
Anlaufverhalten des Buskopplers
Nach dem Einschalten überprüft der Buskoppler in einem Selbsttest alle Funktionen seiner Bauteile und die Kommunikation des K-Busses/E-Busses. Während dieser Phase blinkt die rote I/O-LED. Nach dem erfolgreichen Selbsttest beginnt der Buskoppler die angesteckten Busklemmen in einem Busklemmentest zu testen und liest die Konfiguration ein. Aus der Konfiguration der Busklemmen entsteht eine interne, von außen nicht zugängliche, Aufbauliste. Für den Fall eines Fehlers geht der Buskoppler in den Betriebszustand Stop. Nach dem fehlerfreien Hochlauf geht der Buskoppler in den Zustand Feldbusstart.
Anlaufverhalten des Buskopplers
Der Buskoppler kann nach der Fehlerbeseitigung nur durch erneutes Einschalten in den normalen Betriebszustand gebracht werden.


DIP-Schalter-Einstellungen

Parametrierung und Inbetriebnahme [image] DIP-Schalter-Einstellungen
DIP-Schalter-Einstellungen
Über die DIP-Schalter können Sie zwischen verschiedenen Adressierungsmöglichkeiten und die Auswahl des PROFINET-Namens vergeben.
BK9103
▪
Schalter rechte Position: OFF
▪
Schalter linke Position: ON
DIP-Schalter des BK9103
PROFINET-konform verhält sich das Gerät, wenn die DIP-Schalter 1 bis 8 auf OFF stehen und DIP-Schalter 9 und 10 auf ON. Alle anderen Modi sind als Option möglich.
BK9053
▪
Schalter rechte Position: ON
▪
Schalter linke Position: OFF
DIP-Schalter des BK9053
PROFINET-konform verhält sich das Gerät, wenn die DIP-Schalter 1 bis 8 (rot) auf OFF stehen und DIP-Schalter 1 und 2 (blau) auf ON. Alle anderen Modi sind als Option möglich.
PROFINET Name über DIP-Schalter
Hier wird der Name aus bk9103-xxx + DIP-Schalter gebildet. xxx entspricht den DIP-Schaltern 1 bis 8. bk muss klein geschrieben werden!
BK9103,
DIP9
BK9103,
DIP10
Beschreibung
Verhalten bei Neustart
Verhalten bei Herstellereinstellung
BK9053
DIP1 blau
BK9053
DIP2 blau
0
0
Letztes Byte der IP-Adresse über die DIP-Schalter 1 bis 8
▪
PN-Name aus dem Speicher
▪
IP-Adresse über DIP-Schalter 1 bis 8
▪
PN-Name wird Leerstring
▪
IP-Adresse über DIP-Schalter
172.16.17.xxx (xxx DIP-Schalter)
SNM 255.255.0.0
0
1
DHCP
DIP-Schalter 1 bis 8 auf OFF
▪
PN-Name aus dem Speicher
▪
IP-Adresse und SNM über DHCP
▪
PN-Name wird Leerstring
▪
IP-Adresse und SNM über DHCP
▪
DNS Name "bk9103-xxyyzz"
xxyyzz letzten 3 Byte der MAC-ID
DHCP
DIP-Schalter 1 bis 8 auf ON
▪
PN-Name über DIP-Schalter 1 bis 8*
▪
IP-Adresse und SNM über DHCP
▪
PN-Name über DIP-Schalter 1 bis 8
▪
IP-Adresse und SNM über DHCP
▪
DNS Name "bk9103-xxyyzz"
xxyyzz letzten 3 Byte der MAC-ID
1
0
BootP
▪
PN-Name aus dem Speicher
▪
IP-Adresse und SNM über BootP
▪
PN-Name wird Leerstring
▪
IP-Adresse über BootP
1
1
PROFINET-konform
DIP-Schalter 1 bis 8 auf OFF
▪
PN-Name aus dem Speicher
▪
IP-Adresse aus dem Speicher
▪
PN-Name wird Leerstring
▪
IP-Adresse 0.0.0.0
PROFINET mit festem Namen
DIP-Schalter 1 bis 8 auf ON
▪
PN-Name über DIP-Schalter 1 bis 8*
▪
IP-Adresse aus dem Speicher
▪
PN-Name über DIP-Schalter 1 bis 8
▪
IP-Adresse 0.0.0.0
*) PROFINET-Name (PN-Name) kann nicht von der Steuerung überschrieben werden.
Legende
PN - Profinet
SNM - SubNetMask
DHCP - Dynamic Host Configuration Protocol
DNS - Domain Name Server


Netzwerkklassen

Parametrierung und Inbetriebnahme [image] Netzwerkklassen
Netzwerkklassen
Man unterscheidet drei verschiedene Netzwerkklassen. Diese legen fest, wie viele Adress-Bits für die Netzwerk-ID und wie viele für die Knotennummer (z. B. für PCs oder Buskoppler) reserviert werden. Die Unterscheidung findet in den ersten drei Bits der IP-Adresse statt.
Netzwerk- klasse | Anzahl Bits für die Netzwerk-ID | Ermöglicht Anzahl Netzwerke | Anzahl Bits für die Knotenadresse | Ermöglicht Anzahl Knoten pro Netzwerk
A | 7 | 126 | 24 | 16 777 214
B | 14 | 16 382 | 16 | 65 536
C | 21 | 2 097 150 | 8 | 254
Einmalige IP-Adresse
Eine IP-Adresse muss im gesamten verbundenen Netzwerk einmalig sein!
Netzwerkklassen
Gleiche Netzwerkklasse
Die eingestellte IP-Adresse muss bei einer Kommunikation mit einem anderen Ethernet-Teilnehmer die gleiche Netzwerkklasse besitzen. Beispiel: Ihr PC hat die Adresse 172.16.17.55, damit muss der Koppler die Adresse 172.16.xxx.xxx haben (die xxx stehen für eine Zahl von 0...255. Die 0 wird üblicherweise vom Router/Switch benutzt sollte dafür reserviert bleiben).
Um sich die Adresse des eigenen PCs anzusehen, kann man bei Windows NT/2000/XP im DOS-Fenster den Befehl ipconfig eingeben.


IP-Adresse

Parametrierung und Inbetriebnahme [image] IP-Adresse
IP-Adresse
In der Regel wird die IP Adresse bei PROFINET über die Steuerung (PROFINET Controller) vorgegeben und braucht daher nicht im Buskoppler eingestellt zu werden. Die Adressierung der Buskoppler erfolgt über den PROFINET-Namen, welcher mit unterschiedlichen Verfahren eingestellt werden kann (s. DIP-Schalter-Einstellungen).
In Ausnahmefällen macht es Sinn dem Koppler eine IP Adresse vorab zu geben (ohne PROFINET angeschlossen zu haben), zum Beispiel damit man über die KS2000 Software und Ethernet auf die Koppler zugreifen kann.
Weiterführende Informationen
•
IP-Adresse und PROFINET-Name
•
Adresseinstellung mit KS2000
•
Einstellung der IP-Adresse über den Beckhoff BootP-Server
•
Adresseinstellung über einen DHCP-Server
•
Subnetz-Maske
•
Test der IP-Adresse


IP-Adresse und PROFINET-Name

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] IP-Adresse und PROFINET-Name
IP-Adresse und PROFINET-Name
Die Einstellung der IP-Adresse kann mit drei unterschiedlichen Verfahren durchgeführt werden, die im Folgenden genauer beschrieben werden.
Verfahren | Erläuterung | Benötigte Komponenten
KS2000 | Adressierung über die Konfigurations-Software KS2000 und DIP-Schalter | Konfigurations-Software KS2000 und KS2000-Kabel
BootP | Adressierung über BootP-Server | BootP-Server
DHCP | Adressierung über DHCP-Server | DHCP-Server


Adresseinstellung mit KS2000

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Adresseinstellung mit KS2000
Adresseinstellung mit KS2000
Mit der der Konfigurations-Software KS2000 können Sie (ab Version 3.2.8) die TCP/IP-Adresse per Dialogfenster einstellen oder direkt in die Register schreiben. Die DIP-Schalter 9 und 10 (beim BK9050 DIP-Schalter 1 und 2 in blau) müssen beide vor dem Einschalten auf OFF (0) stehen.
Tabelle 100
Register | High-Byte | Low-Byte
0 | IP-Byte 2 | IP-Byte 1
1 | Nicht benutzt | IP-Byte 3
Default
Byte | Default-Wert (hex) | Default-Wert (dez)
1 | 0xAC | 172dez
2 | 0x10 | 16dez
3 | 0x11 | 17dez
4 | (DIP-Schalter) | (0 bis 255dez)
Beispiel
DIP-Schalter
Schalter-Nr. | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 |
Wertigkeit | 1 | 2 | 4 | 8 | 16 | 32 | 64 | 128 | - | - |
Im Beispiel | ON | OFF | OFF | ON | OFF | OFF | ON | ON | OFF | OFF |
Wert | 1 | 0 | 0 | 8 | 0 | 0 | 64 | 128 | - | - | Summe=201
Software-Reset
Um Änderungen in den Tabellen des Buskopplers zu speichern ist ein Software-Reset erforderlich. Ein Hardware-Reset (Power on/off) reicht nicht aus!


Einstellung der IP-Adresse über den Beckhoff BootP-Server

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Einstellung der IP-Adresse über den Beckhoff BootP-Server
Einstellung der IP-Adresse über den Beckhoff BootP-Server
Stellen Sie für die Adresseinstellung mit dem Beckhoff BootP-Server den DIP-Schalter 9 auf ON (1) und den DIP-Schalter 10 auf OFF (0). Die DIP-Schalter 1-8 haben dann keine Adress-Funktion mehr. Ist dies nicht der Fall so meldet der Buskoppler LED-Fehler-Code 6-4 (siehe Diagnose LEDs). Während der Adressvergabe blinkt die LED TCP/IP ERROR.
Speicherverhalten der IP-Adresse
DIP-Schalter 1-8 in Stellung ON
Die vom BootP-Server vergebene IP-Adresse wird gespeichert und der BootP-Service wird beim nächsten Kaltstart nicht gestartet.
Die Adresse kann durch Reaktivierung der Herstellereinstellungen (mittels Konfigurationssoftware KS2000 oder DIP-Schalter und Endklemme) wieder gelöscht werden.
DIP-Schalter 1-8 in Stellung OFF
Die vom BootP-Server vergebene IP-Adresse ist nur bis zum Ausschalten des Buskopplers gültig. Beim nächsten Kaltstart muss der BootP-Server dem Buskoppler eine neue IP-Adresse vergeben.
Bei einem Software-Reset des Buskopplers bleibt die Adresse allerdings erhalten.
Beckhoff BootP-Server
Beckhoff bietet einen BootP-Server für Windows 98, ME, NT4.0, NT2000 und XP an. Sie finden die Installationsversion auf der Beckhoff TwinCAT CD unter dem Folder >Unsupported Utilities< oder unter http://download.beckhoff.com/.
Konfiguration des Beckhoff BootP-Servers
Sobald der BootP-Server gestartet wird zeigt das Fenster New MAC Address alle Beckhoff-Knoten an, die im BootP-Betrieb arbeiten und noch keine IP-Adresse bekommen haben. Die Zuweisung MAC-ID zu IP-Adresse erfolgt mit dem Button "<<". Eine erfolgreiche Zuweisung wird im Log-Fenster angezeigt.
Um den BootP-Server beim Booten Ihres PCs automatisch zu starten reicht eine Verknüpfung im Autostart von Windows. Fügen Sie hierzu im Verknüpfungspfad den Parameter /Start an (.../TcBootPDlg.exe/start).


Adresseinstellung über einen DHCP-Server

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Adresseinstellung über einen DHCP-Server
Adresseinstellung über einen DHCP-Server
Stellen Sie für die Adresseinstellung über einen DHCP-Server den DIP-Schalter 9 auf OFF (0) und den DIP-Schalter 10 auf ON (1).
In diesem Zustand ist der DHCP-Dienst eingeschaltet und der Buskoppler bekommt eine IP-Adresse vom DHCP-Server zugewiesen.
Der DHCP-Server muss hierfür die MAC-ID des Buskopplers kennen und sollte dieser MAC-ID bei jedem Hochlauf dieselbe IP-Adresse zuweisen!
Während der Adressvergabe blinkt die LED TCP/IP Error.


Subnetz-Maske

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Subnetz-Maske
Subnetz-Maske
Die Subnetz-Maske unterliegt der Kontrolle des Netzwerkverwalters und legt die Struktur der Subnetze fest.
Kleine Netze ohne Router benötigen keine Subnetz-Maske. Das gleiche gilt, wenn Sie keine registrierten IP-Nummern verwenden. Sie können die Subnetz-Maske dazu verwenden, anstelle des Gebrauchs vieler Netznummern das Netz mit dieser Maske zu unterteilen.
Die Subnetz-Maske ist eine 32-Bit Ziffer:
▪
Einsen in der Maske kennzeichnen den Subnetz-Nummernteil eines Adressraums.
▪
Nullen kennzeichnen den Teil des Adressraums, der für die Host-IDs zur Verfügung steht.
Beschreibung | Binäre Darstellung | Dezimale Darstellung
IP-Adresse | 10101100.00010000.00010001.11001000 | 172.16.17.200
Subnetz-Maske | 11111111.11111111.00010100.00000000 | 255.255.20.0
Netz-ID | 10101100.00010000.00010000.00000000 | 172.16.16.0
Host-ID | 00000000.00000000.00000001.11001000 | 0.0.1.200
Standard Subnetz-Maske
Adressklasse | Standard Subnetz-Maske (dezimal) | Standard Subnetz-Maske (hex)
A | 255.0.0.0 | FF.00.00.00
B | 255.255.0.0 | FF.FF.00.00
C | 255.255.255.0 | FF.FF.FF.00
Subnetze und Host-Nummer
Die Subnetze 0 und das nur aus nur Einsen bestehende Subnetz dürfen nicht verwendet werden! Die Host-Nummer 0 und die aus nur Einsen bestehende Host-Nummer dürfen nicht verwendet werden!
Wenn die IP-Adresse über die Konfigurations-Software KS2000 eingestellt wurde, muss auch die Subnetz-Maske mit der Konfigurations-Software KS2000 geändert werden.
Bei ARP-Adressierung wird anhand der IP-Adresse die dazugehörige Standard Subnetz-Maske eingetragen.
Bei BootP und DHCP wird die Subnetz-Maske mit vom Server übertragen.


Test der IP-Adresse

Parametrierung und Inbetriebnahme [image] IP-Adresse [image] Test der IP-Adresse
Test der IP-Adresse
Zum Testen der IP-Adresse können Sie in einer Windows-Eingabeaufforderung das Kommando Ping benutzen.
Test der IP-Adresse über das Kommando Ping


Konfiguration

Konfiguration
Konfiguration
Weiterführende Informationen
•
GSDML-Konfigurationsdateien
•
Mapping der Busklemmen
•
Konfigurationsbeispiel mit Step 7


GSDML-Konfigurationsdateien

Konfiguration [image] GSDML-Konfigurationsdateien
GSDML-Konfigurationsdateien
Zu den Buskopplern BK9053 und BK9103 finden Sie die aktuellen Konfigurationsdatei für den PROFINET-Master auf der Beckhoff Homepage unter Downloads:
http://www.beckhoff.de/german/download/bkconfg.htm


Mapping der Busklemmen

Konfiguration [image] Mapping der Busklemmen
Mapping der Busklemmen
Die Busklemmen KLxxxx oder KSxxxx mappen sich in der Reihenfolge am Buskoppler, wie diese Hardwaremäßig angeschlossen sind. KLxxxx und KSxxxx Busklemmen werden nicht unterschieden. Busklemmen die kein Prozessabbild besitzen müssen und können nicht konfiguriert werden, zum Beispiel KL9100, KL9020, KL9050, KL9010.
Für digitale Busklemmen wird immer mindestens ein Byte reserviert.
Bespiel: KL1xx2 2 digitale Eingänge, 8 Bit wobei die ersten beiden Bits 0-1 mit der Klemme belegt sind. Bits 2-7 haben keine Bedeutung.
Komplexe Busklemmen werden mit Ein- und Ausgangsprozessabbild dargestellt.
Beispiel: KL3001 1 analoger Eingang 1 Byte Control oder Status Informationen, ein Leerbyte, 2 Byte Daten.


Konfigurationsbeispiel mit Step 7

Konfiguration [image] Konfigurationsbeispiel mit Step 7
Konfigurationsbeispiel mit Step 7
Installieren Sie die GSDML-Datei (ab Step 7 ab Version 5.4 + SP1)
Öffnen Sie dazu den Hardware Manager. Installieren Sie die GSDML-Datei.
Step 7 - Installieren der GSDML-Datei
Fügen Sie einen BK9103 als Knoten in ihren Manager ein und fügen Sie dann die Klemmen entsprechend Ihrer Konfiguration an.
Step 7 - Einfügen des Buskopplers BK9103 und der Busklemmen entsprechend der Konfiguration
Tragen Sie den Namen des PN-Gerätes ein, zum Beispiel bk9103-1 (bk muss Klein geschrieben sein).
Stellen Sie die DIP Schalter des BK9103 1,9 und 10 auf ON alle anderen auf OFF und schalten dann den Koppler ein).
Step 7 - Eintragen des Namens für das PROFINET-GERÄT
Die Konfiguration sieht zum Beispiel jetzt wie folgt aus. Laden Sie die Konfiguration in ihrer Steuerung.
Step 7 - Darstellung der Konfiguration in der Steuerung


Feldbussystem

Feldbussystem
Feldbussystem
Weiterführende Informationen
•
Feldbusübersicht
•
Ethernet
•
Topologie


Feldbusübersicht

Feldbussystem [image] Feldbusübersicht
Feldbusübersicht
Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.
Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.
Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.
Grundlagen
Internet-Protokoll (IP)
Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.
Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z. B. IP, TCP, UDP, ARP und ICMP.
Transmission Control Protocol (TCP)
Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.
User Datagram Protocol (UDP)
UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schnellere Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.
Internet Control Message Protocol (ICMP)
Dient dem Informationsaustausch der Endgeräte über den aktuellen Status des Internet-Protokolls.
Address Resolution Protocol (ARP)
Dient der Umwandlung zwischen IP-Adressen und MAC-Adressen.
BootP
Das BootP-Protokoll ermöglicht das Einstellen und Ändern der TCP/IP-Adresse indem der Netzwerk-Teilnehmer mit der MAC-ID angesprochen wird.


Ethernet

Feldbussystem [image] Ethernet
Ethernet
Ethernet wurde ursprünglich von DEC, Intel und Xerox (als DIX-Standard) für die Datenübertragung zwischen Bürogeräten entwickelt. Heute versteht man darunter meist die Spezifikation IEEE 802.3 CSMA/CD, die 1985 veröffentlicht wurde. Diese Technologie ist durch ihren weltweiten Einsatz und die hohen Stückzahlen überall erhältlich und sehr preiswert. Eine Anbindung an vorhandene Netze kann so problemlos realisiert werden.
Mittlerweile gibt es die verschiedensten Übertragungsmedien: Koaxialkabel (10Base5), Lichtwellenleiter (10BaseF) oder verdrillte Zweidrahtleitung (10BaseT) mit Schirmung (STP) oder ohne Schirmung (UTP). Mit Ethernet lassen sich verschieden Topologien aufbauen wie Ring, Linie oder Stern.
Ethernet transportiert Ethernet-Pakete von einem Sender zu einem oder mehreren Empfängern. Diese Übertragung verläuft ohne Quittung und ohne Wiederholung von verlorenen Paketen. Für die sichere Daten-Kommunikation stehen Protokolle wie TCP/IP zu Verfügung, die auf Ethernet aufsetzen.
MAC-ID
Sender und Empfänger von Ethernet-Paketen werden über die MAC-ID adressiert. Die MAC-ID ist ein 6 Byte großer Identifikations-Code, der eineindeutig, d.h. für jedes Ethernet-Gerät weltweit unterschiedlich ist. Die MAC-ID besteht aus zwei Teilen. Der erste Teil (d.h. die ersten 3 Byte) ist eine Herstellerkennung. Die Firma Beckhoff hat die Kennung 00 01 05. Die nächsten 3 Byte werden durch den Hersteller vergeben und entsprechen einer eindeutigen Seriennummer. Die MAC-ID kann zum Beispiel beim BootP-Protokoll zum Einstellen der TCP/IP-Nummer verwendet werden. Dafür wird ein Telegramm zum entsprechenden Knoten geschickt, das die Informationen wie Name oder TCP/IP-Nummer beinhaltet. Sie können die MAC-ID mit der Konfigurationssoftware KS2000 auslesen.
Internet-Protokoll (IP)
Die Grundlage der Datenkommunikation ist das Internet-Protokoll (IP). IP transportiert Datenpakete von einem Teilnehmer zu einem anderen, der sich im gleichen oder in einem anderen Netz befinden kann. IP kümmert sich dabei um das Adress-Management (Finden und Zuordnen der MAC-IDs), die Segmentierung und die Pfadsuche (Routing). Wie das Ethernet-Protokoll gewährleistet auch IP keinen gesicherten Transport der Daten; Datenpakete können verloren gehen oder in ihrer Reihenfolge vertauscht werden.
Für einen standardisierten, gesicherten Informationsaustausch zwischen beliebig vielen verschiedenen Netzwerken wurde TCP/IP entwickelt. Dabei ist TCP/IP weitgehend unabhängig von der verwendeten Hard- und Software. Oftmals als ein Begriff verwendet, handelt es sich hierbei um mehrere aufeinander aufgesetzte Protokolle: z. B. IP, TCP, UDP, ARP und ICMP.
Transmission Control Protocol (TCP)
Das auf IP aufsetzende Transmission Control Protocol (TCP) ist ein verbindungsorientiertes Transport-Protokoll. Es umfasst Fehlererkennungs- und Behandlungsmechanismen. Verlorengegangene Telegramme werden wiederholt.
User Datagram Protocol (UDP)
UDP ist ein verbindungsloses Transport-Protokoll. Es gibt keine Kontrollmechanismen beim Datenaustausch zwischen Sender und Empfänger. Dadurch resultiert eine schneller Verarbeitungsgeschwindigkeit als zum Beispiel bei TCP. Eine Prüfung ob das Telegramm angekommen ist muss vom übergeordneten Protokoll durchgeführt werden.
User Datagram Protocol (UDP)
Auf TCP/IP und UDP/IP aufsetzende Protokolle
Auf TCP/IP bzw. UDP können folgende Protokolle aufsetzen:
▪
ADS
▪
ModbusTCP
Beide Protokolle sind parallel auf dem Buskoppler implementiert, so dass für die Aktivierung der Protokolle keine Konfiguration nötig ist.
Auf TCP/IP und UDP/IP aufsetzende Protokolle
ADS setzt wahlweise auf TCP oder UDP auf, während ModbusTCP stets auf TCP/IP basiert.


Topologie

Feldbussystem [image] Topologie
Topologie
Mit 10BaseT und 100BaseT werden mehrere Stationen im Ethernet-Standard sternförmig verbunden.
Stern-Topologie
Ein Stern-LAN besteht in der einfachsten Netzform aus einzelnen Punkt-zu-Punkt-Verbindungen. Alle Nachrichten laufen über einen zentralen Knoten (Hub oder Switch), der je nach Zieladresse die Informationen an den gewünschten Empfänger weitergibt.
Baum-Topologie
Eine Baum Topologie besteht aus mehreren verbundenen Stern-Topologien. Sobald mehrere Hubs oder Switches im Netz vorhanden sind, ist eine Baumtopologie vorhanden. Ideal ist es, die Verbindungen zwischen den Sternkopplern besonders breitbandig auszuführen, da diese den meisten Datenverkehr transportieren. Beim Aufbau von Baum-Topologien ist die Repeater-Regel zu beachten, die auch als 5-4-3-Repeater-Regel bezeichnet wird. Maximal zwei Repeater-Paare (bzw. Hub-Paare) dürfen im Übertragungsweg zwischen zwei beliebigen Stationen sein, sofern sie nicht durch Bridges, Switches oder Router getrennt sind. Ein Übertragungsweg kann aus maximal fünf Segmenten und vier Repeater-Sets (zwei Repeater-Paaren) bestehen. Dabei können bis zu drei Segmente Koax-Segmente sein, an denen die Stationen angeschlossen sind, die restlichen Segmente müssen Punkt-zu-Punkt-Verbindungen sein, die auch als IRL-Verbindung (Inter Repeater Link) bezeichnet werden.
Verkabelungsrichtlinien
Allgemeine Richtlinien für den Netzwerkaufbau eines LAN gibt die Strukturierte Verkabelung vor. Darin sind maximal zulässige Kabellängen für die Gelände-, Gebäude- und Etagenverkabelung festgelegt. In den Standards EN 50173, ISO 11801 und TIA 568-A normiert, bildet die Strukturierte Verkabelung die Grundlage für eine zukunftsweisende, anwendungsunabhängige und wirtschaftliche Netzwerk-Infrastruktur. Die Verkabelungsstandards definieren einen Geltungsbereich mit einer geographischen Ausdehnung von bis zu 3 km und für eine Bürofläche von bis zu 1 Mio. Quadratmeter mit 50 bis 50.000 Endgeräten. Darüber beschreiben sie Empfehlungen für den Aufbau eines Verkabelungssystems. Abhängig von der gewählten Topologie, den unter Industriebedingungen eingesetzten Übertragungsmedien und Koppelmodulen sowie von dem Einsatz von Komponenten verschiedener Hersteller in einem Netz können sich abweichende Angaben ergeben. Die Angaben verstehen sich hier deshalb lediglich als Empfehlungen.


Fehlerbehandlung und Diagose

Fehlerbehandlung und Diagose
Fehlerbehandlung und Diagose
Weiterführende Informationen
•
Diagnose-LEDs
•
Diagnose-Wort


Diagnose-LEDs

Fehlerbehandlung und Diagose [image] Diagnose-LEDs
Diagnose-LEDs
Nach dem Einschalten überprüft der Buskoppler sofort die angeschlossene Konfiguration. Der fehlerfreie Hochlauf wird durch das Verlöschen roten der LED E/A ERR signalisiert. Das Blinken der LED I/O ERR zeigt einen Fehler im Bereich der Klemmen an. Durch Frequenz und Anzahl des Blinkens kann der Fehler-Code ermittelt werden. Das ermöglicht eine schnelle Fehlerbeseitigung.
Zur Statusanzeige besitzt der Buskoppler zwei Gruppen von LEDs. Die obere Gruppe mit vier LEDs zeigt den Zustand des jeweiligen Feldbusses an. Die Bedeutung der Feldbusstatus-LEDs wird in den entsprechenden Kapiteln dieses Handbuches erläutert. Sie entspricht den feldbusüblichen Anzeigen.
Auf der rechten oberen Seite des Buskopplers befinden sich zwei weitere grüne LEDs zur Anzeige der Versorgungsspannung. Die linke LED zeigt die 24 V Versorgung des Buskopplers an. Die rechte LED signalisiert die Versorgung der Powerkontakte.
LEDs der Buskoppler BK9053 und BK9103
LEDs zur Diagnose der Spannungsversorgung
LED | Bedeutung
LED Us | aus | Versorgungsspannung Us nicht vorhanden
 | an | Versorgungsspannung Us vorhanden
LED Up | aus | Versorgungsspannung Up (für Powerkontakte) nicht vorhanden
 | an | Versorgungsspannung Up (für Powerkontakte) vorhanden
LEDs am RJ45
LED | Bedeutung
LED Link/Act | aus | Keine physikalische Verbindung vorhanden
 | an | Physikalische Verbindung vorhanden
 | blinkt | Kommunikation vorhanden
LED 10/100 MBaud (nur BK9103 | aus | 10 MBaud (falls LED Link/Act leuchtet oder blinkt)
 | an | 100 MBaud
LEDs für die PROFINET-Diagnose
PROFINET-Diagnose | PN Err (rot) | PN Run (grün) | DIAG E (rot) | DIAG R (grün)
IP Address OK | aus | 0,5 s | x | x
No IP valid Address (Dip Switch 9,10 -> on) | 0,1 sec | aus | x | x
Online | aus | an | x | x
Offline PLC Stop | aus | 0,1 s | x | x
TimeOut | 0,5 s | aus | x | x
IP Adresse konfigurations- Fehler | an | aus | x | x
Blinken abwechselnd (wird ausgelöst durch ein Profinet Tool) | 0,5 sec | 0,5 sec | x | x
Configuration Diagnose | PN Err (rot) | PN Run (grün) | DIAG E (rot) | DIAG R (grün)
OK | x | x | off | on
Falsches Modul | x | x | Slot Nummer | 1
Fehlendes Modul (physikalisch) | x | x | Slot Nummer | 2
Fehlendes Modul (in der Konfiguration) | x | x | Slot Nummer | 3
Kein PROFINET-Name vergeben | x | x | 0 | 4
Substitute | x | x | Slot Nummer | 5
x: Der Status der LED ist für die Diagnose nicht relevant
Anmerkung:
▪
Treten mehrere Fehler auf, so wird immer das letzte Fehlerhafte Modul angezeigt.
▪
Substitute - wird bei falsch konfigurierten Modulen gesetzt, die aber trotzdem lauffähig sind (Beispiel KL2xx2 konfiguriert es steckt aber an dem Slot eine KL2xx4
Beispiel
Sie haben eine KL2xx4 am fünften Steckplatz konfiguriert, tatsächlich sind aber nur vier Module gesteckt.
▪
Start Error Code: Rote DIAG E LED flackert schnell, grüne DIAG R LED ist aus
▪
Rote DIAG E LED ist an, grüne LED zeigt den Error Code blinkt 2 mal (0,5 Sec)
▪
Rote und grüne LED aus
▪
Rote DIAG E LED zeigt das Error Argument blinkt 5 mal (0,5 Sec, hier die Slotnummer), grüne LED ist aus
Beispiel für Error Code und Error Argument
LEDs zur K-Bus-Diagnose
Fehler-Code
Fehlerargument
Beschreibung
Abhilfe
Ständiges, konstantes Blinken
EMV-Probleme
▪
Spannungsversorgung auf Unter- oder Überspannungsspitzen kontrollieren
▪
EMV-Maßnahmen ergreifen
▪
Liegt ein K-Bus-Fehler vor, kann durch erneutes Starten (Aus- und Wiedereinschalten des Koppler) der Fehler lokalisiert werden
1 Impuls
0
EEPROM-Prüfsummenfehler
Herstellereinstellungen mit der Konfigurationssoftware KS2000 setzen
1
Überlauf im Code Buffer
Weniger Busklemmen stecken. Bei prog. Konfiguration sind zu viele Einträge in der Tabelle
2
Unbekannter Datentyp
Software Update des Buskopplers notwendig
2 Impulse
0
Programmierte Konfiguration, falscher Tabelleneintrag
Programmierte Konfiguration auf Richtigkeit überprüfen
n (n > 0)
Tabellenvergleich (Busklemme n)
Falscher Tabelleneintrag
3 Impulse
0
K-Bus-Kommandofehler
▪
Keine Busklemme gesteckt
▪
Eine der Busklemmen ist defekt, angehängte Busklemmen halbieren und prüfen ob der Fehler bei den übrigen Busklemmen noch vorhanden ist. Dies weiter durchführen, bis die defekte Busklemme lokalisiert ist.
4 Impulse
0
K-Bus-Datenfehler, Bruchstelle hinter dem Buskoppler
Prüfen ob die n+1 Busklemme richtig gesteckt ist, gegebenenfalls tauschen
n
Bruchstelle hinter Busklemme n
Kontrollieren ob die Busendklemme 9010 gesteckt ist
5 Impulse
n
K-Bus-Fehler bei Register-Kommunikation mit Busklemme n
n-te Busklemme tauschen
6 Impulse
0
Fehler bei der Initialisierung
Buskoppler tauschen
1
Interner Datenfehler
Hardware-Reset des Buskopplers (aus - und wieder einschalten)
4
DIP-Schalter für BootP falsch
1-8 auf on oder off stellen, siehe BootP
8
Interner Datenfehler
Hardware-Reset des Buskopplers (aus- und wieder einschalten)
16
Fehler beim IP-Socket
Hardware-Reset des Buskopplers (aus- und wieder einschalten)
14 Impulse
n
n-te Busklemme hat das falsche Format
Buskoppler erneut Starten, falls der Fehler erneut auftritt die Busklemme tauschen.
15 Impulse
n
Anzahl der Busklemmen stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen
16 Impulse
n
Länge der K-Bus-Daten stimmt nicht mehr
Buskoppler erneut Starten, falls der Fehler erneut auftritt, Herstellereinstellung mit der Konfigurationssoftware KS2000 setzen


Diagnose-Wort

Fehlerbehandlung und Diagose [image] Diagnose-Wort
Diagnose-Wort
Wenn die GSDML-Version nach 2.1 oder höher in den Konfigurator eingebunden wird, wird im DAP ein Status- und Control-DWord (Doppelwort) eingebunden. Hier können weitere Funktionen genutzt werden:
▪
Messen des K-Bus Zykluszeit
▪
K-Bus Zykluszähler (wird nach jedem K-Bus Zyklus inkrementiert)
▪
K-Bus-Fehler, Error-Code und Error-Argument (siehe K-Bus Diagnosse- LEDs)
▪
K-Bus-Reset
▪
Buskopper-Reset
Status-DWord (Eingangswort der SPS)
Das Status-DWord zeigt Diagnose-Informationen an.
Bit | 31-24 | 23-16 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | K-Bus Error Argument | K-Bus Error Code | K-Bus Counter oder K-Bus Cycle Time |  |  |  |  |  |  |  | - | S | - | - | L2 | - | R1 | K1
Legende
K1: 0 -> 1 rising Flag K-Bus Reset
R1: 1 ->0 falling Flag Reboot Buskoppler
L2: "1" K-Bus Stopp bei PROFINET-Fehler oder SPS-Stopp
S: "0" K-Bus Zähler
"1" K-Bus Zyklus Zeit in 0,1 ms
Control-DWord (Ausgangswort der SPS)
Im Control-DWord können die jeweiligen Funktionen aktiviert werden.
Bit | 31-24 | 23-16 | 15 | 14 | 13 | 12 | 11 | 10 | 9 | 8 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
Name | - | - | - |  |  |  |  |  |  |  | - | S | - | - | L2 | - | R1 | K1
Control-DWord (Ausgangswort der SPS)


Anhang

Anhang
Anhang
Weiterführende Informationen
•
Allgemeine Betriebsbedingungen
•
Literaturverzeichnis
•
Abkürzungsverzeichnis
•
Support und Service


Allgemeine Betriebsbedingungen

Anhang [image] Allgemeine Betriebsbedingungen
Allgemeine Betriebsbedingungen
Um einen fehlerfreien Betrieb der Feldbuskomponenten zu erreichen, müssen die nachfolgenden Bedingungen eingehalten werden.
Bedingungen an die Umgebung
Betrieb
An folgenden Orten dürfen die Komponenten nicht ohne Zusatzmaßnahmen eingesetzt werden:
▪
unter erschwerten Betriebsbedingungen, wie z.B. ätzende Dämpfe oder Gase, Staubbildung
▪
bei hoher ionisierender Strahlung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur im Betrieb | Siehe Technische Daten
Einbaulage | beliebig
Vibrationsfestigkeit | gemäß EN 60068-2-6
Schockfestigkeit | gemäß EN 60068-2-27
EMV-Festigkeit | gemäß EN 61000-6-2
Aussendung | gemäß EN 61000-6-4
Transport und Lagerung
Bedingung | zulässiger Bereich
zulässige Umgebungstemperatur bei Lagerung | -25°C... +85°C
Relative Feuchte | 95 %, keine Betauung
Freier Fall | originalverpackt bis 1 m
Schutzklasse und Schutzart
Bedingung | zulässiger Bereich
Schutzklasse nach IEC 536 (VDE 0106, Teil 1) | An der Profilschiene ist ein Schutzleiteranschluss erforderlich!
Schutzart nach IEC 529 | IP20 ( Schutz gegen Berührung mit Standard Prüffinger)
Schutz gegen Fremdkörper | kleiner 12 mm im Durchmesser
Schutz gegen Wasser | kein Schutz
Kennzeichnung der Komponenten
Jede ausgelieferte Komponente enthält einen Aufkleber, mit Informationen über die Zulassung des Produkts. Beispiel für den Buskoppler BK2000:
Aufkleber mit Informationen über die Zulassung des Buskopplers BK2000
Auf dem Aufkleber sind folgende Informationen abzulesen:
Aufdruck | Bedeutung für diesen Aufkleber
genaue Produktbezeichnung | Lightbus Koppler BK2000
Versorgungsspannung | 24 VDC
Übertragungsrate | 2,5 Mbit/s
Hersteller | Beckhoff Automation GmbH
CE-Zeichen | Konformitätskennzeichnung
UL-Zeichen | Kennzeichen für UL-Zulassung. UL steht für Underwriters Laboratories Inc., die führende Zertifizierungsorganisation für Nordamerika mit Sitz in den USA. C = Kanada, US = USA, LISTED 22ZA (unter diesem Eintrag sind die Prüfergebnisse einsehbar)
Produktionsbezeichnung | Die Zahlenfolge ergibt von links nach rechts die Produktionswoche (2 Ziffern), das Produktionsjahr (2 Ziffern), die Software- (2 Ziffern) sowie die Hardwareversion (2 Ziffern) und Sonderbezeichnungen (4 Ziffern). In diesem Fall handelt es sich also um einen BK2000 - produziert in der 9. Kalenderwoche - des Jahres 2001 - mit der Firmware-Version BF - in der 6. Hardwareversion - ohne Sonderbezeichnung


Literaturverzeichnis

Anhang [image] Literaturverzeichnis
Literaturverzeichnis
TCP/IP
TCP/IP (deutsch)
Aufbau und Betrieb eines TCP/IP Netzes
von Kevin Washburn, Jim Evans
Verlag: ADDISON-WESLEY Longmann Verlag
TCP/IP (englisch)
Illustrated, Volume1 The Protocols
von W. Richard Stevens
Verlag: ADDISON-WESLEY Longmann Verlag
Modbus/TCP
http://www.modicon.com/
http://www.modbus.org
TwinCAT
BECKHOFF Information System
http://infosys.beckhoff.com


Abkürzungsverzeichnis

Anhang [image] Abkürzungsverzeichnis
Abkürzungsverzeichnis
ADS
Automation Device Specification
IP (20)
Schutzart der Busklemmen
IPC
Industrie-PC
E/A
Ein- und Ausgänge
K-Bus
Klemmen-Bus
KS2000
Konfigurationssoftware für Busklemmen, Bus Koppler, Busklemmen Controller, Feldbus Box Module usw.
PE
Der PE-Powerkontakt kann als Schutzerde verwendet werden.
TwinCAT
The Windows Control and Automation Technology


Support und Service

Anhang [image] Support und Service
Support und Service
Beckhoff und seine weltweiten Partnerfirmen bieten einen umfassenden Support und Service, der eine schnelle und kompetente Unterstützung bei allen Fragen zu Beckhoff Produkten und Systemlösungen zur Verfügung stellt.
Beckhoff Support
Der Support bietet Ihnen einen umfangreichen technischen Support, der Sie nicht nur bei dem Einsatz einzelner Beckhoff Produkte, sondern auch bei weiteren umfassenden Dienstleistungen unterstützt:
▪
Support
▪
Planung, Programmierung und Inbetriebnahme komplexer Automatisierungssysteme
▪
umfangreiches Schulungsprogramm für Beckhoff Systemkomponenten
Hotline: | +49(0)5246 963 157
Fax: | +49(0)5246 963 9157
E-Mail: | support@beckhoff.com
Beckhoff Service
Das Beckhoff Service-Center unterstützt Sie rund um den After-Sales-Service:
▪
Vor-Ort-Service
▪
Reparaturservice
▪
Ersatzteilservice
▪
Hotline-Service
Hotline: | +49(0)5246 963 460
Fax: | +49(0)5246 963 479
E-Mail: | service@beckhoff.com
Weitere Support- und Serviceadressen finden Sie auf unseren Internetseiten unter http://www.beckhoff.de.
Beckhoff Firmenzentrale
Beckhoff Automation GmbH & Co. KG
Hülshorstweg 20
33415 Verl
Deutschland
Telefon: | +49(0)5246 963 0
Fax: | +49(0)5246 963 198
E-Mail: | info@beckhoff.com
Die Adressen der weltweiten Beckhoff Niederlassungen und Vertretungen entnehmen Sie bitte unseren Internetseiten:
http://www.beckhoff.de
Dort finden Sie auch weitere Dokumentationen zu Beckhoff Komponenten.