BK7150 - Bus Coupler for CC-Link
Home


Foreword

Foreword
Foreword
Additional information
•
Notes on the documentation
•
Safety instructions
•
Documentation issue status


Notes on the documentation

Foreword [image] Notes on the documentation
Notes on the documentation
Intended audience
This description is only intended for the use of trained specialists in control and automation engineering who are familiar with the applicable national standards.
It is essential that the documentation and the following notes and explanations are followed when installing and commissioning these components.
It is the duty of the technical personnel to use the documentation published at the respective time of each installation and commissioning.
The responsible staff must ensure that the application or use of the products described satisfy all the requirements for safety, including all the relevant laws, regulations, guidelines and standards.
Disclaimer
The documentation has been prepared with care. The products described are, however, constantly under development.
We reserve the right to revise and change the documentation at any time and without prior announcement.
No claims for the modification of products that have already been supplied may be made on the basis of the data, diagrams and descriptions in this documentation.
Trademarks
Beckhoff®, TwinCAT®, EtherCAT®, Safety over EtherCAT®, TwinSAFE®, XFC® and XTS® are registered trademarks of and licensed by Beckhoff Automation GmbH.
Other designations used in this publication may be trademarks whose use by third parties for their own purposes could violate the rights of the owners.
Patent Pending
The EtherCAT Technology is covered, including but not limited to the following patent applications and patents: EP1590927, EP1789857, DE102004044764, DE102007017835 with corresponding applications or registrations in various other countries.
The TwinCAT Technology is covered, including but not limited to the following patent applications and patents: EP0851348, US6167425 with corresponding applications or registrations in various other countries.
EtherCAT® is registered trademark and patented technology, licensed by Beckhoff Automation GmbH, Germany
Copyright
© Beckhoff Automation GmbH & Co. KG, Germany.
The reproduction, distribution and utilization of this document as well as the communication of its contents to others without express authorization are prohibited.
Offenders will be held liable for the payment of damages. All rights reserved in the event of the grant of a patent, utility model or design.


Safety instructions

Foreword [image] Safety instructions
Safety instructions
Safety regulations
Please note the following safety instructions and explanations!
Product-specific safety instructions can be found on following pages or in the areas mounting, wiring, commissioning etc.
Exclusion of liability
All the components are supplied in particular hardware and software configurations appropriate for the application. Modifications to hardware or software configurations other than those described in the documentation are not permitted, and nullify the liability of Beckhoff Automation GmbH & Co. KG.
Personnel qualification
This description is only intended for trained specialists in control, automation and drive engineering who are familiar with the applicable national standards.
Description of symbols
In this documentation the following symbols are used with an accompanying safety instruction or note. The safety instructions must be read carefully and followed without fail!
DANGER
Serious risk of injury!
Failure to follow the safety instructions associated with this symbol directly endangers the life and health of persons.
WARNING
Risk of injury!
Failure to follow the safety instructions associated with this symbol endangers the life and health of persons.
CAUTION
Personal injuries!
Failure to follow the safety instructions associated with this symbol can lead to injuries to persons.
Attention
Damage to the environment or devices
Failure to follow the instructions associated with this symbol can lead to damage to the environment or equipment.
Note
Tip or pointer
This symbol indicates information that contributes to better understanding.


Documentation issue status

Foreword [image] Documentation issue status
Documentation issue status
Version
Modifications
1.0.0
▪
Migration


Product overview

Product overview
Product overview
Additional information
•
The Beckhoff Bus Terminal system
•
BK7150 - Introduction
•
Technical Data


The Beckhoff Bus Terminal system

Product overview [image] The Beckhoff Bus Terminal system
The Beckhoff Bus Terminal system
Up to 256 Bus Terminals, with 1 to 16 I/O channels per signal form
The Bus Terminal system is the universal interface between a fieldbus system and the sensor / actuator level. A unit consists of a Bus Coupler as the head station, and up to 64 electronic series terminals, the last one being an end terminal. Up to 255 Bus Terminals can be connected via the K-bus extension. For each technical signal form, terminals are available with one, two, four or eight I/O channels, which can be mixed as required. All the terminal types have the same mechanical construction, so that difficulties of planning and design are minimized. The height and depth match the dimensions of compact terminal boxes.
Decentralised wiring of each I/O level
Fieldbus technology allows more compact forms of controller to be used. The I/O level does not have to be brought to the controller. The sensors and actuators can be wired decentrally, using minimum cable lengths. The controller can be installed at any location within the plant.
Industrial PCs as controllers
The use of an Industrial PC as the controller means that the operating and observing element can be implemented in the controller's hardware. The controller can therefore be located at an operating panel, in a control room, or at some similar place. The Bus Terminals form the decentralised input/output level of the controller in the control cabinet and the subsidiary terminal boxes. The power sector of the plant is also controlled over the bus system in addition to the sensor/actuator level. The Bus Terminal replaces the conventional series terminal as the wiring level in the control cabinet. The control cabinet can have smaller dimensions.
Bus Couplers for all usual bus systems
The Beckhoff Bus Terminal system unites the advantages of a bus system with the possibilities of the compact series terminal. Bus Terminals can be driven within all the usual bus systems, thus reducing the controller parts count. The Bus Terminals then behave like conventional connections for that bus system. All the performance features of the particular bus system are supported.
Mounting on standardized mounting rails
The installation is standardized thanks to the simple and space-saving mounting on a standardized mounting rail (EN 60715, 35 mm) and the direct wiring of actuators and sensors, without cross connections between the terminals. The consistent labelling scheme also contributes.
The small physical size and the great flexibility of the Bus Terminal system allow it to be used wherever a series terminal is also used. Every type of connection, such as analog, digital, serial or the direct connection of sensors can be implemented.
Modularity
The modular assembly of the terminal strip with Bus Terminals of various functions limits the number of unused channels to a maximum of one per function. The presence of two channels in one terminal is the optimum compromise of unused channels and the cost of each channel. The possibility of electrical isolation through potential feed terminals also helps to keep the number of unused channels low.
Display of the channel state
The integrated LEDs show the state of the channel at a location close to the sensors and actuators.
K-bus
The K-bus is the data path within a terminal strip. The K-bus is led through from the Bus Coupler through all the terminals via six contacts on the terminals' side walls. The end terminal terminates the K-bus. The user does not have to learn anything about the function of the K-bus or about the internal workings of the terminals and the Bus Coupler. Many software tools that can be supplied make project planning, configuration and operation easy.
Potential feed terminals for isolated groups
The operating voltage is passed on to following terminals via three power contacts. You can divide the terminal strip into arbitrary isolated groups by means of potential feed terminals. The potential feed terminals play no part in the control of the terminals, and can be inserted at any locations within the terminal strip.
Up to 64 Bus Terminals can be used in a terminal block, with optional K-bus extension for up to 256 Bus Terminals. This count does include potential feed terminals, but not the end terminal.
Bus Couplers for various fieldbus systems
Various Bus Couplers can be used to couple the electronic terminal strip quickly and easily to different fieldbus systems. It is also possible to convert to another fieldbus system at a later time. The Bus Coupler performs all the monitoring and control tasks that are necessary for operation of the connected Bus Terminals. The operation and configuration of the Bus Terminals is carried out exclusively by the Bus Coupler. Nevertheless, the parameters that have been set are stored in each Bus Terminal, and are retained in the event of voltage drop-out. Fieldbus, K-bus and I/O level are electrically isolated.
If the exchange of data over the fieldbus is prone to errors or fails for a period of time, register contents (such as counter states) are retained, digital outputs are cleared, and analog outputs take a value that can be configured for each output when commissioning. The default setting for analog outputs is 0 V or 0 mA. Digital outputs return in the inactive state. The timeout periods for the Bus Couplers correspond to the usual settings for the fieldbus system. When converting to a different bus system it is necessary to bear in mind the need to change the timeout periods if the bus cycle time is longer.
The interfaces
A Bus Coupler has six different methods of connection. These interfaces are designed as plug connectors and as spring-loaded terminals.


BK7150 - Introduction

Product overview [image] BK7150 - Introduction
BK7150 - Introduction
BK7150
Bus Coupler with CC-Link Slave Interface
The “Compact” Bus Couplers BK7150 connects the CC-Link system to the electronic terminal blocks, which can be extended in modular fashion. One unit consists of the Bus Coupler, any number of up to 64 terminals and one end terminal. The K-bus extension technology allows for the connection to one Bus Coupler of up to 255 Bus Terminal spatially distributed.
The Bus Coupler recognizes the connected terminals and automatically generates the affiliations of the inputs/outputs to the bytes of the process image. The first input/output signal is inserted in the first bit of one byte (LSB), beginning from the left. The Bus Coupler inserts further signals in this byte. Inputs and outputs are clearly separated. The Bus Coupler automatically begins a further byte if the number of controller inputs or outputs exceeds 8 bits.
CC-Link is an open fieldbus system. Baud rates up to 10 Mbaud can be selected via a switch, so that the transfer speed can be adapted to the requirement of the technical process.
Complex signal processing for analog I /Os, position measurement, …
The BK7150 Bus Coupler supports the operation of all Bus Terminals. As far as the user is concerned, handling of the analog inputs/outputs is no different to other series. The information is available in the process image of the controller for processing in the form of a byte-array.
The analog and multi-functional Bus Terminals can be adapted to each specific application using the KS2000 configuration set. Depending on the type, the analog Bus Terminals registers contain temperature ranges, gain values and linearization characteristics. Using the KS2000 software, the required parameters can be set on a PC. The Bus Terminal stores settings permanently and in a fail safe manner.
Optionally, the Bus Terminals can also be controlled by the control system. Via function blocks (FBs), the Programmable Logic Controller (PLC) or the Industrial PC (IPC) handles configuration of the complete periphery during the start up phase. If required, the controller can upload the decentrally created configuration data in order to centrally manage and store this data. Therefore, new adjustments are not necessary in the event of replacement of a Bus Terminal. The controller carries out the desired setting automatically after switching on.


Technical Data

Product overview [image] Technical Data
Technical Data
System data | CC-Link | BK7150
Number of I/O modules | 64
Number of I/O points | Depending on controller
Data transfer medium | Shielded 3-core, twisted pair cable
CC-Link Version | 1.1
Cable-length | 1200 m | 900 m | 400 m | 160 m | 100 m
Data transfer rate | 156 kbaud | 625 kbaud | 2.5 Mbaud | 5 Mbaud | 10 Mbaud
Technical data | BK7150
Number of Bus Terminals | 64 (255 with K-bus extension)
Max. number of bytes fieldbus | 32 bytes input and 32 bytes output
Digital peripheral signals | 112 inputs/outputs
Analog peripheral signals | 16 inputs/outputs
Baud rates | 156 kbaud … 10 Mbaud
Configuration possibility | Via KS2000 software
Bus Connection | 1 x open style connector, 5-pin, included
Power Supply | 24 VDC (-15%/+20%)
Input current | 70 mA + (total K-bus current)/4, 500 mA max.
Starting current | 2.5 x continuous current
Recommended fuse | ≤ 10 A
K-bus power supply up to | 1000 mA
Power contact voltage | 24 VDC max.
Power contact current load | 10 A max.
Dielectric strength | 500 V (power contact/supply voltage/fieldbus)
Weight approx. | 100 g
Operating temperature | 0°C ... +55°C
Storage temperature | -25°C ... +85°C
Relative humidity | 95%, no condensation
Vibration/shock resistance | conforms to EN 60068-2-6/EN 60068-2-27/29
EMC resistance burst/ESD | conforms to EN 61000-6-2/EN 61000-6-4
Protect. class/installation pos. | IP 20/variable
Ordering information | Description
BK7150 | CC-Link “Compact” Bus Coupler for up to 64 Bus Terminals (255 with K-bus extension)


Mounting and wiring

Mounting and wiring
Mounting and wiring
Additional information
•
Assembly
•
Wiring


Assembly

Mounting and wiring [image] Assembly
Assembly
Additional information
•
Dimensions
•
Installation
•
Installation on mounting rails


Dimensions

Mounting and wiring [image] Assembly [image] Dimensions
Dimensions
The system of the Beckhoff Bus Terminals is characterized by low physical volume and high modularity. When planning a project it must be assumed that at least one Bus Coupler and a number of Bus Terminals will be used. The mechanical dimensions of the Bus Couplers are independent of the fieldbus system.
BK7150 - Dimensions
The total width in practical cases is composed of the width of the Bus Coupler, the KL9010 Bus End Terminal and the width of the bus terminals in use. Depending on function, the Bus Terminals are 12 or 24 mm wide. The front wiring increases the total height of 68 mm by about 5 to 10 mm, depending on the wire thickness.
Mechanical data | BK7150
Design form | compact terminal housing with signal LED
Material | Polyamide (PA 6.6)
Dimensions (W x H x D) | 44 x 100 x 68 mm
Mounting | on 35 mm C-rail in accordance with EN 60715 with latching
Stackable by | Double groove-tongue connection
Labelling | Standard terminal block labelling
Vibration/shock resistance | conforms to EN 60068-2-6 / EN 60068-2-27
EMC immunity/emission | conforms to EN 61000-6-2 / EN 61000-6-4
Connection technology | BK7150
Wiring | Cage Clamp® spring-loaded system
Connection cross-section | 0.08 mm² ... 2.5 mm², stranded, solid wire, 28 … 14 AWG
Fieldbus connection | CC-Link open style connector
Power contacts | 3 spring contacts
Current loading IMAXX | 10 A (125 A short circuit)
Rated voltage | 24 VDC


Installation

Mounting and wiring [image] Assembly [image] Installation
Installation
The Bus Coupler and all the Bus Terminals can be clipped, with a light press, onto a 35 mm mounting rail. A locking mechanism prevents the individual housings from being pulled off again. For removal from the mounting rail the orange colored tension strap releases the latching mechanism, allowing the housing to be pulled off the rail without any force.
Release the locking mechanism by pulling the orange tab
Up to 64 Bus Terminals can be attached to the Bus Coupler on the right hand side. When plugging the components together, be sure to assemble the housings with groove and tongue against each other. A properly working connection cannot be made by pushing the housings together on the mounting rail. When correctly assembled, no significant gap can be seen between the attached housings.
Power contact on the left
Attention
Bus Terminals should only be pulled or plugged in switched-off state.
Insertion and removal of Bus Terminals is only permitted when switched off. The electronics in the Bus Terminals and in the Bus Coupler are protected to a large measure against damage, but incorrect function and damage cannot be ruled out if they are plugged in under power.
The right hand part of the Bus Coupler can be compared to a Bus Terminal. Eight connections at the top enable the connection with solid or fine wires from 0.08 mm² to 2.5 mm². The connection is implemented with the aid of a spring device. The spring-loaded terminal is opened with a screwdriver or rod, by exerting gentle pressure in the opening above the terminal. The wire can be inserted into the terminal without any force. The terminal closes automatically when the pressure is released, holding the wire safely and permanently.


Installation on mounting rails

Mounting and wiring [image] Assembly [image] Installation on mounting rails
Installation on mounting rails
WARNING
Risk of injury through electric shock and damage to the device!
Bring the Bus Terminals system into a safe, de-energized state before starting mounting, disassembly or wiring of the Bus Terminals.
Mounting
The Bus Couplers and Bus Terminals are attached to commercially available 35 mm mounting rails (DIN rail according to EN 60715) by applying slight pressure:
1.
First attach the Fieldbus Coupler to the mounting rail.
2.
The Bus Terminals are now attached on the right-hand side of the fieldbus Coupler. Join the components with slot and key and push the terminals against the mounting rail, until the lock clicks onto the mounting rail.
If the terminals are clipped onto the mounting rail first and then pushed together without slot and key, the connection will not be operational! When correctly assembled, no significant gap should be visible between the housings.
During the installation of the Bus Terminals, the locking mechanism of the terminals must not come into conflict with the fixing bolts of the mounting rail.
Removal
Each terminal is secured by a lock on the mounting rail, which must be released for disassembly:
1.
Carefully pull the orange-colored lug approximately 1 cm out of the terminal to be disassembled, until it protrudes loosely. The lock with the mounting rail is now released for this terminal, and the terminal can be pulled from the mounting rail without excessive force.
2.
Grasp the released terminal with thumb and index finger simultaneous at the upper and lower grooved housing surfaces and pull the terminal away from the mounting rail.
Connections within a Bus Terminal block
The electric connections between the Bus Coupler and the Bus Terminals are automatically realized by joining the components:
▪
The six spring contacts of the K-Bus/E-Bus deal with the transfer of the data and the supply of the Bus Terminal electronics.
▪
The power contacts deal with the supply for the field electronics and thus represent a supply rail within the Bus Terminal block. The power contacts are supplied via terminals on the Bus Coupler.
Note
Power contacts
During the design of a Bus Terminal block, the pin assignment of the individual Bus Terminals must be taken account of, since some types (e.g. analog Bus Terminals or digital 4-channel Bus Terminals) do not or not fully loop through the power contacts. Power Feed Terminals (KL91xx, KL92xx and EL91xx, EL92xx) interrupt the power contacts and thus represent the start of a new supply rail.
PE power contact
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Attention
Risk of damage to the device
Note that, for reasons of electromagnetic compatibility, the PE contacts are capacitatively coupled to the mounting rail. This may lead to incorrect results during insulation testing or to damage on the terminal (e.g. disruptive discharge to the PE line during insulation testing of a consumer with a rated voltage of 230 V). For insulation testing, disconnect the PE supply line at the Bus Coupler or the Power Feed Terminal! In order to decouple further feed points for testing, these Power Feed Terminals can be released and pulled at least 10 mm from the group of terminals.
The PE power contact must not be used for other potentials!
Wiring
Up to eight connections enable the connection of solid or finely stranded cables to the Bus Terminals. The terminals are implemented in spring force technology. Connect the cables as follows:
1.
Open a spring-loaded terminal by slightly pushing with a screwdriver or a rod into the square opening above the terminal.
2.
The wire can now be inserted into the round terminal opening without any force.
3.
The terminal closes automatically when the pressure is released, holding the wire safely and permanently.
Note
Shielding
Analog sensors and actuators should always be connected with shielded, pair-wise twisted cables.


Wiring

Mounting and wiring [image] Wiring
Wiring
Additional information
•
Potential groups, insulation testing and PE
•
CC-Link
•
Power supply


Potential groups, insulation testing and PE

Mounting and wiring [image] Wiring [image] Potential groups, insulation testing and PE
Potential groups, insulation testing and PE
Potential groups
A Beckhoff Bus Terminal block usually has three different potential groups:
▪
The fieldbus interface is electrically isolated (except for individual Low Cost couplers) and forms the first potential group.
▪
Bus Coupler / Bus Terminal Controller logic, K-bus and terminal logic form a second electrically isolated potential group.
▪
The inputs and outputs are supplied via the power contacts and form further potential groups.
Groups of I/O terminals can be consolidated to further potential groups via potential supply terminals or separation terminals.
Potential groups of a Bus Terminal block
Insulation testing
The connection between Bus Coupler / Bus Terminal Controller and Bus Terminals is realized automatically by latching the components. The transfer of the data and the supply voltage for the intelligent electronics in the Bus Terminals is performed by the K-bus. The supply of the field electronics is performed through the power contacts. Plugging together the power contacts creates a supply rail. Since some Bus Terminals (e.g. analog Bus Terminals or 4-channel digital Bus Terminals) are not looped through these power contacts or not completely the Bus Terminal contact assignments must be considered.
The potential feed terminals interrupt the power contacts, and represent the start of a new supply rail. The Bus Coupler / Bus Terminal Controller can also be used for supplying the power contacts.
PE power contacts
The power contact labelled PE can be used as a protective earth. For safety reasons this contact mates first when plugging together, and can ground short-circuit currents of up to 125 A.
Power contact on the left
It should be noted that, for reasons of electromagnetic compatibility, the PE contacts are capacitively coupled to the mounting rail. This can both lead to misleading results and to damaging the terminal during insulation testing (e.g. breakdown of the insulation from a 230 V power consuming device to the PE conductor). The PE supply line at the Bus Coupler / Bus Terminal Controller must be disconnected for an insulation test. In order to uncouple further feed locations for the purposes of testing, the feed terminals can be pulled at least 10 mm out from the connected group of other terminals. In that case, the PE conductors do not have to be disconnected.
The power contact with the label PE must not be used for other potentials.


CC-Link

Mounting and wiring [image] Wiring [image] CC-Link
CC-Link
CC-Link-Anschluss
CC-Link wiring
Use a resistor (R = 110 Ω) to terminate open ends.


Power supply

Mounting and wiring [image] Wiring [image] Power supply
Power supply
Supply of Bus Coupler / Bus Terminal Controller and Bus Terminals (Us)
Additional information
•
BKxx50 and BKxx51
•
Configuration and Programming Interface
•
Electrical isolation
•
Power contacts


BKxx50 and BKxx51

Mounting and wiring [image] Wiring [image] Power supply [image] BKxx50 and BKxx51
BKxx50 and BKxx51
The Bus Couplers / Bus Terminal Controllers require an operating voltage of 24 VDC. Use a 4 A fuse or a Class 2 power supply to comply with the UL requirements.
The connection is made by means of the upper spring-loaded terminals labelled Us and GNDs. This supply voltage is used for the electronic components of the Bus Coupler and Bus Terminal Controllers and (via the K-bus) the electronic components of the Bus Terminals. It is galvanically separated from the field level voltage.
Power supply connections for BKxx50 and BKxx51
UL identification
DANGER
Note the UL requirements for the power supply.
To comply with the UL requirements, the 24 VDC supply voltage for Us must originate
•
from an isolated source protected by a fuse of max. 4A (according to UL248) or
•
from a voltage supply complying with NEC class 2.
An NEC class 2 voltage source must not be connected in series or parallel with another NEC class 2 voltage source!
DANGER
No unlimited voltage sources!
To comply with the UL requirements, Us must not be connected with unlimited voltage sources.


Configuration and Programming Interface

Mounting and wiring [image] Wiring [image] Power supply [image] Configuration and Programming Interface
Configuration and Programming Interface
The standard Bus Couplers have an RS232 interface at the bottom of the front face. The miniature plug connector can be connected to a PC using a connecting cable and the KS2000 configuration software. The interface permits the Bus Terminals to be configured, for example adjusting the amplification factors of the analog channels. The interface can also be used to change the assignments of the bus terminal data to the process image in the Bus Coupler. The functionality of the configuration interface can also be reached via the fieldbus using string communication facility.


Electrical isolation

Mounting and wiring [image] Wiring [image] Power supply [image] Electrical isolation
Electrical isolation
The Bus Couplers / Bus Terminal Controllers operate with three independent potential groups. The supply voltage feeds the K-bus electronics and the K-bus itself. The supply voltage is also used to generate the operating voltage for the fieldbus interface.
Note: All the Bus Terminals are electrically isolated from the K-bus. The K-bus is thus electrically isolated from everything else.
Potential connection diagram of an EKxxxx


Power contacts

Mounting and wiring [image] Wiring [image] Power supply [image] Power contacts
Power contacts
Power contacts supply (Up)
The bottom six connections with spring-loaded terminals can be used to feed the supply for the peripherals. The spring-loaded terminals are joined in pairs to a power contact. The power supply for the power contacts has no connection to the power supply for the Bus Couplers / Bus Terminal Controllers.
The spring-loaded terminals are designed for wires with cross-sections between 0.08 mm² and 2.5 mm².
The assignment in pairs and the electrical connection between feed terminal contacts allows the connection wires to be looped through to various terminal points. The current load from the power contact must not exceed 10 A for long periods. The current carrying capacity between two spring-loaded terminals is identical to that of the connecting wires.
Power contacts
Three spring contacts of the power contact connections can be found on the right of the Bus Coupler / Bus Terminal Controller. The spring contacts are hidden in slots so that they cannot be accidentally touched. By attaching a Bus Terminal the blade contacts on the left hand side of the Bus Terminal are connected to the spring contacts. The tongue & groove design of the top and bottom of the Bus Coupler / Bus Terminal Controller and Bus Terminals enables secure fitting of the power contacts.


First Steps

First Steps
First Steps
Address-Switch
S3 for Baudrate
0 – 156 kBaud
1 – 625 kBaud
2 – 2,5 MBaud
3 – 5 MBaud
4 – 10 MBaud
5 – 9 no function (reserve)
S1 address x 1
S2 address x 10
Example:
S3 = 2
S1 = 4
S2 = 1
Baudrate = 2,5 MBaud, address = 14
Addressing I/Os from the K-Bus interface:
The coupler has an automatic mapping. The coupler reads the terminals and configures the CC-Link interface. The coupler has four different CC-Link mappings.
16 DI/16 DO and/or 4 channel in/out (8 Byte in/out)
48 DI/48 DO and/or 8 channel in/out (16 Byte in/out)
80 DI/80 DO and/or 12 channel in/out (24 Byte in/out)
112 DI/112 DO and/or 16 channel in/out (32 Byte in/out)
On start up, the BK7150 reads the terminals and configures the CC-link interface. The I/O error LED the coupler shows which mapping is active.
I/O Error LED is flashing once, the mapping 1 is active.
I/O Error LED is flashing twice, the mapping 2 is active.
I/O Error LED is flashing three times, the mapping 3 is active.
I/O Error LED is flashing fore times, the mapping 4 is active.
Mapping digital I/Os:
RX/RY | Number of occupied stations
Mapping | 1 | 2 | 3 | 4
00-0F | DI/DO | DI/DO | DI/DO | DI/DO
01-1F | Status/Control | DI/DO | DI/DO | DI/DO
02-2F | - | DI/DO | DI/DO | DI/DO
03-3F | - | Status/Control | DI/DO | DI/DO
04-4F | - | - | DI/DO | DI/DO
05-5F | - | - | Status/Control | DI/DO
06-6F | - | - | - | DI/DO
07-7F | - | - | - | Status/Control
Sum | 16 DI/16 DO | 48 DI/48 DO | 80 DI/80 DO | 112 DI/122 DO
Status RX |
xxB | Station Ready
xxA | K-Bus Error
Control RY |
xxA | Reset K-Bus
Mapping analoge I/Os:
RWr/RWw | Number of occupied stations
Mapping | 1 | 2 | 3 | 4
x00-x03 | AI/AO | AI/AO | AI/AO | AI/AO
x04-x07 | - | AI/AO | AI/AO | AI/AO
x08-x11 | - | - | AI/AO | AI/AO
X12-x15 | - | - | - | AI/AO
Sum | 4 AI/4 AO 8 byte in/out | 8 AI/8 AO 16 byte In/out | 12 AI/12 AO 24 byte in/out | 16 AI/16 AO 32 byte in/out
Example 1:
BK7150
2 x KL1xx4
2 x KL2xx4
1 x KL9010
8 DI / 8 DO
Mapping 1
Example 2:
BK7150
4 x KL1xx8
2 x KL2xx4
1 x KL9010
32 DI / 8 DO
Mapping 2
Example 3:
BK7150
4 x KL1xx8
4 x KL2xx8
2 x KL3xx2
1 x KL9010
32 DI / 32 DO / 4 AI
Mapping 2
Example 4:
BK7150
4 x KL1xx8
4 x KL2xx8
2 x KL3xx2
2 x KL4xx2
1 x KL9010
32 DI / 32 DO / 4 AI / 4 AO
Mapping 2
Configure with GX IEC Developer
Example 1:
BK7150 Node 1
2 x KL1xx4 X100...X10F
2 x KL2xx4 Y100...Y10F
1 x KL9010
8 DI / 8 DO
Mapping 1
Typ: Master-Station
Modus: Remote Network (Ver. 1-Modus)
Remote-Input (RX) X100
Remote-Output (RY) Y100
Station Typ: Remote device station, Exclusive station 1, 32 points
Example 4:
BK7150 Node 1
4 x KL1xx8 X100...X13F
4 x KL2xx8 Y100...Y13F
2 x KL3xx2 D100…D103
2 x KL4xx2 D200…D203
1 x KL9010
32 DI / 32 DO / 4 AI / 4 AO
Mapping 2
Remote-Input (RX) X100
Remote-Output (RY) Y100
Remote Register (RWr) D100
Remote Register (RWw) D200
Station Typ: Remote device station, Exclusive station 2, 64 points


Appendix

Appendix
Appendix
Additional information
•
Support and Service


Support and Service

Appendix [image] Support and Service
Support and Service
Beckhoff and their partners around the world offer comprehensive support and service, making available fast and competent assistance with all questions related to Beckhoff products and system solutions.
Beckhoff's branch offices and representatives
Please contact your Beckhoff branch office or representative for local support and service on Beckhoff products!
The addresses of Beckhoff's branch offices and representatives round the world can be found on her internet pages:
http://www.beckhoff.com
You will also find further documentation for Beckhoff components there.
Beckhoff Headquarters
Beckhoff Automation GmbH & Co. KG
Huelshorstweg 20
33415 Verl
Germany
Phone: | +49(0)5246/963-0
Fax: | +49(0)5246/963-198
e-mail: | info@beckhoff.com
Beckhoff Support
Support offers you comprehensive technical assistance, helping you not only with the application of individual Beckhoff products, but also with other, wide-ranging services:
▪
support
▪
design, programming and commissioning of complex automation systems
▪
and extensive training program for Beckhoff system components
Hotline: | +49(0)5246/963-157
Fax: | +49(0)5246/963-9157
e-mail: | support@beckhoff.com
Beckhoff Service
The Beckhoff Service Center supports you in all matters of after-sales service:
▪
on-site service
▪
repair service
▪
spare parts service
▪
hotline service
Hotline: | +49(0)5246/963-460
Fax: | +49(0)5246/963-479
e-mail: | service@beckhoff.com